문제
Cisco Secure Client - Umbrella SWG Agent 서비스가 Windows Dell 노트북에서 실행 중인 경우 사용자는 어떤 웹 사이트에도 액세스할 수 없습니다. Umbrella SWG Agent 서비스가 중지되면 일반 웹 액세스가 복원됩니다. 이 문제는 AnyConnect VPN 및 Umbrella 모듈을 모두 포함하는 Cisco Secure Client 버전 5.1.14.145에서 발생합니다. OrgInfo.json 파일이 예상 디렉터리에 있으며 Cisco Secure Access 루트 CA 인증서가 신뢰할 수 있는 루트 인증서 저장소에 설치되어 있습니다.
환경
- 제품: Cisco Secure Client(AnyConnect VPN 및 Umbrella 모듈)
- 소프트웨어 버전: 5.1.14.145
- 운영 체제: Windows(Dell 노트북)
- Umbrella SWG Agent 서비스 사용/사용 안 함
- %ProgramData%\
Cisco\Cisco Secure Client\Umbrella\OrgInfo.json에 있는 OrgInfo.json
- 신뢰할 수 있는 루트 인증 기관 저장소에 설치된 Cisco Secure Access 루트 CA
- Secure Access 대시보드에서 활성화된 DNS/웹 보안
- 암호 해독이 활성화된 할당된 보안 프로필
해결
클라이언트 장치에서 NTP(Network Time Protocol) 동기화 실패를 식별 및 수정하여 문제를 해결했습니다. 시간 동기화를 할 수 없어 웹 트래픽을 프록시하기 위해 Umbrella SWG Agent에서 필요로 하는 보안 통신을 할 수 없으므로 TCP 재설정(RST) 패킷과 웹 액세스 손실이 발생했습니다. NTP 동기화가 복원되면 SWG Agent가 활성화된 상태에서 웹 액세스가 정상적으로 작동했습니다.
이 포괄적인 문제 해결 워크플로를 따릅니다.
1단계: 구성 및 사전 요구 사항 확인
- OrgInfo
.json이 %ProgramData%\Cisco\Cisco Secure Client\Umbrella\OrgInfo.json에 있는지 확인하십시오. - Cisco Secure Access Root CA가 신뢰할 수 있는 루트 인증 기관 저장소에 있는지 확인합니다.
- Secure Access 대시보드에서 DNS/Web Security가 활성화되어 있는지 확인합니다.
- 할당된 보안 프로필에 암호 해독이 활성화되어 있는지 확인합니다.
2단계: 네트워크 트래픽 캡처 및 분석
예기치 않은 TCP 재설정 패킷과 같은 비정상적인 동작을 식별하기 위해 SWG 프록시로 전달되는 클라이언트 트래픽의 패킷 캡처를 가져옵니다.
문제를 표시하는 패킷 캡처에 대한 설명:
The packet capture revealed that TCP reset (RST) packets were being sent to the client, disrupting the connection to the SWG proxy.
4단계: 경계 방화벽 규칙 검증
- 경계 방화벽 규칙을 검사하여 인그레스 인터페이스에서 SWG 서버와의 트래픽이 허용되는지 확인합니다.
5단계: 시스템 및 프로토콜 진단 실행
클라이언트에서 이 명령을 실행하여 NTP 동기화 오류를 확인합니다.
curl ipinfo.io
진단 결과에 대한 설명:
The output indicated NTP timing was out of sync on the client device.
원인
근본 원인은 클라이언트 디바이스에서 NTP(Network Time Protocol) 동기화의 실패입니다. 이 타이밍 문제로 인해 클라이언트와 Umbrella SWG 프록시 서비스 간의 보안 통신이 불가능하여 TCP 재설정 패킷이 발생하고 SWG 에이전트 서비스가 활성 상태일 때 웹 액세스가 손실되었습니다. NTP 동기화 문제를 해결하여 Umbrella SWG 에이전트의 올바른 작동을 복원함으로써 웹 트래픽을 안전하게 프록시할 수 있습니다.
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