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Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

Cancel Save
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Add Cert Enrolilment

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN:

Include Device's IP Address:
Common Mame (CN):
Organization Unit (OU):
Organization (O):

Locality (L):

State (ST):

Country Code (C):

Email (E)

Use Device Hostname as FODN

10.88.243.123

vpntestbed.cisco.com

TAC

Mexico

MX

CDMX

MX

: I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save
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Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device*:
| FTD v|

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com
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b) RADIUS AHH 4

O| & Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.
O|ES U3t 2 S &M IP TAE F7}524{M save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7 |
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

Accounting Port: (1-65535)
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- O™ .2 S50 M7t EA|IELICH

RadiusServer
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o|E Objects > Object Management > Address Pools > Add IPv4 Pools.

Ol HRIE

Name*

21245

tH ObAZ 7 HR K|

OF A
Ls H

LICE.

I vpn_pool

IPv4 Address Range*

‘ 10.72.1.1-10.72.1.150

Mask

‘ Specify a netmask in X.X.X.X format

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across

multiple devices

»  Override (0)

d) XML Z2E gHE 7|
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File Help
4 -
L VPN | Server List
{% preferences (Part 1) Profile: C:\Users\calo\Documents\Anyconnect_profile.xml
----- = Preferences (Part 2) -
----- % Backup Servers
.... g Certificate Pinning Maobile Settings Certificate Pins

=0 Certificate Matching
----- Certificate Enrollment
{23y Mobile Policy

----- Server List

Hostname
VPM(S5L)
VPM(IPSEC)

Host Address

User Group

vpntestbed.dsco....
vpntestbed.cisco....

Backup Server List  SCEP
-- Inherited --
- Inherited --

Mote: it is highly recommended that at least one server be defined in a profile.

. %él OK,—<I File > Save as...

Add...

Delete

Details




e) AnyConnect O|0|X| 2=
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. O|% Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.
- O|§2 35t 1 C|AT M PKG It UE MEAR CH S save:

Edit AnyConnect File (7]

Mame:*

I Wnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

| Cancel |
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. 0|% Devices > VPN > Remote Access > Add a new configuration.
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Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

.48 T2l EHAI0AM CFHS S U=IELICH connection Profile Name= AMEHSFL|C}. Authentication

Server ELJ Address Pools El'% -)F 9&'% |—| |‘



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

- 22! Edit Group Policy AnyConnect B{0{| A client ProfileE 2 28t CHS save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

. C}2 0| X|0 A AnyConnect O|0|X|E AMEHSEI T Next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

. C}= 32404 A Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

- 2E &=0| SHIEA 78 EI™ Finish 2|10 peploy:



P A |

Remote
User

AnyConnect

‘ Ou tside

Client

Remote Access VPN Policy Configuration

Firepower Management Center will configure an RA VPN Policy with the following settings

Name:

Device Targets:

Connection Profile:
Connection Alias:
AAA:

Authentication Method:

Authentication Server:
Authorization Server:
Accounting Server;
Address Assignment:
Address from AAA:
DHCP Servers:
Address Pools (IPvd):
Address Pools (IPv6):
Group Policy:
AnyConnect Images:
Interface Objects:

Device Certificates:

Anyconnect_RA
FTD
Anyconnect_RA

Anyconnect_RA

AAA Only
RadiusServer (RADIUS)

RadiusServer (RADIUS)

vpn_pool
DMGrpPolicy
Anyconnectmac4.10
Qutsied

vpntestbed.cisco.com

Device Identity Certificate Enrollment

Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.
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Additional Configuration Requirements

After the wizard completes, the following
configuration needs to be completed for VPN to
work on all device targets.

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

@ Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.

A Network Interface Configuration

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’
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Add Static Route Configuration 7

Type: @ IPvd () IPV6
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local
IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

. CI22 &, VPN ¢4Z20| B El= QIE{H0|A0M uRPFE &35 ELICE Ol &= & opiH
EP%QE 0|%§." |—| L_-|'. Devices > Device Management > Edit > Interfaces > Edit > Advanced > Security

Configuration > Enable Anti Spoofing.



Edit Physical Interface L]

General IPwd IPv6 Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

‘ Cancel |m
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b) ﬂ' é§§} _’_Eysopt connection permit-vpn %Ad

- T 6.2.3 0| 0] U= B2 OrEHALLE oteliof O|E +&E & = SM0| UELICH pevices >

VPN > Remote Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
Decrypted traffic is subjected to Access Control Policy by default. This option
bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from

AAA server are still applied to VPN traffic.

. 6.2.3 0| BT 2| B2 objects > Object Management > FlexConfig > Text Object > Add Text Object.
. HIAE x| HSE MAEHLICHO0dl: vpnSysVar 240 e B &5). sysopt.

. Ol% Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.

- Create(2d) Flexconfig object with CLI(CLIZ} 4= ZHAI) connection permit-vpn.

. BIAE JHA| B4 E Flexconfig CLIOIA] $vpnSysvar connection permit-vpn. 2 2| save:


/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Variable Name: | wpnSysvar
Description:

Available Objects €

Selected Object
[& search

[0 vonsysvar

e ——
[ tepMssBytes

[T tepMssMinimum

[T threat_cetection_statistics

[T vadan_wve_only

[T vdtan_Port_and_Nve
[T wtan_wni

[T weepPassword

- M FlexconfigZiX| Append +F S MEHSH0A Everytime:

Edit FlexConfig Object

Name: | connection_permit-vpn
Description:
@ Insert + | |

Deployment: Type: Append ¥

Variables

vpnSysvar SINGLE sysopt FREEFORM:vpn.. false

[ Save J [ Cancel J

. O|SDevices > FlexConfig $1KH 234

A S %451 7L} New Policy HE S 2 218FLICT
. Ol =0t

£=3
= =
o= _7:<_7|. FlexConfig, %E—! Save.
. Z2H|XMEE T38| 0l TS sysopt connection permitvpn DS Al EHL|CH
—
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