MTU(Maximum Transmission Unit)는 인터페이스가 프래그먼트화할 필요 없이 전송할 수 있는 패킷의 최대 크기를 정의합니다. MTU보다 큰 IP 패킷은 IP 프래그먼트화 절차를 거쳐야 합니다.
Cisco ATM 라우터 인터페이스는 64~17966바이트 사이의 MTU를 지원합니다. 각 인터페이스는 기본 최대 패킷 크기를 지원합니다. 예를 들어, ATM 인터페이스 프로세서(AIP) 및 네트워크 프로세서 모듈(NP)에서 최대값은 9288바이트이며, PA-A3 및 PA-A2 포트 어댑터에서 4470바이트입니다.
이 문서에서는 ATM 인터페이스에 대한 기본 MTU 값을 검토하고 라우터가 AAL5 Oversized SDU 및 AAL5 길이 위반 카운터를 늘릴 때를 설명합니다.
이 문서에 대한 특정 요건이 없습니다.
이 문서는 특정 소프트웨어 및 하드웨어 버전으로 한정되지 않습니다.
문서 규칙에 대한 자세한 내용은 Cisco 기술 팁 표기 규칙을 참조하십시오.
대부분의 Cisco ATM 라우터 인터페이스는 기본 MTU 크기인 4470바이트를 사용합니다. 이 번호는 자동 스위칭을 위해 FDDI(Fibre Distributed Data Interface) 및 HSSI(High-Speed Serial Interface) 인터페이스와 정확히 일치하도록 선택되었습니다.
기본이 아닌 값을 구성하려면 인터페이스 컨피그레이션 모드에서 mtu 명령을 사용합니다. 주 인터페이스의 값이 최대 하위 인터페이스 MTU보다 크거나 같은 경우 하위 인터페이스는 주 인터페이스와 다른 값을 지원합니다.
7200#show interface atm 3/0
ATM3/0 is up, line protocol is up
Hardware is ENHANCED ATM PA
Internet address is 1.1.1.1/8
MTU 4470 bytes, sub MTU 1500, BW 149760 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
현재 구성된 값을 보려면 show atm interface atm 명령을 사용합니다.
7200#show atm interface atm 3/0 Interface ATM3/0: AAL enabled: AAL5 , Maximum VCs: 4096, Current VCCs: 2 Maximum Transmit Channels: 0 Max. Datagram Size: 4528 PLIM Type: SONET - 155000Kbps, TX clocking: LINE Cell-payload scrambling: ON sts-stream scrambling: ON 8359 input, 8495 output, 0 IN fast, 0 OUT fast, 0 out drop Avail bw = 155000 Config. is ACTIVE
show interface atm 명령은 굵게 강조 표시되어 있으며 패킷 크기에 대한 논의와 관련된 두 카운터를 보고합니다.
7200#show interface atm1/ima0
ATM1/IMA0.1 is up, line protocol is up
Hardware is ATM IMA
MTU 4470 bytes, BW 6000 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 2/255
Encapsulation ATM
1382 packets input, 399282 bytes
1558 packets output,205883 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 280
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 210285
AAL5 CPI Error : 302
두 카운터 모두 ATM 적응 계층 5(AAL5)를 참조합니다. ATM 스택의 CPCS(Common Part Convergence Sublayer)에서 라우팅 또는 브리지된 PDU(Protocol Data Unit)를 캡슐화합니다. RFC 1483
은 이 다이어그램에 표시된 대로 AAL5 트레일러의 형식을 정의합니다.
AAL5 트레일러의 2바이트 길이 필드는 CPCS-PDU 페이로드 필드의 크기를 나타낸다. 2바이트는 16비트 또는 최대 길이 값인 65,535(216) 옥텟입니다.
MTU는 레이어 3 데이터그램의 크기를 정의합니다. AAL5 SDU(Service Data Unit)는 레이어 3 데이터그램과 선택적인 LLC/SNAP(Logical Link Control/Subnetwork Access Protocol) 헤더로 정의됩니다. AAL5 PDU는 결합된 AAL5 SDU에 8바이트 AAL5 트레일러를 더한 것으로서 정의된다. 따라서 MTU 9180은 8바이트 AAL5 트레일러로 9180바이트의 AAL5 SDU와 9188바이트의 AAL5 PDU를 생성할 수 있습니다.
ATM 인터페이스에서 MTU보다 큰 패킷을 수신하면 라우터는 Oversized SDUs 카운터를 늘립니다. Oversize SDUs 카운터는 RFC 1695에 정의되어
있습니다.
aal5VccOverSizedSDUs OBJECT-TYPE
SYNTAX Counter32
MAX-ACCESS read-only
STATUS current
DESCRIPTION
"The number of AAL5 CPCS PDUs discarded
on this AAL5 VCC at the interface
associated with an AAL5 entity because the
AAL5 SDUs were too large."
::= { aal5VccEntry 5 }
RFC 1695는 또한 다음과 같은 개체 ID를 사용하여 별도의 전송 및 수신 SDU 크기를 설정하는 기능을 지원합니다.
atmVccAal5CpcsTransmitSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the transmit direction of this VCC."
DEFVAL { 9188 }
:= { atmVclEntry 9 }
atmVccAal5CpcsReceiveSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the receive direction of this VCC."
DEFVAL { 9188 }
::= { atmVclEntry 10 }
RFC 1695를 따르는 ATM 인터페이스에서는 오버사이즈 SDU 오류를 탐지할 때 ifInErrors 카운터를 증가시킵니다. 이는 RFC에 정의된 두 개의 카운터인 CRC-32 및 SAR 시간 초과 오류 외에도 발생합니다.
라우터는 리어셈블된 패킷의 계산된 크기가 MTU와 상관없이 AAL5 length 필드의 수신 값과 일치하지 않을 경우 AAL5 길이 위반 카운터를 늘립니다. 이러한 위반이 어떻게 발생할 수 있는지 알아보려면 수신 ATM 인터페이스에서 프레임의 마지막 셀을 인식하는 방법을 이해해야 합니다.
셀 헤더는 3비트 PTI(Payload Type Identifier) 필드를 포함한다. 이 3비트는 다음을 나타냅니다.
비트 1 - 셀에 사용자 데이터 또는 관리 데이터가 포함되어 있는지 여부를 나타냅니다.
Bit 2(비트 2) - 전송 중에 셀이 혼잡을 경험하는지 여부를 나타냅니다.
비트 3 - 셀이 상위 레이어 데이터 프레임의 최종 셀인지 여부를 나타냅니다. 이 비트를 1로 설정하면 마커 끝(EOM)이라고 합니다.
001 또는 011의 PTI 값은 AAL5 PDU의 마지막 셀을 표시하고 수신 ATM 인터페이스에 재조합을 시작하도록 알립니다. 혼잡 또는 오류 상태의 기간 동안, ATM 링크는 마지막 셀을 드롭할 수 있다. 그 결과, 수신 인터페이스는 제2 AAL5 패킷의 마커 셀의 끝을 수신할 때까지 리어셈블리를 시작하지 않아, 길이 위반이 발생한다.
경우에 따라 라우터가 AAL5 길이 위반 카운터의 경우 큰 값을 보고하고 AAL5 CRC 오류 카운터의 경우 훨씬 작은 값을 보고합니다. 이 상태는 ATM 인터페이스에서 길이 위반을 선언하고 CRC를 확인하지 않고 리어셈블된 패킷을 삭제할 때 발생합니다. ATM 인터페이스는 패킷 크기가 AAL5 length 필드와 일치하는지 확인한 후에만 CRC를 검사합니다.
네트워크의 여러 인터페이스에서 일관성 있고 최대 크기의 MTU를 사용하면 다음과 같은 이점을 얻을 수 있습니다.
단편화를 줄이거나 제거합니다. MTU가 클수록 프래그먼트화가 제거되어 TCP 성능이 향상될 수 있습니다. 따라서 NFS(Network File System)와 같은 애플리케이션은 약 8kB의 대규모 네이티브 MTU를 더 효과적으로 활용할 수 있습니다.
Cisco 7500 Series 플랫폼의 RSP(Route Switch Processor)에서 MEMD(Packet Memory)에 새겨진 패킷 버퍼 풀의 크기를 최적화합니다. 이 플랫폼에서는 MTU가 버퍼 조각에 중요한 역할을 합니다. 특히 이 플랫폼은 MTU를 기반으로 4개의 버퍼 풀을 생성하는 버퍼 조각 알고리즘을 사용합니다. 모든 인터페이스에서 동일한 MTU를 사용하는 경우 라우터는 동일한 크기의 버퍼로 구성된 대규모 풀을 생성합니다. 이 플랫폼에서 광범위하게 다양한 MTU를 사용할 경우 Cisco IOS® 소프트웨어는 작은 수의 큰 버퍼를 조각해야 하므로 다른 인터페이스에 영향을 줄 수 있습니다. 7500 Series 플랫폼에서 MTU를 조정하면 무시된 입력 오류 수가 더 적을 수 있습니다. "%RSP-3-RESTART의 원인: cbus complex"?
참고: 원래 AIP는 최대 9180개의 MTU를 지원했습니다. 그 이유는 건축에 대한 이해가 필요하다. ATM 인터페이스에서 알려진 최대 활성 동시 가상 회로(VC) 수를 지원하는 기능은 통계 멀티플렉싱과 일부 수의 동시 재결합을 수행할 수 있는 충분한 패킷 버퍼를 보유하는 데 기반합니다. Cisco는 AIP에서 MTU 크기를 약 9000바이트로 제한하여 알려진 최대 활성 VC 값인 2000을 지원합니다.
처리된 패킷 수를 최소화하여 라우터 성능을 향상시킵니다. 라우터의 성능 비용 대부분은 "전송된 바이트"가 아니라 "처리된 패킷"과 관련이 있습니다. 일반적으로 라우터는 인터럽트 모드에서 트랜짓 패킷을 처리합니다. MTU가 클수록 성능이 향상될 수 있습니다. CPU가 빨라야 인터럽트 집약적인 작업이 빨라질 필요는 없습니다.
이 표에는 데이터그램 크기와 관련된 코멘트(RFC) 요청이 나열되어 있습니다.
참고: 테이블의 모든 링크는 RFC1483입니다
.
| 의견 요청 | 설명 |
|---|---|
| RFC 791 |
IP 프래그먼트화 절차를 정의합니다. |
| RFC 1191 |
인터넷에서 IP 프래그먼트화를 줄이기 위한 핵심 메커니즘인 경로 MTU 검색을 정의합니다. ATM은 이더넷이나 FDDI와 같은 다른 기술과는 상당히 다른 기본 MTU 크기를 사용하므로 이 메커니즘이 중요합니다. |
| RFC 1209 |
SMDS를 통한 IP MTU를 9180 옥텟으로 지정합니다. IETF(Internet Engineering Task Force)는 이 값과 RFC를 사용하여 RFC 2225에 정의된 대로 IP over ATM AAL5의 MTU를 9180 옥텟으로 설정했습니다 |
| RFC 1626 |
ATM 인터페이스가 SVC(Switched Virtual Circuits)용 ATM 시그널링 프로토콜을 사용하여 AAL CPCS-SDU 크기를 협상하려고 시도해야 하는 다른 항목 중에서 지정합니다. |
RFC 791
은 IP 프래그먼트화를 정의하고 절차를 "총 길이가 최대 전송 단위보다 작거나 같으면 데이터그램 처리의 다음 단계로 이 데이터그램을 제출합니다. 그렇지 않으면 데이터그램을 두 개의 프래그먼트로 잘라냅니다. 첫 번째 프래그먼트는 최대 크기이고 두 번째 프래그먼트는 데이터그램의 나머지 부분입니다."
debug ip packet {host access-list} 명령 출력은 두 호스트 192.168.1.51 및 192.168.1.254 간의 ping을 캡처합니다. 각 패킷에 대해 라우터는 두 프래그먼트를 수신한다고 보고합니다. 1500바이트 길이 하나와 48바이트 길이 하나.
주의: debug 명령을 실행하기 전에 Debug 명령에 대한 중요 정보를 참조하십시오.
*Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 1500, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 0 bytes *Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 48, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 1480 bytes
라우터가 에코 회신으로 응답하고 두 개의 프래그먼트를 전송한다고 보고합니다.
*Mar 28 09:59:27.002: ICMP: echo reply sent, src 192.168.1.254, dst 192.168.1.51 *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1528, sending *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1500, sending fragment *Mar 28 09:59:27.006: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 48, sending last fragment
Cisco Catalyst 5000 및 6000 스위치의 기가비트 이더넷 인터페이스는 점보 프레임을 지원하며, 이 프레임은 MTU가 9,216바이트입니다. Catalyst 6000 제품군 ATM 모듈(WS-X6101)에 대한 점보 프레임 지원은 릴리스 정보에 따라 Cisco IOS Software 릴리스 12.1(10)E에서 제공됩니다.
하위 인터페이스에서 MTU 크기를 구성해도 Catalyst 6000 제품군 ATM 모듈에서 전송할 수 있는 최대 프레임 크기에는 영향을 주지 않습니다. 최대 프레임 크기(9218바이트)는 모듈이 시작될 때 초기화되며 CLI를 사용하여 MTU 크기가 변경될 때 변경되지 않습니다.
점보 프레임을 연결하려면 set port jumbo mod/port 명령을 사용하여 수퍼바이저 엔진의 ATM 모듈에 대해 이 기능을 활성화해야 합니다.
12.1(10)E 이전의 Cisco IOS Software Release에서 Catalyst ATM 모듈은 명령줄에서 MTU 명령을 수락하며 최대값은 9218바이트입니다. 그러나 점보 프레임 지원이 없으면 이 컨피그레이션 변경은 오해의 소지가 있습니다. 원래 점보 프레임을 지원하지 않는 것은 모든 VC에서 지원되는 최대 버퍼 수에서 비롯됩니다.
ATM#show interface atm0
ATM0 is down, line protocol is down
Hardware is Catalyst 5000 ATM
MTU 1584 bytes, sub MTU 0, BW 156250 Kbit, DLY 80 usec, rely 255/255,
load 1/255
Encapsulation ATM, loopback not set, keepalive not supported
Encapsulation(s): AAL5, PVC mode
4096 maximum active VCs, 1024 VCs per VP, 0 current VCCs
VC idle disconnect time: 300 seconds
Signaling vc = 1, vpi = 0, vci = 5
UNI Version = 3.1, Link Side = user
PHY Type : SINGLE PHY; Link Status: DOWN
[snip]
LANE 버전 1 사양에서는 SETUP 메시지에 AAL 파라미터 정보 요소(IE)가 포함되어야 합니다. 이 IE에서, 발신자 또는 소스 ATM 인터페이스는 착신 최대 CPCS-SDU 크기 및 후방 최대 CPCS-SDU 크기를 지정해야 한다. 지원되는 AAL5 SDU 최대 옥텟 값은 1516, 4544, 9234 및 18190입니다. Cisco IOS Software 릴리스 12.1(10)E를 기준으로 LEC는 최대 9218바이트까지 프레임을 전송할 수 있습니다.
점보 프레임 지원은 이미 8540 고급 기가비트 이더넷 라인 카드 로드맵에 포함되어 있습니다. 이러한 지원은 8510용 기가비트 이더넷 카드에 대해 조사 중입니다. 이제 8540용 ATM 라우터 모듈 2(ARM2)는 구성 가능한 MTU 크기를 지원합니다.
증상으로 데이터그램 크기에 문제가 있는 경우 다음 단계를 완료하여 트러블슈팅 범위를 좁힙니다.
기본 인터페이스와 하위 인터페이스에 올바른 MTU가 있는지 확인합니다.
특정 패킷 크기 이상의 ping이 실패할 경우, 트래픽 셰이핑과 관련된 문제가 발생할 수 있습니다. ATM VC의 VBR-nrt 서비스 범주 및 트래픽 셰이핑 이해를 참조하십시오. 패킷이 소스 라우터를 종료하는지 확인하고 다음 명령을 사용하여 목적지 라우터를 입력합니다.
디버그 ip 패킷(호스트 액세스 목록만 해당)
주의: 이 디버그는 프로덕션 출력에서 많은 양의 출력을 생성할 수 있습니다. 이 디버그를 활성화할 때 각별한 주의를 기울여야 합니다.
debug atm packet interface atm mod/port vpi vci
atm 오류 디버그
show interface atm의 출력에서 giants 카운터에 대해 0이 아닌 값을 확인합니다. 자이언트 카운터가 당신의 핑과 함께 증가합니까?
show buffers 명령을 실행하고 miss 및 failures 카운터에 대해 0이 아닌 값을 찾습니다. 특히 라우터를 ping하고 시스템 버퍼를 사용할 때 카운터가 증가하는지 확인합니다. 자세한 내용은 버퍼 조정을 참조하십시오.
7500#show buffers
Buffer elements:
499 in free list (500 max allowed)
913677 hits, 0 misses, 0 created
Public buffer pools:
Small buffers, 104 bytes (total 480, permanent 480):
474 in free list (20 min, 1000 max allowed)
1036212 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Middle buffers, 600 bytes (total 360, permanent 360):
358 in free list (20 min, 800 max allowed)
635809 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Big buffers, 1524 bytes (total 360, permanent 360):
360 in free list (10 min, 1200 max allowed)
23457 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 40, permanent 40):
40 in free list (5 min, 1200 max allowed)
8969 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 40, permanent 40):
40 in free list (3 min, 120 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Huge buffers, 18024 bytes (total 4, permanent 0):
3 in free list (3 min, 52 max allowed)
0 hits, 1 misses, 427 trims, 431 created
0 failures (0 no memory)
show ip interface atm 명령을 실행하고 CEF(Cisco Express Forwarding)가 활성화되었는지 확인합니다. 이 경우 대상에 대한 인접성 항목에서 참조되는 MTU 크기를 확인합니다.
router#show adj atm 5/0.1 interface
Protocol Interface Address
IP ATM5/0.1 point2point(6)
0 packets, 0 bytes
00040000
AAAA030000000800
CEF expires: 00:02:49
refresh: 00:00:49
ATM-PVC never
Fast adjacency enabled
IP redirect enabled
IP mtu 4470 (0x0)
Fixup disabled
Cisco 버그 ID CSCdv42095(등록된 고객만 해당)는 브리지 인터페이스에서 MTU가 1502바이트 미만으로 구성된 경우 1498바이트보다 큰 패킷에 대한 ping 실패로 인한 문제를 해결합니다. 이 변경을 통해 최대 패킷 크기는 MTU에 최대 ATM 캡슐화를 더한 값(바이트)과 같게 됩니다. 해결 방법으로 MTU를 1502로 설정합니다.