VPIM ネットワーキング

はじめに

Cisco Unity Connection は、インターネットまたは TCP/IP ネットワーク上で異なる音声メッセージシステムが音声やテキストメッセージを交換できるようにする業界標準のプロトコルである、Voice Profile for Internet Mail (VPIM) をサポートしています。 VPIM は、Simple Mail Transfer Protocol (SMTP) および Multi-Purpose Internet MailExtension (MIME) プロトコルに基づいています。

VPIM ネットワークは、Unity Connection 2.x 以降のサーバ間、または Unity Connection 2.x 以降のサーバと Cisco Unity 4.0 以降などの VPIM 互換の音声メッセージングシステム間のメッセージングに使用できます。


(注)  


VPIM ではなくデジタルネットワーキングを使用して複数の Unity Connection 2.x 以降のサーバーを接続する場合は、追加サーバー検出機能とディレクトリ同期機能が利用できます。


VPIM ネットワークの設定

このセクションでは、VPIM ネットワーキングをセットアップするための前提条件について説明し、セットアップに必要なすべてのタスクの全体像と、それらを実行する順序を示したタスクリストを提供します。 VPIM ネットワークについてよく知らない場合は、セットアップを開始する前に、まず 4-15ページの「VPIM メッセージ」項一読してから、タスクリストと手順を確認します。

前提条件

セットアップを開始する前に、以下の前提条件が満たされていることを確認してください。

  • Cisco Unity Connection は既にインストールされ、ネットワークに接続されています。

  • Unity Connection がネットワーク接続されているリモート音声メッセージシステムについては、該当するシステム要件ドキュメント『Cisco Unity Connection リリース 14 向けシステム要件』の「VPIM ネットワークの要件」項を参照してください (入手先: https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/14/requirements/b_14cucsysreqs.html)。

タスクリスト: Cisco Unity Connection をセットアップして、VPIM ネットワークを使用する

以下のタスクリストを使用して、Cisco Unity Connection で VPIM ネットワークを設定セットアップします。 リンクをクリックすると、セットアップの詳細手順ページに移動します。

  1. 番号計画について決定を下し、VPIM ネットワークの設定に必要な情報を収集してください。 4-2 ページの「設計に関する意思決定と必要な情報の収集」項を参照してください。

  2. リモート音声メッセージングシステムと Unity Connection 間のメッセージングに使用されるドメイン名を特定します。 4-3 ページの「ドメイン名を決定する」項を参照してください。

  3. 必要に応じて、DNS ファイルを構成してください。 4-4 ページの「IP アドレスで名前を解決する」項を参照してください。

  4. リモート音声メッセージングシステムとのネットワークおよび SMTP 接続を確認してください。 4-4 ページの「リモート音声メッセージシステムとの接続を確認する」項を参照してください。

  5. 各リモート音声メッセージシステムの VPIM ロケーションを作成します。 4-5 ページの「VPIM ロケーションを作成する」項を参照してください。

  6. 各 VPIM ロケーションの VPIM 連絡先を作成します。 4-6 ページの「VPIM 連絡先を作成する」項を参照してください。

  7. 必要に応じて、各 VPIM ロケーションの連絡先作成設定をカスタマイズできます。 4-10 ページの「VPIM 連絡先ディレクトリ更新設定をカスタマイズする」項を参照してください。

  8. 必要に応じて、各 VPIM ロケーションに代替名を追加してください。 4-13 ページの「各 VPIM ロケーションの代替名を追加する」項を参照してください。

  9. VPIM 用のリモート音声メッセージングシステムを設定します。 具体的な方法は、音声メッセージングシステムによって異なります。 ただし、リモートシステムに Unity Connection に関する情報を提供する必要があります。 4-13 ページの「情報を収集して VPIM 用の別の音声メッセージシステムを構成する」項を参照してください。

  10. Unity Connection がリモート音声メッセージングシステムとメッセージを交換できることを確認するために、セットアップをテストしてください。

Unity Connection で VPIM ネットワークを使用するための設定手順

このセクションでは、VPIM ネットワーク用の Unity Connection をセットアップするために必要なすべての手順について説明します。

VPIM ネットワーキングの概念の詳細については、4-15 ページの「VPIM メッセージ」セクションを参照してください 。

設計上の意思決定と必要な情報の収集

Unity Connection for VPIM Networking の設定を開始する前に、以下の事項に備え、必要な情報を収集します。

  • 番号計画戦略を見直して、VPIM ロケーションでプレフィックスを入力する必要があるかどうか、VPIM ロケーションの ダイヤル ID としてどの番号を割り当てる必要があるかを判断します。 考慮すべき要件は以下のとおりです。

    • 固有のダイヤル ID を割り当てます。 ダイヤル ID は、他のダイヤル ID や内線番号と同じであってはなりません。

    • 可変長のダイヤル ID を使用する場合は、各ダイヤル ID の先頭の数字がほかのダイヤル ID と重複しないようにする必要があります。

      以下の規定に従ってください。

    • ダイヤル ID の長さを固定し、可能であれば内線番号の長さも固定してください。

    • ダイヤル ID には、少なくとも 3 桁の数字を割り当ててください。

    • ダイヤル ID の番号範囲は内線番号とは別にします。 001 や 002 など、内線番号と競合するダイヤル ID は使用しないでください。

  • 各 VPIM ロケーションで使用するパーティションと検索範囲を特定するために、パーティションと検索範囲の設定を見直します。 詳細については、『Cisco Unity Connection リリース 14 向けシステム アドミニストレーション ガイド』の「ダイヤルプラン」項を参照してください (入手先: https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/14/administration/guide/b_14cucsag.html)。

  • 各リモート音声メッセージングシステムについて、受信した VPIM メッセージから得た情報に基づいて、Unity Connection がそのシステムのユーザの VPIM 連絡先レコードを自動的に作成、変更、削除することを許可するかどうかを決定します。 また、ソース情報を VPIM 連絡先の表示名および内線番号にどのようにマッピングするかも決定します。

  • 各リモート音声メッセージシステムについて、Unity Connection ユーザーがそのロケーションの受信者に確認なしでメッセージを送信できるようにするかどうかを決定します。

  • リモート音声メッセージングシステムに関する以下の情報をメモしておいてください。メールボックスの範囲、サーバ名、ドメイン名、および IP アドレス。

ドメイン名の決定

VPIM メッセージは <Mailbox Number>@<Domain Name> 形式で宛先指定されます。 リモート音声メッセージングシステムと Unity Connection の間でメッセージをやり取りするには、リモート音声メッセージングシステムが Unity Connection ユーザにメッセージを送信する際に使用するドメイン名を決定する必要があります。 ドメイン名は以下のように設定します。

  • リモート音声メッセージングシステムでは、ドメイン名は Unity Connection に対応するロケーションまたはノードプロファイルに設定されます。 (詳細については、リモート音声メッセージングシステムのドキュメントを参照してください。)

  • [SMTPドメイン] フィールドは、Cisco Unity Connection Administration の [システム設定] > [SMTP構成] > [SMTPサーバー構成] ページにあります。

Unity Connection に対応するリモート音声メッセージングシステムの場所またはノードプロファイルに既にドメイン名が設定されている場合は、このセクションの手順でそのドメイン名を使用してください。

ドメイン名の要件

ドメイン名は、音声メッセージシステムを一意に識別します。 Unity Connection およびリモート音声メッセージングシステムで使用するドメイン名を選択する際には、以下の点に留意してください。

  • Unity Connection とリモート音声メッセージングシステムは、同じドメイン名を使用することはできません。各システムはそれぞれ固有のドメイン名を使用する必要があります。

  • Unity Connection で使用される完全なドメイン名は、リモート音声メッセージングシステムで使用されるドメイン名の部分集合であってはなりません。 たとえば、Unity Connection のドメイン名が cisco.com の場合、リモート音声メッセージシステムは、london.cisco.com、paris-cisco.com、または romecisco.com のような名前は使用できません。 ただし、Unity Connection で europe.cisco.com を使用し、リモート音声メッセージシステムの名前として london.cisco.com、paris-cisco.com、romecisco.com を使用することもできます。


    注意    


    これらの要件を満たさないドメイン名を選択すると、メッセージの配信が失敗します。


IP アドレスによる名前解決

VPIM メッセージは、インターネットまたは任意の TCP/IP ネットワークを介して SMTP 経由で送信されます。 したがって、リモート音声メッセージングサーバには名前解決のためのメカニズムが必要となる。 名前解決に対してサポートされている方法は、Domain Name System (DNS) を使用する方法です。

リモート音声メッセージングサーバの完全修飾ドメイン名(FQDN)と IP アドレスを知っておく必要があります。 FQDN は、[システム設定] > [SMTP 設定] > [サーバ] ページに表示されます。

ホストアドレスリソース (A) レコードとメール交換 (MX) レコードが存在しない場合は、それらをリモート音声メッセージサーバーの DNS に追加します。

DNS に A レコードと MX レコードを追加する方法の詳細については、DNS サーバのドキュメントを参照してください。

リモート音声メッセージングシステムとの接続確認

送受信する SMTP メッセージを処理するサーバーが、リモートの音声メッセージサーバーとネットワーク接続および SMTP 接続できること、またその逆方向からでも接続できることを確認します。

別の音声メッセージングサーバとネットワーク接続するには、そのサーバに SMTP サービスまたはゲートウェイをインストールして設定する必要がある場合があります。 SMTP サービスまたはゲートウェイのインストール方法については、他の音声メッセージングシステムのドキュメントを参照してください。 次に進む前に、SMTP サービスまたはゲートウェイが別の音声メッセージサーバーにインストールされていることを確認します。

リモート音声メッセージングサーバとのネットワーク接続を確認するには、以下の手順を実行してください。

手順


ステップ 1

Unity Connection サーバーと同じローカル ネットワーク セグメントを使用して、コマンド プロンプト ウィンドウを開きます。

ステップ 2

ping <IP address を入力します。ここでは、<IP address> は、リモート音声メッセージサーバーの IP アドレスです。その後、Enter キーを押します。

返信がない場合は、問題が解決するまでネットワーク接続の問題をトラブルシューティングしてください。 次に、 ステップ 3に進みます。

ステップ 3

ping <Domain name を入力します。ここでは、<Domain name> は、メッセージをリモート音声メッセージサーバーにアドレス指定した際に使用したドメイン名です。 この手順で使用するドメイン名は、VPIM ネットワークの設定時に Cisco Unity Connection Administration で VPIM ロケーション用に入力するドメイン名です。

ステップ 4

手順 2 の IP アドレスに ping したら応答があるにもかかわらず、手順 3 のドメイン名に ping しても応答がない場合は、4-4 ページの「IP アドレスで名前を解決する」項を参照してください。 問題が解決したら、 ステップ 5 に進んでください。

ステップ 5

逆方向のネットワーク接続をテストしてください。 Unity Connection 以外のシステムの場合は、テストの実行方法に関するドキュメントを参照し、手順 6 に進みます。 残りの手順は、お使いのシステムに必要な手順と完全には一致しない場合があるため、必要に応じて調整する必要があります。

ステップ 6

リモートサーバ上で、受信 SMTP メッセージを処理するローカルサーバの IP アドレスに ping を実行します。

返信がない場合は、問題が解決するまでネットワーク接続の問題をトラブルシューティングしてください。 次に、 ステップ 7に進みます。

ステップ 7

リモートサーバーで、ドメイン名を ping します。ここでのドメイン名は、4-3 ページの「ドメイン名を判断する」項で記載されているものです。

ステップ 8

ドメイン名で ping できなかった場合は、4-4 ページの「IP アドレスで名前を解決する」項を参照してください。

(注)  

 
必要に応じて、「utils network ping」CLI コマンドを使用してネットワーク接続を確認できます。

リモート音声メッセージングサーバとの SMTP 接続を確認する

手順


ステップ 1

Unity Connection サーバと同じローカルネットワークセグメント上のコンピューターを使用して、コマンドプロンプトウィンドウを開きます。

ステップ 2

「telnet <servername> 25」と入力します。ここでは、<servername> は、TCP ポート 25 を使用する SMTP サーバーの IP アドレスまたは FQDN です。

ステップ 3

各コマンドの後に ENTER キーを押してください。

ステップ 4

リモートメッセージングサーバが SMTP に接続されている場合、サーバの FQDN と SMTP のバージョンを含む 220 応答を受信します。

ステップ 5

Telnet テストが成功した場合は、「quit」と入力して Telnet セッションを終了してください。


VPIM ロケーションの作成

ユーザがメッセージを送信する各リモート音声メッセージングシステムごとに、Unity Connection 上に VPIM ロケーションを作成します。 Unity Connection が、多数の音声メッセージシステムにメッセージを送信する場合、現時点では、少数の VPIM ロケーションのみを構成して、残りのセットアップは後で行う方がよい場合があります。 Unity Connection と VPIM ロケーションが構成されている音声メッセージシステム間でメッセージが正常に機能していることを確認したら、残りの VPIM ロケーションを作成します。

VPIM ロケーションを作成するには、以下の手順を実行してください。

手順


ステップ 1

Cisco Unity Connection Administration で、[ネットワーク]、[VPIM] の順に選択します。

ステップ 2

[VPIMロケーションを検索] ページで、[新規追加] を選択します。

ステップ 3

[新しいVPIMロケーション] ページで、必要に応じて、基本設定を入力します。 (詳細については、[ヘルプ] > [このページ] を参照してください)。

(注)  

 
アスタリスク(*)が付いている項目は必須項目です。

ステップ 4

保存を選択します。

ステップ 5

VPIM ロケーションの編集ページで、該当する設定の入力を続けます。

ステップ 6

[VPIMロケーションを編集] ページで設定の入力が完了したら、[保存] を選択します。


VPIM ロケーションをカスタマイズする

ユーザーがメッセージを送信するリモート音声メッセージシステムに Cisco Unity Connection Administration を使用すると、VPIM ロケーションをカスタマイズできます。

VPIM の場所をカスタマイズするには、以下の手順を実行してください。

手順


ステップ 1

Cisco Unity Connection Administration で、[ネットワーク]、[VPIM] の順に選択します。

ステップ 2

「VPIM ロケーションの検索」ページで、カスタマイズする VPIM ロケーションの表示名を選択します。

ステップ 3

VPIM ロケーションの編集ページで、必要に応じて設定を変更してください。 (詳細については、ヘルプ> このページをご覧ください。)

ステップ 4

[VPIMロケーションを編集] ページで設定の変更が完了したら、[保存] を選択します。


VPIM 連絡先の作成

最初は、Unity Connection とリモート音声メッセージシステムが正常にメッセージを交換できることを確認するために、VPIM 連絡先を少しだけ作成します。 Unity Connection とリモート音声メッセージングシステム間のメッセージングが正しく機能していることを確認したら、VPIM 連絡先の作成を完了できます。


(注)  


VPIM 連絡先を作成する前に、まず VPIM ロケーションを作成する必要があります。また、VPIM 連絡先は、VPIM ロケーションを作成したのと同じ Unity Connection サーバ上に作成する必要があります。


VPIM 連絡先は、一括管理ツールまたは Cisco Unity Connection Administration を使用して作成できます。 一括管理ツールを使用して複数の VPIM 連絡先を作成する

一括管理ツール (BAT) を使用すると、Comma Separated Values (CSV) ファイルから連絡先データをインポートすることで、複数の VPIM 連絡先を同時に作成できます。 CSV は、データを 1 つのデータストアから別のデータストアに移動するための一般的なテキストファイル形式です。

以下の手順を実行して、CSV ファイルを準備します。

VPIM 連絡先を作成するための CSV ファイルの準備

手順

ステップ 1

VPIM 連絡先の作成に使用するデータを CSV ファイルとして保存します。

ベストプラクティスとして、1 つの CSV ファイルに 7,500 件を超えるレコードを含めないようにしてください。バルク管理ツールでデータをインポートする際に、予期しない結果が生じる可能性があります。

ステップ 2

CSV ファイルを該当するディレクトリにコピーしてください。

ステップ 3

CSV ファイルをスプレッドシート アプリケーション、またはデータの編集や再編成が可能な別のアプリケーションで開きます。 次の手順を実行します。

  • データがカンマで区切られており、タブ、スペース、セミコロンで区切られていないことを確認してください。

  • データにスペース、引用符、またはカンマが含まれている場合は、そのデータ全体を引用符で囲みます。

ステップ 4

データを再配置して、手順 5 で追加した列のヘッダーと同じ順序で配列します。 列のヘッダーの順序は問いませんが、ここで示す順序で CSV ファイルを作成することをお勧めします。 たとえば、この例のデータの列は、連絡先のエイリアス、姓、名、内線、リモートメールボックス ID (RemoteMailAddress)、VPIM ロケーション (DeliveryLocationDisplayName) の順に並んでいます。

aabade、Abade、Alex、2001、3000、シカゴ VMS VPIM ロケーション

kbader、Bader、Kelly、2002、3100、シカゴ VMS VPIM ロケーション

tcampbell、Campbell、Terry、2003、3200、シカゴ VMS VPIM ロケーション

lcho、Cho、Li、2004、3300、シカゴ VMS VPIM ロケーション

(注)  

 
連絡先を作成する際に必須となる列のヘッダーは、エイリアスと内線番号のみです。 ただし、VPIM 連絡先を作成するには、[リモートメールボックスID] 列と [VPIMロケーション] 列も含める必要があります。

ステップ 5

最初のデータ行の上に列ヘッダーを入力してください。 列のヘッダーはカンマで区切り、以下のように表記します。

Alias、LastName、FirstName、Extension、RemoteMailAddress、DeliveryLocationDisplayName

ステップ 6

必要に応じて、最初の行にオプションの列ヘッダーを追加し、その下の行にインポートする対応するデータを入力します。 その際、以下の点を確認してください。

  • 列ヘッダーとデータはカンマで区切られています。 なお、オプションの列ヘッダーについては、すべての行にデータを含める必要はありません。

  • スペース、引用符、またはカンマを含むデータは、引用符で囲まれます。

ヒント

 
ユーザーが通常の Unity Connection ユーザー宛てのメッセージと同様に、内線番号または受信者名のスペルを入力することで、VPIM 連絡先にメッセージを送信できるようにする場合は、ListInDirectory ヘッダーを持つ列を追加し、各連絡先の値を 1 に設定します。 オプションの列のヘッダーの一覧については、『Cisco Unity Connection 向け システム アドミニストレーション ガイド、リリース 14』「一括管理ツール」付録の「BAT の必須 CSV フィールドとオプションの CSV フィールド」項を参照してください (入手先: https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/14/administration/guide/b_14cucsag.html)。

ステップ 7

CSV ファイルにインポートしたくないデータ列が含まれている場合は、それらの列を削除してください。 または、1 つの列に「NOTES」というタイトルを付けます。 BAT は NOTES 列ヘッダー以下のデータを無視しますが、CSV ファイル内で複数の NOTES 列をサポートしていません。

ステップ 8

各行に、各列ヘッダーに対応する適切なデータが含まれていることを確認してください。

ステップ 9

ファイルを CSV ファイルとして保存してください。

ステップ 10

次の「一括管理ツールを使用して VPIM 連絡先を作成する」手順に進みます。


一括管理ツールを使用して VPIM 連絡先を作成する

手順

ステップ 1

Cisco Unity Connection の管理で、[ツール(Tools)] を選択し、[一括管理ツール(Bulk Administration Tool)] を選択します。

ステップ 2

[一括管理ツール] ページの [操作を選択] で、[作成] を選択します。

ステップ 3

[オブジェクトタイプ] で、[システム連絡先] を選択します。

ステップ 4

[ファイルを選択] で、[参照] を選択します。

ステップ 5

[ファイルを選択] ダイアログボックスで、ページ 4-6 に記載されている「CSV ファイルを準備して VPIM 連絡先を作成する」手順で作成した CSV ファイルを保存するディレクトリを参照し、[開く] を選択します。

ステップ 6

「失敗したオブジェクトファイル名」フィールドに、エラーを記録するファイルのパスとファイル名を入力します。

ステップ 7

[送信(Submit)] を選択します。


CSV エラーの修正

失敗したオブジェクトファイルには、VPIM 連絡先の作成に失敗したデータが含まれています。 一括管理ツールは、CSV ファイルの各行で最初に検出されたエラーを報告します。 そのエラーを修正した後、データが再度インポートされた際に、BAT は同じ行でさらにエラーを検出する可能性があります。 そのため、すべてのエラーを見つけて修正するには、BAT を実行して、エラー修正プロセスを数回繰り返す必要がある場合があります。

失敗オブジェクトファイルには、VPIM 連絡先の作成に失敗したすべてのレコードが含まれています。 ファイルを CSV ファイルとして保存すると、BAT を再度実行する際に使用できます。 BAT を実行するたびに、失敗したオブジェクトファイルが上書きされることに注意します。

CSV エラーを修正するには、以下の手順を実行してください。

手順

ステップ 1

一括管理ツール操作がエラーになった場合、[失敗したオブジェクトファイルをダウンロード] を選択することで、すぐに失敗したオブジェクトのレポートファイルを調べることができます。

ステップ 2

ファイルを開いて、各レコードの [FailureReason] 列の情報に従って、データに関するすべての問題を修正します。

ステップ 3

FailureReason 列を削除するか、見出しを JUNK に変更してください。

ステップ 4

データの変更が完了したら、新しい名前で CSV ファイルとして保存してください。

ステップ 5

手順 4 で保存した CSV ファイルを入力ファイルとして使用して、BAT を再度実行します。

BAT を実行するたびに、失敗したオブジェクトファイルは上書きされることに注意してください(ツールを実行するたびにファイルに新しい名前を指定しない限り)。

ステップ 6

すべての VPIM 連絡先アカウントがエラーなしで作成されるまでこの手順を繰り返したら、4-10 ページの「VPIM 連絡先を作成後」項に進みます。


Cisco Unity Connection Administration を使用して VPIM 連絡先を作成する

Cisco Unity Connection Administration を使用すると、VPIM 連絡先を 1 件ずつ作成できます。

VPIM 連絡先を作成するには、以下の手順を実行してください。

手順

ステップ 1

Cisco Unity Connection Administration で、[連絡先]を展開し、[連絡先] を選択します。

ステップ 2

連絡先検索ページで、連絡先メニューから 新しい連絡先を選択します。 または、[連絡先を検索] ページで、[新規追加] を選択して、新規連絡先を追加します。

ステップ 3

新規連絡先ページで、次の設定を入力し、 保存を選択します。

表 1. 新しい連絡先ページの設定

フィールド

設定

Alias

VPIM 連絡先のエイリアスを入力してください。

名

VPIM 連絡先の名 (First Name) を入力します。

[姓(Last Name)]

VPIM 連絡先の姓 (Last Name) を入力します。

表示名

VPIM 連絡先の表示名を入力してください。

連絡先テンプレート

VPIM 連絡先の基にするテンプレートを選択します。

ステップ 4

[連絡先の基本情報を編集] ページで、次の設定を入力し、[保存] を選択します。

表 2. 連絡先基本情報の編集ページの設定

フィールド

設定

音声名

[再生/録音] を選択して、VPIM 連絡先の名前を録音します。

ディレクトリに登録する

このチェックボックスをオンにすると、VPIM 連絡先が Unity Connection ディレクトリに一覧されます。

パーティション

VPIM 連絡先が属するパーティションを選択してください。 パーティションは検索スペースとグループ化され、これは、Unity Connection との通信中にユーザーまたは外部発信者が到達できるオブジェクトの範囲 (例: ユーザーと分散リスト) を定義するために使用されます。 VPIM 連絡先は、1 つのパーティションにのみ属することができます。 パーティションは複数の検索スペースに属することができます。

転送を有効にする

(オプション) Unity Connection が着信コールを VPIM 連絡先のリモート メールボックスにメッセージを送信する代わりに、VPIM 連絡先に関連付けられた電話番号に転送する場合は、このチェックボックスをオンにします。

転送先内線番号/URI

(オプション) 電話システムが VPIM 連絡先に通話を転送するために使用する電話番号または URI を入力します。必要に応じて、発信アクセスコードも入力します。 このフィールドは、「転送有効」フィールドと連携して機能します。

配信ロケーション

VPIM 連絡先の VPIM ロケーションを選択してください。

VPIM リモートメールボックス番号

リモート音声メッセージングシステム上の VPIM 連絡先のメールボックス番号を入力してください。

ローカル内線番号

(オプション) VPIM 連絡先には、Unity Connection の内線番号体系に適合するローカル内線を割り当てることができます。 ローカル内線を使用すると、発信者は連絡先の場所 ID やリモートメールボックス番号を知らなくても、内線番号を使って VPIM 連絡先にメッセージを送信できます。

さらに、[転送を有効にする] フィールドと [転送先内線番号] フィールドを設定すると、発信者は、VPIM 連絡先を識別でき、連絡先に転送されます。

音声コマンドを使用して連絡先に発信するための電話番号

(オプション) 音声認識ユーザーが、その連絡先に対する具体的な電話種別を指定して VPIM 連絡先に発信できるようにするには、[勤務先発信用電話番号]、[自宅発信用電話番号] および [スマートフォン発信用電話番号] フィールドを使用します。

ダイヤルする電話番号については、外線をダイヤルするのに必要な追加番号があればすべて追加します(たとえば、9)。■日本語版では削除:また、長距離電話に必要な追加番号も追加します(たとえば、1)。□

個人通話転送ルールの連絡先を特定するための電話番号または URI

(オプション) [勤務先電話番号]、[自宅の電話番号]、[スマートフォンの番号]、[その他の番号1]、[その他の番号2] フィールドには、Unity Connection がシステム連絡先からの着信通話に対してユーザーのパーソナル着信転送ルールとの照合を行う際に使用する電話番号または URI を入力します。

ステップ 5

作成する残りの VPIM 連絡先に対して手順 2 から手順 4 を繰り返します。


VPIM 連絡先を作成した後

VPIM 連絡先を作成した後、以下の点を考慮してください。

  • 新しく作成された VPIM 連絡先がメッセージを受信できるようになるまでには、数分かかります。

  • Cisco Unity Connection Administration では、個々の VPIM 連絡先の設定を変更できます。

  • 複数の連絡先に対して、内線番号などの固有の VPIM 連絡先設定を一括で変更したい場合は、一括管理ツールを再実行できます。

  • VPIM 連絡先が Unity Connection アカウントを必要としなくなった場合は、VPIM 連絡先を削除できます。 詳細については、4-14 ページの「VPIM 連絡先を削除する」項を参照してください。

VPIM 連絡先ディレクトリ更新設定のカスタマイズ

VPIM 連絡先を手動で作成、変更、削除するだけでなく、受信した VPIM メッセージに含まれる情報に基づいて、VPIM 連絡先ディレクトリ内のレコードを自動的に更新するように Unity Connection を更新できます。 作成、変更、削除といったアクションを自動的に行うかどうか、また受信情報をどのように使用してレコードを作成または変更するかを制御する設定は、VPIM のロケーションごとに個別に構成できます。 デフォルトでは、VPIM のロケーションに対してディレクトリの自動更新は行われません。

Unity Connection は、各 VPIM ロケーションに対して選択した連絡先作成設定に応じて、受信した VPIM メッセージのヘッダー情報を使用します。 VPIM ロケーションの送信者から VPIM メッセージが受信され、その VPIM ロケーションが自動 VPIM 連絡先の作成を許可するように設定されている場合、送信者の情報に一致する既存の VPIM 連絡先が存在しないときは、VPIM メッセージに以下の情報が含まれている場合に限り、新しい VPIM 連絡先レコードが作成されます。

  • 電話番号

  • 文字列名

  • ドメイン名

  • 録音名 (必要に応じて、VPIM ロケーション構成に基づく)

[その他の連絡先作成] 設定では、VPIM 連絡先の解析済みテキスト名を姓、名、表示名にマッピングする方法、および電話番号を内線番号にマッピングする方法を指定できます。


(注)  


VPIM ロケーションの [連絡先作成] ページにある [VPIM連絡先内線番号をマッピング] 設定の変更は、その設定が保存された後に作成される VPIM 連絡先にのみ影響します。 [VPIM連絡先内線番号をマッピング] 設定を変更する前にすでに存在する VPIM 連絡先は、自動更新されません。 その VPIM ロケーションに以前から存在している VPIM 連絡先の内線番号は、手動で変更する必要があります。


VPIM 連絡先の自動変更を許可するように設定された VPIM ロケーションの送信者から VPIM メッセージが受信され、既存の VPIM 連絡先が送信者の情報と一致する場合、VPIM 連絡先を更新できます。 VPIM 連絡先情報の更新は、VPIM 連絡先からメッセージを受信するたびに行うか、ディレクトリエントリが作成されてからテキスト名が変更された VPIM 連絡先からメッセージを受信した場合にのみ行うかを選択できます。 変更が行われた際に、表示名の更新を許可するかどうかも決定できます。

Unity Connection ユーザーから VPIM 連絡先へのメッセージが、宛先の受信者が存在しない (SMTP 5.1.1) ことを示す配信不能通知 (NDR) を返した場合、かつ VPIM ロケーションが VPIM 連絡先の自動削除を許可するように設定されている場合、VPIM 連絡先は削除されます。

Cisco Unity Connection Administration を使用して、VPIM ロケーションの連絡先作成設定を更新できます。

VPIM 連絡先作成設定を構成する前に

VPIM ロケーション連絡先作成設定を構成する前に、以下の点を考慮します。

  • VPIM 連絡先に、変更不可である具体的な表示名を事前入力したが、連絡先レコードのその他のフィールドで自動変更を許可する場合は、[VPIM連絡先表示名の更新を許可する] チェックボックスをオフにします。 この場合、自動更新の際に、連絡先の名、姓、および音声名が変更されることがあります。 音声名が更新されても表示名が更新されない場合、不一致が生じる可能性があります。

  • [録音された音声名のないVPIM連絡先を許可する] チェックボックスがオフになっている場合、Originator-Spoken-Name 添付ファイルが含まれていない受信メッセージに対して、新しい VPIM 連絡先は作成されません。 さらに、VPIM 連絡先の自動変更が有効になっている場合、受信メッセージの送信者が既存の VPIM 連絡先と一致する場合、メッセージに添付ファイルがない場合は、その VPIM 連絡先は削除されます。

  • [録音された音声名のないVPIM連絡先を許可する] チェックボックスがオンになっており、VPIM 連絡先の自動変更が有効になっている場合、Originator-Spoken-Name 添付ファイルが含まれていない受信メッセージの送信者が既存の VPIM 連絡先と一致すると、既存の録音された音声名が削除されます。

  • 受信メッセージに含まれる電話番号を、[VPIM連絡先内線番号のマッピング先] フィールドで選択したオプションを使用して内線番号に正常にマッピングできない場合、送信者用の VPIM 連絡先は作成されません。

Cisco Unity Connection Administration を使用して VPIM 連絡先作成設定を構成する

VPIM ロケーションを作成した後、Cisco Unity Connection Administration を使用して、その特定の VPIM ロケーションの自動ディレクトリ更新を制御する設定を構成できます。

Cisco Unity Connection Administration を使用した VPIM 連絡先作成設定の構成
手順

ステップ 1

Cisco Unity Connection Administration で、[ネットワーク]、[VPIMロケーション] の順に選択します。

ステップ 2

「VPIM ロケーションの検索」ページで、連絡先作成設定を構成する VPIM ロケーションの名前を選択します。

ステップ 3

[VPIMロケーションを編集] ページの [編集] メニューで、[連絡先の作成] を選択します。

ステップ 4

[連絡先の作成] ページで [VPIM連絡先を自動作成する] チェックボックスをオンにして、VPIM メッセージの受信時に、送信者に対応する VPIM 連絡先レコードが存在しない場合、このロケーションに対する VPIM 連絡先レコードを自動的に作成するようにします。

ステップ 5

手順 4 で [VPIM連絡先を自動作成する] チェックボックスをオンにした場合、連絡先テンプレートリストで、自動作成される連絡先の基になるテンプレートを選択します。

ステップ 6

[VPIM連絡先を自動変更する] フィールドで、次のいずれかを選択して、このロケーションに VPIM 連絡先を適用します。

  • 連絡先を自動更新しない - 受信するメッセージで送信者情報が変更されても、VPIM 連絡先レコードは、その VPIM メッセージに記載されている送信者情報で更新されません。

  • テキスト名が変更された場合のみ—VPIM 連絡先レコードは、VPIM メッセージで受信したテキスト名が VPIM 連絡先の名前と一致しない場合にのみ更新されます。

  • 各 VPIM メッセージで - このロケーションで VPIM 連絡先から受信する各 VPIM メッセージによって、対応する VPIM 連絡先レコードが更新されます。

ステップ 7

[VPIM連絡先を自動削除する] チェックボックスをオンにすると、VPIM メッセージが配信不可として返送された場合に、このロケーションの VPIM 連絡先が自動的に削除されます。

ステップ 8

この場所からの受信メッセージで送信者の表示名が変更された場合に、VPIM 連絡先の表示名が自動的に更新されるようにするには、[VPIM 連絡先の表示名の更新を許可する] チェックボックスをオンにします。

ステップ 9

[録音された音声名がないVPIM連絡先を許可する] チェックボックスをオンにすると、録音名が設定されていない VPIM 連絡先レコードに関するこのロケーションからの自動更新が有効になります。

ステップ 10

「テキスト名のマッピング」フィールドで、この場所からの受信メッセージ内のテキスト名を、自動的に作成される VPIM 連絡先レコードの表示名にどのようにマッピングするかを指定するために、次のいずれかのオプションを選択します。

  • VPIM 連絡先の表示名に直接—VPIM 連絡先の表示名は、対応するテキスト名と一致します。

  • カスタム ー VPIM 連絡先のテキスト名を表示名にマッピングする方法を定義するルールを入力します。 トークン <FN>、<LN> または <TN> (それぞれ、名、姓またはテキスト名) を任意に組み合わせて入力できます。また、任意の追加テキストを含めることもできます。 ルールの先頭にない限り、 <FN>、 <LN>、または <TN> の前には必ずスペース、コンマ、またはセミコロンを付けます。 さらに、ルールの末尾に現れる場合を除き、これらのトークンの後には必ずスペース、コンマ、またはセミコロンを付けてください。 ルールの最初または最後に、追加の文字は必要ありません。

ステップ 11

[VPIM連絡先内線番号のマッピング先] フィールドで、つぎのいずれかの設定を選択しすると、VPIM 連絡先レコードを自動生成するために、このロケーションからの着信メッセージの電話番号がどのように内線にマッピングされるかを示すことができます。

  • 電話番号 — 内線番号は、受信した VPIM メッセージから解析された電話番号と同じ番号です。

  • 電話番号 - リモート電話プレフィックス—内線番号は、電話番号の先頭からリモート電話プレフィックスを削除することによって作成されます。

  • 場所ダイヤル ID + 電話番号—内線番号は、電話番号の前に場所ダイヤル ID を追加することで作成されます。

  • ロケーションダイヤル ID + 電話番号 - リモート電話機プレフィックス — 内線番号は、電話番号の先頭からリモート電話機プレフィックスを削除し、その番号の前にロケーションダイヤル ID を追加することで作成されます。

ステップ 12

[保存] を選択します。

ステップ 13

[VPIMロケーション] メニューで、[VPIMロケーションを検索] を選択します。

ステップ 14

残りのすべての VPIM ロケーションに対して、手順 2 から手順 13を繰り返します。


各 VPIM ロケーションに代替名を追加する

Unity Connection システムが音声認識オプションを使用する場合、VPIM ロケーションに付ける表示名に代替名を指定することもできます。 ユーザーが音声コマンドを使用して VPIM ロケーションのメールボックス番号宛てにブラインド アドレッシングを行う場合 (たとえば、Seattle という名前の VPIM ロケーションの内線 55 を宛先にする場合は、「five five at Seattle」と発話します)、または VPIM ロケーションの VPIM 連絡先名宛てにメッセージを送信する場合 (たとえば、「Robin Smith in Chicago」)、ユーザーはこの表示名を発話します。 VPIM の場所の表示名に、ユーザが知らない可能性のある管理情報が含まれている場合、または頭字語や略語のように、読み方と異なる発音になる場合は、代替名を指定することを検討してください。 ユーザが場所を複数の呼び方で呼ぶ傾向がある場合は、代替名を追加することも検討してください。 例えば、あるサイトのユーザが場所を「シアトル支店」と呼び、別のサイトのユーザが同じ場所を「シアトルオフィス」と呼ぶ場合、「シアトル支店」と「シアトルオフィス」の両方を代替名として追加することができます。

代替名を追加するには、以下の手順に従ってください。

手順


ステップ 1

Cisco Unity Connection Administration で、[ネットワーク]、[VPIMロケーション] の順に選択します。

ステップ 2

「VPIM ロケーションの検索」ページで、代替名を追加する VPIM ロケーションの名前を選択します。

ステップ 3

[VPIMロケーションの編集] ページの [編集] メニューで [代替名] を選択します。

ステップ 4

[代替名を編集] ページの [表示名] フィールドで、VPIM ロケーションに使用する代替名を入力し、[新規追加] を選択します。

ステップ 5

[VPIMロケーション] メニューで、[VPIMロケーションを検索] を選択します。

ステップ 6

代替名を追加する残りのすべての VPIMロケーションに対して手順 2 から手順 5 を繰り返します。


VPIM 用の別の音声メッセージングシステムを構成するための情報収集

Unity Connection と VPIM メッセージを交換するために別の音声メッセージングシステムを設定するには、以下の情報が必要になる場合があります。

  • 受信する SMTP メッセージを処理する SMTP サーバのサーバ名とドメイン名。

  • 対応する VPIM ロケーションページに入力された Unity Connection の電話プレフィックス(存在する場合)とリモート電話プレフィックス(存在する場合)。

  • Unity Connection ユーザのメールボックス番号の範囲。

受信した VPIM メッセージは SMTP サーバにルーティングする必要があります。 リモート音声メッセージシステム上で Unity Connection のロケーションを定義する際は、SMTP サーバー用に入力したドメイン名を使用します。

Unity Connection では、受信する VPIM メッセージは以下の形式になっている必要があります。

<ConnectionPhonePrefix+ConnectionUserExtension@PrimaryLocationSMTPDomainName>

これらの特定のプロパティは Unity Connection で設定されますが、同様の情報は他の音声メッセージングシステムでも設定する必要があります。

VPIM 連絡先の削除

手順


ステップ 1

Cisco Unity Connection Administration で、[連絡先]を展開し、[連絡先] を選択します。

ステップ 2

「連絡先の検索」ページで、削除したい VPIM 連絡先の横にあるチェックボックスをオンにします。

ステップ 3

[選択項目の削除]を選択します。

ステップ 4

削除を確認するよう求められたら、 OK を選択してください。


VPIM ロケーションの削除

VPIM ロケーションを削除する場合は、VPIM ロケーションオブジェクトを削除する前に、そのロケーションを使用している連絡先および連絡先テンプレートをすべて削除(または再割り当て)する必要があります。 以下のタスクリストを使用して、VPIM ロケーションを削除します。

  1. 一括管理ツールを使用して、管理者が定義したすべての連絡先のリストをエクスポートします。 「一括管理ツール」を参照してください。

  2. エクスポートファイルをダウンロードし、テキストエディタを使用して、DeliveryLocationDisplayName が、削除する VPIM ロケーションの表示名と一致する行のみが残るように編集します。 (連絡先を別の VPIM ロケーションに再割り当てする場合は、[DeliveryLocationDisplayName] 列の値を更新してください。)

  3. 一括管理ツールを使用して、タスク 2で生成した連絡先リストを削除します。 または、連絡先を別の VPIM ロケーションに再割り当てする場合は、[更新] オプションを使用します。

  4. Cisco Unity Connection の管理で、[テンプレート] を展開し、[連絡先テンプレート] を選択します。 連絡先テンプレートが VPIM ロケーションを配信ロケーションとして使用するように構成されている場合は、配信ロケーションを変更するか、テンプレートを削除します。 ([Search Contactテンプレート] ページで各テンプレートの表示名を選択して、配信ロケーションを検証または変更する必要があります)。

  5. ロケーションを削除するには、Unity Connection Administration で、[ネットワーク]、[VPIMロケーション] の順に選択します。 「VPIM ロケーションの検索」ページで、削除したいロケーションの表示名の横にあるチェックボックスをオンにしてから、「選択した項目を削除」を選択します。

    一括管理ツールの詳細については、『Cisco Unity Connection、リリース 14 向け システム アドミニストレーション ガイド』の付録を参照してください (入手先: https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/14/administration/guide/b_14cucsag.html)。


    (注)  


    Unity Connection が HTTPS ネットワーク上にある場合は、ネットワーク削除タスクを実行して、ネットワークからその場所を完全に削除してください。 VPIM のロケーションを削除すると、VPIM の連絡先も自動的に削除されます。

VPIM メッセージ

VPIM メッセージは、1 つ以上の MIME エンコードされた部分で構成されます。 VPIM 仕様では、音声名、転送メッセージ、テキストメッセージ用の任意の MIME パートが許可されています。 ただし、Unity Connection は vCard(電話番号、名前、メールアドレスを含む電子名刺)の送受信をサポートしていません。 送信メッセージまたは受信メッセージに vCard が添付されている場合、Unity Connection は vCard データを削除します。 さらに、音声メッセージおよび埋め込みメッセージ以外のメッセージへの添付ファイルは、送信メッセージおよび受信メッセージから削除されます。

Unity Connection では、送信者の記録された名前を送信メッセージとともに送信するかどうかを指定できます。 受信メッセージに録音された名前が含まれている場合、その名前はメッセージの一部として再生されます。 Unity Connection は、受信メッセージのヘッダー情報に基づいてディレクトリを更新するように設定することもできます。

VPIM ロケーションへの送信メッセージには、VPIM ロケーション以外の受信者は含まれません。 したがって、VPIM の受信者がメッセージの宛先全員に返信した場合、返信は送信者と、同じ VPIM ロケーションにいるほかの宛先にのみ送信されます。

図 1 は VPIM メッセージのサンプルを示しています。 音声名と音声メッセージ部分の MIME エンコーディングは非常に長いため、その一部のみを表示しています。

図 1. サンプル VPIM メッセージ

VPIM アドレス

VPIM アドレスは、一般的な SMTP メールアドレスと同じ形式です。localpart@hostpart。 アドレスの右側は、TCP/IP ネットワーク上でメッセージを処理するシステムのドメイン名です。 アドレスの左側は、ユーザ固有の識別子です。 通常、左側にはユーザーのメールボックス番号、またはプレフィックス付きのメールボックス番号が設定されます。

たとえば、リモートメールボックス ID 2233 が設定されている Terry Campbell 宛ての VPIM メッセージは、次のようにアドレス指定されます。

宛先: 2233@remotevoicemailsystem.com

組織の番号計画に対応する必要がある場合は、アドレスにプレフィックスを含めることもできます。

宛先: 8882233@remotevoicemailsystem.com

VPIM アドレスは、VPIM メッセージを送信する際に Unity Connection によって生成されます。ユーザーがメッセージの宛先を指定する際に入力するものではありません。

メッセージアドレス指定オプション

Unity Connection では、リモート音声メッセージングシステム上の個人宛てにメッセージを送信するための以下の方法を提供しています。

  • Unity Connection ディレクトリ - VPIM 連絡先の [ディレクトリにリストする] チェックボックスがオンになっている場合、Unity Connection ディレクトリには VPIM 連絡先の名前と内線番号が含まれます。 ユーザーは、メッセージを通常の Unity Connection ユーザーにアドレス指定する方法と同じ方法で、VPIM 連絡先にメッセージをアドレス指定できます。つまり、内線番号で指定するか、受信者の名前のスペルで指定できます。 VPIM 連絡先に録音名が存在する場合は、音声名確認を利用できます。連絡先に録音名がない場合は、Unity Connection は [テキスト読み上げ] 機能を使用して連絡先の表示名を再生します。

  • ブラインドアドレス指定 - ブラインドアドレス指定を使用すると、受信者が Unity Connection ディレクトリで連絡先として定義されていない場合でも、ユーザーは VPIM ロケーションの受信者にメッセージを送信できます。 [VPIMロケーション] ペインの [ブラインドアドレス指定を許可] チェックボックスがオンの場合、ユーザーは、VPIM ロケーションダイヤル ID、受信者のメールボックスの番号で構成される番号を入力するか、メールボックス番号と VPIM ロケーションの表示名 (たとえば、「five five at Seattle office」) を発話することで、このロケーションの受信者にメッセージをアドレス指定できます。

  • 分散リスト - ユーザーは、メッセージを VPIM 連絡先を含むプライベート分散リストまたはシステム分散リストをアドレス指定でき、その結果、VPIM 連絡先がメッセージを受信できるようになります。

メッセージにおける類似点と制限

ほとんどの場合、Unity Connection ユーザーとリモート音声メッセージシステムのユーザー間のメッセージのやり取りは、Unity Connection ユーザー間のメッセージのやり取りと同じです。 次に例を示します。

  • 送信時に緊急としてマークされたメッセージは、受信者が受信した際にも緊急としてマークされます。

  • 送信時にプライベートとしてマークされたメッセージは、受信者が受信した際にもプライベートとしてマークされます。

  • ユーザーは、VPIM の連絡先を含む Unity Connection 分散リストにメッセージを送信できます。

次の例外に注意します。

  • 開封確認と配信確認のリクエストは、いずれも配信確認として返されます。

  • リモート音声メッセージシステムのユーザーが Unity Connection 分散リストにメッセージを送信できるようにするには、Unity Connection Administration の [分散リストの基本を編集する] ページで、[外部システムからのメッセージを許可する] チェックボックスをオンにする必要があります。 このチェックボックスはデフォルトではオフになっています。

音声フォーマットに関する考慮事項

Cisco Unity Connection Administration の [ネットワーク] > [VPIMロケーションを編集] ページにある、VPIM ロケーションの音声形式変換設定を使用すると、送受信する VPIM メッセージの音声形式を次のように制御できます。

  • 受信メッセージ — 受信した VPIM メッセージを、送信された形式のまま保存するか、Unity Connection がメッセージの保存に使用する音声形式に変換するかを設定できます。

  • 送信メッセージ—送信 VPIM メッセージを、記録された形式のまま送信するか、G.726 コーデックに変換して送信するかを設定できます。

これらの設定について決定を下す際には、以下の点を考慮してください。

  • ローカル Unity Connection サーバーが音声メッセージの録音および再生に使用する音声形式。

  • リモート音声メッセージングシステムが VPIM メッセージを送受信する際に使用する音声フォーマット。 音声メッセージシステムによっては、VPIM メッセージに G.726 形式のみをサポートしているものもありますが、念のためにリモート音声メッセージサーバーに関するドキュメントを確認してください。

  • ネットワーク帯域幅。

受信した VPIM メッセージは、ローカルの Unity Connection サーバーがメッセージの録音と再生に使用するのと同じ音声形式で保存されます。

複数の VPIM ブリッジヘッド

HTTPS ネットワークでは、ネットワーク内の複数の Unity Connection ロケーションを VPIM ブリッジヘッドとして指定できます。 HTTPS ネットワークに複数のブリッジヘッドを追加する方法は以下のとおりです。

  • 固有のダイヤル ID を使用すると、HTTPS 内の別の VPIM ブリッジヘッドに別の VPIM サーバーを追加できます。

  • 固有であるが null リモート電話機プレフィックスのダイヤル ID と固有のダイヤル ID を使用すると、複数の VPIM ブリッジヘッドに同じ VPIM サーバーを追加できます。

  • 固有のリモート電話機プレフィックスを使用すると、同じ VPIM ブリッジヘッドに、何度も同じ VPIM サーバーを追加できます。 ただし、リモート電話機プレフィックスを使用しないで、VPIM サーバーがすでに VPIM ブリッジヘッドとして Cisco Unity Connection に追加されており、一部の電話機プレフィックス (Null 以外の値) を使用して、VPIM ブリッジヘッドとして同じ VPIM サーバーを同じ Cisco Unity Connection ロケーションまたは別の Unity Connection ロケーションに追加する場合は、次の手順を実行する必要があります。

    リモート電話機プレフィックスなしで作成された既存の VPIM 連絡先をすべて手動で削除します。

    既に接続されている VPIM ロケーションのリモート電話プレフィックスを変更します。

    同じ VPIM ロケーションを、異なるリモート電話プレフィックスを持つ VPIM ブリッジヘッドとして、別の Unity Connection ロケーションまたは同じ Unity Connection ロケーションに追加します。

    VPIM サーバーから Unity Connection ロケーションに連絡先をプッシュします。