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Real-Time Monitoring の設定

この章では、Cisco Unified Presence Server Real-Time Monitoring Tool（RTMT）を設定する手順につ

いて説明します。この章は、次の項で構成されています。 

（注） 現在のバージョンの Cisco Real-Time Monitoring Tool で使用可能なオプションの一部は、Cisco Unified
Presence Server Release 1.0（3）に適用されません。

• Real-Time Monitoring Tool（RTMT）のインストール（P.7-2）

• RTMT のアップグレード（P.7-3）

• RTMT のアンインストール（P.7-4）

• RTMT の使用（P.7-5）

• 電子メール通知の設定（P.7-7）

• 構成プロファイルの操作（P.7-8）

• 事前定義オブジェクトの操作（P.7-10）

• デバイスの操作（P.7-13）

• 参考情報（P.7-16）

ヒント アラート、パフォーマンス モニタリング、トレース収集、Syslog Viewer の設定については、P.7-16 の

「参考情報」を参照してください。
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Real-Time Monitoring Tool（RTMT）のインストール
RTMT は、800*600 以上の解像度で動作し、Windows 98、Windows XP、Windows 2000、または Red

Hat Linux with KDE や Gnome クライアントにインストールできます。 

（注） Microsoft Windows で稼働する Cisco Unified CallManager サーバと連携するように RTMT がすでにイ

ンストールされている場合、Cisco Unified Presence Server 1.0 対応の RTMT をローカル コンピュー

タの別のフォルダにインストールする必要があります。 

ツールをインストールするには、次の手順を実行します。

手順

ステップ 1 Cisco Unified Presence Server の管理ページで、［アプリケーション］>［プラグイン］の順に選択します。

ステップ 2 ［検索］ボタンをクリックします。

ステップ 3 Cisco Unified Presence Server Real-Time Monitoring Tool の［ダウンロード］リンクをクリックします。

ステップ 4 実行ファイルを適切な場所にダウンロードします。

ステップ 5 デスクトップに表示された RTMT アイコンをダブルクリックするか、ファイルのダウンロード先の

ディレクトリから RTMT インストール ファイルを実行します。

抽出プロセスが開始されます。

ステップ 6 RTMT welcome ウィンドウで Next をクリックします。

ステップ 7 ライセンス契約書に同意するには、Yes をクリックします。

ステップ 8 RTMT のインストール先を選択します。デフォルト以外の場所にインストールする場合は、Browse

をクリックし、別の場所に移動します。Next をクリックします。

ステップ 9 インストールを開始するには、Next をクリックします。

設定状況に関するウィンドウが表示されます。Cancel をクリックしないでください。

ステップ 10 インストールを完了するには、Finish をクリックします。

追加情報

P.7-16 の「関連項目」を参照してください。
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RTMT のアップグレード
ツール（RTMT）を使用すると、ユーザ プリファレンスやダウンロードされたモジュールの jar ファ

イルは、クライアント マシンにローカルに保存されます。システムはプロファイルを Cisco Unified

Presence Server データベースに保存するので、RTMT のアップグレード後もこれらの項目に RTMT

でアクセスできます。

ヒント 互換性を確保するため、クラスタ内のすべてのサーバ上で Cisco Unified Presence Server をアップグ

レードした後に RTMT をアップグレードすることをお勧めします。

RTMT をアップグレードするには、次の手順を実行します。

手順

ステップ 1 Cisco Unified Presence Server の管理ページで、［アプリケーション］>［プラグイン］の順に選択します。

ステップ 2 ［検索］ボタンをクリックします。

ステップ 3 Microsoft Windows オペレーティング システムを実行しているコンピュータに RTMT ツールをイン

ストールする場合は、Cisco Unified CallManager Real-Time Monitoring Tool-Windows の［ダウンロー

ド］リンクをクリックします。Linux オペレーティング システムを実行しているコンピュータに

RTMT ツールをインストールする場合は、Cisco Unified CallManager Real-Time Monitoring Tool-Linux

の［ダウンロード］リンクをクリックします。

ステップ 4 実行ファイルを適切な場所にダウンロードします。

ステップ 5 デスクトップに表示された RTMT アイコンをダブルクリックするか、ファイルのダウンロード先の

ディレクトリから RTMT インストール ファイルを実行します。

抽出プロセスが開始されます。

ステップ 6 ［Real Time Monitoring Tool の InstallShield ウィザードへようこそ］ウィンドウで Next をクリックし

ます。

ステップ 7 アップグレードの場合はインストール先を変更できないので、Next をクリックします。

設定状況に関するウィンドウが表示されます。Cancel をクリックしないでください。

ステップ 8 インストール完了ウィンドウで Finish をクリックします。

追加情報

P.7-16 の「関連項目」を参照してください。
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RTMT のアンインストール
Windows クライアントで RTMT をアンインストールするには、［コントロール パネル］の［アプリ

ケーションの追加と削除］を使用します（［スタート］>［設定］>［コントロール パネル］>［ア

プリケーションの追加と削除］）。

KDE や Gnome クライアントを使用した Red Hat Linux で RTMT をアンインストールするには、タ

スクバーから Start > Accessories > Uninstall Real-time Monitoring tool の順に選択します。

追加情報

P.7-16 の「関連項目」を参照してください。
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RTMT の使用

開始する前に

RTMT を使用する前に、クラスタ内の各ノードで Cisco AMC Service をアクティブにする必要があ

ります。Cisco Unified Presence Server Serviceability から Tools > Service Activation の順に選択し、

Cisco AMC Service チェックボックスをオンにします。Update をクリックします。

手順

ステップ 1 プラグインをインストールした後、次のいずれかの操作を実行します。

• Windows デスクトップで、Cisco Unified CallManager Real-Time Monitoring Tool アイコンをダ

ブルクリックします。

• ［スタート］>［プログラム］> Cisco CallManager Serviceability > Real-Time Monitoring Tool >
Real-Time Monitoring Tool の順に選択します。

Real-Time Monitoring Tool Login ウィンドウが表示されます。 

ステップ 2 Host IP Address フィールドに、ファースト ノードの IP アドレスまたはホスト名を入力します。

ステップ 3 User Name フィールドに、CCMAdministrator アプリケーションのユーザ名を入力します。たとえば、

このユーザのデフォルトのユーザ名は、CCMAdministrator です。

ステップ 4 Password フィールドに、CCMAdministrator アプリケーションのユーザ名に対応するユーザ パスワー

ドを入力します。

（注） 認証に失敗した場合、またはサーバに到達できない場合は、サーバと認証の詳細を再入力

するように求められます。また、Cancel ボタンをクリックして、アプリケーションを終了

することもできます。認証に成功した場合は、RTMT により、ローカル キャッシュまたは

リモート ノードからモニタリング モジュールが起動されます。リモート ノードは、バック

エンドの Cisco Unified Presence Server バージョンと一致するモニタリング モジュールが

ローカル キャッシュに含まれていない場合に使用されます。

ステップ 5 アプリケーションがサーバのリッスンに使用するポートを入力します。デフォルト設定は 8443 で

す。

ステップ 6 Secure Connection チェックボックスをオンにします。

ステップ 7 OK をクリックします。

ステップ 8 Yes をクリックして、証明書ストアを追加します。

ステップ 9 RTMT で実行できる操作については、次のリストを参照してください。

• 電子メール アラートのためのメール サーバを設定する場合は、P.7-7 の「電子メール通知の設

定」を参照してください。

• 構成プロファイルを作成する場合は、P.7-8 の「構成プロファイルの追加」を参照してください。

• 事前定義オブジェクトをモニタする場合は、P.7-10 の「事前定義オブジェクトの操作」を参照

してください。
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• デバイスを操作する場合は、P.7-13 の「デバイスの操作」を参照してください。

• アラートを操作する場合は、P.8-1 の「RTMT でのアラート設定」を参照してください。

• パフォーマンス モニタリング オブジェクトを操作する場合は、P.9-1 の「パフォーマンス モニ

タリングの設定と使用」を参照してください。

• トレースを収集して表示する場合は、P.10-1 の「RTMT の トレース収集とログ集中管理」を参

照してください。

• SysLog Viewer を使用する場合は、P.11-1 の「RTMT SysLog Viewer の使用」を参照してください。

• RTMT のトレース設定値を設定する場合は、Edit > Trace Setting の順に選択します。適切なオ

プション ボタンをクリックします。

• ウィンドウの左側に表示される Quick Launch Channel ペインを非表示にするには、Edit > Hide
Quick Launch Channel の順に選択します。

一度非表示にした Quick Launch Channel を表示するには、Edit > Hide Quick Launch Channel の
順に選択します。

• 1 つのモニタリング ウィンドウを閉じるには、Window > Close の順に選択します。表示されて

いるすべてのモニタリング ウィンドウを閉じるには、Window > Close All Windows の順に選択

します。

• RTMT ウィンドウから Cisco Unified Presence Server の管理ページまたは Cisco Unified Presence
Server Serviceability にアクセスするには、Application > CCMAdmin webpage（または CCM
Serviceability webpage）の順に選択します。

• RTMT から Serviceability Report Archive オプションにアクセスするには、System > Report
Archive の順に選択します。［セキュリティの警告］ウィンドウが表示されたら、［はい］をク

リックします。サーバの管理ユーザ名とパスワードを入力し、OK をクリックします。

• インストールされている RTMT のバージョンを確認するには、Help > About の順に選択しま

す。バージョン情報がウィンドウに表示されます。情報を確認したら、OK をクリックします。

• RTMT のマニュアルにアクセスするには、Help > Help Topics（または For this Window）の順

に選択します。RTMT または Cisco Unified Presence Server Serviceability の詳細については、『Cisco
Unified CallManager Serviceability システムガイド』および『Cisco Unified Presence Server サービ
スアビリティ アドミニストレーション ガイド』を参照してください。

• JVM 情報をモニタするには、System > JVM Information の順にクリックします。JAVA ヒープ

メモリの使用状況がウィンドウに表示されます。OK をクリックします。

• RTMT からログアウトするには、System > Log Off の順に選択します。この操作を実行すると、

現在のユーザがログオフされ、Real-Time Monitoring Tool Login ウィンドウが表示されます。 

• アプリケーションを終了するには、System > Exit の順に選択します。この操作を実行すると、

アプリケーションが終了します。

追加情報

P.7-16 の「関連項目」を参照してください。



第 7 章      Real-Time Monitoring の設定

  電子メール通知の設定

7-7
Cisco Unified Presence Server サービスアビリティ アドミニストレーション ガイド

OL-11383-01-J

電子メール通知の設定
電子メール通知を設定するには、次の手順を実行します。

手順

ステップ 1 Mail Server フィールドに、電子メールの受信者の情報を入力します。

ステップ 2 Port フィールドに、メール サーバのポート番号を入力します。

ステップ 3 OK をクリックします。

追加情報

P.7-16 の「関連項目」を参照してください。
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構成プロファイルの操作
この項では、次のトピックについて取り上げます。

• デフォルトの構成プロファイルの使用（P.7-8）

• 構成プロファイルの追加（P.7-8）

• プロファイルの復元（P.7-9）

• 構成プロファイルの削除（P.7-9）

デフォルトの構成プロファイルの使用

RTMT を初めてロードすると、CM-Default という名前のデフォルト設定が適用されます。RTMT を

初めて使用すると、CM-Default プロファイルが使用され、モニタ ペインに要約ページが表示され

ます。 

独自の構成プロファイルを作成する方法については、P.7-8 の「構成プロファイルの追加」を参照

してください。

追加情報

P.7-16 の「関連項目」を参照してください。

構成プロファイルの追加

RTMT で複数のモニタリング ウィンドウ（CPU & Memory やパフォーマンス カウンタなど）を開

いた後、独自の構成プロファイルを作成すると、これらのウィンドウを個別に開かなくても 1 つの

操作でこれらのモニタリング ウィンドウを復元できます。同じ RTMT セッションで複数の異なる

プロファイルを切り替えたり、後続の RTMT セッションで同じプロファイルを使用したりすること

もできます。 

プロファイルを作成する手順は、次のとおりです。

手順

ステップ 1 System > Profile の順に選択します。

Preferences ダイアログボックスが表示されます。

ステップ 2 Save をクリックします。

Save Current Configuration ダイアログボックスが表示されます。

ステップ 3 Configuration name フィールドに、この構成プロファイルの名前を入力します。

ステップ 4 Configuration description フィールドに、この構成プロファイルの説明を入力します。

（注） 構成プロファイルの名前と説明は任意に入力できます。
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新しい構成プロファイルが作成されます。

追加情報

P.7-16 の「関連項目」を参照してください。

プロファイルの復元

構成済みのプロファイルを復元するには、次の手順を実行します。

手順

ステップ 1 System > Profile の順に選択します。

Preferences ダイアログボックスが表示されます。

ステップ 2 復元するプロファイルをクリックします。

ステップ 3 Restore をクリックします。

復元された構成に対する、あらかじめ用意されている設定やパフォーマンス モニタリング カウン

タのすべてのウィンドウが開きます。

追加情報

P.7-16 の「関連項目」を参照してください。

構成プロファイルの削除

構成済みのプロファイルを削除するには、次の手順を実行します。

手順

ステップ 1 System > Profile の順に選択します。

Preferences ダイアログボックスが表示されます。

ステップ 2 削除するプロファイルをクリックします。

ステップ 3 Delete をクリックします。

ステップ 4 Close をクリックします。

追加情報

P.7-16 の「関連項目」を参照してください。
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事前定義オブジェクトの操作
ツール（RTMT）には、システムの状況をモニタするデフォルトのモニタリング オブジェクトの

セットが用意されています。デフォルト オブジェクトには、パフォーマンス カウンタや Cisco

Unified Presence Server でサポートされているサービスについての重要なイベント ステータスが含

まれています。 

この項では、次のトピックについて取り上げます。

• 事前定義オブジェクトの表示とモニタリング（P.7-11）

• デバイスの操作（P.7-13）
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事前定義オブジェクトの表示とモニタリング
カテゴリ（つまり、事前定義オブジェクト）のモニタリング ペインには、事前定義モニタリング

オブジェクトのアクティビティが表示されます。カテゴリの情報を表示する手順は、次のとおりで

す。

手順

ステップ 1 カテゴリを表示またはモニタするには、次のいずれかの操作を実行します。

• Quick Launch Channel で View タブをクリックします。次に、Summary、Server、Call Process な
どのカテゴリをクリックします。カテゴリのアイコンが表示されている場合は、アイコンをク

リックして、モニタする情報を表示します。

（注） 現在のバージョンの RTMT にあるオプションの一部は、Cisco Unified Presence Server に
適用されません。

• 表示するカテゴリに応じて、次の 表 7-1 から、いずれかのオプションを選択します。

表 7-1 カテゴリのメニュー パス

カテゴリ メニュー パス 表示されるデータ

Summary Monitor > Summary

（注） 現在のバージョンの RTMT にあるオプションの一部は、
Cisco Unified Presence Server に適用されません。

メモリと CPU の使用状況を表示します。

Server Monitor > Server > CPU and Memory

（または Process、Disk Usage、

Critical Services）

• CPU and Memory：メモリと CPU の使用状況を表示します。

• Process：プロセス名、プロセス ID（PID）に加え、プロセス、

常駐メモリ、共有メモリ、および Nice（レベル）によって使用

されている CPU とメモリの割合を表示します。

• Disk Usage：各ホストの最大パーティションで使用されている

ディスク容量の割合を表示します。

• Critical Services：特定のサーバのサービスを表示します。

Service Monitor > Service > Cisco TFTP（ま

たは Heartbeat、Database Summary）

• Cisco TFTP：クラスタ内の各 Cisco Unified Presence Server サー

バの Cisco TFTP ステータスを表示します。TFTP 要求合計、検

出された TFTP 要求合計、中止された TFTP 要求合計などの項

目が含まれます。

• Heartbeat：Cisco Unified Presence Server、Cisco TFTP、Cisco
Presence Server Attendant Console サービスのハートビート情報

を表示します。

• Database Summary：Cisco Unified Presence Server 上のデータベー

スに関する要約情報を表示します。データベースのキューに登

録された接続要求、メモリのキューに登録された接続要求、接

続されたクライアントの合計数、およびキュー登録中にリセッ

トされたデバイスの数などの項目が含まれます。

Performance Performance > Open Performance perfmon カウンタを表示します。 

perfmon カウンタの使用方法の詳細については、P.9-1 の「パフォー

マンス モニタリングの設定と使用」を参照してください。
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ステップ 2 一部のカテゴリでは、特定のサーバやデバイス タイプを選択してモニタできます。特定のサーバや

デバイス タイプを選択してモニタするには、表示されたペインで次のいずれかの操作を実行しま

す。

• CPU and Memory Usage ペイン：特定のサーバの CPU やメモリの使用状況をモニタするには、

Host ドロップダウン リスト ボックスからサーバを選択します。

• Disk Usage ペイン：特定のサーバのディスク使用状況をモニタするには、Host ドロップダウン

リスト ボックスの Disk Usage からサーバを選択します。

• Critical Services ペイン：特定のサーバの重要なサービスをモニタするには、Host ドロップダウ

ン リスト ボックスの Critical Services からサーバを選択します。

（注） 現在のバージョンの RTMT にあるオプションの一部は、Cisco Unified Presence Server に適用されま

せん。

追加情報

P.7-16 の「関連項目」を参照してください。
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デバイスの操作

（注） 現在のバージョンの RTMT にある Device のオプションは、Cisco Unified Presence Server に適用され

ません。

電話機情報の表示

（注） 現在のバージョンの RTMT にある Phone Information のオプションは、Cisco Unified Presence Server
に適用されません。

デバイスのプロパティの表示

（注） 現在のバージョンの RTMT にある Device Properties のオプションは、Cisco Unified Presence Server
に適用されません。

ポーリング レート パフォーマンス モニタリング カウンタの設定

（注） 現在のバージョンの RTMT にあるオプションの一部は、Cisco Unified Presence Server に適用されま

せん。

Cisco Unified Presence Server は、カウンタをポーリングしてステータス情報を収集します。RTMT

monitoring ペインでは、パフォーマンス モニタリング カウンタのポーリング間隔を設定します。

（注） ポーリング レートの頻度を高くすると、Cisco Unified Presence Server のパフォーマンスに悪影響を

及ぼすことがあります。図形式でパフォーマンス カウンタをモニタする場合、最小ポーリング レー

トは 5 秒です。表形式で パフォーマンス カウンタをモニタする場合、最小レートは 1 秒です。デ

フォルト値はいずれも 10 秒です。 

デバイスのデフォルト値は 10 分です。

ポーリング レートを更新するには、次の手順を実行します。

手順

ステップ 1 RTMT monitoring ペインに、パフォーマンス モニタリング カウンタを表示します。

ステップ 2 デバイスをクリックし、Edit > Polling Rate の順に選択します。



第 7 章      Real-Time Monitoring の設定

  デバイスの操作

7-14
Cisco Unified Presence Server サービスアビリティ アドミニストレーション ガイド

OL-11383-01-J

ステップ 3 Polling Interval ペインで、使用する時間間隔を指定します。

ステップ 4 OK をクリックします。

追加情報

P.7-16 の「関連項目」を参照してください。
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カテゴリの操作

（注） 現在のバージョンの RTMT にあるオプションの一部は、Cisco Unified Presence Server に適用されま

せん。

カテゴリを使用すると、パフォーマンス モニタリング カウンタをモニタできます。たとえば、Cisco

UPS SIP Proxy カテゴリでは、SIP プロキシのパフォーマンス モニタリング カウンタをグラフ形式

でモニタできます。それ以上のカウンタを使用する場合は、新しいカテゴリを設定して、データを

表形式で表示できます。

カテゴリの追加

カテゴリを追加するには、次の手順を実行します。

手順

ステップ 1 Performance Monitoring または Devices ツリー階層を表示します。

ステップ 2 Edit > Add New Category の順に選択します。

ステップ 3 カテゴリ名を入力し、OK をクリックします。

ウィンドウの下部に、カテゴリのタブが表示されます。

追加情報

• P.7-16 の「関連項目」を参照してください。

カテゴリ名の変更

カテゴリ名を変更するには、次の手順を実行します。

手順

ステップ 1 次のいずれかの操作を実行します。

• 名前を変更するカテゴリのタブを右クリックし、Rename Category を選択します。

• 名前を変更するカテゴリのタブをクリックし、Edit > Rename Category の順に選択します。

ステップ 2 新しい名前を入力し、OK をクリックします。

ウィンドウの下部に、変更後のカテゴリ名が表示されます。

追加情報

• P.7-16 の「関連項目」を参照してください。
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カテゴリの削除

カテゴリを削除するには、次のいずれかの操作を実行します。

• 削除するカテゴリのタブを右クリックし、Remove Category を選択します。

• 削除するカテゴリのタブをクリックし、Edit > Remove Category の順に選択します。

追加情報

P.7-16 の「関連項目」を参照してください。

参考情報
• RTMT でのアラート設定（P.8-1）

• パフォーマンス モニタリングの設定と使用（P.9-1）

• RTMT の トレース収集とログ集中管理（P.10-1）

追加情報

P.7-16 の「関連項目」を参照してください。

関連項目
• カテゴリの追加（P.7-15）

• カテゴリ名の変更（P.7-15）

• カテゴリの削除（P.7-16）

• パフォーマンス モニタリングの設定と使用（P.9-1）

• デバイスの操作（P.7-13）

• デバイスのプロパティの表示（P.7-13）

• 電話機情報の表示（P.7-13）

• ポーリング レート パフォーマンス モニタリング カウンタの設定（P.7-13）

• デフォルトの構成プロファイルの使用（P.7-8）

• プロファイルの復元（P.7-9）

• デフォルトの構成プロファイルの使用（P.7-8）

• 構成プロファイルの削除（P.7-9）

• 構成プロファイルの追加（P.7-8）

• 構成プロファイルの操作（P.7-8）

• 事前定義オブジェクトの操作（P.7-10）

• RTMT でのアラート設定（P.8-1）

• パフォーマンス モニタリングの設定と使用（P.9-1）

• RTMT SysLog Viewer の使用（P.11-1）

• Real-Time Monitoring Tool（RTMT）のインストール（P.7-2）

• RTMT のアンインストール（P.7-4）

• RTMT のアップグレード（P.7-3）

• RTMT の使用（P.7-5）
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