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show image integrity 1Y > R
show filesystems 1Y > K
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AP Image PreDownload
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+ Catalyst 9800-CL, Cisco IOS® XE 17.15.3
- Catalyst 91627 JEARA > ~
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CORFIXVNORRE. REDFARELCHAZTNARACETVWTERENELEZ, DR
FAXKNTEATDIIXNTOTFNAAGR, JUTBE(T7FIIN ) RETERZRHKLTLE
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<EEL,

APO7—K70O€A
u7—~h
U-BoothEE> —T > A

Cisco APlF, X4 > COSY I )DHICETENDUBOOTE—RT7/—N7TOCRAERBLET
o U-BOOTE—RIZCTBICIE., "OFE=ZHEIELET,
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EAPASHAEThBEVEERE, R—L—KZ9600ICEHREL XTI,

4 APICERZERLET,
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U-Boot 2013.01-gelc49d93a (Jul 28 2023 - 09:08:14) SDK version: 2015_T2.0pl0

Board: Barbados-3K
SoC: MV88F6920 Rev Al
running 2 CPUs
CPU: ARM Cortex A9 MPCore (Rev 1) LE

CPU O
CPU @ 1800 [MHz]
L2 @ 900 [MHz]

TClock @ 250 [MHz]

DDR4 @ 900 [MHz]

DDR4 32 Bit width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM: 1 GiB

RST I2CO

NAND: ECC 4bits, 256 MiB

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB

PCI-e 1 (IF O - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 2 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 2.0

Map : Code: 0x3fed7000: 0x3ffad848
BSS: 0x3ffef314
Stack: 0x3f9c6f20
Heap: 0x3f9c7000: 0x3fed7000
U-Boot Environment: 0x00100000:0x00110000 (SPI)

Board configuration:
| port | Interface

I
| egigal | SGMII 0x01 |
| egigaz | SGMII | In-Band |
Net: egigal. eqgigaz? [PRTIME]

Hit ESC key to stop autoboot: O]
U-boot>>

U-Booti2 B &I H

U-BootE— RA SprintenvIN > RZEFEHAL T, FO9EVARSA D MOEEFETFU-BootIRE D FF
Mz—8ERRLET,



BOOT=part
CASset=max
ENABLE_BREAK=1
FACTORY_RESET=0
MALLOC_ len=5
MANUAL_BOOT=0
MEMORY_DEBUG=0
MPmode=SMP
PART_BOOTCNT=3

autoload=yes
baudrate=9600

COEDEE, T—MNN—F 423 pat1 THDEEZRLTVET, COT—NN—F 1> 3
>~ EU-Boot modW TEETEE T,

U-Boot7 —hN—F 123> DEE
1. setenve BOOT part <1-2>X¥ > RZFERAL T, BEODT—MN—F 123 =2hABLET

2.saveenv N> REFERLT, N—7123a>0HABZRELET,
3.printenvIY > REFAL T, BEOT/—NN—FT 123> =®AELET,



u-boot>> setenv BOOT part 2

u-boot>> saveenv

Saving Environment to SPI Flash...

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB
Erasing SPI flash....Writing to SPI flash..... done
u-boot>> printenv

BOOT=part 2

4. boot AN RZEFEALT, HLLERELET—MNN—TF

u-boot>> boot

Creating 1 MTD partitions on "nand0":
0x000000200000-0x000010000000 : "mtd=2"
UBI: attaching mtdl to ubiO

ubifsmount - mount UBIFS volume

Usage:
ubifsmount

- mount 'volume-name' voTlume
UnabTle to ubi mount UBIFS partition part 2
Trying alternate partition part2
UBIFS: mounted UBI device 0, volume 0, name "part2"

~

P4

ATAPZEFHLFT,

5 BRUIET—MN—TFT14232h8T7OEARANET—MLET,

cCos> Tl

APT 7 AN ATLFIYVY



TV TYIL—ROBIICAPEYO—REBEEMBLET, Chilckl), Ty 7Y
L—ROHIC, F¥Y21EchhTWVWBIXRNTOT7AI)N: SATFLZEHL, —BET7
AINET75Y>21TEXT,

AP®DCLIA SPrivilegedmodelc AY), RODONY RERITUTHEDAPA X—J EtmpT a1 L U
NUS A XEHBRELET,

show image integrity 1< > R

COHENE. APOREON—23 2 ZRLET,
TZARIN=—TF1423>0ON—=23a2EFk, BEOAPO/—MN—23 2 RLET,
Backup partition versionld, APD/)NY O F7 Y TN—23 2 #RLET,

AP-CW9162#show image integrity
/partl(primary) 17.15.3.28



part.bin : Good
ramfs_data_cisco.squashfs : Good
iox.tar.gz : Good

/part2(Backup) 17.9.6.40
part.bin : Good
ramfs_data_cisco.squashfs : Good
iox.tar.gz : Good

bold XY REMFATDE, BEDAPT/—MN—23 %YW EBZZENTEET, XED
APUO—R&BIZ, BIRLEN—FT 13 >TAPAY T —KRLZET,

T—MNAIDKRE (partt/N— 3 TAPET —R )
Fil&

T —RNAR2MRE (part2/N\—2 3 TAPE T —N)
show filesystems 1Y > R

HAOE, APOT77ALNATLBEZRLTVERT,



7 :Mounted onBI D AmpDITIZlE. APF7 Y 7L —RADAPA X—SARNL—DICEH
ENBTT7ANATLAIRNINRENRTVET,

<#root>

AP-CW9162#show filesystems

Filesystem Size Used Available Use% Mounted on
none 114. 4M 4. 7M 109.7M 4% /tnp

AP tmp7 7AND AT LADG A XAHF10 MU LETHBDENEBETY, tmp7 7A LI AT LR
APAX=DOT VT IL—REREFEITRILEHICEAETINET,



FEMmp 7 7P AN AT LI MUAM100MA ETEWVEE
FTEBAPAA—DEBEANRETDARMEA BN KT N—FT 1232 ZHRITZDEE

IN=TFTA42aVICHLTKRE

DAPA X—T A2 O—RAXZE/EAL T, APEN—23M1766ICT7Y7TIL—RT

PHENBHNET,

AP7Y 7 JL—R/NA

Cisco APIZIE, BESRVBWEDN—TJAVICEITBIREOT Y TIL—RNANFBETT,
NDHA4 RTE, CiscolOS XEN—2 32171632 EALET,
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Upgrade Path to Cisco |10S XE 17.15.x

Table 15, Upgrade Path to Cisco 105 XE Dublin 17.15.x {(where x = 1)

Current Software

16.10.x

16.11.%

16.12.x

17.1.x

17.2.x

173110 17.3.4

17.3.4c or later

17.4.x

17.5.x

17.6.x

17.7.%

17.8.x

17.9.110 17.9.5

17.9.6 or later

17.10.x

17.11.x

17.12.x
17.13.%
17.14.x

8.9.x or any 8.10.x version prior to
8.10.171.0

17A5XANDT Y 79 L—RINA

3. TCiscoDA VLAYV A—=23 YT RIIFTEBUINI DA, 2, BIRL EN—

Upgrade Path for Deployments with

9130 0r 9124

Upgrade first to 17.3.5 or later or 17.6.x
or later, then to 17.9.6 or later or 17.12.x

or later, and then to 17.15.x.

Upgrade first to 17.3.5 or later, then to
17.9.6 or later or 17.12.% or later, and

then to 17.15.x.

Upgrade first to 17.3.5 or later, then to
17.9.6 or later or 17.12.x or later, and

then to 17.15.x.

Upgrade first to 17.3.5 or later or 17.6.x
or later, then to 17.9.6 or later or
17.12.x or later, and then to 17.15.x.

Upgrade to 17.9.6 or later or 17.12.x or

later, and then to 17.15.x.

Upgrade first to 17.6.x and then to

17.15.x.

Upgrade first to 17.6.x and then to

17.15.x.

Upgrade to 17.9.6 or later or 17.12.x or

later, and then to 17.15.x.

Upgrade to 17.9.6 or later or 17.12.x or

later, and then to 17.15.x.

Upgrade to 17.9.6 or later or 17.12.x or

later, and then to 17.15.x.

Upgrade to 17.9.6 or later or 17.12.x or

later, and then to 17.15.x

Upgrade directly to 17.15.x

Upgrade te 17.12.x or later, and then to

17.15.x

Upgrade to 17.12.x or later, and then to

17.15.x
Upgrade directly to 17.15.x
Upgrade directly to 17.15.x

Upgrade directly to 17.15.x

Upgrade first to 8.10.171.0 or later,
17.3.5 or later or 17.6.% or later, then to
17.9.6 or later or 17.12.x or later, and
thento 17.15.x

Upgrade Path for Deployments

Without 9130 or 9124

Upgrade first to 16.12.5 or 17.3.x and

then to 17.15.%.

Upgrade first to 16.12.5 or 17.3.x and

then to 17.15.x.

Upgrade first to 17.3.5 or later or 17.6.x

or later, and then to 17.15.x.

Upgrade first to 17.3.5 or later and then

to 17.15.x.

Upgrade first to 17.3.5 or later and then

to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x.

Upgrade directly to 17.15.x

Upgrade directly to 17.15.x

Upgrade directly to 17.15.x

Upgrade directly to 17.15.x

Upgrade directly to 17.15.x
Upgrade directly to 17.15.x
Upgrade directly to 17.15.x

Upgrade directly to 17.15.x.

EEBMDOBHBIAPETFILARENTVET,
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Table 5. Cisco Catalyst 9800 Wireless Controller and Supported Access Points
10S XE Release Access Point Image Access Point Supported Access Points

Version Number Release



isco [0S XE 17.15.3.28 15.3(3)JPT2 Cisco Wireless Wi-Fi 7 APs: 9176 (I/D1),
17.15.3 9178l, 9172(1)
Cisco Catalyst Wi-Fi 6E APs: 9136 (1)

(1), 9163 (E), 9164 (1), 9166 (I/D1)

Cisco Catalyst Wi-Fi 6 APs: 9105AX (I/W),
9115AX (I/E), 9117AX (1), 9120AX (I/E/P),
9130AX (I/E)

Cisco Aironet APs: 1815 (I/W/M/T), 1830
(1),1840 (1), 1852 (I/E), 1800i, 2800 (I/E),
3800 (I/E/P), 4800 (1)

Outdoor and Industrial APs: 1542, 1560,
1570, and IW3702

Integrated Access Point in Cisco 1100 ISR
(ISR-AP1100AC, ISR-AP1101AC, and ISR-
AP1101AX)

Cisco Catalyst Industrial Wireless 6300
Heavy Duty Series Access Point, Cisco 6300
Series Embedded Services Access Point,
Cisco Catalyst 9124AX (I/D/E) Access
Points, Cisco Catalyst Industrial Wireless
9167 (I/E) Heavy Duty Access Points, Cisco
Catalyst IW9165D Heavy Duty Access Points,
Cisco Catalyst IW9165E Rugged Access
Points

Sensors: Cisco Aironet 1800s Active Sensor
Pluggable Modules: Wi-Fi 6 Pluggable
Module for Industrial Routers

DA VLAEBEI NI Y U A17.15.3

4. V7 R ITF7RAIO0—RWebR—D ZRALTT7Y TSI L—RNY =228 L, APA X
—NAIO—RAX (BRODODADIO—RAR ) ICEKET,

APA X—OA D O—REZE
9800 WLCZFEHALTAPE 7Y IJL—RLET, cOZ7OEAICIE. 98005 ¥ —< TDCisco

IOSXE7 Y 7JL—ROAIO—RE, MALETIOEARAD MDA X—=TH D2 O—R
DHRBAEENET,

APAX—=C%TYTIL—RTIBICE, APAX—2OT7 LA O—REBEWLCOT Y 7Y
L—=R®D2DODFEENBHYET,
« APAX=2O7LADO0—R:APOUO—REINCAPAX =Y 7 NI T7%#7LO—R
TEEXT,
« EBEWLCTYTYL—RKRTR. WCTOTFTYTYL—RARETL, WLCEUO—RLTAH
5, APIIAZOEATAPAFHLWNN—2a3a > &#ADO0—-RLET,

AP Image PreDownload
GUUZ & BDAPA XA—DO7LAD>O—R

1. 2AAVYIRDIFTEIVO—RYA N (BFI—HEH ) HSHEECisco I0S XEA X
—IN=23a eI O0-RLET,
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2. Web GUITWLCICCisco IOS XEA/ X—2 T Y 70— KL EF, Administration > Software
Management > Software Upgrade > Source File Path > Select File > Select the 9800
Upgrade File to be uploaded to the controller.

n Wl Gisco Catalyst 9800-CL Wireless Controller

CIsco 17.15.3

Welcome cisco a A o n ® Z

_ Administration ~ > Software Management

Software
| Dashboard Upgrade
@ Monitoring Software H)gll-me INSTALL v
) i ode
MsiTienence Current Mode (until next reload): INSTALL
Upgrade (SMU)
Configuration
One-Shot C]
AP Service Install
rade (3)
Package (APSP) Upgrade (i)
. Transport My Desktop -
AP Device Type
Package (APDP)
File System bootflash - Free Space: 4203.53 MB
Source File
Path* & Select File

Y7 R I 7EEGUI
3. AP Image PredownloadiC F I ¥ X —VZANE T,

4. Download & Installz 2 Yy O L% 9,

halte - Cisco Catalyst 9800-CL Wireless Controller

CIsCo
Welcome cisco A4 € A DO e o Q = [
Administration = »  Software Management
Software There is an upgrade in progress. Please wait till it completes...
Upgrade
Software
Maintenance
Upgrade (SMU) Upgrade NSTALL Status
Mode
Current Mede (until next reload): INSTALL
£ e L.: D load | /Pack:
.’ 4.* Download Image/Package.
Pack; P ST
ackage (APSP) Transport vy Desktor [ Caa00-CL-universalkd.17.15.03.5PA.bin
Type
AP Device ? Install Image/Package
Package (APDP) File System bootflash Free Space: 4201.58 MB % AP Image Predownload
Source File o > Activate Image/Package
St *
Path ? Commit
[ C9800-CL-universalkd.1... 0%
AP Image B

Predownload
(i)




5.APiE. APAX—=I D7 LAVDVO—RARICHI>TTYTIL—RENET,
CLUIZRBDAPA X—=2 D7 LA D>O—R

1. O MNO—FA4X—2ZWLCICEMULTEBELET,

install add file bootflash:image.bin

2. FNTOAP, FREIMO—ZIEMALTVRHEDAPICAX =228 O—RLET

o

ap image predownload

TR

ap name

image predownload

3. INTOAPELERFBEDAPOAP LA O—ROAT—RAZERELET,

show ap image

FhE

show ap name

image



4. BRIZ I VO—RAZTETUETNTODAP, BEDAP, TERFAPOAX—EADY T ULET

o

ap image swap

FhlE

ap name

image swap

FhE

ap image swap completed

5 MLKAVARN=INUIEAX=2TO0T47ICLET, chiZky, WLCAUO—REh,
FLWAN—23 > TRBLET,

install activate

6. WLCH' A>T A4 TEIEABEICE 25, A X—JZBELET,

install commit

BEOWLCBITAPTY JJL—R
GUIZFERL EEBEDODWLCB KVDAPOT Y 7JL—R

1. 2ROV RDIFROVO—RY AN (BFI—HEH ) » SHBEZCisco I0S XEA X



https://software.cisco.com/download/home
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—ION=23 AV O0-RLET,

2. Web GUITWLCIZCisco IOS XEA/ X—2 &7 Y 70— R L% T, Administration > Software
Management > Software Upgrade > Source File Path > Select File > Select the 9800
Upgrade File to be uploaded to the controller.

n -'C|I'S'":|c')' Cisco Catalyst 9800-CL Wireless Controller
A Welcome cisco A € A o I I 2 IS

Administration * > Software Management

Software
Upgrade
Software Upgrade INSTALL v
Maintenance Mode . .
Current Mode (until next reload): INSTALL
Upgrade (SMU)
Configuration
/ One-Shot O
AP Service Install
rade (i)
Package (APSP) Upgrade (&)
) Transport My Desktop v
Licensing AP Device Type
Package (APDP)
File System bootflash v Free Space: 4203.53 MB

Troubleshooting

Source File :
Path* & Select File

V7 NI T TEEGUI

3.7Yv7O—RIBY—RT7ANZEBRL B, ——XICKEA&FT> 3> (Standard WLC
Upgrade = 7= (& AP Image Predownload ) Z3&RL £9,

4. Download and InstallZ 2 )Yy O L&,

5 EH/IN—HD100%ICEL, A X=—JINVT—DDA2ARN=—ILDAT—RAICELET,



Administration - > Software Management

Software
Upgrade
Software
Maintenance
Upgrade (SMU) Upgrade INSTALL
Mode
Current Mode (until next reload): INSTALL
AP Service
Package (APSP) One-Shot D
Install
AP Device Upgrade (i)
Package (APDP)
Transport My Desktop
Type
File System bootflash Free Space: 5691.86 MB
Source File 2
Path* v
[ C9800-CL-universalk8.1... 0%
AP Image O
Predownload
©

Hitless Software Upgrade (N + 1 Upgrade)

Enable O
Hitless
Upgrade

ZEWLCT Y TITL—R  AX=DDAV A=)

There is an upgrade in progress. Please wait till it completes...

Status

4. Download Image/Package.
(3 C2800-CL-universalkg. 17.15.03.SPA bin

? Install Image/Package
¥ Activate Image/Package

» Commit

[3 Show Logs

6. WLCHBRKF T Y U %REITL %, Save Configuration & ActivateZ 7)Y IV LET, ZhiC

KV, WLCA'UO—REh, HILLN—-T3>

TEBLERT,

7.WLCA'GUIZ T L TEBETREICZ 27125, PYTIL—RBEXN—JIVEHELET,




Administration - »  Software Management ‘ Click here for Latest Recommended Software

Software Upgrade

Software Maintenance Upgrade

(SMU) Upgrade Mode INSTALL - Current Mode (until next reload): INSTALL Manage
AP Service Package (APSP) 'BSZ r'as':i!‘é’%‘s‘a" ] .
AP Device Package (4PDP) Transport Type My Desktop -

File System bootflash - Free Space:; 1717.17 MB

Source File Path*

AP Image (m]

Predownload (0

Hitless Software Upgrade (N + 1 Upgrade)

Enabile Hitless ]
Upgrade

cor

7v7IL—kORE
CLICRBEEWLCH LK TAPTY T JL—K

1. AX=220> O—-ZICT7Y7O—RLEY,

copy tftp|ftp|sftp://

bootflash:

22 MO—FRAX=JZ4A2ARM—ILLET,

install add file bootflash:

BHLULWAX—ETOTATIZLET, chiZkly), WLCAUAO—REh, FILLON—=—3 >
TEBLET,



install activate

A WLCHFVTA 2 TEEAREICE 2125, I XA—DZBELET,

install commit

APA X—OFFHA D> O0—R

OV I—RFERY—NETCEBO TP ANS—NFTUT—Y a3V EALET, COT7
ANH—)NE, BET Y 7IL—RT7ALEAPLRETIH—/NTT,

1. 2ROV 7R8I 72O O0—RYABRASEBHODAPA X—N—23a #4020 0—R
LET,

2APYTIRNDITFI7ANEZT7FANG—NFTALIONJICRELET,

3.APOCLINS 7 7ANDT Y7L —RZBHETSICIE, archive download-swIY > R%
FERALET,



https://software.cisco.com/download/home

> : archive download-swN > RTHERATE D EESZEEE. TFTIPBKRUSFTPICREE
nNTVWET

#archive download-sw /reload

://[your TFTP server's IP address]/[image filename.tar]

4. AP, BRIZHST, 77A4NT—NDS5tar7 Yy 7IL—RI77A4I\LEXIO-RLET
o CHhIZIKE, APET7AILNY—NBOEEREICKHLUT, H2BREORENDPLYET,

5 77T ANEBEANTT IR E, APEFILK A DVO—RULEAPAX—=JZBENICUO—RL
. 7—RhLET,



7E:archive download-sw Y > RAAPTE T AN S i WES . debug capwap
console clid~N > R%& AL Tarchive download-sw N> RZBEMICLET

RS

APOT Y7L —R7OANETLES, AR RZFEHAL T, APON—232, A X—=2
NEEM, BREFT—NNN—F 123> &EIELET,

1.APON—2 32 2B LK,

show version

2. AX—=NEEMERIBLED,



show image integrity

3. 7—MN—FT 14> 3> z®AELET,

show boot

BYIE 5 ¥

« U-booth & MC9120/C9115T7 V2 ARA > K DBE
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