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« Web Cache Communication Protocol ( WCCP ) /N\—>3 2 2 (v2)
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axX AE

Web Cache Communication Protocol(WCCP)l&, WebhZ 7 1 v O &F+ v 1H—/NICUXA
LOKNIBEHICHERENET, —MKRIC, HTTP, HTTS, B KU FTD over HTTPEXR Z 7' OF >
H—NIZURALIORNTBEDHIZ, Cisco)l—BERTFATIF=IIBEDRY NTD—DFNA A
ICREEIhET,

WCCPIE, WCCP V1, v2, BLTVIZEULEXETEBN—IJIVTHEATE, FN—23 2 THE
fLEhiBEEE AT —ZEVT 1 2RHELFT,

fH4H

o A—HYZ2Win10-0AHTTPSERZ1TVWE T,

« ZCT, FID77AT7 04— )LEI1—YPCOT—KRIIATT, HTTP/HTTPSERZZ(E
LET,

« FIDREER—KH443THBD 2R HEL. T 71V I EDMZIZURALIKNLET

« DMZIF/NTY NZEGRETHZ EILL., ERZTOFH—NICEELET,

« TOFIH-—NBEF TV 1Z2FANBZD. TOY—NNOHLWERZRKL, 1>
VICEERELET,

XY RNIT—=UK

Firewall Internet

‘_ EO Inside H Outside ‘S

Win10-0 ftdv-0 ext-conn-0
Datal
User machine DMZ

M1

Sl

wsav-0

Proxy server

aA>74Fa2L—>3>

RXDFIEE, FMCTOWCCPOREZRLTWVWET, R—KBOBKRV443DRNTT1 v I %
InsideV —> A SDMZYV =2 ICURAL I NTRIRENFHYET,



E:ZORFIXAKRNTR., BN —ERADOFIEICOVWTHBLET, R—NEHIE
WCCPOZA T RNDASEEFENTVWET,

ATYZ71FMC GUIICOY 1> L T, Object > Object Management > Access List > Extended
>Add Extended Access Listlc BEIL £,

2DDIRT IOELAVARNEERLET,
NI—HYRS T4V OBVEALIRNTDTIOEAVARNEERL, SaveZ IV Y ILET,



Edit Extended Access List Object [7]

Name
I Redirect_traffi
Entries (3)
@ Biox! 5, ’
2 @ B L L |
u
Allow Overrides

E:ZOTIOEAVARNE, RYRND—OROIIN—T7%2ERITDi=HIC, WCCPU A
TORASFIDICAAS RS 74V OICRLTTO>a>7OvYINEREENATVWSCE



ZHELET,

T, 7o2ar7Ov0eERALTROXEERL. AHRANEOBEN7OF>
B—NICEBENBVWRSIITREETEET,

REOXTE., 7O0FAQOUS AL I NCERBEMOINTORNZT 714V JZHAT
DRBNBHYNET,

Q7 VEAVANEHERL TWCCPOIZ AT hE&BIL, SaveZ V)Y JLKRT,

Name
[ weee-cuent

Entries (1)

Sourt
1 Al WEA_s s u
Allow Overrides

WCCPUZA T he#BRITHODOTIEAUAN



FEWCCPH—NDIP7 RLAZEHDI2ODILERT VA ANDERE,

AT ¥ 7°2:0bject > Object Management > FlexConfig > Text Object > Add Text Object M JIEIC %
BL. WCCPH—ERZEMLTRELET,



Edit Text Object T

Mame:

Description:
Variable Type Count
Single v 1
1 a7

|| Allow Overrides

| Cancel | Save

WCCPH—ERFATS I I NEERLTVET



A ZOPITE, Y—ERAIDIFI7TTT, 90 ~ I7TOBDH—EAIDZERIBDEZH
BHLET, i, DAZLT—ERADHFHECZ7ORNILICE) HTSh DY
—EADEHRELBEVWEDHTT,

FHMICOWTIE, TASATOWCCP : #i%. FIREE,. HLVERTEL 2SR LTIEETL,

ATV 3:

+ Object > Object Management > FlexConfig > Text Object® JEIZBE L . isServiceldentifer%
BRELET,

Text Object ['\"« isServiceldentifie] b4

Text objects define free-form text strings that you use as variables in a FlexConfig object. These objects can have single values or be a list of multiple values


https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html

« isServiceldentiferZfalseh StruelCZE L £ 9,
« isServiceldentifer:false M54 . standardweb-cacheservice IDZFERALET, RFI1I XK

FFirepower Management Center(FMC)58EH A Ra 2B L TS EE L,

Edit Text Object @

Name:

iIsServiceldentifier

Description:

A flag to identity whether to use
service in wecep.

Variable Type Count
Single v =
1 true

Allow Overrides

» Override (0)

E%falseh StruelCZEELET



https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html
https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html
https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html

FESIL, ATYT2TRLEI—HYERODTFANF T I O NEHERTEET,

ATV 4:

- Object > Object Management > Flex Config > FlexConfig Object® JEIZBEIL £ 7,
« ¥F—J—RwcepZERELET,
« Wcep_ConfigureT> 7L — K ®OClone#A7’>a>&# o)y O LET,
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Firewsall Mar e Nt Center
irewall Management Center Ovenview Analysis Policies Devices Objects Integration Deploy O @ # @  admin il

> AMA Senver FlexConfig Object A recons oo Jke X
* Access List
— FlexConfig Object includ i es, and scripting language instructions. It is used in FlexConfig polices

Application Filters

AS Path Ham ’ '

EBFD Template

Weep_Configure The tempdate is an example of woep configur.. Ba

Cipher £ I

» Community List o £ I . =

DHCP IPv6 Pool
> Distinguished Name

» External Attributes
File List
"~ FlenConfig
FlexConfg Object
Text Object

X : FlexConfigZ 72 TV NI, BRIERE W=7 > 7L — MWeep_Configure & V)
FY. TVTL—RMEFNA AT RYFTEERRA, VO ZERTEIXENHVY)



x9,

ATYT5:
« 31TH A 5 $serviceldentifierZH Z HIBRL . MEOEHZREELET,
Add FlexConfig Object (7]

Name:

Wccp_Configure_clone

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.
Insert » Deployment: Once v Type: Append v

#set( Sservice = "web-cache")

#if( $isServiceldentifier == "true")
fset( Sservice = "$sepviceldentifier")
#end —

#set ( SwccpCli = "wccp")

####wccpRedirectlist is place-holder for extended ACL.
####Replace wecpRedirectlList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
fif ( SwecpRedirectList )

fset( SweepCli = "SweepCli redirect-list $wegpRedirectList"™)
fend
¥ Variables
Name Dimension Default Value Property Override Description
(Type:Name) P
isServiceldentifier SINGLE true FREEFORM:I... false A flag to determine if service ...
serviceldentifier SINGLE 1 FREEFORM.... false service identifier number is to...

Cancel Save

H—E ZIDD I

o« ATY T2THERL 1= E L TText Objectwecp-serviceZ AL £,
- ROYZFRAIXZ21—h5, Insert> Insert Policy Object > Text Object® JEIZEIRL F 9

o



Add FlexConfig Object

Name:

' Weep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|. Insert . B Deployment: . Once

1

Insert Policy Object
Insert System Variable »

Insert Secret Key

#set ( Sweeplli = “"Swec
t###Replace woopGrouUpLi
#if ( SwcepGrouplist )
#set ( SwecpCli = "$weck
#end

Text Object

Network

Security Zones
Standard ACL Object
Extended ACL Object

Route Map

v Type: Append

i ACL.
afined in FMC by inserting policy-object of type extended ACL.

####weccpRedirectlist is place-nolaer ror extended ACL.

fend

weep-service A 7P T U RN EERE L THEHEALEY

« Variable Namewccp-serviceZ#EL £9,
« Available Object Twccp-service-objectZ2 R EL £9,
s FTSIORNEEMULTRELET,



Insert Text Object Variable (7]

Variable Name:

| wecep-service ‘

Description:
Available Objects Selected Object
| 2, weep b4 ‘ weep-service-object .

wecepPassword

Cancel Save

weep-serviceZAF 7 T N DB
ATYT6:
« weepGroupListZ# &2 1E—L T, MEBOEHEZEELET,



Add FlexConfig Object

MName:

l Weep_Configure_clone l

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

l Insert » s Deployment: | Once v Type: _ Append v

#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set({ ¥service = "Jweccp-service")
#end
#set ( SwcopCli = "SwccpCli $service")
] ###fwocepGroup. t is place-holder for extended ACL.
] ####Replace wecpGrouplist with extended ACL defined in FMC by inserting policy-object of type extended ACL.
=l #if ( $WccpGroupList )
: #set( $weepCli = "SweepCli group-list SweepGroupList™)

#end

####wccpRedirectList is place-holder for extended ACL.

####Replace wceopRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
#if( $weepRedirectList )

TE &K & DweepGroupListZ 0 Bl &

« ROYFTAI>2 XZ1—7H Slnsert > Insert Policy Object > Extended ACL Object® JIE(Z3&1R
LET,

Name:

[ Weep_Configure_clone |

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert » 3 Deployment: | Once v Type: | Append

Il Insert Policy Object Text Object

Insert System Variable »  Network
Insert Secret Key Security Zones

- is pl Standard ACL Object  y acr,

_________ Li fined in FMC by inserting policy-object of type extended ACL.
Extended ACL Object

#set ( SwcepCli = "Swecce >upList™)

#end Route Map

#end

¥ Variables

wecpGrouplistiLsRACLD 3B 1N



« B TEHRE, £V IVOFIETIE—L fEweepGroupliste WS BRI E BV ST E T,
« AT Y 71 THERL fAvailable Objects TWCCP-CLIENTZ# &L £,
- BMLT, RTFELET,

L ettt ettt bbbttt ettt ettt
r

| Insert Extended Access List Object Variable (7]

Variable Name:

; ‘ wccepGrouplList |

Description:

Available Objects C Selected Object

| | search X | Bvcep-CLIENT ¥
0

I-§2edin=\.ct_traﬂ°|c

WCCP-CLIENTHEFR ') A N DB N

FIEg 7:
« wcepRedirectListZ#IRL TAE—L., MBOZEHZEEELEF T,



Add FlexConfig Object

Name:

( Weep_Configure_clone ]

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v Deployment: I Once v ‘ Type: | Append

#set ( $service = "web-cache")

#if( $isServiceldentifier == "true")
#4ena
#set ( S$woepCli = "wecp")

#set ( SweepCli

#end
###dwccpRedirectList is place-holder for extended ACL.
####Replace )

mp-§1f ( $wccpRedirectList )
#set( SweepCli = "$wecpCli redirect-list SwecpRedirectList")
#end

wecpRedirectList ? Bl &

« ROYZTHADUAZ21—H5, Insert> Insert Policy Object > Extended ACL Object M JEIZ
BRLET,

Add FlexConfig Object

Name:

I Wecep_Configure_clone ]

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v J k2 Deployment: [ Once v Type: | Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

####wccpGrouplist is pl Standard ACL Object  j acL.

####Replace wcepGroupLi X pfined in FMC by inserting policy-object of type extended ACL.
#if( ) Extended ACL Object

#set ( SweepCli = "Sweer JupList™)

#end Route Map R
####wocpRedirectlist is place-noiaer ror extended ACL.

¥ Variables

wecpRedirectListDILERACLA 72 T 7 N MiER



- wcepRedirectListZ B E ICBEV T E T,
« Available Object TRedirect_trafficZ &L £,
- AddZERL T, SaveZERLET,

et R

Insert Extended Access List Object Variable @

Variable Name:

‘ wccpRedirectList ‘

Description:

Available Objects C Selected Object

‘ Q_ Search P 4 Lﬁzeo::lirect_traﬂ“lc

3 z Redirect_traffic

‘#VCCP-CLIENT

)

Redirect_traffic ACLO BN
ATYVT8:

o @wccpPassword O Hll B}



Add FlexConfig Object

Name:

[ Wecep_Configure_clone ‘

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

| Insert v

3 Deployment: [ Once v | Type: [ Append v

FMC by inserting policy-object of type extended ACL.

t is place-holder for extended ACL.
irectList with extended ACL defined in FMC by inserting policy-cbject of type extended ACL.

#foreach( $interfaceName in $security-zone)

EHIEREE N -weeppassword % HIBR
e ROV RO XZ1—HD5F—2BRLETHF A CHEBEF—ZFALET,

Add FlexConfig Object

Name:

Wecep_Configure_clone ‘

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘. Insert v . E2 Deployment: l Once A l Type: l Append

)
Insert Policy Obiect » ace-holder for extended ACL.
Y g st with extended ACL defined in FMC by inserting policy-object of type extended ACL.

Insert System Variable » . . .
Y Cli group-list S$weepGroupList™)

Insert Secret Ke
place-holder for extended ACL.

####Replace weccpRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#foreach({ $interfaceName in $security-zone)

¥ Variables

WEF—0=ER

« Add SecretKeyZz 21 JY JLET,



Insert Secret Key @

Add Secret Key

Name

~,
«

[ ] wccpPassword

Cancel Save

HE X — o0&

. Secret Key namel_ BFZAHLE T,
« NAD—RZAHDLET,
+ Confirm PasswordicEU/NAD—R&ZAHL, AddeOUYOLET,



Add Secret Key

Secret Key name:*

‘ wccpPassword

Password:*

A-HY-—EEOHWEZ X —0EM

[ Cancel ’

Add




A ZOBITE, Inside/ > EX—7 T4 ARINOEFIVFTAV—-2VIZBELTVET,

FIE 9 :

« FE&RE A Dsecurity-zone 21— L T, $security-zone ZHBENDERTEEMAE T,



Edit FlexConfig Object 9

Name:

| Weep_Configure_clone |

Description:

The template is an example of
weep configuration. It can not

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v ‘ (3 Deployment: | Once v | Type: | Append v
fset (5
fend

fforeach( $interfaceName in $SECUrity-ZONe |
weep interface $interfaceName §service redireet in

fend
¥ Variables
. Property . .

Name Dimension Default Value (Type:Name) Override Description
wcepGrouplist SINGLE WCCP-CLIENT EXD_ACL:W... false

wcecp-service SINGLE 97 FREEFORM:... false

interfaceName SINGLE in SECURITYZ... false

security-zone SINGLE in SECURITYZ... false

FAisecurity-zoneZ JE—L £ 7,

« ROY 7R U2 XZ1—75h 5Security ZonesZi&IRL . Insert > Insert Policy ObjectZ &R L
S



Add FlexConfig Object

Name:

Wecep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert B2 Deployment: I Once v | Type: I Append

Insert Policy Object Text Object supList™)

Insert System Variable »  Network wded ACL.
X . defined in FMC by inserting peolicy-object of type extended ACL.
Insert Secret Key Security Zones
#SEL( PWCCPLLl = "3WCCE K JRedirectList”)
$end Standard ACL Object

#set( SwccpCli = "$wcck Extended ACL Object vord ")
SweepCli Route Map

##4# RAssiging wcop onto interface
#foreach( in $security-zone)

#end

¥ Variables
t%aYFqJ—rnER

« ZTHF &Zsecurity-zone& U TRV FIFET,
« Available Objectsh' 5., AddT B4 X—T7 T4 AZBIRLE T,
* [Save] 20UV ILET,



Insert Security Zone Variable (7]

Variable Name:

| security-zone |

Description:

Available Objects Selected Object
| C, Search ‘ in

o/

dmz

out

Cancel Save

tXaYTF V-2 DEM
FI&g 10 :

« Devices > FlexConfigi_ & L . New Policy® 7= [&Edit an existing policyZ 2 Y VL&Y,
« BREE N IzWcep_configure_cloneF 72 T KM &BRL, >20 )Y UL TEINETET,
* [Save] 20U YILET,



A FHLWRUS—0FEE. RUS—ZFTIDFNA ARICEE TS ZBELTLE
TV, BBFEORUS—0FERF. RUZ—NFITICEVITSATVILEN BT

o

WCCP_config EZ3




AT ¥ 711:Deploy > Select the FTD DeviceDEIZ#E L. Deploy2 27 JY L E T,

=3
=1

ATY71:RETAV74F 1L 232 z®ELET,
FTDCLICOZ 4> L. O~ > Rshow running-configweep® £1TL £ 9,

B -

e

wccp 97 redirect-1ist Redirect_traffic group-Tist WCCP-CLIENT password ###*#*%
wccp interface inside 97 redirect in

REODNAT—RAELWZ & 2#FEITSICE, OV REZETLET,
1) o system support diagnostic-cli

(2) enable

JINAT—RZANE S ICEnterF—Z2HLET

more system:running-config | include wcep

4)0

ATY T2WCCPRAT—RAZHALE T,

KRNI RZEEITLET,  showweep
Global WCCP information:
Router information:
Router Identifier: -not yet determined-
Protocol Version: 2.0

Service Identifier: 97

Number of Cache Engines: 1

Number of routers: 2

Total Packets Redirected: 0

Redirect access-1ist: Redirect_traffic
Total Connections Denied Redirect: 0

Total Packets Unassigned: 0

Group access-Tist: WCCP-CLIENT
Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

RDOIAX Y RZERTLET, show weep 97 service ( BFEI—HEHR )



WCCP service information definition:

Type: Dynamic
Id: 97
Priority: 240
Protocol: 6
Options: 0x00000012
Hash: DstIP
A1t Hash: -none-
Ports: Destination:: 80 443 000000

E: 22T, 97} —EAIDTY, WCCPOUTAT UMD SEZLER—RNESE, T
A=, a2 THERLTLIEETL,

3 ) o Runthe command show wccp 97 view

ST I—RK



ATY 71 TAOFH—NHSWCCPERZZRBLIEAVE—TI(ALRALAVE—T7 14
ADSDIIL—KAFTIDICHD & Z2BBLET,

COHITE. RZ714Y0dmzA 2 E2—TIAAICIUAALA LI RNENET,

>show route
S 10.xx.xx.xx 255.yyy.yyy.yyy [1/0] via 10.zz.zz.z, dmz

A ZCT, 10xxxxxxlE 7 OF S H—/NDIPT, 255.yyy.yyy.yyikxY N AU T,
10.22.22.2B XV ARNKY TP —RKDIT AT,

ATY 7 2insideBS K BdmzA VX —T IAADF Y TF v EWMEBLT. NS T4V IHFVEAL
DREhB xR LET,

R—PN443OAZPA 2 R—T IAATOF Y S F+



capture capinside interface inside trace detail match tcp any any eq 443

dmzA 2 Z—T7 IAATODFYTF ¥ :

capture capdmz interface dmz trace detail match gre any any

FEodmzA VR —TIAATRE., GREZORIILTTANZRI T TR2RENHYET
o WAALYRNTY MNE, GRENT Y NMZATEILENTweepZ T4 T2 MZEE
ThET,

AT Y 7 3:weepDTFINY &

RODIX RZERITLET,



debug weep event debu weep packet

Cisco bug IDCSCvn90518#4", WCCPEXEICEAL TFDMEFMCO XA T 4 J7E—REYR—NT
EOOBEEIL RO EHICERESNEL .



https://tools.cisco.com/bugsearch/bug/CSCvn90518

BERICDW\T

VZAARIMRFOI—HFITEFNZFNDOEETHR—b VT VY ERHEITZ/HIC, #HEAIC
LBBREMBEDET. FARF XY MEBRLUTVET. L. BREEOKMERTH -
TH, EMARICLDFROLS BRIEERIIERINT BA. X3, ChSEIRROIEHE®ICD

WTERNEEZEVWEEA. BETHZHEEBIR (VIS5 T7 I EATEE) bHHhETESRTS
CETEHRULIEY,



