Introduzione
In questo documento viene descritto come risolvere i problemi relativi a un'appliance virtuale (VA) che non viene visualizzata in Umbrella Dashboard dopo la distribuzione.
Prerequisiti
Requisiti
Nessun requisito specifico previsto per questo documento.
Componenti usati
Le informazioni fornite in questo documento si basano su Cisco Umbrella.
Le informazioni discusse in questo documento fanno riferimento a dispositivi usati in uno specifico ambiente di emulazione. Su tutti i dispositivi menzionati nel documento la configurazione è stata ripristinata ai valori predefiniti. Se la rete è operativa, valutare attentamente eventuali conseguenze derivanti dall'uso dei comandi.
Problema
È stata distribuita un'appliance virtuale (VA), che tuttavia non viene visualizzata nel dashboard ombrello in Distribuzione > Configurazione > Siti e Active Directory. Inoltre, la console dell'appliance virtuale visualizza il processo di sincronizzazione come disabilitato e che il test Updates non è riuscito, come mostrato di seguito:
115008641668
Passaggio rapido agli aggiornamenti: Il test GET non riuscito e premendo Invio vengono visualizzate le seguenti informazioni:
GET failed: GET from http://shared.opendns.com:80/enterprise/upgrade/va/mainline/MANIFEST failed: HTTP/1.1 404 Not Found
115008641688
Soluzione
Se si stanno installando appliance virtuali in VMWare e si osserva il comportamento descritto in precedenza, non apportare modifiche all'archivio dei file OVA o al modello OVF incluso in tale archivio. Distribuire il modello OVF esattamente come mostrato nella documentazione di Cisco Umbrella.
Se si installano le appliance virtuali in Hyper-V, prestare particolare attenzione alla sezione relativa all'importazione di entrambi i dischi rigidi, come illustrato nella documentazione di Cisco Umbrella.
Causa
Il comportamento descritto in precedenza indica che le appliance virtuali non sono state installate in base alla documentazione esistente.
Le appliance virtuali vengono scaricate da Umbrella Dashboard come archivi di file (.ova per VMWare, .zip per Hyper-V). L'estrazione da questi archivi rivela questi file:
VMware:
-
forwarder-va.vmdk (disco rigido)
-
dynamic.vmdk (disco rigido)
-
forwarder-va.ovf (file descrittore)
-
forwarder-va.mf (file manifesto)
Hyper-V:
- Dischi rigidi virtuali\forwarder-va.vhd (disco rigido)
- Dischi fissi virtuali\dynamic.vhd (disco rigido)
- config.xml (file di configurazione)
- Virtual Machines\[ALPHANUMERIC STRING].exp (file di esportazione)
Il primo disco rigido elencato per ciascuna piattaforma, forwarder-va.vmdk e forwarder-va.vhd, contiene il software del server d'inoltro DNS che accetta le query DNS dei client e le inoltra ai resolver Anycast Umbrella. Questo disco contiene anche il processo di sincronizzazione che periodicamente esegue il check-in con l'API Umbrella.
Il secondo disco rigido elencato per ogni piattaforma, dynamic.vmdk e dynamic.vhd, contiene informazioni specifiche dell'organizzazione richieste dal processo di sincronizzazione dell'appliance virtuale. Se il processo di sincronizzazione del dispositivo virtuale situato sul disco rigido del server di inoltro non dispone delle informazioni sul disco dinamico, non sarà possibile eseguire la sincronizzazione con l'API Umbrella e il processo rimarrà disattivato. Inoltre, il dispositivo virtuale non si registra mai con Umbrella Dashboard e può continuare a non superare il test Updates mostrato negli screenshot precedenti.