Configurer et depanner WCCP sur FTD a l'aide
d'un modele predéfini
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Introduction

Ce document décrit les étapes de configuration et de dépannage de WCCP sur FTD.

Conditions préalables

Exigences

Cisco vous recommande de prendre connaissance des rubriques suivantes :

* Protocole WCCP (Web Cache Communications Protocol) version 2 (v2)
» Firepower Management Center (FMC)
» Firepower Threat Defense (FTD)

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de
logiciel suivantes :

» Centre de gestion du pare-feu sécurisé (FMCv) v7.4.2
* Protection pare-feu sécurisée contre les menacesVirtual(FTDv) v7.4.2

The information in this document was created from the devices in a specific lab environment. All of
the devices used in this document started with a cleared (default) configuration. Si votre réseau
est en ligne, assurez-vous de bien comprendre l'incidence possible des commandes.



Configurer

Le protocole WCCP (Web Cache Communication Protocol) est utilisé pour rediriger le trafic Web
vers un serveur de cache. Il est généralement mis en oeuvre dans les périphériques réseau tels
que les routeurs et les pare-feu Cisco pour rediriger les requétes HTTP, HTTS et FTD sur HTTP
VErs un serveur proxy.

WCCP est disponible dans différentes versions, notamment WCCP v1, v2 et v3, chaque version
offrant des fonctionnalités et une évolutivité améliorées.

Comment ¢a fonctionne

* L'ordinateur utilisateur Win10-0 effectue une requéte HTTPS.

* Ici, le pare-feu FTD est la passerelle pour l'ordinateur utilisateur. Il recoit la requéte
HTTP/HTTPS.

* FTD comprend que le port de destination est 443 et redirige le trafic vers DMZ

» DMZ encapsule le paquet avec GRE et transfere la requéte au serveur proxy.

* Le serveur proxy examine son cache ou initie une nouvelle connexion au serveur d'origine et
répond directement a la machine utilisateur.

Diagramme du réseau
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Configurations

Ces étapes illustrent la configuration de WCCP sur FMC. Le trafic avec les ports 80 et 443 doit
étre redirigé de la zone interne vers la zone DMZ.



Remarque : Le document décrit les étapes pour I'ID de service dynamique. Les
informations de port ont été apprises a partir du client WCCP.

Etape 1 : Connectez-vous a l'interface utilisateur graphique de FMC et naviguez jusqu'a Object >
Object Management > Access List > Extended > Add Extended Access List.

Créez deux listes de controle d'accés étendues.

1) Créez une liste d'accés pour rediriger le trafic utilisateur et cliquez sur Enregistrer.



Edit Extended Access List Object

Name

I Redirect_traffic

Entries (3)

@ Block  WSA_serer

2 © Block

user_LanN

3 Allow

Allow Overrides

Remarque : Cette liste d'acces garantit que vous avez Action Block pour le trafic
provenant du client WCCP vers FTD pour éviter la boucle dans le réseau.



En outre, vous pouvez créer une autre instruction avec Action Block pour vous assurer
que la communication entre les hotes internes ne sont pas envoyées au serveur proxy.

L'instruction finale doit autoriser tout autre trafic pouvant étre redirigé vers le proxy.

2) Créez une liste d'accés pour identifier le client WCCP et cliquez sur Save.

Name
[ weee-cuenT

Entries (1)

1 o Allow WSA_server

Allow Overrides

Liste d'acces pour identifier le client WCCP



Remarque : Configuration d'une liste d'accés étendue pour inclure les adresses IP du
serveur WCCP.

Etape 2 : Accédez & Object > Object Management > FlexConfig > Text Object > Add Text Object
pour ajouter le service WCCP et Enregistrer.



Edit Text Object T

Mame:

Description:
Variable Type Count
Single v 1
1 a7
|| Allow Overrides

| Cancel | Save

Création d'un objet service wcep



Remarque : Dans cet exemple, I'ID de service est 97. Il est conseillé de sélectionner un ID
de service compris entre 90 et 97, car il s'agit d'ID de service personnalisés qui ne sont
généralement pas en conflit avec d'autres ID de service attribués a des protocoles

spécifiques.

Pour plus de détails, référez-vous a WCCP sur ASA : Concepts, limites et configuration

Etape 3 :
* Naviguez jusqu'a Object > Object Management > FlexConfig > Text Object et Search for
isServiceldentifer.
Text Object ['\"« isServiceldentifier b

Text objects define free-form text strings that you use as variables in a FlexConfig object. These objects can have single values or be a list of multiple values


https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html

* Modifiez isServiceldentifer de false a true.
» isServiceldentifer - Si la valeur est false, utilise I'identificateur de service web-cacheservice
standard. Reportez-vous au document Guide de configuration de Firepower Management

Center

Edit Text Object @

Name:

iIsServiceldentifier

Description:

A flag to identity whether to use
service in weccep.

Variable Type Count
Single v =
1 true

Allow Overrides

» Override (0)

Modifiez la valeur de false en true



https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html
https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html

Remarque : En outre, vous pouvez créer un objet texte défini par I'utilisateur présenté a
I'étape 2.

Etape 4 :

» Accédez a Object > Object Management > FlexConfig > FlexConfig Object.
* Recherchez le mot clé wccep.
* Cliquez sur I'option Clone du modéle Wccep_Configure.



= o

Firewall Manaae t Canter
irewall Management Center Cvendew Analysis Policies Devices Objects Integration Deploy Q, ﬁm o @ admin ahidn
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* Access List

g Object include device configuration commands, variables, and scripting language instructions. It is used in FlexConfig polices.

Address Pools FlexConf
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» Distinguished Name
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Remarque : L'objet FlexConfig a un modele prédéfini : Wcep_Configure. Le modéle ne
peut pas étre attaché au périphérique. Vous devez le cloner.



Etape 5 :

« Supprimez les variables $serviceldentifier de la troisiéme ligne et fournissez votre propre
variable.

Add FlexConfig Object (7]

Name:

Weep_Configure_clone

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert « Deployment: Once v Type: Append v

#set( $service = "web-cache")

#if({ $isServiceldentifier == "true")
fset( Sservice = “$sepviceldentifier”
fend —

. is place=holder for extended ACL.

####Replace weepGroupList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
#if ( $wecpGrouplist )

fset | $wecpCli = "$SweepCli group-list $wecpGroupList™)

fend

###fwcocpRedirectlist is place-holder for extended ACL.

####Replace wecpRedirectlList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
#if{ SwocpRedirectList )

#set( SweepCli = “SwoepCli redirect-list SwecpRedirectList")
fend
¥ Variables
Name Dimension Default Value ik Override Description
(Type:Name) P
isServiceldentifier SINGLE true FREEFORM:I... false A flag to determine if service ...
serviceldentifier SINGLE 1 FREEFORM:... false service identifier number is to...

Cancel Save

Supprimer l'identificateur de service

* Insérez la variable Text Objectwccp-service créée a I'étape 2.
» Dans le menu déroulant, sélectionnez Insert > Insert Policy Object > Text Object



Add FlexConfig Object

Name:

' Weep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|. Insert . B Deployment: . Once v | Type: ' Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

#set ( SwecepGli = "Sweg

####wcepGroupList is pl Standard ACL Object 3 acr.

####Replace wecepGroupLi 2fined in FMC by inserting policy-object of type extended ACL.
Fif ( $wecpGroupList ) Extended ACL Object

fset( SweepCli = “Sweer JupList")

#end Route Map

####weccpRedirectlist is place-nolaer ror extended ACL.

fend

Insérez 'objet weep-service en tant que variable

* Fournissez un service Variable Namewccp-service.
* Recherchez wccp-service-object dans Objet disponible.
» Ajoutez I'objet et enregistrez-le.



Insert Text Object Variable (7]

Variable Name:

| wecep-service ‘

Description:
Available Objects Selected Object
| 2, weep b4 ‘ weep-service-object .

WCCp-=-5erv [ ce-o

wecepPassword

Cancel Save

Ajouter un objet wcep-service

Etape 6 :

» Copiez le nom de la variable wccpGrouplList et fournissez votre propre variable.



Add FlexConfig Object

Name:

[ Wecep_Configure_clone l

Description

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

llnsertv s Deployment: Once v Type: Append vé

#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set( $service = "$wecp-service")
fend

#set ( SwcopCli = "SwccpCli $service")
] ###fwocepGroup. t is place-holder for extended ACL.
] ####Replace wecpGrouplist with extended ACL defined in FMC by inserting policy-object of type extended ACL.
. #if ( $WCCPGroupList )
| #set( SweepCli = "SwoopCli group-list $weepGrouplist™)

Supprimer la variable wecpGrouplList prédéfinie

* Dans le menu déroulant Insert > Insert Policy Object > Extended ACL Object.

Name:

| Weep_Configure_clone

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

r y r - r
|

Insert v i % Deployment: Once v Type: | Append

. Insert Policy Object Text Object

Insert System Variable »  Network

Insert Secret Key Security Zones

Standard ACL Object  § acr.
2fined in FMC by inserting policy-object of type extended ACL.
Extended ACL Object

¥ Variables

Ajout de la liste de contréle d'acces étendue wccpGrouplist

» Collez le nom wcepGrouplList que vous avez copié a I'étape précédente dans la section Nom



de variable.
* Recherchez WCCP-CLIENT dans Objets disponibles créés a I'étape 1.

+ Ajoutez et enregistrez-le.

ey

Insert Extended Access List Object Variable (7]

Variable Name:

'-!?edirect_traﬂﬁc

& NCCP-CLIENT

; ‘ wccepGrouplList l

Description:

Available Objects C Selected Object

| [ search X Bvcep-CLIENT ¥
.

Ajouter la liste étendue WCCP-CLIENT
Etape 7:

» Sélectionnez wcepRedirectList pour copier et fournir votre propre variable.



Add FlexConfig Object

Name:

( Weep_Configure_clone ]

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v Deployment: I Once v ‘ Type: | Append
f#set ( $service = "web-cache")
#if( $isServiceldentifier == "true")

#if( $wecpGroupl
#set ( SwecepCli =
#end

#end

Supprimer wccpRedirectList

» Dans le menu déroulant, sélectionnez Insert > Insert Policy Object > Extended ACL Object .

Add FlexConfig Object

Name:

[ Wecep_Configure_clone ]

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v | k2 Deployment: | Once v Type: | Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

####wccpGrouplist is pl Standard ACL Object  j acL.

####Replace wcepGroupLi fined in FMC by inserting policy-object of type extended ACL.
#if( ) Extended ACL Object

#set ( SwecpCli = "Sweep oupList™)

#end Route Map

###dwccpRedirectlist is place-nolaer ror extended ACL.

###4Replace weepRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#end

¥ Variables

Sélectionner un objet ACL étendu pour wccpRedirectList

» Collez weepRedirectList dans Nom de variable.



* Recherchez Redirect_traffic dans Objet disponible.
+ Sélectionnez Ajouter et Enregistrer.

e el eileeiliaeosiisisaiiisisisiiisneiios e = = e e e e

Insert Extended Access List Object Variable @

Variable Name:

‘ wccpRedirectList ‘

Description:

Available Objects C Selected Object
’ Q_ Search p 4 Lﬁzeo:jirect_traﬁ“lc

£ Redirect_traffic

#VCCP-CLIENT

)

Ajouter une liste de contréle d'accés Redirect_traffic
Etape 8 :

e Supprimer @wccpPassword



Add FlexConfig Object

Name:

[ Wecep_Configure_clone ‘

Description:
The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

| Insert v

3 Deployment: [ Once v | Type: [ Append

FMC by inserting policy-object of type extended ACL.

t is place-holder for extended ACL.
irectList with extended ACL defined

in FMC by inserting policy-object of type extended ACL.

#foreach( $interfaceName in $security-zone)

Suppression du mot de passe wccp prédéfini

+ Sélectionnez la clé dans le menu déroulant Insert > Insert Secret Key.

Add FlexConfig Object

Name:

' Weep_Configure_clone ‘

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘. Insert v ' k2 Deployment: [ Once v l Type: [ Append

Insert Policy Obiect » ace-holder for extended ACL.
v =0 st with extended ACL defined in FMC by inserting policy-object of type extended ACL.
In m Variable »
sert Syste ariable Cli group-list $weepGroupList™)

Insert Secret Ke
place-holder for extended ACL.

in FMC by inserting policy-object of type extended ACL.

#set( SweepCli = "SweepCli password ")

#foreach( $interfaceName in $security-zone)
¥ Variables

Sélectionner la clé secréte

» Cliquez sur Ajouter une clé secréte.




Insert Secret Key @

Add Secret Key

Name

~,
«

[ ] wccpPassword

Cancel Save

Ajouter une clé secréte

* Entrez un nom dans Nom de clé secréte.
» Entrez le mot de passe.
» Entrez le méme mot de passe dans Confirmer le mot de passe et cliquez sur Ajouter.



Add Secret Key

Secret Key name:*

‘ wccpPassword J

Password:*

[ Cancel ] Add

Ajouter une clé secréte définie par I'utilisateur




Remarque : Dans cet exemple, l'interface interne appartient a la zone de sécurité dans.

Etape 9 :

« Copiez la zone de sécurité prédéfinie et remplacez $ security-zone par votre propre variable.



Edit FlexConfig Object

Name:

| Weep_Configure_clone |

Description:

The template is an example of
weep configuration. It can not

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Deployment: | Once v | Type: | Append

fforeach( $interfaceName in $SECUrity-ZONe |
weep interface $interfaceName §service redireet in

fend
* \ariables
Property . .

Name Dimension Default Value (Type:Name) Override Description
wcepGrouplist SINGLE WCCP-CLIENT EXD_ACL:W... false

wcecp-service SINGLE 97 FREEFORM:... false

interfaceName SINGLE in SECURITYZ... false

security-zone SINGLE in SECURITYZ... false

Copiez le nom security-zone

» Sélectionnez Security Zones dans le menu déroulant et Insert > Insert Policy Object.



Add FlexConfig Object

Name:

Wecep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert B2 Deployment: I Once v ‘ Type: I Append

Insert Policy Object Text Object supList™)

Insert System Variable »  Network wded ACL.
. defined in FMC by inserting peolicy-object of type extended ACL.
Insert Secret Key Security Zones
FSET| SWCCPLLL = "3»WCCE JRedirectList")
$end Standard ACL Object

#set( SwccpCli = "$wcck Extended ACL Object vord ")
SweepCli Route Map

##4# RAssiging wcop onto interface
#foreach( in $security-zone)

#end

¥ Variables

Sélectionnez la zone de sécurité

* Collez le nom de variable en tant que zone de sécurité
» Dans Objets disponibles, sélectionnez l'interface a ajouter.
* Cliquez sur Save.



Insert Security Zone Variable (7]

Variable Name:

| security-zone |

Description:

Available Objects Selected Object
| C, Search ‘ in

o/

dmz

out

Cancel Save

Ajout d'une zone de sécurité
Etape 10:

» Accédez a Devices > FlexConfig, cliquez sur New Policy ou Edit an existing policy.
+ Sélectionnez I'objet Wccep_configure_clone configuré et cliquez sur > pour l'attribuer.
* Cliquez sur Save.



Remarque : Dans le cas d'une nouvelle stratégie, veillez a affecter la stratégie au
périphérique FTD. Pour une stratégie existante, la stratégie doit avoir déja été attribuée.

WCCP_config " E=Z3

Wetp_ Condgure_clone

<7 Selected Append FlexConfigs

Etape 11 : Accédez a Déployer > Sélectionnez le périphérique FTD > cliquez sur Déployer.



Vérifier
Etape 1 : Vérifiez la configuration en cours.

Connectez-vous a l'interface de ligne de commande FTD et exécutez la commande show running-config

weep.

Exemple de configuration :

e

wccp 97 redirect-1ist Redirect_traffic group-Tist WCCP-CLIENT password ###*#*%
wccp interface inside 97 redirect in

Pour vous assurer que la configuration dispose du mot de passe correct, exécutez les
commandes.

1) system support diagnostic-cli

2) enable

3) Appuyez sur Entrée sans mot de passe
4) more system:running-config | include wecp

Etape 2 : Vérification de I'état WCCP

Exécutez la commande show weep

Global WCCP information:
Router information:
Router Identifier: -not yet determined-
Protocol Version: 2.0

Service Identifier: 97

Number of Cache Engines: 1

Number of routers: 2

Total Packets Redirected: 0

Redirect access-1ist: Redirect_traffic
Total Connections Denied Redirect: 0

Total Packets Unassigned: 0

Group access-Tist: WCCP-CLIENT
Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

Exécutez la commande show wccp 97 service



WCCP service information definition:

Type: Dynamic
Id: 97
Priority: 240
Protocol: 6
Options: 0x00000012
Hash: DstIP
A1t Hash: -none-
Ports: Destination:: 80 443 000000

Remarque : Ici, 97 est I'ID de service. Assurez-vous que vous pouvez voir le numéro de
port appris du client WCCP dans Ports : de I'Aide.

3) Run the command show wccp 97 view

Dépannage



Etape 1 : Vérifiez que FTD dispose de la route provenant de la méme interface que celle qui a
recu la requéte WCCP du serveur proxy.

Dans cet exemple, le trafic est redirigé vers l'interface dmz.

>show route
S 10.xx.xx.xx 255.yyy.yyy.yyy [1/0] via 10.zz.zz.z, dmz

Remarque : Ici 10.xx.xx.xx est I'adresse IP du serveur proxy, 255.yyy.yyy.yyy est le
masque de réseau, 10.zz.zz.z est la passerelle de trongon suivant.

Etape 2 : Prenez les captures sur l'interface interne et dmz pour vous assurer que le trafic est
redirigé.

Capture sur l'interface interne pour le port 443



capture capinside interface inside trace detail match tcp any any eq 443

Capture sur l'interface dmz :

capture capdmz interface dmz trace detail match gre any any

Remarque : Sur l'interface dmz, vous devez filtrer avec le protocole GRE. Le paquet de
redirection est encapsulé dans le paquet GRE vers le client wccep.

Etape 3 : Débogage pour wecep

Exécutez les commandes suivantes :



debug weep event debu weep packet

Le bogue Cisco IDCSCvn90518 a été souleveé pour amélioration afin d'avoir la prise en charge du
mode natif FDM et FMC pour la configuration WCCP.



https://tools.cisco.com/bugsearch/bug/CSCvn90518

A propos de cette traduction
Cisco a traduit ce document en traduction automatisée vérifiée par une personne dans le

cadre d’un service mondial permettant a nos utilisateurs d’obtenir le contenu d’assistance
dans leur propre langue.

Il convient cependant de noter que méme la meilleure traduction automatisée ne sera pas
aussi précise que celle fournie par un traducteur professionnel.



