Problema
El módulo de seguridad DNS de Umbrella de Cisco Secure Client (agente VPN AnyConnect) permanece en estado "Desactivado" después de aplicar el archivo de perfil de Umbrella debido a la discordancia de huellas dactilares de registro del dispositivo. Este problema persiste en varios entornos de red, incluidas las conexiones de oficina corporativa y de zonas Wi-Fi personales.
Los artefactos de diagnóstico, como capturas de pantalla, capturas de paquetes DART y archivos de captura de paquetes, han indicado errores de registro de dispositivos vinculados a una discordancia de huella dactilar en el archivo OrgInfo.json:
- El módulo Umbrella muestra el estado "Desactivado".
- El problema ocurre después de aplicar el archivo de perfil de Umbrella.
- El problema se observa en varias redes.
- Los registros de diagnóstico y las capturas de paquetes muestran errores de registro de dispositivos.
Entorno
- Producto: Cisco Secure Client (agente VPN AnyConnect) con el módulo Umbrella
- Plataforma: SO Windows
- Función Umbrella DNS Security
- Archivo de perfil de Umbrella y OrgInfo.json involucrados
- Entornos de red: oficina corporativa, zona Wi-Fi personal
- Artefactos de diagnóstico Paquete DART, captura de paquetes, captura de pantalla
- Versión del software: Todos
Resolución
Este flujo de trabajo detallado resuelve el estado "Desactivado" del módulo Umbrella corrigiendo la discordancia de huellas dactilares en el archivo OrgInfo.json y volviendo a registrar el dispositivo con el servicio en la nube de Umbrella.
Descargar un nuevo archivo OrgInfo.json desde el panel de SSE
Para garantizar que el registro del dispositivo utiliza la huella dactilar correcta:
- Obtenga un archivo OrgInfo.json nuevo.
- Descargue el archivo OrgInfo.json actualizado directamente desde el panel de Cisco Secure Service Edge (SSE).
Detenga el servicio Cisco Secure Client - AnyConnect VPN Agent
Para detener el servicio es necesario modificar de forma segura los archivos asociados con el módulo Umbrella:
Abra Windows Services y detenga el servicio llamado Cisco Secure Client - AnyConnect VPN Agent.
Eliminación de todo el contenido de la carpeta Umbrella Module
- Borre cualquier dato potencialmente dañado u obsoleto de esta ubicación.
- Eliminar todos los archivos y carpetas incluidos:
C:/ProgramData/Cisco/Cisco Secure Client/Umbrella/
Precaución: Posible. Los detalles mencionados aquí parecen contener procedimientos o comandos que podrían causar un impacto significativo si se ejecutan. Asegúrese de que los procedimientos o comandos mencionados han sido evaluados por un SME o una Unidad de Negocio antes de ejecutarlos o recomendarlos.
Cargar el nuevo archivo OrgInfo.json
- Coloque el archivo OrgInfo.json recién descargado en la carpeta Umbrella designada.
- Copie el nuevo archivo OrgInfo.json en:
C:/ProgramData/Cisco/Cisco Secure Client/Umbrella/
Reinicie el servicio Cisco Secure Client
Reinicialice Cisco Secure Client para que los cambios surtan efecto. Inicie el servicio Cisco Secure Client - AnyConnect VPN Agent desde los Servicios de Windows.
(Si el problema persiste) Recopile datos de diagnóstico para analizarlos más a fondo
Si el dispositivo sigue sin registrarse, recopile un nuevo paquete DART para facilitar una resolución de problemas más detallada. Utilice la herramienta DART de Cisco Secure Client para recopilar un nuevo paquete de diagnóstico.
Después de realizar estos pasos, el módulo Umbrella debe pasar de un estado "Desactivado" a un estado operativo, activando las funciones de seguridad DNS según lo previsto.
Causa
La causa raíz del problema fue un archivo OrgInfo.json no válido o obsoleto que contenía un valor incorrecto de huella digital de dispositivo. Esta discordancia provocó un error en las solicitudes de registro de dispositivo a la API de Umbrella, lo que provocó que el módulo permaneciera deshabilitado. El error se confirmó mediante entradas de registro que mostraban "la huella digital no coincide" y "no se pudo crear la ID de dispositivo" durante los intentos de registro.
Ejemplo de extracto de registro de registros DART:
{"error":"invalid_request","message":"fingerprint does not match","code":400,"code_text":"Bad Request"}
Device Registration: failed to create device id
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