Introducción
Este documento describe cómo resolver los errores de inicio de sesión Kerberos o LDAP para el usuario OpenDNS_Connector cuando no se encuentra el DN de informe de eventos de inicio de sesión.
Problema
Este artículo se aplica a los errores de conector en los que falla la autenticación a Kerberos y LDAP, pero se siguen encontrando eventos de inicio de sesión. Los eventos de inicio de sesión indican "DN no encontrado".
Solución
Debe comprobar y actualizar la propiedad UserPrincipalName para el usuario de openns_connector:
1. Abra las propiedades de usuario de la cuenta openns_connector.
2. Asegúrese de que "UserPrincipalName" esté definido con la dirección de correo electrónico de la cuenta.
3. Compare el valor UserPrincipalName con otra cuenta para confirmar el formato y la definición esperada.
4. Actualice el valor si es necesario.
Una vez rellenado el campo UserPrincipalName, el conector puede reanudar el funcionamiento correcto.
Causa
Se ha producido un error de inicio de sesión debido a un nombre de usuario desconocido o a una contraseña incorrecta. Los registros muestran el problema, ya que se siguen encontrando eventos, pero el sistema informa de que no se ha encontrado el DN.
Por ejemplo:
Logon failure: unknown user name or bad password.
7/22/2019 3:16:01 PM: Using NTLM for LDAP://10.0.0.31:389/DC=Nephrology,DC=com communication to fetch the DN
7/16/2019 4:33:18 PM: DN not found!