Introducción
Este documento describe cómo resolver problemas de un dispositivo virtual (VA) que no se muestra en el panel de Umbrella después de la implementación.
Prerequisites
Requirements
No hay requisitos específicos para este documento.
Componentes Utilizados
La información de este documento se basa en Cisco Umbrella.
La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si tiene una red en vivo, asegúrese de entender el posible impacto de cualquier comando.
Problema
Ha implementado un dispositivo virtual (VA), pero no aparece en el panel de Umbrella en Implementación > Configuración > Sitios y Active Directory. Además, la consola del dispositivo virtual muestra el proceso de sincronización como deshabilitado y que la prueba de actualizaciones ha fallado, como se muestra a continuación:
115008641668
Accediendo a las actualizaciones: La prueba GET fallida y al pulsar Intro se muestra esta información:
GET failed: GET from http://shared.opendns.com:80/enterprise/upgrade/va/mainline/MANIFEST failed: HTTP/1.1 404 Not Found
115008641688
Solución
Si está implementando sus appliances virtuales en VMWare y es testigo del comportamiento descrito anteriormente, no realice ningún cambio en el archivo OVA ni en la plantilla OVF incluida en dicho archivo. Implemente la plantilla de OVF exactamente como se muestra en la documentación de Cisco Umbrella.
Si va a implementar los appliances virtuales en Hyper-V, preste especial atención a la sección sobre la importación de ambos discos duros, como se muestra en la documentación de Cisco Umbrella.
Causa
El comportamiento descrito anteriormente indica que los appliances virtuales no se implementaron de acuerdo con la documentación existente.
Los dispositivos virtuales se descargan del panel de Umbrella como archivos de almacenamiento (.ova para VMWare, .zip para Hyper-V). Al extraer de estos archivos, se muestran estos archivos:
VMWare:
-
forwarder-va.vmdk (disco duro)
-
dynamic.vmdk (disco duro)
-
forwarder-va.ovf (archivo descriptor)
-
forwarder-va.mf (archivo de manifiesto)
Hyper-V:
- Discos duros virtuales\forwarder-va.vhd (disco duro)
- Discos duros virtuales\dynamic.vhd (disco duro)
- config.xml (archivo de configuración)
- Máquinas virtuales\[CADENA ALFANUMÉRICA].exp (archivo de exportación)
El primer disco duro enumerado para cada plataforma, forwarder-va.vmdk y forwarder-va.vhd, contiene el software de reenviador de DNS que recoge las consultas de DNS del cliente y las reenvía a los resolvers de Umbrella Anycast. Este disco también contiene el proceso de sincronización que se registra periódicamente con la API Umbrella.
El segundo disco duro de la lista para cada plataforma, dynamic.vmdk y dynamic.vhd, contiene información específica de la organización que requiere el proceso de sincronización del dispositivo virtual. Si el proceso de sincronización del dispositivo virtual ubicado en el disco duro del reenviador a través de no tiene la información disponible en el disco dinámico, no podrá sincronizar con la API Umbrella y el proceso permanecerá deshabilitado. Además, el dispositivo virtual nunca se registra en el panel de Umbrella y puede seguir fallando en la prueba de actualizaciones que se muestra en las capturas de pantalla anteriores.