Configuracion y resolucion de problemas de
WCCP en FTD mediante una plantilla
predefinida
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Introduccion

Este documento describe los pasos de configuracidon y solucion de problemas para WCCP en
FTD.

Prerequisites

Requirements

Cisco recomienda que tenga conocimiento sobre estos temas:

* Protocolo de comunicaciones de caché web (WCCP) version 2 (v2)
» Centro de administracion Firepower (FMC)
» Firepower Threat Defense (FTD)

Componentes Utilizados

La informacion que contiene este documento se basa en las siguientes versiones de software y
hardware.

» Secure Firewall Management Center (FMCv) v7.4.2
» Secure Firewall Threat DefenseVirtual (FTDv) v7.4.2

La informacion que contiene este documento se cred a partir de los dispositivos en un ambiente
de laboratorio especifico. Todos los dispositivos que se utilizan en este documento se pusieron en



funcionamiento con una configuracion verificada (predeterminada). Si tiene una red en vivo,
asegurese de entender el posible impacto de cualquier comando.

Configurar

El protocolo de comunicacion de caché web (WCCP) se utiliza para redirigir el trafico web a un
servidor de caché. Se suele implementar en dispositivos de red como routers y firewalls de Cisco
para redirigir solicitudes HTTP, HTTPS y FTD a través de HTTP a un servidor proxy.

WCCP esta disponible en diferentes versiones, incluidas WCCP v1, v2 y v3, y cada version ofrece
funciones y escalabilidad mejoradas.

Como funciona

 El equipo del usuario Win10-0 realiza una solicitud HTTPS.

» En este caso, el firewall FTD es la puerta de enlace para el PC del usuario. Recibe la
solicitud HTTP/HTTPS.

» FTD entiende que el puerto de destino es 443 y redirige el trafico a DMZ

+ DMZ encapsula el paquete con GRE y reenvia la solicitud al servidor proxy.

 El servidor proxy busca en su caché o inicia una nueva conexion con el servidor original y
responde directamente al equipo del usuario.
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Configuraciones

Estos pasos muestran la configuracion de WCCP en FMC. El trafico con los puertos 80 y 443 se
debe redirigir de la zona interna a la zona DMZ.



Nota: El documento describe los pasos para el id de servicio dinamico. La informacién del
puerto se ha aprendido del cliente WCCP.

Paso 1: Inicie sesién en la GUI de FMC y navegue hasta Object > Object Management > Access
List > Extended >Add Extended Access List .

Cree dos listas de acceso ampliadas.

1) Cree una lista de acceso para redirigir el trafico de los usuarios y haga clic en Guardar.



Edit Extended Access List Object

Name

I Redirect_traffic

Entries (3)

ation U
@ Block  WSA_serer

2 @ Black user_LAN

3 Allow

Allow Overrides

Nota: Esta lista de acceso garantiza que tenga Action Block para el trafico que viene del
cliente WCCP hacia FTD para evitar el loop en la red.



Ademas, puede crear otra instruccion con Action Block para asegurarse de que la
comunicacion entre los hosts internos no se envie al servidor proxy.

La sentencia final debe permitir el resto del trafico que sea elegible para la redireccion al
proxy.

2) Cree una lista de acceso para identificar el cliente WCCP y haga clic en Guardar.

Name

[ wece-cuen
Entries (1)

1 o Allow WSA_server

Allow Overrides

Lista de acceso para identificar el cliente WCCP



Nota: Configuracion de una lista de acceso ampliada para incluir las direcciones IP del
servidor WCCP.

Paso 2: Vaya a Objeto > Administracién de objetos > FlexConfig > Objeto de texto > Agregar
objeto de texto para agregar el servicio WCCP y Guardar.



Edit Text Object T

Mame:

Description:
Variable Type Count
Single v 1
1 a7
|| Allow Overrides

| Cancel | Save

Creando objeto de servicio wcep



Nota: En este ejemplo, el ID de servicio es 97. Se recomienda seleccionar un ID de
servicio entre 90 y 97, ya que se trata de ID de servicio personalizados que normalmente
no entran en conflicto con otros ID de servicio asignados a protocolos especificos.

Para obtener mas detalles, consulte WCCP en ASA: Conceptos, limitaciones y configuracién

Paso 3:

* Vaya a Object > Object Management > FlexConfig > Text Object y Search para
isServiceldentifer.

Text Object ['\"« isServiceldentifie] b4

Text objects define free-form text strings that you use as variables in a FlexConfig object. These objects can have single values or be a list of multiple values


https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html

* Modifique el isServiceldentifer de false a true.
» isServiceldentifer: cuando es false, utiliza el identificador de servicio web-cache estandar.
Consulte el documento Guia de configuracion de Firepower Management Center

Edit Text Object @

Name:

iIsServiceldentifier

Description:

A flag to identity whether to use
service in wecep.

Variable Type Count
Single v =
1 true

Allow Overrides

» Override (0)

Modifique el valor de falso a verdadero



https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html

Nota: Ademas, puede crear un objeto de texto definido por el usuario que se muestra en
el paso 2.

Paso 4:

» Vaya a Object > Object Management > Flex Config > FlexConfig Object.
» Busque la palabra clave wccp.
* Haga clic en la opcién Clone para la plantilla Wccp_Configure.



= o

Firewall Manaae t Canter
irewall Management Center Cvendew Analysis Policies Devices Objects Integration Deploy Q, ﬁm o @ admin ahidn

> AAA Server FlexConfig Object Add FlexConfig Object SN X

* Access List

g Object include device configuration commands, variables, and scripting language instructions. It is used in FlexConfig polices.

Address Pools FlexConf

Application Filters
AS Path Nam o i
BFD Temglate
Wieep_ G The template is 2 mple of weep configur.. 'S

Cipher Suite List

? Community List
DHCP IPvE Pool
» Distinguished Name
DINS Server Group
» External Attributes
File List
"~ FlenConfig
FlexConfg Object
Text Object

Nota: El objeto FlexConfig tiene una plantilla predefinida: Wccp_Configure. La plantilla no
se puede conectar al dispositivo. Usted debe clonar.



Paso 5:

* Quite las variables $serviceldentifier de la tercera linea y proporcione su propia variable.
Add FlexConfig Object (7]
MName:

Weep_Configure_clone

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert « Deployment: Once v Type: Append v
#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set( Sservice = “$sepviceldentifier”
sl —

fset ( SwccpCli = "wccp")
illkwg;pG;pﬁéLi;; isnﬁiééé;holder for extended ACL.
####Replace weepGroupList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#end
###fweccpRedirectlist is place-holder for extended ACL.
###8#Replace wecpRedirectlList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#if( SwccpRedirectList )

fset | SweepCli = "SweopCli redirect-list $weogpRedirectList™)
fend
¥ Variables
Name Dimension Default Value FT’:I':;?;’; ! Override Description
isServiceldentifier SINGLE true FREEFORM:I... false A flag to determine if service ...
serviceldentifier SINGLE 1 FREEFORM:... false service identifier number is to...

Cancel Save

Quitar el identificador de servicio

* Inserte el servicio Text Objectwccp-service como la variable creada en el paso 2.
* En el menu desplegable, seleccione Insertar > Insertar objeto de directiva > Objeto de texto



Add FlexConfig Object

Name:

' Weep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|. Insert . B Deployment: . Once v | Type: ' Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

#set ( SwecepGli = "Sweg

####wcepGroupList is pl Standard ACL Object 3 acr.

####Replace wecepGroupLi 2fined in FMC by inserting policy-object of type extended ACL.
Fif ( $wecpGroupList ) Extended ACL Object

fset( SweepCli = “Sweer JupList")

#end Route Map

####weccpRedirectlist is place-nolaer ror extended ACL.

fend

Inserte el objeto wcep-service como variable

* Proporcione un servicio Variable Namewccp-service.
» Busque wccp-service-object en Available Object.
» Agregue el objeto y guardelo.



Insert Text Object Variable (7]

Variable Name:

| wecep-service ‘

Description:
Available Objects Selected Object
| 2, weep b4 ‘ weep-service-object .

WCCp-=-5erv [ ce-o

wecepPassword

Cancel Save

Agregar objeto de servicio wccp

Paso 6:

» Copie el nombre de la variable wccpGroupList y proporcione su propia variable.



Add FlexConfig Object

Name:

[ Wecep_Configure_clone l

Description

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

llnsertv s Deployment: Once v Type: Append vé

#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set( $service = "$wecp-service")
fend

#set ( SwcopCli = "SwccpCli $service")
] ###fwocepGroup. t is place-holder for extended ACL.
] ####Replace wecpGrouplist with extended ACL defined in FMC by inserting policy-object of type extended ACL.
. #if ( $WCCPGroupList )
| #set( SweepCli = "SwoopCli group-list $weepGrouplist™)

Quitar variable predefinida wecpGrouplList

» En el menu desplegable Insert > Insert Policy Object > Extended ACL Object.

Name:

| Weep_Configure_clone

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

r y r - r
|

Insert v i % Deployment: Once v Type: | Append

. Insert Policy Object Text Object

Insert System Variable »  Network

Insert Secret Key Security Zones

Standard ACL Object  § acr.
2fined in FMC by inserting policy-object of type extended ACL.
Extended ACL Object

¥ Variables

Adicién de ACL extendida de wccpGrouplist

» Pegue el nombre wccpGroupList que ha copiado en el paso anterior de la seccidn Nombre



de variable.
* Busque WCCP-CLIENT en Objetos disponibles creados en el paso 1.
» Anada y guarde el archivo.

Dttt ettt ieiiiiiiiiiiiiiiiieiiiiiiiieiiiiaooen

Insert Extended Access List Object Variable (7]

Variable Name:

; ‘ wccepGrouplList |

f Description:

' Available Objects C Selected Object

| | search X | Bvcep-CLIENT ¥
'ij '—!?edirect_traﬂﬁc

& NCCP-CLIENT

Agregar lista extendida WCCP-CLIENT
Paso 7:

» Seleccione wccpRedirectList para copiar y agregar y proporcionar su propia variable.



Add FlexConfig Object

Name:

( Weep_Configure_clone ]

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v Deployment: I Once v ‘ Type: | Append
f#set ( $service = "web-cache")
#if( $isServiceldentifier == "true")

#if( $wecpGroupl
#set ( SwecepCli =
#end

#end

Quitar wecpRedirectlList

* En el menu desplegable, seleccione Insert > Insert Policy Object > Extended ACL Object .

Add FlexConfig Object

Name:

[ Wecep_Configure_clone ]

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v | k2 Deployment: | Once v Type: | Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

####wccpGrouplist is pl Standard ACL Object  j acL.

####Replace wcepGroupLi fined in FMC by inserting policy-object of type extended ACL.
#if( ) Extended ACL Object

#set ( SwecpCli = "Sweep oupList™)

#end Route Map

###dwccpRedirectlist is place-nolaer ror extended ACL.

###4Replace weepRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#end

¥ Variables

Seleccionar objeto ACL extendido para wccpRedirectList

* Pegue wccpRedirectList en Nombre de variable.



» Busque Redirect_traffic en Available Object.
» Seleccione Add y Save it.

e el eileeiliaeosiisisaiiisisisiiisneiios e = = e e e e

Insert Extended Access List Object Variable @

Variable Name:

‘ wccpRedirectList ‘

Description:

Available Objects C Selected Object
‘ Q_ Search p 4 Lﬁzeorjirect_traﬁ“lc

£ Redirect_traffic

#VCCP-CLIENT

)

Agregar ACL Redirect _traffic

Paso 8:

¢ Eliminar @wccpPassword



Add FlexConfig Object

Name:

[ Wecep_Configure_clone ‘

Description:
The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

| Insert v

3 Deployment: [ Once v | Type: [ Append

FMC by inserting policy-object of type extended ACL.

t is place-holder for extended ACL.
irectList with extended ACL defined

in FMC by inserting policy-object of type extended ACL.

#foreach( $interfaceName in $security-zone)

Se ha eliminado la contrasefia wecppredefinida

+ Seleccione la clave en el menu desplegable Insert > Insert Secret Key.

Add FlexConfig Object

Name:

' Weep_Configure_clone ‘

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘. Insert v ' k2 Deployment: [ Once v l Type: [ Append

Insert Policy Obiect » ace-holder for extended ACL.
v =0 st with extended ACL defined in FMC by inserting policy-object of type extended ACL.
In m Variable »
sert Syste ariable Cli group-list $weepGroupList™)

Insert Secret Ke
place-holder for extended ACL.

in FMC by inserting policy-object of type extended ACL.

#set( SweepCli = "SweepCli password ")

#foreach( $interfaceName in $security-zone)
¥ Variables

Seleccionar clave secreta

* Haga clic en Add Secret Key.




Insert Secret Key @

Add Secret Key

Name

[ ] wccpPassword S u

Cancel Save

Agregar clave secreta

* Introduzca un nombre en Nombre de clave secreta.
 Ingrese la contrasena.
* Introduzca la misma contrasefia en Confirm Password y haga clic en Add.



Add Secret Key

Secret Key name:*

‘ wccpPassword J

Password:*

[ Cancel ] Add

Agregar clave secreta definida por el usuario




Nota: En este ejemplo, la interfaz interior pertenece a la zona de seguridad en.

Paso 9:

« Copie la zona de seguridad predefinida y reemplace $ zona de seguridad por su propia
variable.



Edit FlexConfig Object

Name:

| Weep_Configure_clone |

Description:

The template is an example of
weep configuration. It can not

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Deployment: | Once v | Type: | Append

fforeach( $interfaceName in $SECUrity-ZONe |
weep interface $interfaceName §service redireet in

fend
* \ariables
Property . .

Name Dimension Default Value (Type:Name) Override Description
wcepGrouplist SINGLE WCCP-CLIENT EXD_ACL:W... false

wcecp-service SINGLE 97 FREEFORM:... false

interfaceName SINGLE in SECURITYZ... false

security-zone SINGLE in SECURITYZ... false

Copie el nombre security-zone

» Seleccione Security Zones en el menu desplegable e Insert > Insert Policy Object.



Add FlexConfig Object

Name:

Wecep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert B2 Deployment: I Once v | Type: I Append

Insert Policy Object Text Object supList™)

Insert System Variable »  Network wded ACL.
X . defined in FMC by inserting peolicy-object of type extended ACL.
Insert Secret Key Security Zones
#SEL( PWCCPLLl = "3WCCE K JRedirectList”)
$end Standard ACL Object

#set( SwccpCli = "$wcck Extended ACL Object vord ")
SweepCli Route Map

##4# RAssiging wcop onto interface
#foreach( in $security-zone)

#end

¥ Variables

Seleccione la zona de seguridad

* Pegue el nombre de variable como zona de seguridad

» En Objetos disponibles, seleccione la interfaz que desea agregar.
» Click Save.



Insert Security Zone Variable (7]

Variable Name:

| security-zone |

Description:

Available Objects Selected Object
| C, Search ‘ in

o/

dmz

out

Cancel Save

Agregando zona de seguridad
Paso 10:

* Navegue hasta Dispositivos > FlexConfig, haga clic en Nueva politica o Editar una politica

existente.
+ Seleccione el objeto Wccep_configure_clone configurado y haga clic en > para asignarlo.
+ Click Save.



Nota: En el caso de una nueva directiva, asegurese de asignarla al dispositivo FTD. Para
una politica existente, la politica debe haber sido ya asignada.

WCCP_config E=Z3

Wesp_ Contgure_cions

<7 Selected Append FlexConfigs

Paso 11: Vaya a Deploy > Select the FTD Device > haga clic en Deploy.



Verificacion
Paso 1: Verifique la configuracion en ejecucion.

Inicie sesion en la CLI de FTD y ejecute el comando show running-config wecp.

Ejemplo de configuracion:

wccp 97 redirect-1ist Redirect_traffic group-Tist WCCP-CLIENT password ###*%*%*
wccp interface inside 97 redirect in

Para asegurarse de que la configuracion tenga la contrasefa correcta, ejecute los comandos.
1) system support diagnostic-cli

2) enable

3) Pulse Enter sin contrasena

4) more system:running-config | include wecp

Paso 2: Verificar el estado de WCCP

Ejecute el comando show weep

Global WCCP information:
Router information:
Router Identifier: -not yet determined-
Protocol Version: 2.0

Service Identifier: 97

Number of Cache Engines: 1

Number of routers: 2

Total Packets Redirected: 0

Redirect access-1ist: Redirect_traffic
Total Connections Denied Redirect: 0

Total Packets Unassigned: 0

Group access-Tist: WCCP-CLIENT
Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

Ejecute el comando show wccp 97 service

WCCP service information definition:



Type: Dynamic

Id: 97
Priority: 240
Protocol: 6
Options: 0x00000012
Hash: DstIP
A1t Hash: -none-
Ports: Destination:: 80 443 000000

Nota: Aqui 97 es el service-id. Asegurese de que puede ver el numero de puerto
aprendido del cliente WCCP en Puertos: seccion.

3) Run the command show wccp 97 view

Troubleshoot



Paso 1: Verifique que FTD tenga la ruta de la misma interfaz que recibié la solicitud WCCP del
servidor proxy.

En este ejemplo, el trafico se redirige a la interfaz dmz.

>show route
S 10.xx.xx.xx 255.yyy.yyy.yyy [1/0] via 10.zz.zz.z, dmz

Nota: Aqui 10.xx.xx.xx es la direccion IP del servidor proxy, 255.yyy.yyy.yyy es la
mascara de red, 10.zz.zz.z es la puerta de enlace de préximo salto.

Paso 2: Tome las capturas en la interfaz interna y dmz para asegurarse de que el trafico se
redirija.

Captura en la interfaz interna para el puerto 443



capture capinside interface inside trace detail match tcp any any eq 443

Captura en la interfaz dmz:

capture capdmz interface dmz trace detail match gre any any

Nota: En la interfaz dmz, debe filtrar con el protocolo GRE. El paquete de redireccion se
encapsula en el paquete GRE al cliente wccp.

Paso 3: Depuracion para wcep

Ejecute los comandos:



debug weep event debu weep packet

El error de funcionamiento de Cisco IDCSCvn90518 se ha planteado para su mejora con el fin de
disponer de compatibilidad con el modo nativo de FDM y FMC para la configuracion WCCP.



https://tools.cisco.com/bugsearch/bug/CSCvn90518

Acerca de esta traduccidén

Cisco ha traducido este documento combinando la traduccién automatica y los recursos
humanos a fin de ofrecer a nuestros usuarios en todo el mundo contenido en su propio
idioma.

Tenga en cuenta que incluso la mejor traduccién automatica podria no ser tan precisa como
la proporcionada por un traductor profesional.

Cisco Systems, Inc. no asume ninguna responsabilidad por la precision de estas
traducciones y recomienda remitirse siempre al documento original escrito en inglés (insertar
vinculo URL).



