Introducción
Este documento describe cómo identificar y resolver problemas comunes de la cámara en la aplicación Webex en Windows.
Prerequisites
Requirements
Se recomienda que esté familiarizado con estos temas:
- Sistemas operativos Windows
- Aplicación Webex
Componentes Utilizados
El software que se detalla a continuación se ha utilizado para realizar las pruebas y generar los resultados descritos en este documento:
- Windows 11
- Aplicación Webex en la versión 45.2
La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si tiene una red en vivo, asegúrese de entender el posible impacto de cualquier comando.
Descripción general de problemas comunes de la cámara
Al utilizar Webex en Windows, es posible que los usuarios se encuentren con varios problemas relacionados con la cámara, como:
- Acceso a la cámara denegado.
- Cámara desactivada o no detectada.
- Conflictos de aplicaciones o controladores.
- Dispositivo de cámara no encontrado.
Estos son algunos ejemplos de problemas de conexión de la cámara y los pasos de resolución de problemas para solucionarlos.
Problema 1: Acceso denegado a la cámara
Error:

Registros:
2024-11-25T15:41:28.579Z <Error> [0x3330][]WME:0 ::[WSE] CWseMFSourceReaderSink::CreateSourceReader() ActivateObject failed, hr=-2147024891
2024-11-25T15:41:28.579Z <Info> [0x3330][]WME:0 ::[WSE] CWSEMFVideoCapEngine::Start() Result = -2147024891
2024-11-25T15:41:28.579Z <Error> [0x3330][]WME:0 ::[WME] CWmeLocalVideoTrack::StartCamera, m_pVideoCapEngine start error, ret=1174552834
Causa raíz:
El sistema deniega el acceso a la cámara, posiblemente debido a la configuración de privacidad.
Solución:
1. Abra Configuración en Windows.
2. Vaya a Privacidad y seguridad > Cámara.
3. Asegúrese de que el acceso a la cámara esté habilitado para las aplicaciones y de que Webex pueda acceder a la cámara.
Referencia: Configuración de privacidad de la cámara.

Problema 2: Cámara desactivada
Error:

Registros:
2024-11-25T17:14:42.426Z <Debug> [0x3330][]MediaConnection.cpp:7505 media::Connection::sendMediaErrorDirectly::media error: VideoCameraNoDevicePreCheck
2024-11-25T17:19:03.259Z <Debug> [0x326c][]AudioVideoSettingsViewModel::onMediaDeviceError::2, Media Device Error
Causa raíz:
La cámara está desactivada en los ajustes del sistema o no se detecta.
Solución:
1. Abra el Administrador de dispositivos.
2. Localice la cámara debajo de Cámaras.
3. Haga clic con el botón derecho en el dispositivo y seleccione Enable.

Problema 3: La cámara ya está en uso
Error:

Registros:
2024-11-27T21:04:33.393Z <Warn> [0x2634][]CWseMFSourceReaderSink::OnReadSample failed! Result = -1072875772
2024-11-27T21:04:33.882Z <Debug> [0x1e50][]MediaConnection.cpp:10692 media::Connection::OnError::error type: VideoCameraOccupied
Causa raíz:
Otra aplicación (ejemplo: Zoom, Microsoft Teams) está utilizando la cámara, impidiendo que Webex acceda a ella.
Solución:
1. Cierre cualquier otra aplicación que posiblemente esté utilizando la cámara.
2. Reinicie Webex e inténtelo de nuevo.
Problema 4: Dispositivo de cámara no encontrado
Error:

Registros:
2024-11-22T03:06:53.268Z <Error> [0x492c][]CWseVideoCapDevice::InitCapCapability(), GetBaseFilter_i failed, hr=-2147024894
Causa raíz:
El código de error 0x80070002 (ERROR_FILE_NOT_FOUND) indica que no se ha encontrado el dispositivo de cámara.
Solución:
1. Abra Administrador de dispositivos y desinstale la cámara web integrada.
2. Reinicie el sistema y deje que Windows reinstale el controlador automáticamente.
3. Asegúrese de que el controlador de la cámara esté actualizado.
4. Compruebe si el software antivirus bloquea el acceso de Webex al dispositivo.