CHAPTER 7

Working with Spectrum Tabs, Plots, and Charts

Spectrum Tabs, Plots, and Charts Overview

Cisco Spectrum Expert software provides two spectrum tabs, Spectrum and Spectrum (2). Each tab
operates identically. The tabs allow you to create, name, and save two distinct configurations of plots
and charts. (You can create and save more than two plot/chart configurations; but you can have two of
them as defaults that automatically appear on these tabs.)

Descriptions of the specific charts and plots—including the parameters for fine-tuning the plot/chart
content—may be found in the Online Help, and in “Using Spectrum View Plots” and “Using Spectrum
View Charts” of this guide. This chapter provides an overview of how to use these tabs (Spectrum and
Spectrum (2)) to create your custom plot/chart views.

Create A Spectrum Plot or Chart

Step 1

Step 2

Note

To add a spectrum plot or chart, follow these steps:

Right-click in the workspace for the spectrum plots and select
Add Plot > <Plot Type> or Add Chart > <Chart Type>.

You can also use the menu
Spectrum > Add Plot > <Plot Type> or Spectrum > Add Chart > <Chart Type>.

Use the Plot Control panel at the left of the display to set the parameters for the plot or chart. The
particular parameters will vary depending on the type of plot. An overview of the Plot Control panel is
presented in “Spectrum Plot Controls.” Detailed descriptions of chart parameters are also contained in
the Cisco Spectrum Expert Software Online Help system.

Of particular importance for the spectrum plots, and for some of the
charts — in order to see any data displayed at all, you need to select
the On button for at least one Trace. A Trace describes the line of
data shown on a plot.

= Trace1 ®on  OoOff
Type Max
= Tracez ®on  (OOFf

Type Average
By default, the Trace or Traces for a plot are set to Off. 3 Oon  @of
|8
Max Hold B

e If you are in a Spectrum tab and the Controls are not visible, select View > Control Panel.
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e To access the plot Control Panel for a particular plot or chart, simply use the mouse to click on that
plot.

~

Note If you have more than one plot in view, then as you click on different plots, the plot Control
Panel will display the configuration options for the currently selected plot.

Multiple Plots

You can repeat the instructions immediately above to place more than one plot on display. You can
configure any combination of up to nine plots and charts (in 1024x768 mode or higher), or four plots
and charts (in 800x600 mode) per Spectrum View tab.

Measurement Interval

Unless you have paused a plot (discussed below), the Cisco Spectrum Expert Software updates each plot
or chart once per measurement interval, which is typically once every second.

Pause and Resume Plotting

At times an event may occur in your network, such that you want to immediately capture the RF
environment at that moment for sustained study and review. You can pause and resume plots and charts
by right-clicking in the workspace, and selecting the appropriate menu options, or by selecting these
options from the Spectrum menu (For example, Spectrum i Select All Items I Pause Selected Items):

¢ Select All Items—Selects all plots/charts displayed in the currently selected Spectrum tab and
enables the Spectrum menu options.

¢ Pause Selected Items—Freezes the data displayed on the currently selected plot(s) or chart(s). Be
sure to right-click on the appropriate plot/chart when you bring up the context menu.

¢ Resume Selected Items—Resumes the real-time data display for the currently selected
plot/chart(s).

¢ Pause Selected Items—Freezes the data display on all plots/charts.

¢ Resume Selected Items—Resumes the real-time update of data on all plots/charts.

Copying Plots and Charts

All plots and charts displayed in Cisco Spectrum View can be copied and pasted within the pane area of the
window. You can copy and paste a plot or chart using on of the following three methods.

Method 1
Click on the top of the plot frame and hold down the <Ctrl> key. The cursor changes to indicate copy mode.
Move the mouse to the desired location.

Release the mouse button to paste a copy of the plot or chart. The copied plot or chart is subject to total
count checking and PvT/PvF trace limit checking.
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Method 2

Select a plot.
Press <Ctrl + C>. The selected plot is copied to the clipboard.

Method 3

Right-click on a plot or chart to display the pop-up menu. Or, select Spectrum from the Main menu to
display the drop-down menu.

Select the Copy option. The selected plot is copied to the clipboard.

Pasting Plots and Charts from the Clipboard

Step 1
Step 2
Step 3

Spectrum View plots and charts can be retrieved from the clipboard and pasted into your current
Spectrum View session, an additional Spectrum View session running on your machine, or a different
machine running Cisco Spectrum Expert Software with the same card type. The paste feature is subject
to total plot/chart count checking and PvT/PvF trace limit checking.

To paste a plot from the clipboard, follow these steps:

Open the clipboard and copy the desired plot.

Right-click within the View pane to display the pop-up menu.

Press <Ctrl + V>. The plot gets pasted to the end of the view.

Or, you can paste a plot from the clipboard using the Main menu as follows:
a. Open the clipboard and copy the desired plot.

b. Select Spectrum from the Main menu to display the drop-down menu.

c. Select the Paste option. The plot gets pasted to the end of the view.

Cutting Plots and Charts

Step 1
Step 2

Use any of the following methods to cut a plot or chart:

Method 1

Select a plot.

Press <Ctrl + X>. This removes the plot and copies it to the clipboard.

Method 2
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Step1  Right-click a plot to display the pop-up menu.
Step2  Select the Cut option. This removes the plot from the display and copies it to the clipboard.

Method 3

Step1  Select a plot.
Step2  Select Spectrum from the Main menu to display the drop-down menu.

Step3  Select the Cut option. This removes the plot from the display and copies it to the clipboard.

Method 4

Step1  Left-click on the plot or chart of interest.
Step2  Press Delete.

Method 5

Step1  Left-click on the X icon located in the upper right-hand corner of the plot or chart.

Method 6

Step1  Left-click on the plot or chart of interest.

Step2  Select Spectrum f Remove Selected Item... from the Main menu to display the drop-down menu.

Moving Plots and Charts

All plots and charts displayed in Spectrum View can be moved within the pane area of the window.
Method 1

Step1  Left-click on the top banner of the plot frame.
Step2  Drag the plot to the desired location. A blinking vertical line indicates the new location.

Step3  Release the mouse button to drop the plot in the new location.

Method 2

Step1  Right-click on the top banner of the plot frame.
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Step2  Drag the plot to the desired location. A blinking vertical line indicates the new location.
Step3  Release the mouse button to drop the plot in the new location. A pop-up menu displays.
Step4  Select on of the following options:

e Copy Here—pastes a duplicate of the original plot in this location.

e Move Here—relocates the original plot to this location.

¢ Cancel—terminates the operation.

Selecting Multiple Plots and Charts

In cases where you need to perform the same operation on more than one plot or chart, multiple plots
and charts can be selected. For example, you may want to remove, pause, or resume more than one plot
at the same time.

Note  When multiple plots and charts are selected, the control panel displays a message indicating that
Multiple items are selected and no controls are available for configuring plots and charts.

Multiple plots and charts can be selected as follows:

Step1  Hold down the <Ctrl> key.
Step2  Left-click each plot to select it.

Zoom In/Out

For optimal viewing, a plot or chart can be maximized (zoom in) and minimized (zoom out) to its
original size. A plot or chart in Zoom In mode is indicated by an orange background. Additionally, you
can zoom in/out on up to two plots or charts at the same time.

To zoom in/out a single plot, follow these steps:

Step1  Double-click, or right-click, the frame or left click the magnifying glass icon of the plot to maximize it.
The orange background indicates Zoom In mode.

Step2  Double-click the frame or left-click the magnifying glass icon to minimize it.

Or, use the View menu to zoom in/out:

Step 1 Select a plot.

Step2  Select Spectrum from the Main menu to display the drop-down menu. Or, right-click within the View
pane to display the pop-up menu.
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Step 3

Step 1
Step 2

Step 1
Step 2
Step 3

Step 4

Select the Zoom In option to maximize the plot. Or, select Zoom Qut to minimize it.

To zoom in/out multiple (up to two) plots, follow these steps:

Hold down the <Ctrl> key.

Double-click the frame of each plot to maximize them. Or, double-click each frame to minimize them.

Or, use the View menu to zoom in/out multiple plots:

Hold down the <Ctrl> key.
Select the plots.

Select Spectrum from the Main menu to display the drop-down menu. Or, right-click within the View
pane to display the pop-up menu.

Select the Zoom In option to maximize the plot. Or, select Zoom Out to minimize it.

Saving and Restoring Spectrum View Layouts

Note

Step 1

Step 2

Other operations are available for working with plots and charts. The operations Open Spectrum View
Configuration..., Save Spectrum View Configuration..., and New Spectrum View Configuration
can all be selected from the Spectrum menu. Remove Selected Items... can be selected from the
Spectrum menu.

All these operations can also be selected by right-clicking on the frame of a plot or chart, and selecting
from the context menu that appears.

e Save Spectrum View Configuration—Enables you to save the current configuration of open plots
and charts, including their specific display parameters. (The current data, however, is not saved.)

In the Save Spectrum View Configuration dialog, type in the name for your configuration, or select the
name of a previously defined configuration.

a~

Note  The name you type here will also appear on the Spectrum and Spectrum(2) tabs, so we suggest
you use something short but descriptive, for example, “Plots Only”, “Charts Only”, “Duty Cycle
Charts and Plot”, “Devices and RF Power”, and so on.

To make the current configuration be the default configuration, be sure to first select the Set as startup
default for this view check box. If you select this, the current configuration will appear every time you
log into the Cisco Spectrum Expert Software, and select the current tab.

~

Note  You can save a separate default view for each Spectrum tab.
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Select [OK] to save or Cancel to exit without saving changes..

¢ Open Spectrum View Configuration...—The dialog box for this operation will list all of your
currently saved spectrum views. Select one view, and then select OK.

e New Spectrum View Configuration—This operation clears all currently displayed plots.

¢ Remove Selected Items...—This operation will close only the currently selected plot.

Deleting A Spectrum View

Step 1

Step 2
Step 3
Step 4

To delete a saved spectrum view, follow these steps:

Right-click on the Plots workspace and select Save Spectrum View Configuration or Select File >
Save Spectrum View Configuration.

In the Save Spectrum View Configuration dialog, select an existing view.
Select Remove Saved Configuration.

Select OK on the confirmation dialog box.

Exporting Data

The Export Data feature provides additional functionality to all Spectrum plots and charts, as well as
the active devices listed in the Active Devices tree. This feature allows you to export device information
to a file for future analysis. This option can be accessed by right-clicking on a device name, on any plot
or chart, or anywhere in the display pane to display a pop-up menu.

When Export Selected Data... is selected, a window appears providing a default file name and Save in
location (Spectrum Captures folder). The window also allows user selection of the file name and Save
in location. A sample exported data file for an Interference Power chart is as follows:

Table 7-1 Interference Power

Interference Power

Vertical Scale: 10 dBm /

Channel In-Network Wi-Fi AP Max Interference Cordless Phones Wi-FiCCI  Wi-Fi ACI
WiFi Ch. 1 -85 -78.6 -81.2 -85

WiFi Ch. 2 -78.6 -81.2 -82.4
WiFi Ch. 3 -90 -78.6 -81.2 -80.1
WiFi Ch. 4 -78.6 -81.2 -74.9
WiFiCh. 5 -78.6 -81.2 -70.9
WiFi Ch. 6 -71 -78.6 -81.2 -83 -88
WiFi Ch. 7 -78.6 -81.2 -70.7
WiFi Ch. 8 -84 -78.6 -81.2 -70.2
WiFi Ch. 9 -78.6 -81.2 -65.8
WiFi Ch. 10 -78.6 -81.2 -62
WiFi Ch. 11 -62 -78.6 -81.2 -87
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