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Context Aware Planning and Verification

This chapter describes a number of tools and configurations that can be used to enhance the location 
accuracy of elements (clients, tags, rogue clients, and rogue access points) within an indoor or outdoor 
area.

Context Aware Software (CAS) installed on a mobility services engine retrieves location as well as other 
contextual information such as temperature and asset availability about a client or tag (Cisco CX version 
1 or later) from access points.

Note Non-Cisco CX tags are not tracked or mapped by Cisco WCS.

Note Context Aware Software was previously referred to as Cisco location-based services. 

This chapter contains the following sections:

• “Planning for Data, Voice, and Location Deployment” section on page 7-2

• “Creating and Applying Calibration Models” section on page 7-3

• “Inspecting Location Readiness and Quality” section on page 7-8

• “Verifying Location Accuracy” section on page 7-9

• “Using Chokepoints to Enhance Tag Location Reporting” section on page 7-12

• “Using Location Sensors to Enhance Tag Location Reporting” section on page 7-18

• “Using Location Optimized Monitor Mode to Enhance Tag Location Reporting” section on 
page 7-22

• “Defining Inclusion and Exclusion Regions on a Floor” section on page 7-23

• “Defining a Rail Line on a Floor” section on page 7-27

• “Enabling Location Presence on a Mobility Services Engine” section on page 7-28

• “Modifying Context Aware Software Parameters” section on page 7-30
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Planning for Data, Voice, and Location Deployment
Note • You must purchase licenses from Cisco to retrieve contextual information on tags and clients from 
access points. Licenses for tags and clients are offered independently. (The clients’ license also 
includes tracking of rogue clients and rogue access points).

• For details on tag and client licenses, refer to the Cisco 3350 Mobility Services Engine Release Note 
at: http://www.cisco.com/en/US/products/ps9742/tsd_products_support_series_home.html

Planning for Data, Voice, and Location Deployment
You can calculate the recommended number and location of access points based on whether data and/or 
voice traffic and/or location will be active.

To calculate recommended number and placement of access points for a given deployment, follow these 
steps:

Step 1 In Cisco WCS, click Monitor > Maps.

Step 2 Click on the appropriate location link from the list that displays.

A map appears showing placement of all installed elements (access points, clients, tags) and their 
relative signal strength.

Step 3 Select Planning Mode from the Select a command menu found at the top-right of the window. Click GO.

A color-coded map summarizing contributing access points appears.

Step 4 Click Add APs to open a window to enter data necessary to calculate the recommended number of access 
points.

Step 5 In the window that appears, drag the dashed rectangle over the map location for which you want to 
calculate the recommended access points.

Note Adjust the size or placement of the rectangle by selecting the edge of the rectangle and holding 
down the Ctrl key. Move the mouse as necessary to outline the targeted location.

Step 6 Check the check box next to the service that will be used on the floor. Options are Data/Coverage 
(default), Voice, Location and Location with Monitor Mode APs. Click Calculate.

The recommended number of access points given the services requested appears.

Note Each service option is inclusive of all services that are listed above it. For example, if you check 
the Location box, the calculation will consider data/coverage, voice and location in determining 
the optimum number of access points required.

Note Recommended calculations assume the need for consistently strong signals. In some cases, 
fewer access points may be required than recommended.

Step 7 Click Apply to generate a map based on the recommendations to see recommended placement of the 
access points in the selected area.
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Creating and Applying Calibration Models
Note Check the Location services option to ensure that the recommended access points will provide 
the true location of an element within 10 meters at least 90% of the time.

Creating and Applying Calibration Models
If the provided RF models do not sufficiently characterize the floor layout, you can create a calibration 
model that is applied to the floor and better represents the attenuation characteristics of that floor. In 
environments in which many floors share common attenuation characteristics (such as in a library), one 
calibration model can be created and then applied to floors with the same physical layout and same 
deployment.

You can collect data for a calibration using one of two methods:

• Data point collection–Calibration points are selected and their coverage area is calculated one 
location at a time.

• Linear point collection–A series of linear paths are selected and then calculated as you traverse the 
path. This approach is generally faster than the data point collection. You can also employ data point 
collection to augment data collection for locations missed by the linear paths.

Note Calibration models can only be applied to clients, rogue clients, and rogue access points. Calibration for 
tags is done using the Aeroscout System Manager. Refer to the following link for details on tag 
calibration at: http://support.aeroscout.com.

Note A client device that supports both 802.11a/n and 802.11b/g/n radios is recommended to expedite the 
calibration process for both spectrums.

Use a laptop or other wireless device to open a browser to Cisco WCS and perform the calibration 
process.

To create and apply calibration models, follow these steps:

Step 1 Navigate to Monitor > Maps and click RF Calibration Models from the Select a command drop-down 
menu. Click GO.

Step 2 Choose Create New Model from the Select a command drop-down menu in the upper right. Click GO.

Step 3 Assign a name to the model and click OK.

Step 4 The new model appears along with the other RF calibration models, but its status is listed as Not Yet 
Calibrated. To start the calibration process, click on the hyperlink associated with the new model name. 
A new window appears which indicates the details of the new model. In the upper right-hand corner, 
choose Add Data Points from the Select a command drop-down menu and click GO.

Step 5 If this process is being performed from a mobile device connected to WCS through the Cisco Centralized 
architecture, the MAC address field is automatically populated with the device’s address. Otherwise, you 
can manually enter the MAC address of the device being used to perform the calibration. MAC addresses 
that are manually entered must be delimited with colons (such as FF:FF:FF:FF:FF:FF).
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Creating and Applying Calibration Models
Step 6 Choose the appropriate campus, building, and floor where the calibration is performed (see Figure 7-1). 
Click Next.

Figure 7-1 Starting to Calibrate

Step 7 When the chosen floor map and access point locations display, a grid of plus marks (+) indicates the 
locations where data collection for calibration is performed. 

Using these locations as guidelines, you can perform either a point or linear collection of data by 
appropriate placement of either the Calibration Point pop-up (point) or the Start and Finish pop-ups 
(linear) that display on the map when the respective options are displayed. Figure 7-2 shows the starting 
window for a point calibration.
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Creating and Applying Calibration Models
Figure 7-2 Positioning Calibration Points

a. If you want to do a point collection of data for the calibration, do the following:

1. Select Point from the Collection Method drop-down menu and check the Show Data points 
check box if not already checked. A calibration point pop-up displays on the map.

2. Position the tip of the calibration point pop-up at a data point (+) and click GO. A panel appears 
showing the progress of the data collection.

Note Rotate the calibrating client laptop during data collection so that the client is heard 
evenly by all access points in the vicinity. 

3. When the data collection is complete for a selected data point and the coverage area is plotted 
on the map, move the calibration point pop-up to another data point and click GO.

Note The coverage area plotted on the map is color-coded and corresponds with the specific 
wireless LAN standard used to collect that data. Information on color-coding is 
provided in legend on the left-hand side of the window. Additionally, the progress of the 
calibration process is indicated by two status bars above the legend, one for 802.11a/n 
and one for 802.11b/g/n.

Note To delete data points for locations selected in error, click Delete and move the black 
square that appears over the appropriate data points. Resize the square as necessary by 
pressing Ctrl and moving the mouse.

4. Repeat steps a1 to a3 until the calibrations status bar of the relevant spectrums (802.11a/n, 
802.11b/g/n) display as ‘done.’ b/g/n) display as ‘done.’ 
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Creating and Applying Calibration Models
Note The calibration status bar indicates data collection for the calibration as done, after 
roughly 50 distinct locations and 150 measurements have been gathered. For every 
location point saved in the calibration process, more than one data point is gathered. The 
progress of the calibration process is indicated by two status bars above the legend, one 
for 802.11b/g/n and one for 802.11a/n.

b. If you want to do a linear collection of data for the calibration, do the following:

1. Select Linear from the Collection Method drop-down menu and check the Show Data points 
check box if not already checked. A line appears on the map with both Start and Finish pop-ups.

2. Position the tip of the Start pop-up at the starting data point.

3. Position the Finish pop-up at the ending data point. 

4. Position yourself with your laptop at the starting data point and click GO. Walk steadily towards 
the end point along the defined path. A panel displays to show that data collection is in process.

Note Do not stop data collection until you reach the end point even if the data collection bar 
indicates completion.

5. Press the space bar (or Done on the data collection panel) when you reach the end point. The 
collection panel displays the number of samples taken before it closes to reveal the map. The 
map displays all the coverage areas where data was collected. (see Figure 7-3).

Note To delete data points for locations selected in error, click Delete and move the black square 
that appears over the appropriate data points. Resize the square as necessary by pressing 
Ctrl and moving the mouse.
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Figure 7-3 Linear Data Collection

Note The coverage area is color-coded and corresponds with the specific wireless LAN 
standard used to collect that data. Information on color-coding is provided in legend on 
the left-hand side of the window.

6. Repeat steps b2 to b5 until the status bar for the respective spectrum is filled in (done).

Note You can augment linear collection with data point collection to address missed coverage 
areas.

Step 8 Click on the name of the calibration model at the top of the window to return to the main screen for that 
model to calibrate the data points. 

Step 9 Select Calibrate from the Select a command drop-down menu and click GO.

Step 10 Click the Inspect Location Quality link when calibration completes. A map displays showing RSSI 
readings displays.

Step 11 To use the newly created calibration model, you must apply the model to the floor on which it was 
created (and on any other floors with similar attenuation characteristics as well). Navigate to Monitor 
> Maps and find the specific floor to which the model is applied. At the floor map interface, choose Edit 
Floor Area from the drop-down menu and click GO.

Step 12 From the Floor Type (RF Model) drop-down menu, choose the newly created calibration model. Click 
OK to apply the model to the floor.
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Inspecting Location Readiness and Quality
Note This process can be repeated for as many models and floors as needed. After a model is applied 
to a floor, all location determination performed on that floor is done using the specific collected 
attenuation data from the calibration model.

Inspecting Location Readiness and Quality
You can configure Cisco WCS to verify the ability of the existing access point deployment to estimate 
the true location of a client, rogue client, rogue access point, or tag within 10 meters at least 90% of the 
time. The location readiness calculation is based on the number and placement of access points.

You can also check the location quality and the ability of a given location to meet the location 
specification (10 m, 90%) based on data points gathered during a physical inspection and calibration. 

Inspecting Location Readiness Using Access Point Data
To inspect location readiness using access point data, follow these steps:

Step 1 In Cisco WCS, click Monitor > Maps.

Step 2 Click on the appropriate floor location link from the list that displays.

A map displays showing placement of all installed elements (access points, clients, tags) and their 
relative signal strength.

Note If RSSI is not displayed, you can enable AP Heatmaps under the Layer menu (top-left).

Step 3 Select Inspect Location Readiness from the Select a command menu found at the top-right of the 
window. Click GO.

A color-coded map appears showing those areas that do (Yes) and do not (No) meet the 10 meter, 90% 
location specification.

Inspecting Location Quality Using Calibration Data
After completing a calibration model based on data points generated during a physical tour of the area, 
you can inspect the location quality of the access points. To inspect location quality based on calibration, 
follow these steps:

Step 1 In Cisco WCS, click Monitor > Maps.

Step 2 Choose RF Calibration Model from the Select a command menu. Click GO.

A list of calibration models appears.

Step 3 Click the appropriate calibration model.
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Verifying Location Accuracy
Details on the calibration including date of last calibration, number of data points by signal type 
(802.11a, 802.11 b/g) used in the calibration, location, and coverage are displayed.

Step 4 At the same window, click the Inspect Location Quality link found under the Calibration Floors 
heading.

A color-coded map noting percentage of location errors appears.

Note You can modify the distance selected to see the effect on the location errors.

Verifying Location Accuracy
By checking for location accuracy, you are checking the ability of the existing access point deployment 
to estimate the true location of an element within 10 meters at least 90% of the time.

You can analyze the location accuracy of non-rogue and rogue clients and asset tags by using the 
Accuracy Tool.

The Accuracy Tool enables you to run either a scheduled or on-demand location accuracy test. Both tests 
are configured and executed through a single window.

Using the Accuracy Tool to Conduct Accuracy Testing
There are two methods of conducting location accuracy testing:

• Scheduled Accuracy Testing–Employed when clients and tags are already deployed and associated 
to the wireless LAN infrastructure. Scheduled tests can be configured and saved when clients and 
tags are already pre-positioned so that the test can be run on a regularly, scheduled basis.

• On demand Accuracy Testing–Employed when elements are associated but not pre-positioned. On 
demand testing allows you to test the location accuracy of clients and tags at a number of different 
locations. It is generally used to test the location accuracy for a small number of clients and tags.

Both are configured and executed through a single window.

Note The Advanced Debug option must be enabled in Cisco WCS to allow use of both the Scheduled and 
On-demand location accuracy testing features. Additionally, the Accuracy Tool does not appear as an 
option under the Tools menu when the Advanced Debug option is not enabled.

Follow these steps to enable the advanced debug option in Cisco WCS. 

Step 1 In Cisco WCS, click Monitor > Maps.

Step 2 Select Properties from the Select a command drop-down menu and click GO.

Step 3 Select Enabled from the Advanced Debug drop-down menu. Click OK.

Note If Advanced Debug is already enabled, you do not need to do anything further. Click Cancel.
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Verifying Location Accuracy
You can now run location accuracy tests on the mobility services engine using the Accuracy Tool.

Using Scheduled Accuracy Testing to Verify Accuracy of Current Location

To configure a scheduled accuracy test, do the following:

Step 1 Click Tools > Accuracy Tool.

Step 2 Select New Scheduled Accuracy Test from the Select a command drop-down menu.

Step 3 Enter a Test Name.

Step 4 Select the Area Type from the drop-down menu.

Step 5 Campus is configured as Root Area, by default. There is no need to change this setting.

Step 6 Select the Building from the drop-down menu.

Step 7 Select the Floor from the drop-down menu.

Step 8 Select the begin and end time of the test by entering the days, hours and minutes. Hours are entered using 
a 24-hour clock.

Note When entering the test start time, be sure to allow enough time prior to the test start to position 
testpoints on the map.

Step 9 Select the Destination point for the test results. You can have the report emailed to you or download the 
test results from the Accuracy Tests > Results window. Reports are in PDF format.

Note If you select the email option, a SMTP Mail Server must first be defined for the target email 
address. Click Administrator > Settings > Mail Server to enter the appropriate information.

Step 10 Click Position Testpoints. The floor map appears with a list of all clients and tags on that floor with 
their MAC addresses.

Step 11 Click the check box next to each client and tag for which you want to check the location accuracy. 

When you check a MAC address check box, two icons which overlay each other appear on the map.

One icon represents the actual location and the other the reported location. 

Note To enter a MAC address for a client or tag that is not listed, check the Add New MAC check box 
and enter the MAC address and click Go. An icon for the element appears on the map.If the 
newly added element is on the mobility services engine but on a different floor, the icon displays 
in the left-most corner (0,0 position).

Step 12 If the actual location for an element is not the same as the reported location, drag the actual location icon 
for that element to the correct position on the map. Only the actual location icon can be dragged.

Step 13 Click Save when all elements are positioned. A panel appears confirming successful accuracy testing.

Step 14 Click OK to close the confirmation panel. You are returned to the Accuracy Tests summary window.
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Verifying Location Accuracy
Note The accuracy test status displays as Scheduled when the test is about to execute. A status of 
Running displays when the test is in process and Idle when the test is complete. A Failure status 
appears when the test is not successful. 

Step 15 To view the results of the location accuracy test, click the test name and then select the Results tab on 
the page that displays.

Step 16 At the Results panel, click the Download link under the Saved Report heading to view the report. 

The Scheduled Location Accuracy Report includes the following information:

• A summary location accuracy report that details the percentage of elements that fell within various 
error ranges.

• An error distance histogram

• A cumulative error distribution graph

• An error distance over time graph

• A summary by each MAC address whose location accuracy was tested noting its actual location, 
error distance and a map showing its spatial accuracy (actual vs. calculated location) and error 
distance over time for each MAC.

Using On-demand Accuracy Testing to Test Location Accuracy

An On demand Accuracy Test is run when elements are associated but not pre-positioned. On demand 
testing allows you to test the location accuracy of clients and tags at a number of different locations. It 
is generally used to test the location accuracy for a small number of clients and tags.

To run an On-demand Accuracy Test, do the following:

Step 1 Click Tools > Accuracy Tool.

Step 2 Select New On demand Accuracy Test from the Select a command drop-down menu.

Step 3 Enter a Test Name.

Step 4 Select the Area Type from the drop-down menu.

Step 5 Campus is configured as Root Area, by default. There is no need to change this setting.

Step 6 Select the Building from the drop-down menu.

Step 7 Select the Floor from the drop-down menu.

Step 8 Tests results are viewed at the Accuracy Tests > Results window. Reports are in PDF format.

Step 9 Click Position Testpoints. The floor map appears with a red cross hair at the (0,0) coordinate.

Step 10 To test the location accuracy and RSSI of a particular location, select either client or tag from the 
drop-down menu on the left. A list of all MAC addresses for the selected option (client or tag) displays 
in a drop-down menu to its right.

Step 11 Select a MAC address from the drop-down menu and move the red cross hair to a map location and click 
the mouse to place it.

Step 12 Click Start to begin collection of accuracy data. 
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Using Chokepoints to Enhance Tag Location Reporting
Step 13 Click Stop to finish collection. You should allow the test to run for at least two minutes before clicking 
Stop.

Step 14 Repeat Step 10 to Step 13 for each testpoint that you want to plot on the map. 

Step 15 Click Analyze when you are finished mapping the testpoints.

Step 16 Select the Results tab on the panel that appears.

The On-demand Accuracy Report includes the following information:

• A summary location accuracy report that details the percentage of elements that fell within various 
error ranges.

• An error distance histogram

• A cumulative error distribution graph

Note You can download logs for accuracy tests from the Accuracy Tests summary page.

• To do so, check the listed test check box and select either Download Logs or Download Logs for 
Last Run from the Select a command menu and click GO. 

• The Download Logs option downloads the logs for all accuracy tests for the selected test(s).

• The Download Logs for Last Run option downloads logs for only the most recent test run for the 
selected test(s).

Using Chokepoints to Enhance Tag Location Reporting
Installing chokepoints provides enhanced location information for active RFID tags. When an active 
Cisco CX version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated by the 
chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the 
stimulated tag. All access points that detect this tag beacon then forward the information to the controller 
and location appliance.

Using chokepoints in conjunction with active Cisco CX compliant tags provides immediate location 
information on a tag and its asset. When a Cisco CX tag moves out of the range of a chokepoint, its 
subsequent beacon frames do not contain any identifying chokepoint information. Location 
determination of the tag defaults to the standard calculation methods based on RSSIs reported by access 
point associated with the tag.

Adding Chokepoints to the Cisco WCS
Chokepoints are installed and configured as recommended by the chokepoint vendor. When the 
chokepoint is installed and operational, you can add the chokepoint to the location database and 
positioned on a Cisco WCS map.

Note Chokepoints (also known as exciters) are managed by the chokepoint vendor’s application. For details 
refer to the AeroScout Context-Aware Engine for Tags, for Cisco Mobility Services Engine User’s Guide 
for configuration details at the following link: http://support.aeroscout.com. 
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Using Chokepoints to Enhance Tag Location Reporting
To add a chokepoint to Cisco WCS, follow these steps:

Step 1 Click Configure > Chokepoints from the main menu (top). 

The All Chokepoints summary window appears.

Step 2 Select Add Chokepoint from the Select a command menu and click GO.

The Add Chokepoint entry screen appears.

Figure 7-4 Add Chokepoint Window

Step 3 Enter the MAC address, name, and coverage range for the chokepoint.

Note The chokepoint range is product-specific and is supplied by the chokepoint vendor.

Step 4 Check the Entry/Exit Chokepoint check box if you want the chokepoint to function as an perimeter 
chokepoint. Its function is to track the entry and exit of clients and tags from an area or floor. 

Note If a tag shows strong RSSIs on two floors, you can check for the last perimeter chokepoint the 
tag passed to determine its current floor.

Step 5 Click OK to save the chokepoint entry to the database.

The All Chokepoints summary window appears with the new chokepoint entry listed (Figure 7-5).
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Figure 7-5 All Chokepoints Summary Window

Note After you add the chokepoint to the database, you can place the chokepoint on the appropriate 
WCS floor map.

Step 6 To add the chokepoint to a map, click Monitor > Maps (Figure 7-6).

Figure 7-6 Monitor > Maps Window

Step 7 At the Maps window, select the link that corresponds to the floor location of the chokepoint. The floor 
map appears (Figure 7-7).
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Figure 7-7 Selected Floor Map 

Step 8 Select Add Chokepoints from the Select a command menu. Click GO. 

The Add Chokepoints summary window appears (Figure 7-8).

Note The Add Chokepoints summary window lists all recently-added chokepoints that are in the 
database but not yet mapped.

Figure 7-8 Add Chokepoints Summary Window

Step 9 Check the box next to the chokepoint to be added to the map. Click OK (bottom of screen). 

A map appears with a chokepoint icon located in the top-left hand corner. You can now place the 
chokepoint on the map.

Step 10 Left click on the chokepoint icon and drag and place it in the proper location (Figure 7-9).
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Figure 7-9 Chokepoint Icon is Positioned on the Floor Map

Note The MAC address, name, and coverage range of the chokepoint appear in the left panel when 
you click on the chokepoint icon for placement.

Step 11 Click Save when icon is correctly placed on the map.

You are returned to the floor map and the added chokepoint appears on the map (Figure 7-10).

Note The icon for the newly added chokepoint may or may not appear on the map depending on the 
display settings for that floor. If the icon did not appear, proceed with Step 11.

Figure 7-10 New Chokepoint Displayed on Floor Map
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Note The rings around the chokepoint icon indicate the coverage area. When a Cisco CX tag and its 
asset passes within the coverage area, location details are broadcast and the tag is automatically 
mapped on the chokepoint coverage circle. When the tag moves out of the chokepoint range, its 
location is calculated as before and it is no longer mapped on the chokepoint rings.

Note MAC address, name, and range of a chokepoint display when you pass a mouse over its map icon

Step 12 If the chokepoint does not appear on the map, click Layers to collapse a selection menu of possible 
elements to display on the map. Click the Chokepoints check box.

The chokepoint appears on the map (Figure 7-11).

Figure 7-11 Chokepoints Displayed on Map

Step 13 Click X to close the Layers window.

Note Do not select Save Settings unless you want to save this display criteria for all maps.

Removing Chokepoints from the WCS Database and Map
You can remove one or multiple chokepoints at a time.

Follow these steps to delete a chokepoint.

Step 1 Click Configure > Chokepoints. The All Chokepoints window appears.

Step 2 Check the box(es) next to the chokepoint(s) to be deleted.

Step 3 Select Remove Chokepoints from the Select a command drop-down menu. Click GO (Figure 7-12).
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Figure 7-12 Removing a Chokepoint

Step 4 To confirm chokepoint deletion, click OK in the pop-up window that appears.

You are returned to the All Chokepoints window. A message confirming deletion of the chokepoint 
appears. The deleted chokepoint(s) is no longer listed in the window.

Using Location Sensors to Enhance Tag Location Reporting
The location sensor (also known as a Wi-Fi TDOA location receiver) is an external system designed to 
receive signals transmitted from a tagged, tracked asset. These signals are then forwarded to the mobility 
services engine to aid in the location calculation of the asset. Location sensors use the method of Time 
Difference of Arrival (TDOA) to calculate tag location. This method uses data from a minimum of three 
location sensors to generate a tagged asset’s location.

Note • If a TDOA location sensor is not in use and the partner engine software is resident on the mobility 
service engine, then the location calculations for tags are generated using RSSI readings from access 
points. 

• If the partner software engine is not installed and no location sensor is in use, no tag location 
calculations are done.

Before using a location sensor within the Cisco Unified Wireless Network, you must:

1. Have a mobility services engine active in the network.

Refer to Chapter 2, “Adding and Deleting Systems” for details on adding a mobility services engine.

2. Add the location sensor to the Cisco WCS database and map.

Refer to “Adding Location Sensors to Cisco WCS and Maps” section on page 7-19 for details on 
adding the location sensor to Cisco WCS.

3. Download the partner engine software to the mobility services engine using Cisco WCS.

Refer to “Downloading Software for Location Sensors” section on page 7-21 for details on 
downloading the software.

4. Synchronize Cisco WCS and mobility services engines.

Refer to Chapter 3, “Synchronizing Mobility Services Engines” for details on synchronization.

5. Setup the location sensor using the AeroScout System Manager.
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Note Refer to the AeroScout Context-Aware Engine for Tags, for Cisco Mobility Services Engine 
User’s Guide for configuration details at the following link: http://support.aeroscout.com.

Note Location sensors are referred to as Wi-Fi TDOA location receivers in the AeroScout 
Context-Aware Engine for Tags, for Cisco Mobility Services Engine User’s Guide.

Adding Location Sensors to Cisco WCS and Maps
After the location sensor is installed and configured by the AeroScout System Manager and the partner 
software is downloaded on the mobility services engine, you are ready to add the location sensor to the 
mobility services engine database and position it on a Cisco WCS map.

After adding location sensors to Cisco WCS maps, you continue to make configuration changes to the 
location sensor using the AeroScout System Manager application rather than Cisco WCS. 

Note For more details on configuration options, refer to the AeroScout Context-Aware Engine for Tags, for 
Cisco Mobility Services Engine User’s Guide at the following link: http://support.aeroscout.com. 

To add a location sensor to the Cisco WCS database and appropriate map, follow these steps:

Step 1 In Cisco WCS, click Configure > Location Sensor to display the All Location Sensors window.

Step 2 From the Select a command menu, choose Add Location Sensor and click GO.

Step 3 Enter the MAC Address, Name and Static IP address of the location sensor. 

Step 4 Click OK to save the location sensor entry to the database. The All Locations Sensors summary window 
appears with the new location sensor entry listed.

Note After you add the location sensor to the database, you can place the location sensor on the 
appropriate WCS floor map. To do so, continue with Step 5.

Step 5 To add the location sensor to a map, click Monitor > Maps.

Step 6 At the Maps window, select the link that corresponds to the floor location of the location sensor. The floor 
map appears.

Step 7 Select Add Location Sensors from the Select a command menu. Click GO.

The Add Location Sensors summary window appears.

Note The Add Location Sensors summary window lists all recently-added location sensors that are in 
the database but not yet mapped.

Step 8 Check the check box next to the location sensor(s) to be added to the map. Click OK.

A map appears with a location sensor icon located in the top-left hand corner. You are now ready to place 
the location sensor on the map.

Step 9 Left click on the location sensor icon and drag and place it in the proper location on the floor map. 
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Note The MAC address and name of the location sensor appear in the left panel when you click on the 
location sensor icon for placement.

Step 10 Click Save when the icon is placed correctly on the map.

You are returned to the floor heat map and the added location sensor appears on the map.

Note The icon for the newly added location sensor may or may not appear on the map depending on 
the display settings for that floor. If the icon did not appear, proceed with Step 11.

Step 11 If the location sensor does not appear on the map, click Layers to collapse a selection menu of possible 
elements to display on the map. Click the Location Sensors check box.

Step 12 The location sensor appears on the map (Figure 7-13).

Note You can hover over (mouse over) a location sensor on a map to see configuration details for that 
sensor.

Figure 7-13 Location Sensor Enabled on Layers Menu for Map Display

Step 13 Click X to close the Layers window.

Note Do not select Save Settings in the Layers menu unless you want to save this display criteria for 
all maps.

Step 14 You can now download the partner engine software to the mobility services engine. 
7-20
Cisco 3300 Series Mobility Services Engine Configuration Guide

OL-16583-01



Chapter 7      Context Aware Planning and Verification
Using Location Sensors to Enhance Tag Location Reporting
Refer to the “Downloading Software for Location Sensors” section on page 7-21 for details.

Removing Location Sensors from Cisco WCS and Maps
You can remove one or multiple location sensors at a time. <ADD the maps section; if you remove from 
MP it comes back unassigned but still in database; approach below removes from WCS database.>

To delete a location sensor, follow these steps.

Step 1 In Cisco WCS, click Configure > Location Sensors. The All Location Sensors window appears.

Step 2 Check the box next to each location sensor to be deleted.

Step 3 Select Remove Location Sensors from the Select a command drop-down menu. Click GO.

Step 4 To confirm location sensor deletion, click OK in the pop-up window that appears.

You are returned to the All Location Sensors window. A message confirming deletion of the location 
sensor appears. The deleted location sensor is no longer listed in the window.

Downloading Software for Location Sensors

Note If you have already downloaded the partner engine software onto the mobility services engine and added 
the location sensor to Cisco WCS, you are ready to synchronize the mobility service engine and Cisco 
WCS. Proceed to Chapter 3, “Synchronizing Mobility Services Engines” for more details.

To download software for the location sensor to the mobility services engine, follow these steps:

Step 1 In Cisco WCS, click Mobility > Mobility Service Engines to display the All Servers window.

Step 2 Click the name of the mobility services engine to which you want to download software.

Step 3 From the Partner Engine menu (left panel), select Download Software. The Transfer Partner Software 
Image window appears.

Step 4 To download the partner engine software image onto the mobility services engine, do one of the 
following:

a. To download software listed in the Cisco WCS directory, choose Select from uploaded images to 
transfer into the Server. Then choose the appropriate binary image from the drop-down menu. 

Cisco WCS downloads the binary images listed in the drop-down menu into the FTP server directory you 
specified during Cisco WCS installation.

b. To use software available locally or over the network, select the Browse a new software image to 
transfer into the Server and click Browse. Locate the file and click Open.

Step 5 Enter the time in seconds (between 1 and1800) after which the software download times out.

Step 6 Click Download to send the software to the /opt/installers directory on the mobility services engine.
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Note After the image has been transferred to the mobility service engine, log in to the mobility service 
engine CLI and run the installer image from the /opt/installers directory by entering the 
following command rpm -Uvh aeroscout-engine rpm file to install the software. To run the 
software enter service aeroscout-engine-wd start.

Note To stop the software, enter service aeroscout-engine-wd stop and to check status enter service 
aeroscout-engine-wd status.

Once the partner engine software is installed on the mobility services engine, two additional options, 
Logs and Status, are available on the Partner Engine Menu. Refer to Chapter 9, “Performing 
Maintenance Operations” for details.

Note You are ready to synchronize the mobility service engine and Cisco WCS. Proceed to Chapter 3, 
“Synchronizing Mobility Services Engines” for details.

Using Location Optimized Monitor Mode to Enhance Tag 
Location Reporting

To optimize monitoring and location calculation of tags, you can enable LOMM on up to four channels 
within the 2.4GHz band (802.11b/g radio) of an access point. This allows you to focus channel scans 
only on those channels on which tags are usually programmed to operate (such as channels 1, 6, and 11).

After enabling Monitor Mode at the access point level, you must then enable LOMM and assign 
monitoring channels on the 802.11 b/g radio of the access point.

Note For details on enabling Monitor Mode on an access point, refer to Step 5 in the “Configuring Access 
Points” section in Chapter 9 of the Cisco Wireless Control System Configuration Guide, Release 5.1.

Follow the steps below to set enable LOMM and assign monitoring channels on the access point radio.

Step 1 After enabling Monitor Mode at the access point level, click Configure > Access Points.

Step 2 At the All Access Points Summary window, select the 802.11 b/g Radio link for the appropriate access

Step 3 At the Radio parameters window, disable Admin Status by unchecking the check box. This disables the 
radio.

Step 4 Check the Location Optimized Channel Assignment check box. Drop-down menus for each of the four 
configurable channels display.

Step 5 Select the four channels on which you want the access point to monitor tags.

Note You can configure fewer than four channels for monitoring. To eliminate a monitoring channel, 
select None from the channel drop-down menu.
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Step 6 Click Save. Channel selection is saved.

Step 7 At the Radio parameters window, re-enable the radio by checking the Admin Status check box.

Step 8 Click Save. The access point is now configured as a LOMM access point.

The AP Mode display as Monitor/LOMM on the Monitor > Access Points window.

Defining Inclusion and Exclusion Regions on a Floor
To further refine location calculations on a floor, you can define the areas that are included (inclusion 
areas) in the calculations and those areas that are not included (exclusion areas).

For example, you might want to exclude areas such as an atrium or stairwell within a building but include 
a work area (such as cubicles, labs, or manufacturing floors).

Note In Cisco WCS, inclusion and exclusion regions are only calculated for clients.

Guidelines
Inclusion and exclusion areas can be any polygon shape and must have at least three points.

You can only define one inclusion region on a floor. By default, an inclusion region is defined for each 
floor when it is added to Cisco WCS. The inclusion region is indicated by a solid aqua line, and generally 
outlines the region.

You can define multiple exclusion regions on a floor.

Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility services 
engine recalculates location. 

Defining an Inclusion Region on a Floor
Follow the steps below to define an inclusion area.

Step 1 Click Monitor > Maps. 

Step 2 Click on the name of the appropriate floor area.

Step 3 Select Map Editor from the Select a command drop-down menu.Click GO.

Step 4 At the map, click the aqua box in the tool bar.

Note A message box appears reminding you that only one inclusion area can be defined at a time. 
Defining a new inclusion region automatically removes the previously defined inclusion region. 
By default, an inclusion region is defined for each floor when it is added to Cisco WCS. The 
inclusion region is indicated by a solid aqua line and generally outlines the region (Figure 7-14).
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Figure 7-14 Map Editor Window

Step 5 Click OK in the message box that appears. A drawing icon appears to outline the inclusion area.

Step 6 To begin defining the inclusion area, move the drawing icon to a starting point on the map and click once. 

Step 7 Move the cursor along the boundary of the area you want to include and click to end a border line. Click 
again to define the next boundary line.

Step 8 Repeat Step 7 until the area is outlined and then double click the drawing icon. A solid aqua line defines 
the inclusion area.

Step 9 Select Save from the Command menu or click the disk icon on the tool bar to save the inclusion region.

Note If you made an error in defining the inclusion area, click on the area. The selected area is 
outlined by a dashed aqua line. Next, click on the X icon in the tool bar. The area is removed 
from the floor map.

Step 10 To return to the floor map to enable inclusion regions on heatmaps, select Exit from the Command menu.

Step 11 At the floor map, click the Layers drop-down menu.

Step 12 Check the Location Regions check box if it is not already checked and then click Save settings and close 
the Layers configuration panel when complete.

Step 13 To resynchronize the Cisco WCS and location databases, click Mobility > Synchronize Servers.

Step 14 At the Synchronize window, select Network Designs from the Synchronize drop-down menu and then 
click Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).
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Note Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility 
services engine recalculates location. 

Defining an Exclusion Region on a Floor
To further refine location calculations on a floor, you can define areas that are excluded (exclusion areas) 
in the calculations.

For example, you might want to exclude areas such as an atrium or stairwell within a building.

As a rule, exclusion areas are generally defined within the borders of an inclusion area.

Follow the steps below to define an exclusion area.

Step 1 Click Monitor > Maps. 

Step 2 Click on the name of the appropriate floor area.

Step 3 Select Map Editor from the Select a command drop-down menu.Click GO.

Step 4 At the map, click the purple box in the tool bar.

Step 5 Click OK in the message box that appears. A drawing icon appears to outline the exclusion area.

Step 6 To begin defining the exclusion area, move the drawing icon to the starting point on the map and click 
once. 

Step 7 Move the drawing icon along the boundary of the area you want to exclude and click once to start a 
boundary line and click again to end the boundary line.

Step 8 Repeat Step 7 until the area is outlined and then double click the drawing icon. The defined exclusion 
area is shaded in purple. when the area is completely defined. The excluded area is shaded in purple.

Step 9 To define additional exclusion regions, repeat Step 4 to Step 8 (see Figure 7-15). 
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Figure 7-15 Defining Exclusion Areas on Floor Map

Step 10 When all exclusion areas are defined, select Save from the Command menu or the disk icon on the tool 
bar to save the exclusion region.

Note To delete an exclusion area, click on the area to be deleted. The selected area is outlined by a 
dashed purple line. Next, click on the X icon in the tool bar. The area is removed from the floor 
map.

Step 11 To return to the floor map to enable exclusion regions on heatmaps, select Exit from the Command 
menu.

Step 12 At the floor map, click the Layers drop-down menu.

Step 13 Check the Location Regions check box if it is not already checked and then click Save settings and close 
the Layers configuration panel when complete.

Step 14 To resynchronize the Cisco WCS and location databases, click Mobility > Synchronize Servers.

Step 15 At the Synchronize window, select Network Designs from the Synchronize drop-down menu and then 
click Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).
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Defining a Rail Line on a Floor
You can define a rail line on a floor that represents a conveyor belt. Additionally, you can define an area 
around the rail area known as the snap-width to further assist location calculations. This represents the 
area in which you expect clients to appear. Any client located within the snap-width area is plotted on 
the rail line (majority) or just outside of the snap-width area (minority).

Note Rail line configurations do not apply to tags.

The snap-width area is defined in feet or meters (user-defined) and represents the distance that is 
monitored on either side (east and west or north and south) of the rail.

Follow the steps below to define a rail with a floor.

Step 1 Click Monitor > Maps. 

Step 2 Click on the name of the appropriate floor area.

Step 3 Select Map Editor from the Select a command drop-down menu.Click GO.

Step 4 At the map, click the rail icon (to the right of the purple exclusion icon) in the tool bar (see Figure 7-16).

Figure 7-16 Rail Icon on Map Editor Tool Bar

Step 5 In the message panel that appears, enter a snap-width (feet or meters) for the rail and then click OK. A 
drawing icon appears.

Note The snap-width is defined in feet or meters (as defined by the user) and represents the distance 
that is monitored on either side (left and right) of the rail.

Step 6 Click the drawing icon at the starting point of the rail line. Click again when you want to stop drawing 
the line or change the direction of the line.

Step 7 Click the drawing icon twice when the rail line is completely drawn on the floor map. The rail line 
appears on the map and is bordered on either side by the defined snap-width region (see Figure 7-17).
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Figure 7-17 Rail Line

Note To delete a rail line, click on the area to be deleted. The selected area is outlined by a dashed 
purple line. Next, click on the X icon in the tool bar. The area is removed from the floor map.

Step 8 To return to the floor map to enable rails on heatmaps, select Exit from the Command menu.

Step 9 At the floor map, click the Layers drop-down menu.

Step 10 Check the Rails check box for if it is not already checked and then click Save settings and close the 
Layers configuration panel when complete.

Step 11 To resynchronize the Cisco WCS and mobility services engine, click Mobility > Synchronize Servers.

Step 12 At the Synchronize window, select Network Designs from the Synchronize drop-down menu and then 
click Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

Enabling Location Presence on a Mobility Services Engine
You can enable location presence by mobility services engine to provide expanded Civic (city, state, 
postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default 
setting (campus, building, floor, and X, Y coordinates). This information can then be requested by clients 
on a demand basis for use by location-based services and applications.

Location Presence can be configured when a new Campus, Building, Floor or Outdoor Area is being 
added or configured at a later date.
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Note For details on configuring location presence when adding a new Campus, Building, Floor or Outdoor 
Area, refer to the “Creating Maps” section in Chapter 5 of the Cisco Wireless Control System 
Configuration Guide, release 5.1 and greater.

Follow these steps to enable and configure location presence on a mobility services engine. Once 
enabled, the mobility services engine is capable of providing any requesting Cisco CX v5 client its 
location.

Note Before enabling this feature, synchronize the mobility services engine.

Step 1 Click Mobility > Mobility Service Engines > Server Name. Select the mobility services engine to 
which the campus or building is assigned.

Step 2 From the Location menu (left-panel), select Presence Parameters from the Administration 
sub-heading. The Presence window displays.

Step 3 Check the On Demand check box to enable location presence for Cisco CX clients v5.

Step 4 Select one of the following Location Resolution options.

a. When Building is selected, the mobility services engine can provide any requesting client, its 
location by building. 

– For example, if a client requests its location and the client is located in Building A, the mobility 
services engine returns the client address as Building A.

b. When AP is selected, the mobility services engine can provide any requesting client, its location by 
its associated access point. The MAC address of the access point displays. 

– For example, if a client requests its location and the client is associated with an access point 
with a MAC address of 3034:00hh:0adg, the mobility services engine returns the client address 
of 3034:00hh:0adg.

c. When X,Y is selected, the mobility services engine can provide any requesting client, its location 
by its X and Y coordinates. 

– For example, if a client requests its location and the client is located at (50, 200) the mobility 
services engine returns the client address of 50, 200.

Step 5 Check any or all of the location formats.

a. Check the Cisco check box to provide location by campus, building and floor and X and Y 
coordinates. Default setting.

b. Check the Civic check box to provide the name and address (street, city, state, postal code, country) 
of a campus, building, floor or outdoor area. Expanded location details can also be entered in the 
Advanced panel.

c. Check the GEO check box to provide the longitude and latitude coordinates.

Step 6 By default the Text check box for Location Response Encoding is checked. It indicates the format of the 
information when received by the client. There is no need to change this setting.

Step 7 Check the Retransmission Rule Enable check box to allow the receiving client to retransmit the received 
information to another party.

Step 8 Enter a Retention Expiration value in minutes. This determines how long the received information is 
stored by the client before it is overwritten. Default value is 24 hours (1440 minutes).
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Step 9 Click Save.

Modifying Context Aware Software Parameters
You can modify Context Aware Software properties as to the type and number of clients or tags that are 
tracked and whether or not locations are calculated for those clients or tags.

You can also modify parameters that affect the location calculation of clients and tags such as Receiver 
Signal Strength Indicator (RSSI) measurements.

Note Licenses are required to retrieve contextual information on tags and clients from access points. The 
client’s license also includes tracking of rogue clients and rogue access points. Licenses for tags and 
clients are offered independently. Licenses for tags and clients are offered in a range of quantities, 
ranging from 3,000 to 12,000 units. Refer to the Release Notes for Cisco 3350 Mobility Services Engine 
for Software Release 5.1.30.0 at the following link for details: 
http://www.cisco.com/en/US/products/ps9742/tsd_products_support_series_home.html

Modifying Tracking Parameters
The mobility services engine can track up to18,000 clients and up to18,000 tags (with the proper license 
purchase). Updates on the locations of elements being tracked are provided to the mobility services 
engine from the Cisco wireless LAN controller.

Only those elements designated for tracking by the controller are viewable in Cisco WCS maps, queries 
and reports. No events and alarms are collected for non-tracked elements and none are used in 
calculating the 18,000 element limit for clients or tags.

You can modify the following tracking parameters using Cisco WCS:

• Enable and disable element locations (client stations, active asset tags, and rogue clients and access 
points) you actively track.

• Set limits on how many of a specific element you want to track.

For example, given a client license of 12,000 trackable units, you could set a limit to track only 8,000 
client stations (leaving 4,000 units available to track rogue clients and rogue access points). Once 
the tracking limit is met for a given element, the number of elements not being tracked is 
summarized on the Tracking Parameters page.

• Disable tracking and reporting of ad hoc rogue clients and access points.

To configure tracking parameters for a mobility services engine, follow these steps:

Step 1 In Cisco WCS, click Mobility > Mobility Service Engines. The All Servers window appears.

Step 2 Click the name of the mobility services engine whose properties you want to edit. The General Properties 
window appears.

Step 3 In the Location menu (left panel), select Tracking Parameters from the Administration sub-heading to 
display the configuration options.

Step 4 Modify the tracking parameters as appropriate. Table 7-1 describes each parameter.
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:
Table 7-1 Tracking Parameters

Parameter Configuration Options

Tracking Parameters

Client Stations 1. Check the Enable check box to enable tracking of client stations by the 
mobility services engine.

2. Check the Enable Limiting check box to set a limit on the number of client 
stations to track. 

3. Enter a Limit Value, if limiting is enabled. The limit entered can be any positive 
value up to 18,000 which is the maximum number of clients that can be tracked 
by a mobility services engine.

Note The actual number of tracked clients is determined by the license 
purchased.

Note Active Value (display only): Indicates the number of client stations 
currently being tracked.

Note Not Tracking (display only): Indicates the number of client stations beyond 
the limit.

Asset Tags 1. Check the Enable check box to enable tracking of asset tags by the mobility 
services engine.

2. Check the Enable Limiting check box to set a limit on the number of asset tags 
stations to track. 

3. Enter a Limit Value, if limiting is enabled. The limit entered can be any positive 
value up to 18,000, which is the maximum number of tags that can be tracked 
by a mobility services engine.

Note The actual number of tracked tags is determined by the license purchased.

Note Active Value (display only): Indicates the number of asset tags currently 
being tracked.

Note Not Tracking (display only): Indicates the number of asset tags beyond the 
limit.
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Rogue Clients 
and Access 
Points

1. Check the Enable check box to enable tracking of rogue clients and asset 
points by the mobility services engine.

2. Check the Enable Limiting check box to set a limit on the number of rogue 
clients and asset tags stations to track. 

3. Enter a Limit Value, if limiting is enabled. The limit entered can be any positive 
value up to18,000 which is the maximum number of rogue clients and access 
points that can be tracked by a mobility services engine.

Note The actual number of tracked rogues (clients and access points) is driven by 
the client license purchased. The user must consider the number of clients 
that are being tracked in determining the available quantity to allocate to 
track rogue clients and access points because clients and rogue clients and 
access points are addressed by the same license.

Note Active Value (display only): Indicates the number of rogue clients and 
access points currently being tracked.

Note Not Tracking (display only): Indicates the number of rogue clients and asset 
tags beyond the limit.

Exclude Ad-Hoc 
Rogues

Check the check box to turn off the tracking and reporting of ad hoc rogues in the 
network. As a result, ad hoc rogues are not displayed on Cisco WCS maps or its 
events and alarms reported. 

SNMP Parameters Not applicable to mobility services engines.

SNMP Retry 
Count

Enter the number of times to retry a polling cycle. Default value is 3. Allowed 
values are from 1 to 99999. (Configurable in controller release 4.1 and earlier and 
location server release 3.0 and earlier only).

SNMP Timeout Enter the number of seconds before a polling cycle times out. Default value is 5. 
Allowed values are from 1 to 99999. (Configurable in controller release 4.1 and 
earlier and location server release 3.0 and earlier only).

Client Stations Check the Enable check box to enable client station polling and enter the polling 
interval in seconds. Default value is 300. Allowed values are from 1 to 99999. 
(Configurable in controller release 4.1 and earlier and location server release 3.0 
and earlier only).

Asset Tags Check the Enable check box to enable asset tag polling and enter the polling 
interval in seconds. Default value is 600. Allowed values are from 1 to 99999. 
(Configurable in controller release 4.1 and earlier and location server release 3.0 
and earlier only).

Note Before the location server can collect asset tag data from controllers, you 
must enable the detection of active RFID tags using the CLI command 
config rfid status enable on the controllers.

Table 7-1 Tracking Parameters (continued)

Parameter Configuration Options
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Step 5 Click Save to store the new settings in the mobility services engine database.

Modifying Filtering Parameters
In Cisco WCS, you can limit the number of asset tags, clients, and rogue clients and access points whose 
location is tracked by filtering on:

• MAC addresses

Specific MAC addresses can be entered and labeled as allowed or disallowed from location tracking. 
You can import a file with the MAC addresses that are to be allowed or disallowed, or you can enter 
them individually from the WCS GUI window. 

The format for entering MAC addresses is xx:xx:xx:xx:xx:xx. If a file of MAC addresses is 
imported, the file must follow a specific format as noted below:

– Each MAC address should be listed on a single line.

– Allowed MAC addresses must be listed first and preceded by an “[Allowed]” line item. 
Disallowed MAC addresses must be preceded by “[Disallowed].” 

– Wildcard listings can be used to represent a range of MAC addresses. For example, the first 
entry “00:11:22:33:*” in the Allowed listing below is a wildcard. 

Note Allowed MAC address formats are viewable from the Filtering Parameters configuration 
window. See Table 7-2 for details.

EXAMPLE file listing:

[Allowed]
00:11:22:33:*
22:cd:34:ae:56:45
02:23:23:34:*
[Disallowed]
00:10:*
ae:bc:de:ea:45:23 

Rogue Clients 
and Access 
Points

Check the Enable check box to enable rogue access point polling and enter the 
polling interval in seconds. Default value is 600. Allowed values are from 1 to 
99999.(Configurable in controller release 4.1 and earlier and location server release 
3.0 and earlier only).

Statistics Check the Enable check box to enable statistics polling for the location server, and 
enter the polling interval in seconds. Default value is 900. Allowed values are from 
1 to 99999.(Configurable in controller release 4.1 and earlier and location server 
release 3.0 and earlier only).

Table 7-1 Tracking Parameters (continued)

Parameter Configuration Options
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• Probing clients

Probing clients are clients that are associated to another controller but whose probing activity causes 
them to be seen by another controller and counted as an element by the “probed” controller as well 
as its primary controller.

To configure filtering parameters for a mobility services engine, follow these steps:

Step 1 In Cisco WCS, click Mobility > Mobility Service Engines. The All Servers window appears.

Step 2 Click the name of the mobility services engine whose properties you want to edit. The General Properties 
window appears.

Step 3 From the Location menu (left panel), select Filtering Parameters from the Administration sub-heading 
to display the configuration options.

Step 4 Modify the filtering parameters as appropriate. Table 7-2 describes each parameter.
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Step 5 Click Save to store the new settings in the mobility services engine database.

Table 7-2 Filtering Parameters

Parameter Configuration Options

Exclude Probing Clients Check the check box to prevent location 
calculation of probing clients. 

Enable Location MAC Filtering 1. Check the check box to enable MAC filtering 
of specific elements by their MAC address. 

2. To import a file of MAC addresses (Upload a 
file for Location MAC Filtering field), browse 
for the file name and click Save to load the 
file. The imported list of MAC addresses 
auto-populates the Allowed List and 
Disallowed List based on their designation in 
the file. 

Note To view allowed MAC address formats, 
click on the red question mark next to the 
Upload a file for Location MAC Filtering 
field.

3. To add an individual MAC address, enter the 
MAC addresses (format is 
xx:xx:xx:xx:xx:xx) and click either Allow or 
Disallow. The address appears in the 
appropriate column.

Note To move an address between the Allow 
and Disallow columns, highlight the MAC 
address entry and click the button under 
the appropriate column.

Note To move multiple addresses, click the first 
MAC address and depress the Ctrl to 
highlight additional MAC addresses. 
Click the Allow or Disallow button based 
on its desired destination.

Note If a MAC address is not listed in the Allow 
or Disallow column, by default, it appears 
in the Blocked MACs column. If you click 
the Unblock button, the MAC address 
automatically moves to the Allow column. 
You can move it to the Disallow column 
by selecting the Disallow button under the 
Allow column.
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Editing Advanced Location Parameters
You can use Cisco WCS to modify parameters that affect location calculations such as Receiver Signal 
Strength Indicator (RSSI) measurements for clients. 

You can also apply varying smoothing rates to manage location movement of a client.

Note Tag location is not managed or affected by advanced location parameter settings. Only client location is 
affected.

To configure advanced location parameters, follow these steps:

Step 1 In Cisco WCS, click Mobility> Mobility Service Engine.

Step 2 Click the name of the mobility services engine whose properties you want to edit.

Step 3 From the Location menu (left panel), select Location Parameters from under the Advanced sub-heading. 
The configuration options appear.

Step 4 Modify the location parameters as appropriate. Table 7-3 describes each parameter.

Table 7-3 Advanced Location Parameters

Parameter Configuration Options

Calculation time Check the corresponding check box to enable the calculation of the time required 
to compute location.

Note This parameter applies only to clients.

Caution Enable only under Cisco TAC personnel guidance because enabling this 
parameter slows down overall location calculations.

OW Location Check the corresponding check box to enable Outer Wall (OW) calculation as part 
of location calculation.

Note This parameter is ignored by the mobility services engine.

Relative discard 
RSSI time

Enter the number of minutes since the most recent RSSI sample after which RSSI 
measurement should be considered discarded. For example, if you set this 
parameter to 3 minutes and the mobility services engine receives two samples at 10 
and 12 minutes, it keeps both samples. An additional sample received at 15 minutes 
is discarded. Default value is 3. Allowed values range from 0 to 99999. A value of 
less than 3 is not recommended.

Note This parameter applies only to clients.

Absolute discard 
RSSI time

Enter the number of minutes after which RSSI measurement should be considered 
stale and discarded, regardless of the most recent sample. Default value is 60. 
Allowed values range from 0 to 99999. A value of less than 60 is not recommended.

Note This parameter applies only to clients.
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RSSI Cutoff Enter the RSSI cutoff value, in decibels (dBs) with respect to one (1) mW (dBm), 
above which the mobility services engine will always use the access point 
measurement. Default value is –75.

Note When 3 or more measurements are available above the RSSI cutoff value, 
the mobility services engine will discard any weaker values and use the 3 
(or more) strongest measurements for calculation; however, when only 
weak measurements below the RSSI cutoff value are available, those values 
are used for calculation.

Note This parameter applies only to clients.

Caution Modify only under Cisco TAC personnel guidance. Modifying this value 
can reduce the accuracy of location calculation.

Smooth Location 
Positions

Smoothing compares an element’s prior location to its most recent reported 
location by applying a weighted average calculation to determine its current 
location. The specific weighted average calculation employed is tied to the given 
smoothing option selected. Default value is More Smoothing.

Options:

• Off (No smoothing): Elements assumed to be in location indicated by most 
recent polling.

• Less smoothing: Prior location weighted at 25% and New location weighted at 
75%.

• Average smoothing: Prior location weighted at 50% and New location 
weighted at 50%.

• More smoothing: Prior location weighted at 75% and New location weighted 
at 25%.

• Maximum smoothing: Prior location weighted at 90% and New location 
weighted at 10%.

Note This parameter applies only to clients.

Chokepoint 
Usage

Check the Enable check box to enable tracking of Cisco compatible tags by 
chokepoints.

Note This parameter is ignored by the mobility services engine.

Table 7-3 Advanced Location Parameters (continued)

Parameter Configuration Options
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Step 5 Click Save to store your selections in the Cisco WCS and mobility services engine databases. 

Use Chokepoints 
for Interfloor 
conflicts

Perimeter chokepoints or weighted location readings can be selected to determine 
the location of Cisco compatible tags.

Options:

• Never: When selected, perimeter chokepoints are not used to determine the 
location of Cisco compatible tags. 

• Always: When selected, perimeter points are used to determine the location of 
Cisco compatible tags. 

• Floor Ambiguity: When selected, both weighted location readings and 
perimeter chokepoints are used to generate location for Cisco compatible tags. 
If similar locations are calculated by the two methods, the perimeter 
chokepoint value is used by default.

Note This parameter is ignored by the mobility services engine.

Chokepoint Out 
of Range 
Timeout

When a Cisco compatible tag leaves a chokepoint range, the timeout period entered 
is the period that passes before RSSI values are again used for determining location.

Note This parameter is ignored by the mobility services engine.

Allow Civic 
Address updates 
from Switches

Check the enable check box to receive civic address updates from the controller. 
When enabled, the civic address parameter provides city, state, postal code and 
country specifics for the mobility services engine. This capability is in addition to 
the Cisco default settings of campus, building, floor, and X, Y coordinates. This 
information can then be requested by clients on demand for use by location-based 
services and applications.

Note For more details on civic addresses and other location options, refer to the 
“Enabling Location Presence on a Location Server” section on page 7-24. 

Table 7-3 Advanced Location Parameters (continued)

Parameter Configuration Options
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