THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: https://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1721R)

© 2018 Cisco Systems, Inc. All rights reserved.
Purpose of this Guide

This guide provides information about the following topics:

• Installing and configuring Cisco Jabber Softphone for VDI for Windows
• Installing and configuring Cisco AnyConnect Secure Mobility Client in a Cisco Jabber Softphone for VDI for Windows deployment
• Upgrading Cisco Jabber Softphone for VDI for Windows

About Cisco Jabber Softphone for VDI

Cisco Jabber Softphone for VDI extends the Cisco collaboration experience to virtual deployments. With a supported version of Cisco Jabber for Windows, users can send and receive phone calls on their hosted virtual desktops (HVD). The Cisco Jabber Softphone for VDI software detects the virtual environment and routes all audio and video streams directly from one endpoint to another, without going through the HVD.

The applications in the Cisco Jabber Softphone for VDI family of products are:

• Cisco Jabber Softphone for VDI for HP Thin Pro and Ubuntu
• Cisco Jabber Softphone for VDI for Unicon eLux
• Cisco Jabber Softphone for VDI for Windows
Virtual Deployments

With Cisco Jabber Softphone for VDI, thin client users can place and receive calls with their Cisco Unified Communications application (Cisco Jabber). Cisco Jabber Softphone for VDI consists of the Cisco JVDI Agent and the Cisco JVDI Client. To reduce latency and to enhance media quality, Cisco Jabber Softphone for VDI streams media between the endpoints without going through the hosted virtual desktops.


Use the following flowchart to determine whether you require Cisco Jabber Softphone for VDI for your virtual environment.

Figure 1: Do You Need Cisco Jabber Softphone for VDI?

A Cisco Jabber Softphone for VDI deployment consists of the following components:

- Supported Windows thin clients.
  For more information about supported thin clients, see Release Notes for Cisco Jabber Softphone for VDI for Windows.
- Cisco JVDI Client installed on the thin client.
- Windows hosted virtual desktops (HVD), in a data center.
- Cisco Jabber installed on the HVD.
- Cisco JVDI Agent installed on the HVD.
- Cisco Unified Communications Manager.

Differences in the Virtual Environment

The user experience, with Cisco Jabber Softphone for VDI and a supported Cisco Unified Communications client, is similar to the experience provided by a standard installation. However, in a virtual environment there are some differences:
• The Cisco Unified Communications client detects the virtual environment at run time and starts in virtualization mode.

• Cisco Jabber can control a Cisco IP Phone or use the computer to make and receive calls. The default phone selection is **Use my computer for calls**. After device selection, the Cisco Jabber Softphone for VDI application starts the transfer of the phone configuration data for that user. For more information, see *Configuration Files*, on page 19.

• Use the **Device Selector**, which is located in the Windows notification area, to manage camera and audio devices. Device management is also available from within the Cisco Unified Communications client.

• By default, all calls send and receive video if both parties have video capability. The available options are:
  * **Always start calls with video**: Starts all calls as video calls, which send local video
  * **Never start calls with video**: Starts all calls as audio-only calls

This setting applies to all calls placed and received. The default setting is **Always start calls with video**.

---

**Note**
You can disable video globally or on a per-device basis on the Cisco Unified Communications Manager. Navigate to **System > Enterprise Phone Configuration** and set **Video Calling to Disabled**.

---

• Some menus and options are different in a virtual deployment. For example, Video Desktop Share (Binary Floor Control Protocol) is not available from the call window. Video Desktop Share is supported only from the IM-chat window (Remote Desktop Protocol).

---

**Important**
If Cisco Jabber is also installed on the thin clients, ensure that people exit Jabber before signing in to their HVDs. If Cisco Jabber is running on the local desktop, and one tries to sign in to Jabber on their HVD, Cisco JVDI Client cannot register. Problems with accessories can also occur.
CHAPTER 2

Requirements

- System Requirements, page 5
- Considerations for Thin Clients, page 8
- Port Requirements, page 8
- Supported Codecs, page 9

System Requirements

Important

Each of the components listed in the following table must meet the requirements. Use of unsupported components can result in a nonfunctional deployment.

Only the components, versions, and minimum hardware requirements listed in the table are supported.

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows-based thin client hardware</td>
<td>• Installed RAM 2 GB&lt;br&gt;• Free Physical Memory 128 MB&lt;br&gt;• Free Disk Space 256 MB&lt;br&gt;• CPU Mobile AMD Sempron Processor 3600+, 2-GHz Intel Core 2 CPU, or T7400 2.16 GHz&lt;br&gt;• DirectX 11 compatible GPU&lt;br&gt;• USB 2.0 for USB camera and audio devices</td>
</tr>
</tbody>
</table>

Note

Cisco Jabber Softphone for VDI for Windows does not require the Microsoft .NET Framework or any Java modules.
<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows-based thin client OS</td>
<td>• Microsoft Windows 7 32 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 7 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 8 32 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 8 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 8.1 32 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 8.1 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 10 32 bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows 10 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Windows Thin PC 32 bit</td>
</tr>
<tr>
<td>Windows Embedded Standard-based thin client hardware</td>
<td>• Installed RAM 2 GB</td>
</tr>
<tr>
<td></td>
<td>• Free Physical Memory 128 MB</td>
</tr>
<tr>
<td></td>
<td>• Free Disk Space 256 MB</td>
</tr>
<tr>
<td></td>
<td>• CPU performance affects the maximum video resolution. With Windows Embedded Standard thin clients, the expected resolution depends on the CPU:</td>
</tr>
<tr>
<td></td>
<td>◦ Up to 720p with quad-core AMD GX-420CA SOC 2 GHz or similar</td>
</tr>
<tr>
<td></td>
<td>◦ Up to 240p with dual-core AMD G-T56N 1.65 GHz or similar</td>
</tr>
<tr>
<td></td>
<td>◦ Audio-only support with dual-core VIA Eden X2 U4200 1 GHz or similar CPU</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: These hardware specifications are only guidelines for the expected resolutions. Other factors can affect video resolution.</td>
</tr>
<tr>
<td></td>
<td>• DirectX 11 compatible GPU</td>
</tr>
<tr>
<td></td>
<td>• USB 2.0 for USB camera and audio devices</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: Cisco Jabber Softphone for VDI for Windows does not require the Microsoft .NET Framework or any Java modules.</td>
</tr>
<tr>
<td>Windows Embedded Standard-based thin client OS</td>
<td>• Windows Embedded Standard 7 32 bit</td>
</tr>
<tr>
<td></td>
<td>• Windows Embedded Standard 7 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Windows Embedded Standard 8 64 bit</td>
</tr>
<tr>
<td></td>
<td>• Windows 10 IoT Enterprise</td>
</tr>
</tbody>
</table>
# Requirements

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements</th>
</tr>
</thead>
</table>
| Hosted virtual desktop OS (server-side)             | • Microsoft Windows 7 32 bit  
• Microsoft Windows 7 64 bit  
• Microsoft Windows 8 32 bit  
• Microsoft Windows 8 64 bit  
• Microsoft Windows 8.1 32 bit  
• Microsoft Windows 8.1 64 bit  
• Microsoft Windows 10 32 bit  
• Microsoft Windows 10 64 bit |
| Connection broker for the hosted virtual desktop     | • Citrix XenDesktop 7.5 and later 7.x versions  
• Citrix XenApp 7.5 and later 7.x versions—Published Desktop and Published Application  
• VMware Horizon 6.0 (with View)—Published desktops only  
• VMware Horizon 6 version 6.1.0—Published desktops only  
• VMware Horizon 6 version 6.2.0—Published desktops only  
• VMware Horizon 7 version 7.x—Published desktops only |
| Citrix Receiver or VMware Horizon Client             | • Citrix Receiver (ICA) for Windows 4.4.1000 and later 4.x versions  
• VMware Horizon Client for Windows 4.1.0, 4.2.0, 4.5.0, 4.6.0, and 4.7.0. (Versions 4.3 and 4.4 are not supported.)  
To enable JVDI support with versions 4.5 and later, check **32-bit Core Remote Experience on this 64-bit machine** during the VMware Horizon installation (new install or upgrade).  
**Important** Before you install the Cisco JVDI Client, install the Citrix Receiver or VMware Horizon Client on the thin client.  
If you upgrade your Citrix or VMware product, or change from a Citrix environment to a VMware environment, reinstall the Cisco JVDI Client. |

---

1. Published Desktop and Published Application
2. Installed on the thin client
## Considerations for Thin Clients

Windows thin clients, including older PCs, must meet all system requirements. For more information, see *Release Notes for Cisco Jabber Softphone for VDI—Windows* for your release.

### Port Requirements

1. A connection broker is software that creates connections to hosted virtual desktops. A connection broker performs a number of tasks that include:
   - Validating the username and providing a connection for the user.
   - Allowing the user to connect to a specific virtual desktop.

2. The Citrix Receiver or VMware Horizon Client provides a user interface for the corresponding connection broker.

---

### Considerations for Thin Clients

- **Cisco Unified Communications Manager**
  - Recommended CUCM Release 11.5(1)SU3 or later
  - Minimum CUCM Release 10.5

- **Accessories**

  **Important** Ensure that all Jabra devices are running the latest firmware. You can use the Jabra Direct to update the firmware. For more information visit: [http://www.jabra.com](http://www.jabra.com).

---

1. The Cisco JVDI Client installer does not add firewall rules. You may need to disable the Windows Firewall on the endpoints, or add an exception to allow Cisco JVDI Client.

The following table lists the ports or port ranges used by Cisco Jabber Softphone for VDI.

---

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Unified Communications client on the hosted virtual desktop: Cisco Jabber for Windows or Cisco UC Integration™ for Microsoft Lync.</td>
<td>Cisco Jabber for Windows 12.0 running on the hosted virtual desktop (HVD). Cisco Jabber Softphone for VDI is compatible with all future 12.0(x) Cisco Jabber for Windows versions. For complete information about virtual environment compatibility, see the documentation for Cisco Jabber or Cisco UC Integration™ for Microsoft Lync.</td>
</tr>
<tr>
<td>Cisco Unified Communications Manager</td>
<td>• Recommended CUCM Release 11.5(1)SU3 or later • Minimum CUCM Release 10.5</td>
</tr>
</tbody>
</table>
Table 1: Port Usage

<table>
<thead>
<tr>
<th>Port</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>69 and Ephemeral</td>
<td>UDP Outbound traffic for TFTP</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> An ephemeral port is a short-lived transport protocol port for</td>
</tr>
<tr>
<td></td>
<td>IP communications. IP software can allocate ephemeral ports automatically</td>
</tr>
<tr>
<td></td>
<td>from a predefined range. The following protocols can use an ephemeral</td>
</tr>
<tr>
<td></td>
<td>port assignment for the client end of a communication, to a well-known</td>
</tr>
<tr>
<td></td>
<td>port on a server.</td>
</tr>
<tr>
<td></td>
<td>• Stream Control Transmission Protocol (SCTP)</td>
</tr>
<tr>
<td></td>
<td>• Transmission Control Protocol (TCP)</td>
</tr>
<tr>
<td></td>
<td>• User Datagram Protocol (UDP)</td>
</tr>
<tr>
<td>5060</td>
<td>TCP (default) or UDP Outbound traffic for Session Initiation Protocol (SIP)</td>
</tr>
<tr>
<td>5061</td>
<td>TCP Outbound traffic for Secure SIP call signaling</td>
</tr>
<tr>
<td>6970</td>
<td>TCP Outbound traffic for HTTP</td>
</tr>
<tr>
<td>16384–32767</td>
<td>UDP Inbound and outbound traffic for RTP (audio and video streams)</td>
</tr>
<tr>
<td></td>
<td>You can configure the Cisco Unified Communications Manager to reduce this</td>
</tr>
<tr>
<td></td>
<td>port range. Change the <strong>Start/Stop Media Port</strong> setting in the SIP Profile,</td>
</tr>
<tr>
<td></td>
<td>which is associated with the CSF device.</td>
</tr>
</tbody>
</table>

Supported Codecs

Table 2: Supported Audio and Video Codecs

<table>
<thead>
<tr>
<th>Audio Codec</th>
<th>Video Codec</th>
</tr>
</thead>
<tbody>
<tr>
<td>G.722</td>
<td>H.264/AVC</td>
</tr>
<tr>
<td>G.722.1 (24 and 32k)</td>
<td></td>
</tr>
<tr>
<td>G.722.1 is supported on Cisco Unified Communications Manager 8.6.1 or later.</td>
<td></td>
</tr>
<tr>
<td>G.711 A-law</td>
<td></td>
</tr>
<tr>
<td>G.711 u-law</td>
<td></td>
</tr>
<tr>
<td>Audio Codec</td>
<td>Video Codec</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>G.729a</td>
<td></td>
</tr>
<tr>
<td>Opus</td>
<td></td>
</tr>
</tbody>
</table>
  Opus is supported on Cisco Unified Communications Manager 11.0 or later. |
## Installation and Deployment

- Deployment and Installation Workflow, page 11
- Install the Components Workflow, page 12
- Set up the Hosted Virtual Desktops Workflow, page 13
- Download the Cisco JVDI Client, page 13
- Download the Cisco JVDI Agent, page 13
- Cisco JVDI Client Installation, page 14

### Deployment and Installation Workflow

**Important**
Ensure that all component versions are supported and compatible. The Cisco Jabber for Windows or Cisco UC Integration™ for Microsoft Lync version must match the Cisco Jabber Softphone for VDI for Windows version. For details, see the "System Requirements" section of the release notes document for this release.

### Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Read Requirements, on page 5.</td>
<td>Review the system requirements to confirm that all required hardware and software meet them. Failure to meet all requirements can result in a nonfunctional deployment.</td>
</tr>
</tbody>
</table>
Install the Components Workflow

The Cisco Jabber for Windows or Cisco UC Integration™ for Microsoft Lync version must match the Cisco Jabber Softphone for VDI for Windows version. See the “System Requirements” section of the release notes documentation for your Cisco Jabber Softphone for VDI release.

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Download the Cisco JVDI Client, on page 13.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Download the Cisco JVDI Agent, on page 13.</td>
</tr>
<tr>
<td>Step 3</td>
<td>On the thin client, install the Cisco JVDI Client. See Cisco JVDI Client Installation, on page 14.</td>
</tr>
<tr>
<td>Step 4</td>
<td>On the HVD, uninstall any previously installed versions of Cisco VXME Agent or Cisco JVDI Agent. Also uninstall Cisco Unified Communications clients, such as...</td>
</tr>
</tbody>
</table>
Set up the Hosted Virtual Desktops Workflow

Procedure

Step 1 Log in to the Microsoft Windows HVD as the new user, with administration rights.
Step 2 Join the HVD to the corporate domain.
You must have domain administration rights.
Step 3 Set up Citrix or VMware access to the HVDs.
Important Configure VMware to use PCoIP.
Step 4 Install Cisco JVDI Agent on the HVD.
The Cisco UC Integration™ for Microsoft Lync installer includes Cisco JVDI Agent. If you are installing Cisco UC Integration™ for Microsoft Lync, you can skip this step.
Step 5 Install Cisco Jabber on the HVD.
Step 6 Clone the HVD image.
For best practices for cloning Microsoft Windows HVD images, consult the documentation for your Citrix or VMware product.

Download the Cisco JVDI Client

Download the Cisco JVDI Agent

Install Cisco JVDI Agent on the hosted virtual desktops (HVD), before you install Cisco Jabber for Windows.
If you plan to install Cisco UC Integration™ for Microsoft Lync, do not perform this procedure. Cisco UC Integration™ for Microsoft Lync includes Cisco JVDI Agent.

**Procedure**

**Step 1** Go to the following URL:
http://www.cisco.com/cisco/software/navigator.html

**Step 2** Click Products > Unified Communications > Unified Communications Applications > Messaging > Cisco Jabber Softphone for VDI for Windows.

**Step 3** From the list, choose the file for your release.

**Step 4** Select Download or Add to cart and follow the prompts.

---

### Cisco JVDI Client Installation

Before you install Cisco JVDI Client, complete the following tasks:

- Install and set up the Citrix Receiver or VMware Horizon View Client.
  
  Ensure that you are using a supported version of your Citrix or VMware product. For more information, see *Release Notes for Cisco Jabber Softphone for VDI for Windows* for your release.

**Important**

When you install VMware Horizon View Client 4.5.0, 4.6.0, or 4.7.0, choose **Customize Installation** and configure the following settings:

- Uncheck the **Virtualization Pack for Skype for Business** check box.
- Check the **Install 32-bit Core remote Experience on this 64-bit machine** check box.

- Obtain the Cisco JVDI Client zip file, and extract the contents.

Use one of the following methods to install Cisco JVDI Client:

- **Run the Microsoft Installer**, on page 14
- **Use the Command Line**, on page 15
- **Use the Group Policy Editor**, on page 15

---

### Run the Microsoft Installer

Run the Microsoft Installer (MSI) to install Cisco JVDI Client.

**Before You Begin**

- Install and set up the Citrix Receiver or VMware Horizon View Client.
Ensure that you are using a supported version of your Citrix or VMware product. For more information, see Release Notes for Cisco Jabber Softphone for VDI for Windows for your release.

- Obtain the Cisco JVDI Client zip file, and extract the contents.

**Procedure**

**Step 1** Double-click the CiscoJVDIClientSetup.msi file.

**Step 2** To open the executable file, click **OK**.

**Step 3** If the **Open File - Security Warning** appears, click **Run**.

**Step 4** Read the EULA and, if you agree, click **Accept and Install**.


**Step 5** To complete the installation, click **Finish**.

---

**Use the Command Line**

**Before You Begin**

- Install and set up the Citrix Receiver or VMware Horizon View Client.

Ensure that you are using a supported version of your Citrix or VMware product. For more information, see Release Notes for Cisco Jabber Softphone for VDI for Windows for your release.

- Obtain the Cisco JVDI Client zip file, and extract the contents.

**Procedure**

**Step 1** Open a command window.

**Step 2** Enter the following command: `start /wait msiexec.exe /i <path to MSI>CiscoJVDIClientSetup.msi /quiet`.

The `/quiet` switch specifies a silent installation.

---

**Use the Group Policy Editor**

Use the Group Policy Management console to deploy Cisco JVDI Client to supported thin clients that are running a supported Microsoft Windows operating system.

**Before You Begin**

- Install and set up the Citrix Receiver or VMware Horizon View Client.

Ensure that you are using a supported version of your Citrix or VMware product. For more information, see Release Notes for Cisco Jabber Softphone for VDI for Windows for your release.
• Obtain the Cisco JVDI Client zip file, and extract the contents.
• Use Microsoft Orca to set the language code to 1033.
• Copy the modified Microsoft Installer (MSI) to a software distribution point for deployment. All computers to which you plan to deploy Cisco JVDI Client must be able to access the MSI on the distribution point.

Procedure

Step 1  Select Start > Run.
Step 2  At the prompt, enter the following command: GPMC.msc.
Step 3  Right-click on the appropriate domain in the left section.
Step 4  Select Create a GPO in this Domain, and Link it here.
Step 5  In the New GPO window, Name field, enter a name for the group policy object.
Step 6  Leave the default value or select an option from the Source Starter GPO list, and then select OK. The new group policy appears in the list of group policies for the domain.
Step 7  Select the group policy object under the domain in the left section.
Step 8  From the Security Filtering section of the Scope tab, select Add.
Step 9  Specify the computers and users to which you want to deploy Cisco JVDI Client.
Step 10 Select the MSI file.
Step 11 Right-click the group policy object in the left section and then select Edit. The Group Policy Management Editor opens.
Step 12 Select Computer Configuration and then select Policies > Software Settings.
Step 13 Right-click Software Installation and then select New > Package.
Step 14 Next to File Name, enter the location of the MSI file.

Example:
\\server\software_distribution

Important Enter the Uniform Naming Convention (UNC) path for the location of the MSI file. If you do not enter the UNC path, Group Policy cannot deploy Cisco JVDI Client.
Step 15 Select the MSI file, and then select Open.
Step 16 In the Deploy Software dialog box, select Assigned, and then select OK.

Set the Language Code

Use Microsoft Orca to set the language code if you plan to use Group Policy to deploy Cisco JVDI Client. Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and .NET Framework 4 that you can download from the Microsoft website.

Before You Begin

Ensure that Microsoft Orca is installed.
Procedure

Step 1 Start Microsoft Orca.
Step 2 Select File > Open.
Step 3 Browse to the location of .
Step 4 Select CiscoVXMEClientSetup.msi, and then click Open.
Step 5 Select View > Summary Information.
Step 6 Set the Languages field to 1033.
Step 7 Select OK.
Step 8 Select Tools > Options.
Step 9 Select the Database tab.
Step 10 Select Copy embedded streams during 'Save As'.
Step 11 Select Apply, and then select OK.
Step 12 Select File > Save As.
Step 13 Select a location to which to save the modified CiscoVXMEClientSetup.msi file.
Step 14 Specify a name for the modified file, and then select Save.
Use the Group Policy Editor
Configuration

For each Cisco Unified Client Services Framework (CSF) device that you add to the system, Cisco Unified Communications Manager creates a configuration (CNF.xml) file. The CNF file contains the device specifications for the associated user.

When users sign in to Cisco Jabber, Cisco Jabber Softphone for VDI starts the download of the associated CNF file to the thin client. To ensure the successful transfer of the file, open the relevant ports in all firewall applications to allow the thin client to access the ports. For more information about how to open ports, see the documentation for the firewall software.

---

**Important**

Download of the CNF.xml file follows the system setting for HTTP proxy. Ensure that the proxy does not route the HTTP request from the thin client outside of the corporate network.

---

Set up Users on the Cisco Unified Communications Manager Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create a CSF Device and a Directory Number for Each User, on page 20.</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Associate New Devices with a User, on page 21.</td>
<td></td>
</tr>
</tbody>
</table>
Create a CSF Device and a Directory Number for Each User

Use the same Cisco Unified Client Services Framework (CSF) devices type for the virtual environment as you do for a nonvirtual environment. We recommend that you create only one CSF device for each virtual user. If multiple devices exist for a virtual user, Cisco Virtualization Experience Media Engine automatically selects the first device in the list.

Procedure

Step 1 From Cisco Unified Communications Manager Administration, choose Device > Phone.
Step 2 Select Add New.
Step 3 From the Phone Type drop-down list, choose Cisco Unified Client Services Framework, and then select Next.
Step 4 In the Phone Configuration window, enter the applicable information for the phone as follows:
Step 5 Scroll down to the Product Specific Configuration Layout section, and set Video Calling to Enabled.
Step 6 Select Save.
Step 7 Select Apply Config if this button is available, and then confirm when prompted.
Step 8 Select Add a new DN in the Association Information section that appears on the left side of the window.
Step 9 Enter information for the directory number on the Directory Number Configuration window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory Number</td>
<td>Enter the directory number (line) to assign to the device.</td>
</tr>
<tr>
<td>Route Partition</td>
<td>Enter the route partition. Partitions divide the route plan into logical subsets. These subsets include organization, location, and type of call.</td>
</tr>
<tr>
<td>Display (Internal Caller ID)</td>
<td>Enter the Caller ID. This entry is optional. The actual display depends on this entry and the configuration for the other party. For example, Cisco IP Phones display the Caller ID, but Cisco Jabber does not.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Maximum Number of Calls</strong></td>
<td>Specify the maximum number of calls that can be presented to the application. This number includes all calls placed on hold plus the active call, regardless of which party initiated the calls.</td>
</tr>
<tr>
<td><strong>Busy Trigger</strong></td>
<td>Specify the number of calls (active and on hold). Incoming calls, above this limit receive a busy signal or are redirected to the Forward Busy Internal/External target (if the target is configured).</td>
</tr>
</tbody>
</table>

**Step 10** Select **Save**.

**Step 11** Select **Apply Config** if this button is available, and then confirm when prompted.

**Step 12** Scroll to the bottom of the **Directory Number Configuration** window, and then select **Associate End Users**.

**Step 13** In the **Find and List Users** window, use the search criteria to find the user who you want to associate with the directory number.

**Step 14** Check the box next to that username, and then select **Add Selected**. The user is now associated with the DN.

**Step 15** In the **User Associated with Line** section of the window, select the username.

**Step 16** In the **End User Configuration** window, scroll down to the **Direct Number Associations** section.

**Step 17** From the **Primary Extension** drop-down list, choose the DN for the user.

**Step 18** In the **End User Configuration** window, under **Permissions Information**, select **Add to User Group** or **Add to Access Control Group**, depending on your version of Cisco Unified Communications Manager.

**Step 19** In the **Find and List User Groups** window, use the search criteria to find **Standard CCM End Users**.

**Step 20** Check the box next to **Standard CCM End Users**, and then select **Add Selected**.

**Step 21** In the **Find and List User Groups** window, use the search criteria to find **Standard CTI Enabled**.

**Step 22** Check the box next to **Standard CTI Enabled**, and then select **Add Selected**.

**Step 23** Select **Save**. Cisco Unified Communications Manager reminds you that changes to line or directory number settings require a restart. However, you need only restart after you edit lines on Cisco Unified IP Phones that are running at the time of the modifications.

**Associate New Devices with a User**

*Note* Perform this task in Cisco Unified Communications Manager.

---

Deployment and Installation Guide for Cisco Jabber Softphone for VDI for Windows Release 12.0
**Procedure**

**Step 1** From Cisco Unified Communications Manager Administration, choose > User Management > End User.

**Step 2** Search for the user in the Find and List Users window.

**Step 3** Select the user.

**Step 4** Select Device Association in the Device Information section.

**Step 5** Search for the devices that you require in the User Device Association window.

**Step 6** Select the devices that you require.

For example, you can select a device whose type is Cisco Unified Client Services Framework, and a desk-phone device.

**Step 7** Select Save Selected/Changes.

**Step 8** Select Back to User from the menu in the Related Links navigation box at the top right of the window.

**Step 9** Select Go.

**Step 10** Verify that the devices are listed in the Device Information section in the End User Configuration window.

---

**Enable the CTI Protocol for Users**

Enable the computer-telephony integration (CTI) protocol for each Cisco Jabber Softphone for VDI user.

**Procedure**

**Step 1** In Cisco Unified Communications Manager Administration, click User Management > End Users.

**Step 2** Search for the user in the Find and List Users window.

**Step 3** Select the user.

**Step 4** In the End User Configuration window, scroll down to Permissions Information.

**Step 5** Click Add to User Group.

**Step 6** Select the following groups:

- Standard CCM End Users
- Standard CTI Allow Control of All Devices
- Standard CTI Enabled

**Step 7** Click Save.

---

**What to Do Next**

Enable the Unified Communications Manager IM and Presence Service. See the documentation for your version of Cisco Unified Communications Manager.
Configure Cisco Unified Communications Features for Users

For information about how to configure Cisco Unified Communications features for


Change a User Password

Use this procedure to change the password for a user only if LDAP Authentication is not enabled. If LDAP Authentication is enabled, the passwords are stored on the LDAP Server. For Cisco Unified Communications Manager 9.0 or later, this procedure applies only to passwords for users created locally.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>From Cisco Unified Communications Manager Administration, choose Cisco Unified Communications Manager Administration &gt; User Management &gt; End User.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Search for the user in the Find and List Users window.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Select the user.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the End User Configuration window, in the Password field, enter a new password for the user.</td>
</tr>
<tr>
<td>Step 5</td>
<td>In the Confirm Password field, enter the new password for the user again.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Select Save.</td>
</tr>
</tbody>
</table>
Upgrade

- Upgrade Workflow, page 25
- Upgrade Cisco Jabber for Windows, page 26
- Upgrade the Citrix Receiver or the VMware Client, page 26
- Change the Hosted Virtual Desktop Connection Type, page 27

Upgrade Workflow

Important

To enable the Unified Communications features, upgrade all the following components:

- The platform image on the thin client
- Cisco Jabber Softphone for VDI—Cisco JVDI Client (thin client) and Cisco JVDI Agent (HVD)
- Cisco Unified Communications software on the hosted virtual desktop (HVD)

Ensure that all component versions are supported and compatible. The Cisco Jabber for Windows version must be supported for your Cisco Jabber Softphone for VDI for Windows version.

Procedure


Step 2  See Requirements, on page 5. Review the system requirements to confirm that all required hardware and software meet them. Failure to meet all requirements can result in a nonfunctional deployment.

Step 3  If Cisco Virtualization Experience Media Edition is installed, uninstall it.

Step 4  Install the Cisco Jabber Softphone for VDI components on the thin clients and hosted virtual desktops.
Upgrade Cisco Jabber for Windows

Use this procedure to upgrade to a supported maintenance release of Cisco Jabber for Windows. For supported Cisco Jabber versions, see the “System Requirements” section in the Release Notes for Cisco Jabber Softphone for Windows for your release.

**Procedure**

**Step 1** Close Cisco Jabber and ensure that it is not running on the HVD.  
**Important** If Cisco Jabber is running during the installation, exit and restart Cisco Jabber to enable virtualization.

**Step 2** Install Cisco Jabber.

Upgrade the Citrix Receiver or the VMware Client

Perform this procedure to upgrade the Citrix Receiver or the VMware Horizon Client, with Cisco Jabber Softphone for VDI already installed. This procedure repairs Cisco Jabber Softphone for VDI.

**Procedure**

**Step 1** Upgrade the Citrix Receiver or the VMware Horizon Client.  
See the documentation for your Citrix or VMware product.

**Step 2** Double click the CiscoJVDISetup.msi file.

**Step 3** To open the executable file, select **OK**.

**Step 4** If the Open File - Security Warning appears, select **Run**.

**Step 5** In the **Welcome** window, select **Next**.

**Step 6** In the **Program Maintenance** window, select **Repair** and then **Next**.

**Step 7** To proceed with repairing the installation, select **Install**.

**Step 8** To complete the installation, select **Finish**.

See Install the Components Workflow, on page 12.

If your users do not require VPN access, you can skip the optional steps to install Cisco AnyConnect.
Change the Hosted Virtual Desktop Connection Type

If you change the hosted virtual desktop connection type, you can use this procedure to repair Cisco Jabber Softphone for VDI.

You can change your connection type as follows:

- Citrix Receiver to VMware Horizon Client
- VMware Horizon Client to Citrix Receiver

Procedure

Step 1  Install the software for the new connection type, either Citrix Receiver or VMware Horizon Client.
Step 2  Double click the CiscoJVDISetup.msi file.
Step 3  To open the executable file, select OK.
Step 4  If the Open File–Security Warning appears, select Run.
Step 5  In the Welcome window, select Next.
Step 6  In the Program Maintenance window, select Modify and then Next.
Step 7  In the Custom setup window, select Citrix Client Support or VMware Client Support depending on which you installed and select Next.
Step 8  To proceed with modifying the installation, select Install.

Note  During the modification of Cisco JVDI Client only components that were installed with the previous version are reinstalled.

Step 9  To complete the installation, select Finish.
Upgrade

Change the Hosted Virtual Desktop Connection Type
Troubleshooting

- Registry Keys, page 29
- Verify That Cisco JVDI Client Is Running, page 30
- Verify That Cisco JVDI Agent Is Installed, page 30
- Confirm the Version of Cisco JVDI Client, page 30
- Call Control Is Lost After a Network Failure, page 31
- Call Is Lost After HVD Disconnection, page 31
- Problem Reporting Tool, page 31

Registry Keys

The Cisco JVDI Client installation program checks to ensure that either the Citrix Receiver or the VMware Horizon Client is already installed on the reused PC. In one of the following registry locations, the InstallFolder string-type registry key must be present:

- For Citrix, the installer searches in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Install\ICA Client for the path to the Citrix installation.

  Example (from an x86 PC): [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Install\ICA Client] "InstallFolder"="C:\Program Files\Citrix\ICA Client"

- For VMware Horizon, the installer searches in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware VDM for the path to the VMware installation.

  Example (from an x64 PC): [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VMware, Inc.\VMware VDM] "ClientInstallPath"="C:\Program Files\VMware\VMware View\Client"
Verify That Cisco JVDI Client Is Running

Use Windows Task Manager to verify that Cisco JVDI Client is running.

In a Citrix environment, the Cisco Jabber Softphone for VDI processes start when the user signs in to their hosted virtual desktop (HVD). The processes stop when the session ends.

In a VMware environment, the Cisco Jabber Softphone for VDI processes start after the user signs in to their HVD and in to Cisco Jabber or Cisco UC Integration for Microsoft™ Lync. The processes stop when the session ends.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>On the thin client desktop, right-click the taskbar and then select <strong>Task Manager</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>On the <strong>Processes</strong> tab, scroll down and look for the vxc.exe process.</td>
</tr>
</tbody>
</table>

Verify That Cisco JVDI Agent Is Installed

You can use the Windows Control Panel to verify that Cisco JVDI Agent is installed. You can also verify the version.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From Control Panel, open <strong>Programs and Features</strong> (Windows 7) or <strong>Programs</strong> (Windows 8).</td>
</tr>
<tr>
<td>Step 2</td>
<td>Scroll through the list of installed programs to locate Cisco JVDI Agent. The Cisco JVDI Agent version appears in the <strong>Versions</strong> column.</td>
</tr>
</tbody>
</table>

Confirm the Version of Cisco JVDI Client

Cisco JVDI Client appears in the list of installed programs and features.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Step 2 On the thin client, open <strong>Control Panel &gt; Programs and Features</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Scroll down the list and locate Cisco JVDI Client.</td>
</tr>
<tr>
<td>Step 3</td>
<td>To confirm the version for Cisco JVDI Client, see the <strong>Version</strong> column.</td>
</tr>
</tbody>
</table>
Call Control Is Lost After a Network Failure

Users see a prompt to reconnect to their hosted virtual desktops (HVDs). After the users reconnect, Cisco Jabber or Cisco UC Integration™ for Microsoft Lync call control features do not work.

This problem can occur if the thin client loses network connectivity.

To resolve this issue, have the users exit Cisco Jabber or Cisco UC Integration™ for Microsoft Lync and disconnect from their HVDs. Next they can log back in to their HVDs and sign back in to Cisco Jabber or Cisco UC Integration™ for Microsoft Lync to restore call control.

Call Is Lost After HVD Disconnection

Users receive a prompt to log back in to their hosted virtual desktops (HVD) during an active call, and the call drops. The other party to the call has no indication that the call has ended, except the line is silent.

This issue can occur if the connection between the thin client and the HVD drops, causing a temporary loss of registration and call control.

To work around this issue, users can call the other party back. If the other party is not available, users can send an instant message (IM).

Problem Reporting Tool

The Problem Reporting Tool (PRT) is a small program that automatically runs if Cisco Jabber or Cisco UC Integration™ for Microsoft Lync encounters an unrecoverable error, unhandled exception, or crash. The tool saves a problem report to the user's desktop, as a .zip file. Problem reports include logs from the thin client, the hosted virtual desktop, and any detailed information that users enter. You can use this information to help troubleshoot the issue. You can send the problem report to the Cisco Technical Assistance Center (TAC).

If a user experiences an error that does not crash the software, the user can run the PRT from the Help menu:

Cisco Jabber—Help > Report a problem

Users can generate a problem report from the Windows Start menu if Cisco Jabber or Cisco UC Integration™ for Microsoft Lync is not running. You can access the tool from outside the application, from the Microsoft Windows Start menu.

Cisco Jabber—Start > All Programs > Cisco Jabber > Cisco Jabber Problem Report.
Cisco UC Integration™ for Microsoft Lync—Start > All Programs > Cisco Systems, Inc > Report a problem.

We recommend that users provide a description of the circumstances that lead up to the error.

Users must accept the privacy agreement to run the PRT.
Virtual Channel Problem

If a problem exists with the virtual channel, the problem-reporting tool cannot collect the logs from the thin client. A problem with the virtual channel can cause the Device Selector to not start or to not populate with devices. Cisco Technical Assistance Center (TAC) personnel may instruct you to run the following executable: C:\Program Files (x86)\Cisco Systems\Cisco JVDI\CollectCiscoVXMEClientLogs.exe. This executable gathers the logs from the thin client and saves them to the desktop as a CiscoJVDIClient-logs[timestamp].7z file. You can still use the PRT to gather the logs from the hosted virtual desktop. Submit all logs gathered to TAC.