On-Premises Deployment for Cisco Jabber 12.1

First Published: 2018-05-21
Last Modified: 2018-09-27

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
   800 553-NETS (6387)
Fax: 408 527-0883
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE. IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

All printed copies and duplicate soft copies of this document are considered uncontrolled. See the current online version for the latest version.

Cisco has more than 200 offices worldwide. Addresses and phone numbers are listed on the Cisco website at www.cisco.com/go/offices.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1721R)

© 2019 Cisco Systems, Inc. All rights reserved.
New and Changed Information

<table>
<thead>
<tr>
<th>Description of Change</th>
<th>Status</th>
<th>Where Documented</th>
<th>When Documented</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESET_JABBER installation parameter</td>
<td>Added</td>
<td>Install Cisco Jabber for Windows</td>
<td>September 2018</td>
</tr>
<tr>
<td>Support for Chromebook</td>
<td>Added</td>
<td>Create and Configure Cisco Jabber Devices section</td>
<td>July 2018</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Configure the Phone Security Profile section</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>Updated</td>
<td>Cisco Jabber Diagnostic Tool</td>
<td></td>
</tr>
</tbody>
</table>
CONTENTS

PREFACE

New and Changed Information  iii

PART I

Introduction  13

CHAPTER 1

Cisco Jabber Overview  1
Purpose of this Guide  1
About Cisco Jabber  1

CHAPTER 2

Configuration and Installation Workflows  3
Purpose of Configuration Workflows  3
Prerequisites  3
Activate and Start Essential Services  3
Install Cisco Options Package File for Devices  4
Deployment and Installation Workflows  5
Full UC Deployment  5
Jabber IM Only Deployment  6
Phone Only Mode Deployment  6
Phone Mode with Contacts Deployment  7

PART II

Services  9

CHAPTER 3

Create Default Service Profile  11
Overview of Service Profile  11
Create Default Service Profile  12
CHAPTER 4  
Contact Source  13
Configure Contact Source Workflow  13
Client Configuration for Directory Integration  13
Configure Directory Integration in a Service Profile  14
Add a Directory Service  14
Apply Directory Service to a Service Profile  15
Configure Photos  18
Advanced Directory Integration in the Configuration File  19
Federation  19
Configure Intradomain Federation for CDI  19

CHAPTER 5  
Configure Instant Messaging and Presence Service  21
IM and Presence Service Workflow with Cisco Unified Communications Manager Release 10.5 and Later  21
IM and Presence Service Workflow with Cisco Unified Communications Manager Release 9.x and Later  22
Add an IM and Presence Service  22
Apply an IM and Presence Service  23
Configure IM Address Scheme  23
Enable Message Settings  24
Disable Instant Message Settings  25
Manage Presence Settings  25

CHAPTER 6  
Configure Voicemail  27
Configure Voicemail Workflow  27
Configure Cisco Unity Connection for Use with Cisco Jabber  27
Configure Retrieval and Redirection  29
Add a Voicemail Service  30
Apply a Voicemail Service  30
Set a Voicemail Credentials Source  32

CHAPTER 7  
Configure Webex Conferencing  33
Configure Conferencing for an On-Premises Deployment  33
Configure On-Premises Conferencing using Webex Meetings Server 33
Authenticate Cisco Webex Meetings Server 33
Add Cisco Webex Meetings Server on Cisco Unified Communications Manager 34

CHAPTER 8
Configure CTI Service 37
Configure CTI Service Workflow 37
Add a CTI Service 37
Apply a CTI Service 38

CHAPTER 9
Users 39
LDAP Synchronization Overview 39
Configure Users Workflow 41
Activate Services 41
Enable LDAP Directory Synchronization 42
Configure LDAP Directory Sync 42
Authentication Options 44
Authenticate with the LDAP Server 44
Configure the Client to Authenticate with the LDAP Server 44
Authenticate with Anonymous Binding 45
Manual User Authentication 45
Enable SAML SSO in the Client 45
Certificate-Based SSO Authentication for Mobile Clients 46
Configuring Certificate-Based SSO Authentication on Cisco Unified Communications Manager 47
Configuring Certificate-Based SSO Authentication on Cisco Unity Connection 47
Perform Synchronization 47
Associate Service Profile to User 48
Associate Service Profile to Individual Users 48
Associate Service Profile to Users in Bulk 48
Prepopulate Contact Lists in Bulk 49
Create CSV to Import Contact Lists 49
Upload Contact List Using BAT 50
Configure Authentication for UDS Contact Search 51
Enable Extended UDS Contact Source 51
CHAPTER 10 Configure Softphone 53

Create Softphones Workflow 53
Create and Configure Cisco Jabber Devices 53
Provide Users with Authentication Strings 56
Add a Directory Number to the Device 57
Associate Users with Devices 57
Create Mobile SIP Profiles 58
Setting up System SIP Parameters 59
Configure the Phone Security Profile 59

CHAPTER 11 Configure Deskphone Control 63

Prerequisites 63
Configure Desk Phone Control Workflow 63
Create Desk Phone Devices 64
Enable Device for CTI 65
Configure Desk Phone Video 65
Troubleshooting Desk Phone Video 66
Add Directory Number to the Device for Desktop Applications 67
Enable Video Rate Adaptation 67
Enable RTCP on Common Phone Profiles 68
Enable RTCP on Device Configurations 68

CHAPTER 12 Configure Extend and Connect 71

Configure Extend and Connect Workflow 71
Enable User Mobility 71
Create CTI Remote Devices 72
Add a Remote Destination 73

PART III Configuration 75

CHAPTER 13 Configure Service Discovery 77

Service Discovery Options 77
Configure DNS SRV Records 77
<table>
<thead>
<tr>
<th>CHAPTER 14</th>
<th>Configure Certificate Validation</th>
<th>89</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Certificates for an On-Premises Deployment</td>
<td>89</td>
<td></td>
</tr>
<tr>
<td>Deploy CA Certificates to Clients</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td>Manually Deploy CA Certificates to Cisco Jabber for Windows Clients</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td>Manually Deploy CA Certificates to Cisco Jabber for Mac Clients</td>
<td>91</td>
<td></td>
</tr>
<tr>
<td>Manually Deploy CA Certificates to Mobile Clients</td>
<td>91</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 15</th>
<th>Configure the Clients</th>
<th>93</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Configuration Workflow</td>
<td>93</td>
<td></td>
</tr>
<tr>
<td>Introduction to Client Configuration</td>
<td>93</td>
<td></td>
</tr>
<tr>
<td>Create and Host Client Configuration Files Using an XML Editor</td>
<td>94</td>
<td></td>
</tr>
<tr>
<td>Specify Your TFTP Server Address</td>
<td>95</td>
<td></td>
</tr>
<tr>
<td>Create Global Configurations</td>
<td>96</td>
<td></td>
</tr>
<tr>
<td>Create Group Configurations</td>
<td>96</td>
<td></td>
</tr>
<tr>
<td>Host Configuration Files</td>
<td>97</td>
<td></td>
</tr>
<tr>
<td>Restart Your TFTP Server</td>
<td>98</td>
<td></td>
</tr>
<tr>
<td>Configuration File</td>
<td>98</td>
<td></td>
</tr>
<tr>
<td>Set Parameters on Phone Configuration for Desktop Clients</td>
<td>98</td>
<td></td>
</tr>
<tr>
<td>Parameters in Phone Configuration</td>
<td>99</td>
<td></td>
</tr>
<tr>
<td>Set Parameters on Phone Configuration for Mobile Clients</td>
<td>100</td>
<td></td>
</tr>
<tr>
<td>Parameters in Phone Configuration</td>
<td>100</td>
<td></td>
</tr>
<tr>
<td>Configure Proxy Setting</td>
<td>100</td>
<td></td>
</tr>
</tbody>
</table>
CHAPTER 16

Deploy Cisco Jabber Applications and Jabber Softphone for VDI

Download the Cisco Jabber Clients 103
Install Cisco Jabber for Windows 103
Use the Command Line 104
Example Installation Commands 104
Command Line Arguments 105
LCID for Languages 120
Run the MSI Manually 121
Create a Custom Installer 122
Get the Default Transform File 122
Create Custom Transform Files 123
Transform the Installer 124
Installer Properties 125
Deploy with Group Policy 126
Set a Language Code 126
Deploy the Client with Group Policy 127
Configure Automatic Updates for Windows 128
Uninstall Cisco Jabber for Windows 130
Use the Installer 130
Use the Product Code 130
Install Cisco Jabber for Mac 131
Installer for Cisco Jabber for Mac 131
Run Installer Manually 132
URL Configuration for Cisco Jabber for Mac 132
Configure Automatic Updates for Mac 135
Install Cisco Jabber Mobile Clients 137
URL Configuration for Cisco Jabber for Android, iPhone, and iPad 137
Mobile Configuration Using Enterprise Mobility Management 139
FIPS_MODE Parameter 140
PART IV

Troubleshooting  163

CHAPTER 20

Troubleshooting  165

Cisco Jabber Diagnostic Tool  165

Contact Resolution Tool  166
PART I

Introduction

- Cisco Jabber Overview, on page 1
- Configuration and Installation Workflows, on page 3
Cisco Jabber Overview

• Purpose of this Guide, on page 1
• About Cisco Jabber, on page 1

Purpose of this Guide

The Cisco Jabber Deployment and Installation Guide includes the following task-based information required to deploy and install Cisco Jabber:

• Configuration and installation workflows that outline the processes to configure and install on-premises deployments.

• How to configure the various services that the Cisco Jabber client interacts with, such as IM and Presence Service, Voice and Video Communication, Visual Voicemail, and Conferencing.

• How to configure directory integration, certificate validation, and service discovery.

• How to install the clients.


About Cisco Jabber

Cisco Jabber is a suite of Unified Communications applications that allow seamless interaction with your contacts from anywhere. Cisco Jabber offers IM, presence, audio and video calling, voicemail, and conferencing.

The applications in the Cisco Jabber family of products are:

• Cisco Jabber for Android
• Cisco Jabber for iPhone and iPad
• Cisco Jabber for Mac
• Cisco Jabber for Windows
• Cisco Jabber Softphone for VDI
Configuration and Installation Workflows

- Purpose of Configuration Workflows, on page 3
- Prerequisites, on page 3
- Deployment and Installation Workflows, on page 5

Purpose of Configuration Workflows

Configuration and installation workflows outline the processes to configure and install on-premises deployment. Before you deploy and install Cisco Jabber, see the Cisco Jabber Planning Guide at Install and Upgrade Guides to determine the deployment options that best suit your business needs.

Prerequisites

- Installation servers must be started and active
- Activate and Start Essential Services, on page 3
- Install Cisco Options Package File for Devices, on page 4

Activate and Start Essential Services

Essential services enable communication between servers and provide capabilities to the client.

Procedure

Step 1  Open the Cisco Unified IM and Presence Serviceability interface.
Step 2  Select Tools > Control Center - Feature Services.
Step 3  Select the appropriate server from the Server drop-down list.
Step 4  Ensure the following services are started and activated:

- Cisco SIP Proxy
- Cisco Sync Agent
- Cisco XCP Authentication Service
• Cisco XCP Connection Manager
• Cisco XCP Text Conference Manager
• Cisco Presence Engine

Step 5 Select Tools > Control Center - Network Services.
Step 6 Select the appropriate server from the Server drop-down list.
Step 7 Ensure Cisco XCP Router Service is running.

Install Cisco Options Package File for Devices

To make Cisco Jabber available as a device in Cisco Unified Communications Manager, you must install a device-specific Cisco Options Package (COP) file on all your Cisco Unified Communications Manager nodes. Perform this procedure at a time of low usage; it can interrupt service.

General information about installing COP files is available in the “Software Upgrades” chapter in the Cisco Unified Communications Operating System Administration Guide for your release.

Procedure

Step 1 Download the device COP file.
   a) Locate the device COP file.
      • Go to the software downloads site.
      • Locate the device COP file for your release.
   b) Click Download Now.
   c) Note the MD5 checksum.
      You will need this information later.
   d) Click Proceed with Download and follow the instructions.

Step 2 Place the COP file on an FTP or SFTP server that is accessible from your Cisco Unified Communications Manager nodes.

Step 3 Install this COP file on the Publisher node in your Cisco Unified Communications Manager cluster:
   a) Open the Cisco Unified OS Administration interface.
   b) Select Software Upgrades > Install/Upgrade.
   c) Specify the location of the COP file and provide the required information.
      For more information, see the online help.
   d) Select Next.
   e) Select the device COP file.
   f) Select Next.
   g) Follow the instructions on the screen.
   h) Select Next.
      Wait for the process to complete. This process can take some time.
i) Reboot Cisco Unified Communications Manager at a time of low usage.

j) Let the system fully return to service.

**Note** To avoid interruptions in service, make sure each node returns to active service before you perform this procedure on another server.

**Step 4** Install the COP file on each Subscriber node in the cluster.

Use the same process you used for the Publisher, including rebooting the node.

---

## Deployment and Installation Workflows

- Full UC Deployment, on page 5
- Jabber IM Only Deployment, on page 6
- Phone Only Mode Deployment, on page 6
- Phone Mode with Contacts Deployment, on page 7

## Full UC Deployment

### Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
  • Review requirements to confirm that you meet them.  
  • Review contact sources to determine which contact source you will use. |
| Step 2 | Create Default Service Profile, on page 11                                       |                                                                       |
| Step 3 | Contact Source, on page 13                                                        |                                                                       |
| Step 4 | Configure Instant Messaging and Presence Service, on page 21                      |                                                                       |
| Step 5 | Configure Voicemail, on page 27                                                   |                                                                       |
| Step 6 | Configure Webex Conferencing, on page 33                                           |                                                                       |
| Step 7 | Configure CTI Service, on page 37                                                  |                                                                       |
| Step 8 | Users, on page 39                                                                 |                                                                       |
| Step 9 | Configure Softphone, on page 53                                                   |                                                                       |
| Step 10| Configure Deskphone Control, on page 63                                            |                                                                       |
### Jabber IM Only Deployment

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Create Default Service Profile, on page 11</td>
</tr>
<tr>
<td>Step 3</td>
<td>Contact Source, on page 13</td>
</tr>
<tr>
<td>Step 4</td>
<td>Configure Instant Messaging and Presence Service, on page 21</td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure Webex Conferencing, on page 33</td>
</tr>
<tr>
<td>Step 6</td>
<td>Users, on page 39</td>
</tr>
<tr>
<td>Step 7</td>
<td>Configure Service Discovery, on page 77</td>
</tr>
<tr>
<td>Step 8</td>
<td>Configure Certificate Validation, on page 89</td>
</tr>
<tr>
<td>Step 9</td>
<td>Configure the Clients, on page 93</td>
</tr>
<tr>
<td>Step 10</td>
<td>Deploy Cisco Jabber Applications and Jabber Softphone for VDI, on page 103</td>
</tr>
</tbody>
</table>

### Phone Only Mode Deployment

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
## Purpose

Command or Action | Purpose
--- | ---
unified-communications/jabber-windows/products-installation-guides-list.html | • Review requirements to confirm that you meet them.  
• Review contact sources to determine which contact source you will use.

### Step 2
Create Default Service Profile, on page 11

### Step 3
Configure Voicemail, on page 27

### Step 4
Configure Webex Conferencing, on page 33

### Step 5
Configure CTI Service, on page 37

### Step 6
Users, on page 39

### Step 7
Configure Softphone, on page 53

### Step 8
Configure Service Discovery, on page 77

### Step 9
Configure Certificate Validation, on page 89
Certificates are required for each service to which the Jabber clients connect.

### Step 10
Configure the Clients, on page 93

### Step 11
Deploy Cisco Jabber Applications and Jabber Softphone for VDI, on page 103

---

## Phone Mode with Contacts Deployment

### Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
• Confirm that you meet the requirements.  
• Determine which contact sources you will use. |

| Step 2 | Create Default Service Profile, on page 11  
Create a default service profile to add services. |

| Step 3 | Contact Source, on page 13  
Configure a contact source for your users. |

| Step 4 | Manage Presence Settings, on page 25  
Choose if your users have presence in the client. |

| Step 5 | Disable Instant Message Settings, on page 25  
Remove instant messaging for this phone mode with contacts deployment. |

| Step 6 | Configure Voicemail, on page 27  
Set up voicemail for your users. |

| Step 7 | Configure Webex Conferencing, on page 33  
Set up conferencing with Cisco Webex Meetings Server. |
<table>
<thead>
<tr>
<th><strong>Command or Action</strong></th>
<th><strong>Purpose</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 8</strong></td>
<td>Configure CTI Service, on page 37</td>
</tr>
<tr>
<td><strong>Step 9</strong></td>
<td>Users, on page 39</td>
</tr>
<tr>
<td><strong>Step 10</strong></td>
<td>Configure Softphone, on page 53</td>
</tr>
<tr>
<td><strong>Step 11</strong></td>
<td>Configure Deskphone Control, on page 63</td>
</tr>
<tr>
<td><strong>Step 12</strong></td>
<td>Configure Extend and Connect, on page 71</td>
</tr>
<tr>
<td><strong>Step 13</strong></td>
<td>Configure Service Discovery, on page 77</td>
</tr>
<tr>
<td><strong>Step 14</strong></td>
<td>Configure Certificate Validation, on page 89</td>
</tr>
<tr>
<td><strong>Step 15</strong></td>
<td>Configure the Clients, on page 93</td>
</tr>
<tr>
<td><strong>Step 16</strong></td>
<td>Deploy Cisco Jabber Applications and Jabber Softphone for VDI, on page 103</td>
</tr>
</tbody>
</table>
PART II

Services

• Create Default Service Profile, on page 11
• Contact Source, on page 13
• Configure Instant Messaging and Presence Service, on page 21
• Configure Voicemail, on page 27
• Configure Webex Conferencing, on page 33
• Configure CTI Service, on page 37
• Users, on page 39
• Configure Softphone, on page 53
• Configure Deskphone Control, on page 63
• Configure Extend and Connect, on page 71
Create Default Service Profile

- Overview of Service Profile, on page 11
- Create Default Service Profile, on page 12

Overview of Service Profile

Figure 1: Service Profiles Workflow

1. Create UC services.
2. Associate the UC Service with the Service Profile.

3. Associate the User with the Service Profile.

Create Default Service Profile

Create a service profile to add the UC services.

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

**Step 3** Select Add New.

The Service Profile Configuration window opens.

**Step 4** Enter a name for the service profile in the Name field.

**Step 5** Select Make this the default service profile for the system if you want the service profile to be the default for the cluster.

**Note** On Cisco Unified Communications Manager release 9.x only, users who have IM only capabilities must use the default service profile. For this reason, select Use Default.

**Step 6** Select Save.

**What to do next**

Create the UC services for your deployment.
Contact Source

- Configure Contact Source Workflow, on page 13
- Client Configuration for Directory Integration, on page 13
- Federation, on page 19

Configure Contact Source Workflow

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
| Step 1 | Configure directory integration:  
  • Configure Directory Integration in a Service Profile, on page 14  
  • Advanced Directory Integration in the Configuration File, on page 19 | Configure directory integration through service profiles using Cisco Unified Communications Manager or with the configuration file. |
| Step 2 | Optional: Configure Photos, on page 18                                           | Review the options for configuring photos for users.                                           |
| Step 3 | Optional: Configure Intra-domain Federation for CDI, on page 19                  | Let Cisco Jabber users communicate with users who are provisioned on different systems and who are using client applications other than Cisco Jabber. |

Client Configuration for Directory Integration

You can configure directory integration through service profiles using Cisco Unified Communications Manager release 9 or later or with the configuration file. Use this section to learn how to configure the client for directory integration.

When both a service profile and a configuration file are present, the following table describes which parameter value takes precedence.
Configure Directory Integration in a Service Profile

With Cisco Unified Communications Manager release 9 and later, you can provision users with service profiles and deploy the _cisco-uds SRV record on your internal domain server. The client can then automatically discover Cisco Unified Communications Manager and retrieve the service profile to get directory integration configuration.

### Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Add a Directory Service, on page 14</td>
<td>Create a Directory UC Service.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Apply Directory Service to a Service Profile, on page 15</td>
<td>Add the Directory UC Service to the Service Profile.</td>
</tr>
</tbody>
</table>

Add a Directory Service

### Procedure

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select User Management > User Settings > UC Service. The Find and List UC Services window opens.

**Step 3** Select Add New. The UC Service Configuration window opens.

**Step 4** Select Directory from the UC Service Type menu and then select Next.

**Step 5** Set all appropriate values for the directory service.

To configure Cisco Jabber directory searches on the Global Catalog, add the following values:

- **Port**—3268
- **Protocol**—TCP

**Step 6** Select Save.
What to do next
Apply Directory Service.

Apply Directory Service to a Service Profile

Procedure

Step 1  Select User Management > User Settings > Service Profile. The Find and List Service Profiles window opens.

Step 2  Select Add New. The Service Profile Configuration window opens.

Step 3  Add the directory services to the directory profile. See the Directory Profile Parameters topic for information about the specific settings that are needed for the directory profile.

Step 4  Select Save.

Directory Profile Parameters

The following table lists the configuration parameters you can set in the directory profile:

<table>
<thead>
<tr>
<th>Directory Service Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary server</td>
<td>Specifies the address of the primary directory server. This parameter is required for manual connections where the client cannot automatically discover the directory server.</td>
</tr>
<tr>
<td>Secondary server</td>
<td>Specifies the address of the backup directory server.</td>
</tr>
<tr>
<td>Use UDS for Contact Resolution</td>
<td>Specifies if the client uses UDS as a contact source. <strong>True (Default)</strong> Use UDS as a contact source. When this option is selected the following parameters in this table are not used. <strong>False</strong> Use CDI as a contact source. The following parameters are used to connect to the LDAP server. By default, UDS provides contact resolution when users connect to the corporate network through Expressway for Mobile and Remote Access.</td>
</tr>
<tr>
<td>Directory Service Configuration</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Use Logged On User Credential</strong></td>
<td>Specifies if the client uses the logged on username and password for LDAP contact resolution.</td>
</tr>
<tr>
<td></td>
<td>If you have configured Active Directory (AD) SSO, this will take priority over this setting.</td>
</tr>
<tr>
<td><strong>True (default)</strong></td>
<td>Use logged on user credentials. This is the same as specifying <code>CUCM</code> as the value for the LDAP_UseCredentialsFrom parameter.</td>
</tr>
<tr>
<td><strong>False</strong></td>
<td>Do not use logged on user credentials.</td>
</tr>
<tr>
<td></td>
<td>When you have SSO configured, Jabber uses those credentials before using the ConnectionUsername and ConnectionPassword parameters.</td>
</tr>
<tr>
<td></td>
<td>You must specify the logged on user credentials with the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• ConnectionUsername</td>
</tr>
<tr>
<td></td>
<td>• ConnectionPassword</td>
</tr>
<tr>
<td><strong>Username</strong></td>
<td>Lets you manually specify a shared username that the client can use to authenticate with the directory server.</td>
</tr>
<tr>
<td></td>
<td>By default, Cisco Jabber desktop clients use Kerberos or client certificate authentication.</td>
</tr>
<tr>
<td></td>
<td>You should use this parameter only in deployments where you cannot authenticate with the directory server using either Kerberos or client certificate authentication.</td>
</tr>
<tr>
<td></td>
<td>Use only a well-known or public set of credentials for an account that has read-only permissions.</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>Lets you manually specify a shared password that the client can use to authenticate with the directory server.</td>
</tr>
<tr>
<td></td>
<td>By default, Cisco Jabber desktop clients use Kerberos or client certificate authentication.</td>
</tr>
<tr>
<td></td>
<td>You should use this parameter only in deployments where you cannot authenticate with the directory server using either Kerberos or client certificate authentication.</td>
</tr>
<tr>
<td></td>
<td>Use only a well-known or public set of credentials for an account that has read-only permissions.</td>
</tr>
<tr>
<td>Directory Service Configuration</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Search Base 1</td>
<td>Specifies a location in the directory server from which searches begin. In other words, a search base is the root from which the client executes a search. By default, the client searches from the root of the directory tree. You can specify the value of up to three search bases in your OU to override the default behavior. Active Directory does not typically require a search base. Specify search bases for Active Directory only for specific performance requirements. Specify a search base for directory servers other than Active Directory to create bindings to specific locations in the directory. <strong>Tip</strong> Specify an OU to restrict searches to certain user groups. For example, a subset of your users have instant messaging capabilities only. Include those users in an OU and then specify that as a search base.</td>
</tr>
<tr>
<td>Search Base 2</td>
<td></td>
</tr>
<tr>
<td>Search Base 3</td>
<td></td>
</tr>
<tr>
<td>Search Base 4</td>
<td></td>
</tr>
<tr>
<td>Search Base 5</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Recursive Search on All Search Bases</th>
<th>Select this option to perform a recursive search of the directory starting at the search base. Use recursive searches to allow the Cisco Jabber client contact search queries to search all of the LDAP directory tree from a given search context (search base). This is a common option when searching LDAP. This is a required field. The default value is True.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Base Filter</th>
<th>Specifies a base filter for Active Directory queries. Specify a directory subkey name only to retrieve objects other than user objects when you query the directory. The default value is <code>(&amp;(&amp;(objectCategory=person)(objectClass=user)).</code></th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Predictive Search Filter</th>
<th>Defines filters to apply to predictive search queries. You can define multiple, comma-separated values to filter search queries. The default value is ANR. When Cisco Jabber performs a predictive search, it issues a query using Ambiguous Name Resolution (ANR). This query disambiguates the search string and returns results that match the attributes that are set for ANR on your directory server. <strong>Important</strong> Configure your directory server to set attributes for ANR if you want the client to search for those attributes.</th>
</tr>
</thead>
</table>
Attribute Mappings

It is not possible to change the default attribute mappings in a service profile. If you plan to change any default attribute mappings, you must define the required mappings in a client configuration file.

Configure Photos

Cisco Jabber uses the following methods to configure Photos for users:

- **Active Directory Binary Objects**—No configuration needed, Cisco Jabber retrieves the binary photo from the thumbnailPhoto attribute.

- **PhotoURL attribute**—Use the PhotoSource parameter in the jabber-config.xml file to specify an attribute in your directory. The client will retrieve the attribute and determine if it is a URL or binary data and display the photo from either source.

  CDI parameter: PhotoSource

  Example:

  ```xml
  <Directory>
  <PhotoSource>url</PhotoSource>
  </Directory>
  ```

- **URI Substitution**—For your directory server type, use the following parameters in the jabber-config.xml file:

  CDI parameters:
  - PhotoUriSubstitutionEnabled
  - PhotoUriWithToken
  - PhotoUriSubstitutionToken

  Example:

  ```xml
  <PhotoUriSubstitutionEnabled>True</PhotoUriSubstitutionEnabled>
  <PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
  <PhotoUriWithToken>http://example.com/photo/sAMAccountName.jpg</PhotoUriWithToken>
  ```

  UDS parameters:
  - UdsPhotoUriSubstitutionEnabled
  - UdsPhotoUriWithToken
  - UdsPhotoUriSubstitutionToken

  Example:

  ```xml
  <UDSPhotoUriSubstitutionEnabled>True</UDSPhotoUriSubstitutionEnabled>
  <UDSPhotoUriSubstitutionToken>sAMAccountName</UDSPhotoUriSubstitutionToken>
  <UDSPhotoUriWithToken>http://example.com/photo/sAMAccountName.jpg</UDSPhotoUriWithToken>
  ```
Advanced Directory Integration in the Configuration File

You can configure directory integration in the Cisco Jabber configuration file. For more information see the Directory chapter in the Parameters Reference Guide for Cisco Jabber.

Important

When a Service Profile and a configuration file are present, settings in the Service Profile always take priority.

Federation

Federation lets Cisco Jabber users communicate with users who are provisioned on different systems and who are using client applications other than Cisco Jabber.

Configure Intradomain Federation for CDI

In addition to configuring intradomain federation on the presence server, you might need to specify some configuration settings in the Cisco Jabber configuration files.

To resolve contacts during contact search or retrieve contact information from your directory, Cisco Jabber requires the contact ID for each user. Cisco Unified Communications Manager IM & Presence server uses a specific format for resolving contact information that does not always match the format on other presence servers such as Microsoft Office Communications Server or Microsoft Live Communications Server.

Procedure

Step 1
Set the value of the UseSIPURIToResolveContacts parameter to true:

Step 2
Specify an attribute that contains the Cisco Jabber contact ID that the client uses to retrieve contact information. The default value is msRTCSIP-PrimaryUserAddress, or you can specify another attribute in the SipUri parameter.

Note
When you deploy intradomain federation and the client connects with Expressway for Mobile and Remote Access from outside the firewall, contact search is supported only when the contact ID uses one of the following formats:

- sAMAccountName@domain
- UserPrincipleName (UPN)@domain
- EmailAddress@domain
- employeeNumber@domain
- phoneNumber@domain

Step 3
In the UriPrefix parameter, specify any prefix text that precedes each contact ID in the SipUri parameter.

Example:
For example, you specify `msRTCSIP-PrimaryUserAddress` as the value of `SipUri`. In your directory the value of `msRTCSIP-PrimaryUserAddress` for each user has the following format: `sip:username@domain`.

**Example**

The following XML snippet provides an example of the resulting configuration:

```xml
<Directory>
  <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
  <SipUri>non-default-attribute</SipUri>
  <UriPrefix>sip:</UriPrefix>
</Directory>
```
CHAPTER 5

Configure Instant Messaging and Presence Service

- IM and Presence Service Workflow with Cisco Unified Communications Manager Release 10.5 and Later, on page 21
- IM and Presence Service Workflow with Cisco Unified Communications Manager Release 9.x and Later, on page 22
- Add an IM and Presence Service, on page 22
- Configure IM Address Scheme, on page 23
- Enable Message Settings, on page 24
- Disable Instant Message Settings, on page 25
- Manage Presence Settings, on page 25

IM and Presence Service Workflow with Cisco Unified Communications Manager Release 10.5 and Later

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure IM Address Scheme, on page 23</td>
<td>Configure an IM address for users.</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Enable Message Settings, on page 24</td>
<td>In the Cisco Unified Communications IM and Presence service, set the options to enable instant message and logging.</td>
</tr>
</tbody>
</table>
IM and Presence Service Workflow with Cisco Unified Communications Manager Release 9.x and Later

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
| **Step 1**        | Enable Message Settings, on page 24  
In the Cisco Unified Communications IM and Presence service, set the options to enable instant message and logging. |
| **Step 2**        | Add an IM and Presence Service, on page 22  
Create an IM and Presence UC Service. |
| **Step 3**        | Apply an IM and Presence Service, on page 23  
Add the IM and Presence UC Service to the Service Profile. |

Add an IM and Presence Service

Provide users with IM and Presence Service capabilities.

Procedure

**Step 1**  
Open the Cisco Unified CM Administration interface.

**Step 2**  
Select User Management > User Settings > UC Service.  
The Find and List UC Services window opens.

**Step 3**  
Select Add New.  
The UC Service Configuration window opens.

**Step 4**  
In the Add a UC Service section, select IM and Presence from the UC Service Type drop-down list.

**Step 5**  
Select Next.

**Step 6**  
Provide details for the IM and Presence Service as follows:  
a) Select Unified CM (IM and Presence) from the Product Type drop-down list.  
b) Specify a name for the service in the Name field.  
The name you specify displays when you add the service to a profile. Ensure the name you specify is unique, meaningful, and easy to identify.  
c) Specify an optional description in the Description field.  
d) Specify the instant messaging and presence service address in the Host Name/IP Address field.  

Important  The service address must be a fully qualified domain name or IP address.
Apply an IM and Presence Service

After you add an IM and Presence Service on Cisco Unified Communications Manager, you must apply it to a service profile so that the client can retrieve the settings.

Before you begin
Add an IM and Presence Service, on page 22

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.
The Find and List Service Profiles window opens.
Step 3 Find and select your service profile.
The Service Profile Configuration window opens.
Step 4 In the IM and Presence Profile section, select up to three services from the following drop-down lists:
   • Primary
   • Secondary
   • Tertiary
Step 5 Click Save.

Configure IM Address Scheme

This feature is supported on Cisco Unified Communications Manager IM and Presence Service release 10.x or later. For versions of Cisco Unified Communications Manager IM and Presence Service release 9.x and earlier the default IM address scheme used is UserID@[Default Domain].

Procedure

Step 1 Choose the IM Address Scheme.
a) Open Cisco Unified CM IM and Presence Administration.
b) Select Presence > Settings > Advanced Configuration
   The Advanced Presence Settings window opens.
c) Select IM Address Scheme and from the list choose one of the following:
- UserID@[Default Domain]
  If you use the UserID, ensure that you configure a default domain. For example, services must be named cups.com and not cups.

- Directory URI

**Step 2** Select the required mapping.
  a) Open Cisco Unified CM Administration.
  b) Select System > LDAP > LDAP Directory.
      The Find and List LDAP Directories window opens.
  c) Find and select the directory from the list.
      The LDAP Directory window opens.
  d) In the Standard User Fields To Be Synchronized section choose the mapping:
     - User ID mapped to an LDAP field, the default is sAMAccountName.
     - Directory URI mapped to either mail or msRTCSIP-primaryuseraddress.

---

**Enable Message Settings**

Enable and configure instant messaging capabilities.

**Procedure**

- **Step 1** Open the Cisco Unified CM IM and Presence Administration interface.
- **Step 2** Select Messaging > Settings.
- **Step 3** Select the following options:
  - Enable instant messaging
  - Allow clients to log instant message history
  - Allow cut & paste in instant messages
- **Step 4** Select other messaging settings as appropriate.
- **Step 5** Select Save.

**Important** Cisco Jabber does not support the following settings on the Presence Settings window on Cisco Unified Communications Manager IM and Presence Service release 9.0.x:
  - Use DND status when user is on the phone
  - Use DND status when user is in a meeting
What to do next

- If you have Cisco Unified Communications Manager IM and Presence Service release 9.x and later, Add an IM and Presence Service, on page 22.

Disable Instant Message Settings

In a phone mode with contacts deployment, you can turn off instant messaging for your users as instant messaging doesn't apply to phone mode deployments.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>From Cisco Unified CM IM and Presence Administration go to Messaging &gt; Settings.</th>
</tr>
</thead>
</table>
| Step 2 | Uncheck Enable instant messaging and click Save. |}

What to do next
Restart the Cisco XCP Router service.

Manage Presence Settings

The presence setting for your users is enabled by default. However, in a phone mode with contacts deployment you can disable the presence setting and your users won't see any presence in the client.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>From Cisco Unified CM IM and Presence Administration, go to Presence &gt; Settings &gt; Standard Configuration.</th>
</tr>
</thead>
</table>
| Step 2 | Uncheck Enable availability sharing and click Save. |}

What to do next
Restart the Cisco XCP Router service.
Manage Presence Settings
CHAPTER 6

Configure Voicemail

Configure Voicemail Workflow

- Configure Voicemail Workflow, on page 27
- Configure Cisco Unity Connection for Use with Cisco Jabber, on page 27
- Configure Retrieval and Redirection, on page 29
- Add a Voicemail Service, on page 30
- Set a Voicemail Credentials Source, on page 32

Configure Voicemail Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Configure Cisco Unity Connection for Use with Cisco Jabber, on page 27</td>
<td>Configure Cisco Unity Connection so that Cisco Jabber can access voicemail services.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Configure Retrieval and Redirection, on page 29</td>
<td>Configure retrieval so that users can access voice mail messages. Configure redirection so that users can send incoming calls to voicemail.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Add a Voicemail Service, on page 30</td>
<td>Add a Voicemail UC service. Jabber uses this information to connect to the voicemail server.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Apply a Voicemail Service, on page 30</td>
<td>Apply the Voicemail UC service to the service profile.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Set a Voicemail Credentials Source, on page 32</td>
<td>Set the credentials for connecting to the Voicemail server.</td>
</tr>
</tbody>
</table>

Configure Cisco Unity Connection for Use with Cisco Jabber

You must complete some specific steps to configure Cisco Unity Connection so that Cisco Jabber can access voicemail services. You should refer to the Cisco Unity Connection documentation for instructions on general tasks such as creating users, passwords, and provisioning users with voicemail access.
Cisco Jabber connects to the voicemail service through a REST interface and supports Cisco Unity Connection release 8.5 or later.

**Procedure**

**Step 1** Ensure the **Connection Jetty** and **Connection REST Service** services are started.

a) Open the **Cisco Unity Connection Serviceability** interface.
b) Select **Tools > Service Management**.
c) Locate the following services in the **Optional Services** section:
   - **Connection Jetty**
   - **Connection REST Service**
d) Start the services if required.

**Step 2** Open the **Cisco Unity Connection Administration** interface.

**Step 3** Edit user password settings.

a) Select **Users**.
b) Select the appropriate user.
c) Select **Edit > Password Settings**.
d) Select **Web Application** from the **Choose Password** menu.
e) Uncheck **User Must Change at Next Sign-In**.
f) Select **Save**.

**Step 4** Provide users with access to the web inbox.

a) Select **Class of Service**.

   The **Search Class of Service** window opens.

b) Select the appropriate class of service or add a new class of service.
c) Select **Allow Users to Use the Web Inbox and RSS Feeds**.
d) In the **Features** section, select **Allow Users to Use Unified Client to Access Voice Mail**.
e) Select all other options as appropriate.
f) Select **Save**.

**Step 5** Select API configuration settings.

a) Select **System Settings > Advanced > API Settings**.

   The **API Configuration** window opens.

b) Select the following options:
   - **Allow Access to Secure Message Recordings through CUMI**
   - **Display Message Header Information of Secure Messages through CUMI**
   - **Allow Message Attachments through CUMI**
c) Select **Save**.

---

**What to do next**

If you have Cisco Unified Communications Manager release 9.x and later, [Add a Voicemail Service, on page 30.](#)

---

## Configure Retrieval and Redirection

Configure retrieval so that users can access voicemail messages in the client interface. Configure redirection so that users can send incoming calls to voicemail. You configure retrieval and redirection on Cisco Unified Communications Manager.

**Procedure**

### Step 1

Open the **Cisco Unified CM Administration** interface.

### Step 2

Configure the voicemail pilot.

a) Select **Advanced Features > Voice Mail > Voice Mail Pilot**.

The **Find and List Voice Mail Pilots** window opens.

b) Select **Add New**.

The **Voice Mail Pilot Configuration** window opens.

c) Specify the appropriate details on the **Voice Mail Pilot Configuration** window.

d) Select **Save**.

### Step 3

Add the voicemail pilot to the voicemail profile.

a) Select **Advanced Features > Voice Mail > Voice Mail Profile**.

The **Find and List Voice Mail Profiles** window opens.

b) Specify the appropriate filters in the **Find Voice Mail Profile where Voice Mail Profile Name** field and then select **Find** to retrieve a list of profiles.

c) Select the appropriate profile from the list.

The **Voice Mail Pilot Configuration** window opens.

d) Select the voicemail pilot from the **Voice Mail Pilot** drop-down list.

e) Select **Save**.

### Step 4

Specify the voicemail profile in the directory number configuration.

a) Select **Device > Phone**.

The **Find and List Phones** window opens.

b) Specify the appropriate filters in the **Find Phone where** field and then select **Find** to retrieve a list of devices.

c) Select the appropriate device from the list.
The Phone Configuration window opens.

d) Locate the Association Information section.
e) Select the appropriate device number.

The Directory Number Configuration window opens.

f) Locate the Directory Number Settings section.
g) Select the voicemail profile from the Voice Mail Profile drop-down list.
h) Select Save.

---

Add a Voicemail Service

Add a voicemail service, to allow users to receive voice messages.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open the Cisco Unified CM Administration interface.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select User Management &gt; User Settings &gt; UC Service. The Find and List UC Services window opens.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the Find and List UC Services window, select Add New. The UC Service Configuration window opens.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Add a UC Service section, select Voicemail from the UC Service Type drop-down list and select Next.</td>
</tr>
</tbody>
</table>
| Step 5 | Specify details for the voicemail service as follows:  
  - **Product Type** — Select Unity Connection.  
  - **Name** — Enter a descriptive name for the server, for example, PrimaryVoicemailServer.  
  - **Hostname/IP Address** — Enter the IP address or the fully qualified domain name (FQDN) of the voicemail server.  
  - **Port** — You do not need to specify a port number. By default, the client always uses port 443 to connect to the voicemail server. For this reason, any value you specify does not take effect.  
  - **Protocol Type** — You do not need to specify a value. By default, the client always uses HTTPS to connect to the voicemail server. For this reason, any value you specify does not take effect. |
| Step 6 | Select Save. |

---

Apply a Voicemail Service

After you add a voicemail service on Cisco Unified Communications Manager, apply it to a service profile so that the client can retrieve the settings.
Cisco Jabber does not read Voicemail UC Service Profile when it is deployed only in the Phone mode.

For Cisco Jabber to retrieve the voicemail server information, update the `jabber-config.xml` file with the voicemail parameters.

```xml
<Voicemail>
  <VoicemailService_UseCredentialsFrom>phone</VoicemailService_UseCredentialsFrom>
  <VoicemailPrimaryServer>X.X.X.X</VoicemailPrimaryServer>
</Voicemail>
```

After updating, upload the `jabber-config.xml` file to all the Cisco Unified Communications Manager TFTP servers and restart the TFTP service on TFTP server nodes. Then reset the Jabber client.

**Procedure**

**Step 1** Open the {Cisco Unified CM Administration} interface.

**Step 2** Select {User Management} > {User Settings} > {Service Profile}.

The Find and List Service Profiles window opens.

**Step 3** Find and select your service profile.

The Service Profile Configuration window opens.

**Step 4** Configure the Voicemail Profile section as follows:

a) Select up to three services from the following drop-down lists:

- Primary
- Secondary
- Tertiary

b) For Credentials source for voicemail service, select one of the following:

- Unified CM - IM and Presence — Uses the instant messaging and presence credentials to sign in to the voicemail service. As a result, users do not need to enter their credentials for voicemail services in the client.

- Web conferencing — This option is not supported, it uses the conferencing credentials to sign in to the voicemail service. You cannot currently synchronize with conferencing credentials.

- Not set — This option is selected for Phone mode deployments.

**Step 5** Click Save.
Set a Voicemail Credentials Source

You can specify a voicemail credentials source for users.

Tip
In hybrid cloud-based deployments, you can set a voicemail credentials source as part of your configuration file with the VoiceMailService_UseCredentialsFrom parameter.

Before you begin
Configure Retrieval and Redirection, on page 29

Procedure

Step 1
Open the Cisco Unified CM Administration interface.

Step 2
Select User Management > User Settings > Service Profile.

Step 3
Select the appropriate service profile to open the Service Profile Configuration window.

Step 4
In the Voicemail Profile section, select Unified CM - IM and Presence from the Credentials source for voicemail service drop-down list.

Note
Do not select Web Conferencing from the Credentials source for voicemail service drop-down list. You cannot currently use conferencing credentials as a credentials source for voicemail services.

The user's instant messaging and presence credentials match the user's voicemail credentials. As a result, users do not need to specify their voicemail credentials in the client user interface.

What to do next

Important
There is no mechanism to synchronize credentials between servers. If you specify a credentials source, you must ensure that those credentials match the user's voicemail credentials.

For example, you specify that a user's instant messaging and presence credentials match the user's Cisco Unity Connection credentials. The user's instant messaging and presence credentials then change. You must update the user's Cisco Unity Connection credentials to reflect that change.

Cloud-Based deployments can use the configuration file parameter VoicemailService_UseCredentialsFrom. Set this parameter to the value phone to use the Cisco Unified Communications Manager credentials to sign in to Cisco Unity Connection.
Configure Webex Conferencing

- Configure Conferencing for an On-Premises Deployment, on page 33

Configure Conferencing for an On-Premises Deployment

When you implement an on-premises deployment for Cisco Jabber, you can configure conferencing on-premises with Cisco Webex Meetings Server, or in the cloud in Cisco Webex Meetings Center.

Configure On-Premises Conferencing using Webex Meetings Server

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Authenticate Cisco Webex Meetings Server, on page 33.</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Add Cisco Webex Meetings Server on Cisco Unified Communications Manager, on page 34.</td>
<td></td>
</tr>
</tbody>
</table>

Authenticate Cisco Webex Meetings Server

To authenticate with Cisco Webex Meetings Server, complete one of the following options:

- Configure single sign-on (SSO) with Cisco Webex Meetings Server to integrate with the SSO environment. In this case, you do not need to specify credentials for users to authenticate with Cisco Webex Meetings Server
- Set a credentials source on Cisco Unified Communications Manager. If the users' credentials for Cisco Webex Meetings Server match their credentials for Cisco Unified Communications Manager IM and Presence Service or Cisco Unity Connection, you can set a credentials source. The client then automatically authenticates to Cisco Webex Meetings Server with the users' credential source.
Add Cisco Webex Meetings Server on Cisco Unified Communications Manager

To configure conferencing on Cisco Unified Communications Manager, you must add a Cisco Webex Meetings Server.

Before you begin
Authenticate with Cisco Webex Meetings Server

Procedure

Step 1  Open the Cisco Unified CM Administration interface and select User Management > User Settings > UC Service. The Find and List UC Services window opens.

Step 2  Select Add New.

Step 3  In the Add a UC Service section, from the UC Service Type drop-down list, select Conferencing and then select Next.

Step 4  Complete the following fields:
- **Product Type** — Select Webex (Conferencing).
- **Name** — Enter a name for the configuration. The name you specify is displayed when you add services to profiles. Ensure the name you specify is unique, meaningful, and easy to identify.
- **Hostname/IP Address** — Enter the site URL for Cisco Webex MeetingsServer. This URL is case sensitive and must match the case that was configured for the site URL in Cisco Webex Meetings Server.
- **Port** — Leave the default value.
- **Protocol** — Select HTTPS.

Step 5  To use Cisco Webex as the single sign-on (SSO) identity provider, check User web conference server as SSO identity provider.

Note  This field is available only if you select Webex (Conferencing) from the Product Type drop-down list.

Step 6  Select Save.

What to do next
Add the Cisco Webex Meetings Server to a Service Profile, on page 35
Add the Cisco Webex Meetings Server to a Service Profile

After you add Cisco Webex Meetings Server and add it to a service profile, the client can access conferencing features.

Before you begin

Create a service profile.

Add Cisco Webex Meetings Server on Cisco Unified Communications Manager, on page 34

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Open the Cisco Unified CM Administration interface and select User Management &gt; User Settings &gt; Service Profile</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Find and select your service profile.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the Conferencing Profile section, from the Primary, Secondary, and Tertiary drop-down lists, select up to three instances of Cisco Webex Meetings Server.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>From the Server Certificate Verification drop-down list, select the appropriate value.</td>
</tr>
</tbody>
</table>
| **Step 5** | From the Credentials source for web conference service drop-down list, select one of the following:  
  - **Not set**—Select this option if the user does not have a credentials source that matches their Cisco Webex Meetings Server credentials or if you use SSO at the meeting site.  
  - **Unified CM - IM and Presence**—Select this option if the Cisco Unified Communications Manager IM and Presence Service credentials for the user match their Cisco Webex Meetings Server credentials.  
  - **Voicemail**—Select this option if the Cisco Unity Connection credentials for the user match their Cisco Webex Meetings Server credentials. |
| **Note** | You cannot synchronize the credentials you specify in Cisco Unified Communications Manager with credentials you specify in Cisco Webex Meetings Server. For example, if you specify that instant messaging and presence credentials for a user are synchronized with their Cisco Webex Meetings Server credentials, the instant messaging and presence credentials for that user change. You must update the Cisco Webex Meetings Server credentials for that user to match that change. |
| **Step 6** | Select Save. |
Add the Cisco Webex Meetings Server to a Service Profile
CHAPTER 8

Configure CTI Service

- Configure CTI Service Workflow, on page 37
- Add a CTI Service, on page 37

Configure CTI Service Workflow

The CTI Service provides Jabber with the location of the UDS device service. The UDS device service provides Jabber with the devices that are associated with the user, for example: a softphone or deskphone devices.

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Add a CTI Service, on page 37</td>
<td>Create a CTI UC service to provide Jabber with the location of the CTI service.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Apply a CTI Service, on page 38</td>
<td>Apply the CTI UC service to the service profile.</td>
</tr>
</tbody>
</table>

Add a CTI Service

The CTI service provides Jabber with the address of the UDS device service. The UDS device service provides a list of devices associated with the user.

Procedure

**Step 1** Open the Cisco Unified CM Administration interface.
**Step 2** Select User Management > User Settings > UC Service.
The Find and List UC Services window opens.
**Step 3** Select Add New.
The UC Service Configuration window opens.
**Step 4** In the Add a UC Service section, select CTI from the UC Service Type drop-down list.
Step 5 Select Next.

Step 6 Provide details for the instant messaging and presence service as follows:
   a) Specify a name for the service in the **Name** field.
      The name you specify displays when you add services to profiles. Ensure the name you specify is unique, meaningful, and easy to identify.
   b) Specify the CTI service address in the **HostName/IP Address** field.
   c) Specify the port number for the CTI service in the **Port** field.

Step 7 Select **Save**.

**What to do next**
Add the CTI service to your service profile.

**Apply a CTI Service**

After you add a CTI service on Cisco Unified Communications Manager, you must apply it to a service profile so that the client can retrieve the settings.

**Before you begin**

- Create a service profile if none already exists or if you require a separate service profile for CTI.
- Add a CTI service.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Open the <strong>Cisco Unified CM Administration</strong> interface.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select <strong>User Management &gt; User Settings &gt; Service Profile</strong>. <strong>Find and List Service Profiles</strong> window opens.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Find and select your service profile. <strong>Service Profile Configuration</strong> window opens.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Navigate to <strong>CTI Profile</strong> section, and select up to three services from the following drop-down lists:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Primary</strong></td>
</tr>
<tr>
<td></td>
<td>- <strong>Secondary</strong></td>
</tr>
<tr>
<td></td>
<td>- <strong>Tertiary</strong></td>
</tr>
<tr>
<td>Step 5</td>
<td>Select <strong>Save</strong>.</td>
</tr>
</tbody>
</table>
CHAPTER 9

Users

- LDAP Synchronization Overview, on page 39
- Configure Users Workflow, on page 41
- Activate Services, on page 41
- Enable LDAP Directory Synchronization, on page 42
- Configure LDAP Directory Sync, on page 42
- Authentication Options, on page 44
- Perform Synchronization, on page 47
- Associate Service Profile to User, on page 48
- Prepopulate Contact Lists in Bulk, on page 49
- Configure Authentication for UDS Contact Search, on page 51
- Enable Extended UDS Contact Source, on page 51

LDAP Synchronization Overview

Lightweight Directory Access Protocol (LDAP) synchronization helps you to provision and configure end users for your system. During LDAP synchronization, the system imports a list of users and associated user data from an external LDAP directory into the Cisco Unified Communications Manager database. In addition, you can configure a regular synchronization schedule to pick up any changes in your employee data.

User ID and Directory URI

When you synchronize your LDAP directory server with Cisco Unified Communications Manager, you can populate the end user configuration tables in both the Cisco Unified Communications Manager and the Cisco Unified Communications Manager IM and Presence Service databases with attributes that contain values for the following:

- User ID—You must specify a value for the user ID on Cisco Unified Communications Manager. This value is required for the default IM address scheme and for users to sign in. The default value is `sAMAccountName`. 
If the attribute for the user ID is other than `sAMAccountName` and you are using the default IM address scheme in Cisco Unified Communications Manager IM and Presence Service, you must specify the attribute as the value for the parameter in your client configuration file as follows:

The CDI parameter is `UserAccountName`.

```
<UserAccountName>attribute-name</UserAccountName>
```

If you do not specify the attribute in your configuration, and the attribute is other than `sAMAccountName`, the client cannot resolve contacts in your directory. As a result, users do not get presence and cannot send or receive instant messages.

**Important**

- **Directory URI**—You should specify a value for the directory URI if you plan to:
  - Enable URI dialing in Cisco Jabber.
  - Use the directory URI address scheme on Cisco Unified Communications Manager IM and Presence Service version 10 and higher.

When Cisco Unified Communications Manager synchronizes with the directory source, it retrieves the values for the directory URI and user ID and populates them in the end user configuration table in the Cisco Unified Communications Manager database.

The Cisco Unified Communications Manager database then synchronizes with the Cisco Unified Communications Manager IM and Presence Service database. As a result, the values for the directory URI and user ID are populated in the end user configuration table in the Cisco Unified Communications Manager IM and Presence Service database.
Configure Users Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Activate Services, on page 41</td>
<td>Turn on the required services to synchronize user settings from your LDAP directory with Cisco Unified Communications Manager and with the IM and Presence Service.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Enable LDAP Directory Synchronization, on page 42</td>
<td>Allow Cisco Unified Communications Manager to synchronize user settings from your LDAP directory. Select the attribute from your LDAP directory that you want Cisco Unified Communications Manager to synchronize with for the User ID.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Configure LDAP Directory Sync, on page 42</td>
<td>Configure Cisco Unified Communications Manager to synchronize with your LDAP directory. Set up an automatic synchronization schedule, map the standard user fields, and assign the imported users to access control groups.</td>
</tr>
</tbody>
</table>
| Step 4 | Authentication Options, on page 44                         | Select your authentication option:  
  • Enable SAML SSO in the client.  
  • Authenticate with the LDAP server. |
| Step 5 | Perform Synchronization, on page 47                        | Synchronize Cisco Unified Communications Manager with the directory server.                    |
| Step 6 | Associate Service Profile to User, on page 48               | Associate the service profile to the users.                                                   |
| Step 7 | Prepopulate Contact Lists in Bulk, on page 49               | Populate the contact list for your users.                                                    |

**Activate Services**

You must activate the following services before you can integrate with your corporate LDAP server:

- Cisco DirSync service—you must activate this service if you want to synchronize end user settings from a corporate LDAP directory.

- (Cisco Unified Communications Manager IM and Presence Service) Cisco Sync Agent service—this service keeps data synchronized between the IM and Presence Service node and Cisco Unified Communications Manager. When you perform the synchronization with your directory server, Cisco Unified Communications Manager then synchronizes the data with IM and Presence Service.
## Enable LDAP Directory Synchronization

Perform this procedure if you want to configure Cisco Unified Communications Manager to synchronize end user settings from a corporate LDAP directory.

### Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In Cisco Unified CM Administration, choose <strong>System &gt; LDAP &gt; LDAP System</strong>. The <strong>LDAP System Configuration</strong> window opens.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Check the <strong>Enable Synchronizing from LDAP Server</strong> check box to allow Cisco Unified Communications Manager to import users from your LDAP directory.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the <strong>LDAP Server Type</strong> drop-down list box, choose the type of LDAP directory server that your company uses.</td>
</tr>
<tr>
<td>Step 4</td>
<td>From the <strong>LDAP Attribute for User ID</strong> drop-down list box, choose the attribute from your corporate LDAP directory that you want Cisco Unified Communications Manager to synchronize with for the <strong>User ID</strong> field in the <strong>End User Configuration</strong> window. This value is required for the default IM address scheme and for users to sign in. The default value is <code>sAMAccountName</code>. If you do not specify the attribute in your configuration, and the attribute is other than <code>sAMAccountName</code>, the client cannot resolve contacts in your directory. As a result, users do not get presence and cannot send or receive instant messages.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

## Configure LDAP Directory Sync

Use this procedure to configure Cisco Unified Communications Manager to synchronize with an LDAP directory. LDAP directory synchronization allows you to import end user data from an external LDAP directory.
into the Cisco Unified Communications Manager database such that it displays in End User Configuration window. You can set up a sync schedule so that updates made to the LDAP directory propagate to Cisco Unified Communications Manager regularly.

For help with the fields and their descriptions, refer to the online help.

**Procedure**

**Step 1** In Cisco Unified CM Administration, choose System > LDAP > LDAP Directory.

**Step 2** Perform one of the following steps:
- Click Find and select an existing LDAP directory.
- Click Add New to create a new LDAP directory.

**Step 3** In the LDAP Configuration Name text box, assign a unique name to the LDAP directory.

**Step 4** In the LDAP Manager Distinguished Name field, enter a user ID with access to the LDAP directory server.

**Step 5** Enter and confirm the password details.

**Step 6** In the LDAP Directory Synchronization Schedule fields, create a schedule that Cisco Unified Communications Manager uses to synchronize data with the external LDAP directory.

**Step 7** Complete the Standard User Fields to be Synchronized section. For each End User field, choose an LDAP attribute. The synchronization process assigns the value of the LDAP attribute to the end user field in Cisco Unified Communications Manager.

a) Select one of the following LDAP attributes from the Directory URI drop-down list:
   - **msRTCSIP-primaryuseraddress**—This attribute is populated in the AD when Microsoft Lync or Microsoft OCS are used. This is the default attribute.
   - **mail**

**Step 8** To assign the imported end users to an access control group that is common to all the imported end users, do the following:

a) Click Add to Access Control Group.

b) In the popup window, click the corresponding check box for each access control group that you want to assign to the imported end users.

c) Click Add Selected.

At a minimum you should assign the user to the following access control groups:

- **Standard CCM End Users**

- **Standard CTI Enabled**—This option is used for desk phone control.

If you provision users with secure phone capabilities, do not assign the users to the **Standard CTI Secure Connection** group.

Certain phone models require additional control groups, as follows:

- Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select **Standard CTI Allow Control of Phones supporting Connected Xfer and conf**.

- Cisco Unified IP Phone 6900 series, select **Standard CTI Allow Control of Phones supporting Rollover Mode**.
For Cisco Unified Communications Manager 9.x, you must assign end users to access control groups on the End User Configuration window (User Management > End User).

**Note**

For Cisco Unified Communications Manager 9.x, you must assign end users to access control groups on the End User Configuration window (User Management > End User).

**Step 9**

In the LDAP Server Information area, enter the hostname or IP address of the LDAP server.

**Step 10**

If you want to create a secure connection to the LDAP server, check the Use TLS check box.

**Step 11**

Click Save.

---

### Authentication Options

#### Authenticate with the LDAP Server

Perform this procedure if you want to enable LDAP authentication so that end user passwords are authenticated against the password that is assigned in the company LDAP directory. LDAP authentication gives system administrators the ability to assign an end user a single password for all company applications. This configuration applies to end user passwords only and does not apply to end user PINs or application user passwords. When users sign in to the client, the presence service routes that authentication to Cisco Unified Communications Manager. Cisco Unified Communications Manager then sends that authentication to the directory server.

**Procedure**

**Step 1**

Open the Cisco Unified CM Administration interface.

**Step 2**

Select System > LDAP > LDAP Authentication.

**Step 3**

Select Use LDAP Authentication for End Users.

**Step 4**

Specify LDAP credentials and a user search base as appropriate.

See the Cisco Unified Communications Manager Administration Guide for information about the fields on the LDAP Authentication window.

**Step 5**

Select Save.

---

#### Configure the Client to Authenticate with the LDAP Server

If you are configuring authentication to use LDAP credentials, you must also configure the client.

**Procedure**

**Step 1**

Update the jabber-config.xml file with the LDAP_UseCredentialsFrom parameter.

**Example:**

```xml
<LDAP_UseCredentialsFrom>CUCM</LDAP_UseCredentialsFrom>
```
Step 2  If the LDAP server is deployed in a different domain than the domain where Cisco Unified Communications Manager IM and Presence and Cisco Unified Communications Manager are deployed, configure the LDAPUserDomain parameter. If you don't configure this parameter, by default it uses the value for the PresenceDomain mandatory parameter.

Example:

```xml
<LdapUserDomain>example.com</LdapUserDomain>
```

Step 3  If the LDAP server is deployed in a different domain than the domain where Cisco Unified Communications Manager IM and Presence service and Cisco Unified Communications Manager are deployed, configure the LDAPUserDomain parameter. If you don't configure this parameter, by default it uses the value for the PresenceDomain mandatory parameter.

Example:

```xml
<LdapUserDomain>example.com</LdapUserDomain>
```

Authenticate with Anonymous Binding

You can configure anonymous binding as a means of authenticating users to the LDAP server. Using anonymous binding prevents users from entering credentials on the Accounts tab of the Options menu in Jabber.

Procedure

In the jabber-config.xml file, configure the LdapAnonymousBinding parameter with true or false values.

Example:

```xml
<LdapAnonymousBinding>true</LdapAnonymousBinding>
```

For more information on configuring this parameter, see the Parameters Reference Guide for Cisco Jabber.

Manual User Authentication

You can set up service authentication where users manually enter their own credentials in the Jabber client for the required services.

Users are manually prompted to enter their own credentials when no service authentication is configured (for example, in service profiles or on the LDAP server).

Users enter their credentials on the Accounts tab of the Options menu in Jabber.

Enable SAML SSO in the Client

Before you begin

- If you do not use Cisco Webex Messenger, enable SSO on Cisco Unified Communications Applications 10.5.1 Service Update 1—For information about enabling SAML SSO on this service, read the SAML SSO Deployment Guide for Cisco Unified Communications Applications, Release 10.5.
• Enable SSO on Cisco Unity Connection version 10.5—For more information about enabling SAML SSO on this service, read Managing SAML SSO in Cisco Unity Connection.

• If you use Cisco Webex Messenger, enable SSO on Cisco Webex Messenger Services to support Cisco Unified Communications Applications and Cisco Unity Connection—For more information about enabling SAML SSO on this service, read about Single Sign-On in the Cisco Webex Messenger Administrator’s Guide.

For more information about enabling SAML SSO on this service, read about Single Sign-On in the Cisco Webex Messenger Administrator’s Guide.

Procedure

**Step 1** Deploy certificates on all servers so that the certificate can be validated by a web browser, otherwise users receive warning messages about invalid certificates. For more information about certificate validation, see Certificate Validation.

**Step 2** Ensure Service Discovery of SAML SSO in the client. The client uses standard service discovery to enable SAML SSO in the client. Enable service discovery by using the following configuration parameters: ServicesDomain, VoiceServicesDomain, and ServiceDiscoveryExcludedServices. For more information about how to enable service discovery, see Configure Service Discovery for Remote Access.

**Step 3** Define how long a session lasts.

A session is comprised of cookie and token values. A cookie usually lasts longer than a token. The life of the cookie is defined in the Identity Provider, and the duration of the token is defined in the service.

**Step 4** When SSO is enabled, by default all Cisco Jabber users sign in using SSO. Administrators can change this on a per user basis so that certain users do not use SSO and instead sign in with their Cisco Jabber username and password. To disable SSO for a Cisco Jabber user, set the value of the SSO Enabled parameter to FALSE.

If you have configured Cisco Jabber not to ask users for their email address, their first sign in to Cisco Jabber may be non-SSO. In some deployments, the parameter ServicesDomainSsoEmailPrompt needs to be set to ON. This ensures that Cisco Jabber has the information required to perform a first-time SSO sign in. If users signed in to Cisco Jabber previously, this prompt is not needed because the required information is available.

Certificate-Based SSO Authentication for Mobile Clients

The configuration mentioned here applies to Cisco Jabber for iPhone and iPad only. There is no configuration required for Cisco Jabber for Android.

To enable this feature configure the same settings for SSO Login Behavior for iOS in both Cisco Unified Communications Manager and Cisco Unity Connection.

To enable this feature over Expressway for Mobile and Remote Access, configure Jabber for iPhone and iPad clients to use embedded Safari browser in the VCS Expressway admin console. For more information, see Installation guides for Cisco Expressway 8.9.

The Common Identity cannot be enabled for Webex messenger. You must disable Common Identity (CI) if you want to enable embedded Safari to connect to voicemail using client certificate-based SSO authentication for Cisco Jabber for iPhone and iPad.
Configuring Certificate-Based SSO Authentication on Cisco Unified Communications Manager

This configuration is only supported on Cisco Unified Communications Manager 11.5 or later.

**Procedure**

1. **Step 1** In Cisco Unified CM Administration, go to System > Enterprise Parameters.
2. **Step 2** In the SSO configuration section, scroll down to SSO Login Behavior for iOS and choose Use native browser.
3. **Step 3** Select Save.

Configuring Certificate-Based SSO Authentication on Cisco Unity Connection

**Procedure**

1. **Step 1** In Cisco Unity Connection Administration, go to System Settings > Enterprise Parameters.
2. **Step 2** In the SSO Configuration section, scroll down to SSO Login Behavior for iOS and choose Use native browser.
3. **Step 3** Select Save.

Perform Synchronization

After you add a directory server and specify the authentication method, you can synchronize Cisco Unified Communications Manager with the directory server.

**Procedure**

1. **Step 1** Select System > LDAP > LDAP Directory.
2. **Step 2** Click Find and select the LDAP directory that you configured.
   
   The LDAP Directory window opens.

   **Step 3** Select Perform Full Sync Now.

   **Note** The amount of time it takes for the synchronization process to complete depends on the number of users that exist in your directory. If you synchronize a large directory with thousands of users, you should expect the process to take some time.

User data from your directory server is synchronized to the Cisco Unified Communications Manager database. Cisco Unified Communications Manager then synchronizes the user data to the IM and Presence Service database.
Associate Service Profile to User

Associate Service Profile to Individual Users

Associate service profiles with individual users.

**Procedure**

**Step 1** Open the **Cisco Unified CM Administration** interface.

**Step 2** Select **User Management > End User**.

The **Find and List Users** window opens.

**Step 3** Specify the appropriate filters in the **Find User where** field and then select **Find** to retrieve a list of users.

**Step 4** Select the appropriate username from the list.

The **End User Configuration** window opens.

**Step 5** Locate the **Service Settings** section.

**Step 6** Select **Home Cluster**.

**Step 7** For Phone mode deployments, ensure the **Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile)** option is not selected.

For all other deployments, check the **Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile)** checkbox.

**Step 8** Select your service profile from the **UC Service Profile** drop-down list.

**Important** Cisco Unified Communications Manager release 9.x only—If the user has only instant messaging and presence capabilities (IM only), select **Use Default**. Cisco Unified Communications Manager release 9.x applies the default service profile regardless of what you select from the **UC Service Profile** drop-down list.

**Step 9** Select **Save**.

**Associate Service Profile to Users in Bulk**

Add the service profile to multiple users.

**Procedure**

**Step 1** Open the **Cisco Unified CM Administration** interface.

**Step 2** Select **Bulk Administration > Users > Update Users > Query**.

The **Find and List Users To Update** window opens.
Step 3 Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.

Step 4 Select Next.

The Update Users Configuration window opens.

Step 5 For Phone mode deployments, disable instant messaging and presence, check one check box for Enable User for Unified CM IM and Presence.

For all other deployments, select both check boxes for Enable User for Unified CM IM and Presence.

Step 6 Select the UC Service Profile check box and then select your service profile from the drop-down list.

Important Cisco Unified Communications Manager release 9.x only — If the user has only instant messaging and presence capabilities (IM only), you must select Use Default.

For IM only users — Cisco Unified Communications Manager release 9.x always applies the default service profile regardless of what you select from the UC Service Profile drop-down list.

Step 7 In the Job Information section, specify if you want to run the job immediately or at a later time.

Step 8 Select Submit.

---

Prepopulate Contact Lists in Bulk

You can pre-populate user contact lists with the Bulk Administration Tool (BAT).

In this way you can prepopulate contact lists for users so that they automatically have a set of contacts after the initial launch of the client.

Cisco Jabber supports up to 300 contacts in a client contact list.

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Create a CSV file that defines the contact list you want to provide to users.</td>
<td>Create CSV to Import Contact Lists, on page 49</td>
</tr>
<tr>
<td><strong>Step 2</strong> Use the BAT to import the contact list in bulk to a set of users.</td>
<td>Upload Contact List Using BAT, on page 50</td>
</tr>
</tbody>
</table>

Create CSV to Import Contact Lists

**Structure of the CSV File**

The CSV file must have the following format:

<User ID>, <User Domain>, <Contact ID>, <Contact Domain>, <Nickname>, <GroupName>

Sample CSV file entry:

userA,example.com, userB, example.com, buddyB, General
Table 1: Description of Input File Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID</td>
<td>Required parameter. The user ID of the IM and Presence Service user. It can have a maximum 132 characters.</td>
</tr>
<tr>
<td>User Domain</td>
<td>Required parameter. The Presence domain of the IM and Presence Service user. It can have a maximum of 128 characters.</td>
</tr>
<tr>
<td>Contact ID</td>
<td>Required parameter. The user ID of the contact list entry. It can have a maximum of 132 characters.</td>
</tr>
</tbody>
</table>
| Contact Domain| Required parameter. The Presence domain of the contact list entry. The following restrictions apply to the format of the domain name:  
  • Length must be less than or equal to 128 characters  
  • Contains only numbers, upper- and lowercase letters, and hyphens (-)  
  • Must not start or end with hyphen (-)  
  • Length of label must be less than or equal to 63 characters  
  • Top-level domain must be characters only and have at least two characters |
| Nickname      | The nickname of the contact list entry. It can have a maximum of 255 characters. |
| Group Name    | Required parameter. The name of the group to which the contact list entry is to be added. It can have a maximum of 255 characters. |

Upload Contact List Using BAT

Before you begin
Create a CSV file with contacts.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open the Cisco Unified CM IM and Presence Administration interface.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select Bulk Administration &gt; Upload/Download Files.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Select Add New.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select Choose File to locate and choose the CSV file.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Choose Contact Lists as the target.</td>
</tr>
</tbody>
</table>
Step 6 Choose Import Users' Contacts - Custom File as the Transaction Type.
Step 7 Select Save to upload the file.

---

**Configure Authentication for UDS Contact Search**

Cisco Jabber supports authenticated directory queries when searching for contacts. The authentication is configured on Cisco Unified Communications Manager release 11.5 or later.

**Procedure**

Step 1 Log in to the Command Line Interface.
Step 2 Run the `utils contactsearchauthentication status` command to confirm the contact search authentication setting on this node.
Step 3 If you need to configure contact search authentication:
   - To enable authentication, run the `utils contactsearchauthentication enable` command.
   - To disable authentication, run the `utils contactsearchauthentication disable` command.
Step 4 Repeat this procedure on all Unified Communications Manager cluster nodes.

**Note** You must reset phones in order for the changes to take effect.

---

**Enable Extended UDS Contact Source**

**Before you begin**

Extended UDS contact search is only available on Cisco Unified Communications Manager release 11.5(1) or later.

**Procedure**

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > LDAP > LDAP Search
Step 3 To enable user searches to be performed using an enterprise LDAP directory server, check the **Enable user search to Enterprise Directory Server** check box.
Step 4 Configure the fields in the **LDAP Search Configuration** window. See the online help for more information about the fields and their configuration options.
Step 5 Select Save.
Enable Extended UDS Contact Source
Configure Softphone

• Create Softphones Workflow, on page 53

Create Softphones Workflow

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create and Configure Cisco Jabber Devices, on page 53 Create at least one device for every user that will access Cisco Jabber. Generate an authentication string to provide to end users.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Add a Directory Number to the Device, on page 57 For each device you create, add a directory number.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Associate Users with Devices, on page 57 Associate users with devices.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Create Mobile SIP Profiles, on page 58. Complete this task if you have Cisco Unified Communications Manager release 9 and plan to configure devices for mobile clients.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure the Phone Security Profile, on page 59 Complete this task to set up secure phone capabilities for all devices.</td>
</tr>
</tbody>
</table>

Create and Configure Cisco Jabber Devices

Create at least one device for every user that accesses Cisco Jabber. A user can have multiple devices.

Note

Users can only remove participants from a conference call when using the softphone (CSF) device for calls.

Before you begin

• Install COP files.
• Create SIP profiles if you have Cisco Unified Communications Manager release 9 or earlier and plan to configure devices for mobile clients.

• Create the Phone Security Profile if you plan to set up secure phone capabilities for all devices.

• If you are using CAPF enrollment, for Cisco Unified Communications Manager release 10 or later, ensure that the Cisco Certificate Authority Proxy Function (CAPF) service parameters value for Certificate Issuer to Endpoint is Cisco Certificate Authority Proxy Function. This is the only option supported by Cisco Jabber. For information on configuring the CAPF service parameter see the Update CAPF Service Parameters topic in the Cisco Unified Communications Manager Security Guides.

• Before you create TCT devices, BOT devices, or TAB devices for Cisco Jabber for mobile users, specify the organization top domain name to support registration between Cisco Jabber and the Cisco Unified Communications Manager. In Unified CM Administration interface, select System > Enterprise Parameters. Under the Clusterwide Domain Configuration section, enter the organization top domain name. For example, cisco.com. This top domain name is used by Jabber as the DNS domain of the Cisco Unified Communications Manager servers for phone registration. For example, CUCMServer1@cisco.com.

Procedure

Step 1 Log into the Cisco Unified CM Administration interface.

Step 2 Select Device > Phone. Find and List Phones window opens.

Step 3 Select Add New.

Step 4 From the Phone Type drop-down list, select the option that is applicable to the device type you are configuring and then select Next.

For Jabber users, you can only create one type of device per user although you can create multiple devices for each user. For example, you can create one tablet device and one CSF device but not two CSF devices.

• Cisco Unified Client Services Framework — Select this option to create a CSF device for Cisco Jabber for Mac or Cisco Jabber for Windows.

• Cisco Dual Mode for iPhone — Select this option to create a TCT device for an iPhone.

• Cisco Jabber for Tablet — Select this option to create a TAB device for an iPad or an Android tablet or for Chromebooks.

• Cisco Dual Mode for Android — Select this option to create a BOT device for an Android device.

Step 5 From the Owner User ID drop-down list, select the user for whom you want to create the device.

For the Cisco Unified Client Services Framework option in a Phone mode deployment, ensure that User is selected.

Step 6 In the Device Name field, use the applicable format to specify a name for the device:

<table>
<thead>
<tr>
<th>If You Select</th>
<th>Required Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Unified Client Services Framework</td>
<td>• Valid characters: a–z, A–Z, 0–9.</td>
</tr>
<tr>
<td></td>
<td>• 15-character limit.</td>
</tr>
<tr>
<td>If You Select</td>
<td>Required Format</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Cisco Dual Mode for iPhone</td>
<td>• The device name must begin with TCT.</td>
</tr>
<tr>
<td></td>
<td>For example, if you create a TCT device for user, Tanya Adams, whose username is tadams, enter TCTTADAMS.</td>
</tr>
<tr>
<td></td>
<td>• Must be uppercase.</td>
</tr>
<tr>
<td></td>
<td>• Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).</td>
</tr>
<tr>
<td></td>
<td>• 15-character limit.</td>
</tr>
<tr>
<td>Cisco Jabber for Tablet</td>
<td>• The device name must begin with TAB.</td>
</tr>
<tr>
<td></td>
<td>For example, if you create a TAB device for user, Tanya Adams, whose username is tadams, enter TABTADAMS.</td>
</tr>
<tr>
<td></td>
<td>• Must be uppercase.</td>
</tr>
<tr>
<td></td>
<td>• Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).</td>
</tr>
<tr>
<td></td>
<td>• 15-character limit.</td>
</tr>
<tr>
<td>Cisco Dual Mode for Android</td>
<td>• The device name must begin with BOT.</td>
</tr>
<tr>
<td></td>
<td>For example, if you create a BOT device for user, Tanya Adams, whose username is tadams, enter BOTTADAMS.</td>
</tr>
<tr>
<td></td>
<td>• Must be uppercase.</td>
</tr>
<tr>
<td></td>
<td>• Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).</td>
</tr>
<tr>
<td></td>
<td>• 15-character limit.</td>
</tr>
</tbody>
</table>

**Step 7**  
If you are using CAPF enrollment, complete the following steps to generate an authentication string:

1. Users can use the authentication string that you can provide to access their devices and securely register to Cisco Unified Communications Manager, navigate to the **Certification Authority Proxy Function (CAPF) Information** section.

2. From the **Certificate Operation** drop-down list, select **Install/Upgrade**.

3. From the **Authentication Mode** drop-down list, select **By Authentication String** or **By Null String**. Using the CAPF Authentication mode **By Authentication String** with JVDI and Jabber for Windows CSF devices is not supported. It causes Jabber registration with Cisco Unified Communications Manager to fail.

4. Click **Generate String**. The Authentication String autopopulates with a string value. This is the string that you will provide to end users.

5. From the **Key Size (Bits)** drop-down list, select the same key size that you set in the phone security profile.
6. In the **Operation Completes By** fields, specify an expiration value for the authentication string or leave as default.

7. If you are using a group configuration file, specify it in the **Cisco Support Field** of the **Desktop Client Settings**. Cisco Jabber does not use any other settings that are available on the **Desktop Client Settings**.

**Step 8**
Select **Save**.

**Step 9**
Click **Apply Config**.

---

**What to do next**
Add a Directory Number to the device.

---

**Provide Users with Authentication Strings**

If you are using CAPF enrollment to configure secure phones, then you must provide users with authentication strings. Users must specify the authentication string in the client interface to access their devices and securely register with Cisco Unified Communications Manager.

When users enter the authentication string in the client interface, the CAPF enrollment process begins.

---

**Note**
The time it takes for the enrollment process to complete can vary depending on the user's computer or mobile device and the current load for Cisco Unified Communications Manager. It can take up to one minute for the client to complete the CAPF enrollment process.

The client displays an error if:

- Users enter an incorrect authentication string.

  Users can attempt to enter authentication strings again to complete the CAPF enrollment. However, if a user continually enters an incorrect authentication string, the client might reject any string the user enters, even if the string is correct. In this case, you must generate a new authentication string on the user's device and then provide it to the user.

- Users do not enter the authentication string before the expiration time you set in the **Operation Completes By** field.

  In this case, you must generate a new authentication string on the user's device. The user must then enter that authentication string before the expiration time.

---

**Important**
When you configure the end users in Cisco Unified Communications Manager, you must add them to the following user groups:

- **Standard CCM End Users**
- **Standard CTI Enabled**

Users must not belong to the Standard CTI Secure Connection user group.
Add a Directory Number to the Device

After you create and configure each device, you must add a directory number to the device. This topic provides instructions on adding directory numbers using the Device > Phone menu option.

Before you begin
Create a device.

Procedure

1. Locate the Association Information section on the Phone Configuration window.
2. Click Add a new DN.
3. In the Directory Number field, specify a directory number.
4. In the Users Associated with Line section, click Associate End Users.
5. In the Find User where field, specify the appropriate filters and then click Find.
6. From the list that appears, select the applicable users and click Add Selected.
7. Specify all other required configuration settings as appropriate.
8. Select Apply Config.
9. Select Save.

Associate Users with Devices

On Cisco Unified Communications Manager version 9.x only, when the client attempts to retrieve the service profile for the user, it first gets the device configuration file from Cisco Unified Communications Manager. The client can then use the device configuration to get the service profile that you applied to the user.

For example, you provision Adam McKenzie with a CSF device named CSFKenzi. The client retrieves CSFKenzi.cnf.xml from Cisco Unified Communications Manager when Adam signs in. The client then looks for the following in CSFKenzi.cnf.xml:

```xml
<userId serviceProfileFile="identifier.cnf.xml">amckenzi</userId>
```

For this reason, if you are using Cisco Unified Communications Manager version 9.x, you should do the following to ensure that the client can successfully retrieve the service profiles that you apply to users:

- Associate users with devices.
- Set the User Owner ID field in the device configuration to the appropriate user. The client will retrieve the Default Service Profile if this value is not set.

Note

A CSF should not be associated to multiple users if you intend to use different service profiles for these users.
Procedure

**Step 1**  
Associate users with devices.  
   a) Open the **Unified CM Administration** interface.  
   b) Select **User Management > End User**.  
   c) Find and select the appropriate user.  
       The **End User Configuration** window opens.  
   d) Select **Device Association** in the **Device Information** section.  
   e) Associate the user with devices as appropriate.  
   f) Return to the **End User Configuration** window and then select **Save**.

**Step 2**  
Set the **User Owner ID** field in the device configuration.  
   a) Select **Device > Phone**.  
   b) Find and select the appropriate device.  
       The **Phone Configuration** window opens.  
   c) Locate the **Device Information** section.  
   d) Select **User** as the value for the **Owner** field.  
   e) Select the appropriate user ID from the **Owner User ID** field.  
   f) Select **Save**.

---

**Create Mobile SIP Profiles**

This procedure is required only when you use Cisco Unified Communication Manager release 9 and are configuring devices for mobile clients. Use the default SIP profile provided for desktop clients. Before you create and configure devices for mobile clients, you must create a SIP profile that allows Cisco Jabber to stay connected to Cisco Unified Communication Manager while Cisco Jabber runs in the background.

If you use Cisco Unified Communication Manager Release 10, choose the **Standard SIP Profile for Mobile Device** default profile when you create and configure devices for mobile clients.

Procedure

**Step 1**  
Open the **Cisco Unified CM Administration** interface.

**Step 2**  
Select **Device > Device Settings > SIP Profile**.  
   The **Find and List SIP Profiles** window opens.

**Step 3**  
Do one of the following to create a new SIP profile:  
   • Find the default SIP profile and create a copy that you can edit.  
   • Select **Add New** and create a new SIP profile.

**Step 4**  
In the new SIP profile, set the following values:  
   • **Timer Register Delta** = 120  
   • **Timer Register Expires** = 720
• Timer Keep Alive Expires = 720
• Timer Subscribe Expires = 21600
• Timer Subscribe Delta = 15

Step 5 Select Save.

Setting up System SIP Parameters

If you are connected to a low-bandwidth network and finding it difficult to take an incoming call on your mobile device, you can set the system SIP parameters to improve the condition. Increase the SIP Dual Mode Alert Timer value to ensure that calls to the Cisco Jabber extension are not prematurely routed to the mobile-network phone number.

Before you begin

This configuration is only for mobile clients.
Cisco Jabber must be running to receive work calls.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters.
Step 3 Select the node.
Step 4 Select the Cisco CallManager (Active) service.
Step 5 Scroll to the Clusterwide Parameters (System - Mobility) section.
Step 6 Increase the SIP Dual Mode Alert Timer value to 10000 milliseconds.
Step 7 Select Save.

Note If, after you increase the SIP Dual Mode Alert Timer value, incoming calls that arrive in Cisco Jabber are still terminated and diverted using Mobile Connect, you can increase the SIP Dual Mode Alert Timer value again in increments of 500 milliseconds.

Configure the Phone Security Profile

You can optionally set up secure phone capabilities for all devices. Secure phone capabilities provide secure SIP signaling, secure media streams, and encrypted device configuration files.

If you enable secure phone capabilities for users, device connections to Cisco Unified Communications Manager are secure. However, calls with other devices are secure only if both devices have a secure connection.

Before you begin

• Configure the Cisco Unified Communications Manager security mode using the Cisco CTL Client. At minimum, select mixed mode security.
For instructions on how to configure mixed mode with the Cisco CTL Client, see the Cisco Unified Communications Manager Security Guide.

- For conference calls, ensure that the conferencing bridge supports secure phone capabilities. If the conferencing bridge does not support secure phone capabilities, calls to that bridge are not secure. Likewise, all parties must support a common encryption algorithm for the client to encrypt media on conference calls.

**Procedure**

**Step 1**
In Cisco Unified Communications Manager, select **System > Security > Phone Security Profile**.

**Step 2**
Select **Add New**.

**Step 3**
From the **Phone Type** drop-down list, select the option that is applicable to the device type you are configuring and then select **Next**.

- **Cisco Unified Client Services Framework** — Select this option to create a CSF device for Cisco Jabber for Mac or Cisco Jabber for Windows.
- **Cisco Dual Mode for iPhone** — Select this option to create a TFT device for an iPhone.
- **Cisco Jabber for Tablet** — Select this option to create a TAB device for an iPad or an Android tablet or for Chromebooks.
- **Cisco Dual Mode for Android** — Select this option to create a BOT device for an Android device.
- **CTI Remote Device** — Select this option to create a CTI remote device.

CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

**Step 4**
In the **Name** field of the **Phone Security Profile Configuration** window, specify a name for the phone security profile.

**Step 5**
For **Device Security Mode**, select one of the following options:

- **Authenticated** — The SIP connection is over TLS using NULL-SHA encryption.
- **Encrypted** — The SIP connection is over TLS using AES128/SHA encryption. The client uses Secure Real-time Transport Protocol (SRTP) to offer encrypted media streams.

**Step 6**
For **Transport Type**, leave the default value of TLS.

**Step 7**
Select the **TFTPEncryptedConfig** check box to encrypt the device configuration file that resides on the TFTP server.

**Note**
For a TCT/BOT/Tablet device, do not select the TFTPEncryptedConfig check box here. For Authentication Mode, select By Authentication String or Null String.

**Step 8**
For **Authentication Mode**, select **By Authentication String** or **By Null String**.

**Note**
Using the CAPF Authentication mode **By Null String** with JVDI and Jabber for Windows CSF devices is not supported. It causes Jabber registration with Cisco Unified Communications Manager to fail.

**Step 9**
For **Key Size (Bits)**, select the appropriate key size for the certificate. Key size refers to the bit length of the public and private keys that the client generates during the CAPF enrollment process.
The Cisco Jabber clients were tested using authentication strings with 1024-bit length keys. The Cisco Jabber clients require more time to generate 2048-bit length keys than 1024-bit length keys. As a result, if you select 2048, expect it to take longer to complete the CAPF enrollment process.

**Step 10**

For **SIP Phone Port**, leave the default value.

The port that you specify in this field takes effect only if you select **Non Secure** as the value for **Device Security Mode**.

**Step 11**

Click **Save**.
Configure the Phone Security Profile
Configure Deskphone Control

- Prerequisites, on page 63
- Configure Desk Phone Control Workflow, on page 63
- Create Desk Phone Devices, on page 64
- Enable Device for CTI, on page 65
- Configure Desk Phone Video, on page 65
- Add Directory Number to the Device for Desktop Applications, on page 67
- Enable Video Rate Adaptation, on page 67

Prerequisites

The Cisco CTIManager service must be running in the Cisco Unified Communications Manager cluster.

Configure Desk Phone Control Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create Desk Phone Devices, on page 64</td>
<td>Create a desk phone device.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Enable Device for CTI, on page 65</td>
<td>Allows Cisco Jabber desktop clients to control the desk phone of the user.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Configure Desk Phone Video, on page 65.</td>
<td>Let users receive video transmitted to their desk phone devices on their computers through the client.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Add Directory Number to the Device for Desktop Applications, on page 67.</td>
<td>Assign a Directory number to the device.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Enable Video Rate Adaptation, on page 67</td>
<td>The client uses video rate adaptation to negotiate optimum video quality.</td>
</tr>
</tbody>
</table>
Create Desk Phone Devices

Users can control desk phones on their computers to place audio calls.

**Procedure**

**Step 1**
Open the Cisco Unified CM Administration interface.

**Step 2**
Select Device > Phone.

The Find and List Phones window opens.

**Step 3**
Select Add New.

**Step 4**
Select the appropriate device from the Phone Type drop-down list and then select Next.

The Phone Configuration window opens.

**Step 5**
Complete the following steps in the Device Information section:

a) Enter a meaningful description in the Description field.

The client displays device descriptions to users. If users have multiple devices of the same model, the descriptions help users tell the difference between multiple devices.

b) Select Allow Control of Device from CTI.

If you do not select Allow Control of Device from CTI, users cannot control the desk phone.

**Step 6**
Set the Owner User ID field to the appropriate user.

**Important**
On Cisco Unified Communications Manager version 9.x, the client uses the Owner User ID field to get service profiles for users. For this reason, each user must have a device and the User Owner ID field must be associated with the user.

If you do not associate users with devices and set the Owner User ID field to the appropriate user, the client cannot retrieve the service profile that you apply to the user.

**Step 7**
Complete the following steps to enable desk phone video capabilities:

a) Locate the Product Specific Configuration Layout section.

b) Select Enabled from the Video Capabilities drop-down list.

**Note**
If possible, you should enable desk phone video capabilities on the device configuration. However, certain phone models do not include the Video Capabilities drop-down list at the device configuration level. In this case, you should open the Common Phone Profile Configuration window and then select Enabled from the Video Calling drop-down list.

See Desk Phone Video Configuration for more information about desk phone video.

**Step 8**
Specify all other configuration settings on the Phone Configuration window as appropriate.

See the Cisco Unified Communications Manager documentation for more information about the configuration settings on the Phone Configuration window.

**Step 9**
Select Save.
An message displays to inform you if the device is added successfully. The **Association Information** section becomes available on the **Phone Configuration** window.

---

**What to do next**

Add a directory number to the device and apply the configuration.

---

### Enable Device for CTI

If you want Cisco Jabber desktop clients to be able to control the desk phone of the user, you must select the **Allow Control of Device from CTI** option when you create the device for the user.

**Procedure**

1. **Step 1** In Cisco Unified CM Administration, click **Device > Phone** and search for the phone.
2. **Step 2** In the **Device Information** section, check **Allow Control of Device from CTI**.
3. **Step 3** Click **Save**.

---

### Configure Desk Phone Video

Desk phone video capabilities let users receive video transmitted to their desk phone devices on their computers through the client. Users must physically connect the computer to the desk phone device through the computer port so that the client can establish a connection to the device. Users cannot use desk phone video capabilities with wireless connections to desk phone devices.

#### Note

If users have both wireless and wired connections available, they should configure Microsoft Windows so that wireless connections do not take priority over wired connections. See the following Microsoft documentation for more information: *An explanation of the Automatic Metric feature for Internet Protocol routes*.

For desk phone video capabilities, you must download and install Jabber Desk Phone Video Services Interface from Cisco.com. Jabber Desk Phone Video Services Interface provides the Cisco Discover Protocol (CDP) driver that enables the client to do the following:

- Discover the desk phone device.
- Establish and maintain a connection to the desk phone device using the CAST protocol.

#### Desk Phone Video Considerations

Review the following considerations and limitations before you provision desk phone video capabilities for users:
• You cannot use desk phone video capabilities on devices if video cameras are attached to the devices, such as a Cisco Unified IP Phone 9971. You can use desk phone video capabilities if you remove video cameras from the devices.

• You cannot use desk phone video capabilities with devices that do not support CTI.

• Video desktop sharing, using the BFCP protocol, is not supported with desk phone video.

• It is not possible for endpoints that use SCCP to receive video only. SCCP endpoints must send and receive video. Instances where SCCP endpoints do not send video result in audio only calls.

• 7900 series phones must use SCCP for desk phone video capabilities. 7900 series phones cannot use SIP for desk phone video capabilities.

• If a user initiates a call from the keypad on a desk phone device, the call starts as an audio call on the desk phone device. The client then escalates the call to video. For this reason, you cannot make video calls to devices that do not support escalation, such as H.323 endpoints. To use desk phone video capabilities with devices that do not support escalation, users should initiate calls from the client.

• A compatibility issue exists with Cisco Unified IP Phones that use firmware version SCCP45.9-2-1S. You must upgrade your firmware to version SCCP45.9-3-1 to use desk phone video capabilities.

• Some antivirus or firewall applications, such as Symantec EndPoint Protection, block inbound CDP packets, which disables desk phone video capabilities. You should configure your antivirus or firewall application to allow inbound CDP packets.

See the following Symantec technical document for additional details about this issue: Cisco IP Phone version 7970 and Cisco Unified Video Advantage is Blocked by Network Threat Protection.

• You must not select the Media Termination Point Required checkbox on the SIP trunk configuration for Cisco Unified Communications Manager. Desk phone video capabilities are not available if you select this checkbox.

Procedure

| Step 1 | Physically connect the computer to the computer port on the desk phone device. |
| Step 2 | Enable the desk phone device for video in Cisco Unified Communications Manager. |
| Step 3 | Install Jabber Desk Phone Video Services Interface on the computer. |

Troubleshooting Desk Phone Video

If you encounter an error that indicates desk phone video capabilities are unavailable or the desk phone device is unknown, do the following:

1. Ensure you enable the desk phone device for video in Cisco Unified Communications Manager.

2. Reset the physical desk phone.

3. Exit the client.

4. Run services.msc on the computer where you installed the client.
5. Restart Jabber Desk Phone Video Services Interface from the Services tab of the Windows Task Manager.
6. Restart the client.

Add Directory Number to the Device for Desktop Applications

You must add directory numbers to devices in Cisco Unified Communications Manager. This topic provides instructions on adding directory numbers using the Device > Phone menu option after you create your device. Under this menu option, only the configuration settings that apply to the phone model or CTI route point display. See the Cisco Unified Communications Manager documentation for more information about different options to configure directory numbers.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Locate the Association Information section on the Phone Configuration window.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select Add a new DN.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Specify a directory number in the Directory Number field.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Specify all other required configuration settings as appropriate.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Associate end users with the directory number as follows:</td>
</tr>
<tr>
<td></td>
<td>a) Locate the Users Associated with Line section.</td>
</tr>
<tr>
<td></td>
<td>b) Select Associate End Users.</td>
</tr>
<tr>
<td></td>
<td>c) Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.</td>
</tr>
<tr>
<td></td>
<td>d) Select the appropriate users from the list.</td>
</tr>
<tr>
<td></td>
<td>e) Select Add Selected.</td>
</tr>
<tr>
<td></td>
<td>The selected users are added to the voicemail profile.</td>
</tr>
</tbody>
</table>

| Step 6 | Select Save.                                                                 |
| Step 7 | Select Apply Config.                                                         |
| Step 8 | Follow the prompts on the Apply Configuration window to apply the configuration. |

Enable Video Rate Adaptation

The client uses video rate adaptation to negotiate optimum video quality. Video rate adaptation dynamically increases or decreases video quality based on network conditions.

To use video rate adaptation, you must enable Real-Time Transport Control Protocol (RTCP) on Cisco Unified Communications Manager.

Note

RTCP is enabled on software phone devices by default. However, you must enable RTCP on desk phone devices.
Enable RTCP on Common Phone Profiles

You can enable RTCP on a common phone profile to enable video rate adaptation on all devices that use the profile.

**Note**

RTCP is an integral component of Jabber Telephony services. Jabber will continue to send RTCP packets even when disabled.

**Procedure**

**Step 1**
Open the Cisco Unified CM Administration interface.

**Step 2**
Select Device > Device Settings > Common Phone Profile.

The Find and List Common Phone Profiles window opens.

**Step 3**
Specify the appropriate filters in the Find Common Phone Profile where field and then select Find to retrieve a list of profiles.

**Step 4**
Select the appropriate profile from the list.

The Common Phone Profile Configuration window opens.

**Step 5**
Locate the Product Specific Configuration Layout section.

**Step 6**
Select Enabled from the RTCP drop-down list.

**Step 7**
Select Save.

Enable RTCP on Device Configurations

You can enable RTCP on specific device configurations instead of a common phone profile. The specific device configuration overrides any settings you specify on the common phone profile.

**Procedure**

**Step 1**
Open the Cisco Unified CM Administration interface.

**Step 2**
Select Device > Phone.

The Find and List Phones window opens.

**Step 3**
Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of phones.

**Step 4**
Select the appropriate phone from the list.

The Phone Configuration window opens.

**Step 5**
Locate the Product Specific Configuration Layout section.

**Step 6**
Select Enabled from the RTCP drop-down list.
Step 7  Select Save.
Enable RTCP on Device Configurations
CHAPTER 12

Configure Extend and Connect

- Configure Extend and Connect Workflow, on page 71
- Enable User Mobility, on page 71
- Create CTI Remote Devices, on page 72
- Add a Remote Destination, on page 73

Configure Extend and Connect Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Enable User Mobility, on page 71</td>
<td>Enable users mobility and you can assign users as owners of CTI remote devices.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Create CTI Remote Devices, on page 72</td>
<td>Create CTI remote devices, these virtual devices monitor and have call control over a user's remote destination.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Add a Remote Destination, on page 73</td>
<td>(Optional) If you plan to provision users with dedicated CTI remote devices, add a remote destination in Cisco Unified Communications Manager.</td>
</tr>
</tbody>
</table>

Enable User Mobility

This task is only for desktop clients.

You must enable user mobility to provision CTI remote devices. If you do not enable mobility for users, you cannot assign those users as owners of CTI remote devices.

Before you begin

This task is applicable only if:

- You plan to assign Cisco Jabber for Mac or Cisco Jabber for Windows users to CTI remote devices.
• You have Cisco Unified Communication Manager release 9.x and later.

Procedure

Step 1  Select User Management > End User.
The Find and List Users window opens.

Step 2  Specify the appropriate filters in the Find User where field to and then select Find to retrieve a list of users.

Step 3  Select the user from the list.
The End User Configuration window opens.

Step 4  Locate the Mobility Information section.

Step 5  Select Enable Mobility.

Step 6  Select Save.

Create CTI Remote Devices

CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

Procedure

Step 1  Open the Cisco Unified CM Administration interface.

Step 2  Select Device > Phone.
The Find and List Phones window opens.

Step 3  Select Add New.

Step 4  Select CTI Remote Device from the Phone Type drop-down list and then select Next.
The Phone Configuration window opens.

Step 5  Select the appropriate user ID from the Owner User ID drop-down list.

Note  Only users for whom you enable mobility are available from the Owner User ID drop-down list.
For more information, see Enable SAML SSO in the Client.

Cisco Unified Communications Manager populates the Device Name field with the user ID and a CTIRD prefix; for example, CTIRDusername

Step 6  Edit the default value in the Device Name field, if appropriate.

Step 7  Ensure you select an appropriate option from the Rerouting Calling Search Space drop-down list in the Protocol Specific Information section.

The Rerouting Calling Search Space drop-down list defines the calling search space for re-routing and ensures that users can send and receive calls from the CTI remote device.
Step 8 Specify all other configuration settings on the Phone Configuration window as appropriate.

See the CTI remote device setup topic in the System Configuration Guide for Cisco Unified Communications Manager documentation for more information.

Step 9 Select Save.

The fields to associate directory numbers and add remote destinations become available on the Phone Configuration window.

---

Add a Remote Destination

Remote destinations represent the CTI controllable devices that are available to users.

You should add a remote destination through the Cisco Unified CM Administration interface if you plan to provision users with dedicated CTI remote devices. This task ensures that users can automatically control their phones and place calls when they start the client.

If you plan to provision users with CTI remote devices along with software phone devices and desk phone devices, you should not add a remote destination through the Cisco Unified CM Administration interface. Users can enter remote destinations through the client interface.

---

Note

- You should create only one remote destination per user. Do not add two or more remote destinations for a user.

- Cisco Unified Communications Manager does not verify if it can route remote destinations that you add through the Cisco Unified CM Administration interface. For this reason, you must ensure that Cisco Unified Communications Manager can route the remote destinations you add.

- Cisco Unified Communications Manager automatically applies application dial rules to all remote destination numbers for CTI remote devices.

---

Procedure

- **Step 1** Open the Cisco Unified CM Administration interface.
- **Step 2** Select Device > Phone.
  
The Find and List Phones window opens.
- **Step 3** Specify the appropriate filters in the Find Phone where field to and then select Find to retrieve a list of phones.
- **Step 4** Select the CTI remote device from the list.
  
The Phone Configuration window opens.
- **Step 5** Locate the Associated Remote Destinations section.
- **Step 6** Select Add a New Remote Destination.
The Remote Destination Information window opens.

**Step 7** Specify JabberRD in the **Name** field.

**Restriction** You must specify JabberRD in the **Name** field. The client uses only the JabberRD remote destination. If you specify a name other than JabberRD, users cannot access that remote destination.

The client automatically sets the JabberRD name when users add remote destinations through the client interface.

**Step 8** Enter the destination number in the **Destination Number** field.

**Step 9** Specify all other values as appropriate.

**Step 10** Select **Save**.

---

**What to do next**

Complete the following steps to verify the remote destination and apply the configuration to the CTI remote device:

1. Repeat the steps to open the **Phone Configuration** window for the CTI remote device.
2. Locate the **Associated Remote Destinations** section.
3. Verify the remote destination is available.
4. Select **Apply Config**.

---

**Note**

The **Device Information** section on the **Phone Configuration** window contains a **Active Remote Destination** field.

When users select a remote destination in the client, it displays as the value of **Active Remote Destination**.

**none** displays as the value of **Active Remote Destination** if:

- Users do not select a remote destination in the client.
- Users exit or are not signed in to the client.
PART III

Configuration

- Configure Service Discovery, on page 77
- Configure Certificate Validation, on page 89
- Configure the Clients, on page 93
- Deploy Cisco Jabber Applications and Jabber Softphone for VDI, on page 103
- Remote Access, on page 141
- Quality of Service, on page 151
- Integrate Cisco Jabber with Applications, on page 157
CHAPTER 13

Configure Service Discovery

• Service Discovery Options, on page 77
  • Configure DNS SRV Records, on page 77
  • Customizations, on page 79
  • Manual Connection Settings, on page 85

Service Discovery Options

Service discovery enables clients to automatically detect and locate services on your enterprise network. You can configure service discovery using one of the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure DNS SRV Records, on page 77</td>
<td>The client automatically locates and connects to services. This is the recommended option.</td>
</tr>
<tr>
<td>Customizations, on page 79</td>
<td>You can customize service discovery by using installation parameters, URL configuration, or Enterprise Mobility Management.</td>
</tr>
<tr>
<td>Manual Connection Settings, on page 85</td>
<td>Manual connection settings provide a fallback mechanism when service discovery is not used.</td>
</tr>
</tbody>
</table>

Configure DNS SRV Records

Before you begin

Review your SRV record requirements in the Service Discovery chapter of the Planning Guide for Cisco Jabber.

Procedure

Create the SRV records for your deployment:
<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>_cisco-uds</td>
<td>Provides the location of Cisco Unified Communications Manager 9.0 and later. The client can retrieve service profiles from Cisco Unified Communications Manager to determine the authenticator.</td>
</tr>
<tr>
<td>_collab-edge</td>
<td>Provides the location of Cisco VCS Expressway or Cisco Expressway-E. The client can retrieve service profiles from Cisco Unified Communications Manager to determine the authenticator.</td>
</tr>
</tbody>
</table>

**Example of an SRV record**

`_cisco-uds._tcp.DOMAIN service location:␤priority = 0␤weight = 0␤port = 8443␤svr hostname=192.168.0.26`

**What to do next**

Test SRV Records, on page 78

---

**Test SRV Records**

After creating your SRV records test to see if they are accessible.

**Procedure**

1. **Step 1** Open a command prompt.
2. **Step 2** Enter `nslookup`. The default DNS server and address is displayed. Confirm that this is the expected DNS server.
3. **Step 3** Enter `set type=SRV`.
4. **Step 4** Enter the name for each of your SRV records.
   
   For example, `_cisco-uds.exampledomain`
   
   - Displays server and address—SRV record is accessible.
   - Displays `_cisco-uds.exampledomain: Non-existent domain`—There is an issue with your SRV record.
Customizations

Windows Customizations

Installer Switches: Cisco Jabber for Windows

When you install Cisco Jabber, you can specify the authenticator and server addresses. The installer saves these details to a bootstrap file. When users launch the client for the first time, it reads the bootstrap file. The bootstrap file takes priority if service discovery is deployed.

Bootstrap files provide a fallback mechanism for service discovery in situations where service discovery has not been deployed and where you do not want users to manually specify their connection settings.

The client only reads the bootstrap file on the initial launch. After the initial launch, the client caches the server addresses and configuration, and then loads from the cache on subsequent launches.

We recommend that you do not use a bootstrap file, and instead use service discovery, in on-premises deployments with Cisco Unified Communications Manager release 9.x and later.

Bootstrap Settings for On-Premises Deployments

The following table lists the argument values for various deployment types.

<table>
<thead>
<tr>
<th>Product Mode</th>
<th>Server Releases</th>
<th>Argument Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full UC (Default Mode)</td>
<td>Release 9 and later:</td>
<td>Use the following installer switches and values:</td>
</tr>
<tr>
<td></td>
<td>• Cisco Unified Communications Manager</td>
<td>• AUTHENTICATOR=CUP</td>
</tr>
<tr>
<td></td>
<td>• Cisco Unified Communications Manager IM and Presence Service</td>
<td>• CUP_ADDRESS= &lt;presence_server_address&gt;</td>
</tr>
<tr>
<td>IM Only (Default Mode)</td>
<td>Release 9 and later:</td>
<td>Use the following installer switches and values:</td>
</tr>
<tr>
<td></td>
<td>• Cisco Unified Communications Manager IM and Presence Service</td>
<td>• AUTHENTICATOR=CUP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• CUP_ADDRESS= &lt;presence_server_address&gt;</td>
</tr>
</tbody>
</table>

The following diagram illustrates how the client uses bootstrap settings in on-premises deployments:
When users start the client for the first time, the following occurs:

1. The client retrieves settings from the bootstrap file.
   The client starts in default mode and determines that Cisco Unified Communications Manager IM and Presence Service is the authenticator. The client also gets the address of the presence server, unless Service Discovery results dictate otherwise.

2. The client authenticates to Cisco Unified Communications Manager IM and Presence Service.

3. The client retrieves service profiles from the presence server.

**Bootstrap Settings for On-Premises Deployments in Phone Mode**

During installation, you set values for arguments as follows:

- Set `CUCM` as the value for `AUTHENTICATOR`.
- Set `phone_mode` as the value for `PRODUCT_MODE`.
- Set the TFTP server address as the value for `TFTP`.
- Set the CTI server address as the value for `CTI`.
- Set the CCMCIP server address as the value for `CCMCIP`.

Cisco Unified Communications Manager release 9.x and earlier—If you enable Cisco Extension Mobility, the Cisco Extension Mobility service must be activated on the Cisco Unified Communications Manager nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the Feature and Services guide for your Cisco Unified Communications Manager release.
The following diagram illustrates how the client uses bootstrap settings in phone mode deployments:

When users start the client for the first time, the following process occurs:

1. The client retrieves settings from the bootstrap file.
   The client starts in phone mode and determines that Cisco Unified Communications Manager is the authenticator. The client also gets the addresses for the TFTP server (and CTI servers for Jabber for Windows and Jabber for Mac), unless Service Discovery results dictate otherwise.

2. The client authenticates to Cisco Unified Communications Manager and gets configuration.

3. The client retrieves device and client configuration.

### Mac and Mobile Customizations

#### Configuration URL Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Configuration URL, on page 82</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Provide Users with Configuration URL from a Website, on page 84</td>
<td></td>
</tr>
</tbody>
</table>
**Configuration URL**

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

Include the following parameters in the URL:

- **ServicesDomain**—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.

- **VoiceServiceDomain**—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.

- **ServiceDiscoveryExcludedServices**—Optional. You can exclude any of the following services from the service discovery process:
  - **Webex**—When you set this value, the client:
    - Does not perform CAS lookup
    - Looks for:
      - _cisco-uds
      - _cuplogin
      - _collab-edge
  
  - **CUCM**—When you set this value, the client:
    - Does not look for _cisco-uds
    - Looks for:
      - _cuplogin
      - _collab-edge
  
  - **CUP**—When you set this value, the client:
    - Does not look for _cuplogin
    - Looks for:
      - _cisco-uds
      - _collab-edge

You can specify multiple, comma-separated values to exclude multiple services.

If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

- **ServicesDomainSsoEmailPrompt**—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
• ON
• OFF

• EnablePRTEncryption—Optional. Specifies that the PRT file is encrypted. Applies to Cisco Jabber for Mac.
  • true
  • false

• PRTCertificateName—Optional. Specifies the name of the certificate. Applies to Cisco Jabber for Mac.

• InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
  • RejectAndNotify—A warning dialog displays and the client doesn't load.
  • PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.

• PRTCertificateUrl—Specifies the name of a certificate with a public key in the trusted root certificate store. Applies to Cisco Jabber mobile clients.

• Telephony_Enabled—Specifies whether the user has phone capability or not. The default is true.
  • True
  • False

• ForceLaunchBrowser—Used to force user to use the external browser. Applies to Cisco Jabber mobile clients.
  • True
  • False

  **Note**  ForceLaunchBrowser is used for client certificate deployments and for devices with Android OS below 5.0.

• IP_Mode—Specifies the network IP protocol for the Jabber client.
  • IPv4-Only—Jabber will only attempt to make IPv4 connections.
  • IPv6-Only—Jabber will only attempt to make IPv6 connections.
  • Two Stacks (Default)—Jabber can connect with either IPv4 or IPv6.

Create the configuration URL in the following format:

ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>
The parameters are case sensitive. When you create the configuration URL, you must use the following capitalization:

- ServicesDomain
- VoiceServicesDomain
- ServiceDiscoveryExcludedServices
- ServicesDomainSsoEmailPrompt
- EnablePRTEncryption
- PRTCertificateURL
- PRTCertificateName
- InvalidCertificateBehavior
- Telephony_Enabled
- ForceLaunchBrowser
- IP_Mode

Examples

- `ciscojabber://provision?ServicesDomain=cisco.com`
- `ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com`
- `ciscojabber://provision?ServicesDomain=service_domain&VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX`
- `ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP`
- `ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP&ServicesDomainSsoEmailPrompt=OFF`

Provide Users with Configuration URL from a Website

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

Note

Due to a limitation of the Android operating system, Cisco Jabber for Android users can encounter an issue if they open the configuration URL directly from an Android application. To work around this issue, we recommend that you distribute your configuration URL link using a website.

If you want to use the website explore option for URL provisioning, we recommended you to use Mozilla Firefox.

Use the following procedure to distribute the link from a website.
Procedure

**Step 1**
Create an internal web page that includes the configuration URL as an HTML hyperlink.

**Step 2**
Email the link to the internal web page to users.

In the email message, instruct users to perform the following steps:

1. Install the client.
2. Click the link in the email message to open the internal web page.
3. Click the link on the internal web page to configure the client.

---

### Mobile Configuration Using Enterprise Mobility Management

You can configure Cisco Jabber using Enterprise Mobility Management (EMM) on Cisco Jabber for Android and Cisco Jabber for iPhone and iPad. For more information on setting up EMM, refer to the instructions for administrators provided by the EMM provider.

If you want Jabber to run only on managed devices, then you can deploy certificate-based authentication, and enroll the client certificate through EMM.

For more information about how to deploy EMM, see the section on *Deploy Cisco Jabber Applications* in the *On-Premises Deployment for Cisco Jabber* or in the *Cloud and Hybrid Deployments for Cisco Jabber*.

#### FIPS_MODE Parameter

Use this parameter to enable or disable FIPS mode on Cisco Jabber mobile clients using EMM.

- **true**—Runs Cisco Jabber in FIPS mode.
- **false**—Does not run Cisco Jabber in FIPS mode.

**Example:**

```xml
<FIPS_MODE>false</FIPS_MODE>
```

#### AllowUrlProvisioning Parameter

Use this parameter when migrating users from URL configuration to EMM.

The following values apply to this parameter:

- **true** (default)—Bootstrap configuration is performed using URL configuration
- **false**—Bootstrap configuration is not performed using URL configuration

**Example:**

```xml
<AllowURLProvisioning>false</AllowURLProvisioning>
```

### Manual Connection Settings

Manual connection settings provide a fallback mechanism when Service Discovery is not used.
When you start Cisco Jabber, you can specify the authenticator and server address in the **Advanced settings** window. The client caches the server address to the local application configuration that loads on subsequent starts.

Cisco Jabber prompts users to enter these advanced settings on the initial start as follows:

- **On-Premises with Cisco Unified Communications Manager release 9.x and Later** — If the client cannot get the authenticator and server addresses from the service profile.

Settings that you enter in the **Advanced settings** window take priority over any other sources including SRV records and bootstrap settings.

If you select **Cisco IM & Presence**, the client retrieves UC services from Cisco Unified Communications Manager IM and Presence Service. The client does not use service profiles or SSO discovery.

**Note**

For Cisco Jabber for Windows, service discovery stops after 20 seconds regardless of the number of servers the SRV record resolves to. During service discovery, once Cisco Jabber finds `_cisco-uds`, it attempts to connect to the first 2 servers within 20 seconds. Cisco Jabber doesn't attempt to connect to any servers after it's attempted service discovery for the highest 2 priority servers.

Users can manually point to the working server or re-order SRV priorities to at least one of the top two priority servers available for service discovery.

### Automatic Connection Setting for Service Discovery

Users can select the **Automatic** option in the **Advanced settings** window to discover servers automatically. The Automatic option allows users change from manually setting the service connection details to using service discovery. For example, on the initial launch, you manually set the authenticator and specify a server address in the **Advanced settings** window.

The client always checks the cache for manual settings. The manual settings take higher priority over SRV records, and for Cisco Jabber for Windows, the bootstrap file. For this reason, if you decide to deploy SRV records and use service discovery, you override the manual settings from the initial launch.

### Manual Connection Settings for On-Premises Deployments

Users can set Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service as the authenticator and specify the server address in the **Advanced settings** window.

**Remember**

You can automatically set the default server address with the `_cuplogin` SRV record.

The following diagram illustrates how the client uses manual connection settings in on-premises deployments:
1. Users manually enter connection settings in the **Advanced settings** window.

2. The client authenticates to Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service.

3. The client retrieves service profiles from the presence server.

**Manual Connection Settings for On-Premises Deployments in Phone Mode**

Users can set Cisco Unified Communications Manager as the authenticator and specify the following server addresses in the **Advanced settings** window:

- TFTP server
- CCMCIP server
- CTI server (Cisco Jabber for Windows and Cisco Jabber for Mac)

The following diagram illustrates how the client uses manual connection settings in phone mode deployments:
1. Users manually enter connection settings in the **Advanced settings** window.

2. The client authenticates to Cisco Unified Communications Manager and gets configuration.

3. The client retrieves device and client configuration.
Configure Certificate Validation

- Configure Certificates for an On-Premises Deployment, on page 89

Configure Certificates for an On-Premises Deployment

Certificates are required for each service to which the Jabber clients connect.

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>If you have Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service, download the applicable HTTP (tomcat) and XMPP certificates. For more information, see the Security Configuration on IM and Presence Service chapter in Configuration and Administration of IM and Presence Service on Cisco Unified Communications Manager.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Download the HTTPS (tomcat) certificate for Cisco Unified Communications Manager and Cisco Unity Connection. For more information, see the Cisco Unified Communications Manager Security Guide and Download the HTTPS (tomcat) certificate for Cisco Unified Communications Manager and Cisco Unity Connection.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Download the HTTP (tomcat) for Cisco Webex Meetings Server. For more information, see the Cisco Cisco Webex Meetings Server Administration Guide found here.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>If you plan to configure remote access, download the Cisco VCS Expressway and Cisco Expressway-E Server certificate. The Server certificate is used for both HTTP and XMPP. For more information, see Configuring Certificates on Cisco VCS Expressway.</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>Generate a Certificate Signing Request (CSR).</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>Upload the certificate to the service. If you use a multiserver SAN, you only need to upload a certificate to the service once per cluster per tomcat certificate and once per cluster per XMPP certificate. If you do not use a multiserver SAN, then you must upload the</td>
</tr>
</tbody>
</table>
### Deploy CA Certificates to Clients

To ensure that certificate validation occurs without users receiving a prompt to accept or decline certificates, deploy certificates to the local certificate store of the endpoint clients.

If you use a well-known public CA, then the CA certificate may already exist on the client certificate store or keychain. If so, you need not deploy CA certificates to the clients.

If the CA certificate is not already on the client certificate store or keychain, then deploy the CA certificate to the clients.

#### If your deployment size is

<table>
<thead>
<tr>
<th>If your deployment size is</th>
<th>Then we recommend</th>
</tr>
</thead>
<tbody>
<tr>
<td>To a large number of local machines</td>
<td>That you use a certificate deployment tool, such as Group Policy or a certificate deployment management application.</td>
</tr>
<tr>
<td>To a smaller number of local machines</td>
<td>That you manually deploy the CA certificates.</td>
</tr>
</tbody>
</table>

### Manually Deploy CA Certificates to Cisco Jabber for Windows Clients

#### Procedure

**Step 1**  
Make the CA certificate available to the Cisco Jabber for Windows client machine.

**Step 2**  
From the Windows machine, open the certificate file.

**Step 3**  
Install the certificate and then select **Next**.

**Step 4**  
Select **Place all certificates in the following store**, then select **Browse**.

**Step 5**  
Select the Trusted Root Certification Authorities store.  
When you finish the wizard, a message is displayed to verify successful certificate import.

### What to do next

Verify that the certificate is installed in the correct certificate store by opening the Windows Certificate Manager tool. Browse to **Trusted Root Certification Authorities > Certificates**. The CA root certificate is listed in the certificate store.
Manually Deploy CA Certificates to Cisco Jabber for Mac Clients

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Make the CA certificate available to the Cisco Jabber for Mac client machine.</td>
</tr>
<tr>
<td>2</td>
<td>From the Mac machine, open the certificate file.</td>
</tr>
<tr>
<td>3</td>
<td>Add to the login keychain for the current user only, then select <strong>Add</strong>.</td>
</tr>
</tbody>
</table>

**What to do next**

Verify that the certificate is installed in the correct keychain by opening the Keychain Access Tool and selecting **Certificates**. The CA root certificate is listed in the keychain.

Manually Deploy CA Certificates to Mobile Clients

To deploy the CA certificates to an iOS client, you need a certificate deployment management application. You can email the CA certificate to users, or make the certificates available on a web server for users to access. Users can download and install the certificate using the certificate deployment management tool.

However, Jabber for Android does not have a certificate management tool, you must use the following procedure.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Download the CA certificate to the device.</td>
</tr>
<tr>
<td>2</td>
<td>Tap the device <strong>Settings &gt; Security &gt; Install from device storage</strong> and follow the instructions.</td>
</tr>
</tbody>
</table>
Manually Deploy CA Certificates to Mobile Clients
CHAPTER 15

Configure the Clients

- Client Configuration Workflow, on page 93

Client Configuration Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Introduction to Client Configuration, on page 93</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Create and Host Client Configuration Files Using an XML Editor, on page 94</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Set Parameters on Phone Configuration for Desktop Clients, on page 98</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Set Parameters on Phone Configuration for Mobile Clients, on page 100</td>
<td></td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure Proxy Setting, on page 100</td>
<td></td>
</tr>
</tbody>
</table>

Introduction to Client Configuration

Cisco Jabber can retrieve configuration settings from the following sources:

- Service Profiles—You can configure some client settings in UC service profiles on Cisco Unified Communications Manager release 9 and later. When users launch the client, it discovers the Cisco Unified Communications Manager home cluster using a DNS SRV record and automatically retrieves the configuration from the UC service profile.
  
  Applies to on-premises deployments only.

- Phone Configuration—You can set some client settings in the phone configuration on Cisco Unified Communications Manager release 9 and later. The client retrieves the settings from the phone configuration in addition to the configuration in the UC service profile.
  
  Applies to on-premises deployments only.
• Cisco Unified Communications Manager IM and Presence Service—You can enable instant messaging and presence capabilities and configure certain settings such as presence subscription requests.

In the Advanced settings window, if you select Cisco IM & Presence, the client retrieves UC services from Cisco Unified Communications Manager IM and Presence Service. The client does not use service profiles or SSO discovery.

Applies to on-premises deployments only.

• Client Configuration Files—You can create XML files that contain configuration parameters. You then host the XML files on a TFTP server. When users sign in, the client retrieves the XML file from the TFTP server and applies the configuration.

Applies to on-premises and cloud-based deployments.

• Cisco Webex Administration Tool—You can configure some client settings with the Cisco Webex Administration Tool.

You can upload a jabber-config.xml client configuration file into the Cisco Webex Administration Tool. You can apply separate configuration files for groups in the Cisco Webex Messenger Administration Tool. When the client successfully connects to Cisco Webex Messenger it downloads the XML file and the configuration is applied.

The client will use the following order for configuration settings:

1. Settings in Cisco Webex Messenger Administration Tool
2. Settings in jabber-config.xml file from Cisco Webex Messenger Administration Tool.

Note: Group configuration file settings take priority over the configuration file in Cisco Webex Messenger Administration Tool.

3. Settings in jabber-config.xml file from the TFTP server.

If there are any conflicts with configuration settings, the settings set in Cisco Webex Administration tool will take priority over this configuration file.

Applies to cloud-based deployments only.

Create and Host Client Configuration Files Using an XML Editor

For on-premises and hybrid cloud-based deployments, create client configuration files and host them on the Cisco Unified Communications Manager TFTP service.

For cloud-based deployments, configure the client with the Cisco Webex Administration Tool. However, you can optionally set up a TFTP server to configure the client with settings that are not available in Cisco Webex Administration Tool.

For Cisco Jabber for iPhone and iPad and Cisco Jabber for Android, you must create a global configuration file to set up:

• Directory integration for on-premises deployments.
• Voicemail service credentials for hybrid-cloud deployments.
In most environments, Cisco Jabber for Windows and Cisco Jabber for Mac do not require any configuration to connect to services. Create a configuration file only if you require custom content such as automatic updates, problem reporting, or user policies and options.

**Before you begin**

Note the following configuration file requirements:

- Configuration filenames are case-sensitive. Use lowercase letters in the filename to prevent errors and to ensure the client can retrieve the file from the TFTP server.

- You must use utf-8 encoding for the configuration files.

- The client cannot read configuration files that do not have a valid XML structure. Check the structure of your configuration file for closing elements and confirm that elements are nested correctly.

- Valid XML character entity references only are permitted in your configuration file. For example, use `&amp;` instead of `&`. If your XML contains invalid characters, the client cannot parse the configuration file.

To validate your configuration file, open the file in Microsoft Internet Explorer.

- If Internet Explorer displays the entire XML structure, your configuration file does is valid.

- If Internet Explorer displays only part of the XML structure, it is likely that your configuration file contains invalid characters or entities.

## Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Specify Your TFTP Server Address, on page 95</td>
<td>Specify your TFTP server address for client to enable access to your configuration file.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Create Global Configurations, on page 96</td>
<td>Configure the clients for users in your deployment.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Create Group Configurations, on page 96</td>
<td>Apply different configuration to different set of users.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Host Configuration Files, on page 97</td>
<td>Host configuration files on any TFTP server.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Restart Your TFTP Server, on page 98</td>
<td>Restart the TFTP server before the client can access the configuration files.</td>
</tr>
</tbody>
</table>

### Specify Your TFTP Server Address

The client gets configuration files from a TFTP server. The first step in configuring the client is to specify your TFTP server address so the client can access your configuration file.
Attention  If Cisco Jabber gets the _cisco-uds SRV record from a DNS query, it can automatically locate the user's home cluster. As a result, the client can also locate the Cisco Unified Communications Manager TFTP service. You do not need to specify your TFTP server address if you deploy the _cisco-uds SRV record.

Specify TFTP Servers in Phone Mode

If you deploy the client in phone mode you can provide the address of the TFTP server as follows:

- Users manually enter the TFTP server address when they start the client.
- You specify the TFTP server address during installation with the TFTP argument.
- You specify the TFTP server address in the Microsoft Windows registry.

Create Global Configurations

The client downloads the global configuration file from your TFTP server during the login sequence. Configure the client for all users in your deployment.

Before you begin

If the structure of your configuration file is not valid, the client cannot read the values you set. Review the XML samples in this chapter for more information.

Procedure

Step 1  Create a file named jabber-config.xml with any text editor.

- Use lowercase letters in the filename.
- Use UTF-8 encoding.

Step 2  Define the required configuration parameters in jabber-config.xml.

Step 3  Host the group configuration file on your TFTP server.

If your environment has multiple TFTP servers, ensure that the configuration file is the same on all TFTP servers.

Create Group Configurations

Group configuration files apply to subsets of users and are supported on Cisco Jabber for desktop (CSF devices) and on Cisco Jabber for mobile devices. Group configuration files take priority over global configuration files.

If you provision users with CSF devices, specify the group configuration filenames in the Cisco Support Field field on the device configuration. If users do not have CSF devices, set a unique configuration filename for each group during installation with the TFTP_FILE_NAME argument.
Before you begin

- If the structure of your configuration file is not valid, the client cannot read the values you set. Review the XML samples in this chapter for more information.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Create an XML group configuration file with any text editor. The group configuration file can have any appropriate name; for example, <code>jabber-groupa-config.xml</code>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Define the required configuration parameters in the group configuration file.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Add the group configuration file to applicable CSF devices.</td>
</tr>
<tr>
<td></td>
<td>a) Open the Cisco Unified CM Administration interface.</td>
</tr>
<tr>
<td></td>
<td>b) Select Device &gt; Phone.</td>
</tr>
<tr>
<td></td>
<td>c) Find and select the appropriate CSF device to which the group configuration applies.</td>
</tr>
<tr>
<td></td>
<td>d) In the Phone Configuration window, navigate to Product Specific Configuration Layout &gt; Desktop Client Settings.</td>
</tr>
<tr>
<td></td>
<td>e) In the Cisco Support Field field, enter <code>configurationfile=group_configuration_file_name.xml</code>. For example, enter <code>configurationfile=groupa-config.xml</code>.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If you host the group configuration file on your TFTP server in a location other than the default directory, you must specify the path and the filename; for example, <code>configurationfile=/customFolder/groupa-config.xml</code>.</td>
</tr>
<tr>
<td></td>
<td>Do not add more than one group configuration file. The client uses only the first group configuration in the Cisco Support Field field.</td>
</tr>
<tr>
<td></td>
<td>f) Select Save.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Host the group configuration file on your TFTP server.</td>
</tr>
</tbody>
</table>

Host Configuration Files

You can host configuration files on any TFTP server. However, Cisco recommends hosting configuration files on the Cisco Unified Communications Manager TFTP server, which is the same as that where the device configuration file resides.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Open the Cisco Unified OS Administration interface on Cisco Unified Communications Manager.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select Software Upgrades &gt; TFTP File Management.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Select Upload File.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select Browse in the Upload File section.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Select the configuration file on the file system.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Do not specify a value in the Directory text box in the Upload File section.</td>
</tr>
</tbody>
</table>
You should leave an empty value in the Directory text box so that the configuration file resides in the default directory of the TFTP server.

**Step 7** Select Upload File.

---

**Restart Your TFTP Server**

You must restart your TFTP server before the client can access the configuration files.

**Procedure**

**Step 1** Open the Cisco Unified Serviceability interface on Cisco Unified Communications Manager.

**Step 2** Select Tools > Control Center - Feature Services.

**Step 3** Select Cisco Tftp from the CM Services section.

**Step 4** Select Restart.

A window displays to prompt you to confirm the restart.

**Step 5** Select OK.

The Cisco Tftp Service Restart Operation was Successful status displays.

**Step 6** Select Refresh to ensure the Cisco Tftp service starts successfully.

---

**What to do next**

To verify that the configuration file is available on your TFTP server, open the configuration file in any browser. Typically, you can access the global configuration file at the following URL:

http://tftp_server_address:6970/jabber-config.xml

---

**Configuration File**

For detailed information on the jabber-config.xml configuration file structure, group elements, parameters, and examples, see the Parameters Reference Guide for Cisco Jabber.

---

**Set Parameters on Phone Configuration for Desktop Clients**

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco Unified Communications Manager:

**Enterprise Phone Configuration**

Applies to the entire cluster.

---

**Note**

For users with only IM and Presence Service capabilities (IM only), you must set phone configuration parameters in the Enterprise Phone Configuration window.
Common Phone Profile Configuration

Applies to groups of devices and takes priority over the cluster configuration.

Cisco Unified Client Services Framework (CSF) Phone Configuration

Applies to individual CSF devices and takes priority over the group configuration.

Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the **Product Specific Configuration Layout** section of the phone configuration and maps corresponding parameters from the client configuration file:

<table>
<thead>
<tr>
<th>Desktop Client Settings Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video Calling</td>
<td>Enables or disables video capabilities.</td>
</tr>
<tr>
<td></td>
<td><strong>Enabled (default)</strong></td>
</tr>
<tr>
<td></td>
<td>Users can send and receive video calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Disabled</strong></td>
</tr>
<tr>
<td></td>
<td>Users cannot send or receive video calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Restriction</strong> This parameter is available only on the CSF device configuration.</td>
</tr>
<tr>
<td>File Types to Block in File Transfer</td>
<td>Restricts users from transferring specific file types.</td>
</tr>
<tr>
<td></td>
<td>Set a file extension as the value, for example, .exe.</td>
</tr>
<tr>
<td></td>
<td>Use a semicolon to delimit multiple values, for example, .exe;.msi;.rar;.zip</td>
</tr>
<tr>
<td>Automatically Start in Phone Control</td>
<td>Sets the phone type for users when the client starts for the first time.</td>
</tr>
<tr>
<td></td>
<td>Users can change their phone type after the initial start. The client then</td>
</tr>
<tr>
<td></td>
<td>saves the user preference and uses it for subsequent starts.</td>
</tr>
<tr>
<td></td>
<td><strong>Enabled</strong></td>
</tr>
<tr>
<td></td>
<td>Use the desk phone device for calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Disabled (default)</strong></td>
</tr>
<tr>
<td></td>
<td>Use the software phone (CSF) device for calls.</td>
</tr>
<tr>
<td>Jabber For Windows Software Update</td>
<td>Specifies the URL to the XML file that holds client update information.</td>
</tr>
<tr>
<td>Server URL</td>
<td>The client uses this URL to retrieve the XML file from your web server.</td>
</tr>
<tr>
<td></td>
<td>In hybrid cloud-based deployments, you should use the Cisco Webex</td>
</tr>
<tr>
<td></td>
<td>Administration Tool to configure automatic updates.</td>
</tr>
<tr>
<td>Problem Report Server URL</td>
<td>Specifies the URL for the custom script that allows users to submit problem reports.</td>
</tr>
</tbody>
</table>
Set Parameters on Phone Configuration for Mobile Clients

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco Unified Communications Manager:

- Cisco Dual Mode for iPhone (TCT) Configuration — Applies to individual TCT devices and takes priority over the group configuration.
- Cisco Jabber for Tablet (TAB) Configuration — Applies to individual TAB devices and takes priority over the group configuration.

Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the Product Specific Configuration Layout section of the phone configuration and maps corresponding parameters from the client configuration file:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On-Demand VPN URL</td>
<td>URL for initiating on-demand VPN.</td>
</tr>
<tr>
<td>Note</td>
<td>Applicable for iOS only.</td>
</tr>
<tr>
<td>Preset Wi-fi Networks</td>
<td>Enter the SSIDs for Wi-Fi networks (SSIDs) approved by your organization. Separate SSIDs with a forward slash (/). Devices do not connect to secure connect if connected to one of the entered Wi-Fi networks.</td>
</tr>
<tr>
<td>Default Ringtone</td>
<td>Sets the default ringtone to Normal or Loud.</td>
</tr>
<tr>
<td>Video Capabilities</td>
<td>Enables or disables video capabilities.</td>
</tr>
<tr>
<td>Note</td>
<td>TCT and BOT devices only.</td>
</tr>
<tr>
<td></td>
<td>• Enabled (default) — Users can send and receive video calls.</td>
</tr>
<tr>
<td></td>
<td>• Disabled — Users cannot send or receive video calls.</td>
</tr>
<tr>
<td>Dial via Office</td>
<td>Enables or disables Dial via Office.</td>
</tr>
<tr>
<td>Note</td>
<td>TCT and BOT devices only.</td>
</tr>
<tr>
<td></td>
<td>• Enabled — Users can dial via office.</td>
</tr>
<tr>
<td></td>
<td>• Disabled (default) — Users cannot dial via office.</td>
</tr>
</tbody>
</table>

Configure Proxy Setting

The client uses proxy settings to connect to services.

The following limitations apply when using a proxy for these HTTP requests:

- Proxy Authentication is not supported.
- Wildcards in the bypass list are supported.
- Cisco Jabber supports proxy for HTTP request using HTTP CONNECT, but does not support proxy when using HTTPS CONNECT.
Configure Proxy Settings for Cisco Jabber for Windows

Configure proxy settings for Windows in the Local Area Network (LAN) settings for Internet properties.

Procedure

Step 1  In the **Connections** tab select **LAN Settings**.
Step 2  Configure a proxy using one of the following options:

- For automatic configuration, specify a .pac file URL.
- For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Mac

Configure proxy settings for Mac in **System Preferences**.

Procedure

Step 1  Select **System Preferences > Network**
Step 2  Choose your network service from the list and select **Advanced > Proxies**
Step 3  Configure a proxy using one of the following options:

- For automatic configuration, specify a .pac file URL.
- For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber iPhone and iPad

Configure proxy settings in the Wi-Fi settings of an iOS device using one of the following methods:

Procedure

Step 1  Select **Wi-Fi > HTTP PROXY > Auto** and specify a .pac file URL as the automatic configuration script.
Step 2  Select **Wi-Fi > HTTP PROXY > Manual** and specify an explicit proxy address.
Configure Proxy Settings for Cisco Jabber for Android

Procedure

Configure proxy settings in the Wi-Fi settings of an Android device using one of the following methods:

- Specify a .pac file URL as the automatic configuration script in the Wi-Fi > Modify Network > Show Advanced Options > Proxy Settings > Auto tab.

  Note This method is only supported on devices with Android OS 5.0 and later, and Cisco DX series devices.

- Specify an explicit proxy address in the Wi-Fi Networks > Modify Network > Show Advanced Options > Proxy Settings > Auto tab.
CHAPTER 16

Deploy Cisco Jabber Applications and Jabber Softphone for VDI

- Download the Cisco Jabber Clients, on page 103
- Install Cisco Jabber for Windows, on page 103
- Install Cisco Jabber for Mac, on page 131
- Install Cisco Jabber Mobile Clients, on page 137

Download the Cisco Jabber Clients

If required, you can add your own Customer signature to the Jabber Installer or Cisco Dynamic Libraries by using the signing tools from the Operating System for that client.

**Note**

For Cisco Jabber for Mac, the installer includes the product installer file. Use the Terminal tool to extract the pkg file from the installer and sign the pkg file before adding to the installer.

**Procedure**

- Visit the [Cisco Software Center](#) to download the Cisco Jabber for Mac and Cisco Jabber for Windows clients.
- For Cisco Jabber for Android, download the app from Google Play.
- For Cisco Jabber for iPhone and iPad, download the app from the App store.

**Related Topics**

- Download software

Install Cisco Jabber for Windows

Cisco Jabber for Windows provides an MSI installation package that you can use in the following ways:
Use the Command Line

Specify installation arguments in a command line window.

Procedure

| Step 1 | Open a command line window. |
| Step 2 | Enter the following command: |
|        | msiexec.exe /i CiscoJabberSetup.msi |
| Step 3 | Specify command line arguments as parameter=value pairs. |
|        | msiexec.exe /i CiscoJabberSetup.msi argument=value |
| Step 4 | Run the command to install Cisco Jabber for Windows. |

Example Installation Commands

Review examples of commands to install Cisco Jabber for Windows.
Cisco Unified Communications Manager, Release 9.x

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1

Where:

CLEAR=1 — Deletes any existing bootstrap file.
/quiet — Specifies a silent installation.

Related Topics

Related Topics

Command Line Arguments, on page 105
LCID for Languages, on page 120

Command Line Arguments

Review the command line arguments you can specify when you install Cisco Jabber for Windows.

Related Topics

Example Installation Commands, on page 104
LCID for Languages, on page 120

Override Argument

The following table describes the parameter you must specify to override any existing bootstrap files from previous installations:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLEAR</td>
<td>1</td>
<td>Specifies if the client overrides any existing bootstrap file from previous installations. The client saves the arguments and values you set during installation to a bootstrap file. The client then loads settings from the bootstrap file at startup.</td>
</tr>
</tbody>
</table>

If you specify CLEAR, the following occurs during installation:

1. The client deletes any existing bootstrap file.
2. The client creates a new bootstrap file.

If you do not specify CLEAR, the client checks for existing bootstrap files during installation.

• If no bootstrap file exists, the client creates a bootstrap file during installation.
• If a bootstrap file exists, the client does not override that bootstrap file and preserves the existing settings.

Note

If you are reinstalling Cisco Jabber for Windows, you should consider the following:

• The client does not preserve settings from existing bootstrap files. If you specify CLEAR, you must also specify all other installation arguments as appropriate.
• The client does not save your installation arguments to an existing bootstrap file. If you want to change the values for installation arguments, or specify additional installation arguments, you must specify CLEAR to override the existing settings.
To override existing bootstrap files, specify CLEAR in the command line as follows:

```
msiexec.exe /i CiscoJabberSetup.msi CLEAR=1
```

### Mode Type Argument

The following table describes the command line argument with which you specify the product mode:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODUCT_MODE</td>
<td>Phone_Mode</td>
<td>Specifies the product mode for the client. You can set the following value:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Phone_Mode — Cisco Unified Communications Manager is the authenticator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Choose this value to provision users with audio devices as base functionality.</td>
</tr>
</tbody>
</table>

### When to Set the Product Mode

In phone mode deployments Cisco Unified Communications Manager is the authenticator. When the client gets the authenticator, it determines the product mode is phone mode. However, because the client always starts in the default product mode on the initial launch, users must restart the client to enter phone mode after sign in.

- Cisco Unified Communications Manager, Release 9.x and Later — You should not set PRODUCT_MODE during installation. The client gets the authenticator from the service profile. After the user signs in, the client requires a restart to enter phone mode.

### Change Product Modes

To change the product mode, you must change the authenticator for the client. The client can then determine the product mode from the authenticator.

The method for changing from one product mode to another after installation, depends on your deployment.

#### Procedure

**Step 1** Change the authenticator in the service profiles for the appropriate users.
Change Default Mode > Phone Mode
Do not provision users with an IM and Presence service.
If the service profile does not contain an IM and presence service configuration, the authenticator is Cisco Unified Communications Manager.

Change Phone Mode > Default Mode
Provision users with an IM and Presence service.
If you set the value of the Product type field in the IM and Presence profile to:

- **Unified CM (IM and Presence)** the authenticator is Cisco Unified Communications Manager IM and Presence Service.
- **Webex (IM and Presence)** the authenticator is the Cisco Webex Messenger service.

**Step 2**
Instruct users to sign out and then sign in again.
When users sign in to the client, it retrieves the changes in the service profile and signs the user in to the authenticator. The client then determines the product mode and prompts the user to restart the client.

After the user restarts the client, the product mode change is complete.

**Authentication Arguments**

The following table describe the command line arguments you can set to specify the source of authentication:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTHENTICATOR</td>
<td>CUP</td>
<td>Specifies the source of authentication for the client. This value is used if Service Discovery fails. Set one of the following as the value:</td>
</tr>
<tr>
<td></td>
<td>CUCM</td>
<td>• CUP—Cisco Unified Communications Manager IM and Presence Service. On-premises deployments in the default product mode. The default product mode can be either full UC or IM only.</td>
</tr>
<tr>
<td></td>
<td>Webex</td>
<td>• CUCM—Cisco Unified Communications Manager. On-premises deployments in phone mode.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Webex—Cisco Webex Messenger Service. Cloud-based or hybrid cloud-based deployments.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In on-premises deployments with Cisco Unified Communications Manager version 9.x and later, you should deploy the _cisco-uds SRV record. The client can then automatically determine the authenticator.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CUP_ADDRESS</td>
<td>IP address</td>
<td>Specifies the address of Cisco Unified Communications Manager IM and Presence Service. Set one of the following as the value:</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>- Hostname <em>(hostname)</em></td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>- IP address <em>(123.45.254.1)</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- FQDN <em>(hostname.domain.com)</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td>You should specify this argument if you set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you deploy:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- In phone mode—you should specify the address of the TFTP server that hosts the client configuration.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- In default mode—you can specify the address of the Cisco Unified Communications Manager TFTP service that hosts the device configuration.</td>
</tr>
<tr>
<td>TFTP</td>
<td>IP address</td>
<td>Specifies the address of your TFTP server.</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>- Hostname <em>(hostname)</em></td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>- IP address <em>(123.45.254.1)</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- FQDN <em>(hostname.domain.com)</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td>You should specify this argument if you set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you deploy:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- In phone mode—you should specify the address of the TFTP server that hosts the client configuration.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- In default mode—you can specify the address of the Cisco Unified Communications Manager TFTP service that hosts the device configuration.</td>
</tr>
<tr>
<td>CTI</td>
<td>IP address</td>
<td>Sets the address of your CTI server.</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>Specify this argument if:</td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>- You set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Users have desk phone devices and require a CTI server.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CCMCIP</td>
<td>IP address</td>
<td>Sets the address of your CCMCIP server. Specify this argument if:</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>• You set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>• The address of your CCMCIP server is not the same as the TFTP server address.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The client can locate the CCMCIP server with the TFTP server address if both addresses are the same.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cisco Unified Communications Manager release 9.x and earlier—If you enable Cisco Extension Mobility, the Cisco Extension Mobility service must be activated on the Cisco Unified Communications Manager nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the Feature and Services guide for your Cisco Unified Communications Manager release.</td>
</tr>
<tr>
<td>SERVICES_DOMAIN</td>
<td>Domain</td>
<td>Sets the value of the domain where the DNS SRV records for Service Discovery reside. This argument can be set to a domain where no DNS SRV records reside if you want the client to use installer settings or manual configuration for this information. If this argument is not specified and Service Discovery fails, the user will be prompted for services domain information.</td>
</tr>
<tr>
<td>VOICE_SERVICES_DOMAIN</td>
<td>Domain</td>
<td>In Hybrid Deployments the domain required to discover Webex via CAS lookup may be a different domain than where the DNS records are deployed. If this is the case then set the SERVICES_DOMAIN to be the domain used for Webex discovery (or let the user enter an email address) and set the VOICE_SERVICES_DOMAIN to be the domain where DNS records are deployed. If this setting is specified, the client will use the value of VOICE_SERVICES_DOMAIN to lookup the following DNS records for the purposes of Service Discovery and Edge Detection: _cisco-uds _cuplogin _collab-edge This setting is optional and if not specified, the DNS records are queried on the Services Domain which is obtained from the SERVICES_DOMAIN, email address input by the user, or cached user configuration.</td>
</tr>
</tbody>
</table>
EXCLUDED_SERVICES

Lists the services that you want Jabber to exclude from Service Discovery. For example, you may have done a trial with Webex which means that your company domain is registered on Webex, but you do not want Jabber users to authenticate using Webex. You want Jabber to authenticate with CUCM server. In this case set:

- EXCLUDED_SERVICES=WEBEX
  Possible values are CUCM, Webex

If you exclude all services, you need to use manual configuration or bootstrap configuration to configure the Jabber client.

UPN_DISCOVERY_ENABLED

Allows you to define whether the client uses the User Principal Name (UPN) of a Windows session to get the User ID and domain for a user when discovering services.

- true (default)—The UPN is used to find the User ID and the domain of the user, which is used during service discovery. Only the user discovered from UPN can log in to the client.
- false—The UPN is not used to find the User ID and domain of the user. The user is prompted to enter credentials to find the domain for service discovery.

Example installation command:

```
msiexec.exe /i CiscoJabberSetup.msi /quiet
UPN_DISCOVERY_ENABLED=false
```

TFTP Server Address

Cisco Jabber for Windows retrieves two different configuration files from the TFTP server:

- Client configuration files that you create.
- Device configuration files that reside on the Cisco Unified Communications Manager TFTP service when you provision users with devices.

To minimize effort, you should host your client configuration files on the Cisco Unified Communications Manager TFTP service. You then have only one TFTP server address for all configuration files and can specify that address as required.

You can, however, host your client configuration on a different TFTP server to the one that contains the device configuration. In this case, you have two different TFTP server addresses, one address for the TFTP server that hosts device configuration and another address for the TFTP server that hosts client configuration files.
**Default Deployments**

This section describes how you should handle two different TFTP server addresses in deployments that have a presence server.

You should do the following:

1. Specify the address of the TFTP server that hosts the client configuration on the presence server.
2. During installation, specify the address of the Cisco Unified Communications Manager TFTP service with the TFTP argument.

When the client starts for the first time, it:

1. Retrieves the address of the Cisco Unified Communications Manager TFTP service from the bootstrap file.
2. Gets device configuration from the Cisco Unified Communications Manager TFTP service.
3. Connects to the presence server.
4. Retrieves the address of the TFTP service that hosts the client configuration from the presence server.
5. Gets client configuration from the TFTP server.

**Phone Mode Deployments**

This section describes how you should handle two different TFTP server addresses in phone mode deployments.

You should do the following:

1. During installation, specify the address of the TFTP server that hosts the client configuration with the TFTP argument.
2. Specify the address of the TFTP server that hosts the device configuration in your client configuration file with the following parameter: TftpServer1.
3. Host the client configuration file on the TFTP server.

When the client starts for the first time, it:

1. Retrieves the address of the TFTP server from the bootstrap file.
2. Gets client configuration from the TFTP server.
3. Retrieves the address of the Cisco Unified Communications Manager TFTP service from the client configuration.
4. Gets device configuration from the Cisco Unified Communications Manager TFTP service.

**Common Installation Arguments**

The following table describes command line arguments that are common to all deployments:
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| LANGUAGE               | LCID in decimal | Defines the Locale ID (LCID), in decimal, of the language that Cisco Jabber for Windows uses. The value must be an LCID in decimal that corresponds to a supported language. For example, you can specify one of the following:  
  - 1033 specifies English.  
  - 1036 specifies French.  
  See the LCID for Languages topic for a full list of the languages that you can specify.  
  This argument is optional. If you do not specify a value, Cisco Jabber for Windows uses the regional language for the current user as the default. From Release 11.1(1) onwards, if you do not specify a value, Cisco Jabber for Windows checks the value for the UseSystemLanguage parameter. If the UseSystemLanguage parameter is set to true, the same language is used as for the operating system. If the UseSystemLanguage parameter is set to false or not defined, then the client uses the regional language for the current user as the default. The regional language is set at Control Panel > Region and Language > Change the date, time, or number format > Formats tab > Format dropdown. |
| FORGOT_PASSWORD_URL   | URL            | Specifies the URL where users can reset lost or forgotten passwords.  
  This argument is optional but recommended.  
  **Note** In cloud-based deployments, you can specify a forgot password URL using the Cisco Webex Administration Tool. However, the client cannot retrieve that forgot password URL until users sign in. |
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOMATIC_SIGN_IN</td>
<td>true</td>
<td>Applies to Release 11.1(1) onwards.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td>Specifies whether the <strong>Sign me in when Cisco Jabber starts</strong> check box is checked when the user installs the client.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• true—The <strong>Sign me in when Cisco Jabber starts</strong> check box is checked when the user installs the client.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• false (default)—The <strong>Sign me in when Cisco Jabber starts</strong> check box is not checked when the user installs the client.</td>
</tr>
<tr>
<td>TFTP_FILE_NAME</td>
<td>Filename</td>
<td>Specifies the unique name of a group configuration file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify either an unqualified or fully qualified filename as the value. The filename you specify as the value for this argument takes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>priority over any other configuration file on your TFTP server.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This argument is optional.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Remember</strong> You can specify group configuration files in the <a href="#">Cisco Support Field</a> on the CSF device configuration on Cisco Unified Communications Manager.</td>
</tr>
</tbody>
</table>
## Common Installation Arguments

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| LOGIN_RESOURCE       | WBX    | Controls user sign in to multiple client instances. By default, users can sign into multiple instances of Cisco Jabber at the same time. Set one of the following values to change the default behavior:  
• WBX—Users can sign into one instance of Cisco Jabber for Windows at a time. Cisco Jabber for Windows appends the `wbxconnect` suffix to the user's JID. Users cannot sign into any other Cisco Jabber client that uses the `wbxconnect` suffix.  
• MUT—Users can sign into one instance of Cisco Jabber for Windows at a time, but can sign into other Cisco Jabber clients at the same time. Each instance of Cisco Jabber for Windows appends the user's JID with a unique suffix. |
<p>|                      | MUT    |                                                                                                                                             |
| LOG_DIRECTORY        | Absolute path on the local filesystem | Defines the directory where the client writes log files. Use quotation marks to escape space characters in the path, as in the following example: &quot;C:\my_directory\Log Directory&quot;. The path you specify must not contain Windows invalid characters. The default value is <code>%USERPROFILE%\AppData\Local\Cisco\Unified Communications\Jabber\CSF\Logs</code> |</p>
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLICK2X</td>
<td>DISABLE</td>
<td>Disables click-to-x functionality with Cisco Jabber. If you specify this argument during installation, the client does not register as a handler for click-to-x functionality with the operating system. This argument prevents the client from writing to the Microsoft Windows registry during installation. You must re-install the client and omit this argument to enable click-to-x functionality with the client after installation. <strong>Click2Call function in Browser</strong>—The Click2X parameter can now be configured by using the newly added Click2Call parameter. This enables only the Click to call feature in the browser and disables the Click2X feature.</td>
</tr>
<tr>
<td></td>
<td>Click2Call</td>
<td></td>
</tr>
<tr>
<td>ENABLE_PRT</td>
<td>true</td>
<td>• true (default)—The Report a problem menu item is enabled in the Help menu in the client.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td>• false—The Jabber menu item option Report a problem is removed from the Help menu in the client.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you set the argument to false, users can still manually use the Start Menu &gt; Cisco Jabber directory, or the Program files directory and launch the Problem Report Tool manually. If a user manually creates a PRT, and this parameter value is set to false, then the zip file created from the PRT has no content.</td>
</tr>
<tr>
<td>ENABLE_PRT_ENCRYPTION</td>
<td>true</td>
<td>Enables problem report encryption. You must configure this argument with the PRT_CERTIFICATE_NAME argument.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td>• true—PRT files sent by Jabber clients are encrypted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• false (default)—PRT files sent by Jabber clients are not encrypted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PRT encryption requires a public/private key pair to encrypt and decrypt the Cisco Jabber problem report.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PRT_CERTIFICATE_NAME</td>
<td>Certificate name</td>
<td>Specifies the name of a certificate with a public key in the Enterprise Trust or Trusted Root Certificate Authorities certificate store. The certificate public key is used to encrypt Jabber Problem reports. You must configure this argument with the ENABLE_PRT_ENCRYPTION argument.</td>
</tr>
<tr>
<td>INVALID_CERTIFICATE_BEHAVIOR</td>
<td>RejectAndNotify</td>
<td>Specifies the client behavior for invalid certificates.</td>
</tr>
<tr>
<td></td>
<td>PromptPerSession</td>
<td>▪ RejectAndNotify—A warning dialog displays and the client doesn't load.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▪ PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For invalid certificates in FIPS mode, this argument is ignored, the client displays a warning message and doesn't load.</td>
</tr>
<tr>
<td>Telemetry_Enabled</td>
<td>true/false</td>
<td>Specifies whether analytics data is gathered. The default value is true.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To improve your experience and product performance, Cisco Jabber may collect and send non-personally identifiable usage and performance data to Cisco. The aggregated data is used by Cisco to understand trends in how Jabber clients are being used and how they are performing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full details on what analytics data Cisco Jabber does and does not collect can be found in the Cisco Jabber Supplement to Cisco’s On-Line Privacy Policy at <a href="https://www.cisco.com/web/siteassets/legal/privacy_02Jun10.html">https://www.cisco.com/web/siteassets/legal/privacy_02Jun10.html</a>.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LOCATION_MODE</td>
<td>ENABLED/DISABLED/ENABLEDNOPROMPT</td>
<td>Specifies whether the Location feature is enabled and whether users are notified when new locations are detected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>ENABLED</strong> (default)—Location feature is turned on. Users are notified when new locations are detected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>DISABLED</strong>—Location feature is turned off. Users are not notified when new locations are detected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>ENABLEDNOPROMPT</strong>—Location feature is turned on. Users are not notified when new locations are detected.</td>
</tr>
<tr>
<td>FIPS_MODE</td>
<td>true/false</td>
<td>Specifies whether Cisco Jabber is in FIPS mode. Cisco Jabber can be in FIPS mode on an operating system that is not FIPS enabled. Only connections with non-Windows APIs are in FIPS mode. If you don't include this setting, Cisco Jabber will determine the FIPS mode from the operating system.</td>
</tr>
<tr>
<td>SSO_EMAIL_PROMPT</td>
<td>ON/OFF</td>
<td>Specifies whether the user is shown the email prompt for determining their home cluster. In order for the email prompt to work defined by ServicesDomainSsoEmailPrompt the installer requirements are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>SSO_EMAIL_PROMPT=ON</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>UPN_DISCOVERY_ENABLED=False</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- **VOICE_SERVICES_DOMAIN=&lt;domain_name&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- **SERVICES_DOMAIN=&lt;domain_name&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: msiexec.exe /i CiscoJabberSetup.msi SSO_EMAIL_PROMPT=ON UPN_DISCOVERY_ENABLED=False VOICE_SERVICES_DOMAIN=example.cisco.com SERVICES_DOMAIN=example.cisco.com CLEAR=1</td>
</tr>
</tbody>
</table>
**Common Installation Arguments**

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENABLE_DPI_AWARE</td>
<td>true</td>
<td>Enables DPI awareness. DPI awareness enables Cisco Jabber to automatically adjust the display of text and images to suit different screen sizes.</td>
</tr>
</tbody>
</table>
|                        | false | • true (default)—  
|                        |       |  • on Windows 8.1 and Windows 10, Cisco Jabber adjusts to different DPI settings on each monitor.  
|                        |       |  • on Windows 7 and Windows 8, Cisco Jabber displays according to the system DPI settings. |
|                        |       | • false—DPI awareness is not enabled.                                                                                                         |

DPI awareness is enabled by default. To disable DPI awareness, use the following command:

```
msiexec.exe /i CiscoJabberSetup.msi CLEAR=1 ENABLE_DPI_AWARE=false
```

**Note** If you are installing Cisco Jabber with the command line, remember to include the CLEAR=1 argument. If you are not installing Cisco Jabber from the command line, you must manually delete the jabber-bootstrap.properties file.
### Common Installation Arguments

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP_Mode</td>
<td>IPv4-Only, IPv6-Only, Two Stacks</td>
<td>Specifies the network IP protocol for the Jabber client.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- IPv4-Only—Jabber will only attempt to make IPv4 connections.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- IPv6-Only—Jabber will only attempt to make IPv6 connections.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Two Stacks (Default)—Jabber can connect with either IPv4 or IPv6.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong> IPv6-only support is available only for desktop devices on-premise deployment. All Jabber mobile devices must be configured as Two Stacks. For more details about IPv6 deployment, see the IPv6 Deployment Guide for Cisco Collaboration Systems Release. There are a number of factors used to determine the network IP protocol used by Jabber, for more information see the IPv6 Requirements section in the Planning Guide.</td>
</tr>
<tr>
<td>DIAGNOSTICSTOOLENABLED</td>
<td>true, false</td>
<td>Specifies whether the Cisco Jabber Diagnostics Tool is available to Cisco Jabber for Windows users.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- true (default)—Users can display the Cisco Jabber Diagnostics Tool by entering Ctrl + Shift + D.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- false—The Cisco Jabber Diagnostics Tool is not available to users.</td>
</tr>
<tr>
<td>FORWARD_VOICEMAIL</td>
<td>true, false</td>
<td>Enables voicemail forwarding in the Voice Messages tab.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- true (default)—Users can forward voicemails to contacts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- false—Voicemail forwarding is not enabled.</td>
</tr>
</tbody>
</table>
**Reset the user's local and roaming profile data.**

These folders are deleted:
- `%appdata%\Cisco\Unified Communications\Jabber`
- `%localappdata%\Cisco\Unified Communications\Jabber`

---

## LCID for Languages

The following table lists the Locale Identifier (LCID) or Language Identifier (LangID) for the languages that the Cisco Jabber clients support.

<table>
<thead>
<tr>
<th>Supported Languages</th>
<th>Cisco Jabber for Windows</th>
<th>Cisco Jabber for Mac</th>
<th>Cisco Jabber for Android, Cisco Jabber for iPhone and iPad</th>
<th>LCID/LangID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arabic - Saudi Arabia</td>
<td>X</td>
<td></td>
<td>X</td>
<td>1025</td>
</tr>
<tr>
<td>Bulgarian - Bulgaria</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1026</td>
</tr>
<tr>
<td>Catalan - Spain</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1027</td>
</tr>
<tr>
<td>Chinese (Simplified) - China</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>2052</td>
</tr>
<tr>
<td>Chinese (Traditional) - Taiwan</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1028</td>
</tr>
<tr>
<td>Croatian - Croatia</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1050</td>
</tr>
<tr>
<td>Czech - Czech Republic</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1029</td>
</tr>
<tr>
<td>Danish - Denmark</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1030</td>
</tr>
<tr>
<td>Dutch - Netherlands</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1043</td>
</tr>
<tr>
<td>English - United States</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1033</td>
</tr>
<tr>
<td>Finnish - Finland</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1035</td>
</tr>
<tr>
<td>French - France</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1036</td>
</tr>
<tr>
<td>German - Germany</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1031</td>
</tr>
<tr>
<td>Greek - Greece</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1032</td>
</tr>
<tr>
<td>Supported Languages</td>
<td>Cisco Jabber for Windows</td>
<td>Cisco Jabber for Mac</td>
<td>Cisco Jabber for Android, Cisco Jabber for iPhone and iPad</td>
<td>LCID/LangID</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------------------</td>
<td>----------------------</td>
<td>------------------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Hebrew - Israel</td>
<td>X</td>
<td></td>
<td></td>
<td>1037</td>
</tr>
<tr>
<td>Hungarian - Hungary</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1038</td>
</tr>
<tr>
<td>Italian - Italy</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1040</td>
</tr>
<tr>
<td>Japanese - Japan</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1041</td>
</tr>
<tr>
<td>Korean - Korea</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1042</td>
</tr>
<tr>
<td>Norwegian - Norway</td>
<td>X</td>
<td>X</td>
<td></td>
<td>2068</td>
</tr>
<tr>
<td>Polish - Poland</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1045</td>
</tr>
<tr>
<td>Portuguese - Brazil</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1046</td>
</tr>
<tr>
<td>Portuguese - Portugal</td>
<td>X</td>
<td>X</td>
<td></td>
<td>2070</td>
</tr>
<tr>
<td>Romanian - Romania</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1048</td>
</tr>
<tr>
<td>Russian - Russia</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1049</td>
</tr>
<tr>
<td>Serbian</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1050</td>
</tr>
<tr>
<td>Slovak - Slovakian</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1051</td>
</tr>
<tr>
<td>Slovenian - Slovenia</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1060</td>
</tr>
<tr>
<td>Spanish - Spain (Modern Sort)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>3082</td>
</tr>
<tr>
<td>Swedish - Sweden</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>5149</td>
</tr>
<tr>
<td>Thai - Thailand</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1054</td>
</tr>
<tr>
<td>Turkish</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1055</td>
</tr>
</tbody>
</table>

**Related Topics**

- [Example Installation Commands](#), on page 104
- [Command Line Arguments](#), on page 105

**Run the MSI Manually**

You can run the installation program manually to install a single instance of the client and specify connection settings in the Advanced settings window.
Create a Custom Installer

You can transform the default installation package to create a custom installer.

Note: You use Microsoft Orca to create custom installers. Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and .NET Framework 4.

Create Custom Installers, on page 123

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Get the Default Transform File, on page 122</td>
<td>You must have the default transform file to modify the installation package with Microsoft Orca.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Create Custom Transform Files, on page 123</td>
<td>Transform files contain installation properties that you apply to the installer.</td>
</tr>
<tr>
<td><strong>Step 3</strong> Transform the Installer, on page 124</td>
<td>Apply a transform file to customize the installer.</td>
</tr>
</tbody>
</table>

Related Topics

Microsoft Windows SDK for Windows 7 and .NET Framework 4

Get the Default Transform File

You must have the default transform file to modify the installation package with Microsoft Orca.
Procedure

Step 1
Download the Cisco Jabber administration package from Software Download page.

Step 2
Copy CiscoJabberProperties.msi from the Cisco Jabber administration package to your file system.

What to do next
Create Custom Transform Files, on page 123

Related Topics
Software Downloads

Create Custom Transform Files

To create a custom installer, you use a transform file. Transform files contain installation properties that you apply to the installer.

The default transform file lets you specify values for properties when you transform the installer. You should use the default transform file if you are creating one custom installer.

You can optionally create custom transform files. You specify values for properties in a custom transform file and then apply it to the installer.

Create custom transform files if you require more than one custom installer with different property values. For example, create one transform file that sets the default language to French and another transform file that sets the default language to Spanish. You can then apply each transform file to the installation package separately. The result is that you create two installers, one for each language.

Before you begin
Get the Default Transform File, on page 122

Procedure

Step 1
Start Microsoft Orca.

Step 2
Open CiscoJabberSetup.msi and then apply CiscoJabberProperties.msi.

Step 3
Specify values for the appropriate installer properties.

Step 4
Generate and save the transform file.

a) Select Transform > Generate Transform.

b) Select a location on your file system to save the transform file.

c) Specify a name for the transform file and select Save.

The transform file you created is saved as file_name.mst. You can apply this transform file to modify the properties of CiscoJabberSetup.msi.
What to do next
Transform the Installer, on page 124

Transform the Installer

Apply a transform file to customize the installer.

---

**Note**

Applying transform files will alter the digital signature of CiscoJabberSetup.msi. Attempts to modify or rename CiscoJabberSetup.msi will remove the signature entirely.

---

Before you begin
Create Custom Transform Files, on page 123

Procedure

**Step 1**
Start Microsoft Orca.

**Step 2**
Open CiscoJabberSetup.msi in Microsoft Orca.

a) Select File > Open.

b) Browse to the location of CiscoJabberSetup.msi on your file system.

c) Select CiscoJabberSetup.msi and then select Open.

The installation package opens in Microsoft Orca. The list of tables for the installer opens in the Tables pane.

**Step 3**
Required: Remove all language codes except for 1033 (English).

**Restriction**
You must remove all language codes from the custom installer except for 1033 (English).

Microsoft Orca does not retain any language files in custom installers except for the default, which is 1033. If you do not remove all language codes from the custom installer, you cannot run the installer on any operating system where the language is other than English.

a) Select View > Summary Information.

The Edit Summary Information window displays.

b) Locate the Languages field.

c) Delete all language codes except for 1033.

d) Select OK.

English is set as the language for your custom installer.

**Step 4**
Apply a transform file.

a) Select Transform > Apply Transform.

b) Browse to the location of the transform file on your file system.

c) Select the transform file and then select Open.

**Step 5**
Select Property from the list of tables in the Tables pane.

The list of properties for CiscoJabberSetup.msi opens in the right panel of the application window.
Step 6 Specify values for the properties you require.

**Tip** Values are case sensitive. Ensure the value you enter matches the value in this document.

**Tip** Set the value of the CLEAR property to 1 to override any existing bootstrap file from previous installations. If you do not override existing bootstrap files, the values you set in the custom installer do not take effect.

Step 7 Remove any properties that you do not require.

It is essential to remove any properties that are not being set, otherwise the properties being set will not take effect. Remove each property that is not needed one at a time.

a) Right-click the property you want to remove.
b) Select **Drop Row**.
c) Select **OK** when Microsoft Orca prompts you to continue.

Step 8 Required: Enable your custom installer to save embedded streams.

a) Select **Tools > Options**.
b) Select the **Database** tab.
c) Select **Copy embedded streams during 'Save As'**.
d) Select **Apply** and then **OK**.

Step 9 Save your custom installer.

a) Select **File > Save Transformed As**.
b) Select a location on your file system to save the installer.
c) Specify a name for the installer and then select **Save**.

Related Topics
---
**Installer Properties**, on page 125

**Installer Properties**

The following are the properties you can modify in a custom installer:

- CLEAR
- PRODUCT_MODE
- AUTHENTICATOR
- CUP_ADDRESS
- TFTP
- CTI
- CCMCIP
- LANGUAGE
- TFTP_FILE_NAME
- FORGOT_PASSWORD_URL
- SSO_ORG_DOMAIN
Deploy with Group Policy

Install Cisco Jabber for Windows with Group Policy using the Microsoft Group Policy Management Console (GPMC) on Microsoft Windows Server.

**Note**
To install Cisco Jabber for Windows with Group Policy, all computers or users to which you plan to deploy Cisco Jabber for Windows must be in the same domain.

### Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td><strong>Set a Language Code, on page 126</strong></td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td><strong>Deploy the Client with Group Policy, on page 127</strong></td>
</tr>
</tbody>
</table>

### Set a Language Code

Altering the installation language is not necessary in Group Policy deployment scenarios where the exact MSI file provided by Cisco will be used. The installation language will be determined from the Windows User Locale (Format) in these situations. You must use this procedure and set the Language field to 1033 only if the MSI is to be modified by Orca in any way.

**Procedure**

**Step 1**
Start Microsoft Orca.
Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and .NET Framework 4 that you can download from the Microsoft website.

**Step 2**
Open CiscoJabberSetup.msi.
- Select **File > Open**.
- Browse to the location of CiscoJabberSetup.msi on your file system.
- Select CiscoJabberSetup.msi and then select **Open**.

**Step 3**
Select **View > Summary Information**.
Step 4  Locate the Languages field.
Step 5  Set the Languages field to 1033.
Step 6  Select OK.
Step 7  Required: Enable your custom installer to save embedded streams.
        a) Select Tools > Options.
        b) Select the Database tab.
        c) Select Copy embedded streams during 'Save As'.
        d) Select Apply and then OK.
Step 8  Save your custom installer.
        a) Select File > Save Transformed As.
        b) Select a location on your file system to save the installer.
        c) Specify a name for the installer and then select Save.

What to do next
Deploy the Client with Group Policy, on page 127
Related Topics
   LCID for Languages, on page 120

Deploy the Client with Group Policy

Complete the steps in this task to deploy Cisco Jabber for Windows with Group Policy.

Before you begin
Set a Language Code, on page 126

Procedure

Step 1  Copy the installation package to a software distribution point for deployment.
       All computers or users to which you plan to deploy Cisco Jabber for Windows must be able to access the
       installation package on the distribution point.
Step 2  Select Start > Run and then enter the following command:
       GPMC.msc
       The Group Policy Management console opens.
Step 3  Create a new group policy object.
       a) Right-click on the appropriate domain in the left pane.
       b) Select Create a GPO in this Domain, and Link it here.
          The New GPO window opens.
       c) Enter a name for the group policy object in the Name field.
Configure Automatic Updates for Windows

To enable automatic updates, you create an XML file that contains the information for the most recent version, including the URL of the installation package on the HTTP server. The client retrieves the XML file when users sign in, resume their computer from sleep mode, or perform a manual update request from the Help menu.

**Note** If you use the Cisco Webex Messenger service for instant messaging and presence capabilities, you should use the Cisco Webex Administration Tool to configure automatic updates.

**XML File Structure**

XML files for automatic updates have the following structure:

```xml
<JabberUpdate>
  <App name="JabberWin">
    <LatestBuildNum>12345</LatestBuildNum>
    <LatestVersion>11.8.x</LatestVersion>
    <Mandatory>true</Mandatory>
  </App>
</JabberUpdate>
```

---

d) Leave the default value or select an appropriate option from the Source Starter GPO drop-down list and then select OK.

The new group policy displays in the list of group policies for the domain.

**Step 4** Set the scope of your deployment.

a) Select the group policy object under the domain in the left pane.

The group policy object displays in the right pane.

b) Select Add in the Security Filtering section of the Scope tab.

The Select User, Computer, or Group window opens.

c) Specify the computers and users to which you want to deploy Cisco Jabber for Windows.

**Step 5** Specify the installation package.

a) Right-click the group policy object in the left pane and then select Edit.

The Group Policy Management Editor opens.

b) Select Computer Configuration and then select Policies > Software Settings.

c) Right-click Software Installation and then select New > Package.

d) Enter the location of the installation package next to FileName; for example, `\server\software_distribution`.

**Important** You must enter a Uniform Naming Convention (UNC) path as the location of the installation package. If you do not enter a UNC path, Group Policy cannot deploy Cisco Jabber for Windows.

e) Select the installation package and then select Open.

f) In the Deploy Software dialog box, select Assigned and then OK.

Group Policy installs Cisco Jabber for Windows on each computer the next time each computer starts.
This new version of Cisco Jabber lets you do the following:

- Feature 1
- Feature 2

For more information click [a target="_blank"
href="http://cisco.com/go/jabber"]here[/a].

Before you begin

- Install and configure an HTTP server to host the XML file and installation package.
- Ensure users have permission to install software updates on their workstations.

Microsoft Windows stops update installations if users do not have administrative rights on their workstations. You must be logged in with administrative rights to complete installation.

Procedure

**Step 1**  
Host the update installation program on your HTTP server.

**Step 2**  
Create an update XML file with any text editor.

**Step 3**  
Specify values in the XML as follows:

- **name**—Specify the following ID as the value of the name attribute for the App element:
  - **JabberWin**—The update applies to Cisco Jabber for Windows.

- **LatestBuildNum**—Build number of the update.

- **LatestVersion**—Version number of the update.

- **Mandatory**—(Windows clients only) True or False. Determines whether users must upgrade their client version when prompted.

- **Message**—HTML in the following format:
  
  ```html
  <![[CDATA[your_html]]]>
  ```

- **DownloadURL**—URL of the installation package on your HTTP server.

- **AllowUpdatesViaExpressway**—(Windows client only). False (default) or True. Determines whether Jabber can carry out automatic updates while connected to the corporate network over the Expressway for Mobile and Remote Access.

  If your update XML file is hosted on a public web server, set this parameter to false. Otherwise the update file tells Jabber that it is hosted on an internal server that must be accessed through the Expressway for Mobile and Remote Access.

**Step 4**  
Save and close your update XML file.

**Step 5**  
Host your update XML file on your HTTP server.

**Step 6**  
Specify the URL of your update XML file as the value of the UpdateUrl parameter in your configuration file.
Uninstall Cisco Jabber for Windows

You can uninstall Cisco Jabber for Windows using either the command line or the Microsoft Windows control panel. This document describes how to uninstall Cisco Jabber for Windows using the command line.

Use the Installer

If the installer is available on the file system, use it to remove Cisco Jabber for Windows.

Procedure

Step 1  Open a command line window.
Step 2  Enter the following command:
msiexec.exe /x path_to_CiscoJabberSetup.msi
For example,
msiexec.exe /x C:\Windows\Installer\CiscoJabberSetup.msi /quiet
Where /quiet specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.

Use the Product Code

If the installer is not available on the file system, use the product code to remove Cisco Jabber for Windows.

Procedure

Step 1  Find the product code.
a) Open the Microsoft Windows registry editor.
b) Locate the following registry key: HKEY_CLASSES_ROOT\Installer\Products
c) Select Edit > Find.
d) Enter Cisco Jabber in the Find what text box in the Find window and select Find Next.
e) Find the value of the ProductIcon key.

The product code is the value of the ProductIcon key, for example,
C:\Windows\Installer\{product_code}\ARPPRODUCTICON.exe.

Note  The product code changes with each version of Cisco Jabber for Windows.

Step 2  Open a command line window.
Step 3  Enter the following command:
msiexec.exe /x product_code
For example,
msiexec.exe /x 45992224-D2DE-49BB-B085-6524845321C7 /quiet
Where `/quiet` specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.

**Install Cisco Jabber for Mac**

**Installer for Cisco Jabber for Mac**

**Installing the Client**

You can choose to install the client using one of the following methods:

- Provide the installer for users to manually install the application. The client is installed in the `Applications` folder. Previous versions of the client need to be removed.

- Configure automatic updates for users, the installer silently updates the application.

  For automatic updates, the client is always added in the `Applications` folder.

  - If the client existed in a different folder, or a sub folder of the `Applications` folder, then a link is created in that folder to run the client in the Applications folder.

  - If the user previously renamed the client, then the installer will rename the new client to match.

Users are prompted for system credentials similar to installing other OS X installers.

**Quiet Install**—To install the client quietly, in the Terminal tool use the following Mac OS X command:

```
sudo installer -pkg /path_to/Install_Cisco-Jabber-Mac.pkg -target /
```

For more information on the installer command, refer to the installer manual pages on your Mac.

**Accessories Manager**

Accessories Manager is a component that provides Unified Communication control APIs to accessory device vendors. Third party devices can use these APIs to perform tasks such as mute audio, answer calls, and end calls from the device. Third party vendors write plugins that are loaded by the application. Standard headsets can be connected with speaker and microphone support. Only specific devices interact with Accessories Manager for call control. Please contact your devices vendor for more information. Desktop phones are not supported.

The client installer includes the third party plug-ins from the vendors. They are installed in the `/Library/Cisco/Jabber/Accessories/` folder.

Supported third party vendors:

- Logitech
- Sennheiser
- Jabra
- Plantronics
Accessories manager functionality is enabled by default and configured using the EnableAccessoriesManager parameter. You can disable specific Accessories Manager plugins from third party vendors using the BlockAccessoriesManager parameter.

**Configuration**

Provide configuration information for your users to sign into the client. Choose one of the following:

- Provide your users with a configuration URL with optional server information. For further information, see the *URL Configuration for Cisco Jabber for Mac* section.
- Provide your users with the server information to connect manually. For further information, see the *Manual Connection Settings* section.
- Service discovery—For more information, see the *Service Discovery* section.

**Run Installer Manually**

You can run the installation program manually to install a single instance of the client and specify connection settings in the *Preferences* settings.

**Before you begin**

Remove any older versions of the client.

**Procedure**

| Step 1 | Launch the *jabber-mac.pkg*.  
The installer opens a window to guide you through the installation process. |
|--------|---------------------------------------------------------------------|
| Step 2 | Follow the steps to complete the installation process.  
The installer prompts the user to enter the system credentials. |
| Step 3 | Launch the client, using either a configuration URL or running the client directly.  
Enter user credentials. |

**URL Configuration for Cisco Jabber for Mac**

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

You can include and specify the following parameters in the URL:

- **ServicesDomain**—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.
- **VoiceServiceDomain**—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.
• ServiceDiscoveryExcludedServices—Optional. You can exclude any of the following services from the service discovery process:
  • Webex—When you set this value, the client:
    • Does not perform CAS lookup
    • Looks for:
      • _cisco-uds
      • _cuplogin
      • _collab-edge
  • CUCM—When you set this value, the client:
    • Does not look for _cisco-uds
    • Looks for:
      • _cuplogin
      • _collab-edge
  • CUP—When you set this value, the client:
    • Does not look for _cuplogin
    • Looks for:
      • _cisco-uds
      • _collab-edge

You can specify multiple, comma-separated values to exclude multiple services.

If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

• ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
  • ON
  • OFF

• EnablePRTEncryption—Optional. Specifies that the PRT file is encrypted. Applies to Cisco Jabber for Mac.
  • true
  • false

• PRTCertificateName—Optional. Specifies the name of the certificate. Applies to Cisco Jabber for Mac.
  • InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
• RejectAndNotify—A warning dialog displays and the client doesn't load.
• PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.
• Telephony_Enabled—Specifies whether the user has phone capability or not. The default is true.
  • True
  • False
• DiagnosticsToolEnabled—Specifies whether the diagnostics tool is available in the client. The default is true.
  • True
  • False

Create the configuration URL in the following format:

ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>

Note

The parameters are case sensitive. When you create the configuration URL, you must use the following capitalization:

• ServicesDomain
• VoiceServicesDomain
• ServiceDiscoveryExcludedServices
• ServicesDomainSsoEmailPrompt
• EnablePRTEncryption
• PRTCertificateName
• InvalidCertificateBehavior
• Telephony_Enabled
• IP_Mode
• DiagnosticsToolEnabled

Examples

• ciscojabber://provision?ServicesDomain=cisco.com
• ciscojabber://provision?ServicesDomain=cisco.com
  &VoiceServicesDomain=alphauk.cisco.com
• ciscojabber://provision?ServicesDomain=service_domain
  &VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX
Configure Automatic Updates for Mac

To enable automatic updates, you create an XML file that contains the information for the most recent version, including the URL of the installation package on the HTTP server. The client retrieves the XML file when users sign in, resume their computer from sleep mode, or perform a manual update request from the Help menu.

If you use the Cisco Webex Messenger service for instant messaging and presence capabilities, you should use the Cisco Webex Administration Tool to configure automatic updates.

XML File Structure

The following is an example XML file for automatic updates:

```xml
<JabberUpdate>
  <App name="JabberMac">
    <LatestBuildNum>12345</LatestBuildNum>
    <LatestVersion>9.6.1</LatestVersion>
    <Message><![CDATA[<b>This new version of Cisco Jabber lets you do the following:</b><ul><li>Feature 1</li><li>Feature 2</li></ul>For more information click <a target="_blank" href="http://cisco.com/go/jabber">here</a>.]]></Message>
  </App>
</JabberUpdate>
```

Example XML File 2

The following is an example XML file for automatic updates for both Cisco Jabber for Windows and Cisco Jabber for Mac:

```xml
<JabberUpdate>
  <App name="JabberMac">
    <LatestBuildNum>12345</LatestBuildNum>
    <LatestVersion>9.6.1</LatestVersion>
    <Message><![CDATA[<b>This new version of Cisco Jabber lets you do the following:</b><ul><li>Feature 1</li><li>Feature 2</li></ul>For more information click <a target="_blank" href="http://cisco.com/go/jabber">here</a>.]]></Message>
  </App>
  <App name="JabberWin">
    <LatestBuildNum>12345</LatestBuildNum>
    <LatestVersion>9.0</LatestVersion>
    <Message><![CDATA[<b>This new version of Cisco Jabber lets you do the following:</b><ul><li>Feature 1</li><li>Feature 2</li></ul>For more information click <a target="_blank" href="http://cisco.com/go/jabber">here</a>.]]></Message>
  </App>
</JabberUpdate>
```
Before you begin

Install and configure an HTTP server to host the XML file and installation package.

Note

Configure Web servers to escape special characters to ensure the DSA signature succeeds. For example, on Microsoft IIS the option is: **Allow double spacing.**

Procedure

**Step 1** Host the update installation program on your HTTP server.

**Step 2** Create an update XML file with any text editor.

**Step 3** Specify values in the XML as follows:

- **name**—Specify the following ID as the value of the `name` attribute for the `App` element:
  - **JabberWin**—The update applies to Cisco Jabber for Windows.
  - **JabberMac**—The update applies to Cisco Jabber for Mac.

- **LatestBuildNum**—Build number of the update.

- **LatestVersion**—Version number of the update.

- **Mandatory**—True or False. Determines whether users must upgrade their client version when prompted.

- **Message**—HTML in the following format:

  ```html
  <![CDATA[your_html]]>
  ```

- **DownloadURL**—URL of the installation package on your HTTP server.

  For Cisco Jabber for Mac the URL file must be in the following format:

  `Install_Cisco-Jabber-Mac-version-size-dsaSignature.zip`

**Step 4** Save and close your update XML file.

**Step 5** Host your update XML file on your HTTP server.

**Step 6** Specify the URL of your update XML file as the value of the `UpdateUrl` parameter in your configuration file.
Install Cisco Jabber Mobile Clients

Procedure

Step 1
To install Cisco Jabber for Android, download the app from Google Play from your mobile device.

Step 2
To install Cisco Jabber for iPhone and iPad, download the app from the App Store from your mobile device.

URL Configuration for Cisco Jabber for Android, iPhone, and iPad

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

You can include and specify the following parameters in the URL:

- **ServicesDomain**—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.

- **VoiceServiceDomain**—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.

- **ServiceDiscoveryExcludedServices**—Optional. You can exclude any of the following services from the service discovery process:
  - **Webex**—When you set this value, the client:
    - Does not perform CAS lookup
    - Looks for:
      - _cisco-uds
      - _cuplogin
      - _collab-edge
  
  - **CUCM**—When you set this value, the client:
    - Does not look for _cisco-uds
    - Looks for:
      - _cuplogin
      - _collab-edge
  
  - **CUP**—When you set this value, the client:
• Does not look for _cuplogin
• Looks for:
  • _cisco-uds
  • _collab-edge

You can specify multiple, comma-separated values to exclude multiple services.
If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

• ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
  • ON
  • OFF

• InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
  • RejectAndNotify—A warning dialog displays and the client doesn’t load.
  • PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.

• PRTCertificateUrl—Specifies the name of a certificate with a public key in the trusted root certificate store. Applies to Cisco Jabber mobile clients.

• Telephony_Enabled—Specifies whether the user has phone capability or not. The default is true.
  • True
  • False

• ForceLaunchBrowser—Used to force user to use the external browser. Applies to Cisco Jabber mobile clients.
  • True
  • False

Note: ForceLaunchBrowser is used for client certificate deployments and for devices with Android OS below 5.0.

Create the configuration URL in the following format:

ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>
The parameters are case sensitive. When you create the configuration URL, use the following capitalization:

- ServicesDomain
- VoiceServicesDomain
- ServiceDiscoveryExcludedServices
- ServicesDomainSsoEmailPrompt
- PRTCertificateURL
- InvalidCertificateBehavior
- Telephony_ENABLED
- ForceLaunchBrowser

Examples

- ciscojabber://provision?ServicesDomain=cisco.com
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com
- ciscojabber://provision?ServicesDomain=service_domain&VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP&ServicesDomainSsoEmailPrompt=OFF

Mobile Configuration Using Enterprise Mobility Management

Before using Enterprise Mobility Management (EMM), ensure:

- The EMM vendor supports Android for Work or Apple Managed App Configuration.
- Android devices OS is 5.0 or later.

To allow users to launch Cisco Jabber for Android or Cisco Jabber for iPhone and iPad, you can configure Cisco Jabber using Enterprise Mobility Management (EMM).

For more information on setting up EMM, refer to the instructions for administrators provided by the EMM provider.

If you want Jabber to run only on managed devices, then you can deploy certificate-based authentication, and enroll the client certificate through EMM.

You can configure Cisco Jabber for iPhone and iPad as the default dialer for the local contacts that are imported from Microsoft Exchange Server. Configure the profile with the Exchange ActiveSync and enter the value com.cisco.jabberIM in the Default Audio Call App field of the MDM configuration file.
When using EMM, disable URL configuration by setting the AllowUrlProvisioning parameter to False in the EMM application. For more information on configuring the parameter, refer to the topic AllowUrlProvisioning Parameter.

EMM vendors may allow different value types to be set in Application Configuration settings, but Cisco Jabber only reads String value types. In EMM, configure the following parameters:

- ServicesDomain
- VoiceServicesDomain
- ServiceDiscoveryExcludedServices
- ServicesDomainSsoEmailPrompt
- EnablePRTEncryption
- PRTCertificateURL
- PRTCertificateName
- InvalidCertificateBehavior
- Telephony_Enabled
- ForceLaunchBrowser
- FIPS_MODE
- AllowUrlProvisioning
- IP_Mode

FIPS_MODE Parameter

Use this parameter to enable or disable FIPS mode on Cisco Jabber mobile clients using EMM.

- `true`—Runs Cisco Jabber in FIPS mode.
- `false`—Does not run Cisco Jabber in FIPS mode.

Example:

```
<FIPS_MODE>false</FIPS_MODE>
```

AllowUrlProvisioning Parameter

Use this parameter when migrating users from URL configuration to EMM.

The following values apply to this parameter:

- `true` (default)—Bootstrap configuration is performed using URL configuration
- `false`—Bootstrap configuration is not performed using URL configuration

Example:

```
<AllowURLProvisioning>false</AllowURLProvisioning>
```
Remote Access

• Service Discovery Requirements Workflow, on page 141
• Cisco Anyconnect Deployment Workflow, on page 142
• Define Mobile and Remote Access Policies for User Profiles, on page 148

Service Discovery Requirements Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Service Discovery Requirements, on page 141</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>DNS Requirements, on page 141</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Certificate Requirements, on page 142</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Test _collab-edge SRV Record, on page 142</td>
<td></td>
</tr>
</tbody>
</table>

Service Discovery Requirements

Service discovery enables clients to automatically detect and locate services on your enterprise network. Expressway for Mobile and Remote Access allows you to access the services on your enterprise network. You should meet the following requirements to enable the clients to connect through Expressway for Mobile and Remote Access and discover services:

• DNS requirements
• Certificate requirements
• Test external SRV _collab-edge.

DNS Requirements

The DNS requirements for service discovery through remote access are:

• Configure a _collab-edge DNS SRV record on an external DNS server.
• Configure a _cisco-uds DNS SRV record on the internal name server.

• Optionally, for a hybrid cloud-based deployment with different domains for the IM and Presence server and the voice server, configure the Voice Services Domain to locate the DNS server with the _collab-edge record.

Note
Jabber attempts connections to a maximum of three SSO-enabled servers, which are chosen randomly from all SSO-enabled servers that the DNS SRV records (_collab-edge and _cisco-uds) identify. If Jabber fails to connect three times, it considers Edge SSO unsupported.

Certificate Requirements
Before you configure remote access, download the Cisco VCS Expressway and Cisco Expressway-E Server certificate. The Server certificate is used for both HTTP and XMPP.

For more information on configuring Cisco VCS Expressway certificate, see Configuring Certificates on Cisco VCS Expressway.

Test _collab-edge SRV Record

Test SRV Records
After creating your SRV records test to see if they are accessible.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open a command prompt.</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Enter <code>nslookup</code>.</td>
<td>The default DNS server and address is displayed. Confirm that this is the expected DNS server.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter <code>set type=SRV</code>.</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Enter the name for each of your SRV records.</td>
<td>For example _cisco-uds.exampledomain</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Displays server and address—SRV record is accessible.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Displays _cisco-uds.exampledomain: Non-existent domain—There is an issue with your SRV record.</td>
</tr>
</tbody>
</table>

Cisco Anyconnect Deployment Workflow

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Application Profiles, on page 143</td>
</tr>
</tbody>
</table>
Cisco AnyConnect Deployment

Application Profiles

After you download the Cisco AnyConnect Secure Mobility Client to their device, the ASA must provision a configuration profile to the application.

The configuration profile for the Cisco AnyConnect Secure Mobility Client includes VPN policy information such as the company ASA VPN gateways, the connection protocol (IPSec or SSL), and on-demand policies.

You can provision application profiles for Cisco Jabber for iPhone and iPad in one of the following ways:

ASDM

We recommend that you use the profile editor on the ASA Device Manager (ASDM) to define the VPN profile for the Cisco AnyConnect Secure Mobility Client.

When you use this method, the VPN profile is automatically downloaded to the Cisco AnyConnect Secure Mobility Client after the client establishes the VPN connection for the first time. You can use this method for all devices and OS types, and you can manage the VPN profile centrally on the ASA.

For more information, see the Creating and Editing an AnyConnect Profile topic of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your release.

iPCU

You can provision iOS devices using an Apple configuration profile that you create with the iPhone Configuration Utility (iPCU). Apple configuration profiles are XML files that contain information such as device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1. Use iPCU to create an Apple configuration profile.

   For more information, see the iPCU documentation.

2. Export the XML profile as a .mobileconfig file.

3. Email the .mobileconfig file to users.

   After a user opens the file, it installs the AnyConnect VPN profile and the other profile settings to the client application.
MDM

You can provision iOS devices using an Apple configuration profile that you create with third-party Mobile Device Management (MDM) software. Apple configuration profiles are XML files that contain information such as device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1. Use MDM to create the Apple configuration profiles.
   
   For information on using MDM, see the Apple documentation.

2. Push the Apple configuration profiles to the registered devices.

To provision application profiles for Cisco Jabber for Android, use the profile editor on the ASA Device Manager (ASDM) to define the VPN profile for the Cisco AnyConnect Secure Mobility Client. The VPN profile is automatically downloaded to the Cisco AnyConnect Secure Mobility Client after the client establishes the VPN connection for the first time. You can use this method for all devices and OS types, and you can manage the VPN profile centrally on the ASA. For more information, see the Creating and Editing an AnyConnect Profile topic of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your release.

Automate VPN Connection

When users open Cisco Jabber from outside the corporate Wi-Fi network, Cisco Jabber needs a VPN connection to access the Cisco UC application servers. You can set up the system to allow Cisco AnyConnect Secure Mobility Client to automatically establish a VPN connection in the background, which helps ensure a seamless user experience.

---

**Note**

VPN will not be launched because Expressway for Mobile and Remote Access has the higher connection priority even if VPN is set to automatic connection.

Set Up Trusted Network Connection

The Trusted Network Detection feature enhances the user experience by automating the VPN connection based on the user's location. When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the Cisco UC infrastructure directly. When the user leaves the corporate Wi-Fi network, Cisco Jabber automatically detects that it is outside the trusted network. After this occurs, Cisco AnyConnect Secure Mobility Client initiates the VPN to ensure connectivity to the UC infrastructure.

---

**Note**

The Trusted Network Detection feature works with both certificate- and password-based authentication. However, certificate-based authentication provides the most seamless user experience.

**Procedure**

Step 1 Using ASDM, open the Cisco AnyConnect client profile.
Step 2 Enter the list of Trusted DNS Servers and Trusted DNS Domain Suffixes that an interface can receive when the client is within a corporate Wi-Fi network. The Cisco AnyConnect client compares the current interface DNS servers and domain suffix with the settings in this profile.

Note You must specify all your DNS servers to ensure that the Trusted Network Detection feature works properly. If you set up both the TrustedDNSDomains and TrustedDNSServers, sessions must match both settings to be defined as a trusted network.

For detailed steps for setting up Trusted Network Detection, see the Trusted Network Detection section in the Configuring AnyConnect Features chapter (Release 2.5) or Configuring VPN Access (releases 3.0 or 3.1) of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your release.

Set Up Connect On-Demand VPN

The Apple iOS Connect On Demand feature enhances the user experience by automating the VPN connection based on the user's domain.

When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the Cisco UC infrastructure directly. When the user leaves the corporate Wi-Fi network, Cisco AnyConnect automatically detects if it is connected to a domain that you specify in the AnyConnect client profile. If so, the application initiates the VPN to ensure connectivity to the UC infrastructure. All applications on the device including Cisco Jabber can take advantage of this feature.

Note Connect On Demand supports only certificate-authenticated connections.

The following options are available with this feature:

- **Always Connect** — Apple iOS always attempts to initiate a VPN connection for domains in this list.
- **Connect If Needed** — Apple iOS attempts to initiate a VPN connection to the domains in the list only if it cannot resolve the address using DNS.
- **Never Connect** — Apple iOS never attempts to initiate a VPN connection to domains in this list.

Attention Apple plans to remove the Always Connect option in the near future. After the Always Connect option is removed, users can select the Connect If Needed option. In some cases, Cisco Jabber users may have issues when using the Connect If Needed option. For example, if the hostname for the Cisco Unified Communications Manager is resolvable outside the corporate network, iOS will not trigger a VPN connection. The user can work around this issue by manually launching Cisco AnyConnect Secure Mobility Client before making a call.

Procedure

Step 1 Use the ASDM profile editor, iPUC, or MDM software to open the AnyConnect client profile.

Step 2 In the AnyConnect client profile, under the Connect if Needed section, enter your list of on-demand domains.
The domain list can include wild-card options (for example, cucm.cisco.com, cisco.com, and *.webex.com).

Set Up Automatic VPN Access on Cisco Unified Communications Manager

Before you begin

- The mobile device must be set up for on-demand access to VPN with certificate-based authentication. For assistance with setting up VPN access, contact the providers of your VPN client and head end.
- For requirements for Cisco AnyConnect Secure Mobility Client and Cisco Adaptive Security Appliance, see the Software Requirements topic.
- For information about setting up Cisco AnyConnect, see the Cisco AnyConnect VPN Client Maintain and Operate Guides.

Procedure

Step 1
Identify a URL that will cause the client to launch VPN on Demand.

a) Use one of the following methods to identify a URL that will cause the client to launch VPN on Demand.
   - Connect if Needed
     - Configure Cisco Unified Communications Manager to be accessed through a domain name (not an IP address) and ensure that this domain name is not resolvable outside the firewall.
     - Include this domain in the “Connect If Needed” list in the Connect On Demand Domain List of the Cisco AnyConnect client connection.
   - Always Connect
     - Set the parameter in step 4 to a nonexistent domain. A nonexistent domain causes a DNS query to fail when the user is inside or outside the firewall.
     - Include this domain to the “Always Connect” list in the Connect On Demand Domain List of the Cisco AnyConnect client connection.

     The URL must include only the domain name. Do not include a protocol or a path (for example, use “cm8ondemand.company.com” instead of “https://cm8ondemand.company.com/vpn”).

b) Enter the URL in Cisco AnyConnect and verify that a DNS query on this domain fails.

Step 2
Open the Cisco Unified CM Administration interface.

Step 3
Navigate to the device page for the user.

Step 4
In the Product Specific Configuration Layout section, in the On-Demand VPN URL field, enter the URL that you identified and used in Cisco AnyConnect in Step 1.

The URL must be a domain name only, without a protocol or path.

Step 5
Select Save.
When Cisco Jabber opens, it initiates a DNS query to the URL (for example, ccm-sjc-111.cisco.com). If this URL matches the On-Demand domain list entry that you defined in this procedure (for example, cisco.com), Cisco Jabber indirectly initiates the AnyConnect VPN connection.

What to do next

• Test this feature.
  • Enter this URL into the Internet browser on the iOS device and verify that VPN launches automatically. You should see a VPN icon in the status bar.
  • Verify that the iOS device can connect to the corporate network using VPN. For example, access a web page on your corporate intranet. If the iOS device cannot connect, contact the provider of your VPN technology.
  • Verify with your IT department that your VPN does not restrict access to certain types of traffic (for example, if the administrator set the system to allow only email and calendar traffic).
  • Verify that you set up the client to connect directly to the corporate network.

AnyConnect Documentation Reference

For detailed information on AnyConnect requirements and deployments review the documentation for your release at the following: https://www.cisco.com/c/en/us/support/security/anyconnect-secure-mobility-client/products-user-guide-list.html

Session Parameters

You can configure ASA session parameters to improve performance for secure connections. For the best user experience, you should configure the following ASA session parameters:

• Datagram Transport Layer Security (DTLS) — DTLS is an SSL protocol that provides a data path that prevents latency and data loss.

• Auto Reconnect — Auto reconnect, or session persistence, lets Cisco AnyConnect Secure Mobility Client recover from session disruptions and re-establish sessions.

• Session Persistence — This parameter allows the VPN session to recover from service disruptions and re-establish the connection.

• Idle Timeout — Idle timeout defines a period of time after which ASA terminates secure connections, if no communication activity occurs.

• Dead-Peer Detection (DTD) — DTD ensures that ASA and Cisco AnyConnect Secure Mobility Client can quickly detect failed connections.

Set ASA Session Parameters

Cisco recommends that you set up the ASA session parameters as follows to optimize the end user experience for Cisco AnyConnect Secure Mobility Client.
Procedure

**Step 1**
Set up Cisco AnyConnect to use DTLS.

For more information, see the *Enabling Datagram Transport Layer Security (DTLS) with AnyConnect (SSL) Connections* topic in the *Configuring AnyConnect Features Using ASDM* chapter of the *Cisco AnyConnect VPN Client Administrator Guide, Version 2.0*.

**Step 2**
Set up session persistence (auto-reconnect).

a) Use ASDM to open the VPN client profile.
b) Set the *Auto Reconnect Behavior* parameter to *Reconnect After Resume*.

For more information, see the *Configuring Auto Reconnect* topic in the *Configuring AnyConnect Features* chapter (Release 2.5) or *Configuring VPN Access* chapter (releases 3.0 or 3.1) of the *Cisco AnyConnect Secure Mobility Client Administrator Guide* for your release.

**Step 3**
Set the idle timeout value.

a) Create a group policy that is specific to Cisco Jabber clients.
b) Set the idle timeout value to 30 minutes.

For more information, see the *vpn-idle-timeout* section of the *Cisco ASA 5580 Adaptive Security Appliance Command Reference* for your release.

**Step 4**
Set up Dead Peer Detection (DPD).

a) Disable server-side DPD.
b) Enable client-side DPD.

For more information, see the *Enabling and Adjusting Dead Peer Detection* topic of the *Configuring VPN* chapter of the *Cisco ASA 5500 Series Configuration Guide using the CLI, 8.4 and 8.6*.

---

**Define Mobile and Remote Access Policies for User Profiles**

When your users are working outside your corporate network, you can add Mobile and Remote Access (MRA) access policies in Cisco Unified Communications Manager, and control what services in Cisco Jabber they can access. The MRA access policies are assigned to user profiles and you can allocate different MRA access policies to users in your organization.

**Before you begin**

Mobile and Remote Access policies is supported on Cisco Unified Communications Manager Release 12.0 or later, Cisco Expressway X8.10 or later, and in an OAuth enabled environment.

**Procedure**

**Step 1**
In *Cisco Unified CM Administration*, go to *User Management* and select *End User*.

**Step 2**
Click *Find* to search for end-users, and select an end-user.

**Step 3**
In the *End User Configuration* window, click *View Details* for a *User Profile*. 
Step 4  In the Mobile and Remote Access Policy section, select **Enable Mobile and Remote Access**.

Step 5  In the Jabber Policies drop-down, choose a policy:

- **No Service**—Users cannot access any Cisco Jabber service.
- **IM & Presence only**—Users can access only IM, presence, voicemail, and contact search.
- **IM & Presence, Voice and Video calls**—Users can access all Cisco Jabber services.

Step 6  Select **Save**.
Define Mobile and Remote Access Policies for User Profiles
CHAPTER 18

Quality of Service

- Quality of Service Options, on page 151
- Enable Media Assure, on page 151
- Supported Codecs, on page 153
- Define a Port Range on the SIP Profile, on page 154
- Define a Port Range in Jabber-config.xml, on page 154
- Set DSCP Values, on page 154

Quality of Service Options

Use the following options to configure the quality of service for Cisco Jabber:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Media Assure, on page 151</td>
<td>Configure Media Assure in Cisco Unified Communications Manager.</td>
</tr>
<tr>
<td>Supported Codecs, on page 153</td>
<td>Review the supported Codecs for each client.</td>
</tr>
<tr>
<td>Define a Port Range on the SIP Profile, on page 154</td>
<td>Configure Port Ranges in Cisco Unified Communications Manager</td>
</tr>
<tr>
<td>Define a Port Range in Jabber-config.xml, on page 154</td>
<td>Configure Port Ranges in the jabber-config.xml file.</td>
</tr>
<tr>
<td>Set DSCP Values, on page 154</td>
<td>Configure Differentiated Services Code Point (DSCP) values.</td>
</tr>
</tbody>
</table>

Enable Media Assure

Media Assure enhances the quality of real-time media on all network types so that your meetings aren't interrupted because of poor media quality.
**Before you begin**

Media Assure is supported for video on Cisco Unified Communications Manager Release 10.x or later and for audio and video on Cisco Unified Communications Manager Release 11.5 or later.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open the <strong>Cisco Unified CM Administration</strong> interface.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select <strong>Device &gt; Device Settings &gt; Sip Profile</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Select your profile from the available list.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the <strong>SDP Information</strong> section, select <strong>Pass all unknown SDP attributes</strong> value for <strong>SDP Transparency Profile</strong>.</td>
</tr>
</tbody>
</table>
| Step 5 | Select **Apply Config**.  
All SIP devices using this profile must restart before any changes are applied. |
## Supported Codecs

<table>
<thead>
<tr>
<th>Type</th>
<th>Codec</th>
<th>Codec Type</th>
<th>Cisco Jabber for Android</th>
<th>Cisco Jabber for iPhone and iPad</th>
<th>Cisco Jabber for Mac</th>
<th>Cisco Jabber for Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td>G.711</td>
<td>A-law</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>µ-law/Mu-law</td>
<td></td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Supports normal mode.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>G.722</td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>G.722.1</td>
<td>24 kb/s and 32 kb/s</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Supports normal mode.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>G.729</td>
<td></td>
<td></td>
<td>No</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Does not support Visual Voicemail with G.729; however, you can access voice messages using G.729 and the <strong>Call Voicemail</strong> feature.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>G.729a</td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Minimum requirement for low-bandwidth availability.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Only codec that supports low-bandwidth mode.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Supports normal mode.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Opus</td>
<td></td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Video</td>
<td>H.264/AVC</td>
<td></td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Voicemail</td>
<td>G.711</td>
<td>A-law</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td></td>
<td>µ-law / Mu-law (default)</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td>GSM 06.10</td>
<td></td>
<td></td>
<td>Yes</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PCM linear</td>
<td></td>
<td></td>
<td>Yes</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

If users have issues with voice quality when using Cisco Jabber for Android or Cisco Jabber for iPhone and iPad, they can turn low-bandwidth mode on and off in the client settings.
Define a Port Range on the SIP Profile

The client uses the port range to send RTP traffic across the network. The client divides the port range equally and uses the lower half for audio calls and the upper half for video calls. As a result of splitting the port range for audio media and video media, the client creates identifiable media streams. You can then classify and prioritize those media streams by setting DSCP values in the IP packet headers.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Device Settings > SIP Profile.
Step 3 Find the appropriate SIP profile or create a new SIP profile.

The SIP Profile Configuration window opens.

Step 4 Specify whether you want common or separate port ranges for audio and video. If you are separating your audio and video port ranges, provide audio and video ports. Specify the port range in the following fields:

• **Start Media Port** — Defines the start port for media streams. This field sets the lowest port in the range.
• **Stop Media Port** — Defines the stop port for media streams. This field sets the highest port in the range.

Step 5 Select Apply Config and then OK.

Define a Port Range in Jabber-config.xml

This topic applies to Cisco Jabber for Windows.

Procedure

To specify a port range to use when users share their screen from a chat window in Cisco Jabber for Windows, see "SharePortRangeStart" in the Cisco Jabber Parameters Reference Guide.

Set DSCP Values

Set Differentiated Services Code Point (DSCP) values in RTP media packet headers to prioritize Cisco Jabber traffic as it traverses the network.
Set DSCP Values on Cisco Unified Communications Manager

You can set DSCP values for audio media and video media on Cisco Unified Communications Manager. Cisco Jabber can then retrieve the DSCP values from the device configuration and apply them directly to the IP headers of RTP media packets.

Restriction

For later operating systems such as Microsoft Windows 7, Microsoft implements a security feature that prevents applications from setting DSCP values on IP packet headers. For this reason, you should use an alternate method for marking DSCP values, such as Microsoft Group Policy.

For more information on configuring flexible DSCP values, refer to Configure Flexible DSCP Marking and Video Promotion Service Parameters.

Procedure

Step 1
Open the Cisco Unified CM Administration interface.

Step 2
Select System > Service Parameters.

Step 3
Select the appropriate server and then select the Cisco CallManager service.

Step 4
Locate the Clusterwide Parameters (System - QOS) section.

Step 5
Specify DSCP values as appropriate and then select Save.

Set DSCP Values with Group Policy

If you deploy Cisco Jabber for Windows on a later operating system such as Microsoft Windows 7, you can use Microsoft Group Policy to apply DSCP values.

Complete the steps in the following Microsoft support article to create a group policy: http://technet.microsoft.com/en-us/library/cc771283%28v=ws.10%29.aspx

You should create separate policies for audio media and video media with the following attributes:

<table>
<thead>
<tr>
<th>Attributes</th>
<th>Audio Policy</th>
<th>Video Policy</th>
<th>Signaling Policy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application name</td>
<td>CiscoJabber.exe</td>
<td>CiscoJabber.exe</td>
<td>CiscoJabber.exe</td>
</tr>
<tr>
<td>Protocol</td>
<td>UDP</td>
<td>UDP</td>
<td>TCP</td>
</tr>
<tr>
<td>Port number or range</td>
<td>Corresponding port number or range from the SIP profile on Cisco Unified Communications Manager.</td>
<td>Corresponding port number or range from the SIP profile on Cisco Unified Communications Manager.</td>
<td>5060 for SIP 5061 for secure SIP</td>
</tr>
<tr>
<td>DSCP value</td>
<td>46</td>
<td>34</td>
<td>24</td>
</tr>
</tbody>
</table>
Set DSCP Values on the Client

For some configurations, there is an option to enable differentiated services for calls in the Cisco Jabber for Mac client and Cisco Jabber for mobile clients.

Important

This option is enabled by default. Cisco recommends not disabling this option unless you are experiencing issues in the following scenarios:

- You can hear or see other parties, but you cannot be heard or seen
- You are experiencing unexpected Wi-Fi disconnection issues

Disabling differentiated service for calls may degrade audio and video quality.

Note

If EnableDSCPPacketMarking is configured as true or false, then the user cannot see Enable Differentiated Service for Calls in the Cisco Jabber clients.

Procedure

Step 1
In Cisco Jabber for Mac, go to Jabber > Preferences > Calls > Advanced and select Enable Differentiated Service for Calls.

Step 2
In Cisco Jabber for mobile clients, go to Jabber > Settings > Audio and Video and select Enable Differentiated Service for Calls.

Set DSCP Values on the Network

You can configure switches and routers to mark DSCP values in the IP headers of RTP media.

To set DSCP values on the network, you must identify the different streams from the client application.

- Media Streams — Because the client uses different port ranges for audio streams and video streams, you can differentiate audio media and video media based on those port range. Using the default port ranges in the SIP profile, you should mark media packets as follows:
  - Audio media streams in ports from 16384 to 24574 as EF
  - Video media streams in ports from 24575 to 32766 as AF41

- Signaling Streams — You can identify signaling between the client and servers based on the various ports required for SIP, CTI QBE, and XMPP. For example, SIP signaling between Cisco Jabber and Cisco Unified Communications Manager occurs through port 5060.

You should mark signaling packets as AF31.
CHAPTER 19

Integrate Cisco Jabber with Applications

- Configure Presence in Microsoft SharePoint 2010 and 2013, on page 157
- Client Availability, on page 158
- Protocol Handlers, on page 159

Configure Presence in Microsoft SharePoint 2010 and 2013

If your organization defines users' profiles where their IM address is different from their email address, then additional configuration is required to enable presence integration between the client and Microsoft SharePoint 2010 and 2013.

Before you begin

- For Cisco Jabber for Windows clients only.
- Ensure that all sites are in sync with Microsoft SharePoint Central Administration (CA).
- Ensure that synchronization between Microsoft SharePoint and Active Directory is set up.

Procedure

Step 1
If you have Microsoft SharePoint 2013, update the SharePoint CA profile pages for users with the following information:

a) For the **SIP Address** profile field, leave it blank.
b) In the **Work email** profile field, enter the user profile. For example, john4mail@example.pst.

Step 2
If you have Microsoft SharePoint 2010, update the SharePoint CA profile pages for users with the following information:

a) For the **SIP Address** profile field, enter the user profile. For example, john4mail@example.pst
b) In the **Work email** profile field, leave it blank.
Client Availability

Users can define whether their availability reflects their calendar events by setting an option to let others know they are in a meeting from the Status tab of the Options window from the client. This option synchronizes events in your calendar with your availability. The client only displays In a meeting availability for supported integrated calendars.

The client supports using two sources for the In a meeting availability:

Note

Cisco Jabber for mobile clients support this meeting integration feature from Cisco Jabber 11.7 release.

- Microsoft Exchange and Cisco Unified Communication Manager IM and Presence Integration — Applies to on-premises deployments. The Include Calendar information in my Presence Status field in Cisco Unified Presence is the same as the In a meeting option in the client. Both fields update the same value in the Cisco Unified Communication Manager IM and Presence database.

If users set both fields to different values, then the last field that the user sets takes priority. If users change the value of the Include Calendar information in my Presence Status field while the client is running, the users must restart the client for those changes to apply.

- Cisco Jabber Client — Applies to on-premises and cloud-based deployments. You must disable Cisco Unified Communication Manager IM and Presence and Microsoft Exchange integration for the client to set the In a meeting availability. The client checks if integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange is on or off. The client can only set availability if integration is off.

The following deployment scenarios describe how availability is created:

<table>
<thead>
<tr>
<th>Deployment Scenario</th>
<th>You select In a meeting (according to my calendar)</th>
<th>You do not select In a meeting (according to my calendar)</th>
</tr>
</thead>
<tbody>
<tr>
<td>You enable integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange.</td>
<td>Cisco Unified Communication Manager IM and Presence sets availability status</td>
<td>Availability status does not change</td>
</tr>
<tr>
<td>You do not enable integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange.</td>
<td>Client sets availability status</td>
<td>Availability status does not change</td>
</tr>
<tr>
<td>Cloud-based deployments</td>
<td>Client sets availability status</td>
<td>Availability status does not change</td>
</tr>
</tbody>
</table>

Additionally, the following table describes availability that is supported differently by each deployment scenarios:
Availability Enabled by Integrating Cisco Unified Communication Manager IM and Presence with Microsoft Exchange

<table>
<thead>
<tr>
<th>Availability Enabled in the Client</th>
<th>Availability Enabled by Integrating Cisco Unified Communication Manager IM and Presence with Microsoft Exchange</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Offline in a meeting</strong> availability is not supported.</td>
<td><strong>Offline in a meeting</strong> availability is supported.</td>
</tr>
<tr>
<td><strong>In a meeting</strong> availability is supported for non-calendar events.</td>
<td><strong>In a meeting</strong> availability is not supported for non-calendar events.</td>
</tr>
<tr>
<td><strong>Note</strong> Offline in a meeting availability refers to when the user is not logged in to the client but an event exists in the user's calendar. Non-calendar events refer to events that do not appear in the user's calendar, such as instant meetings, <strong>Offline</strong>, or <strong>On a call</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

## Protocol Handlers

Cisco Jabber registers the following protocol handlers with the operating system to enable click-to-call or click-to-IM functionality from web browsers or other applications:

- **XMPP:** or XMPP://
  Starts an instant message and opens a chat window in Cisco Jabber.

- **IM:** or IM://
  Starts an instant message and opens a chat window in Cisco Jabber.

- **TEL:** or TEL://
  Starts an audio or video call with Cisco Jabber.

  **Note** TEL is registered by Apple native phone. It cannot be used to cross launch Cisco Jabber for iPhone and iPad.

- **CISCOTEL:** or CISCOTEL://
  Starts an audio or video call with Cisco Jabber.

- **SIP:** or SIP://
  Starts an audio or video call with Cisco Jabber.

- **CLICKTOCALL:** or CLICKTOCALL://
  Starts an audio or video call with Cisco Jabber.

## Registry Entries for Protocol Handlers

To register as a protocol handler, the client writes to the following locations in the Microsoft Windows registry:

- **HKEY_CLASSES_ROOT\tel\shell\open\command**
In the case where two or more applications register as handlers for the same protocol, the last application to write to the registry takes precedence. For example, if Cisco Jabber registers as a protocol handler for XMPP: and then a different application registers as a protocol handler for XMPP:, the other application takes precedence over Cisco Jabber.

**Protocol Handlers on HTML Pages**

You can add protocol handlers on HTML pages as part of the `href` attribute. When users click the hyperlinks that your HTML pages expose, the client performs the appropriate action for the protocol.

**TEL and IM Protocol Handlers**

Example of the TEL: and IM: protocol handlers on an HTML page:

```html
<html>
<body>
  <a href="TEL:1234">Call 1234</a><br/>
  <a href="IM:msmith@domain">Send an instant message to Mary Smith</a>
</body>
</html>
```

In the preceding example, when users click the hyperlink to call 1234, the client starts an audio call to that phone number. When users click the hyperlink to send an instant message to Mary Smith, the client opens a chat window with Mary.

**CISCOTEL and SIP Protocol Handlers**

Example of the CISCOTEL and SIP protocol handlers on an HTML page:

```html
<html>
<body>
  <a href="CISCOTEL:1234">Call 1234</a><br/>
  <a href="SIP:msmith@domain">Call Mary</a><br/>
  <a href="CISCOTELCONF:msmith@domain;amckenzi@domain">Weekly conference call</a>
</body>
</html>
```

In the preceding example, when users click the *Call 1234 or Call Mary* hyperlinks, the client starts an audio call to that phone number.

**XMPP Protocol Handlers**

Example of a group chat using the XMPP: protocol handler on an HTML page:

```html
<html>
<body>
  <a href="XMPP:msmith@domain;amckenzi@domain">Create a group chat with Mary Smith and Adam McKenzie</a>
</body>
</html>
```

In the preceding example, when users click the hyperlink to create a group chat with Mary Smith and Adam McKenzie, the client opens a group chat window with Mary and Adam.
Tip

Add lists of contacts for the XMPP: and IM: handlers to create group chats. Use a semi-colon to delimit contacts, as in the following example:

XMPP:user_a@domain.com;user_b@domain.com;user_c@domain.com;user_d@domain.com

Add Subject Lines and Body Text

You can add subject lines and body text to any of the protocol handlers so that when users click on the hyperlink to create a person-to-person or group chat, the client opens a chat window with pre-populated subject line and body text.

Subject and body text can be added in any of the following scenarios:

- Using any supported protocol handler for instant messaging on the client
- For either person-to-person chats or for group chats
- Including a subject and body text, or one or the other

In this example, when users click on the link below it opens a person-to-person chat window with a pre-populated body text of I.T Desk:

xmpp:msmith@domain?message;subject=I.T.%20Desk

In this example, when users click on the link below it opens a Start Group Chat dialog box with a topic of I.T Desk, and the input box for the chat window is pre-populated with the text Jabber 10.5 Query:

im:user_a@domain.com;user_b@domain.com;user_c@domain.com?message;subject=I.T%20Desk;body=Jabber%2010.5%20Query

Protocol Handler Supported Parameters

Cross Launch for Mobile Clients

The Cisco Jabber for mobile clients provide you with the ability to return to a specified application. For example if you create a ciscotel URI link that dials a number, you can add in the application name as a parameter and when the call has completed the user is prompted to return to that application.


- CrossLaunchBackAppName—Users are prompted with the name of an application that Cisco Jabber cross launches back to when a call ends.
  - none (default)—No application in the dialog box.
  - app_name—The application name that is displayed in the dialog box.

- CrossLaunchBackSchema—Specifies the schema used when a call is ended.
  - none (default)—You stay in Cisco Jabber.
  - schema—The schema used to cross launch back the application.
**Supported Separators**

When creating a URI link for HTML pages, you can use a semi-colon to separate the characters. This is supported with the SIP, Tel, CiscoTel and ClickToCall protocol handlers. In the following example, the link will create a conference call with the two numbers:

```
tel:123;123
```

The IM protocol supports the semi-colon separator. In the following example, the link will create a group chat with the two participants:

```
im:participant1@example.com,participant2@example.com
```

**DTMF Support**

**Enter DTMF in the IM Window**

In the conversation window of the client, you can enter a protocol handler including DTMF digits and the client will create a link that participants can use. The supported protocols are TEL, CISCOTEL, SIP, CLICKTOCALL, CISCOIM, IM, and XMPP. The supported parameters are numbers or SIP URIs.

In the following example, the number is 1800123456, the PIN for entry is 5678#, using the TEL URI link this example creates a meeting link:

```
tel:1800123456,,,5678#
```

**Enter DTMF in an Active Call**

During a call, users can copy and paste DTMF digits into the call window of the client. Users can easily enter Meeting IDs, Attendee IDs, and PINs from their meeting invitation. If you enter alphanumeric strings during an active call, they are interpreted as the corresponding numbers on the keypad, and commas represent a one second pause between DTMF signals.

**Supported DTMF Signals**

If a user enters a DTMF signal that isn't supported by the system that Jabber is calling, then Jabber will not send the input from the user.

Cisco Jabber for Windows and mobiles support the following DTMF signals:

- 0 to 9
- #
- *
- A to D
PART IV

Troubleshooting

• Troubleshooting, on page 165
Troubleshooting

- Cisco Jabber Diagnostic Tool, on page 165
- Contact Resolution Tool, on page 166

Cisco Jabber Diagnostic Tool

Windows and Mac

The Cisco Jabber Diagnostics tool provides configuration and diagnostic information for the following services:

- Service Discovery
- Webex
- Cisco Unified Communications Manager Summary
- Cisco Unified Communications Manager Configuration
- Voicemail
- Certificate Validation
- Active Directory
- DNS Records

To access the tool, users must bring the hub, call, or chat window into focus and select $\text{Ctrl + Shift + D}$. Users can update the data by selecting Reload. Users can also save the information to an html file by selecting Save.

The tool is available by default. To disable this tool:

- For Jabber for Windows set the DIAGNOSTICSTOOLENABLED installation parameter to FALSE.
- For Jabber for Mac include the DiagnosticsToolEnabled parameter in the configuration URL with the value set to FALSE.

For more information about these parameters, see On-Premises Deployment for Cisco Jabber, or Cloud and Hybrid Deployments for Cisco Jabber, depending on your deployment.
**Android, iPhone, and iPad**

If users are unable to sign into Cisco Jabber or your Cisco Jabber IM and Phone services aren’t connected, they can use the **Diagnose Error** option to check what’s causing the issue.

Users can tap **Diagnose Error** option either from the **Sign In** page or from the warning notification they get when connecting to Cisco Jabber services. Cisco Jabber then verifies:

- If there are any network issues
- If Cisco Jabber servers are reachable
- If Cisco Jabber can reconnect

If any of these checks fail, Cisco Jabber displays an error report with the possible solution. If the issue persists, they can send a problem report.

**Contact Resolution Tool**

Applies to Cisco Jabber for Windows.

The Contact Resolution tool provides information for the available directory sources and a search tool to display contact search results.

To access the Contact Resolution tool, users must bring the hub, call, or chat window into focus and select **Ctrl + Shift + C**.

The tool is available by default and can be disabled by setting the ContactsDiagnosticsToolEnabled installation parameter to FALSE.

The tool provides the following search options:

- **Predictive**—The search takes the entered string and displays the matching records. This is the same search that is used when a user searches for a contact in the client.

- **Equivalence**—This search type includes further options to resolve the search string:
  - URI or JID
  - Phone number
  - SIP URI
  - Email

  The search will return the records matching the specified values.

For more information about the ContactsDiagnosticsToolEnabled installation parameter, see *On-Premises Deployment for Cisco Jabber*, or *Cloud and Hybrid Deployments for Cisco Jabber*, depending on your deployment.