Configure the Clients

 Client Configuration Workflow, page 1

Client Configuration Workflow

Procedure
Command or Action Purpose
Step 1 Introduction to Client Configuration, on page 1
Step 2 Create and Host Client Configuration Files, on page 2
Step 3 Set Parameters on Phone Configuration for Desktop Clients, on page
7
Step 4 Set Parameters on Phone Configuration for Mobile Clients, on page 8
Step 5 Configure Proxy Setting, on page 9

Introduction to Client Configuration

Cisco Jabber can retrieve configuration settings from the following sources:

* Service Profiles — You can configure some client settings in UC service profiles on Cisco Unified
Communications Manager release 9 and later. When users launch the client, it discovers the Cisco
Unified Communications Manager home cluster using a DNS SRV record and automatically retrieves
the configuration from the UC service profile.

Applies to on-premises deployments only.

* Phone Configuration — You can set some client settings in the phone configuration on Cisco Unified
Communications Manager release 9 and later. The client retrieves the settings from the phone
configuration in addition to the configuration in the UC service profile.

Applies to on-premises deployments only.
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* Cisco Unified Communications Manager IM and Presence Service — You can enable instant messaging
and presence capabilities and configure certain settings such as presence subscription requests.

In the Advanced settings window, if you select Cisco IM & Presence, the client retrieves UC services
from Cisco Unified Communications Manager IM and Presence Service. The client does not use service
profiles or SSO discovery.

Applies to on-premises deployments only.

* Client Configuration Files — You can create XML files that contain configuration parameters. You then
host the XML files on a TFTP server. When users sign in, the client retrieves the XML file from the
TFTP server and applies the configuration.

Applies to on-premises and cloud-based deployments.

* Cisco WebEx Administration Tool — You can configure some client settings with the Cisco WebEx
Administration Tool.

You can upload a jabber-config.xml client configuration file into the Cisco WebEx Administration
Tool. You can apply separate configuration files for groups in the Cisco WebEx Messenger Administration
Tool. When the client successfully connects to Cisco WebEx Messenger it downloads the XML file and
the configuration is applied.

The client will use the following order for configuration settings:
1 Settings in Cisco WebEx Messenger Administration Tool

2 Settings in jabber-config.xml file from Cisco WebEx Messenger Administration Tool.

)

Note  Group configuration file settings take priority over the configuration file in Cisco WebEx
Messenger Administration Tool.

3 Settings in jabber-config.xml file from the TFTP server.
If there are any conflicts with configuration settings, the settings set in Cisco WebEx Administration

tool will take priority over this configuration file.

Applies to cloud-based deployments only.

Create and Host Client Configuration Files

For on-premises and hybrid cloud-based deployments, create client configuration files and host them on the
Cisco Unified Communications Manager TFTP service.

For cloud-based deployments, configure the client with the Cisco WebEx Administration Tool. However,
you can optionally set up a TFTP server to configure the client with settings that are not available in Cisco
WebEx Administration Tool.

For Cisco Jabber for iPhone and iPad and Cisco Jabber for Android, you must create a global configuration
file to set up:

* Directory integration for on-premises deployments.

* Voicemail service credentials for hybrid-cloud deployments.
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A

Note  Inmostenvironments, Cisco Jabber for Windows and Cisco Jabber for Mac do not require any configuration
to connect to services. Create a configuration file only if you require custom content such as automatic
updates, problem reporting, or user policies and options.

Before You Begin

Note the following configuration file requirements:

* Configuration filenames are case-sensitive. Use lowercase letters in the filename to prevent errors and
to ensure the client can retrieve the file from the TFTP server.

* You must use utf-8 encoding for the configuration files.

* The client cannot read configuration files that do not have a valid XML structure. Check the structure
of your configuration file for closing elements and confirm that elements are nested correctly.

« Valid XML character entity references only are permitted in your configuration file. For example, use
&amp; instead of &. If your XML contains invalid characters, the client cannot parse the configuration
file.

To validate your configuration file, open the file in Microsoft Internet Explorer.
o If Internet Explorer displays the entire XML structure, your configuration file does is valid.

o If Internet Explorer displays only part of the XML structure, it is likely that your configuration file
contains invalid characters or entities.

Procedure
Command or Action Purpose

Step 1 Specify Your TFTP Server Address, on |Specify your TFTP server address for client to
page 3 enable access to your configuration file.

Step 2 Create Global Configurations, on page |Configure the clients for users in your deployment.
4

Step 3 Create Group Configurations, on page | Apply different configuration to different set of
4 users.

Step 4 Host Configuration Files, on page 5 Host configuration files on any TFTP server.

Step 5 Restart Your TFTP Server, on page 6 Restart the TFTP server before the client can

access the configuration files.

Specify Your TFTP Server Address

The client gets configuration files from a TFTP server. The first step in configuring the client is to specify
your TFTP server address so the client can access your configuration file.
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Attention  If Cisco Jabber gets the cisco-uds SRV record from a DNS query, it can automatically locate the
user's home cluster. As a result, the client can also locate the Cisco Unified Communications Manager
TFTP service.

You do not need to specify your TFTP server address if you deploy the cisco-uds SRV record.

Specify TFTP Servers in Phone Mode

If you deploy the client in phone mode you can provide the address of the TFTP server as follows:
* Users manually enter the TFTP server address when they start the client.
* You specify the TFTP server address during installation with the TFTP argument.

* You specify the TFTP server address in the Microsoft Windows registry.

Create Global Configurations

The client downloads the global configuration file from your TFTP server during the login sequence. Configure
the client for all users in your deployment.

Before You Begin

If the structure of your configuration file is not valid, the client cannot read the values you set. Review the
XML samples in this chapter for more information.

Procedure

Step1 Create a file named jabber-config.xml with any text editor.
» Use lowercase letters in the filename.

» Use UTF-8 encoding.

Step2 Define the required configuration parameters in jabber—-config.xml.

Step3 Host the group configuration file on your TFTP server.
If your environment has multiple TFTP servers, ensure that the configuration file is the same on all TFTP
Servers.

Create Group Configurations

Group configuration files apply to subsets of users and are supported on Cisco Jabber for desktop (CSF
devices) and on Cisco Jabber for mobile devices. Group configuration files take priority over global
configuration files.

Cloud and Hybrid Deployments for Cisco Jabber 11.6
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Step 1

Step 2
Step 3

Step 4

Create and Host Client Configuration Files .

If you provision users with CSF devices, specify the group configuration filenames in the Cisco Support
Field field on the device configuration. If users do not have CSF devices, set a unique configuration filename
for each group during installation with the TFTP_FILE NAME argument.

Before You Begin

« If the structure of your configuration file is not valid, the client cannot read the values you set. Review
the XML samples in this chapter for more information.

Procedure

Create an XML group configuration file with any text editor.
The group configuration file can have any appropriate name; for example, jabber-groupa-config.xml.

Define the required configuration parameters in the group configuration file.
Add the group configuration file to applicable CSF devices.

a) Open the Cisco Unified CM Administration interface.
b) Select Device > Phone.
¢) Find and select the appropriate CSF device to which the group configuration applies.
d) In the Phone Configuration window, navigate to Product Specific Configuration Layout > Desktop
Client Settings.
e) In the Cisco Support Field field, enter
configurationfile=group configuration file name.xml.For example, enter
configurationfile=groupa-config.xml.
Note  If you host the group configuration file on your TFTP server in a location other than the default
directory, you must specify the path and the filename; for example,
configurationfile=/customFolder/groupa-config.xml.

Do not add more than one group configuration file. The client uses only the first group
configuration in the Cisco Support Field field.
f) Select Save.

Host the group configuration file on your TFTP server.

Host Configuration Files

You can host configuration files on any TFTP server. However, Cisco recommends hosting configuration
files on the Cisco Unified Communications Manager TFTP server, which is the same as that where the device
configuration file resides.
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Procedure

Step1 Open the Cisco Unified OS Administration interface on Cisco Unified Communications Manager.
Step2 Select Software Upgrades > TFTP File Management.
Step3 Select Upload File.
Step4 Select Browse in the Upload File section.
Step5 Select the configuration file on the file system.
Step6 Do not specify a value in the Directory text box in the Upload File section.
You should leave an empty value in the Directory text box so that the configuration file resides in the default
directory of the TFTP server.
Step7 Select Upload File.
Restart Your TFTP Server
You must restart your TFTP server before the client can access the configuration files.
Procedure
Step1 Open the Cisco Unified Serviceability interface on Cisco Unified Communications Manager.
Step2 Select Tools > Control Center - Feature Services.
Step3 Select Cisco Tftp from the CM Services section.
Step4 Select Restart.
A window displays to prompt you to confirm the restart.
Step5 Select OK.
The Cisco Tftp Service Restart Operation was Successful status displays.
Step 6 Sclect Refresh to ensure the Cisco Tftp service starts successfully.

What to Do Next

To verify that the configuration file is available on your TFTP server, open the configuration file in any
browser. Typically, you can access the global configuration file at the following URL:
http://tftp server address:6970/jabber-config.xml

Configuration File

For detailed information on the jabber-config.xml configuration file structure, group elements, parameters,
and examples, see the Parameters Reference Guide for Cisco Jabber.
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Set Parameters on Phone Configuration for Desktop Clients

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco
Unified Communications Manager:

Enterprise Phone Configuration

Applies to the entire cluster.

)

Note  For users with only IM and Presence Service capabilities (IM only), you must
set phone configuration parameters in the Enterprise Phone Configuration
window.

Common Phone Profile Configuration

Applies to groups of devices and takes priority over the cluster configuration.

Cisco Unified Client Services Framework (CSF) Phone Configuration

Applies to individual CSF devices and takes priority over the group configuration.

Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the Product Specific Configuration
Layout section of the phone configuration and maps corresponding parameters from the client configuration
file:

Desktop Client Settings Configuration Description

Video Calling Enables or disables video capabilities.
Enabled (default)

Users can send and receive video calls.
Disabled

Users cannot send or receive video calls.

Restriction  This parameter is available only on the CSF
device configuration.

File Types to Block in File Transfer Restricts users from transferring specific file types.
Set a file extension as the value, for example, . exe.

Use a semicolon to delimit multiple values, for example,

.exe;.msi;.rar;.zip

Cloud and Hybrid Deployments for Cisco Jabber 11.6
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Desktop Client Settings Configuration Description

Automatically Start in Phone Control Sets the phone type for users when the client starts for the
first time. Users can change their phone type after the initial
start. The client then saves the user preference and uses it
for subsequent starts.

Enabled
Use the desk phone device for calls.
Disabled (default)
Use the software phone (CSF) device for calls.

Jabber For Windows Software Update Specifies the URL to the XML file that holds client update
Server URL information. The client uses this URL to retrieve the XML
file from your web server.

In hybrid cloud-based deployments, you should use the Cisco
WebEx Administration Tool to configure automatic updates.

Problem Report Server URL Specifies the URL for the custom script that allows users to
submit problem reports.

Set Parameters on Phone Configuration for Mobile Clients

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco
Unified Communications Manager:

* Cisco Dual Mode for iPhone (TCT) Configuration — Applies to individual TCT devices and takes
priority over the group configuration.

* Cisco Jabber for Tablet (TAB) Configuration — Applies to individual TAB devices and takes priority
over the group configuration.

Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the Product Specific Configuration
Layout section of the phone configuration and maps corresponding parameters from the client configuration

file:

Parameter Description

On-Demand VPN URL URL for initiating on-demand VPN.
Note  Applicable for iOS

only.

Preset Wi-fi Networks Enter the SSIDs for Wi-Fi networks (SSIDs) approved by
your organization. Separate SSIDs with a forward slash (/).
Devices do not connect to secure connect if connected to one
of the entered Wi-Fi networks.

Cloud and Hybrid Deployments for Cisco Jabber 11.6
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Parameter Description
Default Ringtone Sets the default ringtone to Normal or Loud.
Video Capabilities Enables or disables video capabilities.

* Enabled (default) — Users can send and receive video
calls.

 Disabled — Users cannot send or receive video calls.

Dial via Office Enables or disables Dial via Office.
Note TCT and BOT devices L
only. * Enabled — Users can dial via office.

* Disabled (default) — Users cannot dial via office.

Configure Proxy Setting
The client uses proxy settings to connect to services.
The following limitations apply when using a proxy for these HTTP requests:
* Proxy Authentication is not supported.
 Wildcards in the bypass list are supported.

* Cisco Jabber supports proxy for HTTP request using HTTP CONNECT, but does not support proxy
when using HTTPS CONNECT.

Configure Proxy Settings for Cisco Jabber for Windows
Configure proxy settings for Windows in the Local Area Network (LAN) settings for Internet properties.

Procedure

Step1 In the Connections tab select LAN Settings.
Step2 Configure a proxy using one of the following options:

* For automatic configuration, specify a .pac file URL.

* For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Mac

Configure proxy settings for Mac in System Preferences.

Cloud and Hybrid Deployments for Cisco Jabber 11.6
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Procedure

Step1 Select System Preferences > Network
Step2 Choose your network service from the list and select Advanced > Proxies .

Step3 Configure a proxy using one of the following options:
* For automatic configuration, specify a .pac file URL.

* For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber iPhone and iPad

Configure proxy settings in the Wi-Fi settings of an iOS device using one of the following methods:

Procedure

Step1 Sclect Wi-Fi > HTTP PROXY > Auto and specify a .pac file URL as the automatic configuration script.
Step2 Select Wi-Fi > HTTP PROXY > Manual and specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Android

Procedure

Configure proxy settings in the Wi-Fi settings of an Android device using one of the following methods:

* Specify a .pac file URL as the automatic configuration script in the Wi-Fi > Modify Network > Show
Advanced Options > Proxy Settings > Auto tab.
Note  This method is only supported on devices with Android OS 5.0 and later, and Cisco DX series

devices.

* Specify an explicit proxy address in the Wi-Fi Networks > Modify Network > Show Advanced Options
> Proxy Settings > Auto tab.
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