THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: http://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

© 2017 Cisco Systems, Inc. All rights reserved.
CONTENTS

CHAPTER 1  Cisco Jabber Overview  1
   Purpose of this Guide  1
   About Cisco Jabber  1

CHAPTER 2  Configuration and Installation Workflows  3
   Purpose of Configuration Workflows  3
   Prerequisites  3
       Apply COP File for BFCP Capabilities  3
       Activate and Start Essential Services  4
       Install Cisco Options Package File for Devices  5
   Deployment and Installation Workflow for an On-Premises Deployment  6
       Full UC Mode Deployment  6
       Jabber IM only Mode Deployment  7
       Phone Mode Deployment  8

CHAPTER 3  Users  9
   Configure Users  9
       Enable Synchronization  9
       Populate User ID and Directory URI  10
           Specify an LDAP Attribute for the User ID  11
           Specify an LDAP Attribute for the Directory URI  11
       Perform Synchronization  12
       Assign Roles and Groups  13
       Authentication Options  13
           Enable SAML SSO in the Client  13
           Authenticate with the LDAP Server  14

CHAPTER 4  Contact Source  17
CHAPTER 5
Configure Instant Messaging and Presence Service 27
IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 10.5 and Later 27
IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later 28
Add an IM and Presence Service 28
Apply an IM and Presence Service 29
Configure IM Address Scheme 30
Enable Message Settings 30
Prepopulate Contact Lists in Bulk 31
Configure Users with IM and Presence Service 32
Configure Users Individually 32
Configure Users in Bulk 32
Associate User with Line 33

CHAPTER 6
Configure Voicemail 35
Configure Voicemail for an On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later 35
Configure Cisco Unity Connection for Use with Cisco Jabber 36
Configure Retrieval and Redirection 37
Add a Voicemail Service 38
Apply a Voicemail Service 39
Set a Voicemail Credentials Source 40
CHAPTER 7

Configure WebEx Conferencing 43
  Configure Conferencing for an On-Premises Deployment 43
  Configure On-Premises Conferencing using WebEx Meetings Server 43
    Authenticate Cisco WebEx Meetings Server 43
    Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager 44
      Add the Cisco WebEx Meetings Server to a Service Profile 45

CHAPTER 8

Configure Deskphone Control 47
  Prerequisites 47
  Configure Deskphone Control Workflow 47
  Add a CTI Service 48
    Apply a CTI Service 48
  Enable Device for CTI 49
  Desk Phone Video Configuration 49
  Enable Video Rate Adaptation 51
    Enable RTCP on Common Phone Profiles 51
    Enable RTCP on Device Configurations 52
  Configure User Associations 52
  Reset Devices 54

CHAPTER 9

Configure Softphone 55
  Configure Softphones Workflow 55
    Create and Configure Cisco Jabber Devices 55
      Add a Directory Number to the Device 58
      Add a Remote Destination 59
    Configure a SIP Trunk 60
      Configure a SIP Trunk Security Profile for IM and Presence Service 61
      Configure a SIP Trunk for IM and Presence Service 61
    Configure SIP Publish Trunk 63
  Configure User Associations 63
  Create Mobile SIP Profiles 64
    Setting up System SIP Parameters 65
  Configure the Phone Security Profile 66
  Provide Users with Authentication Strings 67
CHAPTER 13

Configure Certificate Validation 93

Configure Certificates for an On-Premises Deployment 93

Deploy CA Certificates to Clients 94

Manually Deploy CA Certificates to Cisco Jabber for Windows Clients 94

Manually Deploy CA Certificates to Cisco Jabber for Mac Clients 95

Manually Deploy CA Certificates to Mobile Clients 95

CHAPTER 14

Configure the Clients 97

Client Configuration Workflow 97

Introduction to Client Configuration 97

Create and Host Client Configuration Files 98

Specify Your TFTP Server Address 99

Specify TFTP Servers in Phone Mode 100

Create Global Configurations 100

Create Group Configurations 100

Host Configuration Files 101

Restart Your TFTP Server 102

Configuration File 102

Set Parameters on Phone Configuration for Desktop Clients 103

Parameters in Phone Configuration 103

Set Parameters on Phone Configuration for Mobile Clients 104

Parameters in Phone Configuration 104

Configure Proxy Setting 105

Configure Proxy Settings for Cisco Jabber for Windows 105

Configure Proxy Settings for Cisco Jabber for Mac 105

Configure Proxy Settings for Cisco Jabber iPhone and iPad 106

Configure Proxy Settings for Cisco Jabber for Android 106

CHAPTER 15

Deploy Cisco Jabber Applications 107

Download the Cisco Jabber Clients 107

Install Cisco Jabber for Windows 107

Use the Command Line 108

Example Installation Commands 108

Command Line Arguments 109
Override Argument 109
Mode Type Argument 109
When to Set the Product Mode 110
Change Product Modes 110
Change Product Modes with Cisco Unified Communications Manager Version 9.x and Later 110
Authentication Arguments 111
TFTP Server Address 115
Common Installation Arguments 116
LCID for Languages 122
Run the MSI Manually 124
Create a Custom Installer 124
Get the Default Transform File 125
Create Custom Transform Files 125
Transform the Installer 126
Installer Properties 127
Deploy with Group Policy 128
Set a Language Code 129
Deploy the Client with Group Policy 129
Cisco Media Services Interface 131
Desk Phone Video Capabilities 131
Install Cisco Media Services Interface 131
Uninstall Cisco Jabber for Windows 131
Use the Installer 131
Use the Product Code 132
Install Cisco Jabber for Mac 132
URL Configuration for Cisco Jabber for Mac 132
Install Cisco Jabber Mobile Clients 135
URL Configuration for Cisco Jabber for Android, iPhone, and iPad 135
Mobile Configuration Using Enterprise Mobility Management 137

CHAPTER 16
Remote Access 139
Service Discovery Requirements Workflow 139
Service Discovery Requirements 139
DNS Requirements 140
Certificate Requirements  140
Test_collab-edge SRV Record  140
Test SRV Records  140
Cisco Anyconnect Deployment Workflow  141
Cisco AnyConnect Deployment  141
Application Profiles  141
Automate VPN Connection  142
Set Up Trusted Network Connection  142
Set Up Connect On-Demand VPN  143
Set Up Automatic VPN Access on Cisco Unified Communications Manager  144
AnyConnect Documentation Reference  145
Session Parameters  145
Set ASA Session Parameters  146

CHAPTER 17  Quality of Service  147
Options  147
Supported Codecs  148
Define a Port Range on the SIP Profile  149
Define a Port Range in Jabber-config.xml  149
Set DSCP Values  149
Set DSCP Values on Cisco Unified Communications Manager  150
Set DSCP Values with Group Policy  150
Set DSCP Values on the Client  151
Set DSCP Values on the Network  151

CHAPTER 18  Integrate Cisco Jabber with Applications  153
Configure Presence in Microsoft SharePoint 2010 and 2013  153
Client Availability  154
Protocol Handlers  155
Registry Entries for Protocol Handlers  155
Protocol Handlers on HTML Pages  156
Protocol Handler Supported Parameters  157
DTMF Support  158
Purpose of this Guide

The Cisco Jabber Deployment and Installation Guide includes the following task-based information required to deploy and install Cisco Jabber:

• Configuration and installation workflows that outline the processes to configure and install on-premises deployments.
• How to configure the various services that the Cisco Jabber client interacts with, such as IM and Presence Service, Voice and Video Communication, Visual Voicemail, and Conferencing.
• How to configure directory integration, certificate validation, and service discovery.
• How to install the clients.


About Cisco Jabber

Cisco Jabber is a suite of Unified Communications applications that allow seamless interaction with your contacts from anywhere. Cisco Jabber offers IM, presence, audio and video calling, voicemail, and conferencing.

The applications in the Cisco Jabber family of products are:

• Cisco Jabber for Android
• Cisco Jabber for iPhone and iPad
• Cisco Jabber for Mac
• Cisco Jabber for Windows
For more information about the Cisco Jabber suite of products, see http://www.cisco.com/go/jabber.
Configuration and Installation Workflows

- Purpose of Configuration Workflows, page 3
- Prerequisites, page 3
- Deployment and Installation Workflow for an On-Premises Deployment, page 6

Purpose of Configuration Workflows

Configuration and installation workflows outline the processes to configure and install on-premises deployment. Before you deploy and install Cisco Jabber, see the Cisco Jabber Planning Guide at Install and Upgrade Guides to determine the deployment options that best suit your business needs.

Prerequisites

- Installation servers must be started and active
- Activate and Start Essential Services, on page 4
- Install Cisco Options Package File for Devices, on page 5

Apply COP File for BFCP Capabilities

You must apply cmterm-bfcp-e.8-6-2.cop.sgn to configure video desktop sharing on Cisco Unified Communication Manager release 8.6.2 and later. This COP file adds an option to enable BFCP on the CSF device.
### Note

- You must install the COP file each time you upgrade. For example, if you configure video desktop sharing on Cisco Unified Communication Manager Release 8.6.2.20000-1 and then upgrade to Cisco Unified Communication Manager Release 8.6.2.20000-2, you must apply the COP file on Cisco Unified Communication Manager Release 8.6.2.20000-2.

- If you configure video desktop sharing on Cisco Unified Communication Manager Release 8.6.1 and then upgrade to Cisco Unified Communication Manager release 8.6.2, you must apply the COP file on Cisco Unified Communication Manager release 8.6.2 before you can configure video desktop sharing.

### Procedure

**Step 1** Download the Cisco Jabber administration package from Cisco.com.

**Step 2** Copy `cmterm-bfcp-e.8-6-2.cop.sgn` from the Cisco Jabber administration package to your file system.

**Step 3** Open the **Cisco Unified Communications Manager Administration** interface.

**Step 4** Upload and apply `cmterm-bfcp-e.8-6-2.cop.sgn`.

**Step 5** Restart the server as follows:

a) Open the **Cisco Unified OS Administration** interface.

b) Select **Settings > Version**.

c) Select **Restart**.

d) Repeat the preceding steps for each node in the cluster, starting with your presentation server.

The COP add the *Allow Presentation Sharing using BFCP* field to the Protocol Specific Information section on the **Phone Configuration** window for CSF devices.

### Activate and Start Essential Services

Essential services enable communication between servers and provide capabilities to the client.

**Procedure**

**Step 1** Open the **Cisco Unified IM and Presence Serviceability** interface.

**Step 2** Select **Tools > Control Center - Feature Services**.

**Step 3** Select the appropriate server from the **Server** drop-down list.

**Step 4** Ensure the following services are started and activated:

- Cisco SIP Proxy
- Cisco Sync Agent
- Cisco XCP Authentication Service
• Cisco XCP Connection Manager
• Cisco XCP Text Conference Manager
• Cisco Presence Engine

Step 5  Select Tools > Control Center - Network Services.
Step 6  Select the appropriate server from the Server drop-down list.
Step 7  Ensure Cisco XCP Router Service is running.

Install Cisco Options Package File for Devices

To make Cisco Jabber available as a device in Cisco Unified Communications Manager, you must install a device-specific Cisco Options Package (COP) file on all your Cisco Unified Communications Manager nodes. Perform this procedure at a time of low usage; it can interrupt service. General information about installing COP files is available in the "Software Upgrades" chapter in the Cisco Unified Communications Operating System Administration Guide for your release.

Procedure

Step 1  Download the device COP file.
   a)  Locate the device COP file.
       •  Go to the software downloads site.
       •  Locate the device COP file for your release.
   b)  Click Download Now.
   c)  Note the MD5 checksum.
       You will need this information later.
   d)  Click Proceed with Download and follow the instructions.

Step 2  Place the COP file on an FTP or SFTP server that is accessible from your Cisco Unified Communications Manager nodes.

Step 3  Install this COP file on the Publisher node in your Cisco Unified Communications Manager cluster:
   a)  Open the Cisco Unified OS Administration interface.
   b)  Select Software Upgrades > Install/Upgrade.
   c)  Specify the location of the COP file and provide the required information.
       For more information, see the online help.
   d)  Select Next.
   e)  Select the device COP file.
   f)  Select Next.
   g)  Follow the instructions on the screen.
   h)  Select Next.
       Wait for the process to complete. This process can take some time.
 Deployment and Installation Workflow for an On-Premises Deployment

- Full UC Mode Deployment, on page 6
- Jabber IM only Mode Deployment, on page 7
- Phone Mode Deployment, on page 8

Full UC Mode Deployment

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
• Review requirements to confirm that you meet them.  
• Review contact sources to determine which contact source you will use. |
| Step 2 | Users, on page 9 | |
| Step 3 | Contact Source, on page 17 | |
| Step 4 | Configure Instant Messaging and Presence Service, on page 27 | |
| Step 5 | Configure Voicemail, on page 35 | |
| Step 6 | Configure WebEx Conferencing, on page 43 | |
| Step 7 | Configure Deskphone Control, on page 47 | |
| Step 8 | Configure Softphone, on page 55 | |
### Jabber IM only Mode Deployment

#### Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
</table>
- Review requirements to confirm that you meet them.  
- Review contact sources to determine which contact source you will use. |
| Step 2 | Users, on page 9                                            |                                                                         |
| Step 3 | Contact Source, on page 17                                  |                                                                         |
| Step 4 | Configure Instant Messaging and Presence Service, on page 27|                                                                         |
| Step 5 | Configure WebEx Conferencing, on page 43                    |                                                                         |
| Step 6 | Configure a Service Profile, on page 73                     |                                                                         |
| Step 7 | Configure Service Discovery, on page 81                     |                                                                         |
| Step 8 | Configure Certificate Validation, on page 93                |                                                                         |
| Step 9 | Configure the Clients, on page 97                           |                                                                         |
| Step 10| Deploy Cisco Jabber Applications, on page 107                |                                                                         |
## Phone Mode Deployment

### Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Read the Cisco Jabber Planning Guide located at <a href="http://www.cisco.com/c/en/us/support/unified-communications/jabber-windows/products-installation-guides-list.html">http://www.cisco.com/c/en/us/support/unified-communications/jabber-windows/products-installation-guides-list.html</a>.</td>
<td>• Choose your deployment scenario. &lt;br&gt;• Review requirements to confirm that you meet them. &lt;br&gt;• Review contact sources to determine which contact source you will use.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Users, on page 9.</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Configure Certificate Validation, on page 93.</td>
<td>Certificates are required for each service to which the Jabber clients connect.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Configure Service Discovery, on page 81.</td>
<td></td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure a Service Profile, on page 73.</td>
<td></td>
</tr>
<tr>
<td>Step 6</td>
<td>Configure Softphone, on page 55.</td>
<td></td>
</tr>
<tr>
<td>Step 7</td>
<td>Configure Voicemail, on page 35.</td>
<td></td>
</tr>
<tr>
<td>Step 8</td>
<td>Configure WebEx Conferencing, on page 43.</td>
<td></td>
</tr>
<tr>
<td>Step 9</td>
<td>Configure the Clients, on page 97.</td>
<td></td>
</tr>
<tr>
<td>Step 10</td>
<td>Deploy Cisco Jabber Applications, on page 107.</td>
<td></td>
</tr>
</tbody>
</table>
CHAPTER 3

Users

• Configure Users, page 9

Configure Users

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Enable Synchronization, on page 9</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Populate User ID and Directory URI, on page 10</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Perform Synchronization, on page 12</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Assign Roles and Groups, on page 13</td>
<td></td>
</tr>
<tr>
<td>Step 5</td>
<td>Authentication Options, on page 13</td>
<td></td>
</tr>
</tbody>
</table>

Enable Synchronization

To ensure that contact data in your directory server is replicated to Cisco Unified Communications Manager, you must synchronize with the directory server. Before you can synchronize with the directory server, you must enable synchronization.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > LDAP > LDAP System.
The **LDAP System Configuration** window opens.

**Step 3** Locate the **LDAP System Information** section.

**Step 4** Select **Enable Synchronizing from LDAP Server**.

**Step 5** Select the type of directory server from which you are synchronizing data from the **LDAP Server Type** drop-down list.

---

**What to Do Next**

Specify an LDAP attribute for the user ID.

---

### Populate User ID and Directory URI

When you synchronize your LDAP directory server with Cisco Unified Communications Manager, you can populate the end user configuration tables in both the Cisco Unified Communications Manager and the Cisco Unified Communications Manager IM and Presence Service databases with attributes that contain values for the following:

- **User ID** — You must specify a value for the user ID on Cisco Unified Communications Manager. This value is required for the default IM address scheme and for users to sign in. The default value is `sAMAccountName`.

- **Directory URI** — You should specify a value for the directory URI if you plan to:
  - Enable URI dialing in Cisco Jabber.
  - Use the directory URI address scheme on Cisco Unified Communications Manager IM and Presence Service version 10 and higher.

When Cisco Unified Communications Manager synchronizes with the directory source, it retrieves the values for the directory URI and user ID and populates them in the end user configuration table in the Cisco Unified Communications Manager database.
The Cisco Unified Communications Manager database then synchronizes with the Cisco Unified Communications Manager IM and Presence Service database. As a result, the values for the directory URI and user ID are populated in the end user configuration table in the Cisco Unified Communications Manager IM and Presence Service database.

Specify an LDAP Attribute for the User ID

When you synchronize from your directory source to Cisco Unified Communications Manager, you can populate the user ID from an attribute in the directory. The default attribute that holds the user ID is sSAMAccountName.

Procedure

**Step 1** Locate the **LDAP Attribute for User ID** drop-down list on the **LDAP System Configuration** window.

**Step 2** Specify an attribute for the user ID as appropriate and then select **Save**.

**Important** If the attribute for the user ID is other than **sSAMAccountName** and you are using the default IM address scheme in Cisco Unified Communications Manager IM and Presence Service, you must specify the attribute as the value for the parameter in your client configuration file as follows:

The **EDI parameter** is **UserAccountName**.

```xml
<UserAccountName>attribute-name</UserAccountName>
```

The **BDI parameter** is **BDIUserAccountName**.

```xml
<BDIUserAccountName>attribute-name</BDIUserAccountName>
```

If you do not specify the attribute in your configuration, and the attribute is other than **sSAMAccountName**, the client cannot resolve contacts in your directory. As a result, users do not get presence and cannot send or receive instant messages.

Specify an LDAP Attribute for the Directory URI

On Cisco Unified Communications Manager release 9.0(1) and later, you can populate the directory URI from an attribute in the directory.

**Before You Begin**

Enable Synchronization.

**Procedure**

**Step 1** Select **System > LDAP > LDAP Directory**.

**Step 2** Select the appropriate LDAP directory or select **Add New** to add an LDAP directory.

**Step 3** Locate the **Standard User Fields To Be Synchronized** section.

**Step 4** Select one of the following LDAP attributes from the **Directory URI** drop-down list:
Perform Synchronization

After you add a directory server and specify the required parameters, you can synchronize Cisco Unified Communications Manager with the directory server.

**Before You Begin**

If your environment includes a presence server, you should ensure the following feature service is activated and started before you synchronize with the directory server:

- Cisco Unified Communications Manager IM and Presence Service — Cisco Sync Agent

This service keeps data synchronized between the presence server and Cisco Unified Communications Manager. When you perform the synchronization with your directory server, Cisco Unified Communications Manager then synchronizes the data with the presence server. However, the Cisco Sync Agent service must be activated and started.

**Procedure**

**Step 1** Select System > LDAP > LDAP Directory.

**Step 2** Select Add New.

The LDAP Directory window opens.

**Step 3** Specify the required details on the LDAP Directory window. See the Cisco Unified Communications Manager Administration Guide for more information about the values and formats you can specify.

**Step 4** Create an LDAP Directory Synchronization Schedule to ensure that your information is synchronized regularly.

**Step 5** Select Save.

**Step 6** Select Perform Full Sync Now.

**Note** The amount of time it takes for the synchronization process to complete depends on the number of users that exist in your directory. If you synchronize a large directory with thousands of users, you should expect the process to take some time.

User data from your directory server is synchronized to the Cisco Unified Communications Manager database. Cisco Unified Communications Manager then synchronizes the user data to the presence server database.
Assign Roles and Groups

For all deployment types assign users to the Standard CCM End Users group.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > End User
   The Find and List Users window opens.
Step 3 Find and select the user from the list.
   The End User Configuration window opens.
Step 4 Locate the Permission Information section.
Step 5 Select Add to Access Control Group.
   The Find and List Access Control Groups dialog box opens.
Step 6 Select the access control groups for the user.
   At a minimum you should assign the user to the following access control groups:
      • Standard CCM End Users
      • Standard CTI Enabled—This option is used for desk phone control.
   If you provision users with secure phone capabilities, do not assign the users to the Standard CTI Secure Connection group.
   Certain phone models require additional control groups, as follows:
      • Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select Standard CTI Allow Control of Phones supporting Connected Xfer and conf.
      • Cisco Unified IP Phone 6900 series, select Standard CTI Allow Control of Phones supporting Rollover Mode.
Step 7 Select Add Selected.
   The Find and List Access Control Groups window closes.
Step 8 Select Save on the End User Configuration window.

Authentication Options

Enable SAML SSO in the Client

Before You Begin

• If you do not use Cisco WebEx Messenger, enable SSO on Cisco Unified Communications Applications 10.5.1 Service Update 1—For information about enabling SAML SSO on this service, read the SAML SSO Deployment Guide for Cisco Unified Communications Applications, Release 10.5.
• Enable SSO on Cisco Unity Connection version 10.5—For more information about enabling SAML SSO on this service, read Managing SAML SSO in Cisco Unity Connection.

• If you use Cisco WebEx Messenger, enable SSO on Cisco WebEx Messenger Services to support Cisco Unified Communications Applications and Cisco Unity Connection—For more information about enabling SAML SSO on this service, read about Single Sign-On in the Cisco WebEx Messenger Administrator's Guide.

For more information about enabling SAML SSO on this service, read about Single Sign-On in the Cisco WebEx Messenger Administrator's Guide.

Procedure

Step 1 Deploy certificates on all servers so that the certificate can be validated by a web browser, otherwise users receive warning messages about invalid certificates. For more information about certificate validation, see Certificate Validation.

Step 2 Ensure Service Discovery of SAML SSO in the client. The client uses standard service discovery to enable SAML SSO in the client. Enable service discovery by using the following configuration parameters: ServicesDomain, VoiceServicesDomain, and ServiceDiscoveryExcludedServices. For more information about how to enable service discovery, see Configure Service Discovery for Remote Access.

Step 3 Define how long a session lasts. A session is comprised of cookie and token values. A cookie usually lasts longer than a token. The life of the cookie is defined in the Identity Provider, and the duration of the token is defined in the service.

Step 4 When SSO is enabled, by default all Cisco Jabber users sign in using SSO. Administrators can change this on a per user basis so that certain users do not use SSO and instead sign in with their Cisco Jabber username and password. To disable SSO for a Cisco Jabber user, set the value of the SSO Enabled parameter to FALSE. If you have configured Cisco Jabber not to ask users for their email address, their first sign in to Cisco Jabber may be non-SSO. In some deployments, the parameter ServicesDomainSsoEmailPrompt needs to be set to ON. This ensures that Cisco Jabber has the information required to perform a first-time SSO sign in. If users signed in to Cisco Jabber previously, this prompt is not needed because the required information is available.

Related Topics

Single Sign-On
Managing SAML SSO in Cisco Unity Connection
SAML SSO Deployment Guide for Cisco Unified Communications Applications

Authenticate with the LDAP Server

Perform this procedure if you want to enable LDAP authentication so that end user passwords are authenticated against the password that is assigned in the company LDAP directory. LDAP authentication gives system administrators the ability to assign an end user a single password for all company applications. This configuration applies to end user passwords only and does not apply to end user PINs or application user passwords. When users sign in to the client, the presence service routes that authentication to Cisco Unified Communications Manager. Cisco Unified Communications Manager then sends that authentication to the directory server.
Procedure

Step 1  Open the Cisco Unified CM Administration interface.
Step 2  Select System > LDAP > LDAP Authentication.
Step 3  Select Use LDAP Authentication for End Users.
Step 4  Specify LDAP credentials and a user search base as appropriate.  
        See the Cisco Unified Communications Manager Administration Guide for information about the fields on 
        the LDAP Authentication window.
Step 5  Select Save.
# Contact Source

- Configure Contact Source Workflow, page 17
- Client Configuration for Directory Integration, page 18
- Federation, page 24

## Configure Contact Source Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Configure directory integration:</td>
</tr>
<tr>
<td>• Configure Directory Integration in a Service Profile, on page 18</td>
<td></td>
</tr>
<tr>
<td>• Advanced Directory Integration in the Configuration File, on page 23</td>
<td>Configure directory integration through service profiles using Cisco Unified Communications Manager or with the configuration file.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Optional: Configure Photos, on page 22</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Optional: Configure Intradomain Federation for BDI or EDI, on page 24</td>
</tr>
</tbody>
</table>
Client Configuration for Directory Integration

You can configure directory integration through service profiles using Cisco Unified Communications Manager release 9 or later or with the configuration file. Use this section to learn how to configure the client for directory integration.

When both a service profile and a configuration file are present, the following table describes which parameter value takes precedence.

<table>
<thead>
<tr>
<th>Service Profile</th>
<th>Configuration File</th>
<th>Which Parameter Value Takes Precedence?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter value is set</td>
<td>Parameter value is set</td>
<td>Service profile</td>
</tr>
<tr>
<td>Parameter value is set</td>
<td>Parameter value is blank</td>
<td>Service profile</td>
</tr>
<tr>
<td>Parameter value is blank</td>
<td>Parameter value is set</td>
<td>Configuration file</td>
</tr>
<tr>
<td>Parameter value is blank</td>
<td>Parameter value is blank</td>
<td>Service profile blank (default) value</td>
</tr>
</tbody>
</table>

Configure Directory Integration in a Service Profile

With Cisco Unified Communications Manager release 9 and later, you can provision users with service profiles and deploy the _cisco-uds SRV record on your internal domain server. The client can then automatically discover Cisco Unified Communications Manager and retrieve the service profile to get directory integration configuration.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Add a Directory Service, on page 18</td>
<td>Create a Directory UC Service.</td>
</tr>
<tr>
<td>2</td>
<td>Apply Directory Service to a Service Profile, on page 22</td>
<td>Add the Directory UC Service to the Service Profile.</td>
</tr>
</tbody>
</table>

Add a Directory Service

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open the <a href="#">Cisco Unified CM Administration</a> interface.</td>
</tr>
<tr>
<td>2</td>
<td>Select <a href="#">User Management &gt; User Settings &gt; UC Service</a>.</td>
</tr>
</tbody>
</table>
The **Find and List UC Services** window opens.

**Step 3**
Select **Add New**.
The **UC Service Configuration** window opens.

**Step 4**
Select **Directory** from the **UC Service Type** menu and then select **Next**.

**Step 5**
Set all appropriate values for the directory service.
To configure Cisco Jabber directory searches on the Global Catalog, add the following values:

- **Port**—3268
- **Protocol**—TCP

**Step 6**
Select **Save**.

---

**What to Do Next**
Apply Directory Service.

---

**Directory Profile Parameters**
The following table lists the configuration parameters you can set in the directory profile:

<table>
<thead>
<tr>
<th>Directory Service Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Primary server</strong></td>
<td>Specifies the address of the primary directory server.</td>
</tr>
<tr>
<td></td>
<td>This parameter is required for manual connections where the client cannot automatically discover the directory server.</td>
</tr>
<tr>
<td><strong>Secondary server</strong></td>
<td>Specifies the address of the backup directory server.</td>
</tr>
<tr>
<td><strong>Tertiary Server</strong></td>
<td>Applies to Cisco Jabber for Windows only.</td>
</tr>
<tr>
<td></td>
<td>Specifies the address of the tertiary directory server.</td>
</tr>
</tbody>
</table>

**Use UDS for Contact Resolution**

<table>
<thead>
<tr>
<th>True (Default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use UDS as a contact source. When this option is selected the following parameters in this table are not used.</td>
</tr>
</tbody>
</table>

**False**

Use EDI or BDI as a contact source.
The following parameters are used to connect to the LDAP server.

By default, UDS provides contact resolution when users connect to the corporate network through Expressway for Mobile and Remote Access.
<table>
<thead>
<tr>
<th>Directory Service Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Logged On User Credential</td>
<td>Specifies if the client uses the logged on username and password for LDAP contact resolution. If you have configured Active Directory (AD) SSO, this will take priority over this setting.</td>
</tr>
<tr>
<td></td>
<td><strong>True (default)</strong></td>
</tr>
<tr>
<td></td>
<td>Use logged on user credentials. This value maps to the values for the UseWindowsCredentials parameter for Windows clients, and the BDIUseJabberCredentials parameter for other clients.</td>
</tr>
<tr>
<td></td>
<td><strong>False</strong></td>
</tr>
<tr>
<td></td>
<td>Do not use logged on user credentials. When you have SSO configured, Jabber uses those credentials before using the ConnectionUsername and ConnectionPassword parameters. You must specify the logged on user credentials with the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• ConnectionUsername</td>
</tr>
<tr>
<td></td>
<td>• ConnectionPassword</td>
</tr>
<tr>
<td></td>
<td>You must specify the logged on user credentials with the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• EDI (Windows client)</td>
</tr>
<tr>
<td></td>
<td>◦ ConnectionUsername</td>
</tr>
<tr>
<td></td>
<td>◦ ConnectionPassword</td>
</tr>
<tr>
<td></td>
<td>• BDI (Mac, Android, iOS clients)</td>
</tr>
<tr>
<td></td>
<td>◦ BDIConnectionUsername</td>
</tr>
<tr>
<td></td>
<td>◦ BDIConnectionPassword</td>
</tr>
<tr>
<td>Username</td>
<td>Lets you manually specify a shared username that the client can use to authenticate with the directory server. By default, Cisco Jabber for Windows uses Integrated Windows Authentication when connecting to the directory server. You should use this parameter only in deployments where you cannot authenticate with the directory server using Microsoft Windows credentials. Use only a well-known or public set of credentials for an account that has read-only permissions.</td>
</tr>
<tr>
<td>Directory Service Configuration</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>Lets you manually specify a shared password that the client can use to authenticate with the directory server. By default, Cisco Jabber for Windows uses Integrated Windows Authentication when connecting to the directory server. You should use this parameter only in deployments where you cannot authenticate with the directory server using Microsoft Windows credentials. Use only a well-known or public set of credentials for an account that has read-only permissions.</td>
</tr>
<tr>
<td><strong>Search Base 1</strong></td>
<td>Specifies a location in the directory server from which searches begin. In other words, a search base is the root from which the client executes a search. By default, the client searches from the root of the directory tree. You can specify the value of up to three search bases in your OU to override the default behavior. Active Directory does not typically require a search base. Specify search bases for Active Directory only for specific performance requirements. Specify a search base for directory servers other than Active Directory to create bindings to specific locations in the directory. <strong>Tip</strong> Specify an OU to restrict searches to certain user groups. For example, a subset of your users have instant messaging capabilities only. Include those users in an OU and then specify that as a search base.</td>
</tr>
<tr>
<td><strong>Search Base 2</strong></td>
<td><strong>Recursive Search on All Search Bases</strong> Select this option to perform a recursive search of the directory starting at the search base. Use recursive searches to allow the Cisco Jabber client contact search queries to search all of the LDAP directory tree from a given search context (search base). This is a common option when searching LDAP. This is a required field. The default value is True.</td>
</tr>
<tr>
<td><strong>Search Base 3</strong></td>
<td><strong>Base Filter</strong> Specifies a base filter for Active Directory queries. Specify a directory subkey name only to retrieve objects other than user objects when you query the directory. The default value is ((objectCategory=person)\ (objectClass=user)).</td>
</tr>
</tbody>
</table>

**Search Base 2**

The following parameters only apply to Cisco Jabber for Windows:
**Directory Service Configuration**

<table>
<thead>
<tr>
<th>Directory Service Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Predictive Search Filter</td>
<td>Defines filters to apply to predictive search queries. You can define multiple, comma-separated values to filter search queries. The default value is ANR. When Cisco Jabber performs a predictive search, it issues a query using Ambiguous Name Resolution (ANR). This query disambiguates the search string and returns results that match the attributes that are set for ANR on your directory server. <strong>Important</strong> Configure your directory server to set attributes for ANR if you want the client to search for those attributes.</td>
</tr>
</tbody>
</table>

**Attribute Mappings**

It is not possible to change the default attribute mappings in a service profile. If you plan to change any default attribute mappings, you must define the required mappings in a client configuration file.

**Apply Directory Service to a Service Profile**

**Procedure**

1. **Step 1** Select User Management > User Settings > Service Profile. The Find and List Service Profiles window opens.
2. **Step 2** Select Add New. The Service Profile Configuration window opens.
3. **Step 3** Add the directory services to the directory profile. See the Directory Profile Parameters topic for information about the specific settings that are needed for the directory profile.
4. **Step 4** Select Save.

**Configure Photos**

Cisco Jabber uses the following methods to configure Photos for users:

- **Active Directory Binary Objects**—No configuration needed, Cisco Jabber retrieves the binary photo from the thumbnailPhoto attribute.
- **PhotoURL attribute**—Use the PhotoSource parameter in the jabber-config.xml file to specify an attribute in your directory. The client will retrieve the attribute and determine if it is a URL or binary data and display the photo from either source.

EDI parameter: PhotoSource
Advanced Directory Integration in the Configuration File

You can configure directory integration in the Cisco Jabber configuration file. For more information see the Directory chapter in the Parameters Reference Guide for Cisco Jabber.
When a Service Profile and a configuration file are present, settings in the Service Profile always take priority.

Federation

Federation lets Cisco Jabber users communicate with users who are provisioned on different systems and who are using client applications other than Cisco Jabber.

Configure Intradomain Federation for BDI or EDI

In addition to configuring intradomain federation on the presence server, you might need to specify some configuration settings in the Cisco Jabber configuration files.

To resolve contacts during contact search or retrieve contact information from your directory, Cisco Jabber requires the contact ID for each user. Cisco Unified Communications Manager IM & Presence server uses a specific format for resolving contact information that does not always match the format on other presence servers such as Microsoft Office Communications Server or Microsoft Live Communications Server.

The parameters that you use to configure intradomain federation depend on whether you use Enhanced Directory Integration (EDI) or Basic Directory Integration (BDI). EDI uses native Microsoft Windows APIs to retrieve contact data from the directory service and is only used by Cisco Jabber for Windows. For BDI, the client retrieves contact data from the directory service and is used by Cisco Jabber for Mac, Cisco Jabber for Android, and Cisco Jabber for iPhone and iPad.

Procedure

**Step 1** Set the value of the relevant parameter to true:

- For BDI: BDIUseSipUriToResolveContacts
- For EDI: UseSIPURIToResolveContacts

**Step 2** Specify an attribute that contains the Cisco Jabber contact ID that the client uses to retrieve contact information. The default value is msRTCSIP-PrimaryUserAddress, or you can specify another attribute in the relevant parameter:

- For BDI: BDISipUri
- For EDI: SipUri
When you deploy intradomain federation and the client connects with Expressway for Mobile and Remote Access from outside the firewall, contact search is supported only when the contact ID uses one of the following formats:

- sAMAccountName@domain
- UserPrincipleName (UPN)@domain
- EmailAddress@domain
- employeeNumber@domain
- phoneNumber@domain

**Step 3**
In the UriPrefix parameter, specify any prefix text that precedes each contact ID in the relevant SipUri parameter.

**Example:**
For example, you specify `msRTCSIP-PrimaryUserAddress` as the value of SipUri. In your directory the value of `msRTCSIP-PrimaryUserAddress` for each user has the following format:

```
sip:username@domain
```

- For BDI: BDIUriPrefix
- For EDI: UriPrefix

The following XML snippet provides an example of the resulting configuration for BDI:
```
<Directory>
  <BDIUseSIPURIToResolveContacts>true</BDIUseSIPURIToResolveContacts>
  <BDISipUri>non-default-attribute</BDISipUri>
  <BDIUriPrefix>sip:</BDIUriPrefix>
</Directory>
```

The following XML snippet provides an example of the resulting configuration for EDI:
```
<Directory>
  <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
  <SipUri>non-default-attribute</SipUri>
  <UriPrefix>sip:</UriPrefix>
</Directory>
```
Configure Intradomain Federation for BDI or EDI
CHAPTER 5

Configure Instant Messaging and Presence Service

- IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 10.5 and Later, page 27
- IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later, page 28
- Add an IM and Presence Service, page 28
- Configure IM Address Scheme, page 30
- Enable Message Settings, page 30
- Prepopulate Contact Lists in Bulk, page 31
- Configure Users with IM and Presence Service, page 32
- Associate User with Line, page 33

IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 10.5 and Later

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1 Configure IM Address Scheme, on page 30</td>
<td></td>
</tr>
<tr>
<td>Step 2 Enable Message Settings, on page 30</td>
<td></td>
</tr>
<tr>
<td>Step 3 Prepopulate Contact Lists in Bulk, on page 31</td>
<td></td>
</tr>
<tr>
<td>Step 4 Configure Users with IM and Presence Service, on page 32</td>
<td></td>
</tr>
</tbody>
</table>
IM and Presence Service Workflow for On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Add an IM and Presence Service, on page 28</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Apply an IM and Presence Service, on page 29</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Configure IM Address Scheme, on page 30</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>Enable Message Settings, on page 30</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>Prepopulate Contact Lists in Bulk, on page 31</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>Configure Users with IM and Presence Service, on page 32</td>
</tr>
</tbody>
</table>

**Add an IM and Presence Service**

Provide users with IM and Presence Service capabilities.

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select User Management > User Settings > UC Service. The Find and List UC Services window opens.

**Step 3** Select Add New. The UC Service Configuration window opens.

**Step 4** In the Add a UC Service section, select IM and Presence from the UC Service Type drop-down list.

**Step 5** Select Next.

**Step 6** Provide details for the IM and Presence Service as follows:

a) Select Unified CM (IM and Presence) from the Product Type drop-down list.
b) Specify a name for the service in the Name field.
The name you specify displays when you add the service to a profile. Ensure the name you specify is unique, meaningful, and easy to identify.

c) Specify an optional description in the Description field.
d) Specify the instant messaging and presence service address in the Host Name/IP Address field.
   Important The service address must be a fully qualified domain name or IP address.

Step 7 Select Save.

Apply an IM and Presence Service

After you add an IM and Presence Service on Cisco Unified Communications Manager, you must apply it to a service profile so that the client can retrieve the settings.

Before You Begin
Add an IM and Presence Service, on page 28

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.
The Find and List Service Profiles window opens.
Step 3 Find and select your service profile.
The Service Profile Configuration window opens.
Step 4 In the IM and Presence Profile section, select up to three services from the following drop-down lists:
   • Primary
   • Secondary
   • Tertiary
Step 5 Click Save.
Step 6 Add users to the service profile.
   a) Select User Management > End User.
The Find and List Users dialog box opens.
   b) Specify the appropriate filters in the Find User where field and then select Find to find a user.
   c) Click the user in the list.
The End User Configuration window appears.
   d) Under the Service Settings area, check the Home Cluster check box.
   e) Check the Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile) check box.
Configure IM Address Scheme

This feature is supported on Cisco Unified Communications Manager IM and Presence Service release 10.x or later. For versions of Cisco Unified Communications Manager IM and Presence Service release 9.x and earlier the default IM address scheme used is UserID@[Default Domain].

Procedure

Step 1  Choose the IM Address Scheme.

a) Open Cisco Unified CM IM and Presence Administration.

b) Select Presence > Settings > Advanced Configuration

   The Advanced Presence Settings window opens.

c) Select IM Address Scheme and from the list choose one of the following:

   • UserID@[Default Domain]
     If you use the UserID, ensure that you configure a default domain. For example, services must be named cups.com and not cups.

   • Directory URI

Step 2  Select the required mapping.

a) Open Cisco Unified CM Administration.

b) Select System > LDAP > LDAP Directory.

   The Find and List LDAP Directories window opens.

c) Find and select the directory from the list.

   The LDAP Directory window opens.

d) In the Standard User Fields To Be Synchronized section choose the mapping:

   • UserID mapped to an LDAP field, the default is sAMAccountName.

   • Directory URI mapped to either mail or msRTCSIP-primaryuseraddress.

Enable Message Settings

Enable and configure instant messaging capabilities.

Before You Begin

Prepopulate Contact Lists in Bulk, on page 31.
**Configure Instant Messaging and Presence Service**

**Prepopulate Contact Lists in Bulk**

You can pre-populate user contact lists with the Bulk Administration Tool (BAT).

In this way you can prepopulate contact lists for users so that they automatically have a set of contacts after the initial launch of the client.

Cisco Jabber supports up to 300 contacts in a client contact list.

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Create a CSV file that defines the contact list you want to provide to users.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Use the BAT to import the contact list in bulk to a set of users. For more information about using BAT and the format of the CSV file, see the <em>Deployment Guide for Cisco Unified Communications Manager IM &amp; Presence</em> for your release.</td>
</tr>
</tbody>
</table>
Configure Users with IM and Presence Service

You can enable users for IM and Presence.

Configure Users Individually

Enable instant messaging and presence service and add your service profile to individual users.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Open the Cisco Unified CM Administration interface.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 3</td>
<td>Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select the appropriate username from the list. The End User Configuration window opens.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Locate the Service Settings section and do the following:</td>
</tr>
<tr>
<td></td>
<td>a) Select Home Cluster.</td>
</tr>
<tr>
<td></td>
<td>b) Select Enable User for Unified CM IM and Presence.</td>
</tr>
<tr>
<td></td>
<td>c) Select your service profile from the UC Service Profile drop-down list.</td>
</tr>
<tr>
<td>Important</td>
<td>Cisco Unified Communications Manager release 9.x only—If the user has only instant messaging and presence capabilities (IM only), select Use Default. Cisco Unified Communications Manager release version 9.x applies the default service profile regardless of what you select from the UC Service Profile drop-down list.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Select Save.</td>
</tr>
</tbody>
</table>

Configure Users in Bulk

Enable instant messaging and presence and add your service profile to multiple users.

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Open the Cisco Unified CM Administration interface.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select Bulk Administration &gt; Users &gt; Update Users &gt; Query. The Find and List Users To Update window opens.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select Next.</td>
</tr>
</tbody>
</table>
The Update Users Configuration window opens.

**Step 5** Select both of the Enable User for Unified CM IM and Presence check boxes.

*Important* There are two check boxes for Enable User for Unified CM IM and Presence. To disable instant messaging and presence, you select one check box. To enable instant messaging and presence, you select both check boxes.

**Step 6** Select the UC Service Profile check box and then select your service profile from the drop-down list.

*Important* Cisco Unified Communications Manager release 9.x only — If the user has only instant messaging and presence capabilities (IM only), you must select Use Default.

For IM only users — Cisco Unified Communications Manager release 9.x always applies the default service profile regardless of what you select from the UC Service Profile drop-down list.

**Step 7** In the Job Information section, specify if you want to run the job immediately or at a later time.

**Step 8** Select Submit.

---

**Associate User with Line**

If the user's presence is set as *Do not disturb*, then the user will not receive the IM notifications, but the user might receive call notifications, to avoid this associate user with Line.

This configuration is applicable for mobile clients.

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Navigate to Device > Phone

**Step 3** Select the user device.

For example, BOTuser or TABuser

**Step 4** From the Phone Configuration screen, select Directory Number or Line configured for this user device under Association.

**Step 5** From the Directory Number Configuration screen, associate the user under Users Associated with Line.
Configure Voicemail

- Configure Voicemail for an On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later, page 35
- Configure Cisco Unity Connection for Use with Cisco Jabber, page 36
- Configure Retrieval and Redirection, page 37
- Add a Voicemail Service, page 38
- Set a Voicemail Credentials Source, page 40

Configure Voicemail for an On-Premises Deployment with Cisco Unified Communications Manager Release 9.x and Later

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Configure Cisco Unity Connection for Use with Cisco Jabber, on page 36</td>
<td>Configure Cisco Unity Connection so that Cisco Jabber can access voicemail services.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Configure Retrieval and Redirection, on page 37</td>
<td>Configure retrieval so that users can access voice mail messages. Configure redirection so that users can send incoming calls to voicemail.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Add a Voicemail Service, on page 38</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Apply a Voicemail Service, on page 39</td>
<td>After you add a voicemail service, you must apply it to a service profile so that the client can retrieve the settings.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Set a Voicemail Credentials Source, on page 40</td>
<td></td>
</tr>
</tbody>
</table>
Configure Cisco Unity Connection for Use with Cisco Jabber

You must complete some specific steps to configure Cisco Unity Connection so that Cisco Jabber can access voicemail services. You should refer to the Cisco Unity Connection documentation for instructions on general tasks such as creating users, passwords, and provisioning users with voicemail access.

Remember
Cisco Jabber connects to the voicemail service through a REST interface and supports Cisco Unity Connection release 8.5 or later.

Procedure

Step 1 Ensure the Connection Jetty and Connection REST Service services are started.
   a) Open the Cisco Unity Connection Serviceability interface.
   b) Select Tools > Service Management.
   c) Locate the following services in the Optional Services section:
      • Connection Jetty
      • Connection REST Service
   d) Start the services if required.

Step 2 Open the Cisco Unity Connection Administration interface.

Step 3 Edit user password settings.
   a) Select Users.
   b) Select the appropriate user.
   c) Select Edit > Password Settings.
   d) Select Web Application from the Choose Password menu.
   e) Uncheck User Must Change at Next Sign-In.
   f) Select Save.

Step 4 Provide users with access to the web inbox.
   a) Select Class of Service.
      The Search Class of Service window opens.
   b) Select the appropriate class of service or add a new class of service.
   c) Select Allow Users to Use the Web Inbox and RSS Feeds.
   d) In the Features section, select Allow Users to Use Unified Client to Access Voice Mail.
   e) Select all other options as appropriate.
   f) Select Save.

Step 5 Select API configuration settings.
   a) Select System Settings > Advanced > API Settings.
      The API Configuration window opens.
   b) Select the following options:
Configure Voicemail

Configure Retrieval and Redirection

Configure retrieval so that users can access voicemail messages in the client interface. Configure redirection so that users can send incoming calls to voicemail. You configure retrieval and redirection on Cisco Unified Communications Manager.

**Procedure**

**Step 1**
Open the Cisco Unified CM Administration interface.

**Step 2**
Configure the voicemail pilot.
-a) Select Advanced Features > Voice Mail > Voice Mail Pilot.
The Find and List Voice Mail Pilots window opens.

-b) Select Add New.
The Voice Mail Pilot Configuration window opens.

c) Specify the appropriate details on the Voice Mail Pilot Configuration window.

-d) Select Save.

**Step 3**
Add the voicemail pilot to the voicemail profile.
-a) Select Advanced Features > Voice Mail > Voice Mail Profile.
The Find and List Voice Mail Profiles window opens.

-b) Specify the appropriate filters in the Find Voice Mail Profile where Voice Mail Profile Name field and then select Find to retrieve a list of profiles.

-c) Select the appropriate profile from the list.
The Voice Mail Pilot Configuration window opens.

-d) Select the voicemail pilot from the Voice Mail Pilot drop-down list.

-e) Select Save.

**Step 4**
Specify the voicemail profile in the directory number configuration.
-a) Select Device > Phone.
The Find and List Phones window opens.

-b) Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of devices.

- What to Do Next

If you have Cisco Unified Communications Manager release 9.x and later, Add a Voicemail Service, on page 38.
c) Select the appropriate device from the list. The Phone Configuration window opens.

d) Locate the Association Information section.
e) Select the appropriate device number. The Directory Number Configuration window opens.

f) Locate the Directory Number Settings section.
g) Select the voicemail profile from the Voice Mail Profile drop-down list.
h) Select Save.

What to Do Next
Set a Voicemail Credentials Source, on page 40

Add a Voicemail Service

Add a voicemail service, to allow users to receive voice messages.

Before You Begin
Configure Cisco Unity Connection for Use with Cisco Jabber, on page 36

Procedure

Step 1 Open the Cisco Unified CM Administration interface.

Step 2 Select User Management > User Settings > UC Service. The Find and List UC Services window opens.

Step 3 In the Find and List UC Services window, select Add New. UC Service Configuration window opens.

Step 4 In the Add a UC Service section, select Voicemail from the UC Service Type drop-down list and select Next.

Step 5 Specify details for the voicemail service as follows:
  • Product Type — Select Unity Connection.
  • Name — Enter a descriptive name for the server, for example, PrimaryVoicemailServer.
  • Hostname/IP Address — Enter the IP address or the fully qualified domain name (FQDN) of the voicemail server.
  • Port — You do not need to specify a port number. By default, the client always uses port 443 to connect to the voicemail server. For this reason, any value you specify does not take effect.
  • Protocol Type — You do not need to specify a value. By default, the client always uses HTTPS to connect to the voicemail server. For this reason, any value you specify does not take effect.

Step 6 Select Save.
Apply a Voicemail Service

After you add a voicemail service on Cisco Unified Communications Manager, apply it to a service profile so that the client can retrieve the settings.

Note
Cisco Jabber does not read Voicemail UC Service Profile when it is deployed only in the Phone mode. For Cisco Jabber to retrieve the voicemail server information, update the `jabber-config.xml` file with the voicemail parameters.

```xml
<Voicemail>
  <VoicemailService_UseCredentialsFrom>phone</VoicemailService_UseCredentialsFrom>
  <VoicemailPrimaryServer>X.X.X.X</VoicemailPrimaryServer>
</Voicemail>
```

After updating, upload the `jabber-config.xml` file to all the CUCM TFTP servers and restart the TFTP service on TFTP server nodes. Then reset the Jabber client.

Before You Begin
Add a Voicemail Service, on page 38

Procedure

1. **Step 1** Open the Cisco Unified CM Administration interface.
2. **Step 2** Select User Management > User Settings > Service Profile. The Find and List Service Profiles window opens.
3. **Step 3** Find and select your service profile. The Service Profile Configuration window opens.
4. **Step 4** Configure the Voicemail Profile section as follows:
   a) Select up to three services from the following drop-down lists:
      - Primary
      - Secondary
      - Tertiary
   b) For Credentials source for voicemail service, select one of the following:
      - **Unified CM - IM and Presence** — Uses the instant messaging and presence credentials to sign in to the voicemail service. As a result, users do not need to enter their credentials for voicemail services in the client.
• **Web conferencing** — This option is not supported, it uses the conferencing credentials to sign in to the voicemail service. You cannot currently synchronize with conferencing credentials.

• **Not set** — This option is selected for Phone mode deployments.

**Step 5**  
Click **Save**.

**Step 6**  
Add users to the service profile.

a) Select **User Management > End User**.  
The **Find and List Users** window opens.

b) Specify the appropriate filters in the **Find User where** field and then select **Find** to find a user.

c) Click the user in the list.  
The **End User Configuration** window opens.

d) Under the **Service Settings** area, check the **Home Cluster** checkbox.

e) For Phone mode deployments, ensure the **Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile)** option is not selected.  
For all other deployments, check the **Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile)** checkbox.

f) Select your service profile from the **UC Service Profile** drop-down list.

g) Click **Save**.

---

### Set a Voicemail Credentials Source

You can specify a voicemail credentials source for users.

#### Tip

In hybrid cloud-based deployments, you can set a voicemail credentials source as part of your configuration file with the VoiceMailService_UseCredentialsForm parameter.

#### Before You Begin

**Configure Retrieval and Redirection**, on page 37

#### Procedure

**Step 1**  
Open the **Cisco Unified CM Administration** interface.

**Step 2**  
Select **User Management > User Settings > Service Profile**.

**Step 3**  
Select the appropriate service profile to open the **Service Profile Configuration** window.

**Step 4**  
In the **Voicemail Profile** section, select **Unified CM - IM and Presence** from the **Credentials source for voicemail service** drop-down list.

**Note**  
Do not select **Web Conferencing** from the **Credentials source for voicemail service** drop-down list. You cannot currently use conferencing credentials as a credentials source for voicemail services.
The user's instant messaging and presence credentials match the user's voicemail credentials. As a result, users do not need to specify their voicemail credentials in the client user interface.

**What to Do Next**

**Important**

There is no mechanism to synchronize credentials between servers. If you specify a credentials source, you must ensure that those credentials match the user's voicemail credentials.

For example, you specify that a user's instant messaging and presence credentials match the user's Cisco Unity Connection credentials. The user's instant messaging and presence credentials then change. You must update the user's Cisco Unity Connection credentials to reflect that change.

Cloud-Based deployments can use the configuration file parameter VoicemailService_UseCredentialsFrom. Set this parameter to the value `phone` to use the Cisco Unified Communications Manager credentials to sign in to Cisco Unity Connection.
Set a Voicemail Credentials Source
Configure WebEx Conferencing

- Configure Conferencing for an On-Premises Deployment, page 43

Configure Conferencing for an On-Premises Deployment

When you implement an on-premises deployment for Cisco Jabber, you can configure conferencing on-premises with Cisco WebEx Meetings Server, or in the cloud in Cisco WebEx Meetings Center.

Configure On-Premises Conferencing using WebEx Meetings Server

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Authenticate Cisco WebEx Meetings Server, on page 43.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager, on page 44.</td>
</tr>
</tbody>
</table>

Authenticate Cisco WebEx Meetings Server

Procedure

To authenticate with Cisco WebEx Meetings Server, complete one of the following options:

- Configure single sign-on (SSO) with Cisco WebEx Meetings Server to integrate with the SSO environment. In this case, you do not need to specify credentials for users to authenticate with Cisco WebEx Meetings Server
- Set a credentials source on Cisco Unified Communications Manager. If the users' credentials for Cisco WebEx Meetings Server match their credentials for Cisco Unified Communications Manager IM and
Presence Service or Cisco Unity Connection, you can set a credentials source. The client then automatically authenticates to Cisco WebEx Meetings Server with the users' credential source.

- Instruct users to manually enter credentials in the client.

**What to Do Next**

*Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager, on page 44*

## Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager

To configure conferencing on Cisco Unified Communications Manager, you must add a Cisco WebEx Meetings Server.

**Before You Begin**

Authenticate with Cisco WebEx Meetings Server

**Procedure**

**Step 1**
Open the **Cisco Unified CM Administration** interface and select **User Management > User Settings > UC Service**. The **Find and List UC Services** window opens.

**Step 2**
Select **Add New**.

**Step 3**
In the **Add a UC Service** section, from the **UC Service Type** drop-down list, select **Conferencing** and then select **Next**.

**Step 4**
Complete the following fields:

- **Product Type** — Select **WebEx (Conferencing)**.
- **Name** — Enter a name for the configuration. The name you specify is displayed when you add services to profiles. Ensure the name you specify is unique, meaningful, and easy to identify.
- **Hostname/IP Address** — Enter the site URL for Cisco WebEx Meetings Server. This URL is case sensitive and must match the case that was configured for the site URL in Cisco WebEx Meetings Server.
- **Port** — Leave the default value.
- **Protocol** — Select **HTTPS**.

**Step 5**
To use Cisco WebEx as the single sign-on (SSO) identity provider, check **User web conference server as SSO identity provider**.

**Note**
This field is available only if you select **WebEx (Conferencing)** from the **Product Type** drop-down list.

**Step 6**
Select **Save**.

**What to Do Next**

*Add the Cisco WebEx Meetings Server to a Service Profile, on page 45*
Add the Cisco WebEx Meetings Server to a Service Profile

After you add Cisco WebEx Meetings Server and add it to a service profile, the client can access conferencing features.

Before You Begin
Create a service profile.
Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager, on page 44

Procedure

Step 1  Open the Cisco Unified CM Administration interface and select User Management > User Settings > Service Profile
Step 2  Find and select your service profile.
Step 3  In the Conferencing Profile section, from the Primary, Secondary, and Tertiary drop-down lists, select up to three instances of Cisco WebEx Meetings Server.
Step 4  From the Server Certificate Verification drop-down list, select the appropriate value.
Step 5  From the Credentials source for web conference service drop-down list, select one of the following:
   • Not set—Select this option if the user does not have a credentials source that matches their Cisco WebEx Meetings Server credentials or if you use SSO at the meeting site.
   • Unified CM - IM and Presence—Select this option if the Cisco Unified Communications Manager IM and Presence Service credentials for the user match their Cisco WebEx Meetings Server credentials.
   • Voicemail—Select this option if the Cisco Unity Connection credentials for the user match their Cisco WebEx Meetings Server credentials.

Note  You cannot synchronize the credentials you specify in Cisco Unified Communications Manager with credentials you specify in Cisco WebEx Meetings Server. For example, if you specify that instant messaging and presence credentials for a user are synchronized with their Cisco WebEx Meetings Server credentials, the instant messaging and presence credentials for that user change. You must update the Cisco WebEx Meetings Server credentials for that user to match that change.

Step 6  Select Save.
Configure On-Premises Conferencing using WebEx Meetings Server
CHAPTER 8

Configure Deskphone Control

- Prerequisites, page 47
- Configure Deskphone Control Workflow, page 47
- Add a CTI Service, page 48
- Enable Device for CTI, page 49
- Desk Phone Video Configuration, page 49
- Enable Video Rate Adaptation, page 51
- Configure User Associations, page 52
- Reset Devices, page 54

Prerequisites

The Cisco CTI Manager service must be running in the Cisco Unified Communications Manager cluster.

Configure Deskphone Control Workflow

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Add a CTI Service, on page 48</td>
<td>Create a CTI UC service, the information is used by Jabber to locate the CTI Server.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Enable Device for CTI, on page 49</td>
<td>Allows Cisco Jabber desktop clients to control the desk phone of the user.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Desk Phone Video Configuration, on page 49.</td>
<td>Let users receive video transmitted to their desk phone devices on their computers through the client.</td>
</tr>
</tbody>
</table>
Add a CTI Service

The CTI service provides Jabber with the address of the UDS device service. The UDS device service provides a list of devices associated with the user.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service. The Find and List UC Services window opens.
Step 3 Select Add New. The UC Service Configuration window opens.
Step 4 In the Add a UC Service section, select CTI from the UC Service Type drop-down list.
Step 5 Select Next.
Step 6 Provide details for the instant messaging and presence service as follows:
   a) Specify a name for the service in the Name field. The name you specify displays when you add services to profiles. Ensure the name you specify is unique, meaningful, and easy to identify.
   b) Specify the CTI service address in the Host Name/IP Address field.
   c) Specify the port number for the CTI service in the Port field.
Step 7 Select Save.

What to Do Next
Add the CTI service to your service profile.

Apply a CTI Service

After you add a CTI service on Cisco Unified Communications Manager, you must apply it to a service profile so that the client can retrieve the settings.
Before You Begin

- Create a service profile if none already exists or if you require a separate service profile for CTI.
- Add a CTI service.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile. Find and List Service Profiles window opens.
Step 3 Find and select your service profile. Service Profile Configuration window opens.
Step 4 Navigate to CTI Profile section, and select up to three services from the following drop-down lists:
  - Primary
  - Secondary
  - Tertiary
Step 5 Select Save.

Enable Device for CTI

If you want Cisco Jabber desktop clients to be able to control the desk phone of the user, you must select the Allow Control of Device from CTI option when you create the device for the user.

Procedure

Step 1 In Cisco Unified CM Administration, click Device > Phone and search for the phone.
Step 2 In the Device Information section, check Allow Control of Device from CTI.
Step 3 Click Save.

Desk Phone Video Configuration

Desk phone video capabilities let users receive video transmitted to their desk phone devices on their computers through the client.

Set Up Desk Phone Video

To set up desk phone video, you must complete the following steps:
1 Physically connect the computer to the computer port on the desk phone device.

You must physically connect the computer to the desk phone device through the computer port so that the client can establish a connection to the device. You cannot use desk phone video capabilities with wireless connections to desk phone devices.

Tip

If users have both wireless and wired connections available, they should configure Microsoft Windows so that wireless connections do not take priority over wired connections. See the following Microsoft documentation for more information: An explanation of the Automatic Metric feature for Internet Protocol routes.

2 Enable the desk phone device for video in Cisco Unified Communications Manager.

3 Install Cisco Media Services Interface on the computer.

Cisco Media Services Interface provides the Cisco Discover Protocol (CDP) driver that enables the client to do the following:

- Discover the desk phone device.
- Establish and maintain a connection to the desk phone device using the CAST protocol.

Note

Download the Cisco Media Services Interface installation program from the download site on cisco.com.

Desk Phone Video Considerations

Review the following considerations and limitations before you provision desk phone video capabilities to users:

- You cannot use desk phone video capabilities on devices if video cameras are attached to the devices, such as a Cisco Unified IP Phone 9971. You can use desk phone video capabilities if you remove video cameras from the devices.
- You cannot use desk phone video capabilities with devices that do not support CTI.
- Video desktop sharing, using the BFCP protocol, is not supported with desk phone video.
- It is not possible for endpoints that use SCCP to receive video only. SCCP endpoints must send and receive video. Instances where SCCP endpoints do not send video result in audio only calls.
- 7900 series phones must use SCCP for desk phone video capabilities. 7900 series phones cannot use SIP for desk phone video capabilities.
- If a user initiates a call from the keypad on a desk phone device, the call starts as an audio call on the desk phone device. The client then escalates the call to video. For this reason, you cannot make video calls to devices that do not support escalation, such as H.323 endpoints. To use desk phone video capabilities with devices that do not support escalation, users should initiate calls from the client.
- A compatibility issue exists with Cisco Unified IP Phones that use firmware version SCCP45.9-2-1S. You must upgrade your firmware to version SCCP45.9-3-1 to use desk phone video capabilities.
• Some antivirus or firewall applications, such as Symantec Endpoint Protection, block inbound CDP packets, which disables desk phone video capabilities. You should configure your antivirus or firewall application to allow inbound CDP packets.

See the following Symantec technical document for additional details about this issue: *Cisco IP Phone version 7970 and Cisco Unified Video Advantage is Blocked by Network Threat Protection.*

• You must not select the **Media Termination Point Required** checkbox on the SIP trunk configuration for Cisco Unified Communications Manager. Desk phone video capabilities are not available if you select this checkbox.

**Desk Phone Video Troubleshooting**

If you encounter an error that indicates desk phone video capabilities are unavailable or the desk phone device is unknown, do the following:

1. Ensure you enable the desk phone device for video in Cisco Unified Communications Manager.
2. Reset the physical desk phone.
3. Exit the client.
4. Run services.msc on the computer where you installed the client.
5. Restart Cisco Media Services Interface.
6. Restart the client.

**Enable Video Rate Adaptation**

The client uses video rate adaptation to negotiate optimum video quality. Video rate adaptation dynamically increases or decreases video quality based on network conditions.

To use video rate adaptation, you must enable Real-Time Transport Control Protocol (RTCP) on Cisco Unified Communications Manager.

**Note**

RTCP is enabled on software phone devices by default. However, you must enable RTCP on desk phone devices.

**Enable RTCP on Common Phone Profiles**

You can enable RTCP on a common phone profile to enable video rate adaptation on all devices that use the profile.

**Note**

RTCP is an integral component of Jabber Telephony services. Jabber will continue to send RTCP packets even when disabled.
Enable RTCP on Device Configurations

You can enable RTCP on specific device configurations instead of a common phone profile. The specific device configuration overrides any settings you specify on the common phone profile.

**Procedure**

Step 1 Open the **Cisco Unified CM Administration** interface.
Step 2 Select **Device > Phone**.
   The **Find and List Phones** window opens.
Step 3 Specify the appropriate filters in the **Find Phone where** field and then select **Find** to retrieve a list of phones.
Step 4 Select the appropriate phone from the list.
   The **Phone Configuration** window opens.
Step 5 Locate the **Product Specific Configuration Layout** section.
Step 6 Select **Enabled** from the **RTCP** drop-down list.
Step 7 Select **Save**.

Configure User Associations

When you associate a user with a device, you provision that device to the user.

**Before You Begin**
Create and configure Cisco Jabber devices.
Procedure

Step 1  Open the Cisco Unified CM Administration interface.

Step 2  Select User Management > End User.
The Find and List Users window opens.

Step 3  Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.

Step 4  Select the appropriate user from the list.
The End User Configuration window opens.

Step 5  Locate the Service Settings section.

Step 6  Select Home Cluster.

Step 7  Select the appropriate service profile for the user from the UC Service Profile drop-down list.

Step 8  Locate the Device Information section.

Step 9  Select Device Association.
The User Device Association window opens.

Step 10 Select the devices to which you want to associate the user. Jabber only supports a single softphone association per device type. For example, only one TCT, BOT, CSF, and TAB device can be associated with a user.

Step 11 Select Save Selected/Changes.

Step 12 Select User Management > End User and return to the Find and List Users window.

Step 13 Find and select the same user from the list.
The End User Configuration window opens.

Step 14 Locate the Permissions Information section.

Step 15 Select Add to Access Control Group.
The Find and List Access Control Groups dialog box opens.

Step 16 Select the access control groups to which you want to assign the user.
At a minimum you should assign the user to the following access control groups:

• Standard CCM End Users
• Standard CTI Enabled

Remember  If you are provisioning users with secure phone capabilities, do not assign the users to the Standard CTI Secure Connection group.

Certain phone models require additional control groups, as follows:

• Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select Standard CTI Allow Control of Phones supporting Connected Xfer and conf.

• Cisco Unified IP Phone 6900 series, select Standard CTI Allow Control of Phones supporting Rollover Mode.

Step 17 Select Add Selected.
The Find and List Access Control Groups window closes.

Step 18 Select Save on the End User Configuration window.
Reset Devices

After you create and associate users with devices, you should reset those devices.

Procedure

Step 1  Open the Cisco Unified CM Administration interface.
Step 2  Select Device > Phone.  
The Find and List Phones window opens.
Step 3  Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of devices.
Step 4  Select the appropriate device from the list.  
The Phone Configuration window opens.
Step 5  Locate the Association Information section.  
Step 6  Select the appropriate directory number configuration.  
The Directory Number Configuration window opens.
Step 7  Select Reset.  
The Device Reset dialog box opens.
Step 8  Select Reset.
Step 9  Select Close to close the Device Reset dialog box.
## Configure Softphone

- Configure Softphones Workflow, page 55

### Configure Softphones Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create and Configure Cisco Jabber Devices, on page 55</td>
<td>Create at least one device for every user that will access Cisco Jabber.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Configure a SIP Trunk, on page 60</td>
<td>From Release 11.5(3), you must create a SIP trunk between Cisco Unified Communications Manager and IM and Presence Service if you want users to see phone presence from Cisco Jabber.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Configure User Associations, on page 52</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Create Mobile SIP Profiles, on page 64.</td>
<td>Complete this task if you have Cisco Unified Communications Manager release 9 and plan to configure devices for mobile clients.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure the Phone Security Profile, on page 66</td>
<td>Complete this task to set up secure phone capabilities for all devices.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Provide Users with Authentication Strings, on page 67</td>
<td></td>
</tr>
</tbody>
</table>

### Create and Configure Cisco Jabber Devices

Create at least one device for every user that accesses Cisco Jabber. A user can have multiple devices.
Before You Begin

- Install COP files.
- Enable mobility for each user for whom you plan to assign to a CTI remote device.
- Create SIP profiles if you have Cisco Unified Communications Manager release 9 or earlier and plan to configure devices for mobile clients.
- Create the Phone Security Profile if you plan to set up secure phone capabilities for all devices.
- For Cisco Unified Communications Manager release 10 or later, ensure that the Cisco Certificate Authority Proxy Function (CAPF) service parameters value for Certificate Issuerto Endpoint is Cisco Certificate Authority Proxy Function, this is the only option supported by Cisco Jabber. For information on configuring the CAPF service parameter see the Update CAPF Service Parameters topic in the Cisco Unified Communications Manager Security Guides.
- Before you create TCT devices, BOT devices, or TAB devices for Cisco Jabber for mobile users, specify the organization top domain name to support registration between Cisco Jabber and the Cisco Unified Communications Manager. In Unified CM Administration interface, select System > Enterprise Parameters. Under the Clusterwide Domain Configuration section, enter the organization top domain name. For example, cisco.com. This top domain name is used by Jabber as the DNS domain of the Cisco Unified Communications Manager servers for phone registration. For example, CUCMServer1@cisco.com.

Procedure

**Step 1** Log in to the Cisco Unified CM Administration interface.

**Step 2** Select Device > Phone. Find and List Phones window opens.

**Step 3** Select Add New.

**Step 4** From the Phone Type drop-down list, select the option that is applicable to the device type you are configuring and then select Next. For Jabber users, you can only create one type of device per user although you can create multiple devices for each user. For example, you can create one tablet device and one CSF device but not two CSF devices.

- **Cisco Unified Client Services Framework**—Select this option to create a CSF device for Cisco Jabber for Mac or Cisco Jabber for Windows.
- **Cisco Dual Mode for iPhone**—Select this option to create a TCT device for an iPhone.
- **Cisco Jabber for Tablet**—Select this option to create a TAB device for an iPad or an Android tablet.
- **Cisco Dual Mode for Android**—Select this option to create a BOT device for an Android device.
- **CTI Remote Device**—Select this option to create a CTI remote device.
CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

**Step 5** From the **Owner User ID** drop-down list, select the user for whom you want to create the device.
For the **Cisco Unified Client Services Framework** option in a Phone mode deployment, ensure that **User** is selected.

**Step 6** In the **Device Name** field, use the applicable format to specify a name for the device:

<table>
<thead>
<tr>
<th>If You Select</th>
<th>Required Format</th>
</tr>
</thead>
</table>
| **CTI Remote Device**                | • When you select **Owner User ID**, the device name field populates with \textit{CTIRD<owner user ID>}. You can change this value. The device name does not have to begin with \textit{CTIRD}.
  • Valid characters: a–z, A–Z, 0–9, period (.), underscore (_), hyphen (-).
  • 15-character limit.               |
| **Cisco Unified Client Services Framework** | • Valid characters: a–z, A–Z, 0–9.
  • 15-character limit.               |
| **Cisco Dual Mode for iPhone**       | • The device name must begin with \textit{TCT}.
  For example, if you create a TCT device for user, Tanya Adams, whose username is tadams, enter TCTTADAMS.
  • Must be uppercase.
  • Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).
  • 15-character limit.               |
| **Cisco Jabber for Tablet**          | • The device name must begin with \textit{TAB}.
  For example, if you create a TAB device for user, Tanya Adams, whose username is tadams, enter TABTADAMS.
  • Must be uppercase.
  • Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).
  • 15-character limit.               |
### If You Select | Required Format
--- | ---
Cisco Dual Mode for Android | • The device name must begin with BOT.
  
  For example, if you create a BOT device for user, Tanya Adams, whose username is tadams, enter BOTTADAMS.

  • Must be uppercase.

  • Valid characters: A–Z, 0–9, period (.), underscore (_), hyphen (-).

  • 15-character limit.

---

**Step 7** If you are creating a CTI Remote Device, in the **Protocol Specific Information** section, select an appropriate option from the **Rerouting Calling Search Space** drop-down list.

The Rerouting Calling Search Space defines the calling search space for rerouting and ensures that users can send and receive calls from the CTI remote device.

**Step 8** To generate an authentication string that you can provide to end users to access their devices and securely register to Cisco Unified Communications Manager, navigate to the **Certification Authority Proxy Function (CAPF) Information** section.

**Step 9** From the **Certificate Operation** drop-down list, select **Install/Upgrade**.

**Step 10** From the **Authentication Mode** drop-down list, select **By Authentication String** or **By Null String**.

**Note** Using the CAPF Authentication mode **By Null String** with VXME and Jabber for Windows CSF devices is not supported. It causes Jabber registration with Cisco Unified Communications Manager (CUCM) to fail.

**Step 11** Click **Generate String**.

The Authentication String autopopulates with a string value. This is the string that you will provide to end users.

**Step 12** From the **Key Size (Bits)** drop-down list, select the same key size that you set in the phone security profile.

**Step 13** In the **Operation Completes By** fields, specify an expiration value for the authentication string or leave as default.

**Step 14** If you are using a group configuration file, specify it in the **Cisco Support Field** of the **Desktop Client Settings**. Cisco Jabber does not use any other settings that are available on the **Desktop Client Settings**.

**Step 15** Select **Save**.

**Step 16** Click **Apply Config**.

---

**What to Do Next**

Add a Directory Number to the device.

### Add a Directory Number to the Device

After you create and configure each device, you must add a directory number to the device. This topic provides instructions on adding directory numbers using the **Device > Phone** menu option.
Before You Begin

Create a device.

Procedure

Step 1 Locate the Association Information section on the Phone Configuration window.
Step 2 Click Add a new DN.
Step 3 In the Directory Number field, specify a directory number.
Step 4 In the Users Associated with Line section, click Associate End Users.
Step 5 In the Find User where field, specify the appropriate filters and then click Find.
Step 6 From the list that appears, select the applicable users and click Add Selected.
Step 7 Specify all other required configuration settings as appropriate.
Step 8 Select Apply Config.
Step 9 Select Save.

Add a Remote Destination

Remote destinations represent the CTI controllable devices that are available to users. You should add a remote destination through the Cisco Unified CM Administration interface if you plan to provision users with dedicated CTI remote devices. This task ensures that users can automatically control their phones and place calls when they start the client.

If you plan to provision users with CTI remote devices along with software phone devices and desk phone devices, you should not add a remote destination through the Cisco Unified CM Administration interface. Users can enter remote destinations through the client interface.

Note

- You should create only one remote destination per user. Do not add two or more remote destinations for a user.
- Cisco Unified Communications Manager does not verify if it can route remote destinations that you add through the Cisco Unified CM Administration interface. For this reason, you must ensure that Cisco Unified Communications Manager can route the remote destinations you add.
- Cisco Unified Communications Manager automatically applies application dial rules to all remote destination numbers for CTI remote devices.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.
The Find and List Phones window opens.

**Step 3** Specify the appropriate filters in the Find Phone where field to and then select Find to retrieve a list of phones.

**Step 4** Select the CTI remote device from the list.
The Phone Configuration window opens.

**Step 5** Locate the Associated Remote Destinations section.

**Step 6** Select Add a New Remote Destination.
The Remote Destination Information window opens.

**Step 7** Specify JabberRD in the Name field.

**Restriction** You must specify JabberRD in the Name field. The client uses only the JabberRD remote destination. If you specify a name other than JabberRD, users cannot access that remote destination.

The client automatically sets the JabberRD name when users add remote destinations through the client interface.

**Step 8** Enter the destination number in the Destination Number field.

**Step 9** Specify all other values as appropriate.

**Step 10** Select Save.

---

**What to Do Next**
Complete the following steps to verify the remote destination and apply the configuration to the CTI remote device:

1. Repeat the steps to open the Phone Configuration window for the CTI remote device.
2. Locate the Associated Remote Destinations section.
3. Verify the remote destination is available.
4. Select Apply Config.

---

**Note** The Device Information section on the Phone Configuration window contains a Active Remote Destination field.

When users select a remote destination in the client, it displays as the value of Active Remote Destination.

none displays as the value of Active Remote Destination if:

- Users do not select a remote destination in the client.
- Users exit or are not signed in to the client.

---

**Configure a SIP Trunk**

From Release 11.5(3), you must configure a SIP trunk between Cisco Unified Communications Manager and IM and Presence Service if you want users to see phone presence.
## Configure a SIP Trunk Security Profile for IM and Presence Service

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From Cisco Unified CM Administration choose System &gt; Security &gt; SIP Trunk Security Profile.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click Find.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click Non Secure SIP Trunk Profile.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click Copy and enter a name for the SIP trunk profile in the Name field.</td>
</tr>
</tbody>
</table>
| Step 5 | Verify the following settings:  
  • Device Security Mode = Non Secure  
  • Incoming Transport Type = TCP + UDP  
  • Outgoing Transport Type = TCP |
| Step 6 | Check to enable the following items:  
  • Accept presence subscription  
  • Accept out-of-dialog refer  
  • Accept unsolicited notification  
  • Accept replaces header |
| Step 7 | Click Save. |

### What to Do Next

Configure a SIP Trunk for IM and Presence Service, on page 61

## Configure a SIP Trunk for IM and Presence Service

You only configure one SIP trunk between a Cisco Unified Communications Manager cluster and an IM and Presence Service cluster. After you configure the SIP trunk, you must assign that SIP trunk as the IM and Presence PUBLISH Trunk on Cisco Unified Communications Manager.

In the **Destination Address** field, enter a value using one of the following formats:

- dotted IP address
- fully qualified domain name (FQDN)
- DNS SRV

If high availability is configured for the IM and Presence cluster, multiple entries should be entered in the dotted IP address or FQDN to identify the various nodes in the cluster. DNS SRV cannot be used for an IM and Presence cluster if high availability is configured.
Before You Begin

Configure a SIP Trunk Security Profile for IM and Presence Service, on page 61

Procedure

Step 1 From Cisco Unified CM Administration, choose Device > Trunk.
Step 2 Click Add New.
Step 3 Choose SIP Trunk from the Trunk Type menu.
Step 4 Choose SIP from the Device Protocol menu.
Step 5 Choose None for the Trunk Service Type.
Step 6 Click Next.
Step 7 Enter CUPS-SIP-Trunk for the Device Name.
Step 8 Choose a device pool from the Device Pool menu.
Step 9 In the SIP Information section at the bottom of the window, configure the following values:
   a) In the Destination Address field, enter the Dotted IP Address, or the FQDN, which can be resolved by DNS and must match the SRV Cluster Name configured on the IM and Presence node.
   b) Check the Destination Address is an SRV if you are configuring a multinode deployment.
      In this scenario, Cisco Unified Communications Manager performs a DNS SRV record query to resolve the name, for example _sip._tcp.hostname.tld. If you are configuring a single-node deployment, leave this checkbox unchecked and Cisco Unified Communications Manager will perform a DNS A record query to resolve the name, for example hostname.tld.
      Cisco recommends that you use the IM and Presence Service default domain as the destination address of the DNS SRV record.
      Note You can specify any domain value as the destination address of the DNS SRV record. No users need to be assigned to the domain that is specified. If the domain value that you enter differs from the IM and Presence Service default domain, you must ensure that the SIP Proxy Service Parameter called SRV Cluster Name on IM and Presence Service matches the domain value that you specify in the DNS SRV record. If you use the default domain, then no changes are required to the SRV Cluster Name parameter.
      In both scenarios, the Cisco Unified Communications SIP trunk Destination Address must resolve by DNS and match the SRV Cluster Name configured on the IM and Presence node.
   c) Enter 5060 for the Destination Port.
   d) Choose Non Secure SIP Trunk Profile from the SIP Trunk Security Profile menu.
   e) Choose Standard SIP Profile from the SIP Profile menu.
Step 10 Click Save.

Troubleshooting Tip

If you modify the DNS entry of the Publish SIP Trunk SRV record by changing the port number or IP address, you must restart all devices that previously published to that address and ensure each device points to the correct IM and Presence Service contact.

What to Do Next

Configure SIP Publish Trunk, on page 63
Configure SIP Publish Trunk

Complete this procedure to enable Cisco Unified Communications Manager to publish phone presence for all line appearances that are associated with users licenses on Cisco Unified Communications Manager for IM and Presence Service.

**Before You Begin**
Configure a SIP Trunk for IM and Presence Service, on page 61

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From Cisco Unified CM IM and Presence Administration choose <strong>Presence</strong> &gt; <strong>Settings</strong> &gt; <strong>Standard Configuration</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>From the CUCM SIP Publish Trunk drop-down list, choose a SIP trunk.</td>
</tr>
<tr>
<td>3</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Configure User Associations

When you associate a user with a device, you provision that device to the user.

**Before You Begin**
Create and configure Cisco Jabber devices.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open the Cisco Unified CM Administration interface.</td>
</tr>
</tbody>
</table>
| 2    | Select **User Management** > **End User**.  
The **Find and List Users** window opens. |
| 3    | Specify the appropriate filters in the **Find User where** field and then select **Find** to retrieve a list of users. |
| 4    | Select the appropriate user from the list.  
The **End User Configuration** window opens. |
| 5    | Locate the **Service Settings** section. |
| 6    | Select **Home Cluster**. |
| 7    | Select the appropriate service profile for the user from the **UC Service Profile** drop-down list. |
| 8    | Locate the **Device Information** section. |
| 9    | Select **Device Association**. |
The User Device Association window opens.

**Step 10** Select the devices to which you want to associate the user. Jabber only supports a single softphone association per device type. For example, only one TCT, BOT, CSF, and TAB device can be associated with a user.

**Step 11** Select Save Selected/Changes.

**Step 12** Select User Management > End User and return to the Find and List Users window.

**Step 13** Find and select the same user from the list.

The End User Configuration window opens.

**Step 14** Locate the Permissions Information section.

**Step 15** Select Add to Access Control Group.

The Find and List Access Control Groups dialog box opens.

**Step 16** Select the access control groups to which you want to assign the user.

At a minimum you should assign the user to the following access control groups:

- Standard CCM End Users
- Standard CTI Enabled

**Remember** If you are provisioning users with secure phone capabilities, do not assign the users to the Standard CTI Secure Connection group.

Certain phone models require additional control groups, as follows:

- Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select Standard CTI Allow Control of Phones supporting Connected Xfer and conf.
- Cisco Unified IP Phone 6900 series, select Standard CTI Allow Control of Phones supporting Rollover Mode.

**Step 17** Select Add Selected.

The Find and List Access Control Groups window closes.

**Step 18** Select Save on the End User Configuration window.

---

**Create Mobile SIP Profiles**

This procedure is required only when you use Cisco Unified Communication Manager release 9 and are configuring devices for mobile clients. Use the default SIP profile provided for desktop clients. Before you create and configure devices for mobile clients, you must create a SIP profile that allows Cisco Jabber to stay connected to Cisco Unified Communication Manager while Cisco Jabber runs in the background.

If you use Cisco Unified Communication Manager Release 10, choose the Standard SIP Profile for Mobile Device default profile when you create and configure devices for mobile clients.

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select Device > Device Settings > SIP Profile.
The **Find and List SIP Profiles** window opens.

**Step 3** Do one of the following to create a new SIP profile:

- Find the default SIP profile and create a copy that you can edit.
- Select **Add New** and create a new SIP profile.

**Step 4** In the new SIP profile, set the following values:

- **Timer Register Delta** = 120
- **Timer Register Expires** = 720
- **Timer Keep Alive Expires** = 720
- **Timer Subscribe Expires** = 21600
- **Timer Subscribe Delta** = 15

**Step 5** Select **Save**.

---

**Setting up System SIP Parameters**

If you are connected to a low-bandwidth network and finding it difficult to take an incoming call on your mobile device, you can set the system SIP parameters to improve the condition. Increase the SIP Dual Mode Alert Timer value to ensure that calls to the Cisco Jabber extension are not prematurely routed to the mobile-network phone number.

**Before You Begin**

This configuration is only for mobile clients.

Cisco Jabber must be running to receive work calls.

**Procedure**

**Step 1** Open the **Cisco Unified CM Administration** interface.

**Step 2** Select **System > Service Parameters**.

**Step 3** Select the node.

**Step 4** Select the **Cisco CallManager (Active)** service.

**Step 5** Scroll to the **Clusterwide Parameters (System - Mobility)** section.

**Step 6** Increase the **SIP Dual Mode Alert Timer** value to 10000 milliseconds.

**Step 7** Select **Save**.

**Note** If, after you increase the SIP Dual Mode Alert Timer value, incoming calls that arrive in Cisco Jabber are still terminated and diverted using Mobile Connect, you can increase the SIP Dual Mode Alert Timer value again in increments of 500 milliseconds.
Configure the Phone Security Profile

You can optionally set up secure phone capabilities for all devices. Secure phone capabilities provide secure SIP signaling, secure media streams, and encrypted device configuration files.

If you enable secure phone capabilities for users, device connections to Cisco Unified Communications Manager are secure. However, calls with other devices are secure only if both devices have a secure connection.

Before You Begin

- Configure the Cisco Unified Communications Manager security mode using the Cisco CTL Client. At minimum, select mixed mode security.
  
  For instructions on how to configure mixed mode with the Cisco CTL Client, see the Cisco Unified Communications Manager Security Guide.

- For conference calls, ensure that the conferencing bridge supports secure phone capabilities. If the conferencing bridge does not support secure phone capabilities, calls to that bridge are not secure. Likewise, all parties must support a common encryption algorithm for the client to encrypt media on conference calls.

Procedure

Step 1  In Cisco Unified Communications Manager, select System > Security > Phone Security Profile.

Step 2  Select Add New.

Step 3  From the Phone Type drop-down list, select the option that is applicable to the device type you are configuring and then select Next.

  - Cisco Unified Client Services Framework—Select this option to create a CSF device for Cisco Jabber for Mac or Cisco Jabber for Windows.
  
  - Cisco Dual Mode for iPhone—Select this option to create a TFT device for an iPhone.
  
  - Cisco Jabber for Tablet—Select this option to create a TAB device for an iPad or an Android tablet.
  
  - Cisco Dual Mode for Android—Select this option to create a BOT device for an Android device.
  
  - CTI Remote Device—Select this option to create a CTI remote device.

  CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

Step 4  In the Name field of the Phone Security Profile Configuration window, specify a name for the phone security profile.

Step 5  For Device Security Mode, select one of the following options:

  - Authenticated—The SIP connection is over TLS using NULL-SHA encryption.
  
  - Encrypted—The SIP connection is over TLS using AES 128/SHA encryption. The client uses Secure Real-time Transport Protocol (SRTP) to offer encrypted media streams.

Step 6  For Transport Type, leave the default value of TLS.

Step 7  Select the TFTP Encrypted Config check box to encrypt the device configuration file that resides on the TFTP server.
For a TCT/BOT/Tablet device, do not select the TFTP Encrypted Config check box here. For Authentication Mode, select By Authentication String or Null String.

**Step 8**

For Authentication Mode, select **By Authentication String** or **By Null String**.

**Note**

Using the CAPF Authentication mode **By Null String** with VXME and Jabber for Windows CSF devices is not supported. It causes Jabber registration with Cisco Unified Communications Manager (CUCM) to fail.

**Step 9**

For Key Size (Bits), select the appropriate key size for the certificate. Key size refers to the bit length of the public and private keys that the client generates during the CAPF enrollment process.

The Cisco Jabber clients were tested using authentication strings with 1024-bit length keys. The Cisco Jabber clients require more time to generate 2048-bit length keys than 1024-bit length keys. As a result, if you select 2048, expect it to take longer to complete the CAPF enrollment process.

**Step 10**

For SIP Phone Port, leave the default value.

The port that you specify in this field takes effect only if you select **Non Secure** as the value for Device Security Mode.

**Step 11**

Click Save.

---

**Provide Users with Authentication Strings**

Users must specify the authentication string in the client interface to access their devices and securely register with Cisco Unified Communications Manager.

When users enter the authentication string in the client interface, the CAPF enrollment process begins.

**Note**

The time it takes for the enrollment process to complete can vary depending on the user's computer or mobile device and the current load for Cisco Unified Communications Manager. It can take up to one minute for the client to complete the CAPF enrollment process.

The client displays an error if:

- Users enter an incorrect authentication string.

Users can attempt to enter authentication strings again to complete the CAPF enrollment. However, if a user continually enters an incorrect authentication string, the client might reject any string the user enters, even if the string is correct. In this case, you must generate a new authentication string on the user's device and then provide it to the user.

- Users do not enter the authentication string before the expiration time you set in the Operation Completes By field.

In this case, you must generate a new authentication string on the user's device. The user must then enter that authentication string before the expiration time.
When you configure the end users in Cisco Unified Communications Manager, you must add them to the following user groups:

- **Standard CCM End Users**
- **Standard CTI Enabled**

Users must not belong to the Standard CTI Secure Connection user group.
Configure Extend and Connect Workflow

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Enable User Mobility, on page 69</td>
<td></td>
</tr>
<tr>
<td><strong>Step 2</strong> Create CTI Remote Devices, on page 70</td>
<td></td>
</tr>
<tr>
<td><strong>Step 3</strong> Configure User Associations, on page 52</td>
<td></td>
</tr>
</tbody>
</table>

**Enable User Mobility**

This task is only for desktop clients.

You must enable user mobility to provision CTI remote devices. If you do not enable mobility for users, you cannot assign those users as owners of CTI remote devices.

**Before You Begin**

This task is applicable only if:

- You plan to assign Cisco Jabber for Mac or Cisco Jabber for Windows users to CTI remote devices.
- You have Cisco Unified Communication Manager release 9.x and later.

**Procedure**

**Step 1** Select User Management > End User.
The **Find and List Users** window opens.

**Step 2** Specify the appropriate filters in the **Find User where** field to and then select **Find** to retrieve a list of users.

**Step 3** Select the user from the list.

The **End User Configuration** window opens.

**Step 4** Locate the **Mobility Information** section.

**Step 5** Select **Enable Mobility**.

**Step 6** Select **Save**.

---

## Create CTI Remote Devices

CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

**Procedure**

**Step 1** Open the **Cisco Unified CM Administration** interface.

**Step 2** Select **Device > Phone**.

The **Find and List Phones** window opens.

**Step 3** Select **Add New**.

**Step 4** Select **CTI Remote Device** from the **Phone Type** drop-down list and then select **Next**.

The **Phone Configuration** window opens.

**Step 5** Select the appropriate user ID from the **Owner User ID** drop-down list.

**Note** Only users for whom you enable mobility are available from the **Owner User ID** drop-down list.

For more information, see **Enable SAML SSO in the Client**.

Cisco Unified Communications Manager populates the **Device Name** field with the user ID and a **CTIRD** prefix; for example, **CTIRDusername**

**Step 6** Edit the default value in the **Device Name** field, if appropriate.

**Step 7** Ensure you select an appropriate option from the **Rerouting Calling Search Space** drop-down list in the **Protocol Specific Information** section.

The **Rerouting Calling Search Space** drop-down list defines the calling search space for re-routing and ensures that users can send and receive calls from the CTI remote device.

**Step 8** Specify all other configuration settings on the **Phone Configuration** window as appropriate.

See the **CTI remote device setup** topic in the **System Configuration Guide for Cisco Unified Communications Manager** documentation for more information.

**Step 9** Select **Save**.

The fields to associate directory numbers and add remote destinations become available on the **Phone Configuration** window.
Configure User Associations

When you associate a user with a device, you provision that device to the user.

Before You Begin
Create and configure Cisco Jabber devices.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > End User.
The Find and List Users window opens.
Step 3 Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.
Step 4 Select the appropriate user from the list.
The End User Configuration window opens.
Step 5 Locate the Service Settings section.
Step 6 Select Home Cluster.
Step 7 Select the appropriate service profile for the user from the UC Service Profile drop-down list.
Step 8 Locate the Device Information section.
Step 9 Select Device Association.
The User Device Association window opens.
Step 10 Select the devices to which you want to associate the user. Jabber only supports a single softphone association per device type. For example, only one TCT, BOT, CSF, and TAB device can be associated with a user.
Step 11 Select Save Selected/Changes.
Step 12 Select User Management > End User and return to the Find and List Users window.
Step 13 Find and select the same user from the list.
The End User Configuration window opens.
Step 14 Locate the Permissions Information section.
Step 15 Select Add to Access Control Group.
The Find and List Access Control Groups dialog box opens.
Step 16 Select the access control groups to which you want to assign the user.
At a minimum you should assign the user to the following access control groups:

• Standard CCM End Users
• Standard CTI Enabled

Remember If you are provisioning users with secure phone capabilities, do not assign the users to the Standard CTISecure Connection group.

Certain phone models require additional control groups, as follows:

• Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select Standard CTI Allow Control of Phones supporting Connected Xfer and conf.
• Cisco Unified IP Phone 6900 series, select **Standard CTI Allow Control of Phones supporting Rollover Mode**.

**Step 17**  Select **Add Selected**.

The **Find and List Access Control Groups** window closes.

**Step 18**  Select **Save** on the **End User Configuration** window.
Configure a Service Profile

Configure Service Profiles Workflow

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1 Configure Service Profiles, on page 73</td>
<td>You can configure some client settings in UC service profiles on Cisco Unified Communications Manager version 9 and later.</td>
</tr>
<tr>
<td>Step 2 Parameters in Service Profiles, on page 74</td>
<td></td>
</tr>
<tr>
<td>Step 3 Add Cisco Unified Communications Manager Services, on page 76</td>
<td></td>
</tr>
<tr>
<td>Step 4 Create Service Profiles, on page 77</td>
<td></td>
</tr>
<tr>
<td>Step 5 Apply Service Profiles, on page 78</td>
<td></td>
</tr>
<tr>
<td>Step 6 Associate Users with Devices, on page 78</td>
<td></td>
</tr>
</tbody>
</table>

Configure Service Profiles

You can configure some client settings in UC service profiles on Cisco Unified Communications Manager version 9 and later.
**Important**

- Cisco Jabber only retrieves configuration from service profiles on Cisco Unified Communications Manager if the client gets the `_cisco-uds` SRV record from a DNS query.

  In a hybrid environment, if the CAS URL lookup is successful Cisco Jabber retrieves the configurations from Cisco WebEx Messenger service and the `_cisco-uds` SRV record is ignored.

- In an environment with multiple Cisco Unified Communications Manager clusters, you can configure the Intercluster Lookup Service (ILS). ILS enables the client to find the user's home cluster and discover services.

  If you do not configure ILS, then you must manually configure remote cluster information, similar to the EMCC remote cluster set up. For more information on Remote Cluster Configuration, see the *Cisco Unified Communications Manager Features and Services Guide*.

---

**Parameters in Service Profiles**

Learn which configuration parameters you can set in service profiles. Review the corresponding parameters in the client configuration file.

**IM and Presence Service Profile**

The following table lists the configuration parameters you can set in the IM and Presence Service profile:
**Parameter** | **Description**
--- | ---
**Product type** | Provides the source of authentication to Cisco Jabber and has the following values:
- Unified CM (IM and Presence Service) — Cisco Unified Communications Manager IM and Presence Service is the authenticator.
- WebEx (IM and Presence Service) — The Cisco WebEx Messenger service is the authenticator.

**Note** As of this release, the client issues an HTTP query in addition to the query for SRV records. The HTTP query allows the client to determine if it should authenticate to the Cisco WebEx Messenger service.

As a result of the HTTP query, the client connects to the Cisco WebEx Messenger service in cloud-based deployments before getting the _cisco-uds SRV record. Setting the value of the **Product type** field to **WebEx** may have no practical effect if the WebEx service has already been discovered by a CAS lookup.

- Not set — If the service profile does not contain an IM and presence service configuration, the authenticator is Cisco Unified Communications Manager.

**Primary server** | Specifies the address of your primary presence server.
- On-Premises Deployments — You should specify the fully qualified domain name (FQDN) of Cisco Unified Communications Manager IM and Presence Service.
- Cloud-Based Deployments — The client uses the following URL as default when you select **WebEx** as the value for the **Product type** parameter:
  https://loginp.webexconnect.com/cas/auth.do
  This default URL overrides any value that you set.

---

**Voicemail Profile**

The following table lists the configuration parameters you can set in the voicemail profile:
Parameter | Description
--- | ---
Voicemail server | Specifies connection settings for the voicemail server.
Credentials source for voicemail service | Specifies that the client uses the credentials for the instant messaging and presence or conferencing service to authenticate with the voicemail service. Ensure that the credentials source that you set match the user's voicemail credentials. If you set a value for this parameter, users cannot specify their voicemail service credentials in the client user interface.

Conferencing Profile

The following table lists the configuration parameters you can set in the conferencing profile:

| Conferencing Service Configuration | Description |
--- | ---
Conferencing server | Specifies connection settings for the conferencing server. |
Credentials source for web conference service | Specifies that the client uses the credentials for the instant messaging and presence or voicemail service to authenticate with the conferencing service. Ensure that the credentials source that you set match the user's conferencing credentials. |

Directory Profile

See the *Client Configuration for Directory Integration* chapter for information about configuring directory integration in a service profile.

CTI Profile

The following table lists the configuration parameters you can set in the CTI profile:

| CTI Service Configuration | Description |
--- | ---
CTI server | Specifies connection settings for the CTI server. |

Add Cisco Unified Communications Manager Services

Add Cisco Unified Communications Manager services to specify the address, ports, protocols, and other settings for services such as IM and Presence Service, voicemail, conferencing, and directory.
**Configure a Service Profile**

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select User Management > User Settings > UC Service. The Find and List UC Services window opens.

**Step 3** Select Add New. The UC Service Configuration window opens.

**Step 4** Select the UC service type you want to add and then select Next.

**Step 5** Configure the UC service as appropriate and then select Save.

**What to Do Next**

Add your UC services to service profiles.

**Create Service Profiles**

After you add and configure Cisco Unified Communications Manager services, you add them to a service profile. You can apply additional configuration in the service profile.

**Procedure**

**Step 1** Open the Cisco Unified CM Administration interface.

**Step 2** Select User Management > User Settings > Service Profile. The Find and List UC Services window opens.

**Step 3** Select Add New. The Service Profile Configuration window opens.

**Step 4** Enter a name for the service profile in the Name field.

**Step 5** Select Make this the default service profile for the system if you want the service profile to be the default for the cluster.

**Note** On Cisco Unified Communications Manager release 9.x only, users who have only instant messaging capabilities (IM only) must use the default service profile. For this reason, you should set the service profile as the default if you plan to apply the service profile to IM only users.

**Step 6** Add your UC services, apply any additional configuration, and then select Save.

**What to Do Next**

Apply service profiles to end user configuration.
Apply Service Profiles

After you add UC services and create a service profile, you apply the service profile to users. When users sign in to Cisco Jabber, the client can then retrieve the service profile for that user from Cisco Unified Communications Manager.

Procedure

Step 1  Open the Cisco Unified CM Administration interface.
Step 2  Select User Management > End User. 
The Find and List Users window opens.
Step 3  Enter the appropriate search criteria to find existing users and then select a user from the list. 
The End User Configuration window opens.
Step 4  Locate the Service Settings section.
Step 5  Select a service profile to apply to the user from the UC Service Profile drop-down list. 
Important Cisco Unified Communications Manager release 9.x only: If the user has only IIM and Presence Service capabilities (IM only), you must select Use Default. For IM only users, Cisco Unified Communications Manager release 9.x always applies the default service profile regardless of what you select from the UC Service Profile drop-down list.
Step 6  Apply any other configuration as appropriate and then select Save.

Associate Users with Devices

On Cisco Unified Communications Manager version 9.x only, when the client attempts to retrieve the service profile for the user, it first gets the device configuration file from Cisco Unified Communications Manager. The client can then use the device configuration to get the service profile that you applied to the user.

For example, you provision Adam McKenzie with a CSF device named CSFAKenzi. The client retrieves CSFAKenzi.cnf.xml from Cisco Unified Communications Manager when Adam signs in. The client then looks for the following in CSFAKenzi.cnf.xml:

```
<userId serviceProfileFile="identifier.cnf.xml">amckenzi</userId>
```

For this reason, if you are using Cisco Unified Communications Manager version 9.x, you should do the following to ensure that the client can successfully retrieve the service profiles that you apply to users:

- Associate users with devices.
- Set the User Owner ID field in the device configuration to the appropriate user. The client will retrieve the Default Service Profile if this value is not set.

Note

A CSF should not be associated to multiple users if you intend to use different service profiles for these users.
**Procedure**

**Step 1** Associate users with devices.
   a) Open the **Unified CM Administration** interface.
   b) Select **User Management > End User**.
   c) Find and select the appropriate user.
      The **End User Configuration** window opens.
   d) Select **Device Association** in the **Device Information** section.
   e) Associate the user with devices as appropriate.
   f) Return to the **End User Configuration** window and then select **Save**.

**Step 2** Set the **User Owner ID** field in the device configuration.
   a) Select **Device > Phone**.
   b) Find and select the appropriate device.
      The **Phone Configuration** window opens.
   c) Locate the **Device Information** section.
   d) Select **User** as the value for the **Owner** field.
   e) Select the appropriate user ID from the **Owner User ID** field.
   f) Select **Save**.
Configure Service Discovery

- Service Discovery Options, page 81
- Configure DNS SRV Records, page 81
- Customizations, page 83
- Manual Connection Settings, page 89

Service Discovery Options

Service discovery enables clients to automatically detect and locate services on your enterprise network. You can configure service discovery using one of the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure DNS SRV Records, on page 81</td>
<td>The client automatically locates and connects to services.</td>
</tr>
<tr>
<td></td>
<td>This is the recommended option.</td>
</tr>
<tr>
<td>Customizations, on page 83</td>
<td>You can customize service discovery by using installation parameters, URL configuration, or Enterprise Mobility Management.</td>
</tr>
<tr>
<td>Manual Connection Settings, on page 89</td>
<td>Manual connection settings provide a fallback mechanism when service discovery is not used.</td>
</tr>
</tbody>
</table>

Configure DNS SRV Records

Before You Begin

Review your SRV record requirements in the Service Discovery chapter of the Planning Guide for Cisco Jabber.
Procedure

Create the SRV records for your deployment:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_cisco-uds</td>
<td>Provides the location of Cisco Unified Communications Manager 9.0 and later. The client can retrieve service profiles from Cisco Unified Communications Manager to determine the authenticator.</td>
</tr>
<tr>
<td>_collab-edge</td>
<td>Provides the location of Cisco VCS Expressway or Cisco Expressway-E. The client can retrieve service profiles from Cisco Unified Communications Manager to determine the authenticator.</td>
</tr>
</tbody>
</table>

Example of an SRV record

```
_cisco-uds._tcp.DOMAIN service location:
priority = 0
weight = 0
port = 8443
svr hostname=192.168.0.26
```

What to Do Next

Test SRV Records, on page 82

Test SRV Records

After creating your SRV records test to see if they are accessible.

Procedure

1. Open a command prompt.
2. Enter `nslookup`. The default DNS server and address is displayed. Confirm that this is the expected DNS server.
3. Enter `set type=SRV`. The name for each of your SRV records.
4. For example `_cisco-uds.exampledomain`
   - Displays server and address—SRV record is accessible.
   - Displays `_cisco-uds.exampledomain: Non-existent domain`—There is an issue with your SRV record.
Customizations

Windows Customizations

Installer Switches: Cisco Jabber for Windows

When you install Cisco Jabber, you can specify the authenticator and server addresses. The installer saves these details to a bootstrap file. When users launch the client for the first time, it reads the bootstrap file. The bootstrap file takes priority if service discovery is deployed.

Bootstrap files provide a fallback mechanism for service discovery in situations where service discovery has not been deployed and where you do not want users to manually specify their connection settings.

The client only reads the bootstrap file on the initial launch. After the initial launch, the client caches the server addresses and configuration, and then loads from the cache on subsequent launches.

We recommend that you do not use a bootstrap file, and instead use service discovery, in on-premises deployments with Cisco Unified Communications Manager release 9.x and later.

Bootstrap Settings for On-Premises Deployments

The following table lists the argument values for various deployment types.

<table>
<thead>
<tr>
<th>Product Mode</th>
<th>Server Releases</th>
<th>Argument Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full UC (Default Mode)</td>
<td>Release 9 and later:</td>
<td>Use the following installer switches and values:</td>
</tr>
<tr>
<td></td>
<td>• Cisco Unified Communications Manager</td>
<td>• AUTHENTICATOR=CUP</td>
</tr>
<tr>
<td></td>
<td>• Cisco Unified Communications Manager IM and Presence Service</td>
<td>• CUP_ADDRESS= &lt;presence_server_address&gt;</td>
</tr>
<tr>
<td>IM Only (Default Mode)</td>
<td>Release 9 and later:</td>
<td>Use the following installer switches and values:</td>
</tr>
<tr>
<td></td>
<td>Cisco Unified Communications Manager IM and Presence Service</td>
<td>• AUTHENTICATOR=CUP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• CUP_ADDRESS= &lt;presence_server_address&gt;</td>
</tr>
</tbody>
</table>

The following diagram illustrates how the client uses bootstrap settings in on-premises deployments:
When users start the client for the first time, the following occurs:

1. The client retrieves settings from the bootstrap file. The client starts in default mode and determines that Cisco Unified Communications Manager IM and Presence Service is the authenticator. The client also gets the address of the presence server, unless Service Discovery results dictate otherwise.

2. The client authenticates to Cisco Unified Communications Manager IM and Presence Service.

3. The client retrieves service profiles from the presence server.

**Bootstrap Settings for On-Premises Deployments in Phone Mode**

During installation, you set values for arguments as follows:

- Set `CUCM` as the value for `AUTHENTICATOR`.
- Set `phone_mode` as the value for `PRODUCT_MODE`.
- Set the TFTP server address as the value for TFTP.
- Set the CTI server address as the value for CTI.
- Set the CCMCIP server address as the value for CCMCIP.

Cisco Unified Communications Manager release 9.x and earlier—If you enable Cisco Extension Mobility, the Cisco Extension Mobility service must be activated on the Cisco Unified Communications Manager nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the *Feature and Services* guide for your Cisco Unified Communications Manager release.
The following diagram illustrates how the client uses bootstrap settings in phone mode deployments:

When users start the client for the first time, the following process occurs:

1. The client retrieves settings from the bootstrap file.
   The client starts in phone mode and determines that Cisco Unified Communications Manager is the authenticator. The client also gets the addresses for the TFTP server (and CTI servers for Jabber for Windows and Jabber for Mac), unless Service Discovery results dictate otherwise.

2. The client authenticates to Cisco Unified Communications Manager and gets configuration.

3. The client retrieves device and client configuration.

### Mac and Mobile Customizations

#### Configuration URL Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Configuration URL, on page 86</td>
<td></td>
</tr>
</tbody>
</table>
Configuration URL

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

Include the following parameters in the URL:

- **ServicesDomain**—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.

- **VoiceServiceDomain**—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.

- **ServiceDiscoveryExcludedServices**—Optional. You can exclude any of the following services from the service discovery process:
  - **WEBEX**—When you set this value, the client:
    - Does not perform CAS lookup
    - Looks for:
      - `_cisco-uds`
      - `_cuplogin`
      - `_collab-edge`
  
  - **CUCM**—When you set this value, the client:
    - Does not look for `_cisco-uds`
    - Looks for:
      - `_cuplogin`
      - `_collab-edge`

  - **CUP**—When you set this value, the client:
    - Does not look for `_cuplogin`
    - Looks for:
      - `_cisco-uds`
You can specify multiple, comma-separated values to exclude multiple services. If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

- ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
  - ON
  - OFF

- EnablePRTEncryption—Optional. Specifies that the PRT file is encrypted. Applies to Cisco Jabber for Mac.
  - true
  - false

- PRTCertificateName—Optional. Specifies the name of the certificate. Applies to Cisco Jabber for Mac.

- InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
  - RejectAndNotify—A warning dialog displays and the client doesn't load.
  - PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.

- PRTCertificateUrl—Specifies the name of a certificate with a public key in the trusted root certificate store. Applies to Cisco Jabber mobile clients.

- Telephony_Enabled—Specifies whether the user has phone capability or not. The default is true.
  - True
  - False

- ForceLaunchBrowser—Used to force user to use the external browser. Applies to Cisco Jabber mobile clients.
  - True
  - False

---

**Note**

ForceLaunchBrowser is used for client certificate deployments and for devices with Android OS below 5.0.

Create the configuration URL in the following format:

ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>
The parameters are case sensitive. When you create the configuration URL, you must use the following capitalization:

- ServicesDomain
- VoiceServicesDomain
- ServiceDiscoveryExcludedServices
- ServicesDomainSsoEmailPrompt
- EnableFRTEncryption
- FRTCertificateURL
- FRTCertificateName
- InvalidCertificateBehavior
- Telephony_Enabled
- ForceLaunchBrowser

Examples

- ciscojabber://provision?ServicesDomain=cisco.com
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com
- ciscojabber://provision?ServicesDomain=service_domain&VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP&ServicesDomainSsoEmailPrompt=OFF

Provide Users with Configuration URL from a Website

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

Note

Due to a limitation of the Android operating system, Cisco Jabber for Android users can encounter an issue if they open the configuration URL directly from an Android application. To work around this issue, we recommend that you distribute your configuration URL link using a website.

If you want to use the website explore option for URL provisioning, we recommended you to use Mozilla Firefox.

Use the following procedure to distribute the link from a website.
Procedure

**Step 1**
Create an internal web page that includes the configuration URL as an HTML hyperlink.

**Step 2**
Email the link to the internal web page to users.
In the email message, instruct users to perform the following steps:

1. Install the client.
2. Click the link in the email message to open the internal web page.
3. Click the link on the internal web page to configure the client.

Mobile Configuration Using Enterprise Mobility Management

Before using Enterprise Mobility Management (EMM), ensure:

- The EMM vendor supports Android for Work or Apple Managed App Configuration.
- Android devices OS is 5.0 or later and iOS devices have iOS 8.0 or later.

You can configure Cisco Jabber using EMM on Cisco Jabber for Android and Cisco Jabber for iPhone and iPad. For more information on setting up EMM, refer to the instructions for administrators provided by the EMM provider.

If you want Jabber to run only on managed devices, then you can deploy certificate-based authentication, and enroll the client certificate through EMM.

Manual Connection Settings

Manual connection settings provide a fallback mechanism when Service Discovery is not used.

When you start Cisco Jabber, you can specify the authenticator and server address in the Advanced settings window. The client caches the server address to the local application configuration that loads on subsequent starts.

Cisco Jabber prompts users to enter these advanced settings on the initial start as follows:

- On-Premises with Cisco Unified Communications Manager release 9.x and Later — If the client cannot get the authenticator and server addresses from the service profile.

Settings that you enter in the Advanced settings window take priority over any other sources including SRV records and bootstrap settings.

If you select Cisco IM & Presence, the client retrieves UC services from Cisco Unified Communications Manager IM and Presence Service. The client does not use service profiles or SSO discovery.
For Cisco Jabber for Windows, service discovery stops after 20 seconds regardless of the number of servers the SRV record resolves to. During service discovery, once Cisco Jabber finds _cisco-uds, it attempts to connect to the first 2 servers within 20 seconds. Cisco Jabber doesn't attempt to connect to any servers after it's attempted service discovery for the highest 2 priority servers.

Users can manually point to the working server or re-order SRV priorities to at least one of the top two priority servers available for service discovery.

---

**Automatic Connection Setting for Service Discovery**

Users can select the **Automatic** option in the **Advanced settings** window to discover servers automatically.

The Automatic option allows users change from manually setting the service connection details to using service discovery. For example, on the initial launch, you manually set the authenticator and specify a server address in the **Advanced settings** window.

The client always checks the cache for manual settings. The manual settings take higher priority over SRV records, and for Cisco Jabber for Windows, the bootstrap file. For this reason, if you decide to deploy SRV records and use service discovery, you override the manual settings from the initial launch.

---

**Manual Connection Settings for On-Premises Deployments**

Users can set Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service as the authenticator and specify the server address in the **Advanced settings** window.

**Remember**

You can automatically set the default server address with the _cuplogin SRV record.

The following diagram illustrates how the client uses manual connection settings in on-premises deployments:
Users manually enter connection settings in the *Advanced settings* window.

The client authenticates to Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service.

The client retrieves service profiles from the presence server.

### Manual Connection Settings for On-Premises Deployments in Phone Mode

Users can set Cisco Unified Communications Manager as the authenticator and specify the following server addresses in the *Advanced settings* window:

- TFTP server
- CCMCIP server
- CTI server (Cisco Jabber for Windows and Cisco Jabber for Mac)

The following diagram illustrates how the client uses manual connection settings in phone mode deployments:
1. Users manually enter connection settings in the **Advanced settings** window.
2. The client authenticates to Cisco Unified Communications Manager and gets configuration.
3. The client retrieves device and client configuration.
CHAPTER 13

Configure Certificate Validation

- Configure Certificates for an On-Premises Deployment, page 93

Configure Certificates for an On-Premises Deployment

Certificates are required for each service to which the Jabber clients connect.

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>If you have Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service, download the applicable HTTP (tomcat) and XMPP certificates. For more information, see the Security Configuration on IM and Presence Service chapter in Configuration and Administration of IM and Presence Service on Cisco Unified Communications Manager.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Download the HTTPS (tomcat) certificate for Cisco Unified Communications Manager and Cisco Unity Connection. For more information, see the Cisco Unified Communications Manager Security Guide and the Cisco Unified Communications Operating System Administration Guide found here.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Download the HTTP (tomcat) for Cisco WebEx Meetings Server. For more information, see the Cisco WebEx Meetings Server Administration Guide found here.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>If you plan to configure remote access, download the Cisco VCS Expressway and Cisco Expressway-E Server certificate. The Server certificate is used for both HTTP and XMPP. For more information, see Configuring Certificates on Cisco VCS Expressway.</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>Generate a Certificate Signing Request (CSR).</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>Upload the certificate to the service. If you use a multiserver SAN, you only need to upload a certificate to the service once per cluster per tomcat certificate and once per cluster per XMPP certificate. If you do not use a multiserver SAN, then you must</td>
</tr>
</tbody>
</table>
Deploy CA Certificates to Clients

To ensure that certificate validation occurs without users receiving a prompt to accept or decline certificates, deploy certificates to the local certificate store of the endpoint clients.

If you use a well-known public CA, then the CA certificate may already exist on the client certificate store or keychain. If so, you need not deploy CA certificates to the clients.

If the CA certificate is not already on the client certificate store or keychain, then deploy the CA certificate to the clients.

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 7 Deploy CA Certificates to Clients, on page 94</td>
<td>To ensure that certificate validation occurs without users receiving a prompt to accept or decline certificates, deploy certificates to the local certificate store of the clients.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>If your deployment size is</th>
<th>Then we recommend</th>
</tr>
</thead>
<tbody>
<tr>
<td>To a large number of local machines</td>
<td>That you use a certificate deployment tool, such as Group Policy or a certificate deployment management application.</td>
</tr>
<tr>
<td>To a smaller number of local machines</td>
<td>That you manually deploy the CA certificates.</td>
</tr>
</tbody>
</table>

Manually Deploy CA Certificates to Cisco Jabber for Windows Clients

Procedure

Step 1 Make the CA certificate available to the Cisco Jabber for Windows client machine.
Step 2 From the Windows machine, open the certificate file.
Step 3 Install the certificate and then select Next.
Step 4 Select Place all certificates in the following store, then select Browse.
Step 5 Select the Trusted Root Certification Authorities store. When you finish the wizard, a message is displayed to verify successful certificate import.

What to Do Next

Verify that the certificate is installed in the correct certificate store by opening the Windows Certificate Manager tool. Browse to Trusted Root Certification Authorities > Certificates. The CA root certificate is listed in the certificate store.
**Manually Deploy CA Certificates to Cisco Jabber for Mac Clients**

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Make the CA certificate available to the Cisco Jabber for Mac client machine.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>From the Mac machine, open the certificate file.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Add to the login keychain for the current user only, then select Add.</td>
</tr>
</tbody>
</table>

**What to Do Next**

Verify that the certificate is installed in the correct keychain by opening the Keychain Access Tool and selecting Certificates. The CA root certificate is listed in the keychain.

**Manually Deploy CA Certificates to Mobile Clients**

To deploy the CA certificates to an iOS client, you need a certificate deployment management application. You can email the CA certificate to users, or make the certificates available on a web server for users to access. Users can download and install the certificate using the certificate deployment management tool. However, Jabber for Android does not have a certificate management tool, you must use the following procedure.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Download the CA certificate to the device.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Tap the device <strong>Settings &gt; Security &gt; Install from device storage</strong> and follow the instructions.</td>
</tr>
</tbody>
</table>
CHAPTER 14

Configure the Clients

- Client Configuration Workflow, page 97

Client Configuration Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Introduction to Client Configuration, on page 97</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Create and Host Client Configuration Files, on page 98</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Set Parameters on Phone Configuration for Desktop Clients, on page 103</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Set Parameters on Phone Configuration for Mobile Clients, on page 104</td>
<td></td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure Proxy Setting, on page 105</td>
<td></td>
</tr>
</tbody>
</table>

Introduction to Client Configuration

Cisco Jabber can retrieve configuration settings from the following sources:

- Service Profiles — You can configure some client settings in UC service profiles on Cisco Unified Communications Manager release 9 and later. When users launch the client, it discovers the Cisco Unified Communications Manager home cluster using a DNS SRV record and automatically retrieves the configuration from the UC service profile.
  
  Applies to on-premises deployments only.

- Phone Configuration — You can set some client settings in the phone configuration on Cisco Unified Communications Manager release 9 and later. The client retrieves the settings from the phone configuration in addition to the configuration in the UC service profile.

  Applies to on-premises deployments only.
• Cisco Unified Communications Manager IM and Presence Service — You can enable instant messaging and presence capabilities and configure certain settings such as presence subscription requests.

In the Advanced settings window, if you select Cisco IM & Presence, the client retrieves UC services from Cisco Unified Communications Manager IM and Presence Service. The client does not use service profiles or SSO discovery.

Applies to on-premises deployments only.

• Client Configuration Files — You can create XML files that contain configuration parameters. You then host the XML files on a TFTP server. When users sign in, the client retrieves the XML file from the TFTP server and applies the configuration.

Applies to on-premises and cloud-based deployments.

• Cisco WebEx Administration Tool — You can configure some client settings with the Cisco WebEx Administration Tool.

You can upload a jabber-config.xml client configuration file into the Cisco WebEx Administration Tool. You can apply separate configuration files for groups in the Cisco WebEx Messenger Administration Tool. When the client successfully connects to Cisco WebEx Messenger it downloads the XML file and the configuration is applied.

The client will use the following order for configuration settings:

1  Settings in Cisco WebEx Messenger Administration Tool

2  Settings in jabber-config.xml file from Cisco WebEx Messenger Administration Tool.

Note

Group configuration file settings take priority over the configuration file in Cisco WebEx Messenger Administration Tool.

3  Settings in jabber-config.xml file from the TFTP server.

If there are any conflicts with configuration settings, the settings set in Cisco WebEx Administration tool will take priority over this configuration file.

Applies to cloud-based deployments only.

Create and Host Client Configuration Files

For on-premises and hybrid cloud-based deployments, create client configuration files and host them on the Cisco Unified Communications Manager TFTP service.

For cloud-based deployments, configure the client with the Cisco WebEx Administration Tool. However, you can optionally set up a TFTP server to configure the client with settings that are not available in Cisco WebEx Administration Tool.

For Cisco Jabber for iPhone and iPad and Cisco Jabber for Android, you must create a global configuration file to set up:

• Directory integration for on-premises deployments.

• Voicemail service credentials for hybrid-cloud deployments.
In most environments, Cisco Jabber for Windows and Cisco Jabber for Mac do not require any configuration to connect to services. Create a configuration file only if you require custom content such as automatic updates, problem reporting, or user policies and options.

**Before You Begin**

Note the following configuration file requirements:

- Configuration filenames are case-sensitive. Use lowercase letters in the filename to prevent errors and to ensure the client can retrieve the file from the TFTP server.
- You must use utf-8 encoding for the configuration files.
- The client cannot read configuration files that do not have a valid XML structure. Check the structure of your configuration file for closing elements and confirm that elements are nested correctly.
- Valid XML character entity references only are permitted in your configuration file. For example, use \&amp; instead of &. If your XML contains invalid characters, the client cannot parse the configuration file.

To validate your configuration file, open the file in Microsoft Internet Explorer.

- If Internet Explorer displays the entire XML structure, your configuration file does is valid.
- If Internet Explorer displays only part of the XML structure, it is likely that your configuration file contains invalid characters or entities.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Specify Your TFTP Server Address, on page 99</td>
<td>Specify your TFTP server address for client to enable access to your configuration file.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Create Global Configurations, on page 100</td>
<td>Configure the clients for users in your deployment.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Create Group Configurations, on page 100</td>
<td>Apply different configuration to different set of users.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Host Configuration Files, on page 101</td>
<td>Host configuration files on any TFTP server.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Restart Your TFTP Server, on page 102</td>
<td>Restart the TFTP server before the client can access the configuration files.</td>
</tr>
</tbody>
</table>

**Specify Your TFTP Server Address**

The client gets configuration files from a TFTP server. The first step in configuring the client is to specify your TFTP server address so the client can access your configuration file.
If Cisco Jabber gets the _cisco-uds SRV record from a DNS query, it can automatically locate the user's home cluster. As a result, the client can also locate the Cisco Unified Communications Manager TFTP service.

You do not need to specify your TFTP server address if you deploy the _cisco-uds SRV record.

### Specify TFTP Servers in Phone Mode

If you deploy the client in phone mode you can provide the address of the TFTP server as follows:

- Users manually enter the TFTP server address when they start the client.
- You specify the TFTP server address during installation with the TFTP argument.
- You specify the TFTP server address in the Microsoft Windows registry.

### Create Global Configurations

The client downloads the global configuration file from your TFTP server during the login sequence. Configure the client for all users in your deployment.

**Before You Begin**

If the structure of your configuration file is not valid, the client cannot read the values you set. Review the XML samples in this chapter for more information.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| Step 1 | Create a file named jabber-config.xml with any text editor.  
- Use lowercase letters in the filename.  
- Use UTF-8 encoding. |
| Step 2 | Define the required configuration parameters in jabber-config.xml. |
| Step 3 | Host the group configuration file on your TFTP server.  
If your environment has multiple TFTP servers, ensure that the configuration file is the same on all TFTP servers. |

### Create Group Configurations

Group configuration files apply to subsets of users and are supported on Cisco Jabber for desktop (CSF devices) and on Cisco Jabber for mobile devices. Group configuration files take priority over global configuration files.
If you provision users with CSF devices, specify the group configuration filenames in the **Cisco Support Field** field on the device configuration. If users do not have CSF devices, set a unique configuration filename for each group during installation with the TFTP_FILE_NAME argument.

### Before You Begin
- If the structure of your configuration file is not valid, the client cannot read the values you set. Review the XML samples in this chapter for more information.

### Procedure

**Step 1** Create an XML group configuration file with any text editor.
The group configuration file can have any appropriate name; for example, `jabber-groupa-config.xml`.

**Step 2** Define the required configuration parameters in the group configuration file.

**Step 3** Add the group configuration file to applicable CSF devices.
- a) Open the **Cisco Unified CM Administration** interface.
- b) Select **Device > Phone**.
- c) Find and select the appropriate CSF device to which the group configuration applies.
- d) In the **Phone Configuration** window, navigate to **Product Specific Configuration Layout > Desktop Client Settings**.
- e) In the **Cisco Support Field** field, enter `configurationfile=group_configuration_file_name.xml`. For example, enter `configurationfile=groupa-config.xml`.

  **Note** If you host the group configuration file on your TFTP server in a location other than the default directory, you must specify the path and the filename; for example, `configurationfile=/customFolder/groupa-config.xml`.

  Do not add more than one group configuration file. The client uses only the first group configuration in the **Cisco Support Field** field.

- f) Select **Save**.

**Step 4** Host the group configuration file on your TFTP server.

### Host Configuration Files

You can host configuration files on any TFTP server. However, Cisco recommends hosting configuration files on the Cisco Unified Communications Manager TFTP server, which is the same as that where the device configuration file resides.
Procedure

Step 1  Open the **Cisco Unified OS Administration** interface on Cisco Unified Communications Manager.
Step 2  Select **Software Upgrades > TFTP File Management**.
Step 3  Select **Upload File**.
Step 4  Select **Browse** in the **Upload File** section.
Step 5  Select the configuration file on the file system.
Step 6  Do not specify a value in the **Directory** text box in the **Upload File** section. You should leave an empty value in the **Directory** text box so that the configuration file resides in the default directory of the TFTP server.
Step 7  Select **Upload File**.

Restart Your TFTP Server

You must restart your TFTP server before the client can access the configuration files.

Procedure

Step 1  Open the **Cisco Unified Serviceability** interface on Cisco Unified Communications Manager.
Step 2  Select **Tools > Control Center - Feature Services**.
Step 3  Select **Cisco Tftp** from the **CM Services** section.
Step 4  Select **Restart**.
       A window displays to prompt you to confirm the restart.
Step 5  Select **OK**.
The **Cisco Tftp Service Restart Operation was Successful** status displays.
Step 6  Select **Refresh** to ensure the **Cisco Tftp** service starts successfully.

What to Do Next

To verify that the configuration file is available on your TFTP server, open the configuration file in any browser. Typically, you can access the global configuration file at the following URL:

http://tftp_server_address:6970/jabber-config.xml

Configuration File

For detailed information on the **jabber-config.xml** configuration file structure, group elements, parameters, and examples, see the [Parameters Reference Guide for Cisco Jabber](#).
Set Parameters on Phone Configuration for Desktop Clients

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco Unified Communications Manager:

**Enterprise Phone Configuration**
Applies to the entire cluster.

| Note | For users with only IM and Presence Service capabilities (IM only), you must set phone configuration parameters in the Enterprise Phone Configuration window. |

**Common Phone Profile Configuration**
Applies to groups of devices and takes priority over the cluster configuration.

**Cisco Unified Client Services Framework (CSF) Phone Configuration**
Applies to individual CSF devices and takes priority over the group configuration.

Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the Product Specific Configuration Layout section of the phone configuration and maps corresponding parameters from the client configuration file:

<table>
<thead>
<tr>
<th>Desktop Client Settings Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Video Calling</strong></td>
<td>Enables or disables video capabilities.</td>
</tr>
<tr>
<td><strong>Enabled (default)</strong></td>
<td>Users can send and receive video calls.</td>
</tr>
<tr>
<td><strong>Disabled</strong></td>
<td>Users cannot send or receive video calls.</td>
</tr>
<tr>
<td><strong>Restriction</strong></td>
<td>This parameter is available only on the CSF device configuration.</td>
</tr>
</tbody>
</table>

| File Types to Block in File Transfer | Restricts users from transferring specific file types. Set a file extension as the value, for example, .exe. Use a semicolon to delimit multiple values, for example, .exe;.msi;.rar;.zip |
### Desktop Client Settings Configuration

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically Start in Phone Control</td>
</tr>
<tr>
<td>Sets the phone type for users when the client starts for the first time. Users can change their phone type after the initial start. The client then saves the user preference and uses it for subsequent starts.</td>
</tr>
<tr>
<td><strong>Enabled</strong></td>
</tr>
<tr>
<td>Use the desk phone device for calls.</td>
</tr>
<tr>
<td><strong>Disabled (default)</strong></td>
</tr>
<tr>
<td>Use the software phone (CSF) device for calls.</td>
</tr>
</tbody>
</table>

| Jabber For Windows Software Update Server URL |
| Specifies the URL to the XML file that holds client update information. The client uses this URL to retrieve the XML file from your web server. |
| In hybrid cloud-based deployments, you should use the Cisco WebEx Administration Tool to configure automatic updates. |

| Problem Report Server URL |
| Specifies the URL for the custom script that allows users to submit problem reports. |

### Set Parameters on Phone Configuration for Mobile Clients

The client can retrieve configuration settings in the phone configuration from the following locations on Cisco Unified Communications Manager:

- Cisco Dual Mode for iPhone (TCT) Configuration — Applies to individual TCT devices and takes priority over the group configuration.
- Cisco Jabber for Tablet (TAB) Configuration — Applies to individual TAB devices and takes priority over the group configuration.

### Parameters in Phone Configuration

The following table lists the configuration parameters you can set in the **Product Specific Configuration Layout** section of the phone configuration and maps corresponding parameters from the client configuration file:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| On-Demand VPN URL | URL for initiating on-demand VPN.  
**Note**  
Applicable for iOS only. |
<p>| Preset Wi-Fi Networks | Enter the SSIDs for Wi-Fi networks (SSID) approved by your organization. Separate SSIDs with a forward slash (/). Devices do not connect to secure connect if connected to one of the entered Wi-Fi networks. |</p>
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Ringtone</td>
<td>Sets the default ringtone to <strong>Normal</strong> or <strong>Loud</strong>.</td>
</tr>
<tr>
<td>Video Capabilities</td>
<td>Enables or disables video capabilities.</td>
</tr>
<tr>
<td></td>
<td>• Enabled (default) — Users can send and receive video calls.</td>
</tr>
<tr>
<td></td>
<td>• Disabled — Users cannot send or receive video calls.</td>
</tr>
<tr>
<td>Dial via Office</td>
<td>Enables or disables Dial via Office.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>TCT and BOT devices only.</td>
</tr>
<tr>
<td></td>
<td>• Enabled — Users can dial via office.</td>
</tr>
<tr>
<td></td>
<td>• Disabled (default) — Users cannot dial via office.</td>
</tr>
</tbody>
</table>

### Configure Proxy Setting

The client uses proxy settings to connect to services.

The following limitations apply when using a proxy for these HTTP requests:

- Proxy Authentication is not supported.
- Wildcards in the bypass list are supported.
- Cisco Jabber supports proxy for HTTP request using HTTP CONNECT, but does not support proxy when using HTTPS CONNECT.

### Configure Proxy Settings for Cisco Jabber for Windows

Configure proxy settings for Windows in the Local Area Network (LAN) settings for Internet properties.

**Procedure**

**Step 1**
In the **Connections** tab select **LAN Settings**.

**Step 2**
Configure a proxy using one of the following options:

- For automatic configuration, specify a `.pac` file URL.
- For Proxy Server, specify an explicit proxy address.

### Configure Proxy Settings for Cisco Jabber for Mac

Configure proxy settings for Mac in **System Preferences**.
Procedure

Step 1 Select System Preferences > Network
Step 2 Choose your network service from the list and select Advanced > Proxies.
Step 3 Configure a proxy using one of the following options:
   • For automatic configuration, specify a .pac file URL.
   • For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber iPhone and iPad

Configure proxy settings in the Wi-Fi settings of an iOS device using one of the following methods:

Procedure

Step 1 Select Wi-Fi > HTTP PROXY > Auto and specify a .pac file URL as the automatic configuration script.
Step 2 Select Wi-Fi > HTTP PROXY > Manual and specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Android

Procedure

Configure proxy settings in the Wi-Fi settings of an Android device using one of the following methods:

   • Specify a .pac file URL as the automatic configuration script in the Wi-Fi > Modify Network > Show Advanced Options > Proxy Settings > Auto tab.
   Note This method is only supported on devices with Android OS 5.0 and later, and Cisco DX series devices.

   • Specify an explicit proxy address in the Wi-Fi Networks > Modify Network > Show Advanced Options > Proxy Settings > Auto tab.
Deploy Cisco Jabber Applications

- Download the Cisco Jabber Clients, page 107
- Install Cisco Jabber for Windows, page 107
- Install Cisco Jabber for Mac, page 132
- Install Cisco Jabber Mobile Clients, page 135

Download the Cisco Jabber Clients

If required, you can add your own Customer signature to the Jabber Installer or Cisco Dynamic Libraries by using the signing tools from the Operating System for that client.

Procedure

- Visit the Cisco Software Center to download the Cisco Jabber for Mac and Cisco Jabber for Windows clients.
- For Cisco Jabber for Android, download the app from Google Play.
- For Cisco Jabber for iPhone and iPad, download the app from the App store.

Install Cisco Jabber for Windows

Cisco Jabber for Windows provides an MSI installation package that you can use in the following ways:

<table>
<thead>
<tr>
<th>Install Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Use the Command Line, on page 108   | You can specify arguments in a command line window to set installation properties.  
                                         | Choose this option if you plan to install multiple instances.                  |
### Install Option | Description
--- | ---
Run the MSI Manually, on page 124 | Run the MSI manually on the file system of the client workstation and then specify connection properties when you start the client. Choose this option if you plan to install a single instance for testing or evaluation purposes.

Create a Custom Installer, on page 124 | Open the default installation package, specify the required installation properties, and then save a custom installation package. Choose this option if you plan to distribute an installation package with the same installation properties.

Deploy with Group Policy, on page 128 | Install the client on multiple computers in the same domain.

### Before You Begin
You must be logged in with local administrative rights.

### Use the Command Line
Specify installation arguments in a command line window.

#### Procedure

**Step 1**
Open a command line window.

**Step 2**
Enter the following command:
`msiexec.exe /i CiscoJabberSetup.msi`

**Step 3**
Specify command line arguments as parameter=value pairs.
`msiexec.exe /i CiscoJabberSetup.msi argument=value`

**Step 4**
Run the command to install Cisco Jabber for Windows.

### Example Installation Commands
Review examples of commands to install Cisco Jabber for Windows.

**Cisco Unified Communications Manager, Release 9.x**
`msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1`

Where:
CLEAR=1 — Deletes any existing bootstrap file.
/quiet — Specifies a silent installation.

Command Line Arguments

Review the command line arguments you can specify when you install Cisco Jabber for Windows.

Override Argument

The following table describes the parameter you must specify to override any existing bootstrap files from previous installations:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLEAR</td>
<td>1</td>
<td>Specifies if the client overrides any existing bootstrap file from previous installations. The client saves the arguments and values you set during installation to a bootstrap file. The client then loads settings from the bootstrap file at startup.</td>
</tr>
</tbody>
</table>

If you specify CLEAR, the following occurs during installation:

1. The client deletes any existing bootstrap file.
2. The client creates a new bootstrap file.

If you do not specify CLEAR, the client checks for existing bootstrap files during installation.

- If no bootstrap file exists, the client creates a bootstrap file during installation.
- If a bootstrap file exists, the client does not override that bootstrap file and preserves the existing settings.

Note

If you are reinstalling Cisco Jabber for Windows, you should consider the following:

- The client does not preserve settings from existing bootstrap files. If you specify CLEAR, you must also specify all other installation arguments as appropriate.
- The client does not save your installation arguments to an existing bootstrap file. If you want to change the values for installation arguments, or specify additional installation arguments, you must specify CLEAR to override the existing settings.

To override existing bootstrap files, specify CLEAR in the command line as follows:

`msiexec.exe /i CiscoJabberSetup.msi CLEAR=1`

Mode Type Argument

The following table describes the command line argument with which you specify the product mode:
When to Set the Product Mode
In phone mode deployments Cisco Unified Communications Manager is the authenticator. When the client gets the authenticator, it determines the product mode is phone mode. However, because the client always starts in the default product mode on the initial launch, users must restart the client to enter phone mode after sign in.

• Cisco Unified Communications Manager, Release 9.x and Later — You should not set PRODUCT_MODE during installation. The client gets the authenticator from the service profile. After the user signs in, the client requires a restart to enter phone mode.

Change Product Modes
To change the product mode, you must change the authenticator for the client. The client can then determine the product mode from the authenticator.

The method for changing from one product mode to another after installation, depends on your deployment.

Note
In all deployments, the user can manually set the authenticator in the Advanced settings window.
In this case, you must instruct the user to change the authenticator in the Advanced settings window to change the product mode. You cannot override the manual settings, even if you uninstall and then reinstall the client.

Change Product Modes with Cisco Unified Communications Manager Version 9.x and Later
To change product modes with Cisco Unified Communications Manager version 9.x and later, you change the authenticator in the service profile.

Procedure

Step 1  Change the authenticator in the service profiles for the appropriate users.

Change Default Mode > Phone Mode
Do not provision users with an IM and Presence service.

If the service profile does not contain an IM and presence service configuration, the authenticator is Cisco Unified Communications Manager.
Change Phone Mode > Default Mode

Provision users with an IM and Presence service.

If you set the value of the **Product type** field in the IM and Presence profile to:

- **Unified CM (IM and Presence)** the authenticator is Cisco Unified Communications Manager IM and Presence Service.
- **WebEx (IM and Presence)** the authenticator is the Cisco WebEx Messenger service.

**Step 2**  
Instruct users to sign out and then sign in again.  
When users sign in to the client, it retrieves the changes in the service profile and signs the user in to the authenticator. The client then determines the product mode and prompts the user to restart the client.

After the user restarts the client, the product mode change is complete.

**Authentication Arguments**

The following table describe the command line arguments you can set to specify the source of authentication:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTHENTICATOR</td>
<td>CUP</td>
<td>Specifies the source of authentication for the client. This value is used if Service Discovery fails. Set one of the following as the value:</td>
</tr>
<tr>
<td></td>
<td>CUCM</td>
<td>• CUP—Cisco Unified Communications Manager IM and Presence Service. On-premises deployments in the default product mode. The default product mode can be either full UC or IM only.</td>
</tr>
<tr>
<td></td>
<td>WEBEX</td>
<td>• CUCM—Cisco Unified Communications Manager. On-premises deployments in phone mode.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• WEBEX—Cisco WebEx Messenger Service. Cloud-based or hybrid cloud-based deployments.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In on-premises deployments with Cisco Unified Communications Manager version 9.x and later, you should deploy the <code>_cisco-uds</code> SRV record. The client can then automatically determine the authenticator.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CUP_ADDRESS</td>
<td>IP address</td>
<td>Specifies the address of Cisco Unified Communications Manager IM and Presence Service. Set one of the following as the value:</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>• Hostname (<em>hostname</em>)</td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>• IP address (123.45.254.1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FQDN (<em>hostname.domain.com</em>)</td>
</tr>
<tr>
<td>TFTP</td>
<td>IP address</td>
<td>Specifies the address of your TFTP server. Set one of the following as the value:</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>• Hostname (<em>hostname</em>)</td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>• IP address (123.45.254.1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FQDN (<em>hostname.domain.com</em>)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You should specify this argument if you set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you deploy:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• In phone mode—you should specify the address of the TFTP server that hosts the client configuration.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• In default mode—you can specify the address of the Cisco Unified Communications Manager TFTP service that hosts the device configuration.</td>
</tr>
<tr>
<td>CTI</td>
<td>IP address</td>
<td>Sets the address of your CTI server. Specify this argument if:</td>
</tr>
<tr>
<td></td>
<td>Hostname</td>
<td>• You set Cisco Unified Communications Manager as the authenticator.</td>
</tr>
<tr>
<td></td>
<td>FQDN</td>
<td>• Users have desk phone devices and require a CTI server.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| CCMCIP     | IP address | Sets the address of your CCMCIP server. Specify this argument if:  
• You set Cisco Unified Communications Manager as the authenticator.  
• The address of your CCMCIP server is not the same as the TFTP server address.  
The client can locate the CCMCIP server with the TFTP server address if both addresses are the same. |
|            | Hostname  |                                                                                                                                            |
|            | FQDN      |                                                                                                                                            |
|            | Domain    | Sets the value of the domain where the DNS SRV records for Service Discovery reside. This argument can be set to a domain where no DNS SRV records reside if you want the client to use installer settings or manual configuration for this information. If this argument is not specified and Service Discovery fails, the user will be prompted for services domain information. |

Cisco Unified Communications Manager release 9.x and earlier—If you enable Cisco Extension Mobility, the Cisco Extension Mobility service must be activated on the Cisco Unified Communications Manager nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the Feature and Services guide for your Cisco Unified Communications Manager release.
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| VOICE_SERVICES_DOMAIN    | Domain    | In Hybrid Deployments the domain required to discover Webex via CAS lookup may be a different domain than where the DNS records are deployed. If this is the case then set the SERVICES_DOMAIN to be the domain used for Webex discovery (or let the user enter an email address) and set the VOICE_SERVICES_DOMAIN to be the domain where DNS records are deployed. If this setting is specified, the client will use the value of VOICE_SERVICES_DOMAIN to lookup the following DNS records for the purposes of Service Discovery and Edge Detection:  
  - _cisco-uds  
  - _cuplogin  
  - _collab-edge  
  This setting is optional and if not specified, the DNS records are queried on the Services Domain which is obtained from the SERVICES_DOMAIN, email address input by the user, or cached user configuration. |
| EXCLUDED_SERVICES        | One or more of:  
  - WEBEX  
  - CUCM | Lists the services that you want Jabber to exclude from Service Discovery. For example, you may have done a trial with WebEx which means that your company domain is registered on WebEx, but you do not want Jabber users to authenticate using WebEx. You want Jabber to authenticate with CUCM server. In this case set:  
  - EXCLUDED_SERVICES=WEBEX  
  Possible values are CUCM, WEBEX.  
  If you exclude all services, you need to use manual configuration or bootstrap configuration to configure the Jabber client. |
**Argument** | **Value** | **Description**
---|---|---
UPN_DISCOVERY_ENABLED | true/false | Allows you to define whether the client uses the User Principal Name (UPN) of a Windows session to get the UserID and domain for a user when discovering services.

- **true** (default)—The UPN is used to find the User ID and the domain of the user, which is used during service discovery. Only the user discovered from UPN can log in to the client.
- **false**—The UPN is not used to find the User ID and domain of the user. The user is prompted to enter credentials to find the domain for service discovery.

Example installation command: `msiexec.exe /i CiscoJabberSetup.msi /quiet UPN_DISCOVERY_ENABLED=false`

---

**TFTP Server Address**

Cisco Jabber for Windows retrieves two different configuration files from the TFTP server:

- Client configuration files that you create.
- Device configuration files that reside on the Cisco Unified Communications Manager TFTP service when you provision users with devices.

To minimize effort, you should host your client configuration files on the Cisco Unified Communications Manager TFTP service. You then have only one TFTP server address for all configuration files and can specify that address as required.

You can, however, host your client configuration on a different TFTP server to the one that contains the device configuration. In this case, you have two different TFTP server addresses, one address for the TFTP server that hosts device configuration and another address for the TFTP server that hosts client configuration files.

**Default Deployments**

This section describes how you should handle two different TFTP server addresses in deployments that have a presence server.

You should do the following:

1. Specify the address of the TFTP server that hosts the client configuration on the presence server.
2. During installation, specify the address of the Cisco Unified Communications Manager TFTP service with the TFTP argument.

When the client starts for the first time, it:

1. Retrieves the address of the Cisco Unified Communications Manager TFTP service from the bootstrap file.
2. Gets device configuration from the Cisco Unified Communications Manager TFTP service.
3  Connects to the presence server.
4  Retrieves the address of the TFTP service that hosts the client configuration from the presence server.
5  Gets client configuration from the TFTP server.

**Phone Mode Deployments**

This section describes how you should handle two different TFTP server addresses in phone mode deployments. You should do the following:

1  During installation, specify the address of the TFTP server that hosts the client configuration with the TFTP argument.
2  Specify the address of the TFTP server that hosts the device configuration in your client configuration file with the following parameter: TftpServer1.
3  Host the client configuration file on the TFTP server.

When the client starts for the first time, it:

1  Retrieves the address of the TFTP server from the bootstrap file.
2  Gets client configuration from the TFTP server.
3  Retrieves the address of the Cisco Unified Communications Manager TFTP service from the client configuration.
4  Gets device configuration from the Cisco Unified Communications Manager TFTP service.

**Common Installation Arguments**

The following table describes command line arguments that are common to all deployments:
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| LANGUAGE               | LCID in decimal    | Defines the Locale ID (LCID), in decimal, of the language that Cisco Jabber for Windows uses. The value must be an LCID in decimal that corresponds to a supported language. For example, you can specify one of the following:  
  - 1033 specifies English.  
  - 1036 specifies French.  
  See the LCID for Languages topic for a full list of the languages that you can specify. This argument is optional. If you do not specify a value, Cisco Jabber for Windows uses the regional language for the current user as the default. From Release 11.1(1) onwards, if you do not specify a value, Cisco Jabber for Windows checks the value for the UseSystemLanguage parameter. If the UseSystemLanguage parameter is set to true, the same language is used as for the operating system. If the UseSystemLanguage parameter is set to false or not defined, then the client uses the regional language for the current user as the default. The regional language is set at Control Panel > Region and Language > Change the date, time, or number format > Formats tab > Format dropdown. |
| FORGOT_PASSWORD_URL    | URL                | Specifies the URL where users can reset lost or forgotten passwords. This argument is optional but recommended. Note  
  In cloud-based deployments, you can specify a forgot password URL using the Cisco WebEx Administration Tool. However, the client cannot retrieve that forgot password URL until users sign in. |
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOMATIC_SIGN_IN</td>
<td>true</td>
<td>Applies to Release 11.1(1) onwards. Specifies whether the Sign me in when Cisco Jabber starts check box is checked when the user installs the client.</td>
</tr>
</tbody>
</table>
|                      | false | • true—The Sign me in when Cisco Jabber starts check box is checked when the user installs the client.  
<p>|                      |       | • false (default)—The Sign me in when Cisco Jabber starts check box is not checked when the user installs the client. |
| TFTP_FILE_NAME       | Filename | Specifies the unique name of a group configuration file. You can specify either an unqualified or fully qualified filename as the value. The filename you specify as the value for this argument takes priority over any other configuration file on your TFTP server. This argument is optional. |
|                      |       | <strong>Remember</strong> You can specify group configuration files in the Cisco Support Field on the CSF device configuration on Cisco Unified Communications Manager. |</p>
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOGIN_RESOURCE</td>
<td>WBX</td>
<td>Controls user sign in to multiple client instances. By default, users can sign in to multiple instances of Cisco Jabber at the same time. Set one of the following values to change the default behavior:</td>
</tr>
<tr>
<td></td>
<td>MUT</td>
<td>• WBX—Users can sign in to one instance of Cisco Jabber for Windows at a time. Cisco Jabber for Windows appends the wbxconnect suffix to the user's JID. Users cannot sign in to any other Cisco Jabber client that uses the wbxconnect suffix.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MUT—Users can sign in to one instance of Cisco Jabber for Windows at a time, but can sign in to other Cisco Jabber clients at the same time. Each instance of Cisco Jabber for Windows appends the user's JID with a unique suffix.</td>
</tr>
<tr>
<td>LOG_DIRECTORY</td>
<td>Absolute path on the local filesystem</td>
<td>Defines the directory where the client writes log files. Use quotation marks to escape space characters in the path, as in the following example: &quot;C:\my_directory\Log Directory&quot; The path you specify must not contain Windows invalid characters. The default value is %USER_PROFILE%\AppData\Local\Cisco\Unified Communications\Jabber\CSF\Logs</td>
</tr>
<tr>
<td>CLICK2X</td>
<td>DISABLE</td>
<td>Disables click-to-x functionality with Cisco Jabber. If you specify this argument during installation, the client does not register as a handler for click-to-x functionality with the operating system. This argument prevents the client from writing to the Microsoft Windows registry during installation. You must re-install the client and omit this argument to enable click-to-x functionality with the client after installation.</td>
</tr>
<tr>
<td>Argument</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| ENABLE_PRT               | true/false     | • true (default)—The **Report a problem** menu item is enabled in the **Help** menu in the client.  
  • false—The Jabber menu item option **Report a problem** is removed from the **Help** menu in the client.  
  If you set the argument to false, users can still manually use the **Start Menu > Cisco Jabber** directory, or the Program files directory and launch the Problem Report Tool manually. If a user manually creates a PRT, and this parameter value is set to false, then the zip file created from the PRT has no content. |
| ENABLE_PRT_ENCRYPTION    | true/false     | Enables problem report encryption. You must configure this argument with the **PRT_CERTIFICATE_NAME** argument.  
  • true—PRT files sent by Jabber clients are encrypted.  
  • false (default)—PRT files sent by Jabber clients are not encrypted.  
  PRT encryption requires a public/private key pair to encrypt and decrypt the Cisco Jabber problem report.                                                                                             |
<p>| PRT_CERTIFICATE_NAME     | Certificate name | Specifies the name of a certificate with a public key in the Enterprise Trust or Trusted Root Certificate Authorities certificate store. The certificate public key is used to encrypt Jabber Problem reports. You must configure this argument with the <strong>ENABLE_PRT_ENCRYPTION</strong> argument. |</p>
<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INVALID_CERTIFICATE_BEHAVIOR</td>
<td>RejectAndNotify</td>
<td>Specifies the client behavior for invalid certificates.</td>
</tr>
<tr>
<td></td>
<td>PromptPerSession</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• RejectAndNotify—A warning dialog displays and the client doesn't load.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PromptPerSession—A warning dialog displays and the user can accept or reject</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the invalid certificate.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For invalid certificates in FIPS mode, this argument is ignored, the client</td>
</tr>
<tr>
<td></td>
<td></td>
<td>displays a warning message and doesn't load.</td>
</tr>
<tr>
<td>Telemetry_Enabled</td>
<td>true</td>
<td>Specifies whether analytics data is gathered.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>The default value is true.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To improve your experience and product performance, Cisco Jabber may collect</td>
</tr>
<tr>
<td></td>
<td></td>
<td>and send non-personally identifiable usage and performance data to Cisco.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The aggregated data is used by Cisco to understand trends in how Jabber</td>
</tr>
<tr>
<td></td>
<td></td>
<td>clients are being used and how they are performing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full details on what analytics data Cisco Jabber does and does not collect</td>
</tr>
<tr>
<td></td>
<td></td>
<td>can be found in the Cisco Jabber Supplement to Cisco’s On-Line Privacy Policy</td>
</tr>
<tr>
<td>LOCATION_MODE</td>
<td>ENABLED</td>
<td>Specifies whether the Location feature is enabled and whether users are</td>
</tr>
<tr>
<td></td>
<td>DISABLED</td>
<td>notified when new locations are detected.</td>
</tr>
<tr>
<td></td>
<td>ENABLEDNOPROMPT</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ENABLED(default)—Location feature is turned on. Users are notified when</td>
</tr>
<tr>
<td></td>
<td></td>
<td>new locations are detected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• DISABLED—Location feature is turned off. Users are not notified when new</td>
</tr>
<tr>
<td></td>
<td></td>
<td>locations are detected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ENABLEDNOPROMPT—Location feature is turned on. Users are not notified</td>
</tr>
<tr>
<td></td>
<td></td>
<td>when new locations are detected.</td>
</tr>
</tbody>
</table>
### Argument Table

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIPS_MODE</td>
<td>true</td>
<td>Specifies whether the Cisco Jabber is in FIPS mode. Cisco Jabber can be in FIPS mode on an operating system that is not FIPS enabled. Only connections with non-Window's APIs are in FIPS mode. If you don't include this setting, Cisco Jabber will determine the FIPS mode from the operating system.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>ENABLE_DPI_AWARE</td>
<td>true</td>
<td>Enables DPI awareness. DPI awareness enables Cisco Jabber to automatically adjust the display of text and images to suit different screen sizes.</td>
</tr>
<tr>
<td></td>
<td>false</td>
<td></td>
</tr>
</tbody>
</table>

- **true** (default) — DPI awareness is enabled.
- **false** — DPI awareness is not enabled.

DPI awareness is enabled by default. To disable DPI awareness, use the following command:

```msiexec.exe /i CiscoJabberSetup.msi CLEAR=1 ENABLE_DPI_AWARE=false```

### LCID for Languages

The following table lists the Locale Identifier (LCID) or Language Identifier (LangID) for the languages that the Cisco Jabber clients support.

<table>
<thead>
<tr>
<th>Supported Languages</th>
<th>Cisco Jabber for Windows</th>
<th>Cisco Jabber for Mac</th>
<th>Cisco Jabber for Android, Cisco Jabber for iPhone and iPad</th>
<th>LCID/LangID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arabic - Saudi Arabia</td>
<td>X</td>
<td></td>
<td>X</td>
<td>1025</td>
</tr>
<tr>
<td>Bulgarian - Bulgaria</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1026</td>
</tr>
<tr>
<td>Catalan - Spain</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1027</td>
</tr>
<tr>
<td>Chinese (Simplified) - China</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>2052</td>
</tr>
<tr>
<td>Chinese (Traditional) - Taiwan</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1028</td>
</tr>
<tr>
<td>Supported Languages</td>
<td>Cisco Jabber for Windows</td>
<td>Cisco Jabber for Mac</td>
<td>Cisco Jabber for Android, Cisco Jabber for iPhone and iPad</td>
<td>LCID/LangID</td>
</tr>
<tr>
<td>---------------------</td>
<td>--------------------------</td>
<td>----------------------</td>
<td>-------------------------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Croatian - Croatia</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1050</td>
</tr>
<tr>
<td>Czech - Czech Republic</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1029</td>
</tr>
<tr>
<td>Danish - Denmark</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1030</td>
</tr>
<tr>
<td>Dutch - Netherlands</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1043</td>
</tr>
<tr>
<td>English - United States</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1033</td>
</tr>
<tr>
<td>Finnish - Finland</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1035</td>
</tr>
<tr>
<td>French - France</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1036</td>
</tr>
<tr>
<td>German - Germany</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1031</td>
</tr>
<tr>
<td>Greek - Greece</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1032</td>
</tr>
<tr>
<td>Hebrew - Israel</td>
<td>X</td>
<td></td>
<td></td>
<td>1037</td>
</tr>
<tr>
<td>Hungarian - Hungary</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1038</td>
</tr>
<tr>
<td>Italian - Italy</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1040</td>
</tr>
<tr>
<td>Japanese - Japan</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1041</td>
</tr>
<tr>
<td>Korean - Korea</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1042</td>
</tr>
<tr>
<td>Norwegian - Norway</td>
<td>X</td>
<td>X</td>
<td></td>
<td>2068</td>
</tr>
<tr>
<td>Polish - Poland</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1045</td>
</tr>
<tr>
<td>Portuguese - Brazil</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1046</td>
</tr>
<tr>
<td>Portuguese - Portugal</td>
<td>X</td>
<td>X</td>
<td></td>
<td>2070</td>
</tr>
<tr>
<td>Romanian - Romania</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1048</td>
</tr>
<tr>
<td>Russian - Russia</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1049</td>
</tr>
</tbody>
</table>
Run the MSI Manually

You can run the installation program manually to install a single instance of the client and specify connection settings in the Advanced settings window.

**Procedure**

**Step 1** Launch `CiscoJabberSetup.msi`.
The installation program opens a window to guide you through the installation process.

**Step 2** Follow the steps to complete the installation process.

**Step 3** Start Cisco Jabber for Windows.

**Step 4** Select Manual setup and sign in.
The Advanced settings window opens.

**Step 5** Specify values for the connection settings properties.

**Step 6** Select Save.

Create a Custom Installer

You can transform the default installation package to create a custom installer.

---

**Supported Languages**

<table>
<thead>
<tr>
<th>Supported Languages</th>
<th>Cisco Jabber for Windows</th>
<th>Cisco Jabber for Mac</th>
<th>Cisco Jabber for Android, Cisco Jabber for iPhone and iPad</th>
<th>LCID/LangID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serbian</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1050</td>
</tr>
<tr>
<td>Slovak - Slovakian</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1051</td>
</tr>
<tr>
<td>Slovenian - Slovenia</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1060</td>
</tr>
<tr>
<td>Spanish - Spain (Modern Sort)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>3082</td>
</tr>
<tr>
<td>Swedish - Sweden</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>5149</td>
</tr>
<tr>
<td>Thai - Thailand</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1054</td>
</tr>
<tr>
<td>Turkish</td>
<td>X</td>
<td>X</td>
<td></td>
<td>1055</td>
</tr>
</tbody>
</table>
You use Microsoft Orca to create custom installers. Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and .NET Framework 4.

Download and install Microsoft Windows SDK for Windows 7 and .NET Framework 4 from the Microsoft website.

**Note**

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Get the Default Transform File, on page 125</td>
<td>You must have the default transform file to modify the installation package with Microsoft Orca.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Create Custom Transform Files, on page 125</td>
<td>Transform files contain installation properties that you apply to the installer.</td>
</tr>
<tr>
<td><strong>Step 3</strong> Transform the Installer, on page 126</td>
<td>Apply a transform file to customize the installer.</td>
</tr>
</tbody>
</table>

**Get the Default Transform File**

You must have the default transform file to modify the installation package with Microsoft Orca.

**Procedure**

**Step 1** Download the Cisco Jabber administration package from Software Download page.

**Step 2** Copy CiscoJabberProperties.msi from the Cisco Jabber administration package to your file system.

**What to Do Next**

Create Custom Transform Files, on page 125

**Create Custom Transform Files**

To create a custom installer, you use a transform file. Transform files contain installation properties that you apply to the installer.

The default transform file lets you specify values for properties when you transform the installer. You should use the default transform file if you are creating one custom installer.

You can optionally create custom transform files. You specify values for properties in a custom transform file and then apply it to the installer.

Create custom transform files if you require more than one custom installer with different property values. For example, create one transform file that sets the default language to French and another transform file that sets the default language to Spanish. You can then apply each transform file to the installation package separately. The result is that you create two installers, one for each language.
Before You Begin
Get the Default Transform File, on page 125

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Start Microsoft Orca.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Open CiscoJabberSetup.msi and then apply CiscoJabberProperties.msi.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Specify values for the appropriate installer properties.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Generate and save the transform file.</td>
</tr>
<tr>
<td></td>
<td>a) Select Transform &gt; Generate Transform.</td>
</tr>
<tr>
<td></td>
<td>b) Select a location on your file system to save the transform file.</td>
</tr>
<tr>
<td></td>
<td>c) Specify a name for the transform file and select Save.</td>
</tr>
</tbody>
</table>

The transform file you created is saved as file_name.mst. You can apply this transform file to modify the properties of CiscoJabberSetup.msi.

What to Do Next
Transform the Installer, on page 126

Transform the Installer

Apply a transform file to customize the installer.

Note
Applying transform files will alter the digital signature of CiscoJabberSetup.msi. Attempts to modify or rename CiscoJabberSetup.msi will remove the signature entirely.

Before You Begin
Create Custom Transform Files, on page 125

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Start Microsoft Orca.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Open CiscoJabberSetup.msi in Microsoft Orca.</td>
</tr>
<tr>
<td></td>
<td>a) Select File &gt; Open.</td>
</tr>
<tr>
<td></td>
<td>b) Browse to the location of CiscoJabberSetup.msi on your file system.</td>
</tr>
<tr>
<td></td>
<td>c) Select CiscoJabberSetup.msi and then select Open.</td>
</tr>
<tr>
<td></td>
<td>The installation package opens in Microsoft Orca. The list of tables for the installer opens in the Tables pane.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Remove all language codes except for 1033 (English).</td>
</tr>
</tbody>
</table>
**Restriction** You must remove all language codes from the custom installer except for 1033 (English). Microsoft Orca does not retain any language files in custom installers except for the default, which is 1033. If you do not remove all language codes from the custom installer, you cannot run the installer on any operating system where the language is other than English.

a) Select **View > Summary Information**.
   The **Edit Summary Information** window displays.

b) Locate the **Languages** field.

c) Delete all language codes except for 1033.

d) Select **OK**.

   English is set as the language for your custom installer.

**Step 4** Apply a transform file.

a) Select **Transform > Apply Transform**.

b) Browse to the location of the transform file on your file system.

c) Select the transform file and then select **Open**.

**Step 5** Select **Property** from the list of tables in the **Tables** pane.

The list of properties for **CiscoJabberSetup.msi** opens in the right panel of the application window.

**Step 6** Specify values for the properties you require.

**Tip** Values are case sensitive. Ensure the value you enter matches the value in this document.

**Tip** Set the value of the CLEAR property to 1 to override any existing bootstrap file from previous installations. If you do not override existing bootstrap files, the values you set in the custom installer do not take effect.

**Step 7** Remove any properties that you do not require.

   It is essential to remove any properties that are not being set, otherwise the properties being set will not take effect. Remove each property that is not needed one at a time.

a) Right-click the property you want to remove.

b) Select **Drop Row**.

c) Select **OK** when Microsoft Orca prompts you to continue.

**Step 8** Enable your custom installer to save embedded streams.

a) Select **Tools > Options**.

b) Select the **Database** tab.

c) Select **Copy embedded streams during 'Save As'**.

d) Select **Apply** and then **OK**.

**Step 9** Save your custom installer.

a) Select **File > Save Transformed As**.

b) Select a location on your file system to save the installer.

c) Specify a name for the installer and then select **Save**.

---

**Installer Properties**

The following are the properties you can modify in a custom installer:
• CLEAR
• PRODUCT_MODE
• AUTHENTICATOR
• CUP_ADDRESS
• TFTP
• CTI
• CCMCIP
• LANGUAGE
• TFTP_FILE_NAME
• FORGOT_PASSWORD_URL
• SSO_ORG_DOMAIN
• LOGIN_RESOURCE
• LOG_DIRECTORY
• CLICK2X
• SERVICES_DOMAIN

These properties correspond to the installation arguments and have the same values.

**Deploy with Group Policy**

Install Cisco Jabber for Windows with Group Policy using the Microsoft Group Policy Management Console (GPMC) on Microsoft Windows Server.

**Note**

To install Cisco Jabber for Windows with Group Policy, all computers or users to which you plan to deploy Cisco Jabber for Windows must be in the same domain.

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Set a Language Code, on page 129</td>
<td>You must use this procedure and set the Language field to 1033 only if the MSI is to be modified by Orca in any way.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Deploy the Client with Group Policy, on page 129</td>
<td>Deploy Cisco Jabber for Windows with Group Policy.</td>
</tr>
</tbody>
</table>
Set a Language Code

Altering the installation language is not necessary in Group Policy deployment scenarios where the exact MSI file provided by Cisco will be used. The installation language will be determined from the Windows User Locale (Format) in these situations. You must use this procedure and set the Language field to 1033 only if the MSI is to be modified by Orca in any way.

Procedure

Step 1  Start Microsoft Orca. Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and .NET Framework 4 that you can download from the Microsoft website.

Step 2  Open CiscoJabberSetup.msi.
   a) Select File > Open.
   b) Browse to the location of CiscoJabberSetup.msi on your file system.
   c) Select CiscoJabberSetup.msi and then select Open.

Step 3  Select View > Summary Information.

Step 4  Locate the Languages field.

Step 5  Set the Languages field to 1033.

Step 6  Select OK.

Step 7  Enable your custom installer to save embedded streams.
   a) Select Tools > Options.
   b) Select the Database tab.
   c) Select Copy embedded streams during 'Save As'.
   d) Select Apply and then OK.

Step 8  Save your custom installer.
   a) Select File > Save Transformed As.
   b) Select a location on your file system to save the installer.
   c) Specify a name for the installer and then select Save.

What to Do Next

Deploy the Client with Group Policy, on page 129

Deploy the Client with Group Policy

Complete the steps in this task to deploy Cisco Jabber for Windows with Group Policy.

Before You Begin

Set a Language Code, on page 129
Procedure

**Step 1** Copy the installation package to a software distribution point for deployment. All computers or users to which you plan to deploy Cisco Jabber for Windows must be able to access the installation package on the distribution point.

**Step 2** Select **Start > Run** and then enter the following command:

```
GPMC.msc
```

The **Group Policy Management** console opens.

**Step 3** Create a new group policy object.

a) Right-click on the appropriate domain in the left pane.

b) Select **Create a GPO in this Domain, and Link it here**. The **New GPO** window opens.

c) Enter a name for the group policy object in the **Name** field.

d) Leave the default value or select an appropriate option from the **Source Starter GPO** drop-down list and then select **OK**.

The new group policy displays in the list of group policies for the domain.

**Step 4** Set the scope of your deployment.

a) Select the group policy object under the domain in the left pane. The group policy object displays in the right pane.

b) Select **Add** in the **Security Filtering** section of the **Scope** tab. The **Select User, Computer, or Group** window opens.

c) Specify the computers and users to which you want to deploy Cisco Jabber for Windows.

**Step 5** Specify the installation package.

a) Right-click the group policy object in the left pane and then select **Edit**. The **Group Policy Management Editor** opens.

b) Select **Computer Configuration** and then select **Policies > Software Settings**.

c) Right-click **Software Installation** and then select **New > Package**.

d) Enter the location of the installation package next to **File Name**; for example, `\server\software_distribution`.

**Important** You must enter a Uniform Naming Convention (UNC) path as the location of the installation package. If you do not enter a UNC path, Group Policy cannot deploy Cisco Jabber for Windows.

e) Select the installation package and then select **Open**.

f) In the **Deploy Software** dialog box, select **Assigned** and then **OK**.

Group Policy installs Cisco Jabber for Windows on each computer the next time each computer starts.
Cisco Media Services Interface

Cisco Jabber for Windows supports Cisco Media Services Interface version 4.1.2 for Microsoft Windows 7 and later.

Cisco Jabber for Mac supports Cisco Media Services Interface version 4.0.2 or later.

Desk Phone Video Capabilities

You must install Cisco Media Services Interface to enable desk phone video capabilities. Cisco Media Services Interface provides a driver that enables Cisco Jabber for Windows to do the following:

- Discover the desk phone device.
- Establish and maintain a connection to the desk phone device using the CAST protocol.

Install Cisco Media Services Interface

Procedure

Step 1
Download the Cisco Media Services Interface installation program from the download site on cisco.com.

Step 2
Install Cisco Media Services Interface on each computer on which you install Cisco Jabber.
See the appropriate Cisco Medianet documentation for installing Cisco Media Services Interface.

Uninstall Cisco Jabber for Windows

You can uninstall Cisco Jabber for Windows using either the command line or the Microsoft Windows control panel. This document describes how to uninstall Cisco Jabber for Windows using the command line.

Use the Installer

If the installer is available on the file system, use it to remove Cisco Jabber for Windows.

Procedure

Step 1
Open a command line window.

Step 2
Enter the following command:
`msiexec.exe /x path_to_CiscoJabberSetup.msi`
For example,
`msiexec.exe /x C:\Windows\Installer\CiscoJabberSetup.msi /quiet`
Where /quiet specifies a silent uninstall.
The command removes Cisco Jabber for Windows from the computer.

**Use the Product Code**

If the installer is not available on the file system, use the product code to remove Cisco Jabber for Windows.

**Procedure**

**Step 1**
Find the product code.

a) Open the Microsoft Windows registry editor.
b) Locate the following registry key: `HKEY_CLASSES_ROOT\Installer\Products`
c) Select `Edit > Find`.
d) Enter Cisco Jabber in the `Find what` text box in the `Find` window and select `Find Next`.
e) Find the value of the `ProductIcon` key.
   The product code is the value of the `ProductIcon` key, for example,
   `C:\Windows\Installer\{product_code}\ARPPRODUCTICON.exe`.
   
   **Note** The product code changes with each version of Cisco Jabber for Windows.

**Step 2**
Open a command line window.

**Step 3**
Enter the following command:

```
msiexec.exe /x product_code
```

For example,

```
msiexec.exe /x 45992224-D2DE-49BB-B085-6524845321C7 /quiet
```

Where `/quiet` specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.

---

**Install Cisco Jabber for Mac**

**URL Configuration for Cisco Jabber for Mac**

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

You can include and specify the following parameters in the URL:

- ServicesDomain—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.
• VoiceServiceDomain—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.

• ServiceDiscoveryExcludedServices—Optional. You can exclude any of the following services from the service discovery process:
  * WEBEX—When you set this value, the client:
    • Does not perform CAS lookup
    • Looks for:
      ◦ _cisco-uds
      ◦ _cuplogin
      ◦ _collab-edge
  * CUCM—When you set this value, the client:
    • Does not look for _cisco-uds
    • Looks for:
      ◦ _cuplogin
      ◦ _collab-edge
  * CUP—When you set this value, the client:
    • Does not look for _cuplogin
    • Looks for:
      ◦ _cisco-uds
      ◦ _collab-edge

You can specify multiple, comma-separated values to exclude multiple services.
If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

• ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
  * ON
  * OFF

• EnablePRTEncryption—Optional. Specifies that the PRT file is encrypted. Applies to Cisco Jabber for Mac.
  * true
  * false
• PRTCertificateName—Optional. Specifies the name of the certificate. Applies to Cisco Jabber for Mac.

• InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
  ◦ RejectAndNotify—A warning dialog displays and the client doesn't load.
  ◦ PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.

• Telephony_ENABLED—Specifies whether the user has phone capability or not. The default is true.
  • True
  • False

Create the configuration URL in the following format:
ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>

Note
The parameters are case sensitive. When you create the configuration URL, you must use the following capitalization:
  • ServicesDomain
  • VoiceServicesDomain
  • ServiceDiscoveryExcludedServices
  • ServicesDomainSsoEmailPrompt
  • EnablePRTEncryption
  • PRTCertificateName
  • InvalidCertificateBehavior
  • Telephony_ENABLED

Examples
  • ciscojabber://provision?ServicesDomain=cisco.com
Install Cisco Jabber Mobile Clients

Procedure

**Step 1**
To install Cisco Jabber for Android, download the app from Google Play from your mobile device.

**Step 2**
To install Cisco Jabber for iPhone and iPad, download the app from the App Store from your mobile device.

URL Configuration for Cisco Jabber for Android, iPhone, and iPad

To enable users to launch Cisco Jabber without having to manually enter service discovery information, create and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the link to a website.

You can include and specify the following parameters in the URL:

- **ServicesDomain**—Required. Every configuration URL must include the domain of the IM and presence server that Cisco Jabber needs for service discovery.

- **VoiceServiceDomain**—Required only if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server. Set this parameter to ensure that Cisco Jabber can discover voice services.

- **ServiceDiscoveryExcludedServices**—Optional. You can exclude any of the following services from the service discovery process:
  - **WEBEX**—When you set this value, the client:
    - Does not perform CAS lookup
    - Looks for:
      - `_cisco-uds`
      - `_cuplogin`
      - `_collab-edge`
  - **CUCM**—When you set this value, the client:
Does not look for _cisco-uds

Looks for:
- _cuplogin
- _collab-edge

*CUP—When you set this value, the client:
- Does not look for _cuplogin
- Looks for:
  - _cisco-uds
  - _collab-edge

You can specify multiple, comma-separated values to exclude multiple services.
If you exclude all three services, the client does not perform service discovery and prompts the user to manually enter connection settings.

• ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for the purposes of determining their home cluster.
  - ON
  - OFF

• InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.
  - RejectAndNotify—A warning dialog displays and the client doesn't load.
  - PromptPerSession—A warning dialog displays and the user can accept or reject the invalid certificate.

• PRTCertificateUrl—Specifies the name of a certificate with a public key in the trusted root certificate store. Applies to Cisco Jabber mobile clients.

• Telephony_Enabled—Specifies whether the user has phone capability or not. The default is true.
  - True
  - False

• ForceLaunchBrowser—Used to force user to use the external browser. Applies to Cisco Jabber mobile clients.
  - True
  - False
ForceLaunchBrowser is used for client certificate deployments and for devices with Android OS below 5.0.

Create the configuration URL in the following format:

ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>

The parameters are case sensitive. When you create the configuration URL, use the following capitalization:

- ServicesDomain
- VoiceServicesDomain
- ServiceDiscoveryExcludedServices
- ServicesDomainSsoEmailPrompt
- PRTCertificateURL
- InvalidCertificateBehavior
- Telephony_Enabled
- ForceLaunchBrowser

Examples

- ciscojabber://provision?ServicesDomain=cisco.com
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com
- ciscojabber://provision?ServicesDomain-service_domain&VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP
- ciscojabber://provision?ServicesDomain=cisco.com&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP&ServicesDomainSsoEmailPrompt=OFF

Mobile Configuration Using Enterprise Mobility Management

Before using Enterprise Mobility Management (EMM), ensure:

- The EMM vendor supports Android for Work or Apple Managed App Configuration.
- Android devices OS is 5.0 or later

To allow users to launch Cisco Jabber for Android or Cisco Jabber for iPhone and iPad, you can configure Cisco Jabber using Enterprise Mobility Management (EMM).
For more information on setting up EMM, refer to the instructions for administrators provided by the EMM provider.

If you want Jabber to run only on managed devices, then you can deploy certificate-based authentication, and enroll the client certificate through EMM.
Remote Access

- Service Discovery Requirements Workflow, page 139
- Cisco Anyconnect Deployment Workflow, page 141

Service Discovery Requirements Workflow

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Service Discovery Requirements, on page 139</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>DNS Requirements, on page 140</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>Certificate Requirements, on page 140</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Test_collab-edge SRV Record, on page 140</td>
<td></td>
</tr>
</tbody>
</table>

Service Discovery Requirements

Service discovery enables clients to automatically detect and locate services on your enterprise network. Expressway for Mobile and Remote Access allows you to access the services on your enterprise network. You should meet the following requirements to enable the clients to connect through Expressway for Mobile and Remote Access and discover services:

- DNS requirements
- Certificate requirements
- Test external SRV _collab-edge.
DNS Requirements

The DNS requirements for service discovery through remote access are:

- Configure a _collab-edge DNS SRV record on an external DNS server.
- Configure a _cisco-uds DNS SRV record on the internal name server.
- Optionally, if you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs from the domain of the voice server, ensure that you configure the Voice Services Domain to locate the DNS server that contains the _collab-edge record.

Certificate Requirements

Before you configure remote access, download the Cisco VCS Expressway and Cisco Expressway-E Server certificate. The Server certificate is used for both HTTP and XMPP.

For more information on configuring Cisco VCS Expressway certificate, see Configuring Certificates on Cisco VCS Expressway.

Test _collab-edge SRV Record

Test SRV Records

After creating your SRV records test to see if they are accessible.

Procedure

1. Open a command prompt.
2. Enter nslookup.
   The default DNS server and address is displayed. Confirm that this is the expected DNS server.
3. Enter set type=SRV.
4. Enter the name for each of your SRV records.
   For example _cisco-uds.exampledomain

   - Displays server and address—SRV record is accessible.
   - Displays _cisco-uds.exampledomain: Non-existent domain—There is an issue with your SRV record.
Cisco Anyconnect Deployment Workflow

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Application Profiles, on page 141</td>
<td></td>
</tr>
<tr>
<td>Step 2</td>
<td>Automate VPN Connection, on page 142</td>
<td></td>
</tr>
<tr>
<td>Step 3</td>
<td>AnyConnect Documentation Reference, on page 145</td>
<td></td>
</tr>
<tr>
<td>Step 4</td>
<td>Session Parameters, on page 145</td>
<td></td>
</tr>
</tbody>
</table>

Cisco AnyConnect Deployment

Application Profiles

After you download the Cisco AnyConnect Secure Mobility Client to their device, the ASA must provision a configuration profile to the application.

The configuration profile for the Cisco AnyConnect Secure Mobility Client includes VPN policy information such as the company ASA VPN gateways, the connection protocol (IPSec or SSL), and on-demand policies. You can provision application profiles for Cisco Jabber for iPhone and iPad in one of the following ways:

ASDM

We recommend that you use the profile editor on the ASA Device Manager (ASDM) to define the VPN profile for the Cisco AnyConnect Secure Mobility Client.

When you use this method, the VPN profile is automatically downloaded to the Cisco AnyConnect Secure Mobility Client after the client establishes the VPN connection for the first time. You can use this method for all devices and OS types, and you can manage the VPN profile centrally on the ASA.

For more information, see the Creating and Editing an AnyConnect Profile topic of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your release.

iPCU

You can provision iOS devices using an Apple configuration profile that you create with the iPhone Configuration Utility (iPCU). Apple configuration profiles are XML files that contain information such as device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1. Use iPCU to create an Apple configuration profile.
   
   For more information, see the iPCU documentation.

2. Export the XML profile as a .mobileconfig file.
3 Email the .mobileconfig file to users. After a user opens the file, it installs the AnyConnect VPN profile and the other profile settings to the client application.

**MDM**

You can provision iOS devices using an Apple configuration profile that you create with third-party Mobile Device Management (MDM) software. Apple configuration profiles are XML files that contain information such as device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1 Use MDM to create the Apple configuration profiles.  
For information on using MDM, see the Apple documentation.

2 Push the Apple configuration profiles to the registered devices.

To provision application profiles for Cisco Jabber for Android, use the profile editor on the ASA Device Manager (ASDM) to define the VPN profile for the Cisco AnyConnect Secure Mobility Client. The VPN profile is automatically downloaded to the Cisco AnyConnect Secure Mobility Client after the client establishes the VPN connection for the first time. You can use this method for all devices and OS types, and you can manage the VPN profile centrally on the ASA. For more information, see the Creating and Editing an AnyConnect Profile topic of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your release.

**Automate VPN Connection**

When users open Cisco Jabber from outside the corporate Wi-Fi network, Cisco Jabber needs a VPN connection to access the Cisco UC application servers. You can set up the system to allow Cisco AnyConnect Secure Mobility Client to automatically establish a VPN connection in the background, which helps ensure a seamless user experience.

**Note**  
VPN will not be launched because Expressway for Mobile and Remote Access has the higher connection priority even if VPN is set to automatic connection.

**Set Up Trusted Network Connection**

The Trusted Network Detection feature enhances the user experience by automating the VPN connection based on the user's location. When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the Cisco UC infrastructure directly. When the user leaves the corporate Wi-Fi network, Cisco Jabber automatically detects that it is outside the trusted network. After this occurs, Cisco AnyConnect Secure Mobility Client initiates the VPN to ensure connectivity to the UC infrastructure.

**Note**  
The Trusted Network Detection feature works with both certificate- and password-based authentication. However, certificate-based authentication provides the most seamless user experience.
Procedure

Step 1  Using ASDM, open the Cisco AnyConnect client profile.
Step 2  Enter the list of Trusted DNS Servers and Trusted DNS Domain Suffixes that an interface can receive when
the client is within a corporate Wi-Fi network. The Cisco AnyConnect client compares the current interface
DNS servers and domain suffix with the settings in this profile.

Note  You must specify all your DNS servers to ensure that the Trusted Network Detection feature works
properly. If you set up both the TrustedDNSDomains and TrustedDNSServers, sessions must match
both settings to be defined as a trusted network.

For detailed steps for setting up Trusted Network Detection, see the Trusted Network Detection
section in the Configuring AnyConnect Features chapter (Release 2.5) or Configuring VPN Access
(releases 3.0 or 3.1) of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your
release.

Set Up Connect On-Demand VPN

The Apple iOS Connect On Demand feature enhances the user experience by automating the VPN connection
based on the user's domain.

When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the Cisco UC infrastructure
directly. When the user leaves the corporate Wi-Fi network, Cisco AnyConnect automatically detects if it is
connected to a domain that you specify in the AnyConnect client profile. If so, the application initiates the
VPN to ensure connectivity to the UC infrastructure. All applications on the device including Cisco Jabber
can take advantage of this feature.

Note  Connect On Demand supports only certificate-authenticated connections.

The following options are available with this feature:

- **Always Connect** — Apple iOS always attempts to initiate a VPN connection for domains in this list.
- **Connect If Needed** — Apple iOS attempts to initiate a VPN connection to the domains in the list only
  if it cannot resolve the address using DNS.
- **Never Connect** — Apple iOS never attempts to initiate a VPN connection to domains in this list.

Attention Apple plans to remove the Always Connect option in the near future. After the Always Connect option is
removed, users can select the Connect If Needed option. In some cases, Cisco Jabber users may have
issues when using the Connect If Needed option. For example, if the hostname for the Cisco Unified
Communications Manager is resolvable outside the corporate network, iOS will not trigger a VPN
connection. The user can work around this issue by manually launching Cisco AnyConnect Secure Mobility
Client before making a call.
Procedure

**Step 1** Use the ASDM profile editor, iPCU, or MDM software to open the AnyConnect client profile.

**Step 2** In the AnyConnect client profile, under the Connect if Needed section, enter your list of on-demand domains. The domain list can include wild-card options (for example, cucm.cisco.com, cisco.com, and *.webex.com).

---

Set Up Automatic VPN Access on Cisco Unified Communications Manager

**Before You Begin**

- The mobile device must be set up for on-demand access to VPN with certificate-based authentication. For assistance with setting up VPN access, contact the providers of your VPN client and head end.

- For requirements for Cisco AnyConnect Secure Mobility Client and Cisco Adaptive Security Appliance, see the *Software Requirements* topic.

- For information about setting up Cisco AnyConnect, see the *Cisco AnyConnect VPN Client Maintain and Operate Guides*.

**Procedure**

**Step 1** Identify a URL that will cause the client to launch VPN on Demand.

a) Use one of the following methods to identify a URL that will cause the client to launch VPN on Demand.

- **Connect if Needed**
  
  - Configure Cisco Unified Communications Manager to be accessed through a domain name (not an IP address) and ensure that this domain name is not resolvable outside the firewall.

  - Include this domain in the "Connect If Needed" list in the Connect On Demand Domain List of the Cisco AnyConnect client connection.

- **Always Connect**
  
  - Set the parameter in step 4 to a nonexistent domain. A nonexistent domain causes a DNS query to fail when the user is inside or outside the firewall.

  - Include this domain to the "Always Connect" list in the Connect On Demand Domain List of the Cisco AnyConnect client connection.

The URL must include only the domain name. Do not include a protocol or a path (for example, use "cm8ondemand.company.com" instead of "https://cm8ondemand.company.com/vpn".)
b) Enter the URL in Cisco AnyConnect and verify that a DNS query on this domain fails.

**Step 2**
Open the **Cisco Unified CM Administration** interface.

**Step 3**
Navigate to the device page for the user.

**Step 4**
In the **Product Specific Configuration Layout** section, in the **On-Demand VPN URL** field, enter the URL that you identified and used in Cisco AnyConnect in Step 1. The URL must be a domain name only, without a protocol or path.

**Step 5**
Select **Save**.
When Cisco Jabber opens, it initiates a DNS query to the URL (for example, ccm-sjc-111.cisco.com). If this URL matches the On-Demand domain list entry that you defined in this procedure (for example, cisco.com), Cisco Jabber indirectly initiates the AnyConnect VPN connection.

---

**What to Do Next**
- Test this feature.
  - Enter this URL into the Internet browser on the iOS device and verify that VPN launches automatically. You should see a VPN icon in the status bar.
  - Verify that the iOS device can connect to the corporate network using VPN. For example, access a web page on your corporate intranet. If the iOS device cannot connect, contact the provider of your VPN technology.
  - Verify with your IT department that your VPN does not restrict access to certain types of traffic (for example, if the administrator set the system to allow only email and calendar traffic).
- Verify that you set up the client to connect directly to the corporate network.

**AnyConnect Documentation Reference**

**Session Parameters**
You can configure ASA session parameters to improve performance for secure connections. For the best user experience, you should configure the following ASA session parameters:
- **Datagram Transport Layer Security (DTLS)** — DTLS is an SSL protocol that provides a data path that prevents latency and data loss.
- **Auto Reconnect** — Auto reconnect, or session persistence, lets Cisco AnyConnect Secure Mobility Client recover from session disruptions and re-establish sessions.
- **Session Persistence** — This parameter allows the VPN session to recover from service disruptions and re-establish the connection.
- **Idle Timeout** — Idle timeout defines a period of time after which ASA terminates secure connections, if no communication activity occurs.
• Dead-Peer Detection (DTD) — DTD ensures that ASA and Cisco AnyConnect Secure Mobility Client can quickly detect failed connections.

Set ASA Session Parameters

Cisco recommends that you set up the ASA session parameters as follows to optimize the end user experience for Cisco AnyConnect Secure Mobility Client.

Procedure

**Step 1**
Set up Cisco AnyConnect to use DTLS.
For more information, see the *Enabling Datagram Transport Layer Security (DTLS) with AnyConnect (SSL) Connections* topic in the *Configuring AnyConnect Features Using ASDM* chapter of the *Cisco AnyConnect VPN Client Administrator Guide, Version 2.0*.

**Step 2**
Set up session persistence (auto-reconnect).
\[a\) Use ASDM to open the VPN client profile.\]
\[b) Set the *Auto Reconnect Behavior* parameter to *Reconnect After Resume*.\]
For more information, see the *Configuring Auto Reconnect* topic in the *Configuring AnyConnect Features* chapter (Release 2.5) or *Configuring VPN Access* chapter (releases 3.0 or 3.1) of the *Cisco AnyConnect Secure Mobility Client Administrator Guide* for your release.

**Step 3**
Set the idle timeout value.
\[a) Create a group policy that is specific to Cisco Jabber clients.\]
\[b) Set the idle timeout value to 30 minutes.\]
For more information, see the *vpn-idle-timeout* section of the *Cisco ASA 5580 Adaptive Security Appliance Command Reference* for your release.

**Step 4**
Set up Dead Peer Detection (DPD).
\[a) Disable server-side DPD.\]
\[b) Enable client-side DPD.\]
For more information, see the *Enabling and Adjusting Dead Peer Detection* topic of the *Configuring VPN* chapter of the *Cisco ASA 5500 Series Configuration Guide using the CLI, 8.4 and 8.6*. 
Quality of Service

- Options, page 147
- Supported Codecs, page 148
- Define a Port Range on the SIP Profile, page 149
- Define a Port Range in Jabber-config.xml, page 149
- Set DSCP Values, page 149

Options

Use the following options to configure the quality of service for Cisco Jabber:

- Supported Codecs, on page 148
- Define a Port Range on the SIP Profile, on page 149
- Define a Port Range in Jabber-config.xml, on page 149
- Set DSCP Values, on page 149
## Supported Codecs

<table>
<thead>
<tr>
<th>Type</th>
<th>Codec</th>
<th>Codec Type</th>
<th>Cisco Jabber for Android</th>
<th>Cisco Jabber for iPhone and iPad</th>
<th>Cisco Jabber for Mac</th>
<th>Cisco Jabber for Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td>G.711</td>
<td>A-law</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>µ-law/Mu-law</td>
<td>Supports normal mode.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>G.722</td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>G.722.1</td>
<td>24 kb/s and 32 kb/s</td>
<td>Yes</td>
<td>Supports normal mode.</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>G.729</td>
<td></td>
<td>Does not support Visual Voicemail with G.729; however, you can access voice messages using G.729 and the <strong>Call Voicemail</strong> feature.</td>
<td>No</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td>G.729a</td>
<td></td>
<td>Yes</td>
<td>Minimum requirement for low-bandwidth availability. Only codec that supports low-bandwidth mode. Supports normal mode.</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Opus</td>
<td></td>
<td></td>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Video</td>
<td>H.264/AVC</td>
<td>A-law</td>
<td>Yes</td>
<td></td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Voicemail</td>
<td>G.711</td>
<td>A-law</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>µ-law / Mu-law (default)</td>
<td>Yes</td>
<td></td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>GSM 06.10</td>
<td></td>
<td></td>
<td></td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>PCM linear</td>
<td></td>
<td></td>
<td></td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
If users have issues with voice quality when using Cisco Jabber for Android or Cisco Jabber for iPhone and iPad, they can turn low-bandwidth mode on and off in the client settings.

**Define a Port Range on the SIP Profile**

The client uses the port range to send RTP traffic across the network. The client divides the port range equally and uses the lower half for audio calls and the upper half for video calls. As a result of splitting the port range for audio media and video media, the client creates identifiable media streams. You can then classify and prioritize those media streams by setting DSCP values in the IP packet headers.

**Procedure**

**Step 1**  
Open the Cisco Unified CM Administration interface.

**Step 2**  
Select Device > Device Settings > SIP Profile.

**Step 3**  
Find the appropriate SIP profile or create a new SIP profile. The SIP Profile Configuration window opens.

**Step 4**  
Specify whether you want common or separate port ranges for audio and video. If you are separating your audio and video port ranges, provide audio and video ports. Specify the port range in the following fields:

- **Start Media Port** — Defines the start port for media streams. This field sets the lowest port in the range.
- **Stop Media Port** — Defines the stop port for media streams. This field sets the highest port in the range.

**Step 5**  
Select Apply Config and then OK.

**Define a Port Range in Jabber-config.xml**

This topic applies to Cisco Jabber for Windows.

**Procedure**

To specify a port range to use when users share their screen from a chat window in Cisco Jabber for Windows, see "SharePortRangeStart" in the Cisco Jabber Parameters Reference Guide.

**Set DSCP Values**

Set Differentiated Services Code Point (DSCP) values in RTP media packet headers to prioritize Cisco Jabber traffic as it traverses the network.
Set DSCP Values on Cisco Unified Communications Manager

You can set DSCP values for audio media and video media on Cisco Unified Communications Manager. Cisco Jabber can then retrieve the DSCP values from the device configuration and apply them directly to the IP headers of RTP media packets.

| Restriction | For later operating systems such as Microsoft Windows 7, Microsoft implements a security feature that prevents applications from setting DSCP values on IP packet headers. For this reason, you should use an alternate method for marking DSCP values, such as Microsoft Group Policy. |

For more information on configuring flexible DSCP values, refer to Configure Flexible DSCP Marking and Video Promotion Service Parameters.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters. The Service Parameter Configuration window opens.
Step 3 Select the appropriate server and then select the Cisco CallManager service.
Step 4 Locate the Clusterwide Parameters (System - QOS) section.
Step 5 Specify DSCP values as appropriate and then select Save.

Set DSCP Values with Group Policy

If you deploy Cisco Jabber for Windows on a later operating system such as Microsoft Windows 7, you can use Microsoft Group Policy to apply DSCP values.

Complete the steps in the following Microsoft support article to create a group policy: http://technet.microsoft.com/en-us/library/cc771283%28v=ws.10%29.aspx

You should create separate policies for audio media and video media with the following attributes:

<table>
<thead>
<tr>
<th>Attributes</th>
<th>Audio Policy</th>
<th>Video Policy</th>
<th>Signaling Policy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application name</td>
<td>CiscoJabber.exe</td>
<td>CiscoJabber.exe</td>
<td>CiscoJabber.exe</td>
</tr>
<tr>
<td>Protocol</td>
<td>UDP</td>
<td>UDP</td>
<td>TCP</td>
</tr>
<tr>
<td>Port number or range</td>
<td>Corresponding port number or range from the SIP profile on Cisco Unified Communications Manager.</td>
<td>Corresponding port number or range from the SIP profile on Cisco Unified Communications Manager.</td>
<td>5060 for SIP 5061 for secure SIP</td>
</tr>
</tbody>
</table>
## Set DSCP Values on the Client

For some configurations, there is an option to enable differentiated services for calls in the Cisco Jabber for Mac client and Cisco Jabber for mobile clients.

**Important**

This option is enabled by default. Cisco recommends not disabling this option unless you are experiencing issues in the following scenarios:

- You can hear or see other parties, but you cannot be heard or seen
- You are experiencing unexpected Wi-Fi disconnection issues

Disabling differentiated service for calls may degrade audio and video quality.

**Note**

If EnableDSCPPacketMarking is configured as true or false, then the user cannot see **Enable Differentiated Service for Calls** in the Cisco Jabber clients.

### Procedure

**Step 1**
In Cisco Jabber for Mac, go to **Jabber > Preferences > Calls > Advanced** and select **Enable Differentiated Service for Calls**.

**Step 2**
In Cisco Jabber for mobile clients, go to **Jabber > Settings > Audio and Video** and select **Enable Differentiated Service for Calls**.

## Set DSCP Values on the Network

You can configure switches and routers to mark DSCP values in the IP headers of RTP media.

To set DSCP values on the network, you must identify the different streams from the client application.

- Media Streams — Because the client uses different port ranges for audio streams and video streams, you can differentiate audio media and video media based on those port range. Using the default port ranges in the SIP profile, you should mark media packets as follows:
  - Audio media streams in ports from 16384 to 24574 as EF
  - Video media streams in ports from 24575 to 32766 as AF41
• Signaling Streams — You can identify signaling between the client and servers based on the various ports required for SIP, CTI QBE, and XMPP. For example, SIP signaling between Cisco Jabber and Cisco Unified Communications Manager occurs through port 5060.

You should mark signaling packets as AF31.
Integrate Cisco Jabber with Applications

- Configure Presence in Microsoft SharePoint 2010 and 2013, page 153
- Client Availability, page 154
- Protocol Handlers, page 155

Configure Presence in Microsoft SharePoint 2010 and 2013

If your organization defines users' profiles where their IM address is different from their email address, then additional configuration is required to enable presence integration between the client and Microsoft SharePoint 2010 and 2013.

Before You Begin

- For Cisco Jabber for Windows clients only.
- Ensure that all sites are in sync with Microsoft SharePoint Central Administration (CA).
- Ensure that synchronization between Microsoft SharePoint and Active Directory is set up.

Procedure

Step 1  If you have Microsoft SharePoint 2013, update the SharePoint CA profile pages for users with the following information:
   a) For the **SIP Address** profile field, leave it blank.
   b) In the **Work email** profile field, enter the user profile. For example, john4mail@example.pst.

Step 2  If you have Microsoft SharePoint 2010, update the SharePoint CA profile pages for users with the following information:
   a) For the **SIP Address** profile field, enter the user profile. For example, john4mail@example.pst
   b) In the **Work email** profile field, leave it blank.
Client Availability

Users can define whether their availability reflects their calendar events by setting an option to let others know they are in a meeting from the Status tab of the Options window from the client. This option synchronizes events in your calendar with your availability. The client only displays In a meeting availability for supported integrated calendars.

The client supports using two sources for the In a meeting availability:

- Microsoft Exchange and Cisco Unified Communication Manager IM and Presence Integration — Applies to on-premises deployments. The Include Calendar information in my Presence Status field in Cisco Unified Presence is the same as the In a meeting option in the client. Both fields update the same value in the Cisco Unified Communication Manager IM and Presence database.

  If users set both fields to different values, then the last field that the user sets takes priority. If users change the value of the Include Calendar information in my Presence Status field while the client is running, the users must restart the client for those changes to apply.

- Cisco Jabber Client — Applies to on-premises and cloud-based deployments. You must disable Cisco Unified Communication Manager IM and Presence and Microsoft Exchange integration for the client to set the In a meeting availability. The client checks if integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange is on or off. The client can only set availability if integration is off.

The following deployment scenarios describe how availability is created:

<table>
<thead>
<tr>
<th>Deployment Scenario</th>
<th>You select In a meeting (according to my calendar)</th>
<th>You do not select In a meeting (according to my calendar)</th>
</tr>
</thead>
<tbody>
<tr>
<td>You enable integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange.</td>
<td>Cisco Unified Communication Manager IM and Presence sets availability status</td>
<td>Availability status does not change</td>
</tr>
<tr>
<td>You do not enable integration between Cisco Unified Communication Manager IM and Presence and Microsoft Exchange.</td>
<td>Client sets availability status</td>
<td>Availability status does not change</td>
</tr>
<tr>
<td>Cloud-based deployments</td>
<td>Client sets availability status</td>
<td>Availability status does not change</td>
</tr>
</tbody>
</table>

Additionally, the following table describes availability that is supported differently by each deployment scenarios:
Protocol Handlers

Cisco Jabber registers the following protocol handlers with the operating system to enable click-to-call or click-to-IM functionality from web browsers or other applications:

- **XMPP**: or XMPP://
  Starts an instant message and opens a chat window in Cisco Jabber.

- **IM**: or IM://
  Starts an instant message and opens a chat window in Cisco Jabber.

- **TEL**: or TEL://
  Starts an audio or video call with Cisco Jabber.

  Note: TEL is registered by Apple native phone. It cannot be used to cross launch Cisco Jabber for iPhone and iPad.

- **CISCOTEL**: or CISCOTEL://
  Starts an audio or video call with Cisco Jabber.

- **SIP**: or SIP://
  Starts an audio or video call with Cisco Jabber.

- **CLICKTOCALL**: or CLICKTOCALL://
  Starts an audio or video call with Cisco Jabber.

Registry Entries for Protocol Handlers

To register as a protocol handler, the client writes to the following locations in the Microsoft Windows registry:

- HKEY_CLASSES_ROOT\tel\shell\open\command
In the case where two or more applications register as handlers for the same protocol, the last application to write to the registry takes precedence. For example, if Cisco Jabber registers as a protocol handler for XMPP and then a different application registers as a protocol handler for XMPP, the other application takes precedence over Cisco Jabber.

**Protocol Handlers on HTML Pages**

You can add protocol handlers on HTML pages as part of the `href` attribute. When users click the hyperlinks that your HTML pages expose, the client performs the appropriate action for the protocol.

**TEL and IM Protocol Handlers**

Example of the TEL: and IM: protocol handlers on an HTML page:

```html
<html>
  <body>
    <a href="TEL:1234">Call 1234</a><br/>
    <a href="IM:msmith@domain">Send an instant message to Mary Smith</a>
  </body>
</html>
```

In the preceding example, when users click the hyperlink to call 1234, the client starts an audio call to that phone number. When users click the hyperlink to send an instant message to Mary Smith, the client opens a chat window with Mary.

**CISCOTEL and SIP Protocol Handlers**

Example of the CISCOTEL and SIP protocol handlers on an HTML page:

```html
<html>
  <body>
    <a href="CISCOTEL:1234">Call 1234</a><br/>
    <a href="SIP:msmith@domain">Call Mary</a><br/>
    <a href="CISCOTELCONF:msmith@domain;amckenzi@domain">Weekly conference call</a>
  </body>
</html>
```

In the preceding example, when users click the Call 1234 or Call Mary hyperlinks, the client starts an audio call to that phone number.

**XMPP Protocol Handlers**

Example of a group chat using the XMPP: protocol handler on an HTML page:

```html
<html>
  <body>
    <a href="XMPP:msmith@domain;amckenzi@domain">Create a group chat with Mary Smith and Adam McKenzie</a>
  </body>
</html>
```

In the preceding example, when users click the hyperlink to create a group chat with Mary Smith and Adam McKenzie, the client opens a group chat window with Mary and Adam.
Add lists of contacts for the XMPP: and IM: handlers to create group chats. Use a semi-colon to delimit contacts, as in the following example:

XMPP:user_a@domain.com;user_b@domain.com;user_c@domain.com;user_d@domain.com

**Add Subject Lines and Body Text**

You can add subject lines and body text to any of the protocol handlers so that when users click on the hyperlink to create a person-to-person or group chat, the client opens a chat window with pre-populated subject line and body text.

Subject and body text can be added in any of the following scenarios:

- Using any supported protocol handler for instant messaging on the client
- For either person-to-person chats or for group chats
- Including a subject and body text, or one or the other

In this example, when users click on the link below it opens a person-to-person chat window with a pre-populated body text of I.T Desk:

xmpp:msmith@domain?message;subject=I.T.%20Desk

In this example, when users click on the link below it opens a Start Group Chat dialog box with a topic of I.T Desk, and the input box for the chat window is pre-populated with the text Jabber 10.5 Query:

im:user_a@domain.com;user_b@domain.com;user_c@domain.com?message;subject=I.T%20Desk;body=Jabber%2010.5%20Query

**Protocol Handler Supported Parameters**

**Cross Launch for Mobile Clients**

The Cisco Jabber for mobile clients provide you with the ability to return to a specified application. For example if you create a ciscotel URI link that dials a number, you can add in the application name as a parameter and when the call has completed the user is prompted to return to that application.


- **CrossLaunchBackAppName**—Users are prompted with the name of an application that Cisco Jabber cross launches back to when a call ends.
  - none (default)—No application in the dialog box.
  - `app_name`—The application name that is displayed in the dialog box.

- **CrossLaunchBackSchema**—Specifies the schema used when a call is ended.
  - none (default)—You stay in Cisco Jabber.
  - `schema`—The schema used to cross launch back the application.
Supported Separators

When creating a URI link for HTML pages, you can use a semi-colon to separate the characters. This is supported with the SIP, Tel, CiscoTel and ClickToCall protocol handlers. In the following example, the link will create a conference call with the two numbers:

```
tel:123;123
```

The IM protocol supports the semi-colon separator. In the following example, the link will create a group chat with the two participants:

```
im:participant1@example.com,participant2@example.com
```

DTMF Support

Enter DTMF in the IM Window

In the IM window of the client, you can enter a protocol handler including DTMF digits and the client will create a link that participants can use. The supported protocols are TEL, CISCOTEL, SIP, CLICKTOCALL, CISCOIM, IM, and XMPP. The supported parameters are numbers or SIP URIs. In the following example, the dial in number is 1800-123456, the PIN for entry is 5678#, using the TEL URI link this example creates a meeting link:

```
tel:1800123456,,,5678#
```

Enter DTMF in an Active Call

During a call, users can copy and paste DTMF digits into the call window of the client. Users can easily enter Meeting IDs, Attendee IDs, and PINs from their meetings invite. If you enter alphanumeric strings during an active call they are interpreted as the corresponding numbers on the keypad.

Supported DTMF Strings

A DTMF string can contain the following:

- 0 to 9
- 
- #
- *
- Comma—meaning a one second delay (multiple commas are supported)
- a to z, A to Z—These characters are not supported when on an active call.

Invalid DTMF digits are ignored.