THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: http://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

© 2015 Cisco Systems, Inc. All rights reserved.
CONTENTS

Preface vii

Change History vii
About This Guide viii
Audience viii
Related Documents viii
Obtaining Documentation and Submitting a Service Request ix
Field Alerts and Field Notices ix
Documentation Feedback ix
Conventions ix

CHAPTER 1 Remote Expert Mobile Solution Overview and Design 1

Remote Expert Mobile Overview 1
Customer Location 4
Deployment Models 5
Remote Expert Mobile Feature Support 7
Restrictions 8
Supported Video Formats and Codecs 9
Call Flows 9
Network Considerations 12
Bandwidth and QoS Considerations 13
Operational Considerations 14

CHAPTER 2 Prerequisites 15

Required Software 15
Required Software Licenses 16
Required Hardware 17
System Requirements for Agents 19
CHAPTER 3  Remote Expert Mobile Solution Configuration 21
   Set Up Remote Expert Mobile Components 21
   Cisco Unified Communications Manager Configuration Sequence for Non-Contact Center Solution 23
   Cisco Unified Communications Manager Configuration 24
      Create a SIP Trunk Security Profile 24
      Create a SIP Profile for Remote Expert Mobile 25
      Create a SIP Trunk 25
      Create a Normalization Script to Apply to the Unified Communications Manager Trunk 25
      Set Up an End User 26
      Create a CTI Remote Device 27
      Add a Directory Number to the Device 27
      Define a Route Pattern and Associate It with the SIP Trunk to the Remote Expert Mobile Cluster 28
      Add a Remote Destination That Matches the Route Pattern 28
      Define a New Line Group and Associate It with a DN 28
      Create a Hunt List 29
      Define a Hunt Pilot 29

CHAPTER 4  Video Conferencing 31
   Video Conferencing 31
   Configure Conference Bridges 31

CHAPTER 5  Video on Hold 33
   Video on Hold 33
   Video on Hold Prerequisites 33
   Video on Hold Restrictions 33
   Video on Hold Configuration Sequence 33
   Configure MediaSense for Video on Hold 34
      Add the Video Files to the Media Resource Group List 34
   Configure Unified CM for Video on Hold 35
   Configure the Unified CCX Routing Script for Video on Hold 35
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>Chapter 9 Finesse Expert Assist Gadget</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td>Finesse Expert Assist Gadget Pre-requisites</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td>Finesse Expert Assist Gadget Restrictions</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td>Finesse Expert Assist Gadget Configuration</td>
<td>62</td>
</tr>
<tr>
<td>10</td>
<td>Chapter 10 Expert Assist Console</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td>Expert Assist Console Pre-requisites</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td>Expert Assist Console Restrictions</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td>Expert Assist Console Configuration</td>
<td>64</td>
</tr>
</tbody>
</table>
Preface

- Change History, page vii
- About This Guide, page viii
- Audience, page viii
- Related Documents, page viii
- Obtaining Documentation and Submitting a Service Request, page ix
- Field Alerts and Field Notices, page ix
- Documentation Feedback, page ix
- Conventions, page ix

Change History

<table>
<thead>
<tr>
<th>Change</th>
<th>Date</th>
<th>Link</th>
</tr>
</thead>
<tbody>
<tr>
<td>Added system requirements for Remote Expert Mobile agents with Jabber and Finesse</td>
<td>December 2015</td>
<td>System Requirements for Agents, on page 19</td>
</tr>
<tr>
<td>Updated the compatible versions of Unified CVP</td>
<td>November 2015</td>
<td>Required Software, on page 15</td>
</tr>
<tr>
<td>Added that Cisco Unified Border Element is an optional component for Unified CCX and Unified Communications Manager.</td>
<td>September 2015</td>
<td>Changes throughout guide</td>
</tr>
<tr>
<td>Initial release</td>
<td>June 26, 2015</td>
<td></td>
</tr>
</tbody>
</table>
About This Guide

This guide explains the features available with Remote Expert Mobile and how to configure them to work with your contact center.

Audience

This guide is prepared for contact center administrators who configure and run the contact center and address operational issues.

Related Documents

<table>
<thead>
<tr>
<th>Subject</th>
<th>Link</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description and listing of Remote Expert Mobile documentation.</td>
<td>Cisco Remote Expert Mobile 10.6 Documentation Guide at [link]</td>
</tr>
<tr>
<td>A guide for Remote Expert Mobile installation and configuration on a Virtual Machine. It takes the network administrator through the series of tasks required to configure the Remote Expert Mobile and then describes how to check that the system is working as expected.</td>
<td>Installing and Configuring Cisco Remote Expert Mobile 10.6 at [link]</td>
</tr>
<tr>
<td>A guide through the component, architecture, deployment models and deployment consideration &amp; requirements for Remote Expert Mobile.</td>
<td>Cisco Remote Expert Mobile 10.6 Design Guide at [link]</td>
</tr>
<tr>
<td>Descriptions of Remote Expert Mobile features, including configuration and use.</td>
<td>Cisco Remote Expert Mobile 10.6 Feature Guide at [link]</td>
</tr>
<tr>
<td>A comprehensive guide for use of the Remote Expert Mobile SDKs for native Apple iOS (Objective-C), Android (Java) as well as Web applications (JavaScript).</td>
<td>Cisco Remote Expert Mobile 10.6 Developer's Guide at [link]</td>
</tr>
<tr>
<td>Description of the current release including feature changes, limitations and restrictions, requirements, and supported languages.</td>
<td>Cisco Remote Expert Release Notes at [link]</td>
</tr>
</tbody>
</table>
Obtaining Documentation and Submitting a Service Request


Subscribe to What's New in Cisco Product Documentation, which lists all new and revised Cisco technical documentation as an RSS feed and delivers content directly to your desktop using a reader application. The RSS feeds are a free service.

Field Alerts and Field Notices

Cisco products may be modified or key processes may be determined to be important. These are announced through use of the Cisco Field Alerts and Cisco Field Notices. You can register to receive Field Alerts and Field Notices through the Product Alert Tool on Cisco.com. This tool enables you to create a profile to receive announcements by selecting all products of interest.

Log into www.cisco.com and then access the tool at http://www.cisco.com/cisco/support/notifications.html.

Documentation Feedback

To provide comments about this document, send an email message to the following address: contactcenterproducts_docfeedback@cisco.com

We appreciate your comments.

Conventions

This document uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>boldface font</td>
<td>Boldface font is used to indicate commands, such as user entries, keys, buttons, and folder and submenu names. For example:</td>
</tr>
<tr>
<td></td>
<td>• Choose <strong>Edit &gt; Find</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Finish</strong>.</td>
</tr>
<tr>
<td>Convention</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>italic font</em></td>
<td>Italic font is used to indicate the following:</td>
</tr>
<tr>
<td></td>
<td>• To introduce a new term. Example: A <em>skill group</em> is a collection of agents</td>
</tr>
<tr>
<td></td>
<td>who share similar skills.</td>
</tr>
<tr>
<td></td>
<td>• A syntax value that the user must replace. Example: IF <em>(condition, true-value,</em></td>
</tr>
<tr>
<td></td>
<td><em>false-value)</em></td>
</tr>
<tr>
<td></td>
<td>• A book title. Example: See the <em>Cisco Unified Contact Center Enterprise</em></td>
</tr>
<tr>
<td></td>
<td><em>Installation and Upgrade Guide</em>.</td>
</tr>
<tr>
<td><em>window font</em></td>
<td>Window font, such as Courier, is used for the following:</td>
</tr>
<tr>
<td></td>
<td>• Text as it appears in code or that the window displays. Example:</td>
</tr>
<tr>
<td></td>
<td><code>&lt;html&gt;&lt;title&gt;Cisco Systems, Inc. &lt;/title&gt;&lt;/html&gt;</code></td>
</tr>
<tr>
<td><em>&lt; &gt;</em></td>
<td>Angle brackets are used to indicate the following:</td>
</tr>
<tr>
<td></td>
<td>• For arguments where the context does not allow italic, such as ASCII output.</td>
</tr>
<tr>
<td></td>
<td>• A character string that the user enters but that does not appear on the window such as a password.</td>
</tr>
</tbody>
</table>
Remote Expert Mobile Solution Overview and Design

- Remote Expert Mobile Overview, page 1
- Remote Expert Mobile Feature Support, page 7
- Restrictions, page 8
- Supported Video Formats and Codecs, page 9
- Call Flows, page 9
- Network Considerations, page 12
- Bandwidth and QoS Considerations, page 13
- Operational Considerations, page 14

Remote Expert Mobile Overview

Cisco Remote Expert Mobile enables real-time customer engagement within mobile and web applications. Remote Expert Mobile is a software solution that allows for personal and actionable customer interaction (interconnected to a contact center environment), from click-to-call to a full collaborative experience (screen share, cobrowse, remote control, content push, annotation, and form-fill). For example, Remote Expert Mobile can connect investors with their financial advisors within a mobile trading application (B2C—Business to Consumer). A field employee can use a mobile application to connect to an internal help desk (B2E—Business to Employee). Developers can deliver voice and video calls in mobile or web applications.

Remote Expert Mobile supports the following browsers for placing and receiving calls:

- Google Chrome
- Internet Explorer
- Mozilla Firefox
- Apple Safari

With WebRTC at its core, in-app communications are enabled without the need for plugins. Where WebRTC is not yet supported (in Internet Explorer and Safari), WebRTC plugins are provided.
Remote Expert Mobile also delivers integrated communications in iOS and Android applications through native libraries.

Remote Expert Mobile provides high-quality video collaboration between customers and agents. The Cisco Remote Expert Mobile solution connects customers with subject matter experts regardless of their respective physical locations. The Remote Expert Mobile solution brings together Cisco technologies in the areas of Telepresence, Collaboration, and Contact Center.

The Remote Expert Mobile components can be installed in an existing Enterprise network. In the following figure, the Remote Enterprise Mobile components are shown in the two boxes on the upper left. The components of the existing Enterprise network are shown in the remaining boxes.

When agents receive Remote Expert Mobile calls, expert assist functionality is enabled on their desktops. When agents receive internal calls from Enterprise registered callers, expert assist functionality is disabled.

Remote Expert Mobile offers two deployment types:

- Contact center deployment

  Remote Expert Mobile is supported with the following contact center solutions:

  * Cisco Packaged Contact Center Enterprise (Packaged CCE)
  * Cisco Unified Contact Center Enterprise (Unified CCE)
  * Cisco Unified Contact Center Express (Unified CCX)
  * Cisco Hosted Collaboration Solution for Contact Center (HCS for Contact Center)
Remote Expert Mobile supports the following capabilities:

- Video communication between agents and callers.
- Video on Hold—Videos play to callers when they are placed on hold by an agent.
- Video-in-Queue—Videos play to callers while they are in queue. This feature presents high-definition video prompts that allow callers to use DTMF keys to navigate a video menu.
  
  Video-in-Queue is fully supported in Packaged CCE, Unified CCE, and HCS for Contact Center deployments.
- Cisco MediaSense recording—Cisco MediaSense can record both the video and audio parts of a video call or record the audio only at the Cisco Unified Border Element level.

Depending on how Remote Expert Mobile is deployed, callers may connect with agents either from within the enterprise network or from devices outside the enterprise. Callers from within the enterprise use endpoints that are registered to Cisco Unified Communications Manager. For example, company employees can engage in a video call with your IT help desk. Callers from outside the enterprise network use an iOS-based or Android-based smartphone or tablet or a browser client for video calls with agents. Expert Assist functionality is not enabled when agents receive calls from within the enterprise.

Remote Expert Mobile requires the following components:

- Cisco MediaSense to store, stream, and play video content. MediaSense can also record video calls.
- Telepresence MCU Video Conference Bridge to facilitate multiparty video conferences.
- Cisco Unified Border Element to connect video calls from Unified Customer Voice Portal (Unified CVP) to Cisco MediaSense to queue the calls or play video prompts. Cisco Unified Border Element is also used for video recording and Unified CVP call survivability at the ingress gateway.
- Video endpoints for agents and callers.
- Remote Expert Mobile Application Server and Media Broker to connect callers from the Internet with agents.

  The Remote Expert Mobile Application Server provides a WebRTC to SIP gateway and an Expert Assist Finesse gadget and Expert console.

  The Remote Expert Media Broker also provides transcoding and pass-through media.

The Remote Expert Mobile Application Server and Media Broker provide expert assist functionality, which includes

- Web cobrowse and screen sharing
- Remote control
- Annotation
- Content push (document and images)
- URL push
- Assisted form completion

- Reverse Proxy to provide load balancing, failover, a single URL for the customer, and SSL offloading.
• Client SDK (iOS and Android) to provide custom applications, JavaScript, and plugin for browser.

The following documents provide more information about the solution components:


**Customer Location**

In the Cisco Remote Expert Mobile solution architecture, the customer location is any one of several devices the customer chooses to use. The location can be:

• Browser-based from a Windows laptop or Apple Mac

• Apple iOS or Android applications from smart phones or tablets

Access is typically through an interactive web-based interface. Customers can select a video chat or assist button to escalate to a video call with an expert. Depending on the browser used, Remote Expert Mobile may download a WebRTC client in the background. Then an IP call is placed to the enterprise using a predetermined HTTP URL. The customer initiating the video call is not registered with the enterprise telephony system.

The enterprise video telephony system completes the call from the customer device when the call is queued for the next available expert.

**Infrastructure Required for Access**

Because customers access the enterprise from the public Internet, Remote Expert Mobile has unique infrastructure requirements. The enterprise typically has two firewalls that this solution must traverse. The first firewall allows access into the corporate DMZ. The DMZ is a network segment within the corporate firewall from the Internet but without unlimited access to the rest of the enterprise. To provide access through this firewall, you must enable the necessary protocols for the video call to be recognized and allowed through.

The Cisco Remote Expert Mobile Media Broker resides within the DMZ and works with the Cisco Remote Expert Mobile Application Server. The Remote Expert Mobile Application Server is located within the data center, beyond the data center firewall, to enable communication to the Unified Communications enterprise infrastructure.
The infrastructure required within the enterprise for this part of the solution includes Cisco Unified Communications Manager or Unified CCE, Packaged CCE, HCS for Contact Center, or Unified CCX. Video-in-Queue, Video on Hold, and Video Recording can be deployed as optional features of the solution. Remote Expert Mobile callers from the Internet and leveraging Remote Expert Mobile components can perform expert assist functions in addition to the audio or video call.

**Deployment Models**

The following figure illustrates a Remote Expert Mobile deployment with Packaged CCE, Unified CCE, or HCS for Contact Center.

---

**Note**

Enterprise registered callers (such as callers to an internal help desk) can only make audio and video calls. When agents receive Remote Expert Mobile calls, expert assist functionality is enabled on their desktops. When agents receive internal calls from Enterprise registered callers, expert assist functionality is disabled.

The following figure illustrates a Remote Expert Mobile deployment with Unified CCX.
Cisco Unified Border Element is an optional component for Unified CCX deployments. It is required only if you need recording at the Cisco Unified Border Element level.

Enterprise registered callers (such as callers to an internal help desk) can only make audio and video calls. When agents receive Remote Expert Mobile calls, expert assist functionality is enabled on their desktops. When agents receive internal calls from Enterprise registered callers, expert assist functionality is disabled.

The following figure illustrates a Remote Expert Mobile deployed in a Unified Communications Manager only solution.
In the Unified Communications Manager only solution, the expert audio and video terminate on the browser only.

Cisco Unified Border Element is an optional component for Unified Communications Manager only deployments. It is required only if you need recording at the Cisco Unified Border Element level.

Enterprise registered callers (such as callers to an internal help desk) can only make audio and video calls. When agents receive Remote Expert Mobile calls, expert assist functionality is enabled on their desktops. When agents receive internal calls from Enterprise registered callers, expert assist functionality is disabled.

---

Remote Expert Mobile Feature Support

The following table lists the Remote Expert Mobile features and indicates which deployment types support each feature.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Unified CCE/Packaged CCE/HCS for Contact Center</th>
<th>Unified CCX</th>
<th>Unified Communications Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video Conference and Transfer</td>
<td>Supported</td>
<td>Supported only for certain endpoints</td>
<td>Not supported</td>
</tr>
<tr>
<td>Video on Hold</td>
<td>Supported</td>
<td>Supported</td>
<td>Not supported</td>
</tr>
</tbody>
</table>
Restrictions

The following table lists restrictions for Remote Expert Mobile.

Note

The following is not an exhaustive list. If an option or feature is not mentioned in this document, it is not supported in this deployment.

<table>
<thead>
<tr>
<th>Restriction Type</th>
<th>Restriction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact center features</td>
<td>Remote Expert Mobile does not support the following contact center features:</td>
</tr>
<tr>
<td></td>
<td>• Agent Greeting</td>
</tr>
<tr>
<td></td>
<td>• Whisper Announcement</td>
</tr>
<tr>
<td></td>
<td>• Mobile Agent</td>
</tr>
<tr>
<td></td>
<td>• Silent Monitor</td>
</tr>
<tr>
<td></td>
<td>• Remote Silent Monitor</td>
</tr>
<tr>
<td></td>
<td>• Video on Hold (caller-initiated)</td>
</tr>
<tr>
<td></td>
<td>• Outbound Dialer</td>
</tr>
<tr>
<td></td>
<td>• Courtesy Callback</td>
</tr>
<tr>
<td>Jabber endpoints</td>
<td>Agents can use Jabber for Mac and Windows as a video endpoint only. As for all endpoints, agents must perform all call control operations (except for answer, mute, and hangup) using the agent desktop. IM and Presence are not supported as part of Jabber.</td>
</tr>
<tr>
<td>Audio codec</td>
<td>Cisco MediaSense does not support G.711 a-law codec for video playback.</td>
</tr>
</tbody>
</table>
Restriction Type | Restriction
---|---
Video resolution scaling | MediaSense does not support video resolution scaling. For example, a 320p video plays at 320p on every device, and a 1080p video plays at 1080p on every device. Supported devices properly handle any necessary up- or down-scaling themselves.

Agent and supervisor desktop features | Agent desktops support a limited set of features for video agents, as follows:
- Standard actions — Agent log in and log out, Agent State (such as Ready, Not Ready, Wrap Up), Dial, Answer, Release, and CTI data.
- Additional services — Hold, Retrieve, and Blind/Consult Transfer/Conference.

Agent desktops do not support these features for video agents:
- Silent Monitor
- Supervisor Barge-In
- Intercept

### Supported Video Formats and Codecs

Cisco MediaSense supports the following formats and codecs for uploaded videos:
- MP4 video with up to 1080p resolution
- H.264 video codec
- AAC-LD MP4A-LATM audio codec

Videos play back using the AAC-LD MP4A-LATM, G.711 mu-law, or G.722 codec, depending on the endpoint.

### Call Flows

**Note**

Cisco Unified Border Element is an optional component in Unified CCX and Unified Communications Manager only deployments. It is required only if you need recording at the Cisco Unified Border Element level.

The following figure illustrates the Remote Expert Mobile high-level topology.
Remote Expert Mobile components include

- Reverse Proxy—Load balancing, failover, hiding Enterprise topology, single URL for consumer, SSL offloading
- Media Broker—Media pass-through and transcoding
- Application Server—WebRTC to SIP gateway, Expert Assist gadget, and Console server
- Client SDK—iOS and Android SDK for custom applications, JavaScript, and plugin for browser

Note

Cisco Unified Border Element is an optional component in Unified CCX and Unified Communications Manager only deployments. It is required only if you need recording at a Cisco Unified Border Element level.

For Unified CCX and Unified Communications Manager only deployments without Cisco Unified Border Element:

In the Cisco Remote Expert Mobile Web Administration portal, go to Gateway > General Administration. For the Outbound Sip Server address, replace the IP address of the Cisco Unified Border Element with the IP address of the Unified Communications Manager.

The following figure illustrates a call flow in a contact center environment.
The client (consumer) connects to the enterprise web server through the Reverse Proxy and starts a call.

The web application gets a session token from the Remote Expert Mobile Application Server and returns it to the client.

The client initiates a web socket connection using the secured context already established.

The Reverse Proxy establishes the web socket connection with the Remote Expert Mobile Application Server.

The Remote Expert Mobile Application Server communicates with the Remote Expert Mobile Media Broker to reserve and negotiate media SDP.

The Remote Expert Mobile Application Server sends a SIP INVITE to the CUBE-E (ingress) gateway.

CUBE-E sends a SIP INVITE to the Packaged CCE, Unified CCE, Unified CCX, or HCS for Contact Center.

Packaged CCE, Unified CCE, Unified CCX, or HCS for Contact Center routes the call to an agent.

The agent uses the Expert Assist Finesse gadget to start the expert assist session with the client (consumer).

The following figure illustrates a call flow in a Unified Communications Manager-only environment.
1. The client (consumer) connects to the enterprise web server through the Reverse Proxy and starts a call.
2. The web application gets a session token from the Remote Expert Mobile Application Server and returns it to the client.
3. The client initiates a web socket connection using the secured context already established.
5. The Remote Expert Mobile Application Server communicates with the Remote Expert Mobile Media Broker to reserve and negotiate media SDP.
6. The Remote Expert Mobile Application Server sends a SIP INVITE to the CUBE-E (ingress) gateway.
7. CUBE-E sends the call to Unified Communications Manager over a SIP trunk.
8. Unified Communications Manager performs hunt group routing and sends the call to a CTI device, which is associated to "Extend and Connect" trunk back to the Remote Expert Mobile Application Server.
9. The Remote Expert Mobile Application Server routes the call to the browser terminating audio and video.
10. The agent uses the Expert Assist console to start the expert assist session with the client (consumer).

Network Considerations

The Remote Expert Mobile solution leverages the Cisco portfolio of routers, switches, and network services so that you can deploy an infrastructure that meets the traffic demands of video. You can configure Cisco Remote Expert Mobile solutions with varying degrees of High Definition video.

To understand the bandwidth required within your deployment, consider the objective of the experience (stationary and detailed video or conversational with a lot of movement). The solution can be delivered over private WANs, MPLS VPNs, or Metro Ethernet networks as long as decisions about QoS policies and video...
and bandwidth requirements are appropriate. Cisco powered WAN/VPN service provider networks typically maintain the levels of network quality required for an acceptable video experience.


**Bandwidth and QoS Considerations**


**Bandwidth Considerations**

To create an immersive collaborative experience between the customer and the agent or expert, plan for and provision Cisco TelePresence calls for the best quality at a resolution of 1080p (1920 x 1080). For calls that come in over the Internet from mobile devices, the maximum resolution is 720p.

The Cisco TelePresence System EX60 and EX90 offer several profile definitions depending on the physical environment in which the devices are located. The minimum required bandwidth depends on the following:

- Optimal definition profile (normal, medium, or high)
- Resolution
- Frame rate

**Note**

The profile definitions refer to the amount of compression applied to the media streams. These names do not refer to the amount of bandwidth required for the profile.

In the Cisco TelePresence software, you can increase the video resolution for situations in which lighting and other environmental considerations are good. You can use the High setting in dedicated rooms with optimal light conditions. You can use Medium for good, stable light conditions. The default setting is Normal. You can usually use the default.

Test each location for session quality, especially if you use the Medium or High setting. In areas with many windows, test at different times of day to ensure that the chosen profile always results in an immersive conferencing experience.

**QoS Considerations**

The following table provides general QoS requirements for the Cisco TelePresence system. Consider these requirements when you plan your expert location capacity.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Optimal</th>
<th>Acceptable</th>
<th>Unacceptable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latency</td>
<td>&lt;= 150-ms RTT</td>
<td>&lt;= 200-ms RTT</td>
<td>&gt;= 400-ms RTT</td>
</tr>
<tr>
<td>Jitter (peak to peak)</td>
<td>&lt;= 10 ms</td>
<td>&lt;= 20 ms</td>
<td>&gt;= 40 ms</td>
</tr>
<tr>
<td>Packet loss</td>
<td>&lt;= 0.05%</td>
<td>&lt;= 0.10%</td>
<td>&gt;= 0.20%</td>
</tr>
</tbody>
</table>
Operational Considerations

A Cisco Remote Expert Mobile solution deployment requires a comprehensive management architecture. The management architecture must provide the capability to provision, monitor, and troubleshoot geographically dispersed customer pods and expert agent positions on a continuous basis.

The number of hardware and software components in the end-to-end system (data center, customer location, and expert location) can make managing a Cisco Remote Expert Mobile solution a challenge. These components provide services to remote users and administrators. Administrators must manage different technologies and services, such as network, storage, databases, and Unified Communications resources.

Use the Cisco Prime Collaboration Assurance (PCA) to monitor the Cisco Unified Communications infrastructure, network components (switches and routers), TelePresence video endpoints, and virtualized ESXi hosts.

Detailed QoS guidance for the expert location WAN edge can depend on whether the WAN is based on a Layer 2 design or on an MPLS and VPN design. For more information, see the Cisco TelePresence Network System 2.0 Design Guide at http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-mediumet/landing_vid_tPresence.html.
Prerequisites

- Required Software, page 15
- Required Hardware, page 17
- System Requirements for Agents, page 19

Required Software

The following table lists the products used in a Remote Expert Mobile solution and their supported software versions.

## Required Software Licenses

Before you install Remote Expert Mobile, acquire the necessary licenses for these products:

- Cisco Telepresence MCU video conference bridge

<table>
<thead>
<tr>
<th>Functional Area</th>
<th>Product</th>
<th>Software Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified Communications Infrastructure</td>
<td>Unified Communications Manager</td>
<td>10.5(2) or later SU</td>
</tr>
<tr>
<td></td>
<td>Unified CCE</td>
<td>10.5(1) or later MR</td>
</tr>
<tr>
<td></td>
<td>Packaged CCE</td>
<td>10.5(1) or later MR</td>
</tr>
<tr>
<td></td>
<td>Unified CCX</td>
<td>10.6(1) or later SU</td>
</tr>
<tr>
<td></td>
<td>HCS for Contact Center</td>
<td>10.6(1) or later MR</td>
</tr>
<tr>
<td></td>
<td>Unified Customer Voice Portal (Unified CVP)</td>
<td>10.5(1) or later MR</td>
</tr>
<tr>
<td></td>
<td>Cisco Unified Border Element/VXML Gateway</td>
<td>15.3(3) M3 or later MR</td>
</tr>
<tr>
<td>Recording</td>
<td>MediaSense</td>
<td>10.5(1) or later SU</td>
</tr>
<tr>
<td>Desk Endpoints</td>
<td>EX-Series: EX60, EX90</td>
<td>TC 7.3.3</td>
</tr>
<tr>
<td></td>
<td>DX-Series: DX650, DX80, DX70</td>
<td>10-2-3-33</td>
</tr>
<tr>
<td>Room Endpoints</td>
<td>MX-Series: MX300 G2, MX700, MX800</td>
<td>TC 7.3.3</td>
</tr>
<tr>
<td>TelePresence Integrator</td>
<td>C-Series: C40, C60, C90</td>
<td>TC 7.3.3</td>
</tr>
<tr>
<td>TelePresence Integration Solutions</td>
<td>SX-Series: SX10, SX20, SX80</td>
<td>TC 7.3.3</td>
</tr>
<tr>
<td>Softphone</td>
<td>Jabber for Windows</td>
<td>10.6.2</td>
</tr>
<tr>
<td></td>
<td>Jabber for Mac</td>
<td>10.6.0</td>
</tr>
<tr>
<td>Remote Expert Mobile Components</td>
<td>Remote Expert Media Broker</td>
<td>10.6(1) or later MR</td>
</tr>
<tr>
<td></td>
<td>Remote Expert Application Server</td>
<td>10.6(1) or later MR</td>
</tr>
</tbody>
</table>
Cisco MediaSense License Requirements

You need the following licenses to run Cisco MediaSense with Remote Expert Mobile:

- MediaSense Base License for the number of concurrent nonredundant sessions required.
- Video Session Licenses for the number of concurrent nonredundant video sessions required.
- MediaSense Server Software Licenses for the Primary and Secondary servers that provide database and media operations.
- MediaSense Expansion Server Software licenses for servers that provide extra capacity for media operations.

More ordering and licensing information is available to Cisco Partners in the following documents:

- Cisco MediaSense Sizing Spreadsheet

Cisco Unified Border Element License Requirements

A software license is required to run Cisco Unified Border Element. If you have already deployed Cisco Unified Border Element, you can reuse the existing ports. However, if you need more sessions to support Remote Expert Mobile, you must purchase extra Cisco Unified Border Element ports. See the Cisco Unified Border Element and Gatekeeper Ordering Guide at [http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/gatecont/ps5640/order_guide_c07_462222.html](http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/gatecont/ps5640/order_guide_c07_462222.html).

Remote Expert Mobile License Requirements

Cisco Remote Expert Mobile is a licensed product. Contact a sales representative from Cisco or a Cisco partner for ordering details. No license keys are provided or required for Remote Expert Mobile.

Required Hardware

Tested Reference Configurations

This section lists the specifications for the C240 M3 server. The customer deployment must run in a duplexed environment using a pair of core Unified Computing System (UCS) C240 M3 servers known as Side A and Side B.
### C240 M3 server

<table>
<thead>
<tr>
<th>Server Model</th>
<th>TRC Name</th>
<th>Specification-Based Hardware Support</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco UCS C240 M3 Tested Reference Configuration (TRC) server</td>
<td>C240 M3S (SFF) TRC#1</td>
<td>Cisco Remote Expert Mobile supports specification-based hardware, but limits this support to only UCS B-Series blade and C-Series server hardware. This section provides the supported server hardware, component version, and storage configurations. For more information about specification-based hardware, see <em>UC Virtualization Supported Hardware</em> at <a href="http://docwiki.cisco.com/wiki/UC_Virtualization_Supported_Hardware#C240_M3S_28SFF.29_TRC.231">http://docwiki.cisco.com/wiki/UC_Virtualization_Supported_Hardware#C240_M3S_28SFF.29_TRC.231</a>.</td>
</tr>
</tbody>
</table>

### Table 1: Hardware Requirements

<table>
<thead>
<tr>
<th>Server</th>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco UCS B2XX Blade Server, such as</td>
<td>CPU Type</td>
<td>Intel Xeon 5600 family 2.40-GHz physical core speed minimum</td>
</tr>
<tr>
<td>• Cisco UCS-B200M2-VCS1 Blade Server</td>
<td></td>
<td>Intel Xeon 7500 family 2.40-GHz physical core speed minimum</td>
</tr>
<tr>
<td>• Cisco UCS-B200M3 Blade Server</td>
<td></td>
<td>Intel Xeon E5-2600 family 2.4-GHz physical core speed minimum</td>
</tr>
<tr>
<td>• Cisco UCS-B230M2-VCDL1 Blade Server</td>
<td></td>
<td>Intel Xeon E5-4600 family 2.4-GHz physical core speed minimum</td>
</tr>
<tr>
<td>Cisco UCS C-Series Server, such as</td>
<td>Memory</td>
<td>64 GB minimum</td>
</tr>
<tr>
<td>• C240 M3</td>
<td>Virtual Interface Card</td>
<td>In addition to legacy M71KR-Q support, all Cisco Virtual Interface Cards (VICs) are supported.</td>
</tr>
</tbody>
</table>
For specification-based hardware, total CPU reservations must be within 65 percent of the available CPU of the host. Total memory reservations must be within 80 percent of the available memory of the host. Total traffic must be within 50 percent of the maximum of the network interface card.

**System Requirements for Agents**

The following table lists the system requirements for Remote Expert Mobile agents who have Jabber and the Finesse Agent Desktop for Windows and Mac.

<table>
<thead>
<tr>
<th>System Requirement</th>
<th>Jabber for Windows and Finesse Agent Desktop</th>
<th>Jabber for Mac and Finesse Agent Desktop</th>
</tr>
</thead>
</table>
| Operating system   | • Microsoft Windows 7 SP1 or later: 32 bit and 64 bit  
 |                    |   • Microsoft Windows 8.x: 32 bit and 64 bit | • Apple OS X Mountain Lion 10.8.1 or later  
 |                    |                                              |   • Apple OS X Mavericks 10.9 or later   
<p>|                    |                                              |   • Apple OS X Yosemite 10.10 or later |
| Installed RAM      | 4 GB                                        | 4 GB                                     |
| Free physical memory | 2 GB                                        | 2 GB                                     |
| Free disk space    | 1 GB                                        | 1 GB                                     |</p>
<table>
<thead>
<tr>
<th>System Requirement</th>
<th>Jabber for Windows and Finesse Agent Desktop</th>
<th>Jabber for Mac and Finesse Agent Desktop</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU speed and type</td>
<td>4th Generation Intel Core i3 or later</td>
<td>1.6-GHz dual-core Intel Core i5 or later on the following Apple hardware:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mac Pro</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MacBook Pro (including Retina Display models)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MacBook</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MacBook Air</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• iMac</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mac mini</td>
</tr>
<tr>
<td>GPU</td>
<td>DirectX 11 on Microsoft Windows 7</td>
<td>—</td>
</tr>
<tr>
<td>I/O ports</td>
<td>USB 2.0 for USB camera and audio devices</td>
<td>USB 2.0 for USB camera and audio devices</td>
</tr>
<tr>
<td>Screen resolution</td>
<td>The minimum supported screen resolution for Finesse clients is 1024x768.</td>
<td>The minimum supported screen resolution for Finesse clients is 1024x768.</td>
</tr>
</tbody>
</table>
Remote Expert Mobile Solution Configuration

- Set Up Remote Expert Mobile Components, page 21
- Cisco Unified Communications Manager Configuration Sequence for Non-Contact Center Solution, page 23

Set Up Remote Expert Mobile Components

You must set up your contact center solution before you install or configure additional Remote Expert Mobile components.

For more information, see one of the following guides:


Install and configure these components for all deployments. This table includes links to installation and configuration instructions for each component.
<table>
<thead>
<tr>
<th>Component Task</th>
<th>Related Document</th>
<th>Notes</th>
</tr>
</thead>
</table>
| Deploy Cisco Unified Border Element                | Cisco IOS Voice Command Reference                      | Confirm that Cisco Unified Border Element is enabled on the system. In the terminal window, type: show cube status  
If Cisco Unified Border Element is disabled, type the following text to enable it:  
Voice service voip  
    Mode border-element  
    Allow-connections sip to sip  
Cisco Unified Border Element is optional in Unified CCX and Unified Communications Manager only deployments. It is required only if you need recording at a Cisco Unified Border Element level. |
| Install and configure Cisco MediaSense             | Cisco MediaSense User Guide at  
http://www.cisco.com/c/en/us/support/customer-collaboration/mediasense/tsd-products-support-series-home.html | The system default incoming call configuration in MediaSense is set to **Record Audio Only**. To record video calls, change this setting to **Record Audio and Video**.  
Follow the instructions to Edit the System Default Incoming Call Rule in the *Administer and Configure MediaSense* chapter to change this setting. |
| Integrate MediaSense and Cisco Unified Border Element | Cisco MediaSense User Guide at  
Be sure to add the username for the AXL Administrator to the Standard Unified Communications Manager Administrators group and Standard AXL API Access roles in Unified Communications Manager, if necessary.  
Cisco Unified Border Element is optional in Unified CCX and Unified Communications Manager only deployments. It is required only if you need recording at a Cisco Unified Border Element level. |
Cisco Unified Communications Manager Configuration Sequence for Non-Contact Center Solution

In a non-contact center deployment, the Remote Expert Mobile application server connects to a Cisco Unified Communications Manager cluster via a SIP trunk. To define a SIP trunk that correlates to the Remote Expert Mobile cluster, perform the following tasks.

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Create a SIP Trunk Security Profile, on page 24</td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td>Create a SIP Profile for Remote Expert Mobile, on page 25</td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>Create a SIP Trunk, on page 25</td>
<td></td>
</tr>
<tr>
<td>4.</td>
<td>Create a Normalization Script to Apply to the Unified Communications Manager Trunk, on page 25</td>
<td></td>
</tr>
<tr>
<td>5.</td>
<td>Set Up an End User, on page 26</td>
<td></td>
</tr>
<tr>
<td>6.</td>
<td>Create a CTI Remote Device, on page 27</td>
<td></td>
</tr>
<tr>
<td>7.</td>
<td>Add a Directory Number to the Device, on page 27</td>
<td></td>
</tr>
<tr>
<td>8.</td>
<td>Define a Route Pattern and Associate It with the SIP Trunk to the Remote Expert Mobile Cluster, on page 28</td>
<td></td>
</tr>
<tr>
<td>Sequence</td>
<td>Task</td>
<td>Notes</td>
</tr>
<tr>
<td>----------</td>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>9.</td>
<td>Add a Remote Destination That Matches the Route Pattern, on page 28</td>
<td></td>
</tr>
<tr>
<td>10.</td>
<td>Define a New Line Group and Associate It with a DN, on page 28</td>
<td></td>
</tr>
<tr>
<td>11.</td>
<td>Create a Hunt List, on page 29</td>
<td></td>
</tr>
<tr>
<td>12.</td>
<td>Define a Hunt Pilot, on page 29</td>
<td></td>
</tr>
</tbody>
</table>
| 13.      | In the Remote Expert Mobile Web Administration portal, go to **Gateway > General Administration.**  
For the Outbound SIP Server address, replace the IP address of the Cisco Unified Border Element with the IP address of the Unified Communications Manager. | Perform this step only for Unified CCX and Unified Communications Manager only deployments that do not have a Cisco Unified Border Element. |

---

**Cisco Unified Communications Manager Configuration**

**Create a SIP Trunk Security Profile**

**Procedure**

**Step 1** In Unified Communications Manager Administration, choose **System > Security > SIP Trunk Security Profile**.

**Step 2** Click **Add New**.

**Step 3** In the Name field, enter **Non Secure SIP Trunk Profile**.

**Step 4** In the Description field, enter a description for the SIP trunk security profile.

**Step 5** Ensure that the setting for Device Security Mode is **Non Secure**.

**Step 6** Ensure that the Incoming Transport Type is **TCP+UDP**.

**Step 7** Ensure that the Outgoing Transport Type is **TCP**.

**Step 8** Check the following check boxes:

- **Accept Presence Subscription**
- **Accept Out-of-Dialog REFER**
- **Accept Unsolicited Notification**
- **Accept Replaces Header**

**Step 9** Click **Save**.
Create a SIP Profile for Remote Expert Mobile

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In Unified Communications Manager Administration, choose <strong>Device &gt; Device Settings &gt; SIP Profile</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>Add New</strong>.</td>
</tr>
<tr>
<td>3</td>
<td>In the <strong>Device Name</strong> field, enter a name for the device.</td>
</tr>
<tr>
<td>4</td>
<td>In the <strong>Description</strong> field, enter a description.</td>
</tr>
<tr>
<td>5</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Create a SIP Trunk

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In Unified Communications Manager Administration, choose <strong>Device &gt; Trunk</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>Add New</strong>.</td>
</tr>
<tr>
<td>3</td>
<td>From the <strong>Trunk Type</strong> drop-down list, choose <strong>SIP Trunk</strong>, and then click <strong>Next</strong>.</td>
</tr>
<tr>
<td>4</td>
<td>Enter a <strong>Device Name</strong>, <strong>Description</strong>, <strong>Device Pool</strong>, and <strong>Destination Address</strong>.</td>
</tr>
<tr>
<td>5</td>
<td>Click <strong>Save</strong>.</td>
</tr>
<tr>
<td>6</td>
<td>Choose <strong>Media Resources &gt; Video On Hold Server</strong>.</td>
</tr>
<tr>
<td>7</td>
<td>Click <strong>Add New</strong>.</td>
</tr>
<tr>
<td>8</td>
<td>Enter a <strong>Name</strong> and <strong>Description</strong> for the MediaSense server.</td>
</tr>
<tr>
<td>9</td>
<td>In the <strong>Default Video Content Identifier</strong> field, enter the address that you used for the Destination Address in Step 4.</td>
</tr>
<tr>
<td>10</td>
<td>In the <strong>SIP Trunk</strong> field, enter the SIP trunk that you created in Steps 1-4.</td>
</tr>
<tr>
<td>11</td>
<td>Click <strong>Save</strong>.</td>
</tr>
<tr>
<td>12</td>
<td>Click <strong>Reset SIP Trunk</strong>.</td>
</tr>
</tbody>
</table>

Create a Normalization Script to Apply to the Unified Communications Manager Trunk

The normalization script alters the SIP message to change to hosts part of destination addresses to what Remote Expert Mobile expects.
Procedure

Step 1  Download the scripts that you need from Cisco.com (https://software.cisco.com/download/navigator.html?mdfid=268439621&flowid=50402). Select the relevant Unified Communications Software version and then select SIP Normalization and Transparency Scripts > Scripts.

Step 2  In Unified Communications Manager Administration, choose Device > Device Settings > SIP Normalization Script.

Step 3  Click Add New.

Step 4  Click Import File.

Step 5  Select the script that you downloaded from Cisco.com.

Step 6  Click Import File.

Step 7  Enter or change the following fields as required:

• Name
• Description
• Memory Threshold
• Lua Instruction Threshold

Step 8  Click Save.

Step 9  Repeat these steps to add each additional script that you require.

Set Up an End User

Procedure

Step 1  In Unified Communications Manager Administration, choose User Management > End User.

Step 2  Enter the appropriate search criteria to find existing users, and then select a user from the list.

Step 3  In the Service Settings section, from the UC Service Profile list, select a service profile to apply to the user. Important For Unified Communications Manager Release 9.x, if the user has only IM and Presence Service capabilities (IM only), you must select Use Default. For IM only users, Unified Communications Manager Release 9.x applies the default service profile even if you select another profile.

Step 4  Apply any other configuration as required and then click Save.
Create a CTI Remote Device

Procedure

Step 1 In Unified Communications Manager Administration, choose **Device > Phone**.
Step 2 Click **Add New**.
Step 3 From the Phone Type drop-down list, choose **CTI Remote Device**.
Step 4 Click **Next**.
Step 5 From the Owner UserID drop-down list, choose the appropriate userID.
   **Note** Only users for whom you enable mobility are available in the Owner UserID drop-down list.
Step 6 In the Device Name field, edit the default value if desired.
Step 7 In the Protocol Specific Information section, from the Rerouting Calling Search Space drop-down list, choose the appropriate option.
Step 8 Specify any other required configuration settings.
Step 9 Click **Save**.

Add a Directory Number to the Device

Procedure

Step 1 In the Phone Configuration window, in the Association Information section, click **Add a new DN**.
Step 2 In the Directory Number field, enter a directory number.
Step 3 Enter all other required information.
Step 4 Click **Save**.
Define a Route Pattern and Associate It with the SIP Trunk to the Remote Expert Mobile Cluster

Procedure

Step 1 In Unified Communications Manager Administration, choose Call Routing > Route/Hunt > Route Pattern.
Step 2 Click Add a New Route Pattern.
Step 3 Choose Call Routing > Route Hunt > Route Pattern.
Step 4 Click Add New.
Step 5 Enter a route pattern of 888111000XXXX.
Step 6 Select the route list that you created.
Step 7 Keep the default value in all other fields.
Step 8 Click Save.
Step 9 Click OK on the Forced Authorization Code message.

Add a Remote Destination That Matches the Route Pattern

Procedure

Step 1 In Unified Communications Manager Administration, choose Device > Phone.
Step 2 In the Find Phone Where field, specify the appropriate filters and then click Find.
Step 3 From the list of phones, select the CTI remote device that you created in Create a CTI Remote Device, on page 27.
Step 4 In the Phone Configuration window, in the Associated Remote Destinations section, click Add a New Remote Destination.
Step 5 In the Destination Number field, enter the destination number.
Step 6 Enter any other required information.
Step 7 Click Save.

Define a New Line Group and Associate It with a DN

Procedure

Step 1 In Unified Communications Manager Administration, choose Call Routing > Route/Hunt > Line Group.
Step 2 In the Find and List Line Groups window, click Add New.
Step 3 In the Line Group Information section, enter settings as follows:
   a) In the Line Group Name field, enter a unique name for the line group.
b) In the RNA Reversion Timeout field, enter the number of seconds after which the call times out if not answered.

c) From the Distribution Algorithm list, select a distribution algorithm to apply to the line group.

Step 4 In the Hunt Options section, enter settings as follows:

a) From the No Answer drop-down list, select the desired option.
b) Check the **Automatically Logout Hunt Member on No Answer** check box.
c) From the Busy drop-down list, select the desired option.
d) From the Not Available drop-down list, select the desired option.

Step 5 In the Line Group Member Information section, you can

a) Find directory numbers or route partitions to add to the line group.
b) Reorder the directory numbers or route partitions in the line group.
c) Remove directory numbers or route partitions from the line group.

Step 6 Click **Save**.

---

### Create a Hunt List

Create a hunt list and associate it with the line group that you defined in [Define a New Line Group and Associate It with a DN, on page 28.](#)

**Procedure**

Step 1 In Unified Communications Manager Administration, choose Call Routing > Route/Hunt > Hunt List.

Step 2 In the Find and List Hunt Lists window, click **Add New**.

Step 3 In the Hunt List Information section, enter settings as follows:

a) In the Name field, enter a unique name for the hunt list.
   The name can contain up to 50 alphanumeric characters, including spaces, periods (.), hyphens (-), and underscores (_).

b) In the Description field, enter a description for the hunt list.

c) Select a Cisco Unified Communications Manager group from the drop-down list.

d) If this hunt list is used for voicemail, check the **For Voice Mail Usage** check box.

Step 4 Click **Save**.

Step 5 Click **Add Line Group**.

Step 6 From the Line Group drop-down list, select the line group that you previously defined.

Step 7 Click **Save**.

---

### Define a Hunt Pilot

Define a hunt pilot and associate it with the hunt list that you created in Create a Hunt List, on page 29.
**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>In Unified Communications Manager Administration, choose <em>Call Routing</em> &gt; <em>Route/Hunt</em> &gt; <em>Hunt Pilot</em>.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Click <em>Add a New Hunt Pilot</em>.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the Hunt Pilot Number field, enter a hunt pilot number.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>From the Hunt List drop-down list, select the hunt list that you previously created.</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>Assign the hunt pilot to a partition and configure other settings as desired.</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>Click <em>Save</em>.</td>
</tr>
</tbody>
</table>
Video Conferencing

Before you can conference video calls, you must configure a conference bridge on Unified Communications Manager.

If you want to use video conferencing in a Unified CCX deployment, you must use DX-Series phones.

Configure Conference Bridges

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In Unified Communications Manager Administration, choose <strong>Media Resources &gt; Conference Bridge</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click <strong>Add New</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Under Hardware Conference, from the Conference Bridge Type list, select <strong>Cisco Telepresence MCU</strong>.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Enter a name for the conference bridge.</td>
</tr>
<tr>
<td>Step 5</td>
<td>In the Destination IP Address field, enter the IP address of the MCU.</td>
</tr>
<tr>
<td>Step 6</td>
<td>From the Device Pool list, select the device pool to which the Remote Expert Customer endpoints are allocated.</td>
</tr>
<tr>
<td>Step 7</td>
<td>For the MCU Conference Bridge SIP port, enter <strong>5060</strong> (default).</td>
</tr>
<tr>
<td>Step 8</td>
<td>Select the SIP Trunk Profile and SIP Profile for the MCU.</td>
</tr>
<tr>
<td>Step 9</td>
<td>In the HTTP Interface section, provide the Username and Password for the MCU and enter 80 for the HTTP Port.</td>
</tr>
<tr>
<td>Step 10</td>
<td>Add an MRG (RE-MRG) in Unified Communications Manager and select this conference bridge as part of the MRG.</td>
</tr>
<tr>
<td>Step 11</td>
<td>Add the MRG to an MRGL (RE-MRGL). Use this MRGL in other Unified Communications Manager configurations (such as SIP trunks).</td>
</tr>
</tbody>
</table>
CHAPTER 5

Video on Hold

- Video on Hold, page 33
- Video on Hold Prerequisites, page 33
- Video on Hold Restrictions, page 33
- Video on Hold Configuration Sequence, page 33
- Configure MediaSense for Video on Hold, page 34
- Configure Unified CM for Video on Hold, page 35
- Configure the Unified CCX Routing Script for Video on Hold, page 35

**Video on Hold**

After you configure the Cisco MediaSense server, Video on Hold is available. After you configure Video on Hold, videos are played to callers when an agent places them on hold.

**Video on Hold Prerequisites**


**Video on Hold Restrictions**

In a Unified CCX deployment, Video on Hold is available only with Enhanced or Premium license packages.

**Video on Hold Configuration Sequence**

To configure Video on Hold, perform the following tasks:
Configure MediaSense for Video on Hold

Add the Video Files to the Media Resource Group List

You must add the video files that you want to be available for Video on Hold to the Media Resource Group List (MRGL) in Cisco MediaSense.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Log in to MediaSense as an Administrator user.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click Administration &gt; Media File Management.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click Add.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Enter the Title, Description, and File.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click Save.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Administration &gt; Incoming Call Configuration.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Click Add.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Enter the Address and Action, and then choose your recently added media file.</td>
</tr>
<tr>
<td>Step 9</td>
<td>Click Save.</td>
</tr>
<tr>
<td>Step 10</td>
<td>Log in to Unified Communications Manager to apply this MRGL to the Device Pool of the client-side video endpoints.</td>
</tr>
</tbody>
</table>
Configure Unified CM for Video on Hold

After you add your new media file to MediaSense, follow these instructions to add a SIP trunk to the MediaSense server and add the Video on Hold server to the Media Resource Group List.

**Note**

In video conference use cases, the video conference bridge is a call leg on Cisco Unified Border Element. Ensure that you select the added Media Resource Group List (MRGL) on the SIP trunk to Cisco Unified Border Element.

**Procedure**

**Step 1** Log in as an Administrator user.
**Step 2** Click **Device > Trunk**.
**Step 3** Click **Add New**.
**Step 4** Click **Trunk Type > SIP Trunk**.
**Step 5** Click **Next**.
**Step 6** Enter the **Device Name**, **Description**, **Device Pool**, and **Destination Address** for the MediaSense server.
**Step 7** Click **Save**.
**Step 8** Click **Media Resources > Video On Hold Server**.
**Step 9** Click **Add New**.
**Step 10** Enter the **Name**, **Description**, **Default Video Content Identifier** (Address from previous section) and recently added SIP Trunk to the MediaSense server. Alternatively, configure a call studio script to prompt the caller for a list of videos, and play the video matching the number the user selected.

**Step 11** Click **Save**.
**Step 12** Click **Device > Trunk** and select the trunk.
**Step 13** Click **Reset**.
**Step 14** Click **Media Resources > Media Resource Group (MRG)**.
**Step 15** Click **Add New**.
**Step 16** Enter the **Name** and **Description**, and then move the new Video on Hold server to **Selected Media Resources**.
**Step 17** Click **Save**.
**Step 18** Click **Media Resources > Media Resource Group List (MRGL)**.
**Step 19** Click **Find** and then select an existing MRGL.
**Step 20** Add the new MRG to the MRGL above the Music on Hold entry (for priority).

Configure the Unified CCX Routing Script for Video on Hold

In the Unified CCX Script Editor, configure the icd.aef script for Video on Hold.

**Procedure**

**Step 1** In the Select Resource Step > Queued output branch, add a Call Hold step to place the call on hold.

**Step 2** Save the script.

**Example Script**

```plaintext
C:\Program Files (x86)\wfvvid_1061\Scripts\system\default\icd.aef

/* Simple Queuing Template */
Start
Acceptor (--Triggering Contact--)
Play Prompt (--Triggering Contact--, WelcomePrompt)
Select Resource (--Triggering Contact-- from CSQ)
Connected
Queued
queueLoop:
    Play Prompt (--Triggering Contact--, QueuePrompt)
    Delay DelayWhileQueued sec
    Goto queueLoop
End
```
Video Recording

Video recording is performed through the Cisco Unified Border Element-E gateway via media forking. The Cisco Unified Border Element-E ingress gateway forks the media stream to the MediaSense server as shown in this configuration:

Video Recording Prerequisites

You must install and configure MediaSense and Cisco Unified Border Element before you can configure Video Recording. For more information, refer to your MediaSense and Cisco Unified Border Element documentation.

Video Recording Restrictions


Video Recording Configuration Sequence

To set up Video Recording, perform the following tasks:

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Configure Cisco Unified Border Element/VXML Gateway</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Configure Cisco Unified Border Element/VXML Gateway for Video Recording, on page 38</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configure Cisco MediaSense</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Add an Incoming Call Rule, on page 40</td>
<td></td>
</tr>
</tbody>
</table>

Configure Cisco Unified Border Element/VXML Gateway for Video Recording

Note

Cisco Unified Border Element is optional in Unified CCX and Unified Communications Manager only deployments. It is required only if you need recording at the Cisco Unified Border Element level.

Procedure

Step 1

Configure the Voice Service VoIP.

Example:

voice service voip
no ip address trusted authenticate
mode border-element
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
  asymmetric payload full
  video screening

Step 2 Configure the voice class codec.

Example:

voice class codec 264
codec preference 1 g729r8
codec preference 2 mp4a-latm
codec preference 3 g711ulaw
codec preference 4 g722-64
video codec h264

Step 3 Configure the media class.
Associate the address that is created in MediaSense under Incoming Call Configuration. The following example uses 3000 (media-recording 3000).

Example:

media class 3
  recorder parameter
    media-recording 3000

Step 4 Configure a dial-peer for the media class (the connection from the Cisco Unified Border Element/VXML to MediaSense). The destination pattern must match the address that is configured in MediaSense under Incoming Call Configuration (3000 in the following example).

Example:

dial-peer voice 3000 voip
description This is the forking dialpeer
destination-pattern 3000
signaling forward none
session protocol sipv2
session target ipv4:10.10.10.60
session transport tcp
voice-class codec 264
voice-class sip options-keepalive

Step 5 Configure the incoming dial-peer.
Associate the media-class that you created in Step 3 to the dial-peer (in the following example, media-class 3).

dial-peer voice 93000 voip
description Incoming Dial-peer for Video Enterprise CC
session protocol sipv2
incoming called-number 930T
voice-class codec 264
voice-class sip asserted-id pai
media-class 3
dtmf-relay rtp-nte
no vad

Configure MediaSense for Video Recording

The following section is optional for Unified CCX and Unified Communications Manager only deployments where there is no Cisco Unified Border Element involved in the call flow.

Add an Incoming Call Rule

You can assign only one incoming call rule to an endpoint address. If you do not assign an incoming call rule, the endpoint uses the system default call rule.

Procedure

Step 1 From the Administration menu, choose Incoming Call Rule Configuration.
Step 2 On the Incoming Call Rule Configuration toolbar, click Add.
Step 3 On the Add Incoming Call Rule screen, in the Address field, enter the address. For example, 3000. This is the address that you added in a media class when you configured the Cisco Unified Border Element/VXML gateway.
Step 4 From the Action drop-down list, select Record Audio and Video.
Step 5 Click Save. MediaSense returns to the Incoming Call Rule Configuration screen. The message "Rule saved" appears at the top of the screen. The new incoming call rule appears in the Incoming Call Rules list.
Video-in-Queue

Video-in-Queue (VIQ) is an optional feature in Packaged CCE, Unified CCE, and HCS for Contact Center deployments. Depending on configuration, the caller interacts through high-definition video prompt or navigates a video menu using DTMF keys. The following figure displays the topology and call flow.
1 Incoming call from the Cisco Unified Border Element-E (Ingress) gateway to Unified CVP.
2 Incoming call to Unified CCE/Packaged CCE/HCS for Contact Center from Unified CVP.
3 Play Unified CVP Studio video application.
4 Unified CVP sends the call to the Cisco Unified Border Element/VXML Gateway.
5 Unified CVP VXML Server application instructs VXML Gateway to connect to a specific dialed number (DN).
6 Cisco Unified Border Element sends the call to Video Media Server with that DN. Caller gets static video.
7 Agent is now available.
8 Unified CVP sends the call to an agent.

The Unified CVP Studio VideoConnect element plays a specific video prompt for video endpoints. VideoConnect also collects and integrates the DTMF input during video-prompt playback with the Unified Call Studio or Unified CCE scripting environment.
Video-in-Queue does not play during a Unified Communications Manager failover.

Note
When setting up the Video-in-Queue for Unified CVP, set the MediaSense Incoming Call Configuration > Action to play once.

Video-in-Queue Prerequisites
You must set up the following components before you can configure Video-in-Queue:

- Packaged CCE, Unified CCE, or HCS for Contact Center
- MediaSense
- Cisco Unified Border Element/VXML
- Unified CVP Call Studio

Video-in-Queue Restrictions
The Video-in-Queue feature is available in deployments with Unified CCE, Packaged CCE, or HCS for Contact Center.

Video-in-Queue is available in Unified CCX without DTMF interaction.

Video-in-Queue is not available in standalone Unified Communications Manager deployments.

Video-in-Queue Configuration Sequence
To set up Video-in-Queue for Packaged CCE, Unified CCE, or HCS for Contact Center deployments, perform the following tasks:

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Configure Cisco Unified Communications Manager</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Provision Video Endpoints, on page 45</td>
<td></td>
</tr>
<tr>
<td><strong>Configure Cisco MediaSense</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Upload Video File, on page 47 to play to callers</td>
<td></td>
</tr>
</tbody>
</table>
## Video-in-Queue Configuration Sequence

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
</table>
| 4        | Associate the Dialed Number with the Video File, on page 47 | The Dialed Number for the video must match the following settings on other components:  
- **VXML/Cisco Unified Border Element gateway dial peer configuration:** destination-pattern  
- **Unified CVP Call Studio Script:** VideoConnect element VideoMedia Server DN setting  
- **Packaged CCE routing script:** "video_id" value for the `Set` variable that points to the Unified CVP Studio script for Video-in-Queue |

Configure Cisco Unified Border Element/VXML Gateway

| 5        | Configure Cisco Unified Border Element/VXML Gateway for Video-in-Queue, on page 48 to connect a dial-peer to MediaSense and configure video capabilities on the gateway. | The destination-pattern must match the pattern used for the Dialed Number that you associated with the uploaded video in MediaSense Administration. |

Write the Cisco Unified CVP Call Studio Script

| 6        | Create Unified CVP Call Studio Script for Video-in-Queue, on page 49 |  |

Write the Routing Script

| 7        | If necessary, create a new dialed number and call type for the Video-in-Queue routing script you will create in the next step. |  |
| 8        | Configure the Routing Script for Video-in-Queue, on page 51 that invokes the Unified CVP Call Studio script. | The "application" value in the `Set` variable must be set to the name of the Unified CVP Call Studio script. The "video_id" value for the `Set` variable must the Dialed Number for the video in MediaSense Administration. |

To set up Video-in-Queue for Unified CCX deployments, perform the following tasks:
<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Upload Video File, on page 47 to play to callers.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Associate the Dialed Number with the Video File, on page 47.</td>
<td></td>
</tr>
</tbody>
</table>

### Configure Unified Communications Manager

3. Create a Video on Hold Server, on page 53, add it to a Media Resource Group, and add the Group to a Media Resource Group List.

### Write the Unified CCX Script


5. Upload the Script, on page 54.

6. Create an Application Using the Script, on page 54 and assign a trigger.

---

**Configure Unified Communications Manager**

After the postinstallation process for a Cisco MediaSense server, access your Unified CM server. In Unified CM Administration, configure the SIP Trunk and video endpoints.

**Provision Video Endpoints**


This section provides additional configuration necessary for video endpoints.

**Configure Multiline Settings for Video Phones**

You configure multiline settings for video phones in both Configuration Manager (for Unified CCE) or Unified CCE Administration (for Packaged CCE) and Unified Communications Manager Administration. After changing the settings, you must restart the Peripheral Gateway services on the Side A and Side B Unified CCE Call Servers.
Procedure

Step 1  For Unified CCE, access the Configuration Manager tool and perform the following steps:
   a) Navigate to **Explorer Tools > PG Explorer**
   b) On the Peripheral tab, select **All Lines** from the **Agent Phone Line Control** drop-down menu.
   c) Click **Save**.

Step 2  For Packaged CCE, log in to **Unified CCE Administration** as an Administrator, and perform the following steps:
   a) Navigate to **System > Settings > Agent**.
   b) Select **All Lines** from the **Agent Phone Line Control** drop-down menu.
   c) Click **Save**.

Step 3  On the Unified Communications Manager publisher, log in to **Unified CM Administration** as an Administrator, and perform the following steps:
   a) Navigate to **Cisco Unified Communications Manager Administration > Bulk Administration**.
   b) Use the Unified Communications Bulk Administration Tool to modify the device profiles for all phones as follows:
      - Set **Maximum Number of Calls** to 2. This value indicates that the phones do not allow multiple calls per line.
      - Set **Busy Trigger** to 1. This value indicates that if the line is in use, other calls presented to that line are rejected with a busy cause.


Step 4  Restart the Peripheral Gateway services as follows:
   a) On the Side A Unified CCE Call Server, use the **Unified CCE Service Control** tool to restart PG1A and PG2A.
   b) On the Side B Unified CCE Call Server, use the **Unified CCE Service Control** tool to restart PG1B and PG2B.

Set the Default Maximum Session Bit Rate for Video Calls

Unified Communications Manager Region settings are set by default to a maximum session bit rate of 384 kbps for video calls. This bit rate does not support HD video. You must change the default value to a value higher than 6000 kbps.
Procedure

Step 1  In Cisco Unified Communications Manager Administration, navigate to System > Region Information > Region.
Step 2  Enter Default in the text field and click Find.
Step 3  Click Default in the results.
Step 4  In the Modify Relationships to other Regions > Maximum Session Bit Rate for Video Calls section, select the kpbs radio button and enter a value higher than 6000.
Step 5  Click Save.

Configure Cisco MediaSense

Use a Video Media Server to upload, store, and play back video prompts. Cisco MediaSense is the Video Media Server that provides network-based multimedia capture, streaming, and recording. Cisco MediaSense records conversations on the network rather than on a device. This process simplifies the architecture, lowers costs, provides optimum scalability, and facilitates use by analytics applications from Cisco technology partners.

Upload Video File

After installing Cisco MediaSense, upload a video MP4 file.

Procedure

Step 1  Go to Administration > Media File Management and click Add.
Step 2  Type in the Title (filename) and Description, and then browse to the location of the video MP4 file.
Step 3  Click Save to upload the video file to MediaSense server.

What to Do Next

Associate the file with a new dialed number.

Associate the Dialed Number with the Video File

Once you upload a video file, associate the file with a dialed number.
Procedure

Step 1  Go to Administration > Incoming Call Configuration and click Add.
Step 2  Click Address, and type the address of the appropriate dialed number.
Step 3  In the Action drop-down menu, choose Play Once.
Step 4  In the Media File drop-down menu, choose the appropriate video file. The file is now associated with this dialed number.

Configure Cisco Unified Border Element/VXML Gateway for Video-in-Queue

Procedure

Step 1  Configure the connection from a dial-peer to Video Media Server.

Example:
This example Cisco Unified Border Element/VXML Gateway dial-peer code shows the configuration needed to connect a dial-peer to MediaSense:

```
application
  service cvp_videoconnect flash:cvp_videoconnect.tcl
voice_service voip
  allow-connections sip to sip
```

Step 2  Configure a connection from Cisco Unified Border Element/VXML Gateway to MediaSense.

Example:
This example code connects Cisco Unified Border Element/VXML Gateway to MediaSense:

```
voice class codec 264
  codec preference 1 mp4a-latm
  codec preference 2 g722-64
  codec preference 3 g711ulaw
  codec preference 4 g729r8
video codec h264

dial-peer voice 7000 voip
  description dial-peer to mediasense
  destination-pattern 7000T
  session protocol sipv2
  session target ipv4:<mediasense ip address>
  dtmf-relay rtp-npe
  voice-class codec 264
  no vad
```
You must add the destination-pattern code to configure video capabilities on the gateway. The destination-pattern must match the pattern used for the Dialed Number that you associated with the uploaded video in MediaSense Administration.

Create Unified CVP Call Studio Script for Video-in-Queue

The CVP Studio VideoConnect element plays the specific video prompts for video endpoints. VideoConnect also collects and integrates the DTMF input during video prompt playback within a standard scripting environment.

The following graphic shows a sample CVP studio script:
Table 2: Settings

<table>
<thead>
<tr>
<th>Name (Label)</th>
<th>Required</th>
<th>Default</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video Media Server DN</td>
<td>Yes</td>
<td>None</td>
<td>Video Media Server Destination Number. Example: 5000. Must be a valid dialed number on Cisco Unified Border Element and Video Media Server.</td>
</tr>
<tr>
<td>Digit Match Pattern</td>
<td>No</td>
<td>None</td>
<td>Pattern to use for matching incoming digit collection. Leave blank for no digit collection. Example: 600. Must be a valid pattern for Cisco IOS gateway. The pattern format is the same as the destination-pattern format used in IOS gateway dial-peers.</td>
</tr>
<tr>
<td>No Input Timeout</td>
<td>No</td>
<td>No timeout</td>
<td>Maximum time (secs) to wait for caller input. Example: 15.</td>
</tr>
</tbody>
</table>

The following table describes the different ways a video call is completed/terminated:

<table>
<thead>
<tr>
<th>Exit State</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>End_of_media</td>
<td>Video played to completion and the video server disconnected.</td>
</tr>
<tr>
<td>Caller_input</td>
<td>Caller entered a DTMF string that matched the specified digit collection pattern.</td>
</tr>
<tr>
<td>No_input</td>
<td>No input received before the input timeout expired on a digit collection pattern.</td>
</tr>
<tr>
<td>Error</td>
<td>An error or other unexpected termination occurred.</td>
</tr>
<tr>
<td>Caller_hangup</td>
<td>Caller disconnected while video in progress.</td>
</tr>
</tbody>
</table>

The following table describes element data that is created when one of these exit states is not completed:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>callerdtmf</td>
<td>string</td>
<td>The digit string value captured.</td>
</tr>
<tr>
<td>result</td>
<td>string</td>
<td>Video call outcome.</td>
</tr>
</tbody>
</table>
Configure the Routing Script for Video-in-Queue

Configure Packaged CCE Routing Script for Video-in-Queue

Procedure

Step 1 Create a new dialed number (if necessary) for the Video-in-Queue script. Use the Dialed Number tool in Unified CCE Administration to complete this step. For instructions, see the Cisco Packaged Contact Center Enterprise Administration and Configuration Guide at http://www.cisco.com/c/en/us/support/customer-collaboration/packaged-contact-center-enterprise/tsd-products-support-series-home.html.

Step 2 Associate the dialed number with either a new or existing call type. Use the Dialed Number and Call Type tools in Unified CCE Administration to complete this step. For instructions, see the Cisco Packaged Contact Center Enterprise Administration and Configuration Guide at http://www.cisco.com/c/en/us/support/customer-collaboration/packaged-contact-center-enterprise/tsd-products-support-series-home.html.

Step 3 Create a routing script in Script Editor that invokes the Unified CVP Call Studio script that you created for Video-in-Queue.

Step 4 Schedule the routing script for the call type in the Script Editor Call Type Manager.

Configure the Unified CCE Routing Script for Video-in-Queue

Procedure

Step 1 Create a new dialed number (if necessary) for the Video-in-Queue script. Use the Dialed Number tool in Configuration Manager to complete this step. For more information, see the Configuration Manager Online Help.

Step 2 Associate the dialed number with either a new or existing call type. Use the Dialed Number and Call Type tools in Configuration Manager to complete this step.

Step 3 Create a routing script in Script Editor that invokes the Unified CVP Call Studio script that you created for Video-in-Queue.

Step 4 Schedule the routing script for the call type in the Script Editor Call Type Manager.
Create Script Editor Routing Script for Video-in-Queue

The following illustration is a sample Script Editor script for Video-in-Queue. In this script:

- The Set variable is set to "application=VideoIVR;video_id=7000019" where application is the name of the Unified CVP Call Studio application, and video_id indicates the video to play. The video_id is the Dialed Number for the video in MediaSense Administration.

- The RunExtScript node uses the standard "GS,Server,V" to invoke the Unified CVP VXML application.

- You can receive the DTMF digits back from CVP Studio application in the "Call.user.microapp.FromExtVXML[0]".

After creating your script, schedule the routing script using Call Type Manager in Script Editor.
Configure Unified CCX for Video-in-Queue

Create a Video on Hold Server

Create a Video on Hold server in Unified Communications Manager and add it to a Media Resource Group (MRG). Use the incoming call rule that you created in the previous step. Add the MRG to a Media Resource Group List (MRGL). You can then assign the MRGL to trunks and gateways as required.

Procedure

Step 1 In Unified Communications Manager Administration, choose Media Resources > Video On Hold Server.
Step 2 Click Add New.
Step 3 Enter the Name, Description, and Default Video Content Identifier (the address from the previous procedure).
Step 4 Click Save.
Step 5 Click Media Resources > Media Resource Group (MRG).
Step 6 Click Add New.
Step 7 Enter the Name and Description, and then move the Video on Hold server to the Selected Media Resources.
Step 8 Click Save.
Step 9 Click Media Resources > Media Resource Group List (MRGL).
Step 10 Click Find and select the MRGL that is assigned to the Unified CCX CTI ports.
Step 11 Add the new MRG to the MRGL.

Create the Unified CCX Script for Video-in-Queue

Procedure

Step 1 In the Unified CCX Script Editor, create a script that uses the Call Hold/Unhold steps as shown in the following example:

Example:

---

**Upload the Script**

Use Script Management in Unified CCX Administration to upload the script you created for Video-in-Queue.

**Procedure**

**Step 1**  In Unified CCX Administration, navigate to *Applications > Script Management > Upload Scripts.*

**Step 2**  Browse to the script that you created for Video-in-Queue.

**Step 3**  Click *Upload.*

---

**Create an Application Using the Script**

In Unified CCX Administration, create an application using the script you created for Video-in-Queue. Then assign a trigger to the application.
Procedure

Step 1  In Unified CCX Administration, navigate to Applications > Application Management.
Step 2  Click Add New.
Step 3  For the Application Type, select Cisco Script Application, and then click Next.
Step 4  Enter a Name for the application.
Step 5  From the Script list, select the script that you created for Video-in-Queue.
Step 6  Click Add.
Step 7  Assign a trigger to the new application.
Step 8  Sign an agent in to the Finesse desktop. Leave the agent state as Not Ready.
Step 9  Call the trigger associated to the Unified CCX application.
Create an Application Using the Script
Call Context

- User-to-User, page 57
- User-to-User Restrictions, page 57
- User to User Configuration Sequence, page 57
- Configure Cisco Unified Border Element/Ingress Gateway, page 58
- Configure Unified CVP, page 58
- Configure the ICM Script, page 59

User-to-User

The User-to-User feature allows a consumer application to pass context information about the call to the contact center agent.

User-to-User Restrictions

The User-to-User feature is available in deployments with Unified CCE, Packaged CCE, or HCS for Contact Center.

This feature is not available in Unified CCX deployments or standalone Unified Communications Manager deployments.

User to User Configuration Sequence

To set up User to User, perform the following tasks.

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Configure Cisco Unified Border Element/Ingress Gateway, on page 58</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Configure Unified CVP, on page 58</td>
<td></td>
</tr>
</tbody>
</table>
Configure Cisco Unified Border Element/Ingress Gateway

**Note**
This section is optional for Unified CCX and Unified Communications Manager only deployments where there is no Cisco Unified Border Element involved in the call flow.

**Procedure**
Configure User-to-User as shown in the following example.

**Example:**
```
voice service voip
sip
    pass-thru headers unsupp
```

Configure Unified CVP

**Procedure**

**Step 1**
On the Unified CVP Call Server, pass the "User-to-User" header to Unified ICM.

**Step 2**
Configure the SIP header as "User-to-User" as shown in the following example.

**Example:**

```
SIP Header Passing (to ICM)
```

```
Header Name:
Parameter: 2
```

```
Add Remove
```

```
User-to-User
```

---

Call Context

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Task</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Configure the ICM Script, on page 59</td>
<td></td>
</tr>
</tbody>
</table>

### Configure the ICM Script

**Procedure**

**Step 1** Extract the SIP header information from Unified CVP in the routing script.

**Step 2** Convert the header from hexadecimal to ASCII using a custom function as shown in the example that follows this procedure.

**Step 3** Assign the header to an agent call variable (for example, Call.PeripheralVariable1).

### ConvertToUUI(%1%)

Given a string in the format

"User-to-User:XXYYZZ<data>;encoding=hex;"

the custom function returns the string in clear text clid+OP_ID.

For example:

"User-to-User:04C812303339333531323334353637B3323434;encoding=hex"

Result:

"0039335123456+244"

Assume the following for the example custom function:

- CLID and OP_ID are numeric only.
- The length of OP_ID is a fixed 3 digits.
- The length of the CLID is a maximum of 24 digits.

**ConvertToUUI**

```
concatenate(concatenate(mid(left(right(before(";encoding=hex",after("User-to-User:",%1%)),
len(before(";encoding=hex",after("User-to-User:",%1%))-6)),len(right(before(";encoding=hex",
after("User-to-User:",%1%))-6))-8),2,1),
mid(left(right(before(";encoding=hex",after("User-to-User:",%1%)),
len(before(";encoding=hex",after("User-to-User:",%1%))-6)),len(right(before(";encoding=hex",
after("User-to-User:",%1%))-6))-8),4,1),
mid(left(right(before(";encoding=hex",after("User-to-User:",%1%)),
len(before(";encoding=hex",after("User-to-User:",%1%))-6)),len(right(before(";encoding=hex",
after("User-to-User:",%1%))-6))-8),6,1),
mid(left(right(before(";encoding=hex",after("User-to-User:",%1%)),
len(before(";encoding=hex",after("User-to-User:",%1%))-6)),len(right(before(";encoding=hex",
after("User-to-User:",%1%))-6))-8),8,1),
left(right(before(";encoding=hex",after("User-to-User:",%1%))-6),10,1)
```

---

Cisco Contact Center Solutions and Unified Communications Manager Solution Configuration Guide for Remote Expert Mobile Release 10.6(x)

Page 59
Configure the ICM Script

After (“User-to-User:”,%1%), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6), len(right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 10, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 12, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 14, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 16, 1), concatenate(mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 16, 1)), mid(right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 16, 11), concatenate(mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 20, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 22, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 24, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 26, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 28, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 30, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 32, 1), concatenate(mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 34, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 36, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 38, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 40, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 42, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 44, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 46, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 48, 1), mid(left (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6))-8), 6, 6), 6, 2, 1), mid(right (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6)), 6, 6), 6, 1), mid(right (right (before (“;encoding=hex”, after (“User-to-User:”,%1%)), len(before (“;encoding=hex”, after (“User-to-User:”,%1%))-6)), 6, 6), 6, 1))

Finesse Expert Assist Gadget

Remote Expert Mobile includes integration with Cisco Finesse. The Finesse Expert Assist gadget is an HTML widget that is accessed by Cisco Finesse over secure HTTP (HTTPS).

The Finesse Expert Assist gadget for agents allows agents to

• Share screens
• Push content (such as documents or URLs)
• Annotate forms

The Finesse Expert Assist gadget for supervisors allows supervisors to manage screen share files and links.

Finesse Expert Assistance Gadget Prerequisites


Finesse Expert Assist Gadget Restrictions

The Finesse Expert Assist gadget is available only when Remote Expert Mobile is deployed with

• Packaged CCE
The Finesse Expert Assist gadget is not available for standalone Unified Communications Manager deployments.

Finesse Expert Assist Gadget Configuration

Expert Assist Console

The Expert Assist Console allows the remote user of an application to share the screen of their tablet, smartphone, or browser tabs with an expert advisor.

Expert Assist Console allows the expert to

- Control the remote user's application through point and click.
- Traverse through menus and jump to specific information.
- Complete a form.
- Walk the remote user through a process.
- Move the live video window.

Expert Assist Console Prerequisites


Expert Assist Console Restrictions

Expert Assist Console is available only in standalone Unified Communications Manager deployments.
Expert Assist Console Configuration