The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

Notwithstanding any other warranty herein, all document files and software of these suppliers are provided "as is" with all faults. Cisco and the above-named suppliers disclaim all warranties, expressed or implied, including, without limitation, those of merchantability, fitness for a particular purpose and noninfringement or arising from a course of dealing, usage, or trade practice.

In no event shall Cisco or its suppliers be liable for any indirect, special, consequential, or incidental damages, including, without limitation, lost profits or loss or damage to data arising out of the use or inability to use this manual, even if Cisco or its suppliers have been advised of the possibility of such damages.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: http://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

© 2012-2013 Cisco Systems, Inc. All rights reserved.
CONTENTS

Preface

About this guide  v
Purpose  v
Important note about Cisco Unified CCE solution deployment  v
Audience  vi
Organization  vi
Related documentation  vi
Conventions  vii
Documentation and support  vii
Documentation feedback  vii

CHAPTER 1
Cisco CTI OS in a Citrix XenApp environment  1
Introduction  1
Supported platforms  1
CTI OS installation and configuration under Citrix XenApp Service  1
Install Cisco CTI OS  2
Tracing configuration  2
  TraceFileName  2
  TraceMask  3
Publish CTI OS clients in Citrix XenApp 6.5  3
Citrix Web Client  12
Purpose

This document is intended to guide a Citrix administrator through the installation and configuration of Cisco CTI OS Release 10.0(x) in a Citrix XenApp 6.5 environment.

Important note about Cisco Unified CCE solution deployment

Cisco's Unified Contact Center Enterprise (Unified CCE) solution consists of a number of Cisco products. These products are thoroughly tested and documented to ensure that the solution has extremely high availability and can be supported easily and quickly.

Deploying platforms, configurations, or third party applications that are not explicitly identified in Cisco product documentation as supported will significantly impact the performance and capacity of the Cisco Unified CCE solution. Using such non-standard components may contribute to extensive outages that could seriously impact your business and your customers. It will also greatly hinder the ability of the Cisco Technical Assistance Center (TAC) organization to diagnose and resolve issues, to the extent that resolution of issues may not be possible.

Cisco TAC supports Cisco products and documented third party applications and configurations that are part of your Unified CCE deployment. However, Cisco TAC cannot and will not guarantee the overall stability of platforms that use non-supported components or configurations. Cisco TAC will not be able to assist in troubleshooting any problems that exist for the agent desktops on unsupported platforms or configurations.
In addition, Cisco TAC may be unable to provide assistance of any type if initial analysis suggests that unsupported platforms might be contributing to the issue. In such cases, Cisco TAC provides best effort support and only troubleshoots the supported applications and components of your Cisco Unified CCE solution, not the overall solution environment.

For these reasons, deploy the Unified CCE solution in accordance with Cisco's published solution design guidelines. See the Design Guide for a quick reference on configuration limits and scalability constraints. For information on system requirements, see Virtualization for Unified CCE and the Compatibility Matrix for Unified CCE pages on the DocWiki.

### Audience

This manual is intended for Cisco and partner system administrators and integrators.

### Organization

The following table describes the information contained in the chapter of this guide.

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1: Cisco CTI OS in a Citrix XenApp environment, on page 1</td>
<td>Guides a Citrix administrator through the installation and configuration of Cisco CTI OS Release 10.0(x) in a Citrix XenApp 6.5 environment.</td>
</tr>
</tbody>
</table>

### Related documentation

Documentation for Cisco Unified ICM/Unified Contact Center Enterprise & Hosted, as well as related documentation, is accessible from Cisco.com at http://www.cisco.com/web/psa/products/index.html.


- For documentation for these Cisco Unified Contact Center Products, go to http://www.cisco.com/web/psa/products/index.html

- click on Voice and Unified Communications, then click on Cisco Unified Contact Center Products or Cisco Unified Voice Self-Service Products, then click on the product/option you are interested in.

- For troubleshooting tips for these Cisco Unified Contact Center Products, go to http://docwiki.cisco.com/wiki/category:Troubleshooting, then click the product/option you are interested in.

- Also related is the documentation for Cisco Unified Communications Manager, which can also be accessed from http://www.cisco.com/web/psa/products/index.html

• The Product Alert tool can be accessed through (login required) http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice

Conventions

This manual uses the following conventions.

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boldface type is used for user entries, keys, buttons, and folder and submenu names.</td>
<td>Choose Edit &gt; Find from the Configure menu bar.</td>
</tr>
<tr>
<td>Italic type indicates one of the following:</td>
<td>A skill group is a collection of agents who share similar skills.</td>
</tr>
<tr>
<td>• A newly introduced term</td>
<td>• Do not use the numerical naming convention that is used in the predefined templates (for example, persvc01).</td>
</tr>
<tr>
<td>• For emphasis</td>
<td>• IF (condition, true-value, false-value)</td>
</tr>
<tr>
<td>• A generic syntax item that you must replace with a specific value</td>
<td>• For more information, see the Database Schema Guide for Cisco Unified ICM/Contact Center Enterprise &amp; Hosted.</td>
</tr>
<tr>
<td>• A title of a publication</td>
<td></td>
</tr>
<tr>
<td>An arrow ( &gt; ) indicates an item from a pull-down menu.</td>
<td>The Save command from the File menu is referenced as File &gt; Save.</td>
</tr>
</tbody>
</table>

Documentation and support

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:


Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.

Documentation feedback

You can provide comments about this document by sending email to the following address:
ccbu_docfeedback@cisco.com

We appreciate your comments.
Cisco CTI OS in a Citrix XenApp environment

• Introduction, page 1
• Supported platforms, page 1
• CTI OS installation and configuration under Citrix XenApp Service, page 1

Introduction

CTI OS Release 10.0(x) supports the running of CTI OS Desktop applications within a Citrix Xenapp 6.5 environment. Citrix XenApp permits hosting of several concurrent client applications simultaneously. This hosted environment reduces the deployment and software maintenance burden on CTI OS administrators and corporate information technology (IT) teams.

This document is intended to guide a Citrix administrator through the installation and configuration of Cisco CTI OS Release 10.0(x) in a Citrix XenApp 6.5 environment.

CTI OS Release 10.0(x) supports CTI OS Clients on Win2k8 R2 with Citrix Xenapp 6.5 64-bit.

Supported platforms

The supported server platform is win2k8 R2 with XenApp.

CTI OS installation and configuration under Citrix XenApp Service

The process of installing and configuring CTI OS for use with a Citrix XenApp environment involves the following procedures:

• Installing Cisco CTI OS
• Publishing CTI OS clients in Citrix XenApp 6.5
Install Cisco CTI OS

To install Cisco CTI OS software, perform the following steps.

**Procedure**

1. Insert the CTI OS software CD.
2. From the Start menu select Control Panel.
3. On the Control Panel, select **Add/Remove Programs**.
4. On the **Add/Remove Programs** screen, double click on the icon marked **Add New Programs**.
5. On the **Add New Programs** screen, click on the button marked **CD or Floppy**.
6. Click **Next** on the **Install From Floppy Disk or CD-ROM** screen.
7. Click **Browse** and locate the CTI OS Toolkit Install program. For CTI OS major releases, this program is named Setup.exe. For Maintenance Releases and Engineering Specials, this program name is in a format that identifies the release number (for example, CTIOS8[17].0(1)_SR1_39.exe).
8. For CTI OS major and minor releases, follow the directions in the **CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted** to install Cisco CTI OS on the Citrix MetaFrame Presentation Server. Accept the default location provided by the CTI OS Setup program. For Service Releases and Engineering Specials, follow the installation instructions for that particular package,
9. If the CTI OS installation program does not reboot the system automatically, click **Finish**.

**Tracing configuration**

The CTI OS Tracing configuration is classified in two categories: Global Machine Settings and Per User Settings.

Global Machine settings are those settings that apply to all the CTI OS trace services that are running on the computer. For detail on the settings that apply, refer to the **CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted**.

Per User Settings are settings that only apply to the CTI OS trace service running under the current user session. The only setting that applies is TraceMask. See Appendix A for details.

**TraceFileName**

This setting contains the system variable %HOMEPATH% prepended to the log file name, as shown in the following example:

"%HOMEPATH%/CtiosClientLog"

**Note**

Specifying the home path may add excessive tracing overhead that will affect the performance of Citrix XenApp Server. For more details, refer to [http://support.citrix.com/docs/](http://support.citrix.com/docs/). In addition, this directory must have read, write, and execute access for the members of the CTIOSCitrixUsers Windows user group.
TraceMask

TraceMask is both a global and a per user setting that controls the tracing level for CTI OS Desktops running on the host.

Note

Tracing should be enabled for troubleshooting purposes only. If it is necessary to enable tracing, the recommended setting for a Citrix environment is 0x0000007 rather than the standard CTI OS default of 0x40000307.

Publish CTI OS clients in Citrix XenApp 6.5

The settings indicated in the following steps were selected carefully to ensure the correct functioning of the CTI OS clients. Combinations other than those mentioned in these steps are not supported by Cisco.
Procedure

**Step 1** Launch the Citrix AppCenter.

**Step 2** From the tree on the left, select the **Farm** on which you want to publish the CTI OS clients, and select the **Applications** branch.

**Step 3** Right click **Applications**, and select **Publish Application**.
Publish CTI OS clients in Citrix XenApp 6.5

Cisco CTI OS in a Citrix XenApp environment

Integrating Cisco CTI OS Release 10.0(x) into Citrix XenApp 6.5

Publish Application (1/4)

Welcome

Steps:
- Welcome
- Basic
- Name
- Type
- Location
- Servers
- Users
- Shortcut
- Presentation
- Publish immediately

This is the application publishing wizard for XenApp. It will guide you through the process of publishing an application.

Select Next to continue or Cancel to stop the application publishing process.

After publishing an application, you can change its settings by selecting the published application and choosing Modify application properties from the Common Tasks pane in the AppCenter console.

Skip this screen in the future
The Publish Application wizard appears. Click **Next**.

**Step 4** Enter the display name and application description to be displayed to clients, and then click **Next**.

**Step 5** Select the options as specified in the image below, and then click **Next**.
Step 6  In the **Command line** and **Working directory** fields, specify the respective paths of the CTI OS client, and then click **Next**.
Step 7 Configure the servers that will host the published CTI OS application, and then click Next.
Step 8 You have to configure the users that will access the published CTI OS application. Select the **Allow only configured users**, and then click **Add**.
Step 9  Add the user names that you want to allow access to the published CTI OS application. When done, click Next.
Integrating Cisco CTI OS in a Citrix XenApp environment

Publish CTI OS clients in Citrix XenApp 6.5

Step 10  Optionally, configure the appearance and location, and then click Next.
Step 11 Click **Finish** to publish the CTI OS application.

After the CTI OS application is published, it will be listed under Applications in the Citrix AppCenter.

**Citrix Web Client**

At each agent workstation, the user should access the XenApp web interface associated with the published CTI OS application.