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Configure Courtesy Callback
The following diagram shows the components that you must configure for Courtesy Callback.
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Figure 1: Courtesy Callback components

Complete the following procedures for Courtesy Callback configurations:

• Configure Gateway, on page 2

• Configure Unified CVP, on page 5

• Configure Unified CCE, on page 9

Configure Gateway

Configure the VXML Gateway for Courtesy Callback
Complete the following procedure to configure the VXML gateway for Courtesy Callback:

Procedure

Step 1 Copy cvp_ccb_vxml.tcl from the CVP Operations Console to the flash memory of the gateway, as follows:
a) Select Bulk Administration > File Transfer > Scripts and Media.
b) In Device Association, select Gateway for Device Type.
c) Select the required gateway from the Available list.
d) Click the right arrow icon to move the available gateway to the Selected list.
e) From the default gateway files, highlight cvp_ccb_vxml.tcl.
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f) Click Transfer.

Step 2 Log on to VXML gateway.
Step 3 Add the cvp_cc service to the configuration service cvp_cc flash:cvp_ccb_vxml.tcl.

This service does not require any parameters.

Step 4 Enter the following command to load the application:

call application voice load cvp_cc

Step 5 On the VoIP dial-peer that defines the VRU fromUnified CCE, verify that the codec can be used for recording.

Example:

The following example verifies that g711ulaw can be used for recording in Courtesy Callback:
dial-peer voice 123 voip
service bootstrap
incoming called-number 123T
dtmf-relay rte-nte
h245-signal
h245-alphanumeric
codec g711ulaw
no vad!

Step 6 Configure the following to ensure that SIP is setup to forward SIP INFO messaging:
voice service voip
signaling forward unconditional

Step 7 To play the beep to prompt the caller to record their name in the BillingQueue example script add the following
text to the configuration:

vxml version 2.0

Whenever you enable vxml version 2.0 on the gateway, vxml audioerror is off by default. When
an audio file cannot be played, error.badfetch will not generate an audio error event.

To generate an error in the gateway, enable vxmlaudioerror.

Note

Example:

The following example uses config terminal mode to add both commands:
config t
vxml version 2.0
vxml audioerror
exit

Configure the Ingress Gateway for Courtesy Callback
Complete the following procedure to configure the ingress gateway for courtesy callback:

Procedure

Step 1 Copy surviability.tcl from the Operations Console to the flash memory of the gateway, as follows:
a) Select Bulk Administration > File Transfer > Scripts and Media.
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b) In Device Association, select Gateway for Device Type.
c) Select the required gateway from the Available list.
d) Click the right arrow icon to move the available gateway to the Selected list.
e) From the default gateway files, highlight survivability.tcl.
f) Click Transfer.

Step 2 Log onto the ingress gateway.
Step 3 Add the following to the survivability service:

param ccb id:<host name or ip of this gateway>;loc:<location name>;trunks:<number of callback

trunks>

• id - A unique identifier for this gateway and is logged to the database to show which gateway processed
the original callback request.

• loc - An arbitrary location name specifying the location of this gateway.

• Trunks - The number of DS0's reserved for callbacks on this gateway. Limit the number of T1/E1 trunks
to enable the system to limit the resources allowed for callbacks.

Example:

The following example shows a basic configuration:
service cvp-survivability flash:survivability.tcl
param ccb id:10.86.132.177;loc:doclab;trunks:1!

Step 4 Create the incoming POTS dial peer, or verify that the survivability service is being used on your incoming
POTS dial peer.

Example:

For example,
dial-peer voice 978555 pots
service cvp-survivability
incoming called-number 9785551234
direct-inward-dial!

Step 5 Create outgoing POTS dial peers for the callbacks. These are the dial peers that place the actual call back out
to the PSTN.

Example:

For example,
dial-peer voice 978555 pots
destination-pattern 978555....
no digit-strip port 0/0/1:23!

Step 6 Use the following configuration to ensure that SIP is set up to forward SIP INFO messaging:

voice service voip signaling forward unconditional
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Configure CUBE-E for Courtesy Callback

If you are using CUBE-E then you need sip profile configuration and apply it on outgoing dial-peer through
cvp. See the below the example:

Note

A "sip-profile¨ configuration is needed on ISR CUBE E for the courtesy callback feature. To configure the
"sip-profile", the following must be added

voice class sip-profiles 103

request INVITE sip-header Call-Info add "X-Cisco-CCBProbe: <ccb param>"

where "<ccb param>" is the "ccb" parameter defined in the survivability service. Add this "sip-profile" to the
outgoing dial-peer to the CVP.

The following is a configuration example

voice class sip-profiles 103

request INVITE sip-header Call-Info add "X-Cisco-CCBProbe: id:10.10.10.180;sydlab;trunks:4"

dial-peer voice 5001 voip

description Comprehensive outbound route to CVP

destination-pattern 5001

session protocol sipv2

session target ipv4:10.10.10.10

dtmf-relay rtp-nte

voice-class sip profiles 103

codec g711ulaw

no vad

In the above example, 10.10.10.180 is the CUBE IP and 10.10.10.10 is the CVP Call Server IP.

If CUBE E is used for Courtesy Call Back then under voice service voip class in CUBE E must have media
flow-through for Courtesy Call Back to work.

Note

Configure Unified CVP

Configure the Reporting Server for Courtesy Callback
A reporting server is required for the Courtesy Callback feature. Complete the following procedure to configure
a reporting server for Courtesy Callback:

Before you begin

Install and configure the Reporting Server.
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Procedure

Step 1 In the Operations Console, select System > Courtesy Callback.

The Courtesy Callback Configuration page displays.

Step 2 Choose the General tab.
Step 3 Click the Unified CVP Reporting Server drop-down, and select the Reporting Server to use for storing

Courtesy Callback data.
Step 4 If required, select Enable secure communication with the Courtesy Callback database.
Step 5 Configure allowed and disabled dialed numbers.

These are the numbers that the system should and should not call when it is making a Courtesy Callback to
a caller.

Initially, there are no allowed dialed numbers for the Courtesy Callback feature. AllowUnmatched
Dialed Numbers is de-selected and, the Allowed Dialed Numbers window is empty.

Note

Step 6 Adjust the Maximum Number of Calls per Calling Number to the desired number.

By default, this is set to 0 and no limit is imposed. This setting allows you to limit the number of calls that
are eligible to receive a callback from the same calling number.

If this field is set to a positive number (X), then the Courtesy Callback Validate element only allows X callbacks
per calling number to go through the preemptive exit state at any time.

If there are already X callbacks offered for a calling number, new calls go through the none exit state of the
Validate element.

In addition, if no calling number is available for a call, the call always goes through the none exit state of the
Validate element.

Step 7 Choose the Call Server Deployment tab and move the Call Server you want to use for Courtesy Callbacks
from the Available box to the Selected box.

Step 8 Click Save.

The configuration becomes active (is deployed) the next time the Reporting Server is restarted.

Step 9 You can also deploy the new Reporting Server configuration immediately by clicking Save & Deploy.

After all the updates are configured, restart the Reporting Server to update the configuration.Note

Configure the Call Studio Scripts for Courtesy Callback
The Courtesy Callback feature is controlled by a combination of Call Studio scripts and ICM scripts. Complete
the following procedure to configure the Call Studio scripts:

Procedure

Step 1 Access the .zip file from the CVP OAMP machine from the location
C:\Cisco\CVP\OPSConsoleServer\StudioDownloads\CourtesyCallbackStudioScripts.zip.
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Step 2 Extract the example Call Studio Courtesy Callback scripts contained in CourtesyCallbackStudioScripts.zip
to a folder of your choice on the computer running CallStudio.

Each folder contains a Call Studio project having the same name as the folder. The five individual project
comprise the Courtesy Callback feature.

Do not modify the scripts CallbackEngine and CallbackQueue.Note

Step 3 Modify the scripts BillingQueue, CallbackEntry, and CallbackWait to suit your business needs.
Step 4 Start Call Studio by selecting Start > All Programs > Cisco > Cisco Unified Call Studio.
Step 5 Select File > Import.

The Import dialog box displays.

Step 6 Expand the Call Studio folder and select Existing Call Studio Project Into Workspace.
Step 7 Click Next .

The Import Call Studio Project From File System displays.

Step 8 Browse to the location where you extracted the call studio projects. For each of the folders that were unzipped,
select the folder (for example BillingQueue) and select Finish.

The project is imported into Call Studio.

Step 9 Repeat the action in previous step for each of the five folders.

The five projects display in the upper-left of the Navigator window.

Step 10 Update the Default Audio Path URI field in Call Studio to contain the IP address and port value for your
media server.

Step 11 For each of the Call Studio projects previously unzipped, complete the following steps:
a) Select the project in the Navigator window of Call Studio.
b) Choose Project > Properties > Call Studio > Audio Settings.
c) On the Audio Settings window, modify the Default Audio Path URI field to http://<media-server

>/en-us/VL/.
d) Click Apply then click OK.

Step 12 Under BillingQueue Project, if required, change the music played to the caller while on hold.
a) Expand the tree structure of the project and click app.callflow.
b) Click the node Audio_01.
c) Navigate to Element Configuration > Audio > Audio Groups expand the tree structure and click audio

item 1, Use Default Audio Path to change the .wav file to be played.

Step 13 Under CallbackEntry Project, if required, modify the caller interaction settings in the SetQueueDefault_01
node.
a) In the Call Studio Navigator panel, open the CallBackEntry project and double-click app.callflow to

display the application elements in the script window.
b) Open the Start of Call page of the script using the tab at the bottom of the script display window.
c) Select the SetQueueDefault_01 node.
d) In the Element Configuration panel, choose the Setting tab and modify the default settings as required.

Step 14 In the CallbackEntry project, on the Wants Callback page, configure the following:
a) Highlight the Record Name node and choose the Settings tab.
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b) In the Path setting, change the path to the location where you want to store the recorded names of the
callers.

c) Highlight the Add Callback to DB 1node.
d) Change the Recorded name file setting to match the location of the recording folder that you created in

the previous step.
e) Ensure the keepalive Interval(in seconds) is greater than the length of the queue music being played. In

the Start of Call page.

The default is 120 seconds for the SetQueueDefaults_01 node.

f) Save the CallbackEntry project.
g) In the CallbackWait Project, modify values in the CallbackWait application.

In this application, you can change the IVR interaction that the caller receives at the time of the actual
callback. The caller interaction elements in CallbackWait > AskIfCallerReady page may be modified.
Save the project after you modify it.

h) Validate each of the five projects associated with the Courtesy Callback feature and deploy them to your
VXML Server.

Step 15 Right-click each Courtesy Callback project in the Navigator window and select Validate.
Step 16 Right-click on one of the project and click Deploy.
Step 17 Check the check box against each project to select the required projects.
Step 18 In the Deploy Destination area, select Archive File and click Browse.
Step 19 Navigate to the archive folder that you have set up.

Example:

C:\Users\Administrator\Desktop\Sample.
Step 20 Enter the name of the file.

Example:

For example Samplefile.zip.
Step 21 Click Save.
Step 22 In the Deploy Destination area click Finish.
Step 23 Log in to OAMP and choose Bulk Administration\File Transfer\VXMLApplications.
Step 24 Select the VXML Server to which you want to deploy the applications.
Step 25 Select the zip file that contains the applications.

Example:

Samplefile.zip.
Step 26 Click Transfer.
Step 27 Right-click each of the projects and click Deploy, then click Finish.
Step 28 Using windows explorer, navigate to %CVP_HOME%\VXMLServer\applications.
Step 29 For each of the five Courtesy Callback applications, open the project's admin folder,

in%CVP_Home%\VXMLServer\applications, and double-click deployApp.bat to deploy the application to
the VXML Server.
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Step 30 Verify that all the applications are running by going into %CVP_HOME%\VXMLServer\admin and
double-clicking status.bat. All five applications should display under Application Name and with the status
Running.

Configure the Media Server for Courtesy Callback
Several Courtesy Callback specific media files are included with the sample scripts for Courtesy Callback.
Complete the procedure to configure the Media Server for Courtesy Callback:

Procedure

Step 1 During the Unified CVP installation, the media files are copied as:
%CVP_HOME%\OPSConsoleServer\CCBDownloads\CCBAudioFiles.zip.

Step 2 Unzip the special audio files and copy to yourmedia serverVXMLServer\Tomcat\webapps\CVP\audio.

The sample scripts are set up to use the default location "\CVP\audio" for the audio files.

Step 3 Change the default location of the audio files in the sample scripts to be your media server path.

Configure Unified CCE

Configure the ICM Script for Courtesy Callback
Following figure shows the sample Courtesy Callback ICM script.
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Figure 2: Sample Courtesy Callback ICM script

Complete the following procedure to configure ICM to use the sample Courtesy Callback ICM script:

Procedure

Step 1 Copy the CCE example script, CourtesyCallback.ICMS to the CCE Admin Workstation.
The example CCE script is available in the following locations:

• On the CVP install media in \CVP\Downloads and Samples\.
• From the Operations Console in %CVP_HOME%\OPSConsoleServer\ICMDownloads.
• In the Import Script - Manual Object Mapping window, map the route and skill group to the route and
skill group available for courtesy callback.

For Small Contact Center Deployment Model, copy the CourtesyCallback.ICMS Routing
Script on the desktop where Internet Script editor is installed.

Note

Step 2 In Script Editor, select File > Import Script...

For Small Contact Center Deployment Model follow the below steps.Note

a. Log In to ISE by sub customer user and Click on File>Import Script.
b. Select the Routing script which is copied in the desktop CourtesyCallback.ICMS.
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Step 3 In the script location dialog, select the CourtesyCallback.ICMS script and click Open. You can bypass the
set variable "Set media server" Highlighted as number 1 node in the Figure 2: Sample Courtesy Callback
ICM script, on page 10, as VXML Server, Call Server, and Media Server are collocated.

Step 4 Define a new ECC variable for courtesy callback.

A new ECC variable is used to determine if a caller is in a queue and can be offered a callback.

Step 5 Navigate to ICM Admin Workstation > ICM Configuration Manager > Expanded Call Variable List
tool to create the ECC Variable user.CourtesyCallbackEnabled specific to Courtesy Callback.

Step 6 Set up the following parameters that are passed to CallbackEntry (VXML application):

Example:

• ToExtVXML[0] =concatenate("application=CallbackEntry",";ewt=",Call.user.microapp.ToExtVXML[0])

• ToExtVXML[1] = "qname=billing";

• ToExtVXML[2] = "queueapp=BillingQueue;"

• ToExtVXML[3] = concatenate("ani=",Call.CallingLineID,";");

CallbackEntry is the name of the VXML Server application that is run:

ewt is calculated in Block #2.

qname is the name of the VXML Server queue into which the call will be placed. There must be a unique
qname for each unique resource pool queue.

queueapp is the name of the VXML Server queuing application that is run for this queue.

ani is the caller's calling Line Identifier.

Step 7 Create Network VRU Scripts.
Step 8 Navigate to ICM Configuration Manager > Network VRU Script List tool, create the following Interruptible

Script Network VRU Scripts.

Name: VXML_Server_Interruptible

Network VRU: Select your Type 10 CVP VRU

VRU Script Name: GS,Server,V,interrupt

Timeout: 9000 seconds

Interruptible: Checked

Step 9 Choose ICM Configuration Manager > Network VRU Script List tool to create the following
Non-Interruptible Script Network VRU Scripts.

Name - VXML_Server_NonInterruptible

Network VRU - Select your Type 10 CVP VRU

VRU Script Name - GS,Server,V, nointerrupt

Timeout - 9000 seconds ( must be greater than the maximum possible call life in Unified CVP)

Interruptible: Not Checked
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Step 10 Verify that the user.microapp.ToExtVXMLECC variable is set up for an array of five items with a minimum
size of 60 characters and the user.microapp.FromExtVXML variable is set up for an array of four with a
minimum size of 60 characters.

Note

Verify that you have at least one available route and skill group to map to the route and skillgroup in the
example script.

Step 11 Save the script, then associate the call type and schedule the script.

For Small Contact Center Deployment Model ensure the resources used in this Routing Script,
like Network VRU Scripts , ECC variables etc are specific to the sub customer.

Note

Configure Agent Greeting
To use Agent Greeting, your phone must meet the following requirements:

• The phones must have the BiB feature.

• The phones must use the firmware version delivered with Unified CM 8.5(1) or greater.

(In most cases phone firmware is upgraded automatically when you upgrade Unified CM installation.)

Complete the following procedures for Agent Greeting configuration:

• Configure Gateway, on page 12

• Configure Unified CVP, on page 13

• Configure Unified CCE, on page 17

• Configure Unified Communications Manager, on page 22

Configure Gateway

Republish the tcl scripts to VXML Gateway
The .tcl script files that ship with Unified CVP include updates to support Agent Greeting. You must republish
these updated files to your VXML Gateway.

Republishing scripts to the VXML Gateways is a standard task in CVP upgrades. You must republish the
scripts before you can use Agent Greeting.

Procedure

Step 1 In the Unified CVP Operation Console, select Bulk Administration > File Transfer > Scripts and Media.
Step 2 Set Device to Gateway.
Step 3 Select the gateways you want to update. Typically you would select all of them unless you have a specific

reason not to.
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Step 4 Select Default Gateway Files.
Step 5 Click Transfer.

Set Cache Size on VXML Gateway
To ensure adequate performance, set the size of the cache on the VXML Gateway to the maximum allowed.
The maximum size is 100 megabytes; the default is 15 kilobytes. Failure to set the VXML Gateway cache to
its maximum can result in slowed performance to increased traffic to the media server.

Use the following Cisco IOS commands on the VXML Gateway to reset the cache size:
conf t
http client cache memory pool 100000
exit
wr

For more information about configuring the cache size, see theConfiguration Guide for Cisco Unified Customer
Voice Portal at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-customer-voice-portal/
tsd-products-support-series-home.html.

Configure Unified CVP
Complete the following procedures for Unified CVP configuration:

• Configure FTP Enabled in Server Manager, on page 13

• Configure Unified CVP Media Server

• Configure the Call Studio Scripts for Record Agent Greeting, on page 15

Configure FTP Enabled in Server Manager
Complete the following procedure to configure the FTP enabled in server manager.

Procedure

Step 1 Right- Click Roles in the left navigation page of server manager.
Step 2 Select Add Roles.
Step 3 Click Next.
Step 4 Check the checkbox Web Server (IIS) and click Next.
Step 5 Check the checkbox FTP Server and click Next.
Step 6 After the successful installation, click Close.
Step 7 Make sure that the FTP and the IIS share the same root directory, because the recording application writes

the file to the media server directory structure, and the greeting playback call uses IIS to fetch the file. The
en-us/app directory should be under the same root directory for FTP and IIS.

Step 8 Create a dedicated directory on the server to store your greeting files.

This lets you specify a lower cache timeout of 5 minutes for your agent greeting files that does not affect other
more static files you may be serving from other directories. By default, the Record Greeting application posts
the .wav file to the en-us/app directory under your web/ftp root directory. You may create a dedicated directory
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such as ag_gr under the en-us/app directory, and then indicate this in the Unified CCE script that invokes the
recording application. Use the array for the ECC variable call.user.microapp.ToExtVXML to send the
ftpPath parameter to the recording application. Make sure the ECC variable length is long enough, or it may
get truncated and fail.

Step 9 In IISManager, set the cache expiration for the dedicated directory to a value that allows re-recorded greetings
to replace their predecessor in a reasonable amount of time, while minimizing requests for data to the media
server from the VXML Gateway.

The ideal value varies depending on the number of agents you support and how often they re-record their
greetings. Two minutes may be a reasonable starting point.

Step 10 Find the site you are using, go to the agent greeting folder you created (ag_gr), and then selectHTTP Response
Headers .

Step 11 Select Add, then Set Common Headers .

Create Voice Prompts for Recording Greetings

You must create audio files for each of the voice prompts that agents hear as they record a greeting. The
number of prompts you require can vary, but a typical set can consist of:

• Awelcome followed by a prompt to select which greeting to work with (this assumes you support multiple
greetings per agent)

• A prompt to select whether they want to hear the current version, record a new one, or return to the main
menu

• A prompt to play if a current greeting is not found.

To create voice prompts for recording greetings:

Procedure

Step 1 Create the files using the recording tool of your choice. When you record your files:

• The media files must be in .wav format. Your .wav files must match Unified CVP encoding and format
requirements (G.711, CCITT A-Law 8 kHz, 8 bit, mono).

• Test your audio files. Ensure that they are not clipped and that they are consistent in volume and tone.

Step 2 After recording, deploy the files to your Unified CVP media server. The default deployment location is to the
<web_server_root>\en-us\app directory.

Step 3 Note the names of the files and the location where you deployed them on the media server. Your script authors
need this information for the Agent Greeting scripts.

Built-In Recording Prompts

The Unified CVPGet Speech micro-application used to record Agent Greetings includes the following built-in
prompts:

• A prompt that agents can use to play back what they recorded
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• A prompt to save the greeting, record it again, or return to the main menu

• A prompt that confirms the save, with an option to end the call or return to the main menu

You can replace these .wav files with files of your own. For more information, see the Unified Customer
Voice Portal Call Studio documentation at https://www.cisco.com/c/en/us/support/unified-communications/
unified-call-studio/tsd-products-support-series-home.html.

Configure Unified CVP Media Server

Procedure

Step 1 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 2 Click Add New.
Step 3 On the General tab, configure the following.

a) Enter the IP address and the hostname of the Unified CVP server.
b) Check FTP Enabled.
c) Either Check Anonymous Access or enter the credentials.
d) Click Test SignIn to validate the FTP access.

Step 4 Click Save.
Step 5 Repeat Step 1 through 4 for all Media Servers.
Step 6 After you configure all Media Servers, click Deploy.
Step 7 Click Deployment Status to make sure that you applied the configuration.
Step 8 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 9 Change Default Media Server from None to any one of the Unified CVP servers. Then click Set.
Step 10 Click Deploy.

Configure the Call Studio Scripts for Record Agent Greeting
The Record Agent Greeting is controlled by a combination of Call Studio script and ICM script. Complete
the following procedure to configure the Call Studio script:

Procedure

Step 1 Access the .zip file from the CVP OAMP machine from the location
C:\Cisco\CVP\OPSConsoleServer\StudioDownloads\RecordAgentGreeting.zip.

Step 2 Extract the example Call Studio Record Agent Greeting scripts contained in RecordAgentGreeting.zip to a
folder of your choice on the computer running CallStudio. The folder contains a CallStudio project having
the same name as the folder.

Step 3 Start Call Studio by selecting Start > Programs > Cisco > Cisco Unified Call Studio.
Step 4 Select File > Import.

The Import dialog box displays.
Step 5 Expand the Call Studio folder and select Existing Call Studio project Into Workspace.
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Step 6 Click Next.
The Import Call Studio Project From File System displays.

Step 7 Browse to the location where you extracted the call studio projects. Select the folder and select Finish.

Example:

RecordAgentGreeting
Step 8 Follow the below steps, to save the file in a defined path:

a) In theCall Studio Navigator panel, open theRecordAgentGreeting project and double click app.callflow
to display the application elements in the script window.

b) Select the Record Greeting With Confirm node.
c) In the Element Configuration panel, choose the Setting tab and modify the default path settings to

c:\inetpub\wwwroot\en-us\app\ag_gr. Save the project after you modify it.
d) Validate the project associated with the Record Agent Greeting and deploy them to your VXML Server.

Step 9 Right-click on Record Agent Greeting project in the Navigator window and select Validate.
Step 10 Right-click on the Record Agent Greeting project and click Deploy.
Step 11 In the Deploy Destination area, select Archive File and click Browse.
Step 12 Navigate to the archive folder that you have set up:

Example:

C:\Users\Administrator\Desktop\Sample.
Step 13 Enter the name of the file.

Example:

Samplefile.zip
Step 14 Click Save.
Step 15 In the Deploy Destinationarea click Finish.
Step 16 Log in to OAMP and choose Bulk Administration\File Transfer\VXMLApplications.
Step 17 Select the VXML Server to which you want to deploy the applications.
Step 18 Select the zip file that contains the applications.

Example:

Samplefile.zip
Step 19 Click Transfer.
Step 20 Right-click on the project and click Deploy, then click Finish.
Step 21 Using windows explorer, navigate to

%CVP_HOME%\VXMLServer\applications\RecordAgentGreeting, open the project's admin
folder and double-click deployApp.bat to deploy the application to the VXML Server.

Step 22 Verify that the application is running in the following path
%CVP_HOME%\VXMLServer\applications\RecordAgentGreeting\admin and double-click
status.bat. The application should display under Application Name and with the status Running.

Set Content Expiration in IIS (Windows Server) in Media
Complete the following procedure to set content expiration in IIS on a Windows Server:
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Procedure

Step 1 Right-click My Computer on the desktop and select Manage.
Step 2 Select Server Manager > Roles > Web Server (IIS) > Internet Information Services (IIS) Manager.
Step 3 Select the default website and navigate to Features View.
Step 4 Double-click HTTP Response Headers.
Step 5 Under Actions, select Set Common Headers….
Step 6 On Set Common HTTP Response Headers, select Enable HTTP keep-alive and Expire Web content and

set After 5 minutes.

Configure Unified CCE
Complete the following procedures forUnified CCE configuration:

• Create Agent Greeting Play Script, on page 17

• Create Agent Greeting Recording Script, on page 18

• Import the Example Agent Greeting Scripts, on page 19

Create Agent Greeting Play Script
A dedicated routing script plays the Agent Greeting. This script is invoked by the PlayAgent Greeting dialed
number on the specific routing client. You must create the dialed number and associate it with a call type that
runs the script.

Figure 3: Agent Greeting Play Script
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Create Agent Greeting Recording Script
The Agent Greeting Recording script lets agents record a greeting. The agent desktop calls the script when
an agent clicks the Record Agent Greeting button, prompting the agent to select which greeting to play or
record. Create the dialed number RecordAgentGreeting for the specific routing client and associate it with a
call type that then runs this script.

Figure 4: Agent Greeting recording script

Unified CCE Configuration for Record Agent Greeting

• user.microapp.ToExtVXML : This is used twice in an Agent Greeting record script, the first time is to
queue the Unified CVP Record Agent Greeting application and the second time is to tell the recording
application where to save greeting files. Configure it as an array with size 3. Use the Unified CCE
Administration tool to ensure this variable includes Maximum Length as 100 and Enabled.

• user.microapp.app_media_lib :This is required in Agent Greeting record and play scripts to specify
the dedicated directory on the media server where your greeting audio files are stored. Maximum Length
is 100 and Enabled.

• user.microapp.input_type: This is required in Agent Greeting record scripts to limit the allowable
input type to DTMF. Maximum Length is 100 and Enabled.

For more information on how to enable the ECC variables, see the Cisco Hosted Collaboration Solution for
Contact Center Configuration Guide at
https://www.cisco.com/c/en/us/support/unified-communications/hosted-collaboration-solution-contact-center/products-installation-and-configuration-guides-list.html.

Note
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Import the Example Agent Greeting Scripts
To view or use the example Agent Greeting scripts, you must first import them into theUnified CCE Script
Editor. Complete the following procedure to import the example Agent Greeting scripts:

Procedure

Step 1 Launch Script Editor.
Step 2 Select File>Import Script and select the following scripts to import:

a) Agent Greeting Play Script
b) Agent Greeting Recording Script

The scripts will be located in the icm\bin directory on the data server (DS) node.

Step 3 Repeat for the remaining scripts.

For Small Contact Center DeploymentModel, Default Routing Scripts are available in the partners
Community. Download the Routing Scripts to the Desktop where ISE is Installed and Login as
the Sub Customer User into the ISE to perform the Step 2 and 3. Download the Routing
Script files for all Deployment models https://software.cisco.com/download/
navigator.html?mdfid=284526699.

Note

For Small Contact Center Deployment Model ensure the resources used in this Routing script,
like Network VRU Scripts , ECC variables etc are specific to the sub customer.

Note

Configure Call Types

Procedure

Step 1 Sign-in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Select the folder where you want to create the call type.
Step 4 Click Resource, then click Call Types.
Step 5 Create a call type to record agent greetings and enter RecordAgentGreeting as the name.
Step 6 Create a call type to play agent greetings and enter PlayAgentGreeting as the name.

Configure Dialed Numbers

Procedure

Step 1 Sign-in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Select the folder where you want to create the dialed number.
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Step 4 Click Resource, then click Dialed Number.
Step 5 Create a dialed number to record agent greetings and enter RecordAgentGreeting as the name.
Step 6 Create a dialed number to play agent greetings and enter PlayAgentGreeting as the name.
Step 7 Complete the following for each dialed number:

a) Select Internal Voice for the Routing type.
b) Retain the default domain value.
c) Select the call type appropriate to the dialed number.

This helps to associate each number to its call type and to a script that runs it.

Schedule the Script

Procedure

Step 1 In the Script Editor, select Script > Call Type Manager.
Step 2 From the Call Type Manager screen, select the Schedules tab.
Step 3 From the Call type drop-down list, select the call type to associate with the script; for example,

PlayAgentGreeting.
Step 4 Click Add and select the script you want from the Scripts box.
Step 5 Click OK twice to exit.

Configure Agent Greeting
This section describes how to deploy and configure the Agent Greeting feature.

Agent Greeting Deployment Tasks

Procedure

Step 1 Ensure your system meets the baseline requirements for software, hardware, and configuration described in
the System Requirements and Limitations section.

Step 2 Configure IIS and FTP on Media Server.
Step 3 In Unified CVP, add media servers, configure FTP connection information, and deploy the media servers.
Step 4 Configure a Unified CVP media server, if you have not already done so. See Configure Unified CVP Media

Server.
Step 5 In Unified CVP Operations Console, republish the VXML Gateway.tcl scripts with updated Agent Greeting

support. See Republish the tcl scripts to VXML Gateway, on page 12 for Agent Greeting support.
Step 6 Set the cache size on the VXML Gateway. See Set Cache Size on VXML Gateway, on page 13.
Step 7 Record the voice prompts to play to agents when they record a greeting and to deploy the audio files to your

media server, see Create Voice Prompts for Recording Greetings, on page 14.
Step 8 Configure Call Types, on page 19 to record and play agent greetings.
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Step 9 Configure Dialed Numbers, on page 19 to record and play agent greetings.
Step 10 Schedule the Script, on page 20
Step 11 In Script Editor:

• To use the installed scripts to record and play agent greetings, see Import the Example Agent Greeting
Scripts, on page 19.

Step 12 Modify the Unified CCE call routing scripts to use Play Agent Greeting script, on page 21.

Modify the Unified CCE call routing scripts to use Play Agent Greeting script
For an Agent Greeting play script to run, you must add an AgentGreetingType Set Variable node to your
existing Unified CCE call routing scripts: This variable's value is used to select the audio file to play for the
greeting. Set the variable before the script node that queues the call to an agent (that is, the Queue [to Skill
Group or Precision Queue], Queue Agent, Route Select, or Select node).

Specify AgentGreetingType Call Variable

To include Agent Greeting in a script, insert a Set Variable node that references the AgentGreetingType call
variable. The AgentGreetingType variable causes a greeting to play and specifies the audio file it should use.
The variable value corresponds to the name of the greeting type for the skill group or Precision Queue. For
example, if there is a skill group or Precision Queue for Sales agents and if the greeting type for Sales is '5',
then the variable value should be 5.

You can use a single greeting prompt throughout a single call type. As a result, use one AgentGreetingType
set node per script. However, as needed, you can set the variable at multiple places in your scripts to allow
different greetings to play for different endpoints. For example, if you do skills-based routing, you can specify
the variable at each decision point used to select a particular skill group or Precision Queue.

Only one greeting can play per call. If a script references and sets the AgentGreetingType variable more than
once in any single path through a script, the last value to be set is the one that plays.

Note

Use these settings in the Set Variable node for Agent Greeting:

• Object Type: Call.

• Variable: Must use the AgentGreetingType variable.

• Type: Must use the PersonID_AgentGreetingType type.

• Value: Specify the value that corresponds to the greeting type you want to play. For example: “2” or
“French”

• You must enclose the value in quotes.

• The value is not case-sensitive.

• The value cannot include spaces or characters that require URL encoding.
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Configure Unified Communications Manager

Built-in-Bridge
Built-in-Bridge (BIB) is not enabled by default for the phones. It is disabled at the system level as it is not
used by all the customer by default. It is used only by the customers having Contact Center.

The provider has to perform the following procedures to enable BIB for the customers having contact center.

Create a new Field Display Policies at the customer level and add Built-in Bridge to the list.Note

• Configure the Built-in-Bridge

• Enable or Disable the Built-in-Bridge

Configure the Built-in-Bridge

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider.
Step 2 Navigate Role Management > Field Display Policies.
Step 3 Ensure that hierarchy is set to the appropriate customer.
Step 4 Select the SubscriberPhoneMenuItemProvider.
Step 5 In the details page, go to Action menu and click Clone.
Step 6 Enter SubscriberPhoneMenuItemProvider as the name.
Step 7 Select relation/SubscriberPhone from the Target Model Type drop-down list.
Step 8 Expand Groups section and enter Phone for Title.
Step 9 Select builtInBridgeStatus from the Available list and click Select.
Step 10 Click Save.

Enable or Disable the Built-in-Bridge

Before you begin

Ensure that you configure Built-in-Bridge. See, Configure the Built-in-Bridge.

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as a provider.
Step 2 Ensure that hierarchy is set to the appropriate customer.
Step 3 Navigate Subscriber Management > Phones and select the appropriate phone.
Step 4 In the Phone tab:
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• To enable BIB choose On from the Built in Bridge drop-down list.

• To disable BIB choose Off from the Built in Bridge drop-down list.

Step 5 Click Save.

Configure Whisper Announcement
Complete the following procedures for Whisper Announcement configuration:

• Configure Gateway, on page 23

• Configure Unified CVP, on page 23

• Configure Unified CCE, on page 24

Configure Gateway
Gateway uses two different dialed numbers for Whisper Announcement.

• 91919191 number calls the ring tone that the caller hears while the whisper plays to the agent

• 9191919100 number calls the whisper itself

Configure a dial peer for incoming number 9191919100 and 91919191 as follows:

dial-peer voice 919191 voip
description CVP SIP ringtone dial-peer
service ringtone
incoming called-number 9191T
voice-class sip rel1xx disable
dtmf-relay rtp-nte
codec g711ulaw
no vad

Configure Unified CVP

Configure the Whisper Announcement Service Dialed Numbers
Unified CVP uses two different dialed numbers for Whisper Announcement:

The first number calls the ring tone service that the caller hears while the whisper plays to the agent. The
Unified CVP default for this number is 91919191.

The second number calls the whisper itself. The Unified CVP default for this number is 9191919100.

For Whisper Announcement to work, your dial number pattern must cover both of these numbers. The easiest
way to ensure coverage is through the use of wild cards such as 9191*. However, if you decide to use an exact
dialed number match, then you must specify both 91919191 and 9191919100.
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Configure Unified CCE

Create Whisper Announcement Script
It is very important to deploy Whisper Announcement with the Call. Whisper Announcement variable and to
set .wav file in your Unified CCE routing scripts.

Figure 5: Whisper Announcement Script

Configure Database Integration
Complete the following procedures for Database Integration configuration:

• Configure Unified CVP, on page 24

• Configure Unified CCE, on page 27

Small Contact Center deployment model supports only CVP Database Integration.Note

Configure Unified CVP

Configure VXML Database Element
You need to configure Java Database Connectivity (JDBC) for VXML Database Element configuration.

Complete the following procedures for JDBC configuration:

• Install JDBC driver, on page 25

• Add JNDI Context, on page 25
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• Configure VXML Studio Script, on page 26

• Create ICM Script, on page 26

Install JDBC driver

Complete the following procedure to install the JDBC driver:

Procedure

Step 1 Download the .exe file for Microsoft JDBC Driver for SQL Server

Example:

1033\sqljdbc_3.0.1301.101_enu.exe

Step 2 Run the executable and install the .exe file in the location C:\temp\
Step 3 Copy the fileC:\temp\sqljdbc_3.0\enu\sqljdbc4.jar to the Unified CVPVXML servers' folder

C:\Cisco\CVP\VXMLServer\Tomcat\common\lib

Add JNDI Context

Complete the following procedure to add the JavaNaming andDirectory Interface (JNDI) context configuration:

Procedure

Step 1 Go to the context.xml file located at C:\Cisco\CVP\VXMLServer\Tomcat\conf\context.xml file.
Step 2 Enter the JNDI name, SQL server address, SQL database name, username and password.

The following is an example of the SQL authentication context.xml file:

<Context>

<WatchedResource>WEB-INF/web.xml</WatchedResource>

<Manager pathname="" />

<Resource name="jdbc/dblookup"

auth="Container"

type="javax.sql.DataSource"

DriverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver"

url="jdbc:sqlserver://<dblookupnode_ipaddress>:1433;databaseName=DBLookup;user=sa;password=sa"

>

</Context>

Step 3 Perform following steps to restart VXML server services:
a) Goto Run window and enter services.msc command.
b) Select Cisco CVP VXML Server option.
c) Right-click and select Restart option.
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For small contact center agent deployment model , Resource name should be unique for each
sub-customers. For example, Sub-cust1 Resource name = "jdbc/dblookup1" and Sub-cust2
Resource name = "jdbc/dblookup2".

Note

Configure VXML Studio Script

Complete the following procedure to configure the VXML studio script:

Procedure

Step 1 Configure the following to create the VXML application with the database element.
a) Select single under Type.
b) Enter the database lookup name in JNDI Name.
c) Query SQL:

For example, select AccountNo from AccountInfo where CustomerNo = {CallData.ANI}

Where AccountNo - Value to be retrieved

AccountInfo - Table name

CustomerNo - condition to be queried

Data:

Create a database element with the following values:

Name - AccountNo

Value - {Data.Element.Database_01.AccountNo}

Step 2 Deploy the script to the local computer or to the remote computer (VXML call server directly) to create CVP
Subdialog return element.

Step 3 If you saved this to the local machine, copy the whole folder to the following location:

<Install dir>:\Cisco\CVP\VXMLServer\applications and deploy it using deployAppwindows batch file located
inside the admin folder of applications.

Create ICM Script

Create an ICM script similar to the one shown in the following figure:
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Figure 6: Sample Script with ICM database Lookup

Configure Unified CCE

Configure ICM Database Lookup
Complete the following procedure to configure ICM Database Lookup.

Procedure

Step 1 Select Enable Database Routing in Router options to edit Router setup for database lookup changes.
Step 2 Configure Database Lookup explorer:

a) Click Start > All programs > Cisco Unified CCE Tools > Administration Tools > Configuration
Manager.

b) Open Tools > Explorer Tools > Database Lookup Explorer.
c) Configure Script Table and Script Table Column as shown in the following example:

Script Table:
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Name: AccountInfo

Side A: \\dblookup1\DBLookup.AccountInfo

Side B: <Update Side B of database here>

Description: <Provide description here>

dblookup1 is external database server name, DBLookup is external database name, and AccountInfo is
the table name.

Script Table Column:

Column name: AccountNo

Description: <Provide description here>

Step 3 Configure the following to change the registry settings in Unified CCE:
a) Navigate to HKEY_LOCAL_MACHINE > SOFTWARE > Cisco Systems, Inc. > ICM > <Instance

Name> > RouterA > Router > CurrentVersion > Configuration > Database registry.

Instance Name is the name of the Instance that is configured.

b) Set the SQLLogin registry key as shown in the following example:

Example:

\\dblookup1\DBLookup=(sa,sa)

Where DBLookup is the external database name and (sa,sa) are the SQL server authentication.

Step 4 Create the ICM script with the database lookup node with the respective table and lookup value.

The following figure shows AccountInfo as the table name and Call.CallingLineID as the lookup value.
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Figure 7: Example ICM Database Look Up

Configure Unified Mobile Agent
• Configure Gateway for SCC Deployment with VRF, on page 30

• Configure Unified CCE, on page 30

• Configure Unified Communications Manager, on page 31
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Configure Gateway for SCC Deployment with VRF

Configure Dial Peer for Sub-Customer1 CUCM

dial-peer voice 21011 voip
description from CVP towards VRF1 to Sub-Customer1 for mobileagent
destination-pattern 100.
session protocol sipv2
session target ipv4:20.20.20.31
session transport udp
voice-class codec 1
voice-class sip rel1xx disable
voice-class sip bind control source-interface GigabitEthernet2.100
voice-class sip bind media source-interface GigabitEthernet2.100
dtmf-relay rtp-nte h245-signal h245-alphanumeric

Configure Dial Peer for Sub-Customer2 CUCM

dial-peer voice 22011 voip
description from CVP towards VRF2 to Sub-Customer2 for mobileagent
destination-pattern 300.
session protocol sipv2
session target ipv4:20.20.20.31
session transport udp
voice-class codec 1
voice-class sip rel1xx disable
voice-class sip bind control source-interface GigabitEthernet2.200
voice-class sip bind media source-interface GigabitEthernet2.200
dtmf-relay rtp-nte h245-signal h245-alphanumeric

Configure Unified CCE
Complete the following procedure to configure Mobile Agent in Unified CCE:

Procedure

Step 1 Sign-in to Unified CCDM Portal as Tenant or Sub Customer user.
Step 2 Click the burger icon and select Provisioning > Resource Manager

Step 3 Select the folder where you want to create the agent desktop.
Step 4 Click Resource, then click Agent Desktop.
Step 5 Enter unique name of up to 32 characters for the record.

This name can use alphanumeric characters, periods, and underscores.

Step 6 Enter the mandatory fields such as Incoming Work mode,Outgoing Work mode,Wrap-up time, and other
required fields.

Step 7 Click Save.
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Enable Mobile Agent Option in CTI OS Server
Complete the following procedure to enable Mobile Agent option in CTI OS server:

Procedure

Step 1 Invoke the CTI OS Server setup.
Step 2 In Peripheral Identifier window, check Enable Mobile Agent check box, and select Mobile Agent Mode

from the drop-down list.
Step 3 Repeat the above steps on both sides of CTI OS server.

Configure Unified Communications Manager
Perform the following to configure unified communications manager:

• Configure CTI Port, on page 31

• Tag CTI Ports as Contact Center Agent Lines, on page 33

Configure CTI Port
Ensure that directory numbers are added. See Add Directory Number Inventory.

Unified Mobile Agent needs two configured CTI Port pools on Unified Communications Domain Manager:

• A local CTI port as the agent's virtual extension

• A network CTI port to initiate a call to the Mobile Agent's phone

For 12000 agent deployment model, add CTI ports for all three Unified CM clusters.Note

Complete the following procedure to configure CTI port:

• Configure CTI Port as Provider or Reseller, on page 31

• Configure CTI Port as Customer, on page 32

Configure CTI Port as Provider or Reseller

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider or reseller.
Step 2 Ensure that hierarchy is set to appropriate site
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click Add.
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Step 5 In Phones tab:
a) Enter Local CTI Port pool name in Device Name field, in LCPxxxxFyyyy format.

• LCP - identifies the CTI port as a local device

• xxxx - is the peripheral ID of the Unified Communication Manager PIM

• yyyy - is the local CTI Port

b) Choose CTI Port from Product Type drop-down list.
c) Choose Calling Search Space from the drop-down list.
d) Choose Device Pool from the drop-down list.
e) Choose Location from the drop-down list.

Step 6 Goto Lines tab:
a) Click Add icon in Lines panel.
b) Choose directory number from Pattern drop-down list, in Drin Panel.
c) Choose Route Partition Name from drop-down list.

Step 7 Click Save.

What to do next

Repeat the above steps to create Network CTI port. Enter Network CTI Port pool name inDevice Name field,
in RCPxxxxFyyyy format.

• RCP - identifies the CTI port as a network device

• xxxx - is the peripheral ID of the Unified Communication Manager PIM

• yyyy - is the network CTI Port

Local CTI port and Network CTI port should be sameNote

Configure CTI Port as Customer

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as Customer admin.
Step 2 Ensure that hierarchy is set to appropriate site
Step 3 Navigate to Subscriber Management > Phones.
Step 4 Click Add.
Step 5 In Basic Information tab:

a) Choose CTI Port from Product Type drop-down list.
b) Enter Local CTI Port pool name in Device Name field, in LCPxxxxFyyyy format.

• LCP - identifies the CTI port as a local device
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• xxxx - is peripheral ID of the Unified Communication Manager PIM

• yyyy - is the local CTI Port

c) Choose Calling Search Space from the drop-down list.

Step 6 Goto Advanced Infromation tab:
a) Choose Device Pool from the drop-down list.
b) Choose Location from the drop-down list.

Step 7 Goto Lines tab:
a) Click Add icon in Lines panel.
b) Choose directory number from Pattern drop-down list, in Drin Panel.
c) Choose Route Partition Name from drop-down list.

Step 8 Click Save.

What to do next

Repeat the above steps to create Network CTI port. Enter Network CTI Port pool name inDevice Name field,
in RCPxxxxFyyyy format.

• RCP - identifies the CTI port as a network device

• xxxx - is the peripheral ID of the Unified Communication Manager PIM

• yyyy - is the network CTI Port

Local CTI port and Network CTI port should be sameNote

Tag CTI Ports as Contact Center Agent Lines

Before you begin

Ensure CTI ports are added. See, Configure CTI Port, on page 31

For 12000 agent deployment model, the CTI port for all three CUCM clusters should be tagged.Note

Perform the below steps for both LCP and RCP CTI ports:

Procedure

Step 1 Login to Cisco Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Ensure that hierarchy is set to appropriate level.
Step 3 Navigate Subscribe Management > Agent Lines
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Step 4 Click Add.
Step 5 Choose Phones from Device Types drop-down list.
Step 6 Choose CTI Ports from Device Name drop-down list.
Step 7 Choose Line from the drop-down list.
Step 8 Choose Application User from drop-down list.
Step 9 Click Save.

Configure Outbound Dialer
Complete the following procedure to configure Outbound Dialer:

• Configure Gateway, on page 34

• Configure Unified CVP, on page 36

• Configure Unified CCE, on page 36

• Configure Unified Communications Manager, on page 50

Configure Gateway

• In small contact center agent deployment model customer can choose a dedicated or a shared outbound
gateway. If it is shared gateway there should be a PSTN connectivity.

• Outbound Dialer do not support A-law, it is not instructed to configure the A-law under inbound dial-peer
in the voice gateway.

Note

Follow the below procedure to configure gateway/CUBE(E):

Procedure

Step 1 Create a voice encapsulation type with following voip parameters

Example:
voice service voip

no ip address trusted authenticate
mode border-element
allow-connections sip to sip
no supplementary-service sip refer
supplementary-service media-renegotiate
redirect ip2ip
signaling forward none

sip
header-passing
error-passthru
asymmetric payload full
options-ping 60
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midcall-signaling passthru
!

Step 2 Default, CPA is enabled for gateway/CUBE(E). Otherwise, enable CPA for CUBE(E).

Example:
voice service voip
cpa

Step 3 Create a voice codec class

Example:
voice class codec 1

codec preference 1 g729r8
codec preference 2 g711ulaw

Step 4 Create dial peer configuration to reach the customer PSTN number.

Example:
dial-peer voice 978100 voip

session protocol sipv2
incoming called-number <Customer Phone Number Pattern>
voice-class codec 1
voice-class sip rel1xx supported "100rel"
dtmf-relay rtp-nte sip-kpml
no vad

dial-peer voice 97810 pots
destination-pattern 97810[1-9]
port 1/0:23
forward-digits all
progress_ind alert enable 8

Step 5 Create dial peer configuration to reach the agent extension (VOIP)

Example:
dial-peer voice 40000 voip

description ***To CUCM Agent Extension***
destination-pattern <Agent Extension Pattern to CUCM>
session protocol sipv2
session target ipv4:<CUCM IP Address>
voice-class codec<Codec Preference number>
voice-class sip rel1xx supported "100rel"
dtmf-relay rtp-nte
no vad
!

In 12000 agent deployment model dial peer needs to be created for all 3 CUCM clusters.Note

Step 6 Create dial peer configuration to reach CVP

Example:
dial-peer voice 99995 voip

description ******To CVP for IVR OB*****
destination-pattern 9999500T
session protocol sipv2
session target ipv4:10.10.10.10
codec g711ulaw
voice-class sip rel1xx disable
dtmf-relay rtp-nte h245-signal h245-alphanumeric
no vad
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!
!

Note

Step 7 Configure Transcoding Profile for CUBE E:

Example:
dspfarm profile 4 transcode universal

codec g729r8
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 250
associate application CUBE
!

Configure Unified CVP

Add Outbound Configuration to an Existing Unified CVP Call Server
Complete the following procedure to add Outbound configuration to an existing Unified CVP Call Server.

Procedure

Step 1 Go to Unified CVP OAMP server and login to Operations console page.
Step 2 Click the Device Management tab and open Unified CVP Call Server from the menu.
Step 3 Open a Call Server and click the ICM tab and add DNIS.

DNIS number should match with the label configured in the Network VRU Explorer for Outbound in Unified
CCE.

Step 4 Click Save and deploy.
Step 5 Repeat step 3 for each CVP Call Server.

Configure Unified CCE
• Add Outbound Option Database Using ICMDBA Tool, on page 37

• Configure the Logger for Outbound Option, on page 37

• Configure Outbound Dialer, on page 38

• Create Outbound PIM, on page 39

• Configure SIP Outbound, on page 39

• Install SIP Dialer Using Peripheral Gateway Setup, on page 47
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• Add DNP Host File, on page 49

• Outbound Option Enterprise Data, on page 49

Add Outbound Option Database Using ICMDBA Tool

• For 2000, 4000 agent deployment models and small contact center, perform the configurations on Unified
CCE Rogger.

• For 12000 agent deployment model, perform the configurations on Unified CCE Logger.

Note

Procedure

Step 1 Select Start > All Programs > Cisco Unified CCE Tools > ICMdba. Click Yes at the warnings.
Step 2 Navigate to Server > Instance >Logger. Right-click on the logger that is installed and selectCreate to create

the Outbound Option database.
Step 3 In the Create Database dialog box, click Add to open the Add Device dialog box. Click Data. Select the E

drive. Leave the DB size with default value and click OK to return to the Create Database dialog box.
Step 4 In theAdd Device dialog box, Click Log. Select the E drive. Leave the log size field with default value. Click

OK to return to the Create Database dialog box.
Step 5 In the Create Database dialog box, click Create, then click Start. When you see the successful creation

message, click OK, then click Close.

Configure the Logger for Outbound Option
Use this procedure to configure the Logger for Outbound Option.

You can (optionally) configure the Logger to enable Outbound Option and Outbound Option High Availability.
Outbound Option High Availability facilitates two-way replication between the Outbound Option database
on Logger Side A and the Outbound Option database on Logger Side B. Use the ICMDBA tool to create an
outbound database on Side A and Side B; then set up the replication by using Web Setup.

Perform the following procedure on both the Side A and Side B Loggers to configure Outbound Option or
Outbound Option High Availability. Both Logger machines must be up and operational.

Before you configure the Logger for Outbound Option High Availability:

• Confirm that an Outbound Option database exists on Logger Side A and Logger Side B.

• Create a Microsoft SQL Server user and assign that user the sysadmin privilege. Use the same username
and password on Logger Side A and Logger Side B. (You use this username and password in the following
procedure to configure Outbound Option and enable Outbound Option High Availability.)

• Assign the sysadmin privilege to the NT authority/System user.

Important
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Procedure

Step 1 Open the Web Setup tool.
Step 2 Choose Component Management > Loggers.
Step 3 Choose the Logger that you want to configure, and click Edit.
Step 4 Click Next twice.
Step 5 On the Additional Options page, click the Enable Outbound Option check box.
Step 6 Click the Enable High Availability check box to enable Outbound Option High Availability on the Logger.

Checking this check box enables High Availability two-way replication between the Outbound Option database
on Logger Side A and the Outbound Option database on Logger Side B. Two-way replication requires that
you check this check box on the Additional Options page for both Logger Side A and Side B. If you disable
two-way replication on one side, you must also disable it on the other side.

You must enable Outbound Option in order to enable Outbound Option High Availability. Similarly, if you
have enabled High Availability, you must disable High Availability (uncheck the Enable High Availability
check box) before you can disable Outbound Option (uncheck the Enable Outbound Option check box).

Step 7 If you enable High Availability, enter a valid public server hostname address for Logger Side A and Logger
Side B. Entering a server IP address instead of a server name is not allowed.

Step 8 If you enable High Availability, enter the SQL Server Admin Credentials (Username and Password) for
a user with the SQL Server SystemAdmin privilege to establish two-way replication. Use the same credentials
on Logger Side A and Logger Side B.

SQL replication requires that the correct SQL Server system admin username and password be in place when
setting up High Availability. If you change the password for that SQL account, replication fails until you
disable High Availability and re-enable it with the new username and password. Because of this requirement,
be careful about how and when you change the password for that account.

You can use any valid SQL Server system administration account to disable High Availability. Once disabled,
you can set any valid SQL Server system administration account when you re-enable High Availability.

Step 9 Select the Syslog box to enable the Syslog event feed process (cw2kfeed.exe).

The event feed is processed and sent to the Syslog collector only if the Syslog collector is
configured. For more information about the Syslog event feed process, see the Serviceability
Guide for Cisco Unified ICM/Contact Center Enterprise at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Note

Step 10 Click Next.
Step 11 Review the Summary page, and click Finish.

Configure Outbound Dialer

Procedure

Step 1 On the Unified CCE Admin Workstation Server, navigate to Start > Cisco Unified CCE Tools >
Administration Tools > Configuration Manager.
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Step 2 In the Configuration Manager window, select Outbound > Dialer.
Step 3 For Small Contact Center, click Retrieve > Add and configure:

a) Enter the Dialer name.
b) Enter the ICM Peripheral Name.
c) Enter Hangup Delay (1-10) value as 1.
d) Enter Port Throttle value as 10.
e) Click Save.

Step 4 Click the Port Map Selection tab to display the port map configuration.
Step 5 Click Add to configure a set of ports and their associated extensions.
Step 6 Click OK.
Step 7 Click Save, then click Close.

For different sub customers, the port and extension range can be same, because each sub customer
has separate dialer.

Note

Create Outbound PIM
Configure Media Routing Peripheral Gateway, then add Outbound PIM. For more information, see Configure
MR Peripheral Gateway.

Configure SIP Outbound
• Add Import Rule, on page 39

• Import Rule Deletion, on page 40

• Add Query Rule, on page 40

• Delete a Query Rule, on page 41

• Add Campaign, on page 41

• Create Admin Script, on page 43

• Add Routing Script for Agent Based Campaign, on page 44

• Add Routing Script for IVR Based Campaign, on page 45

• Create Contact Import File, on page 45

• Create Do Not Call List, on page 46

Add Import Rule

Procedure

Step 1 Goto Unified CCE AW-HDS-DDS machine.
Step 2 Navigate to Configuration Manager > Outbound Option > Import Rule and click Retrieve.
Step 3 Click Add.
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Step 4 In Import Rule General tab:
a) Enter Import Name.
b) Choose Import Type from the drop-down list.
c) Enter Target Table Name.
d) Browse Import File Path.

• For the import typeContact, browse the Contact Import file. See, Create Contact Import
File, on page 45

• For the import type Do Not Call, browse the Do Not Call List file. See, Create Do Not
Call List, on page 46

Note

e) Choose Comma Delimited option from Import Data Type panel.
f) Check Overwrite Table check box.

During Campaign, do not use both Import File Path and Overwrite option. Otherwise,
dialer becomes unavailable to access records.

Note

Step 5 Goto Definition tab:
a) Click Add.
b) Choose Standard Column Type from the drop-down list and retain the default values for remaining

fields.

Step 6 Click Save.

Import Rule Deletion

When you delete an import rule, the corresponding contact table is deleted.

If you are using Outbound Option High Availability and either Side A or Side B is down when the rule is
deleted, the corresponding table on that side is not deleted. However, when the side restarts, the table is then
automatically deleted.

Add Query Rule

Before you begin

One or more Import rules must be defined. See Add Import Rule, on page 39

Procedure

Step 1 Goto Unified CCE AW-HDS-DDS machine.
Step 2 Navigate to Configuration Manager > Outbound Option > Query Rule and click Retrieve.
Step 3 Click Add.
Step 4 Enter Query Rule Name.
Step 5 Choose Import Rule from the drop-down list.
Step 6 Enter Rule Clause.
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Step 7 Click Save.

What to do next

1. Goto Configuration Manager > Tools > List Tools > Call Tye List and add two call types; one for
agent-based and another for IVR-based campaigns.

2. Goto Configuration Manager > Tools > List Tools > Dialed Number / Script Selector List and add
two dialed numbers under Media routing domain. Map the dial numbers with the call types created in the
previous step (one dial number for each call type).

3. Goto Configuration Manager > Tools > Explorer Tools > Skill Group Explorer and add a skill group
under the call manger peripheral. Add a route for this skill group.

4. GotoConfiguration Manager >Tools >Explorer Tools >Agent Explorer and add an agent. Associate
the agent with the skill group created in the previous step.

Delete a Query Rule

When you delete a query rule, the corresponding Dialing List table is also deleted.

If you are using Outbound Option High Availability and either Side A or Side B is down when the rule is
deleted, the corresponding table on that side is not deleted. However, when the side restarts, the table is then
automatically deleted.

Add Campaign

• -

• -

Add IVR Based Campaign

Procedure

Step 1 Goto Unified CCE AW-HDS-DDS machine.
Step 2 Navigate to Configuration Manager > Outbound Option > Campaign and click Retrieve.
Step 3 Click Add.
Step 4 Enter Campaign Name.
Step 5 Goto Campaign Purpose tab:

a) Choose Tranfer to IVR Campaign option.
b) Check Enable IP AMD check box.
c) Choose Transfer to IVR Route Point option.

Step 6 Goto Query Rule Selection tab and click Add:
a) Choose Query Rule Name from the drop-down list and click OK.

Step 7 Goto Skill Group Selection tab:
a) Choose appropriate CUCM PG from Peripheral drop-down list, click Retrieve.
b) Choose Skill Group from the drop-down list.
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c) Enter Overflow Agents per Skill value.
d) Enter Dialed number.
e) Enter Records to cache value.
f) Enter Number of IVR Ports.
g) Click OK.

Step 8 Goto Call Target tab, choose Daylight Savings Zone from the drop-down list.
Step 9 Click Save.

Add Agent Based Campaign

Procedure

Step 1
Step 2 Navigate to Configuration Manager > Outbound Option > Campaign and click Retrieve.
Step 3 Click Add.
Step 4 Enter Campaign Name.
Step 5 Goto Campaign Purpose tab:

a) Choose Agent Based Campaign option.
b) Check Enable IP AMD check box.
c) Choose Transfer to Agent option.

Step 6 Goto Query Rule Selection tab and click Add:
a) Choose Query Rule Name from the drop-down list and click OK.

Step 7 Goto Skill Group Selection tab:
a) Choose appropriate CUCM PG from Peripheral drop-down list, click Retrieve.
b) Choose Skill Group from the drop-down list.
c) Enter Overflow Agents per Skill value.
d) Enter Dialed number.
e) Enter Records to cache value.
f) Enter Number of IVR Ports.
g) Click OK.

Step 8 Goto Call Target tab, choose Daylight Savings Zone from the drop-down list.
Step 9 Click Save.
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Create Admin Script

Figure 8: Create Admin Script

For more information, see Outbound Option Guide.
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Add Routing Script for Agent Based Campaign

Figure 9: Add Routing Script for Agent Based Campaign

For more information, see Outbound Option Guide.
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Add Routing Script for IVR Based Campaign

Figure 10: Add Routing Script for IVR Based Campaign

Configure the following for IVR based campaign:

Procedure

Step 1 Open Network VRU Explorer Tool from Configuration Manager tool. Add a label (label should match with
the DNIS value configured in CVP call server) to the existing Network VRU of type 10 and select Media
Routing type as "Outbound" from drop down list.

Step 2 Add the IVR based campaign.

What to do next

• Create Contact Import File, on page 45

• Create Do Not Call List, on page 46

Related Topics
Add IVR Based Campaign, on page 41

Create Contact Import File

When creating a contact import file, observe the format you designed according to the database rules set up
in Import Rule Definition Tab Page.
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The following example assumes that you have contact informationwithAccountNumber, FirstName, LastName,
and Phone column types.

Procedure

Step 1 Using a text editor, create a text file that contains the information for these fields.
Step 2 Enter an account number, first name, last name, and phone number for each entry on a new line.

Use either Comma Delimited, Pipe Delimited, or Fixed Format, as defined on the Import Rule General Tab
Page.

Step 3 Save the text file to the local server.

Example

The following is an example of a contact import file in the comma-delimited format:

6782,Henry,Martin,2225554444

3456,Michele,Smith,2225559999

4569,Walker,Evans,2225552000

The following is the same example in Fixed Format with the following column definitions:

• Custom - VARCHAR(4)

• FirstName - VARCHAR(10)

• LastName - VARCHAR(20)

• Phone - VARCHAR(20)

6782Henry Martin 2225554444

3456Michele Smith 2225559999

4569Walker Evans 2225552000

Create Do Not Call List

When creating a Do_Not_Call list file, format it correctly using the following instructions.

Procedure

Step 1 Using a text editor, create a text file that contains all the do-not-call phone numbers.
Step 2 Enter a phone number for each Do Not Call entry on a new line.
Step 3 Observe the following characteristics for each Do Not Call entry:

• Each phone number can be a maximum of 20 characters long.

•
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Step 4 Save the text file to the local server.

The following is an example of a Do_Not_Call list:

2225554444

2225556666

2225559999

To add a customer to this list, import a Do Not Call list.

The Campaign Manager reads from the Do_Not_Call table. Dialing List entries are marked as Do Not Call
entries only when the Campaign Manager fetches the Dialing List entry and only when there is an exact,
digit-for-digit match. This allows Do Not Call imports to happen while a Campaign is running without
rebuilding the Dialing List.

If the Dialing List includes a base number plus extension, this entry must match a Do Not Call entry for that
same base number and same extension. The dialer will not dial the extension.

Note

To clear the Do Not Call list, import a blank file with the Overwrite table option enabled.Note

Install SIP Dialer Using Peripheral Gateway Setup

Procedure

Step 1 Stop all ICM Services.
Step 2 On the Unified CCE PG Side A and Side B, run Peripheral Gateway Setup. Select Start > All Programs >

Cisco Unified CCE Tools > Peripheral Gateway Setup.
Step 3 In the Cisco Unified ICM/Contact Center Enterprise & Hosted Components Setup dialog, select an

instance from the left column under Instances.
Step 4 Click Add in the Instance Components section.

The ICM Component Selection dialog opens.

Step 5 Click Outbound Option Dialer.

The Outbound Option Dialer Properties dialog opens.

Step 6 Check Production mode and Auto start at system startup, unless your Unified ICM support provider
specifically tells you otherwise. These options set the Dialer Service startup type to Automatic, so the dialer
starts automatically when the machine starts up.

The SIP (Session Initiation Protocol) Dialer Type is automatically selected.

Step 7 Click Next.
Step 8 On the Outbound Option Dialer Properties dialog, specify the following information:
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• Outbound Option server—The hostname or IP address of the Outbound Option server in Unified CCE.
This server is typically the same VM where the Outbound Option Campaign Manager (Dataserver Side
A) is located.

• Campaign Manager server A—If the Campaign Manager is set up as duplex, enter the hostname or IP
address of the machine where the Side A Campaign Manager is located. If the Campaign Manager is set
up as simplex, enter the same hostname or IP address in this field and the Campaign Manager server
B field. You must supply a value in this field.

• Campaign Manager server B—If the Campaign Manager is set up as duplex, enter the hostname or IP
address of the machine where the Side B Campaign Manager is located. If the Campaign Manager is set
up as simplex, enter the same hostname or IP address in this field and the Campaign Manager server
A field. You must supply a value in this field.

• Enable Secured Connection—Allows you to establish secured connection between the following:

• CTI server and dialer

• MR PIM and dialer

Check the Enable Secured Connection check box to enable secured connection.

If you check the Enable Secured Connection check box, secured connection is established
between the dialer and the servers, such as MR PIM and CTI server.

Note

Before you enable secured connection between the components, ensure to complete the
security certificate management process.

Note

For more information, see the Security Guide for Cisco Unified ICM/Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

• CTI server A—The hostname or IP address of the VM with CTI server Side A. This server is typically
the same VM where the PG is located (Call Server Side A).

• CTI server port A—The port number that the dialer uses to create an interface with CTI server Side A.
The default is 42027 for non-secured connection and 42030 for secured connection. Make sure the CTI
server port matches with the CG configuration. Locate the CTI OS Server port number by running the
Diagnostic Framework Portico page from the call server machine, and selecting ListProcesses.

• CTI server B—The hostname or IP address of the VM with CTI server Side B.

• CTI server port B—The port number that the dialer uses to create an interface with CTI server Side B.
The default is 43027 for non-secured connection and 43030 for secured connection.

• Heart beat—The interval between dialer checks for the connection to the CTI server, in milliseconds.
The default value is 500.

• Media routing port—The port number that the dialer uses to create an interface with the Media Routing
PIM on the Media Routing PG. The default is 38001. Make sure the Media routing port matches that of
the MR PG configuration. For example, you can access this registry key:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems,
Inc.\ICM\mango\PG3A\PG\CurrentVersion\PIMS\pim1\MRData\Config\ApplicationTcpServiceName1.

Step 9 Click Next. A Summary screen appears.

Configure Core Component Integrated Options
48

Configure Core Component Integrated Options
Install SIP Dialer Using Peripheral Gateway Setup

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html


Step 10 Click Next to begin the dialer installation.

Optional - Edit Dialer Registry Value for AutoAnswer

If you enable auto answer in the CallManager with a zip tone, you must disable auto answer in the
Dialer or Dialers, if there are more than one. A zip tone is a tone sent to the agent's phone to signal
that a customer is about to be connected.

To disable auto answer in the Dialer, after the Dialer process runs for the first time, change the value
of the following registry key to 0:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\pra01\Dialer\AutoAnswerCall

For information on other Dialer registry settings, see theOutbound Option Guide for Unified Contact
Center Enterprise.

Add DNP Host File
Complete this procedure to add DNP Host file.

Procedure

Step 1 In the C drive of the virtual machine where dialer is installed, navigate to \icm\customerInstanceName\Dialer
directory.

Step 2 Modify the DNP Host file for static route mapping.

The format for a static route is wildcard pattern, IP address or hostname of the Gateway that

connects to the dialer, description.

Example : 7????? (Dial pattern), 10.86.227.144 (gateway ip) , calls to agent extensions

Repeat these steps for each sub customer Dialer.Note

Outbound Option Enterprise Data
In order for Outbound Option enterprise data to appear in the Cisco Agent Desktop Enterprise Data window,
the administrator must edit the Default layout to include some or all OutboundOption variables. These variables
are prefixed with “BA.” (Edit the default enterprise data layout in the Cisco Desktop Administrator.)

• BAAccountNumber
• BABuddyName
• BACampaign
• BADialedListID
• BAResponse
• BAStatus
• BATimeZone
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To enable the ECC variables, See Configure Expanded Call Variable. The BAStatus field is required. All
other BA fields are optional for Progressive and Predictive modes. In Preview mode, the Skip button will not
work if BADialedListID is not enabled.

Note

• The BABuddyName field is required, if you want to see the customer’s name being called.
• If a call is part of a Preview dialing mode campaign, the first letter in the BAStatus field entry is a P. If
a call is part of a Direct Preview dialing mode campaign, the first letter in the BAStatus field entry is a
“D.”

Configure Unified Communications Manager
• Add Normalization Script, on page 50
• Configure Trunk towards the Outbound Gateway, on page 50

Add Normalization Script
This script is needed to disable Ringback during Transfer to Agent for SIP calls.

Procedure

Step 1 Log in to Unified Communications Manager Administration page.
Step 2 Navigate to Devices > Device Settings > SIP Normalization Scripts.
Step 3 Click Add New.

Displays SIP Normalization Script page.
Step 4 Enter Name of the script.
Step 5 Enter the following script in Content field:

M = {}
function M.outbound_180_INVITE(msg)
msg:setResponseCode(183, "Session in Progress")
end
return M

Step 6 Keep default values for remaining fields.
Step 7 Click Save.

Configure Trunk towards the Outbound Gateway
To configure trunk towards the outbound gateway, see Add SIP Trunks. While updating SIP info tab:

Procedure

Step 1 Enter IP address of outbound gateway in Address IPv4 field.
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Step 2 Choose newly added Normalization Script from the drop-down list.

Configure Post Call Survey
Complete the following procedures to configure post call survey:

• Configure Post Call Survey in CVP, on page 51

• Configure Unified CCE, on page 51

Configure Post Call Survey in CVP
Complete the following procedure to configure Post Call Survey in Unified CVP.

Procedure

Step 1 Log in to the Unified CVP Operations Console and choose System > Dialed Number Pattern.
Step 2 Enter the following configuration settings to associate incoming dialed numbers with survey numbers:

• Dialed Number Pattern - Enter the appropriate dialed number.

The incoming Dialed Number for calls being directed to a Post Call Survey Dialed. This is the Dialed
Number you want to redirect to the survey.

• Enable Post Call Survey for Incoming Calls - Select to enable post call survey for incoming calls.
• Survey Dialed Number Pattern - Enter the dialed number of the Post Call Survey. This is the dialed
number to which the calls should be transferred to after the call flow is completed.

• Click Save to save the Dialed Number Pattern.

Step 3 Click Deploy to deploy the configuration to all Unified CVP Call Server devices.

Configure Unified CCE

Configure ECC Variable
You need not configure Unified CCE to use Post Call Survey, however, you can turn the feature off (and then
on again) within an ICM script by using the ECC variable user.microapp.isPostCallSurvey and a value of
n or y (value is case insensitive) to disable and re-enable the feature.

Configure the ECC variable to a value of n or y before the label node or before the Queue to Skillgroup node.
This sends the correct value to Unified CVP before the agent transfer. This ECC variable is not needed to
initiate a Post Call Survey call, but you can use it to control the feature when the Post Call Survey is configured
using the Operations Console.

When the DN is mapped in the Operations Console for Post Call Survey, the call automatically transfers to
the configured Post Call Survey DN.
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Complete the following procedure to enable or disable the Post Call Survey:

Procedure

Step 1 On the Unified CCE Administration Workstation, using configuration manager, select the Expanded Call
Variable List tool.

Step 2 Create a new ECC Variable with Name:user.microapp.isPostCallSurvey.
Step 3 Set Maximum Length to 1.
Step 4 Select the Enabled check box then click Save.

Configure a-Law Codec
Configure the following in Cisco HCS for CC core components to support a-law codec:

• Configure Gateway, on page 52
• Configure Unified CVP, on page 54
• Configure Unified Communication Manager, on page 56

Configure Gateway
• Configure Ingress Gateway, on page 52

• Configure VXML Gateway, on page 53

Configure Ingress Gateway

Procedure

Step 1 Add the voice class codec 1 to set the codec preference in dial-peer:

Example:
voice class codec 1

codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw

dial-peer voice 70021 voip
description Used for Switch leg SIP Direct
preference 1
max-conn 225
destination-pattern xxxx...... # Customer specific destination
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for Unified CVP
session transport tcp
voice class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
no vad

Configure Core Component Integrated Options
52

Configure Core Component Integrated Options
Configure a-Law Codec



Step 2 Modify the dial-peer to specify the codec explicitly for a dial-peer:
dial-peer voice 9 voip

description For Outbound Call for Customer
destination-pattern <Customer Phone Number Pattern>
session protocol sipv2
session target ipv4:<Customer SIP Cloud IP Address>
session transport tcp
voice-class sip rel1xx supported "100rel"
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 10 voip
description ***To CUCM Agent Extension For Outbound***
destination-pattern <Agent Extension Pattern to CUCM>
session protocol sipv2
session target ipv4:<CUCM IP Address>
voice-class sip rel1xx supported "100rel"
dtmf-relay rtp-nte
codec g711alaw

Configure VXML Gateway

Procedure

Modify the following dial-peer to specify the codec explicitly for a dial-peer:
dial-peer voice 919191 voip

description Unified CVP SIP ringtone dial-peer
service ringtone
incoming called-number 9191T
voice-class sip rel1xx disable
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 929292 voip
description CVP SIP error dial-peer
service cvperror
incoming called-number 9292T
voice-class sip rel1xx disable
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 7777 voip
description Used for VRU leg #Configure VXML leg where the incoming called
service bootstrap
incoming called-number 7777T
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 5 voip
description for SIP TTS Media Call
preference 1
session protocol sipv2
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session target ipv4: <ASR primary server IP>
destination uri tts
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 6 voip
description for SIP ASR Media Call
preference 1
session protocol sipv2
session target ipv4: <TTS primary server IP>
destination uri asr
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 7 voip
description for SIP TTS Media Call
preference 2
session protocol sipv2
session target ipv4: <ASR secondary server IP>
destination uri tts
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
codec g711alaw
no vad

dial-peer voice 8 voip
description for SIP ASR Media Call
preference 2
session protocol sipv2
session target ipv4: <TTS secondary server IP>
destination uri asr
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
codec g711alaw
no vad

Configure Unified CVP
Unified CVP does not require any specific configuration in OAMP.

You must convert the following files to A-law:

1. C:\inetpub\wwwroot\en-us\app
2. C:\inetpub\wwwroot\en-us\app\ag_gr
3. C:\inetpub\wwwroot\en-us\sys
4. C:\Cisco\CVP\OPSConsoleServer\GWDownloads in OAMP server
5. C:\Cisco\CVP\VXMLServer\Tomcat\webapps\CVP\audio
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• After converting the files in the OAMP server, access the Unified CVP OAMP page to upload the newly
converted A-law files to the gateway.

• If gateways are previously used for u-law, then restart the gateway to clear the u-law files in the gateway
cache.

Note

Complete the following procedure to convert mu-law audio files to a-law format:

Procedure

Step 1 Copy the wav file from Unified CVP to your local desktop.
Step 2 Go to All programs > Accessories > Entertainment.
Step 3 Open the Sound Recorder.
Step 4 Select File and click Open.
Step 5 Browse for the mu-law audio file and click Open.
Step 6 Go to Properties.
Step 7 Click Convert Now.
Step 8 Select CCITT A-Law from Format.
Step 9 Click OK.
Step 10 Select Files > Save As and provide a filename.
Step 11 Copy the new a-law format file into the following directory of media server:

C:\inetpub\wwwroot\en-us\app

Enable Recording for Agent Greeting and Courtesy Callback
Complete the following procedure to enable recording for Agent Greeting and Courtesy Callback.

Procedure

Step 1 Open the call studio and go to the callback entry application.
Step 2 Double-click app.callflow.
Step 3 Go to Record Name element settings and change the File Type to other (default is wav).
Step 4 Set the MIME type to audio/x-alaw-basic.
Step 5 Set the File extension as wav

Step 6 Open the RecordAgentGreeting application and double-click app.callflow.
Step 7 Go to Record Greeting With Confirm element settings and change the File Type to other (default is wav).
Step 8 Set the MIME type to audio/x-alaw-basic.
Step 9 Set the File extension as wav.
Step 10 Validate, save, and deploy the application.
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Step 11 Restart the Unified CVP services.

Configure Unified Communication Manager
Complete the following procedure to provision a-Law through Cisco Unified Communications Manager:

Procedure

Step 1 Login to the Cisco Unified Communication Manager Administration page.
Step 2 Navigate to System > Service Parameter.
Step 3 Choose publisher server from Server drop-down list.
Step 4 Choose Cisco CallManager (Active) from Service drop-down list.
Step 5 In ClusterWide Parameters (System - Location and region), choose Enabled for All Devices from G.711

A-law Codec Enabled drop-down list.
Step 6 Choose Disable from following drop-down lists:

• G.711 mu-law Codec Enabled

• G.722 Codec Enabled

• iLBC Codec Enabled

• iSAC Codec Enabled

Step 7 Click Save.

Configure Unified CM Based Silent Monitoring
Perform the following steps to configure unified CM based silent monitoring:

• Enable or Disable the Built-in-Bridge. See, Enable or Disable the Built-in-Bridge

• Add Monitoring Calling Search Space for the device

Add Monitoring Calling Search Space for the device

Before you begin

Ensure that agent phones are added. See, Add Phones.

During CTIOS Server installation, for IPCC Silent Monitor Type, select CCM Based.Note
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Procedure

Step 1 Log in to Unified Communication Domain Manager as provider, reseller or customer.
Step 2 Add Calling Search Space for monitoring purpose. See, Add Class of Service.
Step 3 Edit Lines, choose newly added Calling Search Space from the drop-down list. See, Edit Lines.
Step 4 Click Save.

Configure Unified Communication Manager
A Unified Communications Manager Music On Hold (MoH) server can generate MoH stream from an audio
file or a fixed source. Either of this can be transmitted as unicast or multicast.

MoH server can be deployed in two modes.

1. Along with Unified CM on the same server for HCS for CC deployments with less than 1250 users in a
CM Cluster.

2. As standalone node (TFTP/MoH Server) for HCS for CC deployments with more than 1250 users in a
CM Cluster

• Configure Music On Hold Server Audio Source, on page 57

• Set up Service Parameters for Music on Hold, on page 58

• Set up Phone Configuration for Music on Hold, on page 58

Configure Music On Hold Server Audio Source

Procedure

Step 1 Login to Cisco Unified Communications Manager Administration page.
Step 2 Select Media Resources > Music On Hold Audio Source.
Step 3 Retain the default sample audio source.
Step 4 Select Initial Announcement from drop down list (optional).
Step 5 Click Save.
Step 6 Perform the following steps to create new Audio Source.

a) Click Add New.
b) Select MOH audio stream number from the drop down list.
c) Select MOH audio source file from the drop down list.
d) Enter the MOH source name .
e) Choose Initial Announcement from the drop-down list.
f) Click Save.
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Set up Service Parameters for Music on Hold

Procedure

Step 1 Login to Cisco Unified Communications Manager Administration page.
Step 2 Select System > Service Parameters.
Step 3 Select the MoH server from the drop-down list .
Step 4 Select the app service from Cisco IP Voice Media Streaming App Service drop-down list.
Step 5 Select the required codec in the Supported MOH Codecs field and click Ok.
Step 6 Click Save.

Set up Phone Configuration for Music on Hold

Procedure

Step 1 Login to Cisco Unified Communications Manager Administration page.
Step 2 Select Device > Phone.
Step 3 Select the phone to configure MOH.
Step 4 Select a audio source from User Hold MOH Audio Source drop-down list.
Step 5 Select a audio source from Network Hold MOH Audio Source drop-down list.
Step 6 Click Save and click Apply and reset the phone.
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