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Clone and OS Customization Process

Automated Cloning and OS Customization
For the following automation software and download information see, Automation Software section in Cisco
HCS for Contact Center Installing and Upgrading Guide http://www.cisco.com/c/en/us/support/
unified-communications/hosted-collaboration-solution-contact-center/products-installation-guides-list.html

• GoldenTemplateTool

• PowerCLI

• OVF Tool
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• WinImage

Automated Cloning and OS Customization Using Golden Templates
DoneTaskSequence

Download Golden Template
Automation Tool, on page 3

1

Complete Automation Spreadsheet,
on page 4

2

Run Automation Script, on page
5

3

OSCustomization Process, on page
7

4

Download Golden Template Automation Tool
Golden Template Tool is required for automated cloning of Golden Templates and deploying the customized
Virtual machines in a customer instance. To download and extract the Golden Template Tool, see Automated
Cloning and OS Customization, on page 2 to the root of the C: drive on your system. You can browse the
automation scripts using VMware vSphere PowerCLI.

The extracted content includes the following:

• The automation spreadsheets, which is the interface to the scripts.

• The scripts folder that contains five scripts. The deployVM.PS1 file is the primary automation script,
which calls the other four scripts.

• The Archive, Log, OVF, PlatformConfigRepository, and Report folders are empty until you run the
automation script for export.

Figure 1: Download Automation Tool
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After you run the script for the first time:

• Archive holds the prior versions of the automation spreadsheet, saved with a date and a time stamp.

• Log holds all the log files saved with a date and a time stamp.

• OVF, when the tool runs the Export operation, a sub folder is created for each virtual machine. The
folders take their names from the GOLDEN_TEMPLATE_NAME cells in the spreadsheet. These folders
are used to import the virtual machines to the customer ESXi host.

• PlatformConfigRepository is populated with three subfolders that holds XML files generated as part of
the golden template process.

• Report holds all automation reports, saved with a date and a time stamp.

Related Topics
Automated Cloning and OS Customization, on page 2

Complete Automation Spreadsheet
Fill the information provided in the table to complete the automation spreadsheet for cloning process. Deploy
VM automation script requires this information to clone the virtual machines to the customer instance.

The table describes the values of each virtual server and associated properties:

VOS-based VMWorkgroup-based VMDomain-based VMColumn

YESYESYESCREATEVM

YESYESYESCUSTOMIZATION

OPERATION

10.10.0.1010.10.0.1010.10.0.10SOURCE_HOST_IP

Datastore-A0Datastore-A0Datastore-A0SOURCE_DATASTORE_NAME

SOURCE_VMNAME

OVF_NETWORK1

OVF_NETWORK2

GT-CUCMGT-CVP-ServerGT-RoggerGOLDEN_TEMPLATE_NAME

UCM-SUB-SIDE-ACVP-SVR-SIDE-ACCE-RGR-SIDE-ANEW_VM_NAME

10.10.1.1210.10.1.1110.10.1.10DEST_HOST_IP

Datastore-A6Datastore-A3Datastore-A1DEST_DATASTORE_NAME

10.0.1PRODUCT_VERSION

UCM-SUB-SIDE-ACVP-SVR-SIDE-ACCE-RGR-SIDE-ACOMPUTER_NAME

YESNOWORK_GROUP

WORKGROUPWORK_GROUP_NAME

HCSCC.COM

(Optional)

HCSCC.COMDOMAIN_NAME
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VOS-based VMWorkgroup-based VMDomain-based VMColumn

AmericaTIME_ZONE_LINUX_AREA

Los AngelesTIMEZONE_LINUX_LOCATION

(GMT-08:00)(GMT-08:00)TIME_ZONE_WINDOWS

HCSCC\administratorDOMAIN_USER

••••••••DOMAIN_PASSWORD

XXXX-XXXX-XXXX-XXXXXXXX-XXXX-XXXX-XXXXPRODUCT_KEY

HCSHCSOWNER_NAME

CISCOCISCOCISCOORGANIZATION_NAME

HCSORGANIZATION_UNIT

San JoseORGANIZATION_LOCATION

CAORGANIZATION_STATE

USAORGANIZATION_COUNTRY

10.81.254.131NTP_SERVER

112NIC_NUM

10.10.10.3010.10.10.2010.10.10.10IP_ADDRESS_NIC1

255.255.255.0255.255.255.0255.255.255.0SUB_NET_MASK_NIC1

10.10.10.110.10.10.110.10.10.1DEFAULT_GATEWAY_NIC1

10.10.10.310.10.10.310.10.10.3DNS_IP_NIC1

DNS_ALTERNATE_NIC1

192.168.10.10IP_ADDRESS_NIC2

255.255.255.0SUB_NET_MASK_NIC2

192.168.10.1DEFAULT_GATEWAY_NIC2

192.168.10.3DNS_IP_NIC2

DNS_ALTERNATE_NIC2

Run Automation Script

Before you begin

Download and install VMware vSphere PowerCLI on the client computer.

Ensure WinImage (32-bit) is installed in the following location: C:\Program Files (x86)\WinImageNote

Clone and OS Customization
5

Clone and OS Customization
Run Automation Script



If you import any of the VOS VMs and have an unlicensed copy of WinImage, displays the popup for each
VOS platform. Click OK to continue the import process.

Note

Procedure

Step 1 Sign-in as an administrator and open VMware vSphere PowerCLI (32-bit) application.
Step 2 Enter the get-executionPolicy command to determine the restricted execution policy.
Step 3 If the policy is restricted, enter set-executionPolicy command. At the Supply Values prompt, enter

Unrestricted, then enter Y.

Change the execution policy to run unsigned scripts on your local computer and signed scripts from other
users.

Step 4 Enter the CD < GoldenTemplate directory> command.
Step 5 Run the automation script using the following syntax:

Example:Syntax:

.\scripts\DeployVM.PS1
C:\GoldenTemplate\GoldenTemplate_VMDataSheet.xls
testvCenter testuser testpassword

<Path to the script> <Path
of the spreadsheet>
<vCenter IP / Hostname>
<vCenter User> <Password
to connect to vCenter>

This starts the script that parses and validates the data, creates entries in the GoldenTemplate directory.
Displays the completion percentage on the screen and generates the Status Report in the Report folder.

Click the Log File link in the Status report to debug error conditions and to consult Cisco Support.

Figure 2: Status Report of Golden Template Tool

Related Topics
Automated Cloning and OS Customization, on page 2
OS Customization Process, on page 7

Clone and OS Customization
6

Clone and OS Customization
Run Automation Script



OS Customization Process

DoneTaskSequence

Windows Customization Process

Validate Network Adapter Settings
and Power On, on page 7

1

Edit Registry Settings and Restart
VM, on page 8

2

VOS Customization Process

Configure DNS Server1

Configure Host in DNS Server2

Validate Network Adapter Settings
and Power On, on page 7

3

Validate Network Adapter Settings and Power On

Perform this procedure for all Windows VMs.

Procedure

Step 1 Select the Virtual Machine in the vSphere client. Right-click the VM and choose Edit settings.
Step 2 On theHardware tab, select each Network adapter. Make sure thatConnect at power on in the Device Status

group is checked:
Step 3 Power on the virtual machine.

Do not press Ctrl-Alt-Delete. If you press Ctrl-Alt-Delete after powering on, the customization
does not take effect. You must complete it manually.

Important

Step 4 Wait for the VM to restart and to apply customization. This can take five to ten minutes.

Recover from Pressing Ctrl-Alt-Del During Power-On

Validate Network Adapter Settings and Power On initializes the customization process. Although you are
prompted to press Ctrl-Alt-Delete after powering on, doing do prevents the customization from taking effect.
DONOT pressCtrl-Alt-Del. If you inadvertently pressCtrl-Alt-Del, you have the following option to restore
the customization.

Procedure

Step 1 Get the GoldenTemplate_VMDataSheet.xls from the C:/GoldenTemplateTool/Archive.
Step 2 Copy and paste the GoldenTemplate_VMDataSheet.xls to C:/GoldenTemplateTool.
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Step 3 In the GoldenTemplate_VMDataSheet.xls select No in all the rows for the column CREATEVM except for
those which needs to re-deploy.

Step 4 Else, you can enter that data manually for the VM.

Edit Registry Settings and Restart VM

Perform this procedure for all Windows VMs.

Procedure

Step 1 Select Start > All Programs > Administrative Tools > Computer Management.
Step 2 On the left panel, expand Computer Management (Local) > System Tools > Local Users and Groups >

Users.
Step 3 On the right panel, right-click the administrator and select Set Password.
Step 4 Click Proceed at the warning message, then enter the new password.
Step 5 Click OK.
Step 6 Access the Registry Editor (Start > Run > regedit).
Step 7 Select HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > Current Version >

Winlogon.
a) Set AutoAdminLogon to 0.
b) Remove these keys if they exist: DefaultDomainName and DefaultUserName.

Step 8 Restart the machine. If the machine is in the domain, log in to the domain.
Step 9 Enter NET TIME /DOMAIN:<domain> command to synchronize time with the domain controller.

Automated Cloning and OS Customization Using OVF
DoneTaskSequence

Download Golden Template
Automation Tool, on page 3

1

Complete Automation Spreadsheet
for Export, on page 9

2

Run Automation Script for Export,
on page 9

3

Transport to Desired Location, on
page 10

4

Ensure Readiness of the Location,
on page 11

5

OSCustomization Process, on page
7

6
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Complete Automation Spreadsheet for Export

Prerequisite:

Before the Export process, ensure that the VM has only one Network Adapter to export.

When you complete the automation spreadsheet to export, fill only the columns so that the export automation
script creates export OVFs in the OVF subfolder of the GoldenTemplate directory.

Table 1: Required Columns for Automation Spreadsheet for Export

ExampleDescriptionColumn

NOSelect NO to skip VM creation.CREATEVM

ExportServerSelectExportServer to specify the
operation you are performing with
the script.

OPERATION

xx.xx.xxx.xxxThe IP address of the physical
server hosting the VM to be
exported.

SOURCE_HOST_IP

datastore1(3)The name of the Datastore defined
in VMware.

SOURCE_DATASTORE_NAME

TemplateRoggerAThe name of the VM that will be
exported cannot contain spaces or
special characters. Maximum of 32
characters.

SOURCE_VMNAME

CustomerRoggerANew Name for the Exported VM
cannot contain spaces or special
characters. Maximum of 32
characters.

GOLDEN_TEMPLATE_NAME

Leave all the other columns blank.

Run Automation Script for Export
The export script processes the data in the export spreadsheet and validates that the required fields are present
in the correct format.

The script creates a folder from which you can import the OVF at the desired location.

Run the script from the GoldenTemplate directory.Note

Before you begin

Download and install VMware vSphere PowerCLI on the client computer.
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Procedure

Step 1 Launch VMware vSphere PowerCLI (32-Bit) as administrator.
Step 2 Enter get-executionPolicy command to determine whether the Restricted Execution policy is in effect

or is unrestricted.
Step 3 If the policy is restricted, enter set-executionPolicy command. At the Supply Values prompt, enter

Unrestricted and then enter Y. This changes the execution policy, so that you can run unsigned scripts
that you write on your local computer and signed scripts from other users

Step 4 Enter cd < GoldenTemplate directory> command.
Step 5 Enter the command to run the automation script using the following syntax:

Example:Syntax:

.\scripts\DeployVM.PS1
C:\GoldenTemplate\GoldenTemplate_VMDataSheet.xls
testvCenter testuser testpassword

<Path to the script> <Path of the
spreadsheet> <vCenter IP / Hostname>
<vCenter User> <Password to connect to
vCenter>

This starts a script that parses the data, validates the data, and creates entries in the OVF folder in the
GoldenTemplate directory.

Script is run despite errors. Errors get displayed on the screen and stored in the log file.

Script takes several hours to complete.

After completion, script generates a status report in the Report folder. The status report has a link to the
Log file. Use this file to debug error conditions and to consult with Cisco Support.

Figure 3: Status Report of Golden Template Tool

Related Topics
Automated Cloning and OS Customization, on page 2

Transport to Desired Location
After the successful completion of export process, the OVF files can be transferred to any desired location.
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You can also transfer the GoldenTemplate directory to a USB device.

In that case, you would complete the import spreadsheet and run the import script from the USB drive.Note

Ensure Readiness of the Location
Before completing the import spreadsheet and running the import script, the environment must be set up with
the following:

• the ESXihost or vCenter

• the datastores

Manual Cloning and OS Customization
• Create Customization File for Windows Based Components, on page 11
• Deploy Virtual Machine from the Golden Template, on page 12
• Generate Answer File for VOS Product Virtual Machines, on page 12
• Copy Answer Files to Virtual Machines, on page 14

Create Customization File for Windows Based Components
Complete the following procedure to create the customization file for windows based components .

Procedure

Step 1 In VMware vSphere Client, choose View > Management > Customization Specification Manager.
Step 2 Click New.
Step 3 On the New Customization Specification page, complete the new customization specification:

a) From the Target Virtual Machine OS menu, choose Windows.
b) Under the Customization Specification Information, enter a name for the specification and an optional

description and click Next.

Step 4 On the Registration Information page, specify the registration information for this copy of the guest operating
system. Enter the virtual machine owner's name and organization and click Next.

Step 5 On the Computer Name page, click the most appropriate computer name option that identifies this virtual
machine on the network.

Step 6 On theWindows License page, specify theWindows licensing information for this copy of the guest operating
system:
a) Enter your product volume license key.
b) Check Include Server License information (required to customize a server guest operating system).
c) Click Per server to specify the server license mode. Enter 5 as the maximum number of connections you

want the server to accept. Click Next.
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Step 7 On the Administrator Password page, enter a password for the administrator account and confirm the password
by reentering it. Click Next.

Step 8 On the Time Zone page, choose the time zone for the virtual machine and click Next.
Step 9 On the Run Once page, click Next.
Step 10 On the Network page, choose the type of network settings to apply to the guest operating system and click

Next:
a) Typical settings allow the vCenter server to configure all network interfaces from a DHCP server.
b) Custom settings require you to manually configure the network settings.

Step 11 On the Workgroup or Domain page, click Windows Server Domain and enter the destination domain, the
username, and the password for a user account that has permission to add a computer to the specified domain.

Step 12 On the Operating System Options page, check Generate New Security ID (SID) to generate a new security
identity and click Next.

Step 13 On the Ready to complete page, review your Customization File Summary, and then click Finish.

Deploy Virtual Machine from the Golden Template
Complete the following procedure to deploy the virtual machine from the golden template. Use the deployment
checklists to record the hosts, IP addresses, and SAN locations for your deployment.

Procedure

Step 1 Right-click the template and choose Deploy Virtual Machine from this template.
Step 2 Enter a virtual machine name, choose a location, and click Next.
Step 3 On the Host/Cluster page, specify the host on which you want to store the template. Make sure that the

host/cluster is valid. Click Next.
Step 4 Click Advanced. Specify a valid datastore for the virtual machine that complies with the Cisco HCS for CC

for Contact Center component you deploy.
Step 5 Click Next.
Step 6 Make sure that the data store RAID levels for the component that you install comply with conditions specified

in the table of SAN Configuration for your deployment model.
Step 7 Click Thick provisioned Lazy Zeroed to allocate a fixed amount of storage space to the virtual disk. Click

Next.
Step 8 Click Customize using an existing customization specification and click Next.
Step 9 Select the customization file created in the Customization File for the Template.
Step 10 Review the settings for the new virtual machine. Click Finish.

Generate Answer File for VOS Product Virtual Machines
Complete the following procedure to generate an answer file for VOS product Virtual machines.
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Procedure

Step 1 Open the link http://www.cisco.com/web/cuc_afg/index.html.
Step 2 Configure the following cluster-wide parameters:

a) Under Hardware, select Virtual Machine for Primary Node Installed On.
b) Under Product, select the product name and the product version.
c) Under Administrator credentials, enter the administrator username and password, and confirm the password.
d) Under Security Password, enter a password and confirm password.
e) Under the Application user credentials, enter the application username, password, and confirm the password.

Use the same System Application or Administrator credentials for all nodes.

f) Under Certificate information, enter the organization name, unit, location, state, and country for the Unified
CM and Unified Intelligence Center.

g) Under SMTP, check the box Configure SMTP host and enter the SMTP location.

Step 3 Configure the following primary node parameters:
a) Under NIC Interface Settings, check the check box Use Auto Negotiation.

Do not change the MTU settings.Note

b) Under Network Information, enter the IP address, hostname ,IP mask, and gateway information.

Do not select the option Use DHCP for IP Address Resolution.

c) Under DNS, select the option Configure Client DNS, and enter Primary DNS IP and DNS name.
d) Under Timezone, select the option Use Primary Time Zone Settings.
e) Under Network Time Protocol, check Use Network Time Protocol and enter the IP address, NTP server

name, or NTP Server Pool name for at least one external NTP server.

Step 4 Configure the following secondary node parameters:
a) Under NIC Interface Settings, check the check box Use Auto Negotiation.

Do not change the MTU settings.Note

b) Under Network Information, enter the IP address, hostname, IP mask, and gateway information.

Do not select the option Use DHCP for IP Address Resolution.

c) Under DNS, select the option Configure Client DNS, and enter primary DNS IP and DNS name.
d) Under Timezone, check Use Primary Time Zone Settings check box.
e) Under List of Secondary Nodes, click Add Secondary Node.

Step 5 Click Generate Answer files & License MAC to download the answer file for publisher and first subscriber.

For Unified CM, where an answer file for a second subscriber is required, close and open the
answer file generator web page and enter the details for the publisher and second subscriber.
Download the answer file for the second subscriber only, because you already downloaded the
publisher file along with the first subscriber.

Note

Step 6 Perform steps given in section for mounting the answer files to VM.

Related Topics
Copy Answer Files to Virtual Machines, on page 14

Clone and OS Customization
13

Clone and OS Customization
Generate Answer File for VOS Product Virtual Machines

http://www.cisco.com/web/cuc_afg/index.html


Copy Answer Files to Virtual Machines
Golden Template automation tool generates answer files for unattended installations. Individual answer files
get copied to the C:\GoldenTemplateTool_lO\PlatformConfigRepository directory. These answer files are
then converted to a floppy diskette file format and are used in addition to your VOS product DVD during the
installation process.

Before you begin

Download and then install WinImage 8.5 on the client computer from which the automation scripts will be
run. http://winimage.com/download.htm

Procedure

Step 1 Copy the generated Answer file to the folder and rename it to platformConfig.xml

Example:

Copy CUCM_PUB_SideA_platformConfig.xml to other location and rename it to platformConfig.xml
Step 2 Launch WinImage and select File > New > 1.44 MB and click OK

Step 3 Drag and drop platformConfig.xml into WinImage
Step 4 When prompted to inject the file, click Yes.
Step 5 Select File > Save As

Step 6 From the Save as type list, choose Virtual floppy image. Provide the file name as platformConfig.flp and
click Save

Step 7 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs
are deployed

Step 8 Navigate to the Configuration tab. In the storage section, right click on the Datastore and choose Browse
Datastore, create a folder named <Product_Node>

Example:

CUCM_PUB .
Step 9 Upload the platformConfig.flp file to the folder <Product_Node>.

Example:

CUCM_PUB .
Step 10 Navigate to the <Product_Node> Virtual Machine(Ex; CUCM_PUB_SideA). Right-click and choose Edit

Settings

Step 11 On the Hardware tab, click Floppy drive 1, choose the radio button Use The Existing Floppy Image in
Datastore.

Step 12 Mount the platformConfig.flp from the <Product_Node> folder (Ex: CUCM_PUB) on the data store and
click OK

Step 13 Ensure that the Device status shows Connect at Power On checked for the Network adapter and for the
Floppy drive and click OK.
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