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Device Properties
The term device refers to a configurable application or platform. More than one device can reside on a server.
For example, one physical server can contain a Call Server and a Reporting Server. In this case, each device
is configured with the same IP address.

The network map is a collection of Unified CVP solution components and their configuration data. When you
add a device to the Operations Console, that device becomes visible in the network map and its configuration
data is stored in the Operations Console database.

The Operations Console provides two views of the properties of the devices in the network map:

• Offline View of Device Properties

• Online View of Device Properties

For more information, see Device Information Field Descriptions
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Offline View of Device Properties
In the Offline view, the Operations Server operates without a running Unified CVP solution, allowing you to
build the network map even if the devices do not exist. The configurations are stored locally in the Operations
Console database. The Operations Console displays the property values stored in the local database. When
you modify a property value in the Offline view and click Save, the configuration is stored locally in the
Operations Console database only. Configurations that are saved while a device is Offline can be applied
when the device is ready and available.

By default, Unified CVP devices are displayed in the Offline view. To display the Online device view, select
online from the View drop down menu.

Online View of Device Properties
The Online view provides a snapshot of properties used by the running Unified CVP server at the moment.
When you modify a property value in the Online view and click Save, the configuration is stored locally in
the Operations Console database only. Clicking Save & Deploy saves the change in the Operations Console
database and also applies the change to the device. If you change a device property, click Save, but do not
click Save & Deploy, you see the changed value in the Online view, but see the current value in the Offline
view.

By default, Unified CVP devices are displayed in the Offline view. To display the Online device view, select
online from the View drop-down menu.

Device Information Field Descriptions
When you select a device type from the Device Management menu, information appears about the device that
has been added to the Operations Console.

The following table describes the server window fields.

Table 1: Server Window Fields

DescriptionField

The hostname assigned to the device.Hostname

IP address of the device.IP Address
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DescriptionField

The state of the configuration of the device: configured or invalid.

The following device types can be in the configured or invalid state:

• Unified CVP Call Server

• Unified CVP Reporting Server

• Unified CVP VXML Server

• Unified CVP VXML Server (standalone)

• Speech Server

A configuration can become invalid if the device is reinstalled or errors occur during
device creation. To clear this state, edit the device and click Save & Deploy.

All other devices in the Operations Console are always in the configured state.

Device State

An optional text description for the device.Description

Related Topics
Viewing Device Status

Find Device
Because you probably have several devices in your network, the Operations Console lets you locate specific
devices on the basis of specific criteria. Use the following procedure to locate a device.

See also Display Device Statistics, on page 4.

Step 1 From the Device Management menu, select the menu option for the type of device to find from the Device menu.

The Find, Add, Delete, Edit window lists the available devices of the type you selected, sorted by name, 10 per screen.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
screen to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname; then selecting a modifier, such as begins with;
entering your search term; and then clicking Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Procedure
To find a device:

Step 1 From the Device Management menu, select the menu option for the type of device to find from the Device menu.
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The Find, Add, Delete, Edit window lists the available devices of the type you selected, sorted by name, 10 per screen.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
screen to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname; then selecting a modifier, such as begins with;
entering your search term; and then clicking Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Display Device Statistics
You can display statistics for any Gateway, Unified CVP VXML Server, Unified CVP Reporting Server, or
Unified CVP Call Server, that has been added to the Operations Console.

Step 1 Choose the device from the Device Management menu: For example, if you want to view statistics for the Unified CVP
Reporting Server, choose Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Click Edit.
Step 3 Find the device by using the procedure in Find Device, on page 3.
Step 4 From the list of matching records, choose the device that you want to get statistics for.
Step 5 Select Statistics from the Configuration menu bar.

The Statistics window opens.

Step 6 If there are multiple statistics options to choose, select the desired option from the Statistics drop-down menu.

Procedure
To get device statistics:

Step 1 Choose the device from the Device Management menu: For example, if you want to view statistics for the Unified CVP
Reporting Server, choose Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Click Edit.
Step 3 Find the device using the procedure shown in Find Device, on page 3.
Step 4 From the list of matching records, choose the device for which you want to get statistics.
Step 5 Select Statistics from the Configuration menu bar.

The Statistics window opens.

Step 6 If there are multiple statistics options to choose, select the desired option from the Statistics drop-down menu.
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The Operations Server displays the statistics in the window.

Unified CVP Licensing
The following Unified CVP licenses are enforced by the software on a per-instance basis:

Unified CVP licenses:

• Call Server - The SIP Service and the IVR Service check at startup time to ensure that it is running on a
system with a valid Call Server license.

• Unified CVP VXML Server - The Unified CVP VXML Server checks at startup time to ensure that it is
running on a system with a valid Unified CVP VXML Server license.

• Reporting Server - The Reporting Server runs without requiring a license.

The Reporting Server checks at startup time to ensure that it is running on a systemwith a valid Reporting
Server license.

The Operations Server runs without requiring a license.

In addition, each Call Server and each Unified CVP VXML Server enforce licenses for a particular number
of simultaneous calls. The software does not distinguish between Call Director calls, VRU-only calls, or VRU
calls with ASR/TTS or VXML.

Port licensing is enforced as follows:

• The Call Server is licensed for a certain number of ports; SIP and IVR Services share this port pool.

• The SIP Service attempts to allocate one of its licenses whenever it receives an incoming call. Once the
last license has been allocated, the SIP Service changes its status and that of its host Call Server (the Call
Server on which the SIP Service is running) to Partial status, preventing further calls from being accepted.
When a call terminates, the SIP Service releases a license, and if it had been in Partial status due to license
depletion, it resumes Up status.

You can view the devices in a particular device pool by selectingControl Center
from the Systemmenu, selecting the Device Pool tab, and then selecting a device
pool. You can also view a particular type of device by selecting the Device Type
tab and selecting a device type.

Note

• The IVR Service can receive calls transferred from SIP Service or from some other source. The IVR
Service can handle both the VRU leg and the switch leg of the same call. The IVR Service keeps a list
of active Call IDs, and uses that list to determine whether a particular incoming call has already been
counted. Therefore, the IVR Service always accepts an incoming call if its host Call Server (the Call
Server on which the IVR Service is running) is in the Up state, and then checks whether the call has been
seen before. If the call has not been seen before, the IVR Service allocates a license for that call. If doing
so exhausts the available licenses, the IVR Service changes its state and that of its host Call Server to
Partial. When a call terminates, the IVR Service releases a license and if it had been in Partial state due
to license depletion, it resumes Up status.
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Note that this licensing scheme might change in future releases, and should customers order an insufficient
number of licenses, they will be impacted in future releases when licensing tracks the number of ports actually
ordered.

For more information on licensing, see the Solution Design Guide for Cisco Unified Contact Center Enterprise.

Unified CVP Call Server Setup
From the Unified CVP Call Server option on the Device Management menu, you can configure one or more
Call Servers. The Unified CVP Call Server provides call control capabilities, using Session Initiation Protocol
(SIP) signaling.

The Call Server can be configured to provide the following call control services, which are installed with the
Call Server:

• SIP Service - Session Initiation Protocol (SIP), RFC 3261, is the primary call control protocol in Unified
CVP. The SIP Service uses SIP to communicate with other Unified CVP solution components, such as
the SIP Proxy Server, the VXML and Ingress Gateways, and Cisco Unified Communications Manager
SIP trunks and SIP phones.

• IVR Service - Creates the VXML pages that implement the Unified CVP Micro-applications, based on
Run Script instructions received from ICM server. The IVR service functions as the Voice Response
Unit (VRU) leg, and calls must be transferred to it from the SIP Service to execute micro-applications.
The VXML pages created by this module are sent to the VXMLGateway to be executed. The IVR Service
routes requests from the SIP Service to the ICM Service.

• ICM Service - Enables communication between Unified CVP components and the ICM Server. It sends
and receives messages on behalf of the SIP Service, the IVR Service, and the VXML Service.

You can perform the following tasks:

Related Topics
Shutting Down a Server
Starting a Server

Add Unified CVP Call Server
Adding a Unified CVP Call Server creates a configuration for the Unified CVP Call Server in the Operations
Console database and adds the Unified CVP Call Server to the list of devices in the Operations Console.

Procedure
To add a Unified CVP Call Server:

Step 1 Select Device Management > Unified CVP Call Server.

Call Servers that have been added to the Operations Console are listed.

To use an existing Unified CVP Call Server as a template for creating the new Unified CVP Call Server, select
the Unified CVP Call Server by clicking the radio button preceding it and then click Use As Template.

Note

Step 2 Click Add New from the Menu bar or at the bottom of the screen.

Managing Devices
6

Managing Devices
Unified CVP Call Server Setup

ccvp_b_administration-guide-for-cisco-unified-12-0_chapter1.pdf#nameddest=unique_27
ccvp_b_administration-guide-for-cisco-unified-12-0_chapter1.pdf#nameddest=unique_26


The Unified CVP Call Server Configuration window opens to the General tab.

Step 3 Fill in the IP Address and Hostname fields.
Step 4 Optionally, clickEnable secure communications with the Ops Console to secure communications between theOperations

Console and the Unified CVP Call Server.
Step 5 Turn on the Call Services required for the Call Flow you are using by checking the appropriate check boxes, and then

click Next. See Call Services, on page 7.

The Unified CVP Call Server Configuration page opens to the General tab. Additional tabs for configuring the selected
services are displayed.

Step 6 Select each tab and verify that the default values are correct or change the values if desired:

Configuration Tabs:

• Set Up ICM Service, on page 10

• Set Up SIP Service, on page 13

• Set Up IVR Service, on page 14

• Add or Remove Device From Device Pool

• Set Up Infrastructure, on page 27

Step 7 When you have filled in the configuration settings for all selected Call Services, click Save to save the settings in the
Operations Console database. Click Save & Deploy to save the changes and apply them to the Unified CVP Call Server.

You must only deploy to a freshly installed Unified CVP Call Server. Do not deploy to a Unified CVP Call
Server that was previously configured.

Note

You must apply a license to the Unified CVP Call Server before using it. See Apply Unified CVP Call Server License,
on page 34.

Step 8 Shut down and start the Unified CVP Call Server to start the newly added services.

Related Topics
Unified CVP Call Server Settings, on page 33
View Unified CVP Call Server Statistics, on page 32
View Device Status
Shut Down Server
Start Server

Call Services
Services Needed for CVP Call Flow Models

Choose the desired call flow model, and then select the required call services in the Call Server Configuration
window:

Required Call ServicesCall Flow Model

ICM, IVR, SIPComprehensive Call Flow Using SIP, on page 8

ICM, IVRVRU-Only, on page 8
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Required Call ServicesCall Flow Model

ICM, IVRCall Director Using SIP, on page 8

ICMUnified CVP VXML Server with ICM Lookup, on
page 8

No ServiceUnified CVP VXML Server Standalone Call Flow,
on page 9

ICM, IVR, SIPBasic Video Call Flow, on page 9

Comprehensive Call Flow Using SIP
The Comprehensive call flow model combines the Call Director Using SIP and the VRU-Only scenarios. It
provides initial prompt and collect, self-service IVR, queuing, and VoIP routing among all types of UCCE
and TDM agents. This scenario is supported at two port licensing levels: Basic and Advanced. The Basic level
supports the playing of .wav files and input using DTMF. The Advanced level adds support for ASR, TTS,
and Unified CVP VXML Server applications.

VRU-Only
Unified CVP provides ICM with VRU services for calls which are routed in some other manner, such as by
a carrier switched network through an ICM NIC interface. VRU services could be for initial prompt and
collect, for integrated self service applications, for queuing, or for any combination thereof. This scenario
does not use SIP, and requires no Ingress Gateway. It does use VXMLGateways, but the Unified CVPVXML
Server is optional, as are ASR and TTS Servers.

Depending on which kind of routing client is in charge of call routing, ICM may transfer the call to the
VRU-Only Call Server either by a Translation Route to VRU node, or by a Send To VRU node. In the first
case, the Call Server will determine that the arriving call is a VRU leg call by matching the arriving DNIS
with its configured list of arriving DNIS numbers. In the second case, it will determine that it is a VRU leg
call because the DNIS length is greater than its configuredmaximumDNIS length. Digits beyond themaximum
DNIS length are taken as the Correlation ID.

Call Director Using SIP
In Call Director using SIP, Unified CVP provides ICME with VoIP call routing capabilities only. Use your
own Service Control VRU if you are using an ICM Server to queue calls, or queue calls directly on an ACD.
Calls can be transferred multiple times, from Ingress, to customer-provided VRU, to either UCCE or
customer-provided ACD or agent, and back again.When calls are connected to customer-provided equipment,
their voice paths must go to an Egress gateway which is connected by TDM to that equipment. If the signaling
is SIP, then Unified CVPwill work with customer-provided SIP endpoints which have been tested and certified
to interoperate with Unified CVP. Neither Unified CVP VXML Server nor any VXML Gateways are used
in this model.

Unified CVP VXML Server with ICM Lookup
In this call flow model, the call server with the ICM Service enabled is required to route calls. The Reporting
server is optional. Use a Reporting server if you want to generate reports that include Unified CVP VXML
Server events. You can also use the ICM request label from the Unified CVPVXML Server to an ICM Server,
if the ICM service is enabled on the Call Server. The Reporting server can be installed on the same physical
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machine as the Call Server. After you configure the Call Server, you must configure the Unified CVP VXML
Server. See Unified CVP VXML Server Setup, on page 50.

The RequestICMLabel is a feature that allows you to make back-end requests to an ICM Server without
relinquishing control of the call. The application generally acts on its own, but includes a special step to send
a query to the ICM Server and receive a response. The query and the response may contain full call context
information, as can the response.

Following are the features of the IVR application :

• An IVR application can request an ICM server to select an available UCCE or ACD agent to which the
call should be transferred. Full call context is preserved during the transfer, but queuing is not possible.

• An IVR application can transfer its call to a separate full-blown Unified CVP system for agent selection
and queuing. Full call context is preserved throughout.

• An IVR application can request an ICM server to perform a calculation or application gateway transaction
that it already knows how to perform, and return the result to the application.

• An IVR application can report intermediate or final call data to an ICM server to be stored in its database.

Unified CVP VXML Server Standalone Call Flow
In this call flowmodel, the Call Server is used to route messages between the components. Calls arrive through
a VXML gateway, and interact directly with a Unified CVP VXML Server to execute VXML applications.
The gateway performs both ingress and VXML functions. This call flow model provides a sophisticated
VXML-based VRU, for applications which in many cases do not need to interact with an ICM Server.

For a Unified CVPVXML Server (standalone) with no connection to an ICMServer and no Reporting Server,
configure the Call Server with no services enabled. If you need to make requests to an ICM server, without
relinquishing control of the call or use Unified CVP reporting, you must configure the VXML Server to use
a Call Server with at least the ICM Service enabled. See Unified CVP VXML Server Setup, on page 50.

After you configure the Call Server, you must configure the Unified CVP VXML Server as a Unified CVP
VXML Server (standalone). See Unified CVP VXML Server (Standalone) Setup, on page 67.

Basic Video Call Flow
The Basic Video call flow model combines the Call Director and the VRU-Only call flow models, along with
video capabilities that are only enabled during the caller-agent conversation. It provides initial prompt and
collect, self-service IVR, queuing, and VoIP routing among UCCE and TDM agents.

This call flow model is almost identical to the Unified CVP Comprehensive SIP call flow model. The only
change between the two call flow models is the addition of video-enabled endpoints for the calling and called
parties (Cisco Unified Video Advantage (CUVA), Cisco Unified Personal Communicator (CUPC), and Cisco
TelePresence). See theConfiguration Guide for Cisco Unified Customer Voice Portal for additional information
about CUVA and Cisco Telepresence.

Note

Unified CVP Call Server Services Setup
When you are adding a Unified CVP Call Server, you must configure the call services required for the call
flow model you are using.

• SIP Service - Session Initiation Protocol (SIP), RFC 3261, is the primary call control protocol in Unified
CVP. The SIP Service uses SIP to communicate with other Unified CVP solution components, such as
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the SIP Proxy Server, the VXML and Ingress Gateways, and Cisco Unified Communications Manager
SIP trunks and SIP phones.

• IVR Service - Creates the VXML pages that implement the Unified CVP Micro-applications, based on
Run Script instructions received from an ICM server. The IVR service functions as the Voice Response
Unit (VRU) leg, and calls must be transferred to it from the SIP Service in order to execute
micro-applications. The VXML pages created by this module are sent to the VXML Gateway to be
executed.

• ICM Service - Enables communication between Unified CVP components and the ICM server. It sends
and receives messages on behalf of the SIP Service, the IVR Service, and the VXML Service.

Set Up ICM Service
The ICM service enables communication between Unified CVP components and the ICM server. It sends and
receives messages on behalf of the SIP Service, the IVR Service, and the VXML Service. The ICM service
is installed with the Call Server.

You must configure the ICM service if you are adding or editing a Call Server and you are using any of these
call flow models:

Procedure

• Call Director
• VRU-Only
• Comprehensive

What to do next

You must also configure the ICM service if you use a Unified CVP VXML Server (standalone) that makes
requests to an ICM server without relinquishing control of the call (Request ICM Label).

Procedure

To configure the ICM Service:

Step 1 If you are adding a new Call Server, refer to Add Unified CVP Call Server, on page 6. If you want to change an existing
Call Server, refer to Edit Unified CVP Call Server, on page 30.

Step 2 Fill in the appropriate configuration settings as described in ICM Service Settings, on page 10
Step 3 When you finish configuring all desired Call Server services, click Save to save the settings in the Operations Console

database. Click Save & Deploy to apply the changes to the Call Server.

ICM Service Settings
The following table describes the property settings that you can change to configure the ICM Service. The
first time you configure the ICM Service on a Call Server, you must restart the Call Server. You must also
restart the server if you change a configuration setting that has been marked yes in the restart required column
in the table below.
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Table 2: ICM Service Configuration Settings

Restart
Required

RangeDefaultDescriptionProperty

General Configuration

YesAny valid TCP/IP
connection port

5000The Port Number on which the ICM Service
listens for a TCP connection from the ICM
PIM.

VRU Connection
Port

NoInteger10The maximum length of an incoming Dialed
Number Identification Service (DNIS). Valid
input for this field is 1 - 99999 characters.

Look for this information in your network dial
plan. For example, if the Gateway dial pattern
is 1800******, the value ofMaximumLength
of DNIS should be 10.

The number of DNIS digits from the PSTN
must be less than or equal to the maximum
length of DNIS field.

If you are using the Correlation ID
method in your ICM script to
transfer calls to Unified CVP, the
maximum length of DNIS should
be the length of the label that is
returned from ICM for the VRU
leg of the call. When ICM transfers
the call, the Correlation ID is
appended to the label. Unified CVP
then separates the two, assuming
that any digits greater than
maximum length of DNIS are the
Correlation ID. The Correlation ID
and label are then passed to ICM.

Note

Maximum Length
of DNIS

YesNANoEnables secure communication between ICM
and the Unified CVP Server.

Enable secure
communication
with VRU PIM

Translation Routed DNIS Pool
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Restart
Required

RangeDefaultDescriptionProperty

NoIntegerNoneEnter a single DNIS number for translation
routed calls. DNIS is a phone service that
identifies which number the caller dialed.

DNIS can be up to 32 characters in length.

Validations for DNIS fields are as follows:

• The DNIS must be a positive integer;
DNIS can begin with a zero (0)

• The start and end values for the DNIS
range must be the same length

• Users cannot add a DNIS or DNIS range
that already exists or overlap with (or in)
the range of a DNIS added previously

Add

NoIntegerNoneList of DNIS numbers for translation routed
calls. Add a range of DNIS numbers, select
Add a Range, enter the first DNIS number in
the range, and then enter the last DNIS number
in the range in the to field. Click Add DNIS
to add the entered DNIS or DNIS range to the
list of Configured DNIS numbers. Select a
DNIS or DNIS range in the Configured DNIS
box and click Delete DNIS to remove it from
the list of Configured DNIS numbers.

DNIS can be up to 32 characters in length.
Valid input for DNIS range requires the first
and last DNIS numbers in the range to be the
same length. For example, a range from 100
to 900 is valid because each number is three
characters in length.

Add a Range

Advanced Configuration

YesInteger1Identifies calls to be presented to ICM
software as a new call. New Call Service ID
calls result in a NEW CALL message being
sent to ICM software and the call being treated
as a new call, even if it had been pre-routed
by ICM software.

New Call Service
ID

YesInteger2Identifies calls pre-routed with a translation
route or correlation ID. Pre-routed Service ID
calls result in a REQUEST_INSTRUCTION
message being sent to ICM software, which
continues to run the script for the call.

Pre-routed Call
Service ID
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Restart
Required

RangeDefaultDescriptionProperty

YesInteger100Calls presented to ICM as new calls are sent
with this Trunk Group ID as part of the
NEW_CALL message to ICM.

New Call Trunk
Group ID

YesInteger200Calls pre-routed with a Translation Route or
correlation ID are sent with this Trunk Group
ID as part of the REQUEST_INSTRUCTION
message to ICM.

Pre-routed Call
Trunk Group ID

Trunk Utilization

NoNot applicableNoneCheck the check box to enable gateway trunk
reporting.

TheAddGateway (when adding or
editing a gateway) contains an
optional field, Trunk Group ID,
that can be used to customize the
trunk group ID for each gateway.

Note

Enable Gateway
Trunk Reporting

Yes1-1500700The value used for setting the maximum
number of ports that a gateway supports in a
CVP deployment. This will be used to
calculate the number of ports to report to the
Unified ICM Server for each gateway.

Maximum
Gateway Ports

NoNot applicableNoneThe list of gateways available for trunk
reporting.

Available

NoNot applicableAll
Gateways
Selected

The list of gateways selected for trunk
reporting.

Selected

Set Up SIP Service
You must configure the SIP service if you add a new Call Server (Add Unified CVP Call Server, on page 6)
or edit a Call Server (Edit Unified CVP Call Server, on page 30), and you use any of these call flow models
(Call Services, on page 7):

• Call Director
• Comprehensive

Session Initiation Protocol (SIP), RFC 3261, is the primary call control protocol in Unified CVP. The SIP
Service uses SIP to communicate with other Unified CVP solution components, such as the SIP Proxy Server,
the VXML and Ingress Gateways, and Cisco Unified Communications Manager SIP trunks and SIP phones.

Procedure

The SIP Service is one of the services that can be configured when creating a new Call Server.
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Step 1 If you are adding a new Call Server, refer to Add Unified CVP Call Server, on page 6. If you want to change an existing
Call Server, see Edit Unified CVP Call Server, on page 30.

Step 2 Fill in the appropriate configuration settings. For more information, see section SIP Service Settings in the Managing
Devices chapter.

Step 3 When you finish configuring all desired Call Server services, click Save to save the settings in the Operations Console
database. Click Save & Deploy to apply the changes to the Call Server.

Set Up IVR Service
The first time you configure the service on a Unified CVP Call Server, you must restart the Call Server.

Youmust configure the IVR service if you add a newUnified CVPCall Server (AddUnified CVPCall Server)
or edit a Unified CVP Call Server (Edit Unified CVP Call Server) and you any of these call flow models (Call
Services):

Audio call flow models:

• Call Director, using SIP protocol
• VRU-Only
• Comprehensive, using SIP protocol

The IVR Service creates VXML documents that implement the Micro-Applications based on Run Script
instructions received by the ICM. The VXML pages are sent to the VXML Gateway to be executed. The IVR
Service can also generate external VXML through theMicro-Applications to engage the Unified CVPVXML
Server to generate the VXML documents.

The IVR Service plays a significant role in implementing a failover mechanism: those capabilities that can
be achieved without ASR/TTS Servers, and VXML Servers. Up to two of each such servers are supported,
and the IVR Service orchestrates retries and failover between them.

Before You Begin

Configure the following servers before configuring the IVR Service:

• ICM Server
• Media Server
• ASR/TTS Server
• Unified CVP VXML Server
• Gateway

Procedure

The IVR Service is one of the services that can be configured when creating a new Call Server.

Step 1 If you are adding a new Call Server, refer to Add Unified CVP Call Server, on page 6. If you want to change an existing
Call Server, refer to Edit Unified CVP Call Server, on page 30.

Step 2 Fill in the appropriate configuration settings as described in IVR Service Settings, on page 15
Step 3 When you finish configuring all desired Call Server services, click Save to save the settings in the Operations Console

database. Click Save & Deploy to apply the changes to the Call Server.
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IVR Service Settings
The following table describes the property settings that you can change to configure the IVR Service.

Table 3: IVR Service Configuration Settings

Restart
Required

RangeDefaultDescriptionProperty

IOS Voice Browser Configuration

No0 -21474836477320The number of seconds the IVR
Service waits for a call request from a
non-Unified CVP Voice Browser
before removing that Voice Browser
from its current client list. This value
must be greater than or equal to the call
timeout.

Last Access
Timeout (seconds)

No0 -21474836474The number of seconds the Gateway
should wait to connect to the HTTP
Media Server before timing out.

Media Server
Timeout

No0 -21474836470Maximum number of times the
non-Unified CVPVoice Browser (IOS
Voice Browser) or Unified CVP
VXML Server attempts to connect to
an HTTP Media Server to retrieve a
single prompt. If the Voice Browser
or Unified CVP VXML Server fails
after the specified number of times, it
will try the same number of times to
retrieve the media from a backup
media server before failing and
reporting an error. The backup media
server is defined on the gateway as
<mediaserver>-backup.

Media Server Retry
Attempts

No0 -21474836470Maximum number of times the
Gateway tries to connect to an
ASR/TTS server. If the Gateway fails
to connect this many attempts, it will
try the same number of times to
connect to a backup ASR/TTS server
before failing and reporting an error.
(The backup ASR and TTS servers are
defined on the gateway as
asr-<locale>-backup and
tts-<locale>-backup.)

ASR/TTS Server
Retry Attempts
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Restart
Required

RangeDefaultDescriptionProperty

No0 -21474836470Maximum number of times the
Gateway tries to connect to the IVR
Service before failing and reporting an
error. This setting controls call results
only. The initial NEW_CALL retry
count from the Gateway to the IVR
Service is controlled from within the
bootstrap VXML in flash memory on
the Gateway.

IVR Service Retry
Attempts

NoYes or NoYesIf you select Yes (default) and an
ASR/TTS Server is unavailable, the
Gateway attempts to connect to the
backup ASR/TTS server.

Use Backup
ASR/TTS Servers

NoYes or NoYesIf you selectYes (default) and a media
server is unavailable, the Gateway
attempts to connect to the backup
Media Server.

Use Backup
Media/VXML
Servers

NoYes or NoNoIf you select No (default), the IP
address is used for the XML Server
and Media Server. If you select Yes,
the hostnames are used rather than IP
addresses.

Use hostnames for
default
Media/VXML
servers

NoYes or NoNoIf you selectNo (default), HTTPURLs
are generated to media servers.

The default setting is only
applicable if the client is
SIP Service and the media
server is not set to a URL
that explicitly specifies an
HTTP/HTTPS scheme.

Note

Select Yes to generate HTTPS URLs
to media servers.

Use Security For
Media Fetches

Advanced Configuration

Managing Devices
16

Managing Devices
IVR Service Settings



Restart
Required

RangeDefaultDescriptionProperty

NoMust be 6 seconds
or greater

7200The number of seconds the IVR
Service waits for a response from the
SIP Service before timing out. This
setting should be longer than the
longest prompt, transfer or digit
collection at a Voice Browser. If the
timeout is reached, the call is cancelled
but no other calls are affected. The
only downside to making the number
arbitrarily large is that if calls are being
stranded, they will not be removed
from the IVR Service until this timeout
is reached.

Call timeout

NoYes or NoNoSelect this option if your ASR and TTS
servers are on the samemachine. Using
this option helps to minimize the
number of MRCP connections on the
ASR/TTS server.

ASR/TTS use the
sameMRCP server

SIP Service Settings
The following table describes the properties that you can set to configure the SIP Service. The first time you
configure the SIP service on a Call Server, you must restart the Call Server.

Configuration

Enable Outbound Proxy

Select Yes to use a use a Cisco Unified SIP proxy server. For more information on configuring the Cisco
Unified SIP Proxy Server, consult the CUSP documentation.

Restart RequiredRangeDefault

YesYes and NoNo

Use DNS SRV type query

SelectYes to use DNS SRV for outbound proxy lookup. Otherwise, selectNo. See Load-Balancing SIP Calls,
on page 26 for information on using DNS SRV for load-balancing SIP calls.

If you enable Resolve SRV records locally, you must select Yes to ensure the feature works properly.Note

Restart RequiredRangeDefault

YesYes and NoNo

Resolve SRV records locally
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Select to resolve the SRV domain name with a local configuration file instead of a DNS Server.

If you enable Resolve SRV records locally, you must select Yes to use DNS SRV type query. Otherwise,
this feature will not work.

Note

See the Configuration Guide for Cisco Unified Custom Voice Portal for additional information about local
SRV configuration.

Restart RequiredRangeDefault

YesEnabled or Disabled NoNone

Outbound Proxy Host

If you selected Enable Outbound Proxy, select an Outbound Proxy Server from the drop-down list. These are
the SIP Proxy Servers that have been added to the Operations Console. For information on configuring a SIP
Outbound Proxy Server, consult the CUSP documentation.

Restart RequiredRangeDefault

YesValid IP AddressNo

Outbound SRV domain name/Server group name (FQDN)

If you use a hostname that is an SRV type record instead of a standard DNS type record, this field contains a
fully qualified domain name that is configured on the DNS server. Otherwise, the field contains an SRV
configuration file.

For example, outbound calls made from CVP SIP service will be addressed to the URL of
sip:<label>@<srvfqdn>. Redundant proxy servers, for example, can route calls using such a configuration.

Restart RequiredRangeDefault

YesFollows the same validation rules
as hostname, which includes
uppercase and lowercase letters in
the alphabet, the numbers 0 through
9, and a dash.

0 - 256 character length.

None

DN on the Gateway to Play the Ringtone

Dialed Number (DN) configured on the gateway to play ringtone (dedicated VoIP dial peer).

To learn the DN configured on the gateway to play ringtone, execute the sh run command on the gateway
and look for the dial peer that matches the incoming dialed number. See Ringtone Dialed Number Learning
on Gateway Example, on page 26.

Restart RequiredRangeDefault

NoAny valid label9191

DN on the Gateway to Play the Error Tone

Dialed Number (DN) configured on the gateway to play the error.wav file (dedicated VoIP dial peer).
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To learn the DN configured on the gateway to play the error tone, execute the sh run command on the gateway
and look for the dial peer that matches the incoming dialed number. See Ringtone Dialed Number Learning
on Gateway Example, on page 26.

Restart RequiredRangeDefault

NoAny valid label9292

Override System Dialed Number Pattern Configuration

Use the new Dialed Number Pattern system configuration, but maintain the existing Call Server interface.

Restart RequiredRangeDefault

NoThe override check box's default
state differs depending on the
device state:

• For new devices, override is
disabled (unchecked). New
Unified CVP Call Server
devices will use configured
system-level dialed number
patterns by default.

• For upgraded devices,
override is enabled (checked).
Upgraded Unified CVP Call
Server devices will use
device-level dialed number
patterns by default.

Unchecked

Advanced Configuration

Outbound proxy port

Specify the port to be used.

Restart RequiredRangeDefault

No5060

Outgoing transport type

Specifies the outgoing transport, you can set it as TCP or UDP.

Restart RequiredRangeDefault

YesTCP or UDPTCP

Port number for incoming SIP requests

Specify the port to be used foe incoming SIP requests.

Restart RequiredRangeDefault

Yes5060
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Incoming transport type

Specifies the incoming transport type.

Restart RequiredRangeDefault

YesTCP, UDP, TCP+UDPTCP+UDP

Time to wait for ICM instructions

Specifies the wait time in milliseconds for ICM instructions. It is optional value for the list addition.

Restart RequiredRangeDefault

No2000

SIP info tone duration

Specifies the wait time in milliseconds for SIP info tone. It is optional value for the list addition.

Restart RequiredRangeDefault

No100

SIP info comma duration

Specifies the wait time in milliseconds for SIP info comma. It is optional value for the list addition.

Restart RequiredRangeDefault

Yes100

Generic Type Descriptor (GTD) parameter Forwarding

To be added

Restart RequiredRangeDefault

NoUUS

Prepend digits

Specifies the number of digits to be removed for SIP URI user number.

Restart RequiredRangeDefault

No0-200

UDP Retransmission Count

Specifies the number of UDP retransmission will be attempted.

Restart RequiredRangeDefault

No3

Use Error Refer

Flag for play error tone when call fails to caller.
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Restart RequiredRangeDefault

YesTrue or FalseFalse

IOS Gateway Options Dynamic Routing

Restart RequiredRangeDefault

YesTrue or False

IOS Gateway Options Reporting

Reports on resource utilization.

Restart RequiredRangeDefault

YesTrue or False

Security Properties

Incoming secure port

Specify the port to be used.

Restart RequiredRangeDefault

No5061

Incoming secure protocol

This option is grayed out as it is prepopulated.

Restart RequiredRangeDefault

NoTLS

Outgoing secure protocol

This option is grayed out as it is prepopulated.

Restart RequiredRangeDefault

NoTLS

Supported TLS Versions

This allows to select the versions of TLS to be supported for securing the SIP signaling on the IVR leg. The
TLS versions currently supported are TLSv1.0, TLSv1.1, and TLSv1.2.

Restart RequiredRangeDefault

YesTLSv1.0, TLSv1.1, and TLSv1.2TLS v1.2

When you select a a given TLS version, Unified CVP supports SIP TLS requests for that version and the
higher supported versions.

Note

Supported Ciphers
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This field defines the ciphers, which is supported by Unified CVP, with key size lesser than or equal to 1024
bits.

The default cipher is TLS_RSA_WITH_AES_128_CBC_SHA, which is pre-populated and cannot be deleted
as it is mandatory for TLSv1.2.

Cipher configuration is available only if TLS is enabled.

Restart RequiredRangeDefault

YesTLS_RSA_WITH_AES_128_CBC_SHA

If you are using CUBE version 16.6 and higher, you must manually change the crypto suite to 128 by enabling
CLI on the dial-peer towards CVP as shown:

voice class srtp-crypto 1
crypto 1 AES_CM_128_HMAC_SHA1_32

dial-peer voice xxxx voip (Dial-peer to CVP)
...
voice-class sip srtp-crypto 1

Note

SIP Header Passing (to ICM)

Header Name

Specify the SIP header name and click Add to add it to the list of SIP headers passed to ICM.

Restart RequiredRangeDefault

NoMaximum length of 210 characters.None

Parameter

This field is optional for list addition.

Restart RequiredRangeDefault

NoMaximum length of 210 characters.None

Local Static Routes

Enable "Override System Dialed Number Pattern Configuration" to configure these values.Note

Dialed Number (DN)

Creates a Static Proxy Route Configuration Table. You must create static routes if you do not use a SIP Proxy
Server. Before adding a local static route, you must enter a value into both the Dialed Number (DN) and IP
Address fields so that the local static route is complete.

ClickAdd to create a proxy route using the Dialed Number (DN) and the IP address/Hostname entered above
the Add button. The newly created proxy route is added to the list of proxy routes displayed in the box below
the Add button.
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Click Remove to delete the selected DN from the list box of Dialed Numbers.

Restart RequiredRangeDefault

NoDialed number pattern, destination
(must be format of
NNN.NNN.NNN.NNN or a
hostname). See Valid Formats for
Dialed Numbers, on page 26 for
more information.

None

IP Address/Hostname/Server Group Name

The IP address, hostname, or server group SRV domain name.

If you use Server Group Name, you must selectYes to useDNS SRV type query and youmust enableResolve
SRV records locally to ensure the feature works properly.

Note

Restart RequiredRangeDefault

NoValid IP address, hostname, or SRV
domain name

None

Dialed Number (DN) Patterns

Enable "Override System Dialed Number Pattern Configuration" to configure these values.Note

Patterns for sending calls to the originator :

Dialed Number (DN)

Creates a SIP Send Back to Originator Lookup Table. Specify the DN patterns to match for sending the call
back to the originating gateway for VXML treatment. For the Unified CVP branch model, use this field to
automatically route incoming calls to the Call Server from the gateway back to the originating gateway at the
branch. For information on the Unified CVP branch model, see Planning Guide for Cisco Unified Customer
Voice Portal.

This setting overrides sending the call to the outbound proxy or to any locally configured static routes. It is
also limited to calls from the IOS gateway SIP "User Agent" because it checks the incoming invite's User
Agent header value to verify this information. If the label returned from ICM for the transfer matches one of
the patterns specified in this field, the call is routed to sip:<label>@<host portion of from
header of incoming invite>.

Three types of DNs work with Send To Originator: VRU label returned from ICM, Agent label returned from
ICM, and Ringtone label.

Send To Originator does not work for the error message DN because the inbound error message is played by
survivability and the post-route error message is a SIP REFER. (Send To Originator does not work for REFER
transfers).
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For Send To Originator to work properly, the call must be TDM originated and have survivability configured
on the pots dial peer.

Note

Restart RequiredRangeDefault

NoSee Valid Formats for Dialed
Numbers, on page 26 for more
information.

None

Patterns for RNA timeout on outbound SIP calls:

- Dialed Number (DN)

Creates a Dialed Number (DN) pattern outbound invite timeout using the DN and Timeout entered above the
Add button. Click Add to add the newly created DN pattern outbound invite timeout to the list displayed in
the box below the Add button.

Click Remove to delete the selected DN pattern outbound invite timeout from the list.

Restart RequiredRangeDefault

NoSee Valid Formats for Dialed
Numbers, on page 26 for more
information.

None

Timeout (Seconds)

The number of seconds the SIP Service waits for transferee to answer the phone or accept the call.

If a selected termination (for either a new or transferred call) returns a connection failure or busy status, or if
the target rings for a period of time that exceeds the Call Server's ring-no-answer (RNA) timeout setting, the
Call Server cancels the transfer request and sends a transfer failure indication to Unified ICM. This scenario
causes a router requery operation. The Unified ICM routing script then recovers control and has the opportunity
to select a different target or take other remedial action.

Restart RequiredRangeDefault

No5 - 6060 seconds

Custom ringtone patterns:

Dialed Number (DN)

Specify a custom Dialed Number (DN) pattern. Click Add to add the newly created DN pattern to the list
displayed in the box below the Add button.

To learn the DN configured on the gateway to play ringtone, execute the sh run command on the gateway
and look for the dial peer that matches the incoming dialed number. See Ringtone Dialed Number Learning
on Gateway Example, on page 26.

Restart RequiredRangeDefault

NoSee Valid Formats for Dialed
Numbers, on page 26

None

Ringtone Media file name
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The file name of the ringtone to be played for the respective dialed number.

The ringtone media file must be saved to the VXMLGateway. See Transfer Script andMedia File to Gateway,
on page 77 for more information.

Restart RequiredRangeDefault

No0 - 256 characters. Spaces are not
permitted.

Provide the URL for the stream
name in the following form:
rtsp://<streaming server
IP address>
/<port>/<foldername>/
<filename>.rm

None

Post Call Survey DNIS Mapping

Enable "Override System Dialed Number Pattern Configuration" to configure these values.Note

Incoming Call Dialed Number (DN)

Click Add to add the newly created DN pattern to the list displayed in the box below the Add button. Click
Remove to delete the selected DN pattern from the list.

Restart RequiredRangeDefault

NoDialed Number pattern, destination
(must be in the form of
NNN.NNN.NNN.NNN or a
hostname). See Valid Formats for
Dialed Numbers, on page 26 for
more information.

None

Survey Dialed Number (DN)

Click Add to add the newly created DN to the list displayed in the box below the Add button. Click Remove
to delete the selected DN from the list.

Restart RequiredRangeDefault

NoAccepts only alphanumeric
characters

None

SIP Transport Setting for UDP
UDP is the default transport in high availability SIP deployments. One of the drawbacks of TCP is the slow
response times encountered in transmission failures due to network outages. The slow response times for TCP
are caused by slowness in detecting a connection reset in applications running on other SIP devices in the
network. This slowness is due to the buffering window of the TCP connection. Higher call loads fill the buffer
faster and thus the notification of a connection down with an I/O exception arrives more quickly. Lower call
loads or a test with a single call can be affected by as much as a 30-second delay or more. Invite Retry Counts
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and Retry Timeout settings are not effective when using TCP transport on SIP calls because of the persistent
nature of the TCP connection.

For SIP RFC, use TCP transport in deployments in which packet sizes exceed 1300 bytes, the size of a
MaximumTransmission Unit (MTU). Using UDP, if a SIPmessage exceeds 1300 bytes, then it might fragment
and cause problems with delivery and message ordering. See Section 18.1.1 Sending Requests in RFC 3261.
A SIP packet can exceed 1MTU for various reasons; for example, if there are many Via headers, or the media
portion is very large in bytes.

While the SIP Request For Comments (RFC) mandates the support of both TCP and UDP, not all SIP User
Agents support TCP. However, the Unified CVP SIP Service, IOSGateway, and CiscoUnified Communications
Manager use both transport protocols.

Load-Balancing SIP Calls
SIP calls can be load balanced across destinations in several different ways:

• Using the CUSP, define several static routes with the same route pattern and priorities and weights.
• Using DNS, configure SRV records with priorities and weights. A proxy server is not necessary in this
method, but both the DNS client and the server settings must be configured and operating successfully
for DNS "A" and "SRV" type queries to work. Configure SRV queries to be used wherever outbound
SIP calls are made, such as on the IOS Ingress gateway, on the Call Server itself, and on Cisco Unified
CM.

Valid Formats for Dialed Numbers
Valid dialed number patterns are the same as for the ICM label sizes and limitations, including:

• Use the period (.) or the X character for single-digit wildcard matching in any position.

Lowercase letter "x" cannot be used as a wildcard.Note

• Use the greater than (), asterisk (*), or exclamation (!) character as a wildcard for 0 or more digits at the
trailing end of a DN.

• Do not use the character T for wildcard matching.
• Dialed numbers must not be longer than 24 characters.
• The highest precedence of pattern matching is an exact match, followed by the most specific wildcard
match. When the number of characters are matched equally by more than one wildcarded pattern,
precedence is given from top to bottom of the configured DN list.

Ringtone Dialed Number Learning on Gateway Example
To verify the dialed number configured on the gateway to play ringtone, execute the sh run command on the
gateway and look for the dial peer that matches the incoming dialed number. For example:

sh run

paramspace english index 0

paramspace english language en

paramspace english location flash

service ringtone flash:ringtone.tcl
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paramspace english prefix en

service ringtone

voice-class codec 1

voice-class sip rel1xx disable

incoming called-number 9191T

dtmf-relay rtp-nte h245-signal h245-alphanumeric

no vad

Set Up Infrastructure
The Call Server, Unified CVP VXML Server, and Reporting Server offer one or more services. The Call
Server provides SIP, IVR, and ICM call services. The Unified CVP VXML Server provides VXML services,
and the Reporting Server provides reporting services. Changes to Infrastructure settings affect all services
that use threads, publish statistics, send syslog events, or perform logging and tracing. For example, changing
the syslog server setting applies to all services that write to syslog.

Procedure

Step 1 If you are adding a new Call Server, refer to Add Unified CVP Call Server, on page 6. If you want to change infrastructure
settings for an existing Call Server, refer to Edit Unified CVP Call Server, on page 30.

Step 2 Fill in the appropriate configuration settings as described in Infrastructure Settings, on page 27.
Step 3 When you finish configuring Call Server services, click Save to save the settings in the Operations Console database, or

click Save & Deploy to save the changes to the Operations Console database and apply them to the Call Server.

Infrastructure Settings
The following table describes the infrastructure configuration settings.

Table 4: Infrastructure Service Configuration Settings

Restart
Required

RangeDefaultDescriptionProperty

Configuration: Thread Management

No100 to 1000300Maximum number of threads allocated in
the thread pool, that can be shared by all
services running as part of a CVP Web
Application.

Maximum Threads

Statistics

Managing Devices
27

Managing Devices
Set Up Infrastructure



Restart
Required

RangeDefaultDescriptionProperty

No10 - 1440
minutes

30
minutes

Length of time (in minutes) during which
system and service statistics are published
to the log file and SNMP events are sent.
Once published, the counters will reset and
aggregate data for the next interval. Note
that this is different than the real time
snapshot statistics (for the number of
concurrent calls). Realtime statistics are
on-demand and have no intervals. Statistics
Publishing Interval will be used for
attributes like the number of calls in last
interval, the number of transfers in last
interval, and the number of HTTP sessions
in last interval.

Statistics
Aggregation
Interval

Log File Properties

No1 through 100
MB

10 MBMaximum size of a log file in Megabytes
before a new log file is created.

Max Log File Size

No500 - 500000

The log folder
size divided by
the log file size
must be less
than 5000.

20000
MB

Maximumnumber ofMegabytes to allocate
for disk storage for log files.

Modifying the value to a setting
that is below the default value
might cause logs to be rolled
over quickly. Consequently, log
entries might be lost, which can
affect troubleshooting.

Note

Max Log Directory
Size

License Thresholds

NoPositive
integer less
than or equal
to 100 and
greater than
the warning
threshold.

97%Percentage of licenses in use required to
reach critical licensing state.

Critical Threshold

NoPositive
integer less
than the
critical
threshold and
greater than
the safe
threshold.

94%Percentage of licenses in use required to
reach warning licensing state.

Warning Threshold
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Restart
Required

RangeDefaultDescriptionProperty

NoPositive
integer less
than the
warning
threshold and
greater than 0.

90%Percentage of licenses in use required to
reach safe licensing state.

Safe Threshold

Configuration: Primary Syslog Settings

NoValid IP
address or
hostname.

NoneHostname or IP address of Primary Syslog
Server to send syslog events from a CVP
Application.

Primary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers
between 1 and
65535.

NonePort number of Primary Syslog Server.Primary Syslog
Server Port Number

NoValid IP
address or host
name.

NoneHostname or IP address of the Primary
Backup Syslog Server to send syslog events
from a CVP Application when the Syslog
Server cannot be reached.

Primary Backup
Syslog Server

NoAny available
port number.
Valid port
numbers are
integers
between 1 and
65535.

NonePort number of Primary Backup Syslog
Server.

Primary Backup
Syslog Server Port
Number

Configuration: Secondary Syslog Settings

NoValid IP
address or
hostname.

NoneHostname or IP address of Secondary
Syslog Server to send syslog events from
a CVP Application.

Secondary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers
between 1 and
65535.

NonePort number of Secondary Syslog Server.Secondary Syslog
Server Port Number
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Restart
Required

RangeDefaultDescriptionProperty

NoValid IP
address or
hostname.

NoneHostname or IP address of the Secondary
Backup Syslog Server to send syslog events
from a CVP Application when the Syslog
Server cannot be reached.

Secondary Backup
Syslog Server

NoAny available
port number.
Valid port
numbers are
integers
between 1 and
65535.

NonePort number of Secondary Backup Syslog
Server.

Secondary Backup
Syslog Server Port
Number

License Thresholds
Three thresholds (safe, warning, and critical) describe the percentage of licenses in use required to reach their
respective licensing state. If using a license or releasing a license causes the number of licenses currently in
use to cross a threshold (in either direction), the state of licensing will be that of the threshold.

This does not always mean the state will change. For example, if there are 100 total licenses and the Safe,
Warning, and Critical license thresholds are set to the defaults of 90%, 94%, and 97%, and there are 89 licenses
in use, licenses are at a Safe level. When the licenses in use reach 94, license state changes from Safe to
Warning level. If one more license is used (95), the license state remains at theWarning level. If three licenses
are released (no longer in use), 92 licenses remain in use and the license state remains at the Warning level.
Once the licenses in use reach the previous threshold (90), the state changes from Warning to Safe.

Edit Unified CVP Call Server
You can change the configuration for a Unified CVP Call Server.
Related Topics

Add Unified CVP Call Server, on page 6
Apply Unified CVP Call Server License, on page 34
Shut Down Server
Start Server
Upload Log Messages XML File, on page 65
Download Log Messages XML File, on page 63
View Unified CVP Call Server Statistics, on page 32
View Device Status

Procedure
To edit a Unified CVP Call Server:

Step 1 Select Device Management > Unified CVP Call Server.

The Find, Add, Delete, Edit window opens.
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Step 2 Select a Unified CVP Call Server by clicking the link in the Hostname field or by clicking the radio button preceding it,
and then clicking Edit.

The Edit Unified CVP Call Server Configuration window opens with the current settings displayed.

Step 3 If you have not already applied a license to the Unified CVP Call Server, select File Transfer in the toolbar and then
click Licenses.

The Licenses page opens. See Applying a License to a Unified CVP Call Server.

Step 4 Change the desired configuration settings on the General tab as described in Unified CVP Call Server Settings, on page
33.

You cannot change the IP Address.

Step 5 Optionally, click the Change Type button to change the services that are turned on for this Unified CVP Call Server.
Step 6 Select the appropriate tab and change the desired settings:

Configuration Tabs:

• Set Up ICM Service, on page 10

• Set Up IVR Service, on page 14

• Set Up SIP Service, on page 13

• Add or Remove Device From Device Pool

• Set Up Infrastructure, on page 27

Step 7 When you finish configuring the Unified CVP Call Server, click Save to save the settings, or click Save & Deploy to
save the changes and apply them to the Unified CVP Call Server.

Step 8 If you changed a configuration setting that requires a restart, shut down and start the Unified CVP Call Server.

Configuration settings that require a restart of the Unified CVP Call Server are identified in Unified CVP Call Server
Settings, on page 33.

Delete Unified CVP Call Server
Deleting a Unified CVP Call Server deletes the configuration of the selected Unified CVP Call Server in the
Operations Console database and removes the Unified CVP Call Server from the displayed list of Unified
CVP Call Servers.

Procedure
To delete a Unified CVP Call Server:

Step 1 Select Device Management > Unified CVP Call Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Unified CVP Call Server by clicking the radio button preceding it and then clicking Delete.
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Step 3 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.

Find Unified CVP Call Server
Use the following procedure to locate a Unified CVP Call Server that has been added in the Operations
Console.

Procedure
To find a Unified CVP Call Server:

Step 1 Select Device Management > Unified CVP Call Server from the Main menu.

The Find, Add, Delete, Edit window lists the available Unified CVP Call Servers sorted by name, 10 at a time.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
screen to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname, selecting a modifier such as begins with, entering
your search term, and then clicking Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

View Unified CVP Call Server Statistics
You can view realtime, interval, and aggregate data for the services enabled on a Unified CVP Call Server.
Related Topics

SIP Service Call Statistics
IVR Service Call Statistics
Infrastructure Statistics

Procedure
To view device statistics:

Step 1 Select Device Management > Unified CVP Call Server.

The Find, Add, Delete, Edit window opens.

Step 2 Find the Unified CVP Call Server by using the procedure in Find Unified CVP Call Server, on page 32.
Step 3 From the list of matching records, select the Unified CVP Call Server that you want to edit.
Step 4 Click Edit.

The Edit Unified CVP Call Server Configuration window opens with the current settings displayed.

Step 5 Click the Statistics icon in the toolbar.
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Statistics are reported for the selected device.

Unified CVP Call Server Settings
If you are adding a Call Server (Add Unified CVP Call Server) or editing a Call Server (Edit Unified CVP
Call Server), you can configure the Call Server by filling in or changing values for one or more of these
settings.

Table 5: Call Server Configuration Settings

Restart
Required

RangeDefaultDescriptionProperty

General

NoValid IP addressNoneThe IP address of the Call ServerIP Address

NoA valid DNS
name, which
includes
uppercase and
lowercase letters
in the alphabet,
the numbers 0
through 9,and a
dash

NoneThe hostname of the Call ServerHostname

No0 - 1024
characters

NoneThe description of the Call ServerDescription

YesEnabled or
Disabled

NoneSelect to enable secure communications
between the Operations Console and the
Call Server. The device is accessed using
SSH and files are transferred using HTTPS.

Youmust configure secure communications
before you enable this option. For more
information, see the Configuration Guide
for Cisco Unified Customer Voice Portal.

Enable Secure
Communication with
the Ops Console

Read OnlyRead OnlyRead
Only

Lists the Release and Build Number for this
device.

Device Version

Services

YesNot applicableNoneEnables the Call Server to communicate
with an ICM Server. The ICM Server must
be configured in the Operations Console.

ICM
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Restart
Required

RangeDefaultDescriptionProperty

YesNot applicableNoneThe IVR Service creates VXML pages that
implement the Micro-Applications, based
on Run Script instructions received from
the ICM Server. The VXML pages are sent
to the VXML Gateway to be executed.

IVR

YesNot applicableNoneSession Initiation Protocol (SIP), RFC
3261, is the primary call control protocol
in Unified CVP. The SIP Service uses SIP
to communicate with other Unified CVP
solution components, such as the SIP Proxy
Server, the VXML and Ingress Gateways,
and Cisco Unified Communications
Manager SIP trunks and SIP phones.

Configure the SIP service if you are adding
a new Call Server or editing a Call Server
and you are using the Call Director or
Comprehensive call flow models.

SIP

Apply Unified CVP Call Server License
When you are creating a new Unified CVP Call Server, you must apply a valid license file before configuring
the server. You can browse and upload the license file to the Operations Console, and then transfer the license
to the server. You can select either an existing license file in the Operations Console database or a new license
file from your local PC. For more information on licensing, see Unified CVP Licensing, on page 5.

Procedure
To apply a license file:

Step 1 Select Device Management > Unified CVP Call Server.

The Find, Add, Delete, Edit window lists any Unified CVP Call Servers that have been added to the Operations Console.

Step 2 Select a Unified CVP Call Server by clicking the link in the Hostname field or by clicking the radio button preceding it,
and then clicking Edit.

The Edit Unified CVP Call Server Configuration window opens.

Step 3 Select File Transfer in the toolbar, and then click Licenses.

The File Transfer page opens.

Step 4 If the license file is not listed in the Select From Available License Files text box:
a) Click Select a license file from your local PC.
b) Enter the fully qualified file name in the text box or clickBrowse to search for the license file on the local file system.

Step 5 If the license is listed in the Select From Available License Files text box, select the license file.
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Step 6 Click Transfer to transfer the selected license file to the Unified CVP Call Server.
Step 7 Shut down and start the Unified CVP Call Server.

The Operations console renames the license file to cvp.license under the folder on the machine to which
the file is transferred. If the file cvp.license already exists in the folder, the old cvp.license file will be
deleted first, and then replaced with the new cvp.license file.

Unified CVP Reporting Server Setup
From the Unified CVP Reporting Server option in the Device Management menu, you can configure one or
more Unified CVP Reporting Servers.

Reporting provides historical reporting to a distributed self-service deployment in a call center. The Unified
CVP Reporting Server receives reporting data from one or more Unified CVP Call Servers and Unified CVP
VXML Servers, and stores that data in an Informix database. Call data is stored in a relational database, on
which you can write custom reports. Administrators can use the Operations Console to schedule data removal
(delete) and database backups. Multiple Unified CVP Call Servers can send data to a single Unified CVP
Reporting Server.

You can use third-party reporting tools such as Crystal Reports to generate and view reports on call data.
Unified CVP provides four sample Crystal report templates. One of the included templates provides an example
of joining Unified CVP and ICM data to create a comprehensive report.

Before you start with any of the following tasks, connect to the remote desktop of the Reporting Server machine
and add a user for the Cisco CVP WebServicesManager:

1. Open services.msc.

2. Right click Cisco CVP WebServicesManager and select Properties.

3. Select the Logon tab and add the Administrator credentials under this account.

4. Restart the Cisco CVP WebServicesManager service.

Note

You can perform the following tasks:

Add Unified CVP Reporting Server
Create a new Unified CVP Reporting Server either by using an existing Unified CVP Reporting Server
configuration as a template or by filling in its values from scratch.

Before You Begin

You must configure the Unified CVP Call Server to associate with the Unified CVP Reporting Server before
configuring the Unified CVP Reporting Server.

Collect the following information about the Unified CVP Reporting Server and Reporting Database during
the installation of Unified CVP software:

Managing Devices
35

Managing Devices
Unified CVP Reporting Server Setup



Procedure

• Hostname of the Call Servers associated with the Unified CVP Reporting Server

A Call Server can only be associated with one Unified CVP Reporting Server.Note

• Hostname and IP address of the server on which the Reporting Database resides
• Password for the Reporting Database user

Procedure
To add a Unified CVP Reporting Server:

Step 1 Select Device Management > Unified CVP Reporting Server.

A window listing Unified CVP Reporting Servers opens.

To use an existing Unified CVP Reporting Server as a template for creating the new Unified CVP Reporting
Server, select the Unified CVP Reporting Server by clicking the radio button preceding it and then click Use
As Template.

Note

Step 2 Click Add New.

The Unified CVP Reporting Server Configuration window opens to the General Tab.

Step 3 Fill in the IP Address and hostname for the Unified CVP Reporting Server and fill in any other desired information.
Step 4 Optionally, clickEnable secure communications with the Ops Console to secure communications between theOperations

Console and the Unified CVP Call Server.
Step 5 Associate one or more Unified CVP Call Servers to the Unified CVP Reporting Server by selecting a Unified CVP Call

Server listed in the Available pane and clicking the right arrow to add it to the Selected pane.
Step 6 Select the Reporting Properties tab and configure reporting properties.
Step 7 Optionally, select the Device Pool tab and add the Unified CVP Reporting Server to a device pool.
Step 8 Optionally, select the Infrastructure tab and configure log file and syslog settings.
Step 9 When you finish configuring the Reporting Server, click Save to save the settings in the Operations Server database.

Click Save & Deploy to deploy the changes to the Unified CVP Reporting Server page.

Related Topics
Delete Reporting Server, on page 49
Edit Unified CVP Reporting Server, on page 41
General Unified CVP Reporting Server Information Setup, on page 37
Reporting Properties Setup, on page 38
Add or Remove Device From Device Pool
Unified CVP Reporting Server Infrastructure Settings, on page 38
Device Information Field Descriptions, on page 2
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General Unified CVP Reporting Server Information Setup
You can configure settings that identify the Unified CVP Reporting Server, associate it with one or more
Unified CVP Call Servers, and enable or disable security on the General Tab.

Table 6: Unified CVP Reporting Server General Tab Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

YesValid IP addressNoneThe IP address of the Unified
CVP Reporting Server

IP Address

YesValid DNS name,
which can include
letters in the
alphabet, the
numbers 0
through 9

NoneThe host name of the Unified
CVP Reporting Server
machine

Hostname

NoUp to 1024
characters

NoneAn optional text description
for theUnified CVPReporting
Server

Description

NoOn or OffOffSelect to enable secure
communications between the
Operations Server and this
component. The Unified CVP
Reporting Server is accessed
using SSH and files are
transferred using HTTPS.

You must configure secure
communications before you
enable this option. For more
information, see the
Configuration Guide for Cisco
Unified Customer Voice
Portal.

Enable Secure
Communication
with the Ops
Console

Read OnlyRead OnlyRead OnlyLists the Release and Build
Number for this device.

Device Version
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Restart RequiredRangeDefaultDescriptionField

NoA given Unified
CVP Call Server
can only be
associated with
one Unified CVP
Reporting Server.

NoneSelect one or more Call
Servers to associate with the
Unified CVP Reporting
Server. You must select at
least one Unified CVP Call
Server. Call data for all SIP,
and VXML calls handled by
this Unified CVP Call Server
are stored in the Reporting
Database. Click the right
arrow to add a Call Server to
the Selected pane.

Click the left arrow to remove
a Unified CVP Call Server
from the Selected pane.

Associate
Unified CVP
Call Server(s)

Reporting Properties Setup
You can configure Reporting Server settings on the Reporting Properties Tab.

Table 7: Reporting Server Reporting Properties Tab Configuration Settings

Restart
Required

RangeDefaultDescriptionField

Configuration

YesYes or NoYesEnables the Reporting Server to
receive call data from the associated
Call Server(s).

Enable Reporting

No1 through 250
MB

100Defines the maximum size of the file
used to record the data feed
messages during a database failover.
This can be limited by the amount
of free disk space.

Max. File Size (MB):

Unified CVP Reporting Server Infrastructure Settings
The Unified CVP Reporting Server publishes statistics on the number of reporting events received from the
Unified CVP VXML Server, the SIP Service, and the IVR Service. It also publishes the number of times the
Reporting Server writes data to the Reporting database. You can configure the interval at which the Reporting
Server publishes these statistics, the maximum log file and directory size, and the details for recording syslog
messages on the Reporting Server Infrastructure tab.
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Table 8: Unified CVP Reporting Server Infrastructure Tab Configuration Settings

Restart RequiredRangeDefaultDescriptionField

Configuration: Thread Management

Yes100 - 525525(Required) The maximum thread
pool size in the Reporting Server
Java Virtual Machine.

Maximum
Threads

Advanced

Yes10 - 144030
minutes

TheUnifiedCVPReporting Server
publishes statistics at this interval.

Statistics
Aggregation
Interval

Log File Properties

Yes1 through 100
MB

10 MB(Required) Maximum size of the
log file in megabytes. The log file
name follows this format:
CVP.DateStamp.SeqNum.log

example:

For example:
CVP.2006-07-04.00.log

After midnight each day, a new log
file is automatically created with
a new date stamp. When a log file
exceeds the max log file size, a
new one with the next sequence
number is created, for example,
when CVP.2006-07-04.00.log

reaches 5 Mb,
CVP.2006-07-04.01.log is
automatically created.

Max Log File
Size

Yes500 - 500000
MB

Max Log File
size < Max Log
Directory Size

Max Log File
size > 1

Max Log Dir
Size / Max Log
File Size cannot
be greater than
5000

20000MB(Required) Maximum size of the
directory containing Unified CVP
Reporting Server log files.

Modifying the value to
a setting that is below
the default value might
cause logs to be rolled
over quickly.
Consequently, log
entries might be lost,
which can affect
troubleshooting.

Note

Max Log
Directory Size

Configuration: Primary Syslog Settings
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Restart RequiredRangeDefaultDescriptionField

NoValid IP address
or hostname.

NoneHostname or IP address of Primary
Syslog Server to send syslog
events from a CVP Application.

Primary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Primary Syslog
Server.

Primary Syslog
Server Port
Number

NoValid IP address
or hostname.

NoneHostname or IP address of the
Primary Backup Syslog Server to
send syslog events from a CVP
Application when the Syslog
Server cannot be reached.

Primary Backup
Syslog Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Primary Backup
Syslog Server.

Primary Backup
Syslog Server
Port Number

Configuration: Secondary Syslog Settings

NoValid IP address
or hostname.

NoneHostname or IP address of
Secondary Syslog Server to send
syslog events from a CVP
Application.

Secondary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Secondary Syslog
Server.

Secondary Syslog
Server Port
Number

NoValid IP address
or hostname.

NoneHostname or IP address of the
Secondary Backup Syslog Server
to send syslog events from a CVP
Application when the Syslog
Server cannot be reached.

Secondary
Backup Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Secondary Backup
Syslog Server.

Secondary
Backup Syslog
Server Port
Number
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Edit Unified CVP Reporting Server

Procedure
To edit a Unified CVP Reporting Server:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Unified CVP Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding
it, and then clicking Edit.

The Edit Reporting Server Configuration window opens.

Step 3 If you have not already applied a license, select File Transfer in the toolbar and then click Licenses.

The File Transfer page opens.

Step 4 On the General tab, change the desired general information. You cannot change the IP address of the Reporting Server.
Step 5 Select the Reporting Properties tab and edit the reporting properties.
Step 6 Optionally, you can select the Device Pool tab and add or remove the Reporting Server from a device pool.
Step 7 Optionally, you can select the Infrastructure tab and change log file and syslog settings.
Step 8 When you finish configuring the Unified CVP Reporting Server, click Save to save the settings in the Operations Console

database. Click Save & Deploy to deploy the changes to the Unified CVP Reporting Server.

Related Topics
Delete Reporting Server, on page 49
Add Unified CVP Reporting Server, on page 35
Reporting Properties Setup, on page 38
Add or Remove Device From Device Pool
Find Reporting Server, on page 50
Device Information Field Descriptions, on page 2

Change Reporting Database User Password
The Unified CVP installation procedure creates the following two user accounts and sets an initial password
for each account. You can change these passwords from the Reporting Server screen in edit mode, but you
can only change one user password at a time.

Procedure

• Unified CVP Database Administrator - Uses the Operations Console to run backups, check database
used space, and add and remove Reporting users.

• Unified CVP Database User - Connects, inserts, and updates records in the Informix database. This user
cannot modify the Reporting schema.

Procedure

To change a reporting database user password:
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Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then
clicking Edit.

The Edit Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select the Database Administration menu in the toolbar, then select Change User Passwords.

The Reporting Server: Change User Passwords page opens, displaying the IP address and hostname for the currently
selected Reporting Server.

Step 4 In the User field, use the drop-down menu to select the user whose password you want to change.
Step 5 In the Old Password field, enter the existing password for that user.
Step 6 In the New Password field, enter the new password.

Passwords must follow guidelines for secure passwords.Note

Step 7 In the Reconfirm Password field, retype the new password.
Step 8 Click Save & Deploy to save the changes to the Operations Console database and deploy them to the Reporting Server.

Reporting User Management
The cvp_dbadmin should create reporting users to run reports against the Reporting database. Reporting users
should have read-only access to the Reporting database, so they cannot accidentally modify the database
schema or data.

Add New Reporting Users

To add a new reporting user to the Reporting Server:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then
clicking Edit.

You can also search for a Reporting Server.

The Edit Reporting Server Configuration window opens.

Step 3 Select the Database Administration menu in the toolbar, and then select Manage Reporting Users.

The Reporting Server: Manage Users windows opens, listing the IP address and host name for the selected Reporting
Server.

Step 4 In the Manage Users pane, click Add User.
Step 5 Enter the name for the user in the Username field.
Step 6 Enter a password for the new user in the Password field.
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Step 7 Retype the password in the Reconfirm Password field.
Step 8 Click Add to add the user.

Change Reporting User Password

To change a reporting user's password:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking on the link in the Hostname field or by clicking the radio button preceding it, and
then clicking Edit.

You can also search for a Reporting Server.

The Edit Reporting Server Configuration window opens.

Step 3 Select the Database Administration menu in the toolbar, and then select Manage Reporting Users.

The Reporting Server: Manage Users window opens, listing the IP address and hostname for the currently selected
Reporting Server.

Step 4 In the Manage Users pane, click Change Password.
Step 5 From the Available users list, select the user whose password you want to change and click the left arrow. The user name

is displayed in Username field.
Step 6 Type the original password in Old Password field.
Step 7 In the New Password field, type the new password.
Step 8 In the Reconfirm Password field, retype the new password.
Step 9 Click Change to make the change.

Remove Reporting Users

To remove a reporting user from the Reporting Server:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then
clicking Edit.

You can also search for a Reporting Server.

The Edit Reporting Server Configuration window opens.

Step 3 Select Database Administration in the toolbar, then select Manage Reporting Users.

The Reporting Server: Manage Users window opens, listing the IP address and host name for the currently selected
Reporting Server.
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Step 4 From the Available users list, select the user to remove and click the left arrow. The user is displayed in the Username
field.

Step 5 Enter the Database Administrator password.
Step 6 Click Delete to delete the selected user.

Run Reporting Database Backup
By default, Reporting Database backups are disabled. You can choose to schedule backups of the Reporting
database or run backups on demand. When you enable backups, files are saved to the Reporting Server's local
file system. You are responsible for managing backed-up files. Scheduled backups occur once each day. You
can configure the time of day at which backups occur. A maximum of two backups and a minimum of one
backup will be available at any time on the local machine.

Procedure

To run a reporting database backup:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it and then
clicking Edit.

The Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select the Database Administration menu in the toolbar, then select Reporting Database Backups.

The Reporting Server - Database Backup Activities page opens. The IP address and host name for the currently selected
Reporting Server are listed.

Step 4 To launch a backup immediately, click Backup Now. To schedule a time for daily backups, select Schedule Daily
Backups and then select the hour and minute of the start time.

Step 5 Enter your cvp_dbadmin password and click Save & Deploy.

Related Topics
Change Reporting Database User Password, on page 41
Set Up Reporting Database Delete, on page 45
Cancel Reporting Database Backup, on page 44
Reporting User Management, on page 42
View Database Details, on page 47
View Reporting Statistics, on page 48

Cancel Reporting Database Backup
By default, Reporting Database backups are disabled. You can choose to schedule backups of the Reporting
database or run backups on demand. You can cancel daily backups at any time.
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Procedure

To cancel a reporting database backup:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking on the link in the Hostname field or by clicking the radio button preceding it, and
then clicking Edit.

The Edit Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select the Database Administration menu in the toolbar, and then select Reporting Database Backups.

The Reporting Server - Database Backup Activities page displays. The IP address and host name for the currently selected
Reporting Server are listed.

Step 4 Click Cancel Daily Backups.
Step 5 Enter your cvp_dbadmin Password and Save & Deploy.

Related Topics
Change Reporting Database User Password, on page 41
Set Up Reporting Database Delete, on page 45
Reporting User Management, on page 42
View Database Details, on page 47
View Reporting Statistics, on page 48

Set Up Reporting Database Delete
You can delete call data from the Reporting Database. Data Delete is run daily at the time you specify. Each
category of call data is retained for a default number of days, before being deleted.

Procedure

To configure Reporting Database Delete settings:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then
clicking Edit.

The Edit Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select the Database Administration menu in the toolbar, and then select Data Delete.

The Reporting Server - Database Delete Settings page opens displaying the IP address and host name for the currently
selected Reporting Server.

Step 4 In the Data Delete section of the page, you can change the data retention time for each category of data.
Step 5 Select the hours and minutes to run the delete each day.
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Step 6 Enter your cvp_dbadmin password and click Save & Deploy.

Related Topics
Run Reporting Database Backup, on page 44
Cancel Reporting Database Backup, on page 44
Change Reporting Database User Password, on page 41
Reporting User Management, on page 42
View Database Details, on page 47
View Reporting Statistics, on page 48

Reporting Data Category Deletion
Using the Operations Console, you can select the time of day to run database delete, and set the number of
days that the data is retained by data category. The following table describes each category of data that you
can delete from the Reporting Database and lists the default number of days that this data is kept before
purging. A high level category, such as Call, cannot have a lower retention time than a dependent category,
such as Call Event.

Choosing how much data is to be retained is a sensitive matter. If a database space fills up, then the database
is able to continue processing until data is deleted. This is complicated by the fact that when Informix increases
its extent for a table within the data file, due to data growth, extension remains even after the data is deleted.
This causes space within the file to be reserved even if actual space is no longer needed. The only way to
regain the space is to rebuild the table.

Emergency delete is a critical safety mechanism. If used space has grown past the system's threshold, the
Reporting Server creates an SNMP trap and the data is deleted. The SNMP notification alerts the user to the
loss of data and the data is deleted.

Table 9: Number of Days to Retain Data Before Purging

DefaultDescriptionData Category

30Detailed information about calls received by Unified CVP.Call

30Call state change event messages published by the Call Server
and Unified CVP VXML Server. SIP and IVR services publish
call state change event messages when a SIP call changes its state.
These states include call initiated, transferred, terminated, aborted,
or an error state.

Call Event

30VXML session data includes application names, session ID, and
session variables. Session variables are global to the call session
on the Unified CVP VXML Server. Unlike element data, session
data can be created and modified by all components (except the
global error handler, hotevents, and XML decisions).

VXML Session

15A VXML element is a distinct component of a voice application
call flow whose actions affect the experience of the caller. A
VXML element contains detailed script activity to the element
level, such as, Call Identifiers, activity time stamp, VXML script
name, name and type of the VXML element, and event type.

VXML Element
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DefaultDescriptionData Category

15Expanded Call Context (ECC) variables that are included in
VXML data. Unified CVP uses ECC variables to exchange
information with Unified ICME.

VXML ECC Variable

15Application detailed data at the script element level from the
Unified CVPVXMLServer call services. This data includes input
mode, utterance, interpretation, and confidence.

VXML Voice Interact Detail

15VXML session variables are global to the call session on the
Unified CVP VXML Server.

VXML Session Variable

15The names and values of element variables.VXML Element Detail

15Retention days for Courtesy Callback reporting dataCallback

15Retention days for Gateway Trunk Utilization reporting dataTrunk Utilization Usage

The data categories are hierarchical. For example, Call data includes Call Event and VXML Session data.

VXML Session Data Categories:

• VXML Element

• VXML ECC Variable
• VXML Voice Interact Detail
• VXML Session Variable
• VXML Element Detail

A high level category, such as Call, cannot have a lower retention time than a dependent category, such as
CallEvent.

Note

View Database Details
You can view the size of a Reporting database.

Procedure

To view database details:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then
clicking Edit.

The Edit Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select the Database Administration menu in the toolbar, and then select Database Details.
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The Reporting Server - Disk Drives: Housing Database Files page opens, displaying the IP address and host name for
the currently selected Reporting Server along with the following database information:

Reporting Database Details:

• Database Name - Name of the database.

• Total Size (MB) - Total data size.

When the usage of the database increases beyond 200 GB, it starts occupying the head room space. In this
scenario, the free size is shown as 0(zero) bytes.

Note

• Free size (MB) - Amount of space that has not been taken by extents.

• Used Size (MB) - Data space used.

• Extent size (MB) - Space reserved for tables. This size may be greater than the total size.

• % Free Size - The percent of space that has not been extended (reserved). This might be greater than 100 percent.

Related Topics
Run Reporting Database Backup, on page 44
Cancel Reporting Database Backup, on page 44
Change Reporting Database User Password, on page 41
Set Up Reporting Database Delete, on page 45
Reporting User Management, on page 42
View Reporting Statistics, on page 48

View Reporting Statistics
Reporting Server statistics include the total number of events received from the IVR, SIP, and VXML services.

Procedure

To get Reporting Server statistics:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window opens.

Step 2 Select a Unified CVP Reporting Server by clicking the link in the Hostname field or by clicking the radio button preceding
it, and then clicking Edit.

The Edit Unified CVP Reporting Server Configuration window opens with the current settings displayed.

Step 3 Select Statistics in the toolbar.

The Unified CVP Reporting Server Statistics are listed in the Reporting tab.

Related Topics
Run Reporting Database Backup, on page 44
Cancel Reporting Database Backup, on page 44
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Change Reporting Database User Password, on page 41
Set Up Reporting Database Delete, on page 45
Reporting User Management, on page 42
View Database Details, on page 47

Delete Reporting Server
You can remove a Reporting server from the Operations Console. Deleting a Reporting Server removes its
configuration from the Operations Console database and removes the Reporting Server from the displayed
list of Reporting Servers.

Procedure
To delete a reporting server:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window displays.

Step 2 Find the Reporting Server to delete by using the procedure in Find Reporting Server, on page 50.
Step 3 From the list of matching records, choose the Reporting Server that you want to delete.
Step 4 Click Delete.
Step 5 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.

Related Topics
Add Unified CVP Reporting Server, on page 35

Apply Reporting Server License
When you are creating a new Unified CVP Reporting Server, apply a valid license file before using the server.
You can browse for and upload the license file to the Operations Console, and then transfer the license to the
Reporting Server. Select either an existing license file in the Operations Console database or a new license
file from your local PC.
Related Topics

Unified CVP Licensing, on page 5
Find Device, on page 3

Procedure
To apply a license file:

Step 1 Select Device Management > Unified CVP Reporting Server.

The Find, Add, Delete, Edit window lists any Reporting Servers that have been added to the Operations Console.

Step 2 Select a server by clicking the link in the Hostname field or by clicking the radio button preceding it, and then clicking
Edit.
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Step 3 Select File Transfer in the toolbar and then click Licenses.

The File Transfer page displays, listing the Hostname and IP Address for the currently selected Reporting Server.

Step 4 If the license file is not listed in the Select From Available License Files text box:
a) Click Select a License File from Your Local PC.
b) Enter the file name in the text box or click Browse to search for the license file on the local file system.

Step 5 If the license is listed in the Select From Available License Files text box, select the license file.
Step 6 Click Transfer to transfer the selected license file to the selected device.

The license is applied to the selected server.

The Operations Console renames the license file to cvp.license under the directory on the machine to which
the file is transferred. If the file cvp.license already exists in the directory, the old cvp.license file is deleted
first, and then replaced with the new cvp.license file.

Find Reporting Server
The Operations Console lets you locate a Reporting Server on the basis of specific criteria. Use the following
procedure to locate a Reporting Server.

Procedure
To find a Reporting Server:

Step 1 Choose Device Management > Unified CVP Reporting Server.

A list of the available Reporting Servers appears, 10 devices per screen, sorted by name.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the numbered
page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Unified CVP VXML Server Setup
The Unified CVP VXML Server is an optional J2EE-compliant application server that provides a solution
for rapidly creating and deploying dynamic VXML applications. If you installed a Unified CVP VXML
Server, you must configure it before using it to deploy VXML applications or licenses.

If you are using a VXML gateway to route calls from the Unified CVP VXML Server, but want to use the
Unified CVP reporting feature, install the Call Server and Reporting Server on the same physical machine.
Configure the Call Server with no call services enabled, then configure the Reporting Server and select the
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Call Server that is installed on the samemachine (same IP address) as the primary call server for the Reporting
Server.

To make requests to an ICM server, without relinquishing control of the call or use Unified CVP reporting,
youmust configure the Unified CVPVXMLServer to use a Call Server with at least the ICMService enabled.

You can perform the following tasks:

• Add Unified CVP VXML Server

• Edit Unified CVP VXML Server

• Delete Unified CVP VXML Server

• Upload Log Messages XML File

• Download Log Messages XML File

• VXML Application File Transfers

• Apply Unified CVP VXML Server License

• Find Unified CVP VXML Server

• Viewing Device Status

Add Unified CVP VXML Server
Before You Begin

Before adding a VXML Server to the Operations Console, ensure that you have done the following:

Procedure

• Collect the hostname or IP address of the Unified CVP VXML Server during the installation of Unified
CVP software.

• Install and configure at least one Call Server before configuring the Unified CVP VXML Server.

You do not need to install a Call Server if you are adding a Unified CVP VXML Server (standalone).Note

• Review Call Studio scripts, noting any of the following items you want to include or exclude fromUnified
CVP VXML Server reporting data:
a) Application names
b) Element types
c) Element names
d) Element fields
e) ECC variables

Procedure
To add a Unified CVP VXML Server:
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Step 1 Choose Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit Unified CVP VXML Servers window opens.

To use an existing Unified CVP VXML Server as a template for creating the new VXML Server, select the
Unified CVP VXML Server by clicking the radio button preceding it and then click Use As Template.

Note

Step 2 Click Add New.

The Unified CVP VXML Server Configuration window opens to the General Tab.

Step 3 Fill in the IP Address and Hostname fields and a primary Call Server.
Step 4 Optionally, clickEnable secure communications with the Ops Console to secure communications between theOperations

Console and the Call Server.
Step 5 Select each tab and verify that the default values are correct or change the values if desired:

Configuration tabs:

• Unified CVP VXML Server Configuration Properties, on page 55

• Unified CVP VXML Server Infrastructure Settings, on page 57

• Add or Remove Device From Device Pool

Step 6 When you finish configuring the Unified CVP VXML Server, click Save to save the settings in the Operations Console
database. Click Save & Deploy to apply the changes to the Unified CVP VXML Server.

Step 7 Shut down and then start the Unified CVP VXML Server and the primary and backup Call Servers.

Related Topics
Unified CVP VXML Server General Properties, on page 54
Unified CVP VXML Server Configuration Properties, on page 55
Unified CVP VXML Server Infrastructure Settings, on page 57
Add or Remove Device From Device Pool
Shut Down Server
Start Server

Edit Unified CVP VXML Server
You can edit the configuration for a Unified CVPVXMLServer that has been added to the Operations Console.

Procedure
To edit a Unified CVP VXML Server configuration:

Step 1 Choose Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit Unified CVP VXML Servers window opens.

Step 2 You can search for a VXML Server by using the procedure in the Finding a Unified CVP VXML Server topic.
Step 3 From the list of matching records, choose the Unified CVP VXML Server that you want to edit.
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Step 4 Click Edit.

The Unified CVP VXML Server Configuration window opens to the General Tab.

Step 5 Change any general server information. You cannot change the IP address of the VXML Server.
Step 6 Select the Configuration Tab, then edit Unified CVP VXML Server properties.
Step 7 Optionally, you can select the Device Pool tab and add or remove the Unified CVP VXML Server from a device pool.
Step 8 Optionally, you can select the Infrastructure tab and configure log file and syslog settings.
Step 9 When you finish configuring the Unified CVP VXML Server, click Save to save the settings in the Operations Server

database. Click Save & Deploy to apply the changes to the Unified CVP VXML Server.
Step 10 If instructed, shut down and then start the Unified CVP VXML Server and the primary and backup Call Servers.

Related Topics
Delete Unified CVP VXML Server, on page 53
Add Unified CVP VXML Server, on page 51
Unified CVP VXML Server Configuration Properties, on page 55
Unified CVP VXML Server General Properties, on page 54
Unified CVP VXML Server Infrastructure Settings, on page 57
Find Unified CVP VXML Server, on page 67
Shut Down Server
Start Server
Device Information Field Descriptions, on page 2

Delete Unified CVP VXML Server
Deleting a Unified CVP VXML Server from the Operations Console deletes the configuration of the selected
Unified CVPVXML Server in the Operations Console database and removes the Unified CVPVXML Server
from displayed list of Unified CVP VXML Servers.

Procedure
To delete a Unified CVP VXML Server from the Control Center:

Step 1 Choose Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit Unified CVP VXML Servers window opens.

Step 2 From the list of matching records, select the Unified CVP VXML Server that you want to delete by clicking the radio
button preceding it.

Step 3 Click Delete.
Step 4 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.
Step 5 Shut down and start the Unified CVP VXML Server and the primary and backup Call Servers.

Related Topics
Add Unified CVP VXML Server, on page 51
Transfer Script and Media Files
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Shut Down Server
Start Server
Find Unified CVP VXML Server, on page 67

Unified CVP VXML Server General Properties
You can configure settings that identify the Unified CVP VXML Server and choose a primary, and optionally,
a backup Call Server to communicate with the Reporting Server. You can also enable secure communications
between the Operations Console and the Unified CVP VXML Server.

Table 10: Unified CVP VXML Server General Configuration Settings

Restart/Reboot
Needed

RangeDefaultDescriptionField

General

NoA valid IP addressNoneThe IP address of the Unified CVP
VXML Server

IP Address

NoA valid DNS name,
which includes
uppercase and
lowercase letters in
the alphabet, the
numbers 0 through 9,
and a dash.

NoneThe host name of the Unified CVP
VXML Server. Host names must be
validDNS names, which can include
letters in the alphabet, the numbers
0 through 9, and a dash.

Hostname

NoUp to 1,024 charactersNoneThe Unified CVP VXML Server
description

Description

Yes - rebootOn or OffNoneSelect to enable secure
communications between the
Operations Server and this
component. The device is accessed
using SSH and files are transferred
using HTTPS.

Configure secure communications
before you enable this option. For
more information, see the
Configuration Guide for Cisco
Unified Customer Voice Portal.

Enable secure
communication
with the Ops
console

Read OnlyRead OnlyRead OnlyLists the Release and Build Number
for this device.

Device Version

Unified CVP Call Servers
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Restart/Reboot
Needed

RangeDefaultDescriptionField

Yes - Restart
Call Server and
Unified CVP
VXML Server

Not applicableNoneThe Unified CVP VXML Server
uses themessage service on this Call
Server to communicate with the
Reporting Server and to perform an
ICM lookup. Select a primary Call
Server from the drop-down list. The
drop-down list includes all Call
Servers added to the Operations
Console.

Primary Unified
CVP Call Server

Yes - Restart
Call Server and
VXML Server

Not applicableNoneThe Unified CVP VXML Server
uses themessage service on this Call
Server to communicate with the
Reporting Server and perform an
ICM lookup if the primary Call
Server is unreachable. Select a
backup Call Server from the
drop-down list. The drop-down list
includes all Call Servers added to
the Operations Console.

Backup Unified
CVP Call Server

When the primary Call Server is unreachable, the Unified CVP VXML Sever uses the backup Call Server to
communicate with the Reporting Server and to perform an ICM lookup. But the VXML Server does not
continuously try to re-establish a connection with the primary Call Server. The VXML Server continues to
use the backup Call Server until you restart either the Unified CVP VXML Server or the backup Call Server.

Important

Unified CVP VXML Server Configuration Properties
From the Unified CVPVXML Server Configuration tab, you can enable the reporting of Unified CVPVXML
Server and call activities to the Reporting Server. When enabled, the Unified CVP VXML Server reports on
call and application session summary data. Call summary data includes call identifier, start and end timestamp
of calls, ANI, and DNIS. Application session data includes application names, session ID, and session
timestamps.

If you choose detailed reporting, Unified CVP VXML Server application details are reported, including
element access history, activities within the element, element variables and element exit state. Customized
values added in the Add to Log element configuration area in Call Studio applications are also included in
reporting data. You can also create report filters that define which data are included and excluded from being
reported.

Table 11: Unified CVP VXML Server Configuration Settings

Restart/Reboot
Needed

RangeDefaultDescriptionField

Configuration
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Restart/Reboot
Needed

RangeDefaultDescriptionField

NoEnabled (the default)
or Disabled.

EnabledIndicates whether or not the
Unified CVP VXML Server
sends data to the Reporting
Server. If disabled, no data is
sent to the Reporting Server,
and reports do not contain any
VXML application data.

Enable Reporting for
this Unified CVP
VXML Server

NoEnabled or Disabled
(the default).

DisabledIndicates whether VXML
application details are reported.

Enable Reporting for
VXML Application
Details

Not applicableNot applicable100,000Define the maximum number
of reporting messages that will
be saved in a file if failover
occurs. (Limited by amount of
free disk space.)

Max. Number of
Messages

VXML Applications Details: Filters

Yes - Restart
VXML Server

A semicolon-separated
list of text strings. A
wildcard character (*)
is allowed within each
element in the list.

For
information
about filter
syntax and
rules, see
Inclusive
and
Exclusive
VXML
Reporting
Filter
Examples,
on page 61.

Note

NoneList of applications, element
types, element names, and
element fields, and ECC
variables to include in reporting
data.

Inclusive Filters
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Restart/Reboot
Needed

RangeDefaultDescriptionField

Yes - Restart
VXML Server

A semicolon-separated
list of text strings. A
wildcard character (*)
is allowed within each
element in the list.

For
information
about filter
syntax and
rules, see
Inclusive
and
Exclusive
VXML
Reporting
Filter
Examples,
on page 61.

Note

NoneList of applications, element
types, element names, and
element fields, and ECC
variables to exclude from
reporting data.

Exclusive Filters

Unified CVP VXML Server Infrastructure Settings
Table 12: VXML Server Infrastructure Tab Configuration Settings

Restart RequiredRangeDefaultDescriptionField

Configuration: Thread Management

Yes100 - 1000525(Required) The maximum thread
pool size in the VXMLServer Java
Virtual Machine.

Maximum
Threads

Advanced

Yes10 - 144030
minutes

The VXML Server publishes
statistics at this interval.

Statistics
Aggregation
Interval

Log File Properties
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Restart RequiredRangeDefaultDescriptionField

Yes1 through 100
MB

10 MB(Required) Maximum size of the
log file in Megabytes. The log file
name follows this format:
CVP.DateStamp.SeqNum.log

example:

For example:
CVP.2006-07-04.00.log

After midnight each day, a new log
file is automatically created with
a new date stamp. Also, when a
log file exceeds the max log file
size, a new one with the next
sequence number is created, for
example, when
CVP.2006-07-04.00.log reaches
5 Mb, CVP.2006-07-04.01.log
is automatically created.

Max Log File
Size

Yes500 - 500000
MB

Max Log File
size < Max Log
Directory Size

Max Log File
size > 1

Max Log Dir
Size / Max Log
File Size cannot
be greater than
5.000

20,000
MB

(Required) Maximum size of the
directory containingVXMLServer
log files.

Modifying the value to
a setting that is below
the default value might
cause logs to be rolled
over quickly.
Consequently, log
entries might be lost,
which can affect
troubleshooting.

Note

Max Log
Directory Size

Configuration: Primary Syslog Settings

NoValid IP address
or hostname.

NoneHostname or IP address of Primary
Syslog Server to send syslog
events from a CVP Application.

Primary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Primary Syslog
Server.

Primary Syslog
Server Port
Number
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Restart RequiredRangeDefaultDescriptionField

NoValid IP address
or hostname.

NoneHostname or IP address of the
Primary Backup Syslog Server to
send syslog events from a CVP
Application when the Syslog
Server cannot be reached.

Primary Backup
Syslog Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Primary Backup
Syslog Server.

Primary Backup
Syslog Server
Port Number

Configuration: Secondary Syslog Settings

NoValid IP address
or hostname.

NoneHostname or IP address of
Secondary Syslog Server to send
syslog events from a CVP
Application.

Secondary Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Secondary Syslog
Server.

Secondary Syslog
Server Port
Number

NoValid IP address
or hostname.

NoneHostname or IP address of the
Secondary Backup Syslog Server
to send syslog events from a CVP
Application when the Syslog
Server cannot be reached.

Secondary
Backup Syslog
Server

NoAny available
port number.
Valid port
numbers are
integers between
1 and 65535.

NonePort number of Secondary Backup
Syslog Server.

Secondary
Backup Syslog
Server Port
Number

Inclusive and Exclusive VXML Reporting Filters
You use Inclusive and Exclusive VXML filters to control the data that the Unified CVP VXML Server feeds
to the Reporting Server.

Data feed control is crucial for:

• Saving space in the reporting database.

• Preserving messaging communication bandwidth.
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Procedure
To configure inclusive and exclusive filters for a Reporting Server:

Step 1 Choose Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit Unified CVP VXML Servers window opens.

Step 2 You can search for a Unified CVP VXML Server by using the procedure in the Finding a Unified CVP VXML Server
topic.

Step 3 From the list of matching records, choose the Unified CVP VXML Server that you want to edit.
Step 4 Click Edit.

The Unified CVP VXML Server Configuration window opens to the General Tab.

Step 5 Select the Configuration Tab, then configure Unified CVP VXML Server properties.
Step 6 In the VXML Applications Details: Filters pane, enter an inclusive filter that defines the VXML elements to include

in data sent to the Reporting Server.
Step 7 Optionally, enter an exclusive filter that excludes some of the data specified by the inclusive filter.
Step 8 When you finish configuring filters, click Save to save the settings in the Operations Console database or click Save &

Deploy to save and apply the changes to the Unified CVP VXML Server.
Step 9 Shut down and then start the Unified CVP VXML Server and the primary and backup Call Servers.

Related Topics
VXML Inclusive and Exclusive Filter Rules, on page 60
Inclusive and Exclusive VXML Reporting Filter Examples, on page 61

VXML Inclusive and Exclusive Filter Rules
Inclusive and exclusive filters operate using the following rules:

• Filters are case sensitive.

• By default, all items except the Start, End, Subdialog_Start and Subdialog_End elements are filtered
from reporting data unless they are added to an Inclusive Filter. The Subdialog_Start and Subdialog_End
elements are never filtered from reporting data unless Reporting is disabled on the Unified CVP VXML
Server.

• The Exclusive Filter takes precedence over the Inclusive Filter. For example, if an application name is
in the Exclusive Filter, then the items of that applications are excluded from reporting data even if a
particular field or element is listed in the Inclusive filter.

• The syntax for Inclusive/Exclusive filters is:

Appname.ElementType.ElementName.FieldName

or

AppName.*.*.SESSION:Varname

This syntax indicates session variables.Note
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• Use a semicolon (;) to separate each item in a filter. For example, ElementA ; ElementB is valid.

• Use a single wildcard (*) anywhere within the application name, element type, element name, or field
name.

• Element types, element names, and field names can contain alphanumeric characters, underscores, and
a space character.

• An application name can contain alphanumeric characters and underscores, but the space character is
not allowed. For example, A_aa.B_bb.*C_cc_DD.E_ee_F* is valid.

VXML Filter Wildcard Matching Examples
The table below provides examples of VXML filter wildcard matching.

Table 13: Examples of VXML Filter Wildcard Matching

What It MatchesFilter

Matches all voice elements in MyApplicationMyApplication.voice.*.*

Matches all Voice elements in all applications*.voice.*.*

Matches all fields in MyApplication that start with
the string var

MyApplication.*.*.var*

Matches all fields in MyApplication that end with 3MyApplication.*.*.*3

Matches the Company session variable in
MyApplication

MyApplication.*.*.SESSION:Company

Inclusive and Exclusive VXML Reporting Filter Examples
The table below provides examples of some different combinations of Inclusive and Exclusive filters and the
resulting data that the Unified CVP VXML Server feeds to the Reporting Server.

Table 14: Examples of Inclusive and Exclusive VXML Filters for Reporting

Data the Unified CVP VXML Server
Feeds To the Reporting Server

Exclusive FilterInclusive Filter

All Application1 dataNoneApplication1.*.*.*

All Application1 data, except
Element1 and Element2

*.*.Element1.*;

*.*.Element2.*

Application1.*.*.*

All Application1 data, except
Element1, Element2, and Field1

*.*.Element1.*;

*.*.Element2.*;

*.*.*.Field1

Application1.*.*.*

All Application1 data, except
Element3 and Element4

*.voice.*.* which matches
Element3 and Element4

Application1.*.*.*
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Data the Unified CVP VXML Server
Feeds To the Reporting Server

Exclusive FilterInclusive Filter

No data for Application1. Other Data
for other applications, such as
Application2, which contain
Element1, Element2 and Field1, will
be fed.

Application1.*.*.**.*.Element1.*;

*.*.Element2.*;

*.*.*.Field1

Only Element1 and Element2 and all
applications.

*.*.Element3.*;

*.*.Element4.*

*.voice.*.* which matches
Element1, Element2, Element3,
and Element4

Element1 and Element2, except for
Field1, if it exists in those elements

*.*.*.Field1*.voice.*.* which matches
Element1 and Element2

Element1None*.*.Element1.*

Element1, except for Field1 if it exists
in Element1

*.*.*.Field1*.*.Element1.*

Field1 in any elements except
Element3 and Element4

*.*.Element3.*;

*.*.Element4.*

*.*.*.Field1

A good strategy for using filters is to create an Inclusive filter that includes the data you want to save in the
Reporting database and then create an Exclusive filter to exclude portions of the data, for example, sensitive
security information such as Social Security Numbers. For example, you

• First, create an inclusive filter to include all information:

MyApp.voice.*.*

• Then, create an exclusive filter to remove credit card and social security numbers information:

MyApp.voice.*.CreditCard; MyApp.voice.*.SSN

VXML Application File Transfers
Applications transferred to a Unified CVP VXML Server or Unified CVP VXML Server (standalone) must
be stored in the .zip archive format, otherwise the Operations Console returns an invalid format error message
and the file is not transferred. Use the Call Studio archive feature to create .zip application files to be transferred
to a Unified CVP VXML Server or Unified CVP VXML Server (standalone).

To create an Archive file using Call Studio:

1. Right-click on a project in the Navigator view, and choose Deploy.

2. Under Deploy Destination, choose Archive File.

3. Enter the location and filename of the destination file in the Archive File text field.

The filename must end with a ".zip" extension.Note
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4. Click Finish.

Transferring a file is a two-step process:

1. Upload the file to the Operations Console.

2. Select one or more servers to transfer the uploaded file to.

To transfer VXML application files to the Unified CVP VXML Server (standalone):

1. From the main menu, select Device Management > Unified CVP VXML Server (standalone).

The Find, Add, Delete, Edit window lists any servers that have been added to the Operations Console.

2. Select a server by clicking on the link in its Hostname field or by clicking the radio button preceding it
and then clicking Edit.

3. Select File Transfer > VXML Applications in the toolbar and then click Applications.

The VXML Application File Transfer page opens, listing the host name and IP address for the selected
device. VXML applications currently stored in the Operations Server database are listed in the Select
From available VXML applications box.

4. If the VXML application is not listed in the Select From available VXML application files box: Click
Select a VXML application file from Your Local PC. ClickBrowse to search for the VXML application
on the local file system.

5. If the VXML application is listed in the Select From available VXML applications box, select the
VXML application.

6. Click Transfer to send the file to the device.

The VXML application is transferred to the selected server.

Download Log Messages XML File
You can download a Log Messages XML file, CVPLogMessages.xml, to your local machine from any Unified
CVP server. After downloading the file, you can edit it to configure the way Unified CVP event notifications
are handled. Then after you edit the file, you can upload the customized file to any Unified CVP server.

Procedure
To download a Log Messages XML file from the Operations Console to a Unified CVP Server:

Step 1 From the Device Management menu, choose the type of server from which you want to download a syslog XML file.
For example, to download a file to a Unified CVP VXML Server, choose Device Management > Unified CVP VXML
Server.

The Find, Add, Delete, Edit window lists any servers that have been added to the control panel.

Step 2 Select a server by clicking on the link in its Hostname field or by clicking the radio button preceding it and then clicking
Edit.

Step 3 Select File Transfer in the toolbar and then click Log Messages XML File Download.

The Log Messages XML Download dialog box opens.

Step 4 Click Download to transfer the XML file to the server.
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A message indicates that this operation takes time. Click OK to continue with the download or click Cancel.

Related Topics
Upload Log Messages XML File, on page 65
Edit Log Messages XML File, on page 64

Edit Log Messages XML File
The log messages XML file, CVPLogMessages.xml, defines the severity, destination (SNMP management
station or Syslog server) and possible resolution for Unified CVP log messages. This file also identifies an
event type identifier and message text identifier for each event. The text for these identifiers is stored in the
resource properties file, LogMessagesRes.properties.

Each Unified CVP Call Server, Unified CVP VXML Server, and Reporting Server has a log messages XML
file and log message file. You can edit the CVPLogMessages.xml file on a particular Unified CVP server to
customize the severity, destination and possible resolution for each event that the server generates. You can
also edit the LogMessagesRes.properties file to change the text of the message that is generated when an
event occurs on that server.

Use any plain-text editor (one that does not create any markup) or XML editor to edit the CVPLogMessages.xml
file. Use a resource file editor, to edit the LogMessagesRes.properties file. If a resource file editor is not
available, use a text editor.

What it MeansPossible ValuesMessage Element

Identifies the event type described in the
LogMessagesRes.properties file.

Resource="identifier"Name

Identifies the message text described in the
LogMessagesRes.properties file.

Resource="identifier"Body

Identifies the severity level of the event. See
Unified CVP Event Severity Levels, on page
65.

0 to 6Severity

Set to true, to send this message, when logged,
to an SNMP manager, if one is configured.

True or falseSendToSNMP

Set to true to send this message, when logged,
to a Syslog server, if one is configured.

True or falseSendToSyslog
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What it MeansPossible ValuesMessage Element

Set to true to identify this message, when logged,
as an SNMP raise event, which the SNMP
management station can use to initiate a task or
automatically take an action.

Set to false to identify this message as an SNMP
clear when sent to an SNMP management
station. An SNMP clear event usually
corresponds to an SNMP raise event, indicating
that the problem causing the raise has been
corrected. An administrator on an SNMP
management station can correlate SNMP raise
events with SNMP clear events.

True or falseSNMPRaise

Unified CVP Event Severity Levels
The following table describes the available severity levels for Unified CVP events. You can set the severity
level for an event by editing the log messages XML file, CVPLogMessages.xml, on the server that generates
events. For instructions on editing this file, see Edit Log Messages XML File, on page 64.

PurposeSeverityLevel

System or service is unusable0EMERGENCY

Action must be taken immediately1ALERT

Critical condition, similar to ALERT, but not
necessarily requiring an immediate action

2CRITICAL

An error condition that does not necessarily impact
the ability of the service to continue to function

3ERROR

A warning about a bad condition, which is not
necessarily an error

4WARN

Notification about interesting system-level
conditions, which are not errors

5NOTICE

Information about internal flows or application or
per-request information, not system-wide
information

6INFO

Upload Log Messages XML File
You can download a Log Messages XML file, CVPLogMessages.xml, to your local machine from any Unified
CVP server. After downloading the file, you can edit it to configure the way Unified CVP event notifications
are handled. Then after you edit the file, you can upload the customized file to any Unified CVP server.
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Procedure
To upload a Log Messages XML file from a Unified CVP Server to the Operations Console:

Step 1 From the Device Management menu, select the type of server to which you want to upload a syslog XML file. For
example, to upload a file to a Unified CVP VXML Server, select Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit window lists any servers that have been added to the control panel.

Step 2 Select a server by clicking on the link in its Hostname field or by clicking the radio button preceding it and then clicking
Edit.

Step 3 Select File Transfer in the toolbar and then click Log Messages XML File Upload.

The Log Messages XML Upload page opens.

Step 4 In the Select a Log Messages XML file from your local PC text box, enter a file name or click Browse and search for
the file on your local system.

Step 5 Click Upload to transfer the selected file to the Unified CVP VXML Server.
Step 6 Shut down and then start the corresponding Unified CVP VXML Server.

Related Topics
Upload Log Messages XML File, on page 65
Edit Log Messages XML File, on page 64
Shut Down Server
Start Server

Apply Unified CVP VXML Server License
When you are creating a new Unified CVP VXML Server, you must apply a valid license file before using
the server. You can browse for and upload the license file to the Operations Console, and then transfer the
license to the Unified CVP VXML Server. Select either an existing license file in the Operations Console
database or a new license file from your local PC. For information on licensing, see Unified CVP Licensing,
on page 5.

Procedure
To apply a license file:

Step 1 Select Device Management > Unified CVP VXML Server.

The Find, Add, Delete, Edit window lists any servers that have been added to the Operations Console.

Step 2 Select a server by clicking the link in its Hostname field or by clicking the radio button preceding it and then clicking
Edit.

Step 3 Select File Transfer in the toolbar and then click Licenses.

The File Transfer page displays, listing the Hostname and IP Address for the currently selected Unified CVP VXML
Server.

Step 4 If the license file is not listed in the Select From Available License Files text box:
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a) Click Select a License File from Your Local PC.
b) Enter the file name in the text box or click Browse to search for the license file on the local file system.

Step 5 If the license is listed in the Select From Available License Files text box, select the license file.
Step 6 Click Transfer to transfer the selected license file to the selected device.

The license is applied to the selected server.

Related Topics
Find Unified CVP VXML Server, on page 67

Find Unified CVP VXML Server
The Operations Console lets you locate a Unified CVP VXML Server on the basis of specific criteria.

Procedure
To find a Unified CVP VXML Server:

Step 1 Select Device Management > Unified VXML Server.

The Find, Add, Delete, Edit Unified CVP VXML Servers window lists the available Unified CVP VXML Servers, 10
at a time, sorted by name.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the widow to
page through the list. Or, you can enter a page number in the Page field and press enter to go to the page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Unified CVP VXML Server (Standalone) Setup
In the Unified CVP VXML Server (standalone) call flow model, the Call Server routes messages between
the components. Calls arrive through a VXML gateway and interact directly with a Unified CVP VXML
Server to execute VXML applications. The gateway performs both ingress and VXML functions. This call
flow model provides a sophisticated VXML-based VRU, for applications which in many cases do not need
to interact with an ICM Server.

You can perform the following tasks:

Add Standalone Unified CVP VXML Server

Procedure
To add a Unified CVP VXML Server (standalone):
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Step 1 Choose Device Management > Unified CVP VXML Server (Standalone).

The Find, Add, Delete, Edit Unified CVP VXML Server (standalone) window opens.

To use an existing Unified CVP VXML Server as a template for creating the new Unified CVP VXML Server,
select the Unified CVPVXMLServer by clicking the radio button preceding it, and then clickUse As Template.

Note

Step 2 Click Add New.

The Unified VXML Server (standalone) Configuration window opens to the General Tab.

Step 3 Fill in the IP address and hostname and an optional description for the Unified CVP VXML Server.

Table 15: Unified CVP VXML Server General Configuration Settings

Restart/Reboot
Needed

RangeDefaultDescriptionField

General

NoA valid IP addressNoneThe IP address of the Unified CVP
VXML Server

IP Address

NoA valid DNS name,
which includes
uppercase and lowercase
letters in the alphabet,
the numbers 0 through 9,
and a dash

NoneThe host name of the Unified CVP
VXML Server. Host names must be
valid DNS names, which can include
letters in the alphabet, the numbers 0
through 9, and a dash.

Hostname

NoUp to 1,024 charactersNoneThe description of the Unified CVP
VXML Server

Description

Yes - rebootOn or OffNoneSelect to enable secure communications
between the Operations Server and this
component. The device is accessed using
SSH and the files are transferred using
HTTPS.

You must configure secure
communications before you enable this
option. For more information, see the
Configuration Guide for Cisco Unified
Customer Voice Portal.

Enable secure
communication
with the Ops
console

Read OnlyRead OnlyRead OnlyLists the Release and Build Number for
this device.

Device Version

Step 4 Optionally, clickEnable secure communications with the Ops Console to secure communications between theOperations
Console and the Call Server.

Step 5 Optionally, you can select the Device Pool Tab and add the server to an additional device pool.
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Step 6 When you finish configuring Unified CVP VXML Server (standalone), click Save to save the settings in the Operations
Console database. Click Save & Deploy to save and apply the changes to the Unified CVP VXML Server (standalone).

Related Topics
Delete Standalone Unified CVP VXML Server, on page 69
Edit Standalone Unified VXML Server, on page 69
Find Standalone Unified CVP VXML Server, on page 71
Apply Standalone Unified CVP VXML Server License, on page 71
View Device Status

Delete Standalone Unified CVP VXML Server
Deleting a Unified CVP VXML Server (standalone) from the Operations Console deletes its configuration
data in the Operations Console database and removes the Unified CVP VXML Server from the displayed list
of VXML Servers.

Procedure
To delete a Unified CVP VXML Server (standalone):

Step 1 Select Device Management > Unified CVP VXML Server (Standalone).

The Find, Add, Delete, Edit Unified CVP VXML Servers (standalone) window opens.

Step 2 Select the Unified CVP VXML Server (standalone) by clicking the radio button preceding it and then clicking Delete.
To narrow the list of servers see Find Standalone Unified CVP VXML Server, on page 71.

Step 3 Click Delete.
Step 4 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.

Related Topics
Add Standalone Unified CVP VXML Server, on page 67
Edit Standalone Unified VXML Server, on page 69

Edit Standalone Unified VXML Server

Procedure
To edit a Unified CVP VXML Server (standalone):

Step 1 Choose Device Management > Unified CVP VXML Server (Standalone).

The Find, Add, Delete, Edit Unified CVP VXML Servers (standalone) window opens.

Step 2 Select a server by clicking on the link in its Hostname field or by clicking the radio button preceding it and then clicking
Edit.

the Unified CVP VXML Server (standalone) Configuration window opens to the General Tab.
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Step 3 Make the desired changes to the settings. You cannot change the IP address.

Table 16: Unified CVP VXML Server General Configuration Settings

Restart/Reboot
Needed

RangeDefaultDescriptionField

General

NoA valid IP addressNoneThe IP address of the Unified CVP
VXML Server.

This field is not editable.Note

IP Address

NoA valid DNS name,
which includes
uppercase and lowercase
letters in the alphabet,
the numbers 0 through 9,
and a dash

NoneThe host name of the Unified CVP
VXML Server. Host names must be
valid DNS names, which can include
letters in the alphabet, the numbers 0
through 9, and a dash.

Hostname

NoUp to 1,024 charactersNoneThe description of the Unified CVP
VXML Server

Description

Yes - rebootOn or OffNoneSelect to enable secure communications
between the Operations Server and this
component. The device is accessed using
SSH and files are transferred using
HTTPS.

You must configure secure
communications before you enable this
option. For more information, see the
Configuration Guide for Cisco Unified
Customer Voice Portal.

Enable secure
communication
with the Ops
console

Read OnlyRead OnlyRead OnlyLists the Release and Build Number for
this device.

Device Version

Step 4 When you finish editing Unified CVP VXML Server (standalone), click Save to save the settings in the Operations
Console database. Click Save & Deploy to save and apply the changes to the Unified CVP VXML Server (standalone).

Related Topics
Delete Standalone Unified CVP VXML Server, on page 69
Add Standalone Unified CVP VXML Server, on page 67
Find Standalone Unified CVP VXML Server, on page 71
VXML Application File Transfers, on page 62
Apply Unified CVP VXML Server License, on page 66
View Device Status
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Find Standalone Unified CVP VXML Server
The Operations Console lets you locate a Unified CVP VXML Server on the basis of specific criteria. Use
the following procedure to locate a Unified CVP VXML Server (standalone).
Related Topics

Add Standalone Unified CVP VXML Server, on page 67
Edit Standalone Unified VXML Server, on page 69
Delete Standalone Unified CVP VXML Server, on page 69

Procedure
To find a Unified CVP VXML Server (standalone):

Step 1 Select Device Management > Unified CVP VXML Server (Standalone).

The Find, Add, Delete, Edit Unified CVP VXML Server (standalone) window lists the available Unified CVP VXML
Server (standalone) sorted by name, 10 at a time.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, enter a page number in the Page field and press enter to go directly to the numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Apply Standalone Unified CVP VXML Server License
When you are creating a new Unified CVP VXML Server (standalone), you can apply a valid license file. If
you do not apply a license file then the Unified CVP VXML Server (standalone) is limited to 30 active ports.
You can browse for and upload the license file to the Operations Console, and then transfer the license to the
Unified CVP VXML Server (standalone). Select either an existing license file in the Operations Console
database or a new license file from your local PC. For information on licensing, see Unified CVP Licensing,
on page 5.

Procedure
To apply a license file:

Step 1 Select Device Management > Unified CVP VXML Server (Standalone).

The Find, Add, Delete, Edit window lists any servers that have been added to the Operations Console.

Step 2 Select a server by clicking the link in its Hostname field or by clicking the radio button preceding it and then clicking
Edit.

Step 3 Select File Transfer in the toolbar and then click Licenses.

The File Transfer page displays, listing the Hostname and IP Address for the currently selected Unified VXML Server
(Standalone).
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Step 4 If the license file is not listed in the Select From Available License Files text box:
a) Click Select a License File from Your Local PC.
b) Enter the file name in the text box or click Browse to search for the license file on the local file system.

Step 5 If the license is listed in the Select From Available License Files text box, select the license file.
Step 6 Click Transfer to transfer the selected license file to the selected device.

The license is applied to the selected server.

Related Topics
Find Unified CVP VXML Server, on page 67

Gateway Setup
From the DeviceManagement menu, Gateway option, you can add an IOSGateway to the Operations Console.
Once added, you can execute a subset of IOS Gateway commands on the Gateway from the Operations
Console.

The Ingress Gateway is the point at which an incoming call enters the Unified CVP solution. It terminates
TDM phone lines on one side and implements VoIP on the other side. It also provides for sophisticated call
routing capabilities at the command of other Unified solution components. It works with SIP protocols, and
also supports MGCP for use with Unified CM.

The VXML Gateway hosts the IOS voice browser, the component which interprets VXML pages from either
the Unified CVP IVR service or the VXML Server, plays .wav files and Text-to-Speech (TTS), inputs voice
and DTMF, and sends results back to the VXML requestor. It also mediates between Media Servers, Unified
CVP VXML Servers, ASR and TTS Servers, and the IVR service.

The Ingress Gateway may be deployed separately from the VXML Gateway, but in most implementations
they are the same: one Gateway performs both functions. Gateways are often deployed in farms, for centralized
deployment models. In Branch deployment models, one combined Gateway is usually located at each branch
office.

An Egress Gateway is typically used in Call DirectorModel to provide access to a call center ACD or third-party
IVR.

See Also:

Add Gateway
You can add a an IOS Gateway to the Operations Console.

In Unified CVP there are fields for Trunk Group ID. If the Call Server associated with this Gateway has
Enable Gateway Trunk Reporting checked on the ICM tab, then the Trunk Group ID is used for Gateway
trunk reporting. The default value is 300, however the value can be from 1 to 65535.

Related Topics
IOS Setup
Add or Remove Device From Device Pool
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Procedure
To add a Gateway:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Gateways window opens.

Step 2 Click Add New.

The Gateway Configuration window opens.

In the Username and Passwords panel there is a button labeled Test Sign In. Clicking Test Sign In attempts
to verify the credentials by connecting to the Gateway. A message appears with the test result.

Note

Step 3 Fill in the IP address, hostname, Trunk Group ID, user password, and enable password for the Gateway:

Table 17: Gateway Configuration General Settings

RangeDefaultDescriptionField

Valid IP addressNoneThe IP address of the GatewayIP Address

Valid DNS name, which can
include letters in the alphabet, the
numbers 0 through 9, and a dash

NoneThe name of the GatewayHostname

Valid Gateway devices listed in
the drop-down menu

NoneThe type of Gateway deviceDevice Type

Up to 1,024 charactersNoneThe description of the GatewayDescription

1 to 65535300If the Call Server associated with this
Gateway hasEnable Gateway Trunk
Reporting checked on the ICM tab,
then the Trunk Group ID is used for
Gateway trunk reporting.

Trunk Group ID

Not editableBlank if not assigned
to a system-level
configuration
location.

Read only. The location ID for this
Gateway.

Location ID
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RangeDefaultDescriptionField

Enabled or disabledNoneSelect On to enable secure
communications between the
Operations Server and this component.
The device is accessed using SSH and
files are transferred using HTTPS.
Select only if security is enabled and
configured on Gateway.

Note • You must configure
secure
communications
before you enable this
option. For more
information, see the
Configuration Guide
for Unified Customer
Voice Portal.

• Ops console supports
only
diffie-hellman-group1-sha1
algorithm for secure
communication with
gateway.

Enable Secure
Communication with
the Ops console

Table 18: Gateway Configuration Username and Password Settings

RangeDefaultDescriptionField

NoneNone(Optional) Username to
access the device (Telnet or
SSHUsername). If specified,
the user name must be
configured on the device.

Username

NoneNonePassword to access the
device (Telnet or SSH
password), needs to be
configured on device.

User Password

NoneNonePassword to change to exec
mode on device.

Enable Password

Valid IP Port23The port over which to
connect to the gateway CLI.

Port

To use an existing Gateway as a template for creating the new Gateway, select the Gateway by clicking the
radio button preceding it, and then click Use As Template.

Note

Step 4 Optionally, you can select the Device Pool tab and add the Gateway to a device pool.
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Step 5 When you finish configuring the Gateway, click Save to save the configuration.

Delete Gateway

Procedure
To delete a Gateway:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Gateways window opens.

Step 2 Find the Gateway using the procedure in Find Gateway, on page 77.
Step 3 Select the radio button next to the Gateway that you want to delete and click Delete.

If this Gateway is assigned to a system-level configuration location or trunk utilization, then the association must be
removed prior to deleting this Gateway.

Edit Gateway
Related Topics

Add or Remove Device From Device Pool
Execute IOS Commands on Gateway, on page 79
View Gateway Statistics, on page 78
Transfer Script and Media Files

Procedure
To edit a Gateway:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Gateways window opens.

Step 2 Find the Gateway using the procedure in Find Gateway, on page 77.
Step 3 From the list of matching records, select the Gateway that you want to edit.
Step 4 Click the Gateway name to edit it.

The Gateway Configuration window opens with the current settings displayed on the General tab.

Step 5 Change the appropriate configuration settings.
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Table 19: Gateway Configuration General Settings

RangeDefaultDescriptionField

Not editableNoneThe IP address of the Gateway.

This field is not editable.Note

IP Address

Valid DNS name, which can
include letters in the alphabet, the
numbers 0 through 9, and a dash

NoneThe name of the GatewayHostname

Valid Gateway devices are listed
in the drop-down menu.

NoneThe type of Gateway deviceDevice Type

Up to 1,024 charactersNoneThe description of the GatewayDescription

1 to 65535300If the Call Server associated with this
Gateway hasEnable Gateway Trunk
Reporting checked on the ICM tab,
then the Trunk Group ID is used for
Gateway trunk reporting.

Trunk Group ID

Not editableBlank if not assigned
to a system-level
configuration
location.

Read only. The location ID for this
Gateway.

Location ID

Enabled or disabledNoneSelect On to enable secure
communications between the
Operations Server and this component.
The device is accessed using SSH and
files are transferred using HTTPS.
Select only if security is enabled and
configured on Gateway.

You must configure secure
communications before you enable this
option. For more information, see the
Configuration Guide for Cisco Unified
Customer Voice Portal.

Enable Secure
Communication with
the Ops console

Table 20: Gateway Configuration Username and Password Settings

RangeDefaultDescriptionField

NoneNone(Optional) Username to
access the device (telnet or
ssh Username). If specified,
the user name must be
configured on the device.

Username
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RangeDefaultDescriptionField

NoneNonePassword to access the
device (Telnet or SSH
password) needs to be
configured on device.

User Password

NoneNonePassword to change to exec
mode on device.

Enable Password

Valid IP Port23The port over which to
connect to the gateway CLI.

Port

To use an existing Gateway as a template for creating the new Gateway, select the Gateway by clicking the
radio button preceding it, and then click Use As Template.

Note

Step 6 Optionally, you can select the Device Pool tab and add edit the device pool setting.
Step 7 When you finish editing the Gateway configuration, click Save.

Find Gateway
Because you probably have several Gateways in your network, the Operations Console lets you locate specific
Gateways on the basis of specific criteria. Use the following procedure to locate a Gateway.

Procedure
To find a Gateway:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Window lists the available Gateways, 10 at a time, sorted by name.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
screen to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Transfer Script and Media File to Gateway
You can transfer a single script at a time from the Operations Console to one or more Gateways. If you want
to transfer multiple scripts at a time, use the Bulk Administration File Transfer menu option. See Bulk
Administration File Transfer (BAFT).
Related Topics

Find Gateway, on page 77
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View Gateway Statistics, on page 78
Bulk Administration File Transfer (BAFT)

Procedure
To transfer scripts between the Operations Console and a Gateway:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Gateway window lists any Gateways that have been added to the Operations Console.

Step 2 Select a Gateway by clicking on the link in its name field or by clicking the radio button preceding it, and then clicking
Edit.

The Edit Gateway Configuration window opens.

Step 3 Select File Transfer > Scripts and Media from the Gateway configuration toolbar.

The File Transfer window opens.

Step 4 Select a script and media file to transfer to the Gateway.
a) If the script and media file is located on your local machine, click Select a script and media file from your local

PC, then click Browse and select the script and media file to transfer to the Operations Console.
b) If the script and media is located on the Operations Console, click Select from available script and media files.

Step 5 When you have selected the script and media file to transfer, click Transfer to copy the selected script and media file to
the Operations Console and the Gateway.

View Gateway Statistics
You can display statistics for any Gateway that has been added to the Operations Console.

Procedure
To get Gateway statistics:

Step 1 Choose Device Management > Gateway.

The Find, Add, Delete, Edit Gateways window opens.

Step 2 Select a Gateway by clicking on the link in the Hostname field or by clicking the radio button preceding it and then
clicking Edit.

The Edit Gateway Configuration window opens to the General tab.

Step 3 Click Statistics in the toolbar and then select the type of statistics to view from the drop-down menu.

The Gateway Statistics Results window opens, displaying the selected statistics. If the statistics fill the display area, use
the scroll bar to move forward and backward or up and down in the display. See View Gateway Statistics.
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Related Topics
Find Gateway, on page 77

Execute IOS Commands on Gateway
You can use a drop-down menu to select and execute a subset of available Gateway IOS commands when
you are editing a Gateway configuration.

Procedure
To execute a Gateway commands:

Step 1 Select Device Management > Gateway.

The Find, Add, Delete, Edit Gateways window opens.

Step 2 If you are editing an existing Gateway configuration, click Edit.
Step 3 Select IOS Commands from the Gateway Configuration toolbar.
Step 4 From the IOS Commands drop-down menu, select an IOS command to execute on the Gateway.

You can execute the following IOS Gateway commands from the IOS Commands drop-down menu on the Gateway
Configuration window.

Table 21: IOS Gateway Commands

DescriptionCommand

Displays IOS versionShow version

Displays startup-configShow startup-config

Displays running-configShow running-config

If the command fails, the error will be displayed in an error web page.

Virtualized Voice Browser
From the Device Management menu, you can add Virtualized Voice Browser (VVB) server. You can also
execute a subset of VVB commands on the VVB from the Operations Console.

The VVB component interprets VXML pages from either the Unified CVP IVR service or the VXML Server,
plays .wav files and Text-to-Speech (TTS), inputs voice and DTMF, and sends results back to the VXML
requestor. It also mediates between Media Servers, Unified CVP VXML Servers, ASR and TTS Servers, and
the IVR service.

Add VVB
You can add a new VVB from the Operations Console.
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Procedure

Step 1 Select Device Management > Virtualized Voice Browser.
Step 2 Click Add New.
Step 3 Enter the following fields:

Table 22: General Settings

RangeDefaultDescriptionField

Valid IP addressNoneThe IP address of the VVB.IP Address

Valid DNS name, which can
include letters in the alphabet, the
numbers 0 to 9, and a hyphen

NoneThe name of the VVB.Hostname

Up to 1024 charactersNoneThe description of the VVB.Description

On or OffOffSelect to enable secure
communications between the
Operations Console and VVB.

Enable secure
communication with
the Ops console

Table 23: Administration Credentials Settings

DescriptionField

Username to access the device (VVB Operations Console
password). If specified, the username must be configured
on the device.

Username

Password to access the device (VVB Operations Console
password). The password must be configured on the device.

User Password

Table 24: Cisco VVB Serviceability Fields

Data RangeDefaultDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for VVB.

Enable Serviceability
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Data RangeDefaultDescriptionField

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Not ApplicableThe username (ssh or system
CLI credentials) required to
sign in as system CLI
credentials.

For Cisco VVB, the
username is typically a VVB
CLI Platform credentials.

Username

Any text that follows the
requirements for choosing
secure passwords. See
General User Information
Settings

Not ApplicableThe password required to
sign in (VVB CLI Platform
credentials).

Password/Confirm Password

Not Applicable8443The port on which
Serviceability is configured
on Cisco VVB.

Port

• In the Username and Passwords panel there is a button labeled Test Sign-In. Clicking Test Sign In
attempts to verify the operations console credentials by connecting to the Cisco VVB. A message appears
with the test result.

• To use an existing VVB as a template for creating the new VVB, select the VVB by clicking the radio
button preceding it, and then click Use As Template.

Note

Step 4 Optionally, you can select the Device Pool tab and add the VVB to a device pool.
Step 5 Click Save to save the configuration.

Delete VVB

Procedure

Step 1 Select Device Management > Virtualized Voice Browser.
Step 2 Find the VVB using the procedure in Procedure, on page 83.
Step 3 Select the radio button next to the VVB that you want to delete and click Delete.
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Edit VVB

Procedure

Step 1 Select Device Management > Virtualized Voice Browser.
Step 2 Find the VVB using the procedure in Procedure, on page 83.
Step 3 From the list of matching records, select the VVB that you want to edit.
Step 4 Click the VVB name to edit it.
Step 5 Change the appropriate configuration settings.

Table 25: Virtualized Voice Browser Configuration General Settings

RangeDefaultDescriptionField

Not editableNoneThe IP address of the VVB.

This field is not editable.Note

IP Address

Valid DNS name, which can
include letters in the alphabet, the
numbers 0 to 9, and a hyphen.

NoneThe name of the VVB.Hostname

Up to 1024 charactersNoneThe description of the VVB .Description

On or OffOffSelect to enable secure
communications between the
Operations Console and VVB.

Enable secure
communication with
the Ops console

Table 26: Administration Credentials Settings

DescriptionField

Username to access the device (VVB Operations Console
password). If specified, the username must be configured
on the device.

Username

Password to access the device (VVB Operations Console
password). The password must be configured on the device.

User Password

Table 27: Cisco VVB Serviceability Fields

DefaultData RangeDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for VVB.

Enable Serviceability
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DefaultData RangeDescriptionField

Not ApplicableValid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

The username (ssh or system
CLI credentials) required to
sign in as system CLI
credentials.

For Cisco VVB, the
username is typically a VVB
CLI Platform credentials.

Username

Not ApplicableAny text that follows the
requirements for choosing
secure passwords. See
General User Information
Settings

The password required to
sign in (VVB CLI Platform
credentials).

Password/Confirm Password

8443N/AThe port on which
Serviceability is configured
on Cisco VVB.

Port

To use an existing VVB as a template for creating the new VVB, select the VVB by clicking the radio button
preceding it, and then click Use As Template .

Note

Step 6 Optionally, you can select the Device Pool tab and add edit the device pool setting.
Step 7 Click Save to save the changes.

Find VVB
If you have several Gateways in your network, the Operations Console lets you locate specific VVB on the
basis of specific criteria. Use the following procedure to locate a VVB.

Procedure

Step 1 Select Device Management > Virtualized Voice Browser.
Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the

screen to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note
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Speech Server Setup
A Speech Server provides speech recognition and synthesis services. You can add a pre-configured Speech
Server to the Operations Console. Once added to the Operations Console, you can add a Speech Server to one
or more device pools.

A Speech Server provides speech recognition services and text-to-speech services for a VXML Gateway.

The Operations Console can only manage Speech Servers installed on Microsoft Windows.Note

You can perform the following tasks:

Add Speech Server

Procedure

Before you begin

Install the Remote Operations in the Speech Server before you add the Speech Server to the Operations console.

Step 1 Select Device Management > Speech Server.

The Find, Add, Delete, Edit Speech Server window opens.

To use an existing Speech Server as a template for creating the new Speech Server, select the Speech Server
by clicking the radio button preceding it, and then click Use As Template.

Note

Step 2 Click Add New.

The Speech Server Configuration window opens.

Step 3 Fill in the appropriate configuration settings on the General tab as described in Speech Server Configuration Settings.

You can change the settings described in the following table to configure a Speech Server.

Table 28: Speech Server Configuration Settings

Reboot/Restart RequiredRangeDefaultDescriptionField

General

Yes - Reboot Speech
Server

Valid IP addressNoneThe IP address of the Speech ServerIP Address

Yes - Reboot Speech
Server

Valid DNS name,
includes letters in the
alphabet, the numbers 0
through 9, and a dash

NoneThe host name of the Speech ServerHostname
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Reboot/Restart RequiredRangeDefaultDescriptionField

NoUp to 1,024 charactersNoneThe description of the Speech
Server

Description

Yes - RestartAny textNoneThe path of the license file on the
Speech Server. The Operations
Console transfers the license file to
this location.

The license file is the
license file for the
respective Speech
Server. The location
must be the absolute
path to where the license
file exists on the Speech
Server. The license file
must exist at that path
before you can
successfully save and
deploy.

Note

License File
Location

NoOn or OffNoneSelect On to enable secure
communications between the
Operations Server and this
component. The device is accessed
using SSH and files are transferred
using HTTPS.

Enable secure
communication
with the Ops
console

Step 4 Select the Device Pool tab to optionally add the Speech Server to additional device pools.
Step 5 Click Save to save the settings in the Operations Console database. Click Save & Deploy to deploy the changes to the

Speech Server.

Related Topics
Device Information Field Descriptions, on page 2
Apply Speech Server License, on page 87

Delete Speech Server
You can delete a Speech Server that has been added to the Operations Console. Deleting a Speech Server
removes its configuration from the Operations Console database.

Procedure
To delete a Speech Server:

Step 1 Select Device Management > Speech Server.

The Find, Add, Delete, Edit Speech Server window opens.

Managing Devices
85

Managing Devices
Delete Speech Server



Step 2 Select the Speech Server by clicking the radio button preceding it and then clicking Delete. To narrow the list of servers
see Find Speech Server, on page 87.

Step 3 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.

Edit Speech Server
You can edit a Speech Server that has been added to the Operations Console. Editing a Speech Server changes
its configuration from the Operations Console database.
Related Topics

Find Speech Server, on page 87

Procedure
To edit a Speech Server:

Step 1 Select Device Management > Speech Server.

The Find, Add, Delete, Edit Speech Server window opens.

Step 2 Select the radio button next to the Speech Server that you want to edit, and click Edit.
Step 3 Change the appropriate configuration settings on the General tab.

You can change the settings described in the following table to configure a Speech Server.

Table 29: Speech Server Configuration Settings

Reboot/Restart RequiredRangeDefaultDescriptionField

General

Yes - Reboot Speech
Server

Valid IP addressNoneThe IP address of the Speech
Server.

This field is not editable.Note

IP Address

Yes - Reboot Speech
Server

Valid DNS name,
includes letters in the
alphabet, the numbers 0
through 9, and a dash

NoneThe host name of the Speech ServerHostname

NoUp to 1,024 charactersNoneThe description of the Speech
Server

Description

Yes - RestartAny textNoneThe path of the license file on the
Speech Server. The Operations
Console transfers the license file to
this location.

License File
Location
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Reboot/Restart RequiredRangeDefaultDescriptionField

NoOn or OffNoneSelect On to enable secure
communications between the
Operations Server and this
component. The device is accessed
using SSH and files are transferred
using HTTPS.

Enable secure
communication
with the Ops
console

Step 4 Select the Device Pool tab to optionally add or remove the Speech Server to or from device pools.
Step 5 When you finish configuring the Speech Server, click Save to save the settings in the Operations Console database. Click

Save & Deploy to deploy the changes to the Speech Server.

Find Speech Server
The Operations Console lets you locate a Speech Server on the basis of specific criteria. Use the following
procedure to locate a Speech Server.

Procedure
To find a Speech Server:

Step 1 Select Device Management > Speech Server.

The Find, Add, Delete, Edit Speech Servers window lists the available Call Servers sorted by name, 10 at a time.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
window to page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the
numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Apply Speech Server License
When you are creating a new Speech Server, you must apply a valid license file before using the server. You
can browse for and upload the license file to the Operations Console, and then transfer the license to the
Speech Server. Select either an existing license file in the Operations Console database or a new license file
from your local desktop.

Procedure
To apply a license file:
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Step 1 Select Device Management > Speech Server.

The Find, Add, Delete, Edit Speech Server window opens.

Step 2 Select the radio button next to the Speech Server that you want to edit and click Edit.
Step 3 Make sure the License File Location lists the correct path of the license file on the Speech Server. The Operations

Console transfers the license file to this location.
Step 4 Select File Transfer in the toolbar and then click Licenses.

The License File Transfer page displays, listing the host name and IP address for the currently selected Speech Server.

Step 5 If the license is listed in the Select From Available License Files text box, select the license file.
Step 6 If the license file is not listed in the Select From Available License Files text box:

a) Click Select a License File from Your Local PC.
b) Enter the file name in the text box or click Browse to search for the license file on the local file system.

Step 7 Click Transfer to transfer the selected license file to the selected device.

The license is applied to the selected server.

Related Topics
Find Speech Server, on page 87

Media Server Setup
A Media Server administers the media files that contain messages and prompts callers hear. You can add a
pre-configured Media Server to the Operations Console. Once added, you can add a Media Server to one or
more device pools.

When you add and deploy Media Server(s) to the Operations Console, that information gets pushed to all the
Callservers. It is similar to how WebServices information gets added to the CVP devices. This automatically
populates the media servers in the FTP element of the Studio application. You can designate a default media
server.

The Media Server is a simple web server/FTP server (if FTP enabled) with the sole purpose within Unified
CVP to store and serve .wav files to the VXML gateway, as required in order to render VXML pages. The
VXML gateway caches the .wav files it retrieves from the Media Server. In most deployments, the Media
Server encounters extremely low traffic from Unified CVP.

The Media Server must be an IIS web server on a separate machine, with FTP enabled. The Agent Greeting
recording script requires the Media Server to have FTP enabled. This is done automatically with Unified CVP
as long as the Media Server is configured with Add Media Server, on page 89. If it is not enabled, then make
sure that Microsoft FTP Service Startup Type is set to Automatic and the status is Running. Using Tomcat
on the Unified CVP VXML server is not a supported configuration as a Media Server, and the FTP element
in the recording application fails if the FTP operation fails.

SFTP is also supported with Media Servers. Refer to the Port settings in the Media Server Configuration
Settings table for more details.
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Add Media Server

Procedure
To add a Media Server:

Whenever you add, edit, or delete a Media Server, you must click the Deploy button to make the change
effective.

Note

Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit window opens.

To use an existing Media Server as a template for creating the new Media Server, select the Media Server by
clicking the radio button preceding it, and then click Use As Template.

Note

Step 2 Click Add New.

The Media Server Configuration window opens.

Step 3 Fill in the appropriate configuration settings on the General tab.

The following table describes the fields that can be configured for a Media Server:

Table 30: Media Server Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP address.NoneThe IP address of Media ServerIP Address

NoFollow RFC 1123 Section
2.1 naming conventions for
hostnames.

NoneThe name of the Media ServerHostname

NoUp to 1,024 characters.NoneThe description of the Media
Server

Description

No

Use Test Sign-in button
to verify the FTP
credentials.

Select the check box to
enable this feature.

DisabledIndicates that this media server
has FTP Enabled. A media
server that has FTP enabled is
automatically populated as a
session variable to the Unified
CVPVXMLServer. The default
agent greeting recording
application automatically uses
the media servers defined in
CVP OAMP that have FTP
enabled to FTP the agent
greeting recording.

FTP Enabled
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Restart RequiredRangeDefaultDescriptionField

No

Use Test Sign-in button
to verify the FTP
credentials.

Select the check box to
enable this feature.

You must
enable FTP to
enable
Anonymous
Access.

Note

DisabledIndicates that this media server
uses anonymous FTP access. In
this case, the username is
specified by default as
anonymous. The password field
is not specified for anonymous
access.

The user can specify the port
number or select the default port
number (21).

Anonymous
Access

No

Use Test Sign-in button
to verify the FTP
credentials.

Enter a valid username and
password.

NoneThese fields apply if FTP is
enabled andAnonymousAccess
is disabled. In this case, enter
the username and password.

Username and
Password

No

Use Test Sign-in button
to verify the FTP
credentials.

Enter vaild password.NoneRetype password.Confirm
Password

No

Use Test Sign-in button
to verify the FTP
credentials.

Valid ports are 1 to 65535.21Enter a new port number or use
the default port number (21).

For SFTP, use port 22 or any
other custom port that you may
have configured.

Port

Step 4 Optionally, you can select the Device Pool tab and add the Media Server to a device pool. See Add and Remove Media
Server From Device Pool, on page 93.

Step 5 When you finish configuring the Media Server, click Save.

Delete Media Server

Procedure
To delete a Media Server:

You will receive a special prompt if you attempt to delete the default Media Server.Warning

Whenever you add, edit, or delete a Media Server, click the Deploy button to make the change effective.Note
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Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit Media Server window opens.

Step 2 Select the Media Server by clicking the radio button preceding it and then clicking Delete. To narrow the list of servers
see Find Media Server, on page 93.

Step 3 When prompted to confirm the delete operation, click OK to delete or click Cancel to cancel the delete operation.

Related Topics
Find Media Server, on page 93

Deploy Media Server
Use the Deploy button to update the Media Server device list that is sent to all Call Servers

A default media server device may be specified in the Operations Console. If specified, micro-applications
use that default media server if the ECC variable for the media server is not defined in the UCCE ICM script.

Procedure
To deploy a Media Server to all Call Servers:

Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit window opens.

Step 2 From the Default Media Server drop-down menu, select the default Media Server.
Step 3 Click the Set button next to the Media Server you want to set as the default Media Server.
Step 4 Click the Deploy button to have the default Media Server sent to the Call Servers and VXML Servers.

You must select the Deploy button to have the Media Server sent to the Call Servers and VXML Servers.

Configuration information for all Media Servers, and the default Media Server is updated on each Call Server
in the property file CVP_HOME\conf\mediaServer.properties.

Note

Step 5 Restart the VXML Server.

Edit Media Server

Procedure
To edit a Media Server:

Whenever you add, edit, or delete a Media Server, click the Deploy button to make the change effective.Note
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Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit Media Server window opens.

Step 2 From the list of matching records, select the Media Server that you want to edit.
Step 3 Select the radio button next to the Media Server you want to Edit, and then click Edit.
Step 4 Change appropriate configuration settings on the General tab. You cannot change the IP address of the Media Server.

The following table describes the fields that can be configured for a Media Server:

Table 31: Media Server Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP addressNoneThe IP address ofMedia Server.

This field is not
editable.

Note

IP Address

NoFollow RFC 1123 Section
2.1 naming conventions for
hostnames.

NoneThe name of the Media ServerHostname

NoUp to 1,024 charactersNoneThe description of the Media
Server

Description

No

Use Test Sign-in button
to verify the FTP
credentials.

Select the check box to
enable this feature.

DisabledIndicates that this media server
has FTP Enabled. A media
server(s) that has FTP enabled
is automatically populated as a
session variable to the Unified
CVPVXMLServer. The default
agent greeting recording
application automatically uses
the media servers defined in
CVP OAMP that have FTP
enabled for FTPing the agent
greeting recording.

FTP Enabled

No

Use Test Sign-in button
to verify the FTP
credentials.

Select the check box to
enable this feature.

You must enable
FTP to enable
Anonymous
Access.

Note

DisabledIndicates that this media server
uses anonymous FTP access. In
this case, the username is
specified by default as
anonymous. The password field
is not specified for anonymous
access.

The user can specify the port
number or select the default port
number (21).

Anonymous
Access
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Restart RequiredRangeDefaultDescriptionField

No

Use Test Sign-in button
to verify the FTP
credentials.

Enter a valid username and
password.

NoneThese fields apply if FTP is
enabled andAnonymousAccess
is disabled. In this case, enter
the username and password.

Username and
Password

No

Use Test Sign-in button
to verify the FTP
credentials.

Valid ports are 1 to 65535.21Enter a new port number or use
the default port number (21).

Port

Step 5 Optionally, you can select the Device Pool tab and edit the Media Server's association with a device pool. See Add and
Remove Media Server From Device Pool, on page 93.

Step 6 When you finish configuring the Media Server, click Save.

Related Topics
Find Media Server, on page 93

Find Media Server
The Operations Console lets you locate a Media Server on the basis of specific criteria. Use the following
procedure to locate a Media Server.

Procedure
To find a Media Server:

Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit Call Servers window lists the available Media Servers sorted by name, 10 at a time.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, you can enter a page number in the Page field and press enter to go to the numbered page.

Step 3 You can filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter your
search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

Add and Remove Media Server From Device Pool

Procedure
To add or remove a Media Server from a device pool:
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Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit Media Server window opens.

Step 2 From the list of matching records, select the Media Server that you want to edit.
Step 3 Click Edit.
Step 4 Select the Device Pool tab.
Step 5 To add a device to a device pool, select the device pool from the Available pane, and then click the right arrow to move

the pool to the Selected pane.
Step 6 To remove a device from a device pool, select the device pool from the Selected pane, and then click the left arrow to

move the device pool to the Available pane.
Step 7 Click Save.

View Deployment Status
Use the Deployment Status button to view the status of the Media Server device list.

Procedure
To view the status of the Media Server device list:

Step 1 Select Device Management > Media Server.

The Find, Add, Delete, Edit Media Server window opens.

Step 2 Click theDeployment Status button to view the status of the deployment of the default Media Server to each Call Server.

You must select the Deploy button to have the Media Server sent to the Call Servers.

Unified Communications Manager Server Setup
From the Device Management menu, Communications Manager option, you can add a Unified CM Server
to the Operations Console. Once added, you can add the Unified CM Server to a device pool and access a
Unified CM administration web page, from which you can configure the Unified CM Server.

Unified CM manages and switches VoIP calls among IP phones. Unified CVP interacts with Unified CM to
send PSTN-originated calls to UCCE agents.

If the Unified CM was synchronized for its configured locations, and the Unified CM synchronization is
disabled or the Unified CM device is deleted, then the previously configured synchronization locations are
marked as invalid.

Note

You can perform the following tasks:
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• Add Unified CM Server

• Edit Unified CM Server

• Delete Unified CM Server

• Find Unified CM Server

• Synchronizing Location Information

Add Unified CM Server

Procedure
Use this procedure to add a Unified CM Server. See the following table for the Unified CM field descriptions.

Table 32: Unified CM Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP addressNoneThe IP address of the
Unified CM Server.

IP Address

NoValid DNS names,
includes letters in the
alphabet, the numbers
0 through 9, and a
dash.

NoneThe name of the Unified
CM Server

Hostname

NoAny textNoneThe description of the
Unified CM Server

Description

NoA valid URL. The
Operations Console
validates the URL for
syntax errors but does
not check that the site
exists.

NoneThe Administration URL
for the Unified CMServer

DeviceAdmin
URL

Enable Synchronization (See Synchronize Location Information for more
information.)

NoEnabled or DisabledDisabled

When you
enable this
service, the
Port field
defaults to
8443.

Select to enable
synchronization for
location. If enabled, the
Operations Console
extracts (synchronizes) the
Unified CM location
information from the
Unified CM server.

Enable
synchronization
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Restart RequiredRangeDefaultDescriptionField

NoValid Unified CM
AXL username.

NoneUser name to access the
Unified CM AXL
interface.

Username

NoValid Unified CM
AXL password.

NonePassword to access the
Unified CM AXL
interface

Password

NoText must match the
text entered in the
Password field

NoneRetype the password to
verify that you typed the
password correctly

Confirm
Password

No1 through 655358443The port to which the
Unified CM server
connects when
establishing initial contact

Port

Step 1 Select Device Management > Unified CM.

The Find, Add, Delete, Edit Unified ICM Servers window opens.

Step 2 Click Add New.

The Unified ICM Server Configuration window opens to the General tab.

Step 3 Fill in the appropriate configuration settings.

See the Unified CM configuration settings field descriptions table for details.

Cisco AXL Web Service must be enabled on the Unified CM for synchronization to work.Note

To enable Cisco AXL Web Service on the Unified CM, perform the following steps:

a) Log on to Unified CM.
b) Open the Cisco Unified Serviceability dashboard and select Tools > Service Activation.
c) In the drop down menu, select the Unified CM server that is configured in this Operations Console, and click Go.
d) In the Database and Admin Services section, check the box next to Cisco AXL Web Service.
e) Click Save.

Step 4 (Optional) Select the Device Pool tab and add the Unified CM Server to a device pool.
Step 5 When you finish configuring the Unified CM, click Save.

Related Topics
Device Information Field Descriptions, on page 2
Add or Remove Device From Device Pool
Synchronize Location Information
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Edit Unified CM Server

Procedure
Use this procedure to edit a Unified CM Server.

See the following table for the Unified CM field descriptions

Table 33: Unified CM Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP addressNoneThe IP address of the
Unified CM Server.

This field is
not editable.

Note

IP Address

NoValid DNS names,
includes letters in the
alphabet, the numbers
0 through 9, and a
dash.

NoneThe name of the Unified
CM Server

Hostname

NoAny textNoneThe description of the
Unified CM Server

Description

NoA valid URL. The
Operations Console
validates the URL for
syntax errors, but does
not check that the site
exists.

NoneThe Administration URL
for the Unified CMServer

DeviceAdmin
URL

Enable Synchronization for Location (See Synchronize Location Information
for more information.)

NoEnabled or DisabledDisabled

When you
enable this
service, the
Port field
defaults to
8443.

Select to enable
synchronization for
location. If enabled, the
Operations Console
extracts (synchronizes) the
Unified CM location
information from the
Unified CM server.

Enable
synchronization

NoValid names include
uppercase and
lowercase alphabetical
letters, the numbers 0
through 9, a dash, and
an underscore.

NoneUser name to access the
Unified CM AXL
interface.

Username

Managing Devices
97

Managing Devices
Edit Unified CM Server

ccvp_b_administration-guide-for-cisco-unified-12-0_chapter1.pdf#nameddest=unique_82


Restart RequiredRangeDefaultDescriptionField

NoAny text that follows
the requirements for
choosing secuire
passwords. See
General User
Information Settings.

NonePassword to access the
Unified CM AXL
interface

Password

NoText must match the
text entered in the
Password field

NoneRetype the password to
verify that you typed the
password correctly

Confirm
Password

No1 through 655358443The port to which the
Unified CM server
connects when
establishing initial contact

Port

Step 1 Select Device Management > Unified CM.

The Find, Add, Delete, Edit Unified ICM Servers window opens.

Step 2 Select the Unified CM Server that you want to edit. To narrow down the list of servers see Find Unified CM Server, on
page 99.

Step 3 Click Edit.

The Edit Unified CM Server Configuration window opens to the General tab with the current settings displayed.

Step 4 Update the configuration settings as required.

See the Unified CM configuration settings field descriptions table for details.

Cisco AXL Web Service must be enabled on the Unified CM for synchronization to work.Note

To enable Cisco AXL Web Service on the Unified CM, perform the following steps:

a) Log on to Unified CM .
b) Open the Cisco Unified Serviceability dashboard and select Tools > Service Activation.
c) In the drop down, select the Unified CM server that is configured in this Operations Console, and click Go.
d) In the Database and Admin Services section, check the box next to "Cisco AXL Web Service".
e) Click Save.

Step 5 (Optional) Select the Device Pool tab and add the server to a device pool.
Step 6 When you finish configuring the server, click Save to save the configuration.

Related Topics
Device Information Field Descriptions, on page 2
Find Unified CM Server, on page 99
Add or Remove Device From Device Pool
Synchronize Location Information
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Delete Unified CM Server
Deleting a Unified CM Server deletes the configuration of the selected server from the Operations Console
database and removes the server from the displayed list of Unified CM Servers.

Procedure
To delete a Unified CM Server:

Step 1 Select Device Management > Unified CM.

The Find, Add, Delete, Edit Unified ICM Servers window opens.

Step 2 Select the Unified CM Server that you want to delete. To narrow down the list of servers, see Find Unified CM Server,
on page 99.

Step 3 Click Delete.
Step 4 When prompted to confirm the delete operation, click OK or click Cancel.

Related Topics
Find Unified CM Server, on page 99
Synchronize Location Information

Find Unified CM Server
You can locate a Unified CM Server on the basis of specific criteria. Use the following procedure to locate a
Unified CM Server.
Related Topics

Synchronize Location Information

Procedure
To find a Unified CM Server:

Step 1 Select Device Management > Unified CM.

The Find, Add, Delete, Edit Unified ICM Servers window lists the available Unified ICM Servers, sorted by name, 10
at a time.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, you can enter a page number in the Page field and press enter to go to the numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then clickFind.

The filter is not case sensitive, and wildcard characters are not allowed.Note
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Unified ICM Server Setup
Unified CVP provides VoIP routing services for the Unified CCE and Unified CCX products. Unified ICM
provides the services to determine where calls should be routed, whether to ACDs, specific agents, or to
VRUs, but the routing services themselves must be provided by an external routing client.

A Unified ICM Server is required in Unified CVP Comprehensive, Call Director, and VRU-Only call flow
models.

Add Unified ICM Server
From the Device Management menu, ICM Server option, you can add a pre-configured ICM Server to the
Operations Console. Once added, you can add the ICM Server to a device pool.
Related Topics

Add or Remove Device From Device Pool
Device Information Field Descriptions, on page 2

Procedure
To add an ICM Server:

Step 1 Select Device Management > Unified ICM.

The Find, Add, Delete, Edit ICM Server window opens.

To use an existing ICM Server as a template for creating the new ICM Server, select the ICM Server by clicking
the radio button preceding it, and then clicking Use As Template.

Note

Step 2 Click Add New.

The Unified ICM Server Configuration window opens.

Step 3 Fill in the appropriate Unified ICM configuration settings on the General tab.

Table 34: Unified ICM General Tab Configuration Settings

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP addressNoneThe IP address of the Unified
ICM Server

IP Address

NoValid DNS name,
includes letters in the
alphabet, the numbers 0
through 9, and a dash.

NoneThe name of the Unified ICM
Server

Hostname

NoUp to 1,024 charactersNoneThe description of the
Unified ICM Server

Description
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Restart RequiredRangeDefaultDescriptionField

NoValid URLNoneThe URL for the Unified
ICM web configuration
application.

Device Admin
URL

Step 4 In the Unified ICM server, enter the information in the Enable Serviceability panel so that Serviceability information for
this Unified ICM server is distributed using the web services manager feature of Unified CVP.

Table 35: Unified ICM Serviceability Fields

RangeDefaultDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for Unified ICM.

Enable Serviceability

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Not ApplicableThe username required to
sign in to Unified ICM
Serviceability.

For Unified ICM, the
Username is typically a
domain\username

combination.

Username

Any text that follows the
requirements for choosing
secure passwords. See
General User Information
Settings

Not ApplicableThe password required to
sign in to Unified ICM
Serviceability.

Password/Confirm Password

1 - 655357890The port on which
Serviceability is configured
on Unified ICM.

Port

Step 5 (Optional) Select the Device Pool tab and add the Unified ICM Server to a device pool.
Step 6 When you finish configuring the Unified ICM Server, click Save.

Delete Unified ICM Server
Deleting a Unified ICM Server deletes the configuration of the selected Unified ICM Server in the Operations
Console database and removes the Unified ICM Server from the list of Unified ICM Servers displayed in the
Operations Console.
Related Topics

Find Unified ICM Server, on page 103
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Procedure
To delete a Unified ICM Server:

Step 1 Select Device Management > Unified ICM.

The Find, Add, Delete, Edit window opens.

Step 2 Select the Unified ICM Server that you want to delete. To narrow the list of servers see Find Unified ICM Server, on
page 103.

Step 3 Click Delete.
Step 4 When prompted to confirm the delete operation, click OK or click Cancel.

Edit Unified ICM Server
Related Topics

Add or Remove Device From Device Pool
Device Information Field Descriptions, on page 2
Find Unified ICM Server, on page 103

Procedure
To edit a Unified ICM Server:

Step 1 Select Device Management > Unified ICM.

The Find, Add, Delete, Edit Unified ICM Server window opens.

Step 2 Select the Unified ICM Server that you want to edit. To narrow the list of servers see Find Unified ICM Server, on page
103.

Step 3 Click Edit.

The Unified ICM Server Configuration window opens and displays the current settings.

Step 4 Change the appropriate Unified ICM Server configuration settings on the General tab as required.

Restart RequiredRangeDefaultDescriptionField

General

NoValid IP addressNoneThe IP address of the Unified
ICM Server.

This field is not
editable.

Note

IP Address

NoValid DNS name,
includes letters in the
alphabet, the numbers 0
through 9, and a dash.

NoneThe name of the Unified ICM
Server

Hostname
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Restart RequiredRangeDefaultDescriptionField

NoUp to 1,024 charactersNoneThe description of the
Unified ICM Server

Description

NoValid URLNoneThe URL for the Unified
ICM web configuration
application.

Device Admin
URL

Step 5 In the Unified ICM server, you can change the information in Enable Serviceability panel.

Table 36: Unified ICM Serviceability Fields

DefaultData RangeDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for Unified ICM.

Enable Serviceability

Not ApplicableValid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

The username required to
sign in to Unified ICM
Serviceability.

For Unified ICM, the
Username is typically a
domain\username

combination.

Username

Not ApplicableMust match password on
Unified ICM

The password required to
sign in to Unified ICM
Serviceability (for example,
the web admin password).

Password/Confirm Password

78901 - 65535The port on which
Serviceability is configured
on Unified ICM.

Port

Step 6 Update the Device Pool tab settings.
Step 7 When you are finished configuring the Unified ICM Server, click Save.

Find Unified ICM Server
You can locate a Unified ICM Server on the basis of specific criteria. Use the following procedure to locate
a Unified ICM Server.
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Procedure
To find a Unified ICM Server:

Step 1 Select Device Management > Unified ICM.

The Find, Add, Delete, Edit Unified ICM Servers window lists the available Unified ICM Servers.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, you can enter a page number in the Page field and press enter to go to the numbered page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case sensitive, and wildcard characters are not allowed.Note

SIP Proxy Server Setup
From Device Management > SIP Proxy Server, add a SIP Proxy Server to the Operations Console. Once
added, you can add the SIP Proxy Server to a device pool. You can also configure a link to the administration
web page for the SIP Proxy Server so that you can access that page from the Operations Console.

A SIP Proxy Server is a device that routes individual SIP transport messages among SIP endpoints. It plays
a key role in high availability in a Unified CVP deployment for call switching. It is designed to support multiple
SIP endpoints of various types, and implements load balancing and failover among those endpoints. SIP Proxy
Servers are deployed alone or as a pair. Also, smaller Unified CVP deployments run without a SIP Proxy
Server. In such cases, the Unified CVP SIP service assumes some of those functions because it configures a
static table to look up destinations.

Unified CVP works with RFC-3261-compliant SIP Proxy Servers and has been qualified with the following:

• Cisco Unified SIP Proxy

Add SIP Proxy Server
Related Topics

Add or Remove Device From Device Pool
Device Information Field Descriptions, on page 2

Procedure
To add SIP Proxy Server:

Step 1 Select Device Management > SIP Proxy Server.

The Find, Add, Delete, Edit window opens.

To use an existing SIP Proxy Server as a template for creating the new SIP Proxy Server, select the SIP Proxy
Server by clicking the radio button preceding it, and then click Use As Template.

Note
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Step 2 Click Add New.

The SIP Server Configuration window opens.

Step 3 Fill in the appropriate SIP Proxy Server configuration settings on the General tab.

Table 37: SIP Proxy Server Configuration Settings

Restart RequiredRangeDefaultDescriptionField

Not ApplicableValid IP addressNoneThe IP address of the SIP
Proxy Server

IP Address

Not ApplicableValid DNS name, includes
letters in the alphabet, the
numbers 0 through 9, and a
dash

NoneThe host name of the SIP
Proxy Server

Hostname

Not ApplicableCisco Unified SIP ProxyCisco
Unified
SIP
Proxy

The type of proxy server.Device Type

Not ApplicableUp to 1,024 charactersNoneThe description of the SIP
Proxy Server

Description

Not ApplicableA valid URL. The UI validates
the URL for URL syntax errors,
but no validation for site
existence.

NoneThe Administration URL of
SIP Proxy Server.

Device AdminURL

Table 38: SIP Proxy Server Serviceability Fields

Data RangeDefaultDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for SIP Proxy
Server.

Enable Serviceability

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Not ApplicableThe username required to
sign in to the proxy server's
serviceability.

Username

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

For Unified SIP Proxy Only.
The password that matches
the user password.

Password
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Data RangeDefaultDescriptionField

Must match password on the
SIP Proxy.

Not ApplicableRetype password.Confirm Password

1 - 655358443The port on which
Serviceability is configured
on the SIP Proxy.

Port

Step 4 Optionally, select the Device Pool tab and add the SIP Proxy Server to a device pool.
Step 5 When you finish configuring the SIP Proxy Server, click Save.

Edit SIP Proxy Server
You can change an existing SIP Proxy Server configuration.

Procedure
To edit SIP Proxy Server:

Step 1 Select Device Management > SIP Proxy Server.

The Find, Add, Delete, Edit SIP Servers window opens.

Step 2 Select the SIP Proxy Server that you want to edit. If the list is too long, see Find SIP Proxy Server, on page 108.
Step 3 Click Edit.

The SIP Proxy Server Configuration window opens and displays the current settings.

Step 4 Fill in the appropriate configuration settings on the General tab.

Table 39: SIP Proxy Server Configuration Settings

Restart RequiredRangeDefaultDescriptionField

Not ApplicableValid IP addressNoneThe IP address of the SIP
Proxy Server

This field is not
editable

Note

IP Address

Not ApplicableValid DNS name, includes
letters in the alphabet, the
numbers 0 through 9, and a
dash

NoneThe host name of the SIP
Proxy Server

Hostname

Not ApplicableCisco Unified SIP ProxyCisco
Unified
SIP
Proxy

The type of proxy serverDevice Type
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Restart RequiredRangeDefaultDescriptionField

Not ApplicableUp to 1,024 charactersNoneThe description of the SIP
Proxy Server

Description

Not ApplicableA valid URL. The UI validates
the URL for URL syntax errors,
but no validation for site
existence

NoneThe Administration URL of
SIP Proxy Server

Device AdminURL

Table 40: SIP Proxy Server Serviceability Fields

DefaultData RangeDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for SIP Proxy
Server.

Enable Serviceability

Not ApplicableValid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

The username required to
sign in to Unified ICM
Serviceability.

Username

Not ApplicableMust match password on
Unified ICM

The password required to
sign in to SIP Proxy
Serviceability.

User Password/Enable
Password

84431 - 65535The port on which
Serviceability is configured
on the SIP Proxy.

Port

Step 5 (Optional) Select the Device Pool tab and update the device pool settings.
Step 6 When you finish configuring the SIP Proxy Server, click Save.

Related Topics
Device Information Field Descriptions, on page 2

Delete SIP Proxy Server
Deleting a SIP Proxy Server deletes the configuration of the selected Proxy Server in the Operations Console
database and removes the server from displayed list of SIP Proxy Servers.

Procedure
To delete a SIP Proxy Server:
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Step 1 Select Device Management > SIP Proxy Server.

The Find, Add, Delete, Edit SIP Proxy Server window opens.

Step 2 Select the radio button next to the SIP Proxy Server that you want to delete. If the list is too long, see Find SIP Proxy
Server, on page 108.

Step 3 Click Delete.
Step 4 When prompted to confirm the delete operation, click OK or click Cancel.

Find SIP Proxy Server
You can locate a SIP Proxy Server on the basis of specific criteria. Use the following procedure to locate a
SIP Proxy Server.

Procedure
To find a SIP Proxy Server:

Step 1 Select Device Management > SIP Proxy Server.

The Find, Add, Delete, Edit SIP Proxy Servers window lists the available proxy servers of the type you selected, sorted
by name, 10 at a time.

Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to
page through the list. Or, you can enter a page number in the Page field and press enter to go directly to the numbered
page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case sensitive, and wildcard characters are not allowed.Note

Unified IC Server Setup
The Unified Intelligence Center (Unified IC) Server is a device type in Operations Console for Unified CVP.

To support a Unified CVP reporting solution, install and configure a Unified IC Server with the Unified CVP
Reporting Server.

To use an existing Unified IC Server as a template for creating the new Unified IC Server, select the Unified
IC Server by clicking the radio button preceding it, and then click Use As Template.

Note
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• Configured Unified IC Servers are listed in the Device Past Configurations table listing. Unified IC
Server devices are only saved to the Operations Console database--they are not saved and deployed.
Consequently, each Unified IC Server is listed as one past configuration entry.

• The Unified IC Server is a standalone device and is not integrated with Unified CVP. Therefore, the
Unified IC Server is not displayed in the Device Versions table.

• A Unified IC Server device is not included as a selectable device in the SNMP menu option windows.

• If you select a Unified CVP Reporting Server for deletion and this server has a Unified IC Server
association, a warning message prompts you to remove the association.

Add Unified IC Server
You can create a new Unified IC Server by using an existing Unified IC Server configuration as a template
or by filling in its values from scratch.
Related Topics

Unified IC Server Setup, on page 108
Edit Unified IC Server, on page 111
Delete Unified IC Server, on page 111
Find Unified IC Server, on page 112

Procedure
To add a Unified IC Server to the Operations Console database and associate it with a Unified CVP Reporting
Server:

Step 1 Select Device Management > Unified IC.

All Unified IC Servers that have been added to the Operations Console are listed in the Find, Add, Delete, Edit Unified
IC Servers list.

Step 2 Click Add New.

The Unified IC Server Configuration window opens to the General tab.

Step 3 Fill in the appropriate Unified IC Server configuration settings on the General tab.

Table 41: General Settings

Restart RequiredRangeDefaultDescriptionField

Not ApplicableValid IP addressNoneThe IP address of the Unified
IC

IP Address

Not ApplicableValid DNS name, includes
letters in the alphabet, the
numbers 0 through 9, and a
dash

NoneThe host name of the Unified
IC

Hostname

Not ApplicableUp to 1,024 charactersNoneThe description of the
Unified IC

Description
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Restart RequiredRangeDefaultDescriptionField

Not ApplicableA valid URL. The UI validates
the URL for URL syntax errors,
but no validation for site
existence

NoneThe Administration URL of
Unified IC

Device AdminURL

Table 42: Unified IC Server Serviceability Fields

Data RangeDefaultDescriptionField

Not ApplicableNot SelectedSelect this check box to
enable serviceability. This
option allows you to use
system CLI to collect
diagnostic (health and status)
and device-specific
information for Unified IC.

Enable Serviceability

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Not ApplicableThe username required to
sign in to the proxy server's
serviceability.

Username

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

Valid names contain
uppercase and lowercase
alphanumeric characters,
period, dash and underscore.

For Unified SIP Proxy Only.
The password that matches
the user password.

Password

Must match password on the
SIP Proxy.

Not ApplicableRetype password.Confirm Password

1 - 655358443The port on which
Serviceability is configured
on the SIP Proxy.

Port

Step 4 Assigning Unified CVP Reporting Servers is optional. One Unified CVP Reporting Server can be assigned to multiple
Unified IC Server devices. By associating a Reporting Server, you are tracking that this Reporting Server is being set up
as a data source for Unified IC.

Step 5 Click Device Pool to associate the Unified IC Server to a device pool.

The default device pool is automatically assigned to the newly-configured Unified IC Server. You can specifically assign
the Unified IC Server to required device pool.

Step 6 When you finish configuring the Unified IC Server, click Save to save the settings in the Operations Console database.
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Edit Unified IC Server
While you can edit any existing Unified IC Server device, you cannot change the IP address of a Unified IC
Server. The same fields present when adding a Unified IC Server (see Add Unified IC Server, on page 109)
are also displayed in the edit process.
Related Topics

Unified IC Server Setup, on page 108
Add Unified IC Server, on page 109
Delete Unified IC Server, on page 111
Find Unified IC Server, on page 112

Procedure
To edit an existing Unified IC Server:

Step 1 Select Device Management > Unified IC.

The Find, Add, Delete, Edit Unified IC Server window opens.

Step 2 Select a Unified IC Server by clicking on the link in its name field or by clicking the radio button preceding it, and then
clicking Edit. To narrow the list of servers see Find Unified IC Server, on page 112.

All fields are pre-populated with existing configuration information if available: IP Address (read-only, required),
Hostname (required), Description, Device Admin URL, and Reporting Server Assignment. Serviceability information is
also present if configured. See Add Unified IC Server, on page 109 for details on the fields.

Step 3 (Optional) Select the Device Pool tab to add/remove devices the device pool.
Step 4 When you finish configuring the Unified IC Server, click Save to save the settings in the Operations Console database.

Delete Unified IC Server
One Unified CVP Reporting Server can be assigned to several Unified IC Servers. Before the assigned Unified
CVP Reporting Server can be deleted, these associated references in the Unified IC devices must also be
removed. When you select a Unified CVP Reporting Server for deletion and that server has a Unified IC
Server association, you receive a warning message prompting you to delete all Unified IC Server associations.

You can delete existing Unified IC Servers using the procedure specified in this section.

Related Topics
Unified IC Server Setup, on page 108
Add Unified IC Server, on page 109
Edit Unified IC Server, on page 111
Find Unified IC Server, on page 112

Procedure
To delete a Unified IC Server:
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Step 1 Select Device Management > Unified IC.

The Find, Add, Delete, Edit Unified IC Server window opens.

Step 2 Select the required Unified IC Server by clicking the radio button preceding it, and then clicking Delete. To narrow the
list of servers see Find Unified IC Server, on page 112.

Step 3 When prompted to confirm the delete operation, click OK or click Cancel.

Find Unified IC Server
Use the following procedure to locate a Unified IC Server that has been added in the Operations Console.
Related Topics

Unified IC Server Setup, on page 108
Add Unified IC Server, on page 109
Edit Unified IC Server, on page 111
Delete Unified IC Server, on page 111

Procedure
To find a Unified IC Server:

Step 1 Select Device Management > Unified IC.

The Find, Add, Delete, Edit Unified IC Servers window lists the available Unified IC Servers, sorted by name.

Step 2 If the list is long, you can click the first page, previous page, next page, and last page icons on the bottom right of the
window to page through the list. Or, you can enter a page number in the Page field and press enter to go to the numbered
page.

Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter
your search term, and then click Find.

The filter is not case sensitive, and wildcard characters are not allowed.Note

Past Device Setups in Operations Console Database
You can view the past 10 saved configurations of a selected device that are currently stored in the Operations
Console database.

Find Past Device Setup
To find a past configuration for a device, first find the device. As you probably have several devices in your
network, the Operations Console lets you locate specific devices on the basis of specific criteria. Use the
following procedure to locate a device.
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Procedure
To find a past configuration for a device:

Step 1 Select Device Management > Device Past Configurations.
Step 2 If the list is long, click the first page, previous page, next page, and last page icons on the bottom right of the window to

page through the list. Or, you can enter a page number in the Page field and press enter to go to the numbered page.
Step 3 You can also filter the list by selecting an attribute such as Hostname. Then select a modifier, such as begins with, enter

your search term, and then click Find.

The filter is not case-sensitive, and wildcard characters are not allowed.Note

View Past Device Setup

Procedure
To view the details of a past configuration for a device:

Step 1 Select Device Management > Device Past Configurations.
Step 2 Select the device configuration by clicking the radio button preceding it and then clicking Past Configurations.

The List of Past Configurations window lists the configurations that have been saved for the selected device.

Step 3 Select a device past configuration to view by clicking the link in the description field or by clicking the radio button
preceding it, and then clicking View.

Configuration details for the selected past configuration are displayed.

Apply Past Device Setup
The Operations Console stores configurations for a device. You can select a previous device configuration
and apply it to a device.

Procedure
To apply a past configuration to a device:

Step 1 Select Device Management > Device Past Configurations from the Main menu.
Step 2 Select the device configuration by clicking the radio button preceding it, and then clicking Past Configurations.

The List of Past Configurations window lists the configurations that have been saved for the selected device.

Step 3 Select a device past configuration to view by clicking the link in the description field or by clicking the radio button
preceding it, and then clicking View.
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Configuration details for the selected past configuration are displayed.

Step 4 Click Save to save the selected configuration to the database.

If this is a Reporting Server, Call Server, VXML Server, Unified CVP VXML Server (standalone), or Speech
Server, you must click Save & Deploy.

Note

Device Versions
From the Device Management menu, Device Version option, you can view version information for the Call
Server, Reporting Server, Unified CVP VXML Server, and Unified CVP VXML Server (standalone). Device
version information is available for CVP specific devices only.

To view version information for CVP device types:

1. Select Device Management > Device Versions.

2. From the Select Device Type drop-down menu, select the CVP device type that you want version
information about.

The table refreshes to display devices of the selected type and corresponding version data.
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