THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS.

CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: http://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

© 2014 Cisco Systems, Inc. All rights reserved.
CONTENTS

Preface

Preface xxii

Change History xxii

About This Guide xxvii

Audience xxviii

Related Documents xxviii

Documentation and Support xxix

Documentation Feedback xxix

CHAPTER 1

Unified CCX Introduction 1

Unified CCX Components 1

Unified CCX Product Family 3

Unified IP IVR 3

Unified Contact Center Express 3

Unified CCX Cluster Architecture 5

Unified CCX Active Server 5

Unified CCX Engine 6

Set Up Unified CCX 8

Provision Telephony and Media Subsystems 8

Configure Unified CCX Subsystems 9

Provision Unified CCX Subsystem 9

Provision Additional Unified CCX Subsystems 10

View License Information 10

Upload Licenses 11

Configure Unified CCX Applications 12

Available Applications 12

Manage Scripts Prompts, Grammars, and Documents 13

Configure Unified CCX Historical Reporting 13
CHAPTER 2
Unified CCX Administration Web Interface 15
   Access Unified CCX Administration Web Interface 15
   Cisco Unified CCX Administration Menu Bar and Menus 16
   Cisco Unified CCX Administration Navigation 17
   Unified CCX Configuration Web Pages 19
      Details for Advanced Configuration 19
      Toolbar and Buttons 20
      Application and RmCm Wizards 20

CHAPTER 3
Unified CCX Provision Checklist 21
   Unified CCX 21
   Provision Unified CCX 22
   Change Licensing Packages 23

CHAPTER 4
Provision Unified CM for Unified CCX 25
   Configure Unified Communications Manager Information 25
   Modify AXL Information 26
   Modify Unified Communications Manager Telephony Information 28
   Modify RmCm Provider Information 29
   Unified Communications Manager for Unified CCX Configuration 31
      Invoke Unified Communications Manager Administration 31
      Unified Communications Manager Users as Unified CCX Agents 32
      Guidelines for Agent Phone Configuration 33
      Modify Existing Unified Communications Manager Users 35
      Assign Unified Communications Manager Users as Cisco TelePresence Virtual Agents 37
      Configure Tool for Auto-Registered Phones Support (TAPS) 38

CHAPTER 5
Cisco Applications Configuration 41
   About Unified CCX Applications 41
   Configure Script Applications 42
   Add New Cisco Script Application 43
   Configure Busy Application 45
   Configure Ring-No-Answer Application 47
CHAPTER 6

Telephony and Media Provision 65

Unified CCX Telephony and Media 65
  Media Termination Groups 66
  Channels Required to Process Calls 66
  Provision Telephony and Media Resources 67

Provision Unified CM Telephony Subsystem 68
  Resynchronize Cisco JTAI Client 68
  Resynchronize Unified CM Telephony Data 69
  Configure Unified CM Telephony Provider 69
  Add New Call Control Group 71
  Add Unified CM Telephony Trigger 77

Additional Unified CM Telephony Information 81
  Unified CM Telephony Triggers for Unified CCX Queuing 82
  Unified CM Telephony Information Resynchronization 82

Cisco Media Subsystem 83

Configure Unified ICME Post-Routing Application 48
Configure Unified ICME Translation-Routing Application 50
Configure Remote Monitoring Application 52

Application Triggers 54
  Unified CM Telephony Trigger 54
    Add Unified CM Telephony Triggers from Application Web Page 54
    Add Unified CM Telephony Triggers from Unified CCX 55
  HTTP Trigger Provision 55
    Add HTTP Trigger from Application Web Page 56
    Add HTTP Trigger from HTTP Subsystem 57

Script Management 58
  Upload New Scripts 59
  Download Script File 60
  Refresh Scripts 61
    Refresh Scripts Individually 61
    Refresh Bulk Scripts 62
  Rename Script or Folder 63
  Delete Script or Folder 64
  Sample Scripts 64
CHAPTER 7  Provision of Unified CCX  97

RmCm Provider Configuration  97
   RmCm Provider Modification  98
      Associating Agent Extensions with the RmCm Provider  98

Resource Groups  99
   Create Resource Group  99
   Modify Resource Group Name  99
   Delete Resource Group  100

Skills Configuration  100
   Create a Skill  101
   Modify a Skill Name  101
   Delete a Skill  102

Agent Configuration  102
   Implications of Deleting Agents in Unified CM  103
   Assign Resource Groups and Skills to One Agent  104
   Assign Resource Groups and Skills to Multiple Agents  105
   Remove Skills from Agents  106

Contact Service Queue Configuration  107
   Create a Contact Service Queue  107
      Contact Service Queue Configuration Web Page  110
   Modify a Contact Service Queue  112
   Delete a Contact Service Queue  112
Change IP Address for Server in Single-Node Deployment 168
IP Address Modification in High-Availability (HA) Deployment 169
Change IP Address for Publisher Server in HA Deployment 169
Change IP Address for Subscriber Server in HA Deployment 171

Host Name Modification 173
Change Host Name for Server in a Single-Node Deployment 173
Host Name Modification in High-Availability (HA) Deployment 175
Change Host Name for Publisher Server in HA Deployment 175
Change Host Name for Subscriber Server in HA Deployment 177

Verify Proper Function of System after IP Address/host name Change 178

Exit Unified CCX Administration 179

CHAPTER 11
Unified CCX Reporting 181

Reporting Administration on Unified CCX 181
Import of Stock Reports 181
Unified CCX Historical Reports 181
Unified CCX Historical Datastore 181
Historical Reporting Configuration 182
Configure Database Server Limits 182
View Historical Reports 183
Purge of Historical Data 183
Configure Automatic Purging 183
Configure Automatic Purge Schedule Configuration Parameters 184
Purge Manually 185

File Restore 186
Unified CCX Real-Time Reports 186
Available Unified CCX Real-Time Reports 186
Open Real-Time Reports 188
Run Reports 189
View Detailed Subreports 189
Print Reports 190
Reset Report Statistics 190
Clear Contact Option for Stuck Calls 190
Set Report Options 191
Set Report Appearance 191
Application Reporting User Interface 192
Report Menu 192
High Availability (HA) Setup 193
Contacts Summary Real-Time Report 193
Application Tasks Summary 195
Application Tasks Real-Time Report 195
Engine Tasks Real-Time Report 196
Contacts Report 197
Call Contacts Detailed Info Report 198
Email Detailed Info Report 198
HTTP Detailed Info Report 199
Applications Report 200
Sessions Report 201
Data Source Usage Report 201
Overall Cisco Unified Contact Center Express Stats Report 202
CSQ Cisco Unified Contact Center Express Stats Report 205
Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report 206
Chat CSQ Cisco Unified Contact Center Express Stats Report 208
Chat Resource Cisco Unified Contact Center Express Stats Report 209
Overall Chat Cisco Unified Contact Center Express Stats Report 210
Outbound Campaign Stats Report 211
Overall Outbound Stats Report 213
Resource Cisco Unified Contact Center Express Stats Report 214
Failover Behavior for Unified CCX Stats 216
Tools Menu 216
Reset All Statistics 217
Open Printable Report 217
Refresh Connections 217
Clear Contact Menu 217
Clear Stuck Calls from Contacts Real-Time Report 217
Clear Stuck Calls from Overall Cisco Unified CCX Stats 217
Clear Stuck Calls from CSQ Cisco Unified CCX Stats 218
Views Menu 218
Application Tasks 219
CHAPTER 12

Unified CCX Outbound Dialer Configuration 233

Outbound Feature for Unified CCX 233
Outbound Characteristics 234
Unified CCX Requirements 234
Outbound Components 236
Supported Dialers and Dialing Modes for Outbound 237
  Unified CCX Outbound Dialer Types 237
  Unified CCX Outbound Dialing Modes 238
  Direct Preview Dialing Mode 238
  Progressive Dialing Mode 239
  Predictive Dialing Mode 239
Configure General Outbound Properties 239
  Callbacks 242
  Outbound Area Code Functionality 243
  Configuration Updates 243
  CSQ Agent Pool Allocation 244
Configure Outbound Subsystem in Unified CCX 245
Configure Outbound Subsystem for IVR Campaigns in Unified CCX 245
Add New Campaign 246
Import Contacts for Campaign 256
Do Not Call Contacts 257
Enable Campaigns 258
Outbound Subsystem and Time Detection 259
Add Area Codes 259
Communication with Agents Desktops 260
Contact States Reset at Midnight 261
Call Retrieval Priority 261
Failover and System Restarts 262

CHAPTER 13
Cisco Unified Contact Center Express Supervisor and User Options Plug-Ins 263
  About User Management 263
  About Unified CCX User Capabilities 263
    Administrator Privileges 264
    Supervisor Privileges 264
    Historical Report User Privileges 265
    Agent Privileges 265
  Unified CCX Supervisor Web Interface 266
    Access Unified CCX Supervisor Web Page 266
    Agent Supervision 267
    Monitor CSQs 267
View CSQ IDs for Remote Monitoring 267
Unified CCX User Options Web Interface 268
Access Unified CCX User Options Web Page 268
Download Agent Desktop 268
Cisco Unified CCX Desktop Client Configuration Tool 269
Add Alternative Pronunciations 270
Access Unified CM User Options Page 270

CHAPTER 14

System Menu 273
Access Server Menu 273
Configure Server 274
Configure IPv6 Address 274
Unified CM Configuration 275
System Parameters 275
Recording Configuration 276
Custom File Configuration 276
License Information 276
Add Licenses 277
Display Licenses 277
Language Information 278
Logout Menu 279

CHAPTER 15

Applications Menu 281
Access Application Management Menu 281
Manage Scripts 282
Prompt Management 283
Grammar Management 283
Document Management 284
AAR Management 284

CHAPTER 16

Subsystems Menu 287
Unified CM Telephony Menu 288
Unified CM Telephony Provider Configuration 288
Unified CM Telephony Call Control Group Configuration 289
Unified CM Telephony Triggers Configuration 289
Synchronize Unified CM Telephony Data 289
Unified CM Telephony Cisco JTAPI Resync 290
Unified CM Telephony Advanced Settings 291

RmCm Menu 291
Skill Configuration 292
  Add New Skill 292
  Modify Skills 292
Resources Configuration 293
  Modify Resource 293
Resource Group Configuration 294
  Add New Resource Group 294
  Modify Existing Resource Groups 294
Contact Service Queues Configuration 294
  Add a CSQ 295
RmCm Provider Configuration 295
Skills Configuration Assignment 295
  Add Skills 296
  Remove Skills 296
Remote Monitor Configuration 296
  Assign Resources and CSQs to Remote Supervisor 296
Agent Based Routing Settings Configuration 297
Teams Configuration 297
  Add New Team 297
Chat Menu Option 297
Chat Contact Service Queues 298
Cisco SocialMiner Configuration 300
  Chat Transcripts 301
Predefined Responses 302
  Predefined Response Configuration 302
Chat System Parameters 303
List Chat Web Forms 304
  Chat Web Form Configuration 304
Teams 306
  Obtaining CA-Signed Certificate for Web Chat 306
Outbound Menu 307
General Configuration 307
Campaign Configuration 307
   Add New Campaigns 308
   Import Contacts 308
   Delete Contacts 308
Area Code Management 309
   Add New Area Code 309
Configure SIP Gateway 309
   SIP Gateway Configuration Web Page 310
   Dial Peer Configuration for Outbound 312
Unified ICM Menu 313
   Unified ICME Configuration 313
   Unified ICME VRU Scripts 314
      Add New VRU Script 314
Database Menu 314
   DataSource 315
      New DataSource 315
      Add New Database Parameter 316
      Driver 316
      Add New Database Driver 316
HTTP Menu 317
   HTTP Configuration 317
      Add New HTTP Trigger 318
eMail Menu 318
Cisco Media Menu 318
MRCP ASR Menu 319
   MRCP ASR Provider 319
   MRCP ASR Servers 319
   MRCP ASR Dialog Groups 320
MRCP TTS Menu 320
   MRCP TTS Providers 320
   MRCP TTS Servers 320
   MRCP TTS Default Genders 321

CHAPTER 17 Wizards Menu 323
CHAPTER 18

Tools Menu 327

Plug-Ins Menu 327
Real-Time Reporting Menu 328
Real-Time Snapshot Config Menu 329
Create System DSN for Wallboard 330

Wallboard Software in High Availability (HA) Deployment 332
Use Upgraded Wallboard Software with New Service in HA Deployment 332
Use Wallboard Software (without New Service) in HA Deployment 332

Historical Reporting Menu 333
Database Server Configuration 334
SMTP Configuration 334
Purge Schedule Configuration Option 335
Purge Now Option 335
File Restore Option 335
User Management Menu 336

User View Submenu 337
Name Grammar Generator Configuration 337
Spoken Name Upload Submenu 338
Administrator Capability View Menu 339
Supervisor Capability View Menu 339
Reporting Capability View Menu 340
Agent Capability View Menu 340
Password Management 341

CHAPTER 19

Help Menu 343

Contents and Index 343
For This Page Menu 344
Troubleshooting Tips Menu 344
Unified CCX Documentation Link 344
About Menu 345

CHAPTER 20

Cisco Mobile Skill Manager 347
Access Mobile Skill Manager  347
Adding Skills Using Cisco Mobile Skill Manager  348
Searching Skills Using Cisco Mobile Skill Manager  349
View Details of Resources Assigned to Supervisor  349
View Resources Assigned to Supervisor  350
Search Resources Using Cisco Mobile Skill Manager  350
Modify Resource Team  350
Assign Skill Competency to Resource  351
Unassign Skill Competency of Resource  351

CHAPTER 21
Unified CCX Web Chat  353
Unified CCX Web Chat  353

CHAPTER 22
Cisco Finesse  355
Introduction  355
Cisco Finesse Administration Console  356
Getting Started  356
Administration Tools  356
Cisco Finesse Administration Console  356
Sign In to Cisco Finesse Administration Console  357
Manage Call Variables Layout  357
Call Variables  357
Configure Call Variable Layout  358
Add ECC Variables to Call Variables Layout  359
Manage Desktop Layout  359
Finesse Desktop Layout XML  360
Default Layout XML  360
Update Default Desktop Layout  364
XML Schema Definition  365
Add Web Chat to Finesse  366
Add Web Chat to the Default Desktop Layout  367
Add Web Chat to a Custom Desktop Layout  369
Add Web Chat to a Team Layout  371
Live Data Gadgets  373
Add Live Data Gadgets to Desktop Layout  376
Add Customized Live Data Gadgets to Desktop Layout 377

Manage Phone Books 378
  Phone Books and Contacts 378
    Add Phone Book 379
    Edit Phone Book 379
    Delete Phone Book 380
  Import Contacts 380
  Export Contacts 381
  Add Contact 381
  Edit Contact 382
  Delete Contact 382

Manage Reasons 382
  Not Ready Reason Codes 383
    Add Not Ready Reason Code 384
    Edit Not Ready Reason Code 384
    Delete Not Ready Reason Code 385
  Sign Out Reason Codes 385
    Add Sign Out Reason Code 386
    Edit Sign Out Reason Code 387
    Delete Sign Out Reason Code 387
  Wrap-Up Reasons 388
    Add Wrap-Up Reason 389
    Edit Wrap-Up Reason 389
    Delete Wrap-Up Reason 389

Manage Team Resources 390
  Team Resources 390
  Assign Phone Books and Reasons to Team 391
  Unassign Phone Books and Reasons from Team 392
  Assign Custom Desktop Layout to Team 392
  Assign Workflows to Team 393
  Unassign Workflows from Team 393

Manage Workflows 393
  Workflows and Workflow Actions 394
    Workflow Triggers and Outbound Calls 397
  Add Browser Pop Workflow Action 397
Add HTTP Request Workflow Action 398
Edit Workflow Action 399
Delete Workflow Action 400
Add Workflow 400
Edit Workflow 401
Delete Workflow 401
Manage Security 401
Trust Self-Signed Certificate 402
Obtain and Upload CA Certificate 404
Add Certificate for HTTPS Gadget 406
Add Certificate for Multi-session Chat 407
CTI Failover 407
Backup and Restore 407
Additional Language Support 408
Cisco Finesse Agent and Supervisor Desktop 408
Call Manager-Based Call Recording Using Cisco MediaSense 408
Configure Cisco MediaSense with Unified CM 408
Upload Cisco MediaSense Certificate to Unified CCX Server 409
Upload MediaSense Recording License 409
Configure MediaSense as a Recording Server 409
Call Recording Through Workflow 410
Configure MediaSense Search and Play Gadget 411

CHAPTER 23 Extend and Connect 413
Overview 413
Server Configuration 413
Persistent Connection 415

APPENDIX A Cisco Unified Contact Center Express License Packages 417
Application Availability by License Package 417
Trigger Availability by License Package 417
Subsystem Availability by License Package 418
Unified CCX Services Availability by License Package 419
Unified CCX Component Availability by License Package 419
Preface

• Change History, page xxi
• About This Guide, page xxiii
• Audience, page xxiv
• Related Documents, page xxiv
• Documentation and Support, page xxv
• Documentation Feedback, page xxv

Change History

<table>
<thead>
<tr>
<th>Change</th>
<th>See</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Added additional details about call recording through workflow.</td>
<td>Updated Call Recording Through Workflow, on page 410.</td>
<td>July 25, 2014</td>
</tr>
<tr>
<td>Added that CSV files must use Latin or UTF-8 encoding for importing phone book contacts.</td>
<td>Updated Import Contacts, on page 380.</td>
<td>July 25, 2014</td>
</tr>
<tr>
<td>Change</td>
<td>See</td>
<td>Date</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Updated the Progressive and Predictive Agent Outbound feature for campaign configurations, import contacts, delete contacts, RTR reports, outbound properties, live data reports, outbound license, callbacks, and E.164 support.</td>
<td>• Updated Add New Campaign, on page 246 to add new fields.</td>
<td>Initial release of document for 10.5(1)</td>
</tr>
<tr>
<td></td>
<td>• Updated Import Contacts for Campaign, on page 256.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Delete Contacts, on page 308.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Renamed and updated Outbound Campaign Stats Report, on page 211 and Overall Outbound Stats Report, on page 213 RTR reports.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Configure General Outbound Properties, on page 239.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Live Data Gadgets, on page 373 to add gadget URL for the new live data report.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Display Licenses, on page 277 and View License Information, on page 10 to add outbound licence information.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Resource Cisco Unified Contact Center Express Stats Report, on page 214 RTR report.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Callbacks, on page 242 to add a note.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Outbound Subsystem and Time Detection, on page 259 to support E.164.</td>
<td></td>
</tr>
<tr>
<td>Added E164 support for Call Control Group.</td>
<td>• Updated Add Unified CM Telephony Trigger, on page 77.</td>
<td>Initial release of document for 10.5(1)</td>
</tr>
<tr>
<td></td>
<td>• Updated Add New Call Control Group, on page 71.</td>
<td></td>
</tr>
<tr>
<td>Change</td>
<td>See</td>
<td>Date</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Updated the Web Chat feature for multiline support, multisession chat, new configuration pages, and new reports.</td>
<td>• Updated Chat Web Form Configuration, on page 304 to add new fields and added List Chat Web Forms, on page 304.</td>
<td>Initial release of document for 10.5(1)</td>
</tr>
<tr>
<td></td>
<td>• Updated Chat System Parameters, on page 303 to add new fields.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Introduction, on page 355 to add reboot of server after Finesse activation.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Added Modify Manage Chats Gadget Height.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Live Data Gadgets, on page 373 to add new Web chat reports and their gadget URLs.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Resources Configuration, on page 293 to add the alias field.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Added Predefined Responses, on page 302 and Predefined Response Configuration, on page 302.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Updated Chat Resource Cisco Unified Contact Center Express Stats Report, on page 209 to add a new field.</td>
<td></td>
</tr>
</tbody>
</table>

**About This Guide**

Cisco Unified Contact Center Express (Unified CCX), a member of the Cisco Unified Communications family of products, manages customer voice contact centers for departments, branches, or small to medium-size companies planning to deploy an entry-level or mid-market contact center solution.

The *Cisco Unified CCX Administration Guide* provides instructions for using the Administration web interface to provision the subsystems of the Unified CCX package and to configure Unified CCX applications.

This guide shows you how to implement the following two systems that integrate with the Unified CCX:

- Cisco Unified Contact Center Express (Unified CCX)
- Cisco Unified IP IVR

This guide also includes a reference section that describes all the menus and menu options of the Unified CCX Administration web interface.

This guide will help you to:

- Perform initial configuration tasks
• Administer applications such as the Unified CCX Engine and other components of the Cisco Unified Communications family of products
• Familiarize yourself with the menus and menu options of the Unified CCX Administration web interface

**Audience**

The *Cisco Unified CCX Administration Guide* is written for business analysts and application designers who have the domain-specific knowledge required to create multimedia and telephony customer response applications. Experience or training with Java is not required but is useful for making best use of the capabilities of the Cisco Unified Communications family of products.

**Related Documents**

<table>
<thead>
<tr>
<th>Document or Resource</th>
<th>Link</th>
</tr>
</thead>
<tbody>
<tr>
<td>Troubleshooting tips for Unified CCX</td>
<td><a href="http://docwiki.cisco.com/wiki/Troubleshooting">http://docwiki.cisco.com/wiki/Troubleshooting</a>_ Unified_Contact_Center_Express</td>
</tr>
<tr>
<td>Virtualization for Unified CCX</td>
<td><a href="http://docwiki.cisco.com/wiki/Virtualization_for">http://docwiki.cisco.com/wiki/Virtualization_for</a>_ Cisco_Unified_Contact_Center_Express</td>
</tr>
</tbody>
</table>
Documentation and Support


You can also subscribe to the *What's New in Cisco Product Documentation* RSS feed to deliver updates directly to an RSS reader on your desktop. The RSS feeds are a free service. Cisco currently supports RSS Version 2.0.

Documentation Feedback

To provide your feedback for this document, send an email to:

contactcenterproducts_docfeedback@cisco.com
Unified CCX Introduction

Unified CCX provides a multimedia (voice, data, and web) IP-enabled customer-care application environment that enhances the efficiency of contact centers by simplifying business integration, easing agent administration, increasing agent flexibility, and enhancing network hosting.

The following sections provide an overview of the configuration and management components of the Unified CCX product family:

- Unified CCX Components, page 1
- Unified CCX Product Family, page 3
- Unified CCX Cluster Architecture, page 5
- Unified CCX Engine, page 6
- Set Up Unified CCX, page 8
- Manage Unified CCX, page 14

Unified CCX Components

This section describes the following components of the Unified CCX system:

- Unified Gateway—Connects the Cisco Unified Communications family of products to the Public Switched Telephone Network (PSTN) and to other private telephone systems such as PBX.

- Unified CM Server—The Cisco Unified Communications Manager (Unified CM) provides the features required to implement IP phones, manage gateways, provide failover and redundancy service for the telephony system, and direct Voice over IP (VoIP) traffic to the Unified CCX system.

Note
Cisco Unified Communications Manager was previously known as Unified Call Manager. This guide uses Cisco Unified Communications Manager at the first occurrence and Unified CM for later occurrences.

- Unified CCX Server—Contains the Unified CCX Engine that runs applications, including Cisco script applications, Unified CM user integration, Cisco Unified Intelligent Contact Management Enterprise
(Unified ICME) translation-routing and post-routing applications, Busy applications, Ring No Answer applications, and Voice Extensible Markup Language (VXML) 2.0 applications.

You can position your Unified CCX application server anywhere on the IP network and administer your applications from a web browser on any computer on the IP network. Because Unified CCX uses an open architecture that supports industry standards, you can integrate your applications with a wide variety of technologies and products such as Enterprise databases and Unified CCX Agent Desktop. The Unified CCX Server has the following components:

- Unified CCX Configuration Datastore (CDS)—Manages configuration, component, and application information within the Unified CCX cluster and communicates with Unified CM. See the Cisco Unified Contact Center Express Serviceability Administration Guide.

- Historical Reports Database Server—Dedicated server that stores Unified CCX database for the following datastores: Configuration Datastore (CDS), Historical Datastore (HDS), Repository Datastore (RDS), and Agent Datastore (ADS).

  Note: If you are using Microsoft Internet Explorer Version 6.0 or later or Mozilla Firefox Version 2.0 or 3.0 browser, verify that the popup blocker is disabled.

- Cisco SocialMiner—Acts as the endpoint that hosts the widgets that end users and agents use during the chat session. SocialMiner accepts the chat request, communicates with Unified CCX to allocate an agent for the chat and then establishes the chat session between agent and end user.

  Note: Support for high availability and remote servers is available only in multiple-server deployments.

- Unified CCX Editor—Allows application developers to use a simple Graphical User Interface (GUI) to create, modify, and debug Unified CCX scripts for automating customer interactions. Each script consists of a series of steps, implemented as Java Beans.

- Unified CCX Administration and Unified CCX Serviceability web interfaces—Provides access through a web browser for administrators to configure and manage Unified CCX datastores, servers, and applications.

- Cisco IP Agent and Supervisor Desktops—Desktop programs that allow Unified CCX agents and supervisors to log in to the system, change agent states, and monitor status.


- MRCP Text-to-Speech (TTS) server—(optional) Dedicated server that converts text into speech and plays it back to the caller.

- Cisco Unified Intelligence Center—A web-based reporting solution for historical reports that provides detailed Call Contact Call Detail Records (CCDRs), application performance, and traffic analysis information.
Unified CCX Product Family

The Unified CCX product family provides contact-processing functions for your Cisco Unified Communications solution.

The software package that you choose determines which steps, components, and subsystems you receive. Each Unified CCX product includes Unified CCX Engine and Unified CCX Editor.

Unified IP IVR

The Unified IP IVR is a multimedia (voice, data, web) IP-enabled interactive voice response solution that offers an open and feature-rich foundation for the creation and delivery of Unified IP IVR applications through Internet technology.

Unified IP IVR automates call handling by autonomously interacting with contacts. Using Unified IP IVR, you can create applications that answer calls, provide menu choices for callers, obtain caller data such as passwords or account identification, and transfer calls to caller-selected extensions. You can also create Unified IP IVR applications that respond to HTTP requests, perform outbound calling, send e-mail, and process VXML 2.0 commands.

The Unified IP IVR package provides the following features:

- Java Database Connectivity (JDBC) support—Unified IP IVR applications can access Oracle, Sybase, and IBM DB2 databases.
- Real-time reporting client—Unified IP IVR applications can generate a variety of reports that provide detailed information about the real-time status of your system.
- Cisco Unified Intelligence Center—A web-based reporting solution for historical reports that provides detailed Call Contact Call Detail Records (CCDRs), application performance, and traffic analysis information.
- Automatic Speech Recognition (ASR)—Unified IP IVR applications can take advantage of ASR to provide callers with the option to use speech to navigate through menu options.
- Text-to-Speech (TTS)—Unified IP IVR applications can use TTS to read back documents and prescribed prompts to callers.

Unified Contact Center Express

Cisco Unified Contact Center Express (Unified CCX) is an IP-based Automated Call Distribution (ACD) system that queues and distributes incoming calls to Unified CCX agents, who can be groups of Unified CM users for Unified CM integration.

You can use Unified CCX applications to route calls to specific agents. You can also integrate Unified CCX with Unified IP IVR to gather caller data and classify incoming calls.

Unified CCX includes a web-based real-time and historical reporting system that you can use to monitor system, Contact Service Queue (CSQ), and resource performance.

The Unified CCX system consists of the following major components:
- **ResourceManager**—Application program that monitors Unified CCX agent phones and allows you to organize agents into resource groups or skills-based partitions according to the types of calls each group can handle.

- **CSQ**—Application program that places incoming calls in a queue and distributes them to the appropriate set of agents as the agents become available.

- **Unified CCX Agent Desktop**—Application program that Unified CCX agents run on their desktop computers to log in to the system, change Unified CCX state, and monitor status.

The following licensing options are available for the Unified CCX system:

- **Unified CCX Standard** (designed for entry-level users)—Includes the steps necessary for creating basic Unified CCX applications, including IP Phone Agent (IPPA) and skills-based routing, and does not include Cisco Agent Desktop (CAD).

- **Unified CCX Enhanced** (designed for enterprise-level users)—Includes all functions of Unified CCX Standard, plus support for priority queuing. Includes a license to enable custom Java extensions.

- **Unified CCX Premium**—Adds full Unified IP IVR support (except for Unified ICM integration) including database integration, Voice eXtensible Markup Language (VoiceXML), HTML web integration, custom Java extensions, and e-Notification services. The outbound feature is now bundled with the Premium package. You will receive one outbound seat free with each premium seat. The maximum number of outbound seats supported will be based on the hardware type.

- **Unified CCX Outbound**—You need to have a Unified CCX Outbound license in addition to a Unified CCX Premium license to enable the IVR and agent outbound feature. You can increase the number of ports and agents for an existing Outbound license. For all the IVR and agent based outbound campaigns that are running currently in your Unified CCX, the Display License submenu option displays these IVR ports and agent seats:
  - The licensed IVR ports for outbound.
  - The licensed agent seats for outbound.
  - The sum of the dedicated IVR ports configured for IVR-based outbound campaigns.
  - The agent seats that currently in use for agent-based outbound campaigns.

**Note**

- The dedicated outbound IVR ports for a campaign is the number of IVR ports that you want to reserve for a campaign from the total number of CTI ports available in the outbound call control group.

**Note**
The Unified CCX Enhanced package and the Unified CCX Premium package are provisioned in the same way.
Unified CCX Cluster Architecture

Support for high availability and remote servers is available only in multiple-server deployments.

The Unified CCX cluster consists of one or more servers (nodes) that are running Unified CCX components in your Unified CCX deployment.

If you deploy Unified CCX components on a single server, the Unified CCX cluster (often referred to as cluster in this manual) consists of that server. If you deploy Unified CCX on multiple servers, the cluster includes the Unified CCX server and standby server on which you installed Unified CCX. The Unified CCX cluster can support up to two Unified CCX Servers, one designated as the active Unified CCX Server and the other designated as the standby Unified CCX Server for high availability purposes.

When you install or upgrade Unified CCX on a server, you designate the cluster to which the server will belong by designating the cluster profile for that cluster.

Cluster architecture accommodates high availability and failover because if a component fails, a secondary server will take over the functionality lost by that failed component.

All Unified CCX servers within the cluster are configured identically and installed with the same features. One server is designated the active server.

Unified CCX Active Server

Support for high availability and remote servers is available only in multiple-server deployments.

The Unified CCX active server makes global decisions for the cluster and keeps track of calls in the CSQs, agent states (if Unified CCX is installed) and generating historical detail records.

Only one server in the cluster can be the active server at any given time.

If the active server fails, the Unified CCX provides automatic failover to the standby server. If the active server fails (for example, in the event a hardware failure occurs or the Unified CCX Engine process terminates), some calls being handled by the server are lost. The lost calls are restricted to those being handled by the system (those in the IVR stage or in queue). Calls answered by agents continue to remain live even though related data on the agent desktop is lost. When the standby server takes over as the new active server, call processing continues.

A Unified CCX cluster consists of the one or more servers (nodes) that run Unified CCX components in your Unified CCX deployment.

Cluster management consists of two main elements:

Cluster Manager

Receives updates about cluster status and subsystem states.
Cluster View Daemon (CVD)

Java code that interacts with Platform Service Manager and implements internode communication on behalf of the cluster. It detects availability of the other nodes, components and services, provides consistent cluster view, and dynamically elects a master service.

The following figure shows the components of the CVD interaction with nodes.

**Figure 1: Components of the CVD Interaction with Nodes**

The CVD has two interfaces:

- **One that monitors inside the node**, using:
  - Node Manager to monitor and control local processes
  - Cluster Manager publisher or subscriber to communicate with local applications, such as Engine and Application Administration

- **One that monitors outside the node** and communicates with other nodes in the cluster

For detailed information about Unified CCX clusters, see *Unified CCX System Management*, on page 159.

**Related Topics**

- High Availability and Automatic Failover, on page 160
- Basic Terminology, on page 159
- Unified CCX System Management, on page 159

**Unified CCX Engine**

The Unified CCX Engine enables you to run multiple applications to handle Unified CM Telephony calls or HTTP requests.

The Unified CCX Engine uses the Unified CM Telephony subsystem to request and receive services from the Computer Telephony Interface (CTI) manager that controls Unified CM clusters. The Unified CCX Engine is implemented as a service that supports multiple applications.

You can use a web browser to administer the Unified CCX Engine and your Unified CCX applications from any computer on the network. Unified CCX provides you the following two web interfaces:
• Unified CCX Administration web interface—Used to configure system parameters, subsystems, view real-time reports that include total system activity and application statistics, and so on

• Unified CCX Serviceability web interface—Used to view alarm and trace definitions for Unified CCX services, start and stop the Unified CCX Engine, monitor Unified CCX Engine activity, and so on

**Note**
If you are using Microsoft Internet Explorer Version 6.0 or later or Mozilla Firefox Version 2.0 or 3.0 browser, verify that the popup blocker is disabled.

Depending on the Unified CCX products that you are using, the Unified CCX server may employ as many as 14 subsystems for communicating with other services:

**Applications**
Manages the applications in the Unified CCX Engine and other features such as session management.

**Cisco Media**
Configures Cisco Media Termination (CMT) dialog control groups, which can be used to handle simple Dual Tone Multifrequency (DTMF)-based dialog interactions with customers.

**Core Reporting**
Provides information for Unified IP IVR real-time reports.

**Database**
Handles the connections between the Unified CCX server and the enterprise database.

**eMail**
Adds components to the Unified CCX Engine that allows the engine to send email messages.

**Enterprise Server**
Communicates data for screen pops to the Unified CCX Agent Desktop.

**HTTP**
Adds components to the Unified CCX Engine that allow the engine to respond to HTTP requests.

**ICM Subsystem**
Manages the connection between the Unified CCX server and ICM.

**Unified CM Telephony**
Manages the connection between Unified CM CTI Manager and the Unified CCX Engine.

**MRCP ASR**
Allows a script to respond to voice input in addition to DTMF using the MRCP protocol.

**MRCP TTS**
Composes voice prompts that are generated real-time from text, such as speaking the words in the text of an email message using the MRCP protocol.
Resource Manager-Contact Manager (RmCm)
Allows Unified CCX to monitor agent phones, control agent states, route and queue calls, and manage the historical reporting feature.

Chat
Allows Unified CCX to configure and manage Web Chat.

Voice Browser
Manages Voice Browser functionality.

Unified CCX Voice over Internet Protocol (VoIP)
Enables remote recording and monitoring.

Note
Recording and monitoring over preconfigured SPAN port is not supported in high availability over WAN deployment of Unified CCX.

Set Up Unified CCX
After you install the Unified CCX system and perform the initial setup as described in Cisco Unified Contact Center Express Installation Guide, you can start provisioning and configuring the system:

• Provisioning is the process of allocating resources and devising strategies for using the resources to support the needs of your business.
• Configuring is the process of making applications available to the Unified CCX system.

Provision Telephony and Media Subsystems
The Unified CCX telephony and media subsystems manage telephony and media resources and communicate with supporting telephony and media systems.

Depending on the Unified CCX applications you plan to use, you need to provision some or all of the following subsystems:

• Unified CM Telephony—The Unified CM Telephony subsystem controls the Unified CM Telephony resources for the Unified CCX system.

Caution
While Unified CM supports Unicode characters in first and last names, those characters become corrupted in Unified CCX Administration web pages for Real-Time Reporting, Cisco Agent/Supervisor Desktop.

• Cisco Media—The Cisco Media subsystem controls the CMT media resources for the Unified CCX system.
• MRCP ASR—The MRCP ASR subsystem controls the ASR media resources for the Unified CCX system.
• **MRCP TTS**—The MRCP TTS subsystem controls the TTS media resources for the Unified CCX system.

**Related Topics**

Telephony and Media Provision, on page 65

### Configure Unified CCX Subsystems

You need to provision your Unified CCX subsystems to enable the Unified CCX Engine to run multiple applications to handle Unified Communications calls or HTTP requests.

**Note**

You need to configure a particular subsystem only if you are using Unified CCX applications that require it and which are installed and activated using the appropriate license.

To continue the Unified CCX system configuration process, connect to the Unified CCX Administration web interface and perform the task in the links listed in the Related Topics section.

**Related Topics**

Wizards Menu, on page 323

### Provision Unified CCX Subsystem

If you have purchased any of the three versions of Unified CCX, you must provision the Unified CCX subsystem.

Provision the following settings on the Unified CCX subsystem:

• **RmCm Provider**

  The Resource Manager (RM) of the Unified CCX system uses a Unified CM user (called a Unified CM Telephony provider) for monitoring agent phones, controlling agent states, and routing and queueing calls.

• **Resources**

  Agents that answer calls are also called resources. After you create a resource group, you must assign agents (resources) to that group. You can assign skills to agents if you have a Unified CCX Standard license.

• **Resource Groups**

  Collections of agents that your CSQ uses to handle incoming calls. To use resource group-based CSQs, you must specify a resource group.

• **Skills**

  (Unified CCX Standard license) Customer-definable labels that are assigned to agents. You can route incoming calls to agents who have the necessary skills or set of skills to handle the call.

• **CSQs**

  After you assign an agent to a resource group or assign skills to an agent, you need to configure the agent for the CSQ to which the agent will be assigned.
• **Agent-Based Routing Settings**
  You can configure Automatic Work and Wrapup Time settings for the agent-based routing feature from the Agent-Based Routing Settings page.

• **Remote Monitoring**
  If you want to associate agents and CSQs that will be monitored by remote supervisors, you need to configure remote monitoring settings.

• **Teams**
  If you want to create or associate teams with various agents, CSQs, and supervisors, you need to configure team settings.

**Related Topics**
- Agent Based Routing Settings Configuration, on page 297
- Provision of Unified CCX, on page 97
- Wizards Menu, on page 323

### Provision Additional Unified CCX Subsystems

The additional Unified CCX subsystems provide Unified ICME, HTTP, Database, and email features. Provision the following subsystems:

- **Unified ICME**—The ICM subsystem communicates with Unified ICME software.
- **HTTP**—The HTTP subsystem enables Unified CCX applications to respond to requests from a variety of web clients.
- **Database**—The Database subsystem enables Unified CCX applications to communicate with enterprise database servers.
- **eMail**—The eMail subsystem enables Unified CCX applications to create and send email.

**Related Topics**
- Provision of Additional Subsystems, on page 123

### View License Information

The initial license configuration is part of the Setup Wizard procedure (during installation). The uploaded licenses define the feature set for a Unified CCX system. See *Cisco Unified Contact Center Express Installation Guide* for more information on obtaining and installing licenses for Cisco Unified CCX.

You can add additional licenses using the **Add Licenses** submenu option.
Note

- If two licenses with the same feature name are uploaded, the Unified CCX Administration Display Licenses web page will display the earlier date as the expiry date. Although the expiry date refers to the earlier date, it does not mean that the license expires on the date displayed in the “Display Licenses” page if you upload a permanent license.

- If a permanent license is uploaded over an already existing temporary license, a license expiry message is displayed for the temporary license for the feature. This license expiry message is displayed both in License Information and Appadmin home page. The Appadmin home page displays a popup message.

For Unified CCX, if you have a premium license with an outbound license, the Unified CCX Administration Display Licenses web page displays:

- The number of licensed IVR ports and dedicated IVR ports for IVR outbound.
- The number of licensed agent seats and In Use agent seats for progressive and predictive agent outbound.

Note

The number of In Use IVR ports and In Use agent seats are displayed only for the master node.

Caution

Deleting or reducing the number of IVR ports for outbound in the license is not a supported scenario in Unified CCX. Doing this might lead to inaccurate data in Dedicated Licensed Ports, which in turn might lead to more abandoned calls.

To view license details, perform the following procedure:

Procedure

Choose System > License Information > Display License(s) from the Unified CCX Administration menu bar.
The License Information web page opens, displaying the details of the configured licenses, including the expiry date in the case of time-bound licenses.

Related Topics

Add Licenses, on page 277
Cisco Unified Contact Center Express License Packages, on page 417
License Information, on page 276

Upload Licenses

Software for all of the Unified CCX feature components are loaded on the system during installation. However, no feature is available for use unless a license for that feature is added and activated.
You can upload and display licenses using the License Information page. To upload a license, complete the following steps.

**Procedure**

**Step 1**  
From the Unified CCX Administration menu bar, choose **System > License Information > Add License(s)**. The License Information web page opens.

**Step 2**  
Specify a License file or click **Browse** to locate a file. You can either specify a single file with a .lic extension or a .zip file containing multiple .lic files.  

**Note**  
While you are upgrading from a previous release, if there are multiple licenses, Cisco recommends that you zip all the .lic files into a single .zip file and then upload the zip file. If specifying a .zip file, ensure that all .lic files that need to be added are in the root of the .zip file and are not in subfolders in the .zip file.

**Step 3**  
Click **Upload**.  
On successful upload of the license, you will see the following confirmation message in the status bar at the top of this web page: **License has been uploaded successfully**

If you upload an Add-on license to increase the existing licensed Outbound IVR ports, the following message will be displayed:  

*As the number of licensed Outbound IVR Ports have increased, please increase the number of ports in the Outbound Call Control Group to utilize all the licensed ports.*

**Configure Unified CCX Applications**

After you provision the Unified CCX subsystems and view your license information, you need to configure Unified CCX applications to interact with contacts and perform a wide variety of functions.

To continue the Unified CCX system configuration process, connect to the Unified CCX Administration web interface and manage the following tasks:

- **Available Applications**, on page 12
- **Manage Scripts Prompts, Grammars, and Documents**, on page 13
- **Wizards Menu**, on page 323

**Available Applications**

There are several types of applications you can configure for Unified CCX:

- Script applications perform such functions as receiving calls, playing back prompts, receiving caller input, transferring calls, and queueing calls.
- The Busy application simulates a busy signal.
- The Ring-No-Answer application simulates a ringtone.
In addition, if your Unified CCX system is to be configured to interact with Unified IP IVR for Unified ICME (not with Unified CCX by way of the Unified Gateway), two extra applications are available: ICME post-routing applications and ICME translation-routing applications.

After adding a Unified CCX application, you need to define a trigger so that this application can respond to telephone calls and HTTP requests. Triggers are specified signals that invoke application scripts in response to incoming contacts.

**Related Topics**
- About Unified CCX Applications, on page 41
- Cisco Applications Configuration, on page 41

**Manage Scripts Prompts, Grammars, and Documents**

The process of configuring Cisco script applications includes uploading Unified CCX scripts and prerecorded prompts, installing grammars and customized languages, and adding triggers to applications.

Depending on your particular Unified CCX implementation, you may need to perform most or all of the following tasks to configure a Cisco script application:

- **Manage scripts**—Cisco script applications are based on scripts that you must upload to the repository and make available to the Unified CCX system.

- **Manage prompts**—Many applications make use of prerecorded prompts, stored as .wav files, which are played back to callers to provide information and elicit caller response. You must upload these .wav files to the repository and make them available to the Unified CCX system.

- **Install grammars**—A grammar is a specific set of all possible spoken phrases and Dual Tone Multi-Frequency (DTMF) digits to be recognized by Unified CCX applications and acted upon during run time. The Unified CCX system uses specific grammars when recognizing and responding to caller responses to prompts. You must store these grammars in a directory to make them available to the Unified CCX system.

- **Install customized Unified CCX languages**—Language packs, such as American English and Canadian French, are installed with Unified CCX.

**Related Topics**
- Manage Prompt Files, on page 137

**Configure Unified CCX Historical Reporting**

When you install the Unified CCX system, the installation process creates a database named db_cra. This database contains:

- Information for historical reports, including Unified CCX configuration information, stored procedures, and some call statistics

- The ContactCallDetail table, which is the main table for call statistics

To conclude the Unified CCX system configuration process, connect to the Unified CCX Administration web interface and perform the following Historical Reporting Configuration tasks:
Procedure

**Step 1** Define the maximum number of database connections for report client sessions.
**Step 2** Assign historical reporting capability to users.
**Step 3** Configure the Daily Purge Schedule and specify notification parameters.

Related Topics

Unified CCX Historical Reporting Management

## Manage Unified CCX

To manage your Unified CCX, you must first provision and configure it. The day-to-day administration of the Unified CCX system and datastores consist of many tasks, such as:

- Starting and stopping the Unified CCX Engine and processes.
- Managing and monitoring the status of Unified CCX servers and components across the cluster.

**Note** Support for high availability and remote servers is available only in multiple-server deployments.
Unified CCX Administration Web Interface

The Unified CCX provides a multimedia (voice, data, and web) IP-enabled customer-care application environment, using VoIP technology that allows your Cisco Unified Communications network to share resources with your data network.

You can then use a web browser located on any computer on the IP network to configure and administer your applications with the Unified CCX Administration web interface.

Support for high availability and remote servers is available only in multiple-server deployments.

The Unified CCX Administration web interfaces (Cisco Unified CCX Administration and Cisco Unified CCX Serviceability) allows you to:

- Configure and monitor overall system functions, applications, and subsystems
- Access a wide variety of system tools
- Perform many other administrative tasks

The following sections provide more information about the Unified CCX Administration web interface:

- Access Unified CCX Administration Web Interface, page 15
- Cisco Unified CCX Administration Menu Bar and Menus, page 16
- Cisco Unified CCX Administration Navigation, page 17
- Unified CCX Configuration Web Pages, page 19

Access Unified CCX Administration Web Interface

The web pages of the Unified CCX Administration web interface allow you to configure and manage the Unified CCX system and its subsystems.

Use the following procedure to browse into the server and log in to Unified CCX Administration web interface.
Procedure

Step 1  Open the Unified CCX Administration Authentication page from a web browser on any computer on your network and enter the following case-sensitive URL:

https://<servername>/appadmin

In this example, replace <servername> with the hostname or IP address of the required Unified CCX server.

A Security Alert dialog box is displayed.

Step 2  Click the appropriate button.

The Authentication page appears.

Note

• Ensure that Cisco Tomcat and Cisco Unified Cluster View Daemon services are running before you log in to the Unified CCX Administration using the URL in Step 1.

• Verify that the popup blocker is disabled if you are using Microsoft Internet Explorer Version 6.0 or later or Mozilla Firefox Version 2.0 or 3.0 browser.

• Enable the compatibility mode if you are using Microsoft Internet Explorer Version 11.0.

Tip  Add the IP address of the Unified CCX server to the "Compatibility View Settings," to enable the compatibility mode in Microsoft Internet Explorer Version 11.0.

Step 3  On the main Cisco Unified CCX Administration web page, enter your Unified CCX username and password.

Note  If you are accessing Unified CCX for the first time, enter the Application User credentials specified during installation of the Unified CCX. See the Cisco Unified Contact Center Express Installation Guide for further instructions. The user ID is not case sensitive in Unified CCX 9.0(1).

Step 4  Click Login.

A web page opens listing information about Cisco Unified CCX Administration and the Cisco Unified CCX Administration menu bar appears at the top of the page.

Note

• For security purposes, Cisco Unified CCX Administration logs you out after 30 minutes of inactivity, and you must log back in.

• Unified CCX Administration detects web based cross-site request forgery attacks and rejects malicious client requests. It displays the error message, "The attempted action is not allowed because it violates security policies."

Cisco Unified CCX Administration Menu Bar and Menus

The Cisco Unified CCX Administration menu bar appears at the top of every web page of the Unified CCX Administration web interface. You begin every Unified CCX configuration and administration task by choosing a menu and submenu option from the menu bar.

The Cisco Unified CCX Administration menu bar contains the following menu options:

• System—Contains options for configuring new servers in the cluster, Unified CM information, language information, changing system parameters, custom file configuration, and adding or displaying licenses.

• Applications—Contains options for managing applications, scripts, prompts, grammars, documents, and AAR files.
• **Subsystems**—Contains options for configuring parameters for the subsystems that are licensed for your Unified CCX server. Your Subsystems menu may include submenu options for one or more of the following subsystems: Unified CM Telephony, Unified CCX, Cisco Unified Intelligence Contact Management Enterprise (Unified ICME) software, Database, HTTP, Email, Cisco Media, MRCP Automatic Speech Recognition (ASR), and MRCP Text-To-Speech (TTS).

• **Wizards**—Contains options that provide access to the following wizards of your Unified CCX server: Application and RmCm.

• **Tools**—Contains options that allow you to access system tools such as Plug-ins, Real-Time Reporting, Real-Time Snapshot Config. You can also assign access levels to administrators and supervisors and reset passwords.

• **Help**—Provides access to online help for Unified CCX.

**Related Topics**
- System Menu, on page 273
- Applications Menu, on page 281
- Subsystems Menu, on page 287
- Wizards Menu, on page 323
- Tools Menu, on page 327
- Help Menu, on page 343

---

**Cisco Unified CCX Administration Navigation**

After you log in, the main Cisco Unified CCX Administration web page appears.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>The minimum supported screen resolution specifies 1024 x 768. Devices with lower screen resolutions may not display the applications correctly.</td>
</tr>
</tbody>
</table>

The choices in the drop-down list include the following Cisco Unified CCX Administration applications:

• **Cisco Unified CCX Administration** — Uses Cisco Unified CCX Administration to configure system parameters, subsystems, wizards, and much more.

• **Cisco Unified CCX Serviceability** — Takes you to the main Cisco Unified CCX Serviceability web page that is used to configure trace files, alarms, and to activate and deactivate services.

• **Cisco Desktop Administrator** — Takes you to the main Cisco Desktop Administrator web page that is used to configure Enterprise Data, Personnel, Cisco Unified Presence Settings, and Agent Email Settings.

• **Cisco Finesse Administration** — Uses Cisco Finesse Administration to configure system settings in Cisco Finesse.

• **Cisco Unified Serviceability** — Takes you to the main Cisco Unified Serviceability web page that is used to save alarms and traces for troubleshooting, provide alarm message definitions, activate and deactivate services and so on.

• **Cisco Unified OS Administration** — Takes you to the main Cisco Unified OS Administration web page, so that you can configure and administer the Cisco Unified Communications platform.
Disaster Recovery System — Takes you to the Cisco Disaster Recovery System, a program that provides data backup and restore capabilities for all servers in a Cisco Unified CCX Administration cluster.

You can log in to Cisco Unified CCX Administration either as an administration user or an application user.

Note

An administration user is an end user that is configured on the Unified CM with Administrator capability in Unified CCX.

An application user is an end user that is configured during the installation of Unified CCX having administrator capability by default.

If you log in as an Administrator, you can access the following applications that display in the navigation drop-down list in the top right corner of the Administration menu bar:

• Cisco Unified CCX Administration
• Cisco Unified CCX Serviceability
• Cisco Desktop Administrator
• Cisco Finesse Administrator

If you log in as an application user, you can seamlessly traverse between the Unified CCX web applications as well as the Cisco Unified Serviceability without logging in again.

Note

An application user can log in to these four Unified CCX web applications even when Unified CM is down.

To access these applications from Cisco Unified CCX Administration, you must first choose the desired application from the navigation drop-down list in the upper right corner and click Go.

Note

Cisco Finesse Administration Console opens in a new tab or in a new window based on the browser settings.

To log in to Cisco Finesse Administration, you must be an user with administration privileges.

When the Cisco Tomcat service is down on any of the Unified CCX nodes, you will not be able to launch Cisco Unified CCX Administration from any of the Unified CCX nodes; therefore, you will not be able to launch the Cisco Finesse Administration from within it.

In that case, you can launch the Cisco Finesse Administration directly from the browser.

To launch the Finesse Administration Console, direct your browser to https://hostname or IP address:8445/cfadmin, where hostname or IP address is the hostname or IP address of the server.

For more information about Cisco Finesse Administration Console, see Cisco Finesse Administration Console, on page 356.

You can access the following platform-based web applications using the platform user credentials as configured during installation of Unified CCX:

• Cisco Unified Operating System Administration
Disaster Recovery System

Unified CCX Configuration Web Pages

When you choose any menu and submenu option from the Unified CCX Administration menu bar, a configuration or administration web page opens. Use this web page to continue your configuration or administration task.

In some cases, you will perform your configuration or administration task on this one web page.

In other cases, the web page that first opens when you choose a submenu item leads to a series of web pages. For example, the Unified CM Telephony Call Control Group Configuration web page contains both a tool bar in the top with a few icons that link to other web pages and a configuration area.

The following table describes the Refresh All button and the Copy, Delete, and Refresh icons that are found on several Unified CCX web pages.

<table>
<thead>
<tr>
<th>Icon/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Click this icon to copy the information in that specific row.</td>
</tr>
<tr>
<td>Note</td>
<td>When you click Copy, the web page displays the copied configuration so you can make changes, if desired.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click this icon to delete the information in that specific row.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Click this icon to refresh the information in that specific row.</td>
</tr>
<tr>
<td>Refresh All</td>
<td>Click this button to refresh the information listed on this page.</td>
</tr>
</tbody>
</table>

Details for Advanced Configuration

In Unified CCX Administration web interface, advanced configuration with Show More and Show Less options exists. On the applicable pages, all configuration details can be displayed or minimised based on user preferences and requirements.

A page by default displays fewer parameters. Parameters configured with default values and not requiring modification or user input are now available in the advanced configuration section. You can access this advanced configuration section by clicking the Show More button at the bottom of the page. When you click this button, the extra parameters become visible and the button changes to Show Less. When you click Show Less, the page reverts to its original list of parameters.
If you are using Unified CCX with Cisco Contact Center Gateway solution, see the Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX. The instructions for configuring Unified CCX with that solution differs from what is described in this guide. The Unified Gateway provides for the integration of the Unified ICME system with Unified CCX by way of Unified Gateway. See the Cisco Unified Contact Center Enterprise installation and upgrade guides available at http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html for detailed information. The Unified Gateway is a Peripheral Gateway (PG), which you configure on the Unified ICME software.

**Related Topics**
Unified CCX Configuration Web Pages, on page 19

### Toolbar and Buttons

On the top left toolbar of many web pages, you will find an Add New icon and the same Add New will also be displayed as a button at the bottom of the web page.

For example, the Unified CM Telephony Call Control Group Configuration web page contains Add New and Refresh All icons on the top left toolbar and the same are displayed as buttons at the bottom of the web page. When you click the Add New icon or button, another Unified CM Telephony Call Control Group Configuration web page opens. Use this area to add a new Unified CM Telephony Call Control Group.

Many web pages contain icons or buttons that perform a variety of functions. For example, the Refresh All button on the Unified CM Telephony Call Control Group Configuration web page refreshes all the Unified CM Telephony call control group configurations in the Unified CCX server.

A few web pages (for example, Subsystems > Database > Parameters page) also contain a Reset to Default icon and button. This allows you to revert to the software set defaults for each parameter on this page.

**Related Topics**
Unified CCX Configuration Web Pages, on page 19

### Application and RmCm Wizards

In Unified CCX, two wizards are available in the main menu: the Application Wizard and the RmCm Wizard.

To improve the usability and configuration process, these wizards take you through the configuration pages in the required order and help ease the configuration process for these two features. You can access these wizards from a new main menu option called Wizards.

**Related Topics**
Wizards Menu, on page 323
Unified CCX Configuration Web Pages, on page 19
Unified CCX Provision Checklist

The Cisco Unified Communications Manager (CM) product supports both single-node and two-node (high availability) deployments available for the Cisco Unified Contact Center Express (CCX).

The deployment model is transparent to the Unified CCX installer as the clustering for Unified CM is performed through the Unified CCX Administration using the Unified CCX setup wizard. The high availability over WAN feature of Unified CCX is supported only for Unified CM deployments.

The following topics introduce the Unified CCX subsystem and explain how to modify the Unified CM information from Unified CCX.

- Unified CCX, page 21
- Provision Unified CCX, page 22
- Change Licensing Packages, page 23

Unified CCX

The Unified CCX system uses the Unified CCX subsystem as part of an ACD system to provide resource distribution and queueing to call centers.

Two types of routing are available:

- **Contact Service Queue (CSQ)-based routing**—CSQs are entities that route calls to your resources (agents). Each CSQ controls incoming calls and determines where an incoming call is placed in the queue and to which agent the call is sent.

  Each CSQ selects resources from an associated resource pool that you define or from resource skills for all Unified CCX license packages. When an agent becomes available to take a call, the system chooses a queued call from one of the CSQs whose resource pool includes the agent, and routes that call to that agent.

- **Agent-based routing**—Agent-based routing provides the ability to send a call to a *specific* agent, rather than any agent available in a CSQ.

  A Unified CCX agent can participate in both CSQ-based and agent-based routing. A Unified CCX agent can be any one of the following:

  - Cisco Finesse
Provision Unified CCX

To provision Unified CCX, complete the following tasks:

<table>
<thead>
<tr>
<th>Step</th>
<th>Task</th>
<th>Unified CM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Configure Unified CM users who will be agents in your Unified CCX system.</td>
<td>Provision Unified CM for Unified CCX, on page 25</td>
</tr>
<tr>
<td>Step 2</td>
<td>Provision resources information for Unified CCX telephony and media.</td>
<td>Provision Unified CM Telephony Subsystem, on page 68</td>
</tr>
<tr>
<td>Step 3</td>
<td>Provision RmCm Provider to allow RmCm Subsystem to be in service.</td>
<td>RmCm Provider Configuration, on page 97</td>
</tr>
<tr>
<td>Step 4</td>
<td>Create resource groups.</td>
<td>Resource Groups, on page 99</td>
</tr>
<tr>
<td>Step 5</td>
<td>Create skills.</td>
<td>Skills Configuration, on page 100</td>
</tr>
<tr>
<td>Step 6</td>
<td>Assign agents to resource groups and assign skills to agents.</td>
<td>Agent Configuration</td>
</tr>
<tr>
<td>Step</td>
<td>Task</td>
<td>Unified CM</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
<td>------------</td>
</tr>
<tr>
<td>7</td>
<td>Create Contact Service Queues.</td>
<td>Contact Service Queue Configuration, on page 107</td>
</tr>
<tr>
<td>8</td>
<td>Provision Remote Monitoring—if using Unified CCX Premium.</td>
<td>Remote Monitoring Use and Configuration, on page 116</td>
</tr>
<tr>
<td>9</td>
<td>Provision agent-based routing—if using Unified CCX Enhanced or Premium.</td>
<td>Configure Agent-Based Routing, on page 118</td>
</tr>
<tr>
<td>10</td>
<td>Create teams and assign agents to teams.</td>
<td>Teams Configuration, on page 119</td>
</tr>
</tbody>
</table>

**Related Topics**

Unified CCX

**Change Licensing Packages**

The following three license upgrade options are available for Unified CCX system:

- Standard to Premium
- Standard to Enhanced
- Enhanced to Premium

While upgrading the licenses, you need to configure these system parameters:

- **Standard to Premium or Enhanced**—Only Enhanced and Premium package licenses support Recording. When you upgrade to Enhanced or Premium license package, you need to manually change the Recording Count to a desired value to enable the recording functionality.

- **Standard or Enhanced to Premium**—You need to configure the Number of Direct Preview Outbound Seats while upgrading to a Premium license.

**Note**

Downgrade of license is not supported in Unified CCX.

**Procedure**

Choose **System > System Parameters** from the Cisco Unified CCX Administration menu bar to open the System Parameters Configuration web page where you can update these values.

**Related Topics**

Application Availability by License Package, on page 417
Manage System Parameters, on page 161
CHAPTER 4

Provision Unified CM for Unified CCX

When you access Unified CCX Administration for the first time in a cluster, the system automatically initiates the cluster setup procedure once for each cluster to perform the following tasks:

- Identify Unified CCX license files
- Enter information about Unified CM Administrative XML Layer (AXL) and Unified CM Telephony and RmCm providers

You can modify the Unified CM information from Unified CCX. See the Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, Release 9.0(1) for detailed information on how to perform the initial system setup using the Unified CCX Administration web interface.

The following topics explain how to modify the Unified CM information from Unified CCX:

- Configure Unified Communications Manager Information, page 25
- Modify AXL Information, page 26
- Modify Unified Communications Manager Telephony Information, page 28
- Modify RmCm Provider Information, page 29
- Unified Communications Manager for Unified CCX Configuration, page 31

Configure Unified Communications Manager Information

During initial setup of Unified CCX using the Unified CCX Administration web interface, the administrator who installed the Unified CCX should have already provided the Unified Communications Manager IP address and hostname(s). The administrator must also provide the Administrative XML Layer (AXL) authentication (user ID and password) information.

The Unified Communications Manager Configuration web page allows you to configure and update the AXL authentication information, Unified Communications Manager Telephony subsystem information, and RmCm Provider configuration information from within Unified CCX.

This page has three blocks of information: AXL service details, Unified Communications Manager Telephony Provider details, and RmCm Provider details.
Modify AXL Information

To change previously configured AXL information, complete the following steps.

**Note** If you want to change the credentials, change first in Unified Communications Manager and then in Unified CCX. Otherwise, Unified CCX might have issues communicating with Unified Communications Manager.

### Procedure

**Step 1** From the Unified CCX Administration menu bar, choose **System > Cisco Unified CM Configuration**. The Cisco Unified Communications Manager Configuration web page opens.

**Step 2** Go to the **AXL Service Provider Configuration** section to modify the AXL information using the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AXL Service Provider Configuration</strong></td>
<td></td>
</tr>
<tr>
<td>Selected AXL Service Providers</td>
<td>Lists the AXL service providers selected by the Unified CCX user. Select the required entry and move to the opposite list box using the right and left arrows. Arrange the order of the selected entries using the up and down arrows.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>If you deselect the AXL service provider from the Selected list box, a Microsoft Internet Explorer or Mozilla Firefox window opens, informing you about the (list of) deselected services. For security reasons (in case the service is being used by another AXL service provider), manually disable the AXL service only from the Unified Communications Manager.</td>
</tr>
<tr>
<td>Available AXL Service Providers</td>
<td>Lists the Unified Communications Manager entries in the cluster. Select the required entry and move to the opposite list box using the right and left arrows.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Make sure you configure multiple AXL providers running the AXL Service for a redundant system.</td>
</tr>
</tbody>
</table>

**Cluster Wide Parameters**
Step 3  After logging in to the Unified CCX Administration web interface, follow these steps to update the AXL password:

a) Log in to Unified Communications Manager Administration web interface and update the password for the application user (AXL provider).

b) Navigate back to System > Cisco Unified CM Configuration web page of Unified CCX and enter the new password in the Password field.

   A dialog box prompts you to confirm the AXL username and password. Reenter the AXL user ID and password and click Login.

   The system validates the data and takes you back to the Unified Communications Manager configuration page.

c) Enter the updated password once again to validate and click Update.

   The AXL password is updated successfully and you should be able to log in to Unified CCX Administration web interface of Unified CCX with the new AXL password.

Step 4  Click Update at the top of the Cisco Unified Communications Manager Configuration web page or the Update button that displays at the bottom of the web page to save the changes. The Unified Communications Manager Configuration web page refreshes to display the new settings.

   The selected AXL services are now enabled. If the selected AXL services cannot be enabled, an error message instructs you to reselect AXL service providers.

Related Topics

Modify Unified Communications Manager Telephony Information, on page 28
Modify RmCm Provider Information, on page 29
RmCm Provider Configuration, on page 97
Provision Unified CM Telephony Subsystem, on page 68
The Unified Communications Manager Telephony client is installed in the background after you configure the Unified Communications Manager Telephony user. The Unified Communications Manager Telephony client runs silently and verifies that the right version and the right client are installed.

Configuring the Unified Communications Manager Telephony user does not automatically install the Unified Communications Manager Telephony client. This is normally done during activation of Unified CCX Engine in component activation (see Cisco Unified Contact Center Express Serviceability Guide). To install it manually, go to Subsystems > Unified CM Telephony and select the Cisco JTAPI Resync submenu option from the Unified CCX Administration menu bar.

The latest list of CTI Managers within a cluster are listed in this section. If the Unified Communications Manager is not functioning or if the Unified CCX cannot connect to the Unified Communications Manager for any reason, information obtained from the most recent connection is saved as a part of the bootstrap information.

To change previously configured Unified Communications Manager Telephony information, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose System > Unified CM Configuration.

The Cisco Unified Communications Manager Configuration web page opens.

**Step 2** Scroll down to the Unified CM Telephony Subsystem - Unified CM Telephony Provider Configuration section and reconfigure the Unified Communications Manager Telephony information using the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Unified CM Telephony Subsystem—Unified CM Telephony Provider Configuration</strong></td>
<td></td>
</tr>
<tr>
<td>Selected CTI Managers</td>
<td>Lists the CTI Managers selected by the Unified CCX user. Select the required entry and move to the opposite list box using the right and left arrows. Arrange the order of the selected entries using the up and down arrows.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If you deselect CTI Managers from the Selected list box, a Microsoft Internet Explorer or Mozilla Firefox window opens, informing you about the (list of) deselected CTI Managers.</td>
</tr>
<tr>
<td>Available CTI Managers</td>
<td>Lists the CTI Managers in the cluster. Move to the opposite list box using the right and left arrows.</td>
</tr>
<tr>
<td>Cluster Wide Parameters</td>
<td></td>
</tr>
</tbody>
</table>
**Field** | **Description**
--- | ---
User Prefix | The syntax of the User ID is: `<userprefix>_<nodeid>`. For example, if you set this field to `cti_user`, the User ID for Node 1 will be `cti_user_1`. This is a mandatory field.
Password | Password you defined for the User ID in Unified Communications Manager. If a CTI Manager is already selected, the corresponding password is displayed in this field. This is a mandatory field.
Confirm Password | Reenter the password that you provided in the Password field. This is a mandatory field.

**Step 3**
Click **Update** at the top of the Cisco Unified Communications Manager Configuration web page or click the **Update** button that displays at the bottom of the web page to save the changes. The Unified Communications Manager Configuration web page refreshes to display the new settings.

The newly selected CTI Manager is now enabled. If the selected CTI Manager cannot be enabled, an error message instructs you to reselect CTI Managers.

**Note**
In a HA over WAN deployment of Unified CCX, the JTAPI user will be created only for the selected node. To create JTAPI user for the HA node, you have to explicitly select the HA node, make necessary updates, and click **Update**.

**Related Topics**
- Configure Unified CM Telephony Provider, on page 69
- Modify AXL Information, on page 26
- Modify RmCm Provider Information, on page 29
- Unified Communications Manager for Unified CCX Configuration, on page 31
- RmCm Provider Configuration, on page 97
- Provision Unified CM Telephony Subsystem, on page 68
- Select Server for Unified CM Configuration

**Modify RmCm Provider Information**

The list of all CTI Managers available in a cluster are saved as a part of the bootstrap information. You can change to any available CTI Managers listed in the Available CTI Managers list box in this page.
The RmCm Provider specified through the Unified CCX Administration is automatically created in Unified Communications Manager. You do not need to use the Unified Communications Manager web interface to create the user.

To change previously configured RmCm provider information or to configure a new RmCm Provider, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **System > Unified CM Configuration**. The Unified Communications Manager Configuration web page opens.

**Step 2** Scroll down to **RmCm Subsystem - RmCm Provider Configuration** and reconfigure the selected CTI Manager using the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RmCm Subsystems—RmCm Provider Configuration</strong></td>
<td></td>
</tr>
<tr>
<td>Selected CTI Managers</td>
<td>Lists the CTI Managers selected by the Unified CCX user. Select the required entry and move to the opposite list box using the right and left arrows. Arrange the order of the selected entries using the up and down arrows. <strong>Note</strong> If you deselect CTI Managers from the Selected list box, a Microsoft Internet Explorer or Mozilla Firefox window opens, informing you about the (list of) deselected CTI Managers.</td>
</tr>
<tr>
<td>Available CTI Managers</td>
<td>Lists the CTI Managers in the cluster. Move to the opposite list box using the right and left arrows.</td>
</tr>
<tr>
<td>User ID</td>
<td>User prefix for the Unified Communications Manager User IDs to be created in Unified Communications Manager. If a CTI Manager is already selected, the corresponding user name is displayed in this field. If you change the CTI Managers, be sure to enter the corresponding user prefix for the selected service. This is a mandatory field.</td>
</tr>
<tr>
<td>Password</td>
<td>Password you defined for the User ID in Unified Communications Manager. If a CTI Manager is already selected, the corresponding password is displayed in this field. If you change the CTI Manager, be sure to enter the corresponding password for the selected service. This is a mandatory field.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Reenter the password that you provided in the Password field. This is a mandatory field.</td>
</tr>
</tbody>
</table>

**Step 3** Click **Update** at the top of the Cisco Unified Communications Manager Configuration web page or click the **Update** button that displays at the bottom of the web page to save the changes. The Unified Communications Manager Configuration web page refreshes to display the new settings.
The newly selected RmCm Provider is now enabled. If the selected RmCm Provider cannot be enabled, an error message instructs you to reselect RmCm Provider.

Related Topics

- Modify AXL Information, on page 26
- Modify Unified Communications Manager Telephony Information, on page 28
- RmCm Provider Configuration, on page 97
- Provision Unified CM Telephony Subsystem, on page 68

Unified Communications Manager for Unified CCX Configuration

To enable Unified CCX to communicate with Unified Communications Manager, you also need to assign extensions for the users who will be agents in your Unified CCX system.

Note

If you delete a Unified CCX user with Administrative rights from Unified Communications Manager, you can still log in to the Unified CCX Administration web interface as an application user.

Note

Q Signaling (QSIG) and Path Replacement (PR) features of Unified Communications Manager are not supported by Unified CCX.

Invoke Unified Communications Manager Administration

Begin the process of configuring Unified Communications Manager by connecting to the Unified Communications Manager Administration web interface.

To connect to the Unified Communications Manager Administration web interface, complete the following steps.

Procedure

Step 1
From a web browser on any computer on your network, enter the following URL: https://servername/ccmadmin.
In this example, servername is the hostname or IP address of your Unified Communications Manager server.
A Security Alert dialog box is displayed.

Step 2
Click the appropriate button.

Step 3
At the main Cisco Unified Communications Manager Administration web page, enter the Unified Communications Manager username and password, and then click Login.
The Unified Communications Manager Administration web page appears.
You are now ready to use the Unified Communications Manager Administration web interface to configure users for Unified CCX.

**Unified Communications Manager Users as Unified CCX Agents**

**Warning**
Do not configure Unified Communications Manager users having the same username/password as the application administration credentials (configured during installation). Doing so may restrict the Unified Communications Manager when shared across multiple Unified CCX servers.

**Agent ID**
When logging in to the desktop, agents use the Unified Communications Manager user ID and password. Unified Communications Manager limits agent IDs to 128 alphanumeric characters, but Unified CCX limits the agent IDs to 31 bytes.

**Attention**
- Unified Communications Manager user ID should not exceed 31 bytes. If user ID exceeds 31 bytes, Unified CCX does not synchronize users from Unified Communications Manager.

**Agent Name**
Agent name includes the first name and last name. The following is the limit for agent name:

- English-based script (German, Spanish, English, etc)—50 bytes / 50 characters
- Non-English script (Arabic, Chinese, Cyrillic, etc)—48 bytes / 16 characters

**Attention**
Unified CCX truncates the name to 50 / 48 bytes and stores if the agent name exceeds the above limit.

RmCm uses the Unified Communications Manager database to determine which devices it can control and provides an interface method for getting the Media Access Control (MAC) address of the calling party.

After you install RmCm, you have access to the Unified Communications Manager database. The database stores parameters that initialize Unified Communications Manager Telephony, user profiles, application logic, network-specific configuration information, and Directory Number Associations such as Primary Extension and Unified CCX Extension.

The Primary Extension field represents the primary directory number for the end user. End users can have multiple lines on their phones. From the drop-down list box, choose a primary extension when associating devices for this end user.

Unified CCX Extension allows you to define Unified Communications Manager users as Unified CCX agents in Unified Communications Manager.
To assign Unified CCX devices to end users and application users in the Unified Communications Manager, these users must first exist in Unified Communications Manager. If these users do not exist, you must first add the users. See the Cisco Unified Communications Manager Administration Guide to obtain detailed information about the Unified CCX web interface and configuration procedures. After adding the end user and the application user, be sure to modify their Unified CCX settings.

**Agents and Supervisors with IDs That Match Reserved Words Cannot Sign In**

Do not use the following reserved words for agent ID or supervisor ID because these IDs conflict with system account names that are used internally within the Unified CCX server:

<table>
<thead>
<tr>
<th>System\Components</th>
<th>Reserved words</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified CCX Web Chat</td>
<td>admin</td>
</tr>
<tr>
<td>Cisco Finesse</td>
<td>admin, finesse</td>
</tr>
<tr>
<td></td>
<td>xmpproootowner</td>
</tr>
<tr>
<td></td>
<td>presencelistener</td>
</tr>
<tr>
<td>Cisco Unified Intelligence Center</td>
<td>cuicnodewatchuser</td>
</tr>
<tr>
<td></td>
<td>cuicpresenceuser</td>
</tr>
</tbody>
</table>

**Guidelines for Agent Phone Configuration**

Follow these guidelines when configuring agent phones for Unified CCX agents:

- Choose **Device > Phone** in Unified Communications Manager Administration. The Find and List Phones window is displayed.

Enter search criteria to locate a specific phone and click **Find**. A list of phones that match the search criteria is displayed. Click the device name of the phone to which you want to add a directory number. The Phone Configuration window is displayed.

In the Unified Communications Manager Administration Phone Configuration web page, select the required Association Information (on the left) to get to the Directory Number Configuration web page. On this page, make the following changes:

- In the Multiple Call/Call Waiting Settings section, set the Maximum Number of Calls to 2 (default is 4) for Cisco Unified IP Phones 7900 Series and 3 for Cisco Unified IP Phones 8961, 9951, and 9971.
If you are using Cisco Finesse for your agent desktop, you must set the Maximum Number of Calls to 2 for all agent phones.

- In the Multiple Call/Call Waiting Settings section, set the Busy Trigger value to 1 (default is 2).
- In the Call Forward and Call Pickup Settings section, verify that you do not forward any Unified Communications Manager device to the Unified CCX extension of an agent.
- In the Call Forward and Call Pickup Settings section, verify that you do not configure the Unified CCX extension of an agent to forward to a Unified CCX route point.

- Always disable (turn off) Secure Real-Time Transport Protocol (SRTP) when configuring a Cisco Unified Communications product. You can disable SRTP for a specified device or for the entire Unified Communications Manager:
  - For a specified device—Choose **Device > Phone**. In the Find and List Phone page, select the required phone device. In the Phone Configuration page for the selected phone, scroll down to the Protocol Specific Information section. To turn off SRTP on the phone device, select any one of the **Non Secure SCCP Profile auth by** choices from the drop-down list in **SCCP Phone Security Profile** or **SCCP Device Security Profile** field.
  - For the entire Unified Communications Manager cluster—Choose **System > Enterprise Parameters**. In the Enterprise Parameters Configuration page, scroll down to the Securites Parameters section, to verify that the corresponding value for the Cluster Security Mode field is 0. This parameter indicates the security mode of the cluster. A value of 0 indicates that phones will register in nonsecure mode (no security).

- The Unified CCX extension for the agent must be listed within the top 4 extensions on the device profile. Listing the extension from position 5 on will cause Unified CCX to fail to monitor the device, so the agent will not be able to log in.
- Do not forward any Unified Communications Manager device to the Unified CCX extension of an agent.
- Do not configure the Unified CCX extension of an agent to forward to a Unified CCX route point.
- Do not use characters other than the numerals 0 to 9 in the Unified CCX extension of an agent.
- Do not configure two lines on an agent phone with the same extension when both lines exist in different partitions.
- Do not assign a Unified CCX extension to multiple devices.
- Do not configure the same Unified CCX extension in more than one device or device profile. (Configuring a Unified CCX extension in one device or device profile is supported.)
- To use Cisco Unified IP Phones 9900 Series, 8900 Series, and 6900 Series as agent devices, the RmCm application user in Unified Communications Manager needs to have "Allow device with connected transfer/conference" option assigned to itself.

Modify Existing Unified Communications Manager Users

To use any version of Unified Communications Manager, you must first ensure that you define Unified Communications Manager users as Unified CCX agents in Unified Communications Manager. After you perform this task, these Unified CCX agents can be combined into Resource Groups, assigned Skills, and placed in CSQs.

**Note**
In Unified CCX, this operation is called “associating a device.”

**Note**
Be sure to assign Unified CCX devices to both end users and application users in the Unified Communications Manager web interface.

To assign devices to an end user, you must access the End User Configuration window for that user. The End User Configuration window in Unified Communications Manager Administration allows the administrator to add, search, display, and maintain information about Unified Communications Manager end users.

To assign devices to an application user, you must access the Application User Configuration window for that user. The Application User Configuration window in Unified Communications Manager Administration allows the administrator to add, search, display, and maintain information about Unified Communications Manager application users.

**Note**
If Enterprise Mobility (EM) is used together with both Cisco Unified Communications Manager release 8.0 or later and Cisco Unified Communications Manager, the Resource Manager application user must be associated with the device profile and not with the device.

To modify the Unified CCX Extension settings for existing Unified Communications Manager users who are Unified CCX agents, complete the following steps:

**Note**
If you change or update an end user ID in Unified Communications Manager, Unified CCX resets the end user's resource name, skills, and team to default values.

**Procedure**

**Step 1**
Connect to the Unified Communications Manager Administration web interface. The Unified Communications Manager Administration web page appears.

**Step 2**
Choose **User Management > End User**. The Find and List End Users page displays. Use the two drop-down list to search for an end user.
Tip  To find all end users that are registered in the database, click Find without entering any search text. A list of discovered end users is displayed. Then, skip to Step 6.

Step 3  From the first Find end user where drop-down list, choose one of the listed criteria.

Step 4  From the second Find end user where drop-down list, choose one of the listed criteria.

Step 5  Specify the appropriate search text, if applicable, and click Find. A list of discovered end users is displayed.

Step 6  From the list of records, click the end user name that matches your search criteria. The End User Configuration page opens, displaying the configuration information for the end user that you chose.

Step 7  In the Controlled Devices list box below the Device Information section, select the device and click the Down arrow below the Available Profiles list box. If the device that you want to associate with this end user is not displayed in this pane, do the following to associate devices with an end user:

a) From the Device Information pane, click Device Association. The User Device Association page opens.

b) Finding a Device: Because you may have several devices in your network, Cisco Unified Communications Manager lets you locate specific devices on the basis of specific criteria. Click Find. All or matching records are displayed. You can change the number of items that is displayed in each page by choosing a different value from the Rows per Page drop-down.

c) Associating a Device: From the Device association for (this particular end user) pane, choose the devices that you want to associate with this end user by checking the box to the left of the device names. You can also use the buttons at the bottom of the window to select and deselect devices to associate with the end user.

d) To complete the association, click Save Selected/Changes.

e) From Related Links drop-down list in the upper right corner of the web page, choose Back to User, and click Go.

The End User Configuration page is displayed, and the associated devices that you chose are displayed in the Controlled Devices pane.

Step 8  Select the required device and save your changes to associate that device with this end user.

After the device is associated, the Controlled Devices field displays the description information (for example, the MAC address) that the end user controls.

Step 9  In the End User Configuration page, scroll down to the Directory Number Associations section.

Step 10  In the Primary Extension field drop-down list and the IPCC Extension field drop-down list, choose the required agent extension for this device.

These fields represent the primary directory number for the end user. End users can have multiple lines on their phones. If you have a single line, be sure to select the same extension for both fields.

Step 11  Click Update to apply the changes.

The specific End User Information page for this user appears, with the message that the update was successful.

Step 12  From the Unified Communications Manager Administration menu bar, choose User Management > Application User. RmCm Providers are referred to as application users in Unified Communications Manager.

Note  When you associate one device with the Unified CCX agent (end user), you must also be sure to associate the same device with the Unified CCX RmCm Provider (application user).

The Find and List Application Users window is displayed. Use the two drop-down list to search for the application users in Unified Communications Manager.

Tip  To find all application users registered in the database, click Find without entering any search text. A list of discovered end users is displayed. Then, skip to Step 16.
**Step 13** From the first Find application user where drop-down list, choose one of the listed criteria.

**Step 14** From the second Find application user where drop-down list, choose one of the listed criteria.

**Step 15** Specify the appropriate search text, if applicable, and click **Find**. A list of discovered application users is displayed.

**Step 16** From the list of records, click the application user name that matches your search criteria. The window displays the application user that you choose.

**Step 17** Repeat Step 7 and Step 8 for the selected Application User. These steps ensure that the Unified Communications Manager application users are also defined as Unified CCX agents in Unified Communications Manager.

**Step 18** Click **Update** to apply the changes. The specific Application Information page for this user appears, with the message that the update was successful. See the "User Management Configuration" section in the *Cisco Unified Communications Manager Administration Guide* for detailed information on how to configure an end user and application user using Unified Communications Manager.

Now that you have defined the agent in Unified Communications Manager, you can configure agents in Unified CCX. Before you configure the agent, you will also need to configure resource groups and CSQs.

---

**Related Topics**

- Resource Groups, on page 99
- Create a Contact Service Queue, on page 107
- Guidelines for Agent Phone Configuration, on page 33
- Invoke Unified Communications Manager Administration, on page 31
- Agent Configuration

---

**Assign Unified Communications Manager Users as Cisco TelePresence Virtual Agents**

The Cisco TelePresence application enables enterprises to create a live, face-to-face interaction with customers over the network. This solution allows rapid deployment of a virtual contact center infrastructure. Agents using Cisco TelePresence are referred to as virtual agents in this guide. Virtual agents connect to callers using Unified CCX, which incorporates ACD, CAD, CTI, and Unified IP IVR with Cisco Unified Communications Manager and providing the entire solution on one server.


The following guidelines apply for the Cisco TelePresence integration with Unified CCX:

- The only commonly supported codec for Unified CCX and Cisco TelePresence is G711.
- The following supervisor features are not supported:
• Monitoring and Recording is not supported for Cisco TelePresence integration with Unified CCX.

• Due to the unavailability of third-party call control, Cisco Supervisor Desktop (CSD) features, Barge-in, and Intercept are not supported.

• You will not be able to use the call control Cisco Agent Desktop (CAD) features (Hold, Unhold, Answer, Transfer, Conference, Make Call, and Touch Tone). Be sure to remove or disable these features from CAD as specified in Step 4 in the following procedure.

Follow this procedure to assign Unified Communications Manager users as virtual agents:

Procedure

Step 1  Identify the required Cisco TelePresence system that will participate as a virtual agent in the Unified CCX application.
   a) Note the Unified Communications Manager extension of the Cisco TelePresence deployment.
      Note  The Cisco Unified IP Phone 7970G and Cisco TelePresence system must be assigned the same extension in Unified Communications Manager, because they both share the same line.
   b) Note the MAC address or the Directory Number of the Cisco Unified IP Phone 7970G connected to the identified Cisco TelePresence system.
      Tip  From the Unified CCX perspective, this is another SIP endpoint.

Step 2  Associate the Cisco Unified IP Phone 7970G with the Unified Communications Manager user to configure this user as a virtual agent.

Step 3  Associate the Cisco Unified IP Phone 7970G with the RmCm provider.
   Note  Do not associate the corresponding Cisco TelePresence system with the RmCm provider.

Step 4  Customize the Cisco Agent Desktop workflow groups (see the Cisco Desktop Administrator Users Guide).
   Tip  All the Cisco Agent Desktop call control buttons must be disabled because third-party call control will not be available for the Cisco TelePresence integration with Unified CCX.

Related Topics

  RmCm Provider Configuration, on page 97

Configure Tool for Auto-Registered Phones Support (TAPS)

The Tool for Auto-Registered Phone Support (TAPS) loads a preconfigured phone setting on a phone. The TAPS works in conjunction with the Bulk Administration Tool (BAT). After the BAT is used to bulk add phones with dummy MAC addresses to Cisco Unified Communications Manager Release 9.0(1) Administration, you can plug the phones into the network.

The administrator or users can then dial a TAPS directory number that causes the phone to download its configuration. At the same time, the phone gets updated in the Unified Communications Manager database with the correct MAC address of the phone. Refer to Configuring the Bulk Administration Tool (BAT) if you are not familiar with the BAT.
For the TAPS to function, you must make sure that Auto-registration is enabled in Cisco Unified Communications Manager Administration (select System > Cisco Unified CM). Follow the instructions in the procedure below to install and configure TAPS application with Unified CCX.

**Procedure**

**Step 1** Log in to Cisco Unified Communications Manager Administration Release 9.0(1) and choose **Application > Plugins** from the Cisco Unified Communications Manager Administration menu bar.

**Step 2** In the Find and List Plugins web page, search for “Cisco TAPS” and click **Find**.

**Step 3** Download the TAPS_AAR.aar file to your client PC, which is used for accessing Unified Communications Manager Administration and Unified CCX Administration.


**Step 5** After installing Unified CCX, follow these steps from the User Configuration page in Unified CCX Administration:

a) In the Cisco Unified Communications Manager Users list, select the Cisco Unified Communications Manager user whom you want to designate as the Cisco Unified CCX administrator and who can configure TAPS.

b) Click the left arrow (<) to move the selected user to the Cisco Unified CCX Administrator list.

c) Click **Finish**. The Cisco Unified CCX Setup Result Information window is displayed. This window confirms the result of the initial setup. The Cisco Unified CCX engine will restart.

d) Close your web browser.

**Step 6** Log in to Cisco Unified CCX Administration as the Unified CCX application administrator, who can configure TAPS. After installing and configuring Unified CCX and Unified Communications Manager, follow this procedure to set up TAPS:

a) From the Unified CCX Administration menu bar, choose **Applications > AAR Management**. Click **Browse** and upload the TAPS_AAR.aar file that you downloaded in Step 3 from Unified Communications Manager.

   On successful upload, you will see a confirmation message in the status bar at the top of the AAR Management web page.

   **Note** For TAPS configuration, you need to restart the Unified CCX engine and Unified CCX Cluster View Daemon (CVD). You can restart the CVD using the CLI command,

   ```
   utils service service name stop/start
   ```

b) After restarting the CVD, log in once again to Cisco Unified CCX Administration as the Unified CCX application administrator. From the Unified CCX Administration menu bar, choose **Subsystems > Unified CM Telephony > Call Control Group**. Click **Add New** and provide the Call Control Group Configuration values for TAPS using the following fields:

   • Group ID
   • Number of CTI Ports
   • Media Termination Support
   • Device Name Prefix
   • Starting Directory Number
c) From the Unified CCX Administration menu bar, choose **Subsystems** > **Cisco Unified CM Telephony** > **Triggers**. Click **Add New** and specify values for the following mandatory fields:

- Directory Number
- Language
- Application Name
- Device Name
- Description
- **Call Control Group:**

  The call control group types can be Inbound or Outbound for Unified CCX running with Unified Communications Manager.

d) Choose **Subsystems** > **Cisco Unified CM Telephony** > **Data Resync** from the Cisco Unified CCX Administration menu bar to check and resynchronize the JTAPI data between Cisco Unified Communications Manager and Cisco Unified CCX.

e) From the Unified CCX Administration menu bar, choose **Applications** > **Application Management**. The Application Management web page opens, displaying the details of existing applications.

f) Click the **Add New** icon or button. The Add a New Application web page opens.

g) From the Application Type drop-down menu, choose Cisco Script Application and click **Next**. The Cisco Script Application configuration web page opens.

h) In the Script field, select the script "'/TAPS.aef" from the drop-down list and enter the IP address of the Cisco Unified Communications Manager in the text box below the Script drop-down list.

i) Check the check box against **Cisco_Unified_CM_IP_Address** field.

j) Click the **Yes** radio button in the Enabled field.

k) Click **Update**.

l) Log in to Cisco Unified Communications Manager Serviceability Page and restart the TAPS Service.
Cisco Applications Configuration

The Unified CCX system uses applications to interact with contacts and perform a wide variety of functions, such as prompting callers for information, transferring calls, and providing information to callers.

To configure Unified CCX applications, you must complete the following tasks:

- Provision telephony and media resources (see Telephony and Media Provision, on page 65)
- Provision your Unified CCX subsystem, if required (see Provision of Unified CCX, on page 97)
- Provision additional subsystems, if required (see Provision of Additional Subsystems, on page 123)

The following sections describe how to configure applications and make them available to the Unified CCX system.

- About Unified CCX Applications, page 41
- Application Triggers, page 54
- Script Management, page 58

About Unified CCX Applications

The Unified CCX system uses applications to interact with contacts and perform a wide variety of functions.

Note

Unified CCX licenses you purchase and install determine the applications available on your system.

Unified CCX provides the following application types:

- Script
- Busy
- Ring-No-Answer
- Remote Monitoring

If Unified CCX is integrated with Unified ICME, you will also need to configure one or both of the following application types:
- Unified ICME post-routing
- Unified ICME translation-routing

**Note** If you are not using Cisco Unified Intelligent Contact Management Enterprise (Unified ICME) software, you do not need to configure Unified ICME post-routing and Unified ICME translation-routing applications. For information about these Unified ICME software features, see the *Cisco Unified ICME Scripting and Media Routing Guide*.

**Related Topics**

- Access Application Management Menu, on page 281
- Application Availability by License Package, on page 417
- Configure Script Applications, on page 42
- Configure Busy Application, on page 45
- Configure Ring-No-Answer Application, on page 47
- Configure Remote Monitoring Application, on page 52
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50
- Cisco Unified Contact Center Express License Packages, on page 417

## Configure Script Applications

The Unified CCX *script* applications are applications based on scripts created in the Unified CCX Editor. These applications come with every Unified CCX system and execute scripts created in the Unified CCX Editor.

Use the Unified CCX Editor to create scripts that direct the Unified CCX system to automatically answer calls and other types of contacts, prompt callers for information, accept caller input, queue calls, distribute calls to available agents, place outbound calls, respond to HTTP requests, and send email messages.

**Note** The Unified CCX system includes a number of sample scripts. For a description of these sample scripts, and for more information on creating scripts with the Unified CCX Editor, see the *Cisco Unified CCX Scripting and Development Series: Volume 1, Getting Started with Scripts*. In addition, a script repository is available at [http://www.cisco.com/en/US/products/sw/custswdps1846/productsimplementationdesign_guides_list.html](http://www.cisco.com/en/US/products/sw/custswdps1846/productsimplementationdesign_guides_list.html). This repository provides some examples of scripting techniques that can leverage Unified CCX abilities.

Cisco script applications can make use of many components, such as scripts, prerecorded prompts, grammars, languages, locales, and custom Java classes.

**Tip** Upload these components to the repository before you configure a Cisco script application that uses them.
Depending on your particular Unified CCX implementation, you may need to perform most or all of the following tasks to configure a Cisco script application:

- **Manage scripts**—Cisco script applications are based on scripts that you must upload to the repository and make available to the Unified CCX system.

- **Manage prompts**—Many applications make use of prerecorded prompts, stored as .wav files, which are played back to callers to provide information and elicit caller response. You must upload these .wav files to the repository and make them available to the Unified CCX system.

- **Install grammars**—The Unified CCX system uses specific grammars to recognize and respond to caller response to prompts. You must store these grammars in a directory to make them available to the Unified CCX system.

- **Install customized Unified CCX languages**—Language packs, such as American English, Canadian French, and so on, are installed with Unified CCX. You install language packs in a directory accessible by the Unified CCX system.

- **Install Java files**—In addition to the Java files automatically installed as part of the Unified CCX installation process, you can install your own custom classes and Java Archive (JAR) files to customize the performance of your Unified CCX system.

- **Add a Cisco script application**—Scripts created in the Unified CCX Editor are used as the basis for Cisco script applications.

- **Add an application trigger**—Triggers are specified signals that invoke application scripts in response to incoming contacts. After adding a new Cisco script application, you need to add a trigger so that this application can respond to telephone calls and HTTP requests.

**Related Topics**

- Management of Prompts, Grammars, Documents, and Custom Files, on page 137
- About Unified CCX Applications, on page 41
- Configure Busy Application, on page 45
- Configure Ring-No-Answer Application, on page 47
- Configure Remote Monitoring Application, on page 52
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50

**Add New Cisco Script Application**

To add a new Cisco script application, complete the following steps:

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Application Management**. The Application Management web page opens, displaying the details of any existing applications.

**Step 2** Click **Add New** icon that is displayed in the tool bar in the upper left corner of the window or the **Add New** button that is displayed at the bottom of the window. The Add a New Application web page opens.
### Step 3
From the Application Type drop-down menu, choose **Cisco Script Application** and click **Next**. The Cisco Script Application configuration Web page opens.

### Step 4
Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A name for the application. This is a mandatory field.</td>
</tr>
<tr>
<td>ID</td>
<td>Accept the automatically-generated ID, or enter a unique ID. This is a mandatory field. <strong>Note</strong> The Historical Reporting feature uses this ID to identify this application.</td>
</tr>
<tr>
<td>Maximum Number Of Sessions</td>
<td>The maximum amount of simultaneous sessions (instances) that the application can handle. This is a mandatory field. <strong>Note</strong> The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources. Entering a number that is too high can result in unacceptable system performance.</td>
</tr>
</tbody>
</table>
| Script                             | **Note** This field is available only for Cisco Script Application type. This is a mandatory field. Perform one of the following actions:  

  - Choose a script from the drop-down list to run the application. If the script contains parameters, the parameters are displayed below the Script drop-down menu. Each parameter has a check box, which enables you to override the default value for that parameter. If you want to override the value, check the check box for that parameter.  

  **Note** All scripts under the default directory are listed in the drop-down list of the Script field in the Cisco Script Application Configuration web page.  

  - Click **Edit**, enter the script name in the dialog box, and click **OK**. The User Prompt dialog box closes, and the name you entered appears in the Script field.  

  **Note** If you enter the script name as a file URL, enter the value with double backslashes (\). For example, file://c:\temp\aa.aef |
### Configure Busy Application

The Cisco Busy application comes with each Unified CCX system. This application returns a busy signal when a call reaches a Computer Telephony Interface (CTI) route point and the extension is busy.

**Before You Begin**

To configure the Busy application, you will need to perform the following tasks:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Use the Tab key to automatically populate this field. <strong>Note</strong> For the Busy and Ring-No-Answer application types, this field is only visible when you click <strong>Show More</strong>.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept (<strong>Yes</strong> = default) or reject (<strong>No</strong>). <strong>Note</strong> For the Busy and Ring-No-Answer application types, this field is only visible when you click <strong>Show More</strong>.</td>
</tr>
</tbody>
</table>
| Default Script | **Note** This field is available only for Cisco Script Application type. The default script executes when an error occurs with the configured script application that causes it to abort. Perform one of the following actions:  
- Choose a script from the drop-down list to run the application. If a Default Script is not defined, the internal system default is executed.  
- Click **Edit**, specify a script in the dialog box that appears, and click **OK**. |

**Step 5**

Click **Add**.  
The Cisco Script Application page refreshes, the **Add New Trigger** hyperlink appears in the left navigation bar, and the following message is displayed in the status bar on top:  

The operation has been executed successfully.  

Click **Back to Application List** icon or button to view the list of existing applications.

**Step 6**

Add a trigger for the application.

**Related Topics**

- Application Triggers, on page 54
To configure the Unified CCX server with the Busy application, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Application Management**. The Application Management web page opens, displaying the details of existing applications, if any.

**Step 2** Click **Add New** icon that displays in the tool bar in the upper, left corner of the window or the **Add New** button that is displayed at the bottom of the window. The Add a New Application web page opens.

**Step 3** From the Application Type drop-down menu, choose **Busy**, and then click **Next**. The Busy Application Configuration web page appears.

**Step 4** Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A name for the application. This is a mandatory field.</td>
</tr>
<tr>
<td>ID</td>
<td>Accept the automatically-generated ID, or enter a unique ID. This is a mandatory field.</td>
</tr>
<tr>
<td>Note</td>
<td>The Historical Reporting feature uses this ID to identify this application.</td>
</tr>
<tr>
<td>Maximum Number Of Sessions</td>
<td>The maximum amount of simultaneous sessions (instances) that the application can handle.</td>
</tr>
<tr>
<td>Note</td>
<td>The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources. Entering a number that is too high can result in unacceptable system performance.</td>
</tr>
</tbody>
</table>

*The following fields are displayed only on click of Show More button.*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Use the Tab key to automatically populate this field.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - Yes (the default).</td>
</tr>
</tbody>
</table>

**Step 5** Click **Add**. The Busy web page refreshes, the **Add New Trigger** hyperlink appears in the left navigation bar, and the following message is displayed in the status bar on top:

The operation has been executed successfully

**Step 6** Add a trigger for the application.
Configure Ring-No-Answer Application

The Cisco Ring-No-Answer application comes with each Unified CCX system. This application returns a ring tone signal when a call reaches a CTI route point.

Before You Begin

To configure the Ring-No-Answer application, you will need to perform the following tasks:

- Add the Ring-No-Answer application.
- Add a Unified CM Telephony trigger to the Ring-No-Answer application. The Ring-No-Answer application is activated when it is triggered by a Unified CM Telephony trigger.

To configure the Unified CCX server with the Ring-No-Answer application, complete the following steps:

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From the Unified CCX Administration menu bar, choose Applications &gt; Application Management. The Application Management web page opens, displaying the details of existing applications, if any.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add New button that is displayed at the bottom of the window.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the Application Type drop-down menu, choose Ring-No-Answer, and then click Next. The Ring-No-Answer web page opens.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Specify the following fields.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A name for the application. This is a mandatory field.</td>
</tr>
<tr>
<td>ID</td>
<td>Accept the automatically-generated ID, or enter a unique ID. This is a mandatory field.</td>
</tr>
</tbody>
</table>

Note: The Historical Reporting feature uses this ID to identify this application.
Configure Unified ICME Post-Routing Application

The Unified ICME Post-routing application comes with Unified IP IVR.

These applications use the Unified CCX server as a queue point for Unified ICME. In Unified ICME post-routing, the Unified IP IVR system receives calls directly from Unified CM, which sends the call to the post-routing route point on the Unified CCX system.

If you configure this route point to run an initial application, such as an application to welcome the caller and collect an account number, the Unified CCX system notifies the Unified ICME software about the call, and then waits for further instructions. If you do not configure an initial script, the Unified CCX system informs the Unified ICME software about the call, but takes no other action.

After notification, the Unified ICME system runs a script, which can be composed of many different call-handling steps, including three commands that can be sent to the Unified CCX system:

- **Connect**—This request is automatically sent by Unified ICME whenever an agent is available and the call can be connected to that agent.
• **Release**—This request releases the call.

• **Run VRU Script**—This request runs the VRU script.

---

**Note**
Before you can configure a Unified ICME post-routing application, you must first upload any VRU scripts that the application will need.

---

**Before You Begin**

To configure a Unified ICME post-routing application, you will need to perform the following tasks:

- Add a Unified ICME post-routing application. In addition to configuring general information such as name and ID, you must specify the script on which the Unified ICME post-routing application is based.

- Add a Unified CM Telephony trigger to the Unified ICME post-routing application. The Unified ICME post-routing application is invoked by a Unified CM Telephony trigger. The Unified ICME post-routing application does not support HTTP triggers.

To configure the Unified CCX server with the post-routing application and to add a Unified CM Telephony trigger, complete the following steps:

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose **Applications > Application Management**. The Application Management web page opens displaying the details of existing applications, if any.

**Step 2**
Click the **Add New** icon that is displayed in the tool bar in the upper, left corner of the window or the **Add New** button that is displayed at the bottom of the window.

**Step 3**
From the **Application Type** drop-down menu, choose **Unified ICME Post-Routing**. The Unified ICME Post-Routing configuration web page opens.

**Step 4**
Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A name for the application.</td>
</tr>
<tr>
<td>Description</td>
<td>Use the Tab key to automatically populate this field.</td>
</tr>
<tr>
<td>ID</td>
<td>Accept the automatically-generated ID, or enter a unique ID.</td>
</tr>
<tr>
<td></td>
<td>This ID is the service identifier that will be reported with the call back to Unified ICME.</td>
</tr>
<tr>
<td>Maximum Number Of</td>
<td>The maximum amount of simultaneous sessions (instances) that the application can handle.</td>
</tr>
<tr>
<td>Sessions</td>
<td><strong>Note</strong> The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources. Entering a number that is too high can result in unacceptable system performance.</td>
</tr>
</tbody>
</table>
Configure Unified ICME Translation-Routing Application

The Unified ICME Translation-routing application comes with Unified IP IVR. You must configure these applications when the Unified CCX server is used as a queue point for a Unified CCX solution in which calls are expected to be routed by the Unified ICME to the Unified CCX server.

The call attributes will be reported as part of a configured translation-route on the Unified ICME.

### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - Yes (the default).</td>
</tr>
<tr>
<td>Timeout (in seconds)</td>
<td>The maximum amount of time (in seconds) that the system will wait to invoke the application before rejecting a contact.</td>
</tr>
<tr>
<td>Initial Script</td>
<td>(Drop-down list) Choose a script to run when the Unified CCX receives a call. This script can be used to acquire initial digits from the caller and report the information to Unified ICME as part of the notification of the incoming call. This capability allows Unified ICME to correctly choose a Unified ICME script to serve the call.</td>
</tr>
<tr>
<td>Default Script</td>
<td>(Drop-down list) Choose a script to run to route a call to a default treatment if the following occurs:</td>
</tr>
<tr>
<td></td>
<td>• System error</td>
</tr>
<tr>
<td></td>
<td>• Request by Unified ICME</td>
</tr>
</tbody>
</table>

**Step 5**

Click **Add**.
The Unified ICME Post-Routing web page refreshes, the **Add New Trigger** hyperlink appears in the left navigation bar, and the following message is displayed in the status bar on top:
The operation has been executed successfully

**Step 6**

Your next step is to add a trigger for the application.

**Related Topics**

- Application Triggers, on page 54
- About Unified CCX Applications, on page 41
- Configure Script Applications, on page 42
- Configure Busy Application, on page 45
- Configure Ring-No-Answer Application, on page 47
- Configure Remote Monitoring Application, on page 52
- Provision of Unified ICME Subsystem, on page 124
Before you can configure a Unified ICME translation-routing application, you must first upload any VRU scripts that the application will need.

**Before You Begin**

To configure the Unified ICME translation-routing application, you will need to perform the following tasks:

- Add a Unified ICME translation-routing application.
  In addition to configuring general information such as name and ID, you must specify the script on which the Unified ICME translation-routing application is based.

- Add a Unified CM Telephony trigger to the Unified ICME translation-routing application.
  The Unified ICME translation-routing application is invoked by a Unified CM Telephony trigger, and does not support HTTP triggers.

To configure the Unified CCX server with a Unified ICME translation-routing application and to add a Unified CM Telephony trigger, complete the following steps:

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Application Management**. The Application Management web page opens, displaying the details of existing applications, if any.

**Step 2** Click **Add New** icon that is displayed in the tool bar in the upper, left corner of the window or the **Add New** button that is displayed at the bottom of the window. The Add a New Application web page opens.

**Step 3** From the Application Type drop-down menu, choose **Unified ICME Translation-Routing**. The Unified ICME Translation-Routing configuration web page opens.

**Step 4** Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>A name for the application.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Use the Tab key to automatically populate this field.</td>
</tr>
<tr>
<td><strong>ID</strong></td>
<td>Accept the automatically-generated ID, or enter a unique ID. This field corresponds to the service identifier of the call reported to the Unified ICME and configured in the Unified ICME translation route.</td>
</tr>
<tr>
<td><strong>Maximum Number Of Sessions</strong></td>
<td>The maximum amount of simultaneous sessions (instances) that the application can handle. <strong>Note</strong> The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources. Entering a number that is too high can result in unacceptable system performance.</td>
</tr>
<tr>
<td><strong>Enabled</strong></td>
<td>Click the required radio button to accept - <strong>Yes</strong> (the default).</td>
</tr>
</tbody>
</table>
### Configure Remote Monitoring Application

The Remote Monitoring application comes with Unified CCX Premium systems. You must configure Remote Monitoring applications when you want to use the Remote Monitoring feature to allow a supervisor to monitor an agent’s conversation.

#### Procedure

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Application Management** and click **Add New**.
The Add a New Application web page opens.

**Step 2** Choose **Cisco Script Application** from the Application Type drop-down menu and click **Next**.
The Cisco Script Application web page appears.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout (in seconds)</td>
<td>The maximum amount of time (in seconds) that the system will wait to invoke the application before rejecting a contact.</td>
</tr>
<tr>
<td>Default Script</td>
<td>(Drop-down list) Choose a script to run to route a call to a default treatment if the following occurs:</td>
</tr>
<tr>
<td></td>
<td>• System error</td>
</tr>
<tr>
<td></td>
<td>• Request by Unified ICME</td>
</tr>
</tbody>
</table>

**Step 5** Click **Add**.
The Unified ICME Translation Routing web page refreshes, the **Add New Trigger** hyperlink appears in the left navigation bar, and the following message is displayed in the status bar on top:
The operation has been executed successfully

**Step 6** Add a trigger for the application.

**Related Topics**

- Application Triggers, on page 54
- About Unified CCX Applications, on page 41
- Configure Script Applications, on page 42
- Configure Busy Application, on page 45
- Configure Ring-No-Answer Application, on page 47
- Configure Remote Monitoring Application, on page 52
- Configure Unified ICME Post-Routing Application, on page 48
- Provision of Unified ICME Subsystem, on page 124
Step 3 Specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A name for the application. This is a mandatory field.</td>
</tr>
<tr>
<td>ID</td>
<td>Accept the automatically-generated ID, or enter a unique ID. This is a mandatory field.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>The Historical Reporting feature uses this ID to identify this application.</td>
</tr>
<tr>
<td>Maximum Number of Sessions</td>
<td>The maximum amount of simultaneous sessions that monitoring sessions allow. This is a mandatory field.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources. Entering a number that is too high can result in unacceptable system performance.</td>
</tr>
<tr>
<td>Script</td>
<td>Select a customized Remote Monitor script or rmon.aef from the drop-down list.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>A new set of fields appears for a remote monitoring script.</td>
</tr>
<tr>
<td>Description</td>
<td>Use the Tab key to automatically populate this field.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - Yes (the default).</td>
</tr>
<tr>
<td>Default Script</td>
<td>Accept System Default. The default script is executed if an error occurs with the configured application script.</td>
</tr>
</tbody>
</table>

Step 4 Click Add.
The Remote Monitoring web page refreshes, displaying the following message below the Status bar and the Add New Trigger hyperlink appears on the left navigation bar:

The operation has been executed successfully

Your next step is to add a trigger for the application.

Related Topics

Application Triggers, on page 54
About Unified CCX Applications, on page 41
Configure Script Applications, on page 42
Configure Busy Application, on page 45
Configure Ring-No-Answer Application, on page 47
Application Triggers

After adding a new Cisco application, you need to add one or more triggers so that the application can respond to Unified CM Telephony calls and HTTP requests.

Triggers are specified signals that invoke application scripts in response to incoming contacts. The Unified CCX system uses Unified CM Telephony triggers to trigger responses to telephone calls and HTTP triggers to respond to HTTP requests.

You can use either of the below two methods to add a trigger to an application:

- Add the trigger from the Cisco Application web page or add the trigger from the Unified CM Telephony.
- HTTP Triggers web pages available from the Subsystem menu.

Related Topics
- About Unified CCX Applications, on page 41
- Script Management, on page 58
- Provision Unified CM Telephony Subsystem, on page 68
- Provision of HTTP Subsystem, on page 129

Unified CM Telephony Trigger

You must add Unified CM Telephony triggers to invoke Cisco applications in response to incoming contacts. A Unified CM Telephony trigger responds to calls that arrive on a specific route point by selecting telephony and media resources to serve the call and invoking an application script to handle the call.

Related Topics
- Provision Unified CM Telephony Subsystem, on page 68

Add Unified CM Telephony Triggers from Application Web Page

To add a Unified CM Telephony trigger directly from the Cisco Application Configuration web page, complete the following steps.

Procedure

Step 1 From the configuration web page for the application you want to add a trigger for, click Add New Trigger. The Add a New Trigger window opens.

Step 2 From the Trigger Type drop-down menu, choose Unified CM Telephony and click Next. The Unified CM Telephony Trigger Configuration window opens.

Step 3 Follow the procedure described in Add Unified CM Telephony Trigger, on page 77.
Related Topics

About Unified CCX Applications, on page 41
Unified CM Telephony Trigger, on page 54
Provision Unified CM Telephony Subsystem, on page 68
Configure HTTP Triggers, on page 129

Add Unified CM Telephony Triggers from Unified CCX

To add a Unified CM Telephony trigger to an application from the Unified CM Telephony subsystem, complete the following steps.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Subsystems > Unified CM Telephony > Triggers. The Unified CM Telephony Trigger Configuration summary web page opens.

Step 2
Click the Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add New button that is displayed at the bottom of the window.

Step 3
The Cisco Unified CM Telephony Trigger Configuration web page opens. Follow the procedure described in Add Unified CM Telephony Trigger, on page 77 (Steps 3 and 4) for detailed instructions on adding and configuring a Unified CM Telephony trigger.

Related Topics

About Unified CCX Applications, on page 41
Application Triggers, on page 54
Unified CM Telephony Trigger, on page 54
Provision Unified CM Telephony Subsystem, on page 68
Configure HTTP Triggers, on page 129

HTTP Trigger Provision

A Cisco application can be used to handle HTTP requests when the Unified CCX system is provisioned with an HTTP trigger.

Note
HTTP triggers are available if your system has a license installed for one of the following Cisco product packages: Unified IP IVR or Unified CCX Premium.

An HTTP trigger is the relative URL a user enters into the client browser to start the application. You can upload either eXtensible Style Language Transformation (XSLT) templates or Java Server Pages (JSP) templates to serve as your HTTP trigger.
The following path is an example of an HTTP-triggered request (using the HTTP trigger name "/hello"):

http://www.appserver.acme.com:9080/hello

In this example, the URL starts the application with the HTTP trigger "/hello" on a web server running on port 9080 with the host name www.appserver.acme.com.

You can add the HTTP trigger from the Cisco Script Application web page or add the trigger from the HTTP subsystem.

Add HTTP Trigger from Application Web Page

To add an HTTP trigger directly from a Cisco Application Configuration web page, complete the following steps.

**Procedure**

**Step 1** From the configuration web page for the application you want to add a trigger for, click **Add New Trigger** hyperlink.

The Add a New Trigger window opens.

**Step 2** From the Trigger Type drop-down menu, select **HTTP** and click **Next**.

The HTTP Trigger Configuration window opens.

**Step 3** Specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>The relative URL</td>
</tr>
<tr>
<td></td>
<td>For example: /hello</td>
</tr>
<tr>
<td>Language</td>
<td>Perform one of the following actions:</td>
</tr>
<tr>
<td></td>
<td>• Choose a default language from the drop-down list.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit</strong>, specify a default language in the dialog box that appears, and click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Maximum Number Of Sessions</td>
<td>The maximum amount of simultaneous sessions that can be served by the HTTP subsystem for this trigger.</td>
</tr>
<tr>
<td>Idle Timeout (in ms)</td>
<td>Maximum amount of time (in milliseconds) that the system will wait to invoke the application before rejecting a contact.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - <strong>Yes</strong> (the default).</td>
</tr>
</tbody>
</table>

**Note** If you disable the trigger, the user receives an error message when browsing to the defined trigger URL.
Step 4 Click Add.
The Cisco Application Configuration web page appears, and the URL of the HTTP trigger appears on the navigation bar.

Step 5 Test the trigger by entering the URL you just configured in the address bar of your browser. For example,

/hello

The browser should display "hello".

Related Topics
- About Unified CCX Applications, on page 41
- Unified CM Telephony Trigger, on page 54
- Provision Unified CM Telephony Subsystem, on page 68
- Configure HTTP Triggers, on page 129

Add HTTP Trigger from HTTP Subsystem
To configure an HTTP trigger from the HTTP subsystem, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > HTTP.
The HTTP Trigger Configuration web page opens.

Step 2 Click the Add New icon that is displayed in the tool bar in the upper, left corner of the window or the Add New button that is displayed at the bottom of the window.
The HTTP Trigger Configuration window opens.

Step 3 Specify the following mandatory fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>The relative URL. For example: /hello</td>
</tr>
<tr>
<td>Language</td>
<td>Perform one of the following actions:</td>
</tr>
<tr>
<td></td>
<td>• Choose a default language from the drop-down list.</td>
</tr>
<tr>
<td></td>
<td>• Click Edit, specify a default language in the dialog box that appears, and click OK.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Application Name</td>
<td>Choose the name of the application from the drop-down list.</td>
</tr>
<tr>
<td>Maximum Number Of Sessions</td>
<td>The maximum amount of simultaneous sessions that can be served by the HTTP subsystem for this trigger.</td>
</tr>
<tr>
<td>Idle Timeout (in ms)</td>
<td>Maximum amount of time (in milliseconds) that the system will wait to invoke the application before rejecting a contact.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - Yes (the default)</td>
</tr>
<tr>
<td></td>
<td>Note If you disable the trigger, the user receives an error message when browsing to the defined trigger URL.</td>
</tr>
</tbody>
</table>

**Step 4** Click Add.
The Cisco Application Configuration web page appears, and the URL of the HTTP trigger appears on the navigation bar.

**Step 5** To test the trigger, enter the URL you just configured in the address bar of your browser.
For example, 

/\hello

The browser should display "hello".

**Related Topics**
- About Unified CCX Applications, on page 41
- Unified CM Telephony Trigger, on page 54
- Provision Unified CM Telephony Subsystem, on page 68
- Configure HTTP Triggers, on page 129

**Script Management**

Scripts are created with the Unified CCX Editor, and can perform a wide variety of functions. For example, scripts can prompt callers for extension numbers to transfer calls, place callers in a queue and route calls to available agents, and place outbound calls.

The Script Management option of the Applications menu of the Unified CCX Administration web interface contains options for managing and refreshing Unified CCX scripts that are stored in the repository.
Your Unified CCX system includes sample scripts stored as .aef files.

If a large number of VRU scripts are configured for your system, the Upload a New Script and Refresh Scripts operations can take a long time to complete. These tasks can also result in high CPU utilization.

Related Topics
- About Unified CCX Applications, on page 41
- Application Triggers, on page 54

Upload New Scripts

To make a script available for use as a Unified CCX application, you must first upload the script to the repository. In Unified CCX Release 4.5 and later, uploaded scripts are stored in the Repository Datastore (RDS) database, along with prompts, grammars, and documents files. Prior to Release 4.5, the RDS database only contained the prompts, grammars, and documents files. The scripts can also be grouped into folders and subfolders. When user scripts are uploaded into repository, they get synchronized to local disk and are accessed from there.

To upload a script to the repository, complete the following steps:

Procedure

**Step 1** From the Unified CCX Administration menu bar, choose Applications > Script Management. The Script Management page opens.

The Script Management page allows you to only work with user scripts; it does not have language-based directories.

The following table describes the available columns on the Script Management web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder Path</td>
<td>The level of the directory that is currently selected in the folder drop-down list.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the script.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Click the icon in front of the script name to download the script file.</td>
</tr>
<tr>
<td>Size</td>
<td>The size of the script file prefixed with KB. The file size is converted from bytes to KB.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>This column is usually blank on the root page as the items on this page are usually folders.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>The date and time when the document was last uploaded or changed along with time zone.</td>
</tr>
<tr>
<td>Modified by</td>
<td>The user ID of the person who performed these modifications.</td>
</tr>
</tbody>
</table>
### Related Topics
- Refresh Scripts Individually, on page 61
- About Unified CCX Applications, on page 41
- Download Script File, on page 60
- Refresh Scripts, on page 61
- Rename Script or Folder, on page 63
- Delete Script or Folder, on page 64
- Sample Scripts, on page 64

### Download Script File

To view or download a script file, complete the following steps.

#### Procedure

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Script Management.**

The Script Management page opens to display the contents of the default folder.

**Step 2** Click the **Download Script** icon that appears before the Name of the script file you want to view or download.

The File Download dialog box opens.
Step 3  Perform one of the following tasks:
   a) To view the script file, click Open. The script file opens in the Unified CCX Editor.
   b) To download the script file, click Save, and then follow the prompts to choose a directory and file name for the script file. The file is saved to the specified directory.

---

Related Topics

- About Unified CCX Applications, on page 41
- Upload New Scripts, on page 59
- Refresh Scripts, on page 61
- Rename Script or Folder, on page 63
- Delete Script or Folder, on page 64
- Sample Scripts, on page 64

---

Refresh Scripts

⚠️ Caution
If a large number of VRU scripts are configured for your system, the Upload a New Script and Refresh Scripts operations can take a long time to complete. These tasks can also result in high CPU utilization.

When you make changes to a script, you must refresh the script to direct all the applications and subsystems that use this script to reload the new version. There are two script refresh options:

- Refresh Scripts Individually, on page 61
- Refresh Bulk Scripts, on page 62

---

Refresh Scripts Individually

To refresh an individual script on the Unified CCX server from the repository (RDS), complete the following steps.

Procedure

Step 1  From the Unified CCX Administration menu bar, choose Applications > Script Management. The Script Management page opens to display the contents of the default folder.

Step 2  In the row that contains the script, click Refresh icon. The script information refreshes and the Script Management page reappears.
Refresh Bulk Scripts

**Note** Support for high availability and remote servers is available only in multiple-server deployments.

Bulk scripts refer to multiple .aef script files within one .zip file.

**Note** This option is available only when you upload .zip files. You will see the option to refresh scripts after the selected file is uploaded successfully.

To refresh all scripts (within a zip file) with one command, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Applications > Script Management**. The Script Management page opens to display the contents of the default folder.

**Step 2** Click the **Upload New Scripts** icon or button. The Upload Script dialog box opens.

**Step 3** To locate the script, click the **Browse** button next to the File Name field, navigate to the directory in which the scripts are located, select a file, and click **Open**. The script path for the profile appears in the File Name field.

**Tip** You can only upload .zip files containing .aef files. The total size of the .zip file cannot exceed 20 MB.

**Step 4** Click **Upload** to upload the script to the repository. A window opens, informing you that the script upload succeeded.

**Step 5** Click **Refresh** icon in the Script Management page. The Script Management web page opens, giving you the option of refreshing the script and the applications that reference it, or just refreshing the script.

**Step 6** Specify one of the following options:

- If you want all applications and subsystems that reference the script (in the repository) to use the new version, click **Yes**.
- If you only want to refresh the scripts, click **No**.
If you want to cancel the operation, click **Cancel**.

The script information refreshes and the Script Management page reappears to display the newly loaded .zip file.

---

**Related Topics**

- About Unified CCX Applications, on page 41
- Upload New Scripts, on page 59
- Download Script File, on page 60
- Refresh Scripts, on page 61
- Rename Script or Folder, on page 63
- Delete Script or Folder, on page 64
- Sample Scripts, on page 64

---

**Rename Script or Folder**

To rename a script or folder, complete the following steps.

**Procedure**

**Step 1**  
From the Unified CCX Administration menu bar, choose **Applications > Script Management**. The Script Management page opens to display the contents of the default folder.

**Step 2**  
Click **Rename** icon for the folder or script that you want to rename. A dialog box opens displaying the name of the selected folder or script.

**Step 3**  
Enter a new name for this folder or script in the text box.

**Step 4**  
Click **Rename** button. The dialog box refreshes to state that the folder was successfully renamed.

**Step 5**  
Click **Return to Script Management** button. The dialog box closes and the default folder’s updated Script Management page displays the new script name.

---

**Related Topics**

- About Unified CCX Applications, on page 41
- Upload New Scripts, on page 59
- Download Script File, on page 60
- Refresh Scripts, on page 61
- Delete Script or Folder, on page 64
- Sample Scripts, on page 64
Delete Script or Folder

When you delete a script or a folder, you remove it permanently from the repository.
To delete a script or folder, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script Management. The Script Management page opens to display the contents of the default folder.

Step 2 To delete a folder, click Delete icon for the folder or script that you want to delete. A dialog box opens to confirm your action on the selected script or folder.

Step 3 Click OK. The dialog box closes and the default folder's updated Script Management page refreshes to display the updated list of folders and scripts.

Related Topics

- About Unified CCX Applications, on page 41
- Upload New Scripts, on page 59
- Download Script File, on page 60
- Refresh Scripts, on page 61
- Rename Script or Folder, on page 63
- Sample Scripts, on page 64

Sample Scripts

Your Unified CCX system includes sample scripts stored as .aef files. These scripts have been built using Unified CCX Editor steps, including prerecorded prompts. You can use these scripts to create applications without performing any script development, or you can use these scripts as models for your own customized scripts.

Note The included scripts are bundled with the Unified CCX system only as samples; they are not supported by Cisco. For more information on these sample scripts, see the Cisco Unified CCX Scripting and Development Series: Volume 1, Getting Started with Scripts.
Telephony and Media Provision

Resource provisioning information for the Unified CCX telephony and media subsystems are provided in this chapter.

- Unified CCX Telephony and Media, page 65
- Provision Unified CM Telephony Subsystem, page 68
- Additional Unified CM Telephony Information, page 81
- Cisco Media Subsystem, page 83
- ASR and TTS in Unified CCX, page 84

Unified CCX Telephony and Media

The Unified CCX system uses a telephony resource called Computer Telephony Interface (CTI) ports to accept incoming calls and to place outbound calls. The Unified CCX system uses the following media resources to provide interactive services for calls:

- Unified CM Telephony—The Unified CCX Engine uses the Unified CM Telephony subsystem to send and receive calls from the Unified CM by interfacing with the CTI Manager through the Unified CM Telephony client.

- Cisco Media Termination (CMT)—The CMT channels provide media terminations in the Unified CCX for Unified CM Telephony Call Contacts. These channels enable the Unified CCX to play media to the connected party. DTMF digits are received out of band by the Unified CM Telephony subsystem.

- MRCP Automated Speech Recognition (MRCP ASR)—The ASR media resource allows callers to use speech to navigate menus and to provide other information to Unified CCX applications.

- MRCP Text-To-Speech (MRCP TTS)—The TTS media resource enables Unified CCX applications to play back documents to callers as speech.
Media resources are licensed and sold as Unified IP IVR ports. Although you can provision more channels than you are licensed for, licensing is enforced at run-time. If more channels are provisioned than licensed, the system will not accept the extra calls, because doing so would violate your licensing agreements.

The Unified CCX system uses groups to share telephony and media resources among different applications:

- **Call control groups** allow you to control how the system uses CTI ports. For example, you can reserve more ports for higher-priority applications or provide access to fewer ports for applications with less traffic.

- **Media resource groups** allow you to share media resources among different applications. For example, you can share ASR media resource groups with applications that collect caller information and applications that transfer calls to specific extensions.

The Unified CCX system also uses triggers, which are specified signals that invoke application scripts in response to incoming contacts.

**Media Termination Groups**

Media termination groups are associated with CTI port groups.

During initial Unified CCX Setup, based on the licensed number of CTI ports, a default CTI port group and its associated media termination group are created. By default, every trigger is associated with this CTI port group and the corresponding media termination group.

For Unified CM deployment, you can create and use additional CTI port groups as required.

If a CTI port group is selected to support media termination and if the number of channels are identical to both groups, the CTI port group is automatically created in the background. This auto creation feature eliminates the manual CTI port group creation process.

If you choose to override media termination, the call control channel chooses the media termination automatically. If you want to select a new dialog group, you can have more than one media termination option. The options are used in the order that is displayed in the drop-down list.

**Related Topics**

Add New Call Control Group, on page 71

**Channels Required to Process Calls**

Unified CCX needs two types of channels to process calls:

- A call control channel, which is provisioned through the Unified CM Telephony subsystem and corresponds to CTI port resources in Unified CM.
A media channel, which is provisioned through either the CMT subsystem or the MRCP subsystem and corresponds to the kernel resources for handling the media voice path with the caller.

**Note**
MRCP channels also correspond to additional resources on the MRCP server for performing speech recognition.

Unified CCX needs access to a channel of each type to successfully process a call. However, the capabilities of the two channel types are not identical.

For example, consider a Unified CCX system provisioned with a single Unified CM Telephony call control channel (that is, a CTI port) and a single CMT channel. The system can handle one call at a time; when that call terminates, the system must reinitialize the channel resources before it can accept another call.

However, the time each channel takes to reinitialize is not equal—CMT channels take more time to reinitialize than CTI ports. For example:

- The Unified CM Telephony call control channel may take approximately 1 millisecond to reinitialize.
- The CMT channel may take approximately 200 milliseconds to reinitialize.

This example implies that the system will not be able to accept a new incoming call for 200 milliseconds after the first call terminates; although the Unified CM Telephony channel is available after one millisecond, the CMT channel is not and Unified CCX needs both channels to process a call.

Such a delay can become an issue when a Unified CCX system is experiencing a high load condition or needs to handle a burst of incoming calls. Consequently, CMT channels require a higher channel count provisioning.

**Tip**
To provision Unified CCX systems to handle burst calls equally among all required resources, you must configure approximately 10 percentage more CMT channels than CTI ports, and approximately 10 percentage more MRCP channels than ASR licenses.

---

**Provision Telephony and Media Resources**

To provision telephony and media resources, complete the following tasks:

**Procedure**

**Step 1** Provision the Unified CM Telephony subsystem.
Unified CM Telephony subsystem controls telephony resources for Unified CCX system.

**Step 2** Provision the Cisco Media subsystem.
Cisco Media subsystem controls CMT media resources for Unified CCX system.

**Step 3** Provision the MRCP ASR subsystem.
MRCP ASR subsystem controls ASR media resources for Unified CCX system.

**Step 4** Provision the MRCP TTS subsystem.
MRCP TTS subsystem controls TTS media resources for Unified CCX system.
Provision Unified CM Telephony Subsystem

The Unified CM Telephony subsystem is the subsystem of the Unified CCX Engine that sends and receives call-related messages from the Unified CM CTI Manager through the Unified CM Telephony client. To enable your Unified CCX server to handle Cisco Unified Communications requests, you must provision the Unified CM Telephony subsystem. The Unified CM Telephony subsystem is available in all the Unified CCX license packages.

Note
In previous versions of Unified CCX, it was necessary to configure Unified CM Telephony information using Unified CM. In Unified CCX Release 4.0 and later, Unified CM Telephony configuration tasks are performed directly through Unified CCX Administration web pages.

To provision the Unified CM Telephony subsystem, complete the following tasks:

Procedure

Step 1 Configure a Unified CM Telephony Provider, if not already configured. Specify the server on which Unified CM CTI Manager is running, and provide a Unified CM user ID and password.

Step 2 Provision Unified CM Telephony call control groups.
Unified CM Telephony call control groups pool together a series of CTI ports, which the system then uses to serve calls as they arrive at the Unified CCX server.

Step 3 Provision a Unified CM Telephony trigger.
Unified CM Telephony triggers invoke application scripts in response to incoming contacts.

Step 4 Resynchronize Unified CM Telephony versions.

Related Topics
Telephony and Media Provision, on page 65

Resynchronize Cisco JTAPI Client

During the resynchronizing process, an additional check ensures that the Unified CM Telephony Client (also known as the Cisco JTAPI Client) are the same between the clients installed on the Unified CCX node and the Cisco Unified CM. If the Unified CCX detects a mismatch, the system downloads and installs the required version of Cisco JTAPI Client.

To resynchronize and view the status of Cisco JTAPI client, complete the following steps.
Procedure

**Step 1** Choose **Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync** from the Unified CCX Administration menu bar.

**Step 2** The Cisco JTAPI Resync web page opens, displaying the status of Cisco JTAPI Client resynchronization. At this point, if there is an incompatible version, it automatically downloads the new client.

Related Topics
- Configure Unified CM Telephony Provider, on page 69
- Add Unified CM Telephony Trigger, on page 77
- Additional Unified CM Telephony Information, on page 81

### Resynchronize Unified CM Telephony Data

This resynchronizing process ensures that the Unified CM Telephony user, the call control groups, and the triggers match the data of Unified CM being used.

To resynchronize the Unified CM Telephony data, complete the following steps.

**Procedure**

From the Unified CCX Administration menu bar, choose **Subsystems > Cisco Unified CM Telephony > Data Resync**.

The Data Resync web page opens after resynchronization, displaying the Data Resync status of Unified CM Telephony Port Groups and Unified CM Telephony Triggers.

**Related Topics**
- Configure Unified CM Telephony Provider, on page 69
- Add Unified CM Telephony Trigger, on page 77
- Additional Unified CM Telephony Information, on page 81

### Configure Unified CM Telephony Provider

The Unified CM Telephony Provider web page is a read-only page that displays the latest configured information.
Some setups may prevent the Unified CM directory administrator from creating new Unified CM Telephony providers in a multiserver configuration. If this setup applies to you, be sure to delete preexisting Unified CM Telephony providers before creating new Unified CM Telephony providers. For example, if the Unified CM Telephony provider prefix is `cmtelephony` and you have a two-server configuration (node_id1 and node_id2), you must delete both `cmtelephony_<node_id1>` and `cmtelephony_<node_id2>`. If you do not verify and delete preexisting Unified CM Telephony providers, the Unified CM Telephony subsystem issues an error and will not allow you to create Unified CM Telephony providers from the Unified CM Telephony Provider Configuration web page.

### Procedure

**Step 1**

Choose **Subsystems > Cisco Unified CM Telephony > Provider** from the Unified CCX Administration menu bar.

The Cisco Unified CM Telephony Provider web page opens.

The following table describes the read-only fields displayed in the Unified CM Telephony Provider Configuration web page.

<table>
<thead>
<tr>
<th>Field Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Unified CM Telephony Provider</td>
<td>IP address of the Server, running Unified CM CTI Manager in the cluster. This is normally the first CTI Manager or Cisco Unified CM Telephony Provider selected by the Unified CCX user for Unified CM Telephony subsystem using <strong>System &gt; Cisco Unified CM Configuration</strong> web page.</td>
</tr>
<tr>
<td>Secondary Unified CM Telephony Provider</td>
<td>IP address of the second Server, running Unified CM CTI Manager in the cluster. This is normally the second CTI Manager or Cisco Unified CM Telephony Provider selected by the Unified CCX user for Unified CM Telephony subsystem using <strong>System &gt; Cisco Unified CM Configuration</strong> web page.</td>
</tr>
<tr>
<td>User Prefix</td>
<td>User prefix for the Unified CM user IDs created in Unified CM.</td>
</tr>
</tbody>
</table>

**Step 2**

To modify the Unified CM Telephony subsystem, click **Modify Cisco Unified CM Telephony Provider Information** icon that displays in the tool bar in the upper left corner of the window. The Cisco Unified CM Configuration web page opens.

**Related Topics**

Add New Call Control Group, on page 71
Add New Call Control Group

The Unified CCX system uses Unified CM Telephony call control groups to pool together a series of CTI ports, which the system uses to serve calls as they arrive or depart from the Unified CCX server. You can create multiple Unified CM Telephony call control groups to share and limit the resources to be used by specific applications.

To configure a new Unified CM Telephony call control group, complete the following steps.

Procedure

**Step 1**  
From the Unified CCX Administration menu bar, choose **Subsystems > Unified CM Telephony > Call Control Group**.  
The Cisco Unified CM Telephony Call Control Group Configuration web page opens, which displays the existing Unified CM Telephony Call Control Group information, if any.

**Step 2**  
Click **Add New** icon that is displayed in the tool bar in the upper left corner of the window or the **Add New** button that is displayed at the bottom of the window to create a new CTI port. The Cisco Unified CM Telephony Call Control Group Configuration web page opens.  
**Note**  
You can create only one call control group of the Outbound type, in which the number of CTI ports must be always equal to or greater than the licensed Outbound IVR ports.

**Step 3**  
Use this web page to specify the following information:

<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Group Information  | Group ID| Corresponds to the trunk group number reported to Cisco Unified Intelligent Contact Management Enterprise (Unified ICME) when the Unified CCX server is part of the Unified ICME solution. The value for this field is automatically generated.  
**Note**  
If a Stop icon displays beside the Group ID (on the Cisco Unified CM Call Control Group Configuration list page), it indicates that the data is invalid or out of sync with Unified CM data; if a Head icon displays, the group is valid. |
<p>| Description        | Description of the Group ID. Press the <strong>Tab</strong> key to automatically populate the Description field. |</p>
<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Information (continued)</td>
<td>Number of CTI Ports</td>
<td>Number of CTI Ports assigned to the call control group. This is a mandatory field. If you have a Premium license with an Outbound license, you can create only one Outbound call control group with a minimum licensed number of IVR ports or more. The number of CTI ports for an outbound type of call control group can be modified but not below the licensed ports for Outbound IVR. This rule does not apply to inbound type call control groups. You can continue to create more inbound type call control groups. <strong>Note</strong> If this field is set to <code>&lt;n&gt;</code>, the system creates <code>&lt;n&gt;</code> ports for each Unified CCX Engine node (node in which Unified CCX Engine component is enabled).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Media Termination Support</td>
<td></td>
<td>Enables the auto-creation of media termination groups. This is a mandatory field. Yes = Provides automatic media termination if the CTI port group is successful. No = Media termination port group is not created (default).</td>
</tr>
<tr>
<td>Group Type</td>
<td></td>
<td>Select the group type for the call control group using this radio button. The choices are Inbound and Outbound. This is a mandatory field and Inbound radio button is enabled by default. You cannot change the group type from Outbound to Inbound and vice versa. The Outbound type call control group will be displayed only if you have uploaded the Outbound license on top of the premium license in your Unified CCX. <strong>Note</strong> The existing call control groups will have this value as inbound after an upgrade from Unified CCX versions prior to 9.0(1).</td>
</tr>
<tr>
<td>Directory Number Information</td>
<td>Device Name Prefix</td>
<td>The Device Name Prefix (DNP) used in the name that will be given all of the CTI Ports in this group. This is a mandatory field. The CTI ports for this port group is restricted to a maximum of 5 characters and has the following format: <code>&lt;deviceprefix&gt;_&lt;directoryno&gt;</code> For example, if the Device Name Prefix is CTP and the starting Directory Number is 7000, the CTI Port that is created in Unified CM can have the device name CTP_7000.</td>
</tr>
</tbody>
</table>

Select **Server for Telephony Port Group Configuration** (displayed only in a HA over WAN deployment).
<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Server</td>
<td>This field is displayed only in a HA over WAN deployment and it displays the different Unified CCX nodes that are available in a HA over WAN deployment in a drop-down list. In a HA over WAN setup, you need to configure directory information along with Unified CM-specific information for the ports in each node. Once you select a node, all configuration details displayed below this field will be specific to the selected node only. So, if you update any node-specific parameters (below the Select Server field), it will be applicable only to the ports specific to the selected node. But, if you update any configuration data above the Select Server field, it will be applicable for the ports in both the nodes except for the Number of CTI Ports field.</td>
<td></td>
</tr>
</tbody>
</table>

**Note** You need to ensure that the values in Number of CTI ports field for both the nodes are the same. If you modify this field, the number of ports is modified for the selected node only as the device pool selection for both nodes could be different in a HA over WAN deployment. If you click **Add** before updating this value for either of the node, the port group for that node will be marked with a red cross in the main Cisco Unified CM Telephony Call Control Group Configuration web page to signify the fact that the number of ports between the two nodes is different and the other node should also be updated. In such a scenario, click the hyperlink for the node that is tagged in red; and from the Cisco Unified CM Telephony Call Control Group Configuration page for the selected node, update the value in the Number of CTI Ports field and click **Update** to ensure the number of CTI ports for both the nodes are the same. After you configure the data for the selected node and click **Add** or **Update**, the updated configuration information will be saved. For detailed information on behavior in HA over WAN scenario, refer to the Cisco Unified Contact Center Express Design Guide [http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_implementation_design_guides_list.html](http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_implementation_design_guides_list.html). In case of LAN deployment, this field is not displayed, as the same configuration data will be applicable for both the nodes in the cluster. |
<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory Number Information</td>
<td>Starting Directory Number</td>
<td>A unique phone number. The Starting Directory Number contains numerals, and can have an asterisk (*) or a hash (#), or both as a prefix or a suffix. To support E.164 compliance, Unified CCX allows you to add the plus sign (+) before the directory number. The specified number of ports will be created starting from the value specified in this field. The Directory Number that you enter can appear in more than one partition. This is a mandatory field. Note: When a pattern is used as a Directory Number, the phone display and the caller ID display on the dialed phone will contain characters other than digits. To avoid this, provide a value for Display (Internal Caller ID), Line Text Label, and External Phone Number Mask.</td>
</tr>
<tr>
<td></td>
<td>Device Pool</td>
<td>Set of common characteristics for devices, such as region, date/time group, softkey template, and MLPP information to which you want to assign this phone. Note: The support for having multiple device pools associated with call control group(s) has been withdrawn in Unified CCX. If you have multiple device pools associated with call control group(s) in an older version of Unified CCX, it is recommended to manually assign a single device pool to each call control group. For more information, see Synchronize Unified CM Telephony Data, on page 289.</td>
</tr>
<tr>
<td></td>
<td>DN Calling Search Space</td>
<td>A collection of partitions that are searched to determine how a dialed number should be routed. The calling search space for the device and the calling search space for the directory number get used together. The directory number calling search space takes precedence over the device calling search space. For more information, see the Cisco Unified Communications Manager System Guide.</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>The Cisco Unified Communications phone location setting specifies the total bandwidth that is available for calls to and from this location. A location setting of HUB_NONE means that the location feature does not keep track of the bandwidth that this Cisco Unified Communications phone consumes.</td>
</tr>
<tr>
<td></td>
<td>Partition</td>
<td>The Cisco Unified Communications phone location setting specifies the total bandwidth that is available for calls to and from this location. A location setting of HUB_NONE means that the location feature does not keep track of the bandwidth that this Cisco Unified Communications phone consumes.</td>
</tr>
</tbody>
</table>

**Advanced Directory Number Information** (only available if you click **Show More**)

---

Cisco Unified CCX Administration Guide, Release 10.5
<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory Number (continued)</td>
<td>Alerting Name ASCII</td>
<td>This information is automatically populated based on the configuration in the Unified CM setup and displays the ASCII name field used in one of the following situations:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the device is not capable of handling the Unicode strings</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the locals on endpoint devices do not match</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the Unicode string is not specified</td>
</tr>
<tr>
<td>Redirect Calling Search Space</td>
<td>A collection of partitions that are searched to determine how a redirected call is routed.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Redirect Calling Search Space options:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: <strong>DN Calling Search Space</strong> is deprecated. Use <strong>Calling Party</strong> or <strong>Redirect Party</strong> instead.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>DN Calling Search Space</strong>—This option enables the CTI Port to use its directory number CSS when performing a redirect / consult transfer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Calling Party</strong>—This option enables the CTI Port to use the calling party's CSS when performing a redirect / consult transfer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Redirect Party</strong>—This option enables the CTI Port to use the CTI Route Point's CSS when performing a redirect / consult transfer.</td>
</tr>
<tr>
<td>Media Resource Group List</td>
<td>A prioritized grouping of media resource groups. An application chooses the required media resource, such as a Music On Hold server, from the available media resources according to the priority order that is defined in a Media Resource Group List.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you choose &lt;none&gt;, Unified CM uses the Media Resource Group that is defined in the device pool.</td>
</tr>
<tr>
<td>Page Area</td>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Directory Number Setting</td>
<td>Voice Mail Profile</td>
<td>A list of profiles defined in the Voice Mail Profile Configuration. The first option is &lt;None&gt;, which is the current default Voice Mail Profile that is configured in the Voice Mail Profile Configuration.</td>
</tr>
<tr>
<td>Presence Group</td>
<td>Presence Group</td>
<td>See the <em>Cisco Unified Communications Manager Administration Guide</em> for detailed information on how to configure presence groups.</td>
</tr>
<tr>
<td>Require DTMF Reception</td>
<td>Require DTMF Reception</td>
<td>A Unified CM radio button to determine if DTMF reception is required. Yes is selected by default. If you select No, a warning message is displayed.</td>
</tr>
<tr>
<td>AAR Group</td>
<td>AAR Group</td>
<td>Automated Alternate Routing (AAR) group for this device. The AAR group provides the prefix digits that are used to route calls that are otherwise blocked due to insufficient bandwidth. An AAR group setting of &lt;None&gt; specifies that no rerouting of blocked calls will be attempted.</td>
</tr>
<tr>
<td>User Hold Audio Source</td>
<td>User Hold Audio Source</td>
<td>Audio source heard by the caller when the Unified CCX Script places the caller on Hold by using the Hold Step (when you press the hold key).</td>
</tr>
<tr>
<td>Network Hold Audio Source</td>
<td>Network Hold Audio Source</td>
<td>Audio source heard by the caller when Unified CCX performs a Consult Transfer (when Unified CCX calls an agent). Use this entry for the .wav file (for example, .wav file playing a ringback tone) to be played to the caller during this Consult Transfer.</td>
</tr>
<tr>
<td>Call Forward and Pickup Settings</td>
<td>Call Pickup Group</td>
<td>The number that can be dialed to answer calls to this directory number in the specified partition.</td>
</tr>
<tr>
<td>Display</td>
<td>Display</td>
<td>Use a maximum of 30 alphanumeric characters. Typically, use the user name or the directory number (if you use the directory number, the person receiving the call may not see the proper identity of the caller). Leave this field blank to have the system display the extension.</td>
</tr>
<tr>
<td>External Phone Number Mask</td>
<td>External Phone Number Mask</td>
<td>Phone number (or mask) that is used to send Caller ID information when a call is placed from this line. You can enter a maximum of 24 number, the international escape character +, *, # and &quot;X&quot; characters. The X characters represent the directory number and must appear at the end of the pattern. For example, if you specify a mask of 972813XXXX, an external call from extension 1234 displays a caller ID number of 9728131234.</td>
</tr>
</tbody>
</table>

**Step 4**  Click **Add** or **Save**.  
The Unified CM Telephony Call Control Group Configuration summary web page opens. The corresponding CTI ports are created in the Unified CM Telephony call control group. The new call control group appears in
the list of call control groups displayed in the Cisco Unified CM Telephony Call Control Group Configuration
web page.

Related Topics

Media Termination Groups, on page 66
Unified CM Telephony Information Resynchronization, on page 82
Configure Unified CM Telephony Provider, on page 69
Add Unified CM Telephony Trigger, on page 77
Additional Unified CM Telephony Information, on page 81

Add Unified CM Telephony Trigger

You must configure Unified CM Telephony triggers to invoke application scripts in response to incoming
contacts. A Unified CM Telephony trigger responds to calls that arrive on a specific route point by selecting
telephony and media resources to serve the call and invoking an application script to handle the call. The
Unified CM Telephony triggers are available with all Unified CCX license packages.

Unified CM Telephony trigger settings include:

• **Session** information, such as the application to associate with the trigger, Maximum Number of sessions
  allowed, and the Idle Timeout value.

• **CTI** information, such as a CTI port device and CTI route points for each call Unified CCX
  simultaneously places or accepts.

• **Directory Number** information, such as the Voice Mail Profile and Calling Search Space.

• **Call Forward and Pickup** instructions.

To add and configure a Unified CM Telephony trigger, complete the following steps.

**Procedure**

**Step 1**

From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony >
Triggers.
The Unified CM Telephony Trigger Configuration web page opens displaying the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Route Point</td>
<td>Available CTI route point, which is the directory number associated with the trigger.</td>
</tr>
<tr>
<td>Application</td>
<td>Application name to associate with the trigger.</td>
</tr>
<tr>
<td>Sessions</td>
<td>Maximum number of simultaneous calls that the trigger can handle.</td>
</tr>
<tr>
<td>Enabled</td>
<td>True if the trigger is enabled; False if the trigger is disabled.</td>
</tr>
</tbody>
</table>
If you try to delete a trigger associated with an outbound call control group, then the campaigns associated with the trigger become invalid and the application also gets deleted. In such cases, when you click the Delete icon or button, a dialog box opens to confirm your action. Click OK if you want to delete the trigger and disassociate the campaigns associated with it. If you delete a trigger and navigate to the Campaign Configuration web page, you will also see an alert regarding the missing trigger association for that campaign.

**Step 2**  
Click the Add New icon that is displayed in the tool bar in the upper left corner of the window or the Add New button that is displayed at the bottom of the window. The Unified CM Telephony Trigger Configuration web page opens.

**Step 3**  
Use this web page to specify the following mandatory fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Directory Information</strong></td>
<td></td>
</tr>
</tbody>
</table>
| Directory Number | A unique phone number. To support E.164 compliance, Unified CCX allows you to add a plus sign (+) before the agent extension or a route point directory number followed by 15 characters which consist of numerals and the following special characters: uppercase letter X, hash (#), square brackets ([ ]), hyphen (-), and asterisk (*).  
  - Supports only route point directory numbers and Finesse agent and supervisor extensions.  
  - Does not support Cisco Agent Desktop.  |
| **Note** | +1234 and 1234 are two different directory numbers.  
  - The square brackets ([ ]) enclose a range of values.  
  - For more information, see the “Wildcards and Special Characters in Route Patterns and Hunt Pilots” section in the Cisco Unified Communications Manager System Guide, located at http://www.cisco.com/en/us/products/sw/voicesw/ps556/prod_maintenance_guides_list.html.  
  - Examples:  
    - Valid directory numbers—+1223* or *#12**  
    - Invalid directory numbers—91X+ or +12345 |
| **Trigger Information**                                                                     |                                                                                                                                          |
| Language | Choose the default language to associate with the incoming call when the application is started from this drop-down menu.  
  - To add a Language option, click Edit button. The User Prompt dialog box opens. Enter a locale string value and click OK. The User Prompt dialog box closes, and the name of the language opens in the Language field in the Unified CM Telephony Configuration web page. |
| Application Name | From the drop-down menu, choose the application to associate with the trigger. |
## Field

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Name</td>
<td>A unique identifier for this device, consisting of alphanumeric characters, dots, dashes, or underscores.</td>
</tr>
<tr>
<td>Description</td>
<td>A descriptive name for the CTI route point.</td>
</tr>
<tr>
<td>Call Control Group</td>
<td>Choose the call control group to associate with the trigger from this drop-down menu. For Outbound IVR Dialer, you must select the call control group from Outbound type call control group list. The route point should be created on Unified CM. Once you assign the Outbound group for a trigger, you cannot change it to an Inbound group and vice versa.</td>
</tr>
</tbody>
</table>

### Advanced Configuration (available only if you click Show More).

### Advanced Trigger Information

<table>
<thead>
<tr>
<th>Enabled</th>
<th>Radio buttons to choose the required option:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• <strong>Yes</strong>—enable the trigger (default)</td>
</tr>
<tr>
<td></td>
<td>• <strong>No</strong>—disable the trigger.</td>
</tr>
</tbody>
</table>

| Maximum Number of Sessions   | The maximum number of simultaneous calls that this trigger can handle. The number is actually governed by the Unified CM (10,000 for each separate line). However in Unified CCX, this number is restricted to the maximum number of sessions. Any call after this number is exceeded gets the busy tone. |

| Idle Timeout (in ms)         | The number of milliseconds (ms) the system should wait before rejecting the Unified CM Telephony request for this trigger.                                                                               |

<table>
<thead>
<tr>
<th>Override Media Termination</th>
<th>Radio buttons to choose the required options:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Yes</strong>—Override media termination.</td>
</tr>
<tr>
<td></td>
<td><strong>No</strong>—Enable media termination (default).</td>
</tr>
<tr>
<td></td>
<td>If you select Yes, two panes open:</td>
</tr>
<tr>
<td></td>
<td>• Selected Dialog Groups displays the default or selected group.</td>
</tr>
<tr>
<td></td>
<td>• Available Dialog Groups lists the configured dialog.</td>
</tr>
</tbody>
</table>

### CTI Route Point Information

<table>
<thead>
<tr>
<th>Alerting Name ASCII</th>
<th>This information is automatically populated based on the configuration in the Unified CM setup and displays the ASCII name filed used in one of the following situations:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• If the device is not capable of handling the Unicode strings</td>
</tr>
<tr>
<td></td>
<td>• If the locals on endpoint devices do not match</td>
</tr>
<tr>
<td></td>
<td>• If the Unicode string is not specified</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Device Pool</td>
<td>The device pool to which you want to assign this route point. A device pool defines sets of common characteristics for devices, such as region, date/time group, softkey template, and MLPP information.</td>
</tr>
<tr>
<td>Location</td>
<td>The total bandwidth that is available for calls to/from this location. A location setting of HUB_NONE indicates that the locations feature does not keep track of the bandwidth used by this route point.</td>
</tr>
</tbody>
</table>

**Directory Number Settings**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partition</td>
<td>The partition to which the Directory Number belongs. The Directory Number field value must be unique within the partition that you choose. If you do not want to restrict access to the Directory Number, select &lt;None&gt; as the partition setting.</td>
</tr>
<tr>
<td>Voice Mail Profile</td>
<td>A list of profiles defined in the Voice Mail Profile Configuration. The first option is &lt;None&gt;, which is the current default Voice Mail Profile that is configured in the Voice Mail Profile Configuration.</td>
</tr>
<tr>
<td>Calling Search Space</td>
<td>A collection of partitions that are searched for numbers that are called from this directory number. The specified value applies to all devices that use this directory number.</td>
</tr>
<tr>
<td></td>
<td>For example, assume you have two calling search spaces: Building and PSTN. Building only allows users to call within the building, while PSTN allows users to call both in and outside the building. You could assign the phone to the Building calling search space and the line on your phone to the PSTN calling search space. For more information, see the Cisco Unified Communications Manager System Guide.</td>
</tr>
</tbody>
</table>

**Calling Search Space for Redirect**

By default, Cisco Unified Communications Manager uses the original calling party's calling search space (CSS) to process the redirected call from a Unified CCX Trigger to a Unified CCX CTI Port. This default behavior requires the partition of the Unified CCX CTI ports to be a member of the original calling party's CSS even if the partition of the CTI Route Point/Unified CCX Trigger is accessible to the calling device's CSS and the CSS of the CTI Route Point/Unified CCX Trigger contains the partition of the Unified CCX CTI Ports.

You can modify this behavior using the drop-down list to instruct Cisco Unified Communications Manager which CSS to use when redirecting the call from the CTI Route Point to the CTI Port.

**Calling Search Space for Redirect options:**

- **Default Calling Search Space**—CSS of the calling device
- **Calling Address Search Space**—CSS of the calling device
- **Route Point Address Search Space**—CSS of the CTI Route Point (Trigger)
Field | Description
--- | ---
Presence Group | A list of groups to integrate the device with the iPass server. The device/line information is provided for integrating applications.

**Call Forward and Pickup Settings**

**Forward Busy** | Check one of the following options:

*Voice Mail*—Check this box to use settings in the Voice Mail Profile Configuration window.

*Note* | When this box is checked, Unified CM ignores the settings in the Destination box and Calling Search Space.

*Destination*—To use any disable phone number, including an outside destination.

*Calling Search Space*—To apply the above setting all devices that are using this directory number.

**Display** | Use a maximum of 30 alphanumeric characters. Typically, use the user name or the directory number (if using the directory number, the person receiving the call may not see the proper identity of the caller). Leave this field blank to have the system display an extension.

**External Phone Number Mask** | Phone number (or mask) that is used to send Caller ID information when a call is placed from this line.

You can enter a maximum of 24 number, the international escape character +, *, # and "X" characters. The X characters represent the directory number and must appear at the end of the pattern. For example, if you specify a mask of 972813XXXX, an external call from extension 1234 displays a caller ID number of 9728131234.

**Step 4** Click **Add** or **Save** to save the changes. The specified route point is created on the Unified CM. The Unified CM Telephony Trigger Configuration web page opens and displays the new Unified CM Telephony trigger.

**Related Topics**

- Media Termination Groups, on page 66
- Configure Unified CM Telephony Provider, on page 69
- Add New Call Control Group, on page 71
- Additional Unified CM Telephony Information, on page 81

**Additional Unified CM Telephony Information**

This section includes the following topics:

- Unified CM Telephony Triggers for Unified CCX Queuing, on page 82
Unified CM Telephony Triggers for Unified CCX Queuing

When limiting the number of calls per application in Unified CCX applications, you need to take care to coordinate the Unified CM Telephony trigger Maximum Number of Sessions limit with the Media Group session limit.

For example, if you are using Unified CCX for queuing calls and set the Unified CM Telephony trigger Maximum Number of Sessions limit on Unified CCX to 4 and set the Call Forward and Pickup Settings to send the fifth call to voice mail. To make this happen, you must configure the Media Group Session Limit to the identical setting (4). This will cause Unified CM to forward the next incoming call to voice mail (once the CTI New Call Accept timer setting expires).

The disadvantage of this approach is that you need to define more media groups for each application and you cannot share the same set of media groups across multiple applications.

Related Topics

Provision Unified CM Telephony Subsystem, on page 68

Unified CM Telephony Information Resynchronization

If the Unified CM Telephony information (Unified CM Telephony users, CTI ports, triggers) in the Unified CM is missing or not in sync with Unified CCX data, choose Subsystems > Cisco Unified CM Telephony > Data Resync from the Unified CCX Administration menu bar. Unified CCX checks whether:

- The Unified CM Telephony users exist in Unified CM.
- All the ports belonging to the Port Group exist in Unified CM.
- The port group's data is in sync with Ports data in Unified CM.
- The ports' association to users are correct.
- The route point exists in Unified CM.
- The triggers data is in sync with the Route Point data in the Unified CM.
- The route points have been associated with all the Unified CM Telephony users in Unified CM.

Unified CCX synchronizes the data by:

- Creating any missing users
- Creating any missing ports
- Modifying out-of-sync ports
- Associating CTI Ports to Unified CM Telephony users. (For example, associating CTI Ports created for Node 1 to the Unified CM Telephony User for Node 1, and so forth)
- Creating any missing route points
- Modifying out-of-sync route points
- Associating route points to all the Unified CM Telephony users.
Cisco Media Subsystem

The Cisco Media subsystem is a subsystem of the Unified CCX Engine. The Cisco Media subsystem manages the CMT media resource. CMT channels are required for Unified CCX to be able to play or record media. The Cisco Media subsystem uses dialog groups to organize and share resources among applications. A dialog group is a pool of dialog channels in which each channel is used to perform dialog interactions with a caller, during which the caller responds to automated prompts by pressing buttons on a touch-tone phone.

**Note**

The built-in grammars and grammar options that are supported by Unified CCX when using an MRCP dialog channel is determined by the MRCP speech software you purchase. See the software vendor for information about what built-in grammars and features are supported.

To enable your Unified CCX applications to handle simple DTMF-based dialog interactions with customers, you must provision the Cisco Media subsystem to configure CMT dialog groups.

---

**Caution**

All media termination strings begin with `auto` and contain the same ID as the call control group—not the CMT dialog group. If the default media termination is configured and the ID differs, follow the procedure provided in the Add CMT Dialog Control Group, on page 83.

---

Related Topics

Provision Unified CM Telephony Subsystem, on page 68

Add CMT Dialog Control Group

To add a CMT dialog control group, complete the following steps.

**Procedure**

**Step 1**

From the Unified CCX Administration menu bar, choose Subsystems > Cisco Media. The Cisco Media Termination Dialog Group Configuration web page opens. Any preconfigured entry is listed on this page with the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GroupID</td>
<td>The unique Group ID associated with the media.</td>
</tr>
<tr>
<td>Description</td>
<td>CMT group description.</td>
</tr>
</tbody>
</table>

**Note**

The ID in this field need not necessarily match the CMT group ID.
Step 2  Click **Add New** icon at the top or **Add New** button at the bottom of the window. The Cisco Media Termination Dialog Group Configuration web page opens.

*Note*  By default, a Unified CM Telephony Call Control Group with Group ID 0 is created.

Step 3  Use this web page to specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group ID</td>
<td>A Group ID value unique within all media group identifiers, including ASR group identifiers. This is a mandatory field.</td>
</tr>
<tr>
<td>Description</td>
<td>Description for the Cisco Media Termination Dialog group.</td>
</tr>
<tr>
<td>Number of Licensed IVR ports</td>
<td>Number of licensed IVR ports. Display only.</td>
</tr>
<tr>
<td>Maximum Number Of Channels</td>
<td>Maximum number of channels associated with this group. This is a mandatory field.</td>
</tr>
</tbody>
</table>

*Note*  You can specify any value for Maximum Number Of Channels, but restrictions are placed on the system when a call is made. This restriction is imposed by the number of licensed IVR ports on your system. This is a mandatory field.

Step 4  Click **Add** icon that displays in the tool bar in the upper left corner of the window or the **Add** button that displays at the bottom of the window. The CMT Dialog Group Configuration web page opens, displaying the new CMT dialog group.

You are now ready to provision MRCP ASR and MRCP TTS subsystems.

**Related Topics**

- Cisco Media Subsystem, on page 83
- Cisco Media Menu, on page 318

**ASR and TTS in Unified CCX**

Unified CCX supports ASR and TTS through two subsystems:
MRCP ASR

This subsystem allows users to navigate through a menu of options by speaking instead of pressing keys on a touch-tone telephone.

MRCP TTS

This subsystem converts plain text (UNICODE) into spoken words to provide a user with information, or prompt a user to respond to an action.

Note

Only G.711 codec is supported for ASR/TTS integrations.

Prepare to Provision ASR/TTS

It is the responsibility of the customer to perform the following tasks:

• Order ASR/TTS speech servers from Cisco-supported vendors.

Note

For more information on supported speech servers for Unified CCX, see the Cisco Unified CCX Software and Hardware Compatibility Guide for Active Releases available at http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX.

• Work with the ASR/TTS vendor to size the solutions.

• Provision, install, and configure the ASR/TTS vendor software on a different server (in the same LAN) and not where the Unified CCX runs. You can configure the speech software for Unified CCX in the same way as Unified CCX 7.0 (see http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX for detailed information).

• Before uploading a ASR/TTS script to Unified CCX Administration, validate the script against the capabilities and specifications supported by the ASR/TTS vendor.

Provision of MRCP ASR Subsystem

The MRCP ASR subsystem allows users to navigate through a menu of options by speaking instead of pressing keys on a touch-tone telephone. When a user calls local directory assistance, for example, ASR can prompt the user to say the city and state in which to locate the information, then connect the user to an appropriate operator.

To provision the MRCP ASR subsystem, define the following information:

• MRCP ASR Providers—Information about the vendor of your speech server, including the number of licenses and the grammar type.

• MRCP ASR Servers—Information about the ASR server’s name, port location, and available languages.

• MRCP ASR Groups—Information about the MRCP ASR dialog control groups and associated locales, which enable Unified CCX applications to use speech recognition.
Provision MRCP ASR Providers

Use the MRCP ASR Provider Configuration web page to specify information about the vendor of your speech server.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystem > MRCP ASR > MRCP ASR Providers. The MRCP ASR Provider Configuration web page opens, displaying the list of currently configured MRCP providers, licenses, and the corresponding status.

Step 2 Click Add New icon that displays in the tool bar in the upper left corner of the window or the Add New button that is displayed at the bottom of the window. The MRCP ASR Provider Configuration web page opens.

Step 3 Specify the following mandatory fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Provider Name</td>
<td>Enter the name of the MRCP ASR provider supported by Unified CCX.</td>
</tr>
<tr>
<td>Number of Provider Licenses</td>
<td>The number of ASR port licenses purchased from the ASR vendor.</td>
</tr>
<tr>
<td>Grammar Variant</td>
<td>Vendor-specific grammar setting. Valid options:</td>
</tr>
<tr>
<td></td>
<td>• Nuance Open Speech Recognizer servers version 9.0 and above (OSR 3.1.x)</td>
</tr>
<tr>
<td></td>
<td>• Nuance 8.5 and below version ASR servers (Nuance)</td>
</tr>
<tr>
<td></td>
<td>• IBM WVS ASR servers (2003 SISR)</td>
</tr>
</tbody>
</table>

Step 4 Click Add icon in the tool bar in the upper left corner of the window or the Add button that displays at the bottom of this window to apply changes.

Note After you update MRCP ASR/TTS Providers, Servers, and Groups, the corresponding provider needs to be refreshed for changes to take effect. The Unified CCX Engine does not need to be restarted. However, during a Refresh, Unified CM Telephony triggers using affected groups will fall back to the dialog group that is configured and the MRCP Provider being refreshed will go NOT_CONFIGURED until the reload is complete.

Your changes appear in the MRCP ASR Providers List page. You are now ready to provision MRCP ASR Servers.
If you delete an ASR/TTS provider and all of its associated servers and then create a new ASR/TTS provider, its status might become IN_SERVICE immediately, even before you create any servers for it. In this situation, click **Refresh** for that ASR/TTS provider, or click **Refresh All**. These actions change the status of the ASR/TTS provider to NOT_CONFIGURED.

### Related Topics
- [Provision MRCP ASR Servers](#), on page 87
- [Provision MRCP ASR Dialog Groups](#), on page 89

### Provision MRCP ASR Servers

Use the MRCP ASR Server Configuration web page to specify information about the speech server's name, port location, and available language.

**Note** You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Server.

### Procedure

**Step 1**
From the Unified CCX Administration menu bar, choose **Subsystem > MRCP ASR > MRCP ASR Servers**. The MRCP ASR Server Configuration web page opens, displaying a list of previously configured servers, if applicable with the following information:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer Name</td>
<td>Host name or IP address in which the ASR server software is installed.</td>
</tr>
<tr>
<td><strong>Note</strong> ASR server deployment over WAN is not supported in Unified CCX. The ASR server should be in the same LAN where Unified CCX is. You need to specify the ASR server host name or IP address that is local with the Unified CCX node while installing the ASR server software in this field.</td>
<td></td>
</tr>
<tr>
<td>Provider</td>
<td>The MRCP ASR Provider to which this server is associated.</td>
</tr>
<tr>
<td>Port</td>
<td>TCP port numbers used to connect to a MRCP server</td>
</tr>
<tr>
<td></td>
<td>• OSR 3.1x—4900</td>
</tr>
<tr>
<td></td>
<td>• 2003 SISR—554</td>
</tr>
<tr>
<td></td>
<td>• Nuance—554</td>
</tr>
</tbody>
</table>
Status or state of the subsystem.

**Step 2** Click **Add New** icon that is displayed in the tool bar in the upper, left corner of the window or the **Add New** button that is displayed at the bottom of the window to provision a new MRCP ASR Server. The MRCP ASR Server Configuration web page opens.

**Step 3** Use this web page to specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name</td>
<td>Host name or IP address of the server where the MRCP ASR server software is installed.</td>
</tr>
<tr>
<td>Provider Name</td>
<td>Select the name of the MRCP ASR Provider to which this server is associated from this drop-down list.</td>
</tr>
</tbody>
</table>
| Port Number | TCP port numbers that are used to connect to an MRCP server. Though the default value is shown as 4900, you need to provide any one of the following values in this field based on the TCP provider or grammar variant you have selected while configuring an MRCP ASR provider:  
  • OSR 3.1x—4900  
  • 2003 SISR—554  
  • Nuance—554 |
| Locales | Languages supported by the ASR Provider. Select a language (or multiple languages) from the drop-down list and click **Add Language**; the selected language appears in the Enabled Language list.  
  **Note** Use the check box to disable/enable a language. |

**Step 4** Click **Add** to apply changes. Your changes appear in the MRCP ASR Server list web page. You are now ready to provision MRCP ASR Groups.

**Related Topics**
- Provision MRCP ASR Providers, on page 86
- Provision MRCP ASR Dialog Groups, on page 89
Provision MRCP ASR Dialog Groups

Use the MRCP Groups Configuration web page to specify information about MRCP ASR dialog control groups, which enable Unified CCX applications to use speech recognition.

Note

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Group. Also, you should configure MRCP ASR Servers for the specific MRCP Provider before configuring the MRCP ASR Groups. This allows users to configure languages for the groups based on the languages supported by the configured servers.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Subsystem > MRCP ASR > MRCP ASR Dialog Groups.
The MRCP ASR Dialog Group Configuration web page opens to display a list of preconfigured entries, if applicable with the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group ID</td>
<td>Identifier for the group.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of this dialog group.</td>
</tr>
<tr>
<td>Provider</td>
<td>Name of the MRCP ASR provider.</td>
</tr>
<tr>
<td>Channels</td>
<td>Maximum number of sessions.</td>
</tr>
</tbody>
</table>

This web page also displays the Number of Licensed IVR Channels.

Step 2
Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New button that displays at the bottom of the window to provision a MRCP ASR Group.
The MRCP ASR Dialog Group Configuration web page opens.

Step 3
Use this web page to specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group ID</td>
<td>Associated group ID.</td>
</tr>
</tbody>
</table>
## Provision of MRCP ASR Subsystem

### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Description of this dialog group.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip</strong> Include languages that will be used by this Group to the description. Doing so will provide insight into the languages this Group uses when you set up the dialog group in the Unified CM Telephony trigger configuration. This also ensures that the locales used by the application configured in the Unified CM Telephony trigger match the locales supported by the MRCP ASR dialog group being selected.</td>
</tr>
<tr>
<td>Number Of Provider Licenses</td>
<td>Display only.</td>
</tr>
<tr>
<td>Number Of Licensed IVR Ports</td>
<td>Display only.</td>
</tr>
<tr>
<td>Maximum Number Of sessions</td>
<td>Maximum number of sessions associated with this dialog group.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> You can assign any value for Maximum Number Of Channels, but restrictions are placed on the system when a call is made. This restriction is imposed by the number of licensed IVR ports on your system.</td>
</tr>
<tr>
<td></td>
<td><strong>Caution</strong> Under heavy load, calls that utilize a channel from an MRCP ASR Dialog Control Group, might have a reduced call completion rate as the MRCP channels used by calls can take some additional time to clean up all the sessions set up with MRCP resources. To address this situation, you can over provision the value of this field by a factor of 1.2 or by an additional 20 percent. For example, if your application requires 100 MRCP ASR channels, modify the value in this field to be 120 MRCP ASR channels.</td>
</tr>
<tr>
<td>Provider Name</td>
<td>Select a MRCP Provider name from the drop-down list that contains a list of all previously defined provider names.</td>
</tr>
</tbody>
</table>
Select the languages that you wish to configure for this group from the list displayed. The displayed languages represent the locales configured for all MRCP ASR servers for the specified provider. If there are no MRCP ASR servers configured, no languages are displayed. In this case, you must update the group configuration once MRCP ASR servers have been configured for the specified provider.

**Step 4** Click Add to apply changes. Your changes appear in the MRCP ASR Groups list web page.

### Related Topics
- Provision MRCP ASR Providers, on page 86
- Provision MRCP ASR Servers, on page 87

### MRCP TTS Subsystem

The MRCP TTS subsystem converts plain text (UNICODE) into spoken words to provide a user with information, or prompt a user to respond to an action.

For example, a company might use TTS to read back a customer's name, address, and telephone number for verification before the company ships a requested product to the customer's location. Or a customer might dial into a pre-designated phone number, access a voice portal, and listen to the latest weather report or stock quotes. TTS can also convert email text to speech and play it back to the customer over telephone.

To provision the MRCP TTS subsystem, define the following information:

- **MRCP TTS Providers**—Information about the vendor of your TTS system.

  **Note**
  
  If you delete an ASR/TTS provider and all of its associated servers and then create a new ASR/TTS provider, its status might become IN_SERVICE immediately, even before you create any servers for it. In this situation, click Refresh for that ASR/TTS provider, or click Refresh All. These actions change the status of the ASR/TTS provider to NOT_CONFIGURED.

- **MRCP TTS Servers**—Information about the TTS server's name, port location, and available languages.
- **MRCP TTS Default Genders**—Information about the default gender setting for the Locales specified during TTS Server provisioning.
You will need at least one MRCP TTS Provider for each vendor requiring TTS server installation.

Related Topics
- Prepare to Provision ASR/TTS, on page 85
- Provision of MRCP ASR Subsystem, on page 85

Provision MRCP TTS Providers

Use the MRCP TTS Providers Configuration web page to specify information about the vendor of your TTS server.

Note
After you update MRCP ASR/TTS Providers, Servers, and Groups, the corresponding provider needs to be refreshed for changes to take effect. The Unified CCX Engine does not need to be restarted. However, during a Refresh, Unified CM Telephony triggers using affected groups will fall back to the dialog group that is configured and the MRCP Provider being refreshed will go NOT_CONFIGURED until the reload is complete.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose **Subsystems > MRCP TTS > MRCP TTS Provider**. The MRCP TTS Provider Configuration web page opens. If providers are already configured, this page lists the provider name and corresponding status.

Step 2
Click **Add New** icon that displays in the tool bar in the upper, left corner of the window or the **Add New** button that displays at the bottom of the window. Use this web page to specify the MRCP TTS Provider supported by Unified CCX. The MRCP TTS Provider Configuration web page reopens. The Provider Name drop-down list displays the existing MRCP TTS Providers. Choose the MRCP TTS Provider supported by Unified CCX from this list.

Note
Support for High Availability and remote servers is available only in multiple-server deployments.

Step 3
Click **Add** to apply changes. Your changes appear in the MRCP TTS Provider Configuration web page. You are now ready to provision MRCP TTS Servers.

Related Topics
- Configure Default TTS Provider for Unified CCX System, on page 93
- Provision MRCP TTS Servers, on page 93
- Provision MRCP TTS Default Genders, on page 95
Configure Default TTS Provider for Unified CCX System

Optionally, you can configure a default TTS provider. The Unified CCX Prompt Manager uses the default TTS provider for rendering TTS prompts if a TTS provider is not configured in the TTS Prompt. This usually happens in the case of VXML applications. For additional information on supported VXML tags for Unified CCX, see Scripting and Development Series: Volume 1, Getting Started with Scripts for Cisco Unified CCX and Cisco Unified IP IVR, Release 9.0(1).

To configure a default TTS provider, follow these steps.

**Procedure**

**Step 1** Choose **System > System Parameters**.

**Step 2** In the Default TTS Provider drop down list below Media Parameters section, select the provider you wish to be the system default. You must select only a preconfigured TTS provider as the Default TTS Provider.

**Note** If you are deploying an VXML applications and the only TTS functionality you need is to play pre-recorded .wav files, select the **Cisco LiteSSMLProcessor** option as the Default TTS Provider. This option allows you to execute SSML that has .wav file references in them.

**Step 3** Click **Update**.

**Related Topics**

Provision MRCP TTS Providers, on page 92

Provision MRCP TTS Servers

Use the MRCP TTS Servers Configuration web page to configure the TTS server's name, port location, and available languages.

You need at least one MRCP TTS Server associated with each configured provider.

**Note** You must have a MRCP TTS Provider defined before you can provision a MRCP TTS Server.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > MRCP TTS > MRCP TTS Server**. The MRCP TTS Server Configuration web page opens, displaying a list of previously configured servers, if applicable, with the following information:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Computer Name: Host name or IP address of the server in which the TTS server software is installed.

Note: TTS server deployment over WAN is not supported in Unified CCX. In other words, the TTS server should be in the same LAN where Unified CCX is. Thus, you need to specify the TTS server host name or IP address that is local with the Unified CCX node while installing the TTS server software in this field.

Port: TCP port numbers used to connect to a MRCP server:
- IBM WebSphere Voice Server
- Nuance Vocalizer 4.0
- Scansoft Realspeak 4.0

Provider: The MRCP TTS Provider to which this server is associated.

Status: Status or state of the subsystem.

Step 2: Click Add MRCP TTS Server icon that displays in the tool bar in the upper, left corner of the window or the Add New button that displays at the bottom of the window to provision a new MRCP ASR Server. The MRCP TTS Server Configuration web page opens.

Step 3: Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name</td>
<td>Host name or IP address of the server the MRCP TTS server software is installed.</td>
</tr>
<tr>
<td>Provider Name</td>
<td>Select the name of the MRCP TTS Provider to which this server is associated from this drop-down list.</td>
</tr>
<tr>
<td>Port Number</td>
<td>TCP port number used to connect to a MRCP TTS server. The port numbers are automatically displayed based on the provider or grammar variant that you have selected while configuring a MRCP TTS provider. Following are the different TCP Provider names along with their port numbers:</td>
</tr>
<tr>
<td></td>
<td>- IBM WebSphere Voice Server V5.1.3 - 554</td>
</tr>
<tr>
<td></td>
<td>- Nuance Vocalizer 4.0 - 554</td>
</tr>
<tr>
<td></td>
<td>- Scansoft Realspeak 4.0 - 4900</td>
</tr>
</tbody>
</table>
The TTS Provider supports multiple languages. Select a language (or multiple languages) from the drop-down list and click **Add Language**; the selected language appears in the Enabled Language list.

**Note** Use the check box to disable/enable a language.

**Step 4** Click **Add** to apply changes. Your changes appear in the MRCP TTS Server Configuration web page. You are now ready to provision MRCP TTS Default Genders.

**Note** Whenever a new language is added for a MRCP Server—and if this is the first instance of this language being added for the corresponding MRCP Provider—then the default gender for that locale and for the specified provider is set to Neutral. You should check the MRCP Locales page to review the default genders that are set automatically per locale per provider. Default genders are used when a prompt for a specific locale is used without specifying any gender.

**Related Topics**
- Provision MRCP TTS Providers, on page 92
- Provision MRCP TTS Default Genders, on page 95

### Provision MRCP TTS Default Genders

Use the MRCP TTS Default Genders Configuration web page to configure the default gender settings per Locale per Provider. TTS uses default genders when a prompt for a specific locale is used without specifying the gender.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > MRCP TTS > MRCP TTS Default Genders**. The MRCP TTS Default Gender Configuration web page opens, displaying the default genders currently configured for each locale for every MRCP TTS Provider that is currently configured.

**Step 2** Optionally, change the default gender setting for each locale for each provider.

**Note** The Locale radio button has the Male, Female, or Neutral options. By default, the “Default Gender” is set to “Neutral” unless configured explicitly.

**Step 3** Click **Update** to apply changes. The system updates the default gender setting for each Locale per Provider.

**Related Topics**
- Provision MRCP TTS Providers, on page 92
- Provision MRCP TTS Servers, on page 93
Provision of Unified CCX

To provision the Unified CCX subsystem, you must provision your telephony and media resources (see the Provision Telephony and Media Resources, on page 67).

**Attention**
Do not edit users, teams and permissions in Unified Intelligence Center. The Unified CCX to Unified Intelligence Center sync runs as part of daily purge and synchronizes these settings on Unified Intelligence Center according to Unified CCX settings.

The following topics introduce the Unified CCX subsystem and explain how to provision it in the Unified CCX system:

- RmCm Provider Configuration, page 97
- Resource Groups, page 99
- Skills Configuration, page 100
- Agent Configuration, page 102
- Contact Service Queue Configuration, page 107
- Remote Monitoring Use and Configuration, page 116
- Configure Agent-Based Routing, page 118
- Teams Configuration, page 119
- Unified Gateway Auto-configuration Details, page 122

**RmCm Provider Configuration**

The Unified CCX Resource Manager (RM) uses a Unified CM Telephony user (called the RmCm Provider) to monitor agent phones, control agent states, and route and queue calls. For information on adding Unified CM users, see section "Adding Users to a User Group" section in the *Cisco Unified Communications Manager Administration Guide* available here:

**RmCm Provider Modification**

- **Note**: This section only applies to Unified CCX deployments with Unified CM.

- **Caution**: While Unified CM supports Unicode characters in first and last names, those characters become corrupted in Unified CCX Administration web pages for RmCm configuration, real-time reporting, Cisco Agent/Supervisor Desktop.

The RmCm Provider web page is a read-only page that displays the latest configured information. To access this configuration area, choose **Subsystems > RmCm > RmCm Provider** from the Unified CCX Administration menu bar. The RmCm Provider web page opens, displaying the following read-only fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary RmCm Provider</td>
<td>The host name or IP address of the server, running CTI Manager (Unified CM that runs CTI Manager). The RmCm subsystem registers with the CTI Manager so that it can observe an agent's device when the agent logs in. When the CTI Manager fails, the RmCm subsystem registers with the second CTI Manager, if there is one configured.</td>
</tr>
<tr>
<td>Secondary RmCm Provider</td>
<td>The host name or IP address of the secondary RmCm Provider.</td>
</tr>
<tr>
<td>User ID</td>
<td>The RmCm user ID.</td>
</tr>
</tbody>
</table>

To modify the RmCm Provider, click **Modify RmCm Provider Information** icon in the toolbar in the upper, left corner of the window. The Cisco Unified CM Configuration web page opens.

**Related Topics**

- Modify RmCm Provider Information, on page 29

**Associating Agent Extensions with the RmCm Provider**

- **Note**: This section only applies to Unified CCX Deployments with Unified CM.

For every agent/resource created in Unified CM, make sure that the agent phone is also associated with the RmCm Provider. You do this from the Unified CM User Page for the RmCm Provider. In other words, even
though you create the RmCm User in Unified CCX Administration, you still need to use the Unified CM interface to associate the RmCm user with an agent phone. These phones are the same as those associated with each agent.

**Resource Groups**

Resource groups are collections of agents that your CSQ uses to handle incoming calls. To use resource group-based CSQs, you must specify a resource group.

**Create Resource Group**

To create a resource group, complete the following steps.

**Procedure**

- **Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Resource Groups**. The Resource Group web page opens with a list of configured resource groups (if any).
- **Step 2** Click **Add New** icon in the tool bar in the upper, left corner of the window or **Add New** button at the bottom of the window. The Resource Group Configuration area opens.
- **Step 3** In the Resource Group Name field, enter a resource group name. Enter a name that identifies the resource group to which you want to assign agents (for example, "Languages").
- **Step 4** Click **Add**. The Resource Groups page opens displaying the resource group name in the Resource Group Name column.

**Related Topics**

- **Modify Resource Group Name**, on page 99
- **Delete Resource Group**, on page 100

**Modify Resource Group Name**

To modify a resource group name, complete the following steps.

**Procedure**

- **Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Resource Groups**. The Resource Group web page opens.
- **Step 2** In the Resource Group Name column, click the resource group that you want to modify. The Resource Group Configuration area opens.
Step 3  Type the name of the resource group in the Resource Group Name text field.

Step 4  Click Update to apply the modifications.

The Resource Groups area opens, displaying the modified resource group name in the Resource Group Name column.

---

**Related Topics**

- Create Resource Group, on page 99
- Delete Resource Group, on page 100

---

**Delete Resource Group**

When you delete a resource group, the resource group is removed automatically if it is not associated with any agents and CSQs. If the resource group is associated with any agents or CSQs and if you click **Delete**, you will be directed to another web page, where you can see a list of the associated CSQs and agents, and you are prompted to confirm whether you want to delete the same.

**Tip**

To delete resource groups, you can use the following procedure or open a Resource Group and click the **Delete** icon or button in the Resource Group Configuration web page.

To delete a resource group, complete the following steps.

**Procedure**

**Step 1**  From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Resource Groups**.

The Resource Group web page opens.

**Step 2**  Click **Delete** icon next to the name of the Resource Group that you want to delete.

A dialog box opens, warning that the resource group is about to be permanently deleted.

**Step 3**  Click **Continue**.

The resource group is deleted.

---

**Related Topics**

- Create Resource Group, on page 99
- Modify Resource Group Name, on page 99

---

**Skills Configuration**

Skills are customer-definable labels assigned to agents. All the Unified CCX license packages can route incoming calls to agents who have the necessary skill or sets of skill to handle the call.
Create a Skill

To create a skill, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Skills**. The Skills web page opens to display the Skill Name (customer-definable label assigned to an agent), if configured.

Step 2 Click **Add New** icon in the tool bar in the upper, left corner of the window or **Add New** button at the bottom of the window.

**Note** When the system reaches the maximum number of skills that can be created, the **Add New** icon or button no longer appears.

The Skill Configuration web page opens.

Step 3 In the Skill Name field, enter a description of a relevant skill (for example, French).

Step 4 Click **Add**. The Skills web page opens, showing the skill in the Skill Name column and the total number of skills that exist in the system. You can add a maximum of 150 skills.

Related Topics

Modify a Skill Name, on page 101
Delete a Skill, on page 102

Modify a Skill Name

To modify a skill name, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Skills**. The Skills web page opens.

Step 2 In the Skill Name column, click the skill that you want to modify. The Skill Configuration web page opens.

Step 3 Modify the name of the skill in the Skill Name text field.

Step 4 Click **Update** to apply the modifications. The Skills Configuration summary opens, displaying the modified skill name in the Skill Name column.
Delete a Skill

When you delete a skill, the skill is removed automatically if it is not associated with any agents and CSQs. If the skill is associated with any agents or CSQs and if you click **Delete**, you are directed to another web page, where you can see a list of the associated CSQs and agents, and you are prompted to confirm whether you want to delete the same.

**Tip**

To delete a skill, you can use the following procedure or open a skill and click **Delete** icon or button in the Skills Configuration web page.

To delete a skill, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Skills**. The Skills web page opens.

**Step 2** Click the **Delete** icon next to the name of the skill that you want to delete. A dialog box opens, warning that the skill is about to be permanently deleted.

**Step 3** Click **Continue**. The skill is deleted.

**Agent Configuration**

Once the end users in Cisco Unified Communications are defined as agents, the list of agents and their associated Unified CCX devices are displayed in the **Subsystems > RmCm > Resources** page. These agents are also called resources. After you create a resource group, you can assign agents (resources) to that group.

If you have the Unified CCX Standard license package, you can add skills to agents once the skills have been created. You can also select the competence level of agents in assigned skills. Competence level indicates agent level of expertise in that skill.

---

1 Unified Communications users in a Unified CM deployment refers to a Unified CM user.
You can assign resource groups and skills to agents either individually or in bulk. The bulk option enables you to assign skills and resource groups to multiple agents at the same time.

Once you assign agents to resource groups and skills, you can create a CSQ.

---

**Warning**

After an agent is added, wait for 10 minutes for Unified CCX to automatically synchronize or force synchronization before the agent can sign in to Cisco Finesse.

The maximum allowed length of an agent's IPCC Extension is 15.

---

**Special Characters**

- Unified CM supports the use of special characters—square brackets ([ ]), dollar ($), ampersand (&), single quotes (''), colon (:), angle brackets (< >), forward slash (/), question mark (?), backward slash ( \ ), parentheses ( { } ), double quotes(" "), hash(#), percent (%), semicolon (;), comma (,), pipe ( | ), tilde (~) and space in a user ID when you configure end users. However, Unified CCX restricts the use of these characters when you configure end users as agents or supervisors.

- Unified CCX does not support the use of special characters—square brackets ([ ]), dollar ($), ampersand (&), single quotes (''), colon (:), angle brackets (< >), forward slash (/), question mark (?), backward slash ( \ ), parentheses ( { } ), double quotes(" "), hash(#), percent (%), semicolon (;), comma (,), pipe ( | ), tilde (~).

- With Cisco Finesse for Unified CCX, the password is restricted to the 7-bit printable ASCII characters (any of the 94 characters with the numeric values from 32 to 126). Control characters (for example, Tab) and international characters are not supported.

---

**Implications of Deleting Agents in Unified CM**

If you modify an agent's record in Unified CM (for example, changing the Unified CCX extension or deleting the agent), ensure to refresh the user page on Unified CCX Administration interface so that the agent information in the Unified CCX RmCm subsystem is updated. Choose **Subsystems > RmCm > Resources** option to update the Unified CCX information in the Unified CCX Administration any time. If you change the Unified CCX extension of an agent who is currently logged in, the agent will continue to use the old extension until the agent logs off. The agent must log off and then log back in to the Cisco Agent Desktop to get the new extension. When Unified CCX detects that the agent no longer exists in Unified CM, it automatically deletes that agent from the Unified CCX database.

---

**Caution**

Deleting Inactive Agents removes the agent details and records from the Historical Reporting Database, and HR reports will not display historical information of these agents.

If Unified CM connection errors have occurred, all agents will not be visible to Unified CCX. In this case, Unified CCX interprets these agents as deleted agents. As a result, the Inactive Agents list will not be accurate. When the errors are resolved, click **Inactive Agents** again to see an accurate list.

---

**Related Topics**

- Assign Resource Groups and Skills to One Agent, on page 104
- Assign Resource Groups and Skills to Multiple Agents, on page 105
Assign Resource Groups and Skills to One Agent

To assign a resource group and skills to an individual agent, complete the following steps.

Procedure

**Step 1**  
From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Resources**.  
The Resources web page opens.  

*Note* Only agents or supervisors who have assigned Unified CCX extensions are displayed in the list of resources in the Resources area.

**Step 2**  
Click the name of the agent in the Resource Name column.  
The Resource Configuration web page opens.

**Step 3**  
Specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Name of the agent (display only).</td>
</tr>
<tr>
<td>Resource ID</td>
<td>Unique identifying number of the agent (display only). This is the alpha-numeric user id assigned in the Unified CM End User Configuration page.</td>
</tr>
<tr>
<td>Unified CCX Extension</td>
<td>Unified CCX Extension assigned to the resource group (display only). This is the IP Phone extension assigned to the user from the Unified CM End User Configuration page as IPCC Extension.</td>
</tr>
<tr>
<td>Resource Group</td>
<td>A resource group with which to associate the agent (optional).</td>
</tr>
</tbody>
</table>
| Automatic Available    | Accept the default *(Enabled)* to automatically put the agent into the Available or Ready state after the agent finishes a call and disconnects.  
*Note* When a logged on agent in Ready, Not Ready, or Work state answers a call, the agent state is subject to the Automatic Available setting. |
| Assigned/Unassigned Skills | Select one or more skills from the Unassigned Skills list and click < to add the skills to the Assigned Skills List.  
Select one or more skills from the Assigned Skills List and click > to remove skills from the Unassigned Skills list.  
You can assign up to 50 skills to the agent. |
| Competence Level       | Select a skill from the Assigned Skills list and choose a number from the Competence Level drop-down menu  
Changes the competence level of an assigned skill (1 = Beginner, 10 = Expert).  
*Note* You can change the competency level one skill at a time, only. You cannot change skill competency level as a bulk procedure. |
| Team                   | A group of agents who assign the team to which the resource belongs.         |
**Assign Resource Groups and Skills to Multiple Agents**

To assign resource groups and skills to agents in bulk, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, select **Subsystems > RmCm > Assign Skills**.

- **Tip** Only agents or supervisors who have assigned Unified CCX extensions are displayed in the list of resources in the Resources area.

**Step 2** In the Resource Name column, check the check box beside each agent to whom you want to assign set of same resource group and skills. In the Resource Name column, check the check box next to each agent you want to assign set of same resource group and skills.

- **Note** You can check the Select All check box to select all agents.

The Skill summary web page shows the total number of skills created.

**Step 3** Click **Add Skill** icon that displays in the tool bar in the upper, left corner of the window or the **Add Skill** button that displays at the bottom of the window.

The Add Skill web page opens.

**Step 4** Specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Group</td>
<td>To assign a resource group to all the selected agents, choose a resource group from the Resource Group drop-down menu.</td>
</tr>
<tr>
<td>Skills to Add</td>
<td>Select one or more skills from the Skills list and click &lt; to add the skills to Skills to Add List.</td>
</tr>
<tr>
<td>Note</td>
<td>The Skills to Add list contains all skills, not just the skills that agents already have.</td>
</tr>
<tr>
<td>Skills</td>
<td>List of the available skills.</td>
</tr>
</tbody>
</table>
Step 5  Click **Update** to apply the changes. The Assign Skills area of the RmCm Configuration web page opens, and the agents are now assigned to the resource group and their skills (if skills were assigned).

### Related Topics
- Implications of Deleting Agents in Unified CM, on page 103
- Assign Resource Groups and Skills to One Agent, on page 104
- Remove Skills from Agents, on page 106

## Remove Skills from Agents

**Note**

If a resource is not assigned a skill that you attempt to remove, the resource is not updated. However, the system will still generate a related message.

To remove skills from agents, complete the following steps.

### Procedure

**Step 1**  From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Assign Skills**. The Assign Skill summary web page opens.

**Step 2**  In the Resource Name column, click the check box next to the agent you want to remove skills from.  

**Note**  You can click **Select All** check box to select all agents.

**Step 3**  Click **Remove Skill** icon that displays in the tool bar in the upper, left corner of the window or the **Remove Skill** button that displays at the bottom of the window. The Remove Skill Configuration web page opens.

**Step 4**  Remove skills by choosing one or more skills from the Skills list and clicking > to move the skills to the Skills to Remove list.

**Step 5**  Click **Update** to apply the changes. The Assign Skills area of the RmCm Configuration web page opens, and the agents are no longer assigned to the skills.
Contact Service Queue Configuration

The Contact Service Queue (CSQ) controls incoming calls by determining where an incoming call should be placed in the queue and to which agent the call is sent.

After you assign an agent to a resource group and assign skills, you need to configure the CSQs.

You assign agents to a CSQ by associating a resource group or by associating all skills of a particular CSQ. Agents in the selected resource group or who have all the selected skills are assigned to the CSQ.

Skills within the CSQ can be ordered. This means, when resources are selected, a comparison is done based on the competency level (highest for “most skilled” and lowest for “least skilled”) of the first skill in the list. If there is a “tie” the next skill within the order is used, and so on.

Skills within the CSQ can also be weighted. The weight value is an integer from 1 to 1000. Each competency level is multiplied by the skill’s associated weight, and a final comparison is done on the sum of all the weighted skill competencies (highest value for “most skilled” and lowest for “least skilled”). The maximum number of CSQs in the system depends on the type of server on which the engine is running.


Each agent can belong to up to 25 CSQs. To ensure that agents are not assigned to more than 25 CSQs, click Resources submenu option in the RmCm Configuration web page, and click Open Resources Summary Report icon. The report opens, listing each agent and the number of CSQs to which the agent belongs. If the agent belongs to more than 25 CSQs, modify the skills and resource groups to which the agent is assigned so that the agent does not belong to more than 25 CSQs.

Create a Contact Service Queue

To create a new CSQ and assign agents, complete the following steps.

Procedure

Step 1

From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Contact Service Queues. The Contact Service Queues web page opens.

Use this web page to view the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the resource or skill group.</td>
</tr>
</tbody>
</table>
Create a Contact Service Queue

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Queuing Criteria</td>
<td>Algorithm used to order the queued calls (contacts).</td>
</tr>
<tr>
<td>Resource Pool Selection Model</td>
<td>The resource selection criteria chosen for this CSQ.</td>
</tr>
<tr>
<td>Resource Pool</td>
<td>The skills or resource group used for this CSQ.</td>
</tr>
<tr>
<td>CSQ Type</td>
<td>The type of the CSQ.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected CSQ.</td>
</tr>
</tbody>
</table>

Step 2  Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New button that displays at the bottom of the window.

The Contact Service Queue Configuration web page opens.

Note  If this link does not appear on the page, it means that the system has reached the maximum number of CSQs that can be created. The CSQ Summary page displays the total number of created CSQs.

Step 3  Use the Contact Service Queue Configuration web page to specify the various fields. For more information on the fields, see Contact Service Queue Configuration Web Page, on page 110.

Step 4  Click Next.

The second Contact Service Queue Configuration area opens with the newly-assigned CSQ Name.

Step 5  Select an option from the Resource Selection Criteria drop-down menu.

Note  The Resource Selection Criteria field is displayed only if you have selected the CSQ type as Voice. This field is not configurable for an Email CSQ type.

Note  The Resource Pool Selection Model settings determine the options available in this drop-down menu.

• Longest Available—Selects the agent who has been in the Available state for the longest amount of time.

• Most Handled Contacts—Selects the agent who has handled the most calls.

• Shortest Average Handle Time—Selects the agent who generally spends the least amount of time talking to customers.

• Most Skilled—Used for expert agent call distribution. Selects the agent with the highest total competency level. The total competency level is determined by adding the agent’s competency levels for each of their assigned skills that are also assigned to the CSQ.

  * Example 1: If Agent1 is assigned Skill1(5), Skill2(6), and Skill3(7) and CSQ1 specifies Skill1(min=1) and Skill3(min=1), the total competency level for Agent1 for CSQ1 is 12.

  * Example 2: If Agent1 is assigned Skill1(5) and Skill2(6) and Skill3(7) and CSQ1 specifies Skill1(min=1), only, the total competency level for Agent1 for CSQ1 is 5.

• Least Skilled—Used for expert agent call distribution. Selects the agent with the lowest total competency level. The total competency level is determined by adding the agent’s competency level in each assigned skill.
Most Skilled by Weight—Used for expert agent call distribution. Selects the agent with the highest total competency level multiplied by the skill’s associated weight.

Least Skilled by Weight—Used for expert agent call distribution. Selects the agent with the lowest total competency level multiplied by the skill’s associated weight.

Most Skilled by Order—Used for expert agent call distribution. Selects the agent with the highest total competency level in the ordered list.

Least Skilled by Order—Used for expert agent call distribution. Selects the agent with the lowest total competency level in the ordered list.

Note If two or more agents have equal competency level, the selection automatically defaults to Longest Available selection criteria.

Step 6 Specify the following settings, as necessary:

The Resource Pool Selection Model setting determines the availability of these options.

a) Use the Select Skills list to highlight the skills you want; click the Add button next to the list.
b) Specify a Minimum Competence Level for the skills assigned to the CSQ. Depending on the Resource pool criteria you chose, specify a Weight value between 1 and 1000.
c) If the Resource Selection Criteria is Most Skilled by Order or Least Skilled by Order, use the arrow icons to order the skills by moving them up or down in the list.

Note Use the Delete icon next to a skill to delete that skill from the Skills Required list.

Step 7 If you selected one of the Least/Most Skilled options as shown in the list below for the Resource Selection Criteria, you can view the agent order using Show Resources icon or button.

The order of the agents determines the priority, with the agent at the top of the list having the highest priority.

To change the order of the agents belonging to the CSQ, you should modify the skill set of the agents. The Least/Most Skilled Resource Selection Criteria option comprises the following:

a) Most Skilled
b) Least Skilled
c) Most Skilled by Order
d) Least Skilled by Order
e) Most Skilled by Weight
f) Least Skilled by Weight

Step 8 If you selected Resource Groups as the Resource Pool Selection Model on the previous page, follow these steps:

a) Select an option from the Resource Selection Criteria drop-down menu.

• Longest Available—Selects the agent who has been in the Available state for the longest amount of time.

• Linear—Selects the next available agent with the highest priority, as determined by the agent order in the Resources list.

• Circular—Selects the next available agent with the highest priority, based on the last agent selected and the agent order in the Resources list.

• Most Handled Contacts—Selects the agent who has handled the most calls.
Create a Contact Service Queue

• **Shortest Average Handle Time**—Selects the agent who generally spends the least amount of time talking to customers.

b) Choose the resource group for this CSQ from the Resource Group drop-down menu.
c) Click **Show Resources** icon to show all agents who meet the specified criteria.
d) If you selected *Linear* or *Circular* as the Resource Selection Criteria, if necessary, rearrange the order of agents in the Resources list by highlighting an agent and using the up and down arrows to move the agent in the list.
e) Click **Add** to apply changes and update the system.

The new CSQ is now displayed, and all agents who belong to the resource group or all selected skill groups are now a part of this CSQ.

---

**Related Topics**

- [Contact Service Queue Configuration](#), on page 107
- [Modify a Contact Service Queue](#), on page 112
- [Delete a Contact Service Queue](#), on page 112
- [Resource Pool Selection Criteria: Skills and Groups](#), on page 113
- [Resource Skill Selection Criteria within a Contact Service Queue](#), on page 114

---

**Contact Service Queue Configuration Web Page**

Contact Service Queue Configuration web page:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Service Queue Name</td>
<td>Enter a meaningful name that is concise, yet easy to recognize (for example, Language Experts). This is a mandatory field.</td>
</tr>
<tr>
<td>Contact Service Queue Type</td>
<td>Select one of the following options from this drop-down menu:</td>
</tr>
<tr>
<td></td>
<td>• Voice (default)—Agents in this CSQ can handle inbound and outbound voice calls.</td>
</tr>
<tr>
<td></td>
<td>• Email—Agents in this CSQ can handle inbound email.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If you select <em>Email</em> CSQ type, you can configure only the Resource Pool Selection Model field. All other fields are not configurable.</td>
</tr>
<tr>
<td>Contact Queuing Criteria</td>
<td>Display only. Displays the criteria used for queuing the contacts. For example, First In, First Out (FIFO).</td>
</tr>
</tbody>
</table>

---

Provision of Unified CCX
### Field

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatic Work</strong></td>
<td>Determines whether agents handling calls that are routed through this CSQ automatically enter the Work state when a call ends. This field is mandatory. Options are:</td>
</tr>
<tr>
<td></td>
<td>• Enabled—Agents belonging to a CSQ that has the Automatic Work option enabled enter the Work state automatically when a call that is allocated from this CSQ ends. If agents belonging to a CSQ that has the Automatic Work option disabled handle transferred calls that were originally delivered by a CSQ that has Automatic Work enabled, they also enter the Work state automatically when a call ends.</td>
</tr>
<tr>
<td></td>
<td>• Disabled (default)—Agents enter Ready or Not Ready state when a call ends, depending on the Automatic Available setting.</td>
</tr>
<tr>
<td><strong>Wrapup Time</strong></td>
<td>Determines the length of the Work state for this CSQ when a call ends. Options are:</td>
</tr>
<tr>
<td></td>
<td>• Enabled button with Seconds field—The Seconds field specifies the length of the Work state phase.</td>
</tr>
<tr>
<td></td>
<td>• Disabled—No limit on how long the agent can stay in the Work state.</td>
</tr>
<tr>
<td><strong>Resource Pool Selection Model</strong></td>
<td>Select one of the following options from the drop-down menu:</td>
</tr>
<tr>
<td></td>
<td>• Resource Skills—To create a skills-based CSQ.</td>
</tr>
<tr>
<td></td>
<td>• Resource Group—To create a resource group-based CSQ.</td>
</tr>
<tr>
<td></td>
<td>This is a mandatory field.</td>
</tr>
<tr>
<td><strong>Service Level</strong></td>
<td>The target maximum number of seconds a call is queued before it is connected to an agent. This is a mandatory field.</td>
</tr>
<tr>
<td><strong>Service Level Percentage</strong></td>
<td>The target goal for percentage of contacts that meet the service level. This is a mandatory field.</td>
</tr>
<tr>
<td></td>
<td>For example, a call center that has a service level of 20 and a service level percentage of 80 percent has a goal of answering 80 percent of its calls within 20 seconds.</td>
</tr>
<tr>
<td><strong>Prompt</strong></td>
<td>.wav prompt file to associate with the CSQ. You can retrieve the prompt file that you select from this Prompt drop-down list using the Create CSQ Prompt Step in the Unified CCX Editor.</td>
</tr>
<tr>
<td></td>
<td>In the Unified CCX Editor, Create CSQ Prompt Step is one of the steps used to create scripts for the Unified CCX engine. In this step, you need to give the CSQ ID that is displayed as the last number in the AppAdmin address bar of the web page that is displayed when you click on an existing CSQ. For example, the CSQ ID will be 3 if the address bar of an existing CSQ Configuration web page ends with &quot;&amp;csdid=3&quot;. When the script executes, it will return the prompt associated with the specific CSQ ID. Use the Play Prompt Step within the script to play this prompt.</td>
</tr>
<tr>
<td></td>
<td>See the Cisco Unified CCX Editor Step Reference Guide for detailed information on scripting.</td>
</tr>
</tbody>
</table>
Modify a Contact Service Queue

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Contact Service Queues. The Contact Service Queues web page opens.

**Step 2**
In the Name list, click the CSQ that you want to modify. The Contact Service Queue Configuration page opens.

**Step 3**
Modify the Contact Service Queue Configuration information as necessary.

*Note*
If you change an existing CSQ name, the old name still exists in the HR reports and the CSQ is not removed even if all the data is purged.

*Note*
Click Next icon that displays in the tool bar in the upper, left corner of the window or the Next button that displays at the bottom of the window to view and update the remaining fields.

**Step 4**
Click Update icon in the top of the window or the Update button that displays at the bottom of the window to apply the modifications.

Delete a Contact Service Queue

When you delete a CSQ, any skills or resource groups assigned to that CSQ are automatically removed from the CSQ, and any application using that CSQ can no longer access it. Before deleting the CSQ, change the applications to use a different CSQ. If the application is using a CSQ when the CSQ is deleted, new incoming calls will get an error and existing queued calls will not be routed to agents.

To delete a CSQ, complete the following steps.
Procedure

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Contact Service Queues**. The Contact Service Queues web page opens.

**Step 2** Click the **Delete** icon next to the name of the CSQ that you want to delete.

**Note** You can also delete a CSQ from its Contact Service Queue Configuration page using the Delete icon or button.

**Related Topics**
- Create a Contact Service Queue, on page 107
- Modify a Contact Service Queue, on page 112
- Resource Pool Selection Criteria: Skills and Groups, on page 113
- Resource Skill Selection Criteria within a Contact Service Queue, on page 114

**Resource Pool Selection Criteria: Skills and Groups**

The resource selection criteria available for CSQs with Resource *Skills* is different from that of CSQs with Resource *Groups*.

Example—In a banking application with two skills (Banking and CreditCard) and one Resource Group (General Queries), assume that the following agents, skills, and resource groups are defined:

<table>
<thead>
<tr>
<th>Agent ID</th>
<th>Assigned Skills</th>
<th>Resource Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent1</td>
<td>Banking (Competence Level 10) &lt;br&gt; CreditCard (Competence Level 6)</td>
<td>GeneralQueries</td>
</tr>
<tr>
<td>Agent2</td>
<td>Banking (Competence Level 5) &lt;br&gt; CreditCard (Competence Level 10)</td>
<td>GeneralQueries</td>
</tr>
<tr>
<td>Agent3</td>
<td>None</td>
<td>GeneralQueries</td>
</tr>
</tbody>
</table>

In addition, suppose you had the following Contact Service Queue information defined:

**Table 1: Agent Skill and Resource Group Settings**

<table>
<thead>
<tr>
<th>CSQ Name</th>
<th>Resource Pool Selection Model</th>
<th>Resource Selection Criteria</th>
<th>Skill/Competence</th>
<th>Available Agents</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSQ1</td>
<td>Resource Skills</td>
<td>Most Skilled</td>
<td>BankingMinimum competency: 5</td>
<td>Agent1 &lt;br&gt; Agent2</td>
</tr>
<tr>
<td>CSQ Name</td>
<td>Resource Pool Selection Model</td>
<td>Resource Selection Criteria</td>
<td>Skill/Competence</td>
<td>Available Agents</td>
</tr>
<tr>
<td>----------</td>
<td>------------------------------</td>
<td>----------------------------</td>
<td>------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>CSQ2</td>
<td>Resource Skills</td>
<td>Most Skilled</td>
<td>CreditCardMinimum competency: 5</td>
<td>Agent1, Agent2</td>
</tr>
<tr>
<td>CSQ3</td>
<td>Resource Group</td>
<td>Longest Available</td>
<td>GeneralQueries</td>
<td>Agent1, Agent2, Agent3</td>
</tr>
</tbody>
</table>

In this scenario, if a caller calls with a question about CreditCard information and there are no CSQs currently available with CreditCard skills (that is, Agent1 and Agent2), there is a possibility for Agent3—who has no CreditCard skill—to get selected as the Longest Available Agent.

To avoid such a situation, you could design the script to always look into CSQ2 for available agents since it has the highest competency of 10 for CreditCard, and agent selection here is based on most skilled.

Note

If two or more agents have equal competency level, the selection automatically defaults to Longest Available selection criteria.

Related Topics

- Create a Contact Service Queue, on page 107
- Modify a Contact Service Queue, on page 112
- Delete a Contact Service Queue, on page 112
- Resource Skill Selection Criteria within a Contact Service Queue, on page 114

Resource Skill Selection Criteria within a Contact Service Queue

Resource selection within a CSQ is based on the resource competency levels of the skills associated to the CSQ. You can choose between the most and least skilled.

The Unified CCX system defines a Level 10 competency to be the highest skill level, while a Level 1 denotes the lowest skill level. When more than one skill is involved, each skill is given the same weight, meaning no preference is given to any skill. A comparison is performed on the sum of all the competency levels for the associated skills. (Skills assigned to resources but not associated to the CSQ are ignored.) In the case of a tie when skill competencies are equal, the resource that has been ready for the longest amount of time will be chosen.

The following table provides examples of how Unified CCX selects resources within a CSQ.
### Table 2: Resource Skill Selection Criteria

<table>
<thead>
<tr>
<th>Example</th>
<th>CSQ Skills</th>
<th>Agent Competency Levels</th>
<th>Sequence Agents Become Ready</th>
<th>Selection Order</th>
</tr>
</thead>
</table>
| Most skilled resource selection model | Technical Support | Agent A = 10  
Agent B = 10  
Agent C = 5 | A, B C  
C, A, B  
A, C, B  
C, B, A | A, B, C  
A, B, C  
A, B, C  
B, A, C |
| Least skilled resource selection model | Technical Support | Agent A = 10  
Agent B = 10  
Agent C = 5 | A, B C  
C, A, B  
A, C, B  
C, B, A | C, A, B  
C, A, B  
C, A, B  
C, B, A |

**Note** The ordering in the two examples above are not opposite because the selection criteria has changed from most to least skilled—when competency levels are equal, both selection models choose the resources that have been available for the longest time.

<table>
<thead>
<tr>
<th>Example</th>
<th>CSQ Skills</th>
<th>Agent Competency Levels</th>
<th>Sequence Agents Become Ready</th>
<th>Selection Order</th>
</tr>
</thead>
</table>
| Most skilled resource selection model | SalesSupport | Agent A = Sales (10)  
Support (5)  
Agent B = Sales (5), Support (10)  
Agent C = Sales (5)  
Support (1) | A, B C  
C, A, B  
A, C, B  
C, B, A | A, B, C  
A, B, C  
A, B, C  
B, A, C |
| Least skilled resource selection model | SalesSupport | Agent A = Sales (10)  
Support (5)  
Agent B = Sales (5), Support (10)  
Agent C = Sales (5)  
Support (1) | A, B C  
C, A, B  
A, C, B  
C, B, A | C, A, B  
C, A, B  
C, A, B  
C, B, A |

**Related Topics**
- Create a Contact Service Queue, on page 107
- Modify a Contact Service Queue, on page 112
- Delete a Contact Service Queue, on page 112
- Resource Pool Selection Criteria: Skills and Groups, on page 113
Remote Monitoring Use and Configuration

The Unified CCX Remote Monitoring feature allows a supervisor to call into any site where the supervisor has a Unified CM user profile and monitor agent conversations.

Note
The incoming and outgoing streams to and from the agent phone and the outgoing stream to the supervisor phone must have the same encoding, with only G.711 being supported.

When you, as a supervisor, monitor a conversation, you can hear all parties on the call. The parties will have no indication that you are monitoring the call. You cannot join the call or be heard by the parties. This is referred to as silent monitoring.

With Remote Monitoring, you can choose to monitor a call in either of these ways:

• By resource (agent)—In this case, you identify the resource by agent extension. If the agent is on a call, monitoring will begin immediately. If the agent is not on a call, monitoring will begin when the agent is presented with a call (that is, when the phone rings) or when the agent initiates a call (that is, when the phone goes off-hook).

• By CSQ—In this case, you will monitor the call of an agent who belongs to the CSQ. When you monitor by CSQ, you select the CSQ from a menu. When a call is presented to an agent who belongs to the selected CSQ, monitoring will begin for that agent and call.

Note
For CSQ monitoring, the supervisor cannot start monitoring the call after it connects to the agent; the call must arrive at the agent after supervision begins. For agent monitoring, supervision can begin after the call connects to the agent.

Related Topics
Create Remote Monitoring Supervisor, on page 116
Assign Resources and Contact Service Queues to a Supervisor, on page 117
Configure Remote Monitoring Application, on page 52
View CSQ IDs for Remote Monitoring, on page 267

Create Remote Monitoring Supervisor

Use the User Management web page to assign supervisor privileges to a user.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Tools > User Management > Supervisor Capability View.
The User Configuration web page opens, displaying the list in two panes. The left pane displays the list of existing Unified CCX Supervisors and the right pane displays the list of Available Users.
Step 2 Change the users as required using the arrow in either direction. Your changes are dynamically displayed in this page and are effective immediately.

Step 3 Repeat this process as needed to assign the Supervisor capability for more than one user. Click Back to User List icon that displays in the tool bar in the upper, left corner of the window or the Back to User List button that displays at the bottom of the window to view the list of existing users.

Related Topics
- Remote Monitoring Use and Configuration, on page 116
- Assign Resources and Contact Service Queues to a Supervisor, on page 117
- Configure Remote Monitoring Application, on page 52
- View CSQ IDs for Remote Monitoring, on page 267

Assign Resources and Contact Service Queues to a Supervisor

Use the Remote Monitor Configuration web page to assign a supervisor a list of resources and CSQs they are allowed to monitor.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Remote Monitor. The Remote Monitor web page opens to display the Supervisor, Name, and User ID of Unified CM users who are Unified CCX supervisors (if configured).

Note The Remote Monitor submenu option is available only if you are using the Unified CCX Premium license package.

Step 2 Click a User ID value.

Note This is a Unified CM user configured as a Unified CCX supervisor (see Create Remote Monitoring Supervisor, on page 116).

The Remote Monitor Configuration web page opens.

Step 3 Use this web page to specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Service</td>
<td>(Check box.) CSQ Names the supervisor can monitor.</td>
</tr>
<tr>
<td>Queues Name</td>
<td></td>
</tr>
<tr>
<td>Resources</td>
<td>(Check box.) User IDs of agents the supervisor can monitor.</td>
</tr>
</tbody>
</table>

Step 4 Click Update to apply the changes.

The Remote Monitor area of the RmCm Configuration web page reappears.

The Supervisor can now access the Unified CCX Supervisor web page and view the allowed CSQs and agents.

Tip When running the Remote Monitoring script, you might need to provide a CSQ ID. This ID is internally generated and is only visible on the Unified CCX Supervisor page.
Configure Agent-Based Routing

Agent-based routing provides the ability to send a call to a specific agent, rather than any agent available in a CSQ.

Use the Agent Based Routing Settings web page to configure system-wide parameters to be used in an agent-based routing application.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Agent Based Routing Settings. The Agent Based Routing Settings area opens.

Note The Agent Based Routing Settings are available only if you are using Unified CCX Enhanced or Premium license packages.

Step 2 Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic Work</td>
<td>Determines whether agents handling calls that are routed through this CSQ automatically enter the Work state when a call ends.</td>
</tr>
<tr>
<td></td>
<td>• Enabled—Agents belonging to a CSQ that has the Automatic Work option enabled enter the Work state automatically when a call that is allocated from this CSQ ends. If agents belonging to a CSQ that has the Automatic Work option disabled handle transferred calls that were originally delivered by a CSQ that has Automatic Work enabled, they also enter the Work state automatically when a call ends.</td>
</tr>
<tr>
<td></td>
<td>• Disabled (default)—Agents enter Ready or Not Ready state when a call ends, depending on the Automatic Available setting.</td>
</tr>
<tr>
<td>Wrapup Time</td>
<td>Determines if agents automatically enter Wrapup when a call ends.</td>
</tr>
<tr>
<td></td>
<td>• Enabled button with seconds field—Controls how long the agent can stay in the Work state if Automatic work is enabled. The seconds field specifies the Wrapup time length.</td>
</tr>
<tr>
<td></td>
<td>• Disabled (default)—No limit of how long the agent can stay in the Work state if Automatic Work is enabled.</td>
</tr>
</tbody>
</table>
Step 3  Click Save icon that displays in the tool bar in the upper, left corner of the window or the Save button that displays at the bottom of the window to apply changes.

Wrap-Up Data Usage

Contact centers use wrap-up data to track the frequency of activities or to identify the account to which a call is charged, and other similar situations. Like reason codes, wrap-up data descriptions are set up by your system administrator to reflect the needs of your contact center. By default this feature is disabled.

If the wrap-up data feature is enabled in Cisco Desktop Administration, the agent will see a pop-up window when he moves to Work state, in which he can select the appropriate description that sums up the call outcome. See the Cisco Desktop Administrator User Guide for more information.

Teams Configuration

A team is a group of agents who report to the same supervisor. A team can have one primary supervisor and optional secondary supervisors. A supervisor can also monitor CSQs that are assigned to the team being supervised.

Barge-in is when a supervisor joins an existing call between an agent and a customer.

Intercept is when the supervisor joins a call and drops the agent from the call.

A default team is automatically created by the system and cannot be deleted. If agents are not assigned to any team, they belong to the default team. When an agent is assigned to a team, the team supervisor can barge-in and intercept any call being handled by the agent.

Note  Before creating a team, you must set up supervisors using the User Management page.

Note  A team that accesses Live Data reports should be limited to 20 agents.

Assign Supervisor Privilege to a User

Perform the following procedure to assign supervisor privilege to a user.

Procedure

Step 1  From the Unified CCX Administration menu, choose Tools > User Management > User View. The User Configuration page displays the list of all users.

Step 2  Click the user to whom you want to assign supervisor capability.
The User Configuration page displays information about that user. In the Capabilities section, the left pane displays the list of assigned capabilities and the right pane displays the list of capabilities.

**Step 3** Using the left arrow, assign Supervisor capability.

**Step 4** Click Update to save your changes.

**Related Topics**
- Create Team Supervisor, on page 120
- Create Teams, on page 120

---

**Create Team Supervisor**

Perform the following procedure to create team supervisor:

**Procedure**

**Step 1** From the Unified CCX Administration menu, choose Subsystems > RmCm > Teams. The Team page displays the list of all teams.

**Step 2** Click the team for which you want to create a supervisor. The Team Configuration page displays the configuration information about the team.

**Step 3** From the Primary Supervisor drop-down list, select the primary supervisor for the team.

**Step 4** (Optional) If you want to assign a secondary supervisor, select the supervisor from the Available Supervisors pane and then click the left arrow.

**Step 5** Click Save.

**Related Topics**
- Create Teams, on page 120
- Modify Agents on Teams, on page 121
- Delete a Team, on page 121

---

**Create Teams**

Use the Teams area of the RmCm Configuration web page to create or associate teams with various agents, CSQs, and supervisors.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose Subsystems > RmCm > Teams.

**Step 2** Click Add New icon that displays in the tool bar in the upper, left corner of the window or the Add New button that displays at the bottom of the window.
The Team Configuration page appears.

**Step 3** Click **Add** to apply changes.

**Related Topics**
- Create Team Supervisor, on page 120
- Modify Agents on Teams, on page 121
- Delete a Team, on page 121

## Modify Agents on Teams

Use the Teams area to add agents or change agents on an existing Team.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Teams**. The Teams web page opens.

**Step 2** Click a name in the **Team Name** column
The Team Configuration page appears.

**Step 3** Select an agent name in the **Resources Assigned to other Teams** list and use the arrow icon to move it into the **Assigned Resources** list if you want to add an agent to this team.
To remove an agent from this team, select an agent name in the **Assigned Resources** list and use the arrow icon to move it into the **Resources Assigned to other Teams** list. This agent now belongs to the default team.

**Step 4** Click **Update** to apply changes.

**Related Topics**
- Create Team Supervisor, on page 120
- Create Teams, on page 120
- Delete a Team, on page 121

## Delete a Team

Use the Teams area of the RmCm Configuration web page to delete an existing Team.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > RmCm > Teams**. The Teams web page opens.

**Step 2** Click the **Delete** icon beside the Team Name icon you want to delete.
The system prompts you to confirm the delete.

**Step 3**  
Click **OK**.

**Related Topics**

- Create Team Supervisor, on page 120
- Create Teams, on page 120
- Modify Agents on Teams, on page 121

---

### Unified Gateway Auto-configuration Details

Unified CCX supports ACD integration with the Cisco Unified Intelligent Contact Management Enterprise (Unified ICME) solution by way of the Cisco Unified Gateway. The Unified Gateway is a Peripheral Gateway (PG) which is configured on the Unified ICME software. The Unified Gateway is no longer coresident on the Unified CCX server as opposed to the earlier versions of Unified CCX. The CTI protocol supports integration of Unified Gateway with Unified ICME. The *Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX* provides an overview of the Unified Gateway feature, lists the supported deployment options, provides comparative information, and includes information on configuring and integrating the Unified Gateway.

Some of the configurations performed on the Unified CCX using the appropriate web page in Unified CCX Administration will be automatically configured on Unified ICME via the Unified Gateway. The following table provides a list of these configurations, the equivalent term used on Unified ICME for these configurations, and the Configuration Manager tool that can be used on the Unified ICME Admin Workstation to view these configurations.

<table>
<thead>
<tr>
<th>Unified CCX Term</th>
<th>Unified ICME Term</th>
<th>Unified ICME Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>Service</td>
<td>Service Explorer</td>
</tr>
<tr>
<td>Route Point (Trigger)</td>
<td>Routing Device</td>
<td>Peripheral Monitor Table</td>
</tr>
<tr>
<td>CSQ</td>
<td>Skill Group</td>
<td>Skill Group Explorer</td>
</tr>
<tr>
<td>Resource</td>
<td>Agent</td>
<td>Agent Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong> The agent extension goes to the Peripheral Monitor Table.</td>
</tr>
</tbody>
</table>

**Note** These configurations and their attributes cannot be changed on Unified ICME if auto-configuration is enabled on Unified ICME.
CHAPTER 8

Provision of Additional Subsystems

To provision additional subsystems, you must complete the following tasks:

- Log into the Unified CCX Administration.
- Provision your telephony and media resources.
- Provision your Unified CCX subsystem, if required.

The following sections introduce the additional Unified CCX subsystems and explain how to provision them.

- About Additional Subsystems, page 123
- Provision of Unified ICME Subsystem, page 124
- Provision of HTTP Subsystem, page 129
- Provision of Database Subsystem, page 131
- Provision eMail Subsystem, page 134

About Additional Subsystems

Your Unified CCX system may include some or all of the following additional subsystems:

- The Unified ICME subsystem—The Unified CCX system uses the Cisco Unified Intelligent Contact Management Enterprise (Unified ICME) subsystem to communicate with Unified ICME to manage call distribution across sites and call-processing environments.

Note

If you are using Unified CCX with the Cisco Contact Center Gateway solution, please see the Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX. The instructions for configuring Unified CCX with that solution differs from what is described in this guide. The Unified Gateway provides for the integration of the Unified ICME system with Unified CCX by way of the Unified Gateway. The Unified Gateway is a Peripheral Gateway (PG) which you configure on the Unified ICME software.
• The HTTP subsystem—The Unified CCX system uses the HTTP subsystem to enable Unified CCX applications to respond to requests from a variety of web clients, including computers and IP phones.

• The Database subsystem—The Unified CCX system uses the Database subsystem to enable Unified CCX applications to interact with customer-provided enterprise database servers to make database information accessible to contacts.

• The eMail subsystem—The Unified CCX system uses the eMail subsystem to communicate with your email server and enable your applications to create and send email.

If you plan to run applications that use any of the additional Unified CCX subsystems included in your Unified CCX package, you should now provision those subsystems. The Unified CCX system uses these additional subsystems to communicate with supporting systems such as Unified ICME, web servers, database servers, and email servers.

Note: You need to provision a particular subsystem only if you are using Unified CCX applications that require it.

Related Topics
  Provision of Unified ICME Subsystem, on page 124
  Provision of HTTP Subsystem, on page 129
  Provision of Database Subsystem, on page 131
  Provision eMail Subsystem, on page 134

Provision of Unified ICME Subsystem

Note: The Unified ICME subsystem is available if your system has a license installed for Unified IP IVR.

The Unified CCX system uses the Unified ICME subsystem to communicate with Unified ICME to manage call distribution across sites and call-processing environments.

The Unified CCX server is frequently used as part of a Unified ICME solution with Unified ICME. In this type of installation, the Unified ICME uses the Unified CCX server to queue calls and perform other functions such as collecting caller-entered digits, performing database lookups, and playing back prompts.

Note: If you are not using Unified ICME, you do not need to provision the Unified ICME subsystem.

Unified ICME scripts can direct calls based on various criteria such as the time of day or the availability of subsystems. The Unified ICME uses four different commands to interact with the Unified CCX system:

• Connect—Connects the call. Unified ICME sends the connect message with a label to instruct the Unified CCX system where to direct the call.

• Release—Hangs up the call.
• **Run VRU Script**—Runs a Unified ICME Voice Response Unit (VRU) script on the Unified CCX system.

• **Cancel**—Cancels the Unified ICME VRU script that is currently running.

**Related Topics**

- About Additional Subsystems, on page 123
- Provision of HTTP Subsystem, on page 129
- Provision of Database Subsystem, on page 131
- Provision eMail Subsystem, on page 134
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50

**Configure General Unified ICME Information**

General Unified ICME information includes the TCP/IP socket number for receiving messages from the Unified ICME system and the expanded call context variables you want to use to pass call-related information. To configure general Unified ICME information, complete the following steps.

**Procedure**

**Step 1**  
From the Unified CCX Administration menu bar, choose **Subsystems > ICM > General**. The ICME Configuration web page opens. For information on the web page fields, see **ICME Configuration Web Page, on page 125**

**Step 2**  
Specify the fields.

**Step 3**  
Click **Update**.  
The configuration information is added to the system.  
You are now ready to configure the Unified ICME VRU Scripts area of the Unified ICME Configuration web page.

**Related Topics**

- ICME Configuration Web Page, on page 125
- Configure Unified ICME VRU Scripts, on page 127
- About Additional Subsystems, on page 123

**ICME Configuration Web Page**

The following table describes the fields for the ICME Configuration web page.
### Configure General Unified ICME Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRU Connection Port</td>
<td>The same number configured in the VRU Peripheral Interface Manager (PIM) on the Unified ICME system. The default value in the Unified ICME setup is 5000. This is a mandatory field.</td>
</tr>
<tr>
<td></td>
<td>The system uses this TCP/IP socket number to receive messages from the Unified ICME system. You can copy the VRU Connection Port value from the VRU PIM configuration dialog box of the VRU PG machine.</td>
</tr>
<tr>
<td>PG Hosts Allow</td>
<td>By default, any PG will be able to connect in the Unified ICME setup. For security reasons, you can configure selected PGs, which you want to connect to the Unified IP IVR system using any one of the following three options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>All</strong> – Click the All radio button if you want any PG to be able to connect to the Unified IP IVR. This radio button will be selected by default in the Unified ICME setup.</td>
</tr>
<tr>
<td></td>
<td>• <strong>None</strong> - Click the None radio button if you do not want even a single PG to connect to the Unified IP IVR.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Specific</strong> – Click the Specific radio button if you want to connect only specific PGs to the Unified IP IVR. Once you select this option, you will be able to enter the Host name or IP address for one or both the PGs using the following fields:</td>
</tr>
<tr>
<td></td>
<td>• <strong>PG 1 Hostname/IP Address</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>PG 2 Hostname/IP Address</strong></td>
</tr>
<tr>
<td>Note</td>
<td>When you select the <strong>Specific</strong> option, the PG1 Hostname/IP Address is a mandatory field.</td>
</tr>
<tr>
<td>Service Control</td>
<td>If you click <strong>Yes</strong>, the Service Control interface allows Unified ICME to provide call-processing instructions to the Unified CCX system. It also provides Unified ICME software with event reports indicating changes in call state.</td>
</tr>
<tr>
<td></td>
<td>You must enable the service control interface to use the Unified ICME subsystem.</td>
</tr>
</tbody>
</table>
Select the required variables to pass call-related information by selecting the checkbox. The following expanded call variables are available on the Unified ICME subsystem:

- Task ID: Task ID that handles the current call.
- Media ID: Media ID that handles the current call.
- Last Redirected Address: Transient part ID of the call.
- Arrival Type: Arrival type of the call.
- Session Handled: Boolean flag that the Unified ICME software or a Set Contact Info step with a Handled flag step sets to indicate whether the session is handled.

**Note** Unified CCX automatically sets the flag whenever a call is connected to an agent.

- VRU Script Name: Script name to run on the PreConnect feature.

**Note** All scripts under the default directory are listed in the drop-down list of the Script field in the Cisco Script Application Configuration page.

- Config Param: Parameters for the VRU scripts on the PreConnect feature.

---

**Note** You can also define your own expanded call variables in the Configure ICME tool in the Unified ICME system. The Unified CCX Engine registers the user-defined expanded call variables with Unified ICME after it loads the VRU scripts that use these variables. The variables remain registered until the Unified ICME session is reopened (either by request from the VRU PG or when the Unified CCX Engine is restarted). The variables remain registered even if you delete the script that uses them.

---

**Tip** Every Call Context Variable and Expanded Call Context Variable must be defined on both sides of the system that receive and send variable data in scripts. In a Unified CCX system, these variables must be defined both in Unified CCX and in Cisco Desktop Administrator (CDA). In a Unified CCX system integrated with Unified ICME through the Unified Gateway, these variable must be defined in Unified CCX, in CDA, and also in Unified ICME.

---

**Related Topics**

Configure General Unified ICME Information, on page 125

---

**Configure Unified ICME VRU Scripts**

Configure Unified ICME VRU scripts. Unified ICME VRU Script entries allow you to map the VRU script name, used by Unified ICME in the Run VRU Script node, to a Unified CCX script name.
Unified ICME uses VRU scripts to handle interactions with contacts. These scripts are loaded as applications on the Unified CCX Engine.

To configure Unified ICME VRU Scripts, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose Subsystems > ICM. The Unified ICME Configuration web page opens, displaying the General area.

**Step 2** On the Unified ICME Configuration toolbar, click Unified ICME VRU Scripts. The Unified ICME VRU Scripts summary web page opens.

**Step 3** Use this web page to specify the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRU Script Name</td>
<td>Displays the VRU script name.</td>
</tr>
<tr>
<td></td>
<td>Note All scripts under the default directory are listed in the drop-down list of the Script field in the Cisco Script Application Configuration page.</td>
</tr>
<tr>
<td>Script</td>
<td>Displays the script associated with the VRU script.</td>
</tr>
</tbody>
</table>

**Step 4** Click Add a New VRU Script icon or button. The Unified ICME VRU Script area of the Unified ICME Configuration web page opens.

**Step 5** Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRU Script Name</td>
<td>A name for the VRU script you want to add.</td>
</tr>
<tr>
<td>Script</td>
<td>The Unified CCX script to associate with the VRU script. You can select the script from the drop-down list or click Edit button to specify a new script.</td>
</tr>
<tr>
<td></td>
<td>Note All scripts under the default directory are listed in the drop-down list of the Script field in the Cisco Script Application Configuration page.</td>
</tr>
<tr>
<td></td>
<td>To specify a new script, click Edit, enter the script name in the dialog box, and click OK. The User Prompt dialog box closes, and the name you entered appears in the Script field.</td>
</tr>
<tr>
<td></td>
<td>Note If you enter the script name as a file URL, enter the value with double backslashes (). For example, file://c:\temp\aa.aef</td>
</tr>
</tbody>
</table>

**Step 6** Click Add. The Unified ICME VRU Script area closes, and the name of the VRU script you added appears in the Unified ICME VRU Scripts summary web page.

You are now ready to provision any additional subsystems your Unified CCX applications require or to begin configuring Unified CCX applications.
Provision of HTTP Subsystem

Note

The HTTP subsystem is available if your system has a license installed for one of the following Cisco product packages: Unified IP IVR or Unified CCX Premium.

The Unified CCX system uses the HTTP subsystem to enable Unified CCX applications to respond to requests from a variety of web clients, including computers and IP phones.

Note

If you are not using HTTP applications, you do not need to provision the HTTP subsystem.

The Unified CCX system uses subdirectories in the Unified CCX installation directory to store text substitution, eXtensible Style Language (xsl) templates, static and dynamic web pages, and Java Servlet Pages (JSPs).

Note

Use the Document Management page to upload these documents.

To provision the HTTP subsystem, you need to provision HTTP triggers. HTTP applications use triggers to activate the application in response to an incoming HTTP message.

Note

You cannot change the TCP/IP port numbers used by the HTTP subsystems or triggers in Unified CCX.

Related Topics

Manage Scripts Prompts, Grammars, and Documents, on page 13
Configure HTTP Triggers, on page 129
About Additional Subsystems, on page 123
Provision of Unified ICME Subsystem, on page 124
Provision eMail Subsystem, on page 134
Application Triggers, on page 54

Configure HTTP Triggers

You need to create an application using Applications > Application Management menu from the Unified CCX Administration menu bar. After you create an application, you can configure HTTP triggers for the application using the following procedure.
Procedure

**Step 1**  From the Unified CCX Administration menu bar, choose **Subsystems > HTTP**.

The HTTP Trigger Configuration web page opens.

**Step 2**  Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>The relative URL. For example: /hello</td>
</tr>
<tr>
<td>Application Name</td>
<td>Select an application for which you want to add a HTTP trigger from this list box.</td>
</tr>
<tr>
<td>Sessions</td>
<td>The maximum amount of simultaneous sessions (instances) that the application can handle.</td>
</tr>
<tr>
<td></td>
<td>• The limit for the maximum number of simultaneous remote monitoring sessions is 16, but the actual number depends on CPU and memory resources.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click the required radio button to accept - <strong>Yes</strong> (the default).</td>
</tr>
</tbody>
</table>

**Note**  If you disable the trigger, the user receives an error message when browsing to the defined trigger URL.

**Step 3**  Click **Add New**.

The HTTP Trigger Configuration web page closes, and the trigger information appears on the HTTP Trigger Configuration summary web page.

You are now ready to provision any additional subsystems your Unified CCX applications require or to begin configuring Unified CCX applications.

Related Topics

- HTTP Configuration, on page 317
- Cisco Applications Configuration, on page 41
- About Additional Subsystems, on page 123
- Application Triggers, on page 54
Provision of Database Subsystem

**Note**
The Database subsystem is available if your system has a license installed for either the Unified IP IVR or Unified CCX Premium product packages. If you are not using Unified CCX applications that require access to databases, you do not need to provision the Database subsystem.

The Unified CCX system uses the Database subsystem to enable Unified CCX applications to interact with database servers to make database information accessible to contacts.

**Caution**
The Database subsystem does not support database views or execute store procedures.

**Related Topics**
- About Additional Subsystems, on page 123
- Provision of Unified ICME Subsystem, on page 124
- Provision of HTTP Subsystem, on page 129
- Provision eMail Subsystem, on page 134

Database Subsystem Configuration

The Database subsystem enables the Unified CCX applications to obtain information from data sources, which are databases configured to communicate with the Unified CCX system. You can connect the Unified CCX system with enterprise databases such as Microsoft SQL Server, Sybase, Oracle, or IBM DB2.

You can upload JDBC driver files using Subsystems > Database > Drivers menu option.

**Note**
To determine a list of enterprise databases supported for the Database subsystem, see the Cisco Unified CCX Software and Hardware Compatibility Guide for active releases available at http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX.

**Related Topics**
- Add New Database Driver, on page 316

Add New Datasource

After uploading the JDBC driver, you need to use this to create the datasource in the Database subsystem.

To add a new data source, complete the following steps.
Procedure

Step 1  From the Unified CCX Administration menu bar, choose Subsystems > Database > DataSource. Click Add New icon that displays in the toolbar in the upper, left corner of the window or the Add New button that displays at the bottom of the page.
The Datasource Configuration web page opens. For more information on the web page fields, see Datasource Configuration Web Page, on page 132

Step 2  Click Add to save the changes.
The Enterprise Database Subsystem Configuration web page opens. You are now ready to provision any additional subsystems your Unified CCX applications require or to begin configuring Unified CCX applications.

Related Topics

Database Subsystem Configuration, on page 131
Cisco Applications Configuration, on page 41
About Additional Subsystems, on page 123

Datasource Configuration Web Page

Datasource Configuration web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source Name</td>
<td>Data source name for referring to the datasource. This is a mandatory field.</td>
</tr>
<tr>
<td>User Name</td>
<td>Username defined for connecting to the enterprise database. This is a mandatory field.</td>
</tr>
<tr>
<td>Password</td>
<td>Password defined for connecting to the enterprise database.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Re-enter the password that you provided in the Password field.</td>
</tr>
</tbody>
</table>
| Maximum Number of Connections | Maximum number of connections allowed to connect to the database.  
While the limit is set by that database and governed by your license, if this number in this setting is exceeded, the corresponding workflow is aborted and the caller receives an error message. However, you can avoid this error by configuring the appropriate number of sessions in the corresponding script or application. Also, the script writer can provide information about how many connections are used per call (or instance of application). This is a mandatory field. |
| Driver                     | Displays the list of available drivers for the enterprise database. One or more datasources can use the same driver. Select a driver for this datasource from this list box. This is a mandatory field. |
Field | Description
--- | ---
JDBC URL | JDBC URL that is used to obtain a connection to the enterprise database. This is a mandatory field. The JDBC URL provided will be used by Unified CCX to connect to the enterprise database using JDBC. The URL to be used is dependent on the database you are connecting. The examples provided in the Datasource Configuration web page can be used as a reference to define the URL. Refer to the driver documentation for more information.

**Note** If the test connection fails for Oracle JDBC drive connection, try the following connection url: jdbc:oracle:thin:[user/password]@[host][:port]:SID

### Related Topics
- Add New Datasource, on page 131

### Poll Database Connectivity

To poll connectivity to the database on a periodic basis, complete the following steps.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > Database > Parameters**. The Parameters web page opens to display the parameter-related fields.

**Step 2** Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RetryConnectInterval</td>
<td>Specifies the interval between two connection attempts when a data source is initialized. The default is 15,000 milliseconds.</td>
</tr>
<tr>
<td>NumAttempt</td>
<td>Specifies the number of attempts to establish connections to the database when a data source is initialized. The default is 3 attempts.</td>
</tr>
<tr>
<td>LoginTimeout</td>
<td>Sets the maximum time in seconds that a driver will wait while attempting to connect to a database. The default is 0 (disabled).</td>
</tr>
</tbody>
</table>

**Step 3** Click **Update** to apply changes (or **Reset to Default** if you prefer to retain the default values). The window refreshes and Unified CCX updates the parameters with your changes. You are now ready to provision any additional subsystems your Unified CCX applications require or to begin configuring Unified CCX applications.

### Related Topics
- Cisco Applications Configuration, on page 41
Provision eMail Subsystem

The eMail subsystem is available if your system has a license installed for one of the following Cisco product packages: Unified IP IVR or Unified CCX Premium.

The Unified CCX system uses the eMail subsystem to communicate with your email server and enable your applications to create and send email. You must provision the eMail subsystem if you intend to create scripts that use messaging steps to create and send email.

Tip

If your email system is configured to receive acknowledgments, you should process the mailbox you identify in your configuration to determine whether or not an email was successfully sent.

The email configuration process identifies the default email address and server to be used for sending email (including e-pages and faxes) and for receiving acknowledgments.

Note

If you are not using email applications, you do not need to provision the eMail subsystem.

Procedure

Step 1

Choose Subsystems > eMail.
The eMail Configuration web page opens.

Step 2

Specify the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mail Server</td>
<td>A fully-qualified email server name. (Example: server.domain.com)</td>
</tr>
<tr>
<td>email Address</td>
<td>An existing fully qualified e-mail address for the administrative account. Example: <a href="mailto:administrator@domain.com">administrator@domain.com</a></td>
</tr>
</tbody>
</table>

Step 3

Click Update.
The Unified CCX system saves your changes and the Unified CCX Administration web page opens.
**Note**  Cisco does not currently support multiple email configurations. To remove the email information, you must erase the fields and click **Update**.

You are now ready to provision any additional subsystems your Unified CCX applications require, or to begin configuring Unified CCX applications.

---

**Related Topics**

- Cisco Applications Configuration, on page 41
- Management of Prompts, Grammars, Documents, and Custom Files, on page 137
- About Additional Subsystems, on page 123
- Provision of Unified ICME Subsystem, on page 124
- Provision of HTTP Subsystem, on page 129
- Provision of Database Subsystem, on page 131
Management of Prompts, Grammars, Documents, and Custom Files

Unified CCX applications can make use of many auxiliary files that interact with callers, such as scripts, pre-recorded prompts, grammars, and custom Java classes.

To manage these auxiliary files, you must complete the following tasks:

- Provision telephony and media resources.
- Provision Unified CCX subsystem, if required.
- Provision additional subsystems, if required.
- Configure Cisco script applications.

Depending on your particular Unified CCX implementation, your applications might make use of some or all of the file types described in the following sections.

- Manage Prompt Files, page 137
- Manage Grammar Files, page 139
- Manage Document Files, page 141
- Language Management, page 142
- Upload of Prompt Files, page 145
- Management of Custom Files, page 147
- AAR File Management, page 148

Manage Prompt Files

Many applications make use of pre-recorded prompts stored as .wav files, which are played back to callers to provide information and elicit caller response.

Several system-level prompt files are loaded during Unified CCX installation. However, any file you create needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This
is done through the Unified CCX cluster's Repository datastore, where the prompt, grammar, and document files are created, stored, and updated.

**Note**

Support for High Availability and remote servers is available only in multiple-server deployments.

The Unified CCX Server's local disk prompt files are synchronized with the central repository during Unified CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Prompt Management page, perform the following steps:

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Application > Prompt Management**.

**Step 2** The Prompt Management web page opens to display the following fields and buttons.

<table>
<thead>
<tr>
<th>Field or Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Lists the location of the items listed in the Name column.</td>
</tr>
<tr>
<td>Folder</td>
<td>Path of the current item selected in the Name column with respect to the root folder.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the language.</td>
</tr>
<tr>
<td>Size</td>
<td>The size of the prompt file prefixed with KB. The file size is converted from bytes to KB. <strong>Note</strong> This column is usually blank on the root page because the items on this page are usually folders.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>The date and time when the document was last uploaded or changed along with time zone.</td>
</tr>
<tr>
<td>Modified by</td>
<td>The user ID of the person who performed these modifications.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click <strong>Delete</strong> icon to remove the folder and its contents from the repository.</td>
</tr>
<tr>
<td>Rename</td>
<td>Click <strong>Rename</strong> icon to rename the folder in the repository.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Click <strong>Refresh</strong> icon to refresh the folder in the repository.</td>
</tr>
<tr>
<td>Create Language</td>
<td>Displays a dialog box that lets you create a new language folder.</td>
</tr>
<tr>
<td>Upload Zip Files</td>
<td>Displays a dialog box that lets you locate and upload a zip file. <strong>Note</strong> The zip file must contain language folders in the root directory. Be sure to place the grammar files in folders and then zip the folders.</td>
</tr>
</tbody>
</table>

When you click a hyperlink (if configured) in the Name folder column, a secondary page appears. From this page, you can create a new subfolder or upload a new prompt.
The Unified CCX system uses specific grammars when recognizing and responding to caller response to prompts. A grammar is a specific set of all possible spoken phrases and Dual Tone Multi-Frequency (DTMF) digits to be recognized by Unified CCX applications and acted upon during run time.

Several system-level grammar files are loaded during Unified CCX installation. However, any file you create needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This is done through the Unified CCX cluster's Repository datastore, where the grammar files are created, stored, and updated.

![Note](Image)

Support for High Availability and remote servers is available only in multiple-server deployments.

The Unified CCX Server's local disk grammar files are synchronized with the central repository during Unified CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Grammar Management page, perform the following steps:

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose **Applications > Grammar Management**.

**Step 2**
The Grammar Management web page opens to display the following fields and buttons.

<table>
<thead>
<tr>
<th>Field or Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Lists the location of the items listed in the Name column.</td>
</tr>
<tr>
<td>Folder</td>
<td>Path of the current item selected in the Name column with respect to the root folder.</td>
</tr>
<tr>
<td>Codec</td>
<td>The codec chosen during installation for this Unified CCX server. Display only.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the language folder.</td>
</tr>
</tbody>
</table>
### Field or Button | Description
---|---
Size | The size of the grammar file prefixed with KB. The file size is converted from bytes to KB. This column is usually blank on the root page as the items on this page are usually folders.
Date Modified | The date and time when the document was last uploaded or changed along with time zone.
Modified by | The user ID of the person who performed these modifications.
Delete | Displays a dialog box that lets you delete an existing language folder.
Rename | Displays a dialog box that lets you rename an existing language folder.
Refresh | Refreshes the specified folder in the repository.
Create Language | Displays a dialog box that lets you create a new language folder.
Upload Zip Files | Displays a dialog box that lets you locate and upload a zip file. 
**Note** | The zip file must contain language folders in the root directory. Be sure to place the grammar files in folders and then zip the folders.

When you click a hyperlink (if configured) in the Name folder column, a secondary page appears. From this page, you can create a subfolder or upload a new Prompt, Grammar, or Document.

**Related Topics**
- Wizards Menu, on page 323
- Manage Prompt Files, on page 137
- Manage Document Files, on page 141
- Language Management, on page 142
- Upload of Prompt Files, on page 145
- Management of Custom Files, on page 147
- AAR File Management, on page 148
- Script Management, on page 58
Manage Document Files

Documents might consist of .txt, .doc, .jsp, or .html files. Documents can also include custom classes and Java Archive (JAR) files that allow you to customize the performance of your Unified CCX system.

Several system-level document files are loaded during Unified CCX installation. However, any file you create needs to be made available to the Unified CCX Engine before a Unified CCX application can use them. This is done through the Unified CCX cluster's Repository datastore, where the document files are created, stored, and updated.

Note

Support for High Availability and remote servers is available only in multiple-server deployments.

The Unified CCX Server's local disk document files are synchronized with the central repository during Unified CCX Engine startup and during run-time when the Repository datastore is modified.

To access the Document Management page, perform the following steps:

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose **Applications > Document Management**.

**Step 2**
The Document Management web page opens to display the following fields and buttons.

<table>
<thead>
<tr>
<th>Field or Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Lists the location of the items listed in the Name column.</td>
</tr>
<tr>
<td>Folder</td>
<td>Path of the current item selected in the Name column with respect to the root folder.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the language folder.</td>
</tr>
<tr>
<td>Size</td>
<td>The size of the grammar file prefixed with KB. The file size is converted from bytes to KB. This column is usually blank on the root page as the items on this page are usually folders.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>The date and time when the document was last uploaded or changed along with time zone.</td>
</tr>
<tr>
<td>Modified by</td>
<td>The user ID of the person who performed these modifications.</td>
</tr>
<tr>
<td>Delete</td>
<td>Displays a dialog box that lets you delete an existing language folder.</td>
</tr>
<tr>
<td>Rename</td>
<td>Displays a dialog box that lets you rename an existing language folder.</td>
</tr>
</tbody>
</table>
Language Management

The topics in this section describe the procedure for managing languages.

Create New Language

Follow this procedure to create a new Prompt, Grammar, or Document language folder in the Repository datastore:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Prompt Management or Grammar Management or Document Management. The corresponding Management web page opens.
Step 2  Click **Create New Folder** or **Create Language** icon that displays in the toolbar in the upper, left corner of the window or the **Create New Folder** or **Create Language** button that displays at the bottom of the window. The Create New Folder or Create Language dialog box opens.

Step 3  Perform any one of the following actions:

- Select a value from the Language drop-down list.

- If you are unable to find a particular language or if the Language drop-down list is empty, click **Edit** button to add a new Language. The Explorer User Prompt dialog box opens. Enter the name of the new language in the Language Name field and click **OK**.

Step 4  Click **Create**.

A new language folder Name appears on the summary web page.

---

### Rename Language

Follow this procedure to rename a Prompt/Grammar/Document language folder in the Repository datastore:

**Procedure**

Step 1  From the Unified CCX Administration menu bar, choose **Applications > Prompt Management** or **Grammar Management** or **Document Management**. The corresponding Management web page opens.

Step 2  Select the **Rename** icon against the folder you want to rename. The Rename Folder dialog box opens.

Step 3  From the Select Language Folder To Rename field, choose the name of the folder to be renamed.

Step 4  In the Rename Folder To field, enter the new name.

Step 5  Click **Rename**. The web page then refreshes itself to provide a summary and status. Click **Return to Document Management** to navigate to the respective Prompt or Grammar or Document Management page.

---

### Delete Language

Follow this procedure to delete a Prompt/Grammar/Document language folder in the Repository datastore:

**Procedure**

Step 1  From the Unified CCX Administration menu bar, choose **Applications > Prompt Management** or **Grammar Management** or **Document Management**. The corresponding Management web page opens.
Step 2  Select the Delete icon against the respective folder, that you want to delete. A dialog box opens to confirm the Delete action for the specific folder.

Step 3  Click OK to delete.

Upload Zip Files to Language Folder

In addition to adding Prompt or Document files individually, you can upload multiple files from a Zip file.

Note  The maximum upload file size is 20 MB, whether it is a single file or a Zip file.

Tip  Be sure to upload (or download) large zip files in Prompt, Grammar and Document Management pages during off-peak hours.

Procedure

Step 1  From the Unified CCX Administration menu bar, choose Applications > Prompt Management or Grammar Management or Document Management. The corresponding Management web page opens.

Step 2  Click Upload Zip Files icon that displays in the tool bar in the upper, left corner of the window or the Upload Zip Files button that displays at the bottom of the window to upload a new prompt or zip file. The Upload Document dialog box opens.

Step 3  Enter the path for the script file or click Browse to locate the script or the zip file containing the script files. Select the required script file and click Open.

Note  You can upload only files with extension .aef or .zip.

Step 4  Click the Upload button to upload the new script to the repository. A dialog box confirms the successful upload of the files.

Note  If you try to upload invalid script files, the upload will be unsuccessful and an error message will be displayed on the upload dialog box. You can also create user-defined directories using “Create a New folder” option and uploads scripts to those directories.

Step 5  By default, the files are unzipped after uploading. If you want to change this option, uncheck the Unzip after uploading check box.

Caution  In the Documents Management summary web page, you have the option to zip or to unzip the file before uploading. By default, this check box is checked to unzip the file before uploading. Ensure to uncheck the check box if you want to upload it as a zipped file.

The maximum upload file size of the Zip file is 20 MB.

Step 6  The contents of the zip file is uploaded to the folder. On successful uploading of the zip file, the status icon is updated accordingly. Click Return to Document Management button to go back to the respective Management web page.
Upload of Prompt Files

Prompts are messages that the Unified CCX system plays back to callers. Unified CCX applications often use prompts to elicit caller response so that the Unified CCX system can transfer calls, receive account information, and perform other functions.

To use prompts in your Unified CCX applications, you must first create a folder to store them. You can then record and upload new user prompts, delete prompts, and modify existing prompts.

You store pre-recorded prompts as .wav files. The Unified CCX system also allows users to record spoken names, which you can upload to be used in the playback of prompts.

**Note**

Unified CCX supports audio playback of RIFF header .wav files only though your MRCP vendor might support multiple .wav file header formats.

ScanSoft uses RIFF headers. When generating a wav file prompt specifically for Nuance, be sure to consider the server playing the prompt:

- If the prompt is played by the Nuance Speech Server, the .wav file requires a SPHERE header.
- If the prompt is played by the Unified CCX server, the .wav file requires a RIFF header.

Nuance provides a tool to convert .wav files from RIFF headers to SPHERE headers.

Managing prompts can include one or more of the following activities:

- **Creating a folder**: You must create a folder to store the .wav files that the Unified CCX system uses as prompts.
- **Recording a prompt**: You can record your own prompts to be used in applications.
- **Upload one or more prompts**: You can replace any of the stored prompts used by Cisco script applications with a different .wav file by uploading the new .wav file. If necessary, you can also add spoken name prompts. Some Unified CCX applications play back the pre-recorded names of the people that callers are trying to reach, to allow the caller to confirm the transfer of the call.

**Related Topics**

Manage Prompt Files, on page 137

Record a Prompt

You can record your own prompts to be used in applications. The example provided in this section uses the Windows Sound Record option. This option is one of many possibilities for recording G711 prompts. G711 is a freely distributed public domain codec and has several recording options. Some of these options are included in Microsoft Windows systems and are available to any sound recording application.

The G729 codec is licensed and is not freely distributed. A white paper that describes the G729 prompt recording options is available on request. Send an email to apps-support@cisco.com to obtain a copy of this white paper. To record a prompt, complete the following steps.
The following procedure is an example of recording G.711 prompts with Microsoft Windows Sound Recorder, using a microphone plugged into your computer. If you are not using Microsoft Windows Sound Recorder, see the documentation provided with your audio application.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>From your Windows Start menu, choose <strong>Start &gt; Programs &gt; Accessories &gt; Entertainment &gt; Sound Recorder</strong>. The Sound Recorder dialog box opens.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the <strong>Record</strong> button and speak your greeting into the microphone.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the <strong>Stop</strong> button when you finish recording.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To check your greeting, click the <strong>Rewind</strong> button or drag the slider back to the beginning of the recording. Then click the <strong>Play</strong> button.</td>
</tr>
<tr>
<td>Step 5</td>
<td>When you are satisfied with your greeting, choose <strong>File &gt; Save As</strong>. The Save As window opens.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Change to set the recording options. You can also set recording properties by choosing Properties from the Sound Recorder File menu. The Sound Selection dialog box opens.</td>
</tr>
<tr>
<td>Step 7</td>
<td>From the Format drop-down menu, choose one of the following options based on the prompts selected during the installation of Unified CCX software:</td>
</tr>
<tr>
<td></td>
<td>• If you selected G711 prompts, <strong>CCITT u-Law</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If you selected G729 prompts, see your G.729 white paper.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>The instructions in this procedure assume that, during Unified CCX installation, you configured Unified CCX to use the G.711 codec for prompts. If this assumption is incorrect, and you specified the G.729 codec instead, you would choose a G.729 option from this menu. For more information about recording prompts with G.729, see your G.729 documentation.</td>
</tr>
<tr>
<td>Step 8</td>
<td>From the Attributes drop-down menu, choose 8.000 kHz, 8 Bit, Mono 7 kb/sec.</td>
</tr>
<tr>
<td>Step 9</td>
<td>Click <strong>Save As</strong>. The Save As dialog box opens.</td>
</tr>
<tr>
<td>Step 10</td>
<td>Enter a name for this format, and then click <strong>OK</strong>. The Save As Dialog Box closes.</td>
</tr>
<tr>
<td>Step 11</td>
<td>In the Sound Selection dialog box, click <strong>OK</strong>. The Sound Selection dialog box closes.</td>
</tr>
<tr>
<td>Step 12</td>
<td>In the Save As window, navigate to the directory of your choice, preferably a directory that you have set aside for prompts.</td>
</tr>
<tr>
<td>Step 13</td>
<td>Select the file name, and click <strong>Save</strong>. The Save As dialog box closes. You are now ready to add this prompt to the Unified CCX system.</td>
</tr>
</tbody>
</table>
Add Spoken-Name Prompts

Some Unified CCX applications play back the pre-recorded names of people that callers are trying to reach, to allow callers to confirm the transfer of a call.

To upload .wav files of the spoken names of users, complete the following steps.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>From the Unified CCX Administration menu bar, choose <strong>Tools &gt; User Management &gt; Spoken Name Upload.</strong></td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>The Spoken Name Prompt Upload web page opens with the following fields:</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>User Id</td>
<td>Unique identifier of the user for which the spoken name is to be uploaded. This is a mandatory field.</td>
</tr>
<tr>
<td>Codec</td>
<td>The codec chosen during installation for this Unified CCX server. Display only.</td>
</tr>
<tr>
<td>Spoken Name (.wav)</td>
<td>Location of the .wav file. This is a mandatory field.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the User Id field, enter an ID number that will identify the user.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>In the Spoken Name (.wav) field, enter the path for a .wav file or click <strong>Browse</strong> to navigate to the directory that contains the Spoken Name .wav file. The Choose File dialog box opens. Select the required script file and click <strong>Open</strong>.</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>Click <strong>Upload</strong> icon that displays in the tool bar in the upper, left corner of the window or click the <strong>Upload</strong> button that displays at the bottom of the window to upload the file.</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>Repeat this process as needed to upload all spoken name .wav files.</td>
</tr>
</tbody>
</table>

Management of Custom Files

Use the Custom File Configuration web page to configure the classpath location of custom classes.

Specify Custom Classpath Entries

Use the Custom Classes Configuration web page to specify the available classpath entries.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>From the Unified CCX Administration menu bar, choose <strong>System &gt; Custom File Configuration.</strong></td>
</tr>
</tbody>
</table>
The Custom Classes Configuration web page opens. You can:

- Select required entries from the Available Classpath Entries list and arrange them in the order you want.
- Use the arrow icons to move items between the Available Classpath Entries and Selected Classpath Entries lists.

**Step 2** Click **Update** when your selections are complete.
Click **Upload Custom Jar Files** icon that displays in the tool bar in the upper, left corner of the window or the **Upload Custom Jar Files** button that displays at the bottom of the window to upload Jar files. The Document Management web page opens.

**Related Topics**

- Manage Document Files, on page 141

---

### AAR File Management

**Caution**

Ensure that the contents of the AAR file are correct and conform to the specifications detailed in this section. If you upload AAR files that do not conform to these specifications, the Unified CCX Engine may not function as designed. Consequently, you need to manually reconfigure some of the applications uploaded through AAR.

AAR files are archives of prompt, grammar, document, scripts, applications, and custom classes that you use as building blocks for applications and extensions.

An AAR file can be simple—for instance, consisting of a single prompt—or complex—for example, containing all the prompts for all languages application uses, the workflow, and the configuration information for an application.

An AAR file is essentially a zip file that contains an optional META-INF directory. The META-INF directory, if it exists, stores configuration data, including security, versioning, extensions, and services.

You create AAR files using Java tools. After creating a file, you need to upload it to Unified CCX.

The following example shows a sample AAR Main Manifest and a sample AAR Application Manifest.

**Sample AAR Main Manifest**

```
Manifest-Version: 1.1
Created-By: 1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Cisco Unified CCX-Version: 9.0(1)
Class-Path:
Application-List: customApp1.mf customApp2.mf
Subsystem-List: sub1.mf sub2.mf
Palette-List: Custom1 Custom2
Custom1-Palette-Name: Category1
Custom2-Palette-Name: Category2
Custom1-Step-List: step1.mf
Custom2-Step-List: step2.mf step3.mf
Implementation-Title: AAR Test File
Implementation-Version: 4.5(1)
Implementation-Vendor: Cisco Systems, Inc.
```
Sample AAR Application Manifest

Application-Version: 1.1
Created-By: 1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Implementation-Title: AAR Application MF
Implementation-Version: 9.0(1)
Implementation-Vendor: Cisco Systems, Inc.
Implementation-Vendor-Id: 12345
Implementation-URL: http://www.cisco.com
Application-Name: Custom AA
Application-Type: Cisco Script Application
Application-Description: Cisco Unified CCX Cisco Custom Application
Application-Id: 100
Max-Sessions: 300
Enabled: true
Script: SSCRIPT[aa.aef]
Default-Script: SSCRIPT[aa.aef]
Initial-Script: SSCRIPT[aa.aef]

The figure below shows a sample AAR file.

Figure 2: Sample AAR File

To deploy custom applications, steps, and subsystems through an AAR file, you must first create the AAR file using a jar or zip tool and then upload the file through the Unified CCX Administration web page.
AAR File Creation

You create an AAR file using a jar or WinZip tool.

An AAR file format is similar to a Zip file format. It includes an optional META-INF directory, which is used to store configuration data, including security, versioning, extension, and services.

Upload AAR Files

To upload an AAR file, complete the following steps.

Procedure

**Step 1**

From the Unified CCX Administration menu bar, choose **Applications > AAR Management**. The AAR Management web page opens to display the following fields and buttons.

<table>
<thead>
<tr>
<th>Field or Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter a Valid AAR File to Upload</td>
<td>You can either enter the name of the AAR file or click <strong>Browse</strong> button next to this field to navigate to the directory in which the file is located. This is a mandatory field.</td>
</tr>
<tr>
<td>Overwrite existing files</td>
<td>Enable this checkbox in case you want to overwrite the existing files.</td>
</tr>
<tr>
<td>Upload</td>
<td>Click this button to upload the AAR file.</td>
</tr>
<tr>
<td>Clear</td>
<td>Click this button to clear the selected file.</td>
</tr>
</tbody>
</table>

Enter the path for the AAR file or click **Browse** button to upload the file. The Choose File dialog box opens. Select the required script file and click **Open**.

**Step 2**

Click **Upload**. The contents of the AAR file are uploaded to the respective folders.

**Note**

Unified CCX generates an error if the AAR file is not formatted correctly or is missing some custom files.

META-INF Directory

Unified CCX uses the following files and subdirectories in the META-INF directory to configure applications, extensions and services:

- **MANIFEST.MF**. The file used to define extension and application related data.
- **applications**. This directory stores all application configuration files.
Directories for Prompts, Grammars, Documents, and Scripts

The AAR files feature also provides directories to store prompts, grammars, documents, and scripts to be uploaded to the Repository.

The AAR directory structure mirrors the function of the Unified CCX Prompt, Grammar, Documents, and Scripts Management web pages. Each directory corresponds to each language for which to install prompts, grammars, documents and scripts. Languages are defined using the Java Locale standard, and the special default directory is used for prompts, grammars, and documents that are common to all languages.

Only Unified CCX supported prompt files and extensions are allowed within each directory. The maximum length of each individual folder name and file name within a directory is 64 characters.

**Prompts Directory**

The Prompts directory stores prompts that must be uploaded to the prompt repository (to make it seem like they were uploaded through Unified CCX Prompt Management).

**Grammars Directory**

The Grammars directory stores grammars that must be uploaded to the grammar repository (to make it seem like they were uploaded through Unified CCX Grammar Management).

**Documents Directory**

The Documents directory stores documents that must be uploaded to the document repository (to make it seem like they were uploaded through Unified CCX Document Management).

**Scripts Directory**

The Scripts directory stores scripts that must be uploaded to the script repository (to make it seem like they were uploaded through Unified CCX Script Management).

---

**Note**

The Script directory must define a single directory named default under which all script files must be listed.

---

**AAR Manifest**

An AAR file manifest consists of a main section followed by a list of sections for individual AAR file entries, each separated by a newline.
Information in a manifest file contains name-value pairs—which are also referred to as headers or attributes. Groups of name-value pairs are known as a section; sections are separated by empty lines.

The following table describes the expected syntax of the manifest file.

**Table 3: Manifest File Syntax**

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>section:</td>
<td>*header +newline</td>
</tr>
<tr>
<td>nonempty-section:</td>
<td>+header +newline</td>
</tr>
<tr>
<td>newline:</td>
<td>CR LF</td>
</tr>
<tr>
<td>header:</td>
<td>name: value</td>
</tr>
<tr>
<td>name:</td>
<td>alphanum *headerchar</td>
</tr>
<tr>
<td>value:</td>
<td>SPACE *otherchar newline *continuation</td>
</tr>
<tr>
<td>continuation:</td>
<td>SPACE *otherchar newline</td>
</tr>
<tr>
<td>alphanum:</td>
<td>{A-Z}</td>
</tr>
<tr>
<td>headerchar:</td>
<td>alphanum</td>
</tr>
<tr>
<td>otherchar:</td>
<td>any UTF-8 character except NUL, CR and LF</td>
</tr>
</tbody>
</table>

**Note** To prevent corruption of files sent through email, do not use “From” to start a header.

The main section, which is terminated by an empty line:

- Contains security and configuration information about the AAR file itself, as well as the applications or extensions that this AAR file is defining.
- Defines main attributes that apply to every individual manifest entry. No attribute in this section can have its name equal to “Name”.

The individual sections define various attributes for directories or files contained in this AAR file. Not all files in the AAR file need to be listed in the manifest as entries. The manifest file itself must not be listed. Each section must start with an attribute with the name as “Name”, and the value must be a relative path to the file or directory.

If there are multiple individual sections for the same file entry, the attributes in these sections are merged. If a certain attribute has different values in different sections, the last one is recognized.

Attributes that are not understood are ignored. Such attributes may include implementation-specific information used by applications.

The following table describes the specification for any file that can be archived in the AAR.
Table 4: Syntax for AAR Files

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>manifest-file</td>
<td>main-section newline *individual-section</td>
</tr>
<tr>
<td>main-section</td>
<td>version-info newline *main-attribute</td>
</tr>
<tr>
<td>version-info</td>
<td>Manifest-Version: version-number</td>
</tr>
<tr>
<td>version-number</td>
<td>digit+{.digit+}*</td>
</tr>
<tr>
<td>main-attribute</td>
<td>(any legitimate main attribute) newline</td>
</tr>
<tr>
<td>individual-section</td>
<td>Name: value newline *perentry-attribute</td>
</tr>
<tr>
<td>perentry-attribute</td>
<td>(any legitimate perentry attribute) newline</td>
</tr>
<tr>
<td>newline</td>
<td>CR LF</td>
</tr>
<tr>
<td>digit</td>
<td>{0-9}</td>
</tr>
</tbody>
</table>

Attribute Types

Attributes that appear in the main section are called main attributes. Attributes that appear in individual sections are called per-entry attributes. Some attributes appear in both the main and individual sections, in which case the per-entry attribute value overrides the main attribute value for the specified entry.

Main Attributes

Main attributes are the attributes that are present in the main section of the manifest:

General main attributes as shown in the following table.

Table 5: General Main Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manifest-Version</td>
<td>The manifest file version. The value is a legitimate version number.</td>
</tr>
<tr>
<td>Created-By</td>
<td>The version and the vendor of the java implementation on top of which this manifest file is generated. This attribute is generated by the jar tool.</td>
</tr>
</tbody>
</table>
### Attribute Types

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Unified CCX-Version</td>
<td>The minimum Unified CCX version release compatible with the AAR file. Unified CCX-version is the accumulation of the Unified CCX release, Unified CCX Service Release, and Unified CCX Engineering Special defined in that order. For example, if the AAR file is compatible with Cisco Unified CCX release 4.5(1)_Build705, SR1_Buil001, ES2_Build002, the Cisco Unified CCX-Version would be defined as 4.5(1)SR1ES2_Build002. Only the last build number is taken. So for instance, if the AAR file is compatible with Cisco Unified CCX release 4.5(1)_build705, SR1_Buil001, then the Cisco Unified CCX-Version is 4.5(1)SR1_Buil001. As a last example, if AAR file is compatible with Cisco Unified CCX release 4.5(1)_Build705 and above, then Cisco Unified CCX-Version would be 4.5(1)_Build705.</td>
</tr>
<tr>
<td>Class-Path</td>
<td>The directories or JAR files that need to be installed and accessed by scripts directly. Entries are separated by one or more spaces. The Unified CCX class loader uses the value of this attribute to construct its internal search path where each entry is defined relative to the /Documents/default/classpath directory in this AAR file.</td>
</tr>
<tr>
<td>Application-List</td>
<td>The application configuration files from the META-INF/applications/ directory to be installed. Entries are separated by one or more spaces.</td>
</tr>
<tr>
<td>Subsystem-List</td>
<td>The subsystem configuration files from the META-INF/subsystems/ directory to be installed. Entries are separated by one or more spaces.</td>
</tr>
<tr>
<td>Palette-List</td>
<td>The step palettes that need to be installed. Each palette listed in this attribute will have a set of additional attributes that the Unified CCX editor uses to specify the palette name and the palette steps to install. Entries are separated by one or more spaces.</td>
</tr>
<tr>
<td>Palette-Name</td>
<td>The unique name of the palette to define in the Unified CCX editor where the specified steps will be grouped and accessible.</td>
</tr>
<tr>
<td>Step-List</td>
<td>The step configuration files from the META-INF/steps/ directory to be installed under the palette. Entries are separated by one or more spaces.</td>
</tr>
</tbody>
</table>

Attribute defined for extension identification: Extension-Name

This attribute specifies a name for the extension contained in the AAR file. The name should be a unique identifier.

The following tables show attributes defined for extension and directory versioning and sealing information. These attributes define features of the extension which the AAR file is a part of. The values of these attributes apply to all the directories in the AAR file, but can be overridden by per-entry attributes.

**Table 6: Implementation Category in Main Attributes**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation-Title</td>
<td>The title of the extension implementation.</td>
</tr>
<tr>
<td>Implementation-Version</td>
<td>The version of the extension implementation.</td>
</tr>
</tbody>
</table>
The organization that maintains the extension implementation.

The ID of the organization that maintains the extension implementation.

The URL from which the extension implementation is downloaded.

Defines if this AAR file is sealed. Sealing a directory means that the files uploaded to the corresponding repository will not be modifiable once installed unless the AAR file is reinstalled. If set to true, then all directories in the AAR file default to be sealed, unless individually defined otherwise. If set to false, then all directories are modifiable.

Per-entry Attributes

Per-entry attributes apply only to the individual AAR file entry with which the manifest entry is associated. If the same attribute also appears in the main section, then the value of the per-entry attribute overwrites the main attribute value.

- **Example 1:** If AAR file a.aar has the following manifest content, then all the files archived in a.aar are sealed, except US English prompts. If the same attributes also appeared in an entry representing a parent directory of another entry, then the value of the per-entry attribute overwrites the parent directory per-entry attribute value.

  Manifest-Version: 1.1
  Created-By: 1.2 (Sun Microsystems Inc.)
  Sealed: true
  Name: Prompts/en_US/
  Sealed: false

- **Example 2:** If AAR file a.aar has the following manifest content, then all the US English prompts archived in a.aar are sealed, except US English prompts located in the AA/ directory.

  Manifest-Version: 1.1
  Created-By: 1.2 (Sun Microsystems Inc.)
  Name: Prompts/en_US/
  Sealed: true
  Name: Prompts/en_US/AA/
  Sealed: false

The per-entry attributes fall into the following groups:

- **Attributes defined for file contents: Content-Type**

  This attribute specifies the MIME type and subtype of data for a specific file entry in the AAR file. The value should be a string in the form of type/subtype. For example, image/bmp is an image type with a subtype of bmp (representing bitmap). This indicates that the file entry is an image with the data stored as a bitmap. RFC 1521 and 1522 discuss and define the MIME types definition.

- **Attributes defined for directory versioning and sealing information:**

  These are the same set of attributes defined in Table 6: Implementation Category in Main Attributes, on page 154 for the main attributes. When used as per-entry attributes, these attributes overwrite the main attributes for the individual file specified by the manifest entry.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation-Vendor</td>
<td>The organization that maintains the extension implementation.</td>
</tr>
<tr>
<td>Implementation-Vendor-Id</td>
<td>The ID of the organization that maintains the extension implementation.</td>
</tr>
<tr>
<td>Implementation-URL</td>
<td>The URL from which the extension implementation is downloaded.</td>
</tr>
<tr>
<td>Sealed</td>
<td>Defines if this AAR file is sealed. Sealing a directory means that the files uploaded to the corresponding repository will not be modifiable once installed unless the AAR file is reinstalled. If set to true, then all directories in the AAR file default to be sealed, unless individually defined otherwise. If set to false, then all directories are modifiable.</td>
</tr>
</tbody>
</table>
META-INF Directory Attributes

The Unified CCX recognizes the x.MF file in the applications, subsystems, and steps subdirectories in the META-INF directory and interprets each to configure applications, subsystems, and steps respectively. The x is the base file name as listed on the Application-List main attribute of the manifest file. The X.MF file contains one section defining the configuration of a particular application.

Application Subdirectory Attributes

The following table describes the syntax of the manifest file for the application subdirectory.

Table 7: Application Subdirectory Manifest File Syntax

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>application-file</td>
<td>version-info newline *application-attribute</td>
</tr>
<tr>
<td>version-info</td>
<td>Application-Version: version-number</td>
</tr>
<tr>
<td>version-number</td>
<td>digit+ {digit+}*</td>
</tr>
<tr>
<td>application-attribute</td>
<td>(any legitimate application attribute) newline</td>
</tr>
<tr>
<td>newline</td>
<td>CR LF</td>
</tr>
<tr>
<td>digit</td>
<td>{0-9}</td>
</tr>
</tbody>
</table>

The application attributes fall into the following groups:

Table 8: Application Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application-Version</td>
<td>The application configurations file version. The value is a legitimate version number. For example, Cisco Unified CCX Release 4.5 starts with version 1.1.</td>
</tr>
<tr>
<td>Application-Name</td>
<td>The unique name of the application (see Unified CCX Application Management).</td>
</tr>
<tr>
<td>Application-Type</td>
<td>The type of the application (Cisco Script Application, Busy, Ring-No-Answer, Unified ICME Translation or Post Routing).</td>
</tr>
<tr>
<td>Application-Description (optional)</td>
<td>The description for the application (see Unified CCX Application Management).</td>
</tr>
<tr>
<td>Application-Id</td>
<td>A unique identifier for the application (see Unified CCX Application Management).</td>
</tr>
<tr>
<td>Max-Sessions</td>
<td>The maximum number of sessions for the application (see Unified CCX Application Management).</td>
</tr>
</tbody>
</table>
### Attribute Types

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>The application is enabled if the value is set to true (see Unified CCX Application Management). If the value is set to false, the case is ignored.</td>
</tr>
<tr>
<td>Script</td>
<td>The main script of a Cisco Script Application (see Unified CCX Application Management). The value must be relative to the Scripts directory. Unified CCX does not support configuring script parameters.</td>
</tr>
<tr>
<td>Default-Script</td>
<td>The default script of a Cisco Script Application, Unified ICME Translation or Post Routing application (see Unified CCX Application Management). The value must be relative to the Scripts directory. Unified CCX does not support configuring script parameters.</td>
</tr>
<tr>
<td>Initial-Script</td>
<td>The initial script of a Unified CCX Post Routing application (see Unified CCX Application Management). The value must be relative to the Scripts directory. Unified CCX does not support configuring script parameters.</td>
</tr>
</tbody>
</table>

- Attributes defined for application versioning and sealing information: These attributes define features of the application to which the AAR file belongs. These attributes are the same as those listed in Main Attributes, on page 153.
Unified CCX System Management

Unified CCX administration provides options to configure, control, and monitor Unified CCX component activities and information across a cluster.

**Note**
Support for High Availability and remote servers is available only in multiple-server deployments.

See the *Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, Release 9.0(1)* for instructions about tasks that significantly change your Unified CCX deployment, such as:

- Changing from a single-server deployment to a multiple-server deployment.
- Removing a Unified CCX Software component from a server.
- Moving a Unified CCX Software component to another server.
- Changes to a Unified CCX cluster (adding, removing, or replacing a server).

The following sections describe the day-to-day management of Unified CCX components.

- Basic Terminology, page 159
- High Availability and Automatic Failover, page 160
- Unified CCX CDS Information Management, page 161
- Manage System Parameters, page 161
- Unified CCX IP Address/hostname Management, page 166
- Exit Unified CCX Administration, page 179

**Basic Terminology**

This section provides information about different Unified CCX terminology.

- **Cluster**. A Unified CCX cluster (often referred to as cluster in this manual) consists of one or more servers (nodes) that are running Unified CCX components in your Unified CCX deployment. If you deploy Unified CCX components on a single server, the Unified CCX cluster consists of that server. If you deploy Unified CCX on multiple servers, the cluster includes the Unified CCX server and standby
server on which you installed Unified CCX. The Unified CCX cluster supports up to two Unified CCX servers, one designated as the active Unified CCX server and the other designated as the standby Unified CCX server for high availability purposes.

**Note** Support for High Availability and remote servers is available only in multiple-server deployments.

- **Cluster profile.** The Unified CCX Administration web page (home page) displays information about the cluster profile. A cluster profile includes data relating to the Unified CCX servers, components, and licenses installed in a cluster.
- **Node (server).** A server that is part of the Unified CCX cluster.
- **Active Server.** The active server provides all system services and resources. You can deploy one active server in each Unified CCX subsystem. If the active server fails, the Unified CCX subsystem automatically fails over to the standby server.
- **Standby Server.** You can deploy up to two servers in each Unified CCX system for high availability—one active server (master) and one standby (not active) server. With high availability, if an active server becomes unavailable, the standby server automatically becomes the active server.
- **Component.** The software units in the Unified CCX system. The main software components of the Unified CCX server are the Engine, datastores, monitoring, recording, and the Cluster View Daemon (CVD). See the *Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, Release 9.0(1)* for more information on setup and installation procedures.
- **Service.** An executable unit. A service may have other services as its children. (For example, subsystems and managers are children of the engine service).
- **Feature.** A logical representation of the functional unit.
- **Master service.** A specially-elected service. Only one service from the Engine service, desktop services, or database services set can be the master within the Unified CCX Engine component.
- **Standby service.** An active service that can take over the master functionality in case the master service becomes unavailable within the Unified CCX Engine component. You cannot configure the standby service. The Cluster View Daemon (CVD) dynamically elects the services on the active node to be the master.

**Related Topics**

*High Availability and Automatic Failover*, on page 160

**High Availability and Automatic Failover**

**Note** Support for High Availability (HA) and remote servers is available only in multiple-server deployments. Unified CCX does not support more than two nodes in a HA setup. Expansion servers where the Database, Monitoring, or Recording components are running on separate servers are not supported.
Unified CCX provides high availability and automatic failover capability through the use of two servers, the active server and the standby server.

The active server provides all system services and resources; no services or resources are available from the standby server. When you make administrative changes on the active server, both the servers are synchronized. If the active server fails, there is automatic failover to the standby server. For detailed information on HA over WAN deployment, see Cisco Unified CCX Solution Reference Network Design.

Network Partitions

Network malfunction or misconfiguration can create network partitions and split the network into separate islands. If a node enters this state, the node is referred to as being in the island mode. Nodes in the island mode are hard to detect. While these nodes can communicate within a partitioned island, they cannot communicate between partitioned islands. If the islands do not communicate, then each island will select its own active server.

Generally, you can connect to the Unified CCX administration on any node, and see a consistent cluster view. If a node is in the island mode, you will see different cluster views when you connect to nodes in each island.

**Note**

Support for High Availability and remote servers is available only in multiple-server deployments.

If your node enters the island mode, it should recover from the island mode as soon as the underlying network issue is resolved. If the island mode persists, check the network connectivity/reachability between the two CCX servers and take action accordingly.

Unified CCX CDS Information Management

The Unified CCX system stores configuration information in the Cisco Configuration Datstore Server (CDS). The Unified CCX Administration configurations are stored in the CDS.

**Note**

Support for High Availability and remote servers is available only in multiple-server deployments.

The Unified CCX server can receive directory information from one Cisco Unified Communications directory and application configuration and script logic from a repository on another server.

Manage System Parameters

The parameters in the System Parameters Configuration page are grouped logically into sections with headings. Each parameter has a corresponding suggested or default value on the right side of the page. Where applicable, radio buttons are used to toggle between the parameter options.

In this web page, you can configure the recording count, port settings, the default session timeout, and codec.
Changing some system parameters like IP address, Network Time Protocol (NTP) and so on can result in a different License MAC. You need to get rehosted license files (with new License MAC) in such cases within 30-day grace period beyond which the system will stop working.

Procedure

**Step 1** Choose **System > System Parameters** from the Unified CCX Administration menu bar. The System Parameters Configuration web page appears.

**Step 2** Click the **Update** icon that displays in the tool bar in the upper, left corner of the window or the **Update** button that displays at the bottom of the window. The system notifies all nodes in the cluster about the changes.

**Note** If Cluster View Daemon is in Shutdown state during this operation, then the changes just made are synchronized on that node when Cluster View Daemon is started again.

**Related Topics**

System Parameters Configuration Web Page, on page 162

System Parameters Configuration Web Page

The System Parameters Configuration web page displays the following fields.

**Table 9: System Parameters Configuration**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Generic System Parameters</strong></td>
<td></td>
</tr>
<tr>
<td>System Time Zone</td>
<td>The system or primary time zone will be the same as local time zone of the primary Unified CCX node configured during installation. Display only. Unified CCX Administration uses this primary time zone to display time-related data. <strong>Note</strong> If you have changed the primary time zone, you need to reboot both the nodes in the Unified CCX cluster.</td>
</tr>
<tr>
<td><strong>Network Deployment Parameters (displayed only in a HA over WAN deployment)</strong></td>
<td></td>
</tr>
<tr>
<td>Network Deployment Type</td>
<td>Displays the network deployment type as LAN or WAN only if we have more than one node. Display only.</td>
</tr>
<tr>
<td><strong>Internationalization Parameters</strong></td>
<td></td>
</tr>
<tr>
<td>Customizable Locales</td>
<td>Use to specify a unique locale. Default: (blank)</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Default Currency</td>
<td>Default currency, such as American dollars (USD), Euros, and so on. This is a mandatory field. The system uses the default currency for converting currency amounts in a playable format when no currency designator is specified. Default: American Dollar [USD]</td>
</tr>
</tbody>
</table>

**Media Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Codec</td>
<td>The codec chosen during installation for this Unified CCX server. Unified CCX supports packetization intervals of 20 ms, 30 ms, or 60 ms only. Default: 30 ms</td>
</tr>
<tr>
<td>Recording Count</td>
<td>The maximum number of simultaneous sessions that are supported with this system configuration. This value cannot be greater than the number of seats. This is a mandatory field. Note: Standard license package does not support recording. Premium package license supports recording, however, when you upgrade from Standard to Premium license package, you need to manually change this recording count to a suitable value based on the hardware type to enable recording functionality. Default: 0</td>
</tr>
<tr>
<td>Default TTS Provider</td>
<td>Default TTS (Text-to-Speech) provider. Default: By default, no TTS provider is configured. Select a provider from the drop-down list to configure it as the default. The system uses the default TTS provider to determine which provider to use if the TTS request does not explicitly specify the provider to use.</td>
</tr>
<tr>
<td>User Prompts override System Prompts</td>
<td>When enabled, custom recorded prompt files can be uploaded to the appropriate language directory under Prompt Management to override the system default prompt files for that language. By default, this is disabled.</td>
</tr>
</tbody>
</table>

**Application Parameters**
### Field | Description
--- | ---
**Supervisor Access** | The Administrator uses this option to allow certain privileges to supervisors (all supervisors have the same privilege). The options are:
- **No access to teams**—The supervisor logs into the Supervisor page, but will not be able to see any team information (No RmCm info).
- **Access to all teams**—The supervisor logs into the Supervisor page, and will be able to see all the teams (RmCm information).
- **Access to supervisor teams only**—The supervisor logs into the Supervisor page, and will be able to see the teams they supervise.

Default: No access to teams

**Note** A supervisor who does not have administrator privileges can add, modify, or remove skills from an agent.

**Max Number of Executed Steps** | The maximum number of steps an application can execute before the Unified CCX Engine terminates the script or application. This is a mandatory field. This limitation is intended to prevent a script from running indefinitely.
Default: 1000

**Note** Do not change the default value.

**Additional Tasks** | This field allows you to control the creation of additional threads that the Unified CCX server internally initializes based on licensed Unified IP IVR ports. This is a mandatory field.
Default: 0

**Default Session Timeout** | Maximum amount of time (in minutes) a user-defined mapping ID remains in the session object memory after the session is moved to the idle state. During this duration, the session continues to be accessible even if you have terminated that session. Use this setting to configure the time required to perform your after-call work (for example, writing variables to a database before clearing the session). This is a mandatory field.

The default is 30 minutes (recommended). If you reduce this number, you also reduce the system memory usage comparatively.

You can add a user-defined mapping ID to a session using the Session Mapping step in the script editor. Once assigned, you can use this mapping ID to get the session object from another application instance. By doing so, other applications obtain access to the session context. See the *Cisco Unified CCX Getting Started with Scripts guide* for more information.

**Enterprise Call Info Parameter Separator** | A character used to act as a delimiter for call data. This is a mandatory field.
Default: | (bar)
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Agent State after Ring No Answer           | Radio button determining how agent state should be set after a Ring No Answer event. This is a mandatory field. The options are:  
  • Ready. If an agent does not answer a call, the Agent State is set to Ready.  
  • Not Ready (default). If an agent does not answer a call, the Agent State is set to Not Ready.                                                 |
| Live Data - Short Term Reporting Duration  | This parameter applies to Live Data reports that are available to agents and supervisors on Finesse desktops. For certain fields in the live data reports, you can set the short term value to 5, 10 or 15 minutes. Long term value is always set to 30 minutes. |
| Number of Direct Preview Outbound seats    | The maximum number of Direct Preview Outbound seats. The configuration of Outbound seats is done during the initial configuration or setup phase, after the installation.  
  **Note** This is a mandatory field. This field is displayed only if you have a Premium license. The maximum number of direct preview outbound seats that can be configured is limited by the Premium Seat Count. If there is an invalid entry during configuration, an error message is displayed. |
| Persistent Connection                      | Radio button that determines whether to establish persistent connection to a remote device. The options are:  
  • Enable (default)—Establishes persistent connection.  
  • Disable—Does not establish persistent connection.                                                                                                                                                  |

**System Ports Parameters**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMI Port</td>
<td>The port number used by the Unified CCX CVD to serve RMI requests. This is a mandatory field. Default: 6999</td>
</tr>
<tr>
<td>RmCm TCP Port</td>
<td>TCP port number on which the CTI server component of the RmCm subsystem opens the server socket and listens to the clients. All CTI server clients, such as Cisco Agent Desktop, Unified ICME Server, Sync Server, and IP Phone Agent Server, use this port number. This is a read-only field and cannot be modified. Default: 12028</td>
</tr>
<tr>
<td>Master Listener</td>
<td>TCP port used for communication between CVD and Cisco Agent/Supervisor Desktop Services. This is a read-only field and cannot be modified. Default: 1994</td>
</tr>
</tbody>
</table>
Unified CCX IP Address/hostname Management

This section provides the steps you need to follow whenever there is a change in IP address/hostname for the following Unified CCX deployments:

- Unified CCX Cluster with Single-node
- Unified CCX Cluster with High Availability (HA)

You may want to change the IP address/hostname for a variety of reasons, including moving the server from one segment to another or resolving a duplicate IP address/hostname problem.

**Note**
Hostname change is supported in Cisco Unified CCX. Hostname should be in lower case and the character limit is 24 characters.

Prepare System for IP Address/host name Change

Perform the following tasks to ensure that your system is prepared for a successful IP address/host name change.

**Note**
If you do not receive the results that you expect when you perform these tasks, do not continue with this procedure until after you resolve any problems that you find. DB replication across the entire cluster is essential for this process.

**Procedure**

**Step 1** List all servers in the cluster and note whether the nodes are defined by using IP addresses or host names.

- From Cisco Unified CCX Administration menu bar on the first node, navigate to System > Server. A list of all servers in the cluster displays.
- See whether the servers are defined using IP addresses or host names and capture this list of servers for later reference. Ensure that you have saved an inventory of both the host name and IP address of each node in your cluster.

**Step 2** Ensure that all servers in the cluster are up and available by checking for any active ServerDown alerts. You can check by using either the Real Time Monitoring Tool (RTMT) or the Command Line Interface (CLI) on the first node.

- To check by using RTMT, access Alert Central and check for ServerDown alerts.
- To check by using the CLI on the first node, enter the following command and inspect the application event log:

```bash
file search activelog syslog/CiscoSyslog ServerDown
```
**Step 3** Check the DB replication status on all the Cisco CRS nodes and Cisco Unified Communications nodes in the cluster to ensure that all servers are replicating database changes successfully using the following substeps:

a) **For Unified CCX:** In a High Availability deployment of Unified CCX, you can check the DB replication status for the datastores across all servers in the cluster using Unified CCX Serviceability Administration. Choose **Tools > Datastore Control Center > Replication Servers** from the Unified CCX Serviceability menu bar to view the replication status. The value in State field for both the servers in this web page should display ACTIVE/CONNECTED.

b) **For Cisco Unified Communications Platform:** You can check the DB replication status on all the Cisco Unified Communications nodes in the cluster by using either RTMT or a CLI command.

   • To check by using RTMT, access the Database Summary and inspect the replication status.

   • To check by using the CLI, enter the command that is shown in the following example:

   ```
   admin: show perf query class "Number of Replicates Created and State of Replication"
   ==>query class :
   - Perf class (Number of Replicates Created and State of Replication)
   has instances and values:
   ReplicateCount  -> Number of Replicates Created  = 344
   ReplicateCount  -> Replicate_State            = 2
   ```

   Be aware that the Replicate_State object shows a value of 2 in this case. The following list shows the possible values for Replicate_State:

   • 0—Replication Not Started. Either no subscribers exist, or the Database Layer Monitor service is not running and has not been running since the subscriber was installed.

   • 1—Replicates have been created, but their count is incorrect.

   • 2—Replication is good.

   • 3—Replication is bad in the cluster.

   • 4—Replication setup did not succeed.

**Step 4** Run a manual DRS backup and ensure that all nodes and active services are backed up successfully.

**Step 5** Run the CLI command `utils diagnose module validate_network` through Platform CLI on all nodes in the cluster to ensure network connectivity and DNS server configuration are intact.

---

**IP Address Modification**

This section describes how to change the IP address.
Changing the IP address on any node in a Cisco CRS cluster can interrupt call processing and other system functions. Also, changing the IP address can cause the system to generate certain alarms and alerts such as ServerDown and automatic failover to a backup server may not operate. Because of this potential impact to the system, you must perform IP address changes during a planned maintenance window.

Caution
Changing the IP address on any node in a Cisco CRS cluster can interrupt call processing and other system functions. Also, changing the IP address can cause the system to generate certain alarms and alerts such as ServerDown and automatic failover to a backup server may not operate. Because of this potential impact to the system, you must perform IP address changes during a planned maintenance window.

Change IP Address for Server in Single-Node Deployment

Use this procedure to change the IP address of the server in a single-node deployment.

Procedure

**Step 1** Change the DNS record of the server to point to the new IP address. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

**Step 2** If you want to change the IP address of the server on the same subnet or a different subnet that requires a new default gateway address, use either of the following methods:

- CLI commands
- Cisco Unified Communications Operating System Administration interface

Using CLI commands:

**Note** Skip (a) if you want to change only the IP address of the server.

a) To change the default gateway, enter the following CLI command:

```
set network gateway <IP Address>
```

The following sample output displays:

```
admin:set network gateway 10.3.90.2
```

**WARNING:** Changing this setting will invalidate software license on this server. The license will have to be re-hosted.

Continue(y/n):

Continue (y/n)?y

Ensure that the server is moved to the new subnet and has access to the default gateway before proceeding to the following sub-step.

**Caution**
Ensure that the server is moved to the new subnet and has access to the default gateway before proceeding to the following sub-step.

b) To change the IP address of the server, enter the following CLI command:

```
set network ip eth0 <ip_address> <netmask> <default gateway>
```

where `ip_address` specifies the new server IP address and `netmask` specifies the new server network mask and `default gateway` specifies the default gateway of the new server.

The following sample output displays:

```
admin: set network ip eth0 10.3.90.21 255.255.254.0 10.3.90.1
```

**WARNING**
If there are IP addresses (not hostnames) configured in UCCX Administration under System -> Servers then you must change the IP address there BEFORE changing it here or call processing will fail. This will cause the
system to restart

Note: To recognize the new IP address all nodes within the cluster will have to be manually rebooted.

Do you want to continue?
Enter "yes" to continue and restart or any other key to abort.

Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:

Alternatively, you can change the IP address and default gateway of the server from Cisco Unified Communications Operating System Administration interface as follows:

• Choose Settings > IP > Ethernet.

• Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically with the new IP address.

Step 3 If you change the IP address, License MAC of the server will also change. Rehost the new license. Old license enters its grace period.

Step 4 From Cisco Desktop Administrator web page, choose Services Configuration > Silent Monitoring & Recording > Remove VoIP/Recording & Playback Services. Remove any VoIP Monitor Service or Recording & Playback Service listed, which uses the IP address that has been changed.

Step 5 Click Save and then restart all CAD services on the server after making these updates.

Note: When you change the IP address in a single-node deployment, CAD does not launch itself and you need to run the Cisco Unified CCX Desktop Client Configuration tool to update the client installations with the new IP address.

Related Topics

Verify Proper Function of System after IPAddress/host name Change, on page 178

IP Address Modification in High-Availability (HA) Deployment

Change IP Address for Publisher Server in HA Deployment

Use this procedure to change the IP address of publisher server in a HA deployment.

Procedure

Step 1 Change the DNS record of the publisher server to point to the new IP address. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utilities network host <IP Address> and show tech network hosts CLI commands on all the cluster nodes.

Step 3 From the Cisco Unified Operating System Administration page of the subscriber server in the cluster, perform the following tasks:
a) Navigate to Settings > IP > Publisher.
b) Change the IP address of the publisher server.

Step 4 To update new IP of the publisher server in subscriber, enter the following CLI command on the subscriber server:
```
utils uccx modify remote_IPAddress <Old_IP_of_Publisher> <New_IP_of_Publisher>
```
The following output displays:
```
Old Remote IP Address: 10.3.90.21
New Remote IP Address: 10.3.90.28
```
This command should be executed only in case you are changing IP Address of remote server. Are you sure you want to run this command?
Continue (y/n)? Enter y and press Enter.

Step 5 If you want to change the IP address of the server on the same subnet or a different subnet that requires a new default gateway address, use either of the following methods:
- CLI commands
- Cisco Unified Communications Operating System Administration interface

Using CLI commands:

Note Skip (a) if you want to change only the IP address of the server.

a) To change the default gateway, enter the following CLI command:
```
set network gateway <IP Address>
```
The following sample output displays:
```
admin:set network gateway 10.3.90.2
WARNING: Changing this setting will invalidate software license on this server. The license will have to be re-hosted.
Continue (y/n): Continue (y/n)? y
Caution Ensure that the server is moved to the new subnet and has access to the default gateway before proceeding to the following sub-step.

b) To change the IP address of the server, enter the following CLI command:
```
set network ip eth0 <ip_address> <netmask> <default gateway>
```
where ip_address specifies the new server IP address, netmask specifies the new server network mask and default gateway specifies the default gateway of the new server.
The following sample output displays:
```
admin:set network ip eth0 10.78.92.55 255.255.255.0 10.78.92.1
WARNING: Changing this setting will invalidate software license on this server. The license will have to be re-hosted.
Continue (y/n)? y
*** WARNING ***
This command will cause the system to restart
Note: Please verify that the new IP address is unique across the cluster, and if DNS services are utilized, any DNS configuration is completed before proceeding. To recognize the new IP address all nodes within the cluster will have to be manually rebooted.

Continue (y/n)? y

Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:

Alternatively, you can change the IP address and default gateway of the server from Cisco Unified Communications Operating System Administration interface as follows:

- Choose Settings > IP > Ethernet.
- Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically with the new IP address.

Step 6 Reboot all the servers in the cluster including the publisher using the CLI command `utils system restart`.

Note If you do not reboot the subscriber after the IP address change, all the services on the publisher may not start properly.

Step 7 If you change the IP address, License MAC will also change. Rehost the new license for the new LicenseMAC.

Old license enters its grace period.

Step 8 From Cisco Desktop Administrator web page, choose Services Configuration > Silent Monitoring & Recording > Remove VoIP/Recording & Playback Services. Remove any VoIP Monitor Service or Recording & Playback Service listed, which uses the IP address that has been changed.

Step 9 Click Save and then restart all CAD services on the server after making these updates.

Note When you change the IP address of publisher, CAD will connect to the subscriber and will update the IP address of the publisher automatically through its True Update functionality.

Related Topics

Verify Proper Function of System after IPAddress/host name Change, on page 178

Change IP Address for Subscriber Server in HA Deployment

Use this procedure to change the IP address of a subscriber server in a HA deployment.

Procedure

Step 1 Change the DNS record of the subscriber server to point to the new IP address. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the `utils network host <IP Address>` and `show tech network hosts` CLI commands on all the cluster nodes.

Caution Skip Step 3 if the server is defined by host name and you are changing only the IP address.

Step 3 From Cisco Unified CCX Administration page, perform the following tasks:
a) Navigate to System > Server. From the List Servers web page, click the IP address of the subscriber server. The Server Configuration page for the subscriber server opens.

b) Enter the new IP address in the Host Name/IP Address field and click Save.

Note You can use the CLI command `run sql select name,nodeid from ProcessNode` to check whether the new IP address has been replicated on all the servers.

**Step 4** To update new IP of the subscriber in publisher, enter the following CLI command on the publisher server:

`utils uccx modify remote_IPAddress <Old_IP_of_Subscriber> <New_IP_of_Subscriber>`

The following output displays:

```
admin:utils uccx modify remote_IPAddress 10.3.90.21 10.3.90.28
```

Old Remote IP Address: 10.3.90.21
New Remote IP Address: 10.3.90.28

This command should be executed only in case you are changing IP Address of remote server.
Are you sure you want to run this command?
Continue (y/n)?
Enter y and press Enter.

**Step 5** If you want to change the IP address of the server on the same subnet or a different subnet that requires a new default gateway address, use either of the following methods:

• CLI commands

• Cisco Unified Communications Operating System Administration interface

**Using CLI commands:**

**Note** Skip (a) if you want to change only the IP address of the server.

a) To change the default gateway, enter the following CLI command:

```
set network gateway <IP Address>
```

The following sample output displays:

```
admin:set network gateway 10.3.90.2
```

WARNING: Changing this setting will invalidate software license on this server. The license will have to be re-hosted.
Continue (y/n):
Continue (y/n)? y

Caution Ensure that the server is moved to the new subnet and has access to the default gateway before proceeding to the following sub-step.

b) To change the IP address of the server, enter the following CLI command:

```
set network ip eth0 <ip_address> <netmask> <default gateway>
```

where `ip_address` specifies the new server IP address, `netmask` specifies the new server network mask and `default gateway` specifies the default gateway of the new server.

The following sample output displays:

```
admin:set network ip eth0 10.78.92.55 255.255.255.0 10.78.92.1
```

WARNING: Changing this setting will invalidate software license
on this server. The license will have to be re-hosted.
Continue (y/n)? y

*** WARNING ***
This command will cause the system to restart
=======================================================================
Note: Please verify that the new ip address is unique
across the cluster and, if DNS services are
utilized, any DNS configuration is completed
before proceeding.
To recognize the new ip address all nodes within
the cluster will have to be manually rebooted.
=======================================================================
Continue (y/n)? y
Enter y and press Enter. This will automatically reboot this server with the new IP address.

Using Cisco Unified Communications Operating System Administration interface:
Alternatively, you can change the IP address and default gateway of the server from Cisco Unified
Communications Operating System Administration interface as follows:

- Choose Settings > IP > Ethernet.
- Change the IP address, default gateway, and netmask, and click Save. The server restarts automatically
with the new IP address.

Step 6 Reboot all the servers in the cluster including the publisher using the CLI command utils system restart.

Note If you do not reboot the subscriber after the IP address change, all the services on the publisher may
not start properly.

Step 7 From Cisco Desktop Administrator web page, choose Services Configuration > Silent Monitoring &
Recording > Remove VoIP/Recording & Playback Services. Remove any VoIP Monitor Service or
Recording & Playback Service listed, which uses the IP address that has been changed.

Step 8 Click Save and then restart all CAD services on the server after making these updates.

Host Name Modification

This section describes how to change the host name.

Caution Changing the host name on any node in a Cisco CRS cluster can interrupt call processing and other system
functions. Also, changing the host name can cause the system to generate certain alarms and alerts such
as ServerDown and automatic failover to a backup server may not operate. Because of this potential impact
to the system, you must perform host name changes during a planned maintenance window.

Change Host Name for Server in a Single-Node Deployment

Use this procedure to change the host name of the server in a single-node deployment.
Procedure

Step 1
Change the DNS record of the server to point to the new host name. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2
You can change the host name of the server either using the CLI (command line interface) command or using Cisco Unified Communications Operating System Administration interface. To change the host name using CLI command, go to step 3 or to change the host name using Cisco Unified Communications Operating System Administration interface go to step 4.

Step 3
At the CLI prompt, perform the following tasks:

a) Enter the CLI command `set network hostname` and press Enter.
   The following sample output displays:
   ```
   admin:set network hostname
   WARNING: Changing this setting will invalidate software license on this server. The license will have to be re-hosted.
   Continue(y/n):
   Continue (y/n)?y
   ```
   ```
   ctrl-c: To quit the input.
   *** W A R N I N G ***
   Do not close this window without first canceling the command.
   ```
   This command will automatically restart system services.
   The command should not be issued during normal operating hours.

   ```
   Note: Please verify that the new hostname is a unique name across the cluster and, if DNS services are utilized, any DNS configuration is completed before proceeding.
   ```
   ```
   Security Warning: This operation will regenerate all UCCX Certificates including any third party signed Certificates that have been uploaded.
   ```
   Continue (y/n)?y
   Enter the hostname:
   ```
   b) Enter y twice to continue and enter the hostname and press Enter.
   c) (If required) To change the IP address, follow the instructions on the screen.

   The server automatically reboots with the new host name.

Step 4
From Cisco Unified Communications Operating System Administration interface, perform the following task:

a) Choose Settings > IP > Ethernet.

b) Change the host name.
c) If required, change the IP address, subnet mask, and default gateway.
d) Click Save. The server automatically reboots with the new host name.

**Step 5**
On changing the host name/IP address, License MAC of the server changes. Rehost the new license. Old license enters its grace period.

**Step 6**
From Cisco Desktop Administrator web page, choose **Services Configuration > Silent Monitoring & Recording > Remove VoIP/Recording & Playback Services**. Remove any VoIP Monitor Service or Recording & Playback Service listed, which uses the host name or IP address that has been changed.

**Step 7**
Click Save and then restart all CAD services on the server after making these updates.

**Note**
When you change the host name or IP address in a single-node deployment, CAD does not launch itself and you need to run the Cisco Unified CCX Desktop Client Configuration tool to update the client installations with the new host name or IP address.

---

**Host Name Modification in High-Availability (HA) Deployment**

**Change Host Name for Publisher Server in HA Deployment**

Use this procedure to change the host name of publisher server in a HA deployment.

**Procedure**

**Step 1**
Change the DNS record of the publisher server to point to the new host name. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

**Step 2**
Verify that the DNS change propagates to other nodes by using the `utils network host <IP Address>` and `show tech network hosts` CLI commands on all the cluster nodes.

**Step 3**
To change the host name of the publisher on the subscriber node, use either of the following methods:

- CLI commands
- Cisco Unified Communications Operating System Administration interface

**Using CLI commands:**

a) Run the following CLI command on the subscriber node:

```
set network cluster publisher hostname <hostname>
```

where `hostname` is the new publisher.

The following output displays:

```
admin:set network cluster publisher hostname hijk-lmn-n1
```

New Remote hostname: hijk-lmn-n1

**Using Cisco Unified Communications Operating System Administration interface:**

From **Cisco Unified Communications Operating System Administration** interface of the subscriber server, perform the following tasks:

a) Navigate to **Setting > IP > Publisher**.
b) The Server Configuration page for the publisher server opens. Change the host name of Publisher server in the **Host Name** or **IP Address** field and then click **Save**.

**Step 4**

To change the host name of publisher server, use either of the following methods:

- CLI commands
- Cisco Unified Communications Operating System Administration interface

**Using CLI commands:**

a) Run the following CLI command on the publisher node:

```bash
set network hostname <hostname>
```

The following output displays:

```
admin:set network hostname hijk-lmn-n1
```

**WARNING:** Changing this setting will invalidate software license on this server. The license will have to be re-hosted.

Continue (y/n):

Continue (y/n)? y

*** W A R N I N G ***
This command will cause the system to restart

Note: Please verify that the new ip address is unique across the cluster and, if DNS services are utilized, any DNS configuration is completed before proceeding.

To recognize the new ip address all nodes within the cluster will have to be manually rebooted.

Continue (y/n)? y

Enter y and press Enter. The server automatically reboots with the new host name.

Using Cisco Unified Communications Operating System Administration interface:

Change the host name using Cisco Unified Communications Operating System Administration interface of the publisher server:

a) Choose **Settings > IP > Ethernet**.
b) Change the host name.
c) Click **Save**. The server automatically reboots with the new host name.

**Step 5**

Reboot all the servers in the cluster including the publisher using the CLI command `utils system restart`.

**Note**  If you do not reboot the subscriber, all the services on the publisher may not start properly.
Step 6 From the publisher node, run CLI command `utils dbreplication reset all` to resetup Unified CM database replication across the entire cluster.

Step 7 From the publisher node, run CLI command `utils uccx dbreplication reset` to setup Unified CCX database replication across the cluster.

Step 8 On changing the host name, License MAC changes. Rehost the new license for the new license MAC. Old license enters its grace period.

Step 9 From Cisco Desktop Administrator web page, choose Services Configuration > Silent Monitoring & Recording > Remove VoIP/Recording & Playback Services. Remove any VoIP Monitor Service or Recording & Playback Service listed, which uses the IP address that has been changed.

Step 10 Click Save and then restart all CAD services on the server after making these updates.

Note When you change the host name of publisher, CAD connects to the subscriber and updates the host name of the publisher automatically through its True Update functionality.

---

Change Host Name for Subscriber Server in HA Deployment

Use this procedure to change the host name of a subscriber server in a HA deployment.

Procedure

Step 1 Change the DNS record of the subscriber server to point to the new host name. Ensure that you correctly update both the forward (A) and reverse (PTR) records, and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the `utils network host <IP Address>` and `show tech network hosts` CLI commands on all the cluster nodes.

Step 3 To change the host name of the subscriber server, perform either of the following methods:

- CLI commands
- Cisco Unified Communications Operating System Administration interface

Using CLI commands:

a) Run the following CLI command on the subscriber server:

`set network hostname <hostname>`

The following output displays:

```
admin:set network hostname ijkl-mno-p2

WARNING: Changing this setting will invalidate software license on this server. The license will have to be re-hosted.
Continue (y/n):
Continue (y/n)?y
*** WARNING ***
This command will cause the system to restart
```

Note: Please verify that the new ip address is unique across the cluster and, if DNS services are utilized, any DNS configuration is completed before proceeding. To recognize the new ip address all nodes within...
the cluster will have to be manually rebooted.

Continue {y/n}?y

Enter y and press Enter. The server automatically reboots with the new host name.

Using Cisco Unified Communications Operating System Administration interface:

Change the host name using Cisco Unified Communications Operating System Administration interface of the subscriber server:

a) Choose Settings > IP > Ethernet.
b) Change the host name.
c) Click Save. The server automatically reboots with the new host name.

Step 4 Restart all the servers in the cluster using the CLI command `utils system restart`.

Note If you do not reboot the subscriber, all the services on the publisher may not start properly.

Step 5 From the publisher node, run CLI command `utils dbreplication reset all` to reset the Unified CM database replication across the entire cluster.

Step 6 From the publisher node, run CLI command `utils uccx dbreplication reset` to setup the Unified CCX database replication across the cluster.

Step 7 From Cisco Desktop Administrator web page, choose Services Configuration > Silent Monitoring & Recording > Remove VoIP/Recording & Playback Services. Remove any VoIP Monitor Service or Recording & Playback Service listed, which uses the IP address that has been changed.

Step 8 Click Save and then restart all CAD services on the server after making these updates.

Note When you change the host name of publisher, CAD connects to the subscriber and updates the host name of the publisher automatically through its True Update functionality.

---

Verify Proper Function of System after IP Address/host name Change

After you change the IP addresses/host names of your cluster, complete the following tasks:

Procedure

Step 1 Choose Tools > Plug-ins and click Cisco Unified CCX Desktop Suites from the Unified CCX Administration menu bar. From the Cisco Unified CCX web page, run the Cisco Unified CCX Desktop Client Configuration tool to update the client installations with the new IP addresses. On the client, if only one IP address in a HA system has been updated and the client is an XP machine with administrator privileges, then the Automatic Update process will update the registry the next time the user logs on. However, you will have to manually update the client's system by running `C:\Program Files\Cisco\Desktop\bin\PostInstall.exe` program, and update it with the correct IP addresses, if any of the following conditions are true:

- IP address/host name of a single-node deployment is changed
- Both IP addresses/host names in a HA system are changed
- Client OS is Microsoft Vista or Win7
Client does not have administrative rights

Step 2 Ensure that all the servers in the cluster are up and available.
Step 3 Check the DB replication status as described in Step 3 of Prepare System for IP Address/host name Change, on page 166 to ensure all the servers are replicating database changes successfully.
Step 4 Run a manual DRS Backup and ensure that all nodes and active services are successfully backed up.
Step 5 Run the CLI command `utils diagnose module validate_network` through platform CLI on all nodes in the cluster to ensure network connectivity and DNS server configuration are intact.
Step 6 If you have changed the IP address to move the Unified CCX server to a different network, then any firewall configuration on the other network must be changed to permit or deny traffic from the new IP address.
Step 7 If you have created any DSN using old IP address, change the DSN to point to the new IP. For example, the DSN created for Wallboard.
Step 8 Update the new IP address in the following web pages as well:

- Cisco Desktop Administrator > Cisco Unified Presence Settings > Cisco Unified Presence Cluster - Publisher Host/IP Address and Subscriber Host/IP Addresses
- Cisco Desktop Administrator > Agent E-Mail Settings > Global Settings - IMAP Server Host/IP Address and SMTP Server Host/IP Address
- Work Flow Configuration > User Interface > Browser Setup - URL and Home Page
- Work Flow Configuration > HTTP Action - Host
- Work Flow Configuration > IPC Action - IP Address
- Update the Recording configuration and the Cisco SocialMiner configuration in the Unified CCX Administration page on the Publisher server.

Step 9 For Cisco Finesse and Unified Intelligence Centers users, delete the certificates entries for the old hostname/IP Address from the web browser before you log in to Cisco Finesse Agent Desktop or Unified Intelligence Center.

Exit Unified CCX Administration

To exit Unified CCX Administration without closing your web browser, you can do either of the following:

>Note You can also exit Unified CCX Administration by closing your web browser.

Procedure

Step 1 Click the Logout link displayed in the top right corner of any Cisco Unified CCX Administration web page.
Step 2 Choose System > Logout from the Unified CCX Administration menu bar.
The system logs you out of Unified CCX and displays the Unified CCX Authentication web page.
Unified CCX Reporting

- Reporting Administration on Unified CCX, page 181
- Reporting Administration on Unified Intelligence Center, page 221

Reporting Administration on Unified CCX

Import of Stock Reports

To apply a patch if you import stock reports from Unified Intelligence Center, then run the CLI command `utils uccx synctocuic permission all` to reset the permissions of the user groups. For more information, see the “Command line interface” section of the Cisco Unified Contact Center Express Operations Guide, located at http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_maintenance_guides_list.html.

Note

Do not create a sub-category under the Stock category as the permissions for the Stock category is automatically reset at midnight.

Unified CCX Historical Reports

Historical reports are the preconfigured reports in Unified Intelligence Center. These reports access past data from the historical data source to display information for the specified period of time.

Unified CCX Historical Datastore

In a Unified CCX Cluster, there can be one or more Historical datastores.

Note

Support for High Availability and remote servers is available only in multiple-server deployments.

The Historical Unified CCX Datastore can be co-located only on the server with the Unified CCX Engine.
Historical Reporting Configuration

The Unified CCX Historical Reporting subsystem provides you with a way to set up and manage the purging of the Historical Reporting databases.

Setting up Unified CCX for Historical Reporting consists of the following tasks:

1. Database Server Configuration, on page 334
2. Configure Automatic Purging, on page 183

Configure Database Server Limits

To limit the performance impact of historical reporting on a particular Unified CCX server, you can configure a maximum number of five client/scheduler database connections per server.

To do so, complete the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Database Server Configuration.

The Database Server Configuration web page opens with the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name</td>
<td>The host name or IP Address of the database server.</td>
</tr>
<tr>
<td>Maximum DB Connections for Report Clients Sessions</td>
<td>The maximum number of client and scheduler connections that can access the Historical Reports Database server. There is a limit of instances for the reporting client sessions and the scheduler sessions based on the load that can be run on each server. The following are the limits:</td>
</tr>
<tr>
<td></td>
<td>• Standalone Setup—1 to 8 instances</td>
</tr>
<tr>
<td></td>
<td>• High Availability Setup—1 to 16 instances</td>
</tr>
</tbody>
</table>

Step 2 Enter a value in the Maximum DB Connections for Report Client Sessions field next to a Server Name.

Step 3 Click Update.

The configuration changes take effect.
View Historical Reports

You can view historical reports through the Unified Intelligence Center.

Procedure

Choose Tools > User Management > Reporting Capability View
The User Configuration web page opens.

Related Topics

Historical Report User Privileges, on page 265

Purge of Historical Data

As the Unified CCX Engine runs, it collects information about the status and performance of the Unified CCX system. Historical information is stored in a database that can then be accessed to provide reports (see the Cisco Unified CCX Historical Reports User Guide for more information about Unified CCX Historical Reports).

When the database approaches its maximum size, some or all of the data in it must be removed. Removing data from a database is called purging.

When the system purges data, it removes data from the db_cra database. It determines what information to purge based on the number of months you specify and on the current date. For example, if you instruct the system to purge data older than 12 months, a purge on January 15 will purge data older than January 15 of the previous year.

**Note**

When you purge data, you permanently delete it. If you want to keep data that will be purged, back up the database.

Unified CCX Administration provides the following features for purging historical reports from the database:

- Daily comparison of the size of the database to a user-specified maximum size
- User-specified time at which the system purges data
- Automatic purging of the database when it exceeds the user-specified maximum sizes
- Automatic purging of the database based on user-specified parameters
- Manual purging of the database

Configure Automatic Purging

The Unified CCX Engine performs automatic purging each day at a preset time.
To help keep your system running most efficiently, schedule automatic purging to run when your system is least busy. By default, daily purges are scheduled to run at 12:00 a.m. (00:00 Hrs), but you can change this time.

The system bases its purging activities on a variety of parameters. You can change the default value for any parameter as needed.

The following section contains the procedure for setting the daily purge schedule and auto purge.

Configure Purge Schedule Configuration Parameters

You can change the time of day that the system assesses the need to purge data and the age of data to purge. When data is purged, the Unified CCX sends a "Database purged" message. This message announces that a purge has taken place and includes an explanation of the purging activity. If the database is approaching its maximum size, then the Unified CCX sends the following message - "Database approaching maximum size".

The system can send notifications through the following two methods:

- Syslog (system log)
- SNMP traps

To set the purge schedule configuration parameters, complete the following steps.

Procedure

Step 1

From the Unified CCX Administration menu bar, choose **Tools > Historical Reporting > Purge Schedule Configuration**.

The Purge Schedule Configuration area opens. The following fields are displayed in the Purge Schedule Configuration area.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Purge Schedule</strong></td>
<td></td>
</tr>
<tr>
<td>Daily purge at</td>
<td>Time of day for the daily purge along with the time zone. The time that appears here is based on the primary time zone, which is specified during initial setup of Unified CCX Administration. In a High Availability over WAN deployment, the purge schedule will happen at the time zone of the primary node.</td>
</tr>
<tr>
<td>Purge data older than</td>
<td>Data can persist for a number of months before being purged.</td>
</tr>
</tbody>
</table>

**Note**

Unified CCX to Unified Intelligence Center sync runs as part of the purge. It synchronizes the users, teams and grants Live Data report permissions.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initiate automatic purge when database exceeds</td>
<td>Percentage of the maximum database size at which an automatic purge is initiated (as compared to the total available size).</td>
</tr>
<tr>
<td>Auto purge data for the oldest</td>
<td>Age of data to be purged.</td>
</tr>
</tbody>
</table>

**Step 2** From the drop-down list in the Daily purge at field, choose a time of day at which the system determines if purging is necessary.

**Step 3** From the drop-down list in the Purge data older than field, choose the required number of months. If the system determines that purging is necessary, it will purge both databases of data that is older than the number of months specified in this field.

**Step 4** From the drop-down list in the Initiate automatic purge when database size exceeds field, accept the default, or choose another number.

**Step 5** From the drop-down menu in the Auto purge data for the oldest field, accept the default of 15, or choose another number.

**Step 6** Click Update icon that displays in the tool bar in the upper, left corner of the window or the Update button that displays at the bottom of the window. The new purge schedule configuration is added to the Unified CCX system.

---

### Purge Manually

You can manually purge the databases at any time. This action will not affect the automatic purging schedule.

**Note** Support for High Availability is available only in multiple-server deployments.

To manually purge historical data, complete the following steps.

### Procedure

**Step 1** From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Purge Now. The Purge Now web page opens. The Purge data older than field is displayed in the Purge Now web page. You can specify this field in months and days.

**Step 2** From the drop-down list in the Purge data older than $N$ months field, keep the default (13 months) or specify the required number of months. If the system determines that purging is necessary, it will purge both databases of data that is older than the number of months specified in this field.

The Initiate automatic purge when database exceeds field displays the current historical database size as compared to the total available size.
Step 3 From the drop-down list in the Purge data older than \( N \) days field, keep the default (15 days) or specify the required number of days. If the system determines that purging is necessary, it will purge both databases of data that is older than the number of days specified in this field.

Step 4 Click **Purge Now**. The database purge is initiated in the server and the Purge Now area refreshes.

### Related Topics

- [Configure Purge Schedule Configuration Parameters](#), on page 184

### File Restore

Use the File Restore menu option to restore the database records written to HR files when the database goes down.

### Related Topics

- [File Restore Option](#), on page 335

### Unified CCX Real-Time Reports

When the Unified CCX system is configured and functioning, you can run reports to monitor real-time activity using the Unified CCX Administration web interface.

You must be logged into the Unified CCX Administration web interface to run Unified CCX real-time reports. If you have the Cisco Agent Desktop and Cisco Supervisor Desktop, you also can run real-time reports directly from these applications. Cisco Agent Desktop and Cisco Supervisor Desktop do not use the same calculations or data display methods as those that Unified CCX real-time reporting uses. Therefore, a report run using Unified CCX real-time reporting and a report run using Cisco Supervisor Desktop may not display the same information for a given statistic. To avoid confusion, it might help to make one of these tools your standard reporting tool.

**Caution**

While Unified CM supports Unicode characters in first and last names, those characters become corrupted in Unified CCX Administration web pages for RmCm configuration, Real Time Reporting, Cisco Agent/Supervisor Desktop.

The following sections provide more information about real-time Unified CCX data:

### Available Unified CCX Real-Time Reports

Unified CCX real-time reporting provides real-time reports you can use to monitor Unified CCX system activity. The following table briefly describes each of these reports.

<table>
<thead>
<tr>
<th>Report</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Tasks</td>
<td>Provides information about currently active applications.</td>
</tr>
<tr>
<td>Report</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Application Tasks Summary</td>
<td>Provides a summary of specific application activity.</td>
</tr>
<tr>
<td>Applications</td>
<td>Provides a list of all applications loaded on the Unified CCX server.</td>
</tr>
</tbody>
</table>
| Contacts Summary | Provides information for call contacts, email contacts, and HTTP contacts. Also provides the total number of contacts.  
**Note** Calls made by the Outbound subsystem will not be displayed in the Contacts Summary Real-Time Report. |
| Contacts | Provides information about currently active contacts. |
| Chat CSQ Cisco Unified Contact Center Express Stats | Provides information about Chat CSQ activity. This report is available only if Unified CCX has been configured. |
| Chat Resource Cisco Unified Contact Center Express Stats | Provides information about Chat Unified CCX resources activity. |
| CSQ Cisco Unified Contact Center Express Stats | Provides information about CSQ activity. This report is available only if Unified CCX has been configured. |
| Data Source Usage | Provides information about configured data source names (DSNs). |
| Engine Tasks | Provides information about currently active Engine tasks. |
| Preview Outbound Campaign Cisco Unified Contact Center Express Stats | Provides information about real-time Unified CCX information for the Outbound preview dialer. |
| Outbound Campaign Stats | Provides real-time statistics on IVR and agent based progressive and predictive Outbound campaigns since the statistics were last reset.  
**Note** This report will be available only if you have an Outbound license on top of the Unified CCX premium license in your Unified CCX. |
| Overall Outbound Stats | Provides real-time statistics across all IVR and agent based progressive and predictive Outbound campaigns since the statistics were last reset.  
**Note** This report will be available only if you have an Outbound license on top of the Unified CCX premium license in your Unified CCX. |
| Overall Chat Cisco Unified Contact Center Express Stats | Provides information about Chat Unified CCX resources and contact information. This report is available only if Unified CCX has been configured. |
Report | Description
--- | ---
Overall Cisco Unified Contact Center Express Stats | Provides information about Unified CCX resources and calls. This report is available only if Unified CCX has been configured.
Resource Cisco Unified Contact Center Express Stats | Provides information about Unified CCX resources activity.
Sessions | Provides information on all active sessions.

**Related Topic**

Report Menu, on page 192

**Open Real-Time Reports**

Real-Time reporting is available from the Unified CCX Administration web interface.

Real-Time Reporting requires the Java plug-in. If the Java plug-in is not already installed on the PC on which you are viewing the reports, the Unified CCX system automatically installs it when you choose **Tools > Real Time Reporting**.

*Note*
If you are using Firefox, you must manually install the correct version of JRE to use real-time reports.

The Application Reporting web page is a stand-alone component of the Unified CCX Administration interface. It has its own menubar, which replaces the Unified CCX Administration menu bar.

To open real-time reporting, complete the following steps.

**Procedure**

**Step 1** If you are running Real-Time Reporting for the **first time** on this system, log into Unified CCX Administration as an **Administrator**. The system prompts you to download the Java plug-in; follow the prompt instructions.

*Note* After you perform the initial download of the Real-Time Reporting Java plug-in, non-Administrative users can access Real-Time Reporting on this system.

**Step 2** Choose **Tools > Real-Time Reporting** from the Unified CCX Administration menu bar. The Application Reporting web page opens in a new window. The real-time reporting tool requires a Java plug-in. If the plug-in is not installed on the machine you are using, the Unified CCX system prompts you to accept the automatic installation of the plug-in. If you do not accept the installation, you cannot use real-time reporting.
Run Reports

Open the real-time reporting tool from the Unified CCX Administration web interface to run reports.

To run a real-time report, complete the following steps.

Procedure

Step 1
From the Application Reporting menu bar, choose Reports.

Step 2
From the Reports menu, choose the report to run.

The report opens in the Application Reporting window.

View Detailed Subreports

You can view more detailed information for selected items in these four reports:

• Application Tasks report
• Contacts report
• Applications report
• Sessions report

To view detailed subreports, complete the following steps.

Procedure

Step 1
Run the Application Tasks, Contacts, Applications, or Sessions report.

Step 2
Click a line in the report for which you want to view more detailed information. For example, click an email address in the Contacts report.

Step 3
From the Application Reporting menu bar, choose Views and click the subreport that you want to run.

You can also open a subreport by right-clicking the selected item and choosing a subreport.

The subreport opens.

Related Topics

Application Reporting User Interface, on page 192

Report Menu, on page 192

Views Menu, on page 218
**Print Reports**

To facilitate printing, you can open a printable version of a report.

To print a report, complete the following steps.

**Procedure**

**Step 1** Run a report.

**Step 2** From the Application Reporting menu, choose **Tools > Open Printable Report**.

A printable version of the report opens in a separate window.

**Step 3** Print the report using your browser print functionality.

---

**Reset Report Statistics**

The Unified CCX system automatically resets all statistics each day at midnight. You can reset the accumulated statistics manually at any time. Resetting statistics does not reset active statistics, such as active contacts and active tasks.

To reset report statistics, complete the following steps.

**Procedure**

**Step 1** From the Application Reporting menu bar, choose **Tools > Reset All Stats**.

The Reset Stats dialog box opens for you to confirm the reset.

**Step 2** Click **Yes**.

Accumulated statistics are reset.

---

**Clear Contact Option for Stuck Calls**

You may sometimes see a Contact/Call as waiting in Real Time Reports in CSQ Stats, and even though there are available Agents in the queue, the call does not seem to get routed to these Agents. The waiting time for the Queued call accumulates and will not clear even if the user activates "Reset All Stats" option from the Real-Time Reporting menu.

To enable clearing such stuck call entries from the system, Unified CCX system provides the Clear Contact option. This has the ability to clear stuck calls in the system without requiring a restart of the engine.

**Related Topics**

- [Clear Contact Menu](#), on page 217
Set Report Options

You can set the following reporting options:

- Refresh interval
- Number of times that the Unified CCX Administration web interface should attempt to reconnect to the Unified CCX server
- Whether logged off users appear in reports

To set report options, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Settings > Options. The Options dialog box opens.
Step 2 From the Polling Interval drop-down menu, choose the refresh rate in seconds.
Step 3 From the Server Connect Retry Count drop-down menu, choose the number of times that the Unified CCX Administration web interface should attempt to reconnect to the Unified CCX server.
Step 4 From the Show Logged Off Resources drop-down menu, choose whether logged-off agents appear in reports.
Step 5 Click Apply to apply the settings.

Set Report Appearance

You can select from three report appearances:

- Windows, which displays reports in colors based on your Windows settings
- Motif, which displays reports in purple and menu items in brown
- Metal, which displays reports in grey and menu items in black

To set the report appearance:

Procedure

Choose Settings from the Application Reporting menu bar and click the appearance that you want.

Related Topics

Settings Menu, on page 220
Application Reporting User Interface

Note Support for High Availability and remote servers is available only in multiple-server deployments.

When you choose Tools > Real-Time Reporting from the Unified CCX Administration menu, the Application Reporting tool opens a web page in a new window.

The Application Reporting tool menu bar contains the following options:

- **Report**—Choose this option to display a list of the available top-level real-time reports.
- **Tools**—Choose this option to reset all the statistics and refresh connections.
- **Settings**—Choose this option to set the look and feel of the real-time Reporting client, set the polling (refresh) interval times, and set the amount of times the server will attempt to reconnect.
- **Help**—Choose this option to display system information and to access Unified CCX online help.

Report Menu

Note All real-time reports display a Last Updated At field, which indicates the time of the snapshot. All summary reports display both a start time (which indicates when the summary statistics started being collected) and the current time. All real-time reports display a Connected or Not Connected status for each node in the cluster.

The Report menu provides access to a variety of top-level reports. It contains the following menu options:

- Contacts Summary Real-Time Report, on page 193
- Application Tasks Summary, on page 195
- Application Tasks Real-Time Report, on page 195
- Engine Tasks Real-Time Report, on page 196
- Contacts Report, on page 197
- Applications Report, on page 200
- Sessions Report, on page 201
- Data Source Usage Report, on page 201
- Overall Cisco Unified Contact Center Express Stats Report, on page 202
- CSQ Cisco Unified Contact Center Express Stats Report, on page 205
- Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report, on page 206
- Outbound Campaign Stats Report, on page 211
- Overall Outbound Stats Report, on page 213
- Resource Cisco Unified Contact Center Express Stats Report, on page 214
Failover Behavior for Unified CCX Stats, on page 216

**High Availability (HA) Setup**

In an HA setup, real-time reports obtain data from both nodes in the cluster.

- Support for High Availability and remote servers is available only in multiple-server deployments.
- In case of island mode where each node (on either side of the network) assumes mastership and handles calls, the real-time reports may not report accurate data.

Failover in a two-node cluster is available for Unified IP IVR reports as described in the following table.

<table>
<thead>
<tr>
<th>Failover Scenario</th>
<th>Connection Status</th>
<th>Node 1 Status</th>
<th>Node 2 Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both nodes are up</td>
<td>Fully Connected</td>
<td>Node ID current/start-time</td>
<td>Node ID current/start-time</td>
</tr>
<tr>
<td>Node 1 is up</td>
<td>Partially Connected</td>
<td>Node ID current/start-time</td>
<td>Node ID Not Connected</td>
</tr>
<tr>
<td>Node 2 is down</td>
<td>Partially Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID current/start-time</td>
</tr>
<tr>
<td>Node 1 is down</td>
<td>Partially Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID current/start-time</td>
</tr>
<tr>
<td>Both nodes are down</td>
<td>Not Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID Not Connected</td>
</tr>
</tbody>
</table>

Unified CCX real-time reports obtain data only from the current master node—failover in a two-node cluster is available as described in the following table.

<table>
<thead>
<tr>
<th>Failover Scenario</th>
<th>Connection Status</th>
<th>Node 1 Status</th>
<th>Node 2 Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both nodes are up</td>
<td>Fully Connected</td>
<td>Node ID current/start-time</td>
<td>Node ID Not Connected</td>
</tr>
<tr>
<td>Node 1 is master</td>
<td>Fully Connected</td>
<td>Node ID current/start-time</td>
<td>Node ID Not Connected</td>
</tr>
<tr>
<td>Node 2 is down</td>
<td>Fully Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID current/start-time</td>
</tr>
<tr>
<td>Node 1 is down</td>
<td>Fully Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID current/start-time</td>
</tr>
<tr>
<td>Both nodes are down</td>
<td>Not Connected</td>
<td>Node ID Not Connected</td>
<td>Node ID Not Connected</td>
</tr>
</tbody>
</table>

**Contacts Summary Real-Time Report**

Use the Contacts Summary report to view specific contact information for call contacts, email contacts, HTTP contacts, and total number of contacts.

To access the Contacts Summary real-time report, choose **Reports > Contacts Summary** from the Application Reporting menu bar.
You display the data on this report as numbers or percentages by clicking the Display Value/Display % toggle button.

The following fields are displayed on the Contacts Summary report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>Active contacts that are currently running.</td>
</tr>
<tr>
<td>Inbound</td>
<td>Number of inbound contacts since the statistics were last reset.</td>
</tr>
<tr>
<td>Outbound</td>
<td>Number of outbound contacts since the statistics were last reset.</td>
</tr>
<tr>
<td>Connected</td>
<td>Number of connected contacts since the statistics were last reset.</td>
</tr>
<tr>
<td></td>
<td>Provides a total for contacts that are connected to resources (for example, a call connected to an ACD agent).</td>
</tr>
<tr>
<td>Terminated</td>
<td>Number of terminated contacts since the statistics were last reset.</td>
</tr>
<tr>
<td></td>
<td>This row reports contacts that are ended normally by the application (for example, a caller hangs up and the application terminates), indicating whether the contact was terminated:</td>
</tr>
<tr>
<td></td>
<td>• Locally—On the local server.</td>
</tr>
<tr>
<td></td>
<td>• Remotely—On a remote server in the cluster.</td>
</tr>
<tr>
<td>Rejected</td>
<td>Number of rejected contacts since the statistics were last reset.</td>
</tr>
<tr>
<td></td>
<td>This row reports contacts that are not accepted and processed (as a result, for example, of insufficient resources or the rejection of the contact based on some customer-defined logic). Indicates the reason code for the reject:</td>
</tr>
<tr>
<td></td>
<td>• Channels busy</td>
</tr>
<tr>
<td></td>
<td>• No channel license</td>
</tr>
<tr>
<td></td>
<td>• No trigger</td>
</tr>
</tbody>
</table>

Note: Use the + toggle button to access these statistics.
**Field** | **Description**
--- | ---
Aborted | Number of aborted contacts since the statistics were last reset. This row reports contacts improperly ended by a task associated with the application (as when, for example, the system generates an exception or can not invoke the application because of some error in the application) and includes the associated Java exception code.

**Note** | Java exception codes are dynamic, as they can be generated from a variety of sources.

**Note** | Use the + toggle button to access these statistics.

Handled | Number of handled contacts since the statistics were last reset. This row reports contacts that are explicitly marked "Handled" by the application (typically when the application connects the contact to a Unified CCX agent).

Abandoned | Number of abandoned contacts since the statistics were last reset. This row reports contacts that end without being marked "Handled" by the application.

**Application Tasks Summary**
Use the Application Tasks Summary report to display statistics that summarize the activity of specific applications.

To access the Application Tasks Summary real-time report, choose **Reports > Application Tasks Summary** from the Application Reporting menu bar.

The following fields are displayed on the Application Tasks Summary report.

**Field** | **Description**
--- | ---
Application Name | Names of the applications that are running or have run.
Running | Currently running applications.
Completed | Applications that have stopped running.
Total | Number of times an application was invoked since the statistics were last reset.
DTMF VB and AA | Application names configured from the Unified CCX Administration.
Status | Displays the failover connection status. The possibilities are: Fully connected, Partially connected, and Not connected. See the following tables for detailed status information for Unified IP IVR and Unified CCX reports.

**Application Tasks Real-Time Report**
Use the Application Tasks real-time report to view information about currently active applications.

To access the Application Tasks report, choose **Reports > Application Tasks** from the Application Reporting menu bar. The following fields are displayed on the Application Tasks report.
If this report indicates that an application is running for an unusually long time, there may be a problem with the application. The application script may not include error handling that prevents infinite retries if a call is no longer present. If the application does not receive a disconnect signal after a call, the application repeatedly retries to locate the call, and causes the application to run for an unusually long time. To prevent this problem, include the proper error handling in the application script.

**Engine Tasks Real-Time Report**

Use the Engine Tasks real-time report to view information about currently active Engine tasks.

To access the Engine Tasks report, choose **Reports > Engine Tasks** from the Application Reporting menu bar.

The following fields are displayed on the Engine Tasks report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Unique identifier of the engine task.</td>
</tr>
<tr>
<td></td>
<td>If the engine task is the main task running the application and the parent ID is empty, its identifier will match the Application Task Identifier.</td>
</tr>
<tr>
<td>Parent ID</td>
<td>Unique identifier for the parent of the engine task (if any).</td>
</tr>
<tr>
<td>Node ID</td>
<td>Unique identifier for a server in the cluster.</td>
</tr>
<tr>
<td>Server IP Address</td>
<td>IP address identifying the server in the cluster.</td>
</tr>
<tr>
<td>Script</td>
<td>Name of the script that is running the task (if the task is running a Unified CCX script).</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time that the task started.</td>
</tr>
<tr>
<td>Duration</td>
<td>Length of time the task has been active.</td>
</tr>
</tbody>
</table>
Contacts Report

Use the Contacts real-time report to view information for all the active contacts for all servers across clusters.

Support for High Availability and remote servers is available only in multiple-server deployments.

To access the Contacts report, choose Reports > Contacts from the Application Reporting menu bar.

You can access detailed information about specific contacts listed on the Contacts web page by performing one of the following procedures:

- Call Contacts Detailed Info Report, on page 198
- Email Detailed Info Report, on page 198
- HTTP Detailed Info Report, on page 199

The following fields are displayed on the Contacts report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Unique identifier representing a contact.</td>
</tr>
<tr>
<td>Type</td>
<td>Type of contact: Unified CM Telephony call, Cisco agent call, or Cisco HTTP Contact.</td>
</tr>
<tr>
<td>Impl ID</td>
<td>Unique identifier provided by the particular type of contact. For example, for a call contact, this identifier would represent the Unified CM global call ID.</td>
</tr>
<tr>
<td>Node ID</td>
<td>Unique identifier for a server in the cluster.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time stamp when the contact was created.</td>
</tr>
<tr>
<td>Duration</td>
<td>Length of time that the contact is active.</td>
</tr>
<tr>
<td>Handled</td>
<td>If True, the contact is handled; if False, the contact is not handled.</td>
</tr>
<tr>
<td>Aborting</td>
<td>If True, the contact is aborted with a default treatment; if False, the contact is not aborted.</td>
</tr>
<tr>
<td>Application</td>
<td>Name of the application currently managing the contact.</td>
</tr>
<tr>
<td>Task</td>
<td>Unique identifier of the application task that is currently responsible for the contact.</td>
</tr>
<tr>
<td>Session</td>
<td>Unique identifier of the session currently managing the contact (if any).</td>
</tr>
</tbody>
</table>

The information displayed is dependent on the type of contact selected. Depending on the type of call, some fields may not be supported and will appear blank.
Call Contacts Detailed Info Report

Use the Call Contacts Detailed Info real-time report to view all information related to the call contact.

To access the Call Contacts Detailed Info report, right-click a specific call contact record on the Contacts report; information for that specific record displays.

The following fields are displayed on the Call Contacts Detailed Info report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Current state of the contact.</td>
</tr>
</tbody>
</table>
| Inbound                | If True, this call was received by the Unified CCX server; if False, this call 
                        | was placed as an outbound call by an application.                           |
| Language               | The selected language context of the call.                                  |
| Application ID         | Unique identifier of the associated application.                            |
| Called Number          | Called number for this call leg from the perspective of the called party.   |
| Dialed Number          | Dialed number for this call leg from the perspective of the calling party. |
| Calling Number         | Calling number of the originator of this call.                              |
| ANI                    | Automatic number identification.                                           |
| DNIS                   | Dialed number identification service.                                       |
| CLID                   | Caller ID.                                                                  |
| Arrival Type           | Information on how the call contact arrived in the system.                 |
| Last Redirected Number | Number from which the last call diversion or transfer was invoked.          |
| Original Called Number | Originally called number.                                                   |
| Original Dialed Number | Originally dialed number.                                                   |
| ANI Digits             | Automatic Number Identification information indicator digit codes.        |
| CED                    | Entered digits that were gathered by the network before the call was received. |

Note: Calls running Unified ICME applications are also reported here.

Email Detailed Info Report

Use the Email Detailed Info real-time report to view all information related to the email contact.
To access the Email Detailed Info report, right-click a specific email contact record on the Contacts report; information for that specific record displays.

The following fields are displayed on the Email Detailed Info report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Current state of the contact.</td>
</tr>
<tr>
<td>Inbound</td>
<td>If True, this email message was received by the Unified CCX server; if False, this email was created by an application.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Inbound email messages are not currently supported.</td>
</tr>
<tr>
<td>Language</td>
<td>Selected language context of the email message.</td>
</tr>
<tr>
<td>Application ID</td>
<td>Unique identifier of the associated application.</td>
</tr>
<tr>
<td>From</td>
<td>Sender of this email message.</td>
</tr>
<tr>
<td>To</td>
<td>All the recipients of this email message.</td>
</tr>
<tr>
<td>Subject</td>
<td>“Subject” field of this email message.</td>
</tr>
<tr>
<td>Attachments</td>
<td>List of all attachments (file names) associated with this email message.</td>
</tr>
</tbody>
</table>

HTTP Detailed Info Report

Use the HTTP Detailed Info real-time report to view all information related to the HTTP contact.

To access the HTTP Detailed Info report, right-click a specific HTTP contact record in the Contacts report; information for that specific record displays.

The following fields are displayed on the HTTP Detailed Info report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Current state of the contact.</td>
</tr>
<tr>
<td>Inbound</td>
<td>If True, this HTTP request was received by the Unified CCX server; if False, this HTTP request was created by an application.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This information will always be reported as True, because the Unified CCX server does not currently track outbound HTTP requests in this way.</td>
</tr>
<tr>
<td>Language</td>
<td>Language currently associated with the HTTP request.</td>
</tr>
<tr>
<td>Application ID</td>
<td>Unique identifier of the associated application.</td>
</tr>
<tr>
<td>Authentication Type</td>
<td>Name of the authentication scheme used to protect the servlet; for example, “BASIC” or “SSL.”</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Character Encoding</td>
<td>Length, in bytes, of the request body, which is made available by the input stream, or -1 if the length is not known. &lt;br&gt;<strong>Note</strong> This length is the same as the value of the CGI² variable CONTENT_LENGTH.</td>
</tr>
<tr>
<td>Content Length</td>
<td>MIME type of the body of the request, or null if the type is not known. &lt;br&gt;<strong>Note</strong> This is the same as the value of the CGI variable CONTENT_TYPE.</td>
</tr>
<tr>
<td>Content Type</td>
<td>Type of HTTP contact request.</td>
</tr>
<tr>
<td>Request Language</td>
<td>Preferred language for client content (the language that the client accepts for its content), based on the Accept-Language header.</td>
</tr>
<tr>
<td>Path Info</td>
<td>Any extra path information associated with the URL the client sent when the HTTP request was made.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Name and version of the protocol the request uses in the form: protocol/majorVersion.minorVersion; for example, HTTP/1.1 &lt;br&gt;<strong>Note</strong> This value is the same as the value of the CGI variable SERVER_PROTOCOL.</td>
</tr>
<tr>
<td>Remote Address</td>
<td>IP address of the client that sent the request &lt;br&gt;<strong>Note</strong> This value is the same as the value of the CGI variable REMOTE_ADDR.</td>
</tr>
<tr>
<td>Remote Host</td>
<td>Fully qualified name of the client that sent the request, or the IP address of the client, if the name cannot be determined &lt;br&gt;<strong>Note</strong> This value is the same as the value of the CGI variable REMOTE_HOST.</td>
</tr>
<tr>
<td>Remote User</td>
<td>Login of the user making this request, if the user has been authenticated.</td>
</tr>
<tr>
<td>Requested Session ID</td>
<td>HTTP session ID as specified by the client.</td>
</tr>
<tr>
<td>Request URL</td>
<td>Section of the URL of the HTTP request, from the protocol name up to the query string in the first line of the HTTP request.</td>
</tr>
</tbody>
</table>

² CGI = Common Gateway Interface

**Applications Report**

Use the Applications real-time report to view all the applications loaded on the server.

To access the Applications report, choose **Reports > Applications** from the Application Reporting menu bar.

The following fields are displayed on the Applications report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Unique name of the currently loaded application.</td>
</tr>
</tbody>
</table>
### Field 
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Application ID.</td>
</tr>
<tr>
<td>Type</td>
<td>Type of application that is currently running (for example, a Cisco Script Application).</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the application as entered on the Unified CCX Administration website.</td>
</tr>
<tr>
<td>Enabled</td>
<td>If True, the application is enabled; if False, the application is disabled.</td>
</tr>
<tr>
<td>Max. Sessions</td>
<td>Maximum number of simultaneous task instances that can run simultaneously on the Unified CCX server.</td>
</tr>
<tr>
<td>Valid</td>
<td>If True, the application is valid; if False, the application is invalid.</td>
</tr>
</tbody>
</table>

3 An application is valid if it was successfully loaded and initialized from its configuration. At any time, an application can become invalid if it internally fails to be refreshed.

### Sessions Report

Use the Sessions real-time report to view real-time information on all the active sessions.

To access the Sessions report, choose **Reports > Sessions** from the Application Reporting menu bar.

The following fields are displayed on the Sessions report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Session ID.</td>
</tr>
<tr>
<td>Note</td>
<td>This identifier is guaranteed to remain unique for a period of 12 months.</td>
</tr>
<tr>
<td>Mapping ID</td>
<td>User- or system-defined identifier that maps to this session.</td>
</tr>
<tr>
<td>Node ID</td>
<td>Unique identifier for a server in the cluster.</td>
</tr>
<tr>
<td>Parent</td>
<td>Sessions that were created as a result of consult calls propagated in the system.</td>
</tr>
<tr>
<td>Creation Time</td>
<td>Creation time of the session.</td>
</tr>
<tr>
<td>State</td>
<td>Current state of the session.</td>
</tr>
<tr>
<td>Note</td>
<td>When marked IDLE, the session is subject to being &quot;garbage collected&quot; by the system after a specified period of time. In addition, a session is IN_USE if it still has a contact associated or a child session.</td>
</tr>
<tr>
<td>Idle Time</td>
<td>Length of time that the session has been idle.</td>
</tr>
</tbody>
</table>

### Data Source Usage Report

Use the Data Source Usage real-time report to view real-time information on all configured Data Source Names (DSNs).

To access the Data Source Usage report, choose **Reports > Datasource Usage** from the Application Reporting menu bar.
The following fields are displayed on the Data Source Usage report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source Name</td>
<td>Name of the data source, as configured through the Unified CCX Administration web interface.</td>
</tr>
<tr>
<td>Available Connections</td>
<td>Number of connections available.</td>
</tr>
<tr>
<td>Busy Connections</td>
<td>Number of busy connections.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Busy + available = Maximum number of connections configured.</td>
</tr>
<tr>
<td>Checkouts Granted</td>
<td>Number of times the database connections have been used up since the statistics were last reset.</td>
</tr>
<tr>
<td>Checkouts Denied</td>
<td>Number of times the Database connections have been denied since the statistics were last reset.</td>
</tr>
</tbody>
</table>

**Overall Cisco Unified Contact Center Express Stats Report**

Use the Overall Cisco Unified Contact Center Express Stats real-time report to view real-time Unified CCX resource and call information.

**Note**
Unified CCX reports contain information for calls that have been queued in one or more CSQs. If a call is not queued (for example, the caller hangs up before being queued), the reports do not display data for that call.

Unified CCX reports retrieve the following statistics:

- Unified CCX statistics from the current Master node.
- Unified IP IVR statistics from all nodes in the cluster.

To access the Overall Unified CCX Stats report, choose **Reports > Overall Cisco Unified Contact Center Express Stats** from the Application Reporting menu bar.

**Note**
Preview Outbound durations are updated when the preview outbound call disconnects and all agents (resources) involved in the call move out of the Work and Talking state.

The following fields are displayed on the Overall Cisco Unified Contact Center Express Stats report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Resource Information</strong></td>
<td></td>
</tr>
<tr>
<td>CSQs</td>
<td>Number of CSQs currently configured. If a CSQ is added or removed, this statistic reflects that change.</td>
</tr>
<tr>
<td>Logged-in Resources</td>
<td>Number of resources currently logged in.</td>
</tr>
</tbody>
</table>
### Field | Description
--- | ---
Talking Resources | Number of resources currently talking. **Note** This number includes resources in Talking, Work, and Reserved states.

Ready Resources | Number of resources currently ready.

Not Ready Resources | Number of resources currently not ready.

#### Call Information — Inbound

**Total Contacts** | Number of total contacts that have arrived since the statistics were last reset. This includes contacts that are waiting, contacts connected to a resource, and contacts that have disconnected. If a resource transfers to or conferences with a route point, this value increases.

**Contacts Waiting** | Number of contacts waiting to be connected to a resource. **Note** A contact is shown as waiting until the call is answered by the agent. This means that, even if the phone is ringing at the agent, the contact will still show as waiting in RTR.

**Oldest Contact in Queue** | Displays the wait time for the oldest contact in the queue.

**Contacts Handled** | Number of contacts that have been handled by a resource.

**Contacts Abandoned** | Number of contacts that have arrived and disconnected before being connected to a resource.

**Avg Talk Duration** | Average duration (in seconds) that resources spend talking on Unified CCX contacts. Talk duration starts when a contact first connects to a resource and ends when the contact disconnects from the last resource to which it was connected. Talk duration does not include hold time.

**Avg Wait Duration** | Average wait time (in seconds). It begins when the contact enters the system and ends when the contact stops waiting. Wait duration does not include hold time. The time a contact spends on a CTI port prior to getting queued is included in this report.

**Longest Talk Duration** | Longest talk duration (in seconds) of a contact. Talk duration does not include hold time.

**Longest Wait Duration** | Longest wait (in seconds) for a contact to be connected to a resource. Wait duration does not include hold time.

#### Call Information — Preview Outbound

**Active** | Total number of preview outbound calls currently previewed or connected to agents.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview</td>
<td>Total number of preview outbound calls currently previewed but have not been accepted, rejected, or closed by the agents.</td>
</tr>
<tr>
<td>Connected</td>
<td>Total number of preview outbound calls currently connected to agents. When an agent conferences in other agents, the call is counted once towards the total number of connected calls.</td>
</tr>
<tr>
<td>Offered</td>
<td>Total number of preview outbound calls offered. A call is considered offered when it is presented to an agent. A contact that is presented to an agent, skipped/rejected by that agent, and then presented to the same agent or to another agent is counted twice towards the number of calls offered. Offered = Accepted + Rejected + Closed + Timed-out.</td>
</tr>
<tr>
<td>Accepted</td>
<td>Total number of preview outbound calls accepted. A call is considered accepted if an agent has clicked Accept when presented the call. A call that is presented to an agent, skipped/rejected by that agent, presented to another agent, and then accepted by that other agent is counted once towards the number of calls accepted.</td>
</tr>
<tr>
<td>Rejected</td>
<td>The number of preview outbound calls that were skipped or rejected by an agent. This means that the agent selected Reject, Skip, or Cancel Reservation. These contacts will be dialed again. If a contact is rejected by multiple agents, this field increments each time the contact is rejected. The number Rejected is also incremented each time an agent drops the preview call while it is ringing at the customer’s contact.</td>
</tr>
<tr>
<td>Closed</td>
<td>The number of preview outbound contacts that were closed by agents. This means that the agent selected Skip-Close or Reject-close. These contacts will not be dialed again.</td>
</tr>
<tr>
<td>Timed-Out</td>
<td>Total number of preview outbound calls that timed out. A call is considered timed out when it is presented to an agent and not accepted, rejected, or closed within the allocated time. These contacts will be dialed again. If a contact timed out multiple agents, this field is incremented each time the contact is timed out for each agent.</td>
</tr>
<tr>
<td>Invalid Number</td>
<td>The number of preview outbound calls that were dialed to an invalid number. This means that the agent accepted the call (by clicking Accept), got connected to the customer, and selected the Invalid Number option from the contact Reclassification drop down. It also includes the number of preview outbound calls that failed at the network level.</td>
</tr>
<tr>
<td>Voice</td>
<td>The number of preview outbound calls that ended in successful customer contact. This means that an agent accepted the call (by clicking Accept) and selected a classification of Voice (default) or Do Not Call for this contact.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Answering Machine   | The number of preview outbound calls that connected to an answering machine for this campaign. This means that the agent accepted the call (by clicking Accept), got connected to the answering machine and selected the Answering Machine option from the contact Reclassification drop down.  
**Note** The agent can manually reclassify the contact as Answering Machine while the customer contact is on the call or when the agent has gone into the Work state after the call. |
| Requested Callback  | The number of contacts marked for callback. This means that the agent accepted the call (by clicking Accept), got connected to the contact, the contact requested a callback, and the agent selected the CallBack option. A call that is accepted by an agent, marked for callback, later presented to and accepted by another agent (at the callback time), and marked for callback again is counted twice towards the number of callback calls. |
| Avg Outbound Talk Duration | The average time in HH:MM:SS (hours, minutes, seconds) that agents spend talking on outbound calls. The durations consider all calls that were Agent Accepted and classified as Voice. If a preview outbound call is transferred or conferenced to a route point, this average outbound talk duration does not include the talk time of agents who handle the call after it came through the route point. Instead, the talk time is included in the inbound talk duration. |
| Longest Outbound Talk Duration | The longest talk duration of a preview outbound call in HH:MM:SS (hours, minutes, seconds). The durations consider all calls that were Agent Accepted and classified as Voice. |

**Related Topics**
- Clear Contact Menu, on page 217

**CSQ Cisco Unified Contact Center Express Stats Report**
Use the CSQ Cisco Unified Contact Center Express Stats real-time report to view real-time information.

**Note**
Unified CCX reports contain information for calls that have been queued in one or more CSQs. If a call is not queued, the reports do not display data for that call.

To access the CSQ Cisco Unified Contact Center Express Stats report, choose Reports > CSQ Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the CSQ Cisco Unified Contact Center Express Stats report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the CSQ</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Talking/Ready Resources/Not Ready Resources/Logged-In Resources</td>
<td>Number of resources who are in the talking, ready, and not ready states, and the number of resources logged in for this CSQ. Values for the four items are separated by colons. Values are displayed in the same order that the items appear in the column heading. <strong>Note</strong> This number includes resources in Talking, Work, and Reserved states. If you are logged into the Unified CCX Administration web interface as a Supervisor and opening the Real-Time Reporting plug-in, you will be able see all the logged in agents from all the teams independent of team membership.</td>
</tr>
<tr>
<td>Total Contacts</td>
<td>Number of total contacts since the statistics were last reset for this CSQ.</td>
</tr>
<tr>
<td>Contacts Waiting</td>
<td>Number of contacts waiting to be connected to a resource in this CSQ. This column also displays how long the oldest contact has been waiting.</td>
</tr>
<tr>
<td>Contacts [oldest contact in queue]</td>
<td>Duration of longest currently waiting contact.</td>
</tr>
<tr>
<td>Contacts Handled</td>
<td>Number of contacts that have been handled by this CSQ.</td>
</tr>
<tr>
<td>Contacts Abandoned</td>
<td>Number of contacts that have been abandoned by this CSQ.</td>
</tr>
<tr>
<td>Contacts Dequeued</td>
<td>Number of contacts that have been dequeued from this CSQ.</td>
</tr>
<tr>
<td>Avg Talk Duration</td>
<td>Average time (in seconds) agents in this CSQ spent talking to contacts.</td>
</tr>
<tr>
<td>Avg Wait Duration</td>
<td>Average wait time (in seconds). It begins when the call was queued (when you execute the &quot;Select Resource&quot; step) and ends when the call reaches the agent. Wait duration does not include hold time. The time a contact spends on a CTI port prior to getting queued is not included in this wait time.</td>
</tr>
<tr>
<td>Longest Talk Duration</td>
<td>Longest time (in seconds) agents in this CSQ spend talking to contacts.</td>
</tr>
<tr>
<td>Longest Wait Duration</td>
<td>Longest wait (in seconds) for a contact to be connected to a resource.</td>
</tr>
</tbody>
</table>

### Related Topics
- [Clear Contact Menu](#), on page 217

**Preview Outbound Campaign Cisco Unified Contact Center Express Stats Report**

Use the Preview Outbound Campaign Cisco Unified Contact Center Express Stats real-time report to view real-time Unified Contact CCX information for the Outbound preview dialer.

To access the Preview Outbound Campaign Cisco Unified Contact Center Express Stats report, choose **Reports > Preview Outbound Campaign Cisco Unified Contact Center Express Stats** from the Application Reporting menu bar.

The following fields are displayed on the Preview Outbound Campaign Cisco Unified Contact Center Express Stats report.
<table>
<thead>
<tr>
<th><strong>Field</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Campaign</td>
<td>The name of the preview outbound campaign.</td>
</tr>
</tbody>
</table>
| Status    | The current activation state of the preview outbound campaign:  
• Running: an active preview outbound campaign  
• Stopped: an inactive preview outbound campaign |
| Active    | Total number of outbound calls currently previewed by or connected to agents for this preview outbound campaign. Active Calls = Previewed + Connected. |
| Preview   | Total number of outbound calls currently previewed but have not been accepted, rejected or closed by the agents as part of this preview outbound campaign. |
| Connected | Total number of outbound calls currently connected to agents for this preview outbound campaign. When an agent conferences in other agents, the call is counted once towards the total number of connected calls. |
| Offered   | Total number of outbound calls offered for this preview outbound campaign. A call is considered offered when it is presented to an agent as part of this preview outbound campaign. A contact that is presented to an agent, skipped/rejected by that agent, and then presented to the same agent or to another agent is counted twice towards the number of calls offered. Offered = Accepted + Rejected + Closed + Timed-out. |
| Accepted  | Total number of outbound calls accepted for this preview outbound campaign. A call is considered accepted if an agent has clicked Accept when presented the call. A call that is presented to an agent, skipped/rejected by that agent, presented to another agent, and then accepted by that other agent is counted once towards the number of calls accepted. |
| Rejected  | The number of outbound calls that were skipped or rejected by an agent as part of this preview outbound campaign. This means that the agent selected Reject, Skip, or Cancel Reservation. These contacts will be dialed again. If a contact is rejected by multiple agents, this field increments each time the contact is rejected.  
The number Rejected is also incremented each time an agent drops the preview call while it is ringing at the customer contact. |
<p>| Closed    | The number of outbound contacts that were closed by agents as part of this preview outbound campaign. This means that the agent selected Skip-Close or Reject-close. These contacts will not be dialed again. |
| Timed-Out | Total number of outbound calls that timed out. A call is considered timed out when it is presented to an agent and not accepted, rejected, or closed within the allocated time. These contacts will be dialed again. If a contact times out for multiple agents, this field is incremented each time the contact is timed out for each agent. |</p>
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid Number</td>
<td>The number of outbound calls that were dialed to an invalid number for this preview outbound campaign. This means that the agent accepted the call (by clicking Accept), got connected to the customer, and selected the &quot;Invalid Number&quot; option from the contact Reclassification drop down. It also includes the number of outbound calls that failed at the network level. <strong>Note</strong> The agent can manually reclassify the contact as Invalid Number while the customer contact is on the call or when the agent has gone into the Work state after the call.</td>
</tr>
<tr>
<td>Voice</td>
<td>The number of outbound calls that ended in successful customer contact. This means that an agent accepted the call (by clicking Accept) and selected a classification of Voice or Do Not Call for this contact.</td>
</tr>
<tr>
<td>Answering Machine</td>
<td>The number of outbound calls that connected to an answering machine for this preview outbound campaign. This means that the agent accepted the call (by clicking Accept), got connected to the answering machine and selected the Answering Machine option from the contact Reclassification drop down. <strong>Note</strong> The agent can manually reclassify the contact as Answering Machine while the customer contact is on the call or when the agent has gone into the Work state after the call.</td>
</tr>
<tr>
<td>Requested Callback</td>
<td>The number of contacts marked for callback for this preview outbound campaign. This means that the agent accepted the call (by clicking Accept), got connected to the contact, the contact requested a callback, and the agent selected the CallBack option. A call that is accepted by an agent, marked for callback, later presented to and accepted by another agent (at the callback time), and marked for callback again is counted twice towards the number of callback calls.</td>
</tr>
<tr>
<td>Avg Talk Duration</td>
<td>The average time in HH:MM:SS (hours, minutes, seconds) that agents spend talking on outbound calls for this preview outbound campaign. The durations consider all calls that were Agent Accepted and classified as Voice. If a call is transferred or conferenced back to the route point, the preview outbound campaign talk duration does not handle the talk time of agents who handle the call after it came through the route point.</td>
</tr>
<tr>
<td>Longest Talk Duration</td>
<td>The longest talk duration of an outbound call in HH:MM:SS (hours, minutes, seconds) for this preview outbound campaign. The durations consider all calls that were Agent Accepted and classified as Voice.</td>
</tr>
</tbody>
</table>

**Chat CSQ Cisco Unified Contact Center Express Stats Report**

Use the Chat CSQ Cisco Unified Contact Center Express Stats real-time report to view real-time queue information. This report is available in Cisco Unified CCX Premium license package.

**Note** Unified CCX reports contain information for a chat contact that are queued with a specific CSQ. If a contact is not queued, the reports do not display data for that chat contact.

To access the Chat CSQ Cisco Unified Contact Center Express Stats report, choose Reports > Chat CSQ Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the Chat CSQ Cisco Unified Contact Center Express Stats report.
Use the Chat Resource Cisco Unified Contact Center Express Stats real-time report to view real-time Unified CCX chat resource information. This report is available in Cisco Unified CCX Premium license package.

To access the Chat Resource Cisco Unified Contact Center Express Stats report, choose Reports > Chat Resource Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

The following fields are displayed on the Chat Resource Cisco Unified Contact Center Express Stats report:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the chat CSQ</td>
</tr>
<tr>
<td>Busy Resources/Ready Resources/Not Ready Resources/Logged-In Resources</td>
<td>Number of resources who are in the Busy, Ready, and Not Ready states, and the number of agents logged in for this chat CSQ. Values for the four items are separated by colons. Values are displayed in the same order that the items appear in the column heading. Note If you are logged in to the Unified CCX Administration web interface as a supervisor and you open the Real-Time Reporting plug-in, you can see all the logged-in agents from all the teams.</td>
</tr>
<tr>
<td>Total Contacts</td>
<td>Number of total contacts presented to this queue since last reset of statistics.</td>
</tr>
<tr>
<td>Contacts Waiting [Oldest Contact in Queue]</td>
<td>Number of contacts waiting in this queue with the duration of longest waiting contact in this queue.</td>
</tr>
<tr>
<td>Contacts Handled</td>
<td>Number of contacts that have been handled by this queue since last reset of statistics.</td>
</tr>
<tr>
<td>Contacts Abandoned</td>
<td>Number of contacts that have been abandoned in this queue since last reset of statistics.</td>
</tr>
<tr>
<td>Avg Contact Handling Duration</td>
<td>Average time (in HH:MM:SS) agents in this CSQ spent chatting with contacts.</td>
</tr>
<tr>
<td>Avg Wait Duration</td>
<td>Average wait time (in HH:MM:SS) a contact spent in queue waiting for an agent.</td>
</tr>
<tr>
<td>Longest Contact Handling Duration</td>
<td>Longest time (in HH:MM:SS) agents in this CSQ spent chatting with contacts.</td>
</tr>
<tr>
<td>Longest Wait Duration</td>
<td>Longest wait (in HH:MM:SS) for a contact to be connected to an agent.</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duration in State</td>
<td>Length of time (in HH:MM:SS) the resource has remained in the current state.</td>
</tr>
<tr>
<td>Avg Resource Busy Duration</td>
<td>Average time the agent spent with contacts. The resource busy duration is the elapsed time between the resource accepting the contact and completing the chat by clicking End.</td>
</tr>
<tr>
<td>Longest Resource Busy Duration</td>
<td>Longest time the agent spent with a contact. The resource busy duration is the elapsed time between the resource accepting the contact and completing the chat by clicking End.</td>
</tr>
<tr>
<td>Contacts Presented</td>
<td>Number of contacts that have been presented to this resource.</td>
</tr>
<tr>
<td>Contacts Handled</td>
<td>Number of contacts that have been handled by this resource.</td>
</tr>
</tbody>
</table>

**Overall Chat Cisco Unified Contact Center Express Stats Report**

Use the Overall Chat Cisco Unified Contact Center Express Stats real-time report to view real-time Unified CCX resource and contact information. This report is available in Cisco Unified CCX Premium license package.

---

**Note**

Unified CCX reports contain information for contacts that have been queued in one or more CSQs. If a contact is not queued, the reports do not display data for that contact.

To access the Overall Chat Unified CCX Stats report, choose **Reports > Overall Chat Cisco Unified Contact Center Express Stats** from the Application Reporting menu bar.

The following fields are displayed on the Overall Chat Cisco Unified Contact Center Express Stats report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Resource Information</strong></td>
<td></td>
</tr>
<tr>
<td>CSQs</td>
<td>Number of chat CSQs currently configured. If a chat CSQ is added or removed, this statistic reflects that change.</td>
</tr>
<tr>
<td>Logged-in Resources</td>
<td>Number of resources currently logged in.</td>
</tr>
<tr>
<td>Busy Resources</td>
<td>Number of resources currently busy.</td>
</tr>
<tr>
<td>Ready Resources</td>
<td>Number of resources currently ready.</td>
</tr>
<tr>
<td>Not Ready Resources</td>
<td>Number of resources currently not ready.</td>
</tr>
<tr>
<td><strong>Contact Information</strong></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Total Contacts</td>
<td>Number of total contacts that have arrived since the statistics were last reset. This includes contacts that are waiting, contacts connected to a resource, and contacts that have disconnected.</td>
</tr>
<tr>
<td>Contacts Waiting</td>
<td>Number of contacts waiting to be connected to a resource.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>A contact is shown as waiting until the contact is answered by the agent.</td>
</tr>
<tr>
<td>Oldest Contact in Queue</td>
<td>Displays the wait time for the oldest contact in the queue.</td>
</tr>
<tr>
<td>Contacts Handled</td>
<td>Number of contacts that have been handled by a resource.</td>
</tr>
<tr>
<td>Contacts Abandoned</td>
<td>Number of contacts that have arrived and disconnected before being connected to a resource.</td>
</tr>
<tr>
<td>Avg Contact Handling Duration</td>
<td>Average duration (in HH:MM:SS) that resources spent chatting on Unified CCX contacts. Chat duration starts when a contact first connects to a resource and ends when the contact disconnects from the resource to which it was connected.</td>
</tr>
<tr>
<td>Avg Wait Duration</td>
<td>Average wait time (in HH:MM:SS). It begins when the contact enters the system and ends when either the contact is connected with an agent or if contact was disconnected.</td>
</tr>
<tr>
<td>Longest Contact Handling Duration</td>
<td>Longest contact handling duration (in HH:MM:SS) of a contact.</td>
</tr>
<tr>
<td>Longest Wait Duration</td>
<td>Longest wait (in HH:MM:SS) for a contact to be connected to a resource.</td>
</tr>
</tbody>
</table>

**Outbound Campaign Stats Report**

If you have an Outbound license, use the Outbound Campaign Stats report to view real-time statistics on each IVR-based and agent-based progressive and predictive Outbound campaign configured in Unified CCX. This report will be available only if you have an Outbound license on top of Unified CCX premium license in your Unified CCX.

To access the Outbound Campaign Stats report, choose Reports > Outbound Campaign Stats from the Application Reporting menu bar. The following fields are displayed on the Outbound Campaign Stats report.

**Note**

The call related fields display the data from the time the statistics were last reset.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Campaign Name</td>
<td>The name of the IVR-based or agent-based progressive or predictive campaign.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Status</td>
<td>The current activation state of the campaign:</td>
</tr>
<tr>
<td></td>
<td>• Running: an active IVR-based or agent-based progressive or predictive campaign.</td>
</tr>
<tr>
<td></td>
<td>• Stopped: an inactive IVR-based or agent-based progressive or predictive campaign.</td>
</tr>
<tr>
<td>Campaign Type</td>
<td>The dialer type of the campaign, which can be one of the following:</td>
</tr>
<tr>
<td></td>
<td>• IVR Progressive</td>
</tr>
<tr>
<td></td>
<td>• IVR Predictive</td>
</tr>
<tr>
<td></td>
<td>• Agent Progressive</td>
</tr>
<tr>
<td></td>
<td>• Agent Predictive</td>
</tr>
<tr>
<td>Attempted</td>
<td>The total number of attempted calls.</td>
</tr>
<tr>
<td></td>
<td>If there are no customer abandoned calls, then Attempted will be equal to sum of the following counters:</td>
</tr>
<tr>
<td></td>
<td>Voice + Answering Machine + Invalid Number + Fax/Modem + No Answer + Busy + Failed.</td>
</tr>
<tr>
<td>Voice</td>
<td>The total number of calls that are connected to live voice.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The call will be marked as System Abandoned after it has been marked as Voice and Active due to any of the following reasons:</td>
</tr>
<tr>
<td></td>
<td>• Whenever there is an exception while executing some steps in an IVR script in case of IVR-based campaigns. For example, if there is any codec mismatch issue, there will be an exception in the Accept Step. In such cases, the same call will be marked in the following three categories voice, active, and system abandoned.</td>
</tr>
<tr>
<td></td>
<td>• Whenever the call that is ringing on the agent's phone fails in case of agent-based campaigns.</td>
</tr>
<tr>
<td>Answering Machine</td>
<td>The total number of calls that reached an answering machine.</td>
</tr>
<tr>
<td>Invalid Number</td>
<td>The total number of calls that reached an invalid number:</td>
</tr>
<tr>
<td></td>
<td>• A failed call when the gateway returns an invalid or not found error.</td>
</tr>
<tr>
<td>Fax/Modem</td>
<td>The total number of calls that reached fax or modem.</td>
</tr>
<tr>
<td>No Answer</td>
<td>The total number of calls that were not answered within the time configured for the No Answer Ring Limit field in the Add New Campaign web page.</td>
</tr>
<tr>
<td>Busy</td>
<td>The total number of calls that reached a busy destination.</td>
</tr>
</tbody>
</table>
The total number of calls that failed due to any one of the following reasons:

- Dialer asked the Gateway to cancel a call that was dialed out, but not connected.
- Gateway has declined the call.
- Gateway failure or configuration issues at the Gateway.
- Gateway is down.

The total number of calls that were connected to IVR ports or agents.

All the voice calls that will be connected to Outbound IVR ports or agents will be marked as active. If you have selected Answering Machine Treatment or Abandoned Call Treatment as "Transfer to IVR," the answering machine calls and abandoned calls that are getting transferred to Outbound IVR ports will also be marked as active.

The total number of calls that were disconnected by the customer or agent within the Abandoned Call Wait Time configured in Add New Campaign web page.

The total number of calls that were abandoned due to any of the following reasons:

- Non-availability of ports or agents.
- Any issues at system level.

Abandon Rate = (System Abandoned/Voice)*100

**Note**

- If you have selected Answering Machine Treatment as "End Call" for an IVR or agent based outbound campaign through Campaign Configuration web page, then Voice = Active + System Abandoned.
- If you have selected Answering Machine Treatment or Abandoned Call Treatment as "Transfer to IVR" for an IVR or agent based outbound campaign through Campaign Configuration web page, then Voice + Answering Machine = Active + System Abandoned.

**Overall Outbound Stats Report**

If you have an Outbound license, you can use the Overall Outbound Stats report to view real-time statistics across all IVR-based and agent-based progressive and predictive campaigns since the statistics were last reset. This report will be available only if you have an Outbound license on top of Unified CCX premium license in your Unified CCX.

To access the Overall Outbound Stats report, choose Reports > Overall Outbound Stats from the Application Reporting menu bar. The following fields are displayed on the Overall Outbound Stats report for all the configured IVR-based and agent-based Outbound campaigns.
The call related fields display the data from the time the statistics were last reset.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attempted</td>
<td>The total number of attempted Outbound calls.</td>
</tr>
<tr>
<td>Voice</td>
<td>The total number of Outbound calls that were connected to live voice.</td>
</tr>
<tr>
<td>Answering Machine</td>
<td>The total number of Outbound calls that reached answering machine.</td>
</tr>
<tr>
<td>Invalid Number</td>
<td>The total number of Outbound calls that reached an invalid number.</td>
</tr>
<tr>
<td>Fax/Modem</td>
<td>The total number of Outbound calls that reached fax or modem.</td>
</tr>
<tr>
<td>No Answer</td>
<td>The total number of Outbound calls that were not answered.</td>
</tr>
<tr>
<td>Busy</td>
<td>The total number of Outbound calls that reached a busy destination.</td>
</tr>
<tr>
<td>Failed</td>
<td>The total number of failed Outbound calls for all IVR and agent based Outbound campaigns.</td>
</tr>
<tr>
<td>Active</td>
<td>The total number of Outbound calls that were connected to Outbound IVR ports or agents.</td>
</tr>
<tr>
<td>Customer Abandoned</td>
<td>The total number of Outbound calls that were abandoned by the customer or disconnected by the agent.</td>
</tr>
<tr>
<td>System Abandoned</td>
<td>The total number of Outbound calls that were abandoned by the system.</td>
</tr>
</tbody>
</table>

**Resource Cisco Unified Contact Center Express Stats Report**

Use the Resource Cisco Unified Contact Center Express Stats real-time report to view real-time Unified Contact CCX agent information.

To access the Resource Cisco Unified Contact Center Express Stats report, choose Reports > Resource Cisco Unified Contact Center Express Stats from the Application Reporting menu bar.

**Note**

If multiple lines are configured for an agent, only the calls on the agent's primary extension are reported in Resource Cisco Unified Contact Center Express Stats report.

The following fields are displayed on the Resource Cisco Unified Contact Center Express Stats report.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (ID)</td>
<td>Unique identifier of the agent.</td>
</tr>
<tr>
<td>State</td>
<td>Current state of the agent.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Duration in State</td>
<td>Amount of time (in seconds) the agent has remained in the current state.</td>
</tr>
<tr>
<td>Contacts Presented</td>
<td>Number of contacts presented to the agent.</td>
</tr>
<tr>
<td>Contacts Handled</td>
<td>Number of contacts handled by the agent.</td>
</tr>
<tr>
<td>Avg Talk Duration</td>
<td>Average time (in seconds) the agent spent in talking state.</td>
</tr>
<tr>
<td>Avg Hold Duration</td>
<td>Average time (in seconds) the agent keeps calls on hold.</td>
</tr>
<tr>
<td>Longest Talk Duration</td>
<td>Longest time (in seconds) the agent spent in talking state.</td>
</tr>
<tr>
<td>Longest Hold Duration</td>
<td>Longest time (in seconds) the agent keeps a call on hold.</td>
</tr>
<tr>
<td>Outbound Offered</td>
<td>Total number of preview outbound calls offered to the agent. A call is considered offered when it is presented to an agent. The number of calls offered is counted twice if a contact that is presented to an agent is skipped/rejected by that agent and then the contact is presented to the same agent or to another agent. Offered = Accepted + Rejected + Closed + Timed-out.</td>
</tr>
<tr>
<td>Outbound Accepted</td>
<td>Total number of outbound calls accepted by the agent. For transferred or conferenced outbound calls, the call is considered accepted if it is answered by the agent. A preview outbound call is considered accepted if an agent has clicked Accept to accept the call and then the system places the call to the customer. The number of calls accepted is counted once if a call that is presented to an agent is skipped/rejected by that agent and then the call is presented to another agent who accepts the call. A progressive or predictive outbound call is considered accepted if an agent has answered a live voice call that is presented to the agent (if Agent AutoAnswer is disabled).</td>
</tr>
<tr>
<td>Outbound Rejected</td>
<td>The number of preview outbound calls skipped/rejected by the agent. This means that the agent selected Reject, Skip, or Cancel Reservation. These contacts will be dialed again. The number of calls rejected is also incremented each time an agent drops the preview call while it is ringing at the customer's contact.</td>
</tr>
<tr>
<td>Outbound Closed</td>
<td>The number of contacts closed by the agent for preview outbound. This means that the agent selected Skip-Close or Reject-close. These contacts will not be dialed again.</td>
</tr>
<tr>
<td>Outbound Timed-Out</td>
<td>Total number of preview outbound calls that timed out. A call is considered timed out when the call is presented to an agent but not accepted, rejected, or closed within the allocated time. These contacts will be dialed again. If a contact timed out for multiple agents, this field is incremented each time the contact is timed out for each agent.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Outbound Voice</td>
<td>The number of preview outbound calls that ended in successful customer contact for the agent. This means that the agent accepted the call (by clicking Accept) and selected a classification of Voice or Do Not Call for this contact.</td>
</tr>
<tr>
<td>Outbound Avg Talk Duration</td>
<td>The average time in HH:MM:SS (hours, minutes, seconds) that the agent spends in talking state for outbound calls. This talk duration also includes the time spent on outbound calls that were transferred or conferenced to a route point. For preview outbound, the talk duration considers all calls that were Agent Accepted and classified as Voice.</td>
</tr>
<tr>
<td>Outbound Avg Hold Duration</td>
<td>The average time in HH:MM:SS (hours, minutes, seconds) that the agent spent in holding an outbound call. For preview outbound, the hold duration considers all calls that were Agent Accepted and classified as Voice.</td>
</tr>
<tr>
<td>Outbound Longest Talk Duration</td>
<td>The longest time in HH:MM:SS (hours, minutes, seconds) that the agent spent in talking state for an outbound call. For preview outbound, the talk duration considers all calls that were Agent Accepted and classified as Voice.</td>
</tr>
<tr>
<td>Outbound Longest Hold Duration</td>
<td>The longest time in HH:MM:SS (hours, minutes, seconds) that the agent spent in holding an outbound call. For preview outbound, the hold duration considers all calls that were Agent Accepted and classified as Voice.</td>
</tr>
</tbody>
</table>

**Failover Behavior for Unified CCX Stats**

All failovers, regardless of whether the Unified CCX Engine is restarted, will cause the Unified CCX stats to reset.

The Unified IP IVR stats do not reset in all cases if the Unified CCX Engine is not restarted on a node. However, the node loses its active server status. The Unified IP IVR stats on that node will not be reset.

**Tools Menu**

The Tools menu gives you access to the following Application Reporting tools:

- **Reset All Stats**—Choose this option to reset all statistics.
- **Open Printable Report**—Choose this option to get a printable report of all currently active contacts in the system.
- **Refresh Connections**—Choose this option to refresh connections with the Unified CCX system.
- **Clear Contact**—Choose this option to clear contacts/calls that have been stuck in the system for a long time.
Reset All Statistics

Use the Reset All Stats option to reset all statistics accumulated since the last time the statistics were reset. It will not reset active statistics, such as active contacts, tasks, and so on.

Note

The Unified CCX system automatically resets all statistics each day at midnight.

Procedure

Choose Tools > Reset All Statistics from the Application Reporting menu bar.

Open Printable Report

Use the option to get a printable report of all currently active contacts in the system.

To get a printable report:

Procedure

Choose a real-time report from the Report menu option and then Tools > Open Printable Report from the Application Reporting menu bar.

Refresh Connections

To refresh connections with the Unified CCX system:

Procedure

Choose Tools > Refresh Connections from the Application Reporting menu bar. The Unified CCX system refreshes all connections.

Clear Contact Menu

You can use the Clear Contact menu option to clear contacts in the following three situations:

Clear Stuck Calls from Sontacts Real-Time Report

To clear stuck calls or contacts from the Unified CCX system:

Procedure

Step 1 Choose the contact from Reports > Contacts.
Step 2 From the Application Reporting menu bar, choose Tools > Clear Contact. A Clear Call dialog box is displayed to warn you. If you want to continue with the clear action, click No. To cancel the action, click Yes.
Step 3 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the action. You can click Yes to proceed or No to cancel.
Step 4 Click Yes. The Unified CCX system removes the contact from all its queues.

Clear Stuck Calls from Overall Cisco Unified CCX Stats

To clear stuck calls/contacts from the Unified CCX system:
Procedure

Step 1 Choose Reports > Overall Cisco Unified Contact Center Express Stats.
Step 2 Choose the contact from Views and click Overall Waiting Contacts Info.

Note Please note that the Overall Waiting Contacts Info menu option displays only those calls that are queued in CSQs and not agent-based routing calls.

Step 3 From the Application Reporting menu bar, choose Tools and click Clear Contact. A Clear Call dialog box is displayed to warn you. If you want to continue with the clear action, click No. To cancel the action, click Yes.

Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the action. You can click Yes to proceed or No to cancel.

Step 5 Click Yes. The Unified CCX system removes the contact from all its queues.

Clear Stuck Calls from CSQ Cisco Unified CCX Stats

To clear stuck calls or contacts from the Unified CCX system:

Procedure

Step 1 Choose Reports > CSQ Cisco Unified Contact Center Express Stats.
Step 2 Choose the contact from Views and click CSQ Waiting Contacts Info.
Step 3 From the Application Reporting menu bar, choose Tools > Clear Contact. A Clear Call dialog box is displayed to warn you. If you want to continue with the clear action, click No. To cancel the action, click Yes.

Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed for you to confirm the action. You can click Yes to proceed or No to cancel.

Step 5 Click Yes. The Unified CCX system removes the contact from all its queues.

Views Menu

The Views menu allows you to access more detailed information for six reports: The Application Tasks report, the Contacts report, the Applications report, the Sessions report, Overall Cisco Unified Contact Center Express Stats report, and the CSQ Cisco Unified Contact Center Express Stats report.

Note For some reports, detailed information is also available by right-clicking a record in that report.

The Views menu contains different options, depending on the report you have chosen. Possible options are:

- Contacts by Application Task ID—Choose this option to view contacts according to Application Task ID numbers.
- Engine Tasks by Application Task ID—Choose this option to view Engine tasks according to Application Task ID numbers.
• **Detailed Info**—Choose this option to view more detailed information on selected reports.

• **Application Tasks by Application Name**—Choose this option to view application tasks by application name.

• **Contacts by Session ID**—Choose this option to view contacts by session ID.

• **Overall Waiting Contacts Info**—Choose this option to view detailed information for the overall waiting contacts. To clear stuck calls in this view, see Scenario 2 in *Clear contact menu* option.

• **CSQ Waiting Contacts Info**—Choose this option to view detailed information for the CSQ waiting contacts. To clear stuck calls in this view, see Scenario 3 in *Clear contact menu* option.

**Related Topics**

*Clear Contact Menu*, on page 217

**Application Tasks**

You can obtain reports based on the application task ID associated with application tasks.

Contacts by Application Task ID

This report displays the same report as the Contact report with the exception that the Contacts by Application Task ID report has been filtered using only the contact currently being managed by the selected application task.

Engine Tasks by Application Task ID

This report displays the same report as the Engine Task reports except that the Engine Tasks by Application Task ID report has been filtered to display only the engine tasks that are associated with the application task.

**Contacts**

When you use the Views options with the Contacts report, the Views menu contains only the Detailed Info option.

The Detailed Info option provides various detailed information, depending on the type of contact selected. For example, if the contact is a call, the Calling Party number, the Called Number, and so on, are displayed for that particular call.

**Related Topics**

*Call Contacts Detailed Info Report*, on page 198

**Applications**

When you use the Views options with the Application reports, the Views menu contains only the Application Tasks by Application Name option.

The Application Task By Application Name report displays the same report as the Application Task report except that the Application Task By Application Name report is filtered using only the active application tasks associated with this application.

**Related Topics**

*Application Tasks Real-Time Report*, on page 195

**Sessions**

You can obtain reports based on the session ID associated with a session.
Contacts by Session ID

This report displays the same report as the Contact report with the exception that the Contacts By Session ID report is filtered using only the contacts associated with the selected session.

**Related Topics**

Contacts Report, on page 197

Detailed Info

Detailed info displays the time the session was created and its current state.

**Settings Menu**

The Settings menu of the Application Reporting menu bar allows you to adjust various settings of the Real Time Reporting tool.

The Settings menu contains the following menu options:

- **Options**—Choose this option to set the polling (refresh) interval times and to set the amount of times the server will attempt to reconnect.
- **Window**—Choose this option to display reports in colors based on your Windows settings.
- **Motif**—Choose this option to display reports in purple and menu items in brown.
- **Metal**—Choose this option to display reports in grey and menu items in black.

**Options Menu**

Choose Settings and click **Options** to access the Options dialog box. Use the Options dialog box to set the polling (refresh) interval time, set the number of times the server will attempt to reconnect, and specify whether logged off agents appear in reports.

The following fields are displayed in the Options dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polling Interval</td>
<td>Time between two requests to the server for new statistics by the client.</td>
</tr>
<tr>
<td>Server Connect Retry Count</td>
<td>The number of times that the Unified CCX Administration web interface should attempt to reconnect to the Unified CCX server.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If an error occurs, an Error dialog box opens to alert you that the server is not communicating with the web interface.</td>
</tr>
<tr>
<td>Show Logged Off Resources</td>
<td>Specifies whether logged off agents appear in reports.</td>
</tr>
</tbody>
</table>

Click **Apply** to submit configuration changes.
Reporting Administration on Unified Intelligence Center

Overview

Unified Intelligence Center is the default reporting solution for Unified CCX. Unified Intelligence Center is a comprehensive, end-to-end reporting solution.

Note

Do not access Unified Intelligence Center until you complete the post installation tasks for Unified CCX.

Note

LiveData reportscan only be run by agents, supervisors, and reporting users.

For more information, see the following guides:


Note

Historical Reporting Client (HRC) is not available from 10.0(1).

Cisco Finesse

You can configure theLiveData reportsthat are to be displayed in the gadgets of the Cisco Finesse desktops. For more information, see Cisco Finesse, on page 355.

Start Unified Intelligence Center

Procedure

Step 1
Open a web browser.

Step 2
Access http://<host address> and click Cisco Unified Contact Center Express Reporting.

Note
Host address is the DNS name or IP address of the Unified CCX node.

Step 3
Enter your username and password.

Step 4
Click Log In.
**Administrator Overview**

Access to the functions in the Unified Intelligence Center reporting application is controlled by the one or more users who have the user role of Security Administrator.

The initial, default Security Administrator is the user defined as the System Application User during the installation.

Security Administrators can:

- Create and maintain users.
- Assign User Roles—User roles are assigned to users to control access to drawers and what objects the user can create.
- Assign users to User Groups.
- Create and maintain user groups.
- Assign Permissions—Whereas User Roles are associated with people, permissions are associated with objects (Dashboards, Reports, Report Definitions, Data Sources, Value Lists, and Collections).
- Use the Run As feature to verify other users' permissions.

**Security Overview**

Unified Intelligence Center security offers multi-layered and flexible functionality that allows a security administrator to create a flat or a tiered structure of access to Unified Intelligence Center functions, based on the organization's needs.

A user's access to Unified Intelligence Center functions is based on:

- Login authentication.
- License type under which the user's organization runs Unified Intelligence Center. For example, organizations that use a Standard license cannot access the Report Definition functions.
- User Role (a user can have one, some, or all seven User Roles).
- User Groups in which user is a member.
- For an object the user can access, the **object-level permissions** assigned by the person who created that object.

**User List**

User List page opens from the Security drawer. If a user who does not have the Security Administrator user role accesses this page, that user can see all the parameters except the user roles. The user cannot change his role or group membership.

When Security Administrators access this page, they can see all existing users; can create users, modify or delete users, review or edit user information, and use the **Run As** feature to work in Cisco Unified Intelligence Center as a user.
### Table 10: Fields on User List Page

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Only show currently active users</td>
<td>Check the check box to display users who are currently active.</td>
</tr>
<tr>
<td>Name Contains</td>
<td>Use this filter field to narrow the list of names or to move to a specific name.</td>
</tr>
<tr>
<td>User Name</td>
<td>The domain and user name (domain\name).</td>
</tr>
<tr>
<td>First Name</td>
<td>The user's first name.</td>
</tr>
<tr>
<td>Last Name</td>
<td>The user's last name.</td>
</tr>
</tbody>
</table>

You can perform the following actions on the user lists page:

- **Create**—Opens the User Information page.
- **Edit**—Select a user name and click **Edit** to edit the User Information page.
- **Delete**—Select a user and click **Delete** to delete the user.
- **Run As**—Select a user and click **Run As** to refresh the Cisco Unified Intelligence Center reporting interface.
- **Refresh**—Refreshes the page to show any latest changes to the User List.
- **Page**—Click the arrow to move to the next page of the User List.
- **Help**—Opens online help.
- **X**—Closes the page.

## Create a User

To create a user, perform the following procedure:

### Procedure

**Step 1** Navigate to Security > User List.

**Step 2** Under the General Information tab, perform the following:

- a) In the **User Name** field, enter the domain and user name (domain\name).
- b) In the **Alias** field, enter the alias name for this user.
- c) Check the **User is active** check box to enable the user to log in and remain active.
  
  **Note** If the check box is unchecked, the user cannot log in.
- d) In the **First Name** field, enter the first name of the user.
- e) In the **Last Name** field, enter the last name.
f) In the **Organization** field, enter the company name or other descriptive text to be associated with the user, such as region or Line of Business.

g) In the **Email** field, enter the email address of the user.

h) In the **Phone** field, enter a phone number for the user. This can be the user's personal phone number or an emergency contact.

i) In the **Description** field, enter the description of the user.

j) In the **Time Zone** field, choose the time zone that you want to use in the report from the drop-down list. This time zone is also used for the user's scheduled reports and takes precedence over the time zone used by the report server.

   **Note** If this field is left blank, the system uses the time zone of the report server.

k) For **Start Day of the Week**, perform the following:

   - Select **Locale Based** to select starting day of the week based on locale.
   - Select **Custom Settings** to choose one of the seven days of the week from the drop-down list.

   **Note** Start Day Of The Week is used in Scheduled Report, Report Views, and Permalink.

l) In the **Roles** field, select and assign one or more roles for this user. If the Security Administrator adds or changes User Roles, the change does not take effect until the user logs out and then logs in again.

m) In the **Permissions** field, choose the user's permission setting preference for My Group when creating new objects. My Group is the object owner's default group.

   **Note** Settings for My Group configures whether other users who belong to this user's default group can write, or execute the objects. Higher level permissions persist and override other permissions.

**Step 3** Under the Groups tab, you can determine which groups this user is a member of and how to add group membership(s) for a user. You can view the following:

   - **My Group**: This field shows the user's default group. The Security Administrator can change it. The group is represented as “My Group” for the user.

   - **Available Groups**: This list shows all the groups that have been created and that the user is not yet a member of. You can use arrows to move groups between columns.

   - **Selected Groups**: This column shows all the groups that the user is a member of. You can use arrows to move groups between columns.

   **Note** By default, every user has AllUsers in their Selected Groups column. You cannot remove the AllUsers group from the Selected Groups column.

---

**User Groups**

User Groups page opens from the Security drawer. Use it to see the existing groups, to create or delete groups, and to review or edit group information.

The following are the two default groups created by the system:

- **The AllUsers group** is supplied by Unified Intelligence Center. All users belong to this group by default.
The Administrators group consists of administrators.

**Table 11: Fields on the User Groups Page**

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name Contains</td>
<td>Use this filter field to narrow down the list of group names or to move to a specific name.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the group.</td>
</tr>
<tr>
<td>Full Name</td>
<td>The full name shows the child relationship of a group, as indicated by a dot separator. For example, if the default group for Group 3 is Group 1, and Group 1 is a top level group (does not have a parent), then the Full Name of Group 1 is Group1. The Full Name of Group 3 is Group1.Group3.</td>
</tr>
<tr>
<td>Description</td>
<td>Description text of the group.</td>
</tr>
</tbody>
</table>

You can perform the following actions on the User Groups page:

- **Create**—Opens the Group Information page.
- **Edit**—Select the group name and click Edit to open the Group Information page.
- **Delete**—Select the group name and click Delete.
- **Refresh**—Refreshes the page to show any changes to the Group List.
- **Help**—Opens online help.
- **X**—Closes the page.

**About User Groups**

User Groups are constructs that allow security administrators to partition Unified Intelligence Center functionality.

Creating User Groups expedites the process of provisioning users when multiple users need the same access to dashboards and reports, or when users require distinct permissions and features based on regional or organizational requirements.

User groups have no impact on how data is stored in the database. They are used only for assigning permissions to all the user members of the group through one operation instead of repeating the same operation for each user.

**System-Defined All Users Group**

All users are automatically a member of the system-defined All Users group. All Users always appears on the Manage User Groups window. The security administrator cannot delete it.
System-Defined Administrator User Group

The security administrator is automatically a member of the system-defined Administrators group and can add other security administrators to it.

Additional Security Administrators must be added to the Administrators group. Having the role does not automatically make them members of that group.

Customer-Defined User Groups

Security administrators can create any number of user groups and can add users to them. From those other user groups, one is designated as the user’s Group (also called My Group).

Default Group

After creating the customer-defined groups, the security administrator can add a user to any of these groups and can configure one of them as the user’s default Group (My Group). The All Users group can also be selected as the default group.

The owner of an object can set permission for its Group, and the All Users group. Only the Security Administrator can set extra permissions to other groups or individual users on the User Permissions page. A user’s access permission to an object is the highest level of the permission that user gets from all the permission sources.

Create a User Group

To create a user group, perform the following:

Procedure

Step 1 Navigate to Security > User Groups.

Step 2 Under the General Information tab, perform the following:

a) In the Group Name field, enter the name of the group. This field is available only when you create a new group.
b) In the Description field, enter or modify text to describe this group

Step 3 Under the Groups tab, perform the following:

a) Default Group—From the drop-down list, enter the default group.
b) Available Groups—Lists the groups that were created and that are available for this group to become a child of. Click > or < to move just that group or groups.
c) Selected Groups—Lists the groups that this group is a child of. Click > or < to move just that group or groups.

Step 4 Under the Groups Members tab, perform the following:

a) Under Users tab:

• Available Users—Lists all the users that were created and that are available to be children of this group. Click > or < to move just that group or groups.

• Selected User Members—Lists the users that are currently children of this group. Click > or < to move just that group or groups.
b) Under **Groups** tab:

• **Available Groups**—Lists all the groups that were created and that are available to be children of this group. Click > or < to move just that group or groups.

• **Selected Groups Members**—Lists the groups that are currently children of this group. Click > or < to move just that group or groups.

**Step 5**  
Click **Save** to update new entry or changes to the fields.

**Step 6**  
Click **Cancel** to cancel or close the page.

### Manage User Permissions

Use this page to set extra permissions to Groups or to individual users.

User permissions page has the following tabs:

#### About Permissions

User Roles are associated with people and permissions are associated with objects. Unified Intelligence Center objects are Dashboards, Reports, Report Definitions, Data Sources, Categories, Value Lists, and Collections.

Permissions:

- **EXECUTE**: When the user has EXECUTE permissions for an object, that user can perform some actions that depend on the object.

  For example, with EXECUTE permission, a user can run, print, and refresh a report, open and refresh a dashboard and run a dashboard slide show, and see a Value List query. EXECUTE permission includes the read permission.

  **Note**  
  Permissions set on categories are not recursive. For all entities under Dashboard, Report, or Report Definition types, you need separate EXECUTE/WRITE permissions.

- **WRITE**: When the user has WRITE permission for an object, that user can alter, rename or delete the object. For example, With WRITE permission, you Save As, import, and export reports; you can edit a data source and can delete a custom Value List. WRITE permission also includes EXECUTE and read permission.

  **Note**  
  If no check boxes are selected when setting permission for an object, the user has no access privileges to the object.

The following rules are applicable for all category trees in Unified Intelligence Center — Reports, Report Definitions, Dashboards.

- To delete an entity, you need WRITE permissions for the entity and the entity's parent category.
To delete a category, you need WRITE permissions for the category, the category's parent, and all the categories and/or entities belonging to the category.

A user can only Edit or Save an entity even if the immediate parent category has no WRITE permissions.

A user can only use the Save As feature if the entity has no WRITE permissions enabled.

Any category owner within the Imported Report Definitions can delete a category if the administrator provides explicit WRITE permissions on the Imported Report Definitions category.

Permissions are combined and the highest level prevails.

A user receives permission for an object from different sources. Permission can be inherited from the AllUsers group, the Default Group (My Group), or the permission assigned by the Security Administrator. Among all these permissions, the highest level permission is used when the user accesses the object.

**User Roles and Permissions**

Your User Role allows you to "open" the drawer that corresponds to that role. If you have EXECUTE permission, you can create objects for that drawer. For example, if you are a Dashboard Designer, you can create dashboards on the Available Dashboards page.

When you create an object, you are the owner of that object. You have WRITE permission for the object, and you can set the permissions for that object for All Users and for users in your Group.

If the object is still a work-in-progress and you do not want anyone to access it yet, you can make it "private" by leaving all permissions unchecked for both the All Users and the Groups.

When the object is ready, set your default Group (My Group) permissions to EXECUTE or even WRITE. For example, if you create a Dashboard for your Group and the dashboard has notes, you might want others in your Group to update the notes.

Even though you are a Dashboard Designer, if the Available Dashboards page contains dashboards created by (owned by) other Dashboard Designers, you may not be able to see those dashboards, based on your Group permissions and on the object-level permissions those owners have set for their dashboards.

**Assigned Group Permissions**

**Procedure**

**Step 1** Select the object type in the Permissions For panel. For Dashboard, Report or Report Definition type, you can select a category or an object within a category. For other object types, select an object from the list. All the groups that have already been assigned permissions for the object are displayed in the Group permissions for the selected item panel.

**Step 2** Select a group in the All Groups panel. All user members of this group are displayed in the All Users for the selected group panel.

**Step 3** Click Set Permissions. Check the level you want for the group (Execute, Write), and click OK.

**Step 4** The Group Permissions for the selected item panel updates to include the group and its assigned permission you defined in Step 3.
If the Security Administrator adds or changes User Permissions, the change may not occur immediately.

### Table 12: Fields on the Group Members Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permissions For panel (top left)</td>
<td>Click the drop-down list to select the objects for which you want to set permissions. Options are: Data Sources, Report Definitions, Reports, Dashboards, Value Lists, and Collections. Selecting an object type refreshes the panel to show the list of items or categories for that object.</td>
</tr>
<tr>
<td>All Groups panel (top right)</td>
<td>This panel shows the available User Groups. Highlighting a user group refreshes the page to display an All Users for Selected Group panel that lists the member of the group.</td>
</tr>
<tr>
<td>All Users for the Selected Group panel (bottom right)</td>
<td>This panel shows all members in the group that is highlighted in the All Groups panel above.</td>
</tr>
<tr>
<td>Set Permissions button</td>
<td>Click this option to open a dialog box where you select the permission level for the selected object in the Permissions For panel and the selected group in the All Groups panel.</td>
</tr>
<tr>
<td>Group Permissions for the selected item</td>
<td>This panel shows the groups that have already been assigned permission for the selected object, and their permission level.</td>
</tr>
</tbody>
</table>

### Assigned User Permissions

**Procedure**

**Step 1** Select the object type in the Permissions For panel. For Dashboard, Report, or Report Definition type, you can select a category or an object within a category. For other object types, select an object from the list. All the users that have already been assigned permission for the object are displayed in the User permissions for the selected item panel.

**Step 2** Select a user name in the User List panel.

**Step 3** Click **Show Groups** to see the groups for which this user is a member.

**Step 4** Click **Set Permissions**, check the level you want for this user (Execute, Write), and click **OK**. The **All Permissions for the selected item** panel refreshes to show the user permissions you have added or changed for this user in steps 3 and 4.
Click the drop-down arrow to select the kinds of object for which you want to set permissions. Options are Data Sources, Report Definitions, Reports, Dashboards, Value Lists, Collections, and System Collections. Selecting an object type refreshes the panel to show the list of items or categories for that object.

This panel shows current users. Filter the list and select one or many user names.

Click this option to show the All Groups for the selected user panel.

This panel shows all groups to which the highlighted username in the User List panel above is a member.

Click this option to open a dialog box where you select the permission level for the object (Execute, Write).

This panel shows users who have permission for the object, and the level of permissions they have.

You cannot change the permission for the owner of an object. The owner always has Write permission for the object. For example, if a user is the owner of Report 1, then that user has WRITE permission for Report 1, and no one else can change the permission to EXECUTE.

Security Administrators can select a name on the User List page and click Run As. This refreshes the Unified Intelligence Center web page so that it reflects the interface that user has when logged in.

Use this tool to verify that the User Roles and permissions are configured properly.

- When you Run As another user, the top of the page shows both your Logged In identity and your Run As identity.
- You cannot Run As yourself.
- You can Run As one level of user. A Security Admin cannot Run As User A and, as User A, then Run As User B.

To leave Run As mode, click Stop Run As at the top of the page.
Audit Trail Logging in Cisco Unified Intelligence Center

Unified Intelligence Center now supports Audit Trail Logging. This feature allows you to view the sequence of audit records of the transactions related to create, update, modify, and delete that are performed on the entities of a Unified Intelligence Center server. You can view the audit trails using the Audit Trail stock report. Only System Administrators can access and view this feature by default. However, a System Administrator can then give permissions to other Unified Intelligence Center users to use this feature.

Note
Localization of Audit Trail report is not supported.

View Audit Trail Logging in Unified Intelligence Center

Procedure

Step 1
Log in to the Unified Intelligence Center Reporting Interface.

Step 2
Navigate to Reports > Stock > Intelligence Center Admin and click Audit Trail. The system opens the Audit Trail Report Filter window.

Step 3
Specify the required filter criteria and click Run. The system displays the Audit Trail report based on the filter criteria that you specified.

Audit Trail Report

Views: This report has three grid views - Non-grouped, Groupby – EntityName, Groupby – Username.

Grouping: This report has two grouped views - grouped and sorted by User and Entity Name. The third view is un-grouped which is also the default view for this report.

Value List: CUIC Users, CUIC Operations, CUIC Entity Types.

Database Schema Tables from which data is retrieved:
- CUICAUDITLOG
- CUICLOGEDENTITY

Security Considerations

If you make the user a member of one or more other groups, make one of those groups the user's default group, and set the permissions for the default group higher than those of the AllUsers group.

Higher permissions for the default group prevail over permissions in the AllUsers group. Individual user permissions prevail over group permissions.
XSS Vulnerability

Cross-site scripting (XSS) vulnerability is addressed in Unified Intelligence Center. If a malicious script, pattern, or input is entered into Unified Intelligence Center server, then the server displays a warning message “Malicious Input data detected”.

A user accessing Unified Intelligence Center should ensure that free format texts do not contain the following special characters:

- parentheses pair (( ))
- angle bracket (>)
- forward slash (/)
- question mark (?)
- Any executable scripts (for example, JavaScript)

Also, the text should not start with a quote (" ) or quotation mark (’ ).

Note

- XSS vulnerability is addressed only for English locale in Unified Intelligence Center.
- In release 10.5(1), XSS vulnerability is not addressed for widgets in Dashboards.
- XSS vulnerability is not addressed during the import of reports and report definitions (XML/zip), and also during the upload of help files (Html/zip) for release 10.5(1).
- For existing customers, who has already used these special characters in any entities under Reports, Report Definitions, Dashboards, Data Sources, Value Lists, or Collections, Unified Intelligence Center allows you to view these existing entities. However, when the customer wants to customize these entities, they have to ensure that the above mentioned characters are not used in the free format texts.
Unified CCX Outbound Dialer Configuration

- Outbound Feature for Unified CCX, page 233
- Supported Dialers and Dialing Modes for Outbound, page 237
- Configure General Outbound Properties, page 239
- Configure Outbound Subsystem in Unified CCX, page 245
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, page 245
- Add New Campaign, page 246
- Import Contacts for Campaign, page 256
- Do Not Call Contacts, page 257
- Enable Campaigns, page 258
- Outbound Subsystem and Time Detection, page 259
- Add Area Codes, page 259
- Communication with Agents Desktops, page 260
- Contact States Reset at Midnight, page 261
- Call Retrieval Priority, page 261
- Failover and System Restarts, page 262

Outbound Feature for Unified CCX

The Outbound feature provides outbound dialing functionality in addition to existing Unified CCX inbound capabilities.

The Unified CCX Direct Preview Outbound feature is bundled along with the Unified CCX Premium license package. The Unified CCX IVR and Agent Progressive and Predictive Outbound feature is available with the Unified CCX Outbound license. When you upload the Premium license, the Outbound subsystem will automatically appear in the Subsystems menu. With this Outbound feature, you can maintain high agent productivity by configuring contact centers for automated Outbound activities to perform Outbound calls.
Outbound Characteristics

The Outbound feature has the following characteristics:

- An Outbound subsystem that can be monitored from the control center
- IVR and Agent Progressive and Predictive Outbound
- Dialing modes - Direct preview, Progressive and Predictive
- Unified CCX Administration web pages, REST API to configure the Outbound feature
- Outbound Historical reports
- Outbound Live Data reports (Unified Intelligence Center)
- Real-Time reports are part of the Unified CCX Administration GUI real-time reporting applet

Note
Calls made by the Outbound subsystem will not be displayed in the Contacts Summary Real-Time Report

- Access to real-time Outbound data from the GetReportingStatistics step for Direct Preview Outbound
- Cisco Agent Desktop allows agents to handle Direct Preview Outbound calls
- Cisco Finesse allows agents to handle Direct Preview, Progressive and Predictive Outbound calls

Related Topics
Unified CCX Real-Time Reports, on page 186
Outbound Feature for Unified CCX, on page 233
Unified CCX Requirements, on page 234
Outbound Components, on page 236
Direct Preview Dialing Mode, on page 238

Unified CCX Requirements

To use the Outbound feature, you must adhere to the following requirements:

Unified CCX Licensing Requirements
The licensing requirements for Outbound feature in Unified CCX will vary depending on the dialing modes.

- For Unified CCX Outbound Direct Preview Dialer—The Unified CCX Outbound Direct Preview Dialer feature is automatically available with Premium license package without any additional license. It is no longer available with Enhanced license.

- For Unified CCX Outbound IVR Dialer—You need to upload an Outbound license on top of the Unified CCX premium license with the required number of IVR ports that you would like to use for the Outbound feature.
• For Unified CCX Outbound Agent Dialer—You need to upload an Outbound license on top of the Unified CCX premium license with the required number of agent seats that you would like to use for the Outbound feature.

Note
The sum of inbound and outbound IVR ports should be less than or equal to a maximum number of IVR ports supported for your hardware model.

You can view the licensed IVR ports for outbound and inbound and the dedicated ports for both outbound and inbound calls by navigating to System > License Information > Display License(s) submenu from the Unified CCX Administration menu bar.

Scenario 1:
If your Contact Center is already utilizing maximum licensed IVR ports supported for your hardware model, then:

• Inbound calls will take precedence over the configured Outbound IVR calls.

• If IVR ports are dedicated for a campaign, then the Outbound IVR ports available for the campaign will be gradually incremented as and when the inbound ports become free.

For example, if you have an UCS C220 hardware that supports maximum of 300 IVR ports and if you have 200 premium seats, then the current licensed IVR ports = 300 (Minimum of [seats*2, maximum supported for platform]).

In this case, if you upload an Outbound add-on license for 100 IVR ports and add 3 campaigns with 20 dedicated ports each running at the same time, then the 60 Outbound IVR ports will be available to the campaigns only when the number of inbound ports are freed up to support the Outbound IVR calls.

In other words, if the number of inbound ports that are used during the outbound IVR campaign time is 280, then only 20 Outbound IVR ports will be available to the campaigns. The number of Outbound IVR ports will be gradually incremented depending on the availability of free inbound ports.

Scenario 2:
If your Contact Center is close to utilizing the maximum IVR ports supported for your hardware model, then:

• Inbound calls will take precedence over the configured Outbound IVR calls.

• If IVR ports are dedicated for a campaign and if you reach the maximum inbound call limit, then the Outbound IVR ports available for the campaign will be gradually incremented as and when the inbound ports become free.

For example, if you have an UCS C220 hardware that supports a maximum of 300 IVR ports and if you have 130 premium seats, then the current licensed IVR ports = 260 (Minimum of [seats*2, max supported for platform]).

In this case, if you upload an Outbound add-on license for 50 IVR ports and add 2 campaigns with 25 dedicated ports each running at the same time and if you reach the inbound call limit of 260 during the outbound IVR campaign time, then only 40 ports (300-260) will be freed up initially for Outbound IVR calls. The number of Outbound IVR ports will be gradually incremented depending on the availability of free inbound ports.

Scenario 3:
If your Contact Center is using fewer ports than the maximum licensed ports supported for your hardware model, then the number of available IVR ports for inbound will continue to remain the same.
For example, if you have an UCS C220 hardware that supports maximum of 300 IVR ports and if you have 60 premium seats, then the current licensed IVR ports = 120 (Minimum of [seats*2, max supported for platform]).

In this case if you upload an Outbound add-on license for 50 IVR Outbound ports, and add 2 campaigns with 20 dedicated ports each running at the same time, then Unified CCX will support 40 IVR Outbound calls, and the inbound port limit will continue to be 120 as the sum of both inbound and outbound ports (160) are within the maximum licensed ports (300) for the platform.

**Unified CCX Subsystem Requirements**

- The Outbound subsystem must be IN SERVICE.
- The RmCm subsystem must be IN SERVICE.
- The Unified CM Telephony subsystem must be IN SERVICE.
- The Unified CCX Database must be IN SERVICE.

**Geographic Region Support**

- The Outbound feature can be used in any geographic region supported by Unified CCX. The area codes and time zones mapping for North America are automatically prepopulated in the system. The system uses this information to determine the time zone of a customer’s phone number.

- For regions outside North America, administrators must enter the mapping of the international area codes and their time zones using the Unified CCX Administration GUI or REST API.

- The national do_not_call list is not supported in this release. Be sure to abide by the national do_not_call list.

---

**Note**

In this guide, the underscore character linking each word differentiates the national do_not_call list from the Outbound subsystem's Do Not Call list.

**Related Topics**

- Cisco Unified Contact Center Express License Packages, on page 417
- Outbound Feature for Unified CCX, on page 233
- Upload Licenses, on page 11
- RmCm Provider Configuration, on page 97
- Add Area Codes, on page 259
- Outbound Subsystem and Time Detection, on page 259
- Do Not Call Contacts, on page 257

**Outbound Components**

This section provides details about the following Outbound feature components:

- Unified CCX Administration—Enables the Outbound subsystem configuration, creates campaigns, and imports contacts to generate the dialing list.
• Outbound subsystem—Is responsible for the following tasks:
  ◦ Manages campaigns
  ◦ Maintains Outbound system configurations
  ◦ Manages the dialing list
  ◦ Reserves agents
  ◦ Makes Outbound calls
  ◦ Updates the call data in the dialing list based on the outcome of the call
  ◦ Decides which contact records to retrieve from a campaign

The Outbound subsystem views campaigns as logical entities that group a set of contacts together in a dialing list. Campaigns deliver outgoing calls to agents. Agents are assigned to campaigns using CSQs.

Related Topics
  Outbound Feature for Unified CCX, on page 233
  Outbound Characteristics, on page 234
  Unified CCX Requirements, on page 234
  Direct Preview Dialing Mode, on page 238

Supported Dialers and Dialing Modes for Outbound

In addition to the existing Direct Preview Outbound dialer option, Unified CCX supports IVR-based and agent-based dialing. If you select the IVR-based option for a campaign, the outbound calls are handled by IVR scripts. If you select the agent-based option for a campaign, the outbound calls are handled by agents. Typical applications include appointment and bill-payment reminders.

Unified CCX Outbound Dialer Types

You can choose any one of the following dialer types for an IVR or agent based campaign:
  • Progressive
  • Predictive

Progressive/Predictive Dialer is developed to leverage call control and Answering Machine Detection (AMD) capability of SIP Gateway Interface to perform dialing, call control, and Call Progress Analysis for Outbound campaigns. The dialer offloads call control from the Unified CM, because the calls that need not be treated by an IVR or an agent, such as no answers, busy tones, and so on are not sent to Unified CM.

You can procure Unified CCX Outbound license based on the IVR ports and the agent seats that you want to use for an Outbound campaign. You need to upload an additional license for Outbound feature. The Outbound feature will not be available with Premium license of Unified CCX (see Unified CCX Requirements, on page 234).
The Outbound feature is not supported in the following Unified CCX packages:

- Unified CCX Standard version
- Unified CCX Enhanced version
- Unified IP IVR

Unified CCX Outbound Dialing Modes

The Outbound feature in Unified CCX Release supports the following dialing modes:

- Direct preview dialing mode
- Progressive dialing mode
- Predictive dialing mode

Tip

For agent predictive and agent progressive outbound calls, disable the Call Waiting option on the agent's phone to allow agents to preview a customer call on CAD or Finesse before the call is placed. The Call Waiting option must be disabled (default) in Unified Communications Manager on each Outbound agent phone to ensure that every customer call successfully transfers to an available agent.

When an Outbound call is transferred or conferenced to another agent, the second or subsequent agents are not counted towards the number of Outbound licenses. For example, if you have five seats licensed for Outbound and Agent1 gets an Outbound call, Agent1 accepts the call and conferences in Agent2 and Agent3. Now, three agents are on one Outbound call but only Agent1 is considered an Outbound agent and you are only using one licensed seat. Consequently, your system allows four more Outbound calls to agents.

Direct Preview Dialing Mode

The direct preview dialing mode allows agents to preview a customer call on CAD or Finesse before the call is placed. The advantage of this mode is that an agent is already on the call when the customer answers and can quickly begin talking with the customer immediately.

Caution

In case of CAD, When Agent A transfers an Outbound call to Agent B, all Preview Outbound option buttons are enabled on Agent B's desktop. Despite all buttons being enabled, Agent B must only select the Do Not Call or the callback buttons at this time.

Likewise, after transferring the call to Agent B, Agent A should not attempt to set or change a callback time for that call.

Related Topics

- Outbound Feature for Unified CCX, on page 233
- Outbound Characteristics, on page 234
Progressive Dialing Mode

In the Progressive Dialing mode, you can specify a fixed number of lines that will always be dialed per available IVR port or per available agent. You can configure the progressive dialer settings for each campaign while creating the campaign through Unified CCX Application Administration web interface. You can also update the configuration at a later date.

Related Topics

Add New Campaign, on page 246

Predictive Dialing Mode

The Predictive Dialing mode works similar to the Progressive Dialing mode in terms of dialing the Outbound calls. The difference remains in tuning the lines per port or per agent depending on the abandoned call-rate thus eliminating manual intervention as in the case of the Progressive Dialer.

In other words, in the Predictive Dialing mode, the Dialer adjusts the number of customers to dial per available IVR port or per available agent. The number of lines to dial is calculated by an algorithm and gets updated automatically.

Configure General Outbound Properties

General Outbound properties refer to the settings that is common for all the campaigns.

⚠️ Caution

Area code and long distance prefix configuration changes made to the Outbound subsystem do not take effect for the calls/contacts that are currently in the Outbound subsystem's memory. For example, if you change the long distance prefix or local area code, the contacts that are already in the Outbound subsystem's memory will continue to use the old long distance prefix and local area code.

To configure general Outbound properties, complete the following steps.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Subsystems > Outbound > General.
The General Configuration web page opens.

Step 2
Specify the following fields in the General Configuration section:
### Field | Description
--- | ---
Customer Dialing Time Range (hh:mm) Start Time/End Time | The time range during which a customer can be called. This time range supersedes the time range of the individual campaigns and ensures that a customer is never called outside the legally allowed time range for that country. This is a mandatory field.
For example, in the USA, the Federal Communications Commission (FCC) specifies the legal time range as 8 AM to 9 PM. This does not apply to callbacks, since the customer explicitly requested to be called at a certain time. This time range is always converted to the local time for each contact record.
Default = 8:00 AM to 9:00 PM (USA FCC regulations)

Outbound Call Timeout (seconds) | If an agent does not respond to the Outbound preview call on the Cisco Agent Desktop or Finesse within the timeout duration that is specified in this field, the system sets the agent to the Not Ready state.
If an agent does not respond to the Outbound progressive or predictive call on Finesse within the timeout duration that is specified in this field, then the call is dropped. The system sets the agent to the Ready or Not Ready state depending on the option that is selected for Agent State after Ring No Answer field in the System Parameters Configuration Web Page. This is a mandatory field.
Default = 60 seconds, Range = 5 to 3600 seconds.

**Note** | • This field is used only when Agent AutoAnswer is disabled for agent-based progressive and predictive outbound campaigns.
• If the Unified CCX Engine or Finesse restarts when a call is being presented to an agent, then the timeout value specified in the Outbound Call Timeout field will not be applicable for that call.

Dialing Prefix | The number to prefix to the phone number for dialing outgoing calls (also referred to as switch prefix). This number can have any numeric value, including 0 or leading zeros.

Long Distance Prefix | The number to prefix to the phone number for dialing long distance. This number can have any numeric value, including 0 or leading zeros.

International Prefix | The number to prefix to international phone numbers. This number can have any numeric value, including 0 or leading zeros.

Local Area Code | The area code of the Unified CCX server location. This number can have any numeric value, including 0 or leading zeros.

Do Not Remove Local Area Code When Dialing | If this box is checked, the local area code is included when dialing the phone numbers within this area code. If it is unchecked, then the local area code is stripped from the phone number before dialing the local numbers. It is expected that when contacts are imported into the system, the phone numbers include the area code. For international phone numbers, the country code must be included when importing contacts.
Configure General Outbound Properties

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Long Distance Prefix</td>
<td>This field will be displayed only if you check the Do Not Remove Local Area Code When Dialing check box. For local numbers, the long distance prefix will be prefixed only if this check box is checked. The long distance prefix will be prefixed to the phone number for all non-local numbers (the numbers that do not start with local area code) irrespective of the status (checked/unchecked) of this check box.</td>
</tr>
<tr>
<td>Agent AutoAnswer</td>
<td>If this box is checked, any agent-based progressive or predictive campaign call that gets transferred to the agent is automatically answered by Unified CCX. This check box is checked by default. The agent need not manually answer this call.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> • Either check this option in Unified CCX, or set Auto Answer to 'yes' in Unified Communications Manager. Do not select both of these options. • It is recommended to enable Agent Autoanswer so that the call presented to the agent is automatically answered. A beep tone notifies the agent that the call has been answered.</td>
</tr>
<tr>
<td>Assigned CSQs</td>
<td>Assigned CSQs are CSQs that are used by the Outbound subsystem. This is a mandatory field. To allocate CSQs for Outbound: 1 Select a CSQ in the Available CSQs list. 2 Select a value from the % of Logged in Agents for Outbound drop-down list to indicate what percentage of the CSQ is allocated for Outbound. 3 Click the left arrow icon to move the CSQ to the Assigned CSQs list. The selected CSQ is removed from the Available CSQs box and appears in the Assigned CSQs box with the percentage allocation in parentheses next to the CSQ name.</td>
</tr>
<tr>
<td>Available CSQs</td>
<td>The Available CSQs pane displays all CSQs configured in the CSQ Configuration page under the RmCm subsystem configuration.</td>
</tr>
<tr>
<td>% of Logged in Agents for Outbound</td>
<td>The % of Logged in Agents for Outbound field indicates the percentage of logged in agents in each of the selected CSQs that are allocated for handling Outbound calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The CSQ allocation percentage is defined at the global level and not at a campaign level. For example, if a CSQ has 100 agents and 20% are allocated for Outbound, a pool of 20 agents are shared among the Outbound campaigns. In the Add New Campaign web page, you can specify the CSQs to assign to a campaign.</td>
</tr>
</tbody>
</table>

**Step 3** Click Update icon that is displayed in the tool bar in the upper, left corner of the window or the Update button that is displayed at the bottom of the window.
The System Options components are now updated.

**Related Topics**

- Outbound Feature for Unified CCX, on page 233
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Callbacks, on page 242
- Outbound Area Code Functionality, on page 243
- Configuration Updates, on page 243
- CSQ Agent Pool Allocation, on page 244

**Callbacks**

A customer can request a callback at a specific callback phone number and also specify the time/date of the callback. The Outbound subsystem stores this information (the callback phone number, date, time) in the dialing list table.

The Outbound subsystem handles the callback as follows:

- **Convert to GMT**—The callback date and time specified with respect to the customer's time zone is converted to GMT time zone and then stored in the database.

- **Agent not Available**—When the Outbound subsystem looks up the database for contacts, it first checks the callbacks. The default callback time limit is 15 minutes (can be changed) before and after the customer-specified time. If an agent is available, then the Outbound subsystem places the callback. If an agent is not available, the Outbound subsystem retries agent availability (agent state) after 10 minutes.

- **Missed Callbacks**—If the Unified CCX system is unable to process a callback request in the specified time, you have three action options:
  - Reschedule it to the same time on the next business day.
  - Mark it as another retry (the callback phone number is removed and the callback date time is ignored). In this case, it moves out of the call back state and into the retry state.
  - Close the record (never dialed again).

**Note**

The selected status for the Missed Callbacks is applied at midnight.

- **Agent reclassifications**—If calls were retrieved and presented to the agent and if the agent reclassifies it (for example, changed it to answering machine status), then the call status is updated to the answering machine.

- **Invalid number**—If the number is invalid, the callback continues to be retried until the callback time limit expires or the agent reaches the customer.
If a callback is presented and the callback number is invalid (or busy), the callback continues to be retried irrespective of the number of retries set (for normal busy/invalid). It will be retried until the callback time limit expires.

---

**Caution**

---

**Outbound Area Code Functionality**

In the Outbound option, the area code determines the geographical location of the phone number you dial, which correspondingly provides the Greenwich Meridian Time (GMT) zone. The db_cra database contains a mapping of the area codes to the time zones.

The U.S. area code mappings are provided along with the product. International customers should provide their own data and add it to the database.

**Related Topics**

- Add Area Codes, on page 259
- Outbound Feature for Unified CCX, on page 233
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Outbound Area Code Functionality, on page 243
- Configuration Updates, on page 243
- CSQ Agent Pool Allocation, on page 244

---

**Configuration Updates**

Whenever Outbound parameters are modified in the Unified CCX Administration GUI, the changes take effect immediately. If a new CSQ is added using the **Subsystems > RmCm > Contact Service Queues** menu option, it is instantly displayed in the list of available CSQs in the General configuration page in the Unified CCX Administration GUI, as this list is dynamically updated. If a CSQ is modified and if this impacts the allocation of agents, the Outbound subsystem is aware of this change as it refreshes the list of agents in each relevant CSQ periodically.

- If a configuration change affects the Outbound contacts dialing process (for example, if a campaign is disabled or a CSQ is removed from a campaign), the Outbound subsystem stops processing the Outbound contacts, recalls these contacts to the database, and resets the call status to Pending.

- If a campaign start time is changed, the Outbound subsystem checks if the campaign is enabled. If it is enabled, and if the new start time is after the current time, it performs the following actions:

  - Sends a recall contact message to the Outbound subsystem passing the campaign ID.
For all Outbound contacts for this campaign in the Outbound subsystem's memory that are waiting to be dialed out, it resets all Outbound contacts to the Pending state and clears them from memory.

If the campaign is disabled or if the new start time is before the current time, the Outbound subsystem ignores this change.

• If campaign end time is changed, the Outbound subsystem checks if the campaign is enabled. If it is enabled, and if the new end time is before the current time, it performs the following actions:
  • Sends a recall contact message to the Outbound subsystem passing the campaign ID.
  • For all the Outbound contacts for this campaign in Outbound subsystem's memory that are waiting to be dialed out, it resets all the Outbound contacts to the Pending state and clears them from memory.

If the campaign is disabled or if the new end time is after the current time, the Outbound subsystem ignores this change.

• If a CSQ is deleted from a campaign or if the CSQ itself is deleted, the Outbound subsystem sends a recall contacts message with the csq ID of the deleted CSQ. It also reallocates any Outbound contacts in its memory that are currently allocated to this CSQ among the other existing CSQs for this campaign.

Related Topics

Outbound Feature for Unified CCX, on page 233
Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
callbacks, on page 242
Outbound Area Code Functionality, on page 243
CSQ Agent Pool Allocation, on page 244

CSQ Agent Pool Allocation

You need to specify a percentage of total agents in the assigned CSQs to be allocated for Outbound calls. This pool of agents is shared by all Outbound campaigns.

Tip

The CSQs for Outbound are the same as the CSQs for inbound. If you need more CSQs, you must first configure them in Unified CCX and assign the required CSQs for agents as required by your configuration, before allocating them.

Related Topics

Outbound Feature for Unified CCX, on page 233
Outbound Subsystem and Time Detection, on page 259
Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
Configure General Outbound Properties, on page 239
callbacks, on page 242
Outbound Area Code Functionality, on page 243
Add New Campaign, on page 246
Configuration Updates, on page 243
Configure Outbound Subsystem in Unified CCX

To configure the outbound subsystem, complete the following tasks:

**Procedure**

**Step 1** Install Unified CCX with Unified CM and perform the initial system setup using the Cisco Unified CCX Administration web interface. See *Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR*.

**Step 2** Verify whether you have performed the requirements listed in *Unified CCX Requirements*, on page 234.

**Note** You need to have Unified CCX outbound license on top of Unified CCX premium license to use the outbound feature.

**Step 3** Configure the general properties of the outbound subsystem.

a) Configure customer dialing timerange as determined by the regulations of the required region.

b) Configure the dialing prefixes for your geographic area.

**Step 4** If the dialing list contains contacts outside of North America or if Unified CCX is installed outside of North America, manually add the area codes and their corresponding time zones of the regions.

**Step 5** To enable communication between Unified CCX and SIP gateway for IVR and agent based progressive and predictive campaigns, configure the SIP Gateway parameters using the SIP Gateway Configuration web page in Unified CCX Application Administration web interface.

**Related Topics**

- *Unified CCX Requirements*, on page 234
- *Upload Licenses*, on page 11
- *Configure General Outbound Properties*, on page 239
- *Configure SIP Gateway*, on page 309
- *Add New Call Control Group*, on page 71
- *About Unified CCX Applications*, on page 41
- *Add Unified CM Telephony Trigger*, on page 77
- *Add New Campaign*, on page 246
- *Import Contacts for Campaign*, on page 256

Configure Outbound Subsystem for IVR Campaigns in Unified CCX

To configure the outbound subsystem for IVR Campaigns, complete the following tasks:
Procedure

**Step 1** Create a Call Control Group for Outbound type with the required number of IVR ports to be used for outbound campaigns.

**Step 2** Create an application, which will be used for the outbound campaign.

**Step 3** Create a trigger and assign the newly created Outbound Call Control group to this trigger.

**Step 4** Create a new progressive or predictive outbound campaign.

**Step 5** Import contact for the campaign.

Add New Campaign

Use the Campaign component to configure properties for the campaign, including the campaign name and description, CSQ selection, and the time range when a campaign can call contacts.

**Note** You can create agent-based progressive and predictive outbound campaigns only when Finesse is enabled. If Finesse is disabled, then the campaigns that were created when Finesse was enabled become inactive.

Complete the following steps to define or modify the settings that apply to a campaign.

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > Outbound > Campaigns**. The Campaign web page opens, displaying the details of existing campaigns, if any. Click an existing campaign to view or update the configuration settings for the campaign.

**Step 2** Click the **Add New** icon in the tool bar in the upper, left corner of the window or the **Add New** button at the bottom of the window. Add a New Campaign web page opens up where you can specify the campaign type and the dialer type for the campaign using the following fields.

**Note** You need to upload an Outbound license on top of the Premium license for Unified CCX to create a campaign for Outbound.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select the type of the campaign</strong></td>
<td></td>
</tr>
<tr>
<td>Campaign Type</td>
<td>Type of the campaign to be used for outbound calls. You can specify any one of the following two campaign types:</td>
</tr>
<tr>
<td></td>
<td>• Agent-based—If you select this, all the outbound calls in a campaign will be handled by the available agents.</td>
</tr>
<tr>
<td></td>
<td>• IVR-based—If you select the IVR-based option, the outbound calls in a campaign will be handled by the IVR scripts.</td>
</tr>
</tbody>
</table>
Select the type of dialer for the campaign

<table>
<thead>
<tr>
<th>Description</th>
<th>The dialer type options available for a campaign will vary depending on the selected Campaign Type.</th>
</tr>
</thead>
<tbody>
<tr>
<td>- If you select Agent-based campaign type, then you can select any one of the following dialer types:</td>
<td></td>
</tr>
<tr>
<td>- Direct Preview (default)</td>
<td></td>
</tr>
<tr>
<td>- Progressive</td>
<td></td>
</tr>
<tr>
<td>- Predictive</td>
<td></td>
</tr>
<tr>
<td>- If you select IVR-based campaign type, then you can select any one of the following dialer types:</td>
<td></td>
</tr>
<tr>
<td>- Progressive (default)</td>
<td></td>
</tr>
<tr>
<td>- Predictive</td>
<td></td>
</tr>
</tbody>
</table>

Note: Once the campaign is created, you cannot change the Campaign Type and Dialer Type.

After you select the campaign type and dialer type, click Next to continue. The Campaign Configuration web page opens, displaying the following three column headings:

- Parameter Name
- Parameter Value
- Suggested Value

You can specify values for a new campaign or modify values for an campaign using the fields listed in the Parameter Value column. See the table below for a list of fields along with their description.

The Suggested Value displays the default configuration value for each campaign. You can refer to these values if you want to revert any changes made to one or more parameters listed in the Campaign Configuration web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Campaign Name</td>
<td>Name of the campaign (must be a unique identifier). This is a mandatory field.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Indicates the current state of the campaign to the Outbound subsystem. Yes = The campaign is currently active. No = The campaign is currently inactive (default).</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the campaign.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Start Time/End Time (hh:mm) AM PM Time Zone</strong></td>
<td>Indicate the time range during which the campaign runs. These are mandatory fields. The name of the primary time zone is also displayed adjacent to these two field values. Default = 8:00 AM - 9:00 PM Pacific Standard Time (USA FCC regulations).</td>
</tr>
<tr>
<td><strong>Campaign Calling Number</strong></td>
<td>The campaign calling number is the number that will be displayed to the contact. This number is used by the dialer. This is a mandatory field. Note: This field is not available if you have selected the direct preview dialer type for an agent based campaign.</td>
</tr>
<tr>
<td><strong>Maximum Attempts to Dial Contact</strong></td>
<td>The maximum number of times the Outbound subsystem attempts to dial a contact beyond which the call status will be marked as closed. You can choose this value from the drop-down list box. Default = 3, Range = 1 to 3.</td>
</tr>
<tr>
<td><strong>Callback Time Limit</strong></td>
<td>The time period before and after the scheduled callback time during which the Outbound subsystem attempts to dial out a callback. For example, if a callback was scheduled for 9:30 am and if the Callback Time Limit is set to 15 minutes, then the Outbound subsystem calls the customer anytime between 9:15 am to 9:45 am. This field is also used to determine the dialing time range for the Retries settings in the Add New Campaign web page. Default = 15 minutes, Range = 1 to 60 minutes.</td>
</tr>
</tbody>
</table>

**Fields displayed only if you have selected IVR-based campaign type**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Application Trigger</strong></td>
<td>This is the JTAPI trigger associated with this campaign. There will one-to-one mapping between a campaign and an application trigger. Only those triggers that are not associated with any other campaigns are displayed in the trigger list.</td>
</tr>
<tr>
<td><strong>Application Name</strong></td>
<td>The name of the application associated with the above-mentioned JTAPI trigger. This field is auto-populated.</td>
</tr>
</tbody>
</table>

**Fields displayed only if you have selected Agent-based campaign type**
### Abandoned Call Treatment
If the agent is not available to handle the call, you can choose to abandon the call or transfer it to IVR by selecting the desired radio button in this field. If you choose to transfer the call to IVR, a trigger field and an application name field appears for selection.

The trigger field is a drop-down list of JTAPI triggers associated with this campaign. There is one-to-one mapping between a campaign and a trigger. Only those triggers that are not associated with any other campaigns are displayed in the trigger list.

The application name is associated with the above-mentioned JTAPI trigger. This field is auto-populated.

Transfer to IVR radio button is enabled by default.

**Note**
- This field is not applicable if you have selected the Direct Preview dialer type for an agent-based campaign.
- If the agent is available to handle the call and if Unified CCX fails to transfer the call to the agent, then the call is dropped and will not be transferred to the IVR port.

### Assigned CSQs
The CSQs from which agents are selected for Outbound calls for this campaign. This is a mandatory field.

**Note**
- For agent selection, the CSQs are used in the order in which they are assigned to the campaign.
- CSQs that are associated with agent-based progressive or predictive campaigns cannot be shared across any other campaigns.
- CSQs that are associated with direct preview campaigns can be shared only across other direct preview campaigns and not with agent-based progressive and predictive campaigns.

### Available CSQs
For direct preview campaigns—CSQs that are allocated for outbound but not assigned to any progressive or predictive agent-based campaign.

For progressive and predictive agent-based campaigns—CSQs that are allocated for outbound and not assigned to any other campaign.

---

**Fields displayed only if you have selected Direct Preview dialer type for an Agent-based campaign**

---

**Cisco Unified CCX Administration Guide, Release 10.5**

249
The number of contact records the Outbound subsystem retrieves from the database in bulk for dialing. The allowed values are 1–100. This is a mandatory field. For example, if 50 records are retrieved in bulk for campaign1 and 10 for campaign2 and they are running at the same time, the Outbound subsystem attempts to place 50 Outbound calls for campaign1 and 10 Outbound calls for campaign2. The number of Outbound calls actually placed for each campaign depends upon the number of agents available for the respective campaigns.

Once all the records retrieved for a campaign have been dialed, the Outbound subsystem retrieves another batch of records for that campaign. Over a period of time, it is likely that more contacts would have been called from campaign1 than from campaign2.

If two campaigns run simultaneously and share CSQs or agents, the records in both campaigns may not be processed at the same rate even if their contact cache sizes are identical. It is possible that more records from one of these two campaigns is processed before the other.

Default = 20, Range = 1 to 100

If you select Yes, then the Outbound subsystem retries the contact after all the callbacks and pending contacts for the campaign are dialed out.

Default = No

The following fields in Dialing Options are displayed if you have selected IVR-based campaign type.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Number of Dedicated Ports | Number of dedicated IVR ports that you want to reserve for this campaign based on the number of CTI ports available in the outbound call control group for the campaign duration. That is, the total number of dedicated IVR ports for the selected campaign cannot exceed the maximum licensed ports for outbound IVR minus the sum total of IVR ports dedicated to other campaigns running at the same time. 

You can enter or update this value for a campaign only after associating a trigger with the campaign. Default value = 0, Range = 0 to number of available ports for the campaign duration.

For example, if you have a medium or large profile VM, which supports maximum of 300 IVR ports with 50 licensed ports for outbound IVR and you have already dedicated:

• 20 ports for Campaign1, which runs between 10–12 pm
• 10 ports for Campaign2, which runs between 2–4 pm, then the number of dedicated IVR ports that you can enter in this field for a new campaign cannot exceed:
  • 30 ports if the new campaign runs between 10–12 pm and
  • 40 ports if the new campaign runs between 2–4 pm and
  • 50 ports if the new campaign runs during any time other than 10–12 pm and 2–4 pm

If the number of configured ports for a campaign is greater than the available number of licensed ports at the specified campaign time, then an alert message stating the same will be shown while saving the campaign.

**Note** Ensure that few IVR ports from the total number of licensed IVR ports are left free if you want to use the "Transfer to IVR" option available in the answering machine treatment and abandoned call treatment fields for agent-based progressive and predictive outbound campaigns.

See **Unified CCX Requirements**, on page 234 to know how the licensed IVR ports are distributed between the inbound and outbound IVR calls in different scenarios.
The dialer will try to connect as many live voices to the available port(s) where IVR script is playing and it will disconnect the remaining calls. The probability of abandoned calls increases geometrically as the lines per port increases.

In an IVR based progressive campaign, you can configure the number of lines to dial per port at a time. The dialer will determine the number of calls to dial based on the following calculation - Lines per port * Available number of ports.

In an IVR based predictive campaign, this is the seed value that is passed to the predictive algorithm. Initially the dialer starts dialing with this value.

Note: If you change this value in the middle, the predictive algorithm will take the updated value in this field during the next iteration.

This is a mandatory field.

Default value = 1.5; Range = 1 to 3.

### The following fields in Dialing Options are displayed if you have selected Agent-based campaign type

**Lines Per Port** (1-3)

Number of lines to be dialed for each agent. The dialer will try to connect as many live voices to the available agent(s) and it will disconnect the remaining calls. The probability of abandoned calls increases geometrically as the lines per agent increases.

In an agent-based progressive campaign, you can configure the number of lines to dial per agent at a time. The dialer will determine the number of calls to dial based on the following calculation - Lines per agent * Available number of agents.

In an agent-based predictive campaign, this is the seed value that is passed to the predictive algorithm. Initially the dialer starts dialing with this value.

Note: If you change this value in the middle, the predictive algorithm will take the updated value in this field during the next iteration.

This is a mandatory field.

Default value = 1.5; Range = 1 to 3.

Note: This field is not applicable if you have selected the Direct Preview dialer type for an agent-based campaign.

### Callback Missed

Determines the action that should be taken on the contacts that were not called back. The three options for this field are:

- Reschedule for same time next business day (default)
- Mark it for a retry
- Close the record.

The following fields in Dialing Options are common if you have selected Progressive or Predictive dialer type for IVR-based and Agent-based campaigns.
### Field Description

**Handle Low Volume as Voice**
- Determines whether a low volume call should be treated as voice or disconnected. Select **Yes** or **No** radio button accordingly.
- Default is Yes, which means low volume calls are handled as voice and they are connected to an IVR port or an agent.

**Answering Machine Treatment**
- If the outbound call detects an answering machine, you can choose to end the call or transfer it to IVR by selecting the desired radio button in this field.
- For agent-based campaigns, if you choose to transfer the call to IVR, a trigger field and an application name field appears for selection.
- The trigger field is a drop down list of JTAPI triggers associated with this campaign. There is one-to-one mapping between a campaign and a trigger. Only those triggers that are not associated with any other campaigns are displayed in the trigger list.
- The application name is associated with the above-mentioned JTAPI trigger. This field is auto-populated.
- Transfer to IVR radio button is enabled by default.

### The following fields in Dialing Options are common if you have selected Predictive dialer type for IVR-based and Agent-based campaigns

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Predictive Correction Pace</strong>&lt;br&gt;<strong>(10-1000)</strong></td>
<td>The number of calls that were answered by live voice that the predictive algorithm should consider for each iteration. This is directly proportional with the correction frequency made in the Lines Per Port or Lines Per Agent parameter. This is a mandatory field. Default value = 100, Range = 10 to 1000.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>It is advisable not to change this value.</td>
</tr>
<tr>
<td><strong>Predictive Gain</strong></td>
<td>The Gain parameter controls the size of the lines per port or lines per agent corrections. This is directly proportional to the size of the lines per port or lines per agent correction. This is a mandatory field. Default value = 1.0, Range = Greater than 0 to 1.0.</td>
</tr>
<tr>
<td><strong>Call Abandon Limit</strong>&lt;br&gt;<strong>(0-100)</strong></td>
<td>Call abandon percentage, which should be within the limit specified by Federal Trade Commission (FTC). This is a mandatory field. Default value - 3%, Range 0-100%. This means that no more than three percent of calls that are answered by a person are abandoned, measured per day per calling campaign.</td>
</tr>
</tbody>
</table>

### The following field in Dialing Options is displayed only if you have selected Predictive dialer type for an IVR-based campaign

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Maximum Lines Per Port</strong>&lt;br&gt;<strong>(1-3)</strong></td>
<td>Maximum number of lines to be dialed for each port. You can configure the maximum number of lines that can be dialed per port and the predictive algorithm ensures that it does not exceed this number. This is a mandatory field. Default value = 3.0, Range = 1 to 3.</td>
</tr>
</tbody>
</table>
**Field** | **Description**  
--- | ---  
**The following field in Dialing Options is displayed only if you have selected Predictive dialer type for an Agent-based campaign**  
Maximum Lines Per Agent (1-3) | Maximum number of lines to be dialed for each agent. You can configure the maximum number of lines that can be dialed per agent and the predictive algorithm ensures that it does not exceed this number.  
This is a mandatory field. Default value = 3.0, Range = 1 to 3.  
**Dial Settings (displayed if you have selected IVR-based or Agent-based campaign types)**  
No Answer Ring Limit | The duration for which the progressive/predictive dialer should allow the customer phone to ring before disconnecting an unanswered call.  
The duration is calculated from the time the dialer receives the ringing message from the gateway. If the dialer does not receive any ringing message from the gateway within the time duration entered for this field, then the dialer waits for the same time duration one more time before disconnecting the call.  
For example, if you have configured the value for No Answer Ring Limit as 30 seconds, then the dialer will wait for 60 seconds before disconnecting the call.  
Default = 15 seconds, Range = 1 to 60 seconds.  
**Note** This field is also used to determine the reservation timeout for agent-based progressive or predictive campaigns. If the agent does not receive any outbound calls, then the agent continues to remains in the reserved state up to maximum time duration of twice the value configured in the No Answer Ring Limit field.  
For example, if you have configured the value for No Answer Ring Limit as 30 seconds, then the range for reservation timeout is calculated as 30 to 60 (30 \(\times\) 2) seconds.  
Abandoned Call Wait Time | For IVR-based progressive and predictive outbound campaigns, if the customer disconnects the call within the time set here, then the call is classified as customer abandoned.  
For agent-based progressive and predictive outbound campaigns, if the customer or the agent disconnects the call within the time set here, then the call is classified as customer abandoned.  
This is a mandatory field.  
Default value = 2 seconds, Range = 1 to 10 seconds.  
**Retries (displayed if you have selected IVR-based or Agent-based campaign types):** Set the value for the following four fields as “0” if you want to disable retry option for an existing IVR or agent based outbound campaign.  
**Note** The time duration for the below fields is calculated as the value entered for each field, plus or minus the value entered for the Callback Time Limit field in the Add New Campaign web page.
**Unified CCX Outbound Dialer Configuration**

### Add New Campaign

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Answer Delay</td>
<td>The time duration (in minutes) for which the dialer waits before calling back a no-answer call. Default value = 60 minutes.</td>
</tr>
<tr>
<td>Busy Signal Delay</td>
<td>The time duration (in minutes) for which the dialer waits before calling back a busy telephone number. Default value = 60 minutes.</td>
</tr>
</tbody>
</table>
| Customer Abandoned Delay | • For IVR-based progressive and predictive outbound campaigns, if a customer abandons a call, the time duration (in minutes) after which the dialer should call the customer back.  
  • For agent-based progressive and predictive outbound campaigns, if a customer or an agent abandons a call, the time duration (in minutes) after which the dialer should call the customer back. Default value = 0 |
| Dialer Abandoned Delay | If the dialer abandons a call, the time duration (in minutes) after which the dialer should call back the customer. Default value = 0        |

**Step 3** Click **Add** or **Save** to save the configuration changes. While saving a new or updated campaign, the Outbound subsystem validates the Session values in the application and trigger pages based on following criteria, and it might display an alert message to increase Session value in application and trigger pages:

- In case of a Progressive campaign, the outbound subsystem checks whether the Lines Per Port * Dedicated Port for IVR-based campaigns and Lines Per Agent * Dedicated Agent for agent-based campaigns is greater than the minimum of the Session value in application and trigger.

- In case of a Predictive campaign, the outbound subsystem checks whether the maximum Lines Per Port * Dedicated Port for IVR-based campaigns and maximum Lines Per Agent * Dedicated Agent for agent-based campaigns is greater than minimum of the Session value in application and trigger.

You should increase the Session values in the application and trigger to the suggested value in the alert message to reduce the number of abandoned calls in an Outbound campaign.

Once you create a campaign, you need to import contacts for the campaign.
Import Contacts for Campaign

Attention Cisco recommends that you import a total of 10,000 contacts for a campaign at any given time. If you wish to import more contacts, import them in chunks of 10,000 contacts. You can have a total of 1 million remaining contacts for a campaign.

To import additional contacts, ensure that the total count of additional and remaining contacts for a campaign does not exceed 1 million. The import process is rejected if the total count is greater than 1 million. Import contacts using a comma-separated plain text file with .txt extension. The contacts file should be ASCII-encoded or UTF-8 encoded if it contains special characters (for example, if the contact names are in Chinese, Russian, Japanese and so on).

When contacts are imported, the contact's text file is checked for duplicate entries. If the phone01 value of a contact matches the phone01, phone02, or phone03 values of another contact in the contacts list being imported, then the previous contact is overwritten with the new contact.

Caution You must verify all the contacts against the national do_not_call list before importing them.

Note In this guide, the underscore character linking each word differentiates the national do_not_call list from the Outbound subsystem's Do Not Call list.

Tip Each time contacts are imported, they are appended to the existing list of contacts for the selected campaign. If the new list contains a contact with the same phone01 value as the phone01, phone02, or phone03 value, or the same phone02 value as the phone01, phone02, or phone03 value, or the same phone03 value as the phone01, phone02, or phone03 value, of an existing contact, the existing contact is overwritten with the new contact information. The call history for the contact (if any) is retained.

To import contacts for a selected campaign, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Campaigns. The Campaigns web page opens, displaying the details of existing campaigns.

Step 2 Click the hyperlink below the Name column for the campaign for which you want to import the contacts. The Campaign Configuration web page opens for the selected campaign.

Step 3 Click Import Contacts. The Import Contacts web page opens.

Step 4 Specify a file name to import the contacts from the fields being imported. A contact list can contain up to 7 fields: AccountNumber, FirstName, LastName, Phone1, Phone2, Phone 3 and DialTime.
DialTime field is used to specify the time to dial a number for individual contacts on the current date. The format to be used for this field is HH:MM. For example, to specify the dialing time as 08:25 am, the dial time field value should be 08:25 and for 03:45 pm, the dial time field value should be 15:45.

**Step 5** Navigate to the directory that contains the imported fields in the *same order* as they appear in the text file.

**What to Do Next**

While uploading outbound contacts in a HA over WAN deployment of Unified CCX, if all the contacts that are being uploaded exist in the database and are being modified, follow these guidelines to avoid long delays:

- Upload the contacts during non-peak hours.
- Upload in batches of 500 contacts or less.

---

**Do Not Call Contacts**

**Note** In this guide, the underscore character linking each word differentiates the national do_not_call list from the Outbound subsystem's Do Not Call list.

For direct preview outbound campaigns, when an agent reclassifies an outbound contact as Do Not Call from CAD, then the record of the contact is closed and marked inactive in the database and it will not be dialed again. In addition to this, for all contacts in other campaigns that contain the same phone number as the outbound contact marked as Do Not Call, the records will be closed and marked inactive in the database and those contacts will not be dialed again.

The following actions are performed by the Outbound subsystem:

- All contacts marked Do Not Call are exported to a file. If the file already exists, the new contacts being exported are appended to the file along with a timestamp of when the export was done.
- After the Do Not Call contacts are exported to the file, they are marked inactive in the Dialing List table and are permanently deleted from the database when the database is purged.

**Related Topics**

- Purge of Historical Data, on page 183
- Outbound Feature for Unified CCX, on page 233
- Outbound Subsystem and Time Detection, on page 259
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Configure General Outbound Properties, on page 239
- Add New Campaign, on page 246
- Import Contacts for Campaign, on page 256
- Enable Campaigns, on page 258
- Add Area Codes, on page 259
- Communication with Agents Desktops, on page 260
Enable Campaigns

You must verify that the configured campaigns are active and that the start and end times for the enabled campaigns are specified as required.

To verify the state of the required campaign, complete the following steps.

Procedure

**Step 1**
From the Unified CCX Administration menu bar, choose Subsystems > Outbound > Campaigns. The Campaigns webpage opens, displaying the following information for the existing campaigns:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the campaign.</td>
</tr>
<tr>
<td>Start Time/End Time (hh:mm) AM PM</td>
<td>Start Time and End Time fields indicate the time range during which the campaign runs.</td>
</tr>
<tr>
<td>Remaining Contacts</td>
<td>The Remaining Contacts field indicates the number of contacts that are yet to be dialed for each campaign. In addition to the contacts that have not been dialed, this number also includes contacts that have requested a callback and contacts that will be tried again because of unsuccessful prior attempt(s) (for example, the contact was busy or unavailable). A detailed breakdown of the pending contacts is provided in the Printable Reports page for each campaign.</td>
</tr>
<tr>
<td>Enabled</td>
<td>The Enabled field indicates to the Outbound subsystem whether this campaign is currently active.</td>
</tr>
<tr>
<td>Campaign Type</td>
<td>Denotes whether a specific campaign is IVR-based or Agent-based. The existing campaigns will be marked as Agent-based after an upgrade.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click <strong>Delete</strong> icon next to the name of the campaign that you want to delete.</td>
</tr>
</tbody>
</table>

**Step 2**
Verify that the Enabled field is set to **TRUE** and that the start and end times are specified as required.

**Related Topics**

- Outbound Feature for Unified CCX, on page 233
- Outbound Subsystem and Time Detection, on page 259
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Configure General Outbound Properties, on page 239
- Add New Campaign, on page 246
- Add Area Codes, on page 259
Outbound Subsystem and Time Detection

The Outbound subsystem uses the area code of a contact's phone number to determine the time zone of the contact's calling area. The contact's phone number can also be in E.164 format.

The subsystem provides the mapping for North American area codes to their corresponding time zones. The default North American area codes are used to determine the time zone for phone numbers that are not in the E.164 format (for example, 234-567-8900). The Area Codes web page allows you to add, modify, and delete any area-code-to-time-zone mapping. Some area codes extend across multiple time zones. For such area codes, you can edit the default time zone for that area code and specify a different one, if required.

Changes to area codes take affect the next time you import contacts. For example, if the time zone of area code 603 is changed from 16 to 17, contacts already present in the system that have an area code of 603 continue to have the GMT Offset of 16. Any contacts with area code 603 that are imported after the area code change have 17 for the GMT Offset.

When Outbound contacts are imported into the database, all contacts are assigned a GMT time zone for the three phone numbers provided. The Outbound subsystem determines this GMT time zone by extracting the area code of each phone number and checking it against the Area Codes table to obtain the corresponding time zone. If the area code cannot be matched, the Outbound subsystem uses the local time zone and Daylight Savings Time (DST) setting of the server. The Outbound subsystem also considers the DST to determine if an Outbound contact can be called at a given time.

The Outbound subsystem ensures that the contacts are dialed at valid times. For Outbound contacts which have been scheduled for callback, the scheduled callback time is converted to GMT time zone and stored in the callbackDateTime field in the database.

For pending records, the Outbound subsystem ensures that Outbound contacts are called only within the Customer Dialing Time Range (hh:mm) detected by the MinCustomerDialTime and MaxCustomerDialTime, as per federal regulations. You can configure this time in the Unified CCX Administration GUI.

Related Topics

- Add Area Codes, on page 259
- Import Contacts for Campaign, on page 256
- Configure General Outbound Properties, on page 239
- Outbound Feature for Unified CCX, on page 233
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Configure Outbound Subsystem in Unified CCX, on page 245

Add Area Codes

Caution

Area code and long distance prefix configuration changes made to the Outbound subsystem do not take effect for calls/contacts currently in the Outbound subsystem's memory. For example, if you change the long distance prefix or local area code, the contacts already in the Outbound subsystem's memory will continue to use the old long distance prefix and local area code.

The Outbound subsystem provides all of the mappings from North American area codes to their corresponding time zones at the time of product release. The Area Codes page allows the administrator to add, modify, and delete any area-code-to-time-zone mappings.
Some area codes extend across multiple time zones. For such area codes, an administrator can edit the default time zone for that area code and specify a different one, if required.

The Area Codes Management page allows users to find, add, delete, and modify the mapping of area codes and time zones. The Outbound subsystem uses the area code of a contact's phone number to determine the time zone of the contact's calling area. This page can also be used for adding international area codes. International area codes must include the country code and the city code.

To add an area code, complete the following steps.

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose **Subsystems > Outbound > Area Codes**. The Area Codes Management web page opens.

**Step 2**
In the Area Code field, specify a unique identifier for the area code. This field can have any numeric value, including 0 or leading zeros. This is a mandatory field.

**Step 3**
Click the **Add New** icon that is displayed in the tool bar in the upper, left corner of the window or the **Add New** button that is displayed at the bottom of the window. The new Area Code information is updated.

**Related Topics**

- Outbound Feature for Unified CCX, on page 233
- Outbound Subsystem and Time Detection, on page 259
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Configure General Outbound Properties, on page 239
- Add New Campaign, on page 246
- Import Contacts for Campaign, on page 256
- Enable Campaigns, on page 258

**Communication with Agents Desktops**

In Unified CCX, CAD allows agents to handle Outbound calls. The Cisco Agent Desktop and Cisco Supervisor Desktop do not support any new reports.

To display the additional buttons for the Outbound feature on CAD, the Direct Preview option must be enabled on Cisco Desktop Administrator (CDA). See the *Cisco Desktop Administrator's User Guide* and the *Cisco Agent User Guide* for more information.

**Related Topics**

- Outbound Feature for Unified CCX, on page 233
- Outbound Subsystem and Time Detection, on page 259
- Configure Outbound Subsystem for IVR Campaigns in Unified CCX, on page 245
- Configure General Outbound Properties, on page 239
- Add New Campaign, on page 246
- Import Contacts for Campaign, on page 256
Enable Campaigns, on page 258
Add Area Codes, on page 259

Contact States Reset at Midnight

The Outbound subsystem performs the following actions at midnight:

• The DialingListConfig records with a call status of Unknown are reset to Pending.

  Note
  Outbound contacts with a call status of Unknown indicate that these contacts were retrieved from the database but the system went down before they could be dialed out.

• Missed callback records (dialingListConfig records that have call status callback and a callBackDateTime smaller than the current time) are updated depending on the missed callback action configured in the Unified CCX Administration GUI.

  ◦ MissedCallbackAction: Reschedule (for the same time on the next business day)
  ◦ MissedCallbackAction: Retry (sets the call status to Retry and retries at the start of next business day)
  ◦ MissedCallbackAction: Close (sets the call status to Closed)
  ◦ Dialing list records with a call status of Closed or Max_Calls are moved to a separate historical data table

  Note
  The records marked as closed today will be moved the next day at midnight. For example, the records closed on 4th June will be moved on 5th June at midnight.

  ◦ Dialing list records with a call result of Do Not Call are not deleted, as these records are exported to a text file.

• The DialingListConfig records with a call status of "Retries with delay" and which could not be retried due to lapsed time are marked for immediate retry at midnight.

• When the Unified CCX engine goes from offline to online (for example, the standby server becomes active [online] if the active [first] server fails), the dialing list records with a status of Unknown are reset to Pending.

Related Topics
  Failover and System Restarts, on page 262

Call Retrieval Priority

While retrieving Outbound contacts from the database, records that have scheduled callbacks have priority as the callback time must be adhered to. Outbound contacts are retrieved in the following order of priority:
• Priority 1—Outbound contacts with scheduled callback (call status = 4) and the current time is within the CallbackTimeLimit configured on the Campaigns page (default value is 15 minutes) of the scheduled callback time.

• Priority 2—Outbound contacts to be retried after a specific delay. This is not applicable for direct preview campaigns (call status = 8).

• Priority 3—Outbound contacts in the Pending state (call status = 1).

• Priority 4—Outbound contacts in the Retry state (call status = 6).

Related Topics
Failover and System Restarts, on page 262

Failover and System Restarts

Outbound contacts with an Active call status during a failover indicate that these contacts were retrieved from the database but the system went down either before they could be dialed or after they were dialed but before the call status and call result columns were updated. When the system restarts, the call status for all such Outbound contacts is changed to 7 (Unknown). All Outbound contacts in the Unknown state will be reset to the Pending state (should be retrieved for dialing again) at midnight every night.

If there is an Outbound call in progress during a failover, they cannot be dialed again, as the call status is set to Closed as soon as an Outbound call is placed and these records will not be retrieved for dialing again when the system comes back. However, if the failover happened before the system could update the call status to Closed, these records remain in the Active state and are marked Unknown so they transition to Pending state after midnight. Once they are in the Pending state, they will be dialed again.

Related Topics
Call Retrieval Priority, on page 261
Cisco Unified Contact Center Express Supervisor and User Options Plug-Ins

The following sections provide detailed information on the additional plug-in options provided by the Unified CCX.

• About User Management, page 263
• About Unified CCX User Capabilities, page 263
• Unified CCX Supervisor Web Interface, page 266
• Unified CCX User Options Web Interface, page 268

About User Management

In earlier versions of Unified CCX, many user parameters like userID, password, and pin were configured from the Unified CM Administrator. Some Unified CCX-related user parameters were configured through the Unified CCX Administration.

In Unified CCX, all Unified CCX user roles (capabilities) are consolidated into one User Configuration area. The Unified CM user details are stored in the Unified CM database.

About Unified CCX User Capabilities

The capability for each user refers to the Unified CCX access level assigned for each user. Unified CCX users can be assigned to one of the following four roles (or capabilities):

• Administrator
• Supervisor
• Historical Report User
• Agent

Each of these roles are described in this section.
Related Topics

About User Management, on page 263
Administrator Privileges, on page 264
Supervisor Privileges, on page 264
Historical Report User Privileges, on page 265
Agent Privileges, on page 265

Administrator Privileges

A Unified CCX Administrator is a user with complete access to the Unified CCX Administration and has the authority to configure the entire system. An Administrator can also be assigned a combination of other roles. The Administrator can turn on/off the authority of a Supervisor to manage the teams and agents.

Related Topics

Administrator Capability View Menu, on page 339
About User Management, on page 263
About Unified CCX User Capabilities, on page 263
Supervisor Privileges, on page 264
Historical Report User Privileges, on page 265
Agent Privileges, on page 265

Supervisor Privileges

Supervisors can additionally modify and view skills, view the list of all teams for which this user is the supervisor, view the skills, CSQs, and resource groups configured in this system, view and manage resources, and configure the teams that they are to manage.

Unified CCX provides three types of supervisors:

• **Application Supervisor**: A basic supervisor role applicable to a Unified CCX Application server without a Unified CCX license. An application supervisor can only view reports.

• **ACD Supervisor**: A supervisor with an agent role. This role is applicable to a Unified CCX Application server with any Unified CCX license. An ACD supervisor can administer teams/agents and also view reports. Thus Unified CCX enables dynamic reskilling, the ability by which an ACD supervisor can add or remove skills from an agent without an administrator privilege.

• **Remote Monitoring Supervisor**: An application supervisor role with all numeric characters in the assigned user ID. This role is applicable to a Unified CCX Application server with only a Unified CCX Premium license. In addition to viewing reports, this supervisor can also view the list of agents and CSQs being monitored.

Depending on the license allowed, Unified CCX Supervisors have the following privileges:

• View reports through Unified Intelligence Center web client.

• View agents and CSQ being monitored. This is only for a remote Supervisor.

• Download and install the Supervisor Desktop and the Agent Desktop.
View the list of all teams for which this user is the Supervisor.

Configure the teams managed by the Supervisor.

View the skills, CSQs, and Resource Groups configured in this system.

The RmCm menu can be viewed by the Supervisor only when any of the following two options are selected as the parameter value for the Supervisor Access field located in System > System Parameters > Application Parameters:

- Access to all Teams
- Access to Supervisor's Teams only

View and manage all the resources.

Related Topics

About User Management, on page 263
About Unified CCX User Capabilities, on page 263
Administrator Privileges, on page 264
Historical Report User Privileges, on page 265
Agent Privileges, on page 265
Unified CCX Supervisor Web Interface, on page 266
Supervisor Capability View Menu, on page 339

Historical Report User Privileges

A user with a historical report role can view various historical reports. The number and types of reports allowed to be viewed depends on the licenses available on a given Unified CCX system.

Related Topics

Reporting Capability View Menu, on page 340
About User Management, on page 263
About Unified CCX User Capabilities, on page 263
Administrator Privileges, on page 264
Supervisor Privileges, on page 264
Agent Privileges, on page 265

Agent Privileges

An agent capability is only available with a Unified CCX license.

Unified CM users in Unified CCX are assigned an agent role when an agent extension is associated to the user in the Unified CM User Configuration page. Consequently, this role can only be assigned or removed
for the user using Unified CM Administrator End User Configuration web page. These users cannot be assigned or removed in Unified CCX Administration.

Related Topics
- Provision Unified CM for Unified CCX, on page 25
- Administrator Capability View Menu, on page 339
- About Unified CCX User Capabilities, on page 263
- Administrator Privileges, on page 264
- Supervisor Privileges, on page 264
- Historical Report User Privileges, on page 265

**Unified CCX Supervisor Web Interface**

Use the Unified CCX Supervisor web page to:

- View and monitor permitted agents
- View and monitor permitted CSQs
- Access real-time reports, tools, and settings

Related Topics
- Agent Supervision, on page 267
- Monitor CSQs, on page 267
- Unified CCX Real-Time Reports, on page 186

**Access Unified CCX Supervisor Web Page**

To access the Unified CCX Supervisor web page, perform the following steps:

**Procedure**

1. **Step 1**
   - Ensure supervisor capability is assigned to the user designated as supervisor (see Supervisor Privileges, on page 264 and User View Submenu, on page 337).
   
   **Note** If the supervisor is assigned administrator capability as well, the Unified CCX Administration window is opened instead of the Supervisor web page.

2. **Step 2**
   - From a web browser on any computer on your network, enter the following case-sensitive URL:

     ```
     https://<servername>/appadmin
     ```

   In this example, replace `<servername>` with the hostname or IP address of the required Unified CCX server.

   **Tip** If you have already accessed the Unified CCX Administration application or Supervisor web page in the browser, be sure to logout from the current session using Logout link displayed in the top right corner of any Cisco Unified CCX Administration web page or System > Logout and login with respective user credentials.

   The Unified CCX Supervisor web page appears.
Agent Supervision

The Supervisor can view and monitor agents only when the following conditions are met:

- The Supervisor has to be a remote monitoring Supervisor.
- The resources that are to be monitored should be assigned to the remote monitoring Supervisor.

Related Topics

Create Remote Monitoring Supervisor, on page 116
Assign Resources and Contact Service Queues to a Supervisor, on page 117
Supervisor Privileges, on page 264

Monitor CSQs

The supervisor can view and monitor CSQs only when the following conditions are met:

- The supervisor has to be a Remote Monitoring Supervisor.
- The CSQs that are to be monitored should be assigned to the Remote Monitoring Supervisor.

To monitor CSQs from the Unified CCX Supervisor web page, perform the following steps:

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Select Tools &gt; Plug-ins from the Unified CCX Administration menu bar.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the Cisco Unified CCX Desktop Suites hyperlink.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the View CSQ hyperlink to view allowed CSQs.</td>
</tr>
<tr>
<td>Step 4</td>
<td>When finished, click Logout.</td>
</tr>
</tbody>
</table>

Related Topics

Create Remote Monitoring Supervisor, on page 116
Assign Resources and Contact Service Queues to a Supervisor, on page 117
Supervisor Privileges, on page 264

View CSQ IDs for Remote Monitoring

To view CSQ IDs from the Unified CCX Supervisor web page, perform the following steps:
Procedure

Step 1 From the Unified CCX Supervisor web page, log in as the Remote Monitoring supervisor.
Step 2 Select Tools > Plug-ins from the Unified CCX Administration menu bar.
Step 3 Click the Cisco Unified CCX Desktop Suites hyperlink.
Step 4 Click the View CSQ hyperlink to view allowed CSQs. The CSQ ID column shows the ID value that you should enter for the CSQ that you selected in the Start Monitor Step. See the Start Monitor Step in the Cisco Unified CCX Scripting and Development Series: Volume 2, Editor Step Reference for more information.

Unified CCX User Options Web Interface

Use the Unified CCX User Options web page to perform:

• Unified CCX downloads
• Alternate pronunciations for call by name
• Access the Unified CM User web page

Access Unified CCX User Options Web Page

To access the Unified CCX User Options web page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration, enter http://<Cisco Unified CCX IP address>/appuser.
Step 2 If prompted to do so, enter your UserID and Password. The Unified CCX User Options web page appears.
Step 3 When finished, click Logout.

Download Agent Desktop

To install and configure the Agent Desktop, perform the following steps:

Procedure

Step 1 In the Unified CCX User Options Welcome web page, go to User Options > Cisco Unified CCX Downloads. The Download page appears.
Step 2  Click the Cisco Unified CCX Agent Desktop hyperlink displayed on this page. The File Download dialog box appears.

Step 3  Click Run to install the Unified CCX Agent Desktop on your computer.

Note  You must download Cisco Unified CCX Desktop Client Configuration tool prior to installing any applications from the Cisco Unified CCX Desktop Product Suite.

Cisco Unified CCX Desktop Client Configuration Tool

After completing a fresh installation or upgrade of Unified CCX, you must run the Cisco Unified CCX Desktop Client Configuration tool prior to installing any desktop application(s) from the Cisco Unified CCX Desktop Product Suite.

Since Unified CCX is developed on Cisco Unified Communications Operating System (UCOS), which in turn is based on Redhat Linux, the client MSIs cannot be created while installing the desktop applications. The Unified CCX Desktop Client Configuration Tool uses the client PC for configuring the client MSIs.

The Unified CCX Desktop Client Configuration Tool downloads the files that are needed to create the MSIs into a temporary folder, creates the MSIs, and then uploads those MSIs to the server from where they can be launched through the hyperlinks in the Plug-ins page. This tool uploads the MSIs to the Linux server and cleans up all the folders and files it created on the Windows PC.

From the client PC, which you use to access Unified CCX Administration, choose Tools > Plug-ins menu option; and in the Plug-ins web page, click Cisco Unified CCX Desktop Suites. You will see another web page with the following two categories:

- Cisco Unified CCX Desktop Client Configuration tool
- Cisco Unified CCX Desktop Product Suite

To launch this tool, click the Cisco Unified CCX Desktop Client Configuration tool hyperlink from the Cisco Unified CCX web page. You will see a File Download dialog box. Click Run to run the CAD Client Configuration.msi, which is a Windows Installer (MSI). You will see a dialog box with progress bars showing the status of Agent, Supervisor, and Administrator MSIs that are being packaged and uploaded to the Unified CCX.

If you run this tool from either of the node(s) in a High Availability deployment of Unified CCX, the MSIs are uploaded on both the primary and secondary nodes of Unified CCX.

You must run the Desktop Client Configuration tool in the following scenarios:

- After fresh installation of Unified CCX
- After installing Service Release (SR) and Engineering Special (ES) release of Unified CCX
- After changing the IP address of one or more nodes of Unified CCX
- After installing Unified CCX on the second node
- After moving to single-node from an HA deployment of Unified CCX
- After changing the CAD Language that you want to be available for use in the agent desktops and supervisor desktops of Unified CCX.
Add Alternative Pronunciations

Alternative Pronunciations for Call by Name is an independent feature located on the Unified CCX User Options Welcome web page. This feature lets you add one or more alternate pronunciations for your first or last name and is useful if callers might refer to you by more than one name. For example, if your first name is Bob, you might add the alternate pronunciations “Bob” and “Bobby”. Similarly, if your last name is Xhu, you might add the alternate pronunciation “Xhu”.

To access the Alternative Pronunciations for Call by Name web page, perform the following steps:

**Procedure**

1. **Step 1** In the Cisco Unified CCX User Options Welcome web page, choose User Options > Alternative Pronunciations for Call by Name. The Alternate Pronunciations web page appears.
2. **Step 2** In the First Name field, you can enter an alternate pronunciation of your first name. For example, if your name is “Mary,” you might enter “Maria.”
3. **Step 3** Click Add>>. The name moves to a list of alternate first name pronunciations.
4. **Step 4** Repeat Steps 2 and 3 as needed to add other alternate pronunciations. To remove an alternate pronunciation for your first name, click the alternate pronunciation and then click Remove.
5. **Step 5** In the Last Name field, you can enter an alternate pronunciation of your last name. For example, if your last name is “Smith,” you might enter “Smitty.”
6. **Step 6** Click Add>>. The name moves to a list of alternate last name pronunciations.
7. **Step 7** Repeat Steps 5 and 6 as needed to add other alternate pronunciations. To remove an alternate pronunciation of your last name, click the alternate pronunciation and then click Remove.
8. **Step 8** Click Save to apply the changes.

Access Unified CM User Options Page

To access the Unified CM User Options web page, perform the following steps:

**Procedure**

1. **Step 1** In the Unified CCX User Options Welcome web page, choose User Options > Cisco Unified CM User Page. The Unified CM User Options Log On dialog box appears.
2. **Step 2** Enter your Unified CM user ID and password, and then click Log On. The Unified CM User Options web page appears.
**Step 3**  Click the option you want.

**Step 4**  When finished, click **Logout**.
System Menu

The System menu of the Unified CCX Administration system provides options for performing system-related tasks. Depending on the product package you purchased, the System menu contains some or all of the following menu options:

- Access Server Menu, page 273
- Unified CM Configuration, page 275
- System Parameters, page 275
- Recording Configuration, page 276
- Custom File Configuration, page 276
- License Information, page 276
- Language Information, page 278
- Logout Menu, page 279

Access Server Menu

Choose System > Server from the Cisco Unified CCX Administration menu bar to access the List Servers web page. Use the List Servers web page to view, add, remove, and view servers in the cluster.

Note

Before installing Unified CCX on the second node, you must configure the second server using this procedure. Installation of second node will fail if you do not perform this configuration.

To view, modify, or delete the server configuration information of any server, click the respective hyperlink in the Host Name/IP Address field. The Server Configuration web page opens to display Host Name/IP Address, IPv6 Address (for dual IPv4/IPv6), MAC Address, and Description of the server. Update the values in the fields and click Save to save the changes. Click Delete to delete the configuration information of a server.
Configure Server

To configure a new server that needs to be added to form a Unified CCX cluster for a High Availability setup, complete the following steps.

**Procedure**

### Step 1
Click the **Add New** icon in the toolbar in the upper left corner of the **List Servers** web page or the **Add New** button at the bottom of the **List Servers** web page to add the new server. The Server Configuration web page appears.

**Note**
- The **Add New** button is disabled when two servers are added to the cluster in a High Availability setup.
- A warning message appears when you click the **Add New** button without having a High Availability license.

### Step 2
Complete the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Name/IP Address</td>
<td>Hostname or IP address of the server that you want to add.</td>
</tr>
<tr>
<td>IPv6 Address (for dual IPv4/IPv6)</td>
<td>IPv6 address of the server that you want to add. This field is required only when IPv6 is enabled on the Unified CCX server.</td>
</tr>
<tr>
<td>MAC Address</td>
<td>MAC address of the server that you want to add.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the server that you want to add.</td>
</tr>
</tbody>
</table>

### Step 3
Click **Add** to add details of the new server.

**Configure IPv6 Address**

Follow this procedure to configure IPv6 addressing.
Procedure

Step 1  On the List Servers page, click on the server name link to edit the server details. The Server Configuration web page opens.

Step 2  Enter the IPv6 address or remove it in the IPv6 Address (for dual IPv4/IPv6) field.

Step 3  Click Save to add the IPv6 address.

What to Do Next
Login to Cisco Unified CCX Serviceability page and click Tools>Control Center - Network Services. Restart the Cisco Unified Intelligence Center Reporting service.

Unified CM Configuration

Use the Unified CM Configuration web page to update the following information:

- AXL authentication
- Unified CM Telephony subsystem
- RmCm Provider configuration from within Unified CCX.

Choose System > Unified CM Configuration from the Unified CCX Administration menu bar to access the Unified CM Configuration web page.

Related Topics

- Modify AXL Information, on page 26
- Modify Unified Communications Manager Telephony Information, on page 28
- Modify RmCm Provider Information, on page 29
- Provision Unified CM Telephony Subsystem, on page 68

System Parameters

Use the System Parameters web page to configure system parameters such as port settings, locale settings for Cisco Agent Desktop, and set the default session timeout.

Choose System > System Parameters from the Unified CCX Administration menu bar to access the System Parameters Configuration web page.

Note
You can configure only RMI port in Unified CCX 9.0(1). RmCm TCP and Master Listener TCP ports are display only fields.

Related Topics

- Manage System Parameters, on page 161
Recording Configuration

Use the Recording Configuration web page to configure the host names, user name, and password to connect to the recording server such as Cisco MediaSense.

You must configure recording server details in Unified CCX so that supervisors can search and play recordings based on various filter criteria.

Choose System > Recording Configuration from the Unified CCX Administration menu bar to access the Recording Configuration web page.

This web page displays currently configured recording server details.

Note

User name must be a MediaSense API user. API user name is a Unified CM end user, who is configured in Cisco MediaSense as a MediaSense API user.


Custom File Configuration

Use the Custom Classes Configuration web page to specify the classpath for custom classes.

Choose System > Custom File Configuration from the Unified CCX Administration menu bar to access the Custom Classes Configuration area.

Note

Restart Unified CCX engine and Unified CCX administration services to use the custom files in scripts.

Related Topics

Specify Custom Classpath Entries, on page 147

License Information

Use the License Information web pages to display the cluster licensing information and to upload additional licenses.

Choose System > License Information > Add License(s) or Display License(s) from the Cisco Unified CCX Administration menu bar to access the License Information web pages.

Related Topics

Add Licenses, on page 277
Display Licenses, on page 277
View License Information, on page 10
Add Licenses

From the Unified CCX Administration menu bar:

Procedure

Step 1  Choose System > License Information > Add License(s). The License Information webpage displays.

Step 2  In the License File field, enter the path for the license file or click Browse to locate the license file. Select the required license file and click Open. Use this page to specify a license file and upload it to Unified CCX.

Related Topics

Display Licenses, on page 277
Upload Licenses, on page 11
View License Information, on page 10
Cisco Unified Contact Center Express License Packages, on page 417

Display Licenses

From the Unified CCX Administration menu bar:

Procedure

Choose System > License Information > Display License(s). The License Information webpage opens, displaying the details of the Configured License such as the license type, number of IVR ports, number of seats, maximum number of agents, and so on.

Note  The License Information page displayed on click of Display License(s) menu option will also specify the expiry date in case of time-bound licenses.

For Unified CCX, if you have a premium license with an outbound license, this webpage will display:

• The number of licensed IVR ports and dedicated IVR ports for IVR outbound.

• The number of licensed agent seats and concurrent agent seats for progressive and predictive agent outbound.

Note  The number of In Use IVR ports and In Use agent seats are displayed only for the master node.

Related Topics

Add Licenses, on page 277
Customized Unified CCX languages such as American English, Canadian French, and so on are installed with Unified CCX.

Use the Languages Configuration web page to:

- Enable languages that can be used to play prompts and grammars through Cisco Unified IP IVR.
- Configure the languages that you want to use with Cisco Unified Contact Center Express CAD and CSD.

Choose **System > Language Information** from the Cisco Unified CCX Administration menu bar to access the Languages Configuration web page. The Languages Configuration web page opens to display the following fields and buttons.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IVR Language Configuration</td>
<td></td>
</tr>
<tr>
<td>Language</td>
<td>Language that you wish to use with Unified IP IVR. You can select the language from the drop-down list. You can also specify the group and country-specific information for the language by selecting the desired radio button and check box respectively. Some languages have only one choice. US English (en_US) is the default.</td>
</tr>
<tr>
<td>Default IVR Language Configuration</td>
<td>System default language setting, which could be either one of the selected IVR languages or country-specific or a user-defined language entered using the <strong>Edit</strong> button. This is a mandatory field and you can choose from the drop-down list. Click <strong>Edit</strong> to add a new Language option. Default: English (United States) [en_US]</td>
</tr>
<tr>
<td>CAD/CSD Language Configuration</td>
<td></td>
</tr>
<tr>
<td>CAD/CSD Language</td>
<td>Language that you wish to use with Cisco Agent Desktop (CAD) or Cisco Supervisor Desktop (CSD). You can configure this language by choosing from the drop-down list. <strong>Note</strong> If you are upgrading from CRS 4.5 to Unified CCX 9.0(1) or 9.0(2), ensure that you have the same CAD and CSD Language Selection settings as that of your CRS 4.5 system.</td>
</tr>
<tr>
<td>Update</td>
<td>Click the <strong>Update</strong> icon that displays in the toolbar in the upper left corner of the window or the <strong>Update</strong> button that displays at the bottom of the window to save your changes.</td>
</tr>
<tr>
<td>Clear</td>
<td>Click the <strong>Clear</strong> icon that displays in the toolbar in the upper left corner of the window or the <strong>Clear</strong> button that displays at the bottom of the window to restore the default settings.</td>
</tr>
</tbody>
</table>
Logout Menu

To exit Unified CCX Administration without closing your web browser, you can perform one of the following:

- Choose System > Logout from the Unified CCX Administration menu bar.
- Click the Logout link displayed in the top right corner of any Cisco Unified CCX Administration web page.

The system logs you out of Unified CCX and displays the Unified CCX Authentication web page.

Note
You can also exit Unified CCX Administration by closing your web browser.
Applications Menu

The Applications menu on the top contains the following menu options:

- **Application Management**—to add, configure, copy, delete, or refresh a specific application
- **Script Management**—to add a new script and to view, refresh, upload, or delete an existing script
- **Prompt Management**—to display, modify, or delete existing prompts, and to add new prompts
- **Grammar Management**—to display, modify, or delete existing grammars, and to add new grammars
- **Document Management**—to display, modify, or delete existing documents, and to add new documents
- **AAR Management**—to upload AAR files to Unified CCX

The following sections describe the menu options:

- **Access Application Management Menu,** page 281
- **Manage Scripts,** page 282
- **Prompt Management,** page 283
- **Grammar Management,** page 283
- **Document Management,** page 284
- **AAR Management,** page 284

Access Application Management Menu

The Application Management menu option in the Unified CCX Administration web interface contains options for configuring and managing the applications the Unified CCX system uses to interact with contacts and perform a wide variety of functions.

To access the Application Management web pages, perform the following steps:

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose Applications > Application Management.
The Applications Configuration web page opens, displaying a list of applications that are currently configured on your Unified CCX server.

**Step 2** Click the **Add New** icon that displays in the toolbar in the upper left corner of the window or the **Add New** button that displays at the bottom of the window to add a new application. Add a New Application web page opens.

**Step 3** Select the type of application that you want to create from the Application Type drop-down list.

---

**Related Topics**

- About Unified CCX Applications, on page 41

---

## Manage Scripts

Use the Script Management web page to add a new script and to rename, refresh, or delete an existing script. Unified CCX applications are based on scripts created in the Unified CCX Editor.

To create a new subfolder under the **default** folder, perform the following steps:

### Procedure

**Step 1** To access the Script Management web page, choose **Applications > Script Management** from the Unified CCX Administration menu bar.

The Script Management web page opens, displaying the default directory that contains the scripts uploaded to the repository.

**Step 2** Click the **Create New Folder** icon that displays in the toolbar in the upper left corner of the window or the **Create New Folder** button that displays at the bottom of the window.

The Create New Folder dialog box opens.

**Step 3** Enter a name of the new subfolder in the **Folder Name** field and click **Create**.

Once the folder is successfully created, the dialog box refreshes with the following message:

**Folder successfully created**

**Step 4** Click the **Return to Script Management** button to return to the default folder's updated Script Management page. You can create any number of folders within the **default** folder.

---

**Related Topics**

- Upload New Scripts, on page 59
- About Unified CCX Applications, on page 41
- Download Script File, on page 60
- Refresh Scripts, on page 61
- Sample Scripts, on page 64
Prompt Management

Several system-level prompt files are loaded during Unified CCX installation. However, any file you create must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is done through the Unified CCX cluster's Repository datastore, where the prompt files are created, stored, and updated.

Note

You can use a custom script or the Unified CCX Administration to upload a prompt.

To access the Prompt Management page, choose Applications > Prompt Management from the Unified CCX Administration menu bar.

The Prompt Management web page contains the following icons and buttons:

- **Create Language**—Click the Create Language icon that displays in the toolbar in the upper left corner of the window or the Create Language button that displays at the bottom of the window to create a new language folder.

- **Upload Zip Files**—Click the Upload Zip Files icon that displays in the toolbar in the upper left corner of the window or the Upload Zip Files button that displays at the bottom of the window to upload a new prompt or zip file.

See Manage Prompt Files section to know more about the different fields in this page and how to rename, refresh, or delete existing prompts.

Related Topics

- Create New Language, on page 142
- Upload Zip Files to Language Folder, on page 144
- Manage Prompt Files, on page 137
- Language Management, on page 142
- Upload of Prompt Files, on page 145
- Management of Custom Files, on page 147
- Refresh Scripts, on page 61

Grammar Management

Several system-level grammar files are loaded during Unified CCX installation. However, any file you create must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is done through the Unified CCX cluster's Repository datastore, where the grammar files are created, stored, and updated.

To access the Grammar Management page, choose Applications > Grammar Management from the Unified CCX Administration menu bar.

The Grammar Management web page contains the following icons and buttons:

- **Create Language**—Click the Create Language icon that displays in the toolbar in the upper left corner of the window or the Create Language button that displays at the bottom of the window to create a new language folder.
• **Upload Zip Files**—Click the **Upload Zip Files** icon that displays in the toolbar in the upper left corner of the window or the **Upload Zip Files** button that displays at the bottom of the window to upload a new grammar or zip file.

**Related Topics**
- Manage Grammar Files, on page 139
- Upload Zip Files to Language Folder, on page 144
- Upload of Prompt Files, on page 145
- Create New Language, on page 142
- Management of Custom Files, on page 147
- Refresh Scripts, on page 61

## Document Management

Several system-level document files are loaded during Unified CCX installation. However, any file you create must be made available to the Unified CCX Engine before a Unified CCX application can use them. This is done through the Unified CCX cluster's Repository datastore, where the document files are created, stored, and updated.

To access the Document Management page, choose **Applications > Document Management** from the Unified CCX Administration menu bar.

The Document Management web page contains the following icons and buttons:

• **Create Language**—Click the **Create Language** icon that displays in the toolbar in the upper left corner of the window or the **Create Language** button that displays at the bottom of the window to create a new language folder.

• **Upload Zip Files**—Click the **Upload Zip Files** icon that displays in the toolbar in the upper left corner of the window or the **Upload Zip Files** button that displays at the bottom of the window to upload a new document or zip file.

**Related Topics**
- Upload Zip Files to Language Folder, on page 144
- Manage Document Files, on page 141
- Create New Language, on page 142
- Management of Custom Files, on page 147
- Refresh Scripts, on page 61

## AAR Management

Use the AAR Management web page to upload an AAR file to Unified CCX.

To access the AAR Management web page, choose **Applications > AAR Management** from the Unified CCX Administration menu bar. The AAR Management web page appears.

**Related Topics**
- AAR File Management, on page 148
Upload AAR Files, on page 150
Subsystems Menu

The Subsystems menu of the Unified CCX Administration web interface provides access to the subsystems that are licensed for your Unified CCX system.

The Unified CCX system uses subsystems for communicating with other services. Depending on the Unified CCX package you have installed, the Subsystems menu may contain some or most of the following menu options:

- **Cisco Unified CM Telephony**—to enter Unified CM Telephony provider information, Computer Telephony Interface (CTI) port group information, Unified CM Telephony trigger information, and to resynchronize Unified CM Telephony information.

- **RmCm**—to set up your Unified CCX resources.

- **Chat**—allows Unified CCX to configure and manage chat CSQs, chat widget list, and configure SocialMiner.

- **Outbound**—to configure contact centers for automated outbound activities.

- **ICM**—to configure the Unified Intelligent Contact Management Enterprise (Unified ICME) subsystem to interact with Unified ICME software and to add new Voice Response Units (VRU) scripts.

- **Database**—to configure the Unified CCX system to communicate with database servers.

- **HTTP**—to configure the Unified CCX Engine to respond to requests from a variety of web clients, including computers and IP phones.

- **eMail**—to configure the Unified CCX Engine to communicate with your email server and enable your applications to create and send email.

- **Cisco Media**—to configure Cisco Media Termination (CMT) dialog groups that can be used to handle simple Dual-Tone Multi-Frequency (DTMF) based dialog interactions with customers.

- **MRCP ASR**—to configure the MRCP Automated Speech Recognition (ASR) subsystem, which allows users to navigate through a menu of options using spoken responses to prompts.

- **MRCP TTS**—to configure the MRCP Text-to-Speech (TTS) subsystem, which converts plain text (UNICODE) into spoken words to provide a user with information or to prompt a user to respond to an action.

  - **Unified CM Telephony Menu, page 288**
  - **RmCm Menu, page 291**
Unified CM Telephony Menu

The Unified CCX system uses the Unified CM Telephony subsystem of the Unified CCX Engine to send and receive call-related messages from the Unified CM Computer Telephony Interface (CTI) Manager.

To access the Unified CM Telephony Configuration web pages, choose **Subsystems > Cisco Unified CM Telephony** from the Unified CCX Administration menu bar.

The Unified CM Telephony Configuration menu contains the following submenu options:

- **Unified CM Telephony Provider**—Choose this option to enter Unified CM Telephony provider information.
- **Unified CM Telephony Call Control Group Configuration**—Choose this option to configure CTI port groups for applications.
- **Unified CM Telephony Trigger Configuration**—Choose this option to configure Unified CM Telephony triggers for applications.
- **Data Synchronization**—Choose this option to check and synchronize data components like Unified CM Telephony Users (JTAPI Application Users), Unified CCX Triggers/Route points, and Call Control Groups between Unified CCX and Unified CM.
- **Cisco JTAPI Resync**—Choose this option to resynchronize Cisco JTAPI Client versions.
- **Advanced Settings**—Choose this option to configure advanced settings for the Cisco Unified CM Telephony client.

Unified CM Telephony Provider Configuration

To access this configuration area, choose **Subsystems > Cisco Unified CM Telephony > Provider** from the Unified CCX Administration menu bar. The Cisco Unified CM Telephony Provider web page opens.

Use the Unified CM Telephony Provider Configuration web page to view and modify the primary and secondary location of your Unified CM Telephony provider, and user prefix.

**Related Topics**

- Modify Unified Communications Manager Telephony Information, on page 28
Unified CM Telephony Call Control Group Configuration

Choose **Subsystems** > **Cisco Unified CM Telephony** > **Call Control Group** from the Unified CCX Administration menu bar to access the Unified CM Telephony Call Control Group list web page. Use the Unified CM Telephony Call Control Group Configuration web pages to display, add, modify, and delete information about the call control group.

To add a new Unified CM Telephony Call Control Group, click the **Add New** icon or button on the Unified CM Telephony Call Control Group Configuration web page.

To modify an existing Unified CM Telephony Call Control Group, click any hyperlink within the Ports List table entry; the Cisco Unified CM Telephony Call Control Group Configuration web page opens.

**Related Topics**
- Add New Call Control Group, on page 71
- Additional Unified CM Telephony Information, on page 81

Unified CM Telephony Triggers Configuration

Choose **Subsystems** > **Cisco Unified CM Telephony** > **Unified CM Telephony** > **Triggers** from the Cisco Unified CCX Administration menu bar to configure Unified CM Telephony Triggers.

The Cisco Unified CM Telephony Trigger Configuration web page opens where you can view, add, modify, and delete Unified CM Telephony triggers. To add a Unified CM Telephony trigger, click the **Add New** icon or button. The Cisco Unified CM Telephony Trigger Configuration web page opens.

**Related Topics**
- Add Unified CM Telephony Trigger, on page 77
- Additional Unified CM Telephony Information, on page 81
- Application Triggers, on page 54

Synchronize Unified CM Telephony Data

From Unified CCX Release 9.0(1), you can configure the telephony data synchronization through a new web page called Cisco Unified CM Telephony Data Synchronization.

The data synchronization process ensures that data components like Unified CM Telephony Users (JTAPI Application Users), Unified CCX Triggers/Route points, and Call Control Groups between Unified CCX and Unified CM are in sync, without any inconsistency.

**Data Check** displays whether the selected data components are in synch or not between Unified CCX and Unified CM. If you find any inconsistency, click **Data Resync** to rectify the issue. To check and synchronize the JTAPI data components between Cisco Unified CM and Cisco Unified CCX, perform the following steps:
Caution

It is important that you plan to perform this task during off peak hours to avoid hampering routine contact center operations.

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Subsystems > Cisco Unified CM Telephony > Data Synchronization.
The Cisco Unified CM Telephony Data Synchronization page appears.

Step 2
Select one or more of the following three components by checking the corresponding check boxes:

- Call Control Group(s)
- Trigger(s)
- CM Telephony User(s)

Step 3
Click Data Check or Data Resync. Once you click Data Check or Data Resync, a confirmation message dialog box appears prompting you to either proceed or cancel. Click OK to continue.

Note
Once you click OK in the confirmation message for Data Check or Data Resync, you will not be allowed to cancel the process.

Step 4
The Cisco Unified CM Telephony Data Synchronization web page continues to update until the Data Check or Data Resync process is complete. On completion of the Data Check or Data Resync process, the result is displayed in the same web page in a tree structure. The result for each selected component is displayed in collapsed format with a tick mark if no mismatch is found. Click the arrow adjacent to each selected component to expand and view the detailed results.

If any mismatch is found in the elements of the selected component, the results for those components are displayed automatically in an expanded format.

Note
If you had multiple device pools (for Call Control Groups) in your older versions of Unified CCX setup, performing Data Resync after an upgrade would merge all multiple device pools to a single default device pool. However, you can manually assign a different device pool to the Call Control Group if the default device pool is not the intended one.

Related Topics
Configure Unified CM Telephony Provider, on page 69
Unified CM Telephony Information Resynchronization, on page 82

Unified CM Telephony Cisco JTAPI Resync

Choose Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync from the Cisco Unified CCX Administration menu bar to resynchronize the JTAPI client version on the Unified CCX with the JTAPI version on the Unified CM. You can view the status of Cisco JTAPI client resynchronization in this web page.

If the Unified CCX detects a mismatch, the system downloads and installs the compatible or JTAPI client required installer version. Restart the Unified CCX Engine to view these configuration changes.
The JTAPI client update happens only on the local node and not on the second node in case of High Availability deployment.

Related Topics

Resynchronize Unified CM Telephony Data, on page 69
Configure Unified CM Telephony Provider, on page 69

Unified CM Telephony Advanced Settings

Choose Subsystems > Cisco Unified CM Telephony > Advanced Settings from the Cisco Unified CCX Administration menu bar to configure advanced settings for the Unified CM Telephony Client.

Use the Unified CM Telephony Advanced Settings web page to update the following information:

- Periodic Wakeup Interval (seconds): Select the check box before Enable Periodic Wakeup prior to updating the existing value in this field.
- Queue Size Threshold: Select the check box before Enable Queue Stats prior to updating the existing value in this field.
- CTI Request Timeout (sec)
- Provider Open Request Timeout (sec)
- Provider Retry Interval (sec)
- Server Heartbeat Interval (sec)
- Route Select Timeout (ms)
- Post Condition Timeout
- Use Progress As Disconnect

Click the Update icon that displays in the toolbar in the upper left corner of the window or the Update button that displays at the bottom of the window to save the changes. Restart the Unified CCX Engine to view these configuration changes.

In case of High Availability deployment, the changes are propagated to the second node. If the second node cannot be contacted, an alert message indicating that the update has failed on the remote node is displayed.

Related Topics

Resynchronize Unified CM Telephony Data, on page 69
Configure Unified CM Telephony Provider, on page 69

RmCm Menu

Use the RmCm Configuration web page to configure skills groups, resources, resource groups, Contact Service Queues (CSQs), and RM (Resource Manager) Unified CM Telephony providers. To access the Unified CCX Configuration web page, choose Subsystems > RmCm from the Unified CCX Administration menu bar.

The RmCm menu contains the following submenu options:
Skill Configuration

Use the Skills page to add, modify, or delete skill. Choose **Subsystems > RmCm > Skills** from the Unified CCX Administration menu bar to access the Skills summary web page.

**Related Topics**

Skills Configuration, on page 100

**Add New Skill**

Use the Skill Configuration area to add a new skill name.

**Procedure**

Click the **Add New** icon that displays in the toolbar in the upper left corner of the window or the **Add New** button that displays at the bottom of the window to access the Skill Configuration area.

**Related Topics**

Skills Configuration, on page 100

**Modify Skills**

Click the required skill in the Skill name column on the Skill Configuration web page to access the Skill Configuration area.
Procedure

Click the Open Printable Report of this Skill Configuration icon to view a list of the resources associated with that skill.

Related Topics

- Modify a Skill Name, on page 101
- Delete a Skill, on page 102

Resources Configuration

Use the Resources Configuration area to assign a resource group, to assign skills to a resource, and to assign an alias to the agent. When the agent is on chat, the alias of the agent is displayed to the customer.

To access this configuration area, choose Subsystems > RmCm > Resources from the Unified CCX Administration menu bar. The main area of the Resources area of the Unified CCX Configuration web page contains a list of resources (if configured).

Click the Open Resources Summary Report icon to open the Resources Summary Report in a new window. For each resource, this report lists the resource groups associated with the resource, the Unified CCX extension of the resource, and the number of CSQs and team to which the resource is assigned.

Note

The alias is not available in the Cisco Agent Desktop. It is only available with the Finesse Agent Desktop.

Related Topics

- Agent Configuration
- Contact Service Queue Configuration, on page 107

Modify Resource

Use the Resource Configuration area to modify resource configuration.

To access the Resource Configuration area, click any of the required resource in the Resource area of the Unified CCX Configuration summary web page.

Procedure

Click the Open Printable Report of this Resource Configuration icon to open a Resource Report for the agent. The Resource Report lists each agent resource ID, resource name, Unified CCX extension, resource group, automatic available status, skills, CSQs, and team.

Related Topics

- Assign Resource Groups and Skills to One Agent, on page 104
- Remove Skills from Agents, on page 106
Resource Group Configuration

Use the Resource Group Configuration web page to display and modify the names of existing resource groups and to add new resource groups.

Choose **Subsystems > RmCm > Resource Groups** from the Unified CCX Administration menu bar to access the Resource Groups web page.

**Related Topics**
- Resource Groups, on page 99

Add New Resource Group

Use the Resource Configuration area to enter resource group name in the Resource Group Name field.

**Procedure**

Add a new Resource Groups by clicking **Add New** icon or button in the Resource Group area of the Unified CCX Configuration web page.

**Related Topics**
- Create Resource Group, on page 99

Modify Existing Resource Groups

Use the Resource Modification page to change or update the resource group name into the Resource Group Name field.

Modify an existing Resource Group by clicking the required resource group in the Resource Groups area. In the Resource Group Configuration area, change the Resource Group and update.

**Procedure**

Click the **Open Printable Report of this Resource Group Configuration** icon to view a list of the available resources for this resource group.

**Related Topics**
- Delete Resource Group, on page 100

Contact Service Queues Configuration

Use the Contact Service Queues area of the Unified CCX Configuration web page to display existing CSQs, delete a CSQ, and add a new CSQ.

To access the Contact Service Queues area, choose **Subsystems > RmCm > Contact Service Queues** from the Unified CCX Administration menu bar.
Related Topics

Contact Service Queue Configuration, on page 107

Add a CSQ

Use the Contact Service Queues Configuration area to add a new CSQ.
To access the Contact Service Queues Configuration area, click the Add New icon or button in the Contact Service Queues area of the Unified CCX Configuration web page.
To open the Contact Service Queue Report for the required CSQ, click the Open Printable Report of this CSQ Configuration icon from the Contact Service Queues Configuration area.

Related Topics

Create a Contact Service Queue, on page 107
Modify a Contact Service Queue, on page 112
Delete a Contact Service Queue, on page 112
Resource Pool Selection Criteria: Skills and Groups, on page 113
Resource Skill Selection Criteria within a Contact Service Queue, on page 114

RmCm Provider Configuration

Use the RmCm Provider area of the Unified CCX Configuration web page to identify the Unified CM Telephony user for the Resource Manager.
Choose Subsystems > RmCm > RmCm Provider from the Unified CCX Administration menu bar to access the RmCm Provider web page.

Related Topics

Agent Configuration
Modify RmCm Provider Information, on page 29
Invoke Unified Communications Manager Administration, on page 31

Skills Configuration Assignment

Use the Assign Skills area of the Unified CCX Configuration web page to modify an existing resource group and skill configuration or to assign new resource groups and skills to all or selected agents.
Choose Subsystems > RmCm > Assign Skills from the Unified CCX Administration menu bar to access this configuration area.
This web page also contains the following icons and buttons:

- Add Skill—to add new skills or resource groups to all or selected agents.
- Remove Skill—to remove skills of all or selected agents.

Related Topics

Add Skills, on page 296
Add Skills

When you click the Add Skill button in the Assign Skills area of the Unified CCX Configuration web page, the Add Skill area opens. Use the Add Skill area to add a resource group and skills to the selected agents.

Related Topics
- Assign Resource Groups and Skills to Multiple Agents, on page 105

Remove Skills

When you click the Remove Skill button in the Assign Skills area of the Unified CCX Configuration web page, the Remove Skill area opens. Use the Remove Skill area to remove skills of all or selected agents.

Related Topics
- Remove Skills from Agents, on page 106

Remote Monitor Configuration

Use the Remote Monitor area of the Unified CCX Configuration web page to specify the monitoring method: by agent or by CSQ.

Choose Subsystems > RmCm > Remote Monitor from the Unified CCX Administration menu bar to access this configuration area.

Related Topics
- Remote Monitoring Use and Configuration, on page 116
- Create Remote Monitoring Supervisor, on page 116
- Assign Resources and Contact Service Queues to a Supervisor, on page 117
- Configure Remote Monitoring Application, on page 52
- View CSQ IDs for Remote Monitoring, on page 267

Assign Resources and CSQs to Remote Supervisor

Use the Remote Monitor configuration web page to assign a Supervisor a list of Resources and CSQs they are allowed to monitor.

To access the Remote Monitoring Configuration web page, click a User ID value.

Related Topics
- Remote Monitoring Use and Configuration, on page 116
- Create Remote Monitoring Supervisor, on page 116
- Assign Resources and Contact Service Queues to a Supervisor, on page 117
- Configure Remote Monitoring Application, on page 52
- View CSQ IDs for Remote Monitoring, on page 267
Agent Based Routing Settings Configuration

Use the Agent Based Routing Settings area of the Unified CCX Configuration web page to configure Automatic Work and Wrapup Time.

Choose Subsystems > RmCm > Agent Based Routing Settings from the Unified CCX Administration menu bar to access this configuration area.

Related Topics
- Configure Agent-Based Routing, on page 118

Teams Configuration

Use the Teams area of the Unified CCX Configuration web page to create or associate teams with various agents, CSQs, and supervisors.

Choose Subsystems > RmCm > Teams from the Unified CCX Administration menu bar to access this configuration area.

Related Topics
- Teams Configuration, on page 119
- Create Team Supervisor, on page 120

Add New Team

Click the Add New icon or button on the Teams summary web page. The Team Configuration page appears.

Click the Open Printable Report of this Team Configuration icon in the Teams web page to open the report in a new window and send it to a printer.

Related Topics
- Create Team Supervisor, on page 120
- Create Teams, on page 120
- Modify Agents on Teams, on page 121
- Delete a Team, on page 121

Chat Menu Option

Use the Chat Configuration web page to configure and manage Chat Contact Service Queues (CSQs), Web Forms, and configure SocialMiner. To access the Chat menu option, choose Subsystems > Chat from the Unified CCX Administration menu bar. This option is available only with the Unified CCX Premium license package.

The Chat menu contains the following submenu options:

- Chat Contact Service Queues—Choose this option to configure chat and Email CSQs.
- SocialMiner Configuration—Choose this option to configure and integrate chat CSQs with SocialMiner.
Chat System Parameters—Choose this option to configure chat system parameters.

Chat Web Form List—Choose this option to configure and manage chat web forms.

Teams—Choose this option to configure teams.

Chat Contact Service Queues

Procedure

Step 1
From the Unified CCX Administration menu bar, choose Subsystems > Chat > Chat Contact Service Queues.
The Chat Contact Service Queues (CSQs) web page opens and displays the information for existing chat and Email CSQs if any, or else add new CSQs.

Step 2
To add a new CSQ, click the Add New icon that appears in the toolbar in the upper left corner of the window or the Add New button that appears at the bottom of the window to create a new chat or Email CSQ.

Note: You must create a skill before creating a CSQ. For information, see Skills Configuration, on page 100.
The Chat Contact Service Queues (CSQs) web page opens.

Table 13: CSQ Type—Chat

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSQ Name</td>
<td>Name of the chat CSQ.</td>
</tr>
<tr>
<td>CSQ Type</td>
<td>Type of the chat CSQ.</td>
</tr>
<tr>
<td>Queuing Criteria</td>
<td>Algorithm used to order the queued chat contacts.</td>
</tr>
<tr>
<td>Resource Pool</td>
<td>The resource skills used for the chat CSQ.</td>
</tr>
<tr>
<td>Selection Model</td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Resource Selection Criteria</td>
<td>The resource selection criteria chosen for the chat CSQ.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Longest Available</strong>—Selects the agent who has been in the available state for the longest amount of time.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Most Skilled</strong>—Used for expert agent chat distribution. Selects the agent with the highest total competency level. The total competency</td>
</tr>
<tr>
<td></td>
<td>level is determined by adding the agent's competency levels for each of their assigned skills that are also assigned to the CSQ.</td>
</tr>
<tr>
<td></td>
<td>◦ Example 1: If Agent1 is assigned Skill1(5), Skill2(6), and Skill3(7) and CSQ1 specifies Skill1(min=1) and Skill3(min=1), the total</td>
</tr>
<tr>
<td></td>
<td>competency level for Agent1 for CSQ1 is 12.</td>
</tr>
<tr>
<td></td>
<td>◦ Example 2: If Agent1 is assigned Skill1(5) and Skill2(6) and Skill3(7) and CSQ1 specifies Skill1(min=1), only, the total competency</td>
</tr>
<tr>
<td></td>
<td>level for Agent1 for CSQ1 is 5.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If two agents score equal in the primary selection criteria, the agent who was updated first will be assigned to the incoming chat.</td>
</tr>
</tbody>
</table>

**Step 3**
Click Next.
The Skill Association for CSQ area opens with the newly assigned CSQ Name.

**Step 4**
In the Skills list, view the available skills and highlight the skills you want.
**Note** The Resource Pool Selection Model setting determines the availability of these options.

**Step 5**
Click Add for the skills you selected.
The selected skill and the minimum competence level for that skill are displayed in the right pane below the heading Selected.
**Note** Use the Delete icon next to Minimum Competence to delete that skill from the Skills Required list.

**Step 6**
Specify a minimum competence level for the skill assigned to the chat CSQ.

**Step 7**
Click Save to save the changes for the chat CSQ.

**Step 8**
To view the printable report and associated resources, edit the CSQ and then select **Open Printable Report** or **Show Resources**.
**Note** Click Delete to delete the selected chat CSQ after getting confirmation.

**Warning** When you click Delete for a chat CSQ, an alert message is displayed. Deleting the chat CSQ affects the associated chat web forms. After deleting, modify the corresponding chat web form configurations and generate the HTML code.
Cisco SocialMiner Configuration

Use the SocialMiner Configuration web page in Unified CCX Application Administration to configure and integrate chat CSQs with SocialMiner. This option is available only with the Unified CCX Premium license package. You must configure information on this web page to enable the chat feature to work.

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>From the Unified CCX Administration menu bar, choose <strong>Subsystems &gt; Chat &gt; SocialMiner Configuration</strong>. The SocialMiner Configuration web page opens. <strong>Note</strong> Unified CCX and SocialMiner server should have DNS entries. SocialMiner must be accessible to Unified CCX by hostname.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Use this web page to specify or modify the following fields for SocialMiner Configuration: <strong>Field</strong></td>
</tr>
<tr>
<td>IP Address/Host Name</td>
<td>IP address or fully qualified domain name of the SocialMiner server. For example, 192.168.1.5 or host.example.com.</td>
</tr>
<tr>
<td>User Name</td>
<td>Username of the SocialMiner administrator.</td>
</tr>
<tr>
<td>Password</td>
<td>Password of the SocialMiner administrator.</td>
</tr>
<tr>
<td>Chat Join Timeout (Minutes)</td>
<td>The time after which the customer initiates a chat and, if an agent is not joined, the customer gets a message &quot;No agent could be found&quot;. But an agent can still join the chat after this timeout. The default timeout is one minute and the maximum timeout value allowed is 60 minutes.</td>
</tr>
<tr>
<td>Chat Inactivity Timeout (Minutes)</td>
<td>The system ends the chat if the customer has been inactive for this number of minutes. This timeout is on the customer side only. The agent gets a message &quot;You are alone in the chat room. Click End to close the chat interface.&quot;. The customer gets a message &quot;Warning: the server connection was lost due to an inactivity timeout or connection failure.&quot;.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Click <strong>Save</strong> to save the changes. If you see an error message, click <strong>Save</strong> to re-create the chat feed, campaign, and notifications in SocialMiner. <strong>Note</strong> The following message is displayed for SocialMiner configuration after an add to cluster operation is successful on an HA setup. This creates the notification rule for the second node in SocialMiner.</td>
</tr>
</tbody>
</table>

Note: Cisco Unified CCX Administration Guide, Release 10.5
"In case of HA, configure the SocialMiner on secondary node after adding to cluster in the secondary node."

As part of validation, Unified CCX checks the following:

- Unified CCX sends a request to SocialMiner to check whether the host name and login credentials are valid.
- Unified CCX checks if there is any chat feed session ID stored in the Unified CCX database. If there is an existing chat feed, Unified CCX validates the existence of this feed in SocialMiner, else an error message is displayed in the SocialMiner Configuration web page.
- Unified CCX checks if there is any SocialMiner campaign stored in the Unified CCX database. If there is an existing campaign, Unified CCX validates the existence of this campaign in SocialMiner, or else an error message is displayed in the SocialMiner Configuration web page.
- Unified CCX checks if there is any SocialMiner notification stored in CCX database. If there is an existing notification, Unified CCX validates the existence of this notification in SocialMiner, or else an error message is displayed in the SocialMiner Configuration web page.
- If the validation is successful, the chat feed, campaign, and notification rule status becomes green in color. In case of an issue, the status will be in red in color with an error message.

**Step 4** At anytime if you navigate to this page, the health of chat feed, campaign, and notification rule validates and shows the appropriate status.

---

**Chat Transcripts**

You can search and retrieve stored chat transcripts. You can search by username (chat.agentName) and alias (chat.agentNickname). For more information on how to perform a default search or a field-specific search, see the “Search” section of the *Cisco SocialMiner User Guide* or the SocialMiner interface online help.

For information on how to change chat storages space and calculate the disk space that you need to store data for a specific duration, see the online help that is available for the SocialMiner interface or see the *Cisco SocialMiner User Guide*, located at:

Predefined Responses

You can add a maximum of ten chat predefined responses. These predefined responses are available to all the agents in the Manage Chats Gadget on the Finesse Agent Desktop. Use the Predefined Responses page to configure and manage chat predefined responses. To access the predefined responses, choose Subsystems > Chat > Predefined Responses.

Note
Predefined responses are not available in the Cisco Agent Desktop. They are only available with the Finesse Agent Desktop.

Predefined Response Configuration

Using this web page, you can add, modify, and delete predefined responses.

You can add a maximum of 500 chat and email predefined responses in total.

Note
To modify an existing predefined response, click the Title header for the predefined response that you want to modify. To delete an existing predefined response, click the Delete icon for the predefined response that you want to delete.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Chat > Predefined Responses. The Predefined Responses web page opens, displaying the information for existing responses, if any.

Step 2 Click the Add New icon that is displayed in the toolbar in the upper left corner of the window or the Add New button that is displayed at the bottom of the window to create a new response. The Predefined Response web page opens.

Step 3 Specify the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Unique identifier of the predefined response.</td>
</tr>
<tr>
<td>Note</td>
<td>The special characters angle brackets (&lt; &gt;), parentheses ( () ), double quotation marks (&quot; &quot;), and pipe symbol (</td>
</tr>
<tr>
<td>Type</td>
<td>Types of media.</td>
</tr>
</tbody>
</table>
### Chat System Parameters

Use the Chat System Parameters web page to configure chat parameters.

#### Procedure

**Step 1**

From the Unified CCX Administration menu bar, choose **Subsystems > Chat > Chat System Parameters**. The Chat System Parameters Configuration web page opens.

**Step 2**

Use this web page to specify or modify the following fields for chat system parameters:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chat No Answer Timeout (Seconds)</td>
<td>If an agent does not respond to the chat request within the timeout duration (in seconds) specified in this field, the chat request is routed back to the chat queue. This is a mandatory field.</td>
</tr>
</tbody>
</table>
Click Yes if agents are allowed to handle a chat session during a voice call. This setting takes effect when the agent ends the current voice call.

Click Yes if agents are allowed to handle a voice call during a chat session. This setting takes effect when the agent receives a new incoming chat.

Number of chat sessions (ranging from 1 to 5) that an agent is allowed to handle. This option is available only if Finesse service is activated. For Cisco Agent Desktop, the value is set to 1.

**Step 3**
Click **Save** to save the changes for the chat system parameters.

*Note* If any of the above parameters are changed during the call center operation, the updated values are not applied to the existing contacts in the system. The changed parameters will affect only the new contacts coming into the system.

**List Chat Web Forms**

Use the chat widgets to generate HTML code that can be hosted on the customer website. Use the List Chat Web Forms page to configure and manage chat web forms. To access the chat web forms, choose **Subsystems > Chat > Chat Widget List**.

**Chat Web Form Configuration**

You can add, modify, and delete chat web forms.

*Note* To modify an existing chat web form, click the web form. To delete an existing chat web form, click the delete icon.

**Procedure**

**Step 1**
From the Unified CCX Administration menu bar, choose **Subsystems > Chat > Chat Widget List**. The List Chat Web Forms web page opens, displaying the information for existing Chat Web Forms, if any.

**Step 2**
Click the **Add New** icon that displays in the toolbar in the upper left corner of the window or the **Add New** button that displays at the bottom of the window to create a new chat web form.
The Chat Web Form Configuration web page opens

**Step 3** Specify the following information:

<table>
<thead>
<tr>
<th>Page Area</th>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Widget Details</td>
<td>Name</td>
<td>Unique identifier of the chat widget.</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>Chat widget description.</td>
</tr>
<tr>
<td></td>
<td>Logo URL</td>
<td>Location of the logo file that is displayed in the widget.</td>
</tr>
<tr>
<td></td>
<td>Widget Wait Message</td>
<td>Message that is displayed to the customer when the customer starts a chat session.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Default message: &quot;Welcome. Please wait while we connect you to a customer care representative.&quot;</td>
</tr>
<tr>
<td></td>
<td>Join Time-out Message</td>
<td>Message that is displayed to the customer when a chat request is not handled within the set time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Default message: &quot;All customer care representatives are busy. Please wait or try again later.&quot;</td>
</tr>
<tr>
<td></td>
<td>Error Message</td>
<td>Message that is displayed to the customer when Unified CCX or chat service is not available to handle chat requests.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Default message: &quot;Sorry, the chat service is currently not available. Please try again later.&quot;</td>
</tr>
</tbody>
</table>

**Step 4** Select the desired fields from the *Available Fields* and move it to the *Selected Fields* in the User Form Fields area.

**Step 5** Click the *Add Custom Field* button if you want to create new field(s) in addition to the list of available fields. The Explorer User Prompt dialog box opens.

**Step 6** Enter the name of the new custom field in the text box and click *OK*. The new custom field should appear in the list of Selected Fields.

**Step 7** Click *Next*. The Add problem Statement CSQ mapping area opens.

**Step 8** Add the problem statement for the chat web form and map the same with an existing chat CSQ.

**Step 9** Click any of the following:

- Click the *Add More* button if you want to add more problem statements and associate the same with chat CSQs.
- Click the *Delete* button subsequent to the CSQ List if you want to delete the problem statement.

**Step 10** Click *Next*. 

Cisco Unified CCX Administration Guide, Release 10.5
The Web Form Preview area displays a preview of how the chat web form will look after it is created. It will display all the fields that you had selected for the user form and problem statements along with CSQ mapping.

**Step 11** Click any of the following:
- Click the **Back** button if you want to modify the configuration of the chat web form.
- Click the **Finish** button if you want to generate the web form code.

---

### Teams

Choose **Subsystems > Chat > Teams** from the Unified CCX Administration menu bar to access this configuration area.

**Note**

The team configuration for chat is the same as it is for voice. For information, see **Teams Configuration**, on page 119.

---

### Obtaining CA-Signed Certificate for Web Chat

**CA-Signed Certificate for Unified CCX**

To avoid certification errors on the Cisco Agent Desktop and Cisco Supervisor Desktop, obtain the third-party Certificate Authority (CA) certificates. For more information about how to obtain the third-party CA certificates, follow the upload certification process from step 1 through step 6 from the "Obtain third-party CA certificates" section of the *Cisco Unified Communications Operating System Administration Guide*.

After you upload the certificate, perform the following procedure.

1. Sign out from the Unified CCX.
2. Restart the Unified CCX Notification Service (SSH to Unified CCX and use this CLI: `admin:utils service restart Cisco Unified CCX Notification Service`).
3. Restart Tomcat (SSH to Unified CCX and use this CLI: `admin:utils service restart Cisco Tomcat`).
4. Log in to the Unified CCX.

**CA-Signed Certificate for Cisco SocialMiner**

To avoid certification errors in the SocialMiner, obtain the third-party CA certificates. For more information about how to obtain the third-party CA certificates, see the “Certificates” section of the *SocialMiner User Guide*, located at:

Outbound Menu

Use the Outbound Configuration web page or REST API to provision outbound dialing functionality feature. The Outbound menu option will be displayed when you upload the Cisco Unified Premium license.

Related Topics
Unified CCX Outbound Dialer Configuration, on page 233

General Configuration

Choose Subsystems > Outbound > General from the Cisco Unified CCX Administration menu bar to access the General Configuration web page.

Use this web page to add or modify Outbound dialing preferences.

Related Topics
Unified CCX Outbound Dialer Configuration, on page 233
Configure General Outbound Properties, on page 239
Campaign Configuration, on page 307
Area Code Management, on page 309
Add New Campaigns, on page 308
Delete Contacts, on page 308
Add New Area Code, on page 309

Campaign Configuration

Choose Subsystems > Outbound > Campaigns from the Cisco Unified CCX Administration menu bar to access the Campaigns web page. You can create and schedule a campaign, modify the settings that apply to a campaign, and import a list of contacts (in bulk from a text file) into the Unified CCX database for each campaign using this web page.

You can define any one of the following two types for a campaign:

• Agent-based - If you select this campaign type, all the outbound calls will be handled by the available agents.

• IVR-based - In this campaign type, the outbound calls will be handled by the IVR scripts.

Note
The existing campaigns will be marked as Agent-based after an upgrade from Unified CCX versions prior to 9.0(1).
Add New Campaigns

To configure the properties for direct preview, progressive and predictive agent-based campaigns, for campaign name and description, callback settings, skill group selection, time range, dialing options, retry settings, and the dial settings, click Add New icon or button in the Campaigns web page.

Related Topics

Add New Campaign, on page 246
Import Contacts, on page 308
Delete Contacts, on page 308
Add New Area Code, on page 309

Import Contacts

To import contacts for a selected campaign, click the hyperlink for the required campaign under the Name column and click Import Contacts. This will open the Import Contacts window through which you can import contacts.

The Open Printable Report for this Campaign Configuration icon provides the following information for the selected campaign in addition to call-specific information, which varies depending on the selected dialer type for outbound:

• Campaign Name
• Enabled - Yes or No
• Description
• Start Time of the campaign
• End Time of the campaign
• Contact Records Cache Size
• Remaining Contacts

Related Topics

Import Contacts for Campaign, on page 256
Add New Campaigns, on page 308
Delete Contacts, on page 308
Add New Area Code, on page 309

Delete Contacts

To ensure that a contact does not get called again for subsequent campaigns, you must delete the contact from all campaigns to which it belongs.

Click Delete All Contacts icon or button in the Campaign Configuration web page to delete all contacts of a particular campaign. Once you click Delete All Contacts, you will see a dialog box with the message “This campaign will be disabled and all its contacts will be permanently deleted. Continue?” with OK and Cancel buttons.
If you click OK, the Outbound subsystem checks whether the contacts are used in an active Outbound campaign. If the contacts are used as part of an active Outbound campaign, you will see the following alert message in the status bar at the top of the Campaign Configuration web page: "Campaign is active. Cannot remove contacts from an active campaign. Disable the campaign and try again." In such cases, disable the campaign first and then try deleting all contacts. Click Cancel if you do not want to delete all contacts for the specific campaign.

Related Topics
- Do Not Call Contacts, on page 257
- Add New Campaigns, on page 308
- Import Contacts, on page 308
- Add New Area Code, on page 309

Area Code Management

Use this page to manually add new area codes, update existing area codes, and to add international area codes.

Related Topics
- Add Area Codes, on page 259
- General Configuration, on page 307
- Campaign Configuration, on page 307
- Add New Campaigns, on page 308
- Delete Contacts, on page 308
- Add New Area Code, on page 309

Add New Area Code

The Area Codes Management page allows you to find, add, delete, and modify the mapping of area codes and time zones. The dialer uses the area code of a contact phone number to determine the time zone of the contact calling area.

Related Topics
- Add Area Codes, on page 259
- General Configuration, on page 307
- Area Code Management, on page 309
- Unified CCX Outbound Dialer Configuration, on page 233
- Add New Campaigns, on page 308
- Delete Contacts, on page 308

Configure SIP Gateway

You can use the SIP Gateway Configuration web page to add or modify the parameters that enable the Outbound subsystem of Unified CCX to communicate with the SIP gateway. You can also update the parameters specific to Call Progress Analysis functionality of the gateway using this web page.
Call Progress Analysis is a feature of the SIP gateway by which it determines whether the outcome of a call is an answering machine, live voice, fax, or beep tone and so on. The SIP gateway performs call progressive analysis of the call and informs the outcome of the call to Unified CCX.

**Note**

It is mandatory to configure the SIP Gateway used by the Outbound subsystem to place calls in case of IVR-based and agent-based progressive and predictive Outbound campaigns.

Follow this procedure to configure the SIP gateway parameters through Unified CCX Administration web interface:

**Procedure**

**Step 1** From the Unified CCX Administration menu bar, choose **Subsystems > Outbound > SIP Gateway Configuration**. The SIP Gateway Configuration web page opens.

**Step 2** Click **Update** to save the configuration changes. The new SIP gateway configuration is added to the Unified CCX system.

**Step 3** Click **Cancel** to restore the default settings.

**Related Topics**

- [SIP Gateway Configuration Web Page](#), on page 310
- [Configure General Outbound Properties](#), on page 239
- [Campaign Configuration](#), on page 307
- [Area Code Management](#), on page 309
- [Add New Campaigns](#), on page 308

### SIP Gateway Configuration Web Page

The SIP Gateway Configuration web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Gateway Configuration</strong></td>
<td></td>
</tr>
<tr>
<td>Gateway Hostname/IP Address</td>
<td>The HostName or IP Address of the SIP Gateway in the Unified CCX server, which will be used by the Outbound subsystem to place calls for the predictive or progressive campaigns.</td>
</tr>
<tr>
<td>Gateway Port</td>
<td>The SIP port used by the gateway to communicate with Unified CCX. The default value is 5060.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Local CCX Port</strong></td>
<td>The port number to be used on the Unified CCX server to communicate with the gateway. Default = 5065, Range = 1025-32767 or 61001-65535</td>
</tr>
<tr>
<td><strong>Local User Agent</strong></td>
<td>This read-only field provides a description of the owner for this connection. The default value is Cisco-UCCX/8.5.</td>
</tr>
</tbody>
</table>
| **Transport(TCP/UDP)**                   | The protocol required to send SIP messages. You can select any one of the following protocols:  
• TCP - Transport Control Protocol or  
• UDP - User Datagram Protocol  
The default value is UDP.                                                                  |
| **Call Progress Analysis Configuration** | (displays the parameter name, parameter value, and suggested value for the following fields)                                               |
| **Minimum Silence Period (10-1000)**     | The amount of time that the signal must be silent after speech detection to declare a live voice (in milliseconds).  
Default = 375 milliseconds, Range = 10-1000 milliseconds                                    |
| **Analysis Period (1000 - 10000)**       | Maximum amount of time (from the moment the system first detects the speech) during which analysis will be performed on the input audio.  
Default = 2500 milliseconds, Range = 1000-10000 milliseconds                                  |
| **Maximum Time Analysis (1000-10000)**   | The amount of time to wait when it is difficult for the dialer to determine voice or answering machine.  
Default = 3000 milliseconds, Range = 1000-10000 milliseconds                                  |
| **Minimum Valid Speech Time (50-500)**   | Amount of time that the signal must be active before being declared speech. Anything less is considered as a glitch.  
Default = 112 milliseconds, Range = 50-500 milliseconds                                         |
| **Maximum Term Tone Analysis (1000-60000)** | This is the amount of time the gateway will look for a terminating beep once an answering machine has been detected.  
Default = 15000 milliseconds, Range = 1000-60000 milliseconds                               |
Dial Peer Configuration for Outbound

Dial peer configuration is required to transfer the outbound calls to the IVR ports and agents in case of progressive and predictive outbound campaigns. The dial peer maps to the CUCM trigger for IVR-based campaigns and to the agent extension for agent-based campaigns.

When you configure voice-network dial peers, the key commands that you must configure are the destination-pattern and session-target commands.

IVR

For IVR-based progressive and predictive campaigns, the destination-pattern command specifies the Unified CM Telephony Trigger associated with the IVR campaign. The session-target command specifies a destination address for the voice-network peer.

Agent

For agent-based progressive and predictive campaigns, the destination-pattern command specifies the agent extension. The session-target command specifies a destination address for the voice-network peer.

For Extend and Connect, the destination-pattern should specify the destination address of the CTI Remote Device (CTIRD). See the Cisco Unified TAPI Developers Guide for Cisco Unified Communications Manager at http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html for more information on CTIRD.

Disable Hunting for Agent-Based Outbound Calls

When the agent does not answer a live voice call within the time limit configured for Outbound Call Timeout in General Configuration web page then the call has to be dropped. If hunting is not disabled on the gateway, the call is not dropped and is forwarded to the agent extension.

The gateway receives a 403 forbidden error message and hunts for the “preference 2 dial peer.” The gateway forwards the call to the agent extension using the “preference 2 dial peer.” Hence, the call is seen on the agent desktop and the state of the agent is changed to Ready or Not Ready depending on the option selected for the Agent State after Ring No Answer field in System Parameters Configuration web page.

To disable hunting for the gateway, use no voice hunt 57 command (57 maps to 403 forbidden in SIP).

Note

This is a global configuration to restrict the gateway from hunting for all 403 forbidden error messages.

Translation of Phone Numbers

Unified CCX does not support the translation or modification of the phone number that it uses to dial out outbound calls. Any “voice translation rules” configured in the gateway that modifies the phone number are not supported. If the phone number is translated, then those calls are not treated as agent-based outbound calls.
You can use either of the below two supported methods to modify a dialed number in the gateway:

- To remove the initial digits of the phone number use **forward-digits** or **digit-strip** in the dial peer configuration.
- To add a prefix to the phone number use **prefix** in the dial peer configuration.


### Unified ICM Menu

Use the Intelligent Contact Manager (ICM) Configuration web pages to add or modify Unified ICME configuration parameters and to modify VRU script information.

**Related Topics**
- Provision of Unified ICME Subsystem, on page 124
- Configure General Unified ICME Information, on page 125
- Configure Unified ICME VRU Scripts, on page 127
- Unified Gateway Auto-configuration Details, on page 122
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50

### Unified ICME Configuration

If you are using Unified CCX with Cisco Contact Center Gateway solution, see *Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX*. The instructions for configuring Unified CCX with that solution differs from what is described in this guide. The Unified Gateway provides for the integration of the Unified ICME system with Unified CCX by way of the Unified Gateway. The Unified Gateway is a Peripheral Gateway (PG) which you configure on the Unified ICME software.

Use the General area of the Unified ICME Configuration page to add or modify Unified ICME configuration parameters.

To configure the Unified ICME subsystem, choose **Subsystems > ICME > General** from the Unified CCX Administration menu bar to access the Unified ICME Configuration web page.

**Related Topics**
- Provision of Unified ICME Subsystem, on page 124
- Configure General Unified ICME Information, on page 125
- Configure Unified ICME VRU Scripts, on page 127
- Unified Gateway Auto-configuration Details, on page 122
- Configure Unified ICME Post-Routing Application, on page 48
Unified ICME VRU Scripts

Unified ICME uses Unified ICME Voice Response Unit (VRU) scripts to handle interaction with contacts. These scripts are loaded as applications on the Unified CCX Engine.

Choose Subsystems > ICME > ICME VRU Scripts from the Unified CCX Administration menu bar to access the ICME VRU Scripts web page.

Related Topics
- Provision of Unified ICME Subsystem, on page 124
- Configure General Unified ICME Information, on page 125
- Configure Unified ICME VRU Scripts, on page 127
- Unified Gateway Auto-configuration Details, on page 122
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50

Add New VRU Script

Use the ICME VRU Scripts web page to add a new VRU script.

Procedure

Step 1 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New button that displays at the bottom of the window on the ICME VRU Scripts web page.

Step 2 To modify a VRU script, click any hyperlink within the VRU Script list table entry; the ICME VRU Scripts web page opens, displaying the list of VRU Scripts in the Scripts drop-down box. Click Update to save the changes.

Related Topics
- Provision of Unified ICME Subsystem, on page 124
- Configure General Unified ICME Information, on page 125
- Configure Unified ICME VRU Scripts, on page 127
- Unified Gateway Auto-configuration Details, on page 122
- Configure Unified ICME Post-Routing Application, on page 48
- Configure Unified ICME Translation-Routing Application, on page 50

Database Menu

The Unified CCX system uses the Database subsystem of the Unified CCX Engine to communicate with database servers, to obtain information that can be relayed to callers or to make application decisions. The
Database subsystem enables the Unified CCX applications to obtain information from data sources, which are databases configured to communicate with the Unified CCX system.

The Database menu contains the following options, which are explained below:

- **Datasource**
- **Parameters**
- **Drivers**

**Related Topics**

- **DataSource, on page 315**
- **Add New Database Parameter, on page 316**
- **Database Subsystem Configuration, on page 131**
- **About Additional Subsystems, on page 123**
- **Provision of Unified ICME Subsystem, on page 124**
- **Provision of HTTP Subsystem, on page 129**
- **Provision of Database Subsystem, on page 131**
- **Provision eMail Subsystem, on page 134**

**DataSource**

Use the DataSources web page to add a new data source, display, modify, or delete existing datasources.

Choose **Subsystems > Database > DataSource** from the Cisco Unified CCX Administration menu bar to access the DataSources web page.

**Related Topics**

- **Add New Database Parameter, on page 316**
- **About Additional Subsystems, on page 123**

**New DataSource**

Follow this procedure from the DataSources web page to add a new DataSource:

**Procedure**

Click the **Add New** icon that displays in the toolbar in the upper left corner of the window or the button that displays at the bottom of the window to add a new data source. The DataSource Configuration web page opens.

**Related Topics**

- **Add New Datasource, on page 131**
- **Add New Database Parameter, on page 316**
- **Database Subsystem Configuration, on page 131**
- **About Additional Subsystems, on page 123**
Add New Database Parameter

To add a new database parameter:

Procedure

Choose Subsystems > Database > Parameter from the Unified CCX Administration menu bar. The Parameters web page displays. See Poll Database Connectivity, on page 133 to know more about how to update parameter-related fields.

Related Topics

- Database Subsystem Configuration, on page 131
- About Additional Subsystems, on page 123
- Add New Datasource, on page 131

Driver

Use the Driver List web page to upload new drivers, or to view and delete existing drivers.

Add New Database Driver

Follow this procedure to add a new jdbc driver:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Database > Drivers. The Driver List web page opens up displaying a list of uploaded driver class file names along with a Delete icon.

Step 2 Click the Add New icon that displays in the toolbar in the upper left corner of the window or the Add New button that displays at the bottom of the window to add a new driver class name. The Driver Management web page opens.

Step 3 Specify a valid JDBC driver jar file in the Driver File field or click Browse to locate the driver file. The driver file is validated before uploading.

Step 4 Choose the supported class name for the new driver from the Driver Class Name drop-down list box.

Step 5 Click Upload to save the new driver to the database.

Tip

- Contact your database vendor to know the appropriate JDBC driver versions that is compatible with your Enterprise database server. Though multiple jdbc driver versions are supported, the following table lists the JDBC drivers that have been tested with different databases.

- While uploading com.ibm.db2.jcc.DB2Driver, if your IBM DB2 deployment also requires a license Jar to be in the application's classpath, upload the license Jar as a Custom Jar File using the procedure detailed in Specify Custom Classpath Entries. Then, restart the Unified CCX Engine on all nodes through Unified CCX Serviceability.
Table 14: JDBC Driver Versions Tested with Enterprise Database

<table>
<thead>
<tr>
<th>Databases</th>
<th>Tested JDBC Drivers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle 11g R2</td>
<td>ojdbc6.jar</td>
</tr>
<tr>
<td>Oracle 10g R2</td>
<td>ojdbc14.jar</td>
</tr>
<tr>
<td>Oracle 10g XE</td>
<td>ojdbc14.jar</td>
</tr>
<tr>
<td>Sybase Adaptive Server 12</td>
<td>jTDS 1.2.2, jconn2.jar</td>
</tr>
<tr>
<td>IBM DB2 8.2</td>
<td>db2jcc4.jar</td>
</tr>
<tr>
<td>MS SQL Server 2000</td>
<td>jTDS 1.2.2</td>
</tr>
<tr>
<td>MS SQL Server 2005</td>
<td>jTDS 1.2.2</td>
</tr>
<tr>
<td>MS SQL Server 2008</td>
<td>jTDS 1.2.5</td>
</tr>
</tbody>
</table>

Related Topics

- Add New Datasource, on page 131
- About Additional Subsystems, on page 123

HTTP Menu

The Unified CCX system uses the HTTP subsystem of the Unified CCX Engine to add components to the Unified CCX Engine that allow applications to be triggered in response to requests from a variety of web clients, including computers and IP phones.

Related Topics

- Provision of HTTP Subsystem, on page 129
- Application Triggers, on page 54

HTTP Configuration

Use the HTTP Trigger Configuration web pages to display, add, modify, and delete existing HTTP triggers. Choose Subsystems > HTTP from the Cisco Unified CCX Administration menu bar to access the HTTP Trigger Configuration web page.

Related Topics

- Provision of HTTP Subsystem, on page 129
Add New HTTP Trigger

To add a new HTTP trigger:

Procedure

Click the Add New icon or button on the HTTP Trigger Configuration web page to access the HTTP Trigger Configuration web page.
To modify an existing trigger, click any hyperlink within the HTTP Trigger List table; the HTTP Trigger Configuration web page opens.

Related Topics

Provision of HTTP Subsystem, on page 129
Application Triggers, on page 54

eMail Menu

The Unified CCX system uses the eMail subsystem of the Unified CCX Engine to communicate with your email server and enable your applications to create and send email. The email configuration identifies the default email address and server to be used for sending email (including e-pages and faxes) and for receiving acknowledgments.

Choose Subsystems > eMail from the Cisco Unified CCX Administration menu bar to access the eMail Configuration web page. You must configure email functionality so that Unified CCX scripts created with the email steps will function correctly.

Related Topics

About Additional Subsystems, on page 123
Provision of Unified ICME Subsystem, on page 124
Provision of HTTP Subsystem, on page 129
Provision of Database Subsystem, on page 131
Provision eMail Subsystem, on page 134

Cisco Media Menu

Choose Subsystems > Cisco Media from the Unified CCX Administration menu bar to access the Cisco Media Termination Dialog Group Configuration web page.

The Unified CCX system uses the Media subsystem of the Unified CCX Engine to configure Cisco Media Termination (CMT) dialog groups that can be used to handle simple Dual-Tone Multi-Frequency (DTMF) based dialog interactions with customers. A dialog group is a pool of dialog channels in which each channel is used to perform dialog interactions with a caller.

To modify an existing CMT dialog group, click any hyperlink within the trigger's summary table entry; the Cisco Media Termination Dialog Group Configuration web page opens.
To add a new CMT dialog group, click the Add New icon or button in the Cisco Media Termination Dialog Group Configuration web page. The Cisco Media Termination Dialog Group Configuration web page opens.

Related Topics

Cisco Media Subsystem, on page 83
Add CMT Dialog Control Group, on page 83

MRCP ASR Menu

The Unified CCX system uses the MRCP ASR (Automatic Speech Recognition) subsystem to allow navigation through a menu of options by speaking instead of pressing keys on a touch-tone telephone.

Related Topics

Prepare to Provision ASR/TTS, on page 85
Provision of MRCP ASR Subsystem, on page 85

MRCP ASR Provider

Choose Subsystems > MRCP ASR > MRCP ASR Provider from the Cisco Unified CCX Administration menu bar to configure information about the vendor of your speech server, including the number of licenses, and the grammar type.

To modify an existing ASR Provider information, click any hyperlink within the provider's summary table entry; the ASR Provider Configuration web page opens.

To add a new ASR Provider information, click the Add New icon or button.

Related Topics

Provision MRCP ASR Providers, on page 86

MRCP ASR Servers

Choose Subsystems > MRCP ASR > MRCP ASR Servers from the Cisco Unified CCX Administration menu bar to configure your speech server name, port location, and available languages.

Note

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Server.

To modify an existing ASR Server, click any hyperlink within the server summary table entry; the ASR Server Configuration web page opens.

To add a new ASR Server, click the Add New icon or button.

Related Topics

Provision MRCP ASR Servers, on page 87
MRCP ASR Dialog Groups

Use the MRCP ASR Dialog Group Configuration web page to display, add, modify, and delete information about MRCP ASR dialog control groups, which enable Unified CCX applications to use speech recognition.

Choose Subsystems > MRCP ASR > MRCP ASR Dialog Groups from the Cisco Unified CCX Administration menu bar to configure the MRCP ASR dialog control groups.

Note

You must have a MRCP ASR Provider defined before you can provision a MRCP ASR Group.

To modify an existing MRCP ASR Dialog Group, click any hyperlink within the group summary table entry; the MRCP ASR Dialog Control Group Configuration web page opens.

To add a new MRCP ASR Group, click the Add New icon or button.

Related Topics

Provision MRCP ASR Dialog Groups, on page 89

MRCP TTS Menu

The Unified CCX system uses the MRCP (Text-to-Speech) subsystem to convert plain text (UNICODE) into spoken words to provide a user with information or to prompt a user to respond to an action.

Related Topics

Prepare to Provision ASR/TTS, on page 85
MRCP TTS Subsystem, on page 91

MRCP TTS Providers

Use the MRCP TTS Provider Configuration web pages to display, add, modify, and delete information about your TTS Provider.

Choose Subsystems > MRCP TTS > MRCP TTS Provider from the Cisco Unified CCX Administration menu bar to configure information about the vendor of your TTS system.

To modify an existing MRCP TTS Provider, click any hyperlink within the provider summary table entry; the MRCP TTS Provider Configuration web page opens.

Related Topics

Provision MRCP TTS Providers, on page 92
Configure Default TTS Provider for Unified CCX System, on page 93

MRCP TTS Servers

Use the MRCP TTS Server Configuration web page to display, add, modify, and delete the text-to-speech server name, port location, and available language.
To modify an existing MRCP TTS Server, click any hyperlink within the server summary table entry; the MRCP TTS Server Configuration web page opens.

To add a new MRCP TTS Server, click **Add New** icon or button in the MRCP TTS Server Configuration web page.

**Related Topic**

*Provision MRCP TTS Servers, on page 93*

**MRCP TTS Default Genders**

Use the MRCP TTS Default Genders Configuration web page to display or modify the gender setting for each Locale. You can modify the default gender setting for the Locales specified during TTS Server provisioning using this page. Click the **Update** icon or button to save the changes.

**Related Topic**

*Provision MRCP TTS Default Genders, on page 95*
Wizards Menu

The Wizards menu of the Unified CCX Administration web interface provides access to the wizards available for your Unified CCX system.

In each Wizard web page, you are provided with a list of procedures and a description for each procedure in the main pane.

Click the Exit icon in the toolbar in the upper left corner of the window or the Exit button that displays at the bottom of the window to exit the wizard at any time and to go to the main Unified CCX Administration menu bar. Click Next to go to the next wizard menu option.

The Unified CCX system contains the following options in the Wizards menu:

- Application Wizard, page 323
- RmCm Wizard, page 324

Application Wizard

Application Configuration is one of the very basic requirements in Unified CCX Administration. You must complete several steps in the suggested order to successfully complete Application Configuration.

To access the Application Wizard, select Wizards > Application Wizard > Description of Steps from the Unified CCX Administration menu bar. The Application Configuration Wizard: Description of Steps web page opens up, displaying the different steps to perform the configuration, along with a brief description of each step as shown in the following bulleted list.

Click Next to proceed to the subsequent steps from the main Application Configuration Wizard web page or jump directly to any step using Wizards > Application Wizard and clicking the desired submenu (see Configure Unified CCX Applications, on page 12).

- **Scripts**—In this step, you can view a list of existing custom scripts. When you click the Next button from the main Application Configuration Wizard web page, you are transferred to Script Management web page, which lists the available scripts, provides links to create a folder, and uploads custom scripts. Scripts can be uploaded as either a single script file or a zip file of scripts. You can upload multiple scripts in this step (see Script Management, on page 58).

- **Prompts**—In this step, you can view a list of existing custom prompts. The Prompt Management web page lists the available prompts, provides links to create new folders, and uploads custom prompts.
Prompts can be uploaded as either a single prompt file or a zip file of prompts. You can upload multiple prompts in this step (see Manage Prompt Files, on page 137).

- **Grammars**—In this step, you can view a list of existing custom grammar files that are used to recognize and respond to caller prompts. The Grammar Management web page lists the available grammars, provides the links to create new folders, and uploads custom grammars. Grammars can be uploaded as either a single grammar file or a zip file of grammars. You can upload multiple grammars in this step (see Manage Grammar Files, on page 139).

- **Documents**—In this step, you can view a list of existing custom documents such as .txt, .doc, .jsp, or .html, custom classes, and Java Archive (JAR) files that allow you to customize the performance of your Unified CCX system. The Document Management web page lists the available documents, provides the links to create new folders, and uploads custom documents. Documents can be uploaded as either a single document file or a zip file of documents. You can upload multiple documents in this step (see Manage Document Files, on page 141).

- **Application Configuration**—In this step, you can select the type of application to be configured using Add a New Application page. Click Next to provide configuration details for the selected application type. Each application can be any combination of the scripts, prompts, grammars, and documents on file. By default, the uploaded script, prompt, document and grammar are selected, if applicable. You can create multiple applications in this step (see About Unified CCX Applications, on page 41).

- **Triggers**—In this step, you can create different types of triggers for the applications that were created in the previous step using the Trigger Configuration page. More than one trigger can be created for one application. By default, the application configured in the previous step is automatically selected. On providing the Directory Number, device name and language, the trigger configuration is complete. You can create multiple triggers in this step (see Application Triggers, on page 54).

Selecting the type of the trigger concludes the Application Configuration wizard process.

**Related Topics**

RmCm Wizard, on page 324

---

**RmCm Wizard**

RmCm Configuration is a commonly performed procedure in the contact center environment. You must complete several steps in the suggested order to successfully complete RmCm Configuration. The RmCm Configuration wizard leads you through the suggested steps.

---

**Note**

The RmCm Wizard option is available with all Unified CCX license packages.

To access the Application Wizard, select Wizards > RmCm Wizard > Description of Steps from the Unified CCX Administration menu bar. The Application Configuration Wizard: Description of Steps web page opens up displaying the different steps in which you can perform the configuration along with a brief description of each step as shown in the bulleted list below.

Click Next to proceed to the subsequent steps from the main RmCm Wizard web page or jump directly to any step using Wizards > RmCm Wizard and clicking the desired submenu.

- **Add a Skill**—Choose this submenu to configure the skills to be associated with the user. In this step, you are transferred to the RmCm > Skills web page. Repeat this step to create multiple skills.
• **Add a Resource Group**—Choose this submenu to upload multiple custom scripts. In this step, you are transferred to the Resource Group Configuration web page, where you can enter the Resource Group Name.

• **Add Resources**—Choose this submenu to create resource groups that will later be assigned to resources. In this step, you are transferred to RmCm Wizard - User Configuration web page, which has a hyperlink to **Add resources in Unified CM**. This link invokes **Unified CM** automatically (see the following related topics):
  - RmCm Provider Configuration, on page 295
  - Unified Communications Manager for Unified CCX Configuration, on page 31

• **Add Supervisors**—Choose this submenu to assign supervisor privileges to a user. In this step, you are transferred to the User Management web page, which allows you to search for a specific user.

• **Configure Resources**—Choose this submenu to add or remove skills that are associated with resources. In this step, you are transferred to the RmCm Configuration Resources web page, which lists the configured resources. Resources can be modified together to obtain the same skills, or they can be modified separately to be assigned different skills.

• **Modify Existing Contact Service Queues**—Choose this submenu to modify skills that are associated with a contact service queue. In this step, you are transferred to the RmCm Configuration Contact Service Queue web page, which lists the configured CSQs.

• **Add a Contact Service Queue**—Choose this submenu to add contact service queues. Skills or resource groups are associated to these contact service queues to filter out the resources. In this step, you are transferred to the RmCm Configuration Contact Service Queue Configuration web page, which allows you to add CSQs.

• **Modify Existing Teams**—Choose this submenu to modify agents in existing teams. In this step, you are transferred to the RmCm Configuration Contact Teams page, which lists the configured teams.

• **Add a Team**—Choose this submenu to create new teams and associate those teams with new agents. In this step, you are transferred to the RmCm Configuration Team Configuration web page, which allows you to create new teams.

• **Create an Application**—On completing the RmCm configuration, you can optionally proceed to the Application Wizard configuration.

**Related Topics**

- Configure Unified CCX Subsystems, on page 9
- Create a Skill, on page 101
- Resource Groups, on page 99
- Create Remote Monitoring Supervisor, on page 116
- Agent Configuration
- Contact Service Queue Configuration, on page 107
- Teams Configuration, on page 119
- Application Wizard, on page 323
Tools Menu

The Tools menu of the Unified CCX Administration web interface provides access to system tools you can use to perform a variety of administrative tasks and contains the following menu options:

- **Plug-ins**—to download plug-ins that you can use to enhance the Unified CCX Engine.
- **Real-Time Reporting**—to generate reports that provide detailed information about the status of your Unified CCX system.
- **Real-Time Snapshot Config**—to configure the Unified CCX database connection to a wallboard display.
- **Historical Reporting**—to perform Historical Reporting tasks, including configuring the database server, synchronizing data, configuring users, installing client software, and purging your database.
- **User Management**—to assign access levels to administrators and supervisors.
- **Password Management**—to reset passwords for external database access users like workforce management, historical reporting user and so on.
- **W1 Upgrade**—to show if you have selected "Upgrade from a previous Unified CCX release" option during initial Appadmin setup in a single-node or high availability deployment.

The following sections describe the various menu options.

- Plug-Ins Menu, page 327
- Real-Time Reporting Menu, page 328
- Real-Time Snapshot Config Menu, page 329
- Historical Reporting Menu, page 333
- User Management Menu, page 336
- Password Management, page 341

Plug-Ins Menu

The Unified CCX system includes software components called plug-ins that you can use to enhance the Unified CCX Engine. You can download these plug-ins from the Plug-ins web page.
To access the Plug-ins web page, choose **Tools > Plug-ins** from the Unified CCX Administration menu bar. The Plug-ins web page contains one or more of the following hyperlinks (depending on the Unified CCX package you have purchased):

- **Cisco Unified CCX Editor**—Click this hyperlink to install the client-side Unified CCX Editor. For more information, see the *Cisco Unified Contact Center Express Scripting and Development Series: Volume 1, Getting Started with Scripts 9.0(1) and Volume 2, Editor Step Reference 9.0(1) Guide.*

  ![Caution]
  Do not install the Unified CCX editor on the same machine as the Cisco Unity Editor. Both editors cannot coexist on the same machine.

- **Cisco Unified CCX Desktop Suites**—Click this hyperlink to install Cisco Desktop Administrator, Supervisor Desktop, Agent Desktop, and Client Configuration tool. For more information, see *Cisco Unified CCX Supervisor Desktop Plug-in Tasks* and the *Cisco Unified CCX Agent Desktop Plug-in Tasks*.

  ![Note]
  You must download Cisco Unified CCX Desktop Client Configuration tool prior to installing any applications from the Cisco Unified CCX Desktop Product Suite.

- **Cisco Unified CCX Real-Time Monitoring Tool for Windows**—Click this hyperlink to install client-side Unified CCX Serviceability Real-Time Monitoring Tool (RTMT) for Windows. This tool monitors real-time behavior of the components in a Unified CCX cluster. RTMT uses HTTP/HTTPS and TCP to monitor device status, system performance, device discovery, and CTI applications. It also connects directly to devices by using HTTP/HTTPS for troubleshooting system problems. This plug in is available only for users with administrator capability.

  ![Note]
  To download on Windows, right-click **Download** hyperlink and select **Save Target As** option.

- **Cisco Unified CCX Real-Time Monitoring Tool for Linux**—Click this hyperlink to install client-side Unified CCX Serviceability Real-Time Monitoring Tool (RTMT) for Linux. RTMT uses HTTP/HTTPS and TCP to monitor device status, system performance, device discovery, and CTI applications. It also connects directly to devices by using HTTP/HTTPS for troubleshooting system problems. This plug in is available only for users with administrator capability.

**Real-Time Reporting Menu**

![Caution]
While Unified CM supports Unicode characters in first and last names, those characters become corrupted in Unified CCX Administration web pages for RmCm configuration, Real Time Reporting, Cisco Agent/Supervisor Desktop.
The Real-Time Reporting tool is a Java applet that you can use to generate a variety of reports that provide detailed information about the status of your Unified CCX system. You use the Application Reporting web page to access the Real-Time Reporting tool.

To access the Application Reporting web page, choose **Tools > Real Time Reporting** from the Unified CCX Administration menu bar.

**Related Topics**
- Unified CCX Real-Time Reports, on page 186

## Real-Time Snapshot Config Menu

Many call centers use wallboards to display their real-time reporting status. Wallboards can display data such as available agents in CSQs, call volumes, talk times, wait times, and number of handled calls. You can enable the Unified CCX system to write Unified CCX real-time information to a database that can then be displayed on a wallboard.

---

**Note**

You must purchase the wallboard separately, and configure and control it with its own wallboard software. Wallboard software and hardware are supported by the third-party wallboard vendors, not by Cisco.

You must install the wallboard software on a separate machine or desktop, not on the Unified CCX server. During installation of your wallboard software, you must configure your wallboard software to access the Unified CCX database. To do this, you must assign a DSN, User ID, and password.

Use the Real-Time Snapshot Writing Configuration for Wallboard web page to enable the system to write data to the wallboard system.

To access the Real-Time Snapshot Writing Configuration for Wallboard web page, choose **Tools > Real Time Snapshot Config** from the Unified CCX Administration menu bar.

The following fields are displayed on the Real-Time Snapshot Writing Configuration for Wallboard web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Writing Enable</td>
<td>If checked, the system writes the data to the database. If not checked, the system does not write the data to the database. The default is disabled.</td>
</tr>
<tr>
<td>Data Writing Interval</td>
<td>Sets the refresh interval for the wallboard data. Valid options: 5, 10, 15, 20, and 25.</td>
</tr>
<tr>
<td>Cisco Unified CCX CSQs Summary</td>
<td>If checked, writes information about each CSQ to the RtCSQsSummary table in the Unified CCX database.</td>
</tr>
<tr>
<td>Cisco Unified CCX System Summary</td>
<td>If checked, writes overall Unified CCX system summary to the RtICDStatistics table in the Unified CCX database.</td>
</tr>
</tbody>
</table>

---

Cisco Unified CCX Administration Guide, Release 10.5
Create System DSN for Wallboard

You can create a system Data Source Name (DSN) on your Windows server by performing the following procedure.

Procedure

**Step 1** Install the wallboard software and IBM Informix ODBC Driver (IDS Version 3.0.0.13219 and above) on the wallboard client desktop.

**Note** You can download the Informix ODBC driver from the following URL: [http://www14.software.ibm.com/webapp/download/search.jsp?rs=ifxdl](http://www14.software.ibm.com/webapp/download/search.jsp?rs=ifxdl). Download the IBM Informix Client Software Development Kit (CSDK) Version 3.00 or higher for the operating system you are installing with the wallboard client. More information about the CSDK can be found at the following URL: [http://www.ibm.com/software/data/informix/tools/csdk/](http://www.ibm.com/software/data/informix/tools/csdk/).

**Step 2** Select **Start > Settings > Control Panel**.

**Step 3** From the Control Panel menu, select **Administrative Tools > Data Sources ODBC** to launch the ODBC Data Source Administrator.

**Step 4** Click the **System DSN** tab. Then click **Add** to open the Create New Data Source dialog box.

**Step 5** Scroll down to locate and select the IBM INFORMIX ODBC DRIVER.

**Step 6** Click **Finish** to open the IBM Informix Setup dialog box.

**Step 7** On the **General** tab, enter and apply a Data Source Name and Description.

**Step 8** On the **Connection** tab, enter the values for the fields as shown in the table below:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name</td>
<td>IP addresses of the servers running the Wallboard software pointing to the HDS Database Server, which contains the Wallboard Real-Time Snapshot data. If you have multiple Wallboard servers, you can list their IP addresses in this field separated by commas.</td>
</tr>
</tbody>
</table>
This is the instance name of the Informix database. Informix database instance name can be formed using Host Name of the Unified CCX server by following these conventions:

- Convert all uppercase letters to lower case.
- Replace hyphens with underscore.
- Add the letter “i” as a prefix to the instance name, if the hostname starts with a number.
- Append the letters “_uccx” to the instance name.

For example, if the hostname is “802UCCX-Ha-Node1”, enter “i802uccx_ha_node1_uccx” in the Server Name field.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name</td>
<td>This is the instance name of the Informix database.</td>
</tr>
<tr>
<td>Host Name</td>
<td>Enter the hostname of the primary Unified CCX server.</td>
</tr>
<tr>
<td>Service</td>
<td>Enter 1504.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Enter onsoectcp.</td>
</tr>
<tr>
<td>Options</td>
<td>Leave blank.</td>
</tr>
<tr>
<td>Database Name</td>
<td>Enter db_cra.</td>
</tr>
<tr>
<td>User ID</td>
<td>Enter uccxwallboard. This is the user id of the Unified CCX database created for wallboard.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the wallboard user that has been configured. You can change the password by going to Tools &gt; Password Management submenu option from the Unified CCX Administration menu bar.</td>
</tr>
</tbody>
</table>

**Step 9**  
Click Apply.

**Step 10**  
Click the Environment tab and enter the values for the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Locale</td>
<td>Enter en_US.UTF8.</td>
</tr>
<tr>
<td>Database Locale</td>
<td>Enter en_US.UTF8.</td>
</tr>
</tbody>
</table>

**Step 11**  
Click OK.

**Step 12**  
Return to the Connection tab and click Apply and Test Connection.
If the phrase “Test completed successfully” is returned, click OK.

If the test is unsuccessful, return to the configuration sequence and fix any errors.
Related Topics

Password Management, on page 341

Wallboard Software in High Availability (HA) Deployment

If you use wallboard software in an High Availability (HA) deployment of Unified CCX and do not want any manual intervention in case of failover, you must upgrade your wallboard software.

Upgraded wallboard software should have a new service which periodically requests Unified CCX server for database mastership information using REST API (URL - http://<Unified CCX server IP Address>/uccx/isDBMaster). During failover, this new service in wallboard will update DSN registry to use new database master server.

REST API can be requested only from wallboard servers configured through Tools > Real Time Snapshot Config web page from the Unified CCX Administration menu bar.

Use Upgraded Wallboard Software with New Service in HA Deployment

If you use wallboard software in a High Availability (HA) deployment of Unified CCX, you must work with your wallboard vendor to use the new API exposed by Unified CCX.

Wallboard software with the new service ensures that the wallboard server always displays data from the master database server of Unified CCX and no manual intervention is required. Follow this procedure to complete the setup:

**Procedure**

| Step 1 | Create DSN using secondary server information and modify the same DSN using primary server information. This will create sqlhost entries for both the servers in a registry at HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts. |
| Step 2 | Configure the wallboard software with new service as described in the wallboard software documentation. |
| Step 3 | Configure information of both the Unified CCX servers with new service of wallboard as described in the wallboard software documentation. |

**What to Do Next**

After you complete this procedure, no manual intervention is required in case of failover.

Use Wallboard Software (without New Service) in HA Deployment

If you use the existing wallboard software without the new service in an High Availability (HA) deployment of Unified CCX, you must complete the following actions:
Procedure

Step 1 Create DSN using secondary server information and modify the same DSN using primary server information. This will create sqlhost entries for both the servers in a registry at HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts.

Step 2 Configure the wallboard software as described in the wallboard software documentation.

Step 3 Whenever there is a failover, you must manually change the DSN registry entry as follows:
   a) Enter http://<Unified CCX server IP Address>/uccx/isDBMaster in a web browser from any wallboard client to know whether the requested Unified CCX IP address server has a database master or not.
   b) On failover, change SERVER value to master DB instance name in registry of DSN under HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI
   c) You can find the exact database instance name at HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts

Historical Reporting Menu

Caution While Unified CM supports Unicode characters in first and last names, those characters become corrupted in Unified CCX Administration web pages for RmCm configuration, Real Time Reporting, Cisco Agent/Supervisor Desktop.

Use the areas of the Historical Reporting Configuration web page to perform a variety of tasks, including configuring users, installing client software, and purging your database.

To access the different Historical Reporting Configuration options, choose Tools > Historical Reporting and click any of the following submenu options from the Unified CCX Administration menu bar:

- Reporting Configuration—to specify the reporting options provided to the user using the following configurations:
  - Database Server Configuration

- SMTP Configuration—to configure the email server used to email scheduled Cisco Unified Intelligence Center (CUIC) reports.

- Purge Schedule Configuration—to automatically purge data as per the following configurations:
  - Timing of the purge
  - Automatic purge configuration

- Purge Now—to manually purge data.

- File Restore—to restore database records written to HR files when the database goes down.
For additional information on Historical Reporting, see *Cisco Unified CCX Historical Reports User Guide*.

**Related Topics**
- Database Server Configuration, on page 334
- SMTP Configuration, on page 334
- Purge Now Option, on page 335
- Purge Schedule Configuration Option, on page 335
- File Restore Option, on page 335

**Database Server Configuration**

Use the Database Server Configuration area to specify the maximum number of client and scheduler connections that can access the database server.

**SMTP Configuration**

Use SMTP Server Settings area to configure the email server used to email scheduled Cisco Unified Intelligence Center (CUIC) reports.

**Note**
This page is enabled only if you select Cisco Unified Intelligence Center Reporting Client in the Reporting Configuration page.

The following fields are displayed in the SMTP Server Settings area:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host/IP Address</td>
<td>The host name or IP address of the SMTP server</td>
</tr>
<tr>
<td>From email address</td>
<td>The email address that is to appear in the From field of emails sent by the Scheduler</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Unified CCX supports alphanumeric IDs and special characters (only hyphen &quot;,&quot;, underscore &quot;,&quot;, and dot &quot;,&quot;).</td>
</tr>
<tr>
<td>Use Email Proxy</td>
<td>Check this if you use a proxy server to reach your SMTP server</td>
</tr>
<tr>
<td>Email Proxy Hostname</td>
<td>The hostname or IP address of the proxy server used to reach the SMTP server</td>
</tr>
<tr>
<td>Email Proxy Port</td>
<td>The port used to connect to the SMTP proxy server</td>
</tr>
<tr>
<td>Use SMTP Authentication</td>
<td>Check this if your SMTP server expects to receive username/password credentials</td>
</tr>
<tr>
<td>SMTP Username</td>
<td>If you check the Authenticate checkbox, enter the username that is to be authenticated</td>
</tr>
</tbody>
</table>
If you check the Authenticate checkbox, enter the password that is to be authenticated.

Note
You will not be able to save the SMTP configuration if Cisco Unified Intelligence Center service on the publisher node is down.

Related Topics
Configure Unified CCX Historical Reporting, on page 13

Purge Schedule Configuration Option
Use the Purge Schedule Configuration area to select a user for whom you want to choose a reporting package for the Unified CCX Historical Reports system.
Choose Tools > Historical Reporting > Purge Schedule Configuration from the Unified CCX Administration menu bar to access the Purge Schedule Configuration web page.
The Historical Reporting Configuration web page opens, enabling you to configure the following:
• Daily purge schedule
• Automatic purge (you can specify how long records should persist before the system purges them)

Related Topics
Configure Purge Schedule Configuration Parameters, on page 184
Configure Automatic Purging, on page 183
View Historical Reports, on page 183

Purge Now Option
Use the Purge Now area to manually purge data.
Choose Tools > Historical Reporting > Purge Now from the Unified CCX Administration menu bar to access the Purge Now area.

Related Topics
Purge Manually, on page 185

File Restore Option
Use the File Restore area to restore the database records written to HR files when the database goes down.
In case of an High Availability setup, files from both the nodes are restored to the HR Database of the first and second node respectively. If it is unable to connect to the second node, you will see an alert message stating that the remote node is not reachable. When the second node comes up, the restored data will be replicated but you must repeat this Restore operation to restore the HR files, if any, on the second node.

**Procedure**

**Step 1** Choose **Tools > Historical Reporting > File Restore** from the Unified CCX Administration menu bar to access the Historical Reporting Configuration web page.

*Note* Restore Now radio button is enabled by default on this page.

**Step 2** Click the **Start** icon that displays in the toolbar in the upper left corner of the window or the **Start** button that displays at the bottom of the window to restore the database records.

You can view the status of the restore operation on this page.

---

**User Management Menu**

The User Management menu option allows you to assign access levels to Unified CCX system administrators and supervisors.

When you configure a Unified CCX supervisor, you are configuring users who can access the Unified CCX Supervisor web pages. You are not creating a supervisor for Unified CCX.

*Note* Only administrators can update the Unified CCX system. You must select at least one administrator, so that someone is available to perform updates.

*Attention* Do not edit users, teams and permissions in Unified Intelligence Center. The Unified CCX to Unified Intelligence Center sync runs as part of daily purge and synchronizes these settings on Unified Intelligence Center according to Unified CCX settings.

**Procedure**

Choose **Tools > User Management** and click any of the following submenu options from the Unified CCX Administration menu bar to assign administrative privileges to administrators and supervisors:

- **User View Submenu,** on page 337
- **Name Grammar Generator Configuration,** on page 337
- **Spoken Name Upload Submenu,** on page 338
- **Administrator Capability View Menu,** on page 339
- **Supervisor Capability View Menu,** on page 339
User View Submenu

From the Unified CCX Administration menu bar, choose **Tools > User Management > User View** to access the User Configuration web page.

Use this page to view existing users and assign administrative privileges to administrators and supervisors. You can provide a search string based on a user ID; for example, if you provide the search string as

- “*Agent1*”, it will display user IDs ending with Agent1
- “Agent1*”, it will display user IDs starting with Agent1
- “Agent1”, it will display user IDs that contain Agent1.

All the columns are hyperlinked to the user configuration page.

**Note**

This search bar will search the users only by last name or user ID. Do not use the first name for searching.

**Related Topics**

- Remote Monitoring Use and Configuration, on page 116
- Create Remote Monitoring Supervisor, on page 116
- Assign Resources and Contact Service Queues to a Supervisor, on page 117
- About Unified CCX User Capabilities, on page 263
- Create Team Supervisor, on page 120

Name Grammar Generator Configuration

Use the Name Grammar Generator Configuration web page to define scheduling information for the Name Grammar Generator.

From the Unified CCX Administration menu bar, choose **Tools > User Management > Name Grammar Generator Configuration** to access Name Grammar Generator Configuration area.
Name Grammars must be generated if you wish to use the Name to User Step with ASR. The Name Grammar Generator scans the User Directory and creates a speech recognition grammar containing every user in the directory. These grammars are saved in the grammar repository.

You may use the Name Grammar Generator Configuration page to run the Name Grammar Generator or schedule it to run at some later time. The page also displays the date and time that the Name Grammar Generator was last run and the completion status of that run.

The following fields are displayed on the Name Grammar Generator web page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency</td>
<td>How often Name Grammar Generator is automatically run. Valid options: Never, Daily, and Weekly. This is a mandatory field.</td>
</tr>
<tr>
<td>Run task on (hrs of day)</td>
<td>Time of day to run the task. This is a mandatory field.</td>
</tr>
<tr>
<td>Run task on (day of week)</td>
<td>Day of week to run the task. This is a mandatory field.</td>
</tr>
<tr>
<td>Last Completed on</td>
<td>Date of last generation of name grammar.</td>
</tr>
<tr>
<td>Last Completion Result</td>
<td>The status after the last name grammar generation. (Display only.)</td>
</tr>
<tr>
<td>Grammar Variant</td>
<td>Select one or more grammar variants to generate from the check box next to the following three options:</td>
</tr>
<tr>
<td></td>
<td>• OSR 3.1.x</td>
</tr>
<tr>
<td></td>
<td>• 2003 SISR</td>
</tr>
<tr>
<td></td>
<td>• Nuance</td>
</tr>
<tr>
<td>Current Status</td>
<td>Running status of the Name Grammar Generator. (Display only.)</td>
</tr>
</tbody>
</table>

Click the **Generate Name Grammar Now** icon or button to trigger the Name Grammar Generator.

**Note**

Clicking **Generate Name Grammar Now** will not apply changes to the scheduling configuration; you must click **Update** to apply scheduling changes.

### Spoken Name Upload Submenu

When a caller requests to be transferred to a specific extension, Unified CCX applications can playback a recording of the spoken name of the person to whom the caller has called. These spoken name recordings are stored as .wav files and managed by the Spoken Name Upload tool of the Unified CCX Administration web interface.

To access the Spoken Name Prompt Upload web page, choose **Tools > User Management > Spoken Name Upload** from the Unified CCX Administration menu bar.
The Spoken Name Prompt Upload webpage also contains the Click Here for Recording Information icon and button, which displays a .htm page in your browser with more information on recording spoken name prompts.

**Related Topics**

Add Spoken-Name Prompts, on page 147

**Administrator Capability View Menu**

From the Unified CCX Administration menu bar, choose Tools > User Management > Administrator Capability View to access the capability view for the Administrator User Management area.

This webpage contains a pane for users identified as Unified CCX Administrator and another pane with the list of Available Users. Based on your requirements, you can move users back and forth between these two panes by clicking the arrows in either direction. Click **Update** to save the changes.

---

**Note**

You cannot assign Administrator capability to a user ID that is the same as the application administrator user ID created during the Unified CCX installation. If you assign Administrator capability to such a user ID, an error appears.

---

**Related Topics**

Administrator Privileges, on page 264

**Supervisor Capability View Menu**

From the Unified CCX Administration menu bar, choose Tools > User Management > Supervisor Capability View to access the capability view for the Supervisor User Management area.

This webpage contains a pane for users identified as the Unified CCX Supervisor and another pane with the list of Available Users. Based on your requirements, you can move users back and forth between these two panes by clicking the arrows in either direction.

---

**Note**

For a supervisor to access Unified Intelligence Center Live Data reports, an extension should be assigned to the supervisor.

---

**Note**

You cannot assign Supervisor capability to a user ID that is the same as the application administrator user ID created during the Unified CCX installation. If you assign Supervisor capability to such a user ID, an error appears.

---

**Related Topics**

Supervisor Privileges, on page 264

Unified CCX Supervisor Web Interface, on page 266
Reporting Capability View Menu

From the Unified CCX Administration menu bar, choose Tools > User Management > Reporting Capability View to access the capability view for the Historical Report Users area.

The capability view for the Reporting Management web page contains a pane for users identified as Unified CCX Historical Report Users and another pane with the list of Available Users. Based on your requirements, you can move users back and forth between these two panes by clicking the arrows in either direction.

---

**Note**

You cannot assign Reporting capability to a user ID that is the same as the application administrator user ID created during the Unified CCX installation. If you assign Reporting capability to such a user ID, an error appears.

---

The following users can access Unified Intelligence Center:

<table>
<thead>
<tr>
<th>Roles</th>
<th>Access</th>
<th>Available reports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application administrator</td>
<td>Super user</td>
<td>• Historical reports</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Live Data reports</td>
</tr>
<tr>
<td>Reporting user</td>
<td>Unified CCX administrator must assign this role to a user.</td>
<td>• Historical reports</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Live Data reports</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Unified CCX administrator must assign this role to a user.</td>
<td>Live Data reports</td>
</tr>
<tr>
<td>Agent</td>
<td>Unified CCX administrator must assign this role to a user.</td>
<td>Agent-specific Live Data reports</td>
</tr>
</tbody>
</table>

---

**Related Topics**

- Historical Report User Privileges, on page 265

Agent Capability View Menu

From the Unified CCX Administration menu bar, choose Tools > User Management > Agent Capability View to access the capability view for Unified CCX agents.

The capability view for the Agent User Management web page contains a pane for users identified as Unified CCX Agents and another pane with the list of Available Users. Based on your requirements, you can move users back and forth between these two panes by clicking the arrows in either direction.

---

**Related Topics**

- Agent Privileges, on page 265
Password Management

From the Unified CCX Administration menu bar, choose Tools > Password Management to access the password management web page.

You can set or reset the passwords for the following external database users using this web page:

<table>
<thead>
<tr>
<th>User</th>
<th>Username</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wallboard</td>
<td>uccxwallboard</td>
<td>This user can connect to Configuration and Historical databases and has read-only access to RtICDStatistics and RtCSQsSummary tables.</td>
</tr>
<tr>
<td>Recording SFTP</td>
<td>uccxrecording</td>
<td></td>
</tr>
<tr>
<td>Workforce Management</td>
<td>uccxworkforce</td>
<td></td>
</tr>
<tr>
<td>Historical Reporting</td>
<td>uccxhruser</td>
<td>This user can connect to Configuration, Historical, and Repository databases and has the following privileges:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• read-only access to Historical, Configuration, and Repository tables</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• execute stored procedures</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• create new stored procedures</td>
</tr>
<tr>
<td>System Call Tracking (part of Real Time Monitoring Tool/ Analysis Manager)</td>
<td>uccxsct</td>
<td></td>
</tr>
</tbody>
</table>

Click Save icon that displays in the toolbar in the upper left corner of the window or the Save button that displays at the bottom of the window. An error message appears if the old and new passwords are same for any of the users.

To remove the data entered and to retain the existing passwords, click the Clear button.

Note

• The maximum length of the password entered is limited to 80 characters.

• A new password cannot be one of the last five passwords used.

In case of a High Availability deployment, the password change will not be propagated to the second node. You must access the Administration web interface of the second node manually to change the password. In an HA setup, you can see Check Consistency icon or button in the Password Management page. Use this...
button to check and confirm whether the passwords between the two nodes match or not. You can see the status of the password check in the Password Management page.
Help Menu

The Help Menu of the Unified CCX Administration web interface provides access to online help for the Unified CCX system.

Use the Help menu to access configuration procedures and descriptions of Unified CCX components.

The Help menu contains the following menu options:

- **Contents and Index**—Choose this option to view the entire Unified CCX Administrator Guide online help system and index.
- **For this page**—Choose this option to view context-sensitive help.
- **Troubleshooting Tips**—Choose this option to view the troubleshooting wiki page for suggestions on how to solve problems that may arise in the performance of your Unified CCX system.
- **Unified CCX Documentation on Cisco.com**—Choose this option to view the documentation index page.
- **About**—Choose this option to view Unified CCX version information.

The following sections describe the Help menu options.

- **Contents and Index, page 343**
- **For This Page Menu, page 344**
- **Troubleshooting Tips Menu, page 344**
- **Unified CCX Documentation Link, page 344**
- **About Menu, page 345**

## Contents and Index

To view the entire Unified CCX Administrator Guide online help system and index, choose Help > Contents and Index from the Unified CCX Administration menu bar. The Unified CCX Administrator Guide Online Help window opens.

When you click any topic in the top pane, the section of the online help that corresponds to that topic appears in the bottom pane.
The following table describes the menu options in the Unified CCX Administrator Guide Online Help window.

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Returns you to the beginning of the online help document.</td>
</tr>
<tr>
<td>Search</td>
<td>Opens a search window, in which you can search for specific words in the online help files.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Opens a file explaining how to use the online help files.</td>
</tr>
<tr>
<td>Glossary</td>
<td>Opens a glossary of definitions for terms used in Cisco Unified CCX and Cisco Unified IP IVR.</td>
</tr>
<tr>
<td>View PDF</td>
<td>Opens a PDF version of the Cisco Unified CCX Administration Guide.</td>
</tr>
<tr>
<td>Contents and Index</td>
<td>Displays the index and contents of the Unified CCX Administrator Guide online help files in a separate web page. The index is displayed in the left pane while the contents are displayed in the right pane in the online help page.</td>
</tr>
</tbody>
</table>

**For This Page Menu**

To access context-sensitive help, open the web page for which you want help and choose Help > For This Page from the Unified CCX Administration menu bar. The Unified CCX Administration online help displays information that is specific to the open web page.

**Troubleshooting Tips Menu**

The Unified CCX system provides the Troubleshooting Tips tool as a way for you to search the troubleshooting wiki page for suggestions on how to solve problems that may arise in the performance of your Unified CCX system.

For more information, see the Troubleshooting Wiki page: http://docwiki.cisco.com/wiki/Troubleshooting_Unified_Contact_Center_Express.

To access the Troubleshooting Tips wiki page, choose Help > Troubleshooting Tips from the Unified CCX Serviceability Administration menu bar.

**Unified CCX Documentation Link**

To access the complete Unified CCX documentation set for Unified CCX, and Unified IP IVR, choose Help > Cisco Unified CCX Documentation on Cisco.com from the Unified CCX Administration menu bar. A

About Menu

To access Unified CCX version information, choose Help > About from the Unified CCX Administration menu bar. The Unified CCX Administration web page opens, displaying version information and package information.
Cisco Mobile Skill Manager

The Unified CCX supervisor can use the Cisco Mobile Skill Manager on a smart phone to remotely manage the skill data of all associated agents. This application is not a native one and can run on smart phone browsers. The devices with the following operating systems are supported:

- For Apple devices using iOS - 5.x and above with Safari browser
- For Android devices - 2.x and above with default browser

The following sections provide procedures to allow you to access Cisco Mobile Skill Manager, such as modify the team; add and delete new skills, add, delete and update skills of agents; and view skills and agents.

- Access Mobile Skill Manager, page 347
- Adding Skills Using Cisco Mobile Skill Manager, page 348
- Searching Skills Using Cisco Mobile Skill Manager, page 349
- View Details of Resources Assigned to Supervisor, page 349
- View Resources Assigned to Supervisor, page 350
- Search Resources Using Cisco Mobile Skill Manager, page 350
- Modify Resource Team, page 350
- Assign Skill Competency to Resource, page 351
- Unassign Skill Competency of Resource, page 351

Access Mobile Skill Manager

Pre-requisites

Cisco Mobile Skill Manager allows you as the supervisor to manage the skill data associated with an agent. You can also modify the agent team, and add and delete new skills. Before you access the Cisco Mobile Skill Manager, make sure

- the supervisor capability is assigned to you. To know more on supervisor options, see sections Supervisor Privileges and User View submenu option, in this guide.
- Cisco Tomcat and Cisco Unified Cluster View Daemon services are up and running.

Follow the steps below to login to Cisco Mobile Skill Manager from your smart phone:

1. Open Cisco Mobile Skill Manager home page from your mobile smart phone browser and enter the following case-sensitive URL: https://<ipaddress>/mobileskillmanager
   
   In this example, replace <ipaddress> with the IP address of the required Unified CCX server.

2. In the Security Alert dialog box that displays, click the appropriate button.

3. In the Cisco Mobile Skill Manager authentication page, enter the supervisor credentials, and click Sign In. Note that the user name is case-sensitive.
   
   A window with the Resources and Skills links is displayed.

   - **Resources**: This link is used to access the Resources page. This page displays the resources assigned to you.
   - **Skills**: This link is used to access the Skills page. You can add a new skill or delete an existing skill from this page.

4. Select either depending on what you want to do. Individual tasks related to these two choices are provided separately.

### Adding Skills Using Cisco Mobile Skill Manager

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Login to Cisco Mobile Skill Manager using supervisor credentials.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click <strong>Skills</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the Skills page, enter the name of the skill in the edit box and click the <strong>Add</strong> button. A dialog box confirming the successful addition of skill is displayed.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click <strong>OK</strong>. The dialog box closes and the Skills page refreshes to display the updated list of skills.</td>
</tr>
</tbody>
</table>
Searching Skills Using Cisco Mobile Skill Manager

Procedure

- **Step 1**  
  Login to Cisco Mobile Skill Manager using supervisor credentials.

- **Step 2**  
  Click Skills.

- **Step 3**  
  In the Skills page, enter the skill to be searched in the search filter box.

- **Step 4**  
  If the skill exists, the same will be displayed.

View Details of Resources Assigned to Supervisor

Procedure

- **Step 1**  
  Login to Cisco Mobile Skill Manager using supervisor credentials.

- **Step 2**  
  Click Resources.  
  The Resources page launches to display all resources assigned to the supervisor.

- **Step 3**  
  Click the selected resource name. The Resource details page launches and lists the following details of the selected resource.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Displays the full name of the resource.</td>
</tr>
<tr>
<td>User Id</td>
<td>Displays the user id of the resource.</td>
</tr>
<tr>
<td>IPCC Extension</td>
<td>Displays the IPCC extension of the resource.</td>
</tr>
<tr>
<td>Team</td>
<td>Link to launch the Teams page which displays the team to which the resource is assigned.</td>
</tr>
<tr>
<td>Skills</td>
<td>Link to launch the Assigned skills page which displays the skills assigned to the resource.</td>
</tr>
</tbody>
</table>
**View Resources Assigned to Supervisor**

**Procedure**

**Step 1**  
Login to Cisco Mobile Skill Manager using supervisor credentials.

**Step 2**  
Click **Resources**.  
The Resources page launches to display all resources assigned to the supervisor.

---

**Search Resources Using Cisco Mobile Skill Manager**

**Procedure**

**Step 1**  
Login to Cisco Mobile Skill Manager using supervisor credentials.

**Step 2**  
Click **Resources**.

**Step 3**  
In the Resources page, enter the name of the agent, that you want to search, in the Search box.  
The agent information is displayed.

---

**Modify Resource Team**

**Procedure**

**Step 1**  
Login to Cisco Mobile Skill Manager using supervisor credentials.

**Step 2**  
Click **Resources**.  
The Resource page launches and all resources assigned to the supervisor are displayed.

**Step 3**  
Click the resource name to launch the Resource details page.

**Step 4**  
In the Resource details page, click **Teams**.  
The Teams page launches to display all the teams configured in the Cisco CCX system.

**Step 5**  
Click the team name, then in the confirmation box click **OK**.  
A window displays the successful modification of the team.

**Step 6**  
To return back to the Agents Details page, click **OK**.
### Assign Skill Competency to Resource

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Login to Cisco Mobile Skill Manager using supervisor credentials.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click <strong>Resources</strong>. The Resource page displays all the resources assigned to the supervisor.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the resource name to display the Resource details window.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click <strong>Skill</strong>. All skills configured in Unified CCX are displayed.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To set the competency level for a particular skill, select the value from the drop down list displayed against each skill.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click the <strong>Update</strong> button located at the top of the window. A dialog box displays the successful assignment of a skill to a resource.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Click <strong>OK</strong> to be redirected to the Resources Details page.</td>
</tr>
</tbody>
</table>

### Unassign Skill Competency of Resource

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Login to Cisco Mobile Skill Manager using supervisor credentials.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click <strong>Resources</strong>.</td>
</tr>
</tbody>
</table>

**Example:**

The Resources page launches displaying names of all resources assigned to the supervisor.

<table>
<thead>
<tr>
<th>Step 3</th>
<th>Click on a resource name to launch the Resources details page.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 4</td>
<td>Click <strong>Skills</strong>. The skills page with all skills configured in Unified CCX is displayed.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To unassign the competency level for a particular skill, select the value <strong>NA</strong> from the drop-down list for that resource.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click the <strong>Update</strong> button that displays at the top of the window.</td>
</tr>
</tbody>
</table>

**Example:**

A dialog box shows the success of the task, that is unassigning a skill.

| Step 7 | Click **OK** to return to the Resource Details page. |
Unified CCX Web Chat

Unified CCX Premium provides the facility for end users to initiate a chat session with the agent from a website, typically the public website of the organization using the Unified CCX. Unified CCX provides separate agent and supervisor web applications.

For Web Chat Agent
To enable chat agent login to the Web Chat Agent Desktop using Cisco Agent Desktop as the integrated browser, configure work site for Web Chat Agent Desktop using the URL https://<<servername>>/agentdesktop where <<servername>> is the fully qualified domain name of Unified CCX, for example, https://uccxnode.cisco.com/agentdesktop. Web Chat Agent Desktop will not work if you use the IP address.

For Web Chat Supervisor
To enable chat supervisor login to the Web Chat Supervisor Desktop using Cisco Supervisor Desktop as the integrated browser, configure Web Chat Supervisor Desktop using the Preferences setting.
Cisco Finesse

Introduction

Cisco Finesse is a next-generation agent and supervisor desktop designed to provide a collaborative experience for the various communities that interact with your customer service organization. It helps improve the customer experience while offering a user-centric design to enhance customer care representative satisfaction as well. Cisco Finesse provides:

- A browser-based administration console and a browser-based desktop for agents and supervisors; no client-side installations required.
- A single, customizable "cockpit", or interface, that gives customer care providers quick and easy access to multiple assets and information sources.
- REST APIs that simplify the development and integration of value-added applications and minimize the need for detailed desktop development expertise.
Cisco Finesse service is not activated by default even when you update the appropriate licenses on a Unified CCX deployment.

Run the `utils uccx finesse activate` command to activate Cisco Finesse Service on each Unified CCX node in a cluster.

After you run this command, reboot the Unified CCX server.


If you plan to use multisession chat and email, you must first activate Finesse. Then you must configure SocialMiner and chat and email CSQs in Unified CCX. When you configure SocialMiner, Unified CCX creates a single chat feed. Unified CCX creates an email feed for each email CSQ that you configure.

Finesse configuration changes are permitted on only the primary server. Access to Finesse administration console on the secondary server is read-only.

When you attempt to save the changes in Finesse administration console on the secondary node, you receive a message that administration on the secondary node is read-only.

## Cisco Finesse Administration Console

### Getting Started

This chapter describes the interfaces that you use to configure, administer, and maintain Cisco Finesse and describes how to access them.

### Administration Tools

Cisco Finesse Administration Console

The Cisco Finesse administration console is a web-based interface used to configure system settings in Cisco Finesse. The administration console contains tabs that you click to access the various administration features. The tab names and the tasks that you can perform on each tab are as follows:

- **Call Variables Layout**: Manage the call variables and ECC variables that appear on the agent desktop call control gadget.
- **Desktop Layout**: Make changes to the default desktop layout for agents and supervisors.
- **Phone Books**: Add, edit, or delete phone books or phone book contacts.
- **Reasons**: Add, edit, or delete Not Ready reason codes, Sign Out reason codes, or Wrap-Up reasons.
- **Team Resources**: Assign desktop layouts, phone books, reason codes, and wrap-up reasons to specific teams.
- **Workflows**: Create and manage workflows and workflow actions.
The features you configure in the administration console are case-sensitive. For example, you can create two workflows named WORKFLOW and workflow or two phone books named BOOK and book.

**Sign In to Cisco Finesse Administration Console**

You can access the Cisco Finesse administration console only through HTTPS.

**Procedure**

**Step 1**
Direct your browser to https://hostname or IP address:8445/cfadmin, where hostname is the hostname of your primary server.

**Step 2**
On the Sign-In page, in the ID field, enter the Application User ID that was established during the installation.

**Step 3**
In the Password field, enter the Application User password that was established during the installation.

**Step 4**
Click **Sign In**.
A successful sign-in launches an interface with defined administration gadgets and a Sign Out link.

**Manage Call Variables Layout**

On the Call Variables Layout tab on the Cisco Finesse administration console, you can define how call variables appear on the Finesse agent desktop.

**Call Variables**

The Finesse agent desktop supports one variable in the header of the call control gadget and up to a total of 20 variables in two columns below the header (up to 10 in each column). You can use call variables, Extended Call Context (ECC) variables, or the following Outbound Option ECC variables.

- BACampaign
- BAAccountNumber
- BAResponse
- BStatus
- BADialedListID
- BATimeZone
- BABuddyName
- BACustomerNumber

Columns can be empty.

**Note**

If a Predictive or Progressive Outbound call is transferred or conferenced, the BStatus of the call changes from OUTBOUND to TRANSFERRED/CONFERENCED_OUTBOUND. The BStatus for a Direct Preview outbound call remains OUTBOUND after the call is transferred or conferenced.
The following table describes the fields on the Manage Call Variables Layout gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Name</td>
<td>A label that describes the variable for that entry (for example, Customer Name). The maximum length of this field is 50 characters.</td>
</tr>
<tr>
<td>Variable</td>
<td>The name of the call variable or ECC variable that is displayed to the agent. The maximum length of this field is 32 characters.</td>
</tr>
<tr>
<td>Delete?</td>
<td>Click the &quot;X&quot; to delete the specified row from the column.</td>
</tr>
</tbody>
</table>

Actions on the Manage Call Variables Layout gadget:

- **Add Row**: Adds a new row to the specified column

  Note: The Add Row button is disabled if 10 variables are already configured for the specified column.

- **Save**: Saves your configuration changes

- **Revert**: Retrieves and reapplies the most recently saved call variable layout

Note: When you modify the call variable layout of the agent desktop, the changes you make take effect after three seconds. However, agents who are signed in when the changes are made must sign out and sign back in to see those changes reflected on their desktops.

### Configure Call Variable Layout

**Procedure**

**Step 1**
In the Call Header Layout area, in the Display Name field, enter the text that you want to appear in the header of the Call Control gadget on the Finesse desktop (for example, Customer Name).

**Step 2**
From the Variable drop-down list, choose the call variable or Outbound Option ECC variable that you want to appear in the header (for example, callVariable3).

**Step 3**
In the Call Body Left-Hand Layout and Call Body Right-Hand Layout areas:

a) Click the X beside any row that you want to delete.

b) Click **Add Row** if you want to add a new row.

c) For each row, in the Display Name field, enter the text that you want to appear on the desktop, and then choose the corresponding call variable or Outbound Option ECC variable from the Variable drop-down list.

**Step 4**
Click **Save**.
Add ECC Variables to Call Variables Layout

Note  Cisco Finesse only supports Latin1 characters for ECC variables. Other Unicode characters are not supported. For example, if you add an ECC variable that contains Chinese characters to the call variable layout, it may not appear correctly on the agent desktop.

Procedure

Step 1  In the header or the row where you want the ECC variable to appear, from the Variable drop-down list, choose Custom.
The Custom/ECC Variable Entry dialog box appears.

![Custom/ECC Variable Entry](image)

Step 2  In the Custom/ECC Variable Name field, enter the name of the ECC variable you want to appear on the agent desktop.

Step 3  Click Set.
The ECC variable now appears in the Variable drop-down list for selection.

Manage Desktop Layout

You can define the layout of the Finesse desktop on the Desktop Layout tab.
Requirements, such as processor speed and RAM, for clients that access the Finesse desktop can vary. Desktops that receive events for more than one agent (such as agent and supervisor desktops running Live Data reports that contain information about other agents and skill groups) require more processing power than desktops that receive events for a single agent.

Factors that determine how much power is required for the client include, but are not limited to, the following:

- Contact center traffic
- Additional integrated gadgets in the desktop (such as Live Data reports or third-party gadgets)
- Other applications that run on the client and share resources with the Finesse desktop

**Finesse Desktop Layout XML**

The Finesse Layout XML defines the layout of the Finesse desktop, including tab names and the gadgets that appear on each tab.

Use the Manage Desktop Layout gadget to upload an XML layout file to define the layout of the Finesse desktop for agents and supervisors.

**Actions on the Manage Desktop Layout gadget:**

- **Finesse Default Layout XML:** Expands to show the layout XML for the default Finesse desktop.
- **Restore Default Layout:** Restores the Finesse desktop to the default layout.
- **Save:** Saves your configuration changes.
- **Revert:** Retrieves and applies the most recently saved desktop layout.

**Default Layout XML**

The Finesse default desktop layout XML for Unified CCX contains optional tabs and gadgets for MediaSense and Web Chat and notes that describe how to modify the layout for your deployment type.

Remove the comments from the optional gadgets and tabs that you want to appear on the Finesse desktop. Remove any gadgets or tabs that you do not want to use.

```xml
<finesseLayout xmlns="http://www.cisco.com/vtg/finesse">
  <layout>
    <role>Agent</role>
    <page>
      <gadget>/desktop/gadgets/CallControl.jsp</gadget>
      <!-- The following Gadget is used for WebChat. It is *ONLY* supported with WebChat. If you are not using WebChat, then remove it. If you are using WebChat, include this Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include this functionality:
      1) Remove these comments leaving the gadget
      <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
      -->
      <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
    </gadget>
    <tabs>
      <!--
      <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
      -->
    </tabs>
  </page>
</layout>
</finesseLayout>
```
The following Tab and Gadget are used for WebChat. They are *ONLY* supported with WebChat. If you are not using WebChat, then remove them. If you are using WebChat, include this Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include this functionality:

1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-socialminer-server" with the Fully Qualified Domain Name of your SocialMiner Server.
3) [OPTIONAL] Adjust the height of the gadget by changing the "gadgetHeight" parameter.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented prerequisite steps.

```xml
<tab>
  <id>manageChats</id>
  <label>finesse.container.tabs.agent.manageChatsLabel</label>
  <columns>
    <gadgets>
      <gadget>https://my-socialminer-server/multisession/ui/gadgets/multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
    </gadgets>
  </columns>
</tab>
```
The following Gadget is used for WebChat. It is *ONLY* supported with WebChat. If you are not using WebChat, then remove it. If you are using WebChat, include this Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include this functionality:

1) Remove these comments leaving the gadget

<!--
The following Gadget is used for WebChat. It is *ONLY* supported with WebChat. If you are not using WebChat, then remove it. If you are using WebChat, include this Gadget in the Desktop Layouts used by Teams associated with chat CSQs. To include this functionality:

1) Remove these comments leaving the gadget

<!--
The following Gadgets are used for Predictive/Progressive/Preview Agent Outbound. To include this functionality:

1) Remove these comments leaving the gadget


</columns>
</tab>
</tabs>
</page>
<column>
  <gadgets>
    <gadget>https://localhost:8444/cuic/gadget/LiveData/
    LiveDataGadget.jsp?gadgetHeight=310&
    viewId=C9E2DB161000140000000A6A4E5E6B6
    filterId=VoiceIAQStats.esdName=CL</gadget>
    <gadget>https://localhost:8444/cuic/gadget/LiveData/
    LiveDataGadget.jsp?gadgetHeight=310&
    viewId=9A7A14CE1000140000000E0A4E5E6B6
    filterId=VoiceCSQDetailsStats.agentId=CL&
    compositeFilterId=VoiceCSQDetailsStats.
    AgentVoiceCSQNames.agentVoiceCSQName=CL
  </gadget>
  </gadgets>
</column>

The following Gadget is used for WebChat. It is *ONLY* supported with
WebChat. If you are not using WebChat, then remove it. If you are using WebChat,
include this Gadget in the Desktop Layouts used by Teams associated with chat
CSQs. To include this functionality:
  1) Remove these comments leaving the gadget
      <gadget>https://localhost:8444/cuic/gadget/LiveData/
      LiveDataGadget.jsp?gadgetHeight=310&
      viewId=E42ED7881000140000000007B0A4E5CA1
      filterId=ChatQueueStatistics.queueName=CL</gadget>
  
  
<!--
</gadgets>
</column>
</tab>

</id>manageCall</id>
</label>finesse.container.tabs.supervisor.manageCallLabel</label>
</tab>

The following Tab and Gadget are used for WebChat. They are *ONLY* supported with
WebChat. If you are not using WebChat, then remove them. If you are using WebChat,
include this Gadget in the Desktop Layouts used by Teams associated with chat
CSQs. To include this functionality:
  1) Remove these comments leaving the tab and gadget
  2) Replace all instances of "my-socialminer-server" with the Fully Qualified
    Domain Name of your SocialMiner Server.
  3) [OPTIONAL] Adjust the height of the gadget by changing the "gadgetHeight"
    parameter.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented
  prerequisite steps.

<tab>
  <id>manageChats</id>
</label>finesse.container.tabs.supervisor.manageChatsLabel</label>
</tab>

The following Tab and Gadget are for MediaSense. They are *ONLY* supported with
MediaSense. If you are not using MediaSense, then remove them. If you are using
MediaSense and wish to show Recording Management, then do the following:
  1) Remove these comments leaving the tab and gadget
  2) Replace all instances of "my-mediasense-server" with the Fully Qualified
    Domain Name of your MediaSense Server.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented
  prerequisite steps.
Update Default Desktop Layout

When you modify the layout of the Finesses desktop, the changes you make take effect on the desktop after 10 seconds. However, agents who are signed in when the changes are made must sign out and sign back in to see those changes reflected on the desktop.

Note

The call control gadget is only supported at the page level. You must ensure that the call control gadget (<gadget>/desktop/gadgets/CallControl.jsp</gadget>) is placed within the <page></page> tag for it to work correctly. Do not place this gadget within a <tab></tab> tag.

Procedure

Step 1 In the Finesses Layout XML area, make changes to the XML as required.

Example:
If you want to add a new tab called Reports, add the following XML within the tabs tags under the <role>Agent</role> tag.

```
<tab>
  <id>reports</id>
  <label>Reports</label>
</tab>
```

If you want to add this tab to the supervisor desktop, add the XML within the tabs tags under the <role>Supervisor</role> tag.

To add a gadget to a tab, add the XML for the gadget within the gadgets tag for that tab.

```
<gadgets>
  <gadget>http://<ipAddress>/gadgets/<gadgetname>.xml</gadget>
</gadgets>
```

Replace <ipAddress> with the IP address of the server where the gadget resides.

If you want to add multiple columns to a tab on the Finesses desktop, add the gadgets for each column within the columns tags for that tab. You can have up to four columns on a tab.

```
<tab>
  <id>tab-id</id>
```
<label>Tab Label</label>
<columns>
  <column>
    <gadgets>
      <gadget>/gadget/1/url.xml</gadget>
      <gadget>/gadget/2/url.xml</gadget>
    </gadgets>
  </column>
  <column>
    <gadgets>
      <gadget>/gadget/3/url.xml</gadget>
      <gadget>/gadget/4=url.xml</gadget>
    </gadgets>
  </column>
</columns>

**Step 2**  **Click Save.**  
Finesse validates the XML file to ensure that it is valid XML syntax and conforms to the Finesse schema.

**Step 3**  
After you save your changes, if you want to revert to the last saved desktop layout, click **Revert**. If you want to revert to the default desktop layout, click **Restore Default Layout**.

### XML Schema Definition

You must ensure the XML you upload conforms to the XML schema definition for Finesse. The XML schema definition for Finesse is as follows:

```xml
<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
  targetNamespace="http://www.cisco.com/vtg/finesse"
  xmlns="http://www.cisco.com/vtg/finesse"
  elementFormDefault="qualified">
  <!-- definition of role type -->
  <xs:simpleType name="role">
    <xs:restriction base="xs:string">
      <xs:enumeration value="Agent"/>
      <xs:enumeration value="Supervisor"/>
      <xs:enumeration value="Admin"/>
    </xs:restriction>
  </xs:simpleType>
  <!-- definition of simple elements -->
  <xs:element name="id">
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:pattern value="[a-zA-Z][\-\_\:\.a-zA-Z0-9]*"/>
      </xs:restriction>
    </xs:simpleType>
  </xs:element>
  <xs:element name="label">
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:minLength value="1" />  
      </xs:restriction>
    </xs:simpleType>
  </xs:element>
  <xs:element name="gadget">
    <xs:simpleType>
      <xs:restriction base="xs:anyURI">
        <xs:minLength value="1" />  
      </xs:restriction>
    </xs:simpleType>
  </xs:element>
</xs:schema>
```
Add Web Chat to Finesse

The Cisco Finesse default layout XML contains commented XML code for Web Chat gadgets available for the Finesse desktop. Each gadget or tab is surrounded by comment characters (<!-- and -->) and comments that describe what the tab or gadget is for and how to add it to the desktop.
The Chat Control gadget is only supported at the page level. You must ensure that the Chat Control gadget (<gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>) is placed within the <page></page> tag. Placing this gadget within a <tab></tab> tag is not supported.

The procedure that you follow depends on your deployment. The following table describes when to use each procedure.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Web Chat to the default desktop layout.</td>
<td>Follow this procedure if you want to add Web Chat to the Finesse desktop after a fresh installation or after an upgrade if you have not customized the default desktop layout.</td>
</tr>
<tr>
<td>Add Web Chat to a custom desktop layout.</td>
<td>Follow this procedure if you want to add Web Chat and have customized the desktop layout.</td>
</tr>
<tr>
<td>Add Web Chat to a team layout.</td>
<td>Follow this procedure if you want to add Web Chat to the desktop only for specific teams.</td>
</tr>
</tbody>
</table>

After you add the Web Chat gadgets, sign in to the Finesse desktop and make sure they appear the way you want. Agents who are signed in to Finesse when you change the desktop layout must sign out and sign back in to see the change on their desktops.

**Add Web Chat to the Default Desktop Layout**

If you upgraded from a previous release but do not have a custom desktop layout, click **Restore Default Layout** on the Manage Desktop Layout gadget and then follow the steps in this procedure.

**Procedure**

**Step 1** In the Finesse administration console, click the Desktop Layout tab.

**Step 2** To add the Chat Control gadget to the agent desktop, look for the following under the <role>Agent</role> tag and within the <page></page> tag:

<gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>

**Step 3** Remove the comments and comment characters (<!-- and -->) that surround the gadget, leaving only the gadget (<gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>).

**Step 4** To add the Manage Chats tab and gadget to the agent desktop, look for the following within the <tabs></tabs> tag:

<tab>
  <id>manageChats</id>
</tab>
Step 5  Remove the comments and comment characters (<!-- and -->) that surround the tab.

Step 6  Replace my-socialminer-server in the gadget URL with the fully-qualified domain name (FQDN) of your SocialMiner server.

Step 7  Optionally, change the height of the Manage Chats gadget.

Example:
The height specified in the gadget URL is 430 pixels. If you want to change the height, change the gadgetHeight parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change the code as follows:

Example: The default and minimum height of the Manage Chats gadget is 430 pixels. If you do not specify a value for the gadgetHeight parameter or if you specify a value that is less than 430, the gadget defaults to 430 pixels.

Step 8  To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:

Example: To add the Chat Control gadget to the supervisor desktop, look for the following under the <role>Supervisor</role> tag and within the <page></page> tag:
Step 15  Remove the comments and comment characters (<!-- and -->) that surround the tab.
Step 16  Replace my-socialminer-server in the gadget URL with the fully-qualified domain name (FQDN) of your SocialMiner server.
Step 17  Optionally, change the height of the Manage Chats gadget.
Step 18  Click Save.

Add Web Chat to a Custom Desktop Layout

Procedure

Step 1  In the Finesse administration console, click the Desktop Layout tab.
Step 2  Click Finesse Default Layout XML to show the default layout XML.
Step 3  Copy the XML code for the Chat Control gadget for the agent desktop.
    <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
Step 4  To add the gadget to the agent desktop, paste the code within the <page></page> tags under the Call Control gadget as follows:
    <role>Agent</role>
    <page>
        <gadget>/desktop/gadgets/CallControl.jsp</gadget>
        <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
    </page>
Step 5  To add the gadget to the supervisor desktop, paste the code within the <page></page> tags under the Call Control gadget as follows:
    <role>Supervisor</role>
    <page>
        <gadget>/desktop/gadgets/CallControl.jsp</gadget>
        <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
    </page>
Step 6  Copy the code for the agent Manage Chats tab and gadget from the default layout XML.
    <tab>
        <id>manageChats</id>
        <label>finesse.container.tabs.agent.manageChatsLabel</label>
        <gadgets>
            <gadget>https://my-socialminer-server/multisession/ui/gadgets/multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
        </gadgets>
    </tab>
Step 7  Paste the code within the <tabs></tabs> tag for the agent role after the Manage Call tab:
    <tab>
        <id>manageCall</id>
        <label>finesse.container.tabs.agent.manageCallLabel</label>
    </tab>
    <tab>
        <id>manageChats</id>
        <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
        <gadgets>
            <gadget>https://my-socialminer-server/multisession/ui/gadgets/
Step 8  Replace my-social-miner-server with the FQDN of your Social Miner server.

Step 9  Optionally, change the height of the Manage Chats gadget.

Example:
The height specified in the gadget URL is 430 pixels. If you want to change the height, change the gadgetHeight parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change the code as follows:

```
<gadget>https://my-social-miner-server/multisession/ui/gadgets/
    multisession-reply-gadget.jsp?gadgetHeight=600</gadget>
```

The default and minimum height of the Manage Chats gadget is 430 pixels. If you do not specify a value for the gadgetHeight parameter or if you specify a value that is less than 430, the gadget defaults to 430 pixels.

Step 10  Copy the code for the Live Data gadgets for Agent Chat Statistics and Chat Queue Statistics from the default layout XML.

```
<gadget>https://localhost:8444/cuic/gadget/LiveData/
    LiveDataGadget.jsp?gadgetHeight=310&
    viewId=F2F1FC171000014400000014E0A4E5D48&
    filterId=ChatAgentStats.agentId=CL</gadget>
<gadget>https://localhost:8444/cuic/gadget/LiveData/
    LiveDataGadget.jsp?gadgetHeight=310&
    viewId=E42ED788100001440000007B0A4E5CA1&
    filterId=ChatQueueStatistics.queueName=CL</gadget>
```

Step 11  Paste the code for these gadgets within the `<gadgets>` tags for the tabs on which you want them to appear.

Step 12  Copy the code for the supervisor Manage Chats tab and gadget from the default layout XML.

```
<tab><id>manageChats</id>
    <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
    <gadgets>
        <gadget>https://my-social-miner-server/multisession/ui/gadgets/
            multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
    </gadgets>
</tab>
```

Step 13  Paste the code within the `<tabs>` tag for the supervisor role after the Manage Call tab:

```
<tab><id>manageCall</id>
    <label>finesse.container.tabs.supervisor.manageCallLabel</label>
</tab>
<tab><id>manageChats</id>
    <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
    <gadgets>
        <gadget>https://my-social-miner-server/multisession/ui/gadgets/
            multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
    </gadgets>
</tab>
```
**Add Web Chat to a Team Layout**

**Procedure**

**Step 1** In the Finesse administration console, click the Desktop Layout tab.

**Step 2** Click Finesse Default Layout XML to show the default layout XML.

**Step 3** Copy the XML code for the Chat Control gadget for the agent desktop and paste it into a text file.

```xml
<gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
```

**Step 4** Copy the code for the agent Manage Chats tab and gadget and paste it into your text file.

```xml
<tab>
  <id>manageChats</id>
  <label>finesse.container.tabs.agent.manageChatsLabel</label>
  <gadgets>
    <gadget>https://my-socialminer-server/multisession/ui/gadgets/multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
  </gadgets>
</tab>
```

**Step 5** Copy the code for the Live Data gadgets for Agent Chat Statistics and Chat Queue Statistics and paste it into your text file.

```xml
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&viewId=F2F1FC17100001440000014E0A4E5D48&filterId=ChatAgentStats.agentId=CL</gadget>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&viewId=E42ED78100001440000007B0A4E5CA1&filterId=ChatQueueStatistics.queueName=CL</gadget>
```

**Step 6** Copy the code for the supervisor Manage Chats tab and gadget and paste it into your text file.

```xml
<tab>
  <id>manageChats</id>
  <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
  <gadgets>
    <gadget>https://my-socialminer-server/multisession/ui/gadgets/multisession-reply-gadget.jsp?gadgetHeight=430</gadget>
  </gadgets>
</tab>
```
Step 7  Click the **Team Resources** tab.

Step 8  Select the team from the list of teams for which you want to add Web Chat.

Step 9  Check the **Override System Default** check box.

Step 10  In the Resources for `<team name>` area, click the **Desktop Layout** tab.

Step 11  To add the Chat Control gadget to the agent desktop, copy the code for the gadget from your text file and paste it within the `<page>` tags under the Call Control gadget as follows:

```xml
<role>Agent</role>
<page>
  <gadget>/desktop/gadgets/CallControl.jsp</gadget>
  <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
</page>
```

Step 12  To add the gadget to the supervisor desktop, paste the code within the `<page>` tags under the Call Control gadget as follows:

```xml
<role>Supervisor</role>
<page>
  <gadget>/desktop/gadgets/CallControl.jsp</gadget>
  <gadget>https://localhost/agentdesktop/gadgets/chatControl.xml</gadget>
</page>
```

Step 13  To add the Manage Chats tab and gadget to the agent desktop, copy the code from your text file and paste it within the `<tabs>` tag for the agent role after the Manage Call tab:

```xml
<tab>
  <id>manageCall</id>
  <label>finesse.container.tabs.agent.manageCallLabel</label>
</tab>
<tab>
  <id>manageChats</id>
  <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
  <gadgets>
  </gadgets>
</tab>
```

Step 14  Replace `my-social-miner-server` with the FQDN of your SocialMiner server.

Step 15  Optionally, change the height of the Manage Chats gadget.

**Example:**

The height specified in the gadget URL is 430 pixels. If you want to change the height, change the `gadgetHeight` parameter in the URL to the desired value. For example if you want the gadget height to be 600 pixels, change the code as follows:

```xml
<gadget>https://my-socialminер-server/multisession/ui/gadgets/multisession-reply-gadget.jsp?gadgetHeight=600</gadget>
```

The default and minimum height of the Manage Chats gadget is 430 pixels. If you do not specify a value for the `gadgetHeight` parameter or if you specify a value that is less than 430, the gadget defaults to 430 pixels.

Step 16  To add the Live Data gadgets for Web Chat to the supervisor desktop:

a) Copy the code for the Agent Chat Statistics Live Data gadget from your text file and paste it within the `<gadgets>` tags for the tab on which you want it to appear.
b) Copy the code for the Chat Queue Statistics Live Data gadget from your text file and paste it within the `<gadgets></gadgets>` tags for the tab on which you want it to appear.

**Step 17** To add the Manage Chats tab gadget to the supervisor desktop, copy the code from your text file and paste it within the `<tabs></tabs>` tag for the supervisor role after the Manage Call tab:

```xml
<tab>
  <id>manageCall</id>
  <label>finesse.container.tabs.supervisor.manageCallLabel</label>
</tab>
<tab>
  <id>manageChats</id>
  <label>finesse.container.tabs.supervisor.manageChatsLabel</label>
  <gadgets>
  </gadgets>
</tab>
```

**Step 18** Replace `my-social-miner-server` with the FQDN of your SocialMiner server.

**Step 19** Optionally, change the height of the gadget.

**Step 20** Click Save.

---

**Live Data Gadgets**

Cisco Finesse for Unified CCX supports Live Data gadgets. Live Data gadgets display information about the current state of the contact center. The gadgets receive data from the real-time data source at frequent intervals and display reports in grid format only.

Cisco Unified Intelligence Center provides Live Data real-time reports that you can add to the Cisco Finesse agent and supervisor desktop.

This feature provides the following access:

- Agents can access the Live Data agent reports.
- Supervisors can access the Live Data supervisor reports.

**Gadgets URLs for Reports**

The following table displays gadgets URLs for reports.
<table>
<thead>
<tr>
<th>Users</th>
<th>Reports</th>
<th>Report View</th>
<th>Is the Report Available in Default Layout?</th>
<th>Tab</th>
<th>Gadget URLs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>Agent CSQ Statistics Report</td>
<td>Agent CSQ Statistics Report</td>
<td>Yes</td>
<td>Home</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=76D964AD100001400000000830A4E5E6F&amp;filterId=AgentCSQStats.csqName=CL&amp;compositeFilterId=AgentCSQStats.AgentIds.agentId/loginId&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Agent</td>
<td>Agent Team Summary Report</td>
<td>Agent Team Summary Report</td>
<td>Yes</td>
<td>Home</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=5C626F9C10000140000000600A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Supervisor</td>
<td>Agent Outbound Team Summary Report</td>
<td>Report since midnight</td>
<td>No</td>
<td>Team Data</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=FD919FB91000014400000005D0A4E5B29&amp;filterId=ResourceIAQStats.resourceId=CL&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Supervisor</td>
<td>Agent Outbound Team Summary Report</td>
<td>Short and long term average</td>
<td>No</td>
<td>Team Data</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=FD919FB510000144000000470A4E5B29&amp;filterId=ResourceIAQStats.resourceId=CL&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Supervisor</td>
<td>Chat Agent Statistics Report</td>
<td>Chat Agent Statistics Report</td>
<td>No</td>
<td>Team Data</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=120&amp;viewId=P2F1FC17100001440000014E04A4E5D48&amp;filterId=ChatAgentStats.agentId=CL&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Supervisor</td>
<td>Chat CSQ Summary Report</td>
<td>Chat CSQ Summary Report</td>
<td>No</td>
<td>Queue Data</td>
<td><code>&lt;gadget&gt;https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=120&amp;viewId=E42ED788100001440000007B0A4E5CA1&amp;filterId=ChatQueueStatistics.queueName=CL&lt;/gadget&gt;</code></td>
</tr>
<tr>
<td>Supervisor</td>
<td></td>
<td></td>
<td></td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Users</td>
<td>Reports</td>
<td>Report View</td>
<td>Is the Report Available in Default Layout?</td>
<td>Tab</td>
<td>Gadget URLs</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------</td>
<td>------------------------------</td>
<td>------------------------------------------</td>
<td>-----------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Team State</td>
<td>Team State Report</td>
<td>Team State Report</td>
<td>—</td>
<td>Report</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=5C90012F10000140000000830A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=5C90012F10000140000000830A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL</a>&lt;/gadget&gt;</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Team Summary Report</td>
<td>Report since midnight</td>
<td>Yes</td>
<td>Team Data</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=728283C21000014000000530A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=728283C21000014000000530A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL</a>&lt;/gadget&gt;</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Team Summary Report</td>
<td>Short and long term average</td>
<td>Yes</td>
<td>Team Data</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=7291DCB41000014000000B90A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=7291DCB41000014000000B90A4E5B33&amp;filterId=ResourceIAQStats.resourceId=CL</a>&lt;/gadget&gt;</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Voice CSQ Summary</td>
<td>Snapshot</td>
<td>Yes</td>
<td>Queue Data</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8E2DB161000014000000690A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8E2DB161000014000000690A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL</a>&lt;/gadget&gt;</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Voice CSQ Summary</td>
<td>Short and long term average</td>
<td>Yes</td>
<td>Queue Data</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8EE241900014000000C30A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8EE241900014000000C30A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL</a>&lt;/gadget&gt;</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Voice CSQ Summary</td>
<td>Report since midnight</td>
<td>No</td>
<td>Queue Data</td>
<td>&lt;gadget&gt;<a href="https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8EF5108100014000000EB0A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL">https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&amp;viewId=C8EF5108100014000000EB0A4E5E6B&amp;filterId=VoiceIAQStats.esdName=CL</a>&lt;/gadget&gt;</td>
</tr>
</tbody>
</table>

**Gadgets Customization**

You can use optional query parameter to adjust height of the gadgets.
**Add Live Data Gadgets to Desktop Layout**

The Cisco Finesse default layout XML contains commented XML code for the Live Data gadgets available for Cisco Finesse desktop. Perform the following steps to add Live Data gadgets to desktop layout:

**Procedure**

**Step 1** Sign in to Cisco Finesse administration console. Cisco Finesse home page appears.

**Step 2** Click the **Desktop Layout** tab.

**Step 3** Click **Finesse Default Layout XML** to show the default layout XML.

**Step 4** Copy the gadget URL for the report you want to add from Table 1.

**Example:**
To add the Agent Report, copy the following:

```xml
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=112&viewId=67d437111000140000001080a4e5e6b&filterId=ResourceIAQStats.resourceId=loginId</gadget>
```

**Step 5** Paste the gadget URL within the tab tags where you want it to appear.

**Example:**
To add the report to the home tab of the agent desktop:

```xml
<finesseLayout xmlns="http://www.cisco.com/vtg/finesse">
  <layout>
    <role>Agent</role>
    <page>
      <gadget>/desktop/gadgets/CallControl.jsp</gadget>
    </page>
    <tabs>
      <tab>
        <id>home</id>
        <label>finesse.container.tabs.agent.homeLabel</label>
        <gadgets>
          <gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&viewId=67d437111000140000001080a4e5e6b&filterId=AgentCSQStats.csqName=CL&compositeFilterId=AgentCSQStats.AgentIds.agentId=loginId</gadget>
          <gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&viewId=5c626f9c10001400000060a4e5e6b&filterId=ResourceIAQStats.resourceId=CL</gadget>
        </gadgets>
      </tab>
      <tab>
        <id>myStatistics</id>
        <label>finesse.container.tabs.agent.myStatisticsLabel</label>
        <gadgets>
          <gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=600&viewId=5d411e8a100014000000230a4e5e6b&filterId=AgentStateDetailStats.agentID=loginId</gadget>
        </gadgets>
      </tab>
      <tab>
        <id>manageCall</id>
        <label>finesse.container.tabs.agent.manageCallLabel</label>
      </tab>
    </tabs>
  </layout>
</finesseLayout>
```
Step 6 Click Save. Cisco Finesse validates the XML file to ensure that it is valid XML syntax and conforms to the Cisco Finesse schema.

Step 7 To verify, log in to Cisco Finesse agent desktop as agent/Cisco Finesse supervisor desktop as supervisor and check the reports.

Add Customized Live Data Gadgets to Desktop Layout

This procedure explains how to create gadget URLs for customized Live Data reports, which are copied from stock reports, and add them to desktop layout.

Note
The new gadget renders the report only when the appropriate permission on that report is given in Cisco Unified Intelligence Center.

Procedure

Step 1 Copy the gadget URL of the stock report that you want to customize from Table 1 and paste it in a text editor.

Example:
Consider the URL shown here as the gadget URL. Copy and paste it in a text editor. The underlined ID is the value of viewID.

```
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&gadgetId=gadgetId&filterId=ResourceIAQStats.resourceId=CL</gadget>
```

Step 2 In Cisco Unified Intelligence Center, in the Edit view of the customized report, select the view for which you want to create the gadget URL and then click Links. The HTML Link field displays the permalink of the customized report.

Step 3 Copy the permalink of the customized report from the HTML Link field and paste it in a text editor, then copy the viewID value from this link.

Example:
Copy the underlined viewID value from the permalink of the customized report.

```
https://<Server Name>:8444/cuic/permalink/PermalinkViewer.htm?viewId=5C90012F1000014000000830A4E5B33&linkType=htmlType&viewType=Grid
```

Step 4 Replace the viewID value in the gadget URL with the viewID value from the permalink of the customized report.

Example:
The customized gadget URL appears as shown here after replacing the viewID value with the viewID value
of the customized report.

<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310
&viewId=5C90012F10000140000000830A4E5B33&filterId=ResourceIAQStats.resourceId=CL</gadget>

---

**Step 5**
Add the customized gadget URL to Desktop Layout in the Finesse administration console and save.

**Step 6**
Log in to Finesse desktop and check the report.

---

### Manage Phone Books

On the Phone Books tab of the Cisco Finesse administration console, you can create and manage global and
team phone books and phone book contacts. Global phone books are available to all agents; team phone books
are available to agents in that specific team.

### Phone Books and Contacts

Finesse supports the following number of phone books:

- 10 global phone books
- 50 team phone books

The system supports a total of 1500 contacts.

Use the Manage Phone Books gadget to view, add, edit, or delete phone books and phone book contacts. Click
the Name or Assign To headers to sort the phone books in ascending or descending order. Click the last Name,
First Name, Number, or Note headers to sort the contacts in ascending or descending order.

The following table describes the fields on the Manage Phone Books gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| Name       | The name of the phone book. The name must be unique, and can be a maximum length of 64 alphanumeric characters. The following characters are not supported: & < > " 
| Assign To  | Indicates if the phone book is global (All Users) or team (Teams). |
| Last Name  | The last name of a contact. The last name can be a maximum length of 128 characters. This field is optional. |
| First Name | The first name of a contact. The first name can be a maximum length of 128 characters. This field is optional. |
| Number     | The phone number for the contact. The phone number can be 1-32 characters long and cannot be blank. |
| Note       | Optional text that describes the contact. The note can be a maximum length of 128 characters. |
Actions on the Manage Phone Books gadget:

- **New**: Add a new phone book or contact
- **Edit**: Edit an existing phone book or contact
- **Delete**: Delete a phone book or contact
- **Refresh**: Reload the list of phone books or contacts from the server
- **Import**: Import a list of contacts to the phone book
- **Export**: Export a list of contacts from the phone book

### Add Phone Book

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>In the Manage Phone Books gadget, click <strong>New</strong>. The New Phone Book area appears.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>In the Name box, enter a name for the phone book. <strong>Note</strong>: Phone book names can be a maximum length of 64 characters.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the Assign To box drop-down list, select <strong>All Users</strong> if the phone book is global or <strong>Teams</strong> if the phone book is available to specified teams.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

### Edit Phone Book

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>In the Manage Phone Books gadget, select the phone book you want to edit.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Click <strong>Edit</strong>. The Edit Phone Book area appears.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the Name field, enter the new name for the phone book. If you want to change who can access the phone book, in the Assign To field drop-down list, choose <strong>All Users</strong> or <strong>Teams</strong>.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>Click <strong>Save</strong>. If you change the Assign To field from Teams to All Users, a message appears that asks you to confirm the change. Click <strong>Yes</strong> to confirm.</td>
</tr>
</tbody>
</table>
Delete Phone Book

Procedure

Step 1 In the Manage Phone Books gadget, select the phone book that you want to delete.

Step 2 Click Delete. A question appears asking you to confirm that you want to delete the selected phone book.

Step 3 Click Yes to confirm the deletion of the selected phone book.

Import Contacts

The Import function allows you to replace all the contacts in a phone book with a new list of contacts, or to populate a new phone book with contacts.

The import list must be in the specified comma separated values (CSV) format, and can contain a maximum of 1500 contacts. Import lists that contain more than 1500 contacts are rejected with an error message.

The CSV file contains the fields described in the following table.

<table>
<thead>
<tr>
<th>Field</th>
<th>Max Length</th>
<th>Can Be Blank?</th>
<th>Permitted Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name</td>
<td>128</td>
<td>Yes</td>
<td>Alphanumeric characters</td>
</tr>
<tr>
<td>Last Name</td>
<td>128</td>
<td>Yes</td>
<td>The following characters are not supported: &amp; &lt; &gt; &quot; \ /</td>
</tr>
<tr>
<td>Phone Number</td>
<td>32</td>
<td>No</td>
<td>Note The CSV file that contains the contacts to import must use either Latin or UTF-8 encoding.</td>
</tr>
<tr>
<td>Notes</td>
<td>128</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

The following is an example of a phone book CSV file:

"First Name","Last Name","Phone Number","Notes"
"Amanda","Cohen","6511234",""
"Nicholas","Knight","612-555-1228","Sales"
"Natalie","Lambert","952-555-9876","Benefits"
"Joseph","Stonetree","651-555-7612","Manager"

A phone book CSV file must conform to this format and include the headers in the first line. During import, the file is scanned for illegal characters. If any are found, they are replaced with question marks.

Note

Exported CSV files always show each field enclosed in double quotes, as in the preceding example, to ensure that any commas or double quotes that are part of the actual filed data are not mistaken for field delimiters. If your data does not include these characters, you can omit the double quotes in files you prepare for importing.
**Procedure**

**Step 1** In the Manage Phone Books gadget, select the phone book into which you want to import a list of contacts.

**Step 2** Click **Import**.

The Import Contacts area appears.

**Step 3** Click **Browse** and navigate to the location of the CSV file containing the contacts you want to import.

*Note* The CSV file must use Latin or Unicode-8 encoding.

**Step 4** Click **OK**.

---

**Export Contacts**

The Export function allows you to extract a list of contacts from an existing phone book. The exported list is saved in CSV format.

**Procedure**

**Step 1** In the Manage Phone Books gadget, select the phone book that contains the contacts you want to export.

**Step 2** Click **Export**.

A message is displayed asking if you want to open or save the file.

*Note* The default name for an export file is **PhoneBookContacts.csv**.

**Step 3** Click **Open** to open the CSV file in Excel, or click the **Save** drop-down list and choose **Save**, **Save as**, or **Save and open**, as desired.

**Step 4** A message appears that gives you the option to view the downloaded file, open the folder into which the download was saved, view the Internet Explorer View Downloads window, or dismiss the message without viewing the file.

---

**Add Contact**

**Procedure**

**Step 1** In the Manage Phone Books gadget, select the phone book to which you want to add a contact.

The List of Contacts for <phone book name> area appears.

**Step 2** Click **New**.
The New Contact area appears.

**Step 3** Complete the fields. The First Name, Last Name, and Note fields are optional and have a maximum length of 128 characters. The Number field is required and has a maximum length of 32 characters.

**Step 4** Click Save.

---

**Edit Contact**

**Procedure**

**Step 1** In the Manage Phone Books gadget, select the phone book that contains the contact you want to edit. The List of Contacts for <phone book name> area appears.

**Step 2** Select the contact you want to edit.

**Step 3** Click Edit. The Edit Contact area appears.

**Step 4** Edit the fields that you want to change. The First Name, Last Name, and Note fields are optional and have a maximum length of 128 characters. The Number field is required and has a maximum length of 32 characters.

**Step 5** Click Save.

---

**Delete Contact**

**Procedure**

**Step 1** In the Manage Phone Books gadget, select the phone book that contains the contact you want to delete. The List of Contacts for <phone book name> area appears.

**Step 2** Select the contact that you want to delete.

**Step 3** Click Delete. A question appears asking you to confirm that you want to delete the selected contact.

**Step 4** Click Yes to confirm the deletion of the selected contact.

---

**Manage Reasons**

The Reasons tab on the Cisco Finesse administration console allows you to view, add, edit, and delete Not Ready reason codes, Sign Out reason codes, and Wrap-Up reasons.
Certain reason codes are reserved and cannot be used.
For Unified CCX systems, these reserved reason codes are as follows: 0, 22, and 33.

**Not Ready Reason Codes**

Not Ready reason codes represent reasons that agents can select when they change their state to Not Ready. Use the Manage Reason Codes (Not Ready) gadget to view, add, edit, or delete Not Ready reason codes. Click the Reason Label or Reason Code headers to sort the Not Ready reason codes by label or reason code in ascending or descending order. Click the Global header to sort reason codes by whether they are global (Yes) or not (No).

Not Ready reason codes can be global (visible to all agents) or team (visible only to agents on specified teams).

**Note**
Finesse supports a maximum of 100 global and 100 team Not Ready reason codes.

The following table describes the fields on the Manage Reason Codes (Not Ready) gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reason Label</td>
<td>The label for the Not Ready reason code. The label has a maximum length of 40 characters and should be unique for each Not Ready reason code. Both alphanumeric and special characters are supported.</td>
</tr>
<tr>
<td>Reason Code</td>
<td>A code for the Not Ready reason. The value of the code must be between 1 and 999 and must be unique.</td>
</tr>
<tr>
<td>Global?</td>
<td>Yes/No. Indicates if the reason code is available globally to all agents (Yes) or to specific teams of agents (No).</td>
</tr>
</tbody>
</table>

**Note**
In previous releases, Finesse did allow you to create multiple Not Ready reason codes with the same code or with code values greater than 999. If you upgraded from a previous release, you may have Not Ready reason codes in your database that violate the new rules. After you complete the upgrade, find the codes and edit them to give them unique values within the supported range. You can find the codes by clicking on the Reason Code header to sort the codes by their value.

**Actions on the Manage Reason Codes (Not Ready) gadget:**

- **New**: Add a new Not Ready reason code
- **Edit**: Edit an existing Not Ready reason code
- **Delete**: Delete a Not Ready reason code
- **Refresh**: Reload the list of Not Ready reason codes from the server
When you add, edit, or delete a Not Ready reason code, the changes you make take effect on the Finesse desktop after three seconds. However, agents who are signed in when the changes are made must sign out and sign back in to see those changes reflected on their desktops.

When an agent signs in to the Finesse desktop, the agent state is set to Not Ready. The agent can then choose to go to Ready status or choose from one of the configured Not Ready reason codes from the agent state drop-down list.

If an agent wants to change from Ready to Not Ready status, that agent can choose the appropriate Not Ready reason code from the list of configured codes.

An agent who is on a call can select a state to be applied when the call is complete. For example, if an agent wants to be in Not Ready state when the call ends, that agent can choose Not Ready from the drop-down list while still on the call. The Finesse desktop shows the agent in Talking state and a pending state of Not Ready. Pending state changes appear on the desktop while the agent's state is Talking (for example, on hold, in a consult call, conference, or silent monitor call).

Add Not Ready Reason Code

Perform the following procedure to add a new Not Ready reason code.

Procedure

Step 1  In the Manage Reason Codes (Not Ready) gadget, click New.
The New Reason Code area appears.

Step 2  In the Reason Label box, enter a label for the reason code.
Note  Not Ready reason code labels are limited to 40 characters.

Step 3  In the Reason Code box, enter a reason code.
Note  The code must be between 1 and 999 and must be unique.

Ensure there are no leading or trailing spaces.

Step 4  If the reason code is global, select the Global? check box. If the reason code is specific to a team, clear the Global? check box.
Note  By default, the Global? check box is selected.

Step 5  Click Save.
Note  The Finesse server removes leading or trailing spaces before saving the Reason Label in the database.

Edit Not Ready Reason Code

Perform the following procedure to edit the label or code for an existing Not Ready reason code.
Procedure

Step 1  In the Manage Reason Codes (Not Ready) gadget, select the reason code that you want to edit.

Step 2  Click **Edit**.

The Edit Reason Code area appears.

Step 3  If you want to change the label for the Not Ready reason code, in the Reason Label field, enter a new label for the reason code. If you want to change the code, in the Reason Code field, enter the new code. If you want to change who has access to the code, select or clear the Global? check box.

Step 4  Click **Save**.

Delete Not Ready Reason Code

*Note*  An error may occur if an agent selects a Not Ready reason code after it has been deleted. Agents who are signed in when you make changes to Not Ready reason codes must sign out and sign back in to see those changes reflected on their desktops.

Perform the following procedure to delete a Not Ready reason code.

Procedure

Step 1  In the Manage Reason Codes (Not Ready) gadget, select the Not Ready reason code that you want to delete.

Step 2  Click **Delete**.

A question appears asking you to confirm that you want to delete the selected reason code.

Step 3  Click **Yes** to confirm the deletion of the selected reason code.

Sign Out Reason Codes

Sign Out reason codes represent reasons that agents can select when they sign out of the Finesse desktop.

Use the Manage Reason Codes (Sign Out) gadget to view, add, edit, or delete Sign Out reason codes. Click the Reason Label or Reason Code headers to sort the Sign Out reason codes by label or by reason code, in ascending or descending order. Click the Global header to sort the reason codes by whether they are global (Yes) or not (No).

Sign Out reason codes can be global (visible to all agents) or team (visible only to agents on specified teams).

*Note*  Finesse supports a maximum of 100 global and 100 team Sign Out reason codes.

The following table describes the fields on the Manage Reason Codes (Sign Out) gadget.
Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reason Label</td>
<td>The label for the Sign Out reason code.</td>
</tr>
<tr>
<td></td>
<td>The label has a maximum length of 40 characters and should be unique for each Sign Out reason code. Both alphanumeric and special characters are supported.</td>
</tr>
<tr>
<td>Reason Code</td>
<td>A code for the Sign Out reason.</td>
</tr>
<tr>
<td></td>
<td>The code must be between 1 and 999 and must be unique.</td>
</tr>
<tr>
<td>Global?</td>
<td>Yes/No. Indicates if the reason code is available globally to all agents (Yes) or to specific teams of agents (No).</td>
</tr>
</tbody>
</table>

Note
In previous releases, Finesse did allow you to create multiple Sign Out reason codes with the same code or with code values greater than 999. If you upgraded from a previous release, you may have Sign Out reason codes in your database that violate the new rules. After you complete the upgrade, find the codes and edit them to give them unique values within the supported range. You can find the codes by clicking on the Reason Code header to sort the codes by their value.

Actions on the Manage Reason Codes (Sign Out) gadget:

- **New**: Add a new Sign Out reason code
- **Edit**: Edit an existing Sign Out reason code
- **Delete**: Delete a Sign Out reason code
- **Refresh**: Reload the list of Sign Out reason codes from the server

Note
When you add, edit, or delete a Sign Out reason code, the changes you make take effect on the Finesse desktop after three seconds. However, agents who are signed in when the changes are made must sign out and sign back in to see those changes reflected on their desktops.

When an agent clicks Sign Out on the desktop, any configured Sign Out codes appear in a drop-down list. The agent can then choose the code that represents why that agent is signing out.

Add Sign Out Reason Code

Perform the following procedure to add a new Sign Out reason code.

Procedure

**Step 1** In the Manager Reason Codes (Sign Out) gadget, click **New**.

The New Reason Code area appears.

**Step 2** In the Reason Label box, enter a label for the reason code.

Note
Sign Out reason code labels are limited to 40 characters.
Step 3  In the Reason Code box, enter a reason code.
   Note  The code must be between 1 and 999 and must be unique.
   Ensure there are no leading or trailing spaces.

Step 4  If the reason code is global, select the Global? check box. If the reason code is specific to a team, clear the Global? check box.
   Note  By default, the Global? check box is selected.

Step 5  Click Save.

Edit Sign Out Reason Code

Perform the following procedure to edit the label or code for an existing Sign Out reason code.

Procedure

Step 1  In the Manage Reason Codes (Sign Out) gadget, select the reason code that you want to edit.
Step 2  Click Edit.
   The Edit Reason Code area appears.
Step 3  If you want to change the label of the Sign Out reason code, in the Reason Label field, enter a new label for the reason code. If you want to change the code, in the Reason Code field, enter the new code. If you want to change who has access to the code, select or clear the Global? check box.
Step 4  Click Save.

Delete Sign Out Reason Code

Note  An error may occur if an agent selects a Sign Out reason code after it has been deleted. Agents who are signed in when you make changes to Sign Out reason codes must sign out and sign back in to see those changes reflected on their desktops.

Perform the following procedure to delete a Sign Out reason code.

Procedure

Step 1  In the Manage Reason Codes (Sign Out) gadget, select the Sign Out reason code that you want to delete.
Step 2  Click Delete.
   A question appears asking you to confirm that you want to delete the selected reason code.
Step 3  Click Yes to confirm the deletion of the selected Sign Out reason code.
Wrap-Up Reasons

Wrap-Up reasons represent the reasons that agents can apply to calls. A Wrap-Up reason indicates why a customer called the contact center. For example, you may have one Wrap-Up reason for sales calls and another for support calls.

You can configure Wrap-Up reasons to be available globally to all agents or only to specific teams.

Use the Manage Wrap-Up Reasons gadget to view, add, edit, or delete Wrap-Up reasons. Click the Reason Label header to sort the Wrap-Up reasons in ascending or descending order.

| Note | Finesse supports a maximum of 100 global and 100 team Wrap-Up reasons. |

| Note | If an agent is configured for wrap-up and selects a pending state during a call, when the call finishes that agent goes into wrap-up and not the pending state selected during the call. The agent can end wrap-up by either selecting a new state (Ready or Not Ready) or letting the wrap-up timer expire. If the agent selects a new state, the new state overrides the pending state selected during the call. If the wrap-up timer expires, the agent transitions to the pending state. |

The following table describes the fields on the Manage Wrap-Up Reasons gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reason Label</td>
<td>The label for the Wrap-Up reason. This label must be unique for each Wrap-Up reason and has a maximum length of 39 bytes (which equals 39 US English characters). Both alphanumeric and special characters are supported.</td>
</tr>
<tr>
<td>Global?</td>
<td>Yes/No. Indicates if the Wrap-Up reason is available globally to all agents (Yes) or to specific teams of agents (No).</td>
</tr>
</tbody>
</table>

Actions on the Manage Wrap-Up Reasons gadget:

- **New**: Add a new Wrap-Up reason
- **Edit**: Edit an existing Wrap-Up reason
- **Delete**: Delete a Wrap-Up reason
- **Refresh**: Reload the list of Wrap-Up reasons from the server

| Note | When you add, edit, or delete a Wrap-Up reason, the changes you make take effect on the agent or supervisor desktop after three seconds. However, agents who are signed in when the changes are made must sign out and sign back in to see those changes reflected on their desktops. |
Add Wrap-Up Reason

Perform the following procedure to add a new Wrap-Up reason.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Manage Wrap-Up Reasons gadget, click <strong>New</strong>. The New Wrap-Up Reason area appears.</td>
</tr>
<tr>
<td>2</td>
<td>In the Reason Label field, add a label for the Wrap-Up reason. <strong>Note</strong>: Wrap-Up reason labels are limited to 39 bytes.</td>
</tr>
<tr>
<td>3</td>
<td>If the Wrap-Up reason is global, select the Global? check box. If the Wrap-Up reason is specific to a team, clear the Global? check box. <strong>Note</strong>: By default, the Global? check box is selected.</td>
</tr>
<tr>
<td>4</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Edit Wrap-Up Reason

Perform the following procedure to edit an existing Wrap-Up reason.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Manage Wrap-Up Reasons gadget, select the Wrap-Up reason that you want to edit.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>Edit</strong>. The Edit Wrap-Up Reason area appears.</td>
</tr>
<tr>
<td>3</td>
<td>In the Wrap-Up Reason Label field, enter the new label for the Wrap-Up reason. If you want to change who has access to the Wrap-Up reason, select or clear the Global? check box.</td>
</tr>
<tr>
<td>4</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Delete Wrap-Up Reason

Perform the following procedure to delete a Wrap-Up reason.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Manage Wrap-Up Reasons gadget, select the Wrap-Up reason that you want to delete.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>Delete</strong>.</td>
</tr>
</tbody>
</table>
A question appears asking you to confirm that you want to delete the selected Wrap-Up reason.

**Step 3**  Click **Yes** to confirm the deletion of the selected Wrap-Up reason.

---

## Manage Team Resources

You can assign phone books, reason codes, wrap-up reasons, custom desktop layouts, and workflows to teams on the Team Resources tab of the administration console.

### Team Resources

Use the Manage Team Resources gadget on the Team Resources tab of the Cisco Finesse administration console to assign and unassign phone books, reasons, custom desktop layouts, and workflows to teams. Click the Name or ID header to sort the teams in ascending or descending order.

The Manage Team Resources gadget contains six tabs, each enabling you to assign or unassign resources to a team. The tabs are defined in the following table.

<table>
<thead>
<tr>
<th>Tab Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop Layout</td>
<td>Use this tab to customize the desktop layout for the team. The default layout is defined in the Manage Desktop Layout gadget. You can define one custom layout for the team.</td>
</tr>
<tr>
<td>Phone Books</td>
<td>Use this tab to assign/unassign phone books to the team. Only phone books that are defined in the Manage Phone Books gadget as available to teams are available for assignment.</td>
</tr>
<tr>
<td>Reason Codes (Not Ready)</td>
<td>Use this tab to assign/unassign Not Ready reason codes to the team. Only Not Ready reason codes that are defined in the Manage Reason Codes (Not Ready) gadget as available to teams (not global) are available for assignment.</td>
</tr>
</tbody>
</table>
## Tab Name | Description
--- | ---
Reason Codes (Sign Out) | Use this tab to assign/unassign Sign Out reason codes to the team. Only Sign Out reason codes that are defined in the Manage Reason Codes (Sign Out) gadget as available to teams (not global) are available for assignment.
Wrap-Up Reasons | Use this tab to assign/unassign Wrap-Up reasons to the team. Only Wrap-Up reasons that are defined in the Manage Wrap-Up Reasons gadget as available to teams (not global) are available for assignment.
Workflows | Use this tab to assign/unassign workflows to the team. Only workflows that are defined in the Manage Workflows gadget are available for assignment.

### Actions on the Manage Team Resources gadget:
- **Add**: Assign a phone book, reason, or workflow to the team
- **Save**: Save the phone book, reason, desktop layout assignment, or workflow to the team
- **Revert**: Cancel any changes made before they are saved
- **Refresh**: Refresh the list of teams

**Note**
If you select a team and then click Refresh, the team is de-selected and the Resources area for that team disappears. The list of teams is refreshed and you must select a team again.

### Assign Phone Books and Reasons to Team

**Procedure**

**Step 1**
In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

**Step 2**
Click the tab for the resource you want to assign for the selected team.
The List of <resource> area appears.

**Step 3**
Click **Add**.
The Add <resource> popup appears.

**Step 4**
Select one or more resources from the list to assign them to the team.
Resources you assign are highlighted in blue in the Add <resources> popup and added to the List of <resources> area.

**Step 5**
When you has finished assigning resources, click **Save**.

**Note**
You can make changes on all resource tabs and then save them at the same time. If there is an error on one resource tab but not others, the changes on the tabs with no errors are saved while the changes on the tab with errors are not saved.
Unassign Phone Books and Reasons from Team

**Procedure**

**Step 1** In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

**Step 2** Click the tab for the resource you want to unassign from the selected team.
The List of `<resource>` area appears.

**Step 3** Click the red X next to the resource you want to unassign.

**Step 4** Click **Save**.

Assign Custom Desktop Layout to Team

Perform the following procedure to create and assign a custom desktop layout to a team.

**Procedure**

**Step 1** In the Manage Team Resources gadget, select a team.
Tabs for each available resource appear.

**Step 2** Click the Desktop Layout tab.
The Desktop Layout XML area appears. The area contains the default desktop layout XML.

**Step 3** Select the Override System Default check box.
The XML becomes editable.

**Step 4** Edit the XML as desired.

**Step 5** Click **Save**.
The custom desktop layout replaces the default desktop layout for the team after 10 seconds. If a supervisor or agent is signed in when the change is saved, the change does not go into effect on their desktop until the supervisor or agent signs out and signs in again.

**Note** If you clear the Override System Default check box, any changes you made to the XML are lost and the XML in the editing pane reverts to the default desktop layout XML.
Assign Workflows to Team

**Procedure**

**Step 1** In the Manage Team Resources gadget, select a team. Tabs for each available resource appear.

**Step 2** Click the Workflows tab. The List of Workflows area appears.

**Step 3** Click **Add**. The Add Workflow popup appears.

**Step 4** Select one or more workflows from the list to assign them to the team. Workflows you assign are highlighted in blue in the Add Workflows popup and added to the List of Workflows area.

**Step 5** Workflows are executed in the order in which they are listed. Use the up and down arrows to move a selected workflow to the desired position in the list.

**Step 6** When you have finished assigning workflows, click **Save**.

**Note** You can make changes on all resource tabs and then save them at the same time. If there is an error on one resource tab but not others, the changes on the tabs with no errors are saved while the changes on the tab with errors are not saved.

Unassign Workflows from Team

**Procedure**

**Step 1** In the Manage Team Resources gadget, select a team. Tabs for each available resource appear.

**Step 2** Click the Workflows tab. The List of Workflows area appears.

**Step 3** Click the red X next to the workflow you want to unassign.

**Step 4** Click **Save**.

Manage Workflows

On the Workflows tab of the Cisco Finesse administration console, you can create and manage workflows and workflow actions.
## Workflows and Workflow Actions

You can use workflows to automate common repetitive agent tasks. A workflow has a unique name and a helpful description. Use the Manage Workflows and Manage Workflow Actions gadgets to view, add, edit, or delete workflows and workflow actions.

All workflows are team-level workflows. You cannot create a global workflow. If you need a global workflow, create a team workflow and assign it to all teams.

Finesse supports the following number of workflows and workflow actions:

- 100 workflows per Finesse system
- 100 actions per Finesse system
- 20 workflows per team
- 5 conditions per workflow
- 5 actions per workflow
- 5 variables per action

Click the column headers to sort workflows and workflow actions in ascending or descending order.

The following table describes the fields on the Manage Workflows gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the workflow. The name must be unique and can be a maximum</td>
</tr>
<tr>
<td></td>
<td>length of 40 characters.</td>
</tr>
<tr>
<td>Description</td>
<td>The description of the workflow. The description can be a maximum length of</td>
</tr>
<tr>
<td></td>
<td>128 characters.</td>
</tr>
</tbody>
</table>

The following table describes the fields on the Manage Workflow Actions gadget.

<table>
<thead>
<tr>
<th>Field</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the workflow action. The name must be unique and can be a</td>
</tr>
<tr>
<td></td>
<td>maximum length of 64 characters.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of workflow. Possible values are Browser Pop, HTTP Request.</td>
</tr>
</tbody>
</table>

**Actions on the Manage Workflows and Manage Workflow Actions gadgets:**

- **New**: Add a new workflow or workflow action
- **Edit**: Edit an workflow or workflow action
- **Delete**: Delete a workflow or workflow action
- **Refresh**: Reload the list of workflows or workflow actions from the server
You can configure workflow actions to be handled by the Finesse desktop or in a third-party gadget. A third-party gadget can be designed to handle the action differently than Finesse does.

Each workflow must contain only one trigger. Triggers are based on Finesse dialog events. Dialog events include the following:

- When a call arrives
- When a call is answered

Note: If you set a workflow to trigger when a call is answered, the workflow runs when an agent answers an incoming call or makes an outgoing call, or when a customer answers an Outbound Option call.

- When a call ends
- When making a call
- While previewing a Direct Preview Outbound call.

The workflow engine uses the following simple logic to determine whether to execute a workflow:

- To determine whether a workflow should execute, its trigger set and conditions are evaluated against each dialog event received.
- The workflow engine processes workflow events for the first call that matches any configured workflow's trigger set and conditions. No other workflows run until this call has ended. If the agent accepts a second call while still on the first call, workflows do not run on the second call even after the first call has ended.

Note: Outbound Preview calls are an exception to this rule. You can have a workflow run while the agent previews the call as well as when the agent accepts the call.

- After a workflow for a particular trigger type (for example, Call Arrives) executes, it never triggers again for the same dialog ID.

The workflow engine caches workflows for an agent when the agent signs in. Workflows do not change for the agent until the agent signs out and signs in again or refreshes the browser.

Note: Workflows that trigger when a call arrives, when a call is answered, or when making a call run whenever the browser is refreshed. When an agent refreshes the browser, the workflow engine sees the call as newly arrived or newly made. If an HTTP request action is part of the workflow, the HTTP request is sent when the agent refreshes the browser. Applications that receive the HTTP requests must account for this scenario. Otherwise, undesired results may occur.

An example of a workflow is a Call Arrival event that triggers an action that collects information from the dialog event (for example, the ANI or customer information) and displays a web page containing customer information.

You can filter trigger events by the value of the data that comes in the event. You can configure a workflow to execute if any conditions are met or if all conditions are met.
Individual conditions consist of the following:

- A piece of event data to be examined, for example, DNIS or call variables
- A comparison between the event data and entered values (for example, contains, is equal to, is not equal to, begins with, ends with, is empty, is not empty, and is in list)

When the trigger and its conditions are satisfied, a list of actions assigned to the workflow are executed. The actions execute in the order in which they are listed.

Workflows run only for agents and supervisors who are Finesse users. The Workflow Engine is a JavaScript library that runs client-side on a per-user basis within the Finesse desktop application. The desktop retrieves the workflows to execute for a user from the server when the user signs in or refreshes the browser.

Changes made to a workflow or its actions while a user is signed in are not automatically pushed to that user.

It is possible to set workflows, conditions, and actions that are contradictory so that a workflow or action cannot function. Workflows are not validated.

If multiple workflows are configured for a team, the Workflow Engine evaluates them in the configured order. The Workflow Engine ignores workflows with no actions. When the Workflow Engine finds a workflow with a matching trigger for the event and the workflow conditions evaluate to true, then that workflow is the one used and subsequent workflows in the list are not evaluated. Workflows with no conditions evaluate to true if the event matches the workflow trigger. All workflows are enabled by default. Only one workflow for a specific user can run at a time.

The Workflow Engine retrieves dialog-based variables used in workflow conditions from the dialog that triggered the workflow. If a variable is not found in the dialog, then its value is assumed to be empty.

The Workflow Engine executes the actions associated with the matched workflow in the order in which they are listed. The Workflow Engine executes actions in a workflow even if the previously executed action fails. Failed actions are logged.

The Finesse server controls which calls are displayed to the Finesse user. If the user has multiple calls, the workflow applies only to the first call that matches a trigger. If the first call displayed does not match any triggers but the second call does match a trigger, the Workflow Engine evaluates and processes the triggers for the second call.

A call is considered to be the first displayed call if it is the only call on the Finesse desktop when it appears. If two calls on a phone are merged (as they are in a conference call), then the first displayed call flag value of the surviving call is used.

If the user has a call when the user refreshes the browser, the Workflow Engine evaluates the call as it is. If the dialog data (call variable values) change, the data may not match the trigger and conditions of the original workflow. The data may match a different workflow or no workflows at all.

If the user has multiple calls when the user refreshes the browser, the Workflow Engine treats the first dialog received from the Finesse server as the first displayed call. This call is not necessarily the same call that was the first displayed call before the browser refresh. Dialogs received for any other call are ignored because they are not considered first displayed calls. If dialogs for more than one call are received before the Workflow Engine is loaded after the browser refresh, no dialogs are evaluated because none are considered first displayed calls.
Workflows run for both Finesse agents and supervisors. The team to which the supervisor belongs (as distinguished from the team that the supervisor manages) determines which workflows run for the supervisor. You may want to put the supervisors in their own team to keep agent workflows from being run for them.

Workflow Triggers and Outbound Calls

When you create a workflow specifically for Outbound Option calls, add a condition of BAStatus is not empty. This condition ensures that the workflow can distinguish Outbound Option calls from agent-initiated outbound calls.

The following table illustrates when workflows trigger in outbound call scenarios.

<table>
<thead>
<tr>
<th>Workflow Trigger</th>
<th>Direct Preview Outbound Call</th>
<th>Progressive or Predictive Outbound Call</th>
</tr>
</thead>
<tbody>
<tr>
<td>While previewing a call</td>
<td>When the agent previews the call (before the agent accepts or rejects the call).</td>
<td>Does not trigger.</td>
</tr>
<tr>
<td>When a call arrives</td>
<td>When the agent accepts the call.</td>
<td>Does not trigger.</td>
</tr>
<tr>
<td>When a call is answered</td>
<td>When the customer answers the call.</td>
<td>When the customer answers the call.</td>
</tr>
<tr>
<td></td>
<td>If the agent conferences in another agent or transfers the call, the workflow triggers for the agent who is the recipient of the conference or transfer.</td>
<td>If the agent conferences in another agent or transfers the call, the workflow triggers for the agent who is the recipient of the conference or transfer.</td>
</tr>
<tr>
<td>When a call is made</td>
<td>When the customer call is initiated.</td>
<td>When the customer call is initiated or when failover occurs during the call.</td>
</tr>
<tr>
<td>When a call ends</td>
<td>When the customer call ends.</td>
<td>When the customer call ends.</td>
</tr>
</tbody>
</table>

Add Browser Pop Workflow Action

The Browser Pop workflow action opens a browser window or tab on the user's desktop when workflow conditions are met.

Whether the action opens a new window or tab on the desktop depends on the target user's browser settings.
Procedure

Step 1 In the Manage Workflow Actions gadget, click New. The New Action area appears.

Step 2 In the Name box, enter a name for the action.
Note Workflow action names are limited to 64 characters.

Step 3 From the Type drop-down list, select Browser Pop.

Step 4 From the Handled By drop-down list, select what will execute the action, either the Finesse Desktop or Other (a third-party gadget).

Step 5 In the Window Name box, enter the name that serves as the ID of the window that is opened. Any action that uses this window name reuses that specific window.
Note Window names are limited to 40 characters, and can be blank. If you leave the window name blank, a new window opens every time the action runs.

Step 6 Enter the URL of the browser window to open, and then click the tag icon at the right of the box and select one or more variables from the drop-down list to add tags.

Example:
http://www.google.com/search?q=\text{callVariable1} & \text{callVariable2}

For every variable you select, you can enter test data in the Sample Data box. A sample URL is automatically built in the Browser URL box below the Sample Data area. To test the URL, click Open to open the URL in your browser.

Note Finesse does not validate the URL you enter.

Step 7 Click Save.

Add HTTP Request Workflow Action

The HTTP Request workflow action makes an HTTP request to an API on behalf of the desktop user.

Procedure

Step 1 In the Manage Workflow Actions area, click New. The New Action area appears.

Step 2 In the Name box, enter a name for the action.
A workflow action name can contain a maximum of 64 characters.

Step 3 From the Type drop-down list, select HTTP Request.

Step 4 From the Handled By drop-down list, select what will execute the action, the Finesse desktop or Other (a third-party gadget).

Step 5 From the Method drop-down list, select the method to use.
You can select either PUT or POST.

**Step 6** From the Location drop-down list, select the location. If you are making the HTTP request to a Finesse API, select **Finesse**. If you are making a request to any other API, select **Other**.

**Step 7** In the Content Type box, enter the content type. The default content type is application/xml, which is the content type for Finesse APIs. If you are using a different API, enter the content types for that API (for example, application/JSON).

**Step 8** In the URL box, enter the URL to which to make the request. To add variables to the URL, click the tag icon at the right of the box and select one or more variables from the drop-down list.

**Example:**

```
/finesse/api/User/7777777777777 dia
```

**Note** The preceding example is the URL for a Finesse API. If you want to make a request to another API, you must enter the entire URL (for example, http://googleapis.com). You can click the tag icon at the right of the box and select one or more variables from the drop-down list to add tags to the URL. In the preceding example, to add the dialogId, click the tag icon and select dialogId from the list.

**Step 9** In the Body box, enter the text for the request. The body must match the content type (for example, if the content types is application/xml, the body must contain XML. To add variables to the body, click the tag icon at the right of the box and select one or more variables from the drop-down list.

**Example:**

To make an HTTP request to the Dialog - Start a recording API, enter the following into the Body box:

```
<Dialog>
  <requestedAction>START_RECORDING</requestedAction>
  <targetMediaAddress>extension</targetMediaAddress>
</Dialog>
```

To add the extension, click the tag icon and select extension. For every variable you add, you can enter test data in the Sample Data box.

**Step 10** Click **Save**.

---

**Edit Workflow Action**

**Procedure**

**Step 1** In the Manage Workflow Actions gadget, select the action that you want to edit.

**Step 2** Click **Edit**.
The Edit Action area appears.

**Step 3** Edit the fields that you want to change.

**Step 4** Click Save.

---

**Delete Workflow Action**

**Procedure**

**Step 1** In the Workflow Actions gadget, select the action that you want to delete. The Delete Action area appears.

**Step 2** Click Delete. A question appears asking you to confirm that you want to delete the selected action.

**Step 3** Click Yes to confirm the deletion of the selected action.

---

**Add Workflow**

**Procedure**

**Step 1** In the Manage Workflows gadget, click New. The New Workflow area appears.

**Step 2** In the Name box, enter the name of the workflow. **Note** The name is limited to 40 characters.

**Step 3** In the Description box, enter a description of the workflow. **Note** The description is limited to 128 characters.

**Step 4** In the When to perform Actions drop-down list, select the event that triggers the workflow.

**Step 5** In the How to apply Conditions box, select if all conditions are met, or if any conditions are met, and then click Add Condition to add up to five conditions.

**Example:**
For example, you can specify that the action is taken when CallVariable 1 is equal to 123 and CallVariable 2 begins with 2.

**Step 6**
In the Ordered List of Actions area, click **Add** to open the Add Actions area. Click an action in this area to add it to the Ordered List of Actions.

**Step 7**
Use the up and down arrows next to the Ordered List of Actions to move actions into the order in which they should be performed.

**Step 8**
Click **Save**.

**Step 9**
Assign the workflow to one or more teams.

**Note**
A workflow does not run until it is assigned to a team.

---

**Edit Workflow**

**Procedure**

**Step 1**
In the Manage Workflows gadget, select the workflow you want to edit.

**Step 2**
Click **Edit**.
The Edit Workflow area appears.

**Step 3**
Edit the fields that you want to change.

**Step 4**
Click **Save**.

---

**Delete Workflow**

**Procedure**

**Step 1**
In the Manage Workflows gadget, select the workflow that you want to delete. The Delete Workflow area appears.

**Step 2**
Click **Delete**.
A question appears asking you to confirm that you want to delete the selected workflow.

**Step 3**
Click **Yes** to confirm the deletion of the selected workflow.

---

**Manage Security**

The Cisco Finesse administration console and agent desktop support secure HTTP (HTTPS). To access the administration console, enter the following URL in your browser (where `hostname` is the hostname of your primary server):
Similarly, agents and supervisors can access their desktops as follows:

https://hostname:8445/cfadmin

For HTTPS access, you can eliminate browser security warnings by choosing to trust the self-signed certificate provided with Finesse or uploading a CA certificate.

If you add custom gadgets that perform HTTPS requests to Finesse, you must add a certificate to the Finesse server for that gadget.

**Trust Self-Signed Certificate**

Trust the self-signed certificate provided by Finesse to eliminate browser warnings each time you sign in to the administration console or agent desktop.

If you are not using HTTPS or if you uploaded a CA certificate, you can skip this procedure.

**Procedure**

**Step 1**  
In your browser, enter the URL for the administration console (https://hostname of primary server:portnumber/cfadmin) or the agent desktop (https://hostname of primary server).

**Step 2**  
Perform the steps in the following table for the browser you are using.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you use Internet Explorer:</td>
<td>1 A page appears that states there is a problem with the website's security certificate. Click Continue to this website (not recommended). This action opens the sign in page for the administration console (or agent desktop). A certificate error appears in the address bar of your browser.</td>
</tr>
<tr>
<td></td>
<td>2 Click Certificate Error, and then click View Certificates to open the Certificate dialog box.</td>
</tr>
<tr>
<td></td>
<td>3 On the Certificate dialog box, click Install Certificate. This action opens the Certificate Import Wizard.</td>
</tr>
<tr>
<td></td>
<td>Note If you use Internet Explorer 11 with Windows 8.1, you must add Finesse to your trusted sites before the Install Certificate option appears (Internet Options &gt; Security &gt; Trusted Sites &gt; Sites).</td>
</tr>
<tr>
<td></td>
<td>After you click Install Certificate, under Store Location, select Current User to install the certificate for the current user only, or select Local Machine to install the certificate for all Windows users who use this computer.</td>
</tr>
<tr>
<td></td>
<td>4 Click Next.</td>
</tr>
<tr>
<td></td>
<td>5 Select Place all certificates in the following store, and then click Browse.</td>
</tr>
<tr>
<td></td>
<td>6 Select Trusted Root Certification Authorities, and then click OK.</td>
</tr>
<tr>
<td></td>
<td>7 Click Next.</td>
</tr>
<tr>
<td></td>
<td>8 Click Finish.</td>
</tr>
<tr>
<td></td>
<td>9 If a Security Warning dialog box appears that asks if you want to install the certificate, click Yes. A Certificate Import dialog box that states the import was successful appears.</td>
</tr>
<tr>
<td></td>
<td>10 Click OK.</td>
</tr>
<tr>
<td></td>
<td>11 Enter your credentials, and then click Sign In.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>If you use Firefox:</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>A page appears that states this connection is untrusted.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>I Understand the Risks</strong>, and then click <strong>Add Exception</strong>.</td>
</tr>
<tr>
<td>3</td>
<td>On the Add Security Exception dialog box, ensure the <strong>Permanently store this exception</strong> check box is checked.</td>
</tr>
<tr>
<td>4</td>
<td>Click <strong>Confirm Security Exception</strong>. The page that states this connection is untrusted automatically closes and the administration console (or agent desktop) loads.</td>
</tr>
<tr>
<td>5</td>
<td>Enter your credentials, and then click <strong>Sign In</strong>.</td>
</tr>
<tr>
<td>6</td>
<td>For the agent desktop only, an error appears that states Finesse cannot connect to the Cisco Finesse Notification Service and prompts you to add a security exception for the certificates issued by the Finesse server. Click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>

---

**Obtain and Upload CA Certificate**

**Note** This procedure only applies if you are using HTTPS.

This procedure is optional. If you are using HTTPS, you can choose to obtain and upload a CA certificate or you can choose to use the self-signed certificate provided with Finesse.

To eliminate browser security warnings each time you sign in, obtain an application and root certificate signed by a Certificate Authority (CA). Use the Certificate Management utility from Cisco Unified Communications Operating System Administration.

To open Cisco Unified Communications Operating System Administration, enter the following URL in your browser:

https://hostname of primary Finesse server/cmplatform

Sign in using the username and password for the Application User account created during the installation of Finesse.

**Note** You can find detailed explanations in the Security topics of the *Cisco Unified Communications Operating System Administration Online Help*.

**Procedure**

**Step 1** Generate a CSR.
a) Select Security > Certificate Management > Generate CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Generate CSR.

**Step 2** Download the CSR.

a) Select Security > Certificate Management > Download CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Download CSR.

**Step 3** Generate and download a CSR for the secondary Finesse server.

To open Cisco Unified Operating System Administration for the secondary server, enter the following URL in the address bar of your browser:

https://hostname of secondary Finesse server/cmplatform

**Step 4** Use the CSRs to obtain the CA root certificate, intermediate certificate, and signed application certificate from the Certificate Authority.

*Note* To set up the certificate chain correctly, you must upload the certificates in the order described in the following steps.

**Step 5** When you receive the certificates, select Security > Certificate Management > Upload Certificate.

**Step 6** Upload the root certificate.

a) From the Certificate Name drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the root certificate file.
c) Click Upload File.

**Step 7** Upload the intermediate certificate.

a) From the Certificate Name drop-down list, select tomcat-trust.
b) In the Root Certificate field, enter the name of the root certificate that you uploaded in the previous step.
   Do not include the extension (for example, TEST Root CA 2048).
c) In the Upload File field, click Browse and browse to the intermediate certificate file.
d) Click Upload File.

**Step 8** Upload the application certificate.

a) From the Certificate Name drop-down list, select tomcat.
b) In the Root Certificate field, enter the name of the intermediate certificate that you uploaded in the previous step. Include the .pem extension (for example, TEST-SSL-CA.pem).
c) In the Upload File field, click Browse and browse to the application certificate file.
d) Click Upload File.

**Step 9** After the upload is complete, sign out of Finesse.

**Step 10** Restart Cisco Tomcat on the primary Unified CCX node.

**Step 11** Restart Cisco Finesse on the primary Unified CCX node.

**Step 12** Upload the application certificate to the secondary Finesse server.

You do not need to upload the root and intermediate certificates to the secondary Finesse server. After you upload these certificates to the primary server, they are replicated to the secondary server.

**Step 13** Restart Cisco Tomcat and Cisco Finesse on the secondary Unified CCX node.
Add Certificate for HTTPS Gadget

Add a certificate for a secure HTTP (HTTPS) gadget to allow the gadget to load into the Finesse desktop and successfully perform HTTPS requests to the Finesse server.

This process allows HTTPS communication between the Finesse gadget container and the third-party gadget site for loading the gadget and performing any API calls that the gadget makes to the third-party server.

Note

A gadget that loads using HTTPS may still use HTTP communication between that gadget and the application server where it resides. If all traffic must be secure, the gadget developer must ensure that HTTPS is used to make API calls to the application server.

The certificate must be signed with a common name. The gadget URL in the desktop layout must use the same name (whether it uses an IP address or a fully qualified domain name) as the name with which the certificate is signed. If the certificate name and the name in the gadget URL do not match, the connection is not trusted and the gadget does not load.

To find the certificate name, enter the gadget URL in your browser. Click the lock icon in the address bar and then click View Details. Look for the common name field.

The Finesse host must be able to resolve this name via DNS, using the DNS host that was entered during installation. To verify that Finesse can resolve the name, run the CLI command "utils network ping <hostname>".

Procedure

**Step 1** Download the tomcat.pem certificate from the third-party gadget host.

- a) Sign into Cisco Unified Operating System Administration on the third-party gadget host (http://host or IP address/cmplatform, where host or IP address is the hostname or IP address of the third-party gadget host).
- b) Click Security > Certificate Management.
- c) Click Find.
- d) Click tomcat.pem.
- e) Click Download and save the file on your desktop.

**Step 2** Upload the certificate to the designated Finesses system.

- a) Sign into Cisco Unified Operating System Administration on the primary Unified CCX node (http://host or IP address/cmplatform, where host or IP address is the hostname or IP address of the Unified CCX node).
- b) Click Security > Certificate Management.
- c) Click Upload Certificate/Certificate Chain.
- d) From the Certificate Name drop-down list, select tomcat-trust.
- e) Click Browse and navigate to the tomcat.pem file that you downloaded in the previous step.
- f) Click Upload File.

**Step 3** Restart Cisco Tomcat on the primary Unified CCX node.

**Step 4** Restart Cisco Finesse on the primary Unified CCX node.

**Step 5** After synchronization is complete, restart Cisco Tomcat on the secondary Unified CCX node.

**Step 6** Restart Cisco Finesse on the secondary Unified CCX node.
Add Certificate for Multi-session Chat

Add the SocialMiner certificate to the Finesse servers to allow communication between SocialMiner and Finesse. After you complete this procedure, agents must accept certificates in the Finesse desktop before they can use this gadget.

If SocialMiner is deployed with private certificates, agents cannot join chat rooms until they accept the SocialMiner certificates. If the multi-session chat gadget is not deployed on the Home tab of the Finesse desktop, agents may not realize that they need to accept the certificates. Have agents check the tab where the multi-session chat gadget appears when they sign in to Finesse to make sure that certificates are all accepted and the gadget loads correctly.

The steps to add a certificate for the multi-session chat gadget are the same as the steps outlined in the procedure Add Certificate for HTTPS Gadget, on page 406.

Note

The procedure to add a certificate for an HTTPS gadget refers to the third-party gadget host. To add a certificate for multi-session chat, perform the applicable steps on the SocialMiner server.

CTI Failover

Finesse follows the active/standby model of Unified CCX. Finesse on the active Unified CCX node is "IN_SERVICE" and Finesse on the standby node is "OUT_OF_SERVICE".

A loss of connection to the CTI server can occur due to the following:

- Finesse misses three consecutive heartbeats from the connected CTI server.
- Finesse encounters a failure on the socket opened to the CTI server.
- The CTI server is not active on the node (Unified CCX is standby on the node).

When Finesse loses connection to the CTI server, Finesse attempts to reconnect until it makes a successful connection to the CTI server.

Cisco Finesse connects successfully through CTI to the node where the Unified CCX Engine is currently master. Agents should log in to Finesse on that node.

When the master Unified CCX Engine fails, Finesse establishes a connection with the Unified CCX Engine on the other node, and agents must log in to other node.

Backup and Restore

The Unified CCX backup and restore component also backs up and restores Finesse configurations and data. For more information about backup and restore, see Disaster Recovery System Administration Guide for Cisco Unified Contact Center Express at http://www.cisco.com/en/US/products/sw/custcs/w/custcs/w/custcs/ps1846/products_installation_and_configuration_guides_list.html.
Additional Language Support

For the list of languages that are supported by Finesse, see the *Compatibility Matrix for Unified CCX*, located at:


If you want to use the Finesse desktop interface in a language other than English, download and install the language COP file. For more information, see the "COP File" section of the *Cisco Unified Contact Center Express Installation and Upgrade Guide*, located at:


Cisco Finesse Agent and Supervisor Desktop

Cisco Finesse Desktop provides easy access to the applications and information sources from a single customizable cockpit. Providing this unique access to information helps the agents deliver fast and accurate service.


Call Manager-Based Call Recording Using Cisco MediaSense

Cisco Finesse in Unified CCX supports call recording using Cisco MediaSense. MediaSense is the media-capture platform for Cisco Unified Communications.

To use MediaSense, perform the following procedures:

1. Configure Cisco MediaSense with Unified CM, on page 408
2. Upload Cisco MediaSense Certificate to Unified CCX Server, on page 409
3. Upload MediaSense Recording License, on page 409
4. Configure MediaSense as a Recording Server, on page 409
5. Call Recording Through Workflow
6. Configure MediaSense Search and Play Gadget, on page 411

**Note**

After performing all of the procedures, restart the Unified CCX server. In high availability deployment, restart both of the nodes.

Configure Cisco MediaSense with Unified CM

Upload Cisco MediaSense Certificate to Unified CCX Server

To establish connection with Cisco MediaSense securely, you must upload the Cisco MediaSense certificate to Unified CCX server.

**Procedure**

**Step 1** Download the tomcat.pem certificate from the Cisco MediaSense server.

a) Sign into Cisco Unified Operating System Administration on the Cisco MediaSense host (https://host or IP address/cmplatform/showHome.do, where host or IP address is the hostname or IP address of the Cisco MediaSense server).

b) Choose **Security > Certificate Management**.

c) Click **Find**.

   The Certificate Name must be tomcat-trust and the Certificate Type must be trusts-cert.

d) Click **tomcat.pem**.

e) Click **Download** and save the file on your desktop.

**Step 2** Upload the certificate to the designated Unified CCX server.

a) Sign in to Cisco Unified Operating System Administration on the primary Unified CCX node (http://host or IP address/cmplatform, where host or IP address is the hostname or IP address of the Unified CCX node).

b) Choose **Security > Certificate Management**.

c) Click **Upload Certificate/Certificate Chain**.

d) From the Certificate Name drop-down list, select **tomcat-trust**.

e) Click **Browse** and navigate to the tomcat.pem file that you downloaded in the previous step.

f) Click **Upload File**.


---

Upload MediaSense Recording License

To use the MediaSense recording feature, you must purchase the Unified CCX recording license and upload it to the Unified CCX server.

For information about how to upload the license, see **Upload Licenses,** on page 11.

Configure MediaSense as a Recording Server

For information about configuring MediaSense as a recording server, see **Recording Configuration,** on page 276.
Call Recording Through Workflow

Use the HTTP Request action to invoke the Finesse Recording API after the call is answered.

Procedure

Step 1  Create an HTTP Request Recording action:

a) In the Manage Workflow Actions area, click New.
b) In the Name box, enter a name for the action.
c) From the Type drop-down list, select HTTP Request.
d) From theHandled By drop-down list, select Finesse Desktop.
e) From the Method drop-down list, select PUT.
f) From the Location drop-down list, select Finesse.
g) In the Content Type box, enter application/xml.
h) In the URL box, enter the following:
   /finesse/api/Dialog/
   i) Click the tag icon at the right of the box and select dialogId to add it to the URL.
j) In the Body box, enter the following:
   
   <Dialog>
   <requestedAction>START_RECORDING</requestedAction>
   <targetMediaAddress>
   <extension>extension</extension>
   </targetMediaAddress>
   </Dialog>

   To add the extension, click the tag icon and select extension.

Example:
Configure MediaSense Search and Play Gadget

Before You Begin
In the MediaSense server, you must have already configured Unified CM, Cisco Finesse, and MediaSense API.

Procedure

Step 1 Sign in to the Cisco Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Find the MediaSense tab and gadget in the layout XML. Update the layout according to the comments in the layout.

```xml
<!-- The following Tab and Gadget are for MediaSense. They are *ONLY* supported with MediaSense. 
If you are not using MediaSense, then remove them. If you are using MediaSense and wish to show 
Recording Management, then do the following: -->
```

Step 2 Click Save to save workflow action.
Step 3 Add a Call Answered Workflow that executes the HTTP Request Recording action that you created in the previous step.

**Note** The Call Answered Workflow can be used to trigger an HTTP Request Recording action for inbound calls, agent-initiated outbound calls, and Predictive, Progressive, and Direct Preview outbound calls.

Step 4 Assign the workflow to the teams that you would like to record.
For information about adding HTTP Request workflow action, see Add HTTP Request Workflow Action.
For more information about creating a workflow, see Add Workflow, on page 400.
1) Remove these comments leaving the tab and gadget
2) Replace all instances of "my-mediasense-server" with the Fully Qualified Domain Name of your MediaSense Server.

IMPORTANT NOTE:
- In order for this Gadget to work, you must have performed all documented prerequisite steps.

<tab>
  <id>manageRecordings</id>
  <label>finesse.container.tabs.supervisor.manageRecordingsLabel</label>
  <gadgets>
  </gadgets>
</tab>

Replaced all instances of my-mediasense-server with https://<Fully Qualified Domain Name of your MediaSense Server>/ora/gadget/MediaSenseGadget.xml.

Note: Replace all instances of my-mediasense-server with https://<Fully Qualified Domain Name of your MediaSense Server>/ora/gadget/MediaSenseGadget.xml.

Example:
https://abcd-ef-gh102.abc.com:8440/ora/gadget/MediaSenseGadget.xml

Step 4  Click Save.
Note  The supervisor must log out and log in again to Cisco Finesse Supervisor Desktop to access MediaSense.

Step 5  Sign in to Cisco Finesse desktop as a supervisor and confirm that MediaSense gadget is accessible.
Extend and Connect

Overview

With the Extend and Connect feature, Unified Contact Center Express agents and supervisors can work from a remote location using any device.

This feature gives the user (agent or supervisor) the flexibility to answer or make calls using devices that are connected to the PSTN or to mobile or other PBX networks. Extend and Connect functions by leveraging CTI remote device and persistent connection features of Cisco Unified Communications Manager (CUCM).

You can enable the Extend and Connect feature through the Cisco Jabber client by selecting only the Extend mode. This feature provide the following connections:

- **CTI remote device**—CTI remote devices are Unified CCX off-cluster devices for users that can be connected to any of the third-party networks, such as PSTN, mobile, or PBX.
- **Persistent connection**—Unified CCX users use this feature to set up a persistent call connection to remote destination. The advantage of this connection is that call establishment to the remote destination is much faster.

For more information about the Extend and Connect feature, see [http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/9_1_1/ccmfeat/CUCM_BK_C3E0EFA0_00_cucm-features-services-guide-91 chapter_0110010.html](http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/9_1_1/ccmfeat/CUCM_BK_C3E0EFA0_00_cucm-features-services-guide-91 chapter_0110010.html).


Server Configuration

To use the Extend and Connect, follow these server configuration steps:

**Procedure**

**Step 1** Perform the preinstallation tasks for IM and Presence nodes.

**Step 2** Configure the Cisco IM and Presence node details on Call Manager before you install Cisco IM and Presence. From Cisco Unified CM Administration on the publisher node, choose System > Server > Server Type and then choose CUCM IM and Presence.

**Step 3** Install Cisco IM and Presence as a Call Manager subscriber.

**Step 4** Activate and start all the Cisco IM and Presence services in Cisco Unified Serviceability.
For information about activating services, see the "Activate services" section in Installing Cisco Unified Communications Manager at http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_installation_guides_list.html.

**Step 5** Create Presence Redundancy groups in Call Manager.
  a) Choose System > Presence Redundancy Groups > Add New.
  b) Select Cisco IM and Presence, which you installed from the Presence Server drop-down list.

**Step 6** Create UC services for CTI and IM Presence services in Call Manager.
  **Note** You must select CTI and IM Presence services.

**Step 7** Set up the service profile in Call Manager.
  **Note** You must specify CTI and IM Presence service that you created in step 6.

**Step 8** Set up the end user in Call Manager.
Perform the following steps:
  a) Navigate to User Management > End User.
  b) Click the User ID that you want to set up.
  c) In the Service Settings section, select Enable User for Unified CM IM and Presence (Configure IM and Presence in the associated UC Service Profile) and then in UC Service Profile, select the profile that you created.
  d) In the Mobile Information section, select Enable Mobility.
  e) In Permission Information, add Standard CCM End user and Standard CTI enabled.
  f) Navigate to User Management > Assign Presence End Users.
  g) Click the User ID that you want to set up and then choose Assign Selected Users.

**Step 9** Set up the trunk in Call Manager.

**Step 10**
Add the route pattern in Call Manager to route the calls to the remote device.

**Step 11**
Configure the Presence Gateway configuration on IM and Presence.

---

**Persistent Connection**

Unified CCX makes a persistent connection call to the agent's remote phone when an agent logs in to the agent desktop.

Note: The agent must first answer the persistent connection call and then change the status to Ready in the agent desktop to answer the incoming call.

After establishing the persistent connection, the call remains connected until the Maximum Call Duration timer expires or until the agent logs out, provided that no other problems occur in the remote destination network. You must specify to match the time on the Maximum Call Duration timer with your company shift time or specify more than your company shift time. If the persistent connection gets disconnected, it retries until the connection is established. For more information about configuring the Maximum Call Duration in Cisco Unified Communications Manager, see http://www.cisco.com/en/US/docs/voice_ip_comm/meetingplace/8_5/english/administration/cucm_integration.html#wp1054377.

**Add Customized Announcement for Persistent Connection Call**

When an agent answers persistent connection call, make an announcement to the agent indicating that the persistent connection must be retained so that further calls from or to customers are established over persistent connection.

If the agent's remote device supports Caller ID display, it displays **EC Mode** as the caller name, which indicates a persistent connection call.

By default, the Cisco Unified Communications Manager has announcements created. Unified CCX, through JTAPI communication to Cisco Unified Communications Manager, calls the announcement ID **UCCX Persistent Connection Prompt**. You must create the **UCCX Persistent Connection Prompt** customized announcement ID.

To add the customized announcement ID, see the "Upload customized announcement" procedure in the Cisco Unified Communications Manager Administration Guide at http://www.cisco.com/en/us/products/sw/voicesw/ps556/prod_maintenance_guides_list.html. Enter UCCX Persistent Connection Prompt in the Announcement Identifier field.
• Add a customized prompt to the created UCCX Persistent Connection Prompt, click **Upload Files** and select the desired prompt (.wav file).

• When the announcement is played, the Caller ID information on agent's remote phone changes to **Voice Connect**.

• If no announcement ID is created, Cisco Unified Communications Manager does not play any announcement to the agent when the persistent call is answered.

---

**Incoming Call Notification**

An agent can configure a sound alert to notify an incoming call when the customer calls are routed through Persistent Connection Calls of the agents.

To receive the sound alert, in Cisco Unified Communications Manager, configure the Announcement ID as **UCCX Customer Call Prompt**. When the Announcement ID is configured, Unified CCX plays the announcement before the call is routed to a desktop. If you do not configure an Announcement ID, Unified CCX does not play an announcement, and then the agent relies on desktop signal for an incoming call.

---

**Note**

Configure **UCCX Customer Call Prompt** in the English language in Cisco Unified Communications Manager.
Cisco Unified Contact Center Express License Packages

This appendix describes the features that are available with each Unified CCX license package.

- **Application Availability by License Package**, page 417
- **Trigger Availability by License Package**, page 417
- **Subsystem Availability by License Package**, page 418
- **Unified CCX Services Availability by License Package**, page 419
- **Unified CCX Component Availability by License Package**, page 419

### Application Availability by License Package

The following table lists the applications available with each license package:

<table>
<thead>
<tr>
<th>Application</th>
<th>Unified IP IVR</th>
<th>Unified CCX Standard</th>
<th>Unified CCX Enhanced</th>
<th>Unified CCX Premium</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Script Application</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Busy</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Ring No Answer</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified ICME Post Routing</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified ICME Translation Routing</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Trigger Availability by License Package

The following table lists the triggers available with each license package:
### Subsystem Availability by License Package

The following table lists the subsystems available with each license package:

<table>
<thead>
<tr>
<th>Subsystem</th>
<th>Unified IP IVR</th>
<th>Unified CCX Standard</th>
<th>Unified CCX Enhanced</th>
<th>Unified CCX Premium</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMT Subsystem</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Core RTR Subsystem</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Database Subsystem</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>eMail Subsystem</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Enterprise Server Data Subsystem</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>HTTP Subsystem</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Unified CM Telephony Subsystem</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MRCP ASR Subsystem</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>MRCP TTS Subsystem</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Outbound Subsystem (^4)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>RmCm Subsystem</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Voice Browser Subsystem</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>VoIP Monitor Subsystem</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Chat Subsystem</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>RouteAndQueue Subsystem</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

\(^4\) The Unified CCX Outbound Preview Dialer feature does not require an additional license and it comes as part of the Premium license package.
Unified CCX Services Availability by License Package

The following table lists the Unified CCX Services available with each license package:

<table>
<thead>
<tr>
<th>Unified CCX Services</th>
<th>None (^5)</th>
<th>Unified IP IVR</th>
<th>Unified CCX Standard</th>
<th>Unified CCX Enhanced</th>
<th>Unified CCX Premium</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified CCX Cluster View Daemon</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Administration</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Engine</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Cisco Desktop Call/Chat Service</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop Enterprise Service</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop IP Phone Agent Service</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop LDAP Monitor Service</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop License and Resource Manager</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop Recording Service (call recording)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop Recording and Statistic Service</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop Sync Service</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Desktop VoIP Service</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Cisco Unified CCX Database</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

\(^5\) Available upon installation, before license package is activated.

Unified CCX Component Availability by License Package

The following table lists the Unified CCX Component available with each license package:
### Unified CCX Component Availability by License Package

<table>
<thead>
<tr>
<th>Unified CCX Component</th>
<th>None 6</th>
<th>Unified IP IVR</th>
<th>Unified CCX Standard</th>
<th>Unified CCX Enhanced</th>
<th>Unified CCX Premium</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified CCX Cluster View Daemon (CVD)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Engine</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Repository Datastore</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Unified CCX Historical Datastore</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Configuration Datastore</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Agent Datastore</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Recording</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Unified CCX Monitoring</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

6 Available upon installation, before license package is activated.
INDEX

A
AAR 71, 148, 150, 284
   files 148
group 71
   management 284
   uploading files 150
active server 5, 159, 160
administrator privileges 264
Administrator User Group 225
agent 35, 119, 242, 263, 265
   capabilities 263
   configuring 35
   configuring teams 119
   handling callbacks 242
   user privileges 265
All Users Group 225
alternative pronunciation 270
Call by Name window 270
Call by Name window, how to add 270
application 3, 6, 12, 54, 195, 200, 281, 417
   by package license 417
   configuration overview 12
   management 281
   report 195, 200
   server 3
   subsystem 6
   triggers 54
architecture, cluster 5
ASR 84, 85
   overview 84
   provisioning 85
Automated Alternate Routing, See AAR
automatic failover 5, 159, 160
Automatic Speech Recognition, See ASR

B
best practices 231
   security 231

busy application 45
   about 45
   provisioning 45

C
cache size 246
   contact records 246
call control channel 66
call waiting 238
   disabling in Unified CM 238
calling search space 71, 77
   ignore setting 77
   restrict users 77
   Unified CM Telephony trigger setting 77
   usage 71, 77
campaigns 236, 243, 256
   importing contacts 256
   Outbound subsystem 236
   time changes 243
capabilities 263
   users 263
channels 66
   provisioning 66
Cisco Desktop Administration 119
Cisco IP Agent and Supervisor desktops 1
   about 1
Cisco Media subsystem 6, 83
   about 6
   provisioning 83
Cisco Script Application 42, 43, 54
   adding 42, 43
   adding a trigger 54
Cisco Security Agent 234
   usage 234
Cisco TelePresence application 37
Cisco Unified CCX Administration web interface 1, 15, 16, 19, 20
   about 1, 15
   configuration web pages 19
   menu bar and menus 16
   using navigation bars 20
Cisco Unified CCX applications 41
  configuration overview 41
Cisco Unified CCX cluster 159
  profile 159
Cisco Unified CCX component availability 419
  by package license 419
Cisco Unified CCX components 1
Cisco Unified CCX Editor, about 1
Cisco Unified CCX Engine 6
  about 6
Cisco Unified CCX Engine subsystems 6
  Applications 6
  Cisco Media 6
  Core Reporting 6
  Database 6
  eMail 6
  Enterprise Server 6
  HTTP 6
  MRCP ASR 6
  RmCm 6
  TTS 6
  Unified CM Telephony 6
Cisco Unified CCX platform, about 1
Cisco Unified CCX product family 3, 6
  about 3
  Unified CCX 3
  Unified IP IVR 3, 6
Cisco Unified CCX Server, about 1
Cisco Unified CCX supervisor web interface 266
Cisco Unified CCX user options web interface 268
Cisco Unified Communications components 1
  about 1
  Cisco IP Agent and Supervisor desktops 1
  Cisco Unified CCX Administration web interface 1
  Cisco Unified CCX Editor 1
  Cisco Unified CCX Server 1
  Cisco Unified Gateway 1
  historical reports database server 1
  MRCP ASR server 1
  MRCP TTS 1
  Unified CM 1
Cisco Unified Communications Manager Administration 17
  navigating 17
Cisco Unified IP IVR, about 6
  cluster 5
    active server 5
    architecture 5
    cluster manager 5
    cluster view daemon 5
  cluster, definition 159
CM Telephony 288, 289
  Call Control group configuration 289
  provider configuration 288
  triggers 289
CMT dialog channels, about 83
CMT dialog group 83
  about 83
CMT dialog interactions, about 83
  competence level, about 102
  component, definition 159
Computer Telephony Interface, See CTI
  configuration 1
    datastore server 1
    configuration checklist 245
  Outbound subsystem 245
  configuration updates 243
  Outbound subsystem 243
  configuring, definition 8
Contact Service Queues 107, 110, 112
  about 107
    configuration web page 110
    creating 107, 110
    deleting 112
    modifying 112
  contact summary report 234
  Outbound 234
  contacts report 197
Core Reporting subsystem, about 6
CPU utilization 58
  and VRU scripts 58
  creating campaigns 245
CSQ 3, 107, 244, 245, 294, 295
  about 3
  creating 295
  Outbound percentage 244
  Outbound subsystem percentage 245
  resource based 107
  skill based 107
  Subsystems menu 294
CSQ Cisco Unified CCX Stats report 205
CTI 6, 77
  managing clusters 6
  port device and route point 77
  custom 276
    classpaths for custom classes, steps, subsystems 276
    custom file configuration 276
    custom file configuration (System menu) 147
D
daily purge schedule 184
  about 184
  configuring 184
database 131, 132, 316
  maximum connections 131, 132
  parameter 316
database (continued)
  password 131, 132
  username 131, 132
Database 234
  in service 234
database connectivity 133
  polling 133
Database subsystem 6, 123, 131, 132, 330
  about 6, 123, 131
  adding JDBC datasource 131
  configuration overview 131
  configuration web page 132
  configuring 131
  defining ODBC datasource 330
  supported Enterprise Databases 131
datasource usage report 201
datasource, adding 315
Daylight Savings Time, See DST
db_cra database 243
  area code mapping 243
default time zone 259
devices 419
  by package license 419
dialing functionality 233
dialing mode 234, 238
  direct preview 234, 238
dialing prefixes 245
  geographic area 245
Directory Number 32
  associations 32
Directory Number information 77
Do Not Call list 234
  Outbound subsystem 234
do_not_call list 234
  national 234
document file 144
  unzipping after upload 144
documents 141
  about 141
DST 259
  Outbound subsystem 259
E
eMail subsystem 6, 123, 134
  about 6, 123, 134
  configuring 134
  enabling campaigns 245, 258
  engine tasks report 196
  Enterprise Server subsystem, about 6
execute permission 227
F
failover 5
  automatic 5
feature, definition 159
files 137, 144
  adding zip 144
  managing for applications 137
G
general properties 239, 245
  Outbound subsystem 239, 245
geographic region 234
  Outbound support 234
grammars 139
  about 139
Group 225
H
handling callbacks 242
Help menu 343, 344, 345
  About 345
  Contents and Index 343
  For this Page 344
high availability 160
historical report user capabilities 263
historical report user privileges 265
historical reporting 1, 13
  client 1
  configuration overview 13
  historical reporting database 182, 184, 186
  configuring daily purge schedule 184
  configuring database server 182
  file restore 186
  purge configuration 184
  historical reports database 185
  purging manually 185
  historical reports database server 1
  about 1
HTTP subsystem 6, 123, 129
  about 6, 123, 129
  configuration overview 129
HTTP triggers, adding 57
I
importing campaigns 245
Integrated Service Router, See ISR
international area codes 234
    mapping 234
invalid number 242
    handling callbacks 242

J
JDBC datasource 131, 132
    adding 131, 132

L
LDAP server information (System menu) 161
license 11, 77, 124, 129, 131, 134, 417, 418, 419
    adding components 11
    application availability 417
Cisco Unified CCX component availability 419
database subsystem 131
eMail subsystem 134
HTTP subsystem 129
    product 77
    service availability 419
    subsystem availability 418
    trigger availability 417
Unified ICME subsystem 124
logout 279
logout (System menu) 179

M
manage scripts 282
managing users 263
master service, definition 159
media channel 66
missed callback 242
MRCP ASR 85, 86, 87, 89
    groups configuration 89
    provider configuration 86
    provisioning 85
    server configuration 87
MRCP ASR server, about 1
MRCP ASR subsystem 6, 85
    about 6
    configuration overview 85
    provisioning 85
MRCP TTS 91, 92, 95
    locals configuration 95
    provider configuration 92
    provisioning 91
MRCP TTS server, about 1
MRCP TTS subsystem 6, 91
    about 6, 91
    provisioning 91
multiple time zones 259

N
national do_not_call list 234, 256
navigating 17
    Cisco Unified Communications Manager Administration 17
nickname 270
node, definition 159

O
ODBC datasource 131, 330
    about 131
    defining 330
Outbound 238
    licensed seat 238
Outbound subsystem 234
Do Not Call list 234
Outbound Subsystem 234
    in service 234
Overall Unified CCX Stats report 202
pending records 259
    Outbound subsytem 259
pending state 243
Permissions 227
    and User Groups 227
plug-ins 327
point system for provisioning channels 66
    product 77
    licenses 77
product license 124, 129, 131, 134
    database subsystem 131
    eMail subsystem 134
    HTTP subsystem 129
    Unified ICME subsystem 124
profile, cluster 159
prompts 137, 145, 147
    about 137, 145
    adding spoken name prompt 147
    recording 145
provisioning call control groups 71
provisioning checklist 67
    telephony and media resources 67
Provisioning checklist 22
Unified CCX subsystem 22
  provisioning, definition 8
publisher 5
  cluster manager 5
purge configuration 184
  parameters 184
purging 183, 184
  automatic 183
  manual 184
purging, manually 185

Q
queuing calls 82
  with Unified CCX 82

R
read permission 227
real-time reports 186, 189, 190, 191, 193, 195, 196, 197, 201, 202, 205, 206, 214
  about 186
  application tasks 195
  application tasks summary 195
  available reports 186
  contact summary 193
  contacts 197
  CSQ Cisco Unified CCX Stats 205
  datasource usage 201
  engine tasks 196
  Overall Unified CCX Stats 202
  printing reports 190
  resetting statistics 190
  Resource Unified CCX Stats 206, 214
  running reports 189
  sessions 201
  setting appearance 191
  setting options 191
  viewing subreports 189
Refresh All button 20
Remote Monitoring application 52
  about 52
  provisioning 52
Resource based CSQ 107
resource groups 99, 100, 294
  creating 99, 294
  deleting 100
  modifying name 99
Resource Manager, about 3
Resource pool selection criteria 113, 114
  between skills and groups 113
  within a CSQ 114
Resource Unified CCX Stats report 206, 214
resources 104, 105, 106, 293
  assigning to resource groups and skills in bulk 105
  assigning to resource groups and skills individually 104
  modifying 293
  removing skills from individual agents 106
resynchronizing 68, 69, 82
  Cisco JTAPI Client 68
  Unified CM Telephony data 69
  Unified CM Telephony information 82
Ring-No-Answer application 47
  about 47
  provisioning 47
RmCm provider 97
  about 97
  provisioning 97
RmCm subsystem 234
  in service 234
RmCm subsystem, about 6
RNA application 47
  about 47
  provisioning 47
Run As 230

S
scheduling callbacks 259
  Outbound subsystem 259
script application 42, 43
  about 42, 43
  configuration overview 42, 43
script management 58, 282
script repository 42, 43
scripts 58, 60, 61, 63, 64
  about 58
  deleting 64
  refreshing 61
  renaming 63
  viewing or downloading 60
scripts, uploading 59
security 231
  best practices 231
servers 159, 160
  active and standby 159, 160
Service Control interface 125
service, definition 159
Session Initiation Protocol, See SIP
sessions report 201
SIP 6
   router integration 6
Skill based CSQ 107
skills 101, 102, 106, 296
   creating 101, 296
   deleting 102
   modifying name 101
   removing 296
   removing from individual agents 106
spoken name prompt 147
   adding 147
standby server 159, 160
standby service, definition 159
subscriber 5
   cluster manager 5
subsystems 418
   by package license 418
   Add a New Dialog Control Group 83
   adding HTTP triggers 318
   adding teams 297
   agent-based routing 297
   assigning skills 295
   Cisco Media 318
   CM Telephony 288
   CM Telephony Call Control group configuration 289
   CM Telephony provider configuration 288
   CM Telephony triggers configuration 289
database configuration 314
eMail 318
general 313
HTTP 317
MRCP ASR 319
MRCP TTS 320
remote monitoring 296
resource group 294
resources 293
RmCm provider 295
   skills configuration 292
teams 297
Unified CCX 291
Unified ICME 313
VRU scripts 314
supervisor 119
   configuring teams 119
supervisor capabilities 263
supervisor privileges 264
System menu 147, 161, 179, 273, 276, 279
   about 273
   custom file configuration 147, 276
   LDAP Information 161
   logout 179, 279
   system parameters 161
systems parameters (System menu) 161

T

team 119, 120, 121
   configuring 119
   creating a team 120
   deleting a team 121
   making changes to agents on a team 121
Text-to-speech, See TTS
time zone 242, 259
   determining local time 259
   handling callbacks 242
toolbar 20
   using 20
   application task summary 195
   application tasks 195
   Clear Contact 217
   contact summary report 193
   contacts 197
   CSQ Unified CCX Stats 205
data source usage 201
   engine tasks 196
   file restore 335
   historical reporting 333
   Open Printable Report 217
   Options 220
   overall Unified CCX Stats 202
   overview 327
   password management 341
   plug-ins 327
   purge now 335
   purge schedule 335
   real-time reporting 328
   real-time snapshot config 329
   Refresh Connections 217
   report 192
   Reset All Stats 217
   Resource Unified CCX Stats 206, 214
   sessions 201
   Tools 216
   troubleshooting tips 344
   user configuration 335
   user management 336, 337
   user management, Name Grammar Generation 337
   user management, Spoken Name Upload 338
   Views 218
   Tools meny 220
   Settings 220
Index

Index

triggers 417
  by package license 417
triggers and applications 54
TTS 84, 91, 93
  default provider 93
  overview 84
  provisioning 91
  VXML applications 93

U

UNICODE 91
Unified CCX 3, 268
  about 3
  installing agent desktop 268
Unified CCX Administration 15
  connecting 15
Unified CCX Agent Desktop, about 3
Unified CCX components 3
  CSQ 3
  Resource Manager 3
  Unified CCX Agent Desktop 3
Unified CCX Enhanced with CTI Option, about 3
Unified CCX Enhanced, about 3
Unified CCX Standard, about 3
Unified CM 31, 270
  connecting to web interface 31
  users 270
Unified CM telephony 68
  configuration 68
Unified CM Telephony 77
  trigger information 77
Unified CM Telephony information, resynchronizing 82
Unified CM Telephony subsystem 6, 68, 69, 71, 77, 234
  about 6
  configuration overview 68
  configuring Unified CM Telephony providers 69
  in service 234
  provisioning call control groups 71
  provisioning Unified CM Telephony trigger 77
Unified CM Telephony trigger 55
  adding 55
Unified CM Telephony triggers 82
  using with Unified CCX 82
Unified CM User Options page 270
Unified Communications Manager 32
  configure users 32
Unified ICME 6
  about 6
Unified ICME post-routing application 48
  about 48
  provisioning 48
Unified ICME script commands 124
Unified ICME subsystem 123, 124, 125, 127
  about 123, 124
  configuration overview 124
  configuring general Unified ICME information 125
  configuring VRU scripts 127
Unified ICME translation-routing application 50
  about 50
  provisioning 50
Unified IP IVR, about 3
uploading licenses 11
uploading scripts 59
User Groups 225, 227
  Administrator User Group 225
  and Permissions 227
  Child Groups 225
  Groups 225
User Permissions 227
  write, read, and execute 227
user roles 263
users 32, 230
  configuring in Unified Communications Manager 32
  Run As 230

V

virtual agents 37
virtual infrastructure 37
voice gateways 1
VRU scripts 58, 127, 314
  configuring 127, 314
  uploading time 58
VXML applications 93
  default TTS provider 93

W

wizards 20
  using 20
Wizards menu 323, 324
  Application 323
  RmCm 324
wrap-up data 119
  usage 119
write permission 227

Z

zip files, uploading 144