Paging Overview

Cisco Unified Communications Manager can be configured to integrate with Cisco Paging Server to provide basic paging services for Cisco Unified IP Phones and a variety of endpoints. The Cisco Paging Server product is offered through the InformaCast Virtual Appliance and offers the following deployment options:

InformaCast Basic Paging

InformaCast Basic Paging provides phone-to-phone live audio paging to individual Cisco IP phones or groups of up to 50 phones simultaneously. InformaCast Basic Paging is free to all Cisco Unified Communications Manager customers and all Cisco Business Edition 6000 and Cisco Business Edition 7000 customers.

InformaCast Advanced Notification

InformaCast Advanced Notification is a full-featured emergency notification and paging solution that allows you to reach an unlimited number of Cisco IP phones and various devices and systems with text and audio messages.

To streamline the configuration process, Cisco Unified Communications Manager comes with a provisioning wizard that allows you to quickly configure advanced notifications services.

Some of the features include:

- Text and audio (live or pre-recorded) to Cisco IP Phones and other endpoints
- Analog and IP overhead paging systems integration
- 911 or emergency call monitoring or alerting or recording
- Cisco Jabber integration
- Cisco Spark integration
• Automated weather notifications
• Dynamically triggered emergency conference calls
• Pre-recorded or scheduled broadcasts (school bells or shift changes)
• Event accountability with message confirmation and reporting
• Notification to computer desktops (Windows and Mac OS)
• Facilities integration (control lighting, door locks)
• Security integration (panic or duress buttons, motion detectors, fire)

Purchase a license key to access InformaCast Advanced Notification features.

**InformaCast Mobile**

InformaCast Mobile is a cloud-based service that allows users to send images, text, and pre-recorded audio to mobile devices running iOS or Android. It also has bi-directional integration with InformaCast Advanced Notification.

Some of the features include:
• The ability to send and receive InformaCast messages via mobile devices running iOS or Android
• Bi-directional integration with InformaCast Advanced Notification
• Message confirmations and read receipts
• No calling or SMS messaging fees

InformaCast Mobile must be purchased direct from Singlewire Software. Please refer to the Singlewire website for additional details and downloads.

If you have already configured Cisco Unified Communications Manager to integrate with InformaCast Advanced Notification, no further configuration of Cisco Unified Communications Manager is required.

**Paging Prerequisites**

Cisco Paging Server is designed to work in a multicast environment. You must configure your network for multicast.

For a list of Cisco Unified IP Phones that support paging, refer to the [Cisco Unified IP Phones](http://www.singlewire.com/compatibility-matrix.html) section of the Singlewire Compatibility Matrix at:

Cisco Unified Communications Manager Configuration for Basic Paging Task Flow

Perform the following tasks to configure Cisco Unified Communications Manager to integrate with Cisco Paging Server for an InformaCast Basic Paging deployment.

Before you begin

- Learn more about the feature by reviewing the following:
  - Paging Overview, on page 1
  - InformaCast Basic Paging, on page 1
- Review Paging Prerequisites, on page 2
- The configuration in this section is automated when using the Advanced Notification Paging Configuration Task Flow wizard.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Enable SNMP Service, on page 4</td>
<td>Configure SNMP in Cisco Unified Communications Manager.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Set Default Codec to G.711, on page 6</td>
<td>Set the default codec to G.711.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Configure a Device Pool for Paging, on page 6</td>
<td>Configure a device pool.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Configure Route Partition for InformaCast Paging, on page 7</td>
<td>Configure a route partition for Basic Paging.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Configure Calling Search Space for InformaCast Paging, on page 8</td>
<td>Configure a calling search space for Basic Paging.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Configure CTI Ports for Paging, on page 8</td>
<td>Configure CTI ports.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Configure Access Control Group with AXL Access, on page 9</td>
<td>Configure an AXL access control group.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Configure Application User for Paging, on page 10</td>
<td>Configure an application user.</td>
</tr>
</tbody>
</table>
| Step 9 | Enable web access for the phone using one of the following procedures:  
  - Enable Web Access for a Phone, on page 11  
  - Enable Web Access for Common Phone Profile, on page 11 | You can enable web access on all phones globally using Enterprise Phone Configuration, a group of phones using a Common Phone Profile, or an individual phone. |
Configure SNMP for Paging

Perform the following tasks to configure SNMP services in the cluster.

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Enable SNMP Service, on page 4</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Create an InformaCast SNMP Community String, on page 5</td>
</tr>
</tbody>
</table>

**Enable SNMP Service**

To configure paging, you must enable SNMP on every node in the cluster. In addition, you must enable the following services:

- Cisco CallManager SNMP Service—Enable on all nodes in the cluster.
- Cisco CallManager—Enable on at least one node.
- Cisco AXL Web Services—Enable on at least one node.
- Cisco CTIManager—Enable on at least one node.

**Procedure**

**Step 1** Log in to Cisco Unified Serviceability and choose Tools > Service Activation.
**Step 2** From the Server drop-down list, choose the server on which you want to configure SNMP.
**Step 3** Check the check boxes that correspond to the Cisco CallManager SNMP Service.
**Step 4** For at least one server in the cluster, check the check boxes that correspond to Cisco CallManager, Cisco CTIManager, and Cisco AXL Web Service services.
Create an InformaCast SNMP Community String

Perform this procedure for Basic Paging to set up an SNMP community string.

Before you begin

Enable SNMP Service, on page 4

Procedure

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In Cisco Unified Serviceability, choose SNMP &gt; V1/V2c &gt; Community String.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>From the Server drop-down list box, choose a server and click Find.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click Add New.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Community String Name field, enter ICVA.</td>
</tr>
<tr>
<td>Step 5</td>
<td>From the Access Privileges drop-down menu, select ReadOnly.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Check the Apply to All Nodes check box if the check box is active.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Click Save.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Click OK.</td>
</tr>
</tbody>
</table>

What to do next

Set Default Codec to G.711, on page 6

Configure Region for Paging

For Basic Paging, you must set up a region for your paging deployment.

Before you begin

Configure SNMP for Paging, on page 4

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Set Default Codec to G.711, on page 6</td>
</tr>
</tbody>
</table>
### Purpose

Command or Action | Purpose  
---|---
**Step 2** Configure a Device Pool for Paging, on page 6 | Set up a device pool for paging and assign the region that you created to that device pool.  

---

### Set Default Codec to G.711

You must create an InformaCast region that uses G.711 as the default codec for calls to other regions.

**Before you begin**

Configure SNMP for Paging, on page 4

**Procedure**

1. In Cisco Unified CM Administration, choose **System > Region Information > Region**.
2. Click **Add New**.
3. In the **Name** field, enter **ICVA**.
4. Click **Save**.
5. In the **Regions** text box, select all regions by pressing the **CTRL** key and clicking all of the selected regions.
6. From the **Maximum Audio Bit Rate** drop-down list box, select **64 kbps (G.722, G.711)**.
7. From the **Maximum Session Bit Rate for Video Calls** column click the **None** radio button.
8. Click **Save**.

**What to do next**

Configure a Device Pool for Paging, on page 6

---

### Configure a Device Pool for Paging

Perform this procedure to configure a device pool for your paging deployment.

**Before you begin**

Set Default Codec to G.711, on page 6

**Procedure**

1. In Cisco Unified CM Administration, choose **System > Device Pool**.
2. Click **Add New**.
3. In the **Device Pool Name** field, enter **ICVA**.
4. From the **Cisco Unified Communications Manager Group** drop-down list box, select the group that contains the Cisco Unified Communications Manager cluster with which the InformaCast Virtual Appliance will communicate.
Step 5  From the **Date/Time Group** drop-down list box, select a date/time group. Select **CMLocal** unless you are performing dialing restrictions by the time of day.

Step 6  From the **Region** drop-down list box, choose **ICVA**.

Step 7  From the **SRST Reference** drop-down list box, select **Disable**.

Step 8  Click **Save**.

---

**What to do next**

*Configure Partitions and Calling Search Spaces for Paging, on page 7*

---

**Configure Partitions and Calling Search Spaces for Paging**

Perform the following tasks to configure a partition and calling search space (CSS) for paging as follows:

- For Basic Paging deployments, create a single partition and CSS for InformaCast paging.

**Before you begin**

*Configure Region for Paging, on page 5*

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Configure Route Partition for InformaCast Paging, on page 7</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Configure Calling Search Space for InformaCast Paging, on page 8</td>
</tr>
</tbody>
</table>

---

**Configure Route Partition for InformaCast Paging**

Create a route partition for InformaCast paging.

**Before you begin**

*Configure a Device Pool for Paging, on page 6*

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In Cisco Unified CM Administration, choose <strong>Call Routing &gt; Class of Control &gt; Route Partitions</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click <strong>Add New</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the <strong>Name</strong> field, enter the following name and description for the partition: <strong>ICVA-CTIOutbound</strong>, <strong>ICVA-Do not add to any phone CSS</strong>.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>
Configure Calling Search Space for InformaCast Paging

Perform this procedure to configure a calling search space for InformaCast paging.

**Before you begin**

Configure Route Partition for InformaCast Paging, on page 7

**Procedure**

**Step 1** In Cisco Unified CM Administration, choose Call Routing > Class of Control > Calling Search Space.

**Step 2** Click Add New.

**Step 3** In the Name field, enter ICVA.

**Step 4** In the Available Partitions list box, use the arrows to move the following partitions to the Selected Partitions list box.

- The partition that you created for InformaCast paging
- The partitions that contain your users' extensions and any analog paging extensions

**Step 5** Click Save.

What to do next
Configure CTI Ports for Paging, on page 8

Configure CTI Ports for Paging

Perform this procedure to configure CTI ports for your paging deployment. The number of CTI ports that you need depends on your deployment type and your applications' usage:

- For Basic Paging deployments, you must create a minimum of two CTI ports for InformaCast paging.

**Before you begin**

Configure Calling Search Space for InformaCast Paging, on page 8

**Procedure**

**Step 1** In Cisco Unified CM Administration, choose Device > Phone.

**Step 2** Click Add New.

**Step 3** From the Phone Type drop-down list box, choose CTI Port.

**Step 4** In the Device Name field, enter a name for the CTI Port. For example, ICVA-IC-001 for an InformaCast port.
Step 5  In the Description field, enter a description for the port. For example, InformaCast Recording Port for Call Monitoring.

Step 6  From the Device Pool drop-down list box, select ICVA.

Step 7  From the Calling Search Space drop-down list box, select ICVA.

Step 8  From the Device Security Profile drop-down list box, select Cisco CTI Port - Standard SCCP Non-Secure Profile.

Step 9  Click Save.

Step 10  Click OK.

Step 11  In the left association area, click Line [1] - Add a new DN.

Step 12  In the Directory Number field, enter a directory number. This directory number should not be used for any purpose other than making paging calls. It should not be assigned to a phone and should not be within a direct-inward-dialing range.

Step 13  In the Route Partition drop-down list box, select the following ports:

  • For InformaCast ports, select ICVA-CTIOutbound.

Step 14  In the Display (Internal Caller ID) text box, enter InformaCast.

Step 15  In the ASCII Display (Internal Caller ID) text box, enter InformaCast.

Step 16  Click Save.

Step 17  Repeat this procedure for each CTI port that you need.

What to do next
Configure Access Control Group with AXL Access, on page 9

Configure Access Control Group with AXL Access

Perform this procedure to create an access control group that includes AXL access.

Before you begin
Configure CTI Ports for Paging, on page 8

Procedure

Step 1  In Cisco Unified CM Administration, choose User Management > User Settings > Access Control Group.

Step 2  Click Add New.

Step 3  In the Name text box, enter ICVA User Group.

Step 4  Click Save.

Step 5  From the Related Links drop-down, select Back to Find/List and click Go.

Step 6  In the Roles column, click the i icon that corresponds to the new access control group.

Step 7  Click Assign Role to Group.

Step 8  Click Find.

Step 9  Select Standard AXL API Access check box, and click Add Selected.
Configure Application User for Paging

Perform this procedure to configure an application user:

• For Basic Paging, configure an InformaCast application user.

Before you begin

Configure Access Control Group with AXL Access, on page 9

Procedure

Step 1
In Cisco Unified CM Administration, choose User Management > Application User.

Step 2
Click Add New.

Step 3
In the User ID text box, enter a user ID for the application user. For example, ICVA InformaCast.

Step 4
Enter a password in the Password and Confirm Password fields.

Step 5
In the Available Devices list box, click the CTI ports that you created for your deployment and use the arrows to move the devices to the Controlled Devices list box. For example, select ICVA-IC-001 for InformaCast and ICVA-CA-001 for CallAware.

Step 6
Click the Add to Access Control Group button.

Step 7
Click Find.

Step 8
Check the following check boxes (unless otherwise indicated, select these permissions for all application users):

• ICVA User Group
• Standard CTI Allow Control of All Devices
• Standard CTI Allow Control of Phones supporting Connected Xfer and conf
• Standard CTI Allow Control of Phones supporting Rollover Mode
• Standard CTI Enabled

Step 9
Click Add Selected.

Step 10
Click Save.

What to do next

Perform one of the following procedures to enable web access on your phones:

• Enable Web Access for a Phone, on page 11
• Enable Web Access for Common Phone Profile, on page 11
Enable Web Access for a Phone

Perform this procedure in Basic Paging to enable web access for a Cisco Unified IP Phone. You can also use a Common Phone Profile to enable web access for a group of phones that use that profile. For details, see Enable Web Access for Common Phone Profile, on page 11.

Before you begin
Configure Application User for Paging, on page 10

Procedure

Step 1 In Cisco Unified CM Administration, choose Device > Phone.
Step 2 Click Find and select the phone for which you want to enable web access.
Step 3 In the Product Specific Configuration Layout area, from the Web Access drop-down menu, select Enabled.
Step 4 Click Save.

What to do next
Configure Authentication URL, on page 12

Enable Web Access for Common Phone Profile

Perform this procedure in Basic Paging to enable web access for a group of Cisco Unified IP Phones that use a Common Phone Profile. You can also enable web access on an individual phone. For details, see Enable Web Access for a Phone, on page 11.

Before you begin
Configure Application User for Paging, on page 10

Procedure

Step 1 In Cisco Unified CM Administration, choose Device > Device Settings > Common Phone Profile.
Step 2 Click Find and select the profile that applies to the group of phones for which you want to enable web access.
Step 3 In the Product Specific Configuration Layout area, from the Web Access drop-down list, select Enable.
Step 4 Click Save.
Step 5 Click Apply Config to reset the phones that use the Common Phone Profile.
Step 6 Click OK.
Enable Web Access for Enterprise Phone Configuration

Perform this procedure in Cisco Unified Communications Manager to enable web access for a group of Cisco Unified IP Phones that use a Common Phone Profile. You can also enable web access on an individual phone. For more details, see Enable Web Access for a Phone, on page 11.

Before you begin
Configure Application User for Paging, on page 10.

Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In Cisco Unified CM Administration, choose System &gt; Enterprise Phone Configuration.</td>
<td>Set the Cisco Unified Communications Manager authentication URL to point InformaCast.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the Web Access drop-down list, select Enable.</td>
<td>Set Authentication URL, on page 13</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click Save.</td>
<td>Reset Your Phones, on page 13</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click Apply Config to reset the phones that use the Common Phone Profile.</td>
<td>Test Your Phones, on page 14</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click OK.</td>
<td>Verify that the phones in your deployment use the new authentication URL settings.</td>
</tr>
</tbody>
</table>

Configure Authentication URL

Perform the following tasks to configure an authentication URL that points to InformaCast so that when InformaCast pushes broadcasts to Cisco Unified IP Phones, the phones authenticate with InformaCast instead of Cisco Unified Communications Manager.

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Set Authentication URL, on page 13</td>
</tr>
<tr>
<td>Step 2</td>
<td>Reset Your Phones, on page 13</td>
</tr>
<tr>
<td>Step 3</td>
<td>Test Your Phones, on page 14</td>
</tr>
</tbody>
</table>
Set Authentication URL

Perform this procedure to set the Cisco Unified Communications Manager authentication URL to point to the InformaCast Virtual Appliance.

Procedure

**Step 1**
In Cisco Unified CM Administration choose **System > Enterprise Parameters**.

**Step 2**

**Step 3**
Scroll to the **Phone URL Parameters** area, and in the **URL Authentication** field, enter `http://<IP Address>:8081/InformaCast/phone/auth` where `<IP Address>` is the IP Address of the InformaCast Virtual Appliance.

**Note**
Make a note of the existing URL in the **URL Authentication** field. You may need this when you configure InformaCast. See your InformaCast documentation for details.

**Step 4**
Scroll to the **Secured Phone URL Parameters** area, and in the **Secured Authentication URL** field, enter `http://<IP Address>:8081/InformaCast/phone/auth` where `<IP Address>` is the IP Address of the InformaCast Virtual Appliance.

**Step 5**
Click **Save**.

**What to do next**
Reset Your Phones, on page 13.

Reset Your Phones

After you set the authentication URL to point to the InformaCast Virtual Appliance, you must reset your phones. This procedures describes how to manually reset the phones in device pools. There are many methods for resetting your phones. For example, you can also use Bulk Administration Tool to schedule the reset during off hours. See the *Cisco Unified Communications Manager Bulk Administration Guide* for information on the Bulk Administration Tool.

**Before you begin**
Set Authentication URL, on page 13

**Procedure**

**Step 1**
In Cisco Unified CM Administration, choose **System > Device Pool**.

**Step 2**
Click **Find**.

**Step 3**
Click the name of the Device Pool that you want to reset.

**Step 4**
Click **Reset**.
The **Device Reset** dialog box is displayed.

**Step 5**
Click **Reset**.
What to do next

Test Your Phones, on page 14

Test Your Phones

Verify that your phones are authenticating with the InformaCast Virtual Appliance.

Before you begin

Reset Your Phones, on page 13.

Procedure

Step 1
In Cisco Unified CM Administration, choose Device > Phone.

Step 2
Use the drop-down menus and fields in the Find and List Phones window to filter your search for a phone that should be using the new authentication URL, and click Find.

Step 3
For the phone that should be using the new settings, click the IP Address link in the IPv4 Address column.

Step 4
Click Network Configuration.
The Network Configuration page appears.

Step 5
Verify that the Authentication URL field displays the InformaCast Virtual Appliance IP address that you entered for the URL Authentication enterprise parameter. If the correct URL does not appear, you will need to set the authentication URL.

What to do next

For Basic Paging, you can now start using paging services.

Advanced Notification Paging Configuration Task Flow

Perform the following tasks to integrate InformaCast Paging Server with Cisco Unified Communications Manager for IP paging and emergency call alerting. It includes the following features:

- InformaCast advanced notification
- Panic button configuration
- Text and audio notification to IP phones when a user dials an emergency services number (CallAware)

Procedure

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Install the InformaCast Virtual Appliance, on page 15.</td>
<td>Download the InformaCast OVA file from the Singlewire website and upload it to vSphere.</td>
</tr>
<tr>
<td><strong>Step 2</strong> Configure Connection to InformaCast, on page 17.</td>
<td>Configure Cisco Unified Communications Manager and InformaCast.</td>
</tr>
<tr>
<td>Command or Action</td>
<td>Purpose</td>
</tr>
<tr>
<td>-------------------------------------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Step 3</strong> Configure Panic Button, on page 18.</td>
<td>Configure a panic button to send a text and audio notification to IP phones.</td>
</tr>
<tr>
<td><strong>Step 4</strong> Configure CallAware Emergency Call Alerting, on page 20.</td>
<td>Configure emergency call text and audio notifications.</td>
</tr>
</tbody>
</table>

**Install the InformaCast Virtual Appliance**

Singlewire supports InformaCast Virtual Appliance on the VMware ESXi platform, which is managed through the vSphere client.

**Before you begin**

Import InformaCast Virtual Appliance using the vSphere client. This can be downloaded from your VMware server.

**Procedure**

**Step 1** Download the OVA file from the Singlewire website and then log in to the vSphere client.  
*Note* If you are using InformaCast on the Communications Manager Business Edition 6000, you are supplied with a DVD in a package with an OVA on it (physical media).

The vSphere Client window appears.

**Step 2** From the vSphere Client window, choose File > Deploy OVF Template.  
The Deploy OVF Template dialog box appears.

**Step 3** Click the Deploy from File radio button and then click Browse to select the saved the OVA file (or to the OVA file on the supplied DVD). After you select the OVA file, click Open.  
The Source location is selected in the Deploy OVF Template dialog box.

**Step 4** Click Next to continue.  
The Deploy OVF Template dialog box refreshes and OVF Template Details appears.
Step 5  Click Next to verify the Name and Location, and then click Next to select the network to store the new virtual machine files.

Tip  It is good practice to place the Virtual Appliance on the same VLAN as your Cisco Unified Communications Manager.

Step 6  Click Next to continue, and then click Finish.
The InformaCast Virtual Appliance begins importing.

Step 7  From the vSphere Client window, click Hosts and Clusters icon and then select your host server.
The vSphere Client window refreshes.

Step 8  Click the Configuration tab and select the Virtual Machine Startup/Shutdown link in the Software section.

Step 9  Click the Properties link.
The Virtual Machine Startup and Shutdown dialog box appears.

Step 10  Check the Allow virtual machines to start and stop automatically with the system check box under System Settings.

Step 11  Under Startup Order, scroll to the Manual Startup section and select your virtual machine (by default, this is Singlewire InformaCast VM), and then move it from the Manual Startup section to the Automatic Startup section, by using the Move Up button. After moving it, click OK.
The InformaCast Virtual Appliance starts and stops automatically with the server on which it is hosted. Now you can turn on InformaCast's virtual machine and set its network configuration.

Step 12  Choose View > Inventory > VMs and Templates and then select your virtual machine.

Step 13  Choose the Inventory > Virtual Machine > Open Console
The Singlewire InformaCast VM console window appears.

Step 14  InformaCast configuration starts for the first time. During this configuration, perform the following tasks for the InformaCast Virtual Appliance:
   a)  Accept Cisco End User License Agreement (EULA)
   b)  Accept Singlewire EULA
   c)  Set up hostname
   d)  Set up IP address, subnet mask, and default gateway
   e)  Set up DNS server IP address and domain name
   f)  Set up NTP server IP address or hostname
   g)  Set up time zone
   h)  Set up Secure Socket Layer (SSL) certificate parameters
   i)  Set up SSL subject alternate names (optional)
   j)  Set up the OS admin password
   k)  Set up the InformaCast and PTT (PushToTalk) admin password. This password is required to connect the Cisco Unified Communications Manager and InformaCast in the Cisco Unified CM Administration, Advanced Features > Emergency Notifications Paging.
   l)  Set up security passphrase for backup and communication
When your configuration is successful, the “Welcome to Singlewire InformaCast” message is displayed.

Step 15  Click Continue to work with Singlewire InformaCast.

What to do next
Configure Connection to InformaCast, on page 17.
Configure Connection to InformaCast

Use this procedure to load the InformaCast certificate to the Cisco Unified Communications Manager Tomcat trust store.

Before you begin
Install the InformaCast Virtual Appliance, on page 15.

Procedure

Step 1

Step 2
In the Introduction to InformaCast Emergency Notifications page, click Next to continue. The Installing the InformaCast Virtual Appliance page appears.

Step 3
In the Installing the InformaCast Virtual Appliance page, click Next to continue.

Note
You should have successfully installed InformaCast Virtual Appliance to configure with the Cisco Unified Communications Manager.

Step 4
In the IP address of InformaCast VM field, enter either IP address or Hostname.

Note
By default, the username is stated as admin in the Username to use in InformaCast field, and it is not editable.

Step 5
In the Password for admin app user field, enter the administrator password of the InformaCast application. The dialog box displaying the thumbprint of InformaCast certificate is displayed.

Step 6
Click OK to load the InformaCast certificate to the Cisco Unified Communications Manager Tomcat trust store. Configuration process starts.

Note
When the configuration is successful, the Status field displays the completion status.

Step 7
Click Next.
The wizard performs the following tasks:

• Activates SNMP service
• Configures SNMP Service with locally generated random credentials
• Activates CTI Manager Service
• Configures Cisco Unified Communications Manager for InformaCast
  • Creates new region (1 per cluster)
  • Creates new device pool (1 per cluster)
  • Creates SIP trunk (1 per cluster)
  • Creates route group (1 per cluster)
  • Creates route list
Configure Panic Button

Use this procedure to configure a panic button to send a text and audio notification to IP phones. This allows you to initiate a one click alarm if there is emergency.

Before you begin
Configure Connection to InformaCast, on page 17.

Procedure

Step 1

Step 2
In the Introduction to InformaCast Emergency Notifications page, click Next to continue.

Step 3
In the Installing the InformaCast Virtual Appliance page, click Next to continue.

Step 4
In the Connecting Cisco Unified Communications Manager and InformaCast page, click Next to continue. The Configuring a Panic Button page appears.

Step 5
From the Choose pre-recorded message by name drop-down list, select the pre-recorded message to be displayed on Cisco Unified IP phones and various devices and systems in emergency.

Note You can change the pre-recorded message in InformaCast administration, as required.

Step 6
In the Enter DN to trigger the panic button field, enter the Directory Number (DN), which includes the digits 0 to 9, asterisks (*), and pound signs (#). Default value is ***5.

Step 7
From the Route Partition drop-down list box, select a partition to restrict access to the route pattern.

Note If you do not want to restrict access to the route pattern, select <None> for the partition.

Step 8
Click Choose Phones to Send Notification button. The Phones to Send Notification dialog box appears.
Step 9 From the **Phones to Send Notification** dialog box, select the Cisco Unified IP phones to send the pre-recorded message. The dial pattern entered by you (for example, ***5) is configured as speed dial on the selected phones. The selected Cisco Unified IP phones are displayed in the **Selected Phones to Send Notification** list box.

Step 10 Click **Add Rules**, to create a new rule for the selected Cisco Unified IP Phones to receive notifications.

a) Select one of the parameters from the drop-down list box. The available options are Device Pool, Description, and Directory Number.

b) In the second drop-down list box, select a criteria from the following options:
   - Does
   - Does not

c) In the third drop-down list box, select a criteria from the following options:
   - Begins with
   - Ends with
   - Contains

d) In the text box, enter the search criterion.

   **Note** Minimum of one new rule and maximum of new five rules can be created. The **Add Rules** button gets disabled when five rules are created.

   **Note** To delete a rule, click **Delete Rules** button.

e) Click **Test Rules**, to validate the created rules. When the test rule is completed with more than zero phones, the **Next** button is enabled.

   **Note** Phones added to Cisco Unified Communications Manager at a later date that match this rule will be included as recipients in notifications to this group.

Step 11 Click **Next**.

The wizard performs the following tasks:

- Adds a speed dial for the entered DN to the selected phones. If the selected phones have unused speed dials assigned to existing phone button templates, this speed dial appears directly on the selected phones. If the selected phones do not have unused speed dial buttons, the panic button speed dial is created, but it does not appear on the phone.

- Adds route pattern for entered DN in selected partition using created route list.

- Creates an InformaCast DialCast entry for the entered DN to send the selected message to the phones matching the selected rules.

---

**What to do next**

Configure CallAware Emergency Call Alerting, on page 20.
Configure CallAware Emergency Call Alerting

Use this procedure to configure the CallAware emergency call alerting details. This sends a text and audio notification to IP phones when an emergency number is dialed. It can also detect calls to numbers other than 911.

Before you begin

Configure Panic Button, on page 18.

Procedure

Step 1  From Cisco Unified CM Administration, choose Advanced Features > Emergency Notifications Paging. The Emergency Notifications Paging wizard appears.

Step 2  In the Introduction to InformaCast Emergency Notifications page, click Next to continue.

Step 3  In the Installing the InformaCast Virtual Appliance page, click Next to continue.

Step 4  In the Connecting Cisco Unified Communications Manager and InformaCast page, click Next to continue.

Step 5  In the Configuring a Panic Button page, click Next to continue. The Configuring CallAware Emergency Call Alerting page appears.

Step 6  From the Choose pre-recorded message by name drop-down list, select the pre-recorded message to be displayed on Cisco Unified IP phones and various devices and systems in emergency.

Note You can change the pre-recorded message in InformaCast administration, as required.

Step 7  Click Choose Emergency Route Patterns button. The Route Patterns dialog box appears.

Step 8  From the Route Patterns dialog box, select the route patterns by checking the box next to the desired patterns.  
a) Click the Save Selected/Changes button.  
The selected route patterns are displayed in the Selected Route Patterns list box.

Step 9  Click Add Rules, to create a new rule for the selected Cisco Unified IP Phones to receive notifications.

a) Select one of the parameters from the drop-down list box. The available options are Device Pool, Description, and Directory Number.

b) In the second drop-down list box, select a criteria from the following options:

   • Does
   • Does not

c) In the third drop-down list box, select a criteria from the following options:

   • Begins with
   • Ends with
   • Contains

d) In the text box, enter the search criterion.

Note Minimum of one new rule and maximum of five new rules can be created. The Add Rules button gets disabled when five rules are created.

Note To delete a rule, click Delete Rules button.
e) Click **Test Rules**, to validate the created rules. When the test rule is completed with more than zero phones, the **Finish** button is enabled.

**Note**  Phones added to Cisco Unified Communications Manager at a later date that match this rule will be included as recipients in notifications to this group.

**Step 10**  Click **Finish**.

The wizard performs the following tasks:

- Adds External Call Control profile for InformaCast
- For each selected route pattern, modify that route pattern to reference the External Call Control profile
- Creates a recipient group with rules that match phones to receive the notification
- Creates an InformaCast routing request with the selected message and recipient group

The **Summary** page appears and confirms the successful configuration of InformaCast with Cisco Unified Communications Manager. For more information, see [https://www.singlewire.com](https://www.singlewire.com).

---

**Paging Interactions**

- Advanced Notification Paging Interactions, on page 21

**Advanced Notification Paging Interactions**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Interaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emergency Notifications Paging</td>
<td>You can configure the Emergency Notifications Paging wizard using InformaCast Release 11.5(1)SU3 and later versions in basic paging mode only.</td>
</tr>
<tr>
<td></td>
<td>You can configure call monitoring to route patterns that contain digits only in the Emergency Notifications Paging wizard. For route patterns that contain wildcard characters, configure in InformaCast.</td>
</tr>
</tbody>
</table>