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C H A P T E R 1
Introduction to the Cisco Business Edition
7000H/M

• Who Should Use This Guide?, on page 1
• Essential Documents for Installation of the Business Edition 7000H/M Appliances, on page 2

Who Should Use This Guide?
This guide helps you to set up your Business Edition appliances. It also covers everything that you need to
do to customize it for your business needs.

Answer the following questions to process with the setup.

• Are you performing a manual installation of applications on a Cisco Business Edition appliance using
the factory-loaded software?

• Are you installing application versions from Collaboration System Release 12.7 , 14 or later? If yes, this
installation guide applies. If no, then your applications may not support ESXi 7.0 and you cannot leverage
the factory-loaded software.

Business Edition 7000 Appliances are shown in following:

Figure 1: Business Edition 7000 Appliances
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Cisco partners can find more information on http://www.cisco.com/go/bepartner.Note

Do not reinstall the factory loaded virtualization software. Do not reformat the disks or rebuild the storage
hardware array. Either action wipes out the factory preloaded software and causes post installation licensing
problems.

Caution

Essential Documents for Installation of the Business Edition
7000H/M Appliances

You can proceed with the installation by using the instruction in this document alone, refer the following
documents that are listed for Deployment Options, Equipment, and Applications. All of these documents are
available at the http://www.cisco.com/go/virtualized-collaboration and http://www.cisco.com/go/be7000.

Choose the product version, and then refer to the following documents:

• Deployment Options—To gain insights to help you plan your deployment, see the Preferred Architecture
guides and the Cisco Validated Designs that are relevant to your business needs.

• Equipment—Use the Quick Start Guide to unpack the appliance and install it in a rack.

• Applications—To find out more about applications, see the following documents:

• Cisco Business Edition 6000 and Cisco Business Edition 7000 Co-residency Policy
Requirements—This document contains information on the Cisco virtualized applications that are
available for installation on a Cisco Business Edition 7000 system and the conditions that you must
meet to run those applications and any third-party applications on a Business Edition appliance.

• Business Edition 7000 Software Load Summary—This document contains information on ISO and
OVA files that are pre-loaded in your server's datastore.

• Other documents for UC applications are listed on the Component Documentation tab.
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C H A P T E R 2
Installation of Cisco Business Edition 7000H/M

• Design Your Deployment, on page 3
• Set Up Your Appliance, on page 5
• Set Up Your Applications, on page 13

Design Your Deployment
Review the following topics to design your deployment.

Plan Your UC Applications
Before You Begin:

Ensure that your Cisco Business Edition 7000 server is rack-mounted and connected to power and data
networks. For instructions, refer to the Quick Start Guide for Cisco Business Edition that was packaged with
your server. You can also download a copy at:

https://www.cisco.com/c/en/us/support/unified-communications/business-edition-7000/
products-installation-guides-list.html

Before you begin any installation, plan which UC applications you are going to install.

For information on the UC applications that are available for installation, and on how to design your Business
Edition collaboration deployment refer to the following sites:

• Cisco Business Edition 6000 and Cisco Business Edition 7000 Co-residency Policy Requirements—This
document contains information on the Cisco virtualized applications that are available for installation
on a Cisco Business Edition 7000 system and the conditions that you must meet to run those applications
and any third-party applications on a Business Edition server.

https://www.cisco.com/c/en/us/support/unified-communications/business-edition-7000/
products-implementation-design-guides-list.html

• Unified Communications in a Virtualized Environment—This website contains information on Cisco
Collaboration Virtualization applications and how to design your deployment.

http://www.cisco.com/go/virtualized-collaboration

• Preferred Architecture Guides for Enterprise—Preferred Architecture documents and CVD guides offer
prescriptive, end-to-end system solutions for Collaboration and Voice deployment. The design overviews
provide a basic understanding of the products and their roles in the Preferred Architectures, including
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high-level best practices. The CVDguides providemore detailed design and deployment recommendations
that help streamline the implementation of Preferred Architectures.

http://www.cisco.com/go/pa

• Enterprise Collaboration CVD Guides—Enterprise CVDs provide detailed design and step-by-step
deployment information for collaboration solutions that are built on the Cisco Business Edition 7000.
These CVDs are based on the core recommendations of the Preferred Architectures, and in some cases,
they offer more solution designs as extensions or alternatives to the Preferred Architectures.

http://www.cisco.com/go/pa

• Business Edition 7000 Software Load Summary—Preload Summary documents provide information on
ISO and OVA files that are pre-loaded in your server's datastore.

http://www.cisco.com/c/en/us/support/unified-communications/business-edition-7000/
%20products-release-notes-list.html

Collect Required Network Information
Before you begin the installation, collect the following network information for your solution.

Collect the following network settings for your installation:

• Subnet mask

• Gateway IP Address

• VMware vSphere ESXi management IP address

• Cisco Integrated Management Controller (CIMC) IP address

• UC application IP addresses

• DNS server IP address

• UC application hostnames

• (Optional) Domain name

• NTP server IP address

• Time zone

• (Optional) SMTP server

For general information on the Cisco UCS C240 M5SX server used in Cisco Business Edition 7000, see the
Cisco UCS C240 M5 Server Installation and Service Guide. Cisco Intersight, Cisco UCS Manager, Cisco
CIMC Supervisor do not support managing BE7000 appliances.

Note

For the full range of possible configuration settings options, consult Cisco UCS C240 M5 Rack Server (Small
Form Factor Disk Drive Model) Spec Sheet, Cisco UCS C Server Installation and Service Guide and
docs.vmware.com.

Available physical ethernet ports depend on the appliance model:
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• All M5 appliance models include modular LAN on motherboard ports as described in the Cisco UCS
C240 M5 Rack Server (Small Form Factor Disk Drive Model) Spec Sheet.

• BE7000M and BE7000Hmodels include additional ports via a network interface card. It is not supported
on any appliance model to add network interface cards, add virtual interface cards, or change included
network interface card.

Available VMware vSphere ESXi configuration settings options depend on what license is being used. If your
appliance is using an embedded virtualization license,VMware vSphere ESXi distributed virtual switch features
are not enabled.

Set Up Your Appliance
Review the following topics before you begin your installation.

Installation of Virtualization and Application Software
This section describes the tasks that you must perform to install virtualization and application software on
your Business Edition 7000, using the factory preload.

Preloaded File Types in the Datastore
In addition to pre-deployed virtual machines, Cisco Business Edition servers are shipped with selected
Collaboration application software that is pre-loaded on the datastore. Following is a breakdown of the file
types for application installs:

• ISO Files—An ISO file is a DVD image containing application install files (for example,
Bootable_UCSInstall_UCOS_12.5.1.10000-22.sgn.iso).

An ISO file is present for a UC application only if the OVA file for that application does not include the
application software.

• OVA Files—Each UC application has an associated Open Virtualization Archive (OVA) file, which is
used to package and deploy the virtual machine. There are two types of OVAs for Business Edition
servers:

• SomeOVAs (e.g. cucm_12.5_vmv13_v1.0.ova) are templates that define the VM, but do not include
any application software. For those applications, there is an associated ISO file in the datastore (for
example, Bootable_UCSInstall_UCOS_12.5.1.10000-22.sgn.iso). For the installation, you must
deploy the OVA template and install the software using the associated ISO file.

• Other OVA files define the VM and include the application software (for example,
Bootable-CiscoPagingServer_12.5.1.ova). For these applications, there is no ISO file. You can
deploy the VM and install the software using the OVA file.

For information on which ISO and OVA files are pre-loaded in your server's datastore, refer to the preload
summary for your server at the http://www.cisco.com/c/en/us/support/unified-communications/
%20business-edition-7000/products-release-notes-list.html.
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Cisco recommends that you archive the OVA-ISO directory locally. If there is a hardware failure, replacement
hardware does not include a factory preload. If the factory preloaded software is either deleted, overwritten,
or lost, then manual rebuild of preloaded software is required. Restore to the factory default capability is not
supported.

Note

Installation Task Flow of Cisco Business Edition 7000H/M
Perform the following tasks to install software on your Cisco Business Edition 7000 server.

Procedure

PurposeCommand or Action

Configure CIMC for your Business Edition
7000 server.

Configure Cisco Integrated Management
Controller, on page 6

Step 1

Configure the pre-installed VMware vSphere
ESXi software on the appliance.

Customize Virtualization Software Remote
Access, on page 8Customize Virtualization
Software Remote Access, on page 8

Step 2

Delete any pre-deployed VMs that you do not
require.

Delete Unused or Unwanted Virtual Machines,
on page 12

Step 3

Configure Cisco Integrated Management Controller

Cisco Integrated Management Controller (CIMC) is the management interface for the Cisco UCS appliance.
CIMC runs within the appliance, allowing remote administration, configuration, andmonitoring of the appliance
through web or SSH command-line access.

Complete the following tasks to configure CIMC on a Business Edition 7000 appliance for customized and
preconfigured deployments.

Complete the following tasks to Configure Cisco Integrated Management Controller:

Procedure

PurposeCommand or Action

Power on and Initial CIMC Setup, on page 6Step 1

Complete the CIMC Configuration, on page 8Step 2

Power on and Initial CIMC Setup

Use this procedure to power on the appliance and begin the basic Cisco Integrated Management controller
(CIMC) configuration.

Before you begin

Ensure that the Business Edition 7000 appliance has been rack-mounted, connected to a power supply,
connected to the data network, and that a monitor and keyboard are connected to the appliance, as described
in the Quick Start Guide.
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Procedure

Step 1 Verify that power is connected and that the power button LED is orange.
Step 2 Push the appliance power button and verify that it changes to green.
Step 3 Watch the boot process on the monitor.
Step 4 When the blue Cisco logo appears, press F8 to enter the CIMC configuration dialog.

Figure 2: Press F8 at the CIMC Boot Screen

Step 5 When prompted, enter the username admin and create a new password.
Step 6 On the CIMC configuration screen, complete the following details:

• CIMC IP address
• Subnet mask
• Gateway IP address

Figure 3: Enter the CIMC IP Address Details

Step 7 When complete, press F10 to save your changes and boot the system.
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Complete the CIMC Configuration

Use this procedure to configure DNS and NTP settings in the CIMC interface.

Before you begin

Power on the server and begin basic Cisco Integrated Management Controller(CIMC) configuration.

Procedure

Step 1 In a web browser, enter the CIMC IP address and log in with the username admin and the password that you
created in the previous task.

Step 2 From the left hand menu, select the Admin tab, and click Network.
Step 3 In the main screen, select the Network Settings tab.
Step 4 From Common Properties, change the Hostname setting to the CIMC hostname.
Step 5 From IPv4 Properties, change Preferred DNS Server to the IP address that you have specified for the DNS

server.
Step 6 In the main screen, select the NTP Settings tab.
Step 7 Check the Enable NTP check box.
Step 8 In the Server 1 field, enter the NTP server IP address.
Step 9 Select Save Changes from the bottom right hand corner of the page.

Configure VMware vSphere Hypervisor

Complete the following tasks to set up the VMware vSphere hypervisor:

Procedure

PurposeCommand or Action

Customize VMware vSphere hypervisor
Remote Access.

Step 1

Access and Configure the VMware vSphere
hypervisor.

Step 2

Customize Virtualization Software Remote Access

Follow this procedure to customize the VMware vSphere ESXi to enable remote access from your PC using
the VMware Embedded Host Client.

BE7000 appliances are factory loaded with ESXi 7.0 and vmfs6. If you want to change the vmfs version,
check application support and note you will have to rebuild the appliance.

Note
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Procedure

Step 1 When the hypervisor boots, the ESXi Direct Console User Interface displays on the monitor as shown in the
following figure.

Figure 4: Console Screen After ESXi Loads

Step 2 Press F2 to enter the System Customization menu as shown in the following figure.

Figure 5: ESXi System Customization Menu

The default username is root and default password is c!SCo123.
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Step 3 After logging in, you must change the default password. ChooseConfigure Password to change the password.

If your applications are predeployed, skip to 5 .

Step 4 To assign a static IP address, select the Configure Management Network menu, and follow the instructions
on the screen to change “IP Configuration”.

Figure 6: Assign Static IP Address to ESXi Host

Step 5 Connect your PC to the data network, and browse to the new hypervisor IP address.

Figure 7: Hypervisor Welcome Page
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Access and Configure Virtualization Software

Some Business Edition applications require the host to have a valid time reference. Follow these steps to
access the ESXi host to configure NTP and configure fault tolerance for network interface cards (NICs) using
the NIC teaming feature, view preinstalled applications, and browse the datastore to verify the preloaded
collaboration application software.

Procedure

Step 1 Browse to the “https://[ESXI-HOST-IP-Address]/ui/” to access VMware Embedded Host Client.

Figure 8: Access Virtualization Software Using VMware Embedded Host Client

Step 2 Use the login credentials that you previously configured.
Step 3 If selected at time of quoting, BE 7000 appliances are factory loaded with a Collaboration embedded OEM

license for Cisco Business Edition Embedded Virtualization Basic Plus . If you want to use this license, it is
ready for use. If you want to re upload or version-upgrade this license, follow these steps:
a) Locate your license document that has license serial number for the Cisco Business Edition Embedded

Virtualization license . For installations, license serial number ships from the factory along with the
appliance. For version-upgrades, license serial number ships from the My Cisco Entitlements (MCE)" on
cisco.com.

b) Navigate to Manage > License > Assign License.
c) Type in or copy or paste the license serial number from the license document. Never add these licenses

into vCenter.
d) Click Check License to validate the license key.

"Embedded virtualization licenses do not work the same way as general-purpose vSphere ESXi
licenses or Partner Activation Codes (PAC). They are hardcoded to 2-CPU, pre combined, and
cannot split or expand through myvmware.com. They are neither a VMware Partner Activation
Code (PAC) nor a Cisco Product Authorization Key (PAK). They are pre activated, no registration
or activation on myvmware.com or cisco.com required. They does not support installation through
vCenter, license pooling in vCenter, or any vCenter features.

For more details, see Appendix A.

Note

Step 4 Configure NTP settings:
a) Navigate to Manage > System > Time & date.
b) Click Edit settings to launch the Edit time configuration screen.
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c) Check Manually configure the date and time on this host check box.
d) Update the Time.
e) Check the Use Network Time Protocol (enable NTP client) check box.
f) Select Start and stop with host from NTP service startup policy drop-down.
g) Type the IP address of NTP server in NTP servers. If you want to add multiple NTP servers, type the IP

address of NTP servers that are separated by commas.
h) Click Save.

Step 5 (Optional) Configure fault tolerance by using the NIC teaming feature in VMware:
a) Navigate to the Networking > Management Network.
b) Click Edit settings to launch Edit port group- Management Network.
c) In the Edit port group- Management Network screen, enter the name, VLANID, Virtual switch.
d) Expand NIC teaming, enter the required details.
e) Click Save to add the NIC that is connected to the data network.

By default, only one NIC is enabled for the hypervisor and identified as vmnic0.Note

Step 6 Browse the datastore:
a) Navigate to Storage > Datastore to list the datastores in the Business Edition appliance.
b) Select datastore1.
c) Click the Datastore browser. You can view the Preloaded Collaboration Virtual Machines and preloaded

software.

You must select the VMFS6 file type while creating the datastore.Note

Figure 9: Browse Datastore to View Preloaded Collaboration Virtual Machines and Preloaded Software

Step 7 (Optional) Cisco recommends that you archive the OVA-ISO directory locally. If a appliance fails, the
replacement hardware will not include preloaded content.

Delete Unused or Unwanted Virtual Machines
You can optionally delete unused or unwanted preloaded files to free up disk space or make room for subsequent
installations in the following scenarios:
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• If you want to deploy a new application version or patch level than the existing factory-preloaded
application.

• If you do not want to run a particular preloaded application and its files.

Procedure

Step 1 Log in to VMware Embedded Host Client.

Figure 10: Delete Any VMs That You Are Not Using

Step 2 Expand Virtual Machines and locate the virtual machine that you want to delete.
Step 3 If the VM has a green triangle, right-click the icon and select Power > Power Off.

The green arrow disappears as the VM powers off.
Step 4 Right-click the VM and select Delete.
Step 5 Repeat this procedure for each virtual machine that you wish to remove.

Set Up Your Applications
Perform the following tasks to set up your applications on Cisco Business Edition 7000 appliance.

Procedure

PurposeCommand or Action

Deploy virtual machine OVAs for each UC
application that you want to install.

Deploy Virtual Machine OVAs, on page 14Step 1
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PurposeCommand or Action

If your Business Edition 7000 deployment
includes Cisco Unity Connection, customize
the Unity Connection VM.

Customize Virtual Machines for Cisco Unity
Connection, on page 15

Step 2

For UC application installations that require an
ISO file, mount the ISO file on the application
VM.

Associate Application ISO Files to Virtual
Machines, on page 16

Step 3

For a list of applications that use ISO
installation files, see the Preload
Summary for your appliance.

Note

Optional. Use touchless installation to install
any of the following core UC applications:

Install UC Applications Using Touchless
Installation, on page 17

Step 4

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

If you prefer, you can use manual
installation for these applications.

Note

Use the manual interactive process to install
any remaining UC applications.

Install UC Applications Manually, on page 20Step 5

Deploy Virtual Machine OVAs
For each application that you want to run, requires one of the preloaded virtual machine OVA files. If a new
version is preferred, then it is recommended to delete the existing version.

Depending on the preloaded application, the OVA contains any of the following applications:

• Fully installed ready to run application

• Partially installed application

• VM configuration alone for an empty virtual machine

For more details, see the Preload File Summaries in Release Notes at the http://www.cisco.com/c/en/us/support/
unified-communications/business-edition-7000/products-release-notes-list.html.

The OVA template files that contain empty virtual machines are deployed in seconds, while larger OVA files
that contain partially or fully installed applications can take longer to deploy.

Note
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If you rebuild your appliance to use ESXi 6x, then ensure proper operation of your appliance and any embedded
virtualization licenses, ensure it is running ESXi 6.5 U2 or greater, with the Cisco UCS-specific image of
ESXi.

Caution

Procedure

Step 1 On the VMware Embedded Host Client, navigate to the Virtual Machines.
Step 2 Right-click the Virtual machines and select the Create/Register VM.
Step 3 Select Deploy a virtual machine from an OVF or OVA file as select creation type.
Step 4 Specify a meaningful name for the virtual machine.
Step 5 Browse and select the source OVA template file on your PC. For application and filename mapping, see the

Build Summary PDF in the datastore OVA-ISO directory, or download from here: https://www.cisco.com/c/
en/us/support/unified-communications/business-edition-7000/products-release-notes-list.html.

Step 6 Select the datastore in which to store the configuration and disk files.
Step 7 Select the deployment options.
Step 8 If prompted to accept license agreements, continue to click Next.
Step 9 Select the deployment options.
Step 10 If prompted for the Disk Format, specify Thick Provision Lazy Zero.
Step 11 Review your settings selection before finishing the wizard.
Step 12 Click Next.
Step 13 Deploy VMs for all your UC applications before proceeding to the next task.

If your system includes Cisco Unity Connection, thenCustomize Virtual Machines for Cisco Unity Connection.
Otherwise, Associate Application ISO Files to Virtual Machines.

Customize Virtual Machines for Cisco Unity Connection
For Customized installations, use this procedure to configure your Cisco Unity Connection virtual machine
settings to ensure optimum performance.

Preconfigure

Before you begin

For Customized installations, use this procedure to configure your Cisco Unity Connection virtual machine
settings to ensure optimum performance. Deploy Virtual Machine OVAs, on page 14

Procedure

Step 1 On VMware Embedded Host Client, navigate to the Virtual Machines.
Step 2 Right click the Unity Connection entry and select Edit Settings.
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Step 3 If you want to use the Unity Connection, or Unified, or Integrated Messaging, do the following:
a) Select the Virtual Hardware tab.
b) Select the CPU menu and set the number of Cores per Sockets to 2.
c) In the Reservation tab, increase the reservation to 5.06MHz.

For more information, see the https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/12x/
supported_platforms/b_12xcucspl.html.

Associate Application ISO Files to Virtual Machines
If you have deployed a skip-install OVA that contains any of the following partially installed applications,
skip this step.

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Emergency Responder

If you have deployed an OVA that contains ready to run fully installed applications, skip this step.

For all other OVA files that contain only VM configurations of empty virtual machines, use this procedure
to associate the ISO installation files that is used to complete the installation.

For an up to date list of installation files for your appliance, see the Preload Summary for your appliance in
the datastore OVA-ISO directory or at: https://www.cisco.com/c/en/us/support/unified-communications/
business-edition-7000/products-release-notes-list.html.

Note

Procedure

Step 1 In the VMware Embedded Host Client, select the UC application virtual machine.
Step 2 Click Edit .
Step 3 From Virtual Hardware tab, select CD/DVD Drive 1.
Step 4 Select Datastore ISO File from CD/DVD Drive 1 drop-down list.
Step 5 Browse to the datastore and locate the application ISO file.
Step 6 Select the file and click Select.
Step 7 In CD/DVD Drive 1, check the Connect at power on check box under the Status.
Step 8 Repeat this procedure for each application that you want to install that includes an ISO file.
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Install UC Applications Using Touchless Installation
Touchless installation allows you to install multiple UC applications and virtual machines of an application
simultaneously, across the different hosts if necessary, without having to interact with the system while the
install process runs. While you must prepare the system, touchless installation can save time, particularly if
you want to install multiple applications. If you are installing only one or two applications, you may prefer
to follow the manual procedure in the following section.

Use touchless installation to install the following applications:

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Prime Collaboration Deployment

Procedure

PurposeCommand or Action

Generate answer files (AFG files) for UC
applications.

Generate Answer Files, on page 17Step 1

Use your AFG files to create virtual floppy
images.

Create Virtual Floppy Images, on page 18Step 2

Upload your virtual floppy images to the
datastore.

Upload Virtual Floppy Images to Datastore, on
page 19

Step 3

Mount each virtual floppy on the corresponding
UC application VM.

Mount Virtual Floppy on Virtual Machines and
Set Boot Option, on page 19

Step 4

Run the touchless installation of your UC
applications. We recommend that you run your
installations simultaneously.

Run Touchless Installation, on page 20Step 5

Generate Answer Files
Use this procedure to generate answer files for the touchless installation of your UC applications.

We recommend that you create application-specific folders (for example, UCM, IMP, CUC, CCX) in which
to save the generated files so that you do not get the files mixed up.

Tip

Procedure

Step 1 Go to the online answer file generator at: www.cisco.com web cuc_afg .
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Step 2 From the Product drop-down list, select the UC application for which you want to generate answer files.
Step 3 Select the Version that you want to install.
Step 4 Complete the remaining fields with the installation details that you want to configure on the appliance. For

example, you can assign items such as passwords, IP addressing, and DNS settings.
Step 5 Click Generate Answer Files to generate the platformConfig.xml file for that UC application.

Each UC application generates a platformConfig.xml file. Cisco Unified Communications Manager
also generates a clusterConfig.xml file.

Step 6 Save the generated answer files as follows:

• For Cisco Unified Communications Manager, save both the platformConfig.xml and
clusterConfig.xml files in the UCM folder.

• For other UC applications, save the platformConfig.xml file in the relevant application folder.

Step 7 Repeat these steps for each UC application for which you want to use touchless installation.

Create Virtual Floppy Images
Use this procedure to create virtual floppy images from the answer files. You will use the virtual floppy images
in your touchless installation.

We recommend that you follow the recommended naming conventions for your .flp files.Tip

Before you begin

1. You can use Winimage to create the virtual floppy images. You can download Winimage from
http://www.winimage.com/download.htm. You can also use other tools, such as BFI, to create virtual
floppy images.

2. Generate Answer Files, on page 17

Procedure

Step 1 In Winimage, select File > New.
Step 2 From the Standard format, select 1.44 MB and click OK.
Step 3 Drag the platformConfig.xml file for the UC application onto the Winimage window.
Step 4 When prompted to inject the file into Winimage, click Yes.
Step 5 Cisco Unified Communications Manager only. Drag the clusterConfig.xml file onto the Winimage

window.
Step 6 Select File > Save As.
Step 7 Save the file as a virtual floppy image (.flp file) using the following naming conventions:

• Cisco Unified Communications Manager—ucm.flp
• IM and Presence Service—imp.flp
• Cisco Unity Connection—cuc.flp
• Cisco Unified Contact Center Express—ccx.flp
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Step 8 Repeat this procedure for each UC application for which you want to use touchless installation.

Upload Virtual Floppy Images to Datastore
Use this procedure to upload the virtual floppy images to the datastore.

Before you begin

Create Virtual Floppy Images

Procedure

Step 1 Start the VMware Embedded Host Client.
Step 2 Select Storage.
Step 3 Right-click on a datastore and Browse the datastore.
Step 4 Navigate to the destination directory and click the Upload icon.
Step 5 Upload the vFloppy images to the AFG folder.
Step 6 At the Upload/Download warning, click Yes.
Step 7 Close the Datastore Browser window.

Mount Virtual Floppy on Virtual Machines and Set Boot Option
Use this procedure to mount the UC application virtual floppy images on their corresponding VM.

This step is not required for predeployed VMs as they are already configured.Note

Before you begin

Upload Virtual Floppy Images to Datastore

Procedure

Step 1 In the VMware Embedded Host Client, select the UC application virtual machine.
Step 2 Select Virtual Machine.
Step 3 Click Edit.
Step 4 From the Virtual Hardware tab, select Floppy drive.
Step 5 Select Use existing floppy image.
Step 6 Browse to the datastore and locate the virtual floppy image.
Step 7 Select the file and click OK.
Step 8 Under Status, enable the Connect at power on option.
Step 9 Click the VM Options tab. Under Boot Options, check the Force BIOS setup, and then click Save.
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Step 10 Repeat this procedure for each UC application for which you want to perform touchless installation.

Run Touchless Installation
After you have mounted your virtual floppy drives to your application VMs, run the touchless installation
process. We recommended that you run all of your touchless installations simultaneously.

If your VM is predeployed, you need to perform step 6 only.Note

Procedure

Step 1 In the VMware Embedded Host Client, right-click the VM and select the Console > Open console in new
window.
A console window opens.

Step 2 Click the Power On icon in the console toolbar to power on the virtual machine.
Step 3 When the BIOS screen appears, configure the following boot order:

a) CD-ROM
b) Hard Drive
c) Removable Devices
d) Network

Step 4 Save the settings and exit the console.
The UC application installation commences immediately.

Step 5 Repeat these steps for each UC application that you want to install.
Step 6 Once the installations are complete, remove the vFloppy configurations from the virtual machines.

Install UC Applications Manually
Use this procedure to follow the interactive install process to install any UC applications that do not have a
touchless install option such as Cisco Emergency Responder.

Procedure

Step 1 In the vSphere Client, power on the VM for the application that you want to install.
Step 2 Right-click the VM, and choose the Console > Open console in new window.

A console window appears.
Step 3 Follow the screen prompts to install the application from the console.
Step 4 If you are using the manual method to install both Cisco Unified Communications Manager and IM and

Presence Service, once the Cisco Unified Communications Manager publisher node installation completes,
do the following:
a) From the VMware Embedded Host console, log in to the Cisco Unified Communications Manager CLI.
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b) Run the set network cluster subscriber dynamic-cluster-configuration 24 command.
c) Open a VMware Embedded Host console window for the IM and Presence or subscriber virtual machine.
d) Power On the virtual machine.
e) Enter the configuration information for the application to complete the installation.

Step 5 Repeat this procedure for each UC application that you want to install.
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C H A P T E R 3
Post-Installation of the Cisco Business Edition
7000H/M

• Post-Installation of the Cisco Business Edition 7000H/M, on page 23

Post-Installation of the Cisco Business Edition 7000H/M
Complete the following procedure after the installation of Cisco Business Edition 7000H/M.

Procedure

PurposeCommand or Action

Follow these steps to perform the first-time
setup and apply licenses for your UC
applications.

Licensing Applications, on page 23Step 1

(Optional) Install new locales for your UC
applications.

Install Locales or Patches for Applications, on
page 23

Step 2

Licensing Applications
Appliances are loaded with CSR 14 and CSR 12.7 application versions. All applications are licensed with
Cisco Smart Licensing. Please see the Cisco Smart Licensing for Unified Communications Manager 12.5
BE6000-specific Licenses, on page 31 BE6000 Starter Pack Licenses and the Cisco Smart Software Licensing
with Cisco Unified Communications Manager Solution Overview. Note license logistics will be slightly
different depending on whether your licenses were obtained via a Cisco Collaboration Flex Plan subscription
or via a perpetual license options like Cisco User Connect Licensing or Cisco Unified Workspace Licensing.

Skip this section.

Install Locales or Patches for Applications
Complete the following tasks to install locales or patches for your application VMs.
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• Patches that are shipped with the appliance were current at the time of manufacture. Visit
http://software.cisco.com for more recent updates.

• For additional information on locales, refer to the Phone Locale Installers wiki at: http://docwiki.cisco.com/
wiki/Cucm-phone-locale-installers.

Note

Procedure

PurposeCommand or Action

Associate the locale or patch installer with the
appropriate VM.

Associate Bundled Locale or Patch ISO with
Virtual Machines

Step 1

If you want to install locales or patches for
Cisco Unity Connection, stop the services
before you install the locale or patch.

Stop Services for Unity Connection, on pageStep 2

Install the locale or patchon the VM.Install New Locales or PatchesStep 3

Associate Bundled Locale or Patch ISO with Virtual Machines

Before you begin

Use this procedure to associate your locale or patch images with the appropriate application VM before starting
the install process.

Procedure

Step 1 In the VMware Embedded Host Client, select the Virtual Machine on which you want to install a new locale
or patch.

Step 2 Click Edit .
Step 3 From Virtual Hardware tab, select CD/DVD Drive.
Step 4 Select Datastore ISO File from CD/DVD Drive 1 drop-down list.
Step 5 Browse to the datastore and select the appropriate locale or patch ISO file.
Step 6 Click Select.
Step 7 In CD/DVD Drive 1, check the Connect at power on check box under the Status.
Step 8 Repeat this procedure for each VM for which you want to install a new locale or patch.

Stop Services for Unity Connection
Use this procedure if you want to install a new locale or patch for Cisco Unity Connection. You must stop
services on the Unity Connection VM before you install a new locale or patch.
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Procedure

Step 1 Log in to Cisco Unity Connection Serviceability.
Step 2 Choose Tools > Service Management.
Step 3 Stop the following services:

• Connection Conversation Manager
• Connection Mixer

Install New Locales or Patches
Use this procedure to install a new locale or patch for any UC applications on your Business Edition appliance.

• For Cisco Unified Communications Manager, you must install locales or patches for the publisher node
and restart it before you install it for any subscriber nodes.

• You can install locales for Cisco Unified Communications Manager and Cisco Unity Connection in
parallel.

Note

Procedure

Step 1 Log in to Cisco Unified Communications OS Administration.
Step 2 Navigate to Software Upgrades > Install/Upgrade. The Software Installation/Upgrade window displays.
Step 3 From the Source drop-down list box, choose DVD/CD.
Step 4 Click Next.
Step 5 Select the update file that you want to install and click Next.
Step 6 After the download completes, click Next.
Step 7 After the locale or patch installs, restart the appliance:

a) Log in to the vSphere Client.
b) Right-click the VM on which you installed the locale or patchand select the Power > Restart Guest.

a) Log in to the VMware Embedded Host Client
b) Right-click the VM on which you installed the locale or patch and select the Guest OS > Restart

What to do next

After you install your Cisco Business Edition 7000 appliance, you can provision users, devices and configure
features on the system. Refer to the following guides:

• Cisco Prime Collaboration Provisioning Guide

• Cisco Prime Collaboration Deployment Administration Guide
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A P P E N D I X A
Rebuilding a Business Edition 7000 Appliance

• Rebuilding a Business Edition 7000 Appliance, on page 27
• Hardware and Virtualization Software Reinstall, on page 27
• Reapplying Embedded Virtualization License, on page 27

Rebuilding a Business Edition 7000 Appliance
Use this appendix for the following situations:

• Appliance hardware replacement or RMA.

• Software reinstallation caused by hardware replacement, disk reformatting, RAID rebuilds, virtualization
software reinstall/upgrade or other factors.

• Reapplying an embedded virtualization license key.

Hardware and Virtualization Software Reinstall
If hardware needs to be re-provisioned, or VMware vSphere ESXi needs to be reinstalled, follow the instructions
in Cisco Collaboration on Virtual Servers at https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/
virtual/CUCM_BK_C90D1BE9_00_cisco-collaboration-on-virtual-servers.html

• BE7000M (M5) appliance corresponds to UCS C240 M5SX TRC#1

• BE7000H (M5) appliance corresponds to UCS C240 M5SX TRC#2

Reapplying Embedded Virtualization License
Check Cisco Commerce Services & Subscriptions or My Cisco Entitlements on cisco.com to see what
virtualization software options your appliance ordered.

If your appliance was ordered with one of the following options, then it has an embedded virtualization license:

• BE6/7K-VIRTBASP-7X

• BE6/7K-VIRTENH-7X
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• VMW-VS6-FND-K9

• VMW-VS6-CVSTD-K9

If you instead ordered the appliance with option VIRT-LIC-NONE, or you have substituted a different
virtualization license, then you do not have an embedded virtualization license and the instructions below do
not apply.

By VMware’s design, embedded virtualization licenses work differently from general-purpose VMware
vSphere ESXi licenses.

• They are supported by Cisco TAC; do not contact VMware for support.

• They may not be managed at myvmware.com.

• They are neither VMware.com Partner Activation Codes (PAC) nor Cisco Product Authorization Keys
(PAK).

• Licenses are pre-activated serial numbers and do not require or support activation on myvmware.com.

• They are pre-combined to fixed 2-CPU, and cannot be split or expanded through myvmware.com.

• They must be applied to the appliance through the Embedded Host Client, never add these license keys
to vCenter. They do not support being applied by vCenter or being added to vCenter license pools.

• Formore details, see http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-software-requirements.html#license_comparison

Embedded virtualization licenses aremaster keys. If you purchasedmultiple appliances with the same embedded
virtualization license option, they will all use the same license serial number for the initial install. If you
version-upgrade to a new major release (e.g. 6.x to 7.x), then vCenter-supporting licenses will become a
license key unique to each appliance.

You must apply the embedded virtualization license serial number as-is to an appliance using Embedded Host
Client, NEVER add these license keys to vCenter. Trying to apply through vCenter will either not work at all
or will only work for some of the appliances you purchased.

If you tried to apply for an embedded virtualization license serial number through vCenter, follow the steps
below to “un-do” (“host” refers to the appliance as an ESXi host):

• In vCenter, make sure the host is standalone (NOT managed by vCenter): from vCenter, remove the host
from inventory (important: don’t just “disconnect”).

• While the host is standalone (NOT being managed by vCenter): in Embedded Host Client on the host,
select & remove/delete any existing license key, then enter/assign the embedded virtualization license
key.

• Back to vCenter: re-add the host to inventory. It should show up with the embedded master key that was
entered in step 2.

• For embedded virtualization keys that support vCenter integration, note that these keys will not display
normal "capacity" vs. "used". This is expected behavior.
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