
Installation of Cisco Business Edition 6000H/M

• Installation Overview, page 1

• Installation Task Flow of Cisco Business Edition 6000H/M, page 2

Installation Overview
This chapter describes the tasks that you must perform to install software on your Business Edition 6000
appliance. It contains two main task flows that describe how to install software on the appliance.

For Customized deployments, use the tasks in this chapter to configure VMware and install application software
on your appliance.

If your appliance was configured through the Business Edition Management , your appliance is already
installed with VMware and UC applications.

Skip to Post-installation of Cisco Business Edition 6000H/M chapter.

Preloaded File Types in the Datastore
In addition to pre-deployed virtual machines, Cisco Business Edition servers are shipped with selected
Collaboration application software that is pre-loaded on the datastore. Following is a breakdown of the file
types for application installs:

• ISO Files—An ISO file is a DVD image containing application install files (for example,
Bootable_UCSInstall_UCOS_11.5.1.13900-1.sgn.iso). An ISO file is present for a UC
application only if the OVA file for that application does not include the application software.

• OVA Files—Each UC application has an associated Open Virtualization Archive (OVA) file, which is
used to package and deploy the virtual machine. There are two types of OVAs for Business Edition
servers:

◦Some OVAs are templates that define the VM, but do not include any application software. For
those applications, there is an associated ISO file in the datastore (for example,
Bootable_UCSInstall_UCOS_11.5.1.13900-1.sgn.iso). For the installation, you
must deploy the OVA template and install the software using the associated ISO file.
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◦Other OVA files define the VM and include the application software (for example,
cpc-provisioning-11.2.0-523-small.ova ). For these applications, there is no ISO
file. You can deploy the VM and install the software using the OVA file.

For information on which ISO and OVA files are pre-loaded in your server's datastore, refer to the preload
summary for your server at http://www.cisco.com/c/en/us/support/unified-communications/
business-edition-6000/products-release-notes-list.html.

Cisco recommends that you archive the OVA-ISO directory locally. If there is a hardware failure,
replacement hardware does not include a factory preload. If the factory preloaded software is either deleted,
overwritten or lost, then manual rebuilt of preloaded software is required. Restore to factory default
capability is not supported.

Note

Installation Task Flow of Cisco Business Edition 6000H/M
Perform the following tasks to install software on your Cisco Business Edition 6000 server.

Procedure

PurposeCommand or Action

Configure CIMC for your Business Edition 6000
server.

Configure Cisco IntegratedManagement
Controller, on page 2

Step 1

Configure the pre-installed VMware vSphere ESXi
software on the appliance.

Customize Virtualization Software
Remote Access

Step 2

Delete any pre-deployedVMs that you do not require.Delete Unused or Unwanted Virtual
Machines

Step 3

Skip this step if you deploy the appliance
through Cisco Business Edition
Management.

Note

Configure Cisco Integrated Management Controller
Cisco Integrated Management Controller (CIMC) is the management interface for the Cisco UCS appliance.
CIMC runs within the appliance, allowing remote administration, configuration, andmonitoring of the appliance
through web or SSH command line access.

Complete the following tasks to configure CIMC on a Business Edition 6000 appliance for customized and
pre-configured deployments.
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If you ordered your appliance through Business Edition Management portal, CIMC is already set up on
your appliance. Skip to Configure Virtualization Software, on page 5.

Note

Complete the following tasks to Configure Cisco Integrated Management Controller:

Procedure

PurposeCommand or Action

Power On and Initial CIMC SetupStep 1

Complete the CIMC ConfigurationStep 2

Power On and Initial CIMC Setup
Use this procedure to power on the appliance and begin basic Cisco IntegratedManagement controller (CIMC)
configuration.

Before You Begin

Ensure that the BE6000 appliance has been rack-mounted, connected to a power supply, connected to the data
network, and that a monitor and keyboard are connected to the appliance, as described in the Quick Start
Guide.

Procedure

Step 1 Verify that power is connected and that the power button LED is orange.
Step 2 Push the appliance power button and verify that it changes to green.
Step 3 Watch the boot process on the monitor.
Step 4 When the blue Cisco logo appears, press F8 to enter the CIMC configuration dialog.

Figure 1: Press F8 at the CIMC Boot Screen

Step 5 When prompted, enter the username admin and create a new password.
Step 6 On the CIMC configuration screen, complete the following details:
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• CIMC IP address

• Subnet mask

• Gateway IP address

Figure 2: Enter the CIMC IP Address Details

Step 7 When complete, press F10 to save your changes and boot the system.

What to Do Next

Complete the CIMC Configuration, on page 4

Complete the CIMC Configuration
Use this procedure to configure DNS and NTP settings in the CIMC interface.

Before You Begin

Power on the appliance and begin basic Cisco Integrated Management Controller(CIMC) configuration.
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Procedure

Step 1 In a web browser, enter the CIMC IP address and log in with the username admin and the password that you
created in the previous task.

Step 2 From the left hand menu, select the Admin tab, and click Network.
Step 3 In the main screen, select the Network Settings tab.
Step 4 From Common Properties, change the Hostname setting to the CIMC hostname.
Step 5 From IPv4 Properties, change Preferred DNS Server to the IP address that you have specified for the DNS

server.
Step 6 In the main screen, select the NTP Settings tab.
Step 7 Check the Enable NTP check box.
Step 8 In the Server 1 field, enter the NTP server IP address.
Step 9 Select Save Changes from the bottom right hand corner of the page.

What to Do Next

Customize Virtualization Software Remote Access, on page 5

Configure Virtualization Software
Complete the following tasks to set up the VMware vSphere ESXi.

1 Customize VMware vSphere ESXi Remote Access

2 Access and Configure VMware vSphere ESXi

Customize Virtualization Software Remote Access
Follow this procedure to customize the VMware vSphere ESXi to enable remote access from your PC using
the vSphere client.

For appliances ordered through the Business Edition Management, VMware vSphere ESXi is already
been customized, skip to Step 5, on page 9.

Note

If you use ESXi 6.5, then select VMFS5 file type to create the datastore.Note
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Procedure

Step 1 When the hypervisor boots, the ESXi Direct Console User Interface displays on the monitor as shown in the
following figure.

Figure 3: Console Screen After ESXi Loads

Step 2 Press F2 to enter the System Customization menu as shown in the following figure.
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The default username is root and password is password.

Figure 4: ESXi System Customization Menu

Step 3 Choose Configure Password to change the password.
If your applications are pre-deployed, skip to Step 5, on page 9 .
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Step 4 To assign a static IP address, select the Configure Management Networkmenu, and follow the instructions
on screen to change “IP Configuration”.

Figure 5: Assign Static IP Address to ESXi Host
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Step 5 Connect your PC to the data network, and browse to the new hypervisor IP address.

Figure 6: Hypervisor Welcome Page

Step 6 If not already installed on your PC, download and install the vSphere client.
The vSphere client can be downloaded from the internet, or accessed in the datastore.

What to Do Next

Access and Configure Virtualization Software, on page 10
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Access and Configure Virtualization Software
Some Business Edition applications require the host to have a valid time reference. Follow these steps to
access the ESXi host to configure NTP as well as configure fault tolerance for network interface cards (NICs)
using the NIC teaming feature, view preinstalled applications, and browse the datastore to verify the preloaded
collaboration application software.

Before You Begin

Customize Virtualization Software Remote Access

Procedure

Step 1 Launch the vSphere client application and type the IP address of the VMware vSphere ESXi.

Figure 7: Access VMware vSphere ESXi Using vSphere Client

Step 2 Type the IP address of the VMware vSphere ESXi in the browser to access the vCenter and then select vSphere
Web Client (Flash).

Step 3 Use the login credentials that you previously configured.
Step 4 BE6000 appliances are factory loadedwith a Collaboration embeddedOEM license for Cisco UCVirtualization

Hypervisor Plus. If you want to use this license, it is ready for use. If you want to re-upload or version-upgrade
this license, follow these steps:
a) Locate your license document that has license serial number for Cisco UC Virtualization Hypervisor Plus.

For installations, license serial number ships from the factory alongwith the appliance. For version-upgrades,
license serial number ships from the Cisco Product Upgrade Tool.

b) Navigate to Configuration > Software > Licensed Features, and click Edit.
c) Select Assign a new license key to this host.
d) Click Enter Key....
e) Type in or copy / paste the license serial number from the license document.
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f) Click OK to close configuration dialogs and apply the license.
License for Cisco UC Virtualization Hypervisor Plus is a special Collaboration embedded OEM
license. It is hardcoded to 2-CPU, pre-combined, and cannot split or expand through myvmware.com.
It is pre-activated, no registration or activation on myvmware.com or cisco.com required. It does not
support installation through vCenter, license pooling in vCenter, or any vCenter features.

For more details, see http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/
virtualization/virtualization-software-requirements.html#license_comparison

Note

Step 5 Configure NTP settings:
a) Navigate to Configuration > Software > Time Configuration.
b) Click Properties to launch the Time Configuration screen.
c) Update the Time.
d) Click Options... .
e) Select NTP Settings.
f) Click Add and type the IP address of NTP server. Repeat this step to add multiple NTP servers.
g) Click OK.
h) Select General > Start and Stop with Host.
i) Click Start. Click OK to close the configuration screens.

Step 6 (Optional) Configure fault tolerance by using the NIC teaming feature in VMware:
a) Navigate to Configuration > Hardware > Networking.
b) Click Properties for “Standard Switch: vSwitch0,”.
c) In the configuration screen vSwitch0 Properties, and then select the Network Adapters tab.
d) Click Add… to add the NIC that is connected to data network.
e) Follow the interactive configuration dialogs and close the configuration screens until you see two or more

NICs are added to vSwitch0, as shown in the figure 5 below.
By default, only one NIC is enabled for the hypervisor and identified as vmnic0.Note

If connecting teamed NICs to a Cisco switch channel-group, ensure that the NIC teaming load
balancing policy is set toRoute based on IP hash. For more information about this policy and other
aspects of hypervisor networking for Cisco Collaboration applications, see the Appendix. Configure
NIC Teaming for Business Edition 6000H/M.

Note

Step 7 Browse the datastore:
a) Navigate to Configuration > Hardware > Storage.
b) Click Datastore to list the datastores in the Business Edition appliance.
c) Select datastore1, then right-click, and then select Browse Datastore as shown in the following figure.

Preloaded software is stored in the /OVA-ISO directory.
It is recommend to select VMFS5 file type while creating datastore.
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Figure 8: Browse Datastore to View Preloaded Collaboration Virtual Machines and Preloaded Software

Step 8 (Optional) Cisco recommends that you archive the OVA-ISO directory locally. If a appliance fails, the
replacement product does not include preloaded content.

What to Do Next

Delete Unused or Unwanted Virtual Machines, on page 12

Delete Unused or Unwanted Virtual Machines
You can optionally delete unused or unwanted preloaded files to free up disk space or make room for subsequent
installations.

You can delete unused or unwanted preloaded files in the following scenarios:

• If you want to deploy a new application version or patch level than the existing factory-preloaded
application.

• If you do not want to run a particular preloaded application and its files.
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Procedure

Step 1 Log in to vSphere Client. Locate the virtual machine that you wish to delete.

Figure 9: Delete Any VMs that you are not Using

Step 2 If the VM has a green triangle, right-click the icon and select Power > Power Off.
The green arrow disappears as the VM powers off.

Step 3 Right-click the VM and select Delete From Disk.
Step 4 Repeat this procedure for each virtual machine that you wish to remove.

What to Do Next

Deploy Virtual Machine OVAs, on page 13

Deploy Virtual Machine OVAs
For each application that you want to run, requires one of the preloaded virtual machine OVA files. If a new
version is preferred, then deletion and substitution with the new version's file is recommended. Depending
on the preloaded application, the OVA contains a fully installed ready to run application, a partially installed
application, or only a VM configuration for an empty virtual machine. For more details, see the Preload File
Summaries in Release Notes at http://www.cisco.com/c/en/us/support/unified-communications/
business-edition-6000/products-release-notes-list.html.
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The OVA template files that contain empty virtual machines are deployed in seconds, while larger OVA
files that contain partially or fully installed applications can take longer to deploy.

Note

Figure 10: Deployed Application VMs Viewed in VSphere Client

Procedure

Step 1 On the vSphere Client, navigate to File > Deploy OVF Template.
The Deploy OVF Template screen is launched.

Step 2 Browse and select the source OVA template file on your PC. For application and filename mapping, see the
Build Summary PDF in the datastore OVA-ISO directory, or download from here: http://www.cisco.com/c/
en/us/support/unified-communications/business-edition-6000/products-release-notes-list.html.

Step 3 If prompted to accept license agreements, continue to click Next.
Step 4 Specify a meaningful name for the virtual machine.
Step 5 Select the appropriate virtual machine size for your deployment, if prompted.
Step 6 Set the remaining parameters, as required.
Step 7 If prompted for the Disk Format, specify Thick Provision Lazy Zero.
Step 8 Deploy VMs for all of your UC applications before proceeding to the next task.

What to Do Next

If your system includes Cisco Unity Connection, Customize Virtual Machines for Cisco Unity Connection,
on page 15

Otherwise, Associate Application ISO Files to Virtual Machines, on page 15
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Customize Virtual Machines for Cisco Unity Connection
For Customized installations, use this procedure to configure your Cisco Unity Connection virtual machine
settings to ensure optimum performance.

Pre-configure

Before You Begin

Deploy Virtual Machine OVAs, on page 13
For Customized installations, use this procedure to configure your Cisco Unity Connection virtual machine
settings to ensure optimum performance.

Procedure

Step 1 From the virtual machine inventory in the vSphere client, right click the Unity Connection entry and select
Edit Settings.

Step 2 Click the Resources tab.
Step 3 If installing a version earlier than 11.5, select the Advanced > General menu, and click Configuration

Parameters. Click Add Row and complete the following details:
a) Enter sched.cpu.latencySensitivity in the Name column.
b) Enter High in the Value column.

Step 4 If you want to use Unity Connection, or Unified or Integrated Messaging, do the following:
a) Select the Hardware tab.
b) Select the CPUs menu and set the number of virtual sockets to 2.
c) Select the Resources tab.
d) Select the CPU menu and increase the Reservation to 3598MHz.

What to Do Next

Associate Application ISO Files to Virtual Machines, on page 15

Associate Application ISO Files to Virtual Machines
If you have deployed a skip-install OVA that contains partially installed application, skip this step:

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Emergency Responder

If you deployed an OVA that contains a ready to run fully installed application,skip this step:
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For all other OVA files that contain only VM configurations of empty virtual machines, use this procedure
to associate the ISO installation files that is used to complete the installation.

For an up to date list of installation files for your appliance, see the Preload Summary for your appliance
in the datastore OVA-ISO directory or at: http://www.cisco.com/c/en/us/support/unified-communications/
business-edition-6000/products-release-notes-list.html

Note

Procedure

Step 1 In the vSphere client, select the UC application virtual machine.
Step 2 Select Inventory > Virtual Machine > Edit Settings.
Step 3 From the Hardware tab, select CD/DVD Drive.
Step 4 Select Datastore ISO File.
Step 5 Browse to the datastore and locate the application ISO file.
Step 6 Select the file and click OK.
Step 7 Under Device Status, enable the Connected and Connect at power on option.
Step 8 Repeat this procedure for each application that you want to install that includes an ISO file.

What to Do Next

Install your UC applications using either of the following procedures:

• Install UC Applications Using Touchless Installation, on page 16

• Install UC Applications Manually, on page 21

Install UC Applications Using Touchless Installation
Touchless installation allows you to install multiple UC applications and virtual machines of an application
simultaneously, across different hosts if required, without having to interact with the system while the install
process runs. While you must prepare the system, touchless installation can save time, particularly if you want
to install multiple applications. If you are installing only one or two applications, you may prefer to follow
the manual procedure in the following section.

Use touchless installation to install the following applications:

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Prime Collaboration Deployment
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Procedure

PurposeCommand or Action

Generate answer files (AFG files) for UC
applications.

Generate Answer Files, on page 17Step 1

Use your AFG files to create virtual floppy
images.

Create Virtual Floppy Images, on page 18Step 2

Upload your virtual floppy images to the datastore.Upload Virtual Floppy Images to
Datastore, on page 19

Step 3

Mount each virtual floppy on the corresponding
UC application VM.

Mount Virtual Floppy on VirtualMachines
and Set Boot Option, on page 19

Step 4

Run the touchless installation of your UC
applications. We recommend that you run your
installations simultaneously.

Run Touchless Installation, on page 20Step 5

What to Do Next

Generate Answer Files, on page 17

Generate Answer Files
Use this procedure to generate answer files for the touchless installation of your UC applications.

We recommend that you create application-specific folders (for example, UCM, IMP, CUC, CCX) in
which to save the generated files so that you do not get the files mixed up.

Tip

Procedure

Step 1 Go to the online answer file generator at: www.cisco.com/web/cuc_afg/.
Step 2 From the Product drop-down menu, select the UC application for which you want to generate answer files.
Step 3 Select the Version that you want to install.
Step 4 Complete the remaining fields with the installation details that you want to configure on the appliance. For

example, you can assign items such as passwords, IP addressing, and DNS settings.
Step 5 Click Generate Answer Files to generate the platformConfig.xml file for that UC application.

Each UC application generates a platformConfig.xml file. Cisco Unified Communications Manager
also generates a clusterConfig.xml file.

Step 6 Save the generated answer files as follows:

• For Cisco Unified Communications Manager, save both the platformConfig.xml and
clusterConfig.xml files in the UCM folder.
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• For other UC applications, save the platformConfig.xml file in the relevant application folder.

Step 7 Repeat these steps for each UC application for which you want to use touchless installation.

What to Do Next

Create Virtual Floppy Images, on page 18

Create Virtual Floppy Images
Use this procedure to create virtual floppy images from the answer files. You will use the virtual floppy images
in your touchless installation.

We recommend that you follow the recommended naming conventions for your .flp files.Tip

Before You Begin

1 You can use Winimage to create the virtual floppy images. You can download Winimage from http://
www.winimage.com/download.htm. You can also use other tools, such as BFI, to create virtual floppy
images.

2 Generate Answer Files, on page 17

Procedure

Step 1 In Winimage, select File > New.
Step 2 From the Standard format, select 1.44 MB and click OK.
Step 3 Drag the platformConfig.xml file for the UC application onto the Winimage window.
Step 4 When prompted to inject the file into Winimage, click Yes.
Step 5 Cisco Unified Communications Manager only. Drag the clusterConfig.xml file onto the Winimage

window.
Step 6 Select File > Save As.
Step 7 Save the file as a virtual floppy image (.flp file) using the following naming conventions:

• Cisco Unified Communications Manager—ucm.flp

• IM and Presence Service—imp.flp

• Cisco Unity Connection—cuc.flp

• Cisco Unified Contact Center Express—ccx.flp

Step 8 Repeat this procedure for each UC application for which you want to use touchless installation.
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What to Do Next

Upload Virtual Floppy Images to Datastore, on page 19

Upload Virtual Floppy Images to Datastore
Use this procedure to upload the virtual floppy images to the datastore.

Before You Begin

Create Virtual Floppy Images

Procedure

Step 1 Start the vSphere client.
Step 2 Select the Configuration tab.
Step 3 Select Storage.
Step 4 Right-click on a datastore and Browse the datastore.
Step 5 Navigate to the destination directory and click the Upload files to this datastore icon.
Step 6 Upload the vFloppy images to the AFG folder.
Step 7 At the Upload/Download warning, click Yes.
Step 8 Close the Datastore Browser window.

What to Do Next

Mount Virtual Floppy on Virtual Machines

Mount Virtual Floppy on Virtual Machines and Set Boot Option
Use this procedure to mount the UC application virtual floppy images on their corresponding VM.

This step is not required for pre-deployed VMs as they are already configured.

Before You Begin

Upload Virtual Floppy Images to Datastore
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Procedure

Step 1 In the vSphere client, select the UC application virtual machine.
Step 2 Select Inventory > Virtual Machine > Edit Settings.
Step 3 From the Hardware tab, select Floppy drive.
Step 4 Select Use existing floppy image in datastore.
Step 5 Browse to the datastore and locate the virtual floppy image.
Step 6 Select the file and click OK.
Step 7 Under Device Status, enable the Connected and Connect at power on option.
Step 8 Click the Options tab. Under Boot Options, check Force entry to BIOS, and then click OK.
Step 9 Repeat this procedure for each UC application for which you want to perform touchless installation.

What to Do Next

Run Touchless Installation

Run Touchless Installation
After you have mounted your virtual floppy drives to your application VMs, run the touchless installation
process. It's recommended that you run all of your touchless installations simultaneously.

If your VM is pre-deployed, you need to perform step 6 only.Note

Procedure

Step 1 In the vSphere client, right-click the VM and select Open Console.
A console window opens.

Step 2 Click the Power On icon in the console tool bar to power on the virtual machine.
Step 3 When the BIOS screen appears, configure the following boot order:

a) CD-Rom
b) Hard Drive
c) Removable Devices
d) Network

Step 4 Save the settings and exit the console.
The UC application installation commences immediately.

Step 5 Repeat these steps for each UC application that you want to install.
Step 6 Once the installations are complete, remove the vFloppy configurations from the virtual machines.

What to Do Next

Use the manual method to install any remaining UC applications in the next section.
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Install UC Applications Manually
Use this procedure to follow the interactive install process to install any UC applications that do not have a
touchless install option such as Cisco Emergency Responder.

For details specific to Cisco Prime Collaboration Provisioning or Cisco TelePresence Video Communications
Appliance installations, refer to Complete Other Applications Installation , on page 21.

Procedure

Step 1 In the vSphere Client, power on the VM for the application that you want to install.
Step 2 Right-click the VM, and choose Open Console.

A console window appears.
Step 3 Follow the screen prompts to install the application from the console.
Step 4 If you are using the manual method to install both Cisco Unified Communications Manager and IM and

Presence Service, once the Cisco Unified Communications Manager publisher node installation completes,
do the following:
a) From the vSphere console, log in to the Cisco Unified Communications Manager CLI.
b) Run the set network cluster subscriber dynamic-cluster-configuration 24 command.
c) Open a vSphere console window for the IM and Presence or subscriber virtual machine.
d) Power On the virtual machine.
e) Enter the configuration information for the application to complete the installation.

Step 5 Repeat this procedure for each UC application that you want to install.

Complete Packed Virtual Machine (OVA) Installation
• Complete Other Applications Installation

• Complete Cisco Expressway Installation

Complete Other Applications Installation
Use this procedure to complete installation of Cisco Prime Collaboration Provisioning, Cisco Prime
Collaboration Assurance and Analytics Business, or Cisco Prime Collaboration Deployment.

Before You Begin

Install UC Applications Manually, on page 21
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Procedure

Step 1 In vSphere client, power on the VM that you deployed for the respective Prime Collaboration applications
(Cisco Prime Collaboration Provisioning, Cisco Prime Collaboration Assurance and Analytics Business, or
Cisco Prime Collaboration Deployment).

Step 2 Right-click the VM and choose Open Console.
A console window appears.

Step 3 At the login prompt, type setup.
Step 4 Follow the prompts to complete the installation.

Complete Cisco Expressway Installation
Use this procedure to complete installation of Cisco Expressway.

For detailed documentation on installing and setting up Cisco Expressway refer to
http://www.cisco.com/c/en/us/support/unified-communications/expressway-series/products-installation-guides-list.html.

Note

Before You Begin

Complete Other Applications Installation , on page 21

Procedure

Step 1 Power on and open the console of the virtual machine.
Step 2 At the login prompt, enter admin for username and TANDBERG for the password.
Step 3 At the Run Install Wizard prompt, type Y and press Enter.
Step 4 To change the password, type Y and press Enter.
Step 5 At the prompt, type the new password, and click Enter.
Step 6 In the next series of prompts, configure the following network details:.

• IP Protocol (Default is IPv4)

• IP address

• Subnet mask

• Default gateway IP address

• Ethernet speed of the LAN (Default is auto)

Step 7 For the Run SSH (Secure shell) daemon, type Y and press Enter.
Step 8 At the Restart Now prompt, type Y and press Enter.
Step 9 After the system reboots, access the Cisco Expressway in a web browser.
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