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Installing Cisco UCS Director Express for Big Data Bare Metal
Agent on VMware vSphere

Before You Begin

• You must have system administrator privileges for VMware vSphere or vCenter.

• If you want to use a static IP address rather than DHCP, you must know the following information:

◦IP address

◦Subnet mask
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◦Default gateway

Step 1 On the Cisco.com download site for Cisco UCS Director, download Cisco UCS Director Bare Metal Agent and unzip
the OVF file.

Step 2 Log in to VMware vSphere Client.
Step 3 In the Navigation pane, click the vSphere host on which you want to deploy Cisco UCS Director Express for Big Data

Bare Metal Agent.
Step 4 Choose File > Deploy OVF Template.
Step 5 In the Source screen of theDeploy OVFTemplatewindow, do one of the following to choose your OVF source location

and then click Next:

• If the OVF file is stored on your local computer, browse to the location, choose the file, and click Open.

• If the OVF file is stored on a server on your local area network, enter the location of the file including the IP address
or fully qualified domain name of the server.

Step 6 In the OVF Template Details screen, verify the details and click Next.
Step 7 In the End User License Agreement screen, review the license agreement and click Accept.
Step 8 In the Name and Location screen, do the following:

a) In the Name field, enter a unique name for the VM.
b) In the Inventory Location area, choose the location where you want the VM to reside.
c) Click Next.

Step 9 In the Storage screen, choose the storage location for the VM and click Next.
Step 10 In the Disk Format screen, click Next to accept the default radio button for Thick Provision (Lazy Zeroed) format.
Step 11 In the Network Mapping screen, choose the network for the VM and click Next.
Step 12 In the Properties screen, do the following:

a) In the BMA Root User Password field, enter the password that you want to use as the root password.
b) Configure the IP addresses for both the NICs (eth0 and eth1) that you want to assign, as follows:

• To use DHCP to assign the IP addresses, leave the default of 0.0.0.0 in the IP address fields.

• To use static IP addresses, enter the desired IP addresses in the IP address fields. If you only want to configure
one NIC, only complete one set of IP addresses and leave the second set at the default.

c) Click Next.

Step 13 In the Ready to Complete screen, verify the settings and click Finish.
A message appears to indicate that Cisco UCS Director Express for Big Data Bare Metal Agent is being deployed.

Step 14 Log in to the Cisco UCS Director Express for Big Data Bare Metal Agent server with root privileges, and check if you
are able to ping the Cisco UCS Director Express for Big Data Bare Metal Agent server.

Step 15 In the Navigation pane, right-click the Cisco UCS Director Express for Big Data Bare Metal Agent server and choose
Edit Settings.
a) Choose the Resources tab.
b) In the Resource Allocation window, set CPU and Memory Reservation settings to the maximum.
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c) Click OK.

Step 16 Power on the VM.

NTP Server Configuration on Cisco UCS Director Express for
Big Data Bare Metal Agent

You can configure Cisco UCS Director Express for Big Data BareMetal Agent to have its clock synchronized
to an external NTP server. This ensures that the correct calendar time is maintained on the Bare Metal Agent.

Ensure that you synchronize Cisco UCS Director Express for Big Data and Cisco UCS Director Express for
Big Data BareMetal Agent before you deploy any Hadoop cluster. It is recommended that you also synchronize
Cisco UCS Manager and Cisco UCS Director Express for Big Data on the configured NTP server.

Follow the steps to locate the ntp_server_config.sh:

• Locate /opt/cnsaroot/bigdata_templates/ntp_server_config.sh

• Add execute permissions (chmod+x ntp_server_config.sh)

• Execute ( ./ntp_server_config.sh <ntp_server_ip or hostname>) on the Cisco UCS Director Express
for Big Data Bare Metal Agent server.

Adding Oracle JDK Software Versions to Bare Metal Agent
You can upload Oracle JDK software and use Oracle JDK for all Hadoop distributions (Cloudera, MapR, and
Hortonworks) through an instant Hadoop cluster and customized Hadoop cluster creation actions. You can
also add new nodes to the existing cluster and support upgrading existing clusters.

Step 1 Log in to the Cisco UCS Director Bare Metal Agent server.
Step 2 Create a JDK folder in /opt/cnsaroot/bd-sw-rep/.

For example, create a JDK folder in /opt/cnsaroot/bd-sw-rep/JDK in the Bare Metal Agent.

Step 3 Navigate to Solutions > Big Data > Settings and click the Software Catalogs tab to create JDK software version folder
names for each version.

Step 4 Copy JDK files in .rpm or .gz format to the respective version folders.
Step 5 On the menu bar, choose Administration > Integration to track software uploads.
Step 6 Click the Change Record tab to track the software upload in progress and verify if completed, failed, or timeout.
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Installation of User-Defined Software Post Hadoop Cluster
Creation

Cisco UCSDirector Express for Big Data provides an option to add user-defined installation packages (RPMs)
post Hadoop cluster creation specific to a version. In Cisco UCS Director Express for Big Data, you cannot
install more Hadoop related software other than what is required for the selected type of Hadoop distribution
when creating an instant Hadoop cluster or customizing a Hadoop cluster.

To install user-defined Hadoop related software, you can specify a list of RPMs in the
HadoopDistributionRPM.txt file. This modifiable list defines the required packages for each version of a
Hadoop distribution. You can locate the HadoopDistributionRPM.txt here:
/opt/cnsaroot/bigdata_templates/common_templates in the Cisco UCS Director Express
for Big Data Bare Metal Agent server.

For example, you can specify a list of RPMs in the HadoopDistributionRPM.txt file for MapR-5.0.0:

• mapr-v5.0.0GA.rpm.tgz

• mapr-ecosystem-5.x-20150709.rpm.tgz

• mapr-whirr-0.8.1.18380-GA.noarch.rpm

Configuring the Network Interface using Shelladmin
This procedure is optional.

Step 1 Log in to the Cisco UCS Director Express for Big Data VM console with the following credentials:
a) User—shelladmin
b) Password—changeme
If you have already logged into the shelladmin and changed the default password, use your new password instead.

After you have logged in, you can choose Change shelladmin password to change the default password.

Step 2 Choose Configure Network Interface.
Step 3 At the Do you want to Configure DHCP/STATIC IP [D/S] prompt, enter one of the following choices:

• If DHCP is enabled, enter D (IP addresses are assigned automatically)

• To configure static IP, enter S, and then choose the interface you want to configure at the next prompt followed by
the option to select IPv4 or IPv6. This is followed by the confirmation of the interface selected and the version of
IP for which you select Y to continue. Then enter the following details:

◦IP address

◦Netmask

◦Gateway

◦DNS Server 1
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◦DNS Server 2

Step 4 Confirm when prompted.

Configuring the DHCP Server for a Bare Metal Agent Account

For a multi-home DHCP configuration, use this procedure to configure the first subnet for the DHCP
server. For the remaining subnets, you must manually edit the DHCP configuration file
(/etc/dhcpd.conf).

Note

Before You Begin

To provide required DHCP services, ensure that at least one DHCP server is located in the same PXE VLAN
as Bare Metal Agent. Configure the DHCP server with an appropriate IP address range. The DHCP server,
together with the TFTP server, is used to communicate with a PXE server.

Step 1 Log in to the Cisco UCS Director Express for Big Data server with the following credentials:
a) User—admin
b) Password—admin

Step 2 On the menu bar, choose Administration > Physical Accounts.
Step 3 Click the Bare Metal Agents tab.
Step 4 Click the row for the Bare Metal Agent account for which you want to configure the DHCP server.
Step 5 Click Service Status to verify that services for the Bare Metal Agent account are stopped.
Step 6 Click Configure DHCP.
Step 7 In the Configure DHCP dialog box, complete the following fields and click Submit.

• DHCP Subnet

• DHCP Netmask

• DHCP Start IP

• DHCP End IP

• Router IP Address

The DHCP IP address assignments are updated, and the DHCP service is restarted.

Step 8 Click the row for the Bare Metal Agent account and click Start Services.
Step 9 After the services have started, do the following:

• Verify that the status of the account in the Status column is Active.
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• Verify that the Enabled Services column shows that all services are running. If this status indicates that one or
more services are stopped, verify the configuration of your DHCP server and try again.

• Click Service Status to verify that the status of all expected services is up:

◦Network Services status in the Bare Metal Agent appliance

◦Database connectivity status from the Bare Metal Agent appliance

What to Do Next

Set up PXE boot requests.

Setup and Configuration for PXE Boot Requests
You can use Cisco UCS Director Express for Big Data Bare Metal Agent (Bare Metal Agent) to create and
send a request through the DHCP server for a PXE boot for a specified operating system (OS).

Before you can create and send a PXE boot request, the OS image that you want to use in a given PXE boot
request must be configured correctly and be available in Bare Metal Agent. If the OS image that you want to
PXE boot is not listed as an available OS type, you must first create the OS image template in Bare Metal
Agent,

Although you can perform all the OS image setup procedures manually, we recommend that you use Bare
Metal Agent to set up your OS images.

Note

Adding a New Red Hat Version for Hadoop Cluster
For more information on uploading supported Red Hat Enterprise Linux versions, see Chapter 12, Managing
Hadoop and Splunk Clusters in Cisco UCS Director Express for Big Data Management Guide.

Step 1 On the menu bar, choose Solutions > Big Data > Settings.
Step 2 Click the Software Catalogs tab.
Step 3 Click Add.
Step 4 Click Upload.
Step 5 Choose the target Cisco UCS Director Express for Big Data Bare Metal Agent from the Target BMA drop-down list.
Step 6 Check theRestart BMA Services check box to restart Cisco UCS Director Express for Big Data Bare Metal Agent after

uploading the required files.
Step 7 To verify that the new Red Hat version (operating system software) is available in the Cisco UCS Director Express for

Big Data server, perform the following:
a) Log in to the Cisco UCS Director Express for Big Data user interface.
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b) On the menu bar, choose Administration > Physical Accounts.
c) Click the Bare Metal Agents tab.
You can find the new Red Hat version listed in the Image Catalogs column of the Bare Metal Agents report.

New RHEL Version

Red Hat Enterprise Linux 7.2

Download the following file:

• rhel-server-7.2-x86_64-dvd.iso from Red Hat Enterprise Linux

Upgrading Bare Metal Agent to Release 6.0
Before You Begin

• Upgrade Cisco UCS Director to Release 6.0.

If your system is running versions prior to release 5.4, then you must first migrate to Release 5.4, then
upgrade to Release 5.5 and then upgrade to Release 6.0. For information on upgrading to release 5.4,
see the Cisco UCS Director Release 5.4 Upgrade Guide available at: http://www.cisco.com/c/en/us/
support/servers-unified-computing/ucs-director/products-installation-guides-list.html

Step 1 Download the Bare Metal Agent, Release 6.0 patch to the existing Bare Metal Agent.
Step 2 Log in to the Bare Metal Agent console through PuTTY or another Secure Shell (SSH) client, using the default root

credentials shown or the root credentials for your system.
Username: root
Password: pxeboot

Step 3 Navigate to the /opt/infra directory and run StopInfraAll.sh to stop the services.
Step 4 Unzip the patch.
Step 5 Navigate to the directory of the unzipped file.

cd ucsd_bma_patch_6_0_0_0

Step 6 Run ./applyPatch.sh to apply the patch to Bare Metal Agent.
Step 7 Wait for the installation to complete.
Step 8 Navigate to the /opt/infra directory.
Step 9 Run ./showBMAVersion.sh to verify that you have the correct version of Bare Metal Agent.
Step 10 Run startInfraAll.sh to start the BMA services.
Step 11 Run statusInfra.sh to check the status of the BMA services.
Step 12 Log in to Cisco UCS Director, Release 6.0, and choose Administration > Physical Accounts > Bare Metal Agents.
Step 13 Choose the account for the Bare Metal Agent that you have upgraded.
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If your system has more than one instance of Bare Metal Agent, you can identify the correct account by the IP address.

Step 14 Confirm that the Bare Metal Agent account is reachable from Cisco UCS Director and then stop and start the services
for that account.
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