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Using the Cisco DCNM-LAN Client
This chaptersection describes the user interface of the Cisco Data Center Network Manager for LAN
(DCNM-LAN) client and how to use common features.
This chapter includes the following sections:
•

Information About the DCNM-LAN Client, page 16-1

•

Opening the DCNM-LAN Client, page 16-8

•

Closing the DCNM-LAN Client, page 16-9

•

Deploying Changes, page 16-10

•

Working with Statistics and Charts, page 16-11

•

Configuring Global Preferences, page 16-17

•

Using Online Help, page 16-19

Information About the DCNM-LAN Client
This section describes the DCNM-LAN client and its parts.
This section includes the following topics:
•

User Interface, page 16-2

•

Feature Selector Pane, page 16-2

•

Contents Pane, page 16-3

•

Summary Pane, page 16-3

•

Details Pane, page 16-3

•

Association Pane, page 16-4

•

Menus, page 16-5

•

Toolbars, page 16-7

•

Keyboard Commands, page 16-7

•

Multiple Platform Support, page 16-7
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User Interface
The DCNM-LAN client user interface presents device status information and provides configuration
tools that allow you to manage devices. It is divided into the panes. When you want to view information
about a specific object in a managed device or want to perform a configuration task, you use the panes
in the order shown in the figure below.
Figure 16-1

DCNM-LAN Client User Interface

1

Feature Selector pane

3

Summary pane

2

Contents pane

4

Details pane

Feature Selector Pane
The Feature Selector pane, shown in Figure 16-1the figure in the “User Interface” section on page 16-2,
allows you to see features grouped by categories and to choose the feature that you want to use or
configure. The bottom section of the Feature Selector pane displays buttons for feature categories. When
you choose a category, the top section of the Feature Selector pane displays a tree of features within the
chosen category.
In Figure 16-1the figure in the “User Interface” section on page 16-2, the Interfaces category is chosen,
so the tree shows features that allow you to configure the interfaces of managed devices.
The documentation and online help for DCNM-LAN includes many procedures that begin with choosing
the applicable feature from the Feature Selector pane. For example, a procedure about configuring an
Ethernet interface would start with the following step:
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From the Feature Selector pane, choose Interfaces > Physical > Ethernet.
After you choose a feature on the tree, the Contents pane displays information about the feature.

Contents Pane
The Contents pane, shown in Figure 16-1the figure in the “User Interface” section on page 16-2, displays
information about the currently selected feature and provides fields for configuring that feature. The
Contents pane contains two smaller panes: the Summary pane and the Details pane.

Summary Pane
The Summary pane, shown in Figure 16-1the figure in the “User Interface” section on page 16-2,
displays an organized set of objects that you can view information about or perform actions on. The type
of objects that appear depends upon the currently selected feature.
For example, if you choose Interfaces > Physical > Ethernet from the Feature Selector pane, the
Summary pane shows a table of devices. You can expand the managed devices to view the slots that
contain network interface cards. You can expand the slots to view the interfaces they contain and key
information about the status of the interfaces, such as the port mode, administrative status, and
operational status. For most features, the title bar for the Summary pane shows what you have selected.
After you choose the object that you want to view or configure, the Details pane displays information
about the selected object, such as an Ethernet interface.
Exporting the Summary Pane

You can export the data shown in the Summary pane to a spreadsheet in Microsoft Excel 97-2003 format.
To do so, click the green arrow in the upper-right corner of the Summary pane and specify the filename
and location for the spreadsheet.
Filtering the Summary Pane

For many features, you can filter the objects that appear in the Summary pane. If filtering is supported
for the feature that you selected, you can enable filtering from the menu bar by choosing View > Filter.
In the Summary pane, the columns that you can use to filter the objects become drop-down lists. To filter
the Summary pane, use the drop-down column heading lists to limit the objects that appear.

Details Pane
The Details pane, shown in Figure 16-1the figure in the “User Interface” section on page 16-2, shows
information and configuration fields that are specific to the object that you selected in the Summary
pane. The Details tab is often further divided into tabs. You can click on a tab to view its contents.
This section includes the following topics:
•

Tabs, page 16-4

•

Sections, page 16-4
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Tabs
Tabs organize related fields and information. For example, as shown in Figure 16-1the figure in the
“User Interface” section on page 16-2, when you select an Ethernet interface, four tabs appear in the
Details pane, such as the Port Details tab.
The following two special tabs often appear in the Details pane for many of the types of objects that you
can choose from the Summary pane:
•

Statistics—You can use this tab to work with statistics and charts related to the selected object. For
more information, see the “Working with Statistics and Charts” section on page 16-11.

•

Events—You can use this tab to view feature-specific events about the selected object. For more
information, see the System Management Configuration Guide, Cisco DCNM for LAN.

Sections
Sections provide further organization of related fields and information. The DCNM-LAN client allows
you to expand and collapse sections so that you can show or hide fields and information as needed. For
example, as shown in Figure 16-1the figure in the “User Interface” section on page 16-2, on the Port
Details tab, the Basic Settings section is expanded but the Port Mode Settings section is collapsed.

Association Pane
The DCNM-LAN client also includes the Association pane, which allows you to access objects that you
have configured in features that are associated with the currently selected feature. Figure 16-2The
following figure shows the Association pane.
When tabs appear on the right side of the DCNM-LAN client, you can click on them to access the
Association pane. For example, as shown in Figure 16-2the following figure, if you are configuring an
Ethernet interface, you can use the Association pane to access the IPv4 ACLs that you can apply to the
interface. If you right-click on an IPv4 ACL in the Association pane, you can choose to apply the ACL
to the interface or to go to the IPv4 ACLs feature and configure the ACL.
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Figure 16-2

1

Association Pane

Association pane

Menus
The menu bar in the DCNM-LAN client includes the following standard menus that appear:

File Menu
•

New—Allows you to create new objects. The types of objects that you can create depends upon the
currently selected feature. In some cases, the object selected in the Summary pane also affects what
you can create.

•

Deploy—Saves your changes to the DCNM-LAN server and deploys configuration changes to
managed devices.

•

Exit—Closes the DCNM-LAN client.

•

Toolbars—Allows you to show or hide the toolbars that are available for the currently selected
feature. For more information, see the “Toolbars” section on page 16-7.

•

Refresh—Forces the DCNM-LAN client to retrieve updated information from the DCNM-LAN
server.

•

Filter—Enables or disables the filtering option for the Summary pane.

View Menu
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Tools Menu
•

Preferences—Opens the Global Preferences dialog box. For more information, see the “Configuring
Global Preferences” section on page 16-17.

•

Debug—Opens the DCNM-LAN Client Logging dialog box, which allows you to configure the
logging level for the DCNM-LAN client.

Note

We recommend that you use the default client logging level unless you are troubleshooting
a specific problem or are asked to change client logging levels by the Cisco technical support
staff.

Go Menu
•

Topology—Selects the Topology button on the Feature Selector pane.

•

Inventory—Selects the Inventory button on the Feature Selector pane.

•

Virtual Devices—Selects the Virtual Devices button on the Feature Selector pane.

•

Interfaces—Selects the Interfaces button on the Feature Selector pane.

•

Switching—Selects the Switching button on the Feature Selector pane.

•

FCoE—Selects the FCoE button on the Feature Selector pane.

•

Routing—Selects the Routing button on the Feature Selector pane.

•

Security—Selects the Security button on the Feature Selector pane.

•

Configuration Change Management—Selects the Configuration Change Management button on the
Feature Selector pane.

•

Device OS Management—Selects the Device OS Management button on the Feature Selector pane.

•

Configuration Delivery Management—Selects the Configuration Delivery Management button on
the Feature Selector pane.

•

DCNM-LAN Server Administration—Selects the DCNM-LAN Server Administration button on the
Feature Selector pane.

•

Network Servers—Selects the Network Servers button on the Feature Selector pane.

•

Event Browser—Selects the Event Browser button on the Feature Selector pane.

Actions Menu
The items on the Actions menu reflect what you can do, depending upon the feature you are using and
the object that is selected in the Summary pane. For some features, such as Inventory, the Actions menu
does not appear in the menu bar.

Help Menu
•

Help Contents—Opens the online help system to the Welcome page.

•

Context Help—Opens the online help system to a page that applies to the feature currently selected
in the Feature Selector pane.

•

Show DCNM-LAN Instance ID—Opens a dialog box that displays the license ID for your
DCNM-LAN server. For more information, see the Cisco DCNM Installation Guide, Release 7.1.x.
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•

View Licenses—Opens a dialog box that displays information about license files currently installed
with your DCNM-LAN server.

•

About Data Center Network Manager—Opens a dialog box that displays information about your
DCNM-LAN server, including the software version and implementation version.

Toolbars
The DCNM-LAN client provides several standard toolbars plus additional, feature-specific toolbars that
are available only when you have selected the applicable feature. The following table lists actions that
you can take to configure toolbars.
Action

How To

Show or hide a toolbar

Right-click on the toolbar area and then choose the toolbar that you want to
show or hide.

Rearrange toolbars

On a toolbar that you want to move, click on the left end of the toolbar and
drag it to where you want it.

Float a toolbar

On the toolbar that you want to float, click on the left end of the toolbar and
drag it off of the toolbar area.

Control whether a
toolbar can be hidden,
rearranged, or floated

Right-click on the toolbar area and then choose the option that you want to
control.

Keyboard Commands
You can use the keyboard to perform many of the commands that you can perform with menu items or
toolbars. The menus show the keyboard equivalent of most menu items. For example, the following list
shows some common menu items and the matching keyboard command:
•

Deploy—Ctrl + S

•

Refresh—F5

•

Filter—Ctrl + F

•

Online help—F1

•

Exit—Ctrl + Q

Multiple Platform Support
DCNM-LAN supports several types of Cisco Nexus platforms; however, some of the features supported
in DCNM-LAN are not supported or applicable to all platforms. This section describes how
DCNM-LAN handles unsupported features in the user interface.
•

Unsupported Features—If a platform does not support a particular feature, the platform is not
displayed for that feature.
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For example, if you choose Security > Access Control > Time-range from the Feature Selector
pane, the Summary pane displays only the platform types that support the Time-range feature. In
this case, the Cisco Nexus 1000V does not support this feature, so any managed Cisco Nexus 1000V
platforms are not displayed in the Summary pane. Similarly, the Time-range association pane does
not include any Cisco Nexus 1000V platforms.
•

Unsupported Attributes—Sometimes a platform supports a feature, but does not support a particular
attribute in that feature. In this case, the attribute is grayed-out or a N/A (Not Applicable) value is
displayed in the field or cell.
If all attributes grouped in a particular section are not supported, N/A is added to the section title,
and DCNM-LAN does not allow you to expand the section.
If all attributes in a tab are not supported for a particular platform, the tab is displayed, but if you
click on it, a message appears stating that the attribute is not supported.

•

Unsupported Charts—If a platform does not support some attributes in a chart, DCNM-LAN grays
out those attributes. If a platform does not support any attributes in a chart, when you select the
chart, DCNM-LAN displays a message stating that the chart is not supported.

•

Unsupported Options—If a platform does not support an option, the option is not displayed, for
example, in drop-down lists.

•

Unsupported Operations— If a platform does not support an option for a specific operation on a
context or toolbar menu, the option is grayed-out.

Opening the DCNM-LAN Client
You can open the DCNM-LAN client after you have installed the DCNM-LAN client on the computer
that you are using.

BEFORE YOU BEGIN
Install the DCNM-LAN client on the computer that you are using.

DETAILED STEPS
Step 1

From the start menu, choose All Programs > Cisco DCNM Client > Cisco DCNM LAN.

Note

If the DCNM-LAN client is not available on the All Programs menu, you can launch the
DCNM-LAN client from the DCNM-LAN server website.

A dialog box displays login fields.
Step 2

In the DCNM Server field, enter the IP address or hostname of the DCNM-LAN server. You can use the
hostname only if your DNS server has an entry for the DCNM-LAN server hostname. If you have
previously logged into the server with the current client installation, you may be able to choose the IP
address or hostname from the drop-down list.

Step 3

In the Username field, enter the name of the DCNM-LAN server user account that you want to use to
access the DCNM-LAN client.

Step 4

In the Password field, enter the password for the user account that you specified.
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Step 5

(Optional) If you need to change the DCNM-LAN server port, do the following:
a.

If the Port field is not visible, click More >>.

b.

Enter the port number in the Port field.
The default DCNM-LAN server port number is 1099; however, you can specify a different port
number when you install or reinstall the DCNM-LAN server.

Step 6

(Optional) If you need to use a proxy server to connect to the DCNM-LAN server, do the following:
a.

If the “Connect to the DCNM-LAN server with a proxy server” check box is not visible, click More
>>.

b.

Check Connect to the DCNM server with a proxy server.
The Proxy Server area appears below the check box.

Step 7

c.

In the Address field, enter the IP address of the proxy server.

d.

In the HTTP Port and Socks Port fields, enter the port numbers on which the proxy server accepts
HTTP and Socks connections.

e.

(Optional) If the proxy server requires authentication, check Authentication and enter a valid
username and password in the fields provided.

Click Login.
The DCNM-LAN client user interface appears.
If a dialog box displays a message about device credentials, you have not configured device credentials
for the user account that you specified.

Step 8

If a dialog box shows a message that your device credentials are not set, do one of the following:
•

If you want to set device credentials now, click Yes.

•

If you do not want to set device credentials now, click No.

•

Closing the DCNM-LAN Client, page 16-9

•

Configuring Default Device Credentials, page 30-3

RELATED TOPICS

Closing the DCNM-LAN Client
You can close the DCNM-LAN client when you are done using it.

DETAILED STEPS
Step 1

From the menu bar, choose File > Exit.
A dialog box displays a confirmation message.

Step 2

(Optional) If you have not deployed your changes, do one of the following:
•

If you want to save your changes, including deploying configuration changes to managed devices,
check Save pending changes.

•

If you want to discard your changes, uncheck Save pending changes.
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Step 3

Click Yes.
If you started any statistical data collection processes during the DCNM-LAN client session, a dialog
box displays the collection processes.

Step 4

If a dialog box displays the statistical data collection processes that you started, do the following:
a.

Decide which statistical collection processes that you want to stop.

Note

We recommend that you stop any unnecessary statistical collection processes when you log
out of the DCNM-LAN client.

b.

Check the collection processes that you want to stop. If you want to stop all of your collection
processes, click Select All.

c.

Click Ok.

•

Opening the DCNM-LAN Client, page 16-8

RELATED TOPICS

Deploying Changes
When you use the DCNM-LAN client to make configuration changes to managed devices or to the
DCNM-LAN server, you may need to deploy the changes or the DCNM-LAN client may deploy them
automatically, depending upon what changes you have made.
•

Automatic deployment—If the DCNM-LAN client deploys a change automatically, the “Deploying
configuration” message appears briefly. For example, if you delete an access rule from an ACL, the
DCNM-LAN client immediately deploys this configuration change to the managed device that has
the ACL.

•

Manual deployment—If the DCNM-LAN client is storing a configuration change, on the toolbar,
the Deploy button is available. For example, if you change the sequence number of an access rule
of an ACL, the DCNM-LAN client stores this configuration change until you manually deploy it to
the managed device that has the ACL.
To remind you of the necessity to deploy changes that the DCNM-LAN client is storing, the
procedures in the DCNM-LAN documentation set include a deployment step.

Deploying server changes saves your changes on the DCNM-LAN server. For example, if you add a
DCNM-LAN server user account, deploying your changes adds the user account to the DCNM-LAN
server and does not affect managed devices.
Deploying configuration changes to a managed device causes the DCNM-LAN server to update the
running configuration of the device.

Note

DCNM-LAN does not update the startup configuration of a managed device. When you want to replace
the startup configuration of a managed device with the running configuration, you can log into the
command-line interface of the device and copy the running configuration to the startup configuration.
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When you close the DCNM-LAN client and you have not deployed your changes, you can deploy them
without canceling the process of closing the DCNM-LAN client. For more information, see the “Closing
the DCNM-LAN Client” section on page 16-9.

Working with Statistics and Charts
This section describes how to use the statistical charts available on a Statistics tab.
This section includes the following topics:
•

Information about Statistics and Charts, page 16-11

•

Licensing Requirements for Statistics and Charts, page 16-11

•

Accessing a Chart, page 16-12

•

Starting Statistical Monitoring for a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using a Chart, page 16-14

•

Using an Overview Chart, page 16-15

•

Exporting a Chart, page 16-16

Information about Statistics and Charts
You can use a Statistics tab to start and stop statistical monitoring for an object and to work with charts
of statistical data about the selected object. For each chart, the DCNM-LAN client also provides
overview charts, which allow you to see historical trends and to control the time scale of the standard
chart.
When you start monitoring for a new chart, DCNM-LAN creates a new statistical collection process that
appears in the Statistical Data Collection feature.

Licensing Requirements for Statistics and Charts
The following table shows the licensing requirements for this feature:
Product

License Requirement

Cisco
DCNM-LAN

Real-time monitoring requires no license.
Cisco DCNM-LAN requires a LAN Enterprise license for the following features:
•

Maintaining a history of statistical data

•

Using overview charts

For information about obtaining and installing a Cisco DCNM-LAN LAN Enterprise license, see the Cisco
DCNM Installation Guide, Release 7.1.x.
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Accessing a Chart
You can access any chart. The charts that are available for a particular Statistics tab depend upon the
feature and object selected.

DETAILED STEPS
Step 1

From the Feature Selector pane, choose the feature for which you want to use a statistical chart.
For example, choose Interfaces > Physical > Ethernet.

Step 2

From the Summary pane, select an object.
The Statistics tab appears in the Details pane.

Note

Step 3

If no Statistics tab appears, DCNM-LAN does not provide a statistical chart for the object that
you selected.

Click the Statistics tab.
In the Statistics tab, one or more charts may appear.

Note

A dialog box may appear to confirm if you want to view charts for statistical collections that
DCNM-LAN is running for the object that you selected in the Summary pane. For more
information, see the “Configuring Monitoring Preferences” section on page 16-17.

Step 4

If the chart for the data that you want to monitor does not appear, from the toolbar, choose New Chart
and then choose the chart that you want.

Step 5

Click the title bar of the chart that you want to work with.
The chart status appears in the lower left corner of the chart pane. If the chart is not active, you must
start statistical monitoring for the chart before you can use it. For more information, see the “Starting
Statistical Monitoring for a Chart” section on page 16-12.

RELATED TOPICS
•

Starting Statistical Monitoring for a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using a Chart, page 16-14

•

Using an Overview Chart, page 16-15

•

Exporting a Chart, page 16-16

Starting Statistical Monitoring for a Chart
You can start statistical monitoring for a chart in the Statistics tab for any of the device configuration
features that support statistical monitoring.
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Note

Each time that you start monitoring for a new chart, DCNM-LAN creates a new statistical collection
process that appears in the Statistical Data Collection feature.

DETAILED STEPS
Step 1

Access the chart for which you want to start statistical monitoring. For more information, see the
“Accessing a Chart” section on page 16-12.

Step 2

From the chart pane, click Select Parameters, check at least one statistical parameter that you want to
appear in the chart, and click Select Parameters again.

Step 3

From the Monitor toolbar, choose the

Step 4

The chart starts graphing the selected parameters.

Note

icon to start the collection process.

When you close the DCNM-LAN client without stopping the statistical collection processes that
you started, a dialog box prompts you to decide whether to stop the statistical collections or let
them continue. We recommend that you stop any unnecessary statistical collection processes
when you log out of the DCNM-LAN client.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using a Chart, page 16-14

•

Using an Overview Chart, page 16-15

•

Exporting a Chart, page 16-16

Stopping Statistical Monitoring for a Chart
You can stop statistical monitoring for a chart in the Statistics tab.

Note

When you stop monitoring for a chart, DCNM-LAN stops the corresponding statistical collection
process that appears in the Statistical Data Collection feature.

DETAILED STEPS
Step 1

Access the chart for which you want to stop statistical monitoring. For more information, see the
“Accessing a Chart” section on page 16-12.

Step 2

From the Monitor toolbar choose the Arrow icon.
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Note

If the chart that you want to stop does not appear, use the Statistical Data Collection feature to
stop the collection process. For more information, see the “Starting Statistical Monitoring for a
Chart” section on page 16-12.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Starting Statistical Monitoring for a Chart, page 16-12

•

Using a Chart, page 16-14

•

Using an Overview Chart, page 16-15

•

Exporting a Chart, page 16-16

Using a Chart
The DCNM-LAN client provides the following options for using a chart:
•

Changing parameters

•

Setting the charting frequency

•

Controlling the magnification of the chart data

•

Showing, moving, and hiding threshold lines

•

Tearing the chart away from the DCNM-LAN client window

This procedure provides basic instructions for using each of these options.

Note

For information about using an overview chart, see the “Using an Overview Chart” section on
page 16-15.

DETAILED STEPS
Step 1

Access the chart that you want to use. For more information, see the “Accessing a Chart” section on
page 16-12.

Step 2

If the chart is not active, you must start statistical monitoring for the chart before you can use it. For
more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

Step 3

(Optional) To change parameters, click Select Parameters, check the statistics parameters that you want
to collect, and click Select Parameters again.

Step 4

(Optional) To set the frequency with which DCNM-LAN retrieves statistical data for the selected object,
from the Select Frequency drop-down list on the Monitor toolbar, choose the new frequency.

Step 5

(Optional) To control the magnification, or zoom, of the chart, do one of the following:
•

To zoom in on a portion of the chart, position the mouse pointer at one end of the portion, click and
hold the left mouse button, drag the mouse pointer to the other end of the portion, and release the
mouse button.
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Step 6

Step 7

•

To zoom in on a portion of the chart, position the mouse pointer at one end of the portion and then
click and drag the mouse pointer to the other end of the portion.

•

To change to the previous zoom, click the

•

To change to the next zoom, click the

•

To reset the zoom to the default magnification, click the

icon.
icon.
icon.

(Optional) To show, move, or hide threshold lines, do one of the following:
•

To show or hide threshold lines, on the Monitor toolbar, click the

•

To move the lower threshold line, click and drag the

icon.

•

To move the lower threshold line, click and drag the

icon.

icon.

(Optional) To tear the chart away from the DCNM-LAN client window, click on the red line that appears
below the chart title.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Starting Statistical Monitoring for a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using an Overview Chart, page 16-15

•

Exporting a Chart, page 16-16

Using an Overview Chart
You can use an overview chart to view the historical trend of the statistical data of the current chart and
to set the time scale of the standard chart.

BEFORE YOU BEGIN
Ensure that any device with data that you want to view on an overview chart is included on the list of
DCNM-LAN-licensed devices. For more information, see the “Licensing Requirements for Statistics
and Charts” section on page 16-11.

DETAILED STEPS
Step 1

Access the chart that contains the overview chart that you want to use. For more information, see the
“Accessing a Chart” section on page 16-12.

Step 2

If the chart is not active, you must start statistical monitoring for the chart before you can use its
overview chart. For more information, see the “Starting Statistical Monitoring for a Chart” section on
page 16-12.

Step 3

Click Show Overview Chart.
In a new window, the overview chart displays the historical trends of the charted data.

Step 4

To set the time scale of the chart, at the bottom of the overview chart window, click the desired time scale
button. The time scale buttons are as follows:
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Step 5

•

RT—Real time

•

1d—One day

•

2d—Two days

•

5d—Five days

•

15d—Fifteen days

•

1m—One month

•

3m—Three months

To close the overview chart, click Show Overview Chart again.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Starting Statistical Monitoring for a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using a Chart, page 16-14

•

Exporting a Chart, page 16-16

Exporting a Chart
You can export a chart as a JPG image or as a comma-separated value (CSV) file.
When you export a chart as a JPG image, the image is of the chart as it appears when you export the
image.
When you export a chart as a CSV file, the file contains all data from the statistical collection for the
chart.

DETAILED STEPS
Step 1

Access the chart that you want to use. For more information, see the “Accessing a Chart” section on
page 16-12.

Step 2

If the chart is not active, you must start statistical monitoring for the chart before you can export an
image of it. For more information, see the “Starting Statistical Monitoring for a Chart” section on
page 16-12.

Step 3

If you want to export an image, configure the chart to show the data that you want to appear in the image.
For more information, see the “Using a Chart” section on page 16-14.

Step 4

Right-click on the chart.

Step 5

Choose one of the following:

Step 6

•

Export as CSV

•

Export as JPG

Specify the location and filename, and then click Save.
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The DCNM-LAN client exports the chart in the file format that you specified.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Starting Statistical Monitoring for a Chart, page 16-12

•

Stopping Statistical Monitoring for a Chart, page 16-13

•

Using a Chart, page 16-14

•

Using an Overview Chart, page 16-15

Configuring Global Preferences
Using the Global Preferences dialog box, you can configure several preferences for how the
DCNM-LAN client displays data and fields. The sections on the Global Preferences are as follows:
•

Monitoring—Controls the default frequency of statistical data retrieval from managed devices and
whether statistical charts open automatically. For more information, see the “Configuring
Monitoring Preferences” section on page 16-17.

•

Events—Controls the maximum age of events that the DCNM-LAN client fetches from the
DCNM-LAN server when you start the DCNM-LAN client. For more information, see the
“Configuring the Maximum Age of Events Fetched from the Server” section on page 16-18.

•

Pre Provision—Controls whether the DCNM-LAN client displays some settings only when other
settings are made or whether the DCNM-LAN client always displays all settings. For more
information, see the “Configuring Preprovisioning” section on page 16-19.

Configuring Monitoring Preferences
You can configure the default frequency for statistical data retrieval from monitored devices. The default
frequency for statistical data retrieval is 30 seconds. This frequency determines the initial data retrieval
frequency for a new chart. Users can override the default frequency by configuring the chart-specific
setting.
You can also configure whether the DCNM-LAN client automatically opens statistical charts when you
access the Statistics tab of an object for which DCNM-LAN is already collecting statistical data.

BEFORE YOU BEGIN
Determine how often you want DCNM-LAN to retrieve statistical data by default. Consider how
important it is to your organization that charts update frequently. If very current charting data is
important to your organization, consider using a short data retrieval frequency.

DETAILED STEPS
Step 1

From the menu bar, choose Tools > Preferences.
The Global Preferences dialog box appears. Under Monitoring, the Default Monitoring Frequency
drop-down list displays the current frequency for statistical data retrieval.
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The default polling frequency is 30 seconds.
Step 2

If you want to configure the default frequency of statistical data retrieval, from the Default Monitoring
Frequency drop-down list, choose the new data retrieval frequency.

Step 3

If you want to configure the default behavior when you access the Statistics tab of an object for which
DCNM-LAN is already collecting statistical data, do one of the following:

Step 4

•

If you want the client to show charts without asking for confirmation, check the Load history charts
by default check box.

•

If you want the client to prompt you for confirmation before it opens statistical charts, uncheck the
Load history charts by default check box.

Click Ok.

RELATED TOPICS
•

Accessing a Chart, page 16-12

•

Configuring the Maximum Age of Events Fetched from the Server, page 16-18

•

Configuring Preprovisioning, page 16-19

Configuring the Maximum Age of Events Fetched from the Server
You can configure the maximum age of events that the DCNM-LAN client fetches from the DCNM-LAN
server when you start the DCNM-LAN client. This setting affects how old the events are that the
DCNM-LAN client displays in the Event Browser and on feature-specific Events tabs. By default, the
DCNM-LAN client fetches events that occurred up to 1 hour prior to the DCNM-LAN client startup. You
can configure the DCNM-LAN client to fetch events that are up to 24 hours old.

DETAILED STEPS
Step 1

From the menu bar, choose Tools > Preferences.
The Global Preferences dialog box appears. Under Events, the Fetch events before drop-down list
displays the current maximum age of events.

Step 2

From the Fetch events before drop-down list, choose the new maximum age of events.

Note

Step 3

To prevent the DCNM-LAN client from fetching any old events, choose zero (0) hours as the
maximum age of events. When you choose zero hours, the DCNM-LAN client shows only the
events that the DCNM-LAN server receives after you start the DCNM-LAN client.

Click Ok.

RELATED TOPICS
•

Configuring Monitoring Preferences, page 16-17

•

Configuring Preprovisioning, page 16-19
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Configuring Preprovisioning
Preprovisioning refers to configuring a managed device with settings for modes or protocols that are not
enabled. The preprovisioning preference affects the following sections of the DCNM-LAN client
interface:
•

Interfaces > Physical > Ethernet > Device > Slot > Interface, Port Details tab, Port Mode Settings
section
When you enable preprovisioning, the DCNM-LAN client displays all port mode fields regardless
of the setting in the Mode drop-down list. When you disable preprovisioning, the DCNM-LAN
client displays only the port mode settings that are relevant to the currently selected port mode. For
example, if preprovisioning is disabled and you choose Trunk from the Mode drop-down list, the
DCNM-LAN client displays only the Trunk settings and hides the Access, PVLAN Host, and
PVLAN Promiscuous fields.
Additionally, the dialog boxes for configuring the Access VLAN field and the Native VLAN field
include the Create in the Device check box. When you enable preprovisioning, you can uncheck this
check box if you want DCNM-LAN to configure the device to refer to a VLAN that is not currently
configured. When you disable preprovisioning, this check box is always checked and DCNM-LAN
creates the VLAN specified, if it does not already exist.

•

Switching > Spanning Tree > Device, Configuration tab, Global Settings section
When you enable preprovisioning, the DCNM-LAN client displays MST settings regardless of the
settings in the Protocol drop-down list. When you disable preprovisioning, the DCNM-LAN client
displays the MST Setting fields unless you choose MST from the Protocol drop-down list.

DETAILED STEPS
Step 1

From the menu bar, choose Tools > Preferences.
The Global Preferences dialog box appears. Under Pre Provision, the Pre Provision check box appears.

Step 2

Step 3

Do one of the following:
•

If you want to enable preprovisioning, ensure that the Pre Provision check box is checked.

•

If you want to disable preprovisioning, ensure that the Pre Provision check box is unchecked.

Click Ok.

RELATED TOPICS
•

Configuring Monitoring Preferences, page 16-17

•

Configuring the Maximum Age of Events Fetched from the Server, page 16-18

Using Online Help
Online help has the following features:
•

Contents—The organization of DCNM-LAN online help is shown in the Contents tab of the online
help window. When a topic has subtopics, the book icon appears to the left of the topic in the
contents.
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You can expand and collapse individual topics in the contents. You can also collapse or expand all
topics.
•

Index—DCNM-LAN online help includes an index, which allows you to look up subjects
alphabetically and open related topics directly from the index.

•

Favorites—DCNM-LAN online help allows you to add specific topics to the Favorites tab. Favorites
are stored locally on the computer that you use to access online help.

To access the welcome page in online help, from the menu bar, choose Help > Help Contents.
DCNM-LAN online help includes context-sensitive help.
To access context-sensitive help for a feature, follow these steps:
Step 1

Select a specific feature from the Feature Selector pane in the DCNM-LAN client. For example, choose
Security > Access Control > IPv4 ACL.

Step 2

Do one of the following:
•

Press F1.

•

From the toolbar, click the question mark icon.

Online help for the selected feature appears in a browser window. DCNM-LAN uses the default browser
application on the computer that runs the DCNM-LAN client.
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