Cisco has more than 200 offices worldwide. Addresses, phone numbers, and fax numbers are listed on the Cisco website at www.cisco.com/go/offices.
### CONTENTS

#### Preface
- 61

#### New and Changed Information
- 69

#### Chapter 1
- Introduction to Cisco Data Center Network Manager
  - 1-69

#### Chapter 2
- Cisco DCNM Fundamentals Overview
  - 2-1
  - DCNM-SAN Server
  - DCNM-SAN Client
  - Device Manager
  - DCNM-SAN Web Client
  - Performance Manager
  - Authentication in DCNM-SAN Client
  - Cisco Traffic Analyzer
  - Network Monitoring
  - Performance Monitoring

#### Chapter 3
- Cisco Prime DCNM User Roles
  - 3-1
  - Cisco DCNM Credentials
  - Cisco DCNM Users
  - DCNM Roles
  - Roles from Cisco DCNM Perspective
    - Admin Perspective
      - Web Client Admin Perspective
      - SAN Thick Client Admin Perspective
    - Server Admin Perspective
      - Web Client Server Admin Perspective
      - SAN Thick Client Server Admin Perspective
    - SME Perspective
      - Web Client SME Admin Perspective
      - SME Storage Perspective
      - SME Key Management Perspective
      - SME Recovery Perspective
      - SAN Thick Client SME Perspective

---

**Text Part Number:**
Contents

Operator Perspective  3-5
Web Client Operator Perspective  3-5
SAN Thick Client Operator Perspective  3-5

CHAPTER 1
Cisco DCNM Web Client  1-1
Navigating DCNM Web Client  1-1
Scope Menu  1-2
Admin Menu  1-2
Table and Filtering Navigation  1-2
Printing  1-2
Exporting to a File  1-2
Sorting Columns  1-3
Cisco DCNM Web Search Engine  1-3
Using the Cisco DCNM Search Engine  1-3
Downloading Cisco DCNM-SAN Client  1-3
Downloading Cisco DCNM-LAN Client  1-4
Connecting to a Switch using the CLI  1-4
Adding a Security Exception  1-5
Viewing Dashboard Information  1-5
Summary  1-5
  Health  1-6
  Inventory  1-6
  Top CPU  1-6
  Top ISLs/Trunks  1-6
  Top SAN Host Ports  1-7
  Top SAN Storage Ports  1-7
  Viewing Health Summary Information  1-7
  Viewing Performance Summary Information  1-7
  Viewing Inventory Summary Information  1-8
Differences by changing the Scope to default LAN or configured switch group  1-8
  Topology  1-8
Differences by changing the Scope to default SAN or configured switch group  1-11
  New Area - Daily Performance  1-11
Fabric  1-11
  Inter Switch Links View  1-12
  Edge Ports View  1-13
  Health  1-13
Switch Dashboard  1-14
Contents

Cisco DCNM Fundamentals Guide, Release 7.1.x

OL-30761-01

Compute  1-15
  Viewing Host Enclosures  1-15
  Viewing Host Events  1-16
  Viewing Host Topology  1-16
  View Host Traffic  1-16

Network  1-17

Storage  1-17
  Viewing Storage Enclosure  1-17
  Viewing Storage Enclosure Events  1-18
  Viewing Storage Enclosure Topology  1-18
  Viewing Storage Enclosure Traffic  1-18

Viewing Storage Systems  1-19
  Components  1-19
  Pools  1-19
  LUNs  1-20
  Filer Volumes  1-20
  Hosts  1-21
  Storage Processors  1-21
  Storage Ports  1-21

Viewing Health Information  1-22
  Viewing Accounting Information  1-22
  Viewing Events Information  1-22
  SAN Host Redundancy  1-23
    SAN Path Errors  1-23
    Settings  1-24
  Slow Drain Analysis  1-25
  Viewing a vPC  1-25
    Viewing vPC Inconsistencies  1-26
    Resolving vPC Inconsistencies  1-27

Viewing Performance Information  1-27
  Rx/Tx Calculation  1-28
  Viewing Switch CPU Information  1-28
  Viewing Switch Memory Information  1-28
  Viewing Switch Traffic and Errors Information  1-28
  Viewing ISL Traffic and Errors Information  1-29
  Viewing Performance Information for Ethernet Ports  1-29
  Viewing Other Statistics  1-30
  Viewing Performance Information for NPV Links  1-30
  Viewing Performance Information on All Ports  1-31
  Viewing Performance Information on Host Ports  1-31
Adding an Organization 1-65
Editing an Organization 1-65
Deleting an Organization 1-65
Adding a Partition 1-65
Editing a Partition 1-66
Deleting a Partition 1-66
Adding a Network 1-66
Editing a Network 1-67
Deleting a Network 1-67
Profiles 1-67
  Adding a profile 1-68
  Editing a Profile 1-69
  Delete a Profile 1-69
  Editing a Profile Instance 1-69
Administering Cisco DCNM Web Client 1-69
  Starting, Restarting, and Stopping Services 1-70
Administering Datasources 1-70
  Adding, Editing, Re-discovering, Purging and Removing Managed Fabrics 1-71
  Adding, Editing, Re-discovering, Purging and Removing LAN, LAN Tasks and Switch 1-73
  Adding, Editing, Re-discovering and Removing VMware Servers 1-76
  Adding, editing, removing, rediscovering and refreshing SMI-S Storage 1-78
Viewing Log Information 1-79
Configuring Cisco DCNM-SAN Server Properties 1-79
Configuring SFTP/TFTP Credentials 1-94
Managing Switch Groups 1-95
  Adding Switch Groups 1-96
  Renaming a Group 1-96
  Deleting a Group or a Member of a Group 1-96
  Moving a Switch to Another Group 1-97
  Moving a Switch Group to Another Group 1-97
Managing Custom Port Groups 1-97
  Adding Custom Port Groups 1-97
  Configuring Switch and Interface to the Port Group 1-97
  Generating Reports for the Custom Port Groups 1-98
  Removing Port Group Member 1-98
  Removing Port Group 1-98
Managing Licenses 1-99
Viewing Licenses Using the Cisco DCNM Wizard 1-99
  Automatic License Assignment 1-101
  Adding Cisco DCNM Licenses 1-101
Assigning Licenses 1-101
Unassigning Licenses to a Switch 1-102
Viewing Server Federation 1-102
Configuring AAA Properties 1-102
  Local 1-103
  Radius 1-103
  TACACS+ 1-103
  Switch 1-103
  LDAP 1-103
Adding and Removing Users 1-104
  Adding Local Users 1-104
  Editing a User 1-105
  Removing a User 1-105
Managing Clients 1-105
Performance Manager Collections 1-105
Configuring the RRD Database 1-106
  Importing the RRD Statistics Index 1-106
Configuring Other Statistics 1-107
Viewing Events Registration 1-107
Adding Notification Forwarding 1-108
  Adding Notification Forwarding 1-108
  Removing Notification Forwarding 1-109
Configuring EMCallHome 1-109
Event Suppression 1-109
  Add Event Suppression Rules 1-110
  Delete Event Suppression Rule 1-111
  Modify Event Suppression Rule 1-111
Using Cisco DCNM Web Client with SSL 1-111
  Using a self signed SSL Certificate 1-111
  Using a SSL Certificate when certificate request is generated using OpenSSL 1-112
  Using a SSL Certificate when certificate request is generated using Keytool 1-113
  SSL for Federated (High Availability) setup 1-113
Fabric—General Settings 1-114
Border Leaf Settings 1-114
  Configuring Border Leaf Settings 1-115
Border Leaf Device Pairing 1-115
  Creating an Edge Router 1-116
  Connect New Border leaf to the Edge Router 1-117
  Deleting Edge Router/Border leaf devices 1-117
Border Leaf Extended Partitions  1-118
POAP Settings  1-118
Fabric Encapsulation Settings  1-119
L2 Segment ID Range Management  1-119
  Add Orchestrator  1-120
  Modify Orchestrator  1-120
  Delete Orchestrator  1-120
Mobility Domains  1-120
  Add Mobility Domains  1-121
  Modify Mobility Domains  1-121
  Delete Mobility Domains  1-121

CHAPTER 2
Configuring Cisco DCNM-SAN Server  2-1
  Information About Cisco DCNM-SAN Server  2-1
    DCNM-SAN Server Features  2-1
  Licensing Requirements For Cisco DCNM-SAN Server  2-2
  Installing and Configuring Cisco DCNM-SAN Server  2-2
    Installing Cisco DCNM-SAN Server  2-3
    Data Migration in Cisco DCNM-SAN Server  2-7
    Verifying Performance Manager Collections  2-7
  Managing a Cisco DCNM-SAN Server Fabric  2-7
    Selecting a Fabric to Manage Continuously  2-8
    Cisco DCNM-SAN Server Properties File  2-8
  Modifying Cisco DCNM-SAN Server  2-10
    Changing the Cisco DCNM-SAN Server Username and Password  2-10
    Changing the DCNM-SAN Server Fabric Discovery Username and Password  2-11
    Changing the Polling Period and Fabric Rediscovery Time  2-11
    Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS WINDOWS Server  2-12
    Changing the IP Address of the Cisco DCNM-SAN for Federated Windows Setup  2-12
      Changing the IP address of primary server  2-12
      Changing the IP address of secondary server  2-13
    Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS LINUX Server  2-13
    Using Device Aliases or FC Aliases  2-14
  Configuring Security Manager  2-15
  Server Federation  2-15
    Restrictions  2-15
    Mapping Fabric ID to Server ID  2-16
    Opening the Fabric on a Different Server  2-17
Viewing the Sessions in a Federation 2-18
Viewing the Servers in a Federation 2-19
Discover Devices Managed by SVI 2-19
Additional References 2-20

**CHAPTER 3**
Configuring Authentication in Cisco DCNM-SAN 3-1
Information About Cisco DCNM-SAN Authentication 3-1
Best Practices for Discovering a Fabric 3-2
Setting Up Discovery for a Fabric 3-3
Performance Manager Authentication 3-3
Cisco DCNM-SAN Web Client Authentication 3-4

**CHAPTER 4**
Configuring Cisco DCNM-SAN Client 4-1
Information About DCNM-SAN Client 4-1
Cisco DCNM-SAN Advanced Mode 4-2
Cisco DCNM-SAN Client Quick Tour: Server Admin Perspective 4-2
Cisco DCNM-SAN Main Window 4-2
Menu Bar 4-4
Tool Bar 4-4
Logical Domains Pane 4-4
Physical Attributes Pane 4-4
Information Pane 4-5
Fabric Pane 4-6
Cisco DCNM-SAN Client Quick Tour: Admin Perspective 4-6
Menu Bar 4-8
File 4-8
View 4-9
Zone 4-9
Tools 4-10
Performance 4-11
Server 4-12
Help 4-12
Toolbar 4-12
Logical Domains Pane 4-14
Filtering 4-14
Physical Attributes Pane 4-15
Context Menu for Tables 4-15
Information Pane 4-18
Detachables Tables 4-19
## Fabric Pane
- Context Menus 4-21
- Saving the Map 4-22
- Purging Down Elements 4-22
- Multiple Fabric Display 4-22
- Filtering by Groups 4-23
- Status Bar 4-25

## Launching Cisco DCNM-SAN Client
- Launching Fabric Manager Client in Cisco SAN-OS Release 3.2(1) and Later 4-25
- Launching Cisco DCNM-SAN Client Using Launch Pad 4-31

## Setting Cisco DCNM-SAN Preferences 4-33

## Network Fabric Discovery 4-35

## Network LAN Discovery
- Viewing Ethernet Switches 4-35
- Removing a LAN 4-36

## Modifying the Device Grouping 4-37
- Using Alias Names as Enclosures 4-38
- Using Alias Names as Descriptions 4-39

## Controlling Administrator Access with Users and Roles 4-40

## Using Cisco DCNM-SAN Wizards 4-40

## Cisco DCNM-SAN Troubleshooting Tools 4-41

## Integrating Cisco DCNM-SAN and Data Center Network Management Software 4-41
- Launching a Switch from the Topology Map 4-42

### CHAPTER 5

**Device Manager** 5-1

- Information About Device Manager 5-1
- Device Manager Features 5-2
- Using Device Manager Interface 5-2
- Menu Bar 5-3
- Toolbar Icons 5-4
- Dialog Boxes 5-5
- Tabs 5-6
- Legend 5-6
- Supervisor and Switching Modules 5-7
- Context Menus 5-7

## Launching Device Manager 5-8

## Setting Device Manager Preferences 5-9
CHAPTER 6

Configuring Performance Manager 6-1

- Information About Performance Manager 6-1
  - Data Interpolation 6-2
  - Data Collection 6-2
  - Using Performance Thresholds 6-2

Flow Statistics 6-3

Flow Setup Wizards 6-4
  - Creating a Flow Using Performance Manager Flow Wizard 6-4

CHAPTER 7

Monitoring the Network 7-1

- Information About Network Monitoring 7-1
  - Monitoring Health and Events 7-1
    - DCNM-SAN Events Tab 7-2
    - Event Information in DCNM-SAN Web Server Reports 7-2
    - Events in Device Manager 7-2
    - SAN Discovery and Topology Mapping 7-2

Device Discovery 7-2
  - Topology Mapping 7-3
    - Using the Topology Map 7-3
    - Saving a Customized Topology Map Layout 7-3
    - Using Enclosures with DCNM-SAN Topology Maps 7-4
    - Mapping Multiple Fabrics 7-4

Inventory Management 7-4
  - Using the Inventory Tab from DCNM-SAN Web Server 7-5
  - Viewing Logs from Device Manager 7-5

CHAPTER 8

Monitoring Performance 8-1

- Information About Performance Monitoring 8-1
  - Real-Time Performance Monitoring 8-1
  - Historical Performance Monitoring 8-2

Configuring Performance Manager 8-2
  - Creating a Flow with Performance Manager 8-2
  - Creating a Collection with Performance Manager 8-2
  - Using Performance Thresholds 8-3

Configuring the Summary View in Device Manager 8-4

Configuring Per Port Monitoring using Device Manager 8-4
Displaying DCNM-SAN Real-Time ISL Statistics 8-5
   Using the Performance Manager Configuration Wizard 8-6
   Viewing Performance Statics Using DCNM-SAN 8-6
Displaying Performance Manager Reports 8-7
   Displaying Performance Summary 8-8
   Displaying Performance Tables and Details Graphs 8-8
   Displaying Performance of Host-Optimized Port Groups 8-8
   Displaying Performance Manager Events 8-8
Generating Performance Manager Reports 8-9
   Generating Top10 Reports in Performance Manager 8-9
   Generating Top10 Reports Using Scripts 8-9
   Configuring Performance Manager for Use with Cisco Traffic Analyzer 8-10
Exporting Data Collections 8-12
   Exporting Data Collections to XML Files 8-12
   Exporting Data Collections in Readable Format 8-12
Analyzing SAN Health 8-13
   Installing the SAN Health Advisor Tool 8-14

Chapter 9

Software Images 9-1
   Information About Software Images 9-1
      Software Upgrade Methods 9-2
      Determining Software Compatibility 9-2
      Automated Upgrades 9-3
      Benefits of Using the install all Command 9-4
      Benefits of Using the Software Install Wizard 9-4
      Recognizing Failure Cases 9-5
   Prerequisites for Installing Software Images 9-5
      Selecting the Correct Software Images for Cisco MDS 9100 Series Switches 9-6
      Selecting the Correct Software Images for Cisco MDS 9200 Series Switches 9-6
      Selecting the Correct Software Images for Cisco MDS 9500 Family Switches 9-6
      Essential Upgrade Prerequisites 9-7
   Default Settings 9-9
   Using the Software Install Wizard 9-10
      Using the Software Install Wizard 9-10
         Upgrading Services Modules 9-16
      Using the install all Command 9-17
         Upgrading Services Modules 9-20
         Sample install all Commands 9-21
   Upgrade Status Verification 9-28
Performing Nondisruptive Upgrades on Fabric and Modular Switches 9-29
Preparing for a Nondisruptive Upgrade on Fabric and Modular Switches 9-29
Performing a Nondisruptive Upgrade on a Fabric Switch 9-32
Viewing the Status of a Nondisruptive Upgrade on a Fabric Switch 9-34
Troubleshooting a Nondisruptive Upgrade on a Fabric Switch 9-34
Manual Upgrade on a Dual Supervisor Module Switch 9-35
Preparing for a Manual Installation 9-35
Upgrading a Loader 9-36
Upgrading the BIOS 9-38
Quick Upgrade 9-39
Downgrading from a Higher Release 9-40
Maintaining Supervisor Modules 9-41
Replacing Supervisor Modules 9-41
Migrating from Supervisor-1 Modules to Supervisor-2 Modules 9-41
Setting Standby Supervisor Module Boot Variable Version 9-42
Setting Standby Supervisor Module Bootflash Memory 9-42
Standby Supervisor Module Boot Alert 9-42
Installing Generation 2 Modules in Generation 1 Chassis 9-42
Replacing Modules 9-43
9-44

CHAPTER 10
Management Software FAQ 10-1
Installation Issues 10-3
When installing Cisco DCNM-SAN from windows, why does clicking install fail? 10-3
Why do I have trouble launching Cisco DCNM-SAN on Solaris? 10-3
What do I do if my browser prompts to save JNLP files? 10-3
What do I do if I see a "Java Web Start not detected" error? 10-4
What do I do if my desktop shortcuts not visible? 10-4
How do I upgrade to a newer version of Cisco DCNM-SAN or Device Manager? 10-4
How do I downgrade Cisco DCNM-SAN or Device Manager? 10-4
What do I do if an upgrade is not working? 10-5
What do I do if Java Web Start hangs on the download dialog? 10-5
How do I manually configure a browser for Java Web Start? 10-5
How do I run Java Web Start from the command line? 10-6
How do I clear the Java Web Start cache? 10-6
What do I do if during a Cisco DCNM-SAN upgrade, the installer doesn’t display a prompt to create a shortcut? 10-6
What do I do if my login does not work in Cisco DCNM-SAN or Device Manager? 10-6
What do I do if I cannot install Cisco DCNM-SAN or Device Manager, or run Java, when pcAnyWhere is running? 10-6
What do I do if the Cisco DCNM-SAN or Performance Manager service shows up as “disabled” in the Services menu? 10-7
What do I do if I am unable to install Cisco DCNM-SAN or Device Manager, or run Java, when McAfee Internet Suite 6.0 Professional is running? 10-7

General 10-7
What do I do if I see errors while monitoring Area chart graphing? 10-7
What do I do if I see "gen error" messages? 10-7
What do I do if disk images in the Device Manager Summary View are not visible? 10-7
What do I do if I am unable to set both the D_S_TOV and E_D_TOV timers in Device Manager? 10-8
What do I do if columns in Device Manager tables are too small? 10-8
What do I do if fabric changes are not propagated onto the map (for example, links don’t disappear)? 10-8
What do I do if the PortChannel creation dialog becomes too small after several uses? 10-8
What do I do if I see errors after IPFC configuration? 10-8
What do I do if Cisco DCNM-SAN or Device Manager is using the wrong network interface? 10-8
What do I do if I see display anomalies in Cisco DCNM-SAN or Device Manager? 10-9
What do I do if most of my Physical Attributes catagories disappear? 10-9
What do I do if I can’t see the Information pane? 10-9
Why is the active zone set in edit zone always shown in bold (even after successful activation)? 10-9
Can I create a zone with prefix IVRZ or a zone set with name nozonset? 10-9
What do I do when One-Click License Install fails, and I cannot connect to the Cisco website? 10-9
How do I increase the log window size in Cisco DCNM-SAN Client? 10-10
When do I do when the FM Server Database fails to start or has a file locking error? 10-10
How do I re-synchronize Cisco DCNM-SAN Client with Cisco DCNM-SAN Server? 10-10
How do I rediscover the current fabric? 10-10
How do I rediscover SCSI Targets? 10-10

Windows Issues 10-11
What do I do when text fields show up too small, and I cannot enter any data? 10-11
What do I do when printing causes an application crash? 10-11
What do I do when Windows XP hangs (or I see a blue screen)? 10-11
What do I do when Cisco DCNM-SAN and Device Manager Icons Disappear? 10-11
What do I do when Device Manager or Cisco DCNM-SAN window content disappears in Windows XP? 10-11
What do I do when SCP/SFTP fails when a file is copied from local machine to the switch? 10-12

UNIX Issues 10-12
What do I do when the parent Menus Disappear? 10-12
What do I do when the web browser cannot find web server even it is running? 10-12
How do I fix a "too many open files" error? 10-12
Contents

Other 10-13
How do I set the map layout so it stays after Cisco DCNM-SAN restarted? 10-13
What do I do when two switches show on the map, but there is only one switch? 10-13
What does a red/orange/dotted line through the switch mean? 10-13
How do I upgrade without losing map settings? 10-19
How do I preserve historical data when moving Cisco DCNM-SAN server to new host? 10-19
Are there restrictions when using Cisco DCNM-SAN across FCIP? 10-20
How do I fix a "Please insure that FM server is running on localhost" message? 10-20
How do I run Cisco DCNM-SAN with multiple interfaces? 10-20
Manually specifying an interface for Cisco DCNM-SAN Server 10-21
Manually specifying an interface for Cisco DCNM-SAN Client or Device Manager 10-21
How do I configure an HTTP proxy server? 10-21
How do I clear the topology map? 10-22
How can I use Cisco DCNM-SAN in a mixed software environment? 10-22
How do I fix a "corrupted jar file" error when Launching Cisco DCNM-SAN? 10-22
How do I search for Devices in a Fabric? 10-23
How do I search in a table? 10-24
How does Cisco DCNM-SAN Server licensing work? 10-24
How do I manage Multiple Fabrics? 10-25
How can I clear an Orange X Through a Switch caused by license expiration? 10-25
How can I set a consistent unit of measure for the Performance Manager data export? 10-25

CHAPTER 11  
Overview of DCNM-LAN 11-1
DCNM-LAN Client and Server 11-1
Features in Cisco DCNM-LAN, Release 5.2 11-2
Platform Support 11-3
Documentation About DCNM-LAN 11-3

CHAPTER 12  
Installing and Launching the Cisco DCNM-LAN Client 12-1
Information About Installing and Launching the DCNM-LAN Client 12-1
Prerequisites for Installing and Launching the DCNM-LAN Client 12-2
Secure Client Communications 12-2
Default Administrator Credentials 12-3
Downloading and Launching the DCNM-LAN Client 12-3
Using a Web Browser to Download and Launch the DCNM-LAN Client 12-3
Using a Command Prompt to Download and Launch the DCNM-LAN Client 12-4
Using a Command Prompt to Download and Launch the DCNM-LAN Client without using Java Web Start Launcher 12-5
Restarting the DCNM-LAN Client 12-6
Logging Into the DCNM-LAN Client 12-7
Uninstalling the DCNM-LAN Client 12-8
Modifying Cisco DCNM-LAN Server 12-9
  Changing the IP Address of the Cisco DCNM-LAN for WINDOWS OS 12-9
  Changing the IP Address of the Cisco DCNM-LAN on Federated Windows OS 12-10
  Changing the IP Address of the Cisco DCNM-LAN on Linux OS 12-10
Additional References 12-11
Related Documents 12-11
Standards 12-11
Feature History for Installing and Launching the DCNM-LAN Client 12-12

CHAPTER 13
Using the Cisco DCNM-LAN Client 13-1
  Information About the DCNM-LAN Client 13-1
    User Interface 13-2
    Feature Selector Pane 13-2
    Contents Pane 13-3
    Summary Pane 13-3
    Details Pane 13-3
    Association Pane 13-4
    Menus 13-5
    Toolbars 13-7
    Keyboard Commands 13-7
    Multiple Platform Support 13-7
  Opening the DCNM-LAN Client 13-8
  Closing the DCNM-LAN Client 13-9
  Deploying Changes 13-10
  Working with Statistics and Charts 13-11
    Information about Statistics and Charts 13-11
    Licensing Requirements for Statistics and Charts 13-11
    Accessing a Chart 13-12
    Starting Statistical Monitoring for a Chart 13-12
    Stopping Statistical Monitoring for a Chart 13-13
    Using a Chart 13-14
    Using an Overview Chart 13-15
    Exporting a Chart 13-16
  Configuring Global Preferences 13-17
    Configuring Monitoring Preferences 13-17
Accessing Cisco FabricPath Features from the Topology Map 15-33
  Multi-destination 15-33
  Device Reachability 15-34
  Unicast 15-35
  Multicast 15-36
Launching the vPC Wizard 15-37
Managing a vPC 15-38
Finding and Resolving vPC Configuration Inconsistencies 15-39
Accessing Remotely Connected CNAs from the Topology Map 15-39
Using VSAN Overlay 15-40
Related Documents 15-41
Feature History for Topology 15-41

CHAPTER 16

Working with Inventory 16-1
  Information About Inventory 16-1
  Understanding Inventory 16-2
  Understanding Power Usage 16-2
  Module Pre-Provisioning 16-2
    Supported Hardware 16-2
    Upgrades and Downgrades 16-3
  Licensing Requirements for Inventory 16-3
  Prerequisites 16-3
  Platform Support 16-3
  Configuring Module Pre-Provisioning 16-4
    Pre-Provisioning Offline Modules 16-4
    Pre-Provisioning Online Modules 16-4
    Pre-Provisioning FEX Modules 16-5
  Reloading a Line Card 16-5
  Displaying Inventory Information 16-6
    Displaying the Chassis Information 16-6
    Displaying the Module Information 16-7
    Displaying the Power Supply Information 16-8
    Displaying the Fan Tray Information 16-8
  Displaying Power Usage Information 16-9
    Displaying Power Usage Summary Information 16-9
    Displaying Power Usage Details 16-9
    Displaying Power Usage Statistics 16-10
  Field Descriptions 16-10
CHAPTER 17
Managing Virtual Devices 17-1
Managing Virtual Switches 17-1
Creating VDCs with the VDC Setup Wizard 17-1
Managing VDCs 17-2

CHAPTER 18
Configuring Interfaces on DCNM-LAN Client 18-1
Configuring Basic Interface Parameters 18-2
Configuring Layer 2 Interfaces 18-3
Configuring Layer 3 Interfaces 18-4
Configuring Port Channels 18-4
Configuring vPCs 18-5
Configuring IP Tunnels 18-6
Configuring Virtual Ethernet Interfaces 18-6
Configuring Fabric Extenders 18-6
Configuring Port Profiles 18-7

CHAPTER 19
Configuring Switching on DCNM-LAN Client 19-1
Configuring VLANs 19-1
Configuring Private VLANs 19-2
Configuring STP Extensions 19-2
Configuring Rapid PVST+ 19-3
Configuring MST 19-3
Configuring Link-State Tracking 19-3
Configuring FabricPath Switching 19-3
FabricPath Forwarding 19-4
Configuring Advanced FabricPath Features 19-4
Using the Layer 2 Security Audit Wizard 19-4
Configuring Dynamic ARP Inspection 19-4
Configuring Port Security 19-5
Configuring DHCP Snooping 19-6
Configuring IP Source Guard 19-6
Working with the Version Browser 22-6
  Viewing the Archival Status of a Device 22-7
  Viewing the Archival History of a Device 22-8
  Browsing and Commenting on Configuration Versions 22-8
  Using Copy Run to Start 22-9
  Archiving the Current Running Configuration of a Device 22-9
  Viewing an Archived Configuration Version 22-10
  Comparing Configuration Versions 22-11
  Using the Version Comparison Tools 22-13
  Merging Configuration Differences 22-14
  Performing a Configuration Rollback 22-15
  Viewing the Rollback History of a Device 22-16
  Deleting All Archived Configurations for a Device 22-17

Configuring Archival Jobs 22-18
  Configuring an Archival Job 22-18
  Enabling and Disabling an Archival Job 22-20
  Deleting an Archival Job 22-20
  Viewing Details of an Archival Job 22-21
  Viewing the History of an Archival Job 22-21

Configuring Archival Settings 22-22
  Configuring Version and History Settings 22-22
  Configuring the Rollback File Server Setting 22-23

Configuring Switch Profiles 22-23
  Configuring a Switch Profile 22-24
  Configuring the Switch Profile Wizard Between Two vPCs 22-24
  Configuring the Switch Profile Wizard Between Two Switches 22-25
  Configuring the Sync Network View 22-25
  Configuring the Switch Profile Migration Wizard for Dual Homed FEXes 22-26

Field Descriptions for Configuration Change Management 22-27
  Field Descriptions for the Version Browser 22-27
    Device: Details: Archival Status Section 22-28
    Device: Details: Rollback History Section 22-28
    Device: Details: Archival History Section 22-28
    Version: Version Details Tab 22-28
    Version: Compare Tab 22-29
  Field Descriptions for Archival Jobs 22-29
    Archival Job: Details Tab 22-29
    Archival Job: Archival History Tab 22-30
  Field Descriptions for the Archival Settings Contents Pane 22-31
CHAPTER 23  
Managing Device Operating Systems  23-1

Information About Device OS Management  23-1
Device OS Management Screen  23-2
Software Installation Jobs  23-2
File Servers  23-3
VDC Support  23-3

Licensing Requirements for Device OS Management  23-3

Prerequisites  23-4

Guidelines and Limitations for Device OS Management  23-4

Platform Support  23-4

Using the Device OS Management Window  23-5
Viewing Device Image Details  23-5
Installing Software on a Device  23-5

Configuring Software Installation Jobs  23-7
Viewing Software Installation Job Details  23-7
Creating or Editing a Software Installation Job  23-8
Using the Software Installation Wizard  23-9
Rescheduling a Software Installation Job  23-12
Deleting a Software Installation Job  23-13
Adding or Changing Comments for a Software Installation Job  23-13
Changing Installation Options for a Software Installation Job  23-14

Configuring File Servers  23-15
Adding a File Server  23-15
Changing a File Server  23-16
Deleting a File Server  23-17

Field Descriptions for Device OS Management  23-18

Field Descriptions for Device OS Management  23-18
Device: Details: System Section  23-18
Device: Details: Software Installation Jobs Section  23-18

Field Descriptions for Software Installation Jobs  23-19
Installation Job: Details: General Section  23-19
CHAPTER 24  Starting and Stopping Cisco DCNM-LAN Servers 24-1

Starting and Stopping Cisco DCNM-LAN Servers 24-1

Starting and Stopping Cisco DCNM-LAN Servers 24-1

Licensing Requirements for Starting and Stopping Cisco DCNM-LAN Servers 24-1

Starting DCNM-LAN Servers 24-2

Starting a Single DCNM-LAN Server 24-2

Starting a Single DCNM-LAN Server (Microsoft Windows Server) 24-2

Starting a Single DCNM-LAN Server (RHEL) 24-2

Starting a Cluster of DCNM-LAN Servers 24-3

Starting with Windows GUI or RHEL CLI 24-3

Starting with Install Manager 24-4

Stopping DCNM-LAN Servers 24-5

Stopping Single DCNM-LAN Servers 24-5

Stopping a Single DCNM-LAN Server (Microsoft Windows Server) 24-5

Stopping a Single DCNM-LAN Server (RHEL) 24-6

Stopping a Cluster of DCNM-LAN Servers 24-6

Stopping with CLI 24-6

Example 24-7

Stopping with Install Manager 24-7

Related Documents 24-8

Feature History for Starting and Stopping a DCNM-LAN Server 24-9

CHAPTER 25  Data Center Network Manager (DCNM) - Vacuum and Autovacuum Postgres Databases 25-1

Background Information 25-1

Vacuum DCNM’s Postgresql Database in Windows 25-1

Vacuum DCNM’s Postgresql Database in Linux 25-2

CHAPTER 26  Administering Device Discovery 26-1

Information About Device Discovery 26-1

Device Discovery 26-2

Discovery Protocols 26-2
CHAPTER 27

Device Administration 27-1

Devices 27-2
Credentials 27-2
Device Status 27-2
VDC Support 27-2

Licensing Requirements for Devices and Credentials 27-3
Prerequisites for Administration of Devices and Credentials 27-3
Guidelines and Limitations for Devices and Credentials 27-3

Configuring Devices and Credentials 27-3
  Configuring Default Device Credentials 27-3
  Clearing Default Device Credentials 27-4
  Configuring Unique Credentials for a Device 27-5
  Clearing Unique Credentials for a Device 27-6

Viewing Device Credentials and Status 27-7

Field Descriptions for Devices and Credentials 27-8
  Device and Credentials Content Pane 27-8

Additional References for Devices and Credentials 27-9
  Related Documents 27-9
  Standards 27-9

Feature History for Devices and Credentials 27-10

CHAPTER 28

Administering Auto-Synchronization with Devices 28-1

Information About Auto-Synchronization with Devices 28-1
  Automatic and Manual Purging of Event Data 28-2
  Virtualization Support 28-2

Licensing Requirements for Auto-Synchronization with Devices 28-2
Prerequisites for Auto-Synchronization with Devices 28-2
Guidelines and Limitations for Auto-Synchronization with Devices 28-3

Configuring Device Auto-Synchronization 28-3
  Starting and Stopping a Poller 28-3
  Configuring the Polling Interval 28-4
  Synchronizing with a Device 28-5
  Deleting Data from the Events Database 28-5
  Enabling and Disabling Automatic Event Purging 28-6
  Configuring Automatic Event Purge Settings 28-7
  Purging Events Now 28-8

Viewing the Status of Auto-Synchronization Pollers 28-9

Field Descriptions for Auto-Synchronization with Devices 28-9
  Poller Setting Tab 28-9
Threshold Rule Examples

Triggering an Action Each Time a Threshold is Crossed

Triggering an Action Only Once in a Period When a Threshold is Crossed

Triggering an Action Every Fourth Period When a Threshold is Crossed

Licensing Requirements for Threshold Rules

Configuring Threshold Rules

Creating Threshold Rules

Deleting Threshold Rules

Editing Threshold Rules

Viewing Threshold Rules

Applying a Threshold Rule to a Chart

Additional References

Related Documents

Standards

Feature History for Threshold Rules

CHAPTER 31

Administering DCNM-LAN Server Log Settings

Information About Administering DCNM-LAN Server Log Settings

Logging Levels

Log File and Location

Virtualization Support

Licensing Requirements for Administering DCNM-LAN Server Log Settings

Prerequisites for Administering DCNM-LAN Server Log Settings

Guidelines and Limitations for Administering DCNM-LAN Server Log Settings

Configuring DCNM-LAN Server Log Settings

Configuring the Default Logging Level

Configuring a Unique Logging Level for a Feature or Server Component

Configuring a Feature or Server Component to Use the Default Logging Level

Viewing DCNM-LAN Server Log Settings

Field Descriptions for DCNM-LAN Server Log Settings

DCNM-LAN Server Log Settings Contents Pane

Additional References

Related Documents

Standards

Feature History for DCNM-LAN Server Log Settings

CHAPTER 32

Managing Events

Information About Events
Licensing Requirements for the Event Browser 32-2
Prerequisites 32-2
Guidelines and Limitations for the Event Browser 32-2
Platform Support 32-3

Using the Event Browser and Events Tabs 32-3
- Viewing the Event Browser 32-3
- Applying and Removing an Event Filter 32-5
- Viewing Events on an Events Tab 32-6
- Changing the Status of an Event 32-7
- Adding a Note to One or More Events 32-8
- Deleting an Event 32-9

Field Descriptions for Events 32-10
- Events Table 32-10
- Event Details 32-11

Related Documents 32-11
Feature History for the Event Browser and Events Tabs 32-12

CHAPTER 33
Working with Network Analysis 33-1
- Information About Network Analysis 33-1
- Licensing Requirements for Network Analysis 33-1
- Prerequisites for Network Analysis 33-2
- Guidelines and Limitations for Network Analysis 33-2
- Using the Network Analysis Feature 33-2
- Using Network Analysis 33-2
- Using the New Path Latency Session Wizard 33-4
- Viewing Session Statistics 33-7

Related Documents 33-8
Feature History for Network Analysis 33-8

CHAPTER 34
Maintaining the Cisco DCNM-LAN Database 34-1
- Information About Database Maintenance 34-1
- Automatic and Manual Purging of Data 34-1
- Database Backup 34-2
- Database Clean 34-2
- Database Restore 34-2
- Licensing Requirements for Database Maintenance 34-3
- Prerequisites for Database Maintenance 34-3
Guidelines and Limitations for Database Maintenance 34-3
Performing Database Maintenance 34-4
   Backing Up the DCNM-LAN Database 34-4
   Cleaning a DCNM-LAN Database 34-5
   Restoring a DCNM-LAN Database from a Backup File 34-7
Additional References 34-9
Related Documents 34-9
Standards 34-9
Feature History for DCNM-LAN Database Maintenance 34-9

CHAPTER 35 Troubleshooting DCNM-LAN 35-1
Tips for Using DCNM-LAN 35-1
   Events Tabs Show Fewer Events than the Event Browser 35-1
   Event Browser Pie Chart May Be Inaccurate for Small Numbers 35-2
Trouble with Starting the DCNM-LAN Server 35-2
   DCNM-LAN Server Fails to Start 35-2
Trouble with the DCNM-LAN Database 35-3
   Trouble with a PostgreSQL Database 35-3
      Updating DCNM-LAN Database Name and Username in pgAdmin III 35-3
   Trouble with an Oracle Database 35-4
Trouble with a PostgreSQL Database 35-5
Trouble with the DCNM-LAN Client 35-6
   Cannot Download the DCNM-LAN Client from the Server 35-6
   Cannot Install the DCNM-LAN Client 35-7
   Cannot Start the DCNM-LAN Client 35-7
   Cannot Log into the DCNM-LAN Client 35-8
   Client Loses Connection to the DCNM-LAN Server 35-10
Trouble with Device Discovery or Device Status 35-11
   Deep Discovery Soft Limit in DCNM 6.2.3 35-11
      Scenario 1 35-12
      Scenario 2 35-12
      Scenario 3 35-12
      How to increase the threshold limit 35-12
Trouble with Device Management 35-13
Trouble with Topology 35-13
Trouble with Device OS Management 35-14
Trouble with Event Browsing 35-14
APPENDIX A
Cisco DCNM Unsupported Feature List  A-1

APPENDIX B
Interface Nonoperational Reason Codes  B-1

APPENDIX C
DCNM-SAN Event Management  C-1
Benefits of the Event Management Tool  C-1
DCNM-SAN Event Management  C-1
Events  C-2
Purpose  C-2
Forwarding  C-2
DCNM-SAN Event Classification  C-3
Port Events  C-3
Event Log Format  C-3
Event Types  C-4
IVR  C-4
License  C-4
Port Alarm  C-4
Port Up and Port Down  C-5
Security  C-5
Switch Hardware  C-6
Switch Managability  C-7
Threshold  C-7
VSAN  C-7
Zone  C-7
Others  C-8

APPENDIX D
Vcenter Plugin  D-1
Associating Vcenter with the Datasource  D-1
Registering Vcenter plugin  D-1
Triggering the plugin  D-2
Removing the plugin  D-2
Preface

This preface describes the audience, organization, and conventions of the *Cisco DCNM Fundamentals Guide*. It also provides information on how to obtain related documentation.

Audience

This guide is for experienced network administrators who are responsible for configuring and maintaining the Cisco MDS 9000 Family of multilayer directors and fabric switches.

Organization

This *guide* is organized as follows:

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1</td>
<td>Introduction to Cisco Data Center Network Manager</td>
<td>Provides a brief overview of Cisco DCNM Fundamentals.</td>
</tr>
<tr>
<td>Chapter 2</td>
<td>Cisco DCNM Fundamentals Overview</td>
<td>Provides a brief overview of Cisco DCNM-SAN.</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>Cisco DCNM Web Client</td>
<td>Provides a brief overview of Cisco DCNM-SAN.</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Configuring Cisco DCNM-SAN Server</td>
<td>Provides in-depth descriptions of GUI and capabilities of Cisco DCNM-SAN Server.</td>
</tr>
<tr>
<td>Chapter 6</td>
<td>Configuring Authentication in Cisco DCNM-SAN</td>
<td>Describes the authentication schemes between Cisco DCNM-SAN components and fabric switches.</td>
</tr>
<tr>
<td>Chapter 7</td>
<td>Configuring Cisco DCNM-SAN Client</td>
<td>Provides in-depth descriptions of GUI and capabilities of Cisco DCNM-SAN.</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>Device Manager</td>
<td>Provides in-depth descriptions of GUI and capabilities of Device Manager.</td>
</tr>
<tr>
<td>Chapter 9</td>
<td>Configuring Performance Manager</td>
<td>Provides overview of the Performance Manager architecture.</td>
</tr>
<tr>
<td>Chapter 10</td>
<td>Monitoring the Network</td>
<td>Provides details on monitoring the network.</td>
</tr>
<tr>
<td>Chapter</td>
<td>Title</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Chapter 11</td>
<td>Monitoring Performance</td>
<td>Provides details on using Performance Manager.</td>
</tr>
<tr>
<td>Chapter 12</td>
<td>Software Images</td>
<td>Provides details on installing and upgrading software on switches.</td>
</tr>
<tr>
<td>Chapter 13</td>
<td>Management Software FAQ</td>
<td>Provides answers to some of the most frequently asked questions about Cisco Fabric Manager and Device Manager.</td>
</tr>
<tr>
<td>Chapter 14</td>
<td>Overview of DCNM-LAN</td>
<td>Provides an overview of what you need to do to start using Cisco Data Center Network Manager for LAN (DCNM-LAN).</td>
</tr>
<tr>
<td>Chapter 15</td>
<td>Installing and Launching the Cisco DCNM-LAN Client</td>
<td>Describes how to install and set up the Cisco DCNM-LAN client.</td>
</tr>
<tr>
<td>Chapter 16</td>
<td>Using the Cisco DCNM-LAN Client</td>
<td>Introduces the Cisco DCNM-LAN client and explains how to use it.</td>
</tr>
<tr>
<td>Chapter 17</td>
<td>Administering DCNM-LAN Authentication Settings</td>
<td>Describes how to administer the Cisco DCNM-LAN server user accounts.</td>
</tr>
<tr>
<td>Chapter 29</td>
<td>Administering Device Discovery</td>
<td>Describes how to use the Device Discovery feature.</td>
</tr>
<tr>
<td>Chapter 30</td>
<td>Administering Devices and Credentials</td>
<td>Describes how to use the Devices and Credentials feature.</td>
</tr>
<tr>
<td>Chapter 18</td>
<td>Working with Topology</td>
<td>Describes how to use the Topology feature.</td>
</tr>
<tr>
<td>Chapter 31</td>
<td>Administering Auto-Synchronization with Devices</td>
<td>Describes how to use the Auto-Synchronization with Devices feature.</td>
</tr>
<tr>
<td>Chapter 33</td>
<td>Working With Threshold Rules</td>
<td>Describes how to configure threshold rules.</td>
</tr>
<tr>
<td>Chapter 32</td>
<td>Administering Statistical Data Collection</td>
<td>Describes how to control statistical data collection.</td>
</tr>
<tr>
<td>Chapter 36</td>
<td>Working with Network Analysis</td>
<td>Describes how to track and monitor the latency between two specified switches.</td>
</tr>
<tr>
<td>Chapter 34</td>
<td>Administering DCNM-LAN Server Log Settings</td>
<td>Describes how to control Cisco DCNM-LAN server logs.</td>
</tr>
<tr>
<td>Chapter 27</td>
<td>Starting and Stopping Cisco DCNM-LAN Servers</td>
<td>Describes how to start and stop the Cisco DCNM-LAN server.</td>
</tr>
<tr>
<td>Chapter 37</td>
<td>Maintaining the Cisco DCNM-LAN Database</td>
<td>Describes how to maintain the Cisco DCNM-LAN database.</td>
</tr>
<tr>
<td>Chapter 38</td>
<td>Troubleshooting DCNM-LAN</td>
<td>Explains how to resolve problems that you might encounter with Cisco DCNM-LAN.</td>
</tr>
<tr>
<td>Appendix A</td>
<td>Cisco DCNM Unsupported Feature List</td>
<td>Provides a list of features and functions not supported by Cisco Fabric Manager or Device Manager.</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Interface Nonoperational Reason Codes</td>
<td>Provides the nonoperational reason codes for why an interface is up and the operational state is down.</td>
</tr>
</tbody>
</table>
Document Conventions

Command descriptions use these conventions:

<table>
<thead>
<tr>
<th><strong>boldface font</strong></th>
<th>Commands and keywords are in boldface.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>italic font</strong></td>
<td>Arguments for which you supply values are in italics.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Elements in square brackets are optional.</td>
</tr>
<tr>
<td>[ x</td>
<td>y</td>
</tr>
</tbody>
</table>

Screen examples use these conventions:

<table>
<thead>
<tr>
<th><strong>screen font</strong></th>
<th>Terminal sessions and information the switch displays are in screen font.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface screen font</strong></td>
<td>Information you must enter is in boldface screen font.</td>
</tr>
<tr>
<td><strong>italic screen font</strong></td>
<td>Arguments for which you supply values are in italic screen font.</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>Nonprinting characters, such as passwords, are in angle brackets.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Default responses to system prompts are in square brackets.</td>
</tr>
<tr>
<td>!, #</td>
<td>An exclamation point (!) or a pound sign (#) at the beginning of a line of code indicates a comment line.</td>
</tr>
</tbody>
</table>

This document uses the following conventions:

- **Note**

  Means reader *take note*. Notes contain helpful suggestions or references to material not covered in the manual.

- **Caution**

  Means *reader be careful*. In this situation, you might do something that could result in equipment damage or loss of data.

In this document, the following shortened names are used:

- Cisco Data Center Network Manager for SAN is also referred to as DCNM-SAN.
- Cisco Data Center Network Manager for LAN is also referred to as DCNM-LAN.

Related Documentation

This section contains information about the documentation available for Cisco DCNM and for the platforms that Cisco DCNM manages.

This section includes the following topics:

- Cisco DCNM Documentation, page 64
- Cisco Nexus 1000V Series Switch Documentation, page 65
- Cisco Nexus 2000 Series Fabric Extender Documentation, page 65
- Cisco Nexus 3000 Series Switch Documentation, page 65
Cisco DCNM Documentation

The Cisco DCNM documentation is available at the following URL:

The documentation set for Cisco DCNM includes the following documents:

Release Notes

Cisco DCNM Release Notes, Release 7.x

Cisco DCNM

The following publications support both Cisco DCNM for LAN and DCNM for SAN, and address the new licensing model, the new installation process, and the new features of Cisco DCNM:

- Cisco DCNM Fundamentals Guide, Release 7.1.x
- Cisco DCNM Installation Guide, Release 7.1.x

Cisco DCNM for LAN Configuration Guides

FabricPath Configuration Guide, Cisco DCNM for LAN
Interfaces Configuration Guide, Cisco DCNM for LAN
Layer 2 Switching Configuration Guide, Cisco DCNM for LAN
Security Configuration Guide, Cisco DCNM for LAN
System Management Configuration Guide, Cisco DCNM for LAN
Unicast Configuration Guide, Cisco DCNM for LAN
Virtual Device Context Configuration Guide, Cisco DCNM for LAN
Virtual Device Context Quick Start, Cisco DCNM for LAN
Web Services API Guide, Cisco DCNM for LAN

Cisco DCNM for SAN Configuration Guides

System Management Configuration Guide, Cisco DCNM for SAN
Interfaces Configuration Guide, Cisco DCNM for SAN
Fabric Configuration Guide, Cisco DCNM for SAN
Quality of Service Configuration Guide, Cisco DCNM for SAN
Security Configuration Guide, Cisco DCNM for SAN
IP Services Configuration Guide, Cisco DCNM for SAN
Intelligent Storage Services Configuration Guide, Cisco DCNM for SAN
High Availability and Redundancy Configuration Guide, Cisco DCNM for SAN
Inter-VSAN Routing Configuration Guide, Cisco DCNM for SAN
SMI-S and Web Services Programming Guide, Cisco DCNM for SAN

**Cisco Nexus 1000V Series Switch Documentation**

The Cisco Nexus 1000V Series Switch documentation is available at the following URL:

**Cisco Nexus 2000 Series Fabric Extender Documentation**

The Cisco Nexus 2000 Series Fabric Extender documentation is available at the following URL:

**Cisco Nexus 3000 Series Switch Documentation**

The Cisco Nexus 3000 Series switch documentation is available at the following URL:

**Cisco Nexus 4000 Series Switch Documentation**

The Cisco Nexus 4000 Series Switch documentation is available at the following URL:

**Cisco Nexus 5000 Series Switch Documentation**

The Cisco Nexus 5000 Series Switch documentation is available at the following URL:

**Cisco Nexus 7000 Series Switch Documentation**

The Cisco Nexus 7000 Series Switch documentation is available at the following URL:

**Additional Related Documentation for Cisco MDS 9000**

The documentation set for the Cisco MDS 9000 Family includes the following documents. To find a document online, use the Cisco MDS NX-OS Documentation Locator at:
Release Notes

- Cisco MDS 9000 Family Release Notes for Cisco MDS NX-OS Releases
- Cisco MDS 9000 Family Release Notes for MDS SAN-OS Releases
- Cisco MDS 9000 Family Release Notes for Cisco MDS 9000 EPLD Images

Regulatory Compliance and Safety Information

- Regulatory Compliance and Safety Information for the Cisco MDS 9000 Family

Compatibility Information

- Cisco Data Center Interoperability Support Matrix
- Cisco MDS 9000 NX-OS Hardware and Software Compatibility Information and Feature Lists
- Cisco MDS 9000 Family Switch-to-Switch Interoperability Configuration Guide

Hardware Installation

- Cisco MDS 9500 Series Hardware Installation Guide
- Cisco MDS 9200 Series Hardware Installation Guide
- Cisco MDS 9100 Series Hardware Installation Guide
- Cisco MDS 9124 and Cisco MDS 9134 Multilayer Fabric Switch Quick Start Guide

Software Installation and Upgrade

- Cisco MDS 9000 NX-OS Software Upgrade and Downgrade Guide

Cisco NX-OS

- Cisco MDS 9000 Family NX-OS Licensing Guide
- Cisco MDS 9000 Family NX-OS Fundamentals Configuration Guide
- Cisco MDS 9000 Family NX-OS System Management Configuration Guide
- Cisco MDS 9000 Family NX-OS Interfaces Configuration Guide
- Cisco MDS 9000 Family NX-OS Fabric Configuration Guide
- Cisco MDS 9000 Family NX-OS Quality of Service Configuration Guide
- Cisco MDS 9000 Family NX-OS Security Configuration Guide
- Cisco MDS 9000 Family NX-OS IP Services Configuration Guide
- Cisco MDS 9000 Family NX-OS Intelligent Storage Services Configuration Guide
- Cisco MDS 9000 Family NX-OS High Availability and Redundancy Configuration Guide
Preface

- Cisco MDS 9000 Family NX-OS Inter-VSAN Routing Configuration Guide
- Cisco MDS 9000 Family Cookbook for Cisco MDS SAN-OS

Command-Line Interface

- Cisco MDS 9000 Family Command Reference

Intelligent Storage Networking Services Configuration Guides

- Cisco MDS 9000 Family I/O Acceleration Configuration Guide
- Cisco MDS 9000 Family SANTap Deployment Guide
- Cisco MDS 9000 Family Data Mobility Manager Configuration Guide
- Cisco MDS 9000 Family Storage Media Encryption Configuration Guide

Troubleshooting and Reference

- Cisco MDS 9000 Family and Nexus 7000 Series System Messages Reference
- Cisco MDS 9000 Family SAN-OS Troubleshooting Guide
- Cisco MDS 9000 Family NX-OS MIB Quick Reference
- Cisco DCNM for SAN Database Schema Reference

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:


Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.
# New and Changed Information


Table ii-1 lists the New and Changed features for this guide.

<table>
<thead>
<tr>
<th>Feature</th>
<th>New or Changed Topics</th>
<th>Changed in Release</th>
<th>Where Documented</th>
</tr>
</thead>
</table>
| Border Leaf/Edge Router Auto-Configuration | Border Leaf Settings  
Connect New Border leaf to the Edge Router | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
<p>| VxLAN Support for Nexus 6000 Series and Nexus 9000 Series Switches | Viewing Inventory Information | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Config sync on POAP | Power-On Auto Provisioning (POAP) | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Multiple Orchestrators Support | L2 Segment ID Range Management | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Three Tier Topology | Inter Switch Links View | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Secure LDAP for Fabric | Fabric | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Multiple Mobility Domains with VLAN Translation | Mobility Domains | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Slow drain | Slow Drain Analysis | 7.1(1) | Chapter 4, “Cisco DCNM Web Client” |
| Templates Configuration | Configuring vPC, FCoE and FIP templates | 6.1(2) | Chapter 4, “Cisco DCNM Web Client” |
| Common LAN Discovery | Discover various Cisco devices from a single interface. | 6.1(2) | Chapter 4, “Cisco DCNM Web Client” |</p>
<table>
<thead>
<tr>
<th>Feature</th>
<th>New or Changed Topics</th>
<th>Changed in Release</th>
<th>Where Documented</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Dashboard</td>
<td>Information about SAN and virtual hosts.</td>
<td>6.1(2)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Summary Dashboard</td>
<td>Details about Datacenter switches, selected SAN and LAN switches, or a group of LAN and SAN switches.</td>
<td>6.1(2)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Configuration Archive Web Client Page</td>
<td>Monitor MDS switch events, performance and memory from a remote location</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Enhanced Search Capability</td>
<td>Searching a LAN or SAN device by its name, IP address, worldwide name (WWN), alias, or serial number.</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Events and Syslogs</td>
<td>Viewing all events and syslogs on the Events window.</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Groups</td>
<td>Configuring switch groups</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Host Tracking and Host Screens</td>
<td>Tracking end hosts and screens</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Improved Cisco Prime Look and Feel</td>
<td>Improved look and feel of Cisco DCNM Web Client</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Performance Manager Collection</td>
<td>Viewing Performance Manager collections</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Port Mapper</td>
<td>Viewing the port mapper</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Remote AAA LDAP Configuration</td>
<td>Configuring LDAP for a remote AAA server</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>vPC Inconsistency</td>
<td>Resolving vPC inconsistency</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>vPC Utilization and Traffic Distribution</td>
<td>Viewing the relationship among vPCs</td>
<td>6.1(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Device Discovery</td>
<td>Supports F2 module</td>
<td>5.2(2a)</td>
<td>Chapter 26, “Administering Device Discovery”</td>
</tr>
<tr>
<td>Summary Dashboard</td>
<td>Viewing Dashboard Summary Information</td>
<td>5.2(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Hosts Dashboard</td>
<td>Viewing Hosts and Virtual Hosts Information</td>
<td>5.2(1a)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Integrating FM and DCNM</td>
<td>Integrating Fabric Manager and Data Center Network</td>
<td>5.0(1)</td>
<td>Chapter 7, “Configuring Cisco DCNM-SAN Client”</td>
</tr>
<tr>
<td>Search Engine</td>
<td>Fabric manager Webclient Search Engine</td>
<td>5.0(1)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
</tbody>
</table>
### Table ii-1  New and Changed Features for Cisco DCNM Release 7.1.x (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>New or Changed Topics</th>
<th>Changed in Release</th>
<th>Where Documented</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Configuration Management</td>
<td>Configuration Backups using Fabric Manager Webclient</td>
<td>5.0(1)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>SAN Health Analyzer Tool</td>
<td>Analyzing SAN Health</td>
<td>5.0(1)</td>
<td>Chapter 11, “Monitoring Performance”</td>
</tr>
<tr>
<td>Software Upgrade Wizard Enhancement</td>
<td>Using the Software Install Wizard</td>
<td>5.0(1)</td>
<td>Chapter 12, “Software Images”</td>
</tr>
<tr>
<td>Web Client Report Enhancement</td>
<td>Reports</td>
<td>5.0(1)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Scoped Discovery</td>
<td>VSAN Scoped Discovery</td>
<td>5.0(1)</td>
<td>Chapter 7, “Configuring Cisco DCNM-SAN Client”</td>
</tr>
<tr>
<td>Federated Server</td>
<td>Server Federation</td>
<td>4.2(1)</td>
<td>Chapter 5, “Configuring Cisco DCNM-SAN Server”</td>
</tr>
<tr>
<td>Cisco Discovery Protocol - FM - DM Enhancements</td>
<td>Launching Fabric Manager Client</td>
<td>4.2(1)</td>
<td>Chapter 7, “Configuring Cisco DCNM-SAN Client”</td>
</tr>
<tr>
<td>FM Web Client: Report Enhancements</td>
<td>Viewing Custom Reports by Template. Generating Custom Reports by Template.</td>
<td>4.2(1)</td>
<td>Chapter 4, “Cisco DCNM Web Client”</td>
</tr>
<tr>
<td>Fabric Manager Launch Pad</td>
<td>Launching Fabric Manager Client Using Launch Pad.</td>
<td>4.2(1)</td>
<td>Chapter 7, “Configuring Cisco DCNM-SAN Client”</td>
</tr>
<tr>
<td>Populate Device Alias to Device Description</td>
<td>Using Alias Names as Descriptions.</td>
<td>4.2(1)</td>
<td>Chapter 7, “Configuring Cisco DCNM-SAN Client”</td>
</tr>
<tr>
<td>FM Historical and Real Time Charts</td>
<td>Viewing Statics Using Fabric Manager</td>
<td>4.2(1)</td>
<td>Chapter 11, “Monitoring Performance”</td>
</tr>
</tbody>
</table>
Introduction to Cisco Data Center Network Manager

Cisco Data Center Network Manager (DCNM) is a management system for the Cisco Unified Fabric. It enables you to provision, monitor, and troubleshoot the data center network infrastructure. It provides visibility and control of the unified data center so that you can optimize for the quality of service (QoS) required to meet service-level agreements.

Cisco DCNM increases overall data center infrastructure uptime and reliability, thereby improving business continuity. It provides a robust framework and comprehensive feature set that meets the routing, switching, and storage administration needs of data centers. Cisco DCNM streamlines the provisioning for the unified fabric and monitors the SAN and LAN components. Cisco DCNM provides a high level of visibility and control through a single web-based management console for Cisco Nexus, Cisco MDS, and Cisco Unified Computing System products.

Cisco DCNM also supports the installation of the Cisco DCNM for SAN and Cisco DCNM for LAN components with a single installer.

The following documentation changes support the merged Cisco DCNM product:

- Cisco DCNM product documentation for Cisco DCNM Release 5.2 is retitled with the name Cisco DCNM for LAN.
- Cisco Fabric Manager product documentation for Cisco DCNM Release 5.2 is retitled with the name Cisco DCNM for SAN.

All Cisco DCNM for SAN and Cisco DCNM for LAN product documentation is now published to the Data Center Network Manager listing page on Cisco.com:

Cisco DCNM Fundamentals Overview

This chapter provides an overview of the basic Cisco DCNM-SAN components and includes the following sections:

- DCNM-SAN Server, page 2-1
- Authentication in DCNM-SAN Client, page 2-3
- DCNM-SAN Client, page 2-1
- Device Manager, page 2-2
- DCNM-SAN Web Client, page 2-2
- Performance Manager, page 2-3
- Cisco Traffic Analyzer, page 2-3
- Network Monitoring, page 2-4
- Performance Monitoring, page 2-4

DCNM-SAN Server


Each computer configured as a Cisco DCNM-SAN Server can monitor multiple Fibre Channel SAN fabrics. Up to 16 clients (by default) can connect to a single Cisco DCNM-SAN Server concurrently. The Cisco DCNM-SAN Clients can also connect directly to an MDS switch in fabrics that are not monitored by a Cisco DCNM-SAN Server, which ensures that you can manage any of your MDS devices from a single console.

DCNM-SAN Client

Cisco DCNM-SAN Client is a Java and SNMP-based network fabric and device management tool with a GUI that displays real-time views of your network fabric, including Cisco Nexus 5000 Series switches, Cisco MDS 9000 Family switches and third-party switches, hosts, and storage devices.
DCNM-SAN Client provides Fibre Channel troubleshooting tools, in addition to complete configuration and status monitoring capabilities for Cisco MDS 9000 Family switches and Cisco Nexus 5000 Series switches. You can use these health and configuration analysis tools on the MDS 9000 Family switch or Cisco Nexus 5000 Series switch to perform Fibre Channel ping and traceroute.

Fabric Manager Release 4.1(1b) and later releases provide a multilevel security system by adding a server admin role that allows access to limited features. The configuration capabilities of a server admin is limited to configuring FlexAttach and relevant data. Advanced mode option is available only for network administrators and provides all of the DCNM-SAN features, including security, IVR, iSCSI, and FICON.

**Device Manager**

Device Manager provides a graphical representation of a Cisco MDS 9000 Family switch chassis, Cisco Nexus 5000 Series switch chassis, or Cisco Nexus 7000 Series switch chassis (FCoE only) along with the installed switching modules, the supervisor modules, the status of each port within each module, the power supplies, and the fan assemblies.

The tables in the DCNM-SAN Information pane basically correspond to the dialog boxes that appear in Device Manager. However, while DCNM-SAN tables show values for one or more switches, a Device Manager dialog box shows values for a single switch. Device Manager also provides more detailed information for verifying or troubleshooting device-specific configuration than DCNM-SAN.

Device Manager provides two views: Device View and Summary View. Use Summary View to monitor interfaces on the switch. Use Device View to perform switch-level configurations including the following configurations:

- Configuring virtual Fibre Channel interfaces
- Configuring Fibre Channel over Ethernet (FCoE) features
- Configuring zones for multiple VSANs
- Managing ports, PortChannels, and trunking
- Managing SNMPv3 security access to switches
- Managing CLI security access to the switch
- Managing alarms, events, and notifications
- Saving and copying configuration files and software image
- Viewing hardware configuration
- Viewing chassis, module, port status, and statistics

**DCNM-SAN Web Client**

With DCNM-SAN Web Client you can monitor Cisco MDS switch events, performance, and inventory from a remote location using a web browser.

- Performance Manager Summary reports—The Performance Manager summary report provides a high-level view of your network performance. These reports list the average and peak throughput and provides hot-links to additional performance graphs and tables with additional statistics. Both tabular and graphical reports are available for all interconnections monitored by Performance Manager.
• Performance Manager drill-down reports—Performance Manager can analyze daily, weekly, monthly and yearly trends. You can also view the results for specific time intervals using the interactive zooming functionality. These reports are only available if you create a collection using Performance Manager and start the collector.

• Zero maintenance database for statistics storage—No maintenance is required to maintain Performance Manager’s round-robin database, because its size does not increase over time. At prescribed intervals the oldest samples are averaged (rolled-up) and saved. A full two days of raw samples are saved for maximum resolution. Gradually the resolution is reduced as groups of the oldest samples are rolled up together.

Performance Manager

The primary purpose of DCNM-SAN is to manage the network. A key management capability is network performance monitoring. Performance Manager gathers network device statistics historically and provides this information graphically using a web browser. Performance Manager presents recent statistics in detail and older statistics in summary. Performance Manager also integrates with external tools such as Cisco Traffic Analyzer.

Performance Manager has three operational stages:
• Definition—The Flow Wizard sets up flows in the switches.
• Collection—The Web Server Performance Collection screen collects information on desired fabrics.
• Presentation—Generates web pages to present the collected data through DCNM-SAN Web Server.

Performance Manager can collect statistics for ISLs, hosts, storage elements, and configured flows. Flows are defined based on a host-to-storage (or storage-to-host) link. Performance Manager gathers statistics from across the fabric based on collection configuration files. These files determine which SAN elements and SAN links Performance Manager gathers statistics for. Based on this configuration, Performance Manager communicates with the appropriate devices (switches, hosts, or storage elements) and collects the appropriate information at fixed five-minute intervals.

Authentication in DCNM-SAN Client

Administrators launch DCNM-SAN Client and select the seed switch that is used to discover the fabric. The user name and password are passed to DCNM-SAN Server and are used to authenticate to the seed switch. If this user name and password are not a recognized SNMP user name and password, either DCNM-SAN Client or DCNM-SAN Server opens a CLI session to the switch (SSH or Telnet) and retries the user name and password pair. If the user name and password are recognized by the switch in either the local switch authentication database or through a remote AAA server, then the switch creates a temporary SNMP user name that is used by DCNM-SAN Client and DCNM-SAN Server.

Cisco Traffic Analyzer

Cisco Traffic Analyzer provides real-time analysis of SPAN traffic or analysis of captured traffic through a Web browser user interface. Traffic encapsulated by one or more Port Analyzer Adapter products can be analyzed concurrently with a single workstation running Cisco Traffic Analyzer, which is based on ntop, a public domain software enhanced by Cisco for Fibre Channel traffic analysis.
Cisco Traffic Analyzer monitors round-trip response times, SCSI I/Os per second, SCSI read or traffic throughput and frame counts, SCSI session status, and management task information. Additional statistics are also available on Fibre Channel frame sizes and network management protocols.

**Network Monitoring**

DCNM-SAN provides extensive SAN discovery, topology mapping, and information viewing capabilities. DCNM-SAN collects information on the fabric topology through SNMP queries to the switches connected to it. DCNM-SAN recreates a fabric topology, presents it in a customizable map, and provides inventory and configuration information in multiple viewing options such as fabric view, device view, summary view, and operation view.

Once DCNM-SAN is invoked, a SAN discovery process begins. Using information polled from a seed Cisco MDS 9000 Family switch, including Name Server registrations, Fibre Channel Generic Services (FC-GS), Fabric Shortest Path First (FSPF), and SCSI-3, DCNM-SAN automatically discovers all devices and interconnects on one or more fabrics. All available switches, host bus adapters (HBAs), and storage devices are discovered. The Cisco MDS 9000 Family switches use Fabric-Device Management Interface (FMDI) to retrieve the HBA model, serial number and firmware version, and host operating-system type and version discovery without host agents. DCNM-SAN gathers this information through SNMP queries to each switch. The device information discovered includes device names, software revision levels, vendor, ISLs, PortChannels, and VSANs.

**Performance Monitoring**

DCNM-SAN and Device Manager provide multiple tools for monitoring the performance of the overall fabric, SAN elements, and SAN links. These tools provide real-time statistics as well as historical performance monitoring.

Real-time performance statistics are a useful tool in dynamic troubleshooting and fault isolation within the fabric. Real-time statistics gather data on parts of the fabric in user-configurable intervals and display these results in DCNM-SAN and Device Manager.

Device Manager provides an easy tool for monitoring ports on the Cisco MDS 9000 Family switches. This tool gathers statistics at a configurable interval and displays the results in tables or charts. These statistics show the performance of the selected port in real-time and can be used for performance monitoring and troubleshooting. For a selected port, you can monitor any of a number of statistics including traffic in and out, errors, class 2 traffic, and FICON data. You can set the polling interval from ten seconds to one hour, and display the results based on a number of selectable options including absolute value, value per second, and minimum or maximum value per second.
Cisco DCNM User Roles

Cisco DCNM defines what operations a user can perform in Cisco DCNM Web Client by controlling what features are available in the menu and toolbar items. Cisco DCNM role-based authorization limits access to the server operations depending on the user roles.

This chapter contains following sections:
- Cisco DCNM Credentials, page 3-1
- Cisco DCNM Users, page 3-1
- DCNM Roles, page 3-1
- Roles from Cisco DCNM Perspective, page 3-2

Cisco DCNM Credentials

Cisco DCNM has two sets of credentials, namely:
- Device credentials—used to discover and manage devices
- Cisco DCNM credentials—used to access the Cisco DCNM server.

This document describes about DCNM credentials and how user roles are mapped to specific set of DCNM server operations.

Cisco DCNM Users

Cisco DCNM user-based access allows the administrator to control the access to the Cisco DCNM server by using the DCNM client (Web Client or LAN client). The user access is secured by a password.

DCNM Roles

Cisco DCNM performs authorization of access to the users based on roles. The role-based authorization limits access to the Cisco DCNM server operations based on the roles to which the users are assigned. Cisco DCNM does not define new roles to access the DCNM server; however, the Cisco DCNM leverages the existing roles that are supported on the devices monitored, such as Cisco MDS 9000 Series Switches, and Cisco Nexus Switches.

Cisco DCNM supports following roles:
Roles from Cisco DCNM Perspective

Cisco DCNM perspective defines the operations a user can perform on the Cisco DCNM client by controlling the menu and tool bar items. Different perspectives define different set of operations.

For example, the Admin perspective allows all the operations by showing all the menu and tool bar items where as Operator perspective allows limited set of operation by hiding Admin and Config Menu items.

Each DCNM user role is mapped to a particular DCNM perspective, which allows limited access to server features. DCNM clients support following four perspectives:

- Admin Perspective, page 3-3
- Server Admin Perspective, page 3-3
- SME Perspective, page 3-4
- Operator Perspective, page 3-5

Table 3-1 describes how DCNM roles are mapped to client perspectives.

<table>
<thead>
<tr>
<th>Role</th>
<th>Perspective</th>
</tr>
</thead>
<tbody>
<tr>
<td>global-admin</td>
<td>Admin Perspective</td>
</tr>
<tr>
<td>network-admin</td>
<td></td>
</tr>
<tr>
<td>lan-network-admin</td>
<td></td>
</tr>
<tr>
<td>san-network-admin</td>
<td></td>
</tr>
<tr>
<td>san-admin</td>
<td></td>
</tr>
<tr>
<td>server-admin</td>
<td>Server Admin Perspective</td>
</tr>
<tr>
<td>sme-admin</td>
<td></td>
</tr>
<tr>
<td>sme-stg-admin</td>
<td></td>
</tr>
<tr>
<td>sme-kmc-admin</td>
<td></td>
</tr>
<tr>
<td>sme-recovery</td>
<td></td>
</tr>
<tr>
<td>network-operator</td>
<td></td>
</tr>
</tbody>
</table>

In a typical enterprise environment, users and their roles are defined in a centralized place such as, TACACS+, RADIUS or LDAP. As Cisco DCNM supports the existing device roles, the administrator need not define new roles specifically.
Chapter 3  Cisco Prime DCNM User Roles

Roles from Cisco DCNM Perspective

### Admin Perspective

Admin Perspective can be accessed through the Cisco DCNM Web Client and SAN Client only, by the users who are assigned the role of global-admin, network-admin, san-admin, san-network-admin and lan-network-admin.

### Web Client Admin Perspective

Web client admin perspective has full control of the DCNM server and can access all the features. Via the access to the **Admin** menu items, the users also has full control of Cisco DCNM authentication settings.

### SAN Thick Client Admin Perspective

SAN thick client admin perspective has full control of the DCNM server and can access all the features.

All the top-level menu items are accessible.

### Server Admin Perspective

Server admin perspective can be accessed via web client and SAN thick client only by the users who are assigned the role of server-admin.

### Web Client Server Admin Perspective

Web client server admin perspective has access to all the web client features. Via the access to the **Admin** menu items, the users also has full control of Cisco DCNM authentication settings.

### SAN Thick Client Server Admin Perspective

The configuration capabilities of a server admin role are limited to FlexAttach and relevant data. The server admin can pre-configure SAN for new servers, move a server to another port on the same NPV device or another NPV device and replace a failed server onto the same port without involving the SAN administrator. The server admin will not be able to manage Fabric Manager users or connected clients. The menu items that are not related to server management are not accessible, e.g. **Zone**, **Performance**, **sme-admin SME Perspective**

<table>
<thead>
<tr>
<th>Role</th>
<th>DCNM Roles and Perspectives Mapping Table</th>
<th>Perspective</th>
</tr>
</thead>
<tbody>
<tr>
<td>sme-admin</td>
<td></td>
<td>SME Perspective</td>
</tr>
<tr>
<td>sme-sgt-admin</td>
<td></td>
<td>SME Perspective</td>
</tr>
<tr>
<td>sme-kmc-admin</td>
<td></td>
<td>SME Perspective</td>
</tr>
<tr>
<td>sme-recovery</td>
<td></td>
<td>SME Perspective</td>
</tr>
<tr>
<td>network-operator</td>
<td></td>
<td>Operator Perspective</td>
</tr>
<tr>
<td>lan-network-admin (SAN Thick Client)</td>
<td></td>
<td>Operator Perspective</td>
</tr>
</tbody>
</table>
etc. SAN thick client server admin perspective has no access to Discover button, Fabrics and License Files tabs. The server admin is not able to manage Fabric Manager users or connected clients in SAN thick client.

SME Perspective

Storage Media Encryption (SME) perspective is designed for sme-admin, sme-sgt-admin, sme-kmc-admin and sme-recovery role-based users. It can be categorized to five different sme admin perspective according to the roles:

- Web Client SME Admin Perspective, page 3-4
- SME Storage Perspective, page 3-4
- SME Key Management Perspective, page 3-4
- SME Recovery Perspective, page 3-4
- SAN Thick Client SME Perspective, page 3-4

Web Client SME Admin Perspective

Web client sme admin perspective is designed to sme-admin role users who have no access to Admin and Config menu items in the Web client and cannot use features under those menu items. On the other hand, the SME provision features are accessible.

SME Storage Perspective

SME storage perspective is designed to the sme-stg-admin role users. sme-stg-admin role users have same perspective as sme-admin role except you cannot manage the key management features.

SME Key Management Perspective

SME key management perspective is designed to the sme-kmc-admin role users. sme-kmc-admin role users have same perspective as sme-admin role except that you cannot perform SME configurations.

SME Recovery Perspective

SME recovery perspective is designed to the sme-recovery role users for master key recovery. sme-recovery role users have same perspective as sme-admin role except that you cannot perform the storage and key management features.

SAN Thick Client SME Perspective

SAN thick client SME perspective has no access to Discover button, Fabrics and License Files tabs. All the SME related perspective would not be able to manage Fabric Manager users or connected clients, as well as operator perspective.
Operator Perspective

Operator perspective is designed for network-operator and lan-network-admin role users, and lan-network-admin role only has SAN thick client operator perspective.

Web Client Operator Perspective

Web client operator perspective has no access to Admin and Config menu items and the features under those menu items cannot be used. All the other features can be used.

SAN Thick Client Operator Perspective

SAN thick client operator perspective has no access to Discover button, Fabrics and License Files tabs, and would not be able to manage Fabric Manager users or connected clients.
Cisco DCNM Web Client

Using Cisco DCNM Web Client, you can monitor Cisco MDS and Nexus family switch events, performance and inventory, and perform minor administrative tasks.

Cisco DCNM Web Client has few Graphical User Interface related changes. The new Cisco DCNM Web Client is user experience (UX) 1.7 compliant.

The default user credentials to access DCNM 7.1.x are as configured during the deployment of the installers.

Cisco DCNM Web Client provides the following features:

- Navigating DCNM Web Client section, page 1-1
- Downloading Cisco DCNM-SAN Client section, page 1-3
- Downloading Cisco DCNM-LAN Client section, page 1-4
- Downloading Cisco Device Manager Client section, page 1-4
- Connecting to a Switch using the CLI section, page 1-4
- Viewing Dashboard Information section, page 1-5
- Viewing Health Information section, page 1-22
- Viewing Performance Information section, page 1-27
- Viewing Inventory Information section, page 1-35
- Viewing and Creating Custom Reports section, page 1-40
- Configuring Cisco DCNM Web Client section, page 1-44
- Administering Cisco DCNM Web Client section, page 1-69
- Using Cisco DCNM Web Client with SSL section, page 1-111

Navigating DCNM Web Client

The DCNM Web Client has standardized certain navigation conventions.

- Scope Menu section, page 1-2
- Admin Menu section, page 1-2
- Table and Filtering Navigation section, page 1-2
- Printing section, page 1-2
- Exporting to a File section, page 1-2
Scope Menu

Beginning with Cisco NX-OS Release 6.x, a new drop-down list called Scope is added to Cisco DCNM Web Client that applies to all pages except the Admin pages.

You can use the scope menu to filter network information by:

- Default_LAN
- Default_SAN
- Individual Fabric
- Group

**Note**

You can organize your fabrics and LAN switches in the Admin > Groups page.

The features accessible from the tabs are limited to the areas that you choose in the filter tree.

Admin Menu

You can use the admin menu to:

- **Set Default LAN Credentials**: These credentials will be used when connecting to the DCNM LAN devices.
- **Change Password**: Changes the password for the current logged in user.
- **Logout**: Logout from the DCNM Web Client.

Table and Filtering Navigation

Some tables that can be filtered will have a filter option to view subsets of the information. Either choose the filter menu or click **Filter**. An editable row at the top of the table appears. Enter values into the table cells and click **Return** to display matching rows.

Printing

Click **Print** to view the table in a printer-friendly format. You can then print the page from the browser.

Exporting to a File

An Export icon is in the lower right corner of some tables or top right corner of the window. Click this icon to export the data to Microsoft Excel.
Sorting Columns

Not all columns are sortable but you can click a sortable column head to sort the information for that column.

Cisco DCNM Web Search Engine

The search engine helps you to locate records according to the following search criteria:

- Search by Name.
- Search by IP Address.
- Search by WWN.
- Search by Alias.
- Search by MAC Address.
- Search by Serial Number.

For more information see the section Using the Cisco DCNM Search Engine section, page 1-3.

Using the Cisco DCNM Search Engine

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Click <strong>Search box</strong> on the top right corner of the main window. You see the search text box.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Use the drop-down to search by:</td>
</tr>
<tr>
<td></td>
<td>- Name</td>
</tr>
<tr>
<td></td>
<td>- IP Address</td>
</tr>
<tr>
<td></td>
<td>- WWN</td>
</tr>
<tr>
<td></td>
<td>- Alias</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter the value based on the search option and click the arrow to begin the search.</td>
</tr>
<tr>
<td></td>
<td>The search results are displayed in a new window.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select <strong>Inventory</strong> or <strong>Performance</strong> tabs to view specific search results.</td>
</tr>
</tbody>
</table>

Downloading Cisco DCNM-SAN Client

You must use Cisco DCNM Web Client to launch Cisco DCNM-SAN Client.

| Step 1  | On the DCNM Web Client home screen, click **Cisco DCNM-SAN**.                                |
|         | If you are launching Cisco DCNM-SAN Client for the first time, you see a message asking if you want to create shortcuts for Cisco DCNM-SAN. |
| Step 2  | Click **Yes** to create shortcuts for Cisco DCNM-SAN.                                       |
| Step 3  | If you have the latest Java version installed, a Warning message is displayed.               |
Note: The DCNM-LAN client supports JRE versions 1.6 and 1.7.

**Step 4** Click **Run with the latest version** button.

**Step 5** Enter the user credentials to log on to Cisco DCNM-SAN client. This message appears only the first time you launch Cisco DCNM-SAN Client.

---

**Downloading Cisco DCNM-LAN Client**

You must use Cisco DCNM Web Client to launch Cisco DCNM-LAN Client.

**Step 1** On the DCNM Web Client home screen, click **Cisco DCNM-LAN**.

If you are launching Cisco DCNM-LAN Client for the first time, you see a message asking if you want to create shortcuts for Cisco DCNM-LAN.

**Step 2** Click **Yes** to create shortcuts for Cisco DCNM-LAN.

**Step 3** If you have the latest Java version installed, a Warning message is displayed.

Note: The DCNM-SAN client supports JRE versions 1.6 and 1.7.

**Step 4** Click **Run with the latest version** button.

**Step 5** Enter the user credentials to log on to Cisco DCNM-LAN client. This message appears only the first time you launch Cisco DCNM-LAN Client.

---

**Downloading Cisco Device Manager Client**

You must use Cisco DCNM Web Client to Install Cisco Device Manager client.

**Step 1** On the DCNM Web Client home screen, click **DM**.

Note: Cisco DCNM Device Manager supports JRE versions 1.6 and 1.7. Follow the instructions in the Cisco Device Manager installer wizard to proceed with the installation.

**Step 2** Once the installation is complete, enter the user credentials to log on to the Cisco Device Manager client.

---

**Connecting to a Switch using the CLI**

You can use the Cisco DCNM Web Client to connect to a switch using the CLI.

**Step 1** On the DCNM Web Client home screen, click **CLI**.

**Step 2** Click the **Connect** button.

**Step 3** In the configuration window, use the check-box to select the switches.
Step 4 Enter the user credentials and click the Connect button.
Step 5 Use the switch panel to specify the command for a specific switch.

Adding a Security Exception

Step 1 On the warning page, click Or you can add an exception.
Step 2 Click Add Exception.
The Add Security Exception dialog box appears.
Step 3 Click Get Certificate.
Read the text that describes the problems with this site.
Step 4 Click Confirm Security Exception.
- MAC Address
- Serial Number

Viewing Dashboard Information

The Cisco DCNM Web Client dashboard gives you comprehensive information of the following:
- **Summary** - You can view the summary dashboard which displays the overall functioning of all the devices connected. It gives you daily statistics of the connected devices.
- **Fabric** - You can view the status of the inter switch links and edge ports.
- **Compute** - You can view the details and events for a particular Host along with its events and topology.
- **Switch Dashboard** - You can view details pertaining to a switch along with its current status and licensing information.
- **Storage** - You can view details about the storage device along with its events and topology.

Summary

The intent of the summary dashboard is to enable network and storage administrators to focus on particular areas of concern around health and performance of the data center switching as a snapshot of the last 24 hours. The functional view of the LAN and SAN switching consists of six dynamic portlets that display information in context of the selected scope. The scope can be adjusted in the upper center of the page to display more focused information particular to the managed domain and offers details of the specific topology or set of topologies part of the data center scope.

The various scopes available on the Cisco Prime DCNM Web Client are:
- datacenter
- default_SAN
- default_LAN

The following portlets are displayed on the summary dashboard, based on the scope of the Web Client:
- Health section, page 1-6
- Inventory section, page 1-6
- Top CPU section, page 1-6
- Top ISLs/Trunks section, page 1-6
- Top SAN Host Ports section, page 1-7
- Top SAN Storage Ports section, page 1-7
- Topology section, page 1-8

**Health**

Broken into two sections listing specific problem areas by type of alert (host, ISL/trunks, VSAN, switch, storage) and events in the form of traps and syslogs listed in order of their severity for a period of 24 hours. The events and problems are hyper-linked to Health > Events and are filtered only for the clicked entity allowing you to drill down to particular problem or event for the contextual information. The events and problems change in context of the selected topology scope to display fabrics (SAN) and switches (LAN) that are part of the default or user defined group. The Health pane will display counts for Path not redundant and Missing Paths which will redirect to the SAN Path Errors section, page 1-23 section. To customize these groups to display more granular information see the Managing Switch Groups section, page 1-95 section.

**Inventory**

Displays the currently discovered inventory based on the selected scope. Switch inventory is broken into FC (Director vs Switch) and Ethernet and Virtual environment totals (VSAN and VLAN configuration). The bar graphs depicts used vs. available for capacity planning.

Click the + icon in the upper right corner to display 6 new boxes displaying detailed inventory for the logical environment, physical switches, ISLs of various types, modules installed (director class line cards and switches are shown), Ports which are broken into type (FC vs. Ethernet) with sub-categories showing counts based on speed. The final box displays Port Capacity, which shows percentage of ports used and calculates the days remaining of available ports based on consumption of available ports. By clicking the square icon in the upper right corner you will return to the previous view.

**Top CPU**

Displays CPU utilization for the discovered switches over the last 24 hours with a red bar displaying the high watermark for that 24 hour period.

Click the + symbol in the upper right corner to display more detailed information of the average percentage of usage, peak percentage of usage, and the last time the information was updated.

**Top ISLs/Trunks**

Displays the performance data for the top 10 performing ISLs and/or Trunk ports. Each entry shows current receive and transmit percentage with a graph depicting the percentage of time each trunk spent exceeding the currently configured thresholds, see the Performance Manager Collections section, page 1-105 section. Clicking on the bar graph to the left of each entry will provide a 24 hour graph for the selected item to provide context to the performance data being shown.
Click the + symbol in the upper right corner to display more detailed information on each entry by displaying the speed of the ISL/Trunk, the average and peak receive data, the average and peak transmit data, the combined receive and transmit data, the total number of errors and discards in the last 24 hours, and the time the data was last updated. By clicking the square icon in the upper right corner you will return to the previous view.

**Top SAN Host Ports**

Displays the performance data for the top 10 performing SAN host ports. Each entry shows current receive and transmit percentage with a graph depicting the percentage of time each trunk spent exceeding the currently configured thresholds, see the Performance Manager Collections section, page 1-105 section. Clicking on the bar graph to the left of each entry will provide a 24 hour graph for the selected item to provide context to the performance data being shown.

Click the + symbol in the upper right corner to display more detailed information on each entry by displaying the speed of the ISL/Trunk, the average and peak receive data, the average and peak transmit data, the combined receive and transmit data, the total number of errors and discards in the last 24 hours, and the time the data was last updated. By clicking the square icon in the upper right corner you will return to the previous view.

**Top SAN Storage Ports**

Displays the performance data for the top 10 performing SAN host ports. Each entry shows current receive and transmit percentage with a graph depicting the percentage of time each trunk spent exceeding the currently configured thresholds, see the Performance Manager Collections section, page 1-105 section. Clicking on the bar graph to the left of each entry will provide a 24 hour graph for the selected item to provide context to the performance data being shown.

Click the + symbol in the upper right corner to display more detailed information on each entry by displaying the speed of the ISL/Trunk, the average and peak receive data, the average and peak transmit data, the combined receive and transmit data, the total number of errors and discards in the last 24 hours, and the time the data was last updated. By clicking the square icon in the upper right corner you will return to the previous view.

**Viewing Health Summary Information**

**Step 1** From the menu bar, choose Dashboard > Summary and then see the Health Summary view.

In the left side of the window, you see a summary table of problems and in the right side of the window, you see a summary table of events in the last 24 hours.

**Step 2** Click the warnings next to Switches, ISLs, Hosts, or Storage (other than 0) to see an inventory of switches, ISLs, or end devices for that fabric.

**Step 3** Choose the number of events next to the event severity levels (Emergency, Alert, Critical, Error, Warning, Notice, Info, or Debug) to see a summary of events and descriptions.

**Viewing Performance Summary Information**

**BEFORE YOU BEGIN**

To view performance information, you must activate performance collector.
From the menu bar, choose **Dashboard > Summary**, and then click **Daily Performance** view.

You see the Summary information.

The Top SAN Ports, Top SAN Storage Ports, Top ISL’s/Trunks and Top Access Ports are Performance pods that are displayed depending on the pods selected.

If you select the Scope as default_SAN, a new area Daily Performance is displayed. For more information see the New Area - Daily Performance section, page 1-11 section.

---

**Viewing Inventory Summary Information**

1. From the menu bar, choose **Dashboard > Summary**.
   The Inventory summary pane is displayed.

2. Click the + icon or double-click the **Inventory** summary pane to view information for the selected scope only.
   The complete inventory details are displayed.

---

**Differences by changing the Scope to default LAN or configured switch group**

**Note**

To configure switch groups, see the Managing Switch Groups section, page 1-95 section.

- Health - Only LAN events are displayed.
- Inventory - Only LAN switch data is displayed
- Top ISLs/Trunks - Only displays LAN based ISLs/Trunks
- Top CPU - Only displays CPU data for the LAN switches
- Top Access Ports - Displays LAN access port performance information.
- A new area Topology is displayed. For more information, see the Topology section, page 1-8 section.

---

**Topology**

This displays the current physical topology with color-coding (displayed with a key in the lower right corner) for ISL utilization. You can hover over the switch indication circles to display the configured switch name, IP address, switch model, firmware version, last polled CPU utilization, and last polled memory utilization.

The memory or CPU utilization are displayed on the switch indicators. In addition the ISL/Trunk paths are also color-coded based on their TX+RX peak utilization. You can hover over the ISL/Trunk to show list of ports that create the connection and click on individual paths to launch the performance chart showcasing TX and RX utilization for the last 24 hours.

Click the + symbol in the upper-right corner to maximize the window and enables you to drag the switch icons to best display their infrastructure. Once icons are placed in the most desirable position you can save the layout by clicking the **Save** icon in the upper-left corner of the topology map. If the layout is moved you can restore the previously saved layout during the current session by clicking the **Restore** icon in the upper-left corner next to the save icon.
When the number of nodes is large, the switch information will not be displayed, as it cannot be accommodated on the page. However, if you click the **Switch Name** or use filters down to a subset, you will be able to view the switch information.

VxLAN VTEPs are shown in topology with **VTEP** icons. Click on the filter in top right corner in topology screen to search VTEPs based on VNI (VNI value > 4095) or multicast address. A **Details** link appears below the filter box. Click on the **Details** link below the filter box to view the search data in tabular format. In VNI search context, click **VTEP** to view the VTEP active peers.

The L2 view shows VLANs configured among the discovered devices. You can choose to view your topology based on the VLANs or Mapped Fabric Path topology. It also provides a visual representation of forwarding and non-forwarding links between Cisco Nexus devices in a data center network for configured VLANs.

### FabricPath View

FabricPath support for L2MP capable devices, running the L2MP-ISIS protocol, is available in the L2 View of the Topology drawer. The L2 View contains a dialog box that allows you to select the type of graph to display. In each topology, a broadcast graph (multi-destination graph) is created by default to carry broadcast traffic and unknown unicast traffic. When you select the Fabricpath view in the dialog box, you can display the following types of graphs:

- **Multi-destination**—A multi-destination or broadcast graph built by ISIS for specified VLAN range to which the topology is mapped to in fabric path cloud.
  
  ISIS maintains reachability information from each node to all other nodes that are present in fabric path cloud. Give a node, DCNM will enable users to view which all other nodes in fabric path cloud are not reachable.

- **Unicast**—A unicast graph displays equal cost routes between nodes in the fabric path cloud.

- **Multicast**—A multicast graph displays the multicast traffic from a specified device to all hosts that are listening to a particular IGMP group.

The FabricPath Topology Wizard allows you to do many operations, such as add to the FabricPath topology, display inventory, and display end devices.

To view the FabricPath topology in the L2 view:

---

**Step 1** Navigate to **Dashboard > Topology**. Expand the LAN topology.

**Step 2** Select **L2 view > FabricPath**.

**Step 3** Enter the Topology ID. The resulting action highlights all the links which are part of the specified topology.

**Step 4** To view the broadcast graph, select the **Multi destination** option in the graph selection window. Select the anchor device for which the broadcast graph must be displayed.

**Step 5** To view the unicast graph, select **Unicast** in the graph selection window. Select the source and the destination nodes.

**Step 6** To view the multicast graph, select **Multicast** in the graph selection window. Select the IGMP address and the ftag ID, and the anchor node for which the multicast graph must be displayed.
VLAN View

VLAN view allows you to see the layer 2 network for the given range of VLAN. All the information related to STP such as protocol, STP role, STP root information are shown to the operator on topology. It is possible to see this information for a particular Switch group.

Spanning Tree Protocol (STP) is used to prevent loops when switches are interconnected via redundant links in a switched network. STP identifies the loops in a network and shuts down the redundant links to prevent the loops from forming. In the event of a link failure, STP will automatically activate the corresponding redundant link. In case of a switched network with multiple VLANs, loop-free paths will have to be computed for every VLAN.

During shallow discovery we are already fetching the information related to VLAN. Layer 2 Topology provides a visual representation of forwarding and non-forwarding links between networks of Nexus Devices for VLANs configured on them. VLAN view helps network administrators to manage STP protocol by providing a visual display of blocking and forwarding links and view information such as STP states (forwarding, blocking, learning, listening), STP roles (root, designated) and the root switch for STP.

To view the VLAN topology in the L2 view:

---

**Step 1** Navigate to **Dashboard > Topology**. Expand the LAN topology.

**Step 2** Select **L2 view > VLAN**.

**Step 3** Enter the VLAN range like “1-10”.

**Step 4** Click on **Fetch** button.

By default, the forwarding and blocked links are shown in the topology. All the forwarding links are in green, blocked in red and the other links are greyed out. It will take some time to populate the topology since the information is fetched from the devices on demand. Select a given link and it will show all the information about that link.

Uncheck the option **Show Non-Forwarding link**, only forwarding links are shown in the topology.

Uncheck the option **Show Forwarding link**, only blocked links are shown in the topology.

---

Port Channel and vPC View

To view the PC vPC topology in the L2 view:

---

**Step 1** Select Scope as default_LAN or DataCenter.

**Step 2** Navigate to **Dashboard > Summary**.

**Step 3** Select the appropriate Device Group and open Topology.

**Note**

Note: The port channels and vPC links are displayed when the user switches to PC vPC view on the topology screen supporting both LAN and SAN devices.

The PC vPC displays the vPCs, port channels, and physical links that are not part of vPC or port channel.
Differences by changing the Scope to default SAN or configured switch group

Note
To configure switch groups, see the Managing Switch Groups section, page 1-95 section.

- Health - Only SAN within scope events are displayed.
- Inventory: Only SAN switch data within the inventory is displayed.
- Top SAN Host Ports: Displays SAN host port performance information within scope.
- Top SAN Storage Ports: Displays SAN storage port performance information within scope.
- Topology: Displays SAN topology within scope.
- A new area Daily Performance is displayed. For more information, see the New Area - Daily Performance section, page 1-11 section.

New Area - Daily Performance

This area displays the total performance of the displayed scope broken into three sections. ISL, Host and Storage. Total monitored port count per area is shown below the circular graph.

Each of the circular graphs will display the percentage of utilization based on 3 different thresholds depicted with color differentiation as follows:

- 0-50%: Green
- 51-80%: Yellow
- 81-100%: Red

You can click each displayed area to view performance data for only the ports, which fall within each performance scope. This will display more detailed information on each entry by displaying the name of the port. Click the bar graph icon to display the historical performance data for the selected port. A full performance graph also appears on the bottom of the screen displaying the last 24 hours, week, month, and year.

You can switch the graph to be displayed as a histogram and to perform predictive analysis on the port showing the most likely performance over the next 6 months based on the historical data gathered for the port. Click the + icon in the bar graph to overlay the performance data of any other port by clicking on the + icon and then clicking the graph icon next to another port listed above. The VSAN/VLAN configuration, speed of the trunk/ISL the average and peak receive data, the average and peak transmit data, the combined receive and transmit, the total number of errors and discards in the last 24 hours, and the last time the data was updated are also displayed.

To return to the summary view, from the menu bar select Dashboard>Network.

Fabric

The topology for the Fabric provides a tiered, scalable display for all the spines and leaves in the fabric. The topology feature also provides a visualization showing the health of the Central Point of Management (CPoM), which includes accessibility of DCNM to different services such as Power on Auto Provisioning (POAP) and Lightweight Directory Access Protocol service (LDAP).

The topology views are also integrated with an event/messaging mechanism using the open source package BlazeDS to dynamically update the display whenever any changes in the network are detected.
There are two separate views:

- Inter Switch Links View
- Edge Ports View

**Note**
You can use the Topology View or Table View icons to switch between different views.

### Inter Switch Links View

These features appear on your Cisco DCNM Web Client application only if you have deployed the DCNM installer in the Unified Fabric mode.

This view displays the super spines, spines and leaves in a tiered fashion. The super spines are displayed in the top tier under the section `<number of> Super Spines`, the spines are displayed in the middle tier under the section `<number of> Spines`, and the leaves are displayed under the section `<number of> Leaves`. Any spine that has tier level defined as 3 or above is considered as a Super Spine. If there are no super spines defined, then the spines and leaves are shown in 2 tiers.

The leaves can be grouped into Pods. Leaves inside a pod are shown as circles inside a box. Pod is defined for the switch by using the command `fabric connectivity pod <podname>`. The pod name is considered as the title for the pod. Any switch that do not have pods defined are shown under the Default pod. Border leaves and Edge Routers, are shown in vertical tiers in the BL/Edge Router pod with a dashed line border around the pod. BL/Edge Router is the standard default name for the pod showing border leaves and edge routers.

The Pods are ordered as Default pod, followed by user-defined pods in alphabetical order, followed by BL/Edge Router pod. Pod can be maximized using the ‘+’ button at the top-right corner. Pressing the button again will bring it back to the original size. The size of the node inside the pod depends on the pod size and the number of nodes inside the pod.

All the nodes are shown as circles. The color of the circle depends on the status of the links or the status of the switch according to the color coding legend displayed under the Nodes section in the left-hand pane. The numbers on the circles indicate how many links are down currently on the switch. The numbers are not displayed in case of green (all links are OK) or grey circle (unreachable).

Clicking on the spine or leaf node disables all other nodes in that tier and displays detailed information about the links for the selected node in the left-side pane. The status column in the table shows the status of the link as an icon.

When the mouse is hovered over the target switch, the link between the 2 nodes is shown as a line along with a detailed popup. The popup displays the source port, target port, and status. Also, the corresponding row in the table on the left side panel is highlighted.

Clicking on the selected node again will deselect the node and enable all the disabled nodes.

The color of the line specifying the link between the switches depends on the status of the link as defined below.

- **Green** – Links status is Normal.
- **Red** – Link is down
- **Blue** – Cable/Tier mismatch detected
- **Orange** – Wrong Configuration Detected
When a node is selected, the status of the link between the selected node and all the target nodes that the selected node is connected to is depicted by a colored halo around the original circle. The color of the halo depends on the status of the link, as specified above.

Check **Show Links** to view links between the Spines and the Leaves, and the links between the Border Leaves and the Edge Router.

**Search**

The search box in the left side panel provides a quicker way to search for a spine or leaf by name. It also supports VM search, where a user can enter a VM name (partial or complete) or VM IP or VM Mac or Segment ID or VxLAN ID or Multicast Group and search for the leaf/leaves that the VM(s) belong to.

The search box provides an auto-complete feature, which filters and shows the matched switch names in a drop down as the user types into the text box. User can type the partial or complete switch name in the box and enter to see the filtered results. A 'Details' link is shown under the search text box that can be clicked to see the search results. If only one node matches the entered text, then that node is selected and the rest of the nodes in the tier are disabled. The details for the links for that node are displayed on the left side panel. If multiple switch names match the entered text, all the matched nodes are, but no details are shown in the left side panel.

**Edge Ports View**

Edge Ports view provides a view of the leaf nodes as VPC pairs. The visualization provides an interface similar to Fabric Path Links view but with details specific to VPC feature.

Each leaf is shown as paired with its VPC peer, with the line between the pair indicating the VPC link. The numbers on the nodes indicate the number of edge ports down for that node.

The color of the circle depends on the status of the edge ports or the status of the switch.

Clicking on a node selects the node and its peer (if any) and shows the edge port status details for that node in the left side panel, as shown below.

On Selecting a single VPC pair, specific information about the VPC setup such as VPC domain ID, VPC peer names, VPC consistency state, VPC Peerlink consistency, Primary VPC Port Channel ID, VPC role for each peer, primary VPC peer link ID, Secondary VPC port channel ID and secondary VPC peerlink ID are all displayed in a short table above the interface listing.

No specific information is overloaded on the link colors, since the link is intended to represent both the Peer link and the keep alive link between peers.

**Health**

This view (popup) can be accessed by clicking on ‘Health’ hyperlink on any of the topology visualization screens.

This view shows health of different services as defined by their accessibility from DCNM. These services include POAP (Power on Auto Provisioning), XCP (Extensible Communications Platform) service, LDAP (Lightweight Directory Access Protocol) service, etc., and the orchestrator which in turn is connected to different vCDs.

The node color is either green, which means the service is up and running and is accessible to DCNM, or red, which means the service is down and cannot be accessed.
Switch Dashboard

The switch dashboard displays the details of the selected switch. The system information area includes the logical name of the switch, the group where the switch belongs, model number of the switch, serial number of the switch, the switch version, the location of the switch, IP address, model, world wide name (WWN) if available, uptime, DCNM license, status of the switch, indicators to determine whether the switch is sending traps and syslog information, current central processor unit (CPU) and memory utilization.

Step 1  From the menu bar, choose Dashboard > Network.

Step 2  An inventory of all the switches that are discovered by Cisco DCNM Web Client appears. Click on a switch in the Name column. The switch dashboard appears.

Step 3  (Optional) Click ssh to access the switch through Secure Shell (SSH).

Step 4  (Optional) Click Device Manager to access the switch through Hypertext Transfer Protocol (HTTP) for that switch.

Step 5  (Optional) Click Accounting to go to the Viewing Accounting Information page for that switch.

Step 6  (Optional) Click Backup to go to the Viewing a Configuration page.

Step 7  (Optional) Click Events to go to the Viewing Events Registration page.

This physical port capacity feature is available for Cisco DCNM licensed switches only.

The physical port capacity area includes the available ports in each tier, such as 40G, 10G, 8G, 4G, 2G, and 1G and also the predicted number of days remaining to reach the maximum (100%) utilization.

Step 8  Click a number under the Days left column to view the capacity trend.

Step 9  Choose the Modules tab to display all the modules that are discovered on the switch.

Step 10  Choose the Interfaces tab to display all the interfaces that are discovered for the switch. Select an interface row and right-click to view the following options:

- Port up... - Brings up a port.
- Port down... - Brings down a port.
- Access mode - Sets port in access mode.
- Trunk mode - Sets port in trunk mode.

Step 11  Select an option and in the CLI Authentication for the port window, specify the User Name and Password and click Connect to connect to the switch.

Note  The CLI Authentication is required only if this is the first time you are performing an operation on an interface for a particular switch. For subsequent operations on the same switch, the authentication is not required.

A CLI window is displayed with the CLI details of the specific operation displayed at the bottom of the window.

Step 12  When you press Enter on your keyboard, a dialog is displayed confirming if you want to change the config on a selected interface.

Step 13  Close the Blades tab to display a list of UCS blades and their attributes.

Step 14  Click OK to continue or Cancel to abort the operation.
When you click on a link in the ConnectedTo column, you see the other end of where the interface is connected. For example, if the other end of the interface is a switch interface, then it launches the Interfaces tab of the switch that the interface is connected. If the interface is connected to an end device, then it launches the host or storage dashboard.

**Step 15** Choose the Licenses tab to display all the licenses installed on the switch.

**Step 16** Choose the Features tab to display a list of all the features installed on the switch. The features tab is displayed only on Cisco DCNM-SAN switches.

**Step 17** Choose the VxLAN tab to display all VNIs, Multicast address, VNI Status and mapped VLAN for the VTEP. The VTEP IP address is displayed in left panel.

---

**Note**

VxLAN support is available on Cisco Nexus 6000 Series and Nexus 9000 Series switches only.

## Compute

The compute dashboard provides you with all the information related to the discovered SAN and LAN hosts. It provides detailed information related to the network, such as I/O traffic, disk latency, CPU, memory statistics, topology, and events about each individual host and virtual machines that are configured on top of the virtual host. The compute dashboard consists of four panels:

- Host Enclosures panel—Lists the hosts and their network attributes.
- Traffic panel—Provides the I/O statistics, CPU and memory information, and disk latency of individual hosts or virtual machines.
- Topology panel—Provides end-to-end topology layout and path information between host enclosures and storage enclosures. The discovered virtual machines are displayed and when you select the virtual machine, the path to the SAN data source is displayed. You can toggle this view to list all data paths.
- Event panel—Provides information about events of all of the switch ports that are configured within a specific host enclosure.

This section contains the following topics:

- Viewing Host Enclosures section, page 1-15
- Viewing Host Events section, page 1-16
- Viewing Host Topology section, page 1-16
- View Host Traffic section, page 1-16

### Viewing Host Enclosures

Beginning with Cisco NX-OS Release 6.x, you can view and search the network servers that are connected to the Cisco NX-OS devices. Cisco DCNM extends the fabric visibility up to the server and allows you to discover and search the end devices that are attached to the network.

**Note**

Beginning with Cisco NX-OS Release 6.x, Server Credentials, Servers, and Static Server-Adapter Mapping are no longer available.
Viewing Dashboard Information

Step 1  From the menu bar, choose Dashboard > Compute.
You see the list of hosts in the host enclosures table.

Step 2  Click the Show details icon next to the host enclosure to view more details.
You see the Events, topology and Traffic information in the dashboard.

Step 3  To edit the host name, double-click the Host Name, edit and then click the Apply Changes icon.

Step 4  You can click the Show Filter to filter the storage enclosures by Name or by IP Address.

Viewing Host Events

Step 1  From the menu bar, choose Dashboard > Compute.
You see the list of hosts in the host enclosures table.

Step 2  Click the Events icon next to the host enclosure to view the Events panel.

Step 3  Click the + icon in the Events panel to expand.
A list of all the events for the selected Host is displayed.

Viewing Host Topology

Step 1  From the menu bar, choose Dashboard > Compute.
You see the list of hosts in the host enclosures table.

Step 2  Click the Show details icon next to the host enclosure to view the host topology details.

Step 3  Click the magnifier icons to zoom-in or zoom-out.

Step 4  Click the Fabric/Network icon to view the Fabric/Network path.

Step 5  Click the All Paths icon to view the complete set-up.

Step 6  Click the First Shortest Path icon to view the first shortest path.

Note  Click Map View icon to enable the icons listed in Step 4, 5 and 6 above.

Step 7  Click the Tabular View icon to view the host topology in tabular format.

View Host Traffic

Step 1  From the menu bar, choose Dashboard > Compute.
You see the list of hosts in the host enclosures table.

Step 2  Click the Show details icon next to the host enclosure to view the host topology details.

Step 3  Use the drop-down to select the traffic according to the time duration.

Step 4  Select the icons to view the traffic as a Grid, Line Chart or Stacked Chart.

Step 5  In the Traffic pane, the Enclosure Traffic is displayed by default. Click the Traffic Utilization icon to view the traffic utilization. The daily average percentage of traffic utilization of the enclosure ports is displayed as a pie chart.
Network

Cisco DCNM Web Client enables you to view details of the switch including the system information, switch capacity, modules, interfaces, and licenses.

**Step 1**  From the menu bar, choose **Dashboard > Network**.

**Step 2**  An inventory of all the switches that are discovered by Cisco DCNM Web Client appears. Click on a switch in the Name column to view the **Switch Dashboard**.

Storage

The Storage dashboard provides you all the information about the SAN and LAN storage.

This section contains the following topics:

- Viewing Storage Enclosure section, page 1-17
- Viewing Storage Enclosure Events section, page 1-18
- Viewing Storage Enclosure Topology section, page 1-18
- Viewing Storage Enclosure Traffic section, page 1-18
- Viewing Storage Systems section, page 1-19

Viewing Storage Enclosure

Once a datasource is configured and the discovery is completed, the discovered storage system(s) are displayed in the Name column in storage enclosures.

**Step 1** From the menu bar, choose **Dashboard > Storage**. Use the drop-down to select All, SAN Storage Enclosures or Storage Systems.

You see the storage enclosures table.

**Step 2** Click the **Show details** icon next to the storage name to view more details.

You see the Events, Topology and Traffic information in the dashboard.

**Step 3** You can click the **Show Filter** to filter the storage enclosures by **Name** or by **IP Address**.

**Step 4** In the Traffic pane, the Enclosure Traffic is displayed by default. Click the **Traffic Utilization** icon to view the traffic utilization. The daily average percentage of traffic utilization of the enclosure ports is displayed as a pie chart.

Clicking on an individual port slice of the pie chart will display specific traffic utilization details for that port.

**Note** Only EMC and NetApp vendors are supported. The ‘Other’ storage discovery handler is vendor neutral, so it depends on the vendor’s conformity to SMI-S standards to retrieve and display information.
**Viewing Storage Enclosure Events**

**Step 1** From the menu bar, choose **Dashboard > Storage**. Use the drop-down to select All, SAN Storage Enclosures or Storage Systems.

You see the list of storage enclosures in the table.

**Step 2** Click the **Events** icon next to the storage enclosure to view the Events panel.

**Step 3** Click the + icon in the Events panel to expand.

A list of all the events for the selected storage enclosure is displayed.

**Viewing Storage Enclosure Topology**

**Step 1** From the menu bar, choose **Dashboard > Storage**. Use the drop-down to select All, SAN Storage Enclosures or Storage Systems.

You see the list of storage enclosures in the table.

**Step 2** Click the **Show details** icon next to the storage enclosure to view the topology details.

**Step 3** Click the magnifier icons to zoom-in or zoom-out.

**Step 4** Click the **Fabric/Network** icon to view the Fabric/Network path.

**Step 5** Click the **All Paths** icon to view the complete set-up.

**Step 6** Click the **First Shortest Path** icon to view the shortest path.

---

**Note** Click **Map View** icon to enable the icons listed in Step 4, 5 and 6 above.

**Step 7** Click the **Tabular View** icon to view the host topology in tabular format.

**Viewing Storage Enclosure Traffic**

**Step 1** From the menu bar, choose **Dashboard > Storage**. Use the drop-down to select All, SAN Storage Enclosures or Storage Systems.

You see the list of storage enclosures in the table.

**Step 2** Click the **Show details** icon next to the storage enclosure to view the topology details.

**Step 3** Use the drop-down to select the traffic according to the time duration.

**Step 4** Select the icons to view the traffic as a **Grid**, **Line Chart** or **Stacked Chart**.

**Step 5** Click the **Show Events** icon to view the events.

**Step 6** Use the options at the bottom of the screen to view a pie chart or a line chart. Click on each name on the chart to view its details.
## Viewing Storage Systems

### Step 1
From the menu bar, choose **Dashboard > Storage**. Use the drop-down to select All, SAN Storage Enclosures or Storage Systems.

**Note**
The datasource must be configured and discovered at least once to display the discovered storage system(s). For more information see Adding, editing, removing, rediscovering and refreshing SMI-S Storage.

### Step 2
Select **Click to see more details**... icon to view the storage systems summary.

### Step 3
Use the drop-down to select the Storage System. Only EMC and NetApp vendors are supported.

The default view consists of the storage system summary along with counts of its elements and graph indicating the total aggregate space used vs. free space. Click each name in the graph to go to the item in the left menu.

### Step 4
The storage systems elements and their views are as follows:
- Components section, page 1-19
- Pools section, page 1-19
- LUNs section, page 1-20
- Filer Volumes section, page 1-20
- Hosts section, page 1-21
- Storage Processors section, page 1-21
- Storage Ports section, page 1-21

### Components

Components are containers for a set or sub-set of the disks in a storage system. The Component elements view displays a table of the disks in the collection, total number of disks managed and a summary of the collection’s used vs. raw space.

### Step 1
Use the Storage System drop-down to select the storage system.

### Step 2
The right-hand pane displays a summary of the storage components. Click each name to go to the item in the left menu.

### Step 3
Hover the mouse cursor on the graph to display its details.

### Step 4
In the left-hand pane, select the storage component to view its details.

The number of disks managed along with its details are displayed.

### Step 5
Click a **Serial Number** to display the disk and the mapped LUNs details.

### Step 6
You can use the search box to search for a specific component.

### Pools

Pools are user-defined collections of LUNs displaying the pool storage. The pools elements view displays a summary of the pools, lists the LUNs in the pool and also displays the total managed and raw space.
Chapter 1  Cisco DCNM Web Client

Viewing Dashboard Information

Step 1  Use the Storage System drop-down to select the storage system.

The bar graph next to each pool indicates the total managed space of that pool.

Step 2  In the left-hand pane, select a pool to display:

- Status of the pool
- LUN’s in the pool displaying the total raw space and the total managed space.
- Raid Type
- Disk Type
- Details of the LUNs in the pool

Step 3  You can use the search box to search for a specific pool.

LUNs

LUNs refer to a storage volume or a collection of volumes abstracted into a single volume. It is a unit of storage which can be pooled for access protection and management. Each LUN in the LUN Element View is displayed along with the mapping from Hosts to LUNs. If the associated Fabric has also been discovered, additional information concerning the end-to-end connection between a host and LUN is also displayed.

Step 1  Use the Storage System drop-down to select the storage system.

Step 2  In the left-hand pane, select a LUN to display:

- The LUN details along with its status and the number of Associated Hosts.
- The Host LUN Mapping details along with the Access (Granted) information.

If the associated Fabric has also been discovered, additional information about the switch interfaces and zoning concerning the end-to-end connection between the Host and LUN is also displayed.

Note  All fabrics that are discovered must be licensed or the fabric correlation will be disabled in the Web Client. When the feature is disabled, all correlation fields display “Unlicensed Fabric”.

Step 3  You can use the search box to search for a specific LUN.

Filer Volumes

Filer Volumes are applicable only for NetApp. The Filer Volume Element view displays the Status, Containing Aggregate along with the total capacity and used space.

Step 1  Use the Storage System drop-down to select the storage system.

Step 2  In the left-hand pane, select the filer to display:

- The status of the filer along with the containing aggregate name.
- Hover the mouse cursor over the graph to view the total capacity and available storage of the filer.

Step 3  You can use the search box to search for a specific Filer.
Hosts

The Hosts only describes the NWWN(s) associated with a host or host enclosure along with the associated Host LUN Mapping and the Host Ports. If the associated Fabric has also been discovered, additional information concerning the end-to-end connection between a host and LUN is also displayed.

Step 1  Use the Storage System drop-down to select the storage system.

Step 2  In the left-hand pane, select a host to display:

- The NWWN (Node WWN) is the WWN of the device connected to the switch.
- The Host Ports along with the Host LUN Mapping.
- In the Host Ports section, click a Host Enclosure Name to view its Events, Topology and SAN Traffic. For more information see the Storage section, page 1-17 section.
- In the Host Ports sections, click a Host Interface to view the Switch Dashboard section, page 1-14.
- In the Host LUN Mapping section, click a Storage Interface to view the Switch Dashboard section, page 1-14.
- In the Host LUN Mapping section, click a Storage Name to view its Events, Topology and SAN Traffic. For more information see the Storage section, page 1-17 section.

If the associated Fabric has also been discovered, additional information about the switch interfaces and zoning concerning the end-to-end connection between the Host and LUN is also displayed.

Note  All fabrics that are discovered must be licensed or the fabric correlation will be disabled in the Web Client. When the feature is disabled, all correlation fields display “Unlicensed Fabric”.

Step 3  You can use the search box to search for a specific host.

Storage Processors

Storage Processors are elements on a storage system, which enable some of its features. A storage processor includes the collection of Storage Ports it manages. In the Storage Processor Element View, the list of Storage Ports associated with a Storage Processor is displayed.

Step 1  Use the Storage System drop-down to select the storage system.

Step 2  In the left-hand pane, select a storage processor to display:

- The status, adapter details and the number of ports of the storage processor.
- The storage ports details.

Step 3  You can use the search box to search for a specific storage processor.

Storage Ports

A storage port is a single port on the Storage System. It displays the summary information of each port selected.

Step 1  Use the Storage System drop-down to select the storage system.

Step 2  In the left-hand pane, select a storage port to display its details.
Viewing Health Information

The Health menu shows events and issues for the selected items that are persistent across user sessions. The Health menu contains the following submenus:

- Accounting—Shows a list of accounting events.
- Events—Shows a detailed list of data center events. You can filter these events by scope, date, and type of event.
- Virtual Port Channels (LAN only)

This section includes the following topics:

- Viewing Accounting Information section, page 1-22
- Viewing Events Information section, page 1-22
- SAN Host Redundancy section, page 1-23
- Viewing a vPC section, page 1-25

Viewing Accounting Information

**Step 1**
From the menu bar, choose **Health > Accounting**.

The fabric name or the group name along with the accounting information is displayed.

**Step 2**
Select the **Filter** icon to search the accounting information by Source, User Name and Description. Use the Time drop-down to select the timeline for the search.

**Note**
The Time drop-down appears only if you select the Filter icon.

**Step 3**
You can also select a row and use the **Delete** icon to delete accounting information from the list.

**Step 4**
You can use the **Print** icon to print the accounting details and use the **Export to Excel** icon to export the data to a Microsoft Excel spreadsheet.

Viewing Events Information

You can view the events and syslog from Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose **Health > Events**.

The fabrics along with the switch name and the events details are displayed.

The Count column displays the number of times that the same event has occurred during the time period that is shown in the Last Seen column.

If you click a switch name displayed in the Switch column, Cisco DCNM Web Client displays the switch dashboard.
If you click the IP address displayed in the Description column, the search feature displays all search results pertaining to that device. From here, you can choose the results that you wish to view.

**Step 2** Select one or more events in the table and click the **Add Suppressor** icon to open the shortcut of adding an event suppressor rule. For detailed information about adding event suppressor rules, please refer to **Add Event Suppression Rules**.

**Step 3** Select a fabric and click the **Acknowledge** icon to acknowledge the event information for the fabric. Once you have acknowledged the event for a fabric, the acknowledge icon is displayed in the Ack column next to the fabric.

**Step 4** You can cancel an acknowledgment for a fabric by selecting the fabric and clicking the **Unacknowledge** icon.

**Step 5** You can use the **Filter** icon to enable filters for the columns displayed.

**Step 6** Select a fabric and use the **Delete** icon to delete the fabric and its event information from the list.

**Step 7** You can use the **Print** icon to print the event details and use the **Export to Excel** icon to export the data to a Microsoft Excel spreadsheet.

---

**SAN Host Redundancy**

The SAN Host Redundancy check enables you to view the non-redundant host storage paths. It helps you identify the host enclosure errors along with the resolution to fix the errors.

**Note**

All fabrics that are discovered must be licensed or this feature will be disabled in the Cisco DCNM Web Client. When the feature is disabled, a notification is displayed stating unlicensed fabrics are discovered.

From the menu bar, choose **Health > Diagnostics > SAN Host Redundancy**.

The following tabs are displayed:

- **SAN Path Errors** – Displays the summary section of the errors along with a table of errors.
- **Settings** – Displays the optional checks you can run along with the exclusion lists.

**SAN Path Errors**

**Step 1** From the menu bar, choose **Health > Diagnostics > SAN Host Redundancy > SAN Path Errors** tab.

**Step 2** Use the Error Types checkboxes to filter the types of host redundancy errors from the table.

The **Good**, **Skipped** and **Errored** host enclosure counts are displayed. These are counts of the unique host enclosures as a whole and not path counts.

The Error Types table provides individual path error counts of host enclosures seeing an error. The **Host Enclosure** column displays the hosts that contain the errors. These are counts of each path in the host enclosures seeing an error. Click a host to view the **Compute** details.

The **Storage Enclosure/Storage Port** column displays the connected storage that is involved the errors.

**Step 3** Click a storage to view the **Storage** details.

**Step 4** In the **Fix?** column, hover the mouse cursor on the ? icon to view a solution to fix the error.

**Step 5** Click **Re-run Check Now** to run the check at anytime.

**Step 6** Click **Clear All** to clear all the errors displayed.
Step 7 Click **Ignore Hosts** to add the selected row(s) host enclosure to an exclusion list. The errors from that host will no longer be reported and the current errors will be purged from the database.

Step 8 Click **Ignore Storage** to add the selected row(s) storage enclosure to an exclusion list. The storage name is an hyperlink to the storage page. Select a row to delete the storage from the ignored list.

Step 9 Click **Ignore Host-Storage Pair** to add the selected row(s) host-storage pair enclosure to an exclusion list. The host name is an hyperlink to the compute page and the storage name is an hyperlink to the storage page. Select a row to delete the storage pair from the ignored list.

**Note** If you click on **Ignore Hosts**, **Ignore Storage** or **Ignore Storage Pair** before you select a row, an error message appears.

Step 10 Click the **Print** icon to print the summary section and the errors as tables.

Step 11 Click the **Export to Excel** icon to export the summary section and the errors as tables to a Microsoft excel spreadsheet.

The Dashboard > Summary > Health will display counts for Path not redundant and Missing Paths which will be hyperlinks to SAN Path errors section.

---

**Settings**

Step 1 From the menu bar, choose Health > Diagnostics > SAN Host Redundancy > Settings.

Step 2 Under the Test for pane, use the check boxes to select the host redundancy optional checks.

Step 3 Select the **Automatically Run Check Every 24 hours** checkbox to enable periodic running of the checker. The checker will run every 24 hours starting 10 minutes after the server starts.

Step 4 Select **Excluded VSAN** check box. Enter **VSAN** or **VSAN range** in the text field to skip the host enclosures that belong to VSAN(s) from the redundancy check.

a. The Ignored Hosts pane displays the list of host enclosures that have been skipped/ignored by the redundancy check along with the reason the host enclosure check was skipped. The following reasons may be displayed:
   - Skipped: Enclosure has only one HBA
   - Host was ignored by the user.
   - Host ports managed by more than one federated servers. Check can’t be run.
   - Skipped: No path to storage found.

b. The Ignored Storage tab displays the list of storage enclosures that have been selected to be ignored during redundancy check.

c. The Ignored Host Storage Pairs tab displays the list of host-storage pairs that have been selected to be ignored during redundancy check.

Step 5 The column displays the **Click** a host to view the Compute details.

Step 6 Select a host enclosure and click the **Delete** button to remove the host from the ignored list and begin receiving errors about a host you had chosen to ignore. However, you can delete entries with message “Host was ignored by user”.

---
Slow Drain Analysis

The Slow Drain Analysis enables you to view slow drain statistics at the switch level and the port level. You can monitor the slow drain issue within any time frame. You can display the data in a chart format and export the data for analysis also.

The slow drain statistics are stored in the cache memory. Therefore, the statistics will be lost when the server is restarted or a new diagnostic request is placed.

Note

The jobs run in the background, even after you log off.

To configure and view the slow drain statistics,

Step 1 From the menu bar, choose Health > Diagnostics > Slow Drain Analysis.
Step 2 In the Scope field, select the Fabric from the drop-down list.
Step 3 Use the radio button to select the desired Interval to collect data.
Step 4 Click the Play icon to begin polling.
   The server begins to collect the slow drain statistics based on the scope defined by the user. The Time Remaining is displayed in the right-side of the page.
Step 5 Click the Stop icon to stop polling.
   The server maintains the counters in the cache, until a new diagnostic request is placed. You can stop the polling before the time is up.
Step 6 Click on the arrow next to Current jobs to display the slow drain details for the jobs running on the fabric. The Fabric Name, the Status of polling and Details icon for each fabric is displayed.
Step 7 Click on the Detail icon to view the saved information.
Step 8 Click on Interface chart icon to display the slow drain value for the switch port in chart format.
Step 9 Click on the Filter icon to display the details based on the defined value for each column.
Step 10 Select the Data Rows Only checkbox to filter and display the non-zero entries in the statistics.
Step 11 Click on the Print icon to Prints the slow drain details.
Step 12 Click on the Export icon to export the slow drain statistics to a Microsoft Excel spreadsheet.

Viewing a vPC

The virtual port channel (vPC) feature enables you to view the links that are physically connected to different devices as a single port channel. A vPC is an extended form of a port channel which allows you to create redundancy and increase bisectional bandwidth by enabling multiple parallel paths between nodes and allowing load balancing traffic. Traffic is distributed among two single device vPC end points.
If there is an inconsistency in the vPC configurations, the vPC does not function correctly.
The Cisco DCNM Web Client helps you to identify the inconsistent vPCs and resolve the inconsistencies in each vPC or in all vPCs.

This section contains the following:
- Viewing vPC Inconsistencies
- Resolving vPC Inconsistencies
From the menu bar, choose **Health > Virtual Port Channels (vPC)**.

Cisco DCNM Web Client displays both the consistent and inconsistent vPCs.

**Note**
The vPC inconsistency page displays inconsistencies only for the devices that have required Cisco DCNM licenses installed on them. The devices that do not have Cisco DCNM LAN license installed on them do not appear on this page.

**Table 1-1** displays the following vPC configuration details in the data grid view.

**Table 1-1  vPC Configuration Details**

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vPC ID</td>
<td>You can view all the multichassis vPC end points and corresponding peer switches for each vPC ID.</td>
</tr>
<tr>
<td>Domain ID</td>
<td>Domain ID of the vPC peer switches.</td>
</tr>
<tr>
<td>Multi-chassis vPC End Point - Device Name</td>
<td>Details of the corresponding to peer single chassis primary vPC end points.</td>
</tr>
<tr>
<td>Multi-chassis vPC End Point - Port Channel ID</td>
<td>Single port channel that is connected to two single chassis vPC end points.</td>
</tr>
<tr>
<td>Primary vPC Peer - Peer Port Channel</td>
<td>Details of the corresponding multichassis vPC end points.</td>
</tr>
<tr>
<td>Primary vPC Peer - Port Channel</td>
<td>Single port channel that is connected to two single chassis vPC end points.</td>
</tr>
<tr>
<td>Primary vPC Peer - Device Name</td>
<td>Hostname of the vPC peer switches.</td>
</tr>
<tr>
<td>Secondary vPC Peer - Peer Port Channel</td>
<td>Details that correspond to the peer single chassis secondary vPC end points.</td>
</tr>
<tr>
<td>Secondary vPC Peer - Port Channel</td>
<td>Secondary port channel that is connected to two single chassis vPC end points.</td>
</tr>
<tr>
<td>Secondary vPC Peer -Device Name</td>
<td>Secondary Hostname of the vPC peer switches.</td>
</tr>
<tr>
<td>Consistency - Global</td>
<td>Configuration consistency between vPC peer port channels and vPC port channels. The valid values are Consistent and Inconsistent.</td>
</tr>
<tr>
<td>Consistency - vPC</td>
<td>Configuration consistency between vPC peer switches that form a peer link.</td>
</tr>
<tr>
<td>Consistency - Global</td>
<td>Configuration consistency between vPC peer port channels.</td>
</tr>
</tbody>
</table>

**Viewing vPC Inconsistencies**

You can view vPC inconsistencies from the Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose **Health > Virtual Port Channels (vPC)**.

**Step 2**
Click a specific cell to view the global or vPC inconsistencies.

A popup window displays the inconsistencies between the parameters.
All the conflicts in the configuration for the vPC primary device and the secondary device are displayed in red.

**Resolving vPC Inconsistencies**

You can resolve vPC inconsistencies from the Cisco DCNM Web Client.

**Step 1**
Click the **Resolve All Conflicts** button to resolve all vPC inconsistencies.

**Step 2**
Click the **Print** icon to print the page.

**Step 3**
Click the **Export to Excel** icon to export the data to a Microsoft Excel spreadsheet.

**Viewing Performance Information**

The Performance option displays an overview of the average and peak throughput and link utilization of the SAN components. The Filter drop-down list at the top-right of the screen allows you to filter the data based on various time periods.

In a large scale environment, we recommend that you select only select only "Trunks" and not the "Access or Errors and Discards" option during Performance Collections operations. This will ensure optimal performance monitored and managed entities in DCNM and allow successful Performance collection.

All performance pages allows you to print the page and export to Excel. By default, the Export To Excel icon is the export traffic number in raw digit format. You can export the same unit number for the traffic data, such as GB/Gb/MB/Mb/KB/Kb/B/b. For example; If you want to display the traffic numbers in GB, you need to modify the server.properties file to set `export.unitless=false` and `export.unit=GB`.

If you set `export.unitless=false`, and do not enter a value for the `export.unit`, it will display the default Web Client unit value.

**Note**
You do not have to restart the DCNM server.

The Performance menu contains the following submenus:

- **Switch**—Shows the CPU, memory and traffic information.
- **End Devices**—Shows a detailed list of end devices (host or storage), port traffic and errors.
- **ISLs**—Shows a detailed list of ISL traffic and errors.
- **NPV Links**—Shows a detailed list of traffic between NPV devices and ports.
- **Flows**—Shows a detailed list of host-to-storage traffic.
- **Ethernet**—Shows a detailed list of Ethernet interfaces.
- **Others**—Shows a detailed list of other statistics.
- **Virtual Port Channels**—Shows a list of vPC utilization.
- **N3K Buffer Usage** - Displays performance of the N3K buffer usage and the total number of bursts during a specific time.
Rx/Tx Calculation

- Average Rx/Tx % = Average Rx/Tx divided by Speed * 100
- Peak Rx/Tx % = Peak Rx/Tx divided by Speed * 100

Note: The conversion for Fabrics is 10 bit = 1 byte and for LAN traffic, the conversion is 8 bit = 1 byte.

Viewing Switch CPU Information

Step 1 From the menu bar, choose Performance > Switch > CPU. You see the CPU pane. This pane displays the CPU information for the switches in that scope.

Step 2 You can use the drop-down to filter the view by 24 Hours, Week, Month and Year.

Step 3 In the Switch column, click the switch name to view the Switch Dashboard.

Step 4 Click the chart icon in the Switch column to view the CPU utilization. You can also change the chart timeline to 24 hours, Week, Month and Year.

Note: If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Switch Memory Information

Step 1 From the menu bar, choose Performance > Switch > Memory. You see the memory panel. This panel displays the memory information for the switches in that scope.

Step 2 You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Step 3 Click the chart icon in the Name column to see a graph of the memory usage of the switch.

Step 4 In the Switch column, click the switch name to view the Switch Dashboard.

Step 5 You can use the drop-down to view the chart in different time lines. Use the chart icons to view the traffic chart in varied views.

Note: If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Switch Traffic and Errors Information

Step 1 From the menu bar, choose Performance > Switch > Traffic. You see the Switch Traffic and Errors panel. This panel displays the traffic on that device for the past 24 hours.

Step 2 You can use the drop-down to filter the view by 24 hours, Week, Month and Year.
Viewing ISL Traffic and Errors Information

**Step 1**
From the menu bar, choose Performance > ISLs/Trunks.
You see the ISL Traffic and Errors pane. This panel displays the ISL information for the end devices in that scope. You can reduce or expand the scope of what is displayed by using the scope menu.

**Step 2**
You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Notation NaN (Not a Number) in the data grid means that the data is not available.

There are variations to this procedure. In addition to these basic steps, you can perform the following steps to view detailed information for ISLs:

- To change the time range for this graph, select it from the drop-down list in the upper-right corner.
- To view the detailed information for a specific period, drag the slider control to choose the time interval for which you need the information.
- Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append, Predict and Interpolate Data. To view real-time information, choose Real Time from the drop-down list in the upper right corner. The real-time data is updated in every 10 seconds.
- To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.
- For the Rx/Tx calculation, see the Rx/Tx Calculation section, page 1-28 section.

**Note**
If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance.

Viewing Performance Information for Ethernet Ports

**Step 1**
From the menu bar, choose Performance > Ethernet.
You see the Ethernet Traffic and Errors window.

**Step 2**
You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

There are variations to this procedure. In addition to these basic steps, you can also perform the following steps:

- Select the time range, and click Filter to filter the display.
Viewing Performance Information

- Select the name of an Ethernet port from the Name column to see a graph of the traffic across that Ethernet port for the past 24 hours. You can change the time range for this graph by selecting it from the drop-down list in the upper-right corner. To view real-time information, choose Real Time from the drop-down list in the upper-right corner.

- To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

- Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append, Predict and Interpolate Data.

- For the Rx/Tx calculation, see the Rx/Tx Calculation section, page 1-28 section.

Note: If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Other Statistics

Step 1  From the menu bar, choose Performance > Others.
You see the Others window.

Step 2  You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

There are variations to this procedure. In addition to these basic steps, you can also do the following:
- Select the time range, and click Filter to filter the display.
- Click the chart icon in the Switch column to see a graph of the performance for this user defined object. You can change the time range for this graph by selecting it from the drop-down list in the upper right corner.
- To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.
- Use the chart icons to view the traffic chart in varied views.

Note: If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Performance Information for NPV Links

Step 1  From the menu bar, choose Performance > NPV Links.
You see the NPV Link and Traffic Errors window. This window displays the NPV links for the selected scope.

Step 2  You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Step 3  Click the chart icon in the Name column to see a list of the traffic for the past 24 hours.

There are variations to this procedure. In addition to these basic steps, you can also perform the following steps to view detailed information for NPV links:
You can change the time range for this information by selecting from the drop-down list in the upper-right corner.

To view the detailed information for a specific period, drag the slider control to choose the time interval for which you need the information.

Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append, Predict and Interpolate Data.

To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

To view real-time information, choose Real Time from the drop-down list in the upper right corner. The real-time data is updated in every 10 seconds.

**Note**

If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

---

### Viewing Performance Information on All Ports

You can view the performance of devices connected to all ports.

**Step 1**

From the menu bar, choose Performance > End Devices > All Ports.

You see the All Ports Traffic and Errors window.

**Step 2**

You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

**Step 3**

To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

**Step 4**

Click the chart icon in the Name column to see:

- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views. To view real-time information, choose Real Time from the drop-down list in the upper right corner. The real-time data is updated in every 10 seconds. You can also use the icons to Append, Predict and Interpolate Data.

**Note**

If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

---

### Viewing Performance Information on Host Ports

You can view the performance of devices connected to the host ports.

**Step 1**

From the menu bar, choose Performance > End Devices > Host Ports.

You see the Host Ports Traffic and Errors window.

**Step 2**

You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

**Step 3**

To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.
Step 4   Click the chart icon in the Name column to see
- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views. To view real-time information, choose Real Time from the drop-down list in the upper right corner. The real-time data is updated in every 10 seconds. You can also use the icons to Append, Predict and Interpolate Data.

**Note**   If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

---

**Viewing Performance Information on Storage Ports**

You can view the performance of devices connected to the storage ports.

**Step 1**   From the menu bar, choose Performance > End Devices > Storage Ports. You see the Storage Ports Traffic and Errors window.

**Step 2**   You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

**Step 3**   To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

**Step 4**   Click the chart icon in the Name column to see:
- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views. To view real-time information, choose Real Time from the drop-down list in the upper right corner. The real-time data is updated in every 10 seconds. You can also use the icons to Append, Predict and Interpolate Data.

**Note**   If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

---

**Viewing Performance Information on Host Enclosure**

You can view the performance of devices connected to the host enclosure.

**Step 1**   From the menu bar, choose Performance > End Devices > Host Enclosure. You see the Host Enclosures Traffic and Errors window.

**Step 2**   You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

**Step 3**   To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

**Step 4**   Click the chart icon in the Name column to see:
- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views.
- You can also use the icons to Append, Predict and Interpolate Data.
Viewing Performance Information on Storage Enclosure

You can view the performance of devices connected to the storage enclosure.

Step 1  From the menu bar, choose **Performance > End Devices > Storage Enclosure**. You see the Storage Enclosures Traffic and Errors window.

Step 2  You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Step 3  To export the data into a spreadsheet, click the **Export to Excel** icon in the upper-right corner and then click **Save**.

Step 4  Click the chart icon in the Name column to see:

- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views.
- You can also use the icons to Append, Predict and Interpolate Data.

Note  If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Performance Information on Port Groups

You can view the performance of devices connected to the port groups.

Step 1  From the menu bar, choose **Performance > End Devices > Port Groups**. You see the Port Groups Traffic and Errors window.

Step 2  You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Step 3  Click the name port group to see the members of that port group.

There are variations to this procedure. In addition to these basic steps, you can also perform the following steps to view detailed information for the port groups:

- To change the time range for this graph, select it from the drop-down list in the upper right corner.
- To view the detailed information for a specific period, drag the slider control to choose the time interval for which you need the information.
- Use the chart icons to view the traffic chart in varied views.
- You can also use the icons to Append, Predict and Interpolate Data.
- To export the data into a spreadsheet, click the **Export to Excel** icon in the upper-right corner and then click **Save**.
Viewing Performance Information

You can view the performance of the FC Flow traffic.

Note: Restart the Performance Manager in the Cisco DCNM Web Client when you add or remove an FC FLOW from the switch configuration, for it to reflect under the Performance > FC Flows.

Step 1: From the menu bar, choose Performance > FC Flows. You see the Flow Traffic window.

Step 2: You can use the drop-down to filter the view by 24 hours, Week, Month and Year.

Step 3: To export the data into a spreadsheet, click the Export to Excel icon in the upper-right corner and then click Save.

Step 4: Click the chart icon in the Name column to see:
- A graph of the traffic on that device according to the selected timeline.
- Use the chart icons to view the traffic chart in varied views. To view real-time information, choose Real Time from the drop-down list in the upper right corner.
- You can also use the icons to Append, Predict and Interpolate Data.

Note: If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.

Viewing Performance Information for Virtual Port Channels

You can view the relationship among virtual port channels (vPCs). You can view the statistics of all member interfaces and the aggregate of the statistics at the port channel level.

Step 1: From the menu bar, choose Performance > Virtual Port Channels (vPC).

The vPC performance statistics appears and the aggregated statistics of all vPCs are displayed in a tabular manner.

Step 2: Click on a device name in the Primary vPC peer or Secondary vPC peer column to view its member interface.

A popup window displays the member interfaces of the selected device.

Step 3: Click the Chart icon of the corresponding interface to view its historical statistics.

The traffic distribution statistics appear at the bottom of the vPC window. By default, the Cisco DCNM Web Client displays the historical statistics for 24 hours.

There are variations to this procedure. In addition to these basic steps, you can also perform the following steps to view detailed information for flows:
Viewing Inventory Information

Beginning with Cisco DCNM release 6.x, you can view the inventory and the performance for both SAN and LAN switches by using the global Scope pane. You can select LAN, SAN, or both to view the inventory information. You can also export and print the inventory information.

You can either Print this information or export to Microsoft Excel.

The Inventory menu includes the following submenus:

- **Switches**—Displays details about switches.
- **Modules**—Displays details for MDS switching and services modules, fans and power supplies.
- **ISLs/Trunks**—Displays the Inter-Switch Links.
- **Licenses**—Displays details about the licenses in use in the fabric.
- **NPV Links**—Displays the links between NPV devices and ports.

N3K Buffer Usage

You can view the performance of the N3K buffer usage and the total number of bursts during a specific time.

**Step 1**
From the menu bar, choose **Performance > N3K Buffer Usage**

You see the N3K Buffer Usage window which displays the average number of burst per hour, maximum number of burst per hour and the total number of burst per hour.

**Step 2**
To export the data into a spreadsheet, click the **Export to Excel** icon in the upper-right corner and then click **Save**.

**Step 3**
Click the chart icon in the Name column to see:

- A bar chart of the hourly based burst number for the selected interface.
- Clicking each item in the bar chart will open a detailed buffer burst window for the selected hour.

**Note**
If the performance tables do not contain any data, see the Performance Manager Collections section to turn on performance data collection.
Viewing Inventory Information

- VSANs—Displays details about VSANs.
- Active Zones—Displays details about the Regular and IVR zones.
- FC End Devices—Displays details about the devices connected to the various ports.
- Port Mapper—Displays the port mapper information.
- VxLAN—Displays the VxLAN configured for the switch.

**Note**
You can use the **Print** icon to print the information displayed or you can also use the **Export to Excel** icon to export the information displayed to a Microsoft Excel spreadsheet.

---

Viewing Inventory Information for Switches

**Step 1**
From the menu bar, choose **Inventory > Switches**.
You see the Switches window displaying a list of all the switches for a selected Scope.

**Step 2**
You can also view the following information.
- In the Name column, select a switch to display the **Switch Dashboard**. For more information about switch dashboard, see the **Switch Dashboard** section.
- Use the drop-down to view **All**, **Warning** or **Unmanaged** switches.

**Step 3**
In the Health column, the switch health is calculated by the capacity manager based on the following formula in the **server.properties** file.

The function to implement is

```
# calculate(x, x1, y, y1, z)
#
# @param x: Total number of modules
# @param x1: Total number of modules in warning
# @param y: Total number of switch ports
# @param y1: Total number of switch ports in warning
# @param z: Total number of events with severity of warning or above
```

**Step 4**
The value in the Health column is calculated based on the following default equation.

```
((x-x1)*1.0/x)*0.4 + ((y-y1)*1.0/y)*0.3 + ((z*1.0/1000)>1) ? 0: ((1000-z)*1.0/1000)*0.3
```

In the above formula, the switch health value is calculated based on the following:
- Percentage of Warning Modules (Contributes 40% of the total health).
- Percentage of Warning Ports (Contributes 30% of the total health)
- Percentage of events with severity of Warning or above (Contributes 30% of the total health. If there are more than 1000 warning events, the event health value is 0).

You may also have your own health calculation formula by implementing the common interface class: `com.cisco.dcbu.sm.common.rif.HealthCalculatorRif`. Add the .jar file to the DCNM server and modify the `health.calculator` property to point to the class name you have created.

The default Java class is defined as: `health.calculator=com.cisco.dcbu.sm.common.util.HealthCalculator`. 

---
Cisco DCNM Web Client Online Help

Chapter 1      Cisco DCNM Web Client

Viewing Inventory Information

• Capacity Manager calculates health only for the license switches. If the health column does not display a value, the switch either does not have a license or it has missed the capacity manager’s daily cycle.
• If the switch is unlicensed, in the DCNM License column click Unlicensed. The Admin>License window appears which allows you to assign a license to the user.
• The capacity manager runs two hours after the DCNM server starts. So, if you discover a device after two hours of the DCNM start time, the health will be calculated 24 hours after this DCNM start time.

Viewing Inventory Information for Modules

%Table
<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the menu bar, choose Inventory &gt; Modules. You see the Modules window displaying a list of all the switches and its details for a selected Scope. You can also view the following information:</td>
</tr>
<tr>
<td>2</td>
<td>In the Name column, select a switch to display the Switch Dashboard. For more information about switch dashboard, see the Switch Dashboard section.</td>
</tr>
<tr>
<td>3</td>
<td>Use the drop-down to view All, Warning or Unmanaged switches</td>
</tr>
</tbody>
</table>

Viewing Inventory Information for ISLs/Trunks

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the menu bar, choose Inventory &gt; ISLs/Trunks. You see the ISLs window displaying the ISL details along with the speed and status of the ISLs.</td>
</tr>
<tr>
<td>2</td>
<td>Use the drop-down to view All or Warning information for the ISLs.</td>
</tr>
</tbody>
</table>

Viewing Inventory Information for Licenses

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the menu bar, choose Inventory &gt; Licenses. You see the Licenses window displaying the license type and the warnings. based on the selected Scope.</td>
</tr>
<tr>
<td>2</td>
<td>In the Name column, select a switch to display the Switch Dashboard. For more information about switch dashboard, see the Switch Dashboard section.</td>
</tr>
<tr>
<td>3</td>
<td>Use the drop-down to view All, Warning or Unmanaged switches.</td>
</tr>
</tbody>
</table>

Viewing Inventory Information for NPV Links

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the menu bar, choose Inventory &gt; NPV Links You see the NPV Links window displaying the NPV details along with the speed and status of the NPV links.</td>
</tr>
<tr>
<td>2</td>
<td>Use the drop-down to view All, Warning or Unmanaged switches.</td>
</tr>
</tbody>
</table>
Viewing Inventory Information for VSANs

Step 1  From the menu bar, choose **Inventory > VSANs.**
You see the VSAN window displaying the VSAN details along with the status and Activate Zoneset details.

Step 2  Use the drop-down to view **All** or **Warning** information for the VSANs.

Viewing Inventory Information for Regular Zones

Step 1  From the menu bar, choose **Inventory > Active Zones > Regular Zones.**
You see the Regular Zones window displaying the inventory details of the fabrics in the regular zone.

Step 2  Click the **Show Filter** icon to enable filtering by VSAN or Zone.

Viewing Inventory Information for IVR Zones

Step 1  From the menu bar, choose **Inventory > Active Zones > IVR Zones**
You see the IVR Zones window displaying the inventory details of the fabrics in the IVR zone.

Step 2  Click the **Show Filter** icon to enable filtering by Zone.

Viewing Inventory Information for All Ports on FC End Devices

Step 1  From the menu bar, choose **Inventory > End Devices > All Ports.**
You see the End Devices window displaying details of the FC End Devices on the all the ports.

Step 2  Use the drop-down to view **All** or **Warning** information for the FC End devices.

Step 3  Click the **Show Filter** icon to enable filtering by Enclosure, Name or VSAN.

Viewing Inventory Information for Host Ports on FC End Devices

Step 1  From the menu bar, choose **Inventory > End Devices > Host Ports.**
You see the **End Devices>Host Ports** window displaying details of the FC End Devices on the host ports.

Step 2  Use the drop-down to view **All** or **Warning** information for the FC End devices on host ports.

Step 3  Click the **Show Filter** icon to enable filtering by Enclosure, Name or VSAN.
Viewing Inventory Information for Storage Ports on FC End Devices

**Step 1**  From the menu bar, choose Inventory > End Devices > Storage Ports.
You see the End Devices>Storage Ports window displaying details of the FC End devices on the storage ports.

**Step 2**  Use the drop-down to view All or Warning information for the FC End devices on storage ports.

**Step 3**  Click the Show Filter icon to enable filtering by Enclosure, Name or VSAN.

Viewing Inventory Information for Port Mapper

Beginning with Cisco NX-OS Release 6.x, you can view information about all the logical and physical ethernet interfaces of all the devices that are discovered by the Cisco DCNM Web Client.

**Step 1**  From the menu bar, choose Inventory > Port Mapper.
You see the Port Mapper window displaying the details listed in Table 1-2

<table>
<thead>
<tr>
<th>Table 1-2</th>
<th>Port Mapper Inventory</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Column</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Device</td>
<td>Name of the device to which the interface belongs.</td>
</tr>
<tr>
<td>Interface Name</td>
<td>Name of the interface.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the interface.</td>
</tr>
<tr>
<td>Mode</td>
<td>Mode of the interface.</td>
</tr>
<tr>
<td>Admin Status</td>
<td>Admin status of the port.</td>
</tr>
<tr>
<td>Operational status</td>
<td>Operational status for the port.</td>
</tr>
<tr>
<td>Speed</td>
<td>Speed for the interface. It is not the configured speed.</td>
</tr>
<tr>
<td>Duplex</td>
<td>Single port channel that is connected to two single chassis vPC end points.</td>
</tr>
<tr>
<td>STP Protocol</td>
<td>Spanning Tree Protocol (STP) whether or not the Per-VLAN Spanning Tree (PVST), Multiple Spanning Tree (MST), and rapid-PVST is configured.</td>
</tr>
<tr>
<td>Access/Allowed VLANs</td>
<td>Access VLAN is displayed if the port mode is access or displays allowed VLAN if the port mode is trunk.</td>
</tr>
<tr>
<td>Built-in MAC Address</td>
<td>MAC address for the port.</td>
</tr>
<tr>
<td>IP Address/Mask</td>
<td>IP address configured on the port and the IP mask.</td>
</tr>
<tr>
<td>SFP Serial Number</td>
<td>Serial number of the Small Form-Factor Pluggable (SFP) if it is attached on the port</td>
</tr>
</tbody>
</table>

**Step 2**  Click the Show Filter icon to filter the port mapping information.
The filter options in the Device, Interface Name, Description, Access/Allowed VLANs, Built-in MAC Address, IP Address/Mask, and SFP SerialNumber column allows you to enter text inputs in the respective field and search. In addition, you can use the drop-down list in the Mode, Admin Status, Operational Status, Speed, Duplex, and STP Protocol column to limit the objects that appear in the report.

**Step 3** Click the **Print** icon to print the port mapping report of the selected device.

**Step 4** Click the **Export to Excel** icon to export the port mapping report of the selected device to a Microsoft Excel spreadsheet.

**Step 5** Click a cell in the STP Protocol column

A popup window displays the STP settings of the port.

**Step 6** Click the **Show Filter** icon to filter the STP settings.

### Viewing and Creating Custom Reports

The Reports menu allows you to create customized reports based on historical performance, events, and inventory information gathered by Cisco DCNM. You can create aggregate reports with summary and detailed views. You can also view previously saved reports.

**Note** Beginning with Cisco DCNM Release 6.x versions, reports can be generated for SAN and LAN. The global view Scope pane will contain SAN, LAN, and Default LAN configurations. You can select any of these configurations, and generate reports.

The Report menu includes the following sub-menus:

- **View**—Displays previously saved reports.
- **Generate**—Generates a custom report based on the selected report template.
- **Create SAN User Defined**—Allows you to generate a report based on a new custom template or select an existing template along with the Configuration of Scope, Inventory, Performance, Health and User Selection.
- **Jobs**—Displays scheduled jobs based on the selected report template.

This section includes the following topics:

- Viewing Reports section, page 1-40
- Generating a Report section, page 1-41
- Creating SAN User Defined Reports section, page 1-42
- Deleting a Report Template section, page 1-43
- Modifying a Custom Report Template section, page 1-43
- Modifying a Custom Report Template section, page 1-43

### Viewing Reports

You can view the saved reports based on the following selection options:

- By Template
• By User
• From the menu bar, select Reports > View.

You see the view reports window, displaying the View Reports By tree on the left pane.

---

**Step 1**
In the left pane, expand By Template or By User folder.

**Step 2**
Select the report you wish to view. You can view the report in the main screen or you can select the report in the Report column to view the HTML version of the report in a new browser.

**Step 3**
To delete a specific report, select the check box and click the Delete Report icon.

**Step 4**
To delete all reports, check the check box in the header, and click the Delete Report icon.

---

**Note**
If you have multiple fabrics, you can select the DCNM-SAN group in the Scope to view Host to Storage connectivity of multiple fabrics in a single report.

The report is divided into two sections:

- A summary report for all the devices that have faulty modules. The table displays information for every device that includes the device host name, number of faulty modules and the module number with its PID.
- A detailed information for the device of the module. The table contains details about the tests failed.

---

**Generating a Report**

You can generate reports based on a selected template or you can schedule the report to run at a specified time.

**Step 1**
In the configuration window, use the drop-down to define the scope for report generation.

In the Scope drop-down, you can select a scope group with dual fabrics, the traffic data generated by hosts and storage end devices are displayed side-by-side which enables you to view and compare traffic data generated on dual fabrics. To View this report, in the Other Predefined folder, select Traffic by VSAN (Dual Fabrics). Click Options to select the Device Type and Fabrics. Click Save to save the configuration.

**Step 2**
From the menu bar, select Reports > Generate.

You see the Generate Report window.

**Step 3**
In the Generate a Report Using pane, expand the folders and select the report.

In the Other Pre-defined folder, you can use the drop-down to select either All Devices or Host Devices while generating a report.

**Step 4**
(Optional) In the Report Options pane, you can edit the Report Name.

**Step 5**
(Optional) Check the Report is only visible to the Owner check box to change the attribute of the report. If selected, the report can be viewed only by the specific user and network administrator.

**Step 6**
(Optional) Check the Export to Csv/Excel check box to export the report in to a Microsoft Excel spreadsheet.

**Step 7**
In the Repeat radio buttons, if you select:
Viewing and Creating Custom Reports

- **Never** - The report is generated only during the current session.
- **Once** - The report is generated on a specified date and time apart from the current session.
- **Daily** - The report is generated every day based on the Start and End date at a specified time.
- **Weekly** - The report is generated once a week based on the Start and End date at a specified time.
- **Monthly** - The report is generated once every month based on the Start and End date at a specified time.

**Step 8**  (Optional) In the **Email Report** radio buttons, if you select:
- **No** - You will not receive an e-mail notification.
- **Link Only** - You will receive only a link to the report in the e-mail notification. You can specify the e-mail address of the recipient along with a desired subject.
- **Contents** - You will receive the report contents in the e-mail notification. You can specify the e-mail address of the recipient along with a desired subject.

**Step 9**  Click the **Create button** to generate a report based on the specifications.

You see the report results in a new browser window.
Alternatively, you can view the report by choosing **Report > View** and selecting the report name from the report template that you used in the navigation pane

**Note**  The Start Date must be at least five minutes earlier than the End Date.

The report is divided into two sections:

- A summary report for all the devices that have faulty modules. The table displays information for every device that includes the device host name, number of faulty modules and the module number with its PID.
- A detailed information for the device of the module. The table contains details about the tests failed.

Creating SAN User Defined Reports

You can create custom reports from all or any subset of information obtained by Cisco DCNM-SAN. You create a report template by selecting events, performance, and inventory statistics you want in your report and set the desired SAN, fabrics or VSAN to limit the scope of the template. You can generate and schedule a report of your fabric based on this template immediately or at a later time. DCNM Web Client saves each report based on the report template used and the time you generate the report.

Since the Cisco MDS NX-OS Release 5.0, the report template design has changed to resolve the limitations of the earlier versions. With the new design model, you can perform add, delete, and modify functionalities on a single page. You can choose multiple fabrics and VSANs using the new navigation system, which allows you to add new items and categories in the future.

The new design model has three panels:

- **Templates panel** - The Customs panel allows you to add new templates, modify existing templates and delete existing templates.
Configuration panel - The Configuration panel allows you to configure a new template when it is added and modify an existing template. The options in the configuration panel are disabled until you either add a new template or select an existing template. The upper portion of the configuration panel contains many categories that you can choose and configure.

User Selection panel - The User Selection panel displays your configuration options in real-time. While the configuration panel can display information pertaining to one category at a time, the User Selection panel displays all of your selections or configurations.

Follow the steps to create custom reports

Step 1 From the menu bar, choose Report > Create SAN User Defined
You see the Create SAN User Defined window.

Step 2 In the Templates panel, under the Name column, select CLICK TO ADD NEW CUSTOM to edit the Name of the new report.
In the Configuration Panel:
Step 3 Click Scope to define scope of the report. The default scope will have Data Center, SAN, LAN, and Fabric configurations.
Step 4 Click Inventory and use the checkbox to select the inventory information required in the report. You can also use the drop-down to filter by selecting the Top performance and the timeline required in the report.
Step 5 Click Performance and use the checkbox to select the performance information required in the report.
Step 6 Click Health and use the checkbox to select the health information required in the report.
Step 7 Click Save to save this report template.
A confirmation message is displayed confirming that the report is saved

This section also contains:

- Deleting a Report Template
- Modifying a Custom Report Template

Deleting a Report Template

Step 1 In the Template panel, select the report template that you want to delete.
Step 2 Click the Trash icon to delete the report.
Step 3 In the confirmation pop-up, click Yes to delete the template.

Modifying a Custom Report Template

Step 1 From the menu bar, choose Reports > Create SAN User Defined.
You see the Template, Configuration and User Selection panels.
Step 2 Select a report from the Templates panel.
You see the current information about this report in the User Selection panel.
Step 3 Modify the information in the Configuration panel.
Step 4 Click Save to save the report template.
A confirmation message is displayed confirming that the report is saved.
Viewing Scheduled Jobs Based on a Report Template

**Step 1**  From the menu bar, choose Reports > Jobs.
You see the Jobs window displaying details of the reports scheduled for generation along with its status.

**Step 2**  Select the checkbox for a specific report and click Edit Job icon to edit the report generation settings.

**Step 3**  Select the checkbox for a specific report and click the Delete Job icon to delete a report.

### Configuring Cisco DCNM Web Client

Using Cisco DCNM Web Client, you can periodically start and backup the running configurations of a switch. You can also view backed-up configurations, schedule configuration backups, compare two backed-up configurations and copy a backed-up configuration.

**Note**  You must configure a backup server with Admin/SFTP credentials to create a new backup job.

Beginning with Cisco DCNM Release 6.x, the backup for the LAN configuration are also supported and the backup is skipped for the all the switches where there are no configuration changes.

This section includes the following topics:
- Viewing a Configuration section, page 1-44
- Comparing Configurations section, page 1-45
- Copying a Configuration section, page 1-45
- Configuring Jobs section, page 1-45
- Storage Media Encryption section, page 1-47
- Configuring Templates section, page 1-48
- Power-On Auto Provisioning (POAP) section, page 1-51
- Fabric section, page 1-63

### Viewing a Configuration

**Step 1**  From the menu bar, choose Config > View.
You see the Groups, Eligible Switches and their configuration information.

**Step 2**  Select a fabric from the Groups list.
The Groups pane displays the global view with SAN, LAN, and Default LAN groups. Depending upon the value selected in the Groups pane, the eligible switches and their configurations are listed.

**Step 3**  From the Eligible Switch(es) list, select a switch.
**Comparing Configurations**

**Step 1**  From the menu bar, select **Config>Compare**.
You see the compare configuration information with the **Compare** and **Differences** tabs.

**Step 2**  From the **Groups list**, select a fabric.

**Step 3**  From the **Eligible Switch(es) list**, select a switch.

**Step 4**  (Optional) Click the **Archive, Running**, or **Startup** radio button.

**Step 5**  Click **Compare**.

**Step 6**  Click the **Differences** tab to view differences in configuration based on the specified legend.

**Step 7**  Select the difference line and click the bookmark button to **bookmark/toggle** bookmark.

**Step 8**  Use the **Next/Previous, Next bookmark/Previous bookmark** buttons to navigate over the differences blocks.

**Step 9**  Click on the **colored overview** to strip to navigate to the difference

**Step 10**  Select the **Show All** checkbox to display all the configurations present, irrespective of the options selected in the global Scope pane.

**Copying a Configuration**

**Step 1**  From the menu bar, select **Config > Copy**.
You see the Groups, Eligible Switches and their configuration information.

**Step 2**  From the **Groups List**, select a fabric.

**Step 3**  From the **Eligible Switch(es) list**, select a switch.

**Step 4**  From the **Configuration file** list, select a configuration file name.

**Step 5**  Click **Copy** to copy the configuration file.

**Step 6**  Select the **Show All** checkbox to display all the configurations present, irrespective of the options selected in the global Scope pane.

**Configuring Jobs**

You must set the SFTP/TFTP credentials before you configure Jobs. On the DCNM Web Client, navigate to **Admin > SFTP/TFTP Credentials** to set configure.
Chapter 1      Cisco DCNM Web Client

Configuring Cisco DCNM Web Client

Step 1  From the menu bar, choose **Config > Jobs**.
You see the scheduled jobs information along with its status.

Step 2  From the Scope selector, select a single fabric or a single LAN group.
**Note** You can create jobs for a single fabric or a single LAN group.

Step 3  Click **Create Job** icon to create a new config archive job.
A backup will be scheduled as defined.

Step 4  Specify the **Repeat** information, **Start** and **End** date, **Time** and **Comment**.

**Note** Cisco DCNM will not archive the configuration of a switch, if it is not modified after the completion of the previous archive job.

Step 5  Select a job and click **Delete** Job to delete a specific job.
Click on the **Status** column to view the job execution details for that particular job.

Step 6  View Job execution details in the **Job Status History** tab.

You can also configure the Cisco DCNM to retain the backup and restore configuration file for a defined time period and the number of job status entries per device. Navigate to **Admin > general > Server properties** on the Cisco DCNM Web Client, and update the **configFile.Days2Keep** and **config.JobsStatusPerDevice** fields.

**Job Status History**

From the menu bar, select **Config > Jobs > Job Status History**. This feature allows you to view details about the jobs archived on the Cisco DCNM.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Filter</td>
<td>Filters list of switches based on the defined value for each column.</td>
</tr>
<tr>
<td>Job Name</td>
<td>Displays the system-generated job name.</td>
</tr>
<tr>
<td>User</td>
<td>Specifies the persona of the person who created the job.</td>
</tr>
<tr>
<td>Group</td>
<td>Specifies fabric or the LAN group under which the job was created.</td>
</tr>
<tr>
<td>Device</td>
<td>Specifies the IP Address of the Device.</td>
</tr>
<tr>
<td>Server</td>
<td>Specifies the IP Address of the DCNM Server to which the device is associated with.</td>
</tr>
<tr>
<td>Execution time</td>
<td>Specifies the time at which the job was last executed.</td>
</tr>
<tr>
<td>Status</td>
<td>Specifies the status of the job.</td>
</tr>
<tr>
<td>Description</td>
<td>Specifies the description of the status.</td>
</tr>
</tbody>
</table>
Storage Media Encryption

Encrypting storage media in the data center has become a critical issue. Numerous high profile incidents of lost or stolen tape and disk devices have underscored the risk and exposure companies face when sensitive information falls into the wrong hands. To satisfy the most demanding requirements, Cisco MDS 9000 Family Storage Media Encryption (SME) for the Cisco MDS 9000 family switches offers a highly scalable, reliable, and flexible solution that integrates encryption transparently as a fabric service for Fibre Channel SANs.

This section contains the following:

- Selecting the Key Manager and SSL Settings section, page 1-47
- Viewing SME Clusters section, page 1-48
- Creating a Cluster section, page 1-48

Selecting the Key Manager and SSL Settings

**Step 1**
From the menu bar, select **Config>Provision**.

The Key Manager Settings window is displayed with the following options:

- **None** - No Key Manager selected for SME.
- **Cisco** - Cisco Key Manager selected for SME.
- **RSA** - RSA Key Manager selected for SME.

**Note** Once you have selected a Key Manager, you will not be able to change it.

**Step 1**
Select one of the Radio buttons and click **Submit Settings**.

The Key Manager Settings window is displayed.

The KMC SSL Settings pane displays the location where the certificate is stored.

**Step 2**
If you want to edit the SSL Settings, click **Edit SSL Settings**.

**Step 3**
Use the drop-down to select the **SME KMC Trust Certificate**.

**Step 4**
Use the drop-down to select the **SME KMC Server Certificate**.

**Step 5**
Specify and confirm the **Server Cert Password**.

**Step 6**
Click **Submit SSL Settings**.

**Step 7**
In the High Availability Settings pane, click **Edit HA Settings** to specify the **KMC Role of this Server and SME Secondary Server Address**.

**Step 8**
Click **Submit HA Settings** to confirm.
Viewing SME Clusters

Step 1  From the menu bar, select Config>Provision and select SME from the ribbon. You see the SME: Clusters window displaying the Cluster Name, Status, Fabrics and Key Management Server.

Step 2  Click the cluster in the Name column to view its details.

Step 3  In the Type option, click Convert to Signature Mode... to convert the cluster type to Disk Signature.

Note  Once you have chosen to convert the cluster type, you will not be able to change it again

Step 4  In the Confirm Action window, click Next.

Step 5  In the Convert Cluster window, click Auto to automatically convert the cluster type to Disk Signature

Creating a Cluster

Step 1  From the menu bar, select Config>Provision and select SME from the ribbon.

Step 2  You see the SME: Clusters window displaying the Cluster Name, Status, Fabrics and Key Management Server.

Step 3  Select Create to create a new cluster

Step 4  Select the Cluster Type, specify a Cluster Name and click Next.

Step 5  Select the Fabric(s) and click Next.

Note  You can select multiple fabrics by holding the Ctrl key on your keyboard and selecting the fabrics.

Step 6  Select the SME Interfaces from the list and click Next.

Step 7  Select the Security Type for the cluster and click Next.

Step 8  Specify the Primary Key Management Server and the Secondary Key Management Server of the cluster. Alternatively, you can also use the drop-down to select the Key Management Servers for the cluster and click Next.

Step 9  Specify the Transport Settings for the cluster.

Step 10  Click Confirm to confirm the new cluster setup

Configuring Templates

You can view various templates configured across different Nexus and MDS platforms along with the Name of the template, its Description, Platforms and Tags. This section contains the following:

- Adding a Template section, page 1-49
- Creating a Template Job section, page 1-49
- Editing a Template section, page 1-50
• Importing a Template section, page 1-50
• Exporting a Template section, page 1-50
• Deleting a Template section, page 1-50

Additionally, from the menu bar, select Config>Delivery>Templates and you can also:

• Click the Show Filter icon to filter the templates based on the headers.
• Click the Print icon to print the list of templates.
• Click the Export to Excel icon to export the list of template to a Microsoft Excel spreadsheet

Adding a Template

Step 1 From the menu bar, select Config>Delivery>Templates. You see the name of the template along with its description, Platforms and Tags.

Step 2 Click the Add icon to add a template.

Step 3 Specify a Template Name, Template Description, Tags and select the Supported Platforms. The Template content is displayed in the right-hand pane.

Step 4 Click Validate Template Syntax to validate the template values.

Step 5 Click Save to save the template.

Step 6 Click Save and Exit to save the configuration and go back to the configuring templates screen.

Creating a Template Job

Step 1 From the menu bar, select Config > Templates. You see the name of the template along with its description, Platforms and Tags.

Step 2 Use the checkbox to select a template from the list.

Step 3 Click the Launch Job Creation Wizard icon and click Next.

Step 4 Use the drop-down to select the Device Scope.

Step 5 Use the arrows to select the devices for job creation and click Next.

Step 6 Specify the VSAN_ID, VLAN_ID, ETH_SLOT_NUMBER, VFC_SLOT_NUMBER, SWITCH_PORT_MODE, ETH_PORT_RANGE and ALLOWED_VLANS values.

Step 7 Use the checkbox Edit variables per device to edit the variables for specific devices and click Next.

Step 8 If multiple devices have been selected, use the drop-down to select a specific device and preview its configuration. Click Back to edit the configuration or click Next.

Step 9 Specify a Job Description and enter the Device Credentials.

Step 10 Use the radio button to select Deliver Instantly or Choose time to deliver. If you select Choose time to deliver, specify the date and time for the job delivery.

Step 11 Use the checkbox to select Copy Run to Start.

Step 12 If you want to configure additional Transaction and Delivery options, use the checkbox to select Show more options.

Step 13 Under Transaction Options (Optional), if you have a device with rollback feature support, select Enable Rollback checkbox and select the appropriate radio button.
Step 14  Under Delivery Options (Optional), specify the Timeout in seconds and use the radio button to select the Delivery Order.

Step 15  Click Finish to create the job.

A confirmation message is displayed that the job has been successfully created.

Editing a Template

Note  The pre-defined templates cannot be edited.

Step 1  From the menu bar, select Config > Templates.

You see the name of the template along with its description, Platforms and Tags.

Step 2  Select a template from the list and click the Modify/View template icon

Step 3  Edit the Template Description, Tags and select the Supported Platform

The edited Template content is displayed in the right-hand pane.

Step 4  Click Validate Template Syntax to validate the template values.

Step 5  Click Save to save the template.

Step 6  Click Save and Exit to save the configuration and go back to the configuring templates screen.

Importing a Template

Step 1  From the menu bar, select Config > Templates and select the Import template icon.

Step 2  Select the template saved on your computer.

Step 3  Specify the Template Name, Template Description and Tags.

Step 4  Use the checkboxes to select the Supported Platforms or you can select the All option.

Step 5  Click Validate Template Syntax to validate the template.

Step 6  Click Save to save the template or Save and Exit to save the template and exit.

Exporting a Template

Step 1  From the menu bar, select Config > Templates.

Step 2  Use the checkbox to select a template(s) and click the Export template icon.

Step 3  Specify a name for the template and select a location to save the template on your computer.

Deleting a Template

Note  Pre-defined templates cannot be deleted.
### Configuring Jobs

**Step 1** From the menu bar, select **Config > Delivery > Jobs**. The jobs are listed along with the Job ID, description and status.

**Step 2** Click the **Show Filter** icon to filter the jobs by Job ID, Description, Devices and Status. In the Status column, use the drop-down to select the job status.

**Step 3** Select a job and click the **Delete** icon to delete the job.

### Power-On Auto Provisioning (POAP)

POAP automates the process of upgrading software images and installing configuration files on Cisco Nexus switches that are being deployed in the network for the first time.

When a Cisco Nexus switch with the POAP feature boots and does not find the startup configuration, the switch enters POAP mode, locates a DHCP server and bootstraps itself with its interface IP address, gateway, and DNS server IP addresses. It also obtains the URL of an SCP server and downloads a configuration script that is run on the switch to download and install the appropriate software image and configuration file.

**Note** When you move the mouse cursor over an error identified in a specific parameter in any window, it will display the exact error message before you move to the next screen.

There are five main steps to configure a POAP device:

**Step 1** DHCP Scope Creation

**Step 2** Add the boot, startup, image and server information.

**Step 3** Startup configuration creation

**Step 4** Cable plan.

**Step 5** Script and files (license) attachment

### POAP Launchpad

**Note** These features appear on your Cisco DCNM Web Client application only if you have deployed the DCNM installer in the Unified Fabric mode.

The POAP launchpad contains the following configuration steps:

- **DHCP Scope** - Create and manage scopes for POAP creation.
**DHCP Scope**

DHCP scope is a well-defined term in DHCP arena. It is used to define a policy for giving out IP addresses and other options to host on a specific IP subnet. In DCNM, we use the DHCP scope to distribute IPv4 address, PYTHON bootscript, (or other supported protocol + access credential + server) which stores the bootscript.

From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>DHCP Scope**.

The columns in table Table 1-3 are displayed.

<table>
<thead>
<tr>
<th>Table 1-3: DHCP Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DHCP Scope</strong></td>
</tr>
<tr>
<td>Scope Name</td>
</tr>
<tr>
<td>Scope Subnet</td>
</tr>
<tr>
<td>IP Address Range</td>
</tr>
<tr>
<td>Lease Time</td>
</tr>
<tr>
<td>Default Gateway</td>
</tr>
<tr>
<td>Domain Name Servers</td>
</tr>
<tr>
<td>Bootscript Name</td>
</tr>
<tr>
<td>Bootscript Server</td>
</tr>
</tbody>
</table>

- Adding a DHCP Scope section, page 1-52
- Editing an existing DHCP Scope section, page 1-53
- Deleting a DHCP Scope section, page 1-53

**Adding a DHCP Scope**

**Step 1**  
From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>DHCP Scope**.

**Step 2**  
Click **Add scope** icon.

**Step 3**  
In the Add DHCP Scope window, specify values in the fields according to the information in Table 1-3.

**Step 4**  
Click **Add**.
Editing an existing DHCP Scope

Note
Once the DCNM is accessed for the first time, you must edit the default scope named 'enhanced_fab_mgmt' and add free IP address ranges.

Step 1
From the menu bar, select Config>Power-On Auto Provisioning (POAP)>DHCP Scope.
Step 2
Use the checkbox to select the DHCP scope.
Step 3
Click Edit scope icon.
Step 4
In the Edit DHCP Scope window, edit the DHCP scopes.
Step 5
Click Apply to save the changes.

Deleting a DHCP Scope

Step 1
From the menu bar, select Config>Power-On Auto Provisioning (POAP)>DHCP Scope.
Step 2
Use the checkbox to select the DHCP scope.
Step 3
Click Delete scope icon.
Step 4
In the delete notification, click Yes to delete the DHCP scope.

Note
You may click the Refresh icon to refresh the DHCP Scopes list.

Images and Configuration

This feature enables you to specify the servers & credential used to access the device images and the uploaded or DCNM generated/published device configuration. The server containing the images could be different from the one containing the configurations. If the same server contains both images and configurations, you must provide the server IP address and credentials twice for each server, if the directories holding images and configuration files are different. By default, DCNM server will be the default image and configuration server.

Copy Kickstart and system images into the repository prior to defining POAP definitions for devices. If the DCNM is the image repository, copy the image files into /var/lib/dcnm/ directory.
- Add Image or Configuration Server URL section, page 1-53
- Editing an Image or Configuration Server URL section, page 1-54
- Deleting an Image or Configuration Server URL section, page 1-54

Add Image or Configuration Server URL

Step 1
From the menu bar, select Config>Power-On Auto Provisioning (POAP)>Image and Config Servers.
Step 2
Click the Add icon.
Step 3
In the Add Image or Configuration Servers URL window, specify a Name for the image.
Step 4
Enter Hostname/Ipaddress and Path to download or upload files.
Specify the **Username** and **Password**.

Click **OK** to save.

### Editing an Image or Configuration Server URL

1. From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Image and Config Servers**.
2. Select an existing Image and Configuration Server from the list, and Click the **Edit** icon.
3. In the Edit Image or Configuration Servers URL window, edit the required fields.
4. Click **OK** to save.

### Deleting an Image or Configuration Server URL

1. From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Image and Config Servers**.
2. Select an existing Image and Configuration Server from the list, and Click the **Delete** icon.
3. In the delete notification, click **Yes** to delete the image and configuration server.

**Note**
The default SCP Repository cannot be deleted.

### POAP Templates

Templates can be created or imported into the template builder of DCNM. There are some predefined Fabric specific POAP templates bundled with DCNM. The template builder can be invoked from the GUI, **Config->Delivery -> Templates**. The templates dedicated to POAP will be used to generate many different POAP device configurations.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

- Use the **Show Filter** icon to filter the templates.
- Use the **Print** icon to print the list of templates and their details.
- Use the **Export** icon to export the list of templates to a Microsoft Excel spreadsheet.

This section contains the following:

- Add POAP template
- Editing a Template
- Cloning a Template
- Importing a Template
- Exporting a Template
- Deleting a Template
Add POAP template

Step 1  From the menu bar, select Config>Power-On Auto Provisioning (POAP)>POAP Definitions.
Step 2  In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3  Click Add template icon.
Step 4  Specify the Template Name, Template Description and Tags.
Step 5  Use the checkbox to specify the Supported Platforms.
Step 6  Select the POAP checkbox or else by default, the DCNM will consider it as a CLI template.
Step 7  Select the Published checkbox if you want the template to have ‘Read Only’ access.
Step 8  In the Template Content pane, you can specify the content of the template. For help on creating the template content, click the Help icon next to the Template Content header. For information about POAP template annotations see the POAP Template Annotation section.
Step 9  Click Validate Template Syntax to validate syntax errors.
Step 10 Click Save to save the template.
Step 11 Click Save and Exit to save the template and exit the window.
Step 12 Click Cancel to discard the template.

Editing a Template

Step 1  From the menu bar, select Config>Power-On Auto Provisioning (POAP)>POAP Definitions.
Step 2  In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3  Select a template from the list and click Modify/View template icon.
Step 4  Edit the template content and click Save to save the template or Save and Exit to save and exit the screen.

Cloning a Template

Step 1  From the menu bar, select Config>Power-On Auto Provisioning (POAP)>POAP Definitions.
Step 2  In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3  Select a template from the list and click Modify/View template icon.
Step 4  Edit the template and click Save to save the template or Save and Exit to save and exit the screen.

Importing a Template

Step 1  From the menu bar, select Config>Power-On Auto Provisioning (POAP)>POAP Definitions.
Step 2  In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3  Select a template from the list and click Import template icon.
Step 4  Select the template file and upload.
Exporting a Template

**Step 1**  
From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>POAP Definitions.**

**Step 2**  
In the Configuration Steps, click the **template** hyperlink in the POAP Definitions section.

**Step 3**  
Select a template from the list and click **Export template** icon.

**Step 4**  
Select a location for the file download.

Deleting a Template

**Note**  
Only user-defined templates can be deleted.

**Step 1**  
From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>POAP Definitions.**

**Step 2**  
In the Configuration Steps, click the **template** hyperlink in the POAP Definitions section.

**Step 3**  
Select a template from the list and click **Remove template** icon.

**Step 4**  
Click **Yes** to confirm.

POAP Template Annotation

Annotation is used to add semantic, validation logic and description to the template variable.

The Annotation for a given template variable is required to precede the given template variable. Only one annotation statement is required for each template variable. When a template variable has an associated annotation statement, the template variable has to be declared on a single line. Multiple variables cannot be declared under the same annotation statement.

Format of an annotation statement is as follows:

```
@(<key1>=<value1>,<key2>=<value2>, …, <keyN>=<valueN>)
```

**Note**

- Each annotation statement is composed of one or more key-values pair.
- The value can be true, false, or a string.
- If the value is a string, it should be double quoted.

The following is a sample template variable, “hostname”, with annotation statement with the keys “DisplayName”, and “Description”:

```
@((DisplayName="Host Name", Description = “Description of the host”)
```

String hostname;

The table displays the supported keys in the annotation statement:
Table 1-4  Annotation Keys

<table>
<thead>
<tr>
<th>Key Name</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DisplayName</td>
<td>Empty String</td>
<td>The value is displayed as a variable label in the template form GUI, on POAP definition screen.</td>
</tr>
<tr>
<td>Description</td>
<td>Empty String</td>
<td>Displays the description next or below the template variable field in the template form GUI.</td>
</tr>
<tr>
<td>IsManagement</td>
<td>false</td>
<td>The associated variable is of IP Address type. This will be used as the management IP address. DCNM used this IP address to manage the devices.</td>
</tr>
<tr>
<td>IsMultiplicity</td>
<td>false</td>
<td>If true, this single value can take multiple values. For example; when it is used with IsManagement annotation, it allows you to type in multiple IP addresses and assign each IP address to a device.</td>
</tr>
<tr>
<td>IsSwitchName</td>
<td>false</td>
<td>The associated variable value is used as the device host name.</td>
</tr>
<tr>
<td>IsMandatory</td>
<td>true</td>
<td>It marks the field as mandatory if the value is set as ‘true’.</td>
</tr>
<tr>
<td>UseDNSReverseLookup</td>
<td>false</td>
<td>This annotation compliments the IsSwitchName annotation. Once they are associated with a variable. The variable is populated with the reverse DNS name, if available during the creation time of the corresponding POAP definition record.</td>
</tr>
<tr>
<td>IsFabricPort</td>
<td>false</td>
<td>The associated variable value contains a list of the ports used as fabric ports. The variable value will be used by the cable plan generation from POAP.</td>
</tr>
<tr>
<td>IsHostPort</td>
<td>false</td>
<td>Trunk ports connected to host/servers.</td>
</tr>
<tr>
<td>IsVPCDomainID</td>
<td>false</td>
<td>Used as the VPC Domain ID.</td>
</tr>
<tr>
<td>IsVPCPeerLinkSrc</td>
<td>false</td>
<td>Used as the VPC IPv4 source address.</td>
</tr>
<tr>
<td>IsVPCPeerLinkDst</td>
<td>false</td>
<td>Used as the VPC IPv4 peer address.</td>
</tr>
<tr>
<td>IsVPCPeerLinkPortChannel</td>
<td>false</td>
<td>Used for VPC port channel.</td>
</tr>
<tr>
<td>IsVPCLinkPort</td>
<td>false</td>
<td>Used for VPC interface.</td>
</tr>
<tr>
<td>IsVPC</td>
<td>false</td>
<td>Used as a VPC record.</td>
</tr>
<tr>
<td>IsVPCID</td>
<td>false</td>
<td>Individual VPC ID.</td>
</tr>
<tr>
<td>IsVPCPortChannel</td>
<td>false</td>
<td>Individual VPC port channel.</td>
</tr>
<tr>
<td>IsVPCPort</td>
<td>false</td>
<td>VPC Interface.</td>
</tr>
</tbody>
</table>

POAP Definitions

The POAP switch definition has two major functions:

- Monitoring switch POAP process
- Managing POAP switch configuration

You must copy the Cisco DCNM license files to the `/var/lib/dcnm/license` directory to install as part of the POAP process.

You must also copy the device licenses to the `/var/lib/dcnm/licenses` folder.

The device licenses refers to the devices monitored by the Cisco DCNM.

The following fields and icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Fields and Icons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial Number</td>
<td>Specifies the serial number for the switch.</td>
</tr>
<tr>
<td>Switch ID</td>
<td>Specifies the ID defined for the switch</td>
</tr>
<tr>
<td>Management IP</td>
<td>Specifies the Management IP for the switch.</td>
</tr>
<tr>
<td>Status</td>
<td></td>
</tr>
<tr>
<td>Switch Status</td>
<td>Indicates if the switch is published or not.</td>
</tr>
<tr>
<td>Publish Status</td>
<td>Indicates if this POAP template has been published successfully to the TFTP site.</td>
</tr>
<tr>
<td>Bootscript Status</td>
<td>Indicates the Bootscript execution state when the device executed POAP. For details, view the “Boot Log” file.</td>
</tr>
<tr>
<td>Diff State</td>
<td>Specifies if the configuration defined in POAP is different from the running configuration on the device. If a difference is detected, the user has an option to make changes to the device configuration, thereby ensuring that the configuration on the device in sync with the POAP configuration. The different states are:</td>
</tr>
<tr>
<td></td>
<td>• NA—Specifies that no POAP definition is configured on DCNM for the particular device; therefore, no difference computation can be made.</td>
</tr>
<tr>
<td></td>
<td>• Diff Detected—Specifies that few configuration differences are detected between POAP definition in DCNM and the running configuration on the switch. You can review the difference statements and choose the commands to deploy to the device, and synchronize the running configuration with the POAP definition.</td>
</tr>
<tr>
<td></td>
<td>• No Diff Detected—Specifies that there was no configuration diff perceived between POAP definition and the running configuration on the switch.</td>
</tr>
<tr>
<td></td>
<td>• Error—Specifies that an error has occurred during diff computation. Refer to the logs to troubleshoot the issue.</td>
</tr>
<tr>
<td>Model</td>
<td>Specifies the model of the switch.</td>
</tr>
<tr>
<td>Template/Config File Name</td>
<td>Specifies the template used for creating the POAP definition.</td>
</tr>
<tr>
<td>Bootscript Last Updated Time</td>
<td>Specifies the last updated time for bootscript.</td>
</tr>
<tr>
<td>Last Published</td>
<td>Specifies the last published time for the POAP definition.</td>
</tr>
</tbody>
</table>
Fields and Icons | Description
---|---
Last Saved | Specifies the last saved time for the POAP definition.
POAP Creation Time | Specifies the time when the POAP definition was created.
System Image | Specifies the System Image used while creating the POAP definition.
Kickstart Image | Specifies the kickstart image used the POAP definition

Icons

Add | Allows you to add a POAP definition. For more information, see Creating a POAP definition.
Edit | Allows you to edit a POAP definition. For more information, see Editing a POAP Definition.
Delete | Allows you to delete a POAP definition. For more information, see Deleting POAP Definitions.
Publish | Allows you to publish a POAP definition. For more information, see Publishing POAP definitions.
Write Erase and Reload | Allows you to reboot and reload a POAP definition. For more information, see Write, Erase and Reload the POAP Switch Definition.
Change Image | Allows you to change the image for the defined POAP definition. For more information, see Change Image.
Boot Log | Display the list and view log files from the device bootflash.
Refresh Switch | Refreshes the list of switches.
Show Filter | Filters list of switches based on the defined value for each column.
Print | Prints the list of devices and their details.
Export | Exports the list of devices and their details to a Microsoft Excel spreadsheet.
Select Columns | Displays the columns to be displayed. You can choose to show/hide a column.

1. You can discover the device manually also. Navigate to Admin < Data Sources on the Web Client to initiate a “Diff state” comparison for each device.

Note: Each annotation statement is composed of one or more key-values pair. The value can be true, false or a string. If the value is a string, it should be mentioned in double-quotes.

This section contains the following:

- Creating a POAP definition
- Uploading a POAP Definition
- Editing a POAP Definition
- Deleting POAP Definitions
- Publishing POAP definitions
- Write, Erase and Reload the POAP Switch Definition
Creating a POAP definition

Step 1  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)>POAP Definitions.**
Step 2  Click **Add** to add a new POAP definition.
Step 3  Use the radio button and select **Generate Definition** to generate POAP definition from a template, and click **Next** to specify the switch details.
Step 4  Enter the serial number of switches separated by comma. Alternatively, you can click the **Import from CSV File** button to import the list of switches.
Step 5  Use the drop-down to select the Switch Type.
Step 6  Use the drop-down to select the Image Server.
Step 7  Use the drop-down to select the System Image and Kickstart image.
Step 8  Use the drop-down to select the Config Server, and specify the Switch User Name and Password.
Step 9  Use the drop-down in the Add Switches to Group to add the POAP devices to a specific group, and specify the Switch User Name and Switch Password.
Step 10  Click **Next** to Select the Switch Config Template.
Step 11  Use the drop-down to select the Template and click **View** to specify the Template Parameters.
Step 12  Enter Template Parameters.
Step 13  Use the drop-down to select the Settings File. If the settings file in unavailable, click **Save Parameter as New Settings File** button to specify a name for the settings file, select the variables and click **Save**. The new settings file will now be listed in the Settings File drop-down.
Step 14  Click **View** to view the settings file parameters.
Step 15  Click **Manage** to modify the settings file parameters.
Step 16  Click **Next** to generate the configuration.

Uploading a POAP Definition

Step 1  From the menu bar, select **Config > Power-On Auto Provisioning (POAP) > POAP Definitions.**
Step 2  Use the radio button and select **Upload Startup Config** to upload startup config to the POAP repository Server, and click **Next** to Enter the switch details.
Step 3  Enter the serial number of switches separated by comma.
Step 4  Use the drop-down to select the **Switch Type.**
Step 5  Use the drop-down to select the **Image Server.**
Step 6  Use the drop-down in the **Add Switches to Group** to add the POAP devices to a specific group.
Step 7  Use the drop-down to select the **System Image** and **Kickstart Image.**
Step 8  Use the drop-down to select the **Config Server**, and specify the Switch User Name and Password.
Step 9  Click **Browse** to select the upload configuration file.
Step 10  Click **Save** to save the uploaded the configuration file or **Publish** to publish the POAP definition.
Editing a POAP Definition

**Step 1**  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)** > Select the POAP switch definitions from the list and click the **Edit** icon.

**Step 2**  Follow the steps listed in Creating a POAP definition and Uploading a POAP Definition sections.

**Note**  You can select multiple POAP definitions with similar parameters to edit POAP definition.

Deleting POAP Definitions

**Step 1**  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)** > Select the POAP switch definitions from the list and Click the **Delete** icon.

**Step 2**  Click **Yes** to delete the switch definitions.

A prompt appears to delete the device from the data source.

**Step 3**  Click **OK** to confirm to delete the device from the data source also.

Publishing POAP definitions

**Step 1**  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)** > Select the POAP switch definitions from the list and Click the **Publish** icon.

**Step 2**  Click **Yes** to publish the switch definitions.

Write, Erase and Reload the POAP Switch Definition

**Step 1**  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)** > Select the POAP switch definitions from the list.

**Step 2**  Click the **Write, Erase and Reload** icon.

**Step 3**  Click **Continue** to reboot and reload the switch definitions.

Change Image

**Step 1**  From the menu bar, select **Config > Power-On Auto Provisioning (POAP)** > Select the POAP switch definitions from the list.

**Step 2**  Select the switch for which you need to change the image. Click **Change Image**.

**Note**  You can select multiple POAP definitions with similar parameters to change the image for booting the device.

The Multi Device Image Change screen appears.

**Step 3**  From the **Image Server** dropdown list, select the server where the new image is stored.

**Step 4**  From the **System Image** dropdown list, select the new system image.
Step 5  From the **Kickstart Image** dropdown list, select the new image which will replace the old image.

Step 6  Click **Publish** to apply and change the image.

**Cable Plan**

The Cable plan configuration screen has the following options:

- Create a Cable Plan
- Viewing an Existing Cable Plan Deployment
- Deleting a Cable Plan
- Deploying a Cable Plan
- Revoking a Cable Plan
- Viewing a Deployed Cable Plan from Device

**Note**

If you are generating POAP definitions from the uploaded configuration, then generation of cable plan using the option of “Generate Cable Plan from POAP definition” will not work as the POAP definitions generated from the uploaded configuration will not have the required meta-data to generate the cable plans. You must select either “Capture from Existing Deployment” or “Import Cable plan file” to create a cable plan.

**Create a Cable Plan**

**Step 1**  From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.

**Step 2**  Click **Create Cable Plan**.

In the Create Cable Plan pop-up, use the radio button to select the options.

**Step 3**  If you select:

- **Generate Cable Plan from POAP definition**: You can use the switches defined in the POAP flow and produce a port-to-port cable plan to be used when wiring the physical devices.
- **Capture from existing deployment**: You can ascertain the Inter-Switch Links between existing switches managed by DCNM and “lock down” the cable plan based on the existing wiring.
- **Import Cable Plan File**: You decide how to wire the switches (or how they are already wired) and select an XML file for import into DCNM.

**Viewing an Existing Cable Plan Deployment**

**Step 1**  From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.

**Step 2**  Click **View**.

**Step 3**  In the Cable Plan - Existing_Deployment window, you can view the existing cable plan deployments.

**Step 4**  You can use the Table View and XML View icons to change the view of the cable plan deployments table.
Deleting a Cable Plan

**Step 1** From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.
**Step 2** Click **Delete from DCNM**.
**Step 3** Click **Yes** to confirm deletion.

Deploying a Cable Plan

**Step 1** From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.
**Step 2** In the Switches table, use the checkbox to select cable plan(s) and click **Deploy a Cable Plan**.
**Step 3** Click **Yes** to confirm deployment.

Revoking a Cable Plan

**Step 1** From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.
**Step 2** In the Switches table, use the checkbox to select cable plan(s) and click **Revoke a Cable Plan**.
**Step 3** Click **Yes** to confirm.

Viewing a Deployed Cable Plan from Device

**Step 1** From the menu bar, select **Config>Power-On Auto Provisioning (POAP)>Cable Plan**.
**Step 2** In the Switches table, click **In Sync** or **Out of Sync** hyperlink in the cable plan status column.
**Step 3** You can use the Table View and XML View icons to change the view of the cable plan table.

Fabric

Note

These features appear on your Cisco DCNM Web Client application only if you have deployed the DCNM installer in the Unified Fabric mode.

This feature automates network provisioning and provides a new layer of automation integration in which the data center fabric-switching infrastructure is automatically provisioned for the physical or virtual workload that is being instantiated.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

**Table 1-5**

<table>
<thead>
<tr>
<th>Field/Icons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organizations Section</td>
<td></td>
</tr>
<tr>
<td>Organization/Partition Name</td>
<td>Specifies the organization or the partition name.</td>
</tr>
</tbody>
</table>
Table 1-5

<table>
<thead>
<tr>
<th>Field/Icons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Specifies the description for the organization.</td>
</tr>
<tr>
<td>Partition ID</td>
<td>Specifies the partition ID to be associated with the partition.</td>
</tr>
<tr>
<td>Orchestration Engine</td>
<td>Specifies the Orchestrator name for the organization.</td>
</tr>
<tr>
<td>Service Node IP Address</td>
<td>Specifies the IP address for the service node for a partition.</td>
</tr>
<tr>
<td>Edge Router ID</td>
<td>Specifies the Edge Router ID.</td>
</tr>
<tr>
<td>Extension Status</td>
<td>Specifies if the extension is enabled or disabled.</td>
</tr>
<tr>
<td>Profile</td>
<td>Specifies the default profile used.</td>
</tr>
</tbody>
</table>

Networks Section

<table>
<thead>
<tr>
<th>Field/Icons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Name</td>
<td>Specifies the name to identify the network.</td>
</tr>
<tr>
<td>Partition Name</td>
<td>Allows you to select the partition to be applied for the network.</td>
</tr>
<tr>
<td>Segment ID</td>
<td>Specifies the segment ID to be used for partition extension.</td>
</tr>
<tr>
<td>Mobility Domain VLAN ID</td>
<td>Specified the VLAN ID for the mobility domain.</td>
</tr>
<tr>
<td>Mobility Domain ID</td>
<td>Allows you to select the mobility domain ID from the drop-down list.</td>
</tr>
<tr>
<td>Profile Name</td>
<td>Specifies the default profile used.</td>
</tr>
<tr>
<td>DHCP Scope Subnet</td>
<td>Specifies the subnet for the network.</td>
</tr>
<tr>
<td>Gateway</td>
<td>Specifies the gateway for the network.</td>
</tr>
<tr>
<td>IP Range</td>
<td>Specifies the IP address range available for the network.</td>
</tr>
<tr>
<td>Add</td>
<td>Allows you to add Organization, Partition, or Network.</td>
</tr>
<tr>
<td>Edit</td>
<td>Allows you to edit Organization, Partition, or Network.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allows you to delete Organization, Partition, or Network.</td>
</tr>
<tr>
<td>Enable Extension</td>
<td>Allows you to enable the extension for the selected Organization.</td>
</tr>
<tr>
<td>Disable Extension</td>
<td>Allows you to disable the selected extension.</td>
</tr>
<tr>
<td>Deploy Configuration</td>
<td>Allows you to deploy the network for the selected partition.</td>
</tr>
<tr>
<td>Undeploy Configuration</td>
<td>Allows you to undeploy the network configuration.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the list of items in the view.</td>
</tr>
<tr>
<td>Show Filter</td>
<td>Filters list of items based on the defined value for each column.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the list of Organizations or Networks along with their details.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the list of items and their details to a Microsoft Excel spreadsheet.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Allows you to maximize the view for Organizations or Networks.</td>
</tr>
</tbody>
</table>

Fabric provides the following configuration options:

- Organizations
  - Adding an Organization
  - Editing an Organization
  - Deleting an Organization
Adding an Organization

Step 1  From the menu bar, select Config > Auto-Configuration > Organizations > Add > Organization.
Step 2  In the Add Organization window, specify the Name and Description of the organization.
Step 3  Specify the Orchestration Engine.
Step 4  Click Add.

Editing an Organization

Step 1  From the menu bar, select Config > Auto-Configuration > Organizations.
Step 2  Select an organization from the List and click the Edit icon.
Step 3  In the Edit Organization window, change the configuration.
Step 4  Click Edit to save the changes.

Deleting an Organization

Note You must delete all partitions under an organization before deleting the organization.

Step 1  From the menu bar, select Config > Auto-Configuration > Organizations.
Step 2  Select an organization from the List and click the Delete icon.
Step 3  Click Yes to confirm.

Adding a Partition

Step 1  From the menu bar, select Config > Auto-Configuration > Organizations > Add > Partition.
Step 2  In the Add Partition window, use the drop-down to select the organization.
Step 3  Specify the Name for the partition.
Step 4  Specify the VRF name and provide description for the partition.
Step 5 Specify the Edge Router ID for the partition.
Select the checkbox if you choose to extend the partition across the fabric.
If you do not select the checkbox, this partition will not be extended across the Fabric.

Step 6 Specify the DNS Server and the Secondary DNS server for the partition.

Step 7 From the drop-down list, select the default Profile Name.
The values for the Profile Parameters are auto-populated based on the default Profile Name.

Step 8 Click OK to configure the partition.

Editing a Partition

Step 1 From the menu bar, select Config>Auto-Configuration>Organizations.
Step 2 Click an organization from the List and select the Partition.
Step 3 Click the Edit icon
Step 4 In the Edit Partition window, change the configuration.
Step 5 Click Edit to save the changes.

Deleting a Partition

Note You must delete all networks under the partition before deleting the partition.

Step 1 From the menu bar, select Config>Auto-Configuration>Organizations.
Step 2 Click an organization from the List and select the Partition.
Step 3 Click the Delete icon
Step 4 Click Yes to confirm.

Adding a Network

Step 1 From the menu bar, select Config > Auto-Configuration > Networks >Add.
Step 2 In the Add Network window, use the drop-down to select the Organization and Partition.

Note If there is only one organization and partition configured, the values for these fields are automatically populated.

Step 3 Specify the VRF Name for the partition.
The VRF Name must be of the format organizationName:partitionName.
Step 4 Specify the Network Name to identify the network.
Step 5 Specify the Multicast Group Address.
Profiles

Profiles provide the following configuration options:

- Profiles
  - Adding a profile
  - Editing a Profile

**Note**
The Multicast Group Address is used to enable VxLAN encapsulation on the Admin > Fabric Encapsulation Settings page.

Step 6 Select the **Network Role** from the drop-down list based on the type of the network.

Step 7 In the Network ID section, choose one of the following:

- Segment ID Only
  - Specify the **Segment ID** for the network.
- Mobility Domain and VLAN
  - Specify the **Segment ID** for your network.
  - Select **Generate Seg ID** to generate segment ID automatically.
  - Specify the **VLAN ID** and **Mobility Domain ID** if you need to create a VLAN + Mobility Domain network.

Step 8 In the DHCP Scope section, specify the **IP Range**.

Step 9 Use the drop-down to select the **Profile**.

Step 10 Specify the **Profile** parameters.

Step 11 Specify the **Service Configuration** parameters.

Step 12 Click Add.

**Editing a Network**

Step 1 From the menu bar, select **Config>Auto-Configuration>Networks**.

Step 2 Select a network from the List and click the **Edit** icon.

Step 3 In the Edit Partition window, change the configuration.

Step 4 Click **Edit** to save the changes.

**Deleting a Network**

Step 1 From the menu bar, select **Config>Auto-Configuration>Networks**.

Step 2 Select a network from the List and click the **Delete** icon.

Step 3 Click **Yes** to confirm.
Profiles

Adding a profile

Step 1
From the menu bar, select Config > Profiles > Add.

Step 2
In the Add Profile window, specify the Name and Description of the profile.

Note
For global VLAN profiles which have names ending with “GblVlanProfile”, Cisco Prime DCNM will use the VLAN ID, instead of the Segment ID, to refresh the network when the network of that profile is updated.

Step 3
Use the drop-down, select the Type of the Profile.

Note
Devices with different platforms may use profiles of different profile types. For Cisco Prime DCNM Release 7.1, only FPVLAN is supported.

Step 4
From the drop down, select Sub Type. Sub Type of profiles differentiate profile categories, such as:
- individual profile
- universal profile
- network profile
- partition profile
- DCI profile and so on.

For more information, see Cisco Dynamic Fabric Automation Configuration Guide.

In DCNM Release 7.1, the following subtypes are supported:
- partition:universal - Universal profile for a partition
- network:universal - Universal profile for a network
- bl-er:universal - Universal profile for a Border Leaf or Edge Router
- bl-er:universal,er - Universal profile for an Edge Router
- bl-er:universal,bl - Universal profile for a Border Leaf
- partition:individual - Individual profile for a partition
- network:individual - Individual profile for a network

Step 5
Use the drop-down to select the Forwarding Mode. The following values are supported:
- anycast-gateway
- proxy-gateway
- none

Step 6
Enter the Profile Content from collection of CLI commands to discover a specific configuration.
Step 7  Click Add.

Editing a Profile

Step 1  From the menu bar, select Config > Profiles.
Step 2  Select a profile from the list and click the Edit icon.
Step 3  In the Edit profile window, change the configuration.
Step 4  Click Edit to save the changes.

Delete a Profile

Step 1  From the menu bar, select Config > Profiles.
Step 2  Select a profile from the list and click the Delete icon.
Step 3  Click Yes to confirm.

Editing a Profile Instance

Step 1  From the menu bar, select Config > Profiles.
Step 2  Select a profile from the list and click the Edit icon.
Step 3  In the Edit Profile Instance window, change the configuration.
Step 4  Click Edit to save the changes.

Administering Cisco DCNM Web Client

The Admin options allows you to perform minor administrative and configuration tasks on the Cisco DCNM-SAN Server.

The Admin option contains the following sub-menus:

- **Status**—Displays the status of the Database Server and allows you to start and stop Performance collector services on your server. You should restart services only if something is not working properly or if too large a percentage of system resources are being consumed.
- **Data Sources**—Allows you to view all the data sources such as Fabric, LAN, VMware, SMIS and so on.
- **Logs**—Allows you to view all the logs from the various services running on the Cisco DCNM-SAN Server.
- **Server Properties**—Allows you to view all the fields defined in the server.properties config file.
- **SFTP Credentials**—Allows you to view the SFTP credentials.
- **License**—Allows you to view the licensing details.
Federation—Allows you to view the server federation details.

Clients—Allows you to view all the clients connected to the Cisco DCNM-SAN Server.

Note

You cannot start or stop the Database Server services using DCNM Web Client. If you are using the Microsoft Windows operating system, you need to use Microsoft Management Console to stop, start, or restart the Database Server.

- If you see a database file lock error in the database log, you can fix it by shutting down and restarting the database server using the Web Client.
- Only network administrators can access the DCNM Web Client Admin options. Network operators cannot view the Admin options.

This section includes the following topics:

- Starting, Restarting, and Stopping Services section, page 1-70
- Administering Datasources section, page 1-70

Starting, Restarting, and Stopping Services

Step 1  DETAILSED STEPS  From the menu bar, choose Admin > General > Status.

You see a table of services per server and the status of each as shown in Figure 1-1.

Figure 1-1  DCNM-SAN Services Status

Step 2  In the Actions column, use the Start, (Re)start or Stop icons to start, restart, or stop any of the services.

Administering Datasources

You can manage the Fabrics, LAN and VMWare using the datasources option. This section contains the following:

- Adding, Editing, Re-discovering, Purging and Removing Managed Fabrics section, page 1-71
- Adding, Editing, Re-discovering, Purging and Removing LAN, LAN Tasks and Switch section, page 1-73
- Adding, Editing, Re-discovering and Removing VMware Servers section, page 1-76
Adding, Editing, Re-discovering, Purging and Removing Managed Fabrics

Cisco DCNM Web Client reports information obtained by the Cisco DCNM-SAN on any fabric known to Cisco DCNM-SAN.

This section contains the following:
- Adding a Fabric section, page 1-71
- Editing a Fabric section, page 1-71
- Rediscovering a Fabric section, page 1-72
- Purging a Fabric section, page 1-72
- Removing a Fabric section, page 1-72
- Moving Fabrics to Another Server Federation section, page 1-72

Adding a Fabric


**Step 1**
From the menu bar, choose Admin > General > Data Sources.
You see a list of fabrics (if any) managed by Cisco DCNM-SAN in the Opened column.

**Step 2**
Click Add Fabric to add a new fabric.
You see the Add Fabric dialog box.

**Step 3**
Enter the Fabric Seed Switch IP address for this fabric.

**Step 4**
(Optional) Check the SNMPV3 check box. If you check SNMPV3, the fields Read Community and Write Community change to Username and Password.

**Step 5**
Enter the User Name and Password for this fabric.

**Step 6**
Select the privacy settings from the Auth-Privacy drop-down list.

**Step 7**
(Optional) Check the Limit Discovery by VSAN checkbox to specify the included VSAN list or excluded VSAN list from the VSANs provided to discover a new fabric.

**Step 8**
(Optional) Check the Enable NPV Discovery in all Fabrics check box. If you check enable NPV discovery in all fabrics, the changes are applied to all the fabrics that are previously discovered.

**Step 9**
Click Add to begin managing this fabric.
You can remove single or multiple fabrics from the Cisco DCNM Web Client.

Editing a Fabric

You can remove single or multiple fabrics from the Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose Admin > General > Data Sources.

**Step 2**
Select the check box next to the fabric that you want to edit and click Edit Fabric.
You see the Edit Fabric dialog box. You can edit only one fabric at a time.

**Step 3**
Enter a new fabric Name.
Step 4  (Optional) Check the **SNMPV3** check box. If you check SNMPV3, the Community field change to Username and Password.

Step 5  Enter the **User Name** and **Password**, privacy and specify how you want DCMN Web Client to manage the fabric by selecting one of the status options.

Step 6  Change the fabric management state to **Managed**, **Unmanaged**, or **Managed Continuously**.

Step 7  Click **Apply** to save the changes.

---

**Note**  In the **Admin>Datasources>Fabric**, Select the fabric for which the fabric switch password is changed. Click **Edit Fabric**, unmanage the fabric, specify the new password and then manage the fabric. You will not be able to open the fabric as the new password will not sync with the database. To open the fabric, you must log into the DCMN-SAN client, Go to **Server>Admin** and click the **Open** tab. Select the fabric and change the password manually in the Client Password/Community column.

---

**Rediscovering a Fabric**

**Step 1**  From the menu bar, choose **Admin>General>Datasources**.

**Step 2**  Select the check box next to the fabric and click the **Re-discover Fabric** icon.

**Step 3**  Click **Yes** in the pop-up window.

The Fabric will now be re-discovered.

**Purging a Fabric**

**Step 1**  From the menu bar, choose **Admin>General>Datasources**.

**Step 2**  Select the check box next to the fabric and click the **Purge Fabric** icon.

**Step 3**  Click **Yes** in the pop-up window.

The Fabric will now be purged.

**Removing a Fabric**

**Step 1**  From the menu bar, choose **Admin > General > Data Sources**.

**Step 2**  Select the check box next to the fabric that you want to remove and click **Remove Fabric** icon to remove the fabric from the datasource and to discontinue data collection for that fabric.

**Moving Fabrics to Another Server Federation**

This feature is only available on the federation setup and the Move Fabric is only displayed in the federation setup screen.

You can move the fabrics from a sever that is down to an active server. The management state will remain the same.

**Step 1**  From the menu bar, choose **Admin > General > Data Sources**.

**Step 2**  Select the fabrics from the fabric table. Click **Move Fabrics** to another Federation Server, or **Move LAN Tasks** to another DCMN Server.
Step 3 Select the fabrics that need to be moved and click **Move Fabric**.

Step 4 In the Move Fabrics to another Federation server dialog box, select the DCNM server where the fabrics will be moved. The server drop-down list will list only the active servers.

Step 5 In the Move LAN Tasks to another DCNM Server dialog box, enter the LAN tasks that need to be moved and specify the DCNM server.

**Adding, Editing, Re-discovering, Purging and Removing LAN, LAN Tasks and Switch**

Cisco DCNM Web Client reports information obtained by the Cisco DCNM-LAN devices. This section contains the following:

- Adding LAN Devices section, page 1-73
- Editing LAN Devices section, page 1-74
- Purging LAN section, page 1-74
- Removing LAN Devices section, page 1-74
- Edit LAN Task section, page 1-75
- Re-discover LAN Task section, page 1-75
- Step 3 Click Yes in the pop-up window to re-discover the LAN. section, page 1-75
- Moving LAN Devices Under a Task section, page 1-75
- Remove LAN Task/Switch section, page 1-75
- Delete a Switch section, page 1-75
- Toggle between Task and Device view section, page 1-76

**Adding LAN Devices**

**Step 1** From the menu bar, choose **Admin > General > Data Sources**. You see the list of LAN devices in the Name column.

**Step 2** Click **Add LAN Task** to add LAN. You see the Add LAN dialog box.

**Step 3** Select **Hops from Seed Switch**, **Switch List** or **FWSM**. The fields vary depending on your selection.

**Step 4** Enter the **Seed Switch** IP address for the fabric.

**Step 5** The options vary depending on the discovery type selected. For example; If you select **SNMPV1** or **SNMPV3/CLI** check box varied fields are displayed.

**Step 6** Select the switch group and specify the Scan Time-out.

**Step 7** Specify the user credentials and the Optional Enable Password.

**Step 8** Use the drop-down to select the switch group.

**Step 9** Click **Next** to begin the Shallow Discovery.

**Step 10** In the Shallow LAN Discovery window, you can select all switches by using the checkbox next to the switch name column or select individual switches. Click **Previous** to go back and edit the parameters.
Note
In the Status column, if the switch status is Time-out or Cannot be contacted, these switches cannot be added.

Step 11
Select a switch and click Add to add a switch to the switch group.
If the seed switch(es) are not reachable, it will be shown as “unknown” on the shallow Discovery window.

Editing LAN Devices
You can modify a LAN from Cisco DCNM Web Client.

Step 1
From the menu bar, choose Admin > General > Data Sources.
Step 2
Select the check box next to the LAN that you want to edit and click Edit LAN by CDP Seed.
You see the Edit LAN dialog box.
Step 3
Enter the User Name and Password.
Step 4
Select the LAN status as Managed or Unmanaged.
Step 5
Select the Candidate Switches for Deep Discovery.

Note
You can hold the Ctrl key on your keyboard to select multiple candidate switches.

Step 6
Click Apply to save the changes.

Purging LAN

Step 1
From the menu bar, choose Admin>General>Datasources.
Step 2
Click the Purge unreachable devices or dead links in selected LAN icon.
Step 3
Click Yes in the pop-up window to purge the LAN device.

Note
In case of a Federation set-up, you will have to select the LAN to purge.

Removing LAN Devices
You can remove a LAN from Cisco DCNM Web Client.

Step 1
From the menu bar, choose Admin > General > Data Sources.
Step 2
Select the check box next to the LAN that you want to remove and click the Remove LAN by CDP Seed icon to remove the switches and all their data.
Step 3
Click Yes to review the LAN device.
You can also remove an individual LAN Switch

Step 1
From the menu bar, choose Admin > General > Data Sources.
Step 2
Click the arrow next to the DCNM Server check box to expand the field.
Step 3  In the Switch column, click **Delete Switch** icon to delete a switch connected to the DCNM server.

**Edit LAN Task**

**Step 1**  From the menu bar, choose **Admin > General > Datasources**

**Step 2**  In the Discovery Task column, click the **Edit LAN Task** icon.

**Step 3**  In the Edit LAN Task dialog box, specify the user credentials and the Optional Enable Password.

**Step 4**  Use the radio button to select the Status.

**Step 5**  Click **Apply** to save the changes.

**Re-discover LAN Task**

**Step 1**  From the menu bar, choose **Admin > General > Datasources**.

**Step 2**  In the Discovery Task column, click the **Re-discover LAN** icon.

**Step 3**  Click **Yes** in the pop-up window to re-discover the LAN.

**Moving LAN Devices Under a Task**

You can move LAN devices under a task to a different server using Cisco DCNM Web Client. This feature is available only in the federation setup and the Move LAN is displayed in the federation setup screen.

You can move the LAN from a server that is down to an active server. The management state remains the same.

**Step 1**  From the menu bar, choose **Admin > General > Data Sources**.

**Step 2**  Choose the LAN from the LAN table. Click **Move LAN Tasks to another Federated Server**.

**Step 3**  In the Move LAN Tasks to another DCNM Server dialog box, enter the LAN tasks that need to be moved and specify the DCNM server. All the LAN devices under the selected tasks will be moved.

**Remove LAN Task/Switch**

**Step 1**  From the menu bar, choose **Admin > General > Data Sources**.

**Step 2**  In the Discovery Task column, click the **Remove LAN Task** icon.

**Step 3**  In the confirmation dialog box, click **Yes** to remove the LAN task.

**Delete a Switch**

You can also delete an individual switch connected to a DCNM Server.

**Step 1**  From the menu bar, choose **Admin > General > Data Sources**.

**Step 2**  In the Switch column, click the **Delete Switch** icon.

**Step 3**  In the confirmation dialog box, click **Yes** to delete the switch.
Administering Cisco DCNM Web Client

Chapter 1  Cisco DCNM Web Client

Toggle between Task and Device view

Step 1  From the menu bar, choose Admin > General > Data Sources.

Step 2  Click the Toggle between Task and Device view icon.

Step 3  In the Device view:
- In the Group column, use the drop-down to select the LAN group.
- Click the Add LAN Task icon to add a LAN. For more information see the Adding LAN Devices section.
- In the Discovery Task column, click the Edit LAN Task icon to edit the LAN task. For more information, see the Editing LAN Devices section.
- In the Discovery Task column, click the Re-discover LAN icon to rediscover the LAN. For more information see the Purging LAN section.
- In the Discovery Task column, click the Remove LAN Task icon to delete the LAN task. For more information, see the Removing LAN Devices section.
- In the Switch column, click Re-discover Switch icon to rediscover the switch.
- In the Switch column, click the Delete Switch icon to delete the switch.
- Click the Toggle between Task and Device view icon to toggle to the task view.

Step 4  In the Task view:
- Under Discovery Task, use the checkbox to select the task.
- Click the Add LAN Task icon to add a LAN. For more information see the Adding LAN Devices section.
- Use the checkbox to select the task and then click the Edit LAN Task icon at the upper-right corner above the table to edit the LAN task. For more information, see the Editing LAN Devices section.
- Use the checkbox to select the task and then click the Remove LAN Task icon at the upper-right corner above the table to delete the LAN task. For more information, see the Removing LAN Devices section.
- Use the checkbox to select the task and then click the Re-discover LAN icon at the upper-right corner above the table to rediscover the LAN. For more information see the Purging LAN section.
- Click the Refresh icon to refresh the LAN table.
- Click the Purge unreachable devices or dead links in selected LAN icon to purge the LAN. For more information see the Purging LAN section.
- Click the Toggle between Task and Device view icon to toggle to the device view.
- Click Re-discover Switch icon to rediscover the switch.
- Click the Delete Switch icon to delete the switch.
- In the Group column, use the drop-down to select the LAN group.

Adding, Editing, Re-discovering and Removing VMware Servers

DCNM Web Client reports information gathered by Cisco DCNM-SAN on any VMware servers supported by Cisco DCNM-SAN.
Ensure that the LAN and SAN are discovered before you add the vCenter on the datasource.

This section contains the following:
- Managing a VMware Server section, page 1-77
- Removing a VMware Server section, page 1-77
- Modifying a VMware Server section, page 1-77
- Rediscovering a VMware Server section, page 1-77

Managing a VMware Server

You can manage a VMware server from Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose Admin > General > Data Sources.
You see the list of VMware servers (if any) that are managed by Cisco DCNM-SAN in the table.

**Step 2**
Click the Add Virtual Center icon.
You see the Add VMware dialog box.

**Step 3**
Enter the Virtual Center Server IP address for this VMware server.

**Step 4**
Enter the User Name and Password for this VMware server.

**Step 5**
Click Add to begin managing this VMware server.

Removing a VMware Server

You can remove a VMware server from the Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose Admin > General > Data Sources.

**Step 2**
Select the check box next to the VMware server that you want to remove and click Remove Virtual Center to discontinue data collection for that VMware server.

Modifying a VMware Server

You can modify a VMware server from Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose Admin > General > Data Sources.

**Step 2**
Check the check box next to the VMware server that you want to edit and click Edit Virtual Center icon.
You see the Edit VMware dialog box.

**Step 3**
Enter the User Name and Password.

**Step 4**
Select managed or unmanaged status.

**Step 5**
Click Apply to save the changes.

Rediscovering a VMware Server

You can rediscover a VMware server from Cisco DCNM Web Client.
**Adding, editing, removing, rediscovering and refreshing SMI-S Storage**

The SMI-S providers are managed using the DCNM Web Client.

This section contains the following:

- Adding SMI-S Provider.
- Editing SMI-S Provider.
- Deleting SMI-S Provider.
- Re-Discover SMI-S Provider.
- Refresh SMI-S Provider

### Adding SMI-S Provider

**Step 1**  
From the menu bar, choose Admin > General > Data Sources.

**Step 2**  
Click the Add SMIS Provider icon.

**Step 3**  
In the Add SMI-S Provider window, use the drop-down to select the Vendor. Only EMC and NetApp are currently supported. Additional SMI-S storage vendors are discovered through a ‘best effort’ handler using the ‘Other’ vendor option in the drop-down.

**Note**  
At least one valid DCNM license must be provisioned before adding SMI-S storage discovery datasources.

**Step 4**  
Specify the SMI-S Server IP, User Name and Password.

**Step 5**  
Specify the Name Space and Interop Name Space.

**Step 6**  
By default, the Port number is pre-populated. If you select the Secure checkbox, then the default secure port number is populated.

When using the Secure mode with EMC, the default setting is mutual authentication. For more information, see EMC’s documentation about adding an SSL certificate to their trust store, or set SSLClientAuthentication value to ‘None’ in the Security_Settings.xml config file and then restart the ECOM service.

**Step 7**  
Click Add. The credentials are validated and if it’s valid the storage discovery starts. If the credential check fails, you will be prompted to enter valid credentials.

### Editing SMI-S Provider

**Step 1**  
From the menu bar, choose Admin > General > Data Sources.

**Step 2**  
Use the check-box to select the SMI-S provider and click the Edit SMIS Provider icon.

**Step 3**  
In the Edit SMI-S Provider window, use the drop-down to select the Vendor.
Step 4 Specify the SMI-S Sever IP, User Name and Password.

Step 5 Specify the Name Space and Interop Name Space.

Step 6 By default, the Port number is pre-populated. If you select the Secure checkbox, then the default secure port number is populated.

Step 7 Click Apply. The Storage Discovery is stopped and a new task is created using the new information and the Storage Discover is re-started.

Deleting SMI-S Provider

Step 1 From the menu bar, choose Admin > General > Data Sources.

Step 2 Use the check-box to select the SMI-S provider and click the Remove SMIS Provider icon.

The provider is removed and all data associated with the provider is purged from the system.

Re-Discover SMI-S Provider

Step 1 From the menu bar, choose Admin > General > Data Sources.

Step 2 Use the check-box to select the SMI-S provider and click the Re-discover SMIS Provider icon.

Refresh SMI-S Provider

Step 1 From the menu bar, choose Admin > General > Data Sources.

Step 2 Use the check-box to select the SMI-S provider and click the Refresh Table icon.

The providers are re-discovered.

Viewing Log Information

This feature enables you to view the Cisco DCNM Web Client log. These processes have no corresponding GUI that allows you to view information about these log files. If you see errors, preserve these two files for viewing.

Note Logs cannot be viewed from a remote server in a federation.

Step 1 From the menu bar, choose Admin > General > Logs.

You see a list of viewable logs in the left column.

Step 2 Click a log file to view it.

Configuring Cisco DCNM-SAN Server Properties

To configure Cisco DCNM-SAN Server properties
Step 1
From the menu bar, choose **Admin > General > Server Properties**.

Step 2

<table>
<thead>
<tr>
<th>Server Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>MANAGEMENT USERS&gt; LOCAL</strong></td>
<td></td>
</tr>
<tr>
<td>login.lockout.enabled</td>
<td>If <em>true</em>, lockout user after N failed login attempts. Defaults to <em>false</em> if unspecified.</td>
</tr>
<tr>
<td>login.lockout.threshold</td>
<td>Maximum number of failed login attempts.</td>
</tr>
<tr>
<td>login.lockout.threshold</td>
<td>Time period in minutes where failed attempts occur.</td>
</tr>
<tr>
<td>login.lockout.duration</td>
<td>If locked out, number of minutes before new login attempt. If ‘-1’, only an Administrator can unlock.</td>
</tr>
<tr>
<td><strong>GENERAL</strong></td>
<td></td>
</tr>
<tr>
<td>server.bindaddr</td>
<td>The IP address to be used on a multi-homed host. The server will only accept requests to this address. If unspecified, server will accept connections on any or all local addresses.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If you modify this after installation, you must update FMServer.conf and change &quot;wrapper.app.parameter.4&quot; to the new IP address.</td>
</tr>
<tr>
<td>server.port</td>
<td>Server’s unique TCP port.</td>
</tr>
<tr>
<td>server.data.port</td>
<td>Server’s data TCP Port.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If port is zero or unspecified, an anonymous port is chosen.</td>
</tr>
<tr>
<td>server.useSsl</td>
<td>Enable SSL to encrypt clientserver communication.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Defaults to false; if changed, remember to update client SSL option in FabricManager.{sh</td>
</tr>
<tr>
<td>server.sessiontimeout</td>
<td>Client session time out value, in seconds. Apply for both GUI client and Web client.</td>
</tr>
<tr>
<td>server.translatedAddr</td>
<td>Specify server’s NAT address for SNMP Trap registration. Defaults to no NAT address.</td>
</tr>
<tr>
<td>DFA-install</td>
<td>Default to DFAINSTALL.</td>
</tr>
<tr>
<td><strong>FEDERATION &gt; H/A</strong></td>
<td></td>
</tr>
<tr>
<td>server.autofailover</td>
<td>Automatically Fail Over fabrics from one server to another.</td>
</tr>
<tr>
<td>server.ping.retries</td>
<td>Number of retries before we determine server has failed.</td>
</tr>
<tr>
<td>server.ping.retryInterval</td>
<td>Retry interval in seconds.</td>
</tr>
</tbody>
</table>
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>server.simulationFile</td>
<td>Specified virtual IP address mapping file for simulation testing. The file should be placed in $INSTALL_DIR/fm/conf. The format for mapping is: IP</td>
</tr>
</tbody>
</table>

### DATA SOURCES

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmp.localport</td>
<td>Specify the local UDP port to send SNMP requests and receive SNMP responses. If unspecified or port 0 is specified, SNMP will be bound to a port chosen by the kernel. SNMP local UDP/TCP port to send and receive data to and from switch. If unspecified or zero, first available port will be chosen.</td>
</tr>
<tr>
<td>snmp.forward.udp.port</td>
<td>SNMP trap forwarding port. Default is 0, first available port will be chosen.</td>
</tr>
<tr>
<td>snmp.timeout</td>
<td>SNMP request timeout, in ms. Default is 10 seconds, SET PDUs timeout in 2x value.</td>
</tr>
<tr>
<td>snmp.retries</td>
<td>SNMP request retries. Defaults to 1.</td>
</tr>
<tr>
<td>snmp.qsize</td>
<td>Size of SNMP Pending queue. Defaults to 512.</td>
</tr>
<tr>
<td>snmp.maxRoundTripDelay</td>
<td>Increase round trip delay.</td>
</tr>
<tr>
<td>snmp.sndThreadPriInc</td>
<td>Send Thread Priority Increment.</td>
</tr>
<tr>
<td>snmp.rcvThreadPriInc</td>
<td>Receive Thread Priority Increment.</td>
</tr>
<tr>
<td>snmp.resetTime</td>
<td>Snmp session reset execute time at the hour of day (0-23), default value is 0.</td>
</tr>
<tr>
<td>snmp.resetPeriod</td>
<td>Snmp session reset period: Never=0, Once=1, Daily=2, Weekly=3, default value is 2.</td>
</tr>
<tr>
<td>trap.listen</td>
<td>Listen and process received snmp traps. Default is true.</td>
</tr>
<tr>
<td>trap.autoregistration</td>
<td>Automatically attempt to register with switches for traps. Default is true.</td>
</tr>
</tbody>
</table>
### Server Properties | Description
--- | ---
trap.registaddress | Specify a local IP address for registering SNMP traps and syslog on switches. By default or when unspecified, a kernel selected address is used to register. If server starts on a VPN address, you have to set this address to its VPN assigned address.

**trap.port** | Local SNMP Trap UDP port. This port should not be used by other applications.

**trap.severity.setting** | Mapping switch defined RMON/PMON event id to DCNM event severity.
   - Switch defined event severity (default): FATAL(1), CRITICAL(2), ERROR(3), WARNING(4), INFORMATION(5)
   - DCNM defined event severity: Emergency(0), Alert(1), Critical(2), Error(3), Warning(4), Notice(5), Info(6), Debug(7).
   **Note** The mapping severity name is case sensitive.

**snmp.preferTCP** | Enable SNMP over TCP when possible.
   **Note** If enabled and you wish to change username/password for fabric, you must unmanage fabric, update credentials, and manage fabric.

**snmp.v3only** | Only use SNMPv3 to communicate with v3 capable switches.

**snmp.pmVarBinPerPdu** | Set the number of var binds in one PDU, we assume each var bind size is less than 30 bytes.

**snmp.defaultCommunity** | Set the default community string when fabric is v3. If the switch does not support v3 then switch the protocol to v2 and use the default community string.

**snmpdisableAAASync** | Disable AAA sync through SNMP. Default is false.

**snmp.minPasswordLength** | Minimum SNMP password length. Default is 8.

### SNMP PROXY SERVER

**snmp.proxy** | Address SNMP uses to connect to reach switches. If unspecified, SNMP directly communicates with switches.
   **Format:** proxy_addr:proxy_port
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>proxy.autostart</td>
<td>Automatically start SNMP proxy server at startup. Default is true. Proxy will not be started if snmp.proxy is non-localhost.</td>
</tr>
<tr>
<td>proxy.localport</td>
<td>When proxy server is enabled, local TCP Port for client connection. If port 0 is specified, proxy will be bound to a port chosen by the kernel.</td>
</tr>
</tbody>
</table>

### TELNET,SSH Connection Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vsh.session_timeout</td>
<td>CLI session timeout in mins (used by DM/DCNM-SAN tools as 'Show Tech, Run CLI Commands' etc).</td>
</tr>
<tr>
<td>vsh.tcp_timeout</td>
<td>TCP session timeout in msec (used by DM/DCNM-SAN tools as 'Show Tech, Run CLI Commands' etc).</td>
</tr>
<tr>
<td>cli.channel.type</td>
<td>CLI session channel type: 1. shell (default) 2. exec</td>
</tr>
<tr>
<td>vshmanager.session-timeout</td>
<td>Variables used internally by server during AAA authentication for switch discovery and should not be changed</td>
</tr>
<tr>
<td>vshmanager.tcp-timeout</td>
<td>Variables used internally by server for ssh connections. session-timeout in seconds - session timeout, default 0s (no timeout). read-wait-time in mili-seconds - total wait time for response, default 15000ms.</td>
</tr>
</tbody>
</table>

### GENERAL->DATA SOURCES FABRIC

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>fabric.fcalias</td>
<td>Use FC Zone Aliases instead of Device Aliases.</td>
</tr>
<tr>
<td>fabric.autoAlias</td>
<td>Automatically construct alias from WWN where none exists. No switch config performed.</td>
</tr>
<tr>
<td>fabric.aliasRE</td>
<td>List of Regular Expressions for alias-&gt;enclosure creation. Disable by commenting out property.</td>
</tr>
<tr>
<td>fabric.alias.toEnclosure.toUpper</td>
<td>Force all Enclosure names to uppercase. Enclosure names are case-sensitive across fabrics; true is recommended.</td>
</tr>
<tr>
<td><strong>Server Properties</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>fabric.zone.toAlias.toUpper</td>
<td>Force zone name-&gt;alias aliases to uppercase when &quot;Alias =&gt; Enclosure&quot; button is pressed.</td>
</tr>
<tr>
<td><strong>POLLING</strong></td>
<td></td>
</tr>
<tr>
<td>fabric.max ConcurrentDiscovery</td>
<td>Maximum number of fabrics that can be polled concurrently. Defaults to 3, but may vary according to server machine capacity.</td>
</tr>
<tr>
<td>fabric.maxVsanDiscoveryPoolSize</td>
<td>Maximum number of VSAN-based discovery thread pool. Defaults to 20, but may vary according to server machine capacity.</td>
</tr>
<tr>
<td>fabric.retainSETPorts</td>
<td>Collect SAN_EXT_TUNER ports. Default to false, used for debugging.</td>
</tr>
<tr>
<td>fabric.maxOpenSwitches</td>
<td>Maximum number of switches allowed to be managed per DCNM Server federation node. Defaults to 1000, but may vary according to server machine capacity.</td>
</tr>
<tr>
<td>enableIPFC</td>
<td>Collect IPFC ports.</td>
</tr>
<tr>
<td>enableFV</td>
<td>Allow discover FV endports during discovery. Default to false.</td>
</tr>
<tr>
<td>enableVIRT</td>
<td>Allow discover virtual internal endpoints during discovery. Default to false.</td>
</tr>
<tr>
<td>newOUIs</td>
<td>Add new OUIs for discovering switch, end device with format: 0xhhhhhh vendor_name devicetypes h(host)ld(disk)lt(tape)ls(switch)lg(gateway)lm(cisco mds). For example: newOUIs=0x00E069 JNI h; 0x000ded Cisco m; \0x006069 Brocade s</td>
</tr>
<tr>
<td>zone.displayIVRZones</td>
<td>Retain IVR 'shadow zones' in VSAN active zones. Default is false if unspecified.</td>
</tr>
<tr>
<td>fabric.maxopen</td>
<td>Maximum number of fabrics managed. Defaults to 24, but may vary according to server machine capacity.</td>
</tr>
</tbody>
</table>
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>fabric.enableNpvDiscovery</td>
<td>Allow NPV discovery.</td>
</tr>
<tr>
<td></td>
<td>Default to true.</td>
</tr>
<tr>
<td>fabric.enableUcsHttpDiscovery</td>
<td>Allow UCS HTTP discovery.</td>
</tr>
<tr>
<td></td>
<td>Default to true.</td>
</tr>
<tr>
<td>fabric.useHost</td>
<td>Default device type for unknown end device</td>
</tr>
<tr>
<td></td>
<td>(unable to determine from its fc4feature/OUI).</td>
</tr>
<tr>
<td></td>
<td>Default to true, i.e., default the device to host.</td>
</tr>
<tr>
<td></td>
<td>If set to false, device type is set to storage.</td>
</tr>
<tr>
<td>fabric.managementIpOverwrite</td>
<td>Allow Management IP address overwrite.</td>
</tr>
<tr>
<td></td>
<td>Default to true.</td>
</tr>
<tr>
<td></td>
<td>Set it to false for SVI.</td>
</tr>
<tr>
<td></td>
<td>Default to 120 seconds.</td>
</tr>
</tbody>
</table>

### DCNM-SAN CLIENT

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>deactivate.confirm</td>
<td>Require string for deactivation on zoning config.</td>
</tr>
<tr>
<td></td>
<td>Empty string implies that no deactivation prompt</td>
</tr>
<tr>
<td></td>
<td>required.</td>
</tr>
<tr>
<td>client.enableCredentialCache</td>
<td>Remember user credentials in 'Open Fabric/LAN'</td>
</tr>
<tr>
<td></td>
<td>window.</td>
</tr>
<tr>
<td>client.validateOpenFabricPassword</td>
<td>Validate the user's DCNM login password with</td>
</tr>
<tr>
<td></td>
<td>the passwords used to open fabrics in 'Open</td>
</tr>
<tr>
<td></td>
<td>Fabric' window.</td>
</tr>
<tr>
<td>client.discover.useSNMPv3</td>
<td>Use SNMPv3 where possible.</td>
</tr>
<tr>
<td>client.discover.AuthPrivacy</td>
<td>SNMP Authentication-Privacy Protocol. Choose</td>
</tr>
<tr>
<td></td>
<td>&quot;MD5&quot;, &quot;SHA&quot;, &quot;MD5-DES&quot;, &quot;MD5-AES&quot;, &quot;SHA-DES&quot;,</td>
</tr>
<tr>
<td></td>
<td>or &quot;SHA-AES&quot;.</td>
</tr>
<tr>
<td>client.maxAuthenticationPoolSize</td>
<td>Maximum number of Client Switch Authentication</td>
</tr>
<tr>
<td></td>
<td>thread pool.</td>
</tr>
<tr>
<td></td>
<td>Default to 15.</td>
</tr>
</tbody>
</table>

### GENERAL > DATA SOURCES

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VMware</td>
<td>Enable VMware Discovery.</td>
</tr>
<tr>
<td>VMware in demo mode.</td>
<td>VMware in demo mode.</td>
</tr>
<tr>
<td>Specify the default virtual</td>
<td>Specify the default virtual center polling</td>
</tr>
<tr>
<td>center polling interval in</td>
<td>interval in seconds.</td>
</tr>
<tr>
<td>seconds.</td>
<td>Default to 1 hour.</td>
</tr>
<tr>
<td>Specify the maximum number of</td>
<td>Specify the maximum number of virtual centers</td>
</tr>
<tr>
<td>virtual centers the FM server</td>
<td>Specify the maximum number of virtual centers</td>
</tr>
<tr>
<td>can manage.</td>
<td>the FM server can manage.</td>
</tr>
<tr>
<td>This will vary by virtual</td>
<td>This will vary by virtual center size and host</td>
</tr>
<tr>
<td>center size and host machine</td>
<td>This will vary by virtual center size and host</td>
</tr>
<tr>
<td>computing resource including</td>
<td>machine computing resource including CPU and</td>
</tr>
<tr>
<td>CPU and memory.</td>
<td>memory.</td>
</tr>
</tbody>
</table>

### VMware

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>virtual.pollinterval</td>
<td>Specify the default virtual center polling</td>
</tr>
<tr>
<td></td>
<td>interval in seconds.</td>
</tr>
<tr>
<td></td>
<td>Default to 1 hour.</td>
</tr>
<tr>
<td></td>
<td>minimum allowed is 300 seconds.</td>
</tr>
<tr>
<td>virtual.maxopen</td>
<td>Specify the maximum number of virtual centers</td>
</tr>
<tr>
<td></td>
<td>the FM server can manage.</td>
</tr>
<tr>
<td></td>
<td>This will vary by virtual center size and host</td>
</tr>
<tr>
<td></td>
<td>machine computing resource including CPU and</td>
</tr>
<tr>
<td></td>
<td>memory.</td>
</tr>
</tbody>
</table>
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vi.maxConcurrentDiscovery</td>
<td>Specify the maximum number of virtual centers the FM server can poll/rediscover concurrently: This will vary by the memory and CPU power on your server machine. Default to 3.</td>
</tr>
<tr>
<td>vi.ignore.certificate</td>
<td>Ignore VCenter certificate. Default to false--validate the certificate. Set to true to ignore certificate checking, WARNING: this is a security violation.</td>
</tr>
</tbody>
</table>

### GENERAL > DATA SOURCES LAN

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cdp.pollingInterval</td>
<td>Polling interval in seconds. Default is 5mins.</td>
</tr>
<tr>
<td>cdp.timeout</td>
<td>Discovery timeout in seconds. Default is 5mins.</td>
</tr>
<tr>
<td>cdp.discoverLanHosts</td>
<td>CDP shallow scan discover LAN hosts.</td>
</tr>
<tr>
<td>cdp.discoverUcsClusterInfo</td>
<td>Discover UCS cluster info. Default is true.</td>
</tr>
</tbody>
</table>

### GENERAL > DATA SOURCES SMI-S

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>storage.pollinterval</td>
<td>SMI-S Storage Discovery interval in seconds.</td>
</tr>
</tbody>
</table>

### GENERAL > CLIENTS

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>session.maxopen</td>
<td>Maximum number of concurrent clients.</td>
</tr>
</tbody>
</table>

### WEB SECURITY

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>web.enableCSRFGuard</td>
<td>Enable CSRF Guard to secure web server in untrusted environments.</td>
</tr>
<tr>
<td>web.allowDownload4All</td>
<td>Enable non admin users to download client software.</td>
</tr>
</tbody>
</table>

### PERFORMANCE MANAGER > COLLECTIONS

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pmchart.currenttime</td>
<td>Specify the end time for rrd-based charts, used for debugging/demo purposes. Default to left blank to use the current system time. Example: pmchart.currenttime=10/31/2005 11:30:00</td>
</tr>
<tr>
<td>pm.collect.loopdevice</td>
<td>Allow QA environment for scalability testing. Default to false.</td>
</tr>
<tr>
<td>Server Properties</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>pm.collect.error</td>
<td>Allow QA environment to scale PM collection by disabling error and discards collection. This flag is applicable to SAN PM only. Default to false.</td>
</tr>
<tr>
<td>pm.collect.limit</td>
<td>Specify the max number of entities that PM can collect stats. Default to 500000.</td>
</tr>
<tr>
<td>pm.statsUpdate</td>
<td>Default implementation is PmStatsUpdateAdapter. Customerized implementation must implement the following java interface:</td>
</tr>
<tr>
<td></td>
<td>public interface PmStatsUpdate{</td>
</tr>
<tr>
<td></td>
<td>public void updateFPortStats(String ip, String ifName, String deviceName, long millsSec, double tx, double rx);</td>
</tr>
<tr>
<td></td>
<td>public void updateEPortStats(String swip, String ifName, String islName, long millsSec, double tx, double rx);</td>
</tr>
<tr>
<td></td>
<td>}</td>
</tr>
<tr>
<td>web.performance.networkThroughput.de limitingValues</td>
<td>Specify the delimiting values for the network throughput chart. Must have 5 values, values are in MB.</td>
</tr>
<tr>
<td>web.report.nowrap</td>
<td>Specify custom report attribute.</td>
</tr>
<tr>
<td>pm.n3k_buffer_count</td>
<td>Collect buffer count for n3k device.</td>
</tr>
<tr>
<td>pm.n3k.history</td>
<td>Specify how many days to keep the n3k buffer data, default 7 days.</td>
</tr>
<tr>
<td>Server Properties</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>pm.n3k.threshold</td>
<td>Threshold to define which counter to persist to db, format: value--&gt;range</td>
</tr>
<tr>
<td></td>
<td>1: between 1 and 384 KB.</td>
</tr>
<tr>
<td></td>
<td>2: between 385 KB and 768 KB.</td>
</tr>
<tr>
<td></td>
<td>3: between 769 KB and 1152 KB.</td>
</tr>
<tr>
<td></td>
<td>4: between 1153 KB and 1536 KB.</td>
</tr>
<tr>
<td></td>
<td>5: between 1537 and 1920 KB.</td>
</tr>
<tr>
<td></td>
<td>6: between 1921 KB and 2304 KB.</td>
</tr>
<tr>
<td></td>
<td>7: between 2305 KB and 2688 KB.</td>
</tr>
<tr>
<td></td>
<td>8: between 2689 KB and 3072 KB.</td>
</tr>
<tr>
<td></td>
<td>9: between 3073 and 3456 KB.</td>
</tr>
<tr>
<td></td>
<td>10: between 3457 KB and 3840 KB.</td>
</tr>
<tr>
<td></td>
<td>11: between 3841 KB and 4224 KB.</td>
</tr>
<tr>
<td></td>
<td>12: between 4225 KB and 4608 KB.</td>
</tr>
<tr>
<td></td>
<td>13: between 4609 and 4992 KB.</td>
</tr>
<tr>
<td></td>
<td>14: between 4993 KB and 5376 KB.</td>
</tr>
<tr>
<td></td>
<td>15: between 5377 KB and 5760 KB.</td>
</tr>
<tr>
<td></td>
<td>16: between 5761 KB and 6144 KB.</td>
</tr>
<tr>
<td>pm.response.rate.threshold</td>
<td>Specify PM response rate threshold.</td>
</tr>
<tr>
<td></td>
<td>This is a % response rate threshold. PM server will send out event when %</td>
</tr>
<tr>
<td></td>
<td>response rate for SNMP query is less than the specified value</td>
</tr>
<tr>
<td>storage.minrxtx</td>
<td>Minimum RxTx Traffic in Bytes, used to highlight Storage ports not used to</td>
</tr>
<tr>
<td></td>
<td>full capacity.</td>
</tr>
</tbody>
</table>
**Server Properties** | **Description**
--- | ---
health.calculator | Specify the customized class to use to calculate switch health percentage. Example: com.companyname.healthcal
Rules: 1. please make sure the new class implement interface: com.cisco.dcbu.sm.common.rif.HealthCalculator Rif 2. The function to implement is calculate(x, x1, y, y1, z) @param x : Total number of modules @param x1: Total number of modules in warning @param y: Total number of switch ports @param y1: Total number of switch ports in warning @param z: Total number of events with severity of warning or above Default equation: ((x-x1)*1.0/x) *0.4 + ((y-y1)*1.0/y)*0.3 + ((z*1.0/1000>=1) ? 0: ((1000-z)*1.0/1000)*0.3)
health.calculator.weights.modules | Weight given to modules when computing the health score.
health.calculator.weights.ports | Weight given to ports when computing the health score.
health.calculator.weights.events | Weight given to events when computing the health score.
server.datapath | Shared data path location.
enableSmisCapacity | Enable storage system capacity trend beta feature in foresta.
slowdrain.collectAll | Slow drain feature to collect all ports, default is false.

**DATA MIGRATION MEDIATOR (DMM)**
dmm.read.timeout | Specify time out on SSL socket. Default to 60 seconds.
dmm.read.ini.timeout | Specify initial read time on SSL socket for "telnet ssm_card 2038" after ssh connection is established to management card. Default to 5 seconds.
dmm.connect.timeout | Specify ssh connection time out. Default to 6 seconds.
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dmm.connection.retry</td>
<td>Specify ssh connection retry.  Default to true to try twice for job creation.</td>
</tr>
</tbody>
</table>

### Host Redundancy Checking Configuration

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>hostRedundancy.state.enabled.automatic.run</td>
<td>Specify if the automatic checking should be enabled.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.test.storage.found.vcenter</td>
<td>Specify if VCenter discovered data store should be checked against storage found in the zone.  Check will report any data stores not present in the zone discovered storage.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.test.lun.mismatch</td>
<td>Specify if lun discovered data should be checked to see that each path sees the same set of Luns.  Check will report any host to storage pairs that where all ports don’t see the same luns.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.test.nonredundant.switch</td>
<td>Specify if connected switch data should be checked to see that each port of the host and storage don’t connect to the same switch, or in the case of a director switch the same linecard and thus create a single point of failure.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.test.nonredundant.vsan</td>
<td>Specify if connected switch data should be checked to see that each port of the host and storage don’t connect to the same VSAN and thus create a single point of failure.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.test.nonredundant.fabric</td>
<td>Specify if connected switch data should be checked to see that each port of the host and storage don’t connect to the same Fabric and thus create a single point of failure.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.vsan.exclusion.enabled</td>
<td>Specify the if the VSAN exclusion list should be used for host redundancy check.  This is so the restriction can be turned off without losing the list.  Default to false.</td>
</tr>
<tr>
<td>hostRedundancy.vsan.excluded</td>
<td>Specify the VSAN exclusion list for host redundancy.  Format as a vsan range - example: 1-5,34-60,77,90.  Default to empty.</td>
</tr>
</tbody>
</table>

TRACE PATH
<table>
<thead>
<tr>
<th>Server Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tracepath.maxhops</td>
<td>Specify trace path max hop. Default to 7, range: 1 to 7.</td>
</tr>
<tr>
<td>tracepath.maxpaths</td>
<td>Specify trace path max path. Default to 20000, range: 1 to 2000.</td>
</tr>
</tbody>
</table>

**GENERAL>LOGS**

<table>
<thead>
<tr>
<th>tech_support</th>
<th>Specify list of log files to be zipped for tech support.</th>
</tr>
</thead>
<tbody>
<tr>
<td>debug.server</td>
<td>If specified, server opens port for remote telnet debugging. Edit $INSTALLDIR/dcm/fm/conf/log4j_fms.xml to config server log4j properties. Format: &quot;local_addr:local_port&quot;, or &quot;local_port&quot;.</td>
</tr>
<tr>
<td>debug.stacktrace</td>
<td>Log Java Stack traces for debugging.</td>
</tr>
</tbody>
</table>

**GENERAL>STATUS**

| smis.returnDownPort| Allow smis return down port. |

**OTHERS**

| enableSME          | Display the SME Provisioning. |
| trimDomain         | Trim domain part from switches' sysnames, default is true. |
| export.unitless    | Flag to export Unit-less data to Excel, currently it applies to PM traffic data. |
| export.unit        | Choose export unit if export.unitless=false. "B" stands for Byte, "b" stands for Bit. Only "GB", "Gb", "MB", "Mb", "KB", "Kb", "B" and "b" are allowed. |
| web.dashboard.hideLicenseWarning | Hide/show the license warning messages in Summary dashboard page. |

**DATABASE**

| db.driver         | Specify jdbc driver. |
| db.url            | Specify jdbc url. |
| db.user           | Specify database username. |
| db.password       | Specify database password. |
| db.maxactive      | Specify connection pool, max active connection. |
| db.maxidle        | Specify connection pool, max idle connection. |
| db.validation     | Specify connection validation. |

**Note** Please Do Not Modify These Properties.
<table>
<thead>
<tr>
<th>Server Properties</th>
<th>Description</th>
</tr>
</thead>
</table>
| db.validationquery      | Specify validation query for:  
Oracle: db.validationquery=select 1 from dual  
PostgreSQL: db.validationquery=select 1 |
| db.postgres.perfTest   | PostgreSQL performance test interval. If it’s more than the value, prompt the user to do performance tuning on the db.  
Unit is second, default to 20 seconds. |
| GENERAL> xFTP CREDENTIAL |                                                                                                                                             |
| server.FileServerAddress | xFTP server's ip address for copying switch files.                                                                                         |
| server.type             | Server Type. 3 for SFTP, 1 for TFTP.                                                                                                        |
| server.sftp.rootdir     | SFTP Home Directory.                                                                                                                       |
| server.sftp.username    | SFTP Username.                                                                                                                              |
| server.sftp.password    | SFTP Password.                                                                                                                               |
| configFile.Days2Keep    | Backup & Restore Config File Retention, in days.                                                                                             |
| config.JobStatusPerDevice | Number of Backup & Restore job status entries per device to be retained.                                                                     |
| server.sftp.enabled     | Enable SFTP. Defaults to true.                                                                                                              |
| EVENT> REGISTRATION     |                                                                                                                                             |
| events.linkDown.log     | Allow link down traps get logged in the DCNM-SAN client event tab and web client event tab.                                                   |
| events.log.all          | By default, we only persist trap events for port alarm/sfp failure. Set the property to true will persist/forward the other trap events as well, just like the previous versions. |
| syslog.promiscuous      | Allow any SYSLOG client to send SYSLOG messages to DCNM-SAN server.                                                                          |
| syslog.disable          | Allow user to disable syslog.                                                                                                               |
| events.maxRowsDB        | Specify maximum number of events fetched by GUI client from DB.                                                                             |
| events.Days2Keep        | Backup & store events, in days.                                                                                                             |
| events.maxIncoming      | Give a control for the maximum number in queue before dropping the incoming events/traps/syslog.                                           |
| syslog.dblog.enable     | Allow SYSLOG messages to written into database.                                                                                              |
| syslog.dblog.severity   | Specify severity of SYSLOG messages filtering which to be written into database. All the messages with higher severity (less number) will go through the filter.  
0 - emergencies  1 - alerts  2 - critical  3 - errors  
4 - warnings  5 - notifications  6 - informational  7 - debugging |
## Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>syslog.dblog.accounting.severity</td>
<td>Specify severity of SYSLOG ACCOUNTING messages filtering which to be written into database. All the messages with higher severity (less number) will go through the filter. 0 - emergencies    1 - alerts    2 - critical    3 - errors    4 - warnings    5 - notifications    6 - informational    7 - debugging</td>
</tr>
</tbody>
</table>

**EVENT>EMC CALLHOME**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>server.callhome.enable</td>
<td>Allow EMC Call Home. Default to disable.</td>
</tr>
<tr>
<td>server.callhome.location</td>
<td>Specify Lab Location.</td>
</tr>
<tr>
<td>server.callhome.fromEmail</td>
<td>Specify 'From Email' list. The list should be comma separated. Example: <a href="mailto:callhome@cisco.com">callhome@cisco.com</a>.</td>
</tr>
<tr>
<td>server.callhome.recipientEmail</td>
<td>Specify 'recipientEmail' list. The list should be comma separated. Example: <a href="mailto:callhome@cisco.com">callhome@cisco.com</a>.</td>
</tr>
<tr>
<td>server.callhome.smtphost</td>
<td>Specify the SMTP Host address for outbound email. Example: outgoingsmtp.cisco.com.</td>
</tr>
<tr>
<td>server.callhome.xmlDir</td>
<td>Specify the Path to store the XML message files. The path is relative to the installed base. The directory should exist.</td>
</tr>
<tr>
<td>server.callhome.portDownReasons</td>
<td>Specify the port down reasons from IfOperStatusReason to filter linkDowntrap only when delayed traps are not supported or disabled. Default to the following hardware related port down-events.</td>
</tr>
</tbody>
</table>

**EVENT>FORWARDING**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>server.forward.event.enable</td>
<td>Allow Event forwarding. Default to true.</td>
</tr>
<tr>
<td>server.forward.event.community</td>
<td>SNMP community string for generated trap.</td>
</tr>
<tr>
<td>server.forward.event.SNMPV2Cenabled</td>
<td>SNMP V1 and V2c traps are supported, enable for sending out SNMPV2c traps. By default, SNMP V1 trap will be used.</td>
</tr>
<tr>
<td>server.forward.event.useStandardMIB</td>
<td>If this property is enabled, the CISCO-EPM-NOTIFICATION-MIB will be used for forwarding, by default, the original customized MIB format will be used as before.</td>
</tr>
<tr>
<td>server.forward.email.fromAddress</td>
<td>Specify 'From Email' list. If emails are used in custom report, only one address is allowed. The list should be comma separated.</td>
</tr>
<tr>
<td>server.forward.email.mailCC</td>
<td>Specify 'CC Email' list.</td>
</tr>
</tbody>
</table>
### Server Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>server.forward.email.mailBCC</td>
<td>Specify 'BCC Email' list.</td>
</tr>
<tr>
<td>server.forward.email.smtp host</td>
<td>Specify the SMTP Host address for outbound mail. Example: outgoingsmtp.cisco.com.</td>
</tr>
<tr>
<td>server.forward.event.snooze</td>
<td>Snooze for stopping the event forwarding. Default is disabled.</td>
</tr>
<tr>
<td>server.forward.event.start</td>
<td>In the format of Day Mon Date HH:MM:SS TZD YYYY, i.e. &quot;Tue Apr 30 16:51:25 GMT-0700 2013&quot;.</td>
</tr>
<tr>
<td>server.forward.event.end</td>
<td>In the format of Day Mon Date HH:MM:SS TZD YYYY, i.e. &quot;Tue Apr 30 16:51:25 GMT-0700 2013&quot;.</td>
</tr>
</tbody>
</table>

### Dynamic Fabric Automation (DFA)

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dfa.xmpp.presence.timeout</td>
<td>DCNM waits for devices' XMPP Presence stanza, value in seconds. Default value is 5 seconds.</td>
</tr>
</tbody>
</table>

### Simple Analytics Web Service Logging

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>simple.analytics.log.webservices.enable</td>
<td>Enable or disable Web service logging.</td>
</tr>
<tr>
<td>simple.analytics.log.webservices.dbWriteInterval</td>
<td>Interval at which to write to database. (in milliseconds)</td>
</tr>
</tbody>
</table>

### Web properties modified by installer

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>mds.web.https</td>
<td>Enable or disable HTTPS.</td>
</tr>
<tr>
<td>web.port</td>
<td>Specify the port number of web service.</td>
</tr>
<tr>
<td>web.optimizedPath</td>
<td>Specify the full address of web address to redirect to which is the closest to Database server. Example: <a href="http://host1:8080">http://host1:8080</a></td>
</tr>
<tr>
<td>lan.server.bindaddrs</td>
<td>Specify the LAN server address.</td>
</tr>
<tr>
<td>lan.web.port</td>
<td>Specify the web port number of the LAN server.</td>
</tr>
</tbody>
</table>

**Step 3**  
Follow the on-screen instructions and click **Apply** to confirm the changes.

While connecting to some switches if the connection is getting timed out, in the #CLI session channel type, change default the cli.channel.type value from **exec** to **shell**.

**Note**  
After configuring the server properties, you need to restart the DCNM server only if you receive a notification stating that the server must be restarted.

### Configuring SFTP/TFTP Credentials

You can configure the SFTP/TFTP credentials for the File store.

A file server is required to collect device configuration and restoring configurations to the device.
Chapter 1      Cisco DCNM Web Client

Administering Cisco DCNM Web Client

Step 1
From the menu bar, choose Admin > General > SFTP/TFTP Credentials.
You see the SFTP/TFTP credentials page.
SFTP/TFTP Credentials option is disabled for DFA deployment of Open Virtual Appliance and ISO installers.

Step 2
In the Server Type field, use the radio button to select SFTP.

Note
You must have a SFTP server on the DCNM Server to perform backup operation. The SFTP directory must be an absolute Linux/SSH path format and must have read/write access to the SFTP User.

a. Enter the SFTP Username and SFTP Password.
b. Enter the SFTP Directory path.
   The path must be in absolute Linux path format.
c. From the Verification Switch drop-down, select the switch.
d. Click Apply to apply the configuration.
e. Click Verify and Apply to verify and apply the configuration. If there are any failures during the verification, the new changes will not be stored.
f. Click Clear SSH Hosts to clear SSH hosts for all switches or selected switches. If there is a failure in any of the switches, an error message is displayed. Go to Config > Job > Job Status History to view the number of successful and unsuccessful switches.

Step 3
In the Server Type field, use the radio button to select TFTP.
Cisco DCNM uses an internal TFTP server for data transfer. Ensure that there is no external TFTP server running on the DCNM server.

Note
Ensure that your switch user role includes the copy command. Operator roles will receive a ‘permission denied’ error. You can change your credentials from the Admin > DataSources page.

a. From the Verification Switch drop-down, select the switch.
b. Click Apply to apply the configuration.
c. Click Verify and Apply to verify and apply the configuration. If there are any failures during the verification, the new changes will not be stored.

Step 4
From the menu bar, choose Config > Jobs > Job Status History to view individual device verification status.
The configurations that are backed up are removed from the file server and are stored in the database.

Managing Switch Groups

Beginning with Cisco NX-OS Release 6.x, you can configure switch groups by using Cisco DCNM Web Client. You can add, delete, rename or move a switch to a group or move a group of switches to another group.
This section contains the following:
Adding Switch Groups

You can add a switch group from the Cisco DCNM Web Client.

**Step 1**
From the menu bar, choose **Admin > General > Switch Groups**.

**Step 2**
Click the **Add Group** icon or press the Insert key on your keyboard.

**Note**
A field appears that allows you to enter the name for the switch group. The Insert key does not work unless you highlight the group table first.

**Step 3**
Enter the name of the switch group and click outside the text field or press the Return key to complete adding the switch group. Press the Esc key on your keyboard to discard the text input and exit.

The switch group name validation and the maximum tree depth is 10. If you do not choose a parent group before adding a new switch group, the new group is added on the top of the hierarchy.

Renaming a Group

You can rename a switch group from the Cisco DCNM Web Client.

**Step 1**
Double-click on the switch group name that you want to rename.

**Step 2**
Enter a new name to rename the group.

**Note**
The name of the group cannot contain any of these special characters: ()<>;::\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"\"

**Step 3**
Press the **Return** key to apply changes or press the Esc key on your keyboard to discard the modification.

Deleting a Group or a Member of a Group

You can delete group(s) and/or member(s) of a group from the Cisco DCNM Web Client. When you delete a group, the associated group(s) are deleted and the fabrics or Ethernet switches of the deleted group(s) are moved back to the default SAN or LAN.

**Step 1**
Choose the switch group or member(s) of a group that you want to remove.

**Step 2**
Click the **Remove** icon or press the Delete key on your keyboard.

A dialog box prompts you to confirm the deletion of the switch group or the member of the group. Click **Yes** to delete or **No** to cancel the action.
Moving a Switch to Another Group

- **Step 1** Use the checkbox to choose a switch from the group.
- **Step 2** Select the **Move the selected Switch/Fabric to Group** icon. The Move LAN Member dialog box appears.
- **Step 3** Select the switch group from the list and click **Apply**.

Moving a Switch Group to Another Group

- **Step 1** Use the checkbox to choose a switch group.
- **Step 2** Click **Move Switch/Fabric to selected Group** icon. The Move LAN Member Group dialog box appears.
- **Step 3** Select the switch group from the list and click **Apply**.

Managing Custom Port Groups

Custom Port groups aids you to test the performance of the interfaces in the group. You can view the defined custom ports and their configurations from **Admin > Custom Port Groups** on the Cisco DCNM Web Client.

This section includes the following topics:

- Adding Custom Port Groups section, page 1-97
- Configuring Switch and Interface to the Port Group section, page 1-97
- Generating Reports for the Custom Port Groups section, page 1-98
- Removing Port Group Member section, page 1-98
- Removing Port Group section, page 1-98

Adding Custom Port Groups

You can add a custom port group from the Cisco DCNM Web Client.

- **Step 1** From the menu bar, choose **Admin > Custom Port Groups**.
- **Step 2** In the Defined Groups block, click the **Add Group** icon.
- **Step 3** Enter the name for the custom port group in the Add Group Dialog.

A custom port group is created in the Defined Groups block.

Configuring Switch and Interface to the Port Group

You can configure the custom port group to include switches and their interfaces.

- **Step 1** From the menu bar, choose **Admin > Custom Port Groups**.
- **Step 2** In the Defined Groups block, select the port group for which you need to add the switch and interfaces.
Step 3  In the Configuration block, click the Add Group Member icon.
The Port Configuration window appears for the selected Custom Port Group.
Step 4  In the Switches tab, select the switch that you need to include in custom port group.
The list of available Interfaces appears.
Step 5  Select all the interfaces for which you need to check the performance.
Step 6  Click Submit.
The list of interfaces is added to the custom port group.

Generating Reports for the Custom Port Groups

You can generate the reports to monitor the performance of the interfaces in the custom port group.

Step 1  From the menu bar, choose Reports > Generate.
Step 2  From the Scope dropdownlist, select the port group for which you need to generate the performance report.
Step 3  Generate the Performance report. For information about how to Generate Reports, see Generating a Report.
Step 4  Verify if the report is generated for all the interfaces that were added in the custom port group.

Removing Port Group Member

You can remove or delete the port group member from the Custom Port group.

Step 1  From the menu bar, choose Admin > Custom Port Groups.
Step 2  In the Defined Groups block, select the port group for which you need to add the switch and interfaces.
Step 3  In the Configuration block, select the switch name and interface that must be deleted.
Step 4  In the Defined Groups block, select the group for which you which must be deleted. Click Remove Group Member icon.
   A confirmation window appears.
Step 5  Click Yes to delete the member from the custom port group.

Removing Port Group

You can remove or delete the port group from the Cisco DCNM Web Client.

Step 1  From the menu bar, choose Admin > Custom Port Groups.
Step 2  In the Defined Groups block, select the group which must be deleted. Click Remove Group icon.
   A confirmation window appears.
Step 3  Click Yes to delete the custom group.
Managing Licenses

This section includes the following topics:

- Viewing Licenses Using the Cisco DCNM Wizard section, page 1-99
- Automatic License Assignment section, page 1-101
- Adding Cisco DCNM Licenses section, page 1-101
- Assigning Licenses section, page 1-101
- Unassigning Licenses to a Switch section, page 1-102

Viewing Licenses Using the Cisco DCNM Wizard

You can view the existing Cisco DCNM licenses by DETAILED STEPS selecting Admin > License to start the license wizard.

Figure 1-2 displays the license information.

![Cisco DCNM Licenses](image)

**Note** By default, the Switch Licenses tab appears.
Table 1-6 displays the Cisco DCNM server license fields.

**Table 1-6 Cisco DCNM Server License Fields**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>Name of the license file.</td>
</tr>
</tbody>
</table>
| Feature     | Describes the feature name specified in the license file. The following values are supported:  
  - DCNM-LAN  
  - DCNM-SAN  
  - DCNM-SAN-LAN  
  - LAN-ENT-N7K |
| PID         | Describes the product ID found in the vendor string of the license file. For example, DCNM-N7K-K0 is an enterprise license for Cisco Nexus 7000 series switches. |
| SAN (Free or Total) | Lists the number of SAN licenses used and available.          |
| LAN (Free or Total) | Lists the number of LAN licenses used and available.          |
| Eval Expiration | Displays the expiry date of the license.                               |

**Note**
Text in the eval expiration field will be in red for licenses that expire in seven days.

Table 1-7 displays the Cisco DCNM switch license fields.

**Table 1-7 Cisco DCNM Switch Licenses**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group</td>
<td>Displays if it is a fabric or LAN group.</td>
</tr>
<tr>
<td>Switch Name</td>
<td>Displays the name of the switch.</td>
</tr>
<tr>
<td>Model</td>
<td>Displays the model of the device. For example, DS-C9124 or N5K-C5020P-BF.</td>
</tr>
</tbody>
</table>
| License State | Displays the license state of the switch that can be one of the following:  
  - Permanent  
  - Eval  
  - Unlicensed  
  - Not Applicable  
  - Expired  
  - Invalid |
Automatic License Assignment

When the Fabric is first discovered if the switch does not have a valid switch-based license, a license is automatically assigned to the Fabric from the file license pool until no more licenses are left in the pool. Also, if you have an existing Fabric and a new switch is added to the Fabric, the new switch will be assigned a license if one is available in the file license pool and if it does not already have a switch-based license.

Adding Cisco DCNM Licenses

You must have network administrator privileges to complete the following procedure.

**Step 1** Choose Admin > License to start the license wizard.

**Step 2** Choose the Server License Files tab. The valid Cisco DCNM-LAN and DCNM-SAN license files appear.

Ensure that the security agent is disabled when you load licenses.

**Step 3** Download the license pack file that you received from Cisco into a directory on the local system.

**Step 4** Click Add License File and then select the license pack file that you saved on the local machine. The file will be uploaded to the server machine, saved into the server license directory and then loaded on to the server.

**Note** Ensure that you do not edit the contents of the .lic file or the Cisco DCNM software ignores any features that are associated with that license file. The contents of the file are signed and must remain intact. When you accidentally copy, rename, or insert the license file multiple times, the duplicate files are ignored, but the original will be counted.

Assigning Licenses

**BEFORE YOU BEGIN**

You must have network administrator privileges to complete the following procedure.

**Step 1** Choose Admin > License to start the license wizard.

You see the licenses table.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Type</td>
<td>Displays if the license is a switch-based embedded license or a server-based license.</td>
</tr>
<tr>
<td>Eval Expiration</td>
<td>Displays the expiry date of the license.</td>
</tr>
</tbody>
</table>

**Note** Text in the eval expiration field will be in Red for licenses that expires in seven days.
Step 2  From the table, choose the switch that you want to assign the license to.

Step 3  Click Assign License.

**Unassigning Licenses to a Switch**

**BEFORE YOU BEGIN**

You must have network administrator privileges to complete the following procedure.

**DETAILED STEPS**

**Step 1**  Choose Admin > License to start the license wizard. You see the licenses table.

**Step 2**  From the table, choose the switch that you want to unassign the license.

**Step 3**  Click Unassign License.

**Viewing Server Federation**

**Step 1**  From the menu bar, choose Admin > General > Federation. The list of Servers along with its Status, Local Time and Data Sources are displayed.

**Step 2**  Use the Enable Automatic Failover checkbox to turn on/off the failover functionality.

**Step 3**  In the Location column, double-click to edit the location.

---

**Note**  If the status of one of the servers in the federation is Inactive, then some functionality may not work unless the server status changes to Active in the federation.

---

**Note**  Before upgrading Cisco DCNM, ensure that Enable Automatic Failover is unchecked. Otherwise, if one server within the federation is down, the devices discovered by the server will be moved to the other DCNM server which comes up first after upgrade. To prevent the auto move for DCNM upgrade, you need to disable the auto move on all DCNMs within the federation, and then upgrade the DCNM server one by one. Only after all the DCNMs upgrade successfully and run normally, then enable the auto move again.

To enable / disable Auto Move, please go to Admin > Federation from DCNM web page, click on the checkbox at top left for Enable Automatic Failover.

**Configuring AAA Properties**

To configure AAA properties,

**Step 1**  From the menu bar, choose Admin > Management Users > Remote AAA Properties. The AAA properties configuration page appears.

**Step 2**  Use the radio button to select one of the following Authentication Modes:
Administering Cisco DCNM Web Client

- **Local** - In this mode the authentication will authenticate with the local server.
- **Radius** - In this mode the authentication will authenticate against the Radius servers specified.
- **TACACS+** - In this mode the authentication will authenticate against the TACAS servers specified.
- **Switch** - In this mode the authentication will authenticate against the switches specified.
- **LDAP** - In this mode the authentication will authenticate against the LDAP server specified.

### Local

**Step 1**
Use the radio button and select **Local** as the authentication mode.

**Step 2**
Click **Apply** to confirm the authentication mode.

### Radius

**Step 1**
Use the radio button and select **Radius** as the authentication mode.

**Step 2**
Specify the Primary server details and click **Test** to test the server.

**Step 3**
(Optional) Specify the Secondary and Tertiary server details and click **Test** to test the server.

**Step 4**
Click **Apply** to confirm the authentication mode.

### TACACS+

**Step 1**
Use the radio button and select **TACACS+** as the authentication mode.

**Step 2**
Specify the Primary server details and click **Test** to test the server.

**Step 3**
(Optional) Specify the Secondary and Tertiary server details and click **Test** to test the server.

**Step 4**
Click **Apply** to confirm the authentication mode.

### Switch

**Step 1**
Use the radio button to select **Switch** as the authentication mode.

**Step 2**
Specify the Primary Switch name and click **Apply** to confirm the authentication mode.

**Step 3**
(Optional) Specify the Secondary and Tertiary Switch name and click **Apply** to confirm the authentication mode.

### LDAP

**Step 1**
Use the radio button and select **LDAP** as the authentication mode.

**Step 2**
In the Host field, enter DNS address of the host.

**Step 3**
Click **Test** to test the AAA server.

**Step 4**
Enter a valid Username and Password.
A dialog box appears confirming the status of the AAA server test. If the test has failed, the LDAP Authentication Failed dialog box appears.

Step 5 In the Port field, enter a port number.

Step 6 (Optional) Select the **SSL Enabled** check box, if SSL is enabled on the AAA server.

Step 7 In the Base DN field, enter the base domain name.

Step 8 In the Filter field, specify the filter parameters.

Step 9 Choose an option to determine a role by either **Attribute** or **Admin Group Map**.

Step 10 In the Role Admin Group field, enter the name of the role.

Step 11 In the Map to DCNM Role field, enter the name of the role to be mapped.

Step 12 Click **Apply** to apply the LDAP configuration.

### Adding and Removing Users

You can use Cisco DCNM Web Client to add and remove Web Client users.

This section contains the following:

- Adding Local Users section, page 1-104
- Editing a User section, page 1-105
- Removing a User section, page 1-105

### Adding Local Users

Step 1 From the menu bar, choose **Admin > Management Users > Local**.

You see the Local Database page.

Step 2 Click **Add**.

You see the Add User dialog box.

Step 3 Enter the username in the Username field.

**Note** The username guest is a reserved name (case insensitive). The guest user can only view reports. The guest user cannot change the guest password, or access the Admin options in DCNM Web Client.

Step 4 From the Role drop-down list, select a role for the user.

Step 5 In the Password field, enter the password.

Step 6 In the Confirm Password field, enter the password again.

Step 7 Click **Add** to add the user to the database.

Step 8 Repeat Steps 2 through 7 to continue adding users.
**Editing a User**

**Step 1** From the menu bar, choose **Admin > Management Users > Local**.

**Step 2** Use the checkbox to select a user and click the **Edit Local User** icon.

**Step 3** In the Edit Local User window, the User Name and Role is mentioned by default. Specify the Password and Confirm Password.

**Step 4** Click **Apply** to save the changes.

**Removing a User**

**Step 1** From the menu bar, choose **Admin > Management Users > Local**.

**Step 2** Select the check box next to the user(s) you want to remove and click **Remove**.

**Managing Clients**

You can use the DCNM Web Client to disconnect DCNM Client Servers.

**Step 1** From the menu bar, click **Admin>Clients**.

A list of DCNM Servers are displayed.

**Step 2** Use the check box to select a DCNM server and click **Disconnect Client** icon to disconnect the DCNM server.

**Note** You cannot disconnect a current client session.

**Performance Manager Collections**

If you are managing your switches with the Performance Manager, you must set up an initial set of flows and collections on the switch. You can use Cisco DCNM Web Client to add and remove performance collections. The switch has to be licensed and in the Managed Continuously state before a collection for the switch can be created.

To add a collection follow these steps:

**Step 1** From the menu bar, click **Admin>Collections**.

**Step 2** Under Generate a threshold event when traffic exceeds % of capacity, use the checkbox to specify the **Critical at** and **Warning at** values. User can also use the **For ISL/Trunk Only** checkbox to limit the threshold events generated to ISL and Trunk events only and then click **Apply**.

**Step 3** In the Licensed Fabrics panel, use the checkboxes to select the Fabric, ISLs/NPV Links, Hosts, Storage, FC Flows and FC Ethernet to enable performance collection for these data types.

**Step 4** In the Licensed LAN Switches panel, use the checkboxes to enable performance data collection for **Trunks, Access** and **Errors & Discards**.

**Step 5** Use the checkboxes to select the type(s) of LAN switches for which you want to collect performance data.
Step 6  Click **Apply** to save the configuration.

Step 7  In the confirmation dialog box, click **Yes** to restart the performance collector.

**Configuring the RRD Database**

Configuring the Round Robin Database (RRD) allows you to set the intervals at which data samples are collected. After applying the configuration, the database storage format is converted to a new format at those intervals. Because database formats are incompatible with each other, you must copy the old data (before the conversion) to the $INSTALLDIR/pm directory. See the "Importing the RRD Statistics Index section, page 1-106" topic.

Step 1  From the menu bar, choose **Admin > Performance > Databases**.

You see the Performance Database (collection interval) page.

Step 2  In the top row of the Days column, enter the number of days to collect samples at 5-minute intervals.

Step 3  In the second row of the Days column, enter the number of days to collect samples at 30-minute intervals.

Step 4  In the third row of the Days column, enter the number of days to collect samples at 2-hour intervals.

Step 5  In the bottom row of the Days column, enter the number of days to collect samples at 1-day intervals.

As of Cisco SAN-OS Release 3.1(1) and later releases, you can configure the sampling interval for ISLs. Select a sampling interval from the ISLs drop-down list.

Step 6  Click **Apply** to apply your changes, or click **Defaults** to reset the file sizes to the default values.

If you are applying new values, or if the current values are not the default values, you see a message indicating that the conversion of the RRD files take a certain amount of time and that the database is unavailable until then. The time it takes depends on the difference between the old and new values.

Note  The system allows you to convert data, one process at a time. When you start converting the data, the Apply and Default buttons change to Refresh and Cancel so that another process cannot be inadvertently started. The display is the same for all browsers that access the server during this time. Click Refresh to view the latest progress. Click Cancel to cancel the process of converting the data. If the job is successfully canceled, you see the Apply and Default buttons again. If the cancel job is not successful, you see a message indicating that the cancellation has failed.

If you want to perform this procedure, perform it before collecting a lot of data because data conversion can take a long time.

**Importing the RRD Statistics Index**

Step 1  Stop Cisco DCNM-SAN Server.

Step 2  Copy the original RRD file into $INSTALLDIR/pm/db.

Step 3  Run $INSTALLDIR/bin/pm.bat.

Step 4  Restart Cisco DCNM-SAN and add the fabric.
Configuring Other Statistics

Step 1  From the menu bar, choose **Admin > Performance > Others**.
You see the Others page.

Step 2  Click **Add**.
You see the Add SNMP Statistic dialog box.

Step 3  From the Switch table, select the switch for which you want to add other statistics.

Step 4  From the SNMP OID drop-down list, select the OID.

**Note**

For SNMP OID ModuleX_Temp.IFHCInOctets.IFINDEX, IFHCOutOctets.IFINDEX, selected from drop down box, you must replace 'X' with correct module number or the corresponding IFINDEX.

Step 5  In the Display Name box, enter a new name.

Step 6  From the Type drop-down list, select the type.

Step 7  Click **Add** to add this statistic.

Viewing Events Registration

To enable Send Syslog, Send Traps and Delayed Traps you need to configure the following in the DCNM-SAN client:

- Enabling Send Syslog - Log into the DCNM-SAN client. In the Physical Attributes pane, Select **Events>Syslog>Servers**. Click the Create Row icon, provide the required details and click **Create**.

- Enabling Send Traps - Log into the DCNM-SAN client. In the Physical Attributes pane, Select **Events>SNMP Traps>Destination**. Click the Create Row icon, provide the required details and click **Create**.

- Enabling Delayed Traps - Log into the DCNM-SAN client. In the Physical Attributes pane, Select **Events>SNMP Traps>Delayed Traps**. In the Feature Enable column, use the checkboxes to enable delayed traps for the switch and specify the delay in minutes.

Step 1  From the menu bar, choose **Admin > Events > Registration**.
The SNMP and Syslog receivers along with the statistics information are displayed.

Step 2  Select **Enable Syslog Receiver** checkbox and click **Apply** to enable the syslog receiver if it is disabled in the server property.
To configure the Event Registration/Syslog properties, select **Admin>Server Properties** and follow the on-screen instructions.

Step 3  Select **Copy Syslog Messages to DB** and click **Apply** to copy the syslog messages to the database. If this option is not select, the events will not be displayed in the events page of the Web client.

Step 4  The columns in the second table displays the following:
- Switches sending traps
- Switches sending syslog
- Switches sending syslog accounting
Adding Notification Forwarding

This section contains the following:

- Adding Notification Forwarding section, page 1-108
- Removing Notification Forwarding section, page 1-109

Adding Notification Forwarding

You can use Cisco DCNM Web Client to add and remove notification forwarding for system messages. Cisco DCNM Web Client forwards fabric events through e-mail or SNMPv1 traps.

Note

Test forwarding will only work for the licensed fabrics.

---

Step 1 From the menu bar, choose Admin > Events > Forwarding.
Step 2 The events forwarding scope, the recipient email address, severity of the event and type of the event is displayed. The description Regex field is applicable only when the forwarding source is selected as Syslog while adding the events forwarder.
Step 3 Select the Enable checkbox to enable events forwarding.
Step 4 Specify the SMTP Server details and the From e-mail address. Click Apply to save the configuration or in the Apply and Test icon, use the drop-down to select the fabric and click Apply and Test to save and test the configuration.
Step 5 Select the Snooze checkbox and specify the Start date and time and the End date and time. Click Apply to save the configuration.
Step 6 Click the Add Forwarder icon.
You see the Add Notification dialog box.
Step 7 In the Forwarding Method, choose either E-Mail or Trap. If you choose Trap, a Port field is added to the dialog box.
Step 8 In the Address field, enter the IP address.
Step 9 From the Scope drop-down list, choose the fabric or LAN group for notification.
Step 10 In the Source field select DCNM or Syslog.
If you select DCNM, then:

Step 1 In the VSAN Scope, choose either All or List.
Step 2 From the Type drop-down list, choose an event type.
Step 3 Check the Storage Ports Only check box to select only the storage ports.
Step 4 From the Minimum Severity drop-down list, select the severity level of the messages to receive.
Step 5 Click Add to add the notification.
If you select Syslog, then:
### Event Suppression

Cisco Prime DCNM allows you to suppress the specified events based on the user-specified suppressor rules. Such events will not be displayed on the Cisco Prime DCNM Web Client and SAN Client. The events will neither be persisted to DCNM database, nor forwarded via email/SNMP trap.

**Step 1** In the **Facility** list, select the syslog facility.

**Step 2** Specify the syslog **Type**.

**Step 3** In the **Description Regex** field, specify a description that needs to be matched with the event description.

**Step 4** From the **Minimum Severity** drop-down list, select the severity level of the messages to receive.

**Step 5** Click **Add** to add the notification.

**Note** The minimum Severity option is available only if the Event Type is set to All.

The traps sent by Cisco DCNM correspond to the severity type followed by a text description:

```
trap type(s) = 40990 (emergency) 40991 (alert) 40992 (critical) 40993 (error) 40994 (warning) 40995 (notice) 40996 (info) 40997 (debug)textDescriptionOid = 1, 3, 6, 1, 4, 1, 9, 9, 40999, 1, 1, 3, 0
```

### Removing Notification Forwarding

You can remove notification forwarding.

**Step 1** From the menu bar, choose **Admin > Events > Forwarding**.

**Step 2** Select the check box in front of the notification that you want to remove and click **Remove**.

### Configuring EMC CallHome

Cisco DCNM Release 7.1.x DCNM enhances EMC call home messages. DCNM version information is displayed in with the call home message.

You can configure EMC Callhome from the Cisco DCNM Web Client for EMC supported SAN switches.

**DETAILED STEPS**

**Step 1** From the menu bar, choose **Admin > Events > EMC CallHome**.

**Step 2** Select the **Enable** check box to enable this feature.

**Step 3** Use the check box to select the fabrics.

**Step 4** Enter the general e-mail information.

**Step 5** Click the **Apply** to update the e-mail options.

**Step 6** Click **Apply and Test** to update the e-mail options and test the results.
You can view, add, modify and delete suppressor rules from the table. You can create a suppressor rule from the existing event table. Select a given event as the template, and invoke the rule dialog window. Event details are automatically ported from the selected event in the event table to the input fields of the rule creation dialog window.

This section includes the following:

- Add Event Suppression Rules
- Delete Event Suppression Rule
- Modify Event Suppression Rule

## Add Event Suppression Rules

To add rules to the Event Suppression, do the following tasks:

<table>
<thead>
<tr>
<th>Step</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From the menu bar, select <strong>Admin &gt; Event Suppression</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>In the Add Event Suppressor Rule window, specify the Name for the rule.</td>
</tr>
</tbody>
</table>
| Step 3 | Select the required **Scope** for the rule based on the event source.  
You can choose SAN, LAN, Port Groups or Any. For SAN and LAN, select the scope of the event at the Fabric or Group or Switch level. User can only select group(s) for Port Group scope. If user selects “Any” as the scope, the suppressor rule will be applied globally. |
| Step 4 | Enter the **Facility** name or choose from the **SAN/LAN Switch Event Facility List**.  
If you do not specify a facility, wild card will be applied. |
| Step 5 | From the drop down list, select the Event **Type**.  
If you do not specify the event type, wild card will be applied. |
| Step 6 | In the **Description Matching** field, specify a matching string or regular expression.  
The rule matching engine uses regular expression supported by Java Pattern class to find a match against an event description text. |
| Step 7 | (Optional) Check the **Active Between** box and select a valid time range during which the event will be suppressed.  
By default, the time range is not enabled, i.e., the rule will be always active. |

**Note**

In general, user should not suppress accounting events. Suppressor rule for Accounting events might be created only for certain rare situations where Accounting events are generated by actions of DCNM or switch software. For example, lots of ‘sync-snmp-password’ AAA syslog events are automatically generated during password synchronization between DCNM and managed switches. To suppress Accounting events, user can browse web client to Suppressor table and invoke **Add Event Suppressor Rule** dialog window.

**Note**

You can go to **Health > Events** table of Web Client to create a suppressor rule for a known event. While there is no such shortcut to create suppressor rules for Accounting events.
Delete Event Suppression Rule

To delete event suppressor rules, do the following tasks:

**Step 1**  
From the menu bar, select **Admin > Event Suppression**.

**Step 2**  
Select the rule from the list and click **Delete** icon.

**Step 3**  
Click **Yes** to confirm.

Modify Event Suppression Rule

To modify the event suppressor rules, do the following tasks:

**Step 1**  
From the menu bar, select **Admin > Event Suppression**.

**Step 2**  
Select the rule from the list and click **Edit** icon.

You can edit the **Facility**, **Type**, **Description Matching** string, and the **Valid time range**.

**Step 3**  
Click **Apply** to save the changes.

Using Cisco DCNM Web Client with SSL

By default, Cisco DCNM Web Client uses HTTP. If you want to install SSL certificates and use Cisco DCNM Web Client over HTTPS (using TCP port 443 or another custom port), you need a certificate for each external IP address that accepts secure connections. You can purchase these certificates from a well-known Certificate Authority (CA).

To enable SSL, you must set up the keystore to use either a self-signed certificate or a certificate from a trusted third-party company such as VeriSign.

This section includes the following topics:

- Using a self signed SSL Certificate section, page 1-111
- Using a SSL Certificate when certificate request is generated using OpenSSL section, page 1-112
- Using a SSL Certificate when certificate request is generated using Keytool section, page 1-113
- SSL for Federated (High Availability) setup section, page 1-113

Using a self signed SSL Certificate

**Step 1**  
From command prompt, navigate to `<DCNM install root>/dcm/java/jre1.7/bin/`.

**Step 2**  
Rename keystore located at

```
<DCNM_install_root>dcm\jboss-as-7.2.0.Final\standalone\configuration\fmserver.jks
```

to
Using Cisco DCNM Web Client with SSL

Chapter 1  Cisco DCNM Web Client

Step 3 Generate a self signed certificate using following command

```shell
dcm\jboss-as-7.2.0.Final\standalone\configuration\fmserver.jks
```

Step 4 Stop the DCNM services.

Step 5 Restart the DCNM Services.

Using a SSL Certificate when certificate request is generated using OpenSSL

Step 1 From command prompt, navigate to `<DCNM install root>/dcm/java/jre1.7/bin/`

Step 2 Rename keystore located at

```shell
<DCNM_install_root>/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks
```

to

```shell
<DCNM_install_root>/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks.old
```

Step 3 Generate the RSA private key using openssl

```shell
openssl genrsa -out dcnm.key 2048
```

Step 4 Generate a certificate request using following command:

```shell
openssl req -new -key dcnm.key -out dcnm.csr
```

Step 5 Submit the CSR to certificate signing authority to digitally sign it. CA provides the certificate and signing certificate in as certificate chain in PKCS 7 format (.p7b file) or PEM (.pem) file. If CA provided PKCS 7 format go to Step 6 to convert it to PEM format. If CA provided PEM format then go to Step 7.

Step 6 Convert the PKCS 7 certificate chain to X509 certificate chain

```shell
openssl pkcs7 -print_certs -in cert-chain.p7b -out cert-chain.pem
```

Step 7 Convert the X509 certificate chain and private key to PKCS 12 format

```shell
openssl pkcs12 -export -in cert-chain.pem -inkey dcnm.key -out dcnm.p12 -password fmserver_1_2_3 -name sme
```

Step 8 Import the intermediate certificate first, the root certificate, and finally the signed certificate by using the command:

```shell
keytool -importkeystore -srckeystore dcnm.p12 -srcstoretype PKCS12 -srcstoretype JKS
```

Step 9 Stop the DCNM services.
Step 10 Restart the DCNM Services.

Using a SSL Certificate when certificate request is generated using Keytool

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From command prompt, navigate to <code>&lt;DCNM install root&gt;/dcm/java/jre1.7/bin/</code>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Rename keystore located at <code>&lt;DCNM_install_root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks</code> to <code>&lt;DCNM_install_root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks.old</code></td>
</tr>
<tr>
<td>Step 3</td>
<td>Generate the public-private key pair in DCNM keystore using <code>keytool -genkeypair -alias sme -keyalg RSA -keystore &quot;&lt;DCNM_install_root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks&quot; -storepass fmserver_1_2_3 -storepass fmserver_1_2_3</code></td>
</tr>
<tr>
<td>Step 4</td>
<td>Generate the certificate-signing request (CSR) from the public key generated in Step 1. Using <code>keytool -certreq -alias sme -file dcnm.csr -keystore &quot;&lt;DCNM install root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks&quot; -storepass fmserver_1_2_3</code></td>
</tr>
<tr>
<td>Step 5</td>
<td>Submit the CSR to certificate signing authority to digitally sign it. CA provides the certificate and signing certificate in as certificate chain in PKCS 7 format (.p7b file) or PEM (.pem) file. If CA provided PKCS 7 format go to Step 6 to convert it to PEM format. If CA provided PEM format then go to Step 7.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Convert the PKCS 7 certificate chain to X509 certificate chain using openssl <code>openssl pkcs7 -print_certs -in cert-chain.p7b -out cert-chain.pem</code></td>
</tr>
<tr>
<td>Step 7</td>
<td>Import the intermediate certificate first, then the root certificate, and finally the signed certificate by following these steps: Using <code>keytool -importcert -trustcacerts -file cert-chain.pem -keystore &lt;DCNM_install_root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration/fmserver.jks -storepass fmserver_1_2_3 -alias sme</code></td>
</tr>
<tr>
<td>Step 8</td>
<td>Stop the DCNM services.</td>
</tr>
<tr>
<td>Step 9</td>
<td>Restart the DCNM Services.</td>
</tr>
</tbody>
</table>

SSL for Federated (High Availability) setup

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Generate the SSL certificate for primary node and import all the certificates at the appropriate location as mentioned above.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Copy the <code>fmserver.jks</code> from the primary node located at <code>&lt;DCNM_install_root&gt;/dcm/jboss-as-7.2.0.Final/standalone/configuration</code>.</td>
</tr>
</tbody>
</table>
Fabric—General Settings

Note
These features appear on your Cisco DCNM Web Client application only if you have deployed the DCNM installer in the Unified Fabric mode.

You can specify the general settings for the Fabric.

Step 1  From the menu bar, select Admin > Fabric > General Settings.
Step 2  Specify the Fabric settings based on the required configuration and click Apply.
Step 3  Click Yes to save the configuration.
Step 4  Click Health to view status of the Fabric components.

You can also configure the following settings for the Fabric.

- Border Leaf Settings
- Border Leaf Device Pairing
- Border Leaf Extended Partitions
- POAP Settings
- L2 Segment ID Range Management
- Mobility Domains

Border Leaf Settings

Border Leaf Settings allows you to globally enable Border Leaf/Edge Router auto-configuration, and specify its settings such as load balancing algorithm and redundancy factor.

By default, the Border Leaf/Edge Router auto configuration is disabled.

From the menu bar, select Admin > Border Leaf Settings.

- Configuring Border Leaf Settings
- Creating an Edge Router
- Connect New Border leaf to the Edge Router
- Deleting Edge Router/Border leaf devices
Configuring Border Leaf Settings

Step 1  Check the **Enable Border Leaf/Edge Router Auto-configuration** to globally enable Border Leaf/Edge Router auto-configuration.

Step 2  Specify the autonomous system (AS) number to compose the Route Target using the BGP protocol. This AS number is the same across the fabric.

**Note**  If you do not specify AS number, DCNM will be disabled.

Step 3  From the **Load Balancing Algorithm** list, select the algorithm that must be used by DCNM to determine whether to choose border leaf based on the least load, fair share, round robin, resource consumption, speed or other criteria.

**Note**  In Cisco DCNM Release 7.1 (1), only Round Robin algorithm is supported.

If your setup has vPC pair of border leaf, the vPC pair is chosen with priority over Round Robin. If a switch that is part of vPC pair is selected for partition (VRF) extension, DCNM will also select the vPC pair for the same partition (VRF) extension for load balancing.

Step 4  Specify the **Redundancy Factor** to ensure VRFs is extended on the specified number sets of border leaf switch.

**Note**  The selected number of Border Leaf/Edge Router pairs for partition (VRF) extension also depends on the Border Leaf/Edge Router pairing topology. Therefore the number of pairs is equal to or greater than the specified redundancy factor.

Border Leaf Device Pairing

This feature allows you to pair Border Leaf with the Edge Router and specify device associated configurations such as interface between Border Leaf and Edge Router. DCNM selects appropriate Border Leaf/Edge Router pairs during partition (VRF) extension.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Table 1-2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Field</strong></td>
</tr>
<tr>
<td>Edge Router/Border Leaf</td>
</tr>
<tr>
<td>IP Address</td>
</tr>
<tr>
<td>Interface Name/Port Channel</td>
</tr>
<tr>
<td>Profile Name</td>
</tr>
<tr>
<td>Type</td>
</tr>
</tbody>
</table>
Border Leaf Device Pairing

Table 1-2

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partition Utilization</td>
<td>Specifies the partitions utilized and the maximum partitions available for the device.</td>
</tr>
<tr>
<td>Add</td>
<td>Allows you to add a Border Leaf/Edge Router. For more information, see Creating an Edge Router.</td>
</tr>
<tr>
<td>Edit</td>
<td>Allows you to edit a Border Leaf/Edge Router.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allows you to delete a Border Leaf/Edge Router. For more information, see Deleting Edge Router/Border leaf devices.</td>
</tr>
<tr>
<td>View Profile</td>
<td>Allows you to view the profile created</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the list of switches.</td>
</tr>
<tr>
<td>Show Filter</td>
<td>Filters list of switches based on the defined value for each column.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the list of devices and their details.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the list of devices and their details to a Microsoft Excel spreadsheet.</td>
</tr>
</tbody>
</table>

- Creating an Edge Router
- Connect New Border leaf to the Edge Router
- Deleting Edge Router/Border leaf devices

Creating an Edge Router

**Step 1**
From the menu bar, select **Config > Border Leaf Device Pairing**.

**Step 2**
Click **Add**. Select **Edge Router**.

**Step 3**
To configure the Edge Router:

a. Use the radio button to select **Configure an Edge Router**.

   **Note**
   The **Configure an Edge Router** option will be selected by default.

b. Select **Notify Edge Router when relevant partitions are changed** to notify the Edge Router.

c. Select the **Device Name** from the drop-down list to identify an Edge Router.

d. Specify the **IP Address** for the Edge Router.

e. Specify the **Maximum Number of Partitions** required for the Edge Router.

**Step 4**
To configure a **Border PE**:

a. Use the radio button to select **Configure a Border PE**.

b. Select **Notify Edge Router when relevant partitions** are changed to notify the Edge Router.

c. Select the **Device Name** from the drop-down list to identify an Edge Router.

d. Specify the **IP Address** for the Edge Router.

e. Specify the **Maximum Number of Partitions** required for the Edge Router.
f. Define the Profile Parameters.
   - asn—specifies the autonomous system (AS) number for the Border PE
   - vrfSegmentId—specifies the vrf segment ID.
   - rsvdGlobalAsn—specifies the reserved global autonomous system number.
   - dciId—specifies the Edge Router ID for the Border PE
   - vrfName—Specifies the vrf name

   **Note** Note: The value for vrfName must be of the format 'organizationName:partitionName'.

**Step 5** Click **OK** to save the configuration.

### Connect New Border leaf to the Edge Router

**Step 1** From the menu bar, select **Config > Border Leaf Device Pairing**.

**Step 2** Click **Add**. Select **Border Leaf**.

**Step 3** Define the parameters for the Border leaf configuration and edge router configuration for pairing.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Select the name from the drop-down list for the Border leaf.</td>
</tr>
<tr>
<td>IP Address</td>
<td>The IP address is auto-populated based on the selected Border Leaf.</td>
</tr>
<tr>
<td>Port Channel or the Interface Name</td>
<td>Specify the interface name or port channel between Border Leaf and Edge Router.</td>
</tr>
<tr>
<td>Maximum Number of Partitions</td>
<td>Specifies the number of partitions required for the configuration</td>
</tr>
<tr>
<td>Default Profile Name</td>
<td>Select the default profile name from the drop-down list to apply for the profile.</td>
</tr>
<tr>
<td>Notify Border Leaf when relevant partitions</td>
<td>Select to notify the Border Leaf when relevant partitions are created.</td>
</tr>
</tbody>
</table>

**Step 4** Click **OK** to connect the new border leaf device to the Edge router.

### Deleting Edge Router/Border leaf devices

**Step 1** From the menu bar, select **Config > Border Leaf Device Pairing**.

**Step 2** Select the Edge Router/Border leaf device definitions from the list and click **Delete**.

**Step 3** Click **Yes** to confirm and delete the profile.
Border Leaf Extended Partitions

This screen lists the extended partitions, selected Border Leaf/Edge Router pairs, and their corresponding profiles and configurations. From the menu bar, select **Config > Extended Partitions**.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRF</td>
<td>Specifies the VRF name for the extended partition.</td>
</tr>
<tr>
<td>Organization</td>
<td>Specifies the name of organization which the extended partition belongs to.</td>
</tr>
<tr>
<td>Partition</td>
<td>Specifies the name of the partition that is extended.</td>
</tr>
<tr>
<td>Redundancy Factor</td>
<td>Specifies the run-time redundancy factor for that partition extension.</td>
</tr>
<tr>
<td>Edge Router</td>
<td>Specifies the name of the Edge Router.</td>
</tr>
<tr>
<td>Edge Router IP Address</td>
<td>Specifies the IP address of the Edge Router device.</td>
</tr>
<tr>
<td>Edge Router Profile</td>
<td>Specifies the default profile for the edge router.</td>
</tr>
<tr>
<td>Border Leaf (BL)</td>
<td>Specifies the name of the Border Leaf device</td>
</tr>
<tr>
<td>BL IP Address</td>
<td>Specifies the IP address of the Border Leaf device.</td>
</tr>
<tr>
<td>BL Profile</td>
<td>Specifies the default profile for the border leaf device.</td>
</tr>
</tbody>
</table>

**POAP Settings**

This allows you to set common parameters which will be populated as default values in POAP templates. For a new POAP template, values defined in this global settings page, will be automatically pre-populated. From the menu bar, select **Admin->Fabric->POAP Settings**.

Specify the parameters for the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MGMT_PREFIX</td>
<td>Specify the Management prefix.</td>
</tr>
<tr>
<td>DEFAULT_GATEWAY</td>
<td>Specify the default gateway.</td>
</tr>
<tr>
<td>MANAGEMENT_VLAN</td>
<td>Specify the management VLAN.</td>
</tr>
<tr>
<td>LDAP_SERVER_NAME</td>
<td>Specify the LDAP server name.</td>
</tr>
<tr>
<td>LDAP_SERVER_IP</td>
<td>Specify the LDAP server IP address.</td>
</tr>
<tr>
<td>LDAP2_SERVER_NAME</td>
<td>Specify the secondary LDAP server name.</td>
</tr>
<tr>
<td>LDAP2_SERVER_IP</td>
<td>Specify the secondary LDAP server IP address.</td>
</tr>
<tr>
<td>LDAP_USERNAME</td>
<td>Specify the LDAP username.</td>
</tr>
<tr>
<td>LDAP_PASSWORD</td>
<td>Specify the LDAP password.</td>
</tr>
<tr>
<td>XMPP_SERVER</td>
<td>Specify the XMPP server name.</td>
</tr>
<tr>
<td>XMPP_SERVER_IP</td>
<td>Specify the XMPP IP address.</td>
</tr>
</tbody>
</table>

**Step 4**  Click **Apply** to save the POAP settings for the fabric.
Fabric Encapsulation Settings

To configure encapsulation settings, do the following:

Step 1  From the menu bar, select Admin > Fabric Encapsulation Settings.

Step 2  Select Enable Fabric Path Encapsulation to <<need info>>

Step 3  Select Enable VxLAN Encapsulation to <<need info>>

a. In the Multicast Group Address Range field, specify the range of IP Address for the multicast group.

   This Multicast Group address range is shared between L2 and L3. This field is auto-populated from the Network page at Config > Auto-Configuration > Networks section. However, the value can be modified.

b. In the Number of Rendezvous Points (RPs) field, to divide the multicast address range into buckets, that the user is allowed to configure.

   The maximum value for RPs is 8.

Step 4  Click Apply to save the settings.

L2 Segment ID Range Management

Cisco DCNM allows you to create a new Segment ID range, and map the orchestrator ID. DCNM will associate the range with the specified orchestrator ID.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orchestrator Name</td>
<td>Specifies the Orchestrator name.</td>
</tr>
<tr>
<td>Section ID Range</td>
<td>Specifies the segment ID range for that Orchestrator.</td>
</tr>
<tr>
<td></td>
<td>The Segment ID range is unique for all Orchestrators. The default</td>
</tr>
<tr>
<td></td>
<td>Segment ID range cannot be used for any orchestrator.</td>
</tr>
<tr>
<td>Add</td>
<td>Allows you to add a new Orchestrator.</td>
</tr>
<tr>
<td>Edit</td>
<td>Allows you to edit the selected Orchestrator and segment ID range.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allows you to delete the Orchestrator.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the list of Orchestrators.</td>
</tr>
<tr>
<td>Show Filter</td>
<td>Filters list of switches based on the defined value for each column.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the list of Orchestrator and their details.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the list of Orchestrators and their details to a Microsoft Excel</td>
</tr>
<tr>
<td></td>
<td>spreadsheet.</td>
</tr>
</tbody>
</table>

- Add Orchestrator
- Modify Orchestrator
Add Orchestrator

Step 1  From the menu bar, select Admin > L2 Segment ID Range Management.
Step 2  Click Add to add a new orchestrator.
Step 3  In the Orchestrator Name field, specify the name for the Orchestrator.
Step 4  In the Segment ID Range field, specify Segment ID range to be associated with the Orchestrator.

By default, DCNM continues to support the default Segment ID range defined in the DCNM Admin > Fabric page.

Modify Orchestrator

Step 1  From the menu bar, select Admin > L2 Segment ID Range Management.
Step 2  Select the orchestrator from the list and click Edit.
Step 3  Update and click OK to save the settings.

Delete Orchestrator

Step 1  From the menu bar, select Admin > L2 Segment ID Range Management.
Step 2  Select the orchestrator from the list and click Delete.
Step 3  Click Yes to delete the orchestrator.

Mobility Domains

Cisco DCNM allows you to create mobility domains to configure a Mobility Domain Network. The Mobility Domains configured on this page can be used in Config > Auto-Configuration > Networks page.

The following icons are listed at the menu bar of the window to customize the view of the information in the window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mobility Name</td>
<td>Specifies the name for the mobility domain.</td>
</tr>
<tr>
<td>Detectable VLAN Range</td>
<td>Specifies detectable VLAN range for the particular mobility domain.</td>
</tr>
<tr>
<td>Add</td>
<td>Allows you to add a new mobility domain.</td>
</tr>
<tr>
<td>Edit</td>
<td>Allows you to edit the selected mobility domain and the VLAN range.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allows you to delete the mobility domain.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the list of mobility domains.</td>
</tr>
</tbody>
</table>
Add Mobility Domains

**Step 1** From the menu bar, select **Admin > Mobility Domains**.

**Step 2** Click **Add** to add a new mobility domain.

**Step 3** In the **Mobility Domain Name** field, specify the name for the Mobility Domain.

**Step 4** In the **Detectable VLAN Range** field, specify the VLAN IP address range for mobility domain.

**Step 5** Click **OK** to add a mobility domain.

Modify Mobility Domains

**Step 1** From the menu bar, select **Admin > Mobility Domains**.

**Step 2** Select the mobility domain from the list and click **Edit**.

**Step 3** Update and click **OK** to save the settings.

Delete Mobility Domains

**Step 1** From the menu bar, select **Admin > Mobility Domains**.

**Step 2** Select the mobility domain from the list and click **Delete**.

**Step 3** Click **Yes** to delete the mobility domain.

---

### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Filter</td>
<td>Filters list of domains based on the defined value for each column.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the list of mobility domains and VLAN range.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the list of mobility domains and their details to a Microsoft Excel spreadsheet.</td>
</tr>
</tbody>
</table>

- **Add Mobility Domains**
- **Modify Mobility Domains**
- **Delete Mobility Domains**
Configuring Cisco DCNM-SAN Server

This chapter describes Cisco DCNM-SAN Server, which is a platform for advanced MDS monitoring, troubleshooting, and configuration capabilities. No additional software needs to be installed. The server capabilities are an integral part of the Cisco DCNM-SAN software.

This chapter contains the following sections:

- Information About Cisco DCNM-SAN Server, page 5-1
- Licensing Requirements For Cisco DCNM-SAN Server, page 5-2
- Installing and Configuring Cisco DCNM-SAN Server, page 5-2
- Managing a Cisco DCNM-SAN Server Fabric, page 5-7
- Modifying Cisco DCNM-SAN Server, page 5-10
- Server Federation, page 5-15
- Additional References, page 5-20

Information About Cisco DCNM-SAN Server

Install Cisco DCNM-SAN Server on a computer that you want to provide centralized MDS management services and performance monitoring. SNMP operations are used to efficiently collect fabric information. The Cisco DCNM-SAN software, including the server components, requires about 60 MB of hard disk space on your workstation. Cisco DCNM-SAN Server runs on Windows 2000, Windows 2003, Windows XP, Solaris 9 and 10, and Red Hat Enterprise Linux AS Release 5.

Each computer configured as a Cisco DCNM-SAN Server can monitor multiple Fibre Channel SAN fabrics. Up to 16 clients (by default) can connect to a single Cisco DCNM-SAN Server concurrently. The Cisco DCNM-SAN Clients can also connect directly to an MDS switch in fabrics that are not monitored by a Cisco DCNM-SAN Server, which ensures you can manage any of your MDS devices from a single console.

DCNM-SAN Server Features

Cisco DCNM-SAN Server has the following features:
- **Multiple fabric management**—DCNM-SAN Server monitors multiple physical fabrics under the same user interface. This facilitates managing redundant fabrics. A licensed DCNM-SAN Server maintains up-to-date discovery information on all configured fabrics so device status and interconnections are immediately available when you open the DCNM-SAN Client.

- **Continuous health monitoring**—MDS health is monitored continuously, so any events that occurred since the last time you opened the DCNM-SAN Client are captured.

- **Roaming user profiles**—The licensed DCNM-SAN Server uses the roaming user profile feature to store your preferences and topology map layouts on the server, so that your user interface will be consistent regardless of what computer you use to manage your storage networks.

**Note**
You must have the same release of Cisco DCNM-SAN Client and Cisco DCNM-SAN Server.

**Note**
You will not be able to manage a SAN fabric if the DCNM-SAN Server is going through a IP NAT firewall to access the SAN fabric. All the IP addresses that are discovered in a SAN fabric must be directly reachable by the DCNM-SAN Server.

**Licensing Requirements For Cisco DCNM-SAN Server**

When you install DCNM-SAN, the basic unlicensed version of Cisco DCNM-SAN Server is installed with it. To get the licensed features, such as Performance Manager, remote client support, and continuously monitored fabrics, you need to buy and install the Cisco DCNM-SAN Server package.

However, trial versions of these licensed features are available. To enable the trial version of a feature, you run the feature as you would if you had purchased the license. You see a dialog box explaining that this is a demo version of the feature and that it is enabled for a limited time.

**Installing and Configuring Cisco DCNM-SAN Server**

**Note**
Prior to running Cisco DCNM-SAN Server, you should create a special Cisco DCNM-SAN administrative user on each switch in the fabric or on a remote AAA server. Use this user to discover your fabric topology.

**DETAILED STEPS**

**Step 1**
Install Cisco DCNM-SAN Client and Cisco DCNM-SAN Server on your workstation. See the “Installing Cisco DCNM-SAN Server” section on page 5-3.

**Step 2**
Log in to DCNM-SAN.

**Step 3**
Set Cisco DCNM-SAN Server to continuously monitor the fabric. See the “Managing a Cisco DCNM-SAN Server Fabric” section on page 5-7.

**Step 4**
Repeat **Step 2** through **Step 3** for each fabric that you want to manage through Cisco DCNM-SAN Server.
Step 5  Install DCNM-SAN Web Server. See the “Verifying Performance Manager Collections” section on page 5-7.

Step 6  Verify Performance Manager is collecting data. See the “Verifying Performance Manager Collections” section on page 5-7.

Installing Cisco DCNM-SAN Server

When you install DCNM-SAN, the basic version of the Cisco DCNM-SAN Server (unlicensed) is installed with it. After you click the DCNM-SAN icon, a dialog box opens and you can enter the IP address of a computer running the Cisco DCNM-SAN Server component. If you do not see the Cisco DCNM-SAN Server IP address text box, click Options to expand the list of configuration options. If the server component is running on your local machine, leave localhost in that field. If you try to run DCNM-SAN without specifying a valid server, you are prompted to start the Cisco DCNM-SAN Server locally.

On a Windows PC, you install the Cisco DCNM-SAN Server as a service. This service can then be administered using Services in the Administrative Tools. The default setting for the Cisco DCNM-SAN Server service is that the server is automatically started when the Windows PC is rebooted. You can change this behavior by modifying the properties in Services.

For switches running Cisco MDS 9000 FabricWare, you must install DCNM-SAN from the CD-ROM included with your switch, or you can download DCNM-SAN from Cisco.com.

Note
You can have only one instance of Cisco DCNM-SAN Server running on a computer. If you have a DCNM-SAN Standalone version on your computer, you may need to uninstall it before you install Cisco DCNM-SAN Server.

To download the software from Cisco.com, go to the following website:
http://cisco.com/cgi-bin/tablebuild.pl/mds-fm

Note
If you are upgrading from an earlier version to 5.0(1a) or later, that is configured with HTTPS to use your own self-provisioned or a third-party issued SSL certificate, make sure that you set the keystore password and then restart the DCNM-SAN Server. To set the keystore password, run $INSTALLDIR/dcm/fm/bin/encrypter.bat ssl.

DETAILED STEPS

Step 1  Click the Install Management Software link.
Step 2  Choose Management Software > Cisco DCNM-SAN.
Step 3  Click the Installing DCNM-SAN link.
Step 4  Click the FM Installer link.

You see the welcome message in the Cisco DCNM-SAN Installer window shown in Figure 5-1.
Step 5 Click the **Custom** radio button, and then click **Next** to begin installation.

Step 6 Check the **I accept the terms of the License Agreement** check box, and then click **Next**.

You see the Install Options dialog box as shown in Figure 5-2.

Step 7 Click the **Cisco DCNM-SAN Server (Licensed)** radio button to install the server components for Cisco DCNM-SAN Server.
Step 8 Click **Add server to an existing server federation** to add the server to a federation.

---

**Note** You may need to add the following line in the pg-hba.conf file under # IPv4 local connections in order to allow remote hosts to connect to PostgreSQL database:

```
host    all         all           0.0.0.0/0             md5
```

After adding, save the configuration file, restart the PostgreSQL database before you install the second server node.

---

**Note** If you are joining more then three DCNM-SAN Servers in a federation, you need to use an Oracle database with the following settings.

```
C:\Documents and Settings\Administrator>sqlplus /nolog
SQL*Plus: Release 10.2.0.1.0 - Production on Wed Jan 6 17:19:32 2010
Copyright (c) 1982, 2005, Oracle.  All rights reserved.
SQL> connect / as sysdba;
Connected.

SQL> alter system set processes=150 scope=spfile;
System altered.
SQL> alter system set open_cursors=500 scope=spfile;
System altered.

SQL> shutdown immediate;
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL> startup;
ORACLE instance started.
Total System Global Area  805306368 bytes
Fixed Size                  1453836 bytes
Variable Size             218714356 bytes
Database Buffers          583008256 bytes
Redo Buffers                2129920 bytes
Database mounted.
Database opened.
SQL> show parameter processes;

<table>
<thead>
<tr>
<th>NAME</th>
<th>TYPE</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>aq_tm_processes</td>
<td>integer</td>
<td>0</td>
</tr>
<tr>
<td>db_writer_processes</td>
<td>integer</td>
<td>4</td>
</tr>
<tr>
<td>gcs_server_processes</td>
<td>integer</td>
<td>0</td>
</tr>
<tr>
<td>job_queue_processes</td>
<td>integer</td>
<td>4</td>
</tr>
<tr>
<td>log_archive_max_processes</td>
<td>integer</td>
<td>2</td>
</tr>
<tr>
<td>processes</td>
<td>integer</td>
<td>100</td>
</tr>
</tbody>
</table>
```
Installing and Configuring Cisco DCNM-SAN Server

Chapter 5      Configuring Cisco DCNM-SAN Server

Step 9  Select an installation folder on your workstation for Cisco DCNM-SAN. On Windows, the default location is C:\Program Files\Cisco Systems.

Step 10  Click Next.

You see the Database Options dialog box as shown in Figure 5-3.

Figure 5-3 Database Options Dialog Box

![Database Options Dialog Box]

Step 11  Click the radio button for either Install PostgreSQL or Use existing DB to specify which database you want to use.

If you choose Install PostgreSQL, accept the defaults and enter a password. The PostgreSQL database will be installed.

- **Note** If you choose to install PostgreSQL, you must disable any security software you are running, because PostgreSQL may not install certain folders or users.

- **Note** Before you install PostgreSQL, remove the cygwin/bin from your environment variable path if Cygwin is running on your system.

Step 12  If you select Use existing DB, click the radio button for either PostgreSQL 8.1/8.2 or Oracle10g.

Step 13  Click Next in the Database Options dialog box.

You see the Configuration Options dialog box as shown in Figure 5-4.
Step 14 Click **Install** to install Cisco DCNM-SAN Server.

If you are evaluating one of these Cisco DCNM-SAN Server features and want to stop the evaluation period for that feature, you can do that using Device Manager.

**Data Migration in Cisco DCNM-SAN Server**

The database migration should be limited to the existing database. Data collision can occur when you merge the data between the several databases.

When you upgrade a non federation mode database to a federation mode database for the first time, the cluster sequence table is filled with the values larger than the corresponding ones in the sequence table and conforming to the cluster sequence number format for that server ID.

**Verifying Performance Manager Collections**

Once Performance Manager collections have been running for five or more minutes, you can verify that the collections are gathering data by choosing **Performance Manager > Reports** in DCNM-SAN. You see the first few data points gathered in the graphs and tables.

**Managing a Cisco DCNM-SAN Server Fabric**

You can continuously manage a Cisco DCNM-SAN Server fabric, whether or not a client has that fabric open. A continuously managed fabric is automatically reloaded and managed by Cisco DCNM-SAN Server whenever the server starts.
Selecting a Fabric to Manage Continuously

DETAILED STEPS

Step 1  Choose Server > Admin.

You see the Control Panel dialog box with the Fabrics tab open as shown in Figure 5-5.

Note  The Fabrics tab is only accessible to network administrators.

Step 2  Choose one of the following Admin options:

- Manage Continuously—The fabric is automatically managed when Cisco DCNM-SAN Server starts and continues to be managed until this option is changed to Unmanage.
- Manage—The fabric is managed by Cisco DCNM-SAN Server until there are no instances of DCNM-SAN viewing the fabric.
- Unmanage—Cisco DCNM-SAN Server stops managing this fabric.

Step 3  Click Apply.

Note  If you are collecting data on these fabrics using Performance Manager, you should now configure flows and define the data collections.

Cisco DCNM-SAN Server Properties File

The Cisco DCNM-SAN Server properties file (MDS 9000\server.properties) contains a list of properties that determine how the Cisco DCNM-SAN Server will function. You can edit this file with a text editor, or you can set the properties through the DCNM-SAN Web Services GUI, under the Admin tab.
Chapter 5  Configuring Cisco DCNM-SAN Server

Managing a Cisco DCNM-SAN Server Fabric

As of Cisco NX-OS Release 4.1(1b) and later, you can optionally encrypt the password in the server.properties and the AAA.properties files.

The server properties file contains these nine general sections:

- **GENERAL**—Contains the general settings for the server.
- **SNMP SPECIFIC**—Contains the settings for SNMP requests, responses, and traps.
- **SNMP PROXY SERVER SPECIFIC**—Contains the settings for SNMP proxy server configuration and TCP port designation.
- **GLOBAL FABRIC**—Contains the settings for fabrics, such as discovery and loading.
- **CLIENT SESSION**—Contains the settings for DCNM-SAN Clients that can log into the server.
- **EVENTS**—Contains the settings for syslog messages.
- **PERFORMANCE CHART**—Contains the settings for defining the end time to generate a Performance Manager chart.
- **EMC CALL HOME**—Contains the settings for the forwarding of traps as XML data using e-mail, according to EMC specifications.
- **EVENT FORWARD SETUP**—Contains the settings for forwarding events logged by Cisco DCNM-SAN Server through e-mail.

The following server properties are added or changed in the Cisco DCNM-SAN Release 3.x and later.

**SNMP Specific**

- **snmp.preferTCP**—If this option is set to true, TCP is the default protocol for Cisco DCNM-SAN Server to communicate with switches. By default, this setting is **true**. For those switches that do not have TCP enabled, Cisco DCNM-SAN Server uses UDP. The advantage of this setting is the ability to designate one TCP session for each SNMP user on a switch. It also helps to reduce timeouts and increase scalability.

**Note** If you set this option to false, the same choice must be set in DCNM-SAN. The default value of snmp.preferTCP for DCNM-SAN is true.

**Performance Chart**

- **pmchart.currenttime**—Specifies the end time to generate a Performance Manager chart. This should only be used for debugging purposes.

**EMC Call Home**

- **server.callhome.enable**—Enables or disables EMC Call Home. By default, it is disabled.
- **server.callhome.location**—Specifies the Location parameter.
- **server.callhome.fromEmail**—Specifies the From Email list.
- **server.callhome.recipientEmail**—Specifies the recipientEmail list.
- **server.callhome.smtpHost**—Specifies the SMTP host address for outbound e-mail.
- **server.callhome.xmlDir**—Specifies the path to store the XML message files.
- **server.callhome.connectType**—Specifies the method to use to remotely connect to the server.
• server.callhome.accessType—Specifies the method to use to establish remote communication with the server.
• server.callhome.version—Specifies the version number of the connection type.
• server.callhome.routerIp—Specifies the public IP address of the RSC router.

Event Forwarding
• server.forward.event.enable—Enables or disables event forwarding.
• server.forward.email.fromAddress—Specifies the From Email list.
• server.forward.email.mailCC—Specifies the CC Email list.
• server.forward.email.mailBCC—Specifies the BCC Email list.
• server.forward.email.smtpHost—Specifies the SMTP host address for outbound e-mail.

Deactivation
• deactivate.confirm=deactivate—Specific Request for User to type a String for deactivation.

Note In a federated server environment, you should not change Cisco DCNM-SAN Server properties by modifying server.properties file. You must modify the server.properties using web client menu Admin > Configure > Preferences.

Modifying Cisco DCNM-SAN Server

Fabric Manager Release 2.1(2) or later allows you to modify certain Cisco DCNM-SAN Server settings without stopping and starting the server.

• Changing the Cisco DCNM-SAN Server Username and Password, page 5-10
• Changing the Cisco DCNM-SAN Server Username and Password, page 5-10
• Changing the DCNM-SAN Server Fabric Discovery Username and Password, page 5-11
• Changing the Polling Period and Fabric Rediscovery Time, page 5-11
• Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS WINDOWS Server, page 5-12
• Changing the IP Address of the Cisco DCNM-SAN for Federated Windows Setup, page 5-12
• Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS LINUX Server, page 5-13
• Using Device Aliases or FC Aliases, page 5-14

Changing the Cisco DCNM-SAN Server Username and Password

You can modify the username or password used to access a fabric from DCNM-SAN Client without restarting Cisco DCNM-SAN Server.

DETAILED STEPS

Step 1 Choose Server > Admin.

You see the Control Panel dialog box with the Fabrics tab open as shown in Figure 5-5.
Chapter 5  Configuring Cisco DCNM-SAN Server

Modifying Cisco DCNM-SAN Server

Step 2  Set the Name or Password for each fabric that you are monitoring with Cisco DCNM-SAN Server.

Step 3  Click Apply to save these changes.

Changing the DCNM-SAN Server Fabric Discovery Username and Password

DETAILED STEPS

Step 1  Click Server > Admin in Cisco DCNM-SAN.
You see the Control Panel dialog box with the Fabrics tab open (see Figure 5-6).

Figure 5-6  Fabrics Tab in Control Panel Dialog Box

Step 2  Click the fabrics that have updated user name and password information.

Step 3  From the Admin listbox, select Unmanage and then click Apply.

Step 4  Enter the appropriate user name and password and then click Apply.
For more information, see the “Performance Manager Authentication” section on page 6-3”.

Changing the Polling Period and Fabric Rediscovery Time

Cisco DCNM-SAN Server periodically polls the monitored fabrics and periodically redisCOVERS the full fabric at a default interval of five cycles. You can modify these settings from DCNM-SAN Client without restarting Cisco DCNM-SAN Server.

DETAILED STEPS

Step 1  Choose Server > Admin.
You see the Control Panel dialog box with the Fabrics tab open as shown in Figure 5-5.

Step 2  For each fabric that you are monitoring with Cisco DCNM-SAN Server, set the Polling Interval to determine how frequently Cisco DCNM-SAN Server polls the fabric elements for status and statistics.

Step 3  For each fabric that you are monitoring with Cisco DCNM-SAN Server, set the Rediscover Cycles to determine how often Cisco DCNM-SAN Server redisCOVERS the full fabric.
Step 4  Click **Apply** to save these changes.

---

**Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS WINDOWS Server**

To change the IP address of a Cisco DCNM-SAN & DCNM-SMIS Server, follow these steps:

### Note

To change the IP Address of a Cisco DCNM-LAN Server, see Changing the IP Address of the Cisco DCNM-LAN for WINDOWS OS, page 15-9.

### Detailed Steps

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Stop the Cisco DCNM-SAN and DCNM-SMIS Servers.</td>
</tr>
</tbody>
</table>
| Step 2 | Change the old IP Address with the new IP Address in the following files:  
- `$INSTALLDIR\jboss-as-7.2.0.Final\bin\service\sanservice.bat`  
- `$INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-san.xml(Including DB url)`  
- `$INSTALLDIR\fm\conf\server.properties` |
| Step 3 | Enter the following command to assign a new IP address.  
`run $INSTALLDIR\fm\bin\PLMapping.bat -p newipaddress 0`  
Assume `$INSTALLDIR` is the top directory of DCNM installation. The above command is for single server instance, where 0 is the server ID. |
| Step 4 | Change the old IP Address with the new IP Address in the file `$INSTALLDIR\fm\conf\smis.properties` |
| Step 5 | Start the Cisco DCNM-SAN and DCNM-SMIS Servers. |

---

**Changing the IP Address of the Cisco DCNM-SAN for Federated Windows Setup**

To change the IP address of a Cisco DCNM-SAN for federated Windows OS, follow these steps:

- Changing the IP address of primary server
- Changing the IP address of secondary server

### Changing the IP address of primary server

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Stop the Cisco DCNM-SAN and DCNM-SMIS Servers.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Change the old IP Address with the new IP Address in the file <code>$INSTALLDIR\jboss-as-7.2.0.Final\bin\service\sanservice.bat</code></td>
</tr>
</tbody>
</table>
Chapter 5 Configuring Cisco DCNM-SAN Server

Modifying Cisco DCNM-SAN Server

Step 3 Change the old IP Address with the new IP Address in the file $INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-san.xml.

Step 4 Change the old IP Address with the new IP Address in the file $INSTALLDIR\fm\conf\server.properties.

Note If DB is installed locally (URL pointing to LocalHost), No DB URL change required in standalone-san.xml, server.properties.

Step 5 Enter the following command to assign a new IP address.
run $INSTALLDIR\fm\bin\PLMapping.bat -p newipaddress 0
Assume $INSTALLDIR is the top directory of DCNM installation. The above command is for primary server instance, where 0 is the server ID.

Step 6 Change the old IP Address with the new IP Address in the file $INSTALLDIR\fm\conf\smis.properties.

Step 7 Start the Cisco DCNM-SAN and DCNM-SMIS Servers.

Changing the IP address of secondary server

Step 1 Stop the Cisco DCNM-SAN and DCNM-SMIS Servers.

Step 2 Change the old IP Address with the new IP Address in the file $INSTALLDIR\jboss-as-7.2.0.Final\bin\service\sanservice.bat

Step 3 Change the old IP Address with the new IP Address in the file $INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-san.xml

Step 4 Change the old IP Address with the new IP Address in the file $INSTALLDIR\fm\conf\server.properties.

Step 5 Change DB URL in standalone-san.xml, server.properties, postgresql.cfg.xml, oracle.cfg.xml files, if there is ipaddress change in primary server.

postgresql.cfg.xml, oracle.cfg.xml can be found under $INSTALLDIR\jboss-as-7.2.0.Final\standalone\conf directory.

Step 6 Enter the following command to assign a new IP address.
run $INSTALLDIR\fm\bin\PLMapping.bat -p newipaddress 1.

Note ServerID can be got by run $INSTALLDIR\fm\bin\PLMapping.bat -show. Assume $INSTALLDIR is the top directory of DCNM installation. The above command 1 is the server ID.

Step 7 Change the old IP Address with the new IP Address in the file $INSTALLDIR\fm\conf\smis.properties.

Step 8 Start the Cisco DCNM-SAN and DCNM-SMIS Servers.

Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS LINUX Server

To change the IP address of a Cisco DCNM-SAN & DCNM-SMIS Server, follow these steps:
Modified Cisco DCNM-SAN Server

Note

To change the IP Address of a Cisco DCNM-LAN Server, see Changing the IP Address of the Cisco DCNM-LAN on Linux OS, page 15-10.

Detailed Steps

Step 1
Stop the Cisco DCNM-SAN and DCNM-SMIS Servers.

Step 2
Change the old IP Address with the new IP Address in the following files:

- $INSTALLDIR/jboss-as-7.2.0.Final/bin/init.d/sanservice.sh
- /etc/init.d/FMServer
- $INSTALLDIR/jboss-as-7.2.0.Final/standalone/configuration/standalone-san.xml (Including DB url)
- $INSTALLDIR/fm/conf/server.properties

Step 3
Enter the following command to assign a new IP address.

```
run $INSTALLDIR/fm/bin/PLMapping.bat -p newipaddress 0
```

Assume $INSTALLDIR is the top directory of DCNM installation. The above command is for single server instance, where 0 is the server ID.

Step 4
Change the old IP Address with the new IP Address in the file $INSTALLDIR/fm/conf/smis.properties.

Note
If this is a DCNM virtual appliance (OVA/ISO) deployed without any Fabric enhancements, update the property DCNM_IP_ADDRESS in the file /root/packaged-files/properties/installer.properties with the new IP Address.

Step 5
Start the Cisco DCNM-SAN and DCNM-SMIS Servers.

Using Device Aliases or FC Aliases

You can change whether DCNM-SAN uses FC aliases or global device aliases from DCNM-SAN Client without restarting Cisco DCNM-SAN Server.

Detailed Steps

Step 1
Choose Server > Admin.

You see the Control Panel dialog box with the Fabrics tab open as shown in Figure 5-5.

Step 2
For each fabric that you are monitoring with Cisco DCNM-SAN Server, check or uncheck the FC Alias check box.

If you check the FC Alias checkbox, DCNM-SAN will use FC Alias from DCNM-SAN Client. If you uncheck the FC Alias checkbox, DCNM-SAN will use global device alias from DCNM-SAN Client.

Step 3
Click Apply to save these changes.
Configuring Security Manager

The security at Fabric Manager Server level control access to different features of the Fabric Manager. The existing security controls in the Fabric Manager allows a user to continue even after many unsuccessful login attempts. With the new security manager, the Fabric Manager will perform a lock-out for the specific user after a specified number of unsuccessful login attempts. System administrators will be able to generate a report of login attempts.

To see the number of failed login attempts, follow these steps:

---

**Step 1**

In the Fabric Manager Control Panel, click **Local FM Users**.

You see the control panel as shown in Figure 5-7

---

**Figure 5-7 Number**

---

**Step 2**

**Step 3**

Server Federation

Server Federation is a distributed system that includes a collection of intercommunicated servers or computers that is utilized as a single, unified computing resource. With Cisco DCNM-SAN Server Federation, you can communicate with multiple servers together in order to provide scalability and easy manageability of data and programs running within the federation. The core of server federation includes several functional units such as Cisco DCNM-SAN Server, embedded web servers, database and DCNM-SAN Client that accesses the servers.

The Cisco DCNM-SAN Server in the federation uses the same database to store and retrieve data. The database is shared among different servers to share common information. A DCNM-SAN Client or DCNM-SAN Web Client can open fabrics from the Cisco DCNM-SAN Server using the mapping table. A fabric can be moved from one logical server to another. A logical server also can be moved from one physical machine to another machine.

Restrictions

- You cannot upgrade more than one Cisco DCNM-SAN Server in an existing federation. If you choose to do so, you may not be able to migrate the Performance Manager statistics and other information on that server.
You may require to synchronize the time on all the DCNM-SAN Servers in a federated server environment.

**Mapping Fabric ID to Server ID**

The IP address of the physical server will be mapped to the server ID during the installation of the Cisco DCNM-SAN Server whenever the IP address of the physical server is changed, you need to map the IP address to the server ID using the PLMapping script provided with the Cisco DCNM-SAN Server. Whenever the you open or discover a fabric, the fabric ID will be mapped to the server ID. You can move a fabric to a different server ID using the control panel.

**DETAILED STEPS**

**Step 1** Choose **Server > Admin**.

You see the Control Panel as shown in Figure 5-8.

![Control Panel](image)

**Step 2** Select the fabric that you want to move to a different server and then click **Move**.

You see the Move Fabric dialog box as shown in Figure 5-9.
Step 3 You see the fabrics that you selected in the Fabrics to Move list box. From the Move To Server drop-down list select the server you want to move the fabric to.

Step 4 Click Move.

Opening the Fabric on a Different Server

DETAILED STEPS

Step 1 Choose Server > Admin.

You see the Control Panel as shown in Figure 5-10.

Step 2 Click Discover.

You see the Discover New Fabric dialog box as shown in Figure 5-11.
Step 3 In the Seed Switch list box, enter the IP Address of the seed switch.
Step 4 In the User Name field, enter the username.
Step 5 In the password field, enter the password.
Step 6 From the Auth-Privacy drop-down list, choose the privacy protocol you want to apply.
Step 7 To open the selected fabric in a different server, select the server ID from the Server drop-down list.
Step 8 Click Discover.

Note You may receive an error message when you discover a fabric in a federation while another Cisco DCNM-SAN Server is joining the federation. You can discover the fabric on after the installation or upgradation is complete.

Viewing the Sessions in a Federation

DETAILED STEPS

Step 1 Choose Server > Admin.
Step 2 Click the Connected Clients tab.
You see the Control Panel as shown in Figure 5-12.
Viewing the Servers in a Federation

DETAILED STEPS

| Step 1 | Choose Server > Admin. |
| Step 2 | Click the Servers tab. |

You see the Control Panel as shown in Figure 5-13.

Discover Devices Managed by SVI

| Step 1 | Log on to the DCNM Web Client. |
| Step 2 | Select Admin>Server Properties. |
| Step 3 | Scroll down to the GENERAL->DATA SOURCE FABRIC section. |
| Step 4 | Set the fabric.managementIpOverwrite property to false. |
| Step 5 | Click Apply. |
| Step 6 | Restart the DCNM service. |

Note
If you experiences technical issues using DCNM, you must restart the database service manually.

| Step 7 | Delete any previously discovered switch that incorrectly shows the mgmt0 IP address. |
| Step 8 | Retry the discovery. |

Note
Each SVI switch must be discovered separately.
Server Federation is a licensed feature. For more information on Cisco DCNM-SAN Server Licensing, see *Cisco MDS 9000 Family NX-OS Licensing Guide*.

For more information on deploying Cisco DCNM-SAN Server in a federation, see *Cisco Fabric Manager Server Federation Deployment Guide*. 
CHAPTE R 6

Configuring Authentication in Cisco DCNM-SAN

This chapter describes the interdependent software components in Cisco DCNM-SAN that communicate with the switches, authentication steps and the best practices for setting up your fabric and components for authentication.

This chapter contains the following sections:
- Information About Cisco DCNM-SAN Authentication, page 6-1
- Best Practices for Discovering a Fabric, page 6-2
- Performance Manager Authentication, page 6-3
- Cisco DCNM-SAN Web Client Authentication, page 6-4

Information About Cisco DCNM-SAN Authentication

Cisco DCNM-SAN contains multiple components that interact to manage a fabric. These components include:
- Cisco DCNM-SAN Client
- Cisco DCNM-SAN Server
- Performance Manager
- Interconnected fabric of Cisco MDS 9000 switches and storage devices
- AAA server (optional)

Figure 6-1 shows an example configuration for these components.
Administrators launch Cisco DCNM-SAN Client and select the seed switch that is used to discover the fabric. The user name and password used are passed to Cisco DCNM-SAN Server and used to authenticate to the seed switch. If this user name and password are not a recognized SNMP user name and password, either Cisco DCNM-SAN Client or Cisco DCNM-SAN Server opens a CLI session to the switch (SSH or Telnet) and retries the user name and password pair. If the user name and password are recognized by the switch in either the local switch authentication database or through a remote AAA server, then the switch creates a temporary SNMP user name that is used by Cisco DCNM-SAN Client and server.

Note
You may encounter a delay in authentication if you use a remote AAA server to authenticate Cisco DCNM-SAN or Device Manager.

Note
You must allow CLI sessions to pass through any firewall that exists between Cisco DCNM-SAN Client and Cisco DCNM-SAN Server.

Note
We recommend that you use the same password for the SNMPv3 user name authentication and privacy passwords as well as the matching CLI user name and password.

Best Practices for Discovering a Fabric

Cisco DCNM-SAN Server monitors multiple physical fabrics under the same user interface. This facilitates managing redundant fabrics. A licensed Cisco DCNM-SAN Server maintains up-to-date discovery information on all configured fabrics so device status and interconnections are immediately available when you launch Cisco DCNM-SAN Client.

Caution
If the Cisco DCNM-SAN Server’s CPU usage exceeds 50 percent, it is recommended that you switch to a higher CPU-class system.
We recommend that you use these best practices for discovering your network and setting up Performance Manager. This ensures that Cisco DCNM-SAN Server has a complete view of the fabric. Subsequent Cisco DCNM-SAN Client sessions can filter this complete view based on the privileges of the client logging in. For example, if you have multiple VSANs in your fabric and you create users that are limited to a subset of these VSANs, you want to initiate a fabric discovery through Cisco DCNM-SAN Server using a network administrator or network operator role so that Cisco DCNM-SAN Server has a view of all the VSANs in the fabric. When a VSAN-limited user launches Cisco DCNM-SAN Client, that user sees only the VSANs they are allowed to manage.

**Note**
Cisco DCNM-SAN Server should always monitor fabrics using a local switch account, do not use a AAA (RADIUS or TACACS+) server. You can use a AAA user account to log into the clients to provision fabric services.

### Setting Up Discovery for a Fabric

**DETAILED STEPS**

**Step 1** Create a special Cisco DCNM-SAN administrative user name in each switch on your fabric with network administrator or network operator roles. Or, create a special Cisco DCNM-SAN administrative user name in your AAA server and set every switch in your fabric to use this AAA server for authentication.

**Step 2** Verify that the roles used by this Cisco DCNM-SAN administrative user name are the same on all switches in the fabric and that this role has access to all VSANs.

**Step 3** Launch Cisco DCNM-SAN Client using the Cisco DCNM-SAN administrative user. This step ensures that your fabric discovery includes all VSANs.

**Step 4** Set Cisco DCNM-SAN Server to continuously monitor the fabric.

**Step 5** Repeat **Step 4** for each fabric that you want to manage through Cisco DCNM-SAN Server.

### Performance Manager Authentication

Performance Manager uses the user name and password information stored in the Cisco DCNM-SAN Server database. If this information changes on the switches in your fabric while Performance Manager is running, you need to update the Cisco DCNM-SAN Server database and restart Performance Manager. Updating the Cisco DCNM-SAN Server database requires removing the fabric from Cisco DCNM-SAN Server and rediscovering the fabric.

**DETAILED STEPS**

**Step 1** Click **Server > Admin** in Cisco DCNM-SAN.

You see the Control Panel dialog box with the Fabrics tab open (see Figure 6-2).
Figure 6-2  Fabrics Tab in Control Panel Dialog Box

Step 2  Click the fabrics that have updated user name and password information.
Step 3  From the Admin listbox, choose Unmanage and then click Apply.
Step 4  Enter the appropriate user name and password and then click Apply.
Step 5  From the Admin listbox, choose Manage and then click Apply.
Step 6  To rediscover the fabric, click Open tab and check the check box(es) next to the fabric(s) you want to open in the Select column.
Step 7  Click Open to rediscover the fabric. Cisco DCNM-SAN Server updates its user name and password information.
Step 8  Repeat Step 3 through Step 7 for any fabric that you need to rediscover.
Step 9  Choose Performance > Collector > Restart to restart Performance Manager and use the new user name and password.

Cisco DCNM-SAN Web Client Authentication

Cisco DCNM-SAN Web Server does not communicate directly with any switches in the fabric. Cisco DCNM-SAN Web Server uses its own user name and password combination that is either stored locally or stored remotely on an AAA server.

We recommend that you use a RADIUS or TACACS+ server to authenticate users in Cisco DCNM-SAN Web Server.

DETAILED STEPS

Step 1  Launch Cisco DCNM-SAN Web Client.
Step 2  Choose Admin > Management Users > Remote AAA to update the authentication used by Cisco DCNM-SAN Web Client.
Step 3  Set the authentication mode attribute to radius.
Step 4  Set the RADIUS server name, shared secret, authentication method, and ports used for up to three RADIUS servers.
Step 5  Click Modify to save this information.
Cisco DCNM-SAN Web Client Authentication

**Step 1** Launch Cisco DCNM-SAN Web Client.

**Step 2** Choose **Admin > Management Users > Remote AAA** to update the authentication used by Cisco DCNM-SAN Web Client.

**Step 3** Set the authentication mode attribute to **tacacs**.

**Step 4** Set the TACACS+ server name, shared secret, authentication method, and port used for up to three TACACS+ servers.

**Step 5** Click **Modify** to save this information.

---

**Note**

Cisco DCNM-SAN does not support SecureID because it is not compatible with SNMP authentication. Cisco DCNM-SAN uses the same login credentials for all the switches in a fabric. Since SecureID cannot be used more than once for authentication, Cisco DCNM-SAN will not be able to establish a connection to the second switch using a SecureID.
Configuring Cisco DCNM-SAN Client

This chapter describes about the Cisco DCNM-SAN Client, which is a java-based GUI application that provides access to the Cisco DCNM-SAN applications from a remote workstation.

This chapter contains the following sections:
- Information About DCNM-SAN Client, page 7-1
- Cisco DCNM-SAN Client Quick Tour: Server Admin Perspective, page 7-2
- Cisco DCNM-SAN Client Quick Tour: Admin Perspective, page 7-6
- Launching Cisco DCNM-SAN Client, page 7-25
- Setting Cisco DCNM-SAN Preferences, page 7-33
- Network Fabric Discovery, page 7-35
- Modifying the Device Grouping, page 7-37
- Controlling Administrator Access with Users and Roles, page 7-40
- Using Cisco DCNM-SAN Wizards, page 7-40
- Cisco DCNM-SAN Troubleshooting Tools, page 7-41
- Integrating Cisco DCNM-SAN and Data Center Network Management Software, page 7-41

Information About DCNM-SAN Client

Cisco DCNM-SAN is a Java and SNMP-based network fabric and device management tool with a GUI that displays real-time views of your network fabric, including Cisco Nexus 5000 Series switches, Cisco MDS 9000 Family and third-party switches, hosts, and storage devices.

In addition to complete configuration and status monitoring capabilities for Cisco MDS 9000 Family switches and Cisco Nexus 5000 Series switches, Cisco DCNM-SAN Client provides Fibre Channel troubleshooting tools. You can use these health and configuration analysis tools on the MDS 9000 Family switch or Cisco Nexus 5000 Series switch to perform Fibre Channel ping and traceroute.

Cisco DCNM-SAN Release 4.1(1b) and later provides multilevel security system by adding a server admin role that allows access to limited features. The configuration capabilities of a server admin is limited to FlexAttach and relevant data.

Note
You must use the same release of Cisco DCNM-SAN Client and Cisco DCNM-SAN Server.
Cisco DCNM-SAN Advanced Mode

Advanced mode is enabled by default and provides the full suite of Cisco DCNM-SAN features, including security, IVR, iSCSI, and FICON. To simplify the user interface, from the list box in the upper right corner of the Cisco DCNM-SAN Client, choose Simple. In simple mode, you can access basic MDS 9000 features such as VSANs, zoning, and configuring interfaces. Advanced mode option is not available for server admin role.

Cisco DCNM-SAN Client Quick Tour: Server Admin Perspective

Cisco DCNM-SAN provides a multilevel security system by adding a server admin role that allows access only to limited features. The configuration capabilities of a server admin role is limited to FlexAttach and relevant data. The server admin can pre-configure SAN for new servers, move a server to another port on the same NPV device or another NPV device and replace a failed server onto the same port without involving the SAN administrator. The server role admin will not be able to manage Cisco DCNM-SAN users or connected clients.

Cisco DCNM-SAN provides a much improved user interface by including movable and dockable panes to let users arrange the Physical Attributes pane, Logical Domains pane, Fabric pane and Information pane according to requirements, making it easier to manage the workflow. The dockable panes are also called as dockable frames. A dockable frame can be standalone (floating), minimized or maximized. The logical, physical, information and the fabric panes can be collapsed and expanded as needed. These panes can also be docked at either the right side left side or to the bottom of the workspace.

Cisco DCNM-SAN Main Window

This section describes the Cisco DCNM-SAN Client interface that is specific to server admin users as shown in Figure 7-1.
Cisco Prime DCNM Fundamentals Guide

Chapter 7  Configuring Cisco DCNM-SAN Client

Cisco DCNM-SAN Client Quick Tour: Server Admin Perspective

Figure 7-1  Cisco DCNM-SAN Main Window: Server Admin Perspective

1. Menu bar—Provides access to options that are organized by menus.
2. Toolbar—Provides icons for direct access to the most commonly used options on the File, Tools, and Help menus.
3. Information pane—Displays information about whatever option is selected in the menu tree.
4. Status Bar (right side)—Shows the last entry displayed by the discovery process and the possible error message.
5. Fabric pane—Displays a map of the network fabric, including switches, hosts, and storage. It also provides tabs for displaying log and event data.
6. Status Bar (left side)—Shows short-term transient messages, such as the number of rows displayed in a table.
7. Physical Attributes pane—Displays a tree of available configuration tasks depending on the fabric, VSAN, or zone selected previously. Lists the switches in the logical selection.
8. Logical Domains pane—Displays a tree of configured SAN, fabrics and user-defined groups.
Menu Bar

The menu bar at the top of the Cisco DCNM-SAN main window provides options for managing and for controlling the display of information on the Fabric pane. Server admin will not have all the options that are available for SAN admin. The menu bar provides the following menus:

- **File**—Opens a new fabric, redisCOVERs the current fabric, locates switches, sets preferences, prints the map.
- **View**—Changes the appearance of the map (these options are duplicated on the Fabric pane toolbar).
- **Tools**—Manages the Server and configuration using the FlexAttach virtual pWWN feature.
- **Help**—Displays online help topics for specific dialog boxes in the Information pane.

Tool Bar

The Cisco DCNM-SAN main toolbar (specific to server admin) provides icons for accessing the most commonly used menu bar options as shown in Table 7-1.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="open-switch-fabric.png" alt="Icon" /></td>
<td>Opens switch fabric.</td>
</tr>
<tr>
<td><img src="rediscover-fabric.png" alt="Icon" /></td>
<td>RedisCOVERs current fabric.</td>
</tr>
<tr>
<td><img src="find-in-map.png" alt="Icon" /></td>
<td>Finds in the map.</td>
</tr>
<tr>
<td><img src="help.png" alt="Icon" /></td>
<td>Shows online help.</td>
</tr>
</tbody>
</table>

Logical Domains Pane

Use the Logical Domains pane to view fabrics and to access user-defined groups. You can expand the groups to see different user-defined groups. The non-editable groups created for each core switch contains their NPV switches.

Physical Attributes Pane

Use the Physical Attributes pane to display a tree of the options available for managing the switches in the currently selected fabric or group.
To select an option, click a folder to display the options available and then click the option. You see the table with information for the selected option in the Information pane. The Physical Attributes pane provides the following main folders:

- **Switches**—Views and configures hardware, system, licensing, and configuration files.
- **Interfaces**—Views and configures FC physical, FC logical, VFC (FCoE), Ethernet, SVC, and PortChannel interfaces.

### Information Pane

Use the Information pane to display tables of information associated with the option selected from the menu tree in the Logical Domains or Physical Attributes panes. The Information pane toolbar provides buttons for performing one or more of the operations shown in Table 5-2.

**Table 7-2 Information Pane Toolbar**

<table>
<thead>
<tr>
<th>Icons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Applies configuration changes.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Refreshes table values.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Copies data from one row to another.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Pastes the data from one row to another.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>Undoes the most recent change.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>Finds a specified string in the table.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>Exports and saves information to a file.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>Prints the contents of the Information pane.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>Displays a non-editable copy of the table in the Information pane in its own window, which you can move around the screen.</td>
</tr>
</tbody>
</table>
Fabric Pane

Use the Fabric pane to display the graphical representation of your fabric. Table 5-1 explains the
graphics you may see displayed, depending on which devices you have in your fabric.

The bottom of the Fabric pane has the following tabs:

- **Fabric**—When displaying multiple fabrics, each fabric has its own tab. You can switch between
  fabrics by clicking on their respective tabs.
- **Log**—Displays messages that describe Cisco DCNM-SAN operations, such as fabric discovery.

---

**Note**

Fabric map display is based on what you select in the logical domain pane. When you select a fabric
node, all the switches that belong to that fabric will be enabled. When you select the group node, all the
switches that belong to the groups listed under that group node will be enabled. When you select only a
group, all the switches that belong to the specific group will be enabled.

---

**Note**

You can view information about Events using the DCNM Web Client.

Cisco DCNM-SAN Client Quick Tour: Admin Perspective

This section describes the Cisco DCNM-SAN Client interface shown in Figure 7-2.
<table>
<thead>
<tr>
<th></th>
<th>Menu bar—Provides access to options that are organized by menus.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Toolbar—Provides icons for direct access to the most commonly used options on the File, Tools, and Help menus.</td>
</tr>
<tr>
<td>3</td>
<td>Information pane—Displays information about whatever option is selected in the menu tree.</td>
</tr>
<tr>
<td>4</td>
<td>Status Bar (right side)—Shows the last entry displayed by the discovery process and the possible error message.</td>
</tr>
<tr>
<td>5</td>
<td>Fabric pane—Displays a map of the network fabric, including switches, hosts, and storage. It also provides tabs for displaying log and event data.</td>
</tr>
<tr>
<td>6</td>
<td>Status Bar (left side)—Shows short-term transient messages, such as the number of rows displayed in a table.</td>
</tr>
<tr>
<td>7</td>
<td>Physical Attributes pane—Displays a tree of available configuration tasks depending on the fabric, VSAN, or zone selected previously. Lists the switches and end devices in the logical selection.</td>
</tr>
<tr>
<td>8</td>
<td>Logical Domains pane—Displays a tree of configured SAN, fabrics, VSANs, and zones, and provides access to user-defined groups. The label next to the segmented VSAN indicates the number of segments.</td>
</tr>
</tbody>
</table>
Chapter 7  Configuring Cisco DCNM-SAN Client

Cisco DCNM-SAN Client Quick Tour: Admin Perspective

Note

You can resize each pane by dragging the boundaries between each region or by clicking the Minimize or Maximize controls.

Menu Bar

The menu bar at the top of the Cisco DCNM-SAN main window provides options for managing and troubleshooting the current fabric and for controlling the display of information on the Fabric pane. The menu bar provides the following menus:

- **File**—Opens a new fabric, redisCOVERS the current fabric, locates switches, sets preferences, prints the map, and exports the Fabric pane log.
- **View**—Changes the appearance of the map (these options are duplicated on the Fabric pane toolbar).
- **Zone**—Manages zones, zone sets, and inter-VSAN routing (IVR).
- **Tools**—Verifies and troubleshoots connectivity and configuration, as described in the “Cisco DCNM-SAN Troubleshooting Tools” section on page 7-41.
- **Performance**—Runs and configures Performance Manager and Cisco Traffic Analyzer, and generates reports.
- **Server**—Runs administrative tasks on clients and fabrics. Provides Cisco DCNM-SAN Server management and a purge command. Lists fabrics being managed.
- **Help**—Displays online help topics for specific dialog boxes in the Information pane.

File

The file menu provides the following options:

- **Open Fabric**—Opens a new switch fabric.
- **Locate Switches and Devices**—Uses the SNMPv2 protocol to discover devices responding to SNMP requests with the read-only community string public. You may use this feature if you want to locate other Cisco MDS 9000 switches in the subnet, but are not physically connected to the fabric.
- **Rediscover**—Initiates an on-demand discovery to learn recent changes from the switches and update the Cisco DCNM-SAN Client. You may use this option when Cisco DCNM-SAN Server is not in sync with switches in the fabric and you do not want to wait until the next polling cycle. The rediscover option does not delete the fabric and add it again. You may delete and add the fabric only if the rediscover option fails to update Cisco DCNM-SAN Server.
- **Resync All Open Fabrics**—Cisco DCNM-SAN Server forces all the fabrics to close and re-open. You may use this option when Cisco DCNM-SAN Client is not in sync with Cisco DCNM-SAN Server.
- **Rediscover SCSI Targets**—Initiates an on-demand discovery to learn recent changes from the SCSI target switches. You may use this option when Cisco DCNM-SAN Server is not in sync with SCSI target switches in the fabric and you do not want to wait until the next polling cycle.
- **Preferences**—Sets your preferences to customize the behavior of the Cisco DCNM-SAN Client.
- **Import Enclosures**—Imports saved enclosures.
- **Export**
  - **Map Image**—Generates and export the map to a specified location.
Cisco DCNM-SAN Client Quick Tour: Admin Perspective

- Visio—Exports the map to a Visio file.
- Table—Exports the table data to a text file.
- Log—Exports the log to a text file.
- Events—Exports the events to a text file.
- Enclosures—Exports the enclosure values to a text file.
- Print—Prints the map.
- Exit—Exit Cisco DCNM-SAN.

View

View menu provides the following options:
- Refresh Map—Refreshes the current map.
- Layout
  - Cancel—Cancels the current layout.
  - Spring—Displays the layout based on spring algorithm.
  - Quick—Quickly displays the layout when the switch has many end devices.
- Zoom
  - In—Zooms in the view.
  - Out—Zooms out the view.
  - Fit—Fits the view in the fabric pane.
- Grid—Enables the grid view.
- Overview Window—Allows you to center the Fabric pane on the area of the fabric that you want to see. This option is useful for large fabrics that cannot be displayed entirely within the Fabric pane.
- Legend—Shows all the legends used in the fabric map.
- Find in Map—Finds a device in the fabric map.

Zone

The zone menu provides the following options:
- Edit Local Full Zone Database—Allows you to create zones across multiple switches. Zones provide a mechanism for specifying access control. Zone sets are a group of zones to enforce access control in the fabric. All zoning features are available through the Edit Local Full Zone Database dialog box.
- Deactivate Zoneset—Deactivates an active zone set.
- Copy Full Zone Database—Creates a new zone set. On the Cisco MDS Family switches, you cannot edit an active zone set. However, you can copy an active zone set to create a new zone set that you can edit.
- Merge Analysis—Enables you to determine if zones will merge successfully when two Cisco MDS switches are interconnected. If the interconnected switch ports allow VSANs with identical names or contain zones with identical names, then Cisco DCNM-SAN verifies that the zones contain identical members. You can use merge analysis tool before attempting a merge, or after fabrics are interconnected to determine zone merge failure causes.
Cisco DCNM-SAN Client Quick Tour: Admin Perspective

Chapter 7 Configuring Cisco DCNM-SAN Client

- Merge Fail Recovery—Recover the port from its isolated state either by importing the neighboring switch's active zone set database and replacing the current active or by exporting the current database to the neighboring switch.
- Migrate Non-MDS Database—Migrate a non-MDS database using Cisco DCNM-SAN (you may need to use the Zone Migration Wizard to accomplish this task).
- IVR
  - Deactivate Zoneset—Deactivates an active zone set.
  - Copy Full Zone Database—Recover an IVR zone database by copying the IVR full zone database from another switch.
  - Copy Full Topology—Recover a topology by copying from the active zone database or the full zone database.

Tools

Tools menu provides the following options:

- Health
  - Switch Health—Determines the status of the components of a specific switch.
  - Fabric Configuration—Analyzes the configuration of a switch by comparing the current configuration to a specific switch or to a policy file. You can save a switch configuration to a file and then compare all switches against the configuration in the file.
  - Show Tech Support—Collects large amount of information about your switch for troubleshooting purposes. When you issue a `show tech support` command from Cisco DCNM-SAN for one or more switches in a fabric, the results of each command are written to a text file, one file per switch, in a directory you specify. You can then view these files using Cisco DCNM-SAN.
- Connectivity
  - End to End Connectivity—Determines connectivity and routes among devices with the switch fabric. This tool checks to see that every pair of end devices can talk to each other, using a Ping test and by determining if they are in the same VSAN or in the same active zone.
  - Ping—Determines connectivity from another switch to a port on your switch.
  - Trace Route—Verifies connectivity between two end devices that are currently selected on the Fabric pane.
  - Compact Flash Report—Automatically scans the fabric and generate a report that shows the status of CompactFlash.
- NPV
  - CFS Static Peer Setup—Manage the peer list used during CFS on NPV-enabled switches. After setting up the static peers list, the CFS discovery on the switches will be changed to static mode for all peers in the list. Cisco DCNM-SAN does not automatically update static peers list. You may need to update the list using the CFS Static Peer Setup Wizard when a new switch is added to the fabric.
  - Traffic Map Setup—Configures the list of external interfaces to the servers, and enabling or disabling disruptive load balancing. Using Traffic Map Setup you can specify the external ports that a server should use for traffic management.
Cisco DCNM-SAN Client Quick Tour: Admin Perspective

- Flex Attach Pre-Configure Server—Sets the port configurations for all the ports in a switch such as enabling or disabling FlexAttach, setting the default VSAN ID, and setting the interface status.
- Flex Attach Move Server—Moves a server to another port on the same NPV device or another NPV device without changing the SAN.
- Flex Attach Replace Server—Replaces a failed server with a new server on the same port without changing the SAN.

- Data Mobility Manager
  - Server Based—Performs server-based data migration.
  - Storage based—Performs storage-based data migration.
  - Server LUN Discovery—Performs LUN discovery to select the LUNs available for migration and automates the session creation by matching the LUNs in the existing and new storage.

- FCoE—Launches the FCoE Configuration Wizard to create virtual Fibre Channel interfaces.

- Port Channel—Creates PortChannels from selected ISL either manually or automatically.

- DPVM Setup—Establishes dynamic port VSAN membership, enables autolearning, and activates the DPVM database.

- IP SAN
  - FCIP Tunnel—Creates FCIP links between Gigabit Ethernet ports. Enables Fibre Channel write acceleration and IP compression.
  - iSCSI Setup—Creates zones for iSCSI initiators and adds a VSAN to a target-allowed VSAN list.
  - SAN Extension Tuner—Optimizes FCIP performance by generating either direct access (magnetic disk) or sequential access (magnetic tape) SCSI I/O commands and directing such traffic to a specific virtual target. This option is used to generate SCSI I/O commands (read and write) to the virtual target based on your configured options.

- Security
  - Port Security—Prevents unauthorized access to a switch port in the Cisco MDS 9000 Family, rejects intrusion attempts and reports these intrusions to the administrator.
  - IP ACL—Creates an ordered list of IP filters in a named IPv4-ACL or IPv6-ACL profile using the IPv4-ACL Wizard.

- Install
  - License—Facilitate download and installation of licenses in selected switches in the fabric.
  - Software—Verifies image compatibility and installs software images on selected switches in the fabric.

- Flow Load Balance Calculator—Allows you to get the best load-balancing configuration for your FICON flows. The calculator does not rely on any switch or flow discovery in the fabric.

- Device Manager—Invokes Device Manager for a switch.
- Command Line Interface—Enables command-line operations.
- Run CLI Commands—Runs command-line operations on more than one switch at a time.

Performance

The performance menu provides the following options:
Create Flows—Creates host-to-storage, storage-to-host, or bidirectional flows. You can add these flows to a collection configuration file to monitor the traffic between a host or storage element pair.

Server

The server menu provides the following options:

- Admin—Opens the control panel.
- Purge Down Elements—Purges all down elements in the fabric.

Help

The help menu provides the following options:

- Contents—Launches the online help contents.
- Config Guide—Launches the Cisco DCNM-SAN Configuration Guide.
- About—Displays information about Cisco DCNM-SAN.

Toolbar

The Cisco DCNM-SAN main toolbar provides icons for accessing the most commonly used menu bar options as shown in Table 7-3.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="opens-switch-fabric" alt="Icon" /></td>
<td>Opens switch fabric.</td>
</tr>
<tr>
<td><img src="rediscover-current-fabric" alt="Icon" /></td>
<td>Rediscover current fabric.</td>
</tr>
<tr>
<td><img src="find-in-map" alt="Icon" /></td>
<td>Finds in the map.</td>
</tr>
<tr>
<td><img src="create-vsan" alt="Icon" /></td>
<td>Creates VSAN.</td>
</tr>
<tr>
<td><img src="launch-dpvm-wizard" alt="Icon" /></td>
<td>Launches DPVM wizard.</td>
</tr>
<tr>
<td><img src="launch-port-security-wizard" alt="Icon" /></td>
<td>Launches Port Security wizard.</td>
</tr>
<tr>
<td><img src="edit-full-zone-database" alt="Icon" /></td>
<td>Edits full zone database.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Launches IVR zone wizard.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Launches the FCoE configuration wizard.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Launches PortChannel wizard.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Launches FCIP wizard.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>Launches iSCSI wizard.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>Launches NPVM wizard.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>Launches QoS wizard.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>Configures users and roles.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>Launches IP-ACL wizard.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>Launches License Install wizard.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>Launches Software Install wizard.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>Performs switch health analysis.</td>
</tr>
<tr>
<td><img src="image13.png" alt="Icon" /></td>
<td>Performs fabric configuration analysis.</td>
</tr>
<tr>
<td><img src="image14.png" alt="Icon" /></td>
<td>Performs end-to-end connectivity analysis.</td>
</tr>
</tbody>
</table>
Logical Domains Pane

Use the Logical Domains pane to manage attributes for fabrics, VSANs, and zones, and to access user-defined groups. Starting from NX-OS Release 4.2(0), SAN and LAN nodes are listed under Datacenter node and all the fabrics are listed under SAN node. When you select Datacenter node in the tree, Cisco DCNM-SAN displays all the switches and ISLs. When you select LAN node, Cisco DCNM-SAN displays only Ethernet switches and Ethernet links. Under the fabric node, VSANs are ordered by a VSAN ID. The segmented VSANs are placed under the fabric node. The label next to the segmented VSAN indicates the number of segments. You can expand a segmented VSAN and the segments under that VSAN. Right-click one of the folders in the tree and click a menu item from the pop-up menu. You see the appropriate configuration dialog box.

The default name for the fabric is the name, IP address, or WWN for the principal switch in VSAN 1. If VSAN 1 is segmented, the default name is chosen from a principal switch with the smallest WWN. The fabric names you see are as follows:

- Fabric <sysName>
- Fabric <ipAddress>
- Fabric <sWWN>

You can change the fabric name using Cisco DCNM-SAN.

**DETAILED STEPS**

**Step 1**
Choose Server > Admin.
You see the Control Panel dialog box.

**Step 2**
Double-click the fabric name and enter the new name of the fabric.

**Step 3**
Click Apply to change the name.

Filtering

Cisco DCNM-SAN has a filtering mechanism that displays only the data that you are interested in. To filter, first select the fabric and VSAN from the Logical Domains pane. This action narrows the scope of what is displayed in the Fabric pane. Any information that does not belong to the selected items is dimmed. Also, any information that does not belong to the selected items is not displayed in the tables in the Information pane. The filter that you select is displayed at the top right of the Cisco DCNM-SAN window.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![_icon]</td>
<td>Shows online help.</td>
</tr>
</tbody>
</table>

Table 7-3 Cisco DCNM-SAN Client Main Toolbar (continued)
To further narrow the scope, select attributes from the Physical Attributes pane. The Cisco DCNM-SAN table, display, and filter criteria change accordingly.

**Physical Attributes Pane**

Use the Physical Attributes pane to display a tree of the options available for managing the switches in the currently selected fabric, VSAN, or zone.

To select an option, click a folder to display the options available and then click the option. You see the table with information for the selected option in the Information pane. The Physical Attributes pane provides the following main folders:

- **Switches**—Views and configures hardware, system, licensing, and configuration files.
- **Interfaces**—Views and configures FC physical, FC logical, VFC (FCoE), Ethernet, SVC, and PortChannel interfaces.
- **FC Services**—Views and configures Fibre Channel network configurations.
- **IP**—Views and configures IP storage and IP services.
- **Security**—Views and configures MDS management and FC-SP security.
- **FCoE**—Views and configures FCoE interfaces.
- **ISLs**—Views and configures Inter-Switch Links.
- **End Devices**—Views and configures end devices.

**Note**

You cannot view the detailed physical attributes of the data center switches or monitor the connections. When you select either a data center node or a LAN node the physical attributes pane will be blank.

**Context Menu for Tables**

When you right-click in the table, you see a pop-up menu with options that vary depending on the type of option you selected in the Physical Attributes pane. You can perform various operations by right-clicking the device listed in the table. To view various options available for switches, ISLs, and end devices, refer to the procedures in the sections that follows:

**Viewing Switch Options**

When you select the datacenter node, the switch table displays all the switches that are discovered. When you select the SAN node or the fabric node, the switch table displays all the Fibre Channel switches and when you select the LAN node, the switch table displays all the Ethernet switches.

**DETAILED STEPS**

1. **Step 1** Click **Switches** in the Physical Attributes pane.
2. **Step 2** Right-click the device in the table.

   The pop-up menu provides the following options:
   - **Apply Changes**—Applies the changes to the switch.
   - **Refresh Values**—Refreshes the current values.
Cisco DCNM-SAN Client Quick Tour: Admin Perspective

- Undo Changes—Undoes modifications to the switch.
- Export to File—Exports the values to a file.
- Print Table—Prints the table.
- Detach Table—Detaches the table.
- Switch Attributes—Changes the switch properties.
- Interface Attributes—Changes the interface properties.
- Element Manager—Manages this switch.
- Command Line Interface—Enables to perform command line operations.
- Copy—Copies the switch.
- Purge—Purges the switch.
- Fix Location—Fixes the switch in the current location.
- Align—Aligns the switch.
- Show End Devices—Shows the end devices.
- Expand Multiple Links—Expands the links to this switch.
- Other—Other options.
- Group—Groups switches.

Viewing ISL Options

When you select the data center node, the ISLs table displays all of the Fibre Channel and Ethernet links. When you select the LAN node, the ISLs table displays all the Ethernet links.

DETAILED STEPS

Step 1  In the Physical Attributes pane, click ISLs and then click Summary tab.
Step 2  Right-click the device in the table.

The pop-up menu provides the following options:
- Refresh Values—Refreshes the current values.
- Copy—Copies information from a specific field.
- Find—Conducts search based on the input string.
- Export to File—Exports the values to a file.
- Print Table—Prints the table.
- Detach Table—Detaches the table.
- Interface Attributes—Changes the interface properties.
- Element Manager—Manages the device.
- FCIP Tunnel Attributes—Changes FCIP tunneling properties.
- Create Port Channel—Creates port channel.
- Re-enable—Reenables a disabled device.
- Enable FC-SP—Enables FC-SP.
- SAN Extension Tuner—Optimizes FCIP performance.
- Purge—Purges the device.

**Note**
When you select a port channel from the table, the pop-up menu will have the following additional options:
- Member Attributes—Changes the member properties.
- Channel Attributes—Changes the port channel properties.
- Edit—Edits the channel properties.

**Viewing End Device Options**

**DETAILED STEPS**

**Step 1**
In the Physical Attributes pane, click **End Devices** and then click the **Summary** tab.

**Step 2**
Right-click the device in the table.

The pop-up menu provides the following options:
- Apply Changes—Applies the changes to the device.
- Refresh Values—Refreshes the current values.
- Copy—Copies the information specific to the field.
- Paste—Pastes the copied text.
- Undo Changes—Undoes modifications to the device.
- Find—Searches for information depending on the input string.
- Export to File—Exports the values to a file.
- Print Table—Prints the table.
- Detach Table—Detaches the table.
- Device Attributes—Changes the device properties.
- Interface Attributes—Changes the interface properties.
- Element Manager—Manages this device.
- Command Line Interface—Enables you to perform command line operations.
- Copy—Copies the switch.
- Purge—Purges the switch.
- Fix Location—Fixes the switch in the current location.
- Align—Aligns the switch.
- Ping—Pings another device.
- Trace Route—Determines the route taken by packets across the network.
- Select Dependent Ports—Selects dependent ports.
- Group—Groups devices.
Information Pane

Use the Information pane to display tables of information associated with the option selected from the menu tree in the Logical Domains or Physical Attributes panes. The Information pane toolbar provides buttons for performing one or more of the operations shown in Table 7-4.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Applies configuration changes.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Refreshes table values.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Opens the appropriate dialog box to make a new row in the table.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Deletes the currently highlighted rows from the table.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Copies data from one row to another.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Pastes the data from one row to another.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Undoes the most recent change.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Finds a specified string in the table.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Exports and saves information to a file.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Prints the contents of the Information pane.</td>
</tr>
<tr>
<td><img src="Image" alt="icon" /></td>
<td>Displays a non-editable copy of the table in the Information pane in its own window, which you can move around the screen.</td>
</tr>
</tbody>
</table>
Note: After making changes, you must save the configuration or the changes will be lost when the device is restarted.

Note: The buttons that appear on the toolbar vary according to the option that you select. They are activated or deactivated (dimmed) according to the field or other object that you select in the Information pane.

**Detachable Tables**

Detachable tables in Cisco DCNM-SAN allow you to detach tables and move them to different areas on your desktop so that you can compare similar tables from different VSANs. You can keep informational tables open from one view while you examine a different area in Cisco DCNM-SAN. To detach tables, click the Detach Table icon in the Information pane in Cisco DCNM-SAN.

**Fabric Pane**

Use the Fabric pane to display the graphical representation of your fabric. Table 7-5 explains the graphics you may see displayed, depending on which devices you have in your fabric.

<table>
<thead>
<tr>
<th>Icon or Graphic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Director class MDS 9000 Fibre Channel switch." /></td>
<td>Director class MDS 9000 Fibre Channel switch.</td>
</tr>
<tr>
<td><img src="image" alt="Non-director class MDS 9000 Fibre Channel switch." /></td>
<td>Non-director class MDS 9000 Fibre Channel switch.</td>
</tr>
<tr>
<td><img src="image" alt="Nexus 7000 switch." /></td>
<td>Nexus 7000 switch.</td>
</tr>
<tr>
<td><img src="image" alt="Nexus FCoE or Fibre Channel switch." /></td>
<td>Nexus FCoE or Fibre Channel switch.</td>
</tr>
<tr>
<td><img src="image" alt="Catalyst LAN switch." /></td>
<td>Catalyst LAN switch.</td>
</tr>
<tr>
<td><img src="image" alt="Generic Fibre Channel switch." /></td>
<td>Generic Fibre Channel switch.</td>
</tr>
<tr>
<td><img src="image" alt="Cisco SN5428." /></td>
<td>Cisco SN5428.</td>
</tr>
<tr>
<td>Icon or Graphic</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>\</td>
<td>Dashed or dotted orange line through a device indicates that the device is manageable but there are operational problems.</td>
</tr>
<tr>
<td>✗</td>
<td>Dashed or dotted orange X through a device or link indicates that the device or ISL is not working properly.</td>
</tr>
<tr>
<td>\</td>
<td>A red line through a device indicates that the device is not manageable.</td>
</tr>
<tr>
<td>✗</td>
<td>A red X through a device or link indicates that the device is down or that the ISL is down.</td>
</tr>
<tr>
<td>📱</td>
<td>Fibre Channel HBA (or enclosure).</td>
</tr>
<tr>
<td>🗄️</td>
<td>Fibre Channel target (or enclosure).</td>
</tr>
<tr>
<td>🕵️‍♂️</td>
<td>iSCSI host.</td>
</tr>
<tr>
<td>🚂</td>
<td>Fibre Channel ISL and edge connection.</td>
</tr>
<tr>
<td>🚂</td>
<td>Fibre Channel PortChannel.</td>
</tr>
<tr>
<td>- - - -</td>
<td>IP ISL and edge connection.</td>
</tr>
<tr>
<td>- - - -</td>
<td>IP PortChannel.</td>
</tr>
<tr>
<td>- - - -</td>
<td>DWDM connection.</td>
</tr>
<tr>
<td>- - - -</td>
<td>NPV connection.</td>
</tr>
<tr>
<td>☽</td>
<td>Fibre Channel loop (storage).</td>
</tr>
</tbody>
</table>
If a switch or director is grayed out, Cisco DCNM-SAN can no longer communicate with it.

The bottom of the Fabric pane has the following tabs:

- **Fabric**—When displaying multiple fabrics, each fabric has its own tab. You can switch between fabrics by clicking on their respective tabs.
- **Log**—Displays messages that describe Cisco DCNM-SAN operations, such as fabric discovery.

When viewing large fabrics in the Fabric pane, it is helpful to do the following tasks:

- Turn off end device labels.
- Collapse loops.
- Collapse expanded multiple links (collapsed multiple links are shown as very thick single lines).
- Dim or hide portions of your fabric by VSAN.

**Note**

When a VSAN, zone, or zone member is selected in the VSAN tree, the map highlighting changes to identify the selected objects. To remove this highlighting, click the **Clear Highlight** button on the Fabric pane toolbar or choose **Clear Highlight** from the pop-up menu.

### Context Menus

When you right-click an icon in the Fabric pane, you see a pop-up menu with options that vary depending on the type of icon selected. The various options available for different objects include the following:

- Open an instance of Device Manager for the selected switch.
- Open a CLI session for the selected switch.
- Copy the display name of the selected object.
- Execute a ping or traceroute command for the device.
- Show or hide end devices.
- View attributes.
- Quiesce and disable members for PortChannels.
- Set the trunking mode for an ISL.
- Create or add to a PortChannel for selected ISLs.

The Fabric pane has its own toolbar with options for saving, printing, and changing the appearance of the map. When you right-click the map, a pop-up menu appears that provides options (duplicated on the toolbar) for changing the appearance of the map.

### Table 7-5 Cisco DCNM-SAN Graphics (continued)

<table>
<thead>
<tr>
<th>Icon or Graphic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Cloud Icon]</td>
<td>IP cloud (hosts). This icon is also used to represent a fabric when viewing a SAN (multiple fabrics) in the Cisco DCNM-SAN Fabric pane.</td>
</tr>
<tr>
<td>![Box Around Icon]</td>
<td>Any device, cloud, or loop with a box around it means that there are hidden links attached.</td>
</tr>
</tbody>
</table>
Cisco DCNM-SAN Client Quick Tour: Admin Perspective

**Note**
You can launch web-based or non-web-based applications from the Fabric pane. To do this, you assign an IP address to the storage port or enclosure. Then right-click to bring up the pop-up menu, and select Device Manager.

**Saving the Map**

You can save the map in the Fabric Pane as an image, or as an editable Visio diagram. You can save the map with or without labels on the links. The created Visio diagram is editable and saved in two layers:

- The default layer includes all switches and links in the fabric.
- The end devices layer includes the end devices and can be turned off to remove end devices from the Visio diagram.

To save the map as a Visio diagram, choose Files > Export > Visio and choose Map or Map with link labels. The saved Visio diagram retains the viewing options that you selected from the Fabric pane. For example, if you collapse multiple links in the map and export the links as a Visio diagram, the Visio diagram shows those multiple links as one solid link.

The Show Tech Support option from the Tools menu also supports saving the map as a Visio diagram.

**Purging Down Elements**

The Fabric pane allows you to refresh the map at any time by clicking the Refresh Map icon. The Refresh Map icon redraws the map but does not purge elements that are down. To purge down elements you can:

- Choose Server > Purge Down Elements. This purges all down elements in the fabric.
- Right-click the Fabric pane and choose Purge Down Elements.
- Right-click a down element and choose Purge. This action purges only this element from the fabric.

**Note**
If you select an element that is not down and purge it, that element will reappear on the next fabric discovery cycle.

**Multiple Fabric Display**

Cisco DCNM-SAN can display multiple fabrics in the same pane as shown in Figure 7-3.
The information for both fabrics is displayed; you do not need to select a seed switch. To see details of a fabric, select the tab for that fabric at the bottom of the Fabric pane, or double-click the Cloud icon for the fabric in the SAN tab.

**Note**

Enclosure names should be unique. If the same enclosure name is used for each port, Cisco DCNM-SAN shows a host/target enclosure connected to both fabrics. To fix this problem, you can either disable auto-creation or create unique enclosure names.

### Filtering by Groups

You can filter the Fabric pane display by creating groups of switches or end ports.

**DETAILED STEPS**

**Step 1** Right-click a switch or end port in the Fabric pane map and select **Group > Create**.
You see the Edit User Defined Group dialog box as shown in Figure 7-4.

**Figure 7-4  Edit User Defined Group Dialog Box**

![Edit User Defined Group Dialog Box](image)

**Step 2**  Enter a group name in the **Name** field.

**Step 3**  Use the arrows to move additional switches or end ports from the **Available** column to the **Selected** column.

**Step 4**  Click **OK** to save the group.

---

To add a switch or end port to an existing group in Cisco DCNM-SAN.

**DETAILED STEPS**

**Step 1**  Right-click a switch or end device and select **Group > Add To > YourGroupName**.

You see the Edit User Defined Group dialog box as shown in see Figure 7-4.

**Step 2**  Use the arrows to move additional switches or end ports from the **Available** column to the **Selected** column.

**Step 3**  Click **OK** to save the updated group.

---

To filter the display by a group you have created.

**DETAILED STEPS**

**Step 1**  Expand the **Groups** folder in the Logical Domains pane.

You see the list of groups that you have created as shown in Figure 7-5.
Launching Cisco DCNM-SAN Client

As of Cisco SAN-OS 3.x and NX-OS Release 4.x, the Fabric Manager Client login procedure has changed.

Launching Fabric Manager Client in Cisco SAN-OS Release 3.2(1) and Later

You can launch Fabric Manager Client.

Network administrators must initially launch Cisco DCNM-SAN Client using Cisco DCNM-SAN Web Server, as described in the following procedure. Once an administrator has installed the Cisco DCNM-SAN Client icon on your desktop, you can double-click the icon to launch the Cisco DCNM-SAN Client.
Launching Cisco DCNM-SAN Client

DETAILED STEPS

Step 1  Open your browser and enter the IP address where you installed Cisco DCNM-SAN Server, or enter localhost if you installed Cisco DCNM-SAN Server on your local workstation.

You see the Cisco DCNM Web Client Login dialog box.

Step 2  Enter your user name and password and click Login.

You see the Cisco DCNM Web Client Summary page.

Step 3  Click the Download link in the upper right corner of the page.

You see the Download page for Cisco DCNM-SAN and Device Manager.
Step 4 Click the link for Cisco DCNM-SAN.

If you are launching Cisco DCNM-SAN Client for the first time, you see a message asking whether you want to create shortcuts for Cisco DCNM-SAN.

Step 5 Click Yes to create shortcuts for Cisco DCNM-SAN.

Note This message only appears the first time you launch Cisco DCNM-SAN Client. If you select No, your selection will be remembered and you will not be prompted to make a selection again. In this case, you will need to launch Cisco DCNM-SAN Client using the Cisco DCNM-SAN Web Client.

Step 6 When the software is installed and icons are created on your desktop, double-click the Cisco DCNM-SAN icon to launch Cisco DCNM-SAN.

You see the Cisco DCNM-SAN Login dialog box.
Step 7 Enter the Cisco DCNM-SAN Server user name and password.

Step 8 Check the Use SNMP Proxy check box if you want Cisco DCNM-SAN Client to communicate with Cisco DCNM-SAN Server through a TCP-based proxy server.

Step 9 Click Login. Once you successfully log in to Cisco DCNM-SAN Server, you can set the seed switch and open the fabrics that you are entitled to access.

---

**Note** When you launch Cisco DCNM-SAN Client for the first time or when there are no available fabrics, you see the Discover New Fabric dialog box.

You see the Discover New Fabric dialog box.

---

**Note** Only network administrators can discover new fabrics.
**Step 10** Click the Ethernet (CDP) radio button to discover using Cisco Discovery Protocol (CDP).

**Step 11** Starting from NX-OS Release 4.2(0), Fabric Manager uses Cisco Discovery Protocol to discover Ethernet switches such as Nexus 5000, Nexus 7000, Catalyst 4000, and Catalyst 6000 switches. You need to use a CDP seed switch for a CDP discovery. Set the fabric seed switch to the Cisco MDS 9000 Family switch or Cisco Nexus 5000 Series that you want Fabric Manager to use.

**Step 12** Choose the Auth-Privacy option according to the privacy protocol you have configured on your switch:

- If you have not configured the switch with a privacy protocol, then choose Auth-Privacy option MD5 (no privacy).
- If you have configured the switch with your privacy protocol, choose your Auth-Privacy choice.

**Note** You may use SNMP v2 credentials for CDP discovery as the most of the Catalyst switches do not use MD5-DES for configuration.

**Note** If you want a clean fabric discovery, remove the fabric and rediscover it. If you want a clean LAN discovery, unmanage LAN, remove the CDP seed switch and then rediscover it.

**Step 13** Enter the username and password for the switch.

**Step 14** (Optional) To limit the discovery, specify the VSAN range. Scoping limits the resources discovered by Cisco DCNM-SAN client. You can either include a range of VSANs to be discovered or exclude a range of VSANs from being discovered.

- To limit the discovery to a range of VSANs, click Included VSAN List radio button. Specify the range of VSANs.
- To exclude a range of VSANs from being discovered, click Excluded VSAN List radio button. Specify the range of VSANs to be excluded.

**Step 15** Click Discover.

You see the Control Panel dialog box.

**Figure 7-11** Control Panel Dialog Box: Open Tab

You see the included and excluded VSANs list under the Fabric tab.
Note You see a message in the dialog box when the server and client are running on the same workstation and there are unlicensed fabrics in the database. You also see a message when there are unmanaged fabrics (the state of the licenses is unknown).

Note In the open tab, you see all the discovered fabrics displayed in the control panel. You need to click on the Open button to see all the discovered Ethernet switches.

**Step 16** Check the check box(es) next to the fabric(s) you want to open in the Select column, or click Discover to add a new fabric.

Note Only network administrators can continuously manage or unmanage fabrics. For more information, see the “Selecting a Fabric to Manage Continuously” section on page 5-8.

**Step 17** Click Open to open the selected fabric(s).

Note
- If you have an incomplete view of your fabric, rediscover the fabric with a user that has no VSAN restriction.
- If the fabric includes a Cisco Nexus 5000 Series switch, then the Layer 2 node appears under the Switches > Interfaces > Ethernet tree, the VFC (FCoE) node appears under the Switches > Interfaces tree, and the FCoE node appears under the Switches tree in the Physical Attributes pane.
- For Cisco Nexus 5000 Series switches in the fabric, the tooltip for the switch shows the bind information of a virtual Fibre Channel interface to its corresponding Ethernet interface, such as vfc2(eth1/4).

You can launch Cisco DCNM-SAN Client from within a running instance of Cisco DCNM-SAN.
Chapter 7 Configuring Cisco DCNM-SAN Client

Launching Cisco DCNM-SAN Client

DETAILED STEPS

Step 1  Choose File > Open or click the Open Switch Fabric icon on the Cisco DCNM-SAN toolbar. You see the Control Panel dialog box.

Step 2  Check the check box(es) next to the fabric(s) you want to open in the Select column and click Open.

Note  Changes made using Cisco DCNM-SAN are applied to the running configuration of the switches that you are managing. If you have made changes to the configuration or performed an operation (such as activating zones), Cisco DCNM-SAN prompts you to save your changes before you exit.

Launching Cisco DCNM-SAN Client Using Launch Pad

Starting from Cisco NX-OS Release 4.2(0), you can use Cisco DCNM-SAN launch pad to connect to any server by specifying the IP address of the server. With launch pad, you can connect to any Cisco DCNM-SAN Server version 3.3(0) and later. Launch pad establishes connection with the server using HTTP protocol.

DETAILED STEPS

Step 1  Open your browser and enter the IP address where you installed Cisco DCNM-SAN Server, or enter localhost if you installed Cisco DCNM-SAN Server on your local workstation.

You see the Cisco DCNM-SAN Web Server Login dialog box.

Step 2  Enter your user name and password and click Login.
You see the Cisco DCNM-SAN Web Client Summary page.

**Step 3**  Click the **Download** link in the upper right corner of the page.

You see the Download page for Cisco DCNM-SAN and Device Manager.

---

**Figure 7-14  Download Page for DCNM-SAN and Device Manager**

The Cisco Fabric and Device Manager are separate applications. Click on the links below to run them. If necessary they will be installed or updated on your local PC. Please remember to close older running applications before doing this. Once you install a 2.0 or newer version of the Fabric and Device Manager downgrade is not supported through the installer. Please uninstall the 2.0 or newer instance and install from scratch the older version.

In an environment where there are multiple Fabric Managers of non-identical versions managing different parts of the network, FM clients of a particular release may not necessarily be compatible with servers of another release. The FM Launch Pad (released in NX-OS 4.2) introduces a simpler way to circumvent compatibility matching of Fabric Manager Client and Server releases by webstarting the server's corresponding client.

---

**Product Overviews:**

- **Fabric Management**
- **Device Management**
- **Launch Pad**
- **Smart Card Driver**

**Step 4**  Click the link for **Cisco DCNM-SAN**.

You see the Cisco DCNM-SAN Server launch pad.

**Step 5**  Enter the host name of the server or IP address in the **Server URL** drop-down list.

**Step 6**  Click **Start**.
Setting Cisco DCNM-SAN Preferences

To set your preferences for the behavior of the Cisco DCNM-SAN, choose File > Preferences from the Cisco DCNM-SAN menu bar. You see the Preferences dialog box with the following tabs for setting different components of the application:

- **General**
- **SNMP**
- **Map**

The default General preferences for Cisco DCNM-SAN are as follows:

- **Show Device Name by**—Displays the switches in the Fabric pane by IP address, DNS name, or logical name. The default setting for this value is Logical Name.

- **Show WorldWideName (WWN) Vendor**—Displays the world wide name vendor name in any table or listing displayed by Cisco DCNM-SAN. Check the **Prepend Name** check box to display the name in front of the IP address of the switch. Check the **Replacing Vendor Bytes** check box to display the name instead of the IP address. The default is the Prepend Name option.

- **Show End Device Using**—Displays end devices in the Fabric pane using alias or pWWN alias. The default setting for this value is Alias.

- **Show Shortened iSCSI Names**—Displays the default setting for this value is OFF.

- **Show Timestamps as Date/Time**—Displays timestamps in the date/time format. If this preference is not checked, timestamps are displayed as elapsed time. The default setting is enabled (checked).

- **Telnet Path**—Displays the path for the telnet.exe file on your system. The default is telnet.exe, but you need to browse for the correct location.
Setting Cisco DCNM-SAN Preferences

Note

If you browse for a path or enter a path and you have a space in the pathname (for example, \program files\telnet.exe), then the path will not work. To get the path to work, you must manually place quotes around it (for example, "c:\program files\telnet.exe").

- **Use Secure Shell instead of Telnet**—Specifies whether to use SSH or Telnet when using the CLI to communicate with the switch. If enabled, you must specify the path to your SSH application. The default setting is disabled.
- **Confirm Deletion**—Displays a confirmation pop-up window when you delete part of your configuration using Cisco DCNM-SAN. The default setting is enabled (checked).
- **Export Tables with Format**—Specifies the type of file that is created when you export a table using Device Manager. The options are tab-delimited or XML. The default setting is Tab-Delimited.
- **Show CFS Warnings**—Shows warning messages if CFS is not enabled on all switches for a selected feature.

The default SNMP preferences for Cisco DCNM-SAN are as follows:

- **Retry request 1 time(s) after 5 sec timeout**—You can set the retry value to 0-5, and the timeout value to 3-30.
- **Trace SNMP packets in Log**—The default setting for this value is ON.
- **Enable Audible Alert when Event Received**—The default setting for this value is OFF.

The default Map preferences for Cisco DCNM-SAN are as follows:

- **Display Unselected VSAN Members**—Displays the unselected VSAN members in the Fabric pane. The default setting for this value is ON.
- **Display End Devices**—Displays the fabric’s end devices in the Fabric pane. The default setting for this value is ON.
- **Display End Device Labels**—Displays the fabric’s end device labels in the Fabric pane. The default setting for this value is OFF.
- **Expand Loops**—Displays the loops in the fabric as individual connections in the Fabric pane. The default setting for this value is OFF.
- **Expand Multiple Links**—Displays multiple links in the Fabric pane as separate lines instead of one thick line. The default setting for this value is OFF.
- **Open New Device Manager Each Time**—Opens a new instance of Device Manager each time that you invoke it from a switch in your fabric. The default value is OFF, which means that only one instance of Device Manager is open at a time.
- **Select Switch or Link from Table**—Allows you to select a switch or link in the Fabric pane by clicking the switch or link in a table in the Information pane. The default setting for this value is disabled (unchecked), which means clicking a switch or link in the table does not change the switch or link selection in the Fabric pane.
- **Layout New Devices Automatically**—Automatically places new devices in the Fabric pane in an optimal configuration. The default setting for this value is OFF. In this mode, when you add a new device, you must manually reposition it if the initial position does not suit your needs.
- **Use Quick Layout when Switch has 30 or more End Devices**—Displays the default setting for this value (30). You can enter any number in this field. Enter 0 to disable Quick Layout.
- **Override Preferences for Non-default Layout**—Displays the default setting for this value (ON).
• **Automatically Save Layout**—If this option is enabled, any changes in the layout are automatically saved. The default setting for this value is ON.

• **Detach Overview Window**—Allows you to easily center the Fabric pane on the area of the fabric that you want to see. (This feature is useful for large fabrics that cannot be displayed entirely within the Fabric pane.) Bring up the overview window by clicking the Show/Hide Overview Window button. It overlays the fabric window and remains there until you click the Show/Hide Overview Window button again. If you enable this preference, you can detach the overview window and move it to one side while you access the Fabric pane. The default setting for this value is disabled (unchecked).

### Network Fabric Discovery

Cisco DCNM-SAN collects information about the fabric topology through SNMP queries to the switches that are connected to Cisco DCNM-SAN. The switch replies after having discovered all devices connected to the fabric by using the information from its FSPF technology database and the Name Server database and collected using the Fabric Configuration Server’s request/response mechanisms that are defined by the FC-GS-3/4 standard. When you start Cisco DCNM-SAN, you enter the IP address (or host name) of a seed switch for discovery.

After you start Cisco DCNM-SAN and the discovery completes, Cisco DCNM-SAN presents you with a view of your network fabric, including all discovered switches, hosts, and storage devices.

### Network LAN Discovery

Starting from NX-OS Release 4.2(0), you can discover Nexus and Catalyst Ethernet switches using Cisco Discovery Protocol (CDP). DataCenter 3(DC3) switches are displayed under Datacenter and LAN nodes. Cisco DCNM-SAN displays basic information about DC3 switches and its ISLs.

### Viewing Ethernet Switches

**DETAILED STEPS**

1. **Step 1** Click the LAN node under Datacenter node.
2. **Step 2** Click Switches tab in the Information pane.

You can see the switch information as shown in Figure 7-16.
**Figure 7-16 Ethernet Switch Information**

![Ethernet Switch Information](image)

**Note**  
Datacenter is the parent node of SAN and LAN nodes. The SAN node remains in the tree as the parent for all the fabrics.

---

### Removing a LAN

**DETAILED STEPS**

**Step 1**  
Choose **Server > Admin**.

You can see the switch information as shown in **Figure 7-17**.
Modifying the Device Grouping

Because not all devices are capable of responding to FC-GS-3 requests, different ports of a single server or storage subsystem may be displayed as individual end devices on the Cisco DCNM-SAN map.

DETAILED STEPS

Step 1 Expand End Devices and then choose Storage or Hosts in the Physical Attributes pane.
You see the end devices displayed in the Information pane.

Step 2 Click one of the devices in the Fabric pane, or click the Enclosures tab of the Information pane, and then click the device name (in the Name field) that you want to include in the enclosure.

Step 3 Enter a name to identify the new enclosure in the Fabric pane map.

Step 4 Click once on the device name in the Name field. To select more than one name, press the Shift key and click each of the other names.

Step 5 Press Ctrl-C to copy the selected name(s).

Step 6 Press Ctrl-V to paste the device name into the Name field.

Note To remove devices from an enclosure, triple click the device name and press Delete. To remove an enclosure, repeat this step for each device in the enclosure.
Using Alias Names as Enclosures

DETAILED STEPS

**Step 1**  
Expand End Devices and choose **Hosts** or **Storage** from the Physical Attributes pane. You see the list of devices in the Information pane. The NxPorts tab is the default.

**Step 2**  
Right-click the enclosure names that you want to convert to alias names and choose **Alias > Enclosure** as shown in Figure 7-18.

![Figure 7-18: Alias Enclosure](image)

The **Alias > Enclosures** window appears as shown in Figure 7-19. It contains a list of expressions. You can also add expressions to the list and modify expressions in the current list.

![Figure 7-19: List of Expressions](image)

**Step 3**  
Click the **Apply Changes** icon to save the changes and then click **Close**.
Modifying the Device Grouping

Note
Cisco DCNM-SAN uses the regular expressions to convert multiple alias names into one enclosure. The alias names should be in the same expression pattern rule. You can create enclosure names from selected aliases using the regular expressions list.

Using Alias Names as Descriptions

DETAILED STEPS

Step 1  Choose End Devices and from the Physical Attributes pane.

Step 2  Click the General tab.

You see the list of devices in the Information pane.

Step 3  Select the device names that you want to populate the description with alias names and then click Alias > Enclosure button as shown in Figure 7-20.

You see the alias names are copied to corresponding rows in the description column.

Figure 7-20  Data Population: Alias to Description

Note
Cisco DCNM-SAN does not parse or format the alias name while copying.
Controlling Administrator Access with Users and Roles

Cisco MDS 9000 Family switches support role-based management access whether using the CLI or Cisco DCNM-SAN. This lets you assign specific management privileges to particular roles and then assign one or more users to each role.

The default-role contains the access permissions needed by a user to access the GUI (Cisco DCNM-SAN and Device Manager). These access permissions are automatically granted to all users in order for them to use the GUI.

Cisco DCNM-SAN uses SNMPv3 to establish role-based management access. After completing the setup routine, a single role, user name, and password are established. The role assigned to this user allows the highest level of privileges, which includes creating users and roles. Use the Cisco Cisco DCNM-SAN to create roles and users and to assign passwords as required for secure management access in your network.

Using Cisco DCNM-SAN Wizards

Cisco DCNM-SAN Client provides the following wizards to facilitate common configuration tasks:

- **VSAN**—Creates VSANs on multiple switches in the fabric and sets VSAN attributes including interop mode, load balancing, and FICON.
- **Zone Edit Tool**—Creates zone sets, zones, and aliases. Adds members to zones and edits the zone database.
- **IVR Zone**—Creates IVR zone sets, zones, and aliases. Enables IVR NAT and auto-topology. Adds members to IVR zones, and edits the IVR zone database.
- **FCoE**—Creates virtual Fibre Channel (FC) interfaces and VLAN-VSAN mappings, and binds virtual FC interfaces to Ethernet interfaces or PortChannels.
- **PortChannel**—Creates PortChannels from selected ISLs either manually or automatically. Sets PortChannel attributes such as channel ID and trunking mode.
- **FCIP**—Creates FCIP links between Gigabit Ethernet ports. Enables Fibre Channel write acceleration and IP compression.
- **DPVM**—Establishes dynamic port VSAN membership, enables autolearning, and activates the DPVM database.
- **Port Security**—Prevents unauthorized access to Cisco MDS switches and reports these intrusions to the administrator.
- **iSCSI**—Creates zones for iSCSI initiators and adds a VSAN to a target-allowed VSAN list.
- **NPV**—Reduces the number of Fibre Channel domain IDs in SANs.
- **QoS**—Sets QoS attributes for zones in the selected VSAN.
- **IP ACL**—Creates ordered IP access control lists and distributes to selected switches in the fabric.
- **License Install**—Facilitates download and installation of licenses in selected switches in the fabric.
- **Software Install**—Verifies image compatibility and installs software images on selected switches in the fabric.
Cisco DCNM-SAN Troubleshooting Tools

Cisco DCNM-SAN has several troubleshooting tools available from the toolbar or Tools menu.

- **Zone Merge Analysis**—The zone merge analysis tool (available from the Zone menu) enables you to determine if zones will merge successfully when two Cisco MDS switches are interconnected. If the interconnected switch ports allow VSANs with identical names or contain zones with identical names, then Cisco DCNM-SAN verifies that the zones contain identical members. The merge analysis tool can be run before attempting a merge or after fabrics are interconnected to determine zone merge failure causes.

- **End-to-End Connectivity**—Cisco DCNM-SAN’s end-to-end connectivity analysis tool uses FC Ping to verify interconnections between Cisco MDS switches and end-device (HBAs and storage devices) in a particular VSAN. In addition to basic connectivity, Cisco DCNM-SAN can optionally verify the following:
  - Paths are redundant.
  - Zones contain at least two members.

End devices are connected to a manageable switch (have a currently active in-band or out-of-band management path.)

- **Switch Health Analysis**—You can run an in-depth switch health analysis with Cisco DCNM-SAN. It verifies the status of all critical Cisco MDS switches, modules, ports, and Fibre Channel services. Over 40 conditions are checked. This tool provides a very fast, simple, and thorough way to assess Cisco MDS switch health.

- **Fabric Configuration Analysis**—Cisco DCNM-SAN includes a fabric configuration analysis tool. It compares the configurations of all Cisco MDS switches in a fabric to a reference switch or a policy file. You can define what functions to check and what type of checks to perform. The analysis can look for mismatched values, and missing or extra values. If all configuration checking is performed for all functions, over 200 checks are performed for each Cisco MDS switch.

After the analysis is run, the results are displayed with details about the issues that were discovered. You can automatically resolve configuration differences by selecting them and clicking the **Resolve** button. Cisco DCNM-SAN automatically changes the configuration to match the reference switch or policy file.

Integrating Cisco DCNM-SAN and Data Center Network Management Software

Cisco DCNM-SAN and Data Center Network Management (DCNM) software are the two major components in the Cisco next-generation data center environment. Cisco DCNM-SAN configures Cisco Nexus 5000 Series switches and Cisco MDS 9000 Series switches. DCNM software configures Cisco Nexus 5000 and Cisco Nexus 7000 Series switches. The scope of the Cisco DCNM-SAN software is confined to SAN while the scope of the DCNM-LAN software is limited to the LAN network.

In a typical data center environment, the mixture of SAN and LAN topology are becoming increasingly common. Since the two management software are not designed to work across their topology limits, users are not able to navigate to Cisco DCNM-SAN from DCNM-LAN software and vice versa.

Integrating Cisco DCNM-SAN and DCNM-LAN provides a single platform to manage the networks in data center 3.0 and it provides seamless user experience under specific configuration. Starting from Cisco MDS NX-OS Release 4.2, the directory structure has changed to accommodate the integration of Cisco DCNM-SAN with Cisco Nexus 5000 Series products.
Launching a Switch from the Topology Map

DETAILED STEPS

Step 1 In the Cisco DCNM-SAN fabric pane, right-click the Nexus switch in the LAN map that you want to open with DCNM.

You see the pop-up menu as shown in Figure 7-21.

Figure 7-21 Open with DCNM

Step 2 In the pop up menu, click DCNM and select appropriate context.
Device Manager

This chapter contains descriptions and instructions for using the Device Manager. This chapter contains the following sections:

- Information About Device Manager, page 8-1
- Device Manager Features, page 8-2
- Using Device Manager Interface, page 8-2
- Setting Device Manager Preferences, page 8-9

Information About Device Manager

Device Manager provides a graphical representation of a Cisco MDS 9000 Family switch chassis, a Cisco Nexus 5000 Series switch chassis, or a Cisco Nexus 7000 Series switch chassis including the installed switching modules, the supervisor modules, the status of each port within each module, the power supplies, and the fan assemblies.

Note

Device Manager support for Cisco Nexus 7000 Series switches is only for FCoE. Non-FCoE modules appear as Unsupported Card.

The tables in the DCNM-SAN Information pane basically correspond to the dialog boxes that appear in Device Manager. However, while DCNM-SAN tables show values for one or more switches, a Device Manager dialog box shows values for a single switch. Also, Device Manager provides more detailed information for verifying or troubleshooting device-specific configuration than DCNM-SAN.

Device Manager Release 4.2 and later provides enhanced security using multiple perspectives (simple and advanced) allowing role based-access to its features. The Device Manager perspective filters out menu items that are not relevant to the user. Users with server admin role, can only access a subset of the fabric related features. The server admin role will not be able to manage Device Manager users or connected clients.

Device Manager Release 5.0 and later supports all the software features that are offered by Cisco NX-OS for managing Cisco MDS 9148 and 9124 Multilayer Fabric switches. Cisco MDS 9148 Multilayer Fabric Switch is a 48-port (1/2/4/8G) FC 1RU switch based on the Sabre ASIC and Cisco MDS 9124 Multilayer Fabric switch is a 1/2/4/8G switch module for HP BladeServer based on the Sabre ASIC. Device Manager and DCNM-SAN allow you to discover, display, configure, monitor and service both these new switches. Device Manager also supports the following Cisco Nexus 2000 Series Fabric Extenders on a Cisco Nexus 5000 Series switch that runs Cisco NX-OS Release 5.0(1):
Cisco Nexus 2148T Fabric Extender—It has four 10-Gigabit Ethernet fabric interfaces for its uplink connection to the parent Cisco Nexus 5000 Series switch and eight 1-Gigabit Ethernet or 10-Gigabit Ethernet host interfaces for its downlink connection to servers or hosts.

Cisco Nexus 2232PP Fabric Extender—It has eight 10-Gigabit Ethernet fabric interfaces with SFP+ interface adapters for its uplink connection to the parent Cisco Nexus 5000 Series switch and 32 10-Gigabit Ethernet fabric interfaces with SFP+ interface adapters for its downlink connection to servers or hosts.

Cisco Nexus 2248TP Fabric Extender—It has four 10-Gigabit Ethernet fabric interfaces with small form-factor pluggable (SFP+) interface adapters for its uplink connection to the parent Cisco Nexus 5000 Series switch and 48 1000BASE-T (1-Gigabit) Ethernet host interfaces for its downlink connection to servers or hosts.

Device Manager allows you to discover and display these Fabric Extenders. Cisco Device Manager and the Cisco DCNM-SAN client support provisioning and monitoring of the 48-port 8-Gbps Advanced Fibre Channel switching module (DS-X9248-256K9) and the 32-port 8-Gbps Advanced Fibre Channel switching module (DS-X9232-256K9).

Device Manager Features

Device Manager provides two views: Device View and Summary View. Use Summary View to monitor interfaces on the switch. Use Device View to perform switch-level configurations including the following:

- Configure virtual Fibre Channel interfaces.
- Configure Fibre Channel over Ethernet (FCoE).
- Configure zones for multiple VSANs.
- Manage ports, PortChannels, and trunking.
- Manage SNMPv3 security access to switches.
- Manage CLI security access to the switch.
- Manage alarms, events, and notifications.
- Save and copy configuration files and software image.
- View hardware configuration.
- View chassis, module, port status, and statistics.

Using Device Manager Interface

This section describes the Device Manager interface as shown in Figure 8-1.
The menu bar at the top of the Device Manager main window provides options for managing and troubleshooting a single switch. The menu bar provides the following options:
Information About Device Manager

- Device—Opens an instance of Device Manager, sets management preferences, sets the page layout, opens a Telnet/SSH session with the current switch, exports a device image, and closes the Device Manager application.
- Physical—Allows you to view and manage inventory, modules, temperature sensors, power supplies, fans, and the entire system.
- Interface—Allows you to configure and manage PortChannels, as well as Fibre Channel, Ethernet, iSCSI, and FICON ports. Also provides diagnostic, management and monitoring capabilities, as well as SPAN and port tracking.
  Note The Interface > Port Channels menu option does not appear if the Cisco Nexus 5000 Series switch is in NPV mode and runs a Cisco NX-OS release prior to 4.2(1).
- FC—Allows you to configure and manage VSAN, domain, and name server characteristics. Also provides advanced configuration capabilities.
- FCoE—Allows you to configure the FCoE parameters and map VSANs to VLANs on a Cisco Nexus 5000 Series switch.
  Note The FCoE menu option appears only if the Cisco Nexus 5000 Series switch runs Cisco NX-OS Release 4.0(1a) or later releases.
- FICON—Allows you to configure and manage FICON VSANs, configure RLIR ERL information, swap selected FICON ports, and view FICON port numbers.
- IP—Allows you to configure and manage the following types of information: FCIP, iSCSI, iSNS, routes, VRRP, and CDP.
- Security—Allows you to configure and manage FCSP, port security, iSCSI security, SNMP security, common roles, SSH, AAA, and IP ACLs.
- Admin—Allows you to save, copy, edit, and erase the switch configuration, monitor events, manipulate Flash files, manage licenses, configure NTP, use CFS, and reset the switch. Also enables you to use the show tech support, show cores, and show image commands.
- Logs—Shows the various logs: message, hardware, events, and accounting. Also displays FICON link incidents, and allows you to configure the syslog setup.
- Help—Displays online help topics for specific dialog boxes in the Information pane.

Toolbar Icons

The Device Manager toolbar provides quick access to many Device Manager features. Once the icon is selected, a dialog box may open that allows configuration of the feature. The toolbar provides the main Device and Summary View icons as shown in Table 8-1.
Table 8-1 Device Manager Main Toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Open Device" /></td>
<td>Opens the Device Manager view for another switch, with the option to open this view in a separate window.</td>
</tr>
<tr>
<td><img src="image" alt="Refresh Display" /></td>
<td>Communicates with the switch and displays the information in the Device Manager view.</td>
</tr>
<tr>
<td><img src="image" alt="Command-Line Interface" /></td>
<td>Opens a separate CLI command window to the switch.</td>
</tr>
<tr>
<td><img src="image" alt="Configure Selected" /></td>
<td>Opens a configuration dialog box for the selected component (line card or port).</td>
</tr>
<tr>
<td><img src="image" alt="SysLog" /></td>
<td>Opens a window that lists the latest system messages that occurred on the switch.</td>
</tr>
<tr>
<td><img src="image" alt="VSANs" /></td>
<td>Opens the VSAN dialog box that provides VSAN configuration for the switch.</td>
</tr>
<tr>
<td><img src="image" alt="Save Configuration" /></td>
<td>Saves the current running configuration to the startup configuration.</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copies configuration file between server and switch.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle FICON/Interface Port Labels" /></td>
<td>Toggles the FICON and interface port labels.</td>
</tr>
<tr>
<td><img src="image" alt="Select VSAN" /></td>
<td>Filters the port display to show only those ports belonging to the selected VSAN.</td>
</tr>
<tr>
<td><img src="image" alt="Help" /></td>
<td>Accesses online help for Device Manager.</td>
</tr>
</tbody>
</table>

Dialog Boxes

If a toolbar icon is selected, a dialog box may open that allows configuration of the selected feature. The dialog box may include table manipulation icons. See the “Information Pane” section on page 7-5 for descriptions of these icons.
Information About Device Manager

Tabs

Click the **Device** tab on the Device Manager main window to see a graphical representation of the switch chassis and components.

---

**Note**

The Device view also shows the switch chassis information of the Cisco Nexus 2000 Series Fabric Extenders (FEXs) that are connected to a Cisco Nexus 5000 Series switch that runs Cisco NX-OS Release 5.0(1).

---

Click the **Summary** tab on the Device Manager main window to see a summary of active interfaces on a single switch, as well as Fibre Channel and IP neighbor devices. The Summary View also displays port speed, link utilization, and other traffic statistics. There are two buttons in the upper left corner of the Summary View tab used to monitor traffic. To monitor traffic for selected objects, click the **Monitor Selected Interface Traffic Util%** button. To display detailed statistics for selected objects, click the **Monitor Selected Interface Traffic Details** button. You can set the poll interval, the type or Rx/Tx display, and the thresholds.

---

**Note**

The Summary tab does not display the utilization statistics (Util%) of virtual Fibre Channel interfaces for Cisco Nexus 5000 Series switches that run Cisco NX-OS Release 4.2.

Legend

The legend at the bottom right of the Device Manager indicates port status, as follows:

**Colors**

- Green—The port is up.
- Brown—The port is administratively down.
- Red cross—The port is down or has failed as a result of either hardware failure, loopback Diagnostic failure, or link failure.
- Red square—The port is down or has failed as a result of failure other than described for red cross.
- Amber—The port has a minor fault condition as a result of either signal loss, synchronization loss, credit loss, LIP F8 receiver failure, non operational sequence receiver, or off-line sequence receiver failure.
- Gray—The port is unreachable.
- Blue—The port is out of service.

**Labels**

- X—Link failure
- E—ISL
- TE—Multi-VSAN ISL
- F—Host/storage
- FL—F loop
- I—iSCSI
- SD—SPAN destination
• CH—Channel
• CU—Control Unit
• NP—Proxy N-Port (NPV Mode)
• TNP—Trunking NP_Port (NPV Mode)
• TF—Trunking F_Port
• f—vFC Present (Cisco Nexus 5000 Series switches only)

Supervisor and Switching Modules

In the Device View, you can right-click an object and get information on it, or configure it. If you right-click a module, the menu shows the module number and gives you the option to configure or reset the module. If you right-click a port, the menu shows the port number and gives you the option to configure, monitor, enable/disble, set beacon mode, or perform diagnostics on the port.

Tip
You can select multiple ports in Device Manager and apply options to all the selected ports at one time. Either select the ports by clicking the mouse and dragging it around them, or hold down the Control key and click each port.

To enable or disable a port, right-click the port and click Enable or Disable from the pop-up menu. To enable or disable multiple ports, drag the mouse to select the ports and then right-click the selected ports. Then click Enable or Disable from the pop-up menu.

To manage trunking on one or more ports, right-click the ports and click Configure. In the dialog box that appears, right-click the current value in the Trunk column and click nonTrunk, trunk, or auto from the pull-down list.

To create PortChannels using Device Manager, click PortChannels from the Interface menu.

Note
To create a PortChannel, all the ports on both ends of the link must have the same port speed, trunking type, and administrative state.

Context Menus

Context menus are available in both Device Manager views by right-clicking a device or table.

From Device View:
• Device—Right-click a system, module, or power supply to bring up a menu that gives you the option to configure or reset the device.
• Port—Right-click a port to bring up a menu that shows you the number of the port you have clicked, and to give you the option to configure, monitor, enable, disable, set beacon mode, or perform diagnostics on the port.

From Summary View:
• Table—Right-click the table header to show a list of which columns to display in that table: Interface, Description, VSANs, Mode, Connected To, Speed (Gb), Rx, Tx, Errors, Discards, and Log. Click the Description field to bring up the appropriate configuration dialog box for the port type.
Launching Device Manager

To launch Device Manager from your desktop, double-click the Device Manager icon and follow the instructions described in the Cisco DCNM Installation and Licensing Guide.

DETAILED STEPS

Step 1
You can choose one of the following three steps

a. Right-click the switch you want to manage on the Fabric pane map and choose Device Manager from the menu that appears.

b. Double-click a switch in the Fabric pane map.

c. Select a switch in the Fabric pane map and choose Tools > Device Manager.

You see the Device Manager open dialog box as shown in Figure 8-2.

Figure 8-2  Device Manager: Open Dialog Box

![Device Manager Open Dialog Box]

- Device Name: 172.22.46.220
- User Name:
- Password:
- SNMPv3 Auth-Privacy: MD5
- Proxy SNMP through FMS
- FM Server Proxy: MD5-DES
- Auth-Privacy: MD5
- SHA

Step 2
Enter the IP address of the device.

Step 3
Enter the user name and password.

Step 4
Check the Proxy SNMP through FMS check box if you want Device Manager Client to use a TCP-based proxy server.

Step 5
Choose the Auth-Privacy option according to the privacy protocol you have configured on your switch:

a. If you have not configured the switch with a privacy protocol, then choose Auth-Privacy option MD5 (no privacy).

b. If you have configured the switch with your privacy protocol, choose your Auth-Privacy choice.

Step 6
Click Open to open the Device Manager.
Setting Device Manager Preferences

To set your preferences for the behavior of the Device Manager application, choose **Device > Preferences** from the Device menu. You can set the following preferences:

- **Retry Requests x Time(s) After x sec Timeout**—Allows you to set the retry request values. The default settings are 1 time after a 5-second timeout.
- **Enable Status Polling Every x secs**—Allows you to set the status polling value. The default setting is enabled (checked) with a time of 40 seconds.
- **Trace SNMP Packets in Message Log**—Allows you to set whether Device Manager traces SNMP packets and logs the trace. The default setting is disabled (unchecked).
- **Register for Events After Open, Listen on Port 1163**—Allows you to register this switch so that events are logged once you open Device Manager. The default setting is enabled (checked).
- **Show WorldWideName (WWN) Vendor**—Displays the world wide name vendor name in any table or listing displayed by Device Manager. If **Prepend** is checked, the name is displayed in front of the IP address of the switch. If **Replace** is checked, the name is displayed instead of the IP address. The default setting is enabled (checked) with the **Prepend** option.
- **Show Timestamps as Date/Time**—Displays timestamps in the date/time format. If this preference is not checked, timestamps are displayed as elapsed time. The default setting is enabled (checked).
- **Telnet Path**—Sets the path for the telnet.exe file on your system. The default is `telnet.exe`, but you need to browse for the correct location.

**Note**  If you browse for a path or enter a path and you have a space in the pathname (for example, `c:\program files\telnet.exe`), then the path will not work. To get the path to work, manually place quotes around it (for example, "c:\program files\telnet.exe").

- **Use Secure Shell Instead of Telnet**—Specifies whether to use SSH or Telnet when using the CLI to communicate with the switch. If enabled, you must specify the path to your SSH application. The default setting is disabled.
- **CLI Session Timeout x secs (0= disable)**—Specifies the timeout interval for a CLI session. Enter 0 to disable (no timeout value). The default setting is 30 seconds.
- **Show Tooltips in Physical View**—Determines whether tooltips are displayed in Physical (Device) View. The default setting is enabled (checked).
- **Label Physical View Ports With:**—Specifies the type of label to assign to the ports when you are in Physical (Device) View. The options are FICON and Interface. The default setting is Interface.
- **Export Table**—Specifies the type of file that is created when you export a table using Device Manager. The options are Tab-Delimited or XML. The default setting is Tab-Delimited.
Configuring Performance Manager

This chapter describes how DCNM-SAN is used to monitor and manage a network. This chapter includes the following topics:

- Information About Performance Manager, page 9-1
- Flow Statistics, page 9-4
- Flow Setup Wizards, page 9-5

Information About Performance Manager

This section includes the following topics:

- Data Interpolation, page 9-2
- Data Collection, page 9-2
- Using Performance Thresholds, page 9-3

Performance Manager gathers network device statistics historically and provides this information graphically using a web browser. It presents recent statistics in detail and older statistics in summary. Performance Manager also integrates with external tools such as Cisco Traffic Analyzer.

The Performance Manager has three operational stages:

- Definition—The Flow Wizard sets up flows in the switches.
- Collection—The Web Server Performance Collection screen collects information on desired fabrics.
- Presentation—Generates web pages to present the collected data through DCNM-SAN Web Server.

Performance Manager can collect statistics for ISLs, hosts, storage elements, and configured flows. Flows are defined based on a host-to-storage (or storage-to-host) link. Performance Manager gathers statistics from across the fabric based on collection configuration files. These files determine which SAN elements and SAN links Performance Manager gathers statistics for. Based on this configuration, Performance Manager communicates with the appropriate devices (switches, hosts, or storage elements) and collects the appropriate information at fixed five-minute intervals.

Performance Manager uses a round-robin database to hold the statistical data collected from the fabric. This data is stored based on the configured parameters in the collection configuration file. At each polling interval, Performance Manager gathers the relevant statistics and stores them in the round-robin database. This database is a fixed size and will not grow beyond its preset limits.
Performance Manager creates a series of archived data to hold summarized information present in the real-time round-robin database. This archived data is used to generate daily, weekly, monthly, and yearly consolidated reports. In this way, Performance Manager maintains significant historical data without the cost of an ever-increasing database size.

**Note**

You must restart Performance Manager if you change the user credentials on DCNM-SAN Server.

### Data Interpolation

One of the unique features of Performance Manager is its ability to interpolate data when statistical polling results are missing or delayed. Other performance tools may store the missing data point as zero, but this can distort historical trending. Performance Manager interpolates the missing data point by comparing the data point that preceded the missing data and the data point stored in the polling interval after the missing data. This maintains the continuity of the performance information.

### Data Collection

One year’s worth of data for two variables (Rx and Tx bytes) requires a round-robin database (rrd) file size of 76 K. If errors and discards are also collected, the rrd file size becomes 110 K. The default internal values are as follows:

- 600 samples of 5 minutes (2 days and 2 hours)
- 700 samples of 30 minutes (12.5 days)
- 775 samples of 2 hours (50 days)
- 300 samples of 1 day

A 1000-port SAN requires 110 MB for a year’s worth of historical data that includes errors and discards. If there were 20 switches in this SAN with equal distribution of fabric ports, about two to three SNMP packets per switch would be sent every 5 minutes for a total of about 100 request or response SNMP packets required to monitor the data.

Because of their variable counter requests, flows are more difficult to predict storage space requirements for. But in general you can expect that, each extra flow adds another 76 KB.

**Note**

Performance Manager does not collect statistics on nonmanageable and non-MDS switches. Loop devices (FL/NL) are not collected.

To setup a shared RRD path to collect PM data, perform these steps:

1. **Step 1**
   - Locate the server.properties file.
   - For Windows setup, location is: `C:\Program Files\Cisco Systems\dcm\fm\conf`
   - For Linux setup, location is: `/usr/local/cisco/dcm/fm/conf`.
2. **Step 2**
   - Add `pm.rrdpath` property file information to the server.properties file.
   - For example:
   - Add server location accessible from the DCNM server in the format:
   
   ```
   pm.rrdpath=\server_ip\public\cisco\data
   ```
Step 3  Save `server.properties` file.

Step 4  Restart the Cisco DCNM server.

---

**Note**

After the Performance Manager server is ready, the new updated location will be used to save the RRD files. Performance Manager creates a new directory `pm\db` under the specified location. Ensure that RRD files are not altered, as the Performance Manager server is actively writing into the rrd files.

---

**Using Performance Thresholds**

The Performance Manager Configuration Wizard allows you to set up two thresholds that will trigger events when the monitored traffic exceeds the percent utilization configured. These event triggers can be set as either Critical or Warning events that are reported on the DCNM-SAN web client Events browser page.

Absolute value thresholds apply directly to the statistics gathered. These statistics, as a percent of the total link capacity, are compared to the percent utilization configured for the threshold type. If the statistics exceed either configured threshold, an event is shown on the DCNM-SAN web client Events tab.

Baseline thresholds create a threshold that adapts to the typical traffic pattern for each link for the same time window each day, week, or every two weeks. Baseline thresholds are set as a percent of the average (110% to 500%), where 100% equals the calculated weighted average. Figure 9-1 shows an example of setting a baseline threshold for a weekly or daily option.
The threshold is set for Monday at 2 p.m. The baseline threshold is set at 130% of the average for that statistic. The average is calculated from the statistics value that occurred at 2 p.m. on Monday, for every prior Monday (for the weekly option) or the statistics value that occurred at 2 p.m. on each day, for every prior day (for the daily option).

Flow Statistics

Flow statistics count the ingress traffic in the aggregated statistics table. You can collect two kinds of statistics:

- Aggregated flow statistics to count the traffic for a VSAN.
- Flow statistics to count the traffic for a source and destination ID pair in a VSAN.

If you enable flow counters, you can enable a maximum of 1 K entries for aggregate flow and flow statistics. Be sure to assign an unused flow index to a module for each new flow. Flow indexes can be repeated across modules. The number space for flow index is shared between the aggregate flow statistics and the flow statistics.

Generation 1 modules allow a maximum of 1024 flow statements per module. Generation 2 modules allow a maximum of 2048-128 flow statements per module.

Table 9-1 explains the Flow Type radio button that defines the type of traffic monitored.
Flow Setup Wizards

The Performance Manager Flow and Performance Manager Setup wizards greatly simplify configuration. All you need to do is select the categories of statistics to capture and the wizards provide a list of flows and links to monitor. You can remove entries if desired, or just accept the provided list and start data collection. Statistics for host and storage links are not associated with a specific port on a switch, so you do not lose long term statistics if a connection is moved to a different port.

### Creating a Flow Using Performance Manager Flow Wizard

**DETAILED STEPS**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Step 1** | Choose **Performance > Create Flows**. Specify how you want to determine and add new flows as shown in **Figure 9-2**. For this, you have to define traffic counters between source and destination devices, via one of these options:  
- In a VSAN - For this option, click **VSAN**.  
- Based on high traffic devices - For this option, click **Device Traffic**. Note that PM collections must already be turned on in order to use this option. If PM collection is not turned on for the selected fabric, then an error message will appear and you cannot continue. |
| **Step 2** | If you have clicked **VSAN**, then: |

---

**Table 9-1 Performance Manager Flow Types**

<table>
<thead>
<tr>
<th>Flow type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host-&gt;Storage</td>
<td>Unidirectional flow, monitoring data from the host to the storage element</td>
</tr>
<tr>
<td>Storage-&gt;Host</td>
<td>Unidirectional flow, monitoring data from the storage element to the host</td>
</tr>
<tr>
<td>Both</td>
<td>Bidirectional flow, monitoring data to and from the host and storage elements</td>
</tr>
</tbody>
</table>
Flow Setup Wizards

Figure 9-2 Create Flows Dialog Box

a. Click the drop-down menu in the VSAN field.
b. Choose the list of VSANs provided by the flow configuration wizard.
c. Click the drop-down menu in the Zone field.
d. Choose the list of zones provided by the flow configuration wizard.
e. Click **Next** to continue to the next window as shown in Figure 9-3. 
Choose items in the Possible Flow Pairs area.


Click **Add** to create the selected flow.

Choose items in the Existing Flows for Vsan area.

Click **Remove** to remove the selected flow.

If you have clicked **Device Traffic**, then:

Click **Next**.

You see the Define Traffic Flows page.

Specify a traffic utilization percentage threshold value in the Show device ports with traffic > text box.

Specify whether you want to look at the peak or average traffic values, over the last day or last week, for the traffic types:

- Host<>Storage
- Storage<>Storage
- Both

Click **Next**.

If new flow pairs are found, you will see the Review Traffic Flows page, where possible flow pairs are shown in a table, along with the traffic parameters used to identify them.

To see only rows having a specific source or destination device, specify the name of the device in the **Filter** text box.
f. To create a flow, click the corresponding row in the Possible Flow Pairs table, and then click Add. To remove an existing flow, click the corresponding row in the Existing Flow Pairs table, and then click Remove.

**Step 4**  
Click Finish to restart the Performance Manager collection. You see the Confirmation dialog box as shown in Figure 9-4.

![Confirmation Dialog Box](image)

To verify the newly created flow, choose Physical Attributes > End Devices > Flow Statistics. The newly created flows are displayed.

---

**Note**  
Performance Manager Collection can be enabled for LAN devices and traffic counters are collected periodically.
CHAPTER 10

Monitoring the Network

This chapter describes how the DCNM-SAN manages the network. In particular, SAN discovery and network monitoring are two of its key network management capabilities.

This chapter contains the following sections:

- Information About Network Monitoring, page 10-1
- Device Discovery, page 10-2
- Topology Mapping, page 10-3

Information About Network Monitoring

DCNM-SAN provides extensive SAN discovery, topology mapping, and information viewing capabilities. DCNM-SAN collects information on the fabric topology through SNMP queries to the switches connected to it. DCNM-SAN recreates a fabric topology, presents it in a customizable map, and provides inventory and configuration information in multiple viewing options such as fabric view, device view, summary view, and operation view.

Once DCNM-SAN is invoked, a SAN discovery process begins. Using information polled from a seed Cisco MDS 9000 Family switch, including Name Server registrations, Fibre Channel Generic Services (FC-GS), Fabric Shortest Path First (FSPF), and SCSI-3, DCNM-SAN automatically discovers all devices and interconnects on one or more fabrics. All available switches, host bus adapters (HBAs), and storage devices are discovered. The Cisco MDS 9000 Family switches use Fabric-Device Management Interface (FMDI) to retrieve the HBA model, serial number and firmware version, and host operating-system type and version discovery without host agents. DCNM-SAN gathers this information through SNMP queries to each switch. The device information discovered includes device names, software revision levels, vendor, ISLs, PortChannels, and VSANs.

Monitoring Health and Events

DCNM-SAN works with the Cisco MDS 9000 Family switches to show the health and status of the fabric and switches. Information about the fabric and its components is gathered from multiple sources, including Online System Health Management, Call Home, system messages, and SNMP notifications. This information is then made available from multiple menus on DCNM-SAN or Device Manager.
Information About Network Monitoring

DCNM-SAN Events Tab

The DCNM-SAN Events tab, available from the topology window, displays the events DCNM-SAN received from sources within the fabric. These sources include SNMP events, RMON events, system messages, and system health messages. The Events tab shows a table of events, including the event name, the source and time of the event, a severity level, and a description of the event. The table is sortable by any of these column headings.

Note

Cisco DCNM SAN client displays events that are created after the client session is started. Any event created before the current user login session will not be retrieved and displayed.

Event Information in DCNM-SAN Web Server Reports

The DCNM-SAN web server client displays collections of information gathered by the Performance Manager. This information includes events sent to the DCNM-SAN Server from the fabric. To open these reports, choose Performance Manager > Reports. This opens the web client in a web browser and displays a summary of all fabrics monitored by the DCNM-SAN Server. Choose a fabric and then click the Events tab to see a summary or detailed report of the events that have occurred in the selected fabric. The summary view shows how many switches, ISLs, hosts, or storage elements are down on the fabric and how many warnings have been logged for that SAN entity. The detailed view shows a list of all events that have been logged from the fabric and can be filtered by severity, time period, or type.

Events in Device Manager

Device Manager displays the events when you choose Logs > Events. Device Manager can display the current list of events or an older list of events that has been stored on the DCNM-SAN host. The event table shows details on each event, including time, source, severity, and a brief description of the event.

SAN Discovery and Topology Mapping

DCNM-SAN provides extensive SAN discovery, topology mapping, and information viewing capabilities. DCNM-SAN collects information on the fabric topology through SNMP queries to the switches connected to it. DCNM-SAN recreates a fabric topology, presents it in a customizable map, and provides inventory and configuration information in multiple viewing options.

Device Discovery

Once DCNM-SAN is invoked, a SAN discovery process begins. Using information polled from a seed Cisco MDS 9000 Family switch, including Name Server registrations, Fibre Channel Generic Services (FC-GS), Fabric Shortest Path First (FSPF), and SCSI-3, DCNM-SAN automatically discovers all devices and interconnects on one or more fabrics. All available switches, host bus adapters (HBAs), and storage devices are discovered. The Cisco MDS 9000 Family switches use Fabric-Device Management Interface (FMDI) to retrieve HBA model, serial number and firmware version, and host operating-system type and version discovery without host agents. DCNM-SAN gathers this information through SNMP queries to each switch. The device information discovered includes device names, software revision levels, vendor, ISLs, PortChannels, and VSANs.
For a VSAN change involving a third-party switch, DCNM-SAN will need a second discovery to show the correct topology due to the discovery dependency when there is any change in a mixed VSAN. The first discovery finds the third-party switch and the subsequent discovery will show the information on which VSAN it is going to join and can discover the end devices connected to it. You can wait for the subsequent discovery or trigger a manual discovery.

**Topology Mapping**

DCNM-SAN is built upon a topology representation of the fabric. DCNM-SAN provides an accurate view of multiple fabrics in a single window by displaying topology maps based on device discovery information. You can modify the topology map icon layout with an easy-to-use, drag-and-drop interface. The topology map visualizes device interconnections, highlights configuration information such as zones, VSANs, and ISLs exceeding utilization thresholds. The topology map also provides a visual context for launching command-line interface (CLI) sessions, configuring PortChannels, and opening device managers.

**Using the Topology Map**

The DCNM-SAN topology map can be customized to provide a view into the fabric that varies from showing all switches, end devices, and links, to showing only the core switches with single bold lines for any multiple links between switches. Use the icons along the left side of the topology map to control these views or right-click anywhere in the topology map to access the map controls.

You can zoom in or out on the topology map to see an overview of the SAN or focus on an area of importance. You can also open an overview window that shows the entire fabric. From this window, you can right-click and draw a box around the area you want to view in the main topology map view.

Another way to limit the scope of the topology display is to select a fabric or VSAN from the Logical Domains pane. The topology map displays only that fabric or VSAN.

Moving the mouse pointer over a link or switch provides a simple summary of that SAN component, along with a status indication. Right-clicking on the component brings up a pop-up menu. You can view the component in detail or access configuration or test features for that component.

Double-click a link to bring link status and configuration information to the information pane. Double-click a switch to bring up Device Manager for that switch.

**Saving a Customized Topology Map Layout**

Changes made to the topology map can be saved so that the customized view is available any time you open the DCNM-SAN Client for that fabric.

**DETAILED STEPS**

- **Step 1** Click File > Preferences to open the DCNM-SAN preferences dialog box.
- **Step 2** Click the Map tab and check the Automatically Save Layout check box to save any changes to the topology map as shown in Figure 10-1.
Information About Network Monitoring

Chapter 10 Monitoring the Network

Figure 10-1 DCNM-SAN Preferences

Step 3 Click Apply, and then click OK to save this change.

Using Enclosures with DCNM-SAN Topology Maps

Because not all devices are capable of responding to FC-GS-3 requests, different ports of a single server or storage subsystem may be displayed as individual end devices on the topology map. See the “Modifying the Device Grouping” section on page 7-37 to group these ports into a single enclosure for DCNM-SAN.

Clicking Alias->Enclosure displays hosts and storage elements in the Information pane. This is a shortcut to naming enclosures. To use this shortcut, highlight each row in the host or storage table that you want grouped in an enclosure then click Alias -> Enclosure. This automatically sets the enclosure names of each selected row with the first token of the alias.

Mapping Multiple Fabrics

To log into multiple fabrics, the same username and password must be used. The information for both fabrics is displayed, with no need to select a seed switch. To see details of a fabric, click the tab for that fabric at the bottom of the Fabric pane, or double-click the fabric’s cloud icon. To continuously manage a fabric using DCNM-SAN, follow the instructions in the “Managing a Cisco DCNM-SAN Server Fabric” section on page 5-7.

Inventory Management

The Information pane in DCNM-SAN shows inventory, configuration, and status information for all switches, links, and hosts in the fabric. Inventory management includes vendor name and model, and software or firmware versions. Select a fabric or VSAN from the Logical Domains pane, and then select the Summary tab in the Information pane to get a count of the number of VSANS, switches, hosts, and
storage elements in the fabric. See the “Cisco DCNM-SAN Client Quick Tour: Admin Perspective” section on page 7-6 for more information on the DCNM-SAN/DCNM-SAN user interface.

Using the Inventory Tab from DCNM-SAN Web Server

If you have configured DCNM-SAN Web Server, you can launch this application and access the Inventory tab to see a summary of the fabrics managed by the DCNM-SAN Server. The Inventory tab shows an inventory of the selected SAN, fabric, or switch. See Chapter 4, “” for more information on how to configure and use DCNM-SAN Web Server.

**DETAILED STEPS**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Point your browser at the DCNM-SAN Web Server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the <strong>Events</strong> tab and then the <strong>Details</strong> tab to view the system messages. The columns in the events table are sortable. In addition, you can use the Filter button to limit the scope of messages within the table.</td>
</tr>
</tbody>
</table>

Viewing Logs from Device Manager

You can view system messages from Device Manager if Device Manager is running from the same workstation as the DCNM-SAN Server. Choose **Logs > Events > current** to view the system messages on Device Manager. The columns in the events table are sortable. In addition, you can use the Find button to locate text within the table.

You can view switch-resident logs even if you have not set up your local syslog server or your local PC is not in the switch's syslog server list. Due to memory constraints, these logs will wrap when they reach a certain size. The switch syslog has two logs: an NVRAM log that holds a limited number of critical and greater messages and a nonpersistent log that contains notice or greater severity messages. Hardware messages are part of these logs.

**Note**

To view syslog local logs, you need to configure the IP address of the DCNM-SAN Server in the syslog host.
Monitoring Performance

This chapter describes how to configure Performance Monitoring tools for Cisco DCNM-SAN and Device Manager. These tools provide real-time statistics as well as historical performance monitoring. This chapter contains the following sections:

- Information About Performance Monitoring, page 11-1
- Configuring Performance Manager, page 11-2
- Configuring the Summary View in Device Manager, page 11-4
- Configuring Per Port Monitoring using Device Manager, page 11-4
- Displaying Performance Manager Reports, page 11-7
- Generating Performance Manager Reports, page 11-9
- Exporting Data Collections, page 11-12
- Analyzing SAN Health, page 11-13

Information About Performance Monitoring

Device Manager provides an easy tool for monitoring ports on the Cisco MDS 9000 Family switches. This tool gathers statistics at a configurable interval and displays the results in tables or charts. Real-time performance statistics are useful for dynamic troubleshooting and fault isolation within the fabric. Real-time statistics gather data on parts of the fabric in user-configurable intervals and display these results in DCNM-SAN and Device Manager. For a selected port, you can monitor any of a number of statistics including traffic in and out, errors, class 2 traffic, and FICON data.

Real-Time Performance Monitoring

Device Manager provides an easy tool for monitoring ports on the Cisco MDS 9000 Family switches. This tool gathers statistics at a configurable interval and displays the results in tables or charts. These statistics show the performance of the selected port in real-time and can be used for performance monitoring and troubleshooting. For a selected port, you can monitor any of a number of statistics including traffic in and out, errors, class 2 traffic, and FICON data. You can set the polling interval from ten seconds to one hour, and display the results based on a number of selectable options including absolute value, value per second, and minimum or maximum value per second.
Device Manager checking for oversubscription on the host-optimized four-port groups on relevant modules. Right-click the port group on a module and choose Check Oversubscription from the pop-up menu.

Device manager provides two performance views: the Summary View tab and the configurable monitor option per port.

**Historical Performance Monitoring**

Performance Manager gathers network device statistics historically and provides this information using DCNM-SAN client and web browser. It presents recent statistics in detail and older statistics in summary. Performance Manager also integrates with external tools such as Cisco Traffic Analyzer. See the “Information About Performance Manager” section on page 9-1 for an overview of Performance Manager.

**Configuring Performance Manager**

This section includes the following topics:

- Creating a Flow with Performance Manager, page 11-2
- Creating a Collection with Performance Manager, page 11-2
- Using Performance Thresholds, page 11-3

**Creating a Flow with Performance Manager**

With the Flow Configuration Wizard you can create host-to-storage, storage-to-host, or bidirectional flows. Once defined, you can add these flows to a collection configuration file to monitor the traffic between a host/storage element pair. The flows created become part of the collection options in the Performance Manager Configuration Wizard.

**Creating a Collection with Performance Manager**

The Performance Manager Configuration Wizard steps you through the process of creating collections using configuration files. Collections are defined for one or all VSANs in the fabric. Collections can include statistics from the SAN element types described in Table 11-1.

**Table 11-1 Performance Manager Collection Types**

<table>
<thead>
<tr>
<th>Collection Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISLs</td>
<td>Collects link statistics for ISLs.</td>
</tr>
<tr>
<td>Host</td>
<td>Collects link statistics for SAN hosts.</td>
</tr>
<tr>
<td>Storage</td>
<td>Collects link statistics for a storage elements.</td>
</tr>
<tr>
<td>Flows</td>
<td>Collects flow statistics defined by the Flow Configuration Wizard.</td>
</tr>
</tbody>
</table>
Using Performance Thresholds

The Performance Manager Configuration Wizard allows you to set up two thresholds that trigger events when the monitored traffic exceeds the percent utilization configured. These event triggers can be set as either Critical or Warning events that are reported on the DCNM-SAN web client Events browser page.

You must choose either absolute value thresholds or baseline thresholds that apply to all transmit or receive traffic defined in the collection. Click the **Use absolute values** radio button on the last screen of the Performance Manager Configuration Wizard to configure thresholds that apply directly to the statistics gathered. These statistics, as a percent of the total link capacity, are compared to the percent utilization configured for the threshold type. If the statistics exceed either configured threshold, an event is shown on the DCNM-SAN web client Events tab.

As an example, the collection has absolute value thresholds set for 60% utilization (for warning) and 80% utilization (for critical). If Performance Manager detects that the traffic on a 1-Gigabit link in its collection exceeds 600 Mbps, a warning event is triggered. If the traffic exceeds 800 Mbps, a critical event is triggered.

Baseline thresholds are defined for a configured time of day or week (1 day, 1 week, or 2 weeks). The baseline is created by calculating the average of the statistical results for the configured time each day, week, or every 2 weeks. Table 11-2 shows an example of the statistics used to create the baseline value for a collection defined at 4 pm on a Wednesday.

<table>
<thead>
<tr>
<th>Baseline Time Window</th>
<th>Statistics Used in Average Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 day</td>
<td>Every prior day at 4 pm</td>
</tr>
<tr>
<td>1 week</td>
<td>Every prior Wednesday at 4 pm</td>
</tr>
<tr>
<td>2 weeks</td>
<td>Every other prior Wednesday at 4 pm</td>
</tr>
</tbody>
</table>

Baseline thresholds create a threshold that adapts to the typical traffic pattern for each link for the same time window each day, week, or every 2 weeks. Baseline thresholds are set as a percent of the average (110% to 500%), where 100% equals the calculated average.

As an example, a collection is created at 4 pm on Wednesday, with baseline thresholds set for 1 week, at 150% of the average (warning) and 200% of the average (critical). Performance Manager recalculates the average for each link at 4 pm every Wednesday by taking the statistics gathered at that time each Wednesday since the collection started. Using this as the new average, Performance Manager compares each received traffic statistic against this value and sends a warning or critical event if the traffic on a link exceeds this average by 150% or 200% respectively.

Table 11-3 shows two examples of 1-Gigabit links with different averages in our example collection and at what traffic measurements the Warning and Critical events are sent.

<table>
<thead>
<tr>
<th>Average</th>
<th>Warning Event Sent at 150%</th>
<th>Critical Event Sent at 200%</th>
</tr>
</thead>
<tbody>
<tr>
<td>400 Mbps</td>
<td>600 Mbps</td>
<td>800 Mbps</td>
</tr>
<tr>
<td>200 Mbps</td>
<td>300 Mbps</td>
<td>400 Mbps</td>
</tr>
</tbody>
</table>

Set these thresholds on the last screen of the Collections Configuration Wizard by checking the **Send events if traffic exceeds threshold** check box.
Configuring the Summary View in Device Manager

DETAILED STEPS

Step 1  
Click the Summary tab on the main display.
You see all of the active ports on the switch, as well as the configuration options available from the Summary view shown in Figure 11-1.

![Figure 11-1  Device Manager Summary Tab](image)

Step 2  
Choose a value from the Poll Interval drop-down list.

Step 3  
Decide how you want your data to be interpreted by looking at the Show Rx/Tx drop-down menu. The table updates each polling interval to show an overview of the receive and transmit data for each active port on the switch.

Step 4  
Select a value from the Show Rx/Tx drop-down list. If you select Util%, you need to also select values from the two Show Rx/Tx > %Util/sec drop-down lists. The first value is the warning level and the second value is the critical threshold level for event reporting.

Note that you can also display percent utilization for a single port by selecting the port and clicking the Monitor Selected Interface Traffic Util % icon.

Configuring Per Port Monitoring using Device Manager

The configurable monitor per port option gives statistics for in and out traffic on that port, errors, class 2 traffic and other data that can be graphed over a period of time to give a real-time view into the performance of the port.
Displaying DCNM-SAN Real-Time ISL Statistics

This section includes the following topics:

- “Using the Performance Manager Configuration Wizard” section on page 11-6
- “Viewing Performance Statics Using DCNM-SAN” section on page 11-6

You can configure DCNM-SAN to gather ISL statistics in real time. These ISL statistics include receive and transmit utilization, bytes per second, as well as errors and discards per ISL.

DETAILED STEPS

Step 1  Choose Performance > ISLs in Real-Time.

You see any ISL statistics in the Information pane as shown in Figure 11-3.
Figure 11-3 ISL Performance in Real Time

<table>
<thead>
<tr>
<th>Poll Interval</th>
<th>Rx</th>
<th>Tx</th>
<th>Switch</th>
<th>To Interface</th>
<th>Speed</th>
<th>Rx Byte/s</th>
<th>Rx Pkts</th>
<th>Rx ULPs</th>
<th>Tx Byte/s</th>
<th>Tx Pkts</th>
<th>Tx ULPs</th>
<th>Total Errors</th>
<th>Total Discards</th>
</tr>
</thead>
<tbody>
<tr>
<td>10572-21-46-223T12</td>
<td>7-QA</td>
<td>0</td>
<td>422</td>
<td>320</td>
<td>0</td>
<td>422</td>
<td>9</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QB</td>
<td>0</td>
<td>200</td>
<td>0</td>
<td>0</td>
<td>200</td>
<td>10</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QA</td>
<td>0</td>
<td>300</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QB</td>
<td>0</td>
<td>300</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QB</td>
<td>0</td>
<td>300</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QA</td>
<td>0</td>
<td>300</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10572-21-46-223T12</td>
<td>2-QB</td>
<td>0</td>
<td>300</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Step 2** Select a value from the **Poll Interval** drop-down list.

**Step 3** Select two values from the **Bandwidth** utilization thresholds drop-down lists, one value for the minor threshold and one value for the major threshold.

The table shown updates each polling interval to show the statistics for all configured ISLs in the fabric.

**Step 4** Select a row in the table to highlight that ISL in blue in the Topology map.

### Using the Performance Manager Configuration Wizard

See the “Viewing Performance Information” section on page 4-25.

### Viewing Performance Statics Using DCNM-SAN

You can configure DCNM-SAN to gather historic and real time statistics of ISLs or End devices. These statistics include receive and transmit utilization, bytes per second, as well as errors and discards per ISL or end device.

**DETAILED STEPS**

**Step 1** Right-click the ISL or end device in the Fabric pane.

You see a context menu as shown in the Figure 11-4.

**Step 2** Select Show Statics.
Displaying Performance Manager Reports

This section includes the following topics:

- “Displaying Performance Summary” section on page 11-8
- “Displaying Performance Tables and Details Graphs” section on page 11-8
- “Displaying Performance of Host-Optimized Port Groups” section on page 11-8
- “Displaying Performance Manager Events” section on page 11-8

You can view Performance Manager statistical data using preconfigured reports that are built on demand and displayed in a web browser. These reports provide summary information as well as detailed statistics that can be viewed for daily, weekly, monthly, or yearly results.

DETAILED STEPS

Step 1  Choose **Performance > Reports** to access Performance Manager reports from DCNM-SAN.

This opens a web browser window showing the default DCNM-SAN web client event summary report.

---

**Note**  Show Statics menu will be enabled only if you add the fabric to the Performance Manager collection.
Displaying Performance Manager Reports

Step 2  Click the **Performance** tab to view the Performance Manager reports.

Performance Manager begins reporting data ten minutes after the collection is started.

---

**Note**  DCNM-SAN Web Server must be running for reports to work.

**Displaying Performance Summary**

The Performance Summary page presents a dashboard display of the throughput and link utilization for hosts, ISLs, storage, and flows for the last 24-hour period. The summary provides a quick overview of the fabric’s bandwidth consumption and highlights any hotspots.

The report includes network throughput pie charts and link utilization pie charts. Use the navigation tree on the left to show summary reports for monitored fabrics or VSANs. The summary displays charts for all hosts, storage elements, ISLs, and flows. Each pie chart shows the percent of entities (links, hosts, storage, ISLs, or flows) that measure throughput or link utilization on each of six predefined ranges. Move the mouse over a pie chart section to see how many entities exhibit that range of statistics. Double-click any pie chart to bring up a table of statistics for those hosts, storage elements, ISLs, or flows.

**Displaying Performance Tables and Details Graphs**

Click **Host**, **Storage**, **ISL**, or **Flow** to view traffic over the past day for all hosts, storage, ISLs, or flows respectively. A table lists all of the selected entities, showing transmit and receive traffic and errors and discards, if appropriate. The table can be sorted by any column heading. The table can also be filtered by day, week, month, or year. Tables for each category of statistics display average and peak throughput values and provide hot-links to more detailed information.

Clicking a link in any of the tables opens a details page that shows graphs for traffic by day, week, month, and year. If flows exist for that port, you can see which storage ports sent data. The details page also displays graphs for errors and discards if they are part of the statistics gathered and are not zero.

If you double-click a graph on a Detail report, it will launch the Cisco Traffic Analyzer for Fibre Channel, if configured. The aliases associated with hosts, storage devices, and VSANs in the fabric are passed to the Cisco Traffic Analyzer to provide consistent, easy identification.

**Displaying Performance of Host-Optimized Port Groups**

You can monitor the performance of host-optimized port groups by selecting **Performance > End Devices** and selecting **Port Groups** from the Type drop-down list.

**Displaying Performance Manager Events**

Performance Manager events are viewed through DCNM-SAN Web Server. To view problems and events in DCNM-SAN Web Server, choose a fabric and then click the **Events** tab to see a summary or detailed report of the problems and events that have occurred in the selected fabric.
Generating Performance Manager Reports

- “Generating Top10 Reports in Performance Manager” section on page 11-9
- “Generating Top10 Reports Using Scripts” section on page 11-9

Generating Top10 Reports in Performance Manager

You can generate historical Top10 reports that can be saved for later review. These reports list the entities from the data collection, with the most active entities appearing first. This is a static, one-time only report that generates averages and graphs of the data collection as a snapshot at the time the report is generated. These Top10 reports differ from the other monitoring tables and graphs in Performance Manager in that the other data is continuously monitored and is sortable on any table column. The Top10 reports are a snapshot view at the time the report was generated and are static. These are one-time reports that generate averages and graphs of the data collection as a snapshot at the time the report is generated.

**Tip**

Name the reports with a timestamp so that you can easily find the report for a given day or week.

These Top10 reports differ from the other monitoring tables and graphs in Performance Manager in that the other data is continuously monitored and is sortable on any table column. The Top10 reports are a snapshot view at the time the report was generated.

**Note**

Top10 reports require analyzing the existing data over an extended period of time and can take hours or more to generate on large fabrics.

See the “Creating SAN User Defined Reports” section on page 4-40 for information on creating a Top10 report.

Generating Top10 Reports Using Scripts

You can generate Top10 reports manually by issuing the following commands:

- On UNIX, run the script:
  ```bash
  "<user_directory>/cisco_mds9000/bin/pm.sh display pm/pm.xml <output_directory>"
  ```

- On Windows, run the script:
  ```bash
  "c:\Program Files\Cisco Systems\MDS 9000\bin\pm.bat display pm/pm.xml <output_directory>"
  ```

On UNIX, you can automate the generation of the Top10 reports on your DCNM-SANDCNM-SAN Server host by adding the following cron entry to generate the reports once an hour:

```
0 * * * * /<user_directory>/cisco_mds9000/bin/pm.sh display pm/pm.xml <output_directory>
```

If your crontab does not run automatically or Java complains about an exception similar to Example 11-1, you need to add “-Djava.awt.headless=true” to the JVMARGS command in `/<user_directory>/cisco_mds9000/bin/pm.sh`. 
Example 11-1  Example Java Exception

in thread "main" java.lang.InternalError Can't connect to X11 window server using '0.0' as the value of the DISPLAY variable.

Configuring Performance Manager for Use with Cisco Traffic Analyzer

Performance Manager works in conjunction with the Cisco Traffic Analyzer to allow you to monitor and manage the traffic on your fabric. Using Cisco Traffic Analyzer with Performance Manager requires the following components:

- A configured Fibre Channel Switched Port Analyzer (SPAN) destination (SD) port to forward Fibre Channel traffic.
- A Port Analyzer Adapter 2 (PAA-2) to convert the Fibre Channel traffic to Ethernet traffic.
- Cisco Traffic Analyzer software to analyze the traffic from the PAA-2.

DETAILED STEPS

Step 1  Set up the Cisco Traffic Analyzer according to the instructions in the Cisco MDS 9000 Family Port Analyzer Adapter 2 Installation and Configuration Note.

Step 2  Get the following three items of information:

- The IP address of the management workstation on which you are running Performance Manager and Cisco Traffic Analyzer.
- The path to the directory where Cisco Traffic Analyzer is installed.
- The port that is used by Cisco Traffic Analyzer (the default is 3000).

Step 3  Start the Cisco Traffic Analyzer.

a.  Choose Performance > Traffic Analyzer > Open.

b.  Enter the URL for the Cisco Traffic Analyzer, in the format:

   http://<ip address>:<port number>

   ip address is the address of the management workstation on which you have installed the Cisco Traffic Analyzer

   :port number is the port that is used by Cisco Traffic Analyzer (the default is :3000).

c.  Click OK.

d.  Choose Performance > Traffic Analyzer > Start.

e.  Enter the location of the Cisco Traffic Analyzer, in the format:

   D:\directory\ntop.bat

   D: is the drive letter for the disk drive where the Cisco Traffic Analyzer is installed.

   directory is the directory containing the ntop.bat file.

f.  Click OK.

Step 4  Create the flows you want Performance Manager to monitor, using the Flow Configuration Wizard. See the “Creating a Flow with Performance Manager” section on page 11-2
Step 5 Define the data collection you want Performance Manager to gather, using the Performance Manager Configuration Wizard. See the “Creating a Collection with Performance Manager” section on page 11-2.

a. Choose the VSAN you want to collect information for or choose All VSANs.

b. Check the types of items you want to collect information for (Hosts, ISLs, Storage Devices, and Flows).

c. Enter the URL for the Cisco Traffic Analyzer in the format:

   \[http://<ip address>/<directory>\]

   where:

   - ip address is the address of the management workstation on which you have installed the Cisco Traffic Analyzer, and
   - directory is the path to the directory where the Cisco Traffic Analyzer is installed.

d. Click Next.

e. Review the data collection on this and the next section to make sure this is the data you want to collect.

f. Click Finish to begin collecting data.

   **Note** Data is not collected for JBOD or for virtual ports. If you change the data collection configuration parameters during a data collection, you must stop and restart the collection process for your changes to take effect.

Step 6 Choose Performance > Reports to generate a report. Performance Manager Web Server must be running. You see Web Services; click Custom then select a report template.

   **Note** It takes at least five minutes to start collecting data for a report. Do not attempt to generate a report in Performance Manager during the first five minutes of collection.

Step 7 Click Cisco Traffic Analyzer at the top of the Host or Storage detail pages to view the Cisco Traffic Analyzer information, or choose Performance > Traffic Analyzer > Open. The Cisco Traffic Analyzer page will not open unless ntop has been started already.

   **Note** For information on capturing a SPAN session and starting a Cisco Traffic Analyzer session to view it, refer to the Cisco MDS 9000 Family Port Analyzer Adapter 2 Installation and Configuration Note.

   **Note** For information on viewing and interpreting your Performance Manager data, see the “Creating a Flow with Performance Manager” section on page 11-2.

For information on viewing and interpreting your Cisco Traffic Analyzer data, refer to the Cisco MDS 9000 Family Port Analyzer Adapter 2 Installation and Configuration Note.
For performance drill-down, DCNM-SAN Server can launch the Cisco Traffic Analyzer in-context from the Performance Manager graphs. The aliases associated with hosts, storage devices, and VSANs are passed to the Cisco Traffic Analyzer to provide consistent, easy identification.

Exporting Data Collections

This section includes the following topics:

- “Exporting Data Collections to XML Files” section on page 11-12
- “Exporting Data Collections in Readable Format” section on page 11-12

Exporting Data Collections to XML Files

The RRD files used by Performance Manager can be exported to a freeware tool called rrdtool. The rrd files are located in pm/db on the DCNM-SAN Server. To export the collection to an XML file, enter the following command at the operating system command-line prompt:

```
/bin/pm.bat xport xxx yyy
```

In this command, xxx is the RRD file and yyy is the XML file that is generated. This XML file is in a format that rrdtool is capable of reading with the command:

```
rrdtool restore filename.xml filename.rrd
```

You can import an XML file with the command:

```
bin/pm.bat pm restore <xmlFile> <rrdFile>
```

This reads the XML export format that rrdtool is capable of writing with the command:

```
rrdtool xport filename.xml filename.rrd.
```

The `pm xport` and `pm restore` commands can be found on your DCNM-SAN Server at `bin\PM.bat` for Windows platforms or `bin/PM.sh` on UNIX platforms. For more information on the rrdtool, refer to the following website: [http://www.rrdtool.org](http://www.rrdtool.org).

Exporting Data Collections in Readable Format

You can export the RRD files used by Performance Manager to a freeware tool called rrdtool and export the collection to an XML file. Cisco MDS SAN-OS Release 2.1(1a) introduces the inability to export data collections in comma-separated format (CSV). This format can be imported to various tools, including Microsoft Excel. You can export these readable data collections either from the DCNM-SAN Web Services menus or in batch mode from the command line on Windows or UNIX. Using DCNM-SAN Web Services, you can export one file. Using batch mode, you can export all collections in the pm.xml file.

**Note**

DCNM-SAN Web Server must be running for this to work.

You can export data collections to Microsoft Excel using DCNM-SAN Web Server.
DETAILED STEPS

**Step 1**  
Click the **Performance** tab on the main page.  
You see the overview table.

**Step 2**  
Click the **Flows** sub-tab.

**Step 3**  
Right-click the name of the entity you want to export and select **Export to Microsoft Excel**.  
You see the Excel chart for that entity in a pop-up window.

You can export data collections using command-line batch mode.

DETAILED STEPS

**Step 1**  
Go to the installation directory on your workstation and then go to the bin directory.

**Step 2**  
On Windows, enter `.\pm.bat export C:\Program Files\Cisco Systems\MDS 9000\pm\pm.xml <export directory>`. This creates the csv file (export.csv) in the *export directory* on your workstation.

**Step 3**  
On UNIX, enter `./pm.sh export /usr/local/cisco_mds9000/pm/pm.xml <export directory>`. This creates the csv file (export.csv) in the *export directory* on your workstation.

When you open this exported file in Microsoft Excel, the following information displays:

- Title of the entity you exported and the address of the switch the information came from.
- The maximum speed seen on the link to or from this entity.
- The VSAN ID and maximum speed.
- The timestamp, followed by the receive and transmit data rates in bytes per second.

Analyzing SAN Health

The SAN Health Advisor tool is a utility that used to monitor the performance and collect the statistics. You can perform the following tasks with this tool:

- Run Performance Monitor to collect I/O statistics
- Collect fabric inventory (switches and other devices)
- Create a graphical layout of fabric topology
- Create reports of error conditions and statistical data

You can install this tool at any SAN environment to collect I/O statistics for the specified time (usually 24 hours), generate health reports and automatically send reports to the designated system administrator for review at regular intervals.

When you start SAN Health Advisor tool, it runs in wizard mode, and prompts for inputs such as seed switch credentials, IP address of the server to which the data to be sent and all the necessary information for the software setup. As soon as the fabric is discovered, the tool starts capturing performance data, I/O statistics and error conditions.
The reports generated from the collection is stored in the $INSTALLDIR/dcm/fm/reports directory. These reports are automatically sent to the designated SAN administrator for review. In a situation where the tool fails to collect the data, it generates a report with an error message or exception. After sending the reports the tool automatically uninstalls itself and terminates all the processes that it established on the host machine.

The report that SAN Health Advisor tool generates will have the following details:

- Events
- System messages
- Analysis of connectivity
- Zone discrepancy
- System configuration
- Interface status
- Domain information
- Security settings

## Installing the SAN Health Advisor Tool

SAN Health Advisor tool can be installed and run on Windows, UNIX, and Solaris platforms. Install the package that contains the .jar file with JRE version 6.0.

*Note*  
The SAN Health tool is not installed by default when you install DCNM-SAN software.

### DETAILED STEPS

**Step 1**  
Double-click the San Health Advisor tool installer. You see the San Health Advisor tool Installer window as shown in Figure 11-5.
Step 2  Select an installation folder on your workstation for SAN Health Advisor.
On Windows, the default location is `C:\Program Files\Cisco Systems`.

Step 3  Click **Install** to start the installation.
You see the installation progressing as shown in Figure 11-6.
You see the Fabric Options dialog box as shown in Figure 11-7.
Step 4  In the Seed Switch text box, enter the IP address of the seed switch.
Step 5  Enter the user name and password for the switch.
Step 6  Select the authentication privacy option from the Auth-Privacy drop-down list box.
Step 7  Click the **Performance Collection** check box to enable the process to run for 24 hours.
Step 8  Click **Collect** to start gathering performance information.

You see the collecting dialog box as shown in Figure 11-8.
If you want to stop gathering information in the middle of the process, click Cancel. You see the message indicating performance collection is complete as shown in Figure 11-9.
Figure 11-9  SAN Health Advisor: Performance Collection Complete

Step 9  Click Uninstall to remove the SAN Health Advisor software.
Software Images

This chapter describes how to install and upgrade Cisco MDS software images. It includes the following sections:

- Information About Software Images, page 12-1
- Prerequisites for Installing Software Images, page 12-5
- Using the Software Install Wizard, page 12-10
- Performing Nondisruptive Upgrades on Fabric and Modular Switches, page 12-29
- Upgrade Status Verification, page 12-28
- Manual Upgrade on a Dual Supervisor Module Switch, page 12-35
- Quick Upgrade, page 12-39
- Downgrading from a Higher Release, page 12-40
- Maintaining Supervisor Modules, page 12-41
- Installing Generation 2 Modules in Generation 1 Chassis, page 12-42
- Replacing Modules, page 12-43

Information About Software Images

This section contains the following topics:

- Software Upgrade Methods, page 12-2
- Determining Software Compatibility, page 12-2
- Automated Upgrades, page 12-3
- Benefits of Using the Software Install Wizard, page 12-4
- Recognizing Failure Cases, page 12-5

Each switch is shipped with a Cisco MDS NX-OS or SAN-OS operating system for Cisco MDS 9000 Family switches. The Cisco MDS NX-OS consists of two images—the kickstart image and the system image. To upgrade the switch to a new image, you must specify the variables that direct the switch to the images.

- To select the kickstart image, use the KICKSTART variable.
- To select the system image, use the SYSTEM variable.
The images and variables are important factors in any install procedure. You must specify the variable and the image to upgrade your switch. Both images are not always required for each install.

Note

Unless explicitly stated, the software install procedures in this chapter apply to any switch in the Cisco MDS 9000 Family.

Software Upgrade Methods

You can upgrade software without any disruptions using the Cisco MDS NX-OS software designed for mission-critical high availability environments. To realize the benefits of nondisruptive upgrades on the Cisco MDS 9500 Directors, we highly recommend that you install dual supervisor modules.

You can upgrade any switch in the Cisco MDS 9000 Family using one of the following methods:

- Automatic—You can use the DCNM-SAN Software Install Wizard for Cisco MDS NX-OS switches as described in the “Using the Software Install Wizard” section on page 12-10.

- Manual—For information on manual upgrades, see the Cisco MDS 9020 Switch Configuration Guide and Command Reference.

- Automated, one-step upgrade using the install all command. This upgrade is nondisruptive for directors in the Cisco MDS 9500 Series (see the “Automated Upgrades” section on page 12-3).

- Quick, one-step upgrade using the reload command. This upgrade is disruptive (see the “Quick Upgrade” section on page 12-39).

Tip

The install all command compares and presents the results of the compatibility before proceeding with the installation. You can exit if you do not want to proceed with these changes.

In some cases, regardless of which process you use, the software upgrades may be disruptive. These exception scenarios can occur under the following conditions:

- A single supervisor module system with kickstart or system image changes.

- A dual supervisor module system with incompatible system software images.

Note

For high availability, you need to connect the ethernet port for both active and standby supervisors to the same network or virtual LAN. The active supervisor owns the one IP address used by these Ethernet connections. On a switchover, the newly activated supervisor takes over this IP address.

Determining Software Compatibility

If the running image and the image you want to install are incompatible, the software reports the incompatibility. In some cases, you may decide to proceed with this installation. If the active and the standby supervisor modules run different versions of the image, both images may be HA compatible in some cases and incompatible in others.

Compatibility is established based on the image and configuration:

- Image incompatibility—The running image and the image to be installed are not compatible.
Configuration incompatibility—There is a possible incompatibility if certain features in the running image are turned off as they are not supported in the image to be installed. The image to be installed is considered incompatible with the running image if one of the following statements is true:

- An incompatible feature is enabled in the image to be installed and it is not available in the running image and may cause the switch to move into an inconsistent state. In this case, the incompatibility is strict.
- An incompatible feature is enabled in the image to be installed and it is not available in the running image and does not cause the switch to move into an inconsistent state. In this case, the incompatibility is loose.

The Software Install Wizard compares and presents the results of the compatibility before proceeding with the installation. You can exit if you do not want to proceed with these changes.

When upgrading from Release 2.0(1) or later to Release 3.2(3a), modules may reload and disrupt traffic after an upgrade using the install all command if an enhanced zoning lock exists. To avoid this issue, commit or clear the zone locks and then rerun the install all command. Issue the show zone status command to check if an enhanced zoning lock exists. Do not make enhanced zoning changes while an upgrade is in progress.

To view the results of a dynamic compatibility check, issue the show incompatibility system bootflash:filename command (see Example 12-1). Use this command to obtain further information when the install all command returns the following message:

Warning: The startup config contains commands not supported by the standby supervisor; as a result, some resources might become unavailable after a switchover.

Do you wish to continue? (y/ n) [y]: n

**Example 12-1** Displays HA Compatibility Status

```
switch# show incompatibility system bootflash:new-system-image
The following configurations on active are incompatible with the system image
The following configurations on active are incompatible with the system image
1) Service : cfs , Capability : CAP_FEATURE_CFS_ENABLEDDEVICE_ALIAS
Description : CFS - Distribution is enabled for DEVICE-ALIAS
Enable requirement : STRICT
Disable command : no device-alias distribute
```

**Automated Upgrades**

The Software Install Wizard install all command upgrades all modules in any Cisco MDS 9000 Family switch. Figure 12-1 provides an overview of the switch status before and after using Software Install Wizard issuing the install all command.

**Figure 12-1** The Effect of the Software Install Wizard install all Command
The Software Install Wizard `install all` command automatically verifies if the standby supervisor module is functioning (if present). If it is not functioning, it reloads that module and uses the `force download` option `reload module slot force-dnld` command to force it to function.

Benefits of Using the **install all** Command

Benefits of Using the Software Install Wizard

The Software Install Wizard **install all** command provides the following benefits:

- You can upgrade the entire switch using just one procedure command.
- You can receive descriptive information on the intended changes to your system before you continue with the installation.
- You have the option to cancel the command. Once the effects of the command are presented, you can continue or cancel when you see this question (the default is **no**):

  Do you want to continue (y/n) [n] : y

- You can upgrade the entire switch using the least disruptive procedure.
- You can see the progress of this command on the console, Telnet, and SSH screens:
  - After a switchover process, you can see the progress from both the supervisor modules.
  - Before a switchover process, you can only see the progress from the active supervisor module.
- The Software Install Wizard command automatically checks the image integrity. This includes the running kickstart and system images.
- The Software Install Wizard command performs a platform validity check to verify that a wrong image is not used. For example, to check if an MDS 9500 Series image is used inadvertently to upgrade an MDS 9200 Series switch.
- The **Ctrl-c** escape sequence gracefully ends the command. The command sequence completes the update step in progress and returns to the switch prompt. (Other upgrade steps cannot be ended using **Ctrl-c**)
- After issuing the installation command, if any step in the sequence fails, the wizard command completes the step in progress and ends.
For example, if a switching module fails to be updated for any reason (for example, due to an unstable fabric state), then the command sequence disruptively updates that module and ends. In such cases, you can verify the problem on the affected switching module and upgrade the other switching modules.

**Recognizing Failure Cases**

The following situations cause the installation to end:

- If the standby supervisor module bootflash: file system does not have sufficient space to accept the updated image.
- If the specified system and kickstart images are not compatible.
- If the fabric or switch is configured while the upgrade is in progress.
- If the `install all` command is issued on the standby supervisor module.
- If the `install all` command does not reference the default bootflash: in a dual supervisor module configuration.
- If a module is removed while the upgrade is in progress.
- If the switch has any power disruption while the upgrade is in progress.
- If the entire path for the remote location is not specified accurately.
- If images are incompatible after an upgrade. For example, a switching module image may be incompatible with the system image, or a kickstart image may be incompatible with a system image. This is also identified by the Software Install Wizard compatibility check `show install all impact` command in the compatibility check section of the output (under the Bootable column).

**Caution**

If the installation `install all` command is ended, be sure to verify the state of the switch at every stage and reissue the command after 10 seconds. If you reissue the installation `install all` command within the 10-second span, it the command is rejected with an error message indicating that an installation is currently in progress.

**Tip**

All configurations are disallowed while the installation `install all` command is in progress. However, configurations coming through the CFS applications are allowed and may affect the upgrade procedure.

**Prerequisites for Installing Software Images**

The software image install procedure is dependent on the following factors:

- **Software images**—The kickstart and system image files reside in directories or folders that can be accessed from the Cisco MDS 9000 Family switch prompt.
- **Image version**—Each image file has a version.
- **Flash disks on the switch**—The bootflash: resides on the supervisor module and the CompactFlash disk is inserted into the slot0: device.
- **Supervisor modules**—There are single or dual supervisor modules.
Selecting the Correct Software Images for Cisco MDS 9100 Series Switches

The Supervisor-1 and Supervisor-2 modules supported by Cisco MDS 9100 Series switches require different system and kickstart images. You can determine which images to use on your switch by the naming conventions shown in Table 12-1 and Table 12-2.

Table 12-1  Supervisor Module Software Image Naming Conventions for MDS 9100 Series

<table>
<thead>
<tr>
<th>Cisco MDS 9100 Series Switch Type</th>
<th>Supervisor Module Type</th>
<th>Naming Convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>9124, 9124e, 9134, Cisco Fabric Switch for HP c-Class BladeSystem, Cisco Fabric Switch for IBM BladeCenter</td>
<td>Supervisor-2 module</td>
<td>Filename begins with m9100-s2ek9</td>
</tr>
</tbody>
</table>

Table 12-2  Software Image Naming Conventions for MDS 9100 Series

<table>
<thead>
<tr>
<th>Cisco MDS 9100 Series Switch Type</th>
<th>Supervisor Module Type</th>
<th>Naming Convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco MDS 9148 Multilayer Fabric Switch</td>
<td>Supervisor-2 module</td>
<td>Filename begins with m9100-s3ek9.</td>
</tr>
<tr>
<td>Cisco MDS 9124 Multilayer Fabric Switch</td>
<td>Supervisor-2 module</td>
<td>Filename begins with m9100-s3ek9.</td>
</tr>
</tbody>
</table>

Selecting the Correct Software Images for Cisco MDS 9200 Series Switches

The Supervisor-1 and Supervisor-2 modules supported by Cisco MDS 9200 Series switches require different system and kickstart images. You can determine which images to use on your switch by the naming conventions shown in Table 12-3.

Table 12-3  Supervisor Module Software Image Naming Conventions for MDS 9200 Series

<table>
<thead>
<tr>
<th>Cisco MDS 9200 Series Switch Type</th>
<th>Supervisor Module Type</th>
<th>Naming Convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>9222i</td>
<td>Supervisor-2 module</td>
<td>Filename begins with m9200-s2ek9</td>
</tr>
<tr>
<td>9216, 9216A or 9216i</td>
<td>Supervisor-1 module</td>
<td>Filename begins with m9200-s1ek9</td>
</tr>
</tbody>
</table>

Selecting the Correct Software Images for Cisco MDS 9500 Family Switches

The Supervisor-1 and Supervisor-2 modules supported by Cisco MDS 9500 Family switches require different system and kickstart images. You can determine which images to use on your switch by the naming conventions shown in Table 12-4.
Chapter 12  Software Images

Prerequisites for Installing Software Images

Example 12-2  show module Command Output for Supervisor-1 Modules

```
switch# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
   ... ...
5  0 Supervisor/Fabric-1 DS-X9530-SF1-K9 active*
6  0 Supervisor/Fabric-1 DS-X9530-SF1-K9 ha-standby
```

Example 12-3  show module Command Output for Supervisor-2 Modules

```
switch# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
   ... ...
7  0 Supervisor/Fabric-2 DS-X9530-SF2-K9 active *
8  0 Supervisor/Fabric-2 DS-X9530-SF2-K9 ha-standby
```

Essential Upgrade Prerequisites

During a software upgrade to Cisco SAN-OS 3.1(3), the CompactFlash CRC Checksum test runs automatically in the background. All modules that are online are tested and the installation stops if any modules are running with a faulty CompactFlash. When this occurs, the switch can not be upgraded until the situation is corrected. A system message displays the module information and indicates that you must issue the `system health cf-crc-check module` CLI command to troubleshoot. For descriptions of new commands supported by the CompactFlash checksum feature, refer to the Cisco MDS 9000 Family Command Reference.

Before attempting to migrate to any software image version, follow these guidelines:

- Customer Service
  
  Before performing any software upgrade, contact your respective customer service representative to review your software upgrade requirements and to provide recommendations based on your current operating environment.
Note If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If you purchased support directly from Cisco Systems, contact Cisco Technical Support at this URL: http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

- **Scheduling**
  
  Schedule the upgrade when the fabric is stable and steady. Ensure that everyone who has access to the switch or the network is not configuring the switch or the network during this time. All configurations are disallowed at this time.

- **Space**
  
  Verify that sufficient space is available in the location where you are copying the images. This location includes the active and standby supervisor module bootflash: (internal to the switch).
  
  - Standby supervisor module bootflash: file system.
  - Internal bootflash: offers approximately 200 MB of user space.

- **Hardware**
  
  Avoid power interruption during any install procedure. These kinds of problems can corrupt the software image.

- **Connectivity (to retrieve images from remote servers)**
  
  - Configure the IPv4 address or IPv6 address for the 10/100/1000 BASE-T Ethernet port connection (interface mgmt0).

  Note 1000 BASE-T Ethernet is only available on Supervisor-2 modules.

  - Ensure the switch has a route to the remote server. The switch and the remote server must be in the same subnetwork if you do not have a router to route traffic between subnets.

- **Images**
  
  - Ensure that the specified system and kickstart images are compatible with each other.
  - If the kickstart image is not specified, the switch uses the current running kickstart image.
  - If you specify a different system image, ensure that it is compatible with the running kickstart image.
  - Retrieve images in one of two ways:
    
    Local file—Images are locally available on the switch.
    
    Network file—Images are in a remote location and the user specifies the destination using the remote server parameters and the file name to be used locally.

- **Terminology**
  
  Table 12-5 summarizes terms used in this chapter with specific reference to the install and upgrade process.

  **Table 12-5  Terms Specific to This Chapter**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bootable</td>
<td>The modules ability to boot or not boot based on image compatibility.</td>
</tr>
<tr>
<td>impact</td>
<td>The type of software upgrade mechanism—disruptive or nondisruptive.</td>
</tr>
</tbody>
</table>
Tools

- Verify connectivity to the remote server by clicking **Verify Remote Server in the Software Install Wizard in DCNM-SAN** using the **ping** command.

- Ensure that the required space is available for the image files to be copied by using Software Install Wizard to check free disk space using the **dir** command.

- We recommend the Software Install Wizard in DCNM-SAN one-step **install all** command to upgrade your software. This wizard command upgrades all modules in any Cisco MDS 9000 Family switch (see the “Benefits of Using the Software Install Wizard” section on page 12-4 “Benefits of Using the install all Command” section on page 12-4).

- Run only one installation on a switch at any time.

- Do not issue another command while running the installation.

- Do the installation on the active supervisor module, not the standby supervisor module.

**Note**

If the switching module(s) are not compatible with the new supervisor module image, some traffic disruption may be noticed in the related modules, depending on your configuration. These modules are identified in the summary when you use issue the **Installation Wizard install all** command. You can choose to proceed with the upgrade or end at this point.

**Note**

Prior to Cisco SAN-OS Release 3.0, to preserve the FC IDs in your configuration, verify that the persistent FC ID feature is enabled before rebooting. This feature is enabled by default. In earlier releases, the default is disabled.

**Note**

The Software Install Wizard supports installation and upgrade for Cisco MDS 9020 Fabric Switch or Cisco FabricWare. For successful installation and upgrade, specify the TFTP server address that the Cisco MDS 9020 Fabric Switch should use.

**Note**

Before you use this wizard, be sure the standby supervisor management port is connected.

**Default Settings**

**Table 12-6** lists the default image settings for all Cisco MDS 9000 Family switches.
Using the Software Install Wizard

### Using the Software Install Wizard

You can use the Software Install Wizard to install Cisco NX-OS images on supported switches.

**DETAILED STEPS**

**Step 1**

Click the Software Install Wizard icon in the toolbar (see Figure 12-2).

![Software Install Wizard Icon](image)

You see the Select Switches dialog box with all switches selected by default.
### Using the Software Install Wizard

**Figure 12-3 Select Switches Dialog Box**

<table>
<thead>
<tr>
<th>Select</th>
<th>Switch</th>
<th>Model</th>
<th>Running Software Version [Standby]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>12.22-22-46-162</td>
<td>B2-CE2116</td>
<td>3.3(10)</td>
</tr>
<tr>
<td></td>
<td>12.22-22-46-272</td>
<td>B2-CE2006</td>
<td>3.3(10)</td>
</tr>
<tr>
<td></td>
<td>12.22-22-46-273</td>
<td>B2-CE2007</td>
<td>3.3(10)</td>
</tr>
<tr>
<td></td>
<td>12.22-22-46-274</td>
<td>B2-CE2008</td>
<td>3.3(10)</td>
</tr>
<tr>
<td></td>
<td>12.22-22-46-275</td>
<td>B2-CE2009</td>
<td>3.3(10)</td>
</tr>
<tr>
<td></td>
<td>12.22-22-46-276</td>
<td>B2-CE2010</td>
<td>3.3(10)</td>
</tr>
</tbody>
</table>

**Step 2**
Deselect the check box for the switch(es) for which you do not want to install images on. You must have at least one switch selected to proceed (see Figure 12-3).

**Step 3**
Click **Next** when finished.

**Step 4**
(Optional) Check the **Skip Image Download** check box and click **Next** to use images that are already downloaded (the file is already on the bootflash). Proceed to **Step 11**.

You see the Specify Software Image(s) by Model Dialog Box shown in Figure 12-4.
Figure 12-4  Specify Software Image(s) by Model Dialog Box

Step 5   Click the **Use Saved Settings** check box to load and display the previously saved settings. Settings are saved each time the Next button is clicked.

Step 6   Click the radio button for either:

a. **Local FM TFTP** to transfer files from local computer.

b. **Remote** to transfer files from a remote computer.

Step 7   If you select Local FM TFTP, proceed to **Step 10**.

Step 8   If you select Remote, click one of the Copy Files Via radio buttons transfers files (SFTP, SCP, FTP).

Step 9   Enter the server name, user name and password.

Step 10  Enter the version and the image path and then click **Apply**.

**Note**  You can manually provide the file name, if you had chosen Local FM TFTP in step 6. To do that you may double-click the table, and choose the file form the Open dialog box or manually type the file name in the cell under system.

When you enter the version string and image path, DCNM-SAN tries retrieves the default file name and the calculate the flash space required to accommodate the image file. Version string should be the current version of the version to be installed. Image path is the path to locate the software image as shown in the following example:

- **Image URI**: /tftpboot/rel/qa/5_0_0_201/gdb/m9500-sf2ek9-mzg.5.0.0.201.bin.S2
- **Path**: /tftpboot/rel/qa/5_0_0_201/gdb
- **Version String**: 5.0.0.201.S2
**Step 11**  Click the row under the System, Kickstart or SSI columns to enter image URIs. You must specify at least one image for each switch to proceed.

**Step 12**  Click Verify Remote Server and Path.
DCNM-SAN will validate the file path and server credentials. You see the output as shown in Figure 12-5

![Figure 12-5 Validation Result](image)

**Step 13**  Click OK and then click Next in the Specify Software Images by Model dialog box.
You see the Check Flash Free Space dialog box (see Figure 12-6). This dialog box shows the active (and standby, if applicable) bootflash space on each switch, and shows the status (whether there is enough space for the new images). If any switch has insufficient space, you cannot proceed. Deselect the switch without enough bootflash by going back to the first screen and unchecking the check box for that switch.

![Figure 12-6 Check Flash Free Space Dialog Box](image)

**Step 14**  Click Next.
You see the Start Install dialog box shown in .
Using the Software Install Wizard

Figure 12-7  Start Install Dialog Box

Note  There is no limit on the number of switches you can upgrade.

Step 15  Click one of the the radio buttons:
   a. **Serial**ed to upgrade one switch at a time.
   b. **Parallel** to simultaneously upgrade multiple switches.

Step 16  (Optional) Check the **Version Check Only** check box to complete the version check first and then prompt for your input to continue with installation.

Step 17  (Optional) Click **Finish** to start installation.

You see the Version Check Results dialog box shown in .
Step 18  (Optional) Check the **Install without Version check Prompting** check box to continue with the installation.

**Note**: The version check provides information about the impact of the upgrade for each module on the switch. It also shows any incompatibilities that might result. You see a final dialog box at this stage, prompting you to confirm that this check should be performed. We recommend that you do not ignore the version check results.

**Caution**: If **Install without Version check Prompting** is checked, the upgrade will proceed even if the current switch version is newer than the version you are installing.

Step 19  Click **OK** to close the wizard.

Step 20  Click **Continue to install** to start the installation.

You see the Download and Install Status dialog box shown in Figure 12-9.
Note On hosts where the TFTP server cannot be started, a warning is displayed. The TFTP server may not start because an existing TFTP server is running or because access to the TFTP port 69 has been denied for security reasons (the default setting on Linux). In these cases, you cannot transfer files from the local host to the switch.

Note Before exiting the session, be sure the upgrade process is complete. The wizard will display a status as it goes along. Check the lower left-hand corner of the wizard for the status message Upgrade Finished. First, the wizard displays the message Success followed a few seconds later by InProgress Polling. Then the wizard displays a second message Success before displaying the final Upgrade Finished.

Upgrading Services Modules

Any Fibre Channel switching module supports nondisruptive upgrades. The 14/2-port Multiprotocol Services (MPS-14/2) module supports nondisruptive upgrades for the Fibre Channel ports. Any software upgrade for the two Gigabit Ethernet ports in this module is disruptive.

Any software upgrade for the Caching Services Module (CSM) and the IP Storage (IPS) services modules is disruptive.

CSMs and IPS modules use a rolling upgrade install mechanism to guarantee a stable state for each module in the switch.
• Each IPS module in a switch requires a 5-minute delay before the next IPS module is upgraded.

• Each CSM module requires a 30-minute delay before the next CSM module is upgraded. See the Cisco MDS 9000 Family SAN Volume Controller Configuration Guide for more information on CSMs.

## Using the install all Command

### Note

Ensure that there is enough space available on the active and standby supervisor module bootflash: to store the images being installed, even if the images are supplied in slot0:. The system will automatically synchronize the images to the standby supervisor module.

To perform an automated software upgrade on any switch, follow these steps:

---

**Step 1** Log into the switch through the console, Telnet, or SSH port of the active supervisor module.

**Step 2** Create a backup of your existing configuration file, if required.

**Step 3** Verify that you have enough free space available on the active and standby supervisor module bootflash:. The download site on Cisco.com shows the size of the system image file in bytes. If there is not adequate space, delete files using the `delete filename` EXEC command.

```
switch# dir bootflash:
  12288 Jan 01 00:01:06 1980 lost+found/
  14765056 Mar 21 15:35:06 2005 m9500-sfiek9-kickstart-mz.2.1.1.bin
  15944704 Apr 06 16:46:04 2005 m9500-sfiek9-kickstart-mz.2.1.1a.bin
  48063243 Mar 21 15:34:46 2005 m9500-sfiek9-mz.2.1.1.bin
  48036239 Apr 06 16:45:41 2005 m9500-sfiek9-mz.2.1.1a.bin

Usage for bootflash://sup-local
141066240 bytes used
43493376 bytes free
184559616 bytes total
```

```
switch# show module
Mod  Ports  Module-Type                      Model              Status
---  -----  -------------------------------- ------------------ ------------
 2    32     Storage Services Module          DS-X9032-SSM       ok
 5    0      Supervisor/Fabric-1              DS-X9530-SF1-K9    active *
 6    0      Supervisor/Fabric-1              DS-X9530-SF1-K9    ha-standby
...
```

The `show module` command output shows that the standby supervisor is in slot 6. Use the `attach` command to access the supervisor module.

```
switch# attach module 6
...
switch(standby)# dir bootflash:
  12288 Jan 01 00:01:06 1980 lost+found/
  14765056 Mar 21 15:35:06 2005 m9500-sfiek9-kickstart-mz.2.1.1.bin
  15944704 Apr 06 16:46:04 2005 m9500-sfiek9-kickstart-mz.2.1.1a.bin
  48063243 Mar 21 15:34:46 2005 m9500-sfiek9-mz.2.1.1.bin
  48036239 Apr 06 16:45:41 2005 m9500-sfiek9-mz.2.1.1a.bin

Usage for bootflash://sup-local
141066240 bytes used
43493376 bytes free
184559616 bytes total
```
Using the Software Install Wizard

Chapter 12  Software Images

Step 4  Download a Cisco NX-OS system image to the active supervisor module bootflash: from a TFTP server, if necessary.

switch# copy tftp://10.16.10.100/system-img bootflash:system-img
Trying to connect to tftp server......

Note  Ensure that you download the correct Cisco NX-OS system image. The system image for Supervisor-1 modules is different from the system image for Supervisor-2 modules.

Step 5  Download a kickstart image to the active supervisor module bootflash: from a TFTP server, if necessary.

switch# copy tftp://10.16.10.100/kickstart-img bootflash:kickstart-img
Trying to connect to tftp server......

Step 6  Perform the upgrade by issuing the install all command.

Note  On a dual supervisor module switch, always use the default bootflash: in the install all command syntax. Do not qualify it with “/sup-active/” or “/sup-local”. Always use the following syntax: install all system bootflash:filename kickstart bootflash:filename.

switch# install all system bootflash:system-img kickstart bootflash:kickstart-img

Verifying image bootflash:/kickstart-img
[############################] 100% -- SUCCESS

Verifying image bootflash:/system-img
[############################] 100% -- SUCCESS

Extracting "slc" version from image bootflash:/system-img.
[############################] 100% -- SUCCESS

Extracting "ips" version from image bootflash:/system-img.
[############################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/system-img.
[############################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/kickstart-img.
[############################] 100% -- SUCCESS

Extracting "loader" version from image bootflash:/kickstart-img.
[############################] 100% -- SUCCESS

Compatibility check is done:

<table>
<thead>
<tr>
<th>Module</th>
<th>bootable</th>
<th>Impact</th>
<th>Install-type</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>2</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>3</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>4</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
</tbody>
</table>

Images will be upgraded according to following table:

Module  Image  Running-Version  New-Version  Upg-Required
Chapter 12  Software Images

Using the Software Install Wizard

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th>-----------------</th>
<th>-----------------</th>
<th>----------------</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>slc</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>1</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>2</td>
<td>ips</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>2</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>3</td>
<td>ips</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>3</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>4</td>
<td>slc</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>4</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>system</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>kickstart</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
<tr>
<td>6</td>
<td>system</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>kickstart</td>
<td>1.3(2a)</td>
<td>1.3(1)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>6</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
</tbody>
</table>

Do you want to continue with the installation (y/n)? [n] y

Install is in progress, please wait.

Syncing image bootflash:/kickstart-img to standby.
[############################] 100% -- SUCCESS

Syncing image bootflash:/system-img to standby.
[############################] 100% -- SUCCESS

Jan 18 23:40:03 Hacienda %VSHD-5-VSHD_SYSLOG_CONFIG_I: Configuring console from

Performing configuration copy.
[############################] 100% -- SUCCESS

Module 6: Waiting for module online.

Auto booting bootflash:/kickstart-img bootflash:/system-img...
Booting kickstart image: bootflash:/kickstart-img....

.................................Image verification OK

Starting kernel...
INIT: version 2.78 booting
Checking all filesystems..r.. done.
Loading system software
Uncompressing system image: bootflash:/system-img

.................Image verification OK

INIT: Entering runlevel: 3

**Step 7**

Exit the switch console and open a new terminal session to view the upgraded supervisor module using the show module command.

If the configuration meets all guidelines when the install all command is issued, all modules (supervisor and switching) are upgraded. This is true for any switch in the Cisco MDS 9000 Family.
Caution

If a nondisruptive upgrade operation fails for any reason other than those listed in the “Recognizing Failure Cases” section on page 12-5, contact your reseller or Cisco representative for further assistance.

If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If you purchased support directly from Cisco Systems, contact Cisco Technical Support at this URL: http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

Upgrading Services Modules

Any Fibre Channel switching module supports nondisruptive upgrades. The 14/2-port Multiprotocol Services (MPS-14/2) module supports nondisruptive upgrades for the Fibre Channel ports. Any software upgrade for the two Gigabit Ethernet ports in this module is disruptive.

Caution

Any software upgrade for the Caching Services Module (CSM) and the IP Storage (IPS) services modules is disruptive.

CSMs and IPS modules use a rolling upgrade install mechanism to guarantee a stable state for each module in the switch:

- Each IPS module in a switch requires a 5-minute delay before the next IPS module is upgraded.
- Each CSM module requires a 30-minute delay before the next CSM module is upgraded. Refer to the Cisco MDS 9000 Family SAN Volume Controller Configuration Guide for more information on CSMs.

When you upgrade, or downgrade, the SSI boot image on a Storage Services Module (SSM), you might disrupt traffic through the module. Table 12-7 describes how updating the SSI boot image affects SSM traffic.

<table>
<thead>
<tr>
<th>Cisco MDS SAN-OS Release</th>
<th>Traffic Type</th>
<th>Disrupts Traffic?</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.0(2b) through 2.1(1a)</td>
<td>All</td>
<td>Yes</td>
</tr>
<tr>
<td>2.1(2) and later</td>
<td>Layer 2 Fibre Channel switching only</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Both Layer 2 Fibre Channel switching and Layer 3 Intelligent Storage Services (such as FCWA, NASB, SANTap, ISAPI virtualization)</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Layer 3 Intelligent Storage Services (such as FCWA, NASB, SANTap, ISAPI virtualization) only</td>
<td>Yes</td>
</tr>
</tbody>
</table>
As shown in Table 12-7, Layer 3 Intelligent Storage Services traffic is disrupted when you update the SSI boot image. If you have configured Layer 3 Intelligent Storage Services on your SSM, we recommend that you shut down these services before upgrading the SSI boot image. You can use dual fabric configuration to minimize the impact of shutting down Layer 3 services.

Sample install all Commands

Example 12-4 displays the result of the install all command issued from a console terminal that is connected to the active supervisor module. Once a switchover happens, you can see the rest of the output from the console terminal of the standby supervisor module. Example 12-5 displays the file output continuation of the install all command on the console of the standby supervisor module. Example 12-6 displays the result of the install all command issued from a console terminal for a system that contains an SSI image.

Similarly, you can view the results of the install all command issued from the SSH or Telnet terminal that is connected to the active supervisor module. Once a switchover happens, you need to log back into the switch and issue the show install all status command (see the “Upgrade Status Verification” section on page 12-28).

Example 12-4  Successful install all Command Issued from the Active Console

Hacienda# install all system bootflash:/system-img kickstart bootflash:/kickstart-img

Verifying image bootflash:/kickstart-img
[########################] 100% -- SUCCESS

Verifying image bootflash:/system-img
[########################] 100% -- SUCCESS

Extracting "slc" version from image bootflash:/system-img.
[########################] 100% -- SUCCESS

Extracting "ips" version from image bootflash:/system-img.
[########################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/system-img.
[########################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/kickstart-img.
[########################] 100% -- SUCCESS

Extracting "loader" version from image bootflash:/kickstart-img.
[########################] 100% -- SUCCESS

Compatibility check is done:
Module bootable Impact Install-type Reason
------- -------- -------------- ------------ --------
1 yes  non-disruptive rolling
2 yes  disruptive rolling Hitless upgrade is not supported
3 yes  disruptive rolling Hitless upgrade is not supported
4 yes  non-disruptive rolling
5 yes  non-disruptive reset
6 yes  non-disruptive reset

Images will be upgraded according to following table:
Chapter 12

Software Images

Using the Software Install Wizard

Module
-----1
1
2
2
3
3
4
4
5
5
5
5
6
6
6
6

Image
---------slc
bios
ips
bios
ips
bios
slc
bios
system
kickstart
bios
loader
system
kickstart
bios
loader

Running-Version
-------------------1.3(2a)
v1.1.0(10/24/03)
1.3(2a)
v1.1.0(10/24/03)
1.3(2a)
v1.1.0(10/24/03)
1.3(2a)
v1.1.0(10/24/03)
1.3(2a)
1.3(2a)
v1.1.0(10/24/03)
1.2(2)
1.3(2a)
1.3(2a)
v1.1.0(10/24/03)
1.2(2)

New-Version
-------------------1.3(1)
v1.1.0(10/24/03)
1.3(1)
v1.1.0(10/24/03)
1.3(1)
v1.1.0(10/24/03)
1.3(1)
v1.1.0(10/24/03)
1.3(1)
1.3(1)
v1.1.0(10/24/03)
1.2(2)
1.3(1)
1.3(1)
v1.1.0(10/24/03)
1.2(2)

Do you want to continue with the installation (y/n)?

Upg-Required
-----------yes
no
yes
no
yes
no
yes
no
yes
yes
no
no
yes
yes
no
no

[n] y

Install is in progress, please wait.
Syncing image bootflash:/kickstart-img to standby.
[####################] 100% -- SUCCESS
Syncing image bootflash:/system-img to standby.
[####################] 100% -- SUCCESS
Jan 18 23:40:03 Hacienda %VSHD-5-VSHD_SYSLOG_CONFIG_I: Configuring console from
Performing configuration copy.
[####################] 100% -- SUCCESS
Module 6: Waiting for module online.
|
Auto booting bootflash:/kickstart-img bootflash:/system-img...
Booting kickstart image: bootflash:/kickstart-img....
.....................................Image verification OK
Starting kernel...
INIT: version 2.78 booting
Checking all filesystems..r.r.. done.
Loading system software
Uncompressing system image: bootflash:/system-img
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
CCCCCCCCCCCCCCCCCCCCCCCC
INIT: Entering runlevel: 3

Example 12-5 displays the file output continuation of the install all command on the console of the
standby supervisor module.
Example 12-5 Successful install all Command Output Continued from the Standby Console
Hacienda(standby)#
Auto booting bootflash:/kickstart-img bootflash:/system-img...
Booting kickstart image: bootflash:/kickstart-img....
.....................................Image verification OK
Starting kernel...
INIT: version 2.78 booting
Checking all filesystems..r.r.. done.

Cisco Prime DCNM Fundamentals Guide

12-22


Loading system software
Uncompressing system image: bootflash:/system-img

INIT: Entering runlevel: 3

Continue on installation process, please wait.
The login will be disabled until the installation is completed.

Module 6: Waiting for module online.
Jan 18 23:43:02 Hacienda %PORT-5-IF_UP: Interface mgmt0 is up
Jan 18 23:43:19 Hacienda %LICMGR-3-LOG_LIC_NO_LIC: No license(s) present for feature
FM_SERVER_PKG. Application(s) shutdown in 53 days.
Jan 18 23:43:19 Hacienda %LICMGR-3-LOG_LIC_NO_LIC: No license(s) present for feature
ENTERPRISE_PKG. Application(s) shutdown in 50 days.
Jan 18 23:43:19 Hacienda %LICMGR-3-LOG_LIC_NO_LIC: No license(s) present for feature
SAN_EXTN_OVER_IP. Application(s) shutdown in 50 days.
Jan 18 23:43:19 Hacienda %LICMGR-4-LOG_LICAPP_EXPIRY_WARNING: Application Roles evaluation
license ENTERPRISE_PKG expiry in 50 days
Jan 18 23:44:54 Hacienda %BOOTVAR-5-NEIGHBOR_UPDATE_AUTOCOPY: auto-copy supported by
neighbor, starting...
Module 1: Non-disruptive upgrading.
[#                   ]   0%Jan 18 23:44:56 Hacienda %MODULE-5-STANDBY_SUP_OK: Supervisor 5
is standby
Jan 18 23:44:55 Hacienda %IMAGE_DNLD-SLOT1-2-IMG_DNLD_STARTED: Module image download
process. Please wait until completion...
Jan 18 23:45:12 Hacienda %IMAGE_DNLD-SLOT1-2-IMG_DNLD_COMPLETE: Module image download
process. Download successful.
Jan 18 23:45:48 Hacienda %MODULE-5-MOD_OK: Module 1 is online
[####################] 100% -- SUCCESS
Module 4: Non-disruptive upgrading.
[#                   ] 0%Jan 18 23:46:12 Hacienda %IMAGE_DNLD-SLOT4-2-IMG_DNLD_STARTED: Module image download
process. Please wait until completion...
Jan 18 23:46:26 Hacienda %IMAGE_DNLD-SLOT4-2-IMG_DNLD_COMPLETE: Module image download
process. Download successful.
Jan 18 23:47:02 Hacienda %MODULE-5-MOD_OK: Module 4 is online
[####################] 100% -- SUCCESS
Module 2: Disruptive upgrading.
... -- SUCCESS
Module 3: Disruptive upgrading.
... -- SUCCESS
Install has been successful.
MDS Switch
Hacienda login:

Example 12-6 displays the result of the install all command issued from a console terminal for a system
that contains an SSI image. The install all command syncs the SSI image to the standby supervisor
module.

You can use the install all command for the SSM only if the SSM is already up and running. For first
time SSM installations.
Example 12-6  Successful install all Command Including an SSI Image

Cisco-MDS# install all system bootflash:isan-2-1-1a kickstart
bootflash:boot-2-1-1a  ssi bootflash:ssi-2.1.1a

Verifying image bootflash:/ssi-2.1.1a
[################################] 100% -- SUCCESS

Verifying image bootflash:/boot-2-1-1a
[################################] 100% -- SUCCESS

Verifying image bootflash:/isan-2-1-1a
[################################] 100% -- SUCCESS

Extracting "slc" version from image bootflash:/isan-2-1-1a.
[################################] 100% -- SUCCESS

Extracting "ips4" version from image bootflash:/isan-2-1-1a.
[################################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/isan-2-1-1a.
[################################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/boot-2-1-1a.
[################################] 100% -- SUCCESS

Extracting "loader" version from image bootflash:/boot-2-1-1a.
[################################] 100% -- SUCCESS

Compatibility check is done:

<table>
<thead>
<tr>
<th>Module</th>
<th>bootable</th>
<th>Impact</th>
<th>Install-type</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>4</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>5</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
</tbody>
</table>

Images will be upgraded according to following table:

<table>
<thead>
<tr>
<th>Module</th>
<th>Image</th>
<th>Running-Version</th>
<th>New-Version</th>
<th>Upg-Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>slc</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>2</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>3</td>
<td>slc</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>3</td>
<td>ssi</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>3</td>
<td>bios</td>
<td>v1.0.8(08/07/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>yes</td>
</tr>
<tr>
<td>4</td>
<td>ips4</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>4</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>system</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>kickstart</td>
<td>2.0(3)</td>
<td>2.1(1a)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.1.0(10/24/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
</tbody>
</table>

Do you want to continue with the installation (y/n)? [n] y

Install is in progress, please wait.

Module 6:Force downloading.
-- SUCCESS
Syncing image bootflash:/ssi-2.1.1a to standby.
Chapter 12  Software Images

Using the Software Install Wizard

[########################################] 100% -- SUCCESS
Syncing image bootflash:/boot-2-1-1a to standby.
[########################################] 100% -- SUCCESS
Syncing image bootflash:/isan-2-1-1a to standby.
[########################################] 100% -- SUCCESS
Setting boot variables.
[########################################] 100% -- SUCCESS
Performing configuration copy.
[########################################] 100% -- SUCCESS
Module 3: Upgrading Bios/loader/bootrom.
[########################################] 100% -- SUCCESS
Module 6: Waiting for module online.
   -- SUCCESS

'Switching over onto standby'.
-----------------------------

If you perform the install all command to downgrade to a Cisco MDS SAN-OS release that does not support the SSM module, you must power down the SSM module when prompted by the CLI console. The boot variables for the SSM module are lost.

Example 12-7 displays the result of the install all command if the system and kickstart files are automatically downloaded using a remote (TFTP, FTP, SCP, or SFTP) download option. It shows an accurate and complete example.

Specify the complete path of the remote location. The system will not allow you to proceed if the entire path is not accurately specified. Here are examples of incomplete install all commands:

switch# install all system bootflash:system-image kickstart tftp:
Please provide a complete URI
switch# install all system scp:
Please provide a complete URI

Example 12-7  A Sample of the install all Command Issued Using a Remote Download

switch# install all system
scp://user@10.10.1.1/tftpboot/HKrel/qa/final/m9500-sf1ek9-mz.1.3.2a.bin kickstart scp://user@10.10.1.1/tftpboot/HKrel/qa/final/m9500-sf1ek9-kickstart-mz.1.3.2a.bin
For scp://user@10.10.1.1, please enter password:
For scp://user@10.10.1.1, please enter password:

Copying image from scp://user@10.10.1.1/tftpboot/HKrel/qa/final/m9500-sf1ek9-kickstart-mz.1.3.2a.bin to bootflash:///m9500-sf1ek9-kickstart-mz.1.3.2a.bin.
[########################################] 100% -- SUCCESS

Copying image from scp://user@10.10.1.1/tftpboot/HKrel/qa/final/m9500-sf1ek9-mz.1.3.2a.bin to bootflash:///m9500-sf1ek9-mz.1.3.2a.bin.
[########################################] 100% -- SUCCESS

Verifying image bootflash:///m9500-sf1ek9-kickstart-mz.1.3.2a.bin
[########################################] 100% -- SUCCESS
Using the Software Install Wizard

Verifying image bootflash:///m9500-sf1ek9-mz.1.3.2a.bin
[####################] 100% -- SUCCESS

Extracting "slc" version from image bootflash:///m9500-sf1ek9-mz.1.3.2a.bin.
[####################] 100% -- SUCCESS

Extracting "ips" version from image bootflash:///m9500-sf1ek9-mz.1.3.2a.bin.
[####################] 100% -- SUCCESS

Extracting "system" version from image bootflash:///m9500-sf1ek9-mz.1.3.2a.bin.
[####################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:///m9500-sf1ek9-kickstart-mz.1.3.2a.bin.
[####################] 100% -- SUCCESS

Extracting "loader" version from image bootflash:///m9500-sf1ek9-kickstart-mz.1.3.2a.bin.
[####################] 100% -- SUCCESS

Compatibility check is done:

<table>
<thead>
<tr>
<th>Module</th>
<th>bootable</th>
<th>Impact</th>
<th>Install-type</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>3</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
</tbody>
</table>

Images will be upgraded according to following table:

<table>
<thead>
<tr>
<th>Module</th>
<th>Image</th>
<th>Running-Version</th>
<th>New-Version</th>
<th>Upg-Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>slc</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>1</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>2</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>3</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>4</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>system</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
<tr>
<td>6</td>
<td>system</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>kickstart</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>6</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
<tr>
<td>7</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>7</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>8</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>9</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
</tbody>
</table>

Do you want to continue with the installation (y/n)? [n]
Example 12-8 displays the install all command output of a failed operation due to a lack of disk space.

Example 12-8  Failed Operation Due to a Full bootflash: File System

switch# install all system bootflash:isan-1.3.2a kickstart bootflash:boot-1.3.2a

Verifying image bootflash:/boot-1.3.2a
[####################] 100% -- SUCCESS

Verifying image bootflash:/isan-1.3.2a
[####################] 100% -- SUCCESS

Extracting "slc" version from image bootflash:/isan-1.3.2a.
[####################] 100% -- SUCCESS

Extracting "ips" version from image bootflash:/isan-1.3.2a.
[####################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/isan-1.3.2a.
[####################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/boot-1.3.2a.
[####################] 100% -- SUCCESS

Extracting "loader" version from image bootflash:/boot-1.3.2a.
[####################] 100% -- SUCCESS

Compatibility check is done:

<table>
<thead>
<tr>
<th>Module</th>
<th>bootable</th>
<th>Impact</th>
<th>Install-type</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
<tr>
<td>3</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>yes</td>
<td>non-disruptive</td>
<td>rolling</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>yes</td>
<td>disruptive</td>
<td>rolling</td>
<td>Hitless upgrade is not supported</td>
</tr>
</tbody>
</table>

Images will be upgraded according to following table:

<table>
<thead>
<tr>
<th>Module</th>
<th>Image</th>
<th>Running-Version</th>
<th>New-Version</th>
<th>Upg-Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>slc</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>1</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>2</td>
<td>ips</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>2</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>3</td>
<td>slc</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>3</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>4</td>
<td>slc</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>4</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>system</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>kickstart</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>5</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>loader</td>
<td>1.2(2)</td>
<td>1.2(2)</td>
<td>no</td>
</tr>
<tr>
<td>6</td>
<td>system</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>kickstart</td>
<td>1.3(1)</td>
<td>1.3(2a)</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>bios</td>
<td>v1.1.0(10/24/03)</td>
<td>v1.0.8(08/07/03)</td>
<td>no</td>
</tr>
</tbody>
</table>
Upgrade Status Verification

Use the `show install all status` command to view the ongoing `install all` command or the log of the last installed `install all` command from a console, SSH, or Telnet session.

This command presents the `install all` output on both the active and standby supervisor module even if you are not connected to the console terminal. It only displays the status of an `install all` command that is issued from the CLI (not the GUI). See Example 12-10.

**Example 12-10 Displays the `install all` Command Output**

```
switch# show install all status
There is an on-going installation... <---------------------- in progress installation
Enter Ctrl-C to go back to the prompt.
Verifying image bootflash:/b-1.3.0.104
-- SUCCESS

Verifying image bootflash:/i-1.3.0.104
-- SUCCESS
```

Example 12-9 displays the `install all` command output of a failed operation due to an invalid image.

**Example 12-9 Failed Operation Due to an Invalid Image**

```
install all system bootflash:junk kickstart bootflash:junk
Verifying image bootflash:/junk
[###] 0% -- FAIL. Return code 0x4045001E (mismatch between actual image type and boot variable).
Compatibility check failed. Return code 0x40930011 (Image verification failed).
Hacienda# Jan 19 00:20:35 Hacienda %SYSMGR-3-SERVICE_TERMINATED: Service "installer" (PID 5664) has finished with error code SYSMGR_EXITCODE_FAILURE_NOCALLHOME (20).
```

Upgrade Status Verification

Example 12-9
Performing Nondisruptive Upgrades on Fabric and Modular Switches

This section describes how to perform nondisruptive upgrades on the following Cisco Fabric Switches:

- Cisco MDS 9124 Multilayer Fabric Switch
- Cisco MDS 9134 Multilayer Fabric Switch
- Cisco MDS 9222i Multiservice Modular Switch
- Cisco Fabric Switch for HP c-Class BladeSystem
- Cisco Fabric Switch for IBM BladeCenter

This section includes the following topics:

- Preparing for a Nondisruptive Upgrade on Fabric and Modular Switches, page 12-29
- Performing a Nondisruptive Upgrade on a Fabric Switch, page 12-32
- Viewing the Status of a Nondisruptive Upgrade on a Fabric Switch, page 12-34
- Troubleshooting a Nondisruptive Upgrade on a Fabric Switch, page 12-34

Preparing for a Nondisruptive Upgrade on Fabric and Modular Switches

You can upgrade software on the following without any disruptions using the `install all` command:

- Cisco MDS 9124 Multilayer Fabric Switch
- Cisco MDS 9134 Multilayer Fabric Switch
Performing Nondisruptive Upgrades on Fabric and Modular Switches

When completed, the supervisor kickstart image, supervisor system image, the linecard image and the system BIOS are all updated.

Nondisruptive upgrades on these fabric switches take down the control plane for not more than 80 seconds. In some cases, when the upgrade has progressed past the point at which it cannot be stopped gracefully, or if a failure occurs, the software upgrade may be disruptive.

During the upgrade the control plane is down, but the data plane remains up. So new devices will be unable to log in to the fabric via the control plane, but existing devices will not experience any disruption of traffic via the data plane.

Before attempting to upgrade any software images on these fabric switches, follow these guidelines:

- During the upgrade, the fabric must be stable. None of the following configuration activities are allowed:
  - Zoning changes
  - Telnet sessions
  - Schedule changes
  - Switch cabling
  - Addition or removal of physical devices
- Configure the FSPF timers to the default value of 20 seconds.
- If there are any CFS commits pending in the fabric, the upgrade is aborted.
- If there is a zone server merge in progress, the upgrade is aborted.
- If the upgrade is aborted due to a service not being ready for the upgrade, you are prompted to enter the `show install all failure-reason` command to identify the reason why.
- If there is insufficient space available in the system to load the new images, then you will be notified via the compatibility table. At this point, you need to either abort the upgrade or proceed with a disruptive upgrade.
- Check whether there is sufficient space available in the system to load the new images using the Software Install Wizard. At this point you need to either abort the upgrade or proceed with a disruptive upgrade.
- Issue the `no logging level all` command before the commencing with the upgrade. Failing to issue this command could result in a failure due to the debug system log messages being printed and potentially resulting in control plane downtime exceeding 80 seconds.
- If VRRP is running on the mgmt0 interface, and the switch being upgraded is the master, then a new master is selected. This cannot be avoided because the mgmt0 interface goes down when the control plane goes down.
- On the Cisco MDS 18/4-port multiservice module, upgrades of the 4-Gigabit Ethernet ports for the hybrid Supervisor 18/4 line card will be disruptive.

To ensure that you can view the entire upgrade process, it is recommended that you perform the upgrade via the console port; performing the upgrade in this way also enables you to log your session to a file (in case you need it later for troubleshooting). Also, Telnet sessions are lost when the switch is rebooted, so if you wish to view the process in its entirety, use the console port instead.
Example 12-11 Failed Nondisruptive Upgrade Due to Insufficient Resources

switch# install all kickstart bootflash:boot-fs9124 system bootflash:isan-164

Verifying image bootflash:/boot-fs9124 for boot variable "kickstart".
[ ############### ] 100% -- SUCCESS

Verifying image bootflash:/isan-164 for boot variable "system".
[ ############### ] 100% -- SUCCESS

Extracting "system" version from image bootflash:/isan-164.
[ ############### ] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/boot-fs9124.
[ ############### ] 100% -- SUCCESS

Extracting "bios" version from image bootflash:/isan-164.
[ ############### ] 100% -- SUCCESS

Compatibility check is done:
Module  bootable Impact  Install-type  Reason
------  --------  --------------  ------------  ------
1       yes disruptive  reset  insufficient resources

Images will be upgraded according to following table:
Module Image  Running-Version(pri:alt)  New-Version  Upg-Required
------  ----------  -----------------------  -----------  -------------------
1      system 3.1(1u)                3.1(1)           yes
1   kickstart 3.1(1u)                3.1(1)           yes
1        bios v1.0.0(10/04/06):v1.0.0(10/04/06) v1.0.0(10/04/06) no

Do you want to continue with the installation (y/n)? [n]

Before performing an upgrade, you may wish to use the show install all impact command to view the effect of updating the system from the running image to another specified image.

switch# show install all impact kickstart bootflash:boot-fs9124 system bootflash:isan-164

Verifying image bootflash:/boot-fs9124 for boot variable "kickstart".
[ ############### ] 100% -- SUCCESS

Verifying image bootflash:/isan-164 for boot variable "system".
[ ############### ] 100% -- SUCCESS

Extracting "system" version from image bootflash:/isan-164.
[ ############### ] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/boot-fs9124.
[ ############### ] 100% -- SUCCESS

Extracting "bios" version from image bootflash:/isan-164.
[ ############### ] 100% -- SUCCESS

Compatibility check is done:
Module  bootable Impact  Install-type  Reason
------  --------  --------------  ------------  ------
1       yes non-disruptive  reset
Performing a Nondisruptive Upgrade on a Fabric Switch

To perform a nondisruptive software upgrade on any of the following switches, enter the `install all kickstart` command using the console port:

- Cisco MDS 9124 Multilayer Fabric Switch
- Cisco MDS 9134 Multilayer Fabric Switch
- Cisco MDS 9222i Multiservice Modular Switch
- Cisco Fabric Switch for HP c-Class BladeSystem
- Cisco Fabric Switch for IBM BladeCenter

```
switch# install all kickstart bootflash:boot-fs9124 system bootflash:isan-164u
```

Verifying image bootflash:/boot-fs9124 for boot variable "kickstart".
[####################] 100% -- SUCCESS

Verifying image bootflash:/isan-164u for boot variable "system".
[####################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/isan-164u.
[####################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/boot-fs9124.
[####################] 100% -- SUCCESS

Extracting "bios" version from image bootflash:/isan-164u.
[####################] 100% -- SUCCESS

Compatibility check is done:

<table>
<thead>
<tr>
<th>Module</th>
<th>bootable</th>
<th>Impact</th>
<th>Install-type</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>yes</td>
<td>non-disruptive</td>
<td>reset</td>
<td></td>
</tr>
</tbody>
</table>

Images will be upgraded according to following table:

<table>
<thead>
<tr>
<th>Module</th>
<th>Image</th>
<th>Running-Version(pri:alt)</th>
<th>New-Version</th>
<th>Upg-Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>system</td>
<td>3.1(1)</td>
<td>3.1(1u)</td>
<td>yes</td>
</tr>
<tr>
<td>1</td>
<td>kickstart</td>
<td>3.1(1)</td>
<td>3.1(1u)</td>
<td>yes</td>
</tr>
<tr>
<td>1</td>
<td>bios</td>
<td>v1.0.0(10/04/06): v1.0.0(10/04/06)</td>
<td>v1.0.0(10/04/06)</td>
<td>no</td>
</tr>
</tbody>
</table>

Do you want to continue with the installation (y/n)? [n]

Install is in progress, please wait.

Notifying services about the upgrade.
[####################] 100% -- SUCCESS

Setting boot variables.
Performing nondisruptive upgrades on Cisco MDS 9124 Fabric Switches.

You can use the Software Install Wizard to perform nondisruptive upgrades on Cisco MDS 9124 Fabric Switches. See the “Using the Software Install Wizard” section on page 12-10 for more information on using the Software Install Wizard.

**Caution**

It is recommended that you enable port-fast on the Ethernet interface of the Catalyst switch to which the management interface of the fabric switch is connected. This is to avoid spanning-tree convergence time on the Catalyst switch and packets from the fabric switch are forwarded immediately during the nondisruptive upgrade.

**Note**

When selecting images during the upgrade, ASM-SFN and SSI are not supported on the Cisco MDS 9124 Switch and the Cisco MDS 9134 Multilayer Fabric Switch.
Viewing the Status of a Nondisruptive Upgrade on a Fabric Switch

You can view the status of a nondisruptive upgrade using the `show install all status` command. Note that the output shows the status only after the switch has rebooted to come up with the new image. All actions preceding the reboot are not captured in this output because when you enter the `install all` command using a Telnet session, the session is disconnected when the switch reboots. After you can reconnect to the switch via a Telnet session, the upgrade may already be complete; in this case, the output will show the status of the upgrade.

```
switch# show install all status
This is the log of last installation.

Continuing with installation process, please wait.
The login will be disabled until the installation is completed.

Status for linecard upgrade.
  -- SUCCESS

Performing supervisor state verification.
  -- SUCCESS

Install has been successful.
```

Troubleshooting a Nondisruptive Upgrade on a Fabric Switch

When a nondisruptive upgrade begins, the system notifies all services that an upgrade is about to start, and finds out whether or not the upgrade can proceed. If a service cannot allow the upgrade to proceed at this time (for example, FSPF timers are not configured to the default value, or a CFS operation is in progress), then the service will abort the upgrade. In such a context, you will be prompted to enter the `show install all failure-reason` command to determine the reason why the upgrade cannot proceed.

```
...  
Do you want to continue with the installation (y/n)?  [n] y
Install is in progress, please wait.

Notifying services about the upgrade.
[   ]  0% -- FAIL. Return code 0x401E0066 (request timed out).

Please issue "show install all failure-reason" to find the cause of the failure.<---system prompt to enter the show all failure-reason command.

Install has failed. Return code 0x401E0066 (request timed out).
Please identify the cause of the failure, and try 'install all' again.
```

```
switch# show install all failure-reason
Service: "cfs" failed to respond within the given time period.
```

If there are any failures for whatever reason (a save runtime state failure or linecard upgrade failure) once the upgrade is already in progress, then the switch will be rebooted disruptively because the changes cannot be rolled back. In such cases the upgrade has failed; you are not prompted to enter the `show install all failure-reason` command, and entering it will not yield any useful information.

If further assistance is required to determine why an upgrade is unsuccessful, you should collect the details from the `show tech-support` command output, and the console output from the installation, if available.
Manual Upgrade on a Dual Supervisor Module Switch

Caution
If you are a new user, use the `install all` command to perform a software upgrade. This section is for administrators or individuals who are completely familiar with specific switch functions.

You can manually upgrade the BIOS and the loader in any Cisco MDS switch using the procedures provided in this section. This upgrade process requires you to implement some or all procedures depending on your switch or network configuration.

This section includes the following topics:
- Preparing for a Manual Installation, page 12-35
- Upgrading a Loader, page 12-36
- Upgrading the BIOS, page 12-38

Preparing for a Manual Installation

To prepare any Cisco MDS 9000 Family switch for a manual software installation, follow these steps:

**Step 1** Log into the switch through the console port, an SSH session, or a Telnet session.

**Step 2** Create a backup of your existing configuration file, if required.

**Step 3** Copy the software image from an SCP location to one of two targets: bootflash: or slot0:.

The switch remains operational while the image file is copied.

- Bootflash device (SCP defaults to the bootflash device)—Copy the software image file from the appropriate SCP file system to the bootflash: file system.

  ```
  switch# copy scp://server_IP_address/destination_file_name bootflash:system-image
  ```

  For example:

  ```
  switch# copy scp://user@10.1.7.2/system-image bootflash:system-image
  ```

- CompactFlash device—Copy the software image file from the appropriate SCP file system to the CompactFlash device in slot0: file system.

  ```
  switch# copy scp://server_IP_address/file_name_in_SCP slot0:system-image
  ```

  You can also copy the image onto a new flash disk from a PC and insert it in slot0: in the Cisco MDS 9500 Series switch. After you copy the image and insert it into the slot0: file system, the process is the same as the CompactFlash device after the `copy` command is issued.

**Step 4** Verify that the file was copied in the required directory.

```
switch# dir bootflash:
40295206 Aug  05 15:23:51 1980  ilc1.bin
12456448 Jul 30 23:05:28 1980  kickstart-image1
12288 Jun 23 14:58:44 1980  lost+found/
27602159 Jul 30 23:05:16 1980  system-image1
```
Manual Upgrade on a Dual Supervisor Module Switch

Chapter 12  Software Images

12-36

Cisco Prime DCNM Fundamentals Guide

Step 5  Ensure that the software images are not damaged or corrupted in the saved bootflash: file system.

When copying a new image to your switch, confirm that the image was not corrupted during the copy process.

Use the `show version image` command to verify that the required image was copied successfully.

```
switch# show version image bootflash:kickstart-image
image name: m9500-sflekk-kickstart-mzg.1.0.3.bin
kickstart: version 1.0(3)
loader: version 1.0(3)
compiled: 2/12/2003 11:00:00
```

Note  A verification failed message is generated when you use a Cisco MDS 9500 Series image on a Cisco MDS 9200 Series switch or a Cisco MDS 9200 Series image on a Cisco MDS 9500 Series switch. Be sure to verify the right image.

Step 6  Compare the running system image and the new image by issuing the `show install all impact` command.

Upgrading a Loader

The `install module slot# of the supervisor module loader` command upgrades the (boot) loader.

Note  If the loader is upgraded, you need to reboot to make the new loader effective. You can schedule the reboot at a convenient time so traffic is not impacted.

Caution  Before issuing this command, be sure to read the release notes to verify compatibility issues between the loader and the kickstart or system images.

To upgrade the loader on either the active or standby supervisor module, follow these steps:

Step 1  Use the `show version` command to verify the version on the active and standby supervisor modules.

```
switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
Cisco Systems, Inc. and/or other third parties and are used and
distributed under license. Some parts of this software are covered
under the GNU Public License. A copy of the license is available
Software
```
BIOS:      version 1.0.8
loader:    version 1.1(2)  <-------------------------current running version
kickstart: version 2.0(1)
system:    version 2.0(1)

BIOS compile time:       08/07/03
kickstart image file is: bootflash:///m9500-sf1ek9-kickstart-mzg.2.0.0.6.bin
kickstart compile time:  10/25/2010 12:00:00
system image file is:    bootflash:///m9500-sf1ek9-mzg.2.0.0.6.bin
system compile time:     10/25/2020 12:00:00

Hardware
RAM 1024584 kB

bootflash: 1000944 blocks (block size 512b)
slot0:           0 blocks (block size 512b)

172.22.92.181 uptime is 0 days 2 hours 18 minute(s) 1 second(s)
Last reset at 970069 usecs after Tue Sep 16 22:31:25 1980
  Reason: Reset Requested by CLI command reload
  System version: 2.0(0.6)
  Service:

Step 2  Issue the install module command for the required supervisor module (active or standby). This example displays the command being issued for the standby supervisor module in slot 6:

switch# install module 6 loader bootflash:kickstart-image

Note  If you install a loader version that is the same as the currently installed version, the command will not execute. When both the current version and the installed version are the same, use the init system command to force a loader upgrade.

Step 3  Use the show version command to verify the updated image on the supervisor module.

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
Cisco Systems, Inc. and/or other third parties and are used and
distributed under license. Some parts of this software are covered
under the GNU Public License. A copy of the license is available

Software
BIOS:      version 1.3.1
loader:    version 1.2(2)  <--------------New running version
kickstart: version 1.3(1) ]
system:    version 1.3(1)

BIOS compile time:       08/07/03
kickstart image file is: bootflash:///m9500-sf1ek9-kickstart-mzg.2.0.0.6.bin
kickstart compile time:  10/25/2010 12:00:00
system image file is:    bootflash:///m9500-sf1ek9-mzg.2.0.0.6.bin
system compile time:     10/25/2020 12:00:00

Hardware
Upgrading the BIOS

Tip
Refer to the release notes to verify if the BIOS has changed for the image version being used.

Program the supervisor module or switching module BIOS only if a new BIOS image is provided by Cisco Systems. Only use the provided image to upgrade the BIOS. This command does not affect traffic and can be issued at any time on any switch in the Cisco MDS 9200 Series or Cisco MDS 9500 Series.

Note
If the BIOS is upgraded, reboot to make the new BIOS take effect. You can schedule the reboot at a convenient time so traffic is not impacted.

Caution
The console baud rate automatically reverts to the default rate (9600) after any BIOS upgrade.

To upgrade the BIOS for a module, follow these steps:

Step 1
Use the `show version` command to verify the current running BIOS version.

```
switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by Cisco Systems, Inc. and/or other third parties and are used and distributed under license.
Software
  BIOS: version 1.0(6) <---------- current running version
  loader: version 1.0(3)
  kickstart: version 1.0(3)
  system: version 1.0(3)

  BIOS compile time: 01/27/03
  kickstart image file is: bootflash:/kickstart-image
  kickstart compile time: 01/25/2003 12:00:00
  system image file is: bootflash:/system-image
  system compile time: 01/25/2003 12:00:00

Hardware
  RAM 1027564 kB
```
Step 2
Verify that the BIOS version of the system image is different from the running image.

```
switch# show version image bootflash:system-image
{
  image name: m9500-sfle9k-mz.1.0.3.bin
  bios: version v1.0.6(01/27/03) <----------- BIOS is same version 1.0.6
  system: version 1.0(3)
  compiled: 2/28/2003 5:00:00
}

...system service's list...

package name         package version
acl                   1.0(3)
ascii-cfg             1.0(3)
bios_daemon           1.0(3)

Note: If the versions are different, issue the install module command as specified in Step 3. If they are the same, you do not need to update the BIOS image.

Step 3
Run the install module slot# bios command to install each module (if required). In this example, the supervisor module in slot 6 was updated.

```
switch# install module 6 bios system bootflash:system-image
Started bios programming .... please wait
[########################################] 100%
BIOS upgrade succeeded for module 1
```

Caution: Do not reboot the switch if any errors were indicated in response to this command.

Step 4
Issue the show version command to verify that the module was updated with a new BIOS version.

```
switch# show version module 6
ModNo  Image Type   SW Version   SW Interim Version  BIOS Version
 6      Stby Sup     1.3(2)       1.3(1.1)            1.1.0 [last 1.0.6]
```

Quick Upgrade

To perform a quick upgrade on a Cisco MDS 9000 Family switch, follow these steps:

Step 1
Copy the kickstart and system image files to the required location.

Step 2
Set the boot variables.

```
switch# config t
switch(config)# boot system system-img
switch(config)# boot kickstart kickstart-img
switch(config)# exit
switch#
```

Step 3
Issue the `reload` command. The `reload` command reboots the system. This upgrade is disruptive.
Tip

Use the `install all` command to gracefully reload the switch and handle configuration conversions.

---

### Downgrading from a Higher Release

Use the `install all` command to gracefully reload the switch and handle configuration conversions. When downgrading any switch in the Cisco MDS 9000 Family, avoid using the `reload` command.

**Note**

Downgrading from Cisco MDS NX-OS Release 4.1(1a) or later to Cisco MDS SAN-OS Release is 3.3(1c) and earlier is disruptive and requires a reload of the switch. The 8-Gbps hardware modules will be brought to a power down state.

**Note**

If you downgrade from Cisco MDS SAN-OS Release 3.1(3) to any earlier SAN-OS release after you execute the `system default switchport mode F` command, the ports retain the configuration that resulted from the execution of the command. In other words, the ports do not revert back to the mode they were in prior to executing the command.

For example, to revert to Cisco MDS SAN-OS Release 1.3(4b) or 1.3(5) from Release 3.0(1), follow these steps:

**Step 1** Issue the `show incompatibility system` command to determine if you need to disable any features not supported by the older release. The command output provides the commands needed to disable the incompatible features.

```
switch# show incompatibility system
```

The following configurations on active are incompatible with the system image:

1) Service : cfs , Capability : CAP_FEATURE_CFS_ENABLED_DEVICE_ALIAS
Description : CFS - Distribution is enabled for DEVICE_ALIAS
Capability requirement : STRICT

```
Disable command : no device-alias distribute
```

**Step 2** Disable the incompatible features.

```
switch# config t
switch(config)# no device-alias distribute
switch(config)# exit
switch# 
```

**Step 3** Save the running configuration to the startup configuration.

```
switch# copy running-config start-config
```

**Step 4** Issue the `install all` command to downgrade the software (see the “Automated Upgrades” section on page 12-3).
Maintaining Supervisor Modules

This section includes general information about replacing and using supervisor modules effectively. This section includes the following topics:

- Replacing Supervisor Modules, page 12-41
- Migrating from Supervisor-1 Modules to Supervisor-2 Modules, page 12-41
- Setting Standby Supervisor Module Boot Variable Version, page 12-42
- Setting Standby Supervisor Module Bootflash Memory, page 12-42
- Standby Supervisor Module Boot Alert, page 12-42

Replacing Supervisor Modules

To avoid packet loss when removing a supervisor module from a Cisco MDS 9500 Series Director, take the supervisor modules out of service before removing the supervisor module.

Use the out-of-service command in EXEC mode before removing the supervisor module.

```
out-of-service module slot
```

Where `slot` indicates the chassis slot number in which the supervisor module resides.

**Note** You must remove and reinsert or replace the supervisor module to bring it into service.

Migrating from Supervisor-1 Modules to Supervisor-2 Modules

Cisco MDS NX-OS Release 4.1(1a) requires the Supervisor-2 modules on the Cisco MDS 9509 and 9506 Directors both active and standby. You must upgrade from Supervisor-1 modules to Supervisor-2 modules before upgrading to MDS NX-OS Release 4.1(1a) or later, using the Cisco MDS SAN-OS Release 3.3(1c) or earlier.

Supervisor-1 modules and Supervisor-2 modules cannot be used in the same switch, except for migration purposes. Both the active and standby supervisor modules must be of the same type, either Supervisor-1 or Supervisor-2 modules. For Cisco MDS 9513 Directors, both supervisor modules must be Supervisor-2 modules.

**Caution** Migrating your supervisor modules is a disruptive operation. When migration occurs from a Supervisor 1 to a Supervisor 2 module, a cold switchover occurs and both modules are reloaded. When the Supervisor 1 attempts to come up as the standby with the Supervisor 2 as the active supervisor, the standby is not brought up.

For step-by-step instructions about migrating from Supervisor 1 modules to Supervisor 2 modules, refer to the *Cisco MDS 9000 Family NX-OS and SAN-OS Software Upgrade and Downgrade Guide*.

**Note** Migrating from Supervisor-2 modules to Supervisor-1 modules is not supported.
Setting Standby Supervisor Module Boot Variable Version

If the standby supervisor module boot variable images are not the same version as those running on the active supervisor module, the software forces the standby supervisor module to run the same version as the active supervisor module.

If you specifically set the boot variables of the standby supervisor module to a different version and reboot the standby supervisor module, the standby supervisor module will only load the specified boot variable if the same version is also running on the active supervisor module. At this point, the standby supervisor module is not running the images set in the boot variables.

Setting Standby Supervisor Module Bootflash Memory

When updating software images on the standby supervisor module, verify that there is enough space available for the image using the `dir bootflash://sup-standby/` command. It is a good practice to remove older versions of Cisco MDS NX-OS images and kickstart images.

DETAILED STEPS

| Step 1 | Click Admin > Flash Files. |
| Step 2 | Select the standby supervisor from the Partition drop-down list. At the bottom of the Flash Files dialog box, you see the space used and free space. |

Standby Supervisor Module Boot Alert

If a standby supervisor module fails to boot, the active supervisor module detects that condition and generates a Call Home event and a system message and reboots the standby supervisor module approximately 3 to 6 minutes after the standby supervisor module moves to the loader> prompt.

The following system message is issued:

```
%DAEMON-2-SYSTEM_MSG:Standby supervisor failed to boot up.
```

This error message is also generated if one of the following situations apply:

- You remain at the loader> prompt for an extended period of time.
- You do not set the boot variables appropriately.

Installing Generation 2 Modules in Generation 1 Chassis

The Generation 2 modules have the following installation restrictions:

- Supervisor-2 modules can be installed on all Cisco MDS 9500 Series Directors.

Note: The Cisco MDS 9513 Director does not support Supervisor-1 modules.
• Generation 2 switching modules can be installed on all Cisco MDS 9000 Family switches, except the Cisco MDS 9216 switch.
• Generation 1 modules can be used with Cisco MDS 9000 Family switches. However, installing Generation 1 modules in combination with Generation 2 switching modules in the same chassis reduces the capabilities of the Generation 2 switching modules.
• Generation 1 and Generation 2 switching modules can be installed on Cisco MDS 9500 Family switches with either Supervisor-1 modules or Supervisor-2 modules.

Replacing Modules

When you replace any module (supervisor, switching, or services module), you must ensure that the new module is running the same software version as the rest of the switch.

Refer to Cisco MDS 9000 Family SAN Volume Controller Configuration Guide for configuration details on replacing the Caching Services Module (CSM).

**Note**

When a spare standby supervisor module is inserted, it uses the same image as the active supervisor module. The Cisco NX-OS software image is not automatically copied to the standby flash device.

**Tip**

Use the Software Install Wizard to copy the Cisco NX-OS software image to the standby supervisor bootflash device.

Using the Software Install Wizard after replacing any module, ensures the following actions:
• The proper system and kickstart images are copied on the standby bootflash: file system.
• The proper boot variables are set.
• The loader and the BIOS are upgraded to the same version available on the active supervisor module.

**DETAILED STEPS**

**Step 1** Create a backup of your existing configuration file, if required, by clicking Admin > Copy Configuration and selecting runningConfig to startupConfig.

**Step 2** Replace the required module as specified in the Cisco MDS 9200 Series Hardware Installation Guide or the Cisco MDS 9500 Series Hardware Installation Guide.

**Step 3** Verify that space is available on the standby supervisor bootflash by choosing Admin > Flash Files and selecting the sup-standby. It is a good practice to remove older versions of Cisco MDS NX-OS images and kickstart images.

**Step 4** Use the Software Install Wizard to ensure that the new module is running the same software as the rest of the switch.

**Step 5** Wait until the new module is online and then ensure that the replacement was successful by choosing Physical > Modules in Device Manager.
Tip

Issue the `install all` command to copy the Cisco SAN-OS software image to the standby supervisor module bootflash device.

Issuing the `install all` command after replacing any module, ensures the following actions:

- The proper system and kickstart images are copied on the standby bootflash: file system.
- The proper boot variables are set.
- The loader and the BIOS are upgraded to the same version available on the active supervisor module.

To replace a module in any switch in the Cisco MDS 9200 Series or 9500 Series, follow these steps:

---

Step 1  Create a backup of your existing configuration file, if required, using the `copy running-config startup-config` command.

Step 2  Replace the required module as specified in the *Cisco MDS 9200 Series Hardware Installation Guide* or the *Cisco MDS 9500 Series Hardware Installation Guide*.

Step 3  Verify that space is available on the standby supervisor module bootflash using the `dir bootflash://sup-standby/` command. It is a good practice to remove older versions of Cisco MDS SAN-OS images and kickstart images. For information about displaying file systems and removing files.

Step 4  Issue the `install all` command to ensure that the new module is running the same software as the rest of the switch.

Step 5  Wait until the new module is online and then ensure that the replacement was successful using the `show module` command.
Management Software FAQ

This chapter answers some of the most frequently asked questions about Cisco DCNM-SAN and Device Manager. This chapter contains the following topics:

- **Installation Issues**, page 13-3
  - When installing Cisco DCNM-SAN from windows, why does clicking install fail?, page 13-3
  - Why do I have trouble launching Cisco DCNM-SAN on Solaris?, page 13-3
  - What do I do if my browser prompts to save JNLP files?, page 13-3
  - What do I do if I see a "Java Web Start not detected" error?, page 13-4
  - How do I upgrade to a newer version of Cisco DCNM-SAN or Device Manager?, page 13-4
  - How do I downgrade Cisco DCNM-SAN or Device Manager?, page 13-4
  - What do I do if an upgrade is not working?, page 13-5
  - What do I do if Java Web Start hangs on the download dialog?, page 13-5
  - How do I manually configure a browser for Java Web Start?, page 13-5
  - How do I run Java Web Start from the command line?, page 13-6
  - How do I clear the Java Web Start cache?, page 13-6
  - What do I do if my login does not work in Cisco DCNM-SAN or Device Manager?, page 13-6
  - What do I do if I cannot install Cisco DCNM-SAN or Device Manager, or run Java, when pcAnyWhere is running?, page 13-6
  - What do I do if the Cisco DCNM-SAN or Performance Manager service shows up as “disabled” in the Services menu?, page 13-7
  - What do I do if I am unable to install Cisco DCNM-SAN or Device Manager, or run Java, when McAfee Internet Suite 6.0 Professional is running?, page 13-7

- **General**, page 13-7
  - What do I do if I see errors while monitoring Area chart graphing?, page 13-7
  - What do I do if I see "gen error" messages?, page 13-7
  - What do I do if disk images in the Device Manager Summary View are not visible?, page 13-7
  - What do I do if I am unable to set both the D_S_TOV and E_D_TOV timers in Device Manager?, page 13-8
  - What do I do if columns in Device Manager tables are too small?, page 13-8
  - What do I do if fabric changes are not propagated onto the map (for example, links don't disappear)?, page 13-8
- What do I do if the PortChannel creation dialog becomes too small after several uses?, page 13-8
- What do I do if I see errors after IPFC configuration?, page 13-8
- What do I do if Cisco DCNM-SAN or Device Manager is using the wrong network interface?, page 13-8
- What do I do if I see display anomalies in Cisco DCNM-SAN or Device Manager?, page 13-9
- Why is the active zone set in edit zone always shown in bold (even after successful activation)?, page 13-9
- Can I create a zone with prefix IVRZ or a zone set with name nozonset?, page 13-9
- What do I do when One-Click License Install fails, and I cannot connect to the Cisco website?, page 13-9
- How do I increase the log window size in Cisco DCNM-SAN Client?, page 13-10
- How do I increase the log window size in Cisco DCNM-SAN Client?, page 13-10
- When do I do when the FM Server Database fails to start or has a file locking error?, page 13-10

**Windows Issues, page 13-11**
- What do I do when text fields show up too small, and I cannot enter any data?, page 13-11
- What do I do when printing causes an application crash?, page 13-11
- What do I do when Windows XP hangs (or I see a blue screen)?, page 13-11
- What do I do when Cisco DCNM-SAN and Device Manager Icons Disappear?, page 13-11
- What do I do when Device Manager or Cisco DCNM-SAN window content disappears in Windows XP?, page 13-11
- What do I do when SCP/SFTP fails when a file is copied from local machine to the switch?, page 13-12

**UNIX Issues, page 13-12**
- What do I do when the parent Menus Disappear?, page 13-12
- What do I do when the web browser cannot find web server even it is running?, page 13-12
- How do I fix a "too many open files" error?, page 13-12

**Other, page 13-13**
- How do I set the map layout so it stays after Cisco DCNM-SAN restarted?, page 13-13
- What do I do when two switches show on the map, but there is only one switch?, page 13-13
- What does a red/orange/dotted line through the switch mean?, page 13-13
- How do I upgrade without losing map settings?, page 13-19
- How do I preserve historical data when moving Cisco DCNM-SAN server to new host?, page 13-19
- Are there restrictions when using Cisco DCNM-SAN across FCIP?, page 13-20
- How do I fix a "Please insure that FM server is running on localhost" message?, page 13-20
- How do I run Cisco DCNM-SAN with multiple interfaces?, page 13-20
- How do I configure an HTTP proxy server?, page 13-21
- How do I clear the topology map?, page 13-22
- How can I use Cisco DCNM-SAN in a mixed software environment?, page 13-22
Installation Issues

When installing Cisco DCNM-SAN from windows, why does clicking install fail?

You can make sure that Java Web Start is installed properly.

**DETAILED STEPS**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Go to the Programs menu and see if Java Web Start is there.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Start the <em>Java Web Start</em> program to make sure there is no problem with the Java Runtime installation.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the <em>Preferences</em> tab, and make sure the proxies settings are fine for Web Start.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Check that your browser is set up to handle JNLP settings properly (see the “How do I manually configure a browser for Java Web Start?” section on page 13-5).</td>
</tr>
</tbody>
</table>

If you had older versions of the application and you see an error pop-up window saying cannot open the JNLP file (in the error details), this could be because the Java Web Start cache is messed up. To work around this, clear the cache and retry. To clear the cache, see the “How do I clear the Java Web Start cache?” section on page 13-6.

**Why do I have trouble launching Cisco DCNM-SAN on Solaris?**

If you are using Solaris 2.8 and are logged in as root and are using Netscape Navigator 6, you will not be able to register the mime-type. Regular users can register the mime-type with Netscape Navigator 6 by manually adding it. Netscape 4.x works fine for all users.

**What do I do if my browser prompts to save JNLP files?**

Your browser may not be set up to launch Java Web Start for JNLP mime types. Java Web Start is probably not installed or configured properly (see the “How do I manually configure a browser for Java Web Start?” section on page 13-5).
What do I do if I see a "Java Web Start not detected" error?

If you installed Java Web Start but still see an error message (in red) saying “Java Web Start not detected...” on the switch home page, it could be a simple JavaScript error. We try to detect a Java Web Start installation by running some JavaScript code tested for Internet Explorer and Mozilla (newer versions). On some browsers (for example, Netscape 6.0, Opera) this code does not work properly although the links still work.

- First, try clicking on the install links.
- If that does not work, check to see if the browser helper applications settings are correct (for example, for Netscape 6.0 Edit > Preferences > Navigator > Helper Applications). See the “How do I manually configure a browser for Java Web Start?” section on page 13-5.

What do I do if my desktop shortcuts not visible?

For Windows 2000 and Windows NT, we create Program Menu entries (under a new Cisco MDS 9000 program menu) and desktop shortcuts for Cisco DCNM-SAN and Device Manager. The desktop shortcuts and start menu entries for Cisco DCNM-SAN and Device Manager are called FabricManager and DeviceManager respectively. In other versions of Windows, including XP, we just create batch files on the desktop called FabricManager.bat and DeviceManager.bat. For UNIX, we create shell scripts called FabricManager.sh and DeviceManager.sh under the $HOME/.cisco_mds9000/bin directory. Note that on Windows, installations run under Mozilla variants of browsers, and the desktop shortcuts do not get created. The workaround is to manually create desktop shortcuts.

How do I upgrade to a newer version of Cisco DCNM-SAN or Device Manager?

DETAILED STEPS

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Close all running instances of Cisco DCNM-SAN or Device Manager.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Point your browser at the switch running the new version and click the appropriate install link. Cisco DCNM-SAN or Device Manager prompts you to upgrade if the switch is running a newer version. The installer checks your local copies and updates any newer versions of the software.</td>
</tr>
</tbody>
</table>

How do I downgrade Cisco DCNM-SAN or Device Manager?

As of Cisco MDS NX-OS Release 4.x, downgrades are not supported through the installer. To downgrade Cisco DCNM-SAN or Device Manager to an earlier release, you need to manually uninstall first and then install the previous version of Cisco DCNM-SAN or Device Manager.
What do I do if an upgrade is not working?

If you are trying to upgrade because Cisco DCNM-SAN or Device Manager prompted you saying that the switch version is higher, and the upgrade failed, it might be because your default browser settings are incorrect. Some error must have occurred during your last browser upgrade/install. To work around this, launch the browser independently and click on install.

On rare occasions, we have seen the upgrade happen but the version does not change. This is because of HTTP caching in the network. During the upgrade, HTTP requests for files on the switch get cached in the local machine. Even though the switch is in a higher version, the management software installed is at the old version. The workaround for this is to uninstall the Fabric/Device Manager, clear the Java Web Start cache, and then do a clean install.

What do I do if Java Web Start hangs on the download dialog?

You can make sure Java Web Start is set up to access the switch in the same way your browser is set up.

**DETAILED STEPS**

1. **Step 1** Start Java Web Start (**javaws.exe** or **javaws**). You see the Java Web Start Application Manager.
2. **Step 2** Choose **File > Preferences > General** and make sure your proxy settings are correct. For example, if you are using an HTTP proxy, set it up here.
3. **Step 3** Choose **Use Browser**.
4. **Step 4** Click **OK**.

How do I manually configure a browser for Java Web Start?

For browsers like Opera, certain versions of Mozilla, or Konqueror, you must manually register Java Web Start as the helper application for the JNLP files. To do this, the data you need is:

- **Description**=Java Web Start
- **File Extension**=jnlp
- **Mime Type**=application/x-java-jnlp-file
- **Application**=path-to-javaws (e.g. /usr/local/javaws/javaws)

After setting this up, you may need to restart the browser. If you see "Java Web Start not detected" warnings, you can ignore them. These warnings are based on JavaScript, and not all browsers behave well with JavaScript. Click on the install links to install Cisco DCNM-SAN or Device Manager.

**Note**

For Windows Users: To set up Java Web Start on *.jnlp files, select **Windows Explorer > Tools > Folder Options > File Types**. Either change the existing setting for JNLP or add one so that *.jnlp files are opened by javaws.exe. This executable is under Program Files\Java Web Start.
How do I run Java Web Start from the command line?

If you cannot get your browser to run Java Web Start, you can still run Java Web Start from the command line (javaws.exe or javaws) giving it the URL of the Cisco DCNM-SAN or Device Manager on the switch as an argument. For example, if your switch IP address is 10.0.0.1, you would use these commands to start Cisco DCNM-SAN and Device Manager:

```
javaws http://10.0.0.1/cgi-bin/fabric-manager.jnlp
javaws http://10.0.0.1/cgi-bin/element-manager.jnlp
```

How do I clear the Java Web Start cache?

**DETAILED STEPS**

1. **Step 1** Start the Java Web Start Application Manager (javaws.exe or javaws).
2. **Step 2** Go to File > Preferences > Advanced and clear the applications folder or cache. You can manually delete the .javaws or cache directory. On Windows this is under Documents and Settings, and on UNIX this is under $HOME.

What do I do if during a Cisco DCNM-SAN upgrade, the installer doesn’t display a prompt to create a shortcut?

Clear the Java Web Start cache as described in *How do I clear the Java Web Start cache?* in this chapter.

What do I do if my login does not work in Cisco DCNM-SAN or Device Manager?

Make sure you have done the Initial Setup Routine on the switch.

**Quick checks:**

- Make sure that the management interface on the switch is up (`show interface mgmt0`).
- Check whether you can connect to the management interface (`ping`).
- Verify the username is valid (`show snmp user`). You can also add/edit the users through the CLI.
- If you have multiple network interfaces, see the “What do I do if Cisco DCNM-SAN or Device Manager is using the wrong network interface?” section on page 13-8

What do I do if I cannot install Cisco DCNM-SAN or Device Manager, or run Java, when pcAnyWhere is running?

You can either stop the pcAnyWhere service and install Cisco DCNM-SAN or Device Manager, or install/update DirectX. For more information, refer to the website at [www.oracle.com](http://www.oracle.com)
What do I do if the Cisco DCNM-SAN or Performance Manager service shows up as “disabled” in the Services menu?

This could happen if:

- The service menu for Cisco DCNM-SAN or Performance Manager was open during an uninstall/upgrade.
- The Cisco DCNM-SAN client or Device Manager was running while doing an uninstall/upgrade.

This error happens when Windows is unable to delete a service completely. A reboot of the host should fix the problem.

What do I do if I am unable to install Cisco DCNM-SAN or Device Manager, or run Java, when McAfee Internet Suite 6.0 Professional is running?

The McAfee internet suite comes with a virus scanner, firewall, antispam, and privacy management. The privacy management can interfere with the Cisco DCNM-SAN server-client interactions. To work around this you must shut down the privacy service.

General

What do I do if I see errors while monitoring Area chart graphing?

When doing the area chart graphing from the monitor window, if you move the mouse over the Area chart before the first data comes back, you see a java.lang.ArrayIndexOutOfBoundsException error on the message log from JChart getX(). This is because JChart tries to locate a value that does not exist yet. This might be fixed in a future version of JChart.

What do I do if I see "gen error" messages?

Usually a "gen error" means that the SNMP agent on the switch had an unexpected error in the process of serving an SNMP request. However, when you are accessing the switch through a VPN connection or any sort of NAT scheme, all errors are reported as gen error. This is a known problem and will be fixed in a future release. You can verify whether this was the reason behind your gen error by trying to reproduce this error in an environment where there is no network address translation (where you are on the same network as the switch).

What do I do if disk images in the Device Manager Summary View are not visible?

On some occasions the Summary View table in the Device Manager does not show the icons for disks attached to a Fx port. This is because the FC4 features are empty for this port. A LUN discovery must be issued to discover information about these hosts/disks that do not register their FC4 types. You can do this in the Device Manager by clicking **FC > Advanced > LUNs**.
What do I do if I am unable to set both the D_S_TOV and E_D_TOV timers in Device Manager?

If you modify both E_D_TOV and D_S_TOV at the same time, and the new D_S_TOV value is larger than the old E_D_TOV value, you will get a WrongValue error. To work around this, you must change the values separately.

What do I do if columns in Device Manager tables are too small?

If Device Manager is trying to display a large table and your switch is running slowly, the table will come up with the tabs being hidden. To work around this, you must resize the window to see the data.

What do I do if fabric changes are not propagated onto the map (for example, links don't disappear)?

Cisco DCNM-SAN shows that a device or port is down by displaying a red cross on that port or device. However, Cisco DCNM-SAN does not remove any information that's already discovered. You must rediscover to correctly update the map.

What do I do if the PortChannel creation dialog becomes too small after several uses?

After several uses, the MemberList TextBox (in the PortChannel Create Window) does not display as it should. It changes from a long TextBox with a ComboBox for choosing ports, to a small square TextBox that is too small to choose ports. This is a known problem and will be fixed in a future release. To work around this problem, stop and restart Cisco DCNM-SAN or Device Manager.

What do I do if I see errors after IPFC configuration?

When IPFC and out of band management are configured, the Device Manager might not work using SNMPv3 if you use the IPFC address. The workaround is either to use the management interface (mgmt0) address, or to use SNMPv1/v2c over IPFC.

What do I do if Cisco DCNM-SAN or Device Manager is using the wrong network interface?

The problem happens because the underlying Java library picks a local interface arbitrarily. To work around this, supply a command line argument before starting the Fabric/Device Manager. In the desktop shortcut or shell script or batch file, add the following parameter "-Device Managerds.nmsAddress="

For example, in Windows the line looks like ".\javaw.exe -Device Managerds.nmsAddress=X.X.X.X -cp .".
In desktop shortcuts, this length could exceed the maximum characters allowed. If this happens, delete the ",-Dsun.java2d.doofoffscreen=false" portion to make more space. Releases 1.2 and later allow you to pick a preferred network interface.

**What do I do if I see display anomalies in Cisco DCNM-SAN or Device Manager?**

If you see Cisco DCNM-SAN or Device Manager submenus detached from menus, the mouse pointer in Cisco DCNM-SAN Map is slow to react to mouse movement, or a wrong tooltip is displayed, these are display anomalies, not problems with Cisco DCNM-SAN or Device Manager.

Some older video cards exhibit these display anomalies. To fix this, first try updating the video drivers. If this doesn't solve the problem, replace the video card.

**What do I do if most of my Physical Attributes categories disappear?**

You have somehow turned off advanced features. Look for the check box Advanced Features in the upper right of the Cisco DCNM-SAN screen. Check the box.

**What do I do if I can’t see the Information pane?**

The information pane should be in the upper half of the screen above the map in Cisco DCNM-SAN. The map may be covering it. Drag the edge of the map window down or use the black triangles to reorganize the display.

**Why is the active zone set in edit zone always shown in bold (even after successful activation)?**

A member of this VSAN must be participating in IVR zoning. Because the IVR zones get added to active zones, the active zone set configuration is always different from the local zone set configuration with the same name. The zone set name is always bold.

**Can I create a zone with prefix IVRZ or a zone set with name nozonset?**

Do not use these special names. These names are used by the system for identifying IVR zones.

**What do I do when One-Click License Install fails, and I cannot connect to the Cisco website?**

The one-click license install tries to open an HTTP connection to the Cisco website. If you do your browsing using an HTTP proxy then the following command-line variables need to be added to your Cisco DCNM-SAN client scripts:

```
-Dhttps.proxyHost and -Dhttps.proxyPort.
```
In case your one-click install URL starts with "http://" (and not "https://"), the variables are:
-Dhttp.proxyHost and -Dhttp.proxyPort.

For example, in Windows, edit the MDS 9000\bin\FabricManager.bat file and add to the JVMARGS
"-Dhttps.proxyHost=HOSTADDRESS -Dhttps.proxyPort=HOSTPORT".

How do I increase the log window size in Cisco DCNM-SAN Client?

To limit the memory usage by FM Client, the log window is limited to 500 lines by default. If you want
to increase this, edit sm.properties in <install directory>/db/<user> directory and change
LogBufferSize.

When do I do when the FM Server Database fails to start or has a file locking
error?

In the database log (FMPersist.log) you will see an error message "The database is already in use by
another process". The Hsqldb 1.7.1 version has this problem. The file lock problem seems to happen
occasionally, and can be resolved by shutdown and restart of the db server. On windows this can be done
by stopping and starting the FMPersist service and on Unix just run the FMPersist.sh script with the
argument restart.

How do I re-synchronize Cisco DCNM-SAN Client with Cisco DCNM-SAN
Server?

On some occasions, when the Cisco DCNM-SAN Client in not in sync with the Cisco DCNM-SAN
Server, you may need to re-synchronize the client and server. To re-synchronize Fabrix Manager Client
with Cisco DCNM-SAN Server, click Resync All Open Fabrics from the File menu.

How do I rediscover the current fabric?

When the Cisco DCNM-SAN Server is not in sync with the switches in the fabric, you may need to
initiate an on-demand discovery to update the Cisco DCNM-SAN Client with the most recent changes
from the switches in the fabric. To rediscover the fabric switches, click Rediscover from the File menu.

How do I rediscover SCSI Targets?

When the Cisco DCNM-SAN Server is not in sync with the SCSI Target switches in the fabric, you may
need to initiate an on-demand discovery to update the Cisco DCNM-SAN Client with the most recent
changes from the SCSI Target switches in the fabric. To rediscover the fabric switches, click Rediscover
SCSI Targets from the File menu.
Windows Issues

What do I do when text fields show up too small, and I cannot enter any data?

When Reflection X is running, certain text fields in the Cisco DCNM-SAN and Device Manager are not rendered to the full width of the field. Resize the dialog box to see the text fields properly.

What do I do when printing causes an application crash?

On Windows NT there is a known Sun JVM bug - the printservice crashes the VM. The solution suggested by Sun is to update NT with SP 6. For more details refer to:

What do I do when Windows XP hangs (or I see a blue screen)?

Windows XP with the ATI Radeon AGP graphics cards has known to freeze (hang) when a Java application exits. The newer drivers from ATI seem to have fixed this problem. The other workaround is to run the application with "-Dsun.java2d.noddraw=true". We do this today in the shortcut and shell scripts we create. For more details refer to:

What do I do when Cisco DCNM-SAN and Device Manager icons disappear?

On certain versions of Windows, certain images disappear. This is a Java bug. We have a workaround that is already in place (disable DirectDraw acceleration) - but there are still cases where this problem might arise. For more details refer to:

What do I do when Device Manager or Cisco DCNM-SAN window content disappears in Windows XP?

Device Manager or Cisco DCNM-SAN main window content disappears in Windows XP due to a Java bug. Refer to the following website:

Minimize or maximize the window and restore to the normal size to restore the window content. Disabling Direct Draw may also prevent this from happening by adding "-Dsun.java2d.noddraw=true" to JVMARGS in <FM-install-dir>/bin/FabricManager.bat and DeviceManager.bat
What do I do when SCP/SFTP fails when a file is copied from local machine to the switch?

If there are embedded spaces in the file path, then windows scp/sftp might fail. You will get a copyDeviceBusy error from the switch. In tools such as the License Wizard either make sure tftp copy can be done or pick filenames with no spaces.

UNIX Issues

What do I do when the parent menus disappear?

Displaying a submenu may occasionally cause the parent menu to disappear. For more details on this bug, refer to: http://developer.java.sun.com/developer/bugParade/bugs/4470374.html.

What do I do when the web browser cannot find web server even it is running?

This can happens when web browser uses proxy server. To check that for Internet Explorer, choose tools in menu, then choose internet options, then choose connection subpanel, then click Lan Setting. A dialog comes up, verify the proxy setting.

How do I fix a "too many open files" error?

If you are running the JVM (Java Virtual Machine) on Linux and the drive where Java is installed or your home directory is NFS mounted, there is an open bug against the Sun JDK about errors acquiring file locks. The symptoms for the Cisco DCNM-SAN are that launching a Device Manager or saving/opening files will fail, giving a "too many open files" I/O or socket exception. The JVM keeps trying to open a file on the NFS mounted drives, fails, and keeps trying to do it until it hits the 1024 file descriptors limit. Workarounds (assuming /tmp is a local disk - replace it with your tmp area):

- System Preferences
  
  Make sure the system level preferences are stored on a local disk. The system preferences are stored in $JAVA_HOME/.systemPrefs where JAVA_HOME is where you have installed the JDK. If this directory is NFS mounted, then just do the following:

  ```
  $ rm -rf $JAVA_HOME/.systemPrefs
  $ mkdir /tmp/.systemPrefs
  $ ln -s /tmp/.systemPrefs $JAVA_HOME/.systemPrefs
  ```

  The problem with this workaround is that you have to make sure /tmp/.systemPrefs exists on every box where you are using $JAVA_HOME. We recommend installing the JVM as root and on a local disk.

- User Preferences
  
  If your home directory is NFS mounted and you are getting this problem. Do the following:

  ```
  $ rm -rf $HOME/.java
  $ mkdir /tmp/.java.$USER
  $ ln -s /tmp/.java.$USER $HOME/.java
  ```
For further details, see the following URLs:

Other

How do I set the map layout so it stays after Cisco DCNM-SAN restarted?

You can arrange the map to your liking and would like to “freeze” the map so that the objects stay as they are even after you stop Cisco DCNM-SAN and restart it again.

DETAILED STEPS

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Right-click in a blank space in the map. You see a menu.</td>
</tr>
<tr>
<td>2</td>
<td>Select <strong>Layout &gt; Fix All Nodes</strong> from the menu.</td>
</tr>
</tbody>
</table>

What do I do when two switches show on the map, but there is only one switch?

If two switches show on your map, but you only have one switch, it may be that you have two switches in a non-contiguous VSAN that have the same Domain ID. Cisco DCNM-SAN uses <vsanId><domainId> to look up a switch, and this can cause the fabric discovery to assign links incorrectly between these errant switches.

The workaround is to verify that all switches use unique domain IDs within the same VSAN in a physically connected fabric. (The fabric configuration checker will do this task.)

What does a red/orange/dotted line through the switch mean?

If a red line shows through your switch, this means Fabric Manager sees something wrong with the switch. Choose **Switches** in the Physical Attributes pane to see a status report in the information pane. A module, fan, or power supply has failed or is offline and plugged in.

If a dotted orange line shows through your switch, this indicates a minor status warning for that switch. Usually it means an issue with one of the modules. The tooltip should say exactly what is wrong. Hold the mouse over the switch to see the tooltip.

Below are tables of color settings and tooltip definitions for Cisco DCNM-SAN and Device Manager.
### Table 13-1  Cisco DCNM-SAN Client and Device Manager Color Definitions

<table>
<thead>
<tr>
<th>Cisco DCNM-SAN Color</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Slash</td>
<td>Cannot communicate with a switch via SNMP.</td>
</tr>
<tr>
<td>Red X</td>
<td>Cannot communicate with or see a switch in the Domain Manager/Fabric Configuration Server list of fabric switches.</td>
</tr>
<tr>
<td>Device Manager Color</td>
<td>Definition</td>
</tr>
<tr>
<td>Green Square with Mode (e.g., F, T, TE, U/I for FICON)</td>
<td>Port up.</td>
</tr>
<tr>
<td>Orange Square with Mode</td>
<td>Trunk incomplete.</td>
</tr>
<tr>
<td>Orange Cross</td>
<td>Ols or Nos received.</td>
</tr>
<tr>
<td>Brown Square</td>
<td>Port is administratively down.</td>
</tr>
<tr>
<td>Light Gray Square</td>
<td>Port is not manageable.</td>
</tr>
<tr>
<td>Red Cross</td>
<td>HardwareFailure/LoopbackDiagFailure/LinkFailure</td>
</tr>
<tr>
<td>Red Square</td>
<td>Any other kind of configuration failure.</td>
</tr>
<tr>
<td>No Square or Black Square</td>
<td>Port not yet configured.</td>
</tr>
</tbody>
</table>

### Table 13-2  Device Manager Tooltip Definitions

<table>
<thead>
<tr>
<th>Tooltip</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>adminDown</td>
<td>The port is administratively down.</td>
</tr>
<tr>
<td>bitErrRTThresExceeded</td>
<td>Bit error rate too high.</td>
</tr>
<tr>
<td>bundleMisCfg</td>
<td>Misconfiguration in PortChannel membership detected.</td>
</tr>
<tr>
<td>channelAdminDown</td>
<td>This port is a member of a PortChannel and that PortChannel is administratively down.</td>
</tr>
<tr>
<td>channelConfigurationInProgress</td>
<td>This port is undergoing a PortChannel configuration.</td>
</tr>
<tr>
<td>channelOperSuspended</td>
<td>This port is a member of a PortChannel and its operational parameters are incompatible with the PortChannel parameters.</td>
</tr>
<tr>
<td>deniedDueToPortBinding</td>
<td>Suspended due to port binding.</td>
</tr>
<tr>
<td>domainAddrAssignFailureIsolation</td>
<td>The elected principal switch is not capable of performing domain address manager functions so no Nx_port traffic can be forwarded across switches, hence all Interconnect_Ports in the switch are isolated.</td>
</tr>
<tr>
<td>domainInvalidRCFReceived</td>
<td>Invalid RCF received.</td>
</tr>
<tr>
<td>domainManagerDisabled</td>
<td>Domain manager is disabled.</td>
</tr>
<tr>
<td>domainMaxReTxFailure</td>
<td>Domain manager failure after maximum retries.</td>
</tr>
<tr>
<td>domainOtherSideEportIsolation</td>
<td>The peer E port is isolated.</td>
</tr>
<tr>
<td>Tooltip</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>domainOverlapIsolation</td>
<td>There is an overlap in domains while attempting to connect two existing fabrics.</td>
</tr>
<tr>
<td>elpFailureClassFParamErr</td>
<td>Isolated for ELP failure due to class F parameter error.</td>
</tr>
<tr>
<td>elpFailureClassNParamErr</td>
<td>Isolated for ELP failure due to class N parameter error.</td>
</tr>
<tr>
<td>elpFailureInvalidFlowCTLParam</td>
<td>Isolated for ELP failure due to invalid flow control parameter.</td>
</tr>
<tr>
<td>elpFailureInvalidPayloadSize</td>
<td>Isolated for ELP failure due to invalid payload size.</td>
</tr>
<tr>
<td>elpFailureInvalidPortName</td>
<td>Isolated for ELP failure due to invalid port name.</td>
</tr>
<tr>
<td>elpFailureInvalidSwitchName</td>
<td>Isolated for ELP failure due to invalid switch name.</td>
</tr>
<tr>
<td>elpFailureInvalidTxBBCredit</td>
<td>Isolated for ELP failure due to invalid transmit B2B credit.</td>
</tr>
<tr>
<td>elpFailureIsolation</td>
<td>During a port initialization the prospective Interconnect_Ports find incompatible link parameters.</td>
</tr>
<tr>
<td>elpFailureLoopbackDetected</td>
<td>Isolated for ELP failure due to loopback detected.</td>
</tr>
<tr>
<td>elpFailureRatovEdtovMismatch</td>
<td>Isolated for ELP failure due to R_A_TOV or E_D_TOV mismatch.</td>
</tr>
<tr>
<td>elpFailureRevMismatch</td>
<td>Isolated for ELP failure due to revision mismatch.</td>
</tr>
<tr>
<td>elpFailureUnknownFlowCTLCode</td>
<td>Isolated for ELP failure due to invalid flow control code.</td>
</tr>
<tr>
<td>ePortProhibited</td>
<td>Port down because FICON prohibit mask in place for E/TE port.</td>
</tr>
<tr>
<td>eppFailure</td>
<td>Trunk negotiation protocol failure after maximum retries.</td>
</tr>
<tr>
<td>errorDisabled</td>
<td>The port is not operational due to some error conditions that require administrative attention.</td>
</tr>
<tr>
<td>escFailureIsolation</td>
<td>During a port initialization the prospective Interconnect_Ports are unable to proceed with initialization as a result of Exchange Switch Capabilities (ESC).</td>
</tr>
<tr>
<td>fabricBindingDBMismatch</td>
<td>fabric binding active database mismatch with peer.</td>
</tr>
<tr>
<td>fabricBindingDomainInvalid</td>
<td>Peer domain ID is invalid in fabric binding active database.</td>
</tr>
<tr>
<td>fabricBindingNoRspFromPeer</td>
<td>Fabric binding no response from peer.</td>
</tr>
<tr>
<td>fabricBindingSWWNNotFound</td>
<td>Peer switch WWN not found in fabric binding active database.</td>
</tr>
</tbody>
</table>
Table 13-2  Device Manager Tooltip Definitions (continued)

<table>
<thead>
<tr>
<th>Tooltip</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>fcipPortAdminCfgChange</td>
<td>FCIP port went down due to configuration change.</td>
</tr>
<tr>
<td>fcipPortKeepAliveTimerExpire</td>
<td>FCIP port went down due to TCP keep alive timer expired.</td>
</tr>
<tr>
<td>fcipPortMaxReTx</td>
<td>FCIP port went down due to max TCP retransmissions reached the configured limit.</td>
</tr>
<tr>
<td>fcipPortPersistTimerExpire</td>
<td>FCIP port went down due to TCP persist timer expired.</td>
</tr>
<tr>
<td>fcipPortSrcAdminDown</td>
<td>FCIP port went down because the source ethernet link was administratively shutdown.</td>
</tr>
<tr>
<td>fcipPortSrcLinkDown</td>
<td>FCIP port went down due to ethernet link down.</td>
</tr>
<tr>
<td>fcipSrcModuleNotOnline</td>
<td>FCIP port went down due to source module not online.</td>
</tr>
<tr>
<td>fcipSrcPortRemoved</td>
<td>FCIP port went down due to source port removal.</td>
</tr>
<tr>
<td>fcotChksumErr</td>
<td>FSP SPROM checksum error.</td>
</tr>
<tr>
<td>fcotNotPresent</td>
<td>SFP (GBIC) not present.</td>
</tr>
<tr>
<td>fcosVendorNotSupported</td>
<td>FSP (GBIC) vendor is not supported.</td>
</tr>
<tr>
<td>fcspAuthenfailure</td>
<td>Fibre Channel security protocol authorization failed.</td>
</tr>
<tr>
<td>ficonBeingEnabled</td>
<td>FICON is being enabled.</td>
</tr>
<tr>
<td>ficonNoPortNumber</td>
<td>No FICON port number.</td>
</tr>
<tr>
<td>ficonNotEnabled</td>
<td>FICON not enabled.</td>
</tr>
<tr>
<td>ficonVsanDown</td>
<td>FICON VSAN is down.</td>
</tr>
<tr>
<td>firstPortNotUp</td>
<td>In a over subscribed line card, first port cannot be brought up in E mode when the other ports in the group are up.</td>
</tr>
<tr>
<td>firstPortUpAsEport</td>
<td>In a over subscribed line card, when the first port in a group is up in E mode, other ports in that group cannot be brought up.</td>
</tr>
<tr>
<td>hwFailure</td>
<td>Hardware failure.</td>
</tr>
<tr>
<td>incomAdminRxBBCreditPerBuf</td>
<td>Disabled due to incompatible admin port rxbcredit, performance buffers.</td>
</tr>
<tr>
<td>incompatibleAdminMode</td>
<td>Port admin mode is incompatible with port capabilities.</td>
</tr>
<tr>
<td>incompatibleAdminRxBBCredit</td>
<td>Receive BB credit is incompatible.</td>
</tr>
<tr>
<td>incompatibleAdminRxBufferSize</td>
<td>Receive buffer size is incompatible.</td>
</tr>
<tr>
<td>incompatibleadminSpeed</td>
<td>Port speed is incompatible with port capabilities.</td>
</tr>
<tr>
<td>initializing</td>
<td>The port is being initialized.</td>
</tr>
<tr>
<td>interfaceRemoved</td>
<td>Interface is being removed.</td>
</tr>
<tr>
<td>invalidAttachment</td>
<td>Invalid attachment.</td>
</tr>
</tbody>
</table>
### Table 13-2  Device Manager Tooltip Definitions (continued)

<table>
<thead>
<tr>
<th>Tooltip</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>invalidConfig</td>
<td>This port has a misconfiguration with respect to port channels.</td>
</tr>
<tr>
<td>invalidFabricBindExh</td>
<td>Invalid fabric binding exchange.</td>
</tr>
<tr>
<td>linkFailCreditLoss</td>
<td>Link failure due to excessive credit loss indications.</td>
</tr>
<tr>
<td>linkFailCreditLossB2B</td>
<td>Link failure when link reset (LR) operation fails due to queue not empty.</td>
</tr>
<tr>
<td>linkFailDebounceTimeout</td>
<td>Link failure due to re-negotiation failed.</td>
</tr>
<tr>
<td>linkFailLineCardPortShutdown</td>
<td>Link failure due to port shutdown.</td>
</tr>
<tr>
<td>linkFailLinkReset</td>
<td>Link failure due to link reset.</td>
</tr>
<tr>
<td>linkFailLIPF8Rcvd</td>
<td>Link failure due to F8 LIP received.</td>
</tr>
<tr>
<td>linkFailLIPRcvdB2B</td>
<td>Link failure when loop initialization (LIP) operation fails due to non empty receive queue.</td>
</tr>
<tr>
<td>linkFailLossOfSignal</td>
<td>Link failure due to loss of signal.</td>
</tr>
<tr>
<td>linkFailLossOfSync</td>
<td>Link failure due to loss of sync.</td>
</tr>
<tr>
<td>linkFailLRRcvdB2B</td>
<td>Link failure when link reset (LR) operation fails due to non-empty receive queue.</td>
</tr>
<tr>
<td>linkFailNOSRcvd</td>
<td>Link failure due to non-operational sequences received.</td>
</tr>
<tr>
<td>linkFailOLSRcvd</td>
<td>Link failure due to offline sequences received.</td>
</tr>
<tr>
<td>linkFailOPNyRETB2B</td>
<td>Link failure due to open primitive signal returned while receive queue not empty.</td>
</tr>
<tr>
<td>linkFailOPNyTMOB2B</td>
<td>Link failure due to open primitive signal timeout while receive queue not empty.</td>
</tr>
<tr>
<td>linkFailPortInitFail</td>
<td>Link failure due to port initialization failure.</td>
</tr>
<tr>
<td>linkFailPortUnusable</td>
<td>Link failure due to port unusable.</td>
</tr>
<tr>
<td>linkFailRxQOverFlow</td>
<td>Link failure due to receive queue overflow.</td>
</tr>
<tr>
<td>linkFailTooManyINTR</td>
<td>Link failure due to excessive port interrupts.</td>
</tr>
<tr>
<td>linkFailure</td>
<td>Physical link failure.</td>
</tr>
<tr>
<td>loopbackDiagFailure</td>
<td>Loopback diagnostics failure.</td>
</tr>
<tr>
<td>loopbackIsolation</td>
<td>Port is connected to another port in the same switch.</td>
</tr>
<tr>
<td>noCommonVsanIsolation</td>
<td>Trunk is isolated because there are no common vsans with peer.</td>
</tr>
<tr>
<td>none</td>
<td>No failure.</td>
</tr>
<tr>
<td>nonParticipating</td>
<td>During loop initialization, the port is not allowed to participate in loop operations</td>
</tr>
<tr>
<td>offline</td>
<td>Physical link is in offline state as defined in the FC-FS standards.</td>
</tr>
</tbody>
</table>
### Table 13-2  Device Manager Tooltip Definitions (continued)

<table>
<thead>
<tr>
<th>Tooltip</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>ohmsExtLBTest</td>
<td>Link suspended due to external loopback diagnostics failure.</td>
</tr>
<tr>
<td>other</td>
<td>Undefined reason.</td>
</tr>
<tr>
<td>parentDown</td>
<td>The physical port to which this interface is bound is down.</td>
</tr>
<tr>
<td>peerFCIPPotClosedConnection</td>
<td>Port went down because peer FCIP port closed TCP connection.</td>
</tr>
<tr>
<td>peerFCIPPotResetConnection</td>
<td>Port went down because the TCP connection was reset by the peer FCIP port.</td>
</tr>
<tr>
<td>portBindFailure</td>
<td>Port got isolated due to port bind failure.</td>
</tr>
<tr>
<td>portBlocked</td>
<td>Port blocked due to FICON.</td>
</tr>
<tr>
<td>portChannelMembersDown</td>
<td>No operational members.</td>
</tr>
<tr>
<td>portFabricBindFailure</td>
<td>Port isolated due to fabric bind failure.</td>
</tr>
<tr>
<td>portGracefulShutdown</td>
<td>Port shutdown gracefully.</td>
</tr>
<tr>
<td>portVsanMismatchIsolation</td>
<td>An attempt is made to connect two switches using non-trunking ports having different port VSANs.</td>
</tr>
<tr>
<td>rcfInProgres</td>
<td>An isolated xE_port is transmitting a reconfigure fabric, requesting a disruptive reconfiguration in an attempt to build a single, non-isolated fabric. Only the Interconnect_Ports can become isolated.</td>
</tr>
<tr>
<td>srcPortNotBound</td>
<td>No source port is specified for this interface.</td>
</tr>
<tr>
<td>suspendedByMode</td>
<td>Port that belongs to a port channel is suspended due to incompatible operational mode.</td>
</tr>
<tr>
<td>suspendedBySpeed</td>
<td>Port that belongs to a port channel is suspended due to incompatible operational speed.</td>
</tr>
<tr>
<td>suspendedByWWN</td>
<td>Port that belongs to a port channel is suspended due to incompatible remote switch WWN.</td>
</tr>
<tr>
<td>swFailure</td>
<td>Software failure.</td>
</tr>
<tr>
<td>tooManyInvalidFLOGIs</td>
<td>Suspended due to too many invalid FLOGIs.</td>
</tr>
<tr>
<td>tovMismatch</td>
<td>Link isolation due to TOV mismatch</td>
</tr>
<tr>
<td>trunkNotFullyActive</td>
<td>Some of the VSANs which are common with the peer are not up.</td>
</tr>
<tr>
<td>upgradeInProgress</td>
<td>Line card upgrade in progress.</td>
</tr>
<tr>
<td>vsanInactive</td>
<td>Port VSAN is inactive. The port becomes operational again when the port VSAN is active.</td>
</tr>
<tr>
<td>vsanMismatchIsolation</td>
<td>This VSAN is not configured on both sides of a trunk port.</td>
</tr>
</tbody>
</table>
How do I upgrade without losing map settings?

When you upgrade from one version of Cisco DCNM-SAN to another, there is a way to prevent the loss of map settings (enclosure names, placement on the map, etc.)

The MDS 9000/db directory contains subfolders for each user (and one for fmserver). In these subfolders are files for all discovered fabrics (*.dat) and maps (*.map). These are upgradable between versions. If you need to clear the fabric cache, you should first export the enclosures to a file to avoid losing them. Everything else aside from enclosures and map coordinates are stored on the switch. The preferences, last opened, and site_ouis.txt format doesn’t change from release to release.

How do I preserve historical data when moving Cisco DCNM-SAN server to new host?

DETAILED STEPS

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Export the enclosures to a file.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Reinstall Cisco DCNM-SAN (if you are installing on a new host, install Cisco DCNM-SAN).</td>
</tr>
<tr>
<td>Step 3</td>
<td>After the installation is complete, stop Cisco DCNM-SAN Server.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Copy the RRD files from the old host to the new host. Place it in the database directory (on a Windows PC, the default installation location for this directory is C:\Program Files\Cisco Systems\DCM\fm\pm\db).</td>
</tr>
<tr>
<td>Step 5</td>
<td>On the new host, run <strong>PM.bat sync</strong> from the $INSTALLDIR\dcm\fm\bin folder. This creates files and a new directory structure. There is a directory for each switch for which you have collected data.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Continue to collect data on a specific switch by copying the <strong>db</strong> subfolder from that switch’s folder to the <strong>pm</strong> folder.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Restart Cisco DCNM-SAN Server.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Add the fabric to Performance Manager Collection.</td>
</tr>
<tr>
<td>Step 9</td>
<td>Reimport the enclosures on the new host.</td>
</tr>
<tr>
<td>Step 10</td>
<td>Be sure to turn off the original service on the old host.</td>
</tr>
</tbody>
</table>

**Table 13-2**  
Device Manager Tooltip Definitions (continued)

<table>
<thead>
<tr>
<th>Tooltip</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>zoneMergeFailureIsolation</td>
<td>The two Interconnect_Ports cannot merge zoning configuration after having exchanged merging request for zoning.</td>
</tr>
<tr>
<td>zoneRemoteNoRespIsolation</td>
<td>Isolation due to remote zone server not responding.</td>
</tr>
</tbody>
</table>
Are there restrictions when using Cisco DCNM-SAN across FCIP?

Cisco DCNM-SAN will work with no restriction across an FCIP tunnel, as long as the tunnel is up. However, Cisco DCNM-SAN cannot automatically discover a Cisco SN5428 mgmt IP address in the fabric. For that switch, it will display a red slash through an FCIP device because of a timeout error. It will still see all targets, initiators, and ISLs attached to a Cisco SN5428 (or any other switch) as long as they appear in the name server or FSPF.

To work around this, you can manually enter the IP address in the Switches table, and click Apply. If the community string is correct, the red slash will go away. Even if the community string is incorrect, double-clicking on the Cisco SN5428 will launch the web tool.

How do I fix a "Please insure that FM server is running on localhost" message?

You may see this error message if you cannot connect to the fabric and your PC has multiple network interface cards. The problem may be that Cisco DCNM-SAN is trying to communicate through the wrong interface (you can verify this by checking the FMServer.log file).

Generally it is best to let Cisco DCNM-SAN choose the interface on startup. If you are getting the above error, something may have gone wrong.

DETAILED STEPS

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open the server.properties file in the Cisco DCNM-SAN installation directory. On a Windows platform, this file is in C:\Program Files\Cisco Systems\dcm by default.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Comment out the line: snmp.localaddress.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Save and exit the file.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Restart Cisco DCNM-SAN server.</td>
</tr>
</tbody>
</table>

Note: There are some cases where you would not want to do this, and should manually select the interface that Cisco DCNM-SAN uses. For more information, see the “How do I run Cisco DCNM-SAN with multiple interfaces?” section on page 13-20.

How do I run Cisco DCNM-SAN with multiple interfaces?

If your PC has multiple interfaces (NICs), the four Cisco DCNM-SAN applications detect these interfaces automatically (ignoring loopback interfaces). Cisco DCNM-SAN Client and Device Manager detect all interfaces on your PC each time you launch them, and allow you to select one. Cisco DCNM-SAN Server and Performance Manager detect on initial install, and allows you to select one. You are not prompted again to choose an interface with these two applications.

There may be circumstances where you will want to change the interface you are using. For example:

- If you add an interface after you have installed Cisco DCNM-SAN Server and/or Performance Manager
- If you decide to use a different interface than the one you initially selected
• If for any reason one of the Cisco DCNM-SAN applications did not detect multiple interfaces
Refer to the following sections, depending on which application you want to recognize the interface.
• Manually specifying an interface for Cisco DCNM-SAN Server, page 13-21
• Manually specifying an interface for Cisco DCNM-SAN Client or Device Manager, page 13-21

Manually specifying an interface for Cisco DCNM-SAN Server

DETAILED STEPS

Step 1  Go to the MDS 9000 folder. On a Windows platform, this folder is at C:\Program Files\Cisco
Systems\MDS 9000 by default.
Step 2  Edit the server.properties file with a text editor.
Step 3  Scroll until you find the line: snmp.localaddress.
Step 4  If the line is commented, remove the comment character.
Step 5  Set the local address value to the IP address or interface name of the NIC you want to use.
Step 6  Save the file.
Step 7  Stop and restart Cisco DCNM-SAN Server.

Manually specifying an interface for Cisco DCNM-SAN Client or Device Manager

DETAILED STEPS

Step 1  Go to the MDS 9000/bin folder. On a Windows platform, this folder is at C:\Program Files\Cisco
Systems\MDS 9000 by default.
Step 2  Edit the DeviceManager.bat file or the FabricManager.bat file.
Step 3  Scroll to the line that begins with set JVMARGS=
Step 4  Add the parameter -Device Managerds.nmsaddress=ADDRESS, where ADDRESS is the IP address or
interface name of the NIC you want to use.
Step 5  Save the file and relaunch Cisco DCNM-SAN Client or Device Manager.

How do I configure an HTTP proxy server?

If your network uses a proxy server for HTTP requests, make sure the Java Web Start Application
Manager is properly configured with the IP address of your proxy server.

DETAILED STEPS

Step 1  Launch the Java Web Start application.
Step 2  Choose File > Preferences from the Java WebStart Application Manager.
**Step 3** Choose the **Manual** radio button and enter the IP address of the proxy server in the HTTP Proxy field.

**Step 4** Enter the HTTP port number used by your proxy service in the **HTTP Port** field.

**Step 5** Click **OK**.

---

**How do I clear the topology map?**

If you have a switch that you have removed from the fabric, there will be a red X through the switch’s icon. You can clear this information from the Cisco DCNM-SAN client, or from the Cisco DCNM-SAN server (which will clear the information for all clients) without having to reboot the switch.

**DETAILED STEPS**

**Step 1** Click the **Refresh Map** icon in the Fabric pane.

This clears the information from the client.

**Step 2** Click **Purge Down Elements** in the Server menu.

This clears the information from the server.

---

**Caution** Any devices not currently accessible (may be offline) are purged.

---

**How can I use Cisco DCNM-SAN in a mixed software environment?**

You can use Cisco DCNM-SAN version 2.0(x) to manage a mixed fabric of Cisco MDS 9000 switches. Certain 2.0 feature tabs will be empty for any switches running a software version that does not support those features.

**How do I fix a "corrupted jar file" error when launching Cisco DCNM-SAN?**

If you get the following error:

```
An error occurred while launching the application Cisco DCNM-SAN.

download error:corrupted jar file at <ipaddress>\Device Managerboot.jar
```

(Where `<ipaddress>` is that of the switch)

The error message you are getting indicates that the Java Web Start cache is corrupted. You can try clearing your Java Web Start cache first. To clear the Cache either run Java Web Start (from the Programs menu) and under the **preferences** select **clear cache**. Or do it manually by first making sure all Cisco DCNM-SAN or Device Manager instances are closed and then deleting .javaws/cache. In the newer JREs this directory is created under Documents and Settings\USERNAME and in the older ones it used to be under Program Files\Java Web Start.
You can also browse beneath the cache folder and delete the offending IPAddress folder (e.g. cache/http/D10.0.0.1).

Also, check to make sure that the host is not running a virus checker / java blocker?
You also can run the uninstall program and delete .cisco_mds directory, and then reinstall Cisco DCNM-SAN.

How do I search for devices in a fabric?

In Cisco DCNM-SAN, you can search for one or more devices by different attributes, including pWWN.

**DETAILED STEPS**

**Step 1**
Right-click the map and choose **Find Elements** from the drop-down menu.
You see the Find Fabric dialog box as shown in Figure 13-1.

**Step 2**
Choose **End Device** from the left drop-down list.

**Step 3**
Choose **Port WWN** from the right drop-down list.
You can also enter only part of the WWN and use a wildcard (*) character (for example, you can enter *fb*f8).

**Figure 13-1 Find Fabric Dialog Box with End Device and Port WWN Selected**

**Step 4**
Click **Find in Map**.
To search for devices in a zone, click **Find in Zones**. You see the device highlighted in the Fabric pane.
Right-click any device to see the attributes for that device. You can also select a link leading to a device to see the attributes for the link.
How do I search in a table?

In Cisco DCNM-SAN, you can search for devices having one or more attributes. You can enter a search string in the Find dialog box and then use Next and Previous buttons to navigate through the results.

DETAILED STEPS

- **Step 1**  
  Click the **Find** icon from the tool bar.  
  You see the Find dialog box.

- **Step 2**  
  Enter the search string in the Find text box.

- **Step 3**  
  Click **Selection** to search in selected row(s).

- **Step 4**  
  Check **Ignore Case** to ignore case sensitivity.

- **Step 5**  
  Check **Exact Match** to search for the data value exactly matching the search string.

- **Step 6**  
  Click **Next** to search.

- **Step 7**  
  Click **Cancel** to close the dialog box.

How does Cisco DCNM-SAN Server licensing work?

You must install a Cisco MDS 9000 Family Cisco Fabric Manager Server package on at least one switch in each fabric where you intend to manage switches, if you intend to use the enhanced management capabilities the license package provides. You must also license all switches you plan to monitor with the Performance Manager (historical performance monitoring) feature. Failure to license all switches can prevent effective use of the Flow performance monitoring, so it is recommended to license all switches in each fabric managed by Cisco Fabric Manager Server.

You are free to try Cisco Fabric Manager Server capabilities prior to installing a license, but the those extended functions will stop working after the 120-day grace period expires. Standard Cisco Fabric Manager configuration and management capabilities will continue to be accessible without any licensed switches after the grace period expires.
How do I manage multiple fabrics?

To monitor and manage multiple fabrics, you must persist one or more fabrics. Do this by checking the Persist checkbox on the Server>Admin dialog Fabric tab. You must also use switches running SAN-OS Release 1.3.x or later in both fabrics, and you must use the same user/password on both fabrics. Both fabrics must not be physically connected.

How can I clear an orange X through a switch caused by license expiration?

If you are using a licensed feature and that license is allowed to expire, Cisco DCNM-SAN shows a license violation, and an orange X is placed through the switch on the Cisco DCNM-SAN map.

To clear the license violation message and the orange X, stop the Cisco DCNM-SAN service on the host, and restart it again.

How can I set a consistent unit of measure for the Performance Manager data export?

You can set Performance Manager traffic data to be exported in the same unit of measure throughout the system. The unit of measure is used for data exported to Microsoft Excel. Having a consistent unit of measure helps in sorting and analyzing the exported data.

DETAILED STEPS

Step 1 In the DCNM Web client, choose Admin > Server Properties.

Step 2 Set export.unitless to false.

Step 3 Specify the unit by setting export.unit to GB, Gb, MB, Mb, KB, Kb, B, or b, as required. Here, B denotes Bytes and b denotes Bits.

If you do not specify a unit here, or if you specify an invalid unit, then the default unit used in the web client's display will be used instead.

Note The DCNM server refers the export.unitless and export.unit properties when exporting the data to a Microsoft Excel file. If you set export.unitless to true (which is the default value), the export.unit property will be ignored by the server.

Step 4 Click Apply Changes.
Overview of DCNM-LAN

This chapter provides a brief overview of Cisco Data Center Network Manager for LAN (DCNM-LAN). For information about the specific Cisco Nexus products supported by DCNM-LAN, see the Cisco DCNM Release Notes, Release 7.x.

This chapter includes the following sections:
- DCNM-LAN Client and Server, page 14-1
- Features in Cisco DCNM-LAN, Release 5.2, page 14-2
- Documentation About DCNM-LAN, page 14-3

DCNM-LAN Client and Server

DCNM-LAN is a Java-based client-server application. For Java requirements, server system requirements, and client system requirements, see the Cisco DCNM Release Notes, Release 7.x.

Figure 14-1 shows the DCNM-LAN client-server environment. The DCNM-LAN client communicates with the DCNM-LAN server only, never directly with managed Cisco NX-OS devices. The DCNM-LAN server uses the XML management interface of Cisco NX-OS devices to manage and monitor them. The XML management interface is a programmatic method based on the NETCONF protocol that complements the command-line interface (CLI) functionality. For more information, see the Cisco NX-OS XML Interface User Guide.
Features in Cisco DCNM-LAN, Release 5.2

Cisco DCNM-LAN Release 7.1.x supports the configuration and monitoring of the following Cisco NX-OS features:

- Ethernet switching
  - Physical and virtual ports
  - Port channels and virtual port channels (vPCs)
  - Loopback and management interfaces
  - VLAN network interfaces (sometimes referred to as switched virtual interfaces or SVIs)
  - VLANs and private VLANs (PVLAN)
  - Spanning Tree Protocol, including Rapid Spanning Tree (RST) and Multiple Spanning Tree Protocol (MST)
  - Fabric Extender
  - Link-state tracking
  - Serial Over LAN
  - Chassis Internal Network
  - Fibre-Channel-over-Ethernet Initiation Protocol (FIP) snooping
  - Port profiles
- Ethernet routing
  - Gateway Load Balancing Protocol (GLBP), object tracking, and keychain management
  - Hot Standby Router Protocol (HSRP)
- Network security
  - Access control lists
  - IEEE 802.1X
  - Authentication, authorization, and accounting (AAA)
  - Role-based access control
  - Dynamic Host Configuration Protocol (DHCP) snooping
  - Dynamic Address Resolution Protocol (ARP) inspection
  - IP Source Guard
  - Traffic storm control
  - Port security
- General
  - Virtual Device Context
  - Hardware resource utilization with Ternary Content Addressable Memory (TCAM) statistics
  - Switched Port Analyzer (SPAN)

DCNM-LAN includes the following features for assistance with management of your network:

- Topology viewer
- Network servers
• Device groups
• Event browser
• Configuration Delivery Management
• Configuration Change Management
• Device OS Management
• Hardware and virtual switch inventory

DCNM-LAN includes the following administrative features:
• DCNM-LAN server user accounts
• Device discovery
• Automatic synchronization with discovered devices
• Statistical data collection management
• DCNM-LAN server and client logging

Platform Support

DCNM-LAN supports the following platforms:
• Cisco Nexus 1000V switches
• Cisco Nexus 2000 Fabric Extenders
• Cisco Nexus 3000 Series switches
• Cisco Nexus 4000 Series switches
• Cisco Nexus 5000 Series switches
• Cisco Nexus 6000 Series switches
  – DCNM-LAN supports both fixed and removable expansion modules.
  – In DCNM-LAN, the interface breakout feature can be configured through configuring the delivery feature, and not as a part of configuring an Ethernet interface.
• Catalyst 6500

DCNM-LAN provides limited support for the Catalyst 6500 Series switches that runs classic IOS version 12.2(33)SX1 or higher.
  – DCNM-LAN supports the viewing of the current configuration attributes of the device.
  – DCNM-LAN does not support changing the configuration of the device.
  – DCNM-LAN supports the Firewall Service Module (FWSM) version 4.0 or higher for the Catalyst 6500 Series switches.
• Cisco Nexus 7000 Series switches

Documentation About DCNM-LAN

The documentation for DCNM-LAN includes several configuration guides and other documents. For more information about the DCNM-LAN documentation, see the “Obtaining Documentation and Submitting a Service Request” section on page 67.
Installing and Launching the Cisco DCNM-LAN Client

This chapter describes how to install and launch the Cisco Data Center Network Manager for LAN (DCNM-LAN) client.

This chapter includes the following sections:
- Information About Installing and Launching the DCNM-LAN Client, page 15-1
- Prerequisites for Installing and Launching the DCNM-LAN Client, page 15-2
- Secure Client Communications, page 15-2
- Default Administrator Credentials, page 15-3
- Downloading and Launching the DCNM-LAN Client, page 15-3
- Restarting the DCNM-LAN Client, page 15-6
- Logging Into the DCNM-LAN Client, page 15-7
- Uninstalling the DCNM-LAN Client, page 15-8
- Modifying Cisco DCNM-LAN Server, page 15-9
- Additional References, page 15-11
- Feature History for Installing and Launching the DCNM-LAN Client, page 15-12

Information About Installing and Launching the DCNM-LAN Client

The DCNM-LAN client is a Java application. When you finish installing the DCNM-LAN client on your system, the DCNM-LAN client automatically starts. After installing the DCNM-LAN client, whenever you need to restart the DCNM-LAN client, use the DCNM-LAN client software image on your system for the quickest start. If a more recent version of the DCNM-LAN client is available, the DCNM-LAN client automatically downloads that version to your system.
Prerequisites for Installing and Launching the DCNM-LAN Client

Installing and using the DCNM-LAN client have the following prerequisites:

- Your system must be running a supported operating system to install and use the DCNM-LAN client software. For more information about client system requirements, see the *Cisco DCNM Release Notes, Release 7.x*, which are available at the following site:

- The installation process uses Java version 1.7.0_55 JRE. If your system does not have that version of Java, the installation process will install it to your system.

  The DCNM-LAN client installer requires Internet access to download the Java version 1.7.0_55 JRE. If the system cannot access the Internet, use another system to download the Java installer and copy it to the system that you want to install the DCNM-LAN client on. You can download Java version JRE 1.7.0_55 from the Oracle Technology Network website.

  If your network environment requires a proxy connection to permit the download of the Java installer, ensure that the proxy settings are configured in Internet Options, available from the Control Panel.

- Some DCNM-LAN features require a license. Before you can use licensed features, install the DCNM-LAN license. For more information about licensed features or for more information about the license installation, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*.

Secure Client Communications

By default, communication between the DCNM-LAN client and server is unencrypted; however, you can enable Secure Sockets Layer (SSL) encryption to protect client-server communications. Enabling SSL encryption does not affect how users download, install, and log into the DCNM-LAN client.

For information about enabling secure client communication, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*. 
Default Administrator Credentials

When you install DCNM-LAN, you specify the default administrator account, which is a DCNM-LAN local user. If you use RADIUS or TACACS+ authentication servers to control access to the DCNM-LAN client, the default administrator account provides you access if no authentication servers for the current authentication mode are reachable.

If no one has administrative access to DCNM-LAN, you can reset the local administrator account or change DCNM-LAN server authentication settings by reinstalling the DCNM-LAN server software. For more information, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*.

Downloading and Launching the DCNM-LAN Client

The DCNM-LAN client is available from the web server that is included on the DCNM-LAN server. You can download and launch the DCNM-LAN client either by using a web browser or by using a command prompt.

When you download and launch the DCNM-LAN client, it automatically saves an image of the software on your local system and starts the DCNM-LAN client. Later on, when you start the DCNM-LAN client, you can quickly start it by using the image on your local system.

This section includes the following topics:

- Using a Web Browser to Download and Launch the DCNM-LAN Client, page 15-3
- Using a Command Prompt to Download and Launch the DCNM-LAN Client, page 15-4
- Using a Command Prompt to Download and Launch the DCNM-LAN Client without using Java Web Start Launcher, page 15-5

Using a Web Browser to Download and Launch the DCNM-LAN Client

You can use a web browser to download and launch the DCNM-LAN client.

**BEFORE YOU BEGIN**

The Java version JRE 1.7.0_55 must be installed on the computer that you want to run the DCNM-LAN client on.

The computer that you want to run the DCNM-LAN client on must meet the client system requirements. For details about the client system requirements, see the *Cisco DCNM Release Notes, Release 7.x*, available at the following site:


**DETAILED STEPS**

**Step 1**

On the computer that you want to use the DCNM-LAN client on, open a web browser and go to the following address:

http://server_IP_address_or_DNS_name:web_server_port/dcnm-client/index.html

For example, if the DCNM-LAN server IP address is 172.0.2.1 and the web server port is 8080, use the following address:
http://172.0.2.1:8080/dcnm-client/index.html

The browser shows the DCNM-LAN client page.

Step 2 Click Launch DCNM Client.

The DCNM-LAN server sends the dcnm.jnlp file to the browser. This file should be opened with the Java Web Start Launcher.

Step 3 If the browser prompts you, choose to open the dcnm.jnlp file. You do not need to save the file.

The DCNM-LAN client installer verifies that Java is already installed on your system. If the installer does not find the supported version of Java on the computer, the installer prompts you to install Java version JRE 1.7.0_55.

Note The Cisco DCNM client installer requires Internet access to download the Java version JRE 1.7.0_55. If the system cannot access the Internet, use another system to download the Java installer, copy it to the system that you want to install the Cisco DCNM client on, install Java, and restart the Cisco DCNM client installation. You can download Java version JRE 1.7.0_55 from the Oracle Technology Network website.

If your network environment requires a proxy connection to permit the download of the Java installer, ensure that the proxy settings are configured in Internet Options, available from the Control Panel.

Step 4 If the installer prompts you to install Java version JRE 1.7.0_55, follow these steps:

a. Click OK to begin installing the supported version of Java.

b. If a security warning notifies you that the Java installer was digitally signed by an expired certificate, click Run to continue the installation.

c. Complete the Java installation wizard.

Tip To specify whether the supported version of Java is the default version used by browsers installed on the computer, choose Custom setup on the License Agreement dialog box. Later in the Java installation, on the Browser Registration dialog box, you can specify the browsers that should use the Java version that is supported by DCNM-LAN.

The DCNM-LAN client installs on the computer.

Note You might need to wait a minute or longer while the installer installs the software.

The DCNM-LAN client login window opens.
For detailed login steps, see the “Logging Into the DCNM-LAN Client” section on page 15-7.

Using a Command Prompt to Download and Launch the DCNM-LAN Client

You can use a command prompt to download and launch the DCNM-LAN client.
BEFORE YOU BEGIN

The Java version 1.7.0_55 JRE must be installed on the computer that you want to run the DCNM-LAN client on.

The computer that you want to run the DCNM-LAN client on must meet the client system requirements. For details about the client system requirements, see the Cisco DCNM Release Notes, Release 7.x, available at the following site:


DETAILED STEPS

**Step 1**
On the computer that you want to use the DCNM-LAN client on, access a command prompt.

**Step 2**
Use the `cd` command to change the directory to the bin directory under the Java version 1.7.0_55 installation directory, as follows:

```bash
cd path
```

where `path` is the relative or absolute path to the bin directory. For example, on Microsoft Windows, the default path to the Java version 1.7.0_55 bin directory is `C:\Program Files\dcm\Java\jre1.7.0_55\bin`.

**Step 3**
Enter the applicable command as follows:

- For Microsoft Windows:
  ```bash
  javaws.exe server_IP_address_or_DNS_name:web_server_port/dcnm-client/dcnm.jnlp
  ```

- For RHEL:
  ```bash
  /javaws server_IP_address_or_DNS_name:web_server_port/dcnm-client/dcnm.jnlp
  ```

The Java Web Start Launcher retrieves the dcnm.jnlp file from the DCNM-LAN server and installs the DCNM-LAN client on the computer.

**Note**
You might need to wait a minute or longer while the installer installs the software.

The DCNM-LAN client login window opens.

For detailed login steps, see the “Logging Into the DCNM-LAN Client” section on page 15-7.

---

**Using a Command Prompt to Download and Launch the DCNM-LAN Client without using Java Web Start Launcher**

You can use a command prompt to download and launch the DCNM-LAN client in standalone mode without using the Java Web Start Launcher.

**BEFORE YOU BEGIN**

The Java version 1.7.0_55 JRE must be installed on the computer that you want to run the DCNM-LAN client on.

The computer that you want to run the DCNM-LAN client on must meet the client system requirements. For details about the client system requirements, see the Cisco DCNM Release Notes, Release 7.x, available at the following site:
Chapter 15      Installing and Launching the Cisco DCNM-LAN Client

Restarting the DCNM-LAN Client

If you have previously downloaded and launched the DCNM-LAN client on a computer, you can later start the DCNM-LAN client by using one of the shortcuts that the installer added to the computer.

DETAILED STEPS

Step 1 Access a command prompt on the computer where the DCNM-LAN server is installed and navigate to the directory where the DCNM-LAN server is installed.

- On a Windows DCNM-LAN server, the DCNM-LAN server is installed in <DCNM_INSTALL_LOCATION>/dcm/dcnm/ui-client directory.
  The default for <DCNM_INSTALL_LOCATION> is C:\Program Files\Cisco Systems.
- On a RHEL DCNM-LAN server, the DCNM-LAN server is installed in <DCNM_INSTALL_LOCATION>/dcm/dcnm/ui-client directory.
  The default for <DCNM_INSTALL_LOCATION> is /usr/cisco.

Step 2 In the ui-client directory, locate and run the construct_DCNM_LAN_SA_Client script.

- On a Windows DCNM-LAN server, run construct_DCNM_LAN_SA_Client.bat.
- On a RHEL DCNM-LAN server, run construct_DCNM_LAN_SA_Client.sh.

Step 3 Copy the ui-client directory to the computer that you want to run the DCNM-LAN client on.

Step 4 On the computer that you are preparing for the DCNM-LAN client, access a command prompt and set JAVA_HOME to the location where the Java JRE is installed.
For example:

- For Microsoft Windows:
  set JAVA_HOME=C:\Program Files\Java\jre1.7.0_55
- For RHEL:
  export JAVA_HOME=/usr/java/jre1.7.0_55

Step 5 On the computer that you are preparing for the DCNM-LAN client, navigate to the ui-client directory that was copied from the DCNM-LAN server.

Step 6 In the ui-client directory, locate and run the dcnm-client-sa script to launch the DCNM-LAN client.

- On a RHEL DCNM-LAN server, run dcnm-client-sa.sh.

The DCNM-LAN client login window opens.
For detailed login steps, see the “Logging Into the DCNM-LAN Client” section on page 15-7.

Note

The Cisco DCNM-SAN cross launch feature is not supported when the DCNM-LAN client is installed in standalone mode. (The DCNM-LAN client in standalone mode is not a Java Web Start application.)

 DEPRECATED

TOOLS

For detailed steps, see the “Launching the Cisco DCNM-LAN Client” on page 15-6.
When you start the DCNM-LAN client, it connects to the DCNM-LAN server and checks if the DCNM-LAN client that is available on the DCNM-LAN server is a newer version than the locally installed DCNM-LAN client. How the DCNM-LAN client starts varies depending upon the result of the version check, as follows:

- If the locally installed DCNM-LAN client is the same version as the DCNM-LAN client that is available on the DCNM-LAN server, the DCNM-LAN client window opens quickly.
- If the locally installed DCNM-LAN client is older than the version of the DCNM-LAN client that is available on the DCNM-LAN server, the DCNM-LAN client automatically downloads from the DCNM-LAN server and replaces the locally installed DCNM-LAN client before the DCNM-LAN client window opens.

For detailed login steps, see the “Logging Into the DCNM-LAN Client” section on page 15-7.

Logging Into the DCNM-LAN Client

When you log into the DCNM-LAN client, you must specify a valid DCNM-LAN user account.

BEFORE YOU BEGIN

You should know the following information before logging into the DCNM-LAN client:

- A valid DCNM-LAN username and password.
- The IP address or DNS name of the DCNM-LAN server.
- The DCNM-LAN server port number. By default, the server port number is 1099.
- Proxy server address, HTTP port number, and Socks port number, if a proxy server is required by your network environment.

DETAILED STEPS

Step 1 Start the DCNM-LAN client. If you have previously downloaded and launched the DCNM-LAN client on the computer, you can start the client by using one of the shortcuts added to the computer by the client installer. For more information about downloading and launching the client, see one of the following topics:

- Using a Web Browser to Download and Launch the DCNM-LAN Client, page 15-3
- Using a Command Prompt to Download and Launch the DCNM-LAN Client, page 15-4

The DCNM-LAN client login window opens.

Step 2 In the DCNM-LAN Server field, enter the DNS name or the IP address of the DCNM-LAN server. By default, this field lists the address or name specified the last time the client logged into a server. If you are logging into the client after downloading it, this field lists the address of the server that you downloaded the client from.

Step 3 In the Username field, enter your DCNM-LAN username. If you are logging into DCNM-LAN for the first time after installing the server, enter the local administrator name that you specified during the server installation. For more information, see the “Default Administrator Credentials” section on page 15-3.

Step 4 In the Password field, enter the password for the DCNM-LAN username that you specified.
Uninstalling the DCNM-LAN Client

You can uninstall the DCNM-LAN client from a computer.

DETAILED STEPS

Step 1 Click Start > Control Panel > Java.
The Java Control Panel dialog box opens.

Step 2 In the General tab, under Temporary Internet Files, click Settings.
The Temporary File Settings dialog box appears.

Step 3 Click View Applications.
The Java Application Cache Viewer dialog box opens.

Step 4 Select the DCNM-LAN Client application and click Remove Selected Application.
Java uninstalls the DCNM-LAN client image from your computer.

Step 5 Close the Java Application Cache Viewer.

Step 6 On the Temporary File Settings dialog box, click OK.

Step 7 On the Java Control Panel dialog box, click OK.
Modifying Cisco DCNM-LAN Server

DCNM allows you to modify certain Cisco DCNM-LAN Server settings. Some changes require you to restart the DCNM services.

- Changing the IP Address of the Cisco DCNM-LAN for WINDOWS OS, page 15-9
- Changing the IP Address of the Cisco DCNM-LAN on Federated Windows OS, page 15-10
- Changing the IP Address of the Cisco DCNM-LAN on Linux OS, page 15-10

Changing the IP Address of the Cisco DCNM-LAN for WINDOWS OS

To change the IP address of a Cisco DCNM-LAN Windows Server, follow these steps:

**DETAILED STEPS**

**Step 1** Logon to the Cisco DCNM Web Client.

**Step 2** Select Admin > Server Properties. Edit the value for lan.server.bindaddrs to new IP address.

**Step 3** Stop the Cisco DCNM-LAN Server using Windows Services.

**Step 4** Change the old IP Address with the new IP Address in the following files:

a. $INSTALLDIR\jboss-as-7.2.0.Final\bin\service\lanservice.bat
b. $INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-lan.xml
c. $INSTALLDIR\dcnm\bin\clean-dcnm-db.bat
d. $INSTALLDIR\dcnm\bin\dcnm-log-capture.bat
e. $INSTALLDIR\dcnm\bin\startLANSANSERver.bat
f. $INSTALLDIR\dcnm\bin\status-dcnm.bat.
g. $INSTALLDIR\dcnm\bin\takeServerDump.bat.
h. $INSTALLDIR\jboss-as-7.2.0.Final\standalone\landeployments\dcnm-client.war\dcnm.jnlp
i. $INSTALLDIR\jboss-as-7.2.0.Final\standalone\landeployments\dcnm-client.war\dcnmLatest.jnlp

**Note**
dcnm-client.war can be modified using 7-Zip/Winrar application.

**Step 5** Start the Cisco DCNM-LAN Server using the Windows Services.
Changing the IP Address of the Cisco DCNM-LAN on Federated Windows OS

To change the IP address of a federated Cisco DCNM-LAN Server, follow these steps:

**Step 1** Logon to the Cisco DCNM Web Client.

**Step 2** Navigate to Admin > Server Properties. Edit lan.server.bindaddr with the new IP address.

**Step 3** Stop the Cisco DCNM-LAN Server using Windows Services.

**Step 4** Change the old IP Address with the new IP Address in the file

- \$INSTALLDIR\jboss-as-7.2.0.Final\bin\service\lanservice.bat
- \$INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-lan.xml
- \$INSTALLDIR\dcnm\bin\clean-dcnm-db.bat
- \$INSTALLDIR\dcnm\bin\dcnm-log-capture.bat
- \$INSTALLDIR\dcnm\bin\startLANSANServer.bat
- \$INSTALLDIR\dcnm\bin\status-dcnm.bat
- \$INSTALLDIR\dcnm\bin\takeServerDump.bat
- \$INSTALLDIR\jboss-as-7.2.0.Final\standalone\landeployments\dcnm-client.war\dcnm.jnlp
- \$INSTALLDIR\jboss-as-7.2.0.Final\standalone\landeployments\dcnm-client.war\dcnmLatest.jnlp

**Note** You can modify the dcnm-client.war file by using 7-Zip or Winrar application.

**Step 5** Start the Cisco DCNM-LAN Server using Windows Services.

The IP Address of the Cisco DCNM-LAN on Linux OS

To change the IP address of a Cisco DCNM-LAN Server, follow these steps:

**Note** To change the IP Address of a Cisco DCNM-SAN & DCNM-SMIS Server, see Changing the IP Address of the Cisco DCNM-SAN & DCNM-SMIS LINUX Server, page 5-13.

**DETAILED STEPS**

**Step 1** Logon to the Cisco DCNM Web Client.

**Step 2** Select Admin > Server Properties. Edit the value for lan.server.bindaddr to new IP address.

**Step 3** Stop the Cisco DCNM-LAN Server. Run $INSTALLDIR\dcnm\bin\stopdcnm.sh.

**Step 4** Change the old IP Address with the new IP Address in the following files:

- $INSTALLDIR\jboss-as-7.2.0.Final\bin\init.d\lanservice.sh
- /etc/init.d/LANServer
- $INSTALLDIR\jboss-as-7.2.0.Final\standalone\configuration\standalone-lan.xml
- $INSTALLDIR\dcnm\bin\clean-dcnm-db.sh
e. $INSTALLDIR\dcnm\bin\dcnm-log-capture.sh
f. $INSTALLDIR\dcnm\bin\startLANSANServer.sh
g. $INSTALLDIR\dcnm\bin\takeServerDump.sh

**Step 5**
Start the Cisco DCNM-LAN Server (run $INSTALLDIR\dcnm\bin\startdcnm.sh).

---

**Additional References**

For additional information related to installing and launching the DCNM-LAN client, see the following sections:

- Related Documents, page 15-11
- Standards, page 15-11

**Related Documents**

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to use the DCNM-LAN client</td>
<td>Chapter 16, “Using the Cisco DCNM-LAN Client”</td>
</tr>
<tr>
<td>Starting or stopping a DCNM-LAN server</td>
<td>Chapter 27, “Starting and Stopping Cisco DCNM-LAN Servers”</td>
</tr>
<tr>
<td>The process of deploying DCNM-LAN in your organization</td>
<td>Cisco DCNM Installation and Licensing Guide, Release 6.x</td>
</tr>
<tr>
<td>Installing a DCNM-LAN server</td>
<td>Cisco DCNM Installation and Licensing Guide, Release 6.x</td>
</tr>
</tbody>
</table>

**Standards**

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>
Feature History for Installing and Launching the DCNM-LAN Client

Table 15-1 lists the release history for this feature.

Table 15-1  Feature History for Installing and Launching the DCNM-LAN Client

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using a command prompt to download the client.</td>
<td>5.0(2)</td>
<td>Support was added for this feature.</td>
</tr>
<tr>
<td>Proxy support for the DCNM-LAN client.</td>
<td>5.0(2)</td>
<td>Support was added for this feature.</td>
</tr>
</tbody>
</table>
Using the Cisco DCNM-LAN Client

This chapter section describes the user interface of the Cisco Data Center Network Manager for LAN (DCNM-LAN) client and how to use common features.

This chapter includes the following sections:

- Information About the DCNM-LAN Client, page 16-1
- Opening the DCNM-LAN Client, page 16-8
- Closing the DCNM-LAN Client, page 16-9
- Deploying Changes, page 16-10
- Working with Statistics and Charts, page 16-11
- Configuring Global Preferences, page 16-17
- Using Online Help, page 16-19

Information About the DCNM-LAN Client

This section describes the DCNM-LAN client and its parts.

This section includes the following topics:

- User Interface, page 16-2
- Feature Selector Pane, page 16-2
- Contents Pane, page 16-3
- Summary Pane, page 16-3
- Details Pane, page 16-3
- Association Pane, page 16-4
- Menus, page 16-5
- Toolbars, page 16-7
- Keyboard Commands, page 16-7
- Multiple Platform Support, page 16-7
User Interface

The DCNM-LAN client user interface presents device status information and provides configuration tools that allow you to manage devices. It is divided into the panes. When you want to view information about a specific object in a managed device or want to perform a configuration task, you use the panes in the order shown in the figure below.

Feature Selector Pane

The Feature Selector pane, shown in Figure 16-1, allows you to see features grouped by categories and to choose the feature that you want to use or configure. The bottom section of the Feature Selector pane displays buttons for feature categories. When you choose a category, the top section of the Feature Selector pane displays a tree of features within the chosen category.

In Figure 16-1, the Interfaces category is chosen, so the tree shows features that allow you to configure the interfaces of managed devices.

The documentation and online help for DCNM-LAN includes many procedures that begin with choosing the applicable feature from the Feature Selector pane. For example, a procedure about configuring an Ethernet interface would start with the following step:
From the Feature Selector pane, choose Interfaces > Physical > Ethernet.
After you choose a feature on the tree, the Contents pane displays information about the feature.

Contents Pane

The Contents pane, shown in Figure 16-1 the figure in the “User Interface” section on page 16-2, displays information about the currently selected feature and provides fields for configuring that feature. The Contents pane contains two smaller panes: the Summary pane and the Details pane.

Summary Pane

The Summary pane, shown in Figure 16-1 the figure in the “User Interface” section on page 16-2, displays an organized set of objects that you can view information about or perform actions on. The type of objects that appear depends upon the currently selected feature.

For example, if you choose Interfaces > Physical > Ethernet from the Feature Selector pane, the Summary pane shows a table of devices. You can expand the managed devices to view the slots that contain network interface cards. You can expand the slots to view the interfaces they contain and key information about the status of the interfaces, such as the port mode, administrative status, and operational status. For most features, the title bar for the Summary pane shows what you have selected.

After you choose the object that you want to view or configure, the Details pane displays information about the selected object, such as an Ethernet interface.

Exporting the Summary Pane

You can export the data shown in the Summary pane to a spreadsheet in Microsoft Excel 97-2003 format. To do so, click the green arrow in the upper-right corner of the Summary pane and specify the filename and location for the spreadsheet.

Filtering the Summary Pane

For many features, you can filter the objects that appear in the Summary pane. If filtering is supported for the feature that you selected, you can enable filtering from the menu bar by choosing View > Filter. In the Summary pane, the columns that you can use to filter the objects become drop-down lists. To filter the Summary pane, use the drop-down column heading lists to limit the objects that appear.

Details Pane

The Details pane, shown in Figure 16-1 the figure in the “User Interface” section on page 16-2, shows information and configuration fields that are specific to the object that you selected in the Summary pane. The Details tab is often further divided into tabs. You can click on a tab to view its contents.

This section includes the following topics:

- Tabs, page 16-4
- Sections, page 16-4
**Information About the DCNM-LAN Client**

**Tabs**

Tabs organize related fields and information. For example, as shown in Figure 16-1 the figure in the “User Interface” section on page 16-2, when you select an Ethernet interface, four tabs appear in the Details pane, such as the Port Details tab.

The following two special tabs often appear in the Details pane for many of the types of objects that you can choose from the Summary pane:

- **Statistics**—You can use this tab to work with statistics and charts related to the selected object. For more information, see the “Working with Statistics and Charts” section on page 16-11.
- **Events**—You can use this tab to view feature-specific events about the selected object. For more information, see the *System Management Configuration Guide, Cisco DCNM for LAN*.

**Sections**

Sections provide further organization of related fields and information. The DCNM-LAN client allows you to expand and collapse sections so that you can show or hide fields and information as needed. For example, as shown in Figure 16-1 the figure in the “User Interface” section on page 16-2, on the Port Details tab, the Basic Settings section is expanded but the Port Mode Settings section is collapsed.

**Association Pane**

The DCNM-LAN client also includes the Association pane, which allows you to access objects that you have configured in features that are associated with the currently selected feature. Figure 16-2 The following figure shows the Association pane.

When tabs appear on the right side of the DCNM-LAN client, you can click on them to access the Association pane. For example, as shown in Figure 16-2 the following figure, if you are configuring an Ethernet interface, you can use the Association pane to access the IPv4 ACLs that you can apply to the interface. If you right-click on an IPv4 ACL in the Association pane, you can choose to apply the ACL to the interface or to go to the IPv4 ACLs feature and configure the ACL.
Figure 16-2 Association Pane

Menus

The menu bar in the DCNM-LAN client includes the following standard menus that appear:

File Menu

- New—Allows you to create new objects. The types of objects that you can create depends upon the currently selected feature. In some cases, the object selected in the Summary pane also affects what you can create.
- Deploy—Saves your changes to the DCNM-LAN server and deploys configuration changes to managed devices.
- Exit—Closes the DCNM-LAN client.

View Menu

- Toolbars—Allows you to show or hide the toolbars that are available for the currently selected feature. For more information, see the “Toolbars” section on page 16-7.
- Refresh—Forces the DCNM-LAN client to retrieve updated information from the DCNM-LAN server.
- Filter—Enables or disables the filtering option for the Summary pane.
Tools Menu

- Preferences—Opens the Global Preferences dialog box. For more information, see the “Configuring Global Preferences” section on page 16-17.
- Debug—Opens the DCNM-LAN Client Logging dialog box, which allows you to configure the logging level for the DCNM-LAN client.

Note

We recommend that you use the default client logging level unless you are troubleshooting a specific problem or are asked to change client logging levels by the Cisco technical support staff.

Go Menu

- Topology—Selects the Topology button on the Feature Selector pane.
- Inventory—Selects the Inventory button on the Feature Selector pane.
- Virtual Devices—Selects the Virtual Devices button on the Feature Selector pane.
- Interfaces—Selects the Interfaces button on the Feature Selector pane.
- Switching—Selects the Switching button on the Feature Selector pane.
- FCoE—Selects the FCoE button on the Feature Selector pane.
- Routing—Selects the Routing button on the Feature Selector pane.
- Security—Selects the Security button on the Feature Selector pane.
- Configuration Change Management—Selects the Configuration Change Management button on the Feature Selector pane.
- Device OS Management—Selects the Device OS Management button on the Feature Selector pane.
- Configuration Delivery Management—Selects the Configuration Delivery Management button on the Feature Selector pane.
- DCNM-LAN Server Administration—Selects the DCNM-LAN Server Administration button on the Feature Selector pane.
- Network Servers—Selects the Network Servers button on the Feature Selector pane.
- Event Browser—Selects the Event Browser button on the Feature Selector pane.

Actions Menu

The items on the Actions menu reflect what you can do, depending upon the feature you are using and the object that is selected in the Summary pane. For some features, such as Inventory, the Actions menu does not appear in the menu bar.

Help Menu

- Help Contents—Opens the online help system to the Welcome page.
- Context Help—Opens the online help system to a page that applies to the feature currently selected in the Feature Selector pane.
- Show DCNM-LAN Instance ID—Opens a dialog box that displays the license ID for your DCNM-LAN server. For more information, see the Cisco DCNM Installation Guide, Release 7.1.x.
• View Licenses—Opens a dialog box that displays information about license files currently installed with your DCNM-LAN server.
• About Data Center Network Manager—Opens a dialog box that displays information about your DCNM-LAN server, including the software version and implementation version.

Toolbars

The DCNM-LAN client provides several standard toolbars plus additional, feature-specific toolbars that are available only when you have selected the applicable feature. The following table lists actions that you can take to configure toolbars.

<table>
<thead>
<tr>
<th>Action</th>
<th>How To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide a toolbar</td>
<td>Right-click on the toolbar area and then choose the toolbar that you want to show or hide.</td>
</tr>
<tr>
<td>Rearrange toolbars</td>
<td>On a toolbar that you want to move, click on the left end of the toolbar and drag it to where you want it.</td>
</tr>
<tr>
<td>Float a toolbar</td>
<td>On the toolbar that you want to float, click on the left end of the toolbar and drag it off of the toolbar area.</td>
</tr>
<tr>
<td>Control whether a toolbar can be hidden, rearranged, or floated</td>
<td>Right-click on the toolbar area and then choose the option that you want to control.</td>
</tr>
</tbody>
</table>

Keyboard Commands

You can use the keyboard to perform many of the commands that you can perform with menu items or toolbars. The menus show the keyboard equivalent of most menu items. For example, the following list shows some common menu items and the matching keyboard command:

• Deploy—Ctrl + S
• Refresh—F5
• Filter—Ctrl + F
• Online help—F1
• Exit—Ctrl + Q

Multiple Platform Support

DCNM-LAN supports several types of Cisco Nexus platforms; however, some of the features supported in DCNM-LAN are not supported or applicable to all platforms. This section describes how DCNM-LAN handles unsupported features in the user interface.

• Unsupported Features—If a platform does not support a particular feature, the platform is not displayed for that feature.
Chapter 16      Using the Cisco DCNM-LAN Client

Opening the DCNM-LAN Client

You can open the DCNM-LAN client after you have installed the DCNM-LAN client on the computer that you are using.

BEFORE YOU BEGIN

Install the DCNM-LAN client on the computer that you are using.

DETAILED STEPS

Step 1 From the start menu, choose All Programs > Cisco DCNM Client > Cisco DCNM LAN.

Note If the DCNM-LAN client is not available on the All Programs menu, you can launch the DCNM-LAN client from the DCNM-LAN server website.

A dialog box displays login fields.

Step 2 In the DCNM Server field, enter the IP address or hostname of the DCNM-LAN server. You can use the hostname only if your DNS server has an entry for the DCNM-LAN server hostname. If you have previously logged into the server with the current client installation, you may be able to choose the IP address or hostname from the drop-down list.

Step 3 In the Username field, enter the name of the DCNM-LAN server user account that you want to use to access the DCNM-LAN client.

Step 4 In the Password field, enter the password for the user account that you specified.

For example, if you choose Security > Access Control > Time-range from the Feature Selector pane, the Summary pane displays only the platform types that support the Time-range feature. In this case, the Cisco Nexus 1000V does not support this feature, so any managed Cisco Nexus 1000V platforms are not displayed in the Summary pane. Similarly, the Time-range association pane does not include any Cisco Nexus 1000V platforms.

- Unsupported Attributes—Sometimes a platform supports a feature, but does not support a particular attribute in that feature. In this case, the attribute is grayed-out or a N/A (Not Applicable) value is displayed in the field or cell.

  If all attributes grouped in a particular section are not supported, N/A is added to the section title, and DCNM-LAN does not allow you to expand the section.

  If all attributes in a tab are not supported for a particular platform, the tab is displayed, but if you click on it, a message appears stating that the attribute is not supported.

- Unsupported Charts—If a platform does not support some attributes in a chart, DCNM-LAN grays out those attributes. If a platform does not support any attributes in a chart, when you select the chart, DCNM-LAN displays a message stating that the chart is not supported.

- Unsupported Options—If a platform does not support an option, the option is not displayed, for example, in drop-down lists.

- Unsupported Operations—If a platform does not support an option for a specific operation on a context or toolbar menu, the option is grayed-out.
Step 5  (Optional) If you need to change the DCNM-LAN server port, do the following:
   a. If the Port field is not visible, click More >>.
   b. Enter the port number in the Port field.
      The default DCNM-LAN server port number is 1099; however, you can specify a different port
      number when you install or reinstall the DCNM-LAN server.

Step 6  (Optional) If you need to use a proxy server to connect to the DCNM-LAN server, do the following:
   a. If the “Connect to the DCNM-LAN server with a proxy server” check box is not visible, click More >>.
   b. Check Connect to the DCNM server with a proxy server.
      The Proxy Server area appears below the check box.
   c. In the Address field, enter the IP address of the proxy server.
   d. In the HTTP Port and Socks Port fields, enter the port numbers on which the proxy server accepts
      HTTP and Socks connections.
   e. (Optional) If the proxy server requires authentication, check Authentication and enter a valid
      username and password in the fields provided.

Step 7  Click Login.
The DCNM-LAN client user interface appears.
If a dialog box displays a message about device credentials, you have not configured device credentials
for the user account that you specified.

Step 8  If a dialog box shows a message that your device credentials are not set, do one of the following:
   • If you want to set device credentials now, click Yes.
   • If you do not want to set device credentials now, click No.

RELATED TOPICS
   • Closing the DCNM-LAN Client, page 16-9
   • Configuring Default Device Credentials, page 30-3

Closing the DCNM-LAN Client

You can close the DCNM-LAN client when you are done using it.

DETAILED STEPS

Step 1  From the menu bar, choose File > Exit.
A dialog box displays a confirmation message.

Step 2  (Optional) If you have not deployed your changes, do one of the following:
   • If you want to save your changes, including deploying configuration changes to managed devices,
      check Save pending changes.
   • If you want to discard your changes, uncheck Save pending changes.
Chapter 16  Using the Cisco DCNM-LAN Client

Deploying Changes

When you use the DCNM-LAN client to make configuration changes to managed devices or to the DCNM-LAN server, you may need to deploy the changes or the DCNM-LAN client may deploy them automatically, depending upon what changes you have made.

- Automatic deployment—If the DCNM-LAN client deploys a change automatically, the “Deploying configuration” message appears briefly. For example, if you delete an access rule from an ACL, the DCNM-LAN client immediately deploys this configuration change to the managed device that has the ACL.

- Manual deployment—If the DCNM-LAN client is storing a configuration change, on the toolbar, the Deploy button is available. For example, if you change the sequence number of an access rule of an ACL, the DCNM-LAN client stores this configuration change until you manually deploy it to the managed device that has the ACL.

To remind you of the necessity to deploy changes that the DCNM-LAN client is storing, the procedures in the DCNM-LAN documentation set include a deployment step.

Deploying server changes saves your changes on the DCNM-LAN server. For example, if you add a DCNM-LAN server user account, deploying your changes adds the user account to the DCNM-LAN server and does not affect managed devices.

Deploying configuration changes to a managed device causes the DCNM-LAN server to update the running configuration of the device.

Note  DCNM-LAN does not update the startup configuration of a managed device. When you want to replace the startup configuration of a managed device with the running configuration, you can log into the command-line interface of the device and copy the running configuration to the startup configuration.
When you close the DCNM-LAN client and you have not deployed your changes, you can deploy them without canceling the process of closing the DCNM-LAN client. For more information, see the “Closing the DCNM-LAN Client” section on page 16-9.

**Working with Statistics and Charts**

This section describes how to use the statistical charts available on a Statistics tab.

This section includes the following topics:

- Information about Statistics and Charts, page 16-11
- Licensing Requirements for Statistics and Charts, page 16-11
- Accessing a Chart, page 16-12
- Starting Statistical Monitoring for a Chart, page 16-12
- Stopping Statistical Monitoring for a Chart, page 16-13
- Using a Chart, page 16-14
- Using an Overview Chart, page 16-15
- Exporting a Chart, page 16-16

**Information about Statistics and Charts**

You can use a Statistics tab to start and stop statistical monitoring for an object and to work with charts of statistical data about the selected object. For each chart, the DCNM-LAN client also provides overview charts, which allow you to see historical trends and to control the time scale of the standard chart.

When you start monitoring for a new chart, DCNM-LAN creates a new statistical collection process that appears in the Statistical Data Collection feature.

**Licensing Requirements for Statistics and Charts**

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Real-time monitoring requires no license.</td>
</tr>
<tr>
<td></td>
<td>Cisco DCNM-LAN requires a LAN Enterprise license for the following features:</td>
</tr>
<tr>
<td></td>
<td>• Maintaining a history of statistical data</td>
</tr>
<tr>
<td></td>
<td>• Using overview charts</td>
</tr>
<tr>
<td></td>
<td>For information about obtaining and installing a Cisco DCNM-LAN LAN Enterprise license, see the <em>Cisco DCNM Installation Guide, Release 7.1.x</em>.</td>
</tr>
</tbody>
</table>
Accessing a Chart

You can access any chart. The charts that are available for a particular Statistics tab depend upon the feature and object selected.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose the feature for which you want to use a statistical chart. For example, choose Interfaces > Physical > Ethernet.

Step 2  From the Summary pane, select an object. The Statistics tab appears in the Details pane.

Note  If no Statistics tab appears, DCNM-LAN does not provide a statistical chart for the object that you selected.

Step 3  Click the Statistics tab. In the Statistics tab, one or more charts may appear.

Note  A dialog box may appear to confirm if you want to view charts for statistical collections that DCNM-LAN is running for the object that you selected in the Summary pane. For more information, see the “Configuring Monitoring Preferences” section on page 16-17.

Step 4  If the chart for the data that you want to monitor does not appear, from the toolbar, choose New Chart and then choose the chart that you want.

Step 5  Click the title bar of the chart that you want to work with. The chart status appears in the lower left corner of the chart pane. If the chart is not active, you must start statistical monitoring for the chart before you can use it. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

RELATED TOPICS

- Starting Statistical Monitoring for a Chart, page 16-12
- Stopping Statistical Monitoring for a Chart, page 16-13
- Using a Chart, page 16-14
- Using an Overview Chart, page 16-15
- Exporting a Chart, page 16-16

Starting Statistical Monitoring for a Chart

You can start statistical monitoring for a chart in the Statistics tab for any of the device configuration features that support statistical monitoring.
Chapter 16  Using the Cisco DCNM-LAN Client

Working with Statistics and Charts

Note

Each time that you start monitoring for a new chart, DCNM-LAN creates a new statistical collection process that appears in the Statistical Data Collection feature.

DETAILED STEPS

Step 1
Access the chart for which you want to start statistical monitoring. For more information, see the “Accessing a Chart” section on page 16-12.

Step 2
From the chart pane, click Select Parameters, check at least one statistical parameter that you want to appear in the chart, and click Select Parameters again.

Step 3
From the Monitor toolbar, choose the icon to start the collection process.

Step 4
The chart starts graphing the selected parameters.

Note
When you close the DCNM-LAN client without stopping the statistical collection processes that you started, a dialog box prompts you to decide whether to stop the statistical collections or let them continue. We recommend that you stop any unnecessary statistical collection processes when you log out of the DCNM-LAN client.

RELATED TOPICS

- Accessing a Chart, page 16-12
- Stopping Statistical Monitoring for a Chart, page 16-13
- Using a Chart, page 16-14
- Using an Overview Chart, page 16-15
- Exporting a Chart, page 16-16

Stopping Statistical Monitoring for a Chart

You can stop statistical monitoring for a chart in the Statistics tab.

Note
When you stop monitoring for a chart, DCNM-LAN stops the corresponding statistical collection process that appears in the Statistical Data Collection feature.

DETAILED STEPS

Step 1
Access the chart for which you want to stop statistical monitoring. For more information, see the “Accessing a Chart” section on page 16-12.

Step 2
From the Monitor toolbar choose the Arrow icon.
If the chart that you want to stop does not appear, use the Statistical Data Collection feature to stop the collection process. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

### RELATED TOPICS

- Accessing a Chart, page 16-12
- Starting Statistical Monitoring for a Chart, page 16-12
- Using a Chart, page 16-14
- Using an Overview Chart, page 16-15
- Exporting a Chart, page 16-16

### Using a Chart

The DCNM-LAN client provides the following options for using a chart:

- Changing parameters
- Setting the charting frequency
- Controlling the magnification of the chart data
- Showing, moving, and hiding threshold lines
- Tearing the chart away from the DCNM-LAN client window

This procedure provides basic instructions for using each of these options.

**Note**
For information about using an overview chart, see the “Using an Overview Chart” section on page 16-15.

### DETAILED STEPS

**Step 1**
Access the chart that you want to use. For more information, see the “Accessing a Chart” section on page 16-12.

**Step 2**
If the chart is not active, you must start statistical monitoring for the chart before you can use it. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

**Step 3**
(Optional) To change parameters, click **Select Parameters**, check the statistics parameters that you want to collect, and click **Select Parameters** again.

**Step 4**
(Optional) To set the frequency with which DCNM-LAN retrieves statistical data for the selected object, from the Select Frequency drop-down list on the Monitor toolbar, choose the new frequency.

**Step 5**
(Optional) To control the magnification, or zoom, of the chart, do one of the following:

- To zoom in on a portion of the chart, position the mouse pointer at one end of the portion, click and hold the left mouse button, drag the mouse pointer to the other end of the portion, and release the mouse button.
To zoom in on a portion of the chart, position the mouse pointer at one end of the portion and then click and drag the mouse pointer to the other end of the portion.

To change to the previous zoom, click the icon.

To change to the next zoom, click the icon.

To reset the zoom to the default magnification, click the icon.

**Step 6** (Optional) To show, move, or hide threshold lines, do one of the following:

- To show or hide threshold lines, on the Monitor toolbar, click the icon.
- To move the lower threshold line, click and drag the icon.
- To move the lower threshold line, click and drag the icon.

**Step 7** (Optional) To tear the chart away from the DCNM-LAN client window, click on the red line that appears below the chart title.

### RELATED TOPICS

- Accessing a Chart, page 16-12
- Starting Statistical Monitoring for a Chart, page 16-12
- Stopping Statistical Monitoring for a Chart, page 16-13
- Using an Overview Chart, page 16-15
- Exporting a Chart, page 16-16

### Using an Overview Chart

You can use an overview chart to view the historical trend of the statistical data of the current chart and to set the time scale of the standard chart.

**BEFORE YOU BEGIN**

Ensure that any device with data that you want to view on an overview chart is included on the list of DCNM-LAN-licensed devices. For more information, see the “Licensing Requirements for Statistics and Charts” section on page 16-11.

**DETAILED STEPS**

**Step 1** Access the chart that contains the overview chart that you want to use. For more information, see the “Accessing a Chart” section on page 16-12.

**Step 2** If the chart is not active, you must start statistical monitoring for the chart before you can use its overview chart. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

**Step 3** Click **Show Overview Chart**.

In a new window, the overview chart displays the historical trends of the charted data.

**Step 4** To set the time scale of the chart, at the bottom of the overview chart window, click the desired time scale button. The time scale buttons are as follows:
Working with Statistics and Charts

Chapter 16      Using the Cisco DCNM-LAN Client

Chapter 16

Working with Statistics and Charts

- RT—Real time
- 1d—One day
- 2d—Two days
- 5d—Five days
- 15d—Fifteen days
- 1m—One month
- 3m—Three months

Step 5 To close the overview chart, click **Show Overview Chart** again.

RELATED TOPICS

- Accessing a Chart, page 16-12
- Starting Statistical Monitoring for a Chart, page 16-12
- Stopping Statistical Monitoring for a Chart, page 16-13
- Using a Chart, page 16-14
- Exporting a Chart, page 16-16

**Exporting a Chart**

You can export a chart as a JPG image or as a comma-separated value (CSV) file.

When you export a chart as a JPG image, the image is of the chart as it appears when you export the image.

When you export a chart as a CSV file, the file contains all data from the statistical collection for the chart.

**DETAILED STEPS**

**Step 1** Access the chart that you want to use. For more information, see the “Accessing a Chart” section on page 16-12.

**Step 2** If the chart is not active, you must start statistical monitoring for the chart before you can export an image of it. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.

**Step 3** If you want to export an image, configure the chart to show the data that you want to appear in the image. For more information, see the “Using a Chart” section on page 16-14.

**Step 4** Right-click on the chart.

**Step 5** Choose one of the following:
- Export as CSV
- Export as JPG

**Step 6** Specify the location and filename, and then click **Save**.
Configuring Global Preferences

Using the Global Preferences dialog box, you can configure several preferences for how the DCNM-LAN client displays data and fields. The sections on the Global Preferences are as follows:

- Monitoring—Controls the default frequency of statistical data retrieval from managed devices and whether statistical charts open automatically. For more information, see the “Configuring Monitoring Preferences” section on page 16-17.
- Events—Controls the maximum age of events that the DCNM-LAN client fetches from the DCNM-LAN server when you start the DCNM-LAN client. For more information, see the “Configuring the Maximum Age of Events Fetched from the Server” section on page 16-18.
- Pre Provision—Controls whether the DCNM-LAN client displays some settings only when other settings are made or whether the DCNM-LAN client always displays all settings. For more information, see the “Configuring Preprovisioning” section on page 16-19.

Configuring Monitoring Preferences

You can configure the default frequency for statistical data retrieval from monitored devices. The default frequency for statistical data retrieval is 30 seconds. This frequency determines the initial data retrieval frequency for a new chart. Users can override the default frequency by configuring the chart-specific setting.

You can also configure whether the DCNM-LAN client automatically opens statistical charts when you access the Statistics tab of an object for which DCNM-LAN is already collecting statistical data.

BEFORE YOU BEGIN

Determine how often you want DCNM-LAN to retrieve statistical data by default. Consider how important it is to your organization that charts update frequently. If very current charting data is important to your organization, consider using a short data retrieval frequency.

DETAILED STEPS

Step 1

From the menu bar, choose **Tools > Preferences**.

The Global Preferences dialog box appears. Under Monitoring, the Default Monitoring Frequency drop-down list displays the current frequency for statistical data retrieval.
The default polling frequency is 30 seconds.

**Step 2** If you want to configure the default frequency of statistical data retrieval, from the Default Monitoring Frequency drop-down list, choose the new data retrieval frequency.

**Step 3** If you want to configure the default behavior when you access the Statistics tab of an object for which DCNM-LAN is already collecting statistical data, do one of the following:

- If you want the client to show charts without asking for confirmation, check the **Load history charts by default** check box.
- If you want the client to prompt you for confirmation before it opens statistical charts, uncheck the **Load history charts by default** check box.

**Step 4** Click **Ok**.

**RELATED TOPICS**

- Accessing a Chart, page 16-12
- Configuring the Maximum Age of Events Fetched from the Server, page 16-18
- Configuring Preprovisioning, page 16-19

### Configuring the Maximum Age of Events Fetched from the Server

You can configure the maximum age of events that the DCNM-LAN client fetches from the DCNM-LAN server when you start the DCNM-LAN client. This setting affects how old the events are that the DCNM-LAN client displays in the Event Browser and on feature-specific Events tabs. By default, the DCNM-LAN client fetches events that occurred up to 1 hour prior to the DCNM-LAN client startup. You can configure the DCNM-LAN client to fetch events that are up to 24 hours old.

**DETAILED STEPS**

**Step 1** From the menu bar, choose **Tools > Preferences**.

The Global Preferences dialog box appears. Under Events, the Fetch events before drop-down list displays the current maximum age of events.

**Step 2** From the Fetch events before drop-down list, choose the new maximum age of events.

**Note**

To prevent the DCNM-LAN client from fetching any old events, choose zero (0) hours as the maximum age of events. When you choose zero hours, the DCNM-LAN client shows only the events that the DCNM-LAN server receives after you start the DCNM-LAN client.

**Step 3** Click **Ok**.

**RELATED TOPICS**

- Configuring Monitoring Preferences, page 16-17
- Configuring Preprovisioning, page 16-19
Configuring Preprovisioning

Preprovisioning refers to configuring a managed device with settings for modes or protocols that are not enabled. The preprovisioning preference affects the following sections of the DCNM-LAN client interface:

- **Interfaces > Physical > Ethernet > Device > Slot > Interface, Port Details tab, Port Mode Settings section**
  
  When you enable preprovisioning, the DCNM-LAN client displays all port mode fields regardless of the setting in the Mode drop-down list. When you disable preprovisioning, the DCNM-LAN client displays only the port mode settings that are relevant to the currently selected port mode. For example, if preprovisioning is disabled and you choose Trunk from the Mode drop-down list, the DCNM-LAN client displays only the Trunk settings and hides the Access, PVLAN Host, and PVLAN Promiscuous fields.

  Additionally, the dialog boxes for configuring the Access VLAN field and the Native VLAN field include the Create in the Device check box. When you enable preprovisioning, you can uncheck this check box if you want DCNM-LAN to configure the device to refer to a VLAN that is not currently configured. When you disable preprovisioning, this check box is always checked and DCNM-LAN creates the VLAN specified, if it does not already exist.

- **Switching > Spanning Tree > Device, Configuration tab, Global Settings section**
  
  When you enable preprovisioning, the DCNM-LAN client displays MST settings regardless of the settings in the Protocol drop-down list. When you disable preprovisioning, the DCNM-LAN client displays the MST Setting fields unless you choose MST from the Protocol drop-down list.

**DETAILED STEPS**

**Step 1**

From the menu bar, choose **Tools > Preferences**.

The Global Preferences dialog box appears. Under Pre Provision, the Pre Provision check box appears.

**Step 2**

Do one of the following:

- If you want to enable preprovisioning, ensure that the **Pre Provision** check box is checked.
- If you want to disable preprovisioning, ensure that the **Pre Provision** check box is unchecked.

**Step 3**

Click **Ok**.

**RELATED TOPICS**

- Configuring Monitoring Preferences, page 16-17
- Configuring the Maximum Age of Events Fetched from the Server, page 16-18

**Using Online Help**

Online help has the following features:

- **Contents**—The organization of DCNM-LAN online help is shown in the Contents tab of the online help window. When a topic has subtopics, the book icon appears to the left of the topic in the contents.
You can expand and collapse individual topics in the contents. You can also collapse or expand all topics.

- **Index**—DCNM-LAN online help includes an index, which allows you to look up subjects alphabetically and open related topics directly from the index.

- **Favorites**—DCNM-LAN online help allows you to add specific topics to the Favorites tab. Favorites are stored locally on the computer that you use to access online help.

To access the welcome page in online help, from the menu bar, choose **Help > Help Contents**.

DCNM-LAN online help includes context-sensitive help.

To access context-sensitive help for a feature, follow these steps:

---

**Step 1** Select a specific feature from the Feature Selector pane in the DCNM-LAN client. For example, choose **Security > Access Control > IPv4 ACL**.

**Step 2** Do one of the following:

- Press **F1**.
- From the toolbar, click the question mark icon.

Online help for the selected feature appears in a browser window. DCNM-LAN uses the default browser application on the computer that runs the DCNM-LAN client.
CHAPTER 17

Administering DCNM-LAN Authentication Settings

This chapter describes how to administer Cisco Data Center Network Manager for LAN (DCNM-LAN) authentication settings.

Cisco DCNM authentication settings determine how a Cisco DCNM server authenticates users who attempt to access the server with the Cisco DCNM client. They also determine the user role for the user, which affects what the user can configure in the Cisco DCNM client.

As described in the following table, Cisco DCNM supports two user roles.

<table>
<thead>
<tr>
<th>Cisco DCNM Role</th>
<th>Description</th>
</tr>
</thead>
</table>
| User            | • Cannot change Cisco DCNM authentication mode  
                  • Cannot add or delete Cisco DCNM local user accounts  
                  • Can change the details of its own local user account  
                  • Can use all other features |
| Administrator    | • Has full control of Cisco DCNM authentication settings  
                  • Can use all other features |

This chapter includes the following sections:

- Information About Administering DCNM-LAN Authentication Settings, page 17-2
- Licensing Requirements for Administering DCNM-LAN Authentication Settings, page 17-5
- Prerequisites for Administering DCNM-LAN Authentication Settings, page 17-5
- Guidelines and Limitations for Administering DCNM-LAN Authentication Settings, page 17-5
- Configuring DCNM-LAN Authentication Settings, page 17-5
- Viewing DCNM-LAN Local Users, page 17-13
- Verifying Authentication Server Settings, page 17-13
- Field Descriptions for DCNM-LAN Authentication Settings, page 17-14
- Additional References, page 17-16
- Feature History for DCNM-LAN Authentication Settings, page 17-17
Information About Administering DCNM-LAN Authentication Settings

DCNM-LAN authentication settings determine how a DCNM-LAN server authenticates users who attempt to access the server with the DCNM-LAN client. They also determine the user role for the user, which affects what the user can configure in the DCNM-LAN client.

This section contains the following topics:

- Users and User Roles, page 17-2
- Local Authentication and DCNM-LAN Local Users, page 17-2
- RADIUS and TACACS+ Authentication, page 17-3
- User Role Assignment by RADIUS and TACACS+, page 17-3
- Fallback to Local Authentication, page 17-4
- Password Recovery, page 17-4
- Users and Device Credentials, page 17-4
- Virtualization Support, page 17-4

Users and User Roles

DCNM-LAN implements user-based access to allow you to control who can access a DCNM-LAN server by using the DCNM-LAN client. User access is secured by a password. DCNM-LAN supports strong passwords.

When you ensure that each person who accesses DCNM-LAN has a unique user account, user-based access allows you to determine what actions are taken by each user.

In addition, DCNM-LAN allows you to assign a role to each user. Roles determine what actions a user can take in the DCNM-LAN client. As described in Table 17-1, DCNM-LAN supports two user roles.

<table>
<thead>
<tr>
<th>DCNM-LAN Role</th>
<th>Description</th>
</tr>
</thead>
</table>
| User          | - Cannot change DCNM-LAN authentication mode
|               | - Cannot add or delete DCNM-LAN local user accounts
|               | - Can change the details of its own local user account
|               | - Can use all other features |
| Administrator  | - Has full control of DCNM-LAN authentication settings
|               | - Can use all other features |

Local Authentication and DCNM-LAN Local Users

The DCNM-LAN database contains any DCNM-LAN local users that you create.
DCNM-LAN server users are local to the DCNM-LAN server. Creating, changing, and removing DCNM-LAN server users has no effect on user accounts on managed devices.

A DCNM-LAN server uses local users to grant access in the following cases:
- When the authentication mode is local
- When no authentication server for the current authentication mode is reachable.

You can use local authentication as the primary authentication mode. If you specify RADIUS or TACACS+ as the primary authentication mode, the DCNM-LAN server always falls back to local authentication if no authentication server for the current authentication mode is reachable.

**Attribute Setup for External AAA using ACS 5.x**

The steps for ACS 5.x TACACS+ are to essentially configure the following under Police Elements / Authorization and Permissions / Device Administration / Shell Profiles / shell profile name:
- Attribute: cisco-av-pair
- Requirement: optional
- Value: shell:roles="network-admin"

**RADIUS and TACACS+ Authentication**

You can configure DCNM-LAN to authenticate users with either the RADIUS or TACACS+ AAA protocol.

DCNM-LAN supports primary, secondary, and tertiary authentication servers for RADIUS and TACACS+. Only a primary server is required. For each authentication server, you can specify the port number that the server listens to for authentication requests.

During authentication, if the primary server for the current authentication mode does not respond to the authentication request, the DCNM-LAN server sends the authentication request to the secondary server. If the secondary server does not respond, DCNM-LAN sends the authentication request to the tertiary server.

If none of the servers configured for the current authentication mode responds to an authentication request, the DCNM-LAN server falls back to local authentication.

**User Role Assignment by RADIUS and TACACS+**

DCNM-LAN supports the assignment of a user role by the RADIUS or TACACS+ server that grants a user access to the DCNM-LAN client. The user role assigned to a user is in effect for the current session in the DCNM-LAN client only.

To assign a DCNM-LAN user role by RADIUS, configure the RADIUS server to return the RADIUS vendor-specific attribute 26/9/1, which is the Cisco-AV-Pair attribute. To assign a DCNM-LAN user role by TACACS+, the TACACS+ server must return a cisco-av-pair attribute-value pair. If an authentication response does not assign the user role, DCNM-LAN assigns the User role. Table 17-2 shows the supported attribute-value pair values for each DCNM-LAN user role.
Information About Administering DCNM-LAN Authentication Settings

Chapter 17  Administering DCNM-LAN Authentication Settings

Table 17-2  DCNM-LAN User Role Assignment Values

<table>
<thead>
<tr>
<th>DCNM-LAN Role</th>
<th>RADIUS Cisco-AV-Pair Value</th>
<th>TACACS+ Shell cisco-av-pair Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>shell:roles = &quot;network-operator&quot;</td>
<td>cisco-av-pair:shell:roles=&quot;network-operator&quot;</td>
</tr>
<tr>
<td>Administrator</td>
<td>shell:roles = &quot;network-admin&quot;</td>
<td>cisco-av-pair:shell:roles=&quot;network-admin&quot;</td>
</tr>
</tbody>
</table>

Fallback to Local Authentication

Local authentication always is the fallback method for RADIUS and TACACS+ authentication modes. If none of the servers configured for the current authentication mode is available, the DCNM-LAN server uses the local database to authenticate login requests. This behavior is designed to help you prevent accidental lockout from DCNM-LAN.

For users who need fallback support, the usernames of their local user accounts must be identical to their usernames on the authentication servers. Also, we recommend that their passwords in the local user accounts should be identical to their passwords on the authentication servers in order to provide transparent fallback support. Because the user cannot determine whether an authentication server or the local database is providing the authentication service, using usernames and passwords on authentication servers that are different than the usernames and passwords in the local database means that the user cannot be certain which username and password should be given.

Password Recovery

If no one can log into the DCNM-LAN client as a user with a DCNM-LAN Administrator role, you can reset passwords by using one of the following scripts:

- For Microsoft Windows, use /user/local/cisco/dcm/fm/bin/adduser.bat.
- For Linux, use /user/local/cisco/dcm/fm/bin/adduser.sh.

To reset a password, run the script for the operating system that you are using, and then enter the user ID to be reset and the password to be used for it.

Alternatively, you can reinstall the DCNM-LAN server, which allows you to specify the username and password for a local user account that is assigned the Administrator role. For more information, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.

Users and Device Credentials

Each DCNM-LAN server user has unique device credentials, regardless of whether the user authenticates with a local user account or an account on a RADIUS or TACACS+ server. This feature allows you to maintain accounting logs on managed devices that reflect the actions of each DCNM-LAN server user. For more information, see the “Information About Devices and Credentials” section on page 30-1.

Virtualization Support

Cisco NX-OS support for virtual device contexts has no effect on DCNM-LAN server users.
DCNM-LAN server users can configure any managed device.

Licensing Requirements for Administering DCNM-LAN Authentication Settings

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Administering Cisco DCNM-LAN authentication settings requires no license. Any feature not included in a license package is bundled with the Cisco DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM-LAN LAN Enterprise license, see the Cisco DCNM Installation and Licensing Guide, Release 5.x.</td>
</tr>
</tbody>
</table>

Prerequisites for Administering DCNM-LAN Authentication Settings

Administering DCNM-LAN authentication settings has the following prerequisites:

- You must ensure that every authentication server that you want to use with DCNM-LAN is configured to accept authentication requests from the DCNM-LAN server.
- To add, delete, or modify DCNM-LAN local users, you must be logged into the DCNM-LAN client with a user account that is assigned the Administrator DCNM-LAN role.

Guidelines and Limitations for Administering DCNM-LAN Authentication Settings

Administering DCNM-LAN authentication settings has the following configuration guidelines and limitations:

- Create a DCNM-LAN user account for each person who uses the DCNM-LAN client. Do not allow people to share a user account.
- Delete unused DCNM-LAN user accounts.
- Grant an administrator user account only to those who need to perform administrator tasks in the DCNM-LAN client.
- We recommend that you use strong passwords. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

Configuring DCNM-LAN Authentication Settings

This section includes the following topics:
Configuring the Authentication Mode

*Does this apply to API sessions, too? Or just the DCNM client?*

You can configure the mode that the DCNM-LAN server uses to authenticate DCNM-LAN client users.

**BEFORE YOU BEGIN**

Log into the DCNM-LAN client with a user account that has the Administrator user role.

If you want to enable RADIUS or TACACS+ authentication mode, you must configure at least one authentication server for the desired authentication mode.

**DETAILED STEPS**

1. From the Feature Selector pane, choose **DCNM Server Administration > DCNM Authentication Settings**.
2. If necessary, expand the Authentication Mode section.
3. Choose the authentication mode.
4. From the menu bar, choose **File > Deploy** to apply your changes to the DCNM-LAN server.
5. Restart the DCNM-LAN server. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x* Chapter 27, “Starting and Stopping Cisco DCNM-LAN Servers.”

**RELATED TOPICS**

- Adding a DCNM-LAN Local User, page 17-6
- Adding Authentication Servers, page 17-10

**Adding a DCNM-LAN Local User**

You can add a DCNM-LAN local user account.

*Note*  
Adding a DCNM-LAN local user account does not affect the user account configuration on any Cisco NX-OS device.
BEFORE YOU BEGIN

Log into the DCNM-LAN client with a user account that has the Administrator user role.
Determine the username and password for the new DCNM-LAN local user account.

Note
We recommend that you use a strong password. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > DCNM Authentication Settings.
Step 2 If necessary, expand the DCNM Local Users section.
A table of users appears in the Cisco DCNM Local Users section.
Step 3 From the menu bar, choose Actions > Add User.
A new row appears at the bottom of the list of users. By default, all fields in the new row are blank.
Step 4 In the DCNM User Name column of the new row, enter the username. The username can be 1 to 198 characters. Entries can contain case-sensitive letters, numbers, and symbols.
Step 5 (Optional) In the Full Name column, double-click the entry and add a name. For example, enter the real name of the person who will use the DCNM-LAN local user account. The maximum length is 255 case-sensitive letters, numbers, and symbols.
Step 6 In the DCNM Role column, double-click the entry and choose the role. By default, the role is User.
Step 7 In the Password column, double-click the entry and then click the down-arrow button.
Step 8 In the New Password field and the Confirm Password field, enter the password. The password can be 1 to 255 characters. Entries can contain case-sensitive letters, numbers, and symbols.
Step 9 Click OK.
Step 10 (Optional) In the Description column, double-click the entry and add a description of the user account. For example, you could use this entry to provide e-mail and telephone contact details of the person who will be using this DCNM-LAN server user account. The maximum length is 255 case-sensitive letters, numbers, and symbols.
Step 11 From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Changing the Password of a DCNM-LAN Local User, page 17-8
- Changing the Full Name, Role, or Description of a DCNM-LAN Local User, page 17-8
- Deleting a DCNM-LAN Server User, page 17-9
Changing the Password of a DCNM-LAN Local User

You can change the password of a DCNM-LAN local user.

BEFORE YOU BEGIN

An Administrator role is required if you want to change the password of a local user account other than the account that you use to log into the DCNM-LAN client. If your user account is a local user account and it has the User role, you can change the password of your account only.

Determine what the new password should be.

Note

We recommend that you use a strong password. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > DCNM Server Authentication Settings.

Step 2 If necessary, expand the DCNM Local Users section.

A table of users appears in the DCNM Local Users section.

Step 3 In the User Name column, click the username for the user account that you want to change.

The row of the username that you clicked is highlighted.

Step 4 In the Password column, double-click the entry and then click the down-arrow button.

Step 5 In the New Password field and the Confirm Password field, enter the new password. The password can be 1 to 255 characters. Entries can contain case-sensitive letters, numbers, and symbols.

Step 6 Click OK.

Step 7 From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Adding a DCNM-LAN Local User, page 17-6
- Changing the Full Name, Role, or Description of a DCNM-LAN Local User, page 17-8
- Deleting a DCNM-LAN Server User, page 17-9

Changing the Full Name, Role, or Description of a DCNM-LAN Local User

You can change the full name, role, or description of a DCNM-LAN local user.

Note

You cannot change the username. Instead, add a local user account with the desired username and remove the local user account with the unwanted username.
BEFORE YOU BEGIN

Determine what the new full name or description should be.

An Administrator role is required if you want to change the full name, role, or description of a local user account other than the local user account that you use to log into the DCNM-LAN client. If your user account is a local user account and it has the User role, you can change the full name and description for your account only.

what about sessions where the user was authenticated remotely but with a username that’s identical to a local user? what if the p/w is the same, too?

DETAILED STEPS

---

**Step 1**
From the Feature Selector pane, choose DCNM Server Administration > DCNM Authentication Settings.

**Step 2**
If necessary, expand the DCNM Local Users section.

A table of users appears in the Cisco DCNM Local Users section.

**Step 3**
In the User Name column, click the username of the local user account that you want to change.

The row of the username that you clicked is highlighted.

**Step 4**
(Optional) In the Full Name column, double-click the entry and enter the new name. The maximum length is 255 case-sensitive letters, numbers, and symbols.

**Step 5**
(Optional) In the DCNM Role column, double-click the entry and choose the new role. You can choose Administrator or User.

**Step 6**
(Optional) In the Description column, double-click the entry and enter the new description of the user account. The maximum length is 255 case-sensitive letters, numbers, and symbols.

**Step 7**
From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

---

RELATED TOPICS

- Adding a DCNM-LAN Local User, page 17-6
- Changing the Password of a DCNM-LAN Local User, page 17-8
- Deleting a DCNM-LAN Server User, page 17-9

Deleting a DCNM-LAN Server User

You can remove a DCNM-LAN local user account.

BEFORE YOU BEGIN

Log into the DCNM-LAN client with a user account that has the Administrator user role.

Ensure that you are removing the correct DCNM-LAN local user account.
Chapter 17  Administering DCNM-LAN Authentication Settings

DETAILED STEPS

Step 1  From the Feature Selector pane, choose **DCNM Server Administration > DCNM Authentication Settings**.

Step 2  If necessary, expand the **DCNM Local Users** section.
A table of users appears in the DCNM Local Users section.

Step 3  In the **User Name** column, click the username of the user account that you want to remove.
The row of the username that you clicked is highlighted.

Step 4  From the menu bar, choose **Actions > Delete User**.

Step 5  From the menu bar, choose **File > Deploy** to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- [Adding a DCNM-LAN Local User](#), page 17-6
- [Changing the Password of a DCNM-LAN Local User](#), page 17-8
- [Changing the Full Name, Role, or Description of a DCNM-LAN Local User](#), page 17-8

Adding Authentication Servers

You can add RADIUS and TACACS+ servers to the DCNM-LAN authentication settings.

BEFORE YOU BEGIN

You must ensure that every authentication server that you want to use with DCNM-LAN is configured to accept authentication requests from the DCNM-LAN server.

Ensure that you have the following information about each authentication server that you want to add:

- AAA protocol: RADIUS or TACACS+
- Server IPv4 address or DNS name that can be resolved by the DCNM-LAN server.
- Secret key.
- Port number on which the server accepts authentication requests.
- (RADIUS only) Port number on which the server accepts accounting messages.
- Authentication protocol: PAP, CHAP, MSCHAP, or ASCII.
- (Optional) Username and password of a valid user account on the server for server verification.

Determine whether the server should be a primary, secondary, or tertiary server, which depends upon your authentication server failover strategy.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose **DCNM Server Administration > DCNM Authentication Settings**.
Step 2 If necessary, expand the Authentication Servers section.

The Authentication Server Settings table shows RADIUS and TACACS+ server settings.

Step 3 If necessary, expand the RADIUS or TACACS+ server rows.

Step 4 For each authentication server that you want to add, follow these steps:
   a. Choose the row in which you want to add the server.

   Note The DCNM-LAN client does not allow you to add a secondary server if you have not added a primary server. In addition, you cannot add a tertiary server if you have not added a secondary server.

   b. Double-click the Server Name field and enter the server IPv4 address or DNS hostname.

   Note If you enter a hostname that the DCNM-LAN server cannot resolve, the Server Name field is highlighted in red.

   c. Double-click the Secret Key field and enter the secret key (sometimes called a shared secret) of the authentication server.

   d. (Optional) If you need to change the default Authentication Port or Accounting Port (RADIUS only), double-click the applicable port field and enter the new port number.

   e. Double-click the Authentication Method field and choose the authentication protocol that DCNM-LAN must use when sending authentication requests to the authentication server.

Step 5 (Optional) If you want to verify that the DCNM-LAN server can authenticate a user with a new authentication server, follow these steps:
   a. To the right of the row for the authentication server that you want to verify, click Verify.

       A Verification dialog box appears.

   b. Enter a username and password for a valid user account on the authentication server.

   c. Click Verify.

The DCNM-LAN client displays a message indicating whether the verification attempt succeeded or failed. A verification failure may mean that the authentication server is unavailable or that the authentication settings are incorrect.

Step 6 From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring the Authentication Mode, page 17-6
- Changing Authentication Server Settings, page 17-12
- Removing an Authentication Server, page 17-12
- Verifying Authentication Server Settings, page 17-13
Changing Authentication Server Settings

You can change the settings for authentication servers that you have already configured in the DCNM-LAN client. If you have more than one RADIUS or TACACS+ server, you can change which server is primary, secondary, or tertiary.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose DCNM Server Administration > DCNM Authentication Settings.

Step 2  If necessary, expand the Authentication Servers section.

The Authentication Server Settings table shows RADIUS and TACACS+ server settings.

Step 3  If necessary, expand the RADIUS or TACACS+ server rows.

Step 4  (Optional) If you want to change the settings of an authentication server, double-click each field that you need to change and enter the changes.

Step 5  (Optional) If you want to reorder RADIUS or TACACS+ servers, right-click a server and choose Move Up or Move Down, as needed.

Step 6  (Optional) If you want to verify that the DCNM-LAN server can authenticate a user with an authentication server, follow these steps:

a. To the right of the row for the authentication server that you want to verify, click Verify. A Verification dialog box appears.

b. Enter a username and password for a valid user account on the authentication server.

c. Click Verify.

The DCNM-LAN client displays a message indicating whether the verification attempt succeeded or failed. A verification failure may mean that the authentication server is unavailable or that the authentication settings are incorrect.

Step 7  From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring the Authentication Mode, page 17-6
- Adding Authentication Servers, page 17-10
- Removing an Authentication Server, page 17-12
- Verifying Authentication Server Settings, page 17-13

Removing an Authentication Server

You can remove a RADIUS or TACACS+ authentication server from the DCNM-LAN authentication settings.
BEFORE YOU BEGIN

You cannot remove all authentication servers for the current authentication mode. Instead, change the authentication mode first and then remove all the authentication servers.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > DCNM Authentication Settings.

Step 2 If necessary, expand the Authentication Servers section.

The Authentication Server Settings table shows RADIUS and TACACS+ server settings.

Step 3 If necessary, expand the RADIUS or TACACS+ server rows.

Step 4 Right-click the authentication server that you want to remove and choose Remove Server.

Step 5 From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring the Authentication Mode, page 17-6
- Adding Authentication Servers, page 17-10
- Changing Authentication Server Settings, page 17-12
- Verifying Authentication Server Settings, page 17-13

Viewing DCNM-LAN Local Users

To view DCNM-LAN server user accounts, from the Feature Selector pane, choose DCNM Server Administration > DCNM Authentication Settings and then, if necessary, expand the Cisco DCNM Local Users section.

DCNM-LAN server user accounts, including usernames and descriptions, appear in the Contents pane. Passwords appear masked for security. For information about the fields that appear, see the “Field Descriptions for DCNM-LAN Authentication Settings” section on page 17-14.

RELATED TOPICS

- Adding a DCNM-LAN Local User, page 17-6
- Changing the Password of a DCNM-LAN Local User, page 17-8
- Changing the Full Name, Role, or Description of a DCNM-LAN Local User, page 17-8
- Deleting a DCNM-LAN Server User, page 17-9

Verifying Authentication Server Settings

You can verify that the DCNM-LAN server can authenticate a user with a particular authentication server that you have configured.
Field Descriptions for DCNM-LAN Authentication Settings

**DETAILED STEPS**

**Step 1**  
From the Feature Selector pane, choose **DCNM Server Administration > DCNM Authentication Settings**.

**Step 2**  
If necessary, expand the **Authentication Servers** section.  
The Authentication Server Settings table shows RADIUS and TACACS+ server settings.

**Step 3**  
Click **Verify**.  
A Verification dialog box appears.

**Step 4**  
Enter a username and password for a valid user account on the authentication server.

**Step 5**  
To the right of the row for the authentication server that you want to verify, click **Verify**.  
The DCNM-LAN client displays a message indicating whether the verification attempt succeeded or failed. A verification failure may mean that the authentication server is unavailable or that the authentication settings are incorrect.

**RELATED TOPICS**

- Adding Authentication Servers, page 17-10  
- Removing an Authentication Server, page 17-12  
- Verifying Authentication Server Settings, page 17-13

**Field Descriptions for DCNM-LAN Authentication Settings**

This section includes the following field descriptions for the DCNM-LAN Authentication Settings feature:

- Authentication Mode Section, page 17-14  
- DCNM-LAN Local Users Section, page 17-15  
- Authentication Servers Section, page 17-15

**Authentication Mode Section**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local</td>
<td>Whether DCNM-LAN authenticates users with the local user database only.</td>
</tr>
<tr>
<td>RADIUS</td>
<td>Whether DCNM-LAN authenticates users with a RADIUS server. When no configured RADIUS server is reachable, DCNM-LAN falls back to using the local database for user authentication.</td>
</tr>
<tr>
<td>TACACS+</td>
<td>Whether DCNM-LAN authenticates users with a TACACS+ server. When no configured TACACS+ server is reachable, DCNM-LAN falls back to using the local database for user authentication.</td>
</tr>
</tbody>
</table>
DCNM-LAN Local Users Section

Table 17-4  DCNM-LAN Local Users Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCNM-LAN User Name</td>
<td>Display only. Name of the DCNM-LAN server user account. This name can be used to log into the DCNM-LAN client when the authentication mode is local or when no authentication server for the current authentication mode is reachable. Entries are case sensitive. Valid characters are all letters, numbers, and symbols. The minimum length is 1 character. The maximum length is 198 characters.</td>
</tr>
<tr>
<td>Full Name</td>
<td>Other name for the user account, such as the name of the person who uses the DCNM-LAN server user account. This name cannot be used to log into the DCNM-LAN client. Valid characters are all letters, numbers, and symbols. The maximum length is 255 characters. This field is blank by default.</td>
</tr>
<tr>
<td>DCNM-LAN Role</td>
<td>Role of the user account. Valid values are User and Administrator. For more information, see Table 17-1. By default, a DCNM-LAN server user account is assigned the role of User.</td>
</tr>
<tr>
<td>Password</td>
<td>Password for the DCNM-LAN server user. This field is always masked for security. Entries are case sensitive. Valid characters are all letters, numbers, and symbols. The minimum length is 1 character. The maximum length is 255 characters.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the DCNM-LAN server user. Valid characters are all letters, numbers, and symbols. The maximum length is 255 characters. This field is blank by default.</td>
</tr>
</tbody>
</table>

Authentication Servers Section

Table 17-5  Authentication Servers Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Server Name      | DNS name or IPv4 address of the authentication server.  
|                  | • DNS name—If you specify a DNS name, the DCNM-LAN server must be able to resolve the IP address of the server. Valid DNS names characters are alphanumeric.  
|                  | • IPv4 address—If you specify an IP address, valid entries are in dotted decimal format.                                                      |
| Secret Key       | Shared secret of the authentication server. Valid entries are case-sensitive letters, numbers, and symbols.                                   |
| Authentication Port | TCP or UDP port number that the authentication server listens to for authentication requests. By default, the authentication port for a RADIUS server is UDP port 1812 and the authentication port for a TACACS+ server is TCP port 49. |
Additional References

For additional information related to administering DCNM-LAN authentication settings, see the following sections:

- Related Documents, page 17-16
- Standards, page 17-16

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logging into the DCNM-LAN client</td>
<td>Opening the DCNM-LAN Client, page 16-8</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>
Feature History for DCNM-LAN Authentication Settings

Table 17-6 lists the release history for this feature.

Table 17-6  Feature History for DCNM-LAN Server Users

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCNM-LAN Authentication Settings</td>
<td>5.0(2)</td>
<td>No change from Release 4.2.</td>
</tr>
</tbody>
</table>
This chapter describes how to use the Topology feature in Cisco Data Center Network Manager for LAN (DCNM-LAN).

The Topology feature provides you with a topology map of supported Cisco NX-OS devices. The topology map also shows switches that run Cisco IOS software, such as the Catalyst 6500 series switches, that are linked by the Cisco Discovery Protocol (CDP). For Catalyst 6500 series switches, the physical topology view of the map displays these switches and their links to other devices. For Nexus 7000 Series devices, the map shows details about virtual device contexts (VDCs).

When Cisco Data Center Network Manager (DCNM) receives new information, the Cisco DCNM client updates the map dynamically. By default, updates occur once a minute. You can see changes occur to the status of links and devices, such as links going down or VDC creation, deletion, or modification.

Because the map is always current, you can use it to troubleshoot ongoing network management issues.

Device states are shown on the map. The possible states are as follows:

- **Managed**—You can configure and monitor the device with Cisco DCNM. For the device state to be Managed, device discovery must succeed.
- **Discovery**—Cisco DCNM is currently discovering the device. You cannot configure or monitor the device with Cisco DCNM unless discovery succeeds and the device state changes to Managed. If discovery fails, the device state will change to Unmanaged.
- **Unmanaged**—You cannot configure or monitor the device with Cisco DCNM because discovery failed or a Cisco DCNM user explicitly changed the device state to Unmanaged by using the Devices and Credentials feature.
- **Unreachable**—You cannot configure or monitor the device because the Cisco DCNM server cannot connect to the device. Data shown in Cisco DCNM may be out of date. Common causes for this state are that a network issue is preventing the Cisco DCNM server from connecting to the device, the SSH feature is disabled on the device, or all terminal lines on the device are in use. When connectivity is restored, the state of the device will return to Managed.

For more information about device states, see the Understanding Device Icons and Links.

You can modify and save the layout of device icons. The map also provides you quick access to configuring features for a managed device.

This chapter includes the following sections:

- [Information About Topology](#)
- [Licensing Requirements for Topology](#)
- [Prerequisites for Topology](#)
- [Guidelines and Limitations](#)
Information About Topology

The Topology feature provides you with a topology map of supported Cisco NX-OS devices. The topology map also shows switches that run Cisco IOS software, such as the Catalyst 6500 series switches. For Nexus 7000 Series devices, the map shows details about virtual device contexts (VDCs).

When Cisco Data Center Network Manager for LAN (DCNM-LAN) receives new information, the DCNM-LAN client updates the map dynamically. By default, updates occur once a minute. You can see changes occur to the status of links and devices, such as links going down or VDC creation, deletion, or modification.

Because the map is always current, you can use it to troubleshoot ongoing network management issues.

You can modify and save the layout of device icons. The map also provides you quick access to configuring features for a managed device.

This section includes the following topics:

- Map Views, page 18-2
- Layouts, page 18-6
- vPC Support, page 18-7
- DCNM-SAN Support, page 18-7
- FabricPath Support, page 18-7
- Device Groups, page 18-8
- Network Servers, page 18-9

Map Views

The topology map includes four views of your topology as described in the following topics:

- Physical View, page 18-3
- PortChannel and vPC, page 18-4
- Logical vPC View, page 18-5
- L2 View, page 18-6
Physical View

The Physical View (see Figure 18-1) shows the physical connections between discovered devices. This is the default topology view.

Figure 18-1   Physical View of the Topology Map
PortChannel and vPC

The PortChannel and vPC view (see Figure 18-2) shows all physical connections and all logical connections among discovered devices, including port channel links, virtual port channel (vPC) links, and vPC peer links. Physical links appear in gray in this view.

Figure 18-2  PortChannel and vPC View of the Topology Map
Logical vPC View

The Logical vPC View (see Figure 18-3) shows vPC links and vPC peer links among discovered devices, without showing the physical connections.

Figure 18-3 Logical vPC View of the Topology Map
L2 View

The L2 view (see Figure 18-4) shows VLANs configured among discovered devices. Beginning with Cisco DCNM-LAN Release 5.1, the VSAN Overlay is a part of the L2 view. The VSAN Overlay feature enables you to view the Fibre Channel (FC) and Fibre Channel over Ethernet (FCoE) links that are active for a given VSAN or a range of VSANs. It also provides a visual representation of forwarding and non-forwarding links between Cisco Nexus devices in a data center network for configured VLANs.

Figure 18-4  L2 View of the Topology Map

Layouts

The topology map enables you to move devices to where you want them. You can save the layout so that the next time you use the topology map, devices are where you placed them. The DCNM-LAN client saves topology layouts as local user data on the computer that runs the DCNM-LAN client. When you are using the DCNM-LAN client, you do not have access to topology layouts that you saved on other computers or that you saved while logged in to the computer under a different username.

In addition to saved layouts, when you are using the Physical View, you can load one of the following layouts:

- **Spring**—Devices appear in locations determined by weighting the connections, which often produces a layout with minimal or no crossed connections.
- **Tree**—Devices appear in a tree unless connections create loops among the devices, in which case devices appear in a spanning tree, that is, a grid in which most of the connections follow the grid layout.
vPC Support

The topology map provides the following additional vPC-specific features:

- **vPC creation**—You can launch the vPC Creation Wizard from the PortChannel and vPC view. See the “Launching the vPC Wizard” section on page 18-37.
- **Quick access to the vPC feature**—You can access the configuration for a specific vPC from the PortChannel and vPC view or the Logical vPC View. See the “Managing a vPC” section on page 18-38.
- **vPC configuration inconsistency**—You can see vPC links and vPC peer links that have configuration inconsistencies. You can open the Resolve Configuration Consistency dialog box from the topology map. See the “Finding and Resolving vPC Configuration Inconsistencies” section on page 18-39.

DCNM-SAN Support

The DCNM-LAN topology map supports Cisco Data Center Network Manager for SAN (DCNM-SAN) by providing the features described in the following topics:

- **Common Topology**, page 18-7
- **Access to DCNM-SAN Features**, page 18-7

Common Topology

The topology map can show storage area network (SAN) connections and devices in addition to Ethernet LAN connections and devices. You can use the DCNM-LAN topology map to view your entire data center network.

Access to DCNM-SAN Features

When a SAN device, such as a Cisco MDS 9000 Family Multilayer Switch, appears in the topology map in the DCNM-LAN client, you can use the topology map to launch the Cisco DCNM-SAN client and configure the SAN device.

The Cisco DCNM-SAN cross launch feature is only supported by the DCNM-LAN client when the Cisco DCNM-SAN is installed in Server mode. Cross launch is not supported by the DCNM-LAN client when the Cisco DCNM-SAN is installed in Standalone mode. In addition, cross launch is not supported when the DCNM-LAN client is in standalone mode.

For information about installing the DCNM-LAN client in standalone mode, see Chapter 15, “Installing and Launching the Cisco DCNM-LAN Client.”

For information about installing Cisco DCNM-SAN and DCNM-LAN on the same server system, see the *Cisco DCNM Installation and Licensing Guide, Release 7.1.x*.

FabricPath Support

FabricPath support for L2MP capable devices, running the L2MP-ISIS protocol, is available in the L2 View of the Topology drawer. The L2 View contains a dialog box that allows you to select the type of graph to display. When you select the Fabricpath view in the dialog box, you can display the following types of graphs:
Information About Topology

- Multi-destination
  A multi-destination or broadcast graph represents broadcast traffic and unknown unicast traffic in the topology.

- Reachability
  L2MP-ISIS automatically computes the switch ID reachability for each node in the network.

- Unicast
  A unicast graph displays equal cost routes between nodes in a network.

- Multicast
  A multicast graph displays the multicast traffic from a specified device to all hosts that are listening to a particular IGMP group.

In addition, the FabricPath Topology Wizard can be launched from the L2 View. The FabricPath Topology Wizard allows you to do many operations, such as add to the FabricPath topology, display inventory, and display end devices.

Note
The FabricPath Topology Wizard is not supported in Cisco NX-OS Release 5.1(1).

Note
- Starting from Cisco DCNM Release 6.1(1) the fabric path support feature will be available for the Cisco Nexus 55xx series switches.
- Starting from Cisco DCNM Release 6.1(1) the fabric path support feature will be licensed.

To launch the wizard, you need to select more than one device and right-click to display a context menu that lists the available operations. You can select multiple devices by holding down the shift key and clicking on the appropriate devices displayed on the graph. Alternatively, you may hold down the left mouse key and drag over the appropriate devices.

Device Groups

Device groups allow you to simplify the visualization of interconnections between groups of devices in the topology map. You can categorize devices into device groups that you define, which allows you to focus on a limited number of devices when you view the topology.

You can manage device groups using the topology map, which allows you to create groups, delete groups, and move devices among groups; however, the Device Groups feature is especially useful for assigning multiple devices to groups easily.
Network Servers

The topology map can show network servers. You can use the Network Servers feature to associate host bus adapters (HBAs) and Ethernet network adapters that DCNM-LAN discovered with the Link Layer Discovery Protocol (LLDP) to network servers.

Licensing Requirements for Topology

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>The Topology feature requires no license; however, the Logical vPC View of the topology map requires a LAN Enterprise license. Any feature not included in a license package is bundled with the Cisco DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 7.1.x</em>.</td>
</tr>
</tbody>
</table>

Prerequisites for Topology

Topology has the following prerequisites:

- The topology map shows only devices that DCNM-LAN has discovered.
- For full support on the topology map, discovered devices should have the applicable discovery protocols enabled, both globally and on active interfaces. For more information about the discovery protocols used by DCNM-LAN, see Chapter 29, “Administering Device Discovery.”

Guidelines and Limitations

Topology has the following configuration guidelines and limitations:

- While the Topology feature is an unlicensed feature, you must have a LAN Enterprise license to manage the nondefault VDCs of Cisco Nexus 7000 Series switches that appear in the topology.
- The Topology feature displays changes to the topology periodically as determined by the polling frequency for accounting and system logs. By default, the polling frequency is one minute. For more information, see the “Information About Auto-Synchronization with Devices” section on page 31-1.

Using the Topology Feature

This section includes the following topics:

- Opening the Topology Map, page 18-10
- Understanding Device Icons and Links, page 18-13
- Using the Viewing Tools, page 18-14
- Showing, Hiding, and Using the Details Pane, page 18-16
- Moving Devices in the Topology Map, page 18-18
Opening the Topology Map

You can open the topology map to view the topology of discovered devices.

When you open the topology map, you can choose one of the following topology views:

- **Physical View**—Shows the physical connections between discovered devices. This is the default topology view.
- **PortChannel and vPC**—Shows all physical connections and all logical connections among discovered devices, including port channels, vPCs, and vPC peer links. Physical links appear in gray in this view.
- **Logical vPC View**—Shows vPC and vPC peer links among discovered devices, without showing the physical connections.
- **L2 View**—Shows VLANs configured among discovered devices.

All views show the discovered devices in your network.

**Note**

Before discovery, if you are working with FabricPath, you must use the Command-Line-Interface (CLI) to accomplish the following:

- Install the Enhanced Layer 2 license on the device. See the *Cisco NX-OS Licensing Guide* for complete information on installing this license.
• Install the FabricPath feature set on the device. See the Cisco Configuring Feature Set for FabricPath Guide for complete information on installing the feature set.

• Configure the FabricPath feature set so that it can be enabled in a custom VDC. See the Cisco Configuring Feature Set for FabricPath Guide for complete information on configuring the feature set.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane. Buttons for each of the available topology views appear above the topology map.

Step 2  (Optional) If you want to change topology views, click the topology view name.
The topology map shows the view of the topology that you selected.

Step 3  (Optional) If you want to use a view-specific option, see the following table:
### Using the Topology Feature

#### Related Topics

- Understanding Device Icons and Links
- Using the Viewing Tools
- Showing, Hiding, and Using the Details Pane
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Accessing Cisco FabricPath Features from the Topology Map
- Moving Devices in the Topology Map
- Loading a Layout

---

<table>
<thead>
<tr>
<th>View Feature</th>
<th>Available In View</th>
<th>How to Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/Hide all VDCs</td>
<td>• Physical View</td>
<td>Right-click in the map and choose <strong>Show All VDCs</strong> or <strong>Hide All VDCs</strong>. When you view all VDCs, Cisco Nexus 7000 Series devices appear as gray boxes that contain device icons for each VDC configured on the Cisco Nexus 7000 Series device.</td>
</tr>
<tr>
<td>Show/Hide End Devices</td>
<td>• Physical View</td>
<td>Right-click in the map and choose <strong>Show End Devices</strong> or <strong>Hide End Devices</strong>.</td>
</tr>
</tbody>
</table>
| Filter VLANs                          | • L2 View         | 1. If the VLANs box does not appear on the map, click the Filter icon on the topology toolbar.  
2. Enter a list of VLAN IDs. You can specify a single VLAN ID, a range of VLAN IDs, or comma-separated IDs and ranges.  
3. Click **Filter**. |
| Show/Hide non-forwarding links        | • L2 View         | 1. On the map, find the VLANs box.  
2. Check or uncheck the **Show Non-Forwarding Link (Blocking & Disabled)** as needed. |
| Show/Hide vPCs or port channels       | • PortChannel and vPC | 1. On the map, find the gray box that contains the **Show vPC** check box and the **Show Port Channel** check box. You may need to scroll the map or zoom out to find the gray box.  
2. Check or uncheck the check boxes as needed. |
• Exporting the Topology as a JPG Image
• Launching the vPC Wizard
• Managing a vPC
• Copy Run to Start

Understanding Device Icons and Links

To understand the device icons and links shown in the topology map, you can open the legend. The legend presents information about the device icons and links shown in the currently selected topology view.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane. Buttons for each of the available topology views appear above the topology map.

Step 2
(Optional) If you want to change topology views, click the topology view name.
The topology map shows the view of the topology that you selected. The topology toolbar appears on the left side of the topology map.

Step 3
From the topology toolbar, click the icon.
The Legend dialog box displays information about the device icons and links that may appear in the currently selected topology view.

RELATED TOPICS

• Opening the Topology Map
• Using the Viewing Tools
• Showing, Hiding, and Using the Details Pane
• Launching the vPC Wizard
• Managing a vPC
• Showing or Hiding Network Servers
• Showing or Hiding Device Groups
• Accessing DCNM-LAN Features from the Topology Map
• Accessing Cisco DCNM-SAN Features from the Topology Map
• Accessing Cisco FabricPath Features from the Topology Map
• Moving Devices in the Topology Map
• Loading a Layout
• Exporting the Topology as a JPG Image
• Copy Run to Start
Using the Viewing Tools

You can use the pan, select, zoom, and search tools to view the topology map.

The map shows Nexus 7000 Series devices, switches that run Cisco IOS software, and CDP links between devices. The link colors have the following meanings:

- Dark gray—The link between the two devices is active.
- Light gray—In the Physical view, this color means that one of the devices is not reachable. In the PortChannel and vPC view, all physical links appear light gray.
- Red—The physical link between the two devices are down.

The map also indicates whether a link is a single port link or a multiple port link, as follows:

- Single port link—When one link connects two devices, the map connects the two devices with a thin line. The port icon at either end of the line shows a single port.
- Multiple port link—When more than one link connect two devices, the map connects the two devices with a thick line. The port icon at either end of the line shows two ports.

Tip

To view an explanation of some of icons and links show in the topology map, from the topology tool bar, click Legend. The Legend dialog box provides information for icons and links shown in the current topology view.

The following table describes the viewing tools that are available in the topology toolbar, which is on the left side of the topology map.

<table>
<thead>
<tr>
<th>Viewing Tool Icon and Name</th>
<th>How to Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan</td>
<td>Moves, or pans, the map.</td>
</tr>
<tr>
<td></td>
<td>1. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>2. Click anywhere on the topology map, and hold down the mouse button.</td>
</tr>
<tr>
<td></td>
<td>3. Drag the map in any direction.</td>
</tr>
<tr>
<td></td>
<td>4. Release the mouse button.</td>
</tr>
<tr>
<td>Select</td>
<td>Allows you to select a device, link, or port icon.</td>
</tr>
<tr>
<td></td>
<td>1. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>2. Click the device, link, or port icon that you want to work with.</td>
</tr>
<tr>
<td></td>
<td>A balloon displays information about the icon that you clicked.</td>
</tr>
<tr>
<td>Zoom in Rect</td>
<td>Zooms to a specific portion of the map.</td>
</tr>
<tr>
<td></td>
<td>1. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>2. Click on the map and drag a rectangle over the area that you want to see, and release the mouse button.</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Zooms in. Click the icon.</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Zooms out. Click the icon.</td>
</tr>
<tr>
<td>Fit to View</td>
<td>Fits the entire topology of discovered devices within the topology map. Click the icon.</td>
</tr>
</tbody>
</table>
Viewing Tool Icon and Name | How to Use
--- | ---
Reset Zoom | Resets the zoom to the default magnification. Click the icon.
Load Layout | Loads a layout.
Reload Layout | Loads the most recently saved layout. See the “Reloading the Previously Saved Layout” section on page 18-20.
Show Device Groups | Shows or hides device groups. See the “Showing or Hiding Device Groups” section on page 18-23.
Search | Allows you to use the device search tool, so that you can search for a device by its name.
1. To show the Search tool on the map, click the icon.
2. In the Device box, enter all or some of the name of the device that you want to search for, and then click the icon.
3. To hide the Search tool, click the icon again.
Tip You can move the Search tool on the topology map by clicking and dragging it when you have the Select tool enabled.
Save Layout | Saves changes that you have made to the device icon layout. See the “Moving Devices in the Topology Map” section on page 18-18.
Hide/Show Details | Shows and hides the details pane. See the “Showing, Hiding, and Using the Details Pane” section on page 18-16.
Legend | Opens the Legend dialog box. See the “Understanding Device Icons and Links” section on page 18-13.
Export as JPG | Saves the topology map as a JPG image file. See the “Exporting the Topology as a JPG Image” section on page 18-30.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Showing, Hiding, and Using the Details Pane
- Launching the vPC Wizard
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco FabricPath Features from the Topology Map
- Moving Devices in the Topology Map
- Loading a Layout
- Copy Run to Start
Showing, Hiding, and Using the Details Pane

You can show or hide the Details pane within the topology map. When you are showing the Details pane, you can use the sections within the Details pane to learn about the devices and connections in the topology.

DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Tip
To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
To show or hide details, click the icon.

When you choose to show details, the Details pane appears between the topology toolbar and the topology map.

Tip
Ensure that the Select tool is selected. To select the Select tool, click the icon.

**Step 3**
To use the sections within the Details pane, see the following table:
### Section Available In How to Use

<table>
<thead>
<tr>
<th>Section</th>
<th>Available In</th>
<th>How to Use</th>
</tr>
</thead>
</table>
| VDC View | • Physical View  
• L2 View | Explore the VDC View tree to see which Cisco Nexus 7000 Series devices contain VDCs. To see details about a device, click on it and see the Properties section. |
| vPC | • Port Channel and vPC  
• Logical vPC | Explore the vPC tree to see a categorized listing of all logical connections in the topology map. To see details about a vPC, vPC peer link, or a port channel, click on it and see the Properties section. |
| Overview | • All views | **Tip** To view the Overview section, you may need to click the Overview tab in the Properties section. The Overview and Properties sections share the same section title bar.  
The Overview section shows a thumbnail view of the whole topology. A blue rectangle indicates the portion of the topology that is currently shown in the map.  
• To change which portion of the topology is shown in the map, in the overview, click where you want the map to show.  
• To zoom in or out, click a corner of the blue rectangle and drag it until the map is enlarged or shrunk as you want. |
| Properties | • All views | **Tip** To view the Properties section, you may need to click the Properties tab in the Overview section. The Overview and Properties sections share the same section title bar.  
1. Do one of the following:  
   - In the VDC View section, click on a physical or virtual device.  
   - In the vPC section, click on a logical connection.  
   - In the topology map, click on a device, link, or port.  
2. In the Properties section, view the properties of the object that you selected. |

### RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Managing a vPC
Moving Devices in the Topology Map

You can move device icons that are shown in the topology map. The position of devices is shared by all the topology views, that is, if you move a device and then change to another topology view, the device remains where you moved it to.

You can also save the layout, which you can reload later if you make additional changes and want to revert to your last save.

For more information, see the “Reloading the Previously Saved Layout” section on page 18-20.

The saved layout becomes the default layout that you see in the topology map when you start the DCNM-LAN client.

**Note**
The DCNM-LAN client saves topology layouts as local user data on the computer that runs the DCNM-LAN client. When you are using the DCNM-LAN client, you do not have access to topology layouts that you saved on other computers or that you saved while logged in to the computer under a different username.

**DETAILED STEPS**

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note**
To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
From the topology toolbar, choose the icon.

**Step 3**
Find and move device icons as needed. To move an icon, click on the device icon, hold down the mouse button, drag the icon to the new location, and release the mouse button.

You can zoom and pan as needed to find icons.

For more information, see the “Using the Viewing Tools” section on page 18-14.

For more information, see Using the Viewing Tools.
(Optional) If you want to save the changes to the device icon layout, click the icon.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Loading a Layout
- Reloading the Previously Saved Layout
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Exporting the Topology as a JPG Image

**Loading a Layout**

When you are using the Physical View, you can choose to load a layout. One of the following layouts:

- **Saved**—Devices appear in the layout that you most recently saved on the workstation that is running the Cisco DCNM client.
- **Spring**—Devices appear in locations determined by weighting the connections, which often produces a layout with minimal or no crossed connections.
- **Tree**—Devices appear in a tree unless connections create loops among the devices, in which case devices appear in a spanning tree, that is, a grid in which most of the connections follow the grid layout.

The position of devices is shared by all the topology views. This behavior allows you to use any of the layouts in all views by loading the layout in the Physical View and then choosing another view.

*Note*
If you are using a different view than the Physical View, the icon on the topology toolbar acts the same as the icon. For information about using the icon, see the “Reloading the Previously Saved Layout” section on page 18-20.

**BEFORE YOU BEGIN**

Determine which physical devices, if any, that you want to specify as core switches. When you load a layout other than a saved layout, core switches appear at the top of the topology map, and devices that are one CDP hop from the core switches appear just below them.

**DETAILED STEPS**

**Step 1**

From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.
Using the Topology Feature

Chapter 18 Working with Topology

To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2  (Optional) For each physical device that you want to appear at the top of the layout, right-click on the device icon and choose Make as Core Switch.

Step 3 From the topology toolbar, click the icon. The Layout drop-down list appears.

Step 4 From the Layout drop-down list, choose the layout that you want to load.
The Physical View of the topology map changes to the layout that you selected. Any devices that you specified as core switches appear at the top of the map, with devices that are one CDP hop away from the core switches appearing just below them.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Moving Devices in the Topology Map
- Reloading the Previously Saved Layout
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Exporting the Topology as a JPG Image

Reloading the Previously Saved Layout

You can load the most recently saved layout. This feature allows you to undo changes to device placement that you have made since you last saved the layout.

Note The DCNM-LAN client saves topology layouts as local user data on the computer that runs the DCNM-LAN client. When you are using the DCNM-LAN client, you do not have access to topology layouts that you saved on other computers or that you saved while logged in to the computer under a different username.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.
Step 2 From the topology toolbar, choose the icon. The topology map changes to the most recent layout that you saved.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Showing, Hiding, and Using the Details Pane
- Moving Devices in the Topology Map
- Loading a Layout
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Exporting the Topology as a JPG Image

Showing a Virtual or Physical Chassis

For a Cisco Nexus 1000V device, you can specify whether the topology map shows the virtual chassis or the physical chassis of the device. By default, the topology map shows the virtual chassis.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View. The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Step 2 Find the Cisco Nexus 1000V device icon. The topology map displays either the virtual chassis or the physical chassis.

Step 3 Right-click on the device icon and choose the applicable option:
- Show Virtual Chassis
- Show Physical Chassis

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Showing, Hiding, and Using the Details Pane
- Moving Devices in the Topology Map
- Loading a Layout
Showing or Hiding Network Servers

You can show or hide the network servers that are connected to a specific device. By default, the topology map hides network servers.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Step 2
Find the device that is connected to network servers that you want to show or hide.

Step 3
Right-click on the device and choose one of the following:

- To show connected network servers, choose Show End Devices.
- To hide connected network servers, choose Hide End Devices.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Showing, Hiding, and Using the Details Pane
- Moving Devices in the Topology Map
- Loading a Layout
- Managing a Network Server
- Showing or Hiding Device Groups
- Copy Run to Start

Managing a Network Server

You can use the topology map to access the Network Servers feature for a network server that appears on the map.

BEFORE YOU BEGIN

The network server must be showing in the topology map.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note: To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2
Find the network server that you want to manage with the Network Servers feature.

Tip: If the network server does not appear on the map, right-click a device that it is connected to and choose Show End Devices.

Step 3
Right-click on the server and choose Manage Server.

The DCNM-LAN client opens to the Network Servers feature. If the server that you chose represents a managed server or an Ethernet adapter on a discovered server, the client opens to the Servers contents pane. If the server that you chose represents a host bus adapter (HBA) that is not correlated or bound to a server, the client opens to the Static Server-Adapter Mapping contents pane.

RELATED TOPICS

• Showing or Hiding Network Servers

Showing or Hiding Device Groups

You can show or hide device groups. When device groups are hidden, the topology map shows all discovered devices and connections. When your device groups are shown, you can expand and collapse device groups individually or all at once.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note: To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

The icon on the topology toolbar controls whether device groups appear on the topology map. When the icon appears to be pushed in, the topology map shows device groups. When the icon does not appear to be pushed in, the topology map hides device groups.

Step 2
Click the icon to change between hiding and showing device groups, as needed.
Chapter 18  Working with Topology

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Showing or Hiding Network Servers
- Expanding or Collapsing Device Groups
- Creating a Device Group
- Moving a Device Between Device Groups
- Removing a Device from a Device Group
- Deleting a Device Group
- Copy Run to Start

Expanding or Collapsing Device Groups

You can expand and collapse individual device groups or all device groups.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note  To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2  If device groups do not appear on the topology map, from the topology toolbar, click the icon.

Step 3  Do one of the following:

- If you want to expand a single device group, right-click on the device group icon and choose Expand Device Group.
- If you want to expand all device groups, right-click on a blank area of the map and choose Expand all Device Groups.
- If you want to collapse a single device group, right-click on the title of the device group and choose Collapse Device Group.
- If you want to collapse all device groups, right-click on a blank area of the map and choose Collapse all Device Groups.

RELATED TOPICS

- Opening the Topology Map
Creating a Device Group

You can create a custom device group on the topology map.

**DETAILED STEPS**

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the map.

*Note*  
To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
Right-click on a blank area of the map and choose **New Device Group**.
A dialog box appears, with a field for specifying a name for the new device group.

**Step 3**
Type a name for the device group and click **OK**.
The new device group appears on the topology map.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Creating a Device Group
- Moving a Device Between Device Groups
- Removing a Device from a Device Group
- Deleting a Device Group
- Copy Run to Start
Moving a Device Between Device Groups

You can move devices from one device group to another device group on the topology map.

**Note** If a device group is empty after you move a device out of the group, DCNM-LAN deletes the device group.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note** To see the names of toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2** If device groups do not appear on the topology map, from the toolbar, click the icon.

**Step 3** Find the device group that you want to move the device out of.

**Step 4** If the device group is collapsed, double-click the device group to expand it.

**Step 5** Right-click on the device that you want to move out of the group and choose **Cut**.

**Step 6** Find the device group that you want to move the device into.

**Tip** You do not need to expand the device group before moving the device into the group.

**Step 7** Right-click the device group and choose **Paste**.

**Tip** If the device group is expanded, you must click on the title of the device group.

A warning dialog box confirms that you want to move the device group.

**Step 8** Click **Yes**.

DCNM-LAN adds the device to the second device group and removes it from the first device group. If the first device group is empty after moving the device, DCNM-LAN deletes the first device group.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
Removing a Device from a Device Group

You can remove devices from a custom device group. All devices that you remove from a custom group are added to the default device group.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2 If device groups do not appear on the topology map, from the topology toolbar, click the icon.

Step 3 Find the device group that you want to remove a device from.

Step 4 If the device group is collapsed, double-click the device group to expand it.

Step 5 Right-click on the device that you want to remove from the group and choose Remove from Group.

If you are removing the only device from the group, a warning dialog box confirms that you want to remove the device group.

Step 6 If the warning appears, click Yes.

DCNM-LAN removes the device from the custom device group and adds the device to the default device group.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Showing or Hiding Network Servers
Copy Run to Start

In the Physical View, you can copy the running configuration to the startup configuration on one or more selected devices.

**DETAILED STEPS**

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note** To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
If device groups do not appear on the topology map, from the topology toolbar, click the icon.

**Step 3**
Above the topology map, select **Physical View**.

**Step 4**
Select the devices that you want to copy the running configuration from.

**Step 5**
If the device group is collapsed, double-click the device group to expand it.

**Step 6**
Right-click the device that you want to copy the running configuration from.

- If you want to copy the running configuration to the startup configuration, choose **Copy Run to Start**.
  DCNM-LAN copies the running configuration to the startup configuration.

- If you want to copy the running configuration to a file in the bootflash directory, choose **Copy Run to File in Bootflash**. In the dialog box that appears, enter the name of the file to copy to and click **OK** to complete the operation.
  DCNM-LAN copies the running configuration to the specified file.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Showing or Hiding Network Servers
Deleting a Device Group

You can delete a custom device group from the topology map.
Devices that belong to a custom device group that you delete automatically become members of the default device group.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2 If device groups do not appear on the topology map, from the topology toolbar, click the icon.

Step 3 Find the device group that you want to delete.

Step 4 Right-click on the device group and choose Delete Group.
DCNM-LAN removes the device group from the topology map. The devices that were in the deleted device group are now members of the default device group.

Note If there are no custom device groups after you delete the device group, the topology map automatically hides devices groups because all devices are in the default device group.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Showing or Hiding Network Servers
- Showing or Hiding Device Groups
- Expanding or Collapsing Device Groups
Creating a Device Group
Moving a Device Between Device Groups
Removing a Device from a Device Group
Copy Run to Start

Exporting the Topology as a JPG Image

You can export, or save, a JPG image of the topology map. You can export either the entire topology map or only the visible portion of the topology map.

**DETAILED STEPS**

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note**  To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
View the portion of the topology map that you want to save.
For more information, see the “Using the Viewing Tools” section on page 18-14.
For more information, see the **Using the Viewing Tools**.

**Step 3**
Arrange the device icons as desired.
For more information, see the “Moving Devices in the Topology Map” section on page 18-18.
For more information, see the **Moving Devices in the Topology Map**.

**Step 4**
From the topology toolbar, click the icon.
A dialog box prompts you to choose whether you want to export the entire topology map or only the visible portion of the map.

**Step 5**
Do one of the following:

- To export the entire topology map as a JPG image, click **Yes**.
- To export only the visible portion of the topology map, click **No**.

**Step 6**
Specify the location and filename of the JPG image and click **Save**.
The JPG image of the visible portion of the topology map is saved.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Showing, Hiding, and Using the Details Pane
• Moving Devices in the Topology Map
• Loading a Layout
• Reloading the Previously Saved Layout
• Showing or Hiding Network Servers
• Showing or Hiding Device Groups

Accessing DCNM-LAN Features from the Topology Map

You can use the topology map to access other DCNM-LAN features for managed devices. From the topology map, you can access features that are found in the following Feature Selector drawers:

• Inventory
• Virtual Devices
• Interfaces
• Routing
• Switching
• Security

You can also use the topology map to access the Device Discovery feature.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note
To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2
If you want to access a DCNM-LAN feature for a specific managed device, do the following:

a. Find the device in the topology map.
b. Right-click the device and choose the feature that you want to configure.

The feature that you selected appears in the Contents pane. The device that you selected on the topology map is selected in the Summary table for the feature.

Step 3
If you want to access the Device Discovery feature, right-click a blank area on the map and choose Discover Devices.

The Device Discovery feature appears in the Contents pane.

RELATED TOPICS

• Opening the Topology Map
• Understanding Device Icons and Links
Using the Viewing Tools
Launching the vPC Wizard
Accessing Cisco DCNM-SAN Features from the Topology Map
Accessing Cisco FabricPath Features from the Topology Map
Managing a vPC
Finding and Resolving vPC Configuration Inconsistencies
Moving Devices in the Topology Map
Loading a Layout

Accessing Cisco DCNM-SAN Features from the Topology Map

You can use the topology map to access features in the Cisco DCNM-SAN client for a managed SAN device. If Cisco DCNM-SAN has not discovered the device, accessing the Cisco DCNM-SAN client through the topology map will cause Cisco DCNM-SAN to discover the SAN device.

The Cisco DCNM-SAN features that you can access include the following:

- Zones, zone sets, and zone set membership
- Port channel interfaces
- Fibre Channel physical and logical interfaces
- Fibre Channel over IP tunnels
- Events

Note

The Cisco DCNM-SAN cross launch feature is only supported by the DCNM-LAN client when the Cisco DCNM-SAN is installed in Server mode. Cross launch is not supported by the DCNM-LAN client when the Cisco DCNM-SAN is installed in Standalone mode. In addition, cross launch is not supported when the DCNM-LAN client is in standalone mode.

BEFORE YOU BEGIN

The Cisco DCNM-SAN client must be installed on the computer that is running the DCNM-LAN client.

DETAILED STEPS

Step 1

From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note

To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2

Find the SAN device in the topology map.

Step 3

Right-click the device and choose the feature that you want to configure.
The Cisco DCNM-SAN client opens to the feature that you selected.

**RELATED TOPICS**

- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco FabricPath Features from the Topology Map
- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Moving Devices in the Topology Map
- Loading a Layout

**Accessing Cisco FabricPath Features from the Topology Map**

You can use the topology map to access features of the Cisco FabricPath.

This section includes the following topics:

- Multi-destination, page 18-33
- Device Reachability, page 18-34
- Unicast, page 18-35
- Multicast, page 18-36

**Multi-destination**

A multi-destination or broadcast graph represents broadcast traffic and unknown unicast traffic in the topology. You can view the multi-destination information for a specific topology.

**DETAILED STEPS**

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note**
To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**
Above the map, click **L2 View**.

The dialog box appears in the Contents pane.

**Step 3**
In the dialog box, choose the **Fabricpath** view.

**Step 4**
Enter the Topology ID and click **Fetch**. The graph that is displayed is filtered based upon the Topology ID.

**Step 5**
Check **Select type of graph** to enable the selection for the Multi-destination graph.
Step 6 Check the Multi-destination option.

Step 7 From the Anchor drop-down list, choose a device. The selected device is the entry point for the graph.

Step 8 From the Graph ID drop-down list, choose an ID. The Graph ID is a forwarding tag for the graph.

Step 9 Click Fetch to view the graph.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Moving Devices in the Topology Map
- Loading a Layout

Device Reachability

L2MP-ISIS automatically computes the switch ID reachability for each node in the network. You can view the reachability information for a specific topology.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

Step 2 Above the map, click L2 View.

The dialog box appears in the Contents pane.

Step 3 In the dialog box, choose the Fabricpath view.

Step 4 Enter the Topology ID. The graph that is displayed is filtered based upon the Topology ID.

Step 5 Check Select type of graph to enable the selection for the Reachability graph.

Step 6 Check the Reachability option.

Step 7 From the Anchor drop-down list, choose a device. The selected device is the entry point for the graph.
Step 8  Click **Fetch** to view the graph.

---

**Note**  Devices in the graph that appear as red colored icons indicate that the device is not reachable for the selected topology.

---

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Moving Devices in the Topology Map
- Loading a Layout

---

**Unicast**

A unicast graph displays equal cost routes between nodes in a network. You can view the unicast information for a specific topology.

---

**DETAILED STEPS**

**Step 1**  From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

---

**Note**  To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

---

**Step 2**  Above the map, click **L2 View**.

The dialog box appears in the Contents pane.

**Step 3**  In the dialog box, choose the **Fabricpath** view.

**Step 4**  Enter the Topology ID. The graph that is displayed is filtered based upon the Topology ID.

**Step 5**  Check **Select type of graph** to enable the selection for the Unicast graph.

**Step 6**  Check the **Unicast** option.

**Step 7**  From the Anchor drop-down list, select a device. The selected device is the entry point for the graph.

**Step 8**  From the Destination drop-down list, select a device. The selected device is the destination for the graph.
Step 9  Click **Fetch** to view the graph.

---

**Note**  If the resulting graph does not trace the path from the source to the destination, then one of the following may be the cause:

- Islands in the L2MP cloud.
- DCNM-LAN might not manage intermediate devices.

---

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Moving Devices in the Topology Map
- Loading a Layout

---

**Multicast**

A multicast graph displays the multicast traffic from a specified device to all hosts that are listening to a particular IGMP group. You can view the multicast information for a specific topology.

**DETAILED STEPS**

**Step 1**  From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Note**  To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly for the name of the icon to appear.

**Step 2**  Above the map, click **L2 View**.

The dialog box appears in the Contents pane.

**Step 3**  In the dialog box, choose the **Fabricpath** view.

**Step 4**  Enter the Topology ID. The graph that is displayed is filtered based upon the Topology ID.

**Step 5**  Check **Select type of graph** to enable the selection for the Multicast graph.
Step 6  Check the **Multicast** option.

Step 7  From the Anchor drop-down list, choose a device. The selected device is the entry point for the graph.

Step 8  From the Graph ID drop-down list, choose an ID. The Graph ID is a forwarding tag for the graph.

Step 9  In the Source field, enter the multicast originating device. The multicast originating device is specified as an IP address or as "*" (wildcard).

Step 10 In the IGMP field, enter the IGMP group address.

Step 11 In the VLAN field, enter multicast-associated VLAN information.

Step 12 Click **Fetch** to view the graph.

**RELATED TOPICS**

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Moving Devices in the Topology Map
- Loading a Layout

**Launching the vPC Wizard**

From the topology map, you can launch the vPC wizard to create a vPC.

**BEFORE YOU BEGIN**

Determine which two devices you want to use as the vPC peer switches.

**DETAILED STEPS**

- **Step 1**  From the Feature Selector pane, choose **Topology > Topology View**. The topology map appears in the Contents pane.

- **Step 2**  Above the map, click **PortChannel and vPC**. The map shows the PortChannel and vPC view of the topology.

- **Step 3**  From the topology toolbar, choose the **icon**.

- **Step 4**  Click one device that you want to use as a vPC peer switch.

- **Step 5**  Press and hold the **Shift** key.

- **Step 6**  Click the device that you want to use as a vPC peer switch.
Step 7 Right-click either device and choose Launch vPC Wizard.
The vPC Creation Wizard dialog box appears.
For more information about using this wizard, see the Interfaces Configuration Guide, Cisco DCNM for LAN.

RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Managing a vPC
- Finding and Resolving vPC Configuration Inconsistencies
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Moving Devices in the Topology Map
- Loading a Layout
- Exporting the Topology as a JPG Image

Managing a vPC

From the topology map, you can access the vPC feature for a specific vPC link.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Topology > Topology View.
The topology map appears in the Contents pane.
Step 2 Above the map, click one of the following views:
- PortChannel and vPC
- Logical vPC View
Step 3 Find the vPC link for the vPC that you want to manage.
Step 4 Use the step that applies to the view that you selected:
- PortChannel and vPC—Right-click the ellipse on the vPC link and choose Manage vPC.
- Logical vPC View—Right-click the vPC link and choose Manage vPC.
The vPC feature appears. The vPC that you want to manage is selected in the summary table.
For more information about the vPC feature, see the Interfaces Configuration Guide, Cisco DCNM for LAN.
Finding and Resolving vPC Configuration Inconsistencies

You can use the topology map to find vPCs that have configuration inconsistencies and open the Resolve Configuration Inconsistency dialog box.

DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose **Topology > Topology View**.

The topology map appears in the Contents pane.

**Step 2**
Above the map, click one of the following views:

- **PortChannel and vPC**
- **Logical vPC View**

**Step 3**
Find the vPC for which you want to resolve configuration inconsistencies.

If a vPC link has configuration inconsistencies, a red ellipse appears over the link. If you use the PortChannel and vPC view, vPC peer links with configuration inconsistencies also show a red ellipse.

**Step 4**
(Optional) If you want to resolve configuration inconsistencies now, do one of the following:

- To resolve configuration inconsistencies for the vPC link and the vPC peer link, right-click the red ellipse on the vPC link and choose **Launch Configuration Consistency**.

- To resolve configuration inconsistencies for the vPC peer link only, right-click the red ellipse on the vPC link and choose **Launch Configuration Consistency**.

The Resolve Configuration Inconsistency dialog box opens.

Accessing Remotely Connected CNAs from the Topology Map

You can use the topology map to access servers connected to Cisco Nexus 4000 Series switches.
### Using the Topology Feature

**DETAILED STEPS**

**Step 1**  
From the Feature Selector pane, choose **Topology > Topology View**.  
The topology map appears in the Contents pane. The topology toolbar appears on the left side of the topology map.

**Step 2**  
Right-click on the switch and then choose **Show End Devices**.  
The Contents pane displays all the servers that are connected to the switch. It displays only the pWWN of the servers because the IP address is not available as a part of the enode information in FIP snooping.

### Using VSAN Overlay

**DETAILED STEPS**

**Step 1**  
From the Feature Selector pane, choose **Topology > Topology View**.  
The topology map appears in the Contents pane.

**Step 2**  
Above the map, click **L2 View**.  
The dialog box appears in the Contents pane.

**Step 3**  
In the dialog box, click **VSAN**.

**Step 4**  
Enter the range to search (valid values are between 1 and 4094).

**Step 5**  
Check **View mapped VLANs** to view the VLANs.

**Step 6**  
Click **Fetch**.

### RELATED TOPICS

- Opening the Topology Map
- Understanding Device Icons and Links
- Using the Viewing Tools
- Launching the vPC Wizard
- Managing a vPC
- Accessing DCNM-LAN Features from the Topology Map
- Accessing Cisco DCNM-SAN Features from the Topology Map
- Moving Devices in the Topology Map
- Loading a Layout
- Exporting the Topology as a JPG Image
Related Documents

For additional information related to the topology map, see the following sections:

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>VDCs</td>
<td>Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.1.x</td>
</tr>
<tr>
<td>vPCs</td>
<td>Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.1.x</td>
</tr>
<tr>
<td>Configuring LLDP on managed devices</td>
<td>System Management Configuration Guide, Cisco DCNM for LAN, Release 7.1.x</td>
</tr>
<tr>
<td>Device discovery</td>
<td>Chapter 29, “Administering Device Discovery”</td>
</tr>
</tbody>
</table>

### Feature History for Topology

Table 18-1 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common topology</td>
<td>5.0(2)</td>
<td>Support for SAN devices and connections was added.</td>
</tr>
<tr>
<td>Network servers</td>
<td>5.0(2)</td>
<td>Support for showing network servers was added.</td>
</tr>
<tr>
<td>DCNM-SAN support</td>
<td>5.0(2)</td>
<td>Support for launching the Cisco DCNM-SAN client was added.</td>
</tr>
<tr>
<td>Device groups</td>
<td>5.0(2)</td>
<td>Support for device groups was added.</td>
</tr>
<tr>
<td>VSAN Overlay</td>
<td>5.1(0)</td>
<td>Support for VSAN overlay was added as a part of the L2 view.</td>
</tr>
<tr>
<td>Discovery of servers connected to Cisco Nexus 5000 series switches via CNAs</td>
<td>5.1(0)</td>
<td>Support for discovering servers that are either directly connected to Cisco Nexus 5000 Series switches or CNAs.</td>
</tr>
<tr>
<td>FabricPath support</td>
<td>5.1(0)</td>
<td>Support for FabricPath was added.</td>
</tr>
<tr>
<td>Datacenter Grouping</td>
<td>6.0</td>
<td>Support for Datacenter Grouping was added.</td>
</tr>
</tbody>
</table>
Working with Inventory

This chapter describes how to use the Inventory feature in Cisco Data Center Network Manager for LAN(DCNM-LAN).

This chapter includes the following sections:
- Information About Inventory, page 19-1
- Licensing Requirements for Inventory, page 19-3
- Prerequisites, page 19-3
- Platform Support, page 19-3
- Configuring Module Pre-Provisioning, page 19-4
- Reloading a Line Card, page 19-5
- Displaying Inventory Information, page 19-6
- Displaying Power Usage Information, page 19-9
- Field Descriptions, page 19-10
- Feature History for Inventory, page 19-12

Information About Inventory

The Inventory feature displays information about the components that comprise a selected managed device and power usage information for managed Cisco Nexus 7000 Series switches. In addition, it allows you to configure fundamental system parameters on virtual switches, such as the Cisco Nexus 1000V Series switch. For information about configuring virtual switches, see Chapter 20, “Managing Virtual Devices.”

System-message logging levels for the Inventory feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the Cisco DCNM Fundamentals Configuration Guide, Release 5.x.

This section includes the following topics:
- Understanding Inventory, page 19-2
- Understanding Power Usage, page 19-2
- Module Pre-Provisioning, page 19-2
Understanding Inventory

The Inventory feature displays summary and detailed information about the chassis, modules, fan trays, and power supplies for managed devices.

Understanding Power Usage

Cisco DCNM displays information about the power usage of managed Cisco Nexus 7000 Series switches, including an aggregation of the power usage for all managed Cisco Nexus 7000 Series switches, summary information for a specific device, and graphical information for a selected device.

You can configure Cisco DCNM to collect power usage statistics for up to six managed devices.

Module Pre-Provisioning

This feature is supported only on the Cisco Nexus 5000 Series switches.

The pre-provisioning feature allows you to preconfigure interfaces before inserting or attaching a module to a Cisco Nexus 5000 Series switch. If a module goes offline, you can use pre-provisioning to make changes to the interface configurations for the offline module. When a pre-provisioned module comes online, the pre-provisioning configurations are applied. If any configurations were not applied, a syslog is generated. The syslog lists the configurations that were not accepted.

In some Virtual Port Channel (vPC) topologies, pre-provisioning is required for the configuration synchronization feature. Pre-provisioning allows you to synchronize the configuration for an interface that is online with one peer but offline with another peer.

Supported Hardware

The pre-provisioning feature supports the following hardware:

- N2K-C2148T Fabric Extender 48x1G 4x10G Module
- N2K-C2232P Fabric Extender 32x10G Module
- N2K-C2248T Fabric Extender 48x1G 4x10G Module
- N51-M16EP Cisco 16x10-Gigabit Ethernet Expansion Module
- N51-M8E8FP Cisco 8-port 1/2/4/8G FC and 8 Port 10-Gigabit Ethernet Expansion Module
- N5K-M1008 Cisco 8-port Fiber Channel Expansion Module 8 x SFP
- N5K-M1060 Cisco 6-port Fiber Channel Expansion Module 6 x SFP
- N5K-M1404 Expansion Module 4 x 10GBase-T LAN, 4 x Fiber Channel
- N5K-M1600 Cisco 6-port 10-Gigabit Ethernet SFP Module 6 x SFP
Upgrades and Downgrades

When upgrading from Cisco NX-OS Release 4.2(1)N2(1) and earlier releases to Cisco NX-OS Release 5.0(2)N1(1), there are no configuration implications. When upgrading from a release that supports pre-provisioning to another release that supports the feature including in-service software upgrades (ISSUs), pre-provisioned configurations are retained across the upgrade.

When downgrading from an image that supports pre-provisioning to an image that does not support pre-provisioning, you are prompted to remove pre-provisioning configurations.

Licensing Requirements for Inventory

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM</td>
<td>Inventory requires no license. Any feature not included in a license package is bundled with Cisco DCNM and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 6.x</em>.</td>
</tr>
<tr>
<td>Cisco NX-OS</td>
<td>Inventory requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For an explanation of the Cisco NX-OS licensing scheme for your platform, see the licensing guide for your platform.</td>
</tr>
</tbody>
</table>

Prerequisites

The Inventory feature has the following prerequisite (for a full list of feature-specific prerequisites, see the platform-specific documentation):

- System-message logging levels for the Inventory feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

Platform Support

The following platforms support this feature but may implement it differently. For platform-specific information, including guidelines and limitations, system defaults, and configuration limits, see the corresponding documentation.

<table>
<thead>
<tr>
<th>Platform</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Nexus 1000V Series switches</td>
<td>Cisco Nexus 1000V Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 3000 Series switches</td>
<td>Cisco Nexus 3000 Series Switch Documentation</td>
</tr>
</tbody>
</table>
Configuring Module Pre-Provisioning

Note

This feature is supported only on the Cisco Nexus 5000 Series switches.

The module pre-provisioning feature allows you to pre-provision a new module or a module that is present on the switch but is in an offline state.

This section includes the following topics:

- Pre-Provisioning Offline Modules
- Pre-Provisioning Online Modules
- Pre-Provisioning FEX Modules

Pre-Provisioning Offline Modules

Note

This feature is supported only on the Cisco Nexus 5000 Series switches.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Inventory.

The summary chassis information for each of the managed device is displayed in the Summary pane. You can view the list of offline modules already configured for pre-provisioning.

Step 2
(Optional) From the Summary pane, in the Module Type drop-down list, choose the module type of the pre-provisioned slot you want to edit in the Details tab.

Step 3
Choose a chassis.

Step 4
Expand the chassis and click Add New Provisioned Slot.

Step 5
(Optional) In the pre-provisioned slot, expand the chassis and click Delete Slot.

The offline module is disabled.

Pre-Provisioning Online Modules

Note

This feature is supported only on the Cisco Nexus 5000 Series switches.
Cisco Prime DCNM Fundamentals Guide

Chapter 19      Working with Inventory

Reloading a Line Card

DET AILED STEPS

Step 1  From the Feature Selector pane, choose Inventory.
The summary chassis information for each of the managed device is displayed in the Summary pane.

Step 2  From the Summary pane, choose a chassis.

Step 3  Expand the chassis and choose a card type that corresponds to the online module.

Step 4  From the Details pane, click on the pre-provisioning drop-down list.
You can enable or disable the pre-provisioning.

Pre-Provisioning FEX Modules

Note  This feature is supported only on the Cisco Nexus 5000 Series switches.

DET AILED STEPS

Step 1  From the Feature Selector pane, choose Inventory.
The summary chassis information for each of the managed device is displayed in the Summary pane.

Step 2  From the Summary pane, choose a FEX module.

Step 3  Expand the FEX chassis and choose a card type that corresponds to the online module.

Step 4  From the Details pane, click on the pre-provisioning drop-down list.
You can enable or disable the pre-provisioning.

Reloading a Line Card

Note  This feature is supported only on the Cisco Nexus 7000 Series device.

Beginning with Cisco DCNM Release 5.2(1), you can individually restart any line card in the device without affecting the operational state of other components in the switch.

DET AILED STEPS

Step 1  From the Feature Selector pane, choose Inventory.
The summary chassis information for each of the managed device is displayed in the Summary pane.

Step 2  From the Summary pane, choose a chassis.

Step 3  Expand the chassis and choose a card type.
Displaying Inventory Information

The Inventory feature displays summary and detailed information about the chassis, modules, fan trays, and power supplies for managed devices.

This section includes the following topics:

- Displaying the Chassis Information, page 19-6
- Displaying the Module Information, page 19-7
- Displaying the Power Supply Information, page 19-8
- Displaying the Fan Tray Information, page 19-8

Displaying the Chassis Information

Cisco DCNM displays summary, detail, environmental, and event information for the chassis.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Inventory.
Summary chassis information for each managed device appears in the Summary pane.

Step 2 To display additional information about a chassis, click the device.
Tabs appear in the Details pane with the Details tab selected.

Step 3 Click one of the following tabs:
- Details—Displays detailed hardware and software information.
- Environmental Status—Displays power usage and redundancy information.
- CPU Utilization—Displays collected statistics showing the percentage of utilization devoted to user or kernel functions. For more information on collecting statistics for this feature, see the “Working with Statistics and Charts” section on page 16-11.
- Memory Utilization—Displays collected statistics showing the memory utilization within specific thresholds. For more information on collecting statistics for this feature, see the “Working with Statistics and Charts” section on page 16-11.
- Events—Displays the chassis events, which includes the source, time, severity, message, and status of the event. To see details for the event, select the event in the Details pane and click the up arrow at the bottom of the details pane.
Displaying the Module Information

Cisco DCNM displays summary, detail, environmental, and event information for the supervisor modules, I/O modules, and fabric modules.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Inventory.
Summary chassis information, including module description, product ID, serial number, hardware version, software version, status, temperature, and events, for each managed device appears in the Summary pane.

Step 2  From the Summary pane, expand the device.
The device listing expands to include a summary of each module, power supply, and fan tray in the chassis.

Step 3  Click the module.
Tabs appear in the Details pane with the Details tab selected.

Step 4  Click one of the following tabs:
- **Details**—Displays general identification information and special information for the selected module type.
- **Environmental Status**—Displays environmental status information for the selected supervisor module, I/O module, or fabric module. To see textual temperature information, expand the Temperature Status Table section. To see graphical temperature information, expand the Temperature Status Thermometer section.
- **TCAM Statistics**—Displays collected information about TCAM usage on the module. For more information on collecting statistics for this feature, see the “Working with Statistics and Charts” section on page 16-11.
- **Events**—Displays event information for the selected supervisor module, I/O module, or fabric module. To see details for an event, click on the event and click the up arrow button at the bottom of the pane.

RELATED TOPICS

- Displaying the Module Information, page 19-7
- Displaying the Power Supply Information, page 19-8
- Displaying the Fan Tray Information, page 19-8
Displaying the Power Supply Information

Cisco DCNM displays summary information, general details, and events for power supplies.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose **Inventory**.
Summary chassis information for each managed device appears in the Summary pane.

Step 2  From the Summary pane, expand the device.
The device listing expands to include a summary of each module, power supply, and fan tray in the chassis.

Step 3  Click the power supply.
Tabs appear in the Details pane with the Details tab selected.

Step 4  Click one of the following tabs:
- **Details**—Displays information including general identification information, power (watts), and current (Amps).
- **Events**—Displays event information, including source, time, severity, message, and status information for the events. To see details for an event, click on the event and click the up arrow button at the bottom of the pane. A field opens to display detailed event information.

RELATED TOPICS

- Displaying the Chassis Information, page 19-6
- Displaying the Module Information, page 19-7
- Displaying the Fan Tray Information, page 19-8

Displaying the Fan Tray Information

Cisco DCNM displays summary information, general details, and events for fan trays.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose **Inventory**.
Chassis summary information for the device appears in the Summary pane.

Step 2  From the Summary pane, expand the device.
A list of modules, power supplies, and fan trays appears under the device in the Summary pane. Each row includes summary information for the component.

Step 3  Click a fan tray.
Tabs appear in the Details pane with the Details tab selected.

Step 4  Click one of the following tabs:
- **Details**—Displays descriptive information and status for the fan tray.
Displaying Power Usage Information

Cisco DCNM displays summary and detailed information about the power usage for one or more managed devices in your network. It also displays the aggregated power usage information of all the managed Cisco Nexus 7000 Series switches. You can configure Cisco DCNM to collect power usage statistics for up to six managed devices.

This section includes the following topics:

- Displaying Power Usage Summary Information, page 19-9
- Displaying Power Usage Details, page 19-9
- Displaying Power Usage Statistics, page 19-10

Displaying Power Usage Summary Information

Cisco DCNM displays summary information about the total power capacity and the power drawn, allocated, and available for aggregated power usage information of all the managed Cisco Nexus 7000 Series devices and for each managed device.

DETAILED STEPS

To display power usage summary information, from the Feature Selector pane, choose Inventory > Power Usage. Aggregated power usage information for all managed Cisco Nexus 7000 Series switches and power usage information for each managed device displays in the Summary pane.

RELATED TOPICS

- Displaying Power Usage Details, page 19-9
- Displaying Power Usage Statistics, page 19-10

Displaying Power Usage Details

You can display graphical details about the power usage for one or more managed devices in your network. The graphical information includes bar and pie charts. The bar chart shows the total capacity (watts), total allocated (watts), and total drawn/usage (watts) for the top or bottom five devices based on the power consumed by the devices. The top five starts with the device that consumes the maximum power. The pie chart shows the total drawn/used power and unused power for the selected devices.
DETAILED STEPS

Step 1
From the Feature Selector pane, choose Inventory > Power Usage.
Summary power usage information for the entire network and each managed device displays in the Summary pane.

Step 2
From the Summary pane, click the entire network or one or more devices.
The Details tab displays graphical details about the power usage for selected devices.

RELATED TOPICS

- Displaying Power Usage Summary Information, page 19-9
- Displaying Power Usage Statistics, page 19-10

Displaying Power Usage Statistics

The following window appears in the Statistics tab:
- Power Usage Statistics Chart—Displays statistics on the total capacity (watts), total drawn (watts), total allocated (watts), and total available (watts) for up to six managed devices.

RELATED TOPICS

- Displaying Power Usage Summary Information, page 19-9
- Displaying Power Usage Details, page 19-9

Field Descriptions

This section includes the following field descriptions for the Inventory and Power Usage features:

- Inventory: Details: Hardware Section, page 19-10
- Inventory: Details: Software Section, page 19-11
- Inventory: Power Usage, page 19-11

Inventory: Details: Hardware Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Name</td>
<td>Hostname assigned to the device.</td>
</tr>
<tr>
<td>Description</td>
<td>Word or phrase that describes the device.</td>
</tr>
<tr>
<td>Product ID</td>
<td>ID number for the device.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>Serial number of the device.</td>
</tr>
</tbody>
</table>

Cisco Prime DCNM Fundamentals Guide
Inventory: Details: Software Section

Table 19-2  Inventory: Details: Software Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Uptime</td>
<td>Date and time when the device was last uploaded.</td>
</tr>
<tr>
<td>System Image</td>
<td></td>
</tr>
<tr>
<td>Image Name</td>
<td>Name of the image running on the device.</td>
</tr>
<tr>
<td>Location</td>
<td>Directory where the system image resides.</td>
</tr>
<tr>
<td>Version</td>
<td>Version number of the image running on the device.</td>
</tr>
<tr>
<td>Kickstart Image</td>
<td></td>
</tr>
<tr>
<td>Image Name</td>
<td>Name of the kickstart image file.</td>
</tr>
<tr>
<td>Location</td>
<td>Directory where the kickstart image resides.</td>
</tr>
<tr>
<td>Version</td>
<td>Version number of the kickstart image file.</td>
</tr>
</tbody>
</table>

Inventory: Power Usage

Table 19-3  Inventory: Power Usage

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the device group or device.</td>
</tr>
<tr>
<td>Total Capacity (Watts)</td>
<td>Total power capacity for all devices in the group or total power capacity of a device.</td>
</tr>
<tr>
<td>Total Drawn/Usage (Watts)</td>
<td>Total power used by all devices in the group or total power used by all the modules in a device.</td>
</tr>
<tr>
<td>Total Drawn/Usage (%)</td>
<td>Percentage of power used by all devices in the group or percentage of power used by all modules in a device.</td>
</tr>
<tr>
<td>Total Allocated (Watts)</td>
<td>Total power allocated for all devices in the group or total power allocated for all the modules in a device.</td>
</tr>
<tr>
<td>Total Available (Watts)</td>
<td>Total power available for all devices in the group or total power available for additional modules in a device.</td>
</tr>
<tr>
<td>Last Refresh Time</td>
<td>Time when the power usage information was last updated in Cisco DCNM.</td>
</tr>
</tbody>
</table>
## Feature History for Inventory

Table 19-4 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Pre-provisioning</td>
<td>5.2(1)</td>
<td>Support was added only for the Cisco Nexus 5000 Series switches.</td>
</tr>
<tr>
<td>Inventory</td>
<td>5.2(1)</td>
<td>Support was added for Cisco Nexus 3000 Series switches.</td>
</tr>
<tr>
<td>Inventory</td>
<td>5.1(1)</td>
<td>No change from Release 5.0.</td>
</tr>
<tr>
<td>Power Usage</td>
<td>5.0(2)</td>
<td>This feature was introduced.</td>
</tr>
<tr>
<td>Inventory</td>
<td>4.2(1)</td>
<td>Support was added for Cisco Nexus 5000 Series switches and Nexus 2000 Series Fabric Extenders.</td>
</tr>
</tbody>
</table>
Managing Virtual Devices

This chapter describes virtual device contexts (VDCs) supported on Cisco NX-OS devices. This chapter includes the following sections:

- **Managing Virtual Switches, page 20-1**
- **Creating VDCs with the VDC Setup Wizard, page 20-1**
- **Creating VDCs with the VDC Setup Wizard, page 20-1**

For detailed configuration guide, please refer to *Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.x*.

Managing Virtual Switches

The Cisco Nexus 1000V is a virtual access software switch that works with VMware vSphere 4.0 and has the following components:

- **Virtual Supervisor Module (VSM)**—Control plane of the switch and a virtual machine that runs Cisco NX-OS.
- **Virtual Ethernet Module (VEM)**—Virtual line card embedded in each VMware vSphere (ESX) host.

Managing a virtual switch involves configuring its domain and server connections. A domain is an instance of a Cisco Nexus 1000V Series Switch device, including dual redundant VSMs and managed VEMs, within a VMware vCenter server. Each domain is distinguished by a unique integer called the domain identifier.

In order for the Cisco Nexus 1000V to connect to a vCenter Server or an ESX server, you must first define the connection parameters. All communication with the vCenter Server is secured by the Transport Layer Security (TLS) protocol.

This chapter in *Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to manage virtual switches using Cisco Data Center Network Manager (DCNM).

Creating VDCs with the VDC Setup Wizard

This chapter in *Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to create virtual device contexts (VDCs) on Cisco NX-OS devices.
This chapter in Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to create virtual device contexts (VDCs) on Cisco Data Center Network Manager (DCNM). In Cisco NX-OS, only a user with the network-admin role can create VDCs. You can create up to three VDCs. Beginning with the Cisco NX-OS Release 5.2(1), you can run FCoE on the Cisco Nexus 7000 Series devices. You must create a storage VDC to run FCoE. The storage VDC cannot be the default VDC and you can have one storage VDC on the device.

Managing VDCs

This chapter in Virtual Device Context Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to manage virtual device contexts (VDCs) on Cisco Data Center Network Manager (DCNM).

After you create a VDC, you can change the interface allocation, VDC resource limits, and the high availability (HA) policies. You can also save the VDC configuration on the physical device to the startup configuration or to a bootflash file.
Cisco NX-OS supports multiple configuration parameters for each of the interface types supported. Most of these parameters are covered in this guide but some are described in other documents.

Table 21-1 shows where to get further information on the parameters you can configure for an interface.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Parameters</th>
<th>Further Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic parameters</td>
<td>description, duplex, error disable, flow control, MTU, beacon</td>
<td>Configuring Basic Interface Parameters of this document</td>
</tr>
<tr>
<td>Layer 2</td>
<td>Layer 2 access and trunk port settings</td>
<td>Configuring Layer 2 Interfaces of this document</td>
</tr>
<tr>
<td></td>
<td>Layer 2 MAC, VLANs, private VLANs, Rapid PVST+, Multiple Spanning Tree, Spanning Tree Extensions</td>
<td>Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 6.xCisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x</td>
</tr>
<tr>
<td>Layer 3</td>
<td>medium, IPv4 and IPv6 addresses</td>
<td>Configuring Layer 3 Interfaces of this document</td>
</tr>
<tr>
<td></td>
<td>bandwidth, delay, IP routing, VRFs</td>
<td>Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cisco Nexus 7000 Series NX-OS Multicast Routing Configuration Guide, Release 5.x</td>
</tr>
<tr>
<td>Port Channels</td>
<td>channel group, LACP</td>
<td>Configuring Port Channels of this document</td>
</tr>
<tr>
<td>vPCs</td>
<td>Virtual port channels</td>
<td>Configuring vPCs of this document</td>
</tr>
<tr>
<td>Tunnels</td>
<td>GRE Tunneling</td>
<td>Configuring IP Tunnels of this document</td>
</tr>
</tbody>
</table>

Table 21-1 Interface Parameters
Chapter 21 Configuring Interfaces on DCNM-LAN Client

Table 21-1 Interface Parameters (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Parameters</th>
<th>Further Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>FCoE</td>
<td>Beginning with Cisco NX-OS Release 5.2(1), you can run Fibre Channel over Ethernet (FCoE) on the Cisco Nexus 7000 Series Switch</td>
<td><em>Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500</em></td>
</tr>
<tr>
<td>Virtual Ethernet Interfaces</td>
<td>Logical interfaces that correspond to a switch interface connected to a virtual port</td>
<td><em>Configuring Virtual Ethernet Interfaces</em> of this document</td>
</tr>
<tr>
<td>Fabric Extenders</td>
<td>High-density, low-cost connectivity for server aggregation</td>
<td><em>Configuring Fabric Extenders</em> of this document</td>
</tr>
<tr>
<td>Port Profiles</td>
<td>A mechanism for simplifying the configuration of interfaces.</td>
<td><em>Configuring Port Profiles</em> of this document</td>
</tr>
</tbody>
</table>

This chapter includes the following topics:

- Configuring Basic Interface Parameters, page 21-2
- Configuring Layer 2 Interfaces, page 21-3
- Configuring Layer 3 Interfaces, page 21-4
- Configuring Port Channels, page 21-4
- Configuring vPCs, page 21-5
- Configuring IP Tunnels, page 21-6
- Configuring Virtual Ethernet Interfaces, page 21-6
- Configuring Fabric Extenders, page 21-6
- Configuring Port Profiles, page 21-7

For detailed information about the configuration of the interface on DCNM-LAN client, see the Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x.

Configuring Basic Interface Parameters

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure the basic interface parameters for interfaces managed by Cisco Data Center Network Manager (DCNM) on Cisco NX-OS devices.

*Note*

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

Many Layer 2 and Layer 3 interfaces are configured with the same parameters. When you configure these parameters, your settings affect the other interfaces that use those parameters.
Chapter 21 Configuring Interfaces on DCNM-LAN Client

Configuring Layer 2 Interfaces

Note
Beginning with Cisco Release 5.2, the Cisco Nexus 7000 Series devices support FabricPath Layer 2 interfaces. See the *Cisco Nexus 7000 Series NX-OS FabricPath Command Reference* for complete information about the FabricPath feature and interfaces.

This chapter in *Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure Layer 2 switching ports as access or trunk ports on Cisco NX-OS devices using Cisco Data Center Network Manager (DCNM).

Note
The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

Layer 2 interfaces are used for switching packets. You can configure a Layer 2 port as an access port, which carries only one VLAN, or a trunk port, which carries many VLANs. By default, a trunk port carries all VLANs that are configured on the device, and you configure the trunk port to carry only those VLANs that you want on that port. The device uses IEEE 802.1Q to tag packets. All trunk ports must be in the same device, and trunk ports cannot carry VLANs from different devices.

You identify a native VLAN for each trunk port. The trunk port carries the traffic for that specific VLAN as untagged packets. If you do not configure a native VLAN, the device uses the default VLAN to carry untagged traffic on trunk ports and to retain the tag for the native VLAN.

Note
Beginning with Cisco NX-OS Release 5.1, a Layer 2 port can function as either one of the following:

- A trunk port
- An access port
- A private VLAN port (see the *Cisco DCNM Layer 2 Switching Configuration Guide, Release 5.x*, for more information on private VLANs)
- A FabricPath port (see the *Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide, Release 5.x*, and the *Cisco DCNM FabricPath Configuration Guide, Release 5.x*, for information on FabricPath)

Beginning with Cisco NX-OS Release 5.2(1), a Layer 2 port can also function as a shared interface. You cannot configure an access interface as a shared interface. See the *Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500* for information on shared interfaces.

Note
See the *Cisco DCNM FabricPath Configuration Guide, Release 5.x*, for more information on configuring the FabricPath feature.

Note
A Layer 2 port can function as either a trunk port, an access port, or a private VLAN port.
Configuring Layer 3 Interfaces

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure Layer 3 interfaces for Cisco NX-OS devices using Cisco Data Center Network Manager (DCNM).

Layer 3 interfaces forward IPv4 and IPv6 packets to another device using static or dynamic routing protocols. You can use Layer 3 interfaces for IP routing and inter-VLAN routing of Layer 2 traffic. A layer 3 logical interface (VLAN network interface, loopback, tunnel) configured in one VDC is isolated from a layer 3 logical interface with the same number configured in another VDC. For example, loopback 0 in VDC 1 is independent of loopback 0 in VDC 2.

You cannot configure a shared interface as a Layer 3 interface. See the Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500 for information on shared interfaces.

Beginning with Cisco Release 5.2(1), you can configure a Fabric Extender (FEX) port as a Layer 3 interface for host connectivity, but not for routing. See the Configuring the Cisco Nexus 2000 Series Fabric Extender for more information on fabric extenders.

Configuring Port Channels

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure port channels and to apply and configure the Link Aggregation Control Protocol (LACP) for more efficient use of port channels using Cisco Data Center Network Manager (DCNM) in the Cisco NX-OS devices.

Beginning with Cisco Release NX-OS 5.1(1), you can use any of the F1 series modules or M1 series modules for the port channel, but you cannot combine member ports on an F1 module with ports on an M1 module in a single port channel. On a single switch, the port-channel compatibility parameters must be the same among all the port-channel members on the physical switch.

For more information about the Data Center Network Manager features and using the Topology tab with port channels, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.
Configuring vPCs

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure virtual port channels (vPCs) using Cisco Data Center Network Manager (DCNM) on Cisco NX-OS devices.

Beginning with Cisco NX-OS Release 5.1(1), vPCs have been enhanced to interoperate with FabricPath. To configure vPCs with FabricPath networks, see the Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide, Release 5.x.

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

System-message logging levels for the vPC feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them the minimum requirements. Cisco Nexus 7000 Series Switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x.

Beginning with Cisco NX-OS Release 5.1(1), you can use any of the 10-Gbps Ethernet (10GE) interfaces on the F series modules or the 10GE interfaces on the M series modules for the vPC peer link on an individual switch, but you cannot combine member ports on an F module with ports on an M module into a single port channel on a single switch. The port channel compatibility parameters must be the same for all the port channel members on the physical switch.

You cannot configure shared interfaces to be part of a vPC. See the Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500 for more information on shared interfaces.

The port channel compatibility parameters must also be the same for all vPC member ports on both peers and therefore you must use the same type of module in each chassis.

Virtual port channels (vPCs) allow links that are physically connected to two different Cisco Nexus 7000 series devices to appear as a single port channel by a third device.


Configuring IP Tunnels

Note

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure IP tunnels using Generic Route Encapsulation (GRE) using the Cisco Data Center Network Manager (DCNM) on Cisco NX-OS devices.

Configuring Virtual Ethernet Interfaces

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure virtual Ethernet (vEthernet or vEth) interfaces using Cisco Data Center Network Manager (DCNM).

Virtual Ethernet (vEthernet or vEth) interfaces are logical interfaces. Each vEthernet interface corresponds to a switch interface that is connected to a virtual port. The interface types are as follows:

- Virtual Machine (VM) (interfaces connected to VM NICs)
- Service console
- VM-Fabric Extender (FEX)
- FEX-Adapter
- vmkernel

vEthernet interfaces are created on the Cisco MDS 9000 Series to represent virtual ports in use on the distributed virtual switch.

Note

System-message logging levels for the Virtual Ethernet interfaces feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series Switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.

Configuring Fabric Extenders

Note

Beginning with Cisco DCNM for LAN, Release 5.2, you can configure a Fabric Extender host interface port as a routed or Layer 3 port. However, no routing protocols can be tied to this routed interface.

The Fabric Extender feature allows you to manage a Cisco Nexus 2000 Series Fabric Extender and its association with the Cisco NX-OS switch that it is attached to. A Fabric Extender is connected to the switch through physical Ethernet interfaces or a Port Channel. By default, the switch does not allow the attached Fabric Extender to connect until it has been assigned a chassis ID and is associated with the connected interface.
Chapter 21 Configuring Interfaces on DCNM-LAN Client

Configuring Port Profiles

This chapter in Interfaces Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure port profiles using Cisco Data Center Network Manager (DCNM). A port profile is a mechanism for simplifying the configuration of interfaces. You can configure a port profile and then assign it to multiple interfaces to give them all the same configuration. Changes to the port profile are propagated to the configuration of any interface that is assigned to it.

You can configure Ethernet or vEthernet port profiles to which you can assign Ethernet or vEthernet interfaces, respectively.

Note

We do not recommend that you override port profile configurations by making changes to the assigned interface configurations. Only make configuration changes to interfaces to quickly test a change or to disable a port.

Note

System-message logging levels for the Port Profiles feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series Switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.
Configuring Switching on DCNM-LAN Client

This chapter briefly introduces the following features:

- Configuring VLANs, page 22-1
- Configuring Private VLANs, page 22-2
- Configuring STP Extensions, page 22-2
- Configuring Rapid PVST+, page 22-3
- Configuring MST, page 22-3
- Configuring Link-State Tracking, page 22-3
- Configuring FabricPath Switching, page 22-3
- FabricPath Forwarding, page 22-4
- Configuring Advanced FabricPath Features, page 22-4
- Using the Layer 2 Security Audit Wizard, page 22-4
- Configuring Dynamic ARP Inspection, page 22-4
- Configuring Port Security, page 22-5
- Configuring DHCP Snooping, page 22-6
- Configuring IP Source Guard, page 22-6
- Configuring Traffic Storm Control, page 22-7
- Configuring IGMP Snooping, page 22-7
- Configuring FCoE Initialization Protocol Snooping, page 22-7

For detailed configuration guide, please refer to Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x.

Configuring VLANs

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure virtual LANs (VLANs) on NX-OS devices.

*A VLAN is a switched network that is logically segmented by function, project team, or application, without regard to the physical locations of the users. VLANs have the same attributes as physical LANs, but you can group end stations even if they are not physically located on the same LAN segment.*
Configuring Private VLANs

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure private VLANs. Private VLANs provide additional protection at the Layer 2 level. Private VLANs provide traffic separation and security at the Layer 2 level.

A private VLAN is one or more pairs of a primary VLAN and a secondary VLAN, all with the same primary VLAN. The two types of secondary VLANs are isolated and community VLANs. Hosts on isolated VLANs communicate only with hosts in the primary VLAN. Hosts in a community VLAN can communicate only among themselves and with hosts in the primary VLAN but not with hosts in isolated VLANs or in other community VLANs.

Regardless of the combination of isolated and community secondary VLANs, all interfaces within the primary VLAN comprise one Layer 2 domain, and therefore, require only one IP subnet.

Configuring STP Extensions

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure Spanning Tree Protocol (STP) extensions on Cisco Nexus 7000 Series NX-OS devices.

The software supports the following Cisco proprietary features:

- **Spanning tree port types**—The default spanning tree port type is normal. You can configure interfaces connected to Layer 2 hosts as edge ports and interfaces connected to Layer 2 switches or bridges as network ports.
- **Bridge Assurance**—Once you configure a port as a network port, Bridge Assurance sends BPDUs on all ports and moves a port into the blocking state if it no longer receives BPDUs. This enhancement is available only when you are running Rapid PVST+ or MST.
- **BPDU Guard**—BPDU Guard shuts down the port if that port receives a BPDU.
- **BPDU Filter**—BPDU Filter suppresses sending and receiving BPDUs on the port.
- **Loop Guard**—Loop guard helps prevent bridging loops that could occur because of a unidirectional link failure on a point-to-point link.
- **Root Guard**—The root guard feature prevents a port from becoming root port or blocked port. If a port configured for root guard receives a superior BPDU, the port immediately goes to the root-inconsistent (blocked) state.
Chapter 22: Configuring Switching on DCNM-LAN Client

**Configuring Rapid PVST+**

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure the Rapid per VLAN Spanning Tree (Rapid PVST+) protocol on NX-OS devices.

**Configuring MST**

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure Multiple Spanning Tree (MST) on NX-OS devices.

For more information about the Data Center Network Manager features, see the *Cisco DCNM Fundamentals Configuration Guide*.

**Configuring Link-State Tracking**

*Note*
The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure link-state tracking on the Cisco Nexus 4000 Series device.

The link-state tracking feature binds the link state of multiple interfaces and provides redundancy in the network. In link-state tracking, you configure the server network adapters in a primary or secondary relationship known as teaming. The interfaces are grouped into link-state groups and if the link is lost on a primary interface, connectivity transparently moves to the secondary interface.

*Note*
Link-state tracking is applicable only for the Cisco Nexus 4000 Series platform, beginning with the DCNM 4.2(3) release.

**Configuring FabricPath Switching**

*Note*
You must have an F Series module installed in your Cisco Nexus 7000 Series chassis in order to run FabricPath and conversational learning.

FabricPath switching allows multipath networking at the Layer 2 level. The FabricPath network still delivers packets on a best-effort basis (which is similar to the Classical Ethernet [CE] network), but the FabricPath network can use multiple paths for Layer 2 traffic.

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure FabricPath switching on the Cisco Nexus 7000 Series NX-OS devices.
FabricPath Forwarding

Beginning with Cisco Release 5.1(2) for the Nexus 700 Series devices, you can create additional, nondefault FabricPath topologies. Each additional topology also has two forwarding trees. Additionally, you can display information about the interfaces and reachability status of the FabricPath network.

Note

See the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x for more information on displaying the FabricPath topologies.

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes the forwarding behavior of FabricPath on the Cisco Nexus 7000 Series NX-OS devices.

Configuring Advanced FabricPath Features


For more information about the Data Center Network Manager features, see the Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x.

Using the Layer 2 Security Audit Wizard

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to use the Layer 2 Security Audit Wizard.

The Security Audit Wizard allows you to examine the existing Layer 2 security features such as port security, dynamic ARP inspection (DAI), DHCP snooping, IP Source Guard, and traffic storm control configured on different devices. It also allows you to report and apply configurations that are missing on the device.

For more information about the Data Center Network Manager features, see the Cisco DCNM Fundamentals Configuration Guide.

Configuring Dynamic ARP Inspection

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure dynamic Address Resolution Protocol (ARP) inspection (DAI) on an NX-OS device.

Dynamic ARP inspection (DAI) ensures that only valid ARP requests and responses are relayed. When DAI is enabled and properly configured, a device performs these activities:

- Intercepts all ARP requests and responses on untrusted ports
- Verifies that each of these intercepted packets has a valid IP-to-MAC address binding before updating the local ARP cache or before forwarding the packet to the appropriate destination
- Drops invalid ARP packets
DAI can determine the validity of an ARP packet based on valid IP-to-MAC address bindings stored in a DHCP snooping binding database. This database is built by DHCP snooping if DHCP snooping is enabled on the VLANs and on the device. It can also contain static entries that you create. If the ARP packet is received on a trusted interface, the device forwards the packet without any checks. On untrusted interfaces, the device forwards the packet only if it is valid.

**Note**
The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

System-message logging levels for DAI must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

For more information about the Data Center Network Manager features, see the *Cisco DCNM Fundamentals Configuration Guide*.

### Configuring Port Security

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure port security on NX-OS devices.

You can use port security to configure Layer 2 Ethernet interfaces and Layer 2 port-channel interfaces that allow inbound traffic from only a restricted set of MAC addresses. The MAC addresses in the restricted set are called secure MAC addresses. In addition, the device does not allow traffic from these MAC addresses on another interface within the same VLAN. The number of MAC addresses that the device can secure is configurable per interface.

**Note**
The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release. This chapter includes the following sections:

System-message logging levels for port security must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

For more information about the Data Center Network Manager features, see the *Cisco DCNM Fundamentals Configuration Guide*.
# Configuring DHCP Snooping

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure Dynamic Host Configuration Protocol (DHCP) snooping on an NX-OS device.

DHCP snooping is a security feature that acts like a firewall between untrusted hosts and trusted DHCP servers. DHCP snooping performs the following activities:

- Validates DHCP messages received from untrusted sources and filters out invalid messages.
- (Not in 4.0) Rate-limits DHCP traffic from trusted and untrusted sources.
- Builds and maintains the DHCP snooping binding database, which contains information about untrusted hosts with leased IP addresses.
- Utilizes the DHCP snooping binding database to validate subsequent requests from untrusted hosts.

Dynamic ARP inspection (DAI) and IP Source Guard also use information stored in the DHCP snooping binding database.

---

**Note**

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

---

**Note**

System-message logging levels for DHCP snooping must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

# Configuring IP Source Guard

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure IP Source Guard on NX-OS devices.

IP Source Guard is a per-interface traffic filter that permits IP traffic only when the IP address and MAC address of each packet matches one of two sources of IP and MAC address bindings:

- Entries in the DHCP snooping binding table.
- Static IP source entries that you configure.

Filtering on trusted IP and MAC address bindings helps prevent attacks that rely on spoofing the IP address of a valid host. To circumvent IP Source Guard, an attacker would have to spoof both the IP address and the MAC address of a valid host.

---

**Note**

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.
Configuring Traffic Storm Control

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure traffic storm control on the NX-OS device.

Traffic storm control (also called traffic suppression) allows you to monitor the levels of the incoming traffic over a 1-second interval. During this interval, the traffic level, which is a percentage of the total available bandwidth of the port, is compared with the traffic storm control level that you configured. When the ingress traffic reaches the traffic storm control level that is configured on the port, traffic storm control drops the traffic until the interval ends.

Configuring IGMP Snooping

The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this chapter. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

Cisco recommends that you do not disable IGMP snooping on the device. If you disable IGMP snooping, you may see reduced multicast performance because of excessive false flooding within the device.

The Internet Group Management Protocol (IGMP) snooping software examines Layer 2 IP multicast traffic within a VLAN to discover the ports where interested receivers reside. Using the port information, IGMP snooping can reduce bandwidth consumption in a multi-access LAN environment to avoid flooding the entire VLAN. The IGMP snooping feature tracks which ports are attached to multicast-capable routers to help the routers forward IGMP membership reports. The IGMP snooping software responds to topology change notifications. By default, IGMP snooping is enabled on the device.

Configuring FCoE Initialization Protocol Snooping

The Fiber Channel over Ethernet (FCoE) Initialization Protocol (FIP) is a Layer 2 protocol for end point discovery and fabric association. FIP has its own EtherType and uses its own frame formats.

FIP has two phases: discovery and login. Once the discovery of end nodes and login is complete, FCoE traffic can start flowing between the endpoints.

By snooping on FIP packets during the discovery and login phases, intermediary bridges can implement dynamic data integrity mechanisms using access control lists (ACLs) that permit only valid FCoE traffic between the ENode and the FCoE forwarder (FCF).
A bridge implementing the above functionality is what we refer to as the FIP Snooping Bridge. The process implementing this feature is called FIP Snooping Manager (FIPSM). FIPSM is capable of supporting both Fabric Provided MAC Addresses (FPMAs) and Server Provided MAC Addresses (SPMAs).

This chapter in Layer 2 Switching Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure the Fibre Channel over Ethernet (FCoE) Initialization Protocol (FIP) snooping feature using the Cisco Data Center Network Manager (DCNM).
Configuring Routinging on DCNM-LAN Client

The Cisco Data Center Network Manager (DCNM) supports IP addressing, object tracking, and Gateway Load Balancing Protocol (GLBP). This chapter includes following sections:

- Configuring GLBP, page 23-1
- Configuring HSRP, page 23-1
- Configuring Keychain Management, page 23-2
- Configuring Object Tracking, page 23-2

For more information about the Data Center Network Manager features, see the *Unicast Routing Configuration Guide, Cisco DCNM for LAN, Release 7.x*.

Configuring GLBP

This chapter in *Unicast Routing Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure the Gateway Load Balancing Protocol (GLBP) on the Cisco Data Center Network Manager (DCNM)NX-OS device. This chapter includes the following sections:

GLBP provides path redundancy for IP by sharing protocol and Media Access Control (MAC) addresses between redundant gateways. Additionally, GLBP allows a group of Layer 3 routers to share the load of the default gateway on a LAN. A GLBP router can automatically assume the forwarding function of another router in the group if the other router fails.

Configuring HSRP

This chapter in *Unicast Routing Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure the Hot Standby Router Protocol (*HSRP*) on the Cisco Data Center Network Manager (DCNM)NX-OS device. This chapter includes the following sections:

HSRP is a first-hop redundancy protocol (*FHRP*) that allows a transparent failover of the first-hop IP router. HSRP provides first-hop routing redundancy for IP hosts on Ethernet networks configured with a default router IP address. You use HSRP in a group of routers for selecting an active router and a standby router. In a group of routers, the active router is the router that routes packets; the standby router is the router that takes over when the active router fails or when preset conditions are met.
Many host implementations do not support any dynamic router discovery mechanisms but can be configured with a default router. Running a dynamic router discovery mechanism on every host is not feasible for a number of reasons, including administrative overhead, processing overhead, and security issues. HSRP provides failover services to these hosts.

Configuring Keychain Management

This chapter in *Unicast Routing Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure keychain management on an NX-OS device.

Keychain management allows you to create and maintain keychains, which are sequences of keys (sometimes called shared secrets). You can use keychains with features that secure communications with other devices by using key-based authentication. The device allows you to configure multiple keychains. Some routing protocols that support key-based authentication can use a keychain to implement a hitless key rollover for authentication.

**Note**
The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

This chapter includes the following sections:

Configuring Object Tracking

This chapter in *Unicast Routing Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure object tracking on the Cisco NX-OS Cisco NX-OS device.

This chapter includes the following sections:

Object tracking allows you to track specific objects on the device, such as the interface line protocol state, IP routing, and route reachability, and to take action when the tracked object’s state changes. This feature allows you to increase the availability of the network and shorten recovery time if an object state goes down.

System-message logging levels for the Object Tracking feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements.
The Cisco NX-OS software supports security features that can protect your network against degradation or failure and also against data loss or compromise resulting from intentional attacks and from unintended but damaging mistakes by well-meaning network users.

This chapter includes the following sections:

- Configuring IP ACLs, page 24-1
- Configuring MAC ACLs, page 24-2
- Configuring VLAN ACLs, page 24-2
- Configuring ARP ACLs, page 24-2
- Configuring Object Groups, page 24-3
- Configuring AAA, page 24-3
- Configuring Time Ranges, page 24-3
- Configuring RADIUS, page 24-3
- Configuring TACACS+, page 24-4
- Configuring 802.1X, page 24-4
- Configuring User Accounts and RBAC, page 24-5

For detailed information about the security configuration on DCNM-LAN client, see Security Configuration Guide, Cisco DCNM for LAN, Release 7.x.

Configuring IP ACLs

You can configure an IP ACL on the device. An IP ACL is an ordered set of rules that you can use to filter traffic based on IPv4 or IPv6 information in the Layer 3 header of packets. Each rule specifies a set of conditions that a packet must satisfy to match the rule. When a device determines that an IP ACL applies to a packet, it tests the packet against the conditions of all rules. The first match determines whether a packet is permitted or denied, or if there is no match, the device applies the applicable default rule. The device continues processing packets that are permitted and drops packets that are denied.

Unless otherwise specified, the term IP ACL refers to IPv4 and IPv6 ACLs.
Chapter 24  Security Configurations on DCNM-LAN Client

Configuring MAC ACLs

You can configure a MAC ACL on the device. MAC ACLs are ACLs that filter traffic using the information in the Layer 2 header of each packet. Each rule specifies a set of conditions that a packet must satisfy to match the rule. When a device determines that a MAC ACL applies to a packet, it tests the packet against the conditions of all rules. The first match determines whether a packet is permitted or denied, or if there is no match, the device applies the applicable default rule. The device continues processing packets that are permitted and drops packets that are denied.

Note  The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

Configuring VLAN ACLs

A VLAN ACL (VACL) is one application of a MAC ACL or IP ACL. You can configure VACLs to apply to all packets that are routed into or out of a VLAN or are bridged within a VLAN. VACLs are strictly for security packet filtering and for redirecting traffic to specific physical interfaces. VACLs are not defined by direction (ingress or egress).

Note  The Cisco NX-OS release that is running on a managed device may not support all the features or settings described in this section. For the latest feature information and caveats, see the documentation and release notes for your platform and software release.

Configuring ARP ACLs

You can configure an ARP ACL on the device. An ARP ACL is an ordered set of rules that you can use to filter ARP traffic for dynamic ARP inspection (DAI). Each rule specifies a set of conditions that a packet must satisfy to match the rule. When a device determines that an ARP ACL applies to an ARP packet, it tests the packet against the conditions of all rules. The first match determines whether a packet is permitted or denied, or if there is no match, the device applies the applicable default rule. The device continues processing packets that are permitted and drops packets that are denied.

When you configure the device to apply an ARP ACL to traffic, the ACL take precedence over entries in the DHCP snooping binding database. The switch first compares ARP packets to user-configured ARP ACLs. If the ARP ACL denies the ARP packet, the switch also denies the packet even if a valid binding exists in the database populated by DHCP snooping.
Configuring Object Groups

An object group is a group of IP addresses or a group of TCP or UDP ports. When you create an access control list (ACL) rule, you can specify the object groups rather than specifying IP addresses or ports. Using object groups when you configure IPv4 or IPv6 ACLs can help reduce the complexity of updating ACLs when you need to add or remove addresses or ports from the source or destination of rules. For example, if three rules reference the same IP address group object, you can add an IP address to the object instead of changing all three rules.

Configuring AAA


You can configure authentication, authorization, and accounting (AAA) network security services to provide the primary framework through which you set up access control on your router or access server. Based on the user ID and password combination that you provide, the Cisco NX-OS device performs local authentication or authorization using the local database or remote authentication or authorization using one or more AAA servers.

Note
System-message logging levels for AAA must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.

Configuring Time Ranges

You can use time ranges to control when an ACL rule is in effect. For example, if the device determines that a particular ACL applies to traffic arriving on an interface, if a rule in the ACL uses a time range that is not in effect, the device does not compare the traffic to that rule.

IPv4, IPv6, and MAC ACLs support time ranges. When the device applies an ACL to traffic, the rules that are in effect are as follows:

- All rules that are not configured with a time range.
- Rules that are configured with a time range which is active at the second that the device applies the ACL to traffic.

The device supports named, reusable time ranges. This allows you to configure a time range once and specify it by name when configure many ACL rules.

Configuring RADIUS

You can configure RADIUS on a device. The RADIUS distributed client/server system allows you to secure networks against unauthorized access. In the Cisco implementation, RADIUS clients run on Cisco NX-OS devices and send authentication and accounting requests to a central RADIUS server that contains all user authentication and network service access information.

**Note**

System-message logging levels for RADIUS must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

### Configuring TACACS+


You can use TACACS+ to provide centralized validation of users attempting to gain access to a device. TACACS+ services are maintained in a database on a TACACS+ daemon running, typically, on a UNIX or Windows NT workstation. You must have access to and must configure a TACACS+ server before the configured TACACS+ features on your device are available.

**Note**

System-message logging levels for TACACS+ must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

### Configuring 802.1X

This chapter in Security Configuration Guide, Cisco DCNM for LAN, Release 7.x describes how to configure IEEE 802.1X port-based authentication on Cisco NX-OS devices.

802.1X defines a client-server-based access control and authentication protocol that restricts unauthorized clients from connecting to a LAN through publicly accessible ports. The authentication server authenticates each client connected to a device port.

Until the client is authenticated, 802.1X access control allows only Extensible Authentication Protocol over LAN (EAPOL) traffic through the port to which the client is connected. After authentication is successful, normal traffic can pass through the port.

**Note**

System-message logging levels for 802.1X must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception.
For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

**Configuring User Accounts and RBAC**

This chapter in *Security Configuration Guide, Cisco DCNM for LAN, Release 7.x* describes how to configure user accounts and role-based access control (RBAC) on NX-OS devices.

You can create and manage users accounts and assign roles that limit access to operations on the NX-OS device. Role-based access control (RBAC) allows you to define the rules for an assign role that restrict the authorization that the user must have to access management operations.
Working with Configuration Change Management

This chapter describes how to use the Configuration Change Management feature on Cisco NX-OS devices.

The Configuration Change Management feature allows you to keep an archive of configurations from managed devices. You can view and compare configurations. You can roll back the configuration on a managed device to any archived configuration that Cisco DCNM has for the device.

This chapter includes the following sections:

- Information About Configuration Change Management, page 25-1
- Licensing Requirements for Configuration Change Management, page 25-5
- Prerequisites, page 25-5
- Guidelines and Limitations for Configuration Change Management, page 25-6
- Platform Support, page 25-6
- Working with the Version Browser, page 25-6
- Configuring Archival Jobs, page 25-18
- Configuring Archival Settings, page 25-22
- Configuring Switch Profiles, page 25-23
- Field Descriptions for Configuration Change Management, page 25-27
- Additional References, page 25-32
- Feature History for Configuration Change Management, page 25-32

Information About Configuration Change Management

The Configuration Change Management feature allows you to keep an archive of configurations from managed devices. You can view and compare archived configurations. You can roll back the running configuration of a managed device to any archived configuration version available for the device in Cisco Data Center Network Manager (DCNM).

Note: Beginning with Cisco Release 5.2(1), Cisco DCNM supports the Cisco IOS platform.
Note

Beginning with Cisco DCNM Release 5.2(1), this feature supports Cisco Nexus 5000 Series, Cisco Catalyst 6500 Series, Cisco Nexus 3000 Series, and Cisco Nexus 7000 Series devices, Cisco Nexus 1000 Series, Cisco Nexus 1010 Series, and Cisco Nexus 4000 Series devices.

This section includes the following topics:

- Version Browser, page 25-2
- Archival Jobs, page 25-2
- Archival Settings, page 25-2
- VDC Support, page 25-5

Version Browser

The Version Browser feature allows you to see information about archived configurations, view and compare specific configuration versions, and merge changes from one configuration version to another version. After you modify a configuration by merging changes, you can save the modified configuration as a text file on a file system that is available to the computer that you are using to run the Cisco DCNM client.

From the Version Browser, you can initiate a configuration rollback for a managed Cisco Nexus 7000 Series device, using any of the archived configurations available in Cisco DCNM for the device. Cisco DCNM uses the rollback feature available in Cisco IOS and Cisco NX-OS. For more information about the Cisco NX-OS rollback feature, see the Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x.

Archival Jobs

The Archival Jobs feature allows you to control the automated archival of the running configuration on managed devices. You can add, edit, and delete custom archival jobs. A job consists of settings that determine when the job runs and a list of managed devices included in the job. You can choose to archive configurations at a regular interval, at a scheduled time on selected days, or whenever Cisco DCNM detects configuration changes on a device. You can also comment on a job.

The Default archival job always exists. You cannot delete it. By default, it is disabled.

Devices can be assigned to one archival job only. If you assign a device to an archival job, Cisco DCNM removes the device from the job that it was previously assigned to.

If a managed device is not assigned to a custom archival job, Cisco DCNM automatically assigns it to the Default archival job.

Archival Settings

The Archival Settings feature allows you to configure settings related to configuration change management, including the number of configuration versions that Cisco DCNM stores for each managed device, how many rollback and archival history entries Cisco DCNM stores for each managed device, and which file server Cisco DCNM uses during a configuration rollback.
Switch Profiles

Note
The Switch Profiles feature is supported only on the Cisco Nexus 5000 series switches.

Several applications require consistent configuration across Cisco Nexus 5000 Series switches in the network. For example, with a virtual port channel (vPC), you must have identical configurations. Mismatched configurations can cause errors or misconfigurations that can result in service disruptions. The configuration synchronization (config-sync) feature in Cisco NX-OS Release 5.0(2)N1(1) allows you to configure one switch profile and have the configuration be automatically synchronized to the peer switch.

A switch profile provides the following benefits:
- Allows configurations to be synchronized between switches.
- Merges configurations when connectivity is established between two switches.
- Provides control of exactly which configuration gets synchronized.
- Ensures configuration consistency across peers through merge and mutual-exclusion checks.
- Provides verify and commit semantics.
- Supports configuring and synchronizing port profile configurations.
- Provides an import command to migrate existing vPC configurations to a switch profile.

Switch Profile Configuration Modes

The Cisco NX-OS Release 5.0(2)N1(1) switch profile feature includes the following configuration modes:
- Configuration synchronization mode
- Switch profile mode
- Switch profile import mode

Configuration Synchronization Mode
Beginning with Cisco NX-OS Release 5.0(2)N1(1), the configuration synchronization mode (config-sync) allows you to create switch profiles. After entering the `config sync` command, you can create and name the switch profile that displays the switch profile mode. You must enter the `config sync` command on the local switch and the peer switch that you want to synchronize.

Switch Profile Mode
The switch profile mode allows you to add supported configuration commands to a switch profile that is later synchronized with a peer switch. Commands that you enter in the switch profile mode are buffered until you enter the `commit` command.

Switch Profile Import Mode
When you upgrade from an earlier release to Cisco NX-OS Release 5.0(2)N1(1), you have the option to enter the `import` command to copy supported running-configuration commands to a switch profile. After entering the `import` command, the switch profile mode (config-sync-sp) changes to the switch profile import mode (config-sync-sp-import). The switch profile import mode allows you to import existing switch configurations from the running configuration and specify which commands you want to include in the switch profile.
Because different topologies require different commands that are included in a switch profile, the import command mode allows you to modify the imported set of commands to suit a specific topology. For example, a dual homed Fabric Extender (FEX) topology requires that most of the configuration is synchronized. In other vPC topologies, the configuration that needs to be synchronized might be a much smaller set of commands.

You need to enter the `commit` command to complete the import process and move the configuration into the switch profile. Because configuration changes are not supported during the import process, if you added new commands before entering the `commit` command, the switch profile remains unsaved and the switch remains in the switch profile import mode. You can remove the added commands or abort the import. Unsaved configurations are lost if the process is aborted. You can add new commands to the switch profile after the import is complete.

**Configuration Validation**

Two types of configuration validation checks can identify two types of switch profile failures:

- Mutual exclusion checks
- Merge checks

**Mutual Exclusion Checks**

To reduce the possibility of overriding configuration settings that are included in a switch profile, mutual exclusion (mutex) checks the switch profile commands against the commands that exist on the local switch and the commands on the peer switch. A command that is included in a switch profile cannot be configured outside of the switch profile or on a peer switch. This requirement reduces the possibility that an existing command is unintentionally overwritten.

As a part of the commit process, the mutex-check occurs on both switches if the peer switch is reachable; otherwise, the mutex-check is performed locally. Configuration changes made from the configuration terminal occur only on the local switch.

If a mutex-check identifies errors, these errors are reported as a mutex failure and must be manually corrected.

The following exceptions apply to the mutual exclusion policy:

- Interface configuration—An interface configuration can be partially present in a switch profile and partially present in the running configuration as long as there are no conflicts.
- Shutdown/no shutdown
- System QoS

**Merge Checks**

Merge checks are done on the peer switch that is receiving a configuration. The merge checks ensure that the received configuration does not conflict with the switch profile configuration that already exists on the receiving switch. The merge check occurs during the merge or commit process. Errors are reported as merge failures and must be manually corrected.

When one or both switches are reloaded and the configurations are synchronized for the first time, the merge check verifies that the switch profile configurations are identical on both switches. Differences in the switch profiles are reported as merge errors and must be manually corrected.
Software Upgrades and Downgrades with Switch Profiles

When you downgrade from Cisco NX-OS Release 5.0(2)N1(1) to an earlier release, you are prompted to remove an existing switch profile that is not supported on earlier releases.

When you upgrade from an earlier release to Cisco NX-OS Release 5.0(2)N1(1), you have the option to move some of the running-configuration commands to a switch profile. The `import` command allows you to import relevant switch profile commands. An upgrade can occur if there are buffered configurations (uncommitted); however, the uncommitted configurations are lost.

When you perform an In Service Software Upgrade (ISSU) on one of the switches included in a switch profile, a configuration synchronization cannot occur because the peer is unreachable.

VDC Support

Cisco DCNM treats each virtual device context (VDC) on a Cisco IOS and Cisco NX-OS device as a separate device; therefore, Cisco DCNM archives the running configurations of each VDC if that Cisco DCNM has successfully discovered the VDC and views it as a managed device.

Licensing Requirements for Configuration Change Management

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM</td>
<td>Configuration Change Management requires a LAN Enterprise license. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 6.x</em>.</td>
</tr>
<tr>
<td>Cisco NX-OS</td>
<td>Configuration Change Management requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For an explanation of the Cisco NX-OS licensing scheme for your platform, see the licensing guide for your platform.</td>
</tr>
</tbody>
</table>

Prerequisites

The Configuration Change Management feature has the following prerequisites (for a full list of feature-specific prerequisites, see the platform-specific documentation):

- The Configuration Change Management feature supports only devices that are managed by Cisco DCNM, which means that Cisco DCNM must have successfully discovered the device.
- The Configuration Change Management feature supports only devices that you have added to the list of Cisco DCNM-licensed devices.
- Devices must be reachable by Cisco DCNM when Cisco DCNM attempts to archive the configuration or to perform a configuration rollback. An archival job or configuration rollback fails if the device is unreachable by Cisco DCNM.
Guidelines and Limitations for Configuration Change Management

Configuration Change Management has the following configuration guidelines and limitations:

- You can archive a maximum of 50 configuration versions per managed device.
- Configure archival jobs and archival settings based upon the needs of your organization.
- We recommend enabling the Default archival job and configuring the job to run at the lowest frequency that your backup policy tolerates.
- A configuration rollback can be performed on managed Cisco Nexus 7000 Series devices only.
- Access to archived configurations is supported through the Cisco DCNM client only. The client provides features for viewing, comparing, and deleting archived configurations. Each archived configuration is marked with the date and time that Cisco DCNM archived the configuration. For more information, see the “Working with the Version Browser” section on page 25-6.

Platform Support

The following platforms support this feature but may implement it differently. For platform-specific information, including guidelines and limitations, system defaults, and configuration limits, see the corresponding documentation.

<table>
<thead>
<tr>
<th>Platform</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Nexus 1000V Series switches</td>
<td>Cisco Nexus 1000V Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 3000 Series switches</td>
<td>Cisco Nexus 3000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 4000 Series switches</td>
<td>Cisco Nexus 4000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 5000 Series switches</td>
<td>Cisco Nexus 5000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 7000 Series switches</td>
<td>Cisco Nexus 7000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Catalyst 6500 Series switches</td>
<td>Cisco Catalyst 6500 Series Switches Documentation</td>
</tr>
</tbody>
</table>

Working with the Version Browser

The version browser allows you to see information about archived configurations, view and compare specific configuration versions, merge changes from one configuration version to another, and roll back the running configuration on a managed device to a configuration version that you specify.

This section includes the following topics:

- Viewing the Archival Status of a Device, page 25-7
- Viewing the Archival History of a Device, page 25-8
- Browsing and Commenting on Configuration Versions, page 25-8
- Using Copy Run to Start, page 25-9
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
Viewing the Archival Status of a Device

You can view the archival status of a device. The archival status for a device includes the following information:

- Whether the archival job that includes the device is enabled or disabled.
- The schedule for the archival job that includes the device.
- The job ID of the archival job that includes the device.

BEFORE YOU BEGIN

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

DETAILED STEPS

**Step 1**

From the Feature Selector pane, choose **Configuration Change Management > Version Browser**.

The Summary pane displays a table of devices.

**Step 2**

Click the device that has the archival status that you want to view.

The Details pane displays archive-related information about the device, including an Archival Status section.

If the archival job that includes the device is enabled, the View Schedule link appears.

If the archival job that includes the device is disabled, the Enable Archival Schedule link appears.

**Step 3**

(Optional) If you want to view the details of the archival job that includes the device, click the View Schedule link or the Enable Archival Schedule link. For more information, see the “Viewing Details of an Archival Job” section on page 25-21.

RELATED TOPICS

- Viewing the Archival History of a Device, page 25-8
- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
Viewing the Archival History of a Device

You can view the archival history of a device. The archival history records each attempt to create a new archival configuration version from the current running configuration of a device.

BEFORE YOU BEGIN

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Version Browser.

The Summary pane displays a table of devices.

Step 2
Click the device that has archival history that you want to view.

The Details pane displays archive-related information about the device, including an Archival History section.

Step 3
(Optional) If necessary, click the Archival History section to expand it.

The Archival History section displays a table that lists every attempt made to create a new archival configuration version for the device.

RELATED TOPICS

- Viewing the Archival Status of a Device, page 25-7
- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10

Browsing and Commenting on Configuration Versions

You can browse the archived configuration versions for managed devices. Browsing allows you to see information about all versions of an archived configuration.

You can also add, change, or delete comments on any version of an archived configuration.

BEFORE YOU BEGIN

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

The archived configuration versions that you want to browse or comment on must exist in Cisco DCNM.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Version Browser.

The Summary pane displays a table of devices.
**Step 2**

Double-click the device that has archived configuration versions that you want to browse.

A list of archived configuration versions appears below the device that you double-clicked. For each version, the Summary pane shows the version ID, the date and time that Cisco DCNM created the version, the Cisco DCNM user who created the version, and comments about the version.

**Step 3**

(Optional) If you want to comment on a version, follow these steps:

a. Click the version that you want to update with comments.

   The Details pane shows the Version Details tab, which contains the same information about the version that appears in the Summary pane, except that the Comments field is available for you to use.

b. Click in the Comments field and enter your comments.

c. From the menu bar, choose File > Deploy to save your changes to the Cisco DCNM server.

---

**RELATED TOPICS**

- Configuring Version and History Settings, page 25-22
- Viewing the Archival Status of a Device, page 25-7
- Viewing the Archival History of a Device, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Deleting All Archived Configurations for a Device, page 25-17

---

**Using Copy Run to Start**

You can use the Copy Run to Start feature to copy the running configuration to the startup configuration.

**DETAILED STEPS**

**Step 1**


**Step 2**

Right-click the appropriate device and from the drop-down list, choose Copy Run to Start. You can also press the F7 key to start the Copy Run to Start feature.

A flag appears at the end of the row to indicate that the copy process is in progress. The flag remains when the process is finished to indicate that a configuration change has been made to the device. The running configuration is copied to the startup configuration.

---

**Archiving the Current Running Configuration of a Device**

You can archive the current running configuration of a managed device.
Chapter 25  Working with Configuration Change Management

Working with the Version Browser

Archiving the current running configuration succeeds only if the most recent archived version in Cisco DCNM is different from the current running configuration.

BEFORE YOU BEGIN

The device must be managed and reachable.
A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

DETAILED STEPS

| Step 1 | From the Feature Selector pane, choose Configuration Change Management > Version Browser. The Summary pane displays a table of devices. |
| Step 2 | Click the device that has a running configuration that you want to archive now. |
| Step 3 | From the menu bar, choose Actions > Archive Configuration. |
| Step 4 | To confirm that Cisco DCNM successfully archived the configuration, view the list of archived configuration versions for the device. If necessary, double-click the device to open the list. The new version should appear at the top of the list. |

Note  If a dialog box notifies you that archiving the configuration was skipped, that means that Cisco DCNM did not detect differences between the current running configuration and the most recent archived configuration version for the device. To close the dialog box, click OK.

RELATED TOPICS

- Browsing and Commenting on Configuration Versions, page 25-8
- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Deleting All Archived Configurations for a Device, page 25-17

Viewing an Archived Configuration Version

You can view a version of an archived configuration.

BEFORE YOU BEGIN

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.
The archived configuration version that you want to view must exist in Cisco DCNM.

DETAILED STEPS

| Step 1 | From the Feature Selector pane, choose Configuration Change Management > Version Browser. |
The Summary pane displays a table of devices.

Step 2  Click the device that has an archived configuration version that you want to view.

Step 3  (Optional) If necessary, to view the list of archived configuration versions for the device, double-click the device.

Step 4  Click the version of the archived configuration that you want to view.

Step 5  From the menu bar, choose Actions > View Configuration.

In the Details pane, the Configuration tab displays the configuration version that you selected.

Tip  You can search the text of the configuration by pressing Ctrl + F.

RELATED TOPICS

- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Comparing Configuration Versions, page 25-11
- Deleting All Archived Configurations for a Device, page 25-17

Comparing Configuration Versions

You can compare two configuration versions. The configurations that you can compare can be any two archived configuration version in Cisco DCNM, including archived configurations from different managed devices. You can also compare an archived configuration versions to the running configuration or the startup configuration of a managed device.

BEFORE YOU BEGIN

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

If you are comparing archived configuration versions, the two versions must exist in Cisco DCNM.

If you are comparing an archived configuration version to a running configuration or startup configuration on a managed device, the device must be reachable by Cisco DCNM.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Configuration Change Management > Version Browser.

The Summary pane displays a table of devices.

Step 2  Double-click the device that has an archived configuration version that you want to compare to another configuration version.

Step 3  (Optional) If necessary, to view the list of archived configurations for the device, double-click the device.

Step 4  Click the archived configuration version that you want to compare to another configuration version.
Step 5  Use Table 25-1 to compare the selected version to the configuration version that you want.

**Table 25-1  Comparing Configuration Versions**

<table>
<thead>
<tr>
<th>To Compare With</th>
<th>Follow These Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Most recent configuration version from the current device</td>
<td>Right-click the version and choose <strong>Compare with &gt; Latest.</strong></td>
</tr>
<tr>
<td>Next configuration version from the current device</td>
<td>Right-click the version and choose <strong>Compare with &gt; Next.</strong></td>
</tr>
<tr>
<td>Previous configuration version from the current device</td>
<td>Right-click the version and choose <strong>Compare with &gt; Previous.</strong></td>
</tr>
<tr>
<td>Another configuration version that you select</td>
<td>1. Press and hold the <strong>Ctrl</strong> key.</td>
</tr>
<tr>
<td></td>
<td>2. Click the archived configuration version that you want to compare the first selected version to, and then release the <strong>Ctrl</strong> key.</td>
</tr>
<tr>
<td></td>
<td>3. Right-click either selected configuration version and choose <strong>Compare with &gt; Selected Versions.</strong></td>
</tr>
<tr>
<td></td>
<td>The selected configuration versions appear in the two configuration panes on the Compare tab. The configuration version that is listed highest in the Summary pane appears in the left configuration pane.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip</strong> You can select archived configuration versions from different devices.</td>
</tr>
<tr>
<td>Current running configuration from the current device</td>
<td>Right-click the version and choose <strong>Compare with &gt; Current Running Configuration.</strong></td>
</tr>
<tr>
<td>Current startup configuration from the current device</td>
<td>Right-click the version and choose <strong>Compare with &gt; Current Startup Configuration.</strong></td>
</tr>
<tr>
<td>A configuration version from another device</td>
<td>1. Right-click the version and choose <strong>Compare with &gt; Another Device Configuration Version.</strong></td>
</tr>
<tr>
<td></td>
<td>In the Details pane, the Compare tab shows the selected configuration version in the left configuration pane.</td>
</tr>
<tr>
<td></td>
<td>2. From the Device list above the right configuration pane, choose the device that has the configuration version that you want to compare with the configuration in the left pane.</td>
</tr>
<tr>
<td></td>
<td>3. From the Version list, pick the configuration version that you want to compare. You can use any version archived by Cisco DCNM or you can use the running configuration or the startup configuration currently on the device.</td>
</tr>
<tr>
<td></td>
<td>4. Click the <strong>icon.</strong></td>
</tr>
<tr>
<td></td>
<td>The right configuration pane displays the configuration version that you specified.</td>
</tr>
</tbody>
</table>

In the Details pane, the Compare tab displays the two configuration versions in side-by-side panes.
Chapter 25      Working with Configuration Change Management

Working with the Version Browser

Step 6  Use the version comparison tools as needed. For more information, see the “Using the Version Comparison Tools” section on page 25-13.

RELATED TOPICS

- Viewing an Archived Configuration Version, page 25-10
- Using the Version Comparison Tools, page 25-13
- Merging Configuration Differences, page 25-14

Using the Version Comparison Tools

When you use the Version Browser to compare configuration versions, use the Compare tab in the Details pane to assist you with the comparison.

Note  You must be comparing two configurations to use the version comparison tools. For more information, see the “Comparing Configuration Versions” section on page 25-11.

Use the options described Table 25-1 to compare two configuration versions.

<table>
<thead>
<tr>
<th>Option Icon and Name</th>
<th>How to Use the Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full vs. Delta View</td>
<td>From the list, choose the desired viewing option, as follows:</td>
</tr>
<tr>
<td></td>
<td>• Full Configuration — Shows all of both configuration versions.</td>
</tr>
<tr>
<td></td>
<td>• Delta Configuration — Shows only the sections of each configuration that differ.</td>
</tr>
<tr>
<td>Next Diff</td>
<td>Click the icon to jump to the next difference between the two configurations shown.</td>
</tr>
<tr>
<td>Prev Diff</td>
<td>Click the icon to jump to the previous difference between the two configurations shown.</td>
</tr>
<tr>
<td>Bookmark</td>
<td>1. Click a line in one of the configuration panes.</td>
</tr>
<tr>
<td></td>
<td>2. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>A bookmark icon appears beside the line number.</td>
</tr>
<tr>
<td>Next Bookmark</td>
<td>1. Click the configuration pane that has the bookmarked line that you want to view.</td>
</tr>
<tr>
<td></td>
<td>2. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>The configurations in both panes jump to the next bookmarked line.</td>
</tr>
<tr>
<td>Prev Bookmark</td>
<td>1. Click the configuration pane that has the bookmarked line that you want to view.</td>
</tr>
<tr>
<td></td>
<td>2. Click the icon.</td>
</tr>
<tr>
<td></td>
<td>The configurations in both panes jump to the previous bookmarked line.</td>
</tr>
</tbody>
</table>
Merging Configuration Differences

While you are comparing two configuration versions, you can merge lines that contain differences. The merge feature allows you to merge a whole line shown in the left configuration pane into the configuration that is shown in the right configuration pane.

BEFORE YOU BEGIN

You must be comparing two configuration versions that have differences.

Ensure that the configuration version that you want to want to merge the changes into appears in the right configuration pane.

<table>
<thead>
<tr>
<th>Option Icon and Name</th>
<th>How to Use the Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare</td>
<td>Use this option to choose the archived configuration version shown in the right configuration pane.</td>
</tr>
<tr>
<td></td>
<td>1. From the Device list, choose the device that has the configuration version that you want to compare with the configuration in the left pane.</td>
</tr>
<tr>
<td></td>
<td>2. From the Version list, pick the configuration version that you want to compare. You can use any version archived by Cisco DCNM or you can use the running configuration or the startup configuration currently on the device.</td>
</tr>
<tr>
<td></td>
<td>3. Click the icon. The right configuration pane displays the configuration version that you specified.</td>
</tr>
<tr>
<td>Merge</td>
<td>Use this option to copy a difference from the configuration in the left configuration pane into the configuration in the right pane. For detailed steps, see the “Merging Configuration Differences” section on page 25-14.</td>
</tr>
<tr>
<td>Save As</td>
<td>Click the icon to save the configuration in the right pane to a filename and location that you specify in the Save dialog box that appears.</td>
</tr>
</tbody>
</table>

RELATED TOPICS

- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Merging Configuration Differences, page 25-14
DETAILED STEPS

Step 1 Use the icon and the icon as needed to jump to the line that you want to merge from the left configuration pane into the right configuration pane.

Tip The icon becomes available only when you use the icon and the icon to locate differences.

Step 2 Click the icon.

The selected configuration line in the left pane replaces the selected line in the right pane.

Step 3 Repeat Step 1 and Step 2 as often as needed.

Tip If you want to undo all merges, click the icon.

Step 4 (Optional) If you would like to save a copy of the configuration in the left pane as an ASCII text file, click the icon and use the Save dialog box to save the configuration to a filename and location that you specify.

RELATED TOPICS

- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Using the Version Comparison Tools, page 25-13

Performing a Configuration Rollback

You can roll back the configuration of a managed Cisco Nexus 7000 Series device to any previous version that is archived by Cisco DCNM. A rollback replaces the running configuration of the managed device with an archived configuration version that you specify.

BEFORE YOU BEGIN

A managed Cisco Nexus 7000 Series device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.

The archived configuration version that you want to use in the rollback must exist in Cisco DCNM.
Step 3  (Optional) If necessary, to view the list of archived configurations for the device, double-click the device.

Step 4  Click the version of the archived configuration that you want to use as the running configuration on the device.

Step 5  Do one of the following:

- If you want to save the configuration version that you selected as the startup configuration on the device, choose one of the following rollback options:
  - If you want Cisco DCNM to restore the original running configuration of the device if any configuration command fails during the rollback, from the menu bar, choose \textbf{Actions} > \textbf{Rollback and Save as Start-up > Restore Original Config on Error (Atomic)}.
  - If you want Cisco DCNM to ignore configuration errors during a rollback, from the menu bar, choose \textbf{Actions} > \textbf{Rollback and Save as Start-up > Skip Errors and Rollback (Best Effort)}.
  - If you want Cisco DCNM to stop the rollback at the first configuration error, from the menu bar, choose \textbf{Actions} > \textbf{Rollback and Save as Start-up > Stop Rollback at First Error}.

- If you want the rollback to proceed without affecting the startup configuration currently on the device, choose one of the following rollback options:
  - If you want Cisco DCNM to restore the original running configuration of the device if any configuration command fails during the rollback, from the menu bar, choose \textbf{Actions} > \textbf{Rollback > Restore Original Config on Error (Atomic)}.
  - If you want Cisco DCNM to ignore configuration errors during a rollback, from the menu bar, choose \textbf{Actions} > \textbf{Rollback > Skip Errors and Rollback (Best Effort)}.
  - If you want Cisco DCNM to stop the rollback at the first configuration error, from the menu bar, choose \textbf{Actions} > \textbf{Rollback > Stop Rollback at First Error}.

Cisco DCNM begins the rollback operation.

\textbf{RELATED TOPICS}

- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Viewing the Rollback History of a Device, page 25-16

\textbf{Viewing the Rollback History of a Device}

You can view the rollback history of a Cisco Nexus 7000 Series device.

\textbf{BEFORE YOU BEGIN}

A managed Cisco Nexus 7000 Series device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. Only licensed devices appear in the Version Browser.
Chapter 25 Working with Configuration Change Management

Working with the Version Browser

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Configuration Change Management > Version Browser. The Summary pane displays a table of devices.

Step 2 Click the device for which you want to view the rollback history. The Details pane displays archival information about the device, including a Rollback History section.

Step 3 (Optional) If necessary, double-click the Rollback History section to expand it. In the Rollback History section, a table of rollback history events appears. If no configuration rollbacks have occurred on the device, the table is empty.

RELATED TOPICS

- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11
- Performing a Configuration Rollback, page 25-15

Deleting All Archived Configurations for a Device

You can delete all the archived configuration versions of a device.

Note You cannot delete a specific version of an archived configuration.

BEFORE YOU BEGIN

Be certain that you do not want any of the archived configuration versions for the device. You cannot undo the deletion and the Cisco DCNM client does not confirm your choice to delete the archived configuration versions.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Configuration Change Management > Version Browser. The Summary pane displays a table of devices.

Step 2 Click the device that has archived configurations that you want to delete.

Step 3 Verify that you clicked the correct device.

Note The next step deletes the archived configuration versions without confirming your choice.

Step 4 From the menu bar, choose Actions > Delete All Versions.
The archived configurations for the selected device disappear from the Summary pane.

**RELATED TOPICS**

- Browsing and Commenting on Configuration Versions, page 25-8
- Archiving the Current Running Configuration of a Device, page 25-9
- Viewing an Archived Configuration Version, page 25-10
- Comparing Configuration Versions, page 25-11

**Configuring Archival Jobs**

The Archival Jobs feature allows you to control the automated archival of the running configuration on managed devices.

This section includes the following topics:

- Configuring an Archival Job, page 25-18
- Enabling and Disabling an Archival Job, page 25-20
- Deleting an Archival Job, page 25-20
- Viewing Details of an Archival Job, page 25-21
- Viewing the History of an Archival Job, page 25-21

**Configuring an Archival Job**

You can create an archival job or make changes to an existing archival job.

___

**Note**

By default, a new archival job is enabled.

**BEFORE YOU BEGIN**

A managed device must be on the list of Cisco DCNM-licensed devices before you can use it with Configuration Change Management. You can include only licensed devices in an archival job.

**DETAILED STEPS**

**Step 1**

From the Feature Selector pane, choose **Configuration Change Management > Archival Jobs**.

The Summary pane displays a table of archival jobs.

**Step 2**

Do one of the following:

- If you want to create an archival job, from the menu bar, choose **File > New Job**.
- If you want to make changes to an existing archival job, in the Summary pane, click the job that you want to change.

The Details pane shows the Details tab and Archival History tab for the job.
Step 3  (Optional) If necessary, in the Details pane, click the Details tab.

Step 4  (Optional) In the Comments field, enter your comments about the job.

Step 5  (Optional) If you want the job to archive configurations at a specific time, follow these steps:
   a. Click the Archive at Specified Time radio button.
   b. In the row of Days check boxes, check the check box for each day that you want the archival job to be active.
   c. Do one of the following:
      - If you want the job to archive configurations at a regular interval, click the Archive Interval radio button and use the adjacent box and list to specify the interval. You can specify an interval in minutes or hours. The maximum interval is either 59 minutes or 23 hours.
      - If you want the job to archive configurations once on each day that the job is active, click the Archive at radio button and use the adjacent box to specify the time that you want the job to start.

Step 6  (Optional) If you want the job to archive configurations at any time that Cisco DCNM detects a change to the configuration of a device included in the job, click the Archive whenever a Configuration Change is Detected radio button.

Step 7  (Optional) If you want to add one or more devices to the archival job, follow these steps:
   a. Under Device, right-click in a blank area and choose Add New Device.
      A dialog box shows available and selected devices.
   a. For each device that you want to add, under Available Devices, click the device and click Add.

   Tip  To add all devices to the job, click Add All.

   b. Click OK.

The devices that you added appear under Devices.

Step 8  (Optional) If you want to remove a device from an archival job, follow these steps:
   a. Under Devices, click the device that you want to remove from the job.
   b. Right-click the device and choose Remove Device.

The device that you removed no longer appears under Devices.

Step 9  From the menu bar, choose File > Deploy to save your changes to the Cisco DCNM server.

If you created an archival job, it is enabled by default. If you changed an existing archival job, whether it is enabled or disabled, the archival job information does not change.

RELATED TOPICS

- Enabling and Disabling an Archival Job, page 25-20
- Deleting an Archival Job, page 25-20
- Viewing Details of an Archival Job, page 25-21
- Viewing the History of an Archival Job, page 25-21
Enabling and Disabling an Archival Job

You can enable or disable any archival job.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Configuration Change Management > Archival Jobs. The Summary pane displays a table of archival jobs. In the Job ID column, enabled jobs show a green triangle and disabled jobs show a red square.

Step 2  In the Summary pane, click the archival job that you want to enable or disable.

Step 3  Do one of the following:

- To enable the job, from the menu bar, choose Actions > Enable. The icon in the Job ID column changes to show a green triangle.
- To disable the job, from the menu bar, choose Actions > Disable. The icon in the Job ID column changes to show a red square.

You do not need to save your changes.

RELATED TOPICS

- Configuring an Archival Job, page 25-18
- Deleting an Archival Job, page 25-20
- Viewing Details of an Archival Job, page 25-21
- Viewing the History of an Archival Job, page 25-21

Deleting an Archival Job

You can delete an archival job but not the Default archival job. When you delete an archival job, any devices included in the deleted job are automatically added to the Default archival job.

BEFORE YOU BEGIN

At least one custom archival job must exist in Cisco DCNM. You cannot delete the Default archival job.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Configuration Change Management > Archival Jobs. The Summary pane displays a table of archival jobs.

Step 2  In the Summary pane, click the archival job that you want to delete.

Step 3  From the menu bar, choose Actions > Delete. The archival job disappears from the Summary pane. Devices that were included in the deleted job are automatically added to the Default archival job.
You do not need to save your changes.

RELATED TOPICS

- Configuring an Archival Job, page 25-18
- Enabling and Disabling an Archival Job, page 25-20
- Viewing Details of an Archival Job, page 25-21
- Viewing the History of an Archival Job, page 25-21

Viewing Details of an Archival Job

You can view the details of an archival job, which include the job ID, the owner of the job, comments about the job, the job schedule, and the devices included in the job.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Archival Jobs.
The Summary pane displays a table of archival jobs.

Step 2
In the Summary pane, click the archival job that has details that you want to view.
The Details pane displays information about the archival job, including a Details tab.

Step 3
(Optional) If necessary, in the Details pane, click the Details tab.
The Details pane displays information and settings for the archival job that you selected.

RELATED TOPICS

- Configuring an Archival Job, page 25-18
- Enabling and Disabling an Archival Job, page 25-20
- Deleting an Archival Job, page 25-20
- Viewing the History of an Archival Job, page 25-21

Viewing the History of an Archival Job

You can view the history of an archival job.

BEFORE YOU BEGIN

The archival job must have occurred at least once; otherwise, there are no archival history entries to view.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Archival Jobs.
The Summary pane displays a table of archival jobs.

**Step 2** In the Summary pane, click the archival job that has archival history that you want to view.
The Details pane displays information about the archival job, including an Archival History tab.

**Step 3** In the Details pane, click the **Archival History** tab.
The Details pane displays a list of archival history entries, ordered by the date and time when the entry occurred.

**Step 4** (Optional) To see additional details about an archival history entry, in the Status column, click the plus symbol (+) to expand the entry.
The expanded entry lists information for each device included in the entry.

---

**RELATED TOPICS**
- Configuring an Archival Job, page 25-18
- Enabling and Disabling an Archival Job, page 25-20
- Deleting an Archival Job, page 25-20
- Viewing Details of an Archival Job, page 25-21

---

**Configuring Archival Settings**

The Archival Settings feature allows you to configure settings related to configuration change management, including the number of configuration versions that Cisco DCNM stores for each managed device, how many rollback and archival history entries Cisco DCNM stores for each managed device, and which file server Cisco DCNM uses during a configuration rollback.

This section includes the following topics:
- Configuring Version and History Settings, page 25-22
- Configuring the Rollback File Server Setting, page 25-23

---

**Configuring Version and History Settings**

You can configure the following settings about configuration versions and history:
- Maximum number of configuration versions that Cisco DCNM archives per managed device.
- Maximum number of rollback history and archival history status entries that Cisco DCNM retains per managed device.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **Configuration Change Management > Archival Settings**.
The Contents pane displays the Archival Settings fields.

**Step 2** (Optional) Enter a value from 0 to 50 in the **Maximum Version for a Device [0 - 50]** field to configure the maximum number of configuration versions that Cisco DCNM should archive for each managed device.
**Step 3** (Optional) Enter a value from 0 to 100 in the **Max Rollback and Archival History Status [0 - 100]** field to configure the maximum number of rollback history and archival history status entries that Cisco DCNM retains for each managed device.

**Step 4** From the menu bar, choose **File > Deploy** to save your changes to the Cisco DCNM server.

---

**RELATED TOPICS**

- Browsing and Commenting on Configuration Versions, page 25-8
- Configuring the Rollback File Server Setting, page 25-23

**Configuring the Rollback File Server Setting**

You can configure whether Cisco DCNM uses a specific file server during a configuration rollback or whether it uses any available file server that you have configured.

**BEFORE YOU BEGIN**

You must configure at least one file server in Cisco DCNM. For more information, see the “Adding a File Server” section on page 26-15.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **Configuration Change Management > Archival Settings**. The Contents pane displays the Archival Settings fields.

**Step 2** (Optional) If you want Cisco DCNM to use any available file server during a configuration rollback, under File Server for Configuration Rollback, click the **Any File Server** radio button.

**Step 3** (Optional) If you want to specify a file server that Cisco DCNM should use during a configuration rollback, follow these steps:

a. Under File Server for Configuration Rollback, click the **Use the following File Server** radio button.

b. From the File Server drop-down list, choose the file server.

**Step 4** From the menu bar, choose **File > Deploy** to save your changes to the Cisco DCNM server.

---

**Configuring Switch Profiles**

This section includes the following topics:

- Configuring a Switch Profile, page 25-24
- Configuring the Switch Profile Wizard Between Two vPCs, page 25-24
- Configuring the Switch Profile Wizard Between Two Switches, page 25-25
- Configuring the Sync Network View, page 25-25
- Configuring the Switch Profile Migration Wizard for Dual Homed FEXes, page 25-26
Configuring a Switch Profile

You can configure a switch profile using Cisco DCNM.

Note
This feature is supported only on Cisco Nexus 5000 Series switches.

BEFORE YOU BEGIN

You must create the switch profile with the same name on each switch and the switches must configure each other as a peer. When connectivity is established between switches with the same active switch profile, the switch profiles are synchronized.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Switch-Profile.
All Cisco Nexus 5000 Series switches that are managed by Cisco DCNM are displayed in the Summary pane.

Step 2
Expand the Cisco Nexus 5000 switches to view the switch-profile information.

Step 3
Choose a specific switch-profile for the Cisco Nexus 5000 Series switch. The profile details is displayed in the detailed pane.
You can choose one of the following four options:

- **Sync Status**—Displays the last session operation status on the switch profile.
- **Effective Configuration**—Displays the most effective switch-profile configurations on the switch.
- **Buffered Configuration**—Displays the non committed switch-profile configurations on the switch.
- **Events**—Displays any events that are specific to the switch-profile.

Configuring the Switch Profile Wizard Between Two vPCs

Note
This feature is supported only on the Cisco Nexus 5000 Series switches.

Switch profiles address the configuration conflicts between vPC peers in the network. By using Cisco DCNM, you can configure switch profiles between the vPC peers by selecting any one of the switches. Cisco DCNM configures the switch profiles on both the selected switch and its vPC peer switch with sync-peer IP addresses.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Configuration Change Management > Switch-Profile.
All Cisco Nexus 5000 Series switches that are managed by Cisco DCNM are displayed in the Summary pane.

Step 2
In the Summary pane, choose one of the vPC peer switches by right-clicking the vPC peer that you want.
Step 3  From the Context menu, click the New switch-profile with vPC peer tab.
Cisco DCNM checks if there is any vPC configuration available in the selected switch and if the vPC is active.
A dialog box appears if the vPC is active.

Step 4  Click Yes to create the switch profile.

Step 5  (Optional) Edit the switch-profile name, and click Ok to proceed with the configuration.

Note  If there is no active vPC in the selected switch, Cisco DCNM displays an error message and does not create the switch profile.

Configuring the Switch Profile Wizard Between Two Switches

Note  This feature is supported only on the Cisco Nexus 5000 Series switches.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Configuration Change Management > Switch-Profile.
All Cisco Nexus 5000 Series switches that are managed by Cisco DCNM are displayed in the Summary pane.

Step 2  From the Summary pane, choose one of the switches.

Step 3  From the Context menu, choose the New switch-profile with any other switch tab.
Cisco DCNM launches the switch profile configuration wizard.

Note  By default, the wizard displays the switch profile name and the source switch IP address. You can edit the preferred name and also choose the destination switch IP from the drop-down list.

Step 4  From the drop-down list, choose the destination switch IP address.
Step 5  Click Next.
The wizard configuration summary details appear.
Step 6  Click Finish to create the switch-profile configuration.

Configuring the Sync Network View

Note  This feature is supported only on the Cisco Nexus 5000 Series switches.
The switch-profile network view captures all the Cisco Nexus 5000 Series vPC peers in the network. If a switch profile already exists in the peers, the corresponding switch profile sync status information displays in the configuration sync network view.

If no switch profile exists between the vPC peers, Cisco DCNM provides an option that allows you to configure the switch profile between the peers. If there are any dual-homed Fabric Extenders (FEXs) between the vPC peers, you can import the FEX host interfaces (HIF) configurations inside the switch profile.

**DETAILED STEPS**

| Step 1 | From the Feature Selector pane, choose **Configuration Change Management > Switch-Profile**. All Cisco Nexus 5000 Series switches that are managed by Cisco DCNM are displayed in the Summary pane. |
| Step 2 | From the Summary pane, choose a switch by right-clicking the switch that you want. You can choose one of the following options:  
  - **Migration**—This option is displayed only if there is no switch profile between the vPC Peers. Choose this option to launch the migration wizard using Cisco DCNM.  
  - **Manage Switch profile**—Choose this option to go to the switch profile screen and choose the switch profile on the primary switch. |

**Configuring the Switch Profile Migration Wizard for Dual Homed FEXes**

- **Note** This feature is supported only on the Cisco Nexus 5000 Series switches.

You can launch the migration wizard using any one of the following options:

  - Migration Context menu
  - Migration link provided in the switch-profile Name column.

Both options are active only when no switch profile is configured on both vPC peers.

**DETAILED STEPS**

| Step 1 | From the Feature Selector pane, choose **Configuration Change Management > Switch-Profile**. All the vPCs in the Cisco Nexus 5000 Series switch peers that are managed by Cisco DCNM are displayed in the Summary pane. |
| Step 2 | From the Summary pane, choose a row. |
| Step 3 | Right-click the selected row. |
| Step 4 | Choose the **Migration** option. The Migration wizard appears with the vPC peers switches as primary and secondary with the default switch-profile name. |
| Step 5 | A dual selector option with the FEXes that are present in the primary vPC switch is displayed in the Migration wizard. |
If the FEXes are online, they are automatically selected for the host interfaces (HIF) import. Any pre-provisioned FEXes will not be automatically selected.

Step 6
Click Next.

Step 7
Click Finish.

The wizard creates a switch profile on both the vPC peer switches with appropriate sync-peer IP addresses and also import all the FEX-HIF ports into the switch profile.

RELATED TOPICS

- Performing a Configuration Rollback, page 25-15
- Configuring Version and History Settings, page 25-22

Field Descriptions for Configuration Change Management

This section includes the field descriptions for the three features available in the Feature Selector drawer for Configuration Change Management:

- Field Descriptions for the Version Browser, page 25-27
- Field Descriptions for Archival Jobs, page 25-29
- Field Descriptions for the Archival Settings Contents Pane, page 25-31
- Field Descriptions for the Switch Profiles Pane, page 25-31
- Field Descriptions for the Switch Profiles Network View Pane, page 25-31

Field Descriptions for the Version Browser

This section includes the following field descriptions for the Configuration Change Management feature:

- Device: Details: Archival Status Section, page 25-28
- Device: Details: Rollback History Section, page 25-28
- Device: Details: Archival History Section, page 25-28
- Version: Version Details Tab, page 25-28
- Version: Compare Tab, page 25-29
Field Descriptions for Configuration Change Management

Chapter 25    Working with Configuration Change Management

Device: Details: Archival Status Section

Table 25-3    Device: Details: Archival Status Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Display only. Whether the archival job that the device is assigned to is enabled or disabled.</td>
</tr>
<tr>
<td>Schedule</td>
<td>Display only. When the archival job that the device is assigned to is scheduled to occur.</td>
</tr>
<tr>
<td>Job ID</td>
<td>Display only. Identification number of the archival job that the device is assigned to.</td>
</tr>
</tbody>
</table>

Device: Details: Rollback History Section

Table 25-4    Device: Details: Rollback History Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Display only. Date and time that the rollback occurred.</td>
</tr>
<tr>
<td>Version</td>
<td>Display only. Configuration version that became the running configuration as a result of the rollback.</td>
</tr>
<tr>
<td>User</td>
<td>Display only. Username of the Cisco DCNM user who initiated the rollback.</td>
</tr>
<tr>
<td>Status</td>
<td>Display only. Whether the rollback succeeded or failed.</td>
</tr>
</tbody>
</table>

Device: Details: Archival History Section

Table 25-5    Device: Details: Archival History Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Stamp</td>
<td>Display only. Date and time that the archival event occurred.</td>
</tr>
<tr>
<td>Job Id</td>
<td>Display only. Identification number of the archival job that created the archival event.</td>
</tr>
<tr>
<td>Status</td>
<td>Display only. Whether the archival event succeeded, failed, or was skipped.</td>
</tr>
<tr>
<td>Reason</td>
<td>Display only. Cause of a skipped or failed archival event.</td>
</tr>
</tbody>
</table>

Version: Version Details Tab

Table 25-6    Version: Version Details Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Config Version ID</td>
<td>Display only. Version identification number for the archived configuration version. Each archived configuration for a device receives a unique version ID.</td>
</tr>
<tr>
<td>Creation Time</td>
<td>Display only. Date and time that an archival job created the configuration version.</td>
</tr>
</tbody>
</table>
### Field Descriptions for Archival Jobs

This section includes the following field descriptions for the Archival Jobs feature:

- Archival Job: Details Tab, page 25-29
- Archival Job: Archival History Tab, page 25-30

#### Archival Job: Details Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Job ID</td>
<td><em>Display only.</em> Identification number of the archival job.</td>
</tr>
<tr>
<td>Owner</td>
<td><em>Display only.</em> Username of the Cisco DCNM user who created the archival job.</td>
</tr>
<tr>
<td>Comments</td>
<td>Text entered by Cisco DCNM users.</td>
</tr>
</tbody>
</table>
Table 25-8  Archival Job: Details Tab (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td></td>
</tr>
<tr>
<td>Enable Archival</td>
<td>Whether the archival job is enabled. By default, this check box is unchecked.</td>
</tr>
<tr>
<td>Archive at Specified Time</td>
<td>Archival job that occurs at the time specified by the Days and Archival Interval or Archive at fields.</td>
</tr>
<tr>
<td>Days</td>
<td>Days of the week that the archival job occurs. By default, the All check box is checked, which makes the individual day check boxes unavailable.</td>
</tr>
<tr>
<td>Archive Interval</td>
<td>Archival job that occurs at a regular interval, specified by the interval value box and the unit drop-down list, to the right of this radio button.</td>
</tr>
<tr>
<td>Archive at</td>
<td>Archival job that occurs once on each active day at the time specified in the box to the right of this radio button.</td>
</tr>
<tr>
<td>Archive whenever a Configuration Change is Detected</td>
<td>Archival job that occurs when Cisco DCNM detects that the running configuration of a device has changed.</td>
</tr>
<tr>
<td>Devices</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Name of devices that are assigned to the archival job.</td>
</tr>
<tr>
<td>IP Address</td>
<td>IP address that Cisco DCNM uses to connect to the device.</td>
</tr>
</tbody>
</table>

Archival Job: Archival History Tab

Table 25-9  Installation Job: Details: General Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Display only. Date and time that the archival job ran.</td>
</tr>
<tr>
<td>Status</td>
<td>Display only. Number of devices in the job for which the archival job run succeeded, failed, or was skipped. The numbers are shown after each status, in parentheses.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Display only. Name of a device assigned to the job. This field is shown when you expand the status of an archival history entry.</td>
</tr>
<tr>
<td>IP Address</td>
<td>Display only. IP address that Cisco DCNM used to attempt to connect to the device. This field is shown when you expand the status of an archival history entry.</td>
</tr>
<tr>
<td>Status (per Device)</td>
<td>Display only. Whether the archival job run succeeded, failed, or was skipped for the device.</td>
</tr>
<tr>
<td>Reason</td>
<td>Display only. Explanation for the status. For example, if the device was skipped because the running configuration had not changed since the previous archival job run, the following text appears in the Reason field: Archival skipped as there are no changes from the previous version</td>
</tr>
</tbody>
</table>
Field Descriptions for the Archival Settings Contents Pane

Table 25-10 Archival Settings Contents Pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Versions for a Device</td>
<td>Largest number of archived configuration versions that Cisco DCNM retains for each device included in an archival job. Valid values are from 0 to 50, where 50 is the default value.</td>
</tr>
<tr>
<td>Max Rollback and Archival History Status</td>
<td>Largest number of rollback history and archival history status entries Cisco DCNM retains for each device.</td>
</tr>
<tr>
<td>File Server for Configuration Rollback</td>
<td></td>
</tr>
<tr>
<td>Any File Server</td>
<td>File server that Cisco DCNM selects to upload configurations to during a configuration rollback. Any file server that you have configured in Cisco DCNM may be used.</td>
</tr>
<tr>
<td>Use the following File Server</td>
<td>File server that Cisco DCNM uploads configurations to during a configuration rollback to the File Server drop-down list.</td>
</tr>
<tr>
<td>File Server</td>
<td>IP address or DNS name of the file server that Cisco DCNM uploads configurations to during a rollback. This field is available only when you select the Use the following File Server radio button.</td>
</tr>
</tbody>
</table>

Field Descriptions for the Switch Profiles Pane

Table 25-11 Switch Profiles Pane

Table 0-1

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the switch-profile.</td>
</tr>
<tr>
<td>Revision ID</td>
<td>Current revision number of the switch profile.</td>
</tr>
<tr>
<td>Peer IP Address</td>
<td>IP address of the peer switch for the selected profile.</td>
</tr>
<tr>
<td>Last Session Time</td>
<td>Start time of the last configuration session.</td>
</tr>
<tr>
<td>Last Session Status</td>
<td>Status of the last session action that was performed.</td>
</tr>
<tr>
<td>Sync Status</td>
<td>Overall sync status of that profile with the peer.</td>
</tr>
</tbody>
</table>

Field Descriptions for the Switch Profiles Network View Pane

Table 25-12 Switch Profiles Network View Pane

Table 0-2

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vPC</td>
<td>Hostname of the vPC primary and secondary switch.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the switch profile.</td>
</tr>
</tbody>
</table>
Table 25-2

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revision ID</td>
<td>Current revision number of the switch profile.</td>
</tr>
<tr>
<td>Overall Sync Status</td>
<td>Switch profile status on the primary vPC switch.</td>
</tr>
<tr>
<td>Last Session Time</td>
<td>Start time of the last configuration session.</td>
</tr>
<tr>
<td>Last Session Status</td>
<td>Status of the last session action that was performed.</td>
</tr>
</tbody>
</table>

Additional References

For additional information related to configuration change management, see the following sections:

- Related Documents, page 25-32
- Standards, page 25-32

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>File servers in Cisco DCNM</td>
<td>File Servers, page 26-3</td>
</tr>
<tr>
<td>Configuration rollbacks in Cisco NX-OS</td>
<td>Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 5.x</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

Feature History for Configuration Change Management

Table 25-13 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration Change Management</td>
<td>5.2(1)</td>
<td>Support was added to the Cisco Nexus 3000 Series switches (except the Switch Profile feature).</td>
</tr>
</tbody>
</table>
### Table 25-13 Feature History for Configuration Change Management (continued)

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration Change Management</td>
<td>5.1(1)</td>
<td>You can use the Copy Run to Start feature to copy the running configuration to the startup configuration.</td>
</tr>
<tr>
<td>Configuration Change Management</td>
<td>5.0(2)</td>
<td>Support was extended to all managed Cisco Nexus Series switches.</td>
</tr>
</tbody>
</table>
Managing Device Operating Systems

This chapter describes how to use the Device OS Management feature in Cisco Data Center Network Manager (DCNM).

The Device OS Management feature allows you to control the operating system installed on Nexus 7000 Series devices that are managed by DCNM. You can create software installation jobs that affect one or more managed devices. DCNM can transfer the software images of operating systems to managed devices using one of several supported protocols. Installation jobs can also use software images already present on managed devices.

This chapter includes the following sections:
- Information About Device OS Management, page 26-1
- Licensing Requirements for Device OS Management, page 26-3
- Prerequisites, page 26-4
- Guidelines and Limitations for Device OS Management, page 26-4
- Platform Support, page 26-4
- Using the Device OS Management Window, page 26-5
- Configuring Software Installation Jobs, page 26-7
- Configuring File Servers, page 26-15
- Field Descriptions for Device OS Management, page 26-18
- Additional References, page 26-20
- Feature History for Device OS Management, page 26-21

Information About Device OS Management

The Device OS Management feature allows you to control the software images installed on certain devices that are managed by Cisco DCNM.

This section includes the following topics:
- Device OS Management Screen, page 26-2
- Software Installation Jobs, page 26-2
- File Servers, page 26-3
- VDC Support, page 26-3
Device OS Management Screen

The Device OS Management screen allows you to view information about the software images used by a managed device. You can also start the Software Installation wizard from the Device OS Management Summary pane.

Software Installation Jobs

The Software Installation Jobs feature allows you to create and monitor software installation jobs. Cisco DCNM provides the Software Installation wizard, which you use to specify all the necessary information for configuring a software installation job.

You can create software installation jobs that affect one or more managed devices. You can use software images that are already in the local file system of the devices or Cisco DCNM can instruct each managed device included in a job to transfer software images to the local file system on the managed device. Your options are as follows:

- **Device file system**—You can use software images that are in the local file system of the devices. You must ensure that the images exist on the devices prior to configuring the installation job.

  You can specify a software image for a device type category rather than for a single device; however, the image that you specify must exist on each device in the category in the same location and with the same filename. For example, if you specify bootflash:/images/n7000-s1-dk9.4.1.2.upg.bin, the n7000-s1-dk9.4.1.2.upg.bin image file must exist in bootflash:/images on each device in the device category.

- **File server**—You can use a file server that you have configured in Cisco DCNM. If you use a file server, Cisco DCNM uses the information that you provide when you configure the file server and when you configure the software installation job to assemble a URL that the managed devices in the job can use to retrieve the software images.

  Before configuring a software installation job, you should ensure that the software images are on the file server. You must also configure the file server in Cisco DCNM. For more information, see the “File Servers” section on page 26-3.

- **URL**—You can use a URL to specify the image files. The verification that Cisco DCNM performs for a URL varies depending upon the transfer protocol that you use, as follows:

  - **FTP**—Cisco DCNM verifies the URL format, that the FTP server in the URL is reachable, and that the specified image file exists on the FTP server. The FTP URL format is as follows:
    
    ftp://username@servername/path/filename

  - **SFTP**—Cisco DCNM verifies the URL format, that the SFTP server in the URL is reachable, and that the image file specified exists on the SFTP server. The SFTP URL format is as follows:

    sftp://username@servername/path/filename

  - **TFTP**—You must ensure that the path and image filename are correct. Cisco DCNM verifies the URL format and that the TFTP server in the URL is reachable. The TFTP URL format is as follows:

    tftp://servername/path/filename

  - **SCP**—You must ensure that the SCP server is reachable and that the path and image filename are correct. Cisco DCNM verifies the URL format. The SCP URL format is as follows:

    scp://username@servername/path/filename
The Software Installation wizard includes an optional step for verifying the version compatibility of software images with the managed devices. During this step, if a software image was specified by a URL or file server, Cisco DCNM instructs managed devices to copy the software image from the URL or file server to the bootflash file system on the device. If you skip the version compatibility step, Cisco DCNM does not instruct devices to copy software images from URLs or file servers until the installation job begins.

### File Servers

The File Servers feature allows you to configure file servers, which you can use for the following purposes:

- **Software installation jobs**—Cisco DCNM can get software image files from a file server and transfer them to devices included in a software installation job.
- **Configuration rollbacks**—Cisco DCNM can back up device configurations to a file server when you roll back a device configuration.

Cisco DCNM supports file servers that use the following protocols:

- FTP
- SFTP
- TFTP

If you use a file server in a software installation job, consider the following items:

- The managed devices included in the job must be able to connect to the file server directly.
- To ensure that software image files transfer as quickly as possible, use a file server that is on the same LAN as the devices included in the software installation job. If the available file servers transfer software image files too slowly, before you create the software installation job, manually copy the files to the devices that you will include in the job and configure the job to use the manually copied files rather than a file server.

### VDC Support

Device software images apply to physical devices rather than virtual device contexts (VDCs). When you change the software image on a managed device, all VDCs on the device use the new software image.

### Licensing Requirements for Device OS Management

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM</td>
<td>Device OS Management requires a LAN Enterprise license. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 6.x</em>.</td>
</tr>
<tr>
<td>Cisco NX-OS</td>
<td>Device OS Management requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For an explanation of the Cisco NX-OS licensing scheme for your platform, see the licensing guide for your platform.</td>
</tr>
</tbody>
</table>
Prerequisites

The Device OS Management feature has the following prerequisites (for a full list of feature-specific prerequisites, see the platform-specific documentation):

- The Device OS Management feature supports only devices that are managed by Cisco DCNM, which means that Cisco DCNM must have successfully discovered the device.
- The Device OS Management feature supports only devices that you have added to the list of Cisco DCNM-licensed devices.
- Devices included in a software installation job must be reachable by Cisco DCNM when a software installation job occurs. Software installation jobs fail for unreachable devices.

Guidelines and Limitations for Device OS Management

The Device OS Management feature has the following configuration guidelines and limitations:

- URLs and file servers used in a software installation job must be reachable by the managed devices included in the job.
- If you use a DNS name in a URL or when you configure a file server, ensure that managed devices using the URL or file server can resolve the DNS name.
- Software installation jobs do not reload connectivity management processors (CMPs). You must manually reload CMPs as needed when a software installation job completes. The status for a completed software installation job includes messages about CMPs that must be reloaded manually. For more information, see the Cisco Nexus 7000 Series NX-OS Software Upgrade and Downgrade Guide, Release 5.x.
- For Cisco Nexus 7000 series devices that have a single supervisor module, a software installation job does not reload the device. After the installation job completes, to run the newly installed software image on a single-supervisor Cisco Nexus 7000 series device, you must manually reload the device. For more information, see the Cisco Nexus 7000 Series NX-OS Software Upgrade and Downgrade Guide, Release 5.x.

Platform Support

The following platforms support this feature but may implement it differently. For platform-specific information, including guidelines and limitations, system defaults, and configuration limits, see the corresponding documentation.

<table>
<thead>
<tr>
<th>Platform</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Nexus 4000 Series switches</td>
<td>Cisco Nexus 4000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 5000 Series switches</td>
<td>Cisco Nexus 5000 Series Switch Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 7000 Series switches</td>
<td>Cisco Nexus 7000 Series Switch Documentation</td>
</tr>
</tbody>
</table>
Using the Device OS Management Window

The Device OS Management window allows you to view information about the software images used by a managed device. You can also start the Software Installation Wizard from the Device OS Management Summary pane.

This section includes the following topics:
- Viewing Device Image Details, page 26-5
- Installing Software on a Device, page 26-5

Viewing Device Image Details

You can view details about the software image on a managed device.

DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose Device OS Management.

A table of managed devices appears in the Summary pane. Each row displays software image information about a device. Devices are listed alphabetically.

**Step 2**
Click the device for which you want to see software image details.

The Details pane displays two sections of information. In addition to displaying the information also shown in the Summary pane, if an installation job is scheduled, the System section displays a message about any scheduled installation job, including a link to the installation job.

The Software Installation Jobs section displays information about future, ongoing, and past installation jobs.

*Tip* To expand or collapse the System or the Software Installation Jobs sections, double-click the section title.

**Step 3**
(Optional) To open a scheduled software installation job, in the System section, click the link to the installation job.

The Feature Selector pane changes to the Software Installation Jobs feature. For more information, see the “Viewing Software Installation Job Details” section on page 26-7.

RELATED TOPICS
- Installing Software on a Device, page 26-5

Installing Software on a Device

You can install software on a device listed on the Device OS Management Summary pane. Installing software from the Device OS Management Summary pane starts the Software Installation wizard, which allows you to create or modify a software installation job.
BEFORE YOU BEGIN

Ensure that the software images that you want to install are available by one of the options that the Software Installation wizard supports. For more information, see the “Software Installation Jobs” section on page 26-2. The supported options are the following:

- **File server**—If you want to use a file server, ensure that the software images are available on the server. You must also configure the file server in DCNM. For more information, see the “Adding a File Server” section on page 26-15.

- **Device file system**—If you want to use software images that are in the local file system of the devices, you must ensure that the images exist on the devices prior to configuring the installation job.

You can specify a software image for a device type category rather than for a single device; however, the image that you specify must exist on each device in the category in the same location and with the same filename. For example, if you specify bootflash:/images/n7000-s1-dk9.4.1.2.upg.bin, the n7000-s1-dk9.4.1.2.upg.bin image file must exist in bootflash:/images on each device in the device category.

- **URL**—If you want to use a URL to specify the image files, what DCNM verifies for you and what you need to ensure vary depending upon the transfer protocol that you use, as follows:
  - **FTP**—DCNM verifies the URL format, that the FTP server in the URL is reachable, and that the specified image file exists on the FTP server. The FTP URL format is as follows:
    
    ftp://username@servername/path/filename
  
  - **SFTP**—DCNM verifies the URL format, that the SFTP server in the URL is reachable, and that the image file specified exists on the SFTP server. The SFTP URL format is as follows:
    
    sftp://username@servername/path/filename
  
  - **TFTP**—You must ensure that the path and image filename are correct. DCNM verifies the URL format and that the TFTP server in the URL is reachable. The TFTP URL format is as follows:
    
    tftp://servername/path/filename
  
  - **SCP**—You must ensure that the SCP server is reachable and that the path and image filename are correct. DCNM verifies the URL format. The SCP URL format is as follows:
    
    scp://username@servername/path/filename

DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose **Device OS Management > Device OS Management**.

A table of managed devices appears in the Summary pane.

**Step 2**
Click a device that you want to include in a new software installation job.

**Step 3**
From the menu bar, choose Actions > Install Software.

The Software Installation wizard dialog box displays the Select Switches step. The device that you selected is listed under Selected Switches.

**Step 4**
To use the wizard, see the “Using the Software Installation Wizard” section on page 26-9.

RELATED TOPICS

- Viewing Device Image Details, page 26-5
Configuring Software Installation Jobs

The Software Installation Jobs feature allows you to create and monitor software installation jobs. This section includes the following topics:

- Viewing Software Installation Job Details, page 26-7
- Creating or Editing a Software Installation Job, page 26-8
- Using the Software Installation Wizard, page 26-9
- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
- Adding or Changing Comments for a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14

Viewing Software Installation Job Details

You can view the details of a software installation job, including its status.

BEFORE YOU BEGIN

You must have configured a software installation job before you can view its details.

DETAILED STEPS

Step 1
From the Feature Selector pane, choose Device OS Management > Software Installation Jobs. The Summary pane displays a table of software installation jobs.

Step 2
Click the software installation job for which you want to view details. The Details pane displays two sections of information. The General section displays the job ID, the job owner, scheduling information, comments, and installation options. The Device and Software Images section displays a table of devices included in the job, the software images to be installed on each device, and the status of the installation for the device.

Tip
To expand or collapse the General or the Device and Software Images sections, double-click the section title.

RELATED TOPICS

- Viewing Device Image Details, page 26-5
- Creating or Editing a Software Installation Job, page 26-8
Configuring Software Installation Jobs

- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
- Adding or Changing Comments for a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14

Creating or Editing a Software Installation Job

From the Software Installation Jobs content pane, you can create a software installation job or edit an existing job. Creating or editing a job from the Software Installation Jobs content pane starts the Software Installation wizard, which allows you to create or modify a job.

BEFORE YOU BEGIN

Ensure that the software images that you want to install are available by one of the options that the Software Installation wizard supports. For more information, see the “Software Installation Jobs” section on page 26-2. The supported options are the following:

To ensure that software image files transfer as quickly as possible, use a file server that is on the same LAN as the devices included in the software installation job. If the available file servers transfer software image files too slowly, before you create the software installation job, manually copy the files to the devices that you will include in the job and configure the job to use the manually copied files rather than a file server.

- File server—If you want to use a file server, ensure that the software images are available on the server. You must also configure the file server in DCNM. For more information, see the “Adding a File Server” section on page 26-15.
- Device file system—If you want to use software images that are in the local file system of the devices, you must ensure that the images exist on the devices prior to configuring the installation job.

You can specify a software image for a device type category rather than for a single device; however, the image that you specify must exist on each device in the category in the same location and with the same filename. For example, if you specify bootflash:/images/n7000-s1-dk9.4.1.2.upg.bin, the n7000-s1-dk9.4.1.2.upg.bin image file must exist in bootflash:/images on each device in the device category.

- URL—If you want to use a URL to specify the image files, what DCNM verifies for you and what you need to ensure vary depending upon the transfer protocol that you use, as follows:
  - FTP—DCNM verifies the URL format, that the FTP server in the URL is reachable, and that the specified image file exists on the FTP server. The FTP URL format is as follows:
    ftp://username@servername/path/filename
  - SFTP—DCNM verifies the URL format, that the SFTP server in the URL is reachable, and that the image file specified exists on the SFTP server. The SFTP URL format is as follows:
    sftp://username@servername/path/filename
  - TFTP—You must ensure that the path and image filename are correct. DCNM verifies the URL format and that the TFTP server in the URL is reachable. The TFTP URL format is as follows:
    tftp://servername/path/filename
  - SCP—You must ensure that the SCP server is reachable and that the path and image filename are correct. DCNM verifies the URL format. The SCP URL format is as follows:
### DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose **Device OS Management > Software Installation Jobs**.
The Summary pane displays a table of software installation jobs.

**Step 2**
Do one of the following:
- If you want to create a job, from the menu bar, choose **Actions > New**.
- If you want to edit a job, in the Summary pane, click the job, and then, from the menu bar, choose **Actions > Edit**.

The Software Installation wizard dialog box displays the Select Switches step.

**Step 3**
To use the wizard, see the “Using the Software Installation Wizard” section on page 26-9.

### RELATED TOPICS

- Using the Software Installation Wizard, page 26-9
- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
- Adding or Changing Comments for a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14
- Adding a File Server, page 26-15

### Using the Software Installation Wizard

You can use the Software Installation wizard to configure a new software installation job or make changes to an existing software installation job.

### BEFORE YOU BEGIN

Start the Software Installation wizard, from one of the following places:
- Device OS Management—See the “Installing Software on a Device” section on page 26-5.
- Software Installation Jobs—See the “Creating or Editing a Software Installation Job” section on page 26-8.

### DETAILED STEPS

**Step 1**
In the Software Installation wizard dialog box, follow these steps for each device that you want to include in the installation job:

- **Under Available Switches**, click the device.
- **Click Add.**

scp://username@servername/path/filename
Step 2  Click Next.

The Software Installation wizard dialog box displays the Specify Software Images step. Devices are categorized by the physical device type. You can specify software images for each device individually or for an entire category of devices of the same physical type.

Step 3  For each device or physical device category, specify a kickstart image and a system image. To do so, follow these steps once for the Kickstart Image field and again for the System Image field:

a.  In the applicable image field, click to activate the field and then click the more button.

The Software Image Browser dialog box appears.

b.  Specify the location of the file for the software image to be installed. To do so, choose one of the following options:

- **File Server**—If you choose this option, you must pick a file server from the Repository list, navigate to the folders on the file server, and select the software image file.

- **Switch File System**—If you choose this option, you must navigate to the file system on a device and select the software image file.

  If you are specifying a software image for a device type category, the image specified must exist on each device in the category in the same location and with the same filename.

- **URL**—If you choose this option, enter the URL in the URL field. If the transfer protocol that you use includes a username in the URL, in the Password field type the password for the username in the URL.

c.  Click OK.

If you specified a URL, Cisco DCNM verifies the URL.

The Software Image Browser dialog box closes. The applicable image field displays the software image that you chose.

Step 4  (Optional) If you do not want the Software Installation wizard to verify that the selected kickstart and system software images are compatible with a device, check the Skip Version Compatibility check box in the row of the device.

Tip  The Next button remains unavailable until you have specified a kickstart image and a system image for each device included in the software installation job.

Step 5  Click Next.

If you specified a URL or a software image repository for the location of software images, Cisco DCNM instructs the devices in the job to retrieve the images from the specified locations.

If any device does not have enough space in its local file system to receive the software image files, a dialog box provides you the option to free up space on the device.

Step 6  If you receive a warning about insufficient space on the device, do one of the following:

- If you want to delete files from devices, click Yes. Use the Delete Files dialog box to explore the local file system of devices and delete unwanted files. When you are done, click OK and then click Next.

- If you want to remove the device from the job, click No, click Back, and return to Step 3.
If you want to exit the Software Installation wizard, click **No** and then click **Cancel**.

Unless you chose to skip the version compatibility check for every device in the installation job, the Software Installation wizard dialog box displays the Pre-installation Checks step. The Version Compatibility Check column indicates whether a device passed or failed the check.

**Step 7**  If the Software Install wizard dialog box displays the Pre-installation Checks step, follow these steps:

a. If any device failed the version compatibility check, do one of the following:
   - If you want to change the software image files specified for a device, click **Back** and return to **Step 3**.
   - If you want the job to proceed by not installing software on devices that failed the version compatibility check, check the **Skip devices with version compatibility failure** check box.

b. Click **Next**.

The Software Installation wizard dialog box displays the Installation Options and Schedule step.

**Step 8**  (Optional) If you want the job to save the current configuration or delete the current configuration on each device, follow these steps:

a. Check the **Installation Options** check box.

b. If you want the job to copy the running configuration to the startup configuration on each device, click the **Save Running Configuration to Startup before Installation** radio button. After the installation job, devices in the job will have the same configuration that they did prior to the job, unless the installation is an upgrade or downgrade that modifies the running configuration.

c. If you want the job to delete the startup configuration on each device, click the **Erase Startup Configuration before Installation** radio button. After the installation job completes, devices in the job will have only the default running configuration.

**Step 9**  Under Schedule, do one of the following:

- If you want the software installation job to start immediately after you complete the wizard, click the **Install Now** radio button.

- If you want to specify a date and time for the start of the software installation job, click the **Schedule Installation** radio button and then use the **Date and Time** field to specify when the job should begin.

**Step 10**  (Optional) In the Comments field, enter a comment about the installation job.

**Step 11**  Under Execution Mode, do one of the following:

- If you want the installation job to run on one device at a time before it begins on the next device included in the job, click the **Sequential** radio button.

- If you want the installation job to start at the same time on all the devices included in the job, click the **Concurrent** radio button.

**Step 12**  (Optional) If you want the software installation job to save the log data for failed installations, check the **Archive logs from switches on DCNM server upon installation failure** check box.

**Step 13**  Click **Finish**.

If you specified a date and time for the job under Schedule, the wizard closes and the job appears in the Summary pane.

If you clicked the Install Now radio button under Schedule, the Software Installation Status dialog box displays information about each device in the job and the job status.

**Step 14**  If the Software Installation Status dialog box appears, do one of the following:

- If you want to close the dialog box and allow the job to run, click **Run in Background**.
If you want to abort software installation on one or more devices, for each device, click the device and click **Abort Selected**.

If you want to abort software installation for all devices, click **Abort All**.

**Tip** If you abort software installation on all devices, click **Close** to close the dialog box.

**RELATED TOPICS**

- Installing Software on a Device, page 26-5
- Creating or Editing a Software Installation Job, page 26-8
- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
- Adding or Changing Comments for a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14

**Rescheduling a Software Installation Job**

You can change the scheduled date and time of a software installation job.

**BEFORE YOU BEGIN**

The software installation job that you want to reschedule must have a status of Scheduled. You cannot reschedule aborted or completed jobs.

**DETAILED STEPS**

1. From the Feature Selector pane, choose **Device OS Management > Software Installation Jobs**. The Summary pane displays a table of software installation jobs.
2. In the Summary pane, click the job that you want to reschedule. The Details pane displays information about the job.
3. (Optional) From the Details tab, expand the **General** section, if necessary.
4. Use the **Scheduled At** field to specify when the job should begin.
5. From the menu bar, choose **File > Deploy** to save the change to the job schedule.

**RELATED TOPICS**

- Viewing Software Installation Job Details, page 26-7
- Creating or Editing a Software Installation Job, page 26-8
- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
Deleting a Software Installation Job

You can delete a software installation job, regardless of its state. In the Summary pane for Software Installation Jobs, completed and aborted jobs remain until you delete them.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Device OS Management > Software Installation Jobs. The Summary pane displays a table of software installation jobs.

Step 2 In the Summary pane, click the job that you want to delete. The Details pane displays information about the job.

Step 3 From the menu bar, choose Actions > Delete. A Warning dialog box displays a confirmation message.

Step 4 Click Yes. The job is removed from the summary pane. You do not need to save your changes.

RELATED TOPICS

- Viewing Software Installation Job Details, page 26-7
- Creating or Editing a Software Installation Job, page 26-8
- Rescheduling a Software Installation Job, page 26-12
- Adding or Changing Comments for a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14

Adding or Changing Comments for a Software Installation Job

You can add or change the comments associated with a software installation job.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Device OS Management > Software Installation Jobs. The Summary pane displays a table of software installation jobs.

Step 2 In the Summary pane, click the job for which you want to add or change comments. The Details pane displays information about the job.

Step 3 (Optional) From the Details tab, expand the General section, if necessary.

Step 4 In the Comments field, enter your comments.
## Configuring Software Installation Jobs

### Step 5
From the menu bar, choose **File > Deploy** to save the change to the job schedule.

## RELATED TOPICS
- Viewing Software Installation Job Details, page 26-7
- Creating or Editing a Software Installation Job, page 26-8
- Rescheduling a Software Installation Job, page 26-12
- Deleting a Software Installation Job, page 26-13
- Changing Installation Options for a Software Installation Job, page 26-14

## Changing Installation Options for a Software Installation Job

You can change the installation options associated with a software installation job. Installation options allow you to specify whether Cisco DCNM should save the running configuration of devices, delete the startup configuration, or take no action on the configuration of devices prior to installing the software.

### DETAILED STEPS

#### Step 1
From the Feature Selector pane, choose **Device OS Management > Software Installation Jobs**. The Summary pane displays a table of software installation jobs.

#### Step 2
In the Summary pane, click the job for which you want to add or change comments. The Details pane displays information about the job.

#### Step 3
(Optional) From the Details tab, expand the **General** section, if necessary.

#### Step 4
If you want devices in the software installation job to have only the default device configuration after the installation job completes, follow these steps:

- a. Check the **Installation Options** check box.
- b. If you want the job to delete the startup configuration on each device, click the **Erase Startup Configuration before Installation** radio button.

#### Step 5
If you want devices in the software installation job to have the same running configuration after the installation job completes, follow these steps:

- a. Check the **Installation Options** check box.
- b. If you want the job to copy the running configuration to the startup configuration on each device, click the **Save Running Configuration to Startup before Installation** radio button.

#### Step 6
If you want the devices in the software installation job to use their current startup configuration as their running configuration after the software installation job completes, uncheck the **Installation Options** check box.

#### Step 7
From the menu bar, choose **File > Deploy** to save the change to the job schedule.

## RELATED TOPICS
- Viewing Software Installation Job Details, page 26-7
Configuring File Servers

The File Servers feature allows you to configure file servers, which you can use for the following purposes:

- Software installation jobs—DCNM can get software image files from a file server and transfer them to devices included in a software installation job.
- Configuration rollbacks—DCNM can back up device configurations to a file server when you roll back a device configuration.

This section includes the following topics:

- Adding a File Server, page 26-15
- Changing a File Server, page 26-16
- Deleting a File Server, page 26-17

Adding a File Server

You can add a file server to Cisco DCNM.

BEFORE YOU BEGIN

Gather the following information about the file server:

- Server IP address or hostname

Note

If you use the hostname, it must be registered with the DNS server that the Cisco DCNM server is configured to use.

- Transfer protocol that the server provides. Cisco DCNM supports the following transfer protocols:
  - FTP
  - SFTP
  - TFTP
- Username and password that Cisco DCNM should use to access the server.
- The base directory on the server. All files and directories that Cisco DCNM needs to access must be available under this directory.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose Device OS Management > File Servers.

The Contents pane displays a table of file servers.
Configuring File Servers

Step 2 From the menu bar, choose Actions > New File Server.
A new row appears in the Contents pane, with the cursor in the Server Name/IP Address field.

Step 3 In the Server Name/IP Address field, enter the IP address or hostname of the file server.

Step 4 Double-click the Protocol field and choose the protocol from the list that appears. Supported protocols are as follows:
- FTP
- SFTP
- TFTP

Step 5 If the file server requires authentication, double-click the User Credentials field and enter the username and password for the server. If you want Cisco DCNM to remember the password, check the Save Password check box.

Step 6 Double-click the Base Directory field.
The Software Image Browser dialog box appears.

Step 7 Explore the server file system and choose the directory that Cisco DCNM should use as the base directory. All files and directories that Cisco DCNM needs to access must be located under this directory. By default, the root directory of the server is the base directory.

Step 8 (Optional) Double-click the Comment field and enter your comments.

Step 9 From the menu bar, choose File > Deploy to save the change to the job schedule.

RELATED TOPICS
- Changing a File Server, page 26-16
- Deleting a File Server, page 26-17

Changing a File Server

You can change the user credentials, base directory, and comments of a file server.

Note You cannot change the values in the Server Name/IP Address or Protocol fields. If you need to change these values, delete the file server and create a file server with the new values.

BEFORE YOU BEGIN
If you are changing the user credentials or base directory, determine what the new user credentials or base directory should be.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Device OS Management > File Servers.
The Contents pane displays a table of file servers.

Step 2 In the table, locate the row for the file server that you want to change.
Step 3 Perform the following items to change the file server entry as needed:

- If you want to change the user credentials, double-click the User Credentials field for the file server and enter or clear the username and password for the server. If you want Cisco DCNM to remember the password, check the Save Password check box.

- If you want to change the base directory, double-click the Base Directory field and use the Software Image Browser dialog box to choose the directory that Cisco DCNM should use as the base directory.

- If you want to change the comments, double-click the Comments field and enter your comments.

Step 4 From the menu bar, choose File > Deploy to save the file server changes.

RELATED TOPICS

- Adding a File Server, page 26-15
- Deleting a File Server, page 26-17

Deleting a File Server

You can delete a file server.

BEFORE YOU BEGIN

Ensure that the file server is specified in the Archival Settings feature as the file server for configuration rollback. For more information, see the “Configuring the Rollback File Server Setting” section on page 25-23.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Device OS Management > File Servers.

The Contents pane displays a table of file servers.

Step 2 In the table, click the row for the file server that you want to delete.

Step 3 From the menu bar, choose Actions > Delete.

Note If the file server is specified in the Archival Settings feature as the file server for a configuration rollback, a dialog box informs you that the file server cannot be deleted. For more information, see the “Configuring the Rollback File Server Setting” section on page 25-23.

The file server is removed from the summary pane. You do not need to save your changes.

RELATED TOPICS

- Adding a File Server, page 26-15
- Changing a File Server, page 26-16
Field Descriptions for Device OS Management

This section includes field descriptions for the three features available in the Feature Selector drawer for Device OS Management:

- Field Descriptions for Device OS Management, page 26-18
- Field Descriptions for Software Installation Jobs, page 26-19
- Field Descriptions for the File Servers Contents Pane, page 26-20

Field Descriptions for Device OS Management

This section includes the following field descriptions for the Device OS Management feature:

- Device: Details: System Section, page 26-18
- Device: Details: Software Installation Jobs Section, page 26-18

Device: Details: System Section

Table 26-1  Device: Details: System Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td></td>
</tr>
<tr>
<td>Device Name</td>
<td>Display only. Name of the managed device.</td>
</tr>
<tr>
<td>IP Address</td>
<td>Display only. IP address that Cisco DCNM uses to connect to the managed device.</td>
</tr>
<tr>
<td>Model</td>
<td>Display only. Hardware model name of the managed device.</td>
</tr>
<tr>
<td>Redundancy Supervisor</td>
<td>Display only. Whether the device has a secondary supervisor module.</td>
</tr>
<tr>
<td>Software</td>
<td></td>
</tr>
<tr>
<td>System Version</td>
<td>Display only. Release number of the system image currently installed on the managed device.</td>
</tr>
<tr>
<td>System Image</td>
<td>Display only. Filename of the system image currently installed on the managed device.</td>
</tr>
<tr>
<td>Kickstart Image</td>
<td>Display only. Filename of the kickstart image currently installed on the managed device.</td>
</tr>
</tbody>
</table>

Device: Details: Software Installation Jobs Section

Table 26-2  Device: Details: Software Installation Jobs Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job ID</td>
<td>Display only. Identification number of the job.</td>
</tr>
<tr>
<td>Owner</td>
<td>Display only. Cisco DCNM user who created the installation job.</td>
</tr>
<tr>
<td>Software Image and Version</td>
<td>Display only. Name of the system image specified in the job.</td>
</tr>
</tbody>
</table>
**Table 26-2  Device: Details: Software Installation Jobs Section (continued)**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scheduled At</td>
<td><em>Display only.</em> Date and time that the installation job is scheduled to occur.</td>
</tr>
<tr>
<td>Completed At</td>
<td><em>Display only.</em> Date and time that the installation job occurred. If the job has not completed, this field is blank.</td>
</tr>
<tr>
<td>Status</td>
<td><em>Display only.</em> Status of the installation job. If the job is ongoing, failed, or successful, you can expand the status and see more information about the job.</td>
</tr>
<tr>
<td>Comment</td>
<td><em>Display only.</em> Text of any comments added to the installation job.</td>
</tr>
</tbody>
</table>

**Field Descriptions for Software Installation Jobs**

This section includes the following field descriptions for the Software Installation Jobs feature:

- [Installation Job: Details: General Section, page 26-19](#)
- [Installation Job: Details: Devices and Software Images Section, page 26-20](#)

**Installation Job: Details: General Section**

**Table 26-3  Installation Job: Details: General Section**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Job ID</td>
<td><em>Display only.</em> Identification number of the job.</td>
</tr>
<tr>
<td>Owner</td>
<td><em>Display only.</em> Cisco DCNM user who created the installation job.</td>
</tr>
<tr>
<td>Scheduled At</td>
<td>Date and time that the installation job is scheduled to occur. If the job has not yet occurred, this field is configurable.</td>
</tr>
<tr>
<td>Completed At</td>
<td><em>Display only.</em> Date and time that the installation job occurred. If the job has not completed, this field is blank.</td>
</tr>
<tr>
<td>Status</td>
<td><em>Display only.</em> Status of the installation job.</td>
</tr>
<tr>
<td>Comment</td>
<td>Text entered by Cisco DCNM users.</td>
</tr>
<tr>
<td><strong>Installation Options</strong></td>
<td></td>
</tr>
<tr>
<td>Installation Options</td>
<td>Whether the installation job affects the startup configuration. By default, this check box is unchecked.</td>
</tr>
<tr>
<td>Save Running Configuration to Startup before Installation</td>
<td>Specifies that the installation job copies the running configuration of each device in the job to its startup configuration prior to installing the software image.</td>
</tr>
<tr>
<td>Erase Startup Configuration before Installation</td>
<td>Specifies that the installation job erases the startup configuration of each device in the job prior to installing the software image.</td>
</tr>
</tbody>
</table>
Installation Job: Details: Devices and Software Images Section

Table 26-4  Installation Job: Details: General Section

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Display only. Name of the managed device.</td>
</tr>
<tr>
<td>Platform</td>
<td>Display only. Hardware model name of the managed device.</td>
</tr>
<tr>
<td>Kickstart Image</td>
<td>Display only. Filename of the kickstart image currently installed on the managed device.</td>
</tr>
<tr>
<td>System Image</td>
<td>Display only. Filename of the system image currently installed on the managed device.</td>
</tr>
</tbody>
</table>

Field Descriptions for the File Servers Contents Pane

Table 26-5  File Servers Contents Pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Name/IP</td>
<td>DNS name or IP address of the file server. If you use the file server in a software installation job, ensure that devices in the job can connect to the name or address that you specify. This field is editable only when you create the file server entry. You cannot edit it after saving your changes to the Cisco DCNM server.</td>
</tr>
<tr>
<td>Address</td>
<td>Transfer protocol supported by the server. Valid values are as follows:</td>
</tr>
<tr>
<td></td>
<td>• FTP</td>
</tr>
<tr>
<td></td>
<td>• SFTP</td>
</tr>
<tr>
<td></td>
<td>• TFTP</td>
</tr>
<tr>
<td></td>
<td>This field is editable only when you create the file server entry. You cannot edit it after saving your changes to the Cisco DCNM server.</td>
</tr>
<tr>
<td>User Credentials</td>
<td>Username and password required to access the file server.</td>
</tr>
<tr>
<td>Base Directory</td>
<td>Directory that Cisco DCNM should consider as the root directory on the server. Directories specified for software installation jobs using this server will be relative to this directory.</td>
</tr>
<tr>
<td>Comment</td>
<td>Text entered by Cisco DCNM users.</td>
</tr>
</tbody>
</table>

Additional References

For additional information related to the Device OS Management feature, see the following sections:

- Related Documents, page 26-21
- Standards, page 26-21
Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upgrading and downgrading Cisco NX-OS software using the command-line interface on Nexus 7000 series switches.</td>
<td>Cisco Nexus 7000 Series NX-OS Software Upgrade and Downgrade Guide, Release 5.x</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

Feature History for Device OS Management

Table 26-6 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device OS Management</td>
<td>5.1(1)</td>
<td>No change from Release 5.0.</td>
</tr>
<tr>
<td>Device OS Management</td>
<td>5.0(2)</td>
<td>Support was added for Cisco Nexus 4000 Series Switches and Cisco Nexus 5000 Series Switches.</td>
</tr>
</tbody>
</table>
Starting and Stopping Cisco DCNM-LAN Servers

This chapter describes how to start or stop Cisco Data Center Network Manager for LAN (DCNM-LAN) servers.

This chapter includes the following sections:

- Information About Starting and Stopping DCNM-LAN Servers, page 27-1
- Licensing Requirements for Starting and Stopping Cisco DCNM-LAN Servers, page 27-1
- Starting DCNM-LAN Servers, page 27-2
- Stopping DCNM-LAN Servers, page 27-5
- Related Documents, page 27-8
- Feature History for Starting and Stopping a DCNM-LAN Server, page 27-9

Information About Starting and Stopping DCNM-LAN Servers

Starting and stopping DCNM-LAN servers is a necessary part of server maintenance, such as during database backup, cleaning, or restoration. In a clustered server deployment, the order in which you start DCNM-LAN servers determines which server is the master server. This chapter provides detailed steps for starting and stopping DCNM-LAN servers for both single-server deployments and clustered-server deployments.

Licensing Requirements for Starting and Stopping Cisco DCNM-LAN Servers

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Starting and stopping Cisco DCNM-LAN servers requires no license. Any feature not</td>
</tr>
<tr>
<td></td>
<td>included in a license package is bundled with the Cisco DCNM-LAN and is provided at</td>
</tr>
<tr>
<td></td>
<td>no charge to you. For information about obtaining and installing a Cisco DCNM LAN</td>
</tr>
<tr>
<td></td>
<td>Enterprise license, see the Cisco DCNM Installation and Licensing Guide, Release 5.x.</td>
</tr>
</tbody>
</table>
Starting DCNM-LAN Servers

This section includes the following topics:

- Starting a Single DCNM-LAN Server, page 27-2
- Starting a Cluster of DCNM-LAN Servers, page 27-3

Starting a Single DCNM-LAN Server

You can start a single DCNM-LAN server. The procedures for starting a single DCNM-LAN server differ for systems using the supported Microsoft Windows Server and Red Hat Enterprise Linux (RHEL) operating systems, as described in the following topics:

- Starting a Single DCNM-LAN Server (Microsoft Windows Server), page 27-2
- Starting a Single DCNM-LAN Server (RHEL), page 27-2

Starting a Single DCNM-LAN Server (Microsoft Windows Server)

On a server system running Microsoft Windows Server, you can start a DCNM-LAN server through the Windows services or by clicking the Start DCNM-LAN Server icon.

BEFORE YOU BEGIN

You must have installed the DCNM-LAN server.

If you are starting a server cluster, ensure that you are starting the server in the correct order. For more information, see the “Starting a Cluster of DCNM-LAN Servers” section on page 27-3.

DETAILED STEPS

Step 1
Open the Control Panel window and choose *Administrative Tools > Services.*

The Services window opens.

Step 2
Right-click *Cisco DCNM Server* and choose *Start.*

---

Note

Alternatively, you can choose *Start > All Programs > Cisco DCNM Server > Start DCNM Server;* however, the location of shortcuts depends upon the choices you made when you installed the DCNM-LAN server.

A splash screen opens while the DCNM-LAN server starts. This screen closes once the DCNM-LAN server is running.

Starting a Single DCNM-LAN Server (RHEL)

On a server system that runs RHEL, you can start a DCNM-LAN server with the *Start_DCNM_LAN_Server* script. The script is located in your home folder or the folder that was specified when setting up the link folder during the installation of Cisco DCNM-LAN.
Note
Start_DCNM_LAN_Server launches /usr/local/Cisco/dcm/dcnm/bin/startdcnm.sh.

BEFORE YOU BEGIN

The DCNM-LAN server must be installed.

If you are starting a server cluster, ensure that you are starting the server in the correct order. For more information, see the “Starting a Cluster of DCNM-LAN Servers” section on page 27-3.

DETAILED STEPS

Step 1
Use the Start_DCNM_LAN_Server script to start the server on a RHEL operating system.

The DCNM-LAN server opens a server console window and displays the processes it runs to start the server. The server is running when you see a “Started in Xm:XXs:XXXms” message.

Starting a Cluster of DCNM-LAN Servers

Depending on the operating system of the secondary server, the DCNM-LAN server can be started using the Windows GUI, the CLI, or the DCNM Install Manager tool. You can use the CLI or the DCNM Install Manager tool for a secondary server running RHEL. For a secondary server running Microsoft Windows, the DCNM-LAN server is started with the Windows GUI.

Starting with Windows GUI or RHEL CLI

Starting a cluster of DCNM-LAN servers requires starting each server individually; however, the order of server startup is important. The server with the oldest start time performs the master server role in the server cluster.

BEFORE YOU BEGIN

We recommend that you use the primary installation server as the master server. For information about deploying a clustered-server environment, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.

If any server in the cluster is running, stop it prior to starting the cluster. The only way that you can control which server is the master server is by ensuring that the master server is started before the other servers start. For more information, see the “Stopping DCNM-LAN Servers” section on page 27-5.

DETAILED STEPS

Step 1
Start the server that you want to be the master server of the cluster. To do so, follow the steps for starting a single DCNM-LAN server for the applicable operating system:

- Starting a Single DCNM-LAN Server (Microsoft Windows Server), page 27-2
- Starting a Single DCNM-LAN Server (RHEL), page 27-2

Step 2
Wait for the master server to finish starting.
Starting DCNM-LAN Servers

Step 3
One at a time, start the other servers in the cluster. After starting a server, wait at least one minute before starting the next server. This delay helps ensure faster stabilization of the server cluster.

For each server, follow the steps for starting a single DCNM-LAN server for the applicable operating system:

- Starting a Single DCNM-LAN Server (Microsoft Windows Server), page 27-2
- Starting a Single DCNM-LAN Server (RHEL), page 27-2

Starting with Install Manager

DCNM Install Manager is a GUI tool for servers that run Linux. It is designed to assist in performing silent mode operations on secondary servers (remote nodes).

Note
DCNM Install Manager does not support Windows servers.

DETAILED STEPS

Step 1
To access Install Manager, navigate to the dcnm-install-manager.sh file that is located in the bin folder where the DCNM-LAN server was installed.

The default bin folder location for servers running Linux is /usr/local/Cisco/dcm/dcnm/bin.

Step 2
Double click the dcnm-install-manager.sh file to launch Install Manager.

Step 3
In the tool bar, click the New icon near the top of the Install Manager GUI for every secondary server.

A new row in the list of Server Nodes is created every time the New icon is clicked.

Note
In the toolbar, click the Delete icon to delete a selected row in the list of Server Nodes. This step does not delete a secondary server from the clustered-server environment.

Step 4
For each secondary server represented by a row in the list of Server Nodes, enter the following:

- Server name or IP address in the Server Name/IP Address field.
- Protocol used for connectivity in the Protocol field.
  The protocol is either Telnet or SSH.
- User credentials (user ID and password) used for connecting to the secondary server in the User Credentials field.
  The user credentials are used for SSH connectivity to the server. Telnet connectivity to the server does not require user credentials.
  Alternatively, default user credentials may be set by entering the credentials in the Default Credentials section of the GUI. The default credentials are used when the User Credential field is blank.
- (Optional) Comments that may be useful to identify the secondary server in the Comments field.

The Last Action Status column in the list of Server Nodes includes the success or failure status of the last performed action. Clicking the “+” icon for the Last Action Status expands the display to show the entire log of actions performed on the server.
Step 5 In the list of Server Nodes, select the secondary servers to start.

Step 6 In the toolbar, click the **Verify** icon to verify the connectivity to the selected secondary servers. Correct any connectivity issues before continuing.

Step 7 In the toolbar, click the **Start** icon to start the selected secondary servers.

Note The Install Manager is a standalone application. The settings specified are not saved and are not persistent. The settings are lost when the Install Manager GUI is closed.

Stopping DCNM-LAN Servers

This section includes the following topics:

- Stopping Single DCNM-LAN Servers, page 27-5
- Stopping a Cluster of DCNM-LAN Servers, page 27-6

Stopping Single DCNM-LAN Servers

You can stop a single DCNM-LAN server.

The steps for stopping a single DCNM-LAN server differ for systems using the supported Microsoft Windows Server and RHEL operating systems, as described in the following topics:

- Stopping a Single DCNM-LAN Server (Microsoft Windows Server), page 27-5
- Stopping a Single DCNM-LAN Server (RHEL), page 27-6

Stopping a Single DCNM-LAN Server (Microsoft Windows Server)

On a server system that runs Microsoft Windows Server, you can stop a DCNM-LAN server through the Windows services or by clicking the Stop DCNM Server icon.

DETAILED STEPS

Step 1 Open the Control Panel window and choose **Administrative Tools > Services**.

A window opens listing the Windows services.

Step 2 Right-click **Cisco DCNM Server** and choose **Stop**.

Note Alternatively, you can choose **Start > All Programs > Cisco DCNM Server > Stop DCNM Server**, however, the location of shortcuts depends upon the choices you made when you installed the DCNM-LAN server.
A splash screen opens while the DCNM-LAN server begins to shut down. When the DCNM-LAN server has stopped, the splash screen closes.

### Stopping a Single DCNM-LAN Server (RHEL)

On a server system that runs RHEL, you can stop a DCNM-LAN server with the `Stop_DCNM_LAN_Server` script. The script is located in your home folder or the folder that was specified when setting up the link folder during the installation of Cisco DCNM-LAN.

**Note**

`Stop_DCNM_LAN_Server` launches `/usr/local/Cisco/dcm/dcnm/bin/stopdcnm.sh`.

**DETAILED STEPS**

**Step 1** Use the `Stop_DCNM_LAN_Server` script to stop the server on a RHEL operating system.

The DCNM-LAN server opens a server console window and displays the processes that it runs to stop the server. The server is stopped when you see a “Stopped at Xm:XXs:XXXms” message.

### Stopping a Cluster of DCNM-LAN Servers

Depending on the operating system of the secondary server, the DCNM-LAN server can be stopped using the CLI or the DCNM Install Manager tool. You can use the CLI or the DCNM Install Manager tool for a secondary server running RHEL. For a secondary server running Microsoft Windows, the DCNM-LAN server is stopped with the CLI.

### Stopping with CLI

If you have a clustered-server DCNM-LAN deployment, you can use the `stop-dcnm-cluster` script to stop all the servers in the cluster.

**BEFORE YOU BEGIN**

Ensure that you know which server is currently the master server in the DCNM-LAN server cluster. You can use the Cluster Administration feature to do so.

**DETAILED STEPS**

**Step 1** On the master server, access a command prompt.

**Step 2** Use the `cd` command to change the directory to the bin directory under the Cisco DCNM installation directory, as follows:

```
cd path
```

where `path` is the relative or absolute path to the bin directory. For Microsoft Windows, the default path to the Cisco DCNM bin directory is `C:\Program Files\Cisco Systems\dcm\dcnm\bin`. For RHEL, the default path to the bin directory is `/usr/local/cisco/dcm/dcnm/bin`. 
Step 3  Run the `stop-dcnm-cluster` script. The script name depends upon the server operating system, as shown in the following table:

<table>
<thead>
<tr>
<th>Server Operating System</th>
<th>Stop DCNM Cluster Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows</td>
<td>stop-dcnm-cluster.bat</td>
</tr>
<tr>
<td>Linux</td>
<td>stop-dcnm-cluster.sh</td>
</tr>
</tbody>
</table>

The script instructs each DCNM-LAN server in the cluster to stop.

Example

The following example from a Microsoft Windows server shows how to stop a cluster of DCNM-LAN servers, with DCNM-LAN installed in the default directory:

C:\Documents and Settings\Administrator> cd "C:\Program Files\Cisco Systems\dcn\bin"

C:\Program Files\Cisco Systems\dcn\bin> stop-dcnm-cluster.bat

C:\Program Files\Cisco Systems\dcn\bin> set JAVA_HOME=C:\Program Files\Cisco Systems\dcn\java\jre1.5

C:\Program Files\Cisco Systems\dcn\bin> "C:\Program Files\Cisco Systems\dcn\jbos-4.2.2.GA\bin\twiddle.bat" -s 172.28.254.254:1099 invoke "com.cisco.dcbu.dcm:service=ClusterServerInfo" stopServerInstancesInCluster 10

Shutdown Triggered for all Servers Successfully

C:\Program Files\Cisco Systems\dcn\bin>

Stopping with Install Manager

Cisco DCNM Install Manager is a GUI tool for servers that runs Linux. It is designed to assist in performing silent mode operations on secondary servers (remote nodes).

DETAILED STEPS

Step 1  To access Install Manager, navigate to the dcnm-install-manager.sh file that is located in the bin folder where the DCNM-LAN server was installed.

The default bin folder location for servers running Linux is /usr/local/Cisco/dcm/dcnm/bin.

Step 2  Double click the `dcnm-install-manager.sh` file to launch Install Manager.

Step 3  In the toolbar, click the New icon near the top of the Install Manager GUI for every secondary server. A new row in the list of Server Nodes is created every time that the New icon is clicked.

Note  In the toolbar, click the Delete icon to delete a selected row in the list of Server Nodes. This step does not delete a secondary server from the clustered-server environment.
Step 4  For each secondary server represented by a row in the list of Server Nodes, enter the following:

- Server name or IP address in the Server Name/IP Address field.
- Protocol used for connectivity in the Protocol field.
  The protocol is either Telnet or SSH.
- User credentials (user ID and password) used for connecting to the secondary server in the User Credentials field.
  The user credentials are used for SSH connectivity to the server. Telnet connectivity to the server does not require user credentials.
  Alternatively, default user credentials can be set by entering the credentials in the Default Credentials section of the GUI. The default credentials are used when the User Credential field is blank.
- (Optional) Comments that might be useful to identify the secondary server in the Comments field.

The Last Action Status column in the list of Server Nodes includes the success or failure status of the last performed action. Clicking the “+” icon for the Last Action Status expands the display to show the entire log of actions performed on the server.

Step 5  In the list of Server Nodes, choose the secondary servers to stop.

Step 6  In the toolbar, click the Verify icon to verify the connectivity to the selected secondary servers.
Correct any connectivity issues before continuing.

Step 7  In the toolbar, click the Stop icon to stop the selected secondary servers.

Note  The Install Manager is a standalone application. The settings specified are not saved and are not persistent. The settings are lost when you exit the Install Manager GUI.

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deploying single DCNM-LAN servers and deploying DCNM-LAN server clusters</td>
<td>Cisco DCNM Installation and Licensing Guide, Release 6.x</td>
</tr>
<tr>
<td>Backing up, cleaning, and restoring DCNM-LAN databases</td>
<td>Chapter 37, “Maintaining the Cisco DCNM-LAN Database”</td>
</tr>
</tbody>
</table>
Feature History for Starting and Stopping a DCNM-LAN Server

Table 27-1 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting and stopping a cluster of servers</td>
<td>5.0(2)</td>
<td>Support for starting and stopping a cluster of servers was introduced.</td>
</tr>
</tbody>
</table>
This chapter describes how to vacuum the postgres database in Microsoft Windows and Linux. This chapter includes the following sections:

- Background Information, page 28-1
- Vacuum DCNM's Postgresql Database in Windows, page 28-1
- Vacuum DCNM's Postgresql Database in Linux, page 28-2

### Background Information

It is absolutely critical to vacuum postgres databases in order for the databases to properly function. Through the life of the database, new entries are added and current entries are updated. By design, postgres does not immediately remove the iterations of a record as it gets updated. Therefore, postgres databases can contain a large number of stale, unused records. These old records should be removed at least every two weeks with the vacuum function in order to reduce disk usage and improve the speed of database queries. It is even more effective if you configure postgres to automatically vacuum the database without the need to stop the Data Center Network Manager (DCNM) services.

**Note**

$INSTALLDIR throughout this article refers to "C:\Program Files\Cisco Systems" or "/usr/local/cisco/" based on the operating system, Microsoft Windows or Linux respectively. The install path could be changed from these defaults during installation.

### Vacuum DCNM's Postgresql Database in Windows

**Step 1**

Stop the DCNM services by clicking **Stop DCNM Servers** button, or enter the command as below:

```
$INSTALLDIR/dcm/dcnm/bin/stopLANSANserver.bat
```

**Step 2**

Obtain the database name, username, and password. Locate the `postgresql.cfg.xml` file on the DCNM server.

- In DCNM Version 6.2.x, enter:

```
$INSTALLDIR/dcm/jboss-4.2.2.GA/server/dcnm/conf/database/postgresql.cfg.xml
```
• In DCNM Version 6.3.x, enter:
  $INSTALLDIR/dcm/Jboss-as-7.2.0.Final/standalone/conf/postgresql.cfg.xml

Step 3  Open PgAdmin III.exe, which is a helpful GUI for the postgres database. Then, right-click the object in the list and connect to the database. Enter the password from Step 2 here.

Step 4  Navigate through the drop-down menus to the dcmdb database.

Step 5  Right-click dcmdb and select Maintenance. Select the Vacuum, Full, Analyze, and Verbose options in the Maintain Database dcmdb dialog box.

Note  The vacuum operation usually completes within an hour, but can take much longer for larger databases. Remember to restart the DCNM services.

---

**Vacuum DCNM's Postgresql Database in Linux**

**Step 1**  Stop dcnm by using the appmgr stop dcnm command.

**Step 2**  Open the psql prompt:

```
./usr/local/cisco/dcm/db/bin/psql -U <dbUsername> dcmdb
```

**Step 3**  Run the database vacuum and quit:

```
dcmdb=> VACUUM FULL ANALYZE VERBOSE;
Many pages of output pass on the screen. The vacuum is finished when you see a message similar to this one:
Current limits are: 532000 page slots, 1000 relations, using 3182 kB.
VACUUM
dcmdb=>
dcmdb=> \q
```

The previous command exits the sql prompt.

**Step 4**  Start DCNM services by using the appmgr start dcnm command.
Administering Device Discovery

The Device Discovery feature creates devices in Cisco DCNM by connecting to a Cisco NX-OS device and retrieving the running configuration of the device. Cisco DCNM can also discover Cisco NX-OS devices that are neighbors of the first device, which is known as the seed device.

If the device supports virtual device contexts (VDCs), Cisco DCNM retrieves the running configuration of each virtual device context (VDC) that is configured on the physical device. Cisco DCNM displays each VDC as a device, including the default VDC. If the Cisco NX-OS device has only the default VDC, then device discovery creates only one device in Cisco DCNM.

This chapter describes how to administer the Device Discovery feature in the Cisco Data Center Network Manager for LAN (DCNM-LAN).

This chapter includes the following sections:

- Information About Device Discovery, page 29-1
- Licensing Requirements for Device Discovery, page 29-6
- Prerequisites for Device Discovery, page 29-6
- Guidelines and Limitations for Device Discovery, page 29-6
- Performing Device Discovery, page 29-7
- Viewing the Status of Device Discovery Tasks, page 29-12
- Where to Go Next, page 29-12
- Field Descriptions for Device Discovery, page 29-12
- Device System-Message Logging Level Reference, page 29-15
- Additional References for Device Discovery, page 29-18
- Feature History for Device Discovery, page 29-19

Information About Device Discovery

This section includes the following topics:

- Device Discovery, page 29-2
- Discovery Protocols, page 29-2
- Credentials and Discovery, page 29-3
- Discovery Process, page 29-3
- Cisco NX-OS System-Message Logging Requirements, page 29-4
Information About Device Discovery

- Automatic Logging-Level Configuration Support, page 29-5
- VDC Support, page 29-5

Device Discovery

The Device Discovery feature creates devices in DCNM-LAN by connecting to a Cisco NX-OS device and retrieving data from the device, including its running configuration. DCNM-LAN can also discover Cisco NX-OS devices and network servers that are neighbors of the first device, which is known as the seed device.

Note

- Staring from Cisco NX-OS Release 5.2.2(a) the Cisco DCNM-LAN supports the discovery of the following modules:
  - N7K-F248XP-25 Line Card
  - N55-M16FP 16-Port FC GEM
  - N7K-C7010-FAB2 Fabric 2 module
  - N7K-C7018-FAB2 Fabric 2 module
  - N55-D160L3-V2 Daughter Card
  - N55-M160L3-V2 Line Card
  - N3K-C3048TP-1GE Layer 3 switch
  - N3K-C3016Q- 40GE Layer 3 switch

If the device supports virtual device contexts (VDCs), DCNM-LAN retrieves the running configuration of each VDC that is configured on the physical device. DCNM-LAN displays each VDC as a device, including the default VDC. If the Cisco NX-OS device has only the default VDC, then device discovery creates only one device in DCNM-LAN.

When DCNM-LAN connects to a device to retrieve its configuration, it uses the XML management interface, which uses the XML-based Network Configuration Protocol (NETCONF) over Secure Shell (SSH). For more information, see the Cisco NX-OS XML Interface User Guide.

Discovery Protocols

DCNM-LAN uses a variety of protocols to discover devices and servers in your data center network. This section includes the following topics:

- Cisco Discovery Protocol, page 29-3
- Link Layer Discovery Protocol, page 29-3
- Fibre Channel, page 29-3
Cisco Discovery Protocol

Device discovery uses the Cisco Discovery Protocol (CDP) to find devices that are connected to the initial device in the discovery process. CDP exchanges information between adjacent devices over the data link layer. The exchanged information is helpful in determining the network topology and physical configuration outside of the logical or IP layer.

CDP allows DCNM-LAN to discover devices that are one or more hops beyond the seed device in the discovery process. When you start the discovery process using the Device Discovery feature, you can limit the number of hops that the discovery process can make.

After DCNM-LAN discovers a Cisco NX-OS device using CDP, it connects to the device and retrieves information, such as the running configuration of the device. The information collected allows DCNM-LAN to manage the device.

DCNM-LAN supports CDP hops on some Cisco switches that run Cisco IOS software. Although DCNM-LAN cannot manage these devices, the Topology feature allows you to see unmanaged devices and the CDP links between unmanaged devices and managed devices.

Link Layer Discovery Protocol

Device discovery uses Link Layer Discovery Protocol (LLDP) to discover the network adapters of servers that are connected to Cisco NX-OS devices.

Fibre Channel

To discover network elements in a storage area network (SAN), DCNM-LAN uses Fibre Channel. DCNM-LAN can discover SAN switches, servers, and storage arrays.

Credentials and Discovery

Device discovery requires that you provide a username and password for a user account on the seed device. To successfully complete the discovery of a Cisco NX-OS device, the user account that you specify must be assigned to either the network-admin or the vdc-admin role.

If you want to discover devices that are one or more hops from the seed device, all devices in the chain of hops must be configured with a user account of the same username and password. All Cisco NX-OS devices in the chain of hops must assign the user account to the network-admin or the vdc-admin role.

Discovery Process

DCNM-LAN discovers devices in several phases, as follows:

1. CDP neighbor discovery—Discovers the topology of the interconnected devices, beginning with the seed device and preceding for the number of CDP hops specified when you initiate discovery.
2. Supported device selection—Determines which of the discovered devices are supported by DCNM-LAN. Discovery continues for the supported devices only.
3. Inventory discovery—Discovers the inventory of the devices selected in the previous phase. For example, if the device is a Cisco Nexus 7000 Series switch, inventory discovery determines the supervisor modules, I/O modules, power supplies, and fans. If the device is a Cisco Nexus 1000V switch, inventory discovery finds the Virtual Supervisor Module and Virtual Ethernet Modules.
4. Device configuration discovery—Discovers the details of feature configuration on each device, such as interfaces, access control lists, and VLANs.
5. Network discovery—Associates network features with the device configuration details discovered in the previous phase.

Cisco NX-OS System-Message Logging Requirements

To monitor and manage devices, DCNM-LAN depends partly on system messages that it retrieves from managed devices. This section describes the system-message requirements that all Cisco NX-OS devices must meet before they can be managed and monitored by DCNM-LAN.

This section includes the following topics:

- Interface Link-Status Events Logging Requirement, page 29-4
- Logfile Requirements, page 29-4
- Logging Severity-Level Requirements, page 29-4

Interface Link-Status Events Logging Requirement

Devices must be configured to log system messages about interface link-status change events. This requirement ensures that DCNM-LAN receives information about interface link-status changes. The following two commands must be present in the running configuration on the device:

- logging event link-status enable
- logging event link status default

To ensure that these commands are configured on the device, perform the steps in the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.

Logfile Requirements

Devices must be configured to store system messages that are severity level 6 or lower in the log file. Although you can specify any name for the log file, we recommend that you do not change the name of the log file. When you change the name of the log file, the device clears previous system messages. The default name of the log file is “messages.”

If you use the default name for the log file, the following command must be present in the running configuration on the device:

    logging logfile messages 6

To ensure that this command is configured on the device, perform the steps in the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.

Logging Severity-Level Requirements

DCNM-LAN has minimum severity level requirements for some Cisco NX-OS logging facilities. All enabled features on a Cisco NX-OS have a default logging level. The logging level required by DCNM-LAN varies per logging facility but is often higher than the default logging level in Cisco NX-OS. For more information, see the “Automatic Logging-Level Configuration Support” section on page 29-5.
Automatic Logging-Level Configuration Support

DCNM-LAN provides support for automatic logging level configuration for all supported Cisco NX-OS releases with the exception of Cisco NX-OS Release 4.0, which is available on Cisco Nexus 7000 Series switches only. This section describes how DCNM-LAN supports automatic logging-level configuration. For information about manually configuring logging levels for Cisco NX-OS Release 4.0, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.

During Device Discovery

During device discovery, if DCNM-LAN finds that a logging level on a discovered device is below the minimum logging-level requirement for that logging facility, DCNM-LAN raises the logging level to meet the minimum requirement. If logging levels meet or exceed the requirements, DCNM-LAN does not change the logging levels during discovery.

At Feature Enablement in the DCNM-LAN Client

If you use the DCNM-LAN client to enable a feature on a device and the default logging level for the feature does not meet the minimum requirement, the DCNM-LAN client warns you that it will configure the logging level on the device to meet the requirement. If you reject the logging level change, DCNM-LAN does not enable the feature.

During Auto-Synchronization with Managed Devices

If you use another means, such as the command-line interface (CLI), to enable a feature on a managed device and the default logging level for the feature does not meet the minimum requirement, DCNM-LAN automatically configures the logging level to meet the requirement after DCNM-LAN detects that the feature is enabled.

If you use the CLI or any other method to lower a logging level below the minimum requirement of DCNM-LAN, after DCNM-LAN detects the logging level change, it changes the state of that device to unmanaged. When this occurs, the Devices and Credentials feature shows that logging levels are the reason that the device is unmanaged. You can use the Devices and Credentials feature to discover the device again. During rediscovery, DCNM-LAN sets logging levels that do not meet the minimum requirements.

VDC Support

When DCNM-LAN discovers a Cisco NX-OS device that supports VDCs, it determines how many VDCs are on the Cisco NX-OS device. In DCNM-LAN, each VDC is treated as a separate device. The status of each VDC is tracked separately and you can configure each VDC independently of other VDCs on a Cisco NX-OS device.

Before discovering a Cisco Nexus 7000 Series device that has nondefault VDCs, ensure that each VDC meets the prerequisites for discovery. For more information, see the “Prerequisites for Device Discovery” section on page 29-6.
Licensing Requirements for Device Discovery

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCNM-LAN</td>
<td>The Device Discovery feature requires no license. Any feature not included in a license package is bundled with the DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 5.x</em>.</td>
</tr>
</tbody>
</table>

Prerequisites for Device Discovery

Prior to performing device discovery, you should be familiar with the following:

- VDCs, if you are discovering Cisco Nexus 7000 Series devices.
- CDP

The Device Discovery feature has the following prerequisites:

- The DCNM-LAN server must be able to connect to devices that it discovers.
- Cisco NX-OS devices must be running a supported release of Cisco NX-OS. For information about supported releases of Cisco NX-OS, see the *Cisco DCNM Release Notes, Release 7.x*.
- The Cisco NX-OS device must have the minimal configuration that is required to enable device discovery to succeed. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.
- For a Cisco Nexus 7000 Series device, each VDC that you want to discover must have a management interface configured. DCNM-LAN supports discovery of VDCs that are configured with a management interface that is the mgmt0 interface, which is an out-of-band virtual interface, or with an in-band Ethernet interface that is allocated to the VDC.
- To allow DCNM-LAN to discover devices that are CDP neighbors, CDP must be enabled both globally on each device and specifically on the device interfaces used for device discovery. For a Cisco Nexus 7000 Series device, CDP must be enabled globally in each VDC and on the management interface that each VDC is configured to use.
- Discovery of network servers requires that LLDP is enabled globally on devices connected to network servers and specifically on the device interfaces connected to the network adapters on network servers.

Guidelines and Limitations for Device Discovery

The Device Discovery feature has the following configuration guidelines and limitations:

- Ensure that Cisco NX-OS devices that you want to discover have been prepared for discovery. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.
- DCNM-LAN can manage only devices that run Cisco NX-OS. For more information about supported device operating systems and supported device hardware, see the *Cisco DCNM Release Notes, Release 7.x*. 
Performing Device Discovery

CDP-based discovery of devices requires that all devices in the chain of CDP hops use the same username and password specified for the seed device. If your security practices do not allow the same username and password to be used on each device, you can perform device discovery for each device individually.

Devices that are CDP hops but which are not running Cisco IOS software appear in the Topology feature but cannot be managed by DCNM-LAN.

Performing Device Discovery

This section includes the following topics:
- Verifying the Discovery Readiness of a Cisco NX-OS Device, page 29-7
- Device Discovery, page 29-2
- Viewing the Status of Device Discovery Tasks, page 29-12

Verifying the Discovery Readiness of a Cisco NX-OS Device

Before you perform device discovery with DCNM-LAN, you should perform the following procedure on each Cisco NX-OS device that you want to manage and monitor with DCNM-LAN. This procedure helps to ensure that device discovery succeeds and that DCNM-LAN can effectively manage and monitor the device.

**Note**
If you are preparing a physical device that supports virtual device contexts (VDCs), remember that DCNM-LAN considers each VDC to be a device. You must verify discovery readiness for each VDC that you want to manage and monitor with DCNM-LAN.

**DETAILED STEPS**

**Step 1** Log into the CLI of the Cisco NX-OS device.

**Step 2** Use the `configure terminal` command to access global configuration mode.

**Step 3** Ensure that an RSA or DSA key exists so that secure shell (SSH) connections can succeed. To do so, use the `show ssh key rsa` or `show ssh key dsa` command.

If you need to generate a key, use the `ssh key` command.

**Note** You must disable the SSH server before you can generate a key. To do so, use the `no feature ssh` command.

**Step 4** Ensure that the SSH server is enabled. To do so, use the `show ssh server` command.

If the SSH server is not enabled, use the `feature ssh` command to enable it.

**Step 5** Ensure that CDP is enabled globally and on the interface that DCNM-LAN uses to connect to the device. Use the `show run cdp all` command to see whether CDP is enabled.
Step 6  Verify that the **logging event link-status default** and **logging event link-status enable** commands are configured.

```
switch(config)# show running-config all | include "logging event link-status"
logging event link-status default
logging event link-status enable
```

If either command is missing, enter it to add it to the running configuration.

---

**Note**  The **logging event link-status enable** command is included in the default Cisco NX-OS configuration. The **show running-config** command displays the default configuration only if you use the **all** keyword.

---

Step 7  Verify that the device is configured to log system messages that are severity 6 or lower.

---

**Note**  The default name of the log file is “messages”; however, we recommend that you use the log-file name currently configured on the device. If you change the name of the log file, the device clears previous system messages.

```
switch(config)# show running-config all | include logfile
logging logfile logfile-name 6
```

If the **logging logfile** command does not appear or if the severity level is less than 6, configure the **logging logfile** command.

```
switch(config)# logging logfile logfile-name 6
```

Step 8  If the device is a Cisco Nexus 7000 Series switch that is running Cisco NX-OS Release 4.0, you must manually verify that the logging level configuration of the device meets the DCNM-LAN logging level requirements. To do so, follow these steps:

- a. Determine which nondefault features are enabled on the device.

  ```
  switch(config)# show running-config | include feature
  feature feature1
  feature feature2
  feature feature3
  .
  .
  .
  ```

- b. View the logging levels currently configured on the device. The **show logging level** command displays logging levels only for features that are enabled. The Current Session Severity column lists the current logging level.

  ```
  switch(config)# show logging level
  Facility        Default Severity        Current Session Severity
  --------        ----------------        ------------------------
  aaa                     3                       5
  aclmgr                  3                       3
  .
  .
  .
  ```

---

**Note**  You can use the **show logging level** command with the facility name when you want to see the logging level of a single logging facility, such as **show logging level aaa**.
Performing Device Discovery

c. Determine which logging levels on the device are below the minimum DCNM-LAN required logging levels. To do so, compare the logging levels displayed on page 29-8 to the minimum DCNM-LAN required logging levels that are listed in Table 29-3.

d. For each logging facility with a logging level that is below the minimum DCNM-LAN required logging level, configure the device with a logging level that meets or exceeds the DCNM-LAN requirement.

switch(config)# logging level facility severity-level

The facility argument is the applicable logging-facility keyword from Table 29-3, and severity-level is the applicable minimum DCNM-LAN required logging level or higher (up to 7).

e. Use the show logging level command to verify your changes to the configuration.

Step 9
Copy the running configuration to the startup configuration to save your changes.

switch(config)# copy running-config startup-config
[########################################] 100%
switch(config)#

Discovering Devices

You can discover one or more devices. When a discovery task succeeds, DCNM-LAN retrieves the running configuration and status information of discovered Cisco NX-OS devices.

You can perform Deep Discovery by selecting one task at a time. You can also select all or multiple devices in a single task at a time.

Note
You cannot select multiple tasks or multiple devices across tasks at one instance.

Use this procedure for the following purposes:

- To discover devices that are not currently managed by DCNM-LAN. For example, you should use this procedure when DCNM-LAN has not yet discovered any devices, such as after a new installation.
- To discover devices that you have added to your network without rediscovering devices that DCNM-LAN already has discovered.
- To rediscover the topology when CDP links have changed without rediscovering devices that DCNM-LAN has already discovered.

Note
You must successfully discover a Cisco NX-OS device before you can use DCNM-LAN to configure the device.

BEFORE YOU BEGIN

Ensure that you have configured the Cisco NX-OS device so that the DCNM-LAN server can connect to it and successfully discover it. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.
Performing Device Discovery

Determine the IPv4 address of the device that you want DCNM-LAN to connect to when it starts the discovery task. This is the seed device for the discovery.

Determine whether you want to discover devices that are CDP neighbors of the seed device. If so, determine the maximum number of hops from the seed device that the discovery process can make.

**Note**

The discovery process can perform complete discovery of neighbors only if the neighboring devices are configured with the same credentials as the seed device.

**DETAILED STEPS**

**Step 1**

From the Feature Selector pane, choose **DCNM Server Administration > Device Discovery**.

The discovery tasks appear in the Discovery Tasks area of the Contents pane.

**Step 2**

Click **Here** in the Device Discovery pane to perform Shallow Discovery of the devices in the Cisco DCNM Web Client. The shallow discovery result web page pops out.

There are four types of discovery, they are **Fabric**, **LAN**, **VMWare**, and **SMI-S Storage**.

**Step 3**

In the first table of **Fabric**, you can **Edit**, **Remove**, **Add**, **Re-discover**, **Refresh** and **Purge unreachable devices or dead link** in selected fabric.

- To edit the fabric— Check the box before the fabric you want to select, and click the **edit** icon as a pencil. You can edit the **Fabric Name**, check/uncheck to use/disuse **SNMPv3/SSH** and select the **Auth-Privacy** from the drop-down list. Enter the **User Name** and **Password** and select the **Status** as **managed**, **unmanaged**, or **managedContinuously**. (Optional) You can click the **options** button to input the **UCS User Name** and the **UCS Password**.

- To remove the fabric— Select the fabric that you want to remove, and click the **remove** icon. Click yes to remove the selected fabric.

- To add a fabric— Click the **add** icon to add a fabric. Enter the information about **Fabric Seed Switch**, **SNMP**, **User Name** and **Password**. If you check **Limit Discovery by VSAN**, select which you want to limit by, **Included VSAN List** or **Excluded VSAN List**, and provide the **VSAN List**. Check/uncheck to enable/disable NPV Discovery in All Fabrics. (Optional) Click options button to input the **UCS User Name** and the **UCS Password**.

- To re-discover a fabric— Select the fabric that you want to be re-discovered, and click the **Re-discover Fabric** icon. Click yes to perform re-discovery of the fabric.

- To refresh the fabric discovery table— Click the **refresh** icon to manually refresh the discovery table.

- To purge down elements in the fabric— Select the fabric and click the **Purge** icon to purge unreachable devices or dead links in selected Fabric and click yes.

- To maximize the fabric table— Click the **Maximize** icon to maximize the fabric table and click **Normalize** to return the former view.

**Step 4**

In the second table of **LAN** discovery, you can **Add**, **Refresh**, **Purge unreachable devices or dead links in selected LAN** and **Toggle between Task and Device View**. You can **Edit LAN Task**, **Re-discover LAN** and **Remove LAN Task/Switch** by clicking the icons before the tasks-switches.

- To **Edit LAN Task**— Click the Edit icon, enter the username of a user account on the device in the **User Name** field. The user account must have a network-admin or vdc-admin role. In the **Password** field, enter the password for the user account. Choose the **Status** of the LAN task. For Catalyst 6500 devices, enter the enable password in the Enable Password field to allow for IOS privileged EXEC mode commands.
Performing Device Discovery

- To **Re-discover LAN**— A warning message pops out, click on yes to proceed rediscovery.
- To **Remove LAN Task**— Click on the remove icon and click yes to remove the LAN task.
- To **Add LAN Task**— Choose the **Discovery Type** from **Hops from Seed Switch/Switch List/FWSM**.

If you choose the discovery type as **Hops from Seed Switch**, input the IP address or IP range string in **Seed Switch**. Drag the triangle to the number which represents the **Max Hops from Seed**. Choose the **Protocol** of the LAN. If you choose **SNMPv1**, select the **Scan Timeout** from the drop-down list and enter the **Community**. If you choose **SNMPv3/CLI**, select the auth-privacy and **Scan Timeout** from the drop-down list. Enter the **User Name** and **Password**. Select the group that you want to add the switch to and click **Next**. **Shallow LAN Discovery** window shows up. Select the switches and click Add to add the LAN task.

It’s quite similar with the other discovery type as **Switch List or FWSM**, only that you don’t need to provide the max hops from seed.

**Step 5** If there are VMWare and SMI-S storage devices discovered, you can perform similar function in the VMWare and SMI-S Storage discovery table.

**Step 6** You can only perform deep discovery in the DCNM LAN client, please follow the steps in **Deep Discovery**.

---

**Deep Discovery**

Deep discovery is an ssh based discovery initiated from the DCNM-LAN client and allows DCNM to actually log in via ssh and configure the LAN devices.

To perform Deep Discovery of the devices so that you can configure LAN devices via DCNM, please follow below steps:

**Step 1** From the Feature Selector pane, choose **DCNM Server Administration > Device Discovery**.

**Step 2** Click the plus icon to expand the task under **Task based Discovery** pane, a list of devices under the single task shows up.

**Step 3** You can either select one device or multiple devices under one task. Right click on the single device or multiple devices under one task and select **Deep Discovery**.

**Note** Deep Discovery is a requirement for any of the features found in the DCNM LAN client.

**Step 4** Click **Refresh** button or press F5, the successfully deep discovered device will show **MANAGED** under **SSH/Telnet** of **Status**.

**Step 5** You can also right click the discovered devices and select **Re-do deep discovery**.

**Step 6** In the Device Discovery pane, click the **History** button to open the History of Discovery window. You can see **Task ID, Owner, Seed Device IP Address, Discovered Time, Reason** and **Status** history from the window.
Viewing the Status of Device Discovery Tasks

To view the status of device discovery tasks, from the Feature Selector pane, choose DCNM Server Administration > Device Discovery.

The tasks, including the task status, appear in the Discovery Tasks area in the Contents pane. For information about the fields that appear, see the “Field Descriptions for Device Discovery” section on page 29-12.

Where to Go Next

View the discovered devices and configure unique device credentials, as needed. For more information, see the “Administering Devices and Credentials” section on page 30-1.

Field Descriptions for Device Discovery

This section includes the following field descriptions for the Device Discovery feature:

- Device Discovery Content Pane, page 29-12
- Related Fields, page 29-14

Device Discovery Content Pane

Table 29-1  Shallow Discovery Content Pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin&gt; Data Sources &gt;Fabric</td>
<td></td>
</tr>
<tr>
<td>Fabric Name</td>
<td>Name of the Fabric.</td>
</tr>
<tr>
<td>Seed Switch</td>
<td>The IP address of the fabric’s seed switch. IPv4 address of the first device that you want to discover. Valid entries are in dotted decimal format.</td>
</tr>
<tr>
<td>Status</td>
<td>• managed</td>
</tr>
<tr>
<td></td>
<td>• unmanaged</td>
</tr>
<tr>
<td></td>
<td>• managedContinuously</td>
</tr>
<tr>
<td>SNMPv3/SSH</td>
<td>True if the fabric is using SNMPv3/SSH.</td>
</tr>
<tr>
<td>User/Cmnty</td>
<td>Name of the device user account/community that the DCNM-LAN server uses to access the device. The user account must have network-admin or vdc-admin privileges on the device.</td>
</tr>
<tr>
<td>Auth/Privacy</td>
<td>The authorization method used by the fabric.</td>
</tr>
<tr>
<td>Included VSAN List</td>
<td>The IP address of the included VSAN list that the fabric is limited by.</td>
</tr>
<tr>
<td>Excluded VSAN List</td>
<td>The IP address of the excluded VSAN list that the fabric is limited by.</td>
</tr>
<tr>
<td>Licensed</td>
<td>If the fabric is licensed or not.</td>
</tr>
<tr>
<td>Last Updated Time</td>
<td>The last updated time of the fabric.</td>
</tr>
</tbody>
</table>

Admin> Data Sources> LAN


Table 29-1 **Shallow Discovery Content Pane**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovery Task</td>
<td>The discovery task name of LAN.</td>
</tr>
<tr>
<td>Max Hops from Seed</td>
<td>The max hops from seed switch to be discovered.</td>
</tr>
<tr>
<td>Switch List</td>
<td>The IP address or string of the switch list.</td>
</tr>
<tr>
<td>FWSM IP Address</td>
<td>The FWSM IP address discovered.</td>
</tr>
<tr>
<td>Switch</td>
<td>The seed switch of the task.</td>
</tr>
<tr>
<td>Managed</td>
<td>True if the LAN discovery task is managed.</td>
</tr>
<tr>
<td>SNMP Status</td>
<td>Whether or not the SNMP is enabled.</td>
</tr>
<tr>
<td>Last Updated Time</td>
<td>The last updated time of the LAN.</td>
</tr>
<tr>
<td>Group</td>
<td>Which of the LAN group does the switches belong to.</td>
</tr>
<tr>
<td>SNMPv3/SSH</td>
<td>True if SNMPv3/SSH is used.</td>
</tr>
<tr>
<td>User/Cmnty</td>
<td>Name of the device user account that the DCNM-LAN server uses to access the device. The user account must have network-admin or vdc-admin privileges on the device. By default, this field is blank.</td>
</tr>
<tr>
<td>Auth/Privacy</td>
<td>The authorization method used by the LAN.</td>
</tr>
</tbody>
</table>

**Admin> Data Sources> VMWare**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>The server name of the VMWare.</td>
</tr>
<tr>
<td>Managed</td>
<td>True if the remote device is managed.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the server.</td>
</tr>
<tr>
<td>User</td>
<td>Name of the device user account that the DCNM-LAN server uses to access the device. The user account must have network-admin or vdc-admin privileges on the device.</td>
</tr>
<tr>
<td>Last Updated Time</td>
<td>The last updated time of the virtual machine.</td>
</tr>
</tbody>
</table>

**Admin> Data Sources> SMI-S Storage**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor</td>
<td>The vendor of the storage device.</td>
</tr>
<tr>
<td>Version</td>
<td>The version information of the storage device.</td>
</tr>
<tr>
<td>Provider URL</td>
<td>The URL of the provider.</td>
</tr>
<tr>
<td>Name Space</td>
<td>The name space of the storage.</td>
</tr>
<tr>
<td>Interop Name Space</td>
<td>The interop name space of the storage.</td>
</tr>
<tr>
<td>Port</td>
<td>The port used to access the storage.</td>
</tr>
<tr>
<td>Secure</td>
<td>The secure information of the storage.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the storage.</td>
</tr>
<tr>
<td>Discovery Status</td>
<td>The discovery status of the storage.</td>
</tr>
<tr>
<td>Last Updated Time</td>
<td>The last updated time of the storage.</td>
</tr>
</tbody>
</table>
Table 29-2  

<table>
<thead>
<tr>
<th>Field Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>History of Discovery</strong></td>
<td></td>
</tr>
<tr>
<td>Task ID</td>
<td>Display only. Number assigned to the discovery task. The task ID indicates the order in which discovery tasks occurred.</td>
</tr>
<tr>
<td>Owner</td>
<td>Display only. DCNM-LAN server user account used to start the discovery task.</td>
</tr>
<tr>
<td>Seed Device IP Address</td>
<td>Display only. IPv4 address of the seed device.</td>
</tr>
<tr>
<td>Discovered Time</td>
<td>Display only. Date and time of the most recent update to the Status field.</td>
</tr>
<tr>
<td>Reason</td>
<td>Display only. Why the discovery task was created.</td>
</tr>
</tbody>
</table>
| Status | Display only. State of the discovery task. Valid values are as follows:  
  - In progress—The discovery tasks are ongoing.  
  - Successful—The discovery task completed without errors.  
  - Failed—The discovery task completed with errors. |
| **Task Based Discovery** | |
| Name | Display only. The name of the task. |
| Switches | Display only. The devices under the single task. |
| Managed | Display only. Show if the task is managed by DCNM. |
| SNMP | Display only. SNMP status can be different as below:  
  - ok—The device is accessible/reachable at current time.  
  - Last Seen—The time when the device was last reachable. Last Seen will be in that state for few minutes, after which it will show up as Discovery Timeout.  
  - Discovery Timeout—The device is not accessible/reachable because of discovery timeout. |
| SSH/Telnet | Display only. Status of the discovery task.  
  - ENABLE DEEP DISCOVERY—Deep discovery is not enabled.  
  - UNMANAGED (Connection Failure)—Connection to the device by SSH/Telnet failed.  
  - UNMANAGED (Auth Failure)—Authentication of the device failed.  
  - DISCOVERING—The device is in the process of discovering. |

**Related Fields**

For information about fields that configure devices, see the “Administering Devices and Credentials” section on page 30-1.
Device System-Message Logging Level Reference

This section provides information about the minimum device logging-level requirements of DCNM-LAN. DCNM-LAN has logging-level requirements for only a subset of the logging facilities of supported devices. If a Cisco NX-OS logging facility is not specified in this section, DCNM-LAN does not have a requirement for that logging facility.

Note

DCNM-LAN provides automatic device logging-level support. For more information, see the Automatic Logging-Level Configuration Support, page 29-5.

This section provides the following topics that document DCNM-LAN minimum logging levels per supported device type:

- Cisco Nexus 7000 NX-OS Logging Levels per DCNM-LAN Feature, page 29-15
- Cisco Nexus 5000 NX-OS Logging Levels per DCNM-LAN Feature, page 29-16
- Cisco Nexus 4000 NX-OS Logging Levels per DCNM-LAN Feature, page 29-17
- Cisco Nexus 1000V NX-OS Logging Levels per DCNM-LAN Feature, page 29-18

Cisco Nexus 7000 NX-OS Logging Levels per DCNM-LAN Feature

Table 29-3 Cisco Nexus 7000 NX-OS Logging Levels per Cisco DCNM-LAN Feature

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 7000 NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAA</td>
<td>AAA</td>
<td>Yes</td>
<td>aaa</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>RADIUS</td>
<td>Yes</td>
<td>radius</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>TACACS+</td>
<td>No</td>
<td>tacacs+</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>Device Discovery</td>
<td>CDP</td>
<td>Yes</td>
<td>cdp</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>Topology</td>
<td>LLDP</td>
<td>No</td>
<td>lldp</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>DHCP snooping</td>
<td>DHCP snooping</td>
<td>No</td>
<td>dhcp</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>Dynamic ARP Inspection</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IP Source Guard</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dot1X</td>
<td>802.1X</td>
<td>No</td>
<td>dot1x</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>Ethernet Interfaces</td>
<td>Ethernet port manager</td>
<td>Yes</td>
<td>ethpm</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Traffic Storm Control</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gateway Load Balancing Protocol (GLBP)</td>
<td>GLBP</td>
<td>No</td>
<td>glbp</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Hot Standby Router Protocol (HSRP)</td>
<td>HSRP engine</td>
<td>No</td>
<td>hsrp</td>
<td>3</td>
<td>6</td>
</tr>
</tbody>
</table>
### Table 29-3  
Cisco Nexus 7000 NX-OS Logging Levels per Cisco DCNM-LAN Feature (continued)

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 7000 NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory</td>
<td>Module</td>
<td>Yes</td>
<td>module</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Platform</td>
<td>Yes</td>
<td>platform</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>System manager</td>
<td>Yes</td>
<td>sysmgr</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Object Tracking</td>
<td>Object tracking</td>
<td>Yes</td>
<td>track</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Port-Channel Interfaces</td>
<td>Port-channel interfaces</td>
<td>Yes</td>
<td>port-channel</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>Port security</td>
<td>Port security</td>
<td>No</td>
<td>port-security</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>SPAN</td>
<td>SPAN</td>
<td>Yes</td>
<td>monitor</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Spanning Tree</td>
<td>Spanning tree</td>
<td>Yes</td>
<td>spanning-tree</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>UDLD</td>
<td>UDLD</td>
<td>No</td>
<td>udl</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Virtual Device Contexts(VDCs)</td>
<td>VDC manager</td>
<td>Yes</td>
<td>vde_mgr</td>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>Virtual Port Channel (vPC)</td>
<td>VPC</td>
<td>No</td>
<td>vpc</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>VLAN Network Interfaces</td>
<td>Interface VLAN</td>
<td>No</td>
<td>interface-vlan</td>
<td>2</td>
<td>5</td>
</tr>
</tbody>
</table>

1. Minimum Cisco DCNM-LAN logging levels appear in **bold** text for Cisco Nexus 7000 NX-OS logging facilities that have a default logging level that is too low.

### Cisco Nexus 5000 NX-OS Logging Levels per DCNM-LAN Feature

### Table 29-4  
Cisco Nexus 5000 NX-OS Logging Levels per Cisco DCNM-LAN Feature

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 5000 NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAA</td>
<td>AAA</td>
<td>Yes</td>
<td>aaa</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>RADIUS</td>
<td>Yes</td>
<td>radius</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>TACACS+</td>
<td>No</td>
<td>tacacs+</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>Device Discovery</td>
<td>CDP</td>
<td>Yes</td>
<td>cdp</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>Topology</td>
<td>LLDP</td>
<td>No</td>
<td>lldp</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>Ethernet Interfaces</td>
<td>Ethernet port manager</td>
<td>Yes</td>
<td>ethpm</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Traffic Storm Control</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fabric Extender</td>
<td>FEX</td>
<td>Yes</td>
<td>fex</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Inventory</td>
<td>System manager</td>
<td>Yes</td>
<td>sysmgr</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Platform</td>
<td>Yes</td>
<td>pfm</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>NOHMS</td>
<td>Yes</td>
<td>nohms</td>
<td>2</td>
<td>2</td>
</tr>
</tbody>
</table>
### Table 29-4  
**Cisco Nexus 5000 NX-OS Logging Levels per Cisco DCNM-LAN Feature (continued)**

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 5000 NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port-Channel Interfaces</td>
<td>Port-channel interfaces</td>
<td>Yes</td>
<td>port-channel</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>SPAN</td>
<td>SPAN</td>
<td>Yes</td>
<td>monitor</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Spanning Tree</td>
<td>Spanning tree</td>
<td>Yes</td>
<td>spanning-tree</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Unidirectional Link Detection (UDLD)</td>
<td>UDLD</td>
<td>No</td>
<td>udld</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Virtual Port Channel</td>
<td>VPC</td>
<td>No</td>
<td>vpc</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>VLAN Network Interfaces</td>
<td>Interface VLAN</td>
<td>No</td>
<td>interface-vlan</td>
<td>2</td>
<td>5</td>
</tr>
</tbody>
</table>

1. Minimum Cisco DCNM-LAN logging levels appear in **bold** text for Cisco Nexus 5000 NX-OS logging facilities that have a default logging level that is too low.

### Cisco Nexus 4000 NX-OS Logging Levels per DCNM-LAN Feature

### Table 29-5  
**Cisco Nexus 4000 NX-OS Logging Levels per Cisco DCNM-LAN Feature**

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 4000 NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAA</td>
<td>AAA</td>
<td>Yes</td>
<td>aaa</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>RADIUS</td>
<td>RADIUS</td>
<td>Yes</td>
<td>radius</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>TACACS+</td>
<td>TACACS+</td>
<td>No</td>
<td>tacacs+</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>Device Discovery</td>
<td>CDP</td>
<td>Yes</td>
<td>cdp</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>Topology</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ethernet Interfaces</td>
<td>Ethernet port manager</td>
<td>Yes</td>
<td>ethpm</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Traffic Storm Control</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FIP Snooping</td>
<td>FIPSMS</td>
<td>Yes</td>
<td>fip-snooping</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>Inventory</td>
<td>System manager</td>
<td>Yes</td>
<td>sysmgr</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Link State Tracking</td>
<td>LST</td>
<td>No</td>
<td>lstsvc</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>Port-Channel Interfaces</td>
<td>Port-channel interfaces</td>
<td>Yes</td>
<td>port-channel</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>SPAN</td>
<td>SPAN</td>
<td>Yes</td>
<td>monitor</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Spanning Tree</td>
<td>Spanning tree</td>
<td>Yes</td>
<td>spanning-tree</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Unidirectional Link Detection (UDLD)</td>
<td>UDLD</td>
<td>No</td>
<td>udld</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>VLAN Network Interfaces</td>
<td>Interface VLAN</td>
<td>No</td>
<td>interface-vlan</td>
<td>2</td>
<td>5</td>
</tr>
</tbody>
</table>

1. Minimum Cisco DCNM-LAN logging levels appear in **bold** text for Cisco Nexus 4000 NX-OS logging facilities that have a default logging level that is too low.
Cisco Nexus 1000V NX-OS Logging Levels per DCNM-LAN Feature

Table 29-6  Cisco Nexus 1000V NX-OS Logging Levels per Cisco DCNM-LAN Feature

<table>
<thead>
<tr>
<th>Cisco DCNM-LAN Feature</th>
<th>Cisco Nexus 1000V NX-OS Logging Facility</th>
<th>Enabled by Default?</th>
<th>Logging Facility Keyword</th>
<th>Cisco NX-OS Default Logging Level</th>
<th>Minimum Cisco DCNM-LAN-Required Logging Level¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAA</td>
<td>AAA</td>
<td>Yes</td>
<td>aaa</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>RADIUS</td>
<td>Yes</td>
<td>radius</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>TACACS+</td>
<td>No</td>
<td>tacacs+</td>
<td>3</td>
<td>5</td>
</tr>
<tr>
<td>Device Discovery</td>
<td>CDP</td>
<td>Yes</td>
<td>cdp</td>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>Topology</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ethernet Interfaces</td>
<td>Ethernet port manager</td>
<td>Yes</td>
<td>ethpm</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Virtual Ethernet Interfaces</td>
<td>Ifmgr</td>
<td>Yes</td>
<td>ifmgr</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>VIM</td>
<td>Yes</td>
<td>vim</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Inventory</td>
<td>Module</td>
<td>Yes</td>
<td>module</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Platform</td>
<td>Yes</td>
<td>platform</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>System manager</td>
<td>Yes</td>
<td>sysmgr</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Virtual Switches</td>
<td>MSP</td>
<td>Yes</td>
<td>msp</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Port-Channel Interfaces</td>
<td>Port-channel interfaces</td>
<td>Yes</td>
<td>port-channel</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>Port Profiles</td>
<td>Port profile</td>
<td>Yes</td>
<td>port-profile</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>VMS</td>
<td>Yes</td>
<td>vms</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>SPAN</td>
<td>SPAN</td>
<td>Yes</td>
<td>monitor</td>
<td>3</td>
<td>6</td>
</tr>
</tbody>
</table>

¹ Minimum Cisco DCNM-LAN logging levels appear in bold text for Cisco Nexus 1000V NX-OS logging facilities that have a default logging level that is too low.

Additional References for Device Discovery

For additional information related to device discovery, see the following sections:

- Related Documents, page 29-18
- Standards, page 29-19

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device and Credentials</td>
<td>Chapter 30, &quot;Administering Devices and Credentials&quot;</td>
</tr>
<tr>
<td>Cisco NX-OS XML management interface</td>
<td>Cisco NX-OS XML Interface User Guide</td>
</tr>
</tbody>
</table>
Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>NETCONF protocol over the Secure Shell (SSH)</td>
<td>RFC 4742</td>
</tr>
</tbody>
</table>

Feature History for Device Discovery

Table 29-7 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovery of various supported devices</td>
<td>5.2(2a)</td>
<td>Support was added for this feature.</td>
</tr>
<tr>
<td>LLDP discovery</td>
<td>5.0(2)</td>
<td>Support was added for this feature.</td>
</tr>
<tr>
<td>Fibre Channel discovery</td>
<td>5.0(2)</td>
<td>Support was added for this feature.</td>
</tr>
<tr>
<td>Automatic logging-level configuration support</td>
<td>5.0(2)</td>
<td>Support was added for this feature.</td>
</tr>
</tbody>
</table>
Administering Devices and Credentials

This chapter describes how to administer Cisco NX-OS devices and the credentials that are used by the Cisco Data Center Network Manager for LAN (DCNM-LAN) server to authenticate itself to the devices.

The Devices and Credentials feature allows you to administer the management state of devices. If the managed physical device supports virtual device contexts (VDCs), Cisco DCNM represents each VDC as a device. If you need to retrieve the running configuration and status information of a single VDC on a physical device with multiple VDCs, rather than performing device discovery for all the VDCs on the physical device, you can use the Devices and Credentials feature to rediscover the single device that represents the changed VDC.

Cisco DCNM also supports the ability to secure each VDC with different credentials. Cisco DCNM allows you to configure unique credentials for each discovered device or to use default credentials when you do not configure unique credentials for a device.

This chapter includes the following sections:

- Information About Devices and Credentials, page 30-1
- Licensing Requirements for Devices and Credentials, page 30-3
- Prerequisites for Administering Devices and Credentials, page 30-3
- Guidelines and Limitations for Devices and Credentials, page 30-3
- Configuring Devices and Credentials, page 30-3
- Viewing Device Credentials and Status, page 30-7
- Field Descriptions for Devices and Credentials, page 30-8
- Additional References for Devices and Credentials, page 30-9
- Feature History for Devices and Credentials, page 30-10

Information About Devices and Credentials

This section includes the following topics:

- Devices, page 30-2
- Credentials, page 30-2
- Device Status, page 30-2
- VDC Support, page 30-2
Devices

The Devices and Credentials feature allows you to administer the management state of devices. If the managed physical device supports virtual device contexts (VDCs), DCNM-LAN represents each VDC as a device. If you need to retrieve the running configuration and status information of a single VDC on a physical device with multiple VDCs, rather than performing device discovery for all the VDCs on the physical device, you can use the Devices and Credentials feature to rediscover the single device that represents the changed VDC.

Credentials

Devices and Credentials supports the ability to secure each managed device with different credentials. DCNM-LAN allows you to configure unique credentials for each discovered device or use default credentials when you do not configure unique credentials for a device. If some managed devices share the same credentials but others do not, you can configure unique credentials for some devices and configure the default credentials with the credentials that are shared by some of the managed devices.

Devices and Credentials associates a unique set of device credentials with each DCNM-LAN server user which means that the accounting logs on managed devices reflect the actions of each DCNM-LAN server user. If you log into the DCNM-LAN client as a user who does not have device credentials configured, the DCNM-LAN client prompts you to configure device credentials for the user account.

If support for accounting is not important to your organization, you must still configure each DCNM-LAN server user with device credentials, even if the credentials specified for each user are the same.

Device Status

The Devices and Credentials feature shows the status each device. The possible status are as follows:

- Managed—DCNM-LAN can connect to the device using Secure Shell (SSH), configure the running configuration of the device, and retrieve logs and other data from it. This status is possible only for devices that run a supported release of Cisco NX-OS and that are configured properly to support discovery by DCNM-LAN. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.
- Unmanaged—DCNM-LAN does not manage the device or monitor the status of the device.
- Unreachable—DCNM-LAN cannot connect to the device, which was a managed device prior to becoming unreachable. Common causes for this status are as follows:
  - A network issue is preventing the DCNM-LAN server from contacting the device.
  - SSH is disabled on the device.
  - All terminal lines on the device are in use.

VDC Support

For devices that support VDCs, DCNM-LAN treats each VDC on a physical device as a separate device; therefore, DCNM-LAN can maintain unique credentials for each VDC on a device. DCNM-LAN tracks the status of each VDC separately, as well.
Licensing Requirements for Devices and Credentials

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Device and Credentials requires no license. Any feature not included in a license package is bundled with the Cisco DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 5.x</em>.</td>
</tr>
</tbody>
</table>

Prerequisites for Administering Devices and Credentials

Performing device discovery with the Devices and Credentials feature has the following prerequisites:

- The DCNM-LAN server must be able to connect to a device that you want to discover.
- Cisco NX-OS devices must be running a supported release of Cisco NX-OS. For information about supported releases of Cisco NX-OS, see the *Cisco DCNM Release Notes, Release 7.x*.
- The Cisco NX-OS device must have the minimal configuration that is required to enable device discovery to succeed. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.

Guidelines and Limitations for Devices and Credentials

The Devices and Credentials feature has the following configuration guidelines and limitations:

- Discovering a device by using the Devices and Credentials feature does not support CDP-based discovery of neighboring devices. To use CDP-based discovery, see the “Administering Device Discovery” section on page 29-1.
- Be careful when you change the default credentials or device-specific credentials. Incorrect credentials prevent DCNM-LAN from managing devices.

Configuring Devices and Credentials

This section includes the following topics:

- Configuring Default Device Credentials, page 30-3
- Clearing Default Device Credentials, page 30-4
- Configuring Unique Credentials for a Device, page 30-5
- Clearing Unique Credentials for a Device, page 30-6

Configuring Default Device Credentials

You can configure the default credentials, which DCNM-LAN uses to authenticate itself when it connects to discovered Cisco NX-OS devices. DCNM-LAN uses the default device credentials to communicate with each discovered device that you have not configured with unique device credentials.
Device credentials are unique for each DCNM-LAN server user.

**BEFORE YOU BEGIN**

Determine what the default device credentials should be. All Cisco NX-OS devices that DCNM-LAN uses the default credentials to communicate with must have a network administrator account configured with a username and password that are identical to the default credentials that you configure in DCNM-LAN.

We recommend that you use a strong password. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **DCNM Server Administration > Devices and Credentials**. The Default Credentials area appears in the Contents pane, above the Devices area, which lists the discovered devices.

**Step 2** In the User Name field, enter the username for the default credentials. A valid username can be 1 to 32 characters. Valid characters are numbers, symbols, and case-sensitive letters.

We recommend that you use a strong password. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

**Step 3** To the right of the Password field, click the down-arrow button.

**Step 4** In the Password field and the Confirm Password field, enter the password for the default credentials. Valid passwords are numbers, symbols, and case-sensitive letters.

Cisco NX-OS supports passwords that are a maximum of 64 characters.

**Step 5** Click **OK**.

**Step 6** From the menu bar, choose **File > Deploy** to apply your changes to the DCNM-LAN server.

**RELATED TOPICS**

- Clearing Default Device Credentials, page 30-4
- Configuring Unique Credentials for a Device, page 30-5
- Clearing Unique Credentials for a Device, page 30-6

**Clearing Default Device Credentials**

You can clear the default device credentials.
If you clear the default device credentials, DCNM-LAN can connect to discovered devices only if you have configured unique credentials for each managed device.

BEFORE YOU BEGIN

If you intend to use DCNM-LAN without default device credentials, you should ensure that DCNM-LAN is configured with unique device credentials for each discovered device before you perform this procedure. For more information, see the “Configuring Unique Credentials for a Device” section on page 30-5.

DETAILED STEPS

Step 1: From the Feature Selector pane, choose **DCNM Server Administration > Devices and Credentials**. The Default Credentials area appears in the Contents pane, above the Devices area, which lists the discovered devices.

Step 2: In the Default Credentials area, click **Clear**. The User Name field and the Password field clear.

Step 3: From the menu bar, choose **File > Deploy** to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring Default Device Credentials, page 30-3
- Configuring Unique Credentials for a Device, page 30-5
- Clearing Unique Credentials for a Device, page 30-6
- Administering Device Discovery, page 29-1

Configuring Unique Credentials for a Device

You can configure credentials that are unique to a discovered device. When unique credentials exist for a discovered device, DCNM-LAN uses them when it connects to the device rather than using the default device credentials.

Note: Device credentials are unique for each DCNM-LAN server user.

BEFORE YOU BEGIN

Determine the username and password for a network administrator user account on the discovered device.
Note: We recommend that you use a strong password. Common guidelines for strong passwords include a minimum password length of eight characters and at least one letter, one number, and one symbol. For example, the password Re1Ax@h0m3 has ten characters and contains uppercase and lowercase letters in addition to one symbol and three numbers.

DETAILED STEPS

**Step 1**
From the Feature Selector pane, choose **DCNM Server Administration > Devices and Credentials**. The discovered devices appear in the Devices area of the Contents pane.

**Step 2**
In the User Credentials column for the device, double-click the entry and then click the down-arrow button.

**Step 3**
In the User Name field, enter the username. Valid usernames are between 1 and 32 characters. Valid characters are numbers, symbols, and case-sensitive letters.

Note: Cisco NX-OS supports usernames that are a maximum of 28 characters.

**Step 4**
In the Password field and the Confirm Password field, enter the password. Valid passwords are numbers, symbols, and case-sensitive letters.

Note: Cisco NX-OS supports passwords that are a maximum of 64 characters.

**Step 5**
Click **OK**.

**Step 6**
From the menu bar, choose **File > Deploy** to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring Default Device Credentials, page 30-3
- Clearing Default Device Credentials, page 30-4
- Clearing Unique Credentials for a Device, page 30-6
- Administering Device Discovery, page 29-1

Clearing Unique Credentials for a Device

You can clear unique credentials for a discovered device.

Note: If you clear the unique credentials for a discovered device, DCNM-LAN uses the default credentials to connect to the device.
BEFORE YOU BEGIN

If you intend to operate DCNM-LAN without unique credentials for the device, you should ensure that DCNM-LAN is configured with default device credentials before you perform this procedure. For more information, see the “Configuring Default Device Credentials” section on page 30-3.

DETAILED STEPS

<table>
<thead>
<tr>
<th>Step 1</th>
<th>From the Feature Selector pane, choose <strong>DCNM Server Administration &gt; Devices and Credentials</strong>. Discovered devices appear in the Devices area of the Contents pane.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>In the User Credentials column for the device, double-click the entry and then click the down-arrow button.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the User Name field, delete all text.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Password field, delete all text.</td>
</tr>
<tr>
<td>Step 5</td>
<td>In the Confirm Password field, delete all text.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Step 7</td>
<td>From the menu bar, choose <strong>File &gt; Deploy</strong> to apply your changes to the DCNM-LAN server.</td>
</tr>
</tbody>
</table>

RELATED TOPICS

- Configuring Default Device Credentials, page 30-3
- Clearing Default Device Credentials, page 30-4
- Configuring Unique Credentials for a Device, page 30-5
- Administering Device Discovery, page 29-1

Viewing Device Credentials and Status

To view the status for devices and whether credentials are configured for the device, from the Feature Selector pane, choose **DCNM Server Administration > Devices and Credentials**.

The default credentials appears in the Default Credentials area in the Contents pane. Information about devices, including credentials and status, appear in the Devices area in the Contents pane.

The Reason field provides a brief message that explains the device status. The following table provides information about how to resolve the issue indicated by the message.

<table>
<thead>
<tr>
<th>Reason</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Success</td>
<td>Not applicable. DCNM-LAN is managing the device.</td>
</tr>
<tr>
<td>Authentication failure</td>
<td>Ensure that the credentials are correct for the device. Ensure that DCNM-LAN can reach the device.</td>
</tr>
<tr>
<td>Unsupported platform</td>
<td>Verify that the device is a supported platform and that it is running a supported release of Cisco NX-OS. For information about supported platforms and Cisco NX-OS releases, see the <em>Cisco DCNM Release Notes, Release 7.x</em>.</td>
</tr>
</tbody>
</table>
Field Descriptions for Devices and Credentials

For information about the fields that appear, see the “Field Descriptions for Devices and Credentials” section on page 30-8.

### Field Descriptions for Devices and Credentials

This section includes the following field descriptions for Devices and Credentials:
- **Device and Credentials Content Pane**, page 30-8

#### Device and Credentials Content Pane

<table>
<thead>
<tr>
<th>Reason</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device sync up failure</td>
<td>Cisco Nexus 7000 Series devices only. The sequence numbers of accounting and system message log messages are not in a proper format. Clear the log files on the device and discover the device again.</td>
</tr>
<tr>
<td>Unmanaged manually</td>
<td>A DCNM-LAN user changed the device status to Unmanaged. Discover the device again.</td>
</tr>
<tr>
<td>Error when executing database query</td>
<td>Discover the device again. If the error reoccurs, clean the DCNM-LAN database. For more information about cleaning the database, see Chapter 37, “Maintaining the Cisco DCNM-LAN Database.”</td>
</tr>
<tr>
<td>Auto synchronization for device is disabled by user</td>
<td>Discover the device again.</td>
</tr>
<tr>
<td>Logging levels required by DCNM-LAN are not configured on the device</td>
<td>Discover the device again. For more information, see the “Automatic Logging-Level Configuration Support” section on page 29-5.</td>
</tr>
<tr>
<td>Error in SSH connection</td>
<td>Ensure that SSH is enabled on the device and that it is functioning properly. Discover the device again.</td>
</tr>
<tr>
<td>Unreachable</td>
<td>Ensure that you specify the correct IP address for the device. Ensure that DCNM-LAN can contact the device. Discover the device again.</td>
</tr>
<tr>
<td>Discovery failed because server node stopped/crashed</td>
<td>Discover the device again.</td>
</tr>
<tr>
<td>Syslog messages logging disabled on device</td>
<td>Discover the device again.</td>
</tr>
</tbody>
</table>

For information about the fields that appear, see the “Field Descriptions for Devices and Credentials” section on page 30-8.

### Table 30-1 - Device and Credentials Content Pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Credentials</td>
<td></td>
</tr>
<tr>
<td>User Name</td>
<td>Name of the Cisco NX-OS device user account that the DCNM-LAN server uses to access any device that it is discovering or that it is managing. On the device, the user account must be assigned to the network-admin or vdc-admin role. By default, this field is blank.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The information in the User Credentials field in the Devices area overrides the information in the Default Credentials section.</td>
</tr>
</tbody>
</table>
Table 30-1  Device and Credentials Content Pane (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Devices</strong></td>
<td></td>
</tr>
<tr>
<td>IP Address</td>
<td>Display only. IPv4 address of the Cisco NX-OS device.</td>
</tr>
<tr>
<td>Name</td>
<td>Display only. Name of the Cisco NX-OS device.</td>
</tr>
<tr>
<td>User Credentials</td>
<td>The Cisco NX-OS user account that DCNM-LAN uses to connect to the Cisco NX-OS device.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If you configure this field, DCNM-LAN uses the user account that you configure when it connects to the device. If this field is blank, DCNM-LAN uses the user account specified in the Default Credentials area. By default, this field is blank.</td>
</tr>
<tr>
<td>Status</td>
<td>Display only. Whether the DCNM-LAN server can connect to and configure the device. Valid values are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Managed—The DCNM-LAN server can configure the device.</td>
</tr>
<tr>
<td></td>
<td>• Unmanaged—The DCNM-LAN server cannot configure the device.</td>
</tr>
<tr>
<td></td>
<td>• Unreachable—The DCNM-LAN server cannot reach the device.</td>
</tr>
<tr>
<td>Reason</td>
<td>Display only. Provides a brief explanation for the device status. For more information, see the “Viewing Device Credentials and Status” section on page 30-7.</td>
</tr>
</tbody>
</table>

Additional References for Devices and Credentials

For additional information related to the Devices and Credentials feature, see the following sections:

- Related Documents, page 30-9
- Standards, page 30-9

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco NX-OS XML management interface</td>
<td>Cisco NX-OS XML Interface User GuideTitle may change</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>NETCONF protocol over the Secure Shell (SSH)</td>
<td>RFC 4742</td>
</tr>
</tbody>
</table>
Feature History for Devices and Credentials

Table 30-2 lists the release history for this feature.

Table 30-2 Feature History for Devices and Credentials

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reason field</td>
<td>5.0(2)</td>
<td>The Reason field was added to the Devices and Credentials feature.</td>
</tr>
</tbody>
</table>
Administering Auto-Synchronization with Devices

This chapter describes how to administer the Auto-Synchronization with Devices feature in Cisco Data Center Network Manager for LAN (DCNM-LAN).

Auto-synchronization allows the Cisco DCNM server to ensure that configuration and status information about managed devices is current. The Cisco DCNM server creates a poller process for each managed device. A poller process periodically retrieves system and accounting logs from a device. Cisco DCNM uses the information retrieved by poller processes to update its configuration and status information about polled devices. When you choose Auto Synchronization with Devices on the Feature Selector, the Contents pane displays all the poller instances that are running for different devices and allows you to control each.

You can also use the Auto-Synchronization with Devices feature to delete unwanted event data on demand or automatically.

This chapter includes the following sections:

- Information About Auto-Synchronization with Devices, page 31-1
- Licensing Requirements for Auto-Synchronization with Devices, page 31-2
- Prerequisites for Auto-Synchronization with Devices, page 31-2
- Guidelines and Limitations for Auto-Synchronization with Devices, page 31-3
- Configuring Device Auto-Synchronization, page 31-3
- Viewing the Status of Auto-Synchronization Pollers, page 31-9
- Field Descriptions for Auto Synchronization with Devices, page 31-9
- Additional References, page 31-11
- Feature History for Auto-Synchronization with Devices, page 31-11

Information About Auto-Synchronization with Devices

The Auto Synchronizing with Devices feature ensures that the Cisco Data Center Network Manager for LAN (DCNM-LAN) server has current configuration and status information about managed devices. The DCNM-LAN server creates one poller process for each device to retrieve the system and accounting logs that this feature requires.

When you choose Auto Synchronization with Devices on the Feature Selector pane, the Contents pane shows information about each poller process and allows you to control them.
You can configure the length of time that DCNM-LAN waits before polling a device again. DCNM-LAN sets a default polling interval for each managed device. The default value varies by the type of device. The range of polling interval values is displayed when you begin editing the polling interval field for the device. For more information, see the “Configuring the Polling Interval” section on page 31-4.

DCNM-LAN polls devices concurrently; however, to avoid polling all devices simultaneously, DCNM-LAN begins polling devices in alphabetical device-name order and delays each polling process by a short, random amount of time.

This section includes the following topics:
- Virtualization Support, page 31-2

### Automatic and Manual Purging of Event Data

You can use the Auto-Synchronization with Devices feature to delete unwanted event data. DCNM-LAN supports automatic purging of event data. You can configure the following aspects of automatic event data purging:
- Days of the week and time of day that automatic purging occurs.
- Whether DCNM-LAN determines which event data to purge by the age of the data or by a maximum number of database entries.
- Severity level of events.

You can also manually purge event data.

### Virtualization Support

DCNM-LAN treats each virtual device context (VDC) on a Cisco NX-OS device as a separate device. DCNM-LAN creates one poller process per device.

### Licensing Requirements for Auto-Synchronization with Devices

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCNM-LAN</td>
<td>Auto-Synchronization with Devices requires no license. Any feature not included in a license package is bundled with the DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 5.x</em>.</td>
</tr>
</tbody>
</table>

### Prerequisites for Auto-Synchronization with Devices

The Auto-Synchronization with Devices feature has the following prerequisites:
- The DCNM-LAN server must be able to connect to the devices.
- The Cisco NX-OS device must be running a supported version of Cisco NX-OS.
The Cisco NX-OS device must have the minimal configuration that is required to enable device discovery to succeed. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.

**Guidelines and Limitations for Auto-Synchronization with Devices**

The Auto-Synchronization with Devices feature has the following configuration guidelines and limitations:

- We recommend that you use the default device polling interval unless you encounter issues with synchronization due to slow responses from devices or to managing many devices. For more information, see the “Configuring the Polling Interval” section on page 31-4.
- For the Auto-Synchronization with Devices feature, the DCNM-LAN client does not automatically update the information shown in the Summary pane. To ensure that you are viewing current information, from the menu bar, choose *View > Refresh*.
- We recommend that you configure automatic purging of event data to ensure that the DCNM-LAN database size does not grow too large.

**Configuring Device Auto-Synchronization**

This section includes the following topics:

- Starting and Stopping a Poller, page 31-3
- Configuring the Polling Interval, page 31-4
- Synchronizing with a Device, page 31-5
- Deleting Data from the Events Database, page 31-5
- Enabling and Disabling Automatic Event Purging, page 31-6
- Configuring Automatic Event Purge Settings, page 31-7
- Purging Events Now, page 31-8

**Starting and Stopping a Poller**

You can start and stop a poller for a device. When a poller is stopped, auto-synchronization for the device does not occur.

**DETAILED STEPS**

**Step 1**

From the Feature Selector pane, choose *DCNM Server Administration > Auto Synchronization with Devices*.

A table of pollers appears in the Contents pane. Each row corresponds to a poller for a particular device. Devices are listed alphabetically. The Poller Status field displays messages about whether the poller is running or is stopped.

**Step 2**

Click to select the poller that you want to start or stop.
Configuring Device Auto-Synchronization

Chapter 31      Administering Auto-Synchronization with Devices

Step 3

Do one of the following:

- To start a poller, from the menu bar, choose Actions > Start Poller. The Poller Status field changes to Running.
- To stop a poller, from the menu bar, choose Actions > Stop Poller. The Poller Status field changes to Stopped.

You do not need to save your changes.

RELATED TOPICS

- Configuring the Polling Interval, page 31-4
- Synchronizing with a Device, page 31-5

Configuring the Polling Interval

You can configure how often the DCNM-LAN server synchronizes with managed devices. While synchronizing, the DCNM-LAN server fetches accounting and system logs from managed devices. This setting affects how frequently features in the DCNM-LAN client receive updated information about managed devices.

BEFORE YOU BEGIN

Determine how often you want DCNM-LAN to perform auto-synchronization with managed devices. Consider the following:

- How often device configurations are changed by means other than DCNM-LAN, such as using the command-line interface of a device. If changes by means other than DCNM-LAN are common, consider using a short polling interval.
- How important it is to your organization that DCNM-LAN be up to date with managed device configurations. If up-to-date configuration information is important to your organization, consider using a short polling interval.

DETAILED STEPS

Step 1

From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with Devices.

The polling intervals for all devices appear below the table of pollers in the Poller Setting tab.

Step 2

Select the device in the Platform column that you want to work with.

Step 3

In the Polling Interval field, enter the number of seconds between auto-synchronizations for the selected device. The range of polling interval values is displayed when you begin editing the Polling Interval field for the device.

Step 4

From the menu bar, choose File > Deploy to save the polling interval.

RELATED TOPICS

- Starting and Stopping a Poller, page 31-3
Synchronizing with a Device

You can make DCNM-LAN synchronize with a device manually when you do not want to wait for the next auto-synchronization to occur.

Note

If many configuration changes have occurred on the device since the last successful synchronization, consider performing device discovery instead of synchronization.

BEFORE YOU BEGIN

Ensure that you have either configured the device entry with unique device credentials or that DCNM-LAN can use the default device credentials to connect to the device. For more information, see the “Configuring Default Device Credentials” section on page 30-3.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with Devices.

A table of pollers appears in the Contents pane. Each row corresponds to a poller for a particular device. Devices are listed alphabetically.

Step 2 Click to select the device that you want DCNM-LAN to synchronize with.

Step 3 From the menu bar, choose Actions > Synchronize with Device.

Synchronization begins.

To determine when the synchronization has finished, watch the Last Sync Status column. Typically, synchronization with a device occurs in less than 5 minutes.

You do not need to save your changes.

RELATED TOPICS

- Starting and Stopping a Poller, page 31-3
- Configuring the Polling Interval, page 31-4

Deleting Data from the Events Database

You can delete data from the events database based on the exact age of the events. Events that you delete can no longer appear in the Event Browser or on a feature-specific Events tab.

Tip

If you want to delete events based on the number of events in the database, see the “Purging Events Now” section on page 31-8.
BEFORE YOU BEGIN

Determine the date and time of the newest events data that you want to delete. When you follow the steps in this procedure, DCNM-LAN deletes all events that are older than the date and time that you select.

DETAILED STEPS

**Step 1**  
From the Feature Selector pane, choose **DCNM Server Administration > Auto Synchronization with Devices**. 
The Events Database Administration tab appears in the Details pane, below the table of pollers.

**Step 2**  
From the Delete events older than drop-down list, choose the date and time of the newest event that you want to delete and click **OK**.

**Step 3**  
Click **Delete**.  
DCNM-LAN deletes all events older than the date and time that you specified.

RELATED TOPICS

- Enabling and Disabling Automatic Event Purging, page 31-6
- Configuring Automatic Event Purge Settings, page 31-7
- Purging Events Now, page 31-8

Enabling and Disabling Automatic Event Purging

You can enable or disable the automatic purging of events from the DCNM-LAN events database.

DETAILED STEPS

**Step 1**  
From the Feature Selector pane, choose **DCNM Server Administration > Auto Synchronization with Devices**. 
The Events Database Administration tab appears in the Details pane, below the table of pollers.

**Step 2**  
Under Auto Purge Settings, do one of the following:
- To enable automatic event purging, check **Enable Auto Purge**.
- To disable automatic event purging, uncheck **Enable Auto Purge**.

**Step 3**  
From the menu bar, choose **File > Deploy** to save your changes to the DCNM-LAN server.

RELATED TOPICS

- Deleting Data from the Events Database, page 31-5
- Configuring Automatic Event Purge Settings, page 31-7
- Purging Events Now, page 31-8
Configuring Automatic Event Purge Settings

You can configure when automatic event purging occurs and the criteria that DCNM-LAN uses to determine which events to purge.

BEFORE YOU BEGIN

Determine when you want automatic event purging to occur. We recommend that automatic event purging occur when DCNM-LAN usage is low.

If you perform backups of your DCNM-LAN databases, consider scheduling automatic event purging after database backups have occurred, to ensure that you retain a record of all events.

Determine what criteria you want DCNM-LAN to use to determine which events to purge. The criteria available are as follows:

- Age of event—DCNM-LAN can purge all events that are older than a specific number of days, weeks, or months.
- Number of events in the database—When the number of events in the database exceeds the maximum number that you specify, DCNM-LAN can purge the oldest events first until the maximum number is not exceeded.
- Severity of event—DCNM-LAN can purge events based on the severity level of the event.

If you enable both criteria, DCNM-LAN applies them independently of each other.

DETAILED STEPS

**Step 1**

From the Feature Selector pane, choose **DCNM Server Administration > Auto Synchronization with Devices**.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

**Step 2**

Under Purge Threshold, configure the criteria that DCNM-LAN uses to determine which events to purge. You can configure any of the criteria in the following table:

<table>
<thead>
<tr>
<th>Purge Criteria</th>
<th>How to Configure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Age of events</td>
<td>1. Check <strong>Data older than</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. From the first drop-down list, choose the number of days, weeks, or months.</td>
</tr>
<tr>
<td></td>
<td>3. From the second drop-down list, choose <strong>Days, Weeks, or Months</strong>, as needed.</td>
</tr>
<tr>
<td>Number of events in the database</td>
<td>1. Check <strong>Total Entries Exceed(0-2147483647)</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. In the box, enter the maximum number of entries that you want to allow in the events database.</td>
</tr>
<tr>
<td>Severity of event</td>
<td>1. Check <strong>Severity</strong>. The list of eight severity levels becomes available.</td>
</tr>
<tr>
<td></td>
<td>2. For each severity level that you want DCNM-LAN to use to determine whether to purge events, check the severity level.</td>
</tr>
</tbody>
</table>
Step 3  Under Auto Purge Settings, follow these steps to configure when you want automatic purging to occur:
   a. Check the days-of-the-week check boxes to specify which days of the week that you want automatic purging to occur.
   b. Use the Run at box to configure the exact time on the specified days that you want automatic event purging to occur.

Step 4  (Optional) If you want to enable automatic event purging, check Enable Auto Purge.

Step 5  From the menu bar, choose File > Deploy to save your changes to the DCNM-LAN server.

RELATED TOPICS

- Deleting Data from the Events Database, page 31-5
- Enabling and Disabling Automatic Event Purging, page 31-6
- Purging Events Now, page 31-8

Purging Events Now

You can purge event data on demand, using the automatic event purge settings to determine which events are purged. Events that you delete can no longer appear in the Event Browser or on a feature-specific Events tab.

Tip  If you want to delete events on demand, based on the exact age of the events, see the “Deleting Data from the Events Database” section on page 31-5.

BEFORE YOU BEGIN

Ensure that the automatic event purge settings are configured as needed. For more information, see the “Configuring Automatic Event Purge Settings” section on page 31-7.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose DCMN Server Administration > Auto Synchronization with Devices.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

Step 2  Under Purge, click Purge Now.

DCNM-LAN deletes events, using the automatic event purge settings to determine which events to purge.

RELATED TOPICS

- Deleting Data from the Events Database, page 31-5
- Enabling and Disabling Automatic Event Purging, page 31-6
- Configuring Automatic Event Purge Settings, page 31-7
Viewing the Status of Auto-Synchronization Pollers

To view the status of an auto-synchronization poller, from the Feature Selector pane, choose **DCNM Server Administration > Auto Synchronization with Devices**.

Poller status and information about the synchronization time and status appear in the Pollers area in the Contents pane.

**Table 31-1     Auto Synchronization Pollers Information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pollers</td>
<td></td>
</tr>
<tr>
<td>Last Refresh Time</td>
<td><em>Display only.</em> Date and time that the DCNM-LAN client updated information shown on the Contents pane.</td>
</tr>
<tr>
<td>Device</td>
<td><em>Display only.</em> Name and IP address of the device for the corresponding poller.</td>
</tr>
<tr>
<td>Poller Status</td>
<td><em>Display only.</em> Whether the poller is running or stopped. A running poller attempts to synchronize with the configuration and status information from its device at the frequency specified by the Device Polling Interval field.</td>
</tr>
<tr>
<td>Last Sync Time</td>
<td><em>Display only.</em> Date and time that the poller last retrieved system and accounting log data from the device.</td>
</tr>
<tr>
<td>Last Sync Status</td>
<td><em>Display only.</em> Whether the most recent synchronization attempt succeeded or failed. If synchronization failed, determine why DCNM-LAN failed to connect to the device. If necessary, rediscover the device.</td>
</tr>
</tbody>
</table>

Field Descriptions for Auto Synchronization with Devices

This section includes the following field descriptions for the Auto Synchronization with Devices feature:

- **Poller Setting Tab, page 31-9**
- **Events Database Administration Tab, page 31-10**

**Poller Setting Tab**

**Table 31-2     Auto Synchronization with Devices Poller Setting Tab**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pollers</td>
<td></td>
</tr>
<tr>
<td>Polling Interval</td>
<td>Number of seconds that all pollers wait before the next attempt to synchronize with a device. The range of polling interval values is displayed when you begin editing the Polling Interval field for the device.</td>
</tr>
<tr>
<td>Device</td>
<td><em>Display only.</em> Name and IP address of the device for the corresponding poller.</td>
</tr>
</tbody>
</table>
# Events Database Administration Tab

**Table 31-3  Events Database Administration Tab**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete events older than</td>
<td>Date and time of the newest event to be deleted from the events database. There is no default value for this field.</td>
</tr>
<tr>
<td>Purge Threshold</td>
<td></td>
</tr>
<tr>
<td>Data older than</td>
<td>Whether, during automatic event purging, DCNM-LAN deletes events that are older than the age specified in the drop-down lists located to the right of this check box. By default, this check box is unchecked. If you check the check box, the default age is 1 day.</td>
</tr>
<tr>
<td>Total Entries Exceed</td>
<td>Whether, during automatic event purging, DCNM-LAN deletes the oldest events until the number of events equals the number in the box located to the right of this check box. By default, this check box is unchecked. If you check the check box, the default number of event is 25,000.</td>
</tr>
<tr>
<td>Severity</td>
<td>Whether, during automatic event purging, DCNM-LAN deletes events with severity levels that are selected from the list of severity levels. By default, this check box is disabled.</td>
</tr>
<tr>
<td>Severity Levels</td>
<td>Severity levels of events that DCNM-LAN deletes during automatic event purging. The severity levels are available only if the Severity check box is checked. By default, all severity levels are disabled. The severity levels are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Emergency</td>
</tr>
<tr>
<td></td>
<td>• Alert</td>
</tr>
<tr>
<td></td>
<td>• Critical</td>
</tr>
<tr>
<td></td>
<td>• Error</td>
</tr>
<tr>
<td></td>
<td>• Warning</td>
</tr>
<tr>
<td></td>
<td>• Notification</td>
</tr>
<tr>
<td></td>
<td>• Informational</td>
</tr>
<tr>
<td></td>
<td>• Debugging</td>
</tr>
<tr>
<td>Auto Purge Settings</td>
<td></td>
</tr>
<tr>
<td>Enable Auto Purge</td>
<td>Whether automatic purging of event data is enabled. By default, this check box is disabled.</td>
</tr>
<tr>
<td>Run on</td>
<td>Days of the week that the automatic purging of events data occurs. By default, none of the check boxes are checked. If you check the Daily check box, the check boxes for the individual days of the week become unavailable.</td>
</tr>
<tr>
<td>Run at</td>
<td>Time of day that automatic purging of event data occurs, on the days of the week that automatic purging is enabled.</td>
</tr>
</tbody>
</table>
Additional References

For additional information related to administering Auto-Synchronization with Devices, see the following sections:

- Related Documents, page 31-11
- Standards, page 31-11

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Events</td>
<td>System Management Configuration Guide, Cisco DCNM for LAN, Release 6.x</td>
</tr>
<tr>
<td>Device discovery</td>
<td>Chapter 29, “Administering Device Discovery”</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

Feature History for Auto-Synchronization with Devices

Table 31-4 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-Synchronization with Devices</td>
<td>5.0(2)</td>
<td>No change from Release 4.2.</td>
</tr>
</tbody>
</table>
Administering Statistical Data Collection

This chapter describes how to administer Statistical Data Collection in the Cisco Data Center Network Manager for LAN (DCNM-LAN).

You can use the Statistical Data Collection feature to control the statistics monitoring processes that you have created for one of the many device configuration features that support statistics. You can also use the Statistical Data Collection feature to delete unwanted statistical data on demand or automatically.

This chapter includes the following sections:

- Information About Statistical Data Collection, page 32-1
- Licensing Requirements for Statistical Data Collection, page 32-2
- Prerequisites for Statistical Data Collection, page 32-2
- Guidelines and Limitations for Statistical Data Collection, page 32-3
- Configuring Statistical Data Collection, page 32-3
- Viewing the Status of Statistical Data Collectors, page 32-10
- Field Descriptions for Statistical Data Collection, page 32-10
- Additional References, page 32-11
- Feature History for Statistical Data Collection, page 32-12

Information About Statistical Data Collection

You can use the Statistical Data Collection feature to control the statistics monitoring processes that you have created for one of the many device configuration features that support statistics.

When you choose Statistical Data Collection on the Feature Selector pane, the Contents pane shows information about each statistical collection and allows you to control them. You can also use this feature to purge old data from the statistical database.

You can configure the length of time that Cisco Data Center Network Manager for LAN (DCNM-LAN) waits before retrieving statistical data from devices that it is monitoring. By default, DCNM-LAN retrieves statistical data from monitored devices every 30 seconds. You can increase the length of time to a maximum of 4 minutes. For more information, see the “Configuring Monitoring Preferences” section on page 16-17.

This section includes the following topics:

- Virtualization Support, page 32-2
Automatic and Manual Purging of Statistical Data

You can use the Statistical Data Collection feature to delete unwanted statistical data. DCNM-LAN supports automatic purging of statistical data. You can configure the following aspects of automatic statistical data purging:

- Days of the week and time of day that automatic purging occurs.
- Whether DCNM-LAN determines which statistical data to purge by the age of the data or by a maximum number of database entries.
- Whether DCNM-LAN deletes the statistical data entries that it purges or consolidates them into one entry.

You can also manually purge statistical data.

Virtualization Support

DCNM-LAN treats each virtual device context (VDC) on a Cisco NX-OS device as a separate device. Statistical data collections contain statistics from objects within devices.

Licensing Requirements for Statistical Data Collection

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Real-time monitoring requires no license. Cisco DCNM-LAN requires a LAN Enterprise license for the following features:</td>
</tr>
<tr>
<td></td>
<td>• Maintaining a history of statistical data</td>
</tr>
<tr>
<td></td>
<td>• Using overview charts</td>
</tr>
<tr>
<td></td>
<td>For information about obtaining and installing a Cisco DCNM-LAN Enterprise license, see the Cisco DCNM Installation and Licensing Guide, Release 5.x.</td>
</tr>
</tbody>
</table>

Prerequisites for Statistical Data Collection

Statistical data collection has the following prerequisites:

- The DCNM-LAN server must be able to connect to the devices.
- The system clocks for the DCNM-LAN server and DCNM-LAN client must be synchronized. If the system clocks are not synchronized, scheduling tasks for data collection may start or end at incorrect times.
- The Cisco NX-OS device must be running a supported version of Cisco NX-OS.
- The Cisco NX-OS device must have the minimal configuration that is required to enable device discovery to succeed. For more information, see the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.
Guidelines and Limitations for Statistical Data Collection

The Statistical Data Collection feature has the following configuration guidelines and limitations:

- Collections are created by starting monitoring for a new chart. For more information, see the “Starting Statistical Monitoring for a Chart” section on page 16-12.
- For the Statistical Data Collection feature, the DCNM-LAN client does not automatically update the information shown in the Summary pane. To ensure that you are viewing current information, from the menu bar, choose View > Refresh.
- When you start statistical monitoring for one or more charts and then close the DCNM-LAN client, a dialog box prompts you to decide whether to stop the collections or let them run. We recommend that you stop any unnecessary collections when you log out of the DCNM-LAN client. This practice conserves database space and decreases the server load.
- We recommend that you configure automatic purging of statistical data to ensure that the DCNM-LAN database size does not grow too large.
- You cannot always map the statistics data with the data collectors scheduler. However, a single scheduler can collect data for multiple graphs, and therefore, the statistics chart name need not match the data collector scheduler.

Configuring Statistical Data Collection

This section includes the following topics:

- Starting and Stopping Statistical Data Collection, page 32-3
- Using Modes in Statistics Charts, page 32-4
- Deleting Statistical Data from a Collection, page 32-5
- Deleting a Collection, page 32-6
- Deleting Data from the Statistics Database, page 32-6
- Enabling and Disabling Automatic Statistical Data Purging, page 32-7
- Configuring Automatic Statistical Data Purge Settings, page 32-8
- Purging Statistical Data Now, page 32-9

Starting and Stopping Statistical Data Collection

You can use the Statistical Data Collection feature to start and stop a statistical data collection process. Each collection process represents a statistical monitoring process that you created by starting monitoring for a device configuration feature.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. A table of statistical data collectors appears in the Contents pane. Each row corresponds to a collector for a particular device. The Status field displays whether the collector is running or is stopped.

Step 2 Click the collector that you want to start or stop.
Step 3  
Do one of the following:

- To start a collector, from the menu bar, choose **Actions > Start Collection**. The Status field changes to Running.
- To stop a collector, from the menu bar, choose **Actions > Stop Collection**. The Status field changes to Stopped.

You do not need to save your changes.

### Using Modes in Statistics Charts

You use statistics charts to toggle between the delta mode and the rate mode. The below table lists the features that contain statistics charts and delta mode/rate mode toggle button.

<table>
<thead>
<tr>
<th>Path</th>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interfaces &gt; Physical</td>
<td>Ethernet Interface</td>
</tr>
<tr>
<td>Interfaces &gt; Physical</td>
<td>Management Interface</td>
</tr>
<tr>
<td>Interfaces &gt; Logical</td>
<td>Loopback Interface</td>
</tr>
<tr>
<td>Interfaces &gt; Logical</td>
<td>Port Channel</td>
</tr>
<tr>
<td>Interfaces &gt; Logical</td>
<td>vPC</td>
</tr>
<tr>
<td>Switching</td>
<td>VLAN</td>
</tr>
<tr>
<td>Switching &gt; Spanning Tree</td>
<td>Rapid PVST+</td>
</tr>
<tr>
<td>Switching &gt; Spanning Tree</td>
<td>MST</td>
</tr>
<tr>
<td>Switching &gt; Fabricpath</td>
<td>ISIS Process</td>
</tr>
<tr>
<td>Switching &gt; Layer 2 Security</td>
<td>Port Security</td>
</tr>
<tr>
<td>Switching &gt; Layer 2 Security</td>
<td>ARP Inspection</td>
</tr>
<tr>
<td>Switching &gt; Layer 2 Security</td>
<td>DHCP Snooping</td>
</tr>
<tr>
<td>Switching &gt; Layer 2 Security</td>
<td>Traffic Storm Control</td>
</tr>
<tr>
<td>Switching &gt; Layer 2 Security</td>
<td>IGMP Snooping</td>
</tr>
<tr>
<td>Security</td>
<td>DOT1x</td>
</tr>
<tr>
<td>Security &gt; Access Control</td>
<td>IPv4 ACL</td>
</tr>
<tr>
<td>Security &gt; Access Control</td>
<td>IPv6 ACL</td>
</tr>
<tr>
<td>Security &gt; Access Control</td>
<td>MAC ACL</td>
</tr>
<tr>
<td>Security &gt; AAA</td>
<td>Server Groups</td>
</tr>
<tr>
<td>Inventory</td>
<td>Virtual Switch</td>
</tr>
</tbody>
</table>

### Detailed Steps

Step 1  
From the Feature Selector pane, choose the appropriate feature. For example, if you wanted to see statistics for the Ethernet feature, choose **Interfaces > Physical > Ethernet**.

The available devices appear in the Summary pane.
Step 2 From the Summary pane, double-click the device.
Step 3 From the Summary pane, double-click Slots.
Step 4 Click the interface.
Step 5 From the Details pane, choose the Statistics tab.
Step 6 In the toolbar, click New Chart and then from the menu bar drop-down list, choose the chart that you want to view. For example, if you wanted to see statistics for traffic, choose Traffic Statistics Chart.
Step 7 (Optional) To toggle between the statistics mode and the rate mode, click the button to the right of the Select Frequency drop-down list.

RELATED TOPICS

- Deleting Statistical Data from a Collection, page 32-5
- Deleting a Collection, page 32-6

Deleting Statistical Data from a Collection

You can delete statistical data from a collection. This feature allows you to delete all the data from a collection without affecting data from other collections and without deleting the collection itself. Each collection process represents a statistical monitoring process that you created by starting monitoring for a device configuration feature.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. A table of statistical data collectors appears in the Contents pane. Each row corresponds to a collector for a particular device. Devices are listed alphabetically. The Status field displays whether the collector is running or is stopped.
Step 2 Right-click the collection.
Step 3 From the menu bar, choose Actions > Delete Statistical Data.
DCNM-LAN deletes all statistical data from the collection.

RELATED TOPICS

- Starting and Stopping Statistical Data Collection, page 32-3
- Deleting a Collection, page 32-6
- Deleting Data from the Statistics Database, page 32-6
- Starting Statistical Monitoring for a Chart, page 16-12
Deleting a Collection

You can delete a collection of statistical data from a specific device. Each collection process represents a statistical monitoring process that you created by starting monitoring for a device configuration feature.

Note

If you want to delete all data from a collections rather than deleting the collection itself, perform the steps in the “Deleting Statistical Data from a Collection” section on page 32-5.

BEFORE YOU BEGIN

Determine which collection of data you want to delete.

DETAILED STEPS

Step 1

From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. A table of statistical data collectors appears in the Contents pane. Devices are listed alphabetically. Each row corresponds to a collection of statistical data for a particular device.

Step 2

Click the collection of data that you want to delete.

Step 3

From the menu bar, choose Actions > Delete Collection. The collection is deleted.

You do not need to save your changes.

RELATED TOPICS

- Starting and Stopping Statistical Data Collection, page 32-3
- Deleting Statistical Data from a Collection, page 32-5
- Deleting Data from the Statistics Database, page 32-6
- Starting Statistical Monitoring for a Chart, page 16-12

Deleting Data from the Statistics Database

You can delete statistical data from the statistics database.

Note

If you want to delete all data from a specific collection rather than deleting old data from all collections, perform the steps in the “Deleting a Collection” section on page 32-6.

BEFORE YOU BEGIN

Determine the date and time of the newest statistical data that you want to delete. When you follow the steps in this procedure, DCNM-LAN deletes all statistics that are older than the date and time that you select.
**DETAILED STEPS**

**Step 1**  
From the Feature Selector pane, choose [DCNM Server Administration > Statistical Data Collection](#).  
The Statistics Database area appears in the Contents pane, below the table of statistical data collectors.

**Step 2**  
From the Delete statistical data older than drop-down list, select the date and time of the newest statistics that you want to delete and click **OK**.  

**Step 3**  
Click **Delete**.  
DCNM-LAN deletes all statistics older than the date and time that you specified.

**RELATED TOPICS**

- Deleting Statistical Data from a Collection, page 32-5
- Deleting a Collection, page 32-6
- Enabling and Disabling Automatic Statistical Data Purging, page 32-7
- Configuring Automatic Statistical Data Purge Settings, page 32-8
- Purging Statistical Data Now, page 32-9

### Enabling and Disabling Automatic Statistical Data Purging

You can enable or disable the automatic purging of statistical data from the DCNM-LAN statistics database.

**DETAILED STEPS**

**Step 1**  
From the Feature Selector pane, choose [DCNM Server Administration > Statistical Data Collection](#).  
The Statistical Database Administration tab appears in the Details pane, below the table of statistical data collectors.

**Step 2**  
Under Auto Purge Settings, do one of the following:  
- To enable automatic statistical data purging, check **Enable Auto Purge**.  
- To disable automatic statistical data purging, uncheck **Enable Auto Purge**.

**Step 3**  
From the menu bar, choose **File > Deploy** to save your changes to the DCNM-LAN server.

**RELATED TOPICS**

- Deleting Data from the Statistics Database, page 32-6  
- Configuring Automatic Statistical Data Purge Settings, page 32-8  
- Purging Statistical Data Now, page 32-9
Configuring Automatic Statistical Data Purge Settings

You can configure when automatic statistical data purging occurs and the criteria that DCNM-LAN uses to determine which statistical data to purge.

BEFORE YOU BEGIN

Determine when you want automatic statistical data purging to occur. A good recommendation is that you configure automatic statistical data purging to occur when DCNM-LAN usage is low.

If you perform backups of your DCNM-LAN databases, consider scheduling automatic statistical data purging after database backups have occurred, to ensure that you retain a record of all statistical data.

Determine what criteria you want DCNM-LAN to use to determine which statistical data to purge. The two criteria available are as follows:

- Age of statistical data—DCNM-LAN can purge all statistical data entries that are older than a specific number of days, weeks, or months.
- Number of statistical data entries in the database—When the number of statistical data entries in the database exceeds the maximum number that you specify, DCNM-LAN can purge the oldest statistical data entries first until the maximum number is not exceeded.

If you enable both criteria, DCNM-LAN applies them independently of each other.

DETAILED STEPS

Step 1

From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

The Statistical Database Administration tab appears in the Details pane, below the table of statistical data collectors.

Step 2

Under Purge Threshold, configure the criteria that DCNM-LAN uses to determine which statistical data to purge. You can configure either or both of the criteria using the information in Table 32-1.

<table>
<thead>
<tr>
<th>Purge Criteria</th>
<th>How to Configure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Age of statistical data</td>
<td>1. Check Data older than.</td>
</tr>
<tr>
<td></td>
<td>2. From the first drop-down list, choose the number of days, weeks, or months.</td>
</tr>
<tr>
<td></td>
<td>3. From the second drop-down list, choose Days, Weeks, or Months, as needed.</td>
</tr>
<tr>
<td>Number of statistical data entries in the database</td>
<td>1. Check Stats. Entries Exceed(0-2147483647).</td>
</tr>
<tr>
<td></td>
<td>2. In the box, enter the maximum number of entries that you want to allow in the statistical database.</td>
</tr>
</tbody>
</table>

Step 3

Configure the action that you want DCNM-LAN to take on statistical database entries that meet the purge criteria. You can choose one of the following:
• **Delete**—DCNM-LAN deletes the database entries that meet the purge criteria.
• **Consolidate**—DCNM-LAN merges all statistical data entries that meet the purge criteria into one entry

**Step 4** Under Auto Purge Settings, follow these steps to configure when you want automatic purging to occur:

a. Check the days-of-the-week check boxes to specify which days of the week that you want automatic purging to occur.

b. Use the **Run at** box to configure the exact time on the specified days that you want automatic statistical data purging to occur.

**Step 5** (Optional) If you want to enable automatic statistical data purging, check **Enable Auto Purge**.

**Step 6** From the menu bar, choose **File > Deploy** to save your changes to the DCNM-LAN server.

**RELATED TOPICS**

• Deleting Data from the Statistics Database, page 32-6
• Enabling and Disabling Automatic Statistical Data Purging, page 32-7
• Purging Statistical Data Now, page 32-9

**Purging Statistical Data Now**

You can purge statistical data on demand, using the automatic statistical data purge settings to determine which statistical data are purged.

**Tip**

If you want to delete statistical data on demand, based on the exact age of the statistical data entries, see the “Deleting Data from the Statistics Database” section on page 32-6.

**BEFORE YOU BEGIN**

Ensure that the automatic statistical data purge settings are configured as needed. For more information, see the “Configuring Automatic Statistical Data Purge Settings” section on page 32-8.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **DCNM Server Administration > Statistical Data Collection**. The Statistical Database Administration tab appears in the Details pane, below the table of statistical data collectors.

**Step 2** Under Purge, click **Purge Now**.

DCNM-LAN deletes statistical data, using the automatic statistical data purge settings to determine which statistical data entries to purge.

**RELATED TOPICS**

• Deleting Data from the Statistics Database, page 32-6
Viewing the Status of Statistical Data Collectors

To view the status of statistical data collectors, from the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

Collector status and other information appear in the Statistical Data Collectors area in the Contents pane. For information about the fields that appear, see the “Field Descriptions for Statistical Data Collection” section on page 32-10.

Field Descriptions for Statistical Data Collection

This section includes the following field descriptions for the Statistical Data Collection feature:

- **Summary Pane**, page 32-10
- **Statistical Database Administration Tab**, page 32-11

Summary Pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Statistical Data Collectors</td>
<td><strong>Summary Pane</strong></td>
</tr>
<tr>
<td>Last Refresh Time</td>
<td>Display only. Date and time that the DCNM-LAN client updated information shown on the Content pane.</td>
</tr>
<tr>
<td>Collector ID</td>
<td>Display only. Name and IP address of the device for the corresponding poller.</td>
</tr>
<tr>
<td>Owner</td>
<td>Display only. Username of the DCNM-LAN user who started monitoring for the chart that corresponds to the collection.</td>
</tr>
<tr>
<td>Device</td>
<td>Display only. Name and IP address of the device that is providing the statistical data in the collection.</td>
</tr>
<tr>
<td>Objects</td>
<td>Display only. Description of the entity on the device that is providing the statistical data in the collection. For example, if the collection has statistical data for a rule that is assigned the sequence number 10 and is in an IPv4 ACL named acl-01, this field displays acl-01,seqNo=10. If the collection has data for the Ethernet 1/5 port, this field displays Ethernet1/5.</td>
</tr>
<tr>
<td>Collected Statistics</td>
<td>Display only. Type of statistical data in the collection. For example, if the collection has statistical data for a rule in an IPv4 ACL, this field displays IpAclAceMatchStatistics.</td>
</tr>
<tr>
<td>Status</td>
<td>Display only. Whether the collector is started or stopped.</td>
</tr>
</tbody>
</table>
### Table 32-3 Statistical Database Administration Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete statistical data older than</td>
<td>Date and time of the newest statistical data to be deleted from the statistics database. There is no default value for this field.</td>
</tr>
<tr>
<td>Purge</td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td>Whether automatic statistical data purging deletes or consolidates statistical data entries that trigger the purge threshold. Consolidation merges all statistical data entries that trigger the purge threshold into one entry.</td>
</tr>
<tr>
<td>Purge Threshold</td>
<td></td>
</tr>
<tr>
<td>Data older than</td>
<td>Whether, during automatic statistical data purging, DCNM-LAN deletes statistics entries that are older than the age specified in the drop-down lists located to the right of this check box. By default, this check box is unchecked. If you check the check box, the default age is 1 day.</td>
</tr>
<tr>
<td>Stat. Entries Exceed</td>
<td>Whether, during automatic statistical data purging, DCNM-LAN deletes the oldest statistics entries until the number of entries equals the number in the box located to the right of this check box. By default, this check box is unchecked. If you check the check box, the default number of event is 25,000.</td>
</tr>
<tr>
<td>Auto Purge Settings</td>
<td></td>
</tr>
<tr>
<td>Enable Auto Purge</td>
<td>Whether automatic purging of statistical data is enabled. By default, this check box is disabled.</td>
</tr>
<tr>
<td>Run on</td>
<td>Days of the week that automatic purging of statistical data occurs. By default, none of the check boxes are checked. If you check the Daily check box, the check boxes for the individual days of the week become unavailable.</td>
</tr>
<tr>
<td>Run at</td>
<td>Time of day that automatic purging of statistical data occurs, on the days of the week that automatic purging is enabled.</td>
</tr>
</tbody>
</table>

### Additional References

For additional information related to administering statistical data collection, see the following sections:

- Related Documents, page 32-12
- Standards, page 32-12
Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device discovery</td>
<td>Chapter 29, “Administering Device Discovery”</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

Feature History for Statistical Data Collection

Table 32-4 lists the release history for this feature.

Table 32-4  Feature History for Statistical Data Collection

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Statistical Data Collection</td>
<td>5.0(2)</td>
<td>No change from Release 4.2.</td>
</tr>
</tbody>
</table>
CHAPTER 33

Working With Threshold Rules

This chapter describes how to configure threshold rules using Cisco Data Center Network Manager for LAN (DCNM-LAN).

This chapter includes the following sections:

- Information About Threshold Rules, page 33-1
- Licensing Requirements for Threshold Rules, page 33-5
- Configuring Threshold Rules, page 33-5
- Additional References, page 33-9
- Feature History for Threshold Rules, page 33-9

Information About Threshold Rules

This section includes the following topics:

- Threshold Rules Overview, page 33-1
- Threshold Rule Examples, page 33-2

Threshold Rules Overview

DCNM-LAN provides a feature that you use to specify rising or falling threshold rules for sample variables in collected statistical data. Depending on the rule definition, a set of actions are performed by DCNM-LAN. You define the threshold rule on the Threshold Rules page, and you apply the threshold rule to the existing chart.

This section includes the following topics:

- Rising Threshold, page 33-2
- Falling Threshold, page 33-2
- Threshold Rule Properties, page 33-2
- Threshold Rule Actions, page 33-2
Rising Threshold

The rising threshold is the upper threshold for a sample variable. When the current sampled variable is greater than or equal to the specified threshold, a set of actions is performed.

Falling Threshold

The falling threshold is the lower threshold for a sample variable. When the current sampled variable is lower than or equal to the specified threshold a set of actions is performed.

Note
You can specify only one rising threshold and one falling threshold for a single sampled variable.

Threshold Rule Properties

Threshold rule properties are as follows:

- **Name**—Specifies the threshold rule name.
- **Frequency**—Specifies the number of times the sampled variable must cross a threshold before triggering any actions.
- **Period**—Specifies the interval of time the frequency is monitored.
- **Repeat**—Prevents the timer from resetting after triggering an action within the period.
- **Trend**—Specifies the rising or falling threshold.

Threshold Rule Actions

Threshold rule actions are as follows:

- Send an email or SMS to a mail server or mail to SMS gateway.
- Run a script on the server.
- Send an event to the current DCNM JMS channel.

Threshold Rule Examples

The granularity of a period is driven by the minimal interval of the collected data. Consequently, the period must be higher than that interval.

This section includes the following topics:

- Triggering an Action Each Time a Threshold is Crossed, page 33-2
- Triggering an Action Only Once in a Period When a Threshold is Crossed, page 33-3
- Triggering an Action Every Fourth Period When a Threshold is Crossed, page 33-4

Triggering an Action Each Time a Threshold is Crossed

To trigger an action each time a threshold is crossed, set properties as follows:
- Frequency—1
- Repeat—Yes

Figure 33-1 shows the trigger action when you set rule properties to the preceding values.

Figure 33-1  Trigger an Action Each Time a Threshold is Crossed

If the sampled variable crosses the threshold, an action is taken the first time it crosses the threshold. As a result, an action is performed each time the threshold is crossed.

Triggering an Action Only Once in a Period When a Threshold is Crossed

To trigger an action only once in a period when a threshold is crossed, set properties as follows:
- Frequency—1
- Period—300
- Repeat—No

Figure 33-2 shows the trigger action when you set rule properties to the preceding values.
Information About Threshold Rules

If the sampled variable crosses the threshold, an action is taken the first time it crosses the threshold. For the remaining 5 minutes, an action will not be taken. As a result, an action is performed only once during the specified period.

Triggering an Action Every Fourth Period When a Threshold is Crossed

To trigger an action every fourth period when a threshold is crossed, set properties as follows:

- Frequency — 4
- Period — 300
- Repeat — No

Figure 33-3 shows the trigger action when you set rule properties to the preceding values.

If the sampled variable crosses the threshold, an action is taken the fourth time it crosses the threshold. For the remaining 5 minutes, an action is not taken. As a result, an action is performed only once during the specified period.
Licensing Requirements for Threshold Rules

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>Threshold rules require no license.</td>
</tr>
</tbody>
</table>

Configuring Threshold Rules

You can create and apply threshold rules using the Threshold Rules feature. With this feature, you can create, delete, edit, view, and apply a rule to a chart.

The following sections provide more details about the feature:

- Creating Threshold Rules
- Deleting Threshold Rules
- Editing Threshold Rules
- Viewing Threshold Rules
- Applying a Threshold Rule to a Chart

This section includes the following topics:

- Creating Threshold Rules, page 33-5
- Deleting Threshold Rules, page 33-7
- Editing Threshold Rules, page 33-8
- Viewing Threshold Rules, page 33-8
- Applying a Threshold Rule to a Chart, page 33-8

Creating Threshold Rules

You can create threshold rules using DCNM-LAN.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **DCNM Server Administration > Threshold Rules**.

**Step 2** From the toolbar, choose **New**, and then choose **New Threshold Rule**.

The Details and Threshold Bindings tabs appear in the Details pane, with the Details tab open.

**Step 3** Create a threshold rule as follows:

- In the **Name** field, enter a name.
- In the **Description** field, enter a description of the threshold rule.

After you have entered a description, the Rising Threshold check box is automatically checked and the Threshold field in the Settings area is outlined in red.
Note: A field outlined in red indicates that an entry is required. A field outlined in yellow indicates that the entry is satisfactory.

c. In the Settings area, enter a value in the Threshold field.

Once you have entered a value, the three options in the Action area are outlined in red.
d. In the Action area, provide one of the following:

- Enter email addresses (delimited with commas)
- Select **Sent Event** to forward events to the DCNM-LAN Event Browser
- Enter a script name

The script receives all data regarding the crossed threshold. The script can be written in any programming language and saved in one of the directories of the system PATH.

Table 33-1 describes the available parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$1</td>
<td>Device name</td>
</tr>
<tr>
<td>$2</td>
<td>Threshold name</td>
</tr>
<tr>
<td>$3</td>
<td>Timestamp</td>
</tr>
<tr>
<td>$4</td>
<td>Severity</td>
</tr>
</tbody>
</table>
| $5        | Monitored metric that is a counter or a non-counter.  
  * When used as a counter, it represents a rate in metric units /second.  
  * When used as a non-counter, it represents an absolute in metric units. |
| $6        | Threshold for the monitored metric that is a counter or a non-counter.  
  * When used as a counter, it represents a rate in metric units /second.  
  * When used as a non-counter, it represents an absolute in metric units. |
| $7        | Trend type  
The possible values are:  
  * **rate**  
    which is a counter.  
  * **absolute**  
    which is a non-counter |
Chapter 33  Working With Threshold Rules

Configuring Threshold Rules

Note Ensure that the DCNM-LAN server is configured for an SMTP server. For more information about configuring the DCNM-LAN server, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.

e. (Optional) In the corresponding Settings and Action areas, configure a Falling Threshold.
f. (Optional) Click the Threshold Bindings tab to view bindings.
g. Click Deploy.
The rule is deployed.
When you exit DCNM-LAN and Save Pending Changes is checked in the Warning dialog box, click Yes to save the rule.

Deleting Threshold Rules

You can delete rules using DCNM-LAN.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Threshold Rules.
The rules appear in the Summary pane.

Step 2 From the Summary pane, right-click the appropriate rule.

Step 3 From the drop-down list, choose Delete Threshold Rule.
A warning dialog box appears and displays “Are you sure you want to delete?”

Step 4 Click Yes.
The rule is deleted.
Editing Threshold Rules

You can view threshold rules using DCNM-LAN.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose DCNM Server Administration > Threshold Rules.
        The rules appear in the Summary pane.

Step 2  Edit any appropriate areas.

Note  You cannot edit the Name field.

Viewing Threshold Rules

You can view threshold rules using DCNM-LAN.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose DCNM Server Administration > Threshold Rules.
        The rules appear in the Summary pane.

Step 2  Click on a rule to view it.

Applying a Threshold Rule to a Chart

You can apply threshold rules using DCNM-LAN.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose the appropriate feature. For example, if you wanted to see statistics for an Ethernet port, choose Interfaces > Physical > Ethernet.
        The available devices appear in the Summary pane.

Step 2  From the Summary pane, choose the appropriate device.

Step 3  Click the Statistics tab.

Step 4  In the toolbar, click New Chart and then from the drop-down list choose the chart that you want to view. For example, if you wanted to see statistics for traffic, choose Traffic Statistics Chart.

Step 5  In the chart toolbar, click Launch Threshold Setting.
Additional References

For additional information related to administering threshold rules, see the following sections:

- Related Documents, page 33-9
- Standards, page 33-9

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Events</td>
<td>System Management Configuration Guide, Cisco DCNM for LAN, Release 6.x</td>
</tr>
<tr>
<td>Statistical Data Collection</td>
<td>Chapter 32, “Administering Statistical Data Collection”</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

Feature History for Threshold Rules

Table 33-2 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Threshold Rules</td>
<td>5.2(0)</td>
<td>—</td>
</tr>
</tbody>
</table>
This chapter describes how to administer the DCNM-LAN Server Log Settings feature in Cisco Data Center Network Manager for LAN (DCNM-LAN).

The Cisco DCNM server maintains a log file of its operations. The log file contains information from Cisco DCNM features and server components.

Note

The DCNM Server Log Settings feature does not affect logging levels of Cisco NX-OS devices. Cisco DCNM does not support the configuration of device logging levels.

This chapter includes the following sections:

- Information About Administering DCNM-LAN Server Log Settings, page 34-1
- Licensing Requirements for Administering DCNM-LAN Server Log Settings, page 34-2
- Prerequisites for Administering DCNM-LAN Server Log Settings, page 34-3
- Guidelines and Limitations for Administering DCNM-LAN Server Log Settings, page 34-3
- Configuring DCNM-LAN Server Log Settings, page 34-3
- Viewing DCNM-LAN Server Log Settings, page 34-5
- Field Descriptions for DCNM-LAN Server Log Settings, page 34-5
- Additional References, page 34-7
- Feature History for DCNM-LAN Server Log Settings, page 34-7

Information About Administering DCNM-LAN Server Log Settings

The DCNM-LAN server maintains a log file of its operations. The log file contains information from DCNM-LAN features and server components.

Note

The DCNM-LAN Server Log Settings feature does not affect logging levels of Cisco NX-OS devices. DCNM-LAN does not support the configuration of device logging levels.

This section includes the following topics:

- Logging Levels, page 34-2
Logging Levels

The DCNM-LAN server supports a hierarchy of logging levels, ordered by the severity of log messages. Each level includes messages for that level in addition to all log messages from levels of higher severity. The logging levels, in order from the highest to the lowest severity, are as follows:

- Fatal Errors
- Errors
- Warnings
- Information
- Debugging
- Verbose

Log File and Location

The DCNM-LAN server writes server log messages to the sys.pipe file at the following location:

```
INSTALL_DIR\log
```

By default, when you install the DCNM-LAN server on Microsoft Windows Server, INSTALL_DIR is C:\Program Files\Cisco Systems\dcnm.

What would the default installation directory be for a Linux installation?

Virtualization Support

DCNM-LAN server logs do not contain log messages from Cisco NX-OS devices; therefore, this feature has no effect on virtualization support.

Licensing Requirements for Administering DCNM-LAN Server Log Settings

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM-LAN</td>
<td>DCNM-LAN Server Log Settings requires no license. Any feature not included in a license package is bundled with the Cisco DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 5.x</em>.</td>
</tr>
</tbody>
</table>
Prerequisites for Administering DCNM-LAN Server Log Settings

Administering DCNM-LAN server log settings has the following prerequisites:

- You should be familiar with a DCNM-LAN feature before you configure server log settings for it.

Guidelines and Limitations for Administering DCNM-LAN Server Log Settings

The Administering DCNM-LAN server log settings feature has the following configuration guidelines and limitations:

- Setting a logging level to a lower severity results in more messages in the log file.
- We recommend using the default logging settings unless you are troubleshooting an issue.
- When you are troubleshooting an issue, consider lowering the logging level severity of the affected feature or server component.
- After you resolve an issue, consider restoring the logging level of the affected feature or server component to a higher severity.

Configuring DCNM-LAN Server Log Settings

This section includes the following topics:

- Configuring the Default Logging Level, page 34-3
- Configuring a Unique Logging Level for a Feature or Server Component, page 34-4
- Configuring a Feature or Server Component to Use the Default Logging Level, page 34-4

Configuring the Default Logging Level

You can configure the default logging level for all DCNM-LAN features and server components.

BEFORE YOU BEGIN

Determine what the default logging level should be. For more information, see the “Logging Levels” section on page 34-2.

DETAILED STEPS

Step 1. From the Feature Selector pane, choose DCNM Server Administration > DCNM Server Log Settings. The log settings appear in the Contents pane.

Step 2. From the Default Logging Level drop-down list, choose the logging level.

Step 3. From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.
Configuring DCNM-LAN Server Log Settings

Chapter 34 Administering DCNM-LAN Server Log Settings

RELATED TOPICS

- Configuring a Unique Logging Level for a Feature or Server Component, page 34-4
- Configuring a Feature or Server Component to Use the Default Logging Level, page 34-4

Configuring a Unique Logging Level for a Feature or Server Component

You can configure a logging level of a feature or server component that is independent of the default logging level.

BEFORE YOU BEGIN

Determine what the logging level of the feature or service should be. For more information, see the “Logging Levels” section on page 34-2.

DETAILED STEPS

1. From the Feature Selector pane, choose DCNM Server Administration > DCNM Server Log Settings. The log settings appear in the Contents pane.
2. Find the feature or server component that you want to configure with a unique logging level.
3. Uncheck Default to the right of the feature or server component. The logging level drop-down list for the feature or server component becomes available.
4. From the logging level drop-down list, choose the logging level. For more information, see the “Logging Levels” section on page 34-2.
5. From the menu bar, choose File > Deploy to apply your changes to the DCNM-LAN server.

RELATED TOPICS

- Configuring the Default Logging Level, page 34-3
- Configuring a Feature or Server Component to Use the Default Logging Level, page 34-4

Configuring a Feature or Server Component to Use the Default Logging Level

You can configure a feature or server component to use the default logging level.

BEFORE YOU BEGIN

Ensure that the default logging level is appropriate for the feature or service. For more information, see the “Logging Levels” section on page 34-2.

DETAILED STEPS

1. From the Feature Selector pane, choose DCNM Server Administration > DCNM Server Log Settings. The log settings appear in the Contents pane.
**Viewing DCNM-LAN Server Log Settings**

To view DCNM-LAN server user accounts, from the Feature Selector pane, choose **DCNM Server Administration > DCNM Server Log Settings**.

The default logging level, feature logging settings, and server component logging settings appear in the Contents pane. For information about the fields that appear, see the “Field Descriptions for DCNM-LAN Server Log Settings” section on page 34-5.

**Field Descriptions for DCNM-LAN Server Log Settings**

This section includes the following field descriptions for DCNM-LAN server log settings:

- **DCNM-LAN Server Log Settings Contents Pane, page 34-5**

**DCNM-LAN Server Log Settings Contents Pane**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Logging Level</td>
<td>Logging level for the features or server components whose Default check box is checked. The default value for this list is Informational. For more information about logging levels, see the “Logging Levels” section on page 34-2.</td>
</tr>
</tbody>
</table>

**DCNM-LAN Features**

- **Default**: Whether logging for the corresponding feature uses the default logging level or the logging level specified for the feature. When a Default check box is checked, the logging level list for the corresponding feature is unavailable. By default, these check boxes are unchecked.
- **AAA**: Logging level for the AAA feature.
- **ACL**: Logging level for the access control list feature.
- **Dot1X**: Logging level for the 802.1X feature.
- **GLBP**: Logging level for the Gateway Load-Balancing Protocol feature.
## Administering DCNM-LAN Server Log Settings

### Field Descriptions for DCNM-LAN Server Log Settings

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interfaces</td>
<td>Logging level for the Interfaces feature.</td>
</tr>
<tr>
<td>Key Chain</td>
<td>Logging level for the keychain management feature.</td>
</tr>
<tr>
<td>Layer 2 Security</td>
<td>Logging level for the layer 2 security feature, which are as follows:</td>
</tr>
<tr>
<td></td>
<td>- Dynamic ARP inspection</td>
</tr>
<tr>
<td></td>
<td>- Port security</td>
</tr>
<tr>
<td></td>
<td>- DHCP snooping</td>
</tr>
<tr>
<td></td>
<td>- IP Source Guard</td>
</tr>
<tr>
<td></td>
<td>- Traffic storm control</td>
</tr>
<tr>
<td>Object Tracking</td>
<td>Logging level for the object tracking feature.</td>
</tr>
<tr>
<td>Port Channel</td>
<td>Logging level for the port security feature.</td>
</tr>
<tr>
<td>SPAN</td>
<td>Logging level for the SPAN feature.</td>
</tr>
<tr>
<td>Spanning Tree</td>
<td>Logging level for the STP feature.</td>
</tr>
<tr>
<td>Tunnel</td>
<td>Logging level for the tunnel interface management feature.</td>
</tr>
<tr>
<td>Virtual Devices</td>
<td>Logging level for the virtual device context feature.</td>
</tr>
<tr>
<td>VLAN</td>
<td>Logging level for the VLAN feature.</td>
</tr>
<tr>
<td>FabricExtender</td>
<td>Logging level for the Fabric Extender feature.</td>
</tr>
<tr>
<td>VPC</td>
<td>Logging level for the vPC feature.</td>
</tr>
<tr>
<td>HSRP</td>
<td>Logging level for the HSRP feature.</td>
</tr>
<tr>
<td>DEVICE GROUP</td>
<td>Logging level for the Device Groups feature.</td>
</tr>
</tbody>
</table>

### DCNM-LAN Server Components

| Default             | Whether logging for the corresponding server component uses the default      |
|                     | logging level or the logging level specified for the component. When a      |
|                     | Default check box is checked, the logging level list for the corresponding   |
|                     | component is unavailable. By default, these check boxes are unchecked.      |
| Event               | Logging level for the event component, which includes messages about how     |
|                     | DCNM-LAN processes the system and accounting logs it retrieves from devices  |
|                     | and also events generated by DCNM-LAN.                                       |
| Statistics Collection | Logging level for the statistical data collection component.               |
| Config Archive      | Logging level for the configuration archive component, used by the          |
|                     | Configuration Change Management feature.                                    |
| Device Connections  | Logging level for the component that connects the DCNM-LAN server to devices.|
| Device Discovery    | Logging level for the component that performs device discovery.              |
Additional References

For additional information related to administering DCNM-LAN server log settings, see the following sections:

- Related Documents, page 34-7
- Standards, page 34-7

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Troubleshooting DCNM-LAN</td>
<td>Chapter 38, “Troubleshooting DCNM-LAN”</td>
</tr>
</tbody>
</table>

Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td></td>
</tr>
</tbody>
</table>

Feature History for DCNM-LAN Server Log Settings

Table 34-2 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Groups logging</td>
<td>5.0(2)</td>
<td>Support was added for configuring the logging level for the Device Groups feature.</td>
</tr>
</tbody>
</table>
Managing Events

DCNM allows you to view and manage events that the DCNM server recently received from managed devices or that the DCNM server generated itself. The Event Browser allows you to view recent status events. In addition to listing events, the Event Browser provides a pie chart and a bar chart of events separated by the event severity.

DCNM also displays feature-specific status events on the Events tab that appears in the Details pane for features that can have events.

This chapter describes how to use the Event Browser and feature-specific Events tabs in Cisco Data Center Network Manager (DCNM).

This chapter includes the following sections:

- Information About Events, page 35-1
- Licensing Requirements for the Event Browser, page 35-2
- Prerequisites, page 35-2
- Guidelines and Limitations for the Event Browser, page 35-2
- Platform Support, page 35-3
- Using the Event Browser and Events Tabs, page 35-3
- Field Descriptions for Events, page 35-10
- Related Documents, page 35-11
- Feature History for the Event Browser and Events Tabs, page 35-12

Information About Events

Cisco DCNM allows you to view and manage recent status events. An event can be either of the following:

- A status-related system message that Cisco DCNM retrieves from managed devices. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.
- A message generated by the Cisco DCNM server.

The Cisco DCNM client includes the Event Browser and feature-specific Events tabs that appears in the Details pane for features that can have events. The Event Browser shows all recent status events while a feature-specific Events tab shows recent status events that pertain to the feature. The Cisco DCNM client updates the Event Browser and Events tabs dynamically when it receives new events from the server.
In the Event Browser and on Events tabs, you can change the status of an event, add notes to an event, or delete an event.

In addition, the Event Browser provides a pie chart and a bar chart of events separated by the event severity. You can also delete individual events from the events database.

**Note**
Configuring Cisco DCNM server log settings does not affect logging levels on managed Cisco NX-OS devices.

## Licensing Requirements for the Event Browser

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco DCNM</td>
<td>The Event Browser requires no license. Any feature not included in a license package is bundled with Cisco DCNM and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 6.x</em>.</td>
</tr>
<tr>
<td>Cisco NX-OS</td>
<td>The Event Browser requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For an explanation of the Cisco NX-OS licensing scheme for your platform, see the licensing guide for your platform.</td>
</tr>
</tbody>
</table>

## Prerequisites

The following prerequisites are required for using the Events feature on Cisco DCNM. For a full list of feature-specific prerequisites, see the platform-specific documentation:

- System-message logging levels for the Events feature must meet or exceed Cisco DCNM requirements. During device discovery, Cisco DCNM detects inadequate logging levels and raises them to the minimum requirements. Cisco Nexus 7000 Series switches that run Cisco NX-OS Release 4.0 are an exception. For Cisco NX-OS Release 4.0, prior to device discovery, use the command-line interface to configure logging levels to meet or exceed Cisco DCNM requirements. For more information, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.
- Managed Cisco NX-OS devices must be configured to send system messages to the Cisco DCNM server.

## Guidelines and Limitations for the Event Browser

The Event Browser feature has the following configuration guidelines and limitations:

- The Event Browser and feature-specific Events tabs display only status events, which are events generated when the status of a feature or object changes. For example, configuration events do not appear in the Event Browser or on an Events tab.
- The Event Browser can display event messages that are no older than 24 hours when you start the Cisco DCNM client. By default, the Cisco DCNM client fetches from the server messages that are no older than 1 hour.
The Event Browser can display up to 2000 events. The events database is limited by the amount of space available to the database.

You cannot use Cisco DCNM to control the logging levels of managed Cisco NX-OS devices. For more information, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.

We recommend that you delete events that you no longer need or that you have resolved. For information about deleting old events from the events database, see the Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x.

Platform Support

The following platforms support this feature but may implement it differently. For platform-specific information, including guidelines and limitations, system defaults, and configuration limits, see the corresponding documentation.

<table>
<thead>
<tr>
<th>Platform</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Nexus 1000V Series switches</td>
<td>Cisco Nexus 1000V Series Switches Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 4000 Series switches</td>
<td>Cisco Nexus 4000 Series Switches Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 5000 Series switches</td>
<td>Cisco Nexus 5000 Series Switches Documentation</td>
</tr>
<tr>
<td>Cisco Nexus 7000 Series switches</td>
<td>Cisco Nexus 7000 Series Switches Documentation</td>
</tr>
</tbody>
</table>

Using the Event Browser and Events Tabs

This section includes the following topics:

- Viewing the Event Browser, page 35-3
- Applying and Removing an Event Filter, page 35-5
- Viewing Events on an Events Tab, page 35-6
- Changing the Status of an Event, page 35-7
- Adding a Note to One or More Events, page 35-8
- Deleting an Event, page 35-9

Viewing the Event Browser

You can use the Event Browser to view recent events and a summary chart of those events. By default, the Event Browser shows events that occurred up to 1 hour prior to starting the Cisco DCNM client.

**DETAILED STEPS**

**Step 1** From the Feature Selector pane, choose **Event Browser**.

The event table appears in the Contents pane. A summary chart appears above the Feature Selector pane.
Step 2  (Optional) If you want to change the summary chart that appears above the Feature Selector, choose one of the following Chart Type options, as needed:

- Bar Chart
- Pie Chart

The colors of the chart correspond to event severity levels, as indicated in the legend that appears above the chart.

Step 3  (Optional) If you want to sort or filter events, you can use one or more of the filtering features as described in the following table:

<table>
<thead>
<tr>
<th>Event Sorting and Filtering Feature</th>
<th>How to Use</th>
</tr>
</thead>
</table>
| Alphabetical sorting by column           | Click the column heading to cycle through the sorting options, as follows:  
  - First click—Events are sorted by ascending alphabetical order for the values in the column.  
  - Second click—Events are sorted by descending alphabetical order for the values in the column.  
  - Third click—Events are not sorted by the values in the column.                                                                 |
| Event Filter                             | See the “Applying and Removing an Event Filter” section on page 35-5.                                                                   |
| Filter by Column Values                  | 1. From the menu bar, choose View > Filter.  
   The column headings become drop-down lists.  
  2. From each column heading list that you want to use to filter events, choose the value that events appearing in the Event Browser must include. |
| Filter by text                            | In the Event Browser toolbar, enter the text that you want to use to filter the events.  
   The Event Browser shows only the events that contain the text that you enter.  
   Tip: To configure quick filtering options, use the drop-down list of the Event Browser toolbar. |

Step 4  (Optional) If you want to view details about a specific event, follow these steps:

a. Find the event in the event list.
b. Click the event.
c. Expand the Details pane, if necessary.  
   Details about the selected event appear in the Details pane.
d. (Optional) To read notes and messages about status changes to the event, read the information in the Action Log field.

**RELATED TOPICS**

- Applying and Removing an Event Filter, page 35-5
- Viewing Events on an Events Tab, page 35-6
Applying and Removing an Event Filter

You can filter events in the Event Browser by the following criteria:

- Event date and time—By default, the Cisco DCNM client displays all events received after you started the Cisco DCNM client and for a configurable number of hours prior to starting the Cisco DCNM client (for more information, see the Configuring the Maximum Age of Events Fetched from the Server, page 16-18).
- Event severity—By default, the Cisco DCNM client displays events of all severities.

Note
When you apply an event filter, the Events tab continues to display events when the Cisco DCNM server receives them. The filter criteria that you select only affect the Filtered Events tab.

BEFORE YOU BEGIN
If the message “Filter Applied” appears at the top of the Contents pane, the Cisco DCNM client is applying an event filter to the Event Browser.

DETAILED STEPS

**Step 1** View events in the Event Browser (see the “Viewing the Event Browser” section on page 35-3).

**Step 2** If you want to apply an event filter, follow these steps:
   a. From the menu bar, choose View > Event Filter.
   b. Check the Apply Filter check box.
   c. Configure the filter criteria.
   d. Click OK.

A Filtered Events tab appears in the Event Browser. The tab displays the events that match the filtering criteria that you specified. The message “Filter Applied” appears at the top of the Contents pane.

**Step 3** If you want to remove an event filter, follow these steps:
   a. From the menu bar, choose View > Event Filter.
   b. Uncheck the Apply Filter check box.
   c. Click OK.

The Filtered Events tab disappears. No message appears at the top of the Contents pane.

RELATED TOPICS

- Viewing the Event Browser, page 35-3
Viewing Events on an Events Tab

You can view feature-specific events on the Events tab that appears in the Details pane for a feature. By default, an Events tab shows events received up to 1 hour prior to starting the Cisco DCNM client.

BEFORE YOU BEGIN

Typically, the Events tab appears when, in the Summary pane, you select an object that can have events associated with it. For example, if you select Interfaces > Physical > Ethernet from the Feature Selector pane, the Summary pane displays devices. Devices contain slots, and slots contain Ethernet ports. When you select a device, slot, or port, the Details pane displays an Events tab.

What you select in the Summary pane affects which events are shown in the tab. Continuing the Ethernet interface example, the scope of the events in the Events tab depends on what you select, as follows:

- Device—Events that pertain to the selected device, any slot within the device, and any Ethernet interface within the slot.
- Slot—Events that pertain to the selected slot and to any Ethernet interface within the slot.
- Port—Events that pertain to the selected Ethernet interface.

DETAILED STEPS

Step 1  From the Feature Selector pane, choose the feature for which you want to view events. For example, choose Interfaces > Physical > Ethernet.

Step 2  From the Summary pane, select an object. The Events tab appears in the Details pane. In the Events tab, the events table appears.

Note  If no Events tab appears, Cisco DCNM cannot display events for the object that you selected.

Step 3  (Optional) If you want to sort or filter events, you can use one or more of the filtering features as described in the following table:
Using the Event Browser and Events Tabs

### Event Sorting and Filtering Feature

<table>
<thead>
<tr>
<th>Event Sorting and Filtering Feature</th>
<th>How to Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alphabetical sorting by column</td>
<td>Click the column heading to cycle through the sorting options, as follows:</td>
</tr>
<tr>
<td></td>
<td>• First click—Events are sorted by ascending alphabetical order for the values in the column.</td>
</tr>
<tr>
<td></td>
<td>• Second click—Events are sorted by descending alphabetical order for the values in the column.</td>
</tr>
<tr>
<td></td>
<td>• Third click—Events are not sorted by the values in the column.</td>
</tr>
<tr>
<td>Filter by Column Values</td>
<td>1. From the menu bar, choose <strong>View &gt; Filter.</strong> The column headings become drop-down lists.</td>
</tr>
<tr>
<td></td>
<td>2. From each column heading list that you want to use to filter events, choose the value that events appearing in the Events tab must include.</td>
</tr>
</tbody>
</table>

### Step 4

(Optional) If you want to view details about a specific event, follow these steps:

a. Find the event in the event list.

b. Click the event.

c. Expand the Details pane, if necessary.

   Details about the selected event appear in the Details pane.

d. (Optional) To read notes and messages about status changes to the event, read the information in the Action Log field.

### RELATED TOPICS

- Viewing the Event Browser, page 35-3
- Applying and Removing an Event Filter, page 35-5
- Changing the Status of an Event, page 35-7
- Adding a Note to One or More Events, page 35-8
- Deleting an Event, page 35-9
- Configuring the Maximum Age of Events Fetched from the Server, page 16-18

### Changing the Status of an Event

You can change the status of an event to one of the following statuses:

- Acknowledged—Shown as a green check mark.
- Closed—Shown as a yellow folder.

By default, the status of new event is Open, which is indicated in the Annotation column by a green check mark with a red slash across it.
BEFORE YOU BEGIN

Select an event in the Event Browser or on an Events tab for a specific feature. For more information, see the “Viewing the Event Browser” section on page 35-3 or the “Viewing Events on an Events Tab” section on page 35-6.

DETAILED STEPS

Step 1  In the event table, right-click the selected event.
Step 2  Choose Acknowledge or Open, as needed.

The new status appears in the Annotation column for the selected event.
In the Details pane, the message about the status change appears in the Action Log field.

RELATED TOPICS

- Viewing the Event Browser, page 35-3
- Applying and Removing an Event Filter, page 35-5
- Viewing Events on an Events Tab, page 35-6
- Adding a Note to One or More Events, page 35-8
- Deleting an Event, page 35-9

Adding a Note to One or More Events

You can add a note to one or more events. Notes can contain 1 to 1000 characters.

BEFORE YOU BEGIN

Find the events to which you want to add a note. For more information, see the “Viewing the Event Browser” section on page 35-3 or the “Viewing Events on an Events Tab” section on page 35-6.

DETAILED STEPS

Step 1  Select one or more events. Do one of the following:
- To select one event, click the one event that you want to select.
- To select two or more adjacent events, click and drag across the events.
- To select two more events, press and hold Ctrl and click each event.
Step 2  On one of the selected events, right-click and then choose Add Notes.
The Notes dialog box appears.
Step 3  Enter the note. You can enter up to 1000 case-sensitive, alphanumeric characters.
Step 4  Click OK.
The note appears in the Action Log field for each selected event.
Deleting an Event

You can delete one or more events from the Event Browser or a feature-specific Events tab. A deleted event no longer appears in the Event Browser or on a feature-specific Events tab; however, the event remains in the events database.

For information about deleting old events from the events database, see the *Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x*.

**BEFORE YOU BEGIN**

Select an event in the Event Browser or on an Events tab for a specific feature. For more information, see the “Viewing the Event Browser” section on page 35-3 or the “Viewing Events on an Events Tab” section on page 35-6.

**DETAILED STEPS**

**Step 1**
In the event table, select one or more events that you want to delete.

**Note**
To select more than one event, you can click and drag across the events or you can press and hold Ctrl and click each event.

**Step 2**
Right-click a selected event.

**Step 3**
Choose **Remove Event**.

The selected events disappear from the Event Browser.

**RELATED TOPICS**

- Viewing the Event Browser, page 35-3
- Applying and Removing an Event Filter, page 35-5
- Viewing Events on an Events Tab, page 35-6
- Changing the Status of an Event, page 35-7
- Deleting an Event, page 35-9
Field Descriptions for Events

This section includes the following field descriptions for Events:

- Events Table, page 35-10
- Event Details, page 35-11

Events Table

The events table appears in the Event Browser and on feature-specific Events tabs.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Display only. Name and IP address of the device that the event is related to.</td>
</tr>
<tr>
<td>Source</td>
<td>Display only. Where the event message originated. Sources are either a feature on a managed Cisco NX-OS device or the Cisco DCNM server.</td>
</tr>
<tr>
<td>Feature</td>
<td>Display only. Name of the Cisco NX-OS or Cisco DCNM server feature that the event pertains to.</td>
</tr>
<tr>
<td>Time</td>
<td>Display only. Date and time that the event occurred.</td>
</tr>
<tr>
<td>Severity</td>
<td>Display only. Severity of the event. Possible severities are as follows:</td>
</tr>
<tr>
<td></td>
<td>- Emergency</td>
</tr>
<tr>
<td></td>
<td>- Alert</td>
</tr>
<tr>
<td></td>
<td>- Critical</td>
</tr>
<tr>
<td></td>
<td>- Error</td>
</tr>
<tr>
<td></td>
<td>- Warning</td>
</tr>
<tr>
<td></td>
<td>- Notification</td>
</tr>
<tr>
<td></td>
<td>- Informational</td>
</tr>
<tr>
<td></td>
<td>- Debug</td>
</tr>
<tr>
<td>Message</td>
<td>Display only. Text of the event.</td>
</tr>
<tr>
<td>Annotation</td>
<td>Status of the event. Possible statuses are as follows:</td>
</tr>
<tr>
<td></td>
<td>- Open—The default status of an event. You cannot assign an event the status of Open.</td>
</tr>
<tr>
<td></td>
<td>- Acknowledged</td>
</tr>
<tr>
<td></td>
<td>- Closed</td>
</tr>
</tbody>
</table>
Event Details

Event details appear below the events table in the Event Browser and on feature-specific Events tabs.

Table 35-2 Event Details

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Type</td>
<td><em>Display only.</em> Type of the event. Event types are categories that describe the general nature of the event. Possible event types are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Communication</td>
</tr>
<tr>
<td></td>
<td>• Environmental</td>
</tr>
<tr>
<td></td>
<td>• Equipment</td>
</tr>
<tr>
<td></td>
<td>• Processing Error</td>
</tr>
<tr>
<td></td>
<td>• Quality of Service</td>
</tr>
<tr>
<td></td>
<td>• Security</td>
</tr>
<tr>
<td></td>
<td>• Unknown</td>
</tr>
<tr>
<td>Action Log</td>
<td>Shows all actions taken on the event and all notes added to the event.</td>
</tr>
<tr>
<td>Life Cycle Type</td>
<td><em>Display only.</em> Type of life cycle of the event. Possible life cycle types are as follows:</td>
</tr>
<tr>
<td></td>
<td>• State Change</td>
</tr>
<tr>
<td></td>
<td>• Attribute Value Change</td>
</tr>
<tr>
<td></td>
<td>• Instance Creation</td>
</tr>
<tr>
<td></td>
<td>• Instance Deletion</td>
</tr>
<tr>
<td></td>
<td>• Informational</td>
</tr>
</tbody>
</table>

Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum required Cisco NX-OS logging levels</td>
<td><em>Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x</em></td>
</tr>
<tr>
<td>Cisco DCNM server log settings</td>
<td><em>Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x</em></td>
</tr>
<tr>
<td>Deleting events from the events database</td>
<td><em>Fundamentals Configuration Guide, Cisco DCNM for LAN, Release 5.x</em></td>
</tr>
<tr>
<td>Cisco NX-OS system messages</td>
<td><em>Cisco NX-OS System Messages Reference</em></td>
</tr>
</tbody>
</table>
### Feature History for the Event Browser and Events Tabs

Table 35-3 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Browser and Events tabs</td>
<td>5.1(1)</td>
<td>No change from Release 5.0.</td>
</tr>
<tr>
<td>Event Browser and Events tabs</td>
<td>5.0(2)</td>
<td>No change from Release 4.2.</td>
</tr>
</tbody>
</table>
Working with Network Analysis

This chapter describes how to use the Network Analysis (PONG) feature in Cisco Data Center Network Manager for LAN (DCNM-LAN).

This chapter includes the following sections:

- Information About Network Analysis, page 36-1
- Licensing Requirements for Network Analysis, page 36-1
- Prerequisites for Network Analysis, page 36-2
- Guidelines and Limitations for Network Analysis, page 36-2
- Using the Network Analysis Feature, page 36-2
- Related Documents, page 36-8
- Feature History for Network Analysis, page 36-8

Information About Network Analysis

The Network Analysis feature provides you with information to track and monitor the latency between two specified switches in a specified time interval. With Network Analysis, you can determine the health of the network by examining the delay between the two specified points in the network.

The Network Analysis feature:

- Supports real time and historical network analysis between two user specified devices or ports. The user specifies the required monitoring intervals.
- Supports an archive of historical Network Analysis measurements for the following:
  - End to end round trip time.
  - Switching delay at each hop.
  - Link delay between hops per path.
- Provides reports that contain the resulting statistical information as a chart or summary table.

Licensing Requirements for Network Analysis

The following table shows the licensing requirements for this feature:
Prerequisites for Network Analysis

Network Analysis has the following prerequisite:

- Network Analysis only pertains to the devices that DCNM-LAN has discovered.

Guidelines and Limitations for Network Analysis

The Network Analysis feature has the following configuration guidelines and limitations:

- Specify the IP addresses for devices to monitor the network path between two end hosts or between a host and a server. This allows monitoring of the ingress port of the source connected switch to the egress port of the target switch connected to the end host or server.
- Specify the IP addresses for switches, VLAN, and optional interface information to monitor the path between them.
- Specify the threshold level for the round trip time to help evaluate the path latency results.

Using the Network Analysis Feature

This section includes the following topics:

- Using Network Analysis, page 36-2
- Using the New Path Latency Session Wizard, page 36-4
- Viewing Session Statistics, page 36-7

Using Network Analysis

You can use Network Analysis to specify the scope of the analysis and to view the information about the analysis.

DETAILED STEPS

Step 1

From the Feature Selector pane, choose Network Analysis > Path Latency Monitoring (PONG).

The Summary pane appears in the Contents pane. Each row in the table is a path latency session. You are able to view the sessions that you have created as well as the sessions created by other users. See Table 36-1.

Users with administrator privileges are allowed to modify other users’ sessions.
### Table 36-1  Information in Summary Pane

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session ID</td>
<td>Unique ID of the session created by the user. The ID is updated after the user deploys the session.</td>
</tr>
<tr>
<td>Session Name</td>
<td>Unique name entered by user for the path latency session.</td>
</tr>
<tr>
<td>Source Switch</td>
<td>IP address of the source switch from which path latency is monitored.</td>
</tr>
<tr>
<td>Destination Switch</td>
<td>IP address of the destination switch to which the path latency is monitored.</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN ID through which the actual traffic flows (1 to 4094).</td>
</tr>
<tr>
<td>Class of Service (CoS)</td>
<td>Optional value used to filter the traffic monitoring based on class of service value (0 to 7). CoS values are shown in Table 36-2.</td>
</tr>
<tr>
<td>Round Trip Time (microseconds)</td>
<td>Minimum, maximum, average and latest value of the round trip time (two way path: source &lt;-&gt; destination) of all the RTT latencies calculated up until current time.</td>
</tr>
<tr>
<td>Forward Delay (microseconds)</td>
<td>Minimum, maximum, average and latest value of the forward delay (forward path: source -&gt; destination) of all the forward delay latencies calculated to the current time.</td>
</tr>
<tr>
<td>Reverse Delay (microseconds)</td>
<td>Minimum, maximum, average and latest value of the reverse delay (reverse path: destination -&gt; source) of all the reverse delay latencies calculated to the current time.</td>
</tr>
<tr>
<td>Owner</td>
<td>Creator of the session.</td>
</tr>
<tr>
<td>Success Percentage</td>
<td>Success percentage of the packets traversed from source to destination during the specified time interval.</td>
</tr>
<tr>
<td>Scheduled At</td>
<td>Date and time when the monitoring was started.</td>
</tr>
<tr>
<td>Status</td>
<td>Column that specifies:</td>
</tr>
<tr>
<td></td>
<td>• Session created</td>
</tr>
<tr>
<td></td>
<td>• Monitoring started</td>
</tr>
<tr>
<td></td>
<td>• Monitoring stopped</td>
</tr>
</tbody>
</table>

### Table 36-2  CoS Values and Corresponding Traffic Types

<table>
<thead>
<tr>
<th>User Priority</th>
<th>Traffic Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Background</td>
</tr>
<tr>
<td>1</td>
<td>Best Effort</td>
</tr>
<tr>
<td>2</td>
<td>Excellent Effort</td>
</tr>
<tr>
<td>3</td>
<td>Critical Applications</td>
</tr>
<tr>
<td>4</td>
<td>Video, &lt; 100 ms latency</td>
</tr>
<tr>
<td>5</td>
<td>Voice, &lt; 10 ms latency</td>
</tr>
</tbody>
</table>
Chapter 36  Working with Network Analysis

Using the Network Analysis Feature

Step 2  Above the Summary pane, click the **Configure New Rule** link to set a threshold rule for one of the following parameters.
- Round trip time
- Forward delay
- Reverse delay

*Note*  Clicking **Configure New Rule** links you to Threshold Rules of the DCNM-LAN Server Administration feature.

Step 3  Above the Summary pane, click the **Set Global Threshold** link to set a global threshold rule for the following parameters:
- Round trip time
- Forward delay
- Reverse delay

The global threshold setting is applied to all the sessions in the Summary Table.

Step 4  Above the Summary pane, click the **VLAN-CoS** button to view the sessions grouped by VLAN-CoS.

---

### Using the New Path Latency Session Wizard

You can use the New Path Latency Session wizard to create a new session.

**DETAILED STEPS**

**Step 1**  From the Feature Selector pane, choose **Network Analysis > Path Latency Monitoring (PONG)**. The Summary pane appears in the Contents pane.

**Step 2**  In the Summary pane, right-click and choose **New Path Latency Session** in the context menu. The New Path Latency Session wizard appears.

**Step 3**  In the Select Session Monitor Option of Interest screen, enter the following:
- **Session Name**
  (Length: 1 to 256 characters)
- **VLAN**
  (Value: 1 to 4094)
- **Class of Service (CoS)**

---

### Table 36-2  CoS Values and Corresponding Traffic Types

<table>
<thead>
<tr>
<th>User Priority</th>
<th>Traffic Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Internetwork Control</td>
</tr>
<tr>
<td>7</td>
<td>Network Control</td>
</tr>
</tbody>
</table>
Chapter 36  Working with Network Analysis

Using the Network Analysis Feature

In the Select Option section, choose one of the following options:

- Monitor latency between source VDC and destination VDC.
- Monitor latency between source and destination VDC including source switching delay.
- Monitor latency between source and destination VDC including destination switching delay.
- Monitor latency between source and destination VDC including both switching delays.

Under the Monitor latency between source VDC and destination VDC option, you can additionally choose to measure the latency between switches that have Fabric Path mode connectivity. The latency measurements are measured between the source and destination switches but do not include the switching delay of both the end switches.

**Note**
For the switches that are in a classical ethernet cloud, the wizard allows you to choose their VDC MAC addresses/IP addresses/hostnames in the following wizard screen.

Click **Next** to continue.

In the Select Source and Destination Switch screen, do the following:

- Choose the source switch by clicking on the ellipses next to the Select Source Switch field. Highlight the device in the screen that appears and click **OK** to enter your selection.
- Choose the destination switch by clicking on the ellipses next to the Select Destination Switch field. Highlight the device in the screen that appears and click **OK** to enter your selection.

Depending on the earlier selection that you made in the Select Option section of the wizard, Table 36-4 list the required and optional information that you must enter in the Select Source and Destination Switch screen.

---

**Table 36-3  CoS Values and Corresponding Traffic Types**

<table>
<thead>
<tr>
<th>User Priority</th>
<th>Traffic Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Background</td>
</tr>
<tr>
<td>1</td>
<td>Best Effort</td>
</tr>
<tr>
<td>2</td>
<td>Excellent Effort</td>
</tr>
<tr>
<td>3</td>
<td>Critical Applications</td>
</tr>
<tr>
<td>4</td>
<td>Video, &lt; 100 ms latency</td>
</tr>
<tr>
<td>5</td>
<td>Voice, &lt; 10 ms latency</td>
</tr>
<tr>
<td>6</td>
<td>Internetwork Control</td>
</tr>
<tr>
<td>7</td>
<td>Network Control</td>
</tr>
</tbody>
</table>
### Table 36-4 Required and Optional Information

<table>
<thead>
<tr>
<th>Option</th>
<th>Required</th>
<th>Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor latency between source VDC and destination VDC</td>
<td>• Source and destination</td>
<td>• Egress/outbound interface through which the packet flows out from the source.</td>
</tr>
<tr>
<td>Monitor latency between source and destination VDC including source switching delay</td>
<td>• Source and destination • Inject/ingress interface through which the packet needs to be injected from the source switch. Also requires the source static MAC address associated with the interface.</td>
<td>• N/A</td>
</tr>
<tr>
<td>Monitor latency between source and destination VDC including destination switching delay</td>
<td>• Source and destination • Egress/outbound interface through which the packet terminates at the destination switch. Also requires the destination static MAC address associated with the interface.</td>
<td>• Egress/outbound interface through which the packet flows out from the source.</td>
</tr>
<tr>
<td>Monitor latency between source and destination VDC including both switching delays</td>
<td>• Source and destination • Inject/ingress interface through which the packet needs to be injected from the source switch. Also requires source static MAC address associated with the interface. • Egress/outbound interface through which the packet terminates at the destination switch. Also requires the destination static MAC address associated with the interface.</td>
<td>• N/A</td>
</tr>
</tbody>
</table>

**Note**

You can enter any arbitrary unique static MAC address that points to the selected interface. To configure a new static MAC address, use one of the following recommended addresses to avoid any conflict with globally administered MAC addresses (associated with any other host/devices):

- X2XX.XXXX.XXXX
- X6XX.XXXX.XXXX
- XAXX.XXXX.XXXX
- XEXX.XXXX.XXXX
where X is a hexadecimal value.

Click Next to continue.

**Step 6**

In the dialog box that appears, click OK to start input verification.

The Input Verification screen appears and the results are displayed.

Input verification verifies the following:

- Path latency measurement between specified devices.
- Packet traversal between the specified devices.

If the verification fails, you must specify the information that you entered earlier in the wizard.

Table 36-5 lists the additional settings that are available in the Input Verification window:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor Interval</td>
<td>Interval of time between data collection points.</td>
<td>0.5 - 5 minutes (Default: 5 minutes)</td>
</tr>
<tr>
<td>End Time</td>
<td>Time of session termination</td>
<td>N/A</td>
</tr>
<tr>
<td>Calculate Jitter</td>
<td>Variance of inter packet RTT delay</td>
<td>Default: unchecked</td>
</tr>
<tr>
<td>No. of Packets to send</td>
<td>Packet count to send for the session to measure latency. To calculate jitter (inter packet delay variance), more than 1 packet has to be sent.</td>
<td>1 - 5 packets (Default: 1 packet)</td>
</tr>
</tbody>
</table>

Click Finish after a successful verification and to enter the settings.

### Viewing Session Statistics

You can view session statistics from the Summary pane.

**DETAILED STEPS**

**Step 1**

From the Feature Selector pane, choose Network Analysis > Path Latency Monitoring (PONG).

The Summary pane appears in the Contents pane.

**Step 2**

Right-click a session and choose Go To Statistics in the context menu.

The statistics for the session appear as a chart and a table of detailed information in the Details pane.

**Step 3**

In the Details pane, click the Path Latency tab to display RTT information about each path.

**Step 4**

In the Details pane, right-click to display a context menu of additional statistical displays:
- Path specific switching delay—Switching delay of all the switches traversed in each path.
- Path specific link delay—Link delay at each hop traversed in each path.
- Switching delay of each switch across different paths traversed in the session.
- Link delay of each link across different paths traversed in the session.

**Step 5**

In the Details pane, click the **Session Report** tab to display overall statistical information about the session.

The information can be exported as an Excel .xls file by clicking the export button near the top of the table.

---

**Related Documents**

For additional information related to the topology map, see the following sections:

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device discovery</td>
<td>Chapter 29, “Administering Device Discovery”</td>
</tr>
</tbody>
</table>

**Feature History for Network Analysis**

Table 36-6 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Analysis support</td>
<td>5.2(0)</td>
<td>Support for Network Analysis was added.</td>
</tr>
</tbody>
</table>
Maintaining the Cisco DCNM-LAN Database

This chapter describes how to maintain the Cisco Data Center Network Manager for LAN (DCNM-LAN) database.

This chapter includes the following sections:
- Information About Database Maintenance, page 37-1
- Licensing Requirements for Database Maintenance, page 37-3
- Prerequisites for Database Maintenance, page 37-3
- Guidelines and Limitations for Database Maintenance, page 37-3
- Performing Database Maintenance, page 37-4
- Additional References, page 37-9
- Feature History for DCNM-LAN Database Maintenance, page 37-9

Information About Database Maintenance

DCNM-LAN uses a PostgreSQL database or an Oracle database to store all data, including configuration information from managed devices, events and statistical data gathered from managed devices, and DCNM-LAN user information. In addition to scripts that you can run to perform database maintenance, DCNM-LAN provides features to help you delete events and statistical data that you no longer need.

This section includes the following topics:
- Automatic and Manual Purging of Data, page 37-1
- Database Backup, page 37-2
- Database Clean, page 37-2
- Database Restore, page 37-2

Automatic and Manual Purging of Data

You can use the Auto-Synchronization with Devices feature to delete unwanted event data and the Statistical Data Collection feature to delete unwanted statistical data. DCNM-LAN supports automatic purging of both types of data. You can configure the following aspects of automatic data purging:
Information About Database Maintenance

- Days of the week and time of day that automatic purging occurs.
- Whether DCNM-LAN determines which data to purge by the age of the data or by a maximum number of database entries.
- For event-related data, whether DCNM-LAN determines which events to purge by event severity.

We recommend that you configure automatic purging of events and statistical data to ensure that the DCNM-LAN database size does not grow too large.

You can also manually purge events and statistical data.

For more information, see the following sections:

Database Backup

You can use the Cisco DCNM database backup script to create a backup file of the DCNM-LAN database.

We strongly recommend that you regularly back up the DCNM-LAN database and that you archive backup files in a secure location that is not on the DCNM-LAN server system. You should retain the backup files as long as required by the standards of your organization.

Database Clean

You can use the Cisco DCNM database clean script /usr/local/cisco/dcm/dcnm/bin/clean-dcnm-db.sh to clean the DCNM-LAN database. Cleaning removes all DCNM-LAN data from the database and is a necessary step prior to restoring the DCNM-LAN database. Any database records that have not been backed up are lost when you clean the database.

You can also clean the database if you want to delete all data and rebuild your DCNM-LAN implementation without restoring data from a backup.

Database Restore

You can use the Cisco DCNM database restore script to restore the DCNM-LAN database from a backup file. The backup file must have been created by the DCNM-LAN database backup script included in the same release of DCNM-LAN that you are restoring the data to. For example, if you are running Cisco DCNM Release 5.0(2), you should only perform database restoration from a backup of Cisco DCNM Release 5.0(2).

Also, the backup file must have been created from the same database type and release that you are restoring the data to. For example, if you are restoring data to an Oracle 11g database, the backup file must have been created from an Oracle 11g database.

Before you restore a DCNM-LAN database, you should clean the database. Restoring a database without cleaning the database can have unpredictable results.
Licensing Requirements for Database Maintenance

The following table shows the licensing requirements for this feature:

<table>
<thead>
<tr>
<th>Product</th>
<th>License Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCNM-LAN</td>
<td>Database maintenance requires no license. Any feature not included in a license package is bundled with the DCNM-LAN and is provided at no charge to you. For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the <em>Cisco DCNM Installation and Licensing Guide, Release 5.x</em>.</td>
</tr>
</tbody>
</table>

Prerequisites for Database Maintenance

Database maintenance has the following prerequisites:

- You must have successfully installed the DCNM-LAN server.
- Cleaning the DCNM-LAN database requires that you stop the DCNM-LAN server.
- Restoring the DCNM-LAN database requires the following:
  - You must have a backup file created from exactly the same release of DCNM-LAN that you are restoring with the backup file.
  - You must have a backup file created from exactly the same database type and release that you are restoring data to.
  - You must have a backup file that was created from a DCNM-LAN database running in the same operating system as the database that you want to restore. For example, backup files made from a database running in Microsoft Server 2003 can only be used to restore other DCNM-LAN databases running in Microsoft Server 2003.

Guidelines and Limitations for Database Maintenance

Database maintenance has the following configuration guidelines and limitations:

- We recommend that you configure automatic purging of statistical data and event data to ensure that the DCNM-LAN database size does not grow too large.
- We recommend that you perform backups on a regular basis. Follow the standards of your organization to determine how frequently you should perform backups.
- You can only restore a DCNM-LAN database from a backup of the same release of DCNM-LAN. For example, if you are running Cisco DCNM Release 5.0(2), you should only perform database restoration from a backup of Cisco DCNM Release 5.0(2).
- You can only restore a DCNM-LAN database from a backup of the same database type and release as the current database. For example, if the current database is an Oracle 11g database, you can only restore it with a backup file made from an Oracle 11g database.
- You can only restore a DCNM-LAN database from a backup file that was made from a DCNM-LAN database running in the same operating system as the database that you want to restore. For example, backup files made from a database running in Microsoft Server 2003 can only be used to restore other DCNM-LAN databases running in Microsoft Server 2003.
Performing Database Maintenance

This section includes the following topics:

- Backing Up the DCNM-LAN Database, page 37-4
- Cleaning a DCNM-LAN Database, page 37-5
- Restoring a DCNM-LAN Database from a Backup File, page 37-7

Backing Up the DCNM-LAN Database

You can back up the DCNM-LAN database with the backup script. The DCNM-LAN server installer configures the backup script with the database username and database name that you specified during server installation.

DETAILED STEPS

Step 1
On the DCNM-LAN server, access a command prompt.

Step 2
Use the `cd` command to change the directory to the bin directory under the Cisco DCNM installation directory, as follows:

```
cd path
```

where `path` is the relative or absolute path to the bin directory. For Microsoft Windows, the default path to the bin directory is `C:\Program Files\dcm\dcnm\bin`. For RHEL, the default path to the bin directory is `/usr/local/cisco/dcm/dcnm/bin`.

Step 3
Run the Cisco DCNM database backup script. The script name depends upon the server operating system and database type, as shown in the following table:

<table>
<thead>
<tr>
<th>Server Operating System</th>
<th>Database Type</th>
<th>Backup Script Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows</td>
<td>PostgreSQL</td>
<td>backup-pgsql-dcnm-db.bat</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>backup-oracle-dcnm-db.bat</td>
</tr>
<tr>
<td>Linux</td>
<td>PostgreSQL</td>
<td>backup-pgsql-dcnm-db.sh</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>backup-oracle-dcnm-db.sh</td>
</tr>
</tbody>
</table>

Step 4
Enter the filename for the backup that you are creating.

Step 5
At the confirmation prompt, enter `y` to continue with the backup.

Step 6
Verify that the backup file was created as you specified and has a file size greater than zero.

- On Linux, use the `ls -l` command.
- On Microsoft Windows, use the `dir` command.

Step 7
Store the backup file in a safe location. We recommend that you copy the backup file to a secure location that is off the DCNM-LAN server system so that you can protect your data from the potential of a catastrophic hardware failure.
Example

The following example from a Windows server shows how to create a backup named masterbackup.bkp from a PostgreSQL DCNM-LAN database that was installed using default values:

C:\Documents and Settings\Administrator>cd "C:\Program Files\Cisco Systems\dcn\dcnm\bin"

C:\Program Files\Cisco Systems\dcn\dcnm\bin>backup-pgsql-dcnm-db.bat

Database Postgres Environment

PostgreSQL Bin Path : "C:\Program Files\Cisco Systems\dcn\db\bin"

DCNM Database Name : "dcmdb"

DCNM Database User Name : "dcnmuser"

Please enter the filename to be used for Database Backup: masterbackup.bkp

"Database Schema "dcnmuser" will be backed up in filename : masterbackup.bkp"

Continue y/n [n] : y
.
.
.
Database backup File: woobie1
Operation Completed

C:\Program Files\Cisco Systems\dcn\dcnm\bin>dir masterbackup.bkp

Volume in drive C has no label.
Volume Serial Number is D415-F632

Directory of C:\Program Files\PostgreSQL\8.2\bin

06/15/2009 01:53 PM 900,129 masterbackup.bkp
1 File(s) 900,129 bytes
0 Dir(s) 23,960,858,624 bytes free

Cleaning a DCNM-LAN Database

You can use the DCNM-LAN database clean script to clean the database, which deletes all data from the DCNM-LAN database. You might want to clean the database for the following reasons:

- You want to restore the DCNM-LAN database from a backup.
- You want to delete all data and rebuild your DCNM-LAN implementation without restoring data from a backup.

The DCNM-LAN server installer configures the clean script with the database username and database name that you specified during the server installation.

BEFORE YOU BEGIN

Back up the DCNM-LAN database. Any data not preserved in a backup is lost when you clean the database.
Stop the DCNM-LAN server. The DCNM-LAN server must be down before you can finish the database cleaning procedure. For more information, see the “Stopping DCNM-LAN Servers” section on page 27-5.

**DETAILED STEPS**

**Step 1**  
On the DCNM-LAN server, access a command prompt.

**Step 2**  
If you have not already done so, stop the DCNM-LAN server. For more information, see the “Stopping DCNM-LAN Servers” section on page 27-5.

**Step 3**  
Use the `cd` command to change the directory to the bin directory under the Cisco DCNM installation directory, as follows:

```
cd path
```

where `path` is the relative or absolute path to the bin directory. For Microsoft Windows, the default path to the bin directory is `C:\Program Files\dcm\dcnm\bin`. For RHEL, the default path to the bin directory is `/usr/local/cisco/dcm/dcnm/bin`.

**Step 4**  
Run the Cisco DCNM database clean script. The script name depends upon the server operating system and database type, as shown in the following table:

<table>
<thead>
<tr>
<th>Server Operating System</th>
<th>Database Type</th>
<th>Clean Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows</td>
<td>PostgreSQL</td>
<td>clean-pgsql-dcnm-db.bat</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>clean-oracle-dcnm-db.bat</td>
</tr>
<tr>
<td>Linux</td>
<td>PostgreSQL</td>
<td>clean-pgsql-dcnm-db.sh</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>clean-oracle-dcnm-db.sh</td>
</tr>
</tbody>
</table>

**Step 5**  
At the confirmation prompt, enter `y` to continue with cleaning the database.

**Step 6**  
If you want to restore the DCNM-LAN database from a backup, proceed to the “Restoring a DCNM-LAN Database from a Backup File” section on page 37-7. Do not start the DCNM-LAN server.

If you do not want to restore the DCNM-LAN database from a backup and want to rebuild your DCNM-LAN implementation manually, start the DCNM-LAN server. See the “Starting a Single DCNM-LAN Server” section on page 27-2.

**Example**

The following example from a Windows server shows how to clean a PostgreSQL DCNM-LAN database that was installed using default values:

```
C:\Documents and Settings\Administrator> cd "C:\Program Files\Cisco Systems\dcm\dcnm\bin"
C:\Program Files\Cisco Systems\dcm\dcnm\bin> clean-pgsql-dcnm-db.bat

Database Postgres Environment

PostgreSQL Bin Path : "C:\Program Files\Cisco Systems\dcm\db\bin"

DCNM Database Name : "dcmdb"
```
DCNM Database User Name : "dcnmuser"

DCNM Database SuperUser Name : "cisco"

PLEASE MAKE SURE THE DCNM SERVICE IS SHUTDOWN BEFORE RUNNING THIS SCRIPT!!

DCNM database schema "dcnmuser" will be deleted permanently...

Please Confirm y/n [n] : y

Operation Completed

C:\Program Files\Cisco Systems\dcm\dcnm\bin>

Restoring a DCNM-LAN Database from a Backup File

You can use the Cisco DCNM database restore script to restore the DCNM-LAN database from a backup file. The restore script cleans the database prior to restoring it.

BEFORE YOU BEGIN

Locate the backup file that you want to use to restore the DCNM-LAN database.

Ensure that the backup file that you want to use to restore the database was made from the same release of DCNM-LAN. For example, you can only restore a Cisco DCNM Release 5.0(2) database from a backup file created from a Cisco DCNM Release 5.0(2) database.

Ensure that the backup file was made from the same database type and release as the current database. For example, you can only restore an Oracle 11g database from a backup file made from an Oracle 11g database.

Ensure that the backup file was made from a DCNM-LAN database running in the same operating system as the DCNM-LAN server that you want to restore the database to. For example, backup files made from a database running in Microsoft Server 2003 can only be used to restore other DCNM-LAN databases running in Microsoft Server 2003.

The DCNM-LAN server must be stopped while you are restoring the database.

DETAILED STEPS

Step 1 On the DCNM-LAN server, access a command prompt.

Step 2 If you have not already done so, stop the DCNM-LAN server. For more information, see the “Stopping DCNM-LAN Servers” section on page 27-5.

Step 3 Use the cd command to change the directory to the bin directory under the Cisco DCNM installation directory, as follows:

cd path
where *path* is the relative or absolute path to the bin directory. For Microsoft Windows, the default path to the bin directory is C:\Program Files\dcm\dcm\bin. For RHEL, the default path to the bin directory is /usr/local/cisco/dcm/dcm/bin.

**Step 4** Run the Cisco DCNM database restore script. The script name depends upon the server operating system and database type, as shown in the following table:

<table>
<thead>
<tr>
<th>Server Operating System</th>
<th>Database Type</th>
<th>Restore Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows</td>
<td>PostgreSQL</td>
<td>restore-psql-dcnm-db.bat</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>restore-oracle-dcnm-db.bat</td>
</tr>
<tr>
<td>Linux</td>
<td>PostgreSQL</td>
<td>restore-psql-dcnm-db.sh</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
<td>restore-oracle-dcnm-db.sh</td>
</tr>
</tbody>
</table>

**Step 5** Enter the name of the backup file that you want to use to restore the DCNM-LAN database.

**Step 6** At the confirmation prompt, enter *y* to continue with the database restore.

**Step 7** To resume using DCNM-LAN, start the DCNM-LAN server. See the “Starting a Single DCNM-LAN Server” section on page 27-2.

**Example**

The following example from a Microsoft Windows server shows how to restore a DCNM-LAN PostgreSQL database that was installed using default values and using a backup file named masterbackup.bkp that exists in the bin directory Cisco DCNM installation directory:

```
C:\Documents and Settings\Administrator>cd "C:\Program Files\Cisco Systems\dcm\dcm\bin"

C:\Program Files\Cisco Systems\dcm\dcm\bin>restore-psql-dcnm-db.bat
=================================================================
Database Postgres Environment
PostgreSQL Bin Path : "C:\Program Files\Cisco Systems\dcm\db\bin"
DCNM Database Name : "dcmdb"
DCNM Database User Name : "dcmuser"
=================================================================

=================================================================
PLEASE MAKE SURE THE DCNM SERVICE IS SHUTDOWN BEFORE RUNNING THIS SCRIPT!!
=================================================================

Please enter the filename to be used for Database Restore: masterbackup.bkp
"
"Database Schema "dcmuser" will be Restore from filename : masterbackup.bkp"
"
Continue y/n [n] : y
"Cleaning the database...


```
$pg_restore: connecting to database for restore

Restored Database from : masterbackup.bkp
Operation Completed
C:\Program Files\Cisco Systems\dcm\dcnm\bin>
```

## Additional References

For additional information related to maintaining the DCNM-LAN database, see the following sections:

- Related Documents, page 37-9
- Standards, page 37-9

### Related Documents

<table>
<thead>
<tr>
<th>Related Topic</th>
<th>Document Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic purge of event data</td>
<td>Chapter 31, “Administering Auto-Synchronization with Devices”</td>
</tr>
<tr>
<td>Automatic purge of statistical data</td>
<td>Chapter 32, “Administering Statistical Data Collection”</td>
</tr>
</tbody>
</table>

### Standards

<table>
<thead>
<tr>
<th>Standards</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.</td>
<td>—</td>
</tr>
</tbody>
</table>

## Feature History for DCNM-LAN Database Maintenance

Table 37-1 lists the release history for this feature.

<table>
<thead>
<tr>
<th>Feature Name</th>
<th>Releases</th>
<th>Feature Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database maintenance scripts</td>
<td>5.0(2)</td>
<td>No change from Release 4.2(3).</td>
</tr>
</tbody>
</table>
Troubleshooting DCNM-LAN

This chapter describes how to troubleshoot common issues you might experience while using Cisco Data Center Network Manager for LAN (DCNM-LAN).

For troubleshooting DCNM-LAN server installation issues, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.

This chapter includes the following sections:

- Tips for Using DCNM-LAN, page 38-1
- Trouble with Starting the DCNM-LAN Server, page 38-2
- Trouble with the DCNM-LAN Database, page 38-3
- Trouble with a PostgreSQL Database, page 38-5
- Trouble with the DCNM-LAN Client, page 38-6
- Trouble with Device Discovery or Device Status, page 38-11
- Trouble with Device Management, page 38-13
- Trouble with Topology, page 38-13
- Trouble with Device OS Management, page 38-14
- Trouble with Event Browsing, page 38-14

Tips for Using DCNM-LAN

This section includes the following topics:

- Events Tabs Show Fewer Events than the Event Browser, page 38-1
- Event Browser Pie Chart May Be Inaccurate for Small Numbers, page 38-2

Events Tabs Show Fewer Events than the Event Browser

The Event Browser feature shows all messages received by DCNM-LAN, even if the message pertains to a feature that is not supported by DCNM-LAN.

An Events tab shows only those messages that reflect the status of the currently selected feature. For some features, this is a subset of the possible messages about the feature.
Event Browser Pie Chart May Be Inaccurate for Small Numbers

The Event Browser pie chart may sometimes show incorrect sizes for wedges that are less than 5 percent of the pie; however, the numbers shown are correct.

Trouble with Starting the DCNM-LAN Server

This section includes the following topics:

- DCNM-LAN Server Fails to Start, page 38-2

DCNM-LAN Server Fails to Start

Check Table 38-1 for symptoms related to downloading the DCNM-LAN client. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| DCNM-LAN server fails to start. | The Postgres database did not install. | For troubleshooting DCNM-LAN server installation issues, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*.
| | The Postgres service is not running. | Start the Postgres service:
| | | • In Microsoft Windows Server, choose **Start** > **All Programs** > **Postgres 8.2** > **Start Service**.
| | | • In RHEL, use the following command:
| | | ```
| | | $INSTALLDIR/dcm/db/bin/DB start
| | | ```
| | The Postgres user credentials are incorrect. | 1. Correct the Postgres user credentials. For more information, see the “Updating DCNM-LAN Database Name and Username in pgAdmin III” section on page 38-3.
| | | 2. Start the DCNM-LAN server. For more information, see the “Starting DCNM-LAN Servers” section on page 27-2.
| | The ports used by the server are already in use. | 1. Check the server log for messages such as “Port *port-number* already in use.” The server log is the following file:
| | | `Installation_directory\jboss-4.2.2.GA\server\dcnm\log\server.log`
| | | 2. Determine which application is using the port and stop or reconfigure the application.
| | | 3. Restart the DCNM-LAN server.
Trouble with the DCNM-LAN Database

This section includes the following topics:

- **Trouble with a PostgreSQL Database, page 38-3**
- **Trouble with an Oracle Database, page 38-4**

**Note**
If the DCNM-LAN database fails or communication to the DCNM-LAN database fails, you must stop the DCNM-LAN server or shut down the cluster of DCNM-LAN servers before addressing the problem. Always verify that the DCNM-LAN database and the communication to the DCNM-LAN database are functioning properly before restarting the DCNM-LAN server or cluster of DCNM-LAN servers.

Trouble with a PostgreSQL Database

Check Table 38-2 for symptoms related to the pgAdmin III application for administering a PostgreSQL database used with DCNM-LAN. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

**Table 38-2 pgAdmin III Errors**

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message states that the DCNM-LAN database does not exist.</td>
<td>The DCNM-LAN database name might have changed during an upgrade or reinstallation of the DCNM-LAN server software.</td>
<td>In the pgAdmin III application, perform the steps in the “Updating DCNM-LAN Database Name and Username in pgAdmin III” section on page 38-3.</td>
</tr>
<tr>
<td>Error message states that password authentication failed for the DCNM-LAN database username.</td>
<td>The DCNM-LAN database username may have changed during an upgrade or reinstallation of the DCNM-LAN server software.</td>
<td></td>
</tr>
</tbody>
</table>

Updating DCNM-LAN Database Name and Username in pgAdmin III

You can update the DCNM-LAN database and username in pgAdmin III.

**Step 1**
Open the pgAdmin III application.

**Step 2**
In the Object Browser pane, under Servers, click **PostgreSQL Database Server 8.2**.
In the right-hand pane, the Properties tab appears with several other tabs.

**Step 3**
On the Properties tab, double-click **Maintenance database**.
A dialog box displays a Properties tab for the server.

**Step 4**
If you need to change the database name, click the **Maintenance DB** field and type the correct DCNM-LAN database name.

**Note**
The database name should be the name that you specified when you most recently upgraded or reinstalled the DCNM-LAN server software.
Step 5 If you need to change the database username, click the **Username** field and type the correct DCNM-LAN database username.

![Note]
The database username should be the database username that you specified when you most recently upgraded or reinstalled the DCNM-LAN server software.

Step 6 Click **OK**.

Step 7 In the Object Browser pane, double-click **PostgreSQL Database Server 8.2**.

If you changed the username in **Step 5**, the Connect to Server dialog box appears.

Step 8 If necessary, enter the password for the username that you specified in **Step 5** and click **OK**.

The pgAdmin III application connects to the DCNM-LAN database and displays the databases and login roles.

If you need additional assistance, see the Help menu in the pgAdmin III application or see the pgAdmin web site at the following URL:

http://pgadmin.org/docs/1.6/index.html

---

**Trouble with an Oracle Database**

If the DCNM-LAN server has trouble using an Oracle database, it logs the error messages in the following file:

`Installation_directory\jboss-4.2.2.GA\server\dcnm\log\server.log`

Check Table 38-3 for symptoms related to using an Oracle database with DCNM-LAN. For each error message, see the possible cause and follow the corresponding solution.
### Trouble with a PostgreSQL Database

When the PostgreSQL Database causes high CPU utilization on the DCNM server, perform the following:

<table>
<thead>
<tr>
<th>Step</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Stop the LAN and SAN server, by using the following command:&lt;br&gt;S$INSTALLDIR/dcm/dcnm/bin/stopLANSANServer.sh</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Stop the PostgreSQL Database, by using the following command:&lt;br&gt;S$INSTALLDIR/dcm/db/bin/DB stop</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Start the PostgreSQL Database, by using the following command:</td>
</tr>
</tbody>
</table>
$INSTALLDIR/dcm/db/bin/DB start

Step 4
Start LAN and SAN server, by using the following command:
$INSTALLDIR/dcm/dcnm/bin/startLANSANserver.sh
After the restart, CPU utilization will begin to increase while DCNM runs a device discovery job.

Note
The CPU utilization must decrease after the discovery is complete.

Trouble with the DCNM-LAN Client

This section includes the following topics:
- Cannot Download the DCNM-LAN Client from the Server, page 38-6
- Cannot Install the DCNM-LAN Client, page 38-7
- Cannot Start the DCNM-LAN Client, page 38-7
- Cannot Log into the DCNM-LAN Client, page 38-8
- Client Loses Connection to the DCNM-LAN Server, page 38-10

Cannot Download the DCNM-LAN Client from the Server

Check Table 38-4 for symptoms related to downloading the DCNM-LAN client. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cannot download the DCNM-LAN client from the server.</td>
<td>You are using the wrong URL or web server port.</td>
<td>Verify that you are using the correct URL, including the port number.</td>
</tr>
<tr>
<td></td>
<td>The TCP port is blocked by a gateway device.</td>
<td>Open the TCP port in your firewall. For information about ports used by DCNM-LAN, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.</td>
</tr>
<tr>
<td></td>
<td>You are using an unsupported web browser.</td>
<td>Use a supported web browser. For more information about supported web browsers, see the Cisco DCNM Release Notes, Release 7.x.</td>
</tr>
</tbody>
</table>
Cannot Install the DCNM-LAN Client

Check Table 38-4 for symptoms related to installing the DCNM-LAN client. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

Table 38-5 Cannot Install the DCNM-LAN Client

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installer attempts to install Java version JRE 1.7.0_55 but fails.</td>
<td>The system does not have Internet access.</td>
<td>The DCNM-LAN client installer requires Internet access to download the Java version JRE 1.7.0_55. If the system cannot access the Internet, use another system to download the Java installer, copy it to the system that you want to install the DCNM-LAN client on, install Java, and restart the DCNM-LAN client installation. You can download Java version JRE 1.7.0_55 from the Oracle Technology Network website.</td>
</tr>
<tr>
<td>Your network environment requires the use of a proxy connection to access the Internet.</td>
<td>If your network environment requires a proxy connection to permit the download of the Java installer, ensure that the proxy settings are configured in Internet Options, available from the Control Panel.</td>
<td></td>
</tr>
</tbody>
</table>

Cannot Start the DCNM-LAN Client

Check Table 38-6 for symptoms related to starting the DCNM-LAN client. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

Table 38-6 Cannot Start the DCNM-LAN Client

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| Cannot start the DCNM-LAN client. | The client installation may be corrupted. The wrong version of Java may be installed. | 1. Uninstall the DCNM-LAN client. For more information, see the “Uninstalling the DCNM-LAN Client” section on page 15-8.  
2. Download and install the DCNM-LAN client from the DCNM-LAN server. During the client installation, allow DCNM-LAN to install the supported version of Java on the computer. When you download the client from the DCNM-LAN server, if the supported version of Java is not detected on the computer, DCNM-LAN asks you for permission to install the supported version of Java. Your browser may notify you that the Java installer was digitally signed by an expired certificate. To continue, confirm the installation. For more information, see the “Downloading and Launching the DCNM-LAN Client” section on page 15-3. |

Cannot Log into the DCNM-LAN Client

Check Table 38-7 for symptoms related to logging into the DCNM-LAN client. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.
### Table 38-7 Cannot Log into the DCNM-LAN Client

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| Cannot log into the DCNM-LAN client.        | You forgot your password.                                                     | Ask a DCNM-LAN administrator to reset your password using one of the following scripts:  
  - For Microsoft Windows, use  
    `dcnm_root_directory/dcm/dcnm/bin/pwreset.bat` (by default, `dcnm_root_directory` is `c:\Program Files\Cisco Systems\dcm\dcnm\bin`).  
  - For Linux, use `dcnm_root_directory/dcm/dcnm/bin/pwreset.sh` (by default, the `dcnm_root_directory` is `/usr/local/cisco`).  
  To reset a password, run the appropriate script for the operating system that you are using, and then enter the user ID to be reset and the password to be used for it.  
  If no one has administrative access to DCNM-LAN, you can reset the local administrator account or change DCNM-LAN server authentication settings by reinstalling the DCNM-LAN server software. For more information, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*.  
  Authentication servers are not configured to authenticate DCNM-LAN users. | If DCNM-LAN is configured to use authentication servers, ensure that every authentication server that you have configured DCNM-LAN to use is configured to accept authentication requests from the DCNM-LAN server. If you have deployed DCNM-LAN in a clustered-server environment, ensure that every authentication server is configured to accept requests from each DCNM-LAN server in the cluster.  

| The DCNM-LAN server is down.                 | Reinstall the DCNM-LAN server. See the “Starting a Single DCNM-LAN Server” section on page 27-2. |                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                |
| The DCNM-LAN server is unreachable.         | Ensure that the computer that runs the DCNM-LAN client meets the network requirements for using the DCNM-LAN client remotely. Any gateway network devices between the DCNM-LAN client and server must allow connections to the DCNM-LAN web server and to the DCNM-LAN server. By default, the DCNM-LAN web server listens to port 8080 and the DCNM-LAN server listens to port 1099; however, you can configure these ports during DCNM-LAN server installation. If you need to change either port, reinstall the server and choose the Full Reinstall option. For information about ports used by DCNM-LAN, see the *Cisco DCNM Installation and Licensing Guide, Release 6.x*. |                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                |

| The DCNM-LAN server IP address changed after you installed the server. | Do the following:  
  1. Ensure that the IP address of the DCNM-LAN server is statically assigned.  
  2. Reinstall the DCNM-LAN server and choose the Full Reinstall option, which allows you to specify the server IP address. See the *Cisco DCNM Installation and Licensing Guide, Release 6.x*.  
  3. Log into the DCNM-LAN client and specify the new IP address of the DCNM-LAN server in the DCNM-LAN Server field of the login dialog box. |                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                |
Client Loses Connection to the DCNM-LAN Server

Check Table 38-8 for symptoms related to the DCNM-LAN client losing its connection with the server. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

**Table 38-8  Client Loses Connection to the DCNM-LAN Server**

<table>
<thead>
<tr>
<th>Symptoms</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Client loses connection to the server.</td>
<td>The client had a failure.</td>
<td>Restart the DCNM-LAN client.</td>
</tr>
<tr>
<td></td>
<td>The DCNM-LAN server is down.</td>
<td>Restart the DCNM-LAN server. See Chapter 27, “Starting and Stopping Cisco DCNM-LAN Servers.”</td>
</tr>
<tr>
<td>• The DCNM-LAN client window is pink.</td>
<td>The DCNM-LAN server is unreachable.</td>
<td>Investigate your network to determine if it meets the network requirements for using the DCNM-LAN client remotely. For information about ports used by DCNM-LAN, see the Cisco DCNM Installation and Licensing Guide, Release 6.x.</td>
</tr>
</tbody>
</table>
Trouble with Device Discovery or Device Status

Check Table 38-9 for symptoms related to issues with device discovery or the device status. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

Table 38-9  Trouble with Device Discovery or Management

<table>
<thead>
<tr>
<th>Symptoms</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>• A device discovery task fails.</td>
<td>Incorrect device credentials were provided.</td>
<td>Reenter the username and password, and try discovering the device again.</td>
</tr>
<tr>
<td>• A device status changes to Unmanaged or Unreachable.</td>
<td>The SSH server is disabled on the device.</td>
<td>Reenable the SSH server on the device and try discovering the device again.</td>
</tr>
<tr>
<td></td>
<td>The maximum number of SSH sessions that the device can support has been reached.</td>
<td>Check the number of user sessions on the device. Free at least one connection and try discovering the device again.</td>
</tr>
<tr>
<td></td>
<td>CDP is disabled on the device or on the device interface that the DCNM-LAN server connects to.</td>
<td>Ensure that CDP is enabled on the device globally and that it is enabled on the specific interface that the DCNM-LAN server connects to.</td>
</tr>
<tr>
<td></td>
<td>The device interface that the DCNM-LAN server connects to is shut down.</td>
<td>Ensure that the device interface that the DCNM-LAN server connects to is up.</td>
</tr>
<tr>
<td></td>
<td>The device restarted or shut down before discovery could complete.</td>
<td>Ensure that the device is running and try discovering the device again.</td>
</tr>
<tr>
<td></td>
<td>The DCNM-LAN server cannot reach the device.</td>
<td>Ensure that the network requirements for device management are met. See the “Verifying the Discovery Readiness of a Cisco NX-OS Device” section on page 29-7.</td>
</tr>
<tr>
<td></td>
<td>Discrepancy in system log messages.</td>
<td>Use the clear logging logfie command to clear the system log in the device and try to manually discover the device.</td>
</tr>
<tr>
<td></td>
<td>Discrepancy in accounting log messages.</td>
<td>Use the clear accounting log command to clear the accounting log messages in the device and try to manually discover the device.</td>
</tr>
</tbody>
</table>

Note: When working with a custom VDC, clear the accounting log messages only from the default VDC.

Deep Discovery Soft Limit in DCNM 6.2.3

In DCNM 6.2.3, we have enforced a limit of devices that can be managed in the DCNM LAN client. This limit is only applicable for the deep discovery and can be configured. To configure the property, open Jboss-service.xml, the name of the property is cisco.dcbu.dcm.device.managed. The default value of this property is 50 and you can increase it to a maximum of 75. If the specified value is more than 75, then the value will be taken as 75. If the number of managed devices (Calculated as:
number of managed VDC (Nexus 7k) + number of managed devices (Nexus 5k/3k/1k/cat6k) + number of IP addresses in the deep discovery + number of IP addresses in the deep discovery request) is more than the soft limit then the deep request will be dishonored.

Scenario 1

If you have 51 switches shallow discovered and you perform deep discovery of all the 51 switches. You will be prompted with the following message at the beginning of the deep discovery and it fails “Failed to do deep discovery of task. Number of devices already discovered is <Current Number say 40 or 45). Threshold set for number of manageable devices is 50. Reduce the number of devices selected and retry the discovery”.

Scenario 2

If you have already discovered 49 switches and try to discover 2 more switches. An error message will be displayed stating that you have exceeded the maximum limit of 50 managed devices in DCNM LAN. You must reduce the number of selected devices to ensure that the total count is equal to or below 50.

Scenario 3

If you have upgraded from Cisco DCNM 5.2/6.1 to Cisco DCNM 6.2.3 and discovered 62 switches using Cisco DCNM 5.2/6.1. All the devices managed in DCNM 5.2/6.1 will be re-discovered. Thus, if you have 62 devices, you will be able to manage 62 devices after upgrade to DCNM 6.2.3. However, if any of these 62 devices are deleted or re-discovered manually, the limit will be enforced. You will receive the following notification that is displayed during new installation “Failed to do deep discovery of task. Number of devices already discovered is <Current Number say 40 or 45). Threshold set for number of manageable devices is 50. Reduce the number of devices selected and retry the discovery”.

How to increase the threshold limit

Step 1 Go to <DCNM Root> dcm\jboss-4.2.2.GA\server\dcnm\conf. <DCNM Root> is the directory where DCNM is installed.

- In Microsoft Windows, the default path of the root directory is C:\Program Files\Cisco Systems.
- In Linux, the default path of the root directory is /usr/local/cisco.

Step 2 In the Jboss-service.xml file, look for the following property cisco.dcbu.dcm.jms.port.

Step 3 Add the property cisco.dcbu.dcm.device.managed =75 immediately after the property mentioned in Step 2.

<attribute name="Properties">
cisco.dcbu.dcm.dbCfgResource=database/postgresql.cfg.xml
cisco.dcbu.dcm.mappingCfgResource=com/cisco/dcbu/dcm/model/model.cfg.xml
cisco.dcbu.dcm.notification.syslog.listenerPort=5445
cisco.dcbu.dcm.data.path=C:\\Program Files\\Cisco Systems\\dcnm\\data
cisco.dcbu.dcm.notification.syslog.thresholdLimit=1000
self.dcbu.dcm.cluster.deltaStartingTimer=120
self.dcbu.dcm.cluster.deltaChangingTimer=60
cisco.dcnm.remoting.transport=socket
self.dcbu.dcm.service.discovery.background=true
cisco.dcbu.dcm.discovery.pool.cdp.size=15
cisco.dcnm.remoting.port=3873
cisco.dcnm.remoting.ejbport=3873
cisco.dcnm.remoting.sslejbport=3843
cisco.dcnm.remoting.client.invokerDestructionDelay=0
cisco.dcbu.dcm.jms.port=4457
cisco.dcbu.dcm.device.managed =75
</attribute>

**Trouble with Device Management**

Check Table 38-6 for symptoms related to device management. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

**Table 38-10 Trouble with Device Management**

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clearing the log file or the accounting log on a Cisco NX-OS device does not cause DCNM-LAN to rediscover the device automatically.</td>
<td>The device did not generate a system message about the accounting log or the log file being cleared. This problem is particularly likely if the device is a Cisco MDS 9000 Family Multilayer Switch running Cisco SAN-OS Release 3.1 or earlier releases.</td>
<td>Rediscover the device.</td>
</tr>
<tr>
<td>The DCNM-LAN client shows device configuration information that is out of date.</td>
<td>The DCNM-LAN server was down.</td>
<td>You can do either of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Rediscover the device. For more information, see the “Devices” section on page 30-2.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Restart the DCNM-LAN server with a clean database. If the server was down for a long time, this action is the recommended solution.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2. Cleaning a DCNM-LAN Database, page 37-5</td>
</tr>
</tbody>
</table>

**Trouble with Topology**

Check Table 38-11 for symptoms related to using the topology feature. For each symptom that describes your problem, determine which possible cause applies and follow the corresponding solution.
Trouble with Device OS Management

Check Table 38-12 for symptoms related to the Device OS Management feature. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

Table 38-12  Trouble with Device OS Management

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>During a software installation job, the software image file transfer</td>
<td>The connection between the file server and the device is slow.</td>
<td>Use a file server that is on the same LAN as the devices included in the software installation job.</td>
</tr>
<tr>
<td>between a file server and a device takes too much time.</td>
<td></td>
<td>If all of the available file servers transfer software image files too slowly, before you create the software installation job, manually copy the files to the devices that you will include the job and configure the job to use the manually copied files rather than a file server. For information about configuring a software installation job, see the System Management Configuration Guide, Cisco DCNM for LAN, Release 6.x.</td>
</tr>
</tbody>
</table>

Trouble with Event Browsing

Check Table 38-13 for symptoms related to event browsing issues. For each symptom that describes your problem, determine which possible causes apply and follow the corresponding solutions.

Table 38-13  Trouble with Event Browsing

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Events available on the device command line do not appear in the DCNM-LAN client.</td>
<td>Logging levels on managed devices are set incorrectly.</td>
<td>Check the logging level configuration on managed devices. See the “Cisco NX-OS System-Message Logging Requirements” section on page 29-4.</td>
</tr>
<tr>
<td>Too few events are shown in Event Browser or an Events tab.</td>
<td>The DCNM-LAN client fetches events that are not old enough.</td>
<td>Check the events-related setting in the DCNM-LAN client preferences. For more information, see the “Configuring the Maximum Age of Events Fetched from the Server” section on page 16-18.</td>
</tr>
</tbody>
</table>
### Table 38-13  Trouble with Event Browsing

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Too many events are shown in Event Browser or on an Events tab.</td>
<td>A managed device has an issue that is generating many system log messages.</td>
<td>Temporarily unmanage the device until you resolve the issues on the device.</td>
</tr>
<tr>
<td></td>
<td>Logging levels on managed devices are set incorrectly.</td>
<td>Check the logging level configuration on managed devices. See the “Cisco NX-OS System-Message Logging Requirements” section on page 29-4.</td>
</tr>
<tr>
<td>A feature Events tab does not show events that appear in the Event Browser.</td>
<td>By design, an Events tab shows only messages that apply to the currently selected feature and may show only a subset of the possible messages for the feature. For more information, see the “Events Tabs Show Fewer Events than the Event Browser” section on page 38-1.</td>
<td>Use the Event Browser to see status-related system messages received by DCNM-LAN. For more information, see the System Management Configuration Guide, Cisco DCNM for LAN, Release 6.x.</td>
</tr>
</tbody>
</table>
Cisco DCNM Unsupported Feature List

This appendix contains a list of features and functions not supported by CiscoDCNM or Device Manager. This list is organized according to the chapter in which the feature would be described if it were supported. (See Table A-1.)

<table>
<thead>
<tr>
<th>Part</th>
<th>Chapter/Category</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 Cisco MDS NX-OS Installation and Switch Management</td>
<td>Obtaining and Installing Licenses</td>
<td>Backing Up License Files</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Moving Licences Between Switches</td>
</tr>
<tr>
<td>Initial Configuration</td>
<td>Starting a Switch (Initial Setup)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configuring Console Settings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configuring COM1 and Modem Settings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adjusting for Daylight Savings Time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configuring the Initialization String</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Basic Switch Configuration</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Terminal Settings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>File System Commands</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Displaying File Contents</td>
<td></td>
</tr>
<tr>
<td>Software Images</td>
<td>Manual Upgrade on a Dual Supervisor Switch</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Corrupted Bootflash Recovery</td>
<td></td>
</tr>
</tbody>
</table>
## Features Not Supported by Cisco DCNM or Device Manager (continued)

<table>
<thead>
<tr>
<th>Part</th>
<th>Chapter/Category</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Configuration Files</td>
<td>Formatting External CompactFlash</td>
<td>Compressing and Uncompressing Files</td>
</tr>
<tr>
<td></td>
<td>Displaying the Last Lines in a File</td>
<td>Executing Commands Specified in a Script</td>
</tr>
<tr>
<td></td>
<td>Setting the Delay Time</td>
<td>Displaying Configuration Files</td>
</tr>
<tr>
<td></td>
<td>Unlocking the Startup Configuration File</td>
<td>Accessing Remote File Systems</td>
</tr>
<tr>
<td>Configuring High Availability</td>
<td>Copying Images to the Standby Supervisor</td>
<td>Clock Modules</td>
</tr>
<tr>
<td>Managing System Hardware</td>
<td>Connecting to a Module</td>
<td>Connecting to a Module</td>
</tr>
<tr>
<td>Managing Modules</td>
<td>Preserving Module Configuration</td>
<td>Preserving Module Configuration</td>
</tr>
<tr>
<td></td>
<td>Purging Module Configuration</td>
<td>Purging Module Configuration</td>
</tr>
<tr>
<td></td>
<td>EPLD Configuration</td>
<td>EPLD Configuration</td>
</tr>
<tr>
<td></td>
<td>Configuring SSI Boot Image</td>
<td>Configuring SSI Boot Image</td>
</tr>
<tr>
<td></td>
<td>Managing SSMs</td>
<td>Managing SSMs</td>
</tr>
<tr>
<td>3 Switch Configuration</td>
<td>Configuring Interfaces</td>
<td>Configuring Interfaces</td>
</tr>
<tr>
<td></td>
<td>Displaying the ALPA Cache Contents</td>
<td>Clearing the ALPA Cache</td>
</tr>
<tr>
<td></td>
<td>Scheduling Tasks</td>
<td>Schedule Configuration</td>
</tr>
<tr>
<td>4 Fabric Configuration</td>
<td>Inter-VSAN Routing</td>
<td>Inter-VSAN Routing (IVR) FICON Support</td>
</tr>
<tr>
<td></td>
<td>Configuration</td>
<td>IVR Service Groups</td>
</tr>
<tr>
<td>6 IP Services</td>
<td>Configuring FCIP</td>
<td>Configuring FCIP</td>
</tr>
<tr>
<td></td>
<td>Displaying and Clearing ARP Caches</td>
<td>Displaying and Clearing ARP Caches</td>
</tr>
<tr>
<td></td>
<td>Configuring the SAN Extension Tuner</td>
<td>Tuning Configuration</td>
</tr>
<tr>
<td></td>
<td>Configuring IP Storage</td>
<td>IPS Module Core Dumps</td>
</tr>
<tr>
<td>8 Network and Switch</td>
<td>Monitoring Network Traffic</td>
<td>Monitoring Network Traffic</td>
</tr>
<tr>
<td>Monitoring</td>
<td>Using SPAN</td>
<td>Using SPAN</td>
</tr>
<tr>
<td></td>
<td>Remote SPAN</td>
<td>Remote SPAN</td>
</tr>
</tbody>
</table>
### Table A-1 Features Not Supported by Cisco DCNM or Device Manager (continued)

<table>
<thead>
<tr>
<th>Part</th>
<th>Chapter/Category</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 Troubleshooting</td>
<td>Troubleshooting Your Fabric</td>
<td>Loop Monitoring</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Configuring CIM</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CFS for FC Timers</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Local Text Based Capture</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Capturing FC Analyzer Frames Locally</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sending Captured FC Analyzer Frames to a Remote IP Address</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clearing Configured FC Analyzer Information</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Displaying a List of Hosts Configured for Remote Capture</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Using Fabric Analyzer Display Filters</td>
</tr>
<tr>
<td>Monitoring System Processes and</td>
<td>Saving the Last Core to Flash</td>
<td></td>
</tr>
<tr>
<td>Logs</td>
<td>Kernel Core Dumps</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System Health Initiation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Loopback Test Configuration</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Frequency</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hardware Failure Action</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tests for a Specified Module</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Clearing Previous Error Reports</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Online Health Management System</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Enabling and Disabling the OHMS</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Enabling and Disabling</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hardware Failure Action</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Configuring Onboard Failure</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logging</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Clearing Previous Error Reports</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Performing Tests for a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Specified Module</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Configuring Automatic</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Loopback Tests</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Performing SERDES Loopback</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tests</td>
<td></td>
</tr>
</tbody>
</table>
Interface Nonoperational Reason Codes

If the administrative state for an interface is up and the operational state is down, the reason code differs based on the nonoperational reason code as described in Table B-1.

### Table B-1  Reason Codes for Nonoperational States

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
<th>Applicable Modes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link failure or not connected</td>
<td>Physical layer link is not operational.</td>
<td>All</td>
</tr>
<tr>
<td>SFP not present</td>
<td>The small form-factor pluggable (SFP) hardware is not plugged in.</td>
<td></td>
</tr>
<tr>
<td>Initializing</td>
<td>The physical layer link is operational and the protocol initialization is in progress.</td>
<td></td>
</tr>
<tr>
<td>Reconfigure fabric in progress</td>
<td>The fabric is currently being reconfigured.</td>
<td></td>
</tr>
<tr>
<td>Offline</td>
<td>Cisco MDS SAN-OS waits for the specified R_A_TOV time before retrying initialization.</td>
<td></td>
</tr>
<tr>
<td>Inactive</td>
<td>The interface VSAN is deleted or is in a suspended state.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To make the interface operational, assign that port to a configured and active VSAN.</td>
<td></td>
</tr>
<tr>
<td>Hardware failure</td>
<td>A hardware failure is detected.</td>
<td></td>
</tr>
<tr>
<td>Error disabled</td>
<td>Error conditions require administrative attention. Interfaces may be error-disabled for various reasons. For example:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Configuration failure.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Incompatible buffer-to-buffer credit configuration.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>To make the interface operational, you must first fix the error conditions causing this state; and next, administratively shut down or enable the interface.</td>
<td></td>
</tr>
</tbody>
</table>
### Table B-1  Reason Codes for Nonoperational States (continued)

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
<th>Applicable Modes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Isolation due to ELP failure</td>
<td>Port negotiation failed.</td>
<td>Only E ports and TE ports</td>
</tr>
<tr>
<td>Isolation due to ESC failure</td>
<td>Port negotiation failed.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to domain overlap</td>
<td>The Fibre Channel domains (fcdomain) overlap.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to domain ID assignment failure</td>
<td>The assigned domain ID is not valid.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to other side E port isolated</td>
<td>The E port at the other end of the link is isolated.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to invalid fabric reconfiguration</td>
<td>The port is isolated due to fabric reconfiguration.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to domain manager disabled</td>
<td>The fcdomain feature is disabled.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to zone merge failure</td>
<td>The zone merge operation failed.</td>
<td></td>
</tr>
<tr>
<td>Isolation due to VSAN mismatch</td>
<td>The VSANs at both ends of an ISL are different.</td>
<td></td>
</tr>
<tr>
<td>Nonparticipating</td>
<td>FL ports cannot participate in loop operations. It may happen if more than one FL port exists in the same loop, in which case all but one FL port in that loop automatically enters nonparticipating mode.</td>
<td>Only FL ports and TL ports</td>
</tr>
<tr>
<td>PortChannel administratively down</td>
<td>The interfaces belonging to the PortChannel are down.</td>
<td>Only PortChannel interfaces</td>
</tr>
<tr>
<td>Suspended due to incompatible speed</td>
<td>The interfaces belonging to the PortChannel have incompatible speeds.</td>
<td></td>
</tr>
<tr>
<td>Suspended due to incompatible mode</td>
<td>The interfaces belonging to the PortChannel have incompatible modes.</td>
<td></td>
</tr>
<tr>
<td>Suspended due to incompatible remote switch WWN</td>
<td>An improper connection is detected. All interfaces in a PortChannel must be connected to the same pair of switches.</td>
<td></td>
</tr>
</tbody>
</table>
DCNM-SAN Event Management

DCNM Event Management tool (EMAN) offers event management capability directly in Cisco MDS, Nexus 7000 and 5000 series switches to monitor events and take informational or corrective action as events occur, or when a threshold is reached. EMAN captures the state of the switches during critical situations helping to take immediate recovery actions and gather information to perform root-cause analysis.

An event is generated when the object matches specified values or crosses specified thresholds. When it detects an event, EMAN will parse the event for the host name, severity and then determine the host-to-application dependency by comparing the event in the host table. EMAN monitors these events to detect the severity type such as warning, critical and emergency of the events. It will also list the impacted components such as a host, ISL or a storage port. Switch health and performance threshold are the two event types that the EMAN monitor.

This Appendix contains the following sections:
- Benefits of the Event Management Tool, page C-1
- DCNM-SAN Event Management, page C-1
- DCNM-SAN Event Classification, page C-3

Benefits of the Event Management Tool

EMAN tracks resource utilization and resource depletion by monitoring events in 45000 ports and 240 switches. It also provides a mechanism to send notifications whenever the specified threshold values are exceeded by any of the components. This notification helps network administrators diagnose resource utilization issues and prioritize resources making it more scalable.

EMAN helps in addressing component issues real time by performing the following functions:
- Monitoring resource usage.
- Using resource threshold pre-sets.
- Generating alerts when resource utilization reaches the specified level.
- Provides dependency path mapping.

DCNM-SAN Event Management

This section describes how DCNM handles asynchronous transfer events from the managed switches and contains the following topics:
Events

The following are the three primary methods by which DCNM detects events:

- **SNMP**—The Simple Network Management Protocol v1 (SNMPv1) event detector allows an event to be generated when the object matches specified values or crosses specified thresholds. The Cisco MDS 9000 switch can contain up to 10 trap destinations. The unmanaged fabrics or switches are removed from the list of traps destinations.

- **Syslog**—DCNM-SAN receives syslog messages and are logged in the events table in the database and archived on each switch.

- **Fabric Model**—DCNM-SAN can function even without receiving SNMP traps from the managed switches. DCNM-SAN polls for traps every 5 minutes and does a deeper discovery every 30 minutes by default.

Purpose

Asynchronous event handling serves the following purposes:

- **Model Update**—DCNM-SAN design the model of the physical and logical connectivity of each fabric. Asynchronous events enables real time synchronization with the fabric. In cases such as a linkdown, this model quickly updates the event without polling the fabric. However, for major changes such as an ISL link change, this model polls the fabric to synchronize.

- **Log**—All the events are logged into a database. The number of events that can be logged is set to 10,000 by default. You can view this log in the Cisco DCNM-SAN Client and in Cisco DCNM Web Client. The Cisco DCNM Web Client stores all events in the database unless you do not apply any filters. The Cisco DCNM-SAN Client log is restricted to the fabric(s) that are opened in the client’s interface. The Cisco DCNM-SAN Client automatically updates the table as new events appear.

- **Map**—The Cisco DCNM-SAN Client’s updates the map automatically when topology changes.

Forwarding

Events are forwarded in three ways:

- **Cisco Call Home**—The Cisco MDS 9000 series switches generates an email at the event of a critical event such as a module down etc. You can customize this email to include additional information. You can use Cisco DCNM-SAN client to configure Cisco call home feature and it has no operational dependency on Cisco DCNM.

- **EMC Call Home**—If you enable this feature, the Cisco DCNM server generates an EMC call home email at the event of a critical event such as a linkDown event etc. This email is created in XML format.

- **Event Forwarding**—You can optionally choose to send an email or SNMP traps from Cisco DCNM for any or all events that are logged into the database.
DCNM-SAN Event Classification

Port Events

Port events provides real-time information about the operational status of the host ports, storage ports, ISLs, NPV etc in your network. At the event of a fault, the Cisco DCNM EMAN generates an event or events that are rolled up into an alert. The port events are broadly classified into two as follows:

- **Service Impacting**—Indicates the severity of the event that impacts the service. Examples are PMON, RMON and SFP events.
- **Outage**—Indicates the severity of the event that impacts the functioning of the device. Examples are link up/down and threshold events.

Event Log Format

Events log consists of parseable information that is available to higher level management applications in the following format:

```
<fabric>/<switch> <localTime> <severity> <type> <description>
```

- **Fabric/Switch**—The name of the fabric or the switch.
- **LocalTime**—The date and time of the event occurred. The time is in the following format: hh:mm:ss.ttt. The date is in the following format: MM/DD/YYYY.
- **Severity**—Event severity level, combination of single events, or a range of event severity levels. The severity contains one of the following:
  - Emergencies
  - Alert
  - Critical
  - Error
  - Warning
  - Notice
  - Informational
  - Debugging
- **Type**—Type of events.
  - Fabric
  - FICON
  - IVR
  - License
  - Other
  - Port Alarm
  - Port Up and Port Down
  - Security
DCNM-SAN Event Classification

– Switch Hardware
– Switch Manageability
– Threshold
– VSAN
– Zone

• Description—Description of the event in the following format:
  
  \(<portType>: <name>, Port: <interface>, VSAN: <vsanId(s)>, <condition>\)

## Event Types

### IVR

**Table C-1**  IVR Events

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>civrDomainConflictNotify</td>
<td></td>
</tr>
<tr>
<td>civrZoneActivationDoneNotify</td>
<td></td>
</tr>
<tr>
<td>civrZoneCompactNotify</td>
<td></td>
</tr>
<tr>
<td>civrZoneDeactivationDoneNotify</td>
<td></td>
</tr>
<tr>
<td>civrDomainConflictNotify</td>
<td></td>
</tr>
<tr>
<td>civrAfidConfigNotify</td>
<td></td>
</tr>
</tbody>
</table>

### License

**Table C-2**  Licence Events

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>clmLicenseExpiryNotify</td>
<td></td>
</tr>
<tr>
<td>clmLicenseExpiryWarningNotify</td>
<td></td>
</tr>
<tr>
<td>clmLicenseFileMissingNotify</td>
<td></td>
</tr>
<tr>
<td>clmNoLicenseForFeatureNotify</td>
<td></td>
</tr>
</tbody>
</table>

### Port Alarm

Any RMON event that relates to an interface object.
### Port Up and Port Down

Model-generated events relating to Host, Storage, ISL, NP_Links

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cIfXcvrMonStatusChangeNotif</td>
<td></td>
</tr>
</tbody>
</table>

### Security

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>casServerStateChange</td>
<td></td>
</tr>
<tr>
<td>cfcspAuthFailTrap</td>
<td></td>
</tr>
<tr>
<td>ciscoPsmFabricBindDenyNotifyNew</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowBadSa</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowSetupFail</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowSysFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowTunnelStart</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowTunnelStop</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapAdded</td>
<td></td>
</tr>
</tbody>
</table>

**Note**

Port Moved events will not be logged.
<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ciscoIPsecProvCryptomapAttached</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapDetached</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigOperStateChanged</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPolicyAdded</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPolicyDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPskAdded</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPskDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeFlowInNewGrpRejected</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeFlowOutNewGrpRejected</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgCertCrlFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgSysFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgTunnelStart</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgTunnelStop</td>
<td></td>
</tr>
<tr>
<td>cefcFRUInserted</td>
<td></td>
</tr>
<tr>
<td>cefcFRUInserted</td>
<td></td>
</tr>
<tr>
<td>cefcPowerStatusChange</td>
<td></td>
</tr>
<tr>
<td>cefcPowerSupplyOutputChange</td>
<td></td>
</tr>
<tr>
<td>cefcFanTrapStatusChange</td>
<td></td>
</tr>
<tr>
<td>cefcUnrecognizedFRU</td>
<td></td>
</tr>
<tr>
<td>cefcFRUInserted</td>
<td></td>
</tr>
<tr>
<td>cefcFRUInserted</td>
<td></td>
</tr>
<tr>
<td>cefcFRURemoved</td>
<td></td>
</tr>
<tr>
<td>cefcFRURemoved</td>
<td></td>
</tr>
<tr>
<td>cefcUnrecognizedFRU</td>
<td></td>
</tr>
<tr>
<td>entPhysicalVendorType</td>
<td></td>
</tr>
<tr>
<td>entPhysicalName</td>
<td></td>
</tr>
<tr>
<td>entPhysicalModelName</td>
<td></td>
</tr>
<tr>
<td>cefcPhysicalStatus</td>
<td></td>
</tr>
<tr>
<td>cefcPowerStatusChange</td>
<td></td>
</tr>
<tr>
<td>cefcFRUPOWEROperStatus</td>
<td></td>
</tr>
<tr>
<td>cefcFRUPOWERAdminStatus</td>
<td></td>
</tr>
<tr>
<td>cefcFanTrapStatusChange</td>
<td></td>
</tr>
</tbody>
</table>
Switch Managability

Table C-7  Switch Event Types

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Discovered</td>
<td></td>
</tr>
<tr>
<td>Switch Rebooted</td>
<td></td>
</tr>
<tr>
<td>Switch Unreachable</td>
<td></td>
</tr>
<tr>
<td>Switch Manageable</td>
<td></td>
</tr>
<tr>
<td>Switch Unmanageable</td>
<td></td>
</tr>
<tr>
<td>Switch IP Changed</td>
<td></td>
</tr>
<tr>
<td>warmStart</td>
<td></td>
</tr>
<tr>
<td>coldStart</td>
<td></td>
</tr>
<tr>
<td>ciscoRFPProgressionNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoRFSwactNotif</td>
<td></td>
</tr>
</tbody>
</table>

Threshold

Table C-8  Threshold Events

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cHcRisingAlarm</td>
<td></td>
</tr>
<tr>
<td>cHcFallingAlarm</td>
<td></td>
</tr>
<tr>
<td>hcRisingAlarm</td>
<td></td>
</tr>
<tr>
<td>hcFallingAlarm</td>
<td></td>
</tr>
<tr>
<td>risingAlarm</td>
<td></td>
</tr>
<tr>
<td>FallingAlarm</td>
<td></td>
</tr>
</tbody>
</table>

VSAN

Table C-9  VSAN Events

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vsanPortMembershipChange</td>
<td></td>
</tr>
<tr>
<td>vsanStatusChange</td>
<td></td>
</tr>
</tbody>
</table>

Zone

Table C-10  Zone Events

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>zoneActivateNotify</td>
<td></td>
</tr>
<tr>
<td>zoneCompactNotify</td>
<td></td>
</tr>
</tbody>
</table>
### Others

This table contains all other trap types such as ISCSI, VRRP, Cisco callhome, flex attach, FDMI, FICON, CFS, PMON config, SVC, SCSI, SNE, Core, Domain Manager, FCNS, FCOT, and UCS.

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>zoneDefZoneBehaviourChngNotify</td>
<td></td>
</tr>
<tr>
<td>zoneMergeFailureNotify</td>
<td></td>
</tr>
<tr>
<td>zoneMergeSuccessNotify</td>
<td></td>
</tr>
<tr>
<td>zoneServiceReqRejNotify</td>
<td></td>
</tr>
<tr>
<td>zoneUnsuppMemInIntOpModeNotify</td>
<td></td>
</tr>
<tr>
<td>zoneDefZoneBehaviourChngNotify</td>
<td></td>
</tr>
<tr>
<td>zoneMergeFailureNotify</td>
<td></td>
</tr>
<tr>
<td>zoneMergeSuccessNotify</td>
<td></td>
</tr>
<tr>
<td>zoneServiceReqRejNotify</td>
<td></td>
</tr>
<tr>
<td>zoneUnsuppMemInIntOpModeNotify</td>
<td></td>
</tr>
</tbody>
</table>

**Table C-11 Other Events**

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cIsnsClientInitialRegistration</td>
<td></td>
</tr>
<tr>
<td>cIsnsClientLostConnection</td>
<td></td>
</tr>
<tr>
<td>cIsnsClientNoServerDiscovered</td>
<td></td>
</tr>
<tr>
<td>cIsnsClientStart</td>
<td></td>
</tr>
<tr>
<td>cIsnsServerShutdown</td>
<td></td>
</tr>
<tr>
<td>cIsnsServerStart</td>
<td></td>
</tr>
<tr>
<td>cVrrpNotificationNewMaster</td>
<td></td>
</tr>
<tr>
<td>cVrrpNotificationProtoError</td>
<td></td>
</tr>
<tr>
<td>casServerStateChange</td>
<td></td>
</tr>
<tr>
<td>ccCopyCompletion</td>
<td></td>
</tr>
<tr>
<td>ccmAlertGroupTypeAddedNotif</td>
<td></td>
</tr>
<tr>
<td>ccmAlertGroupTypeDeletedNotif</td>
<td></td>
</tr>
<tr>
<td>ccmCLIRunningConfigChanged</td>
<td></td>
</tr>
<tr>
<td>ccmCTIDRolledOver</td>
<td></td>
</tr>
<tr>
<td>ccmEventNotif</td>
<td></td>
</tr>
<tr>
<td>ccmSmtpMsgSendFailNotif</td>
<td></td>
</tr>
<tr>
<td>ccmSmtpServerFailNotif</td>
<td></td>
</tr>
<tr>
<td>cfaIfVirtualWwnChangeNotify</td>
<td></td>
</tr>
<tr>
<td>cfaVirtualWwnMapChangeNotify</td>
<td></td>
</tr>
<tr>
<td>cfDMIRejectRegNotify</td>
<td></td>
</tr>
<tr>
<td>cficonPortInfoChange</td>
<td></td>
</tr>
<tr>
<td>ciscoCFSDiscoveryCompleteNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoCFSFeatureActionNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoCFSMergeFailNotif</td>
<td></td>
</tr>
<tr>
<td>Event Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>ciscoCFSSStatPeerStatusChngNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoConfigManEvent</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowBadSa</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowSetupFail</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowSysFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowTunnelStart</td>
<td></td>
</tr>
<tr>
<td>ciscoEnhIpsecFlowTunnelStop</td>
<td></td>
</tr>
<tr>
<td>ciscoExtScsiLunDiscDoneNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoFCCCongestionRateLimitEnd</td>
<td></td>
</tr>
<tr>
<td>ciscoFCCCongestionRateLimitStart</td>
<td></td>
</tr>
<tr>
<td>ciscoFCCCongestionStateChange</td>
<td></td>
</tr>
<tr>
<td>ciscoFeatOpStatusChange</td>
<td></td>
</tr>
<tr>
<td>ciscoFeatureOpStatusChange</td>
<td></td>
</tr>
<tr>
<td>ciscoFeatureSetOpStatusChange</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashCopyCompletionTrap</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashDeviceChangeTrap</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashDeviceInsertedNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashDeviceInsertedNotifRev1</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashDeviceRemovedNotif</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashDeviceRemovedNotifRev1</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashMiscOpCompletionTrap</td>
<td></td>
</tr>
<tr>
<td>ciscoFlashPartitioningCompletionTrap</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapAdded</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapAttached</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIPsecProvCryptomapDetached</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigOperStateChanged</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPolicyAdded</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPolicyDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPskAdded</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeConfigPskDeleted</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeFlowInNewGrpRejected</td>
<td></td>
</tr>
<tr>
<td>ciscoIkeFlowOutNewGrpRejected</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgCertCrlFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgSysFailure</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgTunnelStart</td>
<td></td>
</tr>
<tr>
<td>ciscoIpsSgTunnelStop</td>
<td></td>
</tr>
<tr>
<td>Event Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>ciscoPmonPolicyChangeNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoPrefPathHWFailureNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoPsmFabricBindDenyNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoPsmFabricBindDenyNotifyNew</td>
<td></td>
</tr>
<tr>
<td>ciscoPsmPortBindEPortDenyNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoPsmPortBindFPortDenyNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoSanBaseSvcClusterNewMaster</td>
<td></td>
</tr>
<tr>
<td>ciscoSanBaseSvcInterfaceCreate</td>
<td></td>
</tr>
<tr>
<td>ciscoSanBaseSvcInterfaceDelete</td>
<td></td>
</tr>
<tr>
<td>ciscoScsiFlowStatsNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoScsiFlowVerifyNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoScsiFlowWrAccNotify</td>
<td></td>
</tr>
<tr>
<td>ciscoSmeClusterNewMaster</td>
<td></td>
</tr>
<tr>
<td>ciscoSmeInterfaceCreate</td>
<td></td>
</tr>
<tr>
<td>ciscoSmeInterfaceDelete</td>
<td></td>
</tr>
<tr>
<td>ciscoSystemClockChanged</td>
<td></td>
</tr>
<tr>
<td>ciscoVshaStateChngNotify</td>
<td></td>
</tr>
<tr>
<td>ciuUpgradeJobStatusNotify</td>
<td></td>
</tr>
<tr>
<td>ciuUpgradeOpCompletionNotify</td>
<td></td>
</tr>
<tr>
<td>cseFailSwCoreNotify</td>
<td></td>
</tr>
<tr>
<td>cseFailSwCoreNotifyExtended</td>
<td></td>
</tr>
<tr>
<td>cseHaRestartNotify</td>
<td></td>
</tr>
<tr>
<td>cseShutDownNotify</td>
<td></td>
</tr>
<tr>
<td>csiErrorTrap</td>
<td></td>
</tr>
<tr>
<td>csiInformationTrap</td>
<td></td>
</tr>
<tr>
<td>csiWarningTrap</td>
<td></td>
</tr>
<tr>
<td>dmDomainIdNotAssignedNotify</td>
<td></td>
</tr>
<tr>
<td>dmFabricChangeNotify</td>
<td></td>
</tr>
<tr>
<td>dmNewPrincipalSwitchNotify</td>
<td></td>
</tr>
<tr>
<td>fcNameServerDatabaseFull</td>
<td></td>
</tr>
<tr>
<td>fcNameServerRejectRegNotify</td>
<td></td>
</tr>
<tr>
<td>fcPingCompletionNotify</td>
<td></td>
</tr>
<tr>
<td>fcTraceRouteCompletionNotify</td>
<td></td>
</tr>
<tr>
<td>fcoInserted</td>
<td></td>
</tr>
<tr>
<td>fcoRemoved</td>
<td></td>
</tr>
<tr>
<td>fcsDiscoveryCompleteNotify</td>
<td></td>
</tr>
<tr>
<td>fcsMgmtAddrChangeNotify</td>
<td></td>
</tr>
<tr>
<td>dmFabricChangeNotify</td>
<td></td>
</tr>
<tr>
<td>dmNewPrincipalSwitchNotify</td>
<td></td>
</tr>
<tr>
<td>fcNameServerDatabaseFull</td>
<td></td>
</tr>
<tr>
<td>fcNameServerRejectRegNotify</td>
<td></td>
</tr>
<tr>
<td>fcPingCompletionNotify</td>
<td></td>
</tr>
<tr>
<td>fcTraceRouteCompletionNotify</td>
<td></td>
</tr>
<tr>
<td>fcoInserted</td>
<td></td>
</tr>
<tr>
<td>fcoRemoved</td>
<td></td>
</tr>
<tr>
<td>fcsDiscoveryCompleteNotify</td>
<td></td>
</tr>
<tr>
<td>fcsMgmtAddrChangeNotify</td>
<td></td>
</tr>
<tr>
<td>Event Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>fcsReqRejNotify</td>
<td></td>
</tr>
<tr>
<td>fspfNbrStateChangeNotify</td>
<td></td>
</tr>
<tr>
<td>ptopoConfigChange</td>
<td></td>
</tr>
<tr>
<td>qlSB2PortLinkDown</td>
<td></td>
</tr>
<tr>
<td>qlSB2PortLinkUp</td>
<td></td>
</tr>
<tr>
<td>rscnElsRejectReqNotify</td>
<td></td>
</tr>
<tr>
<td>rscnElsRxRejectReqNotify</td>
<td></td>
</tr>
<tr>
<td>rscnIlsRejectReqNotify</td>
<td></td>
</tr>
<tr>
<td>rscnIlsRxRejectReqNotify</td>
<td></td>
</tr>
<tr>
<td>virtualNwIfCreateEntryNotify</td>
<td></td>
</tr>
<tr>
<td>virtualNwIfDeleteEntryNotify</td>
<td></td>
</tr>
<tr>
<td>vlanTrunkPortDynamicStatusChange</td>
<td></td>
</tr>
<tr>
<td>vrrpTrapAuthFailure</td>
<td></td>
</tr>
<tr>
<td>vrrpTrapNewMaster</td>
<td></td>
</tr>
<tr>
<td>vtpConfigDigestError</td>
<td></td>
</tr>
<tr>
<td>vtpConfigRevNumberError</td>
<td></td>
</tr>
<tr>
<td>vtpLocalModeChanged</td>
<td></td>
</tr>
<tr>
<td>vtpMtuTooBig</td>
<td></td>
</tr>
<tr>
<td>vtpPruningStateOperChange</td>
<td></td>
</tr>
<tr>
<td>vtpServerDisabled</td>
<td></td>
</tr>
<tr>
<td>vtpVersionInUseChanged</td>
<td></td>
</tr>
<tr>
<td>vtpVersionOneDeviceDetected</td>
<td></td>
</tr>
<tr>
<td>vtpVlanCreated</td>
<td></td>
</tr>
<tr>
<td>vtpVlanDeleted</td>
<td></td>
</tr>
<tr>
<td>vtpVlanRingNumberConflict</td>
<td></td>
</tr>
<tr>
<td>wwnmType1WwnAvailableNotify</td>
<td></td>
</tr>
<tr>
<td>wwnmType1WwnShortageNotify</td>
<td></td>
</tr>
<tr>
<td>wwnmTypeOtherWwnAvailableNotify</td>
<td></td>
</tr>
<tr>
<td>wwnmTypeOtherWwnShortageNotify</td>
<td></td>
</tr>
</tbody>
</table>
Vcenter Plugin

VMware Vcenter plugin allows you to monitor the Cisco Unified Computing System™ (Cisco UCS®), Cisco Nexus, and Cisco MDS 9000 Family platforms through Cisco Prime DCNM.

The Cisco Prime DCNM plug-in for VMware Vcenter adds a multihop view and monitoring of Ethernet and Fibre Channel Cisco Nexus and Cisco MDS 9000 Family topologies. The increased visibility into virtualized infrastructure helps network administrators locate performance anomalies that may cause service degradation. It also aids to eliminate virtual computing and networking as a root cause of the problem.

This Appendix contains the following sections:

- Associating Vcenter with the Datasource, page D-1
- Registering Vcenter plugin, page D-1
- Triggering the plugin, page D-2
- Removing the plugin, page D-2

Associating Vcenter with the Datasource

To associate the Vcenter with the datasource, Cisco DCNM must discover the LAN and SAN devices. Navigate to Admin > Data Source > Fabric to check if the LAN/SAN devices are discovered on the Cisco DCNM Web Client. In the Admin > Data Sources > VMWare block, click + to add the Vcenter to the datasource.

Registering Vcenter plugin

To register the Vcenter plugin, run the RegisterPlugin script. Enter the Vcenter IP address, Vcenter username, Vcenter password, and complete URL of the DCNM server. The plugin configuration file is stored in the DCNM server.

Example:

RegisterPlugin.bat -add 172.22.29.87 admin nbv123 https://dcnm-san-001:443
Triggering the plugin

When user clicks on the menu, it will show the login page first, and then will launch an internal browser which will show the host dashboard.

Removing the plugin

To remove the Vcenter plugin, run the RegisterPlugin script. Enter the Vcenter IP address, Vcenter username, Vcenter password, and complete URL of the DCNM server. The plugin configuration file is located in the DCNM server.