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C H A P T E R 1
Overview

Cisco Data Center Network Manager (Cisco DCNM) automates the infrastructure of Cisco Nexus 5000, 6000,
7000, and 9000 Series Switches and Cisco MDS 9000 Series switches for data center management. Cisco
DCNM enables you to manage many devices while providing ready-to-use control, management, and automation
capabilities, along with VXLAN control and automation.

The home page contains a navigation pane to the left, and shortcuts to a few DCNM features in the middle
pane.

This guide provides comprehensive information about the UI functionalities for the Media Controller
deployment.

The top pane displays the following:

• Help (?): Launches the context-sensitive online help.

• User Role: Displays the role of the current logged-in user, for example, admin.

• Gear icon: Displays information about Cisco DCNM, enables you to change the DCNM UI password,
and allows you to log out from DCNM UI.

For more information about Cisco DCNM, see https://www.cisco.com/c/en/us/support/
cloud-systems-management/data-center-network-manager-11/model.html.

• Cisco Data Center Network Manager, on page 1

Cisco Data Center Network Manager
Cisco Data Center Network Manager automates the infrastructure of Cisco Nexus 5000, 6000, 7000, and 9000
Series Switches and Cisco MDS 9000 Series switches. Cisco DCNM enables you to manage multiple devices,
while providing ready-to-use control, automation, monitoring, visualization, and troubleshooting capabilities.

The Cisco DCNM home page contains a navigation pane to the left, and shortcuts to a few Cisco DCNM
features in the middle pane.

This guide provides comprehensive information about the Media Controller deployment functionalities.

The top pane displays the following UI elements:

• Help (?): Launches the context-sensitive online help.

• User Role: Displays the role of the user who is currently logged in, for example, admin.
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• Gear icon: Displays information about DCNM, enables you to change Cisco DCNM UI password, and
allows you to log out from the Cisco DCNM UI.

For more information about Cisco DCNM, see:

https://www.cisco.com/c/en/us/support/cloud-systems-management/data-center-network-manager-11/
model.html.
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C H A P T E R 2
Dashboard

This chapter contains the following topics:

• Dashboard, on page 3

Dashboard
The intent of Dashboard is to enable network and storage administrators to focus on particular areas of
concern around the health and performance of data center switching. This information is provided as 24-hour
snapshots. The functional view of LAN switching consists of six dynamic dashlets that display information
in the context of the selected scope by default. The scope can be adjusted in the upper right corner of the
window to display focused information that is particular to the managed domain. It offers details of a specific
topology or set of topologies that is a part of the data center scope.

The various scopes that are available on the Cisco Data Center Network Manager (DCNM) web interface are:

• Data Center

• Default_LAN

• Custom scopes that you create

From the left menu bar, choose Dashboard. The Dashboard window displays the default dashlets.

The following are the default dashlets that appear in the Dashboard window:

• Events

• Data Center

• Network Map

• Link Traffic

• Audit Log

• Server Status

From the Dashlets drop-down list, you can choose more dashlets so that they are added to the dashboard.

The panels can be added, removed, and dragged around to reorder.
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Dashlets
By default, a subset of the available dashlets is automatically displayed in the dashboard. To add a dashlet
that is not automatically displayed in a dashboard, from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Dashboard.
Step 2 From the Dashlets drop-down list, choose the dashlet that you want to add in the dashboard.

In the Dashlets drop-down list, an icon appears before the selected dashlet.

The following table lists the dashlets that you can add on the Dashboard window.

DescriptionDashlet

Displays events with Critical, Error, and Warning
severity. In this dashlet, click the Show

Events

Acknowledged Events link to go to the Monitor >
Switch > Events.

Displays a diagram of Inter-Switch Link (ISL) and
saturation link for transmitting and receiving in the
data center.

Link Traffic

Displays the number of access, spine and leaf devices,
and a generic health score for each switch group in

Data Center

the current scope. Devices are aggregated by type
within a switch group.

Displays the accounting log table of Cisco DCNM.Audit Log

Displays the populated switch groups that are visible
in your Role Based Access Control (RBAC) scope on

Network Map

a world map. If you use the scope selector, it limits
the set of switch groups displayed. If you use the
pop-up option, the map opens in a new tab and can
be configured.

• The network map dialog box has properties that
are different from the Summary dashboard view:

• You can click and drag nodes to move them
around the map. The map saves their new
positions.

• You can double click a node to trigger a slider
that contains the summary inventory information
pertaining to a specific switch group.

• You can upload an image of your choice as the
background to the network map.
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DescriptionDashlet

You will be prompted to upload an image
file with recommended dimension, which
is the current window size. Reset returns
the network map to its default state,
resetting the position of the nodes and
clearing the custom image.

Note

Displays the status of DCNM and federation servers,
and the health check status for the components.

Server Status

Displays the performance data for the top ten
performing ISLs, trunk ports or both. Each entry

Top ISLs/Trunks

shows the current average receive and transmit
percentage, with a graph depicting the percentage of
time each trunk spent exceeding the currently
configured thresholds.

Displays the performance data for the top ten
performing SAN host and storage ports. Each entry

Top SAN End Ports (SAN only)

shows the current receive and transmit percentage,
with a graph depicting the percentage of time each
trunk spent exceeding the currently configured
thresholds.

This dashlet is only for SAN.Note

Displays CPU utilization for the discovered switches
over the last 24 hours, with a red bar displaying the
high watermark for that 24-hour period.

Top CPU

Displays the module temperature sensor details of
switches.

Top Temperature

This dashlet is only for LAN.Note

Displays the health summary that contains two
columns displaying the summary of problems and
summary of events for the past 24 hours.

Health

Click the count adjacent to the warnings pertaining
to switches, ISLs, hosts, or storage (other than 0) to
view the corresponding inventory for that fabric.

Click the count adjacent to the event severity levels
(Emergency, Alert, Critical, Error, Warning, Notice,
Info, or Debug) to view a summary of the
corresponding events and descriptions.

Displays the error packets for the selected interface.
This information is retrieved from the Errors > In-Peak

Errors

and Errors > Out-Peak columns of the Monitor > LAN
/ Ethernet page.
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DescriptionDashlet

Displays the error packets that are discarded for the
selected interface.

Discards

The Discards dashlet is only for LAN.Note

Displays the ports inventory summary information.Inventory (Ports)

Displays the switches on which the modules are
discovered, the models name and the count.

Inventory (Modules)

Displays the ISLs inventory summary information,
such as the category and count of ISLs.

Inventory (ISLs)

Displays the logical inventory summary information,
such as the category and count of logical links.

Inventory (Logical)

Displays the switches inventory summary information
such as the switch models and the corresponding
count.

Inventory (Switches)

Displays the port capacity inventory summary
information such as the tiers, the number and

Inventory (Port Capacity)

percentage of the available ports, and the remaining
days.

To restore the default dashlets in the dashboard page, click the Default Set link in the Dashlet
drop-down list.

Note

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
6

Dashboard
Dashlets



C H A P T E R 3
Inventory

This chapter contains the following topics:

• Viewing Inventory Information, on page 7
• Discovery, on page 31

Viewing Inventory Information
Beginning with Cisco Prime DCNM release 6.x, you can view the inventory and the performance for both
SAN and LAN switches by using the global Scope pane. You can select LAN, SAN, or both to view the
inventory information. You can also export and print the inventory information.

You can either Print this information or export to Microsoft Excel.

You can use the Print icon to print the information that is displayed or you can also use the Export icon to
export the information that is displayed to a Microsoft Excel spreadsheet. You can also choose the column
that you want to display.

Note

The Inventory menu includes the following submenus:

Viewing Inventory Information for Switches
To view the inventory information for switches from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

The Switches window with a list of all the switches for a selected Scope is displayed.

Step 2 You can also view the following information.

• Group column displays the switch group to which the switch belongs.

• In the Device Name column, select a switch to display the Switch Dashboard.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
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• IP Address column displays the IP address of the switch.

• WWN/Chassis ID displays the Worldwide Name (WWN) if available or chassis ID.

• Health displays the health situation of the switch.

To refresh and recalculate the latest health data for all the switches on Cisco DCNM, click the
Recalculate Health button above the switches table.

Note

• Status column displays the status of the switch.

• # Ports column displays the number of ports.

• Model column displays the model name of the switch.

• Serial No. column displays the serial number of the switch.

• Release column displays the switch version.

• License column displays the DCNM license that is installed on the switch.

• Up Time column displays the time period for which the switch is active.

Step 3 In theHealth column, the switch health is calculated by the capacity manager based on the following formula
in the server.properties file.

The function to implement is:

# calculate(x, x1, y, y1, z).

# @param x: Total number of modules.

# @param x1: Total number of modules in warning.

# @param y: Total number of switch ports.

# @param y1: Total number of switch ports in warning.

# @param z: Total number of events with severity of warning or above.

Step 4 The value in the Health column is calculated based on the following default equation.

((x-x1)*1.0/x) *0.4 + ((y-y1)*1.0/y)*0.3 + ((z*1.0/1000>=1) ? 0: ((1000-z)*1.0/1000)*0.3).

In the above formula, the switch health value is calculated based on the following:

• Percentage of Warning Modules (Contributes 40% of the total health).

• Percentage of Warning Ports (Contributes 30% of the total health).

• Percentage of events with severity of Warning or above (Contributes 30% of the total health. If there are
more than 1000 warning events, the event health value is 0).

You may also have your own health calculation formula by implementing the common interface class:
com.cisco.dcbu.sm.common.rif.HealthCalculatorRif. Add the .jar file to the DCNM server and modify the
health.calculator property to point to the class name you have created.

The default Java class is defined as: health.calculator=com.cisco.dcbu.sm.common.util.HealthCalculator.

• Capacity Manager calculates health only for the license switches. If the health column does not display
a value, the switch either does not have a license or it has missed the capacity manager daily cycle.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
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• If the switch is unlicensed, click Unlicensed in the DCNM License column. The Administration >
License window appears which allows you to assign a license to the user.

• The capacity manager runs two hours after the DCNM server starts. So, if you discover a device after
two hours of the DCNM start time, the health will be calculated 24 hours after this DCNM start time

Viewing System Information
The switch dashboard displays the details of the selected switch.

Procedure

Step 1 From the Cisco DCNM home page, choose Inventory > View > Switches.

An inventory of all the switches that are discovered by Cisco Prime DCNM Web Client is displayed.

Step 2 Click a switch in the Device Name column.

The Switch dashboard that corresponds to that switch is displayed along with the following information:

Step 3 Click the System Information tab. This tab displays detailed system information such as group name, health,
module, time when system is up, serial number, the version number, contact, location, DCNM license, status,
system log sending status, CPU and memory utilization, and VTEP IP address are displayed. Click Health
to access the Health score screen, which includes health score calculation and health trend. The popup contains
Overview, Modules, Switch Ports, and Events tabs.

• (Optional) Click SSH to access the switch through Secure Shell (SSH).

• (Optional) ClickDeviceManager to view a graphical representation of a Cisco MDS 9000 Family switch
chassis, a Cisco Nexus 5000 Series switch chassis, a Cisco Nexus 7000 Series switch chassis, or a Cisco
Nexus 9000 Series switch chassis including the installed switching modules, the supervisor modules, the
status of each port within each module, the power supplies, and the fan assemblies.

• (Optional) ClickHTTP to access the switch through Hypertext Transfer Protocol (HTTP) for that switch.

• (Optional) ClickAccounting to go to the Viewing Accounting Information , on page 37 window pertaining
to this switch.

• (Optional) Click Backup to go to the Viewing a Configuration window.

• (Optional) Click Events to go to the #unique_12 window.

• (Optional) Click ShowCommands to display the device show commands. The Device Show Commands
page helps you to view commands and execute them.

• (Optional) Click Copy Running Config to Startup Config to copy the running configuration to the
startup configuration.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
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Interfaces
The Interfaces option displays all the interfaces that are discovered for the switch, Virtual Port Channels and
intended interfaces missing on the device.

Click Port Group to create a new port group or add the interfaces into an existing group.

You can filter and view information for any of the given fields (such as Device Name). The following table
describes the buttons that appear on this page. The following table describes the buttons that appear on this
page.

DescriptionField

Allows you to add a logical interface.Add

Allows you to edit and change policies that are
associated with an interface.

Edit

Allows you to delete a logical interface that is created
from the Interfaces screen.

Delete

Allows you to enable an interface (no shutdown or
admin up).

No Shutdown

Allows you to shut down the interface.Shutdown

Allows you to display the interface show commands.
A show command requires show templates in the
template library.

Show

Allows you to rediscover or recalculate the
compliance status on the selected interfaces.

Rediscover

Allows you to display the interface deployment history
details.

Interface History

This section contains the following:

Adding Interfaces

To add the interfaces from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Add to add a logical interface. The Add Interface window appears.

If you want to add a sub-interface, you select an interface and click Add.
Step 5 In the Type field, choose the type of the interface. For example, VLAN, loopback, NVE.
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Step 6 In the Number field, specify the interface number.
Step 7 Select the Admin State ON check box to specify whether the interface is shut down or not.

Editing Interfaces

To edit the interfaces from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.
You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Edit to edit an interface. The variables that are shown in the Edit Configuration window are based on

the template and its policy.

• The Admin State ON check box in the Edit Configuration window indicates whether the interface is
shut down or not.

• The Clear Config before the deployment check box helps you to set a port to its default configuration.
When there is a set of configurations already available on the port and these configurations conflict with
the configurations that want to place on the port, you may need to clear the configurations before the
deployment.

• In the Previewwindow, the left pane shows the configurations that the template generated based on your
input, whereas the right pane shows the configurations that are currently available on the switch.

Deleting Interfaces

To delete the interfaces from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Delete to add a logical interface.

Shutting Down and Bring Up Interfaces

To shut down and bring up the interfaces from the Cisco DCNM Web UI, perform the following steps:

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
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Procedure

Step 1 Choose Inventory > View > Switches.
The Switches window is displayed with a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Shutdown to disable an interface. For example, you may want to isolate a host from the network or a

host that is not active in the network.

To enable an interface, Click No Shutdown button.

Displaying Interface Show Commands

To display interface show commands from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.
You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Show to display the interface show commands.

The Interface Show Commands window helps you to view commands and execute them.

Rediscovering Interfaces

To rediscover interfaces from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

The Switches window is displayed showing a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Rediscover to rediscover the selected interfaces. For example, after you edit or enable an interface, you

can rediscover the interface.

Viewing Interface History

To view the interface history from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the Interfaces tab.
Step 4 Click Interface History to display the interface history details such as Policy Name, Time of Execution,

and so on.

VLAN
You create a VLAN by assigning a number to it; you can delete VLANs and move them from the active
operational state to the suspended operational state.

To configure VLANs, choose Inventory > View > Switches, and then click a switch in the Device Name
column.

The following table describes the buttons that appear on this page.

Table 1: VLAN Tab

DescriptionField

Allows you to unselect all the VLANs that you
selected.

Clear Selections

Allows you to create Classical Ethernet or Fabric Path
VLANs.

Add

Allows you to edit a VLAN.Edit

Allows you to delete a VLAN.Delete

Allows you to enable a VLAN.No Shutdown

Allows you to disable a VLAN.Shutdown

Allows you to display the VLAN show commands.Show

This section contains the following:

Adding a VLAN

To add a VLAN from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.
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Step 2 In the Device Name column, select a switch to display the Switch Dashboard.
Step 3 Click the VLAN tab.
Step 4 Click Add to create Classical Ethernet or Fabric Path VLANs. In the Add VLAN window, specify the

following fields:
a) In the Vlan Id field, enter the VLAN ID.
b) In the Mode field, specify whether you are adding Classical Ethernet or Fabric Path VLAN.
c) Select the Admin State ON check box to specify whether the VLAN is shut down or not.

Editing a VLAN

To edit a VLAN from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

The Switches window is displayed with a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display the Switch Dashboard.
Step 3 Select one or more VLANs, and then click the Edit.

Deleting a VLAN

To delete a VLAN from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display the Switch Dashboard.
Step 3 Click VLAN tab.
Step 4 Select the VLAN that you want to delete, and then click Delete.

Shutting Down a VLAN

To shut down a VLAN from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

You see the Switches window displaying a list of all the switches for a selected Scope.
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Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the VLAN tab.
Step 4 Click Shutdown to disable a VLAN.

To enable a VLAN, click No Shutdown button. For example, if you want to start traffic flow on a VLAN
you can enable it.

Displaying VLAN Show Commands

To display VLAN show commands from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Switches.

The Switches window is displayed, showing a list of all the switches for a selected Scope.

Step 2 In the Device Name column, select a switch to display Switch Dashboard.
Step 3 Click the VLAN tab.
Step 4 Click Show to display the VLAN show commands. Based on the VLAN selection, you can show the VLAN

commands. Interface Show Commands window displays the commands and allows you to execute them.

FEX
The Fabric Extender feature allows you to manage a Cisco Nexus 2000 Series Fabric Extender and its
association with the Cisco NX-OS switch that it is attached to. A Fabric Extender is connected to the switch
through physical Ethernet interfaces or a Port Channel. By default, the switch does not allow the attached
Fabric Extender to connect until it has been assigned a chassis ID and is associated with the connected interface.
You can configure a Fabric Extender host interface port as a routed or Layer 3 port. However, no routing
protocols can be tied to this routed interface.

FEX feature is available on LAN devices only. Therefore, you will see FEX on Cisco DCNM Inventory
Switches. FEX is also not supported on Cisco Nexus 1000V devices.

Note

4x10G breakout for FEX connectivity is not supported on Cisco Nexus 9500 Switches.Note

The Fabric Extender may connect to the switch through several separate physical Ethernet interfaces or at
most one port channel interface.

Note

This section describes how to manage Fabric Extender (FEX) on Cisco Nexus Switches through Cisco DCNM.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
15

Inventory
Displaying VLAN Show Commands



You can create and manage FEX from Cisco DCNM Inventory > Switches.

FEX tab is visible only if you choose a LAN device.Note

The following table describes the fields that appear on this page.

Table 2: FEX Operations

DescriptionField

Click to add a new FEX to a Cisco Nexus Switch.Add

Select any active FEX radio button and click Edit to edit the FEX
configuration.

You can create an edit template and use it for editing FEX. Select template
type as POLICY and sub type as FEX.

Edit

Select the FEX radio button, and click Delete icon to delete the FEX
associated with the switch.

Delete

Allows you to view various configuration details for the selected FEX
ID. You can select the following from the drop-down list.

• show_diagnostic

• show_fex

• show_fex_detail

• show_fex_fabric

• show_fex_inventory

• show_fex_module

The variables for respective show commands are displayed in the
Variables area. Review the Variables and click Execute. The output
appears in the Output area.

You can create a show template for FEX. Select template type as SHOW
and sub type as FEX.

Show

Allows you to view the history of the FEX configuration tasks for a
particular FEX. You can review the Event Type, Policy Name, Status,
Time of Execution, User Name for the selected FEX.

FEX History

Table 3: FEX Field and Description

DescriptionField

Uniquely identifies a Fabric Extender that is connected to a Cisco NX-OS
device.

Fex Id
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DescriptionField

Description that is configured for the Fabric Extender.Fex Description

Specifies the version of the FEX that is associated with the switch.Fex Version

An integer value that denotes the maximum pinning uplinks of the Fabric
Extender that is active at a time.

Pinning

Specifies the status of the FEX as associated with the Cisco Nexus Switch.State

Specifies the model of the FEX.Model

Specifies the configured serial number.

If this configured serial number and the serial number of the
Fabric Extender are not the same, the Fabric Extender will not
be active.

Note

Serial No.

Specifies the port channel number to which the FEX is physically
connected to the Switch.

Port Channel

Refers to the physical interfaces to which the FEX is connected.Ethernet

Specifies the vPC ID configured for FEX.vPC ID

This chapter includes the following sections:

Add FEX

To add single-home FEX from the Cisco DCNM Web UI, perform the following steps:

Before you begin

You can add a Fabric Extender (FEX) to the Cisco Nexus Switches through the Cisco DCNM Web Client. If
the FEX is physically connected to the switch, FEX will become online after it is added. If the FEX is not
physically connected to the switch, the configuration is deployed to the switch, which in turn enables FEX
when connected.

You can create only single homed FEX through Inventory > Switches > FEX > Add FEX. To create a
dual-homed FEX, use the vPC wizard through Configure > Deploy > vPC.

Note

Ensure that you have successfully discovered LAN devices and configured LAN credentials before you
configure FEX.

Procedure

Step 1 Choose Inventory > Switches > FEX.

The FEX window is displayed.
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Step 2 Click the Add FEX icon.
Step 3 In the General tab, in the PORTCHANNEL field, enter the interface port channel number which is connected

to the FEX.
Step 4 In the INT_RANGE field, enter the interface range within which the FEX is connected to the switch.

Do not enter the interface range, if the interfaces are already a part of port channel.Note

Step 5 In the FEX_ID field, enter the ID for FEX that is connected to a Cisco NX-OS device.

The identifier must be an integer value between 100 to 199.

Step 6 Click Add.

The configured Single-home FEX appears in the list of FEXs associated to the device.

Edit FEX

To edit and deploy FEX from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > Switches > FEX.

The FEX window is displayed.

Step 2 Select the FEX radio button that you must edit. Click Edit FEX icon.
Step 3 In the Edit Configuration window, from the Policy drop-down list, select Edit_FEX to edit the FEX

configuration.
Step 4 Edit the pinning and FEX_DESC fields, as required.

If you initially configured port 33 on the parent switch as your only fabric interface, all 48 host
interfaces are pinned to this port. If you provision another port, for example 35, then you must
perform this procedure to redistribute the host interfaces. All host interfaces are brought down and
host interfaces 1 to 24 are pinned to fabric interface 33 and host interfaces 25 to 48 are pinned to
fabric interface 35.

Note

Step 5 Click Preview.

You can view the generated configuration for the selected FEX ID. The following is a configuration example
for FEX ID 101.
fex 101
pinning max-links 1
description test

Step 6 After you review the configuration summary on the Preview window, on the Edit Configuration screen, click
Deploy to deploy the FEX for the switch.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
18

Inventory
Edit FEX



VDCs
This section describes how to manage Virtual Device Contexts (VDCs) on Cisco Nexus 7000 Switches through
Cisco DCNM.

Users with the network administrator (network-admin) role can create Virtual Device Contexts (VDCs). VDC
resource templates limit the amount of physical device resources available to the VDC. The Cisco NX-OS
software provides a default resource template, or you can create resource templates.

You can create and manage VDCs from Cisco DCNM Inventory > Switches > VDCs. As Cisco DCNM
supports DCNM on Cisco Nexus 7000 Series only, click an active Cisco Nexus 7000 Switch. After you create
a VDC, you can change the interface allocation, VDC resource limits, and the high availability (HA) policies.

The following table describes the fields that appear on this page.

Table 4: Vdc Operations

DescriptionField

Click to add a new VDC.Add

Select any active VDC radio button and click Edit to
edit the VDC configuration.

Edit

Allows you to edit the VDC configuration. Select any
active VDC radio button and click Edit to edit the
VDC configuration.

Delete

Allows you to delete the VDC. Select any active VDC
radio button and click Delete to remove the VDC
associated with the device.

Resume

Allows you to suspend an active non-default VDC.

Save the VDC running configuration to the startup
configuration before suspending the VDC. Otherwise,
you will lose the changes to the running configuration.

You cannot suspend the default VDC.Note

Suspending a VDC disrupts all traffic on
the VDC.

Caution

Suspend

Allows you to resume a non-default VDC from the
suspended state. The VDC resumes with the
configuration that is saved in the startup configuration.

Rediscover

Allows you to view the Interfaces and Resources that
are allocated to the selected VDC.

In the Interface tab, you can view the mode,
admin-status, and operational status for each interface
associated with the VDC.

In the Resource tab, you can view the allocation of
resources and current usage of these resources.

Show
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Table 5: Vdc Table Field and Description

DescriptionField

Displays the unique name for the VDCName

Species the type of VDC. The two types of VDCs are:

• Ethernet

• Storage

Type

Specifies the status of the VDC.Status

Displays the allocated resource limit and module type.Resource Limit-Module Type

Specifies the action that the Cisco NX-OS software
takes when an unrecoverable VDC fault occurs.

You can specify the HA policies for single supervisor
module and dual supervisor module configurations
when you create the VDC. The HA policy options are
as follows:

Single supervisor module configuration:

• Bringdown—Puts the VDC in the failed state.
To recover from the failed state, you must reload
the physical device.

• Reload—Reloads the supervisor module.

• Restart—Takes down the VDC processes and
interfaces and restarts it using the startup
configuration.

Dual supervisor module configuration:

• Bringdown—Puts the VDC in the failed state.
To recover from the failed state, you must reload
the physical device.

• Restart—Takes down the VDC processes and
interfaces and restarts it using the startup
configuration.

• Switchover—Initiates a supervisor module
switchover.

The default HA policies for a non-default VDC that
you create is restart for a single supervisor module
configuration and switchover for a dual supervisor
module configuration. The default HA policy for the
default VDC is reload for a single supervisor module
configuration and switchover for a dual supervisor
module configuration.

HA-Policy

• Single Supervisor

• Dual Supervisor
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DescriptionField

Specifies the default VDC management MAC address.Mac Address

Species the IP Address of the VDC Management
interface. The status shows if the interface if up or
down.

Management Interface

• IP Address Prefix

• Status

Specifies the SSH statusSSH

This chapter includes the following sections:

Add VDCs

To add VDC from the Cisco DCNM Web UI, perform the following steps:

Before you begin

Ensure that you have discovered the physical device using a username that has the network-admin role.

Obtain an IPv4 or IPv6 address for the management interface (mgmt 0) if you want to use out-of-band
management for the VDC.

Create a storage VDC to run FCoE. The storage VDC cannot be the default VDC and you can have one storage
VDC on the device.

Procedure

Step 1 Choose Inventory > Switches > VDC.

The VDC window is displayed.

Step 2 Click the Add VDC icon.
Step 3 From the drop-down list, select the VDC type.

You can configure the VDC in two modes.

• Ethernet VDC

• Storage VDC

The default VDC type is Ethernet.

Step 4 Click OK.

Configuring Ethernet VDCs

To configure VDC in Ethernet mode from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 In the General Parameter tab, specify the VDC Name, Single supervisor HA-policy, Dual supervisor
HA-policy, and Resource Limit - Module Type.

Step 2 In the Allocate Interface tab, select the network interfaces (dedicated interfaces membership) to be allocated
to the VDC.

Click Next.

Step 3 In the Allocate Resource tab, specify the resource limits for the VDC.

Select the radio button and choose Select a Template from existing Templates or Create a New Resource
Template. VDC resource templates describe the minimum and maximum resources that the VDC can use. If
you do not specify a VDC resource template when you create a VDC, the Cisco NX-OS software uses the
default template, vdc-default.

• If you choose Select a Template from existing Templates, from the Template Name drop-down list, you
can select None, global-default, or vdc-default.

The template resource limits are detailed in the following below:

Table 6: Template Resource Limits

MaximumMinimumResource

Global Default VDC Template Resource Limits

Anycast Bundled

8

Route memory is in megabytes.

8IPv6 multicast route memory

4848IPv4 multicast route memory

3232IPv6 unicast route memory

IPv4 unicast route memory

VDC Default Template Resource Limits

Monitor session extended

Monitor session mx exception

Monitor SRC INBAND

Port Channels

Monitor DST ERSPAN

SPAN Sessions

VLAN

Anycast Bundled
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MaximumMinimumResource

IPv6 multicast route memory

IPv4 multicast route memory

IPv6 unicast route memory

IPv4 unicast route memory

VRF

• If you choose Create New Resource Template, enter a unique Template Name. In the Resource Limits
area, enter the minimum and maximum limits, as required for the resources.

You can edit individual resource limits for a single VDC through the Cisco DCNM Web Client > Inventory
> Switches > VDC.

Click Next.

Step 4 In the Authenticate tab, you can allow the Admin to configure the password and also authenticate users using
AAA Server Groups.

In the Admin User Area:

• Check the Enable Password Strength Check checkbox, if necessary.

• In the Password field, enter the admin user password.

• In the Confirm Password field, reenter the admin user password.

• In the Expiry Date field, click the down arrow and choose an expiry date for the admin user from the
Expiry Date dialog box. You can also select Never radio button not to expire the password.

In the AAA Server Groups area:

• In the Group Name field, enter an AAA server group name.

• In the Servers field, enter one or more host server IPv4 or IPv6 addresses or names, which are separated
by commas.

• In the Type field, choose the type of server group from the drop-down list.

Click Next.

Step 5 In the Management Ip tab, enter IPv4 or IPv6 Address information.

Click Next.

Step 6 In the Summary tab, review the VDC configuration.

Click Previous to edit any parameters.

Click Deploy to configure VDC on the device.

Step 7 In the Deploy tab, the status of the VDC deployment is displayed.

A confirmation message appears. Click Know More to view the commands that are executed to deploy the
VDC.
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Click Finish to close the VDC configuration wizard and revert to view the list of VDCs configured on the
device.

Configuring Storage VDCs

To configure VDCs in storage mode from the Cisco DCNM Web UI, perform the following steps:

Before you begin

Create a separate storage VDC when you run FCoE on the device. Only one of the VDCs can be a storage
VDC, and the default VDC cannot be configured as a storage VDC.

You can configure shared interfaces that carry both Ethernet and Fibre Channel traffic. In this specific case,
the same interface belongs to more than one VDC. The shared interface is allocated to both an Ethernet and
a storage VDC.

Procedure

Step 1 In the General Parameter tab, specify the VDC Name, Single supervisor HA-policy, Dual supervisor
HA-policy, and Resource Limit - Module Type.

Step 2 In the Allocate FCoE Vlan tab, select the available Ethernet Vdc from the drop-down list.

The existing Ethernet VLANs range is displayed. Select None not to choose any available Ethernet VDCs.

You can allocate specified FCoE VLANs to the storage VDC and specified interfaces.

Click Next.

Step 3 In the Allocate Interface tab, add the dedicated and shared interfaces to the FCoE VDC.

The dedicated interface carries only FCoE traffic and the shared interface carries both the Ethernet
and the FCoE traffic.

Note

You can configure shared interfaces that carry both Ethernet and Fibre Channel traffic. In this specific case,
the same interface belongs to more than one VDC. FCoE VLAN and shared interface can be allocated from
same Ethernet VDC.

Click Next.

Step 4 In the Authenticate tab, you can allow the Admin to configure the password and also authenticate users using
AAA Server Groups.

In the Admin User Area:

• Check the Enable Password Strength Check checkbox, if necessary.

• In the Password field, enter the admin user password.

• In the Confirm Password field, reenter the admin user password.

• In the Expiry Date field, click the down arrow and choose an expiry date for the admin user from the
Expiry Date dialog box. You can also select Never radio button not to expire the password.

In the AAA Server Groups area:
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• In the Group Name field, enter an AAA server group name.

• In the Servers field, enter one or more host server IPv4 or IPv6 addresses or names, which are separated
by commas.

• In the Type field, choose the type of server group from the drop-down list.

Click Next.

Step 5 In the Management Ip tab, enter IPv4 or IPv6 Address information.

Click Next.

Step 6 In the Summary tab, review the VDC configuration.

Click Previous to edit any parameters.

Click Deploy to configure VDC on the device.

Step 7 In the Deploy tab, the status of the VDC deployment is displayed.

A confirmation message appears. Click Know More to view the commands that are executed to deploy the
VDC.

Click Finish to close the VDC configuration wizard and revert to view the list of VDCs configured on the
device.

Edit VDC

To edit VDC from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > Switches > VDC.

The VDC window is displayed.

Step 2 Select the VDC radio button that you must edit. Click the Edit VDC icon.
Step 3 Modify the parameters as required.
Step 4 After you review the configuration summary on the Summary tab, click Deploy the VDC with the new

configuration.

Switch On-Board Analytics
The Switch On-Board Analytics dashboard displays the following charts:

• Top 10 Slowest Ports

• Top 10 Slowest Target Ports

• Top 10 Slowest Flows

• Top 10 Slowest ITLs
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• Top 10 Port Traffic

• Top 10 Target Ports Traffic

• Top 10 Flow Traffic

• Top 10 ITL Traffic

The following metrics are supported by the Switch On-Board Analytics charts:

• Read and Write Completion Time—Time that is taken for an IO to complete successfully, that is, the
time gap between IO status from a Target and IO command from an Initiator. The following metrics are
supported:

• Read Completion Time Min

• Read Completion Time Max

• Write Completion Time Min

• Write Completion Time Max

The IO engine tracks the maximum and minimum IO completion time for read and write commands in
the context of a switch’s port, target port, flows, initiators, and LUNs.

• Read and Write Initiation Time—Time that is taken for an IO to initiate, that is, the time gap between
the first response packet from a Target and IO Command from Initiator. The following metrics are
supported:

• Read Initiation Time Min

• Read Initiation Time Max

• Write Initiation Time Min

• Write Initiation Time Max

The IO engine tracks the maximum and minimum IO initiation time for read and write commands in the
context of a switch’s port, target port, flows, initiators, and LUNs.

• Read and Write IO Bandwidth—Read and write command bandwidth observed in the context of a switch's
port traffic, target port traffic, flow traffic, initiators, and LUNs. The IO bandwidth is computed at every
four second time interval based on the number of bytes read or written.

• Read and Write IO Rate—Read and write command IO rate observed in the context of a switch's port
traffic, target port traffic, flow traffic, initiators, and LUNs. The IO rate is computed at every four second
time interval that is based on the number of IO performed.

• Read and Write IO Size—Read and write command IO size observed in the context of a switch's port
traffic, target port traffic, flow traffic, initiators, and LUNs. The following metrics are supported:

• Read IO Size Min

• Read IO Size Max

• Write IO Size Min

• Write IO Size Max
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The IO engine tracks the maximum and minimum IO size for read and write commands.

Viewing Switch On-Board Analytics

You can view the switch on-board analytics information from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Inventory > View > Switches.

The discovered switches are displayed.

Step 2 Click a switch name in the Device Name column.

The Switch dashboard that corresponds to that switch is displayed.

Step 3 Click the Switch On-Board Analytics tab.

This tab displays the Switch On-Board Analytics charts.

Configuring Settings for the Switch On-Board Analytics Charts

Perform the following actions to configure the settings for the switch on-board analytics charts:

• From the Show Time drop-down list, choose time to be shown in the charts. You can choose one of the
following options:

• Microseconds

• Milliseconds

• Seconds

By default, Microseconds is chosen.

The Show Time drop-down list is applicable only for the top ten slowest ports,
target ports, flows, and ITLs.

Note

• From the Show Flow From drop-down list, choose whether to show flows from a Target or from an
Initiator. By default, flows from a Target are chosen.

The Show Flow From drop-down list is applicable only for the charts displaying
flows and ITLs.

Note

• From the bandwidth and size drop-down list, choose the traffic information to be shown in the charts.
You can choose one of the following options:

• Bytes
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• KB

• MB

By default, Bytes is chosen.

• Check the Single Column check box to display the charts in a single column instead of double columns.

• Click the Refresh icon in the upper-right corner to refresh the charts.

Viewing Switch On-Board Analytics Charts

Perform the following actions to view the charts under the Switch On-Board Analytics tab:

• View the charts for the top ten slowest ports, target ports, flows, and ITLs by choosing one of the following
variables from the drop-down list:

• ReadCompletion Time—The read command completion time observed in the context of a switch’s
port.

• Write Completion Time—The write command completion time observed in the context of a
switch’s port.

• Read Initiation Time—The read command initiation time observed in the context of a switch’s
port.

• Write Initiation Time—The write command initiation time observed in the context of a switch’s
port.

• By default, Read Completion Time is selected and all the units for time
are in Microseconds.

• Each chart contains a legend that provides information about the variable
displayed. Each variable has a check box. Unselecting the check box removes
the variable data from the chart or table.

Note

• View the charts for the top ten port traffic, target port traffic, flow traffic, and ITL traffic by choosing
one of the following variables from the drop-down list:

• Read IO Rate—The read command data observed in the context of a switch’s port.

• Write IO Rate—The write command observed in the context of a switch’s port.

• Read IO Size—The read command size observed in the context of a switch’s port.

• Write IO Size—The write command size observed in the context of a switch’s port.

• Read IO Bandwidth—The read command bandwidth observed in the context of a switch’s port.

• Write IO Bandwidth—The write command bandwidth observed in the context of a switch’s port.
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• By default, Read IO Rate is selected. The Read IO Rate is IO per second.
Both Rate and Bandwidth units are per second over an 8-second range.
The Size value is for the life of the switch or since the last clear command
was run from the CLI.

• The Read IO Size and Read IO Bandwidth units are in bytes per second.
You can change this unit by using the ShowBandwidth and Size drop-down
list. You can choose from the three options: Bytes, KB, and MB.

• Each chart contains a legend that provides information about the variable
displayed. Each variable has a check box. Unselecting the check box removes
the variable data from the chart or table.

Note

• Choose the format to display information from the Show drop-down list. You can choose one of the
following formats:

• Chart

• Table

• Chart and Table

• To display information in theChart and Table format, enlarge your browser
window or check the Single Column check box on the upper right corner.

• The default for Top ten Slowest Ports and Top 10 Port Traffic is Chart and
Table.

Note

• Use the Chart Type drop-down list to display information in the Bar Chart or Stacked Bar Chart.

• Use theActions drop-down list to export information in a CSV or PDF, or print the required information.

• To view a chart or a table in a new window, click the Detach icon on the upper-right corner of a chart
or a table. After detaching a chart or table, you can view the top 25 slowest ports, target ports, flows,
ITLs, or their traffic.

Viewing Inventory Information for Modules
To view the inventory information for modules from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Modules.

The Modules window is displayed with a list of all the switches and its details for a selected Scope.

Step 2 You can view the following information.
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• Group column displays the group name of the module.

• Switch column displays the switch name on which the module is discovered.

• Name displays the module name.

• ModelName displays the model name.

• SerialNum column displays the serial number.

• 2nd SerialNum column displays the second serial number.

• Type column displays the type of the module.

• Slot column displays the slot number.

• Hardware Revision column displays the hardware version of the module.

• Software Revision column displays the software version of the module.

• Asset ID column displays the asset id of the module.

• OperStatus column displays the operation status of the module.

Viewing Inventory Information for Licenses
To view the inventory information for licenses from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Licenses.

The Licenses window is displayed based on the selected Scope.

Step 2 You can view the following information.

• Group column displays the group name of switches.

• Switch column displays the switch name on which the feature is enabled.

• Feature displays the installed feature.

• Status displays the usage status of the license.

• Type column displays the type of the license.

• Warnings column displays the warning message.
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Discovery
Starting from Cisco DCNM release 10.x, Cisco DCNM Web Client allows the admin to associate user to
one or more device scope or group. That means you can only access and configure the associated group or
scope devices based on Role Based Access Control (RBAC). Though you might not have the access to other
users' associated devices, you can still see all the discovered devices under the Inventory > Discovery tab.

From the left menu bar, go to Administration > Management Users. You can create users and associate
groups, manage remote authentication, and see all the connected clients. For more information about RBAC,
navigate to Managing Local Users.

Adding, Editing, Re-Discovering, Purging and Removing LAN, LAN Tasks and
Switch

Cisco DCNM Web Client reports information that is obtained by the Cisco DCNM-LAN devices.

If the discovered Device is not in the scope of the current user the check box for the LAN Device in the LAN
table grays out.

Tip

This section contains the following:

Adding LAN Switches
To add LAN switches from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > Discovery > LAN Switches.

You see the list of LAN devices in the Switch column.

Step 2 Click the Add icon to add LAN.

You see the Add LAN Devicesdialog box.

Step 3 Select Hops from seed Switch or Switch List. The fields vary depending on your selection.
Step 4 Enter the Seed Switch IP address for the fabric.

For LAN Switches Discovery, DCNM allow both IPv4 and IPv6 address for the Seed Switch.

Step 5 The options vary depending on the discovery type selected. For example, if you check Use SNMPv3/SSH,
varied fields are displayed.

Step 6 Click the drop-down list and choose Auth-Privacy security level.
Step 7 Enter the Community, or user credentials.
Step 8 Select the LAN group from the LAN groups candidates which is in the scope of the current user.

Select DCNM server and click Add to add LAN switches.Note
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Step 9 Click Next to begin the shallow discovery.
Step 10 In the LAN Discovery window, you can select all switches by using the checkbox next to the switch name

column or select individual switches. Click Previous to go back and edit the parameters.

In the Status column, if the switch status is timeout or Cannot be contacted, these switches cannot
be added. Only the switches that are reachable and not managed yet are available to select. The
checkbox is disabled for the switches that are not available.

Note

Step 11 Select a switch and click Add to add a switch to the switch group.

If one of more seed switches is not reachable, it is shown as “unknown” on the shallow Discovery window.

Editing LAN Devices
To edit LAN devices from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Inventory > Discovery > LAN Switches.
Step 2 Select the check box next to the LAN that you want to edit and click Edit icon.

You see the Edit LAN dialog box.

Step 3 Enter the Username and Password.

Select Credential or Management State to change the Credential or Management state. If
Credential is selected, you can change the SNMP version and Auth-Privacy if v3, username or
password. If Management State is selected, you can change the status to managed or unmanaged.

Note

Step 4 Select the LAN status as Managed or Unmanaged.
Step 5 Click Apply to save the changes.

Removing LAN Devices from Cisco DCNM
You can remove a LAN switch from Cisco DCNM.

Procedure

Step 1 Choose Inventory > Discovery > LAN Switches.
Step 2 Select the check box next to the LAN that you want to remove and click Delete to remove the switches and

all their data.
Step 3 Click Yes to review the LAN device.
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Rediscover LAN Task

Procedure

Step 1 Choose Inventory > Discovery > LAN Switches.
Step 2 Click Rediscover LAN.
Step 3 Click Yes in the pop-up window to rediscover the LAN.
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C H A P T E R 4
Monitor

This chapter contains the following topics:

• Monitoring Switch, on page 35
• Monitoring LAN, on page 38
• Monitoring Report, on page 42
• Alarms, on page 44

Monitoring Switch
The Switch menu includes the following submenus:

Viewing Switch CPU Information
To view the switch CPU information from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > CPU.

The CPU window is displayed. This window displays the CPU information for the switches in that scope.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

Step 3 In the Switch column, click the switch name to view the Switch Dashboard.
Step 4 Click the chart icon in the Switch column to view the CPU utilization.

You can also change the chart timeline to Last 10 Minutes, Last Hour, Last Day, Last Week, Last Month, and
Last Year. You can choose the chart type and chart options to show as well.

Viewing Switch Memory Information
To view the switch memory information from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Monitor > Switch > Memory.

The memory panel is displayed. This panel displays the memory information for the switches in that scope.

Step 2 Use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last Month, and
Last Year.

Step 3 Click the chart icon in the Switch column to see a graph of the memory usage of the switch.
Step 4 In the Switch column, click the switch name to view the Switch Dashboard.
Step 5 You can use the drop-down to view the chart in different time lines. Use the chart icons to view the memory

utilization chart in varied views.

Viewing Switch Traffic and Errors Information
To view the switch traffic and errors information from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Traffic.

The Switch Traffic panel is displayed. This panel displays the traffic on that device for the past 24 hours.

Step 2 Use the drop-down to filter the view by 24 hours, Week, Month, and Year.
Step 3 Click the Export icon in the upper-right corner to export the data into a spreadsheet.
Step 4 Click Save.
Step 5 Click the switch name to view the Switch Dashboard section.

Viewing Switch Temperature
Cisco DCNM includes the module temperature sensor monitoring feature, using which you can view the
sensor temperature of a switch. You can choose an interval by which to filter the sensor list. The default
interval is Last Day. Only sensors that have historical temperature data is shown in the list. You can choose
between Last ten Minutes, Last Hour, Last Day, Last Week, and Last Month.

It is not necessary to configure the LAN credentials under the Configure > Credentials Management >
LAN Credentials screen to fetch the temperature monitoring data from the switches.

Note

To view the switch temperature information from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Monitor > Switch > Temperature.

The Switch Temperature window is displayed with the following columns.

• Scope: The sensor belongs to a switch, which is part of a fabric. The fabric that it belongs to is shown
as its scope. When the scope selector at the top of Cisco DCNM is used, the sensor list is filtered by that
scope.

• Switch: Name of the switch the sensor belongs to.
• IP Address: IP Address of the switch.
• Temperature Module: The name of the sensor module.
• Avg/Range: The first number is the average temperature over the interval that is specified at the top of

the table. The second set of numbers is the range of the temperature over that interval.
• Peak: The maximum temperature over the interval

Step 2 From this list, each row has a chart icon, which you can click.
A chart is displayed, which shows historical data for the sensor. The interval for this chart can be changed as
well, between 24 hours, 1 week, and 1 month.

Enabling Temperature Monitoring
You can enable the temperature monitoring feature for LAN switches from the LAN Collections screen, and
for the SAN switches by setting a few properties under Administration > DCNM Server > Server Properties
screens.

Enabling Temperature Monitoring for LAN Switches

1. From the menu bar, choose Administration > Performance Setup > LAN Collections.

2. Select the Temperature Sensor check box.

3. Select the type of LAN switches for which you want to collect performance data.

4. Click Apply to save the configuration.

Viewing Accounting Information
To view the accounting information from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Accounting.

The fabric name or the group name along with the accounting information is displayed.

Step 2 SelectAdvanced Filter beside the filter icon to search the accounting information by Source,Username,Time,
and Description. Or select Quick Filter to search under each column.

Step 3 You can also select a row and click the Delete icon to delete accounting information from the list.
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Step 4 You can use the Print icon to print the accounting details and use the Export icon to export the data to a
Microsoft Excel spreadsheet.

Viewing Events Information
To view the events and syslog from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Events.

The fabrics along with the switch name and the events details are displayed.

TheCount column displays the number of times the same event has occurred during the time period as shown
in the Last Seen and First Seen columns.

Click a switch name in the Switch column to view the switch dashboard.

Step 2 Select an event in the table and click the Add Suppressor icon to open the shortcut of adding an event
suppressor rule.

Step 3 Select one or more events from the table and click theAcknowledge icon to acknowledge the event information
for the fabric.

• After you acknowledge the event for a fabric, the acknowledge icon is displayed in the Ack column next
to the fabric.

Step 4 Select the fabric and click the Unacknowledge icon to cancel an acknowledgment for a fabric.
Step 5 SelectAdvanced Filter beside the filter icon to search the accounting information by Source,Username,Time,

and Description. Or select Quick Filter to search under each column.
Step 6 Select a fabric and use the Delete icon to delete the fabric and event information from the list.
Step 7 Click the Print icon to print the event details.
Step 8 Click the Export to Excel icon to export the data.

Monitoring LAN
The LAN menu includes the following submenus:

Monitoring Performance Information for Ethernet
To monitor the performance information for ethernet from the Cisco DCNM Web UI, perform the following
steps:
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Procedure

Step 1 Choose Monitor > LAN > Ethernet.

The Ethernet window is displayed.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

There are variations to this procedure. In addition to these basic steps, you can also perform the following
steps:

• Select the name of an Ethernet port from theName column to see a graph of the traffic across that Ethernet
port for the past 24 hours. You can change the time range for this graph by selecting it from the drop-down
list in the upper-right corner.

• To export the data into a spreadsheet, click the Export icon in the upper-right corner and click Save.

• Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append,
Predict, and Interpolate Data.

• For the Rx/Tx calculation, see the following Rx/Tx calculation.

The conversion for Fabrics is 10 bit = 1 byte and for LAN traffic, the conversion is 8 bit = 1
byte.

• Average Rx/Tx % = Average Rx/Tx divided by Speed * 100

• Peak Rx/Tx % = Peak Rx/Tx divided by Speed * 100

Note

If the performance tables do not contain any data, see the Thresholds section to turn on performance
data collection.

Note

Monitoring ISL Traffic and Errors
To monitor the ISL traffic and errors from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > LAN > Link.

The ISL Traffic and Errorswindow is displayed. This panel displays the ISL information for the end devices
in that scope. You can reduce or expand the scope of what is displayed by using the scope menu.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

NaN (Not a Number) in the data grid means that the data is not available.Note

There are variations to this procedure. In addition to these basic steps, you can perform the following steps
to view detailed information for ISLs:
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• To change the time range for this graph, select it from the drop-down list in the upper-right corner.

• To view the detailed information for a specific period, drag the slider control to choose the time interval
for which you need the information.

• Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append,
Predict, and Interpolate Data. To view real-time information, choose Real Time from the drop-down
list in the Chart menu.

• To export the data into a spreadsheet, choose Export from the drop-down list in the Chart menu and
then click Save.

• For the Rx/Tx calculation, see the following Rx/Tx calculation.

The conversion for Fabrics is 10 bit = 1 byte and for LAN traffic, the conversion is 8 bit = 1
byte.

• Average Rx/Tx % = Average Rx/Tx divided by Speed * 100
• Peak Rx/Tx % = Peak Rx/Tx divided by Speed * 100

Note

If the performance tables do not contain any data, see the Performance Setup Thresholds section to
turn on performance.

Note

Monitoring a vPC
The virtual port channel (vPC) feature enables you to view the links that are physically connected to different
devices as a single port channel. A vPC is an extended form of a port channel which allows you to create
redundancy and increase bisectional bandwidth by enabling multiple parallel paths between nodes and allowing
load balancing traffic. Traffic is distributed among two single device vPC endpoints. If there is an inconsistency
in the vPC configurations, the vPC does not function correctly.

To view the vPC in vPC Performance, both primary and secondary device should be designated to the user.
If either one kind of switch is not designated, vPC information is isplayed.

Note

Cisco DCNM Web Client > Monitor> vPC displays only consistent vPCs displays both the consistent and
inconsistent vPCs.

You can identify the inconsistent vPCs and resolve the inconsistencies in each vPC by using the Cisco DCNM
Web UI > Configure > Deploy > vPC Peer and Web Client > Configure > Deploy > vPC.

Table 7: vPC Performance, on page 40 displays the following vPC configuration details in the data grid view.

Table 7: vPC Performance

DescriptionColumn

Enter any string to filter the entries in their respective column.Search box

Displays vPC ID's configured device.vPC ID

Displays the domain ID of the vPC peer switches.Domain ID
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DescriptionColumn

Displays the multi-chassis vPC endpoints for each vPC ID
under a vPC domain.

Multi Chassis vPC EndPoints

Displays the vPC Primary device name.Primary vPC Peer - Device Name

Displays the primary vPC interface.Primary vPCPeer - Primary vPC Interface

Displays the capacity for the primary vPC peer.Primary vPC Peer - Capacity

Displays the average receiving speed of primary vPC peer.Primary vPC Peer - Avg. Rx/sec

Displays the average sending speed of primary vPC peer.Primary vPC Peer - Avg. Tx/sec

Displays the peak utilization percentage of primary vPC peer.Primary vPC Peer - Peak Util%

Displays the vPC secondary device name.Secondary vPC Peer - Device Name

Displays the secondary vPC interface.Secondary vPC Interface

Displays the capacity for the secondary vPC peer.Secondary vPC Peer - Capacity

Displays the average receiving speed of secondary vPC peer.Secondary vPC Peer - Avg. Rx/sec

Displays the average sending speed of secondary vPC peer.Secondary vPC Peer - Avg. Tx/sec

Displays the peak utilization percentage of secondary vPC
peer.

Secondary vPC Peer - Peak Util%

You can use this feature as following:

Monitoring vPC Performance
You can view the relationship among consistent virtual port channels (vPCs). You can view the statistics of
all member interfaces and the aggregate of the statistics at the port channel level.

This tab only displays consistent vPCs.Note

To view the VPC performance information from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > LAN > vPC.

The vPC Performance statistics is displayed. The aggregated statistics of all vPCs are displayed in a tabular
manner.

Step 2 Click the vPC ID.

The vPC topology, vPC Details, Peer-link Details, and Peer-link Status is displayed.
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The vPC Consistency, Peer-link Consistency, and vPC Type2 Consistency for the vPC is displayed.

• Click the vPCDetails tab, you can view the parameter details of vPCBasic Setting andLayer 2 Settings
for both Primary and Secondary vPC devices.

• Click the Peer-link Details tab, to view the parameter details of peer-link vPC Global Setting and STP
Global Settings for both Primary and Secondary vPC devices.

• Click the Peer-link Status tab, the vPC Consistency, and Peer-Link Consistency status is displayed.
The parameter details of Role Status and vPC Peer keep-alive Status for both Primary and Secondary
vPC devices is also displayed.

Step 3 Click the peer-link icon in front of the Device Name in the Primary vPC peer or Secondary vPC peer
column to view its member interface.

Step 4 Click the Show Chart icon of the corresponding interface to view its historical statistics.

The traffic distribution statistics appear at the bottom of the vPC window. By default, the Cisco DCNM Web
Client displays the historical statistics for 24 hours.

There are variations to this procedure. In addition to these basic steps, you can also perform the following
steps to view detailed information for flows:

• To change the time range for this graph, select it from the drop-down list in the upper right corner.

• To view the detailed information for a specific period, drag the slider control to choose the time interval
for which you need the information.

• Use the chart icons to view the traffic chart in varied views.

• You can also use the icons to Append, Predict, and Interpolate Data.

• To print the vPC Utilization data, click the Print icon in the upper-right corner. The vPC Utilization
page appears.

• To export the data into a spreadsheet, click the Export icon in the upper-right corner and click Save File.

If the performance tables do not contain any data, see the Thresholds section to turn on performance
data collection.

Note

Monitoring Report
The Report menu includes the following submenus:

Viewing Reports
You can view the saved reports that are based on the following selection options:

• By Template

• By User

• From the menu bar, select Monitor > Report > View.
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To view the reports from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 In the left pane, expand By Template or By User folder.
Step 2 Select the report that you wish to view.

You can view the report in the main screen or you can select the report in the Report column to view the
HTML version of the report in a new browser.

Step 3 To delete a specific report, select the check box and click the Delete icon.
Step 4 To delete all reports, check the check box in the header, and click the Delete icon.

If you have multiple fabrics, you can select the DCNM-SAN group in the Scope to view Host to
Storage connectivity of multiple fabrics in a single report.

Note

The report is divided into two sections:

• A summary report for all the devices that have faulty modules. The table displays information for every
device that includes the device hostname, number of faulty modules, and the module number with its
PID.

• The information for the device of the module. The table contains details about the tests failed.

Generating a Report
You can generate reports that are based on a selected template or you can schedule the report to run at a
specified time.

Procedure

Step 1 From the menu bar, select Monitor > Report > Generate.

You see the Generate Report window.

Step 2 In the configuration window, use the drop-down to define the scope for report generation.

In the Scope drop-down, you can select a scope group with dual fabrics, the traffic data that is generated by
hosts and storage end devices are displayed side by side which enables you to view and compare traffic data
that is generated on dual fabrics. To view this report, in theOther Predefined folder, selectTraffic by VSAN
(Dual Fabrics). Click Options to select the Device Type and Fabrics. Click Save to save the configuration.

Step 3 In the pane on the left, expand the folders and select the report.
Step 4 (Optional) In the pane on the right, you can edit the Report Name.
Step 5 (Optional) Check the Export to Csv/Excel check box to export the report to a Microsoft Excel spreadsheet.
Step 6 In the Repeat radio buttons, if you select:

• Never - The report is generated only during the current session.
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• Once - The report is generated on a specified date and time apart from the current session.

• Daily - The report is generated everyday based on the Start and End date at a specified time.

• Weekly - The report is generated once a week based on the Start and End date at a specified time.

• Monthly - The report is generated once every month based on the Start and End date at a specified time.

When you generate a report for Network Configuration Audit, the daily job generates a report for the selected
devices for last one day. Similarly, the weekly job generates a report for the last 7 days, and the monthly job
generates a report for the last 30 days.

Step 7 Click the Create button to generate a report that is based on the specifications.

You see the report results in a new browser window.

Alternatively, you can view the report by choosing Monitor > Report > View and selecting the report name
from the report template that you used in the navigation pane.

The Start Date must be at least five minutes earlier than the End Date.Note

The report is divided into two sections:

• A summary report for all the devices that have faulty modules. The table displays information for every
device that includes the device hostname, number of faulty modules and the module number with its
PID.

• A detailed information for the device of the module. The table contains details about the tests failed.

Viewing Scheduled Jobs Based on a Report Template
To view the scheduled jobs that are based on a report template from the Cisco DCNM Web UI, perform the
following steps:

Procedure

Step 1 Choose Monitor > Report > Jobs.

The Report Jobs window is displayed with details of the reports that are scheduled for generation along with
its status.

Step 2 Select the checkbox for a specific report and click the Delete Job icon to delete a report.

Alarms
The Alarms menu includes the following submenus:
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Monitoring and Adding Alarm Policies
You can add alarm policies for the following:

• Device Health: Device health policies enable you to create alarms when Device ICMP Unreachable,
Device SNMP Unreachable, or Device SSH Unreachable. Also, these policies enable you to monitor
chassis temperature, CPU, and memory usage.

• Interface Health: Interface health policies enable you to monitor Up or Down, Packet Discard, Error,
Bandwidth details of the interfaces. By default all interfaces are selected for monitoring.

• Syslog Alarm: Syslog Alarm Policy defines a pair of Syslog messages formats; one which raises the
alarm, and one which clears the alarm.

Before you begin

If you have created a self-signed certificate or imported an SSL certificate to the keystore, you must copy the
new fmserver.jks located at
/usr/local/cisco/dcm/wildfly-10.1.0.Final/standalone/configuration to
/etc/elasticsearch. If you do not copy the fmserver.jks file to the elasticsearch directory, you will
not be able to get the Alarms and Policies. As the elasticsearch database will be stabilizing, you cannot
configure any Alarm Policy on the Cisco DCNM Web UI Monitor > Alarms > Alarm Policies.

Procedure

Step 1 Choose Monitor > Alarms > Alarm Policies.
Step 2 Select the Enable Alarms check box to enable alarm policies.
Step 3 From the Add drop-down list, choose any of the following:

• Device Health Policy: Select the devices for which you want to create policies. Specify the policy name,
description, CPU Utilization parameters, Memory Utilization parameters, Environment Temperature
parameters, device availability, and device features.

• Interface Health Policy: Select the devices for which you want to create policies. Specify the policy
name, description, link-state, Bandwidth (In/Out), Inbound errors, Outbound errors, Inbound Discards,
and Outbound Discards.

• Syslog Alarm Policy: Select the devices for which you want to create policies and then specify the
following parameters.

• Devices: Define the scope of this policy. Select individual devices or all devices to apply this policy.

• Policy Name: Specify the name for this policy. It must be unique.

• Description: Specify a brief description for this policy.

• Severity: Define the severity level for this syslog alarm policy. Choices are: Critical, Major, Minor,
and Warning.

• Identifier: Specify the identifier portions of the raise & clear messages.

• Raise Regex: Define the format of a syslog raise message.

• Clear Regex: Define the format of a syslog clear message.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
45

Monitor
Monitoring and Adding Alarm Policies



Table 8: Example1

ID1-ID2Identifier

ETH_PORT_CHANNEL-5-PORT_DOWN:
$(ID1): $(ID2) is down

Raise Regex

ETH_PORT_CHANNEL-5-PORT_UP: $(ID1):
$(ID2) is up

Clear Regex

Table 9: Example2

ID1-ID2Identifier

ETHPORT-5-IF_SFP_WARNING: Interface
$(ID1), High Rx Power Warning

Raise Regex

ETHPORT-5-IF_SFP_WARNING: Interface
$(ID1), High Rx Power Warning cleared

Clear Regex

Step 4 Click OK to add the policy.

Activating Policies
After you create new alarm policies, activate them.

Procedure

Step 1 Choose Monitor > Alarms > Policies.
Step 2 Select the policies that you want to activate and then click the Activate button.

Deactivating Policies
You can deactivate the active alarm policies.

Procedure

Step 1 Choose Monitor > Alarms > Policies.
Step 2 Select the policies that you want to deactivate and then click the Deactivate button.

Importing Policies
You can create alarm policies using the import functionality.
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Procedure

Step 1 Choose Monitor > Alarms > Policies and then click the Import button.
Step 2 Browse and select the policy file saved on your computer.

You can only import policies in text format.

Exporting Policies
You can export the alarm policies into a text file.

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Click the Export button and then select a location on your computer to store the exported file.

Editing Policies

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Select the policy that you want to edit.
Step 3 Click the Edit button and then make necessary changes.
Step 4 Click the OK button.

Deleting Policies

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Select the policy that you want to delete.
Step 3 Click the Delete button. The policy is deleted.

Viewing Alarms and Events
You can view the alarms, cleared alarms, and events.
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Procedure

Step 1 Choose Monitor > Alarms > View.
Step 2 Choose any of the following tabs.

• Alarms: This tab displays the alarms that are generated for various categories. This tab displays
information such as ID (optional), Severity, Failure Source, Name, Category, Acknowledged, Creation
Time, Last Updated (optional), Policy, and Message. You can specify the Refresh Interval in this tab.
You can select one or more alarms and then acknowledge or unacknowledge their status using theChange
Status drop-down list. In addition, you can select one or more alarms and then click the Delete button
to delete them.

• Cleared Alarms: This tab displays the cleared alarms. This tab displays information such as ID (optional),
Severity, Failure Source, Name, Category, Acknowledged, Creation Time, Cleared At (optional), Cleared
By, Policy, and Message. You can select one or more alarms and then click the Delete button to delete
them.

• Events: This tab displays the events that are generated for the switches. This tab displays information
such as Ack, Acknowledged user, Group, Switch, Severity, Facility, Type, Count, Last Seen, and
Description. You can select one or more events and then acknowledge or unacknowledge their status
using the Change Status drop-down list. In addition, you can select one or more alarms and then click
the Delete button to delete them. If you want to delete all events, click the Delete All button.
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C H A P T E R 5
Configure

This chapter contains the following topics:

• Deploy, on page 49
• Templates, on page 66
• Backup, on page 89
• Image Management, on page 101

Deploy
The Deploy menu includes the following submenus:

POAP Launchpad

These features appear on your Cisco DCNM application only if you have deployed the Cisco DCNM installer
in the Unified Fabric mode.

Note

The POAP launchpad contains the following configuration steps:

Procedure

Step 1 Create and manage scopes for POAP creation.
Step 2 Set a server for images and configuration files.
Step 3 Generate from a template or upload existing configuration.
Step 4 Create, Publish, and Deploy Cable Plans.

Power-On Auto Provisioning (POAP)
Power-On Auto Provisioning (POAP) automates the process of upgrading software images and installing
configuration files on Cisco Nexus switches that are being deployed in the network for the first time.
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If the AAA authentication is set up before adding switch, "Invalid Credential" error appears during POAP.
There is no functional impact. However, it refrains from DCNM receiving accurate POAP. You must update
the poap_dcnm.py file located in /var/lib/dcnm/with the new AAA administrative password, by using
the following command:

dcnm# python poap_dcnm.py dcnm-info <dcnm-ipaddress> <username> <password>

When a Cisco Nexus switch with the POAP feature boots and does not find the startup configuration, the
switch enters POAP mode, locates a DHCP server and bootstraps itself with its interface IP address, gateway,
and DNS server IP addresses. It also obtains the URL of an SCP server and downloads a configuration script
that is run on the switch to download and install the appropriate software image and configuration file.

If the POAP does not complete any configurations, you can refresh the configurations on the device. SSH to
Cisco DCNM server and logon. Navigate to the DCNM directory by using the following command:
dcnm# cd /var/lib/dcnm/<switch_serial_number>

Locate the switch configuration file is the above directory. Refresh the configuration by using the following
command:
dcnm# sed -i 's/\r//g' <config_file_for_switch>

When you move the mouse cursor over an error that is identified in a specific parameter in any window, it
will display the exact error message before you move to the next screen.

Note

DHCP Scopes
DHCP scope is a well-defined term in DHCP arena. It is used to define a policy for giving out IP addresses
and other options to host on a specific IP subnet. In DCNM, we use the DCHP scope to distribute IPv4 address,
PYTHON bootscript, (or other supported protocol + access credential + server) which stores the bootscript.

Choose Configure > Deploy > POAP.

The following table details the columns in the display.

Table 10: DCHP Scopes display fields

CommentDHCP Scopes

The DHCP scope name must be unique among the switch scopes. This name
is not used by ISC DHCP but used to identify the scope.

Scope Name

The IPv4 subnet used by the DHCP servers.Scope Subnet

The IP address ranges allocated to the POAP switches. Multiple IP addresses
can be used, separated by comma.

IP Address Range

Maximum lease time for the DHCP lease.Lease Time

The default gateway for the DHCP scope. Enter a valid IP as the default
gateway.

Default Gateway

The domain name server for the DHCP scope.Domain Name Servers

The Python Bootup script.Bootscript Name
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CommentDHCP Scopes

The server that holds the bootscript.TFTP/Bootscript Server

Adding a DHCP Scope

To add a DHCP scope from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > DHCP Scopes.

The DCHP Scopes window is displayed.

Step 2 Click Add scope icon.
Step 3 In theAddDHCP Scopewindow, specify values in the fields according to the information in Table 10: DCHP

Scopes display fields, on page 50.
Step 4 Click OK to add a DHCP scope.

Editing an existing DHCP Scope

Once the DCNM is accessed for the first time, you must edit the default scope named enhanced_fab_mgmt
and add free IP address ranges.

Note

To edit an existing DHCP scope from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > DHCP Scopes.
Step 2 Use the checkbox to select the DHCP scope.
Step 3 Click Edit scope icon.
Step 4 In the Edit DHCP Scope window, edit the DHCP scopes.
Step 5 Click Apply to save the changes.

Deleting a DHCP Scope

To delete a DHCP scope from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > DHCP Scopes.
Step 2 Use the checkbox to select the DHCP scope.
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Step 3 Click Delete scope icon.
Step 4 In the delete notification, click Yes to delete the DHCP scope.

You may click the Refresh icon to refresh the DHCP Scopes list.Note

Image and Configuration Servers
The Image and Configuration Servers page allows you to specify the servers and credentials used to access
the device images and the uploaded or Cisco DCNM generated or published device configuration. The server
that is serving the images could be different from the one serving the configurations. If the same server is
serving both images and configurations, you need to specify the server IP address and credentials twice for
each server because the root directory holding the images or configuration files could be different. By default,
the Cisco DCNM server will be the default image and configuration server. There will be two Cisco DCNM
server addresses, one for configuration, one for image.

From the menu bar, choose Configure > Deploy > POAP. The Power-On Auto Provisioning (POAP) page
appears. Click Images and Configuration.

The following table details the columns in the display.

Table 11: DCHP Scopes display fields

DescriptionImage and Configuration
Servers

Name of the image and configuration server.Name

URL shows where images and files are stored.URL

Indicates the username.Username

Indicates the last modified date.Last Modified

You can add your own image and configuration servers if they are different from the default.

Add Image or Configuration Server URL

To add an image or a configuration server URL from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 On the Image and Configuration Servers page, click the Add icon.
Step 2 In the Add Image or Configuration Servers URL window, specify a name for the image.
Step 3 Select the scp radio button to select the SCP protocol for POAP and Image Management.
Step 4 Enter Hostname/Ipaddress and Path.
Step 5 Specify the Username and Password.
Step 6 Click OK to save.
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Editing an Image or Configuration Server URL

To edit an image or a configuration server URL to the repository from the Cisco DCNM Web UI, perform
the following steps:

Procedure

Step 1 On the Image and Configuration Servers page, select an existing Image and Configuration Server from the
list, and click the Edit icon.

Step 2 In the Edit Image or Configuration Servers URL window, edit the required fields.

The Default_SCP_Repository cannot be edited.

Step 3 Click OK to save or click Cancel to discard the changes.

Deleting an Image or Configuration Server URL

To delete an image or a configuration server URL to the repository from the Cisco DCNM Web UI, perform
the following steps:

Procedure

Step 1 On the Image and Configuration Servers page, select an existing Image and Configuration Server from the
list, and click the Delete icon.

Step 2 In the delete notification, click Yes to delete the image and configuration server.

The default SCP Repository cannot be deleted.Note

Using the File Browser

The file browser feature enables you to browse through the repository.

To view the files using file browser from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 On the Image and Configuration Servers page, select an existing Image and Configuration Server from the
list.

Step 2 Click the File Browser button to see the file in the directory. The File browser pop-up dialog appears.

Uploading an Image File

To upload an image file from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 On the Image and Configuration Servers window, select an existing Image and Configuration Server
from the list.

Step 2 Click the Image Upload button.
Step 3 Click the Choose File button to choose an image file.
Step 4 In the Platform drop-down list, choose the hardware model name of the managed device. For example, N7K,

N9K.
Step 5 In the Type drop-down list, choose the image type. For example, kickstart, system.

POAP Templates
Templates can be created or imported into the template builder of DCNM. There are some predefined Fabric
specific POAP templates bundled with DCNM. The template builder can be invoked from the GUI,Configure
> Templates > Deploy. The templates dedicated to POAP will be used to generate many different POAP
device configurations

The following icons are listed at the menu bar of the window to customize the view of the information in the
window:

• Use the Show Filter icon to filter the templates.

• Use the Print icon to print the list of templates and their details.

• Use the Export icon to export the list of templates to a Microsoft Excel spreadsheet.

This section contains the following:

Add POAP Template

To add POAP templates from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.

The POAP Definitions window is displayed.

Step 2 In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Click the Add template icon.
Step 4 Specify the Template Name, Template Description, and Tags.
Step 5 Use the checkbox to specify the Supported Platforms.
Step 6 Select the template type from the drop-down list.

By default, CLI template type is selected.

Step 7 Select the Published checkbox if you want the template to have ‘Read Only’ access.
Step 8 In the Template Content pane, specify the content of the template.
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For help on creating the template content, click the Help icon next to the Template Content header. For
information about POAP template annotations, see the POAP Template Annotation, on page 56 section.

Step 9 Click Validate Template Syntax to validate syntax errors.
Step 10 Click Save to save the template.
Step 11 Click Save and Exit to save the template and exit the window.
Step 12 Click Cancel to discard the template.

Editing a Template

To edit a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Select a template from the list and click the Modify or View template icon.
Step 4 Edit the template content and click Save to save the template or Save and Exit to save and exit the screen.

Cloning a Template

To clone a template from an existing template, from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Select a template from the list and click Save Template As icon.
Step 4 Edit the template and click Save to save the template or Save and Exit to save and exit the screen.

Importing a Template

To import a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP.
Step 2 Under Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Select a template from the list and click Import Template.
Step 4 Select the template file and upload.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
55

Configure
Editing a Template



Exporting a Template

To export a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Select a template from the list and click Export template icon.
Step 4 Select a location for the file download.

Deleting a Template

Only user-defined templates can be deleted.Note

To delete a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 In the Configuration Steps, click the template hyperlink in the POAP Definitions section.
Step 3 Select a template from the list and click Remove template icon.
Step 4 Click Yes to confirm.

POAP Template Annotation
Annotation is used to add semantic, validation logic and description to the template variable.

The Annotation for a given template variable is required to precede the given template variable. Only one
annotation statement is required for each template variable. When a template variable has an associated
annotation statement, the template variable has to be declared on a single line, Multiple variables cannot be
declared under the same annotation statement.

Format of an annotation statement is as follows:

@(<key1>=<value1>,<key2>=<value2>, ..., <keyN>=<valueN>)

Each annotation statement is composed of one or more key-values pair.Note

• The value can be true, false, or a string.
• If the value is a string, it should be double quoted.
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The following is a sample template variable, “hostname”, with annotation statement with the keys
“DisplayName”, and “Description”:

@(DisplayName=”Host Name”, Description = “Description of the host”)

String hostname;

The table displays the supported keys in the annotation statement:

Table 12: Annotation Keys

DescriptionDefault ValueKey Name

The value is displayed as a variable label in the template form
GUI, on POAP definition screen.

Empty StringDisplayName

Displays the description next or below the template variable
field in the template form GUI.

Empty StringDescription

The associated variable is of IP Address type. This will be used
as the management IP address. DCNM used this IP address to
manage the devices.

falseIsManagement

If true, this single value can take multiple values. For example;
when it is used with IsManagement annotation, it allows you
to type in multiple IP addresses and assign each IP address to
a device.

falseIsMultiplicity

The associated variable value is used as the device host name.falseIsSwitchName

It marks the field as mandatory if the value is set as ‘true’.trueIsMandatory

This annotation compliments the IsSwitchName annotation.
Once they are associated with a variable. The variable is
populated with the reverse DNS name, if available during the
creation time of the corresponding POAP definition record.

falseUseDNSReverseLookup

The associated variable value contains a list of the ports used
as fabric ports. The variable value will be used by the cable
plan generation from POAP

falseIsFabricPort

Trunk ports connected to host/servers.falseIsHostPort

Used as the vPC Domain ID.falseIsVPCDomainID

Used as the VPC IPv4 source address.falseIsVPCPeerLinkSrc

Used as the VPC IPv4 peer address.falseIsVPCPeerLinkDst

Used for VPC port channel.falseIsVPCPeerLinkPortChannel

Used for VPC interface.falseIsVPCLinkPort

Used as a VPC record.falseIsVPC

Individual VPC ID.falseIsVPCID
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DescriptionDefault ValueKey Name

Individual VPC port channel.falseIsVPCPortChannel

VPC Interface.falseIsVPCPort

POAP Definitions
The POAP switch definition has two major functions:

• Monitoring switch POAP process

• Managing POAP switch configuration

You must copy the Cisco DCNM license files to the /var/lib/dcnm/license directory to install as part of the
POAP process.

You must also copy the device licenses to the /var/lib/dcnm/licenses folder.

The device licenses refers to the devices monitored by the Cisco DCNM.Note

The following fields and icons are listed at the menu bar of the window to customize the view of the information
in the window:

DescriptionFields and
Icons

Specifies the serial number for the switch.Serial
Number

Specifies the ID defined for the switchSwitch ID

Specifies the Management IP for the switch.Management
IP

Status

Indicates if the switch is published or not.Switch
Status

Indicates if this POAP template has been published successfully
to the TFTP site.

Publish
Status

Indicates the Bootscript execution state when the device executed
POAP. For details, view the “Boot Log” file.

Bootscript
Status
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DescriptionFields and
Icons

Specifies if the configuration defined in POAP is different from
the running configuration on the device. If a difference is detected,
the user has an option to make changes to the device configuration,
thereby ensuring that the configuration on the device in sync with
the POAP configuration. The different states are:

• NA—Specifies that no POAP definition is configured on
DCNM for the particular device; therefore, no difference
computation can be made.

• Diff Detected—Specifies that few configuration differences
are detected between POAP definition in DCNM and the
running configuration on the switch. You can review the
difference statements and choose the commands to deploy to
the device, and synchronize the running configuration with
the POAP definition.

• No Diff Detected—Specifies that there was no configuration
diff perceived between POAP definition and the running
configuration on the switch.

• Error—Specifies that an error has occurred during diff
computation. Refer to the logs to troubleshoot the issue.

Diff State

Specifies the model of the switch.Model

Specifies the template used for creating the POAP definition.

Fabric and IPFabric POAP templates are available.

Template/Config
File Name

Specifies the last updated time for bootscript.Bootscript
Last
Updated
Time

Specifies the last published time for the POAP definition.Last
Published

Specifies the time when the POAP definition was created.POAP
Creation
Time

Specifies the System Image used while creating the POAP
definition.

System
Image

Specifies the kickstart image used the POAP definition.Kickstart
Image

Icons

Allows you to add a POAP definition. For more information, see
Creating a POAP Definition, on page 60.

Add
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DescriptionFields and
Icons

Allows you to edit a POAP definition. For more information, see
Editing a POAP Definition, on page 62.

Edit

Allows you to delete a POAP definition. For more information,
see Deleting POAP Definitions, on page 62.

Delete

Allows you to reboot and reload a POAP definition. For more
information, see Write, Erase, and Reload the POAP Switch
Definition, on page 63.

Write
Erase and
Reload

Allows you to change the image for the defined POAP definition.
For more information, see Change Image, on page 63.

Change
Image

Display the list and view log files from the device bootflash.Boot Log

Allows the user to modify the serial number of the POAP definition.Update
Serial
Number

Refreshes the list of switches.Refresh
Switch

Refreshes the Diff state.Refresh
Diff State

Filters list of switches based on the defined value for each column.Show Filter

Prints the list of devices and their details.Print

Exports the list of devices and their details to a Microsoft Excel
spreadsheet.

Export

Displays the columns to be displayed. You can choose to show/hide
a column.

Select
Columns

Each annotation statement is composed of one or more key-values pair. The value can be true, false or a string.
If the value is a string, it should be mentioned in double-quotes.

Note

This section contains the following:

Creating a POAP Definition

To create a POAP definition from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
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Step 2 From the Scope drop-down list, select the scope for POAP definition.
Step 3 Click Add to add a new POAP definition.
Step 4 Click Generate Definition radio button to generate POAP definition from a template, and click Next to

specify the switch details.
Step 5 Enter the serial number of switches that are separated by comma. Alternatively, you can click Import from

CSV File to import the list of switches.

The serial number cannot be changed after you create the POAP definition. Verify that the serial
numbers do not contain spaces, the POAP will not work otherwise.

Note

Step 6 Use the drop-down list to select the Switch Type.
Step 7 Use the drop-down list to select the Image Server.
Step 8 Use the drop-down list to select the System Image and Kickstart image.
Step 9 Specify the Switch Username and Switch Password.
Step 10 Click Next to Select the Switch Config Template.
Step 11 Use the drop-down to select the Template and click View to specify the Template Parameters.
Step 12 Enter Template Parameters.
Step 13 From the Settings File drop-down list to select the file. If the settings file in unavailable, click Save Parameter

as New Settings File button to specify a name for the settings file.
Step 14 Select the variables and click Manage.
Step 15 Click Add to see the variables to be saved.

Specify a name for the settings file and click Save.

Step 16 Click Manage to modify the settings file parameters.
Step 17 Click Preview CLI to view the generated configuration.
Step 18 Click Finish to publish the POAP definition.
Step 19 Click Next to generate the configuration.

Uploading a POAP Definition

To upload a POAP definition from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Click Upload Startup Config radio button to upload startup configuration to the POAP repository Server,

and click Next to enter the switch details.
Step 3 Enter the serial number of switches separated by comma.
Step 4 Use the drop-down to select the Switch Type.
Step 5 Use the drop-down to select the Image Server.
Step 6 Use the drop-down to select the System Image and Kickstart Image.
Step 7 Specify the Switch User Name and Password.
Step 8 Click Browse to select the upload configuration file.
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Step 9 Click Finish to publish the POAP definition.

Editing a POAP Definition

To edit a POAP definition from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Select the POAP switch definitions from the list and click the Edit icon.
Step 3 Follow the steps listed in Creating a POAP Definition, on page 60 and Uploading a POAP Definition, on

page 61 sections.

You can select multiple POAP definitions with similar parameters to edit POAP definition.Note

Deleting POAP Definitions

To delete POAP definitions from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Select the POAP switch definitions from the list and click Delete icon.
Step 3 Click Yes to delete the switch definitions.

A prompt appears to delete the device from the data source. Check or uncheck the checkbox based if you want
to delete the switches associated with the POAP Definition.

Step 4 Click OK to confirm to delete the device. Based on the check box, the device will be deleted from the data
source also.

Publishing POAP Definitions

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Select the POAP switch definitions from the list and click Publish.
Step 3 Click Yes to publish the switch definitions.
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Write, Erase, and Reload the POAP Switch Definition

To write, erase, and reload the POAP switch definition from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Select the POAP switch definitions from the list and click the Edit icon.
Step 3 Click Write Erase and Reload.

TheWrite,Erase, andReloadworks only when the selected switches are listed in the Inventory >Discovery
> LAN Switches window. Also, valid credentials must be specified in the Configure > Credentials
Management > LAN Credentials window.

Step 4 Click Continue to reboot and reload the switch definitions.

Change Image

To change image from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > POAP Definitions.
Step 2 Select the POAP switch definitions from the list and click the Edit icon.
Step 3 Select the switch for which you must change the image. Click Change Image.

You can select multiple POAP definitions with similar parameters to change the image for booting
the device.

Note

The Multi Device Image Change window is displayed.

Step 4 From the Image Server drop-down list, select the server where the new image is stored.
Step 5 From the System Image drop-down list, select the new system image.
Step 6 From the Kickstart Image drop-down list, select the new image which replaces the old image.
Step 7 Click OK to apply and change the image.

Updating the Serial Number of a Switch for an Existing POAP Definition

To update the serial number of a switch when performing an RMA from the Cisco DCNM Web UI, perform
the following steps:

Procedure

Step 1 Ensure that the old switch is in place with POAP definition and discovered.
Step 2 Manually update the serial number in Cisco DCNM on the POAP screen.
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This button may be hidden underneath a >> button.Note

Now, two devices in Cisco DCNM have the same IP address.

Step 3 Physically remove the old switch from the network.
Step 4 Place the new switch in the rack and connect network cables and power. Bring up the new switch. The new

switch reboots several times so that it comes up with necessary configurations.
Step 5 Manually rediscover the switches in Cisco DCNM.

There is one device in Cisco DCNM with the same IP address.

Cable Plan

If you are generating POAP definitions from the uploaded configuration, then generation of cable plan using
the option of “Generate Cable Plan from POAP definition” will not work as the POAP definitions that are
generated from the uploaded configuration will not have the required meta-data to generate the cable plans.
You must select either “Capture from Existing Deployment” or “Import Cable plan file” to create a cable
plan.

Note

The Cable plan configuration screen has the following options:

Create a Cable Plan

To create a cable plan from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
Step 2 Click Create Cable Plan.

In the Create Cable Plan pop-up, use the radio button to select the options.

Step 3 If you select:
a) Capture from existing deployment: You can ascertain the Inter-Switch Links between existing switches

that are managed by DCNM and “lock down” the cable plan based on the existing wiring.
b) Import Cable Plan File: You decide how to wire the switches (or how they are already wired) and select

an XML file for import into DCNM.

Viewing an Existing Cable Plan Deployment

To view the existing cable plan deployment from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
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Step 2 Click View.
Step 3 In the Cable Plan – Existing_Deployment window, you can view the existing cable plan deployments.
Step 4 You can use the Table View and XML View icons to change the view of the cable plan deployments table.

Deleting a Cable Plan

To delete a cable plan from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
Step 2 Click Delete icon.
Step 3 Click Yes to confirm deletion.

Deploying a Cable Plan

To deploy a cable plan from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
Step 2 In the Switches table, use the checkbox to select the cable plan and click Deploy a Cable Plan.
Step 3 Click Yes to confirm deployment.

Revoking a Cable Plan

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
Step 2 In the Switches table, use the check box to select cable plans, and click Revoke a Cable Plan.
Step 3 Click Yes to confirm.

Viewing a Deployed Cable Plan from Device

To view the deployed cable plan from a device from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Deploy > POAP > Cable Plan.
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Step 2 In the Switches table, click In Sync or Out of Sync hyperlink in the cable plan status column.
Step 3 You can use the Table View and XML View icons to change the view of the cable plan table.

Templates
The Templates menu includes the following option:

Template Library
Template Library includes the following tabs:

Template Library
You can add, edit, or delete templates that are configured across different Cisco Nexus and Cisco MDS
platforms using Cisco DCNM Web client. From Cisco DCNM Web client home page, choose Configure >
Templates > Template Library > Templates. The following parameters are displayed for each template
that is configured on Cisco DCNM Web client. Templates support JavaScript. You can use the JavaScript
function in a template to perform arithmetic operations and string manipulations in the template syntax.

The following table describes the fields that appear on this page.

Table 13: Templates Operations

DescriptionField

Allows you to add a new template.Add Template

Allows you to create jobs.Launch job creation wizard

Allows you to view the template definition and modify as required.Modify/View Template

Allows you to save the selected template in a different name. You
can edit the template as required.

Save Template As

Allows you to delete a templateDelete Template

Allows you to import a template from your local directory, one at
a time.

Import Template

Allows you to export the template configuration to a local directory
location.

Export template

Allows you to import .zip file, that contains more than one
template that is bundled in a .zip format

All the templates in the ZIP file are extracted and listed in the table
as individual templates.

Import Template Zip File
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Table 14: Template Properties

DescriptionField

Displays the name of the configured template.Template Name

Displays the description that is provided while configuring
templates.

Template Description

Displays the tag that is assigned for the template and aids to filter
templates based on the tags.

Tags

Displays the abstract template to be implemented.Implements

Specifies the specific feature of a switch.Dependencies

Displays the supported Cisco Nexus platforms compatible with the
template. Check the check box of platforms that are supported with
the template.

You can select multiple platforms.Note

Supported Platforms

Displays the type of the template.Template Type

Specifies the sub type that is associated with the template.Template Sub Type

Specifies if it is Jython or Template CLI.Template Content Type

Specifies if the template is published or not.Published

Specifies the base template for importing.Imports

In addition, from the menu bar, choose Configure > Templates > Template Library > Templates and you
can also:

• Click Show Filter to filter the templates that is based on the headers.

• Click Print to print the list of templates.

• Click Export to Excel to export the list of template to a Microsoft Excel spreadsheet.

This section contains the following:

Template Structure

The configuration template content mainly consists of four parts. Click the Help icon next to the Template
Content for information about editing the content of the template.

This section contains the following:

Template Format

This section describes the basic information of the template. The possible fields are as detailed in the table
below.
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Optional?Valid ValuesDescriptionProperty Name

NoTextThe name of the templatename

YesTextBrief description about the
template

description

Yes“true” or “false”Indicates whether the user
created the template. Value is
‘true’ if user created.

userDefined

NoN1K, N3K, N3500, N4K, N5K,
N5500, N5600, N6K, N7K, N9K,
MDS, VDC, N9K-9000v, All list
separated by comma.

List of device platforms
supports this configuration
template. Specify ‘All’ to
support all platforms.

supportedPlatforms

Yes• CLI

• POAP

• POLICY

• SHOW

• PROFILE

• FABRIC

• ABSTRACT

Specifies the type of Template
used.

templateType
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Optional?Valid ValuesDescriptionProperty Name

Specifies the sub type
associated with the template.

templateSubType
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Optional?Valid ValuesDescriptionProperty Name

• CLI

• N/A

• POAP

• N/A

• VXLAN

• FABRICPATH

• VLAN

• PMN

• POLICY

• VLAN

• INTERFACE_VLAN

• INTERFACE_ETHERNET

• INTERFACE_BD

• INTERFACE_PORT_CHANNEL

• INTERFACE_FC

• INTERFACE_MGMT

• INTERFACE_LOOPBACK

• INTERFACE_NVE

• INTERFACE_VFC

• INTERFACE_SAN_PORT_CHANNEL

• DEVICE

• FEX

• INTERFACE

• SHOW

• VLAN

• INTERFACE_VLAN

• INTERFACE_VPC

• INTERFACE_ETHERNET

• INTERFACE_BD

• INTERFACE_PORT_CHANNEL
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Optional?Valid ValuesDescriptionProperty Name

• INTERFACE_FC

• INTERFACE_MGMT

• INTERFACE_LOOPBACK

• INTERFACE_NVE

• INTERFACE_VFC

• INTERFACE_SAN_PORT_CHANNEL

• DEVICE

• FEX

• INTERFACE

• PROFILE

• VXLAN

• FABRIC

• NA

• ABSTRACT

• VLAN

• INTERFACE_VLAN

• INTERFACE_VPC

• INTERFACE_ETHERNET

• INTERFACE_BD

• INTERFACE_PORT_CHANNEL

• INTERFACE_FC

• INTERFACE_MGMT

• INTERFACE_LOOPBACK

• INTERFACE_NVE

• INTERFACE_VFC

• INTERFACE_SAN_PORT_CHANNEL

• DEVICE

• FEX

• INTERFACE
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Optional?Valid ValuesDescriptionProperty Name

Yes• CLI

• TEMPLATE_CLI

• POAP

• TEMPLATE_CLI

• POLICY

• TEMPLATE_CLI

• PYTHON

• SHOW

• TEMPLATE_CLI

• PROFILE

• TEMPLATE_CLI

• PYTHON

• FABRIC

• PYTHON

• ABSTRACT

• TEMPLATE_CLI

• PYTHON

contentType

YesTextUsed to implement the abstract
template.

implements

YesTextUsed to select the specific
feature of a switch.

dependencies

Yes“true” or “false”Used to Mark the template as
read only and avoids changes
to it.

published

YesModified date and time in the
format YYYY-MM-DD
HH:MM:SS

Shows the template modified
time

timestamp

Template Variables

This section contains declared variables, the data type, default values, and valid values conditions for the
parameters that are used in the template. These declared variables are used for value substitution in the template
content section during the dynamic command generation process. Also these variables are used in decision
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making and in iteration blocks in the template content section. Variables have predefined data types. You can
also add a description about the variable. The following table describes the syntax and usage for the available
datatypes.

Iterative?Valid ValueVariable Type

Notrue|falseboolean

No
Example: running-config, startup-config

enum

NoFloating number formatfloat

Yes
Example: 10.1,50.01

floatRange

NoAny numberInteger

YesContiguous numbers separated by “-“

Discrete numbers separated by “,”

Example: 1-10,15,18,20

integerRange

NoFormat: <if type><slot>[/<sub slot>]/<port>

Example: eth1/1, fa10/1/2 etc.

interface

Yes
Example: eth10/1/20-25, eth11/1-5

interfaceRange

NoIPv4 OR IPv6 addressipAddress

Yes
Example: 172.22.31.97, 172.22.31.99,
172.22.31.105, 172.22.31.109

ipAddressList

NoExample: 192.168.1.1

or
Example: 1:2:3:4:5:6:7:8

ipAddressWithoutPrefix

Yes
Example:{192.168.1.1, 192.168.1.2, 10.1.1.1}

ipAddress[]

NoIPv4 addressipV4Address

NoExample: 192.168.1.1/24ipV4AddressWithSubnet

NoIPv6 addressipV6Address

NoExample: 1:2:3:4:5:6:7:8

22

ipV6AddressWithPrefix

NoIPv6 Address with SubnetipV6AddressWithSubnet

NoExample: 49.0001.00a0.c96b.c490.00ISISNetAddress
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Iterative?Valid ValueVariable Type

No14 or 17 character length MAC address formatmacAddress

NoFree text

Example: Description for the variable

string

Yes
Example: {a,b,c,str1,str2}

string[]

No
Example: 20:01:00:08:02:11:05:03

wwn

(Available only in Cisco DCNM Web
Client)

Variable Meta Property

Each variable that is defined in the template variable section has a set of meta properties. The meta properties
are mainly the validation rules that are defined for the variable.

The following table describes the various meta properties applicable for the available variable types.

Variable Meta PropertyDescriptionVariable
Type

regular
Expr

max
Length

min
Length

max
Port

min
Port

max
Slot

min
Slot

maxmindecimal
Length

valid
Values

default
Value

YesA
boolean
value.
Example:
true

boolean

Yesenum

YesYesYesYesYessigned
real
number.
Example:

75.56,
-8.5

float

YesYesYesYesYesrange
of
signed
real
numbers
Example:
50.5
-
54.75

floatRange
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Variable Meta PropertyDescriptionVariable
Type

regular
Expr

max
Length

min
Length

max
Port

min
Port

max
Slot

min
Slot

maxmindecimal
Length

valid
Values

default
Value

YesYesYesYessigned
number
Example:
50,
-75

integer

YesYesYesYesRange
of
signed
numbers
Example:
50-65

integerRange

YesYesYesYesYesYesspecifies
interface/port
Example:

Ethernet
5/10

interface

YesYesYesYesYesYesinterfaceRange

YesIP
address
in
IPv4
or
IPv6
format

ipAddress

YesExample:

192.10.2.10,

172.68.10.1

Separate
the
addresses
in the
list using
commas
and not
hyphens.

Note

ipAddressList
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Variable Meta PropertyDescriptionVariable
Type

regular
Expr

max
Length

min
Length

max
Port

min
Port

max
Slot

min
Slot

maxmindecimal
Length

valid
Values

default
Value

IPv4
or
IPv6
Address
(does
not
require
prefix/subnet).

ipAddressWithoutPrefix

YesList
of IP
addresses
separated
by a
comma
(,)

ipAddress[]

YesIPv4
address

ipV4Address

YesIPv4
Address
with
Subnet

ipV4AddressWithSubnet

YesIPv6
address

ipV6Address

YesIPv6
Address
with
prefix

ipV6AddressWithPrefix

YesIPv6
Address
with
Subnet

ipV6AddressWithSubnet

Example:

49.0001.00a0.c96b.c490.00

ISISNetAddress

YesYesYesExample:
100

long

MAC
address

macAddress
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Variable Meta PropertyDescriptionVariable
Type

regular
Expr

max
Length

min
Length

max
Port

min
Port

max
Slot

min
Slot

maxmindecimal
Length

valid
Values

default
Value

YesYesYesYesliteral
string

string

Yesstring
literals
that
are
separated
by a
comma
(,)
Example:

{string1,

string2}

string[]

Set of
parameters
that
are
bundled
under
a
single
variable.
struct

<structure
name
declaration
> {
<parameter
type>

<parameter
1>;
<parameter
type>

<parameter
2>;
…..
}
[<structure_inst1>]
[,
<structure_inst2>]
[,
<structure_array_inst3
[]>];

struct
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Variable Meta PropertyDescriptionVariable
Type

regular
Expr

max
Length

min
Length

max
Port

min
Port

max
Slot

min
Slot

maxmindecimal
Length

valid
Values

default
Value

WWN
address

wwn

Example: Meta Property Usage

##template variables

integer VLAN_ID {
min = 100;
max= 200;
};

string USER_NAME {
defaultValue = admin123;
minLength = 5;
};

struct interface_a{
string inf_name;
string inf_description;
ipAddress inf_host;
enum duplex {
validValues = auto, full, half;
};
}myInterface;

##

Variable Annotation

You can configure the variable properties marking the variables using annotations.

Variable Annotations are available for POAP only. However, the annotations do not impact on the template
type ‘CLI’.

Note

The following annotations can be used in the template variable section.

Valid ValuesAnnotation Key

TextDataDepend

TextDescription

Text

Enclose the text with quotes, if there is space.Note

DisplayName

“true” or “false”IsAlphaNumeric

“true” or “false”IsDeviceID
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Valid ValuesAnnotation Key

“true” or “false”IsGateway

“true” or “false”IsInternal

“true” or “false”

This annotation must be marked only for
variable “ipAddress”.

Note

IsManagementIP

“true” or “false”IsMandatory

“true” or “false”IsMultiplicity

“true” or “false”IsPositive

TextPassword

“true” or “false”UsePool

TextUsername

Example: Variable Annotation

##template variables
@(DisplayName="Host Name", Description = "Description of the host")
String hostname;
@(DisplayName="Host Address", Description = " test description" IsManagementIP=true)
ipAddress hostAddress;
##

Example: IsMandatory Annotation

##template variables
@(IsMandatory="ipv6!=null")
ipV4Address ipv4;
@(IsMandatory="ipv4!=null")
ipV6Address ipv6;
##

IsShowAnnotation

##template variables
boolean isVlan;
@(IsShow="isVlan==true")
integer vlanNo;
##

Templates Content

This section includes the configuration commands and any parameters that you want to include in the template.
These commands can include the variables declared in the template variables section. During the command
generation process the variable values are substituted appropriately in the template content.
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You must specify the commands that you include as if you were entering them in the global configuration
command mode on any device. You must consider the command mode when you include commands.

Note

Template content is governed by the usage of variables.

• Scalar variables—does not take a range or array of values which cannot be used for iteration (In the
variable types table those marked iterate-able as 'No'). Scalar variables must be defined inside the template
content.

Syntax: $$<variable name>$$
Example: $$USER_NAME$$

• Iterative variables—used for block iteration. These loop variable must be accessed as shown below inside
the iteration block.

Syntax:@<loop variable>
Example:
foreach val in $$INTEGER_RANGE_VALUE$$ {
@val
}

• Scalar Structure Variable—Structure member variables can be accessed inside the template content.

Syntax: $$<structure instance name>.<member variable name>$$
Example: $$myInterface.inf_name$$

• Array Structure Variable—Structure member variables can be accessed inside the template content.

Syntax: $$<structure instance name>.<member variable name>$$
Example: $$myInterface.inf_name$$

In addition to the template variables, you can use the conditional and iterative command generation using the
following statements:

• if-else if-else Statement—makes a logical decision in inclusion/exclusion of set of configuration command
based on the value assigned for the variable in it.

Syntax: if(<operand 1> <logical operator> <operand 2>){
command1 ..
command2..
..
}
else if (<operand 3> <logical operator> <operand 4> )
{
Command3 ..
Command4..
..
}
else
{
Command5 ..
Command6..
..
}
Example: if-else if-else statement
if($$USER_NAME$$ == 'admin'){
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Interface2/10
no shut
}
else {
Interface2/10
shut
}

• foreach Statement—used for iterating a block of commands. The iteration is performed based on the
assigned loop variable value.

Syntax:
foreach <loop index variable> in $$<loop variable>$$ {
@<loop index variable> ..
}
Example: foreach Statement
foreach ports in $$MY_INF_RANGE$${
interface @ports
no shut
}

• Optional parameters—By default all parameters are mandatory. To make a parameter optional, you must
annotate the parameter.

In the variable section, you can include the following command:

• @(IsMandatory=false)

• Integer frequency;

In the template content section, a command can be excluded or included without using “if” condition
check, by assigning a value to the parameter. The optional command can be framed as below:

• probe icmp [frequency frequency-value] [timeout seconds] [retry-count retry-count-value]

Advanced Features

The following are the advanced features available to configure templates.

• Assignment Operation

Config template supports assignment of variable values inside the template content section. The values
are validated for the declared data type of the variable. If there is a mismatch, the value is not assigned.

Assignment operation can be used under the following guidelines:

• The operator on the left must be any of the template parameters or a for loop parameter.

• The operator on the right values can be any of the values from template parameters, for loop
parameters, literal string values surrounded by quotes or simple string values.

If a statement does not follow these guidelines, or if it does not suit this format, it will not be considered
as assignment operation. It is substituted during command generation like other normal lines.

Example: Template with assignment operation
##template properties
name =vlan creation;
userDefined= true;
supportedPlatforms = All;
templateType = CLI;
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published = false;
##
##template variables
integerRange vlan_range;
@(internal=true)
integer vlanName;
##
##template content
foreach vlanID in $$vlan_range$${
vlan @vlanID
$$vlanName$$=@vlanID
name myvlan$$vlanName$$
}
##

• Evaluate methods

Config template uses the Java runtime provided Java script environment to perform arithmetic operations
(such as ADD, SUBTRACT, and so on), string manipulations, and so on.

Locate the javascript file in the template repository path. This file contains primary set of arithmetic,
string functions. You can also add custom Javascript methods.

These methods can be called from config template content section in below format:

Example1:
$$somevar$$ = evalscript(add, "100", $$anothervar$$)

Also the evalscript can be called inside if conditions as below:

if($$range$$ > evalscript(sum, $$vlan_id$$, -10)){
do something...
}

You can call a method that is located at the backend of the Java script file.

• Dynamic decision

Config template provides a special internal variable “LAST_CMD_RESPONSE”. This variable stores
the last command response from the device during the execution of the command. This can be used in
the config template content to make dynamic decisions to deliver the commands that are based on the
device condition.

The if block must be followed by an else block in a new line, which can be empty.Note

An example use case to create a VLAN, if it is does not exist on the device.
Example: Create VLAN
##template content
show vlan id $$vlan_id$$
if($$LAST_CMD_RESPONSE$$ contains "not found"){
vlan $$vlan_id$$
}
else{
}
##

This special implicit variable can be used only in the “IF” blocks.

• Template referencing
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You can have a base template with all the variables defined. This base template can be imported to
multiple templates. The base template content is substituted in the appropriate place of the extending
template. The imported template parameters and the contents can be accessed inside the extending
template.
Example: Template Referencing
Base template:
##template properties
name =a vlan base;
userDefined= true;
supportedPlatforms = All;
templateType = CLI;
published = false;
timestamp = 2015-07-14 16:07:52;
imports = ;
##
##template variables
integer vlan_id;
##
##template content
vlan $$vlan_id$$
##

Derived Template:
##template properties
name =a vlan extended;
userDefined= true;
supportedPlatforms = All;
templateType = CLI;
published = false;
timestamp = 2015-07-14 16:07:52;
imports = a vlan base,template2;
##
##template variables
interface vlanInterface;
##
##template content
<substitute a vlan base>
interface $$vlanInterface$$
<substitute a vlan base>
##

When you launch the extended template, the parameter inputs for the base template are also obtained.
In addition, the substituted content is used for complete CLI command generation.

• Solution POAP Templates for VXLAN and FabricPath

From Cisco DCNM Release 10.0(1), Cisco provides you a set of defined templates to aid in POAP
operations. You can download Cisco-defined templates from
https://software.cisco.com/download/release.html.

For instructions on how to download and install POAP templates, see Cisco DCNM Installation Guide,
Release 10.0(x).

Adding a Template

To add user-defined templates and schedule jobs from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Configure > Templates > Template Library > Templates.

The Templates window is displayed with the name of the template along with its description, supported
platforms, and tags.

Step 2 Click Add to add a new template.
Step 3 Specify a Template Name, Template Description, Tags, Implements, and Dependencies for the new

template. Specify a template name, description, tags, and supported platforms for the new template.
Step 4 Select the supported platforms that the template must support.
Step 5 Specify a Template Type for the template. Select POAP to make this template available when you power

on the application.

The template is considered as a CLI template if POAP is not selected.Note

Step 6 Select a Template Sub Type and Template Content Type for the template. Select Published to make the
template read-only. You cannot edit a published template.

Step 7 Click Template Content to edit the template syntax. For information about the structure of the Configuration
Template, see the Template Structure section.

Step 8 From the Imports > Template Name list, check the template check box.

The base template content is displayed in the Template Content window. The base template displays the
template properties, template variables, and template content. This template can be imported in to another
template and the base template content is substituted in the appropriate place of the extending template. When
you launch the extended template, the parameter inputs for the base template are also obtained. Also, the
substituted content is used for complete CLI command generation.

The base templates are CLI templates.Note

Step 9 Click Validate Template Syntax to validate the template values.

If an error or a warning message appears, you can check the validation details in Validation Table.

You can continue to save the template if there are warnings only. However, if there is an error, you
must edit the templates to fix the errors before you proceed.

Note

Step 10 Click Save to save the template.
Step 11 Click Save and Exit to save the configuration and go back to the configuring templates screen.

Configuring Template Job

To configure and schedule jobs for individual templates from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Configure > Templates > Template Library > Templates.
Step 2 Select a template.
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Config Job wizard is applicable only for CLI templates.Note

Step 3 Click Launch job creation wizard icon and click Next.
Step 4 Use the drop-down to select Device Scope.

The devices that are configured under the selected Device Scope are displayed.

If no devices are displayed, check if the device LAN credentials are configured by choosing
Administration > Credentials Management > LAN Credentials.

Note

Step 5 Use the arrows to move the devices to the right column for job creation and click Next.
Step 6 In the Define Variable section, specify the VSAN_ID, VLAN_ID, ETH_SLOT_NUMBER,

VFC_SLOT_NUMBER, SWITCH_PORT_MODE, ETH_PORT_RANGE and ALLOWED_VLANS values.

Based on the selected template, variables vary.Note

Step 7 In the Edit Variable Per Device section, double click the fields to edit the variables for specific devices and
click Next.

Step 8 If you have selected multiple devices, use the drop-down to select a specific device and preview its
configuration. Click Back to edit the configuration or click Next.

Step 9 Specify a job name and description.

The Device Credentials are populated fromAdministration >CredentialsManagement > LANCredentials.

Step 10 Use the radio button to select Instant Job or Schedule Job.

If you select Schedule Job, specify the date and time for the job delivery.

Step 11 Use the check box to select Copy Run to Start.
Step 12 If you want to configure more transaction and delivery options, use the check box to select Show more

options.
Step 13 Under Transaction Options(Optional), if you have a device with rollback feature support, select Enable

Rollback check box and select the appropriate radio button.

You can choose one of the following options by selecting the appropriate radio button:

• Rollback the configuration on a device if there is any failure on that device

• Rollback the configuration on all the devices if there is any failure on any device

• Rollback the configuration on a device if there is any failure on any device and stop further
configuration delivery to remaining devices

Step 14 Under Delivery Options (Optional), specify the command response timeout in seconds and use the radio
button to select a delivery order. The value of command response timeout ranges from 1 to 180.

You can choose one of the following options by selecting the appropriate radio button:

• Deliver configuration one device at a time in sequential

• Delivery configuration in parallel to all devices at the same time

Step 15 Click Finish to create the job.
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A confirmation message is displayed that the job has been successfully created.

Modifying a Template

You can edit the user-defined templates. However, the predefined templates and templates that are already
published cannot be edited.

Procedure

Step 1 From Configure > Templates > Template Library > Templates, select a template.
Step 2 Click Modify/View template.
Step 3 Edit the template description and tags.

The edited template content is displayed in a pane on the right.

Step 4 From the Imports > Template Name list, check the template check box.

The base template content is displayed in the Template Content window. You can edit the template content
based on your requirement in the Template Content window. Click the help icon next to the Template
Content window for information about editing the content of the template.

Step 5 Edit the supported platforms for the template.
Step 6 Click Validate Template Syntax to validate the template values.
Step 7 Click Save to save the template.
Step 8 Click Save and Exit to save the configuration and go back to the configuring templates screen.

Copying a Template

To copy a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Templates > Template Library > Templates, and select a template.
Step 2 Click Save Template As.
Step 3 Edit the template name, description, tags, and other parameters.

The edited template content is displayed in the right-hand pane.

Step 4 From the Imports > Template Name list, check the template check box.

The base template content is displayed in the Template Content window. You can edit the template content
that is based on your requirement in the Template Content window. Click the help icon next to the Template
Content window for information about editing the content of the template.

Step 5 Edit the supported platforms for the template.
Step 6 Click Validate Template Syntax to validate the template values.
Step 7 Click Save to save the template.
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Step 8 Click Save and Exit to save the configuration and go back to the configuring templates screen.

Deleting a Template

You can delete the user-defined templates. However, you cannot delete the predefined templates. From Cisco
DCNM Release 11.0(1), you can delete multiple templates at once.

To delete a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Templates > Template Library > Templates.
Step 2 Use the check box to select a template and click Remove template icon.

The template is deleted without any warning message.

What to do next

The template is deleted from the list of templates on the DCNM Web UI. When you restart the DCNM services,
the deleted templates are displayed on the Configure > Templates > Template Library > Templates page.

To delete the template permanently, delete the template that is located in your local directory: Cisco
Systems\dcm\dcnm\data\templates\.

Importing a Template

To import a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Templates > Template Library > Templates and click Import Template.
Step 2 Browse and select the template that is saved on your computer.

You can edit the template parameters, if necessary. For information, see Modifying a Template, on page 86.

The “\n” in the template is considered as a new line character when imported and edited, but it works
fine when imported as a ZIP file.

Note

Step 3 Click Validate Template Syntax to validate the template.
Step 4 Click Save to save the template or Save and Exit to save the template and exit.

You can import Cisco-defined FabricPath and IP VXLAN Programmable Fabric POAP Templates
to the Cisco DCNM Web Client. For more information, see Installing POAP Templates, on page
88.

Note
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Exporting a Template

To export a template from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Templates > Template Library > Templates.
Step 2 Use the check box to select a template and click Export Template.

The browser requests you to open or save the template to your directory.

Installing POAP Templates

Cisco DCNM allows you to add, edit, or delete user-defined templates that are configured across different
Cisco Nexus platforms. From Cisco DCNM Release 10.0(x), Cisco-defined FabricPath and IP VXLAN
Programmable Fabric POAP Templates are provided as a separate download on the official Cisco website.
These templates are compatible for use with the DCNM Virtual Appliance (OVA or ISO) for use with Nexus
2000, Nexus 5000, Nexus 6000, Nexus 7000, and Nexus 9000 Series switches.

You can download the Cisco-defined templates from https://software.cisco.com/download/release.html.

Perform the following task to install the POAP templates from the Cisco DCNM.

Procedure

Step 1 Navigate to www.cisco.com/go/dcnm, and download the latest file.

You can choose one of the following:

• dcnm_ip_vxlan_fabric_templates.10.0.1a.zip

• dcnm_fabricpath_fabric_templates.10.0.1a.zip file

Step 2 Unzip and extract the files to the local directory on your computer.
Step 3 Choose Configure > Templates > Template Library > Templates.
Step 4 Click Import Template.
Step 5 Browse and select the template that is saved on your computer. You can edit the template parameters, if

necessary.
Step 6 Check POAP and Publish check box to designate these templates as POAP templates.
Step 7 Click Validate Template Syntax to validate the template.
Step 8 Click Save to save the template or Save and Exit to save the template and exit.

Configuring Jobs
To configure jobs from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Configure > Templates > Templates Library > Jobs.

The jobs are listed along with the Job ID, description and status.

Step 2 Click Show Filter to filter the list.

In the Status column, use the drop-down to select the job status.

Step 3 Select a job and click the Delete icon to delete the job.
Step 4 To view the status of a job, click the Job ID radio button and click Status.
Step 5 To view the command execution status for a device, click the radio button of a device name from the Devices

table in the Job Excecution Status window.

You can delete multiple jobs at once, but you cannot view the status of multiple jobs at once.Note

Backup
The Backup menu includes the following submenus:

Switch Configuration
This feature allows you to backup device configurations from running configuration as a regular text file in
the file system. However, you can also perform operations on startup configuration. The backup files can be
stored in the DCNM server host or on a file server.

You can also configure the archive system to support scheduling of jobs for the selected list of devices. You
can configure only one job for a switch.

The following tables describe the icons and fields that appear onConfigure > Backup > SwitchConfiguration.

Table 15: Switch Configuration Operations

DescriptionIcon

Allows you to copy a configuration file of a switch
to the bootflash of the selected destination switches.

Copy Configuration to bootflash

Allows you to view the configuration file.View Configuration

Allows you to delete the configuration file.Delete Configuration

Allows you to compare two configuration files, from
different devices or on the same device.

Compare Configuration

Allows you to export a configuration file from the
DCNM server.

Export Configuration
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DescriptionIcon

Allows you to import a user-defined configuration
file to the DCNM server.

Import User-Defined Configuration

Allows you to restore configuration from the selected
devices.

Restore Configuration to devices

Allows you to add, delete, view, or modify the jobs.Archive Jobs

Table 16: Switch Configuration Field and Description

DescriptionField

Displays the device name

Click the arrow next to the device to view the
configuration files.

Device Name

Displays the IP address of the device.IP Address

Displays the group of the device.Group

Displays the configuration files that are archived for
that device.

Configuration

Displays the time when the device configuration files
were archived.

The format is Day:Mon:DD:YYYY HH:MM:SS.

Archive Time

Displays the size of the archived file.Size

This section contains the following:

Copy Configuration
You can copy the configuration files to the same device, to another device, or multiple devices concurrently.

Perform the following task to view the status of tasks.

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup > Switch Configuration. Select any
startup/running/archive configuration of the device that you must copy.

Step 2 Click Copy Configuration to bootflash.

CopyConfiguration to bootflash page appears, displaying the Source Configuration Preview and Selected
Devices area.

Source Configuration Preview area shows the contents of running/startup/version configuration file which
is copied to the devices.

Step 3 In the Selected Devices area, check the device name check box to copy the configuration to the device.
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You can select multiple destination devices to copy the configuration.Note

The selected devices area shows the following fields:

• Device Name—Specifies the target device name to which the source configuration is copied.

• IP Address—Specifies the IP Address of the destination device.

• Group—Specifies the group to which the device belongs.

• Status—Specifies the status of the device.

Step 4 Click Copy.

A confirmation window appears.

Step 5 Click Yes to copy the configuration to the destination device configuration.

View Configuration
You can view or edit the configuration file on the device.

Perform the following task to view or edit the configuration file for the devices.

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup > Switch Configuration. Click the arrow next
to the device name to view the configuration files on the device. Select the configuration file radio button to
view the configuration file.

Step 2 Click the View Configuration.

The View Configuration window appears showing the configuration file content.

Delete Configuration
Perform the following task to delete the configuration file from the device.

Ensure that you take a backup of the configuration file before you delete.Note

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup > Switch Configuration. Click the arrow next
to the device name to view the configuration files on the device.

Step 2 Click the configuration file radio button to be deleted.
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You can delete multiple configuration files. However, you cannot delete startup, or running
configuration files.

Note

Step 3 Click Yes to delete the configuration file.

Compare Configuration Files
This feature allows you to compare the configuration file with another version of the same device or with the
configuration file of another device.

Perform the following task to compare the configuration files.

Procedure

Step 1 Navigate to Configure > Backup > Switch Configuration. Click the arrow next to the device name to view
the configuration files on the device.

Step 2 Check the check box and select two configuration files to compare.

The first file that you selected is designated as Source and the second configuration file is designated as the
Target file.

Step 3 Click Compare Configuration.

View Config Diff page appears, displaying the difference between the two configuration files.

The Source and Target configuration files content is displayed in two columns. From the drop-down list in
the right-top corner, choose All to view the entire configuration. You can also choose Changed to view the
configuration differences of the configuration files.

The differences in the configuration file are show in the table, with legends.

• Red: Deleted configuration details.

• Green: New added configuration.

• Blue: Modified configuration details.

Step 4 Click Copy to Target to copy the source configuration to the target configuration file. Click Cancel to revert
to the configuration details page.

The Copy Configuration window displays the source configuration preview and the target device of the
destination configuration. The selected devices area shows the following fields:

• Device Name—Specifies the target device name to which the source configuration is copied.

• IP Address—Specifies the IP Address of the destination device.

• Group—Specifies the group to which the device belongs.

• Status—Specifies the status of the device.

Step 5 Click Yes to copy the configuration to the destination device configuration.
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Export Configuration
You can export a configuration file from the Cisco DCNM server. Perform the following task to export a
configuration file.

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup, select a configuration to export.
Step 2 Click Export Configuration.

The files are downloaded.

Import Configuration File
You can import the configuration file from the file server to the Cisco DCNM.

Perform the following task to import a single or multiple configuration files.

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup > Switch Configuration and click Import
User-Defined Configuration.

The file server directory opens.

Step 2 Browse the directory and select the configuration file that you want to import. Click Open.

A confirmation screen appears.

Step 3 Click Yes to import the selected file.

The imported configuration file appears as a User Imported file.

Restore Configuration
You can restore the configuration file from the selected switches. From Cisco DCNM Release 11.0(1), you
can restore configuration based on the selected date as well.

You cannot restore the configuration for SAN switches and FCoE-enabled switches.Note

Perform the following task to restore the configuration from the selected devices.

Procedure

Step 1 From Cisco DCNM home page, choose Configure > Backup > Switch Configuration, and click Restore.
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Step 2 Select the type of restore from the drop-down list. You can choose Version-based or Date-based.

• If you choose date-based restore, you have to select the date and time. The configuration
available before the mentioned time is restored.

• If you choose version-based restore, you have to choose a configuration from theConfiguration
column. You can view the configuration details in the View column.

Note

Step 3 Check the Device Name check box from which you want to restore the configuration. Click Restore.

The Devices area shows the following fields:

• Device Name—Specifies the device name from which the configuration file is restored.

• IP Address—Specifies the IP Address of the device.

• Group—Specifies the group to which the device belongs.

• Status—Specifies the status of the device.

You can restore the configuration only from the same device. If you select user-imported
configuration files, you can restore configuration for any number of devices.

Note

Archive Jobs
This section contains context-sensitive online help content under Cisco DCNMConfigure > Backup > Switch
Configuration > Archive Jobs.

The following table describes the fields that appear on the Archive Jobs window.

DescriptionField

Specifies the who created this job.User

Specifies the group to which this job belongs.Group

Group Job

Specifies the schedule of the job. Also show the
recurrence information.

Schedule

Specifies the date and time at which this job was last
executed.

Last Execution

Specifies if the job was successful, scheduled, running,
or failure.

Job Status

Running and Scheduled status is not
applicable for existing jobs in an upgraded
Cisco DCNM.

Note
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Archive Jobs

To add, delete or view the job from the Cisco DCNM Web UI, perform the following steps:

You must set the SFTP/TFTP/SCP credentials before you configure jobs. On the DCNM Web Client, navigate
to Administration > DCNM Server > Archive FTP Credentials to set the credentials.

Note

Procedure

Step 1 Choose Configure > Backup > Switch Configuration > Archive Jobs > Archive Jobs tab, and click Add
Job.

The Create Job screen displays the Schedule, Device Selection and Selected Devices.

A backup is scheduled as defined.

a) In the Schedule area, configure the start time, repeat interval and repeat days.

• Start At: Configure the start time using the hour:minutes:second drop-down lists.

• Once: Configure the job to be executed once, on the particular day. The time at which this job
will be executed is determined by the Start At field.

• Now—Configure the job to be executed immediately. Cisco DCNM will consider the default
date and time as configured on the server.

You can schedule a job to run Now even if a job is already scheduled.Note

• Daily: Check the check box on the days you want this job to be executed. The time at which
this job will be executed is determined by the Start At field.

• Real Time: Configure the job to be executed if there is any configuration changes in the device.
The device must be quiet for 5 minutes, after which the DCNM Sever will execute this job.

• Repeat Interval: Check the Repeat Interval check box to repeat the job at scheduled intervals.
Configure the intervals using either days or hours drop-down list.

• Comments: Enter your comments, if any.

b) In the Device Selection area, use the radio button to choose one of the following:

• Device Group: Click the Device Group radio button to select the entire group of devices for this
job.

Select the Device Group from the drop-down list.

When the devices are not licensed, they will not be shown under the group on the Cisco
DCNM Configure > Backup > Switch Configuration > Archive Jobs. When none of
the devices under a group is licensed, the group alone will be shown with no devices, until
a device under that group is licensed.

Note

• Selected Devices: Click the Selected Devices radio button to select one of multiple devices from
various groups for this job.
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Select the devices from the drop-down list.

When the SAN and LAN credentials are not configured for a switch, it will not be listed in the
Selected Devices drop-down list. To configure, navigate to Administration > Credentials
Management > SAN Credentials and Administration > Credentials Management > LAN
Credentials.

Note

c) In the Selected Devices area, the following fields are shown:

• Name: Specifies the name of the device on which the job is scheduled.

• IP Address: Specifies the IP Address of the device.

• Group: Specifies the group to which the device belongs.

• VRF: Specifies the virtual routing and forwarding (VRF) instance.

If a job for a device exists under device level, you can create a group level job which includes
this switch as part of that group. However, this switch will be excluded during the execution of
the job.

Note

d) Click Create to add a new job.

Step 2 To delete a job, from the Cisco DCNM home page, choose Configure > Backup > Switch Configuration
> Archive Jobs > Archive Jobs, and select a job.
a) Click Delete Job.

The Schedule, Device Selection and the Selected devices for this job is displayed.

b) Click Delete.

Step 3 To view the details of the job, from the Cisco DCNM home page, choose Configure > Backup > Switch
Configuration > Archive Jobs > Archive Jobs, and check the job check box.
a) Click View/Modify Job.

The Schedule, Device Selection and the Selected devices for this job is displayed.

b) Modify the required details. Click OK to revert to view the list of jobs.

You cannot modify a job that is scheduled to be run Now to one that is scheduled to be run
Daily.

Note

What to do next

You can also configure the Cisco DCNM to retain the number of archived files per device. Choose
Administration > DCNM Server > Server Properties, and update the archived.versions.limit field.

Job Execution Details

The Cisco DCNM Web Client > Configure > Backup > Switch Configuration > Archive Jobs > Archive
Jobs > Job Execution Details tab shows the following tabs in the Job Execution History table.
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DescriptionField

Displays the system-generated job name.Job Name

Specifies the persona of the person who created the job.User

Specifies fabric or the LAN group under which the job was created.Device Group

Specifies the IP Address of the Device.Device

Specifies the IP Address of the DCNM Server to which the device is associated with.Server

Specifies if the SFTP, TFTP, or SCP protocol is applied.Protocol

Specifies the time at which the job was last executed.Execution time

Specifies the status of the job.

• Skipped

• Failed

• Successful

Status

Specifies the error if the job has failed. The categories are as follows:

• No change in the configuration.

• Switch is not managed by this server.

If the error cause column is empty, it implies that the job was executed
successfully.

Note

Error Cause

Archives
A user with network operator role can view configuration archives for a switch and their details in theArchives
window.

The following tables describe the icons and fields that are displayed in this window.

Table 17: Archive Operations

DescriptionIcon

Allows you to compare two configuration files either
from different devices or on the same device.

Compare

Allows you to viewa configuration file.View
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Table 18: Archive Field and Description

DescriptionField Name

Displays the device name

Click on the arrow next to the device to view the
configuration files.

Device Name

Displays the IP address of the device.IP Address

Displays the group of the device.Group

Displays the configuration files that are archived for
that device.

Configuration

Displays the time at which the device configuration
files were archived.

The format is Day:Mon:DD:YYYY HH:MM:SS.

Archive Time

Displays the size of the archived file.Size

This section contains the following:

Compare Configuration Files
You can compare one version of a configuration file with another version of the same configuration file in
the same device, or the configuration files of two different devices.

To compare the configuration files from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Backup > Archives.
Step 2 In the Archives area, click the arrow that is adjacent the name of the device whose configuration files you

want to view. The list of configuration files is displayed.
Step 3 Check the check box next to configuration files and select two configuration files to compare.

The first file that you select is designated as the source and the second configuration file is designated as the
target file.

Step 4 Click Compare.

The View Config Diff page displays the difference between the two configuration files.

The Source and Target configuration files content are displayed in two columns. ChooseAll from the drop-down
list in the right-top corner to view the entire configuration. Choose Changed to view the configuration
differences between the configuration files.

The differences in the configuration files are shown in a table, with legends.

Red—Deleted configuration details.

Green—Newly added configuration.
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Blue—Modified configuration details.

View Configuration
You can view an archived configuration file.

To view or edit the configuration file for the devices from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Configure > Backup > Archives.

The Archives window is displayed.

Step 2 Click the arrow that is next to the name of the device whose configuration files you want to view.

The list of configuration files are displayed.

Step 3 Select the radio button that is next to the corresponding file you want to view.
Step 4 Click the View configuration icon.

The View configuration window appears showing the configuration file content in the right column.

Network Config Audit
Cisco DCNM provides auditing for the configuration changes across the network switches. The Network
Audit Reporting feature enables you to a generate audit report so that you can track the added, deleted, or
modified configurations. You will be able to generate the network audit reports only when you have existing
archival jobs. Using the generated reports, you can view the config differences on a device for a specified
period.

This section contains the following:

Generating Network Config Audit Reports
To generate the network config audit reports from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Backup > Network Config Audit.

The Network Audit Report window is displayed.

Step 2 In the Devices drop-down list, choose the devices to generate a report.
Step 3 Specify the Start Date and the End Date.
Step 4 Click Generate Report to view the configuration differences. The configuration differences are color-coded.
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• Red: Deleted Configuration
• Green: Newly Added Configuration
• Blue: Changed configuration
• Strikethrough: Old configuration

After you generate a report, you can export the configuration reports into an HTML file.

Creating a Network Config Audit Report

To create a network config audit job and view the configuration differences between the devices from the
Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Report > Generate.

The left pane shows various reports that you can create.

Step 2 Choose Common > Network Config Audit.
Step 3 In the Report Name field, enter the name of the report.
Step 4 In the Repeat field, choose the appropriate repeat interval, that is, Daily, Weekly, or Monthly.

Daily job generates a report of configuration differences for all the selected devices for last 1 day. Weekly
job generates a report for the last 7 days, and the monthly job generates a report for the last 30 days.

Step 5 In the Start and End date fields, specify the start and end date for the report.
Step 6 In the Email Report field, specify the email delivery options.

• No: Select this option if you do not want to send the report through email.
• Link Only: Select this option if you want to send the link to the report.
• Contents: Select this option if you want to send the report content.

If you select Link Only or the Contents option, enter the email address and subject in the To and Subject
fields.

Monitoring Network Config Audit Report

To monitor the network config audit report from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Report > View.
Step 2 Choose Common > Network Config Audit in the left pane to the network config audit reports.
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Deleting a Network Config Audit Report

To delete a network config audit report from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Report > View.
Step 2 Choose Common > Network Config Audit.

The View Reports window is displayed with the reports that you have created.

Step 3 Select the reports that you want to delete, and click the Delete icon.

Image Management
The Image Management menu includes the following options:

Upgrade [ISSU]
The Upgrade [ISSU] menu includes the following submenus:

Upgrade History [ISSU]
This feature enables you to upgrade the Cisco Nexus Platform Switches using In-Service Software Upgrade
(ISSU). This upgrade procedure may be disruptive or non-disruptive based on the device configuration. You
can select the Kickstart, System, or SSI images required for the upgrade from a remote server using SFTP,
SCP, TFTP, FTP or from image repository or the file system on the device. Image repository can use SCP,
SFTP, FTP, or TFTP as file transfer protocol. To select the images from the repository, the same needs to be
uploaded from Configure > Image Management > Repositories tab.

The following table describes the fields that appear on Configure > ImageManagement > Upgrade [ISSU]
> Upgrade History.

DescriptionField

Specifies the serial number of the task. The latest task will be
listed in the top.

If Failover is triggered in Native HA, the Task Id
sequence number is incremented by 32.

Note

Task Id

Specifies the type of task.

• Compatibility

• Upgrade

Task Type

Based on the Role-Based Authentication Control (RBAC),
specifies the owner who initiated this task.

Owner

Displays all the devices that were selected for this task.Devices
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DescriptionField

Specifies the status of the job.

• Planned

• In Progress

• Completed

• Completed with Exceptions

Job Status

Specifies the time when the task was created.Created Time

Specifies the time when the task is specified to be executed.
You can also choose to schedule a task to be executed at a
later time.

Scheduled At

Shows any comments that the Owner has added while
performing the task.

Comment

After a fresh Cisco DCNM installation, this page will have no entries.Note

You can perform the following:

New Installation

To upgrade the devices that are discovered from the Cisco DCNM, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Upgrade [ISSU] > Upgrade History, click New Installation
to install, or upgrade the kickstart and the system images on the devices.

The devices with default VDCs are displayed in the Select Switches window.

Step 2 Select the check box to the left of the switch name.

You can select more than one device and move the devices to the right column.

Step 3 Click Add or Remove icons to include the appropriate switches for upgrade.

The selected switches appear in a column on the right.

Step 4 Click Next to navigate to the Specify Software Images window. This tab displays the switches that you
selected in the previous screen and allows you to choose the images for upgrade.

• The Auto File Selection check box enables you to specify a file server, an image version, and a path
where you can apply the upgraded image to the selected devices.

• In the Select File Server drop-down list, select the one of the file servers that is created in the Cisco
DCNM repositories.
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• In the Image Version field, specify the image version. For example, enter 7.3.9.D1.1 in the Image
Version field if you have selected m9700-sf3ek9-kickstart-mz.7.3.0.D1.1.bin as the image version.

• In the Path field, specify the image path. Specify an absolute path if you choose SCP or SFTP. For
example, //root/images/. Specify a relative path to the FTP or TFTP home directory if you choose
FTP or TFTP. Specify the absolute path of the image if you are using TFTP server that is provided by
Cisco DCNM, local DCNM TFTP. You cannot use the same DCNM TFTP server for creating another
job when the current job is in progress.

Step 5 Click Select Image in the Kickstart image column.

The Software Image Browser dialog box appears.

• Cisco Nexus 3000 Series and 9000 Series Switches require only the system image to load the
Cisco NX-OS operating system. Therefore, the option to select kickstart images for these
devices is disabled.

• If there is an issue in viewing the Software Image Browser dialog box, reduce the font size
of your browser and retry.

Note

Step 6 Click Select Image in the System Image column.

The Software Image Browser dialog box appears.

Step 7 On the Software Image Browser dialog box, you can choose the kickstart image from File Server or Switch
File System.

If you choose File Server:

a) From the Select the File server list, choose the appropriate file server on which the kickstart image is
stored.

The servers at Configure > Image Management > Repositories are displayed in the drop-down list.

b) From the Select Image list, choose the appropriate kickstart image. Check the check box to use the same
image for all other selected devices of the same platform.

Example: For platform types N7K-C7009 and N7K-C7010, logic matches platform (N7K) and three
characters (C70) from subplatform. The same logic is used across all platform switches.

c) Click OK to choose the kickstart image or Cancel to revert to the Specify Software Images window.

If the file server selected is either ftp or tftp, in the text box, enter the relative path of the file from
the home directory.

If you choose Switch File System:

a) From the Select Image list, choose the appropriate image that is located on the flash memory of the device.
b) Click OK to choose the kickstart image or Cancel to revert to the Specify Software Images dialog box.

Step 8 The Vrf column indicates the name of the virtual routing and forwarding (VRF).

VRF is not applicable for Cisco MDS devices.

Step 9 In the Available Space column, specify the available space for the Primary Supervisor and Secondary
Supervisor modules of the switch.

Available Space column shows the available memory in MB on the switch (for less than 1 MB, it is shown
and marked as KB).
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Bootflash browser shows the filename, size, and last modified date for all the files and directories on the
switch bootflash. You can delete files by selecting them and clicking Delete to increase the available space
on the switch.

Step 10 Selected Files Size column shows the size of images that are selected from the SCP or SFTP server.

If the total size of selected images is greater than available space on a switch, the file size is marked in red.
We recommend that you create more space on the switch to copy images to it and install.

Step 11 Drag and drop the switches to reorder the upgrade task sequence.
Step 12 Select Skip Version Compatibility if you are sure that the version of the Cisco NX-OS software on your

device is compatible with the upgraded images that you have selected.
Step 13 Select Select Parallel Line Card upgrade to upgrade all the line cards at the same time.

Upgrading a parallel line card is not applicable for Cisco MDS devices.

Step 14 Select Options under the Upgrade Options column to choose the type of upgrade.

Upgrade Options window appears with two upgrade options. The drop-down list for Upgrade Option 1 has
the following options:

• NA

• bios-force

• non-disruptive

NA is the default value.

The drop-down list for Upgrade Option 2 has the following options:

• NA

• bios-force

When NA is selected under Upgrade Option 1, Upgrade Option 2 is disabled.

When bios-force is selected under Upgrade Option 1, NA is the only option under Upgrade Option 2

When non-disruptive is selected underUpgradeOption 1, you can chooseNA or bios-force underUpgrade
Option 2.

Check the Use this Option for all other selected devices check box to use the selected option for all the
selected devices and click OK.

• The upgrade options are applicable only for Cisco Nexus 3000 Series and 9000 Series switches.

• Selecting the non-disruptive option for upgrading does not ensure a non-disruptive upgrade.
Perform a compatibility check to ensure that the device supports non-disruptive upgrade.

Note

Step 15 Click Next.

If you did not select Skip Version Compatibility, the Cisco DCNM performs a compatibility check.

You can choose to wait until the check is complete or click Finish Installation Later.

The installation wizard is closed and a compatibility task is created in Configure > Image Management >
Upgrade [ISSU] > Upgrade History tasks.
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The time that is taken to check the image compatibility depends on the configuration and the load on the
device.

The Version Compatibility Verification status column displays the status of verification.

If you skip the version compatibility check by choosing Skip Version Compatibility, Cisco DCNM displays
only the name of the device, theCurrent Action column displaysCompleted, and theVersion Compatibility
Verification column displays Skipped.

Step 16 Click Finish Installation Later to perform the upgrade later.
Step 17 Click Next.
Step 18 Check the Next check box to put a device in maintenance mode before upgrade.
Step 19 Check the check box to save the running configuration to the startup configuration before upgrading the

device.
Step 20 You can schedule the upgrade process to occur immediately or later.

1. Select Deploy Now to upgrade the device immediately.

2. Select Choose time to Deploy and specify the time in MMM/DD/YYYY HH:MM:SS format to perform
the upgrade later.

This value is relative to the server time. If the selected time to deploy is in the past, the job is executed
immediately.

Step 21 You can choose the execution mode based on the devices and the line cards you have chosen to upgrade.

1. Select Sequential to upgrade the devices in the order in which they were chosen.

2. Select Concurrent to upgrade all the devices at the same time.

Step 22 Click Finish to begin the upgrade process.

The Installation wizard closes and a task to Upgrade is created on the Configure > Image Management >
Upgrade [ISSU] > Upgrade History page.

Finish Installation

You can choose to complete the installation for tasks which was completed on the Compatibility Check
page. Perform the following task to complete the upgrade process on the devices.

Procedure

Step 1 Choose Configure > Image Management > Upgrade [ISSU] > Upgrade History, select a task for which
the compatibility check is complete.

Select only one task at a time.

Step 2 Click Finish Installation.

Software Installation Wizard appears.
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Step 3 Check the check box to save the running configuration to the startup configuration before upgrading the
device.

Step 4 Check the check box to put a device in maintenance mode before upgrade. This option is valid only for the
devices that support maintenance mode.

Step 5 You can schedule the upgrade process to occur immediately or later.

1. Select Deploy Now to upgrade the device immediately.

2. Select Choose time to Deploy and specify the time in DD/MM/YYYY HH:MM:SS format to perform
the upgrade later.

Step 6 You can choose the execution mode that is based on the devices and the line cards that you have chosen to
upgrade.

1. Select Sequential to upgrade the devices in the order in which they were chosen.

2. Select Concurrent to upgrade the devices at the same time.

Step 7 Click Finish to complete the upgrade process.

View

To view the image upgrade history from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Upgrade [ISSU] > Upgrade History, check the task ID check
box.

Select only one task at a time.

Step 2 Click View.

The Installation Task Details window is displayed.

Step 3 Click Settings. Select Columns and choose the column details options.

This window displays the location of the kickstart and system images, compatibility check status, installation
status, descriptions, and logs.

Step 4 Select the device.

The detailed status of the task is displayed. For the completed tasks, the response from the device is displayed.

If the upgrade task is in progress, a live log of the installation process appears.

This table is refreshed every 30 secs for jobs in progress, when you are on this window.

The switch-level status for an ongoing upgrade on a Cisco MDS switch is not displayed for other
users without SAN credentials applied. To apply SAN Credentials, choose Administration >
Credentials Management > SAN Credentials.

Note
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Delete

To delete a task from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Upgrade [ISSU] > Upgrade History, and check the Task ID
check box.

Step 2 Click Delete.
Step 3 Click OK to confirm deletion of the job.

Switch Level History
You can view the history of the upgrade process at a switch level. You can view the current version of the
switch and other details.

The following table describes the fields that appear on Configure > ImageManagement > Upgrade [ISSU]
> Switch Level History.

DescriptionField

Specifies the name of the switchSwitch Name

Specifies the IP Address of the switchIP Address

Specifies the Cisco Nexus switch platformPlatform

Specifies the current version on the switch softwareCurrent Version

Click the radio button next to a switch name to select the switch and view its upgrade history. Click View to
view the upgrade task history for the selected switch.

The following table describes the fields that appear on Configure > ImageManagement > Upgrade [ISSU]
> Switch Level History > View Device Upgrade Tasks:

DescriptionField

Specifies the owner who initiated the upgrade.Owner

Specifies the status of the job.

• Planned

• In Progress

• Completed

Job Status

Specifies the kickStart image that is used to upgrade
the Switch.

KickStart Image

Specifies the system image that is used to upgrade the
switch.

System Image
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DescriptionField

Specifies the date and time at which the upgrade was
successfully completed.

Completed Time

Specifies the installation log information of the job.Status Description

Patch [SMU]
The Patch [SMU] menu includes the following submenus:

Installation History
This feature allows you to activate or deactivate packages using Software Maintenance Update (SMU).
Personnel with Admin privileges can perform this operation.

The following table describes the fields that appear on Configure > Image Management > Patch [SMU] >
Installation History.

DescriptionField

Specifies the serial number of the task. The latest task
is listed at the top.

The tasks are performed in the sequential order.

Task Id

Specifies the name of the switch for which the patch
file is installed.

Switch Name

Specifies the IP Address of the device.IP Address

Specifies if the patch is installed or uninstalled on this
device.

Task

Specifies the name of the patch file.Package

Specifies the status of installation or uninstallation of
the patch files.

Status

Describes the status of installation or uninstallation
of the patch files.

Status Description

This section contains the following:

Install Patch

To install the patch on your devices from Cisco DCNM Web Client, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Patch [SMU] > Installation History, click Install.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
108

Configure
Patch [SMU]



The Select Switches window appears. All the Cisco Nexus switches that are discovered by Cisco DCNM are
displayed.

Step 2 Select the check box to the left of a switch name.

You can select more than one device.

Step 3 Click Add or Remove icons to include the appropriate switches for installing the patch.

The selected switches appear in the right column.

Step 4 Click Next.
Step 5 Click Select Packages in the Packages column.

The SMU Package Browser dialog box appears.

Step 6 In the SMU Package Browser dialog box, you can choose the patch file from File Server or Switch File
System.

If you choose File Server:

a) From the Select the file server list, choose the appropriate file server on which the patch is stored.

The servers, which are listed in the Repositories window, are displayed in the drop-down list. Choose
Configure > Image Management > Repositories to view the Repositories window.

b) From the Select Image list, choose the appropriate patch that must be installed on the device.

You can select more than one patch file to be installed on the device.

If the patch installation results in the restart of the device, select only one patch file.Note

Check the check box to use the same patch for all other selected devices of the same platform.

c) From the Select Vrf list, choose the appropriate virtual routing and forwarding (VRF).

The two options in the drop-down list are management and default.

Check the check box to use the same VRF for all other selected devices.

d) Click OK to choose the patch image or Cancel to revert to the SMU installation wizard.

If you choose Switch File System:

a) From the Select Image list, choose the appropriate patch file image that is located on the flash memory
of the device.

You can select more than one patch file to be installed on the device.

b) Click OK to choose the image, Clear Selections to uncheck all the check boxes, or Cancel to revert to
the SMU Package Browser dialog box.

Step 7 Click Finish.

You will get a confirmation window. Click OK.

SMU installation may reload the switch if the SMU is reloaded.Note

You can view the list of patches that are installed on the switch in the Switches window by choosing DCNM
> Inventory > Switches.
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Uninstall Patch

To uninstall the patch on your devices from Cisco DCNM Web Client, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Patch [SMU] > Installation History, click Uninstall.

The Select Switches page appears. The discovered Cisco Nexus switches are displayed.

Step 2 Check the check box on the left of the switch name.

You can select more than one image device.

Step 3 Click Add or Remove icons to include the appropriate switches for installing the patch.

The selected switches appear in a column on the right.

Step 4 Click Next.

The Active Packages page appears.

Step 5 Click Select Packages under the Installed Packages column.

The Packages Installed window appears, which lists the patches that are applied to the switch.

Step 6 Select the patches that you want to uninstall from this device.

You can select more than one patch that is applied on the device.

If the patch uninstallation results in the restart of the device, select only one patch.Note

Step 7 Click Finish to uninstall the patch from the device.

You will get a confirmation window. Click OK.

You can uninstall more than one patch at a time.

SMU uninstallation may reload the switch if the SMU is reloaded.Note

Delete Patch Installation Tasks

To delete the patch installation tasks from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Patch [SMU] > Installation History, check the task ID check
box.

Step 2 Click Delete.
Step 3 Click OK to confirm deletion of the patch installation task.
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Switch Installed Patches
You can view the patches that are installed on all the switches in the network. You can refresh the view to
see the latest installed patches.

The following table describes the fields that appear on Configure > Image Management > Patch [SMU] >
Switch Installed Patches.

DescriptionField

Specifies the name of the switch.Switch Name

Specifies the IP address of the switch.IP Address

Specifies the Cisco Nexus switch platform.Platform

Specifies the currently installed patches on switches.Installed Patches

Click Refresh to refresh the table.

Package [RPM]
The Package [RPM] menu includes the following submenus:

Package Installation [RPM]
The package [RPM] feature allows you to install RPM packages. This feature is available for the Cisco Nexus
9000 Series and 3000 Series Switches.

The following table describes the fields that appear on Configure > Image Management > Package [RPM]
> Installation History.

DescriptionField

Specifies the serial number of the task. The latest task
is listed in the top.

The tasks are performed in the sequential order.

Task Id

Specifies the name of the switch for which the
package file is installed.

Switch Name

Specifies the IP address of the device.IPAddress

Specifies if the package is installed or uninstalled on
this device.

Task

Specifies the name of the package file.Package

Specifies the status of installation or uninstallation of
the package files.

Status

Specifies the time at which the installation or
uninstallation task completed.

Completed Time

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
111

Configure
Switch Installed Patches



DescriptionField

Describes the status of installation or uninstallation
of the package files.

Status Description

This section contains the following:

Install Package [RPM]

Perform the following task to install the package on your devices using Cisco DCNM Web client.

Procedure

Step 1 Choose Configure > Image Management > Package [RPM] > Installation History, click Install.

The Select Switches page appears.

Step 2 Check the check box on the left of the switch name.

You can select more than one device.

Step 3 Click Add or Remove to include appropriate switches for installing packaging.

The selected switches appear in a column on the right.

Step 4 Click Next.
Step 5 Click Select Packages in the Packages column.

The RPM Package Browser screen appears.

Step 6 Choose the package file from File Server or Switch File System.

If you choose File Server:

a) From the Select the file server list, choose the appropriate file server on which the package is stored.

The servers at Configure > Image Management > Repositories are displayed in the drop-down list.

b) From the Select Image list, choose the appropriate package that must be installed on the device.

You can select only one package file to be installed on the device.

Check the check box to use the same package for all other selected devices of the same platform.

c) Click OK to choose the patch image or Cancel to revert to the RPM Installation Wizard.

If you choose Switch File System:

a) From the Select Image list, choose the appropriate package file image that is located on the flash memory
of the device.

You can select only one package file to be installed on the device.

b) Click OK.

Step 7 In the Installation Type column, choose one of the installation types:

• Normal—Fresh installation
• Upgrade—Upgrading the existing RPM
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• Downgrade—Downgrading the existing RPM

Step 8 Click Finish.

You can view the list of packages that are installed on the switch, on the Web Client > Inventory > Switches
page.

If you are using Cisco DCNM Release 10.1(2), in case of installation of reload RPMs, perform a
manual install commit on the switch after it switch reloads.

Note

Uninstall Package [RPM]

To uninstall the RPM on your devices from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Configure > Image Management > Package [RPM] > Installation History, click Uninstall.

The Select Switches window appears.

Step 2 Check the check box on the left of the switch name.

You can select more than one switch.

Step 3 Click the Add or Remove icons to include the appropriate switches for uninstalling the package.

The selected switches appear in a column on the right.

Step 4 Click Next.

The Active Packages page appears.

Step 5 Click Select Packages under the Installed Packages column.

The Packages Installed window appears, which lists the packages that are installed in the switch.

Step 6 Click Finish to uninstall the package from the device.

You will get a confirmation window. Click OK.

You can uninstall more than one package at a time.

• If you are using Cisco DCNM Release 10.1(2), in case of uninstallation of reload RPMs, a
manual install commit needs to be performed on the switch once the switch is reloaded.

• RPM uninstallation may reload the switch if the RPM is reload RPM.

Note

Delete Package Installation Tasks

To delete the package installation tasks from the history view from the Cisco DCNM Web UI, perform the
following steps:
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Procedure

Step 1 Choose Configure > Image Management > Package [RPM] > Installation History, select the task ID
check box.

Step 2 Click Delete.
Step 3 Click OK to confirm deletion of the task.

Switch Installed Packages
You can view the RPM packages that are installed on all Switches in the network. You can refresh the view
to see the latest installed packages.

The following table describes the fields that appear onConfigure > ImageManagement > Packages [RPM]
> Switch Installed Packages.

DescriptionField

Specifies the name of the switch.Switch Name

Specifies the IP address of the switch.IP Address

Specifies the Cisco Nexus switch platform.Platform

Specifies the currently installed packages on the
switches. If there are multiple RPM packages that are
installed on the switch, the names of the packages are
separated by commas.

Installed Packages

Click Refresh to refresh the table.

Maintenance Mode [GIR]
The Maintenance Mode [GIR] menu includes the following submenus:

Maintenance Mode
The maintenance mode allows you to isolate the Cisco Nexus Switch from the network to perform an upgrade
or debug, using Graceful Insertion and Removal (GIR). When the switch maintenance is complete, you can
return the switch to normal mode. When the switch is in the maintenance mode, all protocols are gracefully
brought down and all physical ports are shut down. When the normal mode is restored, all the protocols and
ports are initiated again.

Perform the following to change the system mode of the devices.

Procedure

Step 1 Choose Configure > Image Management > Maintenance Mode [GIR] > Maintenance Mode, check the
switch name check box.
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You can select multiple switches.

Step 2 Choose one of the following options under the Mode Selection column:

• Shutdown

• Isolate

Click the appropriate option before you change the mode.Note

Step 3 Click Change System Mode.

A confirmation message appears.

Step 4 Click OK to confirm to change the maintenance mode of the device.

The status of operation can be viewed in the System Mode and the Maintenance Status.

Switch Maintenance History
You can view the history of the maintenance mode changes executed from the Cisco DCNM.

The following table describes the fields that appear on Configure > Image Management > Maintenance
Mode [GIR] > Switch Maintenance History.

DescriptionField

Specifies the serial number of the task. The latest tasks
that are listed in the top.

Task Id

Specifies the name of the switch for which the
maintenance mode was changed.

Switch Name

Specifies the IP address of the switch.IP Address

Specifies the name of the user who initiated the
maintenance.

User

Specifies the mode of the system.System Mode

Specifies the mode of the maintenance process.Maintenance Status

Specifies the status of the mode change.Status

Specified the time at which the maintenance mode
activity was completed.

Completed Time

Click the radio button next to the switch name to select the switch for which you need to view the upgrade
history. Click View to view the upgrade task history for the selected switch.

The following table describes the fields that appear on Configure > ImageManagement > Upgrade [ISSU]
> Switch Level History > View > Upgrade Tasks History
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DescriptionField

Specifies the owner who initiated the upgrade.Owner

Specifies the status of the job.

• Planned

• In Progress

• Completed

Job Status

Specifies the kickstart image that is used to upgrade
the Switch.

KickStart Image

Specifies the system image that is used to upgrade the
switch.

System Image

Specifies the date and time at which the upgrade was
successfully completed.

Completed Time

Repositories
This feature allows you to add image servers and configuration servers information to fetch images for Upgrade,
Patch, and POAP mode operations.

You can specify valid servers for SCP/SFTP/FTP/TFTP. DCNM does not perform the validation for
SCP/SFTP/FTP/TFTP servers while creating or updating the servers. DCNM performs validation only for
the SCP servers.

The SCP repositories use SSH protocol for the directory listing and therefore you need to enable SSH on the
SCP repository server. The SFTP repository uses SFTP protocol for directory listing. The TFTP and FTP
repositories do not support directory listing. You need to specify the file path manually.

Note

Add Image or Configuration Server URL
To add an image or a configuration server URL to the repository from the Cisco DCNM Web UI, perform
the following steps:

Procedure

Step 1 On the Image and Configuration Servers window, click the Add icon.

The Add Image or Configuration Server URL window is displayed.

Step 2 Specify a name for the image.
Step 3 Click the radio button to select the protocol.

The available protocols are SCP, FTP, SFTP, and TFTP. Use the SCP protocol for POAP and Image
Management.
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You can use IPv4 and IPv6 addresses with these protocols.

Step 4 Enter the hostname or IP address and the path to download or upload files.
Step 5 Specify the username and password.
Step 6 Click OK to save.

Deleting an Image or Configuration Server URL
To delete an image from the repository from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 On the Image and Configuration Servers window, select an existing image from the list, and click Delete.
Step 2 In the delete notification, click Yes to delete the image and configuration server.

The default SCP Repository cannot be deleted.Note

Editing an Image or Configuration Server URL
To edit an image or a configuration server URL to the repository from the Cisco DCNM Web UI, perform
the following steps:

Procedure

Step 1 On the Image and Configuration Servers window, select an existing image and configuration server from
the list, and click Edit.

Step 2 In the Edit Image or Configuration Server URL window, edit the required fields.
Step 3 Click OK to save or click Cancel to discard the changes.

File Browser
You can view the contents of the server on the Image and Configuration Servers page.

1. In the Image and Configurations page, check the Server Name check box to view the content.

2. Click File Browser to view the contents of this server.

Image Upload
To upload different types of images to the server from the Cisco DCNM Web UI, perform the following steps:
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Devices use these images during POAP.Note

Procedure

Step 1 On the Image and Configuration Servers window, check the server name check box to select the server for
uploading images.

The Select Image File window appears.

Step 2 Click Browse to select the image file from the directory.
Step 3 From the Platform drop-down list, select the device to which you must upload this image.
Step 4 From the Type drop-down list, select the type of the image you are uploading to the device.
Step 5 Click OK.

The image is uploaded to the repository.
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C H A P T E R 6
Media Controller

• Topology, on page 119
• Host, on page 120
• Flow, on page 132
• Global, on page 146
• Config, on page 147

Topology
You can view the Media Controller topology on the Web UI > Media Controller > Topology page. This
topology is specific to the operations performed by DCNM as a Media Controller.

If you remove a device from the Inventory, the Policy deployment status for that switch is removed. However,
you must clear the policy configuration on the switch also.

Note

Quick Search

Enter the search string to highlight relevant devices.

The following fields are available to search on: switch or hostname, switch or host IP address, switch
MAC, and switch serial number.

Multicast Group

Right-click (or press Return Key) in the field. A list of Multicast Addresses are displayed. You can choose
the multicast IP address for which you need to view the topology.

The devices under this multicast IP address, and links to spine and leaf are highlighted. The dotted moving
lines depict the flow of traffic in the Media Controller topology.

You can search or filter based on flow alias name in the Topology. When you search for Multicast Group,
you can search using the IP address or flow alias name.
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Host
The Host menu includes the following submenus:

Discovered Host
You can view all the hosts that are populated through telemetry on this screen. After the switches are discovered,
all the switches in the fabric will push data to the DCNM server at regular intervals using telemetry. Cisco
DCNM server displays the received Events and Flow statistics for each active flow.

The following table describes the fields that appear on this page. Click the table header to sort the entries in
alphabetical order of that parameter.

Table 19: Discovered Host Table Fields and Description

DescriptionField

Specifies the configured Host Alias for the host IP
address.

The Host IP is displayed if the Host Alias is not
configured.

Host Name

Specifies the role of the host device. The role of the
host can be one of the following:

• Sender

• External Sender

• Dynamic Receiver

• External Receiver

• Static Receiver

Role

Specifies the multicast address of the flow in which
the host participates.

Multicast Group

Specifies the source of the flow which the discovered
host participates in.

Source

Specifies the name of the switch.Switch

Specifies the interface to which host is connected on
the sender or receiver leaf.

Interface

Specifies the MAC address of a physical host, if the
switch has ARP entry for that host).

MAC Address

Specifies the date and time at which the switch
discovered the host.

Host Discovered Time
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DescriptionField

Specifies the failure reason for the flow that the
discovered host has participates in.

Fault Reason

Host Alias
Cisco DCNM allows you to create host aliases for Media Controller sender and receiver hosts. The active
multicast traffic transmitting and receiving devices are termed as hosts. Beginning with Cisco DCNM Release
11.0(1), you can add a host-alias name to your sender and receiver hosts, to help you to identify the hosts by
a name. You can also import a large number of Host Alias to Cisco DCNM Media Controller.

The following table describes the fields that appear on this page.

Table 20: Host Alias Table Field and Description

DescriptionField

Specifies the host name that is configured to identify
the host.

Host Alias

Specifies the IP address of the host connecting to the
switch, which you want to refer with an alias name.

IP Address

Specifies the date and time at which the host alias was
last updated.

Last Updated At

This section contains the following:

Add Host Alias
Perform the following task to add new host aliases to devices in the fabric discovered by Cisco DCNM.

Procedure

Step 1 Choose Media Controller > Host > Host Alias, click Add.
Step 2 In the Add/Edit Host Alias window, enter the following:

• Host Name─Enter a fully qualified unified hostname for the identification.

• IP Address─Enter the IP address of the host that is the part of a flow.

You can also create host alias before a host sends any data to its directly connected sender or
receiver leaf .

Note

Step 3 Click Save to apply the changes.

Click Cancel to discard the host alias.

The new host alias is shown in the table on the Host Alias window.
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Edit Host Alias
Perform the following task to edit the host alias.

Procedure

Step 1 Choose Media Controller > Host > Host Alias, select the check box next to the Host Alias that you need to
modify.

Step 2 In the Add/Edit Host Alias window, enter the following:

• Host Name─Enter a fully qualified unified hostname for the identification.

• IP Address─Enter the IP address of the host that is the part of a flow.

Step 3 Click Save to apply the changes.

Click Cancel to discard the host alias.

The modified host alias is shown in the table on the Host Alias window.

Delete Host Alias
Perform the following task to delete the host alias.

Procedure

Step 1 Choose Media Controller > Host > Host Alias, select the check box next to the Host Alias that you want to
delete.

You can select multiple Host Alias entries to be deleted at the same instance.

Step 2 Click Delete.
Step 3 On the confirmation window, click OK to delete the Host Alias.

Click Cancel to retain the host alias.

Import Host Alias
Perform the following task to import host aliases for devices in the fabric.

Procedure

Step 1 Choose Media Controller > Host > Host Alias, click Import icon.
Step 2 Browse the directory and select the CSV file, which contains the Host IP address and corresponding unique

hostname information.
Step 3 Click Open.
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The host aliases are imported and displayed on the Host Alias table.

Export Host Alias
Perform the following task to export host aliases for devices in the fabric.

Procedure

Step 1 Choose Media Controller > Host > Host Alias, click Export icon.

A notification window appears.

Step 2 Select a location on your local system directory to store the Host Aliases configuration from DCNM and click
OK.

The host alias configuration file is exported to your local directory. The filename is appended with the date
and time at which the file was exported. The format of the exported file is .csv.

Host Policies
You can add policies to the host devices. Navigate to Media Controller > Host > Host Policies to configure
the host policies.

Switches must be deployed with default host policies. You can edit the default host policies to permit or deny.
From the Deployment drop-down list, select Deploy Selected Policies to deploy the default policies to the
switches.You can also deploy all the default policies to all the managed switches by selecting Deploy All
Default Policies even without selecting any default policies.

Note

By default, the sequence numbers for policies are auto-generated by DCNM and Multicast mask/prefix is
taken as /32. The server property pmn.hostpolicy.multicast-ranges.enabled underAdministration >DCNM
Server > Server Properties must be set to 'true' for the user to be able to provide sequence numbers and
multicast mask/prefix. When the server property is set to True, the fields to enter the sequence number and
the multicast mask/prefix is available in the Media Controller > Host > Host Policies > Add and Media
Controller > Host > Host Policies > Edit pages.

The default host policies must be deployed successfully to the switch before you deploy the custom host
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you add, edit, import, or deploy custom policies.

The following table describes the fields that appear on this page.

Table 21: Host Policies Operations

DescriptionField

Allows you to add a new host policy.Add
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DescriptionField

Allows you to view or edit the selected host policy parameters.Edit

Allows you to delete the user-defined host policy.

Note • Undeploy policies from all switches before deleting
them from DCNM.

• You can undeploy the default policy, but you cannot
delete the default policy. You can delete and
undeploy only the custom policies.

• When you undeploy the default policies, All Default
Policies will be reset to have default permission
(Allow).

Delete

Allows you to delete all custom policies without selecting any policy
check box.

Note • Undeploy policies from all switches before deleting
them from DCNM.

• You can undeploy the default policy, but you cannot
delete the default policy. You can delete and
undeploy only the custom policies.

Delete All

Allows you to import host policies from a CSV file to DCNM.

After import, all policies imported from a CSV file are
applied to all managed switches automatically.

Note

Import

Allows you to export host policies from DCNM to a CSV file.Export
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DescriptionField

From the Deployment drop-down list, select an appropriate value.

• Deploy Selected Policies—Select one or more check boxes
next to the policy name. Select this option to deploy selected
policies to the switch.

• Deploy All Custom Policies—Select this option to deploy all
the user-defined policies at a single instance.

• Undeploy Selected Custom Policies—Select one or more check
boxes next to the policy name. Select this option from the
drop-down list to undeploy the selected policies.

• Undeploy All Custom Policies—Select this option to undeploy
all the user-defined policies for a single instance.

• Redo all Failed Custom Policies—Select this option to deploy
all failed user-defined policies.

• Deployment History—Select one policy from the drop-down
list. Select this option to view the deployment history of the
selected policy.

Deployment History shows the following fields.

• Policy Name—Displays the selected policy name.

• Switch Name—Specifies the name of the switch that the
policy was deployed to.

• Deployment Status—Displays the status of deployment.
It shows if the deployment was Success or Failed.

• Specifies the action that is performed on the switch for
that flow policy.

• Create—Implies that the policy has been deployed
on the switch.

• Delete—Implies that the policy has been undeployed
from the switch.

• Deployment Date/Time—Specifies the date and time at
which the host policy was last updated. The format is Day
MMM DD YYYY HH:MM:SS Timezone.

• Failed Reason—Species why the policy was not
successfully deployed.

Deployment

Table 22: Host Policies Table Field and Description

DescriptionField

Specifies the policy name for the host, as defined by the user.Policy Name
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DescriptionField

Specifies the host ID.Host Name

Specifies the IP address of the receiving device.Receiver IP

Specifies the IP Address of the transmitting device.Sender IP

Specifies the multicast IP address for the host.Multicast IP

Specifies the IP Address of the sender.Sender IP

Specifies the host device role. The host device role is either one of
the following:

• Sender

• Receiver-External

• Receiver-Local

Host Role

Specifies if the operation of the host policy. The policy has the
following operations:

• Permit

• Deny

Operation

Specifies the sequence number of the custom policy when the
multicast range is selected.

Sequence #

Specifies the action performed on the switch for that host policy.

• Create─The policy is deployed on the switch.

• Delete─The policy is undeployed from the switch.

Deployment Action

Specifies if the deployment is successful, failed or the policy is not
deployed.

Deployment Status

Specifies the date and time at which the host policy was last updated.

The format is Day MMM DD YYYY HH:MM:SS Timezone.

Last Updated

This section contains the following:

Add Host Policy
By default, the sequence number for policies is auto-generated by DCNM, and Multicast mask/prefix is /32
by default. The server property pmn.hostpolicy.multicast-ranges.enabled under Administration > DCNM
Server > Server Properties must be set to 'true' for the user to be able to provide sequence numbers and
multicast mask/prefix. When the server property is set to true, the fields to enter the sequence number and
the multicast mask/prefix are available in the Media Controller > Host > Host Policies > Add and Media
Controller > Host > Host Policies > Edit windows.
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The default host policies must be deployed successfully to the switch before you deploy the custom host
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you add custom policies.

To add Host policy from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Host > Host Policies.

The Host Policies window is displayed.

Step 2 Click the Add icon.
Step 3 In the Add Host Policy window, specify the parameters in the following fields.

• Policy Name: Specifies a unique policy name for the host policy.

• Host Role: Specifies the host as a multicast sender or receiver. Select one of the following:

• Sender

• Receiver-Local

• Receiver-External

• Host Name: Specifies the host to which the policy is applied. If a destination host is detected, you can
choose the hostname from the drop-down list.

Do not select hosts that are discovered as remote receivers to create receiver or sender host
policies. However, hosts that are discovered as remote senders can be used for creating sender
host policies.

Note

• Sender IP: Specifies the IP address of the Sender host.

• Receiver IP: Specifies the IP address of the receiver host. This field is visible and is applicable only if
the Host Role is set to Receiver-Local.

• Multicast: Specifies the multicast IP Address for the host policy.

• Allow/Deny: Click the radio button to choose, if the policy must Allow or Deny the traffic flow.

Step 4 Click Save & Deploy to configure and deploy the Policy.

Click Cancel to discard the new policy.

Edit Host Policy
The default host policies must be deployed successfully to the switch before you deploy the custom host
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you edit custom policies.

To edit host policy from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Media Controller > Host > Host Policies.

The Host Policies window is displayed.

Step 2 Check the check box next to the host policy name, that you need to edit.
Step 3 Click Edit Host policy icon.
Step 4 In the Edit Host Policy window, edit to specify if the policy will Allow or Deny traffic.

The changes made to Host Policy are applied immediately. If the policy is already applied to any
device, the changes may impact the existing flows.

Note

Step 5 Click Save & Deploy to configure and deploy the Policy.

Click Cancel to discard the changes.

Delete Host Policy
To delete host policy from the Cisco DCNM Web UI, perform the following steps:

You can delete only user-defined Host Policies.Note

Procedure

Step 1 Choose Media Controller > Host > Host Policies.

The Host Policies window is displayed.

Step 2 Check the check box next to the host policy name, that you need to delete.

You can select more than one host policy to delete.

Step 3 Click Delete Host policy icon.

Click Delete All to delete all the policies at a single instance.

Step 4 In the delete notification, click OK to delete the host policy. Click Cancel to return to the Host Policies page.

Deleting a host policy from DCNM does not undeploy the policy from the switches on which it is
deployed. It is highly recommended to undeploy the policy on the switches before deleting it from
DCNM.

Note

A Delete Host policy successful message appears at the bottom of the page.
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Import Host Policy
The default host policies must be deployed successfully to the switch before you deploy the custom host
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you import custom policies.

To import host policies from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Host > Host Policies.

The Host Policies window is displayed.

Step 2 Click the Import host policy icon.
Step 3 Browse the directory and select the .csv format file which contains the Host Policy configuration information.

The policy will not be imported if the format in the .csv file is incorrect.

Step 4 Click Open.

The imported policies are automatically deployed to all the switches in the fabric.

Export Host Policy
To export host policies from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Host > Host Policies.

The Host Policies window is displayed.

Step 2 Click the Export host policy icon.

A notification window appears.

Step 3 Select a location on your directory to store the Host Policy details file.
Step 4 Click OK.

The host policy file is exported to your local directory. The filename is appended with the date on which the
file is exported. The format of the exported file is .csv.

Policy Deployment
Policies are automatically deployed to switches whenever they are added, edited, or imported. You can choose
to undeploy or redeploy the policies, by choosing the appropriate actions in the Deployment drop-down list.
The policies will not be deployed correctly if the device is rebooting while the policy was deployed. In such
case, the Failed message appears in the Status column in the table below.
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The default policies must be deployed successfully to the switch before you deploy the custom policies on
that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default policies
successfully to all the switches before you deploy custom policies.

Deploy Selected Policies

This option allows you to deploy only selected policies to the devices. You can deploy other policies when
required.

Select one or more check boxes next to the policy name. Select this option to deploy selected policies to the
switch.

Deploy All Custom Policies

This option allows you to deploy all the custom or user-defined policies to the switch. The policies are deployed
even if the switch is rebooting. In such case, the deployment fails and a status message Failed appears in the
table below.

Select this option to deploy all the user-defined policies at a single instance.

Undeploy Selected Custom Policies

Select one or more check boxes next to the policy name. Select this option from the drop-down list to undeploy
the selected policies.

Undeploy All Custom Policies

This option allows you to undeploy all the custom or user-defined policies in a single instance.

You cannot undeploy the default configured policies.Note

Redo All Failed Custom Policies

The deployment of policies may fail due to various reasons. This option allows you to deploy all failed
user-defined policies.

All the deployments that failed previously are deployed again only to those switches. All the undeployments
failed previously are redeployed from only those switches.

Deployment History

This option allows you to view the deployment history of the policy.

The policy name is shown in the Policy Name field. From the drop-down list, choose the switch on which
this policy was deployed.

The deployment history of the selected policy for the switch appears in the table below.

Deployment History table shows the following fields.
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Table 23: Policy Deployment History Table Field and Descriptions

DescriptionField

Displays the deployment status of the policy.

It shows if the deployment was Success or Failed.

Deployment Status

Specifies the action that is performed on the switch
for that policy.

Create: The policy is deployed on the switch.

Delete: The policy is undeployed from the switch.

Deployment Action

Specifies the date and time at which the host policy
was last updated. The format is Day MMMDD YYYY
HH:MM:SS Timezone.

Deployment Date/Time

Species why the policy was not successfully deployed.Failed Reason

Applied Host Polices
Beginning from Cisco DCNM Release 11, you can view the policies that you have applied in the entire
network. On the Cisco DCNM Web UI, navigate to Media Controller > Host > Applied Host Policies to
view the various policies.

The table displays default PIM policy, local receiver policy, and sender policy. Media Controller will not
display user-defined PIM Policies or Receiver External Policies.

The following table describes the fields that appear on this page.

Table 24: Field and Description on the Applied Host Policies

DescriptionColumn Name

Specifies the name of the policy applied.Policy Name

Specifies the role of the host.

The host device role is either one of the following:

• PIM

• Sender

• Receiver

Host Role

Specifies the name of the switch to which the policy
is applied.

Switch

Specifies the interface to which the policy is applied.Interface

Specifies if the policy is active or not.Active
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DescriptionColumn Name

Specifies the date and time at which the policy was
created\deployed.

The format is Day, MMM DD YYYY HH:MM:SS
(Timezone).

Time Stamp

Flow
The Flow menu includes the following submenus:

Flow Status
Cisco DCNM allows you to view the flow status pictorially and statistically. The flow status is available on
Media Controller > Flow > Flow Status.

The following table describes the fields that appear on the Active tab.

Table 25: Active Tab

DescriptionField

Click Show Chart icon to view the graphical
representation of the Flow Status.

The data refers to the sender leaf when the
sender starts broadcasting. Please see the
receiver start time in the flow status table
to find when the receiver started getting
data.

Note

Click the Show drop-down list to view the flow status
information in one of the following formats─Chart,
Table, or Chart and Table.

Click Chart Type icon to view the various chart
types. Select a chart type to view the flow status
information that is depicted in that chart format. You
can choose a chart option to see filled patterns or data
markers.

Click Actions icon to print the report or excel chart
information to your local directory.

Show Chart

Specifies the multicast IP address for the flow.

You can click the wave link next to the
Multicast IP address to view the pictorial
representation of flow statistics.

Note

Multicast IP

Specifies the name of the Flow Alias.Flow Alias
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DescriptionField

Specifies the IP Address or the Host alias of the sender
for the multicast group.

Sender

Specifies the IP Address or the Host alias of the
receiver joining the group.

Receiver

Specifies the bandwidth that is allotted for the traffic.Bandwidth

Specifies if the Sender switch is a leaf or spine.Sender Switch

Specifies the interface to which the sender is
connected to.

Sender Interface

Specifies if the Receiver switch is a leaf or spine.Receiver Switch

Specifies the interface to which the receiver is
connected to.

Receiver Interface

Specifies the Switch-defined QoS Policy.QOS/DSCP

Specifies the state of the flow link.

Click active link to view the network diagram of the
Sender and Receiver.

The dotted line displays the direction of the flow of
traffic. You can hover over the nodes to view
information. The table on the right side shows
information about the Sender and Receiver.

Flow Link State

Specifies the policy ID applied to the multicast IP.Policy ID

Displays the time from when the sender joined.Sender Start Time

Specifies the time at which the receiver joined.Receiver Join Time

The following table describes the fields that appear on the Inactive tab.
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Table 26: Inactive Tab

DescriptionField

Click Show Chart icon to view the graphical
representation of the Flow Status.

The data refers to the sender leaf when the
sender starts broadcasting. Please see the
receiver start time in the flow status table
to find when the receiver started getting
data.

Note

Click the Show drop-down list to view the flow status
information in one of the following formats─Chart,
Table, or Chart and Table.

Click Chart Type icon to view the various chart
types. Select a chart type to view the flow status
information that is depicted in that chart format. You
can choose a chart option to see filled patterns or data
markers.

Click icon to print the report or excel chart
information to your local directory.

Show Chart

Specifies the multicast IP address of the flow.Multicast IP

Specifies the name of the Flow Alias.Flow Alias

Specifies the IP Address or the Host alias of the sender
for the multicast groups.

Sender

Specifies the IP Address or the Host alias of the
receiver.

Receiver

Specifies the bandwidth that is allotted for the traffic.Bandwidth

Specifies the Switch-defined QoS Policy.QoS/DSCP

Specifies the policy ID applied to the multicast IP.Policy ID

Specifies the time at which the sender joined.Sender Start Time

Specifies the time at which the receiver joined.Receiver Join Time
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DescriptionField

Specifies reason for the inactive flow.

Cisco DCNM determines the inactive flow if both the
sender and receiver mroute exists with any of the
following combinations.

• Receiver IIF is null

• Receiver OIF is null

• Sender IIF is null

• Sender OIF is null

In this scenario, the switch will not have any fault
reason. Therefore, there is no fault reason for such
inactive flows.

Fault Reason

The following table describes the fields that appear on the Sender Only tab.

Table 27: Sender Only Tab

DescriptionField

Specifies the multicast IP address for the flow.Multicast IP

Specifies the name of the Flow Alias.Flow Alias

Specifies the name of the sender.Sender

Specifies the IP address of the sender switch.Sender Switch

Specifies the name of the sender ingress interface.Sender Ingress Interface

Specifies the flow link state, if it is allow or deny.Flow Link State

Specifies the policy ID applied to the multicast IP.Policy ID

Specifies the bandwidth that is allotted for the traffic.Bandwidth

Displays the time from when the sender switch is
transmitting information.

Sender Start Time

The following table describes the fields that appear on the Receiver Only tab.

Table 28: Receiver Only Tab

DescriptionField

Specifies the multicast IP address for the flow.Multicast IP

Specifies the name of the Flow Alias.Flow Alias
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DescriptionField

Specifies the receiver ID. If the multicast receiver is
remote, theRemote label can be seen next to its name.

Name

Specifies the name of the destination switch interface.Receiver Interface

Specifies the IP address of the receiver switch.Receiver Switch

Specifies the IP address of the multicast sender.Source Specific Sender

Specifies the flow link state, if it is allow or deny.Flow Link State

Specifies the policy ID applied to the multicast IP.Policy ID

Specifies the bandwidth that is allotted for the traffic.Bandwidth

Specifies the time at which the receiver joined.Receiver Join Time

Click theShow drop-down list in the statistical representation area to display the statistical data in various
formats.

Click the arrow to export the statistical data. You can export it in .csv or .pdf formats.

Cisco DCNM holds the Flow statistics values in the DCNM server internal memory. Therefore, after a DCNM
Restart or HA switch over, the Flow statistics will not show previously collected values. However, you can
see the Flow statistics that are collected after the server Restart or HA switch over.

If the new flow joins before the uplinks between the switches that are detected in DCNM, a message
BW_UNAVAIL appears. This is resolved after the uplinks between the switches are detected by DCNM after
discovery of the devices.

Note

Flow Alias
Using the Flow Alias feature, you can specify names for multicast groups. The multicast IP addresses are
difficult to remember, thus by assigning a name to the multicast IP address, you can search and add policies
based on the name.

You can configure a flow alias on Media Controller > Flow > Flow Alias.

The following table describes the fields that appear on this page.

Table 29: Flow Alias Table Field and Description

DescriptionField

Specifies the name of the Flow Alias.Flow Alias

Specifies the multicast IP address for the traffic.Multicast IP Address

Description added to the Flow Alias.Description
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DescriptionField

Specifies the date on which the flow alias was last
updated.

Last Updated at

This section contains the following:

Add Flow Alias
To add flow alias from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Alias.

The Flow Alias window is displayed.

Step 2 Click the Add Flow Alias icon.
Step 3 In the Add Flow Alias window, specify the parameters in the following fields.

• Flow Name: Specifies a unique flow alias name.

• Multicast IP Address: Specifies the multicast IP Address for the flow alias.

• Description: Specifies the description that you add for the flow alias.

Step 4 Click Save to save the flow alias.

Click Cancel to discard.

Edit Flow Alias
To edit a flow alias from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Alias.

The Flow Alias window is displayed.

Step 2 Check the check box next to the flow alias name, that you need to edit.
Step 3 Click Edit Flow Alias icon.
Step 4 In the Edit Flow Alias window, edit the Name, Multicast IP, Description fields.
Step 5 Click Save to save the new configuration.

Click Cancel to discard the changes.
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Delete Flow Alias
To delete flow alias from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Alias.

The Flow Alias window is displayed.

Step 2 Check the check box next to the flow alias, that you need to delete.

You can select more than one flow alias to delete.

Step 3 Click Delete Flow Alias icon.

The flow alias is deleted.

Export Flow Alias
To export host alias from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Alias.

The Flow Alias window is displayed.

Step 2 Click Export flow alias icon.

A notification window appears.

Step 3 Select a location on your directory to store the Alias details file.
Step 4 Click OK.

The flow alias file is exported to your local directory. The filename is appended with the date on which the
file is exported. The format of the exported file is .csv.

Import Flow Alias
To import flow alias from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Alias.

The Flow Alias window is displayed.
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Step 2 Click Import flow alias icon.
Step 3 Browse the directory and select the file which contains the Flow Alias configuration information.
Step 4 Click Open.

The flow alias configuration is imported and displayed on theMedia Controller > Flow > FlowAliaswindow,
on the Cisco DCNM Web Client.

Flow Policies
You can configure the flow policies on Media Controller > Flow > Flow Policies.

The default policies are displayed on the Flow policy page. By default, the bandwidth of these policies is 0.
You can configure the bandwidth such that any flow that matches the default flow policy will accordingly
use the bandwidth and QOS/DSCP parameters. The policy is deployed to all the devices when you save the
configuration.

The default flow policies must be deployed successfully to the switch before you deploy the custom flow
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you add, edit, import, or deploy custom policies.

When you undeploy a default policy, it will be reset to default values, that is, Bandwidth:0gbps, DSCP:Best
Effort, and Policer:Enabled.

Note

The following table describes the fields that appear on this page.

Table 30: Flow Policies Operations

DescriptionField

Allows you to add a new flow policy.Add

Allows you to view or edit the selected flow policy
parameters.

Edit

Allows you to delete the user-defined flow policy.

Note • You cannot delete the default flow
policies.

• Undeploy policies from all switches
before deleting them from DCNM.

Delete

Allows you to delete all the flow policies at a single
instance.

Undeploy policies from all switches before
deleting them from DCNM.

Note

Delete All
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DescriptionField

Allows you to import flow policies from a CSV file.

After import, all policies imported from a
CSV file are applied to all managed
switches automatically.

Note

Import

Allows you to export flow policies to a CSV file.Export
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DescriptionField

From the Deployment drop-down list, select an
appropriate value.

• Deploy Selected Policies—Select one or more
check boxes next to the policy name. Select this
option to deploy selected policies to the switch.

• Deploy All Custom Policies—Select this option
to deploy all the user-defined policies at a single
instance.

• Undeploy Selected Custom Policies—Select one
or more check boxes next to the policy name.
Select this option from the drop-down list to
undeploy the selected policies.

• Undeploy All Custom Policies—Select this
option to undeploy all the user-defined policies
for a single instance.

• Redo all Failed Custom Policies—Select this
option to deploy all failed user-defined policies.

• Deployment History—Select one policy from
the drop-down list. Select this option to view the
deployment history of the selected policy.

Deployment History shows the following fields.

• Policy Name—Displays the selected policy
name.

• Switch Name—Specifies the name of the
switch that the policy was deployed to.

• Deployment Status—Displays the status of
deployment. It shows if the deployment was
Success or Failed.

• Specifies the action that is performed on the
switch for that flow policy.

• Create—Implies that the policy has
been deployed on the switch.

• Delete—Implies that the policy has
been undeployed from the switch.

• Deployment Date/Time—Specifies the date
and time at which the host policy was last
updated. The format isDayMMMDDYYYY
HH:MM:SS Timezone.

• Failed Reason—Species why the policy was
not successfully deployed.

Deployment
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Table 31: Flow Policies Table Field and Description

DescriptionField

Specifies the flow policy name.Policy Name

Specifies the multicast IP address for the traffic.Multicast IP Range

Specifies the bandwidth that is allotted for the traffic.Bandwidth

Specifies the Switch-defined QoS Policy.QoS/DSCP

Specified if the flow policy is deployed successfully
or failed.

Deployment Status

Specifies the action that is performed on the switch
for that host policy.

• Create─The policy is deployed on the switch.

• Delete─The policy is undeployed from the
switch.

Deployment Action

Specifies if the flow policy is in use or not.In Use

Specifies the date and time at which the flow policy
was last updated.

The format is Day MMM DD YYYY HH:MM:SS
Timezone.

Last Updated

A new flow policy or an edited flow policy is effective only under the following circumstances.

• If the new flow matches the existing flow policy.

• If the flow expires and reforms, while the new policy is already added or edited, that matches with the
flow policy.

Note

This section contains the following:

Add Flow Policy
The default flow policies must be deployed successfully to the switch before you deploy the custom flow
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you add custom policies.

To add flow policy from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Policies.
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The Flow Policies window is displayed.

Step 2 Click the Add Flow policy icon.
Step 3 In the Add Flow Policy window, specify the parameters in the following fields.

• Policy Name: Specifies a unique policy name for the flow policy.

• Bandwidth: Specifies the bandwidth that is allocated for the flow policy. Select of the radio buttons to
choose Gbps or Mbps.

Step 4 From the QoS/DSCP drop-down list, choose an appropriate ENUM value.
Step 5 In the Multicast IP Range, enter the beginning IP and ending IP Address for the multicast range.

Click Plus (+) icon to add the multicast range to the policy.

Step 6 Click Deploy to deploy the new policy.

Click Cancel to discard the changes.

Edit Flow Policy
The default flow policies must be deployed successfully to the switch before you deploy the custom flow
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you edit custom policies.

To add flow policy from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Policies.

The Flow Policies window is displayed.

Step 2 Check the check box next to the flow policy name, that you need to edit.
Step 3 Click Edit Flow policy icon.
Step 4 In the Edit Flow Policy window, edit the Multicast IP, Bandwidth, QoS/DSCP fields.
Step 5 Click Deploy to deploy the new policy.

Click Cancel to discard the changes.

Delete Flow Policy
To delete flow policy from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Policies.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
143

Media Controller
Edit Flow Policy



The Flow Policies window is displayed.

Step 2 Check the check box next to the flow policy name, that you need to delete.

You can select more than one flow policy to delete.

You cannot delete the default policies.Note

Step 3 Click Delete icon to delete the selected flow policy.

Click Delete All icon to delete all the flow policies at a single instance.

Import Flow Policy
The default flow policies must be deployed successfully to the switch before you deploy the custom flow
policies on that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default
policies successfully to all the switches before you import custom policies.

To import flow policies from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Policies.

The Flow Policies window is displayed.

Step 2 Click the Import flow policy icon.
Step 3 Browse the directory and select the file which contains the Flow Policy configuration information.
Step 4 Click Open.

The flow policy configuration is imported and displayed on the Media Controller > Flow > Flow Policies
window, on the Cisco DCNM Web Client.

The imported policies are automatically deployed to all the switches in the fabric.

Export Flow Policy
To export host policies from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Media Controller > Flow > Flow Policies.

The Flow Policies window is displayed.

Step 2 Click the Export flow policy icon.

A notification window appears.

Step 3 Select a location on your directory to store the Flow Policy details file.
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Step 4 Click OK.

The flow policy file is exported to your local directory. The filename is appended with the date on which the
file is exported. The format of the exported file is .csv.

Policy Deployment
Policies are automatically deployed to switches whenever they are added, edited, or imported. You can choose
to undeploy or redeploy the policies, by choosing the appropriate actions in the Deployment drop-down list.
The policies will not be deployed correctly if the device is rebooting while the policy was deployed. In such
case, the Failed message appears in the Status column in the table below.

The default policies must be deployed successfully to the switch before you deploy the custom policies on
that switch. Otherwise, the custom policies will fail to deploy. Ensure that you deploy all default policies
successfully to all the switches before you deploy custom policies.

Deploy Selected Policies

This option allows you to deploy only selected policies to the devices. You can deploy other policies when
required.

Select one or more check boxes next to the policy name. Select this option to deploy selected policies to the
switch.

Deploy All Custom Policies

This option allows you to deploy all the custom or user-defined policies to the switch. The policies are deployed
even if the switch is rebooting. In such case, the deployment fails and a status message Failed appears in the
table below.

Select this option to deploy all the user-defined policies at a single instance.

Undeploy Selected Custom Policies

Select one or more check boxes next to the policy name. Select this option from the drop-down list to undeploy
the selected policies.

Undeploy All Custom Policies

This option allows you to undeploy all the custom or user-defined policies in a single instance.

You cannot undeploy the default configured policies.Note

Redo All Failed Custom Policies

The deployment of policies may fail due to various reasons. This option allows you to deploy all failed
user-defined policies.

All the deployments that failed previously are deployed again only to those switches. All the undeployments
failed previously are redeployed from only those switches.
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Deployment History

This option allows you to view the deployment history of the policy.

The policy name is shown in the Policy Name field. From the drop-down list, choose the switch on which
this policy was deployed.

The deployment history of the selected policy for the switch appears in the table below.

Deployment History table shows the following fields.

Table 32: Policy Deployment History Table Field and Descriptions

DescriptionField

Displays the deployment status of the policy.

It shows if the deployment was Success or Failed.

Deployment Status

Specifies the action that is performed on the switch
for that policy.

Create: The policy is deployed on the switch.

Delete: The policy is undeployed from the switch.

Deployment Action

Specifies the date and time at which the host policy
was last updated. The format is Day MMMDD YYYY
HH:MM:SS Timezone.

Deployment Date/Time

Species why the policy was not successfully deployed.Failed Reason

Global
The Global menu includes the following submenus:

Events
Cisco DCNM allows you to view and purge the various events between the Host and Flow. The Events are
recorded on Media Controller > Events.

The PMN Events table is updated real-time.

The maximum stored PMN events and cleanup frequency can be specified via pmn.rows.limit and
pmn.delete.interval respectively in the Administration > DCNM Server > Server Properties page.

The following table describes the fields that appear on this page.
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DescriptionField

Click to remove the old/unwanted events.

If the DCNM server restarts, by default a maximum of 5000
event entries are retained for 6 hours.

Note

Click one of the radio buttons to choose the Purge options.

• Max # of Records—Enter the maximum number of records to delete.

• # of Days—Enter the number of days for which you need to delete
the events.

• Delete all data from the previous date—Specifies a date before
which all the data is deleted.

Click Purge to delete/retain PMN events information.

Purge

Specifies if the event category.Category

Specifies the severity of the event.Severity

Specifies the description of the event.

The sample description appears as:

Creating flow for FlowRequest:The flowRequest is
for hostId:<<IP_Address>>
hostInterface:<<Host_Int_ID>> mcastIp:<<Multicast
IP>> Is sender role:false originating from
switch:<<Host IP Address>>

Description

Specifies the impacted flows due to this event.Impacted Flows

Specifies the date and time at which the event was last modified.

The format is Day MMM DD YYYY HH:MM:SS Timezone.

Last Update Time

Allows you to download the events to a local directory path.

The filename is appended with the date on which the file is exported. The
format of the exported file is .xls.

Export

Config
The Config menu includes the following submenus:

Setting Up the SNMP Server for DCNM
When you add a switch to the DCNM inventory, DCNM automatically configures the switch with the following
configuration so that the switch knows where to send SNMP traps: snmp-server host dcnm-host-IP traps
version 2c public UDP port - 2162
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Follow these steps to establish switch-to-DCNM connectivity if you are planning to use a controller deployment.

Procedure

Step 1 To ensure that DCNM receives SNMP traps from the switches, specify the IP address (or VIP address for
native HA) to which the switches send the SNMP traps by configuring DCNM server property
trap.registaddress=dcnm-ip under Administrator > Server Properties.

Step 2 For an Inband environment, use the pmn_telemetry_snmp CLI template that is packaged along with the
Cisco DCNM Application, to configure more SNMP settings on the switch. For more information, see Switch
Global Config, on page 150.

AMQP Notifications
For all DCNM operations (such as Host Alias, Host Policy, and so on), AMQP notifications are sent. For
operations triggered by the switch and received through telemetry (such as Flow Status), Cisco DCNM
periodically checks for new events and generate appropriate notifications. This time period can be configured
by setting the "AMQP_POLL_TIME" value in the server.properties.

To update the server.properties file and change AMQP poll interval, perform the following:

1. Locate the server.properties file that is located at the following location:

/usr/local/cisco/dcm/fm/conf/
2. Edit the line AMQP_POLL_TIME based on the required poll interval. Poll interval value is in minutes.

AMQP_POLL_TIME=5

The poll interval is set to 5 minutes. By default, the poll interval is set to 2 minutes.

3. Restart the DCNM server to apply the changes that are made in the server.properties file, using
the command:

appmgr restart dcnm—for Standalone deployment

appmgr restart ha-apps—for Native HA deployment

AMQP Notification Components

• Routing Key

The routing key is an address that the exchange may use to decide how to route the message. This is
similar to a URL in HTTP. Most exchange types use the routing key to implement routing logic, but user
may choose to ignore it and filter on some other criteria such as message contents. DCNM PMN
additionally includes routing key criteria in message header properties.

• Routing Key Format

The routing key of DCNM PMN AMQP for object notification has following format:
Severity.Operation.ObjectType

Example: info.com.cisco.dcnm.event.pmn.create.host

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
148

Media Controller
AMQP Notifications



DetailsKey Identifier

Message Severity (Info/Warning/Error)Severity

Create/Update/Delete/Discover/Apply/
Establish/Deploy/SwitchReload/DCNM

Operation

Object involved in notification includes Host Alias,
Host, Host Policy, Flow Policy, Flow, Switch,
DCNM.

Object Type

• Message Properties

Message includes following properties and header which can be used for content parsing.

ValueProperty

Message priority. Its default value is 0.priority

Delivery mode used for the message. Its default
value is 2 (persistent), which means the message is
stored both in-memory and on disk.

delivery_mode

UTF-8content_encoding

MIME type of message content. The default value
is application/json.

content_type

List of name-value pairs about the message.headers

• Severity─Message Severity
(Info/Warning/Error).

• Operation Status─Success/Failure.

• Operation─
Create/Update/Delete/Discover/Apply/
Establish/Deploy/SwitchReload/DCNM.

• Bulk─True/False indicates bulk operation.

• Type─Object involved in notification such as
Host Alias, Host, Host Policy, Flow Policy,
Flow, Switch, DCNM.

• User─Logged-in user who performed the
action.

• Event─Message sent (for backwards
compatibility).

Message IDmessage_id

• Notification Body
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DCNM notification payload contains necessary information to identify the resources that trigger the
notification, as well as link for detailed information retrieval. In case of operation failure, the notification
includes the error message with detailed reason.

Switch Global Config
Prior to Release 11, Cisco DCNM Media Controller performed operations such as managing the bandwidth,
stitching the flows, host link bandwidth, and so on. Beginning with Release 11, DCNM allows two major
operations.

• Monitor the Network

• Configure Host and Flow policies

DCNM monitors the Flow Status, Discovered Host, Applied Host Policies and other operations using Telemetry.
For any operations triggered by the switch and received through telemetry (e.g. Flow Established), DCNM
periodically checks for new events and generate appropriate notification.

If pmn.deploy-on-import-reload.enabled server property is set to true, during a switch reload,
when DCNM receives switch coldStartSNMPtrap, it will push Global Config, and Host and Flow policies
that are showing 'Deployment Status=Successes' to the switch automatically. The switch telemetry and SNMP
configuration can be deployed on demand by using DCNM packagedpmn_telemetry_snmpCLI template
via Configure > Templates > Template Library.

Navigate to Cisco DCNMWeb UI > Media Controller > Global > Config to set or modify Switch Global
configuration and WAN links.

When Cisco DCNM is installed in Media Controller Deployment mode, you can deploy policies the unicast
bandwidth, ASM range, and WAN links through Web UI > Media Controller > Global > Config.

After you deploy the DCNM in Media Controller mode, you must configure the bandwidth and ASM. The
remaining percentage of the bandwidth is utilized by the multicast traffic. DCNM acts like a Master Controller,
and deploy the bandwidth and ASM configurations to all the switches in the fabric.

Navigate to Cisco DCNMWeb UI > Media Controller > Global > Config > Switch Global Config to
configure the global parameters.

AMQP Notifications

As Cisco DCNM uses Telemetry to fetch data from the Fabric, the flow status and AMQP notifications may
not reflect the current state in real time. It periodically checks new events and generate appropriate notification.
Also, flows are no longer limited to a single spine and may take N or W or M shape. Host policies are applied
based on the switch interface configuration and not just-in-time (JIT). All these architecture changes influence
current AMQP messages and trigger time. By default, poll interval is set to 2 minutes. For more information,
see AMQP Notifications, on page 148.

Unicast Bandwidth Reservation

You can configure the server to allot a dedicated percentage of bandwidth to unicast traffic. The remaining
percentage is automatically reserved for multicast traffic.

In the Unicast Bandwidth Reservation (%) field, enter a numeric value to configure the bandwidth.
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ASM Range

Any Source Multicast (ASM) is a PIM tree building mode that uses shared trees to discover new sources and
receivers as well as source trees to form shortest paths from receivers to sources. ASM provides discovery of
multicast sources.

You can configure the ASM range by specifying the IP address and the subnet mask.

In the ASM/Mask field, enter the IP address and subnet mask defining the multicast source. Click Add icon
to add the multicast address to the ASM range. You can add multiple ASM ranges. To delete an ASM range,
select the check box next to the ASM/Mask in the table and click Delete icon.

After you configure the Unicast Bandwidth Reservation and ASM range, you can perform the following
operations to deploy this to the switches.

Table 33: Operations on the Global Config screen

DescriptionIcon

Click Save to save the configurations.Save

After configuring the Unicast Bandwidth and ASM
range, you can choose to deploy the configuration.
You can choose one of the following from the
drop-down list:

• All—Deploys both ASM and Bandwidth
configuration to all switches.

• Bandwidth—Deploys only the bandwidth
configuration.

• ASM—Deploys only the ASM configuration.

• All Failed—Deploys all failed deployments.

Success or Failed message appears next to each of the
ASM range in the table.

Deploy

You can undeploy the Unicast Bandwidth and ASM
range. From the drop-down list, choose one of the
following:

• All—Undeploys both ASM and Bandwidth
configuration to all switches.

• Bandwidth—Undeploys only the bandwidth
configuration from the switches.

• ASM—Undeploys only the ASM configuration.

Undeploy
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DescriptionIcon

Unicast Bandwidth Reservation Status specifies if the
bandwidth deployment was success, or failed or not
deployed.

ASM/Mask Status field displays if the ASM and Mask
configuration was deployed successfully, or failed or
not deployed.

Status

Click the respective History link to view the
deployment history for Unicast Bandwidth and ASM
deployments.

For a description about the fields that appear on the
History link, see #unique_219 unique_219_Connect_
42_deployment_history_table.

History

The following table describes the fields that appear on the Deployment History.

Table 34: Deployment History Field and Description

DescriptionField

Specifies the switch name in the fabric on which the
configuration was deployed.

Switch Name

Specifies the action that is performed on the switch－
Deploy or Undeploy.

Action

Displays the status of deployment. It shows if the
deployment was Success or Failed.

Deployment Status

Displays the date and time when the deployment was
initialized.

Deployment Date/Time

Specifies the reason why the deployment failed.Failed Reason
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DescriptionField

From the drop-down list, choose an appropriate filter.

• Quick Filter－A search field appears in every
column. You can enter a search string to filter.

• Advanced Filter－In the Advanced Filter screen,
select the All or Any radio button in the Match
field. In the Select Filter field, select the category
from the drop-down list. Select an appropriate
condition from the drop-down field in the next
field. Enter a search string in the next field.

Click Add icon to add another filter. Click
Remove icon to delete the filter. Click Clear to
clear all the filters. Click Apply to activate the
filters, and view the filtered events. Click Save
to save the applied filter. ClickCancel to discard
the advanced filters.

• All－This removes all the filters and displays
the complete deployment history.

• Manage Preset Filters－Select an appropriate
filter from the drop-down list.

Click Edit to modify the filter parameters. Click
Remove to delete the filter. Click Cancel to
discard the changes and revert to Deployment
History.

Show

Displays the total number of events on the
Deployment History page.

Total

After deploying the global configurations, configure the WAN for each switch in your network.

WAN Links
Beginning with Release 11, Cisco DCNM Web UI allows you to configure WAN links for each switch in
your fabric.

The external end devices can connect to the network through a Border Leaf and PIM router. The interface
that connects the PIM router to the Border Leaf is called WAN Link.

1. From the Select a Switch drop-down list, choose a switch in the fabric for which you want to establish
WAN links.

The list of interfaces on the switch is populated in the following table.

The switches that are a part of the fabric appear in the drop-down list.Note
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2. In the WAN Links column, from the drop-down list, choose Yes or No to designate the interface as a
WAN link.

3. Click View All DeployedWANLinks to view the Switch Name, Switch IP Address, and Interface Name
which is configured as a WAN link. You can choose an appropriate filter to view the WAN links.

4. Click Save to save the selection on interfaces as WAN links and other configuration changes.

5. Click Deploy to configure the interfaces as WAN links.

6. Click Undeploy to remove the WAN links from the switch.

The following table describes the fields that appear on this page.

Table 35: WAN Links Table Field and Description

DescriptionField

Specifies if the WAN links are deployed or
undeployed on the selected switch.

Status

Click this link to view the deployment history.

For description about the fields that appear on this
page, see the table below.

History

Specifies the interface which is connected as a WAN
link to the end device.

Interface Name

An up arrow depicts that the status is up. A down
arrow implies that the status is down.

Admin Status

An up arrow depicts that the operational state of the
interface is up. A down arrow implies that the status
is down.

Oper Status

From the drop-down, list you can choose to designate
this interface as a WAN link.

• Select Yes to configure the interface as a WAN
link.

• SelectNo to remove the interface as a WAN link.

WAN Links

Specifies if the interface is deployed as a WAN link
or not.

Deployment Status

The following table describes the fields that appear on the Deployment History.

Table 36: Deployment History Field and Description

DescriptionField

Specifies the switch name in the fabric on which the
configuration was deployed.

Switch Name

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
154

Media Controller
WAN Links



DescriptionField

Specifies the action that is performed on the switch－
Deploy or Undeploy.

Action

Displays the status of deployment. It shows if the
deployment was Success or Failed.

Deployment Status

Displays the date and time when the deployment was
initialized.

Deployment Date/Time

Specifies the reason why the deployment failed.Failed Reason

From the drop-down list, choose an appropriate filter.

• Quick Filter－A search field appears in every
column. You can enter a search string to filter.

• Advanced Filter－In the Advanced Filter screen,
select the All or Any radio button in the Match
field. In the Select Filter field, select the category
from the drop-down list. Select an appropriate
condition from the drop-down field in the next
field. Enter a search string in the next field.

Click Add icon to add another filter. Click
Remove icon to delete the filter. Click Clear to
clear all the filters. Click Apply to activate the
filters, and view the filtered events. Click Save
to save the applied filter. ClickCancel to discard
the advanced filters.

• All－This removes all the filters and displays
the complete deployment history.

• Manage Preset Filters－Select an appropriate
filter from the drop-down list.

Click Edit to modify the filter parameters. Click
Remove to delete the filter. Click Cancel to
discard the changes and revert to Deployment
History.

Show

Displays the total number of events on the
Deployment History page.

Total

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
155

Media Controller
WAN Links



Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
156

Media Controller
WAN Links



C H A P T E R 7
Administration

This chapter contains the following topics:

• DCNM Server, on page 157
• Management Users, on page 168
• Performance Setup, on page 172
• Event Setup, on page 173
• Credentials Management, on page 177

DCNM Server
The DCNM Server menu includes the following submenus:

Starting, Restarting, and Stopping Services
To clean up the performance manager database (PM DB) stale entries, start, restart, or stop a service, from
the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > DCNM Server > Server Status.

The Status window appears that displays the server details.

Step 2 In the Actions column, click the Start or Stop icons to start or stop services.
Step 3 In the Actions column, click the Delete icon to clean up PM DB stale entries.
Step 4 You can see the latest status in the Status column.

What to do next

See the latest status in the Status column.

Using the Commands Table
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The commands table contains links to commands that launch new dialog boxes to provide information about
the server status and server administrative utility scripts. These commands can be directly executed on the
server CLI as well.

• ifconfig: click this link to view information about interface parameters, IP address, and netmask used on
the Cisco DCNM server.

• appmgr status all: click this link to view the DCNM server administrative utility script that checks the
status of different services currently running.

• clock: click this link to view information about the server clock details such as time, zone information.

The commands section is applicable only for the OVA or ISO installations.Note

Viewing Log Information
You can view the logs for performance manager, SAN management server, SME server, web reports, web
server, and web services. These processes have no corresponding GUI that allows you to view information
about these log files. If you see errors, preserve these files for viewing.

Logs cannot be viewed from a remote server in a federation.Note

To view the logs from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > DCNM Server > Logs.

You see a tree-based list of logs in the left column. Under the tree, there is a node for every server in the
federation. The log files are under the corresponding server node.

Step 2 Click a log file under each node of the tree to view it on the right.
Step 3 Double-click the tree node for each server to download a ZIP file containing log files from that server.
Step 4 Click the Print icon on the upper right corner to print the logs.

Server Properties
You can set the parameters that are populated as default values in the DCNM server.

To set the parameters of the DCNM server from the Cisco DCNM Web UI, perform the following steps:
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Procedure

Step 1 Choose Administration > DCNM Server > Server Properties.
Step 2 Click Apply Changes to save the server settings.

Configuring SFTP/TFTP/SCP Credentials
A file server is required to collect device configuration and restoring configurations to the device.

To configure the SFTP/TFTP/SCP credentials for a file store from the Cisco DCNM Web UI, perform the
following steps:

Procedure

Step 1 Choose Administration > DCNM Server > Archive FTP Credentials.

The Archive FTP Credentials window is displayed.

The credentials are autopopulated for fresh OVA and ISO installations.Note

Step 2 In the Server Type field, use the radio button to select SFTP.

• You must have an SFTP server to perform backup operation. The SFTP server can be an
external server. The SFTP directory must be an absolute Linux/SSH path format and must have
read/write access to the SFTP User.

• If you are using an external server, enter its IP address in the server.FileServerAddress field
in Administration > DCNM Server > Server Properties.

• If the nat.enabled field under Administration > DCNM Server > Server Properties is true,
you must enter the NAT device IP in the server.FileServerAddress field and the SFTP server
must be local.

Note

a) Enter the User Name and Password.
b) Enter the Directory path.

The path must be in absolute Linux path format.

If SFTP is unavailable on your device, you can use third-party SFTP applications, such as, mini-SFTP,
Solarwinds, and so on. When you use an external SFTP, you must provide the relative path in the STFP
Directory Path. For example, consider the use cases at the end of this procedure.

c) From the Verification Switches drop-down list, select a switch.
d) Click Apply to save the credentials.
e) Click Verify & Apply to verify if SFTP and switch have connectivity and save the configuration.

If there are any failures during the verification, the new changes will not be stored.

f) Click Clear SSH Hosts to clear SSH hosts for all switches or selected switches.

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
159

Administration
Configuring SFTP/TFTP/SCP Credentials



If there is a failure in any of the switches, an error message appears. Navigate to Configure > Backup >
Switch Configuration > Archive Jobs > Job Excecution Details to view the number of successful and
unsuccessful switches.

Step 3 In the Server Type field, use the radio button to select TFTP.

Cisco DCNM uses a local TFTP server for data transfer. Ensure that there is no external TFTP server running
on the DCNM server.

Ensure that your switch user role includes the copy command. Operator roles receive a permission
denied error. You can change your credentials in the Discovery window. Navigate to Inventory >
Discovery.

Note

a) From the Verification Switch drop-down list, select a switch.
b) Click Apply to save the credentials everywhere.
c) Click Verify & Apply to verify if TFTP and switch have connectivity and save the configuration.

If there are any failures during the verification, the new changes are not stored.

Step 4 In the Server Type field, use the radio button to select SCP.

• You must have an SCP server to perform backup operation. The SCP server can be an external
server. The SCP directory must be an absolute Linux/SSH path format and must have read/write
access to the SCP User.

• If you are using an external server, enter its IP address in the server.FileServerAddress field
under Administration > DCNM Server > Server Properties.

• If the nat.enabled field under Administration > DCNM Server > Server Properties is true,
you must enter the NAT device IP in the server.FileServerAddress field and the server must
be local.

Note

a) Enter the User Name and Password.
b) Enter the Directory path.

The path must be in absolute Linux path format.

If SCP is unavailable on your device, use external SCP applications, such as, mini-SCP, Solarwinds, and
so on. When you use an external SCP, you must provide the relative path in the SCP Directory Path. For
example, consider the use cases at the end of this procedure.

c) From the Verification Switches drop-down, select the switch.
d) Click Apply to save the credentials everywhere.
e) Click Verify & Apply to verify if SCP and switch have connectivity and save the configuration. If there

are any failures during the verification, the new changes will not be stored.
f) Click Clear SSH Hosts to clear SSH hosts for all switches or selected switches.

If there is a failure in any of the switches, an error message is displayed. To view the number of successful
and unsuccessful switches, go to Configure > Backup > Switch Configuration > Archive Jobs > Job
Excecution Details.

Step 5 Choose Configuration > Templates > Templates Library > Jobs to view individual device verification
status.
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The configurations that are backed up are removed from the file server and are stored in the file system.

SFTP Directory Path

Use Case 1:

If Cisco DCNM is installed on Linux platforms, like OVA, ISO, or Linux, and the test folder is
located at /test/sftp/, you must provide the entire path of the SFTP directory. In the SFTP
Directory field, enter /test/sftp.

Use Case 2:

If Cisco DCNM is installed on the Windows platform, and the test folder is located at
C://Users/test/sftp/, you must provide the relative path of the SFTP directory. In the SFTP
Directory field, enter /.

For Example:

• If the path in the external SFTP is C://Users/test/sftp/, then the Cisco DCNM SFTP
Directory path must be /.

• If the path in the external SFTP is C://Users/test, then the Cisco DCNM SFTP Directory
path must be /sftp/.

Examples for SCP Directory Path

Use Case 1:

If Cisco DCNM is installed on Linux platforms, like OVA, ISO, or Linux, and the test folder is
located at /test/scp/, you must provide the entire path of the SCP directory. In the SCPDirectory
field, enter /test/scp.

Use Case 2:

If Cisco DCNM is installed on the Windows platform, and the test folder is located at
C://Users/test/scp/, you must provide the relative path of the SCP directory. In the SCP
Directory field, enter /.

For Example:

• If the path in the external SCP is C://Users/test/scp/, then the Cisco DCNM SCP
directory path must be /.

• If the path in the external SCP is C://Users/test, then the Cisco DCNM SCP directory
path must be /scp/.

Modular Device Support
To support any new hardware that does not require many major changes, a patch can be delivered instead of
waiting for the next DCNM release. Modular Device Support helps to deliver and apply the DCNM patch
releases. An authorized DCNM administrator can apply the patch to the production setup. Patch releases are
applicable for the following scenarios:

• Support any new hardware, like chassis or line cards
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• Support latest NX-OS versions

• Support critical fixes as patches

To view the patch details from Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > DCNM Server > Modular Device Support.

You see the DCNM Servers column on the left in the window and Modular Device support information
window on the right.

Step 2 Expand DCNM Servers to view all the DCNM servers.

It includes the list of patches installed along with the version number, corresponding platforms supported,
chassis supported, NX-OS version supported, PID supported, backup directory and the last patch deployment
time in the Modular Device support information table.

What to do next

For more details about how to apply and rollback a patch, go to http://www.cisco.com/go/dcnm for more
information.

Managing Switch Groups
From Cisco NX-OS Release 6x, you can configure switch groups by using Cisco DCNM Web UI. You can
add, delete, rename, or move a switch to a group or move a group of switches to another group.

This section contains the following:

Adding Switch Groups
To add switch groups from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > DCNM Server > Switch Groups.
Step 2 Click the Add icon.

The Add Group window is displayed, that allows you to enter the name for the switch group.

Step 3 Enter the name of the switch group and click Add to complete adding the switch group.

The switch group name validation, and the maximum tree depth is 10. If you do not choose a parent group
before adding a new switch group, the new group is added on the top of the hierarchy
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Deleting a Group or a Member of a Group
You can delete a group or a member of the group from the Cisco DCNM Web UI. When you delete a group,
the associated groups are deleted. The fabrics or ethernet switches of the deleted groups are moved to the
default SAN or LAN.

To delete a group or a member of a group from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose the switch group or members of a group that you want to remove.
Step 2 Click the Remove icon or press the Delete key on your keyboard.

A dialog box prompts you to confirm the deletion of the switch group or the member of the group.

Step 3 Click Yes to delete or No to cancel the action.

Moving a Switch Group to Another Group
To move a switch group to another group from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Select a switch or switch group.
Step 2 Drag the highlighted switch or switch group to another group.

To move multiple switches across different switch groups, use Ctrl key or Shift key.

You can see the switch or switch group. Users are not allowed to move multiple switches in the group level
under the new group now.

It is not allowed to move multiple switches in the group level. You may not mix a group with
switches.

Note

Managing Licenses
You can view the existing Cisco DCNM licenses by choosing Administration > DCNM Server > License.
You can view and assign licenses in the following tabs:

• License Assignments

• Server License Files

By default, the License Assignments tab appears.Note

The following table displays the SAN and LAN license information.
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DescriptionField

Specifies SAN or LAN.License

Specifies the number of free licenses that are purchased out of the total number
of licenses.

Free/Total Server-based
Licenses

Specifies the number of unlicensed switches or VDCs out of the total number
of switches or VDCs.

Unlicensed/Total
(Switches/VDCs)

Specifies the number of licenses to be purchased.Need to Purchase

This section includes the following topics:

License Assignments
The following table displays the license assignment details for every switch or VDC.

DescriptionField

Displays if the group is fabric or LAN.Group

Displays the name of the switch.Switch Name

Displays the world wide name or Chassis ID.WWN/Chassis ID

Displays the model of the device. For example, DS-C9124 or
N5K-C5020P-BF.

Model

Displays the license state of the switch that can be one of the following:

• Permanent

• Eval

• Unlicensed

• Not Applicable

• Expired

• Invalid

License State

Displays if the license is a switch-based embedded license or a server-based
license.

License Type

Displays the expiry date of the license.

Text under the Eval Expiration column is in red for licenses,
which expire in seven days.

Note

Eval Expiration

Select a row and click this option on the toolbar to assign the license.Assign License

Select a row and click this option on the toolbar to unassign the license.Unassign License

Click this option on the toolbar to refresh the table and assign the licenses for
all the items in the table.

Assign All
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DescriptionField

Click this option on the toolbar to refresh the table and unassign all the
licenses.

Unassign All

You must have network administrator privileges to assign or unassign licenses.Note

When the fabric is first discovered and if the switch does not have a valid switch-based license, a license is
automatically assigned to the fabric from the file license pool until no more licenses are left in the pool. If
you have an existing fabric and a new switch is added to the fabric, the new switch is assigned a license if
one is available in the file license pool and if it does not already have a switch-based license.

Server License Files

Server License Files

The following table displays the Cisco DCNM server license fields.

DescriptionField

Specifies the license file name.Filename

Specifies the licensed feature.Feature

Specifies the product ID.PID

Displays the number of free versus total licenses for LAN.LAN (Free/Total)

Displays the expiry date of the license.

Text in theEval Expiration field is in Red for licenses that expires
in seven days.

Note

Eval Expiration

Adding Cisco DCNM Licenses

To add Cisco DCNM licenses from Cisco DCNM, perform the following steps:

Before you begin

You must have network administrator privileges to complete the following procedure.

Procedure

Step 1 Choose Administration > DCNM Server > License to start the license wizard.
Step 2 Choose the Server License Files tab.

The valid Cisco DCNM-LAN license files are displayed.

Ensure that the security agent is disabled when you load licenses.
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Step 3 Download the license pack file that you received from Cisco into a directory on the local system.
Step 4 Click Add License File and select the license pack file that you saved on the local machine.

The file is uploaded to the server machine, which is saved into the server license directory, and then loaded
on to the server.

Ensure that you do not edit the contents of the .lic file or the Cisco DCNM software ignores any
features that are associated with that license file. The contents of the file are signed and must remain
intact. When you accidentally copy, rename, or insert the license file multiple times, the duplicate
files are ignored, but the original is counted.

Note

Native HA

Procedure

Step 1 By default, DCNM is bundled with an embedded database engine PostgreSQL. The native DCNM HA is
achieved by two DCNMs running as Active / Warm Standby, with their embedded databases synchronized
in real time. So once the active DCNM is down, the standby takes over with the same database data and resume
the operation. The standby host database down scenario is documented after this procedure.

Step 2 From the menu bar, choose Administration > DCNM Server > Native HA.

You see the Native HA window.

Step 3 You can allow manual failover of DCNM to the standby host by clicking the Failover button, and then click
OK.

• Alternatively, you can initiate this action from the Linux console.

1. SSH into the DCNM active host.

2. Enter " " /usr/share/heartbeat/hb_standby”

Step 4 You can allow manual syncing database and disk files to standby host by clicking Force Sync, and then click
OK.

Step 5 You can test or validate the HA setup by clicking Test and then click OK.

What to do next

Some HA troubleshooting scenarios are noted in this sub section.

The standby host database is down: Typically, the DCNM database (PostgreSQL) is up on the active and
standby hosts. In DCNM 10.1 and earlier versions, the standby database can be down due to a database
synchronization failure.

• Enter “ps -ef | grep post”. You should see multiple postgres processes running. If not, it indicates that
the database is down.

• Restore database data from a backup file that is created at the beginning of database synchronization.
Change directory to “/usr/local/cisco/dcm/db”
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• Check existence of file replication/ pgsql-standby-backup.tgz. If the file exists, restore database data
files:

rm -rf data/*
tar -zxf replication/ pgsql-standby-backup.tgz data
/etc/init.d/postgresql-9.4 start
ps -ef | grep post

The active DCNM host will synchronize the two databases.

The TFTP server is not bound to the eth1 VIP address on the active host: The TFTP server should run
on the active host (not on the standby host), and it should be bound to the eth1 VIP address. In some setups,
the bind address is not the VIP address, as per the TFTP configuration file, and this could cause issues when
switches try to use TFTP.

• Enter “grep bind /etc/xinetd.d/tftp” to check if the TFTP configuration file has the right bind address.
If the displayed IP address is not the eth1 VIP address, then change the bind address to the VIP address.
Repeat the procedure for the standby host. Update the bind address to the VIP address.

• Enter " " /etc/init.d/xinetd restart” on the active host to restart TFTP.

The TFTP server can be started or stopped with the “appmgr start/stop ha-apps” command.Note

Multi Site Manager

Procedure

Step 1 Multi-Site-Manager (MsM) provides a single pane for users to search for switches that are managed by DCNM
globally. MSM can do realtime search to find out which switch globally handles the traffic for a given virtual
machine based on IP address, name or mac address, and supporting VXLAN basing on segment ID as well.
It provides hyperlink to launch the switch only. This window also plays the role of remote site registration.
The registration only allows the current DCNM server to access the remote DCNM server or site. For the
remote site to access the current DCNM server, registration is required on the remote site as well.

Step 2 Choose Administration > DCNM Server > Multi Site Manager.

The MsM window displays the overall health or status of the remote site and the application health.

Step 3 You can search by Switch, VM IP, VM Name, MAC, and Segment ID.
Step 4 You can add a new DCNM server by clicking +Add DCNM Server. The Enter Remote DCNM Server

Information window opens. Fill in the information that is required and click OK to save.
Step 5 Click Refresh All Sites to display the updated information.
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Management Users
The Management Users menu includes the following submenus:

Remote AAA
To configure remote AAA from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > Management Users > Remote AAA Properties.

The AAA properties configuration window appears.

Step 2 Use the radio button to select one of the following authentication modes:

• Local: In this mode the authentication authenticates with the local server.

• Radius: In this mode the authentication authenticates against the RADIUS servers specified.

• TACACS+: In this mode the authentication authenticates against the TACAS servers specified.

• Switch: In this mode the authentication authenticates against the switches specified.

• LDAP: In this mode the authentication authenticates against the LDAP server specified.

Step 3 Click Apply.

Restart the Cisco DCNM LAN services if you update the Remote AAA properties.Note

Local

Procedure

Step 1 Use the radio button and select Local as the authentication mode.
Step 2 Click Apply to confirm the authentication mode.

Radius

Procedure

Step 1 Use the radio button and select Radius as the authentication mode.
Step 2 Specify the Primary server details and click Test to test the server.
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Step 3 (Optional) Specify the Secondary and Tertiary server details and click Test to test the server.
Step 4 Click Apply to confirm the authentication mode.

TACACS+

Procedure

Step 1 Use the radio button and select TACACS+ as the authentication mode.
Step 2 Specify the Primary server details and click Test to test the server.
Step 3 (Optional) Specify the Secondary and Tertiary server details and click Test to test the server.
Step 4 Click Apply to confirm the authentication mode.

Switch

Procedure

Step 1 Use the radio button to select Switch as the authentication mode.

DCNM also supports LAN switches with the IPv6 management interface.

Step 2 Specify the Primary Switch name and click Apply to confirm the authentication mode.
Step 3 (Optional) Specify the names for Secondary and Tertiary Switches.
Step 4 Click Apply to confirm the authentication mode.

LDAP

Procedure

Step 1 Use the radio button and select LDAP as the authentication mode.
Step 2 In the Host field, enter DNS address of the host.
Step 3 Click Test to test the AAA server. The Test AAA Server window pops out.
Step 4 Enter a valid Username and Password in the Test AAA Server window.

A dialog box appears confirming the status of the AAA server test. If the test has failed, the LDAP
Authentication Failed dialog box appears.

Step 5 In the Port field, enter a port number.
Step 6 (Optional) Select the SSL Enabled check box, if SSL is enabled on the AAA server.
Step 7 In the Base DN field, enter the base domain name.
Step 8 In the Filter field, specify the filter parameters.
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Step 9 Choose an option to determine a role by either Attribute or Admin Group Map.
Step 10 In the Role Admin Group field, enter the name of the role.
Step 11 In the Map to DCNM Role field, enter the name of the role to be mapped.
Step 12 In the Access Map field, enter the Role Based Access Control (RBAC) group to be mapped.
Step 13 Click Apply Changes icon on the upper right corner to apply the LDAP configuration.

Managing Local Users
As an admin user, you can use Cisco DCNM Web UI to create a new user, assign the role and associate one
or more groups or scope for the user.

This section contains the following:

Adding Local Users

Procedure

Step 1 From the menu bar, choose Administration > Management Users > Local. You see the Local Users page.
Step 2 Click Add User.

You see the Add User dialog box.

Step 3 Enter the username in the User name field.

The username is case sensitive, but the username guest is a reserved name, which is not case sensitive.
The guest user can only view reports. The guest user cannot change the guest password, or access
the Admin options in DCNM Web Client.

Note

Step 4 From the Role drop-down list, select a role for the user.
Step 5 In the Password field, enter the password.
Step 6 In the Confirm Password field, enter the password again.
Step 7 Click Add to add the user to the database.
Step 8 Repeat Steps 2 through 7 to continue adding users.

Deleting Local Users
To delete local users from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > Management Users > Local.

The Local Users page is displayed.

Step 2 Select one or more users from the Local Users table and click the Delete User button.
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Step 3 Click Yes on the warning window to delete the local user. Click No to cancel deletion.

Editing a User
To edit a user from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > Management Users > Local.
Step 2 Use the checkbox to select a user and click the Edit User icon.
Step 3 In the Edit User window, the Username and Role are mentioned by default. Specify the Password and

Confirm Password.
Step 4 Click Apply to save the changes.

User Access
To control the local users to access the specific groups from the Cisco DCNM Web UI, perform the following
steps:

Procedure

Step 1 Choose Administration > Management Users > Local.

The Local Users window is displayed.

Step 2 Select one user from the Local Users table. Click User Access.

The User Access selection window is displayed.

Step 3 Select the groups allowed to access for the user and click Apply.

Managing Clients
You can use Cisco DCNM to disconnect DCNM Client Servers.

Procedure

Step 1 Choose Administration > Management Users > Clients.

A list of DCNM Servers are displayed.

Step 2 Use the check box to select a DCNM server and click Disconnect Client to disconnect the DCNM server.
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You cannot disconnect a current client session.Note

Performance Setup
The Performance Setup menu includes the following submenus:

Performance Setup LAN Collections
If you are managing your switches with the Performance Manager, you must set up an initial set of flows and
collections on the switch. You can use Cisco DCNM to add and remove performance collections. License the
switch and kept it in the Managed Continuously state before creating a collection for the switch.

To add a collection, follow these steps:

Procedure

Step 1 Choose Administration > Performance Setup > LAN Collections.
Step 2 For all the licensed LAN switches, use the check boxes to enable performance data collection for Trunks,

Access, Errors & Discards, and Temperature Sensor.
Step 3 Use the check boxes to select the types of LAN switches for which you want to collect performance data.
Step 4 Click Apply to save the configuration.
Step 5 In the confirmation dialog box, click Yes to restart the performance collector.

Performance Setup Thresholds
If you are managing your switches with the Performance Manager, you must set up an initial set of flows and
collections on the switch. You can use Cisco DCNM to add and remove performance collections. License the
switch and keep it in the Managed Continuously state before creating a collection for the switch.

Procedure

Step 1 Choose Administration > Performance Setup > Thresholds.
Step 2 Under Generate a threshold event when traffic exceeds % of capacity, use the check box to specify the

Critical at and Warning at values. The range for Critical at is from 5 to 95, and the default is 80. The range
for Warning at is from 5 to 95, and the default is 60.

Step 3 Select a value for Performance Polling Interval from the drop-down list. Valid values are 5 min and 10
min, and the default is 5 min.

Step 4 Click Apply.
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Event Setup
The Event Setup menu includes the following submenus:

Viewing Events Registration
To enable Send Syslog, Send Traps and Delayed Traps you must configure the following in the DCNM
SAN client:

• Enabling Send Syslog: Choose Physical Attributes > Events > Syslog > Servers. Click Create Row,
provide the required details, and click Create.

• Enabling Send Traps: Choose Physical Attributes > Events > SNMP Traps > Destination. Click
Create Row, provide the required details, and click Create.

• Enabling Delayed Traps: Choose Physical Attributes > Events > SNMP Traps > Delayed Traps. In
the Feature Enable column, use the check boxes to enable delayed traps for the switch and specify the
delay in minutes.

Procedure

Step 1 Choose Administration > Event Setup > Registration.

The SNMP and Syslog receivers along with the statistics information are displayed.

Step 2 Check the Enable Syslog Receiver check box and click Apply, to enable the syslog receiver if it is disabled
in the server property.

To configure event registration or syslog properties, choose Administration > DCNM Server > Server
Properties and follow the on-screen instructions.

Step 3 Select Copy Syslog Messages to DB and click Apply to copy the syslog messages to the database.

If this option is not selected, the events will not be displayed in the events page of the Web client.

The columns in the second table display the following:

• Switches sending traps

• Switches sending syslog

• Switches sending syslog accounting

• Switches sending delayed traps

Notification Forwarding
You can use Cisco DCNM Web UI to add and remove notification forwarding for system messages.

This section contains the following:
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Adding Notification Forwarding
Cisco DCNM Web UI forwards fabric events through email or SNMPv1 traps.

To add and remove notification forwarding for system messages from the Cisco DCNM Web UI, perform
the following steps:

Test forwarding works only for the licensed fabrics.Note

Procedure

Step 1 Choose Administration > Event Setup > Forwarding.

The events forwarding scope, the recipient email address, severity of the event and type of the event is
displayed. The description Regex field is applicable only when the forwarding source is selected as Syslog
while adding the events forwarder.

Step 2 Check the Enable checkbox to enable events forwarding.
Step 3 Specify the SMTP Server details and the From email address.
Step 4 Click Apply to save the configuration, or in the Apply and Test icon, use the drop-down to select the fabric.

Click Apply and Test to save and test the configuration.

Step 5 In the Event Count Filter, add a filter for the event count to the event forwarder.

The forwarding stops forwarding an event if the event count exceeds the limit as specified in the event count
filter. In this field, you can specify a count limit. Before an event can be forwarded, the Cisco DCNM checks
if its occurrence exceeds the count limit. If it does, the event will not be forwarded.

Step 6 Select the Snooze checkbox and specify the Start date and time and the End date and time. Click Apply to
save the configuration.

Step 7 Under the Event Forwarder Rules table, click the + icon to add an event forwarder rule.

You see the Add Event Forwarder Rule dialog box.

Step 8 In the Forwarding Method, choose either E-mail or Trap. If you choose Trap, a Port field is added to the
dialog box.

Step 9 If you choose the E-mail forwarding method, enter the IP address in the Email Address field. If you choose
the Trap method, enter the trap receiver IP address in the Address field and specify the port number.

Step 10 For Forwarding Scope, choose the Fabric/LAN or Port Groups for notification.
Step 11 In the Source field, select DCNM or Syslog.

If you select DCNM, then:
a) From the Type drop-down list, choose an event type.
b) Check the Storage Ports Only check box to select only the storage ports.
c) From the Minimum Severity drop-down list, select the severity level of the messages to receive.
d) Click Add to add the notification.
If you select Syslog, then:
a) In the Facility list, select the syslog facility.
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b) Specify the syslog Type.
c) In the Description Regex field, specify a description that matches with the event description.
d) From the Minimum Severity drop-down list, select the severity level of the messages to receive.
e) Click Add to add the notification.

The Minimum Severity option is available only if the Event Type is set to All.Note

The traps that are transmitted by Cisco DCNM correspond to the severity type. A text description is also
provided with the severity type.
trap type(s) = 40990 (emergency)
40991 (alert)
40992 (critical)
40993 (error)
40994 (warning)
40995 (notice)
40996 (info)
40997 (debug)
textDescriptionOid = 1, 3, 6, 1, 4, 1, 9, 9, 40999, 1, 1, 3, 0

Removing Notification Forwarding
You can remove notification forwarding.

Procedure

Step 1 Choose Administration > Event Setup > Forwarding.
Step 2 Select the check box in front of the notification that you want to remove and click Delete.

Event Suppression
Cisco DCNM allows you to suppress the specified events that are based on the user-specified suppressor rules.
Such events will not be displayed on the Cisco DCNM Web UI. The events will neither be persisted to DCNM
database, nor forwarded via email or SNMP trap.

You can view, add, modify, and delete suppressor rules from the table. You can create a suppressor rule from
the existing event table. Select a given event as the template, and invoke the rule dialog window. Event details
are automatically ported from the selected event in the event table to the input fields of the rule creation dialog
window.

This section includes the following:

Add Event Suppression Rules
To add rules to the Event Suppression from the Cisco DCNM Web UI, perform the following steps:

Cisco DCNM Media Controller Configuration Guide, Release 11.0(1)
175

Administration
Removing Notification Forwarding



Procedure

Step 1 Choose Administration > Event Setup > Suppression.

The Suppression window is displayed.

Step 2 Click the Add icon above the Event Suppressors table.

The Add Event Suppressor Rule window is displayed.

Step 3 In the Add Event Suppressor Rule window, specify the Name for the rule.
Step 4 Select the required Scope for the rule that is based on the event source.

In the Scope drop-down list, the LAN groups and the port groups are listed separately. You can choose LAN,
Port Groups or Any. For LAN, select the scope of the event at the Fabric or Group or Switch level. You can
only select groups for Port Group scope. If use selects Any as the scope, the suppressor rule is applied
globally.

Step 5 Enter the Facility name or choose from the LAN Switch Event Facility List.

If you do not specify a facility, wildcard is applied.

Step 6 From the drop-down list, select the Event Type.

If you do not specify the event type, wildcard is applied.

Step 7 In the Description Matching field, specify a matching string or regular expression.

The rule matching engine uses regular expression that is supported by Java Pattern class to find a match against
an event description text.

Step 8 Check the Active Between box and select a valid time range during which the event is suppressed.

By default, the time range is not enabled, i.e., the rule is always active.

In general, you must not suppress accounting events. Suppressor rule for Accounting events can be
created only for certain rare situations where Accounting events are generated by actions of DCNM
or switch software. For example, lots of 'sync-snmp-password' AAA syslog events are automatically
generated during the password synchronization between DCNM and managed switches. To suppress
Accounting events, navigate to the Suppressor table and invoke the Add Event Suppressor Rule
dialog window.

Note

Choose Monitor > Switch > Events to create a suppressor rule for a known event. There is no such
shortcut to create suppressor rules for Accounting events.

Note

Delete Event Suppression Rule
To delete event suppressor rules from the Cisco DCNM Web UI, perform the following steps:

Procedure

Step 1 Choose Administration > Event Setup > Suppression .
Step 2 Select the rule from the list and click Delete icon.
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Step 3 Click Yes to confirm.

Modify Event Suppression Rule
To modify the event suppressor rules, do the following tasks:

Procedure

Step 1 Choose Administration > Event Setup > Suppression.
Step 2 Select the rule from the list and click Edit.

You can edit Facility, Type, Description Matching string, and Valid time range.

Step 3 Click Apply to save the changes,

Credentials Management
The Credential Management menu includes the following submenus:

LAN Credentials
While changing the device configuration, Cisco DCNM uses the device credentials provided by you. However,
if the LAN Switch credentials are not provided, Cisco DCNM prompts you to open the Administration >
Credentials Management > LAN Credentials page to configure LAN credentials.

Cisco DCNM uses two sets of credentials to connect to the LAN devices:

• Discovery Credentials—Cisco DCNM uses these credentials during discovery and periodic polling of
the devices.

• Configuration Change Credentials—Cisco DCNM uses these credentials when user tries to use the
features that change the device configuration.

LAN Credentials Management allows you to specify configuration change credentials. Before changing any
LAN switch configuration, you must furnish Configuration Change SSH credentials for the switch. If you do
not provide the credentials, the configuration change action will be rejected.

These features get the device write credentials from LAN Credentials feature.

• Upgrade (ISSU)

• Maintenance Mode (GIR)

• Patch (SMU)

• Template Deployment

• POAP-Write erase reload, Rollback

• Interface Creation/Deletion/Configuration
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• VLAN Creation/Deletion/Configuration

• VPC Wizard

You must specify the configuration change credentials irrespective of whether the devices were discovered
initially or not. This is a one-time operation. Once the credentials are set, that will be used for any configuration
change operation.

Default Credentials

Default credentials is used to connect all the devices that the user has access to. You can override the default
credentials by specifying credentials for each of the devices in the Switch Table below.

Cisco DCNM tries to use individual switch credentials in the Switch Table, to begin with. If the credentials
(username/password) columns are empty in the Switch Table, the default credentials will be used.

Switch Table

Switch table lists all the LAN switches that user has access. You can specify the switch credentials individually,
that will override the default credentials. In most cases, you need to provide only the default credentials.

You can perform the following operations on this screen.

• #unique_264 unique_264_Connect_42_section_xnr_slb_nx

• #unique_264 unique_264_Connect_42_section_njy_pmb_nx

• #unique_264 unique_264_Connect_42_section_o1f_5mb_nx

The LAN Credentials for the DCNM User table has the following fields.

DescriptionField

Displays the LAN switch name.Switch

Specifies the IP Address of the switch.IP Address

Specifies the username of the switch DCNM user.User Name

Displays the encrypted form of the SSH password.Password

Displays the group to which the switch belongs.Group

Edit Credentials

Perform the following task to edit the credentials.

1. From the Cisco DCNM home page, choose Administration > Credentials Management > LAN
Credentials, check the Switch check box for which you need to edit the credentials.

2. Click Edit icon.

3. Specify User Name and Password for the switch.
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Validate Credentials

Perform the following task to validate the credentials.

1. From the Administration > Credentials Management > LAN Credentials, check the Switch check
box for which you need to validate the credentials.

2. Click Validate.

A confirmation message appears, stating if the operation was successful or a failure.

Clear Switch Credentials

Perform the following task to clear the switch credentials.

1. From the Administration > Credentials Management > LAN Credentials, check the Switch check
box for which you need to clear the credentials.

2. Click Clear.

3. Click Yes to clear the switch credentials from the DCNM server.
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C H A P T E R 8
Applications

Cisco DCNM uses the Applications Framework to build and deploy its various functions.

The applications framework provides the following features:

• An infrastructure for hosting applications that require more system resources as the network scale
increases.

• An independent application development, deployment, and management lifecycle for applications.

In this release, Cisco DCNM uses the following applications:

• Compliance(0.1): This application helps in fabric building for the Easy Fabric installation. The Compliance
application runs as one instance per fabric. It is enabled when a fabric is created. Similarly, it is disabled
when a fabric is deleted.

• ElasticCluster(5.6): This application is used for storing various database information.

• Kibana(1.0): Kibana is an open source data visualization plug-in for Elasticsearch, which provides
visualization capabilities. Cisco DCNM uses the Kibana application for the media controller functionality.
Kibana is used for Endpoint Locator (EPL) and Telemetry.

• UTR(1.0): The Universal Telemetry Receiver (UTR) receives and decodes the streaming data from the
switches, and feeds the data to a Kafka storage. The UTR can dynamically scale and instantiate multiple
instances of UTR. It is a containerized application, which is instantiated using the Application Hosting
Framework of Cisco DCNM.

• vmmplugin(2.0): The VMM plug-in stores all the Computes and the virtual machine information that is
connected to the fabric or the switch groups that are loaded into Cisco DCNM.

In this release, the applications are view-only in the Cisco DCNM Web UI. You cannot control these
applications from the user interface. For example, you cannot start or stop these applications from theCatalog
tab of the Applications window.

Note

• Using the Applications Framework, on page 182
• Enabling the Cisco DCNM Cluster, on page 182
• Adding Computes into the Cluster Mode, on page 183
• Installing a DCNM Compute, on page 185
• Disaster Recovery, on page 185
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• Converting from Un-Cluster to Cluster Mode with Existing Elasticsearch Data, on page 186

Using the Applications Framework
To use the Applications Framework feature, from the left pane, click Applications.

The Applications window displays the following tabs:

• Catalog: This tab lists the applications that are used by Cisco DCNM. These applications are used for
performing various functions within Cisco DCNM. For example, the Elasticsearch application is used
as a database by the Telemetry feature. In this release, you will not be able to add new third-party
applications, and hence the Add applications button is disabled.

The green icon on top of the application page indicates that the application is
deployed in Cisco DCNM. If you see an amber icon within an application icon,
it indicates a problem. If you see an amber icon within the Compliance application
icon, it indicates that one of the deployed fabrics has some issues.

Note

• Compute: This tab displays the existing compute nodes. The tab shows nodes that are part of the hosting
infrastructure. The uptime indicates how long they have been part of the infrastructure. In a High
Availability setup, both the active and the standby nodes appear as Joined. In a cluster mode, the compute
nodes are also displayed indicating if they are joined or discovered.

In cluster mode, the Cisco DCNM servers will not appear in the computes tab.Note

• Health: This tab displays all the instances of an application; certain applications may have multiple
instances to extend scale. The health parameter indicates how much memory is available to applications.
The uptime indicates how long the instances have been up for.

• Preferences: This tab is relevant to the cluster mode of deployment, where the application instances are
placed. In this tab, you can enable compute cluster connectivity and configure the preferences.

Enabling the Cisco DCNM Cluster
The Compute cluster feature provides scale mechanism to serve larger fabric, more advanced features
(Telemetry, Advisories, and so on). The default status of the Cisco DCNM in any of the install modes does
not support having computes as a cluster.

Compute cluster is supported only on the LAN Fabric mode. The Classic LAN and the IP Fabric for
Media (IPFM) installations will not support the Compute cluster functionality.

Note

The values you specify in the preferences tab are not actually subnets with their gateway, rather they are IP
prefix pools of addresses that can be used within the services that run inside a container. Hovering your mouse
over the “?” button explains what is an acceptable input. Cisco DCNM Computes constantly communicates
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with DCNM Controllers; this ensures that the required applications are properly running on only the computes
that are properly functioning. In a Native-HA environment only the active DCNM initiates the compute cluster,
and standby DCNM is ready to take over in case the active fails. In Cisco DCNM 11.1(1) a maximum of three
computes are supported per DCNM Servers installation.

To enable the Compute Cluster Connectivity, perform the following steps:

Procedure

Step 1 In the left pane, click Applications.
Step 2 Click the Preferences tab.
Step 3 In the InBand Fabric field, specify the IP prefix pool to connect applications through the inband path.

InBand Fabric is required for applications that connect with switches over the Underlay or Front Panel network.
For example, EPL and Telemetry over In-Band. These IP addresses are visible outside of the compute. The
InBand subnet mask should be /24 to /28.

Step 4 In the Out-Of-Band field, specify the IP prefix pool to connect applications with the fabric management
network.

Out-Of-Band is required for applications that connect with switches over the Management network of the
switches, e.g, Telemetry. These IP addresses are visible outside of the compute. The Out-Of-Band subnet
mask should be /24 to /28.

Step 5 In the Inter Application field, specify the IP prefix pool for inter-application communication.

You can specify a pool that does not fall in either of the above subnets. Inter Application Network is not
visible outside of the DCNM cluster, it is an internal network for communication between multiple services.
But, the network should not conflict with the endpoints that the services try to reach. The Inter-Application
subnet mask should be /20 to /24.

Step 6 Click Enable.

Adding Computes into the Cluster Mode
Compute is an additional installation mode with Cisco DCNM 11.1(1). It is supported with both small and
large installations. Cisco DCNM supports a maximum of three Computes.

When a Compute is installed with correct parameters, it appears as Discovered.

To add computes into the cluster mode, perform the following steps:

Procedure

Step 1 In the left pane, click Applications.
Step 2 Click the Compute tab.
Step 3 Click the Add Compute (+) button.
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• While using Compute, ensure that Cisco DCNM GUI shows nodes as Joined.

• Offline indicates that some connectivity issues between Nodes (on Eth0).

• Health only indicates the amount of Memory left (Just like UnClustered mode).

The Compute window can also be used to monitor the health of computes. In Cisco DCNM 11.1(1), the health
essentially indicates the amount of memory left in the compute, this is based on applications that are enabled.
If a Compute is not properly communicating with the DCNM Server, the status of the Compute appears as
Offline, and no applications will be running on Offline Computes. Most applications do not function properly
if there are less than three computes, while a short loss of a single Compute node is mostly fine. In such cases,
refer to the requirements of the individual applications.

Step 4 In the Add Compute dialog box, verify the Compute IP Address, In-Band Interface, and the Out-Band
Interface fields.

Step 5 Click OK.
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Deleting a Compute
To delete a compute, perform the following steps:

Procedure

Step 1 In the left pane, click Applications.
Step 2 Click the Compute tab.
Step 3 Click the Remove (X) button.

When you delete a Compute, you will lose all the data that is stored in the Compute. You need to
be cautious while deleting a Compute, since it can cause a cluster failure, for any data stored on
Elasticsearch. If you are trying to restore a Compute, follow disaster recovery methods.

Caution

Installing a DCNM Compute

With Native HA installations, the HA status s be Ok before DCNM can be converted to cluster mode.Note

A Cisco DCNM Compute can be installed using an ISO or OVA of a regular Cisco DCNM image. It can be
deployed directly on a bare metal using an ISO or a VM using the OVA. After you deploy Cisco DCNM,
using the DCNM web installer, choose Compute as the install mode for Cisco DCNM. On a Compute VM,
you will not find DCNM processes or postgres database; it runs a minimum set of services required to provision
and monitor applications.

Follow the instructions on the Web installer to install the compute. After the compute installation is complete,
it appears as Discovered in the Applications > Compute tab. Compute will not join the cluster unless a user
with admin privileges logs into the DCNM, and adds the compute to the cluster. After it is added, the status
of the compute changes to Joined.

Disaster Recovery
The appmpgr backup operation on a compute gathers all the data that is required to re-install the compute.
Also, this operation preserves all the application data. Using the tar ball generated by the backup command,
the appmgr restore command restores all the data into the compute. This is similar to how you restore Cisco
DCNM from a backup data.

When a compute needs to be reinstalled in a disaster recovery mode, you need to restore the application data
into a new installation. It is also possible that the Cisco DCNM servers need to be restored into a new server.
You may find the following scenarios:

• Cisco DCNM Controllers need to be recovered

• Cisco DCNM Computes need to recovered

• Cisco DCNM Controllers and Computes need to be recovered
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Scenario 1

You can use SSH to access the computes as root, and enter the appmgr stop afw command on each of the
compute nodes. Now, the DCNM controllers can be powered off and restored onto a new DCNM Installation.

After the restore of the DCNM controllers is complete, verify that DCNM controller is completely up and the
Applications screen is loading. Verify that all computes are showing up as offline. Now, enter the appmgr
start afw command on each of the computes. After a while ensure all the applications are running and Computes
are showing as “Joined”.

Scenario 2

In this case, enter the appmgr stop afw command on the compute that is being restored, after the compute
shows offline in the Compute tab. Restore the compute on a new installation.

Perform one restore after the other.

Scenario 3

In this case, first perform scenario 1, and then perform scenario 2.

Converting from Un-Cluster to Cluster Mode with Existing
Elasticsearch Data

Every time Cisco DCNM is converted from un-clustered to clustered, run the steps mentioned below to rebuild
the database schema and preserve the Elasticsearch data.

Note

Read through the complete procedure before proceeding with the Cluster mode conversion.

To convert from un-cluster to cluster mode, perform the following steps.

Procedure

Step 1 From the left pane, choosePreferences, and then click the Preferences tab.
Step 2 Take backup of the Elasticsearch data by executing the appmgr afw backup-es command.

• If the setup is HA, repeat the step on DCNM Standby.

Step 3 Copy the tarball file produced from Step 2 to Compute 1.

• If the setup is HA, copy the tarball file on DCNM Standby to Compute 2.

Step 4 Restore the Elasticsearch data by executing the appmgr afw restore-es $tarball command on the Compute
node, where $tarball is the location of the tarball file copied in Step 3.

• If the setup is HA, repeat the step on Compute 2.

Step 5 Proceed with adding the Compute nodes. Ensure that Compute 1 is added before Compute 2.
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• If the setup is HA, ensure that Compute 2 is added before the rest of the computes (except for Compute
1).
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