S Commands
This chapter describes the Cisco Nexus 1000V commands that begin with the letter S.
send
To send a message to an open session, use the send command.
send { message | session message }
Syntax Description
message |
Message. The message has a maximum length of one line. |
session |
Specifies a specific session. |
Command Modes
Any
network-admin
network-operator
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to send a message to an open session:
n1000v# send session sessionOne testing
Related Commands
|
|
show banner |
Displays a banner. |
server
To configure the Remote Access Dial-In User Service (RADIUS) server as a member of the RADIUS server group, use the server command. To remove a server, use the no form of this command.
server { ipv4-address | server-name }
no server { ipv4-address | server-name }
Syntax Description
ipv4-address |
IPV4 address of the RADIUS server. |
server-name |
RADIUS server name. The name is alphanumeric, case sensitive, and has a maximum of 256 characters. |
Command Modes
Radius configuration (config-radius)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure the RADIUS server as a member of the RADIUS server group:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# aaa group server radius RadServer
n1000v(config-radius)# server 10.10.1.1
This example shows how to remove the server configuration:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# aaa group server radius RadServer
n1000v(
config)#
no server 10.10.1.1
Related Commands
|
|
aaa group server radius |
Creates a RADIUS server group and enters the RADIUS server group configuration submode for that group. |
deadtime |
Configures the monitoring dead time. |
show radius-server groups |
Displays the RADIUS server group configuration. |
use-vrf |
Specifies the VRF instance to use to contact the servers in the server group. |
session-limit
To limit the number of virtual shell (VSH) sessions, use the session-limit command. To remove the limit, use the no form of this command.
session-limit number
no session-limit number
Syntax Description
number |
Number of VSH sessions. The range is from 1 to 64 |
Defaults
No limit is set.
Command Modes
Line configuration (config-line)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to limit the number of VSH sessions:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config-line)# session-limit 10
This example shows how to remove the limit:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config-line)# no session-limit 10
setup
To use the Basic System Configuration Dialog (BSCD) for creating or modifying a configuration file, use the setup command.
setup
Syntax Description
This command has no arguments or keywords, but the BSCD prompts you for complete setup information (see the example below).
Command Modes
Any
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
The BSCD assumes the factory defaults.
All changes made to your configuration are summarized for you at the completion of the setup sequence with an option to save the changes or not.
You can exit the setup sequence at any point by pressing Ctrl-C.
Examples
This example shows how to create or modify a basic system configuration:
Enter the domain id<1-1023>: 400
Enter HA role[standalone/primary/secondary]: standalone
[########################################] 100%
---- Basic System Configuration Dialog ----
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
Would you like to enter the basic configuration dialog (yes/no): y
Create another login account (yes/no) [n]: n
Configure read-only SNMP community string (yes/no) [n]: n
Configure read-write SNMP community string (yes/no) [n]: n
Enter the switch name : n1000v
Continue with Out-of-band (mgmt0) management configuration? (yes/no) [y]:
Configure the default gateway? (yes/no) [y]: n
Configure advanced IP options? (yes/no) [n]:
Enable the telnet service? (yes/no) [y]:
Enable the ssh service? (yes/no) [n]:
Configure the ntp server? (yes/no) [n]:
Configure vem feature level? (yes/no) [n]:
The following configuration will be applied:
switchname n1000v
telnet server enable
no feature ssh
feature http-server
svs-domain
no control vlan
no packet vlan
svs mode L3 interface mgmt0
domain id 400
Would you like to edit the configuration? (yes/no) [n]:
Use this configuration and save it? (yes/no) [y]: n
Related Commands
|
|
show running-config |
Displays the running configuration. |
shutdown (VLAN)
To shut down switching on a VLAN, use the shutdown command. To turn on switching, use the no form of this command.
shutdown
no shutdown
Syntax Description
This command has no arguments or keywords.
Command Modes
VLAN configuration (config-vlan)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
You cannot shut down the default VLAN, VLAN1, or VLANs 1006 to 4094.
Examples
This example shows how to shut down switching on VLAN 10:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config-vlan)# shutdown
This example shows how to turn on switching on VLAN 10:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config-vlan)# no shutdown
Related Commands
|
|
show vlan |
Displays VLAN information. |
shutdown (interface)
To disable an interface, use the shutdown command. To enable an interface, use the no form of this command.
shutdown [ force ]
no shutdown [ force ]
Syntax Description
force |
(Optional) Administratively enables or disables an interface. |
Command Modes
Interface configuration (config-if)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
This command shuts down the interface. No traffic passes and the interface displays as administratively down.
Examples
This example shows how to administratively disable Ethernet interface 3/1:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface ethernet 3/1
n1000v(config-if)# shutdown
This example shows how to administratively enable Ethernet interface 3/1:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface ethernet 3/1
n1000v(config-if)# no shutdown
Related Commands
|
|
interface ethernet |
Creates an Ethernet interface configuration. |
interface vethernet |
Creates a virtual Ethernet interface configuration. |
show interface |
Displays the interface configuration. |
shutdown (port profile)
To disable all ports in a port profile, use the shutdown command. To enable ports in a port profile, use the no form of this command.
shutdown [ force ]
no shutdown [ force ]
Syntax Description
force |
(Optional) Administratively enables or disables all ports in the profile. |
Defaults
all ports administratively disabled
Command Modes
Port profile configuration (config-port-prof)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
This command administratively disables all ports in the profile. No traffic passes and the ports display as administratively down.
Examples
This example shows how to administratively enable all ports in the TrunkProf port profile:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# port-profile TrunkProf
n1000v(config-port-prof)# no shutdown
n1000v(config-port-prof)#
This example shows how to administratively disable all ports in the TrunkProf port profile:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# port-profile TrunkProf
n1000v(config-port-prof)# shutdown
n1000v(config-port-prof)#
Related Commands
|
|
port-profile |
Creates a port profile configuration. |
show port-profile name |
Displays the named port profile configuration. |
sleep
To set a sleep time, use the sleep command.
sleep time
Syntax Description
time |
Sleep time. The range is from 0 to 2147483647 seconds. |
Defaults
Sleep time is not set.
Command Modes
Any
network-admin
network-operator
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
When you set time to 0, sleep is disabled.
Examples
This example shows how to set a sleep time:
This example shows how to disable sleep:
snmp-server aaa-user cache-timeout
To configure how long the accounting, authorization, and authentication (AAA) synchronized user configuration stays in the local cache, use the snmp-server aaa-user cache-timeout command. To revert back to the default value of 3600 seconds, use the no form of this command.
snmp-server user aaa-user cache-timeout seconds
no snmp-server user aaa-user cache-timeout seconds
Syntax Description
seconds |
Length of the time for the user configuration to remain in the local cache. The range is from 1 to 86400 seconds. |
Defaults
The default timeout is 3600 seconds.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure the AAA synchronized user configuration to stay in the local cache for 1200 seconds:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)# snmp-server aaa-user cache-timeout 1200
This example shows how to revert back to the default value of 3600 seconds:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server aaa-user cache-timeout 1200
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server contact |
Configures sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces the SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables the SNMP protocol. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server community
To create an Simple Network Management Protocol (SNMP) community string, use the snmp-server community command. To remove the community, use the no form of this command.
snmp-server community string [ group group-name ] [ ro | rw | use-acl acl-name ]
no snmp-server community string [ group group-name ] [ ro | rw | use-acl acl-name ]
Syntax Description
string |
SNMP community string, which identifies the community. The string has a maximum size of 32 case sensitive, alphanumeric characters. |
group group-name |
(Optional) Specifies a group to which this community belongs. Group name. The group name has a maximum size of 32 case sensitive, alphanumeric characters. |
ro |
(Optional) Specifies read-only access for this community. |
rw |
(Optional) Specifies read-write access for this community. |
use-acl acl-name |
(Optional) Specified an access control list (ACL) to filter SNMP requests. ACL name. The maximum size is 32 case sensitive, alphanumeric characters. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
You can create SNMP communities for SNMPv1 or SNMPv2c.
Examples
This example shows how to configure read-only access for the SNMP community called public:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)# snmp-server community public ro
This example shows how to remove the SNMP community called public:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server community public
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA-synchronized user configuration stays in the local cache. |
snmp-server community |
Creates an SNMP community string and assigns access privileges for the community. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server contact
To configure the sysContact, which is the Simple Network Management Protocol (SNMP) contact name, use the snmp-server contact command.
To remove or modify the sysContact, use the no form of this command.
snmp-server contact [ name ]
no snmp-server contact [ name ]
Syntax Description
name |
(Optional) SNMP contact name (sysContact), which can contain a maximum of 32 characters. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
You can create SNMP communities for SNMPv1 or SNMPv2c.
Examples
This example shows how to configure the sysContact to be Admin:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)# snmp-server contact Admin
This example shows how to remove the sysContact:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server contact
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA-synchronized user configuration stays in the local cache. |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server globalEnforcePriv
To enforce Simple Network Management Protocol (SNMP) message encryption for all users, use the snmp-server globalEnforcePriv command.
snmp-server globalEnforcePriv
Syntax Description
This command has no arguments or keywords.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enforce SNMP message encryption for all users:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)#
snmp-server globalEnforcePriv
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact, (the SNMP contact). |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server host
To configure a host receiver for Simple Network Management Protocol Version 1 (SNMPv1) or SNMPv2c traps, use the snmp-server host command. To remove the host, use the no form of this command.
snmp-server host ip-address { traps | informs }{ version { 1 | 2c | 3 }} [ auth | noauth | priv ] community [ udp_port number ]
no snmp-server host ip-address { traps | informs } { version { 1 | 2c | 3 }} [ auth | noauth | priv ] community [ udp_port number ]
Syntax Description
ip-address |
IPv4 address, IPv6 address, or Domain Name System (DNS) of the SNMP notification host. |
informs |
Specifies Inform messages to this host. |
traps |
Specifies Traps messages to this host. |
version |
Specifies the SNMP version to use for notification messages. |
1 |
Specifies SNMPv1 as the version. |
2c |
Specifies SNMPv2c as the version. |
3 |
Specifies SNMPv3 as the version. |
auth |
(Optional) Specifies (for SNMPv3) the authNoPriv Security Level. |
noauth |
(Optional) Specifies (for SNMPv3) the noAuthNoPriv Security Level. |
priv |
(Optional) Specifies (for SNMPv3) the authPriv Security Level. |
community |
SNMPv1/v2c community string or SNMPv3 user name. The community string can be any alphanumeric string up to 255 characters. |
udp-port number |
(Optional) Specifies an existing User Datagram Protocol (UDP) port. Number that identifies the UDP port of the notification host. The range is from 0 to 65535. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure the host receiver, 192.0.2.1, for SNMPv1 traps:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# snmp-server host 192.0.2.1 traps version 1 public
This example shows how to remove the configuration:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server host 192.0.2.1 traps version 1 public
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server location
To configure the sysLocation, which is the Simple Network Management Protocol (SNMP) location name, use the snmp-server location command.
To remove the sysLocation, use the no form of this command.
snmp-server location [ name ]
no snmp-server location [ name ]
Syntax Description
name |
(Optional) SNMP location name (sysLocation). The name can contain a maximum of 32 characters. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure the sysLocation to be Lab-7:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)# snmp-server location Lab-7
This example shows how to remove the sysLocation:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server location
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server protocol enable
To enable Simple Network Management Protocol (SNMP) protocol operations, use the snmp-server protocol enable command. To disable SNMP protocol operations, use the no form of this command.
snmp-server protocol enable
no snmp-server protocol enable
Syntax Description
This command has no arguments or keywords.
Defaults
This command is enabled by default.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable SNMP protocol operations:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)#
snmp-server protocol enable
This example shows how to disable SNMP protocol operations:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)#
no snmp-server protocol enable
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server tcp-session
To enable authentication for Simple Network Management Protocol (SNMP) over TCP, use the snmp-server tcp-session command. To disable authentication for SNMP over TCP, use the no form of this command.
snmp-server tcp-session [ auth ]
no snmp-server tcp-session
Syntax Description
auth |
(Optional) Enables one-time authentication for SNMP over the entire TCP session (rather than on a per-command basis). |
Defaults
This command is disabled by default.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable one-time authentication for SNMP over TCP:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)#
snmp-server tcp-session auth
This example shows how to disable one-time authentication for SNMP over TCP:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)#
no snmp-server tcp-session
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server user |
Configures an SNMP user with authentication and privacy parameters. |
snmp-server user
To define a user who can access the Simple Network Management Protocol (SNMP) engine, use the snmp-server user command. To deny a user access to the SNMP engine, use the no form of this command.
snmp-server user name [ auth { md5 | sha } passphrase-1 [ priv [ aes-128 ] passphrase-2 ] [ engineID id ] [ localizedkey ]]
no snmp-server user name
Syntax Description
name |
SNMP engine user name. The user name is not case-sensitive and can be up to 28 characters. |
auth |
(Optional) Enables one-time authentication for SNMP over a TCP session |
md5 |
Specifies a keyed-hash message authentication code (HMAC) Message Digest (MD)5 algorithm for authentication. |
sha |
Specifies HMAC Secure Hash Algorithm (SHA) for authentication. |
passphrase-1 |
Authentication passphrase for this user. The passphrase can be any case-sensitive, alphanumeric string of up to 64 characters. |
priv |
(Optional) Specifies encryption parameters for the user. |
aes-128 |
(Optional) Specifies a 128-byte Advanced Encryption Standard (AES) algorithm for privacy. |
passphrase-2 |
Encryption passphrase for this user. The passphrase can be any case-sensitive, alphanumeric string up to 64 characters. |
engineID |
(Optional) Specifies the engineID for configuring the notification target user (for V3 informs). |
id |
EngineID. The ID is in a 12-digit, colon-separated decimal format. |
localizedkey |
(Optional) Specifies the passphrase as any case-sensitive, alphanumeric string of up to 130 characters. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to provide one-time SNMP authorization for the user, Admin, using the HMAC SHA algorithm for authentication:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)# snmp-server user Admin auth sha abcd1234 priv abcdefgh
This example shows how to deny a user access to the SNMP engine:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no snmp-server user Admin
Related Commands
|
|
show snmp |
Displays SNMP information. |
snmp-server aaa-user cache-timeout |
Configures how long the AAA synchronized user configuration stays in the local cache. |
snmp-server contact |
Configures the sysContact (the SNMP contact). |
snmp-server globalEnforcePriv |
Enforces SNMP message encryption for all users. |
snmp-server host |
Configures a host receiver for SNMP traps or informs. |
snmp-server location |
Configures the sysLocation (the SNMP location). |
snmp-server protocol enable |
Enables SNMP. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
snmp trap link-status
To enable Simple Network Management Protocol (SNMP) link-state traps for the interface, use the snmp trap link-status command. To disable SNMP link-state traps for the interface, use the no form of this command.
snmp trap link-status
no snmp trap link-status
Syntax Description
This command has no arguments or keywords.
Command Modes
CLI interface configuration (config-if)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
This command is enabled by default.
Examples
This example shows how to enable SNMP link-state traps for the interface:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface veth 2
n1000v(config-if)# snmp trap link-status
This example shows how to disable SNMP link-state traps for the interface:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface veth 2
n1000v(config-if)# no snmp trap link-status
Related Commands
|
|
interface vethernet |
Creates a virtual Ethernet interface and enters interface configuration mode. |
snmp-server enable traps |
Enables all SNMP notifications. |
snmp-server tcp-session |
Enables a one-time authentication for SNMP over a TCP session. |
source-interface
To specify a source interface for reaching a Remote Access Dial-In User Service (RADIUS) or Terminal Access Controller Access Control System Plus (TACACS+) server group, use the source-interface command. To remove the source interface, use the no form of this command.
source-interface interface-type interface-id
no source-interface
Syntax Description
interface-type |
Interface type:
- loopback = Loopback interface
- mgmt = Management interface
- null = Null interface
- port-channel = Port Channel interface
|
interface-id |
Interface ID, such as the slot/port or number:
- loopback = Virtual interface number from 0 to 1023
- mgmt = Management interface 0
- null = Null interface 0
- port-channel = Port channel number from 1 to 4096
|
Command Modes
RADIUS server group configuration (config-radius)
TACACS+ server group configuration (config-tacacs+)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to specify source interface mgmt0 to reach the RADIUS server for the RadServer RADIUS server group:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# aaa group server radius RadServer
n1000v(
config-radius)#
source-interface mgmt0
This example shows how to remove the source interface from the configuration:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# aaa group server radius RadServer
n1000v(
config-radius)#
no source-interface
Related Commands
|
|
aaa group server radius |
Creates a RADIUS server group. |
aaa group server tacacs+ |
Creates a TACACS+ server group. |
show radius-server groups |
Displays the RADIUS server group configuration. |
show tacacs-server groups |
Displays the TACACS+ server group configuration. |
source lc-exp (NetFlow)
To add an IP address to a flow exporter that designates it as the source for NetFlow flow records, use the source lc-exp command. To remove the source interface from the flow exporter, use the no form of this command.
source lc-exp ip_address
no source lc-exp ip_address
Syntax Description
ip_address |
Exporter IP address in the format A.B.C.D/LEN. |
Command Modes
NetFlow flow exporter configuration ( config-flow-exporter)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to add a source IP to the ExportTest flow exporter:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# flow exporter ExportTest
n1000v(config-flow-exporter)# source lc-exp 10.105.225.180/27
This example shows how to remove a source IP from the ExportTest flow exporter:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# flow exporter ExportTest
n1000v(config-flow-exporter)# no source lc-exp 10.105.225.180/27
Related Commands
|
|
flow exporter |
Creates a Flexible NetFlow flow exporter. |
flow monitor |
Creates a Flexible NetFlow flow monitor. |
flow record |
Creates a Flexible NetFlow flow record. |
show flow exporter |
Displays information about the NetFlow flow exporter. |
show flow monitor |
Displays information about the NetFlow flow monitor. |
show flow record |
Displays information about NetFlow flow records. |
speed
To set the speed for an interface, use the speed command. To automatically set both the speed and duplex parameters to auto, use the no form of this command.
speed { 10 | 100 | 1000 | auto [ 10 [100 [1000 ]]]}
no speed { 10 | 100 | 1000 | auto [ 10 [100 [1000 ]]]}
Syntax Description
10 |
Speed of 10 Mbps. Optional when used with auto. |
100 |
Speed of 100 Mbps. Optional when used with auto. |
1000 |
Speed of 1 Gbps. Optional when used with auto. |
auto |
Sets the interface to autonegotiate the speed with the connecting port. |
Command Modes
Interface configuration (config-if)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
If you configure an Ethernet port speed to a value other than auto (for example, 10, 100, or 1000 Mbps), you must configure the connecting port to match. Do not configure the connecting port to negotiate the speed.
Examples
This example shows how to set the speed of Ethernet port 1 on the module in slot 3 to 1000 Mbps:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface ethernet 2/1
n1000v(config-if)# speed 1000
This example shows how to automatically set the speed to auto:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface ethernet 2/1
n1000v(config-if)# no speed 1000
Related Commands
|
|
duplex |
Specifies the duplex mode as full, half, or autonegotiate. |
interface |
Specifies the interface that you are configuring. |
show interface |
Displays the interface status, which includes the speed and duplex mode parameters. |
ssh
To create a Secure Shell (SSH) session, use the ssh command.
ssh [ username @ ]{ ipv4-address | hostname } [ vrf vrf-name ]
Syntax Description
username |
(Optional) Username for the SSH session. The user name is not case-sensitive and can be up to 64 characters. |
ipv4-address |
IPv4 address of the remote device. |
hostname |
Hostname of the remote device. The hostname is case sensitive. |
vrf vrf-name |
(Optional) Specifies a virtual routing and forwarding (VRF) name to use for the SSH session. VRF name. The name is a maximum of 32 case-sensitive, alphanumeric characters. |
Command Modes
Any
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
The Cisco Nexus 1000V software supports SSH version 2.
Examples
This example shows how to start an SSH session:
n1000v# ssh 10.10.1.1 vrf management
The authenticity of host '10.10.1.1 (10.10.1.1)' can't be established.
RSA key fingerprint is 9b:d9:09:97:f6:40:76:89:05:15:42:6b:12:48:0f:d6.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.10.1.1' (RSA) to the list of known hosts.
Related Commands
|
|
clear ssh session |
Clears SSH sessions. |
feature ssh |
Enables the SSH server. |
ssh key
To generate the key pair for the switch, which is used if the Secure Shell (SSH) server is enabled, use the ssh key command. To remove the SSH server key, use the no form of this command.
ssh key { dsa [ force ] | rsa [ length [ force ]]}
no ssh key [ dsa | rsa ]
Syntax Description
dsa |
Specifies the Digital System Algorithm (DSA) SSH server key. |
force |
(Optional) Forces the replacement of an SSH key. |
rsa |
Specifies the Rivest, Shamir, and Adelman (RSA) public-key cryptography SSH server key. |
length |
(Optional) Bits to use when creating the SSH server key. The range is from 768 to 2048. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
The Cisco Nexus 1000V software supports SSH version 2.
If you want to remove or replace an SSH server key, you must first disable the SSH server using the no feature ssh command.
Examples
This example shows how to create an SSH server key using DSA:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# ssh key dsa
generating dsa key(1024 bits).....
This example shows how to create an SSH server key using RSA with the default key length:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# ssh key rsa
generating rsa key(1024 bits).....
This example shows how to create an SSH server key using RSA with a specified key length:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# ssh key rsa 768
generating rsa key(768 bits).....
This example shows how to replace an SSH server key using DSA with the force option:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no feature ssh
n1000v(config)# ssh key dsa force
deleting old dsa key.....
generating dsa key(1024 bits).....
n1000v(config)# feature ssh
This example shows how to remove the DSA SSH server key:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no feature ssh
XML interface to system may become unavailable since ssh is disabled
n1000v(config)# no ssh key dsa
n1000v(config)# feature ssh
This example shows how to remove all SSH server keys:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no feature ssh
XML interface to system may become unavailable since ssh is disabled
n1000v(config)# no ssh key
n1000v(config)# feature ssh
Related Commands
|
|
feature ssh |
Enables the SSH server. |
show ssh key |
Displays the SSH server key information. |
state (Port Profile)
To set the operational state of a port profile, use the state command.
state enabled
Syntax Description
enabled |
Enables or disables the port profile. |
Command Modes
Port profile configuration (config-port-prof)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable or disable the operational state of a port profile:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# port-profile testprofile
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)#
Related Commands
|
|
show port-profile |
Displays port profile information. |
sub-group-id
To configure subgroup IDs for Ethernet member ports of vPC-HM, use the sub-group-id command. To remove the subgroup IDs, use the no form of this command.
sub-group-id group_id
no sub-group-id
Syntax Description
group_id |
Subgroup ID number. The range is from 0 to 31. |
Command Modes
Interface configuration (config-if)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure an Ethernet member port on subgroup 5:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface Ethernet 3/2
n1000v(config-if)# sub-group-id 1
This example shows how to remove the configuration:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# interface Ethernet 3/2
n1000v(config-if)# no sub-group-id
Related Commands
|
|
show interface ethernet |
Displays information about Ethernet interfaces. |
svs-domain
To configure a software virtual switch (SVS) domain and enter the SVS domain configuration mode, use the svs-domain command.
svs - domain {control | domain | no | packet | svs | switch-guid | end | exit | pop | push | where}
Syntax Description
control |
Configures a control VLAN number. |
domain |
Configures a domain ID. |
no |
Negates a command or sets its defaults. |
packet |
Configures a packet VLAN number. |
svs |
Configures the SVS. |
switch-guid |
Configures a switch-guid. |
end |
Go to EXEC mode. |
exit |
Exit from the command interpreter. |
pop |
Pop a mode from the stack or restore it from name. |
push |
Push the current mode to the stack or save it under name. |
where |
Displays the command-line interface (CLI) context you are in. |
Command Modes
SVS domain configuration (config-svs-domain)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enter SVS domain configuration mode:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs-domain
n1000v(config-svs-domain)#
This example shows how to enter the SVS domain and show the CLI context:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs-domain
n1000v(config-svs-domain)# where
conf; svs-domain admin@n1000v
n1000v(config-svs-domain)#
Related Commands
|
|
show svs |
Displays SVS information. |
svs license transfer src-vem
To transfer licenses from a specified source Virtual Ethernet Module (VEM) to another VEM, or to transfer an unused license to the Virtual Supervisor Module (VSM) license pool, use the svs license transfer src-vem command.
svs license transfer src-vem module number [ dst-vem module number | license_pool ]
Syntax Description
module-number |
Module number. The range is from 3 to 66. |
dst-vem |
(Optional) Specifies the VEM to receive the transferred license. |
license_pool |
Transfers a license back to the VSM license pool. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
Follow these guidelines:
- Licenses cannot be transferred to a VEM unless there are sufficient licenses in the pool for all CPUs on that VEM.
- When licenses are successfully transferred from one VEM to another, the following occurs:
–
The virtual Ethernet interfaces on the source VEM are removed from service.
–
The virtual Ethernet interfaces on the destination VEM are brought into service.
- When licenses are successfully transferred from a VEM to the VSM license pool, the virtual Ethernet interfaces on the source VEM are removed from service.
Examples
This example shows how to transfer a license from VEM 3 to VEM 5 and then display the license configuration:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs license transfer src-vem 3 dst-vem 5
n1000v(config)# show license usage NEXUS1000V_LAN_SERVICES_PKG
This example shows how to transfer a license from VEM 3 to the VSM license pool and then display the license configuration:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs license transfer src-vem 3 license_pool
n1000v(config)# show license usage NEXUS1000V_LAN_SERVICES_PKG
Related Commands
|
|
install license |
Installs a license file(s) on a VSM. |
logging level license |
Designates the level of severity at which license messages should be logged. |
show license usage |
Displays the number and location of CPU licenses in use on your VEMs. |
svs license volatile |
Enables volatile licenses so whenever a VEM is taken out of service, its licenses are returned to the VSM pool of available licenses. |
svs license volatile
To enable volatile licenses so whenever a Virtual Ethernet Module (VEM) is taken out of service, its licenses are returned to the Virtual Supervisor Module (VSM) pool of available licenses, use the svs license volatile command. To disable volatile licenses, use the no form of this command.
svs license volatile
no svs license volatile
Syntax Description
This command has no arguments or keywords.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
Caution
Service Disruption
Volatile licenses are removed from a VEM during a loss in connectivity and are not returned to the VEM when connectivity resumes. We recommend that the volatile license feature remain disabled and that you transfer unused licenses by using the svs license transfer src-vem command.
Examples
This example shows how to enable the volatile license feature for a VSM:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs license volatile
This example shows how to disable the volatile license feature for a VSM:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)#
no svs license volatile
Related Commands
|
|
install license |
Installs a license file(s) on a VSM. |
logging level license |
Designates the level of severity at which license messages should be logged. |
show license |
Displays the license configuration for the VSM. |
svs license transfer src-vem |
Transfers licenses from a source VEM to another VEM or to the VSM pool of available licenses. |
svs mode l3 interface
To configure Layer 3 as the transport mode for the Virtual Supervisor Module (VSM) domain and configure the Layer 3 transport interface, use the svs mode l3 interface command.
svs mode l3 interface { mgmt0 | control0 }
Syntax Description
mgmt0 |
Specifies mgmt0 as the Layer 3 transport interface. |
control0 |
Specifies control0 as the Layer 3 transport interface. |
Command Modes
Software virtual switch (SVS) domain configuration (config-svs-domain)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
If you use mgmt0 as the Layer 3 control interface in the VSM VM, Ethernet adapters 1 and 3 are not used.
If you use control0 as the Layer 3 control interface in the VSM VM, Ethernet adapter 3 is not used.
Examples
This example shows how to configure mgmt0 as the Layer 3 transport interface for the VSM domain:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs-domain
n1000v(config-svs-domain)# svs mode l3 interface mgmt0
n1000v(config-svs-domain)#
Related Commands
|
|
show svs-domain |
Displays the VSM domain configuration. |
svs-domain |
Creates and configures the VSM domain. |
svs veth auto-config-purge
To enable the Virtual Supervisor Module (VSM) to remove all manual configuration on a virtual Ethernet interface when the system administrator changes a port profile on the interface, use the svs veth auto-config-purge command. To remove this control, use the no form of this command.
svs veth auto-config-purge
no svs veth auto-config-purge
Syntax Description
This command has no arguments or keywords.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable the VSM to remove all manual configuration on a virtual Ethernet interface when the system administrator changes a port profile on the interface :
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs veth auto-config-purge
This example shows how to remove the configuration:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no svs veth auto-config-purge
Related Commands
|
|
interface vethernet |
Creates a virtual Ethernet interface. |
show interface vethernet |
Displays information about virtual Ethernet interfaces. |
show running-config |
Displays information about the configuration currently running on the system. |
svs veth auto-delete |
Enables the VSM to automatically delete Distributed Virtual Port (DVPorts) that are no longer used by a vNIC or hypervisor port. |
svs veth auto-setup |
Enables the VSM to automatically create a virtual Ethernet interface when a new port is activated on a host. |
svs veth auto-delete
To e nable the Virtual Supervisor Module (VSM) to automatically delete Distributed Virtual Port (DVPorts) that are no longer used by a virtual network interface card (vNIC) or hypervisor port, use the svs veth auto-delete command. To disable this control, use the no form of this command.
svs veth auto-delete
no svs veth auto-delete
Syntax Description
This command has no arguments or keywords.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable the VSM to automatically delete DVPorts that are no longer used by a vNIC or hypervisor port :
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# svs veth auto-delete
This example shows how to disable the automatic deletion of DVPorts that are no longer used by a vNIC or hypervisor port :
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no svs veth auto-delete
Related Commands
|
|
interface vethernet |
Creates a virtual Ethernet interface. |
show interface vethernet |
Displays information about virtual Ethernet interfaces. |
show running-config |
Displays information about the configuration that is currently running on the system. |
svs veth auto-config-purge |
Enables the VSM to remove all manual configuration on a virtual Ethernet interface when the system administrator changes a port profile on the interface. |
svs veth auto-setup |
Enables the VSM to automatically create a virtual Ethernet interface when a new port is activated on a host. |
svs veth auto-setup
To enable the Virtual Supervisor Module (VSM) to automatically create a virtual Ethernet interface when a new port is activated on a host, use the svs veth auto-setup command. To remove this control, use the no form of this command.
svs veth auto-setup
no svs veth auto-setup
Syntax Description
This command has no arguments or keywords.
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to create a virtual Ethernet interface when a new port is activated on a host :
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)#
svs veth auto-setup
This example shows how to remove a virtual Ethernet interface when a new port is activated on a host :
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(
config)#
no svs veth auto-setup
Related Commands
|
|
interface vethernet |
Creates a virtual Ethernet interface. |
show interface vethernet |
Displays information about virtual Ethernet interfaces. |
show running-config |
Displays information about the configuration that is currently running on the system. |
svs veth auto-config-purge |
Enables the VSM to remove all manual configuration on a virtual Ethernet interface when the system administrator changes a port profile on the interface. |
svs veth auto-delete |
Enables the VSM to automatically delete DVPorts that are no longer used by a vNIC or hypervisor port. |
switchname
To configure the hostname for the device, use the switchname command. To revert to the default, use the no form of this command.
switchname name
no switchname
Syntax Description
name |
Device name. The name is alphanumeric, case-sensitive, it can contain special characters, and can have a maximum of 32 characters. |
Command Modes
Global configuration (config)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
The Cisco Nexus 1000V software uses the hostname in command-line interface (CLI) prompts and in default configuration filenames.
The switchname command performs the same function as the hostname command.
Examples
This example shows how to configure the device hostname:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# switchname Engineering2
This example shows how to revert to the default device hostname:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# no switchname
Related Commands
|
|
hostname |
Configures the device hostname. |
show switchname |
Displays the device hostname. |
switchport access vlan
To set the access mode of an interface, use the switchport access vlan command. To remove access mode configuration, use the no form of this command.
switchport access vlan id
no switchport access vlan
Syntax Description
id |
VLAN identification number. The range is from 1 to 3967. |
Defaults
Access mode is not set.
Command Modes
Interface configuration (config-if)
Network segment configuration (config-net-seg)
network-admin
Note
VLAN configuration must be done only via network segments.
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to set the access mode of an interface:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment vlan_800
n1000v(config-net-seg)# switchport access vlan 800
This example shows how to remove the access mode configuration:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment vlan_800
n1000v(config-net-seg)# no switchport access vlan 800
Related Commands
|
|
show interface |
Displays interface information. |
show nsm |
Displays NSM information. |
switchport mode (network segment)
To set the port mode of an interface, use the switchport mode command. To remove the port mode configuration, use the no form of this command.
switchport mode access
no switchport mode access
Syntax Description
access |
Sets the port mode to access. |
trunk |
Sets the port mode to trunk. |
Defaults
Switchport mode is not set.
Command Modes
Interface configuration (config-if)
Network segment configuration (config-net-seg)
network-admin
Note
VLAN configuration must be done only via network segments.
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to set the network segment mode to an access VLAN:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment vlan_host
n1000v(config-net-seg)# switchport mode access
This example shows how to remove the network segment mode community VLAN:
n1000v#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment vlan_host
n1000v(config-net-seg)# no switchport mode access
Related Commands
|
|
show interface |
Displays interface information. |
show nsm network segment |
Displays NSM network segment information. |
switchport trunk allowed vlan
To set the list of allowed VLANs on the trunking interface, use the switchport trunk allowed vlan command. To allow all VLANs on the trunking interface, use the no form of this command.
switchport trunk allowed vlan { vlan-list | all | none | [ add | except | remove { vlan-list }]}
no switchport trunk allowed vlan
Syntax Description
vlan-list |
VLANs (allowed) that transmit through this interface in tagged format when in trunking mode. The range is from 1 to 4094. |
all |
Allows all appropriate VLANs to transmit through this interface in tagged format when in trunking mode. |
none |
Blocks all VLANs transmitting through this interface in tagged format when in trunking mode. |
add |
(Optional) Adds the defined list of VLANs to those currently set instead of replacing the list. |
except |
(Optional) Allows all VLANs to transmit through this interface in tagged format when in trunking mode except the specified values. |
remove |
(Optional) Removes the defined list of VLANs from those currently set instead of replacing the list. |
Command Modes
Interface configuration (config-if)
Port profile configuration (config-port-prof)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
If you remove VLAN 1 from a trunk, the trunk interface continues to send and receive management traffic in VLAN 1.
Note
This command is auto generated by the network segmentation manager (NSM). The user should not run this command directly for configuration or any other purposes.
Examples
This example shows how to display a
list of allowed VLANs on the trunking interface :
n1000v#
show running-config port-profile vic-uplink
!Command: show running-config port-profile vic-uplink
!Time: Fri May 24 03:28:00 2013
port-profile type ethernet vic-uplink
inherit port-profile vmdata-vpc-mac
guid 1d8703cd-40b4-4848-867d-296be908921e
description NSM created profile. Do not delete.
Related Commands
|
|
show interface switchport |
Displays the administrative and operational status of a switching (nonrouting) port. |
switchport trunk native vlan
To configure trunking parameters on an interface, use the switchport trunk native vlan command. To remove the configuration, use the no form of this command.
switchport trunk native vlan id
no switchport trunk native vlan id
Syntax Description
id |
VLAN identification number. The range is from 1 to 3967 and from 4048 to 4093. |
Command Modes
Interface configuration (config-if)
Port profile configuration (config-port-prof)
network-admin
Note
This command is auto generated by the network segmentation manager (NSM). The user should not run this command directly for configuration or any other purposes.
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to display trunking parameters on an interface:
n1000v# show running-config port-profile vic-uplink
!Command: show running-config port-profile vic-uplink
!Time: Fri May 24 03:28:00 2013
port-profile type ethernet vic-uplink
inherit port-profile vmdata-vpc-mac
guid 1d8703cd-40b4-4848-867d-296be908921e
description NSM created profile. Do not delete.
Related Commands
|
|
show vlan |
Displays VLAN information. |
system network segment
To configure a network segment as a system network segment, use the system network segment command. To revert to the original network configuration, use the no form of this command.
system network segment
no system network segment
Syntax Description
This command has no arguments or keywords.
Command Modes
Network segment configuration (config-net-seg)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
A system network segment is for ports that need to be active even when the VSM is not connected to the VEM. Typical examples are server management ports, storage ports, etc.
Examples
This example shows how to configure a network segment as a system segment:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment system_segment
n1000v(config-net-seg)# switchport access vlan 900
n1000v(config-net-seg)# system network segment
This example shows how to deconfigure a network segment as a system segment:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network segment system_segment
n1000v(config-net-seg)# switchport access vlan 900
n1000v(config-net-seg)# no system network segment
Related Commands
|
|
show nsm network segment |
Displays NSM network segment information. |
system network uplink
To enable a system VLAN on uplink objects, use the system network uplink command. To disable a system VLAN on uplink objects, use the no form of this command.
system network uplink
no system network uplink
Syntax Description
This command has no arguments or keywords.
Command Modes
Uplink network configuration (config-net-seg)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
The system network uplink command is used to configure system VLANs on an uplink object. This command should be enabled when system network segments are part of an uplink object
Examples
This example shows how to enable a system VLAN on an uplink object:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network uplink system_uplink
n1000v(config-uplink-net)# system network uplink
n1000v(config-uplink-net)#
This example shows how to disable a system VLAN on an uplink object:
n1000v# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
n1000v(config)# nsm network uplink system_uplink
n1000v(config-uplink-net)# no system network uplink
n1000v(config-uplink-net)#
Related Commands
|
|
show nsm network uplink |
Displays NSM network uplink information. |
system redundancy role
To configure a redundancy role for the Virtual Supervisor Module (VSM), use the system redundancy role command. To revert to the default setting, use the no form of this command.
system redundancy role { primary | secondary | standalone }
no system redundancy role { primary | secondary | standalone }
Syntax Description
primary |
Specifies the primary redundant VSM. |
secondary |
Specifies the secondary redundant VSM. |
standalone |
Specifies no redundant VSM. |
Command Modes
EXEC
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to configure no redundant VSM:
n1000v# system redundancy role standalone
Related Commands
|
|
show system redundancy |
Displays the system redundancy status. |
system storage-loss
To detect and configure storage connectivity losses, use the system storage-loss command. To disable storage loss checking, use the no form of this command.
system storage-loss { log | reboot } [ time time-interval ]
no system storage-loss { log | reboot } [ time time-interval ]
Syntax Description
log |
Displays a system log when storage loss is detected. |
reboot |
Reloads the Virtual Supervisor Module (VSM) when storage loss is detected. |
time time-interval |
(Optional) Specifies the time interval at which the VSM checks for storage connectivity status. Time interval in seconds. The range is from 30 to 600 seconds. |
Command Default
The default time interval is 30 seconds.
Command Modes
EXEC
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to enable storage loss detection to be performed every 50 seconds.
n1000v# system storage-loss log time 50
This example shows how to disable the storage loss checking:
n1000v# no system storage-loss
Related Commands
|
|
show system redundancy |
Displays the system redundancy status. |
system switchover
To switch over to the standby supervisor, use the system switchover command.
system switchover
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Examples
This example shows how to switch over to the standby supervisor:
n1000v# system switchover
Related Commands
|
|
show system redundancy |
Displays the system redundancy status. |
system vlan
To add the system VLAN to a port profile, use the system vlan command. To remove the system VLAN from a port profile, use the no form of this command.
system vlan vlan-ID-list
no system vlan
Syntax Description
vlan-ID-list |
VLAN identification number list, separated by commas. The range is from 1 to 3967 and from 4048 to 4093. |
Command Modes
Port profile configuration (config-port-prof)
network-admin
Command History
|
|
5.2(1)SK1(1.1) |
This command was introduced. |
Usage Guidelines
A system VLAN is used to configure and bring up physical or virtual Ethernet ports before the Virtual Supervisor Module (VSM) has established communication with the Virtual Ethernet Module (VEM).
Examples
This example shows how to display system VLAN information:
n1000v# show running-config port-profile vic-uplink
!Command: show running-config port-profile vic-uplink
!Time: Fri May 24 03:28:00 2013
port-profile type ethernet vic-uplink
inherit port-profile vmdata-vpc-mac
guid 1d8703cd-40b4-4848-867d-296be908921e
description NSM created profile. Do not delete.
Related Commands
|
|
show vlan all-ports |
Displays the status of all VLANs and the ports that are configured on them. |
show vlan summary |
Displays VLAN summary information. |