Cisco NAC Appliance - Clean Access Server Configuration Guide

Release 4.9(x)
March 2015

Cisco Systems, Inc.
www.cisco.com

Cisco has more than 200 offices worldwide. Addresses, phone numbers, and fax numbers are listed on the Cisco website at www.cisco.com/go/offices.

Text Part Number: OL-28004-01
## Contents

### About This Guide
- Audience ix
- Purpose ix
- Document Organization x
- Document Conventions x
- New Features in this Release xi
- Product Documentation xi
- Documentation Updates xiii
- Obtaining Documentation and Submitting a Service Request xiii

### Introduction
1-1
- What Is Cisco NAC Appliance? 1-1
- Cisco NAC Appliance Components 1-2
  - Clean Access Manager (CAM) 1-4
  - Clean Access Server (CAS) 1-4
  - Cisco NAC Appliance Agents 1-5
  - Cisco NAC Appliance Updates 1-5
- Clean Access Server Features 1-5
- CAS Management Pages Summary 1-6
- Publishing Information 1-7
- Global vs. Local Administration Settings 1-8
  - Priority of Settings 1-8

### Planning Your Deployment
2-1
- Overview 2-1
- Clean Access Server Operating Modes 2-1
  - Real-IP Gateway 2-2
  - Virtual Gateway 2-2
- Central Versus Edge Deployment 2-4
  - Routed Central Deployment (L2) 2-4
  - Multi-Hop L3 Deployment 2-6
  - Bridged Central Deployment 2-6
Contents

Edge Deployment  2-7
CAS Operating Mode Summary  2-8

Configuring Layer 3 Out-of-Band (L3 OOB)  3-1
Overview  3-1
Layer 3 Out-of-Band Deployment Use Cases  3-3
Layer 2 vs Layer 3 Out-of-Band Implementation  3-3
Layer 3 Out-of-Band L3 OOB Details  3-3
Layer 3 OOB: Configuration  3-4
Layer 3 OOB: Configuration  3-4
Layer 3 OOB: Important Configuration Notes  3-5
Layer 3 OOB: Networking  3-7

Configuring the CAS Managed Network  4-1
Overview  4-1
Add the CAS to the CAM  4-1
Add New Server  4-2
IP Addressing Considerations  4-3
Additional Notes for Virtual Gateway with VLAN Mapping (L2 Deployments)  4-4
List of Clean Access Servers  4-5
Configure Clean Access Server-to-Clean Access Manager Authorization  4-6
Summary of Steps to Configure Clean Access Server-to-Clean Access Manager Authorization  4-6
Enable Authorization and Specify the Authorized Clean Access Manager  4-7
Troubleshooting when Adding the Clean Access Server  4-8

Configure Network Settings for the CAS  4-10
Navigating the CAS Management Pages  4-10
IP Form  4-11
Change Clean Access Server Type  4-13
Switching Between NAT and Real-IP Gateway Modes  4-14
Switching Between Virtual Gateway and NAT/ Real-IP Gateway Modes  4-14
Enable Network Access (L3, L3 Strict or L2 Strict)  4-15
Enable L3 Support  4-15
Enable L3 Strict Mode  4-17
Enable L2 Strict Mode  4-17

Connecting to the CAS Using the SWISS Protocol  4-19
What is the SWISS Protocol?  4-19
Discovery Host  4-21
VPN SSO Considerations 4-22
Overcoming Network Latency Issues That Can Delay Discovery 4-22
Using Layer 3 SWISS Packet Delay to Conserve Bandwidth 4-22
Supporting Multiple Active NICs on the Client Machine 4-23

Configuring DHCP 4-24
Configure DNS Servers on the Network 4-24
Configuring Managed Subnets or Static Routes 4-25
  Overview 4-25
  Configure Managed Subnets for L2 Deployments 4-27
    Adding Managed Subnets 4-28
  Configure Static Routes for L3 Deployments 4-29
    Configuring Static Routes for Layer 2 Deployments 4-30
    Add Static Route 4-30
Configure ARP Entries 4-31
  Add ARP Entry 4-31
Understanding VLAN Settings 4-32
  Enable Subnet-Based VLAN Retag in Virtual Gateway Mode 4-33
VLAN Mapping in Virtual Gateway Modes 4-34
  Native VLAN, Management VLAN, Dummy VLAN 4-34
  VLAN Mapping for In-Band 4-35
  VLAN Mapping for Out-of-Band 4-35
    Switch Configuration for Out-of-Band Virtual Gateway Mode 4-35
    Configure VLAN Mapping 4-36
Local Device and Subnet Filtering 4-38
  Configure Local Device Access Filter Policies 4-39
  View Active L2 Device Filter Policies 4-42
  Configure Subnet Access Filter Policies 4-43
CAS Fallback Policy 4-44
  Configuring CAS Fallback 4-45
Configure Proxy Server Settings on the CAS 4-47

Configuring DHCP 5-1
  Overview 5-1
Enable the DHCP Module 5-2
  Configure DHCP Relay or DHCP Server Mode 5-2
    DHCP Status Options 5-4
Contents

Configuring IP Ranges (IP Address Pools) 5-5
   Auto-Generated versus Manually Created Subnets 5-6
Subnetting Rules 5-6
Create IP Pools Manually 5-8
   Auto-Generating IP Pools and Subnets 5-10
      Add Managed Subnet 5-11
      Create Auto-Generated Subnet 5-11
Working with Subnets 5-15
      View Users by MAC Address/VLAN 5-15
      View or Delete Subnets from the Subnet List 5-15
      Edit a Subnet 5-16
      Configuring a Real-IP CAS as DHCP Server for L3 Clients 5-18
Reserving IP Addresses 5-22
   Add a Reserved IP Address 5-22
User-Specified DHCP Options 5-23
Global Action 5-30

Integrating with Cisco VPN Concentrators 6-1
   Overview 6-1
      Single Sign-On (SSO) 6-2
Configure Cisco NAC Appliance for VPN Concentrator Integration 6-4
   Add Default Login Page 6-5
   Configure User Roles and Requirements 6-5
   Enable L3 Support on the CAS 6-5
   Verifying the Discovery Host 6-6
   Adding/Editing VPN Concentrator Entries 6-6
   Make CAS the RADIUS Accounting Server for VPN Concentrator 6-7
   Adding/Editing Accounting Server Entries 6-8
   Mapping VPN Concentrator(s) to Accounting Server(s) 6-9
   Add VPN Concentrator as a Floating Device 6-10
   Configure Single Sign-On (SSO) on the CAS/CAM 6-10
      Configure SSO on the CAS 6-10
      Configure SSO on the CAM 6-12
   Configure VPN SSO in a FIPS 140-2 Compliant Deployment 6-13
      Import a Trusted CA 6-13
      Set up Identity certificate 6-14
      Create a Site-to-Site VPN to CAS 6-15
   Create (Optional) Auth Server Mapping Rules 6-17
Cisco NAC Appliance Agent with VPN Concentrator and SSO 6-18
Cisco NAC Appliance Agent Layer 3 VPN Concentrator User Experience 6-18
View Active VPN Clients 6-19

Local Traffic Control Policies 7-1

Overview 7-1
Local vs. Global Traffic Policies 7-2
View Local Traffic Control Policies 7-3
Add Local IP-Based Traffic Control Policies 7-4
   Add / Edit Local IP-Based Traffic Policy 7-4
Add Local Host-Based Traffic Control Policies 7-6
   Enable Proxy Traffic 7-6
      Enable Proxy on CAS 7-8
   Add Local Allowed Host 7-8
   Add Local Trusted DNS Server 7-9
   View IP Addresses Used by DNS Host 7-9
Add Layer 2 Ethernet Traffic Control Policies 7-10
   Enable Layer 2 Ethernet Traffic Control 7-11
   Add Layer 2 Ethernet Traffic Control 7-12
Controlling Bandwidth Usage 7-14

Configuring Active Directory Single Sign-On (AD SSO) 8-1

Overview 8-1
   Cisco NAC Appliance Agent/AD Server Compatibility for AD SSO 8-2
   Windows SSO Process (Kerberos Ticket Exchange) 8-2
   CAS Communication with AD Server 8-4
AD SSO Configuration Step Summary 8-5
   Configuration Prerequisites 8-5
   Configuration Step Summary 8-6
Add Active Directory SSO Auth Server 8-6
Configure Traffic Policies for Unauthenticated Role 8-7
   TCP/UDP Ports Supporting AD SSO Implementation 8-8
   Add Policy for AD Server 8-9
Configure AD SSO on the CAS 8-11
Configuring a CAS User on the AD Server for AD SSO 8-14
   Create the CAS User 8-14
Install and Run KTPass  8-18
  Install the Correct Version of ktpass.exe to Support Your AD SSO Deployment  8-18
  Run the ktpass.exe Command  8-22
  Configure AD SSO Without KTPass  8-26
Configure AD SSO in a Windows 7 Client Environment  8-34
  Enable Additional Algorithms on Existing AD Servers  8-35
  Manually Enable DES on Individual Windows 7 Client Machines  8-37
Configure Active Directory for FIPS 140-2 Compliant AD SSO  8-37
  Prerequisites  8-37
  Configuring Your Windows Environment for FIPS 140-2 Compliance  8-37
  Configure the User Profile  8-38
Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos)  8-40
Confirm Active AD SSO Service  8-41
Enable GPO Updates  8-41
Enabling a Login Script (Optional)  8-43
  Introducing a Delay to Allow Script Use  8-44
  Using Network-Based Scripts in Out-of-Band Mode with IP Address Changes  8-45
    Reference Script  8-45
    Delay Script with Delete Command  8-45
Add LDAP Lookup Server for Active Directory SSO (Optional)  8-46
  Configure an LDAP Lookup Server  8-47
  Cross-Forest Group Mapping using LDAP Lookup  8-47
Troubleshooting  8-48
  General  8-48
  KTPass Command  8-48
  Cannot Start AD SSO Service on CAS  8-49
  AD SSO Service Starts, But Client Not Performing SSO  8-49
  Kerbtray  8-50
  CAS Log Files  8-50
  “Integrity check on decrypted field failed” Error  8-51

Local Authentication Settings  9-1
  Overview  9-1
  Local Heartbeat Timer  9-1
  Local Login Page  9-3
    Add Local Login Page  9-3
Enabling Web Client for Local Login Page  9-4
Local File Upload  9-6
Enable Active Directory SSO Login  9-7
Enable Windows NetBIOS SSO Login  9-8
OS Detection  9-9

**Local Certified and Floating Devices**  10-1
Overview  10-1
Add Exempt Devices  10-2
Clear Exempt Devices  10-3
Clear Certified Devices  10-3
Specify Floating Devices  10-4

**Administering CAS Certificates, Time, and Support Logs**  11-1
Status Tab  11-1
Clean Access Server Direct Access Web Console  11-2
Manage CAS SSL Certificates  11-6
SSL Certificate Overview  11-6
Web Console Pages for SSL Certificate Management  11-8
CA-Signed Certificates  11-8
Intermediary Certificates  11-9
Certificates for High Availability (HA) Pairs  11-10
Regenerating Certificates for DNS Name Instead of IP  11-10
Typical SSL Certificate Setup on the CAS  11-10
Phase 1: Establish SSL Communication Between the CAS and CAM  11-10
Phase 2: Set Up Your CAS and CAM For Production Deployment  11-11
Phase 3: Adding a New CAM or CAS to an Existing Production Deployment  11-12
Generate Temporary Certificate  11-12
Generate and Export a Certification Request (Non-FIPS CAS Only)  11-14
Manage Signed Certificate/Private Key  11-16
Import Signed Certificate/Private Key  11-16
Export Certificate and/or Private Key  11-18
Manage Trusted Certificate Authorities  11-19
Import/Export Trusted Certificate Authorities  11-20
View Current Private Key/Certificate and Certificate Authority Information  11-21
SSL Requirements for Mac OS X/CAS Communication  11-23
CAS Temporary Certificate Requirements for SSL Connection to Mac OS X Agent  11-23
Installing the Root Certificate for Mac OS 10.5  11-24
About This Guide

Revised March 10, 2015, OL-28004-01

This preface includes the following sections:

- Audience
- Purpose
- Document Organization
- Document Conventions
- New Features in this Release
- Product Documentation
- Documentation Updates
- Obtaining Documentation and Submitting a Service Request

Audience

This guide is for network administrators who are implementing the Cisco NAC Appliance solution to manage and secure their networks. Cisco NAC Appliance comprises the Clean Access Manager (CAM) administration appliance, Clean Access Server (CAS) enforcement appliance, and Agent end-user client software. Use this document along with the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) and Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) to install, configure, and administer your Cisco NAC Appliance deployment.

Purpose

The Cisco NAC Appliance - Clean Access Server Configuration Guide, Release 4.9(x) describes how to configure the Clean Access Server to implement the Cisco NAC Appliance solution on your network for Cisco NAC Appliance, Releases 4.9(2), 4.9(3), 4.9(4), and 4.9(5). The Clean Access Server is the enforcement server between the untrusted and trusted sides of a Cisco NAC Appliance network. This guide provides additional information specific to the Clean Access Server, such as how to configure DHCP, configure your deployment to work with AD SSO, and perform CAS-specific (local) configuration tasks.

See Product Documentation for further details on the document set for Cisco NAC Appliance.
Document Organization

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1, “Introduction”</td>
<td>Provides a high-level overview of the Cisco NAC Appliance solution</td>
</tr>
<tr>
<td>Chapter 2, “Planning Your Deployment”</td>
<td>Discusses planning considerations for deploying the software</td>
</tr>
<tr>
<td>Chapter 3, “Configuring Layer 3 Out-of-Band (L3 OOB)”</td>
<td>Provides a general overview of the configuration needed for Layer 3 Out-of-Band deployment</td>
</tr>
<tr>
<td>Chapter 4, “Configuring the CAS Managed Network”</td>
<td>Describes how to set up the Clean Access Server’s managed domain</td>
</tr>
<tr>
<td>Chapter 5, “Configuring DHCP”</td>
<td>Describes how to configure each of the DHCP modes of the Clean Access Server</td>
</tr>
<tr>
<td>Chapter 6, “Integrating with Cisco VPN Concentrators”</td>
<td>Describes the configuration required to integrate the Clean Access Server with Cisco VPN Concentrators</td>
</tr>
<tr>
<td>Chapter 7, “Local Traffic Control Policies”</td>
<td>Describes how to set up traffic filtering rules in the Clean Access Server</td>
</tr>
<tr>
<td>Chapter 8, “Configuring Active Directory Single Sign-On (AD SSO)”</td>
<td>Describes how to configure Active Directory (AD) Single Sign-On (SSO) for the Cisco NAC Appliance</td>
</tr>
<tr>
<td>Chapter 9, “Local Authentication Settings”</td>
<td>Describes Authentication tab settings in the Clean Access Server management pages</td>
</tr>
<tr>
<td>Chapter 10, “Local Certified and Floating Devices”</td>
<td>Describes local settings that can be configured at the Clean Access Server level for Clean Access implementation</td>
</tr>
<tr>
<td>Chapter 11, “Administering CAS Certificates, Time, and Support Logs”</td>
<td>Describes Clean Access Server (CAS) administration</td>
</tr>
<tr>
<td>Appendix B, “Open Source License Acknowledgments”</td>
<td>Contains Open Source License information for Cisco products</td>
</tr>
</tbody>
</table>

Table 2 Document Conventions

<table>
<thead>
<tr>
<th>Item</th>
<th>Convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indicates command line output.</td>
<td>Screen font</td>
</tr>
<tr>
<td>Indicates information you enter.</td>
<td>Boldface screen font</td>
</tr>
<tr>
<td>Indicates variables for which you supply values.</td>
<td>Italic screen font</td>
</tr>
</tbody>
</table>
**New Features in this Release**

For a brief summary of the new features and enhancements available in this release refer to Documentation Updates and the “New and Changed Information” section of the Release Notes for Cisco NAC Appliance corresponding to your latest Cisco NAC Appliance release version.

**Product Documentation**

This section lists documents are available for Cisco NAC Appliance on Cisco.com at the following URL:


To access external URLs referenced in this document, right-click the link in Adobe Acrobat and select “Open in Weblink in Browser.”

<table>
<thead>
<tr>
<th><strong>Table 3</strong> Cisco NAC Appliance Document Set</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Refer to This Document For Information On:</strong></td>
</tr>
<tr>
<td><strong>Document Title</strong></td>
</tr>
</tbody>
</table>
| *Cisco NAC Appliance Service Contract/Licensing Support* | • Obtaining and installing product licenses  
• Information on service contracts, ordering and RMA |
| *Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later* | • Agent System Requirements, Agent/Server Version Compatibility, Agent(OS/Browser Support Matrix, Agent/AD Server Compatibility for AD SSO, and Agent Localized Language Template Support |
| *Cisco NAC Appliance Switch and Wireless LAN Controller Support* | • Which switches and NMEs support OOB deployment  
• Known issues/troubleshooting for switches and WLCs |
<p>| <em>Getting Started with Cisco NAC Network Modules in Cisco Access Routers</em> | • Installing or upgrading the Clean Access Server (CAS) software on the Cisco NAC network module (NME-NAC-K9) |
| <em>Connecting Cisco Network Admission Control Network Modules</em> | • Connecting Cisco NAC network module (NME-NAC-K9) in an Integrated Services Router |</p>
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Refer to This Document For Information On:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cisco NAC Appliance FIPS Card Field-Replaceable Unit Installation Guide</strong></td>
<td>• Provides instructions to upgrade your existing Cisco NAC-3310, NAC-3350, and NAC-3390 with a field-replaceable FIPS card necessary to introduce FIPS compliance in your network</td>
</tr>
</tbody>
</table>
| **Release Notes for Cisco NAC Appliance**                                    | Details on the latest 4.9(x) release, including:  
• New features and enhancements  
• Fixed caveats  
• Upgrade instructions  
• Supported AV/AS product charts  
• CAM/CAS/Agent compatibility and version information |
| **Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x)**            | Details on CAM/CAS installation topics:  
• Hardware specifications on the various CAM/CAS platforms  
• How to install the Clean Access Manager and Clean Access Server Platforms  
• How to install Cisco NAC Appliance software on the CASM/CAS  
• How to configure CAM and CAS pairs for High Availability |
| **Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)** | Complete CAM details, including:  
• Overviews of major concepts and features of Cisco NAC Appliance  
• How to use the CAM web console to perform global configuration of Cisco NAC Appliance (applying to all CASs in the deployment) |
| **Cisco NAC Appliance - Clean Access Server Configuration Guide, Release 4.9(x)** | CAS-specific details, including:  
• Where to deploy the CAS on the network (general information)  
• How to perform local (CAS-specific) configuration using the CAS management pages of the CAM web console, or the CAS direct access console. |
Documentation Updates

Table 4  Updates to Cisco NAC Appliance - Clean Access Server Configuration Guide, Release 4.9(x)

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>03/09/15</td>
<td>Release 4.9(5)</td>
</tr>
<tr>
<td></td>
<td>• Updated System Upgrade, page 38</td>
</tr>
<tr>
<td></td>
<td>• Updated Release 4.9(5) screenshots as appropriate</td>
</tr>
<tr>
<td>02/10/14</td>
<td>Release 4.9(4)</td>
</tr>
<tr>
<td></td>
<td>• Updated System Upgrade, page 38</td>
</tr>
<tr>
<td></td>
<td>• Updated Release 4.9(4) screenshots as appropriate</td>
</tr>
<tr>
<td>06/28/13</td>
<td>Release 4.9(3)</td>
</tr>
<tr>
<td></td>
<td>• Updated System Upgrade, page 38</td>
</tr>
<tr>
<td></td>
<td>• Updated Release 4.9(3) screenshots as appropriate</td>
</tr>
<tr>
<td>11/27/12</td>
<td>Release 4.9(2)</td>
</tr>
</tbody>
</table>

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, using the Cisco Bug Search Tool (BST), submitting a service request, and gathering additional information, see What’s New in Cisco Product Documentation at: http://www.cisco.com/c/en/us/td/docs/general/whatsnew/whatsnew.html.

Subscribe to What’s New in Cisco Product Documentation, which lists all new and revised Cisco technical documentation as an RSS feed and delivers content directly to your desktop using a reader application. The RSS feeds are a free service.
Introduction

This chapter provides a high-level overview of the Cisco NAC Appliance solution. Topics include:

- What Is Cisco NAC Appliance?, page 1-1
- Cisco NAC Appliance Components, page 1-2
- Clean Access Server Features, page 1-5
- CAS Management Pages Summary, page 1-5
- Global vs. Local Administration Settings, page 1-8

What Is Cisco NAC Appliance?

The Cisco Network Admission Control (NAC) Appliance (formerly known as Cisco Clean Access) is a powerful, easy-to-use admission control and compliance enforcement solution. With comprehensive security features, in-band or out-of-band deployment options, user authentication tools, and bandwidth and traffic filtering controls, Cisco NAC Appliance is a complete solution for controlling and securing networks. As the central access management point for your network, Cisco NAC Appliance lets you implement security, access, and compliance policies in one place instead of having to propagate the policies throughout the network on many devices.

The security features in Cisco NAC Appliance include user authentication, policy-based traffic filtering, and client posture assessment and remediation. Clean Access stops viruses and worms at the edge of the network. With remote or local system checking, Clean Access lets you block user devices from accessing your network unless they meet the requirements you establish.

Cisco NAC Appliance is a network-centric integrated solution administered from the web console of the Clean Access Manager (CAM) administration server and enforced through the Clean Access Server (CAS) and (optionally) the Agent. You can deploy the Cisco NAC Appliance in the configuration that best meets the needs of your network. The Clean Access Server can be deployed as the first-hop gateway for your edge devices providing simple routing functionality, advanced DHCP services, and other services. Alternatively, if elements in your network already provide these services, the CAS can work alongside those elements without requiring changes to your existing network by being deployed as a “bump-in-the-wire.”

Other key features of Cisco NAC Appliance include:

- Standards-based architecture—Uses HTTP, HTTPS, XML, and Java Management Extensions (JMX).
- User authentication—Integrates with existing back end authentication servers, including Kerberos, LDAP, RADIUS, and Windows NT domain.
Cisco NAC Appliance Components

- **VPN concentrator integration**—Integrates with Cisco VPN concentrators (e.g. VPN 3000, ASA) and provides Single Sign-On (SSO).
- **Cisco NAC Appliance compliance policies**—Allows you to configure client posture assessment and remediation via use of Cisco NAC Appliance Agents or Nessus-based network port scanning.
- **L2 or L3 deployment options**—The Clean Access Server can be deployed within L2 proximity of users, or multiple hops away from users. You can use a single CAS for both L3 and L2 users.
- **In-Band (IB) or Out-of-Band (OOB) deployment options**—Cisco NAC Appliance can be deployed in-line with user traffic, or out-of-band to allow clients to traverse the network only during posture assessment and remediation while bypassing it after certification.
- **Traffic filtering policies**—Role-based IP and host-based policies provide fine-grained and flexible control for in-band network traffic.
- **Bandwidth management controls**—Limit bandwidth for downloads or uploads.
- **High availability**—Active/Passive failover (requiring two servers) ensures services continue if an unexpected shutdown occurs. You can configure pairs of Clean Access Manager (CAM) servers and/or CAS servers in high-availability mode.

**Note** Cisco NAC network modules installed in Cisco Integrated Services Routers (ISRs) do not support high availability.

**Cisco NAC Appliance Components**

Cisco NAC Appliance is a network-centric integrated solution administered from the Clean Access Manager web console and enforced through the Clean Access Server and (optionally) the Agent. Cisco NAC Appliance checks client systems, enforces network requirements, distributes patches and antivirus software, and quarantines vulnerable or infected clients for remediation before clients access the network. Cisco NAC Appliance consists of the following components (in Figure 1-1):

- **Clean Access Manager (CAM)**—Administration server for Cisco NAC Appliance deployment. The secure web console of the Clean Access Manager is the single point of management for up to 20 Clean Access Servers in a deployment (or 40 CASs if installing a SuperCAM). For Out-of-Band (OOB) deployment, the web admin console allows you to control switches and VLAN assignment of user ports through the use of SNMP.

**Note** The CAM web admin console supports Internet Explorer 6.0 or above only, and requires high encryption (64-bit or 128-bit). High encryption is also required for client browsers for web login and Agent authentication.

- **Clean Access Server (CAS)**—Enforcement server between the untrusted (managed) network and the trusted network. The CAS enforces the policies you have defined in the CAM web admin console, including network access privileges, authentication requirements, bandwidth restrictions, and Cisco NAC Appliance system requirements.

You can install a CAS as either a stand-alone appliance (like the Cisco NAC-3300 series) or as a network module (Cisco NME-NAC-K9) in a Cisco ISR chassis and deploy it In-Band (always inline with user traffic) or Out-of-Band (inline with user traffic only during authentication/posture assessment). The CAS can also be deployed in Layer 2 mode (users are L2-adjacent to CAS) or Layer 3 mode (users are multiple L3 hops away from the CAS).
You can also deploy several CASs of varying size/capacity to fit the needs of varying network segments. You can install Cisco NAC-3300 series appliances in your company headquarters core, for example to handle thousands of users and simultaneously install one or more Cisco NAC network modules in ISR platforms to accommodate smaller groups of users at a satellite office, for example.

- **Cisco NAC Appliance Agents**—Optional read-only persistent or temporal Agents that reside on client machines. Cisco NAC Appliance Agent check applications, files, services, or registry keys to ensure that client machines meet your specified network and software requirements prior to gaining access to the network.

  **Note**  
  There is no client firewall restriction with client posture assessment via the Agent. The Agent can check the client registry, services, and applications even if a personal firewall is installed and running.

- **Cisco NAC Appliance Updates**—Regular updates of pre-packaged policies/rules that can be used to check the up-to-date status of operating systems, antivirus (AV), antispyware (AS), and other client software. Provides built-in support for AV vendors and AS vendors.

*Figure 1-1  Cisco NAC Appliance Deployment (L2 In-Band Example)*
Clean Access Manager (CAM)

The Clean Access Manager (CAM) is the administration server and database which centralizes configuration and monitoring of all Clean Access Servers, users, and policies in a Cisco NAC Appliance deployment. You can use it to manage up to 20 Clean Access Servers. The web admin console for the Clean Access Manager is a secure, browser-based management interface. See “Admin Console Summary” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for a brief introduction to the modules of the web console. For out-of-band (OOB) deployment, the web admin console provides the OOB Management module to add and control switches in the Clean Access Manager’s domain and configure switch ports.

Clean Access Server (CAS)

The Clean Access Server (CAS) is the gateway between an untrusted and trusted network. The Clean Access Server can operate in one of the following In-Band (IB) or Out-of-Band (OOB) modes:

- IB Virtual Gateway (L2 transparent bridge mode)
- IB Real-IP Gateway
- OOB Virtual Gateway
- OOB Real-IP Gateway


Cisco NAC Appliance Agents

When enabled for your Cisco NAC Appliance deployment, the Agent can ensure that computers accessing your network meet the system requirements you specify. The Agent is a read-only, easy-to-use, small-footprint program that resides on Windows user machines. When a user attempts to access the network, the Agent checks the client system for the software you require, and helps users acquire any missing updates or software.

Agent users who fail the system checks you have configured are assigned to the Agent Temporary role. This role gives users limited network access to access the resources needed to comply with the Agent requirements. Once a client system meets the requirements, it is considered “clean” and allowed network access.

The Cisco NAC Appliance Agent types available in Cisco NAC Appliance are:

- Cisco NAC Agent (persistent Agent for Windows client machines)
- Windows Clean Access Agent (persistent Agent for Windows client machines available prior to release 4.6(1))
- Mac OS X Clean Access Agent (persistent Agent for Macintosh client machines)
- Cisco NAC Web Agent (temporal Agent for Windows client machines)

For more information on the Agent types available in Cisco NAC Appliance, see the “Cisco NAC Appliance Agents” chapter in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).
**Cisco NAC Appliance Updates**

Regular updates of pre-packaged policies/rules can be used to check the up-to-date status of operating systems, antivirus/antispyware software, and other client software. Cisco NAC Appliance provides built-in support for major AV and AS vendors. For more information, see the “Retrieving Cisco NAC Appliance Updates” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.

**Clean Access Server Features**

The following are key features and benefits of the Clean Access Server:

- In-Band or Out-of-Band deployment
- Layer 2 or Layer 3 deployment
- Integration with Cisco VPN concentrators
- Secure user authentication
- Cisco NAC Appliance network-based and Agent-based scanning and remediation
- Role-based access control
- DHCP address allocation for untrusted (managed) clients, or DHCP relay or passthrough modes
- Network address translation (NAT) services, with support for dynamic or 1:1 NAT (non-production only)
- Bandwidth management
- Event logging and reporting services
- VLAN support in which the Clean Access Server can be a VLAN termination point, provide VLAN passthrough, and provide VLAN-based access control.
- Flexible deployment options enabling the Clean Access Server to be integrated into most network architectures
- High availability—Active/Passive failover (requiring two servers) that ensures services continue if an unexpected shutdown occurs. You can configure pairs of Clean Access Manager (CAM) servers and/or CAS servers in high-availability mode.

**Note**

Cisco NAC network modules installed in Cisco Integrated Services Routers (ISR)s do not support high availability.

**CAS Management Pages Summary**

A Clean Access Server must be added to the Clean Access Manager domain before it can be managed from the web admin console, as described in Add the CAS to the CAM, page 4-1. Once you have added the Clean Access Server, you access it from the admin console as shown in the following steps. In this document, *CAS management pages* refers to the set of pages, tabs, and forms accessed as shown below.

1. Click the **CCA Servers** link in the **Device Management** module. The **List of Servers** tab appears by default.
2. Click the Manage button for the Clean Access Server you want to access.

**Note**
For high-availability Clean Access Servers, the Service IP is automatically listed first, and the IP address of the currently active CAS is shown in brackets.

3. The CAS management pages are shown in Figure 1-3. The Status tab of appears by default.
The Clean Access Manager publishes the configuration settings to the Clean Access Servers whenever the following scenarios happen:

- A new CAS is added to the CAM.
- Connection between CAM and CAS restores after a communication failure between them.
- CAM boots up.
- CAS boots up.
- When CAM failover happens, the newly Active CAM would publish configuration to all connected CASs.
Global vs. Local Administration Settings

The Clean Access Manager web admin console has the following types of settings:

- **Clean Access Manager administration settings** are relevant only to the Clean Access Manager. These include its IP address and host name, SSL certificate information, and High-Availability (failover) settings.

- **Global administration settings** are set from the Clean Access Manager and applied to all Clean Access Servers. These include authentication server information, global device/subnet filter policies, user roles, and Cisco NAC Appliance configuration.

- **Local administration settings** are set in the CAS management pages of the admin console and apply only to that Clean Access Server. These include CAS network settings, SSL certificates, VPN concentrator integration, DHCP and 1:1 NAT configuration, IPSec key changes, local traffic control policies, and local device/subnet filter policies.

The global or local scope of a setting is indicated in the **Clean Access Server** column in the web admin console, as shown in **Figure 1-4**.

### Figure 1-4 Scope of Settings

- **GLOBAL**—The entry was created using a global form in the CAM web admin console and applies to all Clean Access Servers in the CAM’s domain.

- **<IP Address>**—The entry was created using a local form from the CAS management pages and applies only for the Clean Access Server with this IP address.

In most cases, global settings are added, edited, and deleted from the global forms used to create them, and local settings are added, edited, and deleted from the local forms used to create them.

Some pages may display global settings (referenced by GLOBAL) and local settings (referenced by IP address) for convenience. Usually, the local settings may be edited or deleted from the global pages but can be **added** only from the local CAS management pages for a particular CAS.

### Priority of Settings

Global (defined in CAM for all CASs) and local (CAS-specific) settings often coexist on the same CAS. If a global and local setting conflict, the local setting typically overrides the global setting. Note the following:

- For device filter policies affecting a range of MAC addresses and traffic control policies, the priority of the policy (higher or lower in **Device Management > Filters > Devices > Order**) determines which global or local policy to enforce. Any device filter policy for an individual MAC address takes precedence over a filter policy (either global or local) for a range of addresses that includes the individual MAC address.
• For subnet filter policies where one subnet filter specifies a subset of an address range in a broader subnet filter, the CAM determines the priority of the filter based on the size of the subnet address range. The smaller the subnet (like a /30 or /28 subnet mask), the higher the priority in the subnet filter hierarchy.

• Some features must be enabled on the CAS first (via the CAS management pages) before being configured in the CAM, for example:
  – Layer 3 support for the Agent (for multi-hop Layer 3 deployments)
  – Bandwidth Management
  – Use of VPN policy between CAS and users in user role

• Cisco NAC Appliance requirements and network scanning plugins are configured globally from the CAM and apply to all CASs.
Planning Your Deployment

This chapter discusses planning considerations for deploying the software. Topics include:

- Overview, page 2-1
- Clean Access Server Operating Modes, page 2-1
- Central Versus Edge Deployment, page 2-4

Overview

Before installing the Clean Access Server (CAS), you should consider how the Clean Access Server will fit into your existing network:

- Choose the operating mode for the Clean Access Server—The operating mode determines the services the Clean Access Server will provide. For example, the CAS can operate as a bridge between the untrusted and trusted network, or it can operate as a gateway for the untrusted network.
- Deploy the Clean Access Server centrally or at the edge of your network.

This chapter describes operating modes and deployment options for the Clean Access Server. It also provides an overview of how the deployment options affect configuration of the Clean Access Server as well as any external elements in your network, such as routers.

Clean Access Server Operating Modes

The Clean Access Server can operate in one of the following in-band (IB) or out-of-band (OOB) modes:

- **IB Virtual Gateway** (L2 transparent bridge mode)—Operates as a bridge between the untrusted network and an existing gateway, while providing posture assessment, filtering and other services.
- **IB Real-IP Gateway**—Operates as the default gateway for the untrusted network.
- **OOB Virtual Gateway** (L2 transparent bridge mode)—Operates as a Virtual Gateway during authentication and certification, before the user is switched out-of-band (i.e., the user is connected directly to the access network).
- **OOB Real-IP Gateway**—Operates as a Real-IP Gateway during authentication and certification, before the user is switched out-of-band (i.e., the user is connected directly to the access network).

The Clean Access Manager can control both in-band and out-of-band CASs in its domain. However, the Clean Access Server itself must be either in-band or out-of-band.
For more information on OOB configuration in the CAM, see the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*. The following sections further describe each CAS operating mode.

**Real-IP Gateway**

In the Real-IP Gateway configuration, the Clean Access Server operates as the default gateway for untrusted network (managed) clients. All traffic between the untrusted and trusted network passes through the Clean Access Server, which applies the IP filtering rules, access policies, and any other traffic handling mechanisms you configure.

When using the Clean Access Server as a Real-IP Gateway, you need to specify the IP addresses of its two interfaces: one for the trusted side and one for the untrusted side. The two addresses should be on different subnets. The Clean Access Server can manage one or more subnets, with its untrusted interface acting as a gateway for the managed subnets. For details on setting up managed subnets, see Configuring Managed Subnets or Static Routes, page 4-25.

The Clean Access Server does not advertise routes. Instead, static routes must be added to the next hop router indicating that traffic to the managed subnets must be relayed to the Clean Access Server’s trusted interface.

**Note**

In Real-IP Gateway mode, the CAS can send traffic out of the trusted port in one VLAN only. You cannot configure the switch port connecting to the trusted port of the CAS as a trunk port.

Additionally, when the Clean Access Server is in Real-IP Gateway mode, it can act as a DHCP server or relay. With DHCP server functionality enabled, the CAS provides the appropriate gateway information to the clients, that is, the appropriate gateway IP held by the CAS for the particular managed subnet. If the CAS is working as a DHCP relay, then the DHCP server must be configured to provide the managed clients with the appropriate gateway information (that is, the appropriate gateway IP held by the CAS for the particular managed subnet). For further details, refer to Configuring Managed Subnets or Static Routes, page 4-25 and Chapter 5, “Configuring DHCP”.

**Virtual Gateway**

In Virtual Gateway deployment, the Clean Access Server operates as a standard Ethernet bridge, but with the added functionality provided by the IP filter and IPSec module. This configuration is typically used when the untrusted network already has a gateway and you do not wish to alter the existing configuration.
For example, if there are two untrusted subnets, 10.1.1.0/24 and 10.1.2.0/24, with gateways 10.1.1.1 and 10.1.2.1, respectively, the CAS in Virtual Gateway mode is deployed between the untrusted subnets and their gateways (Figure 2-2). The untrusted subnets are configured as “Managed Subnets” in the CAS. Note especially that:

- The CAS needs to have an IP address on each managed subnet.
- Traffic from clients **must** pass through the CAS before hitting the gateway.

**Figure 2-2 Virtual Gateway Configuration**

When the CAS is a Virtual Gateway:

- The CAS and CAM **must** be on different subnets.
- eth0 and eth1 of the Clean Access Server can have the same IP address.
- All end devices in the bridged subnet must be on the untrusted side of the CAS.
- The CAS should be configured for DHCP forwarding.
- Make sure to configure managed subnets for the CAS. For the example in Figure 2-2, you would configure two managed subnets:
  - 10.1.1.2 / 255.255.255.0 1001
  - 10.1.2.2 / 255.255.255.0 1002

When the CAS is an Out-of-Band Virtual Gateway, the following also applies:

- The CAS and CAM must be on different VLANs.
- The CAS should be on a different VLAN than the user or Access VLANs.
Central Versus Edge Deployment

The Clean Access Server can be deployed either centrally or at the edge of your network. A central deployment reduces the number of Clean Access Servers you need to deploy, facilitating management and scalability. In a central deployment, the Clean Access Server can be configured to perform either routing or bridging for the untrusted network.

Cisco NAC Appliance allows you to achieve multi-hop L3 deployment if you want to move the CAS several hops away from users.

Routed Central Deployment (L2)

In a routed central deployment, the Clean Access Server is configured to act as the Real-IP Gateway for each of the subnets that you wish to manage.

Deployment Steps
The specific steps to deploy a centrally routed Clean Access Server in a typical network include:

1. Turn off routing on your existing Layer 3 switch or router for the subnets that you wish to manage through the CAS.
2. Configure the untrusted interface of the CAS to be the gateway for the managed subnets.
3. Configure the default gateway of the CAS’s trusted interface to be the L3 switch or the router.
4. Add static routes on the L3 switch or router to route traffic for the managed subnets to the CAS’s trusted interface.
5. If using your own DHCP server, modify its configuration so that the default gateway address that the DHCP server passes to clients with the lease is the address of the CAS’s untrusted interface.

Agent communication with the CAS requires a Maximum Transmission Unit (MTU) of 1500 bytes. In routed or tunneled environments (like VPN, GRE, Metro Ethernet etc.), all hops must allow 1500 byte packets or support Path MTU Discovery (PMTU-D).

If there appears to be an issue with Agent communication in such environments yet basic IP connectivity has been verified, evaluate the MTU end-to-end. Please contact your Cisco WAN support representative for specific options to address this requirement.
In a VLAN-enabled environment, multiple VLANs are trunked through a single Clean Access Server. Aggregating multiple VLANs—organized by location, wiring, or shared needs of users—through a single CAS (by VLAN trunking) can help to simplify your deployment. Figure 2-3 shows a centrally-routed deployment:

**Figure 2-3  Routed Central Deployment in a VLAN-Enabled Network**

Managed Network

Sales
VLAN 1 192.168.20.1/24

Engineering
VLAN 2 192.168.20.2/24

HR
VLAN 3 10.1.50.0/24

Core network

Clean Access Manager

L3 Switch/ Router

Internet

802.1q trunk

802.1q trunk

802.1q trunk

untrusted interface (eth1): 192.168.201.1
192.168.202.1 (virtual I/F)
10.1.50.1 (virtual I/F)

Default G/W for CAS trusted network side: _192.168.151.1

trusted interface (eth0): _192.168.151.10

Clean Access Server

CAS Managed Subnets:
_192.168.201.0 /24
_192.168.202.0/ 24
_10.1.50.0 / 24
Multi-Hop L3 Deployment

You can choose to deploy the CAS either closer to the edge of the network or several hops away from the network. With centralized L3 deployment, the CAS(es) may be placed several hops away from users. Multi-hop L3 deployment allows:

- Easier deployment. The CAS(es) are deployed between routers, spanning VLANs is not necessary and fewer CASs are needed.
- Not every packet has to go through the CAS. User traffic only needs to traverse the CAS for trusted network access.

However, note that Cisco NAC Appliance policies are enforced at the CAS only. Traffic which does not reach the CAS is not subject to policy enforcement.

Deployment Steps

The specific steps to deploy a centrally routed Clean Access Server in a typical network include:

1. Enable L3 on the CAS by going to Device Management > CCA Servers > Manage [CAS_IP] > Network and clicking the checkbox for Enable L3 support for Clean Access Agent.
2. Managed subnets should be configured for user subnets that are Layer 2 adjacent to the CAS. For user subnets that are one or more hops away from the CAS, static routes should be configured. Hence if enabling L3 support on the CAS, for the L3 users configure their subnets under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Static Routes and NOT under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnets.
3. Ensure the IP address in the Discovery Host field under Device Management > Clean Access > Clean Access Agent > Installation is the correct address for your network.
4. If enabling the L3 multi-hop feature for VPN concentrator integration, perform all the configuration described in Chapter 6, “Integrating with Cisco VPN Concentrators.”

Bridged Central Deployment

In a central deployment with the Clean Access Server configured as a bridge (Virtual Gateway), VLAN trunks are used to aggregate the traffic from the managed subnets to the CAS before being forwarded to their respective gateways on the L3 switch or router.

To ensure that no path exists from the clients to the gateway, Cisco recommends deploying a switch that aggregates all VLANs to the untrusted interface of the CAS, while the trusted interface of the CAS is directly connected to the L3 switch or the router, as shown in Figure 2-4. Note that the Clean Access Server interfaces will be connected to trunked ports and should provide VLAN passthrough.
Edge Deployment

While central deployment has advantages in terms of reducing the number of required Clean Access Servers, a central deployment is not always possible. For example, if using gigabit throughput to your network’s edge, an edge deployment is required. In edge deployment, the Clean Access Server is placed between each managed subnet and router in the network, as illustrated in Figure 2-5. This allows the Clean Access Server to continue to capture MAC addresses for the devices to be managed. In edge deployment, the CAS can act as either a Virtual Gateway or a Real-IP Gateway.
## CAS Operating Mode Summary

Table 2-1 summarizes the features and advantages for each operating mode.

<table>
<thead>
<tr>
<th>CAS Type</th>
<th>Features</th>
<th>Advantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual Gateway</td>
<td>• CAS acts like a bridge for the managed network</td>
<td>• CAS acts in an unobtrusive manner.</td>
</tr>
<tr>
<td></td>
<td>• CAS acts as a DHCP passthrough.</td>
<td>• Good if you do not want to modify the existing network.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• There is no need to define static routes on the main router.</td>
</tr>
<tr>
<td>Real-IP Gateway</td>
<td>• CAS acts as a gateway for the managed subnet.</td>
<td>• Good for situations in which a new subnet can be used for the managed network.</td>
</tr>
<tr>
<td></td>
<td>• CAS is designated as a static route for the managed subnet.</td>
<td>• Clients are assigned real IP addresses.</td>
</tr>
<tr>
<td></td>
<td>• CAS can perform DHCP services, or act as a DHCP relay.</td>
<td>• Takes advantage of the CAS’s advanced DHCP services.</td>
</tr>
<tr>
<td>OOB Virtual Gateway</td>
<td>• CAS acts like a bridge for the managed network only during the authentication, posture assessment and remediation process.</td>
<td>• CAS acts as a DHCP passthrough for Authentication VLAN.</td>
</tr>
<tr>
<td></td>
<td>• CAS acts as a DHCP passthrough for Authentication VLAN.</td>
<td></td>
</tr>
<tr>
<td>OOB Real-IP Gateway</td>
<td>• CAS acts as an inline L3 router for the managed network only during the authentication, posture assessment and remediation process.</td>
<td>• Once successfully logged on, user traffic bypasses the CAS and traverses the switch ports directly.</td>
</tr>
<tr>
<td></td>
<td>• CAS can perform DHCP services, or act as a DHCP relay.</td>
<td>• User can be logged out via role-based session timer or link-down SNMP traps.</td>
</tr>
<tr>
<td></td>
<td>• User obtains DHCP address from Authentication VLAN.</td>
<td>• Can be deployed in Edge or Core (central) switches.</td>
</tr>
<tr>
<td></td>
<td>• L3 Switch/router configuration: Configure CAS as default gateway for managed subnets.</td>
<td>• No need to bounce client ports.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Recommended configuration if sharing ports between IP phones and PCs.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Clients are assigned real IP addresses.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Once successfully logged on, user traffic bypasses the CAS and traverse the switch ports directly.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Port bouncing not required. DHCP release/renew is triggered by 4.1.1.0+ Agent or ActiveX/ Java Applet downloaded from web login page.</td>
</tr>
</tbody>
</table>
Configuring Layer 3 Out-of-Band (L3 OOB)

This chapter provides a general overview of the configuration needed for Layer 3 Out-of-Band deployment.

For general information on configuring the Cisco NAC Appliance for out-of-band deployment, see “Switch Management and Configuring Out-of-Band (OOB) Deployment” and “Enable the Login Page for L3 OOB” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Overview

Multi-hop L3 support for In-Band (wired) deployments enables administrators to deploy the Clean Access Server (CAS) in-band centrally (in core or distribution layer) to support users behind L3 Switches (e.g. routed access) and remote users behind VPN Concentrators or remote WAN routers. With L3 IB, users more than one L3 hop away from the CAS are supported and their traffic always goes through Cisco NAC Appliance.

Multi-hop L3 support for Out-of-Band (wired) deployments enables administrators to deploy the CAS out-of-band centrally (in core or distribution layer) to support users behind L3 Switches (e.g. routed access) and remote users behind WAN routers in some instances. With L3 OOB, users more than one L3 hop away from the CAS are supported and their traffic only has to go through Cisco NAC Appliance for authentication/posture assessment only.

Administrators have the option of deploying a remote CAS or L3 IB CAS for remote WAN users, and in some instances using L3 OOB.

Client MAC Address Detection—Agent or ActiveX/Java Applet

The MAC detection mechanism of the Agent automatically acquires the client MAC address in L3 OOB deployments.

Users performing web login will download and execute either an ActiveX control (for IE browsers) or Java applet (for non-IE browsers) to the client machine prior to user login to determine the user machine’s MAC address. This information is then reported to the CAS and the CAM to provide the IP address/MAC address mapping.

Agent Login for L3 OOB Users

Cisco NAC Appliance enables multi-hop L3 support for out-of-band (wired) deployments, enabling administrators to deploy the CAS out-of-band centrally (in core or distribution layer) to support users behind L3 switches (e.g. routed access) and remote users behind WAN routers in some instances. With L3 OOB, users more than one L3 hop away from the CAS are supported and their traffic only has to go through Cisco NAC Appliance for authentication/posture assessment.
Overview

The MAC detection mechanism of the Agent will automatically acquire the client MAC address in L3 OOB deployments.

Users performing web login will download and execute either an ActiveX control (for IE browsers) or Java applet (for non-IE browsers) to the client machine prior to user login to determine the user machine’s MAC address. This information is then reported to the CAS and the CAM to provide the IP address/MAC address mapping.

ActiveX/Java Applet and Browser Compatibility

- Complete ActiveX/Java Applet and Browser Compatibility information is available in Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later.
- Java applets are supported for major browsers including Safari 1.2+, Mozilla (Camino, Opera), and Internet Explorer on Windows XP, Mac OS X, and Linux operating systems.
- Due to Firefox issues with Java, Java applets are not supported for Firefox on Mac OS X. See the Firefox release notes (http://www.mozilla.com/firefox/releases/1.5.0.3.html) for details.

Note

For MAC OS X Clients: On Apple Mac OS X, the browser settings to bypass proxy must have the full CAS IP address (e.g. 10.201.217.93) in order for the client machine to load the Java Applet and login successfully.

Note

For Linux OOB Clients:

Because Linux machines behave differently than Windows/Mac OS X clients (i.e. do not release IP address when NIC is down and renew IP address when NIC is up), use the following steps for OOB Linux clients:

1. Set a short lease time (e.g. 60 seconds) for the DHCP server on the Auth VLAN.
2. In the Port Profile, disable (uncheck) the “Remove out-of-band online user when SNMP linkdown trap is received” option.
   This will cause the Linux client to renew its IP address shortly after authentication/certification.

   Note Because Linux shuts down/restarts the NIC when renewing the IP address, if this option is enabled (checked) in the Port Profile, the renewal will set the port back to the Auth VLAN.

3. Alternatively, you can set the Port Profile to: “Change to [Access VLAN] if the device is certified but not in the out-of-band user list.” This ensures the port stays on the Access VLAN for an authenticated/certified Linux client that is reconnecting to the port after renewing its DHCP lease.

This new feature modifies the following web admin console pages:

- A new checkbox and dropdown menu is added for “Use ActiveX or Java Applet to detect client MAC address when Clean Access Server cannot detect the MAC address” in the following user login configuration pages:
- Device Management > Clean Access > Updates (version information for updates to L3 Java Applet Web Client and L3 ActiveX Web Client)
In addition, the web login pages for L3 OOB users will reflect status information related to loading the ActiveX control or Java applet, and renewing the client IP address.

**Layer 3 Out-of-Band Deployment Use Cases**

- OOB is for wired deployments only
- L3 OOB is best used in Routed Access deployments
- L3 OOB can also be used for Remote WAN sites but considerations/tradeoffs with other deployments, such as:
  - Remote CAS to WAN sites
  - L3 IB CAS in Central site to support WAN sites

**Layer 2 vs Layer 3 Out-of-Band Implementation**

**In L2 OOB:**
- Users are Layer 2 adjacent to the CAS
- User device connects to switch, switch sends SNMP trap to CAM
- CAM gets device mac and port information from switch
- CAS receives packets and sends source IP/MAC info to CAM
- CAM now has complete mapping IP/MAC/Port
- Once device is certified to be compliant, CAM knows which port to change VLAN

**In L3 OOB**
- Users are one or more hops away from the CAS
- CAM still gets device MAC and port information from switch
- CAS receives packets with user’s IP
- CAS gets MAC information from either Agent or web-login page enabled for ActiveX/Java Applet to determine device MAC address and report it back to CAS
- CAS informs CAM of IP/MAC of device
- CAM has complete IP-MAC-Port mapping

**Layer 3 Out-of-Band L3 OOB Details**

**Using the Agent**
The Agent will inform CAS of the device MAC address.

**Without the Agent (using Web Login)**
- Web-login page will download ActiveX Control or Java Applet to determine device MAC address and report it back to CAS
- CAS informs CAM of IP/MAC of device
- CAM has complete IP-MAC-Port mapping
Chapter 3  Configuring Layer 3 Out-of-Band (L3 OOB)

Layer 3 OOB: Configuration

With the Agent
- Agent informs CAS of MAC address
- No additional configuration is needed

Without the Agent (using Web Login)
Configure the Login Page
- On CAM: Administration > User Pages > Login Page > Add/Edit
- On CAS: Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Login Page | [Override Global Settings]

Figure 3-1  Administration User Page

Layer 3 OOB: Configuration

- On Login Page, there is a checkbox and a “Use ActiveX or Java Applet to detect client MAC address when Clean Access Server cannot detect the MAC address” dropdown menu with the following options:
  - ActiveX Only
  - Java Applet Only
  - ActiveX Preferred
  - Java Applet Preferred
  - ActiveX on IE, Java Applet on non-IE Browser
- For “Preferred” options, the preferred option is loaded first; if it fails, the other option is loaded:
  - ActiveX is fastest with IE
  - ActiveX is preferred and faster than applet
- ActiveX supported on IE 6.0 on Windows XP
- Java Applet supported on most browsers

Note
DHCP IP addresses can be refreshed for client machines using the Agent or ActiveX Control/Java Applet without requiring port bouncing after authentication and posture assessment. See “Enable Web Client for Login Page” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for further details.
For detailed information on Access to Authentication VLAN change detection, refer to the “Configuring Access to Authentication VLAN Change Detection” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.

**Figure 3-2 Administration User Page Edit**

Layer 3 OOB: Important Configuration Notes

- If a Managed Subnet is configured, Cisco NAC Appliance does not use L3 OOB for those subnets.
- Managed subnets are for L2 users only.
- You must click the Enable L3 support checkbox under Device Management > CCA Servers > Manage [CAS_IP] > Network > IP.
Client machines should be able to execute either ActiveX or Java Applet.

When the CAM changes the VLAN on the switch port from the Authentication VLAN to the Access/User Role VLAN, port bouncing is required.

- In Port profiles (Switch Management > Profiles > Port > New/Edit), make sure Bounce the port after VLAN is changed is checked.

  or

- If using a version 4.1.2.0 or later Agent, ActiveX Control, or Java Applet to refresh client DHCP IP addresses, the Bounce the switch port after VLAN is changed option in the Port profile can be left disabled. If you use this method, be sure to follow the guidelines and warnings detailed in the “DHCP Release/Renew with Agent/ActiveX/Java Applet,” “Configuring Access to Authentication VLAN Change Detection,” and “Advanced Settings” sections of the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).
Figure 3-4  VLAN Setting Changes to Bounce a Port

In Port profiles, make sure Remove out-of-band online user without bouncing the port is unchecked.

Figure 3-5  Unchecked OOB Selection

Layer 3 OOB: Networking

- L3 OOB will typically be used in Routed Access environments.
- With OOB, the goal is to make user traffic flow through the CAS during Authentication, Posture Assessment, and Remediation only.
  - CAS challenges user for credentials and also acts as policy enforcement device in the Unauthenticated and Quarantine/Temporary roles.
- Once the user is certified to be compliant, it bypasses the CAS.
- Use networking technologies (such as PBR or VRF) to achieve this goal.
- The following failure scenarios might cause the Cisco NAC Agent to appear following successful user authentication when the client machine roams between CASs in Layer 3 (both In-Band and Out-of-Band) and Layer 2/Layer 3 Out-of-Band environments. Erroneous Agent login dialogs could also appear if users roam from the Cisco NAC Appliance network in Layer 3 mode to a non-NAC network:
  - ARP poisoning
Overview

- Temporary loss of network connection between the client machine and the CAS
- Access to untrusted interface IP address on the CAS from non-NAC network segments on NAC-enabled client machines

Cisco offers the following recommendations to prevent this situation:

- Ensure all trusted networks (post-authentication) can reach the CAS untrusted interface IP address through the CAS trusted interface only
- Block discovery packets from all non-NAC networks to the CAS untrusted interface IP address (discovery packets that arrive on the trusted interface of the CAS are blocked by default)

Note: These scenarios are not specific to OOB logoff feature and represent general Cisco NAC Agent behavior for some Out-of-Band topologies.
Configuring the CAS Managed Network

This chapter describes how to set up the Clean Access Server’s managed domain. Topics include:

- Overview, page 4-1
- Add the CAS to the CAM, page 4-1
- Configure Network Settings for the CAS, page 4-9
- Connecting to the CAS Using the SWISS Protocol, page 4-19
- Configuring DHCP, page 4-24
- Configure DNS Servers on the Network, page 4-24
- Configuring Managed Subnets or Static Routes, page 4-25
- Configure ARP Entries, page 4-31
- Understanding VLAN Settings, page 4-32
- VLAN Mapping in Virtual Gateway Modes, page 4-34
- Local Device and Subnet Filtering, page 4-38
- CAS Fallback Policy, page 4-44
- Configure Proxy Server Settings on the CAS, page 4-47

Overview

After installing the Clean Access Server, it needs to be added to the Clean Access Manager’s domain. You can then configure the Clean Access Server’s managed (untrusted) network.

Configuring the Clean Access Server managed network involves setting up passthrough policies, specifying managed subnets (subnets you want to manage that are not within the address space specified at the untrusted network interface), setting up static routes, along with other tasks described here.

Add the CAS to the CAM

This section describes the following topics:

- Add New Server, page 4-2
- IP Addressing Considerations, page 4-3
- Additional Notes for Virtual Gateway with VLAN Mapping (L2 Deployments), page 4-4
The Clean Access Server gets almost all of its runtime parameters from the Clean Access Manager, and cannot operate unless it is added to the domain of a Clean Access Manager. Once it is added to the CAM, the CAS can be configured and monitored through the admin console.

Add New Server

If intending to configure the Clean Access Server in Virtual Gateway mode (IB or OOB), you must disable or unplug the untrusted interface (eth1) of the CAS until after you have added the CAS to the CAM from the web admin console. Keeping the eth1 interface connected while performing initial installation and configuration of the CAS for Virtual Gateway mode can result in network connectivity issues.

For Virtual Gateway with VLAN mapping (In-Band or OOB), the untrusted interface (eth1) of the CAS should not be connected to the switch until VLAN mapping has been configured correctly under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > VLAN Mapping. See Additional Notes for Virtual Gateway with VLAN Mapping (L2 Deployments), page 4-4 for details.

1. Open a web browser and type the IP address of the CAM as the URL to access the CAM web admin console.
2. Go to the Device Management module and click CCA Servers.
3. Click the New Server tab to add a new CAS.

Figure 4-1 New Server
4. In the **Server IP address** field, type the IP address of the Clean Access Server’s eth0 trusted interface.

   **Note**  
The eth0 IP address of the CAS is the same as the Management IP address.

5. The **Server Type** dropdown menu determines whether the Clean Access Server operates as a bridge or a gateway. For in-band operation, choose one of the following CAS operating modes as appropriate for your environment:
   - **Virtual Gateway**—CAS operates as a bridge between the untrusted network and an existing gateway

   **Note**  
See Additional Notes for Virtual Gateway with VLAN Mapping (L2 Deployments), page 4-4.

   - **Real-IP Gateway**—CAS operates as a gateway for the untrusted network

6. The Out-of-Band Server Types appear in the dropdown menu when you apply an OOB-enabled license to a Cisco NAC Appliance deployment. For OOB, the CAS operates as a Virtual or Real-IP Gateway while client traffic is In-Band (in the Cisco NAC Appliance network) during authentication and certification. Once clients are authenticated and certified, they are considered “out-of-band” (no longer passing through the Cisco NAC Appliance network) and allowed directly onto the trusted network. Choose one of the following operating modes for the CAS:
   - **Out-of-Band Virtual Gateway**—CAS operates as a Virtual Gateway during authentication and certification, before the user is switched out-of-band (i.e., the user is connected directly to the access network).
   - **Out-of-Band Real-IP Gateway**—CAS operates as a Real-IP Gateway during authentication and certification, before the user is switched out-of-band (i.e., the user is connected directly to the access network).

   Note that the CAM can control both in-band and out-of-band Clean Access Servers in its domain. However, the **CAS** itself must be **either** in-band or out-of-band.

   For details on in-band operating modes, see Clean Access Server Operating Modes, page 2-1. For details on OOB operating modes, see “Switch Management and Configuring Out-of-Band (OOB) Deployment” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

7. Click **Add Clean Access Server**. The Clean Access Manager looks for the CAS on the network, and adds it to its list of managed Clean Access Servers.

**IP Addressing Considerations**

- **Note**  
  - eth0 and eth1 generally correlate to the first two network cards—NIC 1 and NIC 2—on most types of server hardware.
  - For Virtual Gateway (IB or OOB), do not connect the untrusted interface (eth1) of the CAS to the switch until **after** the CAS has been added to the CAM via the web console, and VLAN mapping has been configured correctly under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > VLAN Mapping.
Add the CAS to the CAM

Chapter 4      Configuring the CAS Managed Network

Add the CAS to the CAM

Real-IP Mode:
- The trusted (eth0) and untrusted (eth1) interfaces of the CAS must be on different subnets.
- You must add static routes on the L3 switch or router to route traffic for the managed subnets to the trusted interface of the respective CASs.
- If using DHCP relay, make sure the DHCP server has a route back to the managed subnets.

Virtual Gateway Mode:
- The CAS and CAM must be on different subnets (or VLANs).
- The trusted (eth0) and untrusted interfaces (eth1) of the CAS can have the same IP address. (Note: this is equivalent to an L3 switched virtual interface (SVI) IP address)
- All end devices in the bridged subnet must be on the untrusted side of the CAS.
- Managed subnets must be configured on the CAS for all the user subnets that are managed by the CAS. When configuring the Managed subnet, make sure that you type an unused IP address in that subnet (for the CAS to use), and not a subnet address.
- The CAS is automatically configured for DHCP Passthrough when set to Virtual Gateway mode.
- Traffic from clients must pass through the CAS before hitting the gateway.

OOB Virtual Gateway Mode:
When the CAS is an OOB VGW, the following also applies:
- The CAS interfaces must be on a separate subnet (or VLAN) from the CAM.
- The CAS management VLAN must be on a different VLAN than the user or Access VLANs.

Additional Notes for Virtual Gateway with VLAN Mapping (L2 Deployments)

1. There should be a management VLAN setting on the CAS IP page (and in your network configuration) to allow communication to the CAS’s trusted and untrusted IP addresses.
2. The Native VLAN ID on the switch ports to which CAS eth0 and eth1 are connected should ideally be two otherwise unused VLAN IDs (e.g. 999, 998). Choose any two VLAN IDs from a range that you are not using anywhere on your network.
4. If the CAM is down and the CAS is performing VLAN mapping in “fail open” state, do not reboot the CAS because the VLAN mapping capability will be lost until the CAM comes back online.

Caution
To avoid switch errors, make sure to correctly set VLAN Mapping in the CAS before connecting the eth1 interface of the CAS. Failure to do so could cause spanning tree loops and shut down the switch.

Note
The Clean Access Server needs to receive Ethernet frames and only supports Ethernet as the LLC (Logical Link Control) protocol. For any non-IP protocol, such as SNA or IPX, the CAS can support it only if Ethernet is used as the LLC protocol, the CAS is a Virtual Gateway, and there is no VLAN mapping (i.e. the CAS is in Edge Deployment mode).
List of Clean Access Servers

Once you add the CAS to the Clean Access Manager, the CAS appears in the List of Servers tab.

Figure 4-2    List of Servers

Each Clean Access Server entry lists the IP address, server type, location, and connection status of the CAS. In addition, four management control icons are displayed: **Manage**, **Disconnect**, **Reboot**, and **Delete**. You access the management pages of a Clean Access Server by clicking the **Manage** icon next to the CAS.
Configure Clean Access Server-to-Clean Access Manager Authorization

When you add Clean Access Servers to the CAM, you can also choose to enable mutual Authorization between the appliances to enhance network security.

Using the CAM Authorization web console page, administrators can enter the Distinguished Names (DNs) of one or more CASs to ensure secure communications between the CAM and CAS(s). Once you enable the Authorization feature and add one or more CASs to the Authorized CCA Servers list, the CAM does not accept communications from CASs that do not appear in the list. Therefore, when you choose to employ and enable this feature in your network, you must add all of your managed CASs to the Authorized CCA Servers list to ensure you maintain CAM-CAS connection for all of the CASs in your network.

Likewise, you must also enable this feature and specify a CAM DN on all of the CASs in your network to establish two-way authorization between the CAMs/CASs.

**Note**

Administrators should expect a few minutes of downtime when updating Trusted CAs on the CAS, as updating certificate information restarts services. This is due to the fact that the CAM/CAS use mutual authentication to communicate back and forth and although you are no longer required to reboot the CAS when you change the certificate or import new Trusted CAs, the CAM-to-CAS connections are still “reset” to ensure network security. Therefore, Cisco recommends performing this type of action during periods of very low Cisco NAC Appliance network traffic.

If you have deployed your CAMs/CASs in an HA environment, you can enable authorization for both the HA-Primary and HA-Secondary machines in the HA pair by specifying the DN of only the HA-Primary appliance. For example, if the CAM manages a CAS HA pair, you only need to list the HA-Primary CAS on the CAM’s Authorization page. Likewise, if you are enabling this feature on a CAS managed by a CAM HA pair, you only need to list the HA-Primary CAM on the CAS’s Authorization page.

Summary of Steps to Configure Clean Access Server-to-Clean Access Manager Authorization


2. Configure CAM Authorization on the CAS web console under **Administration > Authorization** (see the “Enable Authorization and Specify Authorized Clean Access Servers” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*).

3. Before deploying in a production environment, obtain trusted CA-signed certificates for CAM and CAS and import them to CAM/CAS under **Administration > SSL > Trusted Certificate Authorities** (for CAM), and **Administration > SSL > Trusted Certificate Authorities** (for CAS).

**Warning**

If your previous deployment uses a chain of SSL certificates that is incomplete, incorrect, or out of order, CAM/CAS communication may fail after upgrade to release 4.5 and later. You must correct your certificate chain to successfully upgrade to release 4.5 and later. For details on how to fix certificate errors on the CAM/CAS after upgrade to release 4.5 and later, refer to the *How to Fix Certificate Errors on the CAM/CAS After Upgrade* Troubleshooting Tech Note.
4. If you are upgrading your Cisco NAC Appliance release, clean up Trusted Certificate Authorities on the CAM under Administration > CCA Manager > SSL > Trusted Certificate Authorities, and on the CAS under Administration > SSL > Trusted Certificate Authorities (see Manage Trusted Certificate Authorities, page 11-19 and the “View and Remove Trusted Certificate Authorities” section in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x), respectively).

**Note**

If you use the Authorization feature in a CAS HA-pair, follow the guidelines in “Backing Up and Restoring CAM/CAS Authorization Settings” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) to ensure you are able to exactly duplicate your Authorization settings from one CAS to its high availability counterpart.

**Enable Authorization and Specify the Authorized Clean Access Manager**

To enable authorization and specify the CAM authorized to communicate with your CAS:

**Step 1**
Open a web browser and type the IP address of the CAS’s trusted (eth0) interface in the URL/address field (https://<CAS_eth0_IP_address>/admin). For example:

https://172.16.1.2/admin

**Step 2**
Go to Administration > Authorization (Figure 4-3).

**Step 3**
Click the Enable CCA Server Authorization to turn on the Cisco NAC Appliance authorization feature.

**Warning**

Do not click the Enable CCA Server Authorization option without also entering one or more full distinguished names of CAMs you want to authorize to communicate securely with the CAS. If you enable this feature and have not specified any CAM distinguished names, you will not be able to communicate with any of the CAMs in your network.

**Step 4**
Click the plus icon “+” and enter the full distinguished name of the CAM you want to authorize to communicate securely with the CAS. For example, enter a text string like “CN=110.21.2.123, OU=cca, O=cisco, L=sj, ST=ca, C=us” in the Distinguished Name field.
Add the CAS to the CAM

**Note**

Distinguished names require exact syntax. Therefore, Cisco recommends copying the CAM DN from the “CCA Manager Certificate” entry in the certificate information table in the Administration > CCA Manager > SSL > X509 Certificate CAM web console page and pasting it into the CAS’s Authorization page to ensure you specify the exact name for the CAM on the CAS.

**Step 5**

Click **Update** to ensure the CAM you have added is authorized to communicate back-and-forth with the CAS.

When you click **Update**, the CAS restarts services between the CAS and CAM in the Authorized CCA Manager list, which may cause brief network interruptions to users logged into the Cisco NAC Appliance system.

---

**Troubleshooting when Adding the Clean Access Server**

If the Clean Access Server cannot be added to Clean Access Manager, check the following:

1. Ping connectivity from the CAS to the CAM and from the CAM to the CAS.
   a. If the CAS is not pingable, network settings may be incorrect. Reset them using `service perfigo config`. See the “CAS CLI Commands” section in the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.
   b. If the CAS is pingable but cannot be added to the CAM:
      - Physically disconnect the eth1 interface of the CAS.
      - Wait 2 minutes, then add the CAS again from the CAM web console.
      - When the CAS is successfully added, physically connect the eth1 interface of the CAS.
2. SSH from the CAM to the CAS and from the CAS to the CAM and check for any errors.
3. Check the SSL certificates. For details, see Typical SSL Certificate Setup on the CAS, page 11-10 and Troubleshooting Certificate Issues, page 11-31 in this guide, and the corresponding sections of the CAS guide.
4. Check the product license. Make sure you have a license for OOB if using OOB. If running OOB, the “Switch Management” module will be present in left hand pane of the web admin console. When upgrading, your previous license must already enable OOB, or you must obtain a new license to use OOB features. See the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) and Cisco NAC Appliance Service Contract/Licensing Support for more details.
5. Check the date/time on both the CAM and CAS via SSH. The date/time difference cannot be more than 3 minutes.
   - To check the time on the CAS/CAM, issue: `date`
   - To change the time on the CAS/CAM, issue: `service perfigo time`
6. If the CAS is a Virtual Gateway, make sure the CAM and CAS are on different subnets (or VLANs).
7. If the CAS is a Virtual Gateway, and both ports of the CAS are connected to the same switch:
   a. Physically disconnect the eth1 interface of the CAS.
   c. Wait 2 minutes.
d. Physically connect the eth1 interface of the CAS.

8. Check the CAM Event Log (under Monitoring > Event Logs). This can help pinpoint license and other issues.

9. Make sure there are no firewall rules blocking RMI ports (see the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details):

10. Perform `service perfigo restart` on both the CAM and CAS.

11. Perform `service perfigo reboot` on both CAM and CAS.

12. Contact TAC. See Obtaining Documentation and Submitting a Service Request.

For further details on disconnecting, rebooting, or deleting a Clean Access Server see “Working with Clean Access Servers” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

**Configure Network Settings for the CAS**

This section describes the following:

- Navigating the CAS Management Pages, page 4-10
- IP Form, page 4-11
- Change Clean Access Server Type, page 4-13
- Enable L3 Support, page 4-15
Navigating the CAS Management Pages

When you click the Manage icon for a Clean Access Server in the List of Servers tab, the Clean Access Server management pages appear with a default view of the CAS Status tab, as shown in Figure 4-4.

*Figure 4-4*  Clean Access Servers Management Pages

The tabs in the Clean Access Server management pages are as follows:

- **Status**—Status of Clean Access Server modules (Started or Stopped)
- **Network**—Operating mode and interface settings (IP address, VLAN, L2/L3) for the CAS itself, DNS settings, SSL certificate management, and DHCP configuration for managed subnets.
- **Filter**—Local (per CAS) device and subnet access policies, local traffic control and bandwidth policies (by role), and local Certified Device and Floating Device lists.
- **Advanced**—Routing settings for the CAS, such as Managed Subnets (L2) or Static Routes (L3), VLAN mapping for Virtual Gateways, NAT, 1:1 NAT, ARP, and Proxy server settings.
- **Authentication**—Enable and configuration settings for local login page, OS detection, VPN concentrator SSO and Windows AD SSO.
- **Misc**—CAS software upgrade, system time, and heartbeat timer for all users.

Within each tab, click the submenu links to access individual configuration forms.
IP Form

The IP form in the Network tab (Figure 4-5) contains the network settings of the CAS configured at initial installation (or using the service perfigo config utility), as well as the CAS operating mode chosen when the CAS was added to the CAM. You must use the IP form to configure the CAS for L3 or L2 strict deployment, and you can use this form to view or change the IP address and network settings of the CAS as described below.

1. Access the IP form by navigating in the web console to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Network > IP.

![Figure 4-5 CAS Network IP Settings](image)

2. The CAS IP form includes the following settings:
   - **Clean Access Server Type**—This is the operating mode of the CAS, set when you Add the CAS to the CAM, page 4-1. See Change Clean Access Server Type, page 4-13 for additional details.
     - In-Band: Virtual Gateway or Real-IP Gateway
     - OOB: Out-of-Band Virtual Gateway or Out-of-Band Real-IP Gateway
   - **Enable L3 support**—When this option is enabled, the CAS allows all users from any hops away. For multi-hop L3 in-band deployments, this setting enables/disables L3 discovery of the CAS for web login and Agent users at the CAS level. When set, the CAS is forced to use the routing table to send packets. See Enable L3 Support, page 4-15 for details.
   - **Enable L3 strict mode to block NAT devices with NAC Agent**—When this option is checked (in conjunction with “Enable L3 support”), the CAS verifies the source IP address of user packets against the IP address sent by the Agent and blocks all L3 Agent users with NAT devices between those users and the CAS. See Enable L3 Strict Mode, page 4-17 for details.
   - **Enable L2 strict mode to block L3 devices with NAC Agent**—When this option is enabled, the CAS verifies the source MAC address of user packets against the MAC address sent by the Agent and blocks all L3 Agent users (those more than one hop away from the CAS). The user is forced to
remove any router between the CAS and the user’s client machine to gain access to the network. See Enable L2 Strict Mode, page 4-17 for details.

- All L3 or L2/L3 strict options left unchecked (Default setting)—The CAS performs in L2 mode and expects that all clients are one hop away. The CAS will not be able to distinguish if a router is between the CAS and the client and will allow the MAC address of a router as the machine of the first user who logs in and any subsequent users. Checks will not be performed on the actual client machines passing through the router as a result, as their MAC addresses will not be seen.

**Note**
- If using L2 deployment only, make sure the Enable L3 support option is not checked.
- L3 and L2 strict options are mutually exclusive; enabling one option disables the other.
- Enabling or disabling L3 or L2 strict mode always requires an Update and Reboot of the CAS to take effect. Update causes the web console to retain the changed setting until the next reboot. Reboot causes the process to start in the CAS.

- **Platform**—The platform type for the CAS. This setting reads “APPLIANCE” if the CAS is a standard Clean Access Server appliance, or “NME-NAC” if the CAS is a Cisco NAC network module installed in a Cisco ISR router chassis.

For more information on the Cisco NAC network module, see the Cisco NAC network module information included in the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) and Getting Started with Cisco NAC Network Modules in Cisco Access Routers. For detailed installation and configuration information, see Getting Started with NAC Network Modules in Cisco Access Routers and Installing Cisco Network Modules in Cisco Access Routers.

**Note** You can also determine the CAS platform type using the CAS service perfigo platform CLI command. See the “CAS CLI Commands” section in the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for more information.

- **Trusted Interface**—The trusted interface (eth0) connects the CAS to the trusted backend network.
  - IP Address: The IP address of the trusted (eth0) interface of the CAS.
  - Subnet Mask: The subnet mask for the trusted interface.
  - Default Gateway:
    - For Real-IP Gateway—This is the address of the default gateway on the trusted network, such as a network central router address.
    - For Virtual Gateway—This is the address of the existing gateway on the trusted network side of the CAS.
  - Set management VLAN ID: When set at the trusted interface, the specified VLAN ID is added to packets destined to the trusted network.

**Note** See also Native VLAN, Management VLAN, Dummy VLAN, page 4-34 for additional information needed for Virtual Gateway.

- Pass through VLAN ID to managed network: If selected, VLAN IDs in the packets are passed through the interface unmodified.
• Untrusted Interface—The untrusted interface (eth1) connects the CAS to the untrusted managed network.
  - IP Address: The IP address of the untrusted (eth1) interface of the CAS.
  - Subnet Mask: The subnet mask for the untrusted interface.
  - Default Gateway:
    - For Real-IP Gateway—The default gateway is the untrusted interface IP address of the CAS.
    - For Virtual Gateway—The default gateway is the address of the existing gateway on the trusted network side of the CAS.
  - Set management VLAN ID: When set at the untrusted interface, the specified VLAN ID is added to packets destined to clients.
  - Pass through VLAN ID to managed network: If selected, VLAN IDs in the packets are passed through the interface unmodified.

3. After modifying settings, click Update and Reboot.
   - Update causes the web console to retain the changed setting until the next reboot.
   - Reboot causes the process to start in the CAS. The CAS will restart with the new settings.

Note

Modified CAS IP settings always require an Update and Reboot of the CAS to take effect.

Note

For High Availability CAS pairs, any CAS network setting changes performed on an HA-Primary CAS through the CAS management pages or CAS direct access web console must also be repeated on the standby CAS unit through its direct access web console. These settings include updating the SSL certificate, system time/time zone, DNS, or Service IP. See Clean Access Server Direct Access Web Console, page 11-2 and the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.

Note

If you do not have a CA-signed certificate based on the DNS name of the CAS, when changing the IP address of the CAS, you must also regenerate the certificate as described in Manage CAS SSL Certificates, page 11-6.

Change Clean Access Server Type

When you add the CAS to the Clean Access Manager, you specify its operating mode: In-Band or Out-of-Band Real-IP, NAT, or Virtual Gateway. This section describes how to change the Server Type of the CAS after it has been added to the CAM as a different operating mode.

Note

You must have an OOB-enabled license to change the CAS from In-Band to Out-of-Band mode.

Switching Between NAT and Real-IP Gateway Modes

To switch between NAT and Real-IP Gateway modes:
  - Make the necessary configuration changes within the CAM admin console (for example, choose the type in the IP form, configure NAT behavior and DHCP properties, etc.)
Configure Network Settings for the CAS

- Ensure the CAS eth1 interface IP address and all assignable DHCP addresses (if used) are routable.
- If you have two CASs configured in an HA deployment, after you make necessary configuration changes, be sure to reboot the HA-Primary CAS, then reboot the HA-Secondary CAS.

Switching Between Virtual Gateway and NAT/Real-IP Gateway Modes

To switch between Virtual and Real-IP Gateway modes, you will need to change the topology of the network to reflect the modification. You must also modify the routing table on the upstream router to reflect the change. For more information on possible topology changes that are required, see Chapter 2, “Planning Your Deployment.” The general steps for switching between these types are:

1. Delete the CAS from the list of managed Clean Access Servers in the CAM.
2. Modify the network topology as appropriate. Change the cable connections to the CAS, if needed.
3. Access the CAS via SSH console and execute the `service perfigo config` utility to change the IP address of the CAS (see the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x)). You must change the eth1 IP address of the CAS.
4. Ping the CAS from the CAM’s subnet to make sure that the topology is correctly changed.
5. Add the CAS in the CAM admin console.
6. Add or re-add managed subnets with the address that the CAS will represent. The managed subnet entries must specify the CAS as the default gateway for each of the managed subnets.
7. Add static routes in the upstream router for the subnets managed by the CAS.
8. Change the CAS configuration on the CAM from the Device Management > CCA Servers > Manage [CAS_IP] > Network page, and Update and Reboot the CAS.
9. Set up the CAS as either a DHCP server or relay.
10. Update relevant configuration settings such as certificates.
11. If changing to an Out-of-Band Real-IP Gateway, make sure to enable Port Bouncing (Switch Management > Profiles > Port | Bounce the port after VLAN is changed) to help Real-IP gateway clients get a new IP address after successful authentication and certification.

Note

If using a version 4.1.2.0 or later Agent, ActiveX Control, or Java Applet to refresh client DHCP IP addresses, the Bounce the switch port after VLAN is changed option in the Port profile can be left disabled. If you use this method, be sure to follow the guidelines and warnings detailed in the “DHCP Release/Renew with Agent/ActiveX/Java Applet,” “Configuring Access to Authentication VLAN Change Detection,” and “Advanced Settings” sections of the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Enable Network Access (L3, L3 Strict or L2 Strict)

By default, Cisco NAC Appliance supports In-Band web login and Agent users within L2 proximity of the Clean Access Server.

For L2 deployments, you can optionally restrict L2 access so that Agent users cannot use home-based wireless routers or NAT devices to connect to the network.

If deploying for VPN/L3, you must enable L3 support for web login or Agent users that are multiple L3 hops away from the CAS.
You can additionally enable the “L3 strict” option, in conjunction with L3 support, to restrict L3 Agent clients from connecting to the Clean Access Server through NAT devices.

For L2 discovery, the Agent sends SWISS discovery packets to all the default gateways of all the adapters on the machine on which the Agent is running. If a CAS is present either as the default gateway (Real-IP Gateway) or as a bridge before the default gateway (Virtual Gateway), the CAS will respond and the Agent will attempt to authenticate the CAS before launching a login session.

**Note**  
This function does not apply to the Cisco NAC Web Agent.

If the CAS does not respond via L2 discovery, the Agent performs L3 discovery (if enabled). The Agent attempts to send packets to the Discovery Host, an IP address on the trusted side of the CAS. This IP address is set in the **Discovery Host** field of the **Installation** page and is set by default to the IP address of the CAM (which is always assumed to be on the trusted side of the CAS). When these packets reach a CAS (if present), the CAS intercepts the packets and responds to the Agent. The Agent then attempts to authenticate the CAS before launching a login session.

**Note**  
To discover the CAS, the Agent sends SWISS (proprietary CAS-Agent communication protocol) packets on UDP port 8905 for L2 users and on port 8906 for L3 users. The CAS always listens on UDP port 8905 and 8906 and accepts traffic on port 8905 by default. The CAS will drop traffic on UDP port 8906 unless L3 support is enabled. The Agent performs SWISS discovery every 5 seconds.

**Note**  
As a best practice recommendation, when users are L2 adjacent to the CAS, Cisco recommends using the Enable L2 strict mode to block L3 devices with the Agent. It is possible for a single CAS to support both L3 and L2 (non-restricted) Agent users. However, L2 strict mode and L3 support are mutually exclusive. Therefore, Cisco recommends against using the same CAS for L2 and L3 in-band deployment.

### Enable L3 Support

To support multi-hop L3 deployments, you need to enable L3 support on each CAS. L3 support is disabled by default after upgrade or new install, and enabling L3 support requires an update and reboot of the Clean Access Server.

**To Enable L3 Support:**

1. Go **Device Management > CCA Servers > Manage [CAS_IP] > Network** and click the checkbox for **“Enable L3 support”** (see Figure 4-5 on page 4-11).

2. Click **Update**.

3. Click **Reboot**.

**Note**  
For Agent users, the **Discovery Host** field (under **Device Management > Clean Access > Clean Access Agent > Installation**) automatically populates with the IP address of the CAM by default after new install or upgrade.
To Disable L3 Capability:
To disable L3 discovery of the Clean Access Server at the CAS level for Agent and Web Login users:

1. Go Device Management > CCA Servers > Manage [CAS_IP] > Network and uncheck the option for “Enable L3 support” (see Figure 4-5 on page 4-11).
2. Click Update.
3. Click Reboot.

VPN/L3 Access for Agents

The Clean Access Manager, Clean Access Server, and Agent support multi-hop L3 deployment. The Agent:

1. Checks the client network for the Clean Access Server (L2 deployments), and if not found,
2. Attempts to discover the CAS by sending discovery packets to the CAM. This causes the discovery packets to go through the CAS even if the CAS is multiple hops away (multi-hop deployment) so that the CAS will intercept these packets and respond to the Agent.

In order for clients to discover the CAS when they are one or more L3 hops away, clients must initially download the Agent from the CAS through the Agent download page after web login or through auto-upgrade. Either method allows the Agent to acquire the IP address of the Discovery Host (by default, the CAM) in order to send traffic to the CAM/CAS over the L3 network. Once installed in this way, the Agent can be used for L3/VPN concentrator deployments or regular L2 deployments. If using the or Cisco NAC Web Agent, clients must launch the Agent via the Launch Cisco NAC Web Agent page after web login.

Acquiring and installing the Agent on the client by means other than direct download from the CAS will not provide the necessary Discovery information to the Agent and will not allow those Agent installations to operate in a multi-hop Layer 3 deployment.

To support VPN/L3 Access, you must:

- Check the option for “Enable L3 support” and perform an Update and Reboot under Device Management > CCA Servers > Manage [CAS_IP] > Network > IP.
- There must be a valid Discovery Host under Device Management > Clean Access > Clean Access Agent > Installation (set by default to the trusted IP address of the CAM).
- Clients must initially download the Agent from the CAS, in one of the following ways:
  - Agent Download web page (i.e., via web login)
  - Auto-Upgrade to Agent version 4.6.2.113 or later
  - “Launch Cisco NAC Web Agent” web page
- You can enable SSO by integrating Cisco NAC Appliance with Cisco VPN Concentrators and/or Cisco Adaptive Security Appliances (ASAs).

Note
- Uninstalling the Agent while still on the VPN connection does not terminate the connection.
- For VPN SSO deployments, if the Agent is not downloaded from the CAS and is instead downloaded by other methods (e.g. the Cisco Software Download Site), the Agent will not be able to get the runtime IP information of the CAM and will not pop up automatically nor scan the client.
Chapter 4  Configuring the CAS Managed Network

Configure Network Settings for the CAS

If a 3.5.0 or prior version of the Agent is already installed, or if the Agent is installed through non-CAS means (e.g. Cisco Software Download Site), you must perform web login to download the Agent setup files from the CAS directly and reinstall the Agent to get the L3 capability.

---

Enable L3 Strict Mode

Administrators with L3 deployments can optionally restrict L3 Agent clients from connecting to the Clean Access Server through NAT devices using the Enable L3 strict mode to block NAT devices with NAC Agent option.

When this feature is enabled in conjunction with “Enable L3 support,” the CAS will check the client IP information automatically sent by the Agent against source IP information to ensure no NAT device exists between the CAS and the client. If a NAT device is detected between the client device and the CAS, the user is not allowed to log in.

This provides administrators with the following options when enabling network access for clients on the CAS:

- **Enable L3 support** — The CAS allows all users from any hops away.
- **Enable L3 strict mode to block NAT devices with NAC Agent** — When this option is checked (in conjunction with “Enable L3 support”), the CAS verifies the source IP address of user packets against the IP address sent by the Agent and blocks all L3 Agent users with NAT devices between those users and the CAS.
- **Enable L2 strict mode to block L3 devices with NAC Agent** — When this option is enabled, the CAS verifies the source MAC address of user packets against the MAC address sent by the Agent and blocks all L3 Agent users (those more than one hop away from the CAS). The user will be forced to remove any router between the CAS and the user’s client machine to gain access to the network.
- **All options left unchecked** (Default setting) — The CAS performs in L2 mode and expects that all clients are one hop away. The CAS will not be able to distinguish if a router is between the CAS and the client and will allow the MAC address of router as the machine of the first user who logs in and any subsequent users. Checks will not be performed on the actual client machines passing through the router as a result, as their MAC addresses will not be seen.

---

Enable L2 Strict Mode

Administrators can optionally restrict Agent users to be connected to the Clean Access Server directly as their only gateway using the Enable L2 strict mode to block L3 devices with NAC Agent option.

When this feature is enabled, the Agent will send the MAC addresses for all interfaces on the client machine with the login request to the CAS. The CAS then checks this information to ensure no NAT exists between the CAS and the client. The CAS verifies and compares MAC addresses to ensure that the MAC address seen by the CAS is the MAC address of the Agent client machine only. If user home-based wireless routers or NAT devices are detected between the client device and the CAS, the user is not allowed to log in.

**To Enable L2 strict mode to block L3 devices with an Agent**

Configure Network Settings for the CAS

Chapter 4      Configuring the CAS Managed Network

Figure 4-6 CAS Network Tab

2. Click the checkbox for **Enable L2 strict mode to block L3 devices with NAC Agent**.

3. Click **Update**.

4. Click **Reboot**.

**Note**

- Enabling or disabling L3 or L2 strict mode ALWAYS requires an **Update** and **Reboot** of the CAS to take effect. **Update** causes the web console to retain the changed setting until the next reboot. **Reboot** causes the process to start in the CAS.

- L3 and L2 strict options are mutually exclusive; enabling one option disables the other.

See the “Cisco NAC Appliance Agents” chapter of the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for additional information.
Connecting to the CAS Using the SWISS Protocol

This section describes the SWISS proprietary session initiation protocol the Agent uses to discover and initiate client machine connection to the CAS. This section contains the following topics:

- What is the SWISS Protocol?
- Discovery Host
- VPN SSO Considerations
- Overcoming Network Latency Issues That Can Delay Discovery
- Using Layer 3 SWISS Packet Delay to Conserve Bandwidth
- Supporting Multiple Active NICs on the Client Machine

What is the SWISS Protocol?

The Agent connects to the CAS by sending SWISS unicast discovery packets out on UDP ports 8905 (Layer 2) and 8906 (Layer 3) until a CAS responds and initiates a user login session. The UDP 8905 packets are directed to the client machine’s default gateway and the UDP 8906 packets are directed to the IP address configured in the CAMs Discovery Host field (Device Management > Clean Access > Clean Access Agent > Installation).

To enhance network security and adhere to FIPS 140-2 compliance, Cisco NAC Appliance encapsulates SWISS communications between client machines and CASs, including Discovery Packet transmission/acknowledgement, authentication, and posture assessment results using the HTTPS protocol. The SWISS mechanism also features an enhanced handler that uses 3DES encryption for SWISS protocol functions.

Note

SWISS protocol interaction only applies between the CAS and the Windows and Macintosh Agents. The Cisco NAC Web Agent does not connect to the CAS using the SWISS protocol.

Figure 4-7 outlines the basic Agent discovery and login session initiation process.
1. After the user connects to the network and the client machine receives an IP address (via network DHCP server or the CAS itself, depending on your system configuration), the Agent starts sending UDP discovery packets on both ports 8905 and 8906.

2. The CAS intercepts SWISS discovery packets and responds to the Agent with the CAS certificate and instructs the Agent to initiate a user login session on the client machine.

3. The Agent and CAS engage in a SWISS protocol request-response exchange to determine:
   - Authenticity of the CAS prompting login from the Agent
   - User login status (including client IP-MAC address pair for Cisco NAC Appliance release 4.1(3) and later)
   - Authentication provider list
   - VPN connection status
   - Agent upgrade version, availability, and messaging
   - SSO status (Windows Agents only)
   - VPN SSO delay interval (if required)

**Layer 2 Discovery Packets**

If the user is “Layer 2 adjacent” to the CAS, the UDP discovery packets sent out on port 8905 are directed to the client machine’s default gateway IP address and arrive at the CAS before they reach the default gateway device. That way, the CAS is able to respond to the client machine’s search for the Cisco NAC Appliance network and Agent displays the user login dialog on the client machine. (Once it intercepts the UDP discovery packets, the CAS does not forward the packets on to the client machine’s default gateway.)

**Layer 3 Discovery Packets**

If the user is one or more Layer 3 hops away from the CAS, the Agent must establish a connection with the CAS using discovery packets sent out over UDP port 8906. Although the Layer 3 discovery packets are directed to the Discovery Host address on the CAM, which is most likely (but not always) the CAM’s eth0 interface, these packets must traverse (pass from the untrusted to the trusted side of) the CAS in order to reach the CAM. That way, the CAS is able to intercept and respond to the client machine’s search for the Cisco NAC Appliance network and the Agent displays the user login dialog on the client machine.
Note

In a Layer 3 Out-of-Band deployment, Cisco recommends adding an ACL on your network access switch(es) to prevent SWISS packets from traversing the access VLAN. This simultaneously cuts down on unnecessary packets on the access network, and can help prevent authentication looping on the client machine when SWISS packets make it back to the CAS.

Discovery Host

The Discovery Host address on the CAM can be any IP address on the trusted side of the Cisco NAC Appliance network. By default, the Discovery Host address is the CAM eth0 IP address, since CAM only exists on the trusted side of the network and has exist for the Cisco NAC Appliance system to work at all. You can display the destination Discovery Host IP address the Agent uses to address Layer 3 discovery packets by right clicking on the Agent icon on the client taskbar and selecting Properties to bring up the Agent Properties and Information dialog (Figure 4-8).

Figure 4-8    Discovery Host Address in Agent Properties Dialog

In order for the Agent to discover the CAS and initiate a user login session, the Discovery Host must match the address assignment on the CAM. When users install and launch the Agent on the client machine, the Discovery Host setting automatically corresponds to the Discovery Host IP address configured on the CAM. The Discovery Host must be configured on the Agent installer in order for the Agent to discover the Cisco NAC Appliance network. If the Discovery Host is missing when the Agent is downloaded and installed on the client machine, the Agent does not know which destination IP address to use for the UDP discovery packets and will not be able to appropriately direct SWISS discovery packets.

New Agent downloads and upgrades automatically use the most recent Discovery Host address assignment. You must ensure that previously-installed Agents get updated if the Discovery Host IP address changes on the CAM. You can accomplish this in one of the following ways:
Cisco NAC Agent on Windows Client Machines

- Change the DiscoveryHost parameter in the Agent configuration XML file (NACAgentCFG.xml) and upload it to the CAM so users will automatically get the new XML file at their next login, or make the Agent update mandatory so that when users download the Agent update, the client machines are automatically updated to direct queries to the new Discovery Host address.

**Note**


VPN SSO Considerations

If users are connected to the network through an existing VPN connection and the Agent automatically sends SWISS discovery packets out searching for a CAS through which the user can log in, the CAS uses the SWISS packet request-response mechanism to tell the Agent not to display the user login dialog on the client machine. In addition, some VPN concentrators do not send out user session information immediately, so the CAS builds a “delay” into the user login session initiation process whenever VPN SSO has been configured on the Cisco NAC Appliance system. That way, the user is not required to enter their credentials more than once to log into the network for their session.

Overcoming Network Latency Issues That Can Delay Discovery

When the client machine sends out a SWISS discovery packet, it waits a full second for a CAS discovery response packet to return before trying to send a subsequent packet 5 seconds later. If the CAS responds, but network latency issues prevent the response packet from reaching the client machine in time, the client continues to check for a CAS through which it can connect to the network. To address this potential situation, administrators can set an additional “SwissTimeout” period on the client machine to allow a little extra time for the CAS discovery response packet to reach the client machine. To help ensure client machines are able to discover and authenticate with a Clean Access Server in a network featuring this sort of inherent latency, you can specify a value for the setting in the NACAgentCFG.xml Agent configuration file to affect the behavior of client machines where the Cisco NAC Agent is installed. For more details, see the “Cisco NAC Agent XML Configuration File Settings” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.

**Note**


Using Layer 3 SWISS Packet Delay to Conserve Bandwidth

In an effort to cut down on discovery packet transmission on the network, the Agent is designed to begin increasing the interval for Layer 3 discovery packet transmission when the Agent is unable to locate a CAS on the network. Instead of perpetually sending discovery packets every 5 seconds (as is the case for all Layer 2 discovery packets sent out on UDP port 8905), the Layer 3 discovery packets sent out on UDP port 8906 decrease in frequency with each subsequent transmission until the interval between
discovery packets reaches 30 minutes. After that, the Agent stops searching for a CAS until a network connection event (like unplugging the Ethernet cable from the interface and plugging it back in again) “wakes up” port 8906 and restarts the discovery process.

### Supporting Multiple Active NICs on the Client Machine

The Cisco NAC Appliance system supports Agent client machines with more than one active NIC pointing to the same (untrusted side) eth1 interface on a CAS. Historically, this particular scenario could lead to a problem where, even after a user had already logged into the network via the Agent, another user login dialog would repeatedly appear and ask the user to enter their credentials again. This situation occurred because the CAS would receive SWISS discovery packets from over the additional active interface(s) and the CAS would not determine that the request from the additional IP address-MAC address pair(s) did not originate from the same client machine on which there was already an active Agent session. To address this potential problem, when responding to a Agent query for user login, the CAS includes a “valid” IP address-MAC address pair in the return SWISS packet(s) essentially saying, “You can establish a connection to the Cisco NAC Appliance network on the client machine interface <MAC address> with IP Address A.B.C.D. All other requests from this client will be ignored while this session remains active.”

**Note**

If you use the Access to Authentication VLAN change detection feature on a client machine with more than one active NIC, all active NICs on the client use the feature. By design, the NIC with the lowest metric always takes precedence for routing purposes, and you can determine the metric using the `route print` command from a command prompt. For more detailed information on the VLAN change detection feature, see “Configuring Access to Authentication VLAN Change Detection” section in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Figure 4-9 illustrates a common scenario where the CAS behavior helps avoid a potential problem. If the user logs in to the network via an Agent session using NIC1 (the client machine’s active Ethernet interface), the CAS responds back that it will allow login requests from the NIC1 interface with the associated IP address. If the CAS then receives SWISS discovery packets originating from NIC2 (the client machine’s Wireless Ethernet connection that points to the same eth1 interface on the CAS), the CAS does not initiate another Agent login session because the IP address-MAC address pair for NIC2 does not match the pair the CAS allowed when the session was established using NIC1.

**Figure 4-9 Multiple Active Interfaces Pointing to the Same CAS eth1 IP Address**
Configuring DHCP

You can configure the CAS to be a DHCP server when the CAS is in Real-IP Gateway mode, if a DHCP server does not already exist on your network. For complete details, see Chapter 5, “Configuring DHCP.”

Configure DNS Servers on the Network

The DNS form lets you specify the Domain Name Service (DNS) servers to be queried for host name lookups.

To configure a DNS for your environment:
1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Network > DNS.

2. Type the IP addresses of one or more domain name servers in the DNS Servers field. If entering multiple servers, use commas to separate the addresses. The Clean Access Server attempts to contact the DNS servers in the order they appear in the list.
   - Host Name—The host name you want to use for the Clean Access Server.
   - Host Domain—The domain name applicable in your environment.
   - DNS Servers—The IP address of the DNS server in your environment. Separate multiple addresses with commas. If you specify more than one DNS server, the Clean Access Server tries to contact them sequentially, until one of them returns a response.

3. Click Update.

Note

For High Availability CAS pairs, any CAS network setting changes performed on an HA-Primary CAS through the CAS management pages or CAS direct access web console must also be repeated on the standby CAS unit through its direct access web console. These settings include updating the SSL certificate, system time/time zone, DNS, or Service IP. See Clean Access Server Direct Access Web Console, page 11-2 and the Cisco NAC Appliance Hardware Installation Guide, Release 4.9 for details.
Configuring Managed Subnets or Static Routes

This section describes the following:

- **Overview, page 4-25**
- **Configure Managed Subnets for L2 Deployments, page 4-27**
- **Configure Static Routes for L3 Deployments, page 4-29**

**Overview**

For all CAS modes in L2 deployment (Real-IP/NAT/Virtual Gateway) when configuring additional subnets, you must configure Managed Subnets in the CAS so that the CAS can send ARP queries with appropriate VLAN IDs for client machines on the untrusted interface. You must configure the untrusted (authentication) VLAN in the VLAN ID field of the Managed Subnet.

Managed Subnets are only for user subnets that are Layer 2 adjacent to the CAS.

For all CAS modes in L3 deployment, Static Routes must be configured for the user subnets that are one or more hops away. Managed subnets should not be configured for these subnets. See **Configure Static Routes for L3 Deployments, page 4-29** for details.

---

**Note**

In the case of a multi-hop L3 deployment where the VPN concentrator performs Proxy ARP for client machines, managed subnets can be used instead of static routes and should be created in the CAS.

Table 4-1 summarizes the steps required for each deployment. Forms mentioned below are located in the CAS management pages under Device Management > CCA Servers > Manage [CAS_IP].

---

**Note**

- For IPs with VLAN restrictions, all IPs must be in a managed subnet, and you must create a managed subnet first before creating an IP range (DHCP pool).
- For IPs with relay restrictions, all IPs should typically be in static routes, but can be in managed subnets if integrating the CAS with Aironet devices or other non-RFC 2131/2132 compliant devices. Note that these IP address pools must be in either a static route or a managed subnet, and IPs with relay restrictions should only be put in a managed subnet for these non-compliant devices.

See **Configuring IP Ranges (IP Address Pools), page 5-5** for details.

---

### Table 4-1 Guidelines for Adding Managed Subnets vs. Static Routes

<table>
<thead>
<tr>
<th>Layer 2—In-Band or Out-of-Band (CAS has L2 proximity to users)</th>
<th>Layer 3 (Multi-Hop)—In-Band Only (e.g. CAS is behind VPN Concentrator or Router or L3 Switch)</th>
</tr>
</thead>
<tbody>
<tr>
<td>For Real-IP Gateways:</td>
<td>For Real-IP Gateways:</td>
</tr>
<tr>
<td>If the router below the CAS performs proxy ARP:</td>
<td>If the router below the CAS does NOT perform proxy ARP:</td>
</tr>
</tbody>
</table>
Configuring Managed Subnets or Static Routes

### Table 4-1 Guidelines for Adding Managed Subnets vs. Static Routes

<table>
<thead>
<tr>
<th>Layer 2—In-Band or Out-of-Band (CAS has L2 proximity to users)</th>
<th>Layer 3 (Multi-Hop)—In-Band Only (e.g. CAS is behind VPN Concentrator or Router or L3 Switch)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a managed subnet under Advanced &gt; Managed Subnet to assign the gateway IP address of the subnet to the CAS. For example, to configure the CAS to be the gateway (10.10.10.1) for VLAN 10 /subnet 10.10.10.0, specify the following managed subnet:</td>
<td>Always add a managed subnet under Advanced &gt; Managed Subnet</td>
</tr>
<tr>
<td>IP Address: 10.10.10.1 Subnet Mask: 255.255.255.0 VLAN ID: 10</td>
<td>1. Always add static routes for the subnets on the untrusted side under Advanced &gt; Static Routes. For example:</td>
</tr>
<tr>
<td>For Virtual Gateways:</td>
<td>Network Mask Interface Gateway</td>
</tr>
<tr>
<td>Add a managed subnet under Advanced &gt; Managed Subnet to assign an IP address to the CAS that is otherwise unused on the subnet. For example, to have the CAS manage subnet 10.10.10.0/24 on VLAN 10 where the gateway for this subnet is 10.10.10.1, you will need to reserve an IP address for the CAS, such as 10.10.10.2. Specify the following managed subnet:</td>
<td>2. Specify an ARP entry for the gateway IP that the CAS needs to hold under Advanced &gt; ARP. For example:</td>
</tr>
<tr>
<td>IP Address: 10.10.10.2 Subnet Mask: 255.255.255.0 VLAN ID: 10 The CAS is not the gateway, but owns the 10.10.10.2 address for this VLAN/subnet.</td>
<td>10.10.10.0 255.255.255.255 eth1</td>
</tr>
<tr>
<td>See Figure 4-11 on page 4-27.</td>
<td>Note When deploying the CAS in L3 VGW mode, the gateway is not optional and you must specify the gateway for the static route.</td>
</tr>
</tbody>
</table>

**Note** In general, when the CAS is in Virtual Gateway mode for Layer 2 or Layer 3, you cannot ping the gateways of the subnets being handled by the CAS. This should not affect the connectivity of the users on these subnets.
Configure Managed Subnets for L2 Deployments

When the Clean Access Server is first added to the Clean Access Manager, the untrusted IP address provided for the CAS is automatically assigned a VLAN ID of -1 to denote a Main Subnet. By default, the untrusted network the Clean Access Server initially manages is the Main Subnet.

You can configure the CAS to manage additional subnets by adding them under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnet. In this case, the Clean Access Server acts as the virtual default gateway for the untrusted (authentication) managed subnets, and puts a virtual IP for the added managed subnet on the untrusted interface.

If the Clean Access Server is a Real-IP Gateway, you will need to add a static route on the upstream router to send traffic to the CAS. For example, for managed subnet 10.0.0.0/24, you will need to add static route 10.0.0.0/255.255.0.0 gateway <CAS_eth0_IP_address> to the upstream router.

To modify the Main Subnet of the CAS, go to Device Management > CCA Servers > Manage [CAS_IP] > Network > IP. To change the VLAN ID of the Main Subnet, enter it in the Set management VLAN ID field in the Untrusted Interface side of the form. If modifying the IP Address, Subnet Mask, Default Gateway, or management VLAN ID for the untrusted interface of the CAS, you must click Update then Reboot for the new settings to take effect on the CAS and on the network.

When you create a managed subnet, an ARP entry is automatically generated for the gateway of the subnet. Therefore, to manage a subnet of 10.1.1.0/255.255.255.0, configure the managed subnet with the following values:

- IP Address: 10.1.1.1 (if 10.1.1.1 is the desired default gateway)
Configuring Managed Subnets or Static Routes

- Subnet Mask: 255.255.255.0

An ARP entry is automatically generated for the 10.1.1.1 address, the presumed gateway. However, if using a non-standard gateway address (such as 10.1.1.213 for the 10.1.1.0/255.255.255.0 subnet), you will need to create the managed subnet as 10.1.1.213/255.255.255.0.

Adding Managed Subnets

1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnet.

**Figure 4-12 Managed Subnet**

2. In the **IP Address** field, type the IP address that the CAS will own for the managed subnet (the CAS will perform ARP for this IP address):
   - For Real-IP Gateways, the CAS will own the gateway IP address of the managed subnet (for example, 10.10.10.1).
   - For Virtual Gateways, the CAS will own an IP address on the managed subnet that is otherwise unused (for example, 10.10.10.2)

   See Table 4-1 on page 4-25, “Guidelines for Adding Managed Subnets vs. Static Routes” for details.

3. In the **Subnet Mask** field, type the mask for the network address. The CAM calculates the network address by applying the subnet mask to the **IP Address** field.

4. In the **VLAN ID** field, type the untrusted (authentication) VLAN ID associated with this subnet. Use -1 if the subnet is not on a VLAN.

   **Note** The VLAN column for the Main Subnet displays the eth1 Management VLAN of the CAS (if available) or “-1” if no eth1 Management VLAN is set for the CAS.

5. Click **Add Managed Subnet** to save the subnet.

6. Reboot. A reboot is needed after adding a managed subnet.
If you need to provide an ARP entry for the managed subnet other than the one created by default, use the instructions in Add ARP Entry, page 4-31. For the entry, use the gateway address for the subnet and set the Link value to Untrusted (eth1).

**Configure Static Routes for L3 Deployments**

L3 deployments (and some VPN concentrators deployments) should not use Managed Subnets and should only use Static Routes to configure how the CAS should route packets. The Static Route form (Figure 4-15) lets you set up routing rules in the Clean Access Server. Static Routes have the form:

Network / subnet mask / send packets to interface (trusted or untrusted) / Gateway IP address (optional)

Any packet that comes into the CAS is evaluated based on static routes, then routed appropriately to the router. When the CAS receives a packet, it looks through its static route table, finds the most specific match, and if that route has a gateway specified, the CAS sends packets through that gateway. If no gateway is specified, then the CAS puts packets on the interface specified for the route (eth0 or eth1).

**Note**

If converting from L2 to L3 deployment, remove managed subnets and add static routes instead.

Figure 4-13 illustrates a Layer 3 deployment scenario that requires a static route.

![Static Route Example (Layer 3)](image-url)
Configuring Static Routes for Layer 2 Deployments

Figure 4-14 illustrates a Layer 2 deployment scenario that requires a static route. In this case, the Clean Access Server operates as a Virtual Gateway. Two gateways exist on the trusted network (GW1 and GW2). The address for the second gateway, GW2, is outside the address space of the first gateway, which includes the Clean Access Server interfaces. The static route ensures that traffic intended for GW2 is correctly passed to the Clean Access Server’s trusted interface (eth0).

Add Static Route

1. Open the Static Routes form in the Advanced tab of the CAS management pages.

2. In the Static Routes form, type the destination IP address and subnet mask (in CIDR format) in the Dest. Subnet Address/Mask fields. If the destination address in the packet matches this address, the packet is routed to the specified interface.
3. If needed, type the external, destination **Gateway** address (such as 10.1.52.1 in Figure 4-14).

**Note**

For Virtual Gateway mode, the **Gateway** address is not optional and must always be specified.

4. Choose the appropriate interface of the Clean Access Server machine from the **Link** dropdown list. In most cases this is eth0, since most static routing scenarios involve directing traffic from the untrusted to the trusted network.

5. Optionally, type a **Description** of the route definition.

6. Click **Add Route**.

### Configure ARP Entries

An ARP (Address Resolution Protocol) entry allows you to associate IP addresses with one of the Clean Access Server’s interfaces. An ARP entry is typically used to advertise to the trusted network that certain addresses are within the Clean Access Server’s managed domain, so that traffic for the managed clients can be directed to the Clean Access Server’s untrusted interface.

ARP entries are automatically created for:

- The untrusted network specified for the Clean Access Server in the **IP** form.
- Any managed subnets you added (see Configuring Managed Subnets or Static Routes, page 4-25).
- Auto-generated subnets created during DHCP configuration. These entries are identified by the description “ARP Generated for DHCP.” (see Figure 5-12 on page 5-14)

### Add ARP Entry

Use the following steps to manually create an ARP entry.

1. Open the **ARP** form in the **Advanced** tab.

*Figure 4-16 Create ARP Entry*
2. Type the IP address of the network or machine to be associated with the interface along with the subnet mask in the **Subnet Address/Mask** fields. If creating an ARP entry for a single address, such as a virtual default gateway address, specify the address and use 255.255.255.255 as the subnet mask.

3. Choose the interface from the **Link** dropdown menu (usually eth1, the untrusted interface).

4. Optionally, type a **Description** of the ARP entry.

5. Click **Add ARP Entry** to save the settings.

6. Clicking the **Flush ARP Cache** button clears cached MAC-to-IP address associations.

---

### Understanding VLAN Settings

The Clean Access Server can serve either as a VLAN termination point or it can perform VLAN passthrough. In a Virtual Gateway configuration, VLAN IDs are passed through by default.

In a Real-IP Gateway configuration, by default the VLAN identifiers are terminated at the CAS (that is, identifiers are stripped from packets received at the trusted and untrusted interfaces). However, if you enable VLAN ID passthrough, packets retain their VLAN identifiers.

---

**Note**

Due to Roaming feature deprecation, the **Continuously broadcast gratuitous ARP with VLAN ID** option is removed.

---

Use care when configuring VLAN settings. Incorrect VLAN settings can cause the CAS to be inaccessible from the CAM web admin console. If you cannot access the CAS from the CAM after modifying the VLAN settings, you will need to access the CAS directly to correct its configuration, as described in the *Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x)*.
VLAN settings for the CAS eth0 and eth1 interfaces are set under **Device Management > CCA Servers > Manage [CAS_IP] > Network > IP**. The settings are as follows:

- **Set management VLAN ID**—The default VLAN identifier value added to packets that do not have an identifier. Set at the untrusted (eth1) interface to add the VLAN ID to packets directed to managed clients, or at the trusted (eth0) interface to add the VLAN ID to packets destined for the trusted (protected) network.

- **Pass through VLAN ID to managed network / Pass through VLAN ID to protected network**—If selected, VLAN identifiers in the packets are passed through the interface unmodified.

As mentioned, by setting the management VLAN ID value for the managed network, you can add VLAN ID tags to the outbound traffic of the entire managed network. You can also set VLAN IDs based on other characteristics. Specifically, the CAS can tag outbound traffic by:

- Managed network (under **Device Management > CCA Servers > Manage [CAS_IP] > Network > IP**)
- Managed subnet (under **Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnet**)
- User role (under **User Management> User Roles > User Roles > New or Edit Role**)

For example, if you set the VLAN ID for the *faculty* role to 1005, the CAS would set that VLAN ID on every packet belonging to a user in that role as the packet went from the untrusted side to the trusted side of the Clean Access Server.

In addition, once VLAN tagging is configured, traffic from users on a particular VLAN ID and authenticated by an external authentication source can be mapped to a specific user role (under **User Management> Auth Servers > Mapping Rules**). Role mapping rules can use the user’s VLAN ID as one of the attributes when assigning a user to a role. See the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for details.

### Enable Subnet-Based VLAN Retag in Virtual Gateway Mode

The Managed Subnet form (**Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnet**) allows you to add managed subnets for Clean Access Servers in Real-IP, NAT and Virtual Gateway modes as described in **Configure Managed Subnets for L2 Deployments, page 4-27**. Traffic originating from the untrusted interface of the CAS is tagged according to the VLAN ID set for the managed subnet.

For CASs in Virtual Gateway mode only, the **Enable subnet-based VLAN retag** option appears at the top of the **Managed Subnet** form, as shown in **Figure 4-17**.
This feature is more useful on wireless networks than on wired networks. For example, assume that a single CAS in Virtual Gateway mode is managing multiple subnets/VLANs, where each subnet is a separate VLAN. If a user is initially connected to an Access Point on VLAN A, the user will receive an IP address on subnet A. Assume that due to overlapping wireless signals, the user is subsequently connected to an AP on VLAN B. If the Enable subnet-based VLAN retag feature is not enabled, the user’s traffic will not be routed correctly since their address is on subnet A (i.e. VLAN A) but their packets are tagged with VLAN B. This feature allows the CAS to retag packets based on the subnet to which they belong, thus enabling the packets to be routed correctly.

VLAN Mapping in Virtual Gateway Modes

For Clean Access Servers in Virtual Gateway mode only, the VLAN mapping form appears under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > VLAN Mapping. This form allows you to map an untrusted interface VLAN ID to a trusted network VLAN ID. Traffic going through the CAS will be VLAN-retagged according to this VLAN Mapping setting.

Native VLAN, Management VLAN, Dummy VLAN

For best practice purposes, and to prevent trunking configuration issues for Virtual Gateway deployments, Cisco NAC Appliance requires differentiating native, management, and dummy VLANs when configuring your switches.

Caution

Do not put the Clean Access Server on VLAN 1.

A native VLAN is present whether or not one is declared; the default is VLAN 1. By default all Cisco switches have their ports configured to be in VLAN 1, and a trunk link has the native VLAN set as VLAN 1. In addition to the well-known vulnerabilities associated with VLAN 1, as a security appliance, Cisco explicitly recommends setting the native VLAN to a VLAN other than VLAN 1. This ensures that no
traffic is unknowingly passed to or through the CAS on this VLAN. For example, if there is a misconfiguration on the trunk link or any unknown traffic on VLAN 1 (such as a user connecting a laptop on an unused port on default VLAN 1) this will not cause any problems on the CAS.

**Note**
The VLAN 1 restriction is required for the CAS, and highly recommended for the CAM. Because of the configuration requirements on the CAS in Virtual Gateway mode, where no common VLANs should exist between the trusted and untrusted port, VLAN 1 should not be used at all on either the trusted port or the untrusted port. This ensures that a Layer 2 loop cannot occur on VLAN 1 due to misconfiguration.

Although the management VLAN could be the native VLAN, setting the management VLAN to another value also ensures that all traffic that passes to or through the CAS is tagged and that there is no question that the CAS properly associates the traffic either to the Management VLAN of the CAS or to the VLAN mappings from the untrusted to trusted interface of the CAS. For this reason, the “dummy” VLAN is also used so that any untagged packet is correctly dropped.

**Note**
The Management VLAN for the CAS is set under Network > IP. VLAN mappings are set on the CAS under Advanced > VLAN Mapping.

Best practice dictates the use of different dummy VLAN IDs, for example 998 and 999, for the native VLANs on the eth0 and eth1 interfaces of the CAS. This ensures that untagged traffic is dropped and is never passed unknowingly between the Untrusted and Trusted CAS interfaces. The CAS should not pass the traffic in either case without a VLAN mapping. However, the use of different dummy VLAN IDs prevents the possibility of manual/administrator errors resulting in the incorrect passing of traffic to or through the CAS via the native VLAN.

**VLAN Mapping for In-Band**

When a Clean Access Server operates in Virtual Gateway mode, it passes network traffic from its eth0 interface to eth1 and from eth1 to eth0 without changing the VLAN tag.

For In-Band configurations, in order to pass traffic from both interfaces through the same Layer 2 switch without creating a loop, it is necessary to place incoming traffic to the Clean Access Server on a different VLAN from the outgoing traffic of the Clean Access Server.

**VLAN Mapping for Out-of-Band**

In Out-of-Band Virtual Gateway mode, the OOB Clean Access Server uses VLAN mapping to retag an unauthenticated client’s allowed traffic (e.g. DHCP/DNS) from the Authentication VLAN to the Access VLAN and vice versa.

**Note**
See the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for all other details on OOB configuration.

**Switch Configuration for Out-of-Band Virtual Gateway Mode**

**Obtain the following VLAN IDs for Cisco NAC Appliance:**

- VLAN for the Clean Access Manager (the management VLAN, e.g. 64)
VLAN for the Clean Access Server (a new management VLAN, e.g. 222)

**Note**  For a Virtual Gateway, the management VLAN for the CAS must be different from the CAM.

- VLAN(s) for Access (e.g., 10, 20, 30, 40)
- VLAN(s) for Authentication (e.g. 610, 620, 630, 640)
- Dummy (unused) VLAN for native VLAN settings on switch interfaces connected to the CAS interfaces (e.g. 998, 999)

**Example switch configuration on the switch interfaces connecting to eth0 of the CAS:**

- switchport trunk encapsulation dot1q
- switchport trunk native vlan 998
- switchport trunk allowed vlan 10,20,30,40,222

**Example switch configuration on the switch interfaces connecting to eth1 of the CAS:**

- switchport trunk encapsulation dot1q
- switchport trunk native vlan 999
- switchport trunk allowed vlan 610,620,630,640

**CAS eth0 and eth1 network settings:**

(ToDevice Management > CCA Servers > Manage [CAS_IP] > Network > IP):

- Set Trusted management VLAN ID (e.g. 222)

![Setting the Management VLAN ID](image)

**Note**  You must prune VLANs on both the trusted and untrusted sides to only the VLANs that the CAS needs to manage. You must also prune VLAN 1 out of the trunk on both sides.

**Configure VLAN Mapping**

1. Go to Device Management > CCA Servers > List of Servers and click the Manage button for the CAS you added. The CAS management pages appear.
2. Click the Advanced tab.
3. Click the VLAN Mapping link.
Figure 4-19   Enable VLAN Mapping

4. Click the checkbox for **Enable VLAN Pruning** if you want to block any unmapped VLAN packets passing across CAS interfaces in both directions (from Untrusted -> Trusted and from Trusted -> Untrusted).

   **Note** VLAN Pruning is enabled by default.

   The following table briefly describes the net effect on VLAN traffic when VLAN pruning and VLAN mapping are enabled and disabled:

<table>
<thead>
<tr>
<th>VLAN Pruning</th>
<th>VLAN Mapping</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>ON</td>
<td>ON</td>
<td>Discard all unmapped VLAN packets</td>
</tr>
<tr>
<td>ON</td>
<td>OFF</td>
<td>Discard all VLAN packets regardless of mapping</td>
</tr>
<tr>
<td>OFF</td>
<td>ON</td>
<td>Potential Layer 2 UDP broadcast storm due to VLAN packet loop</td>
</tr>
<tr>
<td>OFF</td>
<td>OFF</td>
<td>Potential Layer 2 UDP broadcast storm due to VLAN packet loop</td>
</tr>
</tbody>
</table>

**Warning** If the Enable VLAN Pruning option is enabled alone, the CAS discards all VLAN packets passing through in either direction.

5. Click the checkbox for **Enable VLAN Mapping** and click Update.
6. Enter the Auth VLAN ID for the **Untrusted network VLAN ID** field.
7. Enter the Access VLAN ID for the **Trusted network VLAN ID** field.
8. Type an optional **Description** (such as Users on edge switch).
Local Device and Subnet Filtering

As typically implemented, Cisco NAC Appliance enforces authentication requirements on clients attempting to access the network. Device and subnet filters allow you to define specialized access privileges or limitations for particular clients.

Access policies set in the CAS management page apply only to the CAS being administered. To configure global passthrough policies for all Clean Access Servers, go to the Device Management > Filters module in the CAM web console. Note that local policies typically override global settings.

A device/subnet filter can:
- Allow all traffic for a device/subnet without requiring authentication.
- Block a device/subnet from accessing the network.
- Exempt a device/subnet from authentication while applying other policies of a role for the device(s).
A filter policy is one way that a Cisco NAC Appliance role can be assigned to a client. The order of priority for role assignment as follows:

1. MAC address
2. Subnet / IP address
3. Login information (login ID, user attributes from auth server, VLAN ID of user machine, etc.)

Therefore, if a MAC address associates the client with “Role A”, but the user’s login ID associates him or her to “Role B”, “Role A” is used.

**Note**


**Note**

Device filter settings and/or subnet filter settings take precedence over the CAS Fallback Policy. While in CAS fallback mode, CAS device filter settings determine behavior based on the client MAC address. If device filter settings do not apply (for example, if the CAS is a Layer 3 gateway and cannot determine the client MAC address), the CAS also looks for applicable subnet filter settings before applying the CAS Fallback Policy. See CAS Fallback Policy, page 4-44 for details.

### Configure Local Device Access Filter Policies

You can configure local device filter polices for in-band deployments.

**Step 1**

Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Filter > Devices.

**Figure 4-21**  Local Device Filters List

**Step 2**

Click New. The New local filter form appears as shown in Figure 4-22.

**Step 3**

In the Devices form, enter the MAC address of the device(s) for which you want to create a policy in the MAC Address/IP Address Description text field. Type one entry per line using the following format:

```
<MAC>/<optional_IP> <optional_entry_description>
```

Note the following:

- You can use wildcards “*” or a range “-” to specify multiple MAC addresses.
- Separate multiple devices with a return.
If you enter both a MAC and an IP address, the client must match both for the rule to apply.

You can specify a description by device or for all devices. A description specific to a particular device (in the MAC Address field) supersedes a description that applies all devices in the Description (all entries) field. There cannot be spaces within the description in the device entry.

**Step 4** Choose the policy for the device from the Access Type choices:
- **ALLOW**—IB - bypass login, bypass posture assessment, allow access
- **DENY**—IB - bypass login, bypass posture assessment, deny access
- **ROLE**—IB - bypass login, bypass L2 posture assessment, assign role
- **CHECK**—IB - bypass login, apply posture assessment, assign role

**Step 5** If using CHECK or ROLE, choose a role from the User Role dropdown menu.

**Step 6** Click Add to save the policy. The policy appears in the list at the bottom of the page.

The following examples are all valid entries (that can be entered at the same time):

```
00:16:21:11:4D:67/10.1.12.9 pocket_pc
00:16:21:12:* group1
```
By default, Cisco Clean Access (CAS) forces user devices (identified by MAC address and IP address combination) on the untrusted side of the CAS to authenticate in order to access the network. This page allows you to specify options to bypass authentication and posture assessment on device's MAC address (and IP address).

Note that server-specific device filters are not applicable in Out-of-Band (OOB) deployments. For OOB, you must define global device filters.

MAC Address/IPv4 Address | Description (per entry)
--- | ---

**Access Type**
- **ALLOW**: 18 - bypass login, bypass posture assessment, allow access
- **DENY**: 18 - bypass login, bypass posture assessment, deny access
- **ROLE**: 18 - bypass login, bypass L2 posture assessment, assign role
- **CHECK**: 18 - bypass login, apply posture assessment, assign role

**Note**: Device filter policies have different applicability in L2 deployments (deployments where the CAS is in L2 proximity to the end-point/user devices) versus L3 deployments (where the CAS may be one or more hops away from the end-points/user devices). Note that in an L3 deployment, the endpoint needs to access the network using a web browser (directly/indirectly) or the Clean Access Agent for Clean Access to be able to obtain the endpoint’s MAC address. The behavior in L2 and L3 deployments is different as follows:

<table>
<thead>
<tr>
<th>Option</th>
<th>L2</th>
<th>L3</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ALLOW</strong></td>
<td>Allows all traffic from the end-point if no authentication or posture assessment is required</td>
<td>Allows all traffic from the end-point once the MAC address is known until which time traffic from the end-point is subject to policies in Unauthenticated Role - no authentication or posture assessment is required. <strong>Note</strong>: If MAC address of next hop router connected to the untrusted side of CAS is allowed, all clients going through that router are allowed!</td>
</tr>
<tr>
<td><strong>DENY</strong></td>
<td>Denies all traffic from the end-point</td>
<td>Denies all traffic from the end-point once the MAC address is known until which time traffic from the end-point is subject to policies in Unauthenticated Role</td>
</tr>
<tr>
<td><strong>ROLE</strong></td>
<td>Allows traffic from the end-point without any authentication or posture assessment (for backward compatibility with CAS 3.x, this will continue to behave the same way)</td>
<td>Once MAC address is known, posture assessment is performed if configured following which traffic is allowed as per role traffic policies</td>
</tr>
<tr>
<td><strong>CHECK</strong></td>
<td>Performs posture assessment as specified for the role following which traffic is allowed as per role traffic policies</td>
<td>Same as above</td>
</tr>
</tbody>
</table>

**Note**: If bandwidth management is enabled, devices allowed without specifying a role will use the bandwidth of the Unauthenticated Role.
You can sort the columns of the filter list by clicking on the column heading label (MAC Address, IP Address, Description, Access Type).

You can edit a device access policy by clicking the **Edit** button. Note that the MAC address is not an editable property of the filter policy. To modify a MAC address, create a new filter policy and delete the existing policy.

You can remove any number of device access policies by clicking the checkbox next to the policy and clicking the **Delete** button.

---

**View Active L2 Device Filter Policies**

To view active Layer 2 devices in filter policies for a particular Clean Access Server:

**Step 1** Go to **Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Filter > Devices > Active**.

**Step 2** Click the **Show All** button first to populate the **Active** page with the information from all clients currently connected to the CAS, sending packets, and with their MAC addresses in a device filter.

**Step 3** You can also perform a **Search** on a client IP or MAC address to populate the page with the result. By default, the **Search** parameter performed is equivalent to “contains” for the value entered in the **Search IP/MAC Address** field.

For performance considerations, the **Active** page only displays the most current device information when you refresh the page by clicking **Show All** or **Search**.

**Figure 4-23  Active**

To view active devices for all CASs from the CAM, go **Device Management > Filters > Devices > Active**.
Configure Subnet Access Filter Policies

The **Subnets** form allows you to specify access rules for an entire subnet. All devices accessing the network from the subnet are subject to the rule.

**To set up subnet-based access controls:**
1. Click the **Subnets** link in the **Filter** tab.
2. In the **Subnet address/netmask** fields, enter the address of the subnet and the netmask identifying the significant bits of the subnet address.

**Figure 4-24   Local Subnet Filter**

3. Optionally, type a description of the policy or device in the **Description** field.
4. Choose the network access policy for the device from the **Access Type** choices:
   - **allow** – Enables the device to access the network without authentication.
   - **deny** – Prevents the device from accessing the network. If applicable, the user is blocked and an HTML page appears notifying the user that access is denied.
   - **use role** – Applies a role to users with the specified device. If you select this option, also select the role to be applied. The user will not need to be authenticated.
5. Click **Add** to save the policy.

The policy, which takes effect immediately, appears in the filter policy list. From there you can remove a subnet policy using the **Delete** button or edit it by clicking the **Edit** button. Note that the subnet address is not an editable property of the filter policy. To modify an address, you need to create a new filter policy and delete the existing one.

You can sort the filter list by column by clicking the heading label (e.g. Subnet, Description).
Chapter 4      Configuring the CAS Managed Network

CAS Fallback Policy

The CAS Fallback policy feature allows administrators to configure the level of user access permitted by the Clean Access Server when the Clean Access Manager becomes unreachable from the CAS. For example, if a remote CAS attempts to reach the CAM, but the WAN link fails, CAS Fallback can be used to specify the user access policy: allow all user traffic, block all user traffic, or only allow traffic for already-authenticated users (default CAS behavior).

Note

The CAS Fallback feature is for situations where communication between the CAS and CAM is lost. For protection against CAS failure itself in a Central Deployment, Cisco recommends deploying a CAS high availability (HA) failover bundle. See the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.

The CAS checks the status of the CAM periodically, according to the Detect Interval specified. If the CAM is unreachable a predetermined percentage of the time over the course of the specified Detect Timeout period, the CAS sets the traffic policy of every user role to “Allow All,” “Block All” or “Ignore” based on the specified Fallback Policy. You can specify the Detect Interval, Detect Timeout, and Fail Percentage threshold values as described below.

Device filter settings and/or subnet filter settings take precedence over the CAS Fallback Policy. While in CAS fallback mode, CAS device filter settings determine behavior based on the client MAC address. If device filter settings do not apply (for example, if the CAS is a Layer 3 gateway and cannot determine the client MAC address), the CAS also looks for applicable subnet filter settings before applying the CAS Fallback Policy.

Note

If the CAS enters Fallback mode and the Enable Heartbeat Timer option is enabled in the Device Management > CCA Servers > Manage [CAS_IP] > Misc > Heartbeat Timer web console page, user sessions are still terminated and cleared from the Online Users List and Certified Devices List after the specified time period has passed. For more information, see Local Heartbeat Timer, page 9-1.

During CAS fallback recovery (where the CAS is reconnecting to the CAM), a login dialog appears to users accessing the Cisco NAC Appliance network via the CAS, but they are unable to authenticate and login for approximately 2 minutes. (Until CAS fallback recovery completes, users see a “Failed to add user to the list” error message when attempting to log in.)

Note

You can use the failSafeStatus script in the CAS CLI to determine whether or not the CAS is currently operating normally or in Fallback state. To run the script, log into the CAS CLI as root and type failSafeStatus from the /perfigo/access/bin/ directory.

Note

Starting from release 4.5(1), when a standby CAS in an HA pair assumes the role of an active CAS that is performing DHCP address management and has gone into Fallback state, the new active CAS also assumes DHCP functions in addition to user login.
Configuring CAS Fallback

Step 1  Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Fallback.

Figure 4-25  CAS Fallback

Step 2  From the Fallback Policy dropdown menu, select one of the following options:

- **Ignore** (default)—Allow traffic only for authenticated users but block new users. This allows existing (authenticated) users to access local and remote site resources, but new (unauthenticated) users will be blocked.
- **Allow All**—Allow all traffic for all users (authenticated and new). This allows new and existing users to access local and remote site resources.
- **Block All**—Block all traffic for all users (authenticated and new). This blocks all users from accessing local and remote site resources.

Step 3  Specify a **Detect Interval** (default is 20 seconds). The **Detect Interval** specifies how often the CAS polls the CAM to verify whether it is still reachable on the network. The minimum **Detect Interval** must be 20 seconds.

Step 4  Specify a **Detect Timeout** (default is 300 seconds). The **Detect Timeout** specifies the duration of time the CAS continues to poll the CAM before determining whether or not it is reachable. If the **Fail Percentage** of verification polls fail (see Table 4-2), the CAS declares the CAM unreachable and triggers the CAS Fallback Policy. The **Detect Timeout** value must be at least 15 times the **Detect Interval** (default is 300 seconds), but Cisco recommends setting the **Detect Timeout** to 30 times the **Detect Interval** value (e.g. Detect Timeout of 600 seconds for a Detect Interval of 20 seconds).

Note  Default values for the **Detect Interval** and **Detect Timeout** settings apply to new installations of Cisco NAC Appliance release 4.5(1) and later. If you upgrade from a previous Cisco NAC Appliance release, your original **Detect Interval** and **Detect Timeout** values are preserved, and you may have to specify new settings to maintain expected CAS Fallback behavior.
Step 5 Specify a **Fail Percentage**. The **Fail Percentage** specifies the percentage of CAS polling events allowed to fail over the course of the **Detect Timeout** before the CAS declares the CAM unreachable and triggers the Fallback Policy. To help ensure network stability and minimize CAS Failover events, the **Fail Percentage** setting must be at least 25%, but cannot be more than 50%.

To determine the number of CAS events/polls to monitor over the course of the **Detect Timeout**, simply divide the **Detect Timeout** by the **Detect Interval**. Once you know the number of verification polls the CAS performs, apply the Fail Percentage to determine how many poll events must fail during the **Detect Timeout** to trigger CAS Fallback.

For example, if the CAS performs 15 verification polls over the course of the **Detect Timeout** period, and the CAS is configured to Fallback when 30% of the CAS-to-CAM verification polls fail (that is, you have specified a **Fail Percentage** value of 30), then CAS Fallback will occur when 5 or more verification polls to the CAM fail—30% of 15 polls is 4.5 polls (rounded up to 5). (See Table 4-2 for more examples.)

**Note** For CAS Fallback calculations, always round fractions up to the next integer value.

Step 6 The **Resume Percentage** value is automatically populated depending on the specified **Fail Percentage** value. The **Resume Percentage** indicates the percentage of successful responses from the CAM required to bring the CAS back into normal operation after a CAS Fallback event.

Following a CAS Fallback event, the CAS continues monitoring connection with the CAM according to the specified Fallback parameters and resumes normal operation when the CAM responds to a minimum percentage of periodic connection verification polls over the course of the **Detect Timeout**. The function determining the **Resume Percentage** value is a 100% success rate minus one half of the **Fail Percentage**. Therefore, if the specified **Fail Percentage** is 30%, the CAS resumes normal operation when the CAM responds to 85% (100% minus one half of 30%, or 15%) of the polls during the **Detect Timeout** period.

Step 7 Click **Update**.

Table 4-2 provides some sample CAS Fallback settings with Fallback Policy results in a Cisco NAC Appliance system where CAS Fallback has been enabled. Values in bold are user specified.

**Table 4-2 Sample CAS Fallback Settings and Results**

<table>
<thead>
<tr>
<th>Detect Interval (specify)</th>
<th>Detect Timeout (specify)</th>
<th>Number of CAS Polls over Detect Timeout (Detect Timeout/ Detect Interval)</th>
<th>Fail Percentage 25%-50% (specify)</th>
<th>Number of Failed Polls to Trigger CAS Fallback (CAS Polls x Fail Percentage)</th>
<th>Resume Percentage (100 - Fail Percentage/2)</th>
<th>Number of Successful Polls over Detect Timeout for CAS to Resume Operation (CAS Polls x Resume Percentage)</th>
</tr>
</thead>
<tbody>
<tr>
<td>20 sec</td>
<td>300 sec</td>
<td>15</td>
<td>30%</td>
<td>5 (4.5 rounded up)</td>
<td>85%</td>
<td>13 (12.75 rounded up)</td>
</tr>
<tr>
<td>20 sec</td>
<td>600 sec</td>
<td>30</td>
<td>30%</td>
<td>9</td>
<td>85%</td>
<td>26 (25.5 rounded up)</td>
</tr>
<tr>
<td>20 sec</td>
<td>400 sec</td>
<td>20</td>
<td>25%</td>
<td>5</td>
<td>88% (87.5% rounded up)</td>
<td>18 (17.5 rounded up)</td>
</tr>
<tr>
<td>30 sec</td>
<td>600 sec</td>
<td>20</td>
<td>30%</td>
<td>6</td>
<td>85%</td>
<td>17</td>
</tr>
</tbody>
</table>
Configure Proxy Server Settings on the CAS

By default, the Clean Access Server redirects client traffic on ports 80 and 443 to the login page. If users on your untrusted network are required to use a proxy server and/or different ports, you can configure the CAS with corresponding proxy server information in order to appropriately redirect HTTP/HTTPS traffic client traffic to the login page (for unauthenticated users) or HTTP/HTTPS/FTP traffic to allowed hosts (for quarantine or Temporary role users). You can specify:

- Proxy server ports only (for example, 8080, 8000)—This is useful in environments where users may go through a proxy server but not know its IP address (e.g. university).
- Proxy server IP address and port pair (for example, 10.10.10.2:80)—This is useful in environments where the IP and port of the proxy server to be used are known (e.g. corporate/enterprise).
- The URL for a preconfigured Proxy PAC file—This is a file the CAS should use to redirect the user session. The URL you specify must have the same IP address and port as the Proxy server to successfully enable session redirection. If the URL has a different IP address or port from the Proxy settings, you must configure an IP or host policy for the user session, instead.

To Specify Proxy Server Settings on the CAS:

**Step 1**

Go to **Device Management > Clean Access Servers > Manage [CAS_IP] > Advanced > Proxy.**

**Figure 4-26 Proxy Settings for Client Traffic**

**Step 2**

Specify the proxy source:

- Enter the Proxy IP address in the **Proxy Server (IP:)Port**. Type the port number or IP:port of the proxy server. Separate multiple entries with commas. For example:

  3128,8080,8000,10.10.10.2:6588,10.10.10.2:3382

  **Note**  
  For better security, it is strongly recommended to specify both IP and port for the proxy server. This causes the CAS to intercept only those requests from the IP address specified. Either port or IP:port must be specified for the proxy server; you cannot specify an IP address alone.

- Enter the URL for a preconfigured Proxy PAC file the CAS should use to redirect the user session.
Configure Proxy Server Settings on the CAS

Note

The URL you specify must have the same IP address and port as the Proxy server to successfully enable session redirection. If the URL has a different IP address or port from the Proxy settings, you must configure an IP or host policy for the user session, instead.

Step 3

Click Update to save settings.
Configuring DHCP

In the majority of deployments, a DHCP server already exists on the network, and the Clean Access Server needs to be configured in either DHCP Relay or DHCP Passthrough mode. DHCP Relay mode can be used when a CAS is a Real-IP Gateway, and DHCP Passthrough is used exclusively for a CAS in Virtual Gateway mode. For a lab/test environment, or if a DHCP server is not already set up, you can configure a Real-IP Gateway CAS to be the DHCP Server for your network. This chapter describes how to configure each of the DHCP modes of the Clean Access Server. Topics include:

- Overview, page 5-1
- Enable the DHCP Module, page 5-2
- Configuring IP Ranges (IP Address Pools), page 5-5
- Reserving IP Addresses, page 5-22
- User-Specified DHCP Options, page 5-23
- Global Action, page 5-30

Overview

DHCP (Dynamic Host Configuration Protocol) is a broadcast protocol for dynamically allocating IP addresses to computers on a network. When a client computer attempts to join a DHCP-enabled network, the client broadcasts an address request message. A DHCP server on the network responds to the request, and through the course of several exchanges, an IP address is negotiated for and delivered to the client.

In a DHCP-enabled network, the Clean Access Server can operate in one of several modes:

- **DHCP Passthrough**—This is the only mode that can be used when the CAS is configured as a Virtual Gateway. In DHCP Passthrough mode, a Virtual Gateway CAS propagates the DHCP broadcast messages across its interfaces without modification.
- **DHCP Relay**—In this mode, a Real-IP Gateway CAS forwards messages from clients to another DHCP server.
- **DHCP Server**—In this mode, a Real-IP Gateway CAS acts as the DHCP server and allocates client IP addresses for the managed (untrusted) network.

When a Real-IP Gateway CAS is enabled as a **DHCP Server**, it provides the services of a full-featured DHCP server. It can allocate addresses from a single IP pool or from multiple pools across many subnets. It can assign static IP addresses to particular client devices.

The **DHCP Server** configuration interface includes tools for auto-generating IP pools, making it easier to create many pools at once, and provides checking mechanisms to help detect configuration errors.
Auto-generating IP pools as a response to heightened virus activity can help to protect your network. By segmenting your network into many small subnets (such as /30 subnets), you can isolate clients from one another. Since clients cannot communicate directly across subnets, all traffic between them is routed through the Clean Access Server, limiting the ability of worms to propagate over peer-to-peer connections.

When you generate subnetted IP address pools, the Clean Access Server is automatically configured as the router for the subnet. An ARP entry for the subnet is automatically generated as well.

For static addresses, you can reserve a particular IP address for a particular device by MAC address.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>DHCP IP lease recommended limit of pool size</td>
<td>5000</td>
</tr>
<tr>
<td>Default/Min-Max lease time</td>
<td>0-2147483647 seconds</td>
</tr>
<tr>
<td>Recommended lease time</td>
<td>1800-7200 seconds</td>
</tr>
</tbody>
</table>

**Note** In case of pool size, a warning message is displayed if the limit exceeds.

**Enable the DHCP Module**

You can enable DHCP Relay or DHCP Server mode on a Clean Access Server that is in Real-IP Gateway mode. When a CAS is a Virtual Gateway, it is always in DHCP Passthrough mode (see Figure 5-4).

**Configure DHCP Relay or DHCP Server Mode**

1. From Device Management > CCA Servers > List of Servers, click the Manage button next to the Clean Access Server.
2. Click the DHCP link to open the DHCP form in the Network tab (Figure 5-1).

**Figure 5-1 Select DHCP Type (CAS in Real-IP Gateway Mode)**

3. From the DHCP Type dropdown menu, select one of the following options and click the Select DHCP Type button (note that this button label toggles to Select DHCP Type and Reboot Clean Access Server when in DHCP Server mode.) Options are as follows:
a. None—This is the default mode of the CAS, in which the CAS propagates DHCP broadcast messages across its interfaces without change. Leave the CAS in this default mode if a DHCP server already exists on the trusted network.

b. DHCP Relay—In this mode, the CAS forwards DHCP messages between clients and a specific external DHCP server. For DHCP Relay, you need to configure the DHCP server in the environment so that it hands out the Clean Access Server’s untrusted (eth1) address as the gateway IP address to managed clients. Selecting DHCP Relay mode displays an additional DHCP Relay configuration form (Figure 5-2). Type the IP address of the external DHCP server in the Relay to DHCP server field, and click the Update button.

![Figure 5-2 Configuring DHCP Relay](image)

Figure 5-2 Configuring DHCP Relay

Relay to DHCP Server

null

(separate multiple addresses with a comma)

Update

DHCP Relay

Select DHCP Type

c. DHCP Server—This sets the CAS to perform DHCP services for managed clients. Once the CAS is enabled as a DHCP Server, the DHCP Status, Subnet List, Reserved IPs, Auto-Generate, and Global Options subtabs are displayed (Figure 5-3). From there, you can add IP pools manually, auto-generate pools and subnets, or specify reserved IPs, as described in Configuring IP Ranges (IP Address Pools), page 5-5.
Enable the DHCP Module

Figure 5-3  DHCP Server Mode

![DHCP Server Mode Diagram]

**Note**

Once **DHCP Server** is selected, to switch to a different DHCP Type for the Clean Access Server, you must reboot the CAS. To change the type, select None or DHCP Relay from the dropdown menu and click the button **Select DHCP Type and Reboot Clean Access Server**.

**DHCP Status Options**

When the CAS is enabled as a DHCP server, the **DHCP Status** tab includes the enable buttons shown in Figure 5-3.

Cisco NAC Appliance offers two DHCP enable/disable functions to ensure client IP addresses are renewed properly when the CAS is configured as the DHCP server for your network. These are User Logout on DHCP Lease Expiration and DHCP FORCERENEW, as described below.
Enable/Disable Logout on DHCP Lease Expiration
This toggle button is disabled by default. Clicking the Enable button causes the user to be logged out (either Agent or Web session logout) from the Cisco NAC Appliance when the client's DHCP lease expires.

Enable/Disable DHCP FORCERENEW
This toggle button is disabled by default. Clicking the Enable button instructs the DHCP server to execute a DHCP NAK command, which releases IP addresses assigned to a client by other DHCP servers. Following the NAK command, the DHCP client will be assigned a valid IP address as configured on the CAS.

Show/Hide DHCP Server Startup Message
When this button is clicked, the last DHCP server startup message is displayed. If the server does not start, an error message is shown here.

Show/Hide DHCP Configuration File
When this button is clicked, the DHCP configuration file is displayed. In some cases, the startup message displays an error for a particular line of the configuration. Clicking this button allows you to view the configuration file line-by-line.

For further information on the DHCP Status tab see Working with Subnets, page 5-15.
For additional information on DHCP configuration, see User-Specified DHCP Options, page 5-23.

Note
A Virtual Gateway CAS is always in DHCP Passthrough mode (Figure 5-4).

**Figure 5-4 CAS VGW DHCP Type**

---

Configuring IP Ranges (IP Address Pools)

To set up the Clean Access Server to provide DHCP services, you first configure the range of IP addresses to be allocated to clients (the IP address pool). In addition, you can specify network information to be handed to clients with the address, such as DNS addresses.

The CAS can allocate addresses from multiple pools and subnets. However, allocated addresses must fall within the ranges specified to be managed by the CAS. This can be either:

- The address space of its untrusted interface managed network (set in the Network> IP page)
- A managed subnet specified in the Managed Subnet form of the Advanced tab
If you try to create an address pool from a subnet that is not managed, an error message notifying you of the condition appears in the admin console and the pool is not created.

**Auto-Generated versus Manually Created Subnets**

You can automatically generate subnets in order to create many IP address pools at a time. Creating a large number of IP pools of relatively small size (from which only a few addresses can be assigned) can help protect your network. By isolating clients into small subnets, you limit the ability of peers to communicate directly with one another, and thereby prevent events such as worms from proliferating across peer connections.

Alternatively, you can manually create subnets if only a few IP address pools are required for your network.

**Subnetting Rules**

Whether creating IP pools automatically or manually in the admin console, the subnets you create must follow standard subnetting design rules. Only properly aligned, power-of-two subnet addresses are supported. For example, you cannot start a subnet range at address 10.1.1.57 with a subnet mask of 255.255.255.192, because the final octet of the netmask, 192, corresponds to a “size 64” subnet. There can only be four size-64 subnets, with subnet start address boundaries of .0, .64, .128, and .192. Since .57 is not a power-of-two, it cannot be used as the starting address for a subnet.

You must specify the starting address of the range for either manually-created or automatically-generated subnets. To manually create a pool you specify the end of the range, and to auto-generate a pool you specify the number of subnets to generate.

Addresses in the IP range are assigned as follows:

1. Network address—The first valid number entered for the range is used as the network address for the subnet (or the first subnet, if generating more than one subnet).
2. Router address—The second number is used as the router address (that is, the virtual gateway interface address for the subnet).
3. Host IP address—The third number is the first address that is leasable to clients.
4. Broadcast address—The final address in the range is the broadcast address.

By specifying an IP range of only four addresses, you can create a subnet for a single host.

**Table 5-2** shows the number of leasable addresses for each subnet size and number of subnets possible per CIDR (Classless InterDomain Routing) prefix. Each CIDR prefix corresponds to a specific subnet mask. CIDR notation identifies the number of bits masked for the network portion of a 32-bit IP address in order to produce a specific number of host addresses. For example, a CIDR address of 10.5.50.6 /30 indicates that the first 30 bits of the address are used for the network portion, leaving the remaining 2 bits to be used for the host portion. Two bits of address yield four host addresses: three addresses are automatically allocated for the required network, gateway, and broadcast addresses for the subnet, and the remaining address can be leased. Therefore, a /30 network creates a subnet of one host.
Table 5-2  Addresses per Subnet Size

<table>
<thead>
<tr>
<th>CIDR Prefix</th>
<th>No. of possible subnets (Class C)</th>
<th>Total number of addresses</th>
<th>No. of leasable host addresses</th>
<th>Example valid start-of-range addresses</th>
</tr>
</thead>
<tbody>
<tr>
<td>/30</td>
<td>64</td>
<td>4</td>
<td>1</td>
<td>10.1.65.0 10.1.65.4 10.1.65.8 ...</td>
</tr>
<tr>
<td>/29</td>
<td>32</td>
<td>8</td>
<td>5</td>
<td>10.1.65.0 10.1.65.8 10.1.65.16 ...</td>
</tr>
<tr>
<td>/28</td>
<td>16</td>
<td>16</td>
<td>13</td>
<td>10.1.65.0 10.1.65.16 10.1.65.32 ...</td>
</tr>
<tr>
<td>/27</td>
<td>8</td>
<td>32</td>
<td>29</td>
<td>10.1.65.0 10.1.65.32 10.1.65.64 ...</td>
</tr>
<tr>
<td>/26</td>
<td>4</td>
<td>64</td>
<td>61</td>
<td>10.1.65.0 10.1.65.64 10.1.65.128 10.1.65.192</td>
</tr>
<tr>
<td>/25</td>
<td>2</td>
<td>128</td>
<td>125</td>
<td>10.1.65.0 10.1.65.128</td>
</tr>
<tr>
<td>/24</td>
<td>1</td>
<td>256</td>
<td>253</td>
<td>10.1.65.0</td>
</tr>
</tbody>
</table>

Table 5-3 shows the addressing for an automatically-generated IP range of four /30 subnets starting at address 10.1.100.12.

Table 5-3  Auto-Generated Subnets

<table>
<thead>
<tr>
<th>IP Range Entries</th>
<th>1st Subnet</th>
<th>2nd Subnet</th>
<th>3rd Subnet</th>
<th>4th Subnet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network address</td>
<td>10.1.100.12</td>
<td>10.1.100.16</td>
<td>10.1.100.20</td>
<td>10.1.100.24</td>
</tr>
<tr>
<td>Router address</td>
<td>10.1.100.13</td>
<td>10.1.100.17</td>
<td>10.1.100.21</td>
<td>10.1.100.25</td>
</tr>
<tr>
<td>Client address range</td>
<td>10.1.100.14 - 10.1.100.14</td>
<td>10.1.100.18 - 10.1.100.18</td>
<td>10.1.100.22 - 10.1.100.22</td>
<td>10.1.100.26 - 10.1.100.26</td>
</tr>
<tr>
<td>Broadcast address</td>
<td>10.1.100.15</td>
<td>10.1.100.19</td>
<td>10.1.100.23</td>
<td>10.1.100.27</td>
</tr>
</tbody>
</table>
In general, the admin console enforces rules for properly configured subnets. If you attempt to use an invalid network address for the netmask, the message appears: “Subnet/Netmask pair do not match”. In this case, choose a new value for the address.

Create IP Pools Manually

To create an IP pool manually, you also need to define the subnet in which the pool resides. There are three ways to arrive at the subnet address and netmask values for a manually generated pool:

- Enter the subnet address directly, as an IP address and netmask.
- Have the admin console generate the smallest possible subnet based on the IP range you enter.
- Have the admin console calculate the values from the list of subnets currently managed by the Clean Access Server.

To create an IP pool range:
1. In the DHCP form, click the Subnet List tab, then the New link.

2. The new IP pool form appears.

Figure 5-5 New Subnet List Subtab Link
3. Enter values for these fields:

- **IP Range** – The IP address pool to be assigned to clients. Provide a range of addresses not currently assigned in your environment.

- **Default Gateway** – The IP address of the default gateway passed to clients. This should be the untrusted interface address of the Clean Access Server.

- **Default/Max Lease Time (seconds)** – The amount of time the IP address is assigned to the client, if the client does not request a particular lease time, as well as the maximum amount of time for which a lease can be granted. If the client requests a lease for a time that is greater, the maximum lease time is used.

- **DNS Suffix** – The DNS suffix information to be passed to clients along with the address.

- **DNS Servers** – The address of one or more DNS servers in the client’s environment. Multiple addresses should be separated by commas.

- **WIN Servers** – The address of one or more WIN servers in the client’s environment. Multiple addresses should be separated by commas.

- **Restrict range to [VLAN ID | RELAY IP]**

  If choosing **VLAN ID**, type the VLAN ID in the text field. Clients not associated with the specified VLAN cannot receive addresses from this IP pool. A VLAN ID can be any number between 0 and 4095.
For IPs with VLAN restrictions, all IPs must be in a managed subnet, and you must create a managed subnet first before creating an IP range (DHCP pool). See Configuring Managed Subnets or Static Routes, page 4-25 for details.

If choosing RELAY IP, type the Relay IP in the text field. Clients not associated with the specified Relay IP cannot receive addresses from this IP pool.

For IPs with relay restrictions, all IPs should typically be in static routes, but can be in managed subnets if integrating the CAS with Aironet devices or other non-RFC 2131/2132 compliant devices. Note that these IP address pools must be in either a static route or a managed subnet, and IPs with relay restrictions should only be put in a managed subnet for these non-compliant devices. See Configuring Managed Subnets or Static Routes, page 4-25 for details.

4. From the Subnet/Netmask list, choose how you want the subnet address to be specified, from the following choices:

- Calculate from existing managed subnets – The admin console determines what to use for the subnet and netmask values based on the configuration in the Managed Subnet form (in the Advanced tab). It calculates the network address by applying the netmask to the gateway address for each managed subnet.

- Calculate smallest subnet for IP range entered – The admin console determines the subnet and netmask values based on the IP address range you entered.

- Manually enter subnet and netmask – To specify the desired network address and netmask manually. If selected, the Subnet and NetMask fields appear at the bottom of the form.

- Inherit Scoped Global Options – This field is only visible if DHCP options are enabled, and will be checked by default. If this field is disabled (unchecked), the scoped global options configured in the Global Options tab are not inherited. See User-Specified DHCP Options, page 5-23 for details.

5. Click Update when finished. If there are errors in the configuration, warning messages appear. Follow the instructions to correct the settings.

Auto-Generating IP Pools and Subnets

By automatically generating subnets, you can quickly divide your network into small segments. Segmenting your network into small subnets can be an effective security measure in response to a worm attack, since a network comprised of many small subnets (with one host per subnet possible) limits the ability of clients to engage in peer-to-peer interaction.

Caution

The recommended maximum number of subnets per Clean Access Server is 1000. If the CAS machine has sufficient memory (>1G), up to 2500 subnets can be configured. Do not exceed the recommended limit if this will place an excessive burden on system resources, particularly server memory.
Add Managed Subnet

1. First, make sure that the IP pools you want to add are in the range of a managed subnet. If needed, add the managed subnet under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Managed Subnet (for details, see Configure Managed Subnets for L2 Deployments, page 4-27).

**Note** When adding a managed subnet, the IP Address field you configure should be the gateway address for the subnet—that is the address used by the CAS to route the subnet. The IP Address of the managed subnet should not be the network address (which the Clean Access Manager will calculate by applying the Subnet Mask to the gateway address).

Create Auto-Generated Subnet

1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Network > DHCP > Auto-Generate. The Auto-Generate pane appears as follows:
2. In the **Start Generating at IP** field, type the first IP address of the range to be generated:

```
Start Generating at IP: 192.168.2.0
Number of Subnets to Generate: 20
```

The first available valid address for the managed subnet range is used as the network address for the first subnet, the next number is used as the router address, and the next number after that becomes the first address that is leasable to clients.

3. In the **Number of Subnets to Generate** field, type the number of subnets to generate. As mentioned, the maximum recommended size is 1000. Exceeding this number can impose a burden on the server's system resources.
4. From the **Generate Subnets of Size** dropdown list, select the size of each subnet. Subnet sizes are presented in CIDR format (such as /30). The dropdown menu also lists the corresponding number of available host addresses per subnet for each CIDR prefix. For each range, three addresses are automatically reserved and cannot be allocated to clients:
   - The network address of the subnet
   - The router address (for the Clean Access Server)
   - The broadcast address

Therefore, a /30 size subnet has four addresses, but only one IP available for hosts.

5. Provide values for the remaining fields:
   - **Default Lease Time (seconds)** – The amount of time the IP address is assigned to the client, if the client does not request a particular lease time.
   - **Max Lease Time (seconds)** – The maximum amount of time a lease can be reserved. If the client requests a lease for a time that is greater, this max lease time is used.
   - **DNS Suffix** – The DNS suffix information to be passed to clients along with the address lease.
   - **DNS Server(s)** – The address of one or more DNS servers in the client’s environment. Multiple addresses should be separated by commas.
   - **WIN Server(s)** – The address of one or more WIN servers in the client’s environment. Multiple addresses should be separated by commas.
   - **Restrict this Subnet to a specific VLAN ID** – Clients not associated with the specified VLAN cannot receive addresses from this IP pool. A VLAN ID can be any number between 0 and 4095.
   - **Inherit Scoped Global Options** – This field is only visible if DHCP options are enabled and is turned on by default. If this field is disabled, the scoped global options configured in the **Global Options** tab are not inherited. See **User-Specified DHCP Options**, page 5-23 for details.

6. When finished, generate a preliminary list of subnets by clicking **Generate Subnet List**. If there are errors in the values provided, error messages appear at this time. If the subnet based on your address is not properly aligned, the interface suggests the closest legal starting IP address for your range.

If successful, a preliminary list of IP ranges appears, allowing you to review the results.

7. Click **Commit Subnet List** to save the IP ranges.

8. The auto-generated subnets appear as a single subnet range under **Subnet List > List**. The “# of Subnets” and “# of IPs” columns allow you to view how large the auto-generated range is in terms how many subnets have been created as well as the number of IP addresses for the range.
9. The newly-generated list also appears in summary form under **DHCP Status** tab (listing VLAN ID and number of dynamic, available, and static IP addresses).

**Figure 5-12 ARP Entries Generated for DHCP**

ARP entries are automatically created in the Clean Access Server configuration for the generated subnets (under **Device Management > CCA Servers > Manage [CAS_IP] > Advanced > ARP**), as shown in **Figure 5-12**. Deleting generated subnets also removes the corresponding ARP entries.
Working with Subnets

View Users by MAC Address/VLAN

1. After committing an auto-generated list, the Network > DHCP > DHCP Status page appears and lists the newly-generated subnet. If the auto-generated subnet is restricted to a VLAN ID, the subnet is listed by that VLAN ID; otherwise, the VLAN column is blank if no VLAN is specified.

2. By clicking the View MACs icon for the VLAN, you can see the MAC address, IP and type of client, as shown in Figure 5-14.

View or Delete Subnets from the Subnet List

1. You can view the list of subnets created or modify individual subnets from Device Management > CCA Servers > Manage [CAS_IP] > Network > DHCP > Subnet List > List.
2. To view the subnets for a particular VLAN only, select the VLAN from the scroll menu next to the View button and click View.

3. To remove an individual subnet, click the Delete icon next to it.

4. To remove all auto-generated subnets, click the Delete all Generated Subnets button. This action deletes only auto-generated subnets; all manually entered subnets are retained.

**Edit a Subnet**

1. To edit a subnet, click the Edit button next to it in the Subnet List to bring up the Edit Subnet List form. Figure 5-16 shows the Edit form for an auto-generated subnet. (The Edit form for a manually-generated subnet is similar to Figure 5-6 on page 5-9.)
2. You can modify the lease time, DNS/WIN server information and VLAN ID restriction. Click Update to save the changes. To change the IP range, default gateway or subnet mask, the subnet must be deleted from Subnet List > List form and re-added with the modified parameters.

3. For auto-generated subnets, you can disable a particular subnet by clicking the Disabled checkbox next to it. This allows you to disable the IPs associated with a particular generated subnet so that the IPs are not leased out. This can be particularly useful if you have one or two servers in the middle of a subnet range.
Configuring a Real-IP CAS as DHCP Server for L3 Clients

Typically, when a Clean Access Server is configured as a DHCP server it is in Layer 2 mode. The CAS acts as a DHCP server for the Layer 2 VLANs which are trunked to it. In Layer 2 mode, you configure a DHCP scope for that VLAN on the CAS and then configure a managed subnet for that VLAN so that the CAS can communicate to clients in that VLAN.

However, Layer 3 clients are one or multiple hops away from the CAS and therefore work differently. L3 clients are not adjacent to the CAS and DHCP discover broadcast from these clients will never reach the CAS (DHCP server). Therefore, a DHCP scope for these clients cannot be created based on VLAN. Figure 5-17 illustrates an example scenario.

![Figure 5-17 Example L3 Scenario](image)

In this example:
- CAM is on VLAN 900
- CAS trusted interface is on VLAN 10 and untrusted interface is on VLAN 100.
- Client machines in VLAN 700 are multiple hops away from the CAS
- CAS is required to act as a DHCP server for these clients

As previously mentioned, DHCP discover broadcast from these L3 clients are not able to cross the VLAN 700 boundary. Therefore, an “IP helper address” needs to be configured under the router interface acting as the gateway for VLAN 700, for example:

```
Interface vlan 700
ip address 10.60.60.1 255.255.255.0
ip helper-address x.x.x.x
```

Where x.x.x.x is the untrusted side (eth1) IP address of the CAS (e.g. 10.20.20.1).

On the CAS, the following needs to be configured:
- A DHCP scope for clients in VLAN 700 with an “IP RELAY” of 10.60.60.1
- A route for 10.60.60.0/24 (VLAN 700) pointing towards the untrusted side
Figure 5-18 shows the IP information of the CAS configured as a Real-IP Gateway:

- Trusted (eth0) interface IP address is 10.2.2.1
- Trusted Default Gateway is 10.2.2.2
- Untrusted (eth1) interface IP address is 10.20.20.1
- Untrusted Default Gateway is 10.20.20.3

The CAS has already been enabled as a DHCP Server (as described in Enable the DHCP Module, page 5-2). Figure 5-19 shows the New Subnet list form configured under Device Management > CCA Servers > Manage [CAS_IP] > Network > DHCP > Subnet List > New with:

- A client IP range of 10.60.60.100-10.60.60.200
- Default gateway of 10.60.60.1
- Restricted range to RELAY IP is chosen with 10.60.60.1 entered as the IP relay.
- Subnet of 10.60.60.0 and subnet mask of 255.255.255.0 manually entered
- Click Update to create the new DHCP scope.
Figure 5-19  **Restrict Subnet List to Relay IP**

![Figure 5-19](image)

Figure 5-19 shows the Static Routes form configured under Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Static Routes with:

- Destination Subnet Address of **10.60.60.0** and Subnet Mask of **255.255.255.0** (the subnet/netmask configured in Figure 5-19).
- **Untrusted[eth1]** chosen as the Link.
- Gateway of **10.20.20.3**, which is the CAS eth1 default gateway shown in Figure 5-18.
- Click **Add Route** to add this static route to the CAS.
## Configuring IP Ranges (IP Address Pools)

### Create Static Route

<table>
<thead>
<tr>
<th>Status</th>
<th>Network</th>
<th>Filter</th>
<th>Advanced</th>
<th>Authentication</th>
<th>Misc</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed Subnet</td>
<td>VLAN Mapping</td>
<td>NAT</td>
<td>1:1 NAT</td>
<td>Static Routes</td>
<td>ARP</td>
</tr>
</tbody>
</table>

**Dest. Subnet Address/Mask**: 10.99.99.0 / 255.255.255.0

**Gateway (optional)**: 10.99.99.3

*(Gateway should be the address of an external gateway for the destination subnet that is not the Clean Access Server)*

**Link**: Untrusted [untrusted]

**Description**: 

<table>
<thead>
<tr>
<th>Subnet</th>
<th>Gateway</th>
<th>Link</th>
<th>Description</th>
<th>Delete</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.99.99.0 / 255.255.255.0</td>
<td>10.99.99.3</td>
<td>Untrusted</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Reserving IP Addresses

By reserving an IP address, you can keep a permanent association between a particular IP address and device. A reserved device is identified by MAC address. Therefore, before starting, you need to know the MAC address of the device for which you want to reserve an IP address. The configuration for a reserved IP does not include a maximum or default lease time. The address is always available for the device and in effect has an unlimited lease time. Table 5-4 lists several rules that apply to reserved IP addresses.

Table 5-4  Reserved IP Address Rules

<table>
<thead>
<tr>
<th>A reserved address cannot be...</th>
<th>A reserved address must be...</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Within the address range of an IP pool.</td>
<td>• Within the address range of the Clean Access Server’s managed network (as configured in Device Management &gt; CCA Servers &gt; Manage [CAS_IP] &gt; Network &gt; IP), or</td>
</tr>
<tr>
<td>• A network or broadcast address.</td>
<td>• Within the address range of the CAS’s managed subnets (as configured in Device Management &gt; CCA Servers &gt; Manage [CAS_IP] &gt; Advanced &gt; Managed Subnet).</td>
</tr>
<tr>
<td>• Currently set as a default gateway for an existing IP address range.</td>
<td></td>
</tr>
</tbody>
</table>

Add a Reserved IP Address


Figure 5-21  Reserved IPs—New
2. In the **MAC Address** field, type the MAC address for the device for which you want to reserve an IP address, in hexadecimal MAC address format (e.g., 00:16:21:11:4D:67).

3. In the **IP Address to allocate** field, type the IP address that you want to reserve.

4. Enter an optional **Description**.

5. Provide values for the remaining fields:
   - **DNS Suffix** – The DNS suffix information to be passed to clients along with the address lease.
   - **DNS Servers** – The address of one or more DNS servers in the client’s network. Multiple addresses should be separated by commas.
   - **WIN Servers** – The address of one or more WIN servers in the client’s network. Multiple addresses should be separated by commas.
   - **Restrict this IP to VLAN ID** – If the client is associated with a particular VLAN, click this checkbox to specify the VLAN identifier in the **VLAN ID** field.

6. When finished, click **Update**.

   The reserved IP now appears in under **Subnet List > List**. From there, it can be modified by clicking the **Edit** button or removed by clicking **Delete**.

### User-Specified DHCP Options

The Global Options tab (Figure 5-22) allows advanced users to modify the DHCP configuration directly. DHCP options can be specified as follows:

- Root global options appear at the root level or top of the DHCP configuration file and apply to all DHCP subnet declarations. Root global options are inherited by everything in the file.

- Scoped global options are added to each subnet definition, but you can enable whether or not a subnet inherits the option. When DHCP options are enabled, an “Inherit Scoped Global Option” enable appears on the forms used to add or edit manually-created or automatically-generated subnets. Note that the “Inherit Scoped Global Option” checkbox appears only while customized DHCP options are enabled and only for subnets created after the options are enabled.

- Local options apply only to the subnet for which they are entered. Local DHCP options can be added to an individual subnet using the **Subnet List > Edit** form described in Add Local Scoped DHCP Option, page 5-28.

You can create DHCP option rules based on class restrictions to restrict access to DHCP subnets. You can create rules for:

- All clients on a specific VLAN
- Clients coming from a specific relay IP

You can create new options by selecting the options type or by creating a custom option to create an option that is not on the list, or of a different type.

---

**Caution**

The DHCP configuration file should not be modified under most circumstances.

A server directive instructs the DHCP server to behave differently, while a DHCP option refers to a specific piece of data to be returned by the DHCP server. For example, the “allow-bootp” server directive (disabled by default) instructs the DHCP server to allow older BOOTP clients to connect. See Table 5-5 “DHCP Server Directives” for additional details.
Most server directives can only be added as root global options. This is because their actions direct the behavior of the entire server and cannot be limited in scope or effect on a per-subnet basis.

Enable User-Specified DHCP Options

1. Go to the Network > DHCP > Global Options tab and click the Enable button (Figure 5-22).

2. With Global Options enabled on the CAS (Figure 5-23), choose one of the following option types to configure:
   - Root Global Option
   - Scoped Global Option
   - Class Option

   Once an option is added, it is displayed on this main page under the corresponding list name.
When specifying DHCP Global Options (Root, Scoped or Class), you may select a particular DHCP option by entering its number in the **Option #** input box on the New/Edit form.

If the desired option number is not known, or if specifying a server directive which changes server behavior but has no corresponding DHCP option number, then select the name of the option or directive from the dropdown menu next to the **Set Option Type** button. In either case, click the **Set Option Type** button after the desired DHCP option type has been selected.

DHCP option numbers are specified in RFC 2132.

### Add Root Global DHCP Option

3. Click the **New Option** link at the top right-hand corner of the **Root Global Option List** to open the Root Global DHCP Options form (**Figure 5-24**). This form allows you to enter text directly into the DHCP configuration file at the root level.

### Figure 5-24  **DHCP Global Options - New Root Global (Custom Option)**

4. Either type the **Option #**, or choose the option type from the dropdown list (providing an alphabetized list of commonly-used options), and click **Set Option Type**.

5. If instead configuring a **Custom Option**, type the option number in the **ID** field, choose a data **Type** from the dropdown menu, and click **Create Custom Option**.

### Add Scoped Global DHCP Option

6. From the **Global Options** main page (**Figure 5-23**), click the **New Option** link at the top right-hand corner of the **Scoped Global Option List** to open the Scoped Global DHCP Options form (**Figure 5-24**). This form allows you to enter text directly into the DHCP configuration file at the subnet scope level.
7. Either type the **Option #**, or choose the option type from the dropdown list (providing an alphabetized list of commonly-used options), and click **Set Option Type**.

8. If configuring a **Custom Option**, type the **ID** of the option, choose a data **Type** from the dropdown menu, and click **Create Custom Option**.

**Add New Class Option**

9. From the **Global Options** main page (**Figure 5-23**), choose one of the following **Class Types** from the dropdown menu to the right of the **Class Options** list:

   - **All VLAN-Restricted Subnets**—To apply the option to all subnets in the **Subnet List** (autogenerated or manually-created) that are restricted to a VLAN ID.
   
   - **All Relay IP-Restricted Subnets**—To apply the option to all subnets in the **Subnet List** (manually-created) that are restricted to a Relay IP.
   
   - **No VLAN tagged**—To apply the option to all subnets in the **Subnet List** that have no VLAN specified.
   
   - **VLAN ID <n>**—To apply the option to a specific subnet for VLAN ID (<n>) in the **Subnet List**.

10. Click the **New Class Option** button at the top right-hand corner of the **Class Options List** to open the **New Class Option** form (**Figure 5-25**).
11. Either type the **Option #**, or choose the option type from the dropdown list (providing an alphabetized list of commonly-used options), and click **Set Option Type**.

12. If configuring a Custom Option, type the **ID** of the option, choose a **Type** from the dropdown menu, and click **Create Custom Option**.

**Restore Options to Default**

13. To restore factory defaults, click the **Restore Options To Default** button at the top-right side of the **Global Options > List** page (Figure 5-27).

**Disable DHPC Options**

To disable admin-specified DHCP options, click the Disable button at the top-left side of the **Global Options > List** page (Figure 5-23 on page 5-24).
Add Local Scoped DHCP Option

1. Make sure DHCP options are enabled as described in Enable User-Specified DHCP Options, page 5-24.

2. Go to Network > Subnet List > List and click the Edit button next to the subnet for which you want to add an option.

3. The Edit form appears.

Figure 5-28 Edit Subnet List Form (Local Scoped DHCP Option)

4. Click the Add New Option Link at the bottom of the form. The New Local Option form appears:
5. Either type the **Option #**, or choose the option type from the dropdown list (providing an alphabetized list of commonly-used options), and click **Set Option Type**.

6. If configuring a Custom Option, type the option number in the **ID** field, choose a data **Type** from the dropdown menu, and click **Create Custom Option**.

---

**Table 5-5 DHCP Server Directives**

<table>
<thead>
<tr>
<th>Server Directive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>allow bootp</td>
<td>Allows booting by BOOTP devices. Disabled by default. Some older printers still in use require BOOTP. The BOOTP protocol does not specify a time limit for the lease assignment, although other server directives can invalidate BOOTP leases.</td>
</tr>
<tr>
<td>always-broadcast</td>
<td>Normal DHCP operation calls for the DHCP DISCOVER and OFFER packets to be broadcast if the DHCP client is unsure of where the DHCP server is located. In typical operation, the DHCP REQUEST and ACK, and all subsequent REQUESTS and ACKs between a known client and a known DHCP server are unicast. The “always-broadcast” server directive instructs the DHCP server to always respond to all DHCP packets with a broadcast packet.</td>
</tr>
<tr>
<td>always-reply-rfc1048</td>
<td>Some DHCP clients violate RFC 1048 when sending DHCP packets. The DHCP server responds by default to these clients with packets that also violate RFC 1048. A very small set of clients send a DHCP packet which violates RFC 1048, but do not accept as valid a return packet which violates RFC 1048. This server directive instructs the server to always respond with RFC-1048 compliant packets no matter what is received.</td>
</tr>
<tr>
<td>deny bootp</td>
<td>This is the default behavior of the server. This server directive instructs the server to reject BOOTP requests.</td>
</tr>
<tr>
<td>dynamic-bootp-lease-length</td>
<td>Instructs the server to invalidate and make available for re-assignment IP leases assigned to BOOTP clients. Note that this does not guarantee that the BOOTP client will stop using the IP address. This server directive can be specified as a scoped global or local option.</td>
</tr>
</tbody>
</table>
Global Action

The **Global Action** tab allows you to change fields on all DHCP elements of a particular CAS. For example, if you have 300 managed subnets and IP pools and you need to change the DNS server in all of them, you can achieve this using the **Global Action** form.

1. Go to the **Network > DHCP > Global Action** (Figure 5-30).

### Table 5-5 DHCP Server Directives (continued)

<table>
<thead>
<tr>
<th>Server Directive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>filename</td>
<td>Instructs the DHCP server to fill out the filename portion of the DHCP packet. This is not an option, as it does not appear in the DHCP options list. This server directive can be specified as a scoped global or local option.</td>
</tr>
<tr>
<td>get-lease-hostname</td>
<td>Instructs the server to look up the domain name corresponding to the IP address of each address in the lease pool and use that address for the DHCP hostname.</td>
</tr>
<tr>
<td>next-server</td>
<td>Instructs the server to fill out the next-server field in all DHCP responses. This is typically used by devices which need additional configuration information, such as IP phones. This server directive can be specified as a scoped global or local option.</td>
</tr>
<tr>
<td>one-lease-per-client</td>
<td>Instructs the server to invalidate the first lease assigned to a DHCP client that has requested more than one. By default this is disabled, as some network devices require two or three addresses.</td>
</tr>
<tr>
<td>ping-check</td>
<td>Instructs the server to ping an IP address prior to assigning it. This is disabled by default, and has a significant negative impact on DHCP server performance.</td>
</tr>
<tr>
<td>server-identifier</td>
<td>Instructs the server to change its identifier. By default, the IP address of the untrusted network interface is used.</td>
</tr>
<tr>
<td>server-name</td>
<td>Instructs the server to change its name. By default, the hostname of the CAS is used. This server directive can be specified as a scoped global or local option.</td>
</tr>
<tr>
<td>use-lease-addr-for-default-route</td>
<td>Instructs the server to send a default route (gateway) equal to the assigned IP for all responses.</td>
</tr>
</tbody>
</table>

**Global Action**

The **Global Action** tab allows you to change fields on all DHCP elements of a particular CAS. For example, if you have 300 managed subnets and IP pools and you need to change the DNS server in all of them, you can achieve this using the **Global Action** form.

1. Go to the **Network > DHCP > Global Action** (Figure 5-30).
2. In the **Action will target:** dropdown, choose one of the following options:
   - **Everything** (all of the options below combined)
   - All Manual Subnets
   - All IP Reservations
   - All Auto-Generated Subnets
   - All by VLAN ID

3. Click the checkbox for each applicable parameter, then type the value in the associated textbox.
   - **VLAN ID** (when All by VLAN ID is chosen)
   - Default Lease Time (seconds)
   - Maximum Lease Time (seconds)
   - DNS Suffix
   - DNS Servers (separate multiple addresses with a comma)
   - WINS Servers (separate multiple addresses with a comma)

4. Click **Update**.

5. Click **Perform Action** in the confirmation page that appears (Figure 5-31).
### Figure 5-31  Example Global Action

#### Device Management > Clean Access Servers > 10.201.5.120

<table>
<thead>
<tr>
<th>Status</th>
<th>Network</th>
<th>Filter</th>
<th>Advanced</th>
<th>Authentication</th>
<th>Misc</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP</td>
<td>DHCP</td>
<td>DNS</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### DHCP Status, Subnet List, Reserved IPs, Auto-Generate, Global Options, Global Action

**Change:**

Default Lease Time to 300 seconds

**Change applies to:**

#### Subnet List

<table>
<thead>
<tr>
<th>IP Range</th>
<th>Subnet Range</th>
<th>Domain</th>
<th>VLAN ID</th>
<th># Subnets</th>
<th># IPs</th>
</tr>
</thead>
<tbody>
<tr>
<td>192.168.241.100</td>
<td>192.168.241.0</td>
<td>N/A</td>
<td>1</td>
<td>21</td>
<td></td>
</tr>
<tr>
<td>192.168.241.120</td>
<td>192.168.241.255</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### IP Reservations

<table>
<thead>
<tr>
<th>Enabled</th>
<th>Description</th>
<th>MAC Address</th>
<th>Reserved IP Address</th>
<th>VLAN ID</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Diagram](image-url)
Integrating with Cisco VPN Concentrators

This chapter describes the configuration required to integrate the Clean Access Server with Cisco VPN Concentrators. Topics include:

- Overview, page 6-1
- Configure Cisco NAC Appliance for VPN Concentrator Integration, page 6-4
- Cisco NAC Appliance Agent with VPN Concentrator and SSO, page 6-18
- View Active VPN Clients, page 6-19

Overview

Cisco NAC Appliance enables administrators to deploy the Clean Access Server (CAS) in-band behind a VPN concentrator, or router, or multiple routers. Multi-hop Layer 3 in-band deployment is supported by allowing the Clean Access Manager (CAM) and CAS to track user sessions by unique IP address when users are separated from the CAS by one or more routers. Note that you can have a CAS supporting both L2 and L3 users. With layer 2-connected users, the CAM/CAS continue to manage these user sessions based on the user MAC addresses, as before.

For users that are one or more L3 hops away, note the following considerations:

- User sessions are based on unique IP address rather than MAC address.
- If the user’s IP address changes (for example, the user loses VPN connectivity), the client must go through the Nessus Scanning process again.
- In order for clients to discover the CAS when they are one or more L3 hops away, the Agent must be initially installed and downloaded via the CAS. This provides clients with the CAM information needed for subsequent logins when users are one or more L3 hops away from the CAS. Acquiring and installing the Agent by means other than direct download from the CAS will not provide the necessary CAM information to the Agent and will not allow those Agent installations to operate in a multi-hop Layer 3 deployment.
- The Certified List tracks both L2 and L3 VPN users by MAC address, and the Certified Devices Timer will apply to these users.
- All other user audit trails, such as network scanner and Agent logs, are maintained for multi-hop L3 users.
- The Session Timer will work the same way for multi-hop L3 In-Band deployments and L2 (In-Band or Out-of-Band) deployments.
Overview

Note that when the Single Sign-On (SSO) feature is configured for multi-hop L3 VPN concentrator integration, if the user’s session on the CAS times out but the user is still logged in on the VPN concentrator, the user session will be restored without providing a username/password.

The topology and configuration required is fairly straightforward. Figure 6-1 illustrates a Cisco NAC Appliance network integrated with a VPN concentrator. Figure 6-2 illustrates the VPN concentrator configuration “before” and Figure 6-3 illustrates the configuration “after” integration with Cisco NAC Appliance when multiple accounting servers are being used. The Clean Access Server needs to be configured as the sole RADIUS accounting server for the VPN concentrator. If the VPN concentrator is already configured for one or more RADIUS accounting server(s), the configuration for these needs to be transferred from the concentrator to the CAS.

Note

If using Split Tunneling on the VPN concentrator, make sure that the split tunnel allows access to the network being used for the Discovery Host. If the Discovery Host is the same as the CAM IP address, it should allow the CAM.

Single Sign-On (SSO)

In addition to being deployable with VPN concentrators, Cisco NAC Appliance provides the best user experience possible for Cisco VPN concentrator users through Single Sign-On (SSO). Users logging in through the VPN Client do not have to login again to Cisco NAC Appliance. Cisco NAC Appliance leverages the VPN login and any VPN user group/class attributes to map the user to a particular role.

This level of integration is achieved using RADIUS Accounting with the Clean Access Server acting as a RADIUS accounting proxy. Cisco NAC Appliance supports Single Sign-On (SSO) for the following:

- Cisco VPN Concentrators
- Cisco ASA 5500 Series Adaptive Security Appliances
- Cisco Airespace Wireless LAN Controllers
- Cisco SSL VPN Client (Full Tunnel)
- Cisco VPN Client (IPSec)

Note

The Enable L3 support option must be checked on the CAS (under Device Management > Clean Access Servers > Manage [CAS_IP] > Network > IP) for the Agent to work in VPN tunnel mode.

Note

The Clean Access Server can acquire the client’s IP address from either Calling_Station_ID or Framed_IP_address RADIUS attributes for SSO purposes. Cisco NAC Appliance RADIUS Accounting support for Single Sign-On (SSO) includes the Cisco Airespace Wireless LAN Controller. For SSO to work with Cisco NAC Appliance, the Cisco Airespace Wireless LAN Controller must send the Calling_Station_IP attribute as the client’s IP address (as opposed to the Framed_IP_address attribute that the VPN concentrator uses). See also View Active VPN Clients, page 6-19.

See Configure Single Sign-On (SSO) on the CAS/CAM, page 6-10 for further details.
**Chapter 6      Integrating with Cisco VPN Concentrators**

**Overview**

**Figure 6-1   VPN Concentrator Integrated with Cisco NAC Appliance**

![Diagram showing integration of VPN Concentrator with Cisco NAC Appliance](image)

**Figure 6-2   VPN Concentrator Before Cisco NAC Appliance Integration**

![Diagram showingVPN Concentrator setup before integration](image)

(Optional) with accounting server(s) configured:
Configure Cisco NAC Appliance for VPN Concentrator Integration

The following steps are needed to configure Cisco NAC Appliance to work with a VPN concentrator.

**Step 1**  Add Default Login Page
**Step 2**  Configure User Roles and Requirements for your VPN users
**Step 3**  Enable L3 Support on the CAS
**Step 4**  Verifying the Discovery Host
**Step 5**  Adding/Editing VPN Concentrator Entries
**Step 6**  Make CAS the RADIUS Accounting Server for VPN Concentrator
**Step 7**  Adding/Editing Accounting Server Entries
**Step 8**  Mapping VPN Concentrator(s) to Accounting Server(s)
**Step 9**  Create (Optional) Auth Server Mapping Rules
**Step 10**  Add VPN Concentrator as a Floating Device
**Step 11**  Configure Single Sign-On (SSO) on the CAS/CAM
**Step 12**  Configure VPN SSO in a FIPS 140-2 Compliant Deployment (if FIPS 140-2 compliant deployment)
**Step 13**  Create (Optional) Auth Server Mapping Rules on the CAM for Cisco VPN SSO
**Step 14**  Test as Cisco NAC Appliance Agent with VPN Concentrator and SSO
**Step 15**  View Active VPN Clients (for troubleshooting)
Add Default Login Page

For both web login users and Agent users, a login page must be added and present in the system in order for the user to authenticate via the Agent. Go to Administration > User Pages > Login Page > Add | Add to quickly add the default user login page. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for complete details on login page configuration options.

Configure User Roles and Requirements

User roles must be configured along with requirements to enforce client posture assessment on VPN users. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for configuration details.

Enable L3 Support on the CAS

The Enable L3 support option must be checked on the IP form of the CAS for the Agent to work in VPN tunnel mode.

1. Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Network > IP.

2. The Clean Access Server Type, Trusted Interface, and Untrusted Interface settings should already be correctly configured (from when the CAS was added).

3. Click the checkbox for Enable L3 support.

4. Click Update.

5. Click Reboot.
Configure Cisco NAC Appliance for VPN Concentrator Integration

Chapter 6      Integrating with Cisco VPN Concentrators

Configure Cisco NAC Appliance for VPN Concentrator Integration

Note

- The enable/disable L3 feature is disabled by default, and ALWAYS requires an Update and Reboot of the CAS to take effect. Update causes the web console to retain the changed setting until the next reboot. Reboot causes the process to start in the CAS.
- L3 and L2 strict options are mutually exclusive; enabling one option disables the other.

See also Enable L3 Support, page 4-15.

Verifying the Discovery Host

There must be a Discovery Host enabled in order for the Agent to discover the CAS in VPN or L3 deployments. By default, the Discovery Host field is set to the IP address of the CAM. Because the VPN concentrator acts as a router between the user and the CAS, the Agent uses the Discovery Host to direct its UDP 8906 discovery packets to the network of the CAS. The CAS uses these packets to learn that an Agent is active, and discards the packets before they ever reach the CAM. (This function does not apply to the Cisco NAC Web Agent.) The Discovery Host field should be set in the CAM before the Agent is distributed and installed on client machines.

2. Verify the IP address for the Discovery Host field is either the IP address of the CAM (default), or a trusted network IP address that requires traffic to be routed/forwarded via the CAS.
3. If changing the Discovery Host, click the Update button.


Adding/Editing VPN Concentrator Entries

Step 1  Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Authentication > VPN Auth > VPN Concentrators.

Step 2  If you are editing an existing VPN concentrator entry, click on the Edit icon for that entry in the list at the bottom of the configuration window, update any information necessary according to the following steps, and click Save. Otherwise, skip to Step 3 to add a new VPN concentrator entry.
Configure Cisco NAC Appliance for VPN Concentrator Integration

Chapter 6      Integrating with Cisco VPN Concentrators

**Figure 6-5    Add VPN Concentrator**

<table>
<thead>
<tr>
<th>Status</th>
<th>Network</th>
<th>Filter</th>
<th>Advanced</th>
<th>Authentication</th>
<th>Misc</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login Page</td>
<td>VPN Auth &gt; Windows Auth</td>
<td>OS Detection</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>General</td>
<td>VPN Concentrators</td>
<td>Accounting Servers</td>
<td>Accounting Mapping</td>
<td>Active Clients</td>
<td></td>
</tr>
</tbody>
</table>

**Step 3**  Type a **Name** for the concentrator.

**Step 4**  Type the **Private IP Address** of the concentrator.

**Step 5**  Type a **Shared Secret** between the CAS and VPN concentrator. The same secret must be configured on the concentrator itself.

**Step 6**  Retype the secret in the **Confirm Shared Secret** field.

**Step 7**  Enter an optional **Description**.

**Step 8**  For a FIPS 140-2 compliant deployment, activate the **Enable IPsec** checkbox to ensure you can establish a secure IPSec tunnel for authentication traffic. See also, Configure VPN SSO in a FIPS 140-2 Compliant Deployment, page 6-13.

**Step 9**  Click **Add VPN Concentrator**.

**Make CAS the RADIUS Accounting Server for VPN Concentrator**

Make the CAS the RADIUS accounting server on the VPN concentrator (for example, on the VPN 3000 series, this is done under Configuration > System > Servers > Accounting). It is a good idea to record the settings for each accounting server to transfer to the CAS later. The CAS should be the only accounting server for the VPN concentrator, and the VPN concentrator should be configured with the trusted-side IP address of the CAS and have the same shared secret as the CAS.

For further details, refer to the appropriate product documentation, such as:


Adding/Editing Accounting Server Entries

If the VPN concentrator is configured to work with an accounting server, the information for the accounting server(s) needs to be transferred to the CAS. The CAS maintains these associations instead.

**Step 1** Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP]> Authentication > VPN Auth > Accounting Servers.

**Step 2** If you are editing an existing accounting server entry, click on the Edit icon for that entry in the list at the bottom of the configuration window, update any information necessary according to the following steps, and click Save. Otherwise, skip to Step 3 to add a new accounting server entry.

**Figure 6-6 Add Accounting Server(s)**

<table>
<thead>
<tr>
<th>Name:</th>
<th>IP Address:</th>
<th>Port:</th>
<th>Retry:</th>
<th>Timeout (seconds):</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shared Secret:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Description:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Step 3** Type a Name for the accounting server.

**Step 4** Type the IP Address of the accounting server.

**Step 5** Type the Port of the accounting server (typically 1813).

**Step 6** Type the Retry number for the accounting server. This specifies the number of times to retry a request attempt if there is no response within the Timeout specified. For example, if the Retry is 2, and the Timeout is 3 (seconds), it will take 6 seconds for the CAS to send the request to the next accounting server on the list.

**Step 7** Type the Timeout of the accounting server (in seconds). This specifies how long the CAS should wait before retrying a request to the accounting server when there is no response.

**Step 8** Type a Shared Secret between the CAS and accounting server. You can transfer the settings from the VPN concentrator or create a new secret; however the same secret must be configured on the accounting server itself.

**Step 9** Retype the secret in the Confirm Shared Secret field.

**Step 10** Enter an optional Description.
Step 11 For a FIPS 140-2 compliant deployment, activate the Enable IPsec checkbox to ensure you can establish a secure IPSec tunnel for authentication traffic.

Step 12 Click Add Accounting Server.

---

Mapping VPN Concentrator(s) to Accounting Server(s)

If managing multiple VPN concentrators and multiple accounting servers, you can create mappings to associate the VPN concentrator(s) with sets of Accounting Servers. This allows the CAS to continue to the next server on the list in case an accounting server becomes unreachable.

Step 1 Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Authentication > VPN Auth > Accounting Mapping.

Figure 6-7 Accounting Mapping

Step 2 Choose a VPN Concentrator from the dropdown menu. The menu displays all VPN concentrators added to the CAS.

Step 3 Choose an Accounting Server from the dropdown menu. The menu displays all accounting servers configured for the CAS.

Step 4 Click the Add Entry button to add the mapping. The list below will display all the accounting servers associated per VPN concentrator by name, IP address, and port.
Add VPN Concentrator as a Floating Device

In general, if the Clean Access Server is not on the same subnet as clients, the CAS will not obtain client MAC information for IP addresses as clients log into the system. Where there is a VPN concentrator between users and the CAS (all Server Types), the CAS will see the MAC address of the VPN concentrator with each new client IP address because the VPN concentrator performs Proxy ARP for the client IP addresses. Unless the VPN concentrator is configured as a floating device, only the first user logging into Cisco NAC Appliance will be required to meet requirements. Therefore, administrators must add the MAC address of the router/VPN concentrator to the Floating Device list under Device Management > Clean Access > Certified Devices > Add Floating Device (example entry: 00:16:21:11:4D:67 1 vpn_concentrator). See “Add Floating Devices” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for details.

Configure Single Sign-On (SSO) on the CAS/CAM

Single Sign-On (SSO) allows the user to login only once via the VPN client before being directed through the posture assessment process. To perform SSO, Cisco NAC Appliance takes the RADIUS accounting information from the VPN concentrator/wireless controller for the user authentication and uses it to map the user into a user role. This allows the user to go through posture assessment directly without having to also login on the Clean Access Server. SSO is configured on both the CAS and CAM as described below.

The most important attributes needed from RADIUS accounting packets are User_Name, Framed_IP_address, Calling_Station_ID. For a user to be qualified for SSO through the Clean Access Server, either the Framed_IP_address or Calling_Station_ID attribute (sent for the client's IP address) must be in the RADIUS accounting message.

Note

RADIUS Accounting support for Single Sign-On (SSO) includes the Cisco Airespace Wireless LAN Controller. For SSO to work with Cisco NAC Appliance, the Cisco Airespace Wireless LAN Controller must send the Calling_Station_IP attribute as the client's IP address (as opposed to the Framed_IP_address attribute that the VPN concentrator uses).

Configure SSO on the CAS

Step 1  Go to Device Management > CCA Servers > List of Servers > Manage [CAS_IP] > Authentication > VPN Auth > General.
Configure Cisco NAC Appliance for VPN Concentrator Integration

Chapter 6      Integrating with Cisco VPN Concentrators

Figure 6-8      General Settings (SSO / Logout / RADIUS Accounting Port)

Step 2  Click the checkbox for **Single Sign-On** to enable VPN SSO on the CAS.

Step 3  Enter a time period (in seconds) for the **Agent VPN Detection Delay** value. If the CAS has not received the required RADIUS accounting information before the Agent attempts VPN SSO, the Agent will prompt for user login. The **Agent VPN Detection Delay** field allows you to specify the amount of time the CAS should wait before prompting for authentication from the remote user’s Agent that is transmitting SWISS UDP discovery packets.

This option ensures that the CAS has time to receive updates for users who are already connected via VPN before prompting them for login credentials that the CAS normally leverages from VPN login. If the CAS learns of the existing connection during the specified waiting period, it automatically yields to the VPN SSO function. Otherwise, once the specified waiting period has passed with no indication that the user connection is already established via VPN, the CAS prompts the user to enter their login credentials.

**Note**  The **Agent VPN Detection Delay** applies to all VPN SSO users until the delay expires.

When this value is 0, the CAS requests the Agent to perform VPN SSO immediately. Set this value to 0 if the first RADIUS accounting packet received by the CAS has enough information to perform VPN SSO when the VPN is connected.

When this value is any number other than 0, the CAS informs the Agent in the SWISS packet to wait for the specified delay before attempting VPN SSO login. Set this field to a non-zero value if:

- The Agent is prompting for user authentication because the first RADIUS accounting packet is delayed.
- The VPN concentrator requires a second accounting packet to update the VPN IP address sent in the first accounting packet. In this case, the CAS will not see this VPN connection as valid after the first accounting packet, and the Agent will prompt for user login if the **Agent VPN Detection Delay** is set to 0.

Step 4  Click the checkbox for **Auto-Logout** to automatically terminate the VPN session for users when they log out.

Step 5  Leave the default port (1813) or configure a new one for **RADIUS Accounting Port**.

**Note**  A CAS deployed as a Real-IP gateway supporting VPN SSO opens the Accounting port only on the trusted (eth0) interface.
Configure SSO on the CAM

To support SSO when configuring Cisco NAC Appliance VPN Concentrator integration, a Cisco VPN SSO authentication source must be added to the CAM.

1. Go to User Management > Auth Servers > New.

**Figure 6-9   Add New Auth Server (in CAM)**

2. Choose Cisco VPN SSO from the Authentication Type dropdown menu.
3. The Provider Name is set by default to Cisco VPN.
4. From the Default Role dropdown, choose the user role you want VPN client users to be assigned to for the posture assessment process.
5. Enter an optional Description to identify the VPN concentrator in the list of auth servers.
6. Click Add Server.

The new Cisco VPN SSO auth server appears under User Management > Auth Servers > List of Servers.
- Click the Edit button next to the auth server to modify settings.
- Click the Mapping button next to the auth server to configure RADIUS attribute-based mapping rules for Cisco VPN SSO.

See the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for further details.
Configure VPN SSO in a FIPS 140-2 Compliant Deployment

Setting up IPSec communication between your FIPS compliant Cisco NAC Appliance system and Cisco ASA covers three primary phases:

- Import a Trusted CA
- Set up Identity certificate
- Create a Site-to-Site VPN to CAS

Import a Trusted CA

To import your trusted Certificate Authority (CA) into the ASA VPN concentrator:

**Step 1** In ASDM, click the Configuration toolbar button.

**Step 2** Select the Site-to-Site VPN tab.

**Step 3** Go to Panel Certificate Management > CA Certificates (Figure 6-10).

**Figure 6-10 Import CA Certificate**

- **Step 4** Click Add and enter a trustpoint name for your CA.
- **Step 5** Click Browse and select your CA certificate file.
- **Step 6** Click Install Certificate.
Set up Identity certificate

To set up an Identity Certificate on the ASA VPN concentrator:

**Step 1**  Go to Certificate Management > Identity Certificates.

**Step 2**  Specify a trustpoint name.

**Step 3**  Choose the **Import the identity certificate from a file** option (Figure 6-11).

![Figure 6-11 Import Identity Certificate](image)

**Step 4**  Enter the **Decryption Passphrase** for your certificate (which is the password you specified when you exported the trusted CA certificate).

**Step 5**  Click **Browse** and select the identity certificate.

This certificate/key pair should be in pkcs12 format. If not, you can use the following OpenSSL command to convert separate key/certificate files into one single pkcs12 format:

```
openssl pkcs12 -export -in cert.pem -inkey key.pem -out ASACert.p12
```

**Step 6**  Specify the Identity Certificate password (which is the same as the **Decryption Passphrase** for your certificate).

**Step 7**  Click **Add Certificate**.
Create a Site-to-Site VPN to CAS

**Note**
Use ASDM version 6.2(1) (asdm-621.bin) for the following procedure.

**Step 1** Select Wizards > IPsec VPN Wizard (Figure 6-12).

**Figure 6-12  VPN Wizard**

**Step 2** Specify the following tunnel attributes:
- VPN Tunnel Type: **Site-to-Site**
- VPN Tunnel Interface: **inside**

**Step 3** Check the “Enable inbound IPsec sessions…” option and click **Next**.

**Step 4** Specify the following attributes:
- Peer IP Address: <CAS trusted IP address>
- Authentication method: **Certificate**
- Certificate Name: <trustpoint name you entered when importing identity certificate>
- Tunnel Group Name: <CAS IP address> (default setting)

**Step 5** Click **Next**.

**Step 6** Specify the following IKE Policy attributes:
- Encryption: **AES-128**
- Authentication: **SHA**
- Diffie-Hellman Group: **2**
Step 7  Click Next.
Step 8  Specify the following IPsec Rule attributes:
   • Encryption: AES-128
   • Authentication: SHA
   • Check the Enable Perfect Forward Secrecy option
   • Diffie-Hellman Group: 2
Step 9  Click Next.
Step 10 Specify the following Hosts and Networks attributes:
   • Action: Protect
   • Local Networks: <inside IP address of ASA>
   • Remote Networks: <CAS IP address>
Step 11 Check the Exempt ASA side host/network option and click Next.
Step 12 Verify the configuration summary and click Finish.
Step 13 Go to Configuration > Site-to-Site VPN > Advanced > IPSec Transform Sets (Figure 6-13).

Figure 6-13  Add IPSec Transform Set

Step 14  Click Add.
Step 15 Specify the following attributes:
   • Set Name: NAC-AES-128-SHA
   • Mode: Transport
   • ESP Encryption: AES-128
Configure Cisco NAC Appliance for VPN Concentrator Integration

- ESP Authentication: SHA

**Step 16** Click OK.

**Step 17** Go to Configuration > Site-to-Site VPN > Connection Profiles.

**Step 18** Select the IPSec connection you created and click Edit.

**Step 19** Under Encryption Algorithms, click Manage (next to IKE Proposal).

**Step 20** In the Configure IKE Proposals dialog box, click Edit.

**Step 21** Select the aes-128/sha/2/rsa-sig proposal and edit it so that the Lifetime attribute is set to 8 hours.

**Step 22** Click OK.

**Step 23** Specify the IPSec Proposal to be NAC-AES-128-SHA and click OK.

**Step 24** Click Apply.

**Step 25** Select Tools > Command Line Interface and enter ping <CA Sip address>.

Be sure to verify the ping output.

---

**Create (Optional) Auth Server Mapping Rules**

For the Cisco VPN SSO type, you can create mapping rules based on the RADIUS Auth Server attributes that are passed from the VPN Concentrator to map users into roles. The following RADIUS attributes can be used to configure Cisco VPN SSO mapping rules:

- Class
- Framed_IP_Address
- NAS_IP_Address
- NAS_Port
- NAS_Port_Type
- User_Name
- Tunnel_Client_Endpoint
- Service_Type
- Framed_Protocol
- Acct_Authentic

Mapping rules are configured in the CAM web admin console under User Management > Auth Servers > Mapping Rules. For complete configuration details, see “User Management: Configuring Auth Servers” in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).
Cisco NAC Appliance Agent with VPN Concentrator and SSO

The Agent supports multi-hop L3 deployment and VPN/L3 access from the Agent. The Agent:

1. Checks the client network for the Clean Access Server (L2 deployments), and if not found,
2. Attempts to discover the CAS by sending discovery packets to the CAM. This causes the discovery packets to go through the CAS even if the CAS is multiple hops away (multi-hop deployment) so that the CAS will intercept these packets and respond to the Agent.

In order for clients to discover the CAS when they are one or more L3 hops away, clients must initially download the Agent from the CAS. This can be done in two ways:

- From the Agent download web page (i.e. via web login)
- By client upgrade to the latest Cisco NAC Agent or auto-upgrade to Agent version 4.6.2.113 or later. For the Agent auto-upgrade process to work, clients must have an earlier version of the Agent already installed.

Either method allows the Agent to acquire the IP address of the CAM in order to send traffic to the CAM/CAS over the L3 network. Once installed in this way, the Agent can be used for both L3/VPN concentrator deployments or regular L2 deployments. See Enable L3 Support, page 4-15 for details.

Note
For VPN SSO deployments, if the Agent is not downloaded from the CAS, but is instead downloaded by other means, the Agent is not able to determine the runtime IP information of the CAM and does not automatically pop up, nor does it scan the client machine. For Cisco NAC Agent users, you can work around this issue by specifying a DiscoveryHost setting in the Agent configuration XML file.

Note
- Uninstalling the Agent while still on the VPN connection does not terminate the VPN connection, although the (if configured) the client machine is removed from the Certified Devices List and the user is removed from the Online Users List.
- If a 3.5.0 or earlier version of the Clean Access Agent is already installed, or if the Agent is installed through non-CAS means, you must perform web login to download the latest Agent setup files from the CAS directly and reinstall the Agent to get the L3 capability.

Cisco NAC Appliance Agent Layer 3 VPN Concentrator User Experience

1. Launch the VPN connection application configured to work with Cisco NAC Appliance.
2. Once logged in, open a browser and attempt to go to an intranet or extranet site.

Cisco NAC Appliance enables administrators to deploy the CAS in-band behind a VPN concentrator, or router, or multiple routers. Cisco NAC Appliance supports multi-hop Layer 3 in-band deployment by allowing the CAM and CAS to track user sessions by unique IP address when users are separated from the CAS by one or more routers. With Layer 2-connected users, the CAM/CAS continue to manage these user sessions based on the user MAC addresses, as before. Figure 6-14 illustrates the login and posture assessment process for a VPN user using the Agent with Single Sign-On. Note that the initial download of the Agent must be performed via the VPN connection.
View Active VPN Clients

The Active VPN Clients page lists IP addresses known to the CAS through VPN Single Sign-On (SSO). This page is intended for troubleshooting and is available in both the CAS management pages and CAS direct access console. The Active VPN Clients page shows a list of all users for which the CAS has received valid Radius accounting START packets.

Anytime the CAS receives a valid Radius Accounting START packet for a particular client machine, the CAS adds it to the Active VPN Clients list:
• If a client appears in this list, the client is able to perform SSO.
• If the client does not appear in this list, then most likely the START packet did not make it to the CAS or it was in an incorrect format.

The key things the packet format must include are:
• Account-Status-type = 1 (indicating it is a START packet)
• Calling-station-Id (showing end machine’s IP address)

When the user tries to browse, or runs the Agent, the CAM/CAS compares the Active VPN Client information to its mapping rules to determine what role to put the user in.

To view active VPN clients:

**Figure 6-16    Active Clients (VPN Concentrator)**

2. Click the Show All button to List All VPN Clients or perform a Search. The Active Clients page remains blank until you perform one of these two actions:
   a. Click Show All to display all current IP/user information from the system Single Sign-On (SSO) table.
   b. Alternatively, type an IP address in the Search IP Address text field, select an operator from the dropdown menu (equals, starts with, ends with, contains), and click the Search button to display results.

3. The table at the bottom of the page is populated with the following information. Entries are sorted by Client IP address.
   - **Total Active VPN Clients**—Displays the current number of active VPN clients in the SSO table.
   - **Client IP**—The client IP address received from the RADIUS accounting packet.
   - **Client Name**—The client name received from the RADIUS accounting packet.
   - **VPN Server IP**—The IP address of the Cisco VPN SSO auth server being used for Single Sign-On.
- **Login Time**—The date/time that the active VPN client session was established.

**Note**
Clicking **Show All** or performing a new search refreshes the page with the latest SSO table information.

4. To remove entries from the Active Client page, either:

   a. Click the **Clear** button to **Clear All Active VPN Client** entries from the SSO table. For example, if VPN users lose their sessions due to a VPN server crash, the RADIUS accounting stop message will not be sent to the CAS, and those users will remain in the system SSO table until manually removed. Removing all entries from the **Active VPN Clients** page allows the system to restart from a fresh SSO table.

   b. Click the checkbox for an individual entry and click the **Delete** button at the top of the column to remove that entry from the SSO table.

**Note**
Clicking the **Clear** or **Delete** button only removes the user(s) from the system’s current SSO client table; it does not remove the user(s) from the Online Users list.

**Tip**
You can also view active VPN clients from the direct console of the CAS (https://<CAS_eth0_IP_address>/admin), from the **Monitoring > Active VPN Clients** page.
Local Traffic Control Policies

This chapter describes how to set up traffic filtering rules in the Clean Access Server. Topics include:

- Overview, page 7-1
- Local vs. Global Traffic Policies, page 7-2
- View Local Traffic Control Policies, page 7-3
- Add Local IP-Based Traffic Control Policies, page 7-4
- Add Local Host-Based Traffic Control Policies, page 7-6
- Controlling Bandwidth Usage, page 7-14

Overview

Traffic control policies let you control what network resources can be accessed, and which users can access them. Traffic control policies are configured by user role, and must be configured for Agent Temporary and Quarantine roles.

Cisco NAC Appliance offers three types of traffic policies:

**IP-based policies**—IP-based policies are fine-grained and flexible and can stop traffic in any number of ways. IP-based policies are intended for any role and allow you to specify IP protocol numbers as well as source and destination port numbers. For example, you can create an IP-based policy to pass through IPSec traffic to a particular host while denying all other traffic.

**Host-based policies**—Host-based policies are less flexible than IP-based policies, but have the advantage of allowing traffic policies to be specified by host name or domain name when a host has multiple or dynamic IP addresses. Host-based policies are intended to facilitate traffic policy configuration primarily for Agent Temporary and Quarantine roles and should be used for cases where the IP address for a host is continuously changing or if a host name can resolve to multiple IPs.

**Layer 2 Ethernet traffic policies**—To support data transfer or similar operations originating at the Layer 2 level, Cisco NAC Appliance Layer 2 Ethernet traffic control policies enable you to allow or deny Layer 2 Ethernet traffic through the CAS based on the type of traffic. Network Frames except for IP, ARP, and RARP frames constitute standard Layer 2 traffic.

---

**Note**

Layer 2 Ethernet traffic control only applies to Clean Access Servers operating in Virtual Gateway mode.
Traffic control policies are directional. IP-based and Layer 2 Ethernet traffic policies can allow or block traffic moving from the untrusted (managed) to the trusted network, or from the trusted to the untrusted network. Host-based policies allow traffic from the untrusted network to the specified host and trusted DNS server specified.

By default, when you create a new user role:
- All traffic from the untrusted network to the trusted network is blocked.
- All traffic from the trusted network to the untrusted network is allowed.

Since all traffic from the untrusted network is initially blocked, after creating a role you typically must create policies for permitting traffic as appropriate for the role.

Alternatively, a traffic control policy can block traffic to a particular machine or limit users to particular activities, such as email use or web browsing. Examples of policies are:

- deny access to the computer at 191.111.11.1, or
- allow www communication from computers on subnet 191.111.5/24

Finally, traffic control policies are hierarchical, and the order of the policy in the policy list affects how traffic is filtered. The first policy at the top of the list has the highest priority. The following examples illustrate how priorities work for Untrusted -> Trusted traffic control policies.

**Example 1:**
- Priority 1: Deny Telnet
- Priority 2: Allow All

**Result:** Only Telnet traffic is blocked and all other traffic is permitted.

**Example 2 (priorities reversed):**
- Priority 1: Allow All
- Priority 2: Deny Telnet

**Result:** All traffic is allowed, and the second policy blocking Telnet traffic is ignored.

**Example 3:**
1. Allow TCP *.* 10.10.10.1/255.255.255.255
2. Block TCP *.* 10.10.0.0/255.255.255.0

**Result:** Allow TCP access to 10.10.10.1 while blocking TCP access to everything else in the subnet (10.10.0.*).

**Example 4 (Layer 2 Ethernet - Virtual Gateway mode only):**
1. Allow SNA IBM Systems Network Architecture
2. Block ALL All Traffic

**Result:** Allow only IBM Systems Network Architecture (SNA) Layer 2 traffic and deny all other Layer 2 traffic.

---

**Local vs. Global Traffic Policies**

Most traffic control policies are set globally for all Clean Access Servers using the Clean Access Manager global forms. By adding local traffic policies in individual Clean Access Servers, you can specialize filtering for the network managed by that CAS by extending policies defined globally.
This chapter describes the local traffic control policies configured on a CAS under Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles.

Note that global policies appear with yellow background while local policies appear with white background in the local list of traffic policies. To delete a policy, use the global or local form you used to create it.

Global policies can only be accessed and modified from the User Management > User Roles > Traffic Control global forms. For details, see the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

A local traffic control policy for a CAS takes precedence over a global policy for all Clean Access Servers if the local policy has a higher priority.

View Local Traffic Control Policies

To view and configure local traffic control role policies, go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles. The policies appear by role in the Traffic Control form, as shown in Figure 7-1.

By default, the page lists the policies for traffic traveling from the untrusted network as the source to the trusted network as the destination. To view the policies for the opposite direction, with the trusted network as the source and the untrusted network as the destination, choose Trusted -> Untrusted from the direction field and click Select.

You can similarly display the policies for a single role by choosing the role from the role dropdown menu and clicking Select.
The priority of a policy corresponds to the order in which it appears in the list, the first item having the highest priority. You can change a policy’s priority by clicking the corresponding up or down arrow in the Move column.

Add Local IP-Based Traffic Control Policies

Traffic control policies permit or block traffic to resources on the network and are created per role. Before creating a traffic control policy, make sure the role to which you want to assign the policy already exists. You can specify individual ports, a port range, a combination of ports and port ranges, or wildcards when configuring IP-based traffic policies.

Add / Edit Local IP-Based Traffic Policy

2. In the Traffic Control form, select the source-to-destination direction for which you want the policy to apply. Chose either Trusted -> Untrusted or Untrusted -> Trusted, and click Select.
3. For a new policy:
   - Click the Add Policy link next to the role for which you want to create the policy, or
   - Click Add Policy to All Roles to add the new policy to all the roles (except the Unauthenticated role) at once.

To modify an existing policy:
   - Click Edit next to the policy you want to modify.

Figure 7-3 shows the Add Policy form.

Figure 7-3  Add New Local IP Policy
Chapter 7  Local Traffic Control Policies

Add Local IP-Based Traffic Control Policies

4. Set the **Priority** of the policy from the **Priority** dropdown menu. The IP policy at the top of the list will have the highest priority in execution. By default, the form displays a priority lower than the last policy created (1 for the first policy, 2 for the second policy, and so on). The number of priorities in the list reflects the number of policies created for the role. The built-in **Block All** policy has the lowest priority of all policies by default.

5. Set the **Action** of the traffic policy as follows:
   - **Allow** (default) – Permit the traffic.
   - **Block** – Drop the traffic.

6. Set the **Category** of the traffic as follows:
   - **ALL TRAFFIC** (default) – The policy applies to all protocols and to all trusted and untrusted source and destination addresses.
   - **IP** – If selected, the **Protocol** field displays as described below.
   - **IP FRAGMENT** – By default, the Clean Access Server blocks IP fragment packets, since they can be used in denial of service attacks. To permit fragmented packets, define a role policy allowing them with this option.

7. The **Protocol** field appears if the **IP** Category is chosen, displaying the options listed below:
   - **CUSTOM**: – Select this option to specify a different protocol number than the protocols listed in the **Protocol** dropdown menu.
   - **TCP (6)** – For Transmission Control Protocol. TCP applications include HTTP, HTTPS, and Telnet.
   - **UDP (17)** – For User Datagram Protocol, generally used for broadcast messages.
   - **ICMP (1)** – For Internet Control Message Protocol.
   - **ESP (50)** – For Encapsulated Security Payload, an IPsec subprotocol used to encrypt IP packet data typically in order to create VPN tunnels
   - **AH (51)** – Authentication Header, an IPsec subprotocol used to compute a cryptographic checksum to guarantee the authenticity of the IP header and packet.

8. In the **Untrusted (IP/Mask:Port)** field, specify the IP address and subnet mask of the untrusted network to which the policy applies. An asterisk in the IP/Mask:Port fields means the policy applies for any address/application.

   If you chose TCP or UDP as the **Protocol**, also type the TCP/UDP port number for the application in the **Port** text field.

   **Note** You can specify individual ports, a port range, a combination of ports and port ranges, or wildcards when configuring TCP/UDP ports. For example, you can specify port values such as: “*” or “21, 1024-1100” or “1024-65535” to cover multiple ports in one policy. Refer to [http://www.iana.org/assignments/port-numbers](http://www.iana.org/assignments/port-numbers) for details on TCP/UDP port numbers.
9. In the **Trusted (IP/Mask:Port)** field, specify the IP address and subnet mask of the trusted network to which the policy applies. An asterisk in the IP/Mask:Port fields means the policy applies for any address/application. If you chose TCP or UDP as the **Protocol**, also type the TCP/UDP port number for the application in the **Port** text field.

10. Optionally, type a description of the policy in the **Description** field.

11. Click **Add Policy** when finished. If modifying a policy, click the **Update Policy** button.

---

**Note**

The traffic direction you select for viewing the list of policies (Untrusted -> Trusted or Trusted -> Untrusted) sets the source and destination when you open the **Add Policy** form:

- The first IP/Mask/Port entry listed is the source.
- The second IP/Mask/Port entry listed is the destination.

---

### Add Local Host-Based Traffic Control Policies

Local host-based policies allow you to control user traffic to host sites for users in a role and for a particular Clean Access Server.

Default host policies for the Unauthenticated, Temporary, and Quarantine roles are automatically retrieved and updated after a Cisco NAC Appliance **Update** or **Clean Update** is performed from the CAM.

You can configure custom DNS host-based policies for a role by host name or domain name when a host has multiple or dynamic IP addresses. Note that to use any host-based policy, you must first add a Trusted DNS Server for the user role.

---

**Note**

- After a software upgrade, new default host-based policies are disabled by default but enable/disable settings for existing host-based policies are preserved.
- After a Clean Update, all existing default host-based policies are removed and new default host-based policies are added with default disabled settings.
- The host-based policies have higher priority than IP-based Traffic Policies. The traffic that passes through an allowed host is always allowed, even if an IP-based policy denies it.

See the **Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)** for details on the automatic **Updates** downloaded to the CAM under **Device Management > Clean Access > Updates**.

---

### Enable Proxy Traffic

You can enable an individual CAS to parse host policies when user traffic passes through a specified proxy server by redirecting user session packets to a local Proxy Server or to the URL of a preconfigured Proxy PAC (Proxy Auto Configuration) file reachable from the CAS.

When the **Parse Proxy Traffic** option is checked for an individual CAS, and a proxy server is specified on the CAS **Proxy** page, the CAS will check the payloads of GET, POST, and CONNECT HTTP/HTTPS/FTP requests to make sure that the host is on the host policy list before allowing traffic...
Add Local Host-Based Traffic Control Policies
to the proxy server. This allows users to access only the host sites enabled for a role (e.g. Temporary or Quarantine users that need to meet requirements) when the specified proxy server is used. Note that the “parse proxy traffic” feature is enabled per CAS, and you must specify the Proxy server IP and port on the CAS Proxy page and enable the Parse Proxy Traffic option for this feature to take effect.

To enable host policies when traffic is going through proxy server specified on the CAS:

**Step 1**
Go to Device Management > CCA Servers > Manage [CAS_IP] > Advanced > Proxy.

**Step 2**
Specify the proxy source as described in Configure Proxy Server Settings on the CAS, page 4-47.

**Step 3**
Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Allowed Hosts (see Figure 7-4).

**Figure 7-4 CAS—Allowed Hosts**

<table>
<thead>
<tr>
<th>Unauthenticated Role</th>
<th>View Current IP Addresses for All Roles</th>
<th>Unauthenticated Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allowed Host</td>
<td>Match</td>
<td>Description</td>
</tr>
<tr>
<td>.microsoft.com</td>
<td>ends</td>
<td>Microsoft Windows Update</td>
</tr>
<tr>
<td>.windowsupdate.com</td>
<td>ends</td>
<td>Microsoft Windows Update</td>
</tr>
<tr>
<td>.antivirus.com</td>
<td>ends</td>
<td>TrendMicro Update</td>
</tr>
<tr>
<td>.ncafee.com</td>
<td>ends</td>
<td>McAfee Update</td>
</tr>
</tbody>
</table>

**Step 4**
Enable the Parse Proxy Traffic option. This setting applies to all roles (Unauthenticated, Temporary, Quarantine, and normal user login roles).

When the Parse Proxy Traffic option is enabled for an individual CAS, the CAS checks the payloads of GET, POST and CONNECT HTTP/HTTPS/FTP requests to make sure that the host is on the host policy list before allowing traffic to the proxy server specified on the Proxy page. This allows users to access only the host sites enabled for the associated role when the specified proxy server is used. Note that you must specify the Proxy server IP and port (as described above) before enabling the Parse Proxy Traffic option on each CAS in your deployment.

**Note**
When using proxy settings, also make sure DNS settings are properly configured on the CAS under Device Management > CCA Servers > Manage [CAS_IP] > Network > DNS. See Configure DNS Servers on the Network, page 4-24 for details.

**Step 5**
Click the Update button.
Add Local Host-Based Traffic Control Policies

Enable Proxy on CAS

When administrators apply Host Policies to the Unauthenticated Role, the CAS acts as a proxy for the client machine. If the CAS itself requires a proxy to access the network, you must modify the /perfigo/access/apache/conf/httpd.conf file configuration to feature a ProxyRemote statement associated with an appropriate ProxyAllow statement.

The following example illustrates a part of sample httpd.conf file that shows the ProxyRemote statement associated with an appropriate ProxyAllow statement:

```<VirtualHost _default_:880>
  # TRACE OFF
  TraceEnable off
  RewriteEngine On
  RewriteRule "perfigo$" "/perfigo/access/apache/www/fcgi-bin/proxy.fcgi"
  ProxyAllow "/proc/click/dnshandler/proxyallow"
  ProxyRemote * http://proxyID.mycompany.com:<port-number>/
  ProxyRequests On
</VirtualHost>
```

**Note** Refer to http://httpd.apache.org/docs for more apache syntax/usage references.

Add Local Allowed Host

1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Allowed Hosts and select the role for which to add a DNS host.

<table>
<thead>
<tr>
<th>Role01</th>
<th>View Current IP Addresses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allowed Host</td>
<td>Match</td>
</tr>
<tr>
<td><a href="http://www.allowedhost.com">www.allowedhost.com</a></td>
<td>equals</td>
</tr>
<tr>
<td><a href="http://www.allowedhost.com">www.allowedhost.com</a></td>
<td>equals</td>
</tr>
<tr>
<td>Trusted DNS Server</td>
<td>Description</td>
</tr>
<tr>
<td>*</td>
<td>Any DNS Server</td>
</tr>
</tbody>
</table>

2. Type the hostname in the Allowed Host field (e.g. “allowedhost.com”).
3. In the Match dropdown menu, select an operator to match the host name: equals, ends, begins, or contains.
4. Type a description for the host in the Description field, such as “Allowed Host Update”.
5. Click Enable.
6. Click Add.

**Note** You must add a Trusted DNS Server to the role to enable host-based traffic policies for the role.
Add Local Trusted DNS Server

To add a local trusted DNS server:

1. Enter an IP address in the **Trusted DNS Server** field, or enter an asterisk “*” to specify any DNS server.

2. Type a description for the DNS server in the **Description** field.

3. Click **Add**.

**Note**

When a trusted DNS server is added, an IP-based traffic policy allowing that server is automatically added for the role.

**Note**

When you add a specific DNS server, then use this form later to add any (“*”) DNS server, the previously added server becomes a subset of the overall policy allowing all DNS servers, and will not be displayed. If you later delete the any (“*”) DNS server policy, the specific trusted DNS server you had previously allowed will be displayed again.

View IP Addresses Used by DNS Host

You can view the IP addresses used for the DNS host when clients connect to the host to update their systems.

1. Go to **Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Allowed Hosts**.

2. To view all IP addresses for DNS hosts accessed across all roles, click the **View Current IP addresses for All Roles** at the top of the page.
Chapter 7  Local Traffic Control Policies

Add Layer 2 Ethernet Traffic Control Policies

You can view this list from the CAS management pages, but modifying this list is done from the Clean Access Manager global filters forms. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for details.

3. To view the IP addresses for DNS hosts accessed by clients in a specific role, click the View Current IP addresses link next to the desired role.

4. The IP address, Host name, and Expire time will display for each IP address accessed. The Expire time is based on the DNS reply TTL. When the IP address for the DNS host reaches the Expire time, it becomes invalid.

Add Layer 2 Ethernet Traffic Control Policies

Layer 2 Ethernet traffic control only applies to Clean Access Servers operating in Virtual Gateway mode.

Layer 2 Ethernet traffic control policies enable administrators to allow or block Layer 2 Ethernet traffic based on the type of Layer 2 traffic passing through the CAS.

Default traffic control policies for the Unauthenticated, Temporary, and Quarantine roles are automatically retrieved and updated after an Agent Update or Clean Update is performed from the CAM.
Note

- After a software upgrade, new default Layer 2 Ethernet traffic control policies are disabled by default but enable/disable settings for existing Ethernet traffic control policies are preserved.
- After a Clean Update, all existing Layer 2 Ethernet traffic control policies are removed and new default Ethernet traffic control policies are added with default disabled settings.

See the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for details on the automatic Updates downloaded to the CAM under Device Management > Clean Access > Updates.

Enable Layer 2 Ethernet Traffic Control

You can configure an individual CAS to allow or block specified Layer 2 Ethernet traffic based on control policies.

When the Enable Layer 2 Ethernet Traffic Control option is checked for an individual CAS, the CAS will apply relevant Layer 2 Ethernet traffic control policies to the traffic passing through the CAS, allowing or blocking packets based on the type of Layer 2 traffic passing through the CAS.

To enable Layer 2 Ethernet traffic control on the CAS:

1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Ethernet Control (see Figure 7-6).
Add Layer 2 Ethernet Traffic Control Policies

To add a Layer 2 Ethernet traffic control policy:

1. Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Ethernet Control and select the role for which to allow or block Layer 2 Ethernet traffic.

2. Click the checkbox for Enable Layer 2 Ethernet Traffic Control.

3. Click the Update button.
2. Select either **Allow** or **Block** from the **Action dropdown** menu.

3. Specify the type of Layer 2 Ethernet traffic to either allow or block in the **Protocol** dropdown menu.

**Note**  
Except for allowing all Layer 2 traffic, only the “IBM Systems Network Architecture (SNA)” protocol is available with Cisco NAC Appliance release 4.1(1) and later. Additional preset options may become available through the Cisco NAC Appliance update service on the Clean Access Manager.

4. Click **Enable**.

5. Click **Add**.

After you “Add” a traffic control policy, the CAM automatically populates the Description column for the entry with the description of the option you specified in the **Protocol** dropdown menu.
Controlling Bandwidth Usage

Cisco NAC Appliance lets you control how much network bandwidth is available to users by role. You can independently configure bandwidth management using global forms in the CAM as needed for system user roles, or only on certain Clean Access Servers using local forms. However, the option must first be enabled on the CAS for this feature to work. You can also specify bandwidth constraints for each user within a role or for the entire role.

For example, for a CAM managing two CASs, you can specify all the roles and configure bandwidth management on some of the roles as needed (e.g. guest role, quarantine role, temporary role, etc.). If bandwidth is only important in the network segment where CAS1 is deployed and not on the network segment where CAS2 is deployed, you can then turn on bandwidth management on CAS1 but not CAS2.

With bursting, you can allow for brief deviations from a bandwidth constraint. This accommodates users who need bandwidth resources intermittently (for example, when downloading and reading pages), while users attempting to stream content or transfer large files are subject to the bandwidth constraint.

By default, roles have a bandwidth policy that is unlimited (specified as -1 for both upstream and downstream traffic).

To configure local bandwidth settings for a role:

1. First, enable bandwidth management on the CAS by going to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Roles > Bandwidth.

2. Select Enable Bandwidth Management and click Update.

3. Click the Edit button next to the role for which you want to set bandwidth limitations. The Role Bandwidth form appears.
4. The **Current Status** field lists either:
   - **Default Setting**: Local bandwidth management is not enabled (and settings from User Management > User Roles > Bandwidth are being used), or a local policy has not been set.
   - **Local Setting**: The configured local settings for this CAS apply for the selected role.

5. The **Role Name** field lists the user role for which to configure local settings.

6. Set the maximum bandwidth in kilobits per second for upstream and downstream traffic in **Upstream Bandwidth** and **Downstream Bandwidth**. Upstream traffic moves from the untrusted (managed) to trusted side, while downstream traffic moves from the trusted to untrusted side.

7. Enter a **Burstable Traffic** level from 2 to 10 to allow brief (one second) deviations from the bandwidth limitation. A **Burstable Traffic** level of 1 has the effect of disabling bursting.

   The **Burstable Traffic** field is a traffic burst factor used to determine the “capacity” of the bucket. For example, if the bandwidth is 100 Kbps and the **Burstable Traffic** field is 2, then the capacity of the bucket will be 100Kb*2=200Kb. If a user does not send any packets for a while, the user would have at most 200Kb tokens in his bucket, and once the user needs to send packets, the user will be able to send out 200Kb packets right away. Thereafter, the user must wait for the tokens coming in at the rate of 100Kbps to send out additional packets. This can be thought of as way to specify that for an average rate of 100Kbps, the peak rate will be approximately 200Kbps. Hence, this feature is intended to facilitate bursty applications such as web browsing.

8. In the **Shared Mode** field, choose either:
   - **All users share the specified bandwidth** – The setting applies for all users in the role. In this case, the total available bandwidth is a set amount. In other words, if a user occupies 80 percent of the available bandwidth, only 20 percent of the bandwidth will be available for other users in the role.
   - **Each user owns the specified bandwidth** – The setting applies to each user. The total amount of bandwidth in use may fluctuate as the number of online users in the role increases or decreases, but the bandwidth for each user is equal.
9. Optionally, type a **Description** of the bandwidth setting.

10. Click **Save** when finished.

   The bandwidth setting is now applicable for the role and appears in the **Bandwidth** tab.

   See the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for additional details on bandwidth management.
CHAPTER 8

Configuring Active Directory Single Sign-On (AD SSO)

This chapter describes how to configure Active Directory (AD) Single Sign-On (SSO) for the Cisco NAC Appliance.

Topics include:

- Overview, page 8-1
- AD SSO Configuration Step Summary, page 8-5
- Add Active Directory SSO Auth Server, page 8-6
- Configure Traffic Policies for Unauthenticated Role, page 8-7
- Configure AD SSO on the CAS, page 8-11
- Configuring a CAS User on the AD Server for AD SSO, page 8-14
- Configure AD SSO in a Windows 7 Client Environment, page 8-34
- Configure Active Directory for FIPS 140-2 Compliant AD SSO, page 8-37
- Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos), page 8-40
- Confirm Active AD SSO Service, page 8-41
- Enable GPO Updates, page 8-41
- Enabling a Login Script (Optional), page 8-43
- Add LDAP Lookup Server for Active Directory SSO (Optional), page 8-46
- Troubleshooting, page 8-48

Overview

You can configure Cisco NAC Appliance to automatically authenticate Agent users who are already logged into a Windows domain. AD SSO allows users logging into AD on their Windows systems to automatically go through authentication and posture assessment without ever having to log in via the Agent.
Overview

Note
Users logging into Cisco NAC Appliance via AD SSO must be running Windows Vista or Windows 7 and have the latest Cisco NAC Agent (version 4.7.1.15, 4.8.0.32, or 4.9.0.33) installed on their client machine in order to remain FIPS 140-2 compliant. Windows XP clients performing AD SSO do not conform to FIPS 140-2 compliance requirements.

Note
AD SSO is supported in cross-forest configurations with two-way trust established between the forests.

Note
The Cisco NAC Web Agent does not support AD SSO functions.

Cisco NAC Appliance Agent/AD Server Compatibility for AD SSO


Note
You can configure AD SSO for all deployment types (L2/L3, In-Band/Out-of-Band). For OOB, client ports are put on the Auth VLAN first prior to Windows domain authentication.

With AD SSO, Cisco NAC Appliance authenticates the user with Kerberos, but authorizes the user with LDAP. Cisco NAC Appliance leverages the cached credentials/Kerberos ticket from the client machine login and uses it to validate the user authentication with the backend Windows 2000/2003/2008 server Active Directory. After the user authentication is validated, authorization (role-mapping) is then performed as a separate lookup in Active Directory using LDAP.

You can also use the CAMs Auth Test function to test AD SSO authentication in Cisco NAC Appliance. For details, see the “Auth Test” section of the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Note
The LDAP user account must have privileges sufficient to provide a “Search DN/Password” that can be used to look up any attribute.

Windows SSO Process (Kerberos Ticket Exchange)

Windows SSO is the ability for Cisco NAC Appliance to automatically authenticate users already authenticated to a backend Kerberos Domain Controller (Active Directory server). Figure 8-1 on page 8-3 shows the general process for Kerberos ticket exchange.

Note
AD SSO fails in Cisco NAC Appliance when the CAS and Cisco NAC Agent attempt to exchange Kerberos tickets with the AD domain that are larger than 16kB.
When the Clean Access Server is configured for AD SSO, it essentially replaces the “Network Services” component shown in Figure 8-1. The general sequence is as follows:

- Windows User and the CAS both have an account on the Active Directory server.
- User logs onto Windows AD (or uses cached credentials).
- Credentials are sent to the AD. The AD authenticates and gives a Ticket Granting Ticket (TGT) to the user.
  - The NAC Agent on the client machine asks the Windows user for a Kerberos Service Ticket (ST) from AD, so that the NAC Agent can communicate with the CAS.
  - The client requests a Service Ticket from the AD.
  - The AD sends the new ST to the client and the client provides this ST to the NAC Agent.
  - The NAC Agent presents this ST to the CAS as part of the authentication process to establish communication with the CAS.
- The CAS sends back packets and mutually authenticates the client as part of the ADSSO process.
- The CAS uses this information to sign the client onto Cisco NAC Appliance and hence SSO authentication takes place.
- For additional user role mapping (for authentication and posture assessment), an LDAP lookup server with attribute mapping can be configured.

Starting from Cisco NAC Appliance Release 4.5(1), the default timeout setting that monitors responses from the CAS changed to 60 seconds, which could impact AD SSO behavior if the response takes longer to come back to the Cisco NAC Appliance system. (For example, if the complete AD SSO process takes 2 minutes, once the 60 second timeout has elapsed, the CAM times out assuming that no response is forthcoming from the CAS that is communicating with the AD domain and automatically moves to the next CAS. If you then examine the CAS following the full 2-minute AD SSO process, you see that the service is actually working.) To help ensure reliable AD SSO behavior, Cisco also recommends verifying that your network DNS servers are functioning and accessible along with your Active Directory servers.
CAS Communication with AD Server

Figure 8-2 illustrates the general setup for Clean Access Server communication with the AD server for Active Directory SSO.

The CAS reads user login traffic only to the AD servers under the root domain. As shown in Figure 8-2, the sales domain (sales-name-domain.cisco.com) and the engineering domain (cca-eng-name.domain.cisco.com) are configured under different Clean Access Servers. Taking the cca-eng domain as an example, the CAS user only needs to be created and configured on the cca-eng-test.cca-eng-domain.cisco.com AD server.

Users under cca-eng-domain.cisco.com can log into any AD server in the domain. In addition, the KTPass command (described in Configuring a CAS User on the AD Server for AD SSO, page 8-14) only needs to be executed on the cca-eng-test.cca-eng-domain.cisco.com server.
AD SSO Configuration Step Summary

Administrators should start with a good understanding of their network layout with respect to their AD servers prior to configuring Active Directory SSO.

Configuration Prerequisites

To configure Active Directory SSO, you will need to have the following:

- You must use Windows Server 2008 Enterprise SP1 (32-bit) with KTPass version 6.0.6001.18000, and client machines must be running Windows Vista or Windows 7 with Cisco NAC Agent version 4.7.1.15, 4.8.0.32, or 4.9.0.33 installed, to ensure you are able to maintain FIPS 140-2 compliance and support AD SSO.

- The number of AD servers (domain controllers) to be configured. Typically, the CAS will correspond to one AD server, but you can also associate the CAS with an entire AD domain.

- The Windows 2000 or Windows 2003 server installation CD for the AD server. This is needed to install support tools for the KTPass command. The KTPass command is required to be run only on the AD server (domain controller) to which the CAS is logging in.

- The appropriate version of `ktpass.exe` installed. (To determine the correct version of KTPass to support your Cisco NAC Appliance/AD SSO deployment, see Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later.)

- The IP address of each AD server (to configure Unauthenticated role traffic policies). You will need to allow traffic on the CAS for every AD server that is in charge of that domain. For example, if users can log into multiple AD servers in the domain, you should allow traffic to all the multiple AD servers for the Unauthenticated role.

  **Note** In OOB deployments, ICMP (ping) is used to find the “closest AD server” by the workstation, and must work to all AD servers referenced in sites and services for the Authentication VLAN(s), or all AD servers in the domain if sites and services has not been set up.

- If setting up a connection between the CAS and a single AD server, the FQDN of the Active Directory server that the CAS logs into (for CAS configuration).

- DNS server settings correctly configured on the CAS (under Device Management > CCA Servers > Manage [CAS_IP] > Network > DNS) to resolve the FQDN for the AD server on the CAS.

- The date and time of the CAM, CAS, and AD server synchronized within 5 minutes of each other. The time on the AD server and the CAS must be synchronized to not more than 300 seconds clock skew (Kerberos is sensitive to time).

- The Active Directory Domain Name in Kerberos format (Windows 2000 and above). This is needed for both CAS configuration and CLI configuration of the AD server.

  **Note** The host principal name in the KTPass command (i.e. “<AD_DomainServer>”) must exactly match the case of the “Full computer name” of the AD server (under Control Panel > System > Computer Name | Full computer name.) See Run the ktpass.exe Command, page 8-22 for details.
Add Active Directory SSO Auth Server

To create an AD SSO auth server on the CAM, and map the AD server to a default role for users and a secondary LDAP lookup server (if configured), follow these steps:

**Step 1** Go to User Management > Auth Servers > New.

**Step 2** From the Authentication Type dropdown menu, choose Active Directory SSO.


Configure Traffic Policies for Unauthenticated Role

A user in the domain logging into his/her Windows machine sends credentials to the root domain controller to perform the first portion of Kerberos ticket exchange (as shown in Figure 8-1). Once the machine receives a Service Ticket, the Agent uses it to validate the client authentication through the CAS. Only when the CAS validates the authentication is the user allowed network access, and there is no need for a separate user login through the Agent.
Configure Traffic Policies for Unauthenticated Role

As Figure 8-2 illustrates, the CAS is configured to read the login credentials of user machines as they authenticate to the Active Directory (AD) server. Ports must be opened on the CAS to allow the authentication traffic to pass through the CAS to/from the AD server. The administrator can open either TCP or UDP ports, depending on what the AD server uses.

**Note**

If AD SSO traffic may include fragmented packets, you might need to enable the IP FRAGMENT option according to the guidelines in the Add IP-Based Policy section of the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.

Configure traffic policies for the Unauthenticated role to allow these ports on the trusted-side IP address of the AD server. This allows the client to authenticate to the AD server and for GPO and scripts to run. Cisco recommends that you install Cisco Security Agent (CSA) on the AD server/DMZ AD server.

TCP/UDP Ports Supporting AD SSO Implementation

The following list is an initial comprehensive list of ports to open when implementing AD SSO in your Cisco NAC Appliance network. You may be required to open other ports to support AD services not included in this list.

**Table 8-1 Recommended Ports to Support AD SSO**

<table>
<thead>
<tr>
<th>Action</th>
<th>Protocol</th>
<th>Untrusted</th>
<th>Trusted</th>
<th>Purpose/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Recommended TCP Ports</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 88</td>
<td>Kerberos</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 135</td>
<td>EpMap</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 139</td>
<td>Netbios-ssn</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 389</td>
<td>LDAP</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 445</td>
<td>MS-DC/SMB</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 636</td>
<td>LDAP with SSL</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 1025</td>
<td>MS-AD</td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
<td><em>:</em></td>
<td>IP address DC Port 1026</td>
<td>MS-AD</td>
</tr>
<tr>
<td><strong>Recommended UDP Ports</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allow</td>
<td>UDP</td>
<td><em>:</em></td>
<td>IP address DC Port 88</td>
<td>Kerberos</td>
</tr>
<tr>
<td>Allow</td>
<td>UDP</td>
<td><em>:</em></td>
<td>IP address DC Port 123</td>
<td>NTP</td>
</tr>
<tr>
<td>Allow</td>
<td>UDP</td>
<td><em>:</em></td>
<td>IP address DC Port 137</td>
<td>Netbios-ns</td>
</tr>
</tbody>
</table>
Configure Traffic Policies for Unauthenticated Role

Chapter 8      Configuring Active Directory Single Sign-On (AD SSO)

Note
Typically, the LDAP protocol uses plain text when sending traffic on TCP/UDP port 389. If encryption is required for LDAP communications, use TCP/UDP port 636 (LDAP with SSL encryption) instead.

When using LDAP to connect to the AD server, Cisco recommends using TCP/UDP port 3268 (the default Microsoft Global Catalog port) instead of the default port 389. This allows for a more efficient search of all directory partitions in both single and multi domain environments.

<table>
<thead>
<tr>
<th>Table 8-1</th>
<th>Recommended Ports to Support AD SSO</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>Protocol</td>
</tr>
<tr>
<td>Recommended TCP Ports</td>
<td></td>
</tr>
<tr>
<td>Allow</td>
<td>TCP</td>
</tr>
<tr>
<td>Allow</td>
<td>UDP</td>
</tr>
<tr>
<td>Allow</td>
<td>UDP</td>
</tr>
<tr>
<td>Other Ports</td>
<td></td>
</tr>
<tr>
<td>Allow</td>
<td>ICMP request</td>
</tr>
<tr>
<td>Allow</td>
<td>IP fragments</td>
</tr>
</tbody>
</table>

1. When using LDAP to connect to the AD server, Cisco recommends using TCP/UDP port 3268 (the default Microsoft Global Catalog port) instead of the default port 389. This allows for a more efficient search of all directory partitions in both single and multi domain environments.

Add Policy for AD Server

To Add Policies for AD Server, follow these steps:

Step 1
Go to User Management > User Roles > List of Roles > Policies [Unauthenticated Role]. This brings up the IP traffic policy form for the Unauthenticated Role.

Step 2
With the direction dropdown set for Untrusted -> Trusted, click the Add Policy link. The Add Policy form appears (Figure 8-4).

Typically, the LDAP protocol uses plain text when sending traffic on TCP/UDP port 389. If encryption is required for LDAP communications, use TCP/UDP port 636 (LDAP with SSL encryption) instead.

When using LDAP to connect to the AD server, Cisco recommends using TCP/UDP port 3268 (the default Microsoft Global Catalog port) instead of the default port 389. This allows for a more efficient search of all directory partitions in both single and multi domain environments.
Configure Traffic Policies for Unauthenticated Role

Step 3  Leave the following fields at their defaults:
- **Action**: Allow
- **State**: Enabled
- **Category**: IP
- **Protocol**: TCP 6
- **Untrusted (IP/Mask:Port)**: * / * / *

Step 4  For **Trusted (IP/Mask:Port)**, enter:
- The IP address of the Active Directory server
- 255.255.255.255 as the subnet mask (for just the AD server)
- Ports (using commas to separate port numbers)

For example: 10.201.152.12 / 255.255.255.255 / 88,135,1025,1026

**Note** When using LDAP to connect to the AD server, Cisco recommends using TCP/UDP port 3268 (the default Microsoft Global Catalog port) instead of the default port 389. This allows for a more efficient search of all directory partitions in both single and multi domain environments.

Step 5  Type an optional **Description**.

Step 6  Click **Add Policy**.
Configure AD SSO on the CAS

To configure the CAS corresponding to the domain of the users, follow these steps:

**Step 1**
Go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > Active Directory SSO.

**Figure 8-5  Active Directory SSO**

- **Step 2**
Do not click the checkbox for Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos) yet. The service should only be enabled after you Configuring a CAS User on the AD Server for AD SSO, page 8-14. You can configure the other fields of this page and click Update, as described below.

**Note**
Until you perform the configuration on the AD server, the following message will appear:
Error: Could not start the SSO service. Please check the configuration.

**Step 3**
For Account for CAS on, specify whether the CAS account resides on a Single Active Directory Server or multiple servers within a Domain (All Active Directory Servers).
Configure AD SSO on the CAS

**Note**

Make sure the CAS can resolve the name you type in the Active Directory Server (FQDN) field via DNS. A DNS server must be correctly configured on the CAS (under Device Management > CCA Servers > Manage [CAS_IP] > Network > DNS) so that the CAS can resolve the FQDN for the AD server.

a. If you specify that the CAS account resides on a Single Active Directory Server, enter the fully qualified domain name of the AD server in the Active Directory Server (FQDN) field (for example, cca-eng-test.cca-eng-domain.cisco.com). This field cannot be an IP address, and must exactly match CASE-BY-CASE the name of the AD server it appears under Control Panel > System > Computer Name | Full computer name on the AD server (see Figure 8-7).

*Figure 8-6  AD SSO—Single Active Directory Server*
b. If you select the Domain (All Active Directory Servers) option, the Active Directory Server (FQDN) field disappears (Figure 8-8). DNS automatically resolves the Active Directory domain specified to the primary domain controller (DC) and, if the primary DC becomes inaccessible, the secondary DC. In this case, you specify only the domain and not the full FQDN of the AD server. Note also that the KTPass command syntax also changes based on whether you specify the Single Active Directory Server or Domain (All Active Directory Servers) option. For details, see Run the ktpass.exe Command, page 8-22.

Figure 8-8 AD SSO—Domain (All Active Directory Servers)

Step 4 For Active Directory Domain, type the name of the domain for the KDC/Active Directory server in UPPER CASE (see Figure 8-7). The “Active Directory Domain” is equivalent to “Kerberos Realm”. For example:

CCA-ENG-DOMAIN.CISCO.COM
Configuring a CAS User on the AD Server for AD SSO

You can choose to set up AD SSO with or without running KTPass. In either case you must create the CAS user and then set up encryption according to the following sections:

- Create the CAS User, page 8-14
- Specify encryption using one of the following:
  - Install and Run KTPass, page 8-18
  - Configure AD SSO Without KTPass, page 8-26

Create the CAS User

To create a CAS user, follow these steps:

**Step 1** Login as the administrator on the Active Directory server machine.

**Step 2** Open the Active Directory Management console from All Programs > Admin Tools > Active Directory Users and Computers.

**Step 3** From the left-hand pane of the Active Directory Users and Computers window, navigate to the domain for which you want to configure the CAS, for example, cca-eng-domain.cisco.com.
Configuring a CAS User on the AD Server for AD SSO

Step 4  Right-click the Users folder. In the menu that appears, select New > User (Figure 8-9).

Step 5  In the first New Object - User dialog (Figure 8-10), configure the fields for the Clean Access Server user as follows:

Enter the name you want the CAS to use in the First name field, for example: casuser. This automatically populates the Full name and User logon name fields. The User logon name must be one word. Make sure First name= Full name = User name for the user account.
Step 6  Click Next to bring up the second New Object - User dialog.

Step 7  In the second New Object - User dialog (Figure 8-11), configure the following:

- Type and retype the password for the CAS user in the Password and Confirm Password fields.
- Make sure the Password never expires option is CHECKED.
- Make sure the User must check password at next login option is UNCHECKED.
Step 8  Click Next to bring up the confirmation New Object - User dialog (Figure 8-12).

Figure 8-12  Confirm CAS User Properties

Step 9  Confirm the properties for the CAS user and click Finish to conclude, or click Back if you need to make corrections.
Step 10  The CAS user is successfully added to the AD domain (Figure 8-13).

Figure 8-13  CAS User is Added

Install and Run KTPass

This section addresses the following two topics:

- Install the Correct Version of ktpass.exe to Support Your AD SSO Deployment, page 8-18
- Run the ktpass.exe Command, page 8-22

Install the Correct Version of ktpass.exe to Support Your AD SSO Deployment

The `ktpass.exe` tool is available as part of the Windows 2000/2003/2008 Server support tools on the Microsoft support site: http://support.microsoft.com/. The KTPass executable is not installed by default in Windows Server 2000/2003. Therefore, if you are configuring in a Windows Server 2000/2003 environment, you must retrieve the executable from the Microsoft Support site prior to installation. To determine the correct version of `ktpass.exe` to support your Cisco NAC Appliance/AD SSO deployment, see Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later.
To ensure successful KTPass operation, obtain and install the correct version of `ktpass.exe` according to the AD SSO support table in *Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later.*

You *must* use Windows Server 2008 with KTPass version 6.0.6001.18000, and client machines must be running Windows Vista or Windows 7 with an appropriate version of the Cisco NAC Agent installed, to ensure you are able to maintain FIPS 140-2 compliance and support AD SSO.

Cisco has tested the following versions of Windows AD Server and KTPass for the purposes of enabling AD SSO for Windows 7 client authentication.

### Table 8-2  Windows AD Server and KTPass Version Compatibility for Windows 7 Clients

<table>
<thead>
<tr>
<th>Windows AD Server Version</th>
<th>KTPass Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 2008 Server SP2 ¹,²</td>
<td>6.0.6002.18005</td>
</tr>
<tr>
<td>Windows 2008 Server R2 ²</td>
<td>6.1.7600.16385</td>
</tr>
<tr>
<td>Windows 2008 Server Enterprise SP1³</td>
<td>6.0.6001.18000</td>
</tr>
<tr>
<td>Windows 2003 Server</td>
<td>5.2.3790.1830</td>
</tr>
</tbody>
</table>

1. Window Server 2008 SP2 servers need to perform a Windows Update before running KTPass. Make sure Windows Hotfix KB951191 is installed. Without this Windows Update, the AD SSO service in the CAS might not start. This applies to the KTPass version to be used for Windows 2008 SP2 – 6.0.6002.18005 and for Windows 2008 R2 enterprise it is 6.1.7600.16385.

2. If the AD system is based on an upgrade from Windows Server 2003, you must raise the domain functionality to Windows Server 2008 level for Cisco NAC appliance to perform SSO on Windows 7 clients. Without this you will not be able to automatically login to the Cisco NAC Appliance network.


To install the `ktpass.exe` tool, follow these steps:

**Step 1**  Open a web browser and navigate to [http://support.microsoft.com/](http://support.microsoft.com/).

**Step 2**  Locate the Windows Server 2000/2003/2008 Support Tools section(s) of the Microsoft web site.
Step 3  Click the Download button.

Step 4  Do one of the following:

- Click **Save** to save a copy of the Windows Server 2000/2003/2008 Support Tools Self-Extractor executable on your local machine.

- Click **Run** to begin installing the Windows Server 2000/2003/2008 Support Tools on your local machine.
When you launch the Self-Extractor or click **Run**, Windows automatically launches the **Windows Support Tools Setup Wizard**.

**Figure 8-15** Installing Windows Server 2003 Support Tools

![Windows Support Tools Setup Wizard](image)

**Step 5** Once the installation is complete, open Windows Explorer and navigate to the `C:\Program Files\Support Tools` directory (or another directory you may have specified in the Setup Wizard session), and verify that the **ktpass.exe** component appears in the file list. (See **Figure 8-16**.)

**Figure 8-16** Support Tools—ktpass.exe

![Support Tools—ktpass.exe](image)

**Step 6** Execute the **ktpass.exe** command according to the directions in the next section, **Run the ktpass.exe Command**.
Chapter 8 Configuring Active Directory Single Sign-On (AD SSO)

Configuring a CAS User on the AD Server for AD SSO

Note
Do not double-click the ktpass.exe command in Windows Explorer; it must be run from a command prompt.

Run the ktpass.exe Command

This section is designed to execute the KTPass executable for non-Windows 7 client machines to perform SSO. If you are setting up an environment for Windows 7 client machines, see Configure AD SSO in a Windows 7 Client Environment, page 8-34.

When a CAS is configured to interact with a single AD server, you also need to run the KTPass command on the AD server configured in the CAS.

If you are associating the CAS with an entire AD domain, you must run the KTPass command on any single AD server (not all AD servers) in the AD domain. The information in the KTPass command operation is then automatically propagated to the other members of the AD domain.

See Support Information for Cisco NAC Appliance Agents, Release 4.5 and Later for a list of the Windows server versions supported.

Note
When running ktpass.exe, it is very important to observe the following case sensitivity:

- The computer name that is entered between “/” and “@” in the command (e.g. “AD_DomainServer”) must exactly match CASE-BY-CASE the name of the AD server as it appears under Control Panel > System > Computer Name | Full computer name on the AD server.
- The realm name that is entered after “@” (e.g. “AD_DOMAIN”) must always be in UPPER CASE. You must convert the Domain name that appears under Control Panel > System > Computer Name | Domain on the AD server to UPPER CASE when entering it in the KTPass command. (See Figure 8-19.)
- No warnings should appear after you execute ktpass.exe.
- Execution of the command must display the following output:

    Account <CAS user> has been set for DES-only encryption

To run ktpass.exe on a non-Windows 7 client machine:

Step 1
Open a command prompt and cd to C:\Program Files\Support Tools\. The ktpass.exe command should be in the folder.

Step 2
Enter one of the following commands:

If your Active Directory domain consists of only one server

- ktpass -princ <CAS_username>/<AD_DomainServer>,<AD_Domain>@<AD_DOMAIN> -mapuser <CAS_username> -pass <CAS_password> -out c:\<CAS_username>.keytab -ptype KRBO5_NT_PRINCIPAL +DesOnly

Use this command syntax when you specify the Account for CAS on Single Active Directory Server option in Configure AD SSO on the CAS, page 8-11.

For example (see also Figure 8-17):
Chapter 8  Configuring Active Directory Single Sign-On (AD SSO)

Configuring a CAS User on the AD Server for AD SSO

Configuring a CAS User on the AD Server for AD SSO

C:\Program Files\Support Tools> ktpass -princ
   casuser/cca-eng-test.cca-eng-domain.cisco.com@CCA-ENG-DOMAIN.CISCO.COM -mapuser
casuser -pass Cisco123 -out c:\casuser.keytab -ptype KRB5_NT_PRINCIPAL +DesOnly

If your Active Directory domain consists of multiple servers

While adding new servers to an already existing multi-server domain, it is not required to run the ktpass command again. This includes adding a 2008 server to an existing multi-server domain running in a 2003 domain functional level.

- ktpass -princ <CAS_username>/<AD_Domain>@<AD_DOMAIN> -mapuser <CAS_username>
   -pass <CAS_password> -out c:<CAS_username>.keytab -ptype KRB5_NT_PRINCIPAL +DesOnly

Use this command syntax when you specify the Account for CAS on Domain (All Active Directory Servers) option in Configure AD SSO on the CAS, page 8-11.

For example (see also Figure 8-17):

C:\Program Files\Support Tools> ktpass -princ
casuser/cca-eng-domain.cisco.com@CCA-ENG-DOMAIN.CISCO.COM -mapuser casuser -pass Cisco123 -out c:\casuser.keytab -ptype KRB5_NT_PRINCIPAL +DesOnly

The output of the command should be as follows (see also Figure 8-18):

Targeting domain controller: cca-eng-test.cca-eng-domain.cisco.com
Successfully mapped casuser/cca-eng-test.cca-eng-domain.cisco.com to casuser.
Key created.
Output keytab to c:\casuser.keytab:
Keytab version: 0x502
keysize 97 casuser/cca-eng-test.cca-eng-domain.cisco.com@CCA-ENG-DOMAIN.CISCO.COM ptype 1
(KRB5_NT_PRINCIPAL) vno 3 etype 0x3 (DES-CBC-MD5) keylength 8 (0xbc5120bcfeda01f8)
Account casuser has been set for DES-only encryption.

Note

The “Successfully mapped casuser/cca-eng-test.cca-eng-domain.cisco.com to casuser” response confirms that the casuser account is mapped correctly.

In the example above, the service principal name (SPN),
casuser/cca-eng-domain.cisco.com@CCA-ENG-DOMAIN.CISCO.COM, is the key to ensuring that any AD server within a managed domain can appropriately resolve user credentials passed from the CAS.

Step 3  Save the exact command you ran and the output to a text file (you do not need to save the CAS user password). For troubleshooting purposes, this will facilitate TAC support.
Figure 8-17  Execute ktpass.exe Command

![Command Prompt](image1.png)

Figure 8-18  ktpass.exe Command Output

![Command Prompt](image2.png)

Table 8-3 provides further parameter details.
### Table 8-3  ktpass.exe Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| `-princ`  | Service principal name (SPN) identifier  
The entire SPN string, itself, is constructed as follows:  
`<CAS_username>/[(<AD_DomainServer>|<AD_Domain>)@<AD_DOMAIN>]` |
| `<CAS_username>` | UserName |
| `<AD_DomainServer>` | FQDN machine name for a single AD server. This parameter must exactly match (including the case) the name of the AD server under `Control Panel > System > Computer Name | Full computer name`. |
| `<AD_Domain>` | The name of the AD domain the CAS uses to authenticate user credentials. This parameter must exactly match (including the case) the domain of the AD server(s) under `Control Panel > System > Domain`. |
| `<AD_DOMAIN>` | Domain name (must be in UPPER CASE) |
| `-mapuser` | Maps the CAS user to the domain |
| `-pass` | CAS user password |
| `-out` | Outputs the “`c:\<CAS_user_name>.keytab`” key to generate a key tab (similar to a certificate) for this user |
| `c:\<CAS_user_name>.keytab` | Required parameter |
| `-ptype` | Principal type (required parameter) |
| `KRB5_NT_PRINCIPAL` | The Principal provided is of this type. By default AD servers should use this type, but some do not. |
| `+DesOnly` | Flag for DES encryption |
Example KTPass Command Execution

Figure 8-19 shows how parameters are derived from the CAS user account properties and AD server computer name to run the KTPass command. Note that the values in this figure are example values only; they do not match the configuration example steps outlined in this chapter.

![Figure 8-19 Example of How KTPass is Run—SAMPLE VALUES](image)

Configure AD SSO Without KTPass

The following procedure guides you through the process necessary to configure an AD SSO user account for both Windows Server 2003 and Windows Server 2008 Active Directory entities operating at their respective full functional levels without having to run KTPass. (This method does not support a Server 2008 AD operating at a 2003 domain functional level.)

Note AD SSO user accounts configured to connect with Server 2008 AD entities are not FIPS 140-2 compliant.

The following steps apply for DES only encryption type.

Step 1 Open the Properties dialog for an Active Directory account you created using Create the CAS User, page 8-14.

Step 2 To require DES encryption for the new CAS user account, click on the Account tab, enable (check) the Use DES encryption types for this account (Server 2003) or Use Kerberos DES encryption types for this account (Server 2008) option under Account options, and click OK. (See Figure 8-20 and Figure 8-21.)

Note To set up a Windows 7 client machine for DES encryption, refer to Manually Enable DES on Individual Windows 7 Client Machines.
**Figure 8-20**  Server 2003 Example—Account Properties

![Account Properties](image_url)
Step 3  Open a DOS prompt on the AD server and enter `ldp.exe` (Figure 8-22 background). An additional `Ldp` application window opens.

*Note*  If you do not have a local copy of the `ldp.exe` file, you can locate it under Support Tools in the Microsoft Windows Server Resource Kit.

Step 4  In the `Ldp` window, connect to the Active Directory domain controller using the **Connection > Connect** command and entering the domain controller’s IP address or domain name (Figure 8-22 and Figure 8-23). For example, in the **Connect** dialog, enter `10.201.150.11` or `child.2k8.com`. 
Step 5 After you are connected to the domain controller, use the **Connection > Bind** command to bind to the AD domain as an administrator (Figure 8-24 and Figure 8-25). (You can specify the same ID that you used to create the user account).
Step 6  Display a list of known domain suffixes using the **View > Tree** command and expanding the pull-down menu that appears (Figure 8-26).

Step 7  Choose **DC=cca,DC=cisco,DC=com** and click **OK**.
Step 8  Expand the DC=cca,DC=cisco,DC=com tree and double-click on CN=Users,DC=cca,DC=cisco,DC=com (Figure 8-27).

Step 9  Locate the user account you created in Step 1, right-click on the account entry, and click Modify (Figure 8-28). The account Modify dialog box opens.
Figure 8-28  Modify the User Account Entry

Step 10  Specify userPrincipalName in the Attribute field and enter a <username>/<FQDN>@<REALM> value. For example, enter ccasso_des_NoKT/dcroot.cca.cisco.com@CCA.CISCO.COM (Figure 8-29).

Note  If there are multiple servers in the Active Directory domain, the value must be <username>/<AD_domain>@<AD_DOMAIN> (e.g., casuser_des_NoKT/qa-test1.cca.cisco.com@QA-TEST1.CCA.CISCO.COM).

Step 11  Complete the change by choosing the Replace operation and clicking Enter.
Step 12 Specify `servicePrincipalName` in the attribute field and enter `<username>/<FQDN>`. For example, enter `ccasso_des_NoKT/dcroot.cca.cisco.com` value (Figure 8-30).

Step 13 Complete the addition by choosing the **Add** operation and clicking **Enter**.
Configure AD SSO in a Windows 7 Client Environment

Administrators who configured AD SSO prior to Release 4.7(1) can provide only limited support for Windows 7 clients after upgrade. An unmodified Windows 7 client machine with the Cisco NAC Agent installed still prompts the user with a manual login dialog because Microsoft has disabled DES encryption on Windows 7 client machines by default.

To enable Windows 7 client machines to authenticate via AD SSO in your Cisco NAC Appliance network, you can do one of the following:

Option 1 (Recommended)
Allow AD SSO for Windows 7 by enabling additional algorithms on the Microsoft Active Directory servers (see Enable Additional Algorithms on Existing AD Servers).

Step 14 Verify that there are two lines representing your changes in the Entry List display and click Run.
Step 15 Once complete, the bottom of the Ldp application window should display “Modified <userDN>” without errors.
Modified
"CN=ccasso_des_NoKT,CN=Users,DC=cca,DC-cisco,DC=com".
Step 16 To confirm, double-click on the user account name on the left side of the application window and verify that your changes are present in the user account entry.

Configure AD SSO in a Windows 7 Client Environment

Administrators who configured AD SSO prior to Release 4.7(1) can provide only limited support for Windows 7 clients after upgrade. An unmodified Windows 7 client machine with the Cisco NAC Agent installed still prompts the user with a manual login dialog because Microsoft has disabled DES encryption on Windows 7 client machines by default.

To enable Windows 7 client machines to authenticate via AD SSO in your Cisco NAC Appliance network, you can do one of the following:

Option 1 (Recommended)
Allow AD SSO for Windows 7 by enabling additional algorithms on the Microsoft Active Directory servers (see Enable Additional Algorithms on Existing AD Servers).
Enable Additional Algorithms on Existing AD Servers

**Step 1** Create a new AD SSO service account according to the guidelines in Add Active Directory SSO Auth Server, page 8-6. Cisco recommends that the current AD SSO account remain unchanged to allow you to quickly switch between the original DES encryption system and the this multi-algorithm option.

**Step 2** Run KTPass to allow multiple algorithms for this new service account (see Table 8-2).

- For Windows 2003 Server at full functional level:
  
  ```
  ktpass -princ newadsso/[adserver.]domain.com@DOMAIN.COM -mapuser newadsso -pass PasswordText -out c:\newadsso.keytab -ptype KRB5_NT_PRINCIPAL
  ```

- For Windows 2008 Server at full functional level:
  
  ```
  ktpass -princ newadsso/[adserver.]domain.com@DOMAIN.COM -mapuser newadsso -pass PasswordText -out c:\newadsso.keytab -ptype KRB5_NT_PRINCIPAL -crypto All
  ```

- For Windows 2008 Server at 2003 Server functional level:
  
  ```
  ktpass -princ newadsso/[adserver.]domain.com@DOMAIN.COM -mapuser newadsso -pass PasswordText -out c:\newadsso.keytab -ptype KRB5_NT_PRINCIPAL
  ```

- For Windows 2012 Server at 2003 Server functional level:
  
  ```
  ktpass -princ newadsso/[adserver.]domain.com@DOMAIN.COM -mapuser newadsso -pass PasswordText -out c:\newadsso.keytab -ptype KRB5_NT_PRINCIPAL -crypto All
  ```

See Also CSCuh81091 in Release Notes for Cisco NAC Appliance, Version 4.9(3).

In addition to the above, for Windows 2012 and 2008 Servers at 2003 Server functional level, perform the following steps:

**Note**

The following procedure is not required for Windows 2012 Server at 2003 functional level, if you are using Cisco NAC Appliance, Release 4.9(2).

**For CAM**

**Note** Before performing the following step, Cisco strongly recommends making a backup copy of the CAM’s `/perfigo/control/tomcat/conf/krb.txt` file.

After running the `ktpass` command above, manually modify two files on the CAM as follows:

- In the CAM CLI, navigate to `/perfigo/control/tomcat/conf/krb.txt` and add the following lines:

  ```
  [libdefaults]
  kdc_timeout = 20000
  default_tkt_enctypes = RC4-HMAC
  default_tgs_enctypes = RC4-HMAC
  permitted_enctypes = RC4-HMAC
  ```
Chapter 8      Configuring Active Directory Single Sign-On (AD SSO)

- Navigate to /perfigo/control/bin/starttomcat.

Search for CATALINA_OPTS.
Add -DKRB_OVERRIDE=true to the value of CATALINA_OPTS.
For example:

Old value: CATALINA_OPTS="-server ...
New Value: CATALINA_OPTS="-server ... -DKRB_OVERRIDE=true"

Note If you are applying this change to an existing HA pair, you must perform the above update on both the HA-Primary and HA-Secondary CAM just as you would upgrade a pair of HA-enabled CAMs. For more information, see the corresponding Release Notes for Cisco NAC Appliance.

 Restart the CAM by entering the service perfigo stop and service perfigo start commands.

For CAS

Note Before performing the following step, Cisco strongly recommends making a backup copy of the CAS’s /perfigo/access/tomcat/conf/krb.txt file.

After running the ktpass command above, manually modify two files on the CAS as follows:
- In the CAS CLI, navigate to /perfigo/access/tomcat/conf/krb.txt and add the following lines:

\[\text{libdefaults}\]
\text{kdc_timeout = 20000}
\text{default_tkt_enctypes = RC4-HMAC}
\text{default_tgs_enctypes = RC4-HMAC}
\text{permitted_enctypes = RC4-HMAC}

- Navigate to /perfigo/access/bin/starttomcat.

Search for CATALINA_OPTS.
Add -DKRB_OVERRIDE=true to the value of CATALINA_OPTS.
For example:

Old value: CATALINA_OPTS="-server ...
New Value: CATALINA_OPTS="-server ... -DKRB_OVERRIDE=true"

Note If you are applying this change to an existing HA pair, you must perform the above update on both the HA-Primary and HA-Secondary CAS just as you would upgrade a pair of HA-enabled CASs. For more information, see the corresponding Release Notes for Cisco NAC Appliance.

- Restart the CAS by entering the service perfigo stop and service perfigo start commands.

Step 3 Change the AD SSO service account on the CAM to the new service account according to the guidelines in Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos), page 8-40.

a. Log in to the CAM web console and go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > Active Directory SSO.

b. Modify the AD SSO account name and password.

c. Click the checkbox for Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos).
Configure Active Directory for FIPS 140-2 Compliant AD SSO

This section describes how to configure your Windows Server 2008 environment to communicate with a FIPS 140-2 compliant Cisco NAC Appliance deployment. This section covers the following topics:

- **Prerequisites**
- **Configuring Your Windows Environment for FIPS 140-2 Compliance**

**Prerequisites**

- You **must** use Windows Server 2008 with KTPass version 6.0.6001.18000, and client machines must be running Windows Vista or Windows 7 with Cisco NAC Agent version 4.7.1.15, 4.8.0.32, or 4.9.0.33 installed, to ensure you are able to maintain FIPS 140-2 compliance and support AD SSO. (It is assumed that the user has already configured an Active Directory domain on this system.)

- The Clean Access Manager and Clean Access Server should be configured in FIPS mode and must be running Cisco NAC Appliance Release 4.7(0) or later.

**Configuring Your Windows Environment for FIPS 140-2 Compliance**

To set up your Windows environment for FIPS 140-2 compliant AD SSO with the Cisco NAC Appliance system:

**Step 1** If the AD system is based on an upgrade from Windows Server 2003, you must raise the domain functionality to Windows Server 2008 level for Cisco NAC appliance to operate in FIPS mode, as shown in Figure 8-31. Without this you will not be able connect to the Cisco NAC Appliance network.
Configure Active Directory for FIPS 140-2 Compliant AD SSO

Configure the User Profile

Step 2 Create the user in Windows. The example in this procedure uses the name “fipsy.”

Step 3 Ensure you click the **Password never expires** option and leave the other user options unchecked (especially, ensure that you *do not* require the password to be changed on first login).
Step 4  Open the user Properties and update the username to include the domain, as shown in Figure 8-34.

Figure 8-34  User Properties

Step 5  Specify Account Options as shown in Figure 8-35.
Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos)

After the AD server configuration is completed, perform the final step. To enable the Agent-Based Windows single sign-on with Active Directory (AD), follow these steps:

**Step 1**  
Go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > Active Directory SSO.

**Figure 8-36  Active Directory SSO**

Go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > Active Directory SSO.

- **Status**
- **Network**
- **Filter**
- **Advanced**
- **Authentication**
- **Misc**

**Device Management > Clean Access Servers > 10.201.241.32**

- Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos)
- Account for CAS on
- Active Directory Server (FQDN)
- Active Directory Domain
- Account Name for CAS
- Account Password for CAS
- Active Directory SSO Auth Server

Update

**Step 2**  
Click the checkbox for Enable Agent-Based Windows Single Sign-On with Active Directory (Kerberos).

**Step 3**  
Click Update.
Confirm Active AD SSO Service

Once you have performed all the configuration outlined in AD SSO Configuration Step Summary, page 8-5, make sure the AD SSO service starts on the Clean Access Server.

Go to Device Management > CCA Servers > Manage [CAS_IP] > Status (see Figure 8-37).

Figure 8-37  AD SSO Service Is Started

Make sure Active Directory SSO is listed with a Status of Started.

Note
You can also confirm that the CAS trusted interface (eth0) is listening on TCP port 8910 (used for Windows SSO) via SSH command: netstat -a | grep 8910.

Enable GPO Updates

When a user is not yet authenticated/certified by Cisco NAC Appliance (or is on the Authentication VLAN), access to the Windows Domain Controller is limited; and as a result, a complete group policy update might not finish. In addition, the next refresh for group policies occurs every 90 minutes by default. In order to accomplish a GPO update, administrators can force a group policy refresh for Agent users immediately after AD SSO login by enabling the Refresh Windows domain group policy after login option.

Administrators can configure the Agent to retrigger a Group Policy Object (GPO) update after the AD SSO user login finishes. If configured in the CAM web console, the Agent calls the “gpupdate” command to re-trigger the Group Policy update after users are logged in.

Login scripts are controlled by the Domain Controller and require a login event to run. For more information about how to use login script in a Windows environment, see Enabling a Login Script (Optional), page 8-43.
Enable GPO Updates

Note
Because Microsoft Group Policies are only available since the advent of Active Directory (Windows 2000 and later), the GPO trigger update feature is only available on Windows 7/Vista/XP machines.

To enable GPO update, follow these steps:

Step 1  Go to Device Management > Clean Access > General Setup > Agent Login.

Figure 8-38  Agent Login—General Setup

Step 2  From the User Role dropdown, choose the role to which to apply the GPO update.

Step 3  From the Operating System dropdown, choose the OS to which to apply the GPO update (must be Windows XP or later).

Step 4  Click the checkbox for Refresh Windows domain group policy after login (for Windows).

Step 5  Click Update.
Enabling a Login Script (Optional)

Caution
This step is optional and this section provides reference information for convenience only. Cisco Technical Assistance Center (TAC) does not support questions or troubleshooting for Microsoft login scripts. Refer to http://support.microsoft.com for additional support.

GPO update objects, such as login scripts, require an event to trigger them, such as login, or they fail. Running a script in a Windows environment prior to login fails because users do not have access to drive mappings to the AD server or drive resources.

Network-based login scripts and local login scripts are handled differently:
- Local login scripts run locally on a client machine. If you introduce an artificial delay with a script, they work correctly.
- Network-based scripts require continuous access to a AD server for initialization. Depending on your network deployment, you can use a combination of steps to use them. Network-based scripts typically reside on the AD server in the %Sysvol%\scripts folder.

Table 8-4 lists the options for handling network-based scripts.

Table 8-4   Network-Based Login Script Options

<table>
<thead>
<tr>
<th>Deployment</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Band</td>
<td>Open access to the AD server port in the Temporary or Unauthenticated user role and introduce a delay in the body of the script.</td>
</tr>
<tr>
<td>Out-of-Band without IP change</td>
<td>Open access to the AD server port in the Temporary or Unauthenticated user role and introduce a delay in the body of the script.</td>
</tr>
<tr>
<td>Out-of-Band with IP change</td>
<td>Use a combination of scripts to copy a script that introduces delay locally, run it, and then delete it.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> A security concern exists while the script resides on the client machine because it can be viewed or copied.</td>
</tr>
</tbody>
</table>

In any type of deployment, you need to create an artificial delay script to run during authentication in order for local or network-based scripts to work correctly. See Introducing a Delay to Allow Script Use, page 8-44.

For network-based script use in Out-of-Band deployments with IP address changes, you must also:
- Append the delete command to the end of the “delay” script.
- Use a reference script that copies the “delay” script to the client machine and then launches it.

For more information, see Using Network-Based Scripts in Out-of-Band Mode with IP Address Changes, page 8-45.
Introducing a Delay to Allow Script Use

You can introduce delay by calling a persistent check action that fails until authentication finishes. For example, you can use ping, Telnet, nslookup, or another action that requires network connectivity to succeed. The following example is a .bat script, but you can use other types of scripts.

When using ping, remember:
- You can ping any IP address that is reachable after successful Cisco NAC Appliance login.
- The IP address used for the ping and the AD server do not have to be the same.

![Caution]

If you ping a protected device that has a real IP address, the user will be able to see the IP address while the delay script runs. You can add a statement to the script to hide the DOS window.

- You only need one IP address.
- All of your mappings can be assigned after the ping succeeds.

Example

```batch
@echo off
echo Please wait...
ping -n 1 -t 1 192.168.88.128
if errorlevel 1 goto CHECK
@echo on
netuse L:\\192.168.88.128\Scripttest
```

In the example, ping runs in the background until it succeeds. After succeeding, the loop is broken; the system maps to drive L:\ on the same node, where the network-based script resides, and then that script runs. The user sees a DOS window in the background.

![Note]

You can enhance the script with statements to hide or minimize the DOS window from the user.

### Table 8-5 lists the script statements and meanings.

<table>
<thead>
<tr>
<th>Statement</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>:CHECK</code></td>
<td>Begin the script.</td>
</tr>
<tr>
<td><code>@echo off</code></td>
<td>Only display the command output.</td>
</tr>
<tr>
<td><code>echo Please wait...</code></td>
<td>Show the words “Please wait...” to the end user.</td>
</tr>
<tr>
<td><code>ping -n 1 -t 1 192.168.88.128</code></td>
<td>Use the ping utility to check if the IP address 192.168.88.128 is reachable:</td>
</tr>
<tr>
<td></td>
<td>- <code>n</code>—do not look up a hostname.</td>
</tr>
<tr>
<td></td>
<td>- <code>t</code>—send one packet.</td>
</tr>
<tr>
<td></td>
<td>- <code>l</code>—use the ODBC driver or library.</td>
</tr>
<tr>
<td></td>
<td>- <code>1</code>—wait one second.</td>
</tr>
<tr>
<td><code>if errorlevel 1 goto CHECK</code></td>
<td>If the ping utility did not reach 192.168.88.128 successfully, then start again from :CHECK.</td>
</tr>
</tbody>
</table>
Using Network-Based Scripts in Out-of-Band Mode with IP Address Changes

In Out-of-Band mode with an IP address change, you need to create and run two scripts before calling the targeted network-based script:

- A reference script to copy over and launch the local copy of the script.
- A delay script with a line added to delete the network script after it runs.

Caution

Copying a network script to a user machine that has not been granted network access is a security concern. While the script resides on the user machine, the user can copy or view the script.

Reference Script

Create a script similar to the following example. The script is named “refer.bat”, and it copies over a delay script named “actual.bat” and then launches it.

```bash
@echo off
echo Please wait...
copy \192.168.88.228\notlogon\actual.bat actual.bat
actual.bat
```

Table 8-6 lists the script statements and the meaning of each line.

<table>
<thead>
<tr>
<th>Statement</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>@echo off</td>
<td>Only display the command output.</td>
</tr>
<tr>
<td>echo Please wait...</td>
<td>Show the words “Please wait...” to the end user.</td>
</tr>
<tr>
<td>copy \192.168.88.228\notlogon\actual.bat actual.bat</td>
<td>Copy the script “actual.bat” from the “notlogon” folder on the AD server at IP address 192.168.88.228.</td>
</tr>
<tr>
<td>actual.bat</td>
<td>Launch the script named “actual.bat”.</td>
</tr>
</tbody>
</table>

Delay Script with Delete Command

To create a script that delays script initialization, refer to the “Introducing a Delay to Allow Script Use” section on page 8-44. As shown in the following example add the `del` command and the name of the script that you want to delete to the end of the delay script. The script is named “actual.bat”.

```bash
@echo on
Display debug messages.
netuse L:\192.168.88.128\Scripttest
Map the file share at 192.168.88.128 to the L: drive.
```
Add LDAP Lookup Server for Active Directory SSO (Optional)

Caution
We recommend that you reduce network vulnerability by deleting the local copy of the script residing on the end user machine. The last line of the sample script performs the deletion or clean up function.

Example
```
:CHECK
@echo off
echo Please wait...
ping -n 1 -l 1 192.168.88.128
if errorlevel 1 goto CHECK
@echo on
netuse L:\192.168/88/128/Scripttest
del actual.bat
```

Add LDAP Lookup Server for Active Directory SSO (Optional)

Note
The LDAP Lookup server is only needed if you want to configure mapping rules so that users are placed into user roles based on AD attributes after AD SSO authentication. For basic AD SSO without role mapping, or for testing purposes, it is not necessary to configure an LDAP Lookup Server.

If you plan on mapping Windows domain SSO users to multiple user roles, you will need to configure a secondary LDAP Lookup server so that the CAM can perform the mapping. You then specify this LDAP Lookup server for the Active Directory SSO auth provider, as described in Add Active Directory SSO Auth Server, page 8-6. You can configure your LDAP Lookup server to use one of the following two authentication mechanisms:

- **SIMPLE**—The CAM and LDAP server pass user ID and password information between themselves without encrypting the data.
- **GSSAPI**—(Generic Security Services Application Programming Interface) Provides an option to encrypt user ID and password information passed between the CAM and the specified LDAP server to help ensure privacy.

Note
To ensure complete DNS capability when using GSSAPI, you must ensure that all Domain Controllers, child domains, and hosts conform to strict DNS naming conventions and that you have the ability to perform both forward- and reverse-DNS.

In Cisco NAC Appliance, you can configure one LDAP auth provider using the GSSAPI authentication method and one Kerberos auth provider, but only one of the two can be active at any time. See the “Kerberos” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for more information.
Configure an LDAP Lookup Server

**Step 1**
Go to User Management > Auth Servers > Lookup Servers. The Server Type is automatically set to LDAP Lookup.

The configuration page for the LDAP Lookup Server features the same fields as the LDAP Authentication Provider configuration page. For complete details on configuring SIMPLE and GSSAPI authentication methods, refer to the “LDAP” configuration section in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Cross-Forest Group Mapping using LDAP Lookup

**Step 1**
Set up a bidirectional trust between two AD forests.

**Step 2**
Create an LDAP Lookup Server with GSSAPI in the CAM Web Console.

**Step 3**
In the Base/Realm Mapping field, specify the base context and realm mapping of the AD forest. For example, if the realm of the first AD forest is CCA.CISCO.COM and other AD forest is NAC.PERFIGO.COM respectively, the base/realm mapping will be as follows:

dc=cca,dc=cisco,dc=com/CCA.CISCO.COM

dc=nac,dc=perfigo,dc=com/NAC.PERFIGO.COM

**Step 4**
Create an ADSSO server with the LDAP Lookup server.

**Note**
Reverse DNS lookups should be enabled for the Domain Controllers.
You can use the Auth Test function to test AD SSO authentication in Cisco NAC Appliance. For details, see the “Auth Test” section of the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

In the Auth Test tab, the realm name must be entered in addition to the username. For example, if the username is nacuser and the realm is NAC.PERFIGO.COM, then you must enter nacuser@NAC.PERFIGO.COM.

You can test with users available in either or both the AD forests.

**Troubleshooting**

**General**

- If the following error occurs, the issue is most likely with reverse DNS lookup. Reverse DNS lookups must be enabled for the Domain Controllers.

  **No valid credentials provided (Mechanism level: Server not found in Kerberos database (7)).**

- Make sure the date and time of the CAM, CAS, and AD server are all synchronized within 5 minutes of each other or AD SSO will not work. You will have to delete the account on AD, synchronize the times and recreate the account. If the AD server still keeps a record of the old account even though you have deleted it, you may need to create a new account with a different name.

- When setting up the CAS account on the AD server, make sure that the CAS account does not require Kerberos pre-authentication.

- In OOB deployments, ICMP (ping) is used to find the “closest AD server” by the workstation, and must work to all AD servers referenced in sites and services for the Authentication VLAN(s), or all AD servers in the domain if sites and services has not been set up.

- In a NAT environment, ensure that the CAM is configured with the NAT entry, for the AD SSO to work properly.

**Note**  
Perform a service perfigo restart on the CAS to make sure it is not using old cached credentials.

**KTPass Command**

- Make sure the AD domain name (for multiple servers) or single AD server name you enter between “/” and “@” in the KTPass command (e.g. “AD_DomainServer”) exactly matches case-by-case the domain or single AD server name as it appears under Control Panel > System > Computer Name | Full computer name. See Run the ktpass.exe Command, page 8-22 for details.

- Make sure you enter the realm name after “@” (e.g. “AD_DOMAIN”) in the KTPass command in all upper case characters. You must convert the Domain name that appears under Control Panel > System > Computer Name | Domain on the AD server to UPPER CASE when entering it in the KTPass command.
Cannot Start AD SSO Service on CAS

If the AD SSO service cannot start on the CAS, this typically indicates a communication issue between the AD server and the CAS.

- If the Active Directory server is not reachable from the CAS at the time of CAS startup, AD SSO service is not started. As a workaround, the administrator must go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > Active Directory SSO and click the Update button to restart the AD SSO service.

- Check that the KTPass command is run correctly. Verify the fields are correct as described in Run the ktpass.exe Command, page 8-22. If KTPass was run incorrectly, delete the account, create a new account on the AD server, and run KTPass again.

- Make sure the time on the CAS is synchronized with the AD server. This can be done by pointing them both to the same time server (or, in lab setups by just pointing the CAS to the AD server itself for time (AD server runs Windows time)). Kerberos is sensitive to clock timing and the clock skew cannot be greater than 5 minutes (300 seconds).

- Make sure the Active Directory Domain is in UPPERCASE (Realm) and that the CAS can resolve the FQDN in DNS. (For lab setups you can point to a AD server that runs DNS, as AD requires at least one DNS server).

- Make sure the following are correct: CAS username on the AD server, Active Directory Domain (Kerberos Realm) on the CAS (uppercase), Active Directory Server (FQDN) on the CAS.

- When creating a TAC support case, login to CAS directly at https://<CAS_IP-address>/admin, click on Support Logs and change the logging level for Active Directory communication logging to “INFO”. Recreate the problem and download support logs. Make sure to restart the CAS or change the log level back to the default after the support logs are downloaded. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for further details.

AD SSO Service Starts, But Client Not Performing SSO

If AD SSO service is started on the CAS, but the client machine is not performing Windows Single Sign-On, this typically indicates a communication issue between the AD server and client PC or between the client PC and the CAS. Check that:

- The client does have Kerberos keys.

- Ports are open in the Unauthenticated role to the AD server so that the client can connect.

  **Note** When you test, Cisco recommends first opening complete access to the AD server/DC, then restricting ports once AD SSO is working. When logging into the client PC, make sure to log into the domain using Windows domain credentials (not Local Account).

- The client PC time/clock is synchronized with the AD server.

- The CAS trusted interface (eth0) is listening on TCP port 8910. A sniffer trace on the client PC can help.

- The user is logged in using the Windows domain account and not the local account.

  **Note** The CAS and Agent do not support using multiple NICs on the client machine. The client machine Wireless NIC must be turned OFF when the Wired NIC is turned ON.
Kerbtray

Kerbtray is a free tool available from Microsoft Support Tools that can be used to confirm that the client has obtained the Kerberos Tickets (TGT and ST), and can also be used to purge Kerberos Tickets on a client machine. The ST (Service Ticket) is of concern for the CAS user account that is created on the AD Server. A green Kerbtray icon on the system tray indicates that the client has active Kerberos tickets. However the ticket needs to be verified as correct (valid) for the CAS user account.

Note

AD SSO fails in Cisco NAC Appliance when the CAS and Cisco NAC Agent attempt to exchange Kerberos tickets with the AD domain that are larger than 16kB.

CAS Log Files

The log file of interest on the CAS is `/perfigo/access/tomcat/logs/nac_server.log`.

If AD SSO Service does not start on CAS, this indicates a CAS-AD server communication issue:

- Clock is not synchronized between CAS and the Domain Controller:
  
  SEVERE: startServer - SSO Service authentication failed. Clock skew too great (37)

- Username is incorrect. Note the wrong username “ccass,” error code 6 and the last warning:

  INFO: GSSServer - SPN : [ccass/PreM-vM-2003.win2k3public.local@WIN2K3PUBLIC.LOCAL]

  SEVERE: startServer - SSO Service authentication failed. Client not found in Kerberos database (6)

  WARNING: GSSServer loginSubject could not be created.

- Password is incorrect or Realm is invalid (e.g. not uppercase, bad FQDN, or KTPass run incorrectly). Note error code 24 and last warning:
  Aug 21, 2006 3:40:26 PM com.perfigo.wlan.jmx.admin.GSSServer loginToKDC

  INFO: GSSServer - SPN : [ccasso/PreM-vM-2003.win2k3public.local@WIN2K3PUBLIC.LOCAL]
  Aug 21, 2006 3:40:26 PM com.perfigo.wlan.jmx.admin.GSSServer loginToKDC

  SEVERE: startServer - SSO Service authentication failed. Pre-authentication information was invalid (24)

  WARNING: GSSServer loginSubject could not be created.

The following error indicates a client-CAS communication issue, seen when the client PC’s time is not synchronized with AD server. (Note the difference between this error and the one in which the CAS time is not synchronized with the AD server.)

  Aug 3, 2006 10:03:05 AM com.perfigo.wlan.jmx.admin.GSSHandler run

  SEVERE: GSS Error: Failure unspecified at GSS-API level (Mechanism level: Clock skew too great (37))
“Integrity check on decrypted field failed” Error

If AD SSO is not working, and the CAS logs show a “SEVERE: GSS Error: Failure unspecified at GSS-API level (Mechanism level: Integrity check on decrypted field failed (31))” message, check the account name/password in the AD configuration and KTPass command.

The CAS typically returns error messages such as “Integrity check on decrypted field failed” when the password or key is incorrect. For example, this error could appear if you run KTPass on the same account existing on multiple AD servers. Executing the KTPass command again on a new account from a single AD server should resolve the issue.
Local Authentication Settings

This chapter describes Authentication tab settings in the CAS management pages (other than VPN Auth settings which are described in Chapter 6, “Integrating with Cisco VPN Concentrators”). Topics include:

- Overview, page 9-1
- Local Heartbeat Timer, page 9-1
- Local Login Page, page 9-3
- Enable Active Directory SSO Login, page 9-7
- Enable Windows NetBIOS SSO Login, page 9-8
- OS Detection, page 9-9

Overview

Most user-related configuration settings, such as roles, authentication sources, and local users, are configured for all Clean Access Servers in the global forms of the CAM web console. However, several aspects of user management can be configured locally for an individual CAS. These include:

- User presence scanning – Checks online users to see if their connections are still active. If not, the user session is terminated after a configurable period of time. This setting can be set globally or locally.
- Login pages – Prompts users accessing the network for their login credentials.
- Transparent Windows login – Allows single sign-on in Windows domains.

Local Heartbeat Timer

The heartbeat timer checks the connection status of online users by attempting to contact the client. If the client fails to respond, the user session can be timed out after a configurable amount of time. You can configure how long Cisco NAC Appliance waits to time out disconnected users, as well as how often it attempts to contact users. The actual connection check is performed by an ARP message rather than by pinging. This allow the heartbeat check to function even if ICMP traffic is blocked.

Note

The CAS checks the connection of all users at once, regardless of when an individual user’s session started.
Local Heartbeat Timer

The timer is configurable globally when accessed from User Management > User Roles > Schedule > Heartbeat Timer. By configuring a local setting in the Clean Access Server, you can override the global setting in the Clean Access Manager for that particular CAS.

Note

For information on user session Heartbeat Timer capabilities and behavior, see the “Configure User Session and Heartbeat Timeouts” section in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

To configure timeout properties based on connection status:

Step 1

Go to Device Management > CCA Servers > Manage [CAS_IP] > Misc > Heartbeat Timer.

Figure 9-1  Local Heartbeat Timer

![Local Heartbeat Timer](image)

Step 2

To override the global setting configured using the User Management > User Roles > Schedule > Heartbeat Timer web console page, click the Override Global Settings checkbox. The global heartbeat timer setting is overridden for user sessions established using this specific CAS.

Step 3

Click the Enable Heartbeat Timer checkbox.

Note

If the CAS enters Fallback mode and this option is enabled, user sessions are still terminated and cleared from the Online Users List and Certified Devices List after the specified time period has passed. For more information, see CAS Fallback Policy, page 4-44.

Step 4

Specify a value for the Log Out Disconnected Users After field. After the system detects a disconnected user, this field sets the period of time after which the disconnected user is logged off the network.

Step 5

Click Update.

For complete details on user session timeouts, see the “User Management: Traffic Control, Bandwidth, Schedule” chapter in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).
Local Login Page

A login page configured locally for a CAS takes precedence over the global login pages configured for all Clean Access Servers. If creating login pages local to a Clean Access Server, you can customize pages for particular VLANs, operating systems, and subnets.

Add Local Login Page

2. Select the Override Global Settings option and Update.

3. Click the Add link that appears. Leave asterisks as default values for the VLAN and Subnet field to set the page for any VLAN/subnet or enter values to specify a VLAN/subnet. Likewise, leave the Operating System field as ALL, or specify an OS for which the login page will apply.
4. Click the Add button to add the page to the login page list.
5. In the login page list, click Edit next to the page to modify page contents and properties.
6. The General options page appears. Select a Page Type: Frameless, Frame-based, or Small Screen (frameless).
7. Optionally enter a Description for the page.
8. Click Update to commit the changes made on the General page, then click View to see the login page with the updated changes.
9. Click the Content link. Specify the following content to appear on the login page:
   - **Image**: Use the dropdown menu to choose the logo to appear on the login page.
   - **Title**: Type the title of the login page.
   - **Username Label, Password Label, Login Label, Provider Label, Guest Label, Help Label, Root CA Label**: Use the checkboxes to specify the fields/buttons to appear on the login screen. Enter a label for each of the fields selected.
   - **Default Provider**: Use the dropdown menu to choose the default provider for the login page.
   - **Available Providers**: The authentication sources you want to appear in the providers dropdown menu on the login page.
   - **Instructions**: Type the instructions to be shown on the login page.
- **Root CA File**: The root CA certificate file to use, if the **Root CA Label** is enabled.
- **Help Contents**: Type help text to be presented to users on the login page. Note that only HTML content can be entered in this field (URLs cannot be referenced).

10. Click **Update** to commit the changes made on the Content page, then click **View** to see the login page with the updated changes.

11. Click the **Style** link. You can change the background (BG) and foreground (FG) colors and properties. Note that **Form** properties apply to the portion of the page containing the login fields.

12. Click **Update** to commit the changes made on the Style page, then click **View** to see the login page with the updated changes.

13. If frames are enabled in the **Login Page > General** settings, click the **Right Frame** link. You can enter either URL or HTML content for the right frame as described below:
   
   **a. Enter URLs**: (for a single webpage to appear in the right frame)
   
   For an external URL, use the format `http://www.webpage.com`.
   
   For a URL on the Clean Access Manager use the format:
   
   `https://<CAM_IP_address>/upload/file_name.htm`
   
   where `<CAM_IP_address>` is the domain name or IP listed on the certificate.

   If you enter an external URL or Clean Access Manager URL, make sure you have created a traffic policy for the Unauthenticated role that allows the user HTTP access to the external server or Clean Access Manager.

   For a URL on the local Clean Access Server use the format:
   
   `https://<CAS_eth0_IP_address>/auth/file_name.htm`
   
   **b. Enter HTML**: (to add a combination of resource files, such as logos and HTML links)

   Type HTML content directly into the **Right Frame Content** field.

   To reference any resource file you have already uploaded in the **File Upload** tab as part of the HTML content (including images, JavaScript files, and CSS files) use the following formats:

   To reference a link to an uploaded HTML file:
   
   `<a href="file_name.html"> file_name.html </a>`

   To reference an image file (such as a JPEG file) enter:
   
   `<img src="file_name.jpg">`

14. Click **Update** to commit the changes made on the Right Frame page, then click **View** to see the login page with the updated changes.

### Enabling Web Client for Local Login Page

The web client option can be enabled for all deployments, but is required for L3 OOB.

To set up the Cisco NAC Appliance for L3 out-of-band (OOB) deployment, you must enable the login page to distribute either an ActiveX control or Java Applet to web login users who are multiple L3 hops away from the CAS. The ActiveX control/Java Applet is downloaded when the user performs web login and is used to obtain the correct MAC address of the client. In an OOB deployment, the CAM needs the correct client MAC address to control the port according to Certified List and/or device filter settings of the Port Profile.
DHCP IP addresses can be refreshed for client machines using the Agent or ActiveX Control/Java Applet without requiring port bouncing after authentication and posture assessment. This feature is intended to facilitate NAC Appliance OOB deployment in VoIP environments.

Note

For detailed information on Access to Authentication VLAN change detection, refer to the “Configuring Access to Authentication VLAN Change Detection” section in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

To enable the web client:

Step 1
Go to Administration > User Pages > Login Page > Edit | General.

Figure 9-3 Enable ActiveX/Java Applet for L3 OOB

Step 2
From the Web Client (ActiveX/Applet) dropdown menu, choose one of the following options. For “Preferred” options, the preferred option is loaded first, and if it fails, the other option is loaded. With Internet Explorer, ActiveX is preferred because it runs faster than the Java Applet.

- **ActiveX Only**—Only runs ActiveX. If ActiveX fails, does not attempt to run Java Applet.
- **Java Applet Only**—Only runs Java Applet. If Java Applet fails, does not attempt to run ActiveX.
- **ActiveX Preferred**—Runs ActiveX first. If ActiveX fails, attempts to run Java Applet.
- **Java Applet Preferred**—Runs Java Applet first. If Java Applet fails, attempts to run ActiveX.
Local Login Page

- **ActiveX on IE, Java Applet on non-IE Browser** (Default)—Runs ActiveX if Internet Explorer is detected, and runs Java Applet if another (non-IE) browser is detected. If ActiveX fails on IE, the CAS attempts to run a Java Applet. For non-IE browsers, only the Java Applet is run.

**Step 3**

Two options need to be checked to use the ActiveX/Applet web client to refresh the client’s IP address:

a. Click the checkbox for **Use web client to detect client MAC address and Operating System**.

b. Click the checkbox for **Use web client to release and renew IP address when necessary (OOB)** to release/renew the IP address for the OOB client after authentication without bouncing the switch port.

**Note**

This option can introduce unpredictable results for OOB clients if not configured correctly for your specific network topology. For detailed information on Access to Authentication VLAN change detection, refer to the “Configuring Access to Authentication VLAN Change Detection” section in the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.

**Step 4**

When you enable web client use for IP address release/renew, for Linux/Mac OS X clients, you can optionally click the **Install DHCP Refresh tool into Linux/Mac OS system directory** checkbox. This will install a DHCP refresh tool on the client to avoid the root/admin password prompt when IP address is refreshed.

**Step 5**

Click **Update** to save settings.

**Note**

To use this feature, “Enable L3 support” must be enabled under Device Management > CCA Servers > Manage [CAS_IP] > Network > IP.


**Local File Upload**

1. Go to **Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Login Page**.
2. Make sure the **Override Global Settings** option is enabled.
3. Click **File Upload**.
Figure 9-4  Upload Local File to CAS

4. Browse to a logo image file or other resource file on your workstation and select it in the Filename field.

5. Optionally enter text in the Description field.

6. Click Upload. The file should appear in the resources list.

Note

- Files uploaded to a specific Clean Access Server using Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Login Page > File Upload are available to the Clean Access Manager and the local Clean Access Server only. On the Clean Access Server, uploaded files are located under `/perfigo/access/tomcat/webapps/auth`.

- Files uploaded to the CAM using Administration > User Pages > File Upload are available to the Clean Access Manager and all Clean Access Servers. These files are located under `/perfigo/control/data/upload` in the CAM.

- Files uploaded to the CAM prior to 3.6(2)+ are not removed and continue to be located under `/perfigo/control/tomcat/normal-webapps/admin`.

See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for further details.

Enable Active Directory SSO Login

Enable Windows NetBIOS SSO Login

With Windows NetBIOS SSO login (formerly known as “Transparent Windows” login), users who are authenticated in their Windows domain can be automatically logged into the trusted network.

The feature has been deprecated. Cisco recommends configuring Active Directory SSO instead. Refer to the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for details.

Implementing Windows NetBIOS SSO login involves several steps:

1. Add a Windows NetBIOS SSO authentication provider to the list of authentication servers in the CAM.
   (See the “User Management: Auth Servers” chapter in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).)

2. Modify the policy of the Unauthenticated role to allow users access to the domain controller.
   (See the “User Management: Traffic Control, Bandwidth, Schedule” chapter in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).)

3. Enable Windows NetBIOS SSO Login and specify the Windows domain controller in the CAS management pages (see steps below).

With Windows NetBIOS SSO, only authentication can be done—posture assessment, quarantining, remediation, do not apply. However, the user only needs to perform Ctrl-Alt-Dlt to login.

To configure the Windows domain controller:

Step 1  Go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > Windows Auth > NetBIOS SSO the CAS for which you want to enable transparent Windows login.

Step 2  Click the Enable Transparent Windows Single Sign-On with NetBIOS/SMB checkbox and then click Update.

Step 3  Type the IP address of your Windows domain controller in the Windows Domain Controller IP field.
OS Detection

By default, the system uses the User-Agent string from the HTTP header to determine the client OS. The platform information from JavaScript or the OS fingerprinting from the TCP/IP handshake can also be used to determine the client OS. This enhanced OS fingerprinting feature is intended to prevent users from changing identification of their client operating systems through manipulating HTTP information. Note that this is a “passive” detection technique (accomplished without Nessus) that only inspects the TCP handshake and is not impacted by the presence of a personal firewall.

Additionally, “Current Version of OS Detection Fingerprint” updates are downloaded via the Device Management > Clean Access > Updates interface. Updates to OS Detection Fingerprints (or signatures) are made as new operating systems become available for Windows machines. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for additional details.

If the client is wrongly classified as Windows OS, you can submit the client IP address under Display OS Detection Signatures to display the TCP/IP stack signature stored for the client on the CAM. When troubleshooting, the TCP/IP Stack Signature result can copied/pasted for inclusion in the customer support request when contacting Cisco TAC.

- The OS detection/fingerprinting feature uses both browser User-Agent string and TCP/IP stack information to try to determine the OS of the client machine. While the detection routines will attempt to find the best match, it is possible that the OS may be detected incorrectly if the end-user modifies the TCP/IP stack on the client machine and changes the User-Agent string on the browser. If there is concern regarding malicious users evading the OS fingerprinting/detection mechanisms, then administrators are advised to use network scanning in order to confirm the OS on the machine. If, for any reason, it is not possible or not desirable to use network scanning, then network administrators should consider pre-installing the Agent on client machines or requiring users to log in using the Cisco NAC Web Agent.

- The OS Detection feature supports OS fingerprinting for Windows operating systems only. For example, Cisco NAC Appliance can detect and block a Windows OS disguised as another OS (e.g. Linux, Mac OS X); however it will not support detecting a Mac OS X disguised as Linux.

- In a FIPS 140-2 compliant network where both the CAMs and CASs are configured in failover mode, Cisco NAC Appliance does not correctly report the operating system of a client machine following a failover event and subsequent synchronization. Once the CAM/CAS detect client HTTP/HTTPS traffic, the CAM/CAS are able to “rediscover” the client machine operating system following the failover event.

To Set OS Detection Settings:

Step 1  Go to Device Management > CCA Servers > Manage [CAS_IP] > Authentication > OS Detection in the CAS management pages of the web console.
Figure 9-6 OS Detection

Step 2 Click the checkbox for **Set client OS to WINDOWS_ALL when Win32 platform is detected** to add this as an additional detection option.

Step 3 Click the checkbox for **Set client OS to WINDOWS_ALL when Windows TCP/IP stack is detected (Best Effort Match)** to add this as an additional detection option.

Step 4 Click **Update**.

When troubleshooting, the TCP/IP Stack Signature result can be copied/pasted for inclusion in the customer support request when contacting Cisco TAC.

To Troubleshoot OS Detection Signatures:

Step 1 Go to **Device Management > CCA Servers > Manage [CAS_IP] > Authentication > OS Detection**.

Figure 9-7 Display TCP/IP Stack Signature

Step 2 In the **Client IP Address** field, type the client IP address to be tested.

Step 3 Click **Display Signature**. The OS signature result displays in the **TCP/IP Stack Signature** field.
Step 4  Copy and paste the **TCP/IP Stack Signature** result to your support request when contacting Cisco TAC.
Local Certified and Floating Devices

This chapter describes local settings that can be configured at the CAS level for Cisco NAC Appliance implementation. For complete information on Cisco NAC Appliance configuration in the CAM web console, see the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x). Topics in this chapter include:

- Overview, page 10-1
- Clear Certified Devices, page 10-3
- Add Exempt Devices, page 10-2
- Clear Exempt Devices, page 10-3
- Specify Floating Devices, page 10-4

Overview

Most elements of Cisco NAC Appliance, such as login pages, Nessus scan plugin behavior, Agent requirements, and user roles, are configured at the global level for all CASs. However, certain tasks can also be performed at the local level for an individual CAS. These include the following.

- Clearing certified devices
  The Cisco NAC Appliance module on each Clean Access Server automatically adds devices to the Certified Devices list after the user authenticates and the device passes network scanning with no vulnerabilities found and/or meets Agent Requirements. Certified devices are considered clean until removed from the list. You can remove devices at a specified time or interval from the Certified Devices list in order to force them to repeat network scanning/Agent checking. Note that devices for Agent users are always scanned for requirements at each login.

- Adding/clearing exempt devices
  An exempt device is one which is never subject to certification via network scanning (Nessus scans). You can specify a device as exempt to allow it to bypass network scanning, or you can clear an exempt device to force it to meet Cisco NAC Appliance requirements. Adding or clearing exempt devices is always done manually.

- Specifying floating devices
  A floating device requires authentication at every login and is certified only for the duration of a user session. Floating devices are always added manually.
Add Exempt Devices

Designating a device as exempt is the way a device can be manually added to the automatically-generated Certified Devices list. The CAS only adds a device to the Certified Devices list if the device has passed network scanning with no vulnerabilities found, or met Agent system requirements, or both. Once added to the list, the device is considered clean and therefore exempt from having to go through certification while its MAC address remains on the Certified Devices list. Adding an exempt device in effect bypasses the automated network scanning certification process to certify that the device you are adding to the list is clean.

**Step 1**  
Go to **Device Management > CCA Servers > Manage [CAS_IP] > Filter > Clean Access > Certified Devices**.

**Figure 10-1  Certified Devices (Local)**

![Certified Devices (Local) Image](image)

**Step 2**  
Type the MAC address of the exempt device in the text field. Use line breaks to separate multiple addresses.

**Step 3**  
Click **Add Exempt**.
Clear Exempt Devices

Clearing an exempt device means you are removing it from the Certified Devices list and forcing it to go through Nessus Scanning. Because exempt devices are manually added to the list, they must also be manually removed. This also means that an exempt device on the Certified Devices list is protected from being automatically removed when the global Certified Devices Timer is used to clear the list at regularly scheduled intervals.

To manually clear exempt devices from the list:

**Step 1** Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Clean Access > Certified Devices (see Figure 10-1).

**Step 2** Click Clear Exempt. All exempt devices for this Clean Access Server will be cleared from the list.

Clear Certified Devices

Devices are added to the Certified Devices list by the Clean Access Server and are considered clean until removed from the list.

If a certified device is moved from one CAS to another, it must go through Nessus Scanning again for the new CAS unless it has been manually added as an exempt device at the global level for all CASs. This allows for the case where one CAS has more restrictive requirements than another.

The CAM maintains the central Certified Devices list, which stores device information according to the certifying Clean Access Server. The CAM then publishes each Clean Access Server’s certified devices to the appropriate CAS as well as any globally exempt devices to all Clean Access Servers.

Though devices can only be certified and added to the list per CAS, you can remove certified devices globally from all Clean Access Servers or locally from a particular CAS. Clearing certified devices means you want to force the devices to repeat the Cisco NAC Appliance scanning/requirement checking.

- **Global level (auto)**—You can clear the list at regular intervals using the Certified Devices Timer form (Device Management > Clean Access > Certified Devices > Timer).
- **Global level (manual)**—You can manually clear the Certified Device list using the global form Device Management > Clean Access > Certified Devices.
- **Local level (manual)**—You can manually clear certified devices for a specific Clean Access Server using the local form Device Management > CCA Servers > Manage [CAS_IP] > Filter > Clean Access > Certified Devices.

**Note**

- Clearing the Certified Device list either manually or automatically also logs the user off the network.
- Removing a user from Monitoring > Online Users > View Online Users does not remove the client from the Certified Devices list. This allows the user to log in again without forcing the client device to go through the authentication process when it is still considered clean.
Specify Floating Devices

A floating device is certified only for the duration of a user session. Once the user logs out, the next user of the device needs to be certified again. Floating devices are useful for shared equipment, such as kiosk computers or wireless cards loaned out by a library.

You can also specify devices that are never exempt from certification requirements by MAC address. This is useful for multi-user devices, such as dialup routers that channel multi-user traffic from the untrusted (managed) network. In such cases, the Clean Access Server will see only the MAC address of that device as the source address of traffic from the trusted network. If the device is not configured as a floating device, this means that after the first user is certified, additional users will be unintentionally exempt from certification. By configuring the router’s MAC address as a floating device that is never certified, you can ensure that each user accessing the network through the device is individually assessed for vulnerabilities/requirements met.

In this case, the users are distinguished by IP address. Note that users must have different IP addresses for this to work. If the router performs NATing services, the users are indistinguishable to the Clean Access Manager and only the first user will be certified.

See also Add VPN Concentrator as a Floating Device, page 6-10.

To specify a local floating device:

**Step 1** Go to Device Management > CCA Servers > Manage [CAS_IP] > Filter > Clean Access > Floating Devices.
Specify Floating Devices

Step 2 Specify a floating device by MAC address in the form:

\[ <\text{MAC}> \ <\text{type}> \ <\text{description}> \]

Where:

- \text{MAC} is the MAC address of the device (in standard hexadecimal MAC address format, e.g., 00:16:21:23:4D:00).
- \text{type} is either:
  - 0 - for session-scope certification, or
  - 1 - if the device should never be considered certified
- \text{description} is an optional description of the device.

Be sure to include spaces between each element and use line breaks to separate multiple entries. For example:

00:16:21:23:4D:00 0 LibCard1
00:16:34:21:4C:00 0 LibCard2
00:16:11:12:4A:00 1 Router1

Step 3 Click Add Device to save the setting.

Step 4 To remove a floating MAC address, click the Delete icon next to the address.
Administering CAS Certificates, Time, and Support Logs

This chapter describes Clean Access Server (CAS) administration. Topics include:

- Status Tab, page 11-1
- Manage CAS SSL Certificates, page 11-6
- SNMP, page 11-33
- System Upgrade, page 11-38
- Synchronize System Time, page 11-38
- Support Logs and LogLevel Settings, page 11-40

**Status Tab**

The Status tab of the CAS management pages displays high-level status information on which modules are running in the Clean Access Server.
Clean Access Server Direct Access Web Console

The CAS management pages of the CAM web admin console (Figure 11-1) are the primary configuration interface for the Clean Access Server(s). However, each Clean Access Server has its own web admin console that allows configuration of certain limited Administration and Monitoring settings directly on the CAS (Figure 11-4). The CAS direct access web console is primarily used to download CAS support logs or configure pairs of Clean Access Servers for High Availability. See the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details. If the CAS management pages become unavailable, you can also use the direct console interface for other functions such as managing SSL certificates for the CAS or performing system upgrade.
To access the Clean Access Server’s direct access web admin console:

**Step 1**

Open a web browser and type the IP address of the CAS’s trusted (eth0) interface in the URL/address field: https://<CAS_eth0_IP_address>/admin (for example, https://172.16.1.2/admin).

If you have chosen to enable the customizable Pre-login Banner for the CAS during initial configuration, the CAS admin web console displays in introductory Pre-login Banner (Figure 11-2). Otherwise, the CAS administrator credential entry page (Figure 11-3) appears.

![CAS Pre-Login Banner Example](image)

The Pre-login Banner enables you to present a broad range of messages, including warnings, system/network status, access requirements, etc., to administrator users before they enter authentication credentials in the CAM/CAS. Administrators can specify the text of the Pre-login Banner by enabling this feature on the appliance, logging into the command-line console, and editing the /root/banner.pre file. The text of the Pre-login Banner appears in both the web console interface and the command-line interface when admin users are logging into the CAM/CAS.

You can enable or disable the Pre-login Banner during the initial CAM/CAS configuration CLI session and whenever you choose to alter your base CAM/CAS configuration with the `service perfigo config` CLI command.
Step 2  Accept the temporary certificate and log in as user admin with the associated password.
Because Cisco NAC network modules installed in Cisco Integrated Services Routers (ISRs) do not support high availability, the Failover tab is not available when you view the direct web admin console for a Cisco NAC network module.

Note

- Make sure to precede the CAS IP address with “https://” and append it with “/admin”; otherwise you will see the redirect page for web login users.
- For security purposes, Cisco recommends changing the password for the CAS web console.
Note that almost all of the settings in the CAS web console can be configured via the CAS management pages in the CAM web admin console, with the exception of the Failover, SSL, Admin Password, and Support Logs. The CAS direct access web console provides the following Administration pages for the local CAS:

- Network Settings—IP, DNS, and Failover (Cisco NAC-3300 Series only)
- Software Update
- SSL (Generate Temporary Certificate, Import Certificate, Export CSR/Private Key/Certificate, and view and remove existing Trusted CAs)
- SNMP
- Time Server
- Admin Password

The Monitoring module of the CAS direct access console provides the following pages:

- Active VPN Clients
- Support Logs

For High Availability CAS pairs, any CAS network setting changes performed on an HA-Primary CAS through the CAS management pages or CAS direct access web console must also be repeated on the standby CAS unit through its direct access web console. These settings include updating the SSL certificate, system time, time zone, DNS, or Service IP. See IP Form, page 4-11 and the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.

### Manage CAS SSL Certificates

This section describes the following:

- SSL Certificate Overview, page 11-6
- Typical SSL Certificate Setup on the CAS, page 11-10
- Generate Temporary Certificate, page 11-12
- Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14
- Manage Signed Certificate/Private Key, page 11-16
- Manage Trusted Certificate Authorities, page 11-19
- View Current Private Key/Certificate and Certificate Authority Information, page 11-21
- SSL Requirements for Mac OS X/CAS Communication, page 11-23
- Troubleshooting Certificate Issues, page 11-31

### SSL Certificate Overview

The elements of Cisco NAC Appliance communicate securely over Secure Socket Layer (SSL) connections. Cisco NAC Appliance uses SSL connections for a number of purposes, including the following:

- Secure communications between the CAM and the CAS
Chapter 11  Administering CAS Certificates, Time, and Support Logs

Manage CAS SSL Certificates

Cam-Cas communication and HA-CAM and/or HA-CAS peer communication can break down and adversely affect network functionality when SSL certificates expire. For more information, see HA Active-Active Situation Due to Expired SSL Certificates, page 11-31.

- Policy Import/Export operations between Policy Sync Master and Policy Sync Receiver CAMs
- CAM-to-LDAP authentication server communications where SSL has been enabled for the LDAP authentication provider using the Security Type option on the User Management > Auth Servers > New | Edit page
- Between the CAS and end-users connecting to the CAS
- Between the CAM/CAS and the browsers accessing the CAM/CAS web admin consoles

During installation, the configuration utility script for both the CAM and CAS requires you to generate a temporary SSL certificate for the appliance being installed (CAM or CAS). A corresponding Private Key is also generated with the temporary certificate. For the Clean Access Manager and Clean Access Servers operating strictly in a lab environment, it is not necessary to use a CA-signed certificate and you can continue to use a temporary certificate, if desired. For security reasons in a production deployment, however, you must replace the temporary certificate for the CAM and CAS with a third-party CA-signed SSL certificate.

At installation, a corresponding Private Key is also generated with the temporary certificate. Cisco NAC Appliance Release 4.9 uses two types of keys to support FIPS compliance: Private Keys and Shared Master Keys. Both of these key types are managed and stored using the FIPS card installed in the CAM/CAS. During installation, keys are created using the CAM/CAS setup utilities, the keys are then moved to the FIPS card for security, and key-generation files and/or directories are then removed from the CAM/CAS.

In Cisco NAC Appliance Release 4.9, you can no longer export private keys and you cannot generate CSRs using a FIPS 140-2 compliant CAM/CAS. To adhere to FIPS compliance guidelines, you can only import certificates from trusted third-party resources.

For details on managing SSL certificates for the CAM, see the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Note Cisco NAC Appliance supports 1024-, 2048-, and 4096-bit RSA key lengths for SSL certificates.

Note Cisco NAC Appliance does not support wildcard SSL certificates.

This Overview section discusses the following topics:
- Web Console Pages for SSL Certificate Management
- CA-Signed Certificates
- Intermediary Certificates
- Certificates for High Availability (HA) Pairs
- Regenerating Certificates for DNS Name Instead of IP
Web Console Pages for SSL Certificate Management

CAM SSL certificate files are kept on the CAM machine, and CAS SSL certificate files are kept on the CAS machine. The CAS certificate can be managed from:

- **Administration > SSL > X509 Certificate**—Use this configuration window to import and export temporary or CA-signed certificates, import Private Keys (FIPS and non-FIPS appliances), export Private Keys (non-FIPS appliances only), and generate new temporary certificates
- **Administration > SSL > Trusted Certificate Authorities**—Use this configuration window to view, add, and remove Certificate Authorities on the CAS
- **Administration > SSL > X509 Certification Request** (non-FIPS appliances only)—Use this configuration window to generate a new CA-signed certificate request for the CAS

For additional web console access information, refer to Clean Access Server Direct Access Web Console, page 11-2.

**Note**

For High Availability CAS pairs, any CAS network setting changes performed on an HA-Primary CAS through the CAS management pages or CAS direct access web console must also be repeated on the standby CAS through its direct access web console. These settings include updating the SSL certificate, system time/time zone, DNS, or Service IP. See the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.

CA-Signed Certificates

The CAS SSL certificate is used for communication between the CAS and the user’s web browser and/or Agent, and for communication between the CAM and CAS. In a production deployment, you must replace the temporary certificate for the Clean Access Server with a third-party CA-signed SSL certificate. Cisco NAC Appliance provides a tool to generate and export a Certificate Signing Request (CSR) that you can send to your Certificate Authority on the **Administration > SSL > X509 Certification Request** page. The following reasons highlight the need to obtain and import a third-party CA-signed certificate on the CAS:

- The CAS certificate is visible to the end user. If the CAS has a temporary certificate, users have to explicitly accept the certificate from the CAS each time they login.
- The root certificate needs to be trusted by the client machine.

**Note**

The CAM and CAS require encrypted communication. Therefore, the CAM must contain the Trusted Certificate Authorities from which the certificates on all of its managed CASs originate, and all CASs must contain the same Trusted Certificate Authority from which the CAM certificate originates before deploying Cisco NAC Appliance in a production environment.

- With public certification authorities (Thawte, Verisign, etc.), the root already exists on the client machine.
- For client machines running Windows Vista and/or Internet Explorer 7.0, Certificate Revocation List (CRL) checking is enabled by default. Cisco recommends obtaining a CA-signed certificate for the CAS if supporting Windows Vista/IE 7.0 client machines. For further details, see the section “Windows Vista and Windows 7—IE 7 and IE 8 Certificate Revocation List” in the corresponding Release Notes for Cisco NAC Appliance.
For details on Mac OS X Agent certificates, refer to SSL Requirements for Mac OS X/CAS Communication, page 11-23.

Temporary certificates are designed for lab environments only. When you deploy your CAS in a production environment, Cisco strongly recommends using a trusted certificate from a third-party Certificate Authority to help ensure network security.

In a strictly lab environment, it is not necessary to use a CA-signed certificate and you can continue to use a temporary certificate for the CAM and CAS, if desired. If you deploy your CAM and CAS in a production environment, however, you must use a third-party Trusted CA. For details on managing SSL certificates for the CAM, see the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).

Note

You cannot use a CA-signed certificate that you bought for the Clean Access Manager on the Clean Access Server. You must buy a separate certificate for each Clean Access Server.

Any certificate that is not provided by a public CA or that is not the self-signed certificate is considered a non-standard certificate by the CAS.

Certification Authorities

A Certification Authority (CA) can be public (e.g. Thawte, Verisign) or private.

With a Public CA:

- You submit your CSR to the public CA and request a Webserver type or SSL type of certificate.
- Your CA should provide you a certificate based on the CSR.
- You can also request the CA’s root or public key.
- Note that the CAM/CAS already have the public keys (root) of the most common public CAs.

With a Private CA:

- You can submit your CSR to a private or local CA such as Microsoft CA server.
- The private CA server provides the Certificate and root (Public key).
- However, this root will need to be loaded to CAM/CAS.

Intermediary Certificates

When one or more Intermediary CAs are involved, you will have multiple root certificates or public keys. Each CA has its own root. The root/public key information of all certification authorities in the chain needs to be combined into one single file (for example, root.cer) before it can be uploaded into the CAS. To do this, open the root certificate of each CA and copy the information from each root cert into Wordpad or a similar text editor. Include the “Begin Certificate” and “End Certificate” lines for each CA cert, and put each certificate one right after the other in the text file. Save this compiled root.cer file, then import it into the CAS.
Certificates for High Availability (HA) Pairs

If you are running HA-CAS pairs, you must generate the CSR for the Service IP of the HA pair and import the CA-signed certificate into one of the HA pairs (e.g. CAS-1). After that, the certificate information, i.e. the Private Key, Certificate, and Root, will need to be exported from the HA-Primary CAS and imported into the HA-Secondary CAS. Refer to the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for more information.

Regenerating Certificates for DNS Name Instead of IP

If planning to regenerate certificates based on the DNS name instead of the IP address of your servers:

- When you are generating a CSR for signing, always export and save the Private Key to a secure location (for safekeeping and to have the Private Key handy). Make sure the CA-signed certificate you are importing is the one with which you generated the CSR and that you have NOT subsequently generated another temporary certificate. Generating a new temporary certificate after you have exported the CSR will create a new private-public key combination, and the new Private Key will no longer match the CA-signed certificate.
- When importing certain CA-signed certificates, the system may warn you that you need to import the root certificate (the CA’s root certificate) used to sign the CA-signed certificate, or the intermediate root certificate may need to be imported.
- Make sure there is a DNS entry in the DNS server.
- Make sure the DNS address in your Clean Access Server is correct (see Configure DNS Servers on the Network, page 4-24).
- For High-Availability (failover) configurations, use the DNS name for the Service IP (virtual DNS).
- When using a DNS-based certificate, if it is not CA-signed, the user is typically prompted to accept the certificate.

Typical SSL Certificate Setup on the CAS

The typical steps for managing CAS certificates are as follows:

Phase 1: Establish SSL Communication Between the CAS and CAM

Step 1  Synchronize time.

After CAM and CAS installation, make sure the time on the CAM and CAS is synchronized (within 3-5 minutes) before regenerating the temporary certificate on which the Certificate Signing Request will be based. See the next section, Synchronize System Time, page 11-38, for details.

Step 2  Check DNS settings for the CAS.

If planning to use the DNS name instead of the IP address of your servers for CA-signed certificates, you will need to verify the CAS settings and regenerate a temporary certificate. See Regenerating Certificates for DNS Name Instead of IP, page 11-10 for details. For HA systems, you'll need to regenerate the certificates based on Service IP (see Generate Temporary Certificate, page 11-12).

Step 3  Generate Temporary Certificate, page 11-12.
During initial CAS installation/configuration, a temporary certificate and Private Key are automatically generated. If changing time or DNS settings on the CAM, regenerate the temporary certificate and Private Key.

**Step 4**
Ensure you export the certificate from your CAM, save it on a machine accessible from your CAS, and import the exported certificate on the CAS, and repeat the process in reverse to ensure the CAS certificate also resides on the CAM.

### Phase 2: Set Up Your CAS and CAM For Production Deployment

**Warning**
If your previous deployment uses a chain of SSL certificates that is incomplete, incorrect, or out of order, CAM/CAS communication may fail after upgrade to release 4.5 and later. You must correct your certificate chain to successfully upgrade to release 4.5 and later. For details on how to fix certificate errors on the CAM/CAS after upgrade to release 4.5 and later, refer to the How to Fix Certificate Errors on the CAM/CAS After Upgrade Troubleshooting Tech Note.

**Step 5**
Export (Backup) the certificate to a local machine for safekeeping.
If you are altering your Cisco NAC Appliance SSL configuration, it is always a good idea to back up the certificate and Private Key corresponding to the current certificate to a local hard drive for safekeeping. See Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14.

**Step 6**
(Non-FIPS appliances only) Export (Backup) the Private Key to a local machine for safekeeping.
If you are altering your Cisco NAC Appliance SSL configuration, it is always a good idea to back up the certificate and Private Key corresponding to the current certificate to a local hard drive for safekeeping. See Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14.

**Step 7**
(Non-FIPS appliances only) Export (save) the Certificate Signing Request (CSR) to a local machine. (See Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14.)

**Step 8**
Send the CSR file to a Certification Authority (CA) authorized to issue trusted certificates.

**Step 9**
After the CA signs and returns the certificate, import the CA-signed certificate to your server.
When the CA-signed certificate is received from the CA, upload it as PEM-encoded file to the CAS temporary store. See Manage Signed Certificate/Private Key, page 11-16.

**Note**
Cisco strongly recommends removing this certificate authority before deploying your CAS in a production environment. If you are not deploying your CAS in a production environment, you can choose whether or not to remove this certificate authority.

**Note**
The CAM and CAS require encrypted communication. Therefore, the CAM must contain the Trusted Certificate Authorities from which the certificates on all of its managed CASs originate, and all CASs must contain the same Trusted Certificate Authority from which the CAM certificate originates before deploying Cisco NAC Appliance in a production environment.

**Step 10**
If necessary, upload any required intermediate CA certificate(s) as a single PEM-encoded file to the CAS temporary store (see Intermediary Certificates, page 11-9).

**Step 11**
Test as a client accessing the Clean Access Server.
Phase 3: Adding a New CAM or CAS to an Existing Production Deployment

In production deployments, CA-signed certificates are used exclusively. Use the following steps when introducing new appliances (CAM or CAS) to a production deployment. The new appliance should not be added to the deployment until you have requested and are able to import a new third-party CA-signed certificate.

**Step 1** Install and initially configure the new appliance as described in the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x).

**Step 2** Follow the steps in Phase 1: Establish SSL Communication Between the CAS and CAM, page 11-10.

**Step 3** (Non-FIPS appliances only) Generate a CSR for the new appliance, as described in Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14.

**Step 4** Obtain and install the CA-signed certificate as described in Import Signed Certificate/Private Key, page 11-16.

**Step 5** Add the appliance to your existing production environment.

---

Generate Temporary Certificate

The following procedure describes how to generate a new temporary certificate for the CAS. Any time you change basic configuration settings on the CAM (date, time, associated DNS server, etc.) you should generate a new temporary certificate. See Regenerating Certificates for DNS Name Instead of IP, page 11-10 for additional details.

**Note** Before generating a certificate on the CAS, ensure you enter the CAS distinguished name (DN) in the CAM Device Management > CCA Servers > Authorization web console page.

**Caution** If you are using FIPS 140-2 compliant appliances, be sure you have your current trusted-CA certificate and Private Key stored on an external machine so you can restore them following this procedure.

If you are using a CA-signed certificate on a non-FIPS appliance, Cisco recommends backing up the Private Key for the current certificate prior to generating any new certificate, as generating a new certificate also generates a new Private Key. See Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14 for more information.

**Step 1** Go to Administration > SSL > X509 Certificate.

**Step 2** Click Generate Temporary Certificate to expose the fields required to construct a temporary certificate (Figure 11-6).
Step 3 Enter appropriate values for the form fields:

- **Full Domain Name or IP** – Either the fully qualified domain name (FQDN) or the IP address of the CAS for which the certificate applies, for example: `caserver.<your_domain_name>`.
  - If using an IP-based certificate, generate the certificate based on the Trusted Interface IP address (eth0) of the CAS.

  **Note** If the CAS is configured as an L3 Real-IP Gateway, generate the certificate based on the Untrusted Interface (eth1) IP address of the CAS.

  - If using a domain name, make sure that your DNS server can resolve the “Full Domain Name” entered.

  **Note** To support the Mac OS X Agent, the CAS/CAM must use the FQDN as the “subject” DN on the certificate (this is the “Full Domain Name or IP” on the CAS/CAM console). An IP address is not allowed. Refer to SSL Requirements for Mac OS X/CAS Communication, page 11-23 for details.

- **Organization Unit Name** – The name of the unit within the organization, if applicable.
- **Organization Name** – The legal name of the organization.
- **City Name** – The city in which the organization is legally located.
- **State Name** – The full name of the state in which the organization is legally located.
- **2-letter Country Code** – The two-character, ISO-format country code, such as GB for Great Britain or US for the United States.
Step 4 Specify whether you want the new temporary certificate to use a 1024-, 2048-, or 4096-bit RSA Key Size.

Step 5 When finished, click Generate. This generates a new temporary certificate and new Private Key.

Step 6 For FIPS 140-2 compliant appliances, be sure to be sure to restore your current trusted-CA certificate and Private Key from an external machine.

Note The CCA Server Certificate entry at the top of the certificate display table specifies the full distinguished name of the current CAS SSL certificate. You are required to enter the full distinguished name of the CAS in the CAM web console if you are setting up Authorization between your CAM and CASs. For more information, see Configure Clean Access Server-to-Clean Access Manager Authorization, page 4-6.

---

**Generate and Export a Certification Request (Non-FIPS CAS Only)**

Note The Administration > SSL > X509 Certification Request tab does not appear in the CAS web console on a FIPS 140-2 compliant appliance.

Generating a CSR creates a PEM-encoded PKCS#10-formatted Certificate Signing Request (CSR) suitable for submission to a certificate authority. Before you send the CSR, make sure to export the existing certificate and Private Key to a local machine to back it up for safekeeping.

To export the CSR/Private Key and create a certificate request from the CAS web console:

Step 1 Go to Administration > SSL > X509 Certification Request (Figure 11-7).
Step 2 Click **Generate Certification Request** to expose the fields required to construct a certificate request.

Step 3 Type appropriate values for the following fields:

- **Full Domain Name or IP**—The fully qualified domain name or IP address of the Clean Access Manager for which the certificate is to apply. For example: `camanager.<your_domain_name>`

**Note** If requesting a CA-signed certificate for a CAS HA-pair, the CA-signed certificate must either be based on the Service IP or a host name/domain name resolvable to the Service IP through DNS.

- **Organization Unit Name**—The name of the unit within the organization, if applicable.
- **Organization Name**—The legal name of the organization.
- **City Name**—The city in which the organization is legally located.
- **State Name**—The full name of the state in which the organization is legally located.
- **2-letter Country Code**—The two-character, ISO-format country code, such as GB for Great Britain or US for the United States.

Step 4 Specify whether you want the new temporary certificate to use a 1024-, 2048-, or 4096-bit **RSA Key Size**.

Step 5 Click **Generate** to generate a certificate request and Private Key pair. Make sure these are the ones for which you want to submit the CSR to the certificate authority.

Step 6 Before you submit the new CSR to the Certificate Authority, save the new certification request and Private Key used to generate the request to your local machine by enabling the checkboxes for the **Certification Request** and/or **Private Key** and clicking **Export**. You are prompted to save or open the file (see Default File Names for Exported Files, page 11-16). Save it to a secure location. Use the CSR file to request a certificate from a certificate authority. When you order a certificate, you may be asked to copy and paste the contents of the CSR file into a CSR field of the order form.
Alternatively, you can immediately Open the CSR in Wordpad or a similar text editor if you are ready to fill out the certificate request form, but Cisco strongly recommends you also save a local copy of the CSR and Private Key to ensure you have them should the request process suffer some sort of mishap or your CAM basic configuration change between submitting the CSR and receiving your CA-signed certificate.

When you receive the CA-signed certificate back from the certification authority, you can import it into the Clean Access Server as described in Manage Signed Certificate/Private Key, page 11-16. After the CA-signed cert is imported, the “currently installed certificate” is the CA-signed certificate. You can always optionally Export the currently installed certificate if you need to access a backup of this certificate later.

Default File Names for Exported Files

The default file names for SSL Certificate files that can be exported from the CAS are as follows. When you actually save the file to your local machine, you can specify a different name for the file. For example, to keep from overwriting your chain.pem file containing your certificate chain information, you can specify your Private Key filename to be a more appropriate name like priv_key.pem or something similar.

<table>
<thead>
<tr>
<th>Default File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cert_request.pem</td>
<td>CAS Certificate Signing Request (CSR)</td>
</tr>
<tr>
<td>chain.pem</td>
<td>CAS Currently Installed Private Key and/or Certificate</td>
</tr>
</tbody>
</table>

1. For release 3.6.0.1 and below filename extensions are .csr instead of .pem.
2. For release 3.6(1) only, the filename is secsmart_crt.pem.

Manage Signed Certificate/Private Key

Import Signed Certificate/Private Key

You can import CA-signed PEM-encoded X.509 Certificates and Private Keys using the CAS web console on both FIPS 140-2 compliant and non-FIPS appliances. (Typically, you only need to re-import the Private Key if the current Private Key does not match the one used to create the original CSR on which the CA-Signed certificate is based.) There are two methods administrators can use to import CA-signed certificates, Private Keys, and associated Certificate Authority information into Cisco NAC Appliance:

1. Import the Certificate Authorities and the End Entity Certificates/Private Keys separately:
   a. Import the Certificate Authorities into the trust store using the procedures in Manage Trusted Certificate Authorities, page 11-19
   b. Import the CAS’s end entity certificate and/or Private Key using the instructions below

2. Construct a PEM-encoded X.509 certificate chain (including the Private Key and End Entity, Root CA, and Intermediate CA certificates) and import the entire chain at once using the instructions below

If you have received a CA-signed PEM-encoded X.509 certificate for the Clean Access Server, you can also import it into the Clean Access Server as described here.
Before starting, make sure that the root and CA-signed certificate files are in an accessible file directory location and that you have obtained third-party certificates for both your CAM and CASs. If using a Certificate Authority for which intermediate CA certificates are necessary, make sure these files are also present and accessible if not already present on the CAS.

**Note**

If obtaining a CA-signed certificate for a CAS HA-Pair, the CA-signed certificate must either be based on the Service IP or a host name/domain name resolvable to the Service IP through DNS.

**Note**

Any certificate that is not provided by a public CA or that is not the self-signed certificate is considered a non-standard certificate by the CAM/CAS. When importing certificates to the CAS, make sure to obtain CA-signed certificates for authentication servers.

To import a certificate and/or Private Key for the CAS:

**Step 1**

Go to Administration > SSL > X509 Certificate (see Figure 11-8).

**Step 2**

Click **Browse** and locate the certificate file and/or Private Key on your local machine.

**Note**

Make sure there are no spaces in the filename when importing files (you can use underscores).

**Step 3**

Click **Import**.
Manage CAS SSL Certificates

Note
Neither the CAM nor CAS will install an unverifiable certificate chain. You must have delimiters (BEGIN/END CERTIFICATE) for multiple certificates in one file, but you do not need to upload certificate files in any particular sequence because they are verified in the temporary store first before being installed.

If you already have other members of the certificate chain in the CAS trust store, you do not need to re-import them. The CAS can build the certificate chain from a combination of newly-imported and existing parts.

If you try to upload a root/intermediate CA certificate for the CAM that is already in the list, you may see an error message reading “This intermediate CA is not necessary.” In this case, you must delete the uploaded Root/Intermediate CA in order to remove any duplicate files.

Export Certificate and/or Private Key

Note
You cannot export the Private Key for a FIPS 140-2 compliant CAS. You can only export certificates.

To backup your certificate and/or Private Key in case of system failure or other loss, you can export your certificate and/or Private Key information and save a copy on your local machine. This practice also helps you manage certificate/Private Key information for a CAS HA-Pair. By simply exporting the certificate information from the HA-Primary CAS and importing it on the HA-Secondary CAS, you are able to push an exact duplicate of the certificate info required for CAM/CAS communication to the standby CAS.

Step 1 Go to Administration > SSL > X509 Certificate (Figure 11-8).
Step 2 To export existing certificate/Private Key information:
   a. Select one or more certificates and/or the Private Key displayed in the certificates list by clicking on their respective left hand checkboxes.
   b. Click Export and specify a location on your local machine where you want to save the resulting file.
Manage Trusted Certificate Authorities

You can locate and remove Trusted CAs from the CAS database using the Administration > SSL > Trusted Certificate Authorities CAS web console page. To keep your collection of trusted certificate authority Cisco recommends keeping only trusted certificate authority information critical to Cisco NAC Appliance operations in the CAM trust store.

To view and/or remove Trusted CAs from the CAS:

**Step 1**

Go to Administration > SSL > Trusted Certificate Authorities (Figure 11-9).

**Figure 11-9 Administration > SSL > Trusted Certificate Authorities**

Viewing Trusted CAs

**Step 2**

If you want to refine the list of Trusted CAs displayed in the CAS web console:

a. Choose an option from the Filter dropdown menu:

   - **Distinguished Name**—Use this option to refine the list of Trusted CAs according to whether the Trusted CA name contains or does not contain a specific text string.

   - **Time**—Use this option to refine the display according to which Trusted CAs are currently valid or invalid.

   You can also combine these two options to refine the Trusted CAs display.

b. Click the Filter button after selecting and defining parameters for the search options to display a refined list of all Trusted CAs that match the criteria.

   You can click Reset to negate any of the optional search criteria from the filter dropdown menu and return the Trusted CA display to default settings.

c. You can also increase or decrease the number of viewable items in the Trusted CAs list by choosing one of the options in the dropdown menu at the top-left of the list. The options are 10, 25, or 100 items.

d. If you want to view details about an existing Trusted CA, click the View button (far-right magnifying glass icon) to see information on the specific certificate authority, as shown in Figure 11-10.
Removing Trusted CAs

Step 3 Select one or more Trusted CAs to remove by clicking on the checkbox for the respective Trusted CA in the list. (Clicking on the empty checkbox at the top of the Trusted CAs display automatically selects or unselects all Trusted CAs in the current list.)

Step 4 Click Delete Selected.

Once the CAS removes the selected Trusted CAs from the database, the CAS automatically restarts services to complete the update.

Import/Export Trusted Certificate Authorities

You can also use the Trusted Certificate Authorities web console page to import and export certificate information for the CAS.

Note For standard certificate import and export guidelines, refer to Generate and Export a Certification Request (Non-FIPS CAS Only), page 11-14 and Manage Signed Certificate/Private Key, page 11-16.

Step 1 Go to Administration > SSL > Trusted Certificate Authorities.

Step 2 To import a Trusted Certificate Authority:

a. Ensure you have the appropriate certificate file accessible to the CAS in the network and click Browse.

b. Locate and select the certificate file on your directory system and click Open.

c. Click Import to upload the Trusted Certificate Authority information to your CAS.

Step 3 To export existing Trusted Certificate Authority information:

a. Select one or more Trusted CAs displayed in the Trusted Certificate Authorities list by clicking on their respective left hand checkboxes.

b. Click Export and specify a location on your local machine where you want to save the resulting “caCerts” file.
View Current Private Key/Certificate and Certificate Authority Information

You can verify the following files by viewing them under Administration > SSL > X509 Certificate (see Figure 11-7):

- Currently Installed Private Key
- Currently Installed End Entity, Root, and Intermediate CA Certificate
- Certificate Authority Information

**Note**

You must be currently logged into your web console session to view any Private Key and/or certificate files.

View Currently Installed Private Key

You can view the CAM Private Key by exporting and opening the exported Private Key file in Wordpad or a similar text editor tool to bring up a dialog like the one in Figure 11-11 (BEGIN PRIVATE KEY/END PRIVATE KEY).

**Figure 11-11 View Currently Installed Private Key**

You can also use this method to view uploaded Private Keys before importing them into your CAM.
View Currently Certificate or Certificate Chain

You can view CAS Private Key and End Entity, Root CA, and Intermediate CA certificates by exporting and opening the saved file in Wordpad or a similar text editor tool to bring up a dialog like the one in Figure 11-12 (BEGIN CERTIFICATE/END CERTIFICATE).

Figure 11-12 View Currently Installed Certificate

You can also use this method to view uploaded certificates before importing them into your CAM.

View Certificate Authority Information

You can view Certificate Authority information for CAM End Entity, Root, and Intermediate CA Certificates by clicking on the respective View icon (magnifying glass) in the right hand column to bring up a dialog like the one in Figure 11-13.

Figure 11-13 View Certificate Authority Information
SSL Requirements for Mac OS X/CAS Communication

For the Mac OS X Agent to communicate with the Clean Access Server, the SSL communication between the Agent and CAS must meet certain requirements. The CAS must have one of the following:

- A valid name-based CA-signed certificate (from a trusted Certificate Authority)
- A name-based temporary certificate that meets the requirements described below

Note
Ensure DNS can also resolve all name-based certificates.

CAS Temporary Certificate Requirements for SSL Connection to Mac OS X Agent

If using a temporary certificate for the CAS, make sure the following are in place:

Step 1
The CAS/CAM must use a fully qualified domain name (FQDN) as the “subject” DN on the certificate (this is the “Full Domain Name or IP” on the CAS/CAM console). An IP address is not allowed. This may require regenerating the certificate on your CAS. (See Generate Temporary Certificate, page 11-12 for details.)

Step 2
On the Mac OS X machine, the root certificate which is used to sign the temporary certificate must be installed in the X509 Anchors in Keychain Access application. To do this, use one of the following set of steps for the Mac OS X version running on the machine:

- Installing the Root Certificate for Mac OS 10.5
- Installing the Root Certificate for Mac OS 10.5

Step 3
The Mac OS X machine must be able to correctly resolve the FQDN name via DNS. There are two approaches to this:

a. Add an entry into the DNS server which the Mac machine is using, or

b. For a test machine:
   1. Enable your root account as described in Enable the Root User on Mac OS X, page 11-26
   2. Edit the /etc/hosts file on the Macintosh client machine by running `sudo vi /etc/hosts` to add a new domain lookup entry.

Caution
Because the CAS/CAM use the full domain name, you cannot use an IP address in the certificate. You must use the domain name instead.

Caution
Make sure your machine's date and time are valid for the certificate. If the current date and time fall out of the range of the certificate, the Agent will not work.
Installing the Root Certificate for Mac OS 10.5

**Note**
You must have administrative permissions on your computer in order to run these steps.

**Step 1**
Download the root certificate to your client machine (or desktop). See Obtaining the Root Certificate from the CAS, page 11-28 for details.

**Step 2**
Click the Finder icon in the Dock.

**Step 3**
From the Go menu, choose Applications.

**Step 4**
Open the Utilities folder.

**Step 5**
Launch the Keychain Access application.

**Figure 11-14 Launch Keychain Access Application on Mac OS 10.5**

**Step 6**
Drag the root certificate to the Keychain Access application.
Chapter 11      Administering CAS Certificates, Time, and Support Logs

Manage CAS SSL Certificates

Figure 11-15     Drag and Drop the Certificate Into the Keychain Access Application on Mac OS 10.5

Step 7   Click **Always Trust** in the Certificate dialog.

Figure 11-16     Certificate Dialog on Mac OS 10.5

Step 8   The root certificate is added (**Figure 11-17**).
Chapter 11  Administering CAS Certificates, Time, and Support Logs

Manage CAS SSL Certificates

**Figure 11-17  Display the New Root Certificate on Mac OS 10.5**

![Keychain Access window showing a new root certificate]

**Enable the Root User on Mac OS X**

**Note**
Ensure you are an administrator on the machine. You must have access to an account that has administrator privileges to perform the rest of these steps.

**Step 1** Click the Finder icon in the Dock.
**Step 2** From the Go menu, choose Applications.
**Step 3** Open the Utilities folder.
**Step 4** Open the NetInfo Manager utility.
**Step 5** Click the lock in the NetInfo Manager window (or go to Security > Authenticate).
**Step 6** Type your administrator account username and password and click OK.
**Step 7** For Mac OS 10.5, launch Applications > Utilities > Directory Utility.app (Figure 11-18) and choose Enable Root User from the Edit menu (Figure 11-19).
Step 8  Type a password for root to enable the root account. If you have not previously set a root password, an alert box may appear that says “NetInfo Error,” indicating that the password is blank. Click **OK**.

Step 9  Type the root password you wish to use and click **Set**.

Step 10  Retype the password for verification and click **Verify**.

Step 11  The root user is now enabled.

Step 12  Click the lock again to prevent changes.

---

**Note**  For additional reference, see [http://docs.info.apple.com/article.html?artnum=106290#one](http://docs.info.apple.com/article.html?artnum=106290#one).

For more information on the Mac OS X Agent, see the “Mac OS X Agent Dialogs” section of the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)*.
Obtaining the Root Certificate from the CAS

Because Internet Explorer allows exporting of the CAS certificate, this section describes how to obtain the root certificate on a Windows system. Administrators can then transfer the certificate to their Mac via email as an attachment, FTP, or USB storage device.

There are three ways to retrieve the root certificate:

- Get the Root Certificate From the Mac OS X Agent Bundle
- Transfer the Root Certificate from Windows Using Internet Explorer
- Use Web Login to Get the Root Certificate

Get the Root Certificate From the Mac OS X Agent Bundle

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In the Finder, go to /Applications/CCA.Agent.app.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Ctrl-click on the CCA.Agent.app to display the context menu.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Choose Show Package Contents and search for the “perfigoca.crt” certificate in the /Contents/Resources/ folder.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Drag and drop the “perfigoca.crt” certificate to the keychain.</td>
</tr>
</tbody>
</table>

For more information, see SSL Requirements for Mac OS X/CAS Communication, page 11-23.

Transfer the Root Certificate from Windows Using Internet Explorer

If the temporary certificate has not yet been installed on the Windows system:

Figure 11-20 illustrates the steps to initially download the temporary certificate.

1. Open an IE browser and enter any address. The browser will redirect to the authentication page for web login.
2. Since the certificate has not been installed, the Security Alert dialog pops up from the browser. Click the View Certificate button in the Security Alert dialog.
3. Click the Details tab in the Certificate window that pops up.
4. Click the Copy to File button in the Details tab
5. Leave format option as DER encoded binary x.509 (.CER) on the Certificate Export Wizard and click Next to save the certificate on the Windows system.
6. Transfer the certificate to your Mac machine.
Figure 11-20  Download Certificate Option 1

If the browser already has the temporary certificate installed:

Figure 11-21 illustrates the steps to download the certificate if already installed on the system.

1. Open the IE browser.
2. Go to Tools > Internet Options. Click the Content tab then the Certificates button.
3. Click the Intermediate Root Certificate Authorities tab in the Certificates window.
4. Highlight the certificate issued by www.perfigo.com and click the Export button.
5. Choose a location on your Windows machine to save the certificate.
6. Transfer the certificate to your Mac machine.
Chapter 11      Administering CAS Certificates, Time, and Support Logs

Manage CAS SSL Certificates

Use Web Login to Get the Root Certificate

Step 1  Change the CAM settings to enable the Root CA Label option (in the Administration > User Pages > Login Page > Edit > Content CAM web console configuration page). This shows the link to download the root certificate from the user login page in the browser.

Step 2  When users open a browser and go to the login page, they will see a link for downloading the root certificate. Instruct users to click on the link and save the “perfigoca.crt” certificate on their local client machine.

Step 3  Obtain the certificate from the user and drag and drop the “perfigoca.crt” certificate to the keychain. For more information, see the guidelines “Administering the CAM” chapter in the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x).
Troubleshooting Certificate Issues

There can be issues with Cisco NAC Appliance certificate management if there are mismatched SSL certificates somewhere along the certificate chain. Common problems on SSL certificates can be time-oriented (if the clocks are not synchronized on the CAM and CAS, authentication fails), IP-oriented (certificates are created for the wrong interface) or information-oriented (wrong or mistyped certificate information is imported). This section describes the following troubleshooting topics:

- **HA Active-Active Situation Due to Expired SSL Certificates**
- **CAS Cannot Establish Secure Connection to CAM**
- **Private Key in Clean Access Server Does Not Match the CA-Signed Certificate**
- **Certificate-Related Files**

**Warning**

If your previous deployment uses a chain of SSL certificates that is incomplete, incorrect, or out of order, CAM/CAS communication may fail after upgrade to release 4.5 and later. You must correct your certificate chain to successfully upgrade to release 4.5 and later. For details on how to fix certificate errors on the CAM/CAS after upgrade to release 4.5 and later, refer to the How to Fix Certificate Errors on the CAM/CAS After Upgrade Troubleshooting Tech Note.

**HA Active-Active Situation Due to Expired SSL Certificates**

HA communication for both HA-CAMs and HA-CASs is handled over IPSec tunnels to secure all communications between the two HA pair appliances. This IPSec tunnel is negotiated based on the SSL certificates uploaded to the HA pairs for both CAM and CAS. In case the SSL certificates are not trusted by the two HA peers, have expired, or are no longer valid, the HA heartbeat communication between the two HA pairs breaks down, leading both HA pair appliances to assume the Active HA-Primary) role.

For CASs deployed in VGW mode, this can potentially create a Layer 2 loop that could bring down the network. HA-CAMs with expired or invalid SSL certificates could lead to an Active-Active situation where the database is not synced between the two HA-CAM appliances. Eventually, this situation leads to the CAMs losing all recent configuration changes and/or all recent user login information following an HA-CAM failover event.

As CAM-CAS communication over IPSec tunnels requires valid SSL certificates on both the CAM and CAS, the CAM-CAS communication also breaks down if the SSL certificate expires on either the CAM or CAS. This situation leads to end user authentications failures and the CAS reverting to failback mode per CAS configuration.

Administrators can minimize HA appliance Active-Active situations due to expired SSL certificates by using SSL certificates with longer validity periods and/or using serial port connection (if available and not used to control another CAM or CAS) for HA heartbeat. However, when you configure HA-CAMs to perform heartbeat functions over the serial link and the primary eth1 interface fails because of SSL certificate expiration, the CAM returns a database error indicating that it cannot sync with its HA peer and the administrator receives a “WARNING! Closed connections to peer [standby IP] database! Please restart peer node to bring databases in sync!!” error message in the CAM web console:

**Note**

Starting with Cisco NAC Appliance Release 4.8, the CAM or CAS generates event log messages to indicate the certificate expiry in addition to the message displayed in the CAM/CAS web console.
CAS Cannot Establish Secure Connection to CAM

If clients attempting login get the following error message, “Clean Access Server could not establish a secure connection to the Clean Access Manager at <IPaddress or domain>,” this commonly indicates one of the following issues:

- The time difference between the CAM and CAS is greater than 5 minutes.
- Invalid IP address
- Invalid domain name
- CAM is unreachable

The time set on the CAM and the CAS must be 5 minutes apart or less. To resolve this issue:

1. Set the time on the CAM and CAS correctly first (see Synchronize System Time, page 11-38)
2. Regenerate the certificate on the CAS using the correct IP address or domain.
3. Reboot the CAS.
4. Regenerate the certificate on the CAM using the correct IP address or domain.
5. Reboot the CAM.

Note

If you check `nslookup` and `date` from the CAS, and both the DNS and TIME settings on the CAS are correct, this can indicate that the caCerts file on the CAS is corrupted. In this case, Cisco recommends backing up the existing caCerts file from `/usr/java/j2sdk1.4/lib/security/caCerts`, overriding it with the file from `/perfigo/common/conf/caCerts`, then performing “service perfigo restart” on the CAS.

Private Key in Clean Access Server Does Not Match the CA-Signed Certificate

This issue can arise if a new temporary certificate is generated but a CA-signed certificate is returned for the CSR (certificate signing request) generated from a previous temporary certificate and Private Key pair.

For example, an administrator generates a CSR, backs up the Private Key, and then sends the CSR to a CA authority, such as VeriSign.

Subsequently, another administrator regenerates a temporary certificate after the CSR has been sent. When the CA-signed certificate is returned from the CA authority, the Private Key on which the CA-certificate is based no longer matches the one in the Clean Access Server.

To resolve this issue, re-import the old Private Key and then install the CA-signed certificate.

Certificate-Related Files

For troubleshooting purposes, Table 11-1 lists certificate-related files on the Clean Access Server. For example, if the admin console becomes unreachable due to a mismatch of the CA-certificate/Private Key combination, these files may need to be modified directly in the file system of the Clean Access Server.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/root/.tomcat.key</td>
<td>Private key</td>
</tr>
<tr>
<td>/root/.tomcat.crt</td>
<td>Certificate</td>
</tr>
</tbody>
</table>
You can configure the Clean Access Server to be managed/monitored by an SNMP management tool (such as HP OpenView). This feature provides minimal manageability using SNMP (v1).

**Note**
When management VLAN is set for CAS Eth0 interface, the SNMP management for CAS is not supported. In Virtual Gateway mode, it is mandatory to set the management VLAN. Hence SNMP management for CAS is not supported in the Virtual Gateway mode.

The SNMP settings can be configured in the Clean Access Manager. The settings are globally applied to all the Clean Access Servers connected to the Clean Access Manager. If you want to change the settings of a specific Clean Access Server, you can specify the settings using any one of the following:

- In the CAM web console, go to **Device Management > CCA Servers > Manage [CAS_IP] > Advanced > SNMP** and modify the configuration. Refer to the *Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x)* for more details.

  [OR]

- In the CAS web console, navigate to **Administration > SNMP** and modify the configuration. See **Enable SNMP Polling/Alerts, page 11-34**.

Clicking the **Enable** button preceding **SNMP on NAC Server** under **Administration > SNMP** activates the following features:

- **SNMP Polling**—If an SNMP community ("Read-only community") string is specified, the Clean Access Server will respond to *snmpget* and *snmpwalk* requests with the correct community string.

- **SNMP Traps**—The Clean Access Servers can be configured to send traps by adding trap sinks. A trap sink is any computer configured to receive traps, typically a management box. All traps sent are version 1 (v1) traps. A copy of each trap will be sent to each trap sink.

When enabled, the SNMP module monitors the following processes:

- SSH Daemon
- Java Process
- Apache Web Server process
- Clean Access Server

The Clean Access Server also sends traps in the following cases:

- When Clean Access Server shuts down.
- When Clean Access Server becomes Active.
- When Clean Access Server becomes Standby.
- When there is Linkup and Linkdown of interfaces.

### Table 11-1 Clean Access Server Certificate-Related Files (continued)

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/root/.tomcat.req</td>
<td>Certificate Signing Request</td>
</tr>
<tr>
<td>/root/.chain.crt</td>
<td>Intermediate certificate</td>
</tr>
<tr>
<td>/root/.perfigo/caCerts</td>
<td>The root CA bundle</td>
</tr>
</tbody>
</table>

**SNMP**
Enable SNMP Polling/Alerts

Step 1  Go to Administration > SNMP to bring up the SNMP configuration page (Figure 11-22).

Figure 11-22  Administration > SNMP Page

![Administration > SNMP Page]

Note: SNMP configuration with new thresholds

Step 2  Check the Override Global Settings checkbox and click Update to override the configuration settings that have already been specified in the Clean Access Manager.

Step 3  Click the Enable button preceding SNMP on NAC Servers to activate the SNMP polling and SNMP traps.

Step 4  Specify values for the following fields:

- **Read-Only Community String:**
  Specify a string to enable the Clean Access Server to respond to snmpget and snmpwalk requests with the correct community string. Leave this field blank to disable all Clean Access Server responses to SNMP polling of the Clean Access Server.
- **Disk Trap Threshold %** (default is 50%)
  A trap will be sent when root partition free space falls below specified percentage.

- **One-Minute Load Average Threshold**: (default is 3.0)
  A trap will be sent when the one-minute load average exceeds the threshold set here. Enter load averages as per standard unix definition.

- **Five-Minute Load Average Threshold**: (default is 2.0)
  A trap will be sent when the 5-minute load average exceeds the threshold set here. Enter load averages as per standard unix definition.

- **Fifteen-Minute Load Average Threshold**: (default is 1.0)
  A trap will be sent when the 15-minute load average exceeds the threshold set here. Enter load averages as per standard unix definition.

- **Swap Threshold**: (default is 50%)
  A trap will be sent when swap partition free space falls below specified percentage.

**Step 5**
Click **Update** to update the SNMP configuration with new thresholds.

---

### Add New Trapsink

The Clean Access Server can be configured to send traps by adding trap sinks. All traps sent are version 1 (v1) traps. A copy of each trap will be sent to each trapsink.

**Step 1**
Click the **Add New Trapsink** link in the upper-right-hand corner of the pane to bring up the Add New Trapsink form as shown in Figure 11-23.
Figure 11-23   Add New Trapsink

Step 2 Enter a Trapsink IP.
Step 3 Enter a Trapsink Community string.
Step 4 Enter an optional Trapsink Description.
Step 5 Click Update to update the SNMP Trapsink table.

Once trapsink configuration is complete, the Clean Access Server will send DISMAN-EVENT style traps which refer to UCD table entries. The Clean Access Server also sends traps if the root partition falls below a configured amount of space remaining (which defaults to 50%), and if the CPU load is above the configured amount for 1, 5 or 15 minutes.
A trap will contain the following contents:

<table>
<thead>
<tr>
<th>Trap Contents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type: Enterprise-Specific(1)</td>
<td></td>
</tr>
<tr>
<td>SNMP Trap OID (1.3.6.1.6.3.1.1.4.1.0)</td>
<td>Set to DISMAN-EVENT-MIB 2.0.1 (1.3.6.1.2.1.88.2.0.1)</td>
</tr>
<tr>
<td>The contents of a DISMAN mteObjectsEntry:</td>
<td></td>
</tr>
<tr>
<td>mteHotTrigger (OID 1.3.6.1.2.1.88.2.1.1)</td>
<td>Generally:</td>
</tr>
<tr>
<td></td>
<td>“process table” for processes</td>
</tr>
<tr>
<td></td>
<td>“laTable” for load average alerts</td>
</tr>
<tr>
<td></td>
<td>“dskTable” for disk capacity alerts</td>
</tr>
<tr>
<td></td>
<td>“memory” for virtual memory alerts</td>
</tr>
<tr>
<td>mteHotTargetName (OID 1.3.6.1.2.1.88.2.1.2)</td>
<td>Always blank.</td>
</tr>
<tr>
<td>mteHotContextName (OID 1.3.6.1.2.1.88.2.1.3)</td>
<td>Always blank.</td>
</tr>
<tr>
<td>mteHotOID (OID 1.3.6.1.2.1.88.2.1.4)</td>
<td>Set to the OID of the UCD table that contains the data that triggered the event.</td>
</tr>
<tr>
<td>mteHotValue (OID 1.3.6.1.2.1.88.2.1.5)</td>
<td>Set to 0 if the trap is not an error</td>
</tr>
<tr>
<td></td>
<td>Set to non-zero if an error condition is being reported (generally 1).</td>
</tr>
<tr>
<td>mteFailedReason (OID 1.3.6.1.2.1.88.2.1.6)</td>
<td>Set to a string describing the reason the alert was sent.</td>
</tr>
</tbody>
</table>
System Upgrade

You can upgrade from Release 4.9(x) and 4.8(x) to Release 4.9(5) by uploading a .tar.gz upgrade file to the CAM/CAS and executing an upgrade script using the appliance’s CLI. For complete upgrade details, including instructions for upgrading HA CASs and upgrades via SSH, see the “Upgrading” section of the corresponding Release Notes for Cisco NAC Appliance.

Step 1 Choose Administration > Software Upload.

Step 2 Download the 4.9(5) .tar.gz upgrade image to your local machine from the Cisco Software Download Site as described in the “Upgrading” section of the corresponding Release Notes for Cisco NAC Appliance.

a. In the Software Upload page, click Browse to navigate to the directory where you have stored the 4.9(5) .tar.gz upgrade file.

b. Click Upload. After a brief time, the web console screen automatically refreshes, displaying the newly uploaded upgrade image and the date/time when it was uploaded to the CAS.

You can use the Notes link that appears after the image file name to view important information about the .tar.gz upgrade image.

Step 3 To view upgrade log information, click on the link under List of Upgrade Logs to launch a browser window displaying a brief summary of the upgrade process including the date and time the upgrade was performed.

Step 4 To view important upgrade process details, click on the link under List of Upgrade Details to launch a browser window displaying the details of the upgrade process, in the following format:

- State before upgrade
- Upgrade process details
- State after upgrade

It is normal for the “state before upgrade” to contain several warning/error messages (e.g. “INCORRECT”). The “state after upgrade” should be free of any warning or error messages.

You can also use the CAM web console Device Management > CCA Servers > Manage [CAS_IP] > Misc > Upgrade Logs page to view the CAS software upgrade notes:

- Click on the link under List of Upgrade Logs to view a brief summary of the upgrade process including the date and time it was performed.
- Click on the link under List of Upgrade Details to view the details of the upgrade process.

Synchronize System Time

For logging purposes and other time-sensitive tasks (such as SSL certificate generation), the time on the Clean Access Manager and Clean Access Servers needs to be correctly synchronized. The Time form lets you set the time on the Clean Access Server and modify the time zone setting for the CAS operating system.
After CAM and CAS installation, you should synchronize the time on the CAM and CAS before regenerating a temporary certificate on which a Certificate Signing Request (CSR) will be based. The easiest way to ensure this is to automatically synchronize time with the time server (Sync Current Time button).

**Note**
The time set on the CAS must fall within the creation date/expiry date range set on the CAM SSL certificate. The time set on the user machine must fall within the creation date/expiry date range set on the CAS SSL certificate.

**Note**
For High Availability CAS pairs, any CAS network setting changes performed on an HA-Primary CAS through the CAS management pages or CAS direct access web console must also be repeated on the standby CAS unit through its direct access web console. These settings include updating the SSL certificate, system time/time zone, DNS, or Service IP. See Clean Access Server Direct Access Web Console, page 11-2 and the Cisco NAC Appliance Hardware Installation Guide, Release 4.9(x) for details.

The time can be modified on the CAM under Administration > CCA Manager > System Time. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for details.

To view the current time:

**Step 1** Go to Device Management > CCA Servers > Manage [CAS_IP] > Misc > Time.

**Step 2** The system time for the Clean Access Server appears in the Current Time field.

**Figure 11-24 Time Form**

There are two ways to adjust the system time—manually, by typing in the new time, or automatically, by synchronizing from an external time server.

**To manually modify the system time:**
Go to the Time form of the Misc tab and perform one of the following steps:
Support Logs and LogLevel Settings

The Support Logs page on the Clean Access Server is intended to facilitate TAC support of customer issues. The Support Logs page allows administrators to combine a variety of system logs (such as information on open files, open handles, and packages) into one tarball that can be sent to TAC to be included in the support case. Administrators should download these support logs when sending their customer support request.
The **Support Logs** page on the CAS direct access web console *(Figure 11-25)* allows you to configure the level of log detail recorded for troubleshooting purposes in `/perfigo/access/tomcat/logs/nac_server.log`. These web controls are intended as alternatives to using the CLI `loglevel` command to gather system information when troubleshooting.

For normal operation, the log level should always remain at the default setting (INFO). The log level is only changed temporarily for a specific troubleshooting time period—typically at the request of the customer support/TAC engineer. In most cases, the setting is switched from INFO to DEBUG for a specific interval, then reset to INFO after data is collected. Note that once you reboot the CAS, or perform the `service perfigo restart` command, the log level returns to the default setting (INFO).

---

**Note**

Cisco recommends using the DEBUG and TRACE options only temporarily for very specific issues. Although the CAM records logging information and stores them in a series of nine 20MB files before discarding any old logs, the large amount of logging information can cause the CAM to run out of available log storage space in a relatively short amount of time.

---

**Note**

To optimize memory usage, CAS support logs pages are only available from the CAS direct access console under “Monitoring.” (They are not available from the CAS management pages.)

---

**Downloading CAS Support Logs**

1. **Step 1**
   Open the CAS direct access console from a browser using `https://<CAS_eth0_IP_address>/admin` as the URL/Address.

2. **Step 2**
   Choose Monitoring > Support Logs *(Figure 11-25).*
Step 3  Specify the number of days of debug messages to include in the file you will download for your Cisco customer support request.

Step 4  Click the Download button to download the cas_logs.<CAS_IP_address>.tar.gz file to your local computer.

Step 5  Send this .tar.gz file with your customer support request.

Note  To retrieve the compressed support logs file for the Clean Access Manager, go to Administration > CCA Manager > Support Logs. See the Cisco NAC Appliance - Clean Access Manager Configuration Guide, Release 4.9(x) for details.

If requested to do so by the TAC engineer, you can temporarily change the loglevel to obtain more troubleshooting details prior to downloading the support logs.

To change the LogLevel for CAS logs:

Step 1  Open the CAS direct access console (https://<CAS_eth0_IP_address>/admin).

Step 2  Go to Monitoring > Support Logs.
Step 3  Choose the CAS log category to change:

- **CCA Server General Logging**: This category contains general logging events for this CAS not contained in the other three categories listed below. For example a user that logs in (needs to post request to the CAM) will be logged here.

- **CAS/CAM Communication Logging**: This category contains the majority of relevant logs: CAM/CAS configuration or communication errors specific to this CAS. For example, if the CAM’s attempt to publish information to this CAS fails, the event will be logged here.

- **Active Directory Communication Logging**: This category contains logging information involving Active Directory events to support user Single Sign-On and credential look-up.

- **SWISS Communication Logging**: This category contains log events related to SWISS (proprietary communication protocol) packets sent between this CAS and the Agent.

### Note
To discover the CAS, the Agent sends SWISS (proprietary CAS-Agent communication protocol) packets on UDP port 8905 for Layer 2 users and port 8906 for Layer 3 users. The CAS always listens on UDP port 8905 and 8906 and accepts traffic on port 8905 by default. The CAS will drop traffic on UDP port 8906 unless Layer 3 support is enabled. The Agent performs SWISS discovery every 5 seconds by default.

- **Radius Accounting Proxy Server Logging**: This category contains RADIUS accounting log events related to Single Sign-On (SSO) for this CAS when integrated with a Cisco VPN Server.

Step 4  Click the LogLevel setting for the category of log:

- **OFF**: No log events are recorded for this category.

- **ERROR**: A log event is written to /perfigo/access/tomcat/logs for the CAS, and /perfigo/control/tomcat/logs for the CAM only if the system encounters a severe error, such as:
  - CAS cannot connect to CAM
  - CAS and CAM cannot communicate
  - CAS cannot communicate with database

- **WARN**: Records only error and warning level messages for the given category.

- **INFO**: Provides more details than the ERROR and WARN log levels. For example, if a user logs in successfully an Info message is logged. This is the default level of logging for the system.

- **DEBUG**: Records all debug-level logs for the CAS.

- **TRACE**: This is the maximum amount of log information available to help troubleshoot issues with the CAM/CAS.

Step 5  Click **Update** to save the settings.

### Note
Cisco recommends using the **DEBUG** and **TRACE** options only temporarily for very specific issues. Although the CAM records logging information and stores them in a series of nine 20MB files before discarding any old logs, the large amount of logging information can cause the CAM to run out of available log storage space in a relatively short amount of time.
Filtering logs by CAS and/or agent IP

In Cisco NAC Appliance Release 4.9 and later, you can filter the CAS Logs by Agent machine, by specifying the IP Addresses.

Under **Filter by (Change log level for) Agent IP Address**, enter the following:

- **Agent IP Address**: Enter the IP Address of the specific client machine.

  **Note**
  You can enter more than one IP Address by separating them with a comma. You can include the range of IP Addresses as well. For example, you can enter the IP Address as *10.10.10.10,10.10.10.15-20*.

- **Log at Level**: Choose the log level.

  **Note**
  To enable the Filter by CAS / Agent option, set the log levels of all the other categories to **OFF**.

Click **Update Filter** to save the settings. Now the downloaded support logs contain information related to the specified Agent.
MIB Support

This chapter lists Objects and Object Identifiers (OIDs) for the Management Information Base (MIBs) supported by Clean Access Manager.

- CLEAN ACCESS - MIB
- SNMPv2-MIB
- RFC1213-MIB
- IP-MIB
- UDP-MIB
- HOST-RESOURCES-MIB
- MTA-MIB
- IF-MIB
- DISMAN-EVENT-MIB
- NOTIFICATION-LOG-MIB
- UCD-SNMP-MIB
- UCD-DLMOD-MIB
- NET-SNMP-AGENT-MIB
- SNMPv2-SMI
- SNMP-FRAMEWORK-MIB
- SNMP-MPD-MIB
- SNMP-TARGET-MIB
- SNMP-USER-BASED-SM-MIB
- SNMP-VIEW-BASED-ACM-MIB

Table A-1  CLEAN ACCESS - MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>hostname</td>
<td>1.3.6.1.4.1.16344.1.1.0</td>
<td>Hostname of the Clean Access Manager</td>
</tr>
<tr>
<td>cleanaccessIpAddr</td>
<td>1.3.6.1.4.1.16344.1.2.0</td>
<td>The IP address that the web console is bound to</td>
</tr>
</tbody>
</table>
### Table A-1  CLEAN ACCESS - MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cleanaccessPort</td>
<td>1.3.6.1.4.1.16344.1.3.0</td>
<td>The port, the web management console is listening on</td>
</tr>
<tr>
<td>versionString</td>
<td>1.3.6.1.4.1.16344.1.4.0</td>
<td>Version of Software running on the Clean Access Manager</td>
</tr>
<tr>
<td>cleanaccessServerCount</td>
<td>1.3.6.1.4.1.16344.1.5.0</td>
<td>Number of Clean Access Servers managed by this Clean Access Manager</td>
</tr>
<tr>
<td>alertCount</td>
<td>1.3.6.1.4.1.16344.1.6.0</td>
<td>Number of Alerts</td>
</tr>
<tr>
<td>cleanaccessServerTable</td>
<td>1.3.6.1.4.1.16344.1.7</td>
<td></td>
</tr>
<tr>
<td>cleanaccessServerEntry</td>
<td>1.3.6.1.4.1.16344.1.7.1</td>
<td></td>
</tr>
<tr>
<td>cleanaccessServerTableIndex</td>
<td>1.3.6.1.4.1.16344.1.7.1.1</td>
<td>A number identifying this cleanaccessServerTable entry</td>
</tr>
<tr>
<td>cleanaccessServerTableIpAddresss</td>
<td>1.3.6.1.4.1.16344.1.7.1.2</td>
<td>The IP address of the Clean Access Server</td>
</tr>
<tr>
<td>cleanaccessServerTableLocation</td>
<td>1.3.6.1.4.1.16344.1.7.1.3</td>
<td>The location of Clean Access Server</td>
</tr>
<tr>
<td>cleanaccessServerTableVersion</td>
<td>1.3.6.1.4.1.16344.1.7.1.4</td>
<td>Clean Access Server version</td>
</tr>
<tr>
<td>cleanaccessServerTableType</td>
<td>1.3.6.1.4.1.16344.1.7.1.5</td>
<td>The deployment type of the Clean Access Server</td>
</tr>
<tr>
<td>cleanaccessServerTableRowStatus</td>
<td>1.3.6.1.4.1.16344.1.7.1.6</td>
<td>An existing row in the table</td>
</tr>
<tr>
<td>nodeActive</td>
<td>1.3.6.1.4.1.16344.0.8</td>
<td>Alert sent when this node becomes active in High Availability mode</td>
</tr>
<tr>
<td>nodeStandby</td>
<td>1.3.6.1.4.1.16344.0.9</td>
<td>Alert sent when this node becomes standby in High Availability mode</td>
</tr>
<tr>
<td>nodeShutdown</td>
<td>1.3.6.1.4.1.16344.0.10</td>
<td>Alert sent when this node is being administratively shutdown</td>
</tr>
<tr>
<td>adssosStarted</td>
<td>1.3.6.1.4.1.16344.0.11</td>
<td>ADSSO service started</td>
</tr>
<tr>
<td>adssoStopped</td>
<td>1.3.6.1.4.1.16344.0.12</td>
<td>ADSSO service stopped</td>
</tr>
</tbody>
</table>

### Objects not supported in Clean Access- MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>alertTable</td>
<td>1.3.6.1.4.1.16344.1.8</td>
</tr>
<tr>
<td>alertEntry</td>
<td>1.3.6.1.4.1.16344.1.8.1</td>
</tr>
<tr>
<td>alertTableIndex</td>
<td>1.3.6.1.4.1.16344.1.8.1.1</td>
</tr>
<tr>
<td>alertTableType</td>
<td>1.3.6.1.4.1.16344.1.8.1.2</td>
</tr>
<tr>
<td>alertTableTime</td>
<td>1.3.6.1.4.1.16344.1.8.1.3</td>
</tr>
<tr>
<td>alertTableStatus</td>
<td>1.3.6.1.4.1.16344.1.8.1.4</td>
</tr>
</tbody>
</table>
### Table A-1  CLEAN ACCESS - MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>alertTableText</td>
<td>1.3.6.1.4.1.16344.1.8.1.5</td>
<td></td>
</tr>
<tr>
<td>alertTableRowStatus</td>
<td>1.3.6.1.4.1.16344.1.8.1.6</td>
<td></td>
</tr>
</tbody>
</table>

### Table A-2  SNMPv2-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>sysDescr</td>
<td>1.3.6.1.2.1.1.1</td>
<td></td>
</tr>
<tr>
<td>sysObjectID</td>
<td>1.3.6.1.2.1.1.2</td>
<td></td>
</tr>
<tr>
<td>sysUpTime</td>
<td>1.3.6.1.2.1.1.3</td>
<td></td>
</tr>
<tr>
<td>sysContact</td>
<td>1.3.6.1.2.1.1.4</td>
<td></td>
</tr>
<tr>
<td>sysName</td>
<td>1.3.6.1.2.1.1.5</td>
<td></td>
</tr>
<tr>
<td>sysLocation</td>
<td>1.3.6.1.2.1.1.6</td>
<td></td>
</tr>
<tr>
<td>sysORLastChange</td>
<td>1.3.6.1.2.1.1.8</td>
<td></td>
</tr>
<tr>
<td>sysORID</td>
<td>1.3.6.1.2.1.1.9.1.2</td>
<td></td>
</tr>
<tr>
<td>sysORDescr</td>
<td>1.3.6.1.2.1.1.9.1.3</td>
<td></td>
</tr>
<tr>
<td>sysORUpTime</td>
<td>1.3.6.1.2.1.1.9.1.4</td>
<td></td>
</tr>
</tbody>
</table>

### Table A-3  RFC1213-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ifNumber</td>
<td>1.3.6.1.2.1.2.1</td>
<td></td>
</tr>
<tr>
<td>ifIndex</td>
<td>1.3.6.1.2.1.2.2.1.1</td>
<td></td>
</tr>
<tr>
<td>ifDescr</td>
<td>1.3.6.1.2.1.2.2.1.2</td>
<td></td>
</tr>
<tr>
<td>ifType</td>
<td>1.3.6.1.2.1.2.2.1.3</td>
<td></td>
</tr>
<tr>
<td>ifMtu</td>
<td>1.3.6.1.2.1.2.2.1.4</td>
<td></td>
</tr>
<tr>
<td>ifSpeed</td>
<td>1.3.6.1.2.1.2.2.1.5</td>
<td></td>
</tr>
<tr>
<td>ifPhysAddress</td>
<td>1.3.6.1.2.1.2.2.1.6</td>
<td></td>
</tr>
<tr>
<td>ifAdminStatus</td>
<td>1.3.6.1.2.1.2.2.1.7</td>
<td></td>
</tr>
<tr>
<td>ifOperStatus</td>
<td>1.3.6.1.2.1.2.2.1.8</td>
<td></td>
</tr>
<tr>
<td>ifLastChange</td>
<td>1.3.6.1.2.1.2.2.1.9</td>
<td></td>
</tr>
<tr>
<td>ifInOctets</td>
<td>1.3.6.1.2.1.2.2.1.10</td>
<td></td>
</tr>
<tr>
<td>ifInUcastPkts</td>
<td>1.3.6.1.2.1.2.2.1.11</td>
<td></td>
</tr>
<tr>
<td>ifInNUcastPkts</td>
<td>1.3.6.1.2.1.2.2.1.12</td>
<td></td>
</tr>
<tr>
<td>ifInDiscards</td>
<td>1.3.6.1.2.1.2.2.1.13</td>
<td></td>
</tr>
<tr>
<td>ifInErrors</td>
<td>1.3.6.1.2.1.2.2.1.14</td>
<td></td>
</tr>
<tr>
<td>ifInUnknownProtos</td>
<td>1.3.6.1.2.1.2.2.1.15</td>
<td></td>
</tr>
<tr>
<td>ifOutOctets</td>
<td>1.3.6.1.2.1.2.2.1.16</td>
<td></td>
</tr>
</tbody>
</table>
### RFC1213-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ifOutUcastPkts</td>
<td>1.3.6.1.2.1.2.2.1.17</td>
</tr>
<tr>
<td>ifOutNUcastPkts</td>
<td>1.3.6.1.2.1.2.2.1.18</td>
</tr>
<tr>
<td>ifOutDiscards</td>
<td>1.3.6.1.2.1.2.2.1.19</td>
</tr>
<tr>
<td>ifOutErrors</td>
<td>1.3.6.1.2.1.2.2.1.20</td>
</tr>
<tr>
<td>ifOutQLen</td>
<td>1.3.6.1.2.1.2.2.1.21</td>
</tr>
<tr>
<td>ifSpecific</td>
<td>1.3.6.1.2.1.2.2.1.22</td>
</tr>
</tbody>
</table>

### IP-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ipForwarding</td>
<td>1.3.6.1.2.1.4.1</td>
</tr>
<tr>
<td>ipDefaultTTL</td>
<td>1.3.6.1.2.1.4.2</td>
</tr>
<tr>
<td>ipInReceives</td>
<td>1.3.6.1.2.1.4.3</td>
</tr>
<tr>
<td>ipInHdrErrors</td>
<td>1.3.6.1.2.1.4.4</td>
</tr>
<tr>
<td>ipInAddrErrors</td>
<td>1.3.6.1.2.1.4.5</td>
</tr>
<tr>
<td>ipForwDatagrams</td>
<td>1.3.6.1.2.1.4.6</td>
</tr>
<tr>
<td>ipInUnknownProtos</td>
<td>1.3.6.1.2.1.4.7</td>
</tr>
<tr>
<td>ipInDiscards</td>
<td>1.3.6.1.2.1.4.8</td>
</tr>
<tr>
<td>ipInDelivers</td>
<td>1.3.6.1.2.1.4.9</td>
</tr>
<tr>
<td>ipOutRequests</td>
<td>1.3.6.1.2.1.4.10</td>
</tr>
<tr>
<td>ipOutDiscards</td>
<td>1.3.6.1.2.1.4.11</td>
</tr>
<tr>
<td>ipOutNoRoutes</td>
<td>1.3.6.1.2.1.4.12</td>
</tr>
<tr>
<td>ipReasmTimeout</td>
<td>1.3.6.1.2.1.4.13</td>
</tr>
<tr>
<td>ipReasmReqsds</td>
<td>1.3.6.1.2.1.4.14</td>
</tr>
<tr>
<td>ipReasmOKs</td>
<td>1.3.6.1.2.1.4.15</td>
</tr>
<tr>
<td>ipReasmFails</td>
<td>1.3.6.1.2.1.4.16</td>
</tr>
<tr>
<td>ipFragOKs</td>
<td>1.3.6.1.2.1.4.17</td>
</tr>
<tr>
<td>ipFragFails</td>
<td>1.3.6.1.2.1.4.18</td>
</tr>
<tr>
<td>ipFragCreates</td>
<td>1.3.6.1.2.1.4.19</td>
</tr>
<tr>
<td>ipAdEntAddr</td>
<td>1.3.6.1.2.1.4.20.1.1</td>
</tr>
<tr>
<td>ipAdEntIfIndex</td>
<td>1.3.6.1.2.1.4.20.1.2</td>
</tr>
<tr>
<td>ipAdEntNetMask</td>
<td>1.3.6.1.2.1.4.20.1.3</td>
</tr>
<tr>
<td>ipAdEntBcastAddr</td>
<td>1.3.6.1.2.1.4.20.1.4</td>
</tr>
<tr>
<td>ipRouteDest</td>
<td>1.3.6.1.2.1.4.21.1.1</td>
</tr>
<tr>
<td>ipRouteIfIndex</td>
<td>1.3.6.1.2.1.4.21.1.2</td>
</tr>
<tr>
<td>ipRouteMetric1</td>
<td>1.3.6.1.2.1.4.21.1.3</td>
</tr>
<tr>
<td>ipRouteNextHop</td>
<td>1.3.6.1.2.1.4.21.1.7</td>
</tr>
</tbody>
</table>
### Table A-4  IP-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ipRouteType</td>
<td>1.3.6.1.2.1.4.21.1.8</td>
</tr>
<tr>
<td>ipRouteProto</td>
<td>1.3.6.1.2.1.4.21.1.9</td>
</tr>
<tr>
<td>ipRouteMask</td>
<td>1.3.6.1.2.1.4.21.1.11</td>
</tr>
<tr>
<td>ipRouteInfo</td>
<td>1.3.6.1.2.1.4.21.1.13</td>
</tr>
<tr>
<td>ipNetToMediaIfIndex</td>
<td>1.3.6.1.2.1.4.22.1.1</td>
</tr>
<tr>
<td>ipNetToMediaPhysAddress</td>
<td>1.3.6.1.2.1.4.22.1.2</td>
</tr>
<tr>
<td>ipNetToMediaNetAddress</td>
<td>1.3.6.1.2.1.4.22.1.3</td>
</tr>
<tr>
<td>ipNetToMediaType</td>
<td>1.3.6.1.2.1.4.22.1.4</td>
</tr>
<tr>
<td>ipRoutingDiscards</td>
<td>1.3.6.1.2.1.4.23</td>
</tr>
<tr>
<td>ipCidrRouteDest</td>
<td>1.3.6.1.2.1.4.24.4.1.1</td>
</tr>
<tr>
<td>ipCidrRouteMask</td>
<td>1.3.6.1.2.1.4.24.4.1.2</td>
</tr>
<tr>
<td>ipCidrRouteTos</td>
<td>1.3.6.1.2.1.4.24.4.1.3</td>
</tr>
<tr>
<td>ipCidrRouteNextHop</td>
<td>1.3.6.1.2.1.4.24.4.1.4</td>
</tr>
<tr>
<td>ipCidrRouteIfIndex</td>
<td>1.3.6.1.2.1.4.24.4.1.5</td>
</tr>
<tr>
<td>ipCidrRouteType</td>
<td>1.3.6.1.2.1.4.24.4.1.6</td>
</tr>
<tr>
<td>ipCidrRouteProto</td>
<td>1.3.6.1.2.1.4.24.4.1.7</td>
</tr>
<tr>
<td>ipCidrRouteInfo</td>
<td>1.3.6.1.2.1.4.24.4.1.9</td>
</tr>
<tr>
<td>ipCidrRouteNextHopAS</td>
<td>1.3.6.1.2.1.4.24.4.1.10</td>
</tr>
<tr>
<td>ipCidrRouteMetric1</td>
<td>1.3.6.1.2.1.4.24.4.1.11</td>
</tr>
<tr>
<td>ipCidrRouteMetric2</td>
<td>1.3.6.1.2.1.4.24.4.1.12</td>
</tr>
<tr>
<td>ipCidrRouteMetric3</td>
<td>1.3.6.1.2.1.4.24.4.1.13</td>
</tr>
<tr>
<td>ipCidrRouteMetric4</td>
<td>1.3.6.1.2.1.4.24.4.1.14</td>
</tr>
<tr>
<td>ipCidrRouteMetric5</td>
<td>1.3.6.1.2.1.4.24.4.1.15</td>
</tr>
<tr>
<td>ipCidrRouteStatus</td>
<td>1.3.6.1.2.1.4.24.4.1.16</td>
</tr>
<tr>
<td>inetCidrRouteNumber</td>
<td>1.3.6.1.2.1.4.24.6</td>
</tr>
<tr>
<td>inetCidrRouteIfIndex</td>
<td>1.3.6.1.2.1.4.24.7.1.7</td>
</tr>
<tr>
<td>inetCidrRouteType</td>
<td>1.3.6.1.2.1.4.24.7.1.8</td>
</tr>
<tr>
<td>inetCidrRouteProto</td>
<td>1.3.6.1.2.1.4.24.7.1.9</td>
</tr>
<tr>
<td>inetCidrRouteAge</td>
<td>1.3.6.1.2.1.4.24.7.1.10</td>
</tr>
<tr>
<td>inetCidrRouteNextHopAS</td>
<td>1.3.6.1.2.1.4.24.7.1.11</td>
</tr>
<tr>
<td>inetCidrRouteMetric1</td>
<td>1.3.6.1.2.1.4.24.7.1.12</td>
</tr>
<tr>
<td>inetCidrRouteMetric2</td>
<td>1.3.6.1.2.1.4.24.7.1.13</td>
</tr>
<tr>
<td>inetCidrRouteMetric3</td>
<td>1.3.6.1.2.1.4.24.7.1.14</td>
</tr>
<tr>
<td>inetCidrRouteMetric4</td>
<td>1.3.6.1.2.1.4.24.7.1.15</td>
</tr>
<tr>
<td>inetCidrRouteMetric5</td>
<td>1.3.6.1.2.1.4.24.7.1.16</td>
</tr>
<tr>
<td>inetCidrRouteStatus</td>
<td>1.3.6.1.2.1.4.24.7.1.17</td>
</tr>
</tbody>
</table>
### Table A-4  IP-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ipv4InterfaceTableLastChange</td>
<td>1.3.6.1.2.1.4.27</td>
</tr>
<tr>
<td>ipv4InterfaceReasmMaxSize</td>
<td>1.3.6.1.2.1.4.28.1.2</td>
</tr>
<tr>
<td>ipv4InterfaceEnableStatus</td>
<td>1.3.6.1.2.1.4.28.1.3</td>
</tr>
<tr>
<td>ipv4InterfaceRetransmitTime</td>
<td>1.3.6.1.2.1.4.28.1.4</td>
</tr>
<tr>
<td>ipv6InterfaceTableLastChange</td>
<td>1.3.6.1.2.1.4.29</td>
</tr>
<tr>
<td>ipSystemStatsInReceives</td>
<td>1.3.6.1.2.1.4.31.1.1.3</td>
</tr>
<tr>
<td>ipSystemStatsHCInReceives</td>
<td>1.3.6.1.2.1.4.31.1.1.4</td>
</tr>
<tr>
<td>ipSystemStatsInHdrErrors</td>
<td>1.3.6.1.2.1.4.31.1.1.7</td>
</tr>
<tr>
<td>ipSystemStatsInNoRoutes</td>
<td>1.3.6.1.2.1.4.31.1.1.8</td>
</tr>
<tr>
<td>ipSystemStatsInAddrErrors</td>
<td>1.3.6.1.2.1.4.31.1.1.9</td>
</tr>
<tr>
<td>ipSystemStatsInUnknownProtos</td>
<td>1.3.6.1.2.1.4.31.1.1.10</td>
</tr>
<tr>
<td>ipSystemStatsInTruncatedPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.11</td>
</tr>
<tr>
<td>ipSystemStatsInForwDatagrams</td>
<td>1.3.6.1.2.1.4.31.1.1.12</td>
</tr>
<tr>
<td>ipSystemStatsHCInForwDatagrams</td>
<td>1.3.6.1.2.1.4.31.1.1.13</td>
</tr>
<tr>
<td>ipSystemStatsReasmReqds</td>
<td>1.3.6.1.2.1.4.31.1.1.14</td>
</tr>
<tr>
<td>ipSystemStatsReasmOKs</td>
<td>1.3.6.1.2.1.4.31.1.1.15</td>
</tr>
<tr>
<td>ipSystemStatsReasmFails</td>
<td>1.3.6.1.2.1.4.31.1.1.16</td>
</tr>
<tr>
<td>ipSystemStatsInDiscards</td>
<td>1.3.6.1.2.1.4.31.1.1.17</td>
</tr>
<tr>
<td>ipSystemStatsInDelivers</td>
<td>1.3.6.1.2.1.4.31.1.1.18</td>
</tr>
<tr>
<td>ipSystemStatsHCInDelivers</td>
<td>1.3.6.1.2.1.4.31.1.1.19</td>
</tr>
<tr>
<td>ipSystemStatsOutRequests</td>
<td>1.3.6.1.2.1.4.31.1.1.20</td>
</tr>
<tr>
<td>ipSystemStatsHCOutRequests</td>
<td>1.3.6.1.2.1.4.31.1.1.21</td>
</tr>
<tr>
<td>ipSystemStatsOutNoRoutes</td>
<td>1.3.6.1.2.1.4.31.1.1.22</td>
</tr>
<tr>
<td>ipSystemStatsOutForwDatagrams</td>
<td>1.3.6.1.2.1.4.31.1.1.23</td>
</tr>
<tr>
<td>ipSystemStatsHCOutForwDatagrams</td>
<td>1.3.6.1.2.1.4.31.1.1.24</td>
</tr>
<tr>
<td>ipSystemStatsOutDiscards</td>
<td>1.3.6.1.2.1.4.31.1.1.25</td>
</tr>
<tr>
<td>ipSystemStatsOutFragReqds</td>
<td>1.3.6.1.2.1.4.31.1.1.26</td>
</tr>
<tr>
<td>ipSystemStatsOutFragOKs</td>
<td>1.3.6.1.2.1.4.31.1.1.27</td>
</tr>
<tr>
<td>ipSystemStatsOutFragFails</td>
<td>1.3.6.1.2.1.4.31.1.1.28</td>
</tr>
<tr>
<td>ipSystemStatsOutFragCreates</td>
<td>1.3.6.1.2.1.4.31.1.1.29</td>
</tr>
<tr>
<td>ipSystemStatsOutTransmits</td>
<td>1.3.6.1.2.1.4.31.1.1.30</td>
</tr>
<tr>
<td>ipSystemStatsHCOutTransmits</td>
<td>1.3.6.1.2.1.4.31.1.1.31</td>
</tr>
<tr>
<td>ipSystemStatsInMcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.34</td>
</tr>
<tr>
<td>ipSystemStatsHCInMcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.35</td>
</tr>
<tr>
<td>ipSystemStatsOutMcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.38</td>
</tr>
<tr>
<td>ipSystemStatsHCOutMcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.39</td>
</tr>
</tbody>
</table>
### Table A-4  IP-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ipSystemStatsInBcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.42</td>
</tr>
<tr>
<td>ipSystemStatsHCInBcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.43</td>
</tr>
<tr>
<td>ipSystemStatsOutBcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.44</td>
</tr>
<tr>
<td>ipSystemStatsHCOutBcastPkts</td>
<td>1.3.6.1.2.1.4.31.1.1.45</td>
</tr>
<tr>
<td>ipSystemStatsDiscontinuityTime</td>
<td>1.3.6.1.2.1.4.31.1.1.46</td>
</tr>
<tr>
<td>ipSystemStatsRefreshRate</td>
<td>1.3.6.1.2.1.4.31.1.1.47</td>
</tr>
<tr>
<td>ipIfStatsTableLastChange</td>
<td>1.3.6.1.2.1.4.31.2</td>
</tr>
<tr>
<td>ipAddressPrefixOrigin</td>
<td>1.3.6.1.2.1.4.32.1.5</td>
</tr>
<tr>
<td>ipAddressPrefixOnLinkFlag</td>
<td>1.3.6.1.2.1.4.32.1.6</td>
</tr>
<tr>
<td>ipAddressPrefixAutonomousFlag</td>
<td>1.3.6.1.2.1.4.32.1.7</td>
</tr>
<tr>
<td>ipAddressPrefixAdvPreferredLifetime</td>
<td>1.3.6.1.2.1.4.32.1.8</td>
</tr>
<tr>
<td>ipAddressPrefixAdvValidLifetime</td>
<td>1.3.6.1.2.1.4.32.1.9</td>
</tr>
<tr>
<td>ipAddressIfIndex</td>
<td>1.3.6.1.2.1.4.34.1.3</td>
</tr>
<tr>
<td>ipAddressType</td>
<td>1.3.6.1.2.1.4.34.1.4</td>
</tr>
<tr>
<td>ipAddressPrefix</td>
<td>1.3.6.1.2.1.4.34.1.5</td>
</tr>
<tr>
<td>ipAddressOrigin</td>
<td>1.3.6.1.2.1.4.34.1.6</td>
</tr>
<tr>
<td>ipAddressStatus</td>
<td>1.3.6.1.2.1.4.34.1.7</td>
</tr>
<tr>
<td>ipAddressCreated</td>
<td>1.3.6.1.2.1.4.34.1.8</td>
</tr>
<tr>
<td>ipAddressLastChanged</td>
<td>1.3.6.1.2.1.4.34.1.9</td>
</tr>
<tr>
<td>ipAddressRowStatus</td>
<td>1.3.6.1.2.1.4.34.1.10</td>
</tr>
<tr>
<td>ipAddressStorageType</td>
<td>1.3.6.1.2.1.4.34.1.11</td>
</tr>
<tr>
<td>ipNetToPhysicalPhysAddress</td>
<td>1.3.6.1.2.1.4.35.1.4</td>
</tr>
<tr>
<td>ipNetToPhysicalType</td>
<td>1.3.6.1.2.1.4.35.1.5</td>
</tr>
<tr>
<td>ipNetToPhysicalState</td>
<td>1.3.6.1.2.1.4.35.1.6</td>
</tr>
<tr>
<td>ipNetToPhysicalRowStatus</td>
<td>1.3.6.1.2.1.4.35.1.7</td>
</tr>
<tr>
<td>ipDefaultRouterLifetime</td>
<td>1.3.6.1.2.1.4.37.1.4</td>
</tr>
<tr>
<td>ipDefaultRouterPreference</td>
<td>1.3.6.1.2.1.4.37.1.5</td>
</tr>
</tbody>
</table>

### Table A-5  UDP-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>udpEndpointProcess</td>
<td>1.3.6.1.2.1.7.7.1.8</td>
</tr>
</tbody>
</table>

### Table A-6  HOST-RESOURCES-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>hrSystemUptime</td>
<td>1.3.6.1.2.1.25.1.1</td>
</tr>
<tr>
<td>hrSystemDate</td>
<td>1.3.6.1.2.1.25.1.2</td>
</tr>
<tr>
<td>Object</td>
<td>OID</td>
</tr>
<tr>
<td>---------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>hrSystemInitialLoadDevice</td>
<td>1.3.6.1.2.1.25.1.3</td>
</tr>
<tr>
<td>hrSystemInitialLoadParameters</td>
<td>1.3.6.1.2.1.25.1.4</td>
</tr>
<tr>
<td>hrSystemNumUsers</td>
<td>1.3.6.1.2.1.25.1.5</td>
</tr>
<tr>
<td>hrSystemProcesses</td>
<td>1.3.6.1.2.1.25.1.6</td>
</tr>
<tr>
<td>hrSystemMaxProcesses</td>
<td>1.3.6.1.2.1.25.1.7</td>
</tr>
<tr>
<td>hrMemorySize</td>
<td>1.3.6.1.2.1.25.2.2</td>
</tr>
<tr>
<td>hrStorageIndex</td>
<td>1.3.6.1.2.1.25.2.3.1.1</td>
</tr>
<tr>
<td>hrStorageType</td>
<td>1.3.6.1.2.1.25.2.3.1.2</td>
</tr>
<tr>
<td>hrStorageDescr</td>
<td>1.3.6.1.2.1.25.2.3.1.3</td>
</tr>
<tr>
<td>hrStorageAllocationUnits</td>
<td>1.3.6.1.2.1.25.2.3.1.4</td>
</tr>
<tr>
<td>hrStorageSize</td>
<td>1.3.6.1.2.1.25.2.3.1.5</td>
</tr>
<tr>
<td>hrStorageUsed</td>
<td>1.3.6.1.2.1.25.2.3.1.6</td>
</tr>
<tr>
<td>hrDeviceIndex</td>
<td>1.3.6.1.2.1.25.3.2.1.1</td>
</tr>
<tr>
<td>hrDeviceType</td>
<td>1.3.6.1.2.1.25.3.2.1.2</td>
</tr>
<tr>
<td>hrDeviceDescr</td>
<td>1.3.6.1.2.1.25.3.2.1.3</td>
</tr>
<tr>
<td>hrDeviceID</td>
<td>1.3.6.1.2.1.25.3.2.1.4</td>
</tr>
<tr>
<td>hrDeviceStatus</td>
<td>1.3.6.1.2.1.25.3.2.1.5</td>
</tr>
<tr>
<td>hrDeviceErrors</td>
<td>1.3.6.1.2.1.25.3.2.1.6</td>
</tr>
<tr>
<td>hrProcessorFwID</td>
<td>1.3.6.1.2.1.25.3.3.1.1</td>
</tr>
<tr>
<td>hrProcessorLoad</td>
<td>1.3.6.1.2.1.25.3.3.1.2</td>
</tr>
<tr>
<td>hrNetworkIfIndex</td>
<td>1.3.6.1.2.1.25.3.4.1.1</td>
</tr>
<tr>
<td>hrDiskStorageAccess</td>
<td>1.3.6.1.2.1.25.3.6.1.1</td>
</tr>
<tr>
<td>hrDiskStorageMedia</td>
<td>1.3.6.1.2.1.25.3.6.1.2</td>
</tr>
<tr>
<td>hrDiskStorageRemoveable</td>
<td>1.3.6.1.2.1.25.3.6.1.3</td>
</tr>
<tr>
<td>hrDiskStorageCapacity</td>
<td>1.3.6.1.2.1.25.3.6.1.4</td>
</tr>
<tr>
<td>hrPartitionIndex</td>
<td>1.3.6.1.2.1.25.3.7.1.1</td>
</tr>
<tr>
<td>hrPartitionLabel</td>
<td>1.3.6.1.2.1.25.3.7.1.2</td>
</tr>
<tr>
<td>hrPartitionID</td>
<td>1.3.6.1.2.1.25.3.7.1.3</td>
</tr>
<tr>
<td>hrPartitionSize</td>
<td>1.3.6.1.2.1.25.3.7.1.4</td>
</tr>
<tr>
<td>hrPartitionFSIndex</td>
<td>1.3.6.1.2.1.25.3.7.1.5</td>
</tr>
<tr>
<td>hrFSIndex</td>
<td>1.3.6.1.2.1.25.3.8.1.1</td>
</tr>
<tr>
<td>hrFSMountPoint</td>
<td>1.3.6.1.2.1.25.3.8.1.2</td>
</tr>
<tr>
<td>hrFSRemoteMountPoint</td>
<td>1.3.6.1.2.1.25.3.8.1.3</td>
</tr>
<tr>
<td>hrFSType</td>
<td>1.3.6.1.2.1.25.3.8.1.4</td>
</tr>
<tr>
<td>hrFSAccess</td>
<td>1.3.6.1.2.1.25.3.8.1.5</td>
</tr>
<tr>
<td>hrFSBootable</td>
<td>1.3.6.1.2.1.25.3.8.1.6</td>
</tr>
</tbody>
</table>
### Table A-6  HOST-RESOURCES-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>hrFSStorageIndex</td>
<td>1.3.6.1.2.1.25.3.8.1.7</td>
</tr>
<tr>
<td>hrFSLastFullBackupDate</td>
<td>1.3.6.1.2.1.25.3.8.1.8</td>
</tr>
<tr>
<td>hrFSLastPartialBackupDate</td>
<td>1.3.6.1.2.1.25.3.8.1.9</td>
</tr>
<tr>
<td>hrSWRunIndex</td>
<td>1.3.6.1.2.1.25.4.2.1.1</td>
</tr>
<tr>
<td>hrSWRunName</td>
<td>1.3.6.1.2.1.25.4.2.1.2</td>
</tr>
<tr>
<td>hrSWRunID</td>
<td>1.3.6.1.2.1.25.4.2.1.3</td>
</tr>
<tr>
<td>hrSWRunPath</td>
<td>1.3.6.1.2.1.25.4.2.1.4</td>
</tr>
<tr>
<td>hrSWRunParameters</td>
<td>1.3.6.1.2.1.25.4.2.1.5</td>
</tr>
<tr>
<td>hrSWRunType</td>
<td>1.3.6.1.2.1.25.4.2.1.6</td>
</tr>
<tr>
<td>hrSWRunStatus</td>
<td>1.3.6.1.2.1.25.4.2.1.7</td>
</tr>
<tr>
<td>hrSWRunPerfCPU</td>
<td>1.3.6.1.2.1.25.5.1.1.1</td>
</tr>
<tr>
<td>hrSWRunPerfMem</td>
<td>1.3.6.1.2.1.25.5.1.1.2</td>
</tr>
<tr>
<td>hrSWInstalledLastChange</td>
<td>1.3.6.1.2.1.25.6.1</td>
</tr>
<tr>
<td>hrSWInstalledLastUpdateTime</td>
<td>1.3.6.1.2.1.25.6.2</td>
</tr>
<tr>
<td>hrSWInstalledIndex</td>
<td>1.3.6.1.2.1.25.6.3.1.1</td>
</tr>
<tr>
<td>hrSWInstalledName</td>
<td>1.3.6.1.2.1.25.6.3.1.2</td>
</tr>
<tr>
<td>hrSWInstalledID</td>
<td>1.3.6.1.2.1.25.6.3.1.3</td>
</tr>
<tr>
<td>hrSWInstalledType</td>
<td>1.3.6.1.2.1.25.6.3.1.4</td>
</tr>
<tr>
<td>hrSWInstalledDate</td>
<td>1.3.6.1.2.1.25.6.3.1.5</td>
</tr>
</tbody>
</table>

### Table A-7  MTA-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>mtaStoredMessages</td>
<td>1.3.6.1.2.1.28.1.1.2</td>
</tr>
<tr>
<td>mtaStoredVolume</td>
<td>1.3.6.1.2.1.28.1.1.5</td>
</tr>
<tr>
<td>mtaGroupStoredMessages</td>
<td>1.3.6.1.2.1.28.2.1.4</td>
</tr>
<tr>
<td>mtaGroupStoredVolume</td>
<td>1.3.6.1.2.1.28.2.1.7</td>
</tr>
<tr>
<td>mtaGroupHierarchy</td>
<td>1.3.6.1.2.1.28.2.1.31</td>
</tr>
</tbody>
</table>

### Table A-8  IF-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ifName</td>
<td>1.3.6.1.2.1.31.1.1.1.1</td>
</tr>
<tr>
<td>ifInMulticastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.2</td>
</tr>
<tr>
<td>ifInBroadcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.3</td>
</tr>
<tr>
<td>ifOutMulticastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.4</td>
</tr>
<tr>
<td>ifOutBroadcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.5</td>
</tr>
<tr>
<td>ifHCInOctets</td>
<td>1.3.6.1.2.1.31.1.1.1.6</td>
</tr>
</tbody>
</table>
### Table A-8 IF-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ifHCInUcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.7</td>
</tr>
<tr>
<td>ifHCInMulticastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.8</td>
</tr>
<tr>
<td>ifHCInBroadcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.9</td>
</tr>
<tr>
<td>ifHCOOutOctets</td>
<td>1.3.6.1.2.1.31.1.1.1.10</td>
</tr>
<tr>
<td>ifHCOOutUcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.11</td>
</tr>
<tr>
<td>ifHCOOutMulticastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.12</td>
</tr>
<tr>
<td>ifHCOOutBroadcastPkts</td>
<td>1.3.6.1.2.1.31.1.1.1.13</td>
</tr>
<tr>
<td>ifHighSpeed</td>
<td>1.3.6.1.2.1.31.1.1.1.15</td>
</tr>
<tr>
<td>ifPromiscuousMode</td>
<td>1.3.6.1.2.1.31.1.1.1.16</td>
</tr>
<tr>
<td>ifConnectorPresent</td>
<td>1.3.6.1.2.1.31.1.1.1.17</td>
</tr>
<tr>
<td>ifAlias</td>
<td>1.3.6.1.2.1.31.1.1.1.18</td>
</tr>
<tr>
<td>ifCounterDiscontinuityTime</td>
<td>1.3.6.1.2.1.31.1.1.1.19</td>
</tr>
<tr>
<td>ifTableLastChange</td>
<td>1.3.6.1.2.1.31.1.5</td>
</tr>
</tbody>
</table>

### Table A-9 DISMAN-EVENT-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>mteResourceSampleMinimum</td>
<td>1.3.6.1.2.1.88.1.1.1.1</td>
</tr>
<tr>
<td>mteResourceSampleInstanceMaximum</td>
<td>1.3.6.1.2.1.88.1.1.1.2</td>
</tr>
<tr>
<td>mteResourceSampleInstances</td>
<td>1.3.6.1.2.1.88.1.1.1.3</td>
</tr>
<tr>
<td>mteResourceSampleInstancesHigh</td>
<td>1.3.6.1.2.1.88.1.1.4</td>
</tr>
<tr>
<td>mteResourceSampleInstanceLacks</td>
<td>1.3.6.1.2.1.88.1.1.5</td>
</tr>
<tr>
<td>mteTriggerFailures</td>
<td>1.3.6.1.2.1.88.1.2.1</td>
</tr>
<tr>
<td>mteTriggerComment</td>
<td>1.3.6.1.2.1.88.1.2.2.1.3</td>
</tr>
<tr>
<td>mteTriggerTest</td>
<td>1.3.6.1.2.1.88.1.2.2.1.4</td>
</tr>
<tr>
<td>mteTriggerSampleType</td>
<td>1.3.6.1.2.1.88.1.2.2.1.5</td>
</tr>
<tr>
<td>mteTriggerValueID</td>
<td>1.3.6.1.2.1.88.1.2.2.1.6</td>
</tr>
<tr>
<td>mteTriggerValueIDWildcard</td>
<td>1.3.6.1.2.1.88.1.2.2.1.7</td>
</tr>
<tr>
<td>mteTriggerTargetTag</td>
<td>1.3.6.1.2.1.88.1.2.2.1.8</td>
</tr>
<tr>
<td>mteTriggerContextName</td>
<td>1.3.6.1.2.1.88.1.2.2.1.9</td>
</tr>
<tr>
<td>mteTriggerContextNameWildcard</td>
<td>1.3.6.1.2.1.88.1.2.2.1.10</td>
</tr>
<tr>
<td>mteTriggerFrequency</td>
<td>1.3.6.1.2.1.88.1.2.2.1.11</td>
</tr>
<tr>
<td>mteTriggerObjectsOwner</td>
<td>1.3.6.1.2.1.88.1.2.2.1.12</td>
</tr>
<tr>
<td>mteTriggerObjects</td>
<td>1.3.6.1.2.1.88.1.2.2.1.13</td>
</tr>
<tr>
<td>mteTriggerEnabled</td>
<td>1.3.6.1.2.1.88.1.2.2.1.14</td>
</tr>
<tr>
<td>mteTriggerEntryStatus</td>
<td>1.3.6.1.2.1.88.1.2.2.1.15</td>
</tr>
<tr>
<td>mteTriggerThresholdStartup</td>
<td>1.3.6.1.2.1.88.1.2.6.1.1</td>
</tr>
</tbody>
</table>
### Table A-9 DISMAN-EVENT-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>mteObjectsID</td>
<td>1.3.6.1.2.1.88.1.3.1.1.3</td>
</tr>
<tr>
<td>mteObjectsIDWildcard</td>
<td>1.3.6.1.2.1.88.1.3.1.1.4</td>
</tr>
<tr>
<td>mteObjectsEntryStatus</td>
<td>1.3.6.1.2.1.88.1.3.1.1.5</td>
</tr>
<tr>
<td>mteEventComment</td>
<td>1.3.6.1.2.1.88.1.4.2.1.2</td>
</tr>
<tr>
<td>mteEventActions</td>
<td>1.3.6.1.2.1.88.1.4.2.1.3</td>
</tr>
<tr>
<td>mteEventEnabled</td>
<td>1.3.6.1.2.1.88.1.4.2.1.4</td>
</tr>
<tr>
<td>mteEventEntryStatus</td>
<td>1.3.6.1.2.1.88.1.4.2.1.5</td>
</tr>
<tr>
<td>mteEventNotification</td>
<td>1.3.6.1.2.1.88.1.4.3.1.1</td>
</tr>
<tr>
<td>mteEventNotificationObjectsOwner</td>
<td>1.3.6.1.2.1.88.1.4.3.1.2</td>
</tr>
<tr>
<td>mteEventNotificationObjects</td>
<td>1.3.6.1.2.1.88.1.4.3.1.3</td>
</tr>
</tbody>
</table>

### Table A-10 NOTIFICATION-LOG-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>nlmConfigGlobalEntryLimit</td>
<td>1.3.6.1.2.1.92.1.1.1</td>
</tr>
<tr>
<td>nlmConfigGlobalAgeOut</td>
<td>1.3.6.1.2.1.92.1.1.2</td>
</tr>
<tr>
<td>nlmStatsGlobalNotificationsLogged</td>
<td>1.3.6.1.2.1.92.1.2.1</td>
</tr>
<tr>
<td>nlmStatsGlobalNotificationsBumped</td>
<td>1.3.6.1.2.1.92.1.2.2</td>
</tr>
</tbody>
</table>

### Table A-11 UCD-SNMP-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>prIndex</td>
<td>1.3.6.1.4.1.2021.2.1.1</td>
</tr>
<tr>
<td>prNames</td>
<td>1.3.6.1.4.1.2021.2.1.2</td>
</tr>
<tr>
<td>prMin</td>
<td>1.3.6.1.4.1.2021.2.1.3</td>
</tr>
<tr>
<td>prMax</td>
<td>1.3.6.1.4.1.2021.2.1.4</td>
</tr>
<tr>
<td>prCount</td>
<td>1.3.6.1.4.1.2021.2.1.5</td>
</tr>
<tr>
<td>prErrorFlag</td>
<td>1.3.6.1.4.1.2021.2.1.100</td>
</tr>
<tr>
<td>prErrMessage</td>
<td>1.3.6.1.4.1.2021.2.1.101</td>
</tr>
<tr>
<td>prErrFix</td>
<td>1.3.6.1.4.1.2021.2.1.102</td>
</tr>
<tr>
<td>prErrFixCmd</td>
<td>1.3.6.1.4.1.2021.2.1.103</td>
</tr>
<tr>
<td>memIndex</td>
<td>1.3.6.1.4.1.2021.4.1</td>
</tr>
<tr>
<td>memErrorName</td>
<td>1.3.6.1.4.1.2021.4.2</td>
</tr>
<tr>
<td>memTotalSwap</td>
<td>1.3.6.1.4.1.2021.4.3</td>
</tr>
<tr>
<td>memAvailSwap</td>
<td>1.3.6.1.4.1.2021.4.4</td>
</tr>
<tr>
<td>memTotalReal</td>
<td>1.3.6.1.4.1.2021.4.5</td>
</tr>
<tr>
<td>memAvailReal</td>
<td>1.3.6.1.4.1.2021.4.6</td>
</tr>
<tr>
<td>memTotalFree</td>
<td>1.3.6.1.4.1.2021.4.11</td>
</tr>
<tr>
<td>Object</td>
<td>OID</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>memMinimumSwap</td>
<td>1.3.6.1.4.1.2021.4.12</td>
</tr>
<tr>
<td>memShared</td>
<td>1.3.6.1.4.1.2021.4.13</td>
</tr>
<tr>
<td>memBuffer</td>
<td>1.3.6.1.4.1.2021.4.14</td>
</tr>
<tr>
<td>memCached</td>
<td>1.3.6.1.4.1.2021.4.15</td>
</tr>
<tr>
<td>memSwapError</td>
<td>1.3.6.1.4.1.2021.4.100</td>
</tr>
<tr>
<td>memSwapErrorMsg</td>
<td>1.3.6.1.4.1.2021.4.101</td>
</tr>
<tr>
<td>dskIndex</td>
<td>1.3.6.1.4.1.2021.9.1.1</td>
</tr>
<tr>
<td>dskPath</td>
<td>1.3.6.1.4.1.2021.9.1.2</td>
</tr>
<tr>
<td>dskDevice</td>
<td>1.3.6.1.4.1.2021.9.1.3</td>
</tr>
<tr>
<td>dskMinimum</td>
<td>1.3.6.1.4.1.2021.9.1.4</td>
</tr>
<tr>
<td>dskMinPercent</td>
<td>1.3.6.1.4.1.2021.9.1.5</td>
</tr>
<tr>
<td>dskTotal</td>
<td>1.3.6.1.4.1.2021.9.1.6</td>
</tr>
<tr>
<td>dskAvail</td>
<td>1.3.6.1.4.1.2021.9.1.7</td>
</tr>
<tr>
<td>dskUsed</td>
<td>1.3.6.1.4.1.2021.9.1.8</td>
</tr>
<tr>
<td>dskPercent</td>
<td>1.3.6.1.4.1.2021.9.1.9</td>
</tr>
<tr>
<td>dskPercentNode</td>
<td>1.3.6.1.4.1.2021.9.1.10</td>
</tr>
<tr>
<td>dskErrorFlag</td>
<td>1.3.6.1.4.1.2021.9.1.100</td>
</tr>
<tr>
<td>dskErrorMsg</td>
<td>1.3.6.1.4.1.2021.9.1.101</td>
</tr>
<tr>
<td>laIndex</td>
<td>1.3.6.1.4.1.2021.10.1.1</td>
</tr>
<tr>
<td>laNames</td>
<td>1.3.6.1.4.1.2021.10.1.2</td>
</tr>
<tr>
<td>laLoad</td>
<td>1.3.6.1.4.1.2021.10.1.3</td>
</tr>
<tr>
<td>laConfig</td>
<td>1.3.6.1.4.1.2021.10.1.4</td>
</tr>
<tr>
<td>laLoadInt</td>
<td>1.3.6.1.4.1.2021.10.1.5</td>
</tr>
<tr>
<td>laLoadFloat</td>
<td>1.3.6.1.4.1.2021.10.1.6</td>
</tr>
<tr>
<td>laErrorFlag</td>
<td>1.3.6.1.4.1.2021.10.1.100</td>
</tr>
<tr>
<td>laErrMessage</td>
<td>1.3.6.1.4.1.2021.10.1.101</td>
</tr>
<tr>
<td>ssIndex</td>
<td>1.3.6.1.4.1.2021.11.1</td>
</tr>
<tr>
<td>ssErrorName</td>
<td>1.3.6.1.4.1.2021.11.2</td>
</tr>
<tr>
<td>ssSwapIn</td>
<td>1.3.6.1.4.1.2021.11.3</td>
</tr>
<tr>
<td>ssSwapOut</td>
<td>1.3.6.1.4.1.2021.11.4</td>
</tr>
<tr>
<td>ssIOSent</td>
<td>1.3.6.1.4.1.2021.11.5</td>
</tr>
<tr>
<td>ssIOReceive</td>
<td>1.3.6.1.4.1.2021.11.6</td>
</tr>
<tr>
<td>ssSysInterrupts</td>
<td>1.3.6.1.4.1.2021.11.7</td>
</tr>
<tr>
<td>ssSysContext</td>
<td>1.3.6.1.4.1.2021.11.8</td>
</tr>
<tr>
<td>ssCpuUser</td>
<td>1.3.6.1.4.1.2021.11.9</td>
</tr>
<tr>
<td>ssCpuSystem</td>
<td>1.3.6.1.4.1.2021.11.10</td>
</tr>
</tbody>
</table>
### Table A-11  UCD-SNMP-MIB (continued)

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>ssCpuIdle</td>
<td>1.3.6.1.4.1.2021.11.11</td>
</tr>
<tr>
<td>ssCpuRawUser</td>
<td>1.3.6.1.4.1.2021.11.50</td>
</tr>
<tr>
<td>ssCpuRawNice</td>
<td>1.3.6.1.4.1.2021.11.51</td>
</tr>
<tr>
<td>ssCpuRawSystem</td>
<td>1.3.6.1.4.1.2021.11.52</td>
</tr>
<tr>
<td>ssCpuRawIdle</td>
<td>1.3.6.1.4.1.2021.11.53</td>
</tr>
<tr>
<td>ssCpuRawWait</td>
<td>1.3.6.1.4.1.2021.11.54</td>
</tr>
<tr>
<td>ssCpuRawKernel</td>
<td>1.3.6.1.4.1.2021.11.55</td>
</tr>
<tr>
<td>ssCpuRawInterrupt</td>
<td>1.3.6.1.4.1.2021.11.56</td>
</tr>
<tr>
<td>ssIORawSent</td>
<td>1.3.6.1.4.1.2021.11.57</td>
</tr>
<tr>
<td>ssIORawReceived</td>
<td>1.3.6.1.4.1.2021.11.58</td>
</tr>
<tr>
<td>ssRawInterrupts</td>
<td>1.3.6.1.4.1.2021.11.59</td>
</tr>
<tr>
<td>ssRawContexts</td>
<td>1.3.6.1.4.1.2021.11.60</td>
</tr>
<tr>
<td>ssCpuRawSoftIRQ</td>
<td>1.3.6.1.4.1.2021.11.61</td>
</tr>
<tr>
<td>ssRawSwapIn</td>
<td>1.3.6.1.4.1.2021.11.62</td>
</tr>
<tr>
<td>ssRawSwapOut</td>
<td>1.3.6.1.4.1.2021.11.63</td>
</tr>
</tbody>
</table>

### Table A-12  UCD-DLMOD-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>dlmodNextIndex</td>
<td>1.3.6.1.4.1.2021.13.14.1</td>
</tr>
<tr>
<td>dlmodName</td>
<td>1.3.6.1.4.1.2021.13.14.2.1.2</td>
</tr>
<tr>
<td>dlmodPath</td>
<td>1.3.6.1.4.1.2021.13.14.2.1.3</td>
</tr>
<tr>
<td>dlmodError</td>
<td>1.3.6.1.4.1.2021.13.14.2.1.4</td>
</tr>
<tr>
<td>dlmodStatus</td>
<td>1.3.6.1.4.1.2021.13.14.2.1.5</td>
</tr>
<tr>
<td>diskIOIndex</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.1</td>
</tr>
<tr>
<td>diskIODevice</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.2</td>
</tr>
<tr>
<td>diskIONRead</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.3</td>
</tr>
<tr>
<td>diskIONWritten</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.4</td>
</tr>
<tr>
<td>diskIReads</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.5</td>
</tr>
<tr>
<td>diskIWrites</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.6</td>
</tr>
<tr>
<td>diskIOEntry</td>
<td>1.3.6.1.4.1.2021.13.15.1.1.7</td>
</tr>
<tr>
<td>logMatchMaxEntries</td>
<td>1.3.6.1.4.1.2021.16.1</td>
</tr>
<tr>
<td>versionIndex</td>
<td>1.3.6.1.4.1.2021.100.1</td>
</tr>
<tr>
<td>versionTag</td>
<td>1.3.6.1.4.1.2021.100.2</td>
</tr>
<tr>
<td>versionDate</td>
<td>1.3.6.1.4.1.2021.100.3</td>
</tr>
<tr>
<td>versionCDate</td>
<td>1.3.6.1.4.1.2021.100.4</td>
</tr>
<tr>
<td>versionIdent</td>
<td>1.3.6.1.4.1.2021.100.5</td>
</tr>
</tbody>
</table>
### Table A-12  UCD-DLMOD-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>versionConfigureOptions</td>
<td>1.3.6.1.4.1.2021.100.6</td>
</tr>
<tr>
<td>versionClearCache</td>
<td>1.3.6.1.4.1.2021.100.10</td>
</tr>
<tr>
<td>versionUpdateConfig</td>
<td>1.3.6.1.4.1.2021.100.11</td>
</tr>
<tr>
<td>versionRestartAgent</td>
<td>1.3.6.1.4.1.2021.100.12</td>
</tr>
<tr>
<td>versionSavePersistentData</td>
<td>1.3.6.1.4.1.2021.100.13</td>
</tr>
<tr>
<td>versionDoDebugging</td>
<td>1.3.6.1.4.1.2021.100.20</td>
</tr>
<tr>
<td>snmperrIndex</td>
<td>1.3.6.1.4.1.2021.101.1</td>
</tr>
<tr>
<td>snmperrNames</td>
<td>1.3.6.1.4.1.2021.101.2</td>
</tr>
<tr>
<td>snmperrErrorFlag</td>
<td>1.3.6.1.4.1.2021.101.100</td>
</tr>
<tr>
<td>snmperrErrMessage</td>
<td>1.3.6.1.4.1.2021.101.101</td>
</tr>
</tbody>
</table>

### Table A-13  NET-SNMP-AGENT-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>nsMibRegistry</td>
<td>1.3.6.1.4.1.8072.1.2</td>
</tr>
<tr>
<td>nsExtensions</td>
<td>1.3.6.1.4.1.8072.1.3</td>
</tr>
<tr>
<td>nsCache</td>
<td>1.3.6.1.4.1.8072.1.5</td>
</tr>
<tr>
<td>nsConfiguration</td>
<td>1.3.6.1.4.1.8072.1.7</td>
</tr>
</tbody>
</table>

### Table A-14  SNMPv2-SMI

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmpSetSerialNo</td>
<td>1.3.6.1.6.3.1.1.6.1</td>
</tr>
</tbody>
</table>

### Table A-15  SNMP-FRAMEWORK-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmpEngineID</td>
<td>1.3.6.1.6.3.10.2.1.1</td>
</tr>
<tr>
<td>snmpEngineBoots</td>
<td>1.3.6.1.6.3.10.2.1.2</td>
</tr>
<tr>
<td>snmpEngineTime</td>
<td>1.3.6.1.6.3.10.2.1.3</td>
</tr>
<tr>
<td>snmpEngineMaxMessageSize</td>
<td>1.3.6.1.6.3.10.2.1.4</td>
</tr>
</tbody>
</table>

### Table A-16  SNMP-MPD-MIB

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmpUnknownSecurityModels</td>
<td>1.3.6.1.6.3.11.2.1.1</td>
</tr>
<tr>
<td>snmpInvalidMsgs</td>
<td>1.3.6.1.6.3.11.2.1.2</td>
</tr>
<tr>
<td>snmpUnknownPDUHandlers</td>
<td>1.3.6.1.6.3.11.2.1.3</td>
</tr>
</tbody>
</table>
### Table A-17  **SNMP-TARGET-MIB**

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmpTargetSpinLock</td>
<td>1.3.6.1.6.3.12.1.1</td>
</tr>
<tr>
<td>snmpUnavailableContexts</td>
<td>1.3.6.1.6.3.12.1.4</td>
</tr>
<tr>
<td>snmpUnknownContexts</td>
<td>1.3.6.1.6.3.12.1.5</td>
</tr>
</tbody>
</table>

### Table A-18  **SNMP-USER-BASED-SM-MIB**

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>usmStatsUnsupportedSecLevels</td>
<td>1.3.6.1.6.3.15.1.1.1</td>
</tr>
<tr>
<td>usmStatsNotInTimeWindows</td>
<td>1.3.6.1.6.3.15.1.1.2</td>
</tr>
<tr>
<td>usmStatsUnknownUserNames</td>
<td>1.3.6.1.6.3.15.1.1.3</td>
</tr>
<tr>
<td>usmStatsUnknownEngineIDs</td>
<td>1.3.6.1.6.3.15.1.1.4</td>
</tr>
<tr>
<td>usmStatsWrongDigests</td>
<td>1.3.6.1.6.3.15.1.1.5</td>
</tr>
<tr>
<td>usmStatsDecryptionErrors</td>
<td>1.3.6.1.6.3.15.1.1.6</td>
</tr>
<tr>
<td>usmUserSpinLock</td>
<td>1.3.6.1.6.3.15.1.2.1</td>
</tr>
</tbody>
</table>

### Table A-19  **SNMP-VIEW-BASED-ACM-MIB**

<table>
<thead>
<tr>
<th>Object</th>
<th>OID</th>
</tr>
</thead>
<tbody>
<tr>
<td>vacmContextName</td>
<td>1.3.6.1.6.3.16.1.1.1.1</td>
</tr>
<tr>
<td>vacmGroupName</td>
<td>1.3.6.1.6.3.16.1.2.1.3</td>
</tr>
<tr>
<td>vacmSecurityToGroupStorageType</td>
<td>1.3.6.1.6.3.16.1.2.1.4</td>
</tr>
<tr>
<td>vacmSecurityToGroupStatus</td>
<td>1.3.6.1.6.3.16.1.2.1.5</td>
</tr>
<tr>
<td>vacmAccessContextMatch</td>
<td>1.3.6.1.6.3.16.1.4.1.4</td>
</tr>
<tr>
<td>vacmAccessReadViewName</td>
<td>1.3.6.1.6.3.16.1.4.1.5</td>
</tr>
<tr>
<td>vacmAccessWriteViewName</td>
<td>1.3.6.1.6.3.16.1.4.1.6</td>
</tr>
<tr>
<td>vacmAccessNotifyViewName</td>
<td>1.3.6.1.6.3.16.1.4.1.7</td>
</tr>
<tr>
<td>vacmAccessStorageType</td>
<td>1.3.6.1.6.3.16.1.4.1.8</td>
</tr>
<tr>
<td>vacmAccessStatus</td>
<td>1.3.6.1.6.3.16.1.4.1.9</td>
</tr>
<tr>
<td>vacmViewSpinLock</td>
<td>1.3.6.1.6.3.16.1.5.1</td>
</tr>
<tr>
<td>vacmViewTreeFamilyMask</td>
<td>1.3.6.1.6.3.16.1.5.2.1.3</td>
</tr>
<tr>
<td>vacmViewTreeFamilyType</td>
<td>1.3.6.1.6.3.16.1.5.2.1.4</td>
</tr>
<tr>
<td>vacmViewTreeFamilyStorageType</td>
<td>1.3.6.1.6.3.16.1.5.2.1.5</td>
</tr>
<tr>
<td>vacmViewTreeFamilyStatus</td>
<td>1.3.6.1.6.3.16.1.5.2.1.6</td>
</tr>
</tbody>
</table>
Open Source License Acknowledgments

Notices

The following notices pertain to this software license.

OpenSSL/Open SSL Project

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).
This product includes software written by Tim Hudson (tjh@cryptsoft.com).

License Issues

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL License:
Copyright © 1998-2007 The OpenSSL Project. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software must display the following acknowledgment: “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”.
4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.
5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:

   “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”.

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

**Original SSLeay License:**

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscape’s SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, SHA, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

   “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”.

   The word ‘cryptographic’ can be left out if the routines from the library being used are not cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”.
THIS SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License].
INDEX

A
AD SSO Configuration Steps for CAM, CAS, and AD Server  8-5
AD SSO Overview  8-1
ARP, configuring  4-31

B
Bandwidth
  limiting usage  7-14
bursting  7-14

C
cached ARP, flushing  4-32
calculating subnets (DHCP)  5-10
certificate. See SSL certificate.
Clean Access
  shared devices  10-4
Clean Access Server management pages  1-6
connection checking, user  9-1
CSR, generating  11-14

D
deployment
  operating mode, choosing  2-1
DHCP
  configuring  5-2 to 5-23
  creating pools  5-8
  overview  5-1
  relay  5-3

F
filter policies  7-1 to 7-16
  IP address  4-43
  MAC address  4-39
  subnet, specifying by  4-43
floating devices  10-4
flushing cached ARP  4-32
fragmentation, IP packet  7-5

G
generating DHCP pools  5-10
global settings  1-8

H
heartbeat timer  9-1

I
interface settings  4-11
IP address
  filtering by  4-43
  reserved  5-22
IP address, configuring the server  4-12, 4-13
IP filter status  11-2
IP fragment packets  7-5
IPSec server status  11-2

relay status  11-2
DNS settings  4-24

IN-1
Index

L
local settings  1-8
login page  9-3

M
MAC address filter policies  4-39

O
operating modes
    overview  2-1 to 2-8
    Real-IP gateway  2-2
    virtual gateway  2-2

P
passthrough, VLAN ID  4-33

R
real-IP gateway
    overview  2-2
reserved IP addresses  5-22
roles, user
    assignment priority  4-39
    default policies  7-2
routes, static  4-29

time, system  11-41
timing out users  9-1
transparent Windows login  9-8

U
users
    time-out settings  9-1
    windows login  9-8

V
virtual gateway
    overview  2-2
VLAN settings
    overview  4-32

W
Windows login  9-8

S
shared devices  10-4
SSL Certificate
    Certificate-Related Files  11-32
    overview  11-6
SSL certificate
    exporting CSR  11-14

static route, using  4-29
status tab  11-1
subnet, managing access  4-43
subnetting rules  5-6