FlexConfig Policies
The following topics describe how to configure and deploy FlexConfig policies.
• FlexConfig Policy Overview, on page 1
• Guidelines and Limitations for FlexConfig, on page 17
• Customizing Device Configuration with FlexConfig Policies, on page 18

FlexConfig Policy Overview
A FlexConfig policy is a container of an ordered list of FlexConfig objects. Each object includes a series of
Apache Velocity scripting language commands, ASA software configuration commands, and variables that
you define. The contents of each FlexConfig object is essentially a program that generates a sequence of ASA
commands that will then be deployed to the assigned devices. This command sequence then configures the
related feature on the FTD device.
FTD uses ASA configuration commands to implement some features, but not all features. There is no unique
set of FTD configuration commands. Instead, the point of FlexConfig is to allow you to configure features
that are not yet directly supported through Firepower Management Center policies and settings.

Caution

Cisco strongly recommends using FlexConfig policies only if you are an advanced user with a strong ASA
background and at your own risk. You may configure any commands that are not blacklisted. Enabling features
through FlexConfig policies may cause unintended results with other configured features.
You may contact the Cisco Technical Assistance Center for support concerning FlexConfig policies that you
have configured. The Cisco Technical Assistance Center does not design or write custom configurations on
any customer's behalf. Cisco expresses no guarantees for correct operation or interoperability with other
Firepower System features. FlexConfig features may become deprecated at any time. For fully guaranteed
feature support, you must wait for Firepower Management Center support. When in doubt, do not use
FlexConfig policies.

Recommended Usage for FlexConfig Policies
There are two main recommended uses for FlexConfig:
• You are converting from ASA to FTD, and there are compatible features you are using (and need to
continue using) that Firepower Management Center does not directly support. In this case, use the show

FlexConfig Policies
1

FlexConfig Policies
CLI Commands in FlexConfig Objects

running-config command on the ASA to see the configuration for the feature and create your FlexConfig
objects to implement it. Experiment with the object’s deployment settings (once/everytime and
append/prepend) to get the right setting. Verify by comparing show running-config output on the two
devices.
• You are using FTD but there is a setting or feature that you need to configure, e.g. the Cisco Technical
Assistance Center tells you that a particular setting should resolve a specific problem you are encountering.
For complicated features, use a lab device to test the FlexConfig and verify that you are getting the
expected behavior.
The system includes a set of predefined FlexConfig objects that represent tested configurations. If the feature
you need is not represented by these objects, first determine if you can configure an equivalent feature in
standard policies. For example, the access control policy includes intrusion detection and prevention, HTTP
and other types of protocol inspection, URL filtering, application filtering, and access control, which the ASA
implements using separate features. Because many features are not configured using CLI commands, you will
not see every policy represented within the output of show running-config.

Note

At all times, keep in mind that there is not a one-to-one overlap between ASA and FTD. Do not attempt to
completely recreate an ASA configuration on a FTD device. You must carefully test any feature that you
configure using FlexConfig.

CLI Commands in FlexConfig Objects
FTD uses ASA configuration commands to configure some features. Although not all ASA features are
compatible with FTD, there are some features that can work on FTD but that you cannot configure in Firepower
Management Center policies. You can use FlexConfig objects to specify the CLI required to configure these
features.
If you decide to use FlexConfig to manually configure a feature, you are responsible for knowing and
implementing the commands according to the proper syntax. FlexConfig policies do not validate CLI command
syntax. For more information about proper syntax and configuring CLI commands, use the ASA documentation
as a reference:
• ASA CLI configuration guides explain how to configure a feature. Find the guides at
http://www.cisco.com/c/en/us/support/security/asa-5500-series-next-generation-firewalls/products-installation-and-configuration-guides-list.html
• ASA command references provide additional information sorted by command name. Find the references
athttp://www.cisco.com/c/en/us/support/security/asa-5500-series-next-generation-firewalls/products-command-reference-list.html
The following topics explain more about configuration commands.

Determine the ASA Software Version and Current CLI Configuration
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense
Firepower Threat
Defense Virtual
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Because the system uses ASA software commands to configure some features, you need to determine the
current ASA version used in software running on the FTD device. This version number indicates which ASA
CLI configuration guides to use for instructions on configuring a feature. You also should examine the current
CLI-based configuration and compare it to the ASA configuration you want to implement.
Keep in mind that any ASA configuration will be very different from a FTD configuration. Many FTD policies
are configured outside of the CLI, so you cannot see the configuration by looking at the commands. Do not
try to create a one-to-one correspondence between an ASA and FTD configuration.
To view this information, make an SSH connection to the device's management interface and issue the following
commands:
• show version system and look for the Cisco Adaptive Security Appliance Software Version number. (If
you issue the command through the Firepower Management Center CLI tool, omit the system keyword.)
• show running-config to view the current CLI configuration.
• show running-config all to include all the default commands in the current CLI configuration.
You can also issue these commands from within Firepower Management Center using the following procedure.
Procedure

Step 1

Choose System > Health > Monitor.

Step 2

Click the name of the device targeted by the FlexConfig policy.
You might need to click the open/close arrow in the Count column in the Status table to see any devices.

Step 3

Choose Advanced Troubleshooting.

Step 4

Choose Threat Defense CLI.

Step 5

Choose show as the command, and type version or one of the other commands as the parameter.

Step 6

Click Execute.
For version, search the output for the Cisco Adaptive Security Appliance Software Version number.
You can select the output and press Ctrl+C, then paste it into a text file for later analysis.

Blacklisted CLI Commands
The purpose of FlexConfig is to configure features that are available on ASA devices that you cannot configure
on FTD devices using Firepower Management Center.
Thus, you are prevented from configuring ASA features that have equivalents in Firepower Management
Center. The following table lists some of these blacklisted command areas.
In addition, some clear commands are blacklisted because they overlap with managed policies, and can delete
part of the configuration for a managed policy.
The FlexConfig object editor prevents you from including blacklisted commands in the object.
Blacklisted CLI Command

Description

AAA

Configuration blocked.
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Blacklisted CLI Command

Description

AAA-Server

Configuration blocked.

Access-list

Advanced ACL, Extended ACL, and Standard ACL are blocked.
Ethertype ACL is allowed.
You can use standard and extended ACL objects defined in the object
manager inside the template as variables.

ARP Inspection

Configuration blocked.

As-path Object

Configuration blocked.

Banner

Configuration blocked.

BGP

Configuration blocked.

Clock

Configuration blocked.

Community-list Object

Configuration blocked.

Copy

Configuration blocked.

Delete

Configuration blocked.

DHCP

Configuration blocked.

Enable Password

Configuration blocked.

Erase

Configuration blocked.

Fragment Setting

Blocked, except for fragment reassembly.

Fsck

Configuration blocked.

HTTP

Configuration blocked.

ICMP

Configuration blocked.

Interface

Only nameif, mode, shutdown, ip address and mac-address commands
are blocked.

Multicast Routing

Configuration blocked.

NAT

Configuration blocked.

Network Object/Object-group

Network object creation in the FlexConfig object is blocked, but you
can use network objects and groups defined in the object manager inside
the template as variables.

NTP

Configuration blocked.

OSPF/OSPFv3

Configuration blocked.

Password Encryption

Configuration blocked.
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Blacklisted CLI Command

Description

Policy-list Object

Configuration blocked.

Prefix-list Object

Configuration blocked.

Reload

You cannot schedule reloads. The system does not use the reload
command to restart the system, it uses the reboot command.

RIP

Configuration blocked.

Route-Map Object

Route-map object creation in the FlexConfig object is blocked, but you
can use route map objects defined in the object manager inside the
template as variables.

Service Object/Object-group

Service object creation in the FlexConfig object is blocked, but you can
use port objects defined in the object manager inside the template as
variables.

SNMP

Configuration blocked.

SSH

Configuration blocked.

Static Route

Configuration blocked.

Syslog

Configuration blocked.

Time Synchronization

Configuration blocked.

Timeout

Configuration blocked.

VPN

Configuration blocked.

Template Scripts
You can use scripting language to control processing within a FlexConfig object. Scripting language instructions
are a subset of commands supported in the Apache Velocity 1.3.1 template engine, a Java-based scripting
language that supports looping, if/else statements, and variables.
To learn how to use the scripting language, see the Velocity Developer Guide at http://velocity.apache.org/
engine/devel/developer-guide.html.

FlexConfig Variables
You can use variables in a FlexConfig object in cases where part of a command or processing instruction
depends on runtime information rather than static information. During deployment, the variables are replaced
with strings obtained from other configurations for the device based on the type of variable:
• Policy object variables are replaced with strings obtained from objects defined in Firepower Management
Center.
• System variables are replaced with information obtained from the device itself or from policies configured
for it.
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• Processing variables are loaded with the contents of policy object or system variables as scripting
commands are processed. For example, in a loop, you iteratively load one value from a policy object or
system variable into a processing variable, then use the processing variable to form a command string
or perform some other action. These processing variables do not show up in the Variables list within a
FlexConfig object. Also, you do not add them using the Insert menu in the FlexConfig object editor.
Variables start with the $ character. For example, $ifname is a policy object variable in the following command
interface $ifname

Note

The first time you insert a policy object or system variable, you must do so through the Insert menu in the
FlexConfig object editor. This action adds the variable to the Variables list at the bottom of the FlexConfig
object editor. But you must type in the variable string on subsequent uses, even when using system variables.
If you are adding a processing variable, which does not have an object or system variable assignment, do not
use the Insert menu.
Whether a variable is resolved as a single string, a list of strings, or a table of values depends on the type of
policy object or system variable you assign to the variable. You must understand what will be returned in
order to process the variables correctly.
The following topics explain the various types of variable and how to process them.

How to Process Variables
At runtime, a variable can resolve to a single string, a list of strings of the same type, a list of strings of different
types, or a table of named values. In addition, variables that resolve to multiple values can be of determinate
or indeterminate length. You must understand what will be returned in order to process the values correctly.
Following are the main possibilities.
Single Value Variables
If a variable always resolves to a single string, use the variable directly without modification in the FlexConfig
script.
For example, the predefined text variable tcpMssBytes always resolves to a single value (which must be
numeric). The Sysopt_basic FlexConfig then uses an if/then/else structure to set the maximum segment size
based on the value of another single-value text variable, tcpMssMinimum:
#if($tcpMssMinimum == "true")
sysopt connection tcpmss minimum $tcpMssBytes
#else
sysopt connection tcpmss $tcpMssBytes
#end

In this example, you would use the Insert menu in the FlexConfig object editor to add the first use of
$tcpMssBytes, but you would type in the variable directly on the #else line.
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Note

Policy object variables for network objects also equate to a single IP address specification, either a host address,
network address, or address range. However, in this case, you must know what type of address to expect,
because the ASA commands require specific address types. For example, if a command requires a host address,
using a network object variable that points to an object that contains a network address will result in an error
during deployment.

Multiple Value Variables, All Values Are the Same Type
Several policy object and system variables resolve to multiple values of the same type. For example, an object
variable that points to a network object group resolves to a list of the IP addresses within the group. Similarly,
the system variable $SYS_FW_INTERFACE_NAME_LIST resolves to a list of interface names.
You can also create text objects for multiple values of the same type. For example, the predefined text object
enableInspectProtocolList can contain more than one protocol name.
Multiple value variables that resolve to a list of items of the same type are frequently of indeterminate length.
For example, you cannot know beforehand how many interfaces on a device are named, as users can configure
or unconfigure interfaces at any time.
Thus, you would typically use a loop to process multiple value variables of the same type. For example, the
predefined FlexConfig Default_Inspection_Protocol_Enable uses a #foreach loop to go through the
enableInspectProtocolList object and process each value.
policy-map global_policy
class inspection_default
#foreach ( $protocol in $enableInspectProtocolList)
inspect $protocol
#end

In this example, the script assigns each value in turn to the $protocol variable, which is then used in an ASA
inspect command to enable the inspection engine for that protocol. In this case, you simply type in $protocol
as a variable name. You do not use the Insert menu to add it, because you are not assigning an object or
system value to the variable. However, you must use the Insert menu to add $enableInspectProtocolList.
The system loops through the code between #foreach and #end until there are no values remaining in
$enableInspectProtocolList.
Multiple Value Variables, Values Are Different Types
You can create multiple value text objects, but have each value serve a different purpose. For example, the
predefined netflow_Destination text object should have 3 values, in order, interface name, destination IP
address, and UDP port number.
Objects defined in this way should have a determinate number of values. Otherwise, they would be hard to
process.
Use the get method to process these objects. Type .get(n) at the end of the object name, replacing n with an
index into the object. Start counting at 0, even though the text object lists its values starting at 1.
For example, the Netflow_Add_Destination object uses the following line to add the 3 values from
netflow_Destination to the ASA flow-export command.
flow-export destination $netflow_Destination.get(0) $netflow_Destination.get(1)
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$netflow_Destination.get(2)

In this example, you would use the Insert menu in the FlexConfig object editor to add the first use of
$netflow_Destination, and then add .get(0). But you would type in the variable directly for the
$netflow_Destination.get(1) and $netflow_Destination.get(2) specifications.
Multiple Value Variables that Resolve to a Table of Values
Some system variables return a table of values. These variables include MAP in their name, for example,
$SYS_FTD_ROUTED_INTF_MAP_LIST. The routed interface map returns data that looks like the following
(line returns added for clarity):
[{intf_hardwarare_id=GigabitEthernet0/0, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=255.255.255.0,
intf_ip_addr_v4=10.100.10.1, intf_ipv6_link_local_address=,
intf_logical_name=outside},
{intf_hardwarare_id=GigabitEthernet0/1, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=255.255.255.0,
intf_ip_addr_v4=10.100.11.1, intf_ipv6_link_local_address=,
intf_logical_name=inside},
{intf_hardwarare_id=GigabitEthernet0/2, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=, intf_ip_addr_v4=,
intf_ipv6_link_local_address=, intf_logical_name=},
{intf_hardwarare_id=Management0/0, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=, intf_ip_addr_v4=,
intf_ipv6_link_local_address=, intf_logical_name=diagnostic}]

In the above example, information is returned for 4 interfaces. Each interface includes a table of named values.
For example, intf_hardwarare_id is the name of the interface hardware name property, and returns strings
such as GigabitEthernet0/0.
This type of variable is typically of indeterminate length, so you need to use looping to process the values.
But you also need to add the property name to the variable name to indicate which value to retrieve.
For example, IS-IS configuration requires that you add the ASA isis command to an interface that has a logical
name in interface configuration mode. However, you enter that mode using the interface’s hardware name.
Thus, you need to identify which interfaces have logical names, then configure just those interfaces using
their hardware names. The ISIS_Interface_Configuration predefined FlexConfig does this using an if/then
structure nested in a loop. In the following code, you can see that the #foreach scripting command loads each
interface map into the $intf variable, then the #if statement keys off the intf_logical_name value in the map
($intf.intf_logical_name), and if the value is in the list defined in the isisIntfList predefined text variable,
enters the interface command using the intf_hardwarare_id value ($intf.intf_hardwarare_id). You would need
to edit the isisIntfList variable to add the names of the interfaces on which to configure IS-IS.
#foreach ($intf in $SYS_FTD_ROUTED_INTF_MAP_LIST)
#if ($isIsIntfList.contains($intf.intf_logical_name))
interface $intf.intf_hardwarare_id
isis
#if ($isIsAddressFamily.contains("ipv6"))
ipv6 router isis
#end
#end
#end
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How to See What a Variable Will Return for a Device
An easy way to evaluate what a variable will return is to create a simple FlexConfig object that does nothing
more than process an annotated list of variables. Then, you can assign it to a FlexConfig policy, assign the
policy to a device, save the policy, then preview the configuration for that device. The preview will show the
resolved values. You can select the preview text, press Ctrl+C, then paste the output into a text file for analysis.

Note

Do not deploy this FlexConfig to the device, however, because it will not contain any valid configuration
commands. You would get deployment errors. After obtaining the preview, delete the FlexConfig object from
the FlexConfig policy and save the policy.
For example, you could construct the following FlexConfig object:
Following is a network object group variable for the
IPv4-Private-All-RFC1918 object:
$IPv4_Private_addresses
Following is the system variable SYS_FW_MANAGEMENT_IP:
$SYS_FW_MANAGEMENT_IP
Following is the system variable SYS_FW_ENABLED_INSPECT_PROTOCOL_LIST:
$SYS_FW_ENABLED_INSPECT_PROTOCOL_LIST
Following is the system variable SYS_FTD_ROUTED_INTF_MAP_LIST:
$SYS_FTD_ROUTED_INTF_MAP_LIST
Following is the system variable SYS_FW_INTERFACE_NAME_LIST:
$SYS_FW_INTERFACE_NAME_LIST

The preview of this object might look like the following (line returns added for clarity):
###Flex-config Prepended CLI ###
###CLI generated from managed features ###
###Flex-config Appended CLI ###
Following is an network object group variable for the
IPv4-Private-All-RFC1918 object:
[10.0.0.0, 172.16.0.0, 192.168.0.0]
Following is the system variable SYS_FW_MANAGEMENT_IP:
192.168.0.171
Following is the system variable SYS_FW_ENABLED_INSPECT_PROTOCOL_LIST:
[dns, ftp, h323 h225, h323 ras, rsh, rtsp, sqlnet, skinny, sunrpc,
xdmcp, sip, netbios, tftp, icmp, icmp error, ip-options]
Following is the system variable SYS_FTD_ROUTED_INTF_MAP_LIST:
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[{intf_hardwarare_id=GigabitEthernet0/0, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=255.255.255.0,
intf_ip_addr_v4=10.100.10.1, intf_ipv6_link_local_address=,
intf_logical_name=outside},
{intf_hardwarare_id=GigabitEthernet0/1, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=255.255.255.0,
intf_ip_addr_v4=10.100.11.1, intf_ipv6_link_local_address=,
intf_logical_name=inside},
{intf_hardwarare_id=GigabitEthernet0/2, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=, intf_ip_addr_v4=,
intf_ipv6_link_local_address=, intf_logical_name=},
{intf_hardwarare_id=Management0/0, intf_ipv6_eui64_addresses=[],
intf_ipv6_prefix_addresses=[], intf_subnet_mask_v4=, intf_ip_addr_v4=,
intf_ipv6_link_local_address=, intf_logical_name=diagnostic}]
Following is the system variable SYS_FW_INTERFACE_NAME_LIST:
[outside, inside, diagnostic]

FlexConfig Policy Object Variables
A policy object variable is associated with a specific policy object configured in the Object Manager. When
you insert a policy object variable in a FlexConfig object, you give the variable a name and select the object
associated with it.
Although you can give the variable the exact same name as the associated object, the variable itself is not the
same thing as the associated object. You must use the Insert > Insert Policy Object > Object Type menu in
the FlexConfig object editor to add the variable for the first time to the script in the FlexConfig to establish
the association with the object. Simply typing in the name of the object preceded by a $ sign does not create
a policy object variable.
You can create variables to point to the following types of object. Ensure that you create the right type of
object for each variable. To create objects, go to the Objects > Object Management page.
• Text Objects—For text strings, which can include IP addresses, numbers, and other free-form text such
as interface or zone names. Select FlexConfig > Text Object from the table of contents, then click Add
Text Object. You can configure these objects to contain a single value or multiple values. These objects
are highly flexible and built specifically for use within FlexConfig objects. For detailed information, see
Configure FlexConfig Text Objects, on page 23.
• Network—For IP addresses. You can use network objects or groups. Select Network from the table of
contents, then select Add Network > Add Object or Add Group. If you use a group object, the variable
returns a list of each IP address specification within the group. Addresses can be host, network, or address
ranges, depending on the object contents. See Network Objects.
• Security Zones—For interfaces within a security zone or interface group. Select Interface from the
table of contents, then select Add > Security Zone or Interface Group. A security zone variable returns
a list of the interfaces within that zone or group for the device being configured. See Interface Objects:
Interface Groups and Security Zones.
• Standard ACL Object—For standard access control lists. A standard ACL variable returns the name
of the standard ACL object. Select Access List > Standard from the table of contents, then click Add
Standard Access List Object. See Access List.
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• Extended ACL Object—For extended access control lists. An extended ACL variable returns the name
of the extended ACL object. Select Access List > Extended from the table of contents, then click Add
Extended Access List Object. See Access List.
• Route Map—For route map objects. A route map variable returns the name of the route map object.
Select Route Map from the table of contents, then click Add Route Map. See Route Maps.

FlexConfig System Variables
System variables are replaced with information obtained from the device itself or from policies configured
for it.
You must use the Insert > Insert System Variable > Variable Name menu in the FlexConfig object editor
to add the variable for the first time to the script in the FlexConfig to establish the association with the system
variable. Simply typing in the name of the system variable preceded by a $ sign does not create a system
variable within the context of the FlexConfig object.
The following table explains the available system variables. Before using a variable, examine what is typically
returned for the variable; see How to See What a Variable Will Return for a Device, on page 9.
Name

Description

SYS_FW_OS_MODE

The operating system mode of the device. Possible values are ROUTED or
TRANSPARENT.

SYS_FW_OS_MULTIPLICITY

Whether the device is running in single or multiple context mode. Possible
values are SINGLE, MULTI, or NOT_APPLICABLE.

SYS_FW_MANAGEMENT_IP

The management IP address of the device

SYS_FW_HOST_NAME

The device hostname

SYS_FTD_INTF_POLICY_MAP

A map with interface name as key and policy-map as value. This variable
returns nothing if there are no interface-based service policies defined on
the device.

SYS_FW_ENABLED_INSPECT_PROTOCOL_LIST The list of protocols for which inspection is enabled.
SYS_FTD_ROUTED_INTF_MAP_LIST

A list of routed interface maps on the device. Each map includes a set of
named values related to routed interface configuration.

SYS_FTD_SWITCHED_INTF_MAP_LIST

A list of switched interface maps on the device. Each map includes a set of
named values related to switched interface configuration.

SYS_FTD_INLINE_INTF_MAP_LIST

A list of inline interface maps on the device. Each map includes a set of
named values related to inline set interface configuration.

SYS_FTD_PASSIVE_INTF_MAP_LIST

A list of passive interface maps on the device. Each map includes a set of
named values related to passive interface configuration.

SYS_FTD_INTF_BVI_MAP_LIST

A list of Bridge Virtual Interface maps on the device. Each map includes
a set of named values related to BVI configuration.

SYS_FW_INTERFACE_HARDWARE_ID_LIST

A list of the hardware names for interfaces on the device, such as
GigabitEthernet0/0.
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Name

Description

SYS_FW_INTERFACE_NAME_LIST

A list of logical names for interfaces on the device, such as inside.

SYS_FW_INLINE_INTERFACE_NAME_LIST

A list of logical names for interfaces configured as passive or ERSPAN
passive.

SYS_FW_NON_INLINE_INTERFACE_NAME_LIST A list of logical names for interfaces that are not part of inline sets, such as
all routed interfaces.

Predefined FlexConfig Objects
The predefined FlexConfig objects provide tested configurations for select features. Use these objects if you
need to configure these features, which otherwise cannot be configured through Firepower Management
Center.
The following table lists the available objects. Make note of the associated text objects. You must edit these
text objects to customize the behavior of the predefined FlexConfig object. The text objects make it possible
for you to customize the configuration using the IP addresses and other attributes required by your network
and device.
If you need to modify a predefined FlexConfig object, copy the object, make changes to the copy, and save
it with a new name. You cannot directly edit a predefined FlexConfig object.
Although you might be able to configure other ASA-based features using FlexConfig, the configuration of
those features has not been tested. If an ASA feature overlaps with something that you can configure in
Firepower Management Center policies, do not attempt to configure it through FlexConfig.
For example, Snort inspection includes the HTTP protocol, so do not enable ASA-style HTTP inspection. (In
fact, you cannot add http to the enableInspectProtocolList object. In this case, you are prevented from
misconfiguring your device.) Instead, configure the access control policy to perform application or URL
filtering, as needed, to implement your HTTP inspection requirements.
FlexConfig Object Name

Description

Associated Text Objects

Default_Inspection_Protocol_Disable

Disables protocols in the global_policy
default policy map.

disableInspectProtocolList

Default_Inspection_Protocol_Enable

Enables protocols in the global_policy
default policy map.

enableInspectProtocolList

Eigrp_Configure

Configures EIGRP routing next-hop,
auto-summary, router-id, eigrp-stub.

eigrpAS, eigrpNetworks,
eigrpDisableAutoSummary, eigrpRouterId,
eigrpStubReceiveOnly,
eigrpStubRedistributed,
eigrpStubConnected, eigrpStubStatic,
eigrpStubSummary

Eigrp_Interface_Configure

Configures EIGRP interface authentication eigrpIntfList, eigrpAS, eigrpAuthKey,
mode, authentication key, hello interval, eigrpAuthKeyId, eigrpHelloInterval,
hold time, split horizon.
eigrpHoldTime, eigrpDisableSplitHorizon
Also uses the system variable
SYS_FTD_ROUTED_INTF_MAP_LIST
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FlexConfig Object Name

Description

Associated Text Objects

Eigrp_Unconfigure

Clears EIGRP configuration for an
autonomous system from the device.

—

Eigrp_Unconfigure_all

Clears all EIGRP configurations.

—

ISIS_Configure

Configures global parameters for IS-IS
routing.

isIsNet, isIsAddressFamily, isISType

ISIS_Interface_Configuration

Interface level IS-IS configuration.

isIsAddressFamily, IsIsIntfList
Also uses the system variable
SYS_FTD_ROUTED_INTF_MAP_LIST

ISIS_Unconfigure

Clears the IS-IS router configuration on the —
device.

ISIS_Unconfigure_All

Clears the IS-IS router configuration from —
the device, including the router assignment
from the device interface.

Netflow_Add_Destination

Creates and configures a Netflow export
destination.

Netflow_Destinations,
netflow_Event_Types

Netflow_Clear_Parameters

Restores Netflow export global default
settings.

—

Netflow_Delete_Destination

Deletes a Netflow export destination.

Netflow_Destinations,
netflow_Event_Types

Netflow_Set_Parameters

Sets global parameters for Netflow export. netflow_Parameters

NGFW_TCP_NORMALIZATION

Modifies the default TCP normalization
configuration.

Policy_Based_Routing

To use this example configuration, copy it, —
modify the interface name, and use the
r-map-object text object to identify a route
map object in the object manager.

Policy_Based_Routing_Clear

Clears Policy Based Routing configurations —
from the device.

Sysopt_AAA_radius

Ignores the authentication key in RADIUS —
accounting responses.

Sysopt_AAA_radius_negate

Negates the Sysopt_AAA_radius
configuration.

Sysopt_basic

Configures sysopt wait time , maximum tcpMssMinimum, tcpMssBytes
segment size for TCP packets, and detailed
traffic statistics.

—

—
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FlexConfig Object Name

Description

Associated Text Objects

Sysopt_basic_negate

Clears sysopt_basic detailed traffic
statistics, wait time, and TCP maximum
segment size.

—

Sysopt_clear_all

Clears all sysopt configurations from the
device.

—

Sysopt_noproxyarp

Configures noproxy-arp CLIs.

Uses system variable
SYS_FW_NON_INLINE_INTF_NAME_LIST

Sysopt_noproxyarp_negate

Clears Sysopt_noproxyarp configurations. Uses system variable
SYS_FW_NON_INLINE_INTF_NAME_LIST

Sysopt_Preserve_Vpn_Flow

Configures syopt preserve VPN flow.

—

Sysopt_Preserve_Vpn_Flow_negate

Clears the Sysopt_Preserve_Vpn_Flow
configuration.

—

Sysopt_Reclassify_Vpn

Configures sysopt reclassify vpn.

—

Sysopt_Reclassify_Vpn_Negate

Negates sysopt reclassify vpn.

—

VxLAN_Clear_Nve

Removes the NVE 1 configured when
—
VxLAN_Configure_Port_And_Nve is used
from the device.

VxLAN_Clear_Nve_Only

Clears the NVE configured on the interface —
when deployed.

VxLAN_Configure_Port_And_Nve

Configures VLAN port and NVE 1.

vxlan_Port_And_Nve

VxLAN_Make_Nve_Only

Sets an interface for NVE only.

vxlan_Nve_Only
Also uses system variables
SYS_FTD_ROUTED_MAP_LIST and
SYS_FTD_SWITCHED_INTF_MAP_LIST

VxLAN_Make_Vni

Creates a VNI interface. After deploying vxlan_Vni
this you have to unregister and re-register
the device to properly discover the VNI
interface.

Wccp_Configure

This template provides an example for
configuring WCCP.

isServiceIdentifier, serviceIdentifier,
wccpPassword

Wccp_Configure_Clear

Clears WCCP configurations.

—

Predefined Text Objects
There are several predefined text objects. These objects are associated with variables used in the predefined
FlexConfig objects. In most cases, you must edit these objects to add values if you use the associated FlexConfig
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object, or you will see errors during deployment. Although some of these objects contain default values, others
are empty.
For information on editing text objects, see Configure FlexConfig Text Objects, on page 23.
Name

Description

Associated FlexConfig Object

disableInspectProtocolList

Disables protocols in the default policy map Disable_Default_Inspection_Protocol
(global_policy).

eigrpAS

Autonomous system number.

Eigrp_Configure,
Eigrp_Interface_Configure,
Eigrp_Unconfigure

eigrpAuthKey

EIGRP authentication key.

Eigrp_Interface_Configure

eigrpAuthKeyId

Shared key id that matches the
authentication key.

Eigrp_Interface_Configure

eigrpDisableAutoSummary

A flag that, when true, disables
auto-summary.

Eigrp_Configure

eigrpDisableSplitHorizon

A flag that, when true, disables split
horizon.

Eigrp_Interface_Configure

eigrpHelloInterval

Seconds between hello transmission.

Eigrp_Interface_Configure

eigrpHoldTime

Seconds before neighbor is considered
down.

Eigrp_Interface_Configure

eigrpIntfList

List of logical interface names where
EIGRP is to be applied.

Eigrp_Interface_Configure

eigrpRouterId

Router-Id, in IP address format.

Eigrp_Configure

eigrpStubConnected

A flag that, when true, allows you to use Eigrp_Configure
connected in the eigrp stub configuration.

eigrpStubReceiveOnly

A flag that, when true, allows you to use
receive-only in the eigrp stub
configuration.

Eigrp_Configure

eigrpStubRedistributed

A flag that, when true, allows you to use
redistributed in the eigrp stub
configuration.

Eigrp_Configure

eigrpStubSummary

A flag that, when true, allows you to use Eigrp_Configure
summary in the eigrp stub configuration.

enableInspectProtocolList

Enables protocols in the default policy map Enable_Default_Inspection_Protocol
(global_policy). You are prevented from
adding protocols whose inspection conflicts
with Snort inspection.
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Name

Description

Associated FlexConfig Object

isIsAddressFamily

The IPv4 or IPv6 address family.

ISIS_Configure
ISIS_Interface_Configuration

IsIsIntfList

List of logical interface names.

isIsISType

IS Type (level-1, level-2-only or level-1-2). ISIS_Configure

isIsNet

Network entity.

isServiceIdentifier

When false, uses the standard web-cache Wccp_Configure
service identifier.

netflow_Destination

Defines a single Netflow export
destination's interface, destination, and
UDP port number.

netflow_Event_Types

Defines the types of events to be exported Netflow_Add_Destination
for a destination as any subset of: all,
flow-create, flow-defined, flow-teardown,
flow-update.

netflow_Parameters

Provides the Netflow export global settings: Netflow_Set_Parameters
active refresh interval (number of minutes
between flow update events), delay (flow
create delay in seconds; default 0 =
command will not appear), and template
time-out rate in minutes.

serviceIdentifier

Dynamic WCCP service identifier number. Wccp_Configure

tcpMssBytes

Maximum segment size in bytes.

tcpMssMinimum

Checks whether to set maximum segment Sysopt_basic
size (MSS), which is set only if this flag is
true.

vxlan_Nve_Only

Parameters for configuring NVE-only on
interface:
• logical name of interface
• IPv4 address (optional for routed
interface)
• IPv4 netmask (optional for routed
interface)
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ISIS_Interface_Configuration

ISIS_Configure

Netflow_Add_Destination

Sysopt_basic

VxLAN_Make_Nve_Only

FlexConfig Policies
Guidelines and Limitations for FlexConfig

Name

Description

Associated FlexConfig Object

vxlan_Port_And_Nve

Parameters used for configuring ports and VxLAN_Configure_Port_And_Nve
NVE for VXLAN:
• vxlan port
• source interface (logical name)
• type (peer or mcast)
• Peer IP Address or
default-mcast-grooup

vxlan_Vni

Parameters used for creating VNI:

VxLAN_Make_Vni

• Interface number (1-10000)
• segment-id (1-16777215)
• nameif (Logical Name of the
interface)
• type (routed or transparent)
• IP address (used in case of routed
mode device) or bridge-group number
(used in case of transparent mode
device)
• netmask (If device is in routed mode)
or unused
wccpPassword

WCCP password.

Wccp_Configure

Guidelines and Limitations for FlexConfig
• When you use the VxLAN_Make_VNI object, you must deploy the same FlexConfig to all units in a
cluster or high availability pair before you form the cluster or high availability pair. The Management
Center requires the VXLAN interfaces to match on all devices before forming the cluster or high
availability pair.
• If you want to configure Equal-Cost-Multi-Path (ECMP) routing using traffic zones, the zone command
differs for FTD devices compared to the one used on ASA. Although you can still follow the instructions
in the ASA general configuration guide, use zone name ecmp instead of the ASA version of the command.
Otherwise, the operation of the traffic zone feature is identical between the ASA and FTD .

Note

The system also configures zone name passive commands to configure passive
zones if you define some interfaces as passive. This is handled automatically
based on your interface configuration. Do not use FlexConfig to create passive
traffic zones.
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Customizing Device Configuration with FlexConfig Policies
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
Use FlexConfig policies to customize the configuration of a FTD device.
Before using FlexConfig, try to configure all the policies and settings you need using the other features in
Firepower Management Center. FlexConfig is a method of last resort to configure ASA-based features that
are compatible with FTD but which are not otherwise configurable in Firepower Management Center.
Following is the end-to-end procedure for configuring and deploying a FlexConfig policy.
Procedure

Step 1

Determine the CLI command sequence that you want to configure.
If you have a functioning configuration on an ASA device, use show running-config to get the sequence of
commands that you need. Make adjustments to items such as interface names and IP addresses as needed.
If this is for a new feature, it is best to try to implement it on an ASA device in a lab setting to verify that you
have the correct command sequence.
For more information, see the following topics:
• Recommended Usage for FlexConfig Policies, on page 1
• CLI Commands in FlexConfig Objects, on page 2

Step 2

Select Objects > Object Management, then select FlexConfig > FlexConfig Objects from the table of
contents.
Examine the predefined FlexConfig objects to determine if any will be able to generate the commands you
need. Click the view icon ( ) to see the object contents. If an existing object is close to what you want, start
by making a copy of the object, and then edit the copy. See Predefined FlexConfig Objects, on page 12.
Examining the objects will also give you an idea of the structure, command syntax, and expected sequencing
for a FlexConfig object.
Note

Step 3

If you find any objects that you will use, either directly or as copies, examine the Variables list at
the bottom of the object. Make note of the variable names, except those in all capitals that start with
SYS, which are system variables. These variables are text objects that you will probably need to
edit and define overrides for, especially if the default value column shows the object has no value.

If you need to create your own FlexConfig objects, determine what variables you will need and create the
associated objects.
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The CLI you need to deploy might contain IP addresses, interface names, port numbers, and other parameters
that you might want to adjust over time. These are best isolated into variables, which point to objects that
contain the necessary values. You might also need variables for strings that are part of the configuration but
which might change over time.
Also, determine if you need different values for each device to which you will assign the policy. For example,
you might want to configure the feature on three devices, but you might need to specify a different interface
name or IP address on a given command for each of these devices. If you need to customize the object for
each device, ensure that you enable overrides when creating the object, and then define the override values
per device.
See the following topics for an explanation of the various types of variables and how to configure the related
objects when necessary.
• FlexConfig Variables, on page 5
• FlexConfig Policy Object Variables, on page 10
• FlexConfig System Variables, on page 11
• Configure FlexConfig Text Objects, on page 23
Step 4

If you are using the predefined FlexConfig objects, edit the text objects used as variables.
See Configure FlexConfig Text Objects, on page 23.

Step 5

(If necessary.) Configure FlexConfig Objects, on page 20.
You need to create objects only if the predefined objects cannot do the job.

Step 6

Configure the FlexConfig Policy, on page 25.

Step 7

Set Target Devices for a FlexConfig Policy, on page 26.
You can also assign the policy to devices when you create the policy. The policy must have at least one
assigned device before you can preview it.

Step 8

Preview the FlexConfig Policy, on page 27.
You must save changes before you can preview the policy.
Verify that the generated commands are the ones intended, and that all variables are resolving correctly.

Step 9

Click Deploy in the menu bar, select the devices assigned to the policy, and click the Deploy button.
Wait for deployment to complete.

Step 10

Verify the Deployed Configuration, on page 28.

Step 11

(If necessary.) Remove Features Configured Using FlexConfig, on page 30.
Unlike other types of policy, simply unassigning a FlexConfig from a device might not remove the related
configuration. If you want to remove a FlexConfig-generated configuration, you follow the cited procedure.
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Configure FlexConfig Objects
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
Use FlexConfig objects to define a configuration to be deployed to a device. Each FlexConfig policy is
composed of a list of FlexConfig objects, so the objects are essentially code modules composed of Apache
Velocity scripting commands, ASA software configuration commands, and variables.
There are several predefined FlexConfig objects that you can use directly, or you can make copies if you need
to edit them. You can also create your own objects from scratch. A FlexConfig object’s content can range
from a single simple command string to elaborate CLI command structures that use variables and scripting
commands to deploy commands whose content can differ from device to device or deployment to deployment.
You can also create FlexConfig policy objects when defining FlexConfig policies.
Before you begin
Keep the following in mind:
• FlexConfig objects translate into commands that are then deployed to the device. These commands are
already issued in global configuration mode. Therefore, do not include the enable and configure terminal
commands as part of the FlexConfig object.
• Determine what types of variables you will need, and create any policy objects that you will require.
You cannot create objects for variables while editing a FlexConfig object.
• Ensure that your commands do not conflict in any way with the VPN or access control configuration on
the devices.
• If there is more than one set of commands for an interface, only the last set of commands is deployed.
Therefore, we recommend you not use beginning and ending commands to configure interfaces. For an
example of configuring interfaces, see the ISIS_Interface_Configuration predefined FlexConfig object.
Procedure

Step 1

Choose Objects > Object Management.

Step 2

Choose FlexConfig > FlexConfig Object from the list of object types.

Step 3

Do one of the following:
• Click Add FlexConfig Object to create a new object.
• Click the edit icon (
• Click the view icon (
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) to edit an existing object.
) to see the contents of a predefined object.
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• If you want to edit a predefined object, click the copy icon (
contents.

) to create a new object with the same

Step 4

Enter a Name and optionally, a description for the object.

Step 5

In the object body area, enter the commands and instructions to produce the required configuration.
The object content is a sequence of scripting commands and configuration commands that generate a valid
ASA software command sequence. The FTD device uses ASA software commands to configure some features.
For more information on scripting and configuration commands, see:
• Template Scripts, on page 5
• CLI Commands in FlexConfig Objects, on page 2
You can use variables to supply information that can be known only at runtime, or which can differ from
device to device. You simply type in processing variables, but you must use the Insert menu to add variables
that are associated with policy objects or system variables. For a complete discussion of variables, see
FlexConfig Variables, on page 5.
• To insert system variables, choose Insert > Insert System Variable > Variable Name. For a detailed
explanation of these variables, see FlexConfig System Variables, on page 11.
• To insert policy object variables, choose Insert > Insert Policy Object > Object Type, selecting the
appropriate type of object. Then, give the variable a name (which can be the same name as the associated
policy object), select the object to associate with the variable, and click Save. For a detailed explanation
of these types, see FlexConfig Policy Object Variables, on page 10. For more detail on the procedure,
see Add a Policy Object Variable to a FlexConfig Object, on page 22.
Note

Step 6

You must use the Insert menu to create a new policy object or system variable. However, for
subsequent uses of that variable, you must type it in, $ included. This is also true for system variables:
the first time you use it, add it from the Insert menu. Then, type it out for subsequent uses. If you
use the Insert menu more than once for a system variable, the system variable is added to the
Variables list multiple times, and the FlexConfig will not validate, meaning you cannot save your
changes. For processing variables (those not associated with a policy object or system variable),
simply type in the variable.

Choose the deployment frequency and type.
• Deployment—Whether to deploy the commands in the object Once or Everytime. The only way to
choose the right option is to test the results of deployment.
Start by selecting Everytime. Then, after you attach the object to a FlexConfig policy, deploy the
configuration. After a successful deployment, come back to the FlexConfig policy and preview the
configuration for one of the assigned devices as described in Preview the FlexConfig Policy, on page
27. If the section labeled ###CLI generated from managed features ### contains commands that
clear or negate the commands in the object, and the ###Flex-config Appended CLI ### section contains
the commands to reconfigure the feature, you know that Everytime is the right option.
Even if you do not see negate commands, make some minor change to the device configuration, then
run another deployment. If the deployment completes successfully, you can check the deployment
transcript (see Verify the Deployed Configuration, on page 28). If you see that the commands were
issued again (even when they were already configured) without error, then you can keep Everytime.
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Change to Once only if the system does not first negate the commands in the object before issuing them
again, or if the deployment results in errors that are specific to the command. In some cases, the system
does not allow you to issue a command that is already configured, but this is the exception.
Some additional tips:
• If the FlexConfig object points to system-managed objects such as network or ACL objects, choose
Everytime. Otherwise, updates to the objects might not get deployed.
• Use Once if the only thing you do in the object is to clear a configuration. Then, remove the object
from the FlexConfig policy after the next deployment.
• Type—Select one of the following:
• Append—(The default.) Commands in the object are put at the end of the configurations generated
from the Firepower Management Center policies. You must use Append if you use policy object
variables, which point to objects generated from managed objects. If commands generated for other
policies overlap with those specified in the object, you should select this option so your commands
are not overwritten. This is the safest option.
• Prepend—Commands in the object are put at the beginning of the configurations generated from
the Firepower Management Center policies. You would typically use prepend for commands that
clear or negate a configuration.
Step 7

(Optional.) Click the Validate icon above the object body to check the integrity of the script.
The object is always validated when you click Save. You cannot save an invalid object.

Step 8

Click Save.

What to do next
• If an active policy references your object, deploy configuration changes; see Deploy Configuration
Changes.

Add a Policy Object Variable to a FlexConfig Object
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
You can insert variables into a FlexConfig policy object that are associated with other types of policy object.
When the FlexConfig is deployed to a device, these variables resolve to the names or content of the associated
object.
Use the following procedure for the first use of a policy object variable in a FlexConfig object. If you need
to refer to the object again, type in the variable (including the $ sign). To understand how to use these variables,
see How to Process Variables, on page 6.
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Procedure

Step 1

Choose Insert > Insert Policy Object > Object Type, selecting the appropriate type of object.

Step 2

Enter a name for the variable, and optionally, a description.
The name must be unique within the context of the FlexConfig object. It cannot include spaces. You are
allowed to use the exact same name as the object associated with the variable.

Step 3

Select the object to associate with the variable and click Add to move it to the Selected Object list.
You can associate a variable with a single object only.
Note

Step 4

For text objects, you can select any of the predefined objects as needed. However, many of these
objects have no default values. You must update the objects to add the required values either directly
or as overrides for the device to which you will deploy the FlexConfig object. Trying to deploy a
FlexConfig without updating these objects typically results in deployment errors.

Click Save.
The variable appears in the Variables list at the bottom of the FlexConfig object editor.

Configure FlexConfig Text Objects
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
Use text objects in FlexConfig objects as the target of policy object variables. You can use variables to supply
information that can be known only at runtime, or which can differ from device to device. During deployment,
variables that point to text objects are replaced by the content of the text object.
Text objects contain free-form strings, which can be keywords, interface names, numbers, IP addresses, and
so forth. The content depends on how you will use the information within a FlexConfig script.
Before creating or editing a text object, determine exactly what content you will need. This includes how you
intend to process the object, which will help you decide between creating a single string or multiple string
object. Read the following topics:
• FlexConfig Variables, on page 5
• How to Process Variables, on page 6
Procedure

Step 1

Choose Objects > Object Management.
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Step 2

Choose FlexConfig > Text Object from the list of object types.

Step 3

Do one of the following:
• Click Add Text Object to create a new object.
• Click the edit icon ( ) to edit an existing object. You are allowed to edit the predefined text objects,
which is required if you intended to use the predefined FlexConfig objects.

Step 4

Enter a Name and optionally, a description for the object.

Step 5

(New objects only.) Choose a Variable Type from the drop-down list:
• Single—If the object should contain a single text string.
• Multiple—If the object should contain a list of text strings.
You cannot change the variable type after you save the object.

Step 6

If the variable type is Multiple, use the up and down arrows to specify a Count.
Rows are added or removed from the object as you change the number.

Step 7

Add content to the object.
You can either click in the text box next to a variable number and type in a value, or you can set up device
overrides for each device that will be assigned a FlexConfig object that uses the text object. You can also do
both, in which case the values configured in the base object act as default values in cases where an override
does not exist for a given device.
When editing predefined objects, it is a good practice to use device overrides, so that the system defaults
remain in place for other users who might need to use the object in different FlexConfig policies. The approach
you take depends on the requirements of your organization.
Tip

Some predefined objects require multiple values where each value serves a specific purpose. Read
the description text carefully to determine the expected values in the object. In some cases, the
instructions specify that you must use overrides instead of changing the base values. In the case of
enableInspectProtocolList, you are prevented from entering protocols whose inspection is
incompatible with Snort inspection.

If you decide to use device overrides, do the following.
a) Select Allow Overrides.
b) Expand the Overrides area (if necessary) and click Add.
If an override already exists for the device, click the edit icon for the override to change it.
c) On the Targets tab in the Add Object Override dialog box, select the device for which you are defining
values and click Add to move it to the Selected Devices list.
d) Click the Override tab, adjust the Count as needed, then click in the variable fields and type in the values
for the device.
e) Click Add.
Step 8

Click Save.
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What to do next
• If an active policy references your object, deploy configuration changes; see Deploy Configuration
Changes.

Configure the FlexConfig Policy
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
A FlexConfig policy contains two ordered lists of FlexConfig objects, one prepended list and one appended
list. For an explanation of prepend/append, see Configure FlexConfig Objects, on page 20.
FlexConfig policies are shared policies that you can assign to multiple devices.
Procedure

Step 1

Choose Devices > FlexConfig.

Step 2

Do one of the following:
• Click New Policy to create a new FlexConfig Policy. You are prompted to enter a name. Optionally,
select devices in the Available Devices list and click Add to Policy to assign devices. Click Save.
• Click the edit icon (
them in edit mode.

) to edit an existing Policy. You can change the name or description by clicking

• Click the copy icon ( ) to create a new policy with the same contents. You are prompted for a name.
Device assignments are not retained for the copy.
• Click the delete icon to remove a policy you no longer need.
Step 3

Select the FlexConfig objects required for the policy from the Available FlexConfig list and click > to add
them to the policy.
Objects are automatically added to the prepended or appended list based on the deployment type specified in
the FlexConfig object.
To remove a selected object, click the delete icon (

Step 4

For each selected object, click the view icon (

) next to an object.

) next to the object to identify the variables used in the object.

Except for system variables, which start with SYS, you need to ensure that the objects associated with the
variables are not empty. A blank or brackets with nothing between them, [ ], indicate an empty object. You
will need to edit these objects before deploying the policy.
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Note

Step 5

If you use object overrides, those values will not show up in this view. Thus, an empty default value
does not necessarily mean that you have not updated the object with the required values. Previewing
the configuration will show whether the variables resolve correctly for a given device. See Preview
the FlexConfig Policy, on page 27.

Click Save.

What to do next
• Set target devices for the policy; see Set Target Devices for a FlexConfig Policy, on page 26.
• Deploy configuration changes; see Deploy Configuration Changes.

Set Target Devices for a FlexConfig Policy
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
When you create a FlexConfig policy, you can select the devices that use the policy. You can subsequently
change device assignments for the policy as described below.

Note

Normally, when you unassign a policy from a device, the system automatically removes the associated
configuration upon the next deployment. However, because FlexConfig objects are scripts for deploying
customized commands, simply unassigning a FlexConfig policy from a device does not remove the commands
that were configuring by the FlexConfig objects. If your intention is to remove FlexConfig-generated commands
from a device's configuration, see Remove Features Configured Using FlexConfig, on page 30.
Procedure

Step 1

Choose Devices > FlexConfig and edit a FlexConfig policy.

Step 2

Click Policy Assignments.

Step 3

On the Targeted Devices tab, build your target list:
• Add—Choose one or more Available Devices, then click Add to Policy or drag and drop into the list
of Selected Devices. You can assign the policy to devices, high availability pairs, and clustered devices.
• Delete—Click the delete icon (
choose Delete Selection.

Step 4

Click OK to save your selection.
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Step 5

Click Save to save the FlexConfig policy.

What to do next
• Deploy configuration changes; see Deploy Configuration Changes.

Preview the FlexConfig Policy
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
Preview a FlexConfig policy to see how the FlexConfig objects get translated into CLI commands. The preview
shows the commands that will be generated for a selected device from the scripts and variables used in the
FlexConfig objects. The variables are resolved based on the configuration for the device, so you get a clear
idea of what will be deployed.
Use the preview to look for potential problems in the FlexConfig objects. Correct the objects until the preview
shows the expected results.
You must preview the configuration separately for each device, because the variables can resolve differently
based on the device configuration.
Procedure

Step 1

Choose Devices > FlexConfig and edit a FlexConfig policy.

Step 2

If there are any pending changes, click Save.
The preview shows results only for those FlexConfig objects that were in the most recently saved version of
the policy. You must save the policy to see a preview of newly-added objects.

Step 3

Click Preview Config.

Step 4

Choose a device from the Select Device drop-down list.
The system retrieves information from the device and configured policies, and determines what CLI commands
will be generated on the next deployment to the device. You can select the output and use Ctrl+C to copy it
to the clipboard, where you can paste it into a text file for further analysis.
The preview includes the following sections:
• Flex-config Prepended CLI—These are the commands generated by FlexConfigs that are prepended to
the configuration.
• CLI generated from managed features—These are commands generated for policies configured in
Firepower Management Center. Commands are generated for new or changed policies since the last
successful deployment to the device. These commands do not represent all commands needed to implement
the assigned policies. No commands in this section are generated from FlexConfig objects.
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• Flex-config Appended CLI—These are the commands generated by FlexConfigs that are appended to
the configuration.
Step 5

Click Close to close the preview dialog.

Verify the Deployed Configuration
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
After you deploy a FlexConfig policy to a device, verify that the deployment was successful and that the
resulting configuration is what you expected. Also, verify that the device is performing as expected.
Procedure

Step 1

To verify that deployment was successful:
a) Click the System Status icon in the menu bar, which is the unnamed icon between Deploy and System.
The icon looks like one of the following, and it might include a number if there are errors:
•

— Indicates no warnings or errors are present on the system.

•

— Indicates one or more warnings and no errors are present on the system.

•

— Indicates one or more errors and any number of warnings are present on the system.

b) On the Deployments tab, verify that the deployment was successful.
c) To see more detailed information, especially for failed deployments, click Show History.
d) Select the deployment job in the list of jobs in the left column.
Jobs are listed in reverse chronological order, with the most recent job at the top of the list.
e) Click the download icon in the Transcript column for the device in the right column.
The deployment transcript includes commands sent to the device, and any responses returned from the
device. These response can be informative messages or error messages. For failed deployments, look for
messages that indicate errors with the commands that you sent through FlexConfig. These errors can help
you correct the script in the FlexConfig object that is trying to configure the commands.
Note

There is no distinction made in the transcript between commands sent for managed features and
those generated from FlexConfig policies.

For example, the following sequence shows that Firepower Management Center (FMC) sent commands
to configure GigabitEthernet0/0 with the logical name outside. The device responded that it automatically
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set the security level to 0. FTD does not use the security level for anything. Messages relevant to FlexConfig
are in the CLI Apply section of the transcript.
========= CLI APPLY =========
FMC >> interface GigabitEthernet0/0
FMC >> nameif outside
FTDv 192.168.0.152 >> [info] : INFO: Security level for "outside" set to 0 by default.

Step 2

Verify that the deployed configuration includes the expected commands.
You can do this by making an SSH connection to the device's management IP address. Use the show
running-config command to view the configuration.
Alternatively, use the CLI tool within Firepower Management Center.
a) Choose System > Health > Monitor and click the name of the device.
You might need to click the open/close arrow in the Count column in the Status table to see any devices.
b)
c)
d)
e)

Click Advanced Troubleshooting.
Click the Threat Defense CLI tab.
Select show as the command, and type running-config as the parameter.
Click Execute.
The running configuration appears in the text box. You can select the configuration and press Ctrl+C,
then paste it into a text file for later analysis.

Step 3

Verify that the device is performing as expected.
Use the show commands related to the feature to see detailed information and statistics. For example, if you
enabled additional protocol inspections, the show service-policy command provides this information. The
exact commands to use are feature-dependent and should be mentioned in the ASA configuration guide and
command reference you used to learn how to configure the feature.
If commands that show statistics indicate that numbers are not changing (for example, hit counts, connection
counts, and so forth), the configuration might be valid but not meaningful. If you know that traffic is going
through the device that should show up in statistics, look for what is missing in your configuration. For
example, NAT or access rules might be dropping or changing traffic before a feature can act on it.
You can use the show commands from an SSH session or through the Firepower Management Center CLI
tool.
However, if the show command that you need to use is not available directly within the FTD CLI, you will
need make an SSH connection to the device to use the commands. From the CLI, enter the following command
sequence to enter Privileged EXEC mode within the diagnostic CLI. From there, you should be able to enter
these otherwise unsupported show commands.
> system support diagnostic-cli
Attaching to Diagnostic CLI ... Press 'Ctrl+a then d' to detach.
Type help or '?' for a list of available commands.
firepower> enable
Password: <press enter, do not enter a password>
firepower#
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Remove Features Configured Using FlexConfig
Smart License

Classic License

Supported Devices Supported Domains Access

Any

N/A

Firepower Threat
Defense

Any

Admin

Firepower Threat
Defense Virtual
If you decide you need to remove a set of configuration commands you configured using FlexConfig, you
might need to manually remove that configuration. Unassigning the FlexConfig policy from a device might
not remove all of the configuration.
To manually remove the configuration, you create new FlexConfig objects to clear or negate the configuration
commands.
Before you begin
To determine if you need to manually remove some or all of the configuration generated by an object:
1. Examine the configuration preview, as described in Preview the FlexConfig Policy, on page 27. If the
###CLI generated from managed features ### section contains the clear or negate commands to
remove all of the commands in the FlexConfig object, then you can simply remove the object from the
FlexConfig policy, save, and redeploy.
2. Remove the object from the FlexConfig policy, save the change, then preview the configuration again. If
the ###CLI generated from managed features ### section still does not include the required clear or
negate commands, you must follow this procedure to manually remove the configuration.
Procedure

Step 1

Choose Objects > Object Management and create the FlexConfig Objects to clear or negate the configuration
commands.
If a feature has a clear command that can remove all configuration settings, then use that command. For
example, the predefined Eigrp_Unconfigure_All object contains a single command that removes all
EIGRP-related configuration commands:
clear configure router eigrp

If there is not a clear command for the feature, you need to use the no form of each command you want to
remove. For example, the predefined Sysopt_basic_negate object removes the commands configured through
the predefined Sysopt_basic object.
no sysopt traffic detailed-statistics
no sysopt connection timewait

You would typically configure a FlexConfig object that removes configurations as a prepended, deploy once
object.
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Step 2

Choose Devices > FlexConfig and create a new FlexConfig policy or edit the existing policy.
If you want to preserve the FlexConfig policy that deploys the configuration commands, create a new policy
specifically for negating the commands, and assign the devices to the policy. Then, add the new FlexConfig
objects to the policy.
If you want to completely remove the FlexConfig configuration objects from all devices, you can simply
delete those commands from the existing FlexConfig policy and replace them with the objects that negate the
configuration.

Step 3

Click Save to save the FlexConfig policy.

Step 4

Click Preview Config and verify that the clear and negation commands are generating correctly.

Step 5

Click Deploy in the menu bar, select the device, and click the Deploy button.
Wait for deployment to complete.

Step 6

Verify that the commands were removed.
View the running configuration on the device to confirm that the commands are removed. For more detailed
information, see Verify the Deployed Configuration, on page 28.

Step 7

While editing the FlexConfig policy, click Policy Assignments and remove the device. Optionally, remove
the FlexConfig Objects from the policy.
Assuming that the FlexConfig policy simply removes the unwanted configuration commands, there is no need
to keep the policy assigned to the device after the removal is complete.
However, if the FlexConfig policy retains options that you still want configured on the device, remove the
negation objects from the policy. They are no longer needed.
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