Software and Configurations

This chapter describes how to manage the ASA software and configurations.

* Upgrade the Software, on page 1

* Load an Image Using ROMMON (ISA 3000), on page 1

» Upgrade the ROMMON Image (ISA 3000), on page 3

» Downgrade Your Software, on page 4

* Manage Files, on page 10

* Set the ASA Image, ASDM, and Startup Configuration, on page 16
» Back Up and Restore Configurations or Other Files, on page 18

* Schedule a System Restart, on page 24

* Hot Swap an SSD on the Secure Firewall 3100, on page 25

* History for Software and Configurations, on page 27

Upgrade the Software

See the Cisco ASA Upgrade Guide for full upgrade procedures.

Load an Image Using ROMMON (ISA 3000)

Step 1
Step 2
Step 3
Step 4

To load a software image onto an ASA from the ROMMON mode using TFTP, perform the following steps.

Procedure

Connect to the ASA console port according to the instructions in Access the ISA 3000 Console.
Power off the ASA, then power it on.
During startup, press the Escape key when you are prompted to enter ROMMON mode.

In ROMMOM mode, define the interface settings to the ASA, including the IP address, TFTP server address,
gateway address, software image file, and port, as follows:

rommon #1> interface gigabitethernet0/0
rommon #2> address 10.86.118.4
rommon #3> server 10.86.118.21
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. Load an Image Using ROMMON (ISA 3000)

Step 5

Step 6

Step 7

Step 8

rommon #4> gateway 10.86.118.21
rommon #5> file asa961-smp-k8.bin
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Note Be sure that the connection to the network already exists.

The interface command is ignored on the ASA 5

506-X, ASA 5508-X, and ASA 5516-X, and

ISA 3000 platforms, and you must perform TFTP recovery on these platforms from the

Management 1/1 interface.
Validate your settings:

rommon #6> set

ROMMON Variable Settings:
ADDRESS=10.86.118.3
SERVER=10.86.118.21
GATEWAY=10.86.118.21
PORT=GigabitEthernet0/0
VLAN=untagged
IMAGE=asa961-smp-k8.bin
CONFIG=
LINKTIMEOUT=20
PKTTIMEOUT=4
RETRY=20

Ping the TFTP server:

rommon #7> ping server

Sending 20, 100-byte ICMP Echoes to server 10.86.118.21, timeout is 4 seconds:

Success rate is 100 percent (20/20)

Save the network settings for future use:

rommon #8> sync
Updating NVRAM Parameters...

Load the software image:

rommon #9> tftpdnld
ROMMON Variable Settings:
ADDRESS=10.86.118.3
SERVER=10.86.118.21
GATEWAY=10.86.118.21
PORT=GigabitEthernet0/0
VLAN=untagged
IMAGE=asa961-smp-k8.bin
CONFIG=
LINKTIMEOUT=20
PKTTIMEOUT=4
RETRY=20

tftp asa%96l-smp-k8.bin@10.86.118.21 via 10.86.118.21
Received 14450688 bytes

Launching TFTP Image...
Cisco ASA Security Appliance admin loader (3.0) #0:
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Loading...

After the software image is successfully loaded, the ASA automatically exits ROMMON mode.

Step 9 Booting the ASA from ROMMON mode does not preserve the system image across reloads; you must still
download the image to flash memory. See the Cisco ASA Upgrade Guide for full upgrade procedures.

Upgrade the ROMMON Image (ISA 3000)

Follow these steps to upgrade the ROMMON image for the ISA 3000. For the ASA models, the ROMMON
version on your system must be 1.1.8 or greater. We recommend that you upgrade to the latest version.

You can only upgrade to a new version; you cannot downgrade.

A

Caution  The ISA 3000 ROMMON upgrade for 1.0.5 takes twice as long as previous ROMMON versions, approximately
15 minutes. Do not power cycle the device during the upgrade. If the upgrade is not complete within 30
minutes or it fails, contact Cisco technical support; do not power cycle or reset the device.

Before you begin

Obtain the new ROMMON image from Cisco.com, and put it on a server to copy to the ASA. The ASA
supports FTP, TFTP, SCP, HTTP(S), and SMB servers. Download the image from:

* ISA 3000: https://software.cisco.com/download/home/286288493/type

Procedure

Step 1 Copy the ROMMON image to the ASA flash memory. This procedure shows an FTP copy; enter copy ? for
the syntax for other server types.

copy ftp://[username: password@]server_ip/asas500-firmwar e-xooxx. SPA disk0: asa5500-fir mwar e-xox. SPA

Step 2 To see your current version, enter the show module command and look at the Fw Version in the output for
Mod 1 in the MAC Address Range table:

ciscoasa# show module

[...]

Mod MAC Address Range Hw Version Fw Version Sw Version
1 7426.aceb.ccea to 7426.aceb.ccf2 0.3 1.1.5 9.4 (1)
sfr 7426.aceb.cce9 to 7426.aceb.cce9 N/A N/A

Step 3 Upgrade the ROMMON image:
upgrade rommon disk0:asa5500-fir mwar e-xxx.SPA

Example:
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ciscoasa# upgrade rommon diskO:asa5500-firmware-1108.SPA
Verifying file integrity of disk0:/asa5500-firmware-1108.SPA

Computed Hash SHAZ2: d824bdeeceel308fc64427367fa559%e9
cefe8f182491652ee4c05e6e751f7a4f
5cdea28540cf60acde3ab9b65f£55a9f
4e0cfb84b9e2317a856580576612f4af

Embedded Hash SHA2: d824bdeeceel308fc64427367fa559%9e9
eefe8f182491652ee4c05e6e751f7a4f
5cdea28540cf60acde3ab9b65f£55a9f
4e0cfb84b9e2317a856580576612f4af

Digital signature successfully validated

File Name : disk0:/asa5500-firmware-1108.SPA
Image type : Release
Signer Information
Common Name : abraxas
Organization Unit : NCS_Kenton ASA
Organization Name : CiscoSystems
Certificate Serial Number : 553156F4
Hash Algorithm : SHA2 512
Signature Algorithm : 2048-bit RSA
Key Version : A

Verification successful.
Proceed with reload? [confirm]

Step 4 Confirm to reload the ASA when you are prompted.
The ASA upgrades the ROMMON image, and then reloads the operating system.

Downgrade Your Software

In many cases, you can downgrade your ASA software and restore a backup configuration from the previous
software version. The method of downgrading depends on your ASA platform.

Guidelines and Limitations for Downgrading

See the following guidelines before downgrading:

» Thereisno official Zero Downtime Downgrade support for clustering—However, in some cases,
Zero Downtime Downgrading will work. See the following known issues for downgrading; note that
there may be other issues that require you to reload your cluster units, thus causing downtime.

» Downgradeto a pre-9.9(1) release with clustering—9.9(1) and later includes an improvement in
the backup distribution. If you have 3 or more units in the cluster, you must perform the following
steps:

1. Remove all secondary units from the cluster (so the cluster consists only of the primary unit).
2. Downgrade | secondary unit, and rejoin it to the cluster.

3. Disable clustering on the primary unit; downgrade it, and rejoin the cluster.
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Guidelines and Limitations for Downgrading .

4. Downgrade the remaining secondary units, and join them back to the cluster, one at a time.

» Downgradeto a pre-9.9(1) release when you enable cluster site redundancy—You should
disable site redundancy if you want to downgrade (or if you want to add a pre-9.9(1) unit to a cluster).
Otherwise, you will see side effects, for example, dummy forwarding flows on the unit running the
old version.

» Downgradefrom 9.8(1) with clustering and crypto-map—There is no Zero Downtime Downgrade
support when downgrading from 9.8(1) when you have a crypto-map configured. You should clear
the crypto-map configuration before downgrading, and then re-apply the configuration after the
downgrade.

» Downgrade from 9.8(1) with clustering unit health check set to .3 to .7 seconds—If you
downgrade your ASA software after setting the hold time to .3 - .7 (health-check holdtime), this
setting will revert to the default of 3 seconds because the new setting is unsupported.

» Downgrade from 9.5(2) or later to 9.5(1) or earlier with clustering (CSCuv82933)—There is
no Zero Downtime Downgrade support when downgrading from 9.5(2). You must reload all units
at roughly the same time so that a new cluster is formed when the units come back online. If you
wait to reload the units sequentially, then they will be unable to form a cluster.

» Downgrade from 9.2(1) or later to 9.1 or earlier with clustering—Zero Downtime Downgrade
is not supported.

» Downgradeissue from 9.18 or later—There is a behavior change in 9.18 where the access-group
command will be listed before its access-list commands. If you downgrade, the access-group command
will be rejected because it has not yet loaded the access-list commands. This outcome occurs even if you
had previously enabled the for war d-r efer ence enable command, because that command is now removed.
Before you downgrade, be sure to copy all access-group commands manually, and then after downgrading,
re-enter them.

Downgrade issue for the Firepower 2100 in Platform mode from 9.13/9.14 t0 9.12 or earlier—For
a Firepower 2100 with a fresh installation of 9.13 or 9.14 that you converted to Platform mode: If you
downgrade to 9.12 or earlier, you will not be able to configure new interfaces or edit existing interfaces
in FXOS (note that 9.12 and earlier only supports Platform mode). You either need to restore your version
to 9.13 or later, or you need to clear your configuration using the FXOS erase configuration command.
This problem does not occur if you originally upgraded to 9.13 or 9.14 from an earlier release; only fresh
installations are affected, such as a new device or a re-imaged device. (CSCvr19755)

Downgrade from 9.10(1) for smart licensing—Due to changes in the smart agent, if you downgrade,
you must re-register your device to the Cisco Smart Software Manager. The new smart agent uses an
encrypted file, so you need to re-register to use an unencrypted file required by the old smart agent.

Downgradeto 9.5 and earlier with passwords using PBK DF2 (Passwor d-Based Key Derivation
Function 2) hash—Versions before 9.6 do not support PBKDF2 hashing. In 9.6(1), enableand username
passwords longer than 32 characters use PBKDF2 hashing. In 9.7(1), new passwords of all lengths use
PBKDF?2 hashing (existing passwords continue to use MD5 hashing). If you downgrade, the enable
password reverts to the default (which is blank). Usernames will not parse correctly, and the username
commands will be removed. You must re-create your local users.

» Downgrade from Version 9.5(2.200) for the ASA Virtual—The ASA virtual does not retain the
licensing registration state. You need to re-register with the license smart register idtoken id_token
force command (for ASDM: see the Configuration > Device Management > Licensing > Smart
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Licensing page, and use the Force registration option); obtain the ID token from the Smart Software
Manager.

* VPN tunnelsarereplicated to the standby unit even if the standby unit isrunning a version of
softwar e that does not support the Ciphersuite that the original tunnel negotiated—This scenario
occurs when downgrading. In this case, disconnect your VPN connection and reconnect.

Incompatible Configuration Removed After Downgrading

When you downgrade to an old version, commands that were introduced in later versions will be removed
from the configuration. There is no automated way to check the configuration against the target version before
you downgrade. You can view when new commands were added in ASA new features by release.

You can view rejected commands after you downgrade using the show startup-config errors command. If
you can perform a downgrade on a lab device, you can preview the effects using this command before you
perform the downgrade on a production device.

In some cases, the ASA migrates commands to new forms automatically when you upgrade, so depending on
your version, even if you did not manually configure new commands, the downgrade could be affected by
configuration migrations. We recommend that you have a backup of your old configuration that you can use
when you downgrade. In the case of upgrading to 8.3, a backup is automatically created
(<old_version>_startup_cfg.sav). Other migrations do not create back-ups. See the "Version-Specific Guidelines
and Migrations" in the ASA Upgrade guide for more information about automatic command migrations that
could affect downgrading.

See also known downgrade issues in Guidelines and Limitations for Downgrading, on page 4.

For example, an ASA running version 9.8(2) includes the following commands:

access-list acll extended permit sctp 192.0.2.0 255.255.255.0 198.51.100.0 255.255.255.0
username testl password $shab5l12$1234Sabcdefghijklmnopgrstuvwxyz privilege 15

snmp-server user snmpuserl snmpgroupl v3 engineID abcdefghijklmnopgrstuvwxyz encrypted auth

md5 12:ab:34 priv aes 128 12:ab:34

When you downgrade to 9.0(4), you will see the following errors on startup:

access-list acll extended permit sctp 192.0.2.0 255.255.255.0 198.51.100.0 255.255.255.0
ERROR: % Invalid input detected at '”~' marker.

username testl password $shab512$1234Sabcdefghijklmnopgrstuvwxyz pbkdf2 privilege 15
ERROR: % Invalid input detected at '”~' marker.

snmp-server user snmpuserl snmpgroupl v3 engineID abcdefghijklmnopgrstuvwxyz encrypted auth
md5 12:ab:34 priv aes 128 12:ab:34

~

ERROR: % Invalid input detected at '”~' marker.

In this example, support for sctp in the access-list extended command was added in version 9.5(2), support
for pbkdf2 in the username command was added in version 9.6(1), and support for enginel D in the
snmp-server user command was added in version 9.5(3).
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Downgrade the Firepower 1000, 2100 in Appliance Mode, Secure Firewall 3100

Step 1

Step 2

Step 3

You can downgrade the ASA software version by setting the ASA version to the old version, restoring the
backup configuration to the startup configuration, and then reloading.

Before you begin

This procedure requires a backup configuration of the ASA before you upgraded, so you can restore the old
configuration. If you do not restore the old configuration, you may have incompatible commands representing
new or changed features. Any new commands will be rejected when you load the old software version.

Procedure

Load the old ASA software version using the upgrade procedure in the ASA upgrade guide for standalone,
failover, or clustering deployments. In this case, specify the old ASA version instead of a new version.
Important: Do not reload the ASA yet.

At the ASA CLI, copy the backup ASA configuration to the startup configuration. For failover, perform this
step on the active unit. This step replicates the command to the standby unit.

copy old_config_url startup-config

It's important that you do not save the running configuration to the startup configuration using write memory;
this command will overwrite your backup configuration.

Example:

ciscoasa# copy disk0:/9.13.1 cfg.sav startup-config

Reload the ASA.

ASA CLI

reload

ASDM

Choose Tools> System Reload.

Downgrade the Firepower 2100 in Platform Mode

You can downgrade the ASA software version by restoring the backup configuration to the startup configuration,
setting the ASA version to the old version, and then reloading.

Before you begin

This procedure requires a backup configuration of the ASA before you upgraded, so you can restore the old
configuration. If you do not restore the old configuration, you may have incompatible commands representing
new or changed features. Any new commands will be rejected when you load the old software version.
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. Downgrade the Firepower 4100/9300

Step 1

Step 2

Procedure

At the ASA CLI, copy the backup ASA configuration to the startup configuration. For failover, perform this
step on the active unit. This step replicates the command to the standby unit.

copy old_config_url startup-config

It's important that you do not save the running configuration to the startup configuration using write memory;
this command will overwrite your backup configuration.

Example:

ciscoasa# copy disk0:/9.12.4 cfg.sav startup-config

In FXOS, use the chassis manager or FXOS CLI to use the old ASA software version using the upgrade
procedure in the ASA upgrade guide for standalone, failover, or clustering deployments. In this case, specify
the old ASA version instead of a new version.

Downgrade the Firepower 4100/9300

Step 1

You can downgrade the ASA software version by restoring the backup configuration to the startup configuration,
setting the ASA version to the old version, and then reloading.

Before you begin

* This procedure requires a backup configuration of the ASA before you upgraded, so you can restore the
old configuration. If you do not restore the old configuration, you may have incompatible commands
representing new or changed features. Any new commands will be rejected when you load the old software
version.

» Make sure the old ASA version is compatibile with the current FXOS version. If not, downgrade FXOS
as the first step before you restore the old ASA configuration. Just make sure the downgraded FXOS is
also compatible with the current ASA version (before you downgrade it). If you cannot achieve
compatibility, we suggest you do not perform a downgrade.

Procedure

At the ASA CLI, copy the backup ASA configuration to the startup configuration. For failover or clustering,
perform this step on the active/control unit. This step replicates the command to the standby/data units.

copy old_config_url startup-config

It's important that you do not save the running configuration to the startup configuration using write memory;
this command will overwrite your backup configuration.

Example:

ciscoasa# copy disk0:/9.8.4 cfg.sav startup-config
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Step 2

Step 3

Downgrade the ISA 3000 ]

In FXOS, use the chassis manager or FXOS CLI to use the old ASA software version using the upgrade
procedure in the ASA upgrade guide for standalone, failover, or clustering deployments. In this case, specify
the old ASA version instead of a new version.

If you are also downgrading FXOS, use the chassis manager or FXOS CLI to set the old FXOS software
version to be the current version using the upgrade procedure in the ASA upgrade guide for standalone,
failover, or clustering deployments.

Downgrade the ISA 3000

Step 1

Step 2

Step 3

Step 4
Step 5

The downgrade feature provides a shortcut for completing the following functions on ISA 3000 models:
* Clearing the boot image configuration (clear configure boot).
* Setting the boot image to be the old image (boot system).
* (Optional) Entering a new activation key (activation-key).

* Saving the running configuration to startup (write memory). This sets the BOOT environment variable
to the old image, so when you reload, the old image is loaded.

« Copying the old configuration backup to the startup configuration (copy old_config_url startup-config).

* Reloading (reload).

Before you begin

* This procedure requires a backup configuration of the ASA before you upgraded, so you can restore the
old configuration.

Procedure

Choose Tools> Downgrade Software .

The Downgrade Software dialog box appears.
For the ASA Image, click Select Image File.
The Browse File L ocations dialog box appears.

Click one of the following radio buttons:

* Remote Server—Choose ftp, smb, or http from the drop-down list, and type the path to the old image
file.

* Flash File System—Click Browse Flash to choose the old image file on the local flash file system.
For the Configuration, click Browse Flash to choose the pre-migration configuration file.

(Optional) In the Activation Key field, enter the old activation key if you need to revert to a pre-8.3 activation
key.
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Step 6
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Click Downgrade.

Manage Files

ASDM provides a set of file management tools to help you perform basic file management tasks. The File
Management tool lets you view, move, copy, and delete files stored in flash memory, transfer files, and to
manage files on remote storage devices (mount points).

)

Note In multiple context mode, this tool is only available in the system security context.

Configure File Access

The ASA can use an FTP client, secure copy client, or TFTP client. You can also configure the ASA as a
secure copy server so you can use a secure copy client on your computer.

Configure the FTP Client Mode

Step 1

Step 2

The ASA can use FTP to upload or download image files or configuration files to or from an FTP server. In
passive FTP, the client initiates both the control connection and the data connection. The server, which is the
recipient of the data connection in passive mode, responds with the port number to which it is listening for
the specific connection.

Procedure

From the Configuration > Device Management > Management Access > File Access > FTP Client pane, check
the Specify FTP mode as passive check box.

Click Apply.

The FTP client configuration is changed and the change is saved to the running configuration.

Configure the ASA Secure Copy Client

You can configure SCP settings when the ASA acts as an SCP client using the copy command.

The performance of SCP depends partly on the encryption cipher used. By default, the ASA negotiates one
of the following algorithms in order: 3des-cbc aes128-cbc aes192-cbe aes256-cbc aes128-ctr aes192-ctr
aes256-ctr. If the first algorithm proposed (3des-cbce) is chosen, then the performance is much slower than a
more efficient algorithm such as aes128-cbc. To change the proposed ciphers, use the Configuration > Device
Management > Advanced > SSH Cipher s pane; for example, choose Custom and set it to aes128-cbc.
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Step 1

Step 2

Step 3

Step 4

Configure the ASA Secure Copy Client .

Before you begin

» The ASA license must have the strong encryption (3DES/AES) license to support SSH Version 2
connections.

* Unless otherwise specified, for multiple context mode, complete this procedure in the system execution
space. If you are not already in the System configuration mode, in the Configuration > Device List pane,
double-click System under the active device IP address.

* For the SCP server, enable SSH on the ASA according to Configure HTTPS Access for ASDM, Other
Clients.

Procedure

Depending on your context mode:

» For single mode, choose Configuration > Device Management > M anagement Access > File Access
> Secure Copy (SCP).

* For multiple mode in the System, choose Configur ation > Device M anagement > Device Administration
> Secure Copy

(Optional) The ASA stores the SSH host key for each SCP server to which it connects. You can manually
add or delete servers and their keys from the ASA database if desired.

To add a key:

a) Click Add for a new server, or select the server from the Trusted SSH Hosts table, and click Edit.
b) For a new server, in the Host field, enter the server IP address.

¢) Check the Add public key for thetrusted SSH host check box.

d) Specify one of the following keys:

* Fingerprint—Enter the already hashed key; for example, a key that you copied from show command
output.

» Key—Enter the public key or hashed value of the SSH host. The key string is the Base64 encoded
RSA public key of the remote peer. You can obtain the public key value from an open SSH client;
that is, from the .ssh/id_rsa.pub file. After you submit the Base64 encoded public key, that key is
then hashed via SHA-256.

To delete a key, select the server from the Trusted SSH Hosts table, and click Delete.

(Optional) To be informed when a new host key is detected, check the Inform mewhen anew host key is
detected check box.

By default, this option is enabled. When this option is enabled, you are prompted to accept or reject the host
key if it is not already stored on the ASA. When this option is disabled, the ASA accepts the host key
automatically if it was not stored before.

Click Apply.
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. Configure the ASA TFTP Client Path

Configure the ASA TFTP Client Path

TFTP is a simple client/server file transfer protocol, which is described in RFC 783 and RFC 1350 Rev. 2.
You can configure the ASA as a TFTP client so that it can copy files to or from a TFTP server. In this way,
you can back up and propagate configuration files to multiple ASAs.

This section lets you predefine the path to a TFTP server so you do not need to enter it in commands such as
copy and configure net.

Procedure

Step 1 Choose Configuration > Device Management > Management Access > File Access > TFTP Client,
and check the Enable check box.

Step 2 From the Interface Name drop-down list, choose the interface to use as a TFTP client.

Step 3 In the IP Address field, enter the IP address of the TFTP server on which configuration files will be saved.

Step 4 In the Path field, enter the path to the TFTP server on which configuration files will be saved.
For example: /tftpboot/asa/config3

Step 5 Click Apply.

Add Mount Points

You can add a CIFS or FTP mount point.

Add a CIFS Mount Point

Step 1

Step 2

Step 3
Step 4

Step 5
Step 6
Step 7
Step 8
Step 9

To define a Common Internet File System (CIFS) mount point, perform the following steps.

Procedure

Choose Configuration > Device Management > Management Access > File Access > Mount-Paints,
and click Add > CIFS Mount Point .

The Add CIFS Mount Point dialog box appears.

Check the Enable mount point check box.
This option attaches the CIFS file system on the ASA to the UNIX file tree.

In the Mount Point Name field, enter the name of an existing CIFS location.

In the Server Name or IP Address field, enter the name or IP address of the server in which the mount point
is located.

In the Share Name field, enter the name of the folder on the CIFS server.

In the NT Domain Name field, enter the name of the NT Domain in which the server resides.

In the User Name field, enter the name of the user authorized for file system mounting on the server.

In the Password field, enter the password for the user authorized for file system mounting on the server.

In the Confirm Password field, reenter the password.
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Step 10

Step 11

Add an FTP Mount Point [JJ]

Click OK.
The Add CIFS Mount Point dialog box closes.

Click Apply.

Add an FTP Mount Point

Step 1

Step 2

Step 3
Step 4

Step 5

Step 6
Step 7
Step 8
Step 9
Step 10

Step 11

For an FTP mount point, the FTP server must have a UNIX directory listing style. Microsoft FTP servers
have a default of the MS-DOS directory listing style.

Procedure

Choose Configuration > Device Management > Management Access > File Access > Mount-Paints,
and click Add > FTP Mount Point.

The Add FTP Mount Point dialog box appears.

Check the Enable check box.
This option attaches the FTP file system on the ASA to the UNIX file tree.

In the Mount Point Name field, enter the name of an existing FTP location.

In the Server Name or IP Address field, enter the name or IP address of the server where the mount point is
located.

In the Mode field, click the radio button for the FTP mode (Active or Passive). When you choose Passive
mode, the client initiates both the FTP control connection and the data connection. The server responds with
the number of its listening port for this connection.

In the Path to Mount field, enter the directory path name to the FTP file server.

In the User Name field, enter the name of the user authorized for file system mounting on the server.

In the Password field, enter the password for the user authorized for file system mounting on the server.
In the Confirm Password field, reenter the password.

Click OK.

The Add FTP Mount Point dialog box closes.

Click Apply.

Access the File Management Tool

Step 1

To use the file management tools, perform the following steps.

Procedure

In the main ASDM application window, choose Tools > File Management.

The File Management dialog box appears.

Software and Configurations .
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* The Folders pane displays the available folders on disk.
* Flash Space shows the total amount of flash memory and how much memory is available.

* The Files area displays the following information about files in the selected folder:

* Path

* Filename

* Size (bytes)

* Time Modified

« Status, which indicates whether a selected file is designated as a boot configuration file, boot image
file, ASDM image file, SVC image file, CSD image file, or APCF image file.

Step 2 Click View to display the selected file in your browser.

Step 3 Click Cut to cut the selected file for pasting to another directory.

Step 4 Click Copy to copy the selected file for pasting to another directory.

Step 5 Click Paste to paste the copied file to the selected destination.

Step 6 Click Delete to remove the selected file from flash memory.

Step 7 Click Rename to rename a file.

Step 8 Click New Directory to create a new directory for storing files.

Step 9 Click File Transfer to open the File Transfer dialog box. See Transfer Files, on page 14 for more information.

Step 10 Click Mount Points to open the Manage Mount Points dialog box. See Add Mount Points , on page 12 for
more information.

Transfer Files

The File Transfer tool lets you transfer files from either a local or remote location. You can transfer a local
file on your computer or a flash file system to and from the ASA. You can transfer a remote file to and from
the ASA using HTTP, HTTPS, TFTP, FTP, or SMB.

)

Note For the IPS SSP software module, before you download the IPS software to disk0, make sure at least 50% of
the flash memory is free. When you install IPS, IPS reserves 50% of the internal flash memory for its file
system.

Transfer Files Between Local PC and Flash

To transfer files between your local computer and a flash file system, perform the following steps.

Procedure

Step 1 In the main ASDM application window, choose Tools > File Management.
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Step 2

Step 3

Step 4

Transfer Files Between Remote Server and Flash .

The File Management dialog box appears.

Click the down arrow next to File Transfer, and then click Between Local PC and Flash.
The File Transfer dialog box appears.

Select and drag the file(s) from either your local computer or the flash file system that you want to upload or
download to the desired location. Alternatively, select the file(s) from either your local computer or the flash
file system that you want to upload or download, and click the right arrow or left arrow to transfer the file(s)
to the desired location.

Click Close when you are done.

Transfer Files Between Remote Server and Flash

Step 1

Step 2

Step 3
Step 4

Step 5
Step 6
Step 7

To transfer files between a remote server and a flash file system, perform the following steps.

Procedure

In the main ASDM application window, choose Tools > File Management.

The File Management dialog box appears.

Click the down arrow from the File Transfer drop-down list, and then click Between Remote Server and
Flash.

The File Transfer dialog box appears.
To transfer a file from a remote server, click the Remote server option.

Define the source file to be transferred.

a) (Optional) Specify the interface through which the ASA communicates with the server. If you do not
specify the interface, the ASA checks the management-only routing table; if there are no matches, it then
checks the data routing table.

b) Choose the path to the location of the file, including the IP address of the server.

Note File transfer supports IPv4 and IPv6 addresses.

c) Enter the type (if the path is FTP) or the port number (if the path is HTTP or HTTPS) of the remote server.
Valid FTP types are the following:

» ap—ASCII files in passive mode
» an—ASCII files in non-passive mode
* ip—Binary image files in passive mode

* in—Binary image files in non-passive mode

To transfer the file from the flash file system, click the Flash file system option.
Enter the path to the location of the file or click Browse Flash to find the file location.

In addition, you can copy a file from your startup configuration, running configuration, or an SMB file system
through the CLI. For instructions about using the copy command, see the CLI configuration guide.
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Step 8

Step 9

Step 10

Step 11
Step 12

Step 13

Define the destination of the file to be transferred.

a) To transfer the file to the flash file system, choose the Flash file system option.
b) Enter the path to the location of the file or click Browse Flash to find the file location.

To transfer a file to a remote server, choose the Remote server option.

a) (Optional) Specify the interface through which the ASA communicates with the server. If you do not
specify the interface, the ASA checks the management-only routing table; if there are no matches, it then
checks the data routing table.

b) Enter the path to the location of the file.
c¢) For FTP transfers, enter the type. Valid types are the following:

» ap—ASCII files in passive mode
» an—ASCII files in non-passive mode
* ip—Binary image files in passive mode

* in—Binary image files in non-passive mode

Click Transfer to start the file transfer.

The Enter Username and Password dialog box appears.

Enter the username, password, and domain (if required) for the remote server.
Click OK to continue the file transfer.

The file transfer process might take a few minutes; make sure that you wait until it is finished.

Click Close when the file transfer is finished.

Set the ASA Image, ASDM, and Startup Configuration

If you have more than one ASA or ASDM image, you should specify the image that you want to boot. If you
do not set the image, the default boot image is used, and that image may not be the one intended. For the
startup configuration, you can optionally specify a file in the visible file system instead of a hidden directory.

See the following model guidelines:

* Firepower 4100/9300 chassis—ASA upgrades are managed by FXOS; you cannot upgrade the ASA
within the ASA operating system, so do not use this procedure for the ASA image. You can upgrade the
ASA and FXOS separately from each other, and they are listed separately in the FXOS directory listing.
The ASA package always includes ASDM.

* Firepower 2100 in Platform mode—The ASA, ASDM, and FXOS images are bundled together into a
single package. Package updates are managed by FXOS; you cannot upgrade the ASA within the ASA
operating system, so do not use this procedure for the ASA image. You cannot upgrade the ASA and
FXOS separately from each other; they are always bundled together.

* Firepower 1000, 2100 in Appliance mode, Secure Firewall 3100—The ASA, ASDM, and FXOS images
are bundled together into a single package. Package updates are managed by the ASA using this procedure.
Although these platforms use the ASA to identify the image to boot, the underlying mechanism is different
from legacy ASAs. See the command description below for more information.

. Software and Configurations



| Software and Configurations

Step 1

Set the ASA Image, ASDM, and Startup Configuration .

* ASDM for the models—ASDM can be upgraded from within the ASA operating system, so you do not
need to only use the bundled ASDM image. For the Firepower 2100 in Platform mode and Firepower
4100/9300, ASDM images that you upload manually do not appear in the FXOS image list; you must
manage ASDM images from the ASA.

\}

Note When you upgrade the ASA bundle, the ASDM image in the bundle replaces the
previous ASDM bundle image on the ASA because they have the same name
(asdm.bin). But if you manually chose a different ASDM image that you uploaded
(for example, asdm-782.bin), then you continue to use that image even after a
bundle upgrade. To make sure that you are running a compatible version of
ASDM, you should either upgrade ASDM before you upgrade the bundle, or you
should reconfigure the ASA to use the bundled ASDM image (asdm.bin) just
before upgrading the ASA bundle.

» ASA Virtual—The initial deployment ASA virtual package puts the ASA image in the read-only boot:/
partition. When you upgrade the ASA virtual, you specify a different image in flash memory. Note that
if you later clear your configuration, then the ASA virtual will revert to loading the original deployment
image. The initial deployment ASA virtual package also includes an ASDM image that it places in flash
memory. You can upgrade the ASDM image separately.

See the following default settings:

» ASA image:

* Firepower 1000, 2100 in Appliance mode, Secure Firewall 3100—Boots the previously-running
boot image.

* Other Physical ASAs—Boots the first application image that it finds in internal flash memory.

* ASA Virtual—Boots the image in the read-only boot:/ partition that was created when you first
deployed.

* Firepower 4100/9300 chassis—The FXOS system determines which ASA image to boot. You cannot
use this procedure to set the ASA image.

* Firepower 2100 in Platform mode—The FXOS system determines which ASA/FXOS package to
boot. You cannot use this procedure to set the ASA image.

» ASDM image on all ASAs—Boots the first ASDM image that it finds in internal flash memory, or if
one does not exist in this location, then in external flash memory.

* Startup configuration—By default, the ASA boots from a startup configuration that is a hidden file.

Procedure

Choose Configuration > Device Management > System Image/Configuration > Boot
Image/Configuration.

Firepower 1000, 2100 in Appliance mode, Secure Firewall 3100: You can only add a single image. If you
upgrade to a new image, then you must delete the previous image you set. When you apply this change, the
system performs an action: the system validates and unpacks the image and copies it to the boot location (an
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Step 2
Step 3

Step 4
Step 5

Step 6

Step 7

internal location on diskO managed by FXOS). The new image will load when you reload the ASA. If you
change your mind prior to reloading, you can delete the Boot | mage L ocation and reapply to remove the new
image from the boot location, so the current image continues to run. You can even delete the original image
file from the ASA flash memory after you apply this change, and the ASA will boot correctly from the boot
location. Unlike other models, this command in the startup configuration does not affect the booting image.
The last-loaded boot image will always run upon reload. You can only load images with the original filename
from the Cisco download site. If you change the filename, it will not load.

Other models: You can specify up to four local binary image files for use as the startup image, and one image
located on a TFTP server for the device to boot from. If you specify an image located on a TFTP server, it
must be first in the list. If the device cannot reach the TFTP server to load the image, it tries to load the next
image file in the list located in flash.

Click Add in the Boot Image/Configuration pane.

Browse to the image from which you want to boot. For a TFTP image, enter the TFTP URL in the File Name
field. Click OK.

Arrange the images in order by using the Move Up and Move Down buttons.
(Optional) In the Boot Configuration File Path field, specify the startup configuration file by clicking Browse
Flash and choosing the configuration. Click OK.

This feature is important for when you work with large configurations that do not fit in the hidden directory.
If you save a large configuration and see the following error message, be sure to instead save the configuration
to a new file using this command:

$Error writing. nvram:/startup-config (No space left on device:)

In the ASDM Image File Path field, specify the ASDM image by clicking Browse Flash and choosing the
image. Click OK.

Click Apply.

Back Up and Restore Configurations or Other Files

We recommend that you make regular backups of your configuration and other system files to guard against
system failure.

Perform a Complete System Backup or Restoration

These procedures describe how to back up and restore configurations and images to a zip file and transfer it
to your local computer.

Before You Begin Backup or Restore

* You should have at least 300 MB of disk space available at the backup or restore location before you
start a backup or restore.

* The ASA must be in single context mode.

» If you make any configuration changes during or after a backup, those changes will not be included in
the backup. If you change a configuration after making the backup, then perform a restore, this
configuration change will be overwritten. As a result, the ASA might behave differently.
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* You can start only one backup or restore at a time.

* You can only restore a configuration to the same ASA version as when you performed the original
backup. You cannot use the restore tool to migrate a configuration from one ASA version to another. If
a configuration migration is required, the ASA automatically upgrades the resident startup configuration
when it loads the new ASA OS.

* If you use clustering, you can only back up or restore the startup-configuration, running-configuration,
and identity certificates. You must create and restore a backup separately for each unit.

* If you use failover, you must create and restore a backup separately for the active and standby units.

* If you set a master passphrase for the ASA, then you need that master passphrase to restore the backup
configuration that you create with this procedure. If you do not know the master passphrase for the ASA,
see Configure the Master Passphrase to learn how to reset it before continuing with the backup.

* If you import PKCS12 data (with the crypto catrustpoint command) and the trustpoint uses RSA keys,
the imported key pair is assigned the same name as the trustpoint. Because of this limitation, if you
specify a different name for the trustpoint and its key pair after you have restored an ASDM configuration,
the startup configuration will be the same as the original configuration, but the running configuration
will include a different key pair name. This means that if you use different names for the key pair and
trustpoint, you cannot restore the original configuration. To work around this issue, make sure that you
use the same name for the trustpoint and its key pair.

* You cannot back up using the CLI and restore using ASDM, or vice versa.
* Each backup file includes the following content:
* Running-configuration
» Startup-configuration
* All security images
Cisco Secure Desktop and Host Scan images
Cisco Secure Desktop and Host Scan settings
Secure Client (SVC) images and profiles

Secure Client (SVC) customizations and transforms
* Identity certificates (includes RSA key pairs tied to identity certificates; excludes standalone keys)
* VPN pre-shared keys
* SSL VPN configurations
* Application Profile Custom Framework (APCF)
* Bookmarks
* Customizations
* Dynamic Access Policy (DAP)
* Plug-ins
* Pre-fill scripts for connection profiles

* Proxy Auto-config
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* Translation table
* Web content

 Version information

Back Up the System

This procedure describes how to perform a complete system backup.

\)

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6
Step 7
Step 8

Step 9

Step 10

Step 11

Note If the backup process stalls, your ASDM may not have enough memory to load the configuration. You can
monitor the Java console for the "java.lang.OutOfMemoryError" message to see if running out of memory is

the problem. To increaes the ASDM memory, see Increase the ASDM Configuration Memory.

Procedure

Create a folder on your computer to store backup files so they will be easy to find in case you need to restore
them later.

Choose Tools > Backup Configurations.
The Backup Configurations dialog box appears. Click the down arrow in the SSL VPN Configuration area

to view the backup options for SSL VPN configurations. By default, all configuration files are checked and
will be backed up if they are available. If you want to back up all of the files in the list, go to Step 5.

Uncheck the Backup All check box if you want to select the configurations to back up.
Check the check box next to the option that you want to back up.

Click Browse L ocal to specify adirectory and file namefor the backup .zip file.

In the Select dialog box, choose the directory in which you want to store the backup file.
Click Select. The path appears in the Backup File field.

Enter the name of the destination backup file after the directory path. The backup file name must be between
3 and 232 characters long.

Click Backup. The backup proceeds immediately unless you are backing up certificates or the ASA is using
a master passphrase.

If you have configured and enabled a master passphrase on your ASA, you receive a warning message with
a suggestion to change the master passphrase, if you do not know it, before proceeding with the backup. Click
Yes to proceed with the backup if you know the master passphrase. The backup proceeds immediately unless
you are backing up identity certificates.

If you are backing up an identity certificate, you are asked to enter a separate passphrase to be used for encoding
the certificates in PKCS12 format. You can enter a passphrase or skip this step.

Note Only identity certificates are backed up by this process.

* To encrypt certificates, enter and confirm your certificate passphrase in the Certificate Passphrase dialog
box and click OK. You will need to remember the password you enter in this dialog box when restoring
the certificates.

* Clicking Cancel skips the step and does not back up certificates.

. Software and Configurations


asdm-719-general-config_chapter2.pdf#nameddest=unique_52

| Software and Configurations

Step 12

Step 13

Restore the Backup .

After clicking OK or Cancel, the backup begins immediately.

After the backup is complete, the status window closes and the Backup Statistics dialog box appears to provide
success and failure messages.

Note

Backup “failure messages” are most likely caused by the lack of an existing configuration for
the types indicated.

Click OK to close the Backup Statistics dialog box.

Restore the Backup

Step 1
Step 2

Step 3

Step 4
Step 5

Step 6

Step 7

You can specify configurations and images to restore from a zip tar.gz file on your local computer.

\}

Note If the restore process stalls, your ASDM may not have enough memory to load the configuration. You can
monitor the Java console for the "java.lang.OutOfMemoryError" message to see if running out of memory is
the problem. To increaes the ASDM memory, see Increase the ASDM Configuration Memory.

Procedure

Choose Tools > Restore Configurations.

In the Restore Configurations dialog box, click Browse Local Directory, choose the zip file on your local
computer that contains the configuration to restore, then click Select. The path and the zip filename appear
in the Local File field.

The zip file that you restore must be created by choosing the Tools > Backup Configurations option.

Click Next. The second Restore Configuration dialog box appears. Check the check boxes next to the
configurations that you want to restore. All available SSL. VPN configurations are selected by default.

Click Restore.

If you specified a certificate passphrase with which to encrypt the certificates when you created the backup
file, ASDM prompts you to enter the passphrase.

If you chose to restore the running configuration, you are asked if you want to merge the running configuration,
replace the running configuration, or skip this part of the restoration process.

» Merging configurations combines the current running configuration and the backed-up running
configuration.

* Replacing the running configuration uses the backed-up running configuration only.
» Skipping the step does not restore the backed-up running configuration.
ASDM displays a status dialog box until the restore operation is finished.

If you replaced or merged the running configuration, close ASDM and restart it. If you did not restore the
running configuration or the running configuration, refresh the ASDM session for the changes to take effect.
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. Configure Automatic Backup and Restore (ISA 3000)

Configure Automatic Backup and Restore (ISA 3000)

On the ISA 3000, you can configure automatic backups to a particular location every time you save your
configuration.

Automatic restore lets you easily configure new devices with a complete configuration loaded on an SD flash
memory card. Automatic restore is enabled in the default factory configuration.

Configure Automatic Backup (ISA 3000)

Step 1
Step 2

On the ISA 3000, you can configure automatic backups to a particular location every time you save your
configuration.

Before you begin

This feature is only available on the ISA 3000.

Procedure

Choose Configuration > Device Management > Auto Backup & Restore Configuration.
Check or uncheck Automate Backup Configuration to enable or disable automatic backups.

If you enable automatic backups, when you save the configuration, the configuration is automatically saved
to the backup location as well as to the startup configuration. The backup file has the name
"auto-backup-asa.tgz".

Set the following parameters:

* I nterface—Specifies the interface to reach the backup URL, if you specify off-device storage. If you do
not specify the interface name, the ASA checks the management-only routing table; if there are no
matches, it then checks the data routing table.

* L ocation—Specifies the storage medium to be used for backing up data. You can specify a URL or local
storage. diskO is the internal flash drive. disk1 is an optional USB memory stick on USB 1. disk2 is an
optional USB memory stick on USB 2. And disk3 is the SD memory card. The default for automatic
restore is disk3:.

» Passphrase—Sets the passphrase to secure the backed-up data. The default for automatic restore is
"cisco".

Configure Automatic Restore (ISA 3000)

Automatic restore mode restores the system configuration on a device without any user intervention. For
example, you insert an SD memory card containing a saved backup configuration into a new device and then
power the device on. When the device comes up, it checks the SD card to decide if the system configuration
needs to be restored. (The restoration is only initiated if the backup file has the "fingerprint" of a different
device. The fingerprint of the backup file is updated to match the current device during a backup or restore
operation. So if the device has already completed a restore, or if it has created its own backup, then the
automatic restore is skipped.) If the fingerprint shows a restoration is required, the device replaces the system
configuration (startup-config, running-config, SSL VPN configuration, and so on; see Back Up the System,
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on page 20 for details about the contents of the backup). When the device finishes booting, it is running the
saved configuration.

Automatic restore is enabled in the default factory configuration, so you can easily configure new devices
with a complete configuration loaded on an SD memory card without having to perform any pre-configuration
of the device.

Because the device needs to decide early in the boot process if the system configuration needs to be restored,
it checks ROMMON variables to determine if the device is in automatic restore mode and to obtain the location
of the backup configuration. The following ROMMON variables are used:

* RESTORE_MODE = {auto | manual}
The default is auto.

* RESTORE_LOCATION = {diskO: | disk1: | disk2: | disk3:}
The default is disk3:.

» RESTORE_PASSPHRASE = key

The default is cisco.

To change the automatic restore settings, complete the following procedure.

Before you begin
* This feature is only available on the ISA 3000.
* If you use the default restore settings, you need an SD memory card installed (part number SD-IE-1GB=).

* If you need to restore the default configuration to ensure that automatic restore is enabled, use the
configurefactory default command. This command is only available in transparent firewall mode, so
if you are in routed firewall mode, use the firewall transparent command first.

Procedure
Step 1 Choose Configuration > Device M anagement > Auto Backup & Restore Configuration.
Step 2 Check or uncheck Automate Restore Configuration to enable or disable automatic restore.

The name of the file that is restored is "auto-backup-asa.tgz". If you enable automatic restore, set the following
parameters:

» L ocation—Specifies the storage medium to be used for restoring data. disk0 is the internal flash drive.
disk1 is an optional USB memory stick on USB 1. disk2 is an optional USB memory stick on USB 2.
And disk3 is the SD memory card. The default is disk3.

* Passphrase—Sets the passphrase to read the backed-up data. The default is "cisco".

Save the Running Configuration to a TFTP Server

This feature stores a copy of the current running configuration file on a TFTP server.

Software and Configurations .



Software and Configurations |

. Schedule a System Restart

Step 1

Step 2

Procedure

Choose File > Save Running Configuration to TFTP Server.
The Save Running Configuration to TFTP Server dialog box appears.

Enter the TFTP server IP address and file path on the TFTP server in which the configuration file will be
saved, and then click Save Configur ation.

Note To configure default TFTP settings, choose Configuration > Device Management >
M anagement Access > File Access > TFTP Client. After you have configured this setting, the
TFTP server IP address and file path on the TFTP server appear automatically in this dialog box.

Schedule a System Restart

Step 1
Step 2

Step 3

The System Reload tool lets you schedule a system restart or cancel a pending restart.

Procedure

Choose Tools > System Reload.
In the Reload Scheduling area, define the following settings:

a) For the Configuration State, choose either to save or discard the running configuration at restart time.
b) For the Reload Start Time, choose from the following options:

* Click Now to perform an immediate restart.

* Click Delay by to delay the restart by a specified amount of time. Enter the time before the restart
begins in hours and minutes or only minutes.

* Click Schedule at to schedule the restart to occur at a specific time and date. Enter the time of day

the restart is to occur, and select the date of the scheduled restart.

c) Inthe Reload Message field, enter a message to send to open instances of ASDM at restart time.

d) Check the Onreload failureforceimmediatereload after check box to show the amount of time elapsed
in hours and minutes or only minutes before a restart is attempted again.

e) Click Schedule Reload to schedule the restart as configured.

The Reload Status area displays the status of the restart.

Choose one of the following:

* Click Cancel Reload to stop a scheduled restart.
* Click Refresh to refresh the Reload Status display after a scheduled restart is finished.

* Click Detailsto display the results of a scheduled restart.
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Hot Swap an SSD on the Secure Firewall 3100 .

Hot Swap an SSD on the Secure Firewall 3100

If you have two SSDs, they form a RAID when you boot up. You can perform the following tasks at the CLI
while the firewall is powered up:

A

* Hot swap one of the SSDs—If an SSD is faulty, you can replace it. Note that if you only have one SSD,
you cannot remove it while the firewall is powered on.

* Remove one of the SSDs—If you have two SSDs, you can remove one.

* Add a second SSD—If you have one SSD, you can add a second SSD and form a RAID.

Step 1

Caution Do not remove an SSD without first removing it from the RAID using this procedure. You can cause data
loss.
Procedure

Remove one of the SSDs.

a)

b)

Remove the SSD from the RAID.
raid remove-securelocal-disk {1]| 2}

The remove-secur e keyword removes the SSD from the RAID, disables the self-encrypting disk feature,
and performs a secure erase of the SSD. If you only want to remove the SSD from the RAID and want to
keep the data intact, you can use the remove keyword.

Example:

ciscoasa(config)# raid remove-secure local-disk 2

Monitor the RAID status until the SSD no longer shows in the inventory.
show raid

After the SSD is removed from the RAID, the Operability and Drive State will show as degraded. The
second drive will no longer be listed as a member disk.

Example:

ciscoasa# show raid
Virtual Drive

ID: 1

Size (MB): 858306
Operability: operable
Presence: equipped
Lifecycle: available
Drive State: optimal
Type: raid
Level: raidl
Max Disks: 2

Meta Version: 1.0
Array State: active
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Sync Action: idle
Sync Completed: unknown
Degraded: 0

Sync Speed: none

RAID member Disk:

Device Name: nvmeOnl
Disk State: in-sync
Disk Slot: 1

Read Errors: 0
Recovery Start: none
Bad Blocks:

Unacknowledged Bad Blocks:

Device Name: nvmelnl
Disk State: in-sync
Disk Slot: 2

Read Errors: 0
Recovery Start: none
Bad Blocks:

Unacknowledged Bad Blocks:

ciscoasa# show raid
Virtual Drive

ID: 1

Size (MB): 858306
Operability: degraded
Presence: equipped
Lifecycle: available
Drive State: degraded
Type: raid
Level: raidl
Max Disks: 2

Meta Version: 1.0
Array State: active
Sync Action: idle
Sync Completed: unknown
Degraded: 1

Sync Speed: none

RAID member Disk:

Device Name: nvmeOnl
Disk State: in-sync
Disk Slot: 1

Read Errors: 0
Recovery Start: none
Bad Blocks:

Unacknowledged Bad Blocks:

¢) Physically remove the SSD from the chassis.

Step 2 Add an SSD.

a) Physically add the SSD to the empty slot.
b) Add the SSD to the RAID.

raid add local-disk {12}

It can take several hours to complete syncing the new SSD to the RAID, during which the firewall is
completely operational. You can even reboot, and the sync will continue after it powers up. Use the show
raid command to show the status.
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If you install an SSD that was previously used on another system, and is still locked, enter the following

command:

raid add local-disk {12} psid

The psid is printed on the label attached to the back of the SSD. Alternatively, you can reboot the system,
and the SSD will be reformatted and added to the RAID.

History for Software and Configurations

Feature Name

Platform
Releases

Feature Information

Secure Copy client and server

9.1(5)/9.2(1)

The ASA now supports the Secure Copy (SCP) client and server
to transfer files to and from a SCP server.

We modified the following screens:

Tools > File Management > File Transfer > Between Remote
Server and Flash Configuration > Device M anagement >
Management Access > File Access > Secure Copy (SCP)
Server

Configurable SSH encryption and integrity ciphers

91(7y943)953)04(1)

Users can select cipher modes when doing SSH encryption
management and can configure HMAC and encryption for
varying key exchange algorithms. You might want to change
the ciphers to be more or less strict, depending on your
application. Note that the performance of secure copy depends
partly on the encryption cipher used. By default, the ASA
negotiates one of the following algorithms in order: 3des-cbc
aes128-cbc aes192-cbe aes256-cbe aes128-ctr aes192-ctr
aes256-ctr. If the first algorithm proposed (3des-cbce) is chosen,
then the performance is much slower than a more efficient
algorithm such as aes128-cbc. To change the proposed ciphers,
use ssh cipher encryption custom aes128-chc, for example.

We introduced the following screen: Configuration > Device
Management > Advanced > SSH Ciphers
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Feature Name

Platform
Releases

Feature Information

Auto Update server certificate verification enabled
by default

9.2(1)

The Auto Update server certificate verification is now enabled
by default; for new configurations, you must explicitly disable
certificate verification. If you are upgrading from an earlier
release, and you did not enable certificate verification, then
certificate verification is not enabled, and you see the following
warning:

WARNING: The certificate provided by the
auto-update servers will not be verified.
In order to verify this certificate please
use the verify-certificate option.

The configuration will be migrated to explicitly configure no
verification.

We modified the following screen: Configuration > Device
Management > System/Image Configuration > Auto Update >
Add Auto Update Server.

System backup and restore using the CLI

9.3(2)

You can now back up and restore complete system
configurations, including images and certificates, using the
CLL

We did not modify any ASDM screens.

Recovering and loading a new ASA 5506W-X
image

9.4(1)

We now support the recovery and loading of a new ASA
5506W-X image.

We did not modify any ASDM screens.

Automatic Backup and Restore for the ISA 3000

9.7(1)

You can enable auto-backup and/or auto-restore functionality
using pre-set parameters in the backup and restore commands.
The use cases for these features include initial configuration
from external media; device replacement; roll back to an
operable state.

We introduced the following screen: Configuration > Device
Management > Auto Backup & Restore Configuration

CiscoSSH stack requires SSH access when using
the SCP client

9.17(1)

If you use the CiscoSSH stack, to use the ASA copy command
to copy a file to or from an SCP server, you have to enable
SSH access on the ASA for the SCP server subnet/host

RAID support for SSDs on the Secure Firewall
3100

9.17(1)

The SSDs are self-encrypting drives (SEDs), and if you have
2 SSDs, they form a software RAID.

New/Modified commands: raid, show raid, show ssd
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