Introduction

Note

Cisco MetroPlanner has been renamed to Cisco Transport Planner starting with release 8.5.

Cisco Transport Planner (CTP) provides a way to model and test wavelength division multiplexing (WDM) optical networks in a graphical environment. The primary purpose of Cisco Transport Planner is to help sales engineers (SEs) design and validate networks of Cisco Optical Networking System (ONS) 15454 Multiservice Transport Platforms (MSTP). Using CTP, an SE can create multiple instances of a network to modify different parameters in each instance for comparison. Cisco Transport Planner generates a shelf view of all the sites deployed in the optical network and provides a complete bill of materials (BoM) for the network and the differences between instances of a network.

This chapter describes how you use Cisco Transport Planner to design, analyze, and optimize new or existing Cisco optical networks and contains the following sections:

- 1.1 Overview, page 1-1
- 1.2 Installing Cisco Transport Planner, page 1-15
- 1.3 Uninstalling Cisco Transport Planner, page 1-17
- 1.4 Launching Cisco Transport Planner, page 1-17
- 1.5 CTP Software Updates, page 1-21
- 1.6 Setting Cisco Transport Planner Options, page 1-21
- 1.8 Understanding the Pay As You Grow Feature, page 1-42

1.1 Overview

This section describes the Cisco Transport Planner, 9.2.1 features, network design process, process flow, traffic planning, traffic services, and parameter states.

1.1.1 Cisco Transport Planner 9.2.1 Features

Cisco Transport Planner software provides a simple tool set for designing optical networks with Cisco ONS 15454 MSTP products. You can enter all of the network parameters or minimal information, such as site distance, and Cisco Transport Planner will model the network you need to build and generate a detailed BOM with ordering information. Designing optical networks requires the verification of multiple constraints such as optical budget limitations and platform architectural restrictions. Single
Cisco Transport Planner project can contain multiple copies of a network. This duplication allows you to change parameters in one network copy, then analyze and compare it with another network copy to determine the differences. The new features of Cisco Transport Planner, Release 9.2.1 are listed in Table 1-1.

### Table 1-1 New Features in Cisco Transport Planner, Release 9.2.1

<table>
<thead>
<tr>
<th>Features</th>
<th>Description</th>
</tr>
</thead>
</table>
| 15216-FLD-4 (FLD-4) FlexLayer units | Supports bidirectional four-channel FlexLayer OADM units in Hybrid 15454 ONS nodes that has Functionality as Add/Drop or Hub and Type as OADM. The FLD-4 units cover the entire 40-channel odd grid (C-band) without any guard band
1. |
| 15216-FLD-9-ISO (FLD-9) insulators | An array of the 15216-FLD-9-ISO optical insulators protect Express Add/Drop (EAD) colorless ports of the 80-WXC-C cards configured as demux units. |
| 15216-MD-40-ODD/EVEN unit placement | Supports the 15216-MD-40-ODD and 15216-MD-40-EVEN units in the following site configurations:
  - Nodes with omnidirectional sides
  - Hub and Add/Drop nodes |
| 40G CP-DQPSK MXP card 40G CP-DQPSK ME MXP card | The 40G CP-DQPSK MXP (enhanced mode) and 40G CP-DQPSK ME MXP (metro-edge mode) cards has four client interfaces and one trunk interface. The 40G CP-DQPSK MXP and 40G CP-DQPSK ME MXP cards support aggregation of the following signals:
  - With overclock enabled on the trunk port:
    - 10-Gigabit Fibre Channel
    - OTU2e
  - With overclock disabled on the trunk port:
    - 8-Gigabit Fibre Channel
    - 10-GigabitEthernet LAN-Phy (GFP framing)
    - 10-GigabitEthernet LAN-Phy (WIS framing)
    - 10-GigabitEthernet LAN-to-WAN
    - 10-GigabitEthernet WAN-Phy
    - OC-192/STM-64
    - OTU2 |
| ONS-XC-10G-EP SFP | Supports the ONS-XC-10G-EP SFP. |
| TCC3 card | Supports the placement of TCC3 card as the controller card in the ONS 15454 (M12) shelves. |
1.1.1 Cisco Transport Planner 9.2.1 Features

<table>
<thead>
<tr>
<th>Features</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>40G CP-DQPSK TXP card</td>
<td>The 40G CP-DQPSK TXP (enhanced mode) and 40G CP-DQPSK ME TXP (metro-edge mode) cards have one client and one trunk interface.</td>
</tr>
<tr>
<td>40G CP-DQPSK ME TXP card</td>
<td>The 40G CP-DQPSK TXP and 40G CP-DQPSK ME TXP cards support the following signals:</td>
</tr>
<tr>
<td></td>
<td>- OC-768/STM-256</td>
</tr>
<tr>
<td></td>
<td>- 40GE LAN Phy</td>
</tr>
<tr>
<td></td>
<td>- OTU3</td>
</tr>
<tr>
<td>Any-to-Any connectivity</td>
<td>Supports omnidirectional and colorless properties in a ROADM demands.</td>
</tr>
<tr>
<td>Attenuator placement</td>
<td>Supports placing attenuators before and after each amplifier, in both preamplifier and booster positions.</td>
</tr>
<tr>
<td>Copy &amp; Go back to Design Mode</td>
<td>Supports to copy a network in the Upgrade or Release Upgrade state to Design state.</td>
</tr>
<tr>
<td>CTP software updates</td>
<td>Supports installing of available software updates.</td>
</tr>
<tr>
<td>External switch optimization</td>
<td>Supports the placement of Multi Shelf External Switch as a default option for all the nodes with more than one shelf.</td>
</tr>
<tr>
<td>Fiber properties</td>
<td>Supports specifying PMD values for individual fibers.</td>
</tr>
<tr>
<td></td>
<td>Supports specifying FDP² connector information where the fiber is connected.</td>
</tr>
<tr>
<td></td>
<td>Supports replacing two fiber spans with a single span connecting two adjacent sites during deletion of a site.</td>
</tr>
<tr>
<td>Filler cards</td>
<td>Supports placement of the filler cards in the empty slots of ONS 15454 M2 (M2) and ONS 15454 M6 (M6) chassis.</td>
</tr>
<tr>
<td>Node controller selection</td>
<td>Enables to choose node controller chassis for the selected site.</td>
</tr>
<tr>
<td>OSC frame type</td>
<td>Supports FE Frame as an OSC frame type.</td>
</tr>
<tr>
<td>Pay as you grow (PAYG)</td>
<td>Supports the use of PAYG bundles to reduce the initial setup cost.</td>
</tr>
<tr>
<td>Populate shelves from the bottom</td>
<td>Supports the placement of the shelves in the rack from the bottom.</td>
</tr>
<tr>
<td>Raman without post amplifier</td>
<td>Supports a Raman amplifier configuration without a post amplifier.</td>
</tr>
<tr>
<td>Site type connector loss</td>
<td>Supports specifying the default connector loss values for different type of sites.</td>
</tr>
<tr>
<td>Traffic subnet wavelength settings</td>
<td>Supports setting the wavelength associated to a traffic subnet.</td>
</tr>
<tr>
<td>Wavelength assignment algorithm</td>
<td>Supports the following wavelength assignment options:</td>
</tr>
<tr>
<td></td>
<td>- Coloring Priority Option</td>
</tr>
<tr>
<td></td>
<td>- Flat Grid Filling Option</td>
</tr>
<tr>
<td></td>
<td>- Maximum Separation Option</td>
</tr>
</tbody>
</table>

1. Guard Band = Unused part of the wavelength spectrum, for the purpose of preventing interference between the wavelength channels.
1.1.2 Network Design Process

To generate a network design, the SE enters the following parameters:

- The topology of the network—ring, linear, or meshed
- The type of equipment used at each site
- The distance separating the sites
- The type of fiber connecting the sites
- Service demands, including the service type, the protection type, and the number of channels between nodes
- The number of network sites

When the network parameters are entered, Cisco Transport Planner finds the best routing, defines the required add/drop filters, places optical amplifiers with dispersion compensation units (DCUs) or tunable dispersion compensation units (TDCUs) to fit the user traffic demands at a minimum cost. The TDCU operates only over the C-band. Optimization is performed to meet the boundary conditions. The optimization includes attenuation and amplification.

Finally, Cisco Transport Planner generates a BOM, which includes the product codes, the quantities, and pricing information. In addition, it creates other reports, such as a shelf-level view of the configuration, which can be printed. This information helps the SE understand how the shelf is built and helps to avoid confusion and errors during the actual deployment. Within the BOM is the total network cost, which allows a quick comparison of various design options. The total network cost is the cost of the equipment for all of the sites in the designed network.

1.1.2.1 Network Design Constraints

Cisco Transport Planner searches for the best solution to a designed network using an optimization algorithm.

A network design must meet the optical budget and receiver overload criteria to operate efficiently. An analysis of the optical budget and receiver overload evaluates the strength of the signal traversing the ring. If a design solution satisfies the constraints, it is a valid design. The Cisco Transport Planner optimization algorithms generate multiple solutions and verifies the constraints against those solutions. If the constraints are satisfied, the solution with the lowest cost-to-utilization ratio is selected as the optimal solution.

If the network design solution fails to satisfy all the constraints, Cisco Transport Planner makes adjustments to parameters such as signal attenuation and amplification. Amplification is achieved using an erbium-doped fiber amplifier (EDFA). Attenuation is achieved using the variable optical attenuator (VOA) modules integrated into the platform. Cisco Transport Planner corrects the optical budget using an algorithm that includes automatic placement of EDFAs and VOA regulation.

For each internodal demand, Cisco Transport Planner performs an optical budget and receiver overload analysis and displays the results in various reports in the Graphical User Interface (GUI). If the network design algorithms are not able to provide a solution, then you can modify the input data (for example, by relaxing some user constraints) and run the analysis again.
1.1.2.2 Platform Support

Cisco Transport Planner Software R9.2.1 supports the Cisco ONS 15454 DWDM optical platform Software Releases 8.5, 9.0, 9.1, 9.2, and 9.2.1.

1.1.2.3 Topology Support

Cisco Transport Planner supports the following network topologies:
- Linear (single-span or multispan)
- Ring (open or closed)
- Mesh

For more information on network topologies, see the “5.1 Supported Cisco Transport Planner Topologies” section on page 5-1.

Cisco Transport Planner allows you to design flexible networks with up to 100 site locations. A flexible network is a network that uses ROADM nodes to allow traffic modification/reconfiguration as traffic requirements change.

For Cisco Transport Planner Software R9.2.1, the maximum number of locations where the optical service channel (OSC) is terminated is 40. The maximum number of add/drop locations is 40.

1.1.2.4 Protection Scheme Support

Cisco Transport Planner designs support the following protection schemes:
- Y-cable protected—In Y-cable protection, one transponder card is designated as active and the other as standby. The standby transponder card has the client-side laser turned off to avoid corrupting the signal transmitted back to the client. The active transponder monitors the signal from the trunk side and in the event of loss or signal failure, the system switches to the standby path. Figure 1-1 shows an example of a Y-cable protected link.

![Y-cable protection diagram](image)

- Client-based 1+1—Two client signals are transmitted to separated line cards or transponder cards instead of using a Y-cable to split one client signal into two line cards or transponder cards. In client 1+1 protection, the failure and switchover is controlled by the client system. Figure 1-2 shows an example of a 1+1 protected link.
1.1.2 Network Design Process

Figure 1-2 1+1 Protection

- Fiber-switched protection—The single client signal is injected into the client receive (Rx) port. It is then split into two separate signals on the two trunk transmit (Tx) ports. The two signals are transmitted over diverse paths. The far-end card chooses one of the two trunk Rx port signals and injects it into the Tx client port. Figure 1-3 shows an example of a fiber-switched protected link.

Figure 1-3 Fiber-switched Protection

- PSM-OCH—Channel protection configuration provides protection at trunk level (like Fiber-Switched protection) for TXP/MXP that do not have dedicated Fiber-Switched cards. PSM splits the traffic originated by transponder trunk on working and protected TX ports. Working Tx (W-Tx) and protected TX (P-Tx) are connected to the add ports of Add-Drop stages adding the channel in two different directions. On the receiving direction PSM W-RX and P-RX are connected to the drop ports of Add-Drop stages receiving the channel from the two different directions. PSM switch selects a path among W-Rx and P-Rx ports so that only one direction at a time is connected to COM-RX ports and therefore to the TXP/MXP. Figure 1-4 shows an example of a PSM-OCH protected link.
1.1.2.5 Service Support

Cisco Transport Planner can support any subset of the following services:

- Alien (third-party DWDM interface)
- Cisco ONS 15530 2.5 Gbps Aggregated
- ONS 15530 10 Gbps Aggregated
- ONS 15530 Multirate (MR) Transport
- ONS 15530 Data Multiplexer (MXP)
- 2R Any Rate
- Gigabit Ethernet
- 10GE—10 Gigabit Ethernet (LAN and WAN)
- D1 Video
- DVB-ASI—Digital Video Broadcast-Asynchronous Serial Interface
- DV-6000
- DPSK—Different Phase Shift Keying
- ESCON—Enterprise System Connection
- Fast Ethernet
- Fiber Channel 1G
- Fiber Channel 2G
- Fiber Channel 4G
- Fiber Channel 8G
- Fiber Channel 10G
- FICON—Fiber Connection 1G

- FICON Express 2G
- FICON 4G
- FICON 8G
- FICON 10G
- E3 over FE
- T3 over FE
- DS3 over FE
- High Definition Television (HDTV)
- ISC-3 Peer (1G)
- ISC-3 Peer (2G)
- ISC-3 Peer (2R)
- ISC-Compat (ISC-3 Compatibility mode)
- OC-3
- OC-12
- OC-48
- OC-192
- OC-768
- OTU2
- SDI—Serial Data Input
- STM-1
- STM-4
- STM-16
- STM-64
- STM-256
- 10GE WAN-Phy
- 10GE LANtoWAN
- OTU2
- OTU2e
- OTU3
- Sysplex CLO—control link oscillator
- Sysplex ETR—external throughput rate

Note: The Sysplex CLO and Sysplex ETR services are supported only on the following topologies:
- Single span—Two terminal sites with 32MUX-O and 32DMX-O cards, 40MUX-O and 40DMX-O cards, 40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed and no intermediate sites in between.
• Point-to-Point—Two terminal sites with 32MUX-O and 32DMX-O cards. 40MUX-O and 40DMX-O cards, 40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed. Line amplifiers can be installed between the terminal sites, but intermediate (traffic terminating) sites cannot be installed.

• Two hubs—Two hub nodes in a ring with 32MUX-O, 32DMX-O, 32WSS, 40MUX-O, 40DMX, 40DMX-O, 40WSS, and 32DMX cards or 32DMX-O cards installed. Line amplifiers can be installed between the hubs.

Refer to the Cisco ONS 15454 DWDM Reference Manual for more information about the supported topologies for the ETR and CLO services.

1.1.3 Cisco Transport Planner Process Flow

The following stages are used to complete a network design. See Figure 1-5 for the process flow.

1. Create a project using the Project Creation wizard.

2. Create a network using the Create Network wizard. The Create Network wizards adds sites and places the fiber spans between the sites. A span represents a pair of fibers.

3. Create a point-to-point, AggregatedEthernet, TDM Aggregated, protected ring (P-ring), and/or ROADM service demand.

4. Analyze the network design.

5. If you would like to force automatic tool choices, adjust the design and repeat the analysis until you have reached the desired configuration.

6. Create an Install copy of the network and update the parameters with real data from the field.

7. Analyze the Install network.

8. Create an upgrade copy of the network, as needed, to add forecasted channels.
1.1.4 Planning Traffic in Cisco Transport Planner

Traffic in Cisco Transport Planner is defined as an optical path for each pair of nodes requiring a service demand. An optical path is the combined channels between the two nodes. The following list gives definitions for some basic traffic items:

- **Circuit**—A single channel between a pair of source and destination nodes. In addition to the source and destination nodes and all the attributes that are common to the service containing the circuit, a circuit has the following attributes:
  - Present/forecast indication
  - Routing direction for unprotected service
  - ITU channel
  - Optical bypass indication
• Demand—A set of circuits with common characteristics, such as:
  – Service demand label
  – Number of existing circuits
  – Number of forecasted circuits
  – Client service type
  – Protection type
  – Optical bypass (number of channels and/or sites)
  – WDM interface type (TXT or ITU-LC)
  – WDM card type
  – Source client interface (SR, IR, or LR)
  – Destination client interface (SR, IR, or LR)

• Traffic demand—All traffic between the same set of nodes. Both L-band and C-band are supported. The following traffic demands are supported: P-ring, Fixed (point-to-point), and Any-to-any (ROADM).
  – In P-ring traffic demands, all the demands are used to support traffic topologies similar to bidirectional line switched rings (BLSRs) or multiplex section-shared protection rings (MS-SPRings). Each P-ring demand is between a pair of added/dropped nodes where BLSR-like (or MS-SPRing-like) traffic must exist. The number of circuits is the same for each demand, and is user-specified (from 1 to 40).
  – In fixed (point-to-point) traffic demands, the set of nodes is restricted to two sites. The number of circuits is user-specified (from 1 to 40).
  – In any-to-any (ROADM) traffic demands, a minimum of two nodes and a maximum of 40 ROADM nodes are supported. The any-to-any traffic demand allows each node to establish one or more circuits with the other nodes, either as a hub or meshed configuration. In a meshed configuration, each node defined in the set is connected to each of the nodes. This is the most common traffic type. In a hub configuration, the user-defined hub node is connected to each of the other nodes. ROADM circuits have the same protection types and services. The number of circuits is not user-specified and can vary from 0 to 40.

  Note In any-to-any (ROADM) traffic demand, the default routing strategy is Unprotected minimum hop count.

A ROADM demand can have multiple client service types and support multiple DWDM card interfaces for each client service type. A ROADM demand supports the following routing strategies:
  – Protected (Default)—Each node pair in the traffic demand is connected using two connections.
  – Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected optimum optical path minimizes the number of required optical amplifiers, but also restricts the number of channels that can be deployed among the nodes of the traffic demand (maximum of 40 channels between each node pair) in the installed network.
  – Unprotected minimum hop count—Each node pair in the traffic demand is connected by one connection. The unprotected minimum hop count maximizes the number of channels (for unprotected traffic types only) that can be deployed among the nodes of the traffic demand, but requires a higher number of optical amplifiers on the unprotected optimum optical path (maximum of 40 channels between each node pair) in the installed network.
- **Unprotected subnet**—Each node pair in the traffic demand is connected using one connection. You can manually force connections on only one branch of the ring. For unprotected subnets, you must manually select one starting node of the branch and the direction the ring must be traversed to define the subnet, starting from the initial site. The branch direction is specified by defining the outgoing side first, referred to as the starting node. This routing strategy option allows you to exclude some critical paths and (with ROADM traffic demands containing two sites) to force each ROADM connection clockwise or counterclockwise.

### 1.1.5 Cisco Transport Planner Traffic in the Project Explorer Pane

Cisco Transport Planner represents all of the user-defined traffic services as a tree view within the Project Explorer pane. The Project Explorer pane shows all of the open project information, including the networks, the network dependencies, sites, fibers, services, and so on. (Figure 1-6).

![Project Explorer View](image)

**Figure 1-6 Project Explorer View**

After you analyze a network design, the colors of tree view change according to the error/warning condition of the network design. The icons display as red if there are errors in the network design; orange if there are warnings but no errors; and green if there are no warnings or errors. The icon shows the color of the most severe condition. For more information about analyzing the network, see the “2.9 Analyzing the Network” section on page 2-49.

Right-clicking on certain items in the Project Explorer tree allows you to edit the parameters.
1.1.5.1 Point-to-Point Traffic Demands

Point-to-point traffic demands appear in the Service Demands > PointToPoint folder in the Project Explorer pane. Each point-to-point traffic demand is categorized by its source and destination site names. All of the point-to-point services between the two sites appear under the designated demand name (Figure 1-7).

Figure 1-7 Point-to-Point Traffic Demand in the Project Explorer pane

A point-to-point traffic demand includes the following information:
- Client service type
- Site# – Site# (source and destination site labels for this demand)

1.1.5.2 P-Ring Traffic Demands

Each protected ring (P-ring) traffic demand appears in the Project Explorer pane under the Service Demands > P-Rings folder. Figure 1-8 shows an example of a P-ring traffic demand in the Project Explorer pane.

Figure 1-8 P-Ring Traffic Demand in the Project Explorer pane

All the P-ring channels between each site pair are listed under each P-ring traffic demand. Each demand is labeled with the following information:
- P-ring number
- Client service type
- Site# – Site# (source and destination site labels for this demand)

1.1.5.3 ROADM Traffic Demands

Each ROADM traffic demand appears in the Project Explorer pane under the Service Demands > ROADMs folder. The ROADM folder contains each defined ROADM demand. You can define more demands for the same ROADM for the same set of nodes. Figure 1-9 shows an example of a ROADM traffic demand.
1.1.5 Cisco Transport Planner Traffic in the Project Explorer Pane

In the Project Explorer pane, each ROADM includes the ROADM demand name and a list of DWDM card types that support the client service types. Protection types appear in parentheses.

1.1.5.4 Aggregated Ethernet Demand

Each aggregated ethernet traffic demand appears in the Project Explorer pane under the Service Demands > Aggregated Ethernet folder. The Aggregated Ethernet folder contains each defined aggregated ethernet demand. Aggregated Ethernet demands are supported on ring and linear traffic subnets. Figure 1-10 shows an example of an aggregated ethernet traffic demand.

1.1.5.5 TDM Aggregated Demand

Each TDM aggregated demand appears in the Project Explorer pane under the Service Demands > Aggregated TDMs folder. Figure 1-11 shows an example of a TDM aggregated traffic demand in the Project Explorer pane.
1.1.6 Auto, Forced, and Locked Parameters

Parameters in CTP can be in one of three states:

- **Auto**—This parameter allows the highest degree of flexibility to CTP in designing a network. When you select Auto, CTP chooses the parameter value during network analysis.

- **Forced**—When you set a specific parameter value, other than Auto, CTP designs the network using these constraints. When a setting is forced, the item appears in blue italics in the Project Explorer pane.

- **Locked**—The state of a parameter after network analysis. The next time the analyzer is run, Cisco Transport Planner cannot change the value when it is in the Locked state. You can unlock an item using the Unlock command. For more information, see the “2.10.5 Unlocking Parameters in the Network Design” section on page 2-54 and “2.10.5.1 Forcing Manager” section on page 2-55. Figure 1-12 shows an example of sites in a locked state.

![Figure 1-12 Locked Sites in the Project Explorer View](image)

Depending on the initial state, the network analyzer will:

- Move the parameter into the Locked state if the unit or parameter was set to Auto.
- Leave the parameter in the same state if the user forced a specific value for the unit or parameter.

1.2 Installing Cisco Transport Planner

Use the following procedure to install Cisco Transport Planner:

**Step 1**
To download the installer, go to the Cisco software download site.
Step 2 Navigate to the location where you want to save the CTP executable file to a local hard drive.

Step 3 Click Save.

Step 4 To start the installation of CTP:
- Windows—Navigate to the folder containing the CTP executable file and double-click it.
- Linux—Assuming the CTP.bin file is accessible from the current shell path, navigate to the directory containing the CTP.bin file and enter:
  ```
  % ./CTP.bin
  ```
The graphical CTP installation wizard is displayed.

Step 5 Click Next. The license agreement is displayed.

Step 6 To accept the license, select the I accept the terms of the License Agreement radio button.

Step 7 Click Next.

Step 8 Specify the installation folder. On Windows XP, the default is C:\Program Files\Cisco\CTP-R9.2.1. To choose a different folder, click the Choose... button and browse to the required folder. To restore the default path, click the Restore Default Folder button.

Step 9 Click Next.

Step 10 Specify the shortcut folder by choosing any one of the following options:
- In a new Program Group—Specify a new folder. The default option is CTP-R9.2.1.
- In an existing Program Group—Select a folder from the list of existing folders.
- In the Start Menu
- On the Desktop
- In the Quick Launch Bar
- Other—Use this option to specify a commonly used folder.
- Don't create icons—Choose this option if you do not want to create a shortcut.

Note Check the Create Icons for All Users check box if you want to create shortcuts for all the users of a system.

Step 11 Click Next. The pre-installation summary is displayed.

Step 12 Review the pre-installation summary. If no changes are required, click Install; otherwise, click Previous to make modifications.

A progress bar displays the installation status. Click Cancel at any time to stop the installation.

When the installation process is complete, a screen indicates whether the installation succeeded or failed.

Step 13 Click Done to exit the installation wizard.
1.3 Uninstalling Cisco Transport Planner

Use the following procedure to uninstall Cisco Transport Planner:

**Step 1** Click the Uninstall CTP icon available at the location selected in Step 10 of the “1.2 Installing Cisco Transport Planner” section on page 1-15.

The graphical Uninstall CTP wizard is displayed.

**Step 2** Click **Uninstall**.

**Step 3** A progress bar displays the uninstallation status. Click **Cancel** at any time to stop the uninstallation. When the uninstallation process is complete, a screen displays the files that could not be uninstalled.

**Step 4** Click **Done** to exit the uninstallation wizard.

1.4 Launching Cisco Transport Planner

Before you start Cisco Transport Planner, you need to save the user profiles provided to you by Cisco Systems to the profiles folder available at the installation location. Access to Cisco Transport Planner features depends on the user profile you select when you start Cisco Transport Planner. The default profile is Base Network Designer.

Use the following procedure to launch Cisco Transport Planner:

**Step 1** Launch Cisco Transport Planner using any of the following options:

- Click the CTP icon in the Start > All Programs > CTP menu.
- Double-click the CTP icon in the quick launch bar.
- Double-click the CTP icon on the desktop.
- Browse to the installation folder and double-click the ctp.jar file.

**Step 2** The Cisco Transport Planner login dialog box is displayed (Figure 1-13). Select the user profile from the Current selected profile drop-down list.
1.4.1 Opening a Project

Use the following procedure to open an existing Cisco Transport Planner project. To create a new project, see 2.1 Creating a Project, page 2-1.

**Step 1** Click the project name under Open in the Tasks Pane (Figure 1-14). The project opens. If you do not see the project name listed, continue with **Step 2**.

**Step 2** Click Open under Project in the Tasks Pane or in the File menu.
Chapter 1      Introduction

1.4.2 Loading and Unloading Networks

Step 3 In the Open Project dialog box, navigate to the desired folder and choose the project. Click Open. The Cisco Transport Planner project appears.

Note You cannot open an existing CTP project in multiple CTP instances. The saved project (.MPZ file) is locked for the use of that CTP. If you try to open the project in another instance of CTP, an error message is displayed. The .MPZ project file is unlocked and released only after you close the Network.

1.4.2 Loading and Unloading Networks

Each network in a project requires memory. To save memory, when Cisco Transport Planner opens a project, all networks are in the Unloaded state. An unloaded network appears in the Project Explorer pane with a “U” next to the network identifier (Figure 1-15). To load an unloaded network, double-click on the network folder in the Project Explorer pane, or right-click the network and choose Load from the shortcut menu.
A loaded network appears in the Project Explorer pane with an “L” next to the network identifier (Figure 1-16). To unload a loaded network, right-click the network icon in the Project Explorer pane and choose **Unload** from the shortcut menu.

**Note**
When you load a network containing an alien interface that is not present in the parts database (DB), warning messages are displayed.

**Figure 1-16 Loaded Network in the Project Explorer pane**

---

### 1.4.3 Saving a Project

Use the following procedure to save a project:

**Step 1** Choose one of the following:
- To save an existing project with the same filename, choose **File > Save**. You have completed this procedure.
- To save a new project, choose **File > Save** and go to **Step 2**.
- To save an existing project with a different filename, choose **File > Save As** and go to **Step 2**.

**Step 2** In the Save Project dialog box, navigate to the desired folder and enter the filename. Click **Save**. Cisco Transport Planner saves projects as zipped files with the MPZ extension.

---

### 1.4.4 Closing a Project

Use the following procedure to close a Cisco Transport Planner project:

**Step 1** From the File menu, choose **Close**.

**Step 2** In the Save Project dialog box, click **Yes** to save or **No** to close without saving changes.

**Step 3** If you clicked Yes and have not previously saved the project, the Save Project dialog box appears. Enter the name of the project and click **Save**. The project closes.

**Step 4** To exit Cisco Transport Planner, choose **Exit** from the File menu.
1.5 CTP Software Updates

Software updates for Cisco Transport Planner are routinely made available for installation. Installing the updates can rectify software errors and enhance software functionality. New updates can be installed from a local patch (.upz) file.

1.5.1 Check for Software Updates

You can check for software updates after CTP has started. Click Check updates in the Help menu. The Update CTP dialog box is displayed. In this dialog box, you can select either of the following options:

- Patch file—The updates are installed from a local .upz file. Click Browse to select the .upz file from your local folder. CTP checks all the updates available on the .upz file and displays only those that are new for the currently installed CTP version.

- Update server—CTP checks for online updates available on the server. The default server location is displayed in the corresponding edit box. You can type a different server location, if required. Click Ok to check for available updates on the server. Ensure that you have an internet connection.

Once the available updates are displayed, select those that need to be installed. Click Apply to install the updates or Cancel to continue using CTP without installing any updates. After the updates have been installed, you need to restart CTP for the updates to take effect.

Note
Before restarting CTP, clear the CTP cache from your local system.

To view the patch information, click About in the Help menu. The About Cisco Transport Planner dialog box is displayed. Select the Patch Info tab to display the information about the currently installed patch.

1.5.2 Discarding Software Updates

The CTP can be rolled back to the previous working state if there are performance issues after installing the new updates. At the time of launching CTP, a prompt is displayed to press the “R” key to perform the roll back. If the software roll back does not complete successfully, an error message is displayed.

1.6 Setting Cisco Transport Planner Options

Cisco Transport Planner provides numerous options for customizing the tool and the design.

Note
The following procedures for setting options using the Tools menu apply to new projects during project creation. To change an existing (open) project, click the desired item in the Project Explorer pane Subnets folder and edit the parameter in the Properties pane.

1.6.1 Setting the Graphical Display

Use the following procedure to set the Cisco Transport Planner graphical display:
Chapter 1      Introduction

1.6.1   Setting the Graphical Display

Step 1   From the Tools menu, choose Options.

Step 2   In the Options Explorer dialog box, right-click the Graphic folder and choose Expand from the shortcut menu.

Step 3   Click Chart Panel and complete the following:

- In the Colors area, to change the colors of Border Paint, Background Paint, Line Paint, Plot Background Paint, and Plot Outline Paint, click the relevant fields in the Colors list, and click the drop-down arrow to display a color swatch popup window. Then, click the desired color.

- In the Strokes area, to change the strokes of Border Stroke, Outline Stroke, and Default Line Stroke, click the relevant fields in the Strokes list, and click the drop-down arrow. Then click the desired stroke.

- In the Font area, click the Font drop-down box to display a font popup window. Then select the desired Font, Size and Style.

- In the Alfa area, enter numeric values for Background Alfa and Foreground Alfa.

- In the Shapes area, click the Line Shape drop-down box. Then click the desired line shape.

- In the Gridlines area, check the Range Gridlines and Domain Gridlines check boxes to view the gridlines for the same.

Step 4   To change the color scheme for Cisco Transport Planner, click Look & Feel and choose the desired scheme from the drop-down list.

Step 5   To change the appearance of the Project Explorer tree, click Project Explorer and complete the following tasks as needed:

- Overlapping—Check to reorder sites for a selected network.

- Alarm Mode—Choose Single for an alarm icon to report only the condition of that item or choose Cumulated for an alarm icon to summarize the most critical alarm of the item and its children.

- Bottom Right Icon—(Display only) Displays Locking to indicate that the lock icon appears at the bottom right of each locked item in the Project Explorer pane.

- Top Right Icon—(Display only) Displays Alarm to indicate that the alarm icon appears at the top right of each alarmed item in the Project Explorer pane. The alarm icon will be green, yellow, orange, or red to indicate the alarm severity.

Step 6   To change the NtView Name tab appearance, click Network View and complete the following tasks as needed:

- Site Color—To set the default site color when no forcing is done, click the drop-down arrow to display a color swatch popup window. Click the desired color.

- Site Selection Color, and Highlight Color—To change the site colors, click in the Color, Selection Color, and/or Highlight Color fields in the Site list. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

- Show Name—Check to display the site name on the NtView Name tab.

- Pass Through, OSC, Add/Drop, Hub, Gain equalizer, R-OADM, Line Amplifier, OXC, OIC, Background Amplified Color, Background Raman Amplified Span Color—To change the colors, click in the relevant fields in the Site list. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

- Show Amplifiers—Check to display the amplifier icon for a site on the NtView Name tab.
1.6.1 Setting the Graphical Display

- **Show Raman Amplified Span**—Check to display the Raman amplified span on the NtView Name tab.

- **In the Fiber area, complete the following tasks, as needed.**
  - True wave Reach Color, Dispersion Shifted Color, Metro Core Color, true wave, True Wave Plus Color, True Wave Minus Color, True wave Classic Color, Free Light Color, LS Color, Tera Light Color, E LEAF Color, TRUE WAVE RS Color, G 652 SMF Color, and Selection Color—To change the fiber color, click in the relevant fields in the Fiber list and then click the drop-down arrow.

- **Show Name**—Check to display the fiber name on the NtView Name tab.

- **Show Length**—Check to display the fiber length on the NtView Name tab.

- **Show total SOL Loss**—Check to display start of life (SOL) loss on the NtView Name tab.

- **Show total EOL Loss**—Check to display end of life (EOL) loss on the NtView Name tab.

- **Show CD C-band**—Check to display C-band chromatic dispersion (CD) on the NtView Name tab.

- **Show CD L-band**—Check to display L-band chromatic dispersion (CD) on the NtView Name tab.

The duct details displayed in the NtView Name tab is shown in Figure 1-17.

*Figure 1-17 Duct Details Shown on the NtView Name Tab*

- **Step 7**
  - To change the color of the traffic demands on the NtView Name tab, in the Point To Point, P-Ring, and Any To Any areas, click in the Color and Selection Color fields, and then click on the drop-down arrow to display a color swatch popup window. Click the desired color.

- **Step 8**
  - To change the Network Mgmt Tree tab appearance, complete the following tasks as needed:
    - In the Network area, click in the Color and Selection fields. Click the drop-down arrow to display a color swatch popup window. Click the desired color.
    - In the Link area, complete the following tasks:
      - To change the link color, click the Color field in the Link list and then click the drop-down arrow. Choose the desired line width from the drop-down list.
      - To change the link appearance, click the Stroke field in the Link list and then click the drop-down arrow. Choose the desired line appearance from the drop-down list.

- **Step 8**
  - To change the layout appearance, click Layout View and complete the following tasks as needed:
    - In the General area, click in the Background and Selection Color fields. Click the drop-down arrow to display a color swatch popup window. Click the desired color.
    - In the Any/Present View area, complete the following tasks:
      - To change the color for Foreground, Locked & Unlocked View, Locked Elements Background, and Locked Elements Foreground, click the relevant field and click the drop-down arrow to display a color swatch popup window. Click the desired color.
    - In the Alarmed View area, complete the following tasks:
1.6.2 Setting the Default Software Release

Use the following procedure to set the default software release for CTP. This release will be used as the default software release when creating a project. See 2.1 Creating a Project, page 2-1.

Step 1  From the Tools menu, choose Options.

Step 2  In the Options Explorer dialog box click General.

Step 3  In the column on the right, click the Default CTP Software Release option. A drop-down list appears.

Step 4  Click an option in the list to choose the desired software release. See Figure 1-18.

Figure 1-18  Default CTP Software Release Window

Step 5  Click Ok.
1.6.3 Setting the Default Platform Values

Use the following procedure to establish the default traffic mapping, dense wavelength division multiplexing (DWDM) design, and default layout settings for a particular platform and system release. The default settings will appear during project creation. All the options that you specify can be changed after project creation on a per-span basis.

**Step 1** From the Tools menu, choose Options.

**Step 2** In the Options Explorer dialog box (Figure 1-18), right-click Platform and choose Expand from the shortcut menu.

**Step 3** Click the desired System Release folder and complete the following tasks as needed:

<table>
<thead>
<tr>
<th>Note</th>
<th>Default changes apply only to the specified system release.</th>
</tr>
</thead>
</table>

- For Software Releases 8.5, 9.0, 9.1, 9.2, and 9.2.1, choose the desired settings in the General area:
  - **Shelf Management**—The options available are Auto, Multi Shelf Integrated Switch, Multi Shelf External Switch, and Individual Shelf. These options allow you to specify the type of management to be used for the sites on the network.
    - Select **Auto** to set the default option of Multi Shelf Switch for all the nodes with more than one shelf.
    - Select **Multi Shelf Integrated Switch** to configure all the Multiservice Transport Platform (MSTP) optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches plugged into the MSTP shelves.
    - Select **Multi Shelf External Switch** to configure all the MSTP optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches external to the MSTP shelves. For this option, two external Ethernet switch units (Cisco Catalyst 2950 and Cisco Catalyst 3650) are used to support the multishelf configuration.
    - Select **Individual Shelf** to configure all the MSTP optical units (OADMs and amplifiers) in the same shelf.

<table>
<thead>
<tr>
<th>Note</th>
<th>When the Multi Shelf External Switch is forced, the multishelf external switch is placed in the layout irrespective of the node controller.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Note</th>
<th>The Cisco ONS 15454 M6 (M6) chassis, when used as a node controller with the Multi Shelf External Switch, can support only two subtended shelves.</th>
</tr>
</thead>
</table>

Select **Individual Shelf** to configure all the MSTP optical units (OADMs and amplifiers) in the same shelf.

<table>
<thead>
<tr>
<th>Note</th>
<th>Shelf management is disabled for HYBRID 15454 ONS configuration in Release 9.1 and later.</th>
</tr>
</thead>
</table>
M6 chassis, when used as node controller, can support three subtended shelves, the subtended M6 chassis can subtend two more shelves.

- **Node Protection**—The options available are Same Shelf, Separated Shelves, and Node Split. Select **Same Shelf** to configure the optical units (amplifiers and OADM) on side A (CW direction) and side B (CCW direction) in the same shelf.

- **C-band Rules**—Select the options from the drop-down list. The options appear in the following format: C 64 Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and 8 dBm; and the spacing options available are 100 GHz and 50 GHz. You can use even wavelengths for 80, 72, and 64 channel design.

For HYBRID 15454 ONS configuration, the available options are 8, 16, 20, 32, and 40 channels.

- **L-band Rules**—Select the options from the drop-down list. The options appear in the following format: 32 Ch. 100 Ghz +5 dBm. The options available are: None, Expand, and channels available are 32; the reference per channel power options available are 2 dBm and 5 dBm; and the only spacing options available is 100 GHz.

Select **Expand** to indicate that the L-band rules are upgradable.

- **Installation w/o CTP**—Check this check box to install the network with default parameters. If you choose this option, CTP designs the network according to a set of predefined conditions, so that the selected node can be installed without the Cisco Transport Planner configuration files (thresholds and setpoints).

- **Dithering Lower Limit**—Enter a value that satisfies the following conditions:
  - Not lower than zero
  - Not higher than 32
  - Not higher than the dithering upper-limit value

The dithering value is the site identifier that CTP uses to adjust power on 80-WXC cards. Dithering value is provided only for sites with 40-WXC cards, that is, for sites with multidegree site structure and with the functionality “OXC” or “Auto”. This parameter is not displayed for non-OXC sites.

- **Dithering Upper Limit**—Enter a value that is not lower than zero and not higher than 32.

- **Insulators**—Check this check box to protect the Express Add/Drop (EAD) colorless ports of the 80-WXC-C cards configured as demux units.

The Cisco ONS 15216-FLD-2-ISO optical insulator is not supported in CTP Release 9.2.1.
Note

Optical insulator connections are displayed only in the Patchcord Installation tab in the Internal Connections report.

- Use Payg—Check this check box to enable the Pay As You Grow feature. For more information about the Pay As You Grow feature, see the “1.8 Understanding the Pay As You Grow Feature” section on page 1-42.

- For adding Alien Shelves to the network, enter the required values in the Layout area:
  - Alien Shelf Name—Enter the name of the alien shelves that are added to the site. This name will be displayed in the Layout reports.
  - Number of Alien Shelves—Enter the number of alien shelves that are to be added to the site. Number of alien shelves can vary based on the alien shelf height. Maximum number of alien shelves that can be added is 600, if the alien shelf height is 1 Rack Unit (RU) and there are no other shelves in the layout.
    - The maximum number of racks supported for a site is 15. If the addition of alien shelves require more than 15 racks, an error message will be displayed in the summary report and the layout is not built for the site.
  - Alien Shelf Height—Enter the height of the alien shelves in RU. If the alien shelf height is greater than the rack height, alien shelves will not be added to the site, and an error message will be displayed in the summary report.

The above values are applicable to all the sites in the newly created network. Values can be modified for individual sites after the network creation.

Step 4

Click the Restricted Equipment folder. To restrict a card, check the corresponding check box in the Restricted column for that card.

To change the setting back to unrestricted, uncheck the check box. To apply restricted list changes to an open project, complete the following:

a. Right-click the folder for the network that you want to update and choose Expand from the shortcut menu.

b. Right-click the desired platform and release folder under RestrictedEqptListFolder in the Project Explorer pane and choose Edit List from the shortcut menu. The Restricted Equipment list for MSTP 454 DWDM [Release Number] dialog box appears.

c. Click Update. The modified Restricted Equipment List is replaced with the global restricted equipment List.

d. Click OK to close the dialog box.

Step 5

Enter the Fiber Options details.

- Span Label Tag—Enter the desired span label; the default label is Duct.
- Span Length—Enter the span length. The displayed unit of measure is retrieved from the Span Measurements Units field.
- EOL Ageing loss [dB]—Enter the EOL aging loss value. The EOL loss-per-span value is added at the end of life to each discrete fiber in the network (for example, to add an EOL margin for splicing).
- EOL Ageing Factor—Enter the number to use when factoring fiber aging. This factor is multiplied by the SOL total span loss without connectors.
1.6.3 Setting the Default Platform Values

**Note**

Enter a value in either EOL Ageing Factor or EOL Ageing loss; you do not need to enter a value in both fields.

- Connector loss [dB]—Enter the concentrated loss at the end of the span.
- Length Based Loss—If checked, the fiber loss is determined by multiplying the Span Length by the Loss Factor. If this check box is unchecked, you must enter the total loss of the span.
- Tot SOL loss w/o conn [dB]—Enter the total start of life (SOL) link fiber loss value for each span, excluding the connector concentrated loss. This value is applicable only if the Length Based Loss check box is unchecked.
- DCN Extension (With Software R8.0 and later releases)—Check this check box to enable the default use of data connection network (DCN) extension on each span in the project. This setting implies that the OSC channel is not used to connect the two nodes. This default can be overridden on the network wizard pane.

**Note**

Use one of the following formulas to calculate the fiber loss at SOL:

\[
\text{SOL} = \text{km} \times \text{dB/km} + (2 \times \text{connector loss})
\]

\[
\text{SOL} = \text{user entered loss} + (2 \times \text{connector loss})
\]

Use one of the following formulas to calculate the fiber loss at EOL:

\[
\text{EOL} = \text{km} \times \text{dB/km} \times \text{EOL Aging Factor} + (2 \times \text{connector loss}) + \text{EOL Aging Loss}, \text{ or}
\]

\[
\text{EOL} = \text{user entered loss} \times \text{EOL Aging Factor} + (2 \times \text{connector loss}) + \text{EOL Aging Loss}
\]

- Select the Fiber Type of each span of the network. You can specify a fiber type even if the fiber type is not supported for the design.

**Step 6**

Click the Traffic Mapping folder and complete the following tasks as needed.

- In the Fixed traffic area, choose the unprotected routing strategy from the drop-down list:
  - Auto—CTP automatically selects the minimum number of channels that can be deployed among the nodes of the traffic group.
  - Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected optimum optical path minimizes the number of required optical amplifiers.
  - Unprotected minimum hop count—Each node pair in the traffic group is connected by one connection. The unprotected minimum hop count minimizes the number of channels (for unprotected traffic types only) that can be deployed among the nodes of the traffic group.

- In the General area, choose the algorithm and wavelength options.
  - Force Mesh Algorithm—For CTP Software Release 8.5, check this check box to force the mesh algorithm.
  - Allow Different Wavelengths—Check this check box to allow different wavelengths to be used for regeneration.
  - Coloring Priority Option—Check to assign the wavelength from the left side of the available band, that is, from 1530 nm. If this option is unchecked, the wavelength is assigned from the right side of the available band, that is, from 1565 nm.
  - Flat Grid Filling Option—Check to assign the wavelength in a flat grid, allocating each free wavelength without any guard band. If this option is unchecked, the wavelength is assigned according to the actual assignment rules.
Note: Guard band is an unused part of the wavelength spectrum, for the purpose of preventing interference between the wavelength channels.

- Maximum Separation Option—Check to assign the wavelength related to the service types on the 40G CP-DQPSK MXP and 40G CP-DQPSK ME MXP cards from one side of the wavelength band, and from the opposite side for service types on other transponder cards.

Step 7 Select the C-band and L-band rules.

- **C-band Rules**—Select the options from the drop-down list. The options appear in the following format: C 64Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and, 8 dBm; and the spacing options available are 100GHz and 50 GHz.

- **For L-band Rules**— Select the options from the drop-down list. The options appear in the following format: 32 Ch. 100 Ghz +5 dBm. The options available are: None, Expand, and channels available are 32; the reference per channel power options available are 2 dBm and 5 dBm; and the spacing option available is 100GHz. Select Expand to indicate the L-band rules as upgradable.

Step 8 Click the **DWDM Design Rules** folder and complete the following tasks as needed:

- **OSNR Alarm For Regeneration**—Allows you to define the optical signal-to-noise ratio (OSNR) alarm severity. When this limit is reached, Cisco Transport Planner suggests a channel at an appropriate site on the network. After the network is designed and analyzed, in the Tasks pane (under Reports), click **Optical Results** to see if any site requires regeneration. The regeneration column will suggest the site where Regeneration is required.

- **Run Quick Analysis**—Check to use a quick but less accurate algorithm to analyze the network in a short time. After the analysis, Cisco Transport Planner displays the following warning message: “Dcu design not optimized due to Run Quick Analysis option.”

- **No-Tilt-Network-Design**—Check to force Cisco Transport Planner to operate the amplifiers inside the gain range where no tilt is generated and to determine the type and number of amplifiers in each site of the network accordingly. This option sets all the intermediary points of the network so that channels are always at the reference power level. The default value is Disabled.

Note: Long spans (with insertion loss greater than 25 dB) might not be supportable.

- **No In-line Bulk Attenuator Design**—Check to design the network without using any inline bulk attenuators. If the network cannot be designed without using external in-line attenuators, Cisco Transport Planner displays the following error message: “Unfeasible Network design. Site X should require usage of in-line attenuator. Leave unchecked to allow inline bulk attenuators.”

- **No TXT/Line-Card Bulk Attenuator Design**—Check to design the network without using any external receive (Rx) bulk attenuators on transponder or line cards. If any of the clients require Rx bulk attenuators, then the related channel is shown with the working condition (flagged red, orange, or yellow). No Rx bulk attenuator will be shown in any of the reports (such as Optical Channel Results, Internal Connections, or BoM). Leave unchecked to allow bulk attenuators.

- **Prevent Use of E-LEAF Dispersion Compensation Unit on E-LEAF Dispersion spans**—Check to prevent Cisco Transport Planner from using Extended -Large Effective area fiber (E-LEAF) dispersion compensation units (DCUs) on E-LEAF spans for the overall network. Leave unchecked if you want the algorithm to automatically optimize the usage of the E-LEAF DCUs.

- **No DCU Design**—Check to avoid automatic placement of DCU units.
1.6.3 Setting the Default Platform Values

- Max Scalability Placement — CTP allows you to scale up or expand the network made in your network design. You can add new sites and demands depending on your requirements, thus, CTC automatically creates the flexibility of the possible expansion of your network. It also checks to force the CTP to choose an EDFA/DCU placement that is best suited for future expansion of the designed network without any hardware changes.

- TDCU—Cisco Transport Planner allows you to place the TDCU units (TDCU Coarse and TDCU Fine) in the network. Select the options from the drop-down list:
  - Auto—Cisco Transport Planner automatically places the fixed DCU units in the network.
  - All Positions—Cisco Transport Planner places the TDCU units wherever the fixed DCU units can be placed.
  - Never Place—Cisco Transport Planner does not place the TDCU units in the network.
  - Selected Positions—Cisco Transport Planner places the TDCU units in ROADM, WXC, and Dynamic Gain Equalizer (DGE) nodes.

- Turbo Simplex—Check to achieve faster results by optimizing a subset of the total channels based on type and path rather than optimizing every channel. Unchecking this option can result in longer analysis times for large networks, especially with any-to-any ROADM traffic.

- Max Sc Value—Enables you to enter the maximum slope compensation value.

- Enable Connector Loss—Check this check box to apply the default connector loss values to the fiber. The applied value depends on the type of site where the fiber is connected:
  - Pass through Connector Loss—Enter the connector loss value for a pass-through site.
  - OXC Connector Loss—Enter the connector loss value for an OXC site.
  - ROADM Connector Loss—Enter the connector loss value for a ROADM site.
  - OSC Connector Loss—Enter the connector loss value for an OSC site.
  - Line Amplifier Connector Loss—Enter the connector loss value for a line amplifier site.

Note: The Pass through Connector Loss, OXC Connector Loss, ROADM Connector Loss, OSC Connector Loss, and Line Amplifier Connector Loss properties are enabled only if the Enable Connector Loss check box is checked.

The values of these properties can also be specified in the Properties pane for the Options>DWDM Design Rules>System Release option in the Project Explorer pane and are applicable to the current network.

Step 9 To define the shelf configuration parameters, select a site complete the following tasks under property tree:

- Osmine Compliant—Check to instruct Cisco Transport Planner to ensure that all the sites placing transponder and line cards are compliant with OSMINE.

- Hybrid Node—Check to instruct Cisco Transport Planner to ensure that cross-connect, SDH, and SONET cards are not placed within the optical transport section (OTS) shelf.

- Max Number of Shelves—Allows you to specify the maximum number of shelves per rack. The maximum number of shelves you can specify is 4. The default option is Auto.

- AIC—Choose Yes to instruct Cisco Transport Planner to put the AIC card in slot 9 of the first shelf in each site.
• Fiber Storage—Choose Yes to instruct Cisco Transport Planner to put the fiber storage within the rack below the optical shelf.

• Y-Cable—The options available are Auto, 1RU FlexLayer Shelf Assembly, and 2RU Y-Cable Panel.
  – Auto—Instructs Cisco Transport Planner to set the default value for the Y-Cable option.
  – 1RU FlexLayer Shelf Assembly—Instructs Cisco Transport Planner to use the ONS 15216 Splitter/Combiner Flex Layer modules to implement the required Y-cable protections.
  – 2RU Y-Cable Panel—Instructs Cisco Transport Planner to use the new ADC Splitter/Combiner modules to implement the required Y-cable protections.

• Fan Tray—(Software R8.0 and later) Instructs Cisco Transport Planner to put the type of fan tray within each node. Options available are FTA3-T and FTA4-T.

• TXP/MXP/XP in OTS—Instructs Cisco Transport Planner to place client cards in OTS shelves. Options available are Auto, Yes, and No. Auto instructs CTP to place client cards in OTS shelves.

• Etsi Rack Width—Allows you to specify the ETSI rack width. Choose 19 inches to add 15454E-19IEC-KIT for each ETSI shelf. Options available are Auto, 19 inches, and 600mm.

• Rack Height in RU—Allows you to specify an integer value for the rack height. The default option is Auto. Auto assigns 44 RU for ANSI and 40 RU for ETSI.

• Alien Shelf Height—Enter the height of the alien shelves in RU. If the alien shelf height is greater than the rack height, alien shelves will not be added to the site, and an error message will be displayed in the summary report.

• No of Alien Shelves—Enter the number of alien shelves that are to be added to the site. Number of alien shelves can vary based on the alien shelf height. Maximum number of alien shelves that can be added is 600, if the alien shelf height is 1 Rack Unit (RU) and there are no other shelves in the layout. The maximum number of racks supported for a site is 15. If the addition of alien shelves require more than 15 racks, an error message will be displayed in the summary report and the layout is not built for the site.

• Alien Shelf Name—Enter the name of the alien shelves that are added to the site. This name will be displayed in the Layout reports.

• Chassis Type—(Release 9.2) Enables you to choose the type of chassis. The options available are Auto, M12 Chassis, M6 Chassis, and M2 Chassis. The default option is Auto, which selects combinations of the chassis in an optimized manner.

  – M2 chassis refers to the ONS 15454 M2 chassis.
  – M6 chassis refers to the ONS 15454 M6 chassis.
  – M12 chassis refers to the ONS 15454 chassis.

• Power Supply—(Release 9.2) Enables you to choose the type of power supply. The options available are Auto, AC Power, and DC Power. The default option is DC Power.

• Populate Shelves From Bottom—Check this check box to instruct Cisco Transport Planner to place the shelves in the rack from the bottom. This is useful in installing shelves in tall racks. For more information about the order in which CTP fills the rack, see the “4.13.1 General Placement Rules” section on page 4-62.

• DCC Shelves Management—Check this check box to instruct Cisco Transport Planner to reserve Slot 12 for equipping 15454-MR-L1 units to implement data communication channel (DCC) shelf management.

• Redundant Power—(Release 9.2 and later, M6 chassis only) Enables you to choose the redundant power supply to be added. The options available are Auto, Yes, and No. The default option is Yes.
1.6.4 Setting the Default Project Values

Use the following procedure to set the default project settings and repair time. These defaults will appear during project creation.

**Step 1** From the Tools menu, choose **Options**.

**Step 2** In the Options Explorer dialog box (Figure 1-18 on page 1-24), click **Project** and complete the following tasks to set the defaults that appear in the Project Creation wizard:

- **Customer**—Enter the default customer name (128-character maximum).
- **Created by**—Enter the default user name (128-character maximum).
- **Measurement Units**—Choose the default span length unit of measure from the drop-down list, either **Km** or **Miles**.
- **Price List**—Choose the default price list.
- **Restricted Analysis**—Check to use Restricted Analysis in the project.
- **ANSI/ETSI**—Choose either **ANSI** (American National Standards Institute) or **ETSI** (European Telecommunications Standards Institute) from the drop-down list.

**Step 3** Click **General** and complete the following tasks:

- **MTTR (hours)**—Enter the mean time to repair (MTTR) for all sites in the network. This value will apply to every site in the network. If you change the MTTR value after creating sites, the new value will only apply to sites you create after the change.

---

- **UTS AC Power Cables**—(Release 9.2 and later) Enables you to choose the type of cables to be added for the AC power supply. Cables are listed based on the country type. The default option is EU.
- **Redundant Controller Card**—(Release 9.2 and later, M6 chassis only) Enables you to choose the redundant controller card. The options available are Auto, Yes, and No. The default option is Yes.

**Note** M6 chassis without redundant controller card is not supported in MSM configuration.

- **M6 Chassis in Use**—(Release 9.2 and later) Enter an integer value for the number of M6 chassis to be used.
- **M12 Chassis in Use**—(Release 9.2 and later) Enter an integer value for the number of M12 chassis to be used.
- **M6 Shelves**—(Release 9.2 and later) Enter an integer value for the number of empty shelves to be added to the node layout. CTP supports a maximum of 29 extra M6 shelves. The Auto option does not add any shelves.
- **M12 Shelves**—(Release 9.2 and later) Enter an integer value for the number of empty shelves to be added to the node layout. CTP supports a maximum of 29 extra M12 shelves. The Auto option does not add any shelves.
- **Node Controller**—Allows you to choose a chassis as the node controller. The options are Auto, M12 Chassis, and M6 Chassis. Default is Auto.

**Step 10** Click **OK**.
1.6.5 Defining Third-Party DWDM Interfaces

Cisco Transport Planner allows you to define a third-party DWDM interface to be used in project creation. After you define third-party DWDM interfaces, you can choose them when creating traffic demands. For more information on defining third-party interfaces, see Appendix D, “Third-Party DWDM Wavelength Interface Model.”

Note

If you create a network design with a third-party interface and need to share the design with other users, you must provide not only the saved network MPZ file but also the exported database file containing the third-party interface definition. To view this project, the other user first must import the database with the third-party interface values.

Use the following procedure to define a third-party DWDM interface:

Step 1 Click Tools > DB Parts Mgmt. The DB Parts Manager dialog box appears.
1.6.5 Defining Third-Party DWDM Interfaces

Note: You cannot open the DB Parts Manager if a project is open or if you are using the Base Network Designer profile.

Step 2 Right-click **Platform Parts** and choose **Expand** from the shortcut menu.

Step 3 Right-click **Group** and choose **New Group** from the shortcut menu. The new group appears under **Group** and in each system release under parts DB.

Step 4 In the Group Editor dialog box, complete the following information:
- Name of group—Enter the name of the new database.
- Note—(Optional) Enter a description of the group.

Step 5 In the parts DB for the desired system release, click the group that you created.

Step 6 In the Parts tab of the DB Parts Manager dialog box, right-click and choose **Client** and then **Alien** from the shortcut menu. A new row appears on the Parts tab for the client hardware.

Step 7 Double-click the row to open the Alien dialog box (Figure 1-19).

Figure 1-19 Alien Card Dialog Box

Step 8 In the General tab of the Alien dialog box, type the name of the card in the **Name** field and the enter the **Label** name.

Step 9 Click the **Instance** tab and complete the following:
- ANSI PID—Enter the product identifier of the ANSI system, as needed. If you select BoM visible for this third-party interface with ANSI PID completed, the third-party interface is included in the BoM with the related product identifier.
• Etsi PID—Enter the product identifier of the ETSI system, as needed. If you select BoM visible for this third-party interface with ETSI PID completed, the third-party interface is included in the BoM with the related product identifier.
• TAG—(Display only) For internal use.
• SYS. NAME ANSI—Not applicable for third-party interfaces.
• SYS. NAME ETSI—Not applicable for third-party interfaces.
• WL START—Choose the wavelength starting range that the third-party interface supports from the drop-down list.
• WL END—Choose the wavelength ending range that the third-party interface supports from the drop-down list.

Step 10 Click the Physical Ports tab and in the Label column, type a label for each port. The CTC Ports and TL1 Ports tabs are not applicable for third-party interfaces.

Step 11 Click Ok.

Step 12 In the Parts tab of the DB Parts Manager dialog box, right-click and choose Software and then Alien from the shortcut menu. A new row appears on the Parts tab for the client software.

Step 13 Double-click the row to open the AlienSoft dialog box.

Step 14 In the General tab, complete the following:
  • Name—Enter the name in the Name field.
  • Related Item—Choose the client card that you created in Step 7 to Step 11.

Step 15 Click any of the following depending on the client card that you choose and proceed to Step 16:
  • Default - OCh tab (Figure 1-20)
  • DPSK-OCh tab
  • QPSK-OCh tab
Figure 1-20  AlienSoft Dialog Box, Default-OCH Tab

Step 16  Complete the following (see Tables 1-2 through 1-4 for supported value combinations):

- In the Rules area, choose the C-band or L-band design rule from the Design Rule drop-down list.
- In the Technology area, complete the following:
  - Modulation Format—Choose NRZ (Non Return to Zero) or Duo Binary.
  - Transmitter Type—Choose MZ (Mach Zehnder), DML (Direct Modulated Laser), or EML (Electro-absorption Modulated Laser).
  - Receiver Threshold—Choose Optimal (minimum BER) or Average (average received power). For DPSK—Choose the Receiver Threshold as Optimal. For QPSK—Choose the Receiver Threshold as Average.
  - Regeneration Type—Choose 3R or 2R regeneration mode.
  - FEC Mode—Choose FEC (Forward Error Correction), no FEC, or E-FEC (Enhanced FEC). For DPSK or QPSK, set the FEC Mode to E-FEC.
  - Transmitter Stability—Choose the maximum wavelength error allowed (pm). The values are 12.5, 25, 50, or 100 pm.
- Bit Rate—Choose the desired bit rate from the drop-down list. For DPSK or QPSK, choose the Bit Rate as 40 Gb/s.
- In the TX Power Range area, complete the following:
  - TX Max Power—Enter the maximum power output level (dBm).
  - TX Min Power—Enter the minimum power output level (dBm).
In the Back to Back Receiver Sensitivity area, complete the following as needed to define the working interface area for Back to Back. Back to Back is a configuration where the receiver is placed in front of the transmitter and no other equipment exists between the two. Back to Back is used to measure characteristics of the TX and RX pair. Figure 1-21 shows the interface operative area.

- **Overload Power [ps/nm]**—Enter the overload power level.
- **OL_Power [dBm]**—Enter the minimum power level in the OSNR-limited range.
- **OL OSNR [dB]** on 0.5 nm RBW—Enter the minimum OSNR level in the OSNR-limited range (measured in 0.5 increments).
- **PL_Power [dBm]**—Enter the minimum power level in the power-limited range.
- **PL OSNR [dB]** on 0.5 nm RBW—Enter the minimum power level in the OSNR-limited range (measured on 0.5 nm bandwidth).

In the Chromatic Dispersion area, complete the following as needed:

- **Customize CD Robustness**—Check to enable the CD Robustness field, as needed. Chromatic dispersion (CD) refers to the broadening of a light pulse after traveling a distance in the fiber.
- **CD Robustness [ps/(nm*km)]**—If Customize CD Robustness is checked, choose the maximum positive dispersion, Dmax_pos [ps/(nm*km)], tolerable by the interface: 0 dB, 1 dB, 1.5 dB, 2 dB, or 3 dB.

Customize Penalties—Check to enable the Gaussian cross-talk Penalties, Single-Interfering Cross-Talk Penalties, and Scale Q factors fields as needed.

If Customize Penalties is checked, enter the values to determine the Gaussian cross-talk Penalties in the A_GXt and B_GXt fields, as needed. Gaussian cross talk refers to random power that interferes with a signal. The A_GXt and B_GXt values are the coefficients for the exponential curves that estimate P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for Gaussian cross-talk levels in the OL and PL regions of the interface model with dispersion margins added (see Figure 1-21). The formula is Penalty (GXt) = A_GXt * exp(B_GXt * GXt).

If Customize Penalties is checked, enter the values to determine the Single-Interfering Cross-Talk Penalties in the A_SIXt and B_SIXt fields, as needed. Single-interfering cross talk refers to interference caused by a single signal. The A_SIXt and B_SIXt values are the coefficients for the exponential curves that estimate P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for single-interfering cross-talk in the OL and PL regions of the interface model with dispersion margins added (see Figure 1-21). The formula is Penalty (IXt) = A_SIXt * exp(B_SIXt * IXt).

If Customize Penalties is checked, enter Scale Q values in the F-P(PL), F-P(OL), F-OSNR(PL), and F-OSNR(OL) fields, as needed. The scale factors measure how efficient a card is in recovering the signal distortion. The slope of the Q-factor curve versus OSNR or RX power determines how a BER increase could be recovered with an increase of OSNR, power, or both (depending in which OSNR/power working point the card is). In general, the scale factors are two values (one in OSNR and one in power) for each working point OL and PL of the interface model (see Figure 1-21). The the F-P(PL), F-P(OL), F-OSNR(PL), and F-OSNR(OL) values translate a Q-penalty (that is, a BER increase) into power and OSNR penalties. The formulas follow:

- **P-penalty(PL) = Q-penalty * F-P(PL)**
- **P-penalty(OL) = Q-penalty * F-P(OL)**
- **OSNR-penalty(PL) = Q-penalty * F-OSNR(PL)**
- **OSNR-penalty(OL) = Q-penalty * F-OSNR(OL)**

F-P(PL) and F-OSNR(PL) are evaluated in the PL working region, while F-P(OL) and F-OSNR(OL) are evaluated in the OL working region of the curve with the dispersion margins added.
1.6.5 Defining Third-Party DWDM Interfaces

Step 17 Click Ok.

Table 1-2 lists the supported combinations for 40-Gbps third party interfaces.

Table 1-2 **Supported Combination for 40-Gbps Third-Party Interface**

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>P-penalty (OL)</td>
</tr>
<tr>
<td>Duo Binary</td>
<td>MZ</td>
<td>Optimal</td>
<td>E-FEC</td>
<td>± 12</td>
<td>0</td>
</tr>
</tbody>
</table>

Table 1-3 lists the supported combinations for 10-Gbps third party interfaces.

Table 1-3 **Supported Combinations for 10-Gbps Third-Party Interface**

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>P-penalty (OL)</td>
</tr>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Optimal</td>
<td>E-FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Optimal</td>
<td>FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>2</td>
</tr>
<tr>
<td>NRZ</td>
<td>EML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 100</td>
<td>0</td>
</tr>
</tbody>
</table>
1.6.6 Exporting User Options, Price Lists or Alien Definitions

Use the following procedure to export user options, price lists, maintenance contracts, and the parts database files. The export command creates a ZIP file that includes all of the created files.

**Step 1** From the Tools menu, choose Export. The Export dialog box appears.

**Step 2** In the Export dialog box, enter a file path and name in the file name field. To export to an existing file, click the ... button and navigate to the desired folder and file. Click Select to choose the file.

**Step 3** To select the items to export, complete the following as needed:
- User Option—Check to export the user options set using the Tools > Options command.
- PartsDB—Check the desired platforms.
- PriceDB—Check All Price DB to export all price lists, or expand All Price DB and check the individual price lists that you want to export.

**Step 4** Click Ok.

1.6.7 Importing User Options, Price Lists or Alien Definitions

Use the following procedure to import user options, price lists, maintenance contracts, and the parts database files. You can import a ZIP file of multiple exported items or an individual TXT file.

**Step 1** From the Tools menu, choose Import. The Import dialog box appears.

**Step 2** In the Import dialog box, click the ... button and navigate to the desired folder and file. Click Select to choose the file to import.

**Step 3** Click load.

Table 1-4 lists the supported combinations for 2.5-Gbps third party interfaces.

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>P-penalty (OL)</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>3</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>3</td>
</tr>
<tr>
<td>NRZ</td>
<td>EML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 100</td>
<td>0</td>
</tr>
</tbody>
</table>
Step 4 If you selected a single TXT file, skip this step and go to Step 5. If you selected a ZIP file with multiple exported options, complete the following as needed:

- User Option—Leave checked to import a file with the user options that were set with the Tools > Options command.
- PartsDB—Leave checked to import the parts database for the desired platform.
- PriceDB—Leave All Price DB checked to import all price lists, or uncheck and check the desired individual price lists.

Step 5 Click OK.

Step 6 In the confirmation dialog box, click OK.

### 1.6.8 Importing Osmine Configuration File

The Osmine configuration updates are provided in an Osmine configuration file. When a new Osmine configuration file is available, use this procedure to import it. The networks analyzed after the import operation will be OSMINE compliant as per the configurations provided in the Osmine configuration file.

Step 1 From the Tools menu, choose Osmine File Import. The Select Osmine Config File dialog box is displayed.

Step 2 Browse for the Osmine configuration file.

Step 3 Click Open. The new configuration is loaded into CTP.

### 1.6.9 Resetting the Default Layout

Your graphical layout settings are saved when you exit Cisco Transport Planner. The next time that you launch Cisco Transport Planner, the layout appears as it did upon exiting. The default graphical layout includes items such as whether the panes are visible and/or docked.

To return to the Cisco Transport Planner default layout, choose Default Layout from the View menu. To restore the user modified layout, choose My Default View from the View menu.

### 1.6.10 Adding User Profiles

A user profile is a set of privileges used for running Cisco Transport Planner. Each profile offers different capabilities. Cisco Transport Planner is packaged with the Network Designer profile, but you can add other user profile types provided by Cisco. All the procedures in the Cisco Transport Planner DWDM Operations Guide are written for users with Network Designer access.

Use the following procedure to add a user profile to Cisco Transport Planner:

Step 1 Close all open instances of Cisco Transport Planner.

Step 2 Identify the folder where Cisco Transport Planner is installed on your computer, see the “1.4 Launching Cisco Transport Planner” section on page 1-17.
Step 3 Create a profile folder; if profile folder already exists, go to Step 4.
Step 4 Copy the profile JAR file provided by Cisco Systems into the profile folder.
Step 5 Launch Cisco Transport Planner. For more information, see the “1.4 Launching Cisco Transport Planner” section on page 1-17. The new profile will appear in the Current Selected Profile drop-down list.

1.6.11 Understanding Sides Labeling

In Cisco Transport Planner Software R8.5 and later, the label for each supported site structure is different from the labels that have been used in the previous releases. Table 1-5 summarizes the labeling format in Cisco Transport Planner.

<table>
<thead>
<tr>
<th>Sites</th>
<th>Labeling in Previous Releases</th>
<th>Labeling in Cisco Transport Planner Software R8.5 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terminal/Terminal+</td>
<td>Only one side is created and labeled, T.</td>
<td>Only A can be used for the existing side.</td>
</tr>
<tr>
<td>Line/Line+</td>
<td>Two sides are created and are labeled, West and East.</td>
<td>Only A and B can be used for the existing sides.</td>
</tr>
<tr>
<td>Multidegree with PP-MESH-4</td>
<td>—</td>
<td>Only A, B, C, and D can be used for the existing sides.</td>
</tr>
<tr>
<td>Multidegree with PP-MESH-8</td>
<td>—</td>
<td>Only label A, B, C, D, E, F, G, and H can be used for the existing sides.</td>
</tr>
<tr>
<td>PSM Line</td>
<td>—</td>
<td>Only Aw and Ap can be used for the existing sides, where w stands for working and p stands for protection.</td>
</tr>
<tr>
<td>PSM Section</td>
<td>—</td>
<td>Only Aw and Ap can be used for the existing sides, where w stands for working and p stands for protection.</td>
</tr>
</tbody>
</table>

1.7 Understanding Hybrid Configuration

Typically a node has ONS 15454 MSTP configuration with add/drop units like 40-MUX-C/40-DMX-C, ROADM units and so on. However, the node configuration can also have ONS 15454 amplifiers along with ONS 15216 FlexLayer add/drop units like FLB-2s, FLA-8s, and FLD-4s, and is known as Hybrid 15454 ONS configuration. A network design can have up to 80 channels in a typical MSTP configuration; however, in a Hybrid configuration the number of channels is restricted to 40. In a Hybrid configuration, the Data Connection Network (DCN) manages the traffic instead of Optical Service Channel (OSC). Hybrid nodes are add/drop nodes with express traffic and are comparatively less expensive than MSTP nodes.
1.8 Understanding the Pay As You Grow Feature

The Pay As You Grow (PAYG) feature enables you to implement a cost effective solution when the wavelength requirements are comparatively less than the maximum capacity of the network. Instead of purchasing a standard card that is configured to work on maximum supported wavelengths, you can purchase a PAYG bundle that comprises of license restricted cards and a base license. The license restricted cards support only a number of wavelengths for which the licenses are installed on the card. The base license supports only 10 wavelengths. Therefore, a license restricted card having only the base license will support only ten wavelengths even if its maximum capacity is to support 40 wavelengths. The cost of the PAYG bundle is less than the cost of the standard card. For more information about the PAYG bundles, see the Appendix F, “Pay As You Grow Bundles”.

When there is a need of more than ten wavelengths, additional licenses can be purchased to support the increased demand. Each new license supports ten additional wavelengths. Therefore, the PAYG functionality significantly reduces the initial setup cost and enables the purchase of additional wavelength capacity on a need basis.

During the analysis of the network, the CTP algorithm decides on whether to use a standard card or a PAYG bundle depending on the lower implementation cost.

The cards and units that support a PAYG bundle are:

- 40-SMR1-C
- 40-SMR2-C
- 80-WXC-C
- 15216-MD-40-ODD

The PAYG licensing is applied to each side of every site. The license depends on the cards placed on that side and the wavelengths that are added, dropped, or expressed. The PAYG licensing is not dependent on site, type, or functionality.

The applied PAYG bundle is displayed in the Bill of Material of the site. To view it, right-click the site in the Project Explorer pane and select the Bill of Material option from the shortcut menu.

The PAYG bundle to which a card is associated is displayed in the card property. To view it, select the card in the Project Explorer pane; the PAYG bundle name is displayed for the Payg Bundle property in the Properties pane.

1.8.1 Unlock Pay As You Grow Bundles

When a license restricted card is associated with a PAYG bundle, the association is maintained for future analysis. Therefore, if the network is analyzed with increased wavelength demands, CTP adds additional licenses even though using a standard card is cost effective.

During a network upgrade, the association of the license restricted card with the PAYG bundle is not modified unless the Unlock Pay As You Grow Bundle option is selected. Right-click the site either in the Project Explorer pane or in the NtView Name tab, and select the Unlock Pay As You Grow Bundles option from the shortcut menu. On selecting the Unlock Pay As You Grow Bundle option all the PAYG bundle information from a previous analysis are deleted and are recalculated when the network is analyzed again.

Note

The Unlock Pay As You Grow Bundle option is enabled only in the Upgrade or Install mode.
1.8.2 Forcing PAYG Bundles On a Card

The Developer and Optical Designer profile users can decide whether to associate a card with the PAYG bundle or not. Select the card in the Project Explorer pane; the Force Payg drop-down list is displayed in the Properties pane. The options available are:

- **Auto**—The PAYG bundle or the standard card is used based on cost effectiveness.
- **Yes**—The card is always associated with the PAYG bundle even if using the PAYG bundle is not the most cost effective solution.
- **No**—The card is never associated with a PAYG bundle even if using the PAYG bundle is a more cost effective solution.

**Note**

The Force Payg drop-down list is enabled only in the Upgrade and Install modes, when the card is in the locked state.
1.8.2 Forcing PAYG Bundles On a Card