Introduction

Note
Cisco MetroPlanner has been renamed to Cisco Transport Planner starting with release 8.5.

Cisco Transport Planner provides a way to model and test wavelength division multiplexing (WDM) optical networks in a graphical environment. The primary purpose of Cisco Transport Planner (CTP) is to help sales engineers (SEs) design and validate networks of Cisco Optical Networking System (ONS) 15454 Multiservice Transport Platforms (MSTP). Using Cisco Transport Planner, an SE can create multiple instances of a network to modify different parameters in each instance for comparison. Cisco Transport Planner generates a shelf view of all the sites deployed in the optical network and provides a complete bill of materials (BoM) for the network and the differences between instances of a network.

This chapter describes how you use Cisco Transport Planner to design, analyze, and optimize new or existing Cisco optical networks and contains the following sections:

- 1.1 Overview, page 1-1
- 1.2 Installing Cisco Transport Planner, page 1-15
- 1.3 Uninstalling Cisco Transport Planner, page 1-16
- 1.4 Launching Cisco Transport Planner, page 1-16
- 1.5 Setting Cisco Transport Planner Options, page 1-19

1.1 Overview

This section describes the Cisco Transport Planner 9.1 features, network design process, process flow, traffic planning, traffic services, and parameter states.

1.1.1 Cisco Transport Planner 9.1 Features

Cisco Transport Planner software provides a simple tool set for designing optical networks with Cisco ONS 15454 MSTP products. You can enter all of the network parameters or minimal information, such as site distance, and Cisco Transport Planner will model the network you need to build and generate a detailed BOM with ordering information. Designing optical networks requires the verification of multiple constraints such as optical budget limitations and platform architectural restrictions. One
Cisco Transport Planner project can contain multiple copies of a network. This duplication allows you to change parameters in one network copy, then analyze and compare it to another network copy to determine the differences. Cisco Transport Planner Software R9.1 provides the following new features:

<table>
<thead>
<tr>
<th>Supported Feature</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Unlock Options—Forcing Manager</td>
<td>Forcing Manager enables you to unlock multiple interfaces connected to various ducts and sites. This helps you unlock a group of sites and ducts based on individual units such as amplifiers, add/drop units, band parameters, and node layout. Forcing Manager can be used to unlock sites/ducts in both the design mode and the upgrade mode.</td>
</tr>
<tr>
<td>Alien shelves</td>
<td>Allows you to add third-party vendor entities to the node layout. Alien shelves can be added to individual sites or to the whole network.</td>
</tr>
<tr>
<td>Different Phase Shift Keying (DPSK) and Different Quadrature Phase Shift Keying (DQPSK)</td>
<td>Different Phase Shift Keying (DPSK) and Different Quadrature Phase Shift Keying (DQPSK) are client cards that helps to define third-party DWDM interfaces, when creating traffic demands.</td>
</tr>
<tr>
<td>Double slot card movement</td>
<td>CTP allows a double slot card movement when the destination has a blank faceplate in a single slot card. The single slot card is placed before and/or after the blank faceplate.</td>
</tr>
</tbody>
</table>
## Supported Feature

<table>
<thead>
<tr>
<th>Supported Feature</th>
<th>Functionality</th>
</tr>
</thead>
</table>
| Even channels design     | Supports design of ONS 15454 MSTP systems with 50 GHz channels spacing—64, 72, and 80 channels. This facilitates the usage of even wavelengths in the traffic matrix. 50 GHz designs are allowed only for ROADM-WSS and OIC-WSS configurations. The units available to add/drop even channels are:  
- 40-WSS-CE: 40 Channels Wavelength Selective Switch—C-band—Even  
- 40-DMX-CE: 40 Channels Demultiplexer —C-band— Even  
50 Ghz interleaver/deinterleaver unit is required to separate even and odd channels and provide them to the add/drop units. The following cards can support 50 GHz even channels design going upto 80 channels, due to the availability of the tunable XFP ONS-XC-10G-C:  
- OTU2_XP  
- ADM-10G  
- GE_XP  
- GE_XPE  
- 10GE_XP  
- 10GE_XPE  
If the design of ONS 15454 MSTP systems has an interleaver/deinterleaver, the WSS-C-ODD patchcord connections will be available in internal connection report. |

### Note

The WSS-C-EVEN connections will not be displayed in the internal connections report. The patchcords connections of WSS-C-ODD and WSS-C-EVEN is available in NeUpdate.xml file.

<table>
<thead>
<tr>
<th>CTP File Lock</th>
<th>Any saved network loaded in CTP is locked for the exclusive use of that CTP. You cannot open an existing CTP project in multiple CTP instances. The .MPZ project file is unlocked and released only after you close the CTP instance and Network.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dark Fiber</td>
<td>A dark fiber is a span where no present or forecast traffic has traversed. If a particular side does not have any demand and traffic passing through that side, the ANS parameters related to that side will not be displayed in the Installation Parameters report.</td>
</tr>
<tr>
<td>Km/Miles Runtime Settings</td>
<td>You can change the km/miles runtime settings in the network parameters. Any change made to the measurement unit at the network level will change the measurement unit of all the ducts within that network.</td>
</tr>
</tbody>
</table>
## Overview

### Supported Feature

<table>
<thead>
<tr>
<th>Supported Feature</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>LAN to WAN conversion</td>
<td>The OTU2_XP card can be configured to convert the 10G Ethernet LAN traffic to WAN traffic. The OTU2_XP card supports 10G Ethernet LAN Phy to 10G Ethernet WAN Phy conversion on ports 1 (client port) and 3 (trunk port).</td>
</tr>
<tr>
<td>Maximum Scalability Placement</td>
<td>CTP allows you to create network designs to allow maximum scalability in terms of flexibility and system capacity. This maximum scalability placement operating mode is supported in parallel with the standard one, designing for lowest possible day 1 cost. CTP also checks for the maximum scalability options of shelf placements.</td>
</tr>
<tr>
<td>MSM Shelf ID in Multi Shelf Management Configuration</td>
<td>Allows you to modify the MSM Shelf ID for Multi Shelf Management Configuration.</td>
</tr>
<tr>
<td>MSM Shelf Movement</td>
<td>Allows you to move all the shelves in the layout using the “Move” option.</td>
</tr>
<tr>
<td>Network Wide Layout Export</td>
<td>The network wide layout report feature exports the layout reports of multiple sites in an analyzed network.</td>
</tr>
<tr>
<td>Ne Update XML file to include the installation parameters</td>
<td>CTP supports the Ne Update XML file to include the installation parameters reports that shows the values set (provisioned) at the time of the installation of each site in the network. The NE Update file now provides details of the parameters used to provision the passive units.</td>
</tr>
<tr>
<td>OPT-RAMP-CE card</td>
<td>OPT-RAMP-CE is an enhanced version of the OPT-RAMP-C card, optimized for shorter spans (18 dB to 20 dB) and higher number of channels.</td>
</tr>
<tr>
<td></td>
<td>The OPT-RAMP-CE design is identical to that of OPT-RAMP-C, with the exception of the embedded erbium-doped fiber amplifier (EDFA). For the embedded EDFA, the optimum gain has been moved from 14 dB to 11 dB and its maximum power from 17 dBm to 20 dBm.</td>
</tr>
<tr>
<td>Regeneration in ROADM demand</td>
<td>CTP supports regeneration in ROADM demands.</td>
</tr>
<tr>
<td>Single Module ROADM (SMR)</td>
<td>There are two versions of the SMR card: 40-SMR1-C and 40-SMR2-C.</td>
</tr>
<tr>
<td></td>
<td>• SMR-1—Single Module ROADM for line and terminal sites. It integrates the preamplifier, OSC splitter/combiner, and a 2x1 wavelength cross connect.</td>
</tr>
<tr>
<td></td>
<td>• SMR-2—Single Module ROADM for line, terminal, and multidegree sites (up to a maximum of 4 degrees). It integrates the preamplifier, booster, OSC splitter/combiner, and a 4x1 wavelength cross connect.</td>
</tr>
<tr>
<td>Site Functional View</td>
<td>Allows you to view the graphical display of all the internal connections of cards, circuits, patchcords, and passive units (for example, DCU units, and Patch Panels).</td>
</tr>
<tr>
<td>Support for ONS-XC-10G-C XFP</td>
<td>Cisco Transport Planner supports the ONS-XC-10G-C XFP card.</td>
</tr>
<tr>
<td>Support for OC-192/STM-64 client on of ADM-10G card</td>
<td>Supports OC-192/STM-64 client on port 17 of the ADM-10G card as client port in TDM aggregated demands, when the card is in the single card mode.</td>
</tr>
</tbody>
</table>
1.1.2 Network Design Process

To generate a network design, the SE enters the following parameters:

- The topology of the network—ring, linear, or meshed
- The type of equipment used at each site
- The distance separating the sites
- The type of fiber connecting the sites
- Service demands, including the service type, the protection type, and the number of channels between nodes
- The number of network sites

When the network parameters are entered, Cisco Transport Planner finds the best routing, defines the required add/drop filters, places optical amplifiers with dispersion compensation units (DCUs) or tunable dispersion compensation units (TDCUs) to fit the user traffic demands at a minimum cost. The TDCU operates only over the C-band. Optimization is performed to meet the boundary conditions. The optimization includes attenuation and amplification.

Finally, Cisco Transport Planner generates a BOM, which includes the product codes, the quantities, and pricing information. In addition, it creates other reports, such as a shelf-level view of the configuration, which can be printed. This information helps the SE understand how the shelf is built and helps to avoid confusion and errors during the actual deployment. Within the BOM is the total network cost, which allows a quick comparison of various design options. The total network cost is the cost of the equipment for all of the sites in the designed network.
1.1.2.1 Network Design Constraints

Cisco Transport Planner searches for the best solution to a designed network using an optimization algorithm.

A network design must meet the optical budget and receiver overload criteria to operate efficiently. An analysis of the optical budget and receiver overload evaluates the strength of the signal traversing the ring. If a design solution satisfies the constraints, it is a valid design. The Cisco Transport Planner optimization algorithms generate multiple solutions and verifies the constraints against those solutions. If the constraints are satisfied, the solution with the lowest cost-to-utilization ratio is selected as the optimal solution.

If the network design solution fails to satisfy all the constraints, Cisco Transport Planner makes adjustments to parameters such as signal attenuation and amplification. Amplification is achieved using an erbium-doped fiber amplifier (EDFA). Attenuation is achieved using the variable optical attenuator (VOA) modules integrated into the platform. Cisco Transport Planner corrects the optical budget using an algorithm that includes automatic placement of EDFAs and VOA regulation.

For each internodal demand, Cisco Transport Planner performs an optical budget and receiver overload analysis and displays the results in various reports in the Graphical User Interface (GUI). If the network design algorithms are not able to provide a solution, then you can modify the input data (for example, by relaxing some user constraints) and run the analysis again.

1.1.2.2 Platform Support

Cisco Transport Planner Software R9.1 supports the Cisco ONS 15454 DWDM optical platform Software Releases 7.0, 8.0, 8.5, 9.0, and 9.1.

1.1.2.3 Topology Support

Cisco Transport Planner supports the following network topologies:

- Bus (single span, point-to-point, and linear)
- Open (or hubbed) ring
- Closed (or meshed) ring
- Any-to-any ring (ROADM)
- Meshed network

Cisco Transport Planner allows you to design flexible networks with up to 100 site locations. A flexible network is a network that uses ROADM nodes to allow traffic modification/reconfiguration as traffic requirements change.

For Cisco Transport Planner Software R9.1, the maximum number of locations where the optical service channel (OSC) is terminated is 40. The maximum number of add/drop locations is 40.

1.1.2.4 Protection Scheme Support

Cisco Transport Planner designs support the following protection schemes:

- Y-cable protected—In Y-cable protection, one transponder card is designated as active and the other as standby. The standby transponder card has the client-side laser turned off to avoid corrupting the signal transmitted back to the client. The active transponder monitors the signal from the trunk side and in the event of loss or signal failure, the system switches to the standby path.
• Client-based 1+1—Two client signals are transmitted to separated line cards or transponder cards instead of using a Y-cable to split one client signal into two line cards or transponder cards. In client 1+1 protection, the failure and switchover is controlled by the client system.
• Fiber-switched protection—The single client signal is injected into the client receive (Rx) port. It is then split into two separate signals on the two trunk transmit (Tx) ports. The two signals are transmitted over diverse paths. The far-end card chooses one of the two trunk Rx port signals and injects it into the Tx client port.
• PSM-OCH—Channel protection configuration provides protection at trunk level (like Fiber-Switched protection) for TXP/MXP that do not have dedicated Fiber-Switched cards. PSM splits the traffic originated by transponder trunk on working and protected TX ports. Working Tx (W-Tx) and protected TX (P-Tx) are connected to the add ports of Add-Drop stages adding the channel in two different directions. On the receiving direction PSM W-RX and P-RX are connected to the drop ports of Add-Drop stages receiving the channel from the two different directions. PSM switch selects a path among W-Rx and P-Rx ports so that only one direction at a time is connected to COM-RX ports and therefore to the TXP/MXP.
• Unprotected—Protection is not used.
• External card switch—Protection not used.

1.1.2.5 Service Support

Cisco Transport Planner can support any subset of the following services:
• Alien (third-party DWDM interface)
• Cisco ONS 15530 2.5 Gbps Aggregated
• ONS 15530 10 Gbps Aggregated
• ONS 15530 Multirate (MR) Transport
• ONS 15530 Data Multiplexer (MXP)
• 2R Any Rate
• Gigabit Ethernet
• 10GE—10 Gigabit Ethernet (LAN and WAN)
• D1 Video
• DVB-ASI—Digital Video Broadcast-Asynchronous Serial Interface
• DV-6000
• DPSK—Different Phase Shift Keying
• ESCON—Enterprise System Connection
• Fast Ethernet
• Fiber Channel 1G
• Fiber Channel 2G
• Fiber Channel 4G
• Fiber Channel 10G
• FICON—Fiber Connection 1G
• FICON Express 2G
• FICON 4G
Overview

- High Definition Television (HDTV)
- ISC-3 Peer (1G)
- ISC-3 Peer (2G)
- ISC-3 Peer (2R)
- ISC-Compat (ISC-3 Compatibility mode)
- LAN-WAN Conversion
- OC-3
- OC-12
- OC-48
- OC-192
- OC-768
- OTU2
- Quadrature Phase Shift Keying (QPSK)
- SDI—Serial Data Input
- STM-1
- STM-4
- STM-16
- STM-64
- STM-256
- Sysplex CLO—control link oscillator
- Sysplex ETR—external throughput rate

**Note**
The Sysplex CLO and Sysplex ETR services are supported only on the following topologies:

- Single span—Two terminal sites with 32MUX-O and 32DMX-O cards, 40MUX-O and 40DMX-O cards, 40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed and no intermediate sites in between.

- Point-to-Point—Two terminal sites with 32MUX-O and 32DMX-O cards. 40MUX-O and 40DMX-O cards, 40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed. Line amplifiers can be installed between the terminal sites, but intermediate (traffic terminating) sites cannot be installed.

- Two hubs—Two hub nodes in a ring with 32MUX-O, 32DMX-O, 32WSS, 40MUX-O, 40DMX, 40DMX-O, 40WSS, and 32DMX cards or 32DMX-O cards installed. Line amplifiers can be installed between the hubs.

Refer to the *Cisco ONS 15454 DWDM Reference Manual* for more information about the supported topologies for the ETR and CLO services.

### 1.1.3 Cisco Transport Planner Process Flow

The following stages are used to complete a network design. See Figure 1-1 for the process flow.
1. Create a project using the Project Creation wizard.
2. Create a network using the Create Network wizard. The Create Network wizards adds sites and places the fiber spans between the sites. A span represents a pair of fibers.
3. Create a point-to-point, AggregatedEthernet, TDM Aggregated, protected ring (P-ring), and/or ROADM service demand.
4. Analyze the network design.
5. If you would like to force automatic tool choices, adjust the design and repeat the analysis until you have reached the desired configuration.
6. Create an Install copy of the network and update the parameters with real data from the field.
7. Analyze the Install network.
8. Create an upgrade copy of the network, as needed, to add forecasted channels.

Figure 1-1  Cisco Transport Planner Process Flow
Chapter 1      Introduction

1.1.4 Planning Traffic in Cisco Transport Planner

Traffic in Cisco Transport Planner is defined as an optical path for each pair of nodes requiring a service demand. An optical path is the combined channels between the two nodes. The following list gives definitions for some basic traffic items:

- **Circuit**—A single channel between a pair of source and destination nodes. In addition to the source and destination nodes and all the attributes that are common to the service containing the circuit, a circuit has the following attributes:
  - Present/forecast indication
  - Routing direction for unprotected service
  - ITU channel
  - Optical bypass indication

- **Demand**—A set of circuits with common characteristics, such as:
  - Service demand label
  - Number of existing circuits
  - Number of forecasted circuits
  - Client service type
  - Protection type
  - Optical bypass (number of channels and/or sites)
  - WDM interface type (TXT or ITU-LC)
  - WDM card type
  - Source client interface (SR, IR, or LR)
  - Destination client interface (SR, IR, or LR)

- **Traffic demand**—All traffic between the same set of nodes. Both L-band and C-band are supported. The following traffic demands are supported: P-ring, Fixed (point-to-point), and Any-to-any (ROADM).
  - In P-ring traffic demands, all the demands are used to support traffic topologies similar to bidirectional line switched rings (BLSRs) or multiplex section-shared protection rings (MS-SPRings). Each P-ring demand is between a pair of added/dropped nodes where BLSR-like (or MS-SPRing-like) traffic must exist. The number of circuits is the same for each demand, and is user-specified (from 1 to 40).
  - In fixed (point-to-point) traffic demands, the set of nodes is restricted to two sites. The number of circuits is user-specified (from 1 to 40).
  - In any-to-any (ROADM) traffic demands, a minimum of two nodes and a maximum of 40 ROADM nodes are supported. The any-to-any traffic demand allows each node to establish one or more circuits with the other nodes, either as a hub or meshed configuration. In a meshed configuration, each node defined in the set is connected to each of the nodes. This is the most common traffic type. In a hub configuration, the user-defined hub node is connected to each of the other nodes. ROADM circuits have the same protection types and services. The number of circuits is not user-specified and can vary from 0 to 40.

---

**Note**

In any-to-any (ROADM) traffic demand, the default routing strategy is Unprotected minimum hop count.
A ROADM demand can have multiple client service types and support multiple DWDM card interfaces for each client service type. A ROADM demand supports the following routing strategies:

- Protected (Default)—Each node pair in the traffic demand is connected using two connections.
- Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected optimum optical path minimizes the number of required optical amplifiers, but also restricts the number of channels that can be deployed among the nodes of the traffic demand (maximum of 40 channels between each node pair) in the installed network.
- Unprotected minimum hop count—Each node pair in the traffic demand is connected by one connection. The unprotected minimum hop count maximizes the number of channels (for unprotected traffic types only) that can be deployed among the nodes of the traffic demand, but requires a higher number of optical amplifiers on the unprotected optimum optical path (maximum of 40 channels between each node pair) in the installed network.
- Unprotected subnet—Each node pair in the traffic demand is connected using one connection. You can manually force connections on only one branch of the ring. For unprotected subnets, you must manually select one starting node of the branch and the direction the ring must be traversed to define the subnet, starting from the initial site. The branch direction is specified by defining the outgoing side first, referred to as the starting node. This routing strategy option allows you to exclude some critical paths and (with ROADM traffic demands containing two sites) to force each ROADM connection clockwise or counterclockwise.

1.1.5 Cisco Transport Planner Traffic in the Project Explorer Pane

Cisco Transport Planner represents all of the user-defined traffic services as a tree view within the Project Explorer pane. The Project Explorer shows all of the open project information, including the networks, the network dependencies, sites, fibers, services, and so on. (Figure 1-2).
Figure 1-2  Project Explorer View

After you analyze a network design, the colors of tree view change according to the error/warning condition of the network design. The icons display as red if there are errors in the network design; orange if there are warnings but no errors; and green if there are no warnings or errors. The icon shows the color of the most severe condition. For more information about analyzing the network, see the “2.9 Analyzing the Network” section on page 2-49.

Right-clicking on certain items in the Project Explorer tree allows you to edit the parameters.

1.1.5.1 Point-to-Point Traffic Demands

Point-to-point traffic demands appear in the Service Demands > PointToPoint folder in the Project Explorer pane. Each point-to-point traffic demand is categorized by its source and destination site names. All of the point-to-point services between the two sites appear under the designated demand name (Figure 1-3).

Figure 1-3  Point-to-Point Traffic Demand in the Project Explorer

A point-to-point traffic demand includes the following information:

- Client service type
- Site# – Site# (source and destination site labels for this demand)
1.1.5.2 P-Ring Traffic Demands

Each protected ring (P-ring) traffic demand appears in the Project Explorer pane under the Service Demands > P-Rings folder. Figure 1-4 shows an example of a P-ring traffic demand in the Project Explorer.

Figure 1-4 P-Ring Traffic Demand in the Project Explorer

All the P-ring channels between each site pair are listed under each P-ring traffic demand. Each demand is labeled with the following information:

- P-ring number
- Client service type
- Site# – Site# (source and destination site labels for this demand)

1.1.5.3 ROADM Traffic Demands

Each ROADM traffic demand appears in the Project Explorer under the Service Demands > ROADMs folder. The ROADM folder contains each defined ROADM demand. You can define more demands for the same ROADM for the same set of nodes. Figure 1-5 shows an example of a ROADM traffic demand.

Figure 1-5 ROADM Traffic Demand in the Project Explorer

In the Project Explorer, each ROADM includes the ROADM demand name and a list of DWDM card types that support the client service types. Protection types appear in parentheses.

1.1.5.4 Aggregated Ethernet Demand

Each aggregated ethernet traffic demand appears in the Project Explorer under the Service Demands > Aggregated Ethernet folder. The Aggregated Ethernet folder contains each defined aggregated ethernet demand. Aggregated Ethernet demands are supported on ring and linear traffic subnets. Figure 1-6 shows an example of an aggregated ethernet traffic demand.
1.1.5.5 TDM Aggregated Demand

Each TDM aggregated demand appears in the Project Explorer pane under the Service Demands > Aggregated TDMs folder. Figure 1-7 shows an example of a TDM aggregated traffic demand in the Project Explorer.

TDM aggregated demands are supported only on a ring traffic subnet.

1.1.6 Auto, Forced, and Locked Parameters

Parameters in CTP can be in one of three states:

- **Auto**—This parameter allows the highest degree of flexibility to CTP in designing a network. When you select Auto, CTP chooses the parameter value during network analysis.

- **Forced**—When you set a specific parameter value, other than Auto, CTP designs the network using these constraints. When a setting is forced, the item appears in blue italics in the Project Explorer pane.

- **Locked**—The state of a parameter after network analysis. The next time the analyzer is run, Cisco Transport Planner cannot change the value when it is in the Locked state. You can unlock an item using the Unlock command. For more information, see the “2.10.4 Unlocking Parameters in the Network Design” section on page 2-54 and “2.10.4.1 Forcing Manager” section on page 2-55. Figure 1-8 shows an example of sites in a locked state.
1.2 Installing Cisco Transport Planner

Use the following procedure to install Cisco Transport Planner:

**Step 1** To download the installer, go to the Cisco software download site.

**Step 2** Navigate to the location where you want to save the CTP.exe file to a local hard drive.

**Step 3** Click **Save**.

**Step 4** To start the installation of CTP:

- **Windows**—Navigate to the directory containing the CTP.exe file and double-click it.
- **Linux**—Assuming the CTP.bin file is accessible from the current shell path, navigate to the directory containing the CTP.bin file and type:

  ```
  % ./CTP.bin
  ```

The graphical CTP installation wizard appears.

**Step 5** Click **Next**. The license agreement is displayed.

**Step 6** To accept the license, click the I accept the terms of the License Agreement option.

**Step 7** Click **Next**.

**Step 8** Specify the installation directory. On Windows, the default is C:\Program Files\Cisco\CTP-R9.1.0.

To choose a different directory, click the **Choose...** button and browse to the required directory. To restore the default path, click the **Restore Default Folder** button.

**Step 9** Click **Next**.

**Step 10** Specify the shortcut folder by choosing any one of the following options:

- In a new Program Group: Specify a new folder. The default is CTP.
- In an existing Program Group: Select a folder from the list of existing folders. The default is CTP. This option is the default if you installed CTP earlier.
- In the Start Menu
- On the Desktop
- In the Quick Launch Bar
- Other: Use this option to specify a commonly used folder.
- Don't create icons: Choose this option if you do not want to create a shortcut.

Depending on the initial state, the network analyzer will:

- Move the parameter into the Locked state if the unit or parameter was set to Auto.
- Leave the parameter in the same state if the user forced a specific value for the unit or parameter.
1.3 Uninstalling Cisco Transport Planner

Use the following procedure to uninstall Cisco Transport Planner:

**Step 1** Click the CTP Uninstaller icon in the Start > All Programs > CTP menu.

The graphical Uninstall CTP wizard appears.

**Step 2** Click **Uninstall**.

**Step 3** A progress bar displays the uninstallation status. Click **Cancel** at any time to stop the uninstallation.

When the uninstallation process is complete, a screen displays the files that could not be uninstalled.

**Step 4** Click **Done** to exit the uninstallation wizard.

1.4 Launching Cisco Transport Planner

Before you start Cisco Transport Planner, you need to save the user profiles provided to you by Cisco Systems to the profiles directory. Access to Cisco Transport Planner features depends on the user profile you select when you start Cisco Transport Planner. The default profile is Base Network Designer.

Use the following procedure to launch Cisco Transport Planner:

**Step 1** Launch Cisco Transport Planner using any of the following options:

- Click the CTP icon in the Start > All Programs > CTP menu.
- Double-click the CTP icon in the quick launch bar.
- Double-click the CTP icon on the desktop.
- Browse to the installation directory and double-click the ctp.jar file.

The Cisco Transport Planner login dialog box appears (Figure 1-9).
Step 2  Select the user profile from the drop-down list.

Step 3  Click **Continue** to open Cisco Transport Planner.

The login profile type appears in the lower-right corner of the Cisco Transport Planner window.

### 1.4.1 Opening a Project

Use the following procedure to open an existing Cisco Transport Planner project. To create a new project, see the “2.1 Creating a Project” section on page 2-1.

**Step 1**  Click the project name under Open in the Tasks Pane (**Figure 1-10**). The project opens. If you do not see the project name listed, continue with **Step 2**.

**Step 2**  Click **Open** under Project in the Tasks Pane or in the File menu.
Step 3  
In the Open Project dialog box, navigate to the desired directory and choose the project. Click Open. The Cisco Transport Planner project appears.

Note  
You cannot open an existing CTP project in multiple CTP instances. The saved project (.MPZ file) is locked for the use of that CTP. If you try to open the project in another instance of CTP, an error message is displayed. The .MPZ project file is unlocked and released only after you close the Network.

1.4.2 Loading and Unloading Networks

Each network in a project requires memory. To save memory, when Cisco Transport Planner opens a project, all networks are in the Unloaded state. An unloaded network appears in the Project Explorer with a “U” next to the network identifier (Figure 1-11). To load an unloaded network, double-click on the network folder in the Project Explorer, or right-click the network and choose Load from the shortcut menu.

Figure 1-11 Unloaded Network in the Project Explorer
A loaded network appears in the Project Explorer with an “L” next to the network identifier (Figure 1-12). To unload a loaded network, right-click the network icon in the Project Explorer and choose Unload from the shortcut menu.

Note
When you load a network containing an alien interface that is not present in the parts database (DB), warning messages are displayed.

Figure 1-12  Loaded Network in the Project Explorer

1.4.3 Saving a Project

Use the following procedure to save a project:

Step 1  Choose one of the following:
- To save an existing project with the same filename, choose File > Save. You have completed this procedure.
- To save a new project, choose File > Save and go to Step 2.
- To save an existing project with a different filename, choose File > Save As and go to Step 2.

Step 2  In the Save Project dialog box, navigate to the desired directory and type the filename. Click Save. Cisco Transport Planner saves projects as zipped files with the MPZ extension.

1.4.4 Closing a Project

Use the following procedure to close a Cisco Transport Planner project:

Step 1  From the File menu, choose Close.
Step 2  In the Save Project dialog box, click Yes to save or No to close without saving changes.
Step 3  If you clicked Yes and have not previously saved the project, the Save Project dialog box appears. Enter the name of the project and click Save. The project closes.
Step 4  To exit Cisco Transport Planner, choose Exit from the File menu.

1.5 Setting Cisco Transport Planner Options

Cisco Transport Planner provides numerous options for customizing the tool and the design.
The following procedures for setting options using the Tools menu apply to new projects during project creation. To change an existing (open) project, click the desired item in the Project Explorer pane Subnets folder and edit the parameter in the Properties pane.

1.5.1 Setting the Graphical Display

Use the following procedure to set the Cisco Transport Planner graphical display:

Step 1 From the Tools menu, choose **Options**.

Step 2 In the Options Explorer dialog box, right-click the Graphic folder and choose **Expand** from the shortcut menu.

Step 3 Click **Chart Panel** and complete the following:

- In the Colors area, to change the colors of Border Paint, Background Paint, Line Paint, Plot Background Paint, and Plot Outline Paint, click in the relevant fields in the Colors list, and click the drop-down arrow to display a color swatch popup window. Then, click the desired color.

- In the Strokes area, to change the strokes of Border Stroke, Outline Stroke, and Default Line Stroke, click in the relevant fields in the Strokes list, and click the drop-down arrow. Then click the desired stroke.

- In the Font area, click the Font drop-down box to display a font popup window. Then select the desired Font, Size and Style.

- In the Alfa area, enter numeric values for Background Alfa and Foreground Alfa.

- In the Shapes area, click the Line Shape drop-down box. Then click the desired line shape.

- In the Gridlines area, check the Range Gridlines and Domain Gridlines check boxes to view the gridlines for the same.

Step 4 To change the color scheme for Cisco Transport Planner, click **Look & Feel** and choose the desired scheme from the drop-down list.

Step 5 To change the appearance of the Project Explorer tree, click **Project Explorer** and complete the following tasks as needed:

- Overlapping—Check to reorder sites for a selected network.

- Alarm Mode—Choose **Single** for an alarm icon to report only the condition of that item or choose **Cumulated** for an alarm icon to summarize the most critical alarm of the item and its children.

- Bottom Right Icon—(Display only) Displays Locking to indicate that the lock icon appears at the bottom right of each locked item in the Project Explorer.

- Top Right Icon—(Display only) Displays Alarm to indicate that the alarm icon appears at the top right of each alarmed item in the Project Explorer. The alarm icon will be green, yellow, orange, or red to indicate the alarm severity.

Step 6 To change the NtView Name tab appearance, click **Network View** and complete the following tasks as needed:

- In the Site area, complete the following tasks:

  - Site Color—To set the default site color when no forcing is done, click the drop-down arrow to display a color swatch popup window. Click the desired color.
Setting Cisco Transport Planner Options

– Site Selection Color, and Highlight Color—To change the site colors, click in the Color, Selection Color, and/or Highlight Color fields in the Site list. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

– Show Name—Check to display the site name on the NtView Name tab.

– Pass Through, OSC, Add/Drop, Hub, Gain equalizer, R-OADM, Line Amplifier, OXC, OIC, Background Amplified Color, Background Raman Amplified Span Color—To change the colors, click in the relevant fields in the Site list. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

– Show Amplifiers—Check to display the amplifier icon for a site on the NtView Name tab.

– Show Raman Amplified Span—Check to display the Raman amplified span on the NtView Name tab.

• In the Fiber area, complete the following tasks, as needed.

– True wave Reach Color, Dispersion Shifted Color, Metro Core Color, true wave, True Wave Plus Color, True Wave Minus Color, True wave Classic Color, Free Light Color, LS Color, Tera Light Color, E LEAF Color, TRUE WAVE RS Color, G 652 SMF Color, and Selection Color—To change the fiber color, click in the relevant fields in the Fiber list and then click the drop-down arrow.

– Show Name—Check to display the fiber name on the NtView Name tab.

– Show Length—Check to display the fiber length on the NtView Name tab.

– Show total SOL Loss—Check to display start of life (SOL) loss on the NtView Name tab.

– Show total EOL Loss—Check to display end of life (EOL) loss on the NtView Name tab.

– Show CD C-band—Check to display C-band chromatic dispersion (CD) on the NtView Name tab.

– Show CD L-band—Check to display L-band chromatic dispersion (CD) on the NtView Name tab.

• To change the color of the traffic demands on the NtView Name tab, in the Point To Point, P-Ring, and Any To Any areas, click in the Color and Selection Color fields, and then click on the drop-down arrow to display a color swatch popup window. Click the desired color.

Figure 1-13 Duct Details Shown on the NtView Name Tab

Step 7 To change the Network Mgmt Tree tab appearance, complete the following tasks as needed:

• In the Network area, click in the Color and Selection fields. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

• In the Link area, complete the following tasks:

  – To change the link color, click the Color field in the Link list and then click the drop-down arrow. Choose the desired line width from the drop-down list.

  – To change the link appearance, click the Stroke field in the Link list and then click the drop-down arrow. Choose the desired line appearance from the drop-down list.

Step 8 To change the layout appearance, click Layout View and complete the following tasks as needed:
• In the General area, click in the Background and Selection Color fields. Click the drop-down arrow to display a color swatch popup window. Click the desired color.

• In the Any/Present View area, complete the following tasks:
  – To change the color for Foreground, Locked & Unlocked View, Locked Elements Background, and Locked Elements Foreground, click the relevant field and click the drop-down arrow to display a color swatch popup window. Click the desired color.

• In the Alarmed View area, complete the following tasks:
  – To change the color for Unalarmed Elements Background, Unalarmed Elements Foreground, and Alarmed Elements, click the relevant field and click the drop-down arrow to display a color swatch popup window. Click the desired color.

**Step 9** Click **Ok**.

### 1.5.2 Setting the Default Software Release

Use the following procedure to set the default software release for CTP. This release will be used as the default software release when creating a project. See the section 2.1 Creating a Project, page 2-1.

**Step 1** From the Tools menu, choose Options.

**Step 2** In the Options Explorer dialog box click **General**.

**Step 3** In the column on the right, click the Default CTP Software Release option. A drop-down list appears.

**Step 4** Click an option in the list to choose the desired software release. See Figure 1-14.
1.5.3 Setting the Default Platform Values

Use the following procedure to establish the default traffic mapping, dense wavelength division multiplexing (DWDM) design, and default layout settings for a particular platform and system release. The default settings will appear during project creation. All the options that you specify can be changed after project creation on a per-span basis.

Step 1 From the Tools menu, choose Options.
Step 2 In the Options Explorer dialog box (Figure 1-14), right-click Platform and choose Expand from the shortcut menu.
Step 3 Click the desired System Release folder and complete the following tasks as needed:

Note Default changes apply only to the specified system release.

- For Software Release 9.0 and 9.1, choose the desired settings in the General area:
  
  - **Shelf Management**—The options available are Auto, Multi Shelf Integrated Switch, Multi Shelf External Switch, and Individual Shelf. These options allow you to specify the type of management to be used for the sites on the network. Select Auto to set the default option of Multi Shelf Integrated Switch for all the nodes with more than one shelf.
Select **Multi Shelf Integrated Switch** to configure all the Multiservice Transport Platform (MSTP) optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches plugged into the MSTP shelves.

Select **Multi Shelf External Switch** to configure all the MSTP optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches external to the MSTP shelves.

Select **Individual Shelf** to configure all the MSTP optical units (OADMs and amplifiers) in the same shelf.

---

**Note**

Shelf management is disabled for HYBRID 15454 ONS configuration.

---

**Node Protection**—The options available are Same Shelf, Separated Shelves, and Node Split.

Select **Same Shelf** to configure the optical units (amplifiers and OADM) on side A (CW direction) and side B (CCW direction) in the same shelf.

---

**Note**

Node protection is disabled for HYBRID 15454 ONS configuration.

---

Select **Separated Shelves** to configure the optical units (amplifiers and OADM) on side A (CW direction) in one shelf and those on side B (CCW direction) in a second shelf.

Select **Node Split** to configure the optical units (amplifiers and OADM) in two separate shelves belonging to two separate sites. The two sites are adjacent and are connected with a single fiber span without amplification. You can deploy the add/drop equipments (WSS or OADM) and amplifiers only on the external side and deploy the OSC-CSM unit (without amplification) only on the internal side. The two sites are considered as two different NEs with their own management options, that is, site management can be Individual shelf or Multi Shelf, but in the latter case subtended shelves belong only to one single NE site.

---

**Note**

The Node split feature is supported under the following conditions:

- Available only on nodes with the structure as line and the functionality as ROADM or OADM.
- Available for all Operations Support Network (OSN) with all design rules, provided that there is proper consistency between the OSN and equipment.
- Can terminate only fixed traffic unprotected, client 1+1 protected, or P-Ring traffic, while traffic with protection Y-Cable, FiberSW, or PSM-OCH are not allowed.
- Not allowed for aggregated demand, both TDM and Ethernet.
- Cannot be used for a bypass node of any traffic type.

---

**C-band Rules**—Select the options from the drop-down list. The options appear in the following format: C 64 Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and 8 dBm; and the spacing options available are 100 GHz and 50 GHz. You can use even wavelengths for 80, 72, and 64 channel design.

For HYBRID 15454 ONS configuration, the available options are 8, 16, 20, 32, and 40 channels.

---

**L-band Rules**—Select the options from the drop-down list. The options appear in the following format: 32 Ch. 100 Ghz +5 dBm. The options available are: None, Expand, and channels available are 32; the reference per channel power options available are 2 dBm and 5 dBm; and the only spacing options available is 100 GHz.

Select **Expand** to indicate that the L-band rules are upgradable.
Note

L-Band is not applicable to HYBRID 15454 ONS configuration.

- **Installation w/o CTP**—Check this box to install the network with default parameters. If you choose this option, CTP designs the network according to a set of predefined conditions, so that the selected node can be installed without the Cisco Transport Planner configuration files (thresholds and setpoints).

- **Dithering Lower Limit**—Enter a value that satisfies the following conditions:
  - Not lower than zero
  - Not higher than 32
  - Not higher than the dithering upper-limit value

  The dithering value is the site identifier that CTP uses to adjust power on 40-WXC cards. Dithering value is provided only for sites with 40-WXC cards, that is, for sites with multidegree site structure and with the functionality “OXC” or “Auto”. This parameter is not displayed for non-OXC sites.

- **Dithering Upper Limit**—Enter a value that is not lower than zero and not higher than 32.

- For adding Alien Shelves to the network, enter the required values in the Layout area:
  - **Alien Shelf Name**—Enter the name of the alien shelves that are added to the site. This name will be displayed in the Layout reports.
  - **Number of Alien Shelves**—Enter the number of alien shelves that are to be added to the site.
    
    Number of alien shelves can vary based on the alien shelf height. Maximum number of alien shelves that can be added is 600, if the alien shelf height is 1 Rack Unit (RU) and there are no other shelves in the layout.
    
    The maximum number of racks supported for a site is 15. If the addition of alien shelves require more than 15 racks, an error message will be displayed in the summary report and the layout is not built for the site.
  - **Alien Shelf Height**—Enter the height of the alien shelves in RU. If the alien shelf height is greater than the rack height, alien shelves will not be added to the site, and an error message will be displayed in the summary report.

The above values are applicable to all the sites in the newly created network. Values can be modified for individual sites after the network creation.

- For software release 8.5, choose the desired settings in the General area:
  - **Shelf Management**—The options available are Multi Shelf Integrated Switch, Multi Shelf External Switch, and Individual Shelf. These options allow you to specify the type of management to be used for the sites on the network.
    
    Select **Multi Shelf Integrated Switch** to configure all the Multi-Service Transport Platform (MSTP) optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches plugged into the MSTP shelves.
    
    Select **Multi Shelf External Switch** to configure all the MSTP optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches external to the MSTP shelves.
    
    Select **Individual Shelf** to configure all the MSTP optical units (OADMs and amplifiers) in the same shelf.
Chapter 1      Introduction

Setting Cisco Transport Planner Options

- **Node Protection**—The options available are Same Shelf and Separated Shelves.
  Select **Same Shelf** to configure the optical units (amplifiers and OADM) on side A (CW direction) and side B (CCW direction) in the same shelf.
  Select **Separated Shelves** to configure the optical units (amplifiers and OADM) on side A (CW direction) in one shelf and those on side B (CCW direction) in a second shelf.

- **C-band Rules**—Select the options from the drop-down list. The options appear in the following format: C 64Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and 8 dBm; and the spacing options available are 100GHz or 50 GHz.

- **L-band Rules**—Select the options from the drop-down list. The options appear in the following format: 32 Ch. 100Ghz +5 dBm. The options available are: None, Expand, and channels available are 32; the reference per channel power options available are 2 dBm and 5 dBm; and the only spacing options available is 100GHz.

Select **Expand** to indicate that the L-band rules are upgradable.

- **Installation w/o CTP**—Check this box to install the network with default parameters. If you choose this option CTP designs the network according to a set of predefined conditions, so that the selected node can be installed without the CTP configuration files (thresholds and setpoints).

- **Dithering Lower Limit**—Enter a value that satisfies the following conditions:
  - Not lower than zero
  - Not higher than 32
  - Not higher than the dithering upper-limit value

  The dithering value is the site identifier used by CTP to adjust power on 40-WXC cards.
  Dithering value is provided only for sites with 40-WXC cards, that is, for sites with multidegree site structure and with the functionality “OXC” or “Auto”. This parameter is not displayed for non-OXC sites.

- **Dithering Upper Limit**—Enter a value that is not lower from zero and not higher to 32.

  - For software release 7.0, choose the desired settings in the General area:
    - **C-Band or L-Band** as the default band.
    - **Scalable C/L**—(System Release 7.0 only) Check to set scalable C bands and L bands as the default setting during project creation. If checked, the design will be scalable to support both C-band and L-band on the same system.
    - **Scalable C/50 GHz**—(System Release 7.0 only) Check to set scalable C-band 50 GHz as the default setting during project creation. If checked, the design will be scalable to support 50-Ghz channel spacing in C-band.

- **Shelf Management**—The options available are Multi Shelf Integrated Switch, Multi Shelf External Switch, and Individual Shelf. These options allow you to specify the management to be used for the sites of the network.

  Select **Multi Shelf Integrated Switch** to configure all the MSTP optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches plugged into the MSTP shelves.
  Select **Multi Shelf External Switch** to configure all the MSTP optical units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented with switches external to the MSTP shelves.
  Select **Individual Shelf** to configure all the MSTP optical units (OADMs and amplifiers) in the same shelf.
– **Node Protection**—The options available are Same Shelf and Separated Shelves. Select **Same Shelf** to configure the optical units (amplifiers and OADM) facing the east side (CW direction) and west side (CCW direction) in the same shelf. Select **Separated Shelves** to configure the optical units (amplifiers and OADM) facing the east side (CW direction) in one shelf and those facing the west side (CCW direction) in a second shelf.

**Step 4** Click the **Restricted Equipment** folder. To restrict a card, check the check box in the Restricted column for that card.

To change the setting back to unrestricted, uncheck the check box. To apply restricted list changes to an open project, complete the following:

a. Right-click the folder for the network that you want to update and choose **Expand** from the shortcut menu.

b. Right-click the desired platform and release folder under **RestrictedEqptListFolder** in the Project Explorer and choose **Edit List** from the shortcut menu. The Restricted Equipment list for MSTP 454 DWDM[Release Number] dialog box appears.

c. Click **Update**. The modified Restricted Equipment List is replaced with the global restricted equipment List.

d. Click **OK** to close the dialog box.

**Step 5** Enter the **Fiber Options** details.

- **Span Label Tag**—Enter the desired span label; the default label is Duct.
- **Span Length**—Enter the span length. The displayed unit of measure is retrieved from the Span Measurements Units field.
- **EOL Ageing loss [dB]**—Enter the EOL aging loss value. The EOL loss-per-span value is added at the end of life to each discrete fiber in the network (for example, to add an EOL margin for splicing).
- **EOL Ageing Factor**—Enter the number to use when factoring fiber aging. This factor is multiplied by the SOL total span loss without connectors.

**Note** Enter a value in either EOL Ageing Factor or EOL Ageing loss; you do not need to enter a value in both fields.

- **Connector loss [dB]**—Enter the concentrated loss at the end of the span.
- **Length Based Loss**—If checked, the fiber loss is determined by multiplying the Span Length by the Loss Factor. If the check box is not checked, you must enter the total loss of the span.
- **Tot SOL loss w/o conn [dB]**—Enter the start of life link fiber loss for each span, without the connector concentrated loss. The total SOL loss without connectors is equal to the loss factor multiplied by the length. In the Length Based model, this value is calculated automatically.
- **DCN Extension (With Software R8.0 and later)**—Click the check box to enable the default use of data connection network (DCN) extension on each span in the project. This setting implies that the OSC channel is not used to connect the two nodes. This default can be overridden on the network wizard pane.

**Note** Use one of the following formulas to calculate the fiber loss at SOL:

\[
SOL = \text{km} \times \frac{\text{dB}}{\text{km}} + (2 \times \text{connector loss})
\]

\[
SOL = \text{user entered loss} + (2 \times \text{connector loss})
\]
Use one of the following formulas to calculate the fiber loss at EOL:
\[ EOL = \text{km} \times \frac{\text{dB/km}}{\text{EOL Aging Factor}} + (2 \times \text{connector loss}) + \text{EOL Aging Loss}, \text{ or} \]
\[ EOL = \text{user entered loss} \times \frac{\text{EOL Aging Factor}}{2} + (2 \times \text{connector loss}) + \text{EOL Aging Loss} \]

- Select the **Fiber Type** of each span of the network. You can specify a fiber type even if the fiber type is not supported for the design.

**Step 6** Click the **Traffic Mapping** folder and complete the following tasks as needed.

- In the Fixed traffic area, choose the unprotected routing strategy from the drop-down list:
  - Auto—CTP automatically selects the minimum number of channels that can be deployed among the nodes of the traffic group.
  - Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected optimum optical path minimizes the number of required optical amplifiers.
  - Unprotected minimum hop count—Each node pair in the traffic group is connected by one connection. The unprotected minimum hop count minimizes the number of channels (for unprotected traffic types only) that can be deployed among the nodes of the traffic group.

- In the General area, choose the algorithm and wavelength options.
  - Force Mesh Algorithm—For CTP Software Release 8.5 and earlier, check this option to force the mesh algorithm.
  - Allow Different Wavelengths—Check to allow different wavelengths to be used for regeneration.

**Step 7** Select the C-band and L-band rules.

- **C-band Rules**—Select the options from the drop-down list. The options appear in the following format: C 64Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and, 8 dBm; and the spacing options available are 100 GHz and 50 GHz.

- For **L-band Rules**—Select the options from the drop-down list. The options appear in the following format: 32 Ch. 100 GHz +5 dBm. The options available are: None, Expand, and channels available are 32; the reference per channel power options available are 2 dBm and 5 dBm; and the spacing option available is 100 GHz.

Select **Expand** to indicate the L-band rules as upgradable.

**Step 8** Click the **DWDM Design Rules** folder and complete the following tasks as needed:

- **OSNR Alarm For Regeneration**—Allows you to define the optical signal-to-noise ratio (OSNR) alarm severity. When this limit is reached, Cisco Transport Planner suggests a channel at an appropriate site on the network. After the network is designed and analyzed, in the Tasks pane (under Reports), click **Optical Results** to see if any site requires regeneration. The regeneration column will suggest the site where Regeneration is required.

- **Run Quick Analysis**—Check to use a quick but less accurate algorithm to analyze the network in a short time. After the analysis, Cisco Transport Planner displays the following warning message: “Dcu design not optimized due to Run Quick Analysis option.”

- **No-Tilt-Network-Design**—Check to force Cisco Transport Planner to operate the amplifiers inside the gain range where no tilt is generated and to determine the type and number of amplifiers in each site of the network accordingly. This option sets all the intermediary points of the network so that channels are always at the reference power level. The default value is Disabled.

---

**Note**
Long spans (with insertion loss greater than 25 dB) might not be supportable.
- No In-line Bulk Attenuator Design—Check to design the network without using any inline bulk attenuators. If the network cannot be designed without using external in-line attenuators, Cisco Transport Planner displays the following error message: “Unfeasible Network design. Site X should require usage of in-line attenuator. Leave unchecked to allow inline bulk attenuators.”

- No TXT/Line-Card Bulk Attenuator Design—Check to design the network without using any external receive (Rx) bulk attenuators on transponder or line cards. If any of the clients require Rx bulk attenuators, the related channel is shown with the working condition (flagged red, orange, or yellow). No Rx bulk attenuator will be shown in any of the reports (such as Optical Channel Results, Internal Connections, or BoM). Leave unchecked to allow bulk attenuators.

- Prevent Use of E-LEAF Dispersion—Check to prevent Cisco Transport Planner from using Extended -Large Effective area fiber (E-LEAF) dispersion compensation units (DCUs) on E-LEAF spans for the overall network. Leave unchecked if you want the algorithm to automatically optimize the usage of the E-LEAF DCUs.

- Max Scalability Placement —CTP allows you to scale up or expand the network made in your network design. You can add new sites and demands depending on your requirements, thus, CTC automatically creates the flexibility of the possible expansion of your network. It also checks to force the CTP to choose an EDFA/DCU placement that is best suited for future expansion of the designed network without any hardware changes.

- TDCU—Cisco Transport Planner allows you to place the TDCU units (TDCU Coarse and TDCU Fine) in the network. Select the options from the drop-down list:
  - Auto—Cisco Transport Planner automatically places the fixed DCU units in the network.
  - All Positions—Cisco Transport Planner places the TDCU units wherever the fixed DCU units can be placed.
  - Never Place—Cisco Transport Planner does not place the TDCU units in the network.
  - Selected Positions—Cisco Transport Planner places the TDCU units in ROADM, WXC, and Dynamic Gain Equalizer (DGE) nodes.

- Turbo Simplex—Check to achieve faster results by optimizing a subset of the total channels based on type and path rather than optimizing every channel. Unchecking this option can result in longer analysis times for large networks, especially with any-to-any ROADM traffic.

- Max Sc Value—Allows you to enter the maximum slope compensation value.

**Step 9** To define the shelf configuration parameters, click the **Layout** folder and complete the following tasks:

- Osmine Compliant—Check to instruct Cisco Transport Planner to ensure that all the sites placing transponder and line cards are compliant with OSMINE.

- Hybrid Node—Check to instruct Cisco Transport Planner to ensure that cross-connect, SDH, and SONET cards are not placed within the optical transport section (OTS) shelf.

- Max Number of Shelves—Allows you to specify the maximum number of shelves per rack. The maximum number of shelves you can specify is 4. Default is Auto.

- AIC—Choose Yes to instruct Cisco Transport Planner to put the AIC card in slot 9 of the first shelf in each site.

- Fiber Storage—Choose Yes to instruct Cisco Transport Planner to put the fiber storage within the rack below the optical shelf.

- Y-Cable—The options available are Auto, 1RU FlexLayer Shelf Assembly, and 2RU Y-Cable Panel.
  - Auto—Instructs Cisco Transport Planner to set the default value for the Y-Cable option.
  - 1RU FlexLayer Shelf Assembly—Instructs Cisco Transport Planner to use the ONS 15216 Splitter/Combiner Flex Layer modules to implement the required Y-cable protections.
– 2RU Y-Cable Panel—Instructs Cisco Transport Planner to use the new ADC Splitter/Combiner modules to implement the required Y-cable protections.

• Fan Tray—(Software R8.0 and later) Instructs Cisco Transport Planner to put the type of fan tray within each node. Options available are FTA3-T and FTA4-T.

• TXP/MXP/XP in OTS—Instructs Cisco Transport Planner to place client cards in OTS shelves. Options available are Auto, Yes, and No. Auto instructs CTP to place client cards in OTS shelves.

• Etsi Rack Width—Allows you to specify the ETSI rack width. Choose 19 inches to add 15454E-19IEC-KIT for each ETSI shelf. Options available are Auto, 19 inches, and 600mm.

• Rack Height in RU—Allows you to specify an integer value for the rack height. Default is Auto. Auto assigns 44 RU for ANSI and 40 RU for ETSI.

• Alien Shelf Height—Enter the height of the alien shelves in RU. If the alien shelf height is greater than the rack height, alien shelves will not be added to the site, and an error message will be displayed in the summary report.

• No of Alien Shelves—Enter the number of alien shelves that are to be added to the site. Number of alien shelves can vary based on the alien shelf height. Maximum number of alien shelves that can be added is 600, if the alien shelf height is 1 Rack Unit (RU) and there are no other shelves in the layout. The maximum number of racks supported for a site is 15. If the addition of alien shelves require more than 15 racks, an error message will be displayed in the summary report and the layout is not built for the site.

• Alien Shelf Name—Enter the name of the alien shelves that are added to the site. This name will be displayed in the Layout reports.

• Extra Shelves—Allows you to specify an integer value for the number of empty shelves to be added to the node layout. Auto does not add any shelves.

• DCC Shelves Management—Check to instruct Cisco Transport Planner to reserve slot 12 for equipping 15454-MR-L1 units to implement data communication channel (DCC) shelf management.

Step 10 Click OK.

1.5.4 Setting the Default Project Values

Use the following procedure to set the default project settings and repair time. These defaults will appear during project creation.

Step 1 From the Tools menu, choose Options.

Step 2 In the Options Explorer dialog box (Figure 1-14 on page 1-23), click Project and complete the following tasks to set the defaults that appear in the Project Creation wizard:

• Customer—Enter the default customer name (128-character maximum).

• Created by—Enter the default user name (128-character maximum).

• Units—Choose the default span length unit of measure from the drop-down list, either Km or Miles.

• Price List—Choose the default price list.

• Layout—Choose either ANSI (American National Standards Institute) or ETSI (European Telecommunications Standards Institute) from the drop-down list.
Step 3  Click **General** and complete the following tasks:

- **MTTR (hours)**—Enter the mean time to repair (MTTR) for all sites in the network. This value will apply to every site in the network. If you change the MTTR value after creating sites, the new value will only apply to sites you create after the change.

- **Restocking Time (days)**—Enter the number of days required (including transportation time) to restock the units into the maintenance center.

- **Confidence Level (%)**—Choose the confidence level for finding the spare units in the maintenance center (50, 75, 95, or 99 percent).

- **Default CTP Software Release**—Choose a release to be set as the default CTP software release. This release will be used as the default release when creating a project. See the section 2.1 *Creating a Project*, page 2-1.

Step 4  Click **BoM** and complete the following:

- **Use Bundles**—(Multishelf configuration only) Check to use the Multishelf Management Integrated Kit bundle when generating the BoM instead of the single items. As a bundle, a common price is quoted, which is lesser than when the items are listed individually.

- **Use Global Discount**—Check to allow you to edit the discount box (Global Discount).

- **Global Discount**—Enter the global discount to be applied to the whole BoM.

- **Include SW License(s)**—This check box is selected by default. The software license for the release is shipped with the Cisco ONS 15454 chassis.

- **Include Paper Documentation**—Check to ship paper documentation separately with the product and listed in BoM.

- **Include CD Documentation**—Check to ship CD documentation separately with the product and listed in BoM.

- **Hide BoM price/discount**—Check to hide the BoM discount and the individual unit price. Only the final price is displayed.

- **Service Level**—Choose the service level from the drop-down list.

- **Service Level Num of Years**—Choose the maintenance service level length (in years) from the drop-down list.

Step 5  Click **OK**.

### 1.5.5 Defining Third-Party DWDM Interfaces

Cisco Transport Planner allows you to define a third-party DWDM interface to be used in project creation. After you define third-party DWDM interfaces, you can choose them when creating traffic demands. For more information on defining third-party interfaces, see Appendix D, “Third-Party DWDM Wavelength Interface Model.”

**Note**

If you create a network design with a third-party interface and need to share the design with other users, you must provide not only the saved network MPZ file but also the exported database file containing the third-party interface definition. To view this project, the other user first must import the database with the third-party interface values.
Use the following procedure to define a third-party DWDM interface:

**Step 1**  Click **Tools > DB Parts Mgmt.** The DB Parts Manager dialog box appears.

| Note | You cannot open the DB Parts Manager if a project is open or if you are using the Base Network Designer profile. |

**Step 2**  Right-click **Platform Parts** and choose **Expand** from the shortcut menu.

**Step 3**  Right-click **Group** and choose **New Group** from the shortcut menu. The new group appears under Group and in each system release under parts DB.

**Step 4**  In the Group Editor dialog box, complete the following information:
- Name of group—Enter the name of the new database.
- Note—(Optional) Enter a description of the group.

**Step 5**  In the parts DB for the desired system release, click the group that you created.

**Step 6**  In the Parts tab of the DB Parts Manager dialog box, right-click and choose **Client** and then **Alien** from the shortcut menu. A new row appears on the Parts tab for the client hardware.

**Step 7**  Double-click the row to open the Alien dialog box (Figure 1-15).

**Figure 1-15 Alien Card Dialog Box**

**Step 8**  In the General tab of the Alien dialog box, type the name of the card in the **Name** field and the enter the **Label** name.

**Step 9**  Click the **Instance** tab and complete the following:
• AnsPi—Enter the product identifier of the ANSI system, as needed. If you select BoM visible for this third-party interface with ANSI PID completed, the third-party interface is included in the BoM with the related product identifier.
• Etsi PID—Enter the product identifier of the ETSI system, as needed. If you select BoM visible for this third-party interface with ETSI PID completed, the third-party interface is included in the BoM with the related product identifier.
• TAG—(Display only) For internal use.
• SYS. NAME ANSI—Not applicable for third-party interfaces.
• SYS. NAME ETSI—Not applicable for third-party interfaces.
• WL START—Choose the wavelength starting range that the third-party interface supports from the drop-down list.
• WL END—Choose the wavelength ending range that the third-party interface supports from the drop-down list.

**Step 10**
Click the **Physical Ports** tab and in the Label column, type a label for each port.

The CTC Ports and TL1 Ports tabs are not applicable for third-party interfaces.

**Step 11**
Click **Ok**.

**Step 12**
In the Parts tab of the DB Parts Manager dialog box, right-click and choose **Software** and then **Alien** from the shortcut menu. A new row appears on the Parts tab for the client software.

**Step 13**
Double-click the row to open the AlienSoft dialog box.

**Step 14**
In the General tab, complete the following:
• Name—Type the name in the Name field.
• Related Item—Choose the client card that you created in **Step 7 to Step 11**.

**Step 15**
Click any of the following depending on the client card that you choose and proceed to **Step 16**:
• **Default - OCh** tab (Figure 1-16)
• **DPSK-OCh** tab
• **QPSK-OCh** tab
Step 16 Complete the following (see Tables 1-1 through 1-3 for supported value combinations):

- In the Rules area, choose the C-band or L-band design rule from the Design Rule drop-down list.
- In the Technology area, complete the following:
  - Modulation Format—Choose NRZ (Non Return to Zero) or Duo Binary.
  - Transmitter Type—Choose MZ (Mach Zehnder), DML (Direct Modulated Laser), or EML (Electro-absorption Modulated Laser).
  - Receiver Threshold—Choose Optimal (minimum BER) or Average (average received power). For DPSK—Choose the Receiver Threshold as Optimal. For QPSK—Choose the Receiver Threshold as Average.
  - Regeneration Type—Choose 3R or 2R regeneration mode.
  - FEC Mode—Choose FEC (Forward Error Correction), no FEC, or E-FEC (Enhanced FEC). For DPSK or QPSK, set the FEC Mode to E-FEC.
  - Transmitter Stability—Choose the maximum wavelength error allowed (pm). The values are 12.5, 25, 50, or 100 pm.
- Bit Rate—Choose the desired bit rate from the drop-down list. For DPSK or QPSK, choose the Bit Rate as 40 Gb/s.
- In the TX Power Range area, complete the following:
  - TX Max Power—Enter the maximum power output level (dBm).
  - TX Min Power—Enter the minimum power output level (dBm).
In the Back to Back Receiver Sensitivity area, complete the following as needed to define the working interface area for Back to Back. Back to Back is a configuration where the receiver is placed in front of the transmitter and no other equipment exists between the two. Back to Back is used to measure characteristics of the TX and RX pair. Figure 1-17 shows the interface operative area.

- **Overload Power [ps/nm]**—Enter the overload power level.
- **OL_Power [dBm]**—Enter the minimum power level in the OSNR-limited range.
- **OL_OSNR [dB]** on 0.5 nm RBW—Enter the minimum OSNR level in the OSNR-limited range (measured in 0.5 increments).
- **PL_Power [dBm]**—Enter the minimum power level in the power-limited range.
- **PL_OSNR [dB]** on 0.5 nm RBW—Enter the minimum power level in the OSNR-limited range (measured on 0.5 nm bandwidth).

In the Chromatic Dispersion area, complete the following as needed:

- **Customize CD Robustness**—Check to enable the CD Robustness field, as needed. Chromatic dispersion (CD) refers to the broadening of a light pulse after traveling a distance in the fiber.
- **CD Robustness [ps/(nm*km)]**—If Customize CD Robustness is checked, choose the maximum positive dispersion, Dmax_pos [ps/(nm*km)], tolerable by the interface: 0 dB, 1 dB, 1.5 dB, 2 dB, or 3 dB.

Customize Penalties—Check to enable the Gaussian cross-talk Penalties, Single-Interfering Cross-Talk Penalties, and Scale Q factors fields as needed.

If Customize Penalties is checked, enter the values to determine the Gaussian cross-talk Penalties in the A_GXt and B_GXt fields, as needed. Gaussian cross talk refers to random power that interferes with a signal. The A_GXt and B_GXt values are the coefficients for the exponential curves that estimate P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for Gaussian cross-talk levels in the OL and PL regions of the interface model with dispersion margins added (see Figure 1-17). The formula is Penalty (GXt) = A_GXt * exp(B_GXt *GXt).

If Customize Penalties is checked, enter the values to determine the Single-Interfering Cross-Talk Penalties in the A_SIXt and B_SIXt fields, as needed. Single-interfering cross talk refers to interference caused by a single signal. The A_SIXt and B_SIXt values are the coefficients for the exponential curves that estimate P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for single-interfering cross-talk in the OL and PL regions of the interface model with dispersion margins added (see Figure 1-17). The formula is Penalty (IXt) = A_SIXt * exp(B_SIXt *IXt).

If Customize Penalties is checked, enter Scale Q values in the F-P(PL), F-P(OL), F-OSNR(PL), and F-OSNR(OL) fields, as needed. The scale factors measure how efficient a card is in recovering the signal distortion. The slope of the Q-factor curve versus OSNR or RX power determines how a BER increase could be recovered with an increase of OSNR, power, or both (depending in which OSNR/power working point the card is). In general, the scale factors are two values (one in OSNR and one in power) for each working point OL and PL of the interface model (see Figure 1-17). The the F-P(PL), F-P(OL), F-OSNR(PL), and F-OSNR(OL) values translate a Q-penalty (that is, a BER increase) into power and OSNR penalties. The formulas follow:

- **P-penalty(PL) = Q-penalty * F-P(PL)**
- **P-penalty(OL) = Q-penalty * F-P(OL)**
- **OSNR-penalty(PL) = Q-penalty * F-OSNR(PL)**
- **OSNR-penalty(OL) = Q-penalty * F-OSNR(OL)**

F-P(PL) and F-OSNR(PL) are evaluated in the PL working region, while F-P(OL) and F-OSNR(OL) are evaluated in the OL working region of the curve with the dispersion margins added.
Step 17  Click Ok.

Table 1-1 lists the supported combinations for 40-Gbps third party interfaces.

Table 1-1  Supported Combination for 40-Gbps Third-Party Interface

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duo Binary</td>
<td>MZ</td>
<td>Optimal</td>
<td>E-FEC</td>
<td>± 12</td>
<td>P-penalty (OL) 0</td>
</tr>
</tbody>
</table>

Table 1-2 lists the supported combinations for 10-Gbps third party interfaces.

Table 1-2  Supported Combinations for 10-Gbps Third-Party Interface

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Optimal</td>
<td>E-FEC</td>
<td>± 25</td>
<td>P-penalty (OL) 0</td>
</tr>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Optimal</td>
<td>FEC</td>
<td>± 25</td>
<td>P-penalty (OL) 0</td>
</tr>
<tr>
<td>NRZ</td>
<td>MZ</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>P-penalty (OL) 2</td>
</tr>
<tr>
<td>NRZ</td>
<td>EML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 100</td>
<td>P-penalty (OL) 0</td>
</tr>
</tbody>
</table>
Table 1-3 lists the supported combinations for 2.5-Gbps third party interfaces.

<table>
<thead>
<tr>
<th>Modulation Format</th>
<th>TX Type</th>
<th>RX Threshold</th>
<th>FEC</th>
<th>TX Stability [pm]</th>
<th>Chromatic Dispersion Penalties [dBm]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>P-penalty (OL)</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>3</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>3</td>
</tr>
<tr>
<td>NRZ</td>
<td>EML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 25</td>
<td>0</td>
</tr>
<tr>
<td>NRZ</td>
<td>DML</td>
<td>Average</td>
<td>no FEC</td>
<td>± 100</td>
<td>0</td>
</tr>
</tbody>
</table>

1.5.6 Exporting User Options, Price Lists or Alien Definitions

Use the following procedure to export user options, price lists, maintenance contracts, and the parts database files. The export command creates a ZIP file that includes all of the created files.

**Step 1**

From the Tools menu, choose **Export**. The Export dialog box appears (Figure 1-18).

**Figure 1-18 Export Dialog Box**
Step 2  In the Export dialog box, enter a file path and name in the file name field. To export to an existing file, click the ... button and navigate to the desired directory and file. Click Select to choose the file.

Step 3  To select the items to export, complete the following as needed:

- User Option—Check to export the user options set using the Tools > Options command.
- PartsDB—Check the desired platforms.
- PriceDB—Check All Price DB to export all price lists, or expand All Price DB and check the individual price lists that you want to export.

Step 4  Click Ok.

1.5.7 Importing User Options, Price Lists or Alien Definitions

Use the following procedure to import user options, price lists, maintenance contracts, and the parts database files. You can import a ZIP file of multiple exported items or an individual TXT file.

Step 1  From the Tools menu, choose Import. The Import dialog box appears (Figure 1-19).

Figure 1-19 Import Dialog Box

Step 2  In the Import dialog box, click the ... button and navigate to the desired directory and file. Click Select to choose the file to import.

Step 3  Click load.

Step 4  If you selected a single TXT file, skip this step and go to Step 5. If you selected a ZIP file with multiple exported options, complete the following as needed:
### Setting Cisco Transport Planner Options

- **User Option**—Leave checked to import a file with the user options that were set with the Tools > Options command.
- **PartsDB**—Leave checked to import the parts database for the desired platform.
- **PriceDB**—Leave **All Price DB** checked to import all price lists, or uncheck and check the desired individual price lists.

**Step 5**  
Click **OK**.

**Step 6**  
In the confirmation dialog box, click **OK**.

---

### 1.5.8 Resetting the Default Layout

Your graphical layout settings are saved when you exit Cisco Transport Planner. The next time that you launch Cisco Transport Planner, the layout appears as it did upon exiting. The default graphical layout includes items such as whether the panes are visible and/or docked.

To return to the Cisco Transport Planner default layout, choose **Default Layout** from the View menu. To restore the user modified layout, choose **My Default View** from the View menu.

### 1.5.9 Adding User Profiles

A user profile is a set of privileges used for running Cisco Transport Planner. Each profile offers different capabilities. Cisco Transport Planner is packaged with the Network Designer profile, but you can add other user profile types provided by Cisco. All the procedures in the *Cisco Transport Planner DWDM Operations Guide* are written for users with Network Designer access.

Use the following procedure to add a user profile to Cisco Transport Planner:

**Step 1**  
Close all open instances of Cisco Transport Planner.

**Step 2**  
Identify the directory where Cisco Transport Planner is installed on your computer, see the “1.4 Launching Cisco Transport Planner” section on page 1-16.

**Step 3**  
Create a profile folder; if profile folder already exists, go to **Step 4**.

**Step 4**  
Copy the profile JAR file provided by Cisco Systems into the profile folder.

**Step 5**  
Launch Cisco Transport Planner. For more information, see the “1.4 Launching Cisco Transport Planner” section on page 1-16. The new profile will appear in the **Current Selected Profile** drop-down list.
1.5.10 Understanding Sides Labeling

In Cisco Transport Planner Software R8.5 and later, the label for each supported site structure is different from the labels that have been used in the previous releases. Table 1-4 summarizes the labeling format in Cisco Transport Planner.

Table 1-4  Sides Labeling in Cisco Transport Planner

<table>
<thead>
<tr>
<th>Sites</th>
<th>Labeling in Previous Releases</th>
<th>Labeling in Cisco Transport Planner Software R8.5 and later</th>
</tr>
</thead>
<tbody>
<tr>
<td>Terminal/Terminal+</td>
<td>Only one side is created and labeled, T.</td>
<td>Only A can be used for the existing side.</td>
</tr>
<tr>
<td>Line/Line+</td>
<td>Two sides are created and are labeled, West and East.</td>
<td>Only A and B can be used for the existing sides.</td>
</tr>
<tr>
<td>Multidegree with PP-MESH-4</td>
<td>—</td>
<td>Only A, B, C, and D can be used for the existing sides.</td>
</tr>
<tr>
<td>Multidegree with PP-MESH-8</td>
<td>—</td>
<td>Only label A, B, C, D, E, F, G, and H can be used for the existing sides.</td>
</tr>
<tr>
<td>PSM Line</td>
<td>—</td>
<td>Only Aw and Ap can be used for the existing sides, where w stands for working and p stands for protection.</td>
</tr>
<tr>
<td>PSM Section</td>
<td>—</td>
<td>Only Aw and Ap can be used for the existing sides, where w stands for working and p stands for protection.</td>
</tr>
</tbody>
</table>