
Introduction

Cisco Transport Planner (CTP) provides a way to model and test wavelength division multiplexing (WDM)
optical networks in a graphical environment. The primary purpose of Cisco Transport Planner is to help sales
engineers (SEs) design and validate networks of Cisco Optical Networking Sytem (ONS) 15454Multiservice
Transport Platforms (MSTP) and NCS. Using the CTP, an SE can create multiple instances of a network to
modify different parameters in each instance for comparison. Cisco Transport Planner generates a shelf view
of all the sites deployed in the optical network and provides a complete bill of materials (BoM) for the network
and the differences between instances of a network.

In this guide, M2 chassis refers to the Cisco ONS 15454 M2 chassis or NCS 2002 M2 Chassis, M6 chassis
refers to the Cisco ONS 15454 M6 chassis or NCS 2006 M6 Chassis, M12 chassis refers to the Cisco ONS
15454 M12 chassis, and M15 chassis refers to the Cisco NCS 2015 M15 chassis.

Note

This chapter describes how you use Cisco Transport Planner to design, analyze, and optimize new or existing
Cisco optical networks and contains the following sections:

• Overview, on page 1
• Installing Cisco Transport Planner, on page 14
• Uninstalling Cisco Transport Planner, on page 15
• Launching the Cisco Transport Planner, on page 15
• Performing Software Updates in CTP, on page 19
• Setting Cisco Transport Planner Options, on page 20
• Understanding Hybrid Configuration, on page 44
• Understanding the Pay As You Grow Feature, on page 44

Overview
This section describes the Cisco Transport Planner, Release 11.1 features, network design process, process
flow, traffic planning, traffic services, and parameter states.

Cisco Transport Planner, Release 11.1 Features
Cisco Transport Planner software provides a simple tool set for designing optical networks with Cisco ONS
15454 MSTP and NCS products. You enter all network parameters, or minimal information, such as site
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distance, and Cisco Transport Planner models the network you need to build and generate a detailed BOM
with ordering information. Designing optical networks requires the verification of multiple constraints such,
as optical budget limitations and platform architectural restrictions. A single Cisco Transport Planner project
can contain multiple copies of a network. This duplication allows you to change parameters in one network
copy, and then analyze and compare it with another network copy to study the differences. CTP uses 5us/km
for fiber and DCU as a length-based latency.

The new features of Cisco Transport Planner, Release 11.1 are listed in below table:

DescriptionFeatures

From Release 11.0, SMR9 with Contentionless Configuration is
supported on all SSON Networks.

From Release 11.0, Layer2 SMR flag can be enabled on an SSON
Network, but no Layer2 Contentionless Side support is present.

SMR9 support on SSON

FromRelease 11.1 onwards, Regeneration is supported on the NCS
1004 with the Alien NCS4K-4H-OPW-QC2 Line Card and Denali
Alien.

Support of Regeneration on Alien

From Release 11.1, RAMAN-COP-CTP is supported on SSON
Networks.

Support of RAMAN-COP-CTP on
SSON

From Release 11.1, the 400-XP-LC card with MXP and OTNXC
mode supports QSFP-4X10-MER pluggable on 10GE,
OC192/STM64, OTU2, OTU2e client interfaces.

Support of MER Pluggable on
400G-XP-LC card (OTNXC and
MR-MXP mode)

From Release 11.0, the 8GFC Blocking is enabled on the CDR
ports of the 400G-XP-LC card.

8GFCClient Interface blocking on CDR
ports of 400G-XP-LC card

Important Notes
• In Release 10.6.1, the TCC2P card can be used only on a standalone Network Element (NE) or as
subtended shelf of an MSM having node controller with TCC3 card in M12 or TNCE/TNCS in NCS
2006 or NCS 2015.

• In Release 10.6.1, an MS-ISC card is not supported in a shelf with a TCC2P card.

From R10.6.2 onwards, TCC2P card is no longer supported on M12 ChassisNote

Network Design Process
To generate a network design, the SE enters the following parameters:

• The topology of the network—ring, linear, or meshed
• The type of equipment used at each site
• The distance separating the sites
• The type of fiber connecting the sites
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• Service demands, including the service type, the protection type, and the number of channels between
nodes

• The number of network sites

When the network parameters are entered, Cisco Transport Planner finds the best routing, defines the required
add/drop filters, places optical amplifiers with dispersion compensation units (DCUs) or tunable dispersion
compensation units (TDCU) to fit the user traffic demands at a minimum cost. The TDCU operates only over
the C-band. Optimization is performed to meet the boundary conditions. The optimization includes attenuation
and amplification.

Finally, Cisco Transport Planner generates a BOM, which includes the product codes, the quantities, and
pricing information. In addition, it creates other reports, such as a shelf-level view of the configuration, which
can be printed. This information helps the SE understand how the shelf is built and helps to avoid confusion
and errors during the actual deployment. Within the BOM is the total network cost, which allows a quick
comparison of various design options. The total network cost is the cost of the equipment for all of the sites
in the designed network.

Network Design Constraints
Cisco Transport Planner searches for the best solution to a designed network using an optimization algorithm.

A network design must meet the optical budget and receiver overload criteria to operate efficiently. An analysis
of the optical budget and receiver overload evaluates the strength of the signal traversing the ring. If a design
solution satisfies the constraints, it is a valid design. The Cisco Transport Planner optimization algorithms
generate multiple solutions and verifies the constraints against those solutions. If the constraints are satisfied,
the solution with the lowest cost-to-utilization ratio is selected as the optimal solution.

If the network design solution fails to satisfy all the constraints, Cisco Transport Planner makes adjustments
to parameters such as signal attenuation and amplification. Amplification is achieved using an erbium-doped
fiber amplifier (EDFA). Attenuation is achieved using the variable optical attenuator (VOA)modules integrated
into the platform. Cisco Transport Planner corrects the optical budget using an algorithm that includes automatic
placement of EDFAs and VOA regulation.

For each internodal demand, Cisco Transport Planner performs an optical budget and receiver overload analysis
and displays the results in various reports in the Graphical User Interface (GUI). If the network design
algorithms are not able to provide a solution, then you can modify the input data (for example, by relaxing
some user constraints) and run the analysis again.

Platform Support
Cisco Transport Planner Software Release 11.1 supports the Cisco ONS 15454 DWDM optical platform
Software Releases 9.0, 9.1, 9.2, 9.2.1, 9.3, 9.4, 9.6.0.3, 9.8, 10.0, 10.1, 10.5, 10.5.2, 10.6, 10.6.1, 10.6.2, 10.7,
10.8, 10.9, and 11.0.

Topology Support
The Cisco Transport Planner supports the following network topologies:

• Linear (single-span or multispan)
• Ring (open or closed)
• Meshed

For more information on network topologies, see the Supported Cisco Transport Planner Topologies.
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The Cisco Transport Planner enables you to design flexible networks with up to 150 site locations. A flexible
network uses ROADM nodes to allow traffic modification or reconfiguration, or both as traffic requirements
change.

In Cisco Transport Planner Software R11.1, the maximum number of locations where the optical service
channel (OSC) is terminated is 40. The maximum number of add/drop locations supported is 40.

Protection Scheme Support
Cisco Transport Planner designs support the following protection schemes:

• Y-cable protected—In Y-cable protection, one transponder card is designated as active and the other as
standby. The standby transponder card has the client-side laser turned off to avoid corrupting the signal
transmitted back to the client. The active transponder monitors the signal from the trunk side and in the
event of loss or signal failure, the system switches to the standby path. The following figure shows an
example of a Y-cable protected link.

Figure 1: Y-cable protection

• Client-based 1+1—Two client signals are transmitted to separated line cards or transponder cards instead
of using a Y-cable to split one client signal into two line cards or transponder cards. In client 1+1
protection, the failure and switchover is controlled by the client system. The following figure shows an
example of a 1+1 protected link.
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Figure 2: 1+1 Protection

• Fiber-switched protection—The single client signal is injected into the client receive (Rx) port. It is then
split into two separate signals on the two trunk transmit (Tx) ports. The two signals are transmitted over
diverse paths. The far-end card chooses one of the two trunk Rx port signals and injects it into the Tx
client port. The following figure shows an example of a fiber-switched protected link.

Figure 3: Fiber-switched Protection

From CTP Release 10.5, fiber-switched protection is supported on a 10x10G-LC card. For more information,
see Fiber-Switched Protection on a 10x10G-LC Card, on page 6.

• PSM-OCH—Channel protection configuration provides protection at trunk level (like Fiber-Switched
protection) for TXP/MXP that do not have dedicated Fiber-Switched cards. PSM splits the traffic originated
by transponder trunk on working and protected TX ports. Working Tx (W-Tx) and protected TX (P-Tx)
are connected to the add ports of Add-Drop stages adding the channel in two different directions. On the
receiving direction PSMW-RX and P-RX are connected to the drop ports of Add-Drop stages receiving
the channel from the two different directions. PSM switch selects a path among W-Rx and P-Rx ports
so that only one direction at a time is connected to COM-RX ports and therefore to the TXP/MXP. The
following figure shows an example of a PSM-OCH protected link.

From CTP Release 10.5, networks with PSM-OCH protection can be imported into CTP.
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From CTP Release 10.8, the 400G-XP-LC card supports trunk based PSM protection (PSM-OCH) on the
CFP2 port in Muxponder mode for all the supported trunk rates and service types.

Figure 4: PSM-OCH Protection

• Unprotected—Protection is not used.
• External card switch—Protection not used.

Fiber-Switched Protection on a 10x10G-LC Card

CTP Release 10.5 supports fiber-switched protection on a 10x10G-LC card. The 10x10G-LC cards support
up to two splitter protection groups with one client and two trunk ports:

• First instance: Port 3 (client), Port 4 (Working trunk) and Port 6 (Protect trunk)
• Second instance: Port 7 (client), Port 8 (Working trunk) and Port 10 (Protect trunk)

You can also provision one instance of the fiber-switched protection with port 3 or port 7 as the client port,
and up to 3 trunk ports. The operational mode of the card for fiber-switched protection is TXPP-10G.
Fiber-switched protection is supported only for 10GE traffic with trunkmode set to Disable (NOFEC), Standard
(FEC), or Enhanced (EFEC).

You can configure different wavelengths, threshold crossing alerts (TCAs), alarms threshold, facility and
terminal loopbacks on the working and protect trunk ports.

Y-cable protection and fiber-switched protection cannot be configured on the same card.

To configure fiber-switched protection on a 10x10G-LC card, use the following procedure:

When you create a demand, choose Fiber Switched as the protection type from the Protection drop-down list
in the Demand Editor dialog box.

Service Support
Cisco Transport Planner can support any subset of the following services:

• Alien (third-party DWDM interface)
• Cisco ONS 15530 2.5 Gbps Aggregated
• ONS 15530 10 Gbps Aggregated
• ONS 15530 Multirate (MR) Transport
• ONS 15530 Data Multiplexer (MXP)
• 2R Any Rate
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• 3G-SDI
• Gigabit Ethernet
• 10GE—10 Gigabit Ethernet (LAN and WAN)
• D1 Video
• DVB-ASI—Digital Video Broadcast-Asynchronous Serial Interface
• DV-6000
• DPSK—Different Phase Shift Keying
• ESCON—Enterprise System Connection
• Fast Ethernet
• Fiber Channel 1G
• Fiber Channel 2G
• Fiber Channel 4G
• Fiber Channel 8G
• Fiber Channel 10G
• Fiber Channel 16G
• FICON—Fiber Connection 1G
• FICON Express 2G
• FICON 4G
• FICON 8G
• FICON 10G
• E3 over FE
• T3 over FE
• DS3 over FE
• High Definition Television (HDTV)
• ISC-3 Peer (1G)
• ISC-3 Peer (1G with STP)
• ISC-3 Peer (2G)
• ISC-3 Peer (2G with STP)
• ISC-3 Peer (2R)
• ISC-3 Peer (2R)
• ISC-Compat (ISC-3 Compatibility mode)
• HD-SDI
• HDTV
• OC-3
• OC-12
• OC-48
• OC-192
• OC-768
• OTU2
• SD-SDI
• SDI—Serial Data Input
• STM-1
• STM-4
• STM-16
• STM-64
• STM-256
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• 10GE WAN-Phy
• 10GE LAN PHY
• 10GE LANtoWAN
• 100GE
• 40GE LAN PHY
• OTU1
• OTU2
• OTU2e
• OTU3
• OTU4
• Sysplex CLO—control link oscillator
• Sysplex ETR—external throughput rate
• LAN-WAN Conversion

The Sysplex CLO and Sysplex ETR services are supported only on the following topologies:

• Single span—Two terminal sites with 32MUX-O and 32DMX-O cards, 40MUX-O and 40DMX-O cards,
40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed and no intermediate sites in
between.

• Point-to-Point—Two terminal sites with 32MUX-O and 32DMX-O cards. 40MUX-O and 40DMX-O
cards, 40WSS and 40DMX, or 32WSS and 32DMX or 32DMX-O cards installed. Line amplifiers can
be installed between the terminal sites, but intermediate (traffic terminating) sites cannot be installed.

• Two hubs—Two hub nodes in a ring with 32MUX-O, 32DMX-O, 32WSS, 40MUX-O, 40DMX,
40DMX-O, 40WSS, and 32DMX cards or 32DMX-O cards installed. Line amplifiers can be installed
between the hubs.

For more information about the supported topologies for the ETR and CLO services, refer the Cisco ONS
15454 DWDM Configuration Guide .

The following features are available only when 100GE or OTU4 is selected as the service type during network
creation:

• CRS line card 1-100GE-DWDM (FEC, EFEC [default], or HG-FEC) is available for Point-to-Point,
P-Ring, and ROADM demands.

• (For Release 9.6.03 and later) MPO-MPO cables are available in the Net view and Site view of the BoM
report. MPO-MPO cables are not available for combination cards. For example, MPO-MPO cables are
not available if you have chosen 100G-LC-C+CFP-LC or 100G-LC-C+ASR as card type.

The encryption feature is available only:

• When 10GELANPHY, OTU2e, OC192, STM64, or OTU2 is selected as the service type during network
creation.

• When 100GE is selected with TXP-100G operating mode cards.
• When 100GE/OTU4 is selected with 400G-XP-LC card

• When OTN-XC is selected with 400G-XP-LC card.

Cisco Transport Planner Process Flow
The following stages are used to complete a network design.

1. Create a project using the Project Creation wizard.
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2. Create a network using the Create Network wizard. The Create Network wizards adds sites and places
the fiber spans between the sites. A span represents a pair of fibers.

3. Create a point-to-point, Aggregated Ethernet, OTNAggregated, TDMAggregated, protected ring (P-ring),
and/or ROADM service demand.

4. Analyze the network design.
5. If you would like to force automatic tool choices, adjust the design and repeat the analysis until you have

reached the desired configuration.
6. Create an Install copy of the network and update the parameters with real data from the field.
7. Analyze the Install network.
8. Create an upgrade copy of the network, as needed, to add forecasted channels.

The following figure shows the process flow.

Figure 5: Cisco Transport Planner Process Flow

Planning Traffic in Cisco Transport Planner
Traffic in Cisco Transport Planner is defined as an optical path for each pair of nodes requiring a service
demand. An optical path is the combined channels between the two nodes. The following list gives definitions
for some basic traffic items:

• Circuit—A single channel between a pair of source and destination nodes. In addition to the source and
destination nodes and all the attributes that are common to the service containing the circuit, a circuit
has the following attributes:

– Present/forecast indication

– Routing direction for unprotected service

Introduction
9

Introduction
Planning Traffic in Cisco Transport Planner



– ITU channel

– Optical bypass indication

• Demand—A set of circuits with common characteristics, such as:

– Service demand label

– Number of existing circuits

– Number of forecasted circuits

– Client service type

– Protection type

– Optical bypass (number of channels and/or sites)

– Present/forecast indication WDM interface type (TXT or ITU-LC)

– WDM card type

– Source client interface (SR, IR, or LR)

– Destination client interface (SR, IR, or LR)

• Traffic demand—All traffic between the same set of nodes. Both L-band and C-band are supported. The
following traffic demands are supported: P-ring, Fixed (point-to-point), and Any-to-any (ROADM).

– In P-ring traffic demands, all the demands are used to support traffic topologies similar to bidirectional
line switched rings (BLSRs) or multiplex section-shared protection rings (MS-SPRings). Each P-ring
demand is between a pair of added/dropped nodes where BLSR-like (or MS-SPRing-like) traffic must
exist. The number of circuits is the same for each demand, and is user-specified (from 1 to 40).

– In fixed (point-to-point) traffic demands, the set of nodes is restricted to two sites. The number of
circuits is user-specified (from 1 to 40).

– In any-to-any (ROADM) traffic demands, a minimum of two nodes and a maximum of 40 ROADM
nodes are supported. The any-to-any traffic demand allows each node to establish one or more circuits
with the other nodes, either as a hub or meshed configuration. In a meshed configuration, each node
defined in the set is connected to each of the nodes. This is the most common traffic type. In a hub
configuration, the user-defined hub node is connected to each of the other nodes. ROADM circuits have
the same protection types and services. The number of circuits is not user-specified and can vary from
0 to 40.

In any-to-any (ROADM) traffic demand, the default routing strategy is
Unprotected minimum hop count.

Note

Any-to-Any (ROADM) traffic demand is not supported for SSON networksNote

A ROADM demand can have multiple client service types and support multiple DWDM card interfaces
for each client service type. A ROADM demand supports the following routing strategies:

– Protected (Default)—Each node pair in the traffic demand is connected using two connections.
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– Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected
optimum optical path minimizes the number of required optical amplifiers, but also restricts the number
of channels that can be deployed among the nodes of the traffic demand (maximum of 40 channels
between each node pair) in the installed network.

– Unprotectedminimum hop count—Each node pair in the traffic demand is connected by one connection.
The unprotected minimum hop count maximizes the number of channels (for unprotected traffic types
only) that can be deployed among the nodes of the traffic demand, but requires a higher number of optical
amplifiers on the unprotected optimum optical path (maximum of 40 channels between each node pair)
in the installed network.

– Unprotected subnet—Each node pair in the traffic demand is connected using one connection. You
can manually force connections on only one branch of the ring. For unprotected subnets, you must
manually select one starting node of the branch and the direction the ring must be traversed to define the
subnet, starting from the initial site. The branch direction is specified by defining the outgoing side first,
referred to as the starting node. This routing strategy option allows you to exclude some critical paths
and (with ROADM traffic demands containing two sites) to force each ROADM connection clockwise
or counterclockwise.

Project Explorer Pane
The Project Explorer pane shows all of the open project information, including networks, network dependencies,
sites, fibers, services, and so on. The user-defined traffic services are displayed as folders and icons in the
Project Explorer pane, as shown in the following figure.

Figure 6: Project Explorer View
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After you analyze a network design, the colors of the icons change according to the error/warning condition
of the network design. The icons display in red if there are errors in the network design; orange if there are
warnings but no errors; and green if there are no warnings or errors. The icon shows the color of the most
severe condition. For more information about analyzing the network, see the Analyzing the Network.

The Project Explorer pane provides the following options to edit the parameters:

• Right-click the folder/icon in the Project Explorer pane to edit the parameters.
• Click sticky to select multiple items in the Project Explorer pane. Edit the properties that are common
to the selected items in the Properties pane.

Multiple Selection
Click sticky in the Project Explorer pane toolbar to select multiple folders and icons in the Project Explorer
tree or the Network View. Alternatively, hold the Ctrl key on the keyboard and select multiple folders and
icons. The folders and icons corresponding to the selection in the Project Explorer pane are highlighted in the
Network View and vice-versa. You can also select similar folders and icons by right-clicking them and
choosing Select Similar in the menu. For example, by right-clicking a site choosing Select Similar in the
menu, you can select all the sites in the Project Explorer pane. The Select Similar option is available only for
the folders and icons in the Project Explorer pane that have properties. The properties that are common to the
selected items are displayed in the Properties pane. If any property has a different value than the others, that
value is highlighted in a different color in the Properties pane.

The following options are available when multiple folders and icons are selected:

• Sites

– Delete, Unlock, and Unlock Pay As You Grow Bundles

– Edit properties

• Ducts

– Delete, Insert Site, and Unlock

– Edit properties

• Service Demands

– Delete and Unlock

– Edit properties

Cisco Transport Planner Traffic in the Project Explorer Pane
Cisco Transport Planner represents all of the user-defined traffic services as folders and icons within the
Project Explorer pane.

Point-to-Point Traffic Demands

Point-to-point traffic demands appear in the Service Demands > PointToPoint folder in the Project Explorer
pane. Each point-to-point traffic demand is categorized by its source and destination site names. All of the
point-to-point services between the two sites appear under the designated demand name.

A point-to-point traffic demand includes the following information:

• Client service type
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• Site# – Site# (source and destination site labels for this demand)

P-Ring Traffic Demands

Each protected ring (P-ring) traffic demand appears in the Project Explorer pane under the Service Demands
> P-Rings folder.

All the P-ring channels between each site pair are listed under each P-ring traffic demand. Each demand is
labeled with the following information:

• P-ring number
• Client service type
• Site# – Site# (source and destination site labels for this demand)

ROADM Traffic Demands

Each ROADM traffic demand appears in the Project Explorer pane under the Service Demands > ROADMs
folder. The ROADM folder contains each defined ROADM demand. You can define more demands for the
same ROADM for the same set of nodes.

In the Project Explorer pane, each ROADM includes the ROADM demand name and a list of DWDM card
types that support the client service types. Protection types appear in parentheses.

Aggregated Ethernet Demand

Each aggregated ethernet traffic demand appears in the Project Explorer pane under the Service Demands
> Aggregated Ethernet folder. The Aggregated Ethernet folder contains each defined aggregated ethernet
demand. Aggregated Ethernet demands are supported on ring and linear traffic subnets.

TDM Aggregated Demand

Each TDM aggregated demand appears in the Project Explorer pane under the Service Demands >
Aggregated TDMs folder.

TDM aggregated demands are supported only on a ring traffic subnet.Note

OTN Aggregated Demand

OTNAggregated Demand appear in the Service Demands > Aggregated OTN folder in the Project Explorer
pane. OTN Aggregated demands are supported on ring and linear traffic subnets.

ILK Bandwidth can not be used on Terminal node in Linear traffic subnets.

Always two interface/sides can be associated with any kind of PRing/ OTN demand.

Note

Auto, Forced, and Locked Parameters
Parameters in CTP can be in one of three states:

• Auto— This parameter allows the highest degree of flexibility to CTP in designing a network. When
you select Auto, CTP chooses the parameter value during network analysis.
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• Forced—When you set a specific parameter value, other than Auto, CTP designs the network using these
constraints. When a setting is forced, the item appears in blue italics in the Project Explorer pane.

• Locked—The state of a parameter after network analysis. The next time the analyzer is run, Cisco
Transport Planner cannot change the value when it is in the Locked state. You can unlock an item using
the Unlock command. For more information, see Unlocking Parameters in the Network Design and
Forcing Manager.

For the WSE card, the encryption option can be modified even when the demand is in locked state. This is
available in the Upgrade or Release-upgrade networks and on A2A finalized demands that can be edited from
A2A Finalized Circuits. When modifications are made without the unlock, the encryption parameter on the
specific port of the WSE card is updated on analysis.

Note

Depending on the initial state, the network analyzer will:

• Move the parameter into the Locked state if the unit or parameter was set to Auto.
• Leave the parameter in the same state if the user forced a specific value for the unit or parameter.

Installing Cisco Transport Planner
Use the following procedure to install Cisco Transport Planner:

Procedure

Step 1 To download the installer, go to the Cisco software download site.
Step 2 Navigate to the location where you want to save the CTP executable file to a local hard drive.
Step 3 Click Save.
Step 4 To start the installation of CTP:

• Windows—Navigate to the folder containing the CTP executable file and double-click it.

• Linux—Assuming the CTP.bin file is accessible from the current shell path, navigate to the directory
containing the CTP.bin file and enter: % ./CTP.bin

The graphical CTP installation wizard is displayed.

Step 5 Click Next. The license agreement is displayed.
Step 6 To accept the license, select the I accept the terms of the License Agreement radio button.
Step 7 Click Next.
Step 8 Specify the installation folder. OnWindows 7 orWindows 10, the default is C:\Program Files\Cisco\CTP_11.1.

To choose a different folder, click the Choose... button and browse to the required folder. To restore the
default path, click the Restore Default Folder button.

Step 9 Click Next.
Step 10 Specify the shortcut folder by choosing any one of the following options:

• In a new Program Group—Specify a new folder. The default option is CTP_11.1.
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• In an existing Program Group—Select a folder from the list of existing folders.

• In the Start Menu

• On the Desktop

• In the Quick Launch Bar

• Other—Use this option to specify a commonly used folder.

• Don't create icons—Choose this option if you do not want to create a shortcut.

Check the Create Icons for All Users check box if you want to create shortcuts for all the users
of a system.

Note

Step 11 Click Next. The pre-installation summary is displayed.
Step 12 Review the pre-installation summary. If no changes are required, click Install; otherwise, click Previous to

make modifications.

A progress bar displays the installation status. Click Cancel at any time to stop the installation.

When the installation process is complete, a screen indicates whether the installation succeeded or failed.

Step 13 Click Done to exit the installation wizard.

Uninstalling Cisco Transport Planner
Use the following procedure to uninstall Cisco Transport Planner:

Procedure

Step 1 Click the Uninstall CTP icon available at the location selected in Step 10 of the Installing Cisco Transport
Planner, on page 14.

The graphical Uninstall CTP wizard is displayed.

Step 2 Click Uninstall.
Step 3 A progress bar displays the uninstallation status. Click Cancel at any time to stop the uninstallation.

When the uninstallation process is complete, a screen displays the files that could not be uninstalled.

Step 4 Click Done to exit the uninstallation wizard.

Launching the Cisco Transport Planner
Before you start the Cisco Transport Planner (CTP), you need to save the user profiles provided by Cisco
Systems to the profiles folder available at the installation location. Access to CTP features depends on the
user profile you select when you start CTP. The default profile is Base Network Designer.
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To launch the CTP, perform the following steps:

Procedure

Step 1 Launch Cisco Transport Planner using any of the following options:

• Click the CTP icon in the Start > All Programs > CTPmenu.

• Double-click the CTP icon in the quick launch bar.

• Double-click the CTP icon on the desktop.

• Browse to the installation folder and double-click the ctp.jar file.

CTP validates the installed Java version in the system. If the installed version is Java 1.7 or Java 1.8, the CTP
login dialog box is displayed.

If Java 1.7 or Java 1.8 is unavailable, CTP displays the JVM Version Error dialog box that lists
the incompatible Java versions. Install the required Java version from the http://www.oracle.com/
technetwork/java/index.html website. Repeat Step 1.

Note

Step 2 From the Current selected profile drop-down list, select the user profile.
Step 3 Click Continue to open the Cisco Transport Planner.

The login profile type appears in the lower-right corner of the CTP window.

The Start Page is displayed. The Start Page provides the following options:

• New—Click to create a new project.

• Open—Click to open an existing project.

• Import Network—Click to import node parameters from a network.

• Recent Network Files area—Select an existing project to open it.

Selecting any of the above options opens a new tab.

Step 4 Check the Do not show Start Page at startup check box to disable viewing the start page when Cisco
Transport Planner is started.

Check View Start Page check box under Tools > Option > Graphic > Start Page to enable displaying the
Start Page when launching the CTP.

Opening a Project
Use the following procedure to open an existing Cisco Transport Planner project. To create a new project,
see Creating a Project.
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Procedure

Step 1 Click the project name under Open in the Tasks Pane. The project opens. If you do not see the project name
listed, continue with Step 2.

Step 2 Click Open in the Start Page, click Open under Project in the Tasks Pane, or in the File menu.
Step 3 In the Open Project dialog box, navigate to the desired folder and choose the project. Click Open. The Cisco

Transport Planner project appears.

You cannot open an existing CTP project in multiple CTP instances. The saved project (.MPZ
file) is locked for the use of that CTP. If you try to open the project in another instance of CTP,
an error message is displayed. The .MPZ project file is unlocked and released only after you close
the Network.

Note

Loading and Unloading Networks
Each network in a project requires memory. To save memory, when Cisco Transport Planner opens a project,
all networks are in the Unloaded state. An unloaded network appears in the Project Explorer pane with a “U”
next to the network identifier. To load an unloaded network, double-click on the network folder in the Project
Explorer pane, or right-click the network and choose Load from the shortcut menu.

Figure 7: Unloaded Network in the Project Explorer pane

A loaded network appears in the Project Explorer pane with an “L” next to the network identifier. To unload
a loaded network, right-click the network icon in the Project Explorer pane and choose Unload from the
shortcut menu.

When you load a network containing an alien interface that is not present in the parts database (DB), warning
messages are displayed.

Note

Figure 8: Loaded Network in the Project Explorer pane

Saving a Project
Use the following procedure to save a project:

Introduction
17

Introduction
Loading and Unloading Networks



Procedure

Step 1 Choose one of the following:

• To save an existing project with the same filename, choose File > Save. You have completed this
procedure.

• To save a new project, choose File > Save and go to Step2.

• To save an existing project with a different filename, choose File > Save As and go to Step2.

Step 2 In the Save Project dialog box, navigate to the desired folder and enter the filename. Click Save. Cisco
Transport Planner saves projects as zipped files with the MPZ extension.

Closing a Project
Use the following procedure to close a Cisco Transport Planner project:

Procedure

Step 1 From the File menu, choose Close.
Step 2 In the Save Project dialog box, click Yes to save or No to close without saving changes.
Step 3 If you clicked Yes and have not previously saved the project, the Save Project dialog box appears. Enter the

name of the project and click Save. The project closes.
Step 4 To exit Cisco Transport Planner, choose Exit from the File menu.

Deleting the CTP Cache
To delete the CTP cache, perform the following steps:

CTP must be restarted to delete the CTP cache.Note

Procedure

Step 1 From the Tools menu, choose Delete Cache.
Step 2 Click Yes to delete the CTP cache or No to postpone cache deletion.
Step 3 When you click Yes, an information message is displayed prompting you to restart CTP now or later. If you

do not want to restart CTP immediately, cache deletion is postponed to the next restart.
Step 4 Before you restart, save your project and choose File > Close to close the project.
Step 5 If you click on Restart Now, CTP cache is deleted and CTP restarts automatically.
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Step 6 To restart CTP later, choose File > Restart.

A message is displayed prompting you to continue with restart. Click Yes to restart CTP. A message is
displayed prompting you to continue with cache deletion now or later.

Step 7 Click Yes to delete the CTP cache or No to postpone cache deletion.

Performing Software Updates in CTP
CTP enables you to update the CTP software automatically or manually.

Performing Automatic Software Updates in CTP
This section explains how to perform an automatic software update.

Procedure

Step 1 When CTP is launched, it checks for the latest software update automatically. If available, the following dialog
box appears: Online Update Available, Would you like to Update CTP? Click Yes.

Step 2 The Software Update Dialog box appears listing the applicable software updates. Select the required software
update and click Apply.

Step 3 The Update Successful message appears. Click OK.

The Update dialog box appears every time CTP is launched until the software update is applied.Note

Performing Manual Software Updates in CTP
Contact the Cisco Sales/Account team to get the software update files.

This section explains how to perform a manual software update.

Procedure

Step 1 In the CTP Help menu, go to Help > Check updates. The update CTP dialog box appears.
Step 2 Click Browse.
Step 3 Select the .upz update file and click OK.
Step 4 The Software Update Dialog box appears listing the applicable software updates. Select the required software

update and click Apply.
Step 5 The Update Successful message appears. Click OK.
Step 6 Delete the cache and restart CTP.
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Performing Software Update Rollback
CTP allows rollback of software updates. A single rollback moves the CTP software to the previous state
(prior to the software update). For example, if there are two updates applied one by one—Update 1 and Update
2, after the first rollback, CTP removes Update 2 and retains Update 1. Further rollback(s) are needed if
multiple updates are present.

This section explains how to perform a rollback.

Procedure

Step 1 Press R while CTP is launching. The CTP launch is interrupted to perform a software rollback.
Step 2 Click Yes to confirm software rollback. The rollback successful dialog box appears.

• Delete CTP Cache before and after applying update. Procedures about deleting cache are
mentioned in the CTP Operations Guide. Take a backup of the required files (User
preferences, CTPDesign Files (.mpz), NeUpdate File, Alien Files, and so on) before deleting
CTP cache.

• Automatic Update can be performed only when you are connected to the Cisco network. If
you are not on a Cisco network, try to connect to Cisco VPN first. Otherwise, the software
update file should be manually provided by a Cisco representative and manually updated.

• Changes caused by the software update is applicable even if the CTP Cache is deleted after
the update. To remove an update, follow the rollback procedure mentioned in the previous
section.

• Multiple rollbacks are not supported in this release. Re-install CTP if required.

• In the Java Control Panel, set the Java security tomedium and mention the CTP installation
directory in the Exception Site List (if there are issues with the rollback). If the screen is
unresponsive, end CTP process and restart CTP.

• For MAC, force quit the process and restart CTP (if there are issues with the rollback).

• After uninstallation, delete all the files under the directory where CTP is installed manually.

– Default location on Windows OS: C:\Program Files\Cisco\CTP_11.1

– Default location on Mac OS: Applications/Cisco/CTP11.1

Note

Setting Cisco Transport Planner Options
Cisco Transport Planner provides numerous options for customizing the tool and the design.
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The following procedures for setting options using the Tools menu apply to new projects during project
creation. To change an existing (open) project, click the desired item in the Project Explorer pane Subnets
folder and edit the parameter in the Properties pane.

Note

Setting the Graphical Display
Use the following procedure to set the Cisco Transport Planner graphical display:

Procedure

Step 1 From the Tools menu, choose Options.
Step 2 In the Options Explorer dialog box, right-click the Graphic folder and chooseExpand from the shortcut menu.
Step 3 Click Chart Panel and complete the following:

• In the Colors area, to change the colors of Border Paint, Background Paint, Line Paint, Plot Background
Paint, and Plot Outline Paint, click the relevant fields in the Colors list, and click the drop-down arrow
to display a color swatch popup window. Then, click the desired color.

• In the Strokes area, to change the strokes of Border Stroke, Outline Stroke, and Default Line Stroke,
click the relevant fields in the Strokes list, and click the drop-down arrow. Then click the desired stroke

• In the Font area, click the Font drop-down box to display a font popup window. Then select the desired
Font, Size and Style.

• In the Alfa area, enter numeric values for Background Alfa and Foreground Alfa.

• In the Shapes area, click the Line Shape drop-down box. Then click the desired line shape.

• In the Gridlines area, check the Range Gridlines and Domain Gridlines check boxes to view the gridlines
for the same.

Step 4 To change the color scheme for Cisco Transport Planner, click Look & Feel and choose the desired scheme
from the drop-down list.

Step 5 To enable displaying the Start Page when launching Cisco Transport Planner, check the View Start Page
checkbox.

Step 6 To change the appearance of the Project Explorer tree, click Project Explorer and complete the following
tasks as needed:

• Overlapping—Check to reorder sites for a selected network.

• Alarm Mode—Choose Single for an alarm icon to report only the condition of that item or choose
Cumulated for an alarm icon to summarize the most critical alarm of the item and its children.

• Bottom Right Icon—(Display only) Displays Locking to indicate that the lock icon appears at the bottom
right of each locked item in the Project Explorer pane.

• Top Right Icon—(Display only) Displays Alarm to indicate that the alarm icon appears at the top right
of each alarmed item in the Project Explorer pane. The alarm icon will be green, yellow, orange, or red
to indicate the alarm severity.
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Step 7 To change the NtViewName tab appearance, clickNetwork View and complete the following tasks as needed:

• In the Site area, complete the following tasks:

– Site Color—To set the default site color when no forcing is done, click the drop-down arrow to display
a color swatch popup window. Click the desired color.

–Site Selection Color, and Highlight Color—To change the site colors, click in the Color, Selection
Color, and/or Highlight Color fields in the Site list. Click the drop-down arrow to display a color swatch
popup window. Click the desired color.

– Show Name—Check to display the site name on the NtView Name tab.

– Pass Through, OSC,Add/Drop, Hub, Gain equalizer, R-OADM, LineAmplifier, OXC,OIC, Background
Amplified Color, Background Raman Amplified Span Color—To change the colors, click in the relevant
fields in the Site list. Click the drop-down arrow to display a color swatch popup window. Click the
desired color.

– Show Amplifiers—Check to display the amplifier icon for a site on the NtView Name tab.

– Show Raman Amplified Span—Check to display the Raman amplified span on the NtView Name tab.

• In the Fiber area, complete the following tasks, as needed.

– True wave Reach Color, Dispersion Shifted Color, Metro Core Color, true wave, True Wave Plus
Color, True Wave Minus Color, True wave Classic Color, Free Light Color, LS Color, Tera Light Color,
E LEAF Color, TRUE WAVE RS Color, G 652 SMF Color, and Selection Color—To change the fiber
color, click in the relevant fields in the Fiber list and then click the drop-down arrow.

– Show Name—Check to display the fiber name on the NtView Name tab.

– Show Length—Check to display the fiber length on the NtView Name tab.

– Show total SOL Loss—Check to display start of life (SOL) loss on the NtView Name tab.

– Show total EOL Loss—Check to display end of life (EOL) loss on the NtView Name tab.

– Show CD C-band—Check to display C-band chromatic dispersion (CD) on the NtView Name tab.

– Show CD L-band—Check to display L-band chromatic dispersion (CD) on the NtView Name tab.

The duct details displayed in the NtView Name tab is shown in the following figure .

Figure 9: Duct Details Shown on the NtView Name Tab

• In the Wavelength Usage (%) area, complete the following tasks, as needed.

The ducts in a network carry a predefined number of wavelengths (2, 4, 8, 16, 32, 64, or 80). Wavelength
usage is the percentage of wavelength used by these ducts.

The percentage of wavelength used in individual ducts are displayed in various colors. Use the Wavelength
Usage (%)option to assign any one of the four predefined colors to the different percentage of wavelength
used. The custom values remain until the cache is deleted. After the cache is deleted, CTP populates the
following default values:

– Green—25%
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– Yellow—50%

– Orange—75%

– Red—100%

For example, the wavelength usage in an 80 wavelength duct that uses 40 wavelengths is 50%. This duct is
displayed in yellow.

The valid values range from 1 to 100. If you enter a value greater than 100, it is considered as 100, negative
value is considered as 1, while 0 is ignored.

The ducts that do not carry any wavelength are displayed in grey.

The Wavelength Usage (%) option is not supported on remote spur ducts.Note

For more information on wavelength usage, see Table "Menu and Toolbar Option".

• To change the color of the traffic demands on the NtView Name tab, in the Point To Point, P-Ring, and
Any To Any areas, click in the Color and Selection Color fields, and then click on the drop-down arrow
to display a color swatch popup window. Click the desired color.

Step 8 To change the Network Mgmt Tree tab appearance, complete the following tasks as needed:

• In the Network area, click in the Color and Selection fields. Click the drop-down arrow to display a color
swatch popup window. Click the desired color.

• In the Link area, complete the following tasks:

– To change the link color, click the Color field in the Link list and then click the drop-down arrow.
Choose the desired line width from the drop-down list.

– To change the link appearance, click the Stroke field in the Link list and then click the drop-down
arrow. Choose the desired line appearance from the drop-down list.

Step 9 To change the layout appearance, click Layout View and complete the following tasks as needed:

• In the General area, click in the Background and Selection Color fields. Click the drop-down arrow to
display a color swatch popup window. Click the desired color.

• In the Any/Present View area, complete the following tasks:

– To change the color for Foreground, Locked & Unlocked View, Locked Elements Background, and
Locked Elements Foreground, click the relevant field and click the drop-down arrow to display a color
swatch popup window. Click the desired color.

• In the Alarmed View area, complete the following tasks:

– To change the color for Unalarmed Elements Background, Unalarmed Elements Foreground, and
Alarmed Elements, click the relevant field and click the drop-down arrow to display a color swatch popup
window. Click the desired color.

Step 10 Click Ok.
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Setting the Default Software Release
Use the following procedure to set the default software release for CTP. This release will be used as the default
software release when creating a project. See Creating a Project.

Procedure

Step 1 From the Tools menu, choose Options.
Step 2 In the Options Explorer dialog box click General.
Step 3 In the column on the right, click the Default CTP Software Release option. A drop-down list appears.
Step 4 Click an option in the list to choose the software release.
Step 5 Click Ok.

Setting the Default Platform Values
Use the following procedure to establish the default traffic mapping, dense wavelength division multiplexing
(DWDM) design, and default layout settings for a particular platform and system release. The default settings
appear during project creation. All options that you specify can be changed after project creation on a per-span
basis.

Procedure

Step 1 From the Tools menu, choose Options.
Step 2 In the Options Explorer dialog box, right-click Platform and choose Expand from the shortcut menu.
Step 3 Click the desired System Release folder and complete the following tasks as needed:

Default changes apply only to the specified system release.Note

Choose the required settings:

• ShelfManagement—The options available are Auto,Multi Shelf Integrated Switch,Multi Shelf External
Switch, and Individual Shelf. These options allow you to specify the type of management to be used for
the sites on the network.

– Auto—Sets the default option of the Multi Shelf Switch for all the nodes with more than one shelf. For
M6/M15 chassis, the default option is Multi Shelf Integrated Switch.

– Multi Shelf Integrated Switch—Configures all the Multiservice Transport Platform (MSTP) optical
units (OADMs and amplifiers) in different shelves connected through a LAN. The LAN is implemented
with switches plugged into theMSTP shelves. These switches are used to connect to the external chassis.
For this option, Multi-Shelf Integrated Switch Cards (MS-ISC) are used to support the multishelf
configuration. M15 uses RJ 45 and optical ports to connect to an external chassis.

– Multi Shelf External Switch—Configures all the MSTP optical units (OADMs and amplifiers) in
different shelves connected through a LAN. The LAN is implemented with switches external to the
MSTP shelves.
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For this option, two external Ethernet switch units (Cisco Catalyst 2950 and Cisco Catalyst 3650) are
used to support the multishelf configuration. Cisco Catalyst 2950 supports 12 subtending shelves and
Cisco Catalyst 3650 supports 24 subtending shelves.

CTP supports a maximum of 50 shelves, including the node controller shelf, in a multishelf configuration
when the TNC, TNCE, TSC, TSCE, TNCS, TNCS-2, TNCS-2O, TNCS-O, or TCC3 card is used as the
node controller.

CTP supports a maximum of 5 shelves, including the node controller shelf, in a multishelf configuration
when TCC2P card is used as the node controller.

– Individual Shelf—Configures all the MSTP optical units (OADMs and amplifiers) in the same shelf.

Important Notes for Shelf Management:

a. When you choose Multi Shelf External Switch from the Shelf Management drop-down list, the
multi-shelf external switch is placed in the layout irrespective of the node controller.

b. Shelf management is disabled for HYBRID 15454 ONS configuration from Release 9.1 and later.

c. TheM6 chassis, when used as node controller with Integrated Switch, can support three subtended shelves.
The subtended M6 chassis can subtend two more shelves.

d. The Cisco NCS 2015M15 chassis, controlled by two TNCS cards, can act as a node controller that manages
other subtended M15 shelves. Up to three M15 shelves can be subtended directly to the Primary shelf,
and the number of subtended M15 shelves can be increased up to 10 in a daisy chain connection.

e. In a mixed Multi Shelf Management configuration, M15 shelves can be used as subtended shelves with
M6 as a node controller only when TNCE or TSCE control units are used.

f. Multi Shelf Management mixed configurations can extend up to 25 shelves for M6 and M15 chassis.

g. Multi Shelf Management configurations with M15 as node controller and M6 as subtended shelf are not
supported in CTP 10.5.

h. Multi Shelf Management configurations with M15 and M12 in any combination (node controller or
subtended shelf) are not supported in CTP 10.5.

i. Cisco NCS 2015 as the node controller with NCS 2015 as subtended shelves.

j. Cisco NCS 2015 as the node controller with a mix of NCS 2015, NCS 2006, and ONS 15454 as subtended
shelves.

k. Cisco NCS 2006 as the node controller with a mix of NCS 2015, NCS 2006, and ONS 15454 shelves as
subtended shelves.

l. Cisco ONS 15454 as the node controller with a mix of NCS 2015, NCS 2006, and ONS 15454 shelves
as subtended shelves.

The ONS 15454 shelves must have TCC3 cards installed for the configurations.Warning message
appear if the number of shelves exceed 10 for pure MSM and 15 for mix MSM configuration
that include NCS 2015.

Note

• Node Protection—The options available are Same Shelf, Separated Shelves, and Node Split. Select Same
Shelf to configure the optical units (amplifiers and OADM) on side A (CW direction) and side B (CCW
direction) in the same shelf.

Node protection is disabled for HYBRID 15454 ONS configuration in Release 9.1 and later.Note
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Select Separated Shelves to configure the optical units (amplifiers and OADM) on side A (CW direction)
in one shelf and those on side B (CCW direction) in a second shelf.

• C-band Rules—Select the options from the drop-down list. The options appear in the following format:
C 64 Chs 50 GHz (+2 dBm/Ch). The channels available are 80, 72, 64, 40, 32, 20, 16, and 8; the reference
per channel power options available are -1 dBm, -2 dBm, 1 dBm, 2 dBm, 4 dBm, 5 dBm, 7 dBm and 8
dBm; and the spacing options available are 100 GHz and 50 GHz. You can use even wavelengths for
80, 72, and 64 channel design.

For SSON enabled networks, C-Band options set as Flexgrid.

For HYBRID 15454 ONS configuration, the available options are 8, 16, 20, 32, 40, 48, 64, 72, 80, and
96 channels.

• L-band Rules— Select the options from the drop-down list. The options appear in the following format:
32 Ch. 100 Ghz +5 dBm. The options available are: None, Expand, and channels available are 32; the
reference per channel power options available are 2 dBm and 5 dBm; and the only spacing options
available is 100 GHz.

Select Expand to indicate that the L-band rules are upgradable.

L-band is not applicable to HYBRID 15454 ONS configuration in Release 9.1 and later.Note

• Installation w/o CTP—Check this check box to install the network with default parameters. If you choose
this option, CTP designs the network according to a set of predefined conditions, so that the selected
node can be installed without the Cisco Transport Planner configuration files (thresholds and setpoints).

• Dithering Lower Limit—Enter a value that satisfies the following conditions:

– Not lower than zero

– Not higher than 32

– Not higher than the dithering upper-limit value

The dithering value is the site identifier that CTP uses to adjust power on 80-WXC cards. Dithering value
is provided only for sites with 40-WXC cards, that is, for sites with multidegree site structure and with
the functionality “OXC” or “Auto”. This parameter is not displayed for non-OXC sites.

• Dithering Upper Limit—Enter a value that is not lower than zero and not higher than 32.

• Insulators—Check this check box to protect the Express Add/Drop (EAD) colorless ports of the
80-WXC-C cards configured as demux units.

The Cisco ONS 15216-FLD-2-ISO optical insulator is not supported in CTP Releases 9.3
and later releases.

Note

Optical insulator connections are displayed only in the Patchcord Installation tab in the
Internal Connections report.

Note

• Structure—Choose the site structure from this drop-down list. If the network topology does not support
the selected site structure, then the selection made in this drop-down list is ignored.

• MSM External Switch—Choose the multi shelf external switch type, from the drop-down list.

• Use Payg—Check this check box to enable the Pay As You Grow feature. For more information about
the Pay As You Grow feature, see Understanding the Pay As You Grow Feature, on page 44.

• Service Level—Choose the service level from the drop-down list.
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• Service Level Num of Years—Choose themaintenance service level length (in years), from the drop-down
list.

• Enable NCS—Check this check box to use NCS PIDs. For more information, see table "NCS PIDs".

• Redundant Power—This drop-down list enables you to choose whether the redundant power supply is
to be added.

• UTS AC Power Cables—Choose the type of cables to be used for the AC power supply, from the
drop-down list. Cables are listed based on the country type. M15 does not support AC power supply.

• Filler Card Type—Choose the type of card to be placed in the empty slots of a chassis, from the drop-down
list. The options available are:

– Blank—CTP places only blank cards.

– UTS Filler—CTP places blank cards inM12 chassis and Universal Transport System (UTS) filler cards
in theM2 andM6/M15 chassis. The two type of UTS filler cards placed by CTP are 15454-M-T-FILLER
(in TNC and TSC card slots) and 15454-M-FILLER (in other slots).

• Node Controller—Choose a chassis to act as the node controller, from the drop-down list.

• M6 Chassis in Use—Enter an integer value for the number of M6 chassis to be used.

• M12 Chassis in Use—Enter an integer value for the number of M12 chassis to be used.

• Redundant Controller Card—This drop-down list enables you to choose whether to use a redundant
controller card.

• Side/Side cabling—Choose the loss value between the west and east side of the site, from the drop-down
list. It is useful in case of multi shelf node protection when the racks are not located close to each other.

• Anti ASE— The options available in the drop-down list are:

– Auto—CTP decides if the site should be configured as anti-amplified spontaneous emissions (anti-ASE).

– Yes—The site is configured such that all the express channels on the site are optically dropped and
reinserted. In addition, all the patch cords between the West and East sections are removed.

– No—The site is not configured as anti-ASE.

Step 4 Click the Layout folder and complete the following settings as required:

• OSMINECompliant—Check this check box to instruct CTP to ensure that all the sites placing transponder
and line cards are compliant with OSMINE.

OSMINE is supported in R9.2.1 and R9.6.0.x only.Note

• Hybrid Node—Check this check box to notify CTP to ensure that cross-connect, SDH, and SONET cards
are not placed within the optical transport section (OTS) shelf.

• Max Num of Shelves—Specify the maximum number of shelves per rack. The maximum number of
shelves you can specify is 4.

• Fan Tray—Select the type of fan tray to be placed within each node, from the drop-down list.

• AIC—Choose Yes from the drop-down list to instruct CTP to put the AIC card in slot 9 of the first shelf
in each site.
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• Fiber Storage—Choose Yes from the drop-down list to instruct CTP to put the fiber storage within the
rack below the optical shelf.

• Y-Cable—The the Y-cable options from the drop-down list. The options available are:

– Auto—Instructs CTP to set the default value for the Y-Cable option.

– 1RU FlexLayer Shelf Assembly—Instructs CTP to use the ONS 15216 Splitter/Combiner FlexLayer
modules to implement the required Y-cable protections.

– 2RU Y-Cable Panel—Instructs CTP to use the new ADC Splitter/Combiner modules to implement the
required Y-cable protections.

• TXP/MXP/XP in OTS—The options in the drop-down list enable you to choose whether to place client
cards in OTS shelves.

• Etsi Rack Width—Choose the ETSI rack width from the drop-down list. The 19 inches option adds
15454E-19IEC-KIT for each ETSI shelf.

• Rack Height in RU—Enter an integer value for the rack height. The default option is Auto, which assigns
44 rack units (RU) for ANSI and 40 RUs for ETSI.

• Alien Shelf Height—Enter the height of the alien shelves in RU. If the alien shelf height is greater than
the rack height, alien shelves will not be added to the site, and an error message will be displayed in the
summary report.

• Number of Alien Shelves—Enter the number of alien shelves that are to be added to the site.

Number of alien shelves can vary based on the alien shelf height. Maximum number of alien shelves that
can be added is 600, if the alien shelf height is 1 Rack Unit (RU) and there are no other shelves in the
layout.

The maximum number of racks supported for a site is 15. If the addition of alien shelves require more
than 15 racks, an error message will be displayed in the summary report and the layout is not built for
the site.

• Alien Shelf Name—Enter the name of the alien shelves that are added to the site. This name will be
displayed in the Layout reports.

• Populate Shelves From Bottom—Check this check box to notify CTP to place the shelves in the rack
starting from the bottom. This is useful in installing shelves in tall racks. For more information about the
order in which CTP fills the rack, see theGeneral Placement Rules.

• Chassis Type—Choose the type of chassis from the drop-down list. The options available are Auto, M12
Chassis, M6 Chassis, M15 Chassis, and M2 Chassis. The default option is Auto, which selects
combinations of the chassis in an optimized manner.

• Power Supply—Choose the type of power supply from the drop-down list. The options available are
Auto, AC Power, AC2 Power, DC Power, DC20 Power, and DC40 Power. FromRelease 10.1, the default
option is Auto (DC40). M2 does not support AC2 Power.

The AC2 power cables are present in the BoM only when AC2 Power and Auto or AC2
Power and Data Center options are selected in the Power Supply and UTSAC Power Cables
sections respectively.

Note

• TCC Type (Release 9.4 and later releases)—Choose the type of TCC card from the drop-down list. The
options available are Auto, TCC2P, and TCC3. The default option is Auto, which selects the TCC3 card.
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When used as the node controller, the M12 chassis with TCC2P cards cannot subtend the
M6 chassis.

Note

• M6/M2 Controller Type—Choose the type of controller card from the drop-down list. The options
available are Auto, TNC/TSC, TNCS-O, TNCS, TNCS-2, TNCS-2O, and TNC-E/TSC-E. The default
option is Auto, which selects the TNC-E/TSC-E card applicable till R10.9 and the TNCS-2 card from
R11.0 onwards.When you choose TNCS-O, it is configured for the node controller and not the subtended
shelf.

You can select a different M2/M6 controller type for a network in the release upgrade or
upgrade state by unlocking the TSCE/TSC or TNCE/TNC card in the site layout.

Note

• M15 Controller Type—Choose the type ofM15 controller from the drop-down list. The options available
are Auto, TNCS-O, TNCS-2, TNCS-2O, and TNC-S. When you choose TNCS-O, it is configured for
the node controller and not the subtended shelf. The default option is Auto, which selects the TNC-S
card applicable till R10.9 and the TNCS-2 card from R11.0 onwards.

• M15 Chassis in Use—Enter an integer value for the number of M15 chassis to be used.

• Redundant power scheme—Choose the redundant power scheme from the drop-down list. The options
available are 1+1, 2+1, 3+1, 2+2. You can choose the redundant power scheme to configure the number
of working and protected power units for the chassis. 3+1 is the default redundancy power scheme for
M15 DC chassis and 2+2 is the default redundancy power scheme for M15 AC chassis.

For example, if you choose 3+1 redundant power scheme, there will be 3 working power units and 1
protected power unit.

• SFPs for multi-chassis—Specify the number of small form-factor pluggables (SFPs) that you want to
use for Multi Shelf Management configuration. The number of SFPs you specify here will appear in the
BOM.

• MSMM15 Pluggable—Choose the type of SFP pluggable from the drop-down list. The options available
are Auto, ONS-SI-100-FX, and ONS-SI-100-LX10. The default option is Auto, which is ONS-SI-100-FX
optical pluggable. This option is applicable only for M15 optical MSM port.

• DCC Shelves Management—Check this check box to notify CTP to reserve Slot 12 for equipping
15454-MR-L1 units to implement data communication channel (DCC) shelf management.

• Door—Choose the type of door from the drop-down list. The default option is Auto, which does not add
any door type. Door and deep doors are two types of front doors that act as protective panels in the ONS
15454 M2, ONS 15454 M6, and NCS 2015 M15 chassis. The deep door provides additional space in
front of the shelf to accommodate cables that do not fit inside the standard door.

• M12 Shelves—Enter an integer value for the number of empty M12 shelves to be added to the node
layout. CTP supports a maximum of 29 extra M12 shelves. The default option is Auto, which does not
add any shelves.

• M6 Shelves—Enter an integer value for the number of empty M6 shelves to be added to the node layout.
CTP supports a maximum of 29 extra M6 shelves. The default option is Auto, which does not add any
shelves.

• M2 Shelves—Enter an integer value for the number of empty M2 shelves to be added to the node layout.
The default option is Auto, which does not add any shelves.

• M15 Shelves—(Release 10.5 and later releases) Enter an integer value for the number of empty shelves
to be added to the node layout. The Auto option does not add any shelves.
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The above values are applied to all the sites in the newly created network. The values can be modified
for individual sites after the network creation.

Step 5 Click theRestricted Equipment folder. To restrict a unit, check the corresponding check box in the Restricted
column for that unit.

To change the setting back to unrestricted, uncheck the check box. To apply restricted list changes to an open
project, complete the following:

a. Right-click the folder for the network that you want to update and chooseExpand from the shortcut menu.

b. Right-click the desired platform and release folder under RestrictedEqptListFolder in the Project Explorer
pane and choose Edit List from the shortcut menu. The Restricted Equipment list for ONS 15454 MSTP
or NCS2000[Release Number ] dialog box appears.

c. Click Update. The modified Restricted Equipment List is replaced with the global restricted equipment
List.

d. Click OK to close the dialog box.

Step 6 Click theFiber Options folder and specify the fiber parameters as required:

• Span Label Tag—Enter the desired span label; the default label is Duct.

• Span Length—Enter the span length. The displayed unit of measure is retrieved from the Span
Measurements Units field.

• EOL Ageing loss [dB]—Enter the EOL aging loss value. The EOL loss-per-span value is added at the
end of life to each discrete fiber in the network (for example, to add an EOL margin for splicing).

• EOL Ageing Factor—Enter the number to use when factoring fiber aging. This factor is multiplied by
the SOL total span loss without connectors.

Enter a value in either EOL Ageing Factor or EOL Ageing loss; you do not need to enter a
value in both fields.

Note

• Connector loss [dB]—Enter the concentrated loss at the end of the span.

• Length Based Loss—If checked, the fiber loss is determined by multiplying the Span Length by the Loss
Factor. If this check box is unchecked, you must enter the total loss of the span.

• Tot SOL loss w/o conn [dB]—Enter the total start of life (SOL) link fiber loss value for each span,
excluding the connector concentrated loss. This value is applicable only if the Length Based Loss check
box is unchecked.

• DCN Extension (With Software R8.0 and later releases)—Check this check box to enable the default
use of data connection network (DCN) extension on each span in the project. This setting implies that
the OSC channel is not used to connect the two nodes. This default can be overridden on the network
wizard pane.
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Use one of the following formulas to calculate the fiber loss at SOL:

SOL = km * dB/km + (2 * connector loss)

SOL = user entered loss + (2 * connector loss)

Use one of the following formulas to calculate the fiber loss at EOL:

EOL = km * dB/km * EOL Aging Factor + (2 * connector loss) + EOL Aging Loss, or

EOL = user entered loss * EOL Aging Factor + (2 * connector loss) + EOL Aging Loss

Note

• Select the Fiber Type of each span of the network. You can specify a fiber type even if the fiber
type is not supported for the design.

• PMD at Fiber—Enter the polarization mode dispersion (PMD) value. PMD is always entered in
ps/nm/km.

• Loss—Enter the value of the SOL fiber loss per kilometer used to calculate the loss of each span
in the network. The fiber loss factor is always entered in dB/km.

Step 7 Click the Traffic Mapping folder and complete the following tasks as needed.

• In the Fixed traffic area, choose the unprotected routing strategy from the drop-down list:

– Auto— CTP automatically selects the minimum number of channels that can be deployed among the
nodes of the traffic group.

– Unprotected optimum optical path—Each node pair is connected using one connection. The unprotected
optimum optical path minimizes the number of required optical amplifiers.

– Unprotected minimum hop count—Each node pair in the traffic group is connected by one connection.
The unprotected minimum hop count minimizes the number of channels (for unprotected traffic types
only) that can be deployed among the nodes of the traffic group.

• In the General area, complete the following tasks as needed.

– Force Mesh Algorithm—For CTP Software Release 8.5, check this check box to force the mesh
algorithm.

– Allow Different Wavelengths—Check this check box to allow different wavelengths to be used for
regeneration.

– Coloring Priority Option—Check this check box to assign the wavelength from the left side of the
available band, that is, from 1528.7 nm. If this option is unchecked, the wavelength is assigned from the
right side of the available band, that is, from 1566.7 nm.

– Flat Grid Filling Option—Check this check box to assign the wavelength in a flat grid, allocating each
free wavelength without any guard band. If this option is unchecked, the wavelength is assigned according
to the actual assignment rules.

Guard band is an unused part of the wavelength spectrum, for the purpose of preventing
interference between the wavelength channels.

Note

– Maximum Separation Option—Check this check box to assign the wavelengths for 40 G and 100 G
CP-DQPSK service types from the first wavelength in the C-band (1528.7 nm) and for other service
types from the last wavelength of the C-band (1566.7 nm) to overcome interference in demands where
the wavelength selection is set to Auto.
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– Activate AR-XPE—Check this check box to use the AR-XPE card in the network. When this option
is checked, the AR-XP card is replaced by the AR-XPE card in the exported BoM report. The AR-XPE
card does not support the client PAYG license. When the Activate AR-XPE check box is checked,
uncheck the Use Client Payg check box in the Properties pane to avoid error during network analysis.

Step 8 Click the DWDM Design Rules folder and complete the following tasks as needed:

• OSNRAlarm For Regeneration—Check this check box to define the optical signal-to-noise ratio (OSNR)
alarm severity. When this limit is reached, CTP suggests a channel at an appropriate site on the network.
After the network is designed and analyzed, in the Tasks pane (under Reports), click Optical Results to
see if any site requires regeneration. The regeneration column will suggest the site where Regeneration
is required.

• Run Quick Analysis—Check this check box to use a quick but less accurate algorithm to analyze the
network in a short time. After the analysis, Cisco Transport Planner displays the following warning
message: “Dcu design not optimized due to Run Quick Analysis option.”

• No-Tilt-Network-Design—Check this check box to force Cisco Transport Planner to operate the amplifiers
inside the gain range where no tilt is generated and to determine the type and number of amplifiers in
each site of the network accordingly. This option sets all the intermediary points of the network so that
channels are always at the reference power level. The default value is Disabled.

Long spans (with insertion loss greater than 25 dB) might not be supportable.Note

• No In-line Bulk Attenuator Design—Check this check box to design the network without using any inline
bulk attenuators. If the network cannot be designed without using external in-line attenuators, Cisco
Transport Planner displays the following error message: “Unfeasible Network design. Site X should
require usage of in-line attenuator. Leave unchecked to allow inline bulk attenuators.”

• No TXT/Line-Card Bulk Attenuator Design—Check this check box to design the network without using
any external receive (Rx) bulk attenuators on transponder or line cards. If any of the clients require Rx
bulk attenuators, then the related channel is shown with the working condition (flagged red, orange, or
yellow). No Rx bulk attenuator will be shown in any of the reports (such as Optical Channel Results,
Internal Connections, or BoM). Leave unchecked to allow bulk attenuators.

• Prevent Use of E-LEAFDispersion CompensationUnit on E-LEAFDispersion spans—Check this check
box to prevent Cisco Transport Planner from using Extended -Large Effective area fiber (E-LEAF)
dispersion compensation units (DCUs) on E-LEAF spans for the overall network. Leave unchecked if
you want the algorithm to automatically optimize the usage of the E-LEAF DCUs.

• No DCU Design—Check this check box to avoid automatic placement of DCU units.

• Max Scalability Placement —Check this check box to scale up or expand the network made in your
network design. You can add new sites and demands depending on your requirements, thus, CTC
automatically creates the flexibility of the possible expansion of your network. It also checks to force
the CTP to choose an EDFA/DCU placement that is best suited for future expansion of the designed
network without any hardware changes.

• TDCU—From the drop-down list, select one of options to place the TDCU units (TDCU Coarse and
TDCU Fine) in the network are:

– Auto—Places the fixed DCU units in the network.

– All Positions—Places the TDCU units wherever the fixed DCU units can be placed.

– Never Place—Does not place the TDCU units in the network.
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– Selected Positions—Places the TDCU units in ROADM, WXC, and Dynamic Gain Equalizer (DGE)
nodes.

• FDCU—From the drop-down list, select one of the options to place the FDCU units in the network.

– Auto—Places standard DCUs in the network, automatically. The FDCU option can be set to “Always”
at the network level for a specific network. FDCU units can also be forced on specific nodes in the
network.

– Always—Places the FDCU units in the network. The FDCU option for new networks is set to “Always”.
Standard DCUs are placed if FDCU units are not available. Standard DCU units can also be forced on
specific nodes in the network.

• Turbo Simplex—Check to achieve faster results by optimizing a subset of the total channels based on
type and path rather than optimizing every channel. Unchecking this option can result in longer analysis
times for large networks, especially with any-to-any ROADM traffic.

• Max Sc Value—Enables you to enter the maximum slope compensation value.

• Enable Connector Loss—Check this check box to apply the default connector loss values to the fiber.
The applied value depends on the type of site where the fiber is connected:

• Pass through Connector Loss—Enter the connector loss value for a pass-through site.

• OXC Connector Loss—Enter the connector loss value for an OXC site.

• ROADM Connector Loss—Enter the connector loss value for a ROADM site.

• OSC Connector Loss—Enter the connector loss value for an OSC site.

• Line Amplifier Connector Loss—Enter the connector loss value for a line amplifier site.

The Pass through Connector Loss, OXC Connector Loss, ROADM Connector Loss, OSC
Connector Loss, and Line Amplifier Connector Loss properties are enabled only if the Enable
Connector Loss check box is checked.

The values of these properties can also be specified in the Properties pane for the
Options>DWDM Design Rules>System Release option in the Project Explorer pane and
are applicable to the current network.

Note

Step 9 Click OK.

Setting the Default Project Values
Use the following procedure to set the default project settings and repair time. These defaults will appear
during project creation.

Procedure

Step 1 From the Tools menu, choose Options.
Step 2 In the Options Explorer dialog box, click Project and complete the following tasks to set the defaults that

appear in the Project Creation wizard:
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• Customer—Enter the default customer name (128-character maximum).

• Created by—Enter the default user name (128-character maximum).

• Measurement Units—Choose the default span length unit of measure from the drop-down list, either
Km or Miles.

• Price List—Choose the default price list.

• Restricted Analysis—Check to use Restricted Analysis in the project.

• ANSI/ETSI—Choose either ANSI (American National Standards Institute) or ETSI (European
Telecommunications Standards Institute) from the drop-down list.

Step 3 Click General and complete the following tasks:

• MTTR (hours)—Enter the mean time to repair (MTTR) for all sites in the network. This value will apply
to every site in the network. If you change the MTTR value after creating sites, the new value will only
apply to sites you create after the change.

• Restocking Time (days)—Enter the number of days required (including transportation time) to restock
the units into the maintenance center.

• Confidence Level (%)—Choose the confidence level for finding the spare units in the maintenance center
(50, 75, 95, or 99 percent).

• Default CTP Software Release—Choose a release to be set as the default CTP software release. This
release will be used as the default release when creating a project. See Creating a Project.

• Wavelength Display—Select your preference for wavelength display.

• Hide Network Details—Check this check box to hide network details.

• View FEC Mode Correction Messages—Check this check box to view FEC mode correction messages.

• View Copy Operation—Check this check box to view the copy operation details.

• View Upgrade Operation—Check this check box to view the upgrade operation details.

• View Release Upgrade Operation—Check this check box to view the release upgrade operation details.

• View Upgrade To Design Operation—Check this check box to view the upgrade to design operation
details.

• View High Latency Messages—Check this check box to view the high latency details.

Step 4 Click BoM and complete the following:

• Use Bundles—(Multishelf configuration only) Check this check box to use the Multishelf Management
Integrated Kit bundle when generating the BoM instead of the single items. As a bundle, a common price
is quoted, which is lesser than when the items are listed individually.

• Use Global Discount—Check this check box to allow you to edit the discount box (Global Discount).

• Global Discount—Enter the global discount to be applied to the whole BoM.

• Use Client Payg—Check this check box to include license for client cards. This option is applicable to
AR-MXP, AR-XP, 100G-LC-C, 100G-CK-LC-C and 10X10G-LC cards. This check box is checked by
default.
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• Enable NCS—Check this check box to use NCS PIDs. For more information, see table "NCS PIDs".

• Include SW License(s)—This check box is checked by default. The software license for the release is
shipped with the Cisco ONS 15454 chassis.

• Include Paper Documentation—Check this check box to ship paper documentation separately with the
product and listed in BoM.

• Include CDDocumentation—Check this check box to ship CD documentation separately with the product
and listed in BoM.

• Hide BoM price/discount—Check this check box to hide the BoM discount and the individual unit price.
Only the final price is displayed.

• WSON PID—Check this check box to display the WSON PIDs in the BoM report.

• Service Level—Choose the service level from the drop-down list.

• Service Level Num of Years—Choose the maintenance service level length (in years) from the drop-down
list.

Step 5 Click OK.

Defining Third-Party DWDM Interfaces
Cisco Transport Planner allows you to define a third-party DWDM interface to be used in project creation.
After you define third-party DWDM interfaces, you can choose them when creating traffic demands. For
more information on defining third-party interfaces, see Appendix D, Third-Party DWDMWavelength
Interface Model.

If you create a network design with a third-party interface and need to share the design with other users, you
must provide not only the saved networkMPZ file but also the exported database file containing the third-party
interface definition. To view this project, the other user first must import the database with the third-party
interface values.

Note

Use the following procedure to define a third-party DWDM interface:

Procedure

Step 1 Click Tools > DB Parts Mgmt. The DB Parts Manager dialog box appears.

You cannot open the DB Parts Manager if a project is open or if you are using the Base Network
Designer profile.

Note

Step 2 Right-click Platform Parts and choose Expand from the shortcut menu.
Step 3 Right-click Group and choose New Group from the shortcut menu. The new group appears under Group

and in each system release under parts DB.
Step 4 In the Group Editor dialog box, complete the following information:
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• Name of group—Enter the name of the new database.

• Note—(Optional) Enter a description of the group.

Step 5 In the parts DB for the desired system release, click the group that you created.
Step 6 In the Parts tab of the DB Parts Manager dialog box, right-click and choose Client and then Alien from the

shortcut menu. A new row appears on the Parts tab for the client hardware.
Step 7 Double-click the row to open the Alien dialog box.
Step 8 In the General tab of the Alien dialog box, type the name of the card in the Name field and the enter the Label

name.
Step 9 Click the Istance tab and complete the following:

• Ansi PID—Enter the product identifier of the ANSI system, as needed. If you select BoM visible for this
third-party interface with ANSI PID completed, the third-party interface is included in the BoMwith the
related product identifier.

• Etsi PID—Enter the product identifier of the ETSI system, as needed. If you select BoM visible for this
third-party interface with ETSI PID completed, the third-party interface is included in the BoM with the
related product identifier.

• TAG—(Display only) For internal use.

• SYS. NAME ANSI—Not applicable for third-party interfaces.

• SYS. NAME ETSI—Not applicable for third-party interfaces.

• WL START—Choose the wavelength starting range that the third-party interface supports from the
drop-down list.

• WLEND—Choose thewavelength ending range that the third-party interface supports from the drop-down
list.

Step 10 Click the Physical Ports tab and in the Label column, type a label for each port.

The CTC Ports and TL1 Ports tabs are not applicable for third-party interfaces.

Step 11 Click Ok.
Step 12 In the Parts tab of the DB Parts Manager dialog box, right-click and choose Software and then Alien from

the shortcut menu. A new row appears on the Parts tab for the client software.
Step 13 Double-click the row to open the AlienSoft dialog box.
Step 14 In the General tab, complete the following:

• Name—Enter the name in the Name field.

• Related Item—Choose the client card that you created in Step 7 to Step 11.

Step 15 Click any of the following depending on the client card that you choose and proceed to Step 16:

• Default - OCh tab

• DPSK-OCh tab

• QPSK-OCh tab
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Step 16 Complete the following:

• In the Rules area, choose the C-band or L-band design rule from the Design Rule drop-down list or it
can be Auto

• In the Technology area, complete the following:

–Modulation Format—Choose the desired modulation format from the drop-down list.(see "Transmitter
characteristics" under Interface Operative Area)

– Transmitter Type—Choose MZ (Mach Zehnder), DML (Direct Modulated Laser), or EML
(Electro-absorption Modulated Laser).

– Receiver Threshold—Choose Optimal (minimum BER) or Average (average received power).

For DPSK—Choose the Receiver Threshold as Optimal.

For QPSK—Choose the Receiver Threshold as Average.

– Regeneration Type—Choose 3R or 2R regeneration mode.

– FEC Mode—Choose FEC (Forward Error Correction), no FEC, E-FEC (Enhanced FEC),HG-FEC
(High-Gain FEC) or SD-FEC(Soft-Decision FEC, having different overhead percentage options). For
DPSK or QPSK, set the FEC Mode to E-FEC.

– Transmitter Stability—Choose the maximum wavelength error allowed (pm). The values are 12.5, 25,
50, or 100 pm.

-Oper Mode—Choose the desired operating mode from the drop-down list.

-BER Target—Enter the appropriate BER Target.

• Bit Rate—Choose 2.5 Gb/s, 4.5 Gb/s, 10 Gb/s, 40 Gb/s, 50 Gb/s, 112 Gb/s, 125 Gb/s, 150 Gb/s, 200
Gb/s, 250 Gb/s, 300 Gb/s, 400 Gb/s, 500 Gb/s or 600 Gb/s.

• In the TX Power Range area, complete the following:

– TX Max Power—Enter the maximum power output level (dBm).

– TX Min Power—Enter the minimum power output level (dBm).

• In the Back to Back Receiver Sensitivity area, complete the following as needed to define the working
interface area for Back to Back. Back to Back is a configuration where the receiver is placed in front of
the transmitter and no other equipment exists between the two. Back to Back is used to measure
characteristics of the TX and RX pair. See Figure "Interface Operative Area".

– Overload Power [ps/nm]—Enter the overload power level.

– OL_Power [dBm]—Enter the minimum power level in the OSNR-limited range.

– OL_OSNR [dB] on 0.5 nm RBW—Enter the minimum OSNR level in the OSNR-limited range
(measured on 0.5 nm bandwidth).

– PL_Power [dBm]—Enter the minimum power level in the power-limited range.

– PL_OSNR [dB] on 0.5 nmRBW—Enter theminimumOSNR level in the power-limited range (measured
on 0.5 nm bandwidth).

• In the Chromatic Dispersion area, complete the following as needed:

– Customize CDRobustness—Check to enable the CDRobustness field, as needed. Chromatic dispersion
(CD) refers to the broadening of a light pulse after traveling a distance in the fiber.
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– CDRobustness [ps/(nm*km)]—If Customize CDRobustness is checked, choose the maximum positive
dispersion, Dmax_pos [ps/(nm*km)], tolerable by the interface: 0 dB, 1 dB, 1.5 dB, 2 dB, or 3 dB.

• Customize Penalties—Check to enable the Gaussian cross-talk Penalties, Single-Interfering Cross-Talk
Penalties, and Scale Q factors fields as needed.

• If Customize Penalties is checked, enter the values to determine the Gaussian cross-talk Penalties in the
A_GXt and B_GXt fields, as needed. Gaussian cross talk refers to random power that interferes with a
signal. The A_GXt and B_GXt values are the coefficients for the exponential curves that estimate
P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for Gaussion cross-talk
levels in the OL and PL regions of the interface model with dispersion margins added (see Figure
"Interface Operative Area"). The formula is Penalty (GXt) = A_GXt * exp(B_GXt *GXt).

• If Customize Penalties is checked, enter the values to determine the Single-Interfering Cross-Talk Penalties
in the A_SIXt and B_SIXt fields, as needed. Single-interfering cross talk refers to interference caused
by a single signal. The A_SIXt and B_SIXt values are the coefficients for the exponential curves that
estimate P-penalty (PL), P-penalty (OL), OSNR-penalty (PL), and OSNR-penalty (OL) for
single-interfering cross-talk in the OL and PL regions of the interface model with dispersion margins
added (see Figure "Interface Operative Area"). The formula is Penalty (IXt) = A_SIXt* exp(B_SIXt*
IXt).

• If Customize Penalties is checked, enter Scale Q values in the F-P(PL), F-P(OL), F-OSNR(PL), and
F-OSNR(OL) fields, as needed. The scale factors measure how efficient a card is in recovering the signal
distortion. The slope of the Q-factor curve versus OSNR or RX power determines how a BER increase
could be recovered with an increase of OSNR, power, or both (depending in which OSNR/power working
point the card is). In general, the scale factors are two values (one in OSNR and one in power) for each
working point OL and PL of the interfacemodel (see Figure "Interface Operative Area"). The the F-P(PL),
F-P(OL), F-OSNR(PL), and F-OSNR(OL) values translate a Q-penalty (that is, a BER increase) into
power and OSNR penalties. The formulas follow:

– P-penalty(PL) = Q-penalty * F-P(PL)

– P-penalty(OL) = Q-penalty * F-P(OL)

– OSNR-penalty(PL) = Q-penalty * F-OSNR(PL)

– OSNR-penalty(OL) = Q-penalty * F-OSNR(OL)

F-P(PL) and F-OSNR(PL) are evaluated in the PL working region, while F-P(OL) and F-OSNR(OL)
are evaluated in the OL working region of the curve with the dispersion margins added.
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Figure 10: Interface Operative Area

Step 17 Click Ok.

The following table lists the supported combinations for 40-Gbps third party interfaces.

Table 1: Supported Combination for 40-Gbps Third-Party Interface

Chromatic Dispersion Penalties [dBm]TX
Stability
[pm]

FECRX
Threshold

TX TypeModulation
Format

OSNR-penalty
(PL)

P-penalty
(PL)

OSNR-penalty
(OL)

P-penalty
(OL)

1010± 12E-FECOptimalMZDuo
Binary

The following table lists the supported combinations for 10-Gbps third party interfaces.

Table 2: Supported Combinations for 10-Gbps Third-Party Interface

Chromatic Dispersion Penalties [dBm]TX
Stability
[pm]

FECRX
Threshold

TX TypeModulation
Format

OSNR-penalty
(PL)

P-penalty
(PL)

OSNR-penalty
(OL)

P-penalty
(OL)

0120± 25E-FECOptimalMZNRZ

011.50± 25FECOptimalMZNRZ

0202± 25no FECAverageMZNRZ

0330± 100no FECAverageEMLNRZ
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The following table lists the supported combinations for 2.5-Gbps third party interfaces.

Table 3: Supported Combinations for 10-Gbps Third-Party Interface

Chromatic Dispersion Penalties [dBm]TX
Stability
[pm]

FECRX
Threshold

TX TypeModulation
Format

OSNR-penalty
(PL)

P-penalty
(PL)

OSNR-penalty
(OL)

P-penalty
(OL)

0220± 25FECAverageDMLNRZ

0220± 25no FECAverageDMLNRZ

0303± 25no FECAverageDMLNRZ

3333± 25no FECAverageDMLNRZ

0220± 25no FECAverageEMLNRZ

0330± 100no FECAverageDMLNRZ

Exporting User Options, Price Lists or Alien Definitions
Use the following procedure to export user options, price lists, maintenance contracts, and the parts database
files. The export command creates a ZIP file that includes all of the created files.

Procedure

Step 1 From the Tools menu, choose Export. The Export dialog box appears.
Step 2 In the Export dialog box, enter a file path and name in the file name field. To export to an existing file, click

the ... button and navigate to the desired folder and file. Click Select to choose the file.
Step 3 To select the items to export, complete the following as needed:

• User Option—Check to export the user options set using the Tools > Options command.

• PartsDB—Check the desired platforms.

• PriceDB—CheckAll Price DB to export all price lists, or expand All Price DB and check the individual
price lists that you want to export.

Step 4 Click Ok.

Importing User Options, Price Lists or Alien Definitions
Use the following procedure to import user options, price lists, maintenance contracts, and the parts database
files. You can import a ZIP file of multiple exported items or an individual TXT file.
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Procedure

Step 1 From the Tools menu, choose Import. The Import dialog box appears.
Step 2 In the Import dialog box, click the ... button and navigate to the desired folder and file. Click Select to choose

the file to import.
Step 3 Click load.
Step 4 If you selected a single TXT file, skip this step and go to Step 5. If you selected a ZIP file with multiple

exported options, complete the following as needed:

• User Option—Leave checked to import a file with the user options that were set with the Tools > Options
command.

• PartsDB—Leave checked to import the parts database for the desired platform.

• PriceDB—Leave All Price DB checked to import all price lists, or uncheck and check the desired
individual price lists.

Step 5 Click OK.
Step 6 In the confirmation dialog box, click OK.

Importing the OSMINE Configuration File
The OSMINE configuration updates are provided in an OSMINE configuration file. When a new OSMINE
configuration file is available, use this procedure to import it. The networks analyzed after the import operation
will be OSMINE compliant as per the configurations provided in the OSMINE configuration file.

Procedure

Step 1 From the Tools menu, chooseOSMINE File Import. The Select OSMINEConfig File dialog box is displayed.
Step 2 Browse and select the OSMINE configuration XML file.
Step 3 Select the MSTP release from the drop-down list.
Step 4 Click OK. The new configuration is loaded into CTP.

Resetting the Default Layout
Your graphical layout settings are saved when you exit Cisco Transport Planner. The next time that you launch
Cisco Transport Planner, the layout appears as it did upon exiting. The default graphical layout includes items
such as whether the panes are visible and/or docked.

To return to the Cisco Transport Planner default layout, choose Default Layout from the View menu. To
restore the user modified layout, choose My Default View from the View menu.
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Adding User Profiles
A user profile is a set of privileges used for running Cisco Transport Planner. Each profile offers different
capabilities. Cisco Transport Planner is packaged with the Network Designer profile, but you can add other
user profile types provided by Cisco. All the procedures in the Cisco Transport Planner DWDM Operations
Guide are written for users with Network Designer access.

Use the following procedure to add a user profile to Cisco Transport Planner:

Procedure

Step 1 Close all open instances of Cisco Transport Planner.
Step 2 Identify the folder where Cisco Transport Planner is installed on your computer, see Launching the Cisco

Transport Planner, on page 15, section on page 1-16.
Step 3 Create a profile folder; if profile folder already exists, go to Step 4.
Step 4 Copy the profile JAR file provided by Cisco Systems into the profile folder.
Step 5 Launch Cisco Transport Planner. For more information, see Launching the Cisco Transport Planner, on page

15, section on page 1-16. The new profile will appear in the Current Selected Profile drop-down list.

Understanding Sides Labeling
In Cisco Transport Planner Software R8.5 and later, the label for each supported site structure is different
from the labels that have been used in the previous releases. The following table summarizes the labeling
format in Cisco Transport Planner.

Table 4: Sides Labeling in Cisco Transport Planner

Default labeling in Cisco Transport Planner
Software R8.5 and later

Labeling in Previous
Releases

Sites

Label A is used for the existing side.Only one side is created and
labeled, T.

Terminal/Terminal+

Labels A and B are used for the existing sides.Two sides are created and
are labeled, West and East.

Line/Line+

Labels A, B, C, and D are used for the existing
sides.

—Multidegree with
PP-MESH-4

Labels A, B, C, D, E, F, G, and H are used for the
existing sides.

—Multidegree with
PP-MESH-8

Labels Aw and Ap are used for the existing sides,
where w stands for working and p stands for
protection.

—PSM Line

Labels Aw and Ap are used for the existing sides,
where w stands for working and p stands for
protection.

—PSM Section
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The default labels applied to the sides can be edited. For more information about editing side labels, see Editing
Side Labels.

Note

New Naming Convention for Contentionless sides

New naming convention is introduced in CTP Release 10.6.2 and applicable for Release 10.5.2 onwards.

The new naming convention is enabled by default for the new designs. For the existing network, follow the
below steps to enable the new naming convention for the sides.

1. Unlock the Net.
2. Right click the Net, and select Side naming convention.

New naming convention is applicable for flex nets only.

For MSTP nets the naming convention is disabled and uneditable.

Note

• If you enable the new naming convention then the Layer-1 sides will be named from T, S, R, Q, P, O,
N, M, L, K, J, I, H, G, F, E and index depending upon the used Scalable Upto parameter.

• To use Layer-2 sides new naming convention, you must enable the Layer-2 flag.
• The Layer-2 sides are named from AA to AT, as maximum of 20 sides can be created per site.
• Demand level forcing option is applicable for both contention-less side and extended sides (layer-2 sides).

Layout template support is extended for Layer-2 SMR with new sides are as follows:

Contention-less Side Ordering
(Default as per Convention)

Line Side Ordering (Default as per
Convention)

Scalable Up to Degree

T to E [4 - 19]A to D [0 - 3]4

T to I [8 - 19]A to H [0 - 7]8

T to M [12 - 19]A to L [0 - 11]12

T to Q[16 - 19]A to P [0 - 15]16

To apply the new naming convention on an existing network, you must unlock the net, enable the "Naming
convention Flag" and reanalyze the network.

To enable Layer-2, unlock the net, enable New naming Convention (if disabled), set Site forcing Functionality
as OXC, Structure as Multidegree, Type as SMR-20, and enable Layer 2 Flag under site properties.

In special cases with Degrees 4 and EvolvedMesh OFF, the maximum contentionless sides that can be achieved
are 17, you need to disable both the Evolved Mesh and the New Naming convention to get the 17th
contentionlesss side.

Note
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From CTP Release 11.0, Layer-2 SMR flag can be enabled on the SSON Network. However, Layer 2
Contentionless Support on the Network is not enabled.

Note

Understanding Hybrid Configuration
Typically a node has ONS 15454 MSTP configuration with add/drop units like 40-MUX-C/40-DMX-C1,
ROADM units and so on. However, the node configuration can also have ONS 15454 amplifiers along with
ONS 15216 FlexLayer add/drop units like FLB-2s, FLA-8s, and FLD-4s, and is known as Hybrid 15454 ONS
configuration. A network design can have up to 80 channels in a typical MSTP configuration; however, in a
Hybrid configuration the number of channels is restricted to 40. In a Hybrid configuration, the Data Connection
Network (DCN) manages the traffic instead of Optical Service Channel (OSC). Hybrid nodes are add/drop
nodes with express traffic and are comparatively less expensive than MSTP nodes.

Understanding the Pay As You Grow Feature
The Pay As You Grow (PAYG) feature enables you to implement a cost effective solution when the wavelength
requirements are comparatively less than the maximum capacity of the network. Instead of purchasing a
standard card that is configured to work on maximum supported wavelengths, you can purchase a PAYG
license that comprises of license restricted cards and a base license. The license restricted cards support only
a number of wavelengths for which the licenses are installed on the card. The base license supports only 10
wavelengths. Therefore, a license restricted card having only the base license will support only ten wavelengths
even if its maximum capacity is to support 40 wavelengths. The cost of the PAYG license is less than the cost
of the standard card. For more information about the PAYG licenses, see Pay As You Grow Licensing.

When there is a need of more than ten wavelengths, additional licenses can be purchased to support the
increased demand. Each new license supports ten additional wavelengths. Therefore, the PAYG functionality
significantly reduces the initial setup cost and enables the purchase of additional wavelength capacity on a
need basis.

During the analysis of the network, the CTP algorithm decides on whether to use a standard card or a PAYG
license depending on the lower implementation cost.

The cards and units that support a PAYG bundle are:

• 40-SMR1-C
• 40-SMR2-C
• 80-WXC-C
• AR-MXP
• AR-XP
• 100G-LC-C
• 100G-CK-LC-C
• 10X10G-LC
• 15216-MD-40-ODD
• WSE

1 15454-40-DMX-C and 15454-40-MUX-C is EOL. For an update on End-of-Life and End-of-Sale PIDs, see EOL and EOS PIDs.
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• 15216-EF-40-ODD
• 400G-XP-LC
• NCS2K-20-SMRFS=

• NCS2K-9-SMR17FS-L=

• NCS2K-9-SMR24FS-L=

• NCS2K-9-SMR34FS-L=

The PAYG licensing is applied to each side of every site. The license depends on the cards placed on that
side and the wavelengths that are added, dropped, or expressed. The PAYG licensing is not dependent on site,
type, or functionality.

The applied PAYG bundle is displayed in the Bill of Material of the site. To view it, right-click the site in the
Project Explorer pane and select the Bill of Material option from the shortcut menu.

The PAYG bundle to which a card is associated is displayed in the card property. To view it, select the card
in the Project Explorer pane; the PAYG bundle name is displayed for the Payg Bundle property in the Properties
pane.

Unlock Pay As You Grow Bundles
When a license restricted card is associated with a PAYG bundle, the association is maintained for future
analysis. Therefore, if the network is analyzed with increased wavelength demands, CTP adds additional
licenses even though using a standard card is cost effective.

During a network upgrade, the association of the license restricted card with the PAYG bundle is not modified
unless the Unlock Pay As You Grow Bundle option is selected. Right-click the site either in the Project
Explorer pane or in the NtView Name tab, and select the Unlock Pay As You Grow Bundles option from the
shortcut menu. On selecting the Unlock Pay As You Grow Bundle option all the PAYG bundle information
from a previous analysis are deleted and are recalculated when the network is analyzed again.

The Unlock Pay As You Grow Bundle option is enabled only in the Upgrade or Install mode.Note

Forcing PAYG Bundles On a Card
The Developer and Optical Designer profile users can decide whether to associate a card with the PAYG
bundle or not. Select the card in the Project Explorer pane; the Force Payg drop-down list is displayed in the
Properties pane. The options available are:

• Auto—The PAYG bundle or the standard card is used based on cost effectiveness.
• Yes—The card is always associated with the PAYG bundle even if using the PAYG bundle is not the
most cost effective solution.

• No—The card is never associated with a PAYG bundle even if using the PAYG bundle is a more cost
effective solution.
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The Force Payg drop-down list is enabled only in the Upgrade and Install modes, when the card is in the
locked state.

Note
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