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Hardware and software requirements
The hardware and software requirements for installing Cisco ONP, Release 26.1.1 are:
Hardware requirements

You need to have an Ubuntu server with version 22.04 or 24.04, or Red Hat server with
versions 8.8 or 8.10

Recommended Server Configuration for Cisco Optical Network Planner (ONP):

e 8 CPU, 48 GB RAM, and 500GB server free space after installation, for 3 concurrent Parallel
ONP analysis

e 8 CPU, 64 GB RAM, and 500GB server free space after installation, for 6 concurrent Parallel
ONP analysis

e 8 CPU, 96 GB RAM, and 500GB server free space after installation, for 10 concurrent Parallel
ONP analysis

Software requirements

e Supported browsers: Google Chrome, Mozilla Firefox, and Microsoft Edge

e Recommended version of the Google Chrome browser:
e For Windows: Version 145.0.7632.117
e For Mac: Version 145.0.7632.110

¢ Recommended version of the Microsoft Edge browser:
e For Windows: Version 145.0.3800.70
e For Mac: Version 145.0.3800.70

e Recommended version of the Mozilla Firefox browser:
e For Windows: Version 148.0
e For Mac: Version 146.0.1

Note: For optimal Cisco ONP user experience, we recommend a minimum internet speed of
100 Mbps

Note: We recommend using Mozilla Firefox for large scale networks for better user
experience.

Supported platforms and releases

Cisco ONP supports the following platforms and releases:

Table 1. Supported platforms and releases

Platforms Recommended and supported releases

NCS 1001 7.10.1, 25.4.1
NCS 1004 24.3.1, 25.4.1
NCS 1014 24.3.1, 25.1.1, 26.1.1
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Platforms Recommended and supported releases

NCS 1010 7.10.1,7.11.1, 24.3.1, 25.1.1, 26.1.1
NCS 1020 24.3.1, 25.1.1

NCS 2000 11.1.0, 25.1.1, 26.1.1

NCS 4000 6.5.33

What's new in Cisco Optical Network Planner, Release 26.1.1

Cisco is continuously enhancing the product with every release, and this section covers a brief
description of key features and enhancements. It also includes links to detailed documentation
where available.

This section provides a brief description of the new software features introduced in this
release.

New features for Cisco Optical Network Planner, Release 26.1.1

Cisco Optical Network Planner Configuration

Software Reliability Reusable predefined user Now you can save all network and site-
profiles level settings into a reusable profile file, in

the CONP database. You can use this
profile during network designing,
ensuring consistent configurations across
different designs and teams. This feature
eliminates repetitive manual setup,
reduces errors, and streamlines
configuration sharing and management
within an organization.

Software Reliability Live network import The live network import feature now offers
enhancements the following enhancements:

e Supports the NCS 1001
platform.

e Handles colored, colorless,
and mixed configurations for
NCS 2000.

e Includes all NCS 1000 native
transponders for NCS 2000,
NCS1010, and NCS1001
platforms.

e Imports network with mixed
nodes by grouping NCS2000,
NCS1010, and NCS1001
nodes into separate, platform-
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https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/conp-26-xx-config-guide/design-and-analyze-networks.html#c-predefined-user-profiles
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/conp-26-xx-config-guide/design-and-analyze-networks.html#c-predefined-user-profiles
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/design-and-analyze-networks.html#c-live-network-import
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/design-and-analyze-networks.html#c-live-network-import

specific Cisco ONP networks.

These improvements enhance network
planning, boost automation, and ensure
consistent, error-free network upgrades
and configurations.

Software Reliability CONC licenses support Two new network-level properties, CONC
License Package and CONC Term
Preference, have been introduced to the
Network application configuration
category. Depending on the selected
properties, the following licenses may be
included in the BOM: CONC RTM ESS
SM, CONC RTM SPC SM, CONC RTM API
SM, CONC RTM ESS LG, CONC RTM SPC
LG, and CONC RTM API LG. This feature
allows you to identify and order the
necessary COSM and CONC licenses for
your comprehensive Optical Automation
Software (OAS) solution based on the
network configuration.

Software Reliability COSM enhancements COSM application memory and COSM
RAM Size are considered for COSM
association through COSM Application
Memory and COSM RAM size properties

at site level.
Software Reliability Cisco ONP BoM based on Cisco ONP introduces a network-level
license offer structure Licensing Model option within the Bill of

Materials category. You can select
between Smart Licensed and Perpetual
licensing models for your deployment.
This feature is available on NCS 1010,
NCS 1014, NCS 1001, NCS 2000 4K-1K-
2K SSON networks. The generated BoM
will accurately represent the hardware,
software, and licenses that can be
ordered for the chosen Authorize-to-
Order (ATO) bundle. This enhancement
ensures that the BoM aligns with your
specific licensing needs, allowing for
flexible and precise license selection
within Cisco ONP. Consequently, order
accuracy and compliance with Cisco’s
licensing models are enhanced, offering
greater flexibility and transparency when
configuring solutions in Cisco Commerce
Workspace (CCW).

Software Reliability 2x100G muxponder mode Cisco ONP enables the 2x100GE
support on NCS1K14-2.4T-X- muxponder mode on the NCS1K14-2.4T-
K9 transponder card X-K9 transponder card when designing

networks for the NCS 1010, NCS 1014,
CS 1001, and NCS 2000 (1k-2K traffic
site) platforms. This mode supports trunk
rates ranging from 400G to 1.2T
(excluding 700G) for both slice-0 and
slice-1, and is compatible with client
pluggables QDD-2X100-CWDM4-S and
QDD-2X100-LR4-S. The 2x100G mode
provides flexible and efficient aggregation
of 100GE traffic, optimizing resource
utilization and simplifying service
provisioning within each platform's
design.
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https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#task_1408770
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#task_1408770
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#task_1408770
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#t-modify-service-properties
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#t-modify-service-properties
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#t-modify-service-properties

Software Reliability NCS 1010 network design Cisco ONP has implemented the following
enhancements enhancements for network design:

ALC Phase Il Device Parameters:

e NETCONF XML files now include
additional ALC phase Il parameters
such as Raman ampilification and
advanced optical settings for more
precise device configuration.

e Lookup Table (LUT) Improvements:

e Raman gain values are now visible
in LUT entries.

e LUTs can be imported/exported,
including CPZ data.

e Raman side amplification is
calculated from LUT entries for
better modeling accuracy.

e Tx connector loss is user-
configurable and factored into PSD
values.

SSF simulation enhancements:

e Uses secure HTTPS protocol for
communication with SSF server.

e  Supports multi-subnet network
analysis.

° Displays estimated simulation
timing in the analysis progress bar.

e Enables background analysis
without interrupting other tasks.

e These updates enhance the
accuracy, configurability, security,
and usability of optical network
planning and simulation for NCS
1010 networks.

Software Reliability NCS1K14-FAN-P programmable The new NCS1K14-FAN-P

fan for NCS 1014 programmable fan reduces power use
and improves cooling efficiency by
adjusting its speed to match the card load
in the NCS 1014 chassis. It increases
speed automatically when the chassis
drives higher bandwidth or thermal
demand, keeping airflow aligned with
power requirements. Choose the
programmable fan from the new
NCS1014 Chassis Fan field at the
network level.

Software Reliability Ul/UX enhancement Cisco ONP is enhanced with these UI/UX
designs:

e Salesforce BoM - Choose
Export > Salesforce BoM to
get BoM report in Salesforce
format.

e Multiple network downloads -
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https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/conp-26-xx-config-guide/design-and-analyze-networks.html#c-conp-ssf-method
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/conp-26-xx-config-guide/design-and-analyze-networks.html#c-conp-ssf-method
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#reference__row_bwl_xpf_g3c
https://www.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#reference__row_bwl_xpf_g3c
https://www-author3.cisco.com/content/en/us/td/docs/optical/conp/conp-2611/configuration/guide/b-conp-26-xx-config-guide/modify-network-properties.html#reference__row_bwl_xpf_g3c

Choose File > Download
Networks and select up to five
network designs to download.

Ageing loss support in
imported and exported excel
sheet

Network tree structure
retention - Network tree does
not collapse after parameter
updates.

Populate shelves from bottom
- Enable Populate Shelves
From Bottom check box under
Layout at site level to populate
equipment from the bottom of
the shelves.

Addition of equipment to
restriction list - Add
equipment to Restricted
Equipment under System
Release at network level to
restrict the tool from using it in
network design.

Database clean-up - Set
hibernate.slowQuery.logging.e
nabled to true to enable
database cleanup.

Automatic SD - Enable Auto at
Optical Subnet level to enable
basic automatic spectral
density for the selected
optical subnet.

Enhanced tuner mode -
Added Maximum DataRate
Maximum Capacity and
Maximum DataRate Best
OSNR to calculate results
based on maximum data rate
per maximum capacity and
best OSNR.

Interoperability support for all
networks - Allows different
source and destination card
types to interoperate.

Link availability report -
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Choose Export > Link
Availability for an analyzed
network to download the
network design with link
availability values.

e Enhanced optical source
search - More keywords are
added to the search box to
find Optical sources based on
file parameters.

¢ Frequency update in
wavelength - Now wavelength
values contain corresponding
frequency values.

e Editable Unique ID for chassis
in Layout tab - Choose Edit >
Edit Unique ID to edit the
chassis UID for an analyzed

network.
Software Reliability Support for all NCS 1000 These NCS 1000 transponders are
transponders supported:

o NCS1K14-2.4T-K9

e NCS1K14-2.4T-X-K9
e NCS1K14-2.4T-A-K9
e NCS1K4-1.2T-K9

e NCS1K4-1.2TL-K9

¢ NCS1K4-2-QDD-C-K9
¢ NCS1K4-OTN-XP-K9

¢ NCS1K4-QXP-K9

Software Reliability Support for NCS1K14-2.4TA-  Added support for the NCS1K14-2.4TA-
K9 transponder card K9 transponder card that operates in
Bundle and Slice modes.
Software Reliability Configuration gaps in NCS 2000 NCS 2000 R11.x networks now support
networks MD-32 add/drop configuration. All NCS

2000 networks support MD-48 add/drop
configurations.

Software Reliability Device Netconf and COSM Cisco Optical Site Manager XML supports
support NCS 1001 and NCS 1014 networks. NCS
1004 configurations are added to the XML
file.

NCS 1010 designs now include these
parameters.
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e Patchcord Loss Threshold
(applicable for C+L band device)

e Ots Rx Low Threshold (applicable
for C+L Raman device)

e Bidirectional span-loss mismatch
threshold

e Payload OSC Min Deviation
e Payload OSC Max Deviation

Parameters based on Raman LUT and
ALC2 and LUT:

e Raman-tuning with-payload

e Raman-tuning manual

e Raman-tuning Raman-gain-target
e Raman-turn-up <enable/disable>
e Raman-safety-trigger dfb-los

e Raman-safety-trigger osc-los

e Raman-safety-trigger osc-osnr-
los

e Raman Pump Configuration such
as Raman-tx-power-instance and
Raman-tx-power-value

Open issues

This table lists the open issues in this specific software release.

Note: This software release may contain open bugs first identified in other releases. To see
additional information, click the bug ID to access the Cisco Bug Search Tool (BST).

Open issues

Open issues for Cisco Optical Network Planner

Description

CSCws29890 Circuits are imported with internal IDs instead of Circuit Name/Label

CSCws52323 LNI NCS2K: NCS1K BoM is not displayed for a live imported NCS2K network with
NCS1K TXP
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https://bst.cloudapps.cisco.com/bugsearch/search
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCws29890
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCws52323

Description

CSCws79315 Actual connected port is not retained for circuits after LNI network upgrade analysis

CSCws94754 Line Card Licensing Type is not being set according to the corresponding PID during
LNI import

CSCwr44234 Analysis - LNI-Traffic type is set to Optical source and defaulted to NCS1004
interface for all LNI

CSCwt31406 Optical results of Line Rate tuner do not match with CONP for QDD low power optics

CSCwt31440 Incorrect Optical parameters for L-band Optical Sources generated from Line rate
tuner mode

CSCwt31566 Modulation GB is not being considered to calculate the Spectrum when BRK16/24 is

used in C/L band

Legal information

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates
in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL:
www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their
respective owners. The use of the word partner does not imply a partnership relationship
between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not
intended to be actual addresses and phone numbers. Any examples, command display output,
network topology diagrams, and other figures included in the document are shown for
illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative
content is unintentional and coincidental.

© 2025 Cisco Systems, Inc. All rights reserved.
Other Important Information

The CONP API is now open for external tools to:
e Create or open designs
e Update topology information (sites, fibers, demands)

e Execute analysis
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https://bst.cloudapps.cisco.com/bugsearch/bug/CSCws79315
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCws94754
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwr44234
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwt31406
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwt31440
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwt31566
http://www.cisco.com/go/trademarks

Fetch all reports
Read the status of ongoing actions (design analysis, loading, file fetching)

Additionally, the API allows external tools to force Raman amplification at the span level,
including choosing the desired amplifier.

Copyright © 2025, Cisco Systems, Inc. All rights reserved.
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