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» Download multiple networks, on page 98

Cisco ONP network designs

A Cisco ONP network design is a network architecture planning approach that

+ allows you to create a new design manually or import an existing design,

* supports integration with various sources and tools such as Excel sheets, live network import, Cisco
Transport Planner, or other Cisco ONPA instances, and

» provides flexibility in how network models are created and managed.

You can design a network in one of these ways:
» Manual design: Create a network design using the design palette.

* Import design: Import a network design from an Excel sheet, live network import, Cisco Transport
Planner, or another instance of Cisco ONP.

This dual approach enables network architects to choose the method that best fits their workflow, making
Cisco ONPA adaptable to various project requirements and existing data sources.

Manually design a network using Cisco ONP

Table 1: Feature History

Feature Name Release Information Feature Description

Database Operations Optimization | Cisco ONP Release 5.2 Cisco ONP now provides an option
to run some operations in the
background involving database
interaction, such as Save As,
Import CPZ, and Export CPZ.
You can continue to use the Cisco
ONP interface for other operations
when these operations are running

in the background.
Table 2: Feature History
Feature Name Release Information Feature Description
4K-2K SSON Network Creation | Cisco ONP Release 5.2 Now you can include the 4K-2K
Support nodes in both SSON and

non-SSON networks while
designing the network. This helps
you to validate 4K-2K nodes in the
SSON design which has higher line
rates.
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Table 3: Feature History

Feature Name Release Information Feature Description

NCS 1010 C+L Network Design | Cisco ONP Release 5.1 Cisco ONP now supports the
C+L-band networks that help you
plan NCS 1010 networks using the
OLT-L and ILA-L line cards to
increase your network’s bandwidth
capacity. Enhanced with L-band
related properties, the UI enables
you to design a C+L-band network
for your ever-increasing channel
demands. These L-band types are
introduced to suit your design
needs:

* C+L: This band type adds
more channels to your
network, increasing its traffic
carrying capacity.

» C+L Futuristic: This band
type creates a network with
C-band edges and future
provisions for L-band edges
that you can cost-effectively
upgrade after exhausting the
C-band capacity.

Table 4: Feature History

Feature Name Release Information Feature Description
Greenfield NCS 1010 Network Cisco ONP Release 5.0 You can design and validate
Design NCS1010 optical line system. This

feature helps to create OLT-C,
OLT-R-C, ILA-C, ILA-R-C, and
ILA-2R-C based NCS 1010
networks using fixed grid add/drop
MD-32-ODD, MD-32-EVEN and
flex grid add/drop BRK-24,
BRK-16, and BRK-8 passive
modules.
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Procedure

Table 5: Feature History

Design and Analyze Networks |

Feature Name

Release Information Feature Description

Multi-Layer Platform (MLP)
Greenfield Design with NCS
4k-1k-2k

Cisco ONP Release 4.1 This feature allows you to:

* Support NCS 4K-1K-2K
multiplatforms

* Visualize new layout for Txp
and SVO for NCS 2000 node

* Support different OTN service
types with protection

+ Edit layout for NCS 4000 and
NCS 1004 nodes

Use this procedure to create a network in the Cisco ONP.

You can create any of these network designs:

* Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions.

* Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand

and network conditions.
* NCS 1010 network
* NCS 1001 network
* NCS 1014 network

Before you begin

* Log in to the Cisco ONP web interface

» Create a user profile, if you want to apply the profile that contains predefined configurations, as a template.

Step 1 Choose File> New.

Step 2 In the Create New Network dialog box, choose the required options to create a network.
a) From the LO Network Platform drop-down list:

Choose

To create...

NCS 2000

a non-SSON network that contains NCS 2000 and NCS
4000 nodes, or an SSON network including NCS 2000,
NCS 1004, and NCS 4000 nodes

NCS1010

a network that contains only NCS 1010 nodes
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Step 3

Manually design a network using Cisco ONP .

Choose To create...
NCS1001 a network that contains only NCS 1001 nodes
NCS 1014 a network that contains only NCS 1014 nodes
a) Ifyou want to create an SSON network, check the SSON Network check box. Otherwise, do not check the check
box..
This option is not for the NCS 1010 network.
b) Choose NCS (4K_1K_2K) or NCS (4K _2K) from the Traffic Type drop-down list.
You can view the Traffic Type drop-down list, if you choose to create an SSON network in the previous step.
Note
Once the network is created, you cannot change the Traffic type from 4K 1K 2K to 4K 2K, or the reverse. Export
the network to an Excel sheet, make the required modifications, and import it as a new network.
¢) Choose the System Release for NCS 2K or NCS 1010 from the drop-down list.
You cannot change the system releases that are available for NCS 4K and NCS 1K.
The Band Type drop-down list appears for NCS 1010 networks from Release 7.9.1.
d) From the Band Type drop-down list for NCS 1010, choose:
* C-Band: Only C-band edges are created and ANS is generated based on C-band. For L-band upgrade, ANS
unlock is required.
o C+L Futuristic: Only C-band edges are created and ANS is generated based on C-band and L-band. For L-band
upgrade, ANS unlock is not required.
* C+L: Both C-band and L-band edges are created and ANS is generated based on C-band and L-band.
Note
After the creation of a NCS 1010 R7.9.1 network, if required, you can change the network band type under the
Network Application Configuration section in the Network Properties.
e) From the Profile drop-down list, select either the Default profile, which provides the default properties set by Cisco
ONP, or a user-defined profile. For more details on profiles, see Predefined user profiles, on page 21.
f) Click Create.

The application displays a map and the design palette. For details, refer to Design Palette.

Click the Drawing Tool icon (pencil and ruler crossed), and add sites and other network elements.

a)

Add sites to the map using the drawing tool.

Zoom in on the map to the desired level. Click any of the site icons (ROADM, OLA, or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.

Note
* SRLG is not supported in the SSON networks.

Traffic node is not supported on the NCS 1010 network.
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. Create shared risk link group

Step 4

b)

¢)

d)
e)

Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.

Note
By default, the fiber length is set as 1 kilometer for all the fibers. To update the length automatically based on the x
and y coordinates, enable the Use Coor dinates Distance property in network properties.

Create services between the sites (only for SSON and non-SSON networks).

Cisco ONP provides only OTN service.

Click OTN Service (green) and add the service between the existing Traffic sites on the map.

Click Circuit (purple), M edia channel (purple), or Waves (red), and add media channel, or waves between the
existing sites on the map.

In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Choose File> Save As.

a)
b)

In the Give a Network Name dialog box, enter a network name and click Save.
If you want this operation to run in the background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progress of the
operation running in the background.

Create shared risk link group

Step 1
Step 2
Step 3
Step 4

Use this procedure to create Shared Risk Link Group (SRLG) using the Cisco ONP GUI. The SRLG feature
enables routing of protected services.

\)

Note SRLG is supported only for non-SSON networks that include traffic nodes.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Open the network where you want to create the SRLGs.

Click the network tree panel.
Expand Fibers, and check the check box next to each fiber that should be in the same SRLG.
After selecting all fibers, right-click and choose Create SRLG.

Cisco ONP creates an SRLG with a unique name, which you can subsequently rename.
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Import a network using an Excel sheet .

Import a network using an Excel sheet

Use this procedure to import a network into Cisco ONP, using an Excel sheet.

Before you begin

* Log in to the Cisco ONP web interface

* Create a user profile, if you want to apply the profile that contains predefined configurations, into your

Excel imported network design.

Table 6: Feature History

Feature Name Release Information | Feature Description

CX Unified Planning | Cisco ONP Release |The integration between CX Unified Planning Tool (UPT)

Tool Network Import |5.0 and Cisco ONP enables you to import the networks created
and analyzed in CX UPT into Cisco ONP. This helps you
avoid recreating the networks that are already created in
UPT. This feature allows you to import networks having
NCS 1010 and NCS 2000 nodes into Cisco ONP.

Table 7: Feature History

Feature Name Release Feature Description

Information

Export and Import
of Network
Topology in Excel
Format

Cisco ONP
Release 5.1

It is now possible to export the topology data of an existing network
into an Excel file. You can easily modify the exported data in Excel
and import it back into Cisco ONP to create a new network or modify
an existing network.

These are the supported Excel formats:

* XIsx—Standard Excel with multiple sheets, each corresponding
to a network element such as Network, Sites, Circuits, Spans,
OTNdemands, and so on.

» XIsm—Macros-enabled Excel file that can filter out and display
only the applicable network element sheets based on the platform
selected in the Network sheet.

Cisco ONP has the built-in intelligence to automatically calculate the
shortest path between a source and a destination, even if only a partial
fiber path is mentioned in the imported Excel file.

Follow these steps to import a network into Cisco ONP, using an Excel sheet.

\}

Note By default, the system release of the Excel-imported network is 11.0
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. Import a network using an Excel sheet

Step 1

Step 2
Step 3

Step 4

Step 5

\)

Note From Release 5.0, Cisco ONP supports import of networks created using UPT via Cisco ONP Import Excel
option. UPT does not populate the DWDMChannel Type and Add/Drop Type values in the Excel sheet. If the
values are not found in the Excel sheet, then Cisco ONP picks the default options. By default, DW DM Channel
Typeis NCS1004 QPSK_SP_16QAM_ 200G 27%SDFEC _60GBd and Add/Drop Typeis Colored. We
recommend you to check the DWDMChannel Type and Add/Drop Type values before importing the Excel
sheet into Cisco ONP to avoid any discrepancies.

From Release 5.1, in addition to exporting the template, you can export the entire network design data of an
existing network as an Excel sheet. Modify the network properties available in the Excel sheet and reimport.
The network can be exported in all modes and reimported on Design mode, Upgrade mode, and Release
Upgrade mode.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Choose Export > Excdl .

a) Choose the Network Type as Template or Current Network.
b) Choose the File Type as xIsx or xIsm (Macros-enabled)

The Macros-enabled Excel sheet automatically customizes the tabs on the Excel sheet based on the platform that you
choose. It provides functionalities such as selection of fibers in the path selection, wavelength count validation in
case of regen selection.

¢) Click Download.

The template has tabs and fields that you must fill in the Excel sheet. For details about these tabs and fields, refer to Tabs
available in the Excel sheet template, on page 9.

Fill the network details in the template file or edit the current network file, and save the file.
Choose Import > Excel , and select the Import Type.

» New: Choose this option if you want to create a new network using the design data available in the Excel sheet.

» Existing: Choose this option if you want to update an existing network with the data available in the Excel sheet.
Open the network before you import the Excel sheet. Ensure the network is in Design mode, Upgrade mode, or
Release Upgrade mode.

You can view the data available in the Excel sheet before you import the network data. The View Data check box remains
checked by default. Uncheck it if you do not want to view the imported data.

Browse for the file, select it, and click Import.

During the import for the existing network, If the network is locked, Cisco ONP does not import the data. If the network
is unlocked and in upgrade mode, Cisco ONP updates the parameter. If the state is New, Cisco ONP adds parameters
from the Excel file as a new entry.

During a new network import, the system creates a new network design regardless of the state.

(Optional) After you successfully import the network design through Excel, choose a profile:
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Tabs available in the Excel sheet template .

a) Choose Network > Entity Editor.
b) Click the network name and select the required user profile from the Profile drop-down-list.

Note

Values specified in Excel take precedence over the profile. For properties not available in Excel and set to Auto, they
are updated according to the profile.

The selected network is imported.

If there are errors in the imported data, a pop-up error message is shown in case of new import, and the errors
are available under the Elements> M essages tabs in case of updating the existing network.

Tabs available in the Excel sheet template

This table lists the various tabs available in the Excel sheet template used to import a network.

Table 8: Tabs available in the Excel sheet template

Tabs Description

Network Label (name of the network), Platform (NCS2000(NON SSON), NCS2000
(SSON), NCS1010, NCS 1001 , NCS 1014), Traffic Type, NCS1010 Line Card,
NCS1010 Band Type, Chassis Type, and System Release

Network Property This is applicable for NCS 1010 network alone.
State (New, Locked, and Unlocked), NCS 1010 Line Card, NCS 1010 Band Type,
and Chassis Type

Sites Site Label, Type, X coordinates, Y coordinates,X Rearranged, Y Rearranged,
Pre Equip Degree, Grooming Site, CLLI code, and Site Address, Degree (Scalable
upto degree), NCS1010 Line Card, NCS1010 Band Type, Chassis Type, and State.

Spans Span label, A (Source site name), Z (Destination site name), Kms (Distance),

Loss, Type, A_Edge, Z Edge, AZ Loss,ZA Loss, AZ Kms,ZA Kms,NCS1010
Band Type, Ageing loss, and State.

OTNDemands-4K-2K

Demand Label, A (Source), Z (Destination), Y (Tertiary Source), B (Tertiary
Destination), Type, Quantity, Protection, Primary Path, Secondary Path, and State.

Note: Y and B can be used with Unprotected Disjoint Service.

OTNDemands-4K-1K-2K

Demand Name, Source, Destination, Service Group, Type, A/D Type, Protection,
Primary Wavelength, Secondary Wavelength, Primary Path, Secondary Path, First
Restoration path, Second Restoration Path, Primary ODU Timeslot, Secondary
ODU Timeslot, Primary Regen, Secondary Regen, Trunk Mode, Baud Rate, and
State.

MediaChannels

Channel Label, Source, Destination, Primary Wavelength, Secondary Wavelength,
Protection, Traffic Type, Card Type, A/D Type, Primary Path, Secondary Path,
Primary Regen, Secondary Regen, and State.
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Tabs

Description

ServiceGroup

ServiceGroup Name, Demand Types, 4K Exclusive LC Usage, 4K Symmetric
Aggregation, 1K Exclusive LC Usage, 1K Symmetric AggregationChannel Label,
and State.

DWDMChannels

Primary Wavelength and Secondary Wavelength (Work and Protect Wavelength
for NCS2000 non-SSON waves), Primary Path and Secondary Path (Work and
Protect Path for NCS2000 Wave/Media Channel and NCS1010 circuit), A/D Type
(Colored/Colorless/Contentionless), Traffic Type, Primary Regen Secondary
Regen State, Channel label, A, Z, Wavelength, Protection, and Type.

Services-1K

Service Name, Source, Destination, Type, Protection, Primary Wavelength, Primary
Path, Primary Regen, Card Type, Trunk Mode, A/D Type, Band Type, and State.

Circuits

Circuit Label, Source, Destination, Primary Wavelength, Protection, Traffic Type,
Card Type, A/D Type, Primary Path, Primary Regen, Band Type, and State.

Flex Optical Source

Flex Optical Source Name.

SRLG

SRLG Label, Spans, and State.

Network imports from Cisco Transport Planner

The Cisco Transport Planner network import is a compatibility feature that

+ allows you to import networks created and analyzed in Cisco Transport Planner into Cisco ONP, as .mpz

files,

* prevents the need to recreate existing networks, and

* supports only networks from Release 11.0 or later for compatibility.

Supported hardware for CTP network import

Cisco ONP supports these hardware as part of CTP network import.

* Optical source files and transponders

See Supported Optical Sources, and Supported Cards and Pluggables.

* Contentionless, colorless, and colored point-to-point demands

* Flex network

* Gain Equalizer

A\

Note The Gain Equalizer node converts to a ROADM node when you unlock the site
after a release upgrade.

* ROADM-SMR-9 and SMR-20

« All flex supported amplifiers, controller cards, and chassis types
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Import an mpz design file from Cisco Transport Planner
Use this procedure to import an mpz file from Cisco Transport Planner to Cisco ONP.
Before you begin
* Log in to the Cisco ONP web interface as a user with network creation permission.

* Import the required optical source files and layout template using Manage > Optical Source and
M anage > Optical Sour ce options. For more information, refer to M anage Alien, and M anage L ayout

* Delete the unsupported parameters for Cisco ONP from the mpz file. For example, mpz networks with
P-Ring and A2A demands are not supported for import. Delete these demands in Cisco Transport Planner,
reanalyze the networks in Cisco Transport Planner, and import the mpz file into Cisco ONP.

The network must be in design-analyzed or upgrade-analyzed mode.

Procedure

Step 1 Choose Import > MPZ.
The Import File (mpz) dialog box appears.

a) Browse to the mpz file stored on your computer.
b) From the Traffic Type drop-down list, choose 4K_1K 2K or 4K_2K.

You can view this drop-down list only if you select an SSON MPZ file.
c¢) Click Import.
The mpz file is imported to Cisco ONP.

Note
If you view a blank screen when you click waves in the network tree, refresh the browser.

Step 2 Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

Note
* You cannot go back to design mode on the imported mpz network.

* The wave label of imported mpz network in Cisco ONP is the service name present in the Cisco Transport Planner
properties window.

Export the CPZ file

Cisco ONP saves the network design file as a .cpz file in its database. Use this process to export the design
file to your computer.

The contents of the .cpz file depend on the network mode:

* In design mode, the .cpz file includes the design file, layout template, and optical source details.
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* In analyze mode, the .cpz file contains several items: a design file, analyze file, ANS file, per-side ANS
file, BOM, error messages, trace files, layout template, mpz, and report.

* For networks in upgraded mode, you can only export the last child in the parent-child hierarchy.

N

Note  You can export only one network at a time.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Step 1 Open the network whose design file that you want to export.
The network opens.

Note
If a blank screen appears when you open a network, refresh the browser or log in to Cisco ONP again.

Step 2 Choose Export > CPZ.
Step 3 Inside the Export .cpz file dialog box:

a) Rename the file if necessary.
b) If you want this operation to run in background, click the Run in Background check box.

A notification appears after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

¢) Click Export.

The design file is stored on your computer. Starting with Release 26.1.1, the LUT version, and the user profile
utilized in the current network will be included during the export of the network CPZ file.

Import the CPZ file

Use this procedure to import the cpz network design files that are exported from another Cisco ONP instance.

\}

Note  You can import only the networks that are exported from the current release.

Before you begin
* Log in to the Cisco ONP web interface

* Create a user profile, if you want to apply the profile that contains predefined configurations, into your
cpz imported network design.
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Step 1
Step 2

Step 3

Live Network Import .

Procedure

Choose Import > CPZ.
In the Import .cpz file dialog box:

a)

b)

<)

d)

f)

Click Choosefile, and select a cpz network design file that you want to import into Cisco ONP, from your local
system.
If you want this operation to run in background, click the Run in Background check box.

After the background operation completes, you receive a notification. You can view the progress in Job Monitor.

Click Import.

If the names of the optical source and layout template files in the database and the imported network file match, Cisco
ONP prompts you to confirm whether you want to overwrite the existing file.

Note

The message " Network already existsin the system with another user. New network will be created”, you do
not need to take any action. Cisco ONP automatically imports the network as a new network for you without changing
the existing network.

If you want to overwrite the existing file, check the Overwrite Network check box.

If you do not check the box, Cisco ONP saves the imported network as a new network.

Choose the optical source files and layout template that you want to replace.

If you do not choose the optical source or the layout template file, the files will not be imported.

Click Confirm.

The imported network is saved in the Cisco ONP database.

(Optional) After you successfully import the CPZ network, choose a profile:

Note

If you had imported a CPZ network that was exported from Release 26.1.1, the user profile associated with that network
is included and remains active. Apply a profile only if you have imported a CPZ network from earlier releases without
an attached profile.

a)
b)

Choose Network > Entity Editor.

Click the network name and select the required user profile from the Profile drop-down-list.
The applied profile affects only entities added to the network after the import. Existing entities remain unchanged.

Live Network Import

The Live Network Import (LNI) feature is a network import capability that

* enables real-time import of deployed networks into Cisco ONP,

* supports import of networks and nodes with NCS 2000, NCS 1010, NCS 1001, NCS 1004, NCS 1014
shelves and cards, and

+ allows you to view comprehensive deployed network details after import.
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Feature Name

Release
Information

Feature Description

Live network
import
enhancements

Cisco ONP
Release 26.1.1

The live network import feature now offers the following
enhancements:

* Supports the NCS 1001 platform.

* Includes all NCS 1004, and NCS 1014 native transponders
(except NCS1K14-2.4T-A-K9 and NCS1K-OTN-XP) for NCS
2000, NCS1010, and NCS1001 platforms.

* Imports network with mixed nodes by grouping NCS2000,
NCS1010, and NCS1001 nodes into separate, platform-specific
Cisco ONP networks.

These improvements enhance network planning, boost automation,
and ensure consistent, error-free network upgrades and
configurations.

Table 10: Feature History

Feature Name

Release Information | Feature Description

from Cisco ONC

Live network import

25.1.1

Cisco ONP Release | Cisco ONP now directly communicates with Cisco ONC to

perform a live network import, eliminating the need for Cisco
ONP to be directly connected to a device or network. In
addition to the previously supported NCS 2000, networks
that include NCS 1010 nodes contained within NCS 1010
and NCS 1014 shelves can also be imported.

Table 11: Feature History

Feature Name

Release Information Feature Description

Live Network Import

Cisco ONP Release 4.1 This feature allows you to import

a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

The Map displays the network topology, and you can check the node, fiber, service, and circuit properties
through the Network Tree and the Entity Editor.

From Release 25.1.1, you can import a live network through Cisco ONC.

From Release 26.1.1, Cisco ONP supports these for all OLS platforms:

* NCS 1001 platform is supported.
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Perform live network import .

* Upgrade and Release-upgrade are available for the imported network.
* Netconf generation and ANS are available after upgrading the imported network.

» LNI is supported for all NCS 1004, and NCS 1014 native transponders (except NCS1K14-2.4T-A-K9

and NCS1K-OTN-XP) for NCS 2000, NCS1010, and NCS1001 platforms

* Mixed platform import:

Mixed platform import allows nodes from different OLS platforms to be imported. Cisco ONP groups
nodes from the NCS2000, NCS1010, and NCS1001 platforms into separate, platform-specific networks,
because mixed-platform nodes cannot coexist in a single network.

Each imported network uses a unique name in the format LNI__, which ensures clear distinction between

platforms.

For more details on all hardware supported, see Configurations and hardware supported by LNI, on page 17.

Perform live network import

Use this procedure to perform live import of a network from Cisco ONC.

Before you begin

* Perform LNI only when the Cisco ONC is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

* Ensure that the release version of Cisco ONC you are using for the network import is 25.1.1 or above.

* Cisco ONP removes any card that is not properly connected via IPC in Cisco Optical Site Manager during

LNI. To retain equipment, ensure that each card has at least one valid IPC connection in Cisco Optical

Site Manager.

* Configure all the mandatory parameters on the circuit.

* Check the card label set for these NCS 2000 cards and update it if they are not aligned.

PID Card label
NCS2K-16-AD-CCOFS AD-16-FS
NCS2K-20-SMRFS SMR20-FS-CV
NCS2K-20-SMRFS-L SMR20-FS
NCS2K-9-SMR17FS SMR9-17-FS
NCS2K-9-SMR24FS SMR9-24-FS
NCS2K-9-SMR34FS SMR9-34-FS
NCS2K-9-SMR34FS-L SMR9-34-FS
15454-M-RAMAN-COP= OPT-RAMP-COP
15454-M-RAMAN-CTP= OPT-RAMP-CTP
NCS2K-OPT-EDFA-35 OPT-EDFA-35
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. Perform live network import

Step 1
Step 2

Step 3

Step 4

Step 5

* Log in to the Cisco ONP web interface

Procedure

Choose Import > Live Import.

In the Import Live Network dialog box:

a) Enter CONC Server | P, Username, and Password.
b) Click Import.

The Import button will be enabled only when all the values entered are valid.

View the status of the LNI operation:

a) Click Job Monitor, to view the status of the IMPORT LIVE NETWORK task. Click Refresh to see the updated
status.
After LNI is completed, the job is removed from the Job Monitor page.

b) Click Logsto view the list of events that are related to the LNI operation, as logs.

After the completion of the LNI operation, choose File > Open.

The format of the LNI imported network filename is LNI_<Date> <Time>.

Click the imported network name to view the network under the Map tab and its corresponding network tree in the left
panel.

You can view the tag Imported from Network in the interface.

Note
* During the live import of a network with an optical source, if the configuration code of the optical source does not
match, it will default to NCS1004_SP_16QAM_300G_27%SDFEC_69GBd. You can update the optical source in
upgrade mode while the network is in a locked state.

* The configurations that are supported by Cisco ONC can only be imported into Cisco ONP. See Configurations and
hardware supported by LNI, on page 17.

* Even if errors occur during the LNI operation, the operation is not canceled. In this case, when you open the imported
network, a warning message appears.

* You can view the errors under the Elements > M essages tab. See both critical and noncritical messages.

If you find unconnected equipment in the M essagestab, upgrade the imported LNI network and make the necessary
adjustments to reintegrate the removed equipment into Cisco ONP. However, note that the newly created equipment
UID may not match the one in Cisco Optical Site Manager. You can utilize the UID edit feature to align the UIDs
between Cisco ONP and Cisco Optical Site Manager. Refer to Edit the Unique ID of the chassis

 Each user is permitted to initiate only one LNI process at a time. If a user tries to start an additional concurrent LNI
process, the system will terminate the new request and display an error message indicating the restriction. This
limitation is applied on a per-user basis, allowing multiple users to run their own LNI processes simultaneously on
the same CONC server, as long as each user adheres to the rule of having only one active process.
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* If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS option. You can
edit this option during upgrade after unlocking the site, if necessary.

What to do next
Click the BOM tab to view the BOM details of the network.

)

Note The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.

You can export the CPZ, import the CPZ, and share the imported network. Use the Entity Editor to view
network properties.

Configurations and hardware supported by LNI

The live network import from Cisco ONC supports the configurations and hardware listed in this table.
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Table 12: Configurations and hardware supported by LNI
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Platform

Chassis

Card type

Card

Configurations

NCS 2000*

NCS 2015
NCS 2006
NCS 2002

ROADM

NCS2K-20-SMRFS-L
NCS2K-20-SMRFS=
NCS2K-20-SMRFS-CV=
NCS2K-9-SMR17FS=
NCS2K-9-SMR34FS=
NCS2K-9-SMR24FS-L=
NCS2K-9-SMR34FS-L=

Add/Drop

NCS2K-16-AD-CCOFS
NCS1K-MD-64-C

15216-MD-48-ODD, and
15216-MD-48-EVEN
Mux/Demux

MF-MPO-16-LC
MF-MPO-8LC
MF-6AD-CFS

Amplifiers

NCS2K-OPT-EDFA-17=
NCS2K-OPT-EDFA-24=
NCS2K-OPT-EDFA-35=
15454-M-RAMAN-CTP=
15454-M-RAMAN-COP=
NCS2K-EDRA2-XX
NCS2K-EDRA1-XX

Transponders

Contentionless

Unprotected
circuits

Mixed
configurations

Colored
configurations

Colorless
configurations
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Platform Chassis Card type Card Configurations
NCS2K-400GXP-L-K9
400G-CK-LC
200G-CK-C
200G-CK-C+10x10G-LC
NCS2K-200G-CK-LIC

NCS2K-200G-CK-LIC+
15454-M-10X10G-LC

NCS1K14-2.4T-K9
NCS1K14-2.4T-X-K9
NCS1K4-QXP-K9
NCS1K14-2.4TL-K9,
NCS1K4-2-QDD-C-K9
NCS1K4-1.2T-K9
NCS1K4-1.2TL-K9
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Platform

Chassis

Card type

Card

Configurations

NCS 1010

NCS 1010
NCS 1014

ROADM

All OLT variants with
Standard and Enhanced
faceplate

Add/Drop

CCMD1e6-C
MD-32-ODD
MD-32-EVEN
BRK-24
BRK-8

Direct LC

Amplifiers

All ILA variants

Transponders

NCS1K14-2.4T-K9
NCS1K14-2.4T-X-K9
NCS1K4-QXP-K9
NCS1K14-2.4TL-K9,
NCS1K4-2-QDD-C-K9
NCS1K4-1.2T-K9
NCS1K4-1.2TL-K9

NCS 1001

NCS 1001 (Only
terminal nodes)

Amplifiers

NCSIK-EDFA
NCS1K-PSM

Add/Drop

NCS1K-MD-32E-CE and
NCS1K-MD-320-CE

15216-FLD-4-XX.X

Transponders

NCS1K14-2.4T-K9
NCS1K14-2.4T-X-K9
NCS1K4-QXP-K9
NCS1K14-2.4TL-K9,
NCS1K4-2-QDD-C-K9
NCS1K4-1.2T-K9
NCS1K4-1.2TL-K9

Colored
Colorless

Unprotected
Circuits

! Optical source interface import is not supported in NCS2000. By default, it is set to

NCS1004 SP _16QAM 300G 27%SDFEC 69GBd. You can manually edit the optical source interface

to the correct one during an upgrade, without unlocking the circuit.
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Configurations and hardware unsupported by LNI

This section outlines the configurations and hardware that are not supported by the Live Network Import from
Cisco ONC.

LNI does not support these configurations and hardware

* NCS1K4-OTN-XP card

* These transponder modes are not supported: 50G, 150G, 250G, 350G, 450G, and 550G
* Configurations with Inline amplifiers

* Regeneration and Protection circuits

* NCS 1014 as a platform and NCS1K14-EDFA2 card

* OTN cross-connects on the 400G-XP-LC module and OTN-XP card

* NCS 1010 Omni configurations and NCS 1010 C+L configurations

* Different Add/drop functionalities (Colored, Colorless, or Contentionless) at Source and Destination.

Limitations of LNI

These are the limitations, unsupported features, and known constraints of LNI, and scenarios where LNI may
not function as expected and the available workarounds.

* Simultaneous import of multiple live networks and scheduled import are not supported. LNI does not
support importing Non-SSON networks.

* If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the
node position after importing.

* Cisco ONP imports the proto-PID, if present in the inventory, and show as N/A PID in the Cisco ONP
BOM. Duplicate media channel labels are not supported. If multiple media channels with the same label
exist in the network, only one is imported; the rest are discarded.

* Fiber name, source, and destination names may not match between imports; source and destination site
names may interchange for bidirectional fibers. Fibers may not associate with the correct optical subnet
if channel numbers differ at source and destination, causing amplifier output power issues. Workaround:
Correct channel numbers at both ends and re-import or associate fibers with the correct optical subnet
after upgrade.

* Transponder cards that are not utilized for any circuits will be removed in Cisco ONP.

* The NCS1000 BoM is not included for networks imported with NCS2000 and NCS1004/NCS1014. The
NCS1000 BoM is populated following an upgrade analysis.

* A combination of BRK-8 and BRK-24 on the same node is not supported.

Predefined user profiles

A predefined user profile is a user configuration template that
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* saves all settings across both network and all entities such as sites, fibers, , services, and circuits into a
unified profile file,

* is stored securely in the Cisco ONP database and can be modified or exported as needed, and

* can be imported into the Cisco ONP environment to instantly apply the same configuration settings to
designs.

Table 13: Feature History

Feature Name Release Information Feature Description

Reusable predefined user profiles | Cisco ONP Release 26.1.1 Now you can save all network and
site-level settings into a reusable
profile file, in the CONP database.
You can use this profile during
network designing ensuring
consistent configurations across
different designs and teams. This
feature eliminates repetitive manual
setup, reduces errors, and
streamlines configuration sharing
and management within an
organization.

Cisco ONP lets you create reusable settings profiles that capture all configuration details for your planned or
deployed networks. These profiles help you consistently apply, share, and manage settings across multiple
platforms, including:

* NCS2000 (Releases 11.1.0, 25.1.1, 26.1.1) with SSON/Non-SSON modes and various traffic types
* NCS1010 (Releases 7.10.1 to 26.1.1)

* NCS1001 (Releases 7.10.1, 25.4.1)

* NCS1014 (Releases 25.1.1, 26.1.1)

By using profiles, you can eliminate repetitive manual configuration and reduce errors. Profiles are stored as
JSON files in the Cisco ONP database and include network-level, site-level, fiber, and media channel settings,
each with platform and version-specific compatibility.

Cisco ONP supports profiles for all key network entities, including:

* Networks

* Sides

» Sites (ROADM, OLA, TRAFFIC)
* Fibers

* Media Channels/Waves/Circuits
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Create user profile .

\)

Note Only newly created entities, such as sites and fibers, will be affected after applying the profiles. Existing
entities that were created before the profile application will not be impacted.

Create user profile

Step 1
Step 2

Step 3

Step 4

Step 5

Step 6

Use this task to create a user profile that stores configuration properties you can reuse when building new
networks. This approach allows your organization to standardize network templates and share configurations
easily.

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Choose Manage > Profiles.

Create a new profile.

a)
b)
c)
d)
e)

Click Create New Profile.

Enter the name of the profile.

Select the Profile Details such as platform and the Release number.

Click Fetch Default Propertiesto load the properties.

Under the Properties pane,select the settings you want to include for future networks. Then click Save.

Note
You cannot set optical subnet properties in the profile at this time.

Note

Ensure all necessary entity properties are updated before saving. You can navigate between different entities to update
properties and then save. Once saved, the profile cannot be modified. If changes are needed, users can clone and edit
the profile.

(Optional) Share the profile.

a)
b)

Click Share.
In the Share Profile window, select the groups and users you want to share the profile with and click Share.

(Optional) Export the profile to JSON file format:

a)

Click Export, to download the profile file to your system.

Exported files can be edited externally, backed up, or shared across Cisco ONP instances.

(Optional) Import a profile.

a)

Click Import, and select the JSON file.

The profile is imported to database and added to the user profile list.

Delete a profile if you are the owner of that profile:

a)

Click Delete.
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The system prompts an error message if the profile was already in use, else asks for confirmation to delete

b) Confirm to delete the profile.

Step 7 (Optional) Set the user profile as a default one:
a) Click Manage Default Profiles and for each platform choose the Default Profile.

Limitations of user profiles
User profiles are subject to these limitations:

» User profiles must be finalized before saving, as they cannot be modified afterward. To make changes,
update all necessary entity properties while navigating between entities prior to saving. If further
adjustments are required later, clone the existing profile and edit the clone.

* If you import a CPZ network that was exported from Release 26.1.1, the user profile associated with that
network is included and remains active. If you import a CPZ network from earlier releases without an
attached profile, you can apply a profile using the Profile property at the network level. The applied
profile affects only entities added to the network after the import. Existing entities remain unchanged.

* When you upgrade a network that was designed in releases prior to 26.1.1, where no profile was attached,
you can apply a profile, but it will only affect new entities added to the network after the upgrade, not
the existing ones.

» When creating a network using Excel, users can apply the profile. Values specified in Excel take
precedence over the profile. For properties not available in Excel and set to Auto, they are updated
according to the profile.

Optical subnets and their role in networks

An optical subnet is a network structure that
* consists of a collection of spans with defined properties,
* is automatically created when a new network is set up in Cisco ONP, and

» must exist in at least one instance for every network.

When a new network is created, Cisco ONP links an optical subnet to it, ensuring that each network has its
own optical subnet for proper operation.

Create optical subnet

Use this procedure to create an optical subnet in Cisco ONP for Non-SSON, SSON, or NCS 1010 networks.

\)

Note Check the Current Subnet check box in the properties window below the network tree, to make the subnet
you created as the current subnet. You cannot uncheck the Current Subnet check box.
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Step 1
Step 2
Step 3
Step 4

Before you begin

Log in to the Cisco ONP web interface

\}

Create optical subnet .

Note For NCS 1010 networks, both C-Band and L-Band optical subnets appear by default, from the Release 7.9.1.
For C-Band and C+L Futuristic networks, the L-Band optical subnet contains no fiber links unless upgraded
or configured with an L-Band edge.

Procedure

Open the required network (Non-SSON, SSON, or NCS 1010) in which you want to create a subnet.

Expand Subnet in the network tree panel.

Click the Ellipsisicon available next to the Optical Subnet, and select Create Optical Subnet.

In the Create Optical Subnet dialog box:

If you are creating optical subnet for...

Then...

non-SSON network

From the Cband Rules drop-down list, choose the C-band
design rules for the new optical subnet, then click Save.

SSON network

* From the Band Type drop-down list, choose either
C-Band or L-Band.

* From the Spectral Density drop-down list, choose the
spectral density for the new optical subnet that you
want to create.

The selected spectral density determines the value of
Name, CBand Rulesor L Band Rules, and Maximum
Number of Channelsthat appear in the Create
Optical Subnet dialog box.

Click Save.

NCS1001, NCS 1010 and NCS1014 networks

From the Band Type drop-down list, choose either
C-Band or L-Band.

From the Spectral Density drop-down list, choose the
spectral density for the new optical subnet that you
want to create.

From Release 5.2, the range of spectral density has
increased from 30 to 100 units.

The selected spectral density determines the value of
Name, CBand Rulesor L Band Rules, and Maximum
Number of Channelsthat appear in the Create
Optical Subnet dialog box.

* Click Save.
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Step 5 (Optional) After the new optical subnet is created:

If you want to...

Then...

select a new spectral density

select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

add a fiber to a subnet

add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet from the network
tree panel

* Click the Ellipsisicon available in the right side of the required optical
subnet and select Edit Fibers.

* In the Info dialog box, click OK.
The user interface will freeze to allow fiber selection from the map.

* Select the required fiber and click the Donebutton appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with each fiber.

enable Auto SD

select a new spectral density, and check the Auto checkbox in the properties
window displayed under the network tree.

Auto-SD automatically adjust the optimized spectral density based on the Circuit
Card type selected for the subnet spans.

Cisco ONP creates the new optical subnet with your selected properties and places it under Optical Subnet

in the network tree panel.

Convert NCS 2000 network to NCS 1010 network

Use this procedure to convert an NCS 2000 network (both SSON and non-SSON) into an NCS 1010 network.

Table 14: Feature History

Feature Name

Release Information |Feature Description

Convert NCS 2000
network to NCS 1010
network

Cisco ONP Release | The newly introduced NCS 1010 Convert option under
5.1 the Networ k menu enables you to directly convert an
existing NCS 2000 network into an NCS 1010 network.
This conversion eliminates the need to build an NCS
1010 network from scratch.
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Step 1

Step 2

Step 3

Share a network .

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Open the NCS 2000 network that you want to convert to an NCS 1010 network.

Ensure that the network is in Design M ode, Upgrade M ode or Release Upgrade M ode.
Choose Network > NCS 1010 Convert, then click OK.

The network is not converted and shows an error message if

« the network contains traffic sites,

» the fiber type is LS or TWClassic,

* the network contains OTN services,

» the Traffic Type property is set to anything other than Optical Source or Pluggable Card, and
» the Traffic Type is 100G-SD-FEC or 200G-SD-FEC in non-SSON networks.

Choose File> Save.
These parameters are automatically updated after the conversion:

* Contentionless sides are deleted, and contentionless demands are automatically changed as colorless, and

» protected channels are converted to two unprotected channels. The path, wavelength, regeneration sites, and cards
that are configured are retained.

Share a network

Step 1
Step 2
Step 3

Use this procedure to share a network with one or more users or user groups.
Before you begin
Log in to the Cisco ONP web interface.

Procedure

Open the network that you want to share.
Choose File> Share.
In the Share Network dialog box, select one or more users or user groups, and then click Share.

You can share the network with selected users or user groups in read-only mode.
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Access a shared network

Use this procedure to open a network shared by another user and save an editable copy for your own work.
Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 Open a shared network.
a) Choose File> Open Shared.

b) In the shared network list, choose the network you want to open.
The shared network opens in read-only mode.

Step 2 Choose File > Save As.
Step 3 Enter a name for your copy and click Save.

A copy of the shared network is saved.

You now have your own editable copy of the shared network. You can work on it according to the privileges of your
user role.

Step 4 (Optional) If you want, share your updated network with other users.

Unshare a network

Use this procedure to remove user or user group access to a previously shared network, ensuring only authorized
individuals retain visibility and control of the network.

Before you begin
Log in to the Cisco ONP web interface.

Procedure
Step 1 Open the network you want to unshare.
Step 2 Choose > Share.
Step 3 In the Share Network dialog box, remove the name of one or more users or user groups from the list, then click Share.

The shared network is no longer available to the users or user groups that are removed.

Split-Step Fourier simulation

A split-step Fourier (SSF) simulation is a computational method that

« calculates optical parameters such as OSNR and BER,
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Split-Step Fourier simulation .

* improves simulation accuracy in complex optical network scenarios, and

* leverages GPU-based computation for intensive analysis.

SSF simulation is introduced alongside the e-GN algorithm to enhance the analysis of NCS 1010 networks,
providing improved accuracy for optical signal-to-noise ratio (OSNR) and bit error rate (BER) simulations.

Table 15: Feature History

Feature Name

Release
Information

Feature Description

Split-Step
Fourier (SSF)
Simulation
Method

Cisco ONP
Release
25.1.1

The Split-Step Fourier (SSF) method is introduced to calculate optical
parameters in addition to the existing e-GN algorithm for analyzing NCS 1010
networks. This enhancement:

* Improves the accuracy of the simulations for OSNR and BER, particularly
in complex network scenarios.

* Provides an SSF engine that leverages GPUs to work on intense
calculations.

* Requests simulation generation from GENE (Generic Engine for NCS
1000 platforms)

* Monitors analysis progress on the GPU server, and updates the user
through analysis notifications.

* Sends simulation results to GENE for report generation after analysis
completion.

* Provides a Lookup Table that contains the default optical specification
values for each supported amplifier.

The new properties that enable the SSF method for network analysis are.

* At network level, Advanced Optical Settings> SSF
Simulation—Enables the SSF simulation. Enable the Enable Special
Settings check box to view the SSF Smulation check box

* At network level, Advanced Optical Settings> LUT version—Shows
the default LUT version to be used for network analysis. Enable the Enable
Fecial Settings check box to view the LUT version check box

* Preferences> General Settings> SSF Server Details—Allows to
configure the GPU server used for SSF simulation.

» Manage > L ookup Table—Allows you to refer the default optical
specification of the supported amplifiers.
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Feature Name | Release Feature Description
Information

NCS 1010 Cisco ONP | Cisco ONP has implemented the following enhancements for network design:

network Release * ALC Phase II Device Parameters:
design 26.1.1
enhancements NETCONF XML files now include additional ALC phase II parameters,

such as Raman amplification and advanced optical settings for more
precise device configuration.

* Lookup Table (LUT) Improvements:

* Raman gain values are now visible in LUT entries.
» LUTs can be imported/exported, including CPZ data.

* Raman side amplification is calculated from LUT entries for better
modeling accuracy.

* Tx connector loss is user-configurable and factored into PSD values.

* SSF simulation enhancements:
* Uses secure HTTPS protocol for communication with SSF server.

* Supports parallel SSF analysis from different servers when multiple
users trigger the process

* Enables background analysis without interrupting other tasks.

* Displays estimated simulation timing in the analysis progress bar.

These updates enhance the accuracy, configurability, security, and usability
of optical network planning and simulation for NCS 1010 networks.

From Release 26.1.1, the SSF analysis includes the following enhancements:

* The SSF analysis can now be executed in the background. To enable this feature, set the property
"conp.backgroundAnalysis.enable" to true in the filename.properties in the location /opt/cnp/conf folder
in Cisco ONP server. Once enabled, you can click the "Run in Background" button when starting the
SSF analysis.

* The analysis progress bar now displays the estimated remaining time for the analysis.

* The SSF simulation supports the analysis of networks with multiple point-to-point disjoint networks and
uses the HTTPS Protocol for communication with GPU-based SSF instances.

* If multiple users configure different SSF servers on the CONP server and initiate the analysis, multiple
SSF analysis can run concurrently in the background. However, if a single user starts two SSF analysis,
the second analysis will remain in the queue until the first one is completed. A message stating "waiting
for current SSF analysis to be completed" will be displayed in the analysis progress bar.

Limitations of SSF simulation

SSF simulation currently has these limitations:
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* Supports only point-to-point networks
» Works only with CIMS interfaces
* Supports only colorless add/drop

» Computation intensive than e-GN algorithm for better OSNR margins

How SSF simulation works

SSF simulation uses the split-step Fourier method to analyze optical parameters in NCS 1010 networks by
utilizing GPU acceleration and integrating with the GENE engine.

Summary

The key components involved in the process are:
 SSF engine: Runs on GPUs to perform intensive optical calculations.
* GENE (Generic Engine for NCS 1000 platfor ms): Initiates and receives simulation jobs and results.
* GPU server: Handles the computational workload and notifies you about analysis progress.

* Lookup Table (LUT): Stores default optical specification values for each supported amplifier.

Workflow
The process involves these stages:

1. The SSF engine requests simulation generation from GENE.

2. The GPU server executes intensive optical parameter calculations using the SSF method.

3. The system monitors analysis progress and sends you notifications.

4. When the analysis is complete, you can view the simulation results in GENE for report generation.
5

The system references the Lookup Table for default optical specification values as part of the analysis.

Result

SSF simulation gives you accurate OSNR and BER simulations, especially for complex optical network
scenarios, with improved computational performance through GPU acceleration.

Set SSF server details

Use this procedure to set the SSF server to run the SSF analysis.
Before you begin
Install the SSF component. See Install Cisco ONP.
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. Lookup tables

Procedure

Step 1 Navigate to SSF Server Detalils.

a) Choose Preferences> General Settings

b) In the dialog box, select SSF Server Details.

Step 2 Enter the SSF server details.

» SSF Server IP: Enter the server IP address.

» API Key: This field is disabled.

* Proxy IP: Enter the customized proxy IP address.

* Proxy Port: Enter the proxy port of the server.

Step3  Click OK.

To reset the server details or close the dialog box, click Reset or Cancel.

Lookup tables

A lookup table is a configuration data structure that

» stores predefined values used by analysis and simulation processes,

» allows efficient retrieval of data without the need for recalculation, and

* supports versioning, enabling different simulation or network scenarios.

Design and Analyze Networks |

Cisco ONP uses lookup tables (LUTSs) for analysis with SSF simulation and when SSF simulation is not active.
Only NCS 1010 networks use LUT values. You can enable LUT functionality only after selecting the Advanced

Special Settings check box at the network level.

This table explains the range of span loss for different fiber types. LUT calculations work only if the loss

stays within these ranges.

Fiber Type Raman Min Span loss (dB) Max Span loss (dB)
SMF No 5 26.5

SMF Yes 18 33.0

E-LEAF No 5 22.9

E-LEAF Yes 18 32.9

TW-C No 5 20.3

TW-C Yes 16 30
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Manage amplifier gains using look up table

Use this procedure to refer or to manage the amplifier gains in the look up table.

Procedure

Step 1 Open look up table.

a) Choose Manage > Lookup Table
The Manage L ookup Table dialog box opens displaying the list of supported amplifiers.

Options Actions

Search Allows you to type in the amplifier to filter the desired
lookup table.

Check boxes Selects all amplifier tables or only the required amplifier
tables.

Page numbers Turns to the desired page.

Import Imports the customized tables.

Export Exports the selected tables.

Delete Deletes the selected tables.

Cancel Closes the dialog box.

When expanded, the table displays the optical specifications.

Table 16: Amplifier optical specifications

Parameter Description

Fiber Type Displays the list of supported fibers for the amplifier.

Total Loss (dB) | Displays total signal loss in dB.

SD Range Displays the SD gain range.

Raman Displays the status of Raman amplification in the amplifier. You can select and filter the table based
Amplified on Raman gain value and whether Raman is applicable or not.

Ramna Gain Displays the Raman amplifier gain. You can select and filter the table based on the Raman gain value.

BST PSD (dBm) | Displays the PSD value for the booster amplifier in dBm. Raman gain is used in the calculation of
the PSD.

More Parameters | Contains an information button to check for additional values.

Step 2 (Optional) Customize the optical specifications in the Lookup table.
a) Select the required amplifier.
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b) Click Export.
The amplifier value downloads in spreadsheet.

c) Edit the values in the downloaded spreadsheet and click Import.
The new values are added to the Lookup table.

Step 3 (Optional) Delete the customized specifications in the Lookup table.

a) Select the required amplifier.
b) Click Delete.

Restriction
You cannot delete the default tables.

Analyze the network

After completing the network design, use this procedure to analyze the network.

Table 17: Feature History

Feature Name Release Information Description
Detailed Tooltip for Sites on the | Cisco ONP Release 5.1 The See More Details option has
Map View been introduced in the tooltip

displayed on hovering over Sites
on the Map view of an analyzed
network. This option shows the
Amplifier data and PSD (Power
Spectral Density) profile graph. The
See More Details option avoids
navigating to the Entity Editor to
view these details.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network that you want to analyze.
Step 2 Analyze the network:
a) Choose Network > Analyze.

The analysis progress indicator shows the current analysis status. After successful analysis, the network goes to
Analyze Mode.

b) Ifyou see the “Analysis Failed.” message, navigate to the Elements> M essages tab to see the list of error details in
the analyzed network.

. Design and Analyze Networks


conp-26-xx-config-guide_chapter1.pdf#nameddest=unique_12

| Design and Analyze Networks
Bottom-up flow and network creation .

By default, the system displays only the key messages when the Critical Only toggle button is enabled. If you want
to view the entire network message, disable the Critical Only toggle button.

c) Resolve the error and analyze the network again. Continue until you resolve all errors.

Note

You may see the error message 'Unexpected Situation 999' if incorrect property values are entered or changed during
network design. Contact Cisco TAC to identify the exact cause of the error. Afterwards, modify the suggested property
value so that the network analysis completes successfully.

Step 3 If you want to view the details such as Amplifier Data and PSD Profile graph for a site in an analyzed network, hover

the mouse over a site and click See M ore Details.

Amplifier data includes output power, EOL gain, attenuator in and out, and Raman gain values. For NCS 1010 sites, the
amplifier data does not include attenuator details, and only these sites show the PSD profile graph.

Bottom-up flow and network creation
A bottom-up flow is a network creation approach that
* enables incremental, step-by-step building of a network over several days,

« allows analysis and report generation at each phase without requiring all services or waves to be configured
on the first day, and

» provides flexibility in the order of adding network elements such as services and waves.

How bottom-up flows work

Summary

The bottom-up flow process enables gradual, phase-based network creation and analysis, giving users flexibility
in building and evaluating their network incrementally.

The key components involved in the process are:
* Network administrator: Builds and configures the network in stages.
» Network topology: Consists of sites and fibers initially added to form the network’s structure.

* Services and waves: Additional network components that can be added over time for increased
functionality and connectivity.

Workflow
The process involves the following stages:

1. On Day 0, the administrator creates the network by adding all sites and fibers to define the topology. They
can analyze the network and view reports at this stage without configuring services or waves.

2. On Day 1, the administrator adds waves between sites (including both previously added and new
sites/fibers), then re-analyzes and reviews updated reports.

Design and Analyze Networks .



Design and Analyze Networks |
. Idle timeout in the Analyze mode

3. On Day 2, the administrator adds services and tags the waves created in the previous stage, as well as
incorporates additional sites and fibers as needed, with ongoing analysis and reporting.

4. After the initial topology is created, services or waves can be added in any order, without following a
prescribed sequence.

Result

The bottom-up flow process supports flexible, staged network development and ongoing analysis, optimizing
the configuration and deployment of Non-SSON networks.

Idle timeout in the Analyze mode
An idle timeout in analyze mode is a session management feature that
* logs users out of Cisco ONP if the browser is inactive for a default duration of 15 minutes,
» allows system administrators to disable or adjust the timeout through server configuration options, and

» affects ongoing network analysis by running it in the background if logout occurs during an active analysis
cycle.

Idle timeout settings and session restoration behavior

The default idle timeout in Cisco ONP is 15 minutes. System administrators can disable this timeout by setting
the enabled option to false in the configuration file, or adjust the timeout duration by editing the duration
option.

If a session times out during an analysis, network analysis continues to run in the background. When the user
logs in again:

« If the analysis is ongoing, the progress bar appears and no actions are allowed.
» If the analysis is complete, the network opens in Analyze mode.

» [f the analysis failed, the network opens in Design mode and the failure reason can be viewed under
Elements> M essages.

Upgrade the analyzed network

Table 18: Feature History

Feature Name Release Information Description
NCS 1010 Network Upgrade Cisco ONP Release 5.0 After a network is analyzed, all the
Flexibility network elements get locked. With

this feature, you can selectively
unlock certain network elements to
upgrade the network further. This
helps in preventing accidental
updates to the part of the network
that does not need any
modification.
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Step 1
Step 2

Step 3

Step 4

Step 5

Step 6

Upgrade the analyzed network .

Use this procedure to upgrade an existing network that is in analyzed mode. You can change specific properties
of a network element while keeping the network layout and design locked.

Upgrade is supported for NCS2K, NCS4K-2K, NCS4K-1K-2K, and NCS1010 networks.

Before you begin
* Log in to the Cisco ONP web interface

* Create a user profile, if you want to apply the profile that contains predefined configurations, on a network
that was designed in releases prior to 26.1.1.

Procedure

Open the network that you want to upgrade.
Upgrade the network:

a) Choose Network > Upgrade.
b) Click Yes.

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), media channel (for SSON), and circuits (for NCS 1010) are locked.

To modify a network element in the network tree panel, click the Ellipsisicon next to element, and choose Unlock.
Unlock individual elements at the node, side, add/drop card, or amplifier level in the network tree hierarchy.

If you want to change only the add/drop between MD-32-ODD/Even or BRK 24/16/8 in the NCS 1010 network, you
can unlock the add/drop without unlocking the network elements that are higher in the hierarchy.

Make these modifications:
* Edit properties of network elements.
* Delete elements from the network.

» Add a new site, wave, service, demand, optical subnet, or fiber into the network map.

Choose File> Save.
The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

Note
To insert a node in upgrade mode, unlock the fibers connected to that node, then add the node to the network.

Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network with an applied layout template, the template updates to
include the new service or fiber. You can export the template, make changes, and reapply it to another network.

Choose Network > Design to further upgrade the newly upgraded network design.
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Each time you upgrade the network, Cisco ONP saves the new version as a child network and maintains the parent-child

relationship.

Upgrade LNI network

Use this procedure to correct errors in your LNI network, modify ,and reanalyze it, and view updated BOM,
layout, connections, and optical results.

Table 19: Feature History

Feature Name

Release Information

Feature Description

Upgrade LNI Network

Cisco ONP Release 4.1

This feature allows you to upgrade
and modify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network imported through LNI that you want to upgrade.

Step 2 Upgrade the network:
a) Choose Network > Upgrade.
b) Click Yes.

The message “Network Upgraded Successfully” appears. After you upgrade the network, it enters upgrade mode,

which locks elements such as sites, fiber, OTN services, and media channels.

Step 3 To modify a network element in the network tree panel, click the EllipsisSicon next to element, and choose Unlock.

Unlock individual elements at the node, side, add/drop card, or amplifier level in the network tree hierarchy.

Make these modifications:

» Edit the properties of network elements.

¢ Delete elements from the network.

» Add a new site, wave, service, demand, optical subnet, or fiber into the network map.

Step 4 Choose File> Save.
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Step 5

Step 6

Possible error scenarios and the workarounds .

Each time that you upgrade the network, Cisco ONP saves the new version as a child network and maintains the parent-child
relationship.

Choose Network > Analyze.

Analysis succeeds only if the imported network is consistent and valid. For instance, in an NCS 2000 network imported
from Cisco ONC, if the device connections do not match with Cisco ONP rules, the upgrade analysis may fail with a
connection error. If the analysis fails, perform the listed steps:

a)
b)

<)

Reanalyze the network.

After analyzing the network:
a) Click the Layout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004

platforms. See

Check the reports under Elements M essages for failure reasons.

Unlock the specific site to allow Cisco ONP to rebuild the connections according to its rules. Alternatively, correct
the connections on the device and re-import the network.

b) Click the BOM tab and the Results tab to view the BOM and optical results.

Possible error scenarios and the workarounds

This table provides the workarounds for the errors that are shown under the Elements > M essages tab.

Table 20: Error scenarios and the workarounds

Error message

Workarounds

In Site4.A, output power setting is not supported by
the amplifier.

Unlock C-Band amplifiers for side A within Site4 in
the Network tree, and set the correct output power. If
you are unsure, choose Auto and analyze the result.
Cisco ONP chooses the best value based on the
configuration.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

For protected OTN or SSON services, ensure that at
least two contentionless sides are present on both the
source and destination sites. Add contentionless sides
where necessary, then analyze the network
configuration.

Cannot complete mesh connections at Site3.

Unlock the site and reanalyze.

Fiber between Nodel.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
connector loss value so that it is greater than zero.
The typical value is 0.2.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Unlock the corresponding fiber couple and update the
Tot SOL Loss w/o Connectors value so that it is
greater than zero.

Span Fiber-2 is forced as Raman but no traffic is
present.

Remove Raman forcing on the fiber, or force the path
for a service to ensure it travels through a
Raman-enabled span.
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Error message Workarounds

Couple Fiber-2 has Raman enabled on the duct but | Force RAMAN-CTP or COP on the Fiber-2
corresponding Raman Forcing is missing. connecting node interface, or remove RAMAN forcing
on the Fiber-2.

Circuit Verify the optical source card type configured at the
[onc BH-2 1002/1/PORT-3 BH-4 1002/5/PORT-2] | Circuit or Media Channel Trail level. If it differs from
imported with default optical source card type the expected type, perform a network upgrade of the

imported network and force the required card type at
the Circuit or Media Channel Trail level.

Error: Spectrum could not be assigned for the Forced/Locked wavelength is not feasible for spectrum
demand/group. allocation for the demand. Choose an adjacent central
wavelength or frequency separated by 6.25 GHz. Set
Wavelength is not feasible for the card type or in the
3.125 GHz grid. In NCS2K, only 6.25 GHz width is
supported. Try setting the adjacent wavelength or Set
Wavelength to Auto.

Ductots_Site-2-1_Slte-1-1 is a Raman amplified span | Enable Ignore Raman Span Checks property at
using RAMAN-COP: all circuits must be terminated | network level or create P2P circuits on RAMAN-COP
in Site-1.A and Site-2.A span.

)

Note No specific action is required for noncritical messages. These are just information messages to the user.

Upgrade the software release of a network

Table 21: Feature History

Feature Name |Release Information |Feature Description

Release Cisco ONP Release | This feature allows you to choose the NCS 2000 system release to
Upgrade 4.1 the desired release (11.1.0, 12.0.1, or 12.1.0), while performing the
release upgrade of CTP network, Cisco ONP network, network
imported through Excel, and LNI network.

You can upgrade the software version of networks that are imported from CTP, created in Cisco ONP, LNI
Network, or imported from Excel to any desired release version. The release upgrade is supported for both
SSON and non-SSON networks that have NCS 2000 nodes with ROADM, OLA, Traffic, or Passthrough
functionality, and NCS 1010 networks.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

\)

Note NCS 2000 supports Cisco Optical Site Manager from 25.1.1.
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See Supported upgrade paths for network system releases, on page 41for the available upgrade releases for
each network type.

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network in which you want to perform the system release upgrade.
Step 2 Upgrade the software release of the network:
a) Choose Network > Release Upgrade.

b) From the New System Release drop-down list, choose the system release of NCS 2000 or NCS 1010, to which you
want to upgrade.

c¢) Click Submit.

The upgraded network is saved as a child network.

)

Note If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by
the PMD value when you edit the fiber properties.

What to do next

Unlock and modify network elements as needed.

Supported upgrade paths for network system releases
This table shows the available upgrade releases for each network type.

Table 22: Supported upgrade paths for network system releases

Network Upgrade Release
CTP network * From 11.0.0 to 11.1.0, 25.1.1, and 26.11
(.mpz)

* From 11.1.0 to 25.1.1 and 26.11
Cisco ONP * From 11.0.0 to 11.1.0, and 26.11
network

* From 11.1.0 to 26.1.1

LNI network Note
Release upgrade is not supported for the LNI networks in Release 25.1.1.
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Network Upgrade Release

NCS 1010 Network +7.10.1 to 7.11.1, 24.31, 25.1.1, and 26.1.1
»7.11.1 to 24.31, 25.1.1, and 26.1.1

NCS 1001 Network *7.10.1 to 25.4.1

NCS 1014 Network *25.1.1t0 26.1.1

Plan mode

Plan mode is a feature that

* enables what-if analysis on existing network designs,

* simulates network behavior under failure scenarios, and

* determines the ability to reroute services without providing guidance for expanding network infrastructure.

Table 23: Feature History

Feature Name Release Information

Feature Description

What-if Analysis for OTN Services | Cisco ONP Release 4.1

This feature extends the current
implementation of What-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported forsworn
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Advantages of plan mode
The advantages of the plan mode are:

+ Simulates and analyzes potential network issues and solutions,
» focuses on rerouting capabilities, and

» avoids requiring physical changes to network infrastructure.

Supported network elements

Supported network elements in plan mode include:

* An NCS 2000 aggregated node that includes ROADM, OLA, and passthrough nodes
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Step 3

Step 4

Step 5

* Traffic nodes including1 K-2K, 4K-2K, and 4K-1K-2K
* Nodes created in Cisco ONP
» Networks imported from Cisco Transport Planner in mpz format

* Networks imported from LNI

Limitations of plan mode
Plan mode has these limitations:

* Only users with PLANNER and ADMIN roles can access the Plan mode.

* Plan mode does not guide you in turning up new wavelengths or adding new network components.

Use this procedure to evaluate potential network failures and review restoration outcomes by simulating fiber
and site outages in Plan mode.

Before you begin
Log in to the Cisco ONP web interface as a user with admin or planner role.

Follow these steps to perform a what-if analysis in Plan mode

Procedure

Open the analyzed network.
Choose Network > Enter Plan Mode.

The network switches to Plan mode. In this mode, you can perform what-if analysis by failing fibers and sites.

Fail ne or more sites:

a) In the network tree, expand Sites.

b) Click the Ellipsisicon available in the right side of the site, and select Fail. Alternatively, right-click a site on the
map and select Fail.

¢) To fail multiple sites, select them and choose Fail.

Fail one or more fibers:

a) In the network tree, expand Fibers.
b) Click the Ellipsisicon next to the fiber, and click Fail. Alternatively, right-click a fiber in the map and select Fail.
¢) To fail multiple fibers, select them and choose Fail.

When a fiber fails, all media channels or waves, OTN services, and demands that pass through the failed fiber also
fail. Symbols on the map indicate these failures:

* Failed channels: Red cross
* Fibers impacted due to site failure: Yellow cross

* Restored channels: Green check

d) To undo the fiber failure, click the Ellipsisicon next to the fiber, and click Undo Fail.

(Optional) Create a failure set if you wish to group selected failures. SeeCreate a failure set.
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Step 6

Step 7

Step 8

After testing, restore the failed fibers by choosing Restore.
The restored channels are indicated by a green check mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber are also restored. The Path Computation
Element (PCE) restores OTN services based on optical feasibility and OTN constraints.

Export the failure report:

a) Choose Export > Failure Report to export the failure report as an Excel file. The failure report includes the parameters
described in Failure report , on page 45.

b) Alternatively, click Export in the Failure Report area under the map.

Review unrestored channels and reasons for restoration failure in the Elements > M essages tab.

Exit Plan mode:
a) Choose Network > Exit Plan M ode.

The what-if analysis and failure report are completed and exported, providing insight into service impact and
recovery.

Create a failure set

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Use this procedure to create and manage failed fibers and sites as a failure set within a failure group. You can
simulate or track network outages efficiently in a single action.

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Open a network and enter the Plan mode.
Click the Ellipsisicon next to the Failure Groups option in the network tree panel.
Click Add Failure Group.

A failure group gets created.

Add fibers and sites to the group.

a) Choose the Fibersand Sitesto fail by selecting the check boxes next to them.
b) Click the Ellipsisicon next to the chosen Fibers and Sites, and click Fail.

Click the Ellipsisicon next to the network name and click Add Failure Set.
Select the failure group to which the failed fibers or sites must be added.
The system creates the failure set under the failure group and adds the failed fibers or sites to it.

Note
If a network has dark fibers that do not carry traffic, the system does not consider those paths for restoration.
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Failure report .

This table describes the various parameters of the failure report.

Table 24: Failure report

Report Description
Failed Fibers Shows the failed fibers in the network.
Failed Sites Shows the failed sites in the network.

Impacted Fibers

Shows the fibers that are impacted due to the site failure.

Total Channels

Shows the total number of media channels in the network.

Failed Channels

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Restored Channels

Shows the total number of media channels that are restored from the failure state.

Unrestored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Fiber HotZones

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

» Fiber: Shows the fibers that are listed under fiber hot zones.

« Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

« Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Total Services

Shows the total number of services going through the fiber that was failed.

Failed Services

Shows the number of failed services going through the fiber that was failed.

Restored Services

Shows the number of restored services going through the fiber that was restored.

Unrestored Services

Shows the number of unrestored services going through the fiber that was restored.

Automatic suggestion for regeneration sites in Plan mode

Automatic suggestion for regeneration sites in plan mode is a Cisco ONP feature that

» analyzes optical channels for high and marginal risk of failure,

* automatically proposes feasible regeneration sites in planning mode, and

+ allows users to incorporate these sites to ensure network optical feasibility.
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This feature operates in Plan mode within Cisco ONP, leveraging a regeneration suggestion algorithm run by
the Path Computation Element (PCE). It assesses network feasibility and presents suggested regeneration
sites in the Feasibility Report for optically risky channels, streamlining the process of making the network
optically feasible.

Table 25: Feature History

Feature Name Release Information Feature Description
Automatic Suggestion for Cisco ONP Release 5.0 Cisco ONP displays feasibility
Regeneration Sites report in the Plan mode. This report

automatically suggests regeneration
sites for the channels with high and
marginal risk of failure. You can
incorporate these regeneration sites
in the optical network to make the
channel optically feasible. This
feature avoids multiple iterations
required to manually create the
regeneration sites and test the
optical feasibility of large networks.

Supported scenarios for automatic regeneration site suggestion

Automatic regeneration site suggestion is supported for both SSON and non-SSON networks that have
contentionless channels or waves between these site types:

* NCS2K (ROADM) sites
* 4K-1K-2K (TRAFFIC) sites

If channels already have forced regeneration, suggestions are shown at the section level.

How automatic regeneration site suggestion works

Summary

The automatic regeneration site suggestion process identifies channels at risk of optical failure and proposes
suitable regeneration sites to enhance network feasibility.

The key components involved in the process are:

* Cisco ONP: Assesses network feasibility and displays the Feasibility Report in Plan mode.

* PCE (Path Computation Element): Runs the regeneration suggestion algorithm to determine optimal
regeneration site locations.

* Feasibility Report: Presents the suggested regeneration sites and channel risk statuses for user review.

Workflow

The process involves these stages:
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1. * Cisco ONP evaluates the optical feasibility of the network in Plan mode and identifies channels with
high or marginal risk of failure (indicated as red and orange in the Optical Results page).

2. * Cisco ONP submits these channels to PCE, which executes a regeneration suggestion algorithm.
3. * The algorithm suggests regeneration sites for the identified channels.
4. * Upon entering Plan mode, Cisco ONP displays the recommended regeneration sites at the bottom

of the map in the Feasibility Report.

5. * You can apply the suggested regeneration sites to improve optical feasibility or export the report for
reference.

Result

The process enables rapid identification and application of regeneration sites to ensure optical feasibility for
complex networks, minimizing manual intervention.

Apply the suggested regen sites

Step 1
Step 2
Step 3

Step 4

Step 5

Use this procedure to apply the suggested regeneration sites to make the network optically feasible.

Before you begin

Log in to the Cisco ONP web interface as a user with admin or planner role.

Procedure

Open an analyzed network.

Enter the plan mode.

Apply the suggested regen sites to the network.

a) Choose Network > Open Feasibility Report.

The Feasibility Report is displayed at the bottom of the map.

b) Select the channels that require regeneration and click Apply.
¢) Inthe Suggested Regen Applied dialog box,click OK .

Exit the Plan mode.

a) Choose Network > Exit Plan M ode.
b) Click Yes.

The network gets automatically upgraded and saved as a new network. Channels with applied regens are unlocked. The
Regen Sites property is automatically updated and becomes noneditable.

Analyze the network.
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On the Optical Results page, he SOL and EOL fields become green. Channels do not appear in the feasibility report
again when you switch to plan mode.

Feasibility report

The Feasibility Report table encompasses several fields, which are crucial for assessing the optical feasibility
of the network.

Table 26: Feasibility report

Field Description

Channel Name Displays the list of channels (trail and sections) that
are not optically feasible.

Alarm Displays the color of alarm (red, orange, or yellow)

Paths Displays the actual path of the channel as hyperlink.
If you click the link, the path is highlighted in the
map.

Suggested Regens Displays the intermediate sites that can be used as
regen sites so that the channel becomes optically
feasible.

The Suggested Regen field appears as NA in these situations:

* Channels display yellow alarms, meaning the loss is negligible.
* The loss is high and there are not enough available intermediate sites to compensate for the overall loss.

* Intermediate sites without added contentionless sides are not considered for regeneration sites.

Export the feasibility report

Use this procedure to save the regeneration site suggestions and channel feasibility results for external use or
recordkeeping.

The Feasibility Report in Cisco ONP Plan mode includes regeneration site suggestions for channels at risk.
You may need to export this information.

Procedure

Step 1 In the Plan mode, locate the Feasibility Report at the bottom of the map.
Step 2 Click Export.

The Feasibility Report, including suggested regeneration sites, is exported for reference or further analysis.
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Line Rate Tuner mode

Line Rate Tuner mode is a network planning feature that

* automates the calculation and selection of optimal optical sources for a network,
» reduces human errors by minimizing manual calculations, and

» streamlines the process of selecting the correct optical source from available resources.

Table 27: Feature History

Feature Name Release Information |Feature Description

Automated Selection of Cisco ONP Release | You can now automate the calculation of optical
Optimal Wavelength Bitrate: |5.2 sources for your networks using the new Line Rate
Flexible Modeling Tuner Mode. This mode reduces human errors while

finding the correct optical source for your network
from a set of network resources.

\ )

Note Line Rate Tuner mode is available for NCS 2000 networks and NCS 1010 networks.

Optimize optical sources using Line Rate Tuner mode

Step 1
Step 2

Step 3
Step 4
Step 5

Step 6

Use this procedure to automate, simulate, and apply optimal optical source configurations to your network
using the Line Rate Tuner mode in Cisco ONP.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Open the network in Analyze mode.
Choose Network > Enter Line Rate Tuner Mode.

You see a progress bar while the system switches to Line Rate Tuner mode.

The network opens in the Line Rate Tuner Mode.

Run the line rate tuner analysis on a section of media channel to create custom optical source that you can add to the
network. For steps, see the Create a custom optical source using tuner analysis, on page 50 task.

Run the tuner analysis again for another new section of the media channel. For steps, see the Start a new tuner analysis,
on page 53 task.

Open the tuner results and add them to the network. For steps, see the Add the custom optical source to the network, on
page 53 task.

Exit the Line Rate Tuner mode.
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a) Choose Network > Exit Line Rate Tuner Mode.
The Exiting Tuner dialog box appears.

b) Choose the appropriate action as required.

Button Actions

Previous State Returns your network to its previous state and applies the changes.
Upgrade Switches your network to Upgrade mode and applies the changes.
Cancel Cancels the operation.

The network exits the Line Rate Tuner mode.

The network is updated with optimized optical sources and demand channels. Cisco ONP exits tuner mode,
when required.

Create a custom optical source using tuner analysis

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Use this procedure in Cisco ONP to simulate and configure a new custom optical source. You can also modify
parameters for media channel sections and save the results.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Open the network in Line Rate Tuner mode.
Click Open Tuner Input.

In the network tree, select the section of the media channel to which you want to add the tuner input.
The section you selected appears with default parameter values in Select Input Parameters.
Modify the Input Parameters as required.

See Input parameters for creating custom optical sources, on page 51.

(Optional) Click Reset to reset the modified parameters to default values.

Click Add.

A confirmation message appears indicating the tuner input was added successfully. You can review the details of the
modified section.

Table 28: Select section parameters

Section Parameters Description
Section Label Name of the modified section.
Src Site Site name for the optical channel source.
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Input parameters for creating custom optical sources .

Section Parameters

Description

Dst Site Site name for the optical channel destination.
Path Fiber paths in the section.
Actions Icons to edit or delete the modified section.

Step 7 (Optional) Edit or delete the modified section.

To edit:

a. Click the pencil icon.

b. Modify the input parameters as required.

c. Click Updateto save the changes.

To delete:
a. Click the trash bin icon.

b. Click Yesto confirm.

Step 8 Click Run Tuner to start the simulation.

The progress bar appears and notifies you when the analysis completes.

Step 9 In Tuner Result, click Export to export the results as an Excel file for reference.

The custom optical source is created, tuner analysis is completed, and results are available for export and

review.

What to do next

Add the custom optical source to the network.

Input parameters for creating custom optical sources

This table describes the input parameters that are required for creating custom optical sources.

Table 29: Input parameters for creating custom optical sources

Property Platform Description

Optical Family |NCS 2000 Choose the optical family. Cisco ONP shows options based on the
SSON network analysis and the optical family you select. Based on the optical
NCS 1010 family you select, the remaining parameters provide related options.

Optical Source |NCS 2000 Choose the optical source. Cisco ONP shows a list of optical sources
SSON you have already imported.
NCS 1010
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Property Platform Description
Data Rate NCS 2000 Choose the data rate. Based on the optical family you select, Cisco ONP
SSON displays options to choose the channel capacity for the new section.
NCS 1010
Bit Rate Range |NCS 2000 Choose the bit data rate. Based on the optical family you select, Cisco
SSON ONP shows options to choose the speed of data transfer in the new
NCS 1010 section.
Baud Rate Range | NCS 2000 Choose the baud rate range. Based on the optical family you select,
SSON Cisco ONP shows options to set the minimum signal width for each
NCS 1010 new channel.
FEC Type NCS 2000 Choose the FEC type. Based on the optical family you select, Cisco
SSON ONP shows a list of supported FEC types.
NCS 1010
Result Type NCS 2000 Choose the Result Type. The available options are:
SSON * Best OSNR: shows results based on maximum OSNR margin.
NCS 1010 . . . .
* Maximum Capacity: shows results based on the maximum capacity
of the channels.
* Maximum DataRate Maximum Capacity: show resulsts based on
maximum data rate per maximum capacity.
* Maximum DataRate Best OSNR: show resulsts based on maximum
data rate per maximum OSNR margin.
Optical NCS 2000 Choose optical feasibility for the new section. The available options
Feasibility SSON are:
NCS 1010 » Green
* Yellow
* Orange
* Red
Each color represents the severity of alarms that may arise in the new
section.
Sigma Number |NCS 2000 Choose the sigma number from 0 to 3. The sigma number is used in the
SSON calculation of the OSNR margin.
NCS 1010
Number of NCS 2000 Choose the number of optical source results required for the new section
results SSON .
The default value is 5, but you can select up to 15 results.
NCS 1010
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Start a new tuner analysis
Use these steps to start a fresh tuner analysis for the new section.
Before you begin
Log in to the Cisco ONP web interface

Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Start New.

The Start New Tuner dialog box appears and asks for confirmation.
Step 3 (Optional) Check the Retain the tuner inputs check box to keep the previous input values.
Step 4 Click Yes.
The message Started new tuner successfully appears.
Step 5 Modify the input parameters of the new section as needed, and click Update to save the parameters.
Step 6 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

What to do next

The analysis for the new section is completed successfully using the updated input parameters. The results
are available for review.

What to do next

Add the tuner results to the network.

Add the custom optical source to the network

Use this procedure to add custom demand channels and their associated optical sources generated from a
Tuner Result.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears and displays the new sections and their demand channels.

Step 3 To add the optical source to the network, perform one of these actions:

To add manually:
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Note
For some custom optical source results, the download icon becomes disabled. In such cases, go to Manage > Optical
Sour ce to download the optical result as explained in Download Optical Sources.

a. Click the Download Optical Sourceicon.
The Downloading Optical Source message appears. The Excel sheet contains data in Cisco ONP format.
b. Open the Excel sheet to review the data.

c. Import optical sources as explained in Import Optical Sources.

To add automatically:
a. Click the Add Demand to Network icon.
The No. of demands pop-up appears asking for the number of demands to add to the network.
b. Enter the demands number and click Add.
When the Demand is added successfully message appears, confirm that the new demand appears in the network tree.

Cisco ONP automatically adds the required optical source to the server.

The custom optical source and its demand are successfully added to the network. You can review the new
demand and associated optical source in the network tree.

Import optical sources

Use this procedure to import an optical source

An Optical source wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Before you begin
Log in to the Cisco ONP web interface.

Create an optical source from an Excel template, on page 55

Procedure

Step 1 Choose Manage > Optical Source.
The Manage Optical Source dialog box appears.
The default optical sources available in the server include:

* OpticalSources NCS2K 400GXP-LC NCS4K-4H-OPW-QC2
* NCS1004 OpticalSources_V3
* ONS-CFP2D-400G-C-OpticalSources-V2.mxd
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Step 2

Step 3

Step 4

Create an optical source from an Excel template .

* QDD-400G-ZRP-S-OpticalSources-V2.mxd

Note
By default, all existing optical source files are loaded in the server.

Import the optical source as a .mxd file.

a)
b)

<)

Click Add.
Choose Optical Source (.mxd)

The Import Optical Source (.mxd) dialog box appears.

Click Choose File and browse to the .mxd file stored on your local system, and click Import.

After the optical source is imported, a list of related interfaces appears.

Import the optical source from an Excel spreadsheet.

a)
b)

¢)
d)

e)

Click Add.
Choose Optical Source (.xIsx)

The Import Optical Source (.xIsx) dialog box appears.

Click Choose File and browse to the .xls file (optical source template) saved in your local system, and click mport.
Choose the Release Version of the NSC2K network.

Note
Selected release version is applicable only for NCS2K network. For NCS 1010, NCS 1001, and NCS 1014 networks,

the imported optical source is available for all supported release versions, regardless of the selected NCS 2000 release
version.

Select the interface.

If you want all the interfaces, then click Select All.

Click Create.

After the optical source is imported, a list of related interfaces appears.

Select the check box next to each interface you want to import.

After you import the optical sources and their interfaces, they appear in the Type drop-down list in the properties
window of the network tree. Use these interfaces when you create waves in your network design.

What to do next

Go to Download optical sources, on page 60 to download the optical source for Cisco ONC.

Create an optical source from an Excel template

Use this procedure to create an optical source with an optical source template downloaded from Cisco ONP.
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Step 1

Step 2

Step 3

Table 30: Feature History

Design and Analyze Networks |

Feature Name

Release Information

Feature Description

Create Optical Source using Excel
Sheet

Cisco ONP Release 5.0

You can create an optical source by
defining the details of interfaces
and the corresponding optical
classes in an Excel template. This
feature provides you with the
flexibility to create any required
optical source based on existing or
new traffic resources.

Choose Export > Optical Source Template.

The downloaded Excel template includes two sheets:

* Interface: Contains details specific to each interface.

* Class: Contains information that can be mapped to multiple interfaces.

Enter all required parameters from the specification sheet.

Fill in all information, then save the Excel file using the optical source name.

The optical source Excel file is ready for import.

What to do next

For the list of the required Optical Parameters, refer to Optical Parameters Available in the Excel Sheet for Optical Sources

The downloaded sheet contains data for one existing interface as a reference. You can edit or delete this data from the

There are some hidden columns that are not mandatory for Optical Source Creation. However, you can expand those
columns and enter the details.

Go to Import Optical Sources to import the optical source from an Excel file.

Optical Parameters Available in the Excel Sheet for Optical Sources Creation

The following parameters are available in the Excel sheet template for creating optical sources.
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Table 31: Optical Parameters for Creating Optical Sources

Optical Parameters Available in the Excel Sheet for Optical Sources Creation .

Parameters

Description

Interface Name

The name of the interface. It should be unique for all
the interfaces that are added in the file.

Vendor Name The name of the vendor.

Vendor IDs The vendor IDs.

Platform The name of the platform.

Pluggable PID The PID of the pluggable.

Name It is the combination of the Data Rate and Open
Config Code. For example: R400G#5000.

FEC The forward error correction type for the given
interface.

Data Rate The line rate for the given interface.

Mod Format The modulation format to be used for the interface.

Baud rate The baud rate for the given interface.

BPS The speed of data transfer (bits per symbol) for the
given interface.

Open Config Code The unique code assigned to the interface as specified
by the Open Industry Standard for optical networks.
For example: 5000.

Sub Mode Enter the sub-mode if there are any associated with
the interface. If not, leave it blank.

Trunk Rate The trunk rate of the transponder.

Nominal Bit Rate

The bit Rate for the interface

BER Target

The post FEC BER Target for the interface

Power Min and Power Max

The minimum and maximum Tx Power for the
interface.

Ovl The overload power limit for the interface

OL Power The Rx power sensitivity for the interface.

OL OSNR The Rx OSNR sensitivity for the interface.

PL Power The extended Rx power sensitivity.

PL OSNR The Rx OSNR sensitivity at the extended Rx power

sensitivity.
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Parameters Description

Variance The variance in power in the Txp.

Opt Class The optical class to which the interface will be
mapped.

InBand OSNR The Tx OSNR contribution due to laser instability
inside the Txp.

Out of Band OSNR The Tx OSNR contribution due to Add/Drop at 80%
and 100% channel spectral density.

ONC Release The Software release of Cisco ONC from which this
interface will be supported.

Interface Type It is the same as the name of the interface.

Min and Max Frequency The operating frequency range of the interface.

Table 32: Optical Class Parameters

Class Parameters

Description

Interface Type

The name of the interface. Enter the same name of
the interface, if you are doing one to one mapping
with the interface.

Opt Class

You can create the optical classes for different optical
sources. Certain optical parameters are added in the
optical class. Based on interface properties, multiple
interfaces can be mapped to the same class.

Enter a unique alphanumeric name for the Optical
class. While creating new optical classes, we
recommend using the name starting with “X” to avoid
overlapping in the existing classes.

Bit Rate

The bit rate for the given interface.

Baud Rate

The baud rate for the given interface.

ModGB Coeff

The modulation guard band coefficient.

Modulation OSNR Penalty

The modulation OSNR penalty.

GBf

The filtering GuardBand at different OSNR penalties.

Mux/Demux Filtering Penalty

Enter the mux/demux filtering penalty value, if there
are any.

Chromatic Dispersion

The chromatic dispersion limit at different OSNR
penalties.
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Find optical sources faster

Use these steps to find the optical sources faster.

Before you begin

Log in to the Cisco ONP web interface

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Note

By default, all existing optical source files are loaded in the server.

Step 2 To find the customized optical sources:

a. Check Show only lineratetuner generated sources.

The dialog box displays only the customized optical sources.

Step 3 To filter the required optical source:

a. Enter the optical source name in the Search box.

The dialog box displays the optical sources matching the typed keyword.

Find optical sources faster .

b. In the Search by drop-down, choose the required parameter to narrow down the search results.

Table 33: Search parameters

Parameter options | Description

File Name Name of the optical source
Card Name Name of the card

FEC mode Type of FEC mode

Bit rate Bit rate of the optical source
Baud rate Baud rate of the optical source
Sub mode Operating mode of the card
Modulation Modulation format of the optical source
Format

PID Product ID of the optical source
Vendor ID Vendor ID of the optical source
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. Download optical sources

Parameter options | Description

Open Config Code | Open configuration code of the optical source

Download optical sources

Use this procedure to download an optical source.

Procedure

Step 1 Choose Manage > Optical Source.
The Manage Optical Source dialog box appears.

Step 2 Select one or more optical sources to download.
Step 3 Click Download and select one of these options to download the optical sources.

» .mxd: Downloads the selected optical sources as an .mxd file.

+ xIsx: Downloads only the optical sources that were created and added using the Excel template as an .xIsx file.
Optical sources added directly as an .mxd file are not included in the .xIsx file.

+ .xml: Downloads the optical source data as a .xml file. This contains:

* Application codes for circuit provisioning in Cisco ONC,
* Optical parameters of the interfaces, and

* Product IDs (PIDs) and Vendor ID information.

You can load the .xml file into Cisco ONC to create circuits with these interfaces. See Alien Import.

After the import is successful, the optical source will be present under the Application Code tab in the Service
M anager screen of the Cisco ONC application. See Service Manager.

The selected optical source data is downloaded in the chosen format.

Delete optical sources

Use this procedure to permanently remove unwanted optical sources from Cisco ONP.
Before you begin

Log in to the Cisco ONP web interface.
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Procedure

Step 1 Choose Manage > Optical Source.
The Manage Optical Source dialog box appears.

Step 2 Choose one or more optical sources to delete.
Step 3 Click Delete.

Cisco ONP permanently removes the selected optical sources or aliens.

Layout template for NCS 2000 network

A layout template is a reusable configuration model that

» enables the design of consistent layout configurations for the NCS 2000 network,
» applies fixed layout rules to multiple nodes, and

* saves time, reduces effort, and minimizes configuration errors.

Layout templates are especially useful when deploying NCS 2000 networks that require identical configuration
across several nodes. Defining the layout once allows network engineers to ensure uniformity and compliance
with network design standards during deployment.

\}

Note Layout templates do not support configurations where there is a mix of TXP and Real card labels for
transponders.

Export layout template

Table 34: Feature History

Feature Name Release Information Feature Description

Layout Template Enhancement Cisco ONP Release 4.1 This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in Cisco ONP Release 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Use this procedure to export the layout template for a specific site or for all sites.
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Before you begin

Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network to export the network layout template.
Step 2 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 3 Click the Layout tab.
Step 4 Click the name of a site in the left side panel to download the layout template.
Step 5 Hover the mouse pointer over the Export icon and click L ayout Template for current site or all Sites.

The Export Layout Template dialog box appears.

Step 6 Click Export.

Note
 Export the layout template only in the analyze mode. If you export layout templates in upgrade or release upgrade
modes, the results may be inaccurate.

* You can export the layout template for nodes of type 4000 and 1000. However, the exported layout template includes
only the layout for NCS 2000 nodes. To export the layout template for the node types NCS4K-1K-2K and NCS1K-2K,
complete these steps:

* Right-click the site name in the L ayout panel, and click Export.

* Click OK to export the layout template in text format.

* The layout template for NCS 2000 is provided in XML format.

Import layout template for NCS 2000 network into Cisco ONP database

Use this procedure to import a template for the NCS 2000 network into the Cisco ONP database.

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Step 1 Choose Manage > L ayout Templates.
Step 2 Click Add in the Manage L ayout Template dialog box.
Step 3 Click Choose Files and select a template from your local system.
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Step 4 Click Import.
The template is imported to the Cisco ONP database.

Download a layout template for NCS 2000 network

Use this procedure to download a template from the Cisco ONP database:

Before you begin

Log in to the Cisco ONP web interface.

Procedure
Step 1 Choose Manage > Layout Templates.
Step 2 Choose the template that you want to download and click Download.

You can also choose multiple templates.

The selected layout template is saved to your local system.

Delete Layout Template for NCS 2000 Network

Use this procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to the Cisco ONP web interface.

Procedure

Step 1 Choose Manage> Layout Templates.
Step 2 Choose the template that you want to download, and click Delete to delete the template from the Cisco ONP database.

You can also choose multiple templates.

Apply NCS 2000 layout template into a site

Use this procedure to configure the layout of the NCS 2000 section for a site. Although the site can be
NCS4K-2K, NCS1K-2K-4K, or NCS1K-2K, you should apply the template only to the NCS 2000 section.

Before you begin
Log in to the Cisco ONP web interface.

Design and Analyze Networks .


conp-26-xx-config-guide_chapter1.pdf#nameddest=unique_12
conp-26-xx-config-guide_chapter1.pdf#nameddest=unique_12
conp-26-xx-config-guide_chapter1.pdf#nameddest=unique_12

Design and Analyze Networks |
. Import layout templates into NCS1K-2K and NCS4K-1K-2K sites

Procedure

Step 1 Open a network that contains the site where you want to apply the layout template.
Step 2 Choose Network > Entity Editor.

Step 3 In the Entity Editor window, expand Sites and choose the site.

Step 4 In the Layout Template drop-down list, choose the required template.

Note

Ensure that the other properties under the L ayout section, such as Chassis Type, Power Supply, Controller Card,
Node Protection, Redundant Controller Card, and M F-Unit are set to Auto. Otherwise, the L ayout Template
drop-down list remains disabled.

The NCS 2000 layout template is applied to the NCS 2000 section of the selected site.

Import layout templates into NCS1K-2K and NCS4K-1K-2K sites

Use this procedure to add exported layout templates for NCS 1000 and NCS 4000 into 4K-2K and 4K-1K-2K
sites.

\)

Note Ifyou modify an exported template, rename it before reapplying in upgrade mode to ensure changes are visible
in the layout view.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network that has the site to which you want to apply the layout template.
Step 2 Click the Layout tab.

Step 3 Click Edit to enable the edit mode.

Step 4 Right-click the site where you want to import the layout template, then click Import.
Step 5 Choose the layout template that you want to import into the site and click OK.

Cisco ONP applies the chosen layout template to the specified site.

Network layout visualizations

A network layout visualization is a graphical feature that

» displays the arrangement of racks, chassis, and cards in a network designed using Cisco ONP,
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« allows you to interact with and highlight specific hardware components, and

* enables zooming in and out for detailed or broad views.

Table 35: Feature History

Feature Name Release Information Feature Description

Layout Visualization and Edit Cisco ONP Release 4.1 This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.

When you click a particular rack, chassis, or card in thel ayout panel, the corresponding hardware component
is highlighted in the layout image. This feature enhances the ability to understand and manage complex network
physical topologies.

View network layout

Step 1
Step 2

Step 3
Step 4

Step 5
Step 6

Use this procedure to view the network layout.
Before you begin
Log in to the Cisco ONP web interface.

Procedure

Open the network for which you want to view the layout.
Choose Network > Analyze.

Note
The network must be successfully analyzed to proceed further.

Click the Layout tab.
In the Layout panel, click the site.

Note
The OLA sites are highlighted in green, ROADM sites are highlighted in blue, and Aggregated nodes are highlighted in

purple.
Passthrough sites are not listed in the layout.

Aggregated nodes are not available for the NCS 1010 network.

Click any rack under a site to view the rack view of the network under the L ayout tab.

Click any chassis under a rack to view the chassis view of the network.

Note
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When you click the Aggregated node under L ayout panel, NCS 1004, NCS 2000, and NCS 4000 series chassis are placed
in separate racks.

You can click the screenshot icon to capture images of all rack layouts of the selected site.

Edit the layout manually

Step 1
Step 2

Step 3
Step 4
Step 5
Step 6

Step 7

Use this procedure to position the NCS 4016, NCS 2000, and NCS 1004 chassis and cards by manually
adjusting the layout.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Open the network where you want to edit the layout.
Choose Network > Analyze.

Note
To proceed, make sure the network has been successfully analyzed.

Click the Layout tab.
Click Edit to enter the Edit mode.
Select a chassis (4K-1K-2K and 1K-2K) or card from a rack.

Drag and drop the selected chassis or card from a particular rack to an empty slot in the same chassis, a different chassis,
or a different rack.

Add pluggables to a card.

Note
Make sure to add the required cards.

a) Select the Rack.

The cards available in the rack are displayed.

b) Select the card to which you want to add pluggables.
The ports available in the card are displayed.

¢) Select the pluggable for each port.
These pluggables are displayed:

Card Supported Pluggables

NCS4K-4H-OPW-QC2 * ONS-QSFP8-LR4=
* QSFP-110G-SR4-S=
* ONS-QSFP-4*10-MLR=
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Card Supported Pluggables

NCS4K-4H-OPW-LO « ONS-QSFP8-LR4=
« QSFP-100G-SR4-S=
« ONS-QSFP-4*10-MLR=

NCS1K4-1.2T-K9= * ONS-QSFPS8-LR4=

* QSFP-100G-SR4=

* ONS-QSFP28-LR4-S=

* QSFP-100G-CWDM4-5=
* QSFP-100G-SM-SR=

d) Click the check mark.
Step 8 Click Done.

Your changes are saved in the layout. You can view any new chassis or card that has been added to the layout
in the BOM tab.

After you manually edit the layout, you can view the regenerated BOM.

Manually edit the layout for NCS 1010 networks

Use this procedure to adjust the position of NCS 1010 chassis and patch panels within network layouts.

Table 36: Feature History

Feature Name Release Information Feature Description
Layout Edit Support for NCS 1010 | Cisco ONP Release 5.0 Cisco has introduced NCS 1010 as
Networks a new optical line system to meet

the growing optical network needs.
Using Cisco ONP you can visualize
and edit layouts for NCS 1010
chassis and patch panels.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 Open an NCS 1010 network.

Note
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You can also create a new NCS 1010 network. For more information, see Manually design a network using Cisco ONP,
on page 2.

Step 2 Choose Network > Analyze.

Note
Ensure the network is successfully analyzed before proceeding.

Step 3 Click the Layout tab.

Step 4 Click Edit to enter the Edit mode.

Step 5 Select a site.

Step 6 Select a unit (NCS 1010 chassis or patch panel) :

Choose one of these methods:

» Expand the rack under a site in the left panel and select a unit.

* Or, in the Rack view, click a chassis or patch panel.

Step 7 Adjust the position of the selected units using one of these methods:

Note
If necessary, click the +New Rack button to create more racks.

* In the Rack view, drag and drop the selected chassis or panel from one rack to the empty slot in the same or different
rack.

 Swap units in the Rack view:

* Click a transponder or NCS1K14-CCMD-16 card; the Swap with button appears.

* Click Swap with and select a slot to swap from the drop-down list.

Note
The Swap with button appears only for NCS 1014 and NCS 1020 chassis.

* Cut and Paste unit in the left panel:
* Click Cut above the Rack view.
* Right-click on an empty slot in the same or different rack and click Paste.
Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Cut and Paste unit in the Rack view:
* Right-click the selected chassis or panel and click Cut.
* Right-click on an empty slot in the same or different rack and click Paste.
Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Move the unit in the left panel:

. Design and Analyze Networks



| Design and Analyze Networks

Step 8

Step 9

View layout details using tooltip .

* Go to Moveto> Site-X > Rack-X above the Rack view to move the chassis to the same or different rack. Or
go to Moveto > Site-X > + New rack above the Rack view to move the chassis to a new rack.

* Move the unit in the Rack view:

* Right-click the selected chassis or panel and go to Moveto > Site-X > Rack-X to move the chassis to the same
or different rack. Or go to Moveto > Site-X > + New rack to move the chassis to a new rack.

Note
The Moveto option moves the unit automatically to the immediate empty slot. The Cut and Paste option moves the unit

to the selected empty slot.

Click Done to save the changes in the Layout.

A warning message appears when empty racks are present in the layout.

Click OK to remove the empty racks.

View layout details using tooltip

Step 1
Step 2

Use this procedure when you need to quickly access hardware and port information in the Rack display.

Procedure

Hover over a rack, chassis, or card in the Rack display to view summary details in a tooltip.
Click See More Details in the tooltip to view information such as port number, type, pluggables, and rates.

Cisco ONP displays the detailed information for the selected rack, chassis, or card.

View internal node connections in the NCS 1010 network

Use this procedure to visualize the functional and detailed internal node connections for each site in an analyzed
NCS 1010 network. These connections include port labeling and precise component interconnections.
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Table 37: Feature History

Feature Name Release Information Feature Description
View Internal Node Connections | Cisco ONP Release 5.0 The Node diagram tab displays a
of NCS 1010 Network functional view that includes

precise connections and port
labeling of each component such
as OLT or ILA,
NCS1K-BRK-8/16/24,
AAWG-32-0, and AAWG-32-E,
for each site in an analyzed NCS

1010 network.
Before you begin
Log in to the Cisco ONP web interface.
Procedure
Step 1 Open an NCS 1010 network.
Step 2 Choose Network > Analyze.
Note
Network must be successfully analyzed to proceed further.
Step 3 Click the Layout > Node Diagram tabs.
Step 4 For each site, click its name in the left panel and select a side to display the functional view.

The functional view displays both physical and logical connections, including:

* degree interconnections between NCS1010 (OLT or ILA) and NCS1K-BRK-8

* add/drop connections between NCS1010 and colorless add/drop units (NCS1K-BRK-8, NCS1K-BRK-16, or
NCS1K-BRK-24), and colored add/drop units (AAWG-32-O or AAWG-32-E)

Step 5 To view port names and cable ID details, hover over any cable.

The functional view for each site displays all internal node connections, including port labeling, degree
interconnections, and add/drop relationships between NCS 1010 components and related units. You can review
port and cable details for precise analysis.

Copy configurations from one node to another

Use this procedure to copy the configurations of a specific node to a node at a different site.

You can copy the configuration only during a manual 4K-1K layout movement. It is not supported for NCS1010
layout movement.

Before you begin
Log in to the Cisco ONP web interface.
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Procedure

Step 1 Open the network from which you want to copy the configuration.
Step 2 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 3 Click the Layout tab.

Step 4 Select the rack, chassis, or card of a particular site.

Step 5 Select the site that will receive the configurations from the Copy To drop-down list.
Step 6 Click New Rack to add a new rack. Cisco ONP copies the configuration to the new rack
Step 7 Click Doneto save the changes in the layout.

Note
You can also cut, copy, and delete racks, chassis, and cards in the layout.

Export the IPC report

Use this procedure to export the connections of a current site or all sites to an Excel sheet.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Step 1 Open the network from which you want to export the connections of a current site or all sites to an Excel sheet.
Step 2 Choose Network > Analyze.

Note
The network must be successfully analyzed to proceed further.

Step 3 Click the Layout > | PC tabs.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

The patches that you click are highlighted in the rack.

Step 4 Hover over the Export icon, and click Current site or All Sites option.

The Export | PC dialog box appears.

Step 5 Click Continueto export the connections of the current site or all sites.
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The cable-type and Cable ID are included in the report only for the NCS 1010 network.

Export port usage of an LNI network

Step 1
Step 2

Step 3
Step 4
Step 5

Step 6

Procedure

Use this procedure to export the port usage details of an LNI network.

Table 38: Feature History

Feature Name

Release Information

Feature Description

Multi-Layer Connections Phase 1

Cisco ONP Release 4.1

This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

* Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

* Port usage report based on
sites

* Port usage report only for LNI
imported networks

Before you begin

Log in to the Cisco ONP web interface.

Open the LNI network whose port usage you want to export.
Choose Network > Analyze.

Note

To proceed, make sure the network has been successfully analyzed.

Click the Layout tab.
Select the site for which you want to export port usage.
Hover the mouse over the Export icon and select Port Usage for either Current site or All Sites.

The Export Port dialog box appears.

Click Continue.
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Cisco ONP exports the port usage details in Excel format.

\)

Note * If you modify any services in the NCS 4000 node after upgrading the LNI network, the changes in the
port usage details will not update.

* The demand labels shown for the trunk ports of the NCS4K-DWDM line card in the port mapping report
are not logically related to the NCS 4000 trunk ports. They are related to NCS 1004 client ports.

Define multilayer connections for an SSON network

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Table 39: Feature History

Feature Name Release Information Feature Description
NCS4K-1K-2K Multilayer Cisco ONP Release 4.2 You can define Multilayer
Connection Trace Connections (MLC) such as cards

and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the L ayout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Before you begin
Log in to the Cisco ONP web interface

Procedure

Step 1 Open the network where you want to define multilayer connections.
Step 2 Define the MLC:

a) Click the Layout tab.
b) Click the MLC tab.

Alternatively, you can navigate to the M L C page by clicking the Ellipsisicon available in the right side of the service
name in the network tree and clicking View in MLC

You can view the service properties in a table. See MLC details, on page 75.
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. Define multilayer connections for an SSON network

¢) Click the service name to switch to the layout view.
You will view the layout and the service details in the right pane.

d) Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS
1K out, for both Sour ce and Destination sites.

The NCS 2000 chassis details appear automatically.

Note
For an LNI imported network, all details appear automatically. If you add a new service, you can update its details.

e) Click the check icon to save your changes.
Click the refresh icon to remove changes you made after saving.

The updated details are included in the BOM.

Step 3 To export the MLC details, perform these steps:

a) Click the table icon to switch to the table view.

b) Choose Export > ML C Tracesto export all the details available in the MLC table.

¢) Choose Export >LMP/TTI Connections to export the details of Link Management Protocol (LMP) connections,
which are between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTI) connections, which are between
NCS 4000 and NCS 1004 cards.

All these connections are included in the BOM.

Step 4 To filter the services displayed in the left pane, click the Filter icon and choose one of these options:
* Source Site
* Destination Site
* Type of the traffic

* Trace Origin

* LNI: imported through Import Live Network option

¢ User Created: created through Cisco ONP Ul

» Trace Status
» Completed: User has defined all MLC details,

* Partial: User has defined only partial MLC details, and
* Empty: User has not defined any MLC details.

Step 5 Click the three vertical dots and choose the option you need.
» Enable Multi Select: You can select up to the card level for different OTN.

« Expand All: Expands the service tree.
« Collapse All: Collapses the expanded service tree.

» Show Trace Status: Shows the trace status icon next to the service name.
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MLC details [

Step 6 Click the three horizontal dots next to the service trace and choose the option you need.

* Delete Trace: Deletes the respective trace.

* Locatein Map: Shows the service in the map view.

Note

You can enable the same port number on the primary and secondary NCS4K | N nodes for Client 1+1 and other protection

scheme.

MLC details

This section describes the various fields available in the MLC tab in the Layout view of a network.

The MLC tab includes these fields.

Table 40: MLC details

Properties

Description

Name

Name of the service

Group Name

Name of the group to which the service belongs

Type Traffic type

Src Site Source site

Src NCS4K In Details of the rack, slot, card, port in the input side of
the NCS 4000 chassis in the source site

Src NCS4K Out Details of the rack, slot, card, port in the output side
of the NCS 4000 chassis in the source site

Src NCSI1K In Details of the rack, slot, card, port in the output side
of the NCS 1004 chassis in the source site

Src NCS1K Out Details of the rack, slot, card, port in the output side
of the NCS 1004 chassis in the source site

Src NCS2K AddDrop Add/Drop multiplexer and demultiplexer connected
to the NCS 2000 chassis in the source site

Src NCS2K MPO Media channel between the source and destination
sites

Dst NCS4K In Details of the rack, slot, card, port in the input side of
the NCS 4000 chassis in the destination site

Dst NCS4K Out Details of the rack, slot, card, port in the output side

of the NCS 4000 chassis in the destination site
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Properties Description

Dst NCSIK In Details of the rack, slot, card, port in the input side of
the NCS 1004 chassis in the destination site

Dst NCS1K Out Details of the rack, slot, card, port in the output side
of the NCS 1004 chassis in the destination site

Dst NCS2K AddDrop Add/drop multiplexer and demultiplexer that is
connected to the NCS 2000 chassis in the destination
site

Dst NCS2K MPO MPO cable connecting the NCS 2000 chassis in the
destination site

Media Channel Media channel between the source and destination
sites

Notes Additional notes, if applicable

Trace Origin Indicates whether the service connections are
user-created or imported through LNI.

Add new pluggables, alarm cables and 100G client bandwidth

licenses to BoM

Use this procedure to add new pluggables, alarm cables, and 100G client bandwidth licenses to an existing

BoM for the NCS 1004 and NCS 4000 platforms.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 Open the network you want to update.
Step 2 Analyze the network by choosing Network > Analyze.

Note
Ensure the network is successfully analyzed before proceeding.

Step 3 Click the BOM tab.
Step 4 Start adding new items:
a) Click Add.
The New dialog box opens.

Step 5 Specify the details:

a) Enter the Cisco part number of the pluggable, alarm cable, or 100G bandwidth license in the Cisco Part Number

field.
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b) Click Add to confirm the additions.

The new pluggables, alarm cables, or 100G bandwidth licenses are now listed in the BoM.

Spectrum utilization and path finder capabilities

A spectrum utilization and path finder are network visualization features that

« streamline the identification of available and used optical spectrum across network sites and fibers,
* enable interactive path selection and custom route planning, and

* provide tools for both comprehensive and minimal network mapping.

Table 41: Feature History

Feature Name Release Information Feature Description
Spectrum Utilization and Path Cisco ONP Release 24.3.1 The spectrum utilization and path
Finder finder introduces the Minimal

M ap, a streamlined network
visualization tool focusing on
essential data points like Sites and
Fibers, enhancing usability and
performance. General Settings
now allow individual
customization, including default
map views and spectrum utilization
colors. The Path Finder/Selector
enables interactive path selection
with options for manual and custom
path finding for multiple routing
options. The Spectrum Utilization
provides a comprehensive
visualization of used spectrum,
while the Spectrum Finder helps
locate and apply available spectrum
across fibers, offering dual-view
capabilities and multiple selection
methods. These enhancements
collectively improve network
management, planning, and
resource optimization.

Key components

The spectrum utilization and path finder feature introduces several key components to enhance network
visualization, planning, and resource optimization:

» Minimal map: A visualization tool that focuses on sites and fibers, presenting a simplified network map
for easier navigation and analysis.
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+ Path finder/selector: An interactive feature that lets users select network paths, supporting both manual
and customized route finding to optimize network planning.

« Spectrum utilization: A visualization function that displays the usage status of optical spectrum, helping
operators assess how spectrum resources are allocated.

» Spectrum finder: A utility that locates available optical spectrum on fibers and applies this information

for provisioning circuits or media channels.

Find a custom path

Step 1
Step 2

Step 3

Step 4

Use this procedure to customize a fiber path on the map.

The Custom Path Finder is accessible exclusively through the minimal map. When you choose the custom
path finder, the detailed map automatically switches to the minimal map.

Limitations

* This feature applies only to circuits (NCS1010/NCS1001), waves (NCS2000 NON-SSON), and media

channels (NCS2000 SSON).

Before you begin
Log in to the Cisco ONP web interface.

Procedure

In the network tree, select the section of the media channel or circuit that you want to add a new path.

Click the Ellipsesicon and select Custom Path Finder.

The Custom Path Finder for the selected section opens.

In the Visualization area, choose the required map view.

Map View Result

Complete Map Shows a complete network map of the selected path with
other sites.

Sub Map Shows only maps with chosen sites and fiber.

In the Optionsarea, choose the required parameters to calculate the Path Finder.

Option

Description

Minimum Hop

Routes using the minimum number of hop counts, regardless
of the fiber length.

Minimum Length

Routes using the minimum fiber length, regardless of hop
count.

Distinct Fiber Set

Provides a distinct set of fibers, ensuring that the same fiber
is not used in other paths.

. Design and Analyze Networks


conp-26-xx-config-guide_chapter1.pdf#nameddest=unique_12

| Design and Analyze Networks
Select path manually .

Option Description
Number of Path Count Calculates the number of paths according to the specified
value.

Step 5 Click Calculate.
The system displays the list of paths calculated using the chosen parameters.

The calculated paths table contains the path parameters.

Table 42: Path Parameters

Parameter Description

S.No Displays the serial number.

Path Shows the fiber path direction based on the selected Options parameters.
Funnel icon Filters the path based on fiber labels.

Hops Displays the hop count.

Total Length Displays the total length of the fiber path.

Step 6 Click Export to export the chosen fiber path.

Step 7 In the Selected Serviceand Path area, check the service and path information and click Apply Path to apply the selected
path.

Select path manually

The manual path selector is accessible exclusively through the minimal map. When you choose the manual
path selection, the detailed map automatically switches to the minimal map.

Limitations
* Available in Design and Upgrade modes where circuits path can be updated.

* Applies to only Circuits (NCS1010/NCS1001), Waves (NCS2000 NON-SSON), media channel (NCS2000
SSON).

* Applies to regen circuits/waves/media channel.

* Additional options are applicable for Section under Network Tree.

The procedure to select a path manually on the map is as follows:

Before you begin

Log in to the Cisco ONP web interface.
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Procedure
Step 1 In the network tree, select the section of the media channel that you want to add a new path.
Step 2 Click the Ellipsesicon and select Manual Path Selection.
Step 3 In the Search field, enter the site or fiber to focus on it.

Step 4 Select the required the fibers to create a path.

The selected fibers appear on the Operation Modes pop-up pane under Fibersarea.

Step 5 Click Apply.

View spectrum utilization and find available spectrum

Use this procedure to analyze the availability of network fiber spectrum and to apply the selected spectrum
to a planned service.

The spectrum finder is accessible exclusively through the minimal map. When you choose the spectrum finder,
the detailed map automatically switches to the minimal map.

Use the spectrum finder for the network in Design/Upgrade/Release Upgrade mode and view the spectrum
utilization in Analyze mode.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 In the network tree, select the section of the media channel to view the spectrum utilization for each fiber.
Step 2 Click the Ellipsisicon and select Spectrum Finder.

The spectrum finder for the selected section opens.

Step 3 In the Selected Fibersarea, click +Add Fiber and choose the required fibers from the drop-down list.

Step 4 In the Visualization area, choose the required map view.
Map View Result
Complete Map Shows a complete network map of the selected path with
other sites.
Sub Map Shows only the maps with chosen sites and fiber.
Step 5 In the Spectrum Finder area, modify the parameters as required.
Option Description
Tabular View Similar to Spectrum Utilization View.
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Option

Description

Detailed View

Displays multiple fibers in a vertical orientation (Y-Axis)
and the spectrum on the horizontal axis (X-Axis).

Spectrum Selection

Enable Spectrum Selection to modify the subsequent
parameters.

Spacing

Enter the bandwidth (GHz) that is required for the network
circuit.

Distinct Fiber Set

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths.

Number of Path Count Calculates the number of paths based on the number
provided.

Allow Overlap Allows you to select overlapping wavelengths with selected
fibers, when enabled.

Zoom Zooms in and out of detailed view to granular view. Click
Default reset zoom.

View Labels Displays the labels. Enable to view the labels. You can also

view the labels of existing occupied circuits.

Hovered Spectrum

Shows the start, end, and central wavelengths (THz) of the
hovered spectrum when moving across the view.

Selected Spectrum

Shows the start, end, and central wavelengths (THz) of the
selected spectrum when selecting across the view.

C-Band

Toggle to view the C-band spectrum usage.

L-Band

Toggle to view the L-band spectrum usage.

Fiber Utilization Graph

Displays the frequency utilized in a fiber for each span in
continuation in a vertical axis. Each square block is
3.125GHz. The frequency range starts from the left and
continues towards the right, increasing 3.125GHz per block
for both C- and L-band.

For C-band, the first row has the starting frequency as
191.325 THz. A single row contains 53 blocks, totaling
0.165625 THz ( 53*3.125 GHz). The starting frequency of
subsequent rows increment at 0.165625 GHz.

Color tone of the blocks varies in the fiber utilization graph.

Dark | Indicates overlap of same spectrum across multiple waves.
red

Light |Indicates less spectrum usage.
red
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Step 6

Step 7
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In the Apply Propertiesto Existing Service area, check the service parameters and click Apply Wavelength and Apply

Click Apply Wavelength and Apply Path to revert the changes.

Select Apply to Service.

COSM cards

A COSM card is a network hardware component that

» provides licenses based on functionality for features such as alarm correlation, performance monitoring,
connection verification, and OTDR,

* serves as the primary card for all networks starting from Release 12.1.0, and

» can be deployed in both ROADM and TRAFFIC nodes as part of network designs.

From Release 25.1.1, SVO card is referred as COSM card.

Features of the COSM card:
The COSM card offers these key features and configuration options:
* Occupies two slots in the chassis.
* Serves as the primary card for all networks beginning with Release 12.1.0.

* For high availability, a node can be equipped with two COSM cards, but they cannot reside in the same
chassis.

* Two 10G SFP+ pluggables can be used to connect two COSM cards within a node.
* A Cisco ASR 920 switch can be connected to COSM cards during network design.

» The COSM solution can operate either as a physical card or as a UCS-based solution.

COSM licenses:

From 25.1.1, one COSM license, OAS-COSM-MLCL, is required for each active card present in the chassis,
such as M15, M6, M2, 1010, 1020, 1014, or 1004.

SVO0 licenses

SVO licenses are applicable for NCS 2000 networks until Release 12.3.1.

* SVO cards require either a Base License or an SVO Full License which covers High Availability,
Connection Verification, and Flex Spectrum. If the SVO Full License is not selected, the SVO Base
License and High Availability are enabled by default.

* Types of SVO licenses include:
* Cisco NMS: Features High Availability, Connection Verification, Flex Spectrum, and OTDR.
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¢ Third-Party NMS: Includes North Bound Interface (NBI), Alarm Correlation, Performance
Monitoring, and Circuit Provisioning.

Chassis licensing:

* Every chassis added to the network must be licensed from Release 12.1.0 onwards. For networks upgraded
to Cisco ONP Release 4.0 or higher, a new chassis license is required after analysis.

* Chassis licenses come in variants such as 1-chassis, 5-chassis, 10-chassis, 20-chassis, 50-chassis, and
others, chosen based on cost optimization.

* A license is required for each chassis added to the network after the first chassis.

* Chassis License Flush Out allows you to replace existing chassis licenses with new ones. The current
license remains active if the site is unlocked. However, you can use flush out only during network upgrade
mode.

* You can continue using existing licenses with changes to the chassis unless you opt for the Chassis
License Flush Out option.

)

Note Chassis Licensing and SVO Licenses are applicable until Release 12.3.1.

Cisco Optical Site Manager associations

A Cisco Optical Site Manager association is a network configuration mechanism that

* enables a ROADM or Traffic node equipped with an COSM card to manage OLA, DGE, Traffic, and
other ROADM nodes that may not have their own COSM card

+ allows both manual and automatic association of secondary nodes to a primary node based on network
topology and configuration, and

« supports a range of High Availability options to enhance resiliency and dynamic association in NCS
2000 networks.

From Release 25.1.1, Cisco ONP has been enhanced to support COSM line card connectivity from ROADM
or Traffic nodes to various site types. The node with the COSM card becomes the primary node.The number
of nodes managed by the primary node depends on the total application memory of the primary node and the
RAM size of the individual associated nodes. You can configure these two properties under the COSM
properties of site properties.
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Table 43: Feature History

Feature Name Release Information Feature Description
Cisco Optical Site Cisco ONP Release 25.1.1 | Cisco ONP has been enhanced to support COSM
Manager enhancements line card connectivity from ROADM nodes to

various site types. A ROADM node equipped with
a COSM card can now manage up to 14 additional
OLA and ROADM nodes. Previously, this was
limited to OLA-to-ROADM associations. The node
with the COSM card acts as the primary node.

The new COSM High Availability options
available under the Site properties, such as Auto,
Local HA, None, Only Active, and Geo HA enable
more dynamic and rule-based association in the NCS
2000 network.

Methods of association
» Automatic COSM associations:

* Cisco ONP automatically selects a primary node if the fiber property DCN Extension is enabled or
if a node has the highest number of degrees.

* You can associate up to 15 nodes with one primary node. In networks with more than 15 nodes,
Cisco ONP chooses another primary node to manage the excess nodes.

» Manual association (Network Tree and Map): You can manually associate OLA, DGE, Traffic, and
ROADM nodes with a ROADM or Traffic node (equipped with a COSM card) using the network tree
or topology map interface.

» Association through COSM High Availability property: The association options under the High
Availability drop-down list (Auto, Local HA, None, Only Active, Geo HA) can be directly applied for
both SSON and non-SSON NCS 2000 networks for rule-based and resilient configurations.

» Auto: Based on the analysis and default behavior.
 Local HA: The active and standby COSM cards are both on the same node.
* None: No COSM card present.

» Only Active: This option does not provide High Availability. Only the primary COSM card is
added.

* Geo HA: COSM cards are placed in two sites next to each other in different geographical locations.

* From Release 25.1.1, Traffic nodes may also act as primary nodes if equipped with a COSM card.
* High Availability options support both switched optical networks (SSON) and non-SSON environments.

* These enhancements allow for more scalable and flexible management of optical site nodes in the NCS
2000 platform.
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If your network contains more than 15 nodes, Cisco ONP divides the associations such that another
primary node manages the additional nodes.

* Using the network map, you can manually group OLA and DEG nodes without SVO cards to
a ROADM node with an SVO or COSM card for centralized management.

* Selecting "Geo HA" under High Availability lets you deploy pairs of COSM cards in
geographically separate locations, increasing protection against local failures.

Associate sites with COSM cards

Step 1
Step 2
Step 3

Use this procedure to associate OLA and ROADM sites with the COSM cards:

Before you begin

Log in to the Cisco ONP web interface.

Procedure

In the network tree panel, click the Ellipsisicon available next to any ROADM or Traffic site with COSM card.

Click Edit COSM Associations.

Select thesites on the map to toggle the COSM connections. To confirm your selection, click Doneat the top-right corner.
You can associate up to 14 nodes with a single ROADM or Traffic node equipped with an COSM card. To associate

more than 14 nodes, you will need an additional primary node to manage the extra nodes. You can open widgets in the
map and select the top section to view the association.

Note
You can also right-click any ROADM or Traffic site from the map and click Edit COSM Associations. For the DGE
sites, the Edit COSM Associations option is not displayed.

During network analysis, the tool automatically associates the sites you do not associate with the COSM card.

Export Cisco Optical Site Manager NETCONF XML file for NCS
2000 network

Use this procedure to export the Cisco Optical Site Manager NETCONF XML files for NCS 2000 network
from the Cisco ONP GUI.

This feature has limited scope in this release.

The network must be in Analyze mode.

Design and Analyze Networks .
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. Export NeUpdate XML file for NCS 2000 networks

Step 1

Step 2

Step 3

\)

Note  This procedure applies to all NCS 2000 networks from R25.1.1 only to upload NETCONEF file to Cisco Optical
Site Manager.

Procedure

In the network tree panel, click the three dots.

A pop-up list appears.

In the list, click Generate COSM NetConf XML.

Export window appears with network name.

Click Export.

The message "Success. COSM NetConf exported successfully" appears.

Download the zip file that contains the COSM NETCONF XML files of individual sites.

Note
You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files of
individual sites.

Note
NCS 2000 Cisco Optical Site Manager NETCONF XML file does not support the MD-320-CE and MD-32E-CE card
configurations.

Note
* For the ROADM and OLA nodes, the device name is the same as the Site Name.
Ensure that you align the device name in COSM to match the specified format.

If the Site Name contains any special character, the XML file replaces the special character with its ASCII value in the
COSM XML device name, providing a seamless experience with the COSM data backup workflow.

Export NeUpdate XML file for NCS 2000 networks

Use this procedure to export the NeUpdate XML files for all network sites or the entire network from the
Cisco ONP GUI. This supports device configuration, automation, and network provisioning using the latest
supported parameters.

)

Note  This procedure applies to all NCS 2000 networks till R11.1.x to upload in CTC. For NCS 2000 networks from
R25.1.1, see Export Cisco Optical Site Manager NETCONF XML file for NCS 1001/1010/1014 networks,
on page 93 to export NETCONF XML to upload in Cisco Optical Site Manager UL
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Export device NETCONF XML file for NCS 1010 networks .

The network must be in Analyze mode.
Before you begin
Log in to the Cisco ONP web interface.

Procedure

Step 1 In the network tree panel, click the three dots.
A pop-up list appears.
Step 2 In the list, click Generate Device NetConf XML.
The Export window appears displaying the network name.
Step 3 Click Export.
The message "Success. Device NetConf exported successfully” appears.
You can download a zip file that contains the NETCONF XML files for individual sites.

Note
You can choose the destination folder for saving the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Export device NETCONF XML file for NCS 1010 networks

Use this procedure to export the NETCONF XML files for all network sites or the entire network from the
Cisco ONP GUI. This supports device configuration, automation, and network provisioning using the latest
supported parameters.

\)

Note NETCONF device XML is not supported for NCS1004 and NCS1014 devices.

The network must be in Analyze mode.

Before you begin
Log in to the Cisco ONP web interface.

Design and Analyze Networks .
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Table 44: Feature History

Feature Name Release Information Feature Description

Export Device and Cisco Optical |Cisco ONP Release 26.1.1 The NETCONF XML file exported
Site Manager NETCONF XML file for the analyzed NCS 1000 network
for all NCS 1000 networks designs now include this parameter

when the config mode, card type,
and client type are configured.

* mode
NCS 1010 designs now include
these parameters.

Parameters based on Enable Special
Settings:

* Patchcord Loss Threshold
(applicable for C+L band
device)

* Ots Rx Low Threshold
(applicable for C+L Raman
device)

* Bidirectional span-loss
mismatch threshold

* Payload OSC Min Deviation

* Payload OSC Max Deviation

Parameters based on Raman LUT
and ALC2 and LUT:

* Raman-tuning with-payload

* Raman-turn-up
<enable/disable>

» Raman-safety-trigger dfb-los
» Raman-safety-trigger osc-los

* Raman-safety-trigger
osc-osnr-los

Design and Analyze Networks
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Table 45: Feature History

Export device NETCONF XML file for NCS 1010 networks .

Feature Name

Release Information

Feature Description

ALC2 Enhancements

Cisco ONP Release 25.1.1

The NETCONF XML file exported
for the analyzed NCS 1010 network
design with Microsoft configuration
now includes a new parameter.

* OTDR-ScanMode-Expert

If you enable the Enable Special
Settings check box under Network
level properties, the generated
XML file contains the
OTDR-ScanMode-Expert
parameter that is set to
multi-region.

If you do not enable the Enable
Special Settings check box, then
the scan mode configuration is not
added to the device Netconf XML
file.

Design and Analyze Networks .
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Step 1

Step 2

Table 46: Feature History

Design and Analyze Networks |

Feature Name

Release Information

Feature Description

New Parameters Included in NCS
1010 NETCONF XML file

Cisco ONP Release 24.3.1

The NETCONF XML file exported
from the NCS 1010 network design
now includes these new parameters
to support seamless Day-0
provisioning and the setup of a new
node added to the network.

* Optical cross-connects

* Gain range margin

* Tone Rates

* Raman tuning configurations
* Slot reserve

* Dmux WSS attenuation

* Unused CCMD-16 ports
shutdown

* Span baseline-deviation
* OTDR Thresholds

* APC Span-loss correction
threshold

Table 47: Feature History

Feature Name

Release Information

Feature Description

Export NETCONF File from NCS
1010 network

Cisco ONP Release 5.0

You can export the NETCONF
XML files for all the NCS 1010
nodes, and upload them to the NCS
1010 nodes through the YANG
suite. This enables automatic bring
up of the NCS 1010 nodes using
the NETCONF data.

In the network tree panel, click the three dots.

A pop-up list appears.

. Design and Analyze Networks
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Step 3

Export device NETCONF XML file for NCS 1010 networks .

Click Export.
The message "Success. Device NetConf exported successfully” appears.

You can download a zip file that contains the NETCONF XML files for individual sites.

Note
You can choose the destination folder for saving the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Note
For C+L Network, the partner band configurations are not included in the Cisco ONP-generated XML file. Manually
configure the partner bands on the devices while bringing up the NCS 1010 C+L network.

Note
NETCONF device XML is not supported for NCS1004 and NCS1014 device.

From Release 24.3.1, these new parameters are available in the NETCONF file exported from the NCS 1010 network
design:

* OSC TX Power

* Optical Cross Connect

* OTS tone rate

* OMS tone rate

* OTS tone pattern expected

* OTS tone detect OOB

* OTS tone pattern

* OTS tone frequency

* Raman pump configurations
* Line port attenuation

* Raman dual safety

These parameters are available only if you enable the Enable Special Settings check box under the Network properties.

* Raman turnup

* OTS ports shutdown

* OTDR autoscan

* Gain range margin

* OTDR excess attenuation threshold
* OTDR end of fiber threshold

* Slot reserve

* Dmux WSS attenuation

Design and Analyze Networks .
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» Unused CCMD-16 ports shutdown
* Span baseline-deviation

* OTDR Thresholds

» APC Span-loss correction threshold

* OTDR-ScanMode-Expert

Note
From R25.1.1, the Cisco ONP-generated XML file for the analyzed NCS 1010 networks include the
OTDR-ScanMode-Expert value. The value is set to

« multi-region if you enabled the Enable Special Settings check box.
» auto if you did not enable the Enable Special Settings check box.

From Release 26.1.1, these new parameters are available in the NETCONF file exported from the NCS 1010 network
design. These parameters are available only if you enable the Enable Special Settings check box under the Network
properties.

* Patchcord Loss Threshold (applicable for C+L band device)
* Ots Rx Low Threshold (applicable for C+L Raman device)
* Bidirectional span-loss mismatch threshold

* Payload OSC Min Deviation

* Payload OSC Max Deviation

Parameters based on Raman LUT and ALC2 and LUT:
* Raman-tuning with-payload
* Raman-tuning manual
* Raman-tuning Raman-gain-target
» Raman-turn-up <enable/disable>
» Raman-safety-trigger dfb-los
» Raman-safety-trigger osc-los
» Raman-safety-trigger osc-osnr-los

» Raman Pump Configuration such as Raman-tx-power-instance and Raman-tx-power-value

Export device NETCONF XML Files for individual sites

Use this procedure to export device NETCONF XML files for individual sites from the Cisco ONP GUI.
Before you begin
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Step 1
Step 2

Step 3

Upload NETCONF files to NCS 1010 device using NETCONF client .

Log in to the Cisco ONP web interface.

Procedure

Click the Ellipsisicon next to the site.
In the list, click Generate Device NetConf XML.

Export window appears with network name.
Click Export.
The message, "Success. Device NetConf exported successfully" appears.

You can download a zip file containing device NETCONF XML files of individual sites.

Upload NETCONF files to NCS 1010 device using NETCONF client

Step 1
Step 2
Step 3

Step 4

Use this procedure to upload the NETCONF files that you downloaded from Cisco ONP, into the NCS 1010
device using a NETCONF client.

Before you begin
Log in to the Cisco ONP web interface.

Procedure

Log in to the YANG suite that has access to the NCS 1010 device.
Connect to the NCS 1010 device.

Copy the NETCONF XML file content that is downloaded from Cisco ONP, and paste it into the Protocol NETCONF
Run RPC block.

Append this commit code at the end of the NETCONF XML file content.

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="102">
<commit/>
</rpc>

Export Cisco Optical Site Manager NETCONF XML file for NCS
1001/1010/1014 networks

Use this procedure to export the Cisco Optical Site Manager NETCONF XML files for all the individual sites
in a network, from the Cisco ONP GUI.
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Table 48: Feature History

Feature Name Release Information Feature Description

Export Device and Cisco Optical |Cisco ONP Release 26.1.1 Cisco Optical Site Manager XML

Site Manager NETCONF XML file supports NCS 1001 and NCS 1014

for all NCS 1000 networks networks. NCS 1004 configurations
are added to the XML file.

NCS 1010 designs now include
these parameters.

Parameters based on Raman LUT
and ALC2 and LUT:

* Raman-tuning manual

* Raman-tuning
Raman-gain-target

* Raman Pump Configuration
such as
Raman-tx-power-instance and
Raman-tx-power-value

Table 49: Feature History

Feature Name Release Information Feature Description

Export Cisco Optical Site Manager | Cisco ONP Release 5.2 The new Generate COSM
(COSM) NETCONEF File from NetConf XML option allows you
NCS 1010 network to export from the Cisco Optical

Network Planner, the Cisco Optical
Site Manager NETCONF XML
files for all the NCS 1010 nodes.
You can then upload these files to
the NCS 1010 nodes through the
Cisco Optical Site Manager,
enabling automatic bring-up of the
NCS 1010 nodes.

This feature has limited scope in this release.

The network must be in Analyze mode.

\)

Note From R26.1.1, export of COSM XML for NCS 1001 and NCS 1014 platforms are supported with these
limitations.

* Analysed NCS1001 and NCS1014 networks in R25.1.1 must be reanalysed in R26.1.1 before generating
Cisco Optical Site Manager XML for NCS 1001 and NCS 1014 networks.

* Cisco Optical Site Manager XML is not supported for NCS 1001 networks with PSM-Path protection
configuration.
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Step 1

Step 2

Step 3

Upload a NETCONF XML to NCS 1010 device through COSM web interface .

Procedure

In the network tree panel, click the three dots.

A pop-up list appears.

In the list, click Generate COSM NetConf XML.

Export window appears with network name.

Click Export.

The message "Success. COSM NetConf exported successfully" appears.

Download the zip file that contains the COSM NETCONF XML files of individual sites.

Note
You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files of
individual sites.

Note
* For the ROADM OLT node, the device name is generated in the Site Name-Side Name format.

* For the OLA node, the device name is the same as the Site Name.

Ensure that you align the device name in COSM to match the specified format.
If the Site Name contains any special character, the XML file replaces the special character with its ASCII value in the
COSM XML device name, providing a seamless experience with the COSM data backup workflow.

Note
L-Band Configuration is not certified in Cisco Optical Site Manager XML. A future release will be considered for the
L-Band configuration.

Note
From R26.1.1, the Cisco ONP-generated XML file for the analyzed NCS 1000 networks include the M ode value. The
value is set to

* MXP-1K if you set Config Mode as Muxponder or Bundle.
» MXP-SLICES-1K if you set Config Mode as Sice.

This value appears only when you set the Card Type, Config Mode, and Client Type properties.

Upload a NETCONF XML to NCS 1010 device through COSM web
interface

Use this procedure to upload Cisco Optical Site Manager NETCONF XML files, generated by the Cisco ONP,
to an NCS 1010 device using the Cisco Optical Site Manager web interface.

Design and Analyze Networks .
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Before you begin

* Download the required COSM NETCONF XML files for the target NCS 1010 device. If you want to
configure cross connects, download two files:

« one without optical cross connect (OXC)

» and one with optical cross connect (OXC).

» [f the devices are already onboarded on COSM, verify that the device name and unique identifier (UID)
in COSM are identical to those in the COSM generated XML files. If the device name or UID does not
match, remove the device from the interface. Alternatively, update the device name, UID, and rack
position in the XML to align with COSM and then upload the updated file.

» If the devices are not onboarded on COSM, upload the COSM XML without onboarding the devices.
The device name and UIDs configured in the XML file will be assigned during device onboarding.

Procedure

Step 1 Log in to the Cisco Optical Site Manager Ul that has access to the NCS 1010 device.
Step 2 Click Optical Setup in the left panel.
Step 3 Click the Node Setup tab.
Step 4 Click Select an XML configuration file.
a) Navigate to the location where the COSM XML file without OXC is present and select it.
b) Click Yes.
¢) Click Upload.
A confirmation message appears after the upload is complete.

Important
Manually configure the IP address details of the device, as they are not part of the COSM XML file generated through
Cisco ONP.

Step 5 Create an authorization group for the device added through the imported XML.
a) Click Devicesin the left panel.
b) Inthe Devicestab, click the Authorization Group section to expand it.
¢) Click the Add Auth Group button.

d) Inthe Add Authorization Group dialog box, enter the Auth Group Name, Remote User Name, and Remote
Passwor d in their respective fields.

e) Click Add
The new auth group is added to the table.

Step 6 Edit the device details:

a) In the Devicestab, click the Devices section to expand it.

b) Select the device and update its | P Addressand Auth Group.

c) Click Apply.

d) Wait until Sync Statusto shows sync-completed, and alarm-synchronized.

Step 7 Go to Optical Configuration > ANS parameter and verify whether the respective configurations are complete.
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Export NCS 1010 network planning data for Cisco Optical Network Controller .

Step 8 After you load the Cisco Optical Site Manager XML file without optical cross connect, load the file with optical cross
connect and edit the device details.

Step 9 After adding the Cisco Optical Site Manager XML file with optical cross connect, go to the Optical Cross Connections
tab and verify whether the respective configurations are complete.

Both COSM XML files (without and with OXC) are successfully uploaded to the NCS 1010 device, and
device configurations are updated according to the planned parameters.

Export NCS 1010 network planning data for Cisco Optical
Network Controller

Use this procedure to export NCS 1010 network-planning data from Cisco ONP as a JSON file. You can
upload the exported JSON file to Cisco Optical Network Controller to enable efficient bulk configuration and
management of NCS 1010 devices.

Table 50: Feature History

Feature Name Release Information Feature Description

Export NCS 1010 Network Cisco ONP Release 5.0 You can export the planning data
Planning Data for Cisco Optical of NCS 1010 network, in the form
Network Controller (Cisco ONC) of a JSON file. This JSON file can

be uploaded into Cisco ONC to
configure the managed devices in
bulk.

You can export the planning data of NCS 1010 network only for releases 7.7.1 and 7.9.1.

Procedure

Step 1 In the network tree panel, click the Ellipsisicon next to the network name, and select Generate CONC JSON .

Step 2 In the Export File dialog box, enter the name of the JSON file, and click Export to download the JSON file to your local
system.

Upload planning data into Cisco ONC

Use this procedure to upload the network planning data (JSON file) downloaded from Cisco ONP to efficiently
transfer network design and configuration information into Cisco ONC.

Design and Analyze Networks .
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Procedure

Step 1 Log in to Cisco ONC.

Step 2 Hover over the Import icon in the left panel and click Planning Data Import.
Step 3 Click Import.

Step 4 Browse and select the JSON file you downloaded from Cisco ONP.

You can use the planning data to configure the devices managed by Cisco ONC.

Download multiple networks

Cisco ONP allows you to download multiple networks as an excel sheet.
Follow these steps to download multiple networks.

Before you begin

Log in to the Cisco ONP web interface.

View details of layout and internal connections

Procedure

Step 1 Choose File> Download Networks.

The Select Networ k(s) to Download window appears.

Step 2 Choose a network using one of the options.
Option Description
Search bar Enter the network name and click search icon.
Select All Enable Select All to select maximum 10 networks.
File list Use the file list check box to select the required networks.

Step 3 Click Download.
I nfo panel appears.

Step 4 (Optional) Enter zip folder name to download the selected networks.
Step 5 (Optional) Disable Run in Background to monitor the download progress else go to step Step 7, on page 98.

Step 6 Click Download.
After the zip file is successfully generated, the Download Networ ks notification appears. Choose Download

Step 7 Leaving Run in Background enabled, click Download.

It is recommended to run the network downloads in background for larger networks. Go to Job Monitor to see the
download progress in the background and click Download.
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Note
Download Networksjob will be automatically removed from Job Monitor after 7 days.

The zip folder containing the selected networks downloads in the local folder.
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