
Design and Analyze Networks

• Design a network using Cisco ONP, on page 2
• Create optical subnet for Non-SSON networks, on page 17
• Create optical Subnet for SSON networks, on page 19
• Create optical subnet for NCS 1010 networks, on page 20
• Convert a non-SSON network to SSON network, on page 21
• Convert NCS 2000 network to NCS 1010 network, on page 22
• Share a network, on page 23
• Split-Step Fourier (SSF) Simulation, on page 25
• Analyze the network, on page 28
• Upgrade the analyzed network, on page 30
• Upgrade LNI network, on page 32
• Upgrade the software release of a network , on page 35
• Plan mode, on page 37
• Automatic suggestion for regeneration sites in Plan mode, on page 40
• Line Rate Tuner Mode, on page 42
• Create an Optical Source, on page 48
• Import Optical Sources, on page 49
• Find Optical Sources Faster, on page 53
• Download Optical Sources, on page 53
• Delete Optical Sources, on page 54
• Layout Template for NCS 2000 Network, on page 54
• Layout Visualization, on page 58
• Spectrum Utilization and Path Finder, on page 67
• Regenerate BoM Automatically, on page 71
• Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM, on page 72
• Export IPC Report, on page 72
• Edit the Layout Manually for NCS 1010 Networks, on page 73
• View Internal Node Connections of NCS 1010 Network, on page 75
• Designing networks with COSM card, on page 76
• Cisco Optical Site Manager associations, on page 78
• Export Device NETCONF XML File, on page 79
• Upload NETCONF XML Files on COSMWeb Interface, on page 82
• Export Device NETCONF XML Files for Individual Sites, on page 83

Design and Analyze Networks
1



• Upload NETCONF Files to NCS 1010 Device, on page 83
• Export Cisco Optical Site Manager NETCONF XML File, on page 84
• Upload CiscoOptical SiteManager NETCONFXML toNCS 1010Device via CiscoOptical SiteManager
Web Interface, on page 85

• Export NCS 1010 network planning data for Cisco Optical Network Controller, on page 86
• Upload Planning Data into Cisco ONC, on page 87

Design a network using Cisco ONP
You can design a network in one of these ways:

• Manual Design―Create a network design using a design palette.

• Import Design―Import a network design from an Excel sheet, Live Network Import or from an existing
network from CTP, or another instance of Cisco ONP.

Manually design a network using Cisco ONP
Table 1: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now provides an option
to run some operations in the
background involving database
interaction, such as Save As,
Import CPZ, and Export CPZ.
You can continue to use the Cisco
ONP interface for other operations
when these operations are running
in the background.

Cisco ONP Release 5.2Database Operations Optimization

Table 2: Feature History

Feature DescriptionRelease InformationFeature Name

Now you can include the 4K-2K
nodes in both SSON and
non-SSON networks while
designing the network. This helps
you to validate 4K-2K nodes in the
SSON design which has higher line
rates.

Cisco ONP Release 5.24K-2K SSON Network Creation
Support
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Table 3: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now supports the
C+L-band networks that help you
plan NCS 1010 networks using the
OLT-L and ILA-L line cards to
increase your network’s bandwidth
capacity. Enhanced with L-band
related properties, the UI enables
you to design a C+L-band network
for your ever-increasing channel
demands. The following L-band
types are introduced to suit your
design needs:

• C+L—This band type adds
more channels to your
network, increasing its traffic
carrying capacity.

• C+L Futuristic—This band
type creates a network with
C-band edges and future
provisions for L-band edges
that you can cost-effectively
upgrade after exhausting the
C-band capacity.

Cisco ONP Release 5.1NCS 1010 C+L Network Design

Table 4: Feature History

Feature DescriptionRelease InformationFeature Name

You can design and validate
NCS1010 optical line system. This
feature helps to create OLT-C,
OLT-R-C, ILA-C, ILA-R-C, and
ILA-2R-C based NCS 1010
networks using fixed grid add/drop
MD-32-ODD, MD-32-EVEN and
flex grid add/drop BRK-24,
BRK-16, and BRK-8 passive
modules.

Cisco ONP Release 5.0Greenfield NCS 1010 Network
Design
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Table 5: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to perform
the following:

• Support NCS 4K-1K-2K
multi-platforms

• Visualize new layout for Txp
and SVO for NCS 2000 node

• Support different OTN service
types with protection

• Edit layout for NCS 4000 and
NCS 1004 nodes

Cisco ONP Release 4.1Multi-Layer Platform (MLP)
Greenfield Design with NCS
4k-1k-2k

You can create any of the following network designs:

• Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions

• Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand
and network conditions

• NCS 1010 network

Perform the following steps to create a network in the Cisco ONP:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > New.
Step 2 In the Create New Network dialog box, choose the required options to create a network.

a) From the L0 Network Platform drop-down list, choose one of the following:

• NCS 2000—To create a non-SSON network that contains NCS 2000 and NCS 4000 nodes, or an SSON network
including NCS 2000, NCS 1004, and NCS 4000 nodes

• NCS1010—To create a network that contains only NCS 1010 nodes

• NCS1001—To create a network that contains only NCS 1001 nodes

• NCS1014—To create a network that contains only NCS 1014 nodes

b) If you want to create an SSON network, check the SSON Network check box, else leave it unchecked.

This option is not for the NCS 1010 network.

c) Choose NCS (4K_1K_2K) or NCS (4K_2K) from the Traffic Type drop-down list.
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If you had chosen to create an SSON Network in the previous step, you can view the Traffic Type drop-down list.

Note
Once the network is created you cannot change the Traffic type from 4K_1K_2K to 4K_2K or vice versa. Hence,
we recommend you export the network into an Excel sheet, do the required modification and then import it as a new
network.

d) Choose the System Release for NCS 2K or NCS 1010 from the drop-down list.

You cannot change the system releases that are available for NCS 4K and NCS 1K.

The Band Type drop-down list appears for NCS 1010 networks from Release 7.9.1.

e) From the Band Type drop-down list for NCS 1010, choose one of the following:

• C-Band—Only C-band edges are created and ANS is generated based on C-band. For L-band upgrade, ANS
unlock is required.

• C+L Futuristic—Only C-band edges are created and ANS is generated based on C-band and L-band. For L-band
upgrade, ANS unlock is not required.

• C+L—Both C-band and L-band edges are created and ANS is generated based on C-band and L-band.

Note
After the creation of a NCS 1010 R7.9.1 network, if required, you can change the network band type under the
Network Application Configuration section in the Network Properties.

f) Click Create.

You can view a map and the design palette. For more information, see Design Palette.

Step 3 Click the Drawing Tool icon (pencil and ruler crossed), and add sites and other network elements.
a) Add sites to the map using the drawing tool.

Zoom into the map to the desired level. Click any of the site icons (ROADM, OLA or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.

Note
• SRLG is not supported in the SSON networks.

Traffic node is not supported on the NCS 1010 network.

b) Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.

Note
By default, the fiber length is updated as 1 km for all the fibers. If you want the length to be auto updated based on
the x, y coordinates, then enable the Use Coordinates Distance property under the network properties.

c) Create services between the sites (only for SSON and non-SSON networks).

Cisco ONP provides only OTN service.

d) Click OTN Service (Green in color) and add the service between the existing Traffic sites on the map.
e) Click Circuit (purple in color), Media channel (purple in color), or Waves (red in color), and add media channel,

or waves between the existing sites on the map.
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In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Step 4 Choose File > Save As.
a) In the Give a Network Name dialog box, enter a network name and click Save.
b) If you want this operation to run in the background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

Create Shared Risk Link Group
You can use the Shared Risk Link Group (SRLG) feature for routing protected services. You can create SRLGs
through the Excel import file SRLG tab or through the Cisco ONP GUI using the following procedure:

SRLG is supported only for the non-SSON network including the traffic nodes.Note

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Click the network tree panel in the left.
Step 2 Expand Fibers, and check the check box next to each fiber in the same SRLG.
Step 3 After all fibers are checked, right-click, and select Create SRLG.

SRLG is created with a unique name. You can rename the SRLG.

Import network using Excel sheet
Use this task to import a network into Cisco ONP, using an Excel sheet.

Table 6: Feature History

Feature DescriptionRelease InformationFeature Name

The integration between CX Unified Planning Tool (UPT)
and Cisco ONP enables you to import the networks created
and analyzed in Cisco CX UPT into Cisco ONP. This helps
you avoid recreating the networks that are already created in
UPT. This feature allows you to import networks having NCS
1010 and NCS 2000 nodes into Cisco ONP.

Cisco ONP Release
5.0

CX Unified Planning
Tool Network Import
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Table 7: Feature History

Feature DescriptionRelease
Information

Feature Name

It is now possible to export the topology data of an existing network
into an Excel file. You can easily modify the exported data in Excel
and import it back into Cisco ONP to create a new network or modify
an existing network.

The following are the supported Excel formats:

• xlsx—Standard Excel with multiple sheets, each corresponding
to a network element such as Network, Sites, Circuits, Spans,
OTNdemands, and so on.

• xlsm—Macros-enabled Excel file that can filter out and display
only the applicable network element sheets based on the platform
selected in the Network sheet.

Cisco ONP has the built-in intelligence to automatically calculate the
shortest path between a source and a destination, even if only a partial
fiber path is mentioned in the imported Excel file.

Cisco ONP
Release 5.1

Export and Import
of Network
Topology in Excel
Format

By default, the system release of the Excel imported network is 11.0.Note

From Release 5.0, Cisco ONP supports import of networks created using CX UPT via Cisco ONP Import
Excel option. CX UPT does not populate the DWDMChannel Type and Add/Drop Type values in the Excel
sheet. If the values are not found in the Excel sheet, then Cisco ONP picks the default options. By default,
DWDMChannel Type is NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd and Add/Drop Type
isColored. We recommend you to check theDWDMChannel Type and Add/Drop Type values before importing
the Excel sheet into Cisco ONP to avoid any discrepancies.

Note

From Release 5.1, in addition to exporting the template, you can also export the entire network design data
of an existing network in the form of the Excel sheet, modify the network properties available in the Excel
sheet and reimport. The network can be exported in all modes and reimported on Design mode, Upgrade
mode, and Release Upgrade mode.

Transponders are not supported as part of Export/Import Excel. When you export an existing network with
transponder card forced, the exported Excel sheet will have the Traffic type set to Pluggable Card in
DWDMChannels/MediaChannels tab. Make necessary changes in the exported Excel sheet before you import
it into Cisco ONP.

Note

Before you begin

Log in to Cisco ONP web interface.
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Procedure

Step 1 Choose Export > Excel.
a) Choose the Network Type as Template or Current Network.
b) Choose the File Type as xlsx or xlsm (Macro Enabled)

The Macros Enabled Excel sheet automatically customizes the tabs on the Excel sheet based on the platform that you
choose. It also provides additional functionalities such as selection of fibers in the path selection, wavelength count
validation in case of regen selection.

c) Click Download.

The template has the following mandatory tabs, and the respective fields to be filled in the Excel sheet.

DescriptionTabs

Label (name of the network), Platform (NCS2000(NONSSON), NCS2000 (SSON), NCS1010,
NCS 1001, NCS 1014), Traffic Type, NCS1010 Line Card, NCS1010 Band Type, Chassis
Type, and System Release

Network

This is applicable for NCS 1010 network alone.

State (New, Locked, and Unlocked), NCS 1010 Line Card, NCS 1010 Band Type, and Chassis
Type

Network Property

Site Label, Type, X coordinates, Y coordinates,X_Rearranged, Y_Rearranged, Pre Equip
Degree, Grooming Site, CLLI code, and Site Address, Degree (Scalable upto degree),
NCS1010 Line Card, NCS1010 Band Type, Chassis Type, and State.

Sites

Span label, A (Source site name), Z (Destination site name), Kms (Distance), Loss, Type,
A_Edge, Z_Edge, AZ_Loss, ZA_Loss, AZ_Kms, ZA_Kms, NCS1010 Band Type, and State.

Spans

Demand Label, A (Source), Z (Destination), Y (Tertiary Source), B (Tertiary Destination),
Type, Quantity, Protection, Primary Path, Secondary Path, and State.

Note: Y and B can be used with Unprotected Disjoint Service.

OTNDemands-4K-2K

Demand Name, Source, Destination, Service Group, Type, A/D Type, Protection, Primary
Wavelength, Secondary Wavelength, Primary Path, Secondary Path, First Restoration path,
Second Restoration Path, Primary ODUTimeslot, Secondary ODUTimeslot, Primary Regen,
Secondary Regen, Trunk Mode, Baud Rate, and State.

OTNDemands-4K-1K-2K

Channel Label, Source, Destination, PrimaryWavelength, SecondaryWavelength, Protection,
Traffic Type, Card Type, A/D Type, Primary Path, Secondary Path, Primary Regen, Secondary
Regen, and State.

MediaChannels

ServiceGroup Name, Demand Types, 4K Exclusive LC Usage, 4K Symmetric Aggregation,
1K Exclusive LC Usage, 1K Symmetric AggregationChannel Label, and State.

ServiceGroup

PrimaryWavelength and SecondaryWavelength (Work and ProtectWavelength for NCS2000
non-SSON waves), Primary Path and Secondary Path (Work and Protect Path for NCS2000
Wave/Media Channel and NCS1010 circuit), A/D Type (Colored/Colorless/Contentionless),
Traffic Type, Primary Regen Secondary Regen State, Channel label, A, Z, Wavelength,
Protection, and Type.

DWDMChannels
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DescriptionTabs

Service Name, Source, Destination, Type, Protection, Primary Wavelength, Primary Path,
Primary Regen, Card Type, Trunk Mode, A/D Type, Band Type, and State.

Services-1K

Circuit Label, Source, Destination, PrimaryWavelength, Protection, Traffic Type, Card Type,
A/D Type, Primary Path, Primary Regen, Band Type, and State.

Circuits

Flex Optical Source Name.Flex Optical Source

SRLG Label, Spans, and State.SRLG

Step 2 Fill the network details in the template file or edit the current network file, and save the file.
Step 3 Choose Import > Excel, and select the Import Type.

• New—Choose this option if you want to create a new network using the design data available in the Excel sheet.

• Existing—Choose this option if you want to update an existing network with the data available in the Excel sheet.
Open the network before you import the Excel sheet. The network must be on Design mode, Upgrade mode, or
Release Upgrade mode.

You can view the data available in the Excel sheet before importing the network data. The View Data check box remains
checked by default. Uncheck it of you do not want to view the imported data.

Step 4 Browse, select the saved file, and click Import.

During the import for the Existing network, if the state is Locked, Cisco ONP does not consider the data, if the state is
Unlocked, Cisco ONP changes the existing parameter, provided the network is in upgrade mode, and if the state is New,
the parameters in the Excel is added as a new entry into the network.

During new network import, new network design is created irrespective of the State.

Note
If there are errors in the imported data, a pop-up error message is shown in case of new import, and the errors are available
under the Elements > Messages tabs in case of updating the existing network.

Cisco Transport Planner network import support
You can import the networks that are created and analyzed from Cisco Transport Planner (CTP) to Cisco
ONP, to avoid recreating the networks that are already created in CTP. The CTP network files are in .mpz
format. You can, release upgrade, the imported networks.

• Network must be in design-analyzed or upgrade-analyzed mode.

• You cannot import networks which are earlier than Release11.0.

Note

Supported Hardware

• Optical source files and transponders
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See Supported Optical Sources, and Supported Cards and Pluggables.

• Contentionless, colorless, and colored point-to-point demands

• Flex network

• Gain Equalizer

The Gain Equalizer node changes as a ROADM node when you unlock the site
after the release upgrade.

Note

• ROADM-SMR-9 and SMR-20

• All flex supported amplifiers, controller cards, and chassis types

Import MPZ Design File
Use this task to import .mpz file from CTP to Cisco ONP.

Importing of mpz networks with P-Ring and A2A demands is not supported. Hence, we recommend you to
delete these demands in CTP, reanalyze the networks in CTP and import the mpz into Cisco ONP.

Note

Before you begin

Log in to Cisco ONP web interface as a user with network creation permission.

Import the required optical source files and layout template using Manage > Optical Source and Manage >
Optical Source options. For more information, refer Manage Alien and Manage Layout .

Delete the parameters that are not supported by Cisco ONP from the .mpz file and then import the .mpz file
to Cisco ONP.

Procedure

Step 1 Choose Import > MPZ.

The Import File (.mpz) dialog box appears.

Step 2 Browse to the .mpz file stored in your local system.
Step 3 Choose 4K_1K_2K or 4K_2K from the Traffic Type drop-down list.

If you had chosen an SSON MPZ file, you can view the Traffic Type drop-down list.

Step 4 Click Import.

The .mpz file gets imported to Cisco ONP.

Note
If you view a blank screen when you click waves in the network tree, refresh the browser.
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Step 5 Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

Note
• You cannot go back to design mode on the imported mpz network.

• The wave label of imported mpz network in Cisco ONP is the service name present in the CTP properties window.

Export the CPZ File
Cisco ONP stores the network design file as .cpz file in its database. You can export the design file into your
local system.

• In design mode, the .cpz file includes the design file, layout template, and optical source details.

• In analyze mode, the .cpz file contains a design file, analyze file, ANS file, per-side ANS file, BOM,
error messages, trace files, layout template, mpz, and report.

• For networks in upgraded mode, you can only export the last child in the parent-child hierarchy.

You can export only one network at a time.Note

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Choose File > Open.
Step 2 In the Select Network To Open dialog box , click the network that you want to export, from the list of networks.

The network opens.

Note
If you view a blank screen when you open a network, refresh the browser, or log in to Cisco ONP again.

Step 3 Choose Export > CPZ.
Step 4 In the Export .cpz file dialog box:

a) If required, rename the file.
b) If you want this operation to run in background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

c) Click Export and save the file in your local system.
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Import CPZ File
You can import the cpz network design files that are exported from another Cisco ONP instance.

You can import only the networks that are exported from the current release.Note

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose Import > CPZ.
Step 2 In the Import .cpz file dialog box:

a) Click Choose file, and select a cpz network design file that you want to import into Cisco ONP, from your local
system.

b) If you want this operation to run in background, click the Run in Background check box.
A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

c) Click Import.

If the names of the optical source and layout template files available in the Cisco ONP database and the imported
network file are the same, you are prompted to confirm whether you want to overwrite the existing file.

Note
The error message "Network already exists in the system with another user. New network will be created" is
just an information. You do not need to perform any action. Cisco ONP automatically imports as a new network
specific to the user. There is no impact on the already existing network.

d) If you want to overwrite the existing file, check the Overwrite Network check box.

If you leave the check box unchecked, Cisco ONP saves the imported network as a new network.

e) Choose the optical source files and layout template that you want to replace.

If you do not choose the optical source or the layout template file, the files will not be imported.

f) Click Confirm.

The imported network is saved in the Cisco ONP database.
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Live Network Import
Table 8: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now directly communicates with Cisco ONC to
perform a live network import, eliminating the need for Cisco
ONP to be directly connected to a device or network. In
addition to the previously supported NCS 2000, networks
that include NCS 1010 nodes contained within NCS 1010
and NCS 1014 shelves can also be imported.

Cisco ONP Release
25.1.1

Live network import
from Cisco ONC

Table 9: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to import
a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

Cisco ONP Release 4.1Live Network Import

The Live Network Import (LNI) feature allows you to import deployed networks into Cisco ONP in real-time.
This includes networks containing NCS 2000 nodes and NCS 1010 nodes contained within NCS 1010 and
NCS 1014 shelves. To perform the LNI operation, you must have a Network Management role. Once the
import is complete, you can view the entire deployed network details within Cisco ONP. The Map displays
the network topology, and you can check the node, fiber, service, and circuit properties through the Network
Tree and the Entity Editor.

From Release 25.1.1, you can import a live network through Cisco ONC.

Perform Live Network Import
Use this task to perform live import of a network from Cisco ONC:

Before you begin

• Perform LNI only when the Cisco ONC is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

• Ensure that the release version of Cisco ONC you are using for the network import is 25.1.1.

• Configure all the mandatory parameters on the circuit.

• Check the card label set for the following NCS 2000 cards and update it if they are not aligned.

Card LabelPID

AD-16-FSNCS2K-16-AD-CCOFS
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Card LabelPID

SMR20-FS-CVNCS2K-20-SMRFS

SMR20-FSNCS2K-20-SMRFS-L

SMR9-17-FSNCS2K-9-SMR17FS

SMR9-24-FSNCS2K-9-SMR24FS

SMR9-34-FSNCS2K-9-SMR34FS

SMR9-34-FSNCS2K-9-SMR34FS-L

OPT-RAMP-COP15454-M-RAMAN-COP=

OPT-RAMP-CTP15454-M-RAMAN-CTP=

OPT-EDFA-35NCS2K-OPT-EDFA-35

• Log in to Cisco ONP web interface

.

Procedure

Step 1 Choose Import > Live Import.
Step 2 In the Import Live Network dialog box:

a) Enter CONC Server IP, Username, and Password.
b) Click Import.

The Import button will be enabled only when all the values entered are valid.

Step 3 View the status of the LNI operation:
a) Click Job Monitor, to view the status of the IMPORT_LIVE_NETWORK task. Click Refresh to see the updated

status.

After LNI is completed, the job is removed from the Job Monitor page.

b) Click Logs to view the list of events that are related to the LNI operation, as logs.

Step 4 After the completion of the LNI operation, choose File > Open.

The format of the LNI imported network filename is LNI_<Date>_<Time>.

Step 5 Click the imported network name to view the network under the Map tab and its corresponding network tree in the left
panel.

You can view the tag Imported from Network in the top-right corner.

Note
• The configurations that are supported by Cisco ONC can only be imported into Cisco ONP. See Configurations and
hardware supported by LNI, on page 15.
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• Even If some errors occur during the LNI operation, the LNI operation is not canceled. In such case, when you open
the imported network, a warning message is displayed.

• You can view the errors under the Elements > Messages tab. See both critical and noncritical messages.

• If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS option. You can
edit this option during upgrade after unlocking the site, if necessary.

What to do next

Click the BOM tab to view the BOM details of the network.

The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.Note

You can export the CPZ, import the CPZ, and share the imported network. You can check the properties of
the network using the Entity Editor.

Configurations and hardware supported by LNI
The live network import from Cisco ONC supports the configurations and hardware listed in this table.
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Table 10: Configurations and hardware supported by LNI

ConfigurationsCardCard typeChassisPlatform

Contentionless

Unprotected
circuits

NCS2K-20-SMRFS-L

NCS2K-20-SMRFS=

NCS2K-20-SMRFS-CV=

NCS2K-9-SMR17FS=

NCS2K-9-SMR34FS=

NCS2K-9-SMR24FS-L=

NCS2K-9-SMR34FS-L=

ROADMNCS 2015

NCS 2006

NCS 2002

NCS 20001

NCS2K-16-AD-CCOFSAdd/Drop

NCS2K-OPT-EDFA-17=

NCS2K-OPT-EDFA-24=

NCS2K-OPT-EDFA-35=

15454-M-RAMAN-CTP=

15454-M-RAMAN-COP=

Amplifiers

NCS2K-400GXP-L-K9

NCS2K-200G-CK-LIC

NCS2K-200G-CK-LIC+
15454-M-10X10G-LC

Transponders

Colored

Colorless

Unprotected
Circuits

All OLT variants with
Standard and Enhanced
faceplate

ROADMNCS 1010

NCS 1014

NCS 1010

CCMD16-C

MD-32-ODD

MD-32-EVEN

BRK-24

BRK-8

Direct LC

Add/Drop

All ILA variantsAmplifiers

NCS1K14-2.4T-K9,
NCS1K14-2.4T-X-K9 and
NCS1K4-QXP-K9

Transponders

1 Optical source interface import is not supported in NCS2000. By default, it is set to
NCS1004_SP_16QAM_300G_27%SDFEC_69GBd. You canmanually edit the optical source interface
to the correct one during an upgrade, without unlocking the circuit.
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Limitations of LNI
The LNI feature has these limitations:

• You cannot perform multiple LNI at the same time.

• Scheduled LNI is not supported.

• LNI does not support:

• Non-SSON Network import

• Non-Contentionless configuration import

• Import of NCS1001, NCS1004 and NCS4000 devices

• Importing a network with a mix of NCS 2000 and NCS 1010 nodes from Cisco ONC is not supported.

Workaround: Add either NCS 2000 nodes or NCS 1010 nodes into Cisco ONC and perform the Live
Network Import for the selected node type.

• When importing anNCS2000 network, only the 400G-XP-LC, 200G-CK-C, and 200G-CK-C+ 10x01G-LC
transponder cards are successfully imported.

• If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the
node position after importing.

• Cisco ONP imports the proto-PID, if any, present in inventory, and show as N/A PID in the Cisco ONP
BOM.

• Duplicate media channel label is not supported. If there are multiple media channels with same label
present in the network, only one media channel is imported and the rest of them are discarded.

• Fiber name, source, and destination names may not match between the first and the second import. Source
and destination site names may interchange for bidirectional fibers.

• Fibers may not be associated with correct optical subnet if the fibers are not configured with the same
channel number at both source and destination ends. Due to this amplifier output power may not be
within valid range. Hence, you either correct channel number at both source and destination nodes and
re-import the network, or associate the fiber with correct optical subnet after network upgrade in Cisco
ONP.

Create optical subnet for Non-SSON networks
An optical subnet is a collection of spans with certain associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet that is associated to the network. At least one optical subnet
must exist for each network.

Check the Current Subnet check box in the properties window below the network tree, to make the subnet
you created as the current subnet. You cannot uncheck the Current Subnet check box.

Note
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Use this procedure to create an optical subnet for Non-SSON networks:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the non-SSON network in which you want to create a subnet.

The network opens.

Step 2 Expand Subnet in the network tree panel.
Step 3 Click the Ellipsis icon available in the right side of Optical Subnet.

a) In the Create Optical Subnet dialog box, choose the C-band design rules for the new optical subnet that you want
to create, from the Cband Rules drop-down list, then click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Step 4 After the new optical subnet is created:

Then...If you want to...

select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

select a new spectral density

add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet

• Click the Ellipsis icon available in the right side of the required optical
subnet and select Edit Fibers.

In the Info dialog box, click OK.

The UI freezes, and you can select a fiber only from the map.

• Select the required fiber and click theDone button appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.

add a fiber to a subnet from the network
tree panel
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Create optical Subnet for SSON networks
The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the SSON network in which you want to create a subnet.

The network opens.

Step 2 Expnad Subnet in the network tree panel.
Step 3 Click the Ellipsis icon available in the right side of Optical Subnet, and select Create Optical Subnet.

a) In the Create Optical Subnet, choose the spectral density for the new optical subnet that you want to create from
the Spectral Density drop-down list.
The Name, CBand Rules, and Maximum Number of Channels the you see in the Create Optical Subnet dialog
box, are set based on the spectral density that you have selected.

b) Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Step 4 After the new optical subnet is created:

Then...If you want to...

select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

select a new spectral density

add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet
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Then...If you want to...

• Click the Ellipsis icon available in the right side of the required optical
subnet and select Edit Fibers.

In the Info dialog box, click OK.

The UI freezes, and you can select a fiber only from the map.

• Select the required fiber and click theDone button appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.

add a fiber to a subnet from the network
tree panel

Create optical subnet for NCS 1010 networks

From Release 7.9.1, both C-Band and L-Band optical subnets appear by default for the NCS 1010 networks.

For C-Band and C+L Futuristic networks, the L-Band optical subnet contains no fiber links. To add fiber links
for the L-Band optical subnet, you must upgrade the existing network to a C+L-Band network or add an
L-Band edge for each C-Band edge.

Note

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the NCS 1010 network in which you want to create a subnet.

The network opens.

Step 2 Expand Subnet in the network tree panel.
Step 3 Click the Ellipsis icon available in the right side of Optical Subnet, and select Create Optical Subnet.
Step 4 In the Create Optical Subnet dialog box:

a) Choose either C-Band or L-Band from the Band Type drop-down list.

Note
From R7.9.1, Band Type drop-down list is available when creating an optical subnet for NCS 1010.
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b) From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to
create.

From Release 5.2, the range of spectral density has increased (ranges 30–100).

The Name, CBand Rules or LBand Rules, and Maximum Number of Channels values that appear in the Create
Optical Subnet dialog box are set based on the spectral density that you have selected.

c) Click Save.
A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Step 5 After the new optical subnet is created:

Then...If you want to...

select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

select a new spectral density

add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet

• Click the Ellipsis icon available in the right side of the required optical
subnet and select Edit Fibers.

• In the Info dialog box, click OK.

The UI will freeze to allow fiber selection from the map.

• Select the required fiber and click theDone button appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.

add a fiber to a subnet from the network
tree panel

Convert a non-SSON network to SSON network
The following procedure converts non-SSON networks to SSON networks:

You cannot convert a non-SSON network with Traffic Sites to SSON.Note

Before you begin

Log in to Cisco ONP web interface.
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Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the non-SSON network you wish to convert.

Ensure that the network is in Design Mode. If the network is in Analyze mode, upgrade or release upgrade the
analyzed network, then unlock all the channels, and force CFP-2 optical source.

Step 2 Convert to SSON:
a) Choose Network > SSON Convert and click Ok.
b) If you see the error message "Network cannot be converted to SSON due to following errors : [Network contains

waves with invalid traffic types: [100G-SD-FEC, 200G-SD-FEC]]", follow these steps to resolve it:

• Choose Network > Entity Editor > Services.

• Expand Waves and navigate to trail, and click a trail.

• From the Src Card Type drop-down list, choose any CFP-2optical source

• Click Update, then choose File > Save.

• Choose Network > SSON Convert again.

Step 3 In the Warning pop-up window, choose 4K-2K or 4K-1K-2K from the Traffic Type drop-down list, and click Ok.
Note that 4K-1K-2K is the default option. After the network is converted, you cannot switch the site types between
4K-2K and 4K-1K-2K.
The non-SSON gets converted as SSON network.

Step 4 After the network is converted to SSON, select SSON optical source from theTraffic Type drop-down list in the properties
window displayed under the network tree and click Update.

Convert NCS 2000 network to NCS 1010 network
Use the following task to convert an NCS 2000 network (both SSON and non-SSON) into to NCS 1010
network:

Table 11: Feature History

Feature DescriptionRelease InformationFeature Name

The newly introducedNCS 1010 Convert option under
the Network menu enables you to directly convert an
existing NCS 2000 network into an NCS 1010 network.
This conversion eliminates the need to build an NCS
1010 network from scratch.

Cisco ONP Release
5.1

Convert NCS 2000
network to NCS 1010
network
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Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the non-SSON network that you wish to convert.

The network opens. Ensure that the network is in Design Mode, Upgrade Mode or Release Upgrade Mode.

Step 2 Choose Network > NCS 1010 Convert, then click Ok.

The network does not get converted and shows an error message, if

• the network contains traffic sites.

• the fiber type is LS or TWClassic.

• the network contains OTN services.

• the traffic Type property is set to anything other than Optical Source or Pluggable Card.

• the Traffic Type is 100G-SD-FEC or 200G-SD-FEC in non-SSON networks.

Step 3 Choose File > Save.

The following parameters are automatically updated after the conversion:

• Contentionless sides are deleted and contentionless demands are automatically changed as colorless.

• Protected channels are converted to two unprotected channels. The path, wavelength, regen sites and cards that are
configured are retained.

Share a network
Use these steps to share a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network that you want to share.

The network opens.
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Step 2 Choose File > Share.
Step 3 In the Share Network dialog box, select one or more users or user groups, then click Share.

You can share the network with selected users or user groups in read-only mode.

Access a shared network
Use these steps to access a network shared by another user:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open a shared network:
a) Choose File > Open Shared.
b) In the Select Network To Open dialog box that lists the networks that are shared by other users, select a network.

The shared network opens in read-only mode.

Step 2 Choose File > Save As.
Step 3 Enter the name in the Give a network name dialog box, and click Save.

A copy of the shared network is saved.

Note
You can work on this copy of the network, depending on the privileges of your user role. For example, if your user role
is Designer, you can change the design of the saved copy of the shared network, but you cannot analyze the shared
network.

Step 4 If you want, share the updated network with other users.

Unshare a network
Use these steps to unshare a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network you want to share.

The network opens.
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Step 2 Choose File > Share.
Step 3 In the Share Network dialog box, remove the name of one or more users or user groups from the list, then click Share.

The shared network is no longer available to the users or user groups that are removed.

Split-Step Fourier (SSF) Simulation
Table 12: Feature History

Feature DescriptionRelease
Information

Feature Name

The Split-Step Fourier (SSF) method is introducted to calculate optical
parameters in addition to the existing e-GN algorithm for analysing NCS 1010
networks. This enhancement:

• Improves the accuracy of the simulations for OSNR and BER, particularly
in complex network scenarios.

• Provides an SSF engine that leverages GPUs to work on intense
calculations.

• Requests simulation generation from GENE (Generic Engine for NCS
1000 platforms)

• Monitors analysis progress on the GPU server, and updates the user
through analysis notifications.

• Sends simulation results to GENE for report generation after analysis
completion.

• Provides a Lookup Table that contains the default optical specification
values for each supported amplifier.

The new properties that enable the SSF method for network analysis are.

• At network level, Advanced Optical Settings > SSF
Simulation—Enables the SSF simulation. Enable the Enable Special
Settings check box to view the SSF Simulation check box

• At network level, Advanced Optical Settings > LUT version—Shows
the default LUT version to be used for network analysis. Enable the
Enable Special Settings check box to view the LUT version check box

• Preferences > General Settings > SSF Server Details—Allows to
configure the GPU server used for SSF simulation.

• Manage > Lookup Table—Allows you to refer the default optical
specification of the supported amplifiers.

Cisco ONP
Release
25.1.1

Split-Step
Fourier (SSF)
Simulation
Method
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The Cisco Optical Network Planner supports simulation using Split-Step Fourier (SSF) method in addition
to the existing e-GN Algorithm for optical parameters calculations such as OSNR, BER. The SSF method
uses an SSF engine that runs on GPUs to do intense optical calculations.

Limitations of SSF simulation

• Supports only point-to-point networks

• Works only with CIM8 interfaces

• Supports only colorless add/drop

• Computation intensive than e-GN algorithm for better OSNR margins

Set SSF Server Details
The procedure to set the SSF server to run the SSF analysis is as follows:

Before you begin

Install the SSF component.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network that you want to upgrade.

The network opens.

Step 2 Navigate to SSF Server Details.
a) Choose Preferences > General Settings
b) In the dialog box, select SSF Server Details.

Step 3 Enter the SSF server details.

In SSF Server Details, enter the required details

DescriptionFields

Enter the server IP addressSSF Server
IP

This field is disabled.API Key

Enter the customised proxy IP address.Proxy IP

Enter proxy port of the server.Proxy Port

Step 4 Click OK.
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To reset the server details or close the dialog box, click Reset or Cancel.

Lookup Table (LUT)
CONP uses LUTs while performing analysis using SSF simulation. LUT can also be used even when SSF
simulation is not in use. The LUT values are used for the NCS 1010 networks only.

You can enable LUT only when you enable the Advanced Special Settings checkbox at the Network level.
By default, Lut is set to the version – ‘1.1.3’

Manage Amplifier Gains using Look Up Table
The procedure to refer or manage the amplifier gains in the look up table is as follows:

Procedure

Step 1 Open look up table.
a) Choose Manage > Lookup Table

The Manage Lookup Table dialog box opens displaying the list of supported amplifiers.

ActionsOptions

Allows to type in the amplifier to filter the desired lookup
table.

Search

Selects all or required amplifier tables.Check boxes

Turns to the desired page.Page numbers

Imports the customized tables.Import

Exports the selected tables.Export

Deletes the selected tables.Delete

Closes the dialog box.Cancel

When expanded, the table displays the optical specifications.

Table 13: Amplifier optical specifications

DescriptionParameter

Displays the list of supported fibers for the amplifier.Fiber Type

Displays total signal loss in dB.Total Loss (dB)

Displays the SD gain range.SD Range
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DescriptionParameter

Displays the status of Raman amplification in the amplifier.Raman
Amplified

Displays the PSD value for the booster amplifier in dBm.BSTPSD (dBm)

Contains an information button to check for additional values.More Parameters

Step 2 (Optional) Customize the optical specifications in the Lookup table.
a) Select the required amplifier.
b) Click Export.

The amplifier value downloads in spreadsheet.
c) Edit the values in the downloaded spreadsheet and click Import.

The new values are added to the Lookup table.

Step 3 (Optional) Delete the customized specifications in the Lookup table.
a) Select the required amplifier.
b) Click Delete.

Restriction
You cannot delete the default tables.

Analyze the network
Table 14: Feature History

DescriptionRelease InformationFeature Name

The See More Details option has
been introduced in the tooltip
displayed on hovering over Sites
on the Map view of an analyzed
network. This option shows the
Amplifier data and PSD (Power
Spectral Density) profile graph. The
See More Details option avoids
navigating to the Entity Editor to
view these details.

Cisco ONP Release 5.1Detailed Tooltip for Sites on the
Map View

Use this procedure to analyze the network after design completion.

Before you begin

Log in to Cisco ONP web interface.
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Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network that you want to analyze.

The network opens.

Step 2 Analyze the network:
a) Choose Network > Analyze.

The Cisco ONP analysis progress indicator indicates the analysis status. After successful analysis, the network goes
to Analyze Mode.

b) If you see the “Analysis Failed.” message, navigate to the Elements > Messages tab to see the list of error details in
the analyzed network.

By default, it shows only the key messages when the Critical Only toggle button is enabled. If you want to view the
entire network message, disable the Critical Only toggle button.

c) Resolve the error and analyze the network again. Repeat this step until all errors are resolved.

Note
The error message "Unexpected Situation 999" may occur when the optical simulation becomes inconsistent due to
incorrect values of properties entered or modified while designing the network. Call Cisco TAC to know the exact cause
of the error and modify the suggested property value for the successful analysis of the network.

Step 3 If you want to view the details such as Amplifier Data and PSD Profile graph for a site in an analyzed network, hover
the mouse over a site and click See More Details.

The amplifier data includes output power, EOL gain, attenuator in, attenuator out, and Raman gain. The attenuator details
are not displayed for the NCS 1010 site. The PSD profile graph is displayed only for the NCS 1010 site.

Bottom-Up Flow
Bottom-up support enables step-by-step creation of a network. Adding all the services and waves on day 0
itself is not mandatory to analyze the network and view reports. Bottom-up flow enables you to build a network
over a period.

Day 0: Create a network with only the topology added. Add all sites and add fibers between them. Analyze
the network and view the reports without adding any services or waves.

Day 1: Add waves between the sites that are added on Day 0 and newly added sites and fibers. Analyze the
network and view the reports.

Day 2: Add services and tag waves that are created on Day 1 and newly added sites and fibers. Analyze the
network and view the reports.
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After you have created the topology with sites and fibers added, you can add either a service or a wave. You
need not follow any specific order.

Bottom-up flow is applicable only for Non-SSON networks. In order to achieve this, you must set A2A mode
as A2A_fast in network properties. You can also set the A2A channel type as contentionless, colorless, and
colored.

Note

Idle Timeout in the Analyze Mode
If you keep the browser idle for more than 15 minutes, you are logged out of Cisco ONP. The default timeout
is set to 15 minutes. The System Admin can disable this feature by changing the enabled option in the
configuration file on the server to false. You can change the default time of 15 minutes by editing the duration
option in the configuration file.

During a long network analyze cycle, you get logged out due to idle timeout, and the network analysis runs
in the background. When you log back, the same network opens in one of the following states:

• If the analysis is still on, the analysis progress bar is shown, and you cannot perform any other action.

• If the analysis is complete, the network opens in the Analyze mode.

• If the analysis has failed, the network opens in the design mode, and you can view the reason for failure
on the Elements > Messages page.

The session time out does not redirect you to the login page always; so, reload or enter the URL again.

Upgrade the analyzed network
Table 15: Feature History

DescriptionRelease InformationFeature Name

After a network is analyzed, all the
network elements get locked. With
this feature, you can selectively
unlock certain network elements to
upgrade the network further. This
helps in preventing accidental
updates to the part of the network
that does not need any
modification.

Cisco ONP Release 5.0NCS 1010 Network Upgrade
Flexibility

Cisco ONP allows you to upgrade an existing network that is in analyzed mode. You can modify certain
properties of a network element in the network while retaining the existing network layout and design in the
locked state. Upgrade is supported for NCS2K, NCS4K-2K, NCS4K-1K-2K and NCS1010 networks.

Use these steps to upgrade your network:
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Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network that you want to upgrade.

The network opens.

Step 2 Upgrade the network:
a) Choose Network > Upgrade.
b) Click Yes .

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), media channel (for SSON), and circuits (for NCS 1010) are locked.

Step 3 To modify a network element in the network tree panel, click the Ellipsis icon next to element, and choose Unlock.

You can unlock elements one at a time down to the lower levels of the network tree hierarchy. For example, you can
hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers level.

If you want to change only the add/drop between MD-32-ODD/Even or BRK_24/16/8 in the NCS 1010 network, you
can unlock the add/drop without unlocking the network elements that are higher in the hierarchy.

You can make these modifications:

• Editing the properties of network elements.

• Deleting the network elements from the network.

• Adding a new site, wave, services, demands, optical subnet, or fiber into the network map.

Step 4 Choose File > Save.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

Note
You can insert a node in the upgrade mode only for the unlocked fiber. Therefore unlock the fibers that are connected to
the node and add nodes to the network.

Step 5 Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network that has where layout template is applied, the template gets
updated with the newly added service or fiber. You can export this template, make changes and reapply it to another
network.

Step 6 Choose Network > Design to further upgrade the newly upgraded network design.
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When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Upgrade LNI network
Table 16: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to upgrade
andmodify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

Cisco ONP Release 4.1Upgrade LNI Network

The Upgrade feature can be used to correct LNI errors, modify the network, reanalyze the network and view
updated BOM, Layout, Connections, and Optical Results.

Use these steps to upgrade the LNI network:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network:
a) Choose File > Open.
b) In the Select Network To Open dialog box, select the network imported through LNI that you want to upgrade.

The network opens.

Step 2 Upgrade the network:
a) Choose Network > Upgrade.
b) Click Yes .

The message “Network Upgraded Successfully” appears. After upgrading the network, the network enters the upgrade
mode, locking elements like Sites, Fiber, OTN Services, and Media Channels.

Step 3 To modify a network element in the network tree panel, click the Ellipsis icon next to element, and choose Unlock.

You can unlock elements one at a time down to the lower levels of the network tree hierarchy. For example, you can
hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers level.

You can make these modifications:
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• Editing the properties of network elements.

• Deleting the network elements from the network.

• Adding a new site, wave, services, demands, optical subnet, or fiber into the network map.

Step 4 Choose File > Save.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Step 5 Choose Network > Analyze.

Analysis is successful only if a consistent and valid network is imported. For instance, in an NCS 2000 network imported
from Cisco ONC, if the device connections do not match with Cisco ONP rules, the upgrade analysis may fail with a
connection error. If the analysis fails, perform these steps:

a) Check the reports under Elements Messages for failure reasons.
b) Unlock the specific site to allow Cisco ONP to rebuild the connections according to its rules. Alternatively, correct

the connections on the device and re-import the network.
c) Re-Analyze the network.

Step 6 After analyzing the network:
a) Click the Layout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004

platforms. See
b) Click the BOM tab, and the Results tab to view the BOM and optical results.

After upgrading and analyzing the LNI network:

1. If the LNI inventory has any unconnected cards, that will be removed from the Cisco ONP reports after
upgrading and analyzing the LNI network.

2. These PIDs are added in the Cisco ONP BOM after upgrading and analyzing the LNI network. These
PIDs are not part of the LNI network BOM.

• Pre-provisioned PIDs

• Release software PIDs and Licenses

• Optical cables: Cables used for Internal Patch-cord Connection (IPC) is not imported in LNI as this
data cannot be retrieved from device

• Attenuators

• SMR port license PIDs: Only SMR card PID is imported as part of LNI. If a licensed PID is retrieved,
corresponding port licenses are added after upgrading and analyzing the LNI network, based on the
number of ports used.

• USB cables: Added if Pre-provisioned passive cards are present.

• Blank cards: Blank cards are not imported. They are added in CiscoONP after upgrading and analyzing
the LNI network.
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Possible error scenarios and the workarounds
This table describes the workarounds for the errors that are shown under the Elements > Messages tab.

Table 17: Error scenarios and the workarounds

WorkaroundsError message

Check the username and password of the device,
which is given in LNI input Excel and retry LNI
import with valid device credentials.

Device Authentication failure

Check for any connectivity issue in the setup, fix it
and retry LNI import.

Device collection failed or Device not reachable.

Unlock C-Band amplifiers for side A inside Site4 in
the Network tree and force the valid output power. If
not sure, set it to Auto and analyze. Cisco ONP
chooses the best value based on the configuration.

In Site4.A, output power setting is not supported by
the amplifier.

For protected OTN service or SSON service, a
minimum of two contentionless sides must be present
on the source and destination sites. Check and add
contentionless sides on the target service source and
destination site and analyze.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

Only 100GE, 10GE, and STM-64 service rates are
supported. If any other service rate is present in the
network, unlock the specific service, change it to one
of the supported service types and update the ODU
time slot accordingly and analyze.

• Demand OTU3 has unrecognized type [OTU3]

• ServiceGroup does not support the demandType
OTU3 for OTU3

100GE service type must have ODU time slot in the
range of 1–80. If any other value is set, update the
correct value or leave it blank so that Cisco ONP can
set it to the correct value.

Primary OTN Demand [100GE_Flex] has invalid
Timeslot ranges. Allowed ranges are [1-80]

Unlock the site and reanalyze.Cannot complete mesh connections at Site3.

No action required. This is an information message
to the user.

No OTN demand found for NCS4K trunk port -
NCS4016-B - OTU40/8/0/1.

Unlock the corresponding fiber couple and update the
correct connector loss value to be greater than zero.
The typical value is 0.2.

Fiber between Node1.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
correct Tot SOL Loss w/o Connectors. The value
should be greater than zero.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Remove Raman forcing on the fiber, or check and
force the path for any service so that it goes through
Raman enabled span.

Span Fiber-2 is forced as Raman but no traffic is
present.
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WorkaroundsError message

Force RAMAN-CTP or COP on the Fiber-2
connecting node interface or remove RAMAN forcing
on the Fiber-2

Couple Fiber-2 has Raman enabled on the duct but
corresponding Raman Forcing is missing.

No specific action is required for noncritical messages. These are just information messages to the user.Note

Upgrade the software release of a network
Table 18: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to choose the NCS 2000 system release to
the desired release (11.1.0, 12.0.1, or 12.1.0), while performing the
release upgrade of CTP network, Cisco ONP network, network
imported through Excel, and LNI network.

Cisco ONP Release
4.1

Release
Upgrade

You can upgrade the software version of networks that are imported from CTP, created in Cisco ONP, LNI
Network, or imported from Excel to any desired release version. The release upgrade is supported for both
SSON and non-SSON networks that have NCS 2000 nodes with ROADM, OLA, Traffic, or Passthrough
functionality, and NCS 1010 networks.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

NCS 2000 supports SVO from the Release 12.1.0, and Cisco Optical Site Manager from 25.1.1.Note

The table shows the available upgrade releases for each network type.

Table 19: Supported upgrade paths for network system releases

Upgrade ReleaseNetwork

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1

• From 11.1.0 to 12.1.0, 12.2.0, 12.3.1 and 25.1.1

CTP network (.mpz)

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1

• From 11.1.0 to 12.1.0, 12.2.0, 12.3.1, and 25.1.1

• From 12.1.0 to 12.2.0, 12.3.1, and 25.1.1

Cisco ONP network

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1Excel imported
network
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Upgrade ReleaseNetwork

Note
Release upgrade is not supported for the LNI networks in Release 25.1.1.

LNI network

• 7.7.1 to 7.9.1, 7.10.1, 7.11.1, 24.31,25.1.1

• 7.9.1 to 7.10.1, 7.11.1, 24.31, 25.1.1

• 7.10.1 to 7.11.1, 24.31, 25.1.1

• 7.11.1 to 24.31, 25.1.1

NCS 1010 Network

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open the network in which you want to perform the system release upgrade.
Step 2 Upgrade the software release of the network:

a) Choose Network > Release Upgrade.
b) From the New System Release drop-down list, choose the system release of NCS 2000 or NCS 1010, to which you

want to upgrade.
c) Click Submit.

The upgraded network is saved as a child network.

The network elements are locked in the network tree after the release upgrade. You can unlock and modify the
elements.

Note
If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by the PMD
value when you edit the fiber properties.
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Plan mode
Table 20: Feature History

Feature DescriptionRelease InformationFeature Name

This feature extends the current
implementation ofWhat-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported for SSON
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Cisco ONP Release 4.1What-if Analysis for OTN Services

Plan mode overview

Plan mode is a feature that allows you to perform what-if analysis on existing network designs. This analysis
can simulate network behavior during failures and determine if services can be rerouted. However, it does
not provide guidance on setting up new wavelengths or adding new nodes, cards, or ports.

Advantage

The Plan mode effectively simulates and analyzes potential network issues and solutions, focusing on rerouting
capabilities without physical changes to the network infrastructure.

Supported network elements

• NCS 2000 aggregated node that includes ROADM, OLA, and passthrough nodes

• Traffic nodes such as 1K-2K, 4K-2K, and 4K-1K-2K

• Nodes created in Cisco ONP

• CTP imported networks (mpz format)

• LNI imported networks

Limitations

• Only users with PLANNER and ADMIN roles can access the Plan mode.

• It does not guide on turning up new wavelengths or adding new network components.

Perform a what-if analysis on an analyzed network in the Plan mode
Use this task to perform a what-if analysis of a network and export the failure report in the Plan mode.
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Before you begin

Log in to Cisco ONP web interface as a user with admin or planner role.

Procedure

Step 1 Open a network that is in Analyze mode.
Step 2 Choose Network > Enter Plan Mode.

The network switches to the Plan mode. After entering the Plan mode, you can do what-if analysis of the network by
failing fibers and sites in the network.

Step 3 Fail the sites:
a) Expand the Sites option in the network tree panel.
b) Click the Ellipsis icon available in the right side of the site, and click Fail. Alternatively, you can right-click a site

in the map and select Fail.
c) To fail multiple sites, check the check box next to each fiber before selecting Fail.

Step 4 Fail the fibers.
a) Expand Fibers in the network tree panel.
b) Click the Ellipsis icon available in the right side of the fiber, and click Fail. Alternatively, you can right click a fiber

in map and select Fail.
c) To fail multiple fibers, check the check box next to each fiber before selecting Fail.

You can observe that all media channels or waves, OTN services, and demands that pass through the failed fiber will
fail. These are indicated by symbols in the map:

• Failed channels: Red cross

• Fibers impacted due to site failure: Yellow cross

• Restored channels: Green tick

d) To undo the fiber failure, click the Ellipsis icon available in the right side of the fiber, and click Undo Fail.

Step 5 If you want, you can Create a failure set.
Step 6 Restore the failed fibers by clicking Restore.

The restored channels are indicated with a green color tick mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber also get restored. The Path Computation
Element (PCE) supports the restoration of the OTN services based on the optical feasibility and OTN constraints.

Step 7 After restoring the fibers, export the failure report:
a) Choose Export > Failure Report to export the failure report as an Excel sheet. See Failure report , on page 39for

the parameters included in the failure report.
b) Alternatively, you can click Export in the Failure Report area below the map.

You can view the unrestored channel details in the failure report and the reason for restoration failure under Elements >
Messages tab.

Step 8 Exit the Plan mode.
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a) Choose Network > Exit Plan Mode.

Create a failure set
Create a failure set to fail a set of fibers and sites in a single click. You can save multiple failure sets under a
given failure group.

The following procedure shows how to create a failure set:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Open a network and enter the Plan mode.
Step 2 Click the Ellipsis icon available in the right side of the Failure Groups option in the network tree panel.
Step 3 Click Add Failure Group.

A Failure group gets created.

Step 4 Add fibers and sites to the group.
a) Choose the Fibers and Sites to fail by checking the check boxes next to the them.
b) Click the Ellipsis icon available in the right side of the chosen Fibers and Sites, and click Fail.

Step 5 Click the Ellipsis icon available in the right side of the network name and click Add Failure Set.
Step 6 Select the Failure Group to which the failed fibers or sites must be added.

The Failure Set gets created under the Failure Group. The failed fibers or sites are added to the created Failure Set.

Note
If networks have dark fibers (which do not carry any traffic), that path is not considered for restoration.

Failure report
The failure report shows these parameters:

DescriptionReport

Shows the failed fibers in the network.Failed Fibers

Shows the failed sites in the network.Failed Sites

Shows the fibers that are impacted due to the site failure.Impacted Fibers

Shows the total number of media channels in the network.Total Channels
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DescriptionReport

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Failed Channels

Shows the total number of media channels that are restored from the failure state.Restored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Unrestored Channels

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

• Fiber: Shows the fibers that are listed under fiber hot zones.

• Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

• Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Fiber HotZones

Shows the total number of services going through the fiber that was failed.Total Services

Shows the number of failed services going through the fiber that was failed.Failed Services

Shows the number of restored services going through the fiber that was restored.Restored Services

Shows the number of unrestored services going through the fiber that was restored.Unrestored Services

Automatic suggestion for regeneration sites in Plan mode
Table 21: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP displays feasibility
report in the Plan mode. This report
automatically suggests regeneration
sites for the channels with high and
marginal risk of failure. You can
incorporate these regeneration sites
in the optical network to make the
channel optically feasible. This
feature avoids multiple iterations
required to manually create the
regeneration sites and test the
optical feasibility of large networks.

Cisco ONP Release 5.0Automatic Suggestion for
Regeneration Sites
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Optical network feasibility assessment

Cisco ONP identifies networks that are not optically feasible, focusing on channels with a high or marginal
risk of failure. These risks are highlighted in red and orange on the Optical Results page, indicating End of
Life (EOL) and Start of Life (SOL) issues.

Regeneration site suggestions

To address optical feasibility issues, the Path Computation Element (PCE) runs a regeneration suggestion
algorithm. This algorithm proposes potential regeneration sites.When entering plan mode, Cisco ONP presents
these suggested regeneration sites within the Feasibility Report, located at the bottom of the map. You can
apply these suggestions to enhance network feasibility.

For channels with pre-existing regeneration, the system provides suggestions at the section level.

The Feasibility Report table encompasses several fields, which are crucial for assessing the optical feasibility
of the network.

Table 22: Feasibility Report

DescriptionField

Displays the list of channels (trail and sections) that
are not optically feasible.

Channel Name

Displays the color of alarm (red, orange, or yellow)Alarm

Displays the actual path of the channel as hyperlink.
If you click the link, the path is highlighted in the
map.

Paths

Displays the intermediate sites that can be used as
regen sites so that the channel becomes optically
feasible.

Suggested Regens

Exporting the Feasibility Report

You have the option to export the Feasibility Report. Click Export.

The Suggested Regen field in the report may display as "NA" for the following reasons:

• Negligible Loss: Channels with yellow alarms indicate negligible loss, thus not requiring regeneration
suggestions.

• Insufficient Intermediate Sites:When high loss occurs and there are not enough intermediate sites available
to mitigate the overall loss.

• Lack of Contentionless Sides: Intermediate sites without added contentionless sides are not considered
viable for regeneration sites.

Support for various network configurations

Auto regeneration site suggestion functionality is available for both SSON and non-SSON networks that
includes contentionless channels or waves between NCS2K (ROADM) or 4K-1K-2K (TRAFFIC) sites.
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Apply the suggested regen sites
Use this task to apply the suggested regeneration sites to make the network optically feasible.

Before you begin

Log in to Cisco ONP web interface as a user with admin or planner role.

Procedure

Step 1 Open an analyzed network.
Step 2 Enter the plan mode.
Step 3 Apply the suggested regen sites to the network.

a) Choose Network > Open Feasibility Report.

The Feasibility Report is displayed at the bottom of the map.

b) Select the channels for which regeneration has to be applied and click Apply.
c) In the Suggested Regen Applied dialog box,click Ok .

Step 4 Exit the Plan mode.
a) Choose Network > Exit Plan Mode.
b) Click Yes in the Warning dialog box.

The network gets auto upgraded and saved as a new network. The channels with regens applied are unlocked with the
Regen Sites property auto updated and noneditable.

Step 5 Analyze the network.

In the Optical Results page, the SOL, and EOL fields become green, and the channels are not displayed in the feasibility
report again when you switch to the plan mode.

Line Rate Tuner Mode
Table 23: Feature History

Feature DescriptionRelease InformationFeature Name

You can now automate the calculation of optical
sources for your networks using the new Line Rate
Tuner Mode. This mode reduces human errors while
finding the correct optical source for your network
from a set of network resources.

Cisco ONP Release
5.2

Automated Selection of
Optimal Wavelength Bitrate:
Flexible Modelling

Line Rate Tuner Mode significantly reduces turnaround time, avoiding manual calculation of different
possibilities of network resources.
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Line Rate Tuner Mode is available for NCS 2000 and NCS 1010 networks.Note

Enter the Line Rate Tuner Mode
Use these steps to enter the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Open the network in Analyze mode.
Step 2 Choose Network > Enter Line Rate Tuner Mode.

Switching to line rate tuner mode.. progress bar appears.

The network opens in the Line Rate Tuner Mode.

Create a Custom Optical Source
Use this procedure to create a custom optical source.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Input.

Input Tuner pane appears below the map area.

Step 3 In the network tree, select the section of the media channel that you want to add the tuner input.

In Select Input Parameters, the selected section appears with default parameter values.

Step 4 Modify the following Input Parameters as required.

DescriptionPlatformProperty

Choose the optical family. Based on the analyzed network, Cisco ONP provides
the options. Based on the optical family chosen, the remaining parameters provide
related options.

NCS 2000
SSON

NCS 1010

Optical Family
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DescriptionPlatformProperty

Choose the optical source. Based on the optical sources that are already imported,
Cisco ONP provides the list of optical sources.

NCS 2000
SSON

NCS 1010

Optical Source

Choose the data rate. Based on the optical family chosen, Cisco ONP provides
options to choose the channel capacity for the new section.

NCS 2000
SSON

NCS 1010

Data Rate

Choose the bit data rate. Based on the optical family chosen, Cisco ONP provides
options to choose the speed of data transfer in the new section.

NCS 2000
SSON

NCS 1010

Bit Rate Range

Choose the baud rate range. Based on the optical family chosen, Cisco ONP provides
options to choose the minimum signal width for new each channel.

NCS 2000
SSON

NCS 1010

Baud Rate Range

Choose the FEC type. Based on the optical family chosen, Cisco ONP provides the
list of supported FEC types

NCS 2000
SSON

NCS 1010

FEC Type

Choose the Result Type. The available options are:

• Best OSNR—Provides results based on maximum OSNR margin.

• Maximum Capacity—Provides results based on the maximum capacity of the
channels.

NCS 2000
SSON

NCS 1010

Result Type

Choose optical feasibility for the new section. The available options are:

• Green

• Yellow

• Orange

• Red

Each color represents the severity of alarms that may arise in the new section.

NCS 2000
SSON

NCS 1010

Optical
Feasibility

Choose the sigma number from 0 to 3. The sigma number calculates the OSNR
margin.

NCS 2000
SSON

NCS 1010

Sigma Number

Choose the number of optical source results that you want for the new section.

The default value is set as 5. However, you can choose up to 15 results.

NCS 2000
SSON

NCS 1010

Number of
results

Step 5 (Optional) Click Reset to reset the modified parameters to default values.
Step 6 Click Add.
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In Select Section, Tuner Input is added successfully. Please refer the below table for the added inputs message appears.

The Select Section pane provides the details of the modified section.

Table 24: Select Section Parameters

DescriptionSection Parameters

Name of the modified section.Section Label

Site name for the optical channel source.Src Site

Site name for the optical channel destination.Dst Site

Fiber paths in the section.Path

Icons to edit or delete the modified section.Actions

Step 7 (Optional) To modify or delete the section, choose the following icons as required:
ActionsIcon

Edit Input—Modifies the sectionPencil

Delete Input—Deletes the sectionTrash Bin

To edit the modified section:

a. Click the pencil icon.

b. Modify the input parameters as required.

c. Click Update to update the edited section parameters.

To delete the modified section:

a. Click the trash bin icon.

A confirmation message appears.

b. Click Yes.

Step 8 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

Step 9 In Tuner Result, click Export to export the results as an Excel sheet.

Start the New Tuner Analysis
Use these steps to start a fresh tuner analysis for the new section.

Before you begin

Log in to Cisco ONP web interface
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Start New.

The Start New Tuner dialog box appears asking for a confirmation.

Step 3 (Optional) Check the Retain the tuner inputs check box to retain the previous input values.
Step 4 Click Yes.

The message Started new tuner successfully appears.

Step 5 Modify the input parameters of the new section.
Step 6 Click Update.
Step 7 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

Open the Custom Optical Source Tuner Result
Use these steps to open the tuner results for the customized optical sources.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears.

Add the Custom Optical Source to the Network
Use these steps to add the custom optical sources to the network.

Before you begin

Log in to Cisco ONP web interface
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears displaying the new sections and their demand channels.

The result provides the following action icons to add the optical sources to the network.

• Add Demand to Network—Click this icon to add the demand to the network.

• Download Optical Source—Click this icon to download the optical sources as an Excel sheet to review offline.

Step 3 To add the optical source to the network, perform one of the following actions:

To add manually:

Note
For some custom optical source results, the download icon becomes disabled. In that case, go to Manage > Optical
Source to download the optical result as explained in Download Optical Sources.

a. Click the download icon.

The Downloading Optical Source message appears. The Excel sheet contains data in Cisco ONP format.

b. Open the Excel sheet to review the data.

c. Import optical sources as explained in Import Optical Sources.

To add automatically:

a. Click the add icon.

The No. of demands pop-up appears asking for the number of demands to add to the network.

b. Enter the demands number and click Add.

The Demand is added successfully message appears.

The new demand appears in the network tree. Along with the demand, the Cisco ONP adds the required optical source
also automatically to the server.

Exit the Line Rate Tuner Mode
Use these steps to exit the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP web interface
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Choose Network > Exit Line Rate Tuner Mode.

The Exiting Tuner dialog box appears.

Step 3 Choose the following action as required.
ActionsButton

Moves the network to previous state with applied changes.Previous State

Moves the network to Upgrade mode with applied changes.Upgrade

Cancels the operation.Cancel

The network exits the Line Rate Tuner mode.

Create an Optical Source
Use this task to creat an optical source.

Before you begin

Procedure

Step 1 Choose Export > Optical Source Template.

The downloaded template has two sheets with information related to interfaces and their respective Optical Classes.

DescriptionSheets

contain the details specific to the interface only.Interface

contains the information that can be overlapped with multiple interfaces. In those cases, multiple interfaces
can be mapped to the same class.

Class

For the list of the required Optical Parameters, refer to Optical Parameters Available in the Excel Sheet for Optical Sources
Creation.

The dowloaded sheet has the data for one of the existing interfaces for reference. You can edit or delete the data from
the sheet.

Step 2 Fill all the required parameters from the specicification sheet.
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There are some hidden columns that are not mandatory for Optical Source Creation. But, you can expand those columns
and fill the details.

Step 3 After you have filled all the information, save the excel file with an optical source name.

What to do next

Go to Import Optical Sources to import the optical source from an Excel sheet.

Import Optical Sources
Table 25: Feature History

Feature DescriptionRelease InformationFeature Name

You can create an optical source by
defining the details of interfaces
and the corresponding optical
classes in an Excel template. This
feature provides you with the
flexibility to create any required
optical source based on existing or
new traffic resources.

Cisco ONP Release 5.0Create Optical Source using Excel
Sheet

Optical Source Wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Use this procedure to import an optical source:

Before you begin

Log in to Cisco ONP web interface.

If you want to import the optical sources from an Excel sheet, download the template by choosing Export >
Optical Source Template. Fill the necessary details in the Interfaces and Optical Classes sheets of the
downloaded template and save the file. See Optical Parameters Available in the Excel Sheet for Optical
Sources Creation, on page 50.

The fields in the columns D, E, and F that are not mandatory are hidden by default in the Interfaces sheet of
the template. You can expand the columns and fill the details.

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears. The default optical sources available in the server are:

• OpticalSources_NCS2K_400GXP-LC_NCS4K-4H-OPW-QC2

• NCS1004_OpticalSources_V3
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• ONS-CFP2D-400G-C-OpticalSources-V2.mxd

• QDD-400G-ZRP-S-OpticalSources-V2.mxd

Note
By default, all existing optical source files are loaded in the server.

Step 2 To import optical source as .mxd file:
a) Click Add.
b) Choose Optical Source (.mxd)

The Import Optical Source (.mxd) dialog box appears.

c) Click Choose File and browse to the .mxd file stored in your local system, and click Import.

After the optical source is imported, a list of related interfaces appears.

Step 3 To import the optical source from an Excel sheet:
a) Click Add.
b) Choose Optical Source (.xlsx)

The Import Optical Source (.xlsx) dialog box appears.

c) Click Choose File and browse to the .xls file (optical source template) saved in your local system, and click Import.
d) Choose the Release Version of the NSC2K network.

Note
Selected release version is applicable only for NCS2K network. For NCS 1010, NCS 1001, and NCS 1014 networks,
the imported optical source is available for all supported release versions irrespective of the selected NCS 2000 release
version.

e) Select the interface.

If you want all the interfances, then click Select All.

f) Click Create.

After the optical source is imported, a list of related interfaces appears.

Step 4 Choose the interfaces to import by checking the check box next to them. The selected interfaces get added to the Type
drop-down list in the properties window of the network tree.

When you create waves, you can use the interfaces in the Type drop-down list.

What to do next

Go to Download Optical Sources, on page 53 to download optical source for Cisco ONC.

Optical Parameters Available in the Excel Sheet for Optical Sources Creation

The following parameters are available in the Excel sheet template for creating optical sources.
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Table 26: Optical Parameters for Creating Optical Sources

DescriptionParameters

The name of the interface. It should be unique for all
the interfaces that are added in the file.

Interface Name

The name of the vendor.Vendor Name

The vendor IDs.Vendor IDs

The name of the platform.Platform

The PID of the pluggable.Pluggable PID

It is the combination of the Data Rate and Open
Config Code. For example: R400G#5000.

Name

The forward error correction type for the given
interface.

FEC

The line rate for the given interface.Data Rate

The modulation format to be used for the interface.Mod Format

The baud rate for the given interface.Baud rate

The speed of data transfer (bits per symbol) for the
given interface.

BPS

The unique code assigned to the interface as specified
by the Open Industry Standard for optical networks.
For example: 5000.

Open Config Code

Enter the sub-mode if there are any associated with
the interface. If not, leave it blank.

Sub Mode

The trunk rate of the transponder.Trunk Rate

The bit Rate for the interfaceNominal Bit Rate

The post FEC BER Target for the interfaceBER Target

The minimum and maximum Tx Power for the
interface.

Power Min and Power Max

The overload power limit for the interfaceOvl

The Rx power sensitivity for the interface.OL Power

The Rx OSNR sensitivity for the interface.OL OSNR

The extended Rx power sensitivity.PL Power

The Rx OSNR sensitivity at the extended Rx power
sensitivity.

PL OSNR
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DescriptionParameters

The variance in power in the Txp.Variance

The optical class to which the interface will be
mapped.

Opt Class

The Tx OSNR contribution due to laser instability
inside the Txp.

InBand OSNR

The Tx OSNR contribution due to Add/Drop at 80%
and 100% channel spectral density.

Out of Band OSNR

The Software release of Cisco ONC from which this
interface will be supported.

ONC Release

It is the same as the name of the interface.Interface Type

The operating frequency range of the interface.Min and Max Frequency

Table 27: Optical Class Parameters

DescriptionClass Parameters

The name of the interface. Enter the same name of
the interface, if you are doing one to one mapping
with the interface.

Interface Type

You can create the optical classes for different optical
sources. Certain optical parameters are added in the
optical class. Based on interface properties, multiple
interfaces can be mapped to the same class.

Enter a unique alphanumeric name for the Optical
class. While creating new optical classes, we
recommend using the name starting with “X” to avoid
overlapping in the existing classes.

Opt Class

The bit rate for the given interface.Bit Rate

The baud rate for the given interface.Baud Rate

The modulation guard band coefficient.ModGB Coeff

The modulation OSNR penalty.Modulation OSNR Penalty

The filtering GuardBand at different OSNR penalties.GBf

Enter the mux/demux filtering penalty value, if there
are any.

Mux/Demux Filtering Penalty

The chromatic dispersion limit at different OSNR
penalties.

Chromatic Dispersion
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Find Optical Sources Faster
Use these steps to find the optical sources faster.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Note
By default, all existing optical source files are loaded in the server.

Step 2 To find the customized optical sources:

a. Check Show only line rate tuner generated sources.

The dialog box displays only the customized optical sources.

Step 3 To filter the required optical source:

a. Enter the optical source name in the Search box.

The dialog box displays the optical sources matching the typed keyword.

Download Optical Sources
Use this procedure to download an optical source:

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to download.
Step 3 Click Download and select one of the following options to download the optical sources.

• .mxd—Downloads the selected optical sources as .mxd file.

• .xlsx—Downloads only the optical sources which were created and added using the Excel template, as .xls file.
Others such as the optical sources which were directly added as .mxd file, are not included in the .xsl file.
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• .xml—Downloads the optical source data as a .xml file. This file contains the application codes for circuit provisioning
in Cisco ONC, optical parameters of the interfaces, PIDs, and Vendor ID information. You can load the .xml file
into Cisco ONC to create circuits with these optical source interfaces. See Alien Import.

After the import is successful, the optical source will be present under the Application Code tab in the Service
Manager screen of the Cisco ONC application. See Service Manager.

Delete Optical Sources
Use this procedure to delete an optical source:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to delete.
Step 3 Click Delete to delete the selected optical sources.

Layout Template for NCS 2000 Network
Layout templates are reusable templates that are used to design layout configurations for the NCS 2000
network. When you have an NCS 2000 network with fixed layout rules applicable for multiple nodes, you
can use these templates to accurately set up the layout for those nodes. These templates save you time, effort,
and they minimize errors.

Layout template is not supported for a mix of TXP and Real card label of transponders.Note
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Export Layout Template
Table 28: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in CiscoONPRelease 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Cisco ONP Release 4.1Layout Template Enhancement

Use the following procedure to export the layout template of a specific site or all sites:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network whose network layout template you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Click the name of a site in the left side panel, for which you want to download the layout template.
Step 6 Hover the mouse pointer over the Export icon and click Layout Template for Current site or All Sites.

The Export Layout Template dialog box appears.

Step 7 Click Export.

Note
• We recommend that you export the layout template only in the analyze mode. Exporting layout templates in the
upgrade and release upgrade modes may be inaccurate.

• You can export the layout template for node of the type 4000 and 1000, but the exported layout template will contain
only the layout of NCS 2000 nodes. To export the layout template for the node type NCS4K-1K-2K and NCS1K-2K,
perform the following:

• Right click the site name in the Layout panel, and click Export.
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• Click OK to export the layout template in text format.

• The NCS 2000 layout template is in XML format.

Import Layout Template for NCS 2000 Network in to Cisco ONP Database
Use the following procedure to import a template for NCS 2000 Network into the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose Manage > Layout Templates.
Step 2 Click Add in the Manage Layout Template dialog box.
Step 3 Click Choose Files and select a template from your local system.
Step 4 Click Import.

The template is imported to the Cisco ONP database.

Download Layout Template for NCS 2000 Network
Use the following procedure to download a template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Download.

Save the template into your local system.
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Delete Layout Template for NCS 2000 Network
Use the following procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Delete to delete the template from the Cisco ONP database.

Apply NCS 2000 Layout Template into a Site
Use this task to apply the NCS 2000 Layout template into a site. The site can be NCS4K-2K, NCS1K-2K-4K,
or NCS1K-2K, but the template will be applied only to the NCS 2000 section of that site.

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network where you want to apply the layout template into an NCS 2000 site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 In the Entity Editor window, expand Sites and choose the site.
Step 5 In the right pane, choose the required template from the Layout Template drop-down list.

Note
Make sure that the other properties under Layout section such asChassis Type, Power Supply,Controller Card,Node
Protection, Redundant Controller Card, and MF-Unit are

set to Auto. Otherwise the Layout Template drop-down list remains disabled.
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Import NCS 1000 and NCS 4000 Layout Template into NCS1K-2K and
NCS4K-1K-2K Sites

Use this task to import NCS 1000 and NCS 4000 layout templates that were exported, into 4K-2K and
NCS4K-1K-2K Sites.

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network that has the site to which you want to apply the layout template.

The network opens.

Step 3 Click the Layout tab.
Step 4 Add the required NCS 4000 and/or NCS 1000 chassis, cards, and pluggables to the required slot of the added chassis.

See Edit the Layout Manually, on page 59

Step 5 Click Edit to enter the edit mode.
Step 6 Right click the name of a site on which you want to import the layout template, and click Import.
Step 7 Choose the layout template that you want to import into the site and click OK

The layout template gets applied to the site.

Note
When you modify an exported template, ensure to rename the modified template before reapplying it to a site in the
upgrade mode so that the changes in the template reflect in the layout view.

Layout Visualization
Table 29: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.

Cisco ONP Release 4.1Layout Visualization and Edit
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This feature allows you to visualize the layout of a network, designed using Cisco ONP. You can view the
arrangement of racks, chassis inside the racks and cards inserted in the chassis. When you click a particular
Rack or Chassis or Card in theLayout panel, the corresponding Rack or Chassis or Card gets highlighted in
the Layout image. You can zoom in and zoom out the Layout image.

View Network Layout
The procedure to view the network layout is as follows:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 In the Layout panel on the left side, click the site.

Note
The OLA sites are highlighted in green color, ROADM sites in blue color and Aggregated nodes in purple color.

Passthrough sites are not listed under layout.

For NCS 1010 network, Aggregated nodes are not available.

Step 6 Click any rack under a site to visualize the rack view of the network under Layout tab.
Step 7 Click any chassis under a rack to visualize the chassis view of the network.

Note
When you click the Aggregated node under Layout panel, NCS 1004, NCS 2000 and NCS 4000 series chassis are placed
in separate racks.

You can click the screenshot icon to take screenshot of all racks layout of the selected site.

Edit the Layout Manually
The Manual layout edit feature is used to adjust the position of NCS 4016 and NCS 1004 chassis and cards
in the layout.

The procedure to edit the layout manually is as follows:
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Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.

Choose the network where 4K-1K-2K and 1K-2K aggregated nodes are added. This feature is not supported on NCS
2000 node.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 Select the Chassis (4K-1K-2K and 1K-2K) or Card from a particular rack.
Step 7 Drag and drop the selected Chassis or Card from a particular rack to the empty slot in the same or different Chassis or

Rack.
Step 8 To add pluggables to a particular card, perform the following steps:

Note
Make sure to add the required cards.

a) Select the Rack.

The cards available in the Rack are displayed.

b) Select the card to which you want to add pluggables.

The ports available in the card are displayed.

c) Select the pluggable for each port.

The following pluggables are displayed:

Supported PluggablesCard

• ONS-QSFP8-LR4=

• QSFP-110G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-QC2

• ONS-QSFP8-LR4=

• QSFP-100G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-LO
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Supported PluggablesCard

• ONS-QSFP8-LR4=

• QSFP-100G-SR4=

• ONS-QSFP28-LR4-S=

• QSFP-100G-CWDM4-S=

• QSFP-100G-SM-SR=

NCS1K4-1.2T-K9=

d) Click the Tick icon.

Step 9 Click Done to save the changes in the Layout.

View the Layout Details Using Tooltip
You can hover over the Racks or Chassis or cards in the Rack and view the details using Tooltip. Click See
More Details to view the details of port no. type, pluggables and rates.

Copy the Configurations of a Particular Node to Another Node
The configuration can be copied from one node to another node only for the manual 4K-1K layout movement.
It is not supported for NCS1010 layout movement.

The procedure to copy the configurations of a particular node to another node of a different site is as follows:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Select the Rack, Chassis, or Card of a particular site.
Step 6 Select the site to where you want to copy the configurations to, from the Copy To drop-down list.
Step 7 Click New Rack to add a new rack. The configuration gets copied to the new rack.
Step 8 Click Done to save the changes in the Layout.
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Note
You can also cut, copy, and delete Racks, Chassis, and Cards in the Chassis from the Layout.

Export Port Usage of LNI Network
Table 30: Feature History

Feature DescriptionRelease InformationFeature Name

This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

• Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

• Port usage report based on
sites

• Port usage report only for LNI
imported networks

Cisco ONP Release 4.1Multi-Layer Connections Phase 1

Use the following procedure to export the port usage details of an LNI network:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the LNI network whose port usage you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
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Step 5 Click the name of a site in the left side panel,for which you want to download the port usage.
Step 6 Mouse hover the Export icon and click Port Usage for Current site or All Sites.

The Export Port dialog box appears.

Step 7 Click Continue.

The port usage details are exported in the Excel sheet format.

Note
• If you modify any services in the NCS 4000 node after upgrading the LNI network , the changes will not get updated
in the port usage details.

• The demand labels seen against the trunk ports of NCS4K-DWDM line card in the port mapping report are not
logically related to the NCS 4000 trunk ports, but are related to NCS 1004 client ports.

Define multilayer connections for SSON network
Table 31: Feature History

Feature DescriptionRelease InformationFeature Name

You can define Multilayer
Connections (MLC) such as cards
and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the Layout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Cisco ONP Release 4.2NCS4K-1K-2K Multilayer
Connection Trace

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Open a network:
a) Choose File > Open.
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b) In the Select Network To Open dialog box, click a network in which you want to define the multilayer connections.

Make sure that the network is in analyzed mode and 4K, 1K, and cards are defined in the network.

Step 2 Define the MLC:
a) Click the Layout tab.
b) In the left pane, click the MLC tab.

Alternatively, you can navigate to theMLC page by clicking theEllipsis icon available in the right side of the service
name in the network tree and clicking View in MLC

You can view a table describing the properties of the service, in the right pane. See MLC details, on page 65.

c) Click the service name to switch to the layout view.

You will view the layout and the service details in the right pane.

d) Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS
1K out, for both Source and Destination sites.

The details of the NCS 2000 chassis are auto-populated.

Note
For LNI imported network all the details are auto-populated. If you add any new service, you can change the details
of the new service as per your requirement.

e) Click the Tick icon to save the changes you have done.

You can click the refresh icon to delete the changes you made after saving.

The updated details are included in the BOM.

Step 3 If you want to export the MLC details perform these steps:
a) Click the Table icon to switch to the table view.
b) Choose Export > MLC Tracesto export all the details available in the MLC table.
c) Choose Export > LMP/TTI Connections to export the details of Link Management Protocol (LMP) connections

which are the connections between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTI) connections
which are the connections between NCS 4000 and NCS 1004 cards.

All these connections get added to the BOM.

Step 4 If you want to filter the services displayed in the left pane, click the Filter icon and choose one of these options:

• Source Site

• Destination Site

• Type of the traffic

• Trace Origin

• LNI: Imported through Import Live Network option

• User Created: Created through Cisco ONP UI

• Trace Status

• Completed: User has defined all MLC details.
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• Partial: User has defined only partial MLC details.

• Empty: User has not defined any MLC details.

Step 5 Click the three vertical dots and select the required options:

• Enable Multi Select: You can select up to the card level for different OTN.

• Expand All: Expands the services tree.

• Collapse All: Collapses the expanded services tree.

• Show Trace Status: Shows the trace status icon next to the service name.

Step 6 Click the three horizontal dots across the service trace and select the required options:

• Delete Trace: Deletes the respective trace.

• Locate in Map: Shows the service in the map view.

Note
You can enable the same port number on the primary and secondaryNCS4K IN nodes for Client 1+1 and other protection
scheme.

MLC details
This table describes various fields available in the MLC tab.

Table 32: MLC details

DescriptionProperties

Name of the serviceName

Name of the group to which the service belongs toGroup Name

Traffic typeType

Source siteSrc Site

Details of Rack/Slot/Card/Port in the input side of the
NCS 4000 chassis in the source site

Src NCS4K In

Details of Rack/Slot/Card/Port in the output side of
the NCS 4000 chassis in the source site

Src NCS4K Out

Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the source site

Src NCS1K In

Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the source site

Src NCS1K Out
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DescriptionProperties

Add/Drop multiplexer and demultiplexer connected
to the NCS 2000 chassis in the source site

Src NCS2K AddDrop

Media channel between the source and destination
sites

Src NCS2K MPO

Details of Rack/Slot/Card/Port in the input side of the
NCS 4000 chassis in the destination site

Dst NCS4K In

Details of Rack/Slot/Card/Port in the output side of
the NCS 4000 chassis in the destination site

Dst NCS4K Out

Details of Rack/Slot/Card/Port in the input side of the
NCS 1004 chassis in the destination site

Dst NCS1K In

Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the destination site

Dst NCS1K Out

Add/drop multiplexer and demultiplexer that is
connected to the NCS 2000 chassis in the destination
site

Dst NCS2K AddDrop

MPO cable connecting the NCS 2000 chassis in the
destination site

Dst NCS2K MPO

Media channel between the source and destination
sited

Media Channel

More notes, if anyNotes

Indicates whether the service connections are
user-created or imported through LNI.

Trace Origin
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Spectrum Utilization and Path Finder
Table 33: Feature History

Feature DescriptionRelease InformationFeature Name

The Spectrum Utilization and Path
Finder introduces the Minimal
Map, a streamlined network
visualization tool focusing on
essential data points like Sites and
Fibers, enhancing usability and
performance. General Settings
now allow individual
customization, including default
map views and spectrum utilization
colors. The Path Finder/Selector
enables interactive path selection
with options for manual and custom
path finding for multiple routing
options. The Spectrum Utilization
provides a comprehensive
visualization of used spectrum,
while the Spectrum Finder helps
locate and apply available spectrum
across fibers, offering dual-view
capabilities and multiple selection
methods. These enhancements
collectively improve network
management, planning, and
resource optimization.

Cisco ONP Release 24.3.1Spectrum Utilization and Path
Finder

Spectrum Utilization and Path Finder introduces

• Minimal Map: streamlines network visualization tool focusing Sites and Fibers.

• Path Finder/Selector: enables interactive path selection with options for manual and custom path finding.

• Spectrum Utilization: provides a comprehensive visualization of used spectrum.

• Spectrum Finder: helps to locate available spectrum across fibers and apply them on a Circuit or Media
Channel.

Find a Custom Path
The Custom Path Finder is accessible exclusively through the Minimal Map. When you choose the custom
path finder, the detailed map automatically switches to the Minimal Map.

Limitations
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• Applies to only Circuits (NCS1010/NCS1001),Waves (NCS2000NON-SSON),media channel (NCS2000
SSON).

The procedure to customize a fiber path on the map is as follows:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 In the network tree, select the section of the media channel/circuit that you want to add a new path.
Step 2 Click the Ellipses icon and select Custom Path Finder.

The Custom Path Finder for the selected section opens.

Step 3 In the Visualization area, choose the required map view.
ResultMap View

Shows a complete network map of the selected path with
other sites.

Complete Map

Shows only maps with chosen sites and fiber.Sub Map

Step 4 In the Options area, choose the required parameters to calculate the Path Finder.
DescriptionOption

Performs all the routing based on minimum number of hop
counts, irrespective of length of fibers

Minimum Hop

Performs all the routing based on fiber minimum length,
irrespective of hop count

Minimum Length

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Distinct Fiber Set

Calculates the number of paths based on the provided
number

Number of Path Count

Step 5 Click Calculate.

The list of paths calculated based on the chosen parameters displays.

The calculated paths table contains the path parameters.

Table 34: Path Parameters

DescriptionParameter

Displays the serial numberS.No

Displays fiber path direction based on chosen Options parametersPath
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DescriptionParameter

Filters the path based on fiber labelsFunnel icon

Provides the hop countHops

Provides the total length of the fiber pathTotal Length

Step 6 Click Export to export the chosen fiber path.
Step 7 In the Selected Service and Path area, check the service and path information and clickApply Path to apply the selected

path.

Select Path Manually
The Manual Path Selector is accessible exclusively through the Minimal Map. When you choose the manual
path selection, the detailed map automatically switches to the Minimal Map.

Limitations

• Available in Design and Upgrade modes where circuits path can be updated.

• Applies to only Circuits (NCS1010/NCS1001),Waves (NCS2000NON-SSON),media channel (NCS2000
SSON).

• Applies to regen circuits/waves/media channel.

• Additional options are applicable for Section under Network Tree.

The procedure to select a path manually on the map is as follows:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 In the network tree, select the section of the media channel that you want to add a new path.
Step 2 Click the Ellipses icon and select Manual Path Selection.
Step 3 In the Search field, enter the site or fiber to focus on it.
Step 4 Select the required the fibers to create a path.

The selected fibers appear on the Operation Modes pop-up pane under Fibers area.

Step 5 Click Apply.
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View Spectrum Utilization and Spectrum Finder
The Spectrum Finder is accessible exclusively through the Minimal Map. When you choose the spectrum
finder, the detailed map automatically switches to the Minimal Map.

We recommend that you use the Spectrum Finder for the network in Design/Upgrade/Release Upgrade Mode
and view the Spectrum Utilization in Analyze Mode.

The procedure to view the spectrum utilization and find a spectrum to apply for a service is as follows:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 In the network tree, select the section of the media channel that you want to learn the spectrum utilization per fiber.
Step 2 Click the Ellipses icon and select Spectrum Finder.

The Spectrum Finder for the selected section opens.

Step 3 In the Selected Fibers area, click +Add Fiber and choose the required fibers from the drop-down list.
Step 4 In the Visualization area, choose the required map view.

ResultMap View

Shows a complete network map of the selected path with
other sites.

Complete Map

Shows only maps with chosen sites and fiber.Sub Map

Step 5 In the Spectrum Finder area, modify the parameters as required..
DescriptionOption

Similar to Spectrum Utilization ViewTabular View

Displays multiple fibers in a vertical orientation (Y-Axis)
and the spectrum on the horizontal axis (X-Axis).

Detailed View

Enable Spectrum Selection to modify the subsequent
parameters.

Spectrum Selection

Enter the bandwidth (GHz) that is required for the network
circuit.

Spacing

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Distinct Fiber Set

Calculates the number of paths based on the number
provided

Number of Path Count

Allows you to select overlapping wavelengths with selected
fibers, when enabled.

Allow Overlap
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DescriptionOption

Zooms in and out of detailed view to granular view. Click
Default reset zoom.

Zoom

Displays the labels. Enable to view the labels. You can also
view the labels of existing occupied circuits.

View Labels

Shows the start, end, and central wavelengths (THz) of the
hovered spectrum when moving across the view

Hovered Spectrum

Shows the start, end, and central wavelengths (THz) of the
selected spectrum when selecting across the view.

Selected Spectrum

Toggle to view the C-band spectrum usage.C-Band

Toggle to view the L-band spectrum usage.L-Band

Displays the frequency utilzed in a fiber for each span in
continuation in a vertical axis. Each square block is

Fiber Utilization Graph

3.125GHz. The frequency range starts from the left and
continues towards the right, increasing 3.125GHz per block
for both C- and L-band.

For C-band, the first row has the starting frequency as
191.325 THz. A single row contains 53 blocks, totalling
0.165625 THz ( 53*3.125 GHz). The starting frequency of
subsequent rows increment at 0.165625 GHz.

Color tone of the blocks varies in the Fiber Utilization Graph

Indicates overlap of same spectrum across multiple waves.Dark
red

Indicates less spectrum usage.Light
red

Step 6 In theApply Properties to Existing Service area, check the service parameters and clickApply Wavelength andApply
Path.

Click Apply Wavelength and Apply Path to revert the changes.

Step 7 Select Apply to Service.

Regenerate BoM Automatically
You can view the new Chassis or Card added to the existing layout under the BOM tab. You can also view
the regenerated BoM after manual editing of the layout.
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Add new Pluggables, Alarm Cables and 100G Client Bandwidth
Licenses to BoM

You can add new pluggables, alarm cables and 100G bandwidth licenses of NCS 1004 and NCS 4000 platforms
to the existing BoM.

The procedure to add new pluggables, alarm cables and 100G client bandwidth licenses to the existing BoM
is as follows.

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 Choose File > Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the BOM tab.
Step 5 Click Add.

The New window opens.

Step 6 Enter the Cisco part number of the pluggable or alarm cable or 100G bandwidth license in the Cisco Part Number field.
Step 7 Choose the Quantity of pluggables or alarm cables or 100G bandwidth licenses to be added.
Step 8 Click Add.

The new pluggables or alarm cables or 100G bandwidth licenses are added to the BoM list.

Export IPC Report
You can export the connections of a current site or all sites to an Excel sheet using the following procedure:

Before you begin

Log in to Cisco ONP web interface
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Procedure

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
The network must be successfully analyzed to proceed further.

Step 4 Click the Layout > IPC tabs.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

The patches that you click are highlighted in the rack.

Step 5 Hover over the Export icon, and click Current site or All Sites option.

The Export IPC dialog box appears.

Step 6 Click Continue to export the connections of the current site or all sites.

The cable-type and Cable ID are included in the report only for the NCS 1010 network.

Edit the Layout Manually for NCS 1010 Networks
Table 35: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco has introduced NCS 1010 as
a new optical line system to meet
the growing optical network needs.
Using CiscoONP you can visualize
and edit layouts for NCS 1010
chassis and patch panels.

Cisco ONP Release 5.0Layout Edit Support for NCS 1010
Networks

The Manual layout edit feature is used to adjust the position of the NCS 1010 chassis and patch panels in the
layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP web interface.
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Procedure

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Note
You can also create a new NCS 1010 network. For more information, see Manually design a network using Cisco ONP,
on page 2.

Step 2 Click the network to open from the list of available networks.

Choose the NCS 1010 network.

Step 3 Choose Network > Analyze.

Note
The network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 In the left panel, click a site.
Step 7 Select a unit (NCS 1010 chassis or patch panel) using one of the following methods:

• In the left panel, expand the rack under a site and choose a unit.

• Or, in the Rack view, click a chassis or patch panel.

Step 8 To adjust the position of the selected units, use one of the following methods:

Note
If necessary, click the +New Rack button to create more racks.

• In the Rack view, drag and drop the selected chassis or panel from a particular rack to the empty slot in the same
or different rack.

• Swap units in the Rack view:

• Click a transponder or NCS1K14-CCMD-16 card.

The Swap with button appears.

• Click Swap with and select a slot to swap from the drop-down list.

Note
The Swap with button appears only for NCS 1014 and NCS 1020 chassis.

• Cut and Paste unit in the left panel:

• Click Cut above the Rack view.

• Right-click on an empty slot in the same or different rack and click Paste.

Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.
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Cisco ONP disables the Cut option if an existing cut unit is not pasted.

• Cut and Paste unit in the Rack view:

• Right-click the selected chassis or panel and click Cut.

• Right-click on an empty slot in the same or different rack and click Paste.

Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

• Move the unit in the left panel:

• Go to Move to > Site-X > Rack-X above the Rack view to move the chassis to the same or different rack.
Or go to Move to > Site-X > + New rack above the Rack view to move the chassis to a new rack.

• Move the unit in the Rack view:

• Right-click the selected chassis or panel and go to Move to > Site-X > Rack-X to move the chassis to the
same or different rack. Or go to Move to > Site-X > + New rack to move the chassis to a new rack.

Note
The Move to option moves the unit automatically to the immediate empty slot. The Cut and Paste option moves the
unit to the selected empty slot.

Step 9 Click Done to save the changes in the Layout.

A warning message appears when empty racks are present in the layout.

Step 10 Click OK to remove the empty racks.

View Internal Node Connections of NCS 1010 Network
Table 36: Feature History

Feature DescriptionRelease InformationFeature Name

The Node diagram tab displays a
functional view that includes
precise connections and port
labeling of each component such
as OLT or ILA,
NCS1K-BRK-8/16/24,
AAWG-32-O, and AAWG-32-E,
for each site in an analyzed NCS
1010 network.

Cisco ONP Release 5.0View Internal Node Connections
of NCS 1010 Network

Before you begin

Log in to Cisco ONP web interface.
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Procedure

Step 1 ChooseFileOpen.

The Select Network To Open dialog box appears.

Step 2 Click the analyzed NCS 1010 network.

The network opens.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout > Node Diagram tabs.
Step 5 Click each site in the left panel and select a side to view the functional view of the site.

The functional view includes both the combination of physical and logical connections such as:

• Degree interconnections between NCS1010 (OLT or ILA) and NCS1K-BRK-8

• Add/drop connections between NCS1010 and colorless add/drop units (NCS1K-BRK-8, NCS1K-BRK-16, or
NCS1K-BRK-24) and colored add/drop units (AAWG-32-O or AAWG-32-E)

Step 6 Hover over the cable to view the details such as name of the ports that are connected and the cable ID.

Designing networks with COSM card
The COSM card, along with application software, provides functionality-based licenses for features such as
alarm correlation, performance monitoring, connection verification, and Optical Time Domain Reflectometry
(OTDR). You can design networks with ROADM and TRAFFIC nodes equipped with COSM cards.

From Release 25.1.1, SVO card is referred as COSM card.

Features of the COSM card:

• The COSM card occupies two slots.

• It serves as the primary card for all networks starting from Release 12.1.0.

• For high availability, a node can be equipped with two COSM cards, but they cannot be in the same
chassis.

• Two 10G SFP+ pluggables can be used to connect two COSM cards within a node.

• You can connect a Cisco ASR 920 Switch to the COSM cards during network design.

• The COSM can function as either a card or a UCS-based solution.

Design and Analyze Networks
76

Design and Analyze Networks
Designing networks with COSM card



COSM Licenses:

From 25.1.1, one COSM license PID OAS-COSM-MLCL is added for each active card present in the chassis
like M15, M6, M2, 1010, 1020, 1014, and 1004.

SVO Licenses

SVO licenses are applicable for NCS 2000 networks until Release 12.3.1.

• SVO cards require either a Base License or an SVO Full License (which covers High Availability,
Connection Verification, and Flex Spectrum). If the SVO Full License is not selected, the SVO Base
License and High Availability are enabled by default.

• Types of SVO licenses include:

• Cisco NMS: Features High Availability, Connection Verification, Flex Spectrum, and OTDR.

• Third-Party NMS: Includes NBI (North Bound Interface), Alarm Correlation, Performance
Monitoring, and Circuit Provisioning.

Chassis Licensing:

• Every chassis added to the networkmust be licensed fromRelease 12.1.0 onwards. For networks upgraded
to Cisco ONP Release 4.0 or higher, a new chassis license is required after analysis.

• Chassis licenses come in variants such as 1-chassis, 5-chassis, 10-chassis, 20-chassis, 50-chassis, and so
on, chosen based on cost optimization.

• A license is required for each chassis added to the network beyond the first.

• Chassis License Flush Out: Existing chassis licenses can be flushed out and replaced with new ones. The
current license remains active if the site is unlocked, but flush-out is only supported in network upgrade
mode.

• You can continue using existing licenses with changes to the chassis unless you opt for the Chassis
License Flush Out option.

Chassis Licensing and SVO Licenses are applicable until Release 12.3.1.Note

Design and Analyze Networks
77

Design and Analyze Networks
Designing networks with COSM card



Cisco Optical Site Manager associations
Table 37: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP has been enhanced to support COSM
line card connectivity from ROADM nodes to
various site types. A ROADM node equipped with
a COSM card can now manage upto 14 additional
OLA and ROADM nodes. Previously, this was
limited to OLA-to-ROADMassociations. The node
with the COSM card acts as the primary node.

The new COSM High Availability options
available under the Site properties, such as Auto,
Local HA,None,Only Active, andGeo HA enable
more dynamic and rule-based association in the NCS
2000 network.

Cisco ONP Release 25.1.1Cisco Optical Site
Manager enhancements

From Release 25.1.1, Cisco ONP has been enhanced to support COSM line card connectivity from ROADM
or Traffic nodes to various site types. A ROADM or Traffic node equipped with a COSM card can now
manage upto 14 additional OLA, Traffic, and ROADMnodes. Previously, this was limited to OLA-to-ROADM
and Traffic-to-OLA associations. The node with the COSM card acts as the primary node.

This connectivity enhancement can be implemented in three ways:

1. Automatic COSM associations: Cisco ONP automatically selects a primary node if the fiber property
DCN Extension is enabled or if the node has the highest number of degrees. Up to 15 nodes can be
associated with a single primary node. If there are more than 15 nodes in the network, Cisco ONP will
identify another primary node.

2. Manual association in Network Tree and Map: You can manually associate nodes within the network
tree and map. See Associate sites with COSM cards, on page 79

3. Association through COSM High Availability property: The association options are available under
the High Availability drop-down list, applicable to both SSON and non-SSON NCS 2000 networks. The
options include:

• Auto: Based on analysis and default behavior.

• Local HA: Both active and standby COSM cards are placed on the same node.

• None: No COSM card present.

• Only Active: No High Availability. Only Primary COSM card is added.

• Geo HA: COSM cards are placed in two different sites located at different geographical locations,
but adjacent to each other.

The Geo HA feature offers two selectable values: Primary and Secondary. These rules and behaviors apply:

Rules and Behavior:
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1. Primary HA check box:

• Selecting this check box designates a site as the Primary.

• Adjacent sites will automatically be considered as Secondary.

2. Auto re-assignment:

• If a Primary node selects a different node as its new Secondary, the previous association is
automatically removed.

Associate sites with COSM cards
Use this task to associate OLA and ROADM sites with the COSM cards:

Before you begin

Log in to Cisco ONP web interface.

Procedure

Step 1 In the network tree panel, click the Ellipsis icon available in the right side of any ROADM or Traffic site with COSM
card.

Step 2 Click Edit COSM Associations.
Step 3 Select thesites on the map to toggle the COSM connections. Click Done at the top-right corner to confirm the selection.

You can associate up to 14 nodes with a single ROADM or Traffic node equipped with an COSM card. To associate
more than 14 nodes, you will need an additional primary node to manage the extra nodes. You can open widgets in the
map and select top section to view the association.

Note
You can also right-click any ROADM or Traffic site from the Map and click Edit COSM Associations. For the sites
that are of DGE type, the Edit COSM Associations option is not displayed.

The tool associates the sites that are not associated by you, with the COSM card during the network analysis.

Export Device NETCONF XML File
You can export the NETCONF (Network Configuration Protocol) XML files for all the individual sites in a
network or the complete network. The following procedure shows how to export NETCONF XML files for
the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP web interface.
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Table 38: Feature History

Feature DescriptionRelease InformationFeature Name

TheNETCONFXML file exported
for the analysedNCS 1010 network
designwithMicrosoft configuration
now includes a new parameter.

• OTDR-ScanMode-Expert

If you enable the Enable Special
Settings check box under Network
level properties, the generated
XML file contains the
OTDR-ScanMode-Expert is set to
multi-region when the when
Microsoft Configuration is enabled.

If you do not enable the Enable
Special Settingscheck box, then
scan mode config is not added to
device Netconf XML.

Cisco ONP Release 25.1.1ALC2 Enhancements

Table 39: Feature History

Feature DescriptionRelease InformationFeature Name

TheNETCONFXML file exported
from the NCS 1010 network design
now includes these new parameters
to support seamless Day-0
provisioning and the setup of a new
node added to the network.

• Optical cross-connects

• Gain range margin

• Tone Rates

• Raman tuning configurations

• Slot reserve

• Dmux WSS attenuation

• Unused CCMD-16 ports
shutdown

• Span baseline-deviation

• OTDR Thresholds

• APC Span-loss correction
threshold

Cisco ONP Release 24.3.1New Parameters Included in NCS
1010 NETCONF XML file
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Table 40: Feature History

Feature DescriptionRelease InformationFeature Name

You can export the NETCONF
XML files for all the NCS 1010
nodes, and upload them to the NCS
1010 nodes through the Yang suite.
This enables automatic bring up of
the NCS 1010 nodes using the
NETCONF data.

Cisco ONP Release 5.0Export NETCONF File from NCS
1010 network

The network must be in Analyze mode.

Procedure

Step 1 In the network tree panel, click the three dots.

A pop-up list appears.

Step 2 In the list, click Generate Device NetConf XML.

Export window appears with network name.

Step 3 Click Export.
The message, "Success. Device NetConf exported successfully" appears.

You can download the zip file that contains NETCONF XML files of individual sites.

Note
You can choose the destination folder to save the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Note
For C+LNetwork, the partner band configurations are not part of the Cisco ONP-generated XML file. Youmust manually
configure the partner bands on the devices while bringing up the NCS 1010 C+L network.

From Release 24.3.1, the following new parameters are available in the NETCONF file exported from the NCS 1010
network design:

• OSC TX Power

• Optical Cross Connect

• OTS tone rate

• OMS tone rate

• OTS tone pattern expected

• OTS tone detect OOB

• OTS tone pattern

• OTS tone frequency

Design and Analyze Networks
81

Design and Analyze Networks
Export Device NETCONF XML File



• Raman pump configurations

• Line port attenuation

• Raman dual safety

The following parameters are available only when you have enabled the Enable Special Settings check box under
Network level properties.

• Raman turnup

• OTS ports shutdown

• OTDR autoscan

• Gain range margin

• OTDR excess attenuation threshold

• OTDR end of fiber threshold

• Slot reserve

• Dmux WSS attenuation

• Unused CCMD-16 ports shutdown

• Span baseline-deviation

• OTDR Thresholds

• APC Span-loss correction threshold

• OTDR-ScanMode-Expert

Upload NETCONF XML Files on COSM Web Interface
The following procedure shows how to upload the NETCONF XML files on the COSM web interface:

Procedure

Step 1 In the browser URL field, enter the IP address of the COSM line card.

The login page appears.

Step 2 Enter the username and password.
Step 3 Click Login.
Step 4 Click the hamburger icon at the top-left of the page, and select Node Configuration.
Step 5 Click the Node Setup tab.
Step 6 Click Select files .
Step 7 Browse to the NETCONF XML files exported from the Cisco ONP GUI and upload them.
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If the passive unit ID in the NETCONF file exceeds the range 1–126, COSM displays an error message. Validate the
XML file and reimport.

Note
If the value of FEC mode already provisioned in the 200G-CK-C line card does not match with the value available in the
NETCONF XML file, COSM displays an error message. We recommend that you remove the provisioned FEC settings
for this card and reimport the XML file.

Export Device NETCONF XML Files for Individual Sites
The following procedure shows how to export Device NETCONF XML files for individual sites from the
Cisco ONP GUI.

Before you begin

Log in to Cisco ONP web interface.

The network must be in Analyze mode.

Procedure

Step 1 Click the Ellipsis icon available in the right side of the site.
Step 2 In the list, click Generate Device NetConf XML.

Export window appears with network name.

Step 3 Click Export.
The message, "Success. Device NetConf exported successfully" appears.

You can download the zip file that contains Device NETCONF XML files of individual sites.

Upload NETCONF Files to NCS 1010 Device
Use this task to upload the NETCONF files that downloaded from Cisco ONP into the NCS 1010 device using
a NETCONF client.

Procedure

Step 1 Log in to the NETCONF Yang Suite which has access to the NCS 1010 device.
Step 2 Connect to the NCS 1010 device.
Step 3 Copy the NETCONF XML file content that is downloaded from Cisco ONP, and paste it into the Protocol NETCONF

Run RPC block.

Design and Analyze Networks
83

Design and Analyze Networks
Export Device NETCONF XML Files for Individual Sites

b-conp-25-xx-config-guide_chapter1.pdf#nameddest=unique_12


Step 4 Append the following commit code at the end of the NETCONF XML file content.
<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="102">
<commit/>
</rpc>

Export Cisco Optical Site Manager NETCONF XML File
You can export the Cisco Optical Site Manager NETCONF XML files for all the individual sites in a network
or the complete network. The following procedure shows how to export CiscoOptical SiteManager NETCONF
XML files for the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP web interface.

Table 41: Feature History

Feature DescriptionRelease InformationFeature Name

The new Generate COSM
NetConf XML option allows you
to export from the Cisco Optical
Network Planner, the Cisco Optical
Site Manager NETCONF XML
files for all the NCS 1010 nodes.
You can then upload these files to
the NCS 1010 nodes through the
Cisco Optical Site Manager,
enabling automatic bring-up of the
NCS 1010 nodes.

Cisco ONP Release 5.2Export Cisco Optical SiteManager
(COSM) NETCONF File from
NCS 1010 network

The network must be in Analyze mode.

Procedure

Step 1 In the network tree panel, click the three dots.

A pop-up list appears.

Step 2 In the list, click Generate COSM NetConf XML.

Export window appears with network name.

Step 3 Click Export.
The message, "Success. COSM NetConf exported successfully" appears.

You can download the zip file that contains COSM NETCONF XML files of individual sites.

Note
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You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files of
individual sites.

This feature has limited scope in this release.

Note
• For the ROADM OLT node, the device name is generated in the Site Name-Side Name format.

• For the OLA node, the device name is same as the Site Name.

Align the device name in COSM accordingly.

If the Site Name contains any special character, the XML file replaces the special charcter with its ASCII value in the
COSM XML device name to allow seamless experience with COSM data backup workflow.

Note
L-Band Configuration is not certified in Cisco Optical Site Manager for R7.11.1. A future release will be considered for
the L-Band configuration.

Upload Cisco Optical Site Manager NETCONF XML to NCS 1010
Device via Cisco Optical Site Manager Web Interface

Use this task to upload the Cisco Optical Site Manager NETCONF files that you downloaded from Cisco
ONP into the NCS 1010 device using the Cisco Optical Site Manager web interface.

Before you begin

Log in to Cisco ONP web interface

Procedure

Step 1 Log in to the Cisco Optical Site Manager UI that has access to the NCS 1010 device.
Step 2 Cross-check the device name, UID, and card layout position (Rack ID, RU Position) with CONP XML.

The Cisco Optical Site Manager device name and UID should match with the CONP XML. If any mismatch exists,
delete the device from Cisco Optical Site Manager and add back with name and UID as in the CONP XML.

Step 3 Go to Optical Setup and browse the CONP-generated XML without OXC for that device and load it.
Step 4 Click the Select files... button.

The file explorer window appears.

Step 5 Select the CONP-generated Cisco Optical Site Manager XML from your local device.
Step 6 Click Open.

A confirmation message appears.

Step 7 Click Yes.
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Step 8 Click Upload.

The COSM XML successfully uploaded message appears.

Step 9 Go to Optical Configuration > ANS parameter and verify whether the respective configurations are complete.
Step 10 After loading the Cisco Optical Site Manager XML file without optical cross connect, load the Cisco Optical Site

Manager XML with optical cross connect.
Step 11 After adding the Cisco Optical Site Manager XML file with optical cross connect, go to theOptical Cross Connections

tab and verify whether the respective configurations are complete.

Export NCS 1010 network planning data for Cisco Optical
Network Controller

Table 42: Feature History

Feature DescriptionRelease InformationFeature Name

You can export the planning data
of NCS 1010 network, in the form
of a JSON file. This JSON file can
be uploaded into Cisco ONC to
configure the managed devices in
bulk.

Cisco ONP Release 5.0Export NCS 1010 Network
Planning Data for Cisco Optical
Network Controller (Cisco ONC)

Use this task to export the planning data of NCS 1010 network, which is in the form of JSON file from Cisco
ONP. This JSON file is uploaded into Cisco ONC to configure the managed devices.

You can export the planning data of NCS 1010 network only for the releases 7.7.1 and 7.9.1.

Before you begin

Log in to Cisco ONP web interface.

The network must be in Analyze mode.

Procedure

Step 1 In the network tree panel, click the Ellipsis icon available in the right side of the network name, and select Generate
CONC JSON .

Step 2 In the Export File dialog box, enter the name of the JSON file, and click Export to download the JSON file into your
local system.

Design and Analyze Networks
86

Design and Analyze Networks
Export NCS 1010 network planning data for Cisco Optical Network Controller

b-conp-25-xx-config-guide_chapter1.pdf#nameddest=unique_12


Upload Planning Data into Cisco ONC
Use this task to upload the network planning data (JSON file) downloaded from the Cisco ONP.

Procedure

Step 1 Log into Cisco ONC.
Step 2 Hover over the Import icon in the left panel and click Planning Data Import.
Step 3 Click Import.
Step 4 Browse and select the JSON file that is downloaded from Cisco ONP.

You can use the planning data to configure the devices managed by Cisco ONC.
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