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CHAPTER 1

Get Started with Cisco Optical Network Planner

* Cisco Optical Network Planner, on page |

* Supported platforms, on page 2

* Supported topologies , on page 3

* Supported protection schemes , on page 4

* Supported services, on page 5

* Supported DWDM channel interfaces, on page 6
* Supported fiber types, on page 6

* Register a new user, on page 7

* Log in to Cisco ONP web interface, on page 7

* Cisco ONP home page, on page 8

» Change Password , on page 8

* Reset your password, on page 9

» Sign out from Cisco ONP, on page 9

* Cisco Secure Development Lifecycle compliance, on page 9

Cisco Optical Network Planner

Introduction to Cisco Optical Network Planner

Cisco Optical Network Planner (Cisco ONP) is a web application designed to model and test Optical Transport
Networks (OTN) and Dense Wavelength Division Multiplexing (DWDM) optical networks using a graphical
environment.

Purpose of Cisco ONP

The primary purpose of Cisco ONP is to design and validate networks for the NCS 1001, NCS 1004, NCS
1010, NCS 2000, and NCS 4000 series.

Network design and comparison

With Cisco ONP, users can create multiple instances of a network, modify various parameters for each instance,
and perform comparisons. The tool generates a rack view of all the sites deployed in the network, highlights
the differences between instances, and provides a complete Bill of Materials (BoM).
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. Supported platforms

Detailed network information

Get Started with Cisco Optical Network Planner |

Cisco ONP not only models the network and generates the BoM but also offers detailed information about
the network. This includes reports such as the Cabling report, Optical report, Device Configuration file, and

Traffic matrix.

Features and compliance

This chapter outlines the features of Cisco ONP, including protection scenarios, topology and service support,
and compliance with the Cisco Secure Development Lifecycle (CSDL). It also covers setting up the graphical

display.

Additional resources

For more detailed information about Cisco ONP, please refer to the data sheet.

Supported platforms

Table 1: Feature History

Feature Name

Release Information

Feature Description

Support for NCS 1001 Network
Creation

Cisco ONP Release 24.3.1

This release supports the design of
C-band NCS 1001 networks. The
NCS 1001 is a 1RU, DWDM line
system optimized for data center
environments. It includes support
for amplifiers, PSM modules, and
various colored add/drop modules
such as MD-32-EVEN, FLD-4,
MD-48-ODD, MD-48-EVEN, and
MD-64.

Cisco ONP supports unprotected,
terminal section, and terminal path
protection over the NCS 1001
network. Also, the NCS 1001
network is compatible with optical
sources such as NCS 1004, CIMS,
Bright ZR, QDD, and CFP2.
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Feature Name Release Information Feature Description
Addition of new NCS 1020 Chassis | Cisco ONP Release 24.3.1 NCS 1020 is a 10RU optical line
for NCS 1010 Networks system that supports the OLTs and

NCS1K14-CCMD-16-C card in the
NCS 1010 networks. The NCS
1020 chassis optimizes the NCS
1010 networks design, extending
the reach of NCS 1010 networks.
With OLTs and
NCS1K14-CCMD-16-C, the NCS
1020 chassis provides a wide range
of configuration options to NCS
1010 networks.

Cisco ONP supports these platforms:

Table 2: Supported platforms and releases

Platforms Recommended and Supported Releases
NCS 1001 7.10.1

NCS 1014 25.1.1

NCS 1010 7.7.1,79.1,7.10.1,7.11.1,24.3.1, 25.1.1
NCS 2000 11.0.0, 11.1.0, 12.1.0, 12.2.0, 12.3.1, 25.1.1
NCS 4000 6.5.33

Supported topologies

Cisco ONP supports several network topologies, each offering different configurations and benefits:

Linear topology

In a linear topology, the nodes are arranged in a line and are connected to two adjacent nodes. However, the
first and last nodes are not connected to each other.

Mesh topology

In a mesh topology, each node is connected to one or more nodes. This configuration provides maximum
redundancy to the network.

Ring topology

In a ring topology, each node is connected to exactly two other nodes, forming a circular configuration. It
requires at least three nodes to form a ring.
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. Supported protection schemes

Supported protection schemes

Table 3: Feature History

Feature Name Release Information Feature Description

Protection Types Supported Cisco ONP Release 4.1 The following protection schemes
are supported:

* I+R: For each service, Cisco
ONP automatically finds one
working path. You can define
the restoration path.

e 1+1+R: For each service,
Cisco ONP finds one working
path, and one protected path.
You can define the restoration
path.

e 1+1+R+R: For each service,
Cisco ONP finds one working
path and one protected path.
You can define the restoration
paths.

Cisco ONP offers a variety of protection schemes to enhance network reliability and resilience:

Figure 1: Protection schemes

Unprotected 1+1 S+ NS B
Shortest path routed Node and span disjoint Span but not node disjoint | &
——  Working path

——  Protect path

Unprotected

In unprotected mode, the tool routes the service on the shortest path without any backup.

1+1

In this scheme, two client signals are transmitted to separate line cards or transponder cards, rather than using
a Y-cable to split one client signal into two. Client 1+1 protection allows the client system to control failure
and switchover.
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Figure 2: 1+1 protection
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W - Working (active)
P - Protect (standby)

1+R

Supported on SSON networks, this scheme allows Cisco ONP to automatically find one working path for
each service. Users can define the restoration path.

1+1+R

Also supported on SSON networks, this scheme involves Cisco ONP finding one working path and one
protected path for each service. Users can define the restoration path.

1+1+R+R

Supported on SSON networks, this scheme involves Cisco ONP finding one working path and one protected
path, with the option for users to define additional restoration paths.

S+NS

Supported on both SSON and non-SSON NCS 4000-NCS 2000 network, Cisco ONP uses the shortest path
for the working service and the next shortest path for protection. The paths are span-disjointed but not node
disjointed.

Unprotected disjoint

Supported on both SSON and non-SSON NCS 4000-NCS 2000 network, this scheme provides two cards
following two completely disjoint paths in the network to reach their destination.

PSM-Channel protection
This protection scheme is supported on NCS 2000 non-SSON networks.

Supported services

Cisco ONP supports these OTN demands:
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. Supported DWDM channel interfaces

+ ODU-1,0DU-2,0DU-3,0DU-4

* GE — Gigabit Ethernet

* 10GE - 10-Gigabit Ethernet

* 100GE —100-Gigabit Ethernet

* 400GE —400-Gigabit Ethernet
The 400GE service is supported on the NCS 1010 networks.

» STS-3

» STS-12

+ STS-48

+ STS-192

* VC-4-4

* VC-4-16

* VC-4-64

* STM-64

Supported DWDM channel interfaces

For detailed information on the DWDM channel interfaces supported by Cisco ONP, refer toSupported Cards
and Pluggables, on page 293 and Supported Optical Sources, on page 307.

Supported fiber types
Cisco ONP supports these fiber types:

» G652-SMF
* G652-SMF-28E
* True Wave Reach
* True Wave RS
* True-Wave Plus
* True-Wave Minus
* True-Wave Classic
* Free-Light
* Tera-Light

* Metro-Core
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Register a new user .

* ELEAF

* NDSF (only NCS 1010)

* ALLWave (only NCS 1010)

* SMF-28 ULL (only NCS 1010)
* SMF28-Ultra (only NCS 1010)

Register a new user

Procedure

Step 1
Step 2
Step 3
Step 4

Step 5

Use this task to register yourself as a user.

In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Click Sign Up in the Login page.
Enter the Username, Email, Passwor d, and Confirm Passwor d, and click Submit.

If you want a system-generated password, click Generate, and click Submit. The generated password is autopopulated
in the Password, and Confirm Password fields.

Click Ok in the Success dialog box.

Log in to Cisco ONP web interface

Procedure

Step 1

Step 2

Use this task to log into the Cisco ONP web interface.

In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
If you are a new user, sign up. See Register a new user, on page 7, for more information.

Note
If the Google Chrome browser blocks your access to Cisco ONP due to self-signed certificate security, type thisisunsafe
to proceed to the Login page.

Enter the username and password in the Username and Passwor d text boxes, and click L ogin.
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Cisco ONP home page

After logging in, the Cisco ONP home page displays several key elements that help users navigate and utilize
the tool effectively:

Menu bar

The menu bar includes various menus such as File, Network, Export, Import, Manage, Logs, Job Monitor,
Control Panel, and Help. [Additional information or reference needed here]

Last login details

* Last login: Displays the last date and time of user login to Cisco ONP.

* Last login I P: Shows the IP address from which the user previously logged into Cisco ONP.

User information

» User name: Displays the name of the currently logged-in user, for example, ADMIN.

Reports tabs

The home page includes various report tabs that provide access to different reports. The availability of reports
depends on whether a network has been analyzed. Reports can also be accessed in site properties after network
analysis.

Network tree

The network tree displays the network name and its elements, such as Sites, Fibers, Waves or Media Channels,
SRLGs, and Subnet. [Additional information or reference needed here]

Expanding the workable area

To expand the Cisco ONP workable area, click the horizontal and vertical arrows on the home page. If an
empty grey window appears, ensure you are using the latest version of your browser. For detailed hardware
and software requirements, refer to theCisco ONP Installation Guide.

Change Password

Procedure

use this task to change your existing password.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Step 1 Click the Login icon in the top-right corner of the home page, and choose Change Password.
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Step 2 In the Change Passwor d dialog box, enter the Old Passwor d, New Passwor d, Repeat New Passwor d, and click Update.

Reset your password

The following procedure shows how to reset the password.

Procedure

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Step 2 Click Forgot Password ? in the Cisco ONP Login page. The Forgot Password page appears.
Step 3 Enter the registered email ID in the Forgot Password page, and click Continue.

A verification code is generated and sent to the registered email ID.

Step 4 Enter the verification code, new password and confirm password, and click Continue.

Sign out from Cisco ONP

Use this task to sign out of Cisco ONP.

Procedure

Click the Login icon in the top-right corner of the home page, and choose Sign Out to log out of the Cisco ONP tool.

Cisco Secure Development Lifecycle compliance

Table 4: Feature History

Feature Name Release Information Feature Description

CSDL Compliance Enhancements | Cisco ONP Release 4.1 The following CSDL compliance
enhancements are supported:

* Displays the last login IP
address of the client.

* Allows you to set a passphrase
for encryption of credentials
during the installation of LNI
application and database.
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. Cisco Secure Development Lifecycle compliance

Cisco ONP incorporates several CSDL compliances to enhance security and user management:

Passphrase security

» Dictionary check: Ensures new passphrases do not exist in a dictionary of common passwords.
« Expiration warning: You receive pop-up messages alerting them about impending passphrase expiration.

* Configurablelifetime and grace period: Admin users or those with
CONFIGURATION MANAGEMENT permission can set the lifetime of a passphrase and a grace period
for changing it via the system configuration tab.

* Passphrase requirements: Passphrases must be between 8 and 127 characters, including at least one
lowercase letter, one uppercase letter, one number, and one special character.

Passphrase management

* Initial admin login: Prompts the admin to change the passphrase upon first login.

* Installation encryption: Allows setting a passphrase or key for encrypting credentials during the
installation of the Live Network Import (LNI) application. If unspecified, a default key is used.

* Installation passphrase length: During Cisco ONP and LNI database installation, users can set a
passphrase between 8 and 64 characters.

User login information

« Last login details: Displays the last login date, time, and IP address in the Cisco ONP user interface.

Additional security features

» Passwor d gener ation: Users have the option to generate a password using the Generate Password feature.

» Passwor d strength display: The strength of the password set by the user is displayed.
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Manage Users and Roles

* User roles in Cisco ONP, on page 11

+ Grant access to a new user, on page 12

* Remove access to a user, on page 13

* Delete a user, on page 13

* Create a new user group, on page 14

* Assign a user to a user group, on page 15

* Set password expiration for individual user, on page 15
* Set password expiration for all users, on page 16

* Lock and unlock an individual user account, on page 16
* Expire the password set by an individual user, on page 17
* Create a new role, on page 17

* Assign a role to a user group, on page 18

» Manage password through Dictionary, on page 18

* Retrieve system logs , on page 19

* Retrieve component logs , on page 20

User roles in Cisco ONP

Cisco ONP provides a structured approach to access control management through various user roles. Here's
an overview of the default roles and their capabilities:

Administrator

The roles and responsibilities of the administrator are:

* User activation: Admin or users with admin access grant access by activating new users, who are then
notified by email.

» Group management: Admins can create new user groups, assign users to them, and allocate roles.
Certain predefined user groups cannot be edited or deleted.

* Role assignment: Admins assign roles to groups, defining the actions a group can perform.

Designer

The roles and responsibilities of the designer are:
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. Grant access to a new user

» Network design: Designers can create network topologies using either manual design or import design
methods.

+ Capabilities: They can design networks with various topologies (linear, ring, mesh) and assign fibers
between sites, including Traffic, OLA, ROADM, and Passthrough sites.

« Limitations: Designers cannot analyze networks but can view reports shared by others after analysis.

Planner
The roles and responsibilities of the planner are:

* Design and analysis: Planners can both design and analyze networks. They evaluate network performance
after creating sites, fiber spans, and service demands.

Reader
The roles and responsibilities of the reader are:

* View-only access: Readers can view users, user groups, roles, permissions, network topology, layout,
connections, and the Bill of Materials (BOM).

By default, users are assigned to the READ ONLY GROUP with a READER ROLE.

You can also create new roles. See Create a new role, on page 17.

Under Control Panel > Roles and Control Panel > Permissions, you can view the permissions applicable
for each role and the actions that can be performed for each permission.

Grant access to a new user

Procedure

Step 1

Step 2

All users with Admin role receive an email notification about new user registration.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.

Click Control Panel.

The Access Control M anagement page appears.

You can change the state of a user from INACTIVE to ACTIVE by using either of two ways:
a. From the State field, click INACTIVE in the respective user row.

b. Select a user row or multiple user rows and click Update.

* In the Update User dialog box, select the Group and State from the respective drop-down lists.

* Click Save.
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Remove access to a user .

Step 3 Click OK in the Success dialog box.

Note
* After the Admin grants access, the new user gets notified by email (sent to the email address registered while signing
up). It is only then that the new user will be able to log in.

* The admin assigns a newly created user with a Role and Group that determines what actions the user can perform.

Remove access to a user

Use this task to remove Cisco ONP access to a user.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.

Procedure

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 You can change the state of a user from ACTIVE to INACTIVE by using either of two ways:
a. From the State field, click ACTIVE in the respective user row.
b. Select a user row or multiple user rows and click Update.
* In the Update User dialog box, select the Group and State from the respective drop-down lists.

* Click Save.

Step 3 Click OK in the Success dialog box.

Delete a user

Use this task to delete a user or multiple users.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.
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. Create a new user group

Procedure

Step 1

Step 2

Click Control panel.
The Access Control M anagement page appears.

Delete a user:

a) Select the user or multiple users to be deleted under the USERS tab and click Delete.
b) Click Yesin the Warning dialog box.

The message User deleted successfully appears.

Create a new user group

Procedure

Step 1

Step 2
Step 3

Step 4

Use this task to create a new user group.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.

Click Control Panel.
The Access Control Management page appears.
Click the USER GROUPS tab.

Click Create.
a) In the Create Group dialog box, enter the Group Name.

b) Choose the appropriate role from the Role drop-down list. The available default roles are:

« ADMIN

« PLANNER
* DESIGNER
* READER

The Role drop-down list may also have user-defined roles listed under it.

¢) Click Saveto save the created user group.

Click OK in the Success dialog box.
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Assign a user to a user group

Use this task to assign a user to a user group.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.

Procedure

Step 1 Click Control panel.
The Access Control Management page appears.

Step 2 Under the USERS tab, select the user or users who are to be assigned to the new group, and click Update.
In the Update User dialog box:

a) From the Group drop-down list, select the appropriate group.
b) From the State drop-down list, select Active or | nactive to activate or inactivate the user in the group, respectively.
¢) Click Save.

Step 3 Click OK in the Success dialog box.

Note
a. A user can belong to only one group.

b. Only one role can be assigned to any group.
C. All the users of a group have the same role as that of the group.

d. By default, a new user is assigned to the Read Only_Group.

Set password expiration for individual user

Use this task to set the expiration of the password set by the user.

Before you begin

Log in to Cisco ONP web interface, on page 7 with Admin or Configuration Management permission.

Procedure

Step 1 Click Control Panel.

The Access Control Management page appears.
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Step 2 Select the user under the USERS tab., and click Update.
In the Update User dialog box:

a) Click the PASSWORD EXPIRY tab.
b) Enter values for the Lifetime, Warning and Gr ace fields.
¢) Click Save.

Note
The password expiry settings like lifetime, warning and grace time, take effect after the existing password is changed
by the user.

Step 3 Click OK in the Success dialog box.

Set password expiration for all users

Use this task to set the expiration of the password for all users.

Before you begin

Log in to Cisco ONP web interface, on page 7 with Admin or Configuration Management permission.

Procedure

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the System Configuration tab.
a) Enter values for the Lifetime, Warning and Grace fields.
b) Click Update.

Note
The password expiry settings like lifetime, warning and grace time, take effect after the existing password is changed
by the user.

Lock and unlock an individual user account

Use this task to lock or unlock an individual user account.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.
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Procedure

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.

a) Select the user whose account you want to lock or unlock.
b) Click Lock to lock the user account, or click Unlock to unlock the locked user account.

Note
The user of a locked account must contact the admin to unlock the user account.

Expire the password set by an individual user

Use this task to expire the password set by an individual user.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.
Procedure

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.
a) Select the user whose password you want to expire.
b) Click Expire.

Create a new role

Use the following task to create a new role.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.
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Procedure

Step 1 Click Control Panel.

The Access Control M anagement page appears.

Step 2 Click the ROL EStab, and click Create.
a) Inthe Create Role dialog box, enter the Role Name and select the Permissions for the role, and click Save.

Note
You can select more than one permission.

b) In the Success dialog box, click OK.

Assign a role to a user group

Use this task to assign a new role to a user group.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin role.

Procedure

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USER GROUPS tab.

a) Select the user group whose role is to be updated, and click Update.
b) Inthe Update Group dialog box, select the desired role from the Role drop-down list, and click Save.
¢) In the Success dialog box, click OK.

Manage password through Dictionary

If a password exists in the predefined list of passwords under the Content column in the DICTIONARY tab,
the dictionary rejects the new password set by the user.

This password verification check against the dictionary happens during any one of these events:

» New user sign-up

* Password change
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* Password reset using forgot password option

Use this task to verify whether the new password set by the user exists in the list of predefined passwords:

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with Admin or Configuration Management
permission.

Procedure

Step 1 Click Control Panel.
The Access Control Management page appears.
Step 2 Click the DICTIONARY tab.
a) Enable the Rejection Mode toggle button to verify the password against dictionary.
By default, the Rejection M ode toggle button remains disabled.

b) Enter the password in the Enter Passphrase text box.
¢) Ifyou want to enter the limit (maximum number of matching passphrases), enter the same in the Enter Limit text
box.

d) Click Search.
The matching passphrases get displayed.

Note
If you have entered the limit, a number of search results matching the limit gets displayed. Otherwise, all matching
passphrases get displayed.

Retrieve system logs

The System L ogs page shows at logs the events that are initiated during a specific time interval. See Logs ,
on page 276.

Before you begin

Log in to Cisco ONP web interface, on page 7 as an admin or a user with User Management and Network
Management permission.

Procedure

Click L ogs.

a) Click Select Start Date, and choose the start date. Similarly, click Select End Date, and choose the end date.
b) Choose the L ogs Category.

¢) Click FILTER to retrieve the logs.
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If you want to......

then...

export the system logs to an Excel sheet

click the Export asCSV icon.

export the system logs as a zip file

click the Export Archiveicon.

import the zip file

click the Import Archive
icon.

refresh the system logs page

click the Refresh icon.

delete the existing logs

click the Clear Logs

icon.

Retrieve component logs

Manage Users and Roles |

Use this task to retrieve the critical logs for each event from the Component L ogs page. See Logs , on page

276.

Before you begin

Log in to Cisco ONP web interface, on page 7 as an admin or a user with User Management and Network

Management permission.

Procedure

Step 1 Go to L ogs>Component L ogs.

Step 2 From the Component drop-down list, choose a component.

The logs for the chosen component appear. The available components are:

* BE

* GENE
* ODE
* PCE

Step 3 In the Search field, enter the event to locate the event logs.

The action icons available in the Component L ogs page are:

If you want to......

then......

export the component logs as a text file

click the Export icon.
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If you want to...... then......

see the file path of the chosen component | hover the | nformation
icon.
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CHAPTER 3

Design and Analyze Networks

* Design a network using Cisco ONP, on page 24

* Create optical subnet for Non-SSON networks, on page 39

* Create optical Subnet for SSON networks, on page 41

* Create optical subnet for NCS 1010 networks, on page 42

* Convert a non-SSON network to SSON network, on page 43

* Convert NCS 2000 network to NCS 1010 network, on page 44

* Share a network, on page 45

* Split-Step Fourier (SSF) Simulation, on page 47

* Analyze the network, on page 50

* Upgrade the analyzed network, on page 52

» Upgrade LNI network, on page 54

 Upgrade the software release of a network , on page 57

* Plan mode, on page 59

» Automatic suggestion for regeneration sites in Plan mode, on page 62
* Line Rate Tuner Mode, on page 64

* Create an Optical Source, on page 70

* Import Optical Sources, on page 71

* Find Optical Sources Faster, on page 75

* Download Optical Sources, on page 75

* Delete Optical Sources, on page 76

* Layout Template for NCS 2000 Network, on page 76

* Layout Visualization, on page 80

* Spectrum Utilization and Path Finder, on page 89

» Regenerate BoM Automatically, on page 93

* Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM, on page 94
* Export IPC Report, on page 94

* Edit the Layout Manually for NCS 1010 Networks, on page 95

* View Internal Node Connections of NCS 1010 Network, on page 97
* Designing networks with COSM card, on page 98

* Cisco Optical Site Manager associations, on page 100

» Export Device NETCONF XML File, on page 101

» Upload NETCONF XML Files on COSM Web Interface, on page 104
* Export Device NETCONF XML Files for Individual Sites, on page 105
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* Upload NETCONF Files to NCS 1010 Device, on page 105

* Export Cisco Optical Site Manager NETCONF XML File, on page 106

* Upload Cisco Optical Site Manager NETCONF XML to NCS 1010 Device via Cisco Optical Site Manager
Web Interface, on page 107

» Export NCS 1010 network planning data for Cisco Optical Network Controller, on page 108

* Upload Planning Data into Cisco ONC, on page 109

Design a network using Cisco ONP

You can design a network in one of these ways:

* Manual Design—Create a network design using a design palette.

* Import Design—Import a network design from an Excel sheet, Live Network Import or from an existing
network from CTP, or another instance of Cisco ONP.

Manually design a network using Cisco ONP

Table 5: Feature History

Feature Name Release Information Feature Description

Database Operations Optimization | Cisco ONP Release 5.2 Cisco ONP now provides an option
to run some operations in the
background involving database
interaction, such as Save As,
Import CPZ, and Export CPZ.
You can continue to use the Cisco
ONP interface for other operations
when these operations are running

in the background.
Table 6: Feature History
Feature Name Release Information Feature Description
4K-2K SSON Network Creation |Cisco ONP Release 5.2 Now you can include the 4K-2K
Support nodes in both SSON and

non-SSON networks while
designing the network. This helps
you to validate 4K-2K nodes in the
SSON design which has higher line
rates.
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Table 7: Feature History

Feature Name Release Information Feature Description

NCS 1010 C+L Network Design | Cisco ONP Release 5.1 Cisco ONP now supports the
C+L-band networks that help you
plan NCS 1010 networks using the
OLT-L and ILA-L line cards to
increase your network’s bandwidth
capacity. Enhanced with L-band
related properties, the UI enables
you to design a C+L-band network
for your ever-increasing channel
demands. The following L-band
types are introduced to suit your
design needs:

o C+L—This band type adds
more channels to your
network, increasing its traffic
carrying capacity.

» C+L Futuristic—This band
type creates a network with
C-band edges and future
provisions for L-band edges
that you can cost-effectively
upgrade after exhausting the
C-band capacity.

Table 8: Feature History

Feature Name Release Information Feature Description
Greenfield NCS 1010 Network Cisco ONP Release 5.0 You can design and validate
Design NCS1010 optical line system. This

feature helps to create OLT-C,
OLT-R-C, ILA-C, ILA-R-C, and
ILA-2R-C based NCS 1010
networks using fixed grid add/drop
MD-32-ODD, MD-32-EVEN and
flex grid add/drop BRK-24,
BRK-16, and BRK-8 passive
modules.
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Table 9: Feature History

Feature Name Release Information Feature Description

Multi-Layer Platform (MLP) Cisco ONP Release 4.1 This feature allows you to perform
Greenfield Design with NCS the following:
4k-1k-2k

* Support NCS 4K-1K-2K
multi-platforms

* Visualize new layout for Txp
and SVO for NCS 2000 node

* Support different OTN service
types with protection

+ Edit layout for NCS 4000 and
NCS 1004 nodes

You can create any of the following network designs:

* Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions

* Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand
and network conditions

* NCS 1010 network

Perform the following steps to create a network in the Cisco ONP:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> New.

Step 2 In the Create New Network dialog box, choose the required options to create a network.
a) From the LO Network Platform drop-down list, choose one of the following:

* NCS 2000—To create a non-SSON network that contains NCS 2000 and NCS 4000 nodes, or an SSON network
including NCS 2000, NCS 1004, and NCS 4000 nodes

* NCS1010—To create a network that contains only NCS 1010 nodes
* NCS1001—To create a network that contains only NCS 1001 nodes

* NCS1014—To create a network that contains only NCS 1014 nodes

b) If you want to create an SSON network, check the SSON Network check box, else leave it unchecked.
This option is not for the NCS 1010 network.

¢) Choose NCS (4K_1K_2K) or NCS (4K _2K) from the Traffic Type drop-down list.
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If you had chosen to create an SSON Network in the previous step, you can view the Traffic Type drop-down list.

Note

Once the network is created you cannot change the Traffic type from 4K 1K 2K to 4K 2K or vice versa. Hence,
we recommend you export the network into an Excel sheet, do the required modification and then import it as a new
network.

d) Choose the System Release for NCS 2K or NCS 1010 from the drop-down list.
You cannot change the system releases that are available for NCS 4K and NCS 1K.
The Band Type drop-down list appears for NCS 1010 networks from Release 7.9.1.
e) From the Band Type drop-down list for NCS 1010, choose one of the following:
* C-Band—Only C-band edges are created and ANS is generated based on C-band. For L-band upgrade, ANS
unlock is required.
* C+L Futuristic—Only C-band edges are created and ANS is generated based on C-band and L-band. For L-band
upgrade, ANS unlock is not required.
* C+L—Both C-band and L-band edges are created and ANS is generated based on C-band and L-band.
Note
After the creation of a NCS 1010 R7.9.1 network, if required, you can change the network band type under the
Network Application Configuration section in the Network Properties.
f) Click Create.
You can view a map and the design palette. For more information, see Design Palette, on page 282.
Step 3 Click the Drawing Tool icon (pencil and ruler crossed), and add sites and other network elements.
a) Add sites to the map using the drawing tool.
Zoom into the map to the desired level. Click any of the site icons (ROADM, OLA or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.
Note
* SRLG is not supported in the SSON networks.
Traffic node is not supported on the NCS 1010 network.
b) Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.
Note
By default, the fiber length is updated as 1 km for all the fibers. If you want the length to be auto updated based on
the x, y coordinates, then enable the Use Coor dinates Distance property under the network properties.
¢) Create services between the sites (only for SSON and non-SSON networks).
Cisco ONP provides only OTN service.
d) Click OTN Service (Green in color) and add the service between the existing Traffic sites on the map.
e) Click Circuit (purple in color), Media channel (purple in color), or Waves (red in color), and add media channel,

or waves between the existing sites on the map.
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In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Step 4 Choose File> SaveAs.

a) In the Give a Network Name dialog box, enter a network name and click Save.
b) If you want this operation to run in the background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

Create Shared Risk Link Group

You can use the Shared Risk Link Group (SRLG) feature for routing protected services. You can create SRLGs
through the Excel import file SRLG tab or through the Cisco ONP GUI using the following procedure:

\}

Note SRLG is supported only for the non-SSON network including the traffic nodes.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Click the network tree panel in the left.
Step 2 Expand Fibers, and check the check box next to each fiber in the same SRLG.
Step 3 After all fibers are checked, right-click, and select Create SRLG.

SRLG is created with a unique name. You can rename the SRLG.

Import network using Excel sheet

Use this task to import a network into Cisco ONP, using an Excel sheet.

Table 10: Feature History

Feature Name Release Information | Feature Description

CX Unified Planning | Cisco ONP Release | The integration between CX Unified Planning Tool (UPT)
Tool Network Import |5.0 and Cisco ONP enables you to import the networks created
and analyzed in Cisco CX UPT into Cisco ONP. This helps
you avoid recreating the networks that are already created in
UPT. This feature allows you to import networks having NCS
1010 and NCS 2000 nodes into Cisco ONP.
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Table 11: Feature History

Feature Name Release Feature Description

Information
Export and Import | Cisco ONP It is now possible to export the topology data of an existing network
of Network Release 5.1 into an Excel file. You can easily modify the exported data in Excel
Topology in Excel and import it back into Cisco ONP to create a new network or modify
Format an existing network.

The following are the supported Excel formats:

* XIsx—Standard Excel with multiple sheets, each corresponding
to a network element such as Network, Sites, Circuits, Spans,
OTNdemands, and so on.

» XIsm—Macros-enabled Excel file that can filter out and display
only the applicable network element sheets based on the platform
selected in the Network sheet.

Cisco ONP has the built-in intelligence to automatically calculate the
shortest path between a source and a destination, even if only a partial
fiber path is mentioned in the imported Excel file.

Note By default, the system release of the Excel imported network is 11.0.

Note From Release 5.0, Cisco ONP supports import of networks created using CX UPT via Cisco ONP Import
Excel option. CX UPT does not populate the DWDMChannel Type and Add/Drop Type values in the Excel
sheet. If the values are not found in the Excel sheet, then Cisco ONP picks the default options. By default,
DWDM Channel Typeis NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd and Add/Drop Type
is Colored. We recommend you to check the DWDMChannel Typeand Add/Drop Type values before importing
the Excel sheet into Cisco ONP to avoid any discrepancies.

From Release 5.1, in addition to exporting the template, you can also export the entire network design data
of an existing network in the form of the Excel sheet, modify the network properties available in the Excel
sheet and reimport. The network can be exported in all modes and reimported on Design mode, Upgrade
mode, and Release Upgrade mode.

N

Note Transponders are not supported as part of Export/Import Excel. When you export an existing network with
transponder card forced, the exported Excel sheet will have the Traffic type set to Pluggable Card in
DWDMChannels/MediaChannels tab. Make necessary changes in the exported Excel sheet before you import
it into Cisco ONP.

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure

Step 1 Choose Export > Excel.

Design and Analyze Networks |

a) Choose the Network Type as Template or Current Network.
b) Choose the File Type as xIsx or xIsm (Macro Enabled)

The Macros Enabled Excel sheet automatically customizes the tabs on the Excel sheet based on the platform that you
choose. It also provides additional functionalities such as selection of fibers in the path selection, wavelength count
validation in case of regen selection.

¢) Click Download.

The template has the following mandatory tabs, and the respective fields to be filled in the Excel sheet.

Tabs Description

Network Label (name of the network), Platform (NCS2000(NON SSON), NCS2000 (SSON), NCS1010,
NCS 1001, NCS 1014), Traffic Type, NCS1010 Line Card, NCS1010 Band Type, Chassis
Type, and System Release

Network Property This is applicable for NCS 1010 network alone.
State (New, Locked, and Unlocked), NCS 1010 Line Card, NCS 1010 Band Type, and Chassis
Type

Sites Site Label, Type, X coordinates, Y coordinates,X Rearranged, Y Rearranged, Pre Equip
Degree, Grooming Site, CLLI code, and Site Address, Degree (Scalable upto degree),
NCS1010 Line Card, NCS1010 Band Type, Chassis Type, and State.

Spans Span label, A (Source site name), Z (Destination site name), Kms (Distance), Loss, Type,

A Edge,Z Edge, AZ Loss,ZA Loss, AZ Kms,ZA Kms, NCS1010 Band Type, and State.

OTNDemands-4K-2K

Demand Label, A (Source), Z (Destination), Y (Tertiary Source), B (Tertiary Destination),
Type, Quantity, Protection, Primary Path, Secondary Path, and State.

Note: Y and B can be used with Unprotected Disjoint Service.

OTNDemands-4K-1K-2K

Demand Name, Source, Destination, Service Group, Type, A/D Type, Protection, Primary
Wavelength, Secondary Wavelength, Primary Path, Secondary Path, First Restoration path,
Second Restoration Path, Primary ODU Timeslot, Secondary ODU Timeslot, Primary Regen,
Secondary Regen, Trunk Mode, Baud Rate, and State.

MediaChannels Channel Label, Source, Destination, Primary Wavelength, Secondary Wavelength, Protection,
Traffic Type, Card Type, A/D Type, Primary Path, Secondary Path, Primary Regen, Secondary
Regen, and State.

ServiceGroup ServiceGroup Name, Demand Types, 4K Exclusive LC Usage, 4K Symmetric Aggregation,
1K Exclusive LC Usage, 1K Symmetric AggregationChannel Label, and State.

DWDMChannels Primary Wavelength and Secondary Wavelength (Work and Protect Wavelength for NCS2000

non-SSON waves), Primary Path and Secondary Path (Work and Protect Path for NCS2000
Wave/Media Channel and NCS1010 circuit), A/D Type (Colored/Colorless/Contentionless),
Traffic Type, Primary Regen Secondary Regen State, Channel label, A, Z, Wavelength,
Protection, and Type.
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Step 2
Step 3

Step 4

Cisco Transport Planner network import support .

Tabs Description

Services-1K Service Name, Source, Destination, Type, Protection, Primary Wavelength, Primary Path,
Primary Regen, Card Type, Trunk Mode, A/D Type, Band Type, and State.

Circuits Circuit Label, Source, Destination, Primary Wavelength, Protection, Traffic Type, Card Type,
A/D Type, Primary Path, Primary Regen, Band Type, and State.

Flex Optical Source Flex Optical Source Name.

SRLG SRLG Label, Spans, and State.

Fill the network details in the template file or edit the current network file, and save the file.
Choose Import > Excel, and select the Import Type.

» New—Choose this option if you want to create a new network using the design data available in the Excel sheet.

* Existing—Choose this option if you want to update an existing network with the data available in the Excel sheet.
Open the network before you import the Excel sheet. The network must be on Design mode, Upgrade mode, or
Release Upgrade mode.

You can view the data available in the Excel sheet before importing the network data. The View Data check box remains
checked by default. Uncheck it of you do not want to view the imported data.

Browse, select the saved file, and click Import.

During the import for the Existing network, if the state is Locked, Cisco ONP does not consider the data, if the state is
Unlocked, Cisco ONP changes the existing parameter, provided the network is in upgrade mode, and if the state is New,
the parameters in the Excel is added as a new entry into the network.

During new network import, new network design is created irrespective of the State.

Note
If there are errors in the imported data, a pop-up error message is shown in case of new import, and the errors are available
under the Elements> M essages tabs in case of updating the existing network.

Cisco Transport Planner network import support

You can import the networks that are created and analyzed from Cisco Transport Planner (CTP) to Cisco
ONP, to avoid recreating the networks that are already created in CTP. The CTP network files are in .mpz
format. You can, release upgrade, the imported networks.

)

Note * Network must be in design-analyzed or upgrade-analyzed mode.

* You cannot import networks which are earlier than Releasel1.0.

Supported Hardware

* Optical source files and transponders
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See Supported Optical Sources, on page 307, and Supported Cards and Pluggables, on page 293.
* Contentionless, colorless, and colored point-to-point demands
* Flex network

* Gain Equalizer

A

Note The Gain Equalizer node changes as a ROADM node when you unlock the site
after the release upgrade.

* ROADM-SMR-9 and SMR-20

+ All flex supported amplifiers, controller cards, and chassis types

Import MPZ Design File

Use this task to import .mpz file from CTP to Cisco ONP.

\)

Note Importing of mpz networks with P-Ring and A2A demands is not supported. Hence, we recommend you to
delete these demands in CTP, reanalyze the networks in CTP and import the mpz into Cisco ONP.

Before you begin
Log in to Cisco ONP web interface, on page 7 as a user with network creation permission.

Import the required optical source files and layout template using M anage > Optical Source and M anage >
Optical Source options. For more information, refer Manage Alien and M anage L ayout .

Delete the parameters that are not supported by Cisco ONP from the .mpz file and then import the .mpz file
to Cisco ONP.

Procedure

Step 1 Choose Import > MPZ.
The Import File (.mpz) dialog box appears.
Step 2 Browse to the .mpz file stored in your local system.
Step 3 Choose 4K_1K_2K or 4K_2K from the Traffic Type drop-down list.
If you had chosen an SSON MPZ file, you can view the Traffic Type drop-down list.

Step 4 Click Import.
The .mpz file gets imported to Cisco ONP.

Note
If you view a blank screen when you click waves in the network tree, refresh the browser.
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Step 5 Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

Note
* You cannot go back to design mode on the imported mpz network.

* The wave label of imported mpz network in Cisco ONP is the service name present in the CTP properties window.

Export the CPZ File

Cisco ONP stores the network design file as .cpz file in its database. You can export the design file into your
local system.

* In design mode, the .cpz file includes the design file, layout template, and optical source details.

* In analyze mode, the .cpz file contains a design file, analyze file, ANS file, per-side ANS file, BOM,
error messages, trace files, layout template, mpz, and report.

* For networks in upgraded mode, you can only export the last child in the parent-child hierarchy.

)

Note  You can export only one network at a time.

Before you begin

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 Choose File> Open.
Step 2 In the Select Network To Open dialog box , click the network that you want to export, from the list of networks.

The network opens.

Note
If you view a blank screen when you open a network, refresh the browser, or log in to Cisco ONP again.

Step 3 Choose Export > CPZ.
Step 4 In the Export .cpz file dialog box:

a) Ifrequired, rename the file.
b) If you want this operation to run in background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

c) Click Export and save the file in your local system.
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Import CPZ File

You can import the cpz network design files that are exported from another Cisco ONP instance.

\}

Note  You can import only the networks that are exported from the current release.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose Import > CPZ.
Step 2 In the Import .cpz file dialog box:

a) Click Choosefile, and select a cpz network design file that you want to import into Cisco ONP, from your local
system.
b) If you want this operation to run in background, click the Run in Background check box.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of
the operation running in the background.

¢) Click Import.

If the names of the optical source and layout template files available in the Cisco ONP database and the imported
network file are the same, you are prompted to confirm whether you want to overwrite the existing file.

Note
The error message " Network already existsin the system with another user. New network will be created” is
just an information. You do not need to perform any action. Cisco ONP automatically imports as a new network
specific to the user. There is no impact on the already existing network.

d) Ifyou want to overwrite the existing file, check the Overwrite Network check box.
If you leave the check box unchecked, Cisco ONP saves the imported network as a new network.

e) Choose the optical source files and layout template that you want to replace.
If you do not choose the optical source or the layout template file, the files will not be imported.

f) Click Confirm.

The imported network is saved in the Cisco ONP database.
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Live Network Import

Table 12: Feature History

Feature Name Release Information | Feature Description

Live network import | Cisco ONP Release |Cisco ONP now directly communicates with Cisco ONC to
from Cisco ONC 25.1.1 perform a live network import, eliminating the need for Cisco
ONP to be directly connected to a device or network. In
addition to the previously supported NCS 2000, networks
that include NCS 1010 nodes contained within NCS 1010
and NCS 1014 shelves can also be imported.

Table 13: Feature History

Feature Name Release Information Feature Description

Live Network Import Cisco ONP Release 4.1 This feature allows you to import
a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

The Live Network Import (LNI) feature allows you to import deployed networks into Cisco ONP in real-time.
This includes networks containing NCS 2000 nodes and NCS 1010 nodes contained within NCS 1010 and
NCS 1014 shelves. To perform the LNI operation, you must have a Network Management role. Once the
import is complete, you can view the entire deployed network details within Cisco ONP. The Map displays
the network topology, and you can check the node, fiber, service, and circuit properties through the Networ k
Tree and the Entity Editor.

From Release 25.1.1, you can import a live network through Cisco ONC.

Perform Live Network Import

Use this task to perform live import of a network from Cisco ONC:

Before you begin

* Perform LNI only when the Cisco ONC is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

* Ensure that the release version of Cisco ONC you are using for the network import is 25.1.1.
* Configure all the mandatory parameters on the circuit.

* Check the card label set for the following NCS 2000 cards and update it if they are not aligned.

PID Card Label

NCS2K-16-AD-CCOFS AD-16-FS
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PID Card Label
NCS2K-20-SMRFS SMR20-FS-CV
NCS2K-20-SMRFS-L SMR20-FS
NCS2K-9-SMR17FS SMRO9-17-FS
NCS2K-9-SMR24FS SMR9-24-FS
NCS2K-9-SMR34FS SMR9-34-FS
NCS2K-9-SMR34FS-L SMR9-34-FS
15454-M-RAMAN-COP= OPT-RAMP-COP
15454-M-RAMAN-CTP= OPT-RAMP-CTP
NCS2K-OPT-EDFA-35 OPT-EDFA-35

* Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 Choose Import > Live Import.

Step 2 In the Import Live Network dialog box:
a) Enter CONC Server | P, Username, and Password.
b) Click Import.

The Import button will be enabled only when all the values entered are valid.

Step 3 View the status of the LNI operation:

a) Click Job Monitor, to view the status of the IMPORT LIVE NETWORK task. Click Refresh to see the updated
status.

After LNI is completed, the job is removed from the Job Monitor page.
b) Click Logsto view the list of events that are related to the LNI operation, as logs.
Step 4 After the completion of the LNI operation, choose File> Open.

The format of the LNI imported network filename is LNI_<Date> <Time>.

Step 5 Click the imported network name to view the network under the M ap tab and its corresponding network tree in the left
panel.

You can view the tag Imported from Network in the top-right corner.

Note
* The configurations that are supported by Cisco ONC can only be imported into Cisco ONP. See Configurations and
hardware supported by LNI, on page 37.
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* Even If some errors occur during the LNI operation, the LNI operation is not canceled. In such case, when you open
the imported network, a warning message is displayed.

* You can view the errors under the Elements > Messages tab. See both critical and noncritical messages.

* If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS option. You can
edit this option during upgrade after unlocking the site, if necessary.

What to do next
Click the BOM tab to view the BOM details of the network.

\)

Note The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.

You can export the CPZ, import the CPZ, and share the imported network. You can check the properties of
the network using the Entity Editor.

Configurations and hardware supported by LNI

The live network import from Cisco ONC supports the configurations and hardware listed in this table.
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Table 14: Configurations and hardware supported by LNI

Design and Analyze Networks |

Platform

Chassis

Card type

Card

Configurations

NCS 2000t

NCS 2015
NCS 2006
NCS 2002

ROADM

NCS2K-20-SMRFS-L
NCS2K-20-SMRFS=
NCS2K-20-SMRFS-CV=
NCS2K-9-SMR17FS=
NCS2K-9-SMR34FS=
NCS2K-9-SMR24FS-L=
NCS2K-9-SMR34FS-L=

Add/Drop

NCS2K-16-AD-CCOFS

Amplifiers

NCS2K-OPT-EDFA-17=
NCS2K-OPT-EDFA-24=
NCS2K-OPT-EDFA-35=
15454-M-RAMAN-CTP=
15454-M-RAMAN-COP=

Transponders

NCS2K-400GXP-L-K9
NCS2K-200G-CK-LIC

NCS2K-200G-CK-LIC+
15454-M-10X10G-LC

Contentionless

Unprotected
circuits

NCS 1010

NCS 1010
NCS 1014

ROADM

All OLT variants with
Standard and Enhanced
faceplate

Add/Drop

CCMD1e6-C
MD-32-ODD
MD-32-EVEN
BRK-24
BRK-8

Direct LC

Amplifiers

All ILA variants

Transponders

NCS1K14-2.4T-K9,
NCS1K14-2.4T-X-K9 and
NCS1K4-QXP-K9

Colored
Colorless

Unprotected
Circuits

! Optical source interface import is not supported in NCS2000. By default, it is set to
NCS1004 SP_16QAM 300G 27%SDFEC_69GBd. You can manually edit the optical source interface
to the correct one during an upgrade, without unlocking the circuit.
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Limitations of LNI
The LNI feature has these limitations:

* You cannot perform multiple LNI at the same time.
* Scheduled LNI is not supported.

* LNI does not support:
* Non-SSON Network import

» Non-Contentionless configuration import

* Import of NCS1001, NCS1004 and NCS4000 devices

* Importing a network with a mix of NCS 2000 and NCS 1010 nodes from Cisco ONC is not supported.

Workaround: Add either NCS 2000 nodes or NCS 1010 nodes into Cisco ONC and perform the Live
Network Import for the selected node type.

* When importing an NCS2000 network, only the 400G-XP-LC, 200G-CK-C, and 200G-CK-C+ 10x01G-LC
transponder cards are successfully imported.

* If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the
node position after importing.

* Cisco ONP imports the proto-PID, if any, present in inventory, and show as N/A PID in the Cisco ONP
BOM.

* Duplicate media channel label is not supported. If there are multiple media channels with same label
present in the network, only one media channel is imported and the rest of them are discarded.

* Fiber name, source, and destination names may not match between the first and the second import. Source
and destination site names may interchange for bidirectional fibers.

* Fibers may not be associated with correct optical subnet if the fibers are not configured with the same
channel number at both source and destination ends. Due to this amplifier output power may not be
within valid range. Hence, you either correct channel number at both source and destination nodes and
re-import the network, or associate the fiber with correct optical subnet after network upgrade in Cisco
ONP.

Create optical subnet for Non-SSON networks

An optical subnet is a collection of spans with certain associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet that is associated to the network. At least one optical subnet
must exist for each network.

\)

Note Check the Current Subnet check box in the properties window below the network tree, to make the subnet
you created as the current subnet. You cannot uncheck the Current Subnet check box.
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Use this procedure to create an optical subnet for Non-SSON networks:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:
a) Choose File> Open.
b) In the Select Network To Open dialog box, select the non-SSON network in which you want to create a subnet.

The network opens.

Step 2 Expand Subnet in the network tree panel.
Step 3 Click the Ellipsisicon available in the right side of Optical Subnet.
a) Inthe Create Optical Subnet dialog box, choose the C-band design rules for the new optical subnet that you want
to create, from the Cband Rules drop-down list, then click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under

OpticalSubnet.
Step 4 After the new optical subnet is created:
If you want to... Then...
select a new spectral density select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.
add a fiber to a subnet add a fiber to a subnet from the Fiber links drop-down list in the properties

window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet from the network * Click the Ellipsisicon available in the right side of the required optical
tree panel subnet and select Edit Fibers.

In the Info dialog box, click OK.
The Ul freezes, and you can select a fiber only from the map.
* Select the required fiber and click the Donebutton appearing near the zoom

icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.
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Create optical Subnet for SSON networks

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:
a) Choose File> Open.
b) Inthe Select Network To Open dialog box, select the SSON network in which you want to create a subnet.

The network opens.

Step 2 Expnad Subnet in the network tree panel.
Step 3 Click the Ellipsisicon available in the right side of Optical Subnet, and select Create Optical Subnet.

a) Inthe Create Optical Subnet, choose the spectral density for the new optical subnet that you want to create from
the Spectral Density drop-down list.

The Name, CBand Rules, and Maximum Number of Channels the you see in the Create Optical Subnet dialog
box, are set based on the spectral density that you have selected.

b) Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Step 4 After the new optical subnet is created:

If you want to... Then...

select a new spectral density select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

add a fiber to a subnet add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.
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If you want to... Then...

add a fiber to a subnet from the network * Click the Ellipsisicon available in the right side of the required optical
tree panel subnet and select Edit Fibers.

In the Info dialog box, click OK.

The Ul freezes, and you can select a fiber only from the map.

* Select the required fiber and click the Donebutton appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.

Create optical subnet for NCS 1010 networks
A\

Note From Release 7.9.1, both C-Band and L-Band optical subnets appear by default for the NCS 1010 networks.

For C-Band and C+L Futuristic networks, the L-Band optical subnet contains no fiber links. To add fiber links
for the L-Band optical subnet, you must upgrade the existing network to a C+L-Band network or add an
L-Band edge for each C-Band edge.

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:
a) Choose File> Open.
b) Inthe Select Network To Open dialog box, select the NCS 1010 network in which you want to create a subnet.

The network opens.

Step 2 Expand Subnet in the network tree panel.
Step 3 Click the Ellipsisicon available in the right side of Optical Subnet, and select Create Optical Subnet.
Step 4 In the Create Optical Subnet dialog box:

a) Choose either C-Band or L-Band from the Band Type drop-down list.

Note
From R7.9.1, Band Type drop-down list is available when creating an optical subnet for NCS 1010.
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Convert a non-SSON network to SSON network .

b) From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to

create.

From Release 5.2, the range of spectral density has increased (ranges 30-100).

The Name, CBand Rules or L Band Rules, and Maximum Number of Channels values that appear in the Create
Optical Subnet dialog box are set based on the spectral density that you have selected.

¢) Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under

OpticalSubnet.
Step 5 After the new optical subnet is created:

If you want to...

Then...

select a new spectral density

select a new spectral density from the Spectral Density drop-down list in the
properties window displayed under the network tree.

add a fiber to a subnet

add a fiber to a subnet from the Fiber links drop-down list in the properties
window.

The fiber now appears in the Fiber links field. When you select the optical
subnet, its corresponding fiber is highlighted in the map.

add a fiber to a subnet from the network
tree panel

* Click the Ellipsisicon available in the right side of the required optical
subnet and select Edit Fibers.

* In the Info dialog box, click OK.
The UI will freeze to allow fiber selection from the map.

* Select the required fiber and click the Donebutton appearing near the zoom
icon.

Note
When a fiber is added to one of the subnets, it is automatically removed from
the other subnets. Only one subnet rule is associated with one fiber.

Convert a non-SSON network to SSON network

The following procedure converts non-SSON networks to SSON networks:

\}

Note You cannot convert a non-SSON network with Traffic Sites to SSON.

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure

Step 1 Open the network:
a) Choose File> Open.
b) In the Select Network To Open dialog box, select the non-SSON network you wish to convert.
Ensure that the network is in Design Mode. If the network is in Analyze mode, upgrade or release upgrade the

analyzed network, then unlock all the channels, and force CFP-2 optical source.

Step 2 Convert to SSON:

a) Choose Network > SSON Convert and click Ok.

b) Ifyou see the error message "Network cannot be converted to SSON due to following errors : [Network contains
waves with invalid traffic types: [100G-SD-FEC, 200G-SD-FEC]]", follow these steps to resolve it:

* Choose Network > Entity Editor > Services.

» Expand Waves and navigate to trail, and click a trail.

* From the Src Card Type drop-down list, choose any CFP-2optical source
* Click Update, then choose File> Save.

* Choose Network > SSON Convert again.

Step 3 In the Warning pop-up window, choose 4K-2K or 4K-1K-2K from the Traffic Type drop-down list, and click OK.
Note that 4K -1K-2K is the default option. After the network is converted, you cannot switch the site types between
4K-2K and 4K-1K-2K.

The non-SSON gets converted as SSON network.

Step 4 After the network is converted to SSON, select SSON optical source from the Traffic Typedrop-down list in the properties
window displayed under the network tree and click Update.

Convert NCS 2000 network to NCS 1010 network

Use the following task to convert an NCS 2000 network (both SSON and non-SSON) into to NCS 1010
network:

Table 15: Feature History

Feature Name Release Information | Feature Description

Convert NCS 2000 Cisco ONP Release | The newly introduced NCS 1010 Convert option under

network to NCS 1010 5.1 the Network menu enables you to directly convert an

network existing NCS 2000 network into an NCS 1010 network.
This conversion eliminates the need to build an NCS
1010 network from scratch.
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Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:
a) Choose File> Open.
b) In the Select Network To Open dialog box, select the non-SSON network that you wish to convert.

The network opens. Ensure that the network is in Design M ode, Upgrade M ode or Release Upgrade Mode.

Step 2 Choose Network > NCS 1010 Convert, then click Ok.
The network does not get converted and shows an error message, if

» the network contains traffic sites.

» the fiber type is LS or TWClassic.

» the network contains OTN services.

« the traffic Type property is set to anything other than Optical Source or Pluggable Card.
» the Traffic Type is 100G-SD-FEC or 200G-SD-FEC in non-SSON networks.

Step 3 Choose File> Save.
The following parameters are automatically updated after the conversion:
* Contentionless sides are deleted and contentionless demands are automatically changed as colorless.

* Protected channels are converted to two unprotected channels. The path, wavelength, regen sites and cards that are
configured are retained.

Share a network

Use these steps to share a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:

a) Choose File> Open.

b) In the Select Network To Open dialog box, select the network that you want to share.
The network opens.
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Step 2 Choose File> Share.
Step 3 In the Share Network dialog box, select one or more users or user groups, then click Share.

You can share the network with selected users or user groups in read-only mode.

Access a shared network

Use these steps to access a network shared by another user:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open a shared network:
a) Choose File> Open Shared.

b) Inthe Select Network To Open dialog box that lists the networks that are shared by other users, select a network.
The shared network opens in read-only mode.

Step 2 Choose File > Save As.
Step 3 Enter the name in the Give a networ k name dialog box, and click Save.

A copy of the shared network is saved.

Note

You can work on this copy of the network, depending on the privileges of your user role. For example, if your user role
is Designer, you can change the design of the saved copy of the shared network, but you cannot analyze the shared
network.

Step 4 If you want, share the updated network with other users.

Unshare a network

Use these steps to unshare a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:

a) Choose File> Open.

b) In the Select Network To Open dialog box, select the network you want to share.
The network opens.
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Step 2 Choose File> Share.

Split-Step Fourier (SSF) Simulation .

Step 3 In the Share Network dialog box, remove the name of one or more users or user groups from the list, then click Share.
The shared network is no longer available to the users or user groups that are removed.

Split-Step Fourier (SSF) Simulation

Table 16: Feature History

Feature Name | Release Feature Description

Information
Split-Step Cisco ONP | The Split-Step Fourier (SSF) method is introducted to calculate optical
Fourier (SSF) | Release parameters in addition to the existing e-GN algorithm for analysing NCS 1010
Simulation 25.1.1 networks. This enhancement:
Method

* Improves the accuracy of the simulations for OSNR and BER, particularly
in complex network scenarios.

* Provides an SSF engine that leverages GPUs to work on intense
calculations.

* Requests simulation generation from GENE (Generic Engine for NCS
1000 platforms)

* Monitors analysis progress on the GPU server, and updates the user
through analysis notifications.

* Sends simulation results to GENE for report generation after analysis
completion.

* Provides a Lookup Table that contains the default optical specification
values for each supported amplifier.

The new properties that enable the SSF method for network analysis are.

» At network level, Advanced Optical Settings> SSF
Simulation—Enables the SSF simulation. Enable the Enable Special
Settings check box to view the SS- Smulation check box

At network level, Advanced Optical Settings> LUT version—Shows
the default LUT version to be used for network analysis. Enable the
Enable Special Settings check box to view the LUT version check box

* Preferences> General Settings > SSF Server Details—Allows to
configure the GPU server used for SSF simulation.

» Manage > L ookup Table—Allows you to refer the default optical
specification of the supported amplifiers.
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The Cisco Optical Network Planner supports simulation using Split-Step Fourier (SSF) method in addition
to the existing e-GN Algorithm for optical parameters calculations such as OSNR, BER. The SSF method
uses an SSF engine that runs on GPUs to do intense optical calculations.

Limitations of SSF simulation
* Supports only point-to-point networks
» Works only with CIMS interfaces
* Supports only colorless add/drop

» Computation intensive than e-GN algorithm for better OSNR margins

Set SSF Server Details

The procedure to set the SSF server to run the SSF analysis is as follows:

Before you begin

Install the SSF component.

Procedure

Step 1 Open the network:

a) Choose File> Open.
b) Inthe Select Network To Open dialog box, select the network that you want to upgrade.

The network opens.

Step 2 Navigate to SSF Server Detalils.

a) Choose Preferences> General Settings
b) In the dialog box, select SSF Server Details.

Step 3 Enter the SSF server details.
In SSF Server Details, enter the required details

Fields Description

SSF Server |Enter the server IP address
IP

API Key This field is disabled.

Proxy IP Enter the customised proxy IP address.

Proxy Port | Enter proxy port of the server.

Stepd  Click OK.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Design and Analyze Networks

Lookup Table (LUT) [}

To reset the server details or close the dialog box, click Reset or Cancel.

Lookup Table (LUT)

CONP uses LUTs while performing analysis using SSF simulation. LUT can also be used even when SSF
simulation is not in use. The LUT values are used for the NCS 1010 networks only.

You can enable LUT only when you enable the Advanced Special Settings checkbox at the Network level.

By default, Lut is set to the version — ‘1.1.3’

Manage Amplifier Gains using Look Up Table

The procedure to refer or manage the amplifier gains in the look up table is as follows:

Procedure

Step 1 Open look up table.

a) Choose Manage > Lookup Table

The Manage L ookup Table dialog box opens displaying the list of supported amplifiers.

Options Actions

Search Allows to type in the amplifier to filter the desired lookup
table.

Check boxes Selects all or required amplifier tables.

Page numbers

Turns to the desired page.

Import Imports the customized tables.
Export Exports the selected tables.
Delete Deletes the selected tables.
Cancel Closes the dialog box.

When expanded, the table displays the optical specifications.

Table 17: Amplifier optical specifications

Parameter Description

Fiber Type Displays the list of supported fibers for the amplifier.
Total Loss (dB) | Displays total signal loss in dB.

SD Range Displays the SD gain range.

Cisco Optical Network Planner Configuration Guide, Releases 25.x.x [Jj



Design and Analyze Networks |
. Analyze the network

Parameter Description
Raman Displays the status of Raman amplification in the amplifier.
Amplified

BST PSD (dBm) | Displays the PSD value for the booster amplifier in dBm.

More Parameters | Contains an information button to check for additional values.

Step 2 (Optional) Customize the optical specifications in the Lookup table.

a) Select the required amplifier.

b) Click Export.
The amplifier value downloads in spreadsheet.

c) Edit the values in the downloaded spreadsheet and click Import.
The new values are added to the Lookup table.

Step 3 (Optional) Delete the customized specifications in the Lookup table.

a) Select the required amplifier.
b) Click Delete.

Restriction
You cannot delete the default tables.

Analyze the network

Table 18: Feature History

Feature Name Release Information Description
Detailed Tooltip for Sites on the | Cisco ONP Release 5.1 The See M ore Details option has
Map View been introduced in the tooltip

displayed on hovering over Sites
on the Map view of an analyzed
network. This option shows the
Amplifier data and PSD (Power
Spectral Density) profile graph. The
See More Details option avoids
navigating to the Entity Editor to
view these details.

Use this procedure to analyze the network after design completion.

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure

Step 1

Step 2

Step 3

Bottom-Up Flow .

Open the network:
a) Choose File> Open.
b) In the Select Network To Open dialog box, select the network that you want to analyze.

The network opens.

Analyze the network:
a) Choose Network > Analyze.

The Cisco ONP analysis progress indicator indicates the analysis status. After successful analysis, the network goes
to Analyze Mode.

b) Ifyou see the “Analysis Failed.” message, navigate to the Elements> M essagestab to see the list of error details in
the analyzed network.

By default, it shows only the key messages when the Critical Only toggle button is enabled. If you want to view the
entire network message, disable the Critical Only toggle button.

c) Resolve the error and analyze the network again. Repeat this step until all errors are resolved.

Note

The error message "Unexpected Situation 999" may occur when the optical simulation becomes inconsistent due to
incorrect values of properties entered or modified while designing the network. Call Cisco TAC to know the exact cause
of the error and modify the suggested property value for the successful analysis of the network.

If you want to view the details such as Amplifier Data and PSD Profile graph for a site in an analyzed network, hover
the mouse over a site and click See More Details.

The amplifier data includes output power, EOL gain, attenuator in, attenuator out, and Raman gain. The attenuator details
are not displayed for the NCS 1010 site. The PSD profile graph is displayed only for the NCS 1010 site.

Bottom-Up Flow

Bottom-up support enables step-by-step creation of a network. Adding all the services and waves on day 0
itself is not mandatory to analyze the network and view reports. Bottom-up flow enables you to build a network
over a period.

Day 0: Create a network with only the topology added. Add all sites and add fibers between them. Analyze
the network and view the reports without adding any services or waves.

Day 1: Add waves between the sites that are added on Day 0 and newly added sites and fibers. Analyze the
network and view the reports.

Day 2: Add services and tag waves that are created on Day 1 and newly added sites and fibers. Analyze the
network and view the reports.
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Note

After you have created the topology with sites and fibers added, you can add either a service or a wave. You
need not follow any specific order.

Bottom-up flow is applicable only for Non-SSON networks. In order to achieve this, you must set A2A mode
as A2A_fast in network properties. You can also set the A2A channel type as contentionless, colorless, and
colored.

Idle Timeout in the Analyze Mode

If you keep the browser idle for more than 15 minutes, you are logged out of Cisco ONP. The default timeout
is set to 15 minutes. The System Admin can disable this feature by changing the enabled option in the
configuration file on the server to false. You can change the default time of 15 minutes by editing the duration
option in the configuration file.

During a long network analyze cycle, you get logged out due to idle timeout, and the network analysis runs
in the background. When you log back, the same network opens in one of the following states:

« If the analysis is still on, the analysis progress bar is shown, and you cannot perform any other action.
» If the analysis is complete, the network opens in the Analyze mode.

» If the analysis has failed, the network opens in the design mode, and you can view the reason for failure
on the Elements > M essages page.

The session time out does not redirect you to the login page always; so, reload or enter the URL again.

Upgrade the analyzed network

Table 19: Feature History

Feature Name Release Information Description
NCS 1010 Network Upgrade Cisco ONP Release 5.0 After a network is analyzed, all the
Flexibility network elements get locked. With

this feature, you can selectively
unlock certain network elements to
upgrade the network further. This
helps in preventing accidental
updates to the part of the network
that does not need any
modification.

Cisco ONP allows you to upgrade an existing network that is in analyzed mode. You can modify certain
properties of a network element in the network while retaining the existing network layout and design in the
locked state. Upgrade is supported for NCS2K, NCS4K-2K, NCS4K-1K-2K and NCS1010 networks.

Use these steps to upgrade your network:
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Procedure

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Upgrade the analyzed network .

Before you begin

Log in to Cisco ONP web interface, on page 7.

Open the network:
a) Choose File> Open.
b) In the Select Network To Open dialog box, select the network that you want to upgrade.

The network opens.

Upgrade the network:
a) Choose Network > Upgrade.
b) Click Yes.

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), media channel (for SSON), and circuits (for NCS 1010) are locked.

To modify a network element in the network tree panel, click the Ellipsisicon next to element, and choose Unlock.

You can unlock elements one at a time down to the lower levels of the network tree hierarchy. For example, you can
hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers level.

If you want to change only the add/drop between MD-32-ODD/Even or BRK 24/16/8 in the NCS 1010 network, you
can unlock the add/drop without unlocking the network elements that are higher in the hierarchy:.

You can make these modifications:
« Editing the properties of network elements.
* Deleting the network elements from the network.

» Adding a new site, wave, services, demands, optical subnet, or fiber into the network map.

Choose File> Save.
The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

Note
You can insert a node in the upgrade mode only for the unlocked fiber. Therefore unlock the fibers that are connected to
the node and add nodes to the network.

Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network that has where layout template is applied, the template gets
updated with the newly added service or fiber. You can export this template, make changes and reapply it to another
network.

Choose Network > Design to further upgrade the newly upgraded network design.
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When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Upgrade LNI network

Table 20: Feature History

Feature Name Release Information Feature Description

Upgrade LNI Network Cisco ONP Release 4.1 This feature allows you to upgrade
and modify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

The Upgrade feature can be used to correct LNI errors, modify the network, reanalyze the network and view
updated BOM, Layout, Connections, and Optical Results.

Use these steps to upgrade the LNI network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network:

a) Choose File> Open.
b) Inthe Select Network To Open dialog box, select the network imported through LNI that you want to upgrade.

The network opens.

Step 2 Upgrade the network:
a) Choose Network > Upgrade.
b) Click Yes.

The message “Network Upgraded Successfully” appears. After upgrading the network, the network enters the upgrade
mode, locking elements like Sites, Fiber, OTN Services, and Media Channels.
Step 3 To modify a network element in the network tree panel, click the EllipsisSicon next to element, and choose Unlock.

You can unlock elements one at a time down to the lower levels of the network tree hierarchy. For example, you can
hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers level.

You can make these modifications:

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Design and Analyze Networks
Upgrade LNI network .

« Editing the properties of network elements.
* Deleting the network elements from the network.

» Adding a new site, wave, services, demands, optical subnet, or fiber into the network map.

Step 4 Choose File> Save.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Step 5 Choose Network > Analyze.

Analysis is successful only if a consistent and valid network is imported. For instance, in an NCS 2000 network imported
from Cisco ONC, if the device connections do not match with Cisco ONP rules, the upgrade analysis may fail with a
connection error. If the analysis fails, perform these steps:

a) Check the reports under Elements M essages for failure reasons.

b) Unlock the specific site to allow Cisco ONP to rebuild the connections according to its rules. Alternatively, correct
the connections on the device and re-import the network.

¢) Re-Analyze the network.

Step 6 After analyzing the network:

a) Click the Layout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004
platforms. See

b) Click the BOM tab, and the Results tab to view the BOM and optical results.

After upgrading and analyzing the LNI network:

1. Ifthe LNI inventory has any unconnected cards, that will be removed from the Cisco ONP reports after
upgrading and analyzing the LNI network.

2. These PIDs are added in the Cisco ONP BOM after upgrading and analyzing the LNI network. These
PIDs are not part of the LNI network BOM.

* Pre-provisioned PIDs
* Release software PIDs and Licenses

* Optical cables: Cables used for Internal Patch-cord Connection (IPC) is not imported in LNI as this
data cannot be retrieved from device

 Attenuators

* SMR port license PIDs: Only SMR card PID is imported as part of LNI. If a licensed PID is retrieved,
corresponding port licenses are added after upgrading and analyzing the LNI network, based on the
number of ports used.

* USB cables: Added if Pre-provisioned passive cards are present.

* Blank cards: Blank cards are not imported. They are added in Cisco ONP after upgrading and analyzing
the LNI network.
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Possible error scenarios and the workarounds

This table describes the workarounds for the errors that are shown under the Elements > M essages tab.

Table 21: Error scenarios and the workarounds

Error message

Workarounds

Device Authentication failure

Check the username and password of the device,
which is given in LNI input Excel and retry LNI
import with valid device credentials.

Device collection failed or Device not reachable.

Check for any connectivity issue in the setup, fix it
and retry LNI import.

In Sited4.A, output power setting is not supported by
the amplifier.

Unlock C-Band amplifiers for side A inside Site4 in
the Network tree and force the valid output power. If
not sure, set it to Auto and analyze. Cisco ONP
chooses the best value based on the configuration.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

For protected OTN service or SSON service, a
minimum of two contentionless sides must be present
on the source and destination sites. Check and add
contentionless sides on the target service source and
destination site and analyze.

* Demand OTU3 has unrecognized type [OTU3]

* ServiceGroup does not support the demandType
OTU3 for OTU3

Only 100GE, 10GE, and STM-64 service rates are
supported. If any other service rate is present in the
network, unlock the specific service, change it to one
of the supported service types and update the ODU
time slot accordingly and analyze.

Primary OTN Demand [100GE_Flex] has invalid
Timeslot ranges. Allowed ranges are [1-80]

100GE service type must have ODU time slot in the
range of 1-80. If any other value is set, update the
correct value or leave it blank so that Cisco ONP can
set it to the correct value.

Cannot complete mesh connections at Site3.

Unlock the site and reanalyze.

No OTN demand found for NCS4K trunk port -
NCS4016-B - OTU40/8/0/1.

No action required. This is an information message
to the user.

Fiber between Nodel.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
correct connector loss value to be greater than zero.
The typical value is 0.2.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Unlock the corresponding fiber couple and update the
correct Tot SOL Loss w/o Connectors. The value
should be greater than zero.

Span Fiber-2 is forced as Raman but no traffic is
present.

Remove Raman forcing on the fiber, or check and
force the path for any service so that it goes through
Raman enabled span.
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Error message Workarounds

Couple Fiber-2 has Raman enabled on the duct but | Force RAMAN-CTP or COP on the Fiber-2
corresponding Raman Forcing is missing. connecting node interface or remove RAMAN forcing
on the Fiber-2

N

Note No specific action is required for noncritical messages. These are just information messages to the user.

Upgrade the software release of a network

Table 22: Feature History

Feature Name |Release Information |Feature Description

Release Cisco ONP Release | This feature allows you to choose the NCS 2000 system release to
Upgrade 4.1 the desired release (11.1.0, 12.0.1, or 12.1.0), while performing the
release upgrade of CTP network, Cisco ONP network, network
imported through Excel, and LNI network.

You can upgrade the software version of networks that are imported from CTP, created in Cisco ONP, LNI
Network, or imported from Excel to any desired release version. The release upgrade is supported for both
SSON and non-SSON networks that have NCS 2000 nodes with ROADM, OLA, Traffic, or Passthrough
functionality, and NCS 1010 networks.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

\}

Note NCS 2000 supports SVO from the Release 12.1.0, and Cisco Optical Site Manager from 25.1.1.

The table shows the available upgrade releases for each network type.

Table 23: Supported upgrade paths for network system releases

Network Upgrade Release

CTP network (.mpz) e From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1
* From 11.1.0 to 12.1.0, 12.2.0, 12.3.1 and 25.1.1

Cisco ONP network e From 11.0.0to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1
* From 11.1.0 to 12.1.0, 12.2.0, 12.3.1, and 25.1.1
e From 12.1.0 t0 12.2.0, 12.3.1, and 25.1.1

Excel imported e From 11.0.0to 11.1.0, 12.1.0, 12.2.0, 12.3.1, and 25.1.1
network
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Network Upgrade Release

LNI network Note
Release upgrade is not supported for the LNI networks in Release 25.1.1.

NCS 1010 Network *771t079.1,7.10.1,7.11.1, 24.31,25.1.1
*79.1t07.10.1,7.11.1, 24.31, 25.1.1
*7.10.1t0 7.11.1,24.31, 25.1.1
*7.11.1t024.31,25.1.1

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the network in which you want to perform the system release upgrade.
Step 2 Upgrade the software release of the network:
a) Choose Network > Release Upgrade.
b) From the New System Release drop-down list, choose the system release of NCS 2000 or NCS 1010, to which you
want to upgrade.
¢) Click Submit.

The upgraded network is saved as a child network.

The network elements are locked in the network tree after the release upgrade. You can unlock and modify the
elements.

Note
If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by the PMD
value when you edit the fiber properties.
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Plan mode

Table 24: Feature History

Feature Name Release Information Feature Description

What-if Analysis for OTN Services | Cisco ONP Release 4.1 This feature extends the current
implementation of What-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported for SSON
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Plan mode overview

Plan mode is a feature that allows you to perform what-if analysis on existing network designs. This analysis
can simulate network behavior during failures and determine if services can be rerouted. However, it does
not provide guidance on setting up new wavelengths or adding new nodes, cards, or ports.

Advantage

The Plan mode effectively simulates and analyzes potential network issues and solutions, focusing on rerouting
capabilities without physical changes to the network infrastructure.

Supported network elements

* NCS 2000 aggregated node that includes ROADM, OLA, and passthrough nodes
* Traffic nodes such as 1K-2K, 4K-2K, and 4K-1K-2K

* Nodes created in Cisco ONP

* CTP imported networks (mpz format)

* LNI imported networks

Limitations

* Only users with PLANNER and ADMIN roles can access the Plan mode.

* It does not guide on turning up new wavelengths or adding new network components.

Perform a what-if analysis on an analyzed network in the Plan mode

Use this task to perform a what-if analysis of a network and export the failure report in the Plan mode.
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Procedure

Step 1
Step 2

Step 3

Step 4

Step 5
Step 6

Step 7

Step 8

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with admin or planner role.

Open a network that is in Analyze mode.
Choose Network > Enter Plan Mode.

The network switches to the Plan mode. After entering the Plan mode, you can do what-if analysis of the network by
failing fibers and sites in the network.
Fail the sites:

a) Expand the Sites option in the network tree panel.
b) Click the Ellipsisicon available in the right side of the site, and click Fail. Alternatively, you can right-click a site
in the map and select Fail.

¢) To fail multiple sites, check the check box next to each fiber before selecting Fail.

Fail the fibers.

a) Expand Fibersin the network tree panel.

b) Click the Ellipsisicon available in the right side of the fiber, and click Fail. Alternatively, you can right click a fiber
in map and select Fail.

¢) To fail multiple fibers, check the check box next to each fiber before selecting Fail.

You can observe that all media channels or waves, OTN services, and demands that pass through the failed fiber will
fail. These are indicated by symbols in the map:

* Failed channels: Red cross
* Fibers impacted due to site failure: Yellow cross

» Restored channels: Green tick

d) To undo the fiber failure, click the Ellipsisicon available in the right side of the fiber, and click Undo Fail.
If you want, you can Create a failure set.

Restore the failed fibers by clicking Restore.

The restored channels are indicated with a green color tick mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber also get restored. The Path Computation
Element (PCE) supports the restoration of the OTN services based on the optical feasibility and OTN constraints.

After restoring the fibers, export the failure report:

a) Choose Export > Failure Report to export the failure report as an Excel sheet. See Failure report , on page 61for
the parameters included in the failure report.

b) Alternatively, you can click Export in the Failure Report area below the map.

You can view the unrestored channel details in the failure report and the reason for restoration failure under Elements>
M essages tab.

Exit the Plan mode.
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Create a failure set .

a) Choose Network > Exit Plan M ode.

Create a failure set

Procedure

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Create a failure set to fail a set of fibers and sites in a single click. You can save multiple failure sets under a
given failure group.

The following procedure shows how to create a failure set:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Open a network and enter the Plan mode.
Click the Ellipsisicon available in the right side of the Failure Groups option in the network tree panel.
Click Add Failure Group.

A Failure group gets created.

Add fibers and sites to the group.

a) Choose the Fibersand Sitesto fail by checking the check boxes next to the them.

b) Click the Ellipsisicon available in the right side of the chosen Fibers and Sites, and click Fail.

Click the Ellipsisicon available in the right side of the network name and click Add Failure Set.

Select the Failure Group to which the failed fibers or sites must be added.

The Failure Set gets created under the Failure Group. The failed fibers or sites are added to the created Failure Set.

Note
If networks have dark fibers (which do not carry any traffic), that path is not considered for restoration.

Failure report

The failure report shows these parameters:

Report Description

Failed Fibers Shows the failed fibers in the network.

Failed Sites Shows the failed sites in the network.

Impacted Fibers Shows the fibers that are impacted due to the site failure.
Total Channels Shows the total number of media channels in the network.
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Report

Description

Failed Channéls

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Restored Channels

Shows the total number of media channels that are restored from the failure state.

Unrestored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Fiber HotZones

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

« Fiber: Shows the fibers that are listed under fiber hot zones.

« Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

« Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Total Services

Shows the total number of services going through the fiber that was failed.

Failed Services

Shows the number of failed services going through the fiber that was failed.

Restored Services

Shows the number of restored services going through the fiber that was restored.

Unrestored Services

Shows the number of unrestored services going through the fiber that was restored.

Automatic suggestion for regeneration sites in Plan mode

Table 25: Feature History

Feature Name

Release Information Feature Description

Regeneration Sites

Automatic Suggestion for Cisco ONP Release 5.0 Cisco ONP displays feasibility

report in the Plan mode. This report
automatically suggests regeneration
sites for the channels with high and
marginal risk of failure. You can
incorporate these regeneration sites
in the optical network to make the
channel optically feasible. This
feature avoids multiple iterations
required to manually create the
regeneration sites and test the
optical feasibility of large networks.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x




| Design and Analyze Networks

Automatic suggestion for regeneration sites in Plan mode .

Optical network feasibility assessment

Cisco ONP identifies networks that are not optically feasible, focusing on channels with a high or marginal
risk of failure. These risks are highlighted in red and orange on the Optical Results page, indicating End of
Life (EOL) and Start of Life (SOL) issues.

Regeneration site suggestions

To address optical feasibility issues, the Path Computation Element (PCE) runs a regeneration suggestion
algorithm. This algorithm proposes potential regeneration sites. When entering plan mode, Cisco ONP presents
these suggested regeneration sites within the Feasibility Report, located at the bottom of the map. You can
apply these suggestions to enhance network feasibility.

For channels with pre-existing regeneration, the system provides suggestions at the section level.

The Feasibility Report table encompasses several fields, which are crucial for assessing the optical feasibility
of the network.

Table 26: Feasibility Report

Field Description

Channel Name Displays the list of channels (trail and sections) that
are not optically feasible.

Alarm Displays the color of alarm (red, orange, or yellow)

Paths Displays the actual path of the channel as hyperlink.
If you click the link, the path is highlighted in the
map.

Suggested Regens Displays the intermediate sites that can be used as
regen sites so that the channel becomes optically
feasible.

Exporting the Feasibility Report
You have the option to export the Feasibility Report. Click Export.
The Suggested Regen field in the report may display as "NA" for the following reasons:

* Negligible Loss: Channels with yellow alarms indicate negligible loss, thus not requiring regeneration
suggestions.

* Insufficient Intermediate Sites: When high loss occurs and there are not enough intermediate sites available
to mitigate the overall loss.

* Lack of Contentionless Sides: Intermediate sites without added contentionless sides are not considered
viable for regeneration sites.

Support for various network configurations

Auto regeneration site suggestion functionality is available for both SSON and non-SSON networks that
includes contentionless channels or waves between NCS2K (ROADM) or 4K-1K-2K (TRAFFIC) sites.
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Apply the suggested regen sites

Use this task to apply the suggested regeneration sites to make the network optically feasible.

Before you begin

Log in to Cisco ONP web interface, on page 7 as a user with admin or planner role.

Procedure

Step 1 Open an analyzed network.
Step 2 Enter the plan mode.
Step 3 Apply the suggested regen sites to the network.
a) Choose Network > Open Feasibility Report.

The Feasibility Report is displayed at the bottom of the map.

b) Select the channels for which regeneration has to be applied and click Apply.
¢) In the Suggested Regen Applied dialog box,click Ok .

Step 4 Exit the Plan mode.

a) Choose Network > Exit Plan M ode.
b) Click Yesin the Warning dialog box.

The network gets auto upgraded and saved as a new network. The channels with regens applied are unlocked with the
Regen Sites property auto updated and noneditable.

Step 5 Analyze the network.

In the Optical Resultspage, the SOL, and EOL fields become green, and the channels are not displayed in the feasibility
report again when you switch to the plan mode.

Line Rate Tuner Mode

Table 27: Feature History

Feature Name Release Information |Feature Description

Automated Selection of Cisco ONP Release | You can now automate the calculation of optical
Optimal Wavelength Bitrate: |5.2 sources for your networks using the new Line Rate
Flexible Modelling Tuner Mode. This mode reduces human errors while

finding the correct optical source for your network
from a set of network resources.

Line Rate Tuner Mode significantly reduces turnaround time, avoiding manual calculation of different
possibilities of network resources.
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Enter the Line Rate Tuner Mode .

Note

Line Rate Tuner Mode is available for NCS 2000 and NCS 1010 networks.

Enter the Line Rate Tuner Mode

Use these steps to enter the Line Rate Tuner mode.

Procedure

Step 1
Step 2

Before you begin

Log in to Cisco ONP web interface, on page 7

Open the network in Analyze mode.

Choose Network > Enter Line Rate Tuner Mode.

Switching to line rate tuner mode.. progress bar appears.

The network opens in the Line Rate Tuner Mode.

Create a Custom Optical Source

Use this procedure to create a custom optical source.

Procedure

Step 1
Step 2

Step 3

Step 4

Before you begin

Log in to Cisco ONP web interface, on page 7

Open the network in Line Rate Tuner mode.
Click Open Tuner Input.

Input Tuner pane appears below the map area.

In the network tree, select the section of the media channel that you want to add the tuner input.

In Select Input Parameters, the selected section appears with default parameter values.

Modify the following Input Parameters as required.

Property Platform Description

Optical Family |NCS 2000 Choose the optical family. Based on the analyzed network, Cisco ONP provides
SSON the options. Based on the optical family chosen, the remaining parameters provide
NCS 1010 related options.
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Property Platform Description
Optical Source |NCS 2000 Choose the optical source. Based on the optical sources that are already imported,
SSON Cisco ONP provides the list of optical sources.
NCS 1010
Data Rate NCS 2000 Choose the data rate. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the channel capacity for the new section.
NCS 1010
Bit Rate Range |NCS 2000 Choose the bit data rate. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the speed of data transfer in the new section.
NCS 1010
Baud Rate Range | NCS 2000 Choose the baud rate range. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the minimum signal width for new each channel.
NCS 1010
FEC Type NCS 2000 Choose the FEC type. Based on the optical family chosen, Cisco ONP provides the
SSON list of supported FEC types
NCS 1010
Result Type NCS 2000 Choose the Result Type. The available options are:
SSON * Best OSNR—Provides results based on maximum OSNR margin.
NCS 1010 . . . . .
» Maximum Capacity—Provides results based on the maximum capacity of the
channels.
Optical NCS 2000 Choose optical feasibility for the new section. The available options are:
Feasibility SSON
» Green
NCS 1010
* Yellow
* Orange
* Red
Each color represents the severity of alarms that may arise in the new section.
Sigma Number |NCS 2000 Choose the sigma number from 0 to 3. The sigma number calculates the OSNR
SSON margin.
NCS 1010
Number of NCS 2000 Choose the number of optical source results that you want for the new section.
results SSON The default value is set as 5. However, you can choose up to 15 results.
NCS 1010

Step 5 (Optional) Click Reset to reset the modified parameters to default values.
Step 6 Click Add.
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Step 7

Step 8

Step 9

Start the New Tuner Analysis .

In Select Section, Tuner Input is added successfully. Please refer the below table for the added inputs message appears.

The Select Section pane provides the details of the modified section.

Table 28: Select Section Parameters

Section Parameters Description

Section Label Name of the modified section.

Src Site Site name for the optical channel source.

Dst Site Site name for the optical channel destination.
Path Fiber paths in the section.

Actions Icons to edit or delete the modified section.

(Optional) To modify or delete the section, choose the following icons as required:

Icon Actions
Pencil Edit Input—Modifies the section
Trash Bin Delete Input—Deletes the section

To edit the modified section:
a. Click the pencil icon.
b. Modify the input parameters as required.

c. Click Update to update the edited section parameters.

To delete the modified section:
a. Click the trash bin icon.
A confirmation message appears.

b. Click Yes.

Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

In Tuner Result, click Export to export the results as an Excel sheet.

Start the New Tuner Analysis

Use these steps to start a fresh tuner analysis for the new section.

Before you begin

Log in to Cisco ONP web interface, on page 7
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Start New.

The Start New Tuner dialog box appears asking for a confirmation.

Step 3 (Optional) Check the Retain the tuner inputs check box to retain the previous input values.
Step 4 Click Yes.

The message Started new tuner successfully appears.

Step 5 Modify the input parameters of the new section.
Step 6 Click Update.
Step 7 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

Open the Custom Optical Source Tuner Result

Use these steps to open the tuner results for the customized optical sources.

Before you begin

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears.

Add the Custom Optical Source to the Network

Use these steps to add the custom optical sources to the network.

Before you begin

Log in to Cisco ONP web interface, on page 7
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears displaying the new sections and their demand channels.
The result provides the following action icons to add the optical sources to the network.

» Add Demand to Networ k—Click this icon to add the demand to the network.

» Download Optical Source—Click this icon to download the optical sources as an Excel sheet to review offline.

Step 3 To add the optical source to the network, perform one of the following actions:
To add manually:

Note
For some custom optical source results, the download icon becomes disabled. In that case, go to Manage > Optical
Sour ce to download the optical result as explained in Download Optical Sources.

a. Click the download icon.
The Downloading Optical Source message appears. The Excel sheet contains data in Cisco ONP format.
b. Open the Excel sheet to review the data.

C. Import optical sources as explained in Import Optical Sources.

To add automatically:
a. Click the add icon.

The No. of demands pop-up appears asking for the number of demands to add to the network.
b. Enter the demands number and click Add.

The Demand is added successfully message appears.

The new demand appears in the network tree. Along with the demand, the Cisco ONP adds the required optical source
also automatically to the server.

Exit the Line Rate Tuner Mode

Use these steps to exit the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP web interface, on page 7
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Procedure

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Choose Network > Exit Line Rate Tuner Mode.

The Exiting Tuner dialog box appears.

Step 3 Choose the following action as required.
Button Actions
Previous State Moves the network to previous state with applied changes.
Upgrade Moves the network to Upgrade mode with applied changes.
Cancel Cancels the operation.

The network exits the Line Rate Tuner mode.

Create an Optical Source

Use this task to creat an optical source.

Before you begin

Procedure

Step 1 Choose Export > Optical Source Template.

The downloaded template has two sheets with information related to interfaces and their respective Optical Classes.

Sheets | Description

Interface | contain the details specific to the interface only.

Class | contains the information that can be overlapped with multiple interfaces. In those cases, multiple interfaces
can be mapped to the same class.

For the list of the required Optical Parameters, refer to Optical Parameters Available in the Excel Sheet for Optical Sources
Creation.

The dowloaded sheet has the data for one of the existing interfaces for reference. You can edit or delete the data from
the sheet.

Step 2 Fill all the required parameters from the specicification sheet.
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Step 3

Import Optical Sources .

There are some hidden columns that are not mandatory for Optical Source Creation. But, you can expand those columns
and fill the details.

After you have filled all the information, save the excel file with an optical source name.

What to do next

Go to Import Optical Sources to import the optical source from an Excel sheet.

Import Optical Sources

Procedure

Step 1

Table 29: Feature History

Feature Name Release Information Feature Description
Create Optical Source using Excel | Cisco ONP Release 5.0 You can create an optical source by
Sheet defining the details of interfaces

and the corresponding optical
classes in an Excel template. This
feature provides you with the
flexibility to create any required
optical source based on existing or
new traffic resources.

Optical Source Wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Use this procedure to import an optical source:

Before you begin
Log in to Cisco ONP web interface, on page 7.

If you want to import the optical sources from an Excel sheet, download the template by choosing Export >
Optical Source Template. Fill the necessary details in the I nterfaces and Optical Classes sheets of the
downloaded template and save the file. See Optical Parameters Available in the Excel Sheet for Optical
Sources Creation, on page 72.

The fields in the columns D, E, and F that are not mandatory are hidden by default in the Interfaces sheet of
the template. You can expand the columns and fill the details.

Choose Manage > Optical Source.
The Manage Optical Source dialog box appears. The default optical sources available in the server are:

* OpticalSources NCS2K 400GXP-LC NCS4K-4H-OPW-QC2
* NCS1004 OpticalSources V3
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. Optical Parameters Available in the Excel Sheet for Optical Sources Creation

Step 2

Step 3

Step 4

* ONS-CFP2D-400G-C-OpticalSources-V2.mxd
* QDD-400G-ZRP-S-OpticalSources-V2.mxd

Note
By default, all existing optical source files are loaded in the server.

To import optical source as .mxd file:

a)
b)

c)

Click Add.
Choose Optical Source (.mxd)

The Import Optical Source (.mxd) dialog box appears.
Click Choose File and browse to the .mxd file stored in your local system, and click | mport.

After the optical source is imported, a list of related interfaces appears.

To import the optical source from an Excel sheet:

a)
b)

<)
d)

e)

Click Add.
Choose Optical Source (.xIsx)

The Import Optical Source (.xIsx) dialog box appears.

Click Choose File and browse to the .xls file (optical source template) saved in your local system, and click Import.
Choose the Release Version of the NSC2K network.

Note
Selected release version is applicable only for NCS2K network. For NCS 1010, NCS 1001, and NCS 1014 networks,

the imported optical source is available for all supported release versions irrespective of the selected NCS 2000 release
version.

Select the interface.

If you want all the interfances, then click Select All.

Click Create.

After the optical source is imported, a list of related interfaces appears.

Choose the interfaces to import by checking the check box next to them. The selected interfaces get added to the Type
drop-down list in the properties window of the network tree.

When you create waves, you can use the interfaces in the Type drop-down list.

What to do next

Go to Download Optical Sources, on page 75 to download optical source for Cisco ONC.

Optical Parameters Available in the Excel Sheet for Optical Sources Creation

The following parameters are available in the Excel sheet template for creating optical sources.
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Table 30: Optical Parameters for Creating Optical Sources

Optical Parameters Available in the Excel Sheet for Optical Sources Creation .

Parameters

Description

Interface Name

The name of the interface. It should be unique for all
the interfaces that are added in the file.

Vendor Name The name of the vendor.

Vendor IDs The vendor IDs.

Platform The name of the platform.

Pluggable PID The PID of the pluggable.

Name It is the combination of the Data Rate and Open
Config Code. For example: R400G#5000.

FEC The forward error correction type for the given
interface.

Data Rate The line rate for the given interface.

Mod Format The modulation format to be used for the interface.

Baud rate The baud rate for the given interface.

BPS The speed of data transfer (bits per symbol) for the
given interface.

Open Config Code The unique code assigned to the interface as specified
by the Open Industry Standard for optical networks.
For example: 5000.

Sub Mode Enter the sub-mode if there are any associated with
the interface. If not, leave it blank.

Trunk Rate The trunk rate of the transponder.

Nominal Bit Rate

The bit Rate for the interface

BER Target

The post FEC BER Target for the interface

Power Min and Power Max

The minimum and maximum Tx Power for the
interface.

Ovl The overload power limit for the interface

OL Power The Rx power sensitivity for the interface.

OL OSNR The Rx OSNR sensitivity for the interface.

PL Power The extended Rx power sensitivity.

PL OSNR The Rx OSNR sensitivity at the extended Rx power

sensitivity.
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Parameters Description

Variance The variance in power in the Txp.

Opt Class The optical class to which the interface will be
mapped.

InBand OSNR The Tx OSNR contribution due to laser instability
inside the Txp.

Out of Band OSNR The Tx OSNR contribution due to Add/Drop at 80%
and 100% channel spectral density.

ONC Release The Software release of Cisco ONC from which this
interface will be supported.

Interface Type It is the same as the name of the interface.

Min and Max Frequency The operating frequency range of the interface.

Table 31: Optical Class Parameters

Class Parameters

Description

Interface Type

The name of the interface. Enter the same name of
the interface, if you are doing one to one mapping
with the interface.

Opt Class

You can create the optical classes for different optical
sources. Certain optical parameters are added in the
optical class. Based on interface properties, multiple
interfaces can be mapped to the same class.

Enter a unique alphanumeric name for the Optical
class. While creating new optical classes, we
recommend using the name starting with “X” to avoid
overlapping in the existing classes.

Bit Rate

The bit rate for the given interface.

Baud Rate

The baud rate for the given interface.

ModGB Coeff

The modulation guard band coefficient.

Modulation OSNR Penalty

The modulation OSNR penalty.

GBf

The filtering GuardBand at different OSNR penalties.

Mux/Demux Filtering Penalty

Enter the mux/demux filtering penalty value, if there
are any.

Chromatic Dispersion

The chromatic dispersion limit at different OSNR
penalties.
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Find Optical Sources Faster

Use these steps to find the optical sources faster.

Before you begin

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Note

By default, all existing optical source files are loaded in the server.
Step 2 To find the customized optical sources:

a. Check Show only lineratetuner generated sources.

The dialog box displays only the customized optical sources.

Step 3 To filter the required optical source:
a. Enter the optical source name in the Search box.

The dialog box displays the optical sources matching the typed keyword.

Download Optical Sources

Use this procedure to download an optical source:

Procedure

Step 1 Choose Manage > Optical Source.
The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to download.

Step 3 Click Download and select one of the following options to download the optical sources.

» .mxd—Downloads the selected optical sources as .mxd file.

+ xIsx—Downloads only the optical sources which were created and added using the Excel template, as .xIs file.
Others such as the optical sources which were directly added as .mxd file, are not included in the .xsl file.
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 xml—Downloads the optical source data as a .xml file. This file contains the application codes for circuit provisioning
in Cisco ONC, optical parameters of the interfaces, PIDs, and Vendor ID information. You can load the .xml file
into Cisco ONC to create circuits with these optical source interfaces. See Alien Import.

After the import is successful, the optical source will be present under the Application Code tab in the Service
Manager screen of the Cisco ONC application. See Service Manager.

Delete Optical Sources

Use this procedure to delete an optical source:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose M anage > Optical Source.
The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to delete.
Step 3 Click Deleteto delete the selected optical sources.

Layout Template for NCS 2000 Network

Layout templates are reusable templates that are used to design layout configurations for the NCS 2000
network. When you have an NCS 2000 network with fixed layout rules applicable for multiple nodes, you
can use these templates to accurately set up the layout for those nodes. These templates save you time, effort,
and they minimize errors.

)

Note Layout template is not supported for a mix of TXP and Real card label of transponders.
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Export Layout Template

Procedure

Step 1

Step 2

Step 3

Step 4
Step 5
Step 6

Step 7

Table 32: Feature History

Export Layout Template .

Feature Name

Release Information

Feature Description

Layout Template Enhancement

Cisco ONP Release 4.1

This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in Cisco ONP Release 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Use the following procedure to export the layout template of a specific site or all sites:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.

The Select Network To Open dialog box appears.

Click the network whose network layout template you want to export.

The network opens.

Choose Network > Analyze.

Note

Network must be successfully analyzed to proceed further.

Click the Layout tab.

Click the name of a site in the left side panel, for which you want to download the layout template.

Hover the mouse pointer over the Export icon and click L ayout Template for Current site or All Sites.

The Export Layout Template dialog box appears.

Click Export.

Note

* We recommend that you export the layout template only in the analyze mode. Exporting layout templates in the
upgrade and release upgrade modes may be inaccurate.

* You can export the layout template for node of the type 4000 and 1000, but the exported layout template will contain
only the layout of NCS 2000 nodes. To export the layout template for the node type NCS4K-1K-2K and NCS1K-2K,

perform the following:

* Right click the site name in the L ayout panel, and click Export.
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* Click OK to export the layout template in text format.

» The NCS 2000 layout template is in XML format.

Import Layout Template for NCS 2000 Network in to Cisco ONP Database

Use the following procedure to import a template for NCS 2000 Network into the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose Manage > Layout Templates.

Step 2 Click Add in the Manage L ayout Template dialog box.

Step 3 Click Choose Files and select a template from your local system.

Step 4 Click Import.
The template is imported to the Cisco ONP database.

Download Layout Template for NCS 2000 Network

Use the following procedure to download a template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure
Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage L ayout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Download.

Save the template into your local system.
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Delete Layout Template for NCS 2000 Network .

Delete Layout Template for NCS 2000 Network

Procedure

Step 1
Step 2

Step 3

Use the following procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose Manage > Layout Templates.
In the Manage L ayout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Click Delete to delete the template from the Cisco ONP database.

Apply NCS 2000 Layout Template into a Site

Procedure

Step 1

Step 2

Step 3
Step 4
Step 5

Use this task to apply the NCS 2000 Layout template into a site. The site can be NCS4K-2K, NCS1K-2K-4K,
or NCS1K-2K, but the template will be applied only to the NCS 2000 section of that site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network where you want to apply the layout template into an NCS 2000 site.
The network opens.
Choose Network > Entity Editor.

In the Entity Editor window, expand Sites and choose the site.
In the right pane, choose the required template from the L ayout Template drop-down list.

Note
Make sure that the other properties under L ayout section such as Chassis Type, Power Supply, Controller Card, Node
Protection, Redundant Controller Card, and M F-Unit are

set to Auto. Otherwise the L ayout Template drop-down list remains disabled.
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Import NCS 1000 and NCS 4000 Layout Template into NCS1K-2K and
NCS4K-1K-2K Sites

Use this task to import NCS 1000 and NCS 4000 layout templates that were exported, into 4K-2K and
NCS4K-1K-2K Sites.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network that has the site to which you want to apply the layout template.
The network opens.

Step 3 Click the Layout tab.

Step 4 Add the required NCS 4000 and/or NCS 1000 chassis, cards, and pluggables to the required slot of the added chassis.
See Edit the Layout Manually, on page 81

Step 5 Click Edit to enter the edit mode.
Step 6 Right click the name of a site on which you want to import the layout template, and click Import.
Step 7 Choose the layout template that you want to import into the site and click OK

The layout template gets applied to the site.

Note
When you modify an exported template, ensure to rename the modified template before reapplying it to a site in the
upgrade mode so that the changes in the template reflect in the layout view.

Layout Visualization

Table 33: Feature History

Feature Name Release Information Feature Description

Layout Visualization and Edit Cisco ONP Release 4.1 This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.
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This feature allows you to visualize the layout of a network, designed using Cisco ONP. You can view the
arrangement of racks, chassis inside the racks and cards inserted in the chassis. When you click a particular
Rack or Chassis or Card in theL ayout panel, the corresponding Rack or Chassis or Card gets highlighted in
the Layout image. You can zoom in and zoom out the Layout image.

View Network Layout

The procedure to view the network layout is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.
Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 In the Layout panel on the left side, click the site.

Note
The OLA sites are highlighted in green color, ROADM sites in blue color and Aggregated nodes in purple color.

Passthrough sites are not listed under layout.

For NCS 1010 network, Aggregated nodes are not available.

Step 6 Click any rack under a site to visualize the rack view of the network under L ayout tab.
Step 7 Click any chassis under a rack to visualize the chassis view of the network.
Note

When you click the Aggregated node under L ayout panel, NCS 1004, NCS 2000 and NCS 4000 series chassis are placed
in separate racks.

You can click the screenshot icon to take screenshot of all racks layout of the selected site.

Edit the Layout Manually

The Manual layout edit feature is used to adjust the position of NCS 4016 and NCS 1004 chassis and cards
in the layout.

The procedure to edit the layout manually is as follows:
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Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.

Choose the network where 4K-1K-2K and 1K-2K aggregated nodes are added. This feature is not supported on NCS
2000 node.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 Select the Chassis (4K-1K-2K and 1K-2K) or Card from a particular rack.

Step 7 Drag and drop the selected Chassis or Card from a particular rack to the empty slot in the same or different Chassis or
Rack.

Step 8 To add pluggables to a particular card, perform the following steps:

Note
Make sure to add the required cards.

a) Select the Rack.
The cards available in the Rack are displayed.

b) Select the card to which you want to add pluggables.
The ports available in the card are displayed.

¢) Select the pluggable for each port.
The following pluggables are displayed:

Card Supported Pluggables

NCS4K-4H-OPW-QC2 * ONS-QSFPS8-LR4=
* QSFP-110G-SR4-S=
* ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-LO * ONS-QSFPS8-LR4=
* QSFP-100G-SR4-S=
* ONS-QSFP-4*10-MLR=
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Card Supported Pluggables

NCS1K4-1.2T-K9= « ONS-QSFP8-LR4=
* QSFP-100G-SR4=

* ONS-QSFP28-LR4-S=

* QSFP-100G-CWDM4-S=
* QSFP-100G-SM-SR=

d) Click the Tick icon.

Step 9 Click Doneto save the changes in the Layout.

View the Layout Details Using Tooltip

You can hover over the Racks or Chassis or cards in the Rack and view the details using Tooltip. Click See
More Details to view the details of port no. type, pluggables and rates.

Copy the Configurations of a Particular Node to Another Node

The configuration can be copied from one node to another node only for the manual 4K-1K layout movement.
It is not supported for NCS1010 layout movement.

The procedure to copy the configurations of a particular node to another node of a different site is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.

Step 5 Select the Rack, Chassis, or Card of a particular site.

Step 6 Select the site to where you want to copy the configurations to, from the Copy To drop-down list.
Step 7 Click New Rack to add a new rack. The configuration gets copied to the new rack.

Step 8 Click Done to save the changes in the Layout.
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Export Port Usage of LNI Network

Procedure

Step 1

Step 2

Step 3

Step 4

Note

Table 34: Feature History

Design and Analyze Networks |

You can also cut, copy, and delete Racks, Chassis, and Cards in the Chassis from the Layout.

Feature Name

Release Information

Feature Description

Multi-Layer Connections Phase 1

Cisco ONP Release 4.1

This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

* Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

* Port usage report based on
sites

* Port usage report only for LNI
imported networks

Use the following procedure to export the port usage details of an LNI network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.

The Select Network To Open dialog box appears.

Click the LNI network whose port usage you want to export.

The network opens.

Choose Network > Analyze.

Note

Network must be successfully analyzed to proceed further.

Click the Layout tab.
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Step 5
Step 6

Step 7

Define multilayer connections for SSON network

Procedure

Step 1

Define multilayer connections for SSON network .

Click the name of a site in the left side panel,for which you want to download the port usage.

Mouse hover the Export icon and click Port Usage for Current site or All Sites.

The Export Port dialog box appears.

Click Continue.

The port usage details are exported in the Excel sheet format.

Note

* [f you modify any services in the NCS 4000 node after upgrading the LNI network , the changes will not get updated

in the port usage details.

* The demand labels seen against the trunk ports of NCS4K-DWDM line card in the port mapping report are not
logically related to the NCS 4000 trunk ports, but are related to NCS 1004 client ports.

Table 35: Feature History

Feature Name

Release Information

Feature Description

NCS4K-1K-2K Multilayer
Connection Trace

Cisco ONP Release 4.2

You can define Multilayer
Connections (MLC) such as cards
and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the L ayout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Before you begin

Log in to Cisco ONP web interface, on page 7

Open a network:
a) Choose File> Open.
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. Define multilayer connections for SSON network

Step 2

Step 3

Step 4

b)

In the Select Network To Open dialog box, click a network in which you want to define the multilayer connections.

Make sure that the network is in analyzed mode and 4K, 1K, and cards are defined in the network.

Define the MLC:

a)
b)

<)

d)

Click the Layout tab.
In the left pane, click the ML C tab.

Alternatively, you can navigate to the M L C page by clicking the Ellipsisicon available in the right side of the service
name in the network tree and clicking View in MLC

You can view a table describing the properties of the service, in the right pane. See MLC details, on page 87.
Click the service name to switch to the layout view.
You will view the layout and the service details in the right pane.

Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS
1K out, for both Source and Destination sites.

The details of the NCS 2000 chassis are auto-populated.

Note
For LNI imported network all the details are auto-populated. If you add any new service, you can change the details
of the new service as per your requirement.

Click the Tick icon to save the changes you have done.
You can click the refresh icon to delete the changes you made after saving.

The updated details are included in the BOM.

If you want to export the MLC details perform these steps:

a)
b)
¢)

Click the Table icon to switch to the table view.
Choose Export > MLC Tracesto export all the details available in the MLC table.

Choose Export > LMP/TTI Connections to export the details of Link Management Protocol (LMP) connections
which are the connections between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTT) connections
which are the connections between NCS 4000 and NCS 1004 cards.

All these connections get added to the BOM.

If you want to filter the services displayed in the left pane, click the Filter icon and choose one of these options:

* Source Site
* Destination Site
* Type of the traffic

* Trace Origin

* LNI: Imported through Import Live Network option
* User Created: Created through Cisco ONP UI

* Trace Status

» Completed: User has defined all MLC details.
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MLC details [
* Partial: User has defined only partial MLC details.
* Empty: User has not defined any MLC details.
Step 5 Click the three vertical dots and select the required options:
 Enable Multi Select: You can select up to the card level for different OTN.
» Expand All: Expands the services tree.
* Collapse All: Collapses the expanded services tree.
 Show Trace Status: Shows the trace status icon next to the service name.
Step 6 Click the three horizontal dots across the service trace and select the required options:
* Delete Trace: Deletes the respective trace.
* Locatein Map: Shows the service in the map view.
Note
You can enable the same port number on the primary and secondary NCS4K | N nodes for Client 1+1 and other protection
scheme.
MLC details
This table describes various fields available in the MLC tab.
Table 36: MLC details
Properties Description
Name Name of the service
Group Name Name of the group to which the service belongs to
Type Traffic type
Src Site Source site
Src NCS4K In Details of Rack/Slot/Card/Port in the input side of the
NCS 4000 chassis in the source site
Src NCS4K Out Details of Rack/Slot/Card/Port in the output side of
the NCS 4000 chassis in the source site
Src NCSIK In Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the source site
Src NCS1K Out Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the source site
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Properties Description

Src NCS2K AddDrop Add/Drop multiplexer and demultiplexer connected
to the NCS 2000 chassis in the source site

Src NCS2K MPO Media channel between the source and destination
sites

Dst NCS4K In Details of Rack/Slot/Card/Port in the input side of the
NCS 4000 chassis in the destination site

Dst NCS4K Out Details of Rack/Slot/Card/Port in the output side of
the NCS 4000 chassis in the destination site

Dst NCS1K In Details of Rack/Slot/Card/Port in the input side of the
NCS 1004 chassis in the destination site

Dst NCS1K Out Details of Rack/Slot/Card/Port in the output side of
the NCS 1004 chassis in the destination site

Dst NCS2K AddDrop Add/drop multiplexer and demultiplexer that is
connected to the NCS 2000 chassis in the destination
site

Dst NCS2K MPO MPO cable connecting the NCS 2000 chassis in the
destination site

Media Channel Media channel between the source and destination
sited

Notes More notes, if any

Trace Origin

Indicates whether the service connections are
user-created or imported through LNI.
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Spectrum Utilization and Path Finder

Table 37: Feature History

Feature Name Release Information Feature Description
Spectrum Utilization and Path Cisco ONP Release 24.3.1 The Spectrum Utilization and Path
Finder Finder introduces the Minimal

Map, a streamlined network
visualization tool focusing on
essential data points like Sites and
Fibers, enhancing usability and
performance. General Settings
now allow individual
customization, including default
map views and spectrum utilization
colors. The Path Finder/Selector
enables interactive path selection
with options for manual and custom
path finding for multiple routing
options. The Spectrum Utilization
provides a comprehensive
visualization of used spectrum,
while the Spectrum Finder helps
locate and apply available spectrum
across fibers, offering dual-view
capabilities and multiple selection
methods. These enhancements
collectively improve network
management, planning, and
resource optimization.

Spectrum Utilization and Path Finder introduces

* Minimal Map: streamlines network visualization tool focusing Sites and Fibers.
+ Path Finder/Selector: enables interactive path selection with options for manual and custom path finding.
* Spectrum Utilization: provides a comprehensive visualization of used spectrum.

* Spectrum Finder: helps to locate available spectrum across fibers and apply them on a Circuit or Media
Channel.

Find a Custom Path

The Custom Path Finder is accessible exclusively through the Minimal Map. When you choose the custom
path finder, the detailed map automatically switches to the Minimal Map.

Limitations
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Procedure

Step 1
Step 2

Step 3

Step 4

Step 5

Design and Analyze Networks |

* Applies to only Circuits (NCS1010/NCS1001), Waves (NCS2000 NON-SSON), media channel (NCS2000

SSON).

The procedure to customize a fiber path on the map is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree, select the section of the media channel/circuit that you want to add a new path.

Click the Ellipsesicon and select Custom Path Finder.

The Custom Path Finder for the selected section opens.

In the Visualization area, choose the required map view.

Map View Result

Complete Map Shows a complete network map of the selected path with
other sites.

Sub Map Shows only maps with chosen sites and fiber.

In the Options area, choose the required parameters to calculate the Path Finder.

Option

Description

Minimum Hop

Performs all the routing based on minimum number of hop
counts, irrespective of length of fibers

Minimum Length

Performs all the routing based on fiber minimum length,
irrespective of hop count

Distinct Fiber Set

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Number of Path Count

Calculates the number of paths based on the provided
number

Click Calculate.

The list of paths calculated based on the chosen parameters displays.

The calculated paths table contains the path parameters.

Table 38: Path Parameters

Parameter Description
S.No Displays the serial number
Path Displays fiber path direction based on chosen Options parameters
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Parameter Description

Funnel icon Filters the path based on fiber labels
Hops Provides the hop count

Total Length Provides the total length of the fiber path

Step 6 Click Export to export the chosen fiber path.

Step 7 In the Selected Serviceand Path area, check the service and path information and click Apply Path to apply the selected
path.

Select Path Manually

The Manual Path Selector is accessible exclusively through the Minimal Map. When you choose the manual
path selection, the detailed map automatically switches to the Minimal Map.

Limitations

* Available in Design and Upgrade modes where circuits path can be updated.

* Applies to only Circuits (NCS1010/NCS1001), Waves (NCS2000 NON-SSON), media channel (NCS2000
SSON).

* Applies to regen circuits/waves/media channel.

+ Additional options are applicable for Section under Network Tree.

The procedure to select a path manually on the map is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, select the section of the media channel that you want to add a new path.
Step 2 Click the Ellipsesicon and select Manual Path Selection.

Step 3 In the Search field, enter the site or fiber to focus on it.

Step 4 Select the required the fibers to create a path.

The selected fibers appear on the Operation M odes pop-up pane under Fibers area.

Step 5 Click Apply.
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View Spectrum Utilization and Spectrum Finder

The Spectrum Finder is accessible exclusively through the Minimal Map. When you choose the spectrum
finder, the detailed map automatically switches to the Minimal Map.

Procedure

Step 1
Step 2

Step 3
Step 4

Step 5

We recommend that you use the Spectrum Finder for the network in Design/Upgrade/Release Upgrade Mode
and view the Spectrum Utilization in Analyze Mode.

The procedure to view the spectrum utilization and find a spectrum to apply for a service is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree, select the section of the media channel that you want to learn the spectrum utilization per fiber.

Click the Ellipsesicon and select Spectrum Finder.

The Spectrum Finder for the selected section opens.

In the Selected Fibersarea, click +Add Fiber and choose t
In the Visualization area, choose the required map view.

he required fibers from the drop-down list.

Map View Result

Complete Map Shows a complete network map of the selected path with
other sites.

Sub Map Shows only maps with chosen sites and fiber.

In the Spectrum Finder area, modify the parameters as req

uired..

Option

Description

Tabular View

Similar to Spectrum Utilization View

Detailed View

Displays multiple fibers in a vertical orientation (Y-Axis)
and the spectrum on the horizontal axis (X-Axis).

Spectrum Selection

Enable Spectrum Selection to modify the subsequent
parameters.

Spacing

Enter the bandwidth (GHz) that is required for the network
circuit.

Distinct Fiber Set

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Number of Path Count Calculates the number of paths based on the number
provided
Allow Overlap Allows you to select overlapping wavelengths with selected

fibers, when enabled.
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Option Description

Zoom Zooms in and out of detailed view to granular view. Click
Default reset zoom.

View Labels Displays the labels. Enable to view the labels. You can also

view the labels of existing occupied circuits.

Hovered Spectrum

Shows the start, end, and central wavelengths (THz) of the
hovered spectrum when moving across the view

Selected Spectrum

Shows the start, end, and central wavelengths (THz) of the
selected spectrum when selecting across the view.

C-Band

Toggle to view the C-band spectrum usage.

L-Band

Toggle to view the L-band spectrum usage.

Fiber Utilization Graph

Displays the frequency utilzed in a fiber for each span in
continuation in a vertical axis. Each square block is
3.125GHz. The frequency range starts from the left and
continues towards the right, increasing 3.125GHz per block
for both C- and L-band.

For C-band, the first row has the starting frequency as
191.325 THz. A single row contains 53 blocks, totalling
0.165625 THz ( 53*3.125 GHz). The starting frequency of
subsequent rows increment at 0.165625 GHz.

Color tone of the blocks varies in the Fiber Utilization Graph

red

Dark |Indicates overlap of same spectrum across multiple waves.

red

Light |Indicates less spectrum usage.

Step 6 In the Apply Propertiesto Existing Servicearea, check the service parameters and click Apply Wavelength and Apply

Path.

Click Apply Wavelength and Apply Path to revert the changes.

Step 7 Select Apply to Service.

Regenerate BoM Automatically

You can view the new Chassis or Card added to the existing layout under the BOM tab. You can also view
the regenerated BoM after manual editing of the layout.
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. Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM

Add new Pluggables, Alarm Cables and 100G Client Bandwidth
Licenses to BoM

Procedure

Step 1

Step 2
Step 3

Step 4
Step 5

Step 6
Step 7
Step 8

You can add new pluggables, alarm cables and 100G bandwidth licenses of NCS 1004 and NCS 4000 platforms
to the existing BoM.

The procedure to add new pluggables, alarm cables and 100G client bandwidth licenses to the existing BoM
is as follows.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network to open from the list of available networks.
Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Click the BOM tab.

Click Add.

The New window opens.

Enter the Cisco part number of the pluggable or alarm cable or 100G bandwidth license in the Cisco Part Number field.
Choose the Quantity of pluggables or alarm cables or 100G bandwidth licenses to be added.

Click Add.

The new pluggables or alarm cables or 100G bandwidth licenses are added to the BoM list.

Export IPC Report

You can export the connections of a current site or all sites to an Excel sheet using the following procedure:

Before you begin

Log in to Cisco ONP web interface, on page 7
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Procedure

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.
Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note
The network must be successfully analyzed to proceed further.

Step 4 Click the Layout > | PC tabs.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

The patches that you click are highlighted in the rack.

Step 5 Hover over the Export icon, and click Current site or All Sites option.

The Export | PC dialog box appears.

Step 6 Click Continue to export the connections of the current site or all sites.

The cable-type and Cable ID are included in the report only for the NCS 1010 network.

Edit the Layout Manually for NCS 1010 Networks

Table 39: Feature History

Feature Name Release Information Feature Description
Layout Edit Support for NCS 1010 | Cisco ONP Release 5.0 Cisco has introduced NCS 1010 as
Networks a new optical line system to meet

the growing optical network needs.
Using Cisco ONP you can visualize
and edit layouts for NCS 1010
chassis and patch panels.

The Manual layout edit feature is used to adjust the position of the NCS 1010 chassis and patch panels in the
layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure
Step 1 Choose File> Open.
The Select Network To Open dialog box appears.
Note
You can also create a new NCS 1010 network. For more information, see Manually design a network using Cisco ONP,
on page 24.
Step 2 Click the network to open from the list of available networks.
Choose the NCS 1010 network.
Step 3 Choose Network > Analyze.
Note
The network must be successfully analyzed to proceed further.
Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 In the left panel, click a site.
Step 7 Select a unit (NCS 1010 chassis or patch panel) using one of the following methods:
* In the left panel, expand the rack under a site and choose a unit.
* Or, in the Rack view, click a chassis or patch panel.
Step 8 To adjust the position of the selected units, use one of the following methods:

Note
If necessary, click the +New Rack button to create more racks.

* In the Rack view, drag and drop the selected chassis or panel from a particular rack to the empty slot in the same
or different rack.

* Swap units in the Rack view:
* Click a transponder or NCS1K14-CCMD-16 card.
The Swap with button appears.

* Click Swap with and select a slot to swap from the drop-down list.

Note
The Swap with button appears only for NCS 1014 and NCS 1020 chassis.

* Cut and Paste unit in the left panel:
* Click Cut above the Rack view.

* Right-click on an empty slot in the same or different rack and click Paste.

Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.
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Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Cut and Paste unit in the Rack view:
* Right-click the selected chassis or panel and click Cut.
* Right-click on an empty slot in the same or different rack and click Paste.
Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Move the unit in the left panel:

« Go to Moveto > Site-X > Rack-X above the Rack view to move the chassis to the same or different rack.
Or go to Moveto > Site-X >+ New rack above the Rack view to move the chassis to a new rack.

* Move the unit in the Rack view:

* Right-click the selected chassis or panel and go to Moveto > Site-X > Rack-X to move the chassis to the
same or different rack. Or go to Moveto > Site-X >+ New rack to move the chassis to a new rack.

Note
The Move to option moves the unit automatically to the immediate empty slot. The Cut and Paste option moves the
unit to the selected empty slot.

Step 9 Click Done to save the changes in the Layout.

A warning message appears when empty racks are present in the layout.

Step 10 Click OK to remove the empty racks.

View Internal Node Connections of NCS 1010 Network

Table 40: Feature History

Feature Name Release Information Feature Description
View Internal Node Connections | Cisco ONP Release 5.0 The Node diagram tab displays a
of NCS 1010 Network functional view that includes

precise connections and port
labeling of each component such
as OLT or ILA,
NCS1K-BRK-8/16/24,
AAWG-32-0, and AAWG-32-E,
for each site in an analyzed NCS
1010 network.

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure

Step 1 ChooseFileOpen.
The Select Network To Open dialog box appears.

Step 2 Click the analyzed NCS 1010 network.

The network opens.

Step 3 Choose Network > Analyze.

Note
Network must be successfully analyzed to proceed further.

Step 4 Click the Layout > Node Diagram tabs.

Step 5 Click each site in the left panel and select a side to view the functional view of the site.
The functional view includes both the combination of physical and logical connections such as:

* Degree interconnections between NCS1010 (OLT or ILA) and NCS1K-BRK-8
* Add/drop connections between NCS1010 and colorless add/drop units (NCS1K-BRK-8, NCS1K-BRK-16, or
NCS1K-BRK-24) and colored add/drop units (AAWG-32-O or AAWG-32-E)

Step 6 Hover over the cable to view the details such as name of the ports that are connected and the cable ID.

Designing networks with COSM card

The COSM card, along with application software, provides functionality-based licenses for features such as
alarm correlation, performance monitoring, connection verification, and Optical Time Domain Reflectometry
(OTDR). You can design networks with ROADM and TRAFFIC nodes equipped with COSM cards.

From Release 25.1.1, SVO card is referred as COSM card.

Features of the COSM card:
» The COSM card occupies two slots.

* It serves as the primary card for all networks starting from Release 12.1.0.

* For high availability, a node can be equipped with two COSM cards, but they cannot be in the same
chassis.

* Two 10G SFP+ pluggables can be used to connect two COSM cards within a node.
* You can connect a Cisco ASR 920 Switch to the COSM cards during network design.

» The COSM can function as either a card or a UCS-based solution.
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COSM Licenses:

From 25.1.1, one COSM license PID OAS-COSM-MLCL is added for each active card present in the chassis
like M15, M6, M2, 1010, 1020, 1014, and 1004.

SVO0 Licenses
SVO licenses are applicable for NCS 2000 networks until Release 12.3.1.

* SVO cards require either a Base License or an SVO Full License (which covers High Availability,
Connection Verification, and Flex Spectrum). If the SVO Full License is not selected, the SVO Base
License and High Availability are enabled by default.

* Types of SVO licenses include:
* Cisco NMS: Features High Availability, Connection Verification, Flex Spectrum, and OTDR.

* Third-Party NMS: Includes NBI (North Bound Interface), Alarm Correlation, Performance
Monitoring, and Circuit Provisioning.

Chassis Licensing:

* Every chassis added to the network must be licensed from Release 12.1.0 onwards. For networks upgraded
to Cisco ONP Release 4.0 or higher, a new chassis license is required after analysis.

* Chassis licenses come in variants such as 1-chassis, 5-chassis, 10-chassis, 20-chassis, 50-chassis, and so
on, chosen based on cost optimization.

* A license is required for each chassis added to the network beyond the first.

* Chassis License Flush Out: Existing chassis licenses can be flushed out and replaced with new ones. The
current license remains active if the site is unlocked, but flush-out is only supported in network upgrade
mode.

* You can continue using existing licenses with changes to the chassis unless you opt for the Chassis
License Flush Out option.

)

Note Chassis Licensing and SVO Licenses are applicable until Release 12.3.1.
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Cisco Optical Site Manager associations

Table 41: Feature History

Feature Name

Release Information

Feature Description

Cisco Optical Site
Manager enhancements

Cisco ONP Release 25.1.1

Cisco ONP has been enhanced to support COSM
line card connectivity from ROADM nodes to
various site types. A ROADM node equipped with
a COSM card can now manage upto 14 additional
OLA and ROADM nodes. Previously, this was
limited to OLA-to-ROADM associations. The node
with the COSM card acts as the primary node.

The new COSM High Availability options
available under the Site properties, such as Auto,
Local HA, None, Only Active, and Geo HA enable
more dynamic and rule-based association in the NCS
2000 network.

From Release 25.1.1, Cisco ONP has been enhanced to support COSM line card connectivity from ROADM
or Traffic nodes to various site types. A ROADM or Traffic node equipped with a COSM card can now
manage upto 14 additional OLA, Traffic, and ROADM nodes. Previously, this was limited to OLA-to-ROADM
and Traffic-to-OLA associations. The node with the COSM card acts as the primary node.

This connectivity enhancement can be implemented in three ways:

1. Automatic COSM associations: Cisco ONP automatically selects a primary node if the fiber property
DCN Extension is enabled or if the node has the highest number of degrees. Up to 15 nodes can be
associated with a single primary node. If there are more than 15 nodes in the network, Cisco ONP will
identify another primary node.

2. Manual association in Network Tree and Map: You can manually associate nodes within the network
tree and map. See Associate sites with COSM cards, on page 101

3. Association through COSM High Availability property: The association options are available under
the High Availability drop-down list, applicable to both SSON and non-SSON NCS 2000 networks. The

options include:

* Auto: Based on analysis and default behavior.

* Local HA: Both active and standby COSM cards are placed on the same node.

* None: No COSM card present.

* Only Active: No High Availability. Only Primary COSM card is added.

* Geo HA: COSM cards are placed in two different sites located at different geographical locations,
but adjacent to each other.

The Geo HA feature offers two selectable values: Primary and Secondary. These rules and behaviors apply:

Rules and Behavior:
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Associate sites with COSM cards .

1. Primary HA check box:
* Selecting this check box designates a site as the Primary.

* Adjacent sites will automatically be considered as Secondary.

2. Autore-assignment:

« [f a Primary node selects a different node as its new Secondary, the previous association is
automatically removed.

Associate sites with COSM cards

Procedure

Step 1

Step 2
Step 3

Use this task to associate OLA and ROADM sites with the COSM cards:

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree panel, click the EllipsisSicon available in the right side of any ROADM or Traffic site with COSM
card.

Click Edit COSM Associations.
Select thesites on the map to toggle the COSM connections. Click Done at the top-right corner to confirm the selection.
You can associate up to 14 nodes with a single ROADM or Traffic node equipped with an COSM card. To associate

more than 14 nodes, you will need an additional primary node to manage the extra nodes. You can open widgets in the
map and select top section to view the association.

Note
You can also right-click any ROADM or Traffic site from the Map and click Edit COSM Associations. For the sites
that are of DGE type, the Edit COSM Associations option is not displayed.

The tool associates the sites that are not associated by you, with the COSM card during the network analysis.

Export Device NETCONF XML File

You can export the NETCONF (Network Configuration Protocol) XML files for all the individual sites in a
network or the complete network. The following procedure shows how to export NETCONF XML files for
the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Cisco Optical Network Planner Configuration Guide, Releases 25.x.x [Jj



Design and Analyze Networks |
. Export Device NETCONF XML File

Table 42: Feature History

Feature Name Release Information Feature Description

ALC2 Enhancements Cisco ONP Release 25.1.1 The NETCONF XML file exported
for the analysed NCS 1010 network
design with Microsoft configuration
now includes a new parameter.

* OTDR-ScanMode-Expert

If you enable the Enable Special
Settings check box under Network
level properties, the generated
XML file contains the
OTDR-ScanMode-Expert is set to
multi-region when the when
Microsoft Configuration is enabled.

If you do not enable the Enable
Special Settingscheck box, then
scan mode config is not added to

device Netconf XML.
Table 43: Feature History
Feature Name Release Information Feature Description
New Parameters Included in NCS | Cisco ONP Release 24.3.1 The NETCONF XML file exported
1010 NETCONF XML file from the NCS 1010 network design

now includes these new parameters
to support seamless Day-0
provisioning and the setup of a new
node added to the network.

* Optical cross-connects

* Gain range margin

* Tone Rates

* Raman tuning configurations
* Slot reserve

* Dmux WSS attenuation

* Unused CCMD-16 ports
shutdown

* Span baseline-deviation
* OTDR Thresholds

* APC Span-loss correction
threshold

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Design and Analyze Networks

Procedure

Step 1

Step 2

Step 3

Export Device NETCONF XML File .

Table 44: Feature History

Feature Name Release Information Feature Description
Export NETCONF File from NCS | Cisco ONP Release 5.0 You can export the NETCONF
1010 network XML files for all the NCS 1010

nodes, and upload them to the NCS
1010 nodes through the Yang suite.
This enables automatic bring up of
the NCS 1010 nodes using the
NETCONF data.

The network must be in Analyze mode.

In the network tree panel, click the three dots.
A pop-up list appears.
In the list, click Generate Device NetConf XML.

Export window appears with network name.

Click Export.

The message, "Success. Device NetConf exported successfully" appears.
You can download the zip file that contains NETCONF XML files of individual sites.

Note
You can choose the destination folder to save the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Note
For C+L Network, the partner band configurations are not part of the Cisco ONP-generated XML file. You must manually
configure the partner bands on the devices while bringing up the NCS 1010 C+L network.

From Release 24.3.1, the following new parameters are available in the NETCONF file exported from the NCS 1010
network design:

* OSC TX Power

* Optical Cross Connect

* OTS tone rate

* OMS tone rate

* OTS tone pattern expected
* OTS tone detect OOB

* OTS tone pattern

* OTS tone frequency
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* Raman pump configurations
* Line port attenuation

* Raman dual safety

The following parameters are available only when you have enabled the Enable Special Settings check box under
Network level properties.

* Raman turnup

* OTS ports shutdown

* OTDR autoscan

* Gain range margin

* OTDR excess attenuation threshold
* OTDR end of fiber threshold

* Slot reserve

* Dmux WSS attenuation

* Unused CCMD-16 ports shutdown
* Span baseline-deviation

* OTDR Thresholds

» APC Span-loss correction threshold
* OTDR-ScanMode-Expert

Upload NETCONF XML Files on COSM Web Interface

The following procedure shows how to upload the NETCONF XML files on the COSM web interface:

Procedure

Step 1 In the browser URL field, enter the IP address of the COSM line card.
The login page appears.

Step 2 Enter the username and password.

Step 3 Click L ogin.

Step 4 Click the hamburger icon at the top-left of the page, and select Node Configuration.

Step 5 Click the Node Setup tab.

Step 6 Click Select files.

Step 7 Browse to the NETCONF XML files exported from the Cisco ONP GUI and upload them.
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Export Device NETCONF XML Files for Individual Sites .

If the passive unit ID in the NETCONEF file exceeds the range 1-126, COSM displays an error message. Validate the
XML file and reimport.

Note

If the value of FEC mode already provisioned in the 200G-CK-C line card does not match with the value available in the
NETCONF XML file, COSM displays an error message. We recommend that you remove the provisioned FEC settings
for this card and reimport the XML file.

Export Device NETCONF XML Files for Individual Sites

Procedure

Step 1
Step 2

Step 3

The following procedure shows how to export Device NETCONF XML files for individual sites from the
Cisco ONP GUI.

Before you begin
Log in to Cisco ONP web interface, on page 7.

The network must be in Analyze mode.

Click the Ellipsisicon available in the right side of the site.
In the list, click Generate Device NetConf XML.

Export window appears with network name.

Click Export.
The message, "Success. Device NetConf exported successfully" appears.

You can download the zip file that contains Device NETCONF XML files of individual sites.

Upload NETCONF Files to NCS 1010 Device

Procedure

Step 1
Step 2
Step 3

Use this task to upload the NETCONF files that downloaded from Cisco ONP into the NCS 1010 device using
a NETCONF client.

Log in to the NETCONF Yang Suite which has access to the NCS 1010 device.
Connect to the NCS 1010 device.

Copy the NETCONF XML file content that is downloaded from Cisco ONP, and paste it into the Protocol NETCONF
Run RPC block.
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Step 4

Append the following commit code at the end of the NETCONF XML file content.

Design and Analyze Networks |

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="102">

Export Cisco Optical Site Manager NETCONF XML File

You can export the Cisco Optical Site Manager NETCONF XML files for all the individual sites in a network
or the complete network. The following procedure shows how to export Cisco Optical Site Manager NETCONF

Procedure

Step 1

Step 2

Step 3

XML files for the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Table 45: Feature History

Feature Name

Release Information

Feature Description

Export Cisco Optical Site Manager
(COSM) NETCONF File from
NCS 1010 network

Cisco ONP Release 5.2

The new Generate COSM
NetConf XML option allows you
to export from the Cisco Optical
Network Planner, the Cisco Optical
Site Manager NETCONF XML
files for all the NCS 1010 nodes.
You can then upload these files to
the NCS 1010 nodes through the
Cisco Optical Site Manager,
enabling automatic bring-up of the
NCS 1010 nodes.

The network must be in Analyze mode.

In the network tree panel, click the three dots.

A pop-up list appears.

Export window appears with network name.

Click Export.
The message, "Success. COSM NetConf exported successfully" appears.

In the list, click Generate COSM NetConf XML.
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Upload Cisco Optical Site Manager NETCONF XML to NCS 1010 Device via Cisco Optical Site Manager Web Interface .

You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files of
individual sites.

This feature has limited scope in this release.
Note

* For the ROADM OLT node, the device name is generated in the Site Name-Side Name format.

* For the OLA node, the device name is same as the Site Name.

Align the device name in COSM accordingly.

If the Site Name contains any special character, the XML file replaces the special charcter with its ASCII value in the
COSM XML device name to allow seamless experience with COSM data backup workflow.

Note
L-Band Configuration is not certified in Cisco Optical Site Manager for R7.11.1. A future release will be considered for
the L-Band configuration.

Upload Cisco Optical Site Manager NETCONF XML to NCS 1010
Device via Cisco Optical Site Manager Web Interface

Procedure

Step 1
Step 2

Step 3
Step 4

Step 5
Step 6

Step 7

Use this task to upload the Cisco Optical Site Manager NETCONF files that you downloaded from Cisco
ONP into the NCS 1010 device using the Cisco Optical Site Manager web interface.

Before you begin

Log in to Cisco ONP web interface, on page 7

Log in to the Cisco Optical Site Manager UI that has access to the NCS 1010 device.
Cross-check the device name, UID, and card layout position (Rack ID, RU Position) with CONP XML.

The Cisco Optical Site Manager device name and UID should match with the CONP XML. If any mismatch exists,
delete the device from Cisco Optical Site Manager and add back with name and UID as in the CONP XML.

Go to Optical Setup and browse the CONP-generated XML without OXC for that device and load it.
Click the Select files... button.

The file explorer window appears.

Select the CONP-generated Cisco Optical Site Manager XML from your local device.
Click Open.

A confirmation message appears.

Click Yes.
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. Export NCS 1010 network planning data for Cisco Optical Network Controller

Step 8 Click Upload.
The COSM XML successfully uploaded message appears.

Step 9 Go to Optical Configuration > ANS parameter and verify whether the respective configurations are complete.

Step 10 After loading the Cisco Optical Site Manager XML file without optical cross connect, load the Cisco Optical Site
Manager XML with optical cross connect.

Step 11 After adding the Cisco Optical Site Manager XML file with optical cross connect, go to the Optical Cross Connections
tab and verify whether the respective configurations are complete.

Export NCS 1010 network planning data for Cisco Optical
Network Controller

Table 46: Feature History

Feature Name Release Information Feature Description

Export NCS 1010 Network Cisco ONP Release 5.0 You can export the planning data
Planning Data for Cisco Optical of NCS 1010 network, in the form
Network Controller (Cisco ONC) of a JSON file. This JSON file can

be uploaded into Cisco ONC to
configure the managed devices in
bulk.

Use this task to export the planning data of NCS 1010 network, which is in the form of JSON file from Cisco
ONP. This JSON file is uploaded into Cisco ONC to configure the managed devices.

You can export the planning data of NCS 1010 network only for the releases 7.7.1 and 7.9.1.

Before you begin
Log in to Cisco ONP web interface, on page 7.

The network must be in Analyze mode.

Procedure

Step 1 In the network tree panel, click the Ellipsisicon available in the right side of the network name, and select Generate
CONC JSON .

Step 2 In the Export File dialog box, enter the name of the JSON file, and click Export to download the JSON file into your
local system.
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Upload Planning Data into Cisco ONC .

Upload Planning Data into Cisco ONC

Use this task to upload the network planning data (JSON file) downloaded from the Cisco ONP.

Procedure

Step 1 Log into Cisco ONC.

Step 2 Hover over the Import icon in the left panel and click Planning Data Import.
Step 3 Click Import.

Step 4 Browse and select the JSON file that is downloaded from Cisco ONP.

You can use the planning data to configure the devices managed by Cisco ONC.
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Modify Network Properties
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. Modify Network Properties

Modify Network Properties

Table 49: Feature History

Feature Name Release Information Description

Improved Optical Results Cisco ONP Release 24.3.1 The new network-level properties
introduced improve the accuracy of
the optical results.

* Ignore APC Penalty: When
enabled, the APC penalty is
not considered while
calculating the OSNR and
power margin.

* SOL Optimized PSD: When
enabled, an optimum PSD
value is calculated by
considering the SOL Span
losses.

Also, Cisco ONP sets PSD and
drop attenuation to specific values
for the CCMD-16 LC card
connected to the ports of the
OLT-E-C, to achieve optimal RX
power for the circuits.
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Feature Name Release Information Description
Skip Routing Failures in NCS 2000 | Cisco ONP Release 24.3.1 A new Continue AnalysisOn
Network Analysis Routing Failure check box is

introduced to improve network
analysis reliability for larger NCS
2000 networks. When a routing
failure occurs, this enhancement
moves the network to Partially
Analysed mode, and move the
network to Design or Upgrade
mode to edit properties and correct
routing.

After the analysis,

* successful routing paths
appear in the BOM and
Optical Reports tabs.

« failed routing paths are not
listed in these tabs.

« error messages for the
individual routing failures
appear in the M essages tab.

» red cross marks appear next to
the failed routing paths.

This approach prevents a single
failure from failing the entire
analysis, isolating specific issues to
enhance troubleshooting.
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Table 50: Feature History

Feature Name Release Information Description

New Network Level Properties Cisco ONP Release 5.2 New Network Level properties are
introduced under Advanced
Optical Settings for NCS 1010
network. You have the flexibility
to define custom values for the
following properties for the Raman
span and validate the optical circuit
feasibility.

« Amplifier Gain Range
» Connector Loss
* Minimum OSNR Margin

* Minimum Span L oss for
Raman Amplifiers

* Percentage of Fiberswith
Higher Aging Loss

« Generate Cross-Connect

« Maximum OSC Reach for
NCS1010Raman Amplifiers

» Retain Auto Placed Raman
Spansfor Failure

* Freq Allocation Order
» Link Power Control
» Gain Estimator

+ OTDR
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Table 51: Feature History

Feature Name Release Information Description

New Bandwidth Properties Cisco ONP Release 5.1 Cisco ONP introduces the
Statistical Simulation Sigma,
Statistical Simulation Margin
Sigma, and OSNR Resolution
Bandwidth properties in this
release. When the ideal OSNR
values calculated by Cisco ONP are
not feasible to be used at the time
of deployment, you can modify the
values for these properties to
customize OSNR margin, power
margin, and G-OSNR values to fix
the fiber span issues.
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Feature Name Release Information Description

New Network Level Properties Cisco ONP Release 5.1 Three new Network Level
properties are introduced to enable
you to customize the core
operations of an NCS 2000
Network. These operations ran in
the background in the earlier
releases. The new properties
available under Core Operations
as check boxes are:

+ Enable LOGO
Algorithm—It runs the Local
Optimization Global
Optimization (LOGO)
algorithm to find the efficient
output power setpoint for
booster amplifiers. By default,
this Enable LOGO
Algorithm check box is
enabled.

L og Enabled—It generates,
and stores logs only for
selected network topologies.
This saves a lot of storage
space compared to previous
implementations in which logs
were automatically generated
and saved for all topologies.

Ignore Raman Span
Checks—It ignores the
analysis of Raman spans
between ROADM sites. This
is useful when designing
nonstandard network
topologies with more than two
Raman amplifiers between
ROADM sites. Selecting the
check box prevents Cisco
ONP from raising an error
message when analyzing such
topologies.
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Feature Name Release Information Description

BOM Customization for the Cisco ONP Release 5.1 From this release onwards, the
UCS-based SVO Server BOM does not include any
Application UCS-based SVO server

information. It is expected that you
add the server PID and quantities
manually. Cisco ONP prompts you
to add the server by displaying the
message "UCS server isnot billed
in BoM, please add it as needed."
in the M essages tab of the

Elementstab.
Use this task to modify the properties of the network.
Before you begin
Log in to Cisco ONP web interface, on page 7.
Procedure
Step 1 In the network tree, click the network name.
You can view the basic properties of the network at the bottom of the network tree.
Step 2 Modify the following network properties as required.
Property Platform Description
Name NCS 2000 Modify the network name as required.
NCS 1010
NCS 1001
Quick Analysis NCS 2000 Check the Quick Analysischeck box to quickly analyze

the network by using a less accurate algorithm.

The quick analysis option does not optimize the DCU and
amplifier placement algorithm, hence resulting in an
approximate BoM.

To receive an accurate BoM, uncheck the Quick Analysis
check box.
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Modify Network Properties |

Property Platform Description
DWDM Interfaces NCS 2000 Cisco ONP supports 100G and 200G transceivers as DWDM
interfaces.
This option is applicable only for automatically created
waves, when OTN services are present.
* 100G—The entire network chooses the 100G
wavelength for transmission.
* 200G—The entire network chooses the 200G
wavelength for transmission.
If you enable both 100G and 200G options, by default, the
entire network chooses the 200G wavelength for
transmission. If the 200G wavelength is not optically
feasible, then it selects 100G automatically for transmission.
Customer Name NCS 2000 Enter the customer name.
NCS 1010
NCS 1001
Project NCS 2000 Choose ANSI (North American standard) or ETSI
(European Telecommunications Standards Institute) from
the drop-down list. ANSI networks do not allow you to
define SDH (ETSI) service demands. ETSI networks do
not allow you to define SONET (ANSI) service demands.
NCS 1010 Displays the type of the project, ANSI, or ETSI. You cannot
NCS 1001 edit it.
Measurement Unit NCS 2000 Select the unit of measurement of span length. The available
NCS 1010 options are Miles and Km.
NCS 1001
Chassis Type NCS 1010 Choose the type of chassis. The available options are:
* NCS 1010
* NCS 1020
Note
When you check the Enable Special Settings check box,
NCS 1020 is selected as Chassis Type by default.
NCS1014 Grouping NCS 1010 Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.
NCS 1014 Enable this property to group all the NCS 1000 transponder

cards of a site in NCS1014 shelf.
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Property

Platform

Description

A2A Mode

NCS 2000

Choose the A2A (Any to Any) mode. The available options
are:

*+ A2A None
*+ A2A FAST

A2A Power Output

NCS 2000

The power output value is based on the chosen A2A mode.

A2A Demand Type

NCS 2000

The demand type is based on the chosen A2A mode.

A2A Channel Type

NCS 2000

Choose the type of channel. You can choose multiple types.
The available options are:

* Contentionless—This property enables an N-degree
ROADM node to accommodate N wavelengths of the
same frequency from a single add or drop device.

* Colorless—The colorless property enables tuning of
channel wavelengths without changing the optical
interface of the port.

* Colored—The Colored property dedicates a separate
port for each wavelength.

SSON

NCS 2000

Indicates whether the network is an SSON network.

Use client Payg

NCS 2000

Check this check box to enable the Pay As You Grow
feature on the client cards.

The PAYG feature enables you to implement a
cost-effective solution when the wavelength requirements
are comparatively less than the maximum capacity of the
network. A standard card is configured to work on
maximum supported wavelengths, whereas a PAYG license
comprises license restricted cards and a base license. So,
instead of purchasing a standard card, you can purchase a
PAYG license.

Naming Convention Enabled

NCS 2000

(Display only.) By default, the Naming Convention Enabled
option is enabled by default for the networks that are created
in Cisco ONP, and you cannot edit it. By default, the sides
are named from T, S, R, Q, P, O,N,M, L, K, J, I, H, G, F,
E, and index, depending upon the used Scalable Upto
parameter.

* You can import a mpz network without naming
convention enabled, but the Cascaded SMR option
remains disabled.

* You cannot edit the label name of the side.

System Release
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Property Platform Description

NCS 1001 NCS 1001 Displays the system release of the NCS 1001 node in the
network.

NCS 1010 NCS 1010 Displays the system release of the NCS 1010 node in the
network.

NCS 4K NCS 4000 Displays the system release of the NCS 4000 node in the
network.

NCS 2K NCS 2000 Displays the system release of the NCS 2000 node in the
network.

NCS 1K (Available only on | NCS 1004 Displays the system release of the NCS 1004 node in the

the SSON network) network.

Previous NCS 2K (Available | NCS 2000 Displays the system release of the NCS 2000 node in the

only on the Release upgraded network, before the Release upgrade.

network)

Previous NCS 1010 NCS 1010 Displays the system release of the NCS 1010 node in the

(Available only on the network, before the Release upgrade.

Release upgraded network)

COSM NCS 2000 Line Card is the only option. You can edit this property.

Note
In Release 25.1.1, only Line card option is available. For
Release 12.x, both server and line options are available.

Network Application Configuration

Install with COSM NCS 1010 Enable I nstall with COSM to see software license for
COSM file for R7.11.1 networks.
Use Coordinates Distance | NCS 2000 Check this check-box to use the x and y coordinates to
NCS 1010 calculate the fiber length.
NCS 1001
Raman-Tuner NCS 1010 Check this check-box to enable the Raman tuner.
Spectrum Utilization NCS 1010 By default, the spectrum utilization is Short Path First. This

field is noneditable.
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Property

Platform

Description

Band Type

NCS 1010
NCS 1001

Choose the band type. The available options are:
* C-Band
* C+L Futuristic

«C+L

Note
After creation of a network, you can change the network
band type, if required.

NCS 1010 Line Card

NCS 1010

Choose the Line Card faceplate. The available options are:

* Standard Faceplate

* Enhanced Faceplate

The default option is Enhanced Faceplate. For R7.10.1

networks, Cisco ONP supports Enhanced NCS 1010 Line
Cards. For 7.11.1 networks, Cisco ONP supports Enhanced
NCS 1010 Line Cards and NCS1K 14-CCMD-16-C/L cards.

Routing Strategy

NCS 1010

Choose default routing priority for circuits based on
minimum distance (Length) or minimum number of hops

(Hop).

NCS1010 Line Card

NCS 1010

Choose the line card variant that will be applied to all edge
sides in the network. The options available are:

+ Standard Faceplate

* Enhanced Faceplate

Max Auto Omni Allowed

NCS 1010

Based on the number that you enter, Cisco ONP will
automatically generate up to that many Omni Edges and
run the analysis. There is no need for manual creation by
the user.

The default value is 0.

Probe Channel

NCS 1014

Choose the coherent probe pluggable to enable the probe
functionality. The available options are:

* DPO1QSDD-ZT5-Al

* None

Note

You can force the selected probe channel option at the
network level only. The selected option applies to all the
edges of all sites in the network and remains disabled at
the edge and site levels.
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Property

Platform

Description

OTDR Pluggable

NCS 1014

Choose the pluggable to enable OTDR functionality. The
available options are:

« ONS-QSFP-OTDR

* None

Note

You can force the selected OTDR pluggable option at the
network level only. The selected option applies to all the
edges of all sites in the network and remains disabled at
the edge and site levels.

Optical Algorithm Options

Stat Sim Sigma

NCS 2000
NCS 1010
NCS 1001

Choose the Statistical Simulation Sigma (Stat Sim Sigma)
value. The available options are 0, 1, 2, and 3. The default
value is 3.

The Stat Sim Sigma value is used in calculating the SOL
G-OSNR, EOL G-OSNR, SOL Power, EOL Power, SOL
OSNR margin, EOL OSNR margin, SOL Power margin,
and EOL Power margin displayed in the Optical Results
page. The lower the value you choose, the better is the
OSNR and power margins.

You can edit this value in Design mode, and Upgrade mode
(after unlocking the network). Analyze the network and
check the Optical Resultspage to view the updated OSNR
and Power values.

Stat Sim Margin Sigma

NCS 2000
NCS 1010
NCS 1001

Choose the Stat Sim Margin Sigma value. The available
options are 0, 1, 2, and 3. The default value is 3. You can
edit this value in all modes (Design, Analyze (locked state),
Upgrade, and Release Upgrade). To view the OSNR margin
and power values that get updated based on the value you
selected, reopen the Optical Results page.

Core Operations

Enable LOGO Algorithm

NCS 2000

By default, this property is enabled. In non-SSON networks,
it is editable. In the SSON network, it is noneditable. This
algorithm enables the Cisco ONP to automatically find the
optimal output power setpoint for booster amplifiers within
a fiber span.

Log Enabled

NCS 2000
NCS 1010
NCS 1001

Check this check-box to enable generation and storage of
network logs.
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Routing failure

Property Platform Description

Ignore Raman Span Checks | NCS 2000 Check this check-box to enable network analysis to ignore
Raman span checks.

Traffic Algorithm Options

Continue Analysis On NCS 2000 Check this check-box to skip routing demand failures when

analyzing the networks. Passed demands appear in the
Optical Reports tab, while failed demands are not listed in
the Optical Reportstab. Red cross marks appear next to the
failed demands in the network tree, and error messages for
these failures appear in the Messages tab. If any demand
fails during the analysis, the network enters the Partial
Analysismode. To edit the network, enter Design mode or
Upgrademode. It is recommended to use the Upgrademode
for retaining the already analysed results and data.

Note
If any non-routing issue is present in the network, then the
design network will not move to the Partial Analysismode

Advanced Optical Settings
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Property

Platform

Description

Enable Special Settings

NCS 1010

Check this check-box to enable the following properties
and set default values for them.

» Amplifier Gain Range Margin

* Connector Loss

* Minimum OSNR Margin

* Minimum Span loss for Raman Amplifiers

* Percentage of Fibers with Higher Ageing Loss
* Freq Allocation Order

* MC Routing Order

* Ignore APC Penalty

* SOL optimized PSD

If you check the Enable Special Settings check box, the
following parameters are added to the Device Netconf XML
file.

* Slot reserve

* Unused CCMD-16 ports shutdown
* Span baseline-deviation

* OTDR Thresholds

* Dmux WSS slice attenuation

* APC span-loss correction threshold

Amplifier Gain Range
Margin

NCS 1010

Enter the amplifier gain range margin.

The default value is 3 dB.

Connector Loss

NCS 1010

For all fibers the default connector loss would be set to 0.5
from 0.25.

The default value is 0.5 dB.

Minimum OSNR Margin

NCS 1010

Enter the minimum OSNR margin required for the amplifier.

The default value is 1 dB.

Minimum Span Loss for
Raman Amplifiers

NCS 1010

This is the minimum required span loss for fiber to be
considered for Auto Raman placement.

The default value is 27 dB.
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Property

Platform

Description

Percentage of Fibers with
Higher Aging Loss

NCS 1010

Click the field and enter the values for the following fields
in the Fiber Sorting Settings window:

* Percentage of Fibers with Higher Aging Loss (default
value is 40%)

» Ageing Loss for Top Fibers (default value is 3 dB)
» Ageing Loss for Bottom Fibers (0.75 dB)

Generate Cross-Connect

NCS 1010

Check this check-box to add Cross connect details in the
COSM XML

Raman Amplification

NCS 1010

Choose whether Raman amplification is Auto or User
Forced.

The default option is User Forced.

Maximum Auto Ramans

NCS 1010

Choose the maximum number of Raman enabled links on
an end-to-end circuit path. The available options are 0-5,
and ALL.

Maximum OSC Reach for
Raman Amplifiers

NCS 1010

Enter the maximum span loss for which fiber can be
considered for Auto Raman placement.

The default value is 33 dB.

Link Tuner

NCS 1010

Choose how to enable the Link Tuner. The available options
are Automatic-Enabled, Force-Disabled, and
On-Request-Enabled.

The default option is On-Request-Enabled, when the
Enable Special Settings check-box is checked, and the
Automatic-Enabled check-box is unchecked.

Ignore APC Penality

NCS 1010

By default this check-box remains checked, when the
Enable Special Settingscheck-box is checked. Automatic
Power Control (APC) penality occurs due to the inherent
error in regulating the set-point for power. This penalty is
considered while calculating the OSNR and power margin.
When this property is enabled, this penalty is ignored during
the calculation and thus providing accurate optical results.

Retain Auto Placed Raman
Spans for Failure

NCS 1010

In general, automatically placed Raman will be retained
only if the circuit becomes feasible with those Raman
placements. Otherwise, it will be removed automatically.
If you want to retain it, check this check-box.

It is disabled by default.
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Property

Platform

Description

Raman Gain Auto Tuner

NCS 1010

Choose how to calibrate the Raman gain. The available
options are Automatic, Automatic-On-request, and
No-calibration.

The default option is No-Calibration.

SOL Optimized PSD

NCS 1010

By default this check-box remains checked, when the
Enable Special Settings check-box is checked. When
enabled, an optimum PSD value is calculated by considering
the SOL Span losses.

Freq Allocation Order

NCS 1010

Choose the Freq Allocation Order. The available options
are:

* FROM-LOWER-FREQ
* FROM-HIGHER-FREQ

The default option is FROM-HIGHER-FREQ.

Link Power Control

NCS 1010

Choose how to enable the Link Power Control. The
available options are Automatic-Enabled, Force-Disabled,
and On-Request-Enabled.

The default option is On-Request-Enabled , when the
Enable Special Settings check-box is checked, and
Automatic-Enabled when the check-box is unchecked.

Gain Estimator

NCS 1010

Choose how to enable the Gain Estimator. The available
options are Automatic-Enabled, Force-Disabled, and
On-Request-Enabled.

The default option is On-Request-Enabled , when the
Enable Special Settings check-box is checked, and
Automatic-Enabled when the check-box is unchecked.

OTDR

NCS 1010

Choose whether to enable or disable the OTDR.
The default option is Enabled.

MC Routing Order

NCS 1010

Choose routing order for the multicarriers:

* CREATION: Based on the Freq Allocation Order
chosen, the tool allocates frequency based on order
carrier creation.

* NO-OF-CARRIERS: Based on the Freq Allocation
Order chosen, the tool allocates frequency to circuits
based on the number of carriers.

The default option is CREATION.

SSF Simulation

NCS 1010

Enable optical simulation using Split-Step Fourier(SSF)
algorithms for better OSNR margins.
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Property Platform Description
LUT Version NCS 1010 The default value is 1.1.3.
NCS 1014 * For NCS 1010, the network analysis can be done with

or without LUT. If you check Enable Special Settings
check box, then LUT is enabled. You can set LUT to
None. Otherwise, it will be non-LUT-based analysis.

* For NCS 1014, the network analysis is always
LUT-based analysis. Look-Up Table is noneditable.
You cannot unselect LUT.

Step 3 Click Update.

Step 4 To modify the advanced properties of the service, click Show Advanced Propertiesor choose Networ k > Entity Editor.
Step 5 In the Entity Editor window, click the Site tab.

Step 6 Click the network, and modify the properties in the right pane.

Step 7 Click Update.

Modify site properties

Table 52: Feature History

Feature Name Release Information Feature Description

M2 chassis support Cisco ONP Release 25.1.1 | You can now select M2 Chassis as Chassis Type
under the site properties for the NCS 2000 ROADM
and OLA nodes in SSON and non-SSON networks.
This is in addition to the M6 and M 15 chassis that
were supported previously.

M2 chassis is suitable for small sites where only
two slots are sufficient to meet the networking
requirements. It provides a compact and efficient
solution for locations with limited space or lower
capacity needs.
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Procedure

Table 53: Feature History

Modify Network Properties |

Feature Name

Release Information

Feature Description

Layer-2 SMR Enhancement to
Support Second and Third Port
Extension

Cisco ONP Release 5.2

This enhancement allows you to
extend the contentionless sides in
a ROADM site, increasing the
number of provisioned
contentionless sides in the NCS
2000 networks. New contentionless
sides increase the number of traffic
channels in the NCS 2000
networks. The new Reserve
Cascaded SMR Port property
reserves more SMR ports to extend
the Layer-2 contentionless sides in
a ROADM site.

Table 54: Feature History

Feature Name

Release Information

Feature Description

Shared SMR Port

Cisco ONP Release 4.2

You can enable the Colored
Add/Drop property. This feature
supports the use of contentionless
and colored demands that are
connected to the same port of an
SMR card. With the Shared SMR
Port enabled, you can create and
validate the contentionless and
colored configuration on a
16-degree SMR-20 node.

Before you begin

Use this task to modify the properties of the site.

Log in to Cisco ONP web interface, on page 7.

Step 1 In the network tree, expand Sites, and click a site.

You can view the basic properties of the site at the bottom of the network tree.

Step 2 Modify the following site properties as required.

Property

Platform

Description

General
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Modify site properties .

Property Platform Description

Name NCS 2000 Enter the site name, either alphanumeric or numeric.
NCS 1010
NCS 1001

Type NCS 2000 Choose the type of site. For example, ROADM, OLA,
PASSTHROUGH, or a Traffic site.

* You can add a passthrough site as a place holder. You
cannot add services or waves to this site and therefore
cannot generate the report. Later, you can convert the
passthrough site to a ROADM, OLA, or the Traffic
site in the design mode.

* OLA is an optical line amplifier site that is used only
for amplification. You cannot add service or waves on
this site.

* You cannot add a Traffic site of the type 4K-2K into
an SSON network.

NCS 1010 Choose the type of site. For example, ROADM, OLA, or
PASSTHROUGH.
NCS 1001 Displays the type of site.

MPO Cable NCS 1010 Choose the type of MPO cable. The options available are:

 Auto

* 16MPO-MPO

* 24MPO-MPO

Node Type NCS 2000 The default value is FLEX NG-DWDM for all nodes. This
field is noneditable.

Equipment Configuration NCS 2000 Choose the configuration from the drop-down list. This
option is available only for the Traffic site. The available
options are:

» Large CO - NCS 4016

* Small Site - NCS 4016

* Small Site - NCS 4009

Traffic Type (only for Traffic | NCS 2000 Choose the traffic type. The available options are:

site) « 4K_1K_2K (for SSON)

* 1K 2K (for SSON)

* 4K 2K (non- SSON)
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Modify Network Properties |

Property Platform Description
SSON NCS 2000 Indicates whether the network is an SSON network.
COSM NCS 2000 This property is noneditable at site level. This property
enables you to select an COSM card as Server or Line card
at the network level.
L ayout
Chassis Type NCS 2000 Choose the type of chassis. The chassis type is supported
for all the sites except the passthrough.
The available options are:
* M2 Chassis
M2 chassis does not support multichassis and
multidegree system.
* M6 Chassis
* M15 Chassis
* Auto
M15 is the default option when you choose Auto.
NCS 1010 Choose the type of chassis. The available options are:
* NCS 1010
* NCS 1020
NCS1014 Grouping NCS 1010 Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.
NCS 1014 Enable this property to group all the NCS 1000 transponder
cards of a site in NCS1014 shelf.
Power Supply NCS 2000 Choose the type of Power Supply. The available options
NCS 1010 are Auto, AC Power, and DC Power.
NCS 1001 The default option is Auto.
NCS 1014
UTS AC Power Cables NCS 2000 Choose the type of cables to be used for the AC power
NCS 1010 supply. Cables are listed based on the country type and the
Chassis type selected.
NCS 1001
NCS 1014
C Band
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Modify site properties .

Property

Platform

Description

Structure

NCS 2000

Choose the type of the site. The available options for
ROADM and Traffic sites are:

* Multi-degree
* Line

e Terminal

For OLA and PASSTHROUGH, it is Line, and you cannot
edit it.

NCS 1010

Choose the type of the site. The available options for
ROADM sites are:

* Multi-degree
* Line

e Terminal

For OLA and PASSTHROUGH, it is Line, and you cannot
edit it.

NCS 1001

Choose the type of the site. The available options are:

e Terminal
e Terminal-Section

» Terminal-Path

NCS 1014

Choose the type of the site. The default option is:

e Terminal

Functionality

NCS 2000

Displays the site functionality. Following is the functionality
available for each type of sites:

* Optical Cross Connect (OXC) for ROADM and traffic

site

* Auto or Line Amplifier for OLA site, Cisco ONP
downgrades OLA site to passthrough if OLA is not
required.

* Passthrough for passthrough site

NCS 1010

Displays the site functionality. ROADM is the default
functionality for all site types.

NCS 1001

Displays site functionality.
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Modify Network Properties |

Property

Platform

Description

Scalable up to Degree

NCS 2000

This parameter determines the maximum number of degrees,
ducts, or line sides that can be supported by the site.

For an NCS 2000 site, the available options are 2, 4, 8, 12,
and 16. The default option is 4. The network is scalable up
to 16 degrees for ROADM and Traffic sites. Choose 2 to
have a LINE ROADM site.

For OLA, the value is 2 and is noneditable.

NCS 1010

For an NCS 1010 site, the available options are 7, 9, 15,
17,23, 25, and 31.

If you choose Line Car d Faceplateas Enhanced Faceplate,
for NCS 1010 site, the available options are 3...15, 23, and
31.

Site Type

NCS 2000

Choose the type of site. The available options are:
* Auto

Note When you choose Auto, the default option is
SMR-20.

* SMR-20
* SMR-9

The Site type is Line for the OLA site.

NCS 1010

For NCS 1010 site, the only option is OLT, and it is not
editable.

NCS 1001

Displays the type of site, and it is noneditable.

L0 Platform

NCS 2000
NCS 1010
NCS 1001

Displays the platform. For example, NCS 1010, NCS 1001,
or NCS 2000.

Step 3 Click Update.

Step 4 To modify advanced properties of the site, click Show Advanced Properties, or choose Network > Entity Editor.

Step 5 In the Entity Editor window, expand Sitesunder the network tree, choose the site, and modify the following properties
that are displayed in the right pane. For more information on entity editor, see Entity Editor, on page 284.

Properties Platform Description

General

CLLI Code NCS 1004 Enter a string holding the CLLI code.
NCS 2000
NCS 4000
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Modify site properties .

Properties Platform Description
Site Address NCS 2000 Enter the site address.
NCS 1010
NCS 1001
Evolved Mesh NCS 2000 By default, this option is unchecked. When you enable this
feature on the network, it is automatically enabled on the
associated sites of the network.
Status NCS 2000 Displays the status of the network. It shows whether the
network is Up or Down.
Node Protection NCS 2000 Choose the Node Protection. The available options are:
* Same shelf
* Separated shelves
Mpol6Lc NCS 2000 Displays the fan-out module. The default option is
MF-MPO-16LC.
The MPO-16 to 16-LC fan-out module is a double slot
module with one MPO-16 connector (COM) and eight LC
duplex connectors. The MPO-16 connector is compatible
with the SMR20 FS EXP and 16-AD-CCO FS units.
Mpol6ToMpo8 NCS 2000 Choose the required Mpol6 to Mpo8 converter. The
available options are:
* MPO16ToMPOS8Cable
* MF-2MPO_ADP
MPO Cable NCS 1010 Choose the required Mpo cable. The available options are:
* Auto
* 16MPO-MPO
* 24MPO-MPO
Cascaded SMR NCS 2000 Enable this option to add Layer-2 contentionless sides.
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Modify Network Properties |

Properties

Platform

Description

Reserve Cascaded SMR Port

NCS 2000

Note

This property becomes available when you enable
Cascaded SMR for NCS 2000 networks from Release
11.1.x.

Choose the number of ports to reserve for the cascaded
SMR. The available options are:

* 1,2, and 3 if Scalable Upto Degree is 12 and 16.
* 1 and 2 if Scalable Upto Degree is 8.
* 1 if Scalable Upto Degree is 12 and 4.

Flex Spectrum

NCS 2000

By default, this check-box remains checked for a newly
created network. You cannot edit it.

Grooming Site

NCS 2000
NCS 4000

When you enable this option, it indicates that OTN traffic
can be groomed at this site.

MR-MXP BreakOut Cable

NCS 2000

Check this check box to use the ONS-MPO-MPOLC-10
breakout cable to interconnect the client ports of the
MR-MXP card with the NCS2K-MF-MPO-20LC passive
module.

8X10G-FO

NCS 2000

Check this check box to use the NCS2K-MF-8X10G-FO
passive module only for 10G on the client-side of the
NCS2K-400G-XP card. By default, this passive module is
enabled.

Band Type

NCS 1010
NCS 1001

Choose the required band type for NCS 1010 R7.9.1.

NCS 1010 Line Card

NCS 1010

Choose whether the Line Card faceplate is Standard
Faceplate or Enhanced Faceplate.

Note

If you assigned a Scalable Upto Degree value that is
supported for both standard and enhance at the site level,
then you can select Sandard Faceplate in one side and
Enhanced Faceplate in another side.

Bill of Material

License Suite

NCS 1010

Choose whether the License Suite is Essential (RTU +
SIA3) or Advanced (RTU + SIA3).

NCS 1014

The default option is RTU + SIA3. It is noneditable.
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Modify site properties .

Properties Platform Description
NCS1k Line card license NCS 1010 Choose whether the License Suite is:
* Essential (RTU + SIA3)
* Advanced (RTU + SIA3)
* Essential (RTU + SIAS)
» Advanced (RTU + SIAS)

Enable NCS NCS 2000 This feature enables NCS features on all sites in the
network.

Use PAYG NCS 2000 The Pay As You Grow (PAYG) functionality significantly
reduces the initial setup cost and enables the purchase of
another wavelength capacity on a need basis.

PAYG enables port-based cost or licensing for SMR-9 and
SMR-20 cards.

Connection Verification NCS 2000 Enable this check box to:

* Validate the correct optical interconnection between
the optical cards inside a Flex ROADM.

* Measure the insertion loss of the external passive path.

* Validate the quality of the connections to the patch
panel.

* Check if the insertion loss is within the expected value.

The following cards support connection verification:

* SMR20 FS CV

* MF-DEG-5-CV

* MF-MPO-16LC-CV

* MF-UPG-4-CV

New FS-SMR PID NCS 2000 By default, this check-box remains checked for newly

created network. You cannot edit it. This option enables
displaying of the new SMR-20 PID in the BOM page.

You can enable this option when you unlock an mpz
network where SMR-20 is selected, during an upgrade or
release upgrade.

L ayout
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Properties Platform Description
Chassis Type NCS 2000 Choose the type of chassis. The available options are:
* M2, M6, and M15 Chassis for OLA and ROADM
* M6 and M15 Traffic
* Auto for all nodes
Note
Chassis type is not supported for the passthrough site.
NCS 1010 Choose the type of chassis. The available options are:
* NCS1010
* NCS1020
NCS1014 Grouping NCS 1010 Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.
NCS 1014 Enable this property to group all the NCS 1000 transponder
cards of a site in NCS1014 shelf.
Power Supply NCS 2000 Choose the type of Power Supply.
For an NCS 2000 site, the available options are based on
the chassis type:
* Auto for all types of chassis
* AC Power, DC power for M15 and M2 chassis
* AC Power, DC Power, AC2 Power, DC40 Power, and
DC20 Power for M6 chassis
NCS 1010 The options available for the NCS 1010 site are Auto, AC
NCS 1001 Power, and DC power.
NCS 1014
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Properties Platform Description
Controller Card NCS 2000 Choose the type of the controller card.
For an NCS 2000 site, the default controller card is TNCS-2.
The available options are based on the chassis type chosen.
By default, controller cards that are supported by M15
chassis are listed. The available options are:
* Auto
* TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2,
and TNCS-20 for M2 chassis
* TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2,
and TNCS-20 for M6 chassis
* TNCS, TNCS-0 TNCS-2, TNCS-20 for M15 chassis
NCS 1010 The following options are available for the NCS 1010 site:
* Auto
* NCS1010-CNTRL-K9
* NCS1010-CNTRL-B-K9
NCS1010-CNTRL-B-K9 appears for networks from
R7.11.1.
Note
If you enable Advanced Optical Settings, Cisco ONP
takes the default controller card as NCS1010-CNTRL-B-K9,
else NCS1010-CNTRL-K9. However, you can still change
the controller later.
NCS 1001 CONP takes NCS1K-CNTLR?2 as default.
NCS 1014 The following options are available for the NCS 1014 site:
* NCS1K14-CNTLR-K9
* NCS1K14-CNTLR-B-K9
Redundant Controller Card | NCS 2000 Choose whether to use a redundant controller card.
NCS 1010 Note
NCS 1001 When you select Chassis Type as NCS1020, you can force

Redundant Controller Card to Yes.
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Properties

Platform

Description

Layout Template

NCS 2000

Choose the required layout template.

Note
After the chosen layout template is applied, all layout
properties will be reset and disabled.

Note

After design analysis, if the applied layout template is not
considered for card placement in the layout, check for the
error message (non-critical) under the Elements >

M essages tab. If you see a template-related error which
indicates that there is a mismatch between the cards that
are defined in the template and the cards that are created
on the site, perform the following:

* Export the template from the Layout page, and
modify it as required.

* Import the modified template using the Manage >
Layout Template option.

* Switch to Design mode and apply the template to the
site using the Entity Editor.

* Reanalyze the network to get the correct layout
populated.

UTS AC Power Cables

NCS 2000
NCS 1010
NCS 1001
NCS 1014

Choose the type of cables to be used for the AC power
supply. Cables are listed based on the country type and the
Chassis type selected.

Redundant Power Scheme

NCS 2000

Choose the redundant power scheme from the drop-down
list to configure the number of working and protected power
units for the chassis.

For an NCS 2000 site, the options available are based on
the chassis type. For M15 chassis, the options available are
1+0, 1+1, 2+0, 2+1, 3+0, 3+1, 2+2, 3+1 is the default
redundancy power scheme for M15 DC chassis and 2+2 is
the default redundancy power scheme for M15 AC chassis.
For example, if you choose 3+1 redundant power scheme,
there are 3 working power units and 1 protected power unit.

For an M6 chassis, the options available are Auto, Yes, and
No.

NCS 1010
NCS 1001
NCS 1014

The options available are Auto, 1+0, and 1+1.
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Properties

Platform

Description

Raman Adapter Share

NCS 2000

This option is available only for the OLA site. By default,
this check box remains checked. This option indicates that
MF-2LC-ADP can be shared with EDRA amplifiers and
not with RAMAN amplifiers irrespective of the default
selection.

ECU Type

NCS 2000

Choose the External Connection Unit (ECU) type from the
drop-down list. The options available are based on the
chassis type. By default, the ECU applicable for M15 is
listed.

» ECU—Has 12 USB 2.0 ports and supports
IEEE1588v2 PTP, time-of-day (ToD), and
pulse-per-second (PPS) inputs.

* ECU-S—Similar to ECU except that it has eight USB
2.0 ports and two USB 3.0 ports.

* ECU60-S—Variant of ECU-S introduced for the NCS
2006 when the shelf is powered at —-60VDC nominal
input voltage.

ECU-S and ECU60-S are supported only for M6 chassis.

MF Unit

NCS 2000

Choose the mechanical frame for the passive optical
modules from the drop-down list. The options available are
Auto, MF-6RU/MF-10RU, and MF-1RU.

* The NCS2K-MF-1RU has four slots for the passive
optical modules.

* The NCS2K-MF-6RU supports up to 14 single-slot
passive optical modules such as any combination of
NCS2K-MF-DEG-5, CS2K-MF-UPG-4, or Connection
Verification (CV) units.

* The NCS2K-MF10-6RU supports up to 10 double-slot
passive optical modules such as
NCS2K-MF-MPO-16LC=.

NCS 1010

For NCS 1010 site, the available options are Auto,
MF-4RU, and MF-1RU.

NCS 1001
NCS 1014

MF-1RU is the default option. This property is noneditable.

Chassis Disaggregation

NCS 2000

If you check this check-box, ROADM, and transponder
cards are placed in different chassis.

Map
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Properties Platform Description
X Coordinate NCS 2000 It represents the longitudinal location of the site. Longitude
can be positive or negative (-180 to 180). Negative is west
NCS 1010 . o
of Greenwich, and positive is eastward.
NCS 1001
Y Coordinate NCS 2000 It represents the latitudinal location of the site. Latitude can
NCS 1010 be positive or negative (- 90-90), north and south of the
Equator.
NCS 1001
Position Lock NCS 2000 Check this check box to lock the site position on the map.
NCS 1010
NCS 1001
C Band
Shared SMR Port NCS 2000 Check this check box to connect Contentionless unit
16-AD-CCOFS and Colored unit MD-48-ODD/Even to the
same MPO port of SMR-20. When Shared SMR port is
enabled, MD-48-ODD/EVEN unit connects to the specific
side of SMR-20 through MPO-8LC and UPG-4 instead of
directly connecting to SMR-20 through MPO-16LC.
Note
Shared SMR port becomes disabled, if
* Degree Mesh Type property is PPMESH8-5AD
* Or, Site Type property is SMR-9 and Scalable Upto
Degree property is 8
Degree Mesh Type NCS 2000 Choose the mesh type for the Flex NG-DWDM site. The
available options are:
» DEG-5/UPG-4
* PPMESH8-5AD
DEG-5/UPG-4 is the default value.
Degree Type NCS 1010 Displays the type of degree. For example, BRK-8.
Pre Equip Degree NCS 2000 This parameter determines the number of degrees to be
considered for the site hardware placement on day 0.
For NCS 2000, the values can be None, Auto, 4, 8, 12 or
16. The default option is None. If you choose None, only
the sides that are present in the Cisco ONP GUI are shown.
The values in the drop-down list are populated based on
the value of Scalable Upto Degree parameter.
NCS 1010 For NCS 1010 site, the options available are Yes and No.
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Properties

Platform

Description

COSM

Chassis License Flush Out

NCS 2000

Allows you to flush out the existing chassis license and
purchase a new chassis license.

COSM Pluggables

NCS 2000

You can choose one of the following options from the
drop-down list. When you choose Auto, ONS_SC+-10G_SR
is the default option.

» Auto

* ONS-SC +- 10G-SR

* ONS-SC +-10G-LR
Note

The COSM pluggables are not applicable for UCS-based
COSM network design.

CiscoNM S

COSM Full License

NCS 2000

Enable this check box to add High Availability (Feature
and License), Connection Verification license, Flex
Spectrum license, and OTDR license packaged in it.

COSM High Availability

NCS 2000

Choose the high availability options:
* Auto: Based on analysis and default behavior.

* Local HA: Both active and standby COSM cards are
placed on the same node.

* None: No COSM card present.

* Only Active: No High Availability. Only Primary
COSM card is added.

* Geo HA: COSM cards are placed in two different sites
located at different geographical locations, but adjacent
to each other. See Rules and Behaviour that are
applicable for the selection.

Primary HA

NCS 2000

Enable this check box to add the High Availability feature
to the license package.

Connection Verification
License

NCS 2000

Enable this check box to add the Connection Verification
feature to the license package. (This is applicable for the
NCS 2000 networks until Release 12.3.1 )

SVO Flex Spectrum License

NCS 2000

Enable this check box to add the Flex Spectrum feature to
the COSM license package. For SSON networks, the Flex
Spectrum license is enabled by default. (This is applicable
for the NCS 2000 networks until Release 12.3.1)
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Modify Network Properties |

Properties Platform

Description

OTDR License NCS 2000

Enable this check box to add the OTDR feature to the
license package. (This is applicable for the NCS 2000
networks until Release 12.3.1)

3rd party NM S (These are applicable for the NCS 2000 ne

tworks until Release 12.3.1)

3rd party Full License NCS 2000 Enable this check box to add NBI (North Bound Interface),
Alarm Correlation, Performance Monitoring, and Circuit
Provisioning features to the license package.

NBI NCS 2000 Enable this check box to add the NBI feature to the license
package.

Alarm Correlation NCS 2000 Enable this check box to add the Alarm Correlation feature
to the license package.

Performance Monitoring NCS 2000 Enable this check box to add the Performance Monitoring
feature to the license package.

Circuit Provisioning NCS 2000 Enable this check box to add the Circuit Provisioning

feature to the license package.

Enhanced Face Plate Options

Degree Priority NCS 1010

Choose the port type for interconnect degree priority. The
available options are:

» LC Ports
* MPO Group

The default option is LC Ports.

Note
This field appears only when you select NCS 1010 Line
Card as Enhanced Faceplate.

Add/Drop Shelf Type NCS 1010

This property is noneditable and appears for networks from
R7.11.1.

Click Update.

Add Contentionless Side to a Site

Contentionless functionality on a site refers to the contentionless add or drop ability of an N-degree ROADM

node to accommodate N wavelengths of the same

frequency from a single add or drop device. Fora ROADM

to be contentionless, the number of drop units must be equal to ROADM degrees.

Use the following procedure to add contentionless sides to a ROADM or traffic site.
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Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to add contentionless sides to a site.

The network opens.

Step 3 Choose Network > Entity Editor.

Step 4 Click the site to which you want to add contentionless sides.
Step 5 Click the Add Contentionless Side icon.
Step 6 Enter the appropriate value in the Enter number of contentionless sides field.

The number of contentionless sides that can be added to a site depends on the type of site, the Scalable Upto Degree
property. The following table explains the same.

Table 55: Contentionless Sides for Layer-1 SMR

Site Type Scalable Upto Degree Number of Contentionless Sides
SMR-20 4 16

SMR-20 8 12

SMR-20 12 8

SMR-20 16 4

SMR-20 Line 8

SMR-20 Terminal 8

SMR-9 4 5

SMR-9 8 1

Step 7 To add layer-2 SMR-20 contentionless sides, perform the following steps:
a) Check the Evolved M esh check box.
b) Choose Site Type as SMR-20 or Auto.
¢) Check the Cascaded SMR check box.
d) Choose Degree M esh Type as DEG-5/UPG-4.
e) Click Update.

You can add 20 more contentionless sides on each site for layer-2 SMR.

Step 8 To add an extended layer-2 SMR-20 contentionless side, choose the Reserve Cascaded SMR Port value.
Note
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Modify Network Properties |

The Reserve Cascaded SMR Port drop-down property is available for NCS 2000 networks from R11.1.x.

Based on the N-degree and Layer-2 SMR, you can add more contentionless sides on each site for the extended layer-2
SMR, sacrificing some Layer-1 contentionless sides. The following table explains the same.

Table 56: Contentionless Sides for Extended Layer-2 SMR

Reserve | Site Type | Scalable | No. of Contentionless | No. of No. of No. of

Cascaded Upto | SidesforLayer-1Side | Contentionless Contentionless Contentionless Sides

SMR Degree Sides with 1st Port | Sides with 2nd Port | with 3rd Port Layer-2

Port Layer-2 Layer-2

1 SMR-20 |4 16 20 Unsupported Unsupported
SMR-20 |8 12 20 Unsupported Unsupported
SMR-20 |12 8 20 Unsupported Unsupported
SMR-20 |16 4 20 Unsupported Unsupported

2 SMR-20 |4 Unsupported Unsupported Unsupported Unsupported
SMR-20 |8 11 20 20 Unsupported
SMR-20 |12 7 20 20 Unsupported
SMR-20 |16 3 20 20 Unsupported

3 SMR-20 |4 Unsupported Unsupported Unsupported Unsupported
SMR-20 |8 Unsupported Unsupported Unsupported Unsupported
SMR-20 |12 6 20 20 20
SMR-20 |16 2 20 20 20

Step 9 Click OK.

Modify Number of Contentionless Side Ports for a Site

Procedure

Step 1

Use this task to modify the number of contentionless ports for a side in a ROADM site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.

The Select Network To Open dialog box appears.
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| Modify Network Properties
Modify Contentionless Side to a Site in Upgrade Mode .

Step 2 Click the network in which you want to modify the number of contentionless ports for a side in a ROADM site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Expand a ROADM site and select a contentionless side.

You can view the properties of the side in the right panel.

Step 5 From the Contentionless Ports drop-down list, choose the required number of ports.
Click Update.

Modify Contentionless Side to a Site in Upgrade Mode
Use the following procedure to modify contentionless sides to a ROADM or traffic site in upgrade mode.
Limitation
* Supports networks from R11.1.x.

* NCS 2000 networks have the limitation of Passive units count up to 126. When you add the second and
third L2 contentionless sides, the passive units count goes beyond the limit. In such cases, the tool allows
the analysis and notifies the limitation via an error message, The passive unitsin this design (count) has
exceeded the maxi mum supported passive units on the NE SW (126). Please review the design with Cisco
before proceeding for deployment.

Before you begin
Set the following conditions.

1. Enable Evolved Mesh.

2. Set Site Type as SMIR-20 or Auto

3. Enable Cascaded SMR.

4. Set Degree Mesh Type as DEG-5/UPG-4.
5. Set Scalable Upto Degree.

If the above Prerequisites are not met, you must unlock the site to modify the contentionless sides.

Procedure

Step 1 Choose Network > Entity Editor.
Step 2 Click the site to which you want to modify the contentionless sides.
Step 3 Check the Cascaded SMR check box if not enabled already.

The Reserve Cascaded SMR Port drop-down appears.

Step 4 Choose the SMR port value in Reserve Cascaded SMR Port.
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Modify Network Properties |

[ AddL-Band Side to a Site

Step 5
Step 6
Step 7

Step 8

To reduce the Layer-2 SMR sides:
a. Choose a lower value.
b. Click Update.

If SMR ports are available, the update becomes successful. Else, an error message appears. Perform the following
actions:

1. Unlock the site.

2. Start over from Step 1.

To increase the Layer-2 SMR sides:
a. Choose a higher value.
b. Click Update.

If SMR ports are available, the update becomes successful. Else, an error message appears. Perform the following
actions:

1. Unlock the site.
2. Delete the lowest contentionless side in Layer-1 SMR site.

3. Start over from Step 1.

Click the site to which you want to add contentionless sides.
Click the Add Contentionless Side icon.
Enter the appropriate value in the Enter number of contentionless sides field.

The number of contentionless sides that can be added to a site depends on the type of site, the Scalable Upto Degree
property.

Click OK.

Add L-Band Side to a Site

Procedure

Step 1

Step 2

Use the following procedure to add L-Band sides to an NCS 1010 R7.9.1 site:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network in which you want to add the L-Band sides to a site.
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Add L-Band Side to a Site [J|]

The network opens.
Step 3 Choose Network > Entity Editor.
Step 4 To add the L-Band sides, choose one of the following options:
* Click the site to which you want to add the L-Band sides.

Note
If you add an L-Band side to a site, the corresponding attached sides from other sites also automatically add L-Band
sides. A pop-up message appears to indicate the addition of L-Band sides.

* Or, expand the site and click on a side to add L-Band to the selected side only.

Step 5 Click the Add L-Band icon.
The L-Band side appears under the required site or side.

Note
If ILA or pass-through sites are present in APC domain, then the end-to-end path in the L-band becomes enabled
automatically.
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Add Omni-Directional Side to a Site

Table 57: Feature History

Modify Network Properties |

Feature Name

Release Information

Description

Omnidirectional Configuration
Support for NCS 1010 Network

Cisco ONP Release 24.3.1

You can now include both colorless
and colored omnidirectional
configurations when designing an
NCS 1010 network.

New Properties Added:

* Add Omni-Directional icon
(under Entity Editor): Use this
icon to add the required
number of omnidirectional
sides.

» Omni Variant (under Side
Properties): Select the desired
Add/Drop stage, such as Dual
OLT or 4x4 COFS.

* Max Auto Omni Allowed
(under Network Properties):
Cisco ONP automatically
generates the omni edges
based on the number entered.

This omnidirectional setup
enhances the flexibility of the
multidegree topology, allowing
channels to be routed through any
optical degree during a fiber cut
without needing physical fiber
reconnections.

The omnidirectional configuration allows you to add/drop traffic to/from any of the node directions in a
multidegree topology. This configuration gives flexibility to the multidegree topology to route channels
through any of the optical degrees during fiber cut without the need for changing the physical fiber connections.

\}

Note Omni edges are not supported on a Terminal site.

Use the following procedure to add omnidirectional sides to an NCS 1010 site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Modify Network Properties

Procedure

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6

Step 7

Modify Fiber Properties .

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network in which you want to add contentionless sides to a site.
The network opens.

Choose Network > Entity Editor.

Click the site to which you want to add contentionless sides.

Click the Add Omni-Directional icon.
Enter the appropriate value in the Enter number of Omni Directional sides field.

The number of omnidirectional sides that can be added to a site depends on the Scalable Upto Degr ee property.

Click OK.

The omnidirectional sides are created under the site and are labeled as omni-1, and omni-2 and so on. Also, a tag called
Omni is added to the Omni side to indicate it as an omnidirectional side.

You can add L-band functionality to the side by clicking the Add L-Band icon.

Note
Cisco ONP will automatically generate up to the number of Omni Edges specified in the Max Auto Omni Allowed field
under Network properties. Manual creation by the user is not required.

Modify Fiber Properties

Procedure

Step 1

Step 2

Use this task to modify the properties of fiber.

Before you begin

Log in to Cisco ONP web interface, on page 7

In the network tree, expand Fiber, and select a fiber or click a fiber on the map. The selected fiber will be highlighted in
orange.

You can view the basic properties of the fiber at the bottom of the network tree.

Modify the following fiber properties as required.

Property Platform Description
General
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. Modify Fiber Properties

Modify Network Properties |

Property Platform Description

Name NCS 2000 By default, the name of the fiber is based on the number of
NCS 1010 ﬁb.ers between the source and destination sites. You can

edit the name.

NCS 1001

Source NCS 2000 Displays the source site name. This field is noneditable.
NCS 1010
NCS 1001

Destination NCS 2000 Displays the destination site name. This field is noneditable.
NCS 1010
NCS 1001

Bidirectional NCS 2000 Indicates whether a standard single fiber is used to transmit
NCS 1010 the data in both directions.
NCS 1001
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Modify Fiber Properties .

Property

Platform

Description

Fiber Type

NCS 2000

Select the fiber type. Cisco ONP supports the following
fibers, and the default fiber type is G652-SMF.

* G652-SMF

* G652-SMF-28E

* True Wave Reach
* True Wave RS

* True-Wave Plus

* True-Wave Minus
* True-Wave Classic
* Free-Light

* Tera-Light

* Metro-Core

* ELEAF

* NDSF

* ALLWave

* SMF-28 ULL

* SMF28-Ultra

NCS 1010
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. Modify Fiber Properties

Modify Network Properties |

Property

Platform

Description

Select the fiber type. Cisco ONP supports the following
fibers, and the default fiber type is G652-SMF.

* G652-SMF

* G652-SMF-28E

* True Wave Reach
* True Wave RS

* True-Wave Plus

* True-Wave Minus
* True-Wave Classic
* Free-Light

* Tera-Light

* Metro-Core

* ELEAF

* NDSF

* ALLWave

* SMF-28 ULL

* SMF28-Ultra

NCS 1001

* G652-SMF

* G652-SMF-28E
* True Wave Reach
* True Wave RS

* Free-Light

¢ Tera-Light

* ELEAF
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Modify Fiber Properties .

Property Platform Description
Length NCS 2000 Displays the span length of the fiber connecting a source

NCS 1010 and destination site. If necessary, change the span length

manually.

NCS 1001 * The Cisco ONP tool automatically updates the fiber
length to 1 km or 1 mile. If you change the fiber length,
then the tool updates the same in the network tree and
the map accordingly.

* In the network tree pane, expand Fiber and select the
fiber couple, A-Z and Z-A. The properties pane
displays the fiber couple name, source side, destination
side, its span length, loss, and, Polarization Mode
Dispersion (PMD) value.

* You can enter the different span length and loss values
for the individual fibers in a fiber couple.

Network status NCS 2000 Displays the status of the network, whether the network is

NCS 1010 being deployed or not. If the network is not deployed, it

shows the status as UNDISCOVERED.

NCS 1001

Business status NCS 2000 Displays the status of the fiber in a business perspective

NCS 1010 view. If fiber is not deployed, it shows the status as

FUTURE. This field is noneditable.
NCS 1001
Measurement Units NCS 2000 Choose the measurement unit (Km or Miles) for the fiber

NCS 1010 span. You can set the measurement unit only for the duct,

but not for the fiber pair (couple) or fiber.

NCS 1001

Ageing Loss [dB] NCS 2000 Enter the aging loss value for the fiber.
NCS 1010
NCS 1001
DCN Extension NCS 2000 Check this check box to enable the default use of data

NCS 1010 connection network (DCN) extension on each span in the

project. This setting implies that the optical service channel

NCS 1001 (OSC) channel is not used to connect the two nodes.
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. Modify Fiber Properties

Step 3
Step 4
Step 5
Step 6

Modify Network Properties |

Property Platform Description
OSC FrameType NCS 2000 Choose the OSC frame type. The options available are:
* Auto
» OC3 Frame
* GE Frame
* FE Frame
The default option is Auto. When set in Auto, Cisco ONP
uses FE Frame as the preferred frame type.
Ageing Factor NCS 2000 Enter the number to fiber aging factor.
NCS 1010
NCS 1001
Physical
Length-Based Loss NCS 2000 The fiber loss value is automatically calculated based on
NCS 1010 length and loss coefficient, when you check this option.
NCS 1001
Tot SOL Loss w/o NCS 2000 Enter the start of life fiber loss value for each span,
connectors NCS 1010 excluding the connector concentrated loss.
NCS 1001
Raman Amplification
Raman Amplified NCS 2000 Enable Raman Amplification on the ducts.
Note
When you enable Raman amplification for NCS 2000
system release 12.2, the side property Enable C+L Band
SC is automatically disabled and vice versa.
Click Update.

To modify the advanced properties of the fibers, click Show Advanced Properties, or choose Network > Entity Editor.

Click the FIBER tab in the Entity Editor window.

Choose the fiber and modify the following properties in the right pane.

Property Platform Description

General

Ageing loss [dB] NCS 2000 Enter the aging loss value.
NCS 1010
NCS 1001
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Modify Fiber Properties .

Property Platform Description
DCN Extension NCS 2000 Enable the default use of data connection network (DCN)
NCS 1010 extension on each span in the network.
NCS 1001
OSC Frame Type NCS 2000 Choose the OSC frame type. The options available are Auto,
NCS 1010 OC3 Frame, Gigabit E.ther.net Frame, and Fa.st Etherne.t
Frame. The default option is Auto. When set in Auto, Cisco
ONP uses Fast Ethernet Frame as the preferred frame type.
Aging Factor NCS 2000 Enter the number to factor fiber aging. This factor is
NCS 1010 multiplied by the SOL total span loss without connectors.
NCS 1001
Physical
Connector Loss A NCS 2000 Connector Loss at Source Site [dB]
NCS 1010
NCS 1001
Connector Loss B NCS 2000 Connector Loss at Destination Site [dB]
NCS 1010
NCS 1001
Factors
Loss Coefficient [dB/km] | NCS 2000 Loss is calculated based on the loss coefficient.
NCS 1010
NCS 1001
PMD Coefficient NCS 2000 Displays the PMD coefficient.
NCS 1010
NCS 1001
QD C-Band NCS 2000 Displays the secondary order dispersion for C-band.
NCS 1010
NCS 1001
CD C-Band NCS 2000 Displays the secondary order dispersion for L-band.
NCS 1010
NCS 1001
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Modify Network Properties |

(The properties under Totals are noneditable)

Property Platform Description

RD Factor NCS 2000 Displays the random dispersion value.
NCS 1010
NCS 1001

Extended

Effective Mode Area NCS 2000 Displays the effective mode area [um”2]
NCS 1010
NCS 1001

SRS tilt coefficient NCS 2000 Displays the Stimulated Raman Scattering tilt coefficient
NCS 1010 on the band.
NCS 1001

DRBS coefficient NCS 2000 Displays the Rayleigh Scattering capture coefficient.
NCS 1010
NCS 1001

N2 NCS 2000 Nonlinear index of refraction [1e-16 cm”2/W]
NCS 1010
NCS 1001

LFBR NCS 2000 Length of individual fibers for sigmaDSP [Km]
NCS 1010
NCS 1001

Totals

Loss EOL

NCS 2000
NCS 1010
NCS 1001

Displays the total loss EOL calculation.

Loss SOL

NCS 2000
NCS 1010
NCS 1001

Displays the total loss SOL calculation.

CD C-Band

NCS 2000
NCS 1010
NCS 1001

Displays the total chromatic dispersion for the C-band.
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Step 7

Modify Fiber Couple Properties .

Property Platform Description

QD C-Band NCS 2000 Displays the secondary order dispersion for C-band.
NCS 1010
NCS 1001

RD NCS 2000 Displays the random dispersion value.
NCS 1010
NCS 1001

PMD NCS 2000 Displays the Polarization Mode Dispersion (PMD) value.
NCS 1010
NCS 1001

Click Update.

Modify Fiber Couple Properties

Use this task to modify properties of the fiber couple.

Procedure

Step 1

Step 2

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree, expand Fiber, and drill down up to a fiber couple and click the fiber couple.

You can view the basic properties of the fiber couple at the bottom of the network tree.

Modify the following fiber couple properties as required.

Property Platform Description
General
Name * NCS 2000 By default, fiber couple is named based on the fiber name
followed by COUPLE-AZ or COUPLE-ZA. The sides that
* NCS 1010 are connected by the fiber couple are indicated inside
« NCS 1001 brackets. The name is noneditable.
Source Side * NCS 2000 Displays the source side name. This field is noneditable.
* NCS 1010
* NCS 1001
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. Modify Fiber Couple Properties

Step 3
Step 4

Step 5
Step 6

Modify Network Properties |

Property Platform Description
Destination Side * NCS 2000 Displays the destination side name. This field is noneditable.
* NCS 1010
* NCS 1001
Length * NCS 2000 Automatically displays the span length of the fiber
connecting a source and destination side. Change the span
* NCS 1010 .
length manually, if necessary.
* NCS 1001 You can enter the different span length and loss values for
the individual fibers in a fiber couple.
Factors
Loss coefficient [dB] * NCS 2000 Enter the value of the SOL fiber loss per kilometer used to
calculate the loss of each span in the network.
* NCS 1010
* NCS 1001
Totals
Loss SOL * NCS 2000 Displays the total loss SOL calculation.
* NCS 1010
* NCS 1001
Loss EOL * NCS 2000 Displays the total loss EOL calculation.
* NCS 1010
* NCS 1001
Physical
Tot SOL Loss w/o * NCS 2000 Enter the start of life fiber loss value for each span,
connectors excluding the connector concentrated loss.
* NCS 1010
* NCS 1001
Click Update.

To modify advanced properties of the fiber couple, click Show Advanced Properties, or choose Network > Entity

Editor.

Click the FIBER tab in the Entity Editor window.

Choose the fiber and drill down to the fiber couple, and modify the following properties in the right pane.

Property

Platform

Description

Physical
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Modify Fiber Couple Properties .

Property Platform Description
Connector Loss A * NCS 2000 Connector Loss at Source Site [dB]
* NCS 1010
Connector Loss B * NCS 2000 Connector Loss at Destination Site [dB]
* NCS 1010
Factors
PMD coefficient * NCS 2000 Displays the PMD coefficient.
* NCS 1010
* NCS 1001
Totals

(The properties under Totals are noneditable)

PMD * NCS 2000 Displays the PMD value.

* NCS 1010
* NCS 1001

Loss EOL * NCS 2000 Displays the total loss EOL calculation.
* NCS 1010
* NCS 1001

Loss SOL * NCS 2000 Displays the total loss SOL calculation.
*+ NCS 1010
* NCS 1001

CD C-Band * NCS 2000 Displays the total chromatic dispersion for the C-band.
* NCS 1010
* NCS 1001

QD C-Band * NCS 2000 Displays the secondary order dispersion for C-band.
* NCS 1010
* NCS 1001
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. Modify Service Properties

Property Platform Description

RD * NCS 2000 Displays the random dispersion value.
* NCS 1010
* NCS 1001

Step 7 Click Update.

Modify Service Properties

Use this task to modify the properties of the service.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Services and click a service.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

Property Platform Description
General
Name NCS 2000 By default, the service name is based on the source and

destination sites and the number of services between them.
You can edit the name.

For example, if there are two services between site 1 and
site 2, the names of the services are Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

Type NCS 2000 Choose the types of service.
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Step 3
Step 4
Step 5
Step 6

Modify Service Properties .

Property

Platform

Description

Protection

NCS 2000

Choose the protection type from the drop-down list. Options
available are:

* Unprotected
e 1+1

* Disjoint

* S+NS

* 1+R

e 1+14+R

¢ [+1+R+R

For more information on protection types, see Supported
protection schemes , on page 4.

Source

NCS 2000

Displays the source site name.

Destination

NCS 2000

Displays the destination site name.

Click Update.

To modify advanced properties of the service, click Show Advanced Properties or choose Network > Entity Editor.

In the Entity Editor window, click the Service tab.

Choose the service under the network tree, and modify the following properties in the right pane.

Property Platform Description
General
Tertiary Source NCS 2000 From the drop-down list, select the possible site as a tertiary

source.
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Modify Network Properties |

Property Platform Description

Tertiary Destination NCS 2000 From the drop-down list, select the possible site as a tertiary
destination.
Tertiary source and tertiary destination are enabled only
when you select the protection scheme as Unprotected
Disjoint.
You can select either tertiary destination or both tertiary
source and tertiary destination.

* If you select only the tertiary destination, the demand
is created between the source and destination and
between the source and tertiary destination. These do
not have common fibers in the path, which are disjoint.

* If you select both tertiary source and tertiary
destination, two unprotected demands are created
between the source to destination, and tertiary source
to tertiary destination. The demands are disjoint to
each other.

Primary Path Forcing

Path NCS 2000 Cisco ONP automatically selects the shortest path as
working path and also allows you to force the path
manually.

Fiber NCS 2000 Primary path fiber is forcing path for working trail.

Regeneration Platform NCS 2000 Displays the platform of the regeneration site

Regen Sites NCS 2000 Choose the regeneration site.

Wavelength NCS 2000 Click Edit to choose the wavelength. The default option is
Auto.

ODU Timeslot NCS 2000 Enter the ODU timeslot value.

Section Wavelength(s) NCS 2000 Displays the selected Wavelength.

Src Channel Type NCS 2000 Choose the type of source channel. The available options
are:

* Auto—This is the default option. Auto option is the
contentionless demand.

+ Contentionless

* Colorless

* Colored

Dst Channel Type NCS 2000 Choose the type of destination channel.
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Property Platform Description

Secondary Path Forcing (Available only for (1+1)

Path NCS 2000 Secondary path is the protected path when the primary path
fails. This path is the second best path after the primary
path.

Fiber NCS 2000 Secondary path fiber is for protected service, forcing path
for the protected trail.

Regeneration Platform NCS 2000 Displays the platform of the regeneration site

Regen Sites NCS 2000 Choose the regeneration site.

Wavelength NCS 2000 Click Edit to choose the wavelength. The default option is
Auto.

ODU Timeslot NCS 2000 Enter the ODU timeslot value.

Section Wavelength(s) NCS 2000 Displays the selected Wavelength.

Src Channel Type NCS 2000 Choose the type of source channel.

Dst Channel Type NCS 2000 Choose the type of destination channel.

Restoration 1 Path Forcing (Available for 1+R, 1+14R, 1+1+R+R)

Path NCS 2000 Cisco ONP automatically selects the first restoration path.

Fiber NCS 2000 Choose the first restoration path fibers.

Restoration 2 Path Forcing (Available for 1+1+R+R)

Path NCS 2000 Cisco ONP automatically selects the second restoration
path.
Fiber NCS 2000 Choose the second restoration path fibers.

NCS 1K Domain

Client Type NCS 2000 Displays the client type. By default, client type is OTU4.

Interface Type NCS 2000 Displays the interface type. By default, interface type is
BH.

Trunk Mode NCS 2000 Choose whether the trunk mode is 200G or 300G. By

default, Trunk Mode is 200G.

Note
Based on the selected trunk mode, Baud rates are filtered.

Baud Rate NCS 2000 Choose whether the Baud rates mode as 60 or 69GBd.

Note
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* Ensure that you force both primary and secondary path fiber or channel for protected service. Also ensure that the
wave type is same for both primary and secondary paths. While doing path forcing, make sure that you perform an
end-to-end path forcing from the source to the destination. Analysis fails if the partial path is forced.

* Force the wave path for the wave, which is tagged to the service.

* In case of protection type: 1+1+R+R, 1+1+R, and 1+R, you can force a path in restoration path1 or restoration path2
Fiber that is forced in primary or secondary path Fiber.

Step 7 Click Update.

Modify service properties for NCS 1010

Table 58: Feature History

Feature Name Release Information Description

L-Band support for 2.4TX Cisco ONP Release 25.1.1 In addition to the previously
transponder card in NCS 1010 supported C-band, the

network NCS1K14-2.4T-X-K9 transponder

card now also supports the L-band
under the Service and Trail
properties for the NCS 1010
network.

The 2.4TX card's support for the
L-band increases capacity and
spectral efficiency by utilizing both
the L-band and C-band. C-band and
L-band circuits can now use the
same cards with different trunks for

propagation.
Table 59: Feature History
Feature Name Release Information | Feature Description
Transponder Cisco ONP Release | You can now create optical services for the NCS 1010 network.
Support on NCS 24.3.1 You can include cards such as NCS1K14-2.4T-K9,
1010 Network NCS1K14-2.4T-X-K9, and NCS1K4-QXP-K9 as native

transponder instead of optical sources and check the feasibility
of the network. You can generate the traffic report and BoM with
the exact count of cards and pluggables based on the
requirements, along with licensing details for the OLT card and
the transponders.

From Release 24.3.1, you can add services between two NCS 1010 or NCS 1020 sites. Use this task to modify
the properties of the service.
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Procedure

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree, expand Services and click a service.

Modify service properties for NCS 1010 .

You can view the basic properties of the service at the bottom of the network tree.

Modify the following service properties as required.

Property Platform Description

General

Name NCS 1010 The services are named as Service-1, Service-2, and so on.
You can edit the name.

Type NCS 1010 Choose the traffic type as 100GE or 400GE.

Protection NCS 1010 Protection is not supported for the NCS 1010 network. The
only option available is Unprotected.

Source NCS 1010 Displays the source site name.

Destination NCS 1010 Displays the destination site name.

Encryption NCS 1010 Check this check box to enable encryption on the service.
Encrypted and non-encrypted services will not be aggregated
and they use separate trunks.

Note
Encryption is supported only for NCS1K14-2.4T-X-K9
and NCS1K4-QXP-K9

Click Update.

To modify the advanced properties of the service, click Show Advanced Propertiesor choose Networ k > Entity Editor.

In the Entity Editor window, click the Service tab.

Choose the service under the network tree, and modify the following properties in the right pane.

Property Platform Description

Primary Path

Path NCS 1010 Path of the service.

Fiber NCS 1010 Choose the fiber.

Regen Sites NCS 1010 Choose the regeneration site.
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Modify Network Properties |

Property

Platform

Description

Channel

NCS 1010

Choose if'a new circuit is to be created or an existing circuit
to be used. The available options are:

* Auto: The system will automatically choose whether
to create a new circuit or use an existing one.

* Create New: A new circuit will be created, and no
existing circuits will be used.

« Existing circuits ( Displays the name of the circuits
that are already created): Select an existing circuit to
use. If you need to specify a particular circuit, choose
a circuit from drop-down list.

Note
When you select an existing circuit with the following
conditions:

« Traffic Typeis set to Transponder Card under the
circuit properties.

* Trunk Mode and Baud Rate are already defined
under the Trail properties

You will not be able to select Trunk M odeand Baud Rate
under the Service properties. To edit these properties
change the traffic type and change the Channel property
to Auto or Create New.

Band Type

NCS 1010

Displays whether it is a C-type or L-type band.

If you choose NCS1K 14-2.4T-X-K9 as the Card Type, you
can select the band as C-Band or L-Band.

Section Wavelengths

NCS 1010

Choose the wavelength for the regen site that is selected.

Trunk mode

NCS 1010

Choose the trunk mode of the line card. The trunk rate is
from 400G to 1200G for NCS1K14-2.4T-K9 and
NCS1K14-2.4T-X-K9, from 100G to 400G for
NCS1K4-QXP-KO9.

Baud Rate

NCS 1010

Select the baud rate. The baud rates that are suitable for the
trunk rate chosen are displayed.

Wavelength

NCS 1010

Click Edit to choose the wavelength. The default option is
Auto.

Primary Channel Source
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Modify service properties for NCS 1010 .

Property Platform Description

Card Type NCS 1010 Choose the card for the service. The available options are:
* NCS1K14-2.4T-K9

* NCS1K14-2.4T-X-K9
* NCS1K4-QXP-K9

TXP Chassis NCS 1010 Choose the transponder chassis for the service. The available
options are:

* NCS 1014
* NCS 1004—Supports only NCS1K4-QXP-K9

Modulation NCS 1010 Displays the type of modulation.

Bundle Mode NCS 1010 This property is enabled when the NCS1K14-2.4T-X-K9
card is selected. When selected, the routing will be based
on Muxponder mode and supports Trunk modes 600G or
1000G.

Note
Default value for trunk mode will be 600G when bundle
mode is enabled.

Trunk Mode NCS 1010 Choose a trunk mode from the drop-down list. The options
for trunk mode changes based on the selected Card Type.

Sub Mode NCS 1010 This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

‘1 E
<0S

FEC NCS 1010 Displays the type of FEC supported on the chosen card.

Src Add/Drop Type NCS 1010 Choose the Add/drop type. The available options are:
* Colored

* Colorless
* Omni-colored

e Omni-colorless

Client Interface NCS 1010 Choose the client pluggable for the selected card.

Client Port NCS 1010 This property is enabled only when a trunk mode is selected.
Choose the client port.
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Modify Network Properties |

Property Platform Description
Trunk Type NCS 1010 The trunk pluggables that are applicable for the selected
card is displayed. Choose the required trunk pluggable.
Primary Channel Destination
Card Type NCS 1010 Choose the card for the service. The available options are:
* NCS1K14-2.4T-K9
* NCS1K14-2.4T-X-K9
* NCS1K4-QXP-K9
TXP Chassis NCS 1010 Choose the transponder chassis for the service. The available
options are:
* NCS 1014
* NCS 1004—Supports only NCS1K4-QXP-K9
Modulation NCS 1010 Displays the type of modulation.
Bundle Mode NCS 1010 This property is enabled when the NCS1K14-2.4T-X-K9
4 card is selected. When selected, routing will be based on
Muxponder mode and supports Trunk modes 600G or
1000G.
Note
Default value for trunk mode will be 600G when bundle
mode is enabled.
Trunk Mode NCS 1010 Choose a trunk mode from the drop-down list. The options
for trunk mode changes based on the selected Card Type.
Sub Mode NCS 1010 This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:
*1E
*0 S
FEC NCS 1010 Displays the type of FEC supported on the chosen card.
Dst Add/Drop Type NCS 1010 Choose the Add/drop type. The available options are:
* Colored
* Colorless
* Omni-colored
* Omni-colorless
Client Interface NCS 1010 Choose the client pluggable for the selected card.
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Services Aggregation .

Property Platform Description

Client Port NCS 1010 This property is enabled only when a trunk mode is selected.
Choose the client port.

Trunk Type NCS 1010 The trunk pluggables that are applicable for the selected
card is displayed. Choose the required trunk pluggable.

Step 7 Click Update.

Services Aggregation

Table 60: Feature History

Feature Name

Release Information

Feature Description

Services Aggregation

Cisco ONP Release 4.1

Services aggregation feature allows
two or more services to share the
same trunk port or channel. By
default, the services are added to
the DefaultGroup. You can also
export the aggregation reports.

Services aggregation indicates whether two or more services can share the same trunk port or channel. The
aggregation is defined based on the properties of the Service Group. When you add services to the Traffic
site (of the type 1K-2K-4K) in an SSON network, a DefaultGroup is created under the Servicesin the network
tree. The services that you add, are associated to the DefaultGroup.

Create a New Service Group

Use this task to create a new service group:

Before you begin

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 Choose File> Open.

The Select Network To Open dialog box appears.

Step 2 Click a network, where you want to create a new service group.

The network opens.

Step 3 Click the Ellipsisicon available in the right side of Services under the network tree and choose Create Service Group.
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A new service group gets created under the Services.

Modify Service Group Properties

Modify Network Properties |

Use this task to modify the properties of service group.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Services and click a service group.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

Property

Platform

Description

General

Name

NCS 2000

By default, the service name is based on the source and
destination sites and the number of services between them.
You can edit the name.

For example, if there are two services between site 1 and
site 2, the name of the services are Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

Demand Types

NCS 2000

Choose the demand type. For default group all demand
types are available, and you cannot edit them.

Default Group

NCS 2000

Indicates whether the service group is a default group or a
user created group.

NCS4 K

Exclusive LC Usage

NCS 4000

Indicates whether the services belonging to this group must
have an exclusive Line Card (LC) or not.

For example, when you check this check box, neither the
Client LC nor the Trunk LC of the services belonging to
this group can be shared by services belonging to any other
groups.
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Aggregation Rules .

Property Platform Description

Symmetric Aggregation NCS 4000 Indicates whether this group allows aggregation of only
symmetric services. Services are symmetric if they have
same protection scheme. Following are the various
protection schemes:

* Unprotected
*« 1+R

e 1+1

¢ 1+1+R

e |+1+R+R

For Example, all “1+1” services are symmetrical.

If you check this check box, this service group allows
aggregation of only symmetrical services.

For example, “Unprotected” can be aggregated only with
“Unprotected”, “1+R” only with “1+R”, “1+1” only with
“1+1”, and so on.

If this check box is unchecked, this service group allows
aggregation of symmetrical and unsymmetrical services
together.

For example, “Unprotected” can be aggregated with either
“Unprotected”, “1+R”, “1+1” “1+1+R” or “1+1+R+R”.

See Aggregation Rules, on page 171.

NCS1K
Exclusive LC Usage NCS 1004 Same as NCS 4 K.
Symmetric Aggregation NCS 1004 Same as NCS 4 K.

Step 3 Click Update.

Aggregation Rules

Following are the rules for any two services (symmetrical or nonsymmetrical) to be aggregated:
* The services must have the same Source and Destination.
* The services must have same paths for the same path types.
For example:

* For symmetric aggregation between two “1+1” services, the working path of the first service must
match with the working path of the second service and the protection path of the first service must
match with the protection path of the second service.
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. Associate a Service to the Newly Created Group

* For non-symmetric aggregation between “1+1”” and “1+1+R” services, the working path of the first
service must match with the working path of the second service and the protection path of the first
service must match with the protection path of the second service. The restoration path of second
service can be anything.

* The services must be configured to use same wavelength for same path types.

« If the wavelength is set to “auto”, it is flexible to be aggregated with other “auto" wavelength or a fixed
wavelength.

* The services must be configured to use same trunk mode for same path types.

* The services must be configured to use same regeneration sites for same path types.

\)

Note Demand Type is not used as a constraint for aggregation (except for trunk capacity availability).

Associate a Service to the Newly Created Group

By default, the services are associated to the DefaultGroup. But you can change the group.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, click the service that you want to associate to a group.

You can view the basic properties of the network at the bottom of the network tree.
Step 2 Choose the group from the Service Group drop-down list.
Step 3 Click Update.

Note

For an LNI imported network, by default, all the services are present in the Default group. Only when you upgrade the
LNI imported network for the first time, you can move the services to other newly created Service Groups without having
to unlock them. On subsequent upgrades, you must unlock the services to facilitate the movement between Service Groups.
Also, the Service Groups are in locked state in the upgrade mode, unless a complete Network-level unlock has been
performed.

What to do next

Export Aggregation Reports

Use this task to export the service aggregation reports:
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Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click an analyzed network.

The network opens.

Step 3 Choose Export > Service Aggregation.

Step 4 Save the aggregation report in the form of an Excel sheet to your local system.

Modify Wave Properties

Table 61: Feature History

Modify Wave Properties .

Feature Name Release Information Feature Description
PSM Support on Non-SSON Cisco ONP Release 24.3.1 The PSM-channél option is now
Network available as a Protection Type

under the Wave properties for NCS
2000 non-SSON networks. This
option allows you to use PSM
channel trunk protection with the
PSM card during network design,
in addition to existing client
protection. You can verify the
optical feasibility for both working
and protection paths, providing all
necessary parameters and
connections for deployment.

Use the following task to modify the properties of the wave.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Waves, and click a wave.

You can view the basic properties of the wave at the bottom of the network tree.

Cisco Optical Network Planner Configuration Guide, Releases 25.x.x [Jj



. Modify Wave Properties

Step 2 Modify the following wave properties as required.

Modify Network Properties |

Property Platform Description

General

Label NCS 2000 By default, the wave is named based on the source and
destination sites and the number of waves between them.
You can edit the name.
For example, if there are two waves defined between site
1 and site 2, the waves are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

Source Site NCS 2000 Displays the source site name.

Destination Site NCS 2000 Displays the destination site name.

Traffic Type NCS 2000 Choose the traffic type from the drop-down list. The

available options are:
* Optical Source
* 100GE
* 10GE LAN PHY
* 40GE LAN PHY
* Fiber Channel 10G
* Fiber Channel 16G
* Fiber Channel 8G
* OC-192/STM-64
+ OTU2
* OTU2e
+ OTU4
* Pluggable Card
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Modify Media Channel Properties .

Property

Platform

Description

Protection Type

NCS 2000

Choose the protection type.

* Unprotected
* Client 1+1

¢ PSM-Channel

The PSM-channel option is available only for non-SSON
networks. PSM-channel is not supported with the colorless
Add/Drop MF-6AD-COFS.

When you select the PSM-Channel option, the Protection
Switch Module (PSM) for the Cisco ONS15454
Multiservice Transport Platform (MSTP) (15454-PSM card)
is placed in the network to provide protection at the trunk
level. The PSM card splits the traffic originated by
transponder trunk across the working and protected TX
ports.

For more information on protection types, see Supported
protection schemes , on page 4.

Forecast

NCS 2000

Check this check box to change a present wave to a forecast
wave.

Encryption

NCS 2000

Check this check box to enable encryption.

Step 3 Click Update.

Modify Media Channel Properties

Use the following task to modify properties of the media channel.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Media Channels, and click a media channel.

You can view the basic properties of the media channel at the bottom of the network tree.

Alternatively, you can choose Networ k > Entity Editor > Services, expand Media Channels, and click a media channel

to view the properties.

Step 2 Modify the following properties as required.
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Modify Network Properties |

Property

Platform

Description

General

Label

NCS 2000

By default, the media channel is named based on the source
and destination sites and the number of media channels
between them. You can edit the name.

For example, if there are two media channels between site
1 and site 2, they are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

Source Site

NCS 2000

Displays the source site name.

Destination Site

NCS 2000

Displays the destination site name.

Traffic Type

NCS 2000

Choose the traffic type from the drop-down list. The
available options are:

* Optical Source

* 100GE

* I0GE LAN PHY

* 40GE LAN PHY

* Fiber Channel 10G
* Fiber Channel 16G
* Fiber Channel 8G
* OC-192/STM-64

+ OTU2

* OTU2e

*« OTU4

* Pluggable Card

Protection Type

NCS 2000

Choose the protection type.
* Unprotected
* Client 1+1

For more information on protection types, see Supported
protection schemes , on page 4.

For Client 1+1, ensure that the sites have contentionless
sides for the analysis to be successful. By default, Cisco
ONP finds both span and node disjoint path for Client1+1
protected waves, but allows you to force span and node
disjoint path.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Modify Network Properties

Modify circuit properties .

Property Platform Description

Forecast NCS 2000 Check this check box to change a present wave to a forecast
wave.

Encryption NCS 2000 Check this check box to enable encryption.

Step 3 Click Update.

Modify circuit properties

Use the following task to modify the properties of the circuit in an NCS 1010 network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Circuits, and click a circuit.

You can view the basic properties of the circuit at the bottom of the network tree.

Step 2 Modify the following circuit properties as required.

Property Platform Description
General
Label NCS 1010 By default, the circuit is named based on the source and
NCS 1001 destination '51tes and the number of circuits between them.
You can edit the name.
For example, if there are two circuits defined between site
1 and site 2, the circuits are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.
Source Site NCS 1010 Displays the source site name.
NCS 1001
Destination Site NCS 1010 Displays the destination site name.
NCS 1001
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Modify Network Properties |

Property Platform Description
Traffic Type NCS 1010 Choose the traffic type from the drop-down list. The
NCS 1001 available options are:
* Optical Source
* Pluggable Card
* Transponder Card
Note
QDD interfaces (both as optical source and pluggable) are
not supported with colorless BRK-8, BRK-16, and BRK-24
configurations.
Protection Type NCS 1010 Choose the protection type. Currently, we support only
NCS 1001 Unprotected.
Encryption NCS 1010 The Encryption property gets enabled when you select Line
card as the Traffic Type.
Forecast NCS 1010 Check this check box to change a present wave to a forecast
NCS 1001 wave.

Step 3 Click Update.

Modify trail properties

Use this task to modify the properties of the trail.

Table 62: Feature History

Feature Name

Release Information Description

Bright ZR+ Pluggable Support

Cisco ONP Release 5.1 The Bright ZR+ pluggable can now

be included in the network design
by choosing them as Card Typeor
Client Interface under the Trail
properties. This selection is
available for all types of sites. The
Bright ZR+ pluggable has high
transmit optical power up to 0dBm,
high transmit OSNR, and
high-density QSFP-DD form factor.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x




| Modify Network Properties

Table 63: Feature History

Modify trail properties .

Feature Name

Release Information Description

Multilayer Nodes Enhancements

Cisco ONP Release 5.1 You can now choose from the full
array of supported Card Typesand
Client I nterfaces under the Trail
properties option for the multilayer
nodes. Previously, only a limited
set of cards were available for
selection. With this enhancement,
you can design diverse networks
leveraging the unique
functionalities of all types of cards.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Waves, M edia Channels or Circuits, drill down up to a trail and click a trail.

The basic properties of the trail are displayed at the bottom of the network tree.

Step 2 Modify the following trail properties as required.

Property Platform Description

General

Label NCS 2000 Displays the name of the trail.
NCS 1010
NCS 1001

Path of Wave NCS 2000 Select a fiber from the drop-down list.
NCS 1010
NCS 1001

Regen Sites NCS 2000 Select the regeneration site.
NCS 1010

Source Site NCS 2000 Displays the source site name.
NCS 1010
NCS 1001
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Step 3
Step 4
Step 5

Modify Network Properties |

Property Platform Description
Destination Site NCS 2000 Displays the destination site name.
NCS 1010
NCS 1001
Wavelength NCS 2000 (Non-SSON) Click Edit to choose the wavelength. The default option is
Auto.
Central Wavelength [nm] NCS 2000 Click Edit to choose the central wavelength. The default
NCS 1010 option is Auto.
Note
NCS 1001 If you select L-Band as Band Type, the L-band wavelength
options appear along with C-band wavelengths for NCS
1010 R7.9.1.
Multicarrier NCS 2000 Indicates whether the transmission is a multicarrier
NCS 1010 transmission.
Trunk Mode NCS 2000 The trunk mode can be edited only when you choose
400G-XP-LC as Card Type.
NCS 1010 The trunk mode can be edited only when the Traffic Type
is set to Line card under the circuit properties.
NCS 1001 Trunk mode is noneditable. Auto is default option.
Number Of Carrier(s) NCS 1010 Enter values 2—16 to add the required number of carriers to
the channel. The default value is 1.
Note
If you select Colorless or Omni-Colorless as Add/Drop
Type and Auto or OLT/LC/AddDrop as Add/Drop
Connector, this property becomes editable.
Note
When you enable bundle mode in line circuit, this value is
2 and non-editable.
Baud Rate NCS 1010 Choose the baud rate that is suitable for the selected trunk
rate.
Filtering Penality NCS 2000 Displays the value of the penalties that are caused by the
NCS 1010 different filter types (OADM, and ROADM).

To modify the advanced properties of the trail, click Show Advanced Properties or choose Network > Entity Editor.

In the Entity Editor window, click the Service tab.

Expand Waves, Media Channels or Circuits, under the network tree, drill down to the trail, click the trail, and modify

the following properties that are displayed in the right pane.
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Modify trail properties .

Property Platform Description

General

OSNR Forward [dB] NCS 2000 (non-SSON) Displays the forward optical signal to noise ratio.

OSNR Reverse [dB] NCS 2000 (non-SSON) Displays the reverse optical signal to noise ratio.

Band Type NCS 1010 Choose the required band type for the circuit.
Note

When you select L-Band as Band Type, then the
Add/Drop Type field automatically selects Colorlessand
becomes disabled.

NCS 1001 This property is noneditable. C-Band is the default option.
OTN (non-SSON)
ODUTimeslot NCS 2000 (non-SSON) Displays the Optical Data Unit timeslot.
SRLGs NCS 2000 (non-SSON) Displays the SRLGs associated with the trail.
OTN Hops NCS 2000 (non-SSON) Displays the number of OTN hops.
Quantity NCS 2000 (non-SSON) Displays the number of OTN services on the trail.

Source
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Modify Network Properties |

Property

Platform

Description

Card Type

NCS 2000
NCS 1010

Choose the card used in the source site. See Supported Cards
and Pluggables, on page 293 and Supported Optical Sources,
on page 307 for more information on the list of supported
cards.

From Release 5.1, Bright ZR+ pluggables are supported for
all the types of sites. Also, there are no limitations on the
type of cards that can be chosen for the multilayer nodes.

Note
* Non-SSON

* Colored and colorless—Baud rates less than 42
are supported and listed.

* Contentionless—Mean power less than —4.4 is
supported and listed.
+ SSON

* Colored—Baud rates less than 65 are supported
and listed.

* Colorless—All interfaces supported and listed.

* Contentionless—Mean power less than —4.4 are
supported and listed.

Mean power = (ochData.txRange.max +
ochData.txRange.min)/2

If contentionless is selected for the source channel type,
the QDD interfaces are not supported.

NCS 1001

Choose a card type from the drop-down list.
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Modify trail properties .

Property Platform Description

Client Interface NCS 2000 Choose the pluggable from the drop-down list. The
NCS 1010 pluggables suitable for the chosen card type are displayed.

See Supported Cards and Pluggables, on page 293 for more
information on the list of supported pluggables.

From Release 5.1, Bright ZR+ pluggables are supported for
all the types of sites. Also, there are no limitations on the
type of cards that can be chosen for the multilayer nodes.

The pluggable FR-1(QSFP-100G-FR-S) is supported on
the client ports of the 400G-XP LC starting from NCS 2000
Release 11.1.0.

The pluggable ERL (QSFP-100G-ERL-S) is supported on
the client ports of the 400G-XP LC with 100G traffic type
starting from NCS 2000 Release 11.1.3.

Note

When you export the NCS 2000 R11.1.3 network, the Cisco
ONP exports the NCS 2000 R11.1.0 report. You must edit
the exported report for R11.1.3.

NCS 1001 This property is noneditable. Auto is the default option.

Add/Drop Type NCS 2000 Choose the type of Add/Drop. The available options are:
* Auto

 Contentionless
 Colorless

* Colored

NCS 1010 Choose the type of Add/Drop. The available options are:
* Auto

* Colorless
* Colored
* Omni-Colorless

* Omni-Colored

NCS 1001 This property is noneditable. Colored is the default option.
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Modify Network Properties |

Property

Platform

Description

Add/Drop Connector

NCS 1010

Note
This property appears when you select Add/Drop Type
as Colorless.

Choose the type of Add/Drop Connector. The available
options are:

* Auto—Auto is OLT/LC/AddDrop.

* OLT/LC/Add/Drop—Combination of OLT LC ports
and CCMD-16 LC ports

* OLT/LC—Direct OLT LC ports

* OLT/MPO/Add/Drop—Combination of OLT LC ports
and break out units such as BRK-8, BRK-16, BRK-24
MPO ports

Note
This property is applicable only for Enhanced NCS 1010
line cards from R7.11.1.

Modulation

NCS 1010

Displays the type of modulation.

Bundle Mode

NCS 1010

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, the routing is based on
Muxponder mode and supports Trunk modes 600G or
1000G.

Sub Mode

NCS 1010

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

‘1 E
<0 S

FEC

NCS 1010

Displays the type of FEC supported on the chosen card.

Trunk Type

NCS 2000
NCS 1010

Choose the trunk type from the drop-down list.

NCS 1001

This property is noneditable. Auto is the default option.

Contentionless Side

NCS 2000

Choose the contentionless side from the drop-down list.

Launch Power

NCS 1010
NCS 1001

Enter a launch power value. Default option is Auto.

Destination
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Modify trail properties .

Property Platform Description
Card Type NCS 2000 The destination card type is auto populated based on the
NCS 1010 source card type chosen.
NCS 1001 Choose the card type from the drop-down list.
Client Interface NCS 2000 Choose the pluggable from the drop-down list. The
NCS 1010 pluggables suitable for the chosen card type are displayed.
NCS 1001 This property is noneditable. Auto is the default option.
Trunk Type NCS 2000 Choose the trunk type from the drop-down list.
NCS 1010
NCS 1001 This property is noneditable. Auto is the default option.
Add/Drop Type NCS 2000 Choose the type of the Add/Drop. The available options
are:
* Auto
* Contentionless
* Colorless
* Colored
NCS 1010 Choose the type of the Add/Drop. The available options
are:
* Auto
* Colorless
* Colored
* Omni-Colorless
* Omni-Colored
NCS 1001 Colored is the default option.
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Modify Network Properties |

Property

Platform

Description

Add/Drop Connector

NCS 1010

Note
This property appears when you select Add/Drop Type
as Colorless.

Choose the type of Add/Drop Connector. The available
options are:

* Auto—Auto is OLT/LC/AddDrop.

* OLT/LC/Add/Drop—Combination of OLT LC ports
and CCMD-16 LC ports

* OLT/LC—Direct OLT LC ports

* OLT/MPO/Add/Drop—Combination of OLT LC ports
and break out units such as BRK-8, BRK-16, BRK-24
MPO ports

Note
This property is applicable only for Enhanced NCS 1010
line cards.

Modulation

NCS 1010

Displays the type of modulation.

Bundle Mode

NCS 1010

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, the routing is based on
Muxponder mode and supports Trunk modes 600G or
1000G.

Sub Mode

NCS 1010

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

‘1 E
<0 S

FEC

NCS 1010

Displays the type of FEC supported on the chosen card.

Trunk Type

NCS 1010

Choose the trunk pluggable.

From R25.1.1, new pluggables are supported on the
NCS1K4-QXP-K9 card.

Contentionless Side

NCS 2000

Choose the contentionless side from the drop-down list.

Launch Power

NCS 1010
NCS 1001

Enter a launch power value. Default option is Auto.

Step 6 Click Update.
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Modify Section Properties

Use this task to modify properties of the section.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, expand Waves, drill down up to section and click a section.

You can view the basic properties of the section at the bottom of the network tree.

Step 2 Modify the section properties as required.

Section and trail have the same properties. Refer Modify trail properties, on page 178 for the descriptions of the properties.

Step 3 Click Update.

Modify Side Properties

Table 64: Feature History

Feature Name Release Information | Feature Description

Colorless Add/Drop Cisco ONP Release | In addition to the SMR-20 card, the colorless Add/Drop

Configuration with SMR-9 |24.3.1 configuration can now be added to both SSON and

Card non-SSON networks using the SMR-9 card, providing
more flexibility to use the available SMR-9 ports for
add/drop functionality.

Table 65: Feature History

Feature Name Release Information |Feature Description

NCS2K-RMN-CTP-C+L | Cisco ONP Release | Cisco ONP now supports the passive module,

support 5.0 NCS2K-RMN-CTP-C+L (C- and L-band
counterpropagating Raman amplifier), starting from the
NCS 2000 system release 12.3.1 for SSON and non-SSON
networks.
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Procedure

Step 1
Step 2

Table 66: Feature History

Modify Network Properties |

Feature Name

Release Information

Feature Description

Support for NCS2K-MF-CL-SC (C
and L-band combiner and splitter)

Cisco ONP Release 4.2

Cisco ONP supports the passive
module, NCS2K-MF-CL-SC (C
and L-band combiner and splitter),
starting from the NCS 2000 system
release 12.2 for SSON and
non-SSON networks. This feature
enables combining C and L band
wavelengths.

Use this task to modify the properties of a side in a site.

Before you begin

Log in to Cisco ONP web interface,

on page 7.

In the network tree, Choose Sites> Site > Sitedomain > Side.
To modify the side properties, perform the following steps:

a) Click Show Advanced Properties.
b) In the right pane of the Entity Editor window, modify the following properties of the side.

Note

You cannot edit the properties of the Pass through site side.

Options Platform Description
General
Label NCS 2000 Displays the label of the side.

NCS 1010 Editable for NCS 1001.

NCS 1001 Note

For L-band nodes, the suffix L is added to the side label.

Type NCS 2000 Displays the type of the side. You cannot edit this

NCS 1010 property.

NCS 1001
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Modify Side Properties .

(Displayed for
Contentionless side)

Options Platform Description
Omni Variant NCS 1010 Select the type of omnidirectional add/drop stage. The
available options are:
* Dual OLT (the default option)
* 4x4 COFS (supports only C-band Omni colorless)
You can choose 4x4 COFS only if the Structure
under the Sites properties is Line.
Note
In a site, all Omni edges must have the same Omni
Variant. Changing the Omni Variant for one edge updates
the variant for all edges.
Omni Directional Ports NCS 1010 Enter the number of omnidirectional ports.
It is applicable only for the 4x4COFS Omni variant. The
available values range from 1 through 4, with a default
value of 4.
Node Address NCS 1010 Enter the node address
NCS 1001
MPO Cable NCS 1010 Choose the MPO cable. The available options are:
* Auto
* 16MPO-MPO
* 24AMPO-MPO
Colorless Ports (Displayed | NCS 2000 Enter the number of colorless ports.
for Line side) From Release 24.3.1, this property is enabled for the
SMR-9 card.
Contentionless Ports NCS 2000 Choose the number of contentionless ports.
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Modify Network Properties |

Options Platform Description
Enable C+L Band S/C NCS 2000 Cisco ONP supports the following passive modules:
E}]}D;:g)layed for Line side * NCS2K-MF-CL-SC (C and L-band combiner and

splitter), starting from the NCS 2000 system release
12.2 for SSON and non-SSON networks. Check this
check box to enable the NCS2K-MF-CL-SC card.
This card is supported for ROADM, OLA, and traffic
nodes, but not on the passthrough node.

Note
When you enable this option on a side:

« [t is automatically enabled on the side that is
connected to the selected side through a fiber.

* The fiber property Raman Amplified is
automatically disabled, and the opposite way.

« This card introduces a certain amount of
attenuation and insertion loss that is reflected
in the ANS parameters.

The NCS2K-MF-CL-SC module does not appear
in the layout.

* NCS2K-RMN-CTP-C+L (C- and L-band
counterpropagating Raman amplifier), starting from
the NCS 2000 system release 12.3 for SSON and
non-SSON networks. Check this check box to enable
the NCS2K-RMN-CTP-C+L card.

Note
When you enable this option on a side:

* If you enable the fiber property Raman
Amplified, then the NCS2K-RMN-CTP-C+L
card is automatically forced.

« If you disable the fiber property Raman
Amplified, then the NCS2K-MF-CL- SC card
is automatically forced.

* Fiber property Raman Amplified is
automatically disabled for NCS 2000 system
release 12.2.

The NCS2K-RMN-CTP-C+L module appears in
the layout.
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Modify Side Properties .

Options

Platform

Description

Band Type

NCS 1010
NCS 1001

Choose the required band type.
The available options are:
* C-Band

¢ C+L Futuristic

NCS 1010 Line Card

NCS 1010

Choose whether the Line Card faceplate is Standard
Faceplate or Enhanced Faceplate.

Note

If you assigned a Scalable Upto Degree value that is
supported for both standard and enhance at the site level,
then you can select Sandard Faceplate in one side and
Enhanced Faceplate in another side.

Probe Channel

NCS 1014

The Probe channel pluggable option that you selected at
the network level applies to all the edges of all sites in
the network. This field is noneditable.

OTDR Pluggable

NCS 1014

The OTDR pluggable option that you selected at the
network level applies to all the edges of all sites in the
network. This field is noneditable.

OSC Pluggable

NCS 1001

Choose the type of OSC pluggable. The available options
are:

* CWDM-SFP-1510
* CWDM-SFP-1610
* ONS-SC-Z3-1510
* ONS-SC-Z3-1610
* ONS-SE-155-1510

NCS 1014

Choose the type of OSC pluggable. The available option
is:

* ONS-SC-PTP-1510

Bill of Material

License Suite

NCS 1010

Choose whether the License Suite is Essential (RTU
+SIA3) or Advanced (RTU +SIA3).

NCS 1014

The default option is RTU + SIA3. It is noneditable.

L ayout
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Modify Network Properties |

Options Platform Description
Power Supply NCS 1010 Choose the type of Power Supply. The available options
NCS 1001 are Auto, AC Power, and DC Power.
The default option is Auto.
With the Auto option, the default power supply is selected
as DC Power.
Chassis Type NCS 1010 Choose the type of chassis. The available options are:
* NCS 1010
* NCS 1020
NCS1014 Grouping NCS 1014 This check box is enabled by default. If you enabled NCS
1014 grouping at the site level, then this check box
becomes noneditable.
Controller Card NCS 1010 Choose the type of the controller card. The available
options are:
* Auto
* NCS1010-CNTRL-K9
* NCS1010-CNTRL-B-K9
NCS 1001 NCS1K-CNTLR? is default.
Redundant Controller Card | NCS 1010 Displays the redundant controller card, if any. Else
NCS 1001 displays No.
UTS AC Power Cables NCS 1010 Choose the type of cables to be used for the AC power
NCS 1001 supply. You can choose the cables when the Power
Supply is set as AC Power or DC Power.
Redundant Power Scheme |NCS 1010 Choose the redundant power scheme from the drop-down
NCS 1001 list to configure the number of working and protected
power units for the chassis. The available options are
Auto, 1+0, and 1+1.
MF Unit NCS 1010 Choose the mechanical frame for the passive optical
NCS 1001 modules from the drop-down list. The options available

are Auto, MF-1RU, and MF-4RU.

Enhanced Face Plate Options
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Modify C-Band Amplifier Properties .

Options

Platform

Description

Degree Priority

NCS 1010

Choose the port type for interconnect degree priority. The
available options are:

¢ LC Ports

* MPO Group

The default option is LC Ports.

Note
This field appears only when you select NCS 1010 Line
Card as Enhanced Faceplate.

Direct LC Add/Drop

NCS 1010

Choose the number of LC ports to reserve for Direct
Add/Drop connection. The range of values is 0—14. This
property appears for networks from R7.10.1.

The chosen option will not be used for Degree
Connection.

¢) Click Update.

Modify C-Band Amplifier Properties

Table 67: Feature History

Feature Name

Release Information Feature Description

values

Manual Editing of Raman COP

Cisco ONP Release 4.1 This feature allows you to edit the

crosstalk values of the Raman COP
amplifier in the SSON network,
starting from NCS 2000 Release

I1.1.
Table 68: Feature History
Feature Name Release Information Feature Description
Inline Amplifier Cisco ONP Release 4.2 The Inline Amplifier option allows

you to enable an inline amplifier in
the network. You can simulate the
optical feasibility of the network
with and without an inline
amplifier. Based on the colorless or
colored add/drop type selected and
the QSFP-DD pluggable status, a
default inline amplifier is enabled
for the network.
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Modify Network Properties |

Use this task to modify the properties of a c-band amplifier in a site.

\)

Note Make sure that SMR card is forced on the site before you update the c-band amplifier properties.

Before you begin

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 In the network tree, choose Sites> Site > Site domain > Side > C-Band.

Step 2 To modify the amplifier properties, perform the following steps:

a) Click C-Band Amplifier.

You can view the properties of the C-Band Amplifier at the bottom of the network tree. For more information, see
Supported Amplifiers, on page 313.

b) Modify the following properties of the amplifier:

You can also modify the properties by choosing the C-Band Amplifier under Network > Entity Editor.

Options Platform Description

General

PSD Shape NCS 1010 Enter a Power Spectral Density (PSD) value.

Dual Band PSD Shape NCS 1010 Enter Central PSD and Tilt values.

Raman COP Tilt NCS 2000 The default value is Auto. You can enter a value.

Pre Tilt NCS 2000 The default value is Auto. You can enter a value.
NCS 1010

Raman Tilt NCS 2000 The default value is Auto. You can enter a value.
NCS 1010

Booster Tilt NCS 2000 The default value is Auto. You can enter a value.
NCS 1010
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Modify C-Band Amplifier Properties .

Options

Platform

Description

Inline Amplifier

NCS 2000

Choose whether inline amplifier can be forced. The
available options are:

* Yes—EDFA17 or EDFA35 amplifier is chosen as
the default amplifier when you choose colored
add/drop module MD-64-C or colorless add/drop
MF-6AD-CEFS, respectively. See Modify Add/Drop
Multiplexer Properties, on page 202.

* No—No amplifier can be forced.

e Auto

* EDFA17 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MD-64-C has low launch power
optical resource or QSFP-DD pluggable is
forced.

« EDFA35 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MF-6AD-CFS has low launch
power optical resource or QSFP-DD pluggable
is forced.

Note

When you configure MF-6AD-CFS+EDFA35 in an
SSON or non-SSON network, the optical results show
system error for the demands of the same or different
types. This error affects the what-if analysis. Hence we
recommend choosing the appropriate channel and client
attenuators so that the inline amplifier works at the proper
gain range.

You can view the amplifier added in the |PC, BOM, and
L ayout tabs, after the successful analysis.

Note
* When you add a QDD demand while upgrading a
network where the Inline Amplifier property is set
as Nno, the inline amplifier can be included in the
network only if you unlock the side and set the
Inline amplifier property as Auto or Yes.

* Default colorless configuration does not require
inline amplifier.

* When there are no demands passing through the
colored or colorless Add/Drop device, the forced
Inline amplifier is not placed.
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Modify Network Properties |

Options

Platform

Description

From Fiber

Pre Amp

NCS 2000

Choose a preamplifier from the drop-down list. The
default value is Auto. To enable this field for ROADM
and Traffic nodes, you must choose SMR-9 or SMR-20
from the Site Type drop-down list under the Site
properties.

If you choose SMR-9, the available options are:
* SMR9-FS-EDFA17-PRE
* SMR9-FS-EDFA24-PRE
* SMR9-FS-EDFA24-PRE

If you choose SMR-20, the available options are:
* SMR20-FS-EDFA17-PRE

* SMR20-FS-EDFA24-PRE

For the OLA site, the available options are:
* EDFA35-35-PRE

» EDFA35-24-PRE
* OPT -EDFA-17
* OPT -EDFA-24

NCS 1010

The options available for NCS 1010 are:

* Auto
¢ Normal

« Extended

NCS 1001

The options available for NCS 1001 are:

* Auto
* NCS1001-PRE-1
* NCS1001-PRE-2

NCS 1014

The Pre Amplifier value is decided based on the launch
power of the optical source.

The default option is Auto. It is noneditable.

Pre PSD

NCS 1014

The Pre PSD value is picked from LUT.

The default option is Auto. It is noneditable.
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Options Platform Description
Output Power NCS 2000 The default value is Auto. You can enter a value.
NCS 1001
Attenuator In NCS 2000 This field is enabled only when you choose a preamplifier.

Choose an attenuator from the drop-down list. The
available options are:

* ATT-LC-2
* ATT-LC-3
* ATT-LC-5
* ATT-LC-7
* ATT-LC-10
* ATT-LC-12
* ATT-LC-15
* ATT-LC-18

Attenuator Out NCS 2000 This field is enabled only when you choose a preamplifier.
Choose an attenuator from the drop-down list. The
available options are:

* ATT-LC-2
* ATT-LC-3
* ATT-LC-5
* ATT-LC-7
* ATT-LC-10
* ATT-LC-12
* ATT-LC-15
* ATT-LC-18

To Fiber
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Options Platform Description

Booster NCS 2000 The default value is Auto. To enable this field for
ROADM and Traffic nodes, you must choose SMR-9 or
SMR-20 from the Site Type drop-down list under the
Site properties.

If you choose SMR-20, the default booster is
20SMR-FS-BST.

If you choose SMR-9, default booster is
SMR9-FS-EDFA-BST.

For the OLA node, the available options are:

* EDFA35-35-BST
* EDFA35-24-BST
» OPT -EDFA-17
* OPT -EDFA-24

NCS 1010 For NCS 1010, it is OLT-C-EDFA-Bst

NCS 1001 The option available for NCS 1001 is:
* NCS1001-BST

First Booster NCS 1014 The options available are:

* Normal

* Extended
Second Booster NCS 1014 The default option is Auto. It is noneditable.
Second Booster PSD NCS 1014 The Pre PSD value is picked from LUT.

The default option is Auto. It is noneditable.

Output Power NCS 2000 The default value is Auto. You can enter a value.
NCS 1001
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Modify C-Band Amplifier Properties .

Options

Platform

Description

Attenuator In

NCS 2000

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

* ATT-LC-2
* ATT-LC-3
* ATT-LC-5
* ATT-LC-7
* ATT-LC-10
* ATT-LC-12
* ATT-LC-15
* ATT-LC-18

Attenuator Out

NCS 2000

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

* ATT-LC-2
* ATT-LC-3
* ATT-LC-5
* ATT-LC-7
* ATT-LC-10
* ATT-LC-12
* ATT-LC-15
* ATT-LC-18

Raman Amplification
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Modify Network Properties |

Options

Platform

Description

Raman Amp

NCS 2000

Choose the Raman amplifier from the drop-down list.

Note

To force the RAMAN amplifier on NCS 2000 node, you
must enable RAM AN amplified on the fiber, else the
Raman Amp is disabled, and network analysis fails.

Note

When you enable the fiber property Raman amplified
and the side property Enable C+L Band S/C for NCS
2000 node, Raman Amp is automatically forced as
RAMAN-C+L.

The available options for NCS 2000 ROADM and Traffic
sites are:

* RAMAN-CTP
* RAMAN-COP-CTP

Raman Amp can be forced only between two nodes.

The available options for the OLA site are:
* EDRA1-26
* EDRA1-35
* EDRA2-26
* EDRA2-35
* RAMAN-CTP

NCS 1010

The available options for NCS 1010 ROADM site are:
* Auto
* None

¢ Raman

Note

For NCS 1010 network, when Raman is forced on one
side, Raman is automatically forced on all connected
sides (APC Domain). If there are passthrough nodes
connected, Raman will be automatically enabled on both
sides of the passthrough nodes.

Raman CTP Gain

NCS 2000

Enter a value.

Raman COP Gain

NCS 2000

Enter a value. This field is enabled only when you choose
RAMAN-COP-CTP.
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Modify L-Band Amplifier Properties .

Options Platform Description
Raman Gain NCS 1010 Displays the Raman gain.
Static Data NCS 2000 By default, this option is disabled. Enable it to edit the
crosstalk values of the Raman COP amplifier.
Note
Static data is supported from Release 11.1 for SSON
network.
Linear XT Avg NCS 2000 Edit the value of average linear crosstalk.
Linear XT Six NCS 2000 Edit the value average linear crosstalk sigma.
NonLinear XT Avg NCS 2000 Edit the value of average nonlinear crosstalk.
NonLinear XT Sig NCS 2000 Edit the value of average nonlinear crosstalk sigma.

Note

Raman crosstalk values are present in the ANS file under logoparameters section.

Click Update.

Modify L-Band Amplifier Properties

Use this task to modify the properties of an L-band amplifier in a site.

Procedure

Step 1
Step 2

Before you begin

Log in to Cisco ONP web interface, on page 7

In the network tree, choose Sites> Site > Sitedomain > Side > L -Band.

To modify the amplifier properties, perform the following steps:

a)

b)

Click L-Band Amplifier.

You can view the properties of the L-Band Amplifier at the bottom of the network tree. For more information, see
Supported Amplifiers, on page 313.

Modify the following properties of the amplifier:

You can also modify the properties by choosing the L-Band Amplifier under Network > Entity Editor.

Options

Platform

Description

General
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Modify Network Properties |

Options Platform Description
PSD Shape NCS 1010 Enter a Power Spectral Density (PSD) value.
Dual Band PSD Shape NCS 1010 Enter Central PSD and Tilt values.
Pre Tilt NCS 1010 The default value is Auto. You can enter a value.
Raman Tilt NCS 1010 The default value is Auto. You can enter a value.
Booster Tilt NCS 1010 The default value is Auto. You can enter a value.
From Fiber
Pre Amp NCS 1010 The options available for NCS 1010 are:

* Normal

* Extended
To Fiber
Booster NCS 1010 For NCS 1010, it is OLT-L-EDFA-Bst

¢) Click Update.

Modify Add/Drop Multiplexer Properties

Table 69: Feature History

Feature Name

Release Information

Description

User-Defined Colorless Ports
Distribution for CCMD Card in
NCS 1010 Network

Cisco ONP Release 24.3.1

The new property, Colorless Port
Distribution is introduced under
the Add/Drop Multiplexer
properties. This property allows
you to select the number of CCMD
cards to connect to the LC ports of
the enhanced OLT and determine
the number of channels for each
chosen CCMD card. It provides the
flexibility to choose the desired
number of CCMD cards and
distribute the colorless ports across
them.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Modify Network Properties

Procedure

Step 1
Step 2

Table 70: Feature History

Modify Add/Drop Multiplexer Properties .

Feature Name

Release Information

Feature Description

Modify Properties of
Add/Drop
Multiplexer and
Demultiplexer

Cisco ONP Release
42

You can create and validate network designs by choosing colored
and colorless add/drop multiplexers and demultiplexers, and
interlever under C-Band > Add/Drop. The following options
are supported in this release:

Type of Add/Drop |Options Network Supported
Colorless * Direct SMR *+ SSON

* MF-6AD-CFS * Non-SSON

Colored * MD-64-C *« SSON
« MD-48-ODD * Non-SSON
* MD-48-EVEN

* MD-48-ODD +
MD-48-EVEN

Interlever * MpoCable * Non-SSON
* MD-48-CM

Use this task to modify the properties of the add/drop multiplexer in a site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

In the network tree, Choose Sites> Site > Sitedomain > Side > C-Band.

To modify the Add/Drop multiplexer card properties, perform the following steps:

a) Click Add/Drop.

You can view the properties of the add/drop multiplexer at the bottom of the network tree.

b) Modify the following properties of the add/drop multiplexer:

You can also modify the properties by choosing the Add/Drop under Networ k > Entity Editor.

Options Platform

Description

General
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Modify Network Properties |

Options

Platform

Description

Colored Add/Drop

NCS 2000

Choose the colored add/drop multiplexer and demultiplexer: The
available options are:

* MD-64-C—Passive optical multiplexer and demultiplexer
module (for SSON network)

* None

* Auto

To mix 16-AD-CCOFS and MD-48-ODD/EVEN on the same
MPO port of SMR-20 and connect MD-48-ODD/EVEN to
SMR-20 via MPO-8LC and UPG-4, enable Shared SMR port and
force the required colored Add/Drop.

The following options are added automatically based on the
colored demands created and the wavelengths forced in the
non-SSON network.

* MD-48-ODD
* MD-48-EVEN
* MD-48-ODD + MD-48-EVEN

NCS 1010

The options available for NCS 1010 are:
* Auto
* None
* MD-32-EVEN
* MD-32-ODD
* MD-32- ODD+MD-32-EVEN

NCS 1001
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Modify Add/Drop Multiplexer Properties .

Options Platform Description
The options available for NCS 1001 are:
* Auto
* MD-64
* MD-32-EVEN
Note
In pre-R2511 networks, MD-32-EVEN refers to
N1K-MD-32E-C patch panel. In R2511 networks,
NCS1K-MD-32E-CE replaces N1K-MD-32E-C. For
pre-R2511 networks with MD-32E-C add/drop option, you
need to reset the add/drop option to Auto and then to
MD-32-EVEN and reanalyse the network to add the new
MD-32E-CE PID.
* MD-48-EVEN
* MD-48-ODD
* MD-48-ODD+MD-48-EVEN
* FLD-4 (10 variants)
Note
Choose a Add/Drop type with a Baud rate that matches the Optical
Source Baud rates.
NCS 1014 The options available for NCS 1014 are:

¢ Auto
* NCS1K-MD-320-CE
* NCS1K-MD-32E-CE

* MD-32-ODD+MD-32-EVEN— Combination of both
MD-32-CE add/drop panels.
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Modify Network Properties |

Options Platform Description
Colorless Add/Drop NCS 2000 Choose the colorless add/drop multiplexer and demultiplexer. The
available options for NCS 2000 are:
» Auto
* Direct SMR—SMR-20 and SMR-9 cards that are directly
connected to the colorless channels through MF-MPO-16-LC
and MF-MPO-8-LC respectively.
* MF-6AD-CFS—6 Port Add/Drop Module (supported only
for ROADM starting from NCS 2000 system release 11.0,
and traffic site).
Note
If you choose MF-6AD-CFS for a side, we recommend you
to choose the same for other sides of the site.
NCS 1010 The options available for NCS 1010 are:
* Auto
* None
* BRK-8
* BRK-16
* BRK-24
Note
QDD optical sources are not supported (both as optical source
and pluggable) with colorless BRK-8, BRK-16, or BRK-24
configurations.
Interlever Type NCS 2000 Choose the interlever type from the drop-down list. The available
options are:
* Auto
* MpoCable
* MD-48-CM
Note
Interlever Type property is visible and editable only for Line
sides of Multi-Degree nodes having Site Typeproperty as SMIR-9
and Scalable Upto Degree property as 8 under the C-Band tab
at the Site level.
M PO Connector Add/Drop
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Modify Add/Drop Multiplexer Properties .

Options

Platform

Description

Colorless Add/Drop

NCS 1010

Note
M PO Connector Add/Drop appears for networks from R7.10.1.

The options available for NCS 1010 are:
* Auto
* None
* BRK-8
* BRK-16
* BRK-24

Note

QDD optical sources are not supported (both as optical source
and pluggable) with colorless BRK-8, BRK-16, or BRK-24
configurations.

Colorless Ports

NCS 1010

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

Note

For the R7.10.1 network, you can assign a maximum of 48
colorless ports. The assigned ports are applicable to the MPO
ports.

For the R7.11.1 network, you can assign a maximum of 128
colorless ports.

L C Connector Add/Dr

op

Colorless Add/Drop

NCS 1010

Note
L C Connector Add/Drop appears for networks from R7.11.1.

The options available for NCS 1010 are:

e Auto
* None

* NCS1K14-CCMD-16C
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Modify Network Properties |

Options

Platform

Description

Colorless Ports

NCS 1010

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

Note
For the R7.10.1 network, you can assign a maximum of 48
colorless ports. The assigned ports are applicable for the LC ports.

For the R7.11.1 network, you can assign a maximum of 128
colorless ports.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Modify Network Properties

Modify Add/Drop Multiplexer Properties .

Options

Platform

Description

Colorless Ports
Distribution

NCS 1010

* Click the field to open the Colorless Ports Distribution
pop-up window.

* Choose the CCMD card (NCS1K14-CCMD-16C) for each
of the LC ports (A/D 4 - A/D 17).

* Select the number of ports for each CCMD card, ensuring
the total does not exceed 128.

* Click Submit.

When allocating LC ports, the priority is as follows:

1. Degree connection

2. Direct LC ports

Only the remaining LC ports can be allocated to CCMD cards.

If the Degree Priority under Site Properties is set to LC Ports, the
number of CCMD cards that can be forced on the line side edges
depends on the number of degrees (including omni and line
degrees, depending on the scalable degree) and the Direct LC
ports.

This is explained in the following formula:

If Degree Priority is LC_Ports, Maximum number of CCMDs
Allowed = 14 - (scalableUptoDegree - 1) - Direct LC add/drops
- Number of Omni Edges

The number of ports that you have selected is displayed in the
field.

When the Enable Special Settingsunder the Network properties
is enabled and if the Colorless Ports Distribution has not been
set previously, it will default to 16,16,0. In this case three LC ports
already used for CCMD card.

Note
For omnidirectional sides, you can select the CCMD card for all
the LC ports.

After successful analysis of the network, you can view the port
distribution under the L ayout > Node Diagram tab.

Currently, this property is only supported for the enhanced plate.

¢) Click Update.
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Modify L-Band Add/Drop Multiplexer Properties

Use this task to modify the properties of the add/drop multiplexer in a site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 In the network tree, Choose Sites> Site > Site domain > Side> L-Band.
Step 2 To modify the Add/Drop multiplexer card properties, perform the following steps:
a) Click Add/Drop.

You can view the properties of the add/drop multiplexer at the bottom of the network tree.
b) Modify the following properties of the add/drop multiplexer:
You can also modify the properties by choosing the Add/Drop under Network > Entity Editor.

Options Platform Description

General

Colorless Add/Drop NCS 1010 The options available for NCS 1010 are:
* Auto

* None

« BRK-8

* BRK-16

« BRK-24
Note

Only L-band optical sources are supported. Pluggables are not
supported in L-band networks.

M PO Connector Add/Drop
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Modify L-Band Add/Drop Multiplexer Properties .

Options

Platform

Description

Colorless Add/Drop

NCS 1010

Note
M PO Connector Add/Drop appears for networks from R7.10.1.

The options available for NCS 1010 are:
* Auto
* None
* BRK-8
* BRK-16
* BRK-24

Note

QDD optical sources are not supported (both as optical source
and pluggable) with colorless BRK-8, BRK-16, or BRK-24
configurations.

Colorless Ports

NCS 1010

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

Note

For the R7.10.1 network, you can assign a maximum of 48
colorless ports. The assigned ports are applicable for the MPO
ports.

For the R7.11.1 network, you can assign a maximum of 128
colorless ports.

L C Connector Add/Dr

op

Colorless Add/Drop

NCS 1010

Note
L C Connector Add/Drop appears for networks from R7.11.1.

The options available for NCS 1010 are:

e Auto
* None

* NCS1K14-CCMD-16L
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Modify Network Properties |

Options

Platform

Description

Colorless Ports

NCS 1010

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

Note
For the R7.10.1 network, you can assign a maximum of 48
colorless ports. The assigned ports are applicable for the LC ports.

For the R7.11.1 network, you can assign a maximum of 128
colorless ports.
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Options

Platform

Description

Colorless Ports
Distribution

NCS 1010

* Click the field to open the Colorless Ports Distribution
pop-up window.

* Choose the CCMD card (NCS1K14-CCMD-16L) for each
of the LC ports (A/D 4 - A/D 17).

* Select the number of ports for each CCMD card, ensuring
the total does not exceed 128.

* Click Submit.

When allocating LC ports, the priority is as follows:

1. Degree connection

2. Direct LC ports

Only the remaining LC ports can be allocated to CCMD cards.

If the Degree Priority under Site Properties is set to LC Ports, the
number of CCMD cards that can be forced on the line side edges
depends on the number of degrees (including omni and line
degrees, depending on the scalable degree) and the Direct LC
ports.

This is explained in the following formula:

If Degree Priority is LC_Ports, Maximum number of CCMDs
Allowed = 14 - (scalableUptoDegree - 1) - Direct LC add/drops
- Number of Omni Edges

The number of ports that you have selected is displayed in the
field.

When the Enable Special Settingsunder the Network properties
is enabled and if the Colorless Ports Distribution has not been
set previously, it will default to 16,16,0. In this case three LC ports
already used for CCMD card.

Note
For omnidirectional sides, you can select the CCMD card for all
the LC ports.

After successful analysis of the network, you can view the port
distribution under the L ayout > Node Diagram tab.

Currently, this property is only supported for the enhanced plate.

¢) Click Update.
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Modify Client Properties

Use this task to modify the properties of a client-side attenuator in a site.

Before you begin

Table 71: Feature History

Feature Name Release Information Feature Description

Channel Attenuators Cisco ONP Release 4.2 You can set up channel attenuators
for QSFP-DD demands. You can
choose different channel attenuators
based on the specific configuration
and check for the optical feasibility
of the channel.

Log in to Cisco ONP web interface, on page 7

Procedure

Step 1 In the network tree, choose Sites> Site > Site domain > Side > Clients > Channel-Attenuators.
Step 2 In the right pane of the Entity Editor window, modify the following properties of the client-side attenuator.

Properties Platform Description

General

Wavelength NCS 2000 This column displays the selected wavelength.
RX-Attenuator NCS 2000 Choose an RX-Attenuator from the drop-down list. The

default option is Auto.

Note
You must select a wavelength to edit this field.

TX-Attenuator NCS 2000 Choose a TX-Attenuator from the drop-down list. The
default option is Auto.

Note
You must select a wavelength to edit this field.
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Sort the Network Elements .

Properties Platform Description

New Wavelength - Auto NCS 2000 Click Edit to select a Flex Grid or Fixed Grid wavelength.
Note
Select Fixed Grid (64-Chs) for SSON network with
NCS1K-MD-64-C card.
Note
NCS1K-MD-64-C card has First Channel limitation for
Colored sites. First Channel (196.1 THz) in Fixed Grid
(64-Chs) wavelength supports only Terminal Add/Drop
sites and not ROADM sites.

New Wavelength NCS 1001 Click Add to select a wavelength.

Step 3 Click Update.

Sort the Network Elements

You can sort the sites, services, fibers, waves, and SRLG in ascending or descending order. This feature is
helpful for huge networks, to find out the required site, fiber, waves, or SRLG names quickly. Click the
Ellipsisicon available in the right side of the network element, for example Sites and choose Ascending or
Descending. You can sort based on alphabets, numbers, or alphanumeric.

Regeneration Support

In optical networks, as the fiber length increases, a loss in the signal ratio and power could occur due to

attenuation and dispersion. You require a regenerator to recreate the weak and distorted optical signals through
reamplification, regeneration, and retiming processes. The regenerators remove noise and distortion, convert
the optical signal to electrical signal, and then convert the signals back to optical signals (OEO conversion).

Cisco ONP supports creation of regeneration sites in the network.

)

Note A regenerator site can only be a ROADM site.

Create a Regeneration Site

Table 72: Feature History

Feature Name

Release Information

Feature Description

Level

Wavelength Forcing at the Section

Cisco ONP Release 4.1

This feature allows you to assign
different wavelengths for different
sections of the Regen sites.
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Use the following procedure to create a regeneration site in the network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Choose File > Open.
The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks. This opens the selected network’s map.

You can also add a regeneration site when you are designing a new network or upgrading a network.

Step 3 In the network tree, expand Waves, select a wave and drill down to its trail.

Note
If the network is an SSON network or NCS 1010 network, you see M edia Channels or Circuitsrespectively. instead of
waves. Expand Media Channels or Circuits, and drill down to its trail.

Step 4 Click the trail.

You can view the properties of the trail at the bottom of the network tree.

Step 5 From the Regen Sites drop-down list, select a regeneration site.

Note

If you select a fiber from the Path of Wave drop-down list, you cannot select any regeneration site to force a path.
Similarly, if you select a regeneration site, you cannot force a path for the wave. However, if you want to force a fiber,
select the fiber from the Path of Wave drop-down list available under the section properties.

Step 6 (Optional) Select the wavelength of each section in the properties for non-SSON network.

Note
For the SSON network, you can select the wavelength only at the trial level.

Step 7 Click Update.

A new section is added along with the existing section under the trail, whenever a regeneration site is created. Regeneration
can be performed using any two cards back-to-back or with a dedicated regenerator card.

Step 8 Click Analyze to analyze the network.

After analysis, if you click trail or section in the network tree, the map highlights the trail in orange color, and the section
in green color.

Note
You can assign different wavelengths for different sections. The Central Wavelength is denoted as a *, when different
wavelengths are assigned for different sections.
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Multidegree ROADM

In multidegree ROADM, sites have two or more sides and face two or more fibers spans. You can select the
degree of a node from the Cisco ONP GUI. The values are 2, 4, 8, 12, and 16 for Evolved Mesh (EV) ON
and OFF scenarios. The default value is 4. Degrees 5, 9, and 13 are not supported. EV flag is editable.

Prerequisites for Cascaded SMR
* The Structure field under C Band in the Entity Editor must be Multidegree.
* The Site Type field under C Band in the Entity Editor must be SMR-20.
* The Evolved Mesh check box under General in the Entity Editor must be checked.
* The Degree Mesh Type field under C Band in the Entity Editor must be Auto or DEG-5/UPG-4.
* The Mpol6TOM po8 field under General in the Entity Editor must be MPO16To2MPOS cable.

* By default, the Cascaded SMR check box is unchecked, but you can edit in the design mode as a site
property. Check the Cascaded SMR check box for contentionless side creation. L2 SMR is supported
for both SSON and Non-SSON networks.

* You can edit the Cascaded SM R check box when Evolved M esh is ON and the SMR-20 card is selected.
You can create Layer 2 SMR sides only after you check the Cascaded SMR check box.

* You can create contentionless sides manually and force the contentionless ports. The default value is 16
for the contentionless ports. The range of values is 0—16.

Limitations
* Supports only contentionless add/drop demands.

* Supports Layer-2 SMR for SMR-20 card only.
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Configure a Network

Table 73: Feature History

Feature Release Feature Description

Name Information

MOLS 2.0 | Cisco ONP | CONP now supports the latest Metro DCI Open Line System, MOLS 2.0,

Support Release which is hosted on the NCS 1014 chassis. This includes support for:
25.1.1

» new EDFA amplifier that hosts
» anew OTDR pluggable (ONS-QSFP-OTDR),
* a new coherent probe pluggable (DP01QSDD-ZT5-A1), and
« an existing OSC pluggable (ONS-SC-PTP-1510), and

* a pair of new 32-channel colored add/drop passive modules

* NCS1K-MD-320-CE
* NCS1K-MD-32E-CE

Select the NCS 1014 platform during network creation to create MOLS 2.0
networks. You can design the new MOLS 2.0 networks through the properties.

* Probe Channel and OTDR Pluggable at the nework level,
* OSC Pluggable property at the edge level,

* the MOLS 2.0 colored add/drop modules (default option is odd + even
cards) at add/drop level, and

* noneditable Pre Amp, Pre PSD, Second Booster, Second Booster PSD
at the C-band amplifier level.

Cisco Optical Network Planner Configuration Guide, Releases 25.x.x [Jj



Configure a Network |

. Configure a NCS 2000 Network for Contentionless Functionality

Feature Release Feature Description

Name Information

Transponder | Cisco ONP | This release introduces the transponder aggregation service, which provides
Aggregation |Release comprehensive support for transponder service aggregation across NCS 1000
Service 25.1.1 line cards on all LO platforms. Key features include:

* Support for transponder service creation and network-wide analysis,
considering transponder services in both greenfield and brownfield
deployments.

* Compatibility with NCS 2000, NCS 1001, NCS 1010, and NCS 1014
platforms, with specific add/drop support for each platform.

* Force update the transponder properties, with support for service control,
property override, and Ul configurations.

« Update Optical, Traffic, BOM, Installation Parameters, and Cabling
Reports to include transponder parameters.

* Placement of transponder cards in NCS1004 and NCS1014 chassis, with
NFV view including Transponder connections.

* Draw services between ROADM/Terminal/Traffic sites, force transponder
properties, and view updated BOM and reports after network analysis.

This chapter describes the various ways of configuring the network designed through Cisco ONP.

* Configure a NCS 2000 Network for Contentionless Functionality, on page 220

* Configure an NCS 2000 Network for Colorless Functionality, on page 221

* Configure an NCS 2000 Network for Colored Functionality, on page 222

* Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers, on page 223

* Configure an NCS 1010 Network for Colorless Functionality, on page 227

* Configure an NCS 1010 Network for Colored Functionality, on page 228

* Configure an NCS 1010 Network with Mixed Add/Drop Multiplexers and Demultiplexers, on page 229

* Configure an NCS 1010 C+L-Band Network with Mixed Add/Drop Multiplexers and Demultiplexers,
on page 229

* Configure an NCS 1010 Network for Omnidirectional Functionality, on page 230

* Configure an NCS 1001 Network for Colored Functionality, on page 231

* Configure an NCS 1014 Network for Colored Functionality, on page 231

* Configure a NCS 1001/1010/1014 Network with NCS 1000 Transponders, on page 232

* Configure a NCS 2000 Network with NCS 1000 Transponders, on page 233

Configure a NCS 2000 Network for Contentionless Functionality

Use the following procedure to configure the contentionless functionality in a network:

Before you begin

Log in to Cisco ONP web interface, on page 7
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Procedure

Step 1
Step 2
Step 3

Step 4

Configure an NCS 2000 Network for Colorless Functionality .

Create a network design. See Design a network using Cisco ONP, on page 24 .

Add contentionless sides to the required sites. See Add Contentionless Side to a Site, on page 142.

Set the channel type for the demands:

a)
b)

c)

In the Entity Editor window, click the Servicestab.

Click the service connecting the site and set the Src Channel Type property as Auto or Contentionless. Similarly,
click the trail under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property
as Auto or Contentionless.

Note
Contentionless is the default option when you select Auto.

Click Update.

Analyze the network by choosing Network > Analyze.

Configure an NCS 2000 Network for Colorless Functionality

Procedure

Step 1
Step 2

Use the following procedure to configure the colorless functionality in a network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Create a network design. See Design a network using Cisco ONP, on page 24 .

Set the channel type for the demands:

a)
b)

c)

In the Entity Editor window, click the Servicestab.

Click the service connecting the site and set the Src Channel Type property as Colorless. Similarly, click the trail
under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property as Colorless.
Under the Site > Side properties, choose the Line type side from which you want to create the colorless demand, and
enter the number of Colorless Ports.

From Release 24.3.1, you can select the colorless ports for the SMR-9 card.

The number of colorless ports for MF-6AD-CFSdepends on the Scalable Upto Degr ee property. The following table
explains the same.

Table 74: Colorless Ports for SSON and Non-SSON Networks

Site Type Scalable Upto Maximum Number of Colorless Maximum Number of Colorless
Degree Ports for SSON Ports for Non-SSON
SMR-20 4 72 72
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Site Type Scalable Upto Maximum Number of Colorless Maximum Number of Colorless
Degree Ports for SSON Ports for Non-SSON

SMR-20 8 72 72

SMR-20 12 24 24

SMR-20 16 24 24

SMR-20 Line 96 96

SMR-20 Terminal 120 96

d) Click Update.

Step 3 Under the C-Band properties, choose MF-6AD-CFSor Direct SMIR as the Colorless Add/Drop.

Step 4 Click Update..

Step 5 Analyze the network by choosing Network > Analyze.

You can see the colorless Add/Drop unit getting added in the layout and BOM.

Configure an NCS 2000 Network for Colored Functionality

Use the following procedure to configure the colored functionality in a network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .

Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Servicestab.
b) Click the service connecting the site and set the Src Channel Type property as Colored. Similarly, click the trail
under the wave (for non-SSON) or media channel (for SSON) and set the Src Channel Type property as Colored.

¢) Click Update.

Step 3 For SSON network, perform the following:
a) Under the C-Band properties, choose MD-64-C as the Colored Add/Drop.

Note

MD-64-C is supported from NCS 2000 Release 12.x.

b) Click Update..

For non-SSON network, by default, MD-48-ODD or MD-48-EVEN is added as the Colored Add/Drop when Share
SMR Port is not enabled.
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Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers .

Note
If you choose MD-48-EVEN or MD-48-ODD, make sure to select an even wavelength for the Wavelength property under
Trail.

Step 4 When Share SMR Port port is enabled, you can select the Colored Add/Drop by using the following steps:

a) Under the C-Band properties, choose MD-438-ODD, MD-48-EVEN, or MD-48-ODD+MD-48-EVEN as the Colored
Add/Drop.

Note
The above mentioned Add/Drop units are supported from NCS 2000 Release 11.x.

b) Click Update.
Step 5 Analyze the network by choosing Network > Analyze.
You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure a Network with Mixed Add/Drop Multiplexers and
Demultiplexers

Use the following procedure to configure mixed wavelengths in a network:
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Table 75: Feature History

Configure a Network |

Feature Name

Release Information

Feature Description

Support for Mixed Add/Drop
Configuration

Cisco ONP Release 4.2

You can configure different
functionalities in the network created
in Cisco ONP. Mixed wavelengths
such as colorless and contentionless,
colored and contentionless, can be
added/dropped on the same side or
direction. The following mixed
configurations are supported:

* Colored
(MD-48-ODD/MD-48-EVEN)
and Contentionless
(16-AD-CCOFS) without shared
SMR port

* Colored and Contentionless
(MD-64-C and 16-AD-CCOFS)

* Colored (MD-64-C) and
Colorless (Direct SMR)

* Colored (MD-48) and
Contentionless (16-AD-CCOFS)
with Shared SMR Port

* Colorless and
MD-48-ODD/MD-48-EVEN

* Colorless and 16-AD-CCOFS

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .

Step 2 Set the properties of the network under the Entity Editor for different combinations of the functionalities, as described

in the following table:
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Table 76: Supported Mixed Configurations

Supported
Network Type

Possible Mixed Configurations

Properties to be Set

Non-SSON

Colored (MD-48-ODD/MD-48-EVEN) and
Contentionless (16-AD-CCOFS) without shared
SMR port

* Add required number of contentionless sides.

» Channel Type—Set the Src Channdl Type
and Dst Channel Typeto be Colored for
one wave. Set the Src Channel Type and
Dst Channel Typeto be Contentionless for
the second wave created on the same site.
Both wavelengths must add/drop in the same
side or direction.

By default, MD-48-ODD or MD 48-EVEN
is added as the Colored Add/Drop in the
BOM and layout, when you set the Channel
Typeas Colored and when Shared SMR
Port is disabled.

By default, 16-AD-CCOFS is added in the
BOM and layout, when you set the Channel
Type as Contentionless.

SSON

Colored and Contentionless (MD-64-C and
16-AD-CCOFS)

Add required number of contentionless sides.

Channel Type—Set the Src Channd Type
and Dst Channel Typeto be Colored for
one media channel. Set the Src Channel
Type and Dst Channel Typeto be
Contentionless for the second media channel
created on the same site. Both channels must
add/drop in the same side or direction.

Colored Add/Drop—MD-64-C under the
side.

SSON

Colored (MD-64-C) and Colorless (Direct SMR)

Channel Type—Set the Src Channel Type
and Dst Channel Typeto be Colored for
one media channel. Set the Src Channel
Typeand Dst Channd Typeto be Colorless
for the second media channel created on the
same site. Both channels must add/drop in
the same side or direction.

 Enter the number of Colorless Portsunder
the Line Side properties.

» Colored Add/Drop—MD-64-C
Colorless Add/Drop—Direct SMR
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Supported
Network Type

Possible Mixed Configurations

Properties to be Set

Non-SSON

Colored (MD-48) and Contentionless
(16-AD-CCOFS) with Shared SMR Port

* Add required number of contentionless sides.

» Channel Type—Set the Src Channéd Type
and Dst Channel Typeto be Colored for
one wave. Set the Src Channel Type and
Dst Channel Typeto be Contentionless for
the second wave created on the same site.
Both wavelengths must add/drop in the same
side or direction.

» Check the Shared SMR Port check box,
under the Site properties.

* Colored Add/Drop—MD-48-ODD,
MD-48-EVEN, or MD-48-ODD and
MD-48-EVEN

If you choose MD-48-EVEN, make sure to
select an even wavelength for the
Wavelength property under Trail.

Non-SSON

Colorless and MD-48-ODD/MD-48-EVEN

» Channel Type—Set the Src Channel Type
and Dst Channel Typeto be Colorless for
the wave.

» Enter the number of Colorless Ports under
the Line Side properties.

* By default, MD-48-ODD/MD-48-EVEN is
added as colored Add/Drop in the BOM and
layout, when any colored demand is added
in the non-SSON network.

SSON

Colorless and Contentionless (16-AD-CCOFS)

* Add required number of contentionless sides.

» Channel Type—Set the Src Channéd Type
and Dst Channel Typeto be Colorless for
the wave or media channel.

» Channd Type—Colorlessfor one wave and
Contentionless for another wave created on
the same site. Both wavelengths must
add/drop in the same side or direction.

Note

MF-6AD-CEFS colorless configuration cannot be mixed with any other configurations.

The following is the list of mixed configurations that are not supported by Cisco ONP.
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Table 77: Unsupported Mixed Configurations

Network Type Mixed Configurations

SSON Colored (MD-64-C) and Colorless (MF-6AD-CFS)

SSON Contentionless and Colorless (MF-6AD-CFS)

SSON Colored (MD-64-C), Contentionless, and Colorless
(MF-6AD-CFS)

SSON Colored (MD-64-C) and Layer-2 Contentionless

Non-SSON Contentionless and Colorless (MF-6AD-CFS)

Non-SSON Colored (MD-48) and Colorless (MF-6AD-CFES)

Non-SSON Colorless (Direct SMR) and Colorless (MF-6AD-CFS)

Non-SSON Colored, Contentionless, and Colorless (MF-6AD-CFS)

Configure an NCS 1010 Network for Colorless Functionality

Use the following procedure to configure the colorless functionality in an NCS 1010 network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Servicestab.
b) Click the trail under the circuit set the Src Channel Type property as Colorless.
¢) Click Update.

Step 3 Under the C-Band properties, choose BRK-8, BRK-16 or BRK-24 as the Colorless Add/Drop.

The Maximum number of colorless ports depends on the scalable up to degree. The following table explains the same.

Table 78: Colorless Ports for NCS 1010 Networks

Scalable Upto Degree | MPO Port Used for Maximum Number of Colorless Ports Supported
Degree Interconnect

BRK-24 BRK-16 BRK-8

7 4 72 48 24
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Scalable Upto Degree | MPO Port Used for Maximum Number of Colorless Ports Supported
Degree Interconnect
BRK-24 BRK-16 BRK-8

9 1 66 44 22
15 3,4 48 32 16
17 1,2 42 28 14
23 2,3,4 24 16 8
25 1,2,3 18 12 6
31 1,2,3,4 0 0 0
Terminal NA 90 60 30
Line 4 72 48 24

Note
Colorless configuration is not supported for scalable upto degree 31.

Step 4 Click Update.
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colorless Add/Drop unit getting added in the layout and BOM.

Configure an NCS 1010 Network for Colored Functionality

Use the following procedure to configure the colored functionality in an NCS 1010 network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the channel type for the demands:

a) Inthe Entity Editor window, click the Services tab.
b) Click the trail under the circuit and set the Src Channel Type property as Colored.
¢) Click Update.

Step 3 Under the C-Band properties, choose MD-32-EVEN, MD-32-ODD, or MD-32- ODD+MD-32-EVENas the Colored
Add/Drop.

Step 4 Click Update.

Step 5 Analyze the network by choosing Network > Analyze.
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You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure an NCS 1010 Network with Mixed Add/Drop
Multiplexers and Demultiplexers

Use the following procedure to configure mixed wavelengths in an NCS 1010 network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the properties under the Entity Editor for different combinations of the functionalities:

For example, set the source Add/Drop Type and destination Add/Drop Typeto Colored for one circuit. Set the Src
Channel Typeand Dst Channel Type to Colorless for the second circuit created on the same site. Both channels must
add/drop in the same side or direction.

You can choose any combination of the colored or colorless add/drop.

Note
When the Scalable Upto Degreeis 31, the colorless configuration is not supported, and hence mixed configuration is

also not supported for Scalable Upto Degree 31.

Configure an NCS 1010 C+L-Band Network with Mixed Add/Drop
Multiplexers and Demultiplexers

Use the following procedure to configure mixed wavelengths in an NCS 1010 C+L-Band network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the properties under the Entity Editor for different combinations of the functionalities:
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For example, set the source Add/Drop Type and destination Add/Drop Typeto Colored or Colorless for the C-band
circuit. Set Band Type as L-band for the second circuit created on the same site. Both channels must add/drop in the
same side or direction.

You can choose any combination of the colored or colorless add/drop for C-band circuits. However, for L-band circuits,
colorless add/drop is the default value.

Note
When Scalable Upto Degreeis 31, only C-band colored configuration is supported. Colorless cannot be created as all
colorless ports are exhausted and hence mixed configuration is also not supported for Scalable Upto Degree 31.

Configure an NCS 1010 Network for Omnidirectional
Functionality

Use the following procedure to configure colored and colorless omnidirectional functionalities in an NCS
1010 network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure
Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Add Omnidirectional sides to the required sites. See Add Omni-Directional Side to a Site, on page 148. You can also use

the Max Auto Omni Allowed property under the network properties. Based on the number that you enter, Cisco ONP
will automatically generate up to that many Omni Edges and run the analysis.

Step 3 Select the Omni variant and type of omnidirectional add/drop stage.
a) In the Entity Editor window, click the Sites tab.
b) Choose the omnidirectional side under the required site, and set the following properties.

Omni Variant: Select the type of omni variant as Dual OLT or 4x4 COFS. The available options are:

Omni Directional Ports: Enter the number of omnidirectional ports.

Step 4 Select the type of omnidirectional add/drop stage.
a) In the Entity Editor window, click the Servicestab.
b) Choose the required service and set the Src Add/Drop Type and Dst Add/Drop Type as omni-colored or
omni-colorless.
¢) Choose the trail under the service, and set the Add/Drop Type as omni-colred or omni-colorless.
Step 5 Click Update.
Step 6 Analyze the network by choosing Network > Analyze.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Configure a Network
Configure an NCS 1001 Network for Colored Functionality .

You can see the Omni Add/Drop unit getting added in the layout and BOM.

Configure an NCS 1001 Network for Colored Functionality

Use the following procedure to configure the colored functionality in an NCS 1001 network.

\}

Note Deployment of more than two OLA nodes between two Terminal Sites is not supported.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the trail under the circuit and set the Src Add/Drop Type property as Colored.
¢) Click Update.

Step 3 Under the C-Band properties, choose MD-32-EVEN, FLD-4, MD-48-ODD, MD-48-EVEN, MD-48-ODD+MD-48-EVEN,
or MD-64 as the Colored Add/Drop.

Step 4 Click Update.
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure an NCS 1014 Network for Colored Functionality

Use the following procedure to configure the colored functionality in an NCS 1014 network:

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the channel type for the demands:
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a) In the Entity Editor window, click the Servicestab.
b) Click the trail under the circuit and set the Src Add/Drop Type property as Colored.
¢) Click Update.

Step 3 Under the C-Band properties, choose MD-32-EVEN, MD-32-ODD, or MD-32- ODD+MD-32-EVENas the Colored
Add/Drop.

Step 4 Click Update.
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure a NCS 1001/1010/1014 Network with NCS 1000
Transponders

Use the following procedure to add transponders in a network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Create a network design. See Design a network using Cisco ONP, on page 24 .
Step 2 Set the TXP Chassis and Card type for the transponders.
a) In the Entity Editor window, click the Servicestab.

b) At circuit/media channel level, set Traffic Type as Transponder Card.
At trail level, Card Type and TXP Chassis properties appear.

¢) Click the trail under the sections, set the TXP Chassis and Card Type properties.
d) Click the services under the services and set the TXP Chassisand Card Type properties.

Choose the required chassis and card type.

Table 79: Supported Transponders

TXP Chassis Card Type

NCS 1014 « Auto

« NCS1K14-2.4T-K9

« NCS1K 14-2.4T-X-K9
« NCS1K4-QXP-K9

NCS 1004 * Auto

* NCS1K4-QXP-K9
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Step 3
Step 4
Step 5

Configure a NCS 2000 Network with NCS 1000 Transponders .

e) Click Update.

Under the C-Band properties, choose the required multiplexer and demultiplexer.
Click Update.
Analyze the network by choosing Network > Analyze.

Configure a NCS 2000 Network with NCS 1000 Transponders

Procedure

Step 1

Step 2

Step 3

Use the following procedure to add transponders in a network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Create a network design. See Design a network using Cisco ONP, on page 24.
a) Enable SSON Network check box and choose Traffic type as NCS (4K_1K_2K).
b) In the design palette, use the drawing tool to add traffic sites to the network.

Set Traffic Site and Traffic Type.

a) In the Entity Editor window, click the Site tab and expand the sites.
b) Select a site.
On the right pane, the General tab opens.

¢) Under the General tab, set Type as Traffic and Traffic Type as 1K-2K.

Set the TXP Chassis and Card type for the transponders.
a) In the Entity Editor window, click the Service tab.

b) At circuit/media channel level, set Traffic Type as Transponder Card.
At trail level, Card Type and TXP Chassis properties appear.

¢) Click the trail under the sections, set the TXP Chassis and Card Type properties.
d) Click the services under the services and set the TXP Chassisand Card Type properties.

Choose the required chassis and card type.

Table 80: Supported Transponders

TXP Card Type
Chassis

NCS 1014 |« Auto

« NCSIK14-24TK9
« NCSIKH24TXK9
« NCSIK4-QXPK9
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TXP Card Type
Chassis
NCS 1004 * Auto
« NCSIK4-QXPK9

e) Click Update.

Step 4 Under the C-Band properties, choose the required multiplexer and demultiplexer.

Step 5 Click Update.

Step 6 Analyze the network by choosing Network > Analyze.
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View Network Reports

Table 81: Feature History

Feature Name Release Information Feature Description

Deployability and Debuggability | Cisco ONP Release 24.3.1
Enhancements
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Feature Name Release Information Feature Description

Cisco ONP enhances the
debuggability and deployability of
the network with the following
improvements in Optical sources,
and various reports available in the
Results page:

* Optical Sources: Including
new optical parameters such
as vendor name, vendor ID,
and submode in the
downloaded optical souce
Excel file to improve
inperoperability with Cisco
Optical Network Controller.

* BOM: The exported Excel file
includes these updates:

* Sales BOM Sheet:
Providing information
tailored for sales
personnel.

* Net BOM Sheet:
Providing the site-wise
BOM count and
categories of elements
such as Chassis,
Controllers, Mux-Demux
units, Line Cards, Fillers,
and more, offering a
comprehensive overview
of all network elements
in the analyzed network.

« |PC:

* Consolidating the IPC
Cabling Report and the
IPC Patch Report into a
unified view with
additional columns,
streamlining connection
details and eliminating
the need to access
multiple sources.

* Highlighting patches
when clicked.

* Optical Reports: Filtering
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Feature Name

Release Information

Feature Description

results by any column
available in the report for
more precise data analysis.

» Elements > M essages:
Providing links to navigate to
the respective object in the
network tree, allowing users
to take the necessary action to
correct errors.
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Table 82: Feature History

Network reports .

Feature Name

Release Information

Description

Simplified Navigation to Results
Tab

Cisco ONP Release 5.1

Cisco ONP now provides a
simplified approach to navigate to
the Resultstab to view reports for
analyzed multinode network
topologies with the following
enhancements:

* Click the Ellipsisicon
available in the right side of
a particular site in the network
tree to view:

* BOM details

* Optical Reports

Click the Ellipsisicon
available in the right side of
a particular
circuit/media/wave in the
network tree to view:

* Optical Report
» Traffic Report

New |PC tab —The I PC tab
is introduced in Cabling
Reports to intuitively view
the internal patch connections
for a site.

Search Box—The Resultstab
is enhanced with a Search Box
at the top. You can use this
search box to find a particular
site in the topology by
entering the site name.

» Network reports, on page 239

Network reports

The Cisco ONP home page has multiple tabs to access the reports of the analyzed network. You can also view
the reports for specific site, fiber, or wave properties by clicking the respective report in the Network Tree

pane. The tabs are:

» Dashboard

Cisco Optical Network Planner Configuration Guide, Releases 25.x.x [Jj



. View reports in the Dashboard tab

* Elements
* Map

* BOM

* Layout

* Results

View reports in the Dashboard tab

Table 83: Feature History

View Network Reports |

Feature Name

Release Information

Feature Description

View sustainability report

Cisco ONP Release 25.1.1

The Sustainability Insightstab in the Cisco ONP
Dashboard presents these sustainability metrics for
a network designed in Cisco ONP:

* Energy Consumption Distribution (kWh)
* CO2 Emission (Kg)
* Energy Efficiency (kWh/GHz)

* CO2 Emission Equivalent: This shows the
number of miles traveled by a car, bus, and
airplane that would produce the same amount
of CO2 emissions.

* Number of Trees Needed: Indicates the number
of trees that would need to be planted to absorb
the network's carbon emissions.

This report helps you understand the environmental
impact of the optical networks you design.

From Release 25.1.1, Cisco ONP uses the Energy Management Capability (EMC) API to display sustainability
reports. The EMC API calculates sustainability metrics by considering the power consumption and the

geographical location of the site. See Formulas for sustainability calculation , on page 242 to know how the
EMC API does the calculation.

Follow these steps to view various reports of an analyzed network under the Dashboar d tab.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Enable Sustainability report, on page 241 to view the sustainability report.
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Procedure

Step 1
Step 2

Step 3

Enable Sustainability report .

Open the analyzed network for which you want to view the network summary.
Click the Dashboard tab.

By default, the Network Summary tab will appear and display this information about the network:

* Total count of sites

* Total count of fibers

* Total count of SRLGs (Shared Risk Link Groups)
* Total count of services

* Total count of waves/media channels/circuits

* Total count of messages

Click the Sustainability Insightstab to view the sustainability metrics for a network designed in Cisco ONP.
* Energy Consumption Distribution (kWh)
* CO2 Emission (Kg)
* Energy Efficiency (kWh/GHz)

* CO2 Emission Equivalent: This shows the number of miles traveled by a car, bus, and airplane that would produce
the same amount of CO2 emissions.

* Number of Trees Needed: Indicates the number of trees that would need to be planted to absorb the network's carbon
emissions.

a) Click the BypassEMC API radio button to display default values for the metrics regardless of the site's location or
its power consumption.

Enable Sustainability report

Procedure

Step 1
Step 2

Step 3

Use this task to enable the Sustainability Insightstab under the Cisco ONP Dashboard.

Log in to the server where Cisco ONP is installed.

Use the cd command to go to the cnp directory and then to the conf directory.

Example:
root#cd /opt /cnp / conf

use the vi feature.properties command to open the feature.properties file in the vi editor.

Example:
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root:/opt/cnp/conf# vi feature.properties

Step 4 Edit the file.
a) Change SustainabilityInsights.enabled=false to Sustainabilitylnsights.enabled=true.
b) Press the w and q keys to save and exit the vi editor.

Example:

twq

What to do next

View reports in the Dashboard tab, on page 240

Formulas for sustainability calculation
The EMC API calculates sustainability metrics using these formulas:
1. Energy Consumed (kWh)
Formula:
EnergyConsumed = PowerUtilizedByNode * ObservationPeriodicity / 60
PowerUtilizedByNode: The total power consumed by the optical node (in Watts).
ObservationPeriodicity: The observation duration, fixed at 300 seconds (approximately 5 minutes).
2. Carbon Emission (kg)
Formula:
CarbonEmission = EnergyConsumed * CarbonIntensity

Carbonlntensity: The value obtained from the EMC API. If the EMC API does not return a value, a default
constant value of 442 is used.

3. Energy Efficiency (kWh/GHz)
Formula:
EnergyEfficiency = EnergyConsumed / TrafficServed
EnergyConsumed: The result from the first formula.

TrafficServed: The total traffic passing or reserved in the network

View reports in the Elements tab

The Elements tab provides comprehensive reports of network elements and any associated messages.

Follow these steps to view the network elements report and messages.

Before you begin

Log in to Cisco ONP web interface, on page 7.
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Procedure

Step 1
Step 2

Step 3
Step 4

View reports in the Elements tab .

Open the analyzed network for which you want to view the network summary.

Click the Elements tab.

You can view the reports described in this table.

Table 84: Reports under Elements

Report

Description

Sites

Shows the site information, which consists of the name of the sites, their types, and
their X and Y coordinate values.

Fibers

Shows the information about the fiber length between the source and the destination
for the corresponding sites.

You can sort and filter the fiber details available in each column of the table.

Services

Shows the service type, source and destination sites for particular service, quantity,
protection type, and status.

For each service, the report shows the primary path, secondary path, and their status.

Waves

The Waves report shows the number of waves available in the network and the wave
utilization. Click each wave to view the following details:

» Wave: Consists of a wave UID and its source and destination sites.

» Wave Details: Provides details of wave OSNR, channel path, OTN services
associated to wave and excluded channels.

* Channels: Port details of the source and destination cards, the wavelength that
is used, and its utilization demands.

* Optical Results: Provides details of optical parameters such as OSNR, SOL,
EOL, power margin, CD, and PMD.

SRLGs

Lists the names of created SRLGs and their fiber details. Click Export at the bottom
to export the report in .xlsx format.

Messages

Shows messages that relate to errors that occurred while analyzing the network. By
default, only critical messages for the analyzed network are listed here. You can
disable the Critical Only toggle button to view all messages.

Click the link in the Target column to navigate to the respective object in the network
tree and take the necessary action to correct the error.

Click each tab to view the respective report.

Click the Pop-up icon to view the reports in a larger, resizable window.
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View details of the BOM report

Procedure

Step 1
Step 2

Step 3

Step 4

Table 85: Feature History

View Network Reports |

Feature Name

Release Information

Feature Description

MLP Brownfield with Diff BOM

Cisco ONP Release 4.1

This feature allows you to perform
the following:

* Compare the BOMs of two or
more LNI imported networks.

 Upgrade brownfield network.

» Upgrade the Cisco ONP
network with traffic sites.

The Bill of Materials (BOM) report includes these components:

* Detailed price lists for each site.

* Categories of elements such as Chassis, Controller, Mux-Demux, Line Card, Filler, and more.

» The overall BOM for the entire network.

Follow these steps to view the BOM report for an analyzed network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Open the analyzed network for which you want to view the BOM.
Click the BOM tab.

The BOM details are displayed.
To view the BOM details for OTN and DWDM separately, click each site. See Licensed PIDs available in the BOM

report, on page 245for the list of licensed PIDs added into the BOM report.

See for the list of licensed PIDs added into the BOM report.

View the BOM details for any particular site.

a)
b)

c)

Expand the Site to view the PID information.

In the network tree, expand Site and click the Ellipsisicon available in the right side of the required site.
Click Open BOM

Cisco ONP opens the BoM tab and provides the BoM details of the selected site.

Click Export to export the BOM details in the form of a spreadsheet, and save it into your local system.

We recommend that you export the BOM report only in analyze mode. Exporting the reports in the upgrade and release
upgrade modes may lead to inaccuracies..
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From Release 24.3.1, the exported Excel file includes these updates:
» SalesBOM Sheet: Contains information tailored for sales representatives.

* Net BOM Sheet: Now includes the sitewide BOM count, providing a comprehensive overview of all network
elements in the analyzed network.

Step 5 Compare the BOM of the existing network with other networks:

a) Click Comparewith: Other Networks.
b) From the Other Networks dialog box, choose the network that you want to be compared with.

You can view both BOM reports displayed on the same page for comparison.

Step 6 Use the Search box on top of the BOM reports to search for any specific site or wave in the reports.

a) Enter the name of the specific site or wave in the Search box.
b) Choose equals or contains from the drop-down list.
c) Click the Search icon to search for the required site or wave.

Licensed PIDs available in the BOM report

Table 86: Feature History

Feature Name Release Information Feature Description
Support for New PIDs for SMR-20 | Cisco ONP Release 4.2 The following new licensed PIDs
Card for the SMR-20 card are displayed

on the BOM page so that you can
view the price details and consider
ordering.

* NCS2K-FSSMR-2LIC=
* E-NCS2K-1P-LIC=

* E-NCS2K-5P-LIC=

* E-NCS2K-10P-LIC=

Cisco ONP introduces new licensing PIDs with each platform release to incorporate the latest updates and
features.

This table lists the licensed PIDs included in the BOM report for different Cisco ONP releases.
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Table 87: Licensed PIDs added to BOM report

View Network Reports

Cisco ONP release supported from

Platform

PIDs and description

4.2

NCS 2000

* NCS2K-FSSMR-2-LIC=:
20-port FS-SMR licensed to
enable two ports

E-NCS2K-1P-LIC=":
Software license to enable one
port on licensed 20-port
FS-SMR

E-NCS2K-5P-LIC=:
Software license to enable five
ports on licensed 20-port
FS-SMR

E-NCS2K-10P-LIC=:
Software license to enable ten
ports on licensed 20-port
FS-SMR

52

NCS 1010 from Release 7.11.1

NCS1K10-ATO=:NCS 1010
ATO

SF-NCS1K 10-7111K9S=:
Software license to download
the COSM NETCONF XML
file for the COSM UL

NCS1K4-CCMD-C=:
16-port, C-Band Colorless
Coherent
Multiplexer/Demultiplexer
with an EDFA

NCS1K4-CCMD-L=:
16-port, L-Band Colorless
Coherent
Multiplexer/Demultiplexer
with an EDFA
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Licensed PIDs available in the BOM report .

Cisco ONP release supported from

Platform

PIDs and description

NCS 1020 from Release 24.3.1
NCS 1001 from Release 7.10.1

* NCS1020-SA=: NCS 1020
Shelf Assembly

* NCS1020-FAN=: NCS 1020
Fan for NCS 1014 Slots

* NCS1020-FAN-BLANK=:
NCS 1020 Fan Blank

* CWDM-SFP-1510=: CWDM
1510 NM SFP Gigabit
Ethernet and 1G/2G FC

* CWDM-SFP-1610=: CWDM
1610 NM SFP Gigabit
Ethernet and 1G/2G FC

* ONS-SC-Z3-1510=: SFP -
OC48/STM16/GE, CWDM,
1510 nm, Commercial Temp

* ONS-SC-Z3-1610=: SFP -
OC48/STM16/GE, CWDM,
1610 nm, Commercial Temp

* ONS-SE-155-1510=: SFP -
OC3/STM1 CWDM, 1510
nm, EXT

NCS 1014 transponder cards
from Release 24.3.1.
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Cisco ONP release supported from | Platform PIDs and description

* SNCS1K 14-L-100U=:NCS
1014 100G Client Capacity
Smart License - 400-600

* S-NCS1K14-L-100L=: NCS
1014 100G Client Capacity
Smart License - 700-900

* S-NCS1K14-L-100M=:NCS
1014 100G Client Capacity
Smart License - 1T-1.2T

* NCS1K14-2.4T-K9=:
Network Convergence System
1014 2.4T Line Card

* NCS1K 14-2.4T-X-K9=":
Network Convergence System
1014 2.4T-X Line Card

* NCS1K4-QXP-K9=:
NCS1004 3.2T QSFP-DD
DCO Transponder

« ESS- TXP-SIA3 : Essential
Coherent DWDM interface
SIA 36-59 months

« ESS- TXP-SIAS : Essential
Coherent DWDM interface
SIA 60-120 months

« ESS-TXP-RTU : Essential
Coherent line card interface
RTU

« ADV-TXP-SIA3: Advance
Coherent DWDM interface
SIA 36-59 months

* ADV-TXP-SIA5 : Advance
Coherent DWDM interface
STA 60-120 months

« ADV-TXP-RTU : Advance
Coherent line card interface
RTU

Note

This is applicable only for the
newly designed and upgraded
networks.
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Cisco ONP release supported from | Platform PIDs and description

25.1.1 NCS 2000 with chassis models M6, | OAS-COSM-MLCL
MI3, M2 One COSM PID is added for each
NCS 1004 active card present in the chassis.

If a chassis slot is occupied with
NCS 1014 any active card such as SMR,
NCS 1010 16-AD, EDFA, RAMAN, TXP,
PSM cards, OLT, ILA,
NCS 1020 NCS1K14-2.4T-KO9,
NCS1K14-2.4T-X-K9, and
NCS1K4-QXP-K9, one license is
added for each occupied slot.

View details of layout and internal connections

Follow these steps to obtain the layout details and internal connections of an analyzed network.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Click the Layout tab on the Cisco ONP homepage.
Step 2 Type the site name in the search box, or select a site from the Sites drop-down list.

The site layout is displayed with its racks and cards.

a) Hover the mouse pointer over the transponder card to view the details of the slot, the PID of the card, and the ports.
b) Expand the Ports to view details, such as wavelength and trunk mode.
¢) Hover the mouse pointer over the chassis to view the total power consumption.

COSM supports up to 50 UIDs; beyond which, the site layout displays incorrect UID for the chassis.

Step 3 Click the I PC tab to view the internal patch connections of the selected site.

Export Internal connections
Cisco ONP allows you to export internal fiber connections in two ways: either at site-level or network-level.

Follow these steps to export internal fiber connections.

Before you begin
Log in to Cisco ONP web interface, on page 7.

View details of layout and internal connections, on page 249
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Procedure

View Network Reports |

Step 1 Click the Ellipsisicon available in the right side of the internal fiber connection or site.

Step 2 Click Export.

View end-to-end OCH connections

Procedure

Table 88: Feature History

Feature Name

Release Information

Feature Description

View the End-to-End Optical
Channel (OCH) Connectivity from
Source to Destination

Cisco ONP Release 24.3.1

You can now view the end-to-end
OCH connection details in the
graphical form for the analyzed
NCS 1010 networks. The new
OCH tab in L ayout displays all the
OCH connectivity from source to
destination in:

* Degree Connection View:
Displays the source and
destination site's connectivity.

* Functional View: Displays
the end-to-end port and card
connections from source to
destination through the fiber.

You can now view the end-to-end OCH connection details in the graphical form in Degree Connection and
Functional views for the analyzed NCS 1010 networks.

Follow these steps to view the end-to-end OCH connectivity from source to destination.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Step 1 Open the analyzed NCS 1010 network for which you want to view the end-to-end OCH connectivity./
Step 2 Click the Layout tab on the Cisco ONP homepage.

Step 3 Click the OCH tab.

The OCH Pipes pane appears to display the sites and sections in the circuits tree.

Step 4 Click the ellipsis icon next to the Circuits.
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A pop-up list displays the view options.

Table 89: Option Descriptions

View end-to-end OCH connections .

Options Descriptions
Expand All Expands all the items in the circuits tree.
Collapse All Collapses all the items in the circuits tree.
Step 5 Use the search bar or filter icon to select the required source and destination sites.
Icon/Field Description
Search Locates the site based on the typed-in site name.
Filter Filters the circuit based on Sour ce Site and Destination
Site.
Reset Resets the filter conditions.

Based on the unit that you select in the circuit tree, you can see the site connectivity or the detailed end-to-end OCH

connectivity.
If you click the... Then you can see the...
circuit in the OCH tree source and destination site connectivity only.
sections in the OCH tree end-to-end OCH connectivity, including intermediate nodes and cards connectivity.
Step 6 In the graphical area, use the action icons to view the source and destination sites connectivity.

Table 90: Action icons

Icons Description
Zoom In Zooms in for a closer view of a specific connection
Zoom Out Zooms out for a larger view of the entire connection
Fit View Resets the zoom-in/zoom-out view to the default view
Lock/Unlock Locks the view at a specific area
Unlocks the view
Download PNG Downloads the end-to-end circuit connection as a PNG image

Switch to Degree Connection View /
Switch to Functional View

* Degree Connection View: Displays the source and destination site's
connectivity

 Functional View: Displays the end-to-end port and card connections from
source to destination through the fiber
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. Export end-to-end OCH connections

Icons Description

Reset All Nodes Position Reverts the nodes to the default position

Export end-to-end OCH connections

Follow these steps to view the end-to-end OCH connectivity from source to destination.

Before you begin
Log in to Cisco ONP web interface, on page 7

View end-to-end OCH connections, on page 250

Procedure
Step 1 In the graphical area, click the download icon.

The Export pop-up list displays the circuit options.

Table 91: Option descriptions

Options Descriptions

Current Circuit Provides details of the end-to-end OCH connectivity for the circuit that you

selected.

All Circuits Provides details of the end-to-end OCH connectivity for all the circuits.

Step 2 Click the required option to export the end-to-end OCH connectivity details to an Excel sheet.
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View power consumption and unit weight report .

View power consumption and unit weight report

Table 92: Feature History

Feature Name Release Feature Description

Information
Power Consumption | Cisco ONP Now, you can generate the power consumption and unit weight
and Unit Weight Release 5.2 report for each product ID (PID). In the layout tab, you can see the
Report power consumption and unit weight values and export them into

Excel as a report for a single site or all sites. With prior knowledge
of power consumption and weight details for each PID, you can
plan and design an energy-efficient network.

The new options that allow you to view and export the reports are:

» Show Typical Power Consumption
» Show Max Power Consumption
» Show Unit Weight

 Power Consumption & Weight

The Power Consumption and Unit Weight report includes power consumption and weight details of cards
and shelves at each site.

| A

Remember The power consumption of the Power Supply Unit (PSU) is not included in the total power consumption for
NCS 1001, NCS 1010, NCS 1014, and NCS 1020 chassis. Determine the total power consumption for these
chassis by adding 8 percent of the aggregated power consumption of all the cards inside the chassis to account
for the PSU power consumption.

\)

Note To view the power consumption and weight report, upgrade and analyze the LNI network.

Follow these steps to view the power consumption and unit weight report for each site.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Open the analyzed network for which you want to view the power consumption and weight report.
Step 2 Click the Layout tab on the Cisco ONP homepage.
Step 3 Click the ellipsis icon next to Sites.

A pop-up list displays these options.
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. Export power consumption and unit weight report

Table 93: Option descriptions

Options Description
Expand All Expands all the items in the layout tree.
Collapse All Collapses all the items in the layout tree.
Show Typical Power Check the Show Typical Power Consumption check box to view typical power
Consumption consumption values of each card and shelf in watts.
Show Max Power Check the Show Max Power Consumption check box to view the power consumption
Consumption values of each card and shelf in watts.
Max Power Consumption for a shelf is the sum of cards and modules.
Note
The total power consumption of an NCS 2000, NCS 4000, or NCS 1000 shelf changes
based on AC or DC power supply.
* For DC power supply, total power consumption of the shelf includes all Cards, DC
power module, and fan tray.
* For AC power supply in NCS 2000 M6 only, total power consumption of the shelf
includes all cards, fan tray, 10% of power consumed by all cards, and 5W of Cooling
Unit power consumption.
Show Unit Weight Check the Show Unit Weight check box to view the weight of each card and shelf in
kilograms.
The unit weight for a shelf is the sum of cards and modules.
Step 4 Select the options as you require.

Export power consumption and unit weight report

Follow these steps to export the power consumption and weight report of each shelf and card.

Before you begin

Log in to Cisco ONP web interface, on page 7

View power consumption and unit weight report , on page 253.

Procedure

Step 1 In the graphical area, click the download icon.

The Export pop-up list displays these options.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| View Network Reports

Step 2
Step 3

View the results of analyzed network .

Table 94: Option Descriptions

Options

Current | Provides details of the site that you selected.
site

All Sites | Provides details of all the sites.

Click the option as you require.

Click Power Consumption & Weight to export the optical reports details in an Excel sheet.

We recommend that you export the power consumption and weight report only in the analyze mode. Exporting the reports
in the upgrade and release upgrade modes may be inaccurate.

View the results of analyzed network

Procedure

Step 1
Step 2

)

Note You can refer to the optical results data to check and correct the optically not feasible channels. You can
modify the network properties in the Upgrade and Release Upgrade modes. After making the necessary
corrections, analyze again to update the optical results based on the new modifications.

Follow these steps to view the details of optical reports, installation parameters, traffic reports, and cabling
reports.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Open the analyzed network for which you want to view the optical results.
Click the Resultstab on the Cisco ONP home page.

By default, the Optical Report tab appears. Each row in the tab shows the performance of one optical path. See Optical
Report, on page 258.

Note
From Release 24.1.1, you can view the multicarrier sites highlighted in the Optical Report tab, and organized in the
Installation Report tab.

To view the optical report for any particular optical path:

a) In the network tree, expand Circuits/Waves/M edia Channels and click the Ellipsisicon available in the right side
of the required optical path.

b) Click Open Results.
The Cisco ONP opens the Optical Report tab and provides the details of the selected optical path.
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. View the results of analyzed network

Step 3

Step 4

Step 5

Step 6

Step 7

Step 8

¢) Expand the optical path to view the wave and aggregated wave information for a selected circuit.
From the OSNR RBW drop-down list, select the OSNR Resolution bandwidth between 0.5 nm and 0.1 nm.

The default value is 0.5 nm. You can change it in Design mode, Analyzed mode, Upgrade mode, and Release upgrade
mode. When set to 0.1 nm, the SOL G-OSNR and EOL G-OSNR values increase to 7 dB.

Click the Installation Par ameter s tab.
The Installation Parameters report specifies the values to be provisioned at installation for each site in the network.

To view the installation parameters for Automatic Node Setup (ANS) and Automatic Node Provisioning (ANP), click
the respective tabs. See Installation parameters, on page 260

Click the Traffic Report tab.
You can view the aggregated demand channel data in the form of the traffic reports. See Traffic reports, on page 261.

In Release 5.1, you can view the traffic report for all imported networks except the imported .mpz networks. To view the
traffic report for individual optical path in imported .mpz networks, you must manually search in the Search box.

To view the traffic report for any particular optical path:

a) Inthe network tree, expand Circuit and click the Ellipsisicon available in the right side of the required optical path.
b) Click Open Results.

The Cisco ONP displays the traffic report for the selected optical path.

Note

By default, Optical Result appears under the Results tab. Click Traffic Report to view traffic reports.
¢) Expand the optical path to view the wave information.
Click the Cabling Report tab. See Cabling report , on page 262

You can view the patch cord connections related to internal patch connections and multishelf management. This report
is available for the networks starting from NCS 2000 system Release 12.1.0.

To view the internal patch connections for any particular site:

a) In the network tree, expand Site and click the Ellipsisicon available in the right side of the required site.
b) Click Open Cabling Report.

The Cisco ONP opens the Cabling Report tab. By default, the | PC tab appears and provides the IPC details of the
selected site.

¢) To view the internal patch connections, expand the Site.

Use the Search box on top of the reports to search for any specific site or wave in the reports

a) Enter the name of the specific site or wave in the Search box.
b) Choose equals or contains from the drop-down list.
c) Click the Search icon to search for the required site or wave.

Click Export Report to export the optical reports details in an Excel sheet.

We recommend exporting the optical report only in analyze mode. Exporting reports in upgrade and release upgrade
modes may be inaccurate.
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Compare installation parameters of two networks

Compare installation parameters of two networks .

Table 95: Feature History

Feature Name Release Information

Feature Description

UI Revamp of Optical Reports Cisco ONP Release 4.1

This feature improves the user
experience while comparing the
installation parameters and optical
reports of two networks.

Use this task to compare the installation parameters of two networks.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Click the Resultstab on the Cisco ONP home page.

Step 2 Click Installation Parameters.

Step 3 Click Other Networks.

Step 4 From the list of networks, select the network with which to compare.
FInd a new parameter called diffBy.

Step 5 To stop comparing the two networks, click Clear.

Step 6 Click Export Report to export the comparison report.

Compare the optical reports of two networks

Follow these steps to compare the optical reports of two networks.

Before you begin

Log in to Cisco ONP web interface, on page 7.

Procedure

Step 1 Click the Results tab on the Cisco ONP home page.

Step 2 Click Optical Report.

Step 3 Click Other Networks.

Step 4 From the list of networks, select the network with which to compare.
The optical parameters display two values.

Step 5 To stop comparing the two networks, click Clear.
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View Network Reports |

Step 6 Click Export Report to export the comparison report.

Optical Report

From Release 24.3.1, you can filter the results by any column available in the report for more precise data
analysis. For reports represented as colored icons, you can use the first letter of the color (e.g., "g" for green)

to filter the results.

Table 96: Optical Report

Optical Parameter

Name

Displays the ID number of the wave and aggregated waves. ID is automatically
generated based on the site name.

Protection

Displays the protection type of the wave.

Protection Type

Displays whether the path type is Protected or Working path for NCS 1001.

SOL

Displays an icon indicating the results summary of the analysis that is run with
Start of Life (SOL) fiber loss values:

* Green indicates success.
* Yellow indicates success with a marginal failure risk.
* Orange indicates that the channel has a higher risk of failure.

* Red indicates failure.

EOL

Displays an icon indicating the results summary of the analysis that is run with
End of Life (EOL) fiber loss values. The indicator shows the optical performance
for the path at the end of the fiber life:

* Green indicates success.
* Yellow indicates success with a marginal failure risk.
* Orange indicates that the channel has a higher risk of failure.

* Red indicates failure.

SE

Indicates a system-related error that may impact the analysis of the design. If
the indicator is red, review the messages that are reported at the end of the analysis
or determine which units or sites have a problem.

P/F

Displays the present or forecast services indication.

Source

Displays the name of the source site and side; for example, Site 1-E.

Src Colorless

Displays whether the colorless functionality is enabled on source ports.

Src Contentionless

Displays whether the contentionless functionality is enabled on source ports.

Destination

Displays the name of the destination site and side; for example, Site 1-E.

Dst Colorless

Displays whether the colorless functionality is enabled on destination ports.
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Optical Report .

Optical Parameter

Dst Contentionless

Displays whether the contentionless functionality is enabled on destination ports.

Wavelength Displays the wavelength of the optical channel.

Band Type Displays the band type of the optical path.

Src Tx Type Displays the type of DWDM unit or pluggable port module that is used at the
source of the specific Optical Channel (OCH) trail. The class of the DWDM unit
is also displayed.

Dst Tx type Displays the type of DWDM unit or pluggable port module that is used at the
destination of the specific OCH Trail. The class of the DWDM unit is also
displayed.

Span Displays the total span length (source to destination) for this path in kilometers.

Suggested Regen Displays the regeneration locations.

Locations

BER Target Displays the bit error rate (BER) target for this channel, based on the capability
of the channel’s optical interface. It is 1.0E-15 for the interfaces using forward
error correction (FEC) and 1.0E-12 for interfaces without FEC.

SOL OSNR Displays the start of life average Optical Signal to Noise Ratio (OSNR) value
at the receiver.

EOL OSNR Displays the end of life average OSNR value at the receiver.

SOL OSNR margin Displays the SOL OSNR margin calculation. It is the difference between the
OSNR value at certain power of the working point of the receiver client and the
working area boundary.

EOL OSNR margin Displays the EOL OSNR margin calculation, which is the difference between
the OSNR value at a certain power of the working point of the receiver client
and the working area boundary.

SOL RX Displays the SOL average power that is received at the destination site in dBm.

EOL RX Displays the EOL average power that is received at the destination site in dBm.

SOL Power Margin Displays the SOL power budget margin at the receiver in decibels. It is defined
as the offset between the receiver working point and the BER curve with margin.
A positive value indicates that there are no power problems.

EOL Power Margin Displays the EOL power budget margin at the receiver in decibels. It is defined
as the offset between the receiver working point and the BER curve with margin.
A positive value indicates that there are no power problems.

SOL Overload Displays the SOL overload margin at the receiver in decibels. A positive value
indicates that there are no overload problems.

EOL Overload Displays the EOL overload margin at the receiver in decibels. A positive value
indicates that there are no overload problems.

Residual CD Displays the chromatic dispersion (CD) margin of the demand.

CD robustness

Displays the robustness to chromatic dispersion of the receiver.
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Optical Parameter

Single-Channel NLE Displays the status of alarms if any nonlinear effect (NLE) is present in the

Status demand.

Multi-Channel NLE Status | Provides the status of the nonlinear effect (NLE) on a particular channel or
demand due to other channels or demands.

Min GB Displays the minimum Guard Band (GB) requirement between channels on the
40G CP-DQPSK MXP and 40G CP-DQPSK ME MXP cards, and other
transponders in a mixed any-to-any connectivity.

Filtering Penalty Displays the value of the penalties that are caused by different filter types
(OADM, ROADM, and arrayed waveguide grating (AWGQ)).

PMD Displays the calculated total Polarization Mode dispersion (PMD) for each circuit.
If the overall PMD for the link overcomes the maximum that is allowed, the
PMD value is displayed in a red-colored font. The maximum allowed value
depends on the client interface. For these special cases, the network must be
manually resolved by contacting a Cisco TAC team.

RX Atten Displays the attenuation at the input of the receiver.

TX Atten Displays the attenuation at the output of the receiver.

Encryption Displays the encryption type of the channel. Possible values are N/A, Yes, No.

Installation parameters

This table outlines the installation parameters for the ANS component.

Table 97: ANS Parameters

Parameter

Description

Name

Displays the name of the site

Side

Displays the line side

Position

Displays the rack number, shelf number, and slot position of the card where the patch
cord originates.

Unit

Displays the name of the card.

Port

Displays the port number where the patch cord originates.

Port ID

Displays the port ID.

Port Label

Displays the name of the port.

Parameter

Displays the name of the parameter to be set, such as RX Power Low, PSDShape, PSD,
Gain, AmpliGainRange, AddAttenuation, DropAttenuation, Control Mode,
MinExpSpanLoss, MaxExpSpanLoss, and so on.

For the CCMD-16 LC card connected to the ports of the OLT-E-C, the PSD is set using
a specific formula and the VOA drop attenuation is set to 0dB to have optimal RX power
for the circuits.
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Traffic reports

Traffic reports .

Parameter Description

Value Displays the name of the value to be set for the parameter.

Measurement Displays the measurement unit for the related installation parameter value, such as dBm.

Unit

Manual Set Indicates with a Yes or No which parameters must be manually set using the Cisco
Transport Controller (CTC) interface.

This table outlines the installation parameters for the ANP component.

Table 98: ANP Parameters

Parameter Description

Name Displays the name of the site.

Unit ID Displays the unit (slot number) of the passive units in the shelf.
Shelf ID Displays the shelf identifier.

Rack Number |Displays the rack number.

Rack Position

Displays the rack position in the shelf.

Slot Position

Displays the slot position in the shelf for the card.

Equipment Displays the card type.
Type
Description Displays the details of the card type.

This table displays the aggregated data of demand channel in the traffic report for the analyzed network.

Table 99: Traffic Reports

Traffic report Description

Demand Categorizes each demand type. Each demand is further
categorized into service, trails, and sections.

Section Displays the sections under every service.

Src Site Displays the site name for the optical channel source.

Band Type Displays the band type for the optical path.

Src Position

Displays the rack, shelf ID, and slot identifiers for the
source of the optical channel.

Src Card

Displays the unit name for the optical channel source.
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Traffic report

Description

Dst Site

Displays the site name for the optical channel
destination.

Dst Position

Displays the rack, shelf ID, and slot identifiers for the
destination of the optical channel.

Dst Card Displays the unit name for the optical channel
destination.

Client Service Type Displays the client service type of the demand; for
example, OC-48.

Protection Type Displays the protection type of the demand

Encryption Displays whether the demand is encrypted with
values: NA, Yes, or No.

Wavelength Displays the wavelength value of the optical channel,

and the serial number of the wavelength in the
wavelength band.

Max Latency (for NCS 2000 network)

Displays the latency time for the current circuit. This
value includes all the latency components for the
circuit, including fiber and DWDM units on the path.

Fiber Latency (for NCS 1010 and NCS 1001)

Displays the latency time for the fiber.

Cabling report

The IPC Cabling and Patch reports are consolidated into a single view with additional columns. This streamlines
connection details and eliminates the need to access multiple sources.

This table shows patch cord connections related to internal patch connections and multishelf management.

Table 100: IPC

Parameter Description
Name Displays the name of the site.
Src Unit Type Displays the source unit.

Src Position

Displays the rack, shelf, and slot position of the card
from which the patch cord originates.

Src Port Label Displays the name of the port.

SrcFicBay Displays the assigned rack number.
SrcShelfName Displays the type of shelf or the shelf name.
SrcShelfNumber Displays the type of shelf or the shelf name.
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Cabling report .

Parameter Description

SrcShelfUniqueld Displays the unique ID assigned to the shelf. The
unique ID will be used in COSM XML to push the
configuration to the device.

SrcRUPosition Displays the rack unit position in layout.

SrcCardNumber Displays the card slot number within the shelf .

Cable Displays the type of cable.

Dst Unit Type Displays the source unit.

Dst Position

Displays the rack, shelf, and slot position of the card
from which the patch cord terminated.

Dst Port Label Displays the name of the port.

DstFicBay Displays the assigned rack number.

DstShelfName Displays the type of shelf or the shelf name.

DstShelfNumber Displays the assigned shelf number.

DstShelfUniqueld Displays the unique ID assigned to the shelf, which
is used in COSM XML to push the configuration to
the device.

DstRUPosition Displays the rack unit position in layout.

DstCardNumber Displays the card slot number within the shelf .

ManuallySet/AutomaticallySet

Indicates whether a cable connection will be
automatically generated or requires manual
configuration for NCS 2000 networks.

Table 101: MSM

Parameter

Description

Name

Displays the name of the site.

Src Unit Type

Displays the source unit.

Src Position

Displays the rack, shelf, and slot position of the card
from which the patch cord originates.

Src ID Displays the source unit ID.
Src Port Label Displays the name of the port.
Cable Type Displays the type of cable.
Dst Unit Type Displays the source unit.
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Parameter

Description

Dst Position

Displays the rack, shelf, and slot position of the card
from which the patch cord terminated.

DstID Displays the destination unit ID.
Dst Port Label Displays the name of the port.
W/P Indicates whether the connection relates to a present

or forecast circuit.

Confidential banner in exported reports

Table 102: Feature History

Feature Name

Release Information

Feature Description

Confidential Banner

Cisco ONP Release 4.1

This feature indicates the
confidentiality of the reports or
results generated by Cisco ONP for
a network. The CONFIDENTIAL
banner is placed in all the exported
reports. It is placed in the first row
and first cell of the Excel sheet,
followed by a blank row and the
contents of the exported report.

Table 103: Feature History

Feature Name

Release Information

Feature Description

Customizable Confidential Banner

Cisco ONP Release 4.2

The Confidential Banner string can
be customized as required. An
admin user can modify the banner
string when the

confidential Banner.enabled field
is set to true in the
feature.properties file.

The "CONFIDENTIAL" banner appears in all exported reports. In Excel files (.xIsx), it is located in the first
cell of the first row, followed by a blank row, and then the report contents. If the .xIsx file contains multiple
sheets, the banner is included on each sheet.

The "CONFIDENTIAL" banner is updated only when reports are exported in .xIsx format.

Server administrators can customize the "CONFIDENTIAL" banner text by modifying the
confidentialBanner.content field. To enable banner customization, the confidentialBanner.enabled
field must be set to true in the feature.properties file. By default, this field is set to false.
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CHAPTER 7

Backup and Restore Cisco ONP Database

* Backup Database, on page 265
* Restore database using script, on page 269

Backup Database

The database backup configuration on the server, set by the system administrators, allows backups of the
entire database to be taken daily, weekly, or monthly. Only system administrators have access to the backup
folders and can perform restorations. Backup archives are stored on a highly durable NFS share. The available
backup archives include:

* Daily archives for the last 7 days
» Weekly archives for the last 4 weeks

* Monthly archives for the last 6 months

)

Note  You can change the duration for monthly archives.

Setup Backup

Before you begin
* Ensure that a highly durable 2 TB NFS storage is available to store database archives.
* Ensure that the storage is accessible from the Cisco ONP environment.

* Set up rules as defined by the Cisco ONP network and configure the appropriate Access Control List
(ACL) to permit or deny access to the storage as needed.

Procedure

Step 1 Log into the Cisco ONP server, where you have installed Cisco ONP by using the tar archive.
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. Perform manual backup

Step 2 Create a folder for backup. Ideally it should be mounted on a reliable object storage such as NFS.
Step 3 Copy backup, rotation, and setup backup scripts from onp/images folder to the new folder created in step 2.
Example:

$ cd

$ mkdir cnp backups

$ tree ~/cnp backups/
/home/ciscocnp/cnp_backups/
F—— backup postgres.sh

L— rotation.sh

— setup backup.sh

Ensure that all scripts have necessary permissions:
$ chmod +x backup postgres.sh
$ chmod +x rotation.sh
$ chmod +x setup backup.sh
$ 1s -1 | grep .sh
-rwxrwxr-x 1 ciscocnp ciscocnp 518 Jan 16 05:23 backup postgres.sh

-rwxrwxr-x 1 ciscocnp ciscocnp 1412 Feb 1 05:50 rotation.sh

Step4 Copy restore postgres.sh from /ONP/images/.

Perform manual backup

Follow these steps to back up the Cisco ONP database.

Procedure

Step 1 Browse to the location where the backup postgres.sh script is stored.

Step 2 Use the bash rotation.sh command to execute the rotation.sh script.
Example:

user@server:~/cnp backups$ bash rotation.sh

This command creates the necessary folder structure.

Step 3 Use the bash backup postgres.sh command to execute the script.

Example:

user@server:~/cnp backups$ bash backup postgres.sh

The backup file is stored in the daily backup folder (backup.daily) with the current time stamp.

Schedule a backup

You can schedule a backup in either of these two ways:
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Schedule a backup using script .

* Schedule a backup using script, on page 267
* Schedule a backup with Crontab, on page 267

Schedule a backup using script

Procedure

Step 1
Step 2

Step 3

Step 4

Follow these steps to schedule the backup operation using a script.

Log in to the Cisco ONP server.

Use the command bash rotation.sh to execute the rotation.sh script.

Example:

user@server:~/cnp backups$ bash rotation.sh

This command creates the necessary folder structure.

Use the command bash setup backup.sh to execute the setup_backup.sh script.

Example:

user@server:~/cnp backups$ bash setup backup.sh
The backup file is stored in the daily backup folder (backup.daily) with the current time stamp.
Enter the path at the user prompt to store the file.
Backup files are stored in your required file path as shown in this example.

Example:
/user-defined path/backups/backup.daily

Schedule a backup with Crontab

Procedure

Step 1
Step 2

Step 3

Follow these steps to schedule the backup operation using Crontab.

Log in to the Cisco ONP server.
Use the command sudo crontab -e to configure the Crontab job.

user@server~/cnp backups$ sudo crontab -e

Update the crontab. shscript with the required cron job entries using the Syntax to schedule the backup using Crontab,
on page 270, to schedule backup operations.

Example:

This example shows the scheduling of the backup operation at 3:00 a.m daily.
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0 3 * * * /home/ciscocnp/cnp_backups/backup_postgres.sh

Syntax to schedule the backup using Crontab

Use this syntax to schedule a backup in Crontab:

m h dom mon dow

Where:
» m: Minutes (0-59)
* h: Hours (1-23)
* dom: Day of the month (1-31)
» mon: Month of the year (1-12)

» dow: Day of the week (0—6, where 0 represents Sunday)

To specify the time, you can provide exact values for the minute (m), hour (h), day of the month (dom), month
(mon), and day of the week (dow). Alternatively, you can use the wildcard character * in these fields to indicate
"any value."

\)

Note The backup jobs are initiated according to the system daemon's understanding of time and time zones as
defined by the cron scheduler.

Restore the database manually

Follow these steps to restore the database manually.

Procedure

Step 1 Check the Cisco ONP Database.

Example:
$ postgres CnpDB

MongoDB shell version: 2.6.10

connecting to: CnpDB

Server has startup warnings:

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten]

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS filesystem is
strongly recommended with the WiredTiger storage engine.

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten] ** See
http://dochub.mongodb.org/core/prodnotes-filesystem

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten]

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled
for the database.

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten] ** Read and write access to data and
configuration is unrestricted.

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten]
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Step 2

Step 3

Step 4

Restore database using script .

> show collections
NetworkEntity
SystemLog

BOM

fs.files
Users
fs.chunks
ErrorInfo
NetworkObject
UserGroups
TaskInfo
ActionGroups
Roles

>

Remove the Cisco ONP back-end and front-end Docker services,"docker service rm cnp_cnp cnp_cnp_frontend" and
check again:

Example:

$ postgres CnpDB

MongoDB shell version: 2.6.10

connecting to: CnpDB

Server has startup warnings:

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten]

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS file system is
strongly recommended with the WiredTiger storage engine.

2019-01-31T12:17:39.354+0000 I STORAGE [initandlisten] ** See
http://dochub.mongodb.org/core/prodnotes—-filesystem

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten]

2019-01-31T12:17:40.01340000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled
for the database.

2019-01-31T12:17:40.01340000 I CONTROL [initandlisten] ** Read and write access to data and
configuration is unrestricted.

2019-01-31T12:17:40.013+0000 I CONTROL [initandlisten]

> show collections

>

Copy the database to the folder that is mapped to PostgresDB container's volume:

Example:
$ sudo cp backups/2019-02-01-04-29.archive /var/lib/postgresdb cnp/

Restore the database and check.

Example:

$ docker exec -t cnp postgres.l.$ (docker service ps -f 'name=cnp postgres.l' -f 'desired-state=running'
cnp_postgres -q) bash -c "postgresrestore -u \$(cat \$MONGO INITDB ROOT USERNAME FILE) -p \$(cat
\$MONGO_INITDB_ROOT_PASSWORD_FILE) --authenticationDatabase admin --port 27017 -h localhost --db
CnpDB --gzip --archive=/data/db/2019-02-01-04-29.archive"

Restore database using script

You can restore the database using a script, which is available at this location:
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/ONP/Images/restore postgres.sh

Follow these steps to restore the database using a script:

Procedure

Use the command sudo bash restore postgres.sh to restore the database

Example:

$ sudo bash restore postgres.sh DB backup archive file path.

$ sudo bash restore postgres.sh /backups/backup.daily/2019-05-05-23-58.archive

The database backup is created and a confirmation prompt appears asking to delete the database.

I'l'l WARNING! Complete Restore Operation will replace Existing Database with Backup Database
(Recommended) !!!

Do you want Complete Restore? (Yes/No) [default - Yes]

Enter ves to delete the database and restore the database with backup file.

Enter no to not delete the database and apply only missing data(s) from backup file.

Syntax to schedule the backup using Crontab

Use this syntax to schedule a backup in Crontab:

m h dom mon dow

Where:
* m: Minutes (0-59)
* h: Hours (1-23)
* dom: Day of the month (1-31)
» mon: Month of the year (1-12)

» dow: Day of the week (0-6, where 0 represents Sunday)

To specify the time, you can provide exact values for the minute (m), hour (h), day of the month (dom), month
(mon), and day of the week (dow); alternatively, you can use the wildcard character * in these fields to indicate
"any value."

)

Note The backup jobs are initiated according to the system daemon's understanding of time and time zones as
defined by the cron scheduler.
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Cisco ONP Ul Reference

This appendix chapter describes the various options available in the Cisco ONP Ul.

Table 104: Feature History

Feature Name

Release
Information

Feature Description

Enhancements
and Engineering
Initiatives

Cisco ONP
Release 25.1.1

This release includes several user experience and functionality
enhancements to the application:

» Added color indication at the circuit and network level in the
network tree to represent optical feasibility and overall network
performance.

» Enhanced selection capabilities within the network tree for more
efficient management.

* Added version and timestamp information to exported reports to
improve traceability and documentation.

* Displayed edge labels directly on the map view for easier
identification and understanding of network topology.

* Provided users with the ability to unlock and modify entity
properties within the entity editor.

* Enabled users to edit the Effective Mode Area parameter for fibers
to achieve more accurate OSNR and power calculations.
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Table 105: Feature History

Cisco ONP Ul Reference |

Feature Release Feature Description

Name Information

User Cisco ONP | Cisco ONP improves the user experience with these user interface
Interface Release 24.3.1 | enhancements:

Enhancements

* Maps:
* Providing an option to increase the workable area.

* Switching to zoom mode that automatically centers the map on the
selected node.

* Highlighting nodes and fibers selected in the network tree on the
map.
* Entity Editor: Adding tooltips for some of the properties.
* Results:

* Including Raman information in the Fiber Details that are exported
from Export>Fibers.

* Introducing Export Report button to export Optical Reports/BOM
differences between two networks in CONP.

* Maintaining the recent view in the Resultstab view when switching
to the Map or BoM tabs.

* Enabling editing of EOL Aging Loss with Aging L oss[dB] property in
both the entity editor and Properties pane.

+ Updating optical sources with minimum system release information for
user visibility in the Manage Optical Sour ce dialog box.

* Adding an OMNI marker to identify the Omni-Directional sides in the
NCS 2000 networks.

» Component L ogs: Streamlining log management, this L ogsmenu option
provides direct access to critical component logs such as cnp Backend
(BE), ODE, GENE, and PCE through the user interface.

* Menu bar, on page 272

* Network Tree, on page 280

* Design Palette, on page 282

* Entity Editor, on page 284

Menu bar

This table lists all options available in your Cisco ONP GUI menu bar.
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File

File [

Table 106: Menu options and descriptions

Options Description

File Performs common file operations such as New, Open, Open Shared, Save, Save As, Share,
and Delete

Network Opens Entity Editor, analyzes the network, and converts non-SSON to SSON networks

Export Exports reports of CPZ, sites, fibers, SRLGs, services, waves, media channels, optical results,
service aggregation, BOM, and messages. Export allows you to download Excel and LNI
templates

Import Imports CPZ, Excel, LNI, and MPZ to design a network in Cisco ONP

Manage Manages Layout Templates and Optical Sources

Logs Displays log events initiated during a specific period, such as user login, user logout, password

change, and LNI - start, failed, and completed

Job Monitor

Monitors background tasks

Control Panel | Manages users, user groups, user roles, permissions, system configuration, and dictionary
Preferences | Changes the default map view and personalizes the color code for spectrum utilization
Help Displays the Cisco ONP version

Last Login | Shows the last date and time you logged in to Cisco ONP including the last login IP details
Username Displays the name of the user who has currently logged in to Cisco ONP

The File menu includes common file options such as New, Open, and Delete.

Options Description

New Creates a new network. By default, NCS 1010 is created. To create NCS 2000 networks,
change L O Network Platform to NCS2000. You can check the SSON Network check box
and select System Release for NCS 2K to create an SSON network.

Open Opens a saved network. The network name in blue-colored font indicates that the network is
in the Design mode, and the network name in green-colored font indicates that the network
is in the Analyze mode.

Note
If you view a blank screen when you open a network, refresh the browser, or log in to Cisco
ONP again.

Open Shared | Opens a shared network.

Save Saves a network.

Save As Saves the network with a new name.

Share Shares a network or networks.
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Options Description

Delete Deletes a network or networks.

Network

The Networ k menu includes options such as Entity Editor, Analyze, and SSON Convert in the design mode.
It includes options such as Entity Editor, Design, Upgrade, and Enter Plan Mode in the Analyze mode.

Options Description

Entity Editor Use this option to edit various properties of an element in the network

Analyze Analyzes the network after completing the design

SSON Convert Converts a Non-SSON network to an SSON network

Design Switches from Analyze mode to Design, Upgrade, or Release Upgrade mode

Upgrade Upgrades an existing network that is in the Analyze mode

Release Upgrade Upgrades the NCS 2K or NCS 1010 System Release of a network

Enter Plan Mode Switches to the Plan mode

Exit Plan Mode Exits the plan mode

Enter Link Rate Tuner Enters the link rate tuner mode

Mode

Open Tuner Input Opens the tuner input table to add parameters for custom optical sources

Run Tuner Runs the tuner input options to provide custom optical source results.

Start New Starts fresh tuner analysis

Open Tuner Result Opens the already analyzed tuner results

Exit Link Rate Tuner Mode | Exits the link rate tuner mode

Restore Restores failed fibers and nodes

Open Failure Report Expands the Failure Report from the bottom of the Map. Data is populated
after Restore.

Open Feasibility Report Expands the Feasibility Report from the bottom of the Map. The report displays
the data regarding Auto Regen Suggestions for channel feasibility.

Export

The Export menu includes options to export reports of Sites, Fibers, Services, SRLG, Waves, Messages, and
BOM.
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Options Description
CPzZ Export the .cpz design file of a network into your local system.
Sites Exports site details such as x and y coordinates, grooming site flag, CLLI

code, site address, site type, and site name.

Fibers Exports fiber details such as length, loss to fiber, source and destination site,
source and destination edge.

From Release 24.3.1, the exported fiber details contains the Raman information.

Services Exports service details such as name, type, path, quantity, and protection.
SRLGs Exports details about created SRLGs.

Waves (Available for Exports wave details such as Label, Source and Destination sites, Card Type,
non-SSON network) Wavelength, Utilization, Source port, Destination port, Demands, OTN Hops,

OSNR, OSNRMarginEOL, StatusEOL, Excluded Channels, and Path of Wave.

Media Channels (Available | Exports media channel details such as Media Channel Label, Media Carrier
for SSON network) Label, Source and Destination sites, Card Type, Wavelength, Utilization,
Source port, Destination port, Demands, OTN Hops, OSNR,
OSNRMarginEOL, StatusEOL, Excluded Channels, and Path of Media

channel.
Circuits (Available for Exports circuits details such as Circuit Label, Carrier Label, Source and
NCS1010 network) Destination sites, Card Type, Traffic Type, Wavelength, Utilization, Source

port, Destination port, Demands, OTN Hops, OSNR, OSNRMarginEOL,
StatusEOL, Excluded Circuits, and Path of Circuit.

Messages Shows the complete log of the analysis, including critical errors.

Excel Download sample Excel file that can be used as a reference for creating
networks using the Import Excel feature.

LNI Template Download sample LNI file that can be used as a reference for creating networks
using the Import feature.

Optical Source Template Download sample Optical Source Excel file that can be used as a reference
for creating User Defined/custom Optical Source using the M anage> Optical
Sour ces feature.

BOM Exports details about pricing and quantity of the network equipment

Failure Groups This option is available only in the plan mode. You can add failed fibers to a

failure group.

Failure Report This option is available only in the plan mode. It shows the failed fibers, total
channels, failed channels, restored channels, and fiber hotzones.

Optical Results Exports details such as protection type, SOL, EOL, source, and destination

Device Configuration Exports the Device Netconf XML file and COSM Netconf file.
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Import

The Import menu imports an Excel file, a CPZ file, or an MPZ file.

Options | Description

CPZ | Imports the .cpz network design files that are exported from another Cisco ONP instance

Excel |Imports an Excel file containing all the design parameters

Live |Imports a live deployed network by retrieving configurations of the nodes, provided in the LNI
input Excel sheet

MPZ | Imports the .mpz network design files from CTP to Cisco ONP, to avoid recreating the networks
that are already created in CTP

Manage
You can manage layout templates and optical sources.
Options Description
Layout Imports reusable templates to design layout configurations for a network
Templates

Optical Sources | Imports an optical source from your local system

Look Up Table | Displays the optical feasability values for the gain ranges of each EDFA cards.

Logs

System Logs

The System Logs option allows an admin user, or user with USER MANAGEMENT, and NETWORK
MANAGEMENT permissions to view at logs the events that are initiated during a specific time interval.
Examples of events are user login, user logout, password change, Live Network Import (LNI)-start, failed,
completed and analysis-start, and failed.

The SYSTEM L OGS page includes the following fields:

Field Description
Time Stamp Provides the date and time of the specific event
Event Type Shows the type of event, which includes user login, user logout, password

change, and so on

Description Describes the event, which includes user login success, user logout
success, and so on

Username Shows the user who has initiated specific events

Event Source Shows the IP address of the device from where the event is initiated
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Events that are captured in the System Logs are:

Event Description

SIGNUP New user sign-up for Cisco ONP

LOGIN User log in to Cisco ONP

USER STATE CHANGE User state change from Active to Inactive and the converse
USER ROLE CHANGE User role change, such as admin to planner, and so on
LOGOUT User log out from Cisco ONP

USER DELETION Deletion of a particular user

UNAUTHORIZED User enters invalid login credentials

LNI_START Successful initiation of Live Network Import

LNI COMPLETE

Successful completion of live import of a network

LNI_CANCEL

Cancellation of Live Network Import

CONC_IMPORT COMPLETE

Successful completion of live import of a network from Cisco ONC

ANALYZE LNI START

Analysis of LNI network started successfully

ANALYZE_LNI_END

Analysis of LNI network completed successfully

ANALYZE START

Starting of the network analysis

ANALYZE END Completion of the network analysis
ANALYZE CANCEL Cancellation of the network analysis
UPGRADE NETWORK Entering the Upgrade mode

PLAN INIT Entering the Plan mode

PLAN _END Exiting the Plan mode

PLAN REROUTE

Checking for alternate paths to restore failed media channels or waves

PLAN PROGRESS

Restoration of failed media channels or waves in progress

RELEASE UPGRADE NETWORK

Upgrading the system release of the network is in progress.

Component Logs

The Component Logs option allows you to access logs for multiple critical components such as cnp Backend
(BE), ODE, GENE, and PCE, directly through the user interface. This streamlines the process, eliminating
the need for server access and manual file navigation. This enhancement simplifies log management, aiding
in performance monitoring, troubleshooting, and system insights.

The Component L ogs page includes the fields:
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Field Description
Time Stamp Provides the date and time of the specific event
Logs Describes the events for the selected component
Component Provides list of critical components to choose from. The available
components are:

* BE

* ODE

* GENE

* PCE
Search Locates specific log entries based in the entered value
Pages Allows you to navigate through logs page by page

Jobh Monitor

The Job Monitor menu checks and manages tasks running in the background.

You can access this menu if you have ADMIN, NETWORK MANAGEMENT, or NETWORK PLANNING
role.

The JOB MONITOR page has the following options:

Options Description
Refresh Refreshes the display information.
Filter Applies one or more of the following filter options:

Task Type: Filters the display information based on the task type.

Select Start Date: Filters the display information based on the start date of the
task.

Select End Date: Filters the display information based on the end date of the task.

Username: Filters the display information based on the username.

Created Date The date on which the task is started by the user.

User Name Name of the user who initiated the job.

Network Name Name of the network on which the task is running.

Task Type The type of background task: Valid values are ANALYZE and EPNM_IMPORT.
Messages The current state of the task.
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Options Description

Cancel Enables you to cancel or stop an ongoing background task:

» The Admin can cancel any of the running background tasks. Other valid
users can cancel only their own tasks.

* If you want to cancel your ongoing network analysis, you can open Cisco
ONP at the browser in incognito mode, or contact the Admin.

* After a task is cancelled, it gets removed from the job monitor. You can
check the status of a cancelled task from System logs page. Click L ogsto
open the System logs page.

Clear all Completed Removes all the completed tasks from the Job Monitor page.
Tasks

Control Panel

Apart from designing, analyzing, and creating BOM for a network, a user with admin rights can activate,
manage, and delete users and their roles.

To navigate to the control panel page, click Control Panel.

The admin or any user with USER_ MANAGEMENT role can lock, unlock an individual user account, and
manually expire the individual user password. For more information, see Manage Users and Roles, on page
11.

Preferences

This menu contains the General Settings option to customize Cisco ONP settings such as the default map
view and spectrum utilization percentage.

Field Description

General Settings Allows choosing the default map view and applying color codes for
spectrum usage percentage

+ Default Map: Choose the Detailed or Minimal map from the
drop-down list.

* Spectrum Utilization Percentage: Click and drag to change the
color code to indicate spectrum usage.

Help

This menu provides information about the Cisco ONP version.

Field |Description

About | Provides the Cisco ONP version.
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Table 107: Feature History
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Feature Name Release Information Feature Description

Network Tree Enhancements Cisco ONP Release 5.2 Now, you can use the Ellipsis icon

at the right side of each element in
the Network tree to perform various
actions such as Expand All,
Collapse All, Enable Multi-Select,
and so on. Also, you have multiple
entity-level options to filter the
elements under the Network tree.
These enhancements make the
Network tree more intuitive.

The left pane of the Cisco ONP home page comprises a network tree. The network tree includes various
network elements. When you click each element, the respective property is displayed under the network tree.
You can edit the properties. For more information on editing the network properties, see Modify Network

Properties, on page 111.

From R25.1.1, the network tree provides the Ul enhancements

* Default multi-select check boxes—network tree entities have the multi-select check boxes enabled by
default. To disable the multi-select check boxes, click the ellipses icon and click the Disable M ulti-Select
option. To enable the multi-select option, follow the same navigation.

* Coloring indication on network tree—network tree entities display red, green, and yellow colors to
indicate the optical feasibility of the circuits and overall network.

Table 108: Network Tree Elements

Network Tree Elements

Description

Network name

Displays the name of the network.

Sites

Customer premise equipment that is located in a rack
within a building.

When you click a site name in the network tree, the
site will be highlighted in orange on the map.

When multiselect is enabled, the network tree displays
checkboxes for each site, fiber, and circuit. Selecting
multiple sites from the network tree highlights the
same sites on the map.

Fiber

Optical fiber connecting two sites.

Fiber Couple

A fiber couple consists of two different fibers
(clockwise and counterclockwise), one for
transmission and another for reception.
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Network Tree Elements

Description

Services

Service is the circuit through which traffic flows
between nodes.

When you add services to the Traffic site (of the type
1K-2K-4K) in an SSON network, a DefaultGroup is
created under the Services in the network tree. You
can also create a new service group.

Waves or Medial Channel or Circuits

The wave or Media channel represents a DWDM
channel. In a wave hierarchy, for each wave, there is
a trail. When you expand a trail, there is a section
under each trail. The trail is an optical path or a
network section joining two traffic nodes. It can have
more than one section depending on whether the trail
has a regenerator site. For more information on
regeneration, see Regeneration Support, on page 215.

SRLG

Shared Risk Link Group (SRLG) is useful for routing
the protected services. If there are Fiber 1 and Fiber
2 in the network, they are assumed to be diverse and
are used as alternates for protection purposes. If Fiber
1 and Fiber 2 are in an SRLG, they are not true
alternates, and they share the same risk of failure.
Therefore, if Fiber1 fails, Fiber 2 also fails, and Fiber
2 cannot be used as a protected path.

Optical subnet

An optical subnet is a collection of spans with certain
associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet
that is associated to the network. At least one optical
subnet must exist for each network.

Use the Search box on top of the network tree to search for any specific site, fiber, or wave in the network
tree panel. Click the Refresh icon to refresh your search.

Now, you can filter the elements available in the network tree using the Filter icon available next to the Search
box. The following table explains the various filter options available.

Table 109: Network Tree Elements

Filters

Options Available Under Each Filter

Network Filter

Entity Type

Sites Filter

Site Type, and DWDM Site Type

Fibers Filter

Source Site, Destination Site, Source Edge,
Destination Edge, and Raman

Services Filter

Protection Type, Source Site, Destination Site, Src
Add-Drop Type, and Dst Add-Drop Type
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Filters

Options Available Under Each Filter

Waves, Medial Channel, or Circuits Filter Protection Type, Source Site, Destination Site, Src

Add-Drop Type, and Dst Add-Drop Type

Design Palette

Table 110: Feature History

Feature Name |Release

Feature Description

Information
Intuitive Map | Cisco ONP The new intuitive map display allows you to virtually rearrange
Display Release 5.2 networks for a clutter-free view without impacting the original design.

This display simplifies adding new nodes to complex networks. Save
the last modified network in the new view to retain the latest
rearrangement. The new icons in the Design Palette that enable the
intuitive display are:

« Switch to I ntuitive Arrangement/Switch to Coor dinates
Arrangement—Toggles the map between the intuitive and
original displays.

» Rearrange nodes—Overrides node coordinates and rearranges
the map in a presentable manner.

At the right of the Cisco ONP home page, there is the design palette. You can use this design palette to create
a network design. It consists of the following six icons:

Icons

Description

Switch to Zoom M ode/
Switch toNormal Mode

Click this icon to toggle between Normal and Zoom modes.

Zoom M ode: Highlights the selected node and automatically centers the map on
the selected node. The size of labels, such as fiber and service names, adjusts
according to the mode.

Normal Mode: Highlights the selected node on the map. Autozoom is disabled.
You need to manually move the map to view the selected node if it is not visible.

Zoom In Click this icon to magnify the map.
Zoom Out Click this icon to minimize the map.
Reset Zoom Click this icon to reset the map to its original size.

Switch to Intuitive
Arrangement/Switch to
Coordinates
Arrangement

Click this icon to toggle between the intuitive and coordinates display. Save the
last modified network in the Intuitive view to retain the latest rearrangement. The
saved networks retain the map designs when reopened or shared with others. When
you export the network as CPZ or Excel files, the exported files include both
original and modified or rearranged coordinate data.
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Icons Description
Rearrange nodes Click this icon to rearrange the map in a presentable fashion.
Drawing Tool The Drawing Tool consists of the following icons:

» Traffic Site: Select this icon, and click the working area to create traffic sites
in the network.

* ROADM Site: Select this icon, and click the working area to create ROADM
sites.

* OLA Site: Select this icon, and click the working area to create OLA sites.

* Passthrough Site: Select this icon, and click the working area to create
passthrough sites.

e Link: Click this icon, and drag and drop between sites to create a fiber link.
* OTN Service: Click this icon to create OTN service between sites.

* DWDM channd: Click this icon to add a wave or medial channel between
sites.

* Select: The Select icon looks similar to the cursor tool. Click this icon to
select a node, link service, and so on.

LayersWindow

Use this icon to view or hide layers such as fiber link, service, text, and channel.
The following are the four toggle icons:

» Toggle Fiber: Click this icon to view or hide fiber link details from the
network.

* Toggle Service: Click this icon to view or hide service details from the
network.

» Toggle Wave: Click this icon to view or hide the channel or wave details
from the network.

* Toggle Text: Click this icon to view or hide the text from the network.

* Toggle COSM associations: Click this icon to remove or add COSM
associations.

» Expand/Collapse All Demands: Click this icon to expand the waves or
media channels so that you can view them clearly. Click this icon again to
collapse the waves and media channels to their original shape and position.

The eye symbol in the icon indicates that you are currently viewing the respective
details.
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Icons

Description

Zoom Tool

The icon below the Drawing Tool is the Zoom Tool. You can change the display
of the working area by using this function. Click the arrow to view two sliders.

» Map Fade: Move the M ap Fade slider from right to left to fade the map
from the background.

» Zoom In/Out: To magnify the map, move the Zoom in or out slider from
left to right.

Zoom Elements

Click the Zoom Elementsicon to view four sliders.

» Media Channel Width: Move this slider from left to right to increase the
channel width.

« Path Spread: Move this slider from left to right to increase the space between
the paths.

* Fiber Width: Move this slider from left to right to increase the fiber width.

* Service Width: Move this slider from left to right to increase the service
width.

Show Failed (available
only in plan mode)

This icon shows the failed media channels in the map. Failed ones are marked
with a red cross mark.

Traffic Monitor
(available only in plan
mode)

This icon shows the total number of impacted media channels, demands, or services
that are working or failed in the entire network.

Switch to Minimal
M ap/Switch to Detailed

Map

Click this icon to toggle between Minimal Map and Detailed Map.

Switch to Minimal Map: Focuses on Sites and Fibers, allowing you to view
spectrum utilization, and supporting the spectrum and path finder.

Switch to Detailed M ap: Displays all network components for a comprehensive
view.

Entity Editor

The Entity Editor allows you to edit various properties of an element in the network. Choose Network >
Entity Editor to open the Entity Editor window.

The Entity Editor enhances some properties with descriptions in the form of tooltips.

The table lists the operations that you can perform in the Entity Editor window.
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Options

Description

Left pane filter

Includes check boxes to filter the network elements displayed under each tab:

* For the SITE tab, you can choose whether to display OTN (only traffic
node), DWDM (ROADM, OLA, or pass-through) node, or both.

* For the FIBER tab, you can choose the fiber connecting a particular source
and destination sites.

* For the SERVICE tab, you can choose to display either services, waves,

or both.
Right pane properties Displays all properties of the selected network element. You can modify the
properties as required.
Search Searches for a particular network element.
Refresh Refreshes the list of network elements displayed under each tab.

Expand/Collapse

Expands or collapses the network elements available in the network tree under
each tab.

Select Similar

Selects similar network elements available in the network tree.

For example, select a ROADM site, and click the Select Similar icon. All
ROADM sites are selected.

You can change a property in all the selected sites at the same time.

This option allows you to identify and compare the property difference. For
example, if a property is different among the selected sites, that property is
dimmed. You can select an option that is applied to all the selections.

Un-Select All

Deselects all selections that you make under the network tree.

Delete

Deletes the selected network elements.

Add Contentionless Sides
(available only under the
Site tab for the NCS 2000
network)

Adds contentionless sides to NCS 2000 networks.

Contentionless functionality on a site refers to the contentionless add/drop
ability of an N-degree ROADM node to accommodate N wavelengths of the
same frequency from a single add/drop device. For a ROADM to be
contentionless, the number of drop units have to be equal to ROADM degrees.

* Click the ROADM site to add contentionless sides.
* Click the Add Contentionless Side icon.

* Enter an appropriate value in the Enter number of contentionless sides
field.

* Click OK.

After adding the contentionless side, you can edit the contentionless port
property of the side at the right pane. You can select any of the values ranging
from 1 to16. The default value is 16.
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Options

Description

Add L-Band (available
only under the Site tab for
NCS 1010 site)

Adds L-Band sides to an NCS 1010 R7.9.1 site. To add L-Band sides,

* Click the site or side to which you want to add L-band sides.
* Click the Add L-Band icon.

Add Omni-Directional
(available only under the
Site tab for the NCS 1010
network)

Adds omnidirectional functionality on a site.

Omnidirectional functionality on a site refers to the ability to route channels
through any of the optical degrees in a multidegree topology during fiber cut
without the need for physical fiber reconnections. To add omnidirectional
functionality,

* Click the ROADM site to which you want to add omnidirectional sides.
* Click the Omni-Directional icon.

* Enter the appropriate value in the Enter number of Omni Directional
sides field.

* Click OK.

Copy (available only under
the Servicetab)

Clones a service or wave that is connected between two sites. To clone a service,

* Select a wave and click Copy.
* Enter the quantity in the Clone Service/DWDM Channel dialog box, and
click OK.

—1 is added at the end of the label of the cloned wave. An example label of a
cloned wave is Site-2-Site3-1-1. The original wave is Site-2-Site3-1. You can
rename the label.

You can also clone a service in a similar way.

Unlock

Unlocks the required entities in an analysed network for editing.
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Modules

* Supported ROADMSs, Add/Drop Cards, and Modules, on page 287

Supported ROADMSs, Add/Drop Cards, and Modules

Cisco ONP supports the following ROADM, Add/Drop cards and modules:

Table 111: NCS 2000 ROADM Cards

Product Product Description

NCS2K-9-SMR34FS= 9-port Single Module ROADM - 20—34-dB Gain - Flex Spectrum
NCS2K-9-SMR24FS= 9-port Single Module ROADM - 12—24-dB Gain - Flex Spectrum
NCS2K-9-SMR17FS= 9-port Single Module ROADM - 0—17-dB Gain - Flex Spectrum
NCS2K-20-SMRFS= 20-port Single Module ROADM - Switchable Gain Flex Spectrum
NCS2K-20-SMRFS-CV= 20-port SMR - Switch. Gain Flex Spectrum with Connection Verification

Table 112: NCS 2000 ADD/DROP Line Cards and Optical Passive Modules

Product Product Description

NCS2K-16-AD-CCOFS= 4- to 12-degree 16-port Contentionless Add/Drop Unit

NCS2K-MF-6AD-CFS= 6-port Colorless Flex Spectrum Add/Drop MF Unit

NCS2K-MF-MPO-16LC= MPO-16 to 16xLC Fan-Out MF Unit with Integrated Monitoring

NCS2K-MF-M16LC-CV= MPO-16 to 16xLC Fan-Out with Connection Verification

15216-MD-48-ODD= ONS 15216 48-channel Mux/DeMux Exposed Faceplate Patch Panel
Odd

15216-MD-48-EVEN= ONS 15216 48-channel Mux/DeMux Exposed Faceplate Patch Panel
Even
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Product

Product Description

15216-MD-48-CM=

ONS 15216 Mux/Demux Plugin Coupler/De-Interleaver Module

NCS1K-MD-64-C=

NCS 1000 64-channel Odd Mux/Demux Patch Panel—C-band

Table 113: NCS 2000 Controller Cards and Common Equipment

Product Product Description
NCS2006-DC= NCS 2006 30A DC Power Filter
NCS2006-AC= NCS 2006 1500W AC Power Supply

NCS2015-SA-DC=

NCS 2015 Shelf Assembly - DC Power

NCS2015-SA-AC=

NCS 2015 Shelf Assembly - AC Power

NCS2K-TNCS-2-K9=

NCS 2000 Transport Node Controller, version 2

NCS2K-TNCS-20-K9=

NCS2000 Transport Node Controller with 2x OTDR/OSC, version 2

NCS2K-TNCS-K9=

Transport Node Controller for NCS2002, 2006, and 2015 chassis

NCS2K-TNCS-0-K9=

NCS 2000 Transport Node Controller with 2x OTDR/OSC

NCS2K-SVO-K9=

Shelf Virtualization Orchestrator - LC, Full

NCS2K-PSM=

Protection Switching Module (PSM) card for NCS 2000

Table 114: NCS 2000 Series Passive Optical Modules

Product

Product Description

NCS2K-MF-6RU=

6RU Mechanical Frame for Passive Units—14 slots with USB Hub

NCS2K-MF10-6RU=

6RU Mechanical Frame for Passive Units—10 slots with USB Hub

NCS2K-MF-1RU=

1RU Mechanical Frame—+4 slots

NCS2K-MF-UPG-4=

4-degree Upgrade Mesh Interconnection MF Unit

NCS2K-MF-UPG-4-CV=

4-degree Upgrade Mesh Interconnect with Connection Verification

NCS2K-MF-DEG-5=

Up to 5-degree Mesh Interconnection MF Unit

NCS2K-MF-DEG-5-CV=

5-degree Mesh Interconnect with Connection Verification

NCS2K-PPMESHS8-5AD=

2RU 8-degree Mesh Patch Panel—5-Add/Drop Port + Monitoring

Table 115: NCS 4000 Chassis and NCS 1004 Line Cards

Product

Product Description

NCS4016-SA-DC=

NCS 4016 shelf assembly - DC Power
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Product

Product Description

NCS4016-SA-AC=

NCS 4016 shelf assembly - AC Power

NCS4009-SA-DC=

NCS 4009 shelf assembly - DC Power

NCS4K-4H-OPW-QC2=

NCS 4000 400G Packet/OTN/WDM—QSFP28/CFP2 line card

NCS4K-24LR-O-S=

NCS 4000 24-port low rate OTN—SFP line card

NCS1004=

Network Convergence System 1004 four line card slots

Table 116: NCS 1010 Line Cards, Chassis, and PSUs

Product Product Description
NCS1K-OLT-C= NCS 1010 Optical Line Terminal—C-band
NCS1K-OLT-L= NCS 1010 Optical Line Terminal—L-band

NCSIK-OLT-R-C=

NCS 1010 Optical Line Terminal with Raman—C-band

NCS1K-ILA-C=

NCS 1010 In-Line Amplifier—C-band

NCSIK-ILA-L=

NCS 1010 In-Line Amplifie—L-band

NCS1K-ILA-2R-C=

NCS 1010 In-Line Amplifier with 2x Raman—C-band

NCS1K-ILA-R-C=

NCS 1010 In-Line Amplifier with 1x Raman—C-band

NCS1010-SA=

NCS 1010 Shelf Assembly

NCS1010-DC-PSU=

NCS 1010 DC Power Supply Unit

NCS1010-AC-PSU=

NCS 1010 AC Power Supply Unit

NCS1K-E-OLT-C=

NCS 1010 Optical Line Terminal—C-band, enhanced

NCS1K-E-OLT-R-C=

NCS 1010 Optical Line Terminal with Raman—C-band, enhanced

NCS1K-E-OLT-L=

NCS 1010 Optical Line Terminal—L-band, enhanced

NCS1K-E-ILA-R-C=

NCS 1010 In-Line Amplifier with 1x Raman—C-band, enhanced

NCSIK-E-ILA-2R-C=

NCS 1010 In-Line Amplifier with 2x Raman—C-band, enhanced

NCS1K-E-ILA-R-C-2=

NCS 1010 In-Line Amplifier with 1x Raman west facing—C-band,
enhanced

NCS1K14-2.4T-K9=

NCS 1014 2.4T Line Card

Table 117: NCS 1014 Line Cards, Chassis, and PSUs

Product Product Description

NCS1K14-SYS NCS 1014 Assemble to Order
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Product Product Description

NCS1K14-EDFA2=

NCS 1014 EDFA terminal with equalization

NCS1K4-AC-PSU

NCS 1004 AC Power Supply Unit, 2.1 kW

NCS1K4-DC-PSU

NCS 1004 DC Power Supply Unit, 2.1 kW

NCS1K4-AC-PSU-2

NCS 1004 AC Power Supply Unit, 2.5 kW

NCS1K4-DC-PSU-2

NCS 1004 DC Power Supply Unit, 2.5 kW

Table 118: NCS 1014 Passive Modules

Product

Product Description

NCS1K-MD-320-CE=

NCS 1000 32chs Odd Mux/Demux Patch Panel - 150GHz—C-band
Enhanced

NCS1K-MD-32E-CE=

NCS 1000 32chs Even Mux/Demux Patch Panel - 150GHz—C-band
Enhanced

Table 119: NCS 1010 Passive Modules

Product

Product Description

NCSI1K-BRK-SA=

NCS 1000 shelf for four passive modules

NCS1K-BRK-8=

NCS 1000 MTP/MPO to 8-port passive breakout module

NCS1K-BRK-24=

NCS 1000 MTP/MPO to 24-port colorless channels passive breakout
module

NCS1K-BRK-16=

NCS 1000 MTP/MPO to 16-port colorless channels passive breakout
module

NCS1K-MD-320-C=

NCS 1000 32-channel Odd Mux/Demux Patch Panel - 150GHz—C-band

NCS1K-MD-32E-C=

NCS 1000 32-channel Even Mux/Demux Patch Panel -
150GHz—C-band

NCS1K14-CCMD-16-C

NCS 1000 16-port Colorless Mux/Demux Optical Line Card—C-band

NCS1K14-CCMD-16-L

NCS 1000 16-port Colorless Mux/Demux Optical Line Card—L-band

Table 120: NCS 1020 Chassis and Modules

Product

Product Description

NCS1020-SA=

NCS 1020 Shelf Assembly

NCS1010-CTR2-K9=

NCS 1010, 1012, 1020 Controller, 112500-bps Default Console Baud
Rate

NCS1010-CTR2-B-K9=

NCS 1010, 1012, 1020 Controller, 9600-bps Console Baud Rate
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Product Product Description

NCS1020-FAN= NCS 1020 Fan for NCS 1014 Slots

NCS1020-FAN-BLANK= NCS 1020 Fan Blank

NCS1010-FLR-P= Filler / Blank for NCS 1010 Slot on NCS 1012, 1020, Passive

NCS1010-FLR-A= Filler / Blank for NCS 1010 Slot on NCS 1012, 1020, Active, with Fan
slots

NCS1010-CTR2-FLR= Filler / Blank for Controller Slot on NCS 1012, 1020

NCS1K14-BLANK= Network Convergence System 1014 Blank card

Table 121: NCS 1001 Chassis, Modules, and Pluggables

Product Product Description

NCS1001-K9= Network Convergence System 1001 line system 3 slots

NCS1K-CNTLR2= Network Convergence System 1001 Control card

NCS1K-EDFA= Network Convergence System 1001 amplifier module

NCSI1K-PSM= Network Convergence System 1001 protection module

NCSI1K-2KW-AC2= Network Convergence System 1001 AC power supply unit - 2KW
normal operating temperature, 600W short term high temperature

NCS1K-2KW-DC= Network Convergence System 1001 DC power supply unit - 2KW
normal operating temperature, 600W short term high temperature

NCS1KI1-FAN= Network Convergence System 1001 line system Fan

ONS-SC-Z3-1510= SFP OC-48/STM-16/GE, CWDM, 1510 nm

ONS-SE-155-1510 SFP OC-3/STM-1, CWDM, 1510 nm EXT; SFP Pluggable Optics
Module

CWDM-SFP-1510 CWDM 1510-nm SFP; Gigabit Ethernet 1 and 2 Gb Fibre Channel

CWDM-SFP-1610 CWDM 1610-nm SFP; Gigabit Ethernet 1 and 2 Gb Fibre Channel

ONS-SC-Z3-1610= SFP OC-48/STM-16/GE, CWDM, 1610 nm

Product Product Description

15216-MD-48-ODDE ONS Multiplexer/Demultiplexer Patch Panel Even Extended

15216-MD-48-EVENE ONS Multiplexer/Demultiplexer Patch Panel Odd Extended

15216-MD-48-CME ONS Coupler and Splitter

15216-FLD-0OSC OSC Combiner and Splitter

NCS1K-MD-64-C NCS 1000 64 channels Odd Multiplexer/Demultiplexer Patch
Panel-C-band

NCS1K-MD-32E-CE NCS 1000 32chs Even Mux/Demux Patch Panel - 150GHz—C-band
Enhanced
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* Supported Transponder Cards and Pluggables, on page 293

Supported Transponder Cards and Pluggables

Table 122: Feature History

Feature Name Release Information Feature Description

Pluggable Support Cisco ONP Release 4.1 QSFP-100G-FR-S= pluggable is
supported on the QSFP ports of the
400G-XP LC transponder card with
100GE data rate.

QSFP-100G-ERL-S Pluggable Cisco ONP Release 5.1 The new QSFP-100G-ERL-S
pluggable enables you to design
and validate topologies for NCS
2000 R11.1.3 networks. This
pluggable is supported on the QSFP
ports of the 400G-XP-LC
transponder card with 100GE data
rate. You can select this pluggable
from the Client Interface
drop-down list at trail level
properties for the 400G-XP-LC
transponder card.

Cisco ONP supports the following transponders and pluggables for NCS 2000 networks:
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Table 123: Supported Transponder Cards and Pluggables for NCS 2000 Network

Supported Cards and Pluggables |

Transponder/ | Traffic Type | FEC mode |Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
200G-CK-LC|  + 100GE |SD-FEC 20| + SR-1(CPAK-100G-SR10) | Yes (only | No Auto,
+ MR-MXP for TRK 200G
(200G MXP « OTU4 * SR-1(CPAK-100G-SR4) |9
mode) + LR-1(CPAK-100G-LR4)
+ SR-1(CPAK-100G-SR10)
+ LR-1(CPAK-100G-LR4)
200G-CK-LC | 100GE SD-FEC 20| + SR-1(CPAK-100G-SR10) | Yes Yes Auto,
+ MR-MXP TRK_100G
(100G TXP + SR-1(CPAK-100G-SR4
mode) « LR-1(CPAK-100G-LR4)
200G-CK-LC | 100GE SD-EFEC + SR-1(CPAK-100G-SR10) | Yes Yes Auto,
+ MR-MXP TRK_100G
(100G TXP + SR-1(CPAK-100G-SR4
mode) « LR-1(CPAK-100G-LR4)
200G-CK-LC | 100GE SD-FEC + SR-1(CPAK-100G-SR10) | Yes Yes Auto,
+ MR-MXP TRK_100G
(100G TXP + SR-1(CPAK-100G-SR4
mode) * LR-1(CPAK-100G-LR4)
200G-CK-LC| + 10GE |SD-FEC 20| + LR-I(ONS-QSFP4*10GMLR) | Yes Yes Auto,
+ MR-MXP . TRK_ 100G
(100G MXP « 10GE « LR-1(QSFP-4*10G-MLR)
mode) LAN « SR-1(QSFP-40G-SR4
PHY = (Q - - )
. OC192 + SR-1(ONS-SC+10G-SR)
. OTU2 + LR-1(ONS-SC+10G-LR)
« DWDM(ONS-SC+-10G-C)
+ DWDM(ONS-SC+10GEPxxx)
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
200G-CK-LC * 10GE |SD-EFEC * [ R-1(ONS-QSFP4*10G-MLR) | Yes Yes Auto,
+ MR-MXP N TRK 100G
(100G MXP « 10GE « LR-1(QSFP-4*10G-MLR)
mode) LAN * SR-1(QSFP-40G-SR4
PHY -1(QSFP-40G-SR4)
. OC192 « SR-1(ONS-SC+10G-SR)
« OTU2 * LR-1(ONS-SC+10G-LR)
« DWDM(ONS-SC+-10G-C)
« DWDM(ONS-SC:+10GEPxxx)
200G-CK-LC * 10GE |SD-FEC * [ R-1(ONS-QSFP4*10G-MLR) | Yes Yes Auto,
+ MR-MXP LAN N TRK 100G
(100G MXP PHY « LR-1(QSFP-4*10G-MLR)
d L]
mode) . 10GE SR-1(QSFP-40G-SR4)
. OC19 « SR-1(ONS-SC+10G-SR)
. OT2 * LR-1(ONS-SC+10G-LR)
« DWDM(ONS-SC+-10G-C)
« DWDM(ONS-SC:+10GEPxxx)
200G-CK-LC * 10GE |SD-FEC 20 * SR-1(ONS-SC+10G-SR) | Yes Yes Auto,
+ MR-MXP TRK 100G
(100G MXP . ]{()AC;\IIE * LR-1(ONS-SC+10G-LR)
mode 2*10G * DWDM(ONS-SC+-10G-C)
2%40G PHY
MODE) « 40GE * LR-1(QSFP-40G-LR4)
« DWDM(ONS-SC-+10GEPxxx)
* SR-1(QSFP-40G-SR4)
« SR-1(QSFP-40G-SR-BD)
200G - * 10GE |SD-EFEC * SR-1(ONS-SC+10G-SR) | Yes Yes Auto,
CK-LC + TRK_100G
MR - MXP « 40GE « LR-1(ONS-SC+10G-LR)
(100G MXP « DWDM(ONS-SC+-10G-C)
mode 2*¥10G
2*40G * DWDM(ONS-SC+10GEPxxx)
MODE) « SR-1(QSFP-40G-SR4)
« LR-1(QSFP-40G-LR4)
« SR-1(QSFP-40G-SR-BD)
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Supported Cards and Pluggables |

Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
200G - * 10GE |SD-FEC * SR-1(ONS-SC+10G-SR) | Yes Yes Auto,
CK-LC + TRK 100G
MR -MXP « 40GE « LR-1(ONS-SC+10G-LR)
(100G MXP « DWDM(ONS-SC+-10G-C)
mode 2*10G
2*40G * DWDM(ONS-SC+10GEPxxx)
MODE) * SR-1(QSFP-40G-SR4)
« LR-1(QSFP-40G-LR4)
« SR-1(QSFP-40G-SR-BD)
200G - * 10GE |SD- * SR-1(ONS-SC+-10G-SR) | Yes for | No Auto,
CK-LC FEC 20 OTU2e TRK 100G
+10x10G * OC192 * LR-1(ONS-SC+-10G-LR
-LC - OTU2 « DWDM(ONS-SC+-10G-C)
*« OTU2e  DWDM(ONS-SC:+10GEPxxx)
+ ER(ONS-SC+-10G-ER)
« ZR (ONS-SC+-10G-ZR)
« DWDM(ONS-SC+-10G-xx.x)
200G - * 10GE |SD-EFEC * SR-1(ONS-SC+-10G-SR) | Yes for |No Auto,
CK-LC OTU2e TRK 100G
+10x10G * OC192 * LR-1(ONS-SC+-10G-LR
-LC - OTU2 « DWDM(ONS-SC+-10G-C)
. OTU2e « DWDM(ONS-SC:+10GEPxxX)
« ER (ONS-SC+-10G-ER)
« ZR (ONS-SC+-10G-ZR)
« DWDM(ONS-SC+-10G-xx.x)
200G-CK-LC * 10GE |SD-FEC * SR-1(ONS-SC+-10G-SR) | Yes for |No Auto,
+10x10G OTU2e TRK 100G
LC + OC192 * LR-1(ONS-SC+-10G-LR
« OTU2 « DWDM(ONS-SC+-10G-C)
« OTU2e « DWDM(ONS-SC+10GEPxxx)
« ER(ONS-SC+-10G-ER)
« ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
200G - « 100GE | SD- * SR-1(CPAK-100G-SR10) | Yes for |No Auto,
CK-LC + FEC 20 100GE TRK 200G
MR-MXP « 10GE * SR-1(CPAK-100G-SR4) |, 4
(200G Mxp .« 0C192 « LR-1(CPAK-100G-LR4) |OTU2
100G+10*10G
Mode) « OTU2 « SR-1(ONS-SC+-10G-SR)

* LR-1(ONS-SC+-10G-LR)

« DWDM(ONS-SC+-10G-C)

« DWDM(ONS-SC+10GEPxxx)

« ER(ONS-SC+-10G-ER)

+ ZR(ONS-SC+-10G-ZR)

« DWDM(ONS-SC+10Gxx.x)
200G-CK-LC| + 10GE |SD- * SR-1(ONS-SC+-10G-SR) | Yes Yes Auto,
+ MR-MXP FEC 20 TRK_ 200G
+ MR-MXP . &(I‘]\}Iz * LR-1(ONS-SC+-10G-LR)
(200G Mxp PHY « DWDM(ONS-SC+-10G-C)
4*%40G +
4*%10G « 40GE « DWDM(ONS-SC+10GEPxxx)
Mode) « SR-1(QSFP-40G-SR4)

+ LR-1(QSFP-40G-LR4)

+ SR-1(QSFP-40G-SR-BD)
200G-CK-LC| « 10GE |SD- * SR-1(ONS-SC+-10G-SR) | Yes Yes Auto,
+10x10G FEC 20 TRK_ 200G
-LC+ + OC192 « LR-1(ONS-SC+-10G-LR)
MR-MXP < OTU2 « DWDM(ONS-SC+-10G-C)

« DWDM(ONS-SC+10GEPxxx)

+ ER(ONS-SC+-10G-ER)

+ ZR(ONS-SC+-10G-ZR)

* DWDM(ONS-SC+-10G-xx.x)

« LR-1(ONS-QSFP4*10G-MILR)

+ ZR(ONS-SC+-10G-ZR)
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
200G-CK-LC * 10GE |SD-FEC 20 * SR-1(ONS-SC+-10G-SR) | Yes Yes Auto,
+ MR-MXP TRK 200G
+ MRMXP < 0C192 « LR-1(ONS-SC+-10G-LR)
« OTU2 « DWDM(ONS-SC+-10G-C)
 DWDM(ONS-SC:+10GEPxxx)
* ER(ONS-SC+-10G-ER)
« ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
« LR-1(ONS-QSFP4*10G-MLR)
* ZR(ONS-SC+-10G-ZR)
100GS - * 10GE | EFEC, * SR-1(ONS-SC+-10G-SR) | No No Auto,
CK-LC + SD-FEC 20 TRK_100G
10x10G-LC * OC192 * LR-1(ONS-SC+-10G-LR)
* DWDM(ONS-SC+-10G-C)
« DWDM(ONS-SC-+10GEPxxx)
« ER(ONS-SC+-10G-ER)
« ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
100G - LC-C * 10GE |FEC * SR-1(ONS-SC+-10G-SR) | No No Auto
+
10x10G-LC * OC192 * LR-1(ONS-SC+-10G-LR)
« Fiber « DWDM(ONS-SC+-10G-C)
Channel
10G « DWDM(ONS-SC-+10GEPxxx)
. Fiber « ER(ONS-SC+-10G-ER)
ggmfl « ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
*+ OTU2
* OTU2e
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
100G - LC-C * 10GE |EFEC * SR-1(ONS-SC+-10G-SR) | No No Auto
+
10x10G-LC < 0C192 « LR-1(ONS-SC+-10G-LR)
« Fiber « DWDM(ONS-SC+-10G-C)
Channel
10G  DWDM(ONS-SC:+10GEPxxx)
« Fiber « ER (ONS-SC+-10G-ER)
S(l}amd « ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC+10G-xx.X)
« OTU2
* OTU2e
100G - LC-C * 10GE |HG-FEC * SR-1(ONS-SC+-10G-SR) | No No Auto
+
L0x10G-LC « 0C192 « LR-1(ONS-SC+-10G-LR)
« Fiber « DWDM(ONS-SC+-10G-C)
Charnel
10G « DWDM(ONS-SC:+10GEPxxx)
« Fiber « ER (ONS-SC+-10G-ER)
ggalml * ZR (ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
*« OTU2
* OTU2e
100G - CK- * 10GE |FEC * SR-1(ONS-SC+-10G-SR) | No No Auto
LC-C+
10x10G-LC . I{(I)A(;}IE * LR-1(ONS-SC+-10G-LR)
PHY * DWDM(ONS-SC+-10G-C)
. OC19 « DWDM(ONS-SC-+10GEPxxx)
. Fiber « ER(ONS-SC+-10G-ER)
%ﬂéﬂfl « ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
* Fiber
Channel
8G
« OTU2
* OTU2e
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Supported Cards and Pluggables |

Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
100G * 10GE |EFEC * SR-1(ONS-SC+-10G-SR) | No No Auto
-CK-LC-C +
10X 10G-LC . i(ﬁ]E + LR-1(ONS-SC+-10G-LR)
PHY « DWDM(ONS-SC+-10G-C)
. OC19  DWDM(ONS-SC:+10GEPxxx)
« Fiber * ER(ONS-SC+-10G-ER)
%Egml « ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
* Fiber
Channel
8G
*« OTU2
* OTU2e
100G - * 10GE |HG-FEC * SR-1(ONS-SC+-10G-SR) | No No Auto
CK-LC-C +
10x10G-LC . i (i(;i\lli * LR-1(ONS-SC+-10G-LR)
PIY « DWDM(ONS-SC+-10G-C)
. OC19  DWDM(ONS-SC:+10GEPxxx)
« Fiber + ER(ONS-SC+-10G-ER)
%}agﬂ « ZR(ONS-SC+-10G-ZR)
« DWDM(ONS-SC-+-10G-xx.x)
* Fiber
Charnel
8G
*« OTU2
* OTU2e
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
400G-XP-LC * 100GE | SD-FEC 25- * SR-1(QSFP-100G-SR4-S) | Yes Yes TRK 100G,
NO _DE TRK 200G
* 10GE - * LR-1(QSFP-100G-LR4-S) -
LAN
PIY « LR-1(QSFP-28-LR4)
. 10GE « SR-1(QSFP-100G-SM-SR)
« 40GE * SR-1(QSFP-40/100G-SRBD)
« Fiber « LR-1(ONS-QSFP4*10G-MLR)
%ﬂéﬂﬂ « LR-1(QSFP-4*10G-LR)
« SR-1(QSFP-40G-SR4)
* Fiber
Channel « ER(ONS-QSFP4*10G-MER)
16G « LR-1(QSFP-40G-LR4)
* Fiber SR-1(QSFP-40G-SR-BD
Channel
8G « LR-1(ONS-QC16GFC-LW)
« 0C192 « LR-1(ONS-QC16GFC-SW)
SIMA
* LR-1(ONS-QSFP28-LR4)
« OTU2
« FR-1 (QSFP-100G-FR-S)
* OTU2e (only for 100GE)
+ OTU4 * ER-1

(QSFP-100G-ERL-S)
(only for 100GE)
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Supported Cards and Pluggables |

Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
400G-XP-LC * 100GE | SD-FEC 15 * SR-1(QSFP-100G-SR4-S) | Yes Yes TRK 100G,
-NO_DE TRK 200G
* 10GE - * LR-1(QSFP-100G-LR4-S) -
LAN
PHY * LR-1(QSFP-28-LR4)
« 10GE * SR-1(QSFP-100G-SM-SR)
- 40GE " SR-1
(QSFP-40/100G-SRBD)
* Fiber N
Cherndl « LR-1(ONS-QSFP4*10G-MLR)
10G « LR-1(QSFP-4*10G-LR)
* Fiber « SR-1(QSFP-40G-SR4)
Charnel
16G * ER(ONS-QSFP-4*10G-MER)
« Fiber « LR-1(QSFP-40G-LR4)
3G ! * SR-1(QSFP-40G-SR-BD
. OC192 « LR-1(ONS-QC16GFC-LW)
STV « LR-1(ONS-QC16GFC-SW)
+ OTU2 * LR-1(ONS-QSFP28-LR4)
. OTU2e « FR-1 (QSFP-100G-FR-S)
. OTU4 (only for 100GE)
* LR-1
(QSFP-100G-ERL-S)
(only for 100GE)
100G-LC-C * 100GE | FEC SR-1(CPAK-100G-SR10) No No Auto
+ OTU4
100G-LC-C * 100GE | EFEC SR-1(CPAK-100G-SR10) No No Auto
*« OTU4
100G-LC-C * 100GE | HGFEC SR-1(CPAK-100G-SR10) No No Auto
*« OTU4
100G - * 100GE | FEC * SR-1(CPAK-100G-SR4) |No No Auto
CK-LC-C
* 40GE * SR-1(CPAK-100G-SR10)
- OTU4 « LR-1(CPAK-100G-LR4)
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Transponder/ | Traffic Type | FEC mode | Pluggables Supported Encryption | Encryption | Trunk
Muxponder SSON Non-SSON | Mode
100G - * 100GE | EFEC * SR-1(CPAK-100G-SR4) |No No Auto
CK-LC-C

* 40GE * SR-1(CPAK-100G-SR10)

- OTU4 « LR-1(CPAK-100G-LR4)
100G - * 100GE | HGFEC * SR-1(CPAK-100G-SR4) |No No Auto
CK-LC-C

* 40GE * SR-1(CPAK-100G-SR10)

- OTU4 « LR-1(CPAK-100G-LR4)
100GS - 100GE FEC SR-1(CPAK-100G-SR10) Yes No Auto,
CK-LC TRK 100G
100GS - 100GE EFEC LR-1(CPAK-100G-LR4) YEs No Auto,
CK-LC TRK_100G
100GS - 100GE SD-FEC 20 | SR-1(CPAK-100G-SR10) Yes No Auto,
CK-LC TRK_100G
200G - * 100GE | FEC * SR-1(CPAK-100G-SR4) | Yes (for |No Auto,
CK-LC 100GE) TRK 100G
(100G Mode + OTU4 * SR-1(CPAK-100G-SR10)
only) « LR-1(CPAK-100G-LR4)
200G - * 100GE | EFEC * SR-1(CPAK-100G-SR4) | Yes (for |No Auto,
CK-LC 100GE) TRK 100G
(100G Mode *+ OTU4 * SR-1(CPAK-100G-SR10)
only) « LR-1(CPAK-100G-LR4)
200G-CK-LC * 100GE | SD-FEC 20 * SR-1(CPAK-100G-SR4) | Yes (for |No Auto,
(100G Mode 100GE) TRK._ 100G

+ OTU4 * SR-1(CPAK-100G-SR10)
only)

« LR-1(CPAK-100G-LR4)

Cisco ONP supports the following transponders and pluggables for NCS 2000 networks:
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Table 124: Supported Transponder Cards and Pluggables for NCS 1010 Network

Supported Cards and Pluggables |

Transponder / Traffic | FEC mode |Pluggables Supported Encryption | Trunk
Muxponder Type Mode
Client Pluggables Trunk Pluggables

NCS1K14-2.4T-K9 | 100GE | SD_FEC 15 * Auto * Auto No * Auto

400GE * QDD-400G-FR4-S * CIMS8-C-K9 * 400G

* QDD-400-AOCIM * 500G

* QDD-400G-DR4-S * 600G

* QDD-4x100G-LR-S * 700G

* 800G

* 900G

* 1000G

* 1100G

* 1200G

NCS1K14-2.4T-X-K9 | 100GE | SD_FEC 15 » Auto » Auto Yes * Auto

400GE * QDD-400G-FR4-S * CIMS8-LE-K9 * 400G

* QDD-400-AOCIM * CIM8-C-K9 * 500G

* QDD-400G-DR4-S * 600G

* QDD-400G-LR4-S * 700G

* QDD-4x100G-LR-S * 800G

* QDD-4x100G-FR-S * 900G

* 1000G

* 1100G

* 1200G
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Transponder / Traffic | FEC mode |Pluggables Supported Encryption | Trunk
Muxponder Type Mode
Client Pluggables Trunk Pluggables
NCS1K4-QXP-K9 | 100GE | OFEC * Auto * Auto Yes * Auto
PR * QSFP-100G-DR-S » QIDALZES * 100G
* QSFP-100G-LR4-S " QODANGZRS
« QSFP-100G-LR-S » DRQRLDH®
. ONSQSFP28LR4|  TORDDLO
* QSFP-I00GCWDIVIS " DRAEIDEED
* QSFP-100G-FR-S
* QSFP-100G-SR4-S
* QDD-4x100G-LR-S * 100G
* 200G
* 300G
* 400G
400GE * QDD-400G-FR4-S * 400G
* QDD-400-AOCIM
» QDD-400G-DR4-S
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APPENDIX D

Supported Optical Sources

* Supported Optical Sources, on page 307

Supported Optical Sources

Table 125: Feature History

Feature Name Release Information Feature Description

New Optical Source and | Cisco ONP Release 4.2 | Optical Sources enable you to simulate the optical
Pluggable Support feasibility of the network with the 400G and other
interfaces that are not natively modeled in Cisco ONP.
The following Optical Sources are introduced in this
release:

* ONS-CFP2D-400G-C-OpticalSources-V 2.mxd
» QDD-400G-ZRP-S-OpticalSources-V2.mxd

Cisco ONP supports the following optical sources:

)

Note From Release 24.3.1, the optical sources for NCS 2000 networks are tagged with System Release to indicate
from when the optical sources support the network release.

* OpticalSources NCS2K 400GXP-LC NCS4K-4H-OPW-QC2 DWDM Line Card
* 400GXP_100G_25% DE
* 400GXP_200G_15% DE
+ 100G-SD-FEC
* 400GXP_100G_15% DE
* 200G-SD-FEC
* 400GXP_100G_15%
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« 400GXP_200G_15%
« 400GXP_200G_25%DE

* NCS1004 OpticalSources_V3
* NCS1004 QPSK SP 16QAM 200G 27%SDFEC 60GBd

«NCS1004_SP_16QAM 300G _27%SDFEC_69GBd

« NCS1004_QPSK_200G_27%SDFEC_69GBd

« NCS1004_16QAM_32QAM 400G _27%SDFEC_62GBd

« NCS1004_16QAM_400G_27%SDFEC_69GBd

« NCS1004_SP_16QAM_16QAM 300G _27%SDFEC_60GBd
« NCS1004_32QAM_500G_27%SDFEC_69GBd

* NCS1004 L Band OpticalSources V3
* NCS1004_L 200G_QPSK 27%SDFEC _69GBd

«NCS1004_L 200G_QPSK_SP_16QAM_27%SDFEC_60GBd

« NCS1004 L 300G _SP_16QAM_16QAM 27%SDFEC_60GBd
« NCS1004 L 300G_SP_16QAM _27%SDFEC_69GBd

+ NCS1004_L_400G_16QAM _32QAM 27%SDFEC_62GBd

«NCS1004_L _400G_16QAM_27%SDFEC_69GBd

* QDD and CFP2-DCO variants
. ONS—CFPZD-4OOG-C-OpticalSources—VZ.mxd2
* CFP2 2000R _TXP_ FOIC2 OFEC 15 DE ON 4Q 1S BR63 1

« CFP2_3000R_TXP_FOIC3_OFEC_15 DE_ON_8Q 1S BR63_1
« CFP2_4000R_TXP_FOIC4 OFEC_15 DE ON_16Q 1S BR63 1

. ONS—CFPZD-4OOG-C-OpticalSources-VZ.mxd3
« CFP2_300ZR+ MXP_GAUI8 OFEC_15 DE ON_8Q 0S BR60 1
« CFP2_200ZR+ MXP GAUI2 OFEC_15 DE ON 8Q 1E BR40 1
« CFP2_200ZR+ MXP GAUI2 OFEC_15 DE ON_16Q 1E BR30 1
« CFP2_400ZR_TXP_GAUI8 CFEC_15 DE ON_16Q 0S_BR59 8
« CFP2 200ZR+ MXP GAUI2 OFEC_15 DE ON 4Q 0S BR60 1
« CFP2_100ZR+ TXP_GAUI2 OFEC 15 DE ON 4Q 1S BR30 1

2 The optical source interfaces are supported for SSON networks.
3 The optical source interfaces are supported for SSON and non-SSON networks.
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« CFP2_200ZR+ MXP_GAUI2 OFEC 15 DE ON 4Q 1S BR60 1
« CFP2_400ZR+ TXP_GAUI8_OFEC_15 DE_ON_16Q I1E BR60 1
« CFP2_300ZR+ MXP_GAUI8_OFEC_15 DE ON _8Q IE BR60 I
- CFP2_400ZR+ TXP GAUI8 OFEC_15 DE ON _16Q 0S BR60 1
« CFP2_1000R_TXP_FOIC! OFEC 15 DE_ON 4Q 1S BR31 6

« CFP2_2000R_TXP_FOIC2 _OFEC 15 DE_ON_8Q 1S BR42 1

« CFP2_2000R_TXP_FOIC2 _OFEC_15 DE _ON_16Q_IE_BR31 6

. QDD-4OOG-ZRP-S—OpticalSourceﬁ-VZ.mxd3

« QDD 200ZR+ MXP GAUI2 OFEC_15 DE ON 4Q 1S BR60 1
* QDD 400ZR_TXP_GAUI8 CFEC 15 DE ON _16Q 0S BR59 8

« QDD _200ZR+ MXP GAUI2 OFEC_15 DE ON_4Q 0S_BR60 1
« QDD_400ZR+ TXP_GAUI8 OFEC_15 DE_ON_16Q I1E BR60 1
« QDD 400ZR+ TXP_GAUI8 OFEC 15 DE ON 16Q 0S _BR60 1
« QDD _300ZR+ MXP GAUI8 OFEC_15 DE ON 8Q IE BR60 1
« QDD _400ZR+ TXP_GAUI8 OFEC 15 DE ON_16Q 0E BR60 1
« QDD 300ZR+ MXP GAUI8 OFEC_15 DE ON 8Q OE BR60 1
« QDD_100ZR+ TXP_GAUI2 OFEC_15 DE ON 4Q 1S BR30 I

« QDD _200ZR+ MXP GAUI2 OFEC_15 DE ON_16Q 1E BR30 I
« QDD _300ZR+ MXP GAUI8 OFEC_15 DE ON_8Q 0S_BR60 1
« QDD_200ZR+ MXP_GAUI2_OFEC_15 DE ON_8Q IE BR40 I

* From Release 24.3.1, CONP supports QDD-400G-ZR-S Optical Sources.
QDD 400ZR_TXP _GAUI8 CFEC 15 DE ON_16Q 0S BR359 8

* Bright ZR+ Optical Sources
* Bright-400G-FOIC4-OFEC-16QAM-1-E BR63 14
* Bright-400G-FOIC4-OFEC-16QAM-1-S BR63 14
* Bright-300G-FOIC3-OFEC-8QAM-1-S_BR63 14
* Bright-200G-FOIC2-OFEC-QPSK-1-S BR63 14
* Bright-200G-FOIC2-OFEC-8QAM-1-E_BR42 09
* Bright-200G-FOIC2-OFEC-16QAM-1-E_BR31 57
* Bright-200G-FOIC2-OFEC-16QAM-1-S BR31 57
* Bright-100G-FOIC1-OFEC-QPSK-1-S_BR31 57
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* Bright-100G-FOIC1-OFEC-DQPSK-1-S BR31 57

* Bright-400G-400ZR-CFEC-16QAM-1-S BR59 84

* Bright-400G-400ZRP-OFEC-16QAM-1-E_BR60 14

* Bright-400G-400ZRP-OFEC-16QAM-1-S BR60 14

* Bright-300G-300ZRP-OFEC-8QAM-1-E BR60 14

* Bright-300G-300ZRP-OFEC-8QAM-1-S BR60 14

* Bright-200G-200ZRP-OFEC-QPSK-1-S BR60 14

* Bright-200G-200ZRP-OFEC-8QAM-1-E_BR40 09

* Bright-200G-200ZRP-OFEC-16QAM-1-E_BR30 07

* Bright-100G-100ZRP-OFEC-QPSK-1-S BR30 07

* Bright-100G-OTU4-SCFEC-DQPSK-1-S BR27 95

* From Release 24.3.1, CONP supports the DP04QSDD-HEO Optical Sources.
Bright 100G_100ZRP_OFEC QPSK 1S BR30 07

* Bright 200G_200ZRP_OFEC 16QAM 1E BR30 07

* Bright 400G_400ZRP_OFEC 16QAM 1S BR60 14

* Bright 200G_200ZRP_OFEC 8QAM 1E BR40 09

* Bright 400G_400ZRP_OFEC 16QAM 1E BR60 14

* Bright 300G_300ZRP_OFEC 8QAM _1E BR60 14

* Bright 300G_300ZRP_OFEC 8QAM 1S BR60 14

* Bright 200G_200ZRP_OFEC QPSK 1S BR60 14

* Bright 400G _400ZR_CFEC 16QAM 1S BR59 84

A\

Note Delete any of the old versions of Bright ZR+ optical sources that may be present
in the server. The latest list of optical resources will be automatically loaded after
Cisco ONP, Release 5.1 software is installed.

* Bright ZRP OpticalSources V2

The Rx OSNR sensitivity is improved for the Bright_400G_400ZRP_OFEC_16QAM_1E BR60_14
interface in the new version.

The latest list of optical resources will be automatically loaded after Cisco ONP, Release 5.2 software
is installed.

* From Release 25.1.1, CONP supports the CIM8 Optical Sources:
CIM8_OpticalSource v12
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« CIM8_400G_15FEC_Eth ZR BR108
- CIM8_400G_15FEC_Eth ZR_BR130
- CIM8_400G_15FEC_FEth_ZR_BRS8

« CIM8_500G_15FEC_Eth_ZR_BR128
- CIM8_500G_15FEC_Eth ZR_BR88

- CIM8_600G_15FEC_Eth ZR_BR128
« CIM8_600G_15FEC_FEth_ZR_BR98

« CIM8_700G_15FEC_Eth_ZR_BR98

« CIM8_700G_15FEC_Eth ZR BR128
- CIM8_800G_15FEC_Eth ZR_BR108
- CIM8_800G_15FEC_Eth ZR_BR118
« CIM8_800G_15FEC_Eth_ZR_BR128
« CIM8_800G_15FEC_Eth ZR BR138
- CIM8_900G_15FEC_Eth ZR_BR118
« CIM8_900G_15FEC_Eth_ZR_BR138
« CIM8_1000G_15FEC_Eth_ZR_BR128
« CIM8_1000G_15FEC_Eth ZR_BR138
« CIM8_1100G_15FEC_Eth_ZR_BR138
- CIM8_1200G_15FEC_FEth_ZR_BR138
« CIM8_500G_15FEC_Eth_ZR_BR138
« CIM8_600G_15FEC_Eth ZR BR138
« CIM8_700G_15FEC_Eth ZR_BR138

1. Delphi ULH_Optical Source v2 (new)
* Delphi-400G-ULH_OpenZR 16Q OS E 60 1
* Delphi-400G-ULH OpenZR 16Q OS HB 60 1
* Delphi-400G-ULH_FlexO-4e_OS_65_7
* Delphi-400G-ULH_FlexO-4 MPCS OS 69 1
* Delphi-400G-ULH_FlexO-4e MPCS OS 75
* Delphi-400G-ULH_FlexO-4e MPCS OS 78 9
* Delphi-400G-ULH_FlexO-4 MPCS_OS_87_3
* Delphi-400G-ULH_FlexO-4e MPCS_OS_87 4
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* Delphi-400G-ULH_FlexO-4e MPCS_OS 97 9
* Delphi-400G-ULH_FlexO-4e QPSK NOS OR 118 2
* Delphi-400G-ULH_OpenZR 16Q OS LA 60 1
* Delphi-400G-ULH_FlexO-4_MPCS_OS_100_8
Pluto QSFP28 100G_Optical Source vl (new)
* QSFP28_100G_SC_FEC_7_QPSK_BR28

\}

Note NCS 1004 is supported as an optical source.

\)

Note The following optical source files are not supported in NCS 2000 Release 11.0:
* NCS1004 16QAM_32QAM 400G 27%SDFEC_62GBd

« NCS1004 QPSK_SP_16QAM_200G_27%SDFEC_60GB

Hence, we recommend you to upgrade the system release of the network to Release 11.1, or force the optical
source files that are supported for the Release 11.0.
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APPENDIX E

Supported Amplifiers

* Supported Amplifiers, on page 313

Supported Amplifiers

Cisco ONP supports the following amplifiers:

Table 126: Cisco ONP Supported NCS 2000 Amplifiers

Amplifier Description

15454-M-RAMAN-CTP | Raman Amp C-Band

15454-M-RAMAN-COP | Raman Amp C-Band

EDFA 35 for OLA node | Erbium Doped Fiber Amplifier (EDFA) that can function in dual gain with
maximum gain of 35 dB

NCS2K-EDRA2-26C 21dBm EDFA + Bst 26dB Span - C-Band

NCS2K-EDRA1-26C 21dBm EDFA 26dB Span - C-Band

NCS2K-EDRA2-35C 21dBm EDFA + Bst 35dB Span - C-Band

NCS2K-EDRA1-35C 21dBm EDFA35dB Span - C-Band

\}

Note * RAMAN-CTP is supported on all nodes.
* EDRAS are supported on the OLA node.

* For ROADM and Traffic nodes, the booster amplifier and preamplifier are in-built. The booster is
20SMR-FS-BST.
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Table 127: Cisco ONP Supported NCS 1010 Amplifiers

Supported Amplifiers |

Amplifier Description

Lower Range Gain (dB) | Standard Range Gain (dB) | Tilt Uncontrolled Range

Gain (dB)

C-Band
OLT-C-Bst 16 24 31
OLT-C-Pre-Normal 12 22 25
OLT-C-Pre-Extended 17 32 35
ILA-C-Normal 8 17 20
ILA-C-Extended 13 30 33
ILA-R-C-Normal 8 17 23
ILA-R-C-Extended 13 30 36
ILA-2R-C-Normal 8 17 20
ILA-2R-C-Extended 13 30 33
E-ILA-R-C-Normal 8 17 20
E-ILA-R-C-Extended 13 30 33
E-ILA-2R-C-Normal 8 17 20
E-ILA-2R-C-Extended |13 30 33
E-ILA-C-R-2-Normal 8 17 20
E-ILA-C-R-2-Extended |13 30 33
L-Band
OLT-L-Bst 17.5 25.5 325
OLT-L-Pre-Normal 133 233 26.3
OLT-L-Pre-Extended 18.3 36.3 39.3
ILA-L-Normal 10.8 19.8 22.8
ILA-L-Extended 15.8 32.8 35.8




| Supported Amplifiers

Table 128: Cisco ONP Supported NCS 1001 Amplifiers

Supported Amplifiers .

Amplifier

Description

Pre Amplifier Gain (dB)

Standard Range Gain (dB)

Tilt Uncontrolled
Extended Range Gain (dB)

NCS1K-EDFA-Bst 1-20 20-25
NCS1K-EDFA-Pre - 0-24 24-27
Range 1
NCS1K-EDFA-Pre - 20-34 34-27
Range 2
Table 129: Cisco ONP Supported NCS 1014 Amplifiers
Amplifier Description
Fixed Gain (dB) Standard Range Gain (dB) | Tilt Uncontrolled
Extended Range Gain (dB)
NCS1K14-EDFA2-Bst-1 |8 - -
- Range 1
NCS1K14-EDFA2-Bst-1 |20 - -
- Range 2
NCS1K14-EDFA2-Bst-2 |- 12-24 24-27
NCS1K14-EDFA2-Pre - |- 0-25 25-28
Range 1
NCS1K14-EDFA2-Pre - |- 20-26 36-29

Range 2
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APPENDIX F

Troubleshoot

* Troubleshooting Tasks, on page 317

Troubleshooting Tasks

The following table describes the common error messages that are related to Cisco ONP configuration and
the workarounds:

Table 130: Troubleshooting Tasks for Cisco ONP Configuration

Warning Message or Error Probable Reason for the Error Workaround

Cannot Route demand! Didn't find | Required contentionless sides are | Check and add the required number

any valid Contentionless Side. not created on add/drop sites. For | of contentionless sides on the target
protected service or wave, minimum | service or wave source and
two contentionless sides are destination sites.

required on the add/drop sites.

Error: No valid path from Disjoint path is not available for | For linear topology, change the
<source> to <destination> protected demand. demand protection to unprotected.
Or For ring topology, ensure that at

least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Forced wavelength may be already
used for other demand in the same
path.

Or .
Force the required number of
The number of colorless demands | colorless ports.

created is more than the colorless
ports forced on the interfaces.

Error: Traffic subnet constraints | Disjoint path is not available for | For linear topology, change the
prevent routing of section. protected demand. demand protection to unprotected.

Or For ring topology, ensure that at
least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Forced wavelength may be already
used for other demands in the same
path.
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. Troubleshoot

Troubleshoot |

Warning Message or Error

Probable Reason for the Error

Workaround

Error: The sum of CoDem and
Non-CoDem colorless ports and
ports that are used for
Omnidirectional and Contentional
sides cannot exceed 20 when the
TYPE is SMR-20.

The number of contentionless sides,
colorless ports that are forced, and
colored demand exceed SMR-20
port capacity.

Or

The Cascaded SMR flag is enabled,
and colored or colorless demand is
created.

If the Cascaded SMR flag is
enabled, create only contentionless
demands on those nodes. Else,
reduce the number of contentionless
sides, colorless ports, or colored
demands that are created, to get
successful network analysis.

Couple between <source>.<side>
and <destination>.<side> is of
invalid type.

The fiber connecting these sides is
not supported by Cisco ONP.

Change the fiber type to the one that
is supported by Cisco ONP.

Unconnected nodes or sites are
present in the network.

Any of the sites are connected to the
fiber in the Ring/Linear network.

Connect the fiber to the nodes in the
ring network.

Unfeasible forcing

Wrong path has been forced on the
wave or media channel.

Force the correct path on the
Wave/Media Channel.

E11000 duplicate key error
collection: CnpDB.dbchangelog
index: id_dup key: {:
Objectld(") }

Restore database script attempts to
write data in the postgres database,
but the data with the same index is
already present.

Clear the contents of
postgresdb_cnp folder before
running the restore command: rm
-rf

Ivar llib/postgresdb_cnp/* cannot

Cannot complete mesh
connection.

There is an issue with setting up
connection in the lock mode.

Unlock the mentioned entity or
unlock the complete site.

Path constraints prevent routing.

Invalid path has been forced.

Check the path and choose the
correct primary path and secondary
path fibers.

Or

Remove all the fibers that are forced
to set the Path of Wave property as
Auto.

Traffic subnet constraints prevent
routing.

Forced Wavelength is not part of
the Optical subnet rule.

Force the wavelength as per optical
subnet rule or change the optical
subnet rule.

MF Unit value MF1-RU is not
supported in RPT, so resetting the
value to default for <site name>.

Template is applied when properties
such as ECU, MF Unit are forced.

Set the property MF Unit to Auto
and then force the template.
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| Troubleshoot

Troubleshoot .

Warning Message or Error

Probable Reason for the Error

Workaround

Please force MD-48-CM as
Interlever Type for {0}.

In non-SSON traffic, the ROADM
site with the properties (DEG-8,
SMR-9, number of contentionless
sites is equal to 1) has 96 colored
waves.

The Interlever Typeis property
set to Auto or MpoCable.

Modify the Interlever forcing on the
line side to MD-48-CM.

The sum of forced CoDem and
Non-CoDem colorless ports and
colored demands can't be greater
than 9 for type SMR-9.

During upgrade or Release upgrade,
colorless port is forced on SMR-9,
and more than one contentionless
side is added in the imported MPZ
network.

Delete the extra contentionless
sides.

No Route Found.

Plan mode restoration fails because
the presence of dark fiber in the
restoration path makes it difficult to
find it.

Check the restoration path. It must
not have any dark fiber.

Wavelength Forced {0} in this
{1} is already in use / not as per
current optical subnet channel
rule.

Two fibers are occupied by a wave
with the same wavelength.

The fiber belongs to a subnet where
the wavelength is not supported. For
example, a wave with an even
wavelength is forced through a fiber
belonging to the C40 channel or
C48 channel subnet rules.

Correct the wave such that the
wavelength is supported by the
optical subnet C-band rule.

tm.unsupported client pluggable.msg
=Incompatible Client Interface
forcing.

ROADM sites having waves with
optical source other than 100,
200SDFEC are converted to traffic
sites.

Before you convert the site type to
traffic, modify the optical source
wave to be feasible.

Error Message

Slow internet connectivity, or idle
session.

Refresh the browser and try again.

Please provide a valid .mpz
network file.

The MPZ file that you are trying to
upload does not have a valid file
extension.

Upload proper .MPZ file.

Failed to import mpz file, please
make sure the MPZ file is not in
use and retry.

MPZ file remains open in the CTP
tool.

Close MPZ file in the CTP tool
before uploading it to Cisco ONP .

Cannot connect to
Server;(Password).

Failed to connect to Postgres DB on
opening Control Panel tab.

Restart the Postgres database
container or reinstall the Build.
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. Troubleshoot

Troubleshoot |

Warning Message or Error

Probable Reason for the Error

Workaround

Null pointer exception

The applied layout template file has
syntax error such as extra SPACE,

TAB, missing symbols such as <,
>.

Fix the syntax and reapply the
template.

Object not found in cache.

Intermediate network disconnection.

Refresh the browser or log in again
to Cisco ONP.

Session does not exist.

Idle time-out

Log in again to Cisco ONP.

Forced/Locked wavelength is not
feasible for spectrum to be
allocated for the demand/MCH
<Ste-1-Ste-3-1>. Insufficient
spectrum around the forced central
wavelength.

Forced wavelength is not a feasible
central wavelength based on the
configuration.

Force another wavelength that is
next to the currently forced one.

Route could not be
found/Alternate path not
found/<Optically not feasible>.

Insufficient spectral width due to
the following reasons:

* The alternate path has no
waves (dark fiber).

* Optical parameters are not
feasible.

» Wavelength dos not have
sufficient bandwidth.

Make sure that the alternate path has
waves associated with the fiber and
has sufficient bandwidth available.

Error: Could not find any valid
flex configuration for the traffic
matrix defined at <Ste-1.A> This
could be because of configuration
limitations, invalid forcings, or
equipment restrictions.

Check if it is 8 degrees, SMR-9
node with Evolved Mesh ON and
contentionless and colorless/colored
mixed add/drop configuration.

Change Evolved Mesh to Off,
reduce Scalable upto degree to 8,
change Site Type to SMR-20, or
Remove contentionless or colorless
forcing.

Single hop path Site-1~Site-3
needs regeneration but has no
regenerator hosting sites.

Check if Quick analysisunder
Network property is disabled.

* Enable Quick analysis.

* After successful analysis,
check the optical report and
look for the waves that require
regeneration.

* Split the long haul demand
between the intermediate short
distance nodes that are
equivalent to regen site.

« Disable Quick analysisand
analyze.

Il Cisco Optical Network Planner Configuration Guide, Releases 25.x.x



| Troubleshoot

Troubleshoot .

Warning Message or Error

Probable Reason for the Error

Workaround

Missing SOURCE TermPoint for

Required Add/Drop card cannot be

Check the source node configuration

PceServiceRequest placed on the source node. (such as scalable upto degree,
number of colored and colorless
circuits or port forcing,and colored
add/drop card forcing).

Missing DESTINATION Required Add/Drop card cannot be | Check the destination node

TermPoint for PceServiceRequest

placed on the destination node.

configuration (such as scalable upto
degree, number of colored and
colorless circuits or port forcing,and
colored add/drop card forcing).

Service allocation failed: No
resource available

Spectrum allocation failed for the
mentioned service

* Check the colored add/drop
forcing and the number of
colored demands routing on the
path.

* Check the number of colorless
demands, ports, and add/drop
cards forced on the path.

* Check the optical subnet
defined on the path and the
type of service used.

Service allocation failed:
[PCE-WALO00028] - No free
spectrum available to allocate
circuit: [PCE-WAL00028]

Spectrum allocation failed for the
mentioned service

Check the card type forced for the
colored circuit. Circuits with a
maximum spectrum of 75GHz can
be used with colored add/drop
MD-32-ODD/EVEN. For example,
a circuit that has an interface with
rate greater than 60-bit rate or
60GBd cannot work with 75GHz
fixed grid add/drop with 82%
spectral density. Change to colorless
add/drop BRK-24 or change to
interface type having less spectral
occupancy.

Colorless configuration is not
supported for Scalable Upto
Degree [25]

Check if MF Unit is forced as
MF-1RU. Only 3 USB ports
available with NCS 1010 OLT-C-R.
Maximum of only 3 Passives can be
connected to OLT line cards. So, for
Scalable upto degree >25, since
USB ports are not available to
connect to passive colorless
Add/Drop, error appears.

Force MF Unit as MF-4RU
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Troubleshoot |

Warning Message or Error

Probable Reason for the Error

Workaround

Error: No free spectrum available
to allocate circuit

1. Ifitis an L-band Circuit,

L-band forcing may be missing

in the intermediate nodes.

2. Complete spectrum is utilized

in the path if forced, or on all
the available path between
source and destination.

1.

2.

1. Force L-band on all
intermediate nodes on the
L-band circuit route path.

2. Try to force other available
path or add new path if
spectrum is exhausted on all
available paths.

Untested System Configuration:
Number of OLA sites between
Terminal sites is more than 2.
Please contact support before
deployment.

The NCS 1001 network has more
than two OLA sites between
Terminal sites.

Keep only two OLA sites between
Terminal sites.
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