Design and Analyze Networks

* Design a Network Using Cisco ONP, on page 2

* Create Optical Subnet for Non-SSON Networks, on page 21

* Create Optical Subnet for SSON Networks, on page 22

* Create Optical Subnet for NCS 1010 Networks, on page 23

* Convert Non-SSON Network to SSON Network, on page 24

* Convert NCS 2000 Network to NCS 1010 Network, on page 25

* Share a Network, on page 26

* Analyze the Network, on page 28

* Upgrade the Analyzed Network, on page 30

* Upgrade LNI Network, on page 31

» Upgrade the Software Release of a Network , on page 35

* Plan Mode, on page 37

» Automatic Suggestion for Regeneration Sites in Plan Mode, on page 42
* Line Rate Tuner Mode, on page 44

* Import Optical Sources, on page 49

* Find Optical Sources Faster, on page 52

» Download Optical Sources, on page 53

* Delete Optical Sources, on page 54

» Layout Template for NCS 2000 Network, on page 54

* Layout Visualization, on page 58

* Spectrum Utilization and Path Finder, on page 66

* Regenerate BoM Automatically, on page 70

* Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM, on page 70
* Export [PC Report, on page 71

+ Edit the Layout Manually for NCS 1010 Networks, on page 72

* View Internal Node Connections of NCS 1010 Network, on page 74

* Design Networks with SVO Card, on page 75

* Associate OLA or DGE Sites with SVO Cards, on page 76

» Export Device NETCONF XML File, on page 76

» Upload NETCONF XML Files on SVO Web Interface, on page 79

» Export Device NETCONF XML Files for Individual Sites, on page 79
» Upload NETCONEF Files to NCS 1010 Device, on page 80

* Export Cisco Optical Site Manager NETCONF XML File, on page 80

Design and Analyze Networks .



Design and Analyze Networks |
. Design a Network Using Cisco ONP
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Design a Network Using Cisco ONP

You can design a network in one of the following ways:
» Manual Design—Create a network design using a design palette.

* Import Design—Import a network design from an Excel sheet, Live Network Import or from an existing
network from CTP, or another instance of Cisco ONP.

Manually Design a Network Using Cisco ONP

Table 1: Feature History

Feature Name Release Information Feature Description

Database Operations Optimization | Cisco ONP Release 5.2 Cisco ONP now provides an option
to run some operations in the
background involving database
interaction, such as Save As,
Import CPZ, and Export CPZ.
You can continue to use the Cisco
ONP interface for other operations
when these operations are running

in the background.
Table 2: Feature History
Feature Name Release Information Feature Description
4K-2K SSON Network Creation | Cisco ONP Release 5.2 Now you can include the 4K-2K
Support nodes in both SSON and

non-SSON networks while
designing the network. This helps
you to validate 4K-2K nodes in the
SSON design which has higher line
rates.
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Table 3: Feature History

Feature Name Release Information Feature Description

NCS 1010 C+L Network Design | Cisco ONP Release 5.1 Cisco ONP now supports the
C+L-band networks that help you
plan NCS 1010 networks using the
OLT-L and ILA-L line cards to
increase your network’s bandwidth
capacity. Enhanced with L-band
related properties, the UI enables
you to design a C+L-band network
for your ever-increasing channel
demands. The following L-band
types are introduced to suit your
design needs:

o C+L—This band type adds
more channels to your
network, increasing its traffic
carrying capacity.

» C+L Futuristic—This band
type creates a network with
C-band edges and future
provisions for L-band edges
that you can cost-effectively
upgrade after exhausting the
C-band capacity.

Table 4: Feature History

Feature Name Release Information Feature Description
Greenfield NCS 1010 Network Cisco ONP Release 5.0 You can design and validate
Design NCS1010 optical line system. This

feature helps to create OLT-C,
OLT-R-C, ILA-C, ILA-R-C, and
ILA-2R-C based NCS 1010
networks using fixed grid add/drop
MD-32-ODD, MD-32-EVEN and
flex grid add/drop BRK-24,
BRK-16, and BRK-8 passive
modules.
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. Manually Design a Network Using Cisco ONP

Step 1

Step 2

Step 3

Step 4

Table 5: Feature History

Feature Name Release Information Feature Description

Multi-Layer Platform (MLP) Cisco ONP Release 4.1 This feature allows you to perform
Greenfield Design with NCS the following:

4k-1k-2k

* Supports NCS 4K-1K-2K
multi-platforms

* Visualizes new layout for Txp
and SVO for NCS 2000 node

* Supports different OTN
service types with protection

+ Edits layout for NCS 4000 and
NCS 1004 nodes

You can create any of the following network designs:

* Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions

* Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand
and network conditions

* NCS 1010 network

Perform the following steps to create a network in the Cisco ONP:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> New.

The Create New Network dialog box appears.

From the LO Network Platform drop-down list, choose one of the following:

* NCS 2000—To create a non-SSON network that contains NCS 2000 and NCS 4000 nodes, or an SSON network
including NCS 2000, NCS 1004, and NCS 4000 nodes

* NCS1010—To create a network that contains only NCS 1010 nodes
* NCS1001—To create a network that contains only NCS 1001 nodes

If you want to create an SSON network, check the SSON Network check box, else leave the SSON Network check
box unchecked.

This option is not for the NCS 1010 network.

Choose NCS (4K _1K _2K) or NCS (4K _2K) from the Traffic Type drop-down list.

If you had chosen to create an SSON Network in the previous step, you can view the Traffic Type drop-down list.
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Step 5

Step 6

Step 7

Step 8
Step 9

Step 10

Step 11

Manually Design a Network Using Cisco ONP .

Note Once the network is created you cannot change the Traffic type from 4K 1K 2K to 4K 2K or vice versa.
Hence, we recommend you export the network into an Excel sheet, do the required modification and then import
it as a new network.

Choose the System Release for NCS 2K or NCS 1010 from the drop-down list.
You cannot change the system releases that are available for NCS 4K and NCS 1K.
The Band Type drop-down list appears for NCS 1010 R7.9.1 network.

From the Band Type drop-down list for NCS 1010, choose one of the following:

* C-Band—Only C-band edges are created and ANS is generated based on C-band. For L-band upgrade, ANS
unlock is required.

* C+L Futuristic—Only C-band edges are created and ANS is generated based on C-band and L-band. For L-band
upgrade, ANS unlock is not required.

* C+L—Both C-band and L-band edges are created and ANS is generated based on C-band and L-band.

Note  After the creation of a NCS 1010 R7.9.1 network, if required, you can change the network band type under the
Network Application Configuration section in the Network Properties.

Click Create.

You can view a map and the design palette. For more information, see Design Palette.

Click the Drawing Tool icon (pencil and ruler crossed).
Add sites to the map using the drawing tool.

a) Zoom into the map to the desired level. Click any of the site icons (ROADM, OLA or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.

SRLG is not supported in the SSON networks
Traffic node is not supported on the NCS 1010 network.

b) Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.

Note By default, the fiber length is updated as 1 km for all the fibers. If you want the length to be auto updated
based on the X, y coordinates, then enable the Use Coor dinates Distance property under the network
properties.

Create services between the sites (only for SSON and non-SSON networks).
Cisco ONP provides only OTN service.

a) Click the Drawing Tool icon and select OTN Service (Green in color).
b) Add the service between the existing Traffic sites on the map.
Create circuits (for NCS 1010), media channels (for SSON), or waves (for non-SSON) between the sites.

a) Click the Drawing Tool icon, and select Circuit (purple in color), M edia channel (purple in color), or Waves
(red in color).

b) Add the circuit, media channel, or waves between the existing sites on the map.

Design and Analyze Networks .
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. Create Shared Risk Link Group

In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Step 12 Choose File> SaveAs.
Step 13 Enter a network name in the Give a Network Name dialog box.
Step 14 Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job M onitor to view the progression of the
operation running in the background.

Step 15 Click Save.

Create Shared Risk Link Group

You can use the Shared Risk Link Group (SRLG) feature for routing protected services. You can create SRLGs
through the Excel import file SRLG tab or through the Cisco ONP GUI using the following procedure:

\}

Note SRLG is supported only for the non-SSON network including the traffic nodes.

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Click the network tree panel in the left.

Step 2 Expand Fibers.

Step 3 Check the check box next to each fiber in the same SRLG.

Step 4 After all fibers are checked, right-click, and select Create SRLG.

SRLG is created with a unique name. You can rename the SRLG.

Import Network Using Excel Sheet
Use this task to import a network into Cisco ONP, using an Excel sheet.

Table 6: Feature History

Feature Name Release Information | Feature Description

CX Unified Planning | Cisco ONP Release | The integration between CX Unified Planning Tool (UPT)
Tool Network Import |5.0 and Cisco ONP enables you to import the networks created
and analyzed in Cisco CX UPT into Cisco ONP. This helps
you avoid recreating the networks that are already created in
UPT. This feature allows you to import networks having NCS
1010 and NCS 2000 nodes into Cisco ONP.
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Table 7: Feature History

Feature Name Release Feature Description

Information
Export and Import | Cisco ONP It is now possible to export the topology data of an existing network
of Network Release 5.1 into an Excel file. You can easily modify the exported data in Excel
Topology in Excel and import it back into Cisco ONP to create a new network or modify
Format an existing network.

The following are the supported Excel formats:

* XIsx—Standard Excel with multiple sheets, each corresponding
to a network element such as Network, Sites, Circuits, Spans,
OTNdemands, and so on.

» XIsm—Macros-enabled Excel file that can filter out and display
only the applicable network element sheets based on the platform
selected in the Network sheet.

Cisco ONP has the built-in intelligence to automatically calculate the
shortest path between a source and a destination, even if only a partial
fiber path is mentioned in the imported Excel file.

Note By default, the system release of the Excel imported network is 11.0.

Note From Release 5.0, Cisco ONP supports import of networks created using CX UPT via Cisco ONP Import
Excel option. CX UPT does not populate the DWDMChannel Type and Add/Drop Type values in the Excel
sheet. If the values are not found in the Excel sheet, then Cisco ONP picks the default options. By default,
DWDM Channel Typeis NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd and Add/Drop Type
is Colored. We recommend you to check the DWDMChannel Typeand Add/Drop Type values before importing
the Excel sheet into Cisco ONP to avoid any discrepancies.

From Release 5.1, in addition to exporting the template, you can also export the entire network design data
of an existing network in the form of the Excel sheet, modify the network properties available in the Excel
sheet and reimport. The network can be exported in all modes and reimported on Design mode, Upgrade
mode, and Release Upgrade mode.

N

Note Transponders are not supported as part of Export/Import Excel. When you export an existing network with
transponder card forced, the exported Excel sheet will have the Traffic type set to Pluggable Card in
DWDMChannels/MediaChannels tab. Make necessary changes in the exported Excel sheet before you import
it into Cisco ONP.

Before you begin

Log in to Cisco ONP Web Interface.

Design and Analyze Networks .
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. Import Network Using Excel Sheet

Step 1 Choose Export > Excel.

Design and Analyze Networks |

a) Choose the Network Type as Template or Current Network.

b) Choose the File Type as xIsx or xIsm (Macro Enabled)

The Macros Enabled Excel sheet automatically customizes the tabs on the Excel sheet based on the platform that you
choose. It also provides additional functionalities such as selection of fibers in the path selection, wavelength count

validation in case of regen selection.

¢) Click Download.

The template has the following mandatory tabs, and the respective fields to be filled in the Excel sheet.

Tabs

Description

Network

Label (name of the network), Platform (NCS2000(NON
SSON), NCS2000 (SSON), NCS1010, NCS 1001), Traffic
Type, NCS1010 Line Card, NCS1010 Band Type, Chassis
Type, and System Release

Sites

Site Label, Type, X coordinates, Y

coordinates,X Rearranged, Y Rearranged, Pre Equip
Degree, Grooming Site, CLLI code, and Site Address,
Degree (Scalable upto degree), NCS1010 Line Card,
NCS1010 Band Type, Chassis Type, and State.

Spans

Span label, A (Source site name), Z (Destination site name),
Kms (Distance), Loss, Type, A_Edge, Z Edge, AZ Loss,
ZA Loss, AZ Kms, ZA Kms, NCS1010 Band Type, and
State.

OTNDemands-4K-2K

Demand Label, A (Source), Z (Destination), Y (Tertiary
Source), B (Tertiary Destination), Type, Quantity,
Protection, Primary Path, Secondary Path, and State.

Note: Y and B can be used with Unprotected Disjoint
Service.

OTNDemands-4K-1K-2K

Demand Name, Source, Destination, Service Group, Type,
A/D Type, Protection, Primary Wavelength, Secondary
Wavelength, Primary Path, Secondary Path, First
Restoration path, Second Restoration Path, Primary ODU
Timeslot, Secondary ODU Timeslot, Primary Regen,
Secondary Regen, Trunk Mode, Baud Rate, and State.

MediaChannels Channel Label, Source, Destination, Primary Wavelength,
Secondary Wavelength, Protection, Traffic Type, Card
Type, A/D Type, Primary Path, Secondary Path, Primary
Regen, Secondary Regen, and State.

ServiceGroup ServiceGroup Name, Demand Types, 4K Exclusive LC

Usage, 4K Symmetric Aggregation, 1K Exclusive LC
Usage, 1K Symmetric AggregationChannel Label, and State.
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Cisco Transport Planner Network Import Support .

Tabs

Description

DWDMChannels

Primary Wavelength and Secondary Wavelength (Work
and Protect Wavelength for NCS2000 non-SSON waves),
Primary Path and Secondary Path (Work and Protect Path
for NCS2000 Wave/Media Channel and NCS1010 circuit),
A/D Type (Colored/Colorless/Contentionless), Traffic Type,
Primary Regen Secondary Regen State, Channel label, A,
Z, Wavelength, Protection, and Type.

Services-1010

Service Name, Source, Destination, Type, Protection,
Primary Wavelength, Primary Path, Primary Regen, Card
Type, Trunk Mode, A/D Type, and State.

Circuits

Circuit Label, Source, Destination, Primary Wavelength,
Protection, Traffic Type, Card Type, A/D Type, Primary
Path, Primary Regen, Band Type, and State.

Flex Optical Source

Flex Optical Source Name.

SRLG

SRLG Label, Spans, and State.

Step 2 Fill the network details in the template file or edit the current network file, and save the file.

Step 3 Choose Import > Excel, and select the Import Type.

» New—Choose this option if you want to create a new network using the design data available in the Excel sheet.

* Existing—Choose this option if you want to update an existing network with the data available in the Excel sheet.
Open the network before you import the Excel sheet. The network must be on Design mode, Upgrade mode, or

Release Upgrade mode.

You can view the data available in the Excel sheet before importing the network data. The View Data check box remains
checked by default. Uncheck it of you do not want to view the imported data.

Step 4 Browse, select the saved file, and click Import.

During the import for the Existing network, if the state is Locked, Cisco ONP does not consider the data, if the state is
Unlocked, Cisco ONP changes the existing parameter, provided the network is in upgrade mode, and if the state is New,
the parameters in the Excel is added as a new entry into the network.

During new network import, new network design is created irrespective of the State.

Note Ifthere are errors in the imported data, a pop-up error message is shown in case of new import, and the errors are
available under the Elements> M essages tabs in case of updating the existing network.

Cisco Transport Planner Network Import Support

You can import the networks that are created and analyzed from Cisco Transport Planner (CTP) to Cisco
ONP, to avoid recreating the networks that are already created in CTP. The CTP network files are in .mpz
format. You can, release upgrade, the imported networks.

Design and Analyze Networks .
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I import MPZ Design File

\)

Note » Network must be in design-analyzed or upgrade-analyzed mode.

* You cannot import networks which are earlier than Releasel1.0.

Supported Hardware
* Optical source files and transponders

See Supported Optical Sources, and Supported Cards and Pluggables.
+ Contentionless, colorless, and colored point-to-point demands
* Flex network

* Gain Equalizer

)

Note The Gain Equalizer node changes as a ROADM node when you unlock the site
after the release upgrade.

* ROADM-SMR-9 and SMR-20

+ All flex supported amplifiers, controller cards, and chassis types

Import MPZ Design File
Use this task to import .mpz file from CTP to Cisco ONP.

\}

Note Importing of mpz networks with P-Ring and A2A demands is not supported. Hence, we recommend you to
delete these demands in CTP, reanalyze the networks in CTP and import the mpz into Cisco ONP.

Before you begin

Log in to Cisco ONP Web Interface as a user with network creation permission.

Import the required optical source files and layout template using M anage > Optical Source and Manage >
Optical Source options. For more information, refer Manage Alien and Import Layout Template for NCS
2000 Network in to Cisco ONP Database.

Delete the parameters that are not supported by Cisco ONP from the .mpz file and then import the .mpz file

to Cisco ONP.

Step 1 Choose Import > MPZ.
The Import File (mpz) dialog box appears.

Step 2 Browse to the .mpz file stored in your local system.
Step 3 Choose 4K_1K_2K or 4K_2K from the Traffic Type drop-down list.
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Step 4

Step 5

Export the CPZ File [

If you had chosen an SSON MPZ file, you can view the Traffic Type drop-down list.
Click Import.
The .mpz file gets imported to Cisco ONP.

Note Ifyou view a blank screen when you click waves in the network tree, refresh the browser.

Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

Note * You cannot go back to design mode on the imported mpz network.

* The wave label of imported mpz network in Cisco ONP is the service name present in the CTP properties
window.

Export the CPZ File

Step 1

Step 2

Step 3

Step 4
Step 5

Cisco ONP stores the network design file as .cpz file in its database. You can export the design file into your
local system.

* The .cpz file of a network in the design mode includes design file, layout template, and optical source
details.

* The .cpz file of a network in the analyze mode includes a design file, analyze file, ANS file, per side
ANS file, BOM, error messages, trace files, layout template, mpz, and report.

* For the network in upgraded mode, you can export only the last child in the parent child hierarchy.

* You can export only one network at a time.

Before you begin

Log in to Cisco ONP Web Interface

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network that you want to export, from the list of networks.

The network opens.

Note If you view a blank screen when you open a network, refresh the browser, or log in to Cisco ONP again.

Choose Export > CPZ.
The Export .cpz file dialog box appears.
Rename the file if required.

Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of the
operation running in the background.

Design and Analyze Networks .
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Step 6 Click Export.
Step 7 Save the file in your local system.

Import CPZ File

You can import the cpz network design files that are exported from another Cisco ONP instance.

)

Note  You can import only the networks that are exported from the current release.

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Import > CPZ.
The Import .cpz file dialog box appears.
Step 2 Click Choosefile, and select a cpz network design file that you want to import into Cisco ONP, from your local system.

Step 3 Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of the
operation running in the background.

Step 4 Click Import.

If the names of the optical source and layout template files available in the Cisco ONP database and the imported network
file are the same, you are prompted to confirm whether you want to overwrite the existing file.

Note The error message " Network already existsin the system with another user. New network will be created”
is just an information. You do not need to perform any action. Cisco ONP automatically imports as a new network
specific to the user. There is no impact on the already existing network.

Step 5 Check the Overwrite Network check box, if you want to overwrite the existing file.

If you leave the check box unchecked, Cisco ONP saves the imported network as a new network.

Step 6 Choose the optical source files and layout template that you want to replace.

If you do not choose the optical source or the layout template file, the files will not be imported.

Step 7 Click Confirm.

The imported network is saved in the Cisco ONP database.
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Live Network Import

Table 8: Feature History

Feature Name Release Information Feature Description

Live Network Import Cisco ONP Release 4.1 This feature allows you to import
a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

The Live Network Import (LNI) feature allows you to perform a live import of network having NCS 1004,
NCS 2000, and NCS 4000 nodes into Cisco ONP. You must have Network Management role to perform the
LNI operation. After importing you can visualize the complete deployed network details in Cisco ONP. Map
shows the network topology, and you can view the node, fiber, OTN service, and media channel properties
in the Network Tree, and the Entity Editor.

Perform Live Network Import

Use this task to perform live import of a network:

Before you begin

¢ Perform LNI only when the network is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

* Configure all the mandatory parameters on the circuit.

» Make sure that the following Cisco IOS XR Software Maintenance Updates (SMUs) are loaded on the
NCS 4000 devices on top of Cisco IOS XR Release 6.5.28:

* ncsdk-6.5.28.CSCvu93045.tar
* ncs4k-sysadmin-6.5.28.CSCvt67465 tar
e ncs4k-6.5.28.CSCvv79518.tar

» Make sure that there is a provision for opening three TL1 sessions per NCS 2000 device for Live data
collection. NCS 2000 devices should not be overloaded with too many TL1 sessions.

» Make sure that the fibers are configured with the same channel numbers (Spectral Density, ex: 91.0/82.0)
on both source and destination ends.

* Check the card label set for the following NCS 2000 cards and update it if they are not aligned.

PID Card Label
NCS2K-16-AD-CCOFS AD-16-FS
NCS2K-20-SMRFS SMR20-FS-CV

Design and Analyze Networks .
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. Perform Live Network Import

Step 1

Step 2

Step 3
Step 4
Step 5

PID Card Label
NCS2K-20-SMRFS-L SMR20-FS
NCS2K-9-SMR17FS SMR9-17-FS
NCS2K-9-SMR24FS SMR9-24-FS
NCS2K-9-SMR34FS SMR9-34-FS
NCS2K-9-SMR34FS-L SMR9-34-FS
15454-M-RAMAN-COP= OPT-RAMP-COP
15454-M-RAMAN-CTP= OPT-RAMP-CTP
NCS2K-OPT-EDFA-35 OPT-EDFA-35

* You must install Microsoft Excel in the Client Machine from where the browser is launched to open
Cisco ONP application.

* Log in to Cisco ONP Web Interface

Choose Export > Download LNI Import Template, and download the template which is in the form of an Excel
sheet.

Fill the template with the details of all the nodes belonging to the network to be imported and save the file.
The following fields are mandatory:

* Node IP

» User Name

* Password
* Connectivity Type—TL1 for NCS 2000 nodes and NETCONF for NCS 1004 and NCS 4000 nodes
* Connectivity port—830 for NCS 4000 and NCS 2000 nodes

Note Enter a value in the range of 60—180 in the Connectivity Timeout field or leave the field empty.

Choose Import > Live Import.

Browse and choose the saved file.

If you want to clean the existing LNI database of the nodes and perform a fresh import, check the Fresh Import
(Cleanup LNI Database) check box.

Note We recommend fresh import of the live network.

Leave this check box unchecked, if you want to import the details of only few of the nodes which had issues during
the previous import.

Note LNI import is not user-specific. When you perform a fresh import, Cisco ONP overwrites all the LNI data that
are imported by the other users.

. Design and Analyze Networks


b-conp-24-3-1-config-guide_chapter1.pdf#nameddest=unique_12

| Design and Analyze Networks

Step 6
Step 7

Step 8

Step 9
Step 10

Step 11

Perform Live Network Import .

Click Import.
In the Device Onboarding dialog box, click OK.

Note If you try to import a network of unsupported version, the device collection does not happen, and an error
message "device collection failed" appears. See Supported Hardware and Software for LNI, on page 18.

Click Job Monitor, and click Check Progress for the IMPORT LIVE NETWORK task, to view the status of the
LNI operation in the L NI Progress dialog box. Click Refresh to see the updated status.

After LNI is completed, the job is removed from the Job M onitor page.
Click L ogsto view the list of events that are related to the LNI operation, as logs.
After the completion of the LNI operation, choose File> Open.

The format of the LNI imported network filename is LNI_<Date> <Time>.

Click the imported network name to view the network under the M ap tab and its corresponding network tree in the left
panel.

The aggregated node including NCS 1004, NCS 2000, and NCS 4000 is indicated in purple color, and the aggregated
node including NCS1004 and NCS 2000 is indicated in orange color in the network tree. You can view the tag |mported
from Network in the top-right corner.

Design and Analyze Networks .
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B Portsusedin LNI

Step 12

Note * Even If some errors occur during the LNI operation, the LNI operation is not canceled. In such case, when
you open the imported network, a warning message is displayed.

* You can view the errors under the Elements > M essages tab.
* Device collection failure is listed under critical messages.
* The reason for failure is listed under noncritical messages.
* If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS option.
You can edit this option during upgrade after unlocking the site, if necessary.
* Service path for the restored circuits is displayed as follows in the Cisco ONP UI:
* Primary Path: Working path before restoration
* Secondary path: Protected path

* Restoration path: Current work path after restoration

Note If the circuit is not in the restored state, the restoration path is not shown.

* SSON circuits carrying protected OTN services are merged as Client 1+1 protected Media Channel. Due
to this, you may see difference in total number of SSON circuits between the imported network in Cisco
ONP and the actual network.

« If LNI is not installed properly, you may encounter the errors such as LNI failure or LNI not able to purge
the data. In such cases, we recommend starting and stopping the LNI services in the server where Cisco
ONP and LNI are installed using the following commands:

* Stop the LNI services.
root:~/$SONP_HOME# cd LNI

root:~/SONP_HOME/LNI# bash ciscolniinstaller.sh -o stop -t update -m offlinemode

« Start the LNI services.

root:~/$SONP_HOME/LNI# bash ciscolniinstaller.sh -o start -t update -m offlinemode

Note  Wait for a minimum of five minutes after starting the services, for the LNI services to resume before triggering
a new live network import. You can

Click the BOM tab to view the BOM details of the network.
Note The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.

You can export the CPZ, import the CPZ, and share the imported network. You can check the properties of the network
using the Entity Editor.

Ports Used in LNI

LNI application uses the following ports. If any port is shut down due to any failure, then the service is restarted
by the Docker system.
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Ports Used in LNI [}

Port Service Usage
8761 Eureka Service Registration and discovery service, which holds the information about
all microservice applications
8080 API Gateway Receives all the incoming requests, and then delegates the requests to
internal microservices like LNI Broker
8080 Collector Service | Collects metrics and operation data from the devices
8080 Device Manager | Responsible for device onboarding process
8080 Inventory Service |Provides inventory data
9888 TL1 plug-in South bound interface plug-ins for TL1 protocol-based NCS 2000 devices
Service
8888 NCS 2K Inventory | Adapter module to transform NCS 2000 device response from collector
Adapter Service to Cisco ONP NCMS schema-based POJO
8888 NCS 4K Inventory | Adapter module to transform NCS 4000 device response from collector
Adapter Service to Cisco ONP NCMS schema-based POJO
8888 NCS 1K Inventory | Adapter module to transform NCS 1004 device response from collector
Adapter Service to Cisco ONP NCMS schema-based POJO
9976 NETCONF plug-in | South bound interface plug-ins for NETCONF based 1K/4K devices
Service
8888 LNI Broker Service | Provides interfaces for Cisco ONP BE service to trigger live network
import
8085 Topology Service |Provides network topology data
8090 Circuit Service Provides network circuit data
8024 NETCONF Common adapter for Topology and Circuit services
Adapter Service
8888 Model Aggregator | Aggregates inventory, topology, and circuit details under NCMS
Service schema-based networks
8092 TL1 Adapter Common adapter for Topology and Circuit Service
Service
5601 Kibana Data visualization and exploration tool that is used for log and time-series
analytics, application monitoring, and operational intelligence use cases
Note The default Edge browser on Windows OS is not supported for
viewing the Kibana logs. Cisco recommends using Firefox or
Chrome browser for viewing the Kibana logs.
2181 Zookeeper Keeps track of status of the Kafka cluster nodes, and also keeps track
of Kafka topics, partitions publish-subscribe messaging system that
enables inter service communication
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Port Service Usage

9092 Kafka Publish-subscribe messaging system that enables inter-service
communication

5432 Postgres Database to persist services data

Supported Hardware and Software for LNI

The following table describes the software versions and hardware requirements of the network imported

through LNI.

Table 9:

Property Values

Network

Network Type SSON

Platform ETSI

System Release NCS 2000: R11.1, and R11.1.1.2
NCS 1004: XR 7.0.1
NCS 4000: XR 6.5.2.8

Site/Node

Site Type 4K-1K-2K: ADD/DROP, 1K-2K;Regen,
2K:ROADM/OLA

ROADM SMR-20, SMR-9-17FS, SMR-9-34FS, SMR-9-24FS

Amplifier RAMAN-CTP, RAMAN-COP, EDFA35-24,
EDFA35-35

Degree Mesh Type DEG-5/UPG-4

Chassis Type 4K: NCS4016, 2K:NCS2006, 1K:NCS1004

Power Supply 4K-DC, 1K-DC, 2K-DC40

ECU ECU-S

Controller Card TNCS-2, TNCS-20

Channel Rule 82

Line Cards NCS1K4-1.2T-K9=, NCS4K-4H-OPW-QC2

Evolved Mesh ON and OFF

Node Protection 2K: Separated shelves, 4K: Single shelf
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Property Values

Mpol6Lc MPO-16LC Unit
Mpol6ToMpo08 MPO16TO2MPO8Cable
Cascaded SMR Yes

Enable NCS Yes

Use Payg No

Connection Verification Yes, No

MF Unit MF-6RU, MF6-10RU, or MF-1RU
Structure Line, Multidegree, Terminal
Scalable upto degree 4,8,12

Power redundancy Yes

IP Address IPv4

Fiber

OSC Frame Type Auto

DCN Extension Yes

ENE/GNE Yes

Length Yes

Loss Yes

Measurement Unit KM

Length based Loss No

Raman Amplified Yes

Fiber Type G652-SMF-28E

Connector Loss A Yes

Connector Loss B Yes

Cross OSC and Parallel OSC Yes

Media Channel

Traffic Type NCS1004 SP_16QAM 16QAM 300G 27%SDFEC 60GBd
Protection Unprotected, and 1+R

Path Actual Path
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Property Values

Regen Regen site

Multicarrier No

Contentionless Yes

Circuit State Restored, Unrestored

Service

Service Type 100GE, 10GE, STM-64

Protection 1+1, Unprotected, 1+R, 1+1+R, 1+1+R+R

Path Actual Path

Client Type (1K) OTU4

Interface Type (1K) BH

Trunk Mode (1K) 200G, 300G

Baud Rate (1K) 60 and 69 GBd

Client Pluggable ONS-QSFP28-LR4=,

QSFP-100G-SR4-S=,0NS-QSFP-4X10-MLR=

Limitations of LNI

The LNI feature has the following limitations:

* You cannot perform multiple LNI at the same time.

* Scheduled LNI is not supported.

» LNI does not support the following:
* Non-SSON Network import

* Non-Contentionless configuration import

* Circuit import with NCS 2000 Transponder or Muxponder cards

* Chassis position in layout may not be accurate in the live imported network.

Workaround: NCS 2000, NCS 1004, and NCS 4000 chassis are placed in separate racks for a better
view of the layout. You can edit the same after network upgrade and analysis.

* If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the

node position after importing.
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* Scalable up to degree parameter is not imported from the real device. Cisco ONP chooses the maximum
scalable up to degree based on the number of line sides and contentionless sides present on the node.

Wor karound: You can unlock node after upgrading and change the scalable up to degree. After unlocking
the site, use layout template to rearrange the layout.

* Cisco ONP imports the proto-PID, if any, present in inventory, and show as N/A PID in the Cisco ONP
BOM.

* Duplicate media channel label is not supported. If there are multiple media channels with same label
present in the network, only one media channel is imported and the rest of them are discarded.

* Fiber name, source, and destination names may not match between the first and the second import. Source
and destination site names may interchange for bidirectional fibers.

* If the regenerated demand is in restored state, the restored path is shown as working or protected path,
and the service protection is shown as 1+R in Cisco ONP. The restoration details will not be available.

» Service protection type is shown as 1+1+R or 1+1+R+R only if restoration path is available. Otherwise,
service protection type will be shown as 1+1.

* Preprovisioned cards are not listed in the Cisco ONP BOM, and they are populated after successful
upgrade and analysis of the LNI network. Make sure that the cards are equipped to retrieve the PID
details.

* Fibers may not be associated with correct optical subnet if the fibers are not configured with the same
channel number at both source and destination ends. Due to this amplifier output power may not be
within valid range. Hence, you either correct channel number at both source and destination nodes and
re-import the network, or associate the fiber with correct optical subnet after network upgrade in Cisco
ONP.

Create Optical Subnet for Non-SSON Networks

An optical subnet is a collection of spans with certain associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet that is associated to the network. At least one optical subnet
must exist for each network.

)

Note Check the Current Subnet check box in the properties window, to make the subnet you created as the current

subnet. You cannot uncheck the Current Subnet check box.

The following procedure creates an optical subnet for Non-SSON networks:

Before you begin

Log in to Cisco ONP Web Interface.
Step 1 Click Subnet in the network tree panel.

Step 2 Click the Ellipsisicon available in the right side of Optical Subnet.
Step 3 Click Create Optical Subnet.
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Step 4
Step 5

The Create Optical Subnet dialog box appears.
From the Cband Rulesdrop-down list, choose the C-band design rules for the new optical subnet that you want to create.
Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Note You can select new Cband rules from the Cband Rules drop-down list in the properties window.

Note You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

* Click the Ellipsisicon available in the right side of the required optical subnet and select Edit Fibers.
An Info dialog box appears displaying "Do you want to continue?.

* Click OK.
The Ul freezes. You can only select a fiber from the map.

* Select the required fiber and click the Done button appearing near the zoom icon.
The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber

is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Create Optical Subnet for SSON Networks

Step 1
Step 2
Step 3

Step 4

Step 5

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP Web Interface.

Click Subnet in the network tree panel.
Click the Ellipsisicon available in the right side of Optical Subnet.
Click Create Optical Subnet.

The Create Optical Subnet dialog box appears.

From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to create.

The Name, CBand Rules, and Maximum Number of Channelsthe you seenin the Create Optical Subnet dialog box,
are set based on the spectral density that you have selected.

Click Save.
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A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Note  You can select a new spectral density from the Spectral Density drop-down list in the properties window.

Note You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

* Click the Ellipsisicon available in the right side of the required optical subnet and select Edit Fibers.
An Info dialog box appears displaying "Do you want to continue?.

* Click OK.
The Ul freezes. You can only select a fiber from the map.

* Select the required fiber and click the Done button appearing near the zoom icon.
The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber

is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Create Optical Subnet for NCS 1010 Networks

Step 1
Step 2
Step 3

Step 4

\)

Note From Release 7.9.1, both C-Band and L-Band optical subnets appear by default for the NCS 1010 networks.

For C-Band and C+L Futuristic networks, the L-Band optical subnet contains no fiber links. To add fiber links
for the L-Band optical subnet, you must upgrade the existing network to a C+L-Band network or add an
L-Band edge for each C-Band edge.

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP Web Interface.

Click Subnet in the network tree panel.
Click the Ellipsisicon available in the right side of Optical Subnet.
Click Create Optical Subnet.

The Create Optical Subnet dialog box appears.

From the Band Type drop-down list, choose either C-Band or L-Band.
Note From R7.9.1, Band Type drop-down list is available when creating optical subnet for NCS 1010.
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Step 5

Step 6

From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to create.

From Release 5.2, the range of spectral density has increased (ranges from 30 to 100).

The Name, CBand Rulesor L Band Rules, and Maximum Number of Channels values that appear in the Create
Optical Subnet dialog box are set based on the spectral density that you have selected.

Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

Note

Note

You can select a new spectral density from the Spectral Density drop-down list in the properties window.

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

* Click the Ellipsisicon available in the right side of the required optical subnet and select Edit Fibers.
An Info dialog box appears displaying "Do you want to continue?.

* Click OK.
The Ul freezes. You can only select a fiber from the map.

* Select the required fiber and click the Done button appearing near the zoom icon.
The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber

is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Convert Non-SSON Network to SSON Network

Step 1

Step 2

Step 3
Step 4

The following procedure converts non-SSON networks to SSON networks:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click a non-SSON network that you want to convert to SSON.

The network opens. Ensure that the network is in Design Mode.

Choose Network > SSON Convert.
Click Ok.
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Step 5
Step 6
Step 7
Step 8
Step 9
Step 10

Convert NCS 2000 Network to NCS 1010 Network .

The error message, "Network cannot be converted to SSON due to following errors : [Network contains waves with
invalid traffic types: [100G-SD-FEC, 200G-SD-FEC]]" appears.

Choose Network > Entity Editor > Services.

Expand Waves and navigate to trail, and click a trail.

Choose any CFP-2optical source from the Src Card Type drop-down list.

Click Update.

Choose File> Save.

Choose Network > SSON Convert.

In the War ning pop-up window, choose 4K-2K or 4K-1K-2K from the Traffic Type drop-down list and click Ok.

4K-1K-2K is the defalut option. After the network is coverted, you cannot change the site type from 4K-2K to 4K-1K-2K
or vice versa.

* Select SSON optical source from the Traffic Type drop-down list in the properties window.
* You cannot convert a non-SSON network with Traffic Sites to SSON.

* To convert a non-SSON network to SSON network in Analyze mode, upgrade or release upgrade the analyzed
network. In the Upgrade mode, or Release Upgrade mode network, unlock all the channels, and force CFP-2
optical source.

Convert NCS 2000 Network to NCS 1010 Network

Step 1

Step 2

Use the following task to convert an NCS 2000 network (both SSON and non-SSON) into to NCS 1010
network:

Table 10: Feature History

Feature Name Release Information |Feature Description

Convert NCS 2000 Cisco ONP Release | The newly introduced NCS 1010 Convert option under

Network to NCS 1010 5.1 the Networ k menu enables you to directly convert an

Network existing NCS 2000 network into an NCS 1010 network.
This conversion eliminates the need to build an NCS
1010 network from scratch.

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click an NCS 2000 network (non-SSON or SSON) that you want to convert to NCS 1010 network.

The network opens. Ensure that the network is in Design M ode, Upgrade M ode or Release Upgrade M ode.
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Step 3 Choose Network > NCS 1010 Convert.
Step 4 Click Ok.

The network does not get converted and shows an error message, when"

* The network contains traffic sites.

* The fiber type is LS or TWClassic.

* The network contains OTN services.

* The traffic Type property is set to anything other than Optical Source or Pluggable Card.
* If the Traffic Type is 100G-SD-FEC or 200G-SD-FEC in non-SSON networks.

Step 5 Choose File> Save.
The following parameters get automatically updated after the conversion:

* Contentionless sides are deleted and contentionless demands are automatically changed as colorless.

* Protected channels are converted to two unprotected channels. The path, wavelength, regen sites and cards that are
configured are retained.

Share a Network

Use these steps to share a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks.

The map of the selected network opens.

Step 3 Choose File> Share.
Step 4 Select one or more users or user groups from the Share Network dialog box.
Step 5 Click Share.

You can share the network with selected users or user groups in read-only mode.

Access a Shared Network

Use these steps to access a network shared by another user:
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Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File > Open Shared Network.
The Select Network To Open dialog box appears with a list of networks that are shared by other users.

Step 2 Click a network name from the list.

The shared network opens in read-only mode.

Step 3 Choose File > Save As.
Step 4 Enter the name in the Give a network name dialog box, and click Save.

A copy of the shared network is saved.

Note  You can work on this copy of network, depending on the privileges of your user role. For example, if your user
role is Designer, you can change the design of the saved copy of the shared network, but you cannot analyze the
shared network.

Step 5 (Optional) Share the updated network with other users.

Unshare a Network

Use these steps to unshare a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click a network from the list of networks.

The network opens.

Step 3 Choose File> Share.
Step 4 In the Share Network dialog box, remove the name of one or more users or user groups from the list.
Step 5 Click Share.

The shared network is no longer available to the users or user groups that are removed.
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Analyze the Network

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Table 11: Feature History

Feature Name Release Information Description
Detailed Tooltip for Sites on the | Cisco ONP Release 5.1 The See M ore Details option has
Map View been introduced in the tooltip

displayed on hovering over Sites
on the Map view of an analyzed
network. This option shows the
Amplifier data and PSD (Power
Spectral Density) profile graph. The
See More Details option avoids
navigating to the Entity Editor to
view these details.

The Analyze tool allows you to analyze the network after design completion.

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click a network that you want to analyze, from the list of networks.

The network opens.

Choose Network > Analyze.
The Cisco ONP analysis progress indicator indicates the analysis status.

If there is any failure in the analysis stage, a dialog box appears with the message, “Analysis Failed.”

Choose the Elements> M essages tab to see the list of error details in the analyzed network..

By default, it shows only the key messages when the Critical Only toggle button is enabled. If you want to view the
entire network message, disable the Critical Only toggle button.

Note

If you find an error message under the M essages tab, resolve the error and analyze the network again. Repeat this step
until all errors are resolved.

Note The error message "Unexpected Situation 999" may occur when the optical simulation becomes inconsistent due
to incorrect values of properties entered or modified while designing the network. Call Cisco TAC to know the
exact cause of the error and modify the suggested property value for the successful analysis of the network.

(Optional) After the successful analysis of the network, to view the details such as Amplifier Data and PSD Profile
graph for a site, hover the mouse over a site and click See More Details.
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Bottom-Up Flow .

The amplifier data includes output power, EOL gain, attenuator in, attenuator out, and Raman gain. The attenuator details
are not displayed for the NCS 1010 site. The PSD profile graph is displayed only for the NCS 1010 site.

Bottom-Up Flow

Bottom-up support enables step-by-step creation of a network. Adding all the services and waves on day 0
itself is not mandatory to analyze the network and view reports. Bottom-up flow enables you to build a network
over a period.

Day 0: Create a network with only the topology added. Add all sites and add fibers between them. Analyze
the network and view the reports without adding any services or waves.

Day 1: Add waves between the sites that are added on Day 0 and newly added sites and fibers. Analyze the
network and view the reports.

Day 2: Add services and tag waves that are created on Day 1 and newly added sites and fibers. Analyze the
network and view the reports.

Y

Note

After you have created the topology with sites and fibers added, you can add either a service or a wave. You
need not follow any specific order.

Bottom-up flow is applicable only for Non-SSON networks. In order to achieve this, you must set A2A mode
as A2A fast in network properties. You can also set the A2A channel type as contentionless, colorless, and
colored.

Idle Timeout in the Analyze Mode

If you keep the browser idle for more than 15 minutes, you are logged out of Cisco ONP. The default timeout
is set to 15 minutes. The System Admin can disable this feature by changing the enabled option in the
configuration file on the server to false. You can change the default time of 15 minutes by editing the duration
option in the configuration file.

During a long network analyze cycle, you get logged out due to idle timeout, and the network analysis runs
in the background. When you log back, the same network opens in one of the following states:

« If the analysis is still on, the analysis progress bar is shown, and you cannot perform any other action.
« If the analysis is complete, the network opens in the Analyze mode.

» If the analysis has failed, the network opens in the design mode, and you can view the reason for failure
on the Elements > M essages page.

The session time out does not redirect you to the login page always; so, reload or enter the URL again.
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Upgrade the Analyzed Network

Step 1

Step 2

Step 3
Step 4

Step 5

Step 6

Table 12: Feature History

Feature Name Release Information Description
NCS 1010 Network Upgrade Cisco ONP Release 5.0 After a network is analyzed, all the
Flexibility network elements get locked. With

this feature, you can selectively
unlock certain network elements to
upgrade the network further. This
helps in preventing accidental
updates to the part of the network
that does not need any
modification.

Cisco ONP allows you to upgrade an existing network that is in analyzed mode. You can modify certain
properties of a network element in the network while retaining the existing network layout and design in the
locked state. Upgrade is supported for NCS2K, NCS4K-2K, NCS4K-1K-2K and NCS1010 networks.

Use these steps to upgrade your network:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the analyzed network that you want to upgrade.

The network opens.

Choose Network > Upgrade.
Click Yesin the Warning dialog box.

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), media channel (for SSON), and circuits (for NCS 1010) are locked.

Click the Ellipsisicon available in the right side of the network element that you plan to modify from the network tree
panel, and choose Unlock. You can unlock individual element and one at a time for multiple elements until the lower
level in the network tree hierarchy.

For example, you can hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers
level.

If you want to change only the add/drop between MD-32-ODD/Even or BRK 24/16/8 in the NCS 1010 network, you
can unlock the add/drop without unlocking the network elements that are higher in the hierarchy.

You can make the following modifications according to your requirement:
a) Edit the properties of network elements.
b) Delete the network elements from the network.
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Step 7
Step 8

Step 9

Upgrade LNI Network .

¢) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.
The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

Note You can insert a node in the upgrade mode only for the unlocked fiber. Therefore unlock the fibers that are
connected to the node and add nodes to the network.

Choose File> Save.
Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network that has where layout template is applied, the template gets
updated with the newly added service or fiber. You can export this template, make changes and reapply it to another
network.

Choose Network > Design to further upgrade the newly upgraded network design.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Upgrade LNI Network

Step 1

Step 2

Table 13: Feature History

Feature Name Release Information Feature Description

Upgrade LNI Network Cisco ONP Release 4.1 This feature allows you to upgrade
and modify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

The Upgrade feature can be used to correct LNI errors, modify the network, reanalyze the network and view
updated BOM, Layout, Connections, and Optical Results.

Use these steps to upgrade the LNI network:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click a network imported through LNI that you want to upgrade.
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. Upgrade LNI Network

Step 3
Step 4

Step 5

Step 6

Step 7

Step 8

Step 9
Step 10

Step 11
Step 12

Step 13

The network opens.

Choose Network > Upgrade.
Click Yes.

The message “Network Upgraded Successfully” appears. After upgrading the network, the network goes into upgrade
mode, and network elements such as Sites, Fiber, OTN Services and Media Channels are locked.

You can modify certain properties of the network element, while retaining the existing network layout and design
locked.

Click the Ellipsisicon available in the right side of the network element that you plan to modify from the network tree
panel, and choose Unlock. You can unlock individual element and multiple elements until the lower level in the network
tree hierarchy.

For example, you can unlock node level, side level, side add/drop card level, and side amplifier level.

You can make the following modifications according to your requirement:

a) Edit the properties of network elements.

b) Delete the network elements from the network.

¢) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

Note » Unlocking a media channel has few constraints. See Media Channel Unlocking Scenarios, on page 33.

* Cisco ONP automatically sets the scalable up to degree value based on certain design rules, as this value
is not present in the network that is imported through LNI. Hence, we recommend you to check and update
the actual scalable up to degree value, if necessary.

Choose File> Save.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Choose Network > Analyze.

Note Analysis is successful only if a consistent and valid network is imported from LNI.

If the analysis fails, go to Elements > M essages tab and check for the failure reason.

If any validation error is thrown from any component, resolve the issue by manually changing the network or by
reimporting the LNI networks after correcting some configuration on the live network. See Possible Error Scenarios
and the Workarounds, on page 34.

Re-Analyze the network.

Click the L ayout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004
platforms. See

Click the BOM tab, and the Results tab to view the BOM and optical results.
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Note a. Ifthe LNI inventory has any unconnected cards, that will be removed from the Cisco ONP reports after
upgrading and analyzing the LNI network.

b. The following PIDs are added in the Cisco ONP BOM after upgrading and analyzing the LNI network.
These PIDs are not part of the LNI network BOM.

* Pre-provisioned PIDs
* Release software PIDs

* Optical cables—Cables used for Internal Patch-cord Connection (IPC) is not imported in LNI as this
data cannot be retrieved from device

* Attenuators

* SMR port license PIDs—Only SMR card PID is imported as part of LNI. If a licensed PID is retrieved,
corresponding port licenses are added after upgrading and analyzing the LNI network, based on the
number of ports used.

» USB cables—Added if preprovisioned passive cards are present.

* Blank cards—Blank cards are not imported. They are added in Cisco ONP after upgrading and analyzing
the LNI network.

Media Channel Unlocking Scenarios

The following table explains the various media channel conditions and the unlocking possibilities.

Table 14:

Conditions Unlocking Possibilities

Channel has OTN services going over it. For 4K-2K, | Cisco ONP throws an error indicating that there are
the service is directly mapped to the channel, and for | OTN services associated with the media channel. You
4K-1K-2K, the service is mapped via OTU4 trail. | can neither update nor delete the channel. To unlock
and delete the media channel, unlock associated OTN
services first and then unlock the media channel.

Channel does not have OTN services going over it. | Cisco ONP allows you to unlock the channel but does
For example, in case of 4K-1K-2K, the media channel | not automatically clear the properties of the channel
carries empty OTU4s. or its child entities such as Trail and Section,
irrespective of whether the properties or user-defined
or auto-assigned. Also, the channel is not unlocked
automatically, if it has any associated OTU4.

After unlocking the channel, you can delete the
channel, but cannot update the properties of the
channel or its child entities. (When the properties of
the media channel or its child entities are
auto-assigned, only wavelength is cleared and set to
Auto, and all other properties are not cleared.)
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Conditions

Unlocking Possibilities

Channel has neither OTN services nor OTU4(s) going
over it. In case of 4K-1K-2K networks, Media
Channel does not carry even empty OTUs.

Cisco ONP allows you to unlock the channel and
automatically clears auto-assigned properties. After
unlocking you can perform the following:

* Update various properties of the channel and its
child entities.

« Delete the channel.

Possible Error Scenarios and the Workarounds

Following table describes the workarounds for the errors that are shown under the Elements> M essages tab.

Table 15: Error Scenarios and the Workarounds

Error Message

Workarounds

Device Authentication failure

Check the username and password of the device,
which is given in LNI input Excel and retry LNI
import with valid device credentials.

Device collection failed or Device not reachable.

Check for any connectivity issue in the setup, fix it
and retry LNI import.

In Sited4.A, output power setting is not supported by
the amplifier.

Unlock C-Band amplifiers for side A inside Site4 in
the Network tree and force the valid output power. If
not sure, set it to Auto and analyze. Cisco ONP
chooses the best value based on the configuration.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

For protected OTN service or SSON service, a
minimum of two contentionless sides must be present
on the source and destination sites. Check and add
contentionless sides on the target service source and
destination site and analyze.

* Demand OTU3 has unrecognized type [OTU3]

* ServiceGroup does not support the demandType
OTU3 for OTU3

Only 100GE, 10GE, and STM-64 service rates are
supported. If any other service rate is present in the
network, unlock the specific service, change it to one
of the supported service types and update the ODU
time slot accordingly and analyze.

Primary OTN Demand [100GE_Flex] has invalid
Timeslot ranges. Allowed ranges are [1-80]

100GE service type must have ODU time slot in the
range of 1-80. If any other value is set, update the
correct value or leave it blank so that Cisco ONP can
set it to the correct value.

Cannot complete mesh connections at Site3.

Unlock the site and reanalyze.

No OTN demand found for NCS4K trunk port -
NCS4016-B - OTU40/8/0/1.

No action required. This is an information message
to the user.
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Error Message

Workarounds

Fiber between Nodel.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
correct connector loss value to be greater than zero.
The typical value is 0.2.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Unlock the corresponding fiber couple and update the
correct Tot SOL Loss w/o Connectors. The value
should be greater than zero.

Span Fiber-2 is forced as Raman but no traffic is
present.

Remove Raman forcing on the fiber, or check and
force the path for any service so that it goes through
Raman enabled span.

Couple Fiber-2 has Raman enabled on the duct but
corresponding Raman Forcing is missing.

Force RAMAN-CTP or COP on the Fiber-2
connecting node interface or remove RAMAN forcing
on the Fiber-2

\)

Note

No specific action is required for noncritical messages. These are just information messages to the user.

Table 16: Feature History

Upgrade the Software Release of a Network

Feature Name

Release Information

Feature Description

Release Upgrade

Cisco ONP Release 4.1

This feature allows you to choose
the NCS 2000 system release to the
desired release (11.1.0, 12.0.1, or
12.1.0), while performing the
release upgrade of CTP network,
Cisco ONP network, network
imported through Excel, and LNI
network.

You can upgrade the software version of a network that is imported from CTP, the network created in Cisco
ONP, LNI Network, and Excel imported network to any desired release. Release upgrade is supported for
both SSON and non-SSON networks having NCS 2000 nodes with ROADM, OLA, Traffic, or the Passthrough

functionality.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

)

Note

NCS 2000 supports SVO from the Release 12.1.0.

The following table lists the releases to which the existing system release can be upgraded, for each type of

network..
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Network Upgrade Release

CTP network (.mpz) * From 11.0.0to 11.1.0, 12.1.0, 12.2.0, and 12.3.1
* From 11.1.0 to 12.1.0, 12.2.0, and 12.3.1

Cisco ONP network * From 11.0.0to 11.1.0, 12.1.0, 12.2.0, and 12.3.1

e From 11.1.0 to 12.1.0, 12.2.0, and 12.3.1
e From 12.1.0 to 12.2.0, and 12.3.1

Excel imported network

* From 11.0.0to0 11.1.0, 12.1.0, 12.2.0, and 12.3.1

LNI network

11.1.0 to 12.0.1, 12.1.0, and 12.3.1
11.1.0 to 12.1.0, 12.2.0, and 12.3.1

Note You cannot directly release upgrade an LNI
network. Perform the following:

* Upgrade the LNI network. see Upgrade
LNI Network, on page 31)

* Analyze the network. (see Analyze the
Network, on page 28

* Release upgrade the analyzed LNI
network.

NCS 1010 Network

7.7.1t079.1,7.10.1, 7.11.1, 24.31
7.9.1t07.10.1,7.11.1, 24.31
7.10.1to0 7.11.1, 24.31

7.11.1 to 24.31

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to perform system release upgrade.

The network opens.

Step 3 Choose Network > Release Upgrade.

Step 4 Choose the System Release of NCS 2000, to which you want to upgrade, from the drop-down list.

Step 5 Click Submit.

The upgraded network is saved as a child network.
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Plan Mode

Table 17: Feature History

Plan Mode .

The network elements are locked in the network tree after the release upgrade. You can unlock and modify the elements.

If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by the
PMD value when you edit the fiber properties.

Feature Name

Release Information

Feature Description

What-if Analysis for OTN Services

Cisco ONP Release 4.1

This feature extends the current
implementation of What-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported for SSON
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Plan mode enables you to perform what-if analysis on the existing network resources, such as failing and
restoring the fiber, OTN services, and site. This mode is applicable only for PLANNER and ADMIN roles.
This mode simulates the actual network behavior during failure and determines whether a service can be
rerouted; however, this mode does not suggest how to turn-up new wave lengths, insert new nodes, cards, or

ports, and so on.

The network can enter the Plan mode only from the Analyze mode. The what-if analysis can be done on the
NCS 2000 aggregated node (ROADM, OLA, Passthrough), Traffic node (1K-2K, 4K-2K and 4K-1K-2K),
the node created in Cisco ONP, CTP imported (mpz), and LNI imported networks.

Enter the Plan Mode

Step 1
Step 2

The following procedure shows how to enter the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface as a user with admin or planner role.

Open the network in Analyze mode.
Choose Network > Enter Plan Mode.

Switching to Plan Mode progress bar appears. The message, Entered Plan Mode successfully appears in the Success
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[ Exitthe Plan Mode

Exit the Plan Mode

The following procedure shows how to exit the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface as a user with admin or planner role.

Step 1 Open the network in the Analyze mode.
Step 2 Choose Network > Exit Plan Mode.

Fail a Fiber

The following procedure shows how to fail a fiber or a list of fibers in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Expand the Fiber s option in the network tree panel.

Step 2 Click the Ellipsisicon available in the right side of the fiber, and click Fail. You can choose multiple fibers to fail by
checking the check boxes next to the fibers.

All media channels or waves, OTN services, and demands that pass through the failed fiber fail. You can see the failed
media channels from the Map option or from the network tree.

Note * You can also fail a fiber or undo a fiber failure from Map.

* You can view the unrestored channel details in the failure report and the reason for restoration failure under
Elements> M essages tab.

» Failed channels are indicated with a red cross symbol, impacted fibers are marked with yellow cross symbol,
and the restored channels with a green tick symbol.

Undo Fiber Failure

The following procedure shows how to undo fiber failure in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 In the network tree panel, click Fiber.
Step 2 Click the Ellipsisicon available in the right side of the failed fiber, and click Undo Fail.
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Create a Failure Set .

Create a Failure Set

Step 1
Step 2

Step 3
Step 4
Step 5
Step 6
Step 7

You can click any set of fibers or sites, click the Ellipsisicon available in the right side, and fail them. The
failed fibers or sites are marked with a red cross mark beside them. You can also choose multiple fibers or
sites.

* Cisco ONP saves the user created failure sets.

* You can save multiple failure sets under a given failure group.

The following procedure shows how to create a failure set:

Before you begin

Log in to Cisco ONP Web Interface.

Click the Ellipsisicon available in the right side of the Failure Groups option in the network tree panel.
Click Add Failure Group.

A Failure group gets created.

Choose the Fibersor Sitesto fail by checking the check boxes next to the them.

Click the Ellipsisicon available in the right side of the chosen Fibersor Sitesand click Fail.
Select the network name, and right-click.

Click Add Failure Set.
Select the Failure Group to which the failed fibers or sites must be added.

The Failure Set gets created under the Failure Group. The failed fibers or sites are added to the created Failure Set.

Note If networks have dark fibers (which does not carry any traffic), that path is not considered for restoration.

Fail a Site

Step 1
Step 2

The following procedure shows how to fail a site or a list of sites in the Plan mode.

Before you begin

Log in to Cisco ONP Web Interface.

Expand the Sites option in the network tree panel.

Click the Ellipsisicon available in the right side of the site, and click Fail. You can choose multiple sites to fail by
checking the check boxes next to the sites.

You can also fail a site from the network map view.
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Undo Site Failure

The following procedure shows how to undo the site failure in the Plan mode:

Step 1
Step 2

Before you begin

Design and Analyze Networks |

Log in to Cisco ONP Web Interface.

In the network tree panel, click Site.
Click the Ellipsisicon available in the right side of the failed site, and click Undo Fail.

You can also undo the site failure from the network map view.

Failure Report

The failure report shows the following parameters:

Report Description

Failed Fibers Shows the failed fibers in the network.

Failed Sites Shows the failed sites in the network.

Impacted Fibers Shows the fibers that are impacted due to the site failure.

Total Channels

Shows the total number of media channels in the network.

Failed Channels

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Restored Channels

Shows the total number of media channels that are restored from the failure state.

Unrestored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Fiber HotZones

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

 Fiber: Shows the fibers that are listed under fiber hot zones.

* Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

« Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Total Services

Shows the total number of services going through the fiber that was failed.

Failed Services

Shows the number of failed services going through the fiber that was failed.

Restored Services

Shows the number of restored services going through the fiber that was restored.
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Report Description

Unrestored Services Shows the number of unrestored services going through the fiber that was restored.

Export Failure Report

The following procedure shows how to export the failure report.

Before you begin

Log in to Cisco ONP Web Interface.

Choose Export > Failure Report to export the failure report as an Excel sheet.

You can save the Excel sheet.

Export Failure Report from Map

The following procedure shows how to export the failure report from the map:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Click Failure Report under Map.
Step 2 Click Export to export the failure report as an Excel sheet. You can save the Excel sheet.

Restore Failed Channels

The following procedure shows how to restore the failed fibers:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Network > Enter Plan Mode.
Step 2 Click Restore.

The message, "Restoration is in progress" appears.

Step 3 Click Failure Report to view the number of media channels that are restored or unrestored.
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Note Restored channels are indicated with a green color tick mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber also get restored. The Path
Computation Element (PCE) supports the restoration of the OTN services based on the optical feasibility and

OTN constraints.

Automatic Suggestion for Regeneration Sites in Plan Mode

Table 18: Feature History

Feature Name

Release Information

Feature Description

Automatic Suggestion for
Regeneration Sites

Cisco ONP Release 5.0

Cisco ONP displays feasibility
report in the Plan mode. This report
automatically suggests regeneration
sites for the channels with high and
marginal risk of failure. You can
incorporate these regeneration sites
in the optical network to make the
channel optically feasible. This
feature avoids multiple iterations
required to manually create the
regeneration sites and test the
optical feasibility of large networks.

Cisco ONP submits the networks that are not optically feasible (the channels that have marginal and high risk
of failure assessed based on the EOL and SOL indicated as red, and orange in the Optical Resultspage). PCE
runs a regen suggestion algorithm and suggests the regeneration sites. When you enter the plan mode, Cisco
ONP displays regen sites in the Feasibility Report displayed at the bottom of the map. You can apply the

suggested regen sites to make the network optically feasible.

Auto regen site suggestion is supported for both SSON and non-SSON network that has contentionless channels

or waves between NCS2K (ROADM) or 4K-1K-2K(TRAFFIC) sites.

If the channels have already regen forced, the regen suggestion is shown at sections level.

The Feasibility Report table includes the following fields:

Table 19: Feasibility Report

Field

Description

Channel Name

Displays the list of channels (trail and sections) that
are not optically feasible.

Alarm

Displays the color of alarm (red, orange, or yellow)

Paths

map.

Displays the actual path of the channel as hyperlink.
If you click the link, the path is highlighted in the

. Design and Analyze Networks



| Design and Analyze Networks

Apply Suggested Regen .

Field Description

Suggested Regens Displays the intermediate sites that can be used as
regen sites so that the channel becomes optically
feasible.

You can also export the report by clicking Export.
The Suggested Regen field is displayed as NA for the following reasons:

* The channels with yellow alarms, as the loss is negligible.

» When the loss is high and the number of available intermediate sites are not enough to compensate the
overall loss.

* The intermediate sites where no contentionless sides are added will not be considered for regen sites.

Apply Suggested Regen

Step 1
Step 2

Step 3
Step 4
Step 5
Step 6

Step 7

Use this task to apply the suggested regeneration sites to make the network optically feasible.

Before you begin

Log in to Cisco ONP Web Interface as a user with admin or planner role.

Enter the Plan Mode, on page 37.
Choose Network > Open Feasibility Report.

The Feasibility Report is displayed at the bottom of the map.
Select the channels for which regeneration has to be applied and click Apply.
Click Ok in the Suggested Regen Applied dialog box.

Click Exit Plan Mode.
Click Yesin the Warning dialog box.

The network gets auto upgraded and saved as a new network. The channels with regens applied are unlocked with the
Regen Sites property auto updated and noneditable.

Analyze the network.

In the Optical Resultspage, the SOL, and EOL fields become green, and the channels are not displayed in the feasibility
report again when you switch to the plan mode.
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Line Rate Tuner Mode

Enter the Line Rate Tuner Mode

Step 1
Step 2

Create a Custom Optical Source

Step 1
Step 2

Step 3

Step 4

Table 20: Feature History
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Feature Name

Release Information

Feature Description

Automated Selection of
Optimal Wavelength Bitrate:
Flexible Modelling

Cisco ONP Release
5.2

You can now automate the calculation of optical
sources for your networks using the new Line Rate
Tuner Mode. This mode reduces human errors while
finding the correct optical source for your network
from a set of network resources.

Line Rate Tuner Mode significantly reduces turnaround time, avoiding manual calculation of different
possibilities of network resources.

Use these steps to enter the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP Web Interface

Open the network in Analyze mode.

Choose Network > Enter Line Rate Tuner Mode.

Switching to line rate tuner mode.. progress bar appears.

The network opens in the Line Rate Tuner Mode.

Use this procedure to create a custom optical source.

Before you begin

Log in to Cisco ONP Web Interface

Open the network in Line Rate Tuner mode.

Click Open Tuner Input.

Input Tuner pane appears below the map area.

In the network tree, select the section of the media channel that you want to add the tuner input.

In Select Input Parameters, the selected section appears with default parameter values.

Modify the following Input Parameters as required.
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Property Platform Description
Optical Family |NCS 2000 Choose the optical family. Based on the analyzed network, Cisco ONP provides
SSON the options. Based on the optical family chosen, the remaining parameters provide
NCS 1010 related options.
Optical Source |NCS 2000 Choose the optical source. Based on the optical sources that are already imported,
SSON Cisco ONP provides the list of optical sources.
NCS 1010
Data Rate NCS 2000 Choose the data rate. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the channel capacity for the new section.
NCS 1010
Bit Rate Range |NCS 2000 Choose the bit data rate. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the speed of data transfer in the new section.
NCS 1010
Baud Rate Range | NCS 2000 Choose the baud rate range. Based on the optical family chosen, Cisco ONP provides
SSON options to choose the minimum signal width for new each channel.
NCS 1010
FEC Type NCS 2000 Choose the FEC type. Based on the optical family chosen, Cisco ONP provides the
SSON list of supported FEC types
NCS 1010
Result Type NCS 2000 Choose the Result Type. The available options are:
SSON * Best OSNR—Provides results based on maximum OSNR margin.
NCS 1010 . . . . .
* Maximum Capacity—Provides results based on the maximum capacity of the
channels.
Optical NCS 2000 Choose optical feasibility for the new section. The available options are:
Feasibility SSON
* Green
NCS 1010
* Yellow
* Orange
* Red
Each color represents the severity of alarms that may arise in the new section.
Sigma Number |NCS 2000 Choose the sigma number from 0 to 3. The sigma number calculates the OSNR
SSON margin.
NCS 1010
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Step 5
Step 6

Step 7

Step 8
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NCS 1010

Property Platform Description
Number of NCS 2000 Choose the number of optical source results that you want for the new section.
results SSON

The default value is set as 5. However, you can choose up to 15 results.

(Optional) Click Reset to reset the modified parameters to default values.
Click Add.

In Select Section, Tuner Input is added successfully. Please refer the below table for the added inputs message appears.

The Select Section pane provides the details of the modified section.

Table 21: Select Section Parameters

Section Parameters Description

Section Label Name of the modified section.

Src Site Site name for the optical channel source.

Dst Site Site name for the optical channel destination.
Path Fiber paths in the section.

Actions Icons to edit or delete the modified section.

(Optional) To modify or delete the section, choose the following icons as required:

Icon Actions
Pencil Edit Input—Modifies the section
Trash Bin Delete Input—Deletes the section

To edit the modified section:

a. Click the pencil icon.
b. Modify the input parameters as required.

c. Click Updateto update the edited section parameters.

To delete the modified section:
a. Click the trash bin icon.
A confirmation message appears.

b. Click Yes.

Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.
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Step 9 In Tuner Result, click Export to export the results as an Excel sheet.

Start the New Tuner Analysis

Use these steps to start a fresh tuner analysis for the new section.

Before you begin

Log in to Cisco ONP Web Interface

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Start New.

The Start New Tuner dialog box appears asking for a confirmation.

Step 3 (Optional) Check the Retain the tuner inputs check box to retain the previous input values.
Step 4 Click Yes.

The message Sarted new tuner successfully appears.

Step 5 Modify the input parameters of the new section.
Step 6 Click Update.
Step 7 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

Open the Custom Optical Source Tuner Result

Use these steps to open the tuner results for the customized optical sources.

Before you begin

Log in to Cisco ONP Web Interface

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears.

Add the Custom Optical Source to the Network

Use these steps to add the custom optical sources to the network.
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Before you begin

Log in to Cisco ONP Web Interface

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears displaying the new sections and their demand channels.
The result provides the following action icons to add the optical sources to the network.

» Add Demand to Networ k—Click this icon to add the demand to the network.

» Download Optical Source—Click this icon to download the optical sources as an Excel sheet to review offline.

Step 3 To add the optical source to the network, perform one of the following actions:
To add manually:

Note For some custom optical source results, the download icon becomes disabled. In that case, go to Manage> Optical
Sour ce to download the optical result as explained in Download Optical Sources.

a. Click the download icon.

The Downloading Optical Source message appears. The Excel sheet contains data in Cisco ONP format.
b. Open the Excel sheet to review the data.

C. Import optical sources as explained in Import Optical Sources.

To add automatically:
a. Click the add icon.

The No. of demands pop-up appears asking for the number of demands to add to the network.
b. Enter the demands number and click Add.

The Demand is added successfully message appears.

The new demand appears in the network tree. Along with the demand, the Cisco ONP adds the required optical source
also automatically to the server.

Exit the Line Rate Tuner Mode

Use these steps to exit the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP Web Interface

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Choose Network > Exit Line Rate Tuner Mode.
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Step 3

Import Optical Sources .

The Exiting Tuner dialog box appears.

Choose the following action as required.

Button Actions

Previous State Moves the network to previous state with applied changes.
Upgrade Moves the network to Upgrade mode with applied changes.
Cancel Cancels the operation.

The network exits the Line Rate Tuner mode.

Import Optical Sources

Step 1

Table 22: Feature History

Feature Name Release Information Feature Description
Create Optical Source using Excel | Cisco ONP Release 5.0 You can create an optical source by
Sheet defining the details of interfaces

and the corresponding optical
classes in an Excel template. This
feature provides you with the
flexibility to create any required
optical source based on existing or
new traffic resources.

Optical Source Wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Use this procedure to import an optical source:

Before you begin
Log in to Cisco ONP Web Interface.

If you want to import the optical sources from an Excel sheet, download the template by choosing Export >
Optical Source Template. Fill the necessary details in the I nterfaces and Optical Classes sheets of the
downloaded template and save the file. See Optical Parameters Available in the Excel Sheet for Optical
Sources Creation, on page 50.

The fields in the columns D, E, and F that are not mandatory are hidden by default in the Interfaces sheet of
the template. You can expand the columns and fill the details.

Choose Manage > Optical Source.

The Manage Optical Source dialog box appears. The default optical sources available in the server are:
* OpticalSources NCS2K 400GXP-LC NCS4K-4H-OPW-QC2
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b-conp-24-3-1-config-guide_chapter1.pdf#nameddest=unique_12

Design and Analyze Networks |
. Optical Parameters Available in the Excel Sheet for Optical Sources Creation

* NCS1004 OpticalSources V3
* ONS-CFP2D-400G-C-OpticalSources-V2.mxd
* QDD-400G-ZRP-S-OpticalSources-V2.mxd

Note By default, all existing optical source files are loaded in the server.

Step 2 To import optical source as .mxd file:
a) Click Add.
b) Choose Optical Source (.mxd)

The Import Optical Source (.mxd) dialog box appears.
¢) Click Choose File and browse to the .mxd file stored in your local system, and click Import.
After the optical source is imported, a list of related interfaces appears.
Step 3 To import the optical source from an Excel sheet:

a) Click Add.
b) Choose Optical Source (.xIsx)

The Import Optical Source (.xIsx) dialog box appears.

¢) Click Choose Fileand browse to the .xIs file (optical source template) saved in your local system, and click Import.
d) Choose the Release Version of the NSC2K network.

e) Select the interface.

f) Click Create.

After the optical source is imported, a list of related interfaces appears.

Step 4 Choose the interfaces to import by checking the check box next to them. The selected interfaces get added to the Type
drop-down list in the properties window of the network tree.

When you create waves, you can use the interfaces in the Type drop-down list.

Optical Parameters Available in the Excel Sheet for Optical Sources Creation
The following parameters are available in the Excel sheet template for creating optical sources.

Table 23: Optical Parameters for Creating Optical Sources

Parameters Description

Interface Name The name of the interface. It should be unique for all
the interfaces that are added in the file.

Vendor Name The name of the vendor.

Vendor IDs The vendor IDs.
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Optical Parameters Available in the Excel Sheet for Optical Sources Creation .

Parameters Description

Platform The name of the platform.

Pluggable PID The PID of the pluggable.

Name It is the combination of the Data Rate and Open
Config Code. For example: R400G#5000.

FEC The forward error correction type for the given
interface.

Data Rate The line rate for the given interface.

Mod Format The modulation format to be used for the interface.

Baud rate The baud rate for the given interface.

BPS The speed of data transfer (bits per symbol) for the
given interface.

Open Config Code The unique code assigned to the interface as specified
by the Open Industry Standard for optical networks.
For example: 5000.

Sub Mode Enter the sub-mode if there are any associated with
the interface. If not, leave it blank.

Trunk Rate The trunk rate of the transponder.

Nominal Bit Rate The bit Rate for the interface

BER Target The post FEC BER Target for the interface

Power Min and Power Max

The minimum and maximum Tx Power for the
interface.

Ovl The overload power limit for the interface

OL Power The Rx power sensitivity for the interface.

OL OSNR The Rx OSNR sensitivity for the interface.

PL Power The extended Rx power sensitivity.

PL OSNR The Rx OSNR sensitivity at the extended Rx power
sensitivity.

Variance The variance in power in the Txp.

Opt Class The optical class to which the interface will be
mapped.

InBand OSNR The Tx OSNR contribution due to laser instability

inside the Txp.
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Parameters Description

Out of Band OSNR The Tx OSNR contribution due to Add/Drop at 80%
and 100% channel spectral density.

ONC Release The Software release of Cisco ONC from which this
interface will be supported.

Interface Type It is the same as the name of the interface.

Min and Max Frequency The operating frequency range of the interface.

Table 24: Optical Class Parameters

Class Parameters

Description

Interface Type

The name of the interface. Enter the same name of
the interface, if you are doing one to one mapping
with the interface.

Opt Class

You can create the optical classes for different optical
sources. Certain optical parameters are added in the
optical class. Based on interface properties, multiple
interfaces can be mapped to the same class.

Enter a unique alphanumeric name for the Optical
class. While creating new optical classes, we
recommend using the name starting with “X” to avoid
overlapping in the existing classes.

Bit Rate

The bit rate for the given interface.

Baud Rate

The baud rate for the given interface.

ModGB Coeff

The modulation guard band coefficient.

Modulation OSNR Penalty

The modulation OSNR penalty.

GBf

The filtering GuardBand at different OSNR penalties.

Mux/Demux Filtering Penalty

Enter the mux/demux filtering penalty value, if there
are any.

Chromatic Dispersion

The chromatic dispersion limit at different OSNR
penalties.

Find Optical Sources Faster

Use these steps to find the optical sources faster.
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Before you begin

Log in to Cisco ONP Web Interface

Step 1 Choose M anage > Optical Source.
The Manage Optical Source dialog box appears.

Note By default, all existing optical source files are loaded in the server.

Step 2 To find the customized optical sources:
a. Check Show only lineratetuner generated sources.

The dialog box displays only the customized optical sources.

Step 3 To filter the required optical source:
a. Enter the optical source name in the Search box.

The dialog box displays the optical sources matching the typed keyword.

Download Optical Sources

Use this procedure to download an optical source:

Step 1 Choose Manage > Optical Source.
The Manage Optical Source dialog box appears.
Step 2 Choose an optical source to download.
Step 3 Click Download and select one of the following options to download the optical sources.

» .mxd—Downloads the selected optical sources as .mxd file.

» xIsx—Downloads only the optical sources which were created and added using the Excel template, as .xIs file.
Others such as the optical sources which were directly added as .mxd file, are not included in the .xsl file.

 xml—Downloads the optical source data as a .xml file. This file contains the application codes for circuit provisioning
in Cisco ONC, optical parameters of the interfaces, PIDs, and Vendor ID information. You can load the .xml file
into Cisco ONC to create circuits with these optical source interfaces. See Alien Import.

After the import is successful, the optical source will be present under the Application Code tab in the Service
Manager screen of the Cisco ONC application. See Service Manager.
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. Delete Optical Sources

Delete Optical Sources

Use this procedure to delete an optical source:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to delete.

Step 3 Click Deleteto delete the selected optical sources.

Layout Template for NCS 2000 Network

Layout templates are reusable templates that are used to design layout configurations for the NCS 2000
network. When you have an NCS 2000 network with fixed layout rules applicable for multiple nodes, you
can use these templates to accurately set up the layout for those nodes. These templates save you time, effort,

and they minimize errors.

\)

Design and Analyze Networks |

Note Layout template is not supported for a mix of TXP and Real card label of transponders.

Export Layout Template

Table 25: Feature History

Feature Name

Release Information

Feature Description

Layout Template Enhancement

Cisco ONP Release 4.1

This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in Cisco ONP Release 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Use the following procedure to export the layout template of a specific site or all sites:
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Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network whose network layout template you want to export.
The network opens.

Step 3 Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.

Step 4 Click the Layout tab.
Step 5 Click the name of a site in the left side panel, for which you want to download the layout template.
Step 6 Hover the mouse pointer over the Export icon and click L ayout Template for Current site or All Sites.

The Export Layout Template dialog box appears.
Step 7 Click Export.

Note » We recommend that you export the layout template only in the analyze mode. Exporting layout templates
in the upgrade and release upgrade modes may be inaccurate.

* You can export the layout template for node of the type 4000 and 1000, but the exported layout template
will contain only the layout of NCS 2000 nodes. To export the layout template for the node type
NCS4K-1K-2K and NCS1K-2K, perform the following:

* Right click the site name in the L ayout panel, and click Export.

* Click OK to export the layout template in text format.

» The NCS 2000 layout template is in XML format.

Import Layout Template for NCS 2000 Network in to Cisco ONP Database

Use the following procedure to import a template for NCS 2000 Network into the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Manage> Layout Templates.

Step 2 Click Add in the Manage L ayout Template dialog box.

Step 3 Click Choose Files and select a template from your local system.
Step 4 Click Import.
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. Download Layout Template for NCS 2000 Network

The template is imported to the Cisco ONP database.

Download Layout Template for NCS 2000 Network

Use the following procedure to download a template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Manage> Layout Templates.
Step 2 In the Manage L ayout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Download.

Save the template into your local system.

Delete Layout Template for NCS 2000 Network

Use the following procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose Manage> Layout Templates.
Step 2 In the Manage L ayout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Deleteto delete the template from the Cisco ONP database.

Apply NCS 2000 Layout Template into a Site

Use this task to apply the NCS 2000 Layout template into a site. The site can be NCS4K-2K, NCS1K-2K-4K,
or NCS1K-2K, but the template will be applied only to the NCS 2000 section of that site.

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
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The Select Network To Open dialog box appears.

Step 2 Click the network where you want to apply the layout template into an NCS 2000 site.
The network opens.
Step 3 Choose Network > Entity Editor.

Step 4 In the Entity Editor window, expand Sites and choose the site.
Step 5 In the right pane, choose the required template from the L ayout Template drop-down list.

Note Make sure that the other properties under L ayout section such as Chassis Type, Power Supply, Controller
Card, Node Protection, Redundant Controller Card, and MF-Unit are

set to Auto. Otherwise the L ayout Template drop-down list remains disabled.

Import NCS 1000 and NCS 4000 Layout Template into NCS1K-2K and
NCS4K-1K-2K Sites

Use this task to import NCS 1000 and NCS 4000 layout templates that were exported, into 4K-2K and
NCS4K-1K-2K Sites.

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network that has the site to which you want to apply the layout template.
The network opens.

Step 3 Click the Layout tab.

Step 4 Add the required NCS 4000 and/or NCS 1000 chassis, cards, and pluggables to the required slot of the added chassis.
See Edit the Layout Manually, on page 59

Step 5 Click Edit to enter the edit mode.
Step 6 Right click the name of a site on which you want to import the layout template, and click Import.
Step 7 Choose the layout template that you want to import into the site and click OK

The layout template gets applied to the site.

Note When you modify an exported template, ensure to rename the modified template before reapplying it to a site in
the upgrade mode so that the changes in the template reflect in the layout view.
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. Layout Visualization

Layout Visualization

Table 26: Feature History

Feature Name Release Information Feature Description

Layout Visualization and Edit Cisco ONP Release 4.1 This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.

This feature allows you to visualize the layout of a network, designed using Cisco ONP. You can view the
arrangement of racks, chassis inside the racks and cards inserted in the chassis. When you click a particular
Rack or Chassis or Card in theL ayout panel, the corresponding Rack or Chassis or Card gets highlighted in
the Layout image. You can zoom in and zoom out the Layout image.

View Network Layout

Step 1

Step 2
Step 3

Step 4
Step 5

Step 6
Step 7

The procedure to view the network layout is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

From the File menu, click Open.

The Select Network To Open dialog box appears.

Click the network to open from the list of available networks.
Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.

Click the Layout tab.
In the Layout panel on the left side, click the site.

Note The OLA sites are highlighted in green color, ROADM sites in blue color and Aggregated nodes in purple color.
Passthrough sites are not listed under layout.

For NCS 1010 network, Aggregated nodes are not available.

Click any rack under a site to visualize the rack view of the network under L ayout tab.

Click any chassis under a rack to visualize the chassis view of the network.
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Edit the Layout Manually .

Note When you click the Aggregated node under L ayout panel, NCS 1004, NCS 2000 and NCS 4000 series chassis
are placed in separate racks.

You can click the screenshot icon to take screenshot of all racks layout of the selected site.

Edit the Layout Manually

Step 1

Step 2

Step 3

Step 4
Step 5
Step 6
Step 7

Step 8

The Manual layout edit feature is used to adjust the position of NCS 4016 and NCS 1004 chassis and cards
in the layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network to open from the list of available networks.

Choose the network where 4K-1K-2K and 1K-2K aggregated nodes are added. This feature is not supported on NCS
2000 node.

Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.

Click the Layout tab.
Click Edit to enter the Edit mode.
Select the Chassis (4K-1K-2K and 1K-2K) or Card from a particular rack.

Drag and drop the selected Chassis or Card from a particular rack to the empty slot in the same or different Chassis or
Rack.

To add pluggables to a particular card, perform the following steps:

Note Make sure to add the required cards.

a) Select the Rack.
The cards available in the Rack are displayed.

b) Select the card to which you want to add pluggables.

The ports available in the card are displayed.

¢) Select the pluggable for each port.
The following pluggables are displayed:
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Card Supported Pluggables

NCS4K-4H-OPW-QC2 « ONS-QSFP8-LR4=
« QSFP-110G-SR4-S=
« ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-LO * ONS-QSFPS8-LR4=
* QSFP-100G-SR4-S=
* ONS-QSFP-4*10-MLR=

NCS1K4-1.2T-K9= * ONS-QSFPS8-LR4=

* QSFP-100G-SR4=

* ONS-QSFP28-LR4-S=

* QSFP-100G-CWDM4-5=
* QSFP-100G-SM-SR=

d) Click the Tick icon.

Step 9 Click Done to save the changes in the Layout.

View the Layout Details Using Tooltip

You can hover over the Racks or Chassis or cards in the Rack and view the details using Tooltip. Click See
More Details to view the details of port no. type, pluggables and rates.

Copy the Configurations of a Particular Node to Another Node

The configuration can be copied from one node to another node only for the manual 4K-1K layout movement.
It is not supported for NCS1010 layout movement.

The procedure to copy the configurations of a particular node to another node of a different site is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.
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Step 4 Click the Layout tab.

Step 5 Select the Rack, Chassis, or Card of a particular site.

Step 6 Select the site to where you want to copy the configurations to, from the Copy To drop-down list.
Step 7 Click New Rack to add a new rack. The configuration gets copied to the new rack.

Step 8 Click Doneto save the changes in the Layout.

Note  You can also cut, copy, and delete Racks, Chassis, and Cards in the Chassis from the Layout.

Export Port Usage of LNI Network

Table 27: Feature History

Feature Name Release Information Feature Description

Multi-Layer Connections Phase 1 | Cisco ONP Release 4.1 This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

* Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

* Port usage report based on
sites

* Port usage report only for LNI
imported networks

Use the following procedure to export the port usage details of an LNI network:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 Choose File> Open.
The Select Network To Open dialog box appears.

Step 2 Click the LNI network whose port usage you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.
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. Define Multilayer Connections for SSON Network

Step 4
Step 5
Step 6

Step 7

Click the Layout tab.
Click the name of a site in the left side panel,for which you want to download the port usage.
Mouse hover the Export icon and click Port Usage for Current site or All Sites.

The Export Port dialog box appears.

Click Continue.
The port usage details are exported in the Excel sheet format.

Note * If you modify any services in the NCS 4000 node after upgrading the LNI network , the changes will not get
updated in the port usage details.

* The demand labels seen against the trunk ports of NCS4K-DWDM line card in the port mapping report are
not logically related to the NCS 4000 trunk ports, but are related to NCS 1004 client ports.

Define Multilayer Connections for SSON Network

Step 1

Step 2

Table 28: Feature History

Feature Name Release Information Feature Description
NCS4K-1K-2K Multilayer Cisco ONP Release 4.2 You can define Multilayer
Connection Trace Connections (MLC) such as cards

and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the L ayout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Before you begin

Log in to Cisco ONP Web Interface

Choose File> Open.
The Select Network To Open dialog box appears.

Click a network in which you want to define the multilayer connections.
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Step 3

Step 4
Step 5

Define Multilayer Connections for SSON Network .

Make sure that the network is in analyzed mode and 4K, 1K, and cards are defined in the network.

The network opens.

Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.

Click the L ayout tab.

In the left pane, click the ML C tab.

You can also navigate to the ML C page by clicking the Ellipsisicon available in the right side of the service name in

the network tree and clicking View in MLC

You can view a table describing the following properties of the service, in the right pane:

Table 29: MLC Details

Properties

Description

Name

Name of the service

Group Name

Name of the group to which the service belongs to

Type Traffic type

Src Site Source site

Src NCS4K In Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the source site

Src NCS4K Out Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the source site

Src NCS1K In Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS1K Out Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS2K AddDrop Add/Drop multiplexer and demultiplexer connected to the
NCS 2000 chassis in the source site

Src NCS2K MPO Media channel between the source and destination sites

Dst NCS4K In Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the destination site

Dst NCS4K Out Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the destination site

Dst NCSIK In Details of Rack/Slot/Card/Port in the input side of the NCS
1004 chassis in the destination site

Dst NCSIK Out Details of Rack/Slot/Card/Port in the output side of the

NCS 1004 chassis in the destination site
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. Define Multilayer Connections for SSON Network

Step 6

Step 7

Step 8

Step 9

Step 10

Properties Description

Dst NCS2K AddDrop Add/drop multiplexer and demultiplexer that is connected
to the NCS 2000 chassis in the destination site

Dst NCS2K MPO MPO cable connecting the NCS 2000 chassis in the
destination site

Media Channel Media channel between the source and destination sited

Notes More notes, if any

Trace Origin Indicates whether the service connections are user-created
or imported through LNI.

Note The details of source and destination NCS2K AddDrop and NCS2K MPO are not displayed for the networks
that are created in Cisco ONP Release 4.1 and migrated to Cisco ONP Release 4.2.

Click the service name to switch to the layout view.

You will view the layout and the service details in the right pane.

Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS 1K
out, for both Source and Destination sites.

The details of the NCS 2000 chassis are auto-populated.

Note For LNI imported network all the details are auto-populated. If you add any new service, you can change the
details of the new service as per your requirement.

Click the Tick icon to save the changes you have done.

You can click the refresh icon to delete the changes you made after saving.
The updated details are included in the BOM.

(Optional) To export the MLC details perform the following steps:

a) Click the Table icon to switch to the table view.
b) Choose Export > MLC Tracesto export all the details available in the MLC table.

¢) Choose Export >LMP/TTI Connectionsto export the details of Link Management Protocol (LMP) connections
which are the connections between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTI) connections
which are the connections between NCS 4000 and NCS 1004 cards.

All these connections get added to the BOM.

(Optional) Click the Filter icon to filter the services displayed in the left pane, based on the following:.
The following filter options are available:

* Source Site
* Destination Site
* Type of the traffic

* Trace Origin
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* LNI—Imported through Import Live Network option
* User Created—Created through Cisco ONP Ul

e Trace Status
» Completed—User has defined all MLC details.
* Partial —User has defined only partial MLC details.

* Empty—User has not defined any MLC details.

Step 11 (Optional) Click the three vertical dots and select the following as required:
» Enable Multi Select—You can select up to the card level for different OTN.

» Expand All—Expands the services tree.
* Collapse All—Collapses the expanded services tree.

« Show Trace Status—Shows the trace status icon next to the service name.

Step 12 (Optional) Click the three horizontal dots across the service trace and select the following as required:

* Delete Trace—Deletes the respective trace.

* Locate in Map—Shows the service in the map view.

Note  User can enable the same port number on the primary and secondary NCS4K | N nodes for Client 1+1 and other
protection scheme.
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Spectrum Utilization and Path Finder

Table 30: Feature History

Design and Analyze Networks |

Feature Name

Release Information

Feature Description

Finder

Spectrum Utilization and Path

Cisco ONP Release 24.3.1

The Spectrum Utilization and Path
Finder introduces the Minimal
Map, a streamlined network
visualization tool focusing on
essential data points like Sites and
Fibers, enhancing usability and
performance. General Settings
now allow individual
customization, including default
map views and spectrum utilization
colors. The Path Finder/Selector
enables interactive path selection
with options for manual and custom
path finding for multiple routing
options. The Spectrum Utilization
provides a comprehensive
visualization of used spectrum,
while the Spectrum Finder helps
locate and apply available spectrum
across fibers, offering dual-view
capabilities and multiple selection
methods. These enhancements
collectively improve network
management, planning, and
resource optimization.

Spectrum Utilization and Path Finder introduces

* Minimal Map: streamlines network visualization tool focusing Sites and Fibers.

+ Path Finder/Selector: enables interactive path selection with options for manual and custom path finding.

* Spectrum Utilization: provides a comprehensive visualization of used spectrum.

* Spectrum Finder: helps to locate available spectrum across fibers and apply them on a Circuit or Media

Channel.

Find a Custom Path

The Custom Path Finder is accessible exclusively through the Minimal Map. When you choose the custom
path finder, the detailed map automatically switches to the Minimal Map.

Limitations
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Step 1
Step 2

Step 3

Step 4

Step 5

Find a Custom Path .

* Applies to only Circuits (NCS1010/NCS1001), Waves (NCS2000 NON-SSON), media channel (NCS2000

SSON).

The procedure to customize a fiber path on the map is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

In the network tree, select the section of the media channel/circuit that you want to add a new path.

Click the Ellipsesicon and select Custom Path Finder.

The Custom Path Finder for the selected section opens.

In the Visualization area, choose the required map view.

Map View Result

Complete Map Shows a complete network map of the selected path with
other sites.

Sub Map Shows only maps with chosen sites and fiber.

In the Optionsarea, choose the required parameters to calculate the Path Finder.

Option

Description

Minimum Hop

Performs all the routing based on minimum number of hop
counts, irrespective of length of fibers

Minimum Length

Performs all the routing based on fiber minimum length,
irrespective of hop count

Distinct Fiber Set

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Number of Path Count

Calculates the number of paths based on the provided
number

Click Calculate.

The list of paths calculated based on the chosen parameters displays.

The calculated paths table contains the path parameters.

Table 31: Path Parameters

Parameter Description

S.No Displays the serial number

Path Displays fiber path direction based on chosen Options parameters
Funnel icon Filters the path based on fiber labels
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Parameter Description
Hops Provides the hop count
Total Length Provides the total length of the fiber path

Step 6 Click Export to export the chosen fiber path.

Step 7 In the Selected Serviceand Path area, check the service and path information and click Apply Path to apply the selected
path.

Select Path Manually

The Manual Path Selector is accessible exclusively through the Minimal Map. When you choose the manual
path selection, the detailed map automatically switches to the Minimal Map.

Limitations
* Available in Design and Upgrade modes where circuits path can be updated.

* Applies to only Circuits (NCS1010/NCS1001), Waves (NCS2000 NON-SSON), media channel (NCS2000
SSON).

* Applies to regen circuits/waves/media channel.

* Additional options are applicable for Section under Network Tree.

The procedure to select a path manually on the map is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 In the network tree, select the section of the media channel that you want to add a new path.
Step 2 Click the Ellipsesicon and select Manual Path Selection.
Step 3 In the Search field, enter the site or fiber to focus on it.

Step 4 Select the required the fibers to create a path.

The selected fibers appear on the Operation M odes pop-up pane under Fibersarea.

Step 5 Click Apply.

View Spectrum Utilization and Spectrum Finder

The Spectrum Finder is accessible exclusively through the Minimal Map. When you choose the spectrum
finder, the detailed map automatically switches to the Minimal Map.

We recommend that you use the Spectrum Finder for the network in Design/Upgrade/Release Upgrade Mode
and view the Spectrum Utilization in Analyze Mode.
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Step 1
Step 2

Step 3
Step 4

Step 5

View Spectrum Utilization and Spectrum Finder .

The procedure to view the spectrum utilization and find a spectrum to apply for a service is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

In the network tree, select the section of the media channel that you want to learn the spectrum utilization per fiber.

Click the Ellipsesicon and select Spectrum Finder.

The Spectrum Finder for the selected section opens.

In the Selected Fibersarea, click +Add Fiber and choose the required fibers from the drop-down list.

In the Visualization area, choose the required map view.

Map View Result

Complete Map Shows a complete network map of the selected path with
other sites.

Sub Map Shows only maps with chosen sites and fiber.

In the Spectrum Finder area, modify the parameters as req

uired..

Option

Description

Tabular View

Similar to Spectrum Utilization View

Detailed View

Displays multiple fibers in a vertical orientation (Y-Axis)
and the spectrum on the horizontal axis (X-Axis).

Spectrum Selection

Enable Spectrum Selection to modify the subsequent
parameters.

Spacing

Enter the bandwidth (GHz) that is required for the network
circuit.

Distinct Fiber Set

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Number of Path Count Calculates the number of paths based on the number
provided

Allow Overlap Allows you to select overlapping wavelengths with selected
fibers, when enabled.

Zoom Zooms in and out of detailed view to granular view. Click
Defaultreset zoom.

View Labels Displays the labels. Enable to view the labels. You can also

view the labels of existing occupied circuits.

Hovered Spectrum

Shows the start, end, and central wavelengths (THz) of the
hovered spectrum when moving across the view

Design and Analyze Networks .


b-conp-24-3-1-config-guide_chapter1.pdf#nameddest=unique_12

Design and Analyze Networks |

. Regenerate BoM Automatically

Step 6

Step 7

Option Description

Selected Spectrum Shows the start, end, and central wavelengths (THz) of the
selected spectrum when selecting across the view.

C-Band Toggle to view the C-band spectrum usage.

L-Band Toggle to view the L-band spectrum usage.

In the Apply Propertiesto Existing Service area, check the service parameters and click Apply Wavelength and Apply
Path.

Click Apply Wavelength and Apply Path to revert the changes.

Select Apply to Service.

Regenerate BoM Automatically

You can view the new Chassis or Card added to the existing layout under the BOM tab. You can also view
the regenerated BoM after manual editing of the layout.

Add new Pluggables, Alarm Cables and 100G Client Bandwidth
Licenses to BoM

Step 1

Step 2
Step 3

Step 4
Step 5

Step 6

You can add new pluggables, alarm cables and 100G bandwidth licenses of NCS 1004 and NCS 4000 platforms
to the existing BoM.

The procedure to add new pluggables, alarm cables and 100G client bandwidth licenses to the existing BoM
is as follows.

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Click the network to open from the list of available networks.
Choose Network > Analyze.

Note Network must be successfully analyzed to proceed further.

Click the BOM tab.
Click Add.
The New window opens.

Enter the Cisco part number of the pluggable or alarm cable or 100G bandwidth license in the Cisco Part Number field.
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Step 7
Step 8

Export IPC Report .

Choose the Quantity of pluggables or alarm cables or 100G bandwidth licenses to be added.
Click Add.

The new pluggables or alarm cables or 100G bandwidth licenses are added to the BoM list.

Export IPC Report

Step 1

Step 2
Step 3

Step 4

Step 5

Step 6

You can export the connections of a current site or all sites to an Excel sheet using the following procedure:

Before you begin

Log in to Cisco ONP Web Interface

From the File menu, click Open.

The Select Network To Open dialog box appears.

Click the network to open from the list of available networks.
Choose Network > Analyze.

Note The network must be successfully analyzed to proceed further.

Click the Layout > | PC tabs.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

The patches that you click are highlighted in the rack.

Hover over the Export icon, and click Current site or All Sites option.

The Export | PC dialog box appears.

Click Continue to export the connections of the current site or all sites.

The cable-type and Cable ID are included in the report only for the NCS 1010 network.
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Edit the Layout Manually for NCS 1010 Networks

Step 1

Step 2

Step 3

Step 4
Step 5
Step 6
Step 7

Step 8

Table 32: Feature History

Feature Name Release Information Feature Description
Layout Edit Support for NCS 1010 | Cisco ONP Release 5.0 Cisco has introduced NCS 1010 as
Networks a new optical line system to meet

the growing optical network needs.
Using Cisco ONP you can visualize
and edit layouts for NCS 1010
chassis and patch panels.

The Manual layout edit feature is used to adjust the position of the NCS 1010 chassis and patch panels in the
layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP Web Interface.

Choose File> Open.
The Select Network To Open dialog box appears.

Note You can also create a new NCS 1010 network. For more information, see Manually Design a Network Using
Cisco ONP, on page 2.

Click the network to open from the list of available networks.

Choose the NCS 1010 network.

Choose Network > Analyze.

Note The network must be successfully analyzed to proceed further.

Click the L ayout tab.
Click Edit to enter the Edit mode.
In the left panel, click a site.

Select a unit (NCS 1010 chassis or patch panel) using one of the following methods:

* In the left panel, expand the rack under a site and choose a unit.

* Or, in the Rack view, click a chassis or patch panel.

To adjust the position of the selected units, use one of the following methods:

Note If necessary, click the +New Rack button to create more racks.

* In the Rack view, drag and drop the selected chassis or panel from a particular rack to the empty slot in the same
or different rack.
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* Swap units in the Rack view:
* Click a transponder or NCS1K14-CCMD-16 card.
The Swap with button appears.

* Click Swap with and select a slot to swap from the drop-down list.

Note The Swap with button appears only for NCS 1014 and NCS 1020 chassis.

* Cut and Paste unit in the left panel:
* Click Cut above the Rack view.
* Right-click on an empty slot in the same or different rack and click Paste.
Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Cut and Paste unit in the Rack view:
* Right-click the selected chassis or panel and click Cut.
* Right-click on an empty slot in the same or different rack and click Paste.
Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

* Move the unit in the left panel:

« Go to Moveto > Site-X > Rack-X above the Rack view to move the chassis to the same or different rack.
Or go to Moveto > Site-X >+ New rack above the Rack view to move the chassis to a new rack.

* Move the unit in the Rack view:

* Right-click the selected chassis or panel and go to Moveto > Site-X > Rack-X to move the chassis to the
same or different rack. Or go to Move to > Site-X >+ New rack to move the chassis to a new rack.

Note The Moveto option moves the unit automatically to the immediate empty slot. The Cut and Paste option moves
the unit to the selected empty slot.

Step 9 Click Done to save the changes in the Layout.

A warning message appears when empty racks are present in the layout.

Step 10 Click OK to remove the empty racks.
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View Internal Node Connections of NCS 1010 Network

Step 1

Step 2

Step 3

Step 4
Step 5

Step 6

Table 33: Feature History

Feature Name

Release Information

Feature Description

View Internal Node Connections
of NCS 1010 Network

Cisco ONP Release 5.0

The Node diagram tab displays a
functional view that includes
precise connections and port
labeling of each component such
as OLT or ILA,
NCS1K-BRK-8/16/24,
AAWG-32-0, and AAWG-32-E,
for each site in an analyzed NCS
1010 network.

Before you begin

Log in to Cisco ONP Web Interface.

ChooseFileOpen.
The Select Network To Open dialog box appears.

Click the analyzed NCS 1010 network.

The network opens.

Choose Network > Analyze.

Note

Click the Layout > Node Diagram tabs.

Network must be successfully analyzed to proceed further.

Click each site in the left panel and select a side to view the functional view of the site.

The functional view includes both the combination of physical and logical connections such as:

* Degree interconnections between NCS1010 (OLT or ILA) and NCS1K-BRK-8

» Add/drop connections between NCS1010 and colorless add/drop units (NCS1K-BRK-8, NCS1K-BRK-16, or

NCS1K-BRK-24) and colored add/drop units (AAWG-32-O or AAWG-32-E)

Hover over the cable to view the details such as name of the ports that are connected and the cable ID.
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Design Networks with SVO Card

An SVO card along with the application software provides functionality-based licenses for alarm correlation,
performance monitoring, connection verification, and Optical Time Domain Reflectometry (OTDR). You can
design a network with ROADM and TRAFFIC nodes that are equipped with SVO cards.

Features

* The SVO card is a two-slot card.

* The SVO card acts as the primary card for all the networks after Release12.1.0.

* To achieve high availability, you can have two SVO cards equipped in one node.

* You can use two 10G SFP+ pluggables to connect two SVO cards present in a node.

* You cannot have two SVO cards in the same chassis, to achieve high availability in the network.
* When designing the network, you can connect a Cisco ASR 920 Switch to the SVO cards.

* The SVO can be used as a card or as a UCS-based solution.

SVO Licenses

SVO cards require either Base License or SVO Full License (High Availability, Connection Verification,
Flex Spectrum). If you do not select SVO Full License, by default, SVO Base License and High Availability
are enabled.

The different types of SVO licenses are

* Cisco NMS: This includes features such as High Availability, Connection Verification, Flex spectrum,
and OTDR.

* Third-Party NMS: This includes features such as NBI (North Bound Interface), Alarm Correlation,
Performance Monitoring, and Circuit Provisioning.

ChassisLicensing

* Every chassis added to the network must have license after Release 12.1.0. For the release upgraded
network, a new chassis license is added after it is analyzed in Cisco ONP Release 4.0 or higher.

* There are many variants of the chassis license, such as 1-chassis, 5-chassis, 10-chassis, 20-chassis,
50-chassis, and so on. The variants of chassis license are added based on cost optimization.

* A license is required for every chassis that is added to the network after the first chassis.

* Chassis License Flush Out: You can flush out the existing chassis license and purchase a new chassis
license. If you hold the existing chassis license, the license remains active even if the site is unlocked.

* Chassis License Flush Out is supported only in the network upgrade mode.

* You can use the existing license with new changes in chassis, if you do not use the Chassis License Flush
Out option.
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Associate OLA or DGE Sites with SVO0 Cards

The following procedure shows how to associate OLA sites with the SVO cards:

Before you begin

Log in to Cisco ONP Web Interface.

Step 1 In the network tree panel, click the Ellipsisicon available in the right side of any ROADM site.
Step 2 Click Edit SVO Associations.
Step 3 Select the OLA sites on the map to toggle the SVO connections. Click Doneat the top-right corner to confirm the selection.

You can open widgets in the map and select top section to view the association.

Note  You can also click the Ellipsisicon available in the right side of any ROADM site from the Map and click Edit
SVO Associations. For the sites that are of DGE type, the Edit SVO Associations option is not displayed.

The tool associates the OLA and DGE sites that are not associated by you, with the SVO card during the network
analysis.

Export Device NETCONF XML File

You can export the NETCONF (Network Configuration Protocol) XML files for all the individual sites in a
network or the complete network. The following procedure shows how to export NETCONF XML files for
the complete network from the Cisco ONP GUIL

Before you begin

Log in to Cisco ONP Web Interface.
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Step 1

Step 2

Table 34: Feature History

Export Device NETCONF XML File .

Feature Name Release Information

Feature Description

New Parameters Included in NCS | Cisco ONP Release 24.3.1
1010 NETCONF XML file

The NETCONF XML file exported
from the NCS 1010 network design
now includes these new parameters
to support seamless Day-0
provisioning and the setup of a new
node added to the network.

* Optical cross-connects

* Gain range margin

* Tone Rates

* Raman tuning configurations
* Slot reserve

* Dmux WSS attenuation

* Unused CCMD-16 ports
shutdown

* Span baseline-deviation
* OTDR Thresholds

* APC Span-loss correction
threshold

Table 35: Feature History

Feature Name Release Information

Feature Description

Export NETCONF File from NCS | Cisco ONP Release 5.0
1010 network

You can export the NETCONF
XML files for all the NCS 1010
nodes, and upload them to the NCS
1010 nodes through the Yang suite.
This enables automatic bring up of
the NCS 1010 nodes using the
NETCONF data.

The network must be in Analyze mode.

In the network tree panel, click the three dots.
A pop-up list appears.
In the list, click Generate Device NetConf XML.

Export window appears with network name.
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Step 3 Click Export.

The message, "Success. Device NetConf exported successfully" appears.
You can download the zip file that contains NETCONF XML files of individual sites.
Note You can choose the destination folder to save the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Note For C+L Network, the partner band configurations are not part of the Cisco ONP-generated XML file. You must
manually configure the partner bands on the devices while bringing up the NCS 1010 C+L network.

From Release 24.3.1, the following new parameters are available in the NETCONF file exported from the NCS 1010
network design:

* OSC TX Power

* Optical Cross Connect

* OTS tone rate

* OMS tone rate

* OTS tone pattern expected

* OTS tone detect OOB

* OTS tone pattern

* OTS tone frequency

* Raman pump configurations
* Line port attenuation

* Raman dual safety

The following parameters are available only when you have enabled the Enable Special Settings check box under
Network level properties.

* Raman turnup

* OTS ports shutdown

* OTDR autoscan

* Gain range margin

* OTDR excess attenuation threshold
* OTDR end of fiber threshold

* Slot reserve

* Dmux WSS attenuation

* Unused CCMD-16 ports shutdown
* Span baseline-deviation

* OTDR Thresholds
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» APC Span-loss correction threshold

Upload NETCONF XML Files on SVO Web Interface

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

The following procedure shows how to upload the NETCONF XML files on the SVO web interface:

In the browser URL field, enter the IP address of the SVO line card.
The login page appears.

Enter the username and password.

Click Login.

Click the hamburger icon at the top-left of the page, and select Node Configuration.
Click the Node Setup tab.

Click Select files.

Browse to the NETCONF XML files exported from the Cisco ONP GUI and upload them.

If the passive unit ID in the NETCONTF file exceeds the range 1-126, SVO displays an error message. Validate the XML
file and reimport.

Note Ifthe value of FEC mode already provisioned in the 200G-CK-C line card does not match with the value available
in the NETCONF XML file, SVO displays an error message. We recommend that you remove the provisioned
FEC settings for this card and reimport the XML file.

Export Device NETCONF XML Files for Individual Sites

Step 1
Step 2

Step 3

The following procedure shows how to export Device NETCONF XML files for individual sites from the
Cisco ONP GUI.

Before you begin
Log in to Cisco ONP Web Interface.

The network must be in Analyze mode.

Click the Ellipsisicon available in the right side of the site.
In the list, click Generate Device NetConf XML.

Export window appears with network name.

Click Export.

The message, "Success. Device NetConf exported successfully" appears.
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You can download the zip file that contains Device NETCONF XML files of individual sites.

Upload NETCONF Files to NCS 1010 Device

Use this task to upload the NETCONF files that downloaded from Cisco ONP into the NCS 1010 device using
a NETCONF client.

Step 1 Log in to the NETCONF Yang Suite which has access to the NCS 1010 device.
Step 2 Connect to the NCS 1010 device.

Step 3 Copy the NETCONF XML file content that is downloaded from Cisco ONP, and paste it into the Protocol NETCONF
Run RPC block.

Step 4 Append the following commit code at the end of the NETCONF XML file content.

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="102">
<commit/>
</rpc>

Export Cisco Optical Site Manager NETCONF XML File

You can export the Cisco Optical Site Manager NETCONF XML files for all the individual sites in a network
or the complete network. The following procedure shows how to export Cisco Optical Site Manager NETCONF
XML files for the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP Web Interface.

Table 36: Feature History

Feature Name Release Information Feature Description

Export Cisco Optical Site Manager | Cisco ONP Release 5.2 The new Generate COSM
(COSM) NETCONEF File from NetConf XML option allows you
NCS 1010 network to export from the Cisco Optical

Network Planner, the Cisco Optical
Site Manager NETCONF XML
files for all the NCS 1010 nodes.
You can then upload these files to
the NCS 1010 nodes through the
Cisco Optical Site Manager,
enabling automatic bring-up of the
NCS 1010 nodes.

The network must be in Analyze mode.
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Step 1 In the network tree panel, click the three dots.
A pop-up list appears.
Step 2 In the list, click Generate COSM NetConf XML.
Export window appears with network name.
Step 3 Click Export.
The message, "Success. COSM NetConf exported successfully" appears.
You can download the zip file that contains COSM NETCONF XML files of individual sites.

Note You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files
of individual sites.

This feature has limited scope in this release.

Note [-Band Configuration is not certified in Cisco Optical Site Manager for R7.11.1. A future release will be considered
for the L-Band configuration.

Upload Cisco Optical Site Manager NETCONF XML to NCS 1010
Device via Cisco Optical Site Manager Web Interface

Use this task to upload the Cisco Optical Site Manager NETCONF files that you downloaded from Cisco
ONP into the NCS 1010 device using the Cisco Optical Site Manager web interface.

Before you begin

Log in to Cisco ONP Web Interface

Step 1 Log in to the Cisco Optical Site Manager UI that has access to the NCS 1010 device.
Step 2 Cross-check the device name, UID, and card layout position (Rack ID, RU Position) with CONP XML.

The Cisco Optical Site Manager device name and UID should match with the CONP XML. If any mismatch exists,
delete the device from Cisco Optical Site Manager and add back with name and UID as in the CONP XML.

Step 3 Go to Optical Setup and browse the CONP-generated XML without OXC for that device and load it.
Step 4 Click the Select files... button.

The file explorer window appears.

Step 5 Select the CONP-generated Cisco Optical Site Manager XML from your local device.
Step 6 Click Open.

A confirmation message appears.

Step 7 Click Yes.
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. Export NCS 1010 Network Planning Data for Cisco Optical Network Controller

Step 8

Step 9
Step 10

Step 11

Click Upload.
The COSM XML successfully uploaded message appears.

Go to Optical Configuration > ANS parameter and verify whether the respective configurations are complete.

After loading the Cisco Optical Site Manager XML file without optical cross connect, load the Cisco Optical Site
Manager XML with optical cross connect.

After adding the Cisco Optical Site Manager XML file with optical cross connect, go to the Optical Cross Connections
tab and verify whether the respective configurations are complete.

Export NCS 1010 Network Planning Data for Cisco Optical
Network Controller

Step 1
Step 2
Step 3
Step 4

Table 37: Feature History

Feature Name Release Information Feature Description

Export NCS 1010 Network Cisco ONP Release 5.0 You can export the planning data
Planning Data for Cisco Optical of NCS 1010 network, in the form
Network Controller (Cisco ONC) of a JSON file. This JSON file can

be uploaded into Cisco ONC to
configure the managed devices in
bulk.

Use this task to export the planning data of NCS 1010 network, which is in the form of JSON file from Cisco
ONP. This JSON file is uploaded into Cisco ONC to configure the managed devices.

You can export the planning data of NCS 1010 network only for the releases 7.7.1 and 7.9.1.

Before you begin
Log in to Cisco ONP Web Interface.

The network must be in Analyze mode.

In the network tree panel, click the Ellipsisicon available in the right side of the network name.
Click Generate CONC JSON.

In the Export File dialog box, enter the name of the JSON file.
Click Export to download the JSON file into your local system.

Upload Planning Data into Cisco ONC

Use this task to upload the network planning data (JSON file) downloaded from the Cisco ONP.
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Upload Planning Data into Cisco ONC .

Step 1 Log into Cisco ONC.

Step 2 Hover over the Import icon in the left panel and click Planning Data Import.
Step 3 Click Import.

Step 4 Browse and select the JSON file that is downloaded from Cisco ONP.

You can use the planning data to configure the devices managed by Cisco ONC.

Design and Analyze Networks .
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