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Add and Remove Nodes
This chapter explains how to add and remove Cisco ONS 15310-MA SDH nodes from path protection
configurations and linear add-drop multiplexers.

Before You Begin
Before performing any of the following procedures, complete the “NTP-H56 Document Existing
Provisioning” procedure on page 8-2. Also investigate all alarms and clear any trouble conditions. Refer
to the Cisco ONS 15310-MA SDH Troubleshooting Guide as necessary.
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).
1.

NTP-H97 Add a Path Protection Node, page 13-1—Complete as needed.

2.

NTP-H98 Remove a Path Protection Node, page 13-4—Complete as needed.

3.

NTP-H99 Add an End Node to a Linear ADM, page 13-6—Complete as needed.

4.

NTP-H135 Add a Non-ONS 15310-MA Node to a Linear ADM, page 13-7—Complete as needed to
add an ONS 15600, ONS 15454, or ONS 15310-MA SDH node to a linear configuration where an
ONS 15310-MA SDH is an end node.

5.

NTP-H101 Remove an In-Service Node from a Linear ADM, page 13-9—Complete as needed to
remove an node from a linear ADM without disrupting traffic.

NTP-H97 Add a Path Protection Node
Purpose

This procedure adds a node to a path protection configuration.

Tools/Equipment

None

Prerequisite Procedures Cards must be installed and node turn-up procedures completed on the
node that will be added to the path protection configuration. See Chapter 1,
“,” and Chapter 3, “Turn Up a Node.”

Step 1

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Superuser only

According to local site practice, complete the “NTP-H102 Back Up the Database” procedure on
page 14-2 for all the nodes in the ring.
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Step 2

Verify the card installation on the new node. See the NTP-H148 Verify Card and SFP Installation,
page 3-2.

Note

In Cisco Transport Controller (CTC), SFPs are called pluggable port modules (PPMs).

Step 3

Verify that the STM-M ports (or cards in non-310 nodes) that will serve as the path protection trunk
(span) ports match the path protection optical rate of the trunk cards to which the new node will be
connected. For example, if the adjacent nodes have STM4 ports, the new node must have STM4 ports.

Step 4

Verify that fiber is available to connect the new node to the existing nodes.

Step 5

Complete the “NTP-H26 Verify Node Turn-Up” procedure on page 4-2.

Step 6

Log into a node in the path protection configuration where you want to add a node. See the “DLP-H29
Log into CTC” task on page 16-43 for instructions. In order to have CTC visibility to the new node after
it is added, you must be an authorized user on the node and you must have IP connectivity to the node.

Step 7

Complete the “DLP-H163 Check the Network for Alarms and Conditions” task on page 17-56 to verify
that the path protection configuration is free of major alarms or problems. If trouble is indicated (for
example, a major alarm exists), resolve the problem before proceeding. See Chapter 8, “Manage
Alarms” or, if necessary, refer to the Cisco ONS 15310-MA SDH Troubleshooting Guide.

Step 8

Count the total number of circuits on the fiber that is cut between the existing nodes. To count the number
of circuits, right click on the fiber that is cut, and click circuits.

Step 9

In network view, click the Circuits tab.
To view Partial circuits, click the Filter button and select PARTIAL from the Status drop-down list. The
Partial circuits, if any, are displayed.
To view Partial_TL1 circuits, click the Filter button and select PARTIAL_TL1 from the Status
drop-down list. The Partial_TL1 circuits, if any, are displayed.
Resolve any partial circuits (both Partial and Partial_TL1) in the network before proceeding. However,
if you want to continue with Step 10, match the number of partial circuits and circuit names that existed
before and after adding a path protection node. This ensures that no additional partial circuits are created
after this procedure is completed.

Step 10

Step 11

Step 12

Log into the new node:
•

If the node has a LAN connection and does not appear on the network map, from the File menu,
choose Add Node, then enter the IP address or the DNS name of the new node and click OK. Wait
for the new node to initialize and appear on the network map. Proceed to the next bullet point.

•

If the node has a LAN connection and appears on the network map, from the View menu, choose Go
to Other Node, then choose the new node from the Select Node to Go to drop-down list on the Select
Node dialog box and click OK.

•

If the new node is not connected to the network, log into it directly using the “DLP-H29 Log into
CTC” task on page 16-43.

Click the Alarms tab and click Synchronize.
a.

Verify that the alarm filter is not on. See the “DLP-H88 Disable Alarm Filtering” task on
page 16-107 as necessary.

b.

Verify that no critical or major alarms are present, nor any facility alarms, such as LOS, LOF, AIS-L,
SF, and SD. If trouble is indicated (for example, a major alarm exists), resolve the problem before
proceeding. See Chapter 8, “Manage Alarms” or, if necessary, refer to the Cisco ONS 15310-MA
SDH Troubleshooting Guide.

In network view, click the Circuits tab.
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To view Partial circuits, click the Filter button and select PARTIAL from the Status drop-down list. The
Partial circuits, if any, are displayed.
To view Partial_TL1 circuits, click the Filter button and select PARTIAL_TL1 from the Status
drop-down list. The Partial_TL1 circuits, if any, are displayed.
Resolve any partial circuits (both Partial and Partial_TL1) in the network before proceeding. However,
if you want to continue with Step 13, match the number of partial circuits and circuit names that existed
before and after adding a path protection node. This ensures that no additional partial circuits are created
after this procedure is completed.
Step 13

Complete the following steps if the node is on the same subnet as other path protection nodes, it is not
provisioned as an ENE (see the “NTP-H21 Set Up CTC Network Access” procedure on page 3-6), and
a CTC computer will directly connect to the node while other CTC computers are directly connected to
other path protection nodes. If not, continue with Step 14.
a.

Click the Provisioning > Network > General tabs. View the IP Address and Net/Subnet Mask
Length fields to verify the node is on the same subnet as other path protection nodes.

b.

Click the Static Routing tab and click Create.

c.

In the Create Static Route dialog box, enter the following settings:

d.

•

Destination IP address: Local-PC-IP-address

•

Net Mask: 255.255.255.255

•

Next Hop: IP-address-of-the-Cisco-ONS-15310- MA

•

Cost: 1

Click OK.

Step 14

(Optional) Create test circuits, making sure they pass through the path protection line ports, and run test
traffic through the node to ensure the ports are functioning properly. See the “NTP-H48 Create a
Manually Routed Optical Circuit” procedure on page 5-35 and the “NTP-H50 Test Optical Circuits”
procedure on page 5-41 for information.

Step 15

Create the DCC terminations on the new node. See the “DLP-H52 Provision Section DCC Terminations”
task on page 16-68.

Step 16

From the View menu, choose Go to Network View.

Step 17

Complete the “DLP-H166 Initiate a Path Protection Force Switch on a Span” task on page 17-58 to
switch traffic away from the span that will be broken to connect to the new node.

Step 18

Two nodes will connect directly to the new node; remove their fiber connections:
a.

Remove the east fiber connection from the node that will connect to the west port of the new node.

b.

Remove the west fiber connection from the node that will connect to the east port of the new node.

Step 19

Replace the removed fibers with the fibers that are connected to the new node.

Step 20

Log out of CTC and log back into a node in the network.

Step 21

From the View menu, choose Go to Network View to display the path protection nodes. The new node
should appear in the network map. Wait for a few minutes to allow all the nodes to appear.

Step 22

Click the Circuits tab and wait for all the circuits to appear, including spans. Count the number of partial
circuits.

Step 23

Ensure that nodes involved in the node addition operation are in the initialized state. This is because,
CTC does not consider nodes that are not initialized (they appear as gray icons in the CTC network map)
when evaluating the circuits.

Cisco ONS 15310-MA SDH Procedure Guide, Release 9.1 and Release 9.2
78-19416-01

13-3

Chapter 13

Add and Remove Nodes

Before You Begin

Note

Step 24 is recommended to be performed only on nodes (the newly added node, and the existing two
nodes in the network between which the new node is added) involved in the node addition operation.
Disable network discovery while launching CTC, add only those nodes involved in the node addition
operation.

Note

CTC automatically creates VT Tunnels. The cross connects should not be created manually in the
intermediate nodes.

Note

Step 24 does not create the overlay ring circuits. To create overlay ring circuits that route traffic around
multiple rings passing through one or more nodes more than once, see the “NTP-H179 Create an Overlay
Ring Circuit” procedure on page 5-52.

Step 24

In the network view, right-click the new node and choose Update Circuits With New Node from the
list of options. Wait for the confirmation dialog box to appear. Verify that the number of updated circuits
in the dialog box is correct (the circuit count should be same as obtained in Step 8).

Step 25

Click the Circuits tab and verify that no partial circuits appear. However, if the partial circuits still exist
in the network, verify whether they were present in Step 8 and Step 12. This will ensure that no
additional partial circuits are created by this procedure.

Step 26

Complete the “DLP-H167 Clear a Path Protection Force Switch” task on page 17-59.

Step 27

(Optional) Complete the “NTP-H32 Path Protection Acceptance Test” procedure on page 4-11.
Stop. You have completed this procedure.

NTP-H98 Remove a Path Protection Node
Purpose

This procedure removes a node from a path protection configuration.

Tools/Equipment

None

Prerequisite Procedures NTP-H102 Back Up the Database, page 14-2
Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Caution

The following procedure minimizes traffic outages during node removals.

Caution

If you remove a node that is the only BITS timing source for the ring, you also remove the only source
of synchronization for all the nodes in that ring. Circuits that connect to other networks which are
synchronized to a Stratum 1 clock will experience a high level of pointer adjustments, which might
adversely affect customer service.
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Step 1

Draw a diagram of the path protection configuration where you will remove the node. In the diagram,
identify the following:
•

The node that is connected through its west port to the node that will be removed (the target node)

•

The node that is connected through its east port to the target node

Step 2

Log into a node in the network where you want to remove a path protection node. See the “DLP-H29
Log into CTC” task on page 16-43 for instructions.

Step 3

Complete the “DLP-H163 Check the Network for Alarms and Conditions” task on page 17-56 to verify
that the path protection configuration is free of alarms. If trouble is indicated (for example, a major alarm
exists), resolve the problem before proceeding. See Chapter 8, “Manage Alarms” or, if necessary, refer
to the Cisco ONS 15310-MA SDH Troubleshooting Guide.

Step 4

Complete the “DLP-H115 Delete Circuits” task on page 17-19 for circuits that originate or terminate in
the target node. (If a circuit has multiple drops, delete only the drops that terminate on the node you are
deleting.)

Step 5

Complete the “DLP-H168 Verify Pass-Through Circuits” task on page 17-59 to verify that circuits
passing through the target node enter and exit the node on the same VC high-order path or VC low-order
path.

Step 6

Complete the “DLP-H166 Initiate a Path Protection Force Switch on a Span” task on page 17-58 for all
spans connected to the node you are removing.

Step 7

Remove all fiber connections between the target node and the two neighboring nodes.

Step 8

Reconnect the fiber of the two neighboring nodes directly, west port to east port.

Note

If you delete a node that was in a login node group, you will see partial circuits for that node in
CTC network view. (Although it is no longer part of the ring, the removed node still reports to
CTC until it is no longer in a login node group.)

Step 9

Exit CTC and log back in. See the “DLP-H29 Log into CTC” task on page 16-43 for instructions.

Step 10

Log into each newly connected node and open the Alarms tab.
a.

Verify that the alarm filter is not on. See the “DLP-H88 Disable Alarm Filtering” task on
page 16-107 as necessary.

b.

Verify that the trunk cards/ports are free of alarms. Resolve any alarms before proceeding. Refer to
the Cisco ONS 15310-MA SDH Troubleshooting Guide.

Step 11

Complete the “DLP-H140 Verify Timing in a Reduced Ring” task on page 17-43.

Step 12

Complete the “DLP-H167 Clear a Path Protection Force Switch” task on page 17-59.

Step 13

Click the Circuits tab and verify that no partial circuits are present.

Step 14

(Optional) Complete the “NTP-H32 Path Protection Acceptance Test” procedure on page 4-11.
Stop. You have completed this procedure.
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NTP-H99 Add an End Node to a Linear ADM
Purpose

This procedure adds a single ONS 15310-MA SDH node to the end of
an ONS 15310 linear add-drop multiplexer (ADM) network.

Tools/Equipment

None

Prerequisite Procedures

NTP-H29 Provision a Linear ADM Network, page 4-6

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Note

Optical transmit and receive levels should be in their acceptable range as shown in the specifications
section for each card in Table 1-2 on page 1-30 for the ONS 15310-MA SDH.

Note

In a linear ADM configuration, two STM-M ports in 1+1 protection are connected to two STM-M ports
in 1+1 protection on a second node. On the second node, two more STM-M ports are connected to a third
node. The third node can be connected to a fourth node, and so on, depending on the number of nodes
in the linear ADM. The ONS 15310-MA SDH has four optical ports and can be added as an end node or in
the middle of a linear ADM.

Note

The two optical ports on the ONS 15310-MA SDH are present on either Slot 3 or Slot 4 of the chassis.
Other ONS 15xxx platforms do not allow a 1+1 protection group to be created if the working and protect
ports are on the same slot. Any of these ports (Slot 3, Port 1-1 or Port 2-1 or Slot 4, Port 1-1 or Port 2-1
for the ONS 15310-MA SDH) can be designated as the working port, depending on your configuration
and fiber connections.

Caution

If the linear ADM carries traffic, you cannot add a node between two linear nodes unless you delete and
recreate the circuits. Use this procedure to add a node to the end of the linear ADM.

Step 1

According to local site practice, complete the “NTP-H102 Back Up the Database” procedure on
page 14-2 for all the nodes in the ring.

Step 2

At the new node, complete one of the following procedures:
•

If the node has not been turned up, complete all procedures in Chapter 3, “Turn Up a Node.”

•

If the node has been turned up, complete the “NTP-H26 Verify Node Turn-Up” procedure on
page 4-2.

Step 3

Verify that the new node has two available optical ports with the same rate as the linear ADM. If the
optical ports are not installed, complete the “DLP-H16 Install SFP Connectors” task on page 16-19. If
the optical ports have different line rates, complete the “DLP-H194 Change the Optical Line Rate” task
on page 17-89.

Step 4

For the ONS 15310-MA SDH, complete “NTP-H142 Create Protection Groups for ONS 15310-MA
SDH” procedure on page 3-10 for the two STM-M ports that will connect to the linear ADM node.
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Step 5

Complete the “DLP-H52 Provision Section DCC Terminations” task on page 16-68 for the working
STM-M port at the new node. Make sure to set the Port State in the Create RS-DCC Termination dialog
box to unlocked. (Do not create a DCC termination on the protect port.)

Note

DCC failure alarms appear after you create DCC terminations in the linear ADM node until you
connect the fiber during Step 13.

Step 6

Complete the “DLP-H29 Log into CTC” task on page 16-43 at the linear ADM node that will connect
to the new node. If you are already logged in, continue with Step 7.

Step 7

Complete the “DLP-H163 Check the Network for Alarms and Conditions” task on page 17-56.

Step 8

Install the STM-M port that will connect to the new node. See “DLP-H16 Install SFP Connectors” task
on page 16-19. If the ports are already installed, continue with Step 9.

Note

If the new node is not an ONS 15310-MA SDH, refer to the corresponding user documentation
for installation procedures.

Step 9

Connect the working port at the existing linear ADM node to the working port at the new node. See
“DLP-H18 Install Fiber-Optic Cables in a 1+1 Configuration” task on page 16-21.

Step 10

Connect the protect port at the existing linear ADM node to the protect port at the new node.

Step 11

Complete NTP-H142 Create Protection Groups for ONS 15310-MA SDH, page 3-10 for the two STM-M
ports that connect to the new node.

Step 12

Complete the “NTP-H142 Create Protection Groups for ONS 15310-MA SDH” procedure on page 3-10
for the two STM-M ports that connect to the new node.

Step 13

Complete the “DLP-H52 Provision Section DCC Terminations” task on page 16-68 for the working
STM-M port that connects to the working port on the new node. Make sure to set the Port State in the
Create RS-DCC Termination dialog box to unlocked. (Do not create a DCC termination for the protect
port.)

Step 14

From the View menu, choose Go to Network View. Verify that the newly created linear ADM
configuration is correct. A green span line should appear between each linear node.

Step 15

Complete the “DLP-H163 Check the Network for Alarms and Conditions” task on page 17-56 to verify
that no unexpected alarms or conditions are present.
Stop. You have completed this procedure.

NTP-H135 Add a Non-ONS 15310-MA Node to a Linear ADM
Purpose

This procedure adds an ONS 15600, ONS 15454, or ONS 15310-MA
SDH between two nodes in a 1+1 configuration. The ONS 15310-MA
SDH has four optical ports and can be added as a middle node.

Tools/Equipment

None
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Prerequisite Procedures

This procedure requires that the node to be added is reachable (has IP
connectivity with CTC).
If the PC running CTC and the ONS 15310-MA SDH nodes are not at
the same location, two technicians who can communicate with each
other during the upgrade might be needed.

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Note

Optical transmit and receive levels should be in their acceptable range as shown in the specifications
section for each card in Table 1-2 on page 1-30 for the ONS 15310-MA SDH.

Note

If overhead circuits exist on the network, an In-Service Topology Upgrade is service affecting. The
overhead circuits will drop traffic and have a status of PARTIAL after the upgrade is complete.

Step 1

Complete the “DLP-H29 Log into CTC” task on page 16-43 at a node on the point-to-point or linear
ADM. If you are already logged in, continue with Step 2.

Step 2

In network view, right-click the span between the two nodes where you want to the new node. The Select
Upgrade Protection dialog box appears.

Step 3

Select Terminal to Linear from the drop-down list. The first page of the wizard, Upgrade Protection:
Terminal to Linear, appears.

Step 4

The Upgrade Protection: Terminal to Linear page lists the following conditions that must be met before
adding a new node:
•

The terminal network has no critical or major alarms.

•

The node that you will add has no critical or major alarms.

•

The node has a compatible software version with that of the terminal nodes.

•

The node has four unused optical ports matching the speed of the 1+1 protection group and no
communications channel has been provisioned on these four ports.

•

Fiber is available to connect the added node to the terminal nodes.

If all of these conditions are met and you wish to continue with the procedure, click Next.

Note

If you are attempting to add an unreachable node, you must first log into the unreachable node
using a separate CTC session and configure that node.

Step 5

Enter the node host name or IP address, or choose the name of the new node from the drop-down list. If
you type in the name, make sure it is identical to the actual node name. The node name is case sensitive.

Step 6

Click Next. The Select Protection Group Ports page appears.

Step 7

Select the working and protect ports on the new node that you want to connect to each terminal node
from the drop-down lists.

Step 8

Click Next. The Re-fiber the Protected Path dialog box appears.

Step 9

Follow the instructions in the dialog box for connecting the fibers between the nodes.
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Step 10

When the fibers are connected properly, click Next. The Update Circuit(s) on Node-Name dialog box
appears.

Note

Step 11

The Back button is not enabled in the wizard. You can click the Cancel button at this point and
choose the Yes button if you want to cancel the Upgrade Protection procedure. If the procedure
fails after you have physically moved the fiber-optic cables, you must restore the fiber-optic
cables to the original positions and verify (through CTC) that traffic is on the working path of
the nodes before restarting the process. To check traffic status, go to node view and click the
Maintenance > Protection tabs. In the Protection Groups area, click the 1+1 protection group.
You can see the status of the traffic in the Selected Group area.

Click Next on the Update Circuit(s) on Node-Name dialog box.
The Force Traffic to Protect Path dialog box appears. This dialog box states that it is about to force the
traffic from the working to protect path for the terminal nodes.

Step 12

When you are ready to proceed, click Next.

Step 13

Follow each step as instructed by the wizard as it guides you through the process of refibering the
working path between nodes and forcing the traffic back to the working path. The final dialog box
informs you when you have completed the procedure.

Step 14

Click Finish.
Stop. You have completed this procedure.

NTP-H101 Remove an In-Service Node from a Linear ADM

Note

Purpose

This procedure removes a single ONS 15600, ONS 15454, pr
ONS 15310-MA SDH node from a linear ADM that contains an
ONS 15310-MA SDH as an end node(s).

Tools/Equipment

None

Prerequisite Procedures

NTP-H29 Provision a Linear ADM Network, page 4-6

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

The 1+1 protection group must be unidirectional in order to delete a node from a linear ADM. If your
1+1 protection group is bidirectional, see the “DLP-H137 Modify a 1+1 Protection Group” task on
page 17-41 to change it to unidirectional. After you have removed the node from the linear group you
can then change the protection setting back to bidirectional.

Step 1

Complete the “DLP-H29 Log into CTC” task on page 16-43 at a node in the network where you will
remove the node.

Step 2

From the View menu, choose Go to Network View.
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Step 3

Click the Alarms tab and click Synchronize.
a.

Verify that the alarm filter is not on. See the “DLP-H88 Disable Alarm Filtering” task on
page 16-107 as necessary.

b.

Verify that no unexplained alarms appear on the network. If unexplained alarms appear, resolve
them before continuing. Refer to the Cisco ONS 15310-MA SDH Troubleshooting Guide if
necessary.

Step 4

On the Conditions tab, and click Retrieve. Verify that no unexplained conditions appear on the network.
If unexplained conditions appear, resolve them before continuing. Refer to the Cisco ONS 15310-MA
SDH Troubleshooting Guide if necessary.

Step 5

On the network map, double-click a node in the 1+1 protection group that is adjacent to the node you
intend to remove (the target node).

Step 6

In node view, click the Maintenance > Protection tabs.

Step 7

Initiate a Force switch on the working port:
a.

In the Protection Groups area, click the 1+1 protection group.

b.

In the Selected Group area, click the working port.

c.

Next to Switch Commands, click Force.

d.

In the Confirm Force Operation dialog box, click Yes.

e.

In the Selected Group area, verify that the following appears:
•

Protect port - Protect/Active [FORCE_SWITCH_TO_PROTECT], [PORT STATE]

•

Working port - Working/Standby [FORCE_SWITCH_TO_PROTECT], [PORT STATE]

Step 8

Repeat Step 5 through Step 7 for the node that is connected directly to the other side of the target node.

Step 9

Remove the fiber from the working ports of the target node.

Step 10

Connect the fiber between the working ports of the two nodes that were directly connected to either side
of the target node.

Step 11

On the node where you initiated a Force switch in Step 8, clear the switch:

Step 12

a.

Next to Switch Commands, click Clear.

b.

In the Confirm Clear Operation dialog box, click Yes.

Initiate a Force switch on the protect port:
a.

In the Selected Group area, click the protect port. Next to Switch Commands, click Force.

b.

In the Confirm Force Operation dialog box, click Yes.

c.

In the Selected Group area, verify that the following appears:
•

Protect port - Protect/Standby [FORCE_SWITCH_TO_WORKING], [PORT STATE]

•

Working port - Working/Active [FORCE_SWITCH_TO_WORKING], [PORT STATE]

Step 13

From the View menu, choose Go to Network View.

Step 14

On the network map, double-click the other node where you initiated a Force switch.

Step 15

In node view, click the Maintenance > Protection tabs.

Step 16

Clear the Force switch on the working port:
a.

In the Protection Groups area, click the 1+1 protection group.

b.

In the Selected Group area, click the working port.

c.

Next to Switch Commands, click Clear.
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d.

In the Confirm Clear Operation dialog box, click Yes.

Step 17

Complete Step 12 to initiate a Force switch on the protect port.

Step 18

Remove the fiber from protect ports of the target node.

Step 19

Connect the fiber between the protect ports of the two nodes on each side of the target node.

Step 20

Clear the Force switch:
a.

Next to Switch Commands, click Clear.

b.

In the Confirm Clear Operation dialog box, click Yes.

c.

In the Selected Group area, verify the following states:
•

Protect port - Protect/Standby

•

Working port - Working/Active

Step 21

Repeat Step 13 through Step 16 to clear the switch on the other node.

Step 22

Exit CTC.

Step 23

Relaunch CTC at any one of the nodes that were adjacent to the target node. The nodes will now show
the circuit status as DISCOVERED when checked.
Stop. You have completed this procedure.
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