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Convert Network Configurations
This chapter explains how to convert from one SDH topology to another in a Cisco ONS 15454 SDH
network. For initial network turn-up, see Chapter 5, “Turn Up a Network.”

Before You Begin
Before performing any of the following procedures, investigate all alarms and clear any trouble
conditions. Refer to the Cisco ONS 15454 SDH Troubleshooting Guide as necessary.
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).
1.

NTP-D338 Convert a Point-to-Point to a Linear ADM Automatically, page 13-2—Complete as
needed.

2.

NTP-D154 Convert a Point-to-Point to a Linear ADM Manually, page 13-4—Complete as needed if
the in-service topology upgrade wizard is not available or you need to back out of the wizard.

3.

NTP-D318 Convert an Unprotected Point-to-Point or Linear ADM to a Two-Fiber MS-SPRing
Automatically, page 13-6—Complete as needed.

4.

NTP-D155 Convert a Point-to-Point or a Linear ADM to a Two-Fiber MS-SPRing Manually, page
13-8—Complete as needed if the in-service topology upgrade wizard is not available or you need to
back out of the wizard.

5.

NTP-D351 Convert a Point-to-Point or Linear ADM to an SNCP Automatically, page
13-10—Complete as needed.

6.

NTP-D156 Convert a Point-to-Point or Linear ADM to an SNCP Manually, page 13-12—Complete
as needed if the in-service topology upgrade wizard is not available or you need to back out of the
wizard.

7.

NTP-D320 Convert an SNCP to a Two-Fiber MS-SPRing Automatically, page 13-13—Complete as
needed.

8.

NTP-D210 Convert an SNCP to a Two-Fiber MS-SPRing Manually, page 13-15—Complete as
needed if the in-service topology upgrade wizard is not available or you need to back out of the
wizard.

9.

NTP-D377 Convert an MS-SPRing to SNCP Manually —Complete as needed.

10. NTP-D211 Convert a Two-Fiber MS-SPRing to a Four-Fiber MS-SPRing Automatically, page

13-18—Complete as needed.
11. NTP-D159 Modify an MS-SPRing, page 13-20—Complete as needed.
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NTP-D338 Convert a Point-to-Point to a Linear ADM
Automatically
Purpose

This procedure upgrades a point-to-point configuration (two nodes) to a
linear add/drop multiplexer (ADM) configuration (three or more nodes)
by adding a node to a 1+1 protection group without losing traffic.

Tools/Equipment

Compatible hardware
Attenuators might be needed for some applications.

Prerequisite Procedures

The in-service topology upgrade procedure requires that the node to be
added is reachable (has IP connectivity with Cisco Transport Controller
[CTC]). Two technicians who can communicate with each other during
the upgrade might be needed if the PC running CTC and the
ONS 15454 SDH nodes are not at the same location.

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Note

Optical transmit and receive levels should be in their acceptable range as shown in Table 2-4 on
page 2-17.

Note

If overhead circuits exist on the network, an in-service topology upgrade is service affecting. The
overhead circuits will drop traffic and have a status of PARTIAL after the upgrade is complete.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at one of the two point-to-point nodes. If
you are already logged in, continue with Step 2.

Step 2

In network view, right-click the span between the two nodes where you want to add the new node. A
dialog box appears.

Step 3

Select Upgrade Protection. A drop-down list appears.

Step 4

Select Terminal to Linear. The Upgrade Protection: Terminal to Linear page appear.

Step 5

The Upgrade Protection: Terminal to Linear page lists the following conditions for adding a new node:
•

The terminal network has no critical or major alarms.

•

The node that you will add has no critical or major alarms.

•

The node has compatible software version with that of the terminal nodes.

•

The node has four unused optical ports matching the speed of the 1+1 protection and no DCC has
been provisioned on these four ports.

•

Fiber is available to connect the added node to the terminal nodes.

If all of these conditions are met and you wish to continue with the procedure, click Next.
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Note

If you are attempting to add an unreachable node you must first log in to the unreachable node
using a separate CTC session and configure that node. Delete any existing protection groups as
described in the “DLP-D155 Delete a Protection Group” task on page 18-48. Delete any existing
SDH DCC terminations as described in the “DLP-D360 Delete a Regenerator-Section DCC
Termination” task on page 20-63.

Step 6

Enter the node host name or IP address or choose the name of the new node from the drop-down list. If
you type in the name, make sure it is identical to the actual node name. The node name is case sensitive.

Step 7

When you have the name of the node in the menu, click Next. The Select Protection Group Ports page
appears (Figure 13-1).

Step 8

From the drop-down lists, select the working and protect ports on the new node that you want to connect
to each terminal node.
Figure 13-1

Step 9

Click Next. The Re-fiber the Protected Path dialog box appears (Figure 13-2).
Figure 13-2

Step 10

Selecting Protection Group Ports

Refibering the Protect Path

Follow the instructions on the page for connecting the fibers between the nodes.
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Step 11

When the fibers are connected properly, click Next. The Update Circuit(s) on Node-Name page appears.

Note

The Back button is not enabled in the wizard. You can click the Cancel button at this point and
choose the Yes button if you want to cancel the upgrade protection procedure. If the procedure
fails after you have physically moved the fiber-optic cables, you will need to restore the
fiber-optic cables to the original positions and verify (through CTC) that traffic is on the working
path of the nodes before restarting the process. To check traffic status go to node view, click the
Maintenance > Protection tabs. In the Protection Groups area, click the 1+1 protection group.
You can see the status of the traffic in the Selected Group area.

Step 12

Click Next on the Update Circuit(s) on Node-Name page to continue with the procedure.

Step 13

The Force Traffic to Protect Path page states that it is about to force the traffic from the working to
protect path for the terminal nodes. When you are ready to proceed, click Next.

Step 14

Follow each step as instructed by the wizard as it guides you through the process of refibering the
working path between nodes and forcing the traffic back to the working path.

Step 15

The Force Traffic to Working Path page states that it is about to force the traffic from the protect to
working path for the terminal nodes. When you are ready to proceed, click Next.

Step 16

The Completed page appears. This page is the final one in the process. Click Finish.

Step 17

Stop. You have completed this procedure.

NTP-D154 Convert a Point-to-Point to a Linear ADM Manually

Caution

Note

Purpose

This procedure upgrades a point-to-point configuration (two nodes) to a
linear ADM configuration (three or more nodes) manually, that is,
without using the in-service topology upgrade wizard. Use this
procedure if the wizard is unavailable or you need to back out of the
wizard.

Tools/Equipment

None

Prerequisite Procedures

NTP-D124 Provision a Point-to-Point Network, page 5-3

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

This procedure is service-affecting.

Optical transmit and receive levels should be in their acceptable range as shown in Table 2-4 on
page 2-17.
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Note

In a point-to-point configuration, two STM-N cards are connected to two STM-N cards on a second
node. The working STM-N ports have data communications channel (DCC) terminations, and the
STM-N cards are in a 1+1 protection group.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at one of the two point-to-point nodes. If
you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

Log into the node that will be added to the point-to-point configuration (the new node).

Step 4

Complete the “NTP-D24 Verify Card Installation” procedure on page 4-2 to ensure that the new node
has two STM-N cards with the same rate as the point-to-point nodes.

Step 5

Complete the “NTP-D35 Verify Node Turn-Up” procedure on page 5-2 for the new node.

Step 6

Physically connect the fibers between the point-to-point node and the new node. The fiber connections
should be connected working card to working card and protect card to protect card.

Step 7

On the new node, create a 1+1 protection group for the STM-N cards that will connect to the
point-to-point node. See the “DLP-D73 Create a 1+1 Protection Group” task on page 17-59.

Step 8

Complete the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66 for the
working STM-N cards in the new node that will connect to the linear ADM network. (Alternatively, if
additional bandwidth is needed for CTC management, complete the “DLP-D364 Provision
Multiplex-Section DCC Terminations” task on page 20-68.) Make sure to set the port administrative
state in the Create RS-DCC Termination dialog box to Unlocked.

Note

DCC failure alarms appear until you create DCC terminations in the point-to-point node.

Step 9

Display the point-to-point node that will connect to the new node in CTC node view.

Step 10

Complete the “NTP-D24 Verify Card Installation” procedure on page 4-2 to ensure that the
point-to-point node has STM-N cards installed that can connect to the new node.

Step 11

Create a 1+1 protection group for the STM-N cards in the point-to-point node that will connect to the
new node. See the “DLP-D73 Create a 1+1 Protection Group” task on page 17-59 for instructions.

Step 12

Create DCC terminations on the working STM-N card in the point-to-point node that will connect to the
new node. See the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66.
(Alternatively, if additional bandwidth is needed for CTC management, complete the “DLP-D364
Provision Multiplex-Section DCC Terminations” task on page 20-68.) In the Create RS-DCC
Termination dialog box, set the port administrative state to Unlocked.

Step 13

From the View menu, choose Go to Node View to display the new node in node view.

Step 14

Complete the “NTP-D28 Set Up Timing” procedure on page 4-10 for the new node. If the new node is
using line timing, set the working STM-N card as the timing source.

Step 15

From the View menu, choose Go to Network View to display the network view to verify that the newly
created linear ADM configuration is correct. One green span line should appear between each linear
node.

Step 16

Click the Alarms tab.
a.

Verify that the alarm filter is not on. See the “DLP-D227 Disable Alarm Filtering” task on
page 19-27 as necessary.
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b.
Step 17

Verify that no unexplained alarms appear on the network. If alarms appear, investigate and resolve
them before continuing. Refer to the Cisco ONS 15454 SDH Troubleshooting Guide for procedures.

Repeat the procedure to add an additional node to the linear ADM.
Stop. You have completed this procedure.

NTP-D318 Convert an Unprotected Point-to-Point or Linear ADM
to a Two-Fiber MS-SPRing Automatically
Purpose

This procedure converts an unprotected point-to-point or linear ADM to
a two-fiber multiplex section-shared protection ring (MS-SPRing)
without disrupting traffic.

Tools/Equipment

None

Prerequisite Procedures

NTP-D44 Provision SNCP Nodes, page 5-21

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Note

Before beginning this procedure, you should have a unique ring name to identify the new MS-SPRing
and a unique node ID number for each node on the ring.

Note

Before beginning this procedure, optical transmit and receive levels should be in their acceptable range
as shown in Table 2-4 on page 2-17.

Note

If overhead circuits exist on the network, an in-service topology upgrade is service affecting. The
overhead circuits will drop traffic and have a status of PARTIAL after the upgrade is complete.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at a node on the point-to-point or linear
ADM. If you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

Complete the “DLP-D155 Delete a Protection Group” task on page 18-48 at the nodes that support the
point-to-point or linear ADM span.

Step 4

Complete the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66 at the
nodes that support the point-to-point or linear ADM span. (Alternatively, if additional bandwidth is
needed for CTC management, complete the “DLP-D364 Provision Multiplex-Section DCC
Terminations” task on page 20-68.) Provision the slot in each node that is not already in the RS-DCC
Terminations list.

Step 5

In the Tools menu, choose Topology Upgrade > Convert SNCP to MS-SPRing.

Step 6

In the Topology Conversion dialog box, set the MS-SPRing properties:
•

Ring Type—(Display only) The default is two-fiber.
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•

Speed—Choose the MS-SPRing ring speed: STM-1, STM-16, or STM-64. The speed must match
the OC-N speed of the MS-SPRing trunk (span) cards.

Note

Step 7

If you are creating an STM-1 MS-SPRing and will eventually upgrade it to STM-16 or
STM-64, use the single-port STM-1 cards (OC12 IR/STM4 SH 1310, OC12 LR/STM4 SH
1310, or OC12 LR/STM4 LH 1550).

•

Ring Name—Assign a ring name. The name can be from 1 to 6 characters in length. Any
alphanumeric string is permissible, and upper and lower case letters can be combined. Do not use
the character string “All” in either upper or lower case letters. This is a TL1 keyword and will be
rejected. Do not choose a name that is already assigned to another MS-SPRing.

•

Reversion time—Set the amount of time that will pass before the traffic reverts to the original
working path following a ring switch. The default is 5 minutes. Ring reversions can be set to Never.

Click Next. If the network graphic appears, go to Step 8.
If CTC determines that a MS-SPRing cannot be created, for example, not enough optical cards are
installed or it finds circuits with subnetwork connection protection (SNCP) selectors, a “Cannot Create
MS-SPRing” message appears. If this occurs, complete the following steps:
a.

Click OK.

b.

In the Create MS-SPRing window, click Excluded Nodes. Review the information explaining why
the MS-SPRing could not be created, then click OK.

c.

Depending on the problem, click Back to start over or click Cancel to cancel the operation.

d.

Complete the “NTP-D40 Provision MS-SPRing Nodes” procedure on page 5-10, making sure all
steps are completed accurately, then start this procedure again.

Step 8

In the network graphic, double-click a MS-SPRing span line. If the span line is DCC connected to other
MS-SPRing cards that constitute a complete ring, the lines turn blue. If the lines do not form a complete
ring, double-click span lines until a complete ring is formed. Click Next.

Step 9

The SNCP to MS-SPRing Topology Conversion dialog box appears. The dialog box states that the
system is about to force traffic to the shortest SNCP paths. Click Next to continue.

Step 10

Another dialog box appears, stating that the force has been applied to the shortest SNCP path. Click
Finish. If the MS-SPRing window appears with the MS-SPRing you created, go to Step 11.
If a “Cannot Create MS-SPRing” or “Error While Creating MS-SPRing” message appears, complete the
following:
a.

Click OK.

b.

In the Create MS-SPRing window, click Excluded Nodes. Review the information explaining why
the MS-SPRing could not be created, then click OK.

c.

Depending on the problem, click Back to start over or click Cancel to cancel the operation.

d.

Complete the “NTP-D40 Provision MS-SPRing Nodes” procedure on page 5-10, making sure all
steps are completed accurately, then start this procedure again.

Note

Step 11

Some or all of the following alarms may briefly appear during MS-SPRing setup: E-W
MISMATCH, RING MISMATCH, APSCIMP, APSDFLTK, and MS-SPRingOSYNC.

Verify the following:
•

On the network map, a green span line appears between all MS-SPRing nodes.
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•

All E-W MISMATCH, RING MISMATCH, APSCIMP, DFLTK, and MS-SPRingOSYNC alarms are
cleared.

Stop. You have completed this procedure.

NTP-D155 Convert a Point-to-Point or a Linear ADM to a
Two-Fiber MS-SPRing Manually
Purpose

This procedure upgrades a point-to-point configuration (two nodes) or a
linear ADM configuration (three or more nodes) to a two-fiber
MS-SPRing manually, that is, without using the in-service topology
upgrade wizard. Use this procedure if the wizard is unavailable or you
need to back out of the wizard.

Tools/Equipment

None

Prerequisite Procedures

NTP-D124 Provision a Point-to-Point Network, page 5-3 or
NTP-D38 Provision a Linear ADM Network, page 5-6

Caution

Note

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

This procedure is service affecting.

Optical transmit and receive levels should be in their acceptable range as shown in Table 2-4 on
page 2-17.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at one of the nodes that you want to convert
from a point-to-point or linear ADM to an MS-SPRing. If you are already logged in, continue with
Step 2.

Step 2

According to local site practice, complete the “NTP-D108 Back Up the Database” procedure on
page 15-5 for each node in the configuration.

Step 3

Check for alarms and conditions. See the “DLP-D298 Check the Network for Alarms and Conditions”
task on page 19-88 for instructions.

Step 4

On the network map, right-click a span adjacent to the node you are logged into. A shortcut menu
appears.

Step 5

From the shortcut menu, click Circuits. The Circuits on Span window appears.

Step 6

Verify that the total number of active VC4 circuits does not exceed 50 percent of the span bandwidth. In
the Circuits column, there is a block titled “Unused.” This number should exceed 50 percent of the span
bandwidth.
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If the span is an STM-16, no more than 8 VC4s can be provisioned on the span. If the span is an
STM-64, no more than 32 VC4s can be provisioned on the span. If the span is an STM-4, no
more than 2 VC4s can be provisioned on the span.

Note

Caution

If the first half of the capacity is exceeded, this procedure cannot be completed. Bandwidth must be
50 percent unassigned to convert to an MS-SPRing. Refer to local procedures for relocating circuits if
these requirements are not met.

Step 7

Repeat Step 4 through Step 6 for each node in the point-to-point or linear ADM that you will convert to
MS-SPRing. When all nodes comply with Step 6, continue with the next step.

Step 8

For every node in the point-to-point or linear ADM network that you want to convert to an MS-SPRing,
complete the following tasks:

Step 9

a.

Complete the “DLP-D189 Verify that a 1+1 Working Slot is Active” task on page 18-75 for every
1+1 protection group that supports a span in the point-to-point or linear ADM network.

b.

Complete the “DLP-D155 Delete a Protection Group” task on page 18-48 at each node that supports
the point-to-point or linear ADM span.

c.

Complete the “DLP-D214 Change the Service State for a Port” task on page 19-11 to put the protect
ports in the Unlocked-enabled service state at each node that supports the point-to-point or linear
ADM span.

(Linear ADM only) Physically remove the protect fibers from all nodes in the linear ADM; for example,
the fiber running from Node 2/Slot 13 to Node 3/Slot 13 can be removed (Figure 13-3).
Figure 13-3

Linear ADM to MS-SPRing Conversion

Linear
ONS 15454 SDH
Node 1

ONS 15454 SDH
ONS 15454 SDH
Node 2
Node 3
Slot 6 to Slot 6
Slot 12 to Slot 12
Slot 5 to Slot 5

Slot 13 to Slot 13
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Slot 5
(West)

Step 10
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ONS 15454 SDH
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Slot 6
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Slot 12
(East)

ONS 15454 SDH
Node 3

Slot 12
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Slot 13
(East)

71271

ONS 15454 SDH
Node 1

Create the ring by connecting the protect fiber from one end node to the protect port on the other end
node. For example, the fiber between Node 1/Slot 5 and Node 2/Slot 5 can be rerouted to connect
Node 1/Slot 5 to Node 3/Slot 13 (Figure 13-3).
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Note

If you need to remove any STM-N cards from the shelf, do so now. In this example, cards in
Node 2/Slots 5 and 13 can be removed. See the “NTP-D227 Remove and Replace a Card”
procedure on page 2-21.

Step 11

From network view, click the Circuits tabs and complete the “DLP-D147 Export CTC Data” task on
page 18-39 to save the circuit data to a file on your hard drive.

Step 12

Complete the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66 at the
end nodes; provision the slot in each node that is not already in the RS-DCC Terminations list (in the
Figure 13-3 example, Port 1 of Node 1/Slot 5 and Port 1 of Node 3/Slot 13). (Alternatively, if additional
bandwidth is needed for CTC management, complete the “DLP-D364 Provision Multiplex-Section DCC
Terminations” task on page 20-68.)

Step 13

For circuits provisioned on a VC4 that is now part of the protection bandwidth (VC4s 3 to 4 for an
STM-4 MS-SPRing, VC4s 9 to 16 for an STM-16 MS-SPRing, and VC4s 33 to 64 for an STM-64),
delete and recreate each circuit:

Step 14

a.

Complete the “DLP-D27 Delete Circuits” task on page 17-21 for one circuit.

b.

Create the circuit on VC4s 1 to 2 for an STM-4 MS-SPRing, 1 to 8 for an STM-16 MS-SPRing, or
1 to 32 for an STM-64 MS-SPRing on the fiber that served as the protect fiber in the linear ADM.
See the “NTP-D324 Create a Manually Routed High-Order Circuit” procedure on page 6-61 for
instructions.

c.

Repeat Steps a and b for each circuit residing on an MS-SPRing protect VC4.

Complete the “NTP-D41 Create the MS-SPRing” procedure on page 5-12 to put the nodes into an
MS-SPRing.
Stop. You have completed this procedure.

NTP-D351 Convert a Point-to-Point or Linear ADM to an SNCP
Automatically

Note

Purpose

This procedure upgrades a point-to-point or linear ADM to an SNCP
without disrupting traffic. You can upgrade synchronous transport signal
(STS), Virtual Tributary (VT), and VT tunnel circuits to SNCP. This
option is a single circuit operation.

Tools/Equipment

None

Prerequisite Procedures

NTP-D124 Provision a Point-to-Point Network, page 5-3

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

When upgrading VT tunnels, CTC does not convert the VT tunnel to SNCP, but instead creates a
secondary tunnel for the alternate path. The result is two unprotected VT tunnels using alternate paths.
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Note

If overhead circuits exist on the network, an in-service topology upgrade is service affecting. The
overhead circuits will drop traffic and have a status of PARTIAL after the upgrade is complete.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at a node on the point-to-point or linear
ADM. If you are already logged in, continue with Step 2.

Step 2

If the point-to-point or linear ADM is 1+1 protected, complete the “DLP-D155 Delete a Protection
Group” task on page 18-48. If the point-to-point or linear ADM is unprotected, continue with Step 3.

Step 3

Complete the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66 at the
nodes that support the point-to-point or linear ADM span. (Alternatively, if additional bandwidth is
needed for CTC management, complete the “DLP-D364 Provision Multiplex-Section DCC
Terminations” task on page 20-68.) Provision the slot in each node that is not already in the RS-DCC
Terminations list.

Step 4

From network or node view, click the Circuits tab. Click the circuit you want to upgrade.

Step 5

From the Tools menu, choose Topology Upgrade > Convert Unprotected to SNCP.

Step 6

To set the SNCP parameters, complete the “DLP-D218 Provision SNCP Ring Selectors During Circuit
Creation” task on page 19-19.

Note

When upgrading point-to-point or linear ADM circuits to an SNCP topology, a traffic hit of
greater than 300 ms occurs if the “Provision working go & return on primary path” routing
option is not checked in the Circuit Attributes pane.

Step 7

Click Next.

Step 8

Complete one of the following tasks:
a.

To route the new SNCP circuit automatically, complete the “DLP-D471 Automatically Route an
SNCP Circuit for a Topology Upgrade” task on page 21-48.

b.

To route the new SNCP circuit manually, complete the “DLP-D470 Manually Route an SNCP
Circuit for a Topology Upgrade” task on page 21-47.

Stop. You have completed this procedure.
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NTP-D156 Convert a Point-to-Point or Linear ADM to an SNCP
Manually
Purpose

This procedure upgrades a point-to-point or linear ADM configuration
to a SNCP ring manually, that is, without using the in-service topology
upgrade wizard. Use this procedure if the wizard is unavailable or you
need to back out of the wizard.

Tools/Equipment

None

Prerequisite Procedures

NTP-D124 Provision a Point-to-Point Network, page 5-3 or
NTP-D38 Provision a Linear ADM Network, page 5-6

Caution

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

This procedure is service affecting. All circuits are deleted and reprovisioned.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at a node on the point-to-point or linear
ADM. If you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

Complete the “DLP-D189 Verify that a 1+1 Working Slot is Active” task on page 18-75 for each node.

Step 4

Complete the “DLP-D155 Delete a Protection Group” task on page 18-48 for each 1+1 protection group
that supports the point-to-point or linear ADM span.

Step 5

Complete the “DLP-D363 Provision Regenerator-Section DCC Terminations” task on page 20-66 at the
protect cards in all nodes that will be part of the SNCP ring. Alternatively, if additional bandwidth is
needed for CTC management, complete the “DLP-D364 Provision Multiplex-Section DCC
Terminations” task on page 20-68.

Step 6

Complete the “DLP-D27 Delete Circuits” task on page 17-21 and the “NTP-D323 Create an
Automatically Routed High-Order Circuit” procedure on page 6-56 to delete and recreate the circuits
one at a time.

Note

If you want to add additional nodes to the SNCP, see the “NTP-D360 Add an SNCP Node” procedure
on page 14-10.

Note

An SNCP is the default configuration if the cards installed are installed and the DCCs are configured.
Stop. You have completed this procedure.
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NTP-D320 Convert an SNCP to a Two-Fiber MS-SPRing
Automatically
Purpose

This procedure converts a SNCP to a two-fiber MS-SPRing without
disrupting traffic.

Tools/Equipment

None

Prerequisite Procedures

NTP-D44 Provision SNCP Nodes, page 5-21

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Note

Open-ended SNCP and SNCP dual-ring interconnect (DRI) configurations do not support in-service
topology upgrades.

Note

Before beginning this procedure, you should have a unique ring name to identify the new MS-SPRing
and a unique node ID number for each node on the ring.

Note

Before beginning this procedure, optical transmit and receive levels should be in their acceptable range
as shown in Table 2-4 on page 2-17.

Note

If overhead circuits exist on the network, an in-service topology upgrade is service affecting. The
overhead circuits will drop traffic and have a status of PARTIAL after the upgrade is complete.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at a node on the SNCP. If you are already
logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

From the Tools menu, choose Topology Upgrade > Convert SNCP to MS-SPRing.

Step 4

In the SNCP to MS-SPRing Topology Conversion dialog box, set the MS-SPRing properties:
•

Ring Type—(Display only) The default is two-fiber.

•

Speed—Choose the MS-SPRing ring speed: STM-1, STM-16, or STM-64. The speed must match
the OC-N speed of the MS-SPRing trunk (span) cards.

Note

•

If you are creating an STM-1 MS-SPRing and will eventually upgrade it to STM-16 or
STM-64, use the single-port STM-1 cards (OC12 IR/STM4 SH 1310, OC12 LR/STM4 SH
1310, or OC12 LR/STM4 LH 1550).

Ring Name—Assign a ring name. The name can be from 1 to 6 characters in length. Any
alphanumeric string is permissible, and upper and lower case letters can be combined. Do not use
the character string “All” in either upper or lower case letters. This is a TL1 keyword and will be
rejected. Do not choose a name that is already assigned to another MS-SPRing.
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•
Step 5

Reversion time—Set the amount of time that will pass before the traffic reverts to the original
working path following a ring switch. The default is 5 minutes. Ring reversions can be set to Never.

Click Next. If the SNCP to MS-SPRing Topology Conversion dialog box with the network graphic
appears, go to Step 6.
If CTC determines that a MS-SPRing cannot be created, for example, not enough optical cards are
installed or it finds circuits with SNCP selectors, a “Cannot Create MS-SPRing” message appears. If this
occurs, complete the following steps:
a.

Click OK.

b.

In the Create MS-SPRing window, click Excluded Nodes. Review the information explaining why
the MS-SPRing could not be created, then click OK.

c.

Depending on the problem, click Back to start over or click Cancel to cancel the operation.

d.

Complete the “NTP-D40 Provision MS-SPRing Nodes” procedure on page 5-10, making sure all
steps are completed accurately, then start this procedure again.

Step 6

In the network graphic, double-click a MS-SPRing span line. If the span line is DCC connected to other
MS-SPRing cards that constitute a complete ring, the lines turn blue. If the lines do not form a complete
ring, double-click span lines until a complete ring is formed. Click Next.

Step 7

The next SNCP to MS-SPRing Topology Conversion page appears. The page states that the system is
about to force traffic to the shortest SNCP paths. Click Next to continue.

Step 8

Another page appears, stating that the force has been applied to the shortest SNCP path. Click Finish.
If the MS-SPRing window appears with the MS-SPRing you created, go to Step 9. If a “Cannot Create
MS-SPRing” or “Error While Creating MS-SPRing” message appears, complete the following:
a.

Click OK.

b.

In the Create MS-SPRing window, click Excluded Nodes. Review the information explaining why
the MS-SPRing could not be created, then click OK.

c.

Depending on the problem, click Back to start over or click Cancel to cancel the operation.

d.

Complete the “NTP-D40 Provision MS-SPRing Nodes” procedure on page 5-10, making sure all
steps are completed accurately, then start this procedure again.

Note

Step 9

Some or all of the following alarms might briefly appear during MS-SPRing setup:
E-W MISMATCH, RING MISMATCH, APSCIMP, APSDFLTK, and MS-SPRingOSYNC.

Verify the following:
•

On the network view graphic, a green span line appears between all MS-SPRing nodes.

•

All E-W MISMATCH, RING MISMATCH, APSCIMP, DFLTK, and MS-SPRingOSYNC alarms are
cleared. Refer to the Cisco ONS 15454 SDH Troubleshooting Guide for alarm troubleshooting.

Stop. You have completed this procedure.
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NTP-D210 Convert an SNCP to a Two-Fiber MS-SPRing
Manually
Purpose

This procedure converts an SNCP to an MS-SPRing manually, that is,
without using the in-service topology upgrade wizard. Use this
procedure if the wizard is unavailable or you need to back out of the
wizard.

Tools/Equipment

None

Prerequisite Procedures

NTP-D44 Provision SNCP Nodes, page 5-21

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Caution

This procedure is service affecting. All circuits on the ring are deleted and reprovisioned.

Caution

Read through this procedure completely before beginning the conversion.

Note

Prior to beginning this procedure, you should have a unique ring ID name to identify the new MS-SPRing
and a unique node ID number for each node on the ring.

Note

Prior to beginning this procedure, optical transmit and receive levels should be in their acceptable range
as shown in Table 2-4 on page 2-17.

Step 1

Log into an ONS 15454 SDH on the network where you will begin the ring conversion. See the
“DLP-D60 Log into CTC” task on page 17-44. If you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

On the network map, right-click a span adjacent to the node you are logged into. A shortcut menu
appears.

Step 4

From the shortcut menu, click Circuits. The Circuits on Span window appears.

Step 5

Verify that the total number of active VC4 circuits does not exceed 50 percent of the span bandwidth. In
the Circuits column, there is a block titled “Unused.” This number should exceed 50 percent of the span
bandwidth.

Note

If the span is an STM-16, no more than 8 VC4s can be provisioned on the span. If the span is an
STM-64, no more than 32 VC4s can be provisioned on the span. If the span is an STM-4, no
more than 2 VC4s can be provisioned on the span.
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Caution

If the first half of the capacity is exceeded, this procedure cannot be completed. Bandwidth must be
50 percent unassigned to convert to MS-SPRing. Refer to your site plan for relocating circuits if these
requirements are not met.

Step 6

Repeat Steps 1 to 5 for each node in the SNCP that you will convert to an MS-SPRing. When all nodes
comply with Step 5, continue with the next step.

Step 7

Save all circuit information:

Step 8

a.

In network view, click the Circuits tab.

b.

Record the circuit information using one of the following options:
•

From the File menu, click Print to print the circuits table. See the “DLP-D146 Print CTC Data”
task on page 18-37.

•

From the File menu, click Export and choose the data format: HTML, CSV (comma separated
values), or TSV (tab separated values). Click OK and save the file in a temporary directory. See
the “DLP-D147 Export CTC Data” task on page 18-39.

Delete the circuits:

Note

This method uses the network view. To delete circuits one at a time from each node, see the
“DLP-D27 Delete Circuits” task on page 17-21.

a.

In network view, click the Circuits tab. All circuits on the ring appear.

b.

With the Ctrl key pressed, click each circuit. Each line turns dark blue as it is selected.

c.

After all circuits have been selected, click Delete. Allow several minutes for processing; the actual
length of time depends on the number of circuits in the network.

Step 9

Complete the “NTP-D41 Create the MS-SPRing” procedure on page 5-12 to create the MS-SPRing.

Step 10

To recreate the circuits, see Chapter 6, “Create Circuits and Low-Order Tunnels.” and choose the
applicable procedure for the circuit type you want to enter.

Note

To add additional nodes to an MS-SPRing, see the “NTP-D359 Add an MS-SPRing Node”
procedure on page 14-2.

Stop. You have completed this procedure.
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NTP-D377 Convert an MS-SPRing to SNCP Manually

Note

Purpose

This procedure converts an MS-SPRing to SNCP manually.

Tools/Equipment

None

Prerequisite Procedures

NTP-D40 Provision MS-SPRing Nodes, page 5-10

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

You cannot convert an MS-SPRing to SNCP automatically or by using the in-service topology upgrade
wizard.

Caution

This procedure is service affecting. All circuits on the ring are deleted and reprovisioned.

Caution

Read through this procedure completely before beginning the conversion.

Note

Prior to beginning this procedure, you should have a unique ring ID name to identify the new SNCP and
a unique node ID number for each node on the ring.

Note

Prior to beginning this procedure, optical transmit and receive levels should be in their acceptable range
as shown in Table 2-4 on page 2-17.

Step 1

Log into an ONS 15454 SDH on the network where you will begin the ring conversion. See the
“DLP-D60 Log into CTC” task on page 17-44. If you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

Repeat Steps 1 and 2 for each node in the MS-SPRing that you will convert to an SNCP.

Step 4

Save all circuit information:

Step 5

a.

In network view, click the Circuits tab.

b.

Record the circuit information using one of the following options:
•

From the File menu, click Print to print the circuits table. See the “DLP-D146 Print CTC Data”
task on page 18-37.

•

From the File menu, click Export and choose the data format: HTML, CSV (comma separated
values), or TSV (tab separated values). Click OK and save the file in a temporary directory. See
the “DLP-D147 Export CTC Data” task on page 18-39.

Convert the MS-SPRing:
a.

From the View menu, choose Go to Network View. Click the Provisioning > MS-SPRing tabs.
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b.

With the Ctrl key pressed, select all the MS-SPRing that you want to convert and click Delete. In
the confirmation dialog box that appears, click Yes.

If an error message is displayed, rectify the error and then delete the MS-SPRing. For more
information, refer to Cisco ONS 15454 SDH Troubleshooting Guide.

Note

c.

As needed, perform one of the following steps to upgrade the circuit to SNCP:
– Complete the NTP-D351 Convert a Point-to-Point or Linear ADM to an SNCP Automatically,

page 13-10.
– Complete the NTP-D156 Convert a Point-to-Point or Linear ADM to an SNCP Manually, page

13-12.
Step 6

In network view, verify the following:
•

The Protection column in the Circuits tab displays SNCP.

•

The Edit Circuit window displays working and alternate paths of nodes and spans in the circuit.

Stop. You have completed this procedure.

NTP-D211 Convert a Two-Fiber MS-SPRing to a Four-Fiber
MS-SPRing Automatically
Purpose

This procedure upgrades a two-fiber MS-SPRing to a four-fiber
MS-SPRing without disrupting traffic. The conversion will be easier if
the same east and west configuration is used on all nodes being
upgraded.

Tools/Equipment

None

Prerequisite Procedures

NTP-D41 Create the MS-SPRing, page 5-12

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Note

Two-fiber STM-16 or STM-64 MS-SPRings can be converted to four-fiber MS-SPRings. To convert, you
install two additional STM-16 or STM-64 cards at each two-fiber MS-SPRing node, then log into CTC
and convert the MS-SPRing from two-fiber to four-fiber. The fibers that were divided into working and
protect bandwidths for the two-fiber MS-SPRing are now fully allocated for working MS-SPRing traffic.
A span upgrade can be performed prior to the two-fiber to four-fiber MS-SPRing conversion.

Note

MS-SPRing protection channel access (PCA) circuits, if present, will remain in their existing VC4s.
Therefore, they will be located on the working path of the four-fiber MS-SPRing and will have full
MS-SPRing protection. To route PCA circuits on protection channels in the four-fiber MS-SPRing,
delete and recreate the circuits after the upgrade. For example, if you upgrade a two-fiber STM-16
MS-SPRing to four-fiber, PCA circuits on the protection VC4s (VCs 8 to 16) in the two-fiber
MS-SPRing will remain in their existing VC4s, which are working VC4s in the four-fiber MS-SPRing.
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Deleting and recreating the STM-16 PCA circuits moves the circuits to VC4s 1 to 7 in the protect
bandwidth of the four-fiber MS-SPRing. To delete circuits, see the “NTP-D288 Modify and Delete
Overhead Circuits and Server Trails” procedure on page 7-4. To create circuits, see Chapter 6, “Create
Circuits and Low-Order Tunnels.”

Note

Before beginning this procedure, optical transmit and receive levels should be in their acceptable range
as shown in Table 2-4 on page 2-17.

Note

If you use source and drop cards that are already carrying traffic to upgrade a two-fiber MS-SPRing to
a four-fiber MS-SPRing, the APSC-IMP alarms will generate and remain outstanding.

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at one of the two-fiber nodes that you want
to convert.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88.

Step 3

Complete the “NTP-D16 Install STM-N Cards and Connectors” procedure on page 2-7 to install two
STM-16 or STM-64 cards at each MS-SPRing node. You must install the same STM-N card rate as the
two-fiber MS-SPRing.

Step 4

Connect the fiber to the new cards. Use the same east-west connection scheme that was used to create
the two-fiber connections. See the “DLP-D338 Install Fiber-Optic Cables for MS-SPRing
Configurations” task on page 20-36.

Step 5

Complete the “DLP-D214 Change the Service State for a Port” task on page 19-11 to put the ports in the
Unlocked-enabled service state on each new STM-N card.

Step 6

Test the new fiber connections using procedures standard for your site.

Step 7

Convert the MS-SPRing:
a.

From the View menu, choose Go to Network View. Click the Provisioning > MS-SPRing tabs.

b.

Choose the two-fiber MS-SPRing you want to convert, then click the Upgrade to 4 Fiber button.

c.

In the Upgrade MS-SPRing dialog box, set the amount of time that will pass before the traffic reverts
to the original working path after the condition that caused the switch has been resolved. The default
is 5 minutes.

d.

Click Next.

e.

Assign the east and west protection ports:

f.
Step 8

•

West Protect—Select the west MS-SPRing port that will connect to the west protect fiber from
the drop-down list.

•

East Protect—Select the east MS-SPRing port that will connect to the east protect fiber from
the drop-down list.

Click Finish.

Click the Alarms tab.
a.

Verify that the alarm filter is not on. See the “DLP-D227 Disable Alarm Filtering” task on
page 19-27 as necessary.

b.

Verify that no unexplained alarms appear on the network. If alarms appear, investigate and resolve
them before continuing. Refer to the Cisco ONS 15454 SDH Troubleshooting Guide for procedures.
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Step 9

Complete the “NTP-D342 Four-Fiber MS-SPRing Acceptance Test” procedure on page 5-15.
Stop. You have completed this procedure.

NTP-D159 Modify an MS-SPRing
Purpose

This procedure changes an MS-SPRing ring ID, node ID, or ring and span
reversion times.

Tools/Equipment

None

Prerequisite Procedures DLP-D468 Create a Two-Fiber MS-SPRing Using the MS-SPRing Wizard,
page 21-44
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Step 1

Complete the “DLP-D60 Log into CTC” task on page 17-44 at a node in the MS-SPRing that you want
to modify. If you are already logged in, continue with Step 2.

Step 2

Complete the “DLP-D298 Check the Network for Alarms and Conditions” task on page 19-88 for
instructions.

Note

Step 3

Some or all of the following alarms appear during MS-SPRing setup: E-W MISMATCH,
RING MISMATCH, APSCIMP, APSDFLTK, and MSSP-OSYNC. The alarms clear after you
configure all the nodes in the MS-SPRing. For definitions of these alarms, see the
Cisco ONS 15454 SDH Troubleshooting Guide.

To change the MS-SPRing ring name or the ring or span reversion times, complete the following steps.
If you want to change a node ID, continue with Step 4.
a.

Switch to network view and click the Provisioning > MS-SPRing tabs.

b.

Click the MS-SPRing you want to modify and click Edit.

c.

In the MS-SPRing window, change any of the following:
– Ring Name—If needed, change the MS-SPRing ring name. The name can be from 1 to 6

characters in length. The alphanumeric character strings that can be used are 0 to 9 and A to Z.
You can combine numbers and letters and use upper or lower case letters. Do not use the
character string “All” in either upper or lower case letters because it is a TL1 keyword. Do not
choose a name that is already assigned to another MS-SPRing.
– Reversion time—If needed, change the amount of time that will pass before the traffic reverts

to the original working path after a ring switch.
– Span Reversion—(Four-fiber MS-SPRings only) If needed, change the amount of time that will

pass before the traffic reverts to the original working path after a span switch.
d.

Click Apply.

e.

If you changed the ring name, the MS-SPRing window closes automatically. If you only changed a
reversion time, close the window by choosing Close from the File menu.
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Step 4

As needed complete the “DLP-D24 Change an MS-SPRing Node ID” task on page 17-19; otherwise,
continue with Step 5.

Step 5

In network view, verify the following:
•

A green span line appears between all MS-SPRing nodes.

•

All E-W MISMATCH, RING MISMATCH, APSCIMP, DFLTK, MSSP-OSYNC, and Node ID
Mismatch alarms are cleared.

Note

For definitions of these alarms, see the Cisco ONS 15454 SDH Troubleshooting Guide.

Stop. You have completed this procedure.
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