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Upgrading Software Release 2.2.x to 4.0.x Using 
the TCC+ Card

This chapter explains how to upgrade Cisco ONS 15454’s Cisco Transport Controller (CTC) software 
from Software Release 2.2.x to Software R4.0.x using the Timing, Communications, and Control + 
(TCC+) card.

Before You Begin
Before beginning, write down the following information about your site; the data will be useful during 
and after the upgrade: date, street address, site phone number, and dial up number.

Caution Read each procedure before you begin the upgrade.

Caution This chapter supports Software R2.2.x only. If you want to upgrade from Releases 3.0 – 3.4, use the 
procedures in Chapter 2, “Upgrading Release 3.x to 4.0.x Using the TCC+ Card.” If you want to upgrade 
from a release prior to Release 2.2.0, contact the Technical Assistance Center (TAC). For contact 
information, see the “Obtaining Technical Assistance” section on page ix.

Note Perform the procedures in this chapter in consecutive order unless otherwise noted. In general, you are 
not done with a procedure until you have completed it for each node you are upgrading, and you are not 
done with the upgrade until you have completed each procedure that applies to your network. If you are 
new to upgrading the ONS 15454, you may want to check off each procedure on your printed copy of 
this chapter as you complete it.

Note For a description of non-trouble procedures (NTP) and detailed level procedures (DLP), see the 
“Document Organization” section on page vi.

This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

1. NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade, page 1-2—This procedure contains 
critical information and tasks that you must read and complete before beginning the upgrade 
process. 
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NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade
2. NTP-U2 Back Up the Software R2.2.x Database, page 1-5—Complete the database backup to ensure 
that you have preserved your node and network provisioning in the event that you need to restore 
them.

3. NTP-U3 Upgrade the TCC Card to the TCC+ Card, page 1-6—Complete this procedure if you have 
any TCC cards installed.

4. NTP-U20 Upgrade Software R2.2.x to Software R4.0.x, page 1-8—You must complete this entire 
procedure before the upgrade is finished.

5. NTP-U5 Revert to Previous Software Load and Database, page 1-18—Complete this procedure only 
if you need to return to the software load you were running before activating Software R4.0.x.

6. NTP-U6 Upgrade the TCC+ Card to the TCC2 Card, page 1-23—Complete this procedure only if 
you want to upgrade the TCC+ card to a TCC2 card.

NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade

Step 1 Read the Release Notes for Cisco ONS 15454 Release 4.0.x.

Step 2 Log into the node that you will upgrade. For detailed instructions, refer to the Cisco ONS 15454 
Procedure Guide. 

Step 3 Complete the “DLP-U1 Verify CTC Workstation Requirements” task on page 1-3.

Disable all other Ethernet devices (such as a dial-up adapter) on the workstation that runs CTC. For more 
information, see the “Obtaining Technical Assistance” section on page ix.

If you have multiple IP addresses on your workstation, you should remove them; you cannot run CTC 
Release 2.2.x if multiple IP addresses are configured. 

Step 4 Complete the “DLP-U2 Verify LAN Connections” task on page 1-4

Step 5 Complete the “DLP-U3 Verify Common Control Cards” task on page 1-4.

Step 6 Complete the “DLP-U4 Verify Alarm Interface Panel” task on page 1-4.

Step 7 When you have completed the tasks for this section, proceed with the “NTP-U2 Back Up the Software 
R2.2.x Database” procedure on page 1-5.

Stop. You have completed this procedure.

Purpose This procedure steps you through the critical information checks and tasks 
you must complete before beginning an upgrade.

Tools/Equipment PC or UNIX workstation; Cisco ONS 15454 Release 4.0.x software.

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Superuser
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NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade
DLP-U1 Verify CTC Workstation Requirements

Step 1 Ensure that your workstation is either one of the following:

• IBM-compatible PC with a Pentium or higher processor, CD-ROM drive, and 128 MB RAM running 
Windows 95, Windows 98, Windows 2000, or Windows NT

• UNIX workstation running any Solaris release

Step 2 Ensure that your web browser software is one of the following:

• Netscape Navigator 4.73 or higher (Netscape Navigator is included on the ONS 15454 software CD 
shipped with the node)

• Internet Explorer 4.0.x Service Pack 2 or higher 

Step 3 Verify the following:

• The Java Version installed on your computer is Java Runtime Environment (JRE) Release 1.3.1_02. 
You can check this on your browser window after entering the node IP address in the URL window 
under Java Version.

• The Java Policy file is installed on your computer. 

Note If you need to install either the JRE 1.3.1_01 or the Java Policy file, they are included on the 
ONS 15454 software CD. For detailed installation instructions, refer to the Cisco ONS 15454 
Procedure Guide.

Note When you upgrade to JRE 1.3.1_02, you will no longer be able to log into an ONS 15454 running 
Release 2.2.1 or prior, or an ONS 15327 running release 1.0.0. If you must later revert to a 
release that requires a previous version of the JRE, you will have to reinstall Java and delete the 
JAR files from your workstation’s user TEMP directory after reverting all of the nodes in the 
network. If you are currently running a release that is also compatible with JRE 1.3.1_02, the 
extra steps are not necessary. 

Step 4 Return to your originating procedure (NTP).

Purpose Before upgrading the workstation to run CTC Release 4.0.x, verify all PC 
or UNIX workstation hardware and software requirements.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U2 Verify LAN Connections

Step 1 If you have multiple ONS 15454 nodes configured in the same IP subnet, ensure that only one is 
connected to a router. Otherwise, the remaining nodes might be unreachable. Refer to the 
Cisco ONS 15454 Reference Manual for LAN-connection suggestions.

Step 2 Return to your returning procedure (NTP).

DLP-U3 Verify Common Control Cards

Step 1 Ensure that the cards are installed. The TCC+ cards are in Slots 7 and 11 and the XC/XCVT/XC10G 
cross connect cards are in Slots 8 and 10. Release 2.2.x does not support simplex operation.

Step 2 Repeat Step 1 at every node in the network.

Step 3 Return to your originating procedure (NTP).

DLP-U4 Verify Alarm Interface Panel

Purpose Use this procedure to ensure that LAN connections are correct.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U1 Verify CTC Workstation Requirements, page 1-3

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of a PC or UNIX workstation)

Security Level Superuser

Purpose This task verifies that two TCC+ cards and two cross-connect cards (two 
XCs, two XCVTs, or two XC10G) are installed at each node.

Tools/Equipment PC or UNIX workstation with CTC installed

Prerequisite Procedures DLP-U2 Verify LAN Connections, page 1-4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser

Purpose Use this task to ensure Alarm Interface Panel quality.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U3 Verify Common Control Cards, page 1-4

Required/As Needed Required

Onsite/Remote Onsite

Security Level Superuser
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NTP-U2 Back Up the Software R2.2.x Database
Caution If any of your nodes has an AIP board with the part number 67-xx-xxxxx, where each “x” can be any 
number or letter, the board must be replaced. Perform the following steps to ensure that all of your AIPs 
are good.

Step 1 Look at the back of your ONS 15454 node and locate the green board with “AIP” stamped into the right 
hand side (the writing will be sideways as you face the board). 

Step 2 Locate the sticker with the part number. The number should be preceded by “P/N” on the sticker. 

Note If there is no sticker with a part number, the number may be stamped into the board itself. If you 
cannot find the part number, contact TAC. For contact information, see the “Obtaining Technical 
Assistance” section on page ix.

Step 3 If the part number is any number other than 67-xx-xxxxx, go to the next node and start from Step 1 again.

Step 4 If the part number is any 67-xx-xxxxx combination, contact TAC to request a Return Materials 
Authorization (RMA).

Step 5 Repeat Steps 1 through 4 for every node.

Step 6 Return to your originating procedure (NTP).

NTP-U2 Back Up the Software R2.2.x Database

Step 1 Log into CTC. For detailed instructions, refer to the Cisco ONS 15454 Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 In the node (default) view, click the Maintenance > Database tabs.

Step 3 Click Backup.

Step 4 Save the database on the workstation's hard drive or on network storage. Use an appropriate file name 
with the file extension .db (for example, myDatabase.db).

Step 5 Click Save. A message appears indicating that the backup is complete.

Step 6 Click OK.

Step 7 Repeat Steps 1 through 6 for each node in the network.

Purpose Use this procedure to preserve all configuration data for your network 
before performing the upgrade.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade, page 1-2

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U3 Upgrade the TCC Card to the TCC+ Card
Step 8 (Optional) Cisco recommends that you manually log critical information by either writing it down or 
printing screens where applicable. Use the following table to determine the information you should log; 
complete the table (or your own version) for every node in the network.

Step 9 You must be using TCC+ cards and not TCC cards to upgrade to Release 4.0.x. If you have any TCC 
cards installed, you must first upgrade them to TCC+ cards before continuing with the software upgrade. 
Complete the “NTP-U3 Upgrade the TCC Card to the TCC+ Card” procedure on page 1-6. If you do not 
have any TCC cards, proceed with the “NTP-U20 Upgrade Software R2.2.x to Software R4.0.x” 
procedure on page 1-8.

Stop. You have completed this procedure.

NTP-U3 Upgrade the TCC Card to the TCC+ Card

Table 1-1 Manually Logged Data

Item Record data here (if applicable)

IP address of the node

Node name 

Timing settings

DCC connections; list all optical ports that have DCCs 
activated

User IDs (List all, including at least one super user)

Inventory; do a print screen from the inventory window

Active TCC+ Slot 7 or Slot 11 (circle one)

Active XC Slot 8 or Slot 10 (circle one)

Network information; do a print screen from the 
Provisioning tab in the network view.

Current configuration: BLSR, linear, etc. (do print screens as 
needed)

List all protection groups in the system; do a print screen 
from the protection group window

List alarms; do a print screen from the alarm window

List circuits; do a print screen from the circuit window

Purpose This procedure upgrades the TCC card to the TCC+ card.

Tools/Equipment Two TCC+ cards

Prerequisite Procedures NTP-U2 Back Up the Software R2.2.x Database, page 1-5

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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NTP-U3 Upgrade the TCC Card to the TCC+ Card
Step 1 Verify that your database was backed up before starting.

Step 2 Before you install TCC+ cards, verify that the node you are upgrading has ONS 15454 Software R2.2.x. 
The TCC card to TCC+ card upgrade process requires Release 2.2.x to support the TCC/TCC+ card 
mismatch that occurs briefly during the TCC card to TCC+ card upgrade process.

Step 3 Physically replace the standby TCC card on the ONS 15454 with a TCC+ card. The ACT/STBY LED 
indicator should be lit amber for standby TCC cards.

a. Open the TCC card ejectors.

b. Slide the card out of the slot. This raises the IMPROPRMVL alarm which will clear when the upgrade 
is complete.

c. Open the ejectors on the TCC+ card.

d. Slide the TCC+ card into the slot along the guide rails.

e. Close the ejectors.

Note The MEA (card mismatch) alarm appears because CTC recognizes a mismatch between TCC 
card types. Disregard this alarm; it clears by the end of the procedure.

Note It takes approximately 20 or 30 minutes for the active TCC card to transfer the system 
software to the newly-installed TCC+ card. Software transfer occurs in instances where 
different software versions exist on the two cards. During this operation, the LEDs on the 
TCC+ card flash Fail and then the active/standby LED flashes. When the transfer completes, 
the TCC+ card reboots and goes into standby mode after approximately three minutes.

Step 4 Right click the active TCC card to reveal a pull-down menu.

Step 5 Choose Reset Card.

Wait for the TCC card to reboot. The ONS 15454 switches the standby TCC+ card to active mode.

Step 6 Verify that the remaining TCC card is now in standby mode (the ACT/STBY LED changes to amber). 

Step 7 Physically replace the remaining TCC card with the second TCC+ card.

a. Open the TCC card ejectors.

b. Slide the card out of the slot.

c. Open the ejectors on the TCC+ card.

d. Slide the TCC+ card into the slot along the guide rails.

e. Close the ejectors.

The ONS 15454 boots up the second TCC+ card. The second TCC+ card must also copy the system 
software, which can take up to 20 or 30 minutes. The MEA alarm clears when the ONS 15454 recognizes 
the matching TCC+ cards.

Tip When a newly installed TCC+ card has a different version of the ONS 15454 software installed than the 
version running on the active TCC+ card, the newly installed TCC+ card automatically copies the 
software version running on the active TCC+ card. You do not need to do anything in this situation. 
However, the loading TCC+ card does not boot up in the normal manner. When the card is first inserted, 
the red FAIL LED stays on for a short period. The FAIL LED then blinks normally and all LEDs go dark. 
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The FAIL LED and the ACT/STBY LED flash alternately every 30 to 45 seconds as the new software 
loads onto the new TCC+ card. After loading the new software for approximately 30 minutes, the TCC+ 
card becomes the standby card and the amber LED is illuminated.

Step 8 When you have upgraded to TCC+ cards, proceed to the “NTP-U20 Upgrade Software R2.2.x to 
Software R4.0.x” procedure on page 1-8.

Stop. You have completed this procedure.

NTP-U20 Upgrade Software R2.2.x to Software R4.0.x

Note To upgrade the software successfully, you must read and perform each of the tasks that applies to your 
network in the proper order. Begin with the “DLP-U5 Run the Script” task on page 1-10.

Step 1 Insert the Release 4.0.x software CD into the workstation CD-ROM (or otherwise acquire access to the 
software) to begin the upgrade process.

Note Inserting the software CD activates the CTC Setup Wizard. You can use the setup wizard to 
install components or click Cancel to continue with the upgrade.

Caution A traffic interruption of less than 50 ms on each circuit is possible during the activation task, with 
Ethernet traffic disruption possibly lasting up to several minutes on each circuit.

Caution Do not perform maintenance or provisioning activities during the activation task.

Step 2 Log into the node that you want to upgrade. For detailed instructions, refer to the Cisco ONS 15454 
Procedure Guide. If you are already logged in, continue with Step 3.

Step 3 If you are upgrading from Release 2.2.0, complete the “DLP-U5 Run the Script” task on page 1-10; if 
you are upgrading from Release 2.2.1 or 2.2.2, skip this task.

Step 4 Complete the “DLP-U6 Download Release 4.0.x Software” task on page 1-11.

Step 5 Complete the “DLP-U7 Perform a BLSR Lock Out” task on page 1-12 (BLSR nodes only).

Step 6 Complete the “DLP-U28 Activate the New Load” task on page 1-13.

Purpose Use this procedure to upgrade your CTC software to Software R4.0.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U2 Back Up the Software R2.2.x Database, page 1-5
NTP-U3 Upgrade the TCC Card to the TCC+ Card, page 1-6 (if applicable)

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U20 Upgrade Software R2.2.x to Software R4.0.x
Step 7 As needed, complete the “DLP-U9 Delete Cached JAR Files” task on page 1-15.

Step 8 Reconnect to CTC using the IP address from Step 6. The new CTC applet for Release 4.0.x uploads. 
During this logon, you will need to type the user name CISCO15. A password is not required.

Note Steps 7 and 8 are only necessary after upgrading the first node in a network because cached files 
only need to be removed from your workstation once. For the remaining nodes, you will still be 
disconnected and removed to the network view during the node reboot, but after the reboot is 
complete, CTC will restore connectivity to the node.

Step 9 Repeat Step 6 (activation) for all nodes in the network that need to be upgraded. Allow each node to 
finish (all alarms cleared for 10 minutes) before activating the next node.

Note Only activate one node at a time.

Step 10 Complete the “DLP-U10 Remove the BLSR Lock Out” task on page 1-16 (BLSR nodes only).

Step 11 Complete the “DLP-U11 Run LDCOMPAT.JAR” task on page 1-17 to manage 2.x.x nodes in the 
network.

Step 12 Complete the “DLP-U12 Set the Date and Time” task on page 1-17 for any nodes that are not using 
SNTP.

Step 13 As needed, upgrade any spare TCC+ cards by installing the spare in the standby slot of a Software R4.0.x 
node.

Note The standby TCC+ card will copy one or both software releases from the active TCC+ card, as 
needed. Each software copy takes about 15 minutes, and the TCC+ card will reset after each 
copy. Thus, for a TCC+ card that has no matching software with the active TCC+ card, you 
should expect to see two TCC+ card resets, lasting about 30 minutes total.

Stop. You have completed this procedure.

Note You can also upgrade to Software R4.0.x when a TCC+/TCC2 card that has the Software R4.0.x is 
installed. Refer to “NTP-U3 Upgrade the TCC Card to the TCC+ Card” section on page 1-6 or “NTP-U6 
Upgrade the TCC+ Card to the TCC2 Card” section on page 1-23.
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NTP-U20 Upgrade Software R2.2.x to Software R4.0.x
DLP-U5 Run the Script

Note This task is only necessary with Release 2.2.0 upgrades. If you are upgrading from Release 2.2.1 or 
greater, you can skip this task and continue with the “DLP-U6 Download Release 4.0.x Software” task 
on page 1-11.

Caution Do not run the script on more than one node and one workstation at the same time.

Note Running the script takes approximately 2 to 3 minutes.

Step 1 Display the node (default login) view of the Software R2.2.0 node where you will run the script.

Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is depressed (selected) and disabled if the tool is raised (not 
selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Step 4 From the node view, click the Maintenance > Software tabs.

Step 5 Verify that the active load is 2.2.0 (02.20-001A-00.38). The script will only work for the Release 2.2.0 
(02.20-001A-00.38) load.

Step 6 Close all active telnet connections to the ONS 15454.

Step 7 Run the script. In a command window, from the CD software “Cisco15454” directory, run ptfix.exe (or 
ptfix.pl, in UNIX) using the IP address of the node you are running the script on.

EXAMPLE G:\Cisco15454> ptfix 172.16.17.18

This step takes approximately 2 to 3 minutes. When the script has completed successfully, an “Upgrade 
Preparation Complete” message appears. 

Step 8 Close CTC and then reconnect to the node.

Step 9 From the network view, log into the node you ran the script on.

Step 10 Click the Maintenance > Software tabs.  

Purpose Use this task to prepare your Release 2.2.0 nodes for upgrade with a 
software patch.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U2 Back Up the Software R2.2.x Database, page 1-5
NTP-U3 Upgrade the TCC Card to the TCC+ Card, page 1-6 (if applicable)

Required/As Needed Required for Release 2.2.0 only

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Step 11 Verify that the protect software is now “none.”

Step 12 Return to the network view.

Step 13 Repeat Steps 1 through 11 for each node in the network running Release 2.2.0.

Caution Rerun the script on any node for which the active/standby TCC+ card reboots at any time before the 
Release 4.0.x load is activated.

Step 14 Repeat this task for all nodes in the network.

Step 15 Return to your originating procedure (NTP).

DLP-U6 Download Release 4.0.x Software

Note The TCC+ card has two flash RAMs. An upgrade downloads the software to the backup RAM on both 
the backup and active TCC+ cards. The download task does not affect traffic because the active software 
continues to run at the primary RAM location; therefore, you can download the software at any time.

Step 1 From the View menu, choose Go to Network View.

Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is depressed (selected) and disabled if the tool is raised (not 
selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Note During the software download process, the SWFTDWN alarm indicates that the software 
download is taking place. The alarm is normal and clears when the download is complete.

Step 4 Return to node view and click the Maintenance > Software tabs.

Step 5 Click Upgrade. The File Open dialog box opens.

Purpose Use this task to download Software R4.0.x to the ONS 15454 nodes prior 
to activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U2 Back Up the Software R2.2.x Database, page 1-5
DLP-U5 Run the Script, page 1-10 (if applicable)

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U20 Upgrade Software R2.2.x to Software R4.0.x
Step 6 Browse to locate the software files on the ONS 15454 software CD or on your hard drive, if you are 
working from a local copy.

Step 7 Open the “Cisco15454” folder. 

Step 8 Select the file with the “.pkg” extension and click Open. CTC displays a status window so you can 
monitor the download process. A message indicating that your files transferred successfully will appear 
after the software has finished loading.

Step 9 Repeat Steps 1 through 8 for each node.

Note The software download process can take 30 minutes or more per node.

Step 10 Repeat this task for each node you are upgrading.

Step 11 Return to your originating procedure (NTP).

DLP-U7 Perform a BLSR Lock Out 

Note During the lockout, BLSR spans will not be protected. Be sure to remove the lockout after activating all 
nodes in the ring.

Note To prevent ring or span switching, perform the lockout on both the east and west spans of each node.

Step 1 In node view, click the Maintenance > Ring tabs.

Step 2 For each of the BLSR trunk (span) cards (OC-12, OC-48, or OC-192), perform the following steps:

a. Next to the trunk card row, click the West Operation column to show the pull-down menu.

b. From the menu options, choose Ring Lockout.

c. In the same row, click the East Operation column to show the pull-down menu.

d. From the menu options, choose Ring Lockout.

e. Click Apply to activate the command. 

Step 3 Repeat Step 2 at each node in the ring.

Note Ignore any Default K alarms that occur on the protect STS timeslots during this lockout period.

Purpose You must perform a lockout at each node in the BLSR before activating the 
software for Release 4.0.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Note Leave the BLSR in the lockout state until you have finished activating all nodes.

Step 4 Return to your originating procedure (NTP).

DLP-U28 Activate the New Load

Note Cisco recommends that the first node you activate be a LAN-connected node. This ensures that the new 
CTC JAR files will download to your workstation as quickly as possible.

Note Make sure all cards that are part of a protection group (1+1, 1:1, or 1:N) are active on the working card 
of that protection group and that no protection switches are occurring. In other words, make sure that the 
protect cards are in standby before proceeding. Move your mouse cursor over a card in node view to see 
its active or standby status.

Step 1 To ensure database synchronization, run the memAudit utility:

a. Close all active telnet connections to the ONS 15454.

b. Copy the memAudit.exe from the ONS 15454 software CD or the following Cisco.com web page to 
a folder on your hard drive: 

http://www.cisco.com/cgi-bin/tablebuild.pl/ons15454

c. In a command window, change the prompt to the folder where the memAudit.exe is located. 

d. At the prompt, type the following command:

memAudit <nodename or IP address>

Note Use the full memAudit command with the version numbers. In addition, optional parameters 
exist for the memAudit command. For more information about the memAudit utility, view the 
memAudit_readme.htm file on the CD or Cisco.com web page.

The command prompt window displays the following:

IP address DB:insync RESET:no:

Step 2 Record the IP address of the node. The IP address is either on the LCD or on the upper left corner of the 
CTC window.

Purpose Use this task to activate Software R4.0.x in each node in the network.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U7 Perform a BLSR Lock Out, page 1-12 (if required)
DLP-U6 Download Release 4.0.x Software, page 1-11

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Step 3 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is depressed (selected) and disabled if the tool is raised (not 
selected). 

Step 4 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Step 5 Click the Maintenance > Software tabs.

Step 6 Verify that the protect version is 4.0.x.

Step 7 Click Activate. The Activate dialog box appears with a warning message.

Step 8 Click Yes to proceed with the activation. The “Activation Successful” message appears when the 
software is successfully activated.

Note CTC will lose connection to the node and will display the network view.

Step 9 Click OK to begin the node rebooting process. A rebooting window appears.

Step 10 After activating the node, wait until the software upgrade reboot finishes at that node before continuing. 
The following occurs:

• Each card in the node reboots, beginning with the standby TCC+ card followed by the active TCC+ 
card. When the active TCC+ card is rebooted, it signals the standby TCC+ card to transition to be 
the active TCC+ card while it becomes now the standby TCC+ card. 

• When the TCC+ cards are finished, the XC/XCVT card in Slot 8 reboots, and then the XC/XCVT 
card in Slot 10 reboots. 

• Next, the Ethernet cards reset at the same time, then the traffic cards boot consecutively from left to 
right. 

• A system reboot (SYSBOOT) alarm is raised while activation is in progress. When all cards have 
reset, this alarm clears. The upgrade process can take up to 30 minutes, depending on how many 
cards are installed. 

When all the cards finish rebooting and all alarms clear, you can safely proceed to the next step. If you 
are upgrading remotely and cannot see the nodes, wait for 30 minutes for the process to complete, then 
check to ensure all alarms have cleared before proceeding.

Caution The upgrade process is service affecting, so Cisco recommends that you activate the new load during a 
maintenance window. Time Division Multiplexing (TDM) traffic can endure a hit of up to 50 ms. 
Ethernet traffic may remain down from the time the TCC+ cards switch to the time all Ethernet cards 
have finished resetting. 

Step 11 In CTC, choose File > Exit.

Step 12 Return to your originating procedure (NTP).
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DLP-U9 Delete Cached JAR Files

Step 1 Delete cache files from your browser directory.

In Netscape:

a. Choose Edit > Preferences > Advanced > Cache.

b. Click Clear Memory Cache.

c. Click OK.

d. Click Clear Disk Cache.

e. Click OK twice.

In Microsoft Internet Explorer:

a. Choose Tools > Internet Options > General.

b. Choose Delete Files.

c. Select the Delete all offline content checkbox.

d. Click OK twice.

Step 2 Close your browser.

Note You will not be able to delete cached JAR files from your hard drive until you have closed your 
browser. If you have other applications open that use JAR files, you must also close them.

Step 3 Delete cached files from your workstation (Windows systems only).

a. In your Windows start menu, choose Settings > Control Panel > System > Advanced.

b. Click Environment Variables. This will show you a list of user variables and a list of system 
variables.

c. In the list of user variables, look for the TEMP variable. The value associated with this variable is 
the path to your temporary directory where JAR files are stored.

d. Open the TEMP directory located in the path you just looked up.

e. Select View > Details.

f. Select and delete all files with “jar” in the Name or Type field.

Step 4 Reopen your browser. You should now be able to connect to CTC.

Purpose When you upgrade or revert to a different CTC software load, you must 
reload CTC to your browser. Before you can reload CTC you must ensure 
that previously cached files are cleared from your browser and hard drive.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U28 Activate the New Load, page 1-13

Required/As Needed You need to complete this task only after you activate the first node in the 
network only.

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Step 5 Return to your originating procedure (NTP).

DLP-U10 Remove the BLSR Lock Out

Step 1 In CTC node view, click the Maintenance > BLSR tabs.

Step 2 For each of the BLSR trunk (span) cards (OC-12, OC-48, or OC-192), perform the following steps: 

a. Next to the trunk card row, click the West Switch column to show the pull-down menu.

b. From the menu options, choose Clear.

c. Click Apply to activate the command. 

Note When removing a lockout, be sure to apply your changes each time you choose the Clear option. 
If you try to select Clear for more than one lockout at a time, you risk traffic loss on the first ring 
switch.

d. In the same row, click the East Switch column to show the pull-down menu.

e. From the menu options, choose Clear.

f. Click Apply to activate the command. 

Step 3 Repeat this task as many times as necessary to remove all BLSR span lock outs on the upgrade nodes.

Step 4 Return to your originating procedure (NTP).

Purpose Release the span lockouts on all BLSR nodes after the new software load 
is activated on all nodes.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U6 Download Release 4.0.x Software, page 1-11

Required/As Needed Required for BLSR

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
1-16
Cisco ONS 15454 Software Upgrade Guide

June 2003



 

Chapter 1      Upgrading Software Release 2.2.x to 4.0.x Using the TCC+ Card
NTP-U20 Upgrade Software R2.2.x to Software R4.0.x
DLP-U11 Run LDCOMPAT.JAR

Step 1 If you are using Windows, run the LDCOMPAT.jar from the ONS 15454 Software CD. The 
LDCOMPAT.jar file is located at the Cisco15454 folder.

Step 2 If you are using UNIX, enter the following commands:

% cd /Cisco15454

% java -jar LDCOMPAT.jar

LDCOMPAT. jar copies the COMPAT.jar file to the client machine and updates the CTC.ini so that CTC 
can use it to manage 2.x.x nodes.

Step 3 Return to your originating procedure (NTP).

DLP-U12 Set the Date and Time

Note If you are using SNTP, you do not need this task.

Step 1 In CTC node view, click the Provisioning > General tabs.

Step 2 Set the correct date and time, then click Apply. 

Step 3 Repeat Steps 1 and 2 for each remaining node.

Step 4 Return to your originating procedure (NTP).

Purpose This task enables CTC to manage 2.x.x nodes after a software upgrade.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U28 Activate the New Load, page 1-13
DLP-U10 Remove the BLSR Lock Out, page 1-16 (if applicable)

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser

Purpose If you are not using SNTP, the upgrade procedure can cause the Date/Time 
setting to change. Perform this task to reset the date and time at each node.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U5 Revert to Previous Software Load and Database

Note The tasks to revert to a previous load are not a part of the upgrade. They are provided here as a 
convenience to those wishing to perform a revert after an upgrade. If you have performed all necessary 
procedures up to this point, you have finished the software upgrade.

Note Cisco does not recommend reverting to R3.x when both a TCC+ card and a TCC2 card are installed on 
the same ONS 15454 shelf. You must have two TCC+ cards installed to revert to R3.x. Additionally, you 
cannot revert to 3.x if two TCC2 cards are installed and running R4.0.x.

Note Before you upgraded to Release 4.0.x software, you should have backed up the existing database at all 
nodes in the network (this is part of the “NTP-U2 Back Up the Software R2.2.x Database” procedure on 
page 1-5). Cisco recommends that you record or export all critical information to your hard drive. If you 
need to revert to the backup database, use the following tasks, in order. 

Step 1 Log into the node. For detailed instructions, refer to the Cisco ONS 15454 Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 Complete the “DLP-U13 Perform a Software R4.0.x BLSR Lock Out” task on page 1-19 (BLSR only).

Step 3 Complete the “DLP-U14 Revert to Protect Load” task on page 1-20.

Step 4 Complete the “DLP-U15 Remove the Software R4.0.x BLSR Lock Out” task on page 1-21 (BLSR only).

Step 5 If you need to revert to Software R2.2.0 or the revert to a later release failed, complete the “DLP-U16 
Manually Restore the Database” task on page 1-22.

Stop. You have completed this procedure.

Purpose Use this procedure to return to the software and database provisioning you 
had before you activated Release 4.0.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade, page 1-2
NTP-U7 Prepare for Release 3.x to Release 4.0.x Upgrade, page 2-2 (if 
applicable)
NTP-U2 Back Up the Software R2.2.x Database, page 1-5
NTP-U8 Back Up the Software R3.x Database, page 2-3 (if applicable)
NTP-U20 Upgrade Software R2.2.x to Software R4.0.x, page 1-8
NTP-U22 Upgrade Software R3.x to Software R4.0.x, page 2-4 (if 
applicable)

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U13 Perform a Software R4.0.x BLSR Lock Out

Note During the lockout, BLSR spans will not be protected. You must leave the BLSR in the lockout state 
until you have finished reverting all nodes, but then you must be sure to remove the lockout once you are 
finished reverting.

Note To prevent ring or span switching, perform the lockout on both the east and west spans of each node.

Step 1 In node view, click the Maintenance > Ring tabs.

Step 2 For each of the BLSR trunk (span) cards (OC-12, OC-48, OC-192), perform the following steps:

a. Next to the trunk card row, click the East Switch column to show the pull-down menu.

b. From the menu options, choose Lockout Span.

c. Click Apply.

d. In the same row, click the West Switch column to show the pull-down menu.

e. From the menu options, choose Lockout Span.

f. Click Apply. 

Step 3 Repeat Step 2 at each node in the ring.

Note Ignore any Default K alarms that occur on the protect STS timeslots during this lockout period.

Note Leave the BLSR in the lockout state until you have finished reverting all nodes.

Step 4 Return to your originating procedure (NTP).

Purpose If you have a BLSR provisioned, before beginning the revert you must 
perform a span lockout at each node.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U2 Back Up the Software R2.2.x Database, page 1-5
NTP-U8 Back Up the Software R3.x Database, page 2-3 (if applicable)
NTP-U20 Upgrade Software R2.2.x to Software R4.0.x, page 1-8
NTP-U22 Upgrade Software R3.x to Software R4.0.x, page 2-4 (if 
applicable)

Required/As Needed Required for BLSR only

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U14 Revert to Protect Load

Note To perform a supported (non service-affecting) revert from Release 4.0.x, the release you want to revert 
to must have been working at the time you activated to Release 4.0.x on that node. Also, a supported 
revert automatically restores the node configuration at the time of the previous activation. Thus, any 
configuration changes made after activation will be lost when you revert the software.

Note In the following task, the database is restored automatically as a part of the revert only for Releases 2.2.1 
and later. If you were running Release 2.2.0 before activation, you will need to manually restore the 
database after performing the steps to revert. Restoring the database manually is service affecting and 
should be performed during a service window. 

Step 1 From the node view, click the Maintenance > Software tabs.

Step 2 Verify that the protect software displays the release you upgraded from.

Step 3 Click Revert. Revert activates the protect software and restores the database from the previous load. A 
dialog box asks you to confirm the choice.

Step 4 Click OK. This begins the revert and drops the connection to the node. 

Step 5 Wait until the software revert finishes before continuing.

Note The system reboot might take up to 30 minutes to complete.

Step 6 Close your Netscape or Internet Explorer browser.

Step 7 Wait one minute before restoring another node.

Purpose Use this task to revert to the software you were running prior to the last 
activation. If you were running Release 2.2.1 or greater, this task will also 
restore your database to the provisioning you had prior to the activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U1 Prepare for Release 2.2.x to Release 4.0.x Upgrade, page 1-2
NTP-U7 Prepare for Release 3.x to Release 4.0.x Upgrade, page 2-2 (if 
applicable)
NTP-U2 Back Up the Software R2.2.x Database, page 1-5
NTP-U8 Back Up the Software R3.x Database, page 2-3 (if applicable)
NTP-U20 Upgrade Software R2.2.x to Software R4.0.x, page 1-8
NTP-U22 Upgrade Software R3.x to Software R4.0.x, page 2-4 (if 
applicable)
DLP-U13 Perform a Software R4.0.x BLSR Lock Out, page 1-19 (if 
required)

Required/As Needed Required for revert

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Note When you upgrade to JRE 1.3.1_02, you cannot log into an ONS 15454 running Release 2.2.1 
or prior (or an ONS 15327 running Release 1.0.0). If you are reverting to a release that required 
a previous version of JRE, you will need to reinstall Java and delete the JAR files from your 
workstation’s TEMP directory after reverting all of the nodes in the network. If you are reverting 
to a release that also uses JRE 1.3.1_02, or if you retained JRE 1.3.1_02 during the upgrade, you 
do not need to reinstall Java and delete JAR files.

Step 8 After reverting all of the nodes in the network, restart the browser and log back into the last node that 
was reverted. This uploads the appropriate CTC applet to your workstation.

Note It might also be necessary to delete cache files from your browser’s directory or from the TEMP 
directory on your MS Windows workstation. If you have trouble reconnecting to CTC, see the 
“DLP-U9 Delete Cached JAR Files” task on page 1-15.

Step 9 Return to your originating procedure.

DLP-U15 Remove the Software R4.0.x BLSR Lock Out

Step 1 In CTC node view, click the Maintenance > Ring tabs.

Step 2 For each of the BLSR trunk cards (OC-12, OC-48, OC-192), perform the following steps:

a. Next to the trunk card row, click the West Switch column to show the pull-down menu. 

b. From the menu options, choose Clear.

c. Click Apply to activate the command. 

Note When removing a lockout, be sure to apply your changes each time you select the Clear option. 
If you try to select Clear for more than one lockout at a time, you risk traffic loss on the first ring 
switch.

d. In the same row, click the East Switch column to show the pull-down menu.

e. From the menu options, choose Clear.

f. Click Apply to activate the command. 

Purpose To restore BLSR protection you must clear the span lockouts on all BLSR 
nodes after reverting the software load and restoring the database on all 
nodes.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U13 Perform a Software R4.0.x BLSR Lock Out, page 1-19

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Step 3 You might need to accept a new ring map to clear Default K byte or Node ID mismatch alarms. In the 
Provisioning > Ring tabs, click the Ring Map button. If a new ring map exists, click Accept.

Step 4 Return to your originating procedure.

DLP-U16 Manually Restore the Database

Caution Do not perform these steps unless you are restoring Release 2.2.0 or the software revert for a later release 
failed.

Caution This process is service affecting and should be performed during a maintenance window.

Step 1 In the CTC node view, click the Maintenance > Database tabs.

Step 2 Click Backup. The “Open…” dialog box appears.

Step 3 Select the previously saved file and choose Open.

The database will be restored and the TCC+s cards will reboot.

Step 4 When the TCC+ cards have rebooted, log back into CTC and verify that the database is restored.

Wait one minute before restoring the next node.

Step 5 You have now completed the manual database backup.

Step 6 Return to your originating procedure (NTP).

Purpose Use this task to revert to Release 2.2.0 or if you were unable to perform a 
revert using another software release.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U14 Revert to Protect Load, page 1-20, and DLP-U15 Remove the 
Software R4.0.x BLSR Lock Out, page 1-21 (if required)

Required/As Needed Required for Release 2.2.0 database restoral after a revert; otherwise, as 
needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U6 Upgrade the TCC+ Card to the TCC2 Card

Note The TCC2 card does not carry any software other than Software R4.0.x. You will not be able to revert to 
a software release earlier than Software R4.0.x with both TCC2 cards installed. 

Note Features that require TCC2 functionality are not supported with a mixed configuration (one TCC2 card 
and oneTCC+ card installed on an ONS 15454 shelf). 

Note Downgrade procedures from TCC2 cards to TCC+ cards are not supported. Contact TAC for more 
information. See the “Obtaining Technical Assistance” section on page ix for contact information.

Step 1 Log into CTC. For detailed instructions, refer to the Cisco ONS 15454 Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 Verify that the LAN wires on the backplane are installed properly. The TCC2 card does not autodetect 
miswired LAN connections. If a LAN connection is miswired, a “LAN Connection Polarity Reversed” 
condition appears. For information on backplane pinouts, refer to the Cisco ONS 15454 Reference 
Manual.

Step 3 Verify that the node you are upgrading has ONS 15454 Software R4.0.x installed. The software version 
is displayed in the upper left corner of the window.

Step 4 Complete the “NTP-U2 Back Up the Software R2.2.x Database” section on page 1-5 before beginning 
the upgrade.

Step 5 Physically replace the standby TCC+ card on the ONS 15454 with a TCC2 card. 

a. Check the LED on the faceplate. The ACT/STBY LED on the faceplate of the TCC+/TCC2 card 
indicates whether the card is in active or standby mode. A green ACT/STBY LED indicates an active 
card and an amber light indicates a standby card.

b. Open the standby TCC+ card ejectors.

c. Slide the card out of the slot. This raises the IMPROPRMVL alarm which will clear when the upgrade 
is complete.

d. Open the ejectors on the TCC2 card to be installed.

e. Slide the TCC2 card into the slot along the guide rails.

f. Close the ejectors.

Purpose Use this procedure to upgrade the TCC+ card to the TCC2 card. The 
TCC2 card supports ONS 15454 Software R4.0.x. The TCC+ card is 
compatible with ONS 15454 Software R4.0.x and earlier software 
versions.

Tools/Equipment Two SONET TCC2 cards

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Maintenance or higher
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g. In CTC node view, Ldg (loading) appears on the newly installed TCC2 card.

Note The MEA (card mismatch) alarm appears because CTC recognizes a mismatch between TCC 
card types. Disregard this alarm; it clears by the end of the procedure.

Note It takes approximately 10 minutes for the active TCC+ card to transfer the database to the newly 
installed TCC2 card. During this operation, the LEDs on the TCC2 card flash Fail and then the 
active/standby LED flashes. When the transfer completes, the TCC2 card reboots and goes into 
standby mode after approximately three minutes. Do not remove the card from the shelf during 
a database transfer.

Caution If your active TCC+ card resets during the upgrade before the new TCC2 card is in full 
standby mode, remove the new TCC2 card immediately. 

Step 6 When the newly installed TCC2 card is in standby, right-click the active TCC+ card in CTC.

Note You can no longer revert to a software version prior to Software R4.0.x after you switch the 
standby TCC2 card to the active TCC2 card.

Step 7 From the pull-down menu, choose Reset Card.

Wait for the TCC+ card to reboot. The ONS 15454 switches the standby TCC2 card to active mode. The 
TCC+ card verifies that it has the same database as the TCC2 card and then switches to standby.

Step 8 Verify that the remaining TCC+ card is now in standby mode (the ACT/STBY LED changes to amber). 

Step 9 Physically replace the remaining TCC+ card with the second TCC2 card.

a. Open the TCC+ card ejectors.

b. Slide the card out of the slot. This raises the IMPROPRMVL alarm, which will clear when the 
upgrade is complete.

c. Open the ejectors on the TCC2 card.

d. Slide the TCC2 card into the slot along the guide rails.

e. Close the ejectors.

The ONS 15454 boots up the second TCC2 card. The second TCC2 card must also copy the database. 
Do not remove the card from the shelf during a database transfer.

Tip When a newly installed TCC2 card has a different version of the ONS 15454 software installed than the 
version running on the active TCC2 card, the newly installed TCC2 card automatically copies the 
software version running on the active TCC2 card. You do not need to do anything in this situation. 
However, the loading TCC2 card does not boot up in the normal manner. When the card is first inserted, 
the red FAIL LED stays on for a short period. The FAIL LED then blinks normally and all LEDs go dark. 
After loading the new software for approximately 10 minutes, the TCC2 card becomes the standby card 
and the amber LED is illuminated.
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Step 10 If power-related alarms occur after the second TCC2 card is installed, check the voltage on the 
backplane.

Stop. You have completed this procedure.
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