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C H A P T E R 6

Manage Alarms

This chapter explains how to view and manage the alarms and conditions on a Cisco ONS 15327.

Cisco Transport Controller (CTC) detects and reports SONET alarms generated by the Cisco ONS 15327 
and the larger SONET network. You can use CTC to monitor and manage alarms at a card, node, or 
network level. You can also view alarm counts on the LCD front panel.

Before You Begin
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

1. NTP-B195 Document Existing Provisioning, page 6-2—Complete this procedure as needed to 
record node information or to troubleshoot rings and spans.

2. NTP-B196 View Alarms, History, Events, and Conditions, page 6-5—Complete this procedure as 
needed to see alarms and conditions occurring on the node and a complete history of alarm and 
condition messages.

3. NTP-B68 Delete Cleared Alarms from Display, page 6-13—Complete this procedure as needed to 
delete cleared alarm information that is no longer needed.

4. NTP-B69 View Alarm-Affected Circuits, page 6-14—Complete this procedure as needed to find 
circuits that are affected by a particular alarm or condition.

5. NTP-B70 Create, Download, and Assign Alarm Severity Profiles, page 6-16—Complete this 
procedure as needed to change the default severity for certain alarms, assign the new severities to a 
port, card, or node, and delete alarm profiles.

6. NTP-B168 Enable, Modify, or Disable Alarm Severity Filtering, page 6-26—Complete this 
procedure as needed to enable, disable, or modify alarm severity filtering in the Conditions, Alarms, 
or History screens; you can enable, modify, and disable alarm severity filtering at the node or 
network level.

7. NTP-B72 Suppress and Discontinue Alarm Suppression, page 6-30—As needed, use these tasks to 
suppress reported alarms at the port, card, or node level and disable the suppress command to resume 
normal alarm reporting.
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NTP-B195 Document Existing Provisioning

Step 1 Complete the “DLP-B60 Log into CTC” task on page 2-23 at the node that has the information you want 
to record or save. If you are already logged in, continue with Step 2.

Step 2 As needed, complete the “DLP-B138 Print CTC Data” task on page 6-2.

Step 3 As needed, complete the “DLP-B139 Export CTC Data” task on page 6-3.

Stop. You have completed this procedure.

DLP-B138 Print CTC Data

Step 1 Click the CTC tab (and subtab, if present) containing the information you want to print. For example, 
click the Alarms tab to print Alarms window data.

The print operation is available for all network, node (default login), and card view windows.

Step 2 From the File menu, choose Print.

Step 3 In the Print dialog box, click a a printing option (Figure 6-1).

• Entire Frame—Prints the entire CTC window including the graphical view of the card, node, or 
network. This option is available for all windows.

• Tabbed View—Prints the lower half of the CTC window containing tabs and data. The printout 
includes the selected tab (on top) and the data shown in the tab window. For example, if you print 
the History window Tabbed View, you print only history items appearing in the window. This option 
is available for all windows.

Purpose Use this procedure to print card, node, or network CTC information in 
graphical or tabular form on a Windows-provisioned printer, or to export 
card, node, or network information as editable delineated text files to 
other applications. This procedure is useful for network record keeping 
and troubleshooting.

Tools/Equipment Printer connected to the CTC computer by a direct or network connection

Prerequisite Procedures Chapter 3, “Turn Up Node”

Required/As needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve or higher

Purpose Use this task to print CTC card, node, or network data in graphical or 
tabular form on a Windows-provisioned printer.

Tools/Equipment Printer connected to the CTC computer by a direct or network connection

Prerequisite procedures DLP-B60 Log into CTC, page 2-23

Required/As needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve or higher
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• Table Contents—Prints CTC data in table format without graphical representations of shelves, 
cards, or tabs. This option is available only for CTC table data, so it does not apply to:

– Provisioning > General, Protection, Security, SNMP, SONET DCC, or Timing windows

– Maintenance > Database, Protection, Diagnostic, or Timing windows

The Table Contents option prints all the data contained in a table with the same column headings. 
For example, if you print the History window Table Contents view, you print all data included in the 
table whether or not items appear in the window.

Tip When you print using the Tabbed View option, it can be difficult to distinguish whether the 
printout applies to the network, node, or card view. Look at the tabs to determine which view 
you are printing. Network, node, and card views are identical except that network view does not 
contain an Inventory tab; node view and card view contain a Performance tab.

Figure 6-1 Selecting CTC Data For Print

Step 4 Click OK.

Step 5 In the Windows Print dialog box, click a printer and click OK.

Step 6 Repeat this task for each window that you want to print.

Step 7 Return to your originating procedure (NTP).

DLP-B139 Export CTC Data

Step 1 Click the CTC tab containing the information you want to export (for example, the Alarms tab or the 
Circuits tab).

Purpose Use this task to export CTC table data as delineated text to view or edit the 
data in text editor, word processing, spreadsheet, database management, or 
web browser applications.

Tools/Equipment None

Prerequisite procedures DLP-B60 Log into CTC, page 2-23

Required/As needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve or higher
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Step 2 From the File menu choose Export.

Step 3 In the Export dialog box (Figure 6-2), click a data format:

• As HTML—Saves data as a simple HTML table file without graphics. The file must be viewed or 
edited with applications such as Netscape Navigator, Microsoft Internet Explorer, or other 
applications capable of opening HTML files.

• As CSV—Saves the CTC table as comma-separated values (CSV).

• As TSV—Saves the CTC table as tab-separated values (TSV).

Step 4 If you want to open a file in a text editor or word processor application, procedures may vary; typically 
you can use the File > Open command to display the CTC data, or you can double-click the file name 
and choose an application such as Notepad. 

Text editor and word processor applications display the data exactly as it is exported, including comma 
or tab separators. All applications that open the data files allow you to format the data.

Step 5 If you want to open the file in spreadsheet and database management applications, procedures may vary; 
typically you need to open the application and choose File > Import, then choose a delimited file to 
display the data in cells.

Spreadsheet and database management programs also allow you to manage the exported data.

Note An exported file cannot be opened in CTC. 

The export operation only applies to tabular data, so it is not available for the following CTC tabs and 
subtabs:

• Provisioning > General, Protection, Security, SNMP, SONET DCC, or Timing windows

• Maintenance > Database, Protection, Diagnostic, or Timing windows

Figure 6-2 Selecting CTC Data For Export

Step 6 Click OK.

Step 7 In the Save dialog box, enter a name in the File name field using one of the following formats:

• [filename].html—for HTML files

• [filename].csv—for CSV files

• [filename].tsv—for TSV files

Step 8 Navigate to a directory where you want to store the file.

Step 9 Click OK.
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Step 10 Repeat the task for each window that you want to export.

Step 11 Return to your originating procedure (NTP).

NTP-B196 View Alarms, History, Events, and Conditions

Step 1 Log into the node that contains the alarms you want to view. See the “DLP-B60 Log into CTC” task on 
page 2-23 for instructions. If you are already logged in, proceed to Step 2.

Step 2 In the card, node (default), or network-level CTC view, click the Alarms tab to display the alarms for 
that card, node, or network (Figure 6-3 on page 6-6).

Purpose Use this procedure to view current or historical alarms and conditions for 
a card, a node, or network. This information is useful for monitoring and 
troubleshooting hardware and software events.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning
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Figure 6-3 ONS 15327 CTC Node (Login) View

Table 6-1 lists the columns in the Alarms window and their descriptions.

Table 6-1 Alarm Column Descriptions

Column Information Recorded

New Indicates a new alarm; to change this status, click either the Synchronize button or 
the Delete Cleared Alarms button

Date Date and time of the alarm

Node Node where the alarm occurred (appears only in network view)

Object TL1 access identifier (AID) for the alarmed object. For an STSmon or VTmon, this 
is the monitored STS or VT object.

Eqpt Type Card type in this slot

Slot Slot where the alarm occurred (appears only in network and node view)

Port Port where the alarm is raised. For STSTerm and VTTerm, the port refers to the 
upstream card it is partnered with.

Sev Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR 
(not-reported)

ST Status: R (raised), C (clear)

SA When selected (checked), indicates a service-affecting alarm
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Table 6-2 lists the color codes for alarm and condition severities.

Software Release 4.0 has specifically numbered STS and VT alarm object identifiers based upon the 
object TL1 access identifiers (AIDs). The R40 numbering scheme is compared in Table 6-3 to the 
numbering scheme in previous releases.

Step 3 If alarms are present, refer to the Cisco ONS 15327 Troubleshooting Guide for information and 
troubleshooting procedures.

Step 4 Complete the “DLP-B110 View Alarm History” task on page 6-8, the “DLP-B113 Synchronize Alarms” 
task on page 6-10, or the “DLP-B114 View Conditions” task on page 6-11 as needed.

Stop. You have completed this procedure.

Cond The error message/alarm name; these names are alphabetically defined in the “Alarm 
Troubleshooting” chapter of the Cisco ONS 15327 Troubleshooting Guide

Description Description of the alarm

Num A count of incrementing alarm messages 

Ref The reference number assigned to the alarm

Table 6-1 Alarm Column Descriptions (continued)

Column Information Recorded

Table 6-2 Color Codes for Alarms and Conditions

Color Description

Red Raised Critical (CR) alarm

Orange Raised Major (MJ) alarm

Yellow Raised Minor (MN) alarm

Magenta (pink) Raised Not-Alarmed (NA) condition

Blue Raised Not-Reported (NR) condition

White Cleared (C) alarm or condition

Table 6-3 Release 4.0 Port-Based Alarm Numbering Scheme Comparison

Previous Release STS and VT Alarm Numbering Release 4.0 STS and VT Alarm Numbering1

1. In Release 4.0 STSTerm and VtTerm alarms, the Object and Port columns apply to the paired MON object within the upstream 
card. In these alarms, STSMon and STSTerm, or VTMon or VtTerm alarm objects are identical.

MON
object

STS (or VT)-6-6
(Slot-STS or VT within card)

Port=1 MON
object

STS (or VT)-6-1-6 
(Slot-Port-STS or VT within 
port)

Port=1

TERM
object

STS-2-3
(Local slot-STS or VT within 
local terminating card)

Port=3 TERM
object

STS-6-1-6
(Upstream Slot-Port-STS or VT 
within port)

Port=1
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DLP-B110 View Alarm History

Step 1 To view node alarm history, proceed to Step 2. To view network alarm history, proceed to Step 3. To view 
card alarm history, proceed to Step 5.

Step 2 To view node alarm history:

a. Click the History > Session tabs if you want to view the alarms and conditions (events) raised 
during the current session (since you logged into the CTC).

b. Click the History > Node tabs to retrieve all available alarm messages for the node.

Tip Double-click an alarm in the alarm table or an event (condition) message in the history table to 
display the view that corresponds to the alarm message. Double-click a card alarm to display the 
card view. In network view, double-click a node alarm to display the node view.

Step 3 To view network alarm history, from node view click View > Go to Network View.

Step 4 Click the History tab.

Alarms and conditions (events) raised during the current session appear.

Step 5 To view card alarm history, from the network view click View > Go to Previous View.

The previous view is the node (default login) view.

Step 6 From node view, double-click a card on the shelf graphic to display the card-level view for the card.

Note Mechanical Interface cards (MICs) do not have a card view.

a. Click the History > Session tabs to view the alarm messages raised during the current session.

b. Click the History > Card tabs to retrieve all available alarm messages for the card.

Note The ONS 15327 can store up to 640 critical alarm messages, 640 major alarm messages, 640 
minor alarm messages, and 640 condition messages. When any of these limits is reached, 
the ONS 15327 discards the oldest events in that category.

Step 7 In the node or card view, display Not-Alarmed (NA) and transient event (condition) history in addition 
to alarm history by clicking the Events check box in the History > Node window or 
History > Card window.

Purpose Use this task to view past cleared and uncleared ONS 15327 alarm 
messages at the card, node, or network level. This task is useful for 
troubleshooting configuration, traffic, or connectivity issues that are 
indicated by alarms.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Retrieve
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Step 8 Click Retrieve.

Step 9 The window displays raised and cleared alarm messages (and events, if selected).

Tip Double-click an alarm in the alarm table or a condition in the history table to display the view 
that corresponds to the alarm message. For example, double-clicking a card alarm takes you to 
card view. In network view, double-clicking a node alarm takes you to node view.

Step 10 Return to your originating procedure (NTP).

DLP-B111 Changing the Maximum Number of Session Entries for Alarm History

Step 1 From the Edit menu choose Preferences.

The CTC Preferences Dialog box appears (Figure 6-4).

Figure 6-4 CTC Preferences Dialog Box

Step 2 Click the up or down arrow buttons next to the Maximum History Entries field to change the entry.

Step 3 Click Apply and OK.

Purpose This task changes the maximum number of session entries included in the 
alarm history. Use this task to extend the history list in order to save 
information for future reference or troubleshooting.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Provisioning
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Note Setting the Maximum History Entries value to the high end of the range uses more CTC memory 
and could impair CTC performance.

Note This task changes the maximum history entries recorded for CTC sessions. It does not affect the 
maximum number of history entries viewable for a network, node, or card.

Step 4 Return to your originating procedure (NTP).

DLP-B112 Display Alarms and Conditions Using Time Zone

Step 1 From the Edit menu choose Preferences.

The CTC Preferences Dialog box appears (Figure 6-4 on page 6-9).

Step 2 Click the Display Events Using Each Node’s Timezone check box. 

Step 3 Click Apply and OK.

Step 4 Return to your originating procedure (NTP).

DLP-B113 Synchronize Alarms

Purpose Use this task to change the timestamp for events to the timezone of the 
ONS node reporting the alarm. By default, the events timestamp is set to 
the timezone for the CTC workstation.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Provisioning

Purpose Use this task to view ONS 15327 events at the card, node, or network level 
and to refresh the alarm listing while troubleshooting so that you can check 
for new and cleared alarms and conditions.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve
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Step 1 At the card, node, or network view, click the Alarms tab.

Step 2 Click Synchronize.

This button causes CTC to retrieve a current alarm summary for the card, node, or network. This step is 
optional because CTC updates the Alarms window automatically as messages arrive from the node.

Alarms that have been raised during the session will have a check mark in the Alarms window New 
column. When you click Synchronize, the check mark disappears.

Step 3 Return to your originating procedure (NTP).

DLP-B114 View Conditions

Step 1 In the card, node, or network view, click the Conditions tab.

Step 2 Click Retrieve (Figure 6-5). 

The Retrieve button requests the current set of fault conditions from the node, card, or network. The 
window is not updated when conditions change on the node. You must click Retrieve to see any changes.

Purpose Use this task to view conditions, [events with a Not-Reported (NR) 
severity] at the card, node, or network level. Conditions give you a clear 
record of changes or events that do not result in alarms.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve
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Figure 6-5 Node View Conditions Window

Conditions include all fault conditions raised on the node, whether or not they are reported.

Note Alarms can be unreported when they are filtered out of the display. See the “DLP-B225 Enable 
Alarm Filtering” section on page 6-27 for information.

Events that are reported as Major (MJ), Minor (MN), or Critical (CR) severities are alarms. Events that 
are reported as Not-Alarmed (NA) are conditions. Conditions that are not reported at all are marked 
Not-Reported (NR) in the Conditions window severity column.

Conditions that have a default severity of Critical (CR), Major (MJ), Minor (MN), or Not-Alarmed (NA) 
but are not reported due to exclusion or suppression are shown as NR in the Conditions window. 

Note For more information about alarm suppression, see the “DLP-B119 Suppress Alarm Reporting” 
section on page 6-31.

Current conditions are shown with the severity chosen in the alarm profile, if used. (For more 
information about alarm profiles, see the “NTP-B70 Create, Download, and Assign Alarm Severity 
Profiles” section on page 6-16.)
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Note When ports are placed in OOS state for maintenance (OOS-MT), they raise the Alarms 
Suppressed for Maintenance (AS-MT) condition. For information about alarm and condition 
troubleshooting, refer to the Cisco ONS 15327 Troubleshooting Guide.

Step 3 If you want to apply exclusion rules, check the Exclude Same Root Cause check box at the node or 
network view, but do not check the Exclude Same Root Cause check box in card view.

An exclusion rule eliminates all lower-level alarms or conditions that originate from the same cause. For 
example, a fiber break may cause an LOS alarm, an AIS condition, and an SF condition. If you check 
the Exclude Same Root Cause checkbox, only the LOS alarm will appear. According to Telcordia, 
exclusion rules apply to a query of “all conditions from a node.”

Step 4 Return to your originating procedure (NTP).

NTP-B68 Delete Cleared Alarms from Display

Step 1 Log into a node where you want to delete alarms. See the “DLP-B60 Log into CTC” task on page 2-23 
for instructions. If you are already logged in, proceed to Step 2.

Step 2 To manually delete cleared node-level alarms:

a. In the node view, click the Alarms tab.

b. Refer to the rules in Step 8 and Click Delete Cleared Alarms.

This action removes any cleared ONS 15327 alarms from the Alarms display. The rows of cleared alarms 
turn white and have a C in their status (ST) column (Figure 6-5 on page 6-12).

Step 3 To automatically delete cleared alarms at the node level, check the Autodelete Cleared Alarms check 
box at the bottom-left of the window.

Step 4 To manually delete cleared card-level alarms:

a. In the node view, double-click the card graphic for the card you want to open.

b. Click the Alarms tab and click the Delete Cleared Alarms button, referring to the rules in 
Step 8.

Step 5 To automatically delete cleared alarms at the card level, check the Autodelete Cleared Alarms check 
box at the bottom-left of the window.

Step 6 To manually delete cleared network-level alarms:

a. In the node view click View > Go to Network View.

Purpose Use this procedure to delete Cleared (C) status alarms from the alarms 
window. The procedure can be used to delete transient messages from the 
CTC History window.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve
6-13
Cisco ONS 15327 Procedure Guide, R4.0

November 2004



Chapter 6      Manage Alarms
NTP-B69 View Alarm-Affected Circuits
b. Click the Alarms tab and then, referring to the rules in Step 8, click Delete Cleared Alarms.

Step 7 If you want to automatically delete cleared alarms at the network level, check the Autodelete Cleared 
Alarms check box at the bottom-left of the window.

Step 8 Consult the following rules when deleting cleared alarms from the display:

• If the Autodelete Cleared Alarms check box is checked, an alarm disappears from the window when 
it is cleared.

• If the Autodelete Cleared Alarms check box is not checked, an alarm remains in the window after it 
is cleared. The alarm appears white in the window and has a Clear (CL) severity. The alarm can be 
removed by clicking the Delete Cleared Alarms button.

Step 9 Click Delete Cleared Alarms to remove the transient messages from the History window. Transient 
messages are single messages, and not raise-and-clear pairs (that is, they do not have companion 
messages stating they are cleared). 

Stop. You have completed this procedure.

NTP-B69 View Alarm-Affected Circuits

Step 1 Complete the “DLP-B60 Log into CTC” task on page 2-23. If you are already logged in, continue with 
Step 2.

Step 2 In the network, node, or card view, click the Alarms tab or Conditions tab and then right-click anywhere 
in the row of an active alarm or condition.

Note The node view is the default, but you can also navigate to the Alarms tab in the network view or 
card view to perform Step 2.

Note The card view is not available for the MIC-A or MIC-B cards.

The Select Affected Circuit option appears on the shortcut menu (Figure 6-6).

Purpose Use this procedure to view all circuits, if any, affected by an alarm or 
condition.

Tools/Equipment None

Prerequisite Procedures NTP-B196 View Alarms, History, Events, and Conditions, page 6-5

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve
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Figure 6-6 Select Affected Circuits Option

Step 3 Left-click or right-click Select Affected Circuits.

The Circuits window appears with the affected circuits highlighted (Figure 6-7).
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Figure 6-7 Viewing an Alarm-Affected Circuit

Step 4 If you want to search for particular circuits, see the “DLP-B131 Search for Circuits” task on page 8-5.

Stop. You have completed this procedure.

NTP-B70 Create, Download, and Assign Alarm Severity Profiles

Purpose Use this procedure to create a customized copy of the default alarm profile 
applied to a node, to download a saved custom profile from a network 
location to another node, to individually assign the custom severities to a 
port, card, or node, and to delete alarm profiles.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Step 1 Complete the “DLP-B60 Log into CTC” task on page 2-23 at the node where you want to create an alarm 
profile.If you are already logged in, continue with Step 2 to clone or modify an alarm profile, or continue 
with Step 3 to download an alarm profile.

Step 2 Complete the “DLP-B115 Create Alarm Severity Profiles” task on page 6-17. This task clones a current 
alarm profile, renames the profile, and customizes the new profile. Continue with Step 4.

Step 3 Complete the “DLP-B223 Download an Alarm Severity Profile” task on page 6-20. This task downloads 
an alarm severity profile from a CD or a node.

Step 4 As necessary, complete the “DLP-B116 Apply Alarm Profiles to Ports” task on page 6-21 or the 
“DLP-B117 Apply Alarm Profiles to Cards and Nodes” task on page 6-24.

Stop. You have completed this procedure.

DLP-B115 Create Alarm Severity Profiles

Step 1 In node view, choose Go to Network View from the View menu.

Step 2 Click the Provisioning > Alarm Profiles tabs (Figure 6-3 on page 6-6).

Step 3 Click Load.

Step 4 In the Select Profile(s) from Node or Filename to Load dialog box, click the From Node radio button.

Step 5 Click the node name you are logged into in the Node Names list.

Step 6 Click Default to highlight this profile in the Profile Names list.

Step 7 Click OK.

The default alarm severity profile appears in the Alarm Profiles window (Figure 6-8).

Purpose Use this task to create a custom severity profile by modifying the default 
severity profile.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Figure 6-8 Network View Alarm Profiles Window

Step 8 Right-click anywhere in the Default profile column to display the profile editing shortcut menu.

Step 9 Choose Clone from the shortcut menu.

Tip To identify profiles available for loading or cloning, click the Available button. You can clone 
any profiles except Inherited profiles.

Step 10 In the Clone Profile dialog box, enter a name for the copied profile in the New Profile Name field.

Profile names must be unique. If you try to import or name a profile that has the same name as another 
profile, CTC adds a suffix to create a new name. Long file names are supported (45 character maximum).

Step 11 Click OK.

A new alarm profile (named in Step 10) is created. This profile duplicates the default profile severities 
and appears to the right of the default profile in the Alarm Profiles window. You can highlight it and drag 
it to a different position.

Step 12 Modify (customize) the new alarm profile:

a. In the new alarm profile column, double-click the alarm severity you want to change.

b. Choose the desired severity in the Severity drop-down menu.

c. Repeat Steps a and b for each severity you want to customize.

Step 13 After you have customized the new alarm profile, right-click the profile column to highlight it.
6-18
Cisco ONS 15327 Procedure Guide, R4.0

November 2004



Chapter 6      Manage Alarms
NTP-B70 Create, Download, and Assign Alarm Severity Profiles
Step 14 Click Store in the profile editing shortcut menu.

Step 15 Click the To Node(s) radio button and continue with Step a or click the To File radio button and continue 
with Step b (Figure 6-9).

a. Choose the node(s) where you want to save the profile:

• If you want to save the profile to only one node, click the node in the Node Names list.

• If you want to save the profile to all nodes, click Select All.

• If you do not want to save the profile to any nodes, click Select None.

• If you want to update alarm profile information, click Synchronize.

b. Click Browse to navigate to the profile save location.

c. Enter a name in the file name field.

Long file names are supported. CTC supplies a suffix of *.pfl.

d. Click OK.

Note Click the Hide Identical Rows check box to configure the Alarm Profiles window to display rows 
with dissimilar severities.

Note Click the Hide Values Matching Profile Default check box to configure the Alarm Profiles 
window to display severities that do not match the Default profile.

Figure 6-9 Store Profile(s) Dialog Box

Step 16 Return to your originating procedure (NTP).
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DLP-B223 Download an Alarm Severity Profile

Step 1 In node view, choose Go to Network View from the View menu (Figure 6-3 on page 6-6).

Step 2 Click the Provisioning > Alarm Profiles tabs.

Step 3 Click Load.

Step 4 If you want to download a file from the local PC hard drive, floppy disk, CD-ROM, or a network drive 
(if connected), click the From File radio button in the Select Profile(s) from Node or Filename to Load 
dialog box.

a. Click Browse.

The Open dialog box appears.

b. In the Look in drop-down menu, navigate to the folder where the profile file is located.

c. Click the name in the window to highlight it.

The file must have the *.pfl extension.

d. Click Open.

Continue with Step 6.

Step 5 If you want to download a file from the login node or another connected node, click the From Node radio 
button in the Select Profile(s) from Node or Filename to Load dialog box.

a. Click the node where the profile is located under the Node Names list.

b. Click the profile under the Profile Names list.

Step 6 Click OK in the Select Profile(s) from Node or Filename to Load dialog box.

The downloaded profile appears at the right side of the Alarm Profiles window.

Step 7 Right-click anywhere in the downloaded profile column to display the profile editing shortcut menu.

Step 8 Click Store in the shortcut menu.

Step 9 In the Store Profile(s) dialog box, click the To Node(s) radio button (Figure 6-9 on page 6-19).

a. Choose the node(s) where you want to save the profile:

• If you want to save the profile to only one node, click the node in the Node Names list.

• If you want to save the profile to all nodes, click Select All.

• If you do not want to save the profile to any nodes, click Select None.

• If you want to update alarm profile information, click Synchronize.

Purpose Use this task to download a custom alarm severity profile from a 
network-drive accessible CD-ROM, floppy disk, or hard drive location.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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b. Click OK.

Step 10 Return to your originating procedure (NTP).

DLP-B116 Apply Alarm Profiles to Ports

Step 1 To change alarm profiles for optical cards, proceed to Step 2. To apply alarm profiles to optical card 
ports, proceed to Step 4. To apply alarm profiles to electrical card ports, proceed to Step 8.

Step 2 To change alarm profiles for optical cards, double-click an optical card in node view to display the card 
view.

Note You can also apply alarm profiles to cards using the “DLP-B117 Apply Alarm Profiles to Cards 
and Nodes” task on page 6-24.

Note The card view is not available for the MIC-A or MIC-B cards.

Step 3 Click the Provisioning > Alarm Behavior tabs.

Figure 6-10 shows an alarm profile for OC-3 card ports. CTC shows Parent Card Profile: Inherited.

Purpose Use this task to apply a custom or default alarm severity profile to a port 
or ports.

Tools/Equipment None

Prerequisite Procedures DLP-B115 Create Alarm Severity Profiles, page 6-17

DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Figure 6-10 Card View Optical Port Alarm Profile

Step 4 To apply alarm profiles to a port for optical cards:

a. Click the port row under the Profile column.

b. Choose the new profile from the Force all ports to profile drop-down menu.

c. Click Apply.

Step 5 To change alarm profiles for DS-1 and DS-3 ports, double-click the XTC card at the node (default login) 
view.

Step 6 Click the Provisioning > DS1 > Alarm Behavior tabs to change alarm profiles for DS-1 ports, or click 
the Provisioning > DS3 > Alarm Behavior tabs to change alarm profiles for DS-3 ports (Figure 6-11).
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Figure 6-11 Card View Electrical Port Alarm Profile

Step 7 Repeat Step 5 for each DS-1 or DS-3 port where you want to change profiles.

Step 8 To apply profiles to all optical or electrical ports on a card:

a. Choose a new profile from the Force all ports to profile drop-down menu.

b. Click Force (still need to “Apply”).

c. Click Apply.

Tip If you choose the wrong profile, click Reset to return to the previous profile setting.

Step 9 Return to your originating procedure (NTP).
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DLP-B117 Apply Alarm Profiles to Cards and Nodes 

Step 1 In node view, click the Provisioning > Alarm Behavior tabs (Figure 6-12).

Figure 6-12 Node View Alarm Profile

Step 2 To apply profiles to a card:

a. Click the Profile row for the card.

b. Choose the new profile from the Profile drop-down menu.

c. Click the Apply button.

Continue with Step 4.

Purpose Use this task to apply a custom or default alarm profile to cards or nodes.

Tools/Equipment None

Prerequisite Procedures DLP-B115 Create Alarm Severity Profiles, page 6-17

DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Step 3 To apply the profile to an entire node:

a. Click the Node Profile menu arrow at the bottom of the window (Figure 6-12 on page 6-24).

b. Choose the new alarm profile in the Profile drop-down menu.

c. Click Apply.

Tip If you choose the wrong profile, click Reset to return to the previous profile.

Step 4 Return to your originating procedure (NTP).

DLP-B118 Delete Alarm Severity Profiles

Step 1 In node view, choose Go to Network View from the View menu.

Step 2 Click the Provisioning > Alarm Profiles tabs.

Step 3 Click the column heading for the profile column you want to delete (Figure 6-8 on page 6-18).

The selected alarm profile name is displayed in the Description field.

Step 4 Click Delete.

The Select Node/Profile Combination for Delete dialog box appears (Figure 6-13).

Figure 6-13 Select Node/Profile Combination For Delete Dialog Box

Step 5 Click the node name(s) in the Node Names list to highlight the profile location.

Tip If you hold the Shift key down, you can select consecutive node names. If you hold the Ctrl key 
down, you can select any combination of nodes.

Purpose Use this task to delete a custom or default alarm severity profile.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Step 6 Click the profile name(s) you want to delete in the Profile Names list.

Step 7 Click OK.

The Delete Alarm Profile confirmation dialog box appears.

Step 8 Click Yes for each Delete Alarm Profile confirmation dialog box.

Note If you delete a profile from a node, it still appears in the network view
Provisioning > Alarm Profiles window unless you remove it by choosing Remove.

Step 9 To remove the alarm profile from the Provisioning > Alarm Profiles window, right-click the column of 
the profile you deleted and choose Remove from the shortcut menu.

Note If a a node and profile combination is selected but does not exist, a warning appears: “One or 
more of the profile(s) selected do not exist on one or more of the node(s) selected.” The profiles 
that do exist will be deleted.

Note The special profiles named Default and Inherited cannot be deleted and do not appear in the 
Select Node/Profile Combination for Delete Window.

Step 10 Return to your originating procedure (NTP).

NTP-B168 Enable, Modify, or Disable Alarm Severity Filtering

Step 1 Complete the “DLP-B60 Log into CTC” task on page 2-23. If you are already logged in, continue with 
Step 2.

Step 2 As necessary, complete the “DLP-B225 Enable Alarm Filtering” task on page 6-27 to enable alarm 
filtering at the card, node, and network views for all nodes in the network. Alarm filtering can be enabled 
for alarms, conditions, or events.

Step 3 As necessary, complete the “DLP-B226 Modify Alarm and Condition Filtering Parameters” task on 
page 6-28 to modify the alarm filtering for network nodes to show or hide particular alarms or 
conditions.

Purpose Use this procedure to start, change, or stop alarm filtering for one or more 
severities in the Alarms, Conditions, and History windows in all network 
nodes.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve or higher
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Step 4 As necessary, complete the “DLP-B227 Disable Alarm Filtering” task on page 6-30 to disable alarm 
profile filtering for all network nodes.

Stop. You have completed this procedure.

DLP-B225 Enable Alarm Filtering

Step 1 At the node, network, or card view, click the Alarms tab.

Step 2 Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is selected and disabled if the tool is raised (not selected).

Alarm filtering will be enabled in the card, node, and network views of the Alarms tab at the node and 
for all other nodes in the network. If, for example, the Alarm Filter tool is enabled in the Alarms tab of 
the node view at one node, the Alarms tab in the network view and card view of that node will also show 
the tool enabled. All other nodes in the network will also have the tool enabled. 

If you filter an alarm in card view, the alarm will still be displayed in node view. In this view, the card 
will display the color of the highest-level alarm. The alarm is also shown for the node in the network 
view.

Step 3 If you want alarm filtering enabled when you view conditions, repeat Steps 1 and 2 using the Conditions 
window.

Step 4 If you want alarm filtering enabled when you view alarm history, repeat Steps 1 and 2 using the History 
window.

Step 5 Return to your originating procedure (NTP).

Purpose Use this task to enable alarm filtering for alarms, conditions, or event 
history in all network nodes.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Retrieve or higher
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DLP-B226 Modify Alarm and Condition Filtering Parameters

Step 1 At the node, network, or card view, click the Alarms tab.

Step 2 Click the Filter button at the lower-left of the bottom toolbar.

The Alarm Filter Dialog box appears, showing the General tab (Figure 6-14).

Figure 6-14 Alarm Filter Dialog Box General Tab

In the General tab Show Severity area, you can choose which alarm severities will show through the 
alarm filter and provision a snapshot period during which alarms will appear. To change the alarm 
severities shown in the filter, continue with Step 3. To change the alarm time period, continue with 
Step 4.

Step 3 In the Show Severity area, click the check boxes for the severities [Critical (CR), Major (MJ), Minor 
(MN), or Not-Alarmed (NA)] you want to be reported at the network level. Leave severity check boxes 
deselected (unchecked) to keep them from appearing.

Note When alarm filtering is disabled, all alarms show.

Purpose Use this task change alarm and condition reporting in all network nodes.

Tools/Equipment None

Prerequisite Procedures DLP-B225 Enable Alarm Filtering, page 6-27

DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Retrieve or higher
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Step 4 In the Time area, check the Show alarms between time limits check box to enable it. Then click the up 
and down arrows in the From Date, To Date, and Time fields to modify the time limits.

To modify filter parameters for conditions, continue with Step 5. If you do not need to modify them, 
continue with Step 6.

Step 5 Click the Conditions tab (Figure 6-15).

Figure 6-15 Alarm Filter Dialog Box Conditions Tab

When alarm filtering is enabled, conditions in the Show list are visible and conditions in the Hide list 
are invisible.

• To move conditions individually from the Show list to the Hide list, click the > button.

• To move conditions individually from the Hide list to the Show list, click the < button.

• To move conditions collectively from the Show list to the Hide list, click the >> button.

• To move conditions collectively from the Hide list to the Show list, click the << button.

Note Conditions include alarms.

Step 6 Click Apply and OK.

Alarm and condition filtering parameters are enforced when alarm filtering is enabled (see the 
“DLP-B225 Enable Alarm Filtering” task on page 6-27), and are not enforced when alarm filtering is 
disabled (see the “DLP-B227 Disable Alarm Filtering” task on page 6-30).

Step 7 Return to your originating procedure (NTP).
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DLP-B227 Disable Alarm Filtering

Step 1 At the node, network, or card view, click the Alarms tab.

Step 2 Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is selected and disabled if the tool is raised (not selected).

Step 3 If you want alarm filtering disabled when you view conditions, click the Conditions tab and repeat
Step 2.

Step 4 If you want alarm filtering disabled when you view alarm history, click the History tab and repeat
Step 2.

Step 5 Return to your originating procedure (NTP).

NTP-B72 Suppress and Discontinue Alarm Suppression

Step 1 Complete the “DLP-B60 Log into CTC” task on page 2-23. If you are already logged in, proceed to 
Step 2.

Step 2 Complete the “DLP-B119 Suppress Alarm Reporting” task on page 6-31 to make the node send out 
autonomous messages that clear particular raised alarms and cause the suppressed alarms to appear in 
the Conditions window.

Purpose Use this task to turn off specialized alarm filtering in all network nodes so 
that all severities are reported in CTC.

Tools/Equipment None

Prerequisite Procedures DLP-B225 Enable Alarm Filtering, page 6-27

DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed
Onsite/Remote Onsite or remote
Security Level Retrieve or higher

Purpose Use this procedure to prevent alarms from being reported for a port, card, 
or node in circumstances when an alarm or condition is known to exist but 
you do not want to include in the display. Also use this procedure to resume 
normal alarm reporting by discontinuing the suppression.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Note Suppressing one or more alarms prevents them from appearing in Alarm or History windows or 
in any other clients. The suppress command causes CTC to display them in the Conditions 
window, where Not-Reported (NR) events are shown. The suppressed alarms appear there with 
the alarm severity they would have if they were reported; their severity color code, and 
service-affecting status.

Step 3 Complete the “DLP-B120 Discontinue Alarm Suppression” task on page 6-32 to remove the suppress- 
command and restore the alarms to their normal state of being reported at their provisioned severity.

Stop. You have completed this procedure.

DLP-B119 Suppress Alarm Reporting

Caution If multiple CTC/TL1 sessions are open, suppressing alarms in one session suppresses the alarms in all 
other open sessions.

Step 1 At either the node or card view, click the Provisioning > Alarm Behavior tabs.

Step 2 To suppress alarms at the node level for optical cards, proceed to Step 3. To suppress alarms at the card 
level for optical ports, proceed to Step 5. To suppress alarms for electrical ports, proceed to Step 8. 

Step 3 To suppress alarms at the node level for optical cards, check the Suppress Alarms column check box 
for the slot row where you want to suppress alarms (Figure 6-12 on page 6-24).

Note In the node view, row numbers correspond to slot numbers.

Step 4 Click Apply.

The node sends out autonomous messages to clear any raised alarms.

Step 5 To suppress alarms at the card level for optical ports, double-click the card and click the 
Provisioning > Alarm Behavior tabs.

Step 6 Click the Suppress Alarms column check box for the optical port row where you want to suppress 
alarms (Figure 6-10 on page 6-22).

Step 7 Click Apply.

Step 8 To suppress alarms for DS-1 or DS-3 ports, double-click the XTC card graphic at the node view.

Purpose Use this task to suppress the reporting of ONS 15327 alarms at the port, 
card, or node level.

Tools/Equipment None

Prerequisite Procedures DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
6-31
Cisco ONS 15327 Procedure Guide, R4.0

November 2004



Chapter 6      Manage Alarms
NTP-B72 Suppress and Discontinue Alarm Suppression
Step 9 To suppress DS-1 port alarms, click the Provisioning > DS1 > Alarm Behavior tabs. To suppress DS-3 
port alarms, click the Provisioning > DS3 > Alarm Behavior tabs (Figure 6-11 on page 6-23).

Step 10 Check the Suppress Alarms column check box for each port where you want to enable alarm reporting.

Step 11 Return to your originating procedure (NTP).

DLP-B120 Discontinue Alarm Suppression

Step 1 In node view click the Provisioning > Alarm Behavior tabs. To discontinue suppression for optical 
cards, proceed to Step 2. To discontinue suppression for electrical ports, proceed to Step 4.

Note You must restore alarm reporting at the view where it was originally suppressed.

Step 2 To discontinue alarm suppression at the node level for optical cards, uncheck the Suppress Alarms 
check box at the lower-left of the Alarm Behavior window.

Step 3 Click Apply.

Step 4 To discontinue alarm suppression at the card level for optical ports, double-click the card to display the 
card view.

Step 5 Uncheck the Suppress Alarms check box for the port(s) you no longer want to suppress.

Step 6 Click Apply.

Step 7 To discontinue alarm suppression for DS-1 or DS-3 ports, double-click the XTC card graphic at the node 
view.

Step 8 To discontinue DS-1 port alarm suppression, click the Provisioning > DS1 > Alarm Behavior tabs. To 
discontinue DS-3 port alarm suppression, click the Provisioning > DS3 > Alarm Behavior tabs.

Step 9 Uncheck the Suppress Alarms column check box for each port where you want to discontinue alarm 
reporting.

Step 10 Return to your originating procedure (NTP).

Purpose Use this task to discontinue alarm suppression and reenable alarm 
reporting on a port, card, or node.

Tools/Equipment None

Prerequisite Procedures DLP-B119 Suppress Alarm Reporting, page 6-31

DLP-B60 Log into CTC, page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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NTP-B32 Provision External Alarms and Controls on the XTC

Note For information about the XTC external alarms and controls, virtual wire and orderwire, refer to the 
Cisco ONS 15327 Reference Guide.

Note External alarm physical connections are made on the MIC. However, the alarms are provisioned using 
the XTC card view.

Step 1 In the node view, double-click the active XTC card. The card view appears.

Step 2 If you are provisioning external alarms, click the Provisioning > External Alarms tabs (Figure 6-16). 
If you are not provisioning external alarms, continue with Step 6.

Note You can only provision external alarms on the active XTC card.

Purpose Use this procedure to create external (environmental) alarms and external 
controls.

Tools/Equipment An XTC card must be installed in Slot 5 or 6.

Prerequisite Procedures NTP-B24 Verify Card Installation, page 3-2

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Figure 6-16 XTC Card External Alarms

Step 3 Complete the following fields for each external device wired to the Mechanical Interface card (MIC):

• Enabled—Check this check box to activate the fields for the alarm input number.

• Alarm Type—Choose an option from the Alarm Type drop-down menu.

• Severity—Choose an option from the Severity drop-down menu. 

The severity determines the severity the alarm has in the Alarms and History tabs and determines 
whether the LEDs are activated. Critical (CR), Major (MJ), and Minor (MN) alarms activate the 
XTC LEDs. Not-Alarmed (NA) and Not-Reported (NR) do not activate LEDs, but do report the 
information in CTC.

• Virtual Wire—Choose an option to assign the external device to a virtual wire. Otherwise, do not 
change the None default. For information about the virtual wire, see the Cisco ONS 15327 Reference 
Manual. 

• Raised When—Choose the condition (open or closed) that triggers the alarm.

• Description—A default description is provided; enter a different description if needed.

Step 4 To provision up to six virtual wire inputs for external devices, complete Step 3 for each additional 
device.

Step 5 Click Apply.

Step 6 If you are provisioning external control outputs for external devices, click the External Controls subtab 
(Figure 6-16).
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Step 7 Complete the following fields for each external control wired to the MIC:

• Enabled—Check this the check box to activate the Control Type, Trigger Type, and Description 
columns for the alarm input number.

• Control Type—Choose an option: air conditioner, engine, fan, generator, heat, light, sprinkler, or 
miscellaneous.

• Trigger Type—Choose a trigger type: a local minor, major, or critical alarm; a remote minor, major, 
or critical alarm; or a virtual wire activation.

• Description—Enter a description.

Step 8 To provision a second external control, complete Step 7 for the additional device.

Step 9 Click Apply.

Stop. You have completed this procedure.
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