
Multicast Simulation

WAE Design supports source-specific multicast (SSM), which is a method of delivering multicast packets to
receivers only from a specified source address that is requested by the receiver. By limiting the source, SSM
reduces resource requirements and improves security.

This section contains the following topics:

• SSM Parameters , on page 1
• Discovered Versus Simulated Multicast Flows, on page 1
• Multicast Demands, on page 4
• Creating Multicast Flows, on page 7
• Creating Demands for Multicast Flows, on page 9
• Toggling Multicast Flow Destinations to On and Off, on page 9

SSM Parameters
SSM is specified by an (S,G) parameter per multicast flow. The (S,G) pair is labeled using a dot-decimal
notation similar to IP addresses (for example, 1.1.1.1, 2.2.2.2). Each (S,G) pair is the name of a multicast
flow, and each flow is listed in the Multicast Flows table.

Discovered Versus Simulated Multicast Flows
How you work with multicast flows within WAE Design differs depending on whether the multicast flow
was discovered by WAE or whether you are simulating it (Table 1: Discovered Versus Simulated Multicast
Flows , on page 1).

Table 1: Discovered Versus Simulated Multicast Flows

Simulated Multicast FlowDiscovered Multicast Flow

First, manually create the multicast flow, defining
both the source (S) and the destinations (G). Next,
create a demand that links the source to these
multicast destinations, allowing the routing to be
simulated through the network.

WAE discovers multicast flows—(S,G) pairs)—and multicast
traffic is derived from the Multicast Flow Traffic table (accessed
from the Multicast Flows tab after choosing Edit > Traffic).

Creation
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Simulated Multicast FlowDiscovered Multicast Flow

When you create a demand, it determines the path
to take.

Each discovered multicast flow includes multicast flow hops,
which are node-interface combinations through which the
multicast path flows. The Multicast Demand initializer uses
multicast flow hops to determine multicast sources and
destinations.

Hops

When you create a demand, it determines the path
to take, but multicast external flow hops are not
identified.

WAE discovers multicast flow hops on interfaces that are
external to the plan file. These are interfaces from a plan node
to an external node, or from an external node to a plan node.
The Multicast Demand initializer uses multicast flow external
hops to determine multicast sources and destinations.

External hops

Specify destinations (nodes, interfaces, external
ASes, or external endpoints) when you create
multicast flows. When creating multicast demands,
specify these as multicast destinations.

WAE does not identify a list of multicast destinations for each
flow. The Multicast Demand initializer generates destinations
from the Multicast Flow Hops and Multicast Flow External
Hops tables.

Destinations

• Multicast Flows

• Multicast Flow Destinations

• Demands

• Multicast Flows

• Multicast Flow Hops

• Multicast Flow External Hops

• Multicast Flow Traffic (accessed from the Multicast Flows
tab after choosing Edit > Traffic)

Applicable
tables

• Selecting multicast demands from the Demands
table highlights the multicast path in blue on
the plot and labels the source as A and the
destinations as Z.

• Selecting multicast flow destinations from the
Multicast Flow Destinations table labels the
final destinations with a Z in the plot.

• Selecting a multicast flow from the Multicast Flow table
highlights a pink path on the plot (Figure 1: Multicast
Flows, on page 3).

• Selecting a multicast flow hop from the Multicast Flow
Hops table highlights a pink path on the plot (Figure 2:
Multicast Flow Hops, on page 3).

Plot displays
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Figure 1: Multicast Flows

Figure 2: Multicast Flow Hops

Global Multicast Simulations

Flow Hops
If a plan file contains multicast information, it includes the current hops taken by multicast flows. You can
specify that WAE Design multicast simulations should follow these flow hops if possible. This is useful, for
example, when calculating incremental routing changes on the current network state, such as those caused by
a failure. For planning purposes, when the current state is not relevant, you can change this behavior to
disregard the multicast flow hops.
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WAE Design uses the network state in its multicast simulation. You can set simulations to take into account
multicast flow hops, as follows.

Step 1 Choose Edit > Network Options or click the Network Options icon in the Visualization toolbar.

Step 2 Click the Simulation tab.

Step 3 To use or disregard multicast flow hops in simulation, check or uncheck Use multicast flow hops, and click OK.

Cisco Next Hop
For manually inserted demands, all SSM demand traffic for the (S,G) pair (multicast flow) goes through any
interface that is traversed by that demand.

However, you can set WAE Design to use Cisco next hops, which are calculated using a hash on S and G for
a multicast flow (S,G). The hash calculation is different in IOS and IOS XR. The default behavior is that of
IOS. The IOS XR hash is used on all nodes whose OS field starts with IOS XR.

Step 1 Choose Edit > Network Options or click the Network Options icon in the Visualization toolbar.

Step 2 Click the Protocols tab.

Step 3 From the Multipath Selection drop-down list, choose CiscoNextHop, and click OK.

Multicast Demands
For discovered multicast flows, you can insert demands manually or use the initializer.

For simulated multicast flows, create demands manually. For information on demands in general, see Traffic
Demand Modeling.

To find demands associated with a multicast flow, right-click either a multicast flow or multicast flow
destination, and choose Filter to Demands. Conversely, to find multicast flows associated with demands,
right-click a demand and choose Filter to > Multicast Flows.

Multicast Simulation
4

Multicast Simulation
Cisco Next Hop

cisco-wae-design-73-user-guide_chapter4.pdf#nameddest=unique_14
cisco-wae-design-73-user-guide_chapter4.pdf#nameddest=unique_14


Initialized Multicast Demands
The initializer creates simulated multicast flows corresponding to the discovered multicast flows. The demand
traffic for all traffic levels existing is set to the traffic measured in the multicast flow. Following is how WAE
Design determines the source and destination.

• Source—WAE Design first looks for an external endpoint with the same source (S) name as the source
of the discovered multicast flow. If this source does not exist, WAE Design infers it from the multicast
flow hops that have traffic going out of them, but none coming in. The inferred source can be a node or
external endpoint.

• Destination—WAE Design first looks for multicast flow destinations with the same (S,G) name as those
in the discovered multicast flow. If these multicast node destinations do not exist, WAE Design infers
them from the multicast flow hops that have traffic going into them, but none coming out. WAE Design
also infers multicast external flow hops if traffic is leaving a node in a direction that is outside the plan.
These destinations are populated in the Multicast Flow Destinations table.

To run this initializer, choose Initializers > Multicast Demands.

Simulated Multicast Demands
For manually inserted demands, all SSM demand traffic for the (S,G) pair (multicast flow) goes through any
interface that is traversed by that demand. SSM demands are routed to take the shortest path from the destination
to the source, rather than from the source to the destination, as unicast demands do. By default, multicast
multipath is disabled. If two paths of equal cost exit from a node on the route back to the source, the path is
chosen based on:

• The remote interface with the highest IP address is used.

• If IP addresses are not available, the router name with the lowest lexicographical name is used.

However, you can set WAE Design to use the Cisco next-hop multicast, multipath selection method. For
information, see Cisco Next Hop, on page 4.

The sources of these multicast demands can be nodes, interfaces, external ASes, or external endpoints. Using
interfaces lets you specify the exact interface on which demand traffic is entering. Using external endpoints
lets you model situations where the multicast source is outside of the nodes in the plan, and there is more than
one possible entry point of the traffic flow into and through the interfaces in the plan.

In this example, the selected demand has a node source of DEN, and a multicast destination containing two
nodes: CHI and OKC. The source node (S) is marked by A, and the destinations in the receiver group (G) are
marked by Z.
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You can model a source that is outside the plan using external endpoints. In this example, the demand’s source
is an external endpoint that contains SJC and DEN as members. The multicast destination includes both CHI
and OKC.

Viewing Multicast Flows
To highlight discovered multicast flows and multicast flow hops in the plot, select them from their respective
tables. To view sources and destinations of multicast demands, select the demand from its table. The source
is identified in the plot by A and the destinations are identified by Z.
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For complex multicast flows, filter to the demand, right-click the demand, and choose Plot Demand. Figure
3: Example Demand Plot of Multicast Flow, on page 7 shows an example of a demand plot for a multicast
flow.

Figure 3: Example Demand Plot of Multicast Flow

Show This TableTo View...

Multicast FlowsMulticast flows, including both source and receiver names

Multicast Flow HopsDiscovered multicast flow hops, including (S,G) name, hop node, and hop
interface

Multicast Flow External HopsDiscovered multicast flow external hops (destinations that are inferred as
external to the plan), including (S,G) name, direction of the outbound interface

Multicast Flow DestinationsUser-created multicast flow destinations, including (S,G) name and destination
node

DemandsMulticast demands

Creating Multicast Flows
The recommended method of creating multicast flow destinations is to do so while creating the associated
multicast flows, as follows.
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Step 1 Choose Insert > Multicast Flow, or right-click the plot and choose New > Multicast Flow. A Multicast Flow dialog
box opens.

Step 2 In the S field, identify the source node by entering its dot-decimal name; for example, 2.3.2.3.

Step 3 In the G field, identify the collective name for all receiver nodes (destinations) by entering its dot-decimal name; for
example, 7.7.7.7.

Step 4 Add destinations to the receiver group.

a) Click Add Destination.
b) In the Type list, select either a node, interface, external AS, or external endpoint.
c) If you are adding a node to the receiver group, select both the site and node name of the destination point in the

multicast flow.

If you are adding an interface, select the site, the node, and the interface.

If you are adding an external AS, select the external AS name and node for the destination point.

If you are selecting an external endpoint, select its name.

d) Click OK. These values now appear in the Multicast Flow dialog box, where you can disable or enable them from
participating in the multicast flow.

Step 5 Repeat Step 4 for each destination in the multicast flow.

Step 6 Click OK to save and exit.

After creating the multicast flow, you need to create demands for the multicast flows.
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Creating Demands for Multicast Flows

Step 1 Choose Insert > Demands > Demand, or right-click the plot and choose New > Demands > Demand.

Step 2 In the Name field, enter the name of the demand.

Step 3 In the Source area, define the source (S) of the multicast flow.

a) From the Type list, select the source as a node, interface, external AS, or external endpoint.
b) For node sources, select both the site and the node.

For interface sources, select the site, node, and the interface.

For external ASes, select both the external AS and the node within the plan file through which this external traffic
flows.

For external endpoints, select its name.

Step 4 In the Destination area, define the receiver group (G) of the multicast flow.

a) From the Type list, choose Multicast Destination.
b) From the Receiver list, choose the receiver that identifies the simulated multicast flow (S,G).

Step 5 (Optional) Complete all other fields as needed, and then click OK.

Toggling Multicast Flow Destinations to On and Off

Step 1 In the Multicast Flows table, double-click the multicast flow. A dialog box opens with a list of existing destinations. Each
destination has a T next to it if it is currently part of the receiver group or an F if it exists, but is not part of the receiver
group.

Step 2 To enable or disable the multicast flow destination, click its associated T/F value.

Step 3 Click OK to save and exit.
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